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Introduction

This introduction helps you get started with the Autodesk Revit Architecture 2010 tutorials and presents the fundamental
concepts of the product, including:

■ How Revit Architecture works.

■ An overview of the concepts and terms used in the product.

■ How to perform common tasks in the product.
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Using the Tutorials

This lesson provides information on how to get started with the Revit® Architecture 2010 tutorials, including an overview
of the building information model that you design in the tutorials, and where to find the training files required to complete
the exercises.

The Contents tab of the Revit Architecture Tutorials window displays the available tutorial titles. Expand a title for a list
of lessons in the tutorial. Expand a lesson title for a list of exercises in the lesson.

NOTE You may find it helpful to print a tutorial to make it easier to reference the instructions as you work in Revit
Architecture. The tutorials are also available in PDF format by clicking Help menu ➤ Documents on the Web in Revit
Architecture.

What is in the Tutorials
In these tutorials, you learn how to design a building information model (BIM) in Revit Architecture. The
technical training facility you design was a product of a design competition in Munich, Germany. This
building is also used as the model in the Revit® Structure and Revit® MEP 2010 tutorials.

How the tutorials are organized

The tutorials are designed to follow the typical architectural workflow. You complete the following activities:

■ Establish a site and lay it out.

■ Add basic building elements, such as floors, walls, and roofs.

■ Add more detailed elements, such as stairs, rooms, and furniture.

■ Refine the building elements.

■ Create schedules, views, and sheets to document the project.

1
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■ Prepare presentation views such as renderings and walkthroughs.

The tutorial exercises are designed to be basic and brief. You do not design the entire building, but only
enough of the building to learn how to use the tools and options in the product. For example, when you
lay out the interior walls, you only draw walls for one floor of one wing of the building.

When you open a training file, you may notice that building elements are included that were not specifically
added in an exercise. For example, to provide a richer and more finished building design, elements such as
skylights, solar shades, and interior finishes are incorporated into subsequent training files. These elements
enhance the exercises you complete, such as rendering or presentation views.

Accessing Training Files
Training files are Revit Architecture projects, templates, and families that were created specifically for use
with the tutorials. In this exercise, you learn where the training files are located, as well as how to open and
save them.

Locate the training files

The Tutorials option on the Autodesk Revit Architecture 2010 Help menu provides a link to the installation
website for the tutorial content and training files. When you install the training files as instructed, they are
copied to the default location C:\Documents and Settings\All Users\Application Data\Autodesk\RAC
2010\Training. Training files are grouped into 3 folders within the Training folder:

■ Common: common drawing files for users working with imperial or metric units.

■ Imperial: files for users working with imperial units. Imperial file names have an _i suffix.

■ Metric: files for users working with metric units. Metric file names have an _m suffix.

NOTE Depending on your installation, your Training folder may be in a different location. Contact your CAD
manager for more information.

IMPORTANT Content used in the tutorials, such as templates and families, is located and accessed in the training
files location. Although this content may be installed in other locations on your system, all content used in the
tutorials is installed in the training files location to ensure that all audiences access the correct files.

Use the training files

A training file is a Revit Architecture project that defines a building information model and views of the
model that are used to complete the steps in a tutorial. The tutorials include a Training File section that
references the training file to be used with the tutorial.

The training files include a starting point for each tutorial exercise. So, you can complete any exercise without
first completing the preceding exercises. On the Contents tab, the tutorials are grouped and presented in a
recommended order for optimal learning; however, the exercises and lessons can be completed in any order.

Open a training file

1 Click  ➤ Open.

NOTE If you click the word Open in the menu, the Open dialog displays, and you can open any
supported file type. If you click the arrow to the right of the Open option, a list of file types displays.
Click a file type to display the Open dialog for the specified file type.

2 In the left pane of the Open dialog, scroll down, and click the Training Files icon.
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3 In the right pane, double-click Common, Imperial, or Metric, depending on the instructions in
the tutorial.

4 Click the training file name, and click Open.

Save a training file

5 To save a training file with a new name, click  ➤ Save As.

NOTE You are not required to save your work in a training file. A training file is provided as a starting
point for each exercise.

6 Complete the information in the Save As dialog:

■ For Save in, select the folder in which to save the new file.
You can save the file in the appropriate Training Files folder or in another location.

■ For File name, enter the new file name.
A good practice is to save the training file with a unique name after you have made changes.
For example, if you open settings.rvt and make changes, you should save this file with a new
name such as settings_modified.rvt.

■ For Files of type, verify that Project Files (*.rvt) is selected, and click Save.

Close a training file

7 Click  ➤ Close.

8 If you have made changes, you are prompted to save the changes. You may close the file with
or without saving changes.
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Understanding the Basics

In this lesson, you learn what Revit Architecture is and how its parametric change engine benefits you and your work.
You begin with the fundamental concepts on which Revit Architecture is built. You learn the terminology, the hierarchy
of elements, and how to perform some common tasks in the product.

Understanding the Concepts

What is Autodesk Revit Architecture 2010?

The Revit Architecture platform for building information modelling is a design and documentation system
that supports the design, drawings, and schedules required for a building project. Building information
modelling (BIM) delivers information about project design, scope, quantities, and phases when you need
it.

In the Revit Architecture model, every drawing sheet, 2D and 3D view, and schedule is a presentation of
information from the same underlying building model database. As you work in drawing and schedule
views, Revit Architecture collects information about the building project and coordinates this information
across all other representations of the project. The Revit Architecture parametric change engine automatically
coordinates changes made anywhere—in model views, drawing sheets, schedules, sections, and plans.

What is meant by parametric?

The term parametric refers to the relationships among all elements of the model that enable the coordination
and change management that Revit Architecture provides. These relationships are created either automatically
by the software or by you as you work. In mathematics and mechanical CAD, the numbers or characteristics
that define these kinds of relationships are called parameters; hence, the operation of the software is
parametric. This capability delivers the fundamental coordination and productivity benefits of Revit
Architecture: Change anything at any time anywhere in the project, and Revit Architecture coordinates that
change through the entire project.

The following are examples of these element relationships:

■ The outside of a door frame is a fixed dimension on the hinge side from a perpendicular partition. If you
move the partition, the door retains this relationship to the partition.

■ Windows or pilasters are spaced equally across a given elevation. If the length of the elevation is changed,
the relationship of equal spacing is maintained. In this case, the parameter is not a number but a
proportional characteristic.

2
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■ The edge of a floor or roof is related to the exterior wall such that when the exterior wall is moved, the
floor or roof remains connected. In this case, the parameter is one of association or connection.

How does Autodesk Revit Architecture 2010 keep things updated?

A fundamental characteristic of a building information modelling application is the ability to coordinate
changes and maintain consistency at all times. You do not have to intervene to update drawings or links.
When you change something, Revit Architecture immediately determines what is affected by the change
and reflects that change to any affected elements.

Revit Architecture uses 2 key concepts that make it especially powerful and easy to use. The first is the
capturing of relationships while the designer works. The second is its approach to propagating building
changes. The result of these concepts is software that works like you do, without requiring entry of data that
is unimportant to your design.

Element behavior in a parametric modeler

In projects, Revit Architecture uses 3 types of elements:

■ Model elements represent the actual 3D geometry of the building. They display in relevant views of the
model. For example, walls, windows, doors, and roofs are model elements.

■ Datum elements help to define project context. For example, grids, levels, and reference planes are datum
elements.

■ View-specific elements display only in the views in which they are placed. They help to describe or
document the model. For example, dimensions, tags, and 2D detail components are view-specific elements.

There are 2 types of model elements:

■ Hosts (or host elements) are generally built in place at the construction site. For example, walls and roofs
are hosts.

■ Model components are all the other types of elements in the building model. For example, windows,
doors, and cabinets are model components.

There are 2 types of view-specific elements:

■ Annotation elements are 2D components that document the model and maintain scale on paper. For
example, dimensions, tags, and keynotes are annotation elements.
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■ Details are 2D items that provide details about the building model in a particular view. Examples include
detail lines, filled regions, and 2D detail components.

This implementation provides flexibility for designers. Revit Architecture elements are designed to be created
and modified by you directly; programming is not required. If you can draw, you can define new parametric
elements in Revit Architecture.

In Revit Architecture, the elements determine their behavior largely from their context in the building. The
context is determined by how you draw the component and the constraint relationships that are established
with other components. Often, you do nothing to establish these relationships; they are implied by what
you do and how you draw. In other cases, you can explicitly control them, by locking a dimension or aligning
2 walls, for example.

Understanding Autodesk Revit Architecture 2010 terms

Most of the terms used to identify objects in Revit Architecture are common, industry-standard terms familiar
to most architects. However, some terms are unique to Revit Architecture. Understanding the following
terms is crucial to understanding the software.

Project: In Revit Architecture, the project is the single database of information for your design—the building
information model. The project file contains all information for the building design, from geometry to
construction data. This information includes components used to design the model, views of the project,
and drawings of the design. By using a single project file, Revit Architecture makes it easy for you to alter
the design and have changes reflected in all associated areas (plan views, elevation views, section views,
schedules, and so forth). Having only one file to track also makes it easier to manage the project.

Level: Levels are infinite horizontal planes that act as a reference for level-hosted elements, such as roofs,
floors, and ceilings. Most often, you use levels to define a vertical height or story within a building. You
create a level for each known story or other needed reference of the building; for example, first floor, top of
wall, or bottom of foundation. To place levels, you must be in a section or elevation view.

Level 2 work plane cutting through the 3D view with the corresponding floor plan
next to it

Element: When creating a project, you add Revit Architecture parametric building elements to the design.
Revit Architecture classifies elements by categories, families, and types.

Understanding the Concepts | 9



Category: A category is a group of elements that you use to model or document a building design. For
example, categories of model elements include walls and beams. Categories of annotation elements include
tags and text notes.

Family: Families are classes of elements in a category. A family groups elements with a common set of
parameters (properties), identical use, and similar graphical representation. Different elements in a family
may have different values for some or all properties, but the set of properties—their names and meaning—is
the same. For example, 6-panel colonial doors could be considered one family, although the doors that
compose the family come in different sizes and materials.

There are 3 kinds of families:

■ Loadable families can be loaded into a project and created from family templates. You can determine
the set of properties and the graphical representation of the family.

■ System families include walls, dimensions, ceilings, roofs, floors, and levels. They are not available for
loading or creating as separate files.

■ Revit Architecture predefines the set of properties and the graphical representation of system families.

■ You can use the predefined types to generate new types that belong to this family within the project.
For example, the behavior of a wall is predefined in the system. However, you can create different
types of walls with different compositions.

■ System families can be transferred between projects.

■ In-place families are custom families that you create in the context of a project. Create an in-place family
when your project needs unique geometry that you do not expect to reuse or geometry that must maintain
one of more relationships to other project geometry.

■ Because in-place families are intended for limited use in a project, each in-place family contains only
a single type. You can create multiple in-place families in your projects, and you can place copies of
the same in-place family element in your projects. Unlike system and standard component families,
you cannot duplicate in-place family types to create multiple types.

Type: Each family can have several types. A type can be a specific size of a family, such as a A0 title block
or a 910 x 2110 door. A type can also be a style, such as default aligned or default angular style for dimensions.

Instance: Instances are the actual items (individual elements) that are placed in the project and have specific
locations in the building (model instances) or on a drawing sheet (annotation instances).

Using the Revit Architecture User Interface
Revit Architecture is a powerful CAD product for the Microsoft® Windows operating system. Its interface
resembles those of other products for Windows featuring a ribbon that contains the tools used to complete
tasks.
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In the Revit Architecture interface, many of the components (such as walls, beams, and columns) are available
at the click of a button. You can place these components in the drawing and immediately determine whether
they meet your design requirements.

Parts of the Revit Interface
The Revit Architecture interface is designed to simplify your workflow. With a few clicks, you can change
the interface to better support the way that you work. For example, you can set the ribbon to one of the
three display settings for optimum use of the interface. You can also display several project views at one
time, or layer the views to see only the one on top.

Read the following topics to familiarize yourself with the basic parts of the Revit interface. Then experiment
with them, hiding, showing, and rearranging interface components to support the way that you work.

Ribbon Overview
The ribbon displays automatically when you create or open a file, and provides all the tools necessary to
create your file. Customize the ribbon by changing the panel order, or moving a panel off the ribbon to
your desktop. The ribbon can be minimized for maximum use of the drawing area.

To move panels:

■ Click a panel label and drag the panel to a desired place on the ribbon.

■ Click a panel label and drag the panel off the ribbon to the desktop. To return the panel to the ribbon,
click the Return Panels to Ribbon button, or drag the panel back to its original ribbon tab.
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To minimize the ribbon

1 Click  (Show Full Ribbon) to the right of the ribbon tabs.

2 The minimize behavior cycles through the following minimize options:

■ Show Full Ribbon: Shows entire ribbon.

■ Minimize to Panel Tiles: Shows tab and panel labels.

■ Minimize to Tabs: Shows tab labels.

Ribbon Tabs and Panels

Ribbon example

TIP When you see a button that shows a line dividing it into two sides, you can click the top (or left) side to access
the tool you probably use most often. Click the other side to expose a list of other related tools.

Examples of
buttons that can
be clicked on two
sides

The following table describes the ribbon tabs and the types of commands they contain.

There are a number of button types on the ribbon

Includes commands for...Ribbon Tab

many of the tools you need to create the
building model.

Home

many of the tools you need to create and
modify a family of elements.

Create (family files only)

tools to add and manage secondary items
such as raster images, and CAD files.

Insert
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Includes commands for...Ribbon Tab

tools used for adding 2D information to a
design.

Annotate

tools used for editing existing elements,
data and systems. When working on the

Modify

Modify tab, select the tool first, then select
what you want to modify.

tools for modeling and modifying concep-
tual mass families and site objects.

Massing & Site

tools for collaboration with internal and
external project team members.

Collaborate

tools used for managing and modifying
the current view, and for switching views.

View

project and system parameters, and set-
tings.

Manage

third-party tools used with Autodesk Revit
Architecture 2010. The Add-Ins tab is en-

Add-Ins

abled only when a third-party tool is in-
stalled.

Expanded Panels

A drop-down arrow at the bottom of a panel indicates that you can expand the panel to display additional
tools and controls. By default, an expanded panel closes automatically when you click another panel. To
keep a panel expanded, click the push pin icon in the bottom-left corner of the expanded panel.

A dialog-launcher arrow on the bottom of a panel opens a dialog.

Contextual Ribbon Tabs

When you execute certain commands or select an element, a special contextual ribbon tab displays that
contains a set of tools that relate only to the context of the command.

For example, when drawing walls, the Place Wall contextual tab displays that has 3 panels:

■ Select: contains the Modify command.

■ Element: contains Element Properties and the Type Selector.

■ Draw: contains the draw editors necessary for creating the wall.
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This contextual ribbon tab closes once you end the command.

Application Frame Overview
The application frame contains tools and provides feedback to help you manage your Revit Architecture
projects.

The application frame consists of five main areas described in the following table:

DescriptionApplication Window Tool

opens the application menu (single -click).
closes the application menu (double-click).application button 

provides access to common tools.application menu

displays frequently used tools.Quick Access toolbar

provides requested information.InfoCenter

displays information related to the current
state of a Revit operation.

Status Bar
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The Application Menu

The application menu provides access to many common file actions and also allows you to manage your
files using more advanced commands, such as Export and Publish.

NOTE Revit Architecture options are set from Options on the application menu.

Access Common Tools
Access common tools to start or publish a file in the application menu.

Click  to quickly perform the following actions:

■ Create a file

■ Open an existing file

■ Save a file

■ Export a file to another file format

■ Publish a file and place it in a central or shared location

■ Print a file

■ Access license information

■ Close the application
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You can quickly access the following dialogs from the application menu:

to open the...Click the left side of...

New Project dialog
 (New)

Open dialog
 (Open)

DWF Publish Settings dialog
 (Publish)

Print dialog
 (Print)

Product and License Information dialog
 (Licensing)

Using the Quick Access Toolbar
The Quick Access toolbar contains the following items by default:

DescriptionQuick Access Toolbar Item

opens a project, family, annotation, or
template file.

 (Open)

saves a current project, family, annotation,
or template file.

 (Save)

cancels the last action by default. Displays
list of all actions taken during the session.

 (Undo)

reinstates the last cancelled action also
displays a list of all reinstated actions per-
formed during the session.

 (Redo)

synchronizes a local file with that on the
central server.

 (Modify Settings before Synchronizing)

provides views including Default 3D,
Camera, and Walkthrough.

 (3D View)

enters selection mode and ends the current
operation.

 (Modify)

customizes the items displayed on the
Quick Access toolbar. To enable or disable

 (Customize Quick Access Toolbar)

a tool item, click next to it on the Custom-
ize Quick Access Toolbar drop-down.

NOTE New displays on the Customize
Quick Access Toolbar drop-down, but is
not enabled by default.
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To undo or redo a series of operations, click the drop-down to the right of the Undo and Redo buttons. This
displays the command history in a list. Starting with the most recent command, you can select any number
of previous commands to include in the Undo or Redo operation.

The Quick Access toolbar can display below the ribbon. Click Show Below the Ribbon on the Customize
Quick Access Toolbar to change the display setting.

You can customize the Quick Access toolbar. to include commands that you use frequently. To add a ribbon
button to the Quick Access toolbar, right-click the button on the ribbon and click Add to Quick Access
toolbar. Buttons are added to the right of the default commands on the Quick Access toolbar.

While in an edit mode (such as Place a Wall), or the Family Editor, items that are added to the Quick Access
toolbar from the Create, Modify, Group, Clipboard, or View Graphics panel persist on the toolbar for that
mode. However, when you switch to another editing mode, these items do not display and need to be
re-added to the Quick Access toolbar.

NOTE There are some tools on contextual tabs that cannot be added to the Quick Access toolbar.

Status Bar
The status bar is located along the bottom of the Revit Architecture application frame. When you are using
a command, the left side of the status bar provides tips or hints on what to do. When you are highlighting
an element or component, the status bar displays the name of the family and type.

Several other controls appear on the right side of the status bar

■ Press & Drag: Allows you to click and drag an element without it selecting first.

■ Editable Only: Filters selections to select only editable, workshared components.

■ Active Only: Filters selections to select only active design option components.

■ Exclude Options: Filters selections to exclude components that are part of a design option.

■ Filter button: Displays how many elements are selected and refines the element categories selected in a
view.

To hide the status bar, click View tab  ➤ Windows panel ➤ User Interface drop-down. Clear the Status Bar
check mark. To show the status bar again, repeat the command.
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Getting Hints About What to Do Next
If you start a command (such as Rotate) and are not sure what to do next, check the status bar. It often
displays tips or hints about what to do next for the current command. In addition, a tool tip appears next
to the cursor, displaying the same information.

To cancel or exit the current command, do either of the following:

■ Press Esc twice.

■ On the Quick Access toolbar, click  (Modify).

Options Bar
The Options Bar is located below the ribbon. Its contents change depending on the current command or
selected element.

Type Selector
The Type Selector is located on the Element panel for the currently invoked tool, for example, Place a Wall.
Its contents change depending on the current function or selected elements. When you place an element
in a drawing, use the Type Selector to specify the type of element to add.

To change existing elements to a different type, select one or more elements of the same category. Then use
the Type Selector to select the desired type.
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View Control Bar
The View Control Bar is located at the bottom of the Revit window above the status bar. It provides quick
access to functions that affect the drawing area, including the following:

■ Scale

■ Detail Level

■ Model Graphics Style

■ Shadows On/Off

■ Show/Hide Rendering Dialog (Available only when the drawing area displays a 3D view.

■ Crop View On/Off

■ Show/Hide Crop Region

■ Temporary Hide/Isolate

■ Reveal Hidden Elements

Modifying the View
In this exercise, you learn how to modify the views within your Revit Architecture project. After you are
familiar with these tasks, it will be easier to work in Revit Architecture and focus on the lessons of each
tutorial.

Use zoom commands to adjust the view

In the tutorials, you are instructed to use a zoom command to adjust the viewable area in the window. For
example, you may be asked to zoom to a specific region of a view or to zoom to fit the entire building or
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floor plan in the view. Understanding how to adjust the view will make it easier to work with the building
model in the window.

There are several ways to access zoom options. In the following steps, you open a training file and practice
adjusting the view with the different zoom commands.

1 Click  ➤ Open.

2 In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_UB_02_Common_Tasks_m.rvt.

The 3D isometric view displays:

3 Click Navigation bar ➤ Zoom In Region drop-down to display the zoom menu. (The Navigation
bar is located in the top-right corner of the view.)

The zoom menu lists the zoom options.

NOTE Clicking the Zoom icon itself activates the currently-selected zoom command.

4 Click Zoom Out (2x).

In the drawing area, the view zooms out from the building model.

5 Click Zoom To Fit.

The view of the building model is sized to fit the available window.

6 Click in the drawing area, and type the shortcut ZR to zoom in on a region.

The cursor becomes a magnifying glass.

7 Click the upper left corner and lower right corner of the region to magnify; this is referred to
as a crossing selection.
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When you release the mouse button, the view zooms in on the selected area.

8 If you use a mouse that has a wheel as the middle button, you can roll the wheel to zoom the
view. Use the wheel mouse to zoom out to see the entire building again.

If you do not have a wheel mouse, use a zoom menu command or the toolbar option to zoom
out.

NOTE As you zoom in and out, Revit Architecture uses the largest snap increment that represents
less than 2mm in the drawing area. To modify or add snap increments, click Settings menu ➤ Snaps.

Zoom is also available using SteeringWheels. SteeringWheels provide 2D and 3D navigation
tools.

9 To display SteeringWheels, on the Navigation bar, click  .

The Full Navigation wheel displays in the drawing area.

As you move the mouse, the wheel follows the cursor around the drawing area.

10 Move the cursor over the Zoom wedge of the wheel so that it highlights.

11 Click and hold the mouse button.

The cursor displays a pivot point for the Zoom tool.
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12 Drag the cursor down or left to zoom out.

13 Drag the cursor up or right to zoom in.

You can change the pivot point by releasing the mouse button, moving the wheel to the desired
location, and then using the Zoom tool again.

For more information about SteeringWheels, click the pull-down menu on the Full Navigation

wheel, and click Help. To define settings for SteeringWheels, click  ➤ Options (located in
the lower-right corner of the application menu), and click the SteeringWheels tab.

14 To exit the wheel, press Esc.

15 Close the file without saving your changes.

Performing Common Tasks
In this exercise, you learn to perform some of the common Revit Architecture tasks that are included in the
tutorials. After you are familiar with these tasks, it will be easier to work in Revit Architecture and focus on
the lessons of each tutorial.

Resize elements using drag controls

1 Click  ➤ Open.

2 In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_UB_02_Common_Tasks_m.rvt.

3 In the Project Browser, expand Views (all), expand Floor Plans, and double-click 2nd Flr. Cnst.

When drawing or modifying a building model, it is important to understand how to adjust the
size of components in the drawing area. Small blue dots, called drag controls, display at the
ends of selected lines and walls in a plan view. Similar controls, referred to as shape handles,
display along the ends, bottoms, and tops of selected walls in elevation views and 3D views.

4 Type ZR, zoom in on the upper-left corner of the floor plan, and select the wall, as shown.

Notice the small blue dots that display at both ends of the wall. These are the drag controls.

5 Click and drag the left control, moving the cursor to the left horizontally, to lengthen the wall.

6 Click in the drawing area to deselect the wall.

Move an element

7 Scroll the view down so you can see the couch and table in the floor plan.
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8 Select the Craftsman02 table, and on the Modify panel, click Move.

Some commands, such as Move and Copy, require 2 clicks to complete the command. After
selecting the element to move, for example, click to specify the starting position, and click again
to specify the ending position. In this case, you want to move the table closer to the wall.

9 Click the lower-left endpoint of the table.

10 Click next to the lower wall, as shown.

The table moves down, and the lower-left corner is placed at the move endpoint.

Another way to move an element is to select it and drag it to a new location.
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11 Select the plant, and drag it on top of the table.

Undo commands

12 On the Quick Access toolbar, click the drop-down next to  (Undo).

All changes you make to a project are tracked. The Undo command allows you to reverse the
effects of one or more commands. In this example, you decide that you prefer the table in its
original position.

13 On the Undo menu, select the second item in the list, Move.

Selecting the second item in the list will undo the last 2 actions. All commands are canceled up
to and including the selected command. The table and plant are returned to their original
locations.

NOTE To quickly undo the previous action, on the Quick Access toolbar, click  , or press Ctrl+Z.

End a command

14 Click Home tab ➤ Model panel ➤ Model Line.

Some commands, such as the Lines command, stay active or current until you choose another
command or end the current command.

15 Click in the drawing area to start the line, and click again to end it.

Notice that the Lines command is still active and you could continue to draw lines.

16 To end the command, use one of the following methods:

■ Choose another command.

■ On the Selection panel, click Modify.

■ Press Esc twice.

17 Close the file without saving your changes.
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Starting a Project

Use the lessons in this tutorial to set up the sample project, including:

■ Specifying general system settings and file locations.

■ Modifying project settings to customize the work environment.

■ Creating the site for the project, from the toposurface to the building pad and parking areas.
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Modifying System Settings

In this lesson, you learn how to control the system settings for Revit Architecture. System settings are local to each computer
and are applied to all projects; they are not saved to project files or template files.

You learn to modify:

■ General options, such as colors for the display background and selection.

■ Default file locations, including file paths for the project template, family template, and family library.

■ Spelling options, including adding terms to the personal dictionary.

■ Snap settings, such as increments for snapping to length and angular dimensions.

Modifying General System Options
In this exercise, you modify the settings that control your local Revit Architecture working environment.
These settings control the graphics, selection default options, notification preferences, journal cleanup
options, and your user name when using worksharing.

Set graphics settings

1 Click  ➤ Options. (The Options button is in the lower right corner of the menu.)

2 In the Options dialog, click the Graphics tab.

3 Under Colors, select Invert background color, and click OK.

4 Click  ➤ New ➤ Project to open a new Revit Architecture project.

5 In the New Project dialog, under Template file, click Browse.

6 In the left pane of the Choose Template dialog, click Training Files, and open
Metric\Templates\RAC_MSS_Tutorial_Default_m.rte.

7 In the New Project dialog, click OK.

Notice that the drawing area is black.

8 Click  ➤ Options.

9 In the Options dialog, click the Graphics tab.

10 Under Colors, click the value for Selection color.

3
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11 In the Color dialog, select yellow, and click OK.

NOTE You can also specify the Highlight and Alert colors. When you move the cursor over an element
in the drawing area, the element displays using the Highlight color. When an error occurs, the elements
causing the error display using the Alert color.

12 Click the General tab.

13 Under Notifications, specify the following options:

■ For Save reminder interval, select One hour.

■ For Tooltip assistance, select None.

14 Click OK.

15 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.

16 Draw a straight horizontal wall in the center of the drawing area.

17 Click Modify.

18 In the drawing area, select the wall.

Notice the selected wall is yellow rather than the default blue.

19 Press Esc.

20 Place the cursor over the wall but do not select it.

Notice that a tooltip is not displayed. However, the status bar displays information about the
highlighted element.

21 Click  ➤ Close.

22 When prompted to save changes, click No.

23 Click  ➤ Open.

24 In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_MSS_01_System_Options_m.rvt.

Notice that the system settings apply to this project.

25 Click  ➤ Options.

26 In the Options dialog, click the Graphics tab, and make the following changes:

■ Under Colors, clear Invert background color.

■ For Selection color, select blue.

27 Click the General tab, and make the following changes:

■ Under Notifications, select your preferred Save reminder interval. For Tooltip assistance,
select Normal.
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■ Under Username, enter the name you want to use during worksharing. Your login name
displays by default.

■ Under Journal File Cleanup, select values for When number of journals exceeds and Delete
journals older than (days).
Journal files are deleted automatically after their number exceeds the value you specify.
Journal files are text documents that record each step during your Revit Architecture sessions.
These files are used in the software support process. Journals can be run to detect a problem
or recreate lost steps or files. They are saved at the termination of each Revit Architecture
session.

28 Click OK.

Notice that the drawing area background colors are no longer inverted and that tooltips display
when you place the cursor over any building component.

29 Click  ➤ Close. If prompted, do not save the changes.

Specifying File Locations
In this exercise, you specify default file locations. These settings control locations of important Revit
Architecture files, including your default project template, family template files, and family libraries.

Set file locations

1 Click  ➤ Options.

2 In the Options dialog, click the File Locations tab.

3 Under Default template file, click Browse.

Notice that you can choose an industry-specific template as your default template.

TIP To view a template, you can start a new project with that template. Click  ➤ New ➤ Project,
and click Browse to select a template.

4 Click Cancel.

5 Under Default path for user files, click Browse.

6 In the Browse For Folder dialog, select the folder to save your files to by default, and click Open.

7 In the Options dialog, under Default path for family template files, click Browse.

This path is set automatically during the installation process. These are the family templates
that you use to create new families. It is unlikely that you would ever want to modify this path.
However, there are some circumstances where you may need to modify the path, such as in a
large, centralized, architectural firm where customized templates reside on a network drive.

8 Click Cancel.

Specify library settings and create a library

9 In the Options dialog, click Places.

10 In the Places dialog, notice the list of library names.

The list is dependent on the options that you selected during installation. Each library path
points Revit Architecture to a folder of families or training files. You can modify the existing
library names and path, and you can create new libraries. An icon for each library displays in
the left pane of all Revit Architecture Open, Save, Load, and Import dialogs.
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When you are opening, saving, or loading a Revit Architecture file, you can click on the library
folder located in the left pane of the dialog. In the following illustration, notice that the libraries
display as icons in the left pane of the dialog. You can scroll the left pane to access all of the
library icons.

11 In the Places dialog, under Libraries, click  (Add Value).

12 Click in the Library Name field of the new library, and change the name to My Library.

13 Click in the Library Path field for My Library, and click the icon  that displays on the right
side of the field.

14 Navigate to C:\My Documents or a folder where you want to create a personal library of Revit
Architecture projects, templates, or families, and click Open.

TIP You may want to create a new folder first, and select it as the library path.

The new library displays in the left pane of all Revit Architecture Open, Save, Load, and Import
dialogs.

15 Click OK twice.

16 Click  ➤ Open.

17 In the left pane of the Open dialog, click the My Library icon.
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Notice that Revit Architecture navigates directly to the library path. If you work in a large office,
you may want to set up an office library on a network path to increase productivity and maintain
office standards.

18 Click Cancel.

19 Click  ➤ Options.

20 Click the File Locations tab.

21 Click Places.

22 Select My Library.

23 Click  (Remove Value) to delete the library.

24 Click OK.

Specify rendering settings

25 Click the Rendering tab.

26 Under Render Appearance Library Location, view the current path.

This path specifies the location of the Render Appearance Library. This path is determined during
installation. A project file can be used to create a standard material library. Then, you can use
the Transfer Project Standard option to make the materials available in the current project.

Under Additional Render Appearance Paths, you can specify the locations of other files used to
define render appearances, such as bump maps, custom color files, and decal image files. These
files can be stored on a network resource.

27 Click OK.

Specifying Spelling Options
In this exercise, you modify the spelling settings and the custom dictionaries for Revit Architecture.

Modify spelling settings

1 Click  ➤ Options.

2 In the Options dialog, click the Spelling tab.

3 Under Settings, select Ignore words in uppercase (DWG).

4 Under Personal dictionary contains words added during spell check, click Edit.

The custom dictionary opens in your default text editor.

5 In the text editor, enter sheetmtl-Cu, and press Enter.

Pressing Enter adds a blank line as the last entry in the dictionary. The custom dictionary and
building industry dictionaries must end with a blank line (a line with no text).

6 Click File menu ➤ Save.

7 Click File menu ➤ Exit.

8 Under Building industry dictionary, click Edit.

9 In the text editor, scroll down the list of building industry terms.

10 Click File menu ➤ Exit.

11 In the Options dialog, click OK.

12 Click  ➤ New.
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13 In the New Project dialog, click OK to open a new Revit Architecture project using the default
template.

14 Click Annotate tab ➤ Text panel ➤ Text.

15 Click in the drawing area, and enter This is sheetmtl-Cu and SHTMTL-CU.

16 Click Modify.

17 Click Annotate tab ➤ Text panel ➤ Spelling.

Notice that the spell checker allowed sheetmtl-Cu because you added it to the custom dictionary.
It allowed SHTMTL-CU because you set the spelling options to ignore words in uppercase.

18 Click  ➤ Options.

19 In the Options dialog, click the Spelling tab.

20 Under Settings, click Restore Defaults.

This command resets the spelling settings to their original configuration.

21 Under Personal dictionary, click Edit.

The custom dictionary opens in your default text editor.

22 In the text editor, delete sheetmtl-Cu.

23 In the text editor, click File menu ➤ Save, and then click File menu ➤ Exit.

24 In the Options dialog, click OK.

25 Close the file without saving it.

Modifying Snap Settings
In this exercise, you modify snap settings. Snap settings are system settings that are applied to all projects
and not saved within a project file. You can turn snap settings on and off, or use the shortcut keys to force
a particular snap method. In this exercise, you modify snap increments, work with snapping turned off, and
use shortcut keys to control snapping on an instance basis.

Modify snap increments

1 Click  ➤ New ➤ Project to open a new Revit Architecture project.

2 In the New Project dialog, under Template file, click Browse.

3 In the left pane of the Choose Template dialog, click Training Files, and open
Metric\Templates\RAC_MSS_Tutorial_Default_m.rte.

4 In the New Project dialog, click OK.

5 Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Snaps.

Notice that you can modify both length and angular snap increments. As you zoom in and out
within a view, Revit Architecture uses the largest increment that represents less than 2mm in
the drawing area. You can add an increment by entering the value with a semicolon after it.
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6 Under Dimension Snaps, click in the Length dimension snap increments box following the
value 1000 ; and enter 500 ;.

7 Under Object Snaps, notice the 2-letter acronyms next to each object snap option.

You can use these shortcut keys at any time when working on the design. For example, if you
want to snap an object to a wall midpoint, enter SM, and only midpoint snaps are recognized
until you commit an action. After you click to place the object at the midpoint, snapping reverts
to the system default settings.

8 In the Snaps dialog, click OK.

9 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.

10 On the Options Bar, clear Chain.

11 Click in the center of the drawing area, and move the cursor to the right.

Notice that the listening dimension snaps at 1000 mm increments. If it does not, zoom out
until it does so.

A listening dimension refers to the dimension that displays while you are drawing. This dimension
reacts to the movement of the cursor and numerical keyboard entries.

TIP To zoom while drawing, use the wheel button on your mouse. If you do not have a wheel button,
you can right-click and select a zoom option from the shortcut menu. While drawing, you can also
use the zoom shortcut keys, such as ZO to zoom out.
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12 While drawing a generic straight wall, zoom in until the listening dimension snap increment
shifts to 500 mm.

This is the increment that you added previously.

Draw without snapping

13 While drawing the wall, enter the shortcut key SO to turn snaps off.

Notice that when snapping is turned off completely, the listening dimension reflects the exact
length of the wall as you move the cursor to the left or right.

14 Click to set the wall endpoint.

15 Click in the drawing area to start a second wall, and move the cursor to the right. Do not set
the wall end point.

Notice that snapping is once again active. When you use shortcut keys to control snapping, the
command is only active for one click of the mouse.

Use snapping shortcut keys

16 Click Modify.

17 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.

18 Place the cursor over the horizontal wall you added previously.

Notice that the cursor snaps to various points on the wall. If you move the cursor along the
wall, it will snap to the endpoints, the midpoint, and the wall edges.

19 Enter SM.

This is the snap shortcut key that restricts all snapping to midpoints.

20 Notice that the cursor now snaps only to the midpoint of the wall.

21 Click to start the wall at the midpoint.

22 Move the cursor downward, and specify the wall endpoint.

23 Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Snaps.

24 Under Dimension Snaps, click in the Length dimension snap increments box, and delete the
value 500 ;.

Make sure you also delete the semicolon.

25 Click OK.

26 Close the file without saving it.
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Modifying Project Settings

In this lesson, you learn how to control the project environment by using the options available on the Settings menu.
Using these options, you modify the appearance of components and subcomponents in a project. You learn to:

■ Modify line patterns and styles.

■ Identify where to modify object styles for the project.

■ Modify project units of measurement, temporary dimension snap preferences, and view scales for detail levels.

■ Modify the Project Browser organization.

Modifying Line Patterns and Styles/Controlling Object Styles
In this exercise, you create a line pattern and apply it to the fascia of the roof in a sample project. You then
create a line style to mark the zoning setback from the property line.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_MPS_01_Object_Styles_m.rvt.

Create a line pattern

1 In the Project Browser, under 3D Views, double-click {3D}.

2 Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Line Patterns.

3 In the Line Patterns dialog, click New.

4 In the Line Pattern Properties dialog, for Name, enter Roof Line.

5 Enter the Types and Values shown in the following illustration:

4
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6 Click OK twice.
Now that you have created a line pattern, you can apply it using either of the following methods:

■ Use Visibility/Graphics settings to modify the roof appearance in a specific view.

■ Use object styles to apply the change to all views.

7 On the View Control Bar, click Model Graphics Style ➤ Hidden Line.

8 On the Project Settings panel, click Settings drop-down ➤ Object Styles.

9 In the Object Styles dialog, under Category, select Roofs.

10 For Line Color, select Red.

11 For Line Pattern, select Roof Line.

12 Click OK.

The line style is applied to the roof in the view.

NOTE Object Styles for the project can be modified. For example, Projection and Cut Line Weight
values can be modified to match office standards.

36 | Chapter 4   Modifying Project Settings



13 In the Project Browser, under 3D Views, double-click to Building.

14 On the View Control Bar, click Model Graphics Style, and verify that Hidden Line is selected.

Notice that the line color displays in this view, but not the line pattern.

NOTE The line pattern is most appropriate in plan views. The pattern is not applied in a perspective
or camera view where you expect to see a solid line. Plans, sections, elevations, and orthogonal 3D
views show line color and pattern.

15 In the Project Browser, under Floor Plans, double-click 03 Roof.
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16 Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Object Styles.

17 In the Object Styles dialog, under Category, select Roofs.

18 For Line Color, select Black.

19 For Line Pattern, select Solid.

20 Click OK.

21 Click View tab ➤ Graphics panel ➤ Visibility/Graphics.

22 On the Model Categories tab, for Visibility, select Roofs.

23 For Projection/Surface Lines, click Override.

This setting overrides the appearance of the roof only in the current view.

24 In the Line Graphics dialog, specify the following options:

■ For Weight, select 5.

■ For Color, select Blue.

■ For Pattern, select Roof Line.

25 Click OK twice.

Notice that only the appearance of the projection line of the roof is changed. You did not specify
a graphic override for the cut lines, so they remain unchanged.

Create a line style

26 In the Project Browser, under Floor Plans, double-click Site.

Notice the site topography and the property lines.
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27 Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Line Styles.

28 In the Line Styles dialog, under Modify Subcategories, click New.

29 For Name, enter Zoning Setback, and click OK.

30 For the Zoning Setback category, specify the following values:

■ For Line Weight Projection, select 2.

■ For Line Color, select Red.

■ For Line Pattern, select Double dash.

31 Click OK.

32 Click Home tab ➤ Model panel ➤ Model Line.

33 On the Element panel, in the Type Selector, select Zoning Setback.

34 On the Options Bar, For Placement Plane, select Level: 02 Entry Level.

This places the line above the topography.

35 On the Draw panel, click  (Line).

36 Draw lines for the setback approximately as shown:

NOTE If you only want the setback to display on the site view, click Annotate tab ➤ Detail
panel ➤ Detail Line. Detail lines only show in the view where they are created, as if they are placed
on an overlay of the view.

37 Click Modify.

38 On the Quick Access toolbar, click  (3D View).

Notice that the Zoning Setback lines display in this view.

39 Click View tab ➤ Graphics panel ➤ Visibility/Graphics.

40 On the Model Categories tab, expand Lines, and clear Zoning Setback.

This turns off the visibility of the Zoning Setback lines only in this view.
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41 Click OK.

42 In the Project Browser, under Floor Plans, double-click 02 Entry Level.

43 Click View tab ➤ Graphics panel ➤ Visibility/Graphics.

44 On the Model Categories tab:

■ Expand Lines, and clear Zoning Setback.

■ Expand Site, and clear Property Lines.

NOTE If Site is not selected, select it, and then clear Property Lines.

45 Click OK.

46 On the Quick Access toolbar, click  (3D View).

47 Close the file with or without saving it.

Specifying Units of Measurement, Temporary Dimensions, and Detail Level
Options

In this exercise, you modify 3 settings that have a broad impact on the project. In the first section, you
specify the project units of measurements. Unless overridden, dimension values display using this setting.
In the second section, you modify the temporary dimension settings. In the final section, you modify the
detail level assignments.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_MPS_01_Object_Styles_m.rvt.

Set units of measurement

1 Click Manage tab ➤ Project Settings panel ➤ Project Units.

2 In the Project Units dialog, for Length, click the default value.

3 In the Format dialog, for Rounding, select To the nearest 100, and click OK.

4 In the Project Units dialog, for Area, click the default value.

5 In the Format dialog:

■ For Rounding, select 0 decimal places.

■ For Unit symbol, select meters squared.

■ Click OK.

Modifications to area rounding are displayed in schedules and area tags.

6 Click OK.

Unless overridden, dimensions use these project settings.

Specify temporary dimension properties

7 Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Temporary Dimensions.

8 Under Walls, select Faces.

9 Under Doors and Windows, select Openings, and click OK.
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In this project, temporary dimensions now snap to the wall faces and to the door and window
openings. The location of temporary witness lines can be changed by clicking their controls.

Specify detail levels

10 On the Project Settings panel, click Settings drop-down ➤ Detail Level.

When you create a new view and specify its view scale, the detail level is specified automatically
according to the arrangement in the table.

TIP You can override the detail level at any time by specifying the Detail Level parameter in the View
Properties dialog or the Detail Level icon on the View Control Bar.

In this table, you use the arrows between the columns to move view scales from one detail level
to another. You do not select a view scale to move it. The view scale moves either from the
bottom or the top of the column based on the direction.

11 Between the columns Coarse and Medium, click  .

Notice the 1 : 50 view scale moved to the Medium column. Any new view created using this
scale is automatically assigned the detail level Medium.

12 Click OK.

13 Close the file with or without saving it.

Modifying Project Browser Organization
In a typical project, you often produce multiple packages of related drawings. These drawings and sheets
can become so numerous that navigating a lengthy Project Browser list can be cumbersome. To organize
the views and sheets into sets of deliverables, you can use the Project Browser settings to instantly modify
how the Project Browser groups and sorts.

In this exercise, you modify the Project Browser organization and create methods of grouping and sorting
the views and sheets.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_MPS_03_Browser_Org_m.rvt.

Organize the Project Browser by views

1 In the Project Browser, expand Views (all), expand Floor Plans, and expand 3D Views.

Notice that the views are listed alphabetically.

2 In the Project Browser, expand Sheets (all).

Notice that the sheets are listed alphanumerically based on the sheet number.

3 Open each of the 3D views in the following order, and notice the progression of each view:

■ Main Bldg - Phase 1-Structure

■ East Wing - Phase 2-Structure

■ West Wing - Phase 3-Structure

■ Completed Project-Structure

■ Completed Structure w/ Roof&Floors
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■ Completed Project

Each of the 3D views varies by phase and discipline.

4 Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Browser Organization.

5 On the Views tab of the Browser Organization dialog, select Discipline, and click OK.

In the Project Browser, notice that Views are divided into Architectural and Structural disciplines.

6 In the Project Browser, expand both the Architectural and Structural views.

7 On the Windows panel, click User Interface drop-down ➤ Browser Organization.

8 Select Phase, and click Apply.

In the Project Browser, notice that views are grouped by phase.

9 In the Browser Organization dialog, select Type/Discipline, and click OK.

10 In the Project Browser, expand each view type, and notice that each is grouped by discipline.

Organize the Project Browser by sheets

11 On the Windows panel, click User Interface drop-down ➤ Browser Organization.

12 Click the Sheets tab.

13 Select Sheet Prefix, and click OK.

14 In the Project Browser, under Sheets, expand each sheet set.
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Create a browser organization name

15 On the Windows panel, click User Interface drop-down ➤ Browser Organization.

16 Click the Views tab, and click New.

17 Enter Phase/Type/Discipline, and click OK.

18 In the Browser Organization Properties dialog, click the Folders tab, and specify the following:

■ Group by: Phase

■ Then by: Family and Type

■ Then by: Discipline

19 Click OK.

20 In the Browser Organization dialog, select Phase/Type/Discipline as the current browser
organization, and click OK.

21 In the Project Browser, under Views, expand Complete, expand 3D Views, and expand both
Architectural and Structural.

Notice that the Project Browser has reorganized all the views within this project according to
Phase, View Type (Family and Type), and Discipline.

22 Close the file with or without saving it.
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Creating a Site

In this lesson, you use site tools to add and modify site components within a project. You learn to:

■ Import site contour data and convert it to a 3D toposurface.

■ Create and tag property lines, using information from an imported DWG file.

■ Add a subregion to the area to define access roads and a parking area.

■ Add a building pad.

■ Add parking and planting components.

Creating a Toposurface
In this exercise, you create a toposurface by importing contour data from a DWG file and using it to create
the project toposurface. You add a section box to the 3D view of the toposurface to cut the site and view
the topography more clearly.

5
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Training File

■ Click  ➤ New ➤ Project.

■ In the New Project dialog, for Template file, click Browse, and open Training
Files\Metric\Templates\DefaultMetric.rte.

■ Click OK.

Import contour data to create a toposurface

1 Click Insert tab ➤ Import panel ➤ Import CAD.

2 In the Import CAD Formats dialog:

■ In the left pane, click Training Files, and select Common\Site Plan.dwg.

■ For Colors, select Preserve.

■ Verify that the Current view only option located on the left side of the dialog is cleared.

NOTE If you select the Current view only option when importing the DWG, then the drawing is
added as a drafting item and is view-specific. You cannot use a drafting item to create a
toposurface.

■ Click Open.

3 Zoom to fit the drawing in the view.

The drawing must be moved to the right to ensure that the building is modeled close to the
origin of the project. The elevation markers in the project template point to the origin. It is
critical that you create Revit Architecture projects as close to this origin as possible.
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4 In the drawing area, select the imported site plan.

5 Click Modify Site Plan.dwg tab ➤ Modify panel ➤ Move.

6 Click near the center of the building to enter the move start point, as shown.

7 Click to the right outside of the building to enter the move end point, as shown.

Position the center of the building close to the central area indicated by the elevation markers.
(Exact placement is not important.)

8 Press Esc.
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9 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Default 3D.

You can see results more clearly when creating the toposurface from a 3D view.

NOTE The contours in the DWG imported file are drawn with a z value. Revit Architecture uses these
values to create 3D points and generate the toposurface object.

10 Click Massing & Site tab ➤ Model Site panel ➤ Toposurface.

11 Click Create Topography Surface tab ➤ Tools panel ➤ Create from Import drop-down ➤ Select
Import Instance.

12 In the drawing area, select the site plan.

13 In the Add Points from Selected Layers dialog:

■ Click Check None.

■ Select C-TOPO-MAJR.

■ Select C-TOPO-MINR.

■ Click OK.

The DWG site plan contains information in addition to the contour lines. Use the Add Points
from Selected Layers dialog to filter out the lines you do not want to use in creating the
toposurface.
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14 Click Create Topography Surface tab ➤ Surface panel ➤ Finish Surface.

NOTE Using an imported instance, such as a DWG file or a points file, decreases the time it takes to
input points and create a toposurface. Also, you can create or add points used to define the toposurface
manually. For additional information about the manual process of creating a toposurface, refer to
Autodesk Revit Architecture 2010 Help.

Turn off the visibility of the DWG

15 In the Project Browser, expand 3D Views, right-click {3D}, and click Properties.

16 In the Instance Properties dialog, for Visibility/Graphics Overrides, click Edit.

17 On the Imported Categories tab of the Visibility/Graphic Overrides for 3D View: {3D} dialog,
under Visibility, clear Site Plan.dwg, and click OK.

18 In the Instance Properties dialog, under Extents, select Section Box, and click OK.

The DWG no longer displays, and a section box is drawn to the extents of the toposurface
geometry.
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Create a sectioned edge

19 In the drawing area, select the section box.

20 Drag the controls to adjust the edges of the section box to cut the toposurface with the box.
(Exact placement of the edge is not important.)

When the section box edge cuts the toposurface, a cut pattern is displayed on the edge of the
toposurface, making it easier to see the topography.

50 | Chapter 5   Creating a Site



View the toposurface

21 Right-click the section box, and click Hide in View ➤ Elements.

22 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

23 On the navigation bar, click  (Full Navigation Wheel), and use the Orbit tool to spin the
toposurface to view it at various angles.

24 Click  ➤ Close, and close the file without saving it.

Adding Property Lines
In this exercise, you use the imported DWG file to create property lines. You use the Tag tool to label the
property lines with distance and bearing information.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_CS_02_Property_Lines_m.rvt.

Add property lines

1 In the Project Browser, under Floor Plans, double-click Site.

2 Click Massing & Site tab ➤ Modify Site panel ➤ Property Line.

3 In the Create Property Line dialog, select Create by sketching.

You use the sketch option because the DWG already contains property line information. The
table option can also be used, depending on the information available to users at the time they
create the property lines in a project. For more information about the table method, refer to
Autodesk Revit Architecture 2010 Help.

4 Click Create Property Line Sketch tab ➤ Draw panel ➤  (Pick Lines).

Using the pick lines method, you can use existing geometry in the project as the basis for the
property lines.

5 On the View Control Bar, click Model Graphics Style ➤ Wireframe.

You change to the Wireframe style to view the right property line. It is hidden by the 3D
toposurface in the Hidden Line style.

6 Select the 4 property lines, as shown.

■ Right line.

■ Top line.
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■ Left line.

■ bottom line.

7 Click Create Property Line Sketch tab ➤ Property Line panel ➤ Finish Property Line.

Tag property lines

8 Click Annotate tab ➤ Tag panel ➤ Tag by Category.

9 On the Options Bar, clear Leader.

10 Select the midpoint of the north property line.

There are no tags loaded for Property Line Segments in this project.

11 In the dialog, click Yes to load a property line tag family for use in this project.
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12 In the left pane of the Open dialog, click Training Files, and open Metric\Families\M_Property
Line Tag.rfa.

13 Click to tag each of the 4 property lines.

14 Press Esc.

The property line tag is very small. Change the view scale to make the tags easier to read.

15 On the View Control Bar, for Scale, select 1:500.

NOTE Project North and True North can be manipulated in the project for proper bearing information.
Refer to Autodesk Revit Architecture 2010 Help for more information.

16 Close the file with or without saving it.

Creating a Topographic Subregion
In this exercise, you create a subregion to define the layout of the access roads and parking area. Creating a
subregion does not result in separate surfaces; it defines an area of the surface where you can apply a different
set of properties, such as material.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_CS_03_Subregion_m.rvt.
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Pick DWG geometry for the road and parking

1 Zoom in to the area of the roadway and parking, as shown.

2 Click Massing & Site tab ➤ Modify Site panel ➤ Subregion.

3 Click Create Subregion Boundary tab ➤ Draw panel ➤  (Pick Lines).

4 In the drawing area, position the cursor over a magenta line. (The magenta lines depict the
roadway and parking areas.)

■ Press Tab until the Status Bar indicates that a Chain of walls or lines is highlighted.

■ Click to select the chain of lines.

NOTE A chain is a series of lines or arc segments connected by their respective endpoints. You can
use this technique to quickly select each of the chains of magenta lines.

5 Using the same method, select all of the magenta lines.
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Draw lines to complete the boundary

6 Click Create Subregion Boundary tab ➤ Draw panel ➤  (Line).

7 On the Options Bar, clear Chain.

The boundary must be a closed loop. Use the draw option to close the subregion at the 2
roadways.

NOTE Clear the Chain option to draw individual line segments. Select the Chain option to draw a
series of lines or arcs connected at their endpoints.

8 Draw a line to close the boundary where the left roadway intersects the site boundary. Click the
intersection of the road and site line on the left.

Move the cursor horizontally, and click the intersection of the line on the right, as shown.

9 Using the same method, draw a line across the roadway on the right to close the boundary.

10 Press Esc.

Change the material of the subregion

11 Click Create Subregion Boundary tab ➤ Element panel ➤ Subregion Properties.

12 In the Properties dialog, under Materials and Finishes, for Material, click  .

13 In the Materials dialog, scroll and select Site - Tarmacadam.

14 Click OK twice.

15 Click Create Subregion Boundary tab ➤ Subregion panel ➤ Finish Subregion.

16 On the Quick Access toolbar, click  (Default 3D).
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17 Close the file with or without saving it.

Adding a Building Pad
In this exercise, you create a building pad. A building pad is a toposurface-hosted element and can only be
added to a topographic surface. When you add a building pad, either the pad will cut into the toposurface
or the toposurface will be built up, as required by the placement of the pad object.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_CS_04_Building_Pad_m.rvt.

Add a building pad to the project

1 In the Project Browser, under Floor Plans, double-click Site.

2 Zoom in to the building footprint.
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3 Click Massing & Site tab ➤ Model Site panel ➤ Building Pad.

NOTE By default, the Pick Walls command is active. If you have an existing building model, you can
pick the exterior walls to define the building pad.

4 Click Create Pad Boundary tab ➤ Draw panel ➤  (Pick Lines).

You use the DWG information to establish the boundary of the pad object.

5 Select all of the lines representing the extents of the building. (These are the dark blue lines
including the small square representing the pavilion.)

NOTE Optionally, position the cursor over a line, press Tab until the Status Bar indicates that a chain
of lines is highlighted, and click to select it.

The lines change color when you select them.
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6 Click Create Pad Boundary tab ➤ Selection panel ➤ Modify.

7 Click Create Pad Boundary tab ➤ Edit panel ➤ Split.

You use the Split and Trim tools to modify the lines to get a closed loop boundary. When drawing
in Revit Architecture, it is important that boundaries are established as closed loops with no
intersecting lines.

8 Click the right vertical line of the building where it attaches to the pavilion, as shown. (The
exact location of the split is not important, as long as it is between the lines of the pavilion
edge.)

9 Click Create Pad Boundary tab ➤ Edit panel ➤ Trim.

10 Select the following lines to trim the boundary:

■ Vertical building line above the split.
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■ Top horizontal line of the pavilion.

■ Vertical building line below the split.

■ Bottom horizontal line of the pavilion.

11 Click Create Pad Boundary tab ➤ Building Pad panel ➤ Finish Building Pad.

12 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Default 3D.
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13 Close the file with or without saving it.

Adding Parking Spaces
In this exercise, you add parking spaces to the site surface. You also create a schedule to display the total
number of parking spaces.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_CS_05_Parking_m.rvt.

Add parking components

1 In the Project Browser, under Floor Plans, double-click Site.

2 Zoom in to the parking area.

3 Click Massing & Site tab ➤ Model Site panel ➤ Parking Component.

4 On the Element panel, in the Type Selector, under M_Parking Space, select 5480 x 2740 mm -
90 deg.

Because Revit Architecture subregions do not support snapping, you use the DWG linework to
place the parking component.

5 Align the parking space in the upper-right corner of the parking area, and click to place a parking
component, as shown.
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6 Press the Spacebar twice to rotate the parking space component, and click to place another
parking space in the lower-left corner of the parking lot, as shown.

7 Click Modify.

Array parking spaces

8 Select the parking space in the upper-right corner.

9 Click Modify Parking tab ➤ Modify panel ➤ Array.

10 Array the parking components in the upper area of the lot:

■ Click the upper-right corner of the parking space to specify the endpoint of the array.

■ Move the cursor to the left, type 2740 mm, and press Enter.
This value defines the distance to the placement of the 2nd object in the array.
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■ Type 16, and press Enter to define the array count (number of objects in the array).

11 Press Esc.

12 Using the same method, define an array for the parking spaces on the other side of the parking
lot. Use the following specifications:

■ Endpoint - lower-left corner.

■ Distance between spaces 2740 mm.

■ Array count - 10.
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13 Press Esc.

Modify the array

Notice that a count of 10 parking spaces was 1 too few. You can add 1 space to the array. To add an instance
to the array, select 1 of the objects in the array and change the array count value.

14 Select a parking space in the array, type 11 for the array count, and press Enter, as shown.

15 Press Esc.

Create a schedule to count parking spaces

16 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.

17 In the New Schedule dialog, for Category, select Parking, and click OK.

18 In the Schedule Properties dialog, for Available fields, select Count, and click Add.

19 Click OK.

The schedule itemizes each instance of the parking objects. However, you would like the schedule
to display a total.
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20 In the Project Browser, expand Schedules/Quantities, right-click Parking Schedule, and click
Properties.

21 In the Instance Properties dialog, for Sorting/Grouping, click Edit.

22 On the Sorting/Grouping tab of the Schedule Properties dialog, clear Itemize every instance,
and click OK.

23 In the Instance Properties dialog, for Formatting, click Edit.

24 On the Formatting tab of the schedule Properties dialog, for Heading, type Number of Spaces.

25 Click OK twice.

26 In the schedule, click and drag the right border to expand the view.

Turn off the visibility of the DWG

27 In the Project Browser, open the Site plan view.

28 Zoom to fit the site plan in the view.

You do not need the DWG site plan anymore. You can turn off the visibility (or totally remove
the drawing from the project) for visual clarity in the site plan.

29 In the Project Browser, right-click Site, and click View Properties.

30 In the Instance Properties dialog, for Visibility/Graphics Overrides, click Edit.

31 On the Imported Categories tab of the Visibility/Graphic Overrides dialog, clear Site Plan.dwg.

32 Click OK twice.
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33 Close the file with or without saving it.

Adding Planting Components
In this exercise, you add planting components to the site surface. You also create a schedule to determine
landscape counts.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_CS_06_Planting_m.rvt.

Add planting families to the site

1 In the Project Browser, under Floor Plans, double-click Site.

2 Click Massing & Site tab ➤ Model Site panel ➤ Site Component.

3 Click to place a tree to the left of the parking lot, as shown.

In this step, you place the default tree that is selected. To place a different variety of tree
(planting), choose a different type in the Type Selector on the Element panel.
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4 Click to place 3 trees in the courtyard for the building, as shown.

5 On the Element panel, in the Type Selector, select Honey Locust - 7.6 Meters.

6 Click to place the tree in the island to the left of the building.

Load a planting family

7 Click Site Component tab ➤ Model panel ➤ Load Family.

8 In the left pane of the Load Family dialog, click Training Files, and open Metric\Families\M_RPC
Shrub.rfa.

9 Click to place 3 shrubs along the interior of the left roadway.
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10 Optional: Populate the project with a variety of plantings. (Exact variety and placement is not
important.)

Create a landscape schedule

After the layout is complete, you create a landscape schedule to count and sort the planting selections.

11 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.

12 In the New Schedule dialog:

■ For Category, select Planting.

■ For Name, type Landscape Schedule.

■ Click OK.

13 On the Schedule Properties dialog, specify options:

■ On the Fields tab, select Type and click Add.

■ Select Count, and click Add.
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■ On the Sorting/Grouping tab, clear Itemize every instance. (Each planting type will be totaled
in the schedule.)

■ For Sort by, select Type.
You use the Sort by field to have the planting selections sorted alphabetically by name.

■ On the Formatting tab, for Heading, type Plant Name.

■ Click OK.

14 In the schedule, double-click the column borders to expand the columns to fit the text.

The content of the schedule will vary depending on the type of plantings you placed.

15 In the Project Browser, under 3D Views, double-click {3D} to view the site layout with the
plantings.

16 Zoom to fit the site plan in the view.

17 On the navigation bar, click  (Full Navigation Wheel), and use the Orbit tool to spin the
toposurface to view it at various angles. Notice how the trees vertically attach to the toposurface.

NOTE Plants are displayed as simple geometry until rendered.
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18 If the tops of the trees appear to be cut off, do the following to adjust the section box:

■ On the View Control Bar, click  (Reveal Hidden Elements).

■ Select the section box, and use the control to drag the top of the section box up until the
trees are displayed correctly.

■ On the View Control Bar, click  (Close Reveal Hidden Elements).

19 Close the file with or without saving it.
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Modeling a Project

In this tutorial, you use a recommended workflow to create a Building Information Model (BIM) and refine the model.

71



72



Creating Project Datums

In this lesson, you establish the datums for the building model, including:

■ Adding levels.

■ Creating labeled and dimensioned grid lines.

■ Adjusting grid line length and adding gaps to optimize the layout.

Adding Project Levels
In this exercise, you add levels to the project. The levels serve as datums for placing additional objects in
the project.

6
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_CPD_01_Adding_Levels_m.rvt.

Adjust existing level

1 In the Project Browser, under Elevations (Building Elevation), double-click South.

2 In the elevation view, zoom in to the level markers.

3 In the drawing area, right-click a tree, and click Hide in view ➤ Category.

The visibility for the planting category is turned off, reducing the visual clutter.

4 Zoom in to the level labels on the right.

5 Before adding levels, adjust the height of Level 2:

■ Select Level 2.

■ Click the Level 2 height parameter.

■ Type 3800 mm, and press Enter.
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6 Zoom out until you can see both ends of the existing levels.

Add levels

7 Click Home tab ➤ Datum panel ➤ Level.

8 On the left side of the existing levels, click to add a third level 3800 mm above Level 2, as shown.

NOTE To locate the starting point, move the cursor over the end point of Level 2, and move the
cursor up, using the displayed drawing aids to locate the correct starting point.

9 Move the cursor to the right, and click to align the right edge of the level marker with the
existing levels.

10 Using the same method, add a fourth level 3800 mm above Level 3, as shown.
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11 On the Options Bar, clear Make Plan View.

The next level you add is used to establish the parapet height of the wall. This level is used only
for reference, so you do not need to create a plan view.

12 Using the same method, add a fifth level 2000 mm above Level 4, as shown.

13 Click Place Level tab ➤ Select panel ➤ Modify.

Modify levels

14 Zoom in to the level heads.

15 Select Level 5, click the height parameter, type 12400 mm, and press Enter.

16 Adjust the Level 5 marker so it does not overlap the text from the level below:

■ Select Level 5.

■ Click the control to add an elbow, as shown.

■ Drag the elbow to adjust the label position. (Exact placement is not important.)
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Rename levels

17 Select Level 1, click the Level 1 label, type 01 - Entry Level, and press Enter.

18 In the dialog, click Yes to rename corresponding views.

19 Using the previous method, rename the remaining levels:

New NameExisting Name

02 - FloorLevel 2

03 - FloorLevel 3

RoofLevel 4

ParapetLevel 5

20 Close the file with or without saving it.

Creating Project Grid Lines
In this exercise, you add grid lines to the project. The grid lines are numbered and lettered automatically as
they are placed. You use the dimension tools to dimension the grids and space them equally across the
building.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_CPD_02_Grid_Lines_m.rvt.

Adjust the visibility of the view

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

Placing grids in this view minimizes the necessity of manipulating the grids in other views.
However, you can also display grid objects in the other plans as well.

2 In the Project Browser, right-click 01 - Entry Level, and click Properties.

To make it easier to position the grids, you temporarily display the building pad object in this
view. To display the pad, you switch on the topography visibility and adjust the view range.

3 In the Instance Properties dialog, for Visibility/Graphics Overrides, click Edit.

4 On the Model Categories tab of the Visibility/Graphics Overrides dialog, clear Planting, select
Topography, and click OK.

5 In the Instance Properties dialog, under Extents, for View Range, click Edit.

6 In the View Range dialog, under View Depth, for Level, select Unlimited, and click OK.

7 In the Instance Properties dialog, for View Scale (at the top of the parameter list), select 1 : 200.

You change the scale of the view so the grid labels are easier to see when you place the grid
lines.

8 Click OK.

Place vertical grid lines

9 Zoom in to the building pad to more easily place the grids.
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10 Click Home tab ➤ Datum panel ➤ Grid.

11 Add the grid using the left pad edge as a snap point.

■ Click the upper-left end point of the building pad.

■ Move the cursor down, and click below the lower-left corner of the pad.

Creating Project Grid Lines | 79



12 Press Esc twice.

13 In the drawing area, click the grid line.

14 Click and drag the model ends of the grid line so that it overhangs the pad on both sides. (Exact
placement of grid end points is not important.)

15 Click the box at the top end of the grid line to toggle on the visibility of the label.
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16 Press Esc twice.

17 Using the same method, add 9 additional vertical grid lines.

■ Use the end points of the first grid line as the snap points.

■ The placement of the additional grid lines is not important. However, grid 6 should be near
the end line of the shorter wing of the building.
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■ Use snap points to place grid 10 at the end line of the longer wing. Then, adjust the end
points as required to align with the other grids.

18 Click Modify.

19 Align grid line 6 with the end line of the shorter wing of the building.

■ Click Modify tab ➤ Edit panel ➤ Align.

■ Click the right vertical line of the shorter wing.

■ Click grid line 6.
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20 Click Modify.

Dimension the grid lines

21 Click Annotate tab ➤ Dimension panel ➤ Aligned.

22 Click grid lines 1 through 6 sequentially, and click above the grid lines to place the dimension
string.

23 Click EQ on the dimension string to specify equal spacing among the grid lines between the
dimensioned points.
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24 Click Modify.

25 Using the previous method, equalize the grids from 6 to 10.

26 Click Modify.

27 Select the left dimension string, and press Delete.

NOTE Dimensions can be used to establish constraints. If a dimension used to establish a constraint
(in this case the EQ spacing) is subsequently deleted, you can choose to maintain the constraint or
unconstrain the elements.

28 In the warning dialog, click Unconstrain.

29 Using the previous method, delete the right dimension string and remove the constraint on the
grid lines.
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Place and dimension horizontal grid lines

30 Click Home tab ➤ Datum panel ➤ Grid.

31 Click the end point at the upper-right corner of the short wing.

32 Draw a horizontal grid line to the left, click outside of the building, and press Esc.
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33 Adjust the overhang of the grid as desired.

34 Use alphabetic grid labels for the horizontal grid lines:

■ Click grid label 11.

■ Type A.

■ Press Enter.

35 Place 9 additional horizontal grid lines over the building.

The grids automatically use the alphabetic sequence for labelling. Grid line C should align with
the lower wall of the short wing and grid line H should align with the upper wall of the long
wing.

36 Using the techniques of dimensioning and the EQ control, space the grids as follows:

■ A-C are equalized on the short building wing.

■ C-H are equalized through the center section of the building.

■ H-J are equalized on the long wing of the building.
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37 Close the file with or without saving it.

Adjusting Grid Lines
In this exercise, you adjust the grid lines for clarity in the project. You modify end points and add gaps in
grid lines where it will simplify the view.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_CPD_03_Adjust_Grids_m.rvt.

Adjust grid line length

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 In the drawing area, select grid line 7.

3 Click the top lock to remove the constraint.

4 Adjust the end point of the grid line by dragging it down close to the edge of the longer building
wing.

5 Using the previous method, adjust grid lines 8-10 to the same length.

The grid lines will snap with the endpoint of grid line 7 to help with alignment. Remember to
click the lock to remove the constraint before adjusting the end point. (Exact placement is not
important.)

6 Using the previous method, adjust the horizontal grid lines D-G so that they are closer to the
edge of the midsection of the building.

■ Select the grid line.

■ Click the lock to remove the constraint.
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■ Drag the model end point to the left.

Display gridline labels

7 Display grid labels for grid lines 1-6 so that the grid is labeled on both sides of the building.

■ Select grid line 2, and click in the box above the grid line.

■ Using the previous method, display the labels for grid lines 3-6.

Change the grid type

8 While pressing CTRL, select grid lines 4-6.

9 Click Modify Grids tab ➤ Element panel ➤ Type Selector drop-down ➤ 6.5 mm Bubble Gap.

You change to a grid type that allows a gap to be displayed in the grid line.

10 Select grid line 6, and adjust the gap:

■ Using the control, adjust the top end point of the grid line gap so that it extends just below
the shorter wing of the building, as shown. (Exact placement is not important.)
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■ Adjust the bottom end point of the grid line gap so that it extends above the longer wing
of the building, as shown.

■ Press Esc.
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11 Using the previous method, adjust the top and bottom end points of the grid line gaps for lines
4 and 5.

12 Close the file with or without saving it.
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Using Massing

In this lesson, you learn to:

■ Use massing tools to create building massing objects.

■ Create mass floors based on building levels.

■ Schedule floor areas.

■ Use Building Maker tools to create floors, walls, and a roof from the massing faces.

■ Create a perspective view.

Using Massing Tools
In this exercise, you create massing for the main building. You use the building pad created in a previous
exercise to establish the massing.

7
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_UM_01_Massing_Tools_m.rvt.

Create a mass for the main building

1 In the Project Browser, under 3D Views, double-click {3D}.

2 On the View Control Bar, click Model Graphics Style ➤ Hidden Line.

3 Zoom in to the building pad.

4 Click Massing & Site tab ➤ Conceptual Mass panel ➤ In-Place Mass.

5 In the Massing - Show Mass Enabled dialog, click Close.

6 In the Name dialog, type Main Building, and click OK.

The massing that you create for the main building is a simple extrusion of the shape already
established by the pad object.

7 Click Model In-Place Mass tab ➤ Draw panel ➤ Line.

8 On the Draw panel, click  (Pick Lines).

The boundary can be established quickly using the Pick Lines option.
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9 On the Placement panel, click Work Plane.

10 Position the cursor over the outline of the pad, and press Tab until Chain of walls or lines displays
in the Status Bar.

11 Click to select the outline.

12 On the Selection panel, click Modify.

The portion of the building in the courtyard (the pavilion) will have different massing. You
remove this portion of the boundary and use the Trim/Extend tool to close the boundary loop.

13 While pressing Ctrl, select the 3 lines representing the pavilion and the line to the left of the
pavilion, and press Delete.

NOTE To select an individual line segment instead of the chain of lines, press Tab to highlight the
segment, and click to select it.
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14 Click Modify tab ➤ Edit panel ➤ Trim.

15 Select the main building boundary line to the left of the pavilion.

16 Select the line to the right of the pavilion.

The boundary is now a closed loop.

17 Click Modify.

18 Select the boundary you just created.

19 Click Modify Lines tab ➤ Form panel ➤ Create Form drop-down ➤ Form.
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20 In the drawing area, click the dimension value for the height, type 13000 mm, and press Enter.

21 Click Model In-Place Mass tab ➤ In-Place Editor panel ➤ Finish Mass.

22 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
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23 Close the file with or without saving it.

Creating a Mass Study Analysis
In this exercise, you add floor areas to the mass object based on the levels created in a previous exercise.
You then schedule floor areas for preliminary analysis of the building form. After you add a mass for the
pavilion to the study, the floor area schedule is updated automatically.

Floor areas defined by building levels

Mass floor schedule with gross
floor area

Training File

■ Click  ➤ Open.
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■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_UM_02_Massing_Study_m.rvt.

Assign floors to the mass

1 Click Massing & Site tab ➤ Conceptual Mass panel ➤ Show Mass.

2 In the drawing area, select the mass.

3 Click Modify Mass tab ➤ Massing panel ➤ Mass Floors.

4 In the Mass Floors dialog, select the following levels:

■ 01 - Entry Level

■ 02 - Floor

■ 03 - Floor

The levels in the project are seen as valid datums that can be used to establish floor levels in the
mass object.

5 Click OK.

6 Press Esc.
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Create a schedule to report mass floor areas

You create a schedule that totals the floor areas from each level and reports the area of the entire building.

7 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.

8 In the New Schedule dialog, under Category, select Mass Floor, and click OK.

9 In the Schedule Properties dialog, under Available Fields, select Mass: Family, and click Add.

10 Using the previous method, add the following fields:

■ Level

■ Floor Area

11 Click OK.

12 Expand the columns to view the entire mass floor schedule.

Modify the schedule properties

13 In the Project Browser, under Schedules/Quantities, right-click Mass Floor Schedule, and click
Properties.

14 In the Instance Properties dialog, for Formatting, click Edit.

15 On the Formatting tab of the Schedule Properties dialog, under Fields, select Floor Area, and
under Field formatting, select Calculate totals.

16 On the Sorting/Grouping tab, select Grand totals, and in the drop-down list, select Totals only.

17 Click OK twice.

Add a mass for the pavilion

18 In the Project Browser, under 3D Views, double-click {3D}.

19 Click Massing & Site tab ➤ Conceptual Mass panel ➤ In-Place Mass.

You add a pavilion in the courtyard of the building. The pavilion is not as tall as the other
portions of the building and only has a floor on the first level.

20 In the Name dialog, type Pavilion, and click OK.

21 Zoom in to the outline for the pavilion.

22 Click Model In-Place Mass tab ➤ Draw panel ➤ Line.

23 On the Draw panel, click  (Pick Lines).

24 On the Placement panel, click Work Plane.

25 Position the cursor over the edge of the pavilion, press Tab until the edge is highlighted, and
click to select it.

NOTE If it is difficult to select the edge of the pavilion, use the ViewCube to change the orientation,
as shown.
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26 Using the previous method, select the other 3 edges of the pad.

You will only be able to select the long edge of the main building mass for the back edge of the
pavilion. Trim this long edge in the next step.

27 Click Modify tab ➤ Edit panel ➤ Trim.

28 Trim the long back line so that it completes the perimeter of the pavilion.

29 On the Selection panel, click Modify.

30 Select the pavilion boundary.

31 Click Model In-Place Mass tab ➤ Form panel ➤ Create Form drop-down ➤ Form.

32 Click the dimension length value for the height (the lower dimension value), type 6600 mm,
and press Enter.

33 Click Model In-Place Mass tab ➤ In-Place Editor panel ➤ Finish Mass.

Add a floor area to the pavilion mass

34 Select the pavilion mass.

35 Click Modify Mass tab ➤ Massing panel ➤ Mass Floors.
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36 In the Mass Floors dialog, select 01 - Entry Level, and click OK.

37 In the Project Browser, under Schedules/Quantities, double-click Mass Floor Schedule.

Notice that the floor area schedule is automatically updated to include the pavilion.

38 Close the file with or without saving it.

Using Building Maker Tools
In this exercise, you use the building massing established in earlier exercises to create the exterior shell of
the building. You adjust the size of the massing and remake the walls to accommodate the massing changes.

After the shell is complete, you create a camera view for a 3D perspective of the courtyard of the building.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_UM_03_Building_Maker_m.rvt.
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Create floors by selecting faces

1 In the Project Browser, under 3D Views, double-click {3D}.

2 Click Massing & Site tab ➤ Conceptual Mass panel ➤ Show Mass.

3 Zoom in to the building area.

4 Click Massing & Site tab ➤ Conceptual Mass panel ➤ Model by Face drop-down ➤ Floor.

Use the Floor by Face command before adding walls. Adding the walls first makes it difficult to
select the floor faces in the mass.

5 Select the 2nd floor in the main building.

NOTE You begin on the second floor because in previous steps a pad object was placed on the
ground. This pad is acting as the floor for the entry level.
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6 Click Place Floor by Face tab ➤ Multiple Selection panel ➤ Create Floor.

7 Using the previous method, create a floor for the 3rd level.

8 Click Modify.

Create walls by selecting faces

9 Click Massing & Site tab ➤ Conceptual Mass panel ➤ Model by Face drop-down ➤ Wall.

10 On the Options Bar, for Location Line, select Finish Face: Interior.

Specify that the location line of the wall is the interior face of the wall.

11 Select the outside faces of the building. Do not select the pavilion or the main building faces
toward the courtyard.

12 After the outside walls are placed, use the ViewCube to turn the model to the right back side so
the courtyard and pavilion walls can be placed.

These walls will use a curtain wall family.
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13 Click Place Wall tab ➤ Element panel ➤ Type Selector drop-down, and select Curtain Wall.

14 Select the courtyard faces of the main building and the pavilion faces.

15 Click Modify.

Adjust the mass object height

16 Select the main building mass and use the controls to drag the height of the mass up. (The exact
height is not important.)

Changing the height allows you to more easily align the mass object with the correct level in
an elevation view.
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17 In the Project Browser, under Elevations (Building Elevation), double-click South.

18 Zoom in to the building.

19 Click Modify tab ➤ Edit panel ➤ Align.

In an elevation view, use the Align tool to align the top of the mass with the parapet level of
the building.

20 Select the Parapet level.

21 Select the top of the Main Building mass.
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22 Press Esc to end the Align command.

23 In the Project Browser, under 3D Views, double-click {3D}.

In a 3D view, you can see that the walls no longer line up with the massing used to create them.
The Remake tool allows you to recreate the walls if the massing changes.

24 Place the cursor over a basic wall, and press Tab until Chain of walls or lines displays in the
Status Bar.

25 Click to select the walls.

The entire selection set can be remade at one time to make editing quicker.

26 Click Modify Walls tab ➤ Model by Face panel ➤ Update to Face.
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27 Using the previous method, update the curtain walls along the courtyard.

NOTE While pressing Ctrl, click to add each curtain wall to the selection set to adjust all of the walls
at one time.

28 Click Modify.

Add a roof

29 Click Massing & Site tab ➤ Conceptual Mass panel ➤ Model by Face drop-down ➤ Roof.

Add a roof to the building to finish the exterior skin of the building.

30 Select the top face of the main building.

31 Click Place Roof by Face tab ➤ Multiple Selection panel ➤ Create Roof.

32 Click Modify.

33 Select the roof, and click Modify Roofs tab ➤ Element panel ➤ Element Properties
drop-down ➤ Instance Properties.

Adjust the roof properties so it is offset from the face of the massing by the height of the parapet.

34 In the Instance Properties dialog, for Level Offset, type -1000 mm, and click OK.

35 Press Esc.

Create a perspective view

36 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.
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37 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Camera.

■ Click outside of the building in the upper-right corner to place the eye position of the camera.

■ Click below the lower-left corner of the building to place the view target.

38 Use the controls of the crop boundary to adjust the view as required.

NOTE The view can also be adjusted using the SteeringWheels tools in the perspective view.

39 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

40 Click Massing & Site tab ➤ Conceptual Mass panel ➤ Show Mass to hide the massing.
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Rename the view

41 In the Project Browser, right-click 3D View 1, and click Rename.

42 In the Rename View dialog, type Building Courtyard, and click OK.

43 Close the file with or without saving it.
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Adding Basic Building
Elements

In this lesson, you add basic building elements to the model. You learn to:

■ Place structural columns, using the grid as a layout tool.

■ Use drawing tools to edit the floor shape to accommodate a second floor balcony.

■ Modify the roof slab shape and structure to provide roof drain conditions.

■ Create a butterfly-shaped roof over the pavilion, using the walls as a footprint.

■ Add an interior wall layout to the entry level, and modify the exterior wall to create an entry.

■ Place windows and doors in the entry level layout.

■ Use 2 methods to add ceilings to the layout: placing by automatically detecting room boundaries and placing by
drawing a boundary.
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Adding Columns
In this exercise, you place structural columns in the model. When placing the columns, you use the grids
placed during previous exercises as a layout tool. You alter the columns to meet design requirements, and
place them on multiple levels of the building model.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_BBE_01_Add_Columns_m.rvt.

Load a column family

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Click Home tab ➤ Build panel ➤ Column drop-down ➤ Structural Column.

The design calls for a round concrete column.

3 Click Place Structural Column tab ➤ Element panel ➤ Type Selector drop-down, and notice that
the round column required is not available in the project.
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Load the column family from an external library.

4 Click Place Structural Column tab ➤ Detail panel ➤ Load Family.

5 In the left pane of the Load Family dialog, click Training Files and open
Metric\Families\M_Concrete-Round-Column.rfa.

Add columns

6 Click Place Structural Column tab ➤ Multiple panel ➤ On Grids.

This option allows you to quickly select all of the grid intersections where columns can be
placed.

7 Starting in the lower left corner and ending in the upper right corner, draw a selection window
around the entire floor plan.

All model elements except grids are filtered out of the selection set.

8 On the Multiple Selection panel, click Finish Selection.

The columns are placed at the intersections of all selected grids.

Adding Columns | 113



9 Click Modify.

Columns placed at grid intersections C4-C6 and H4-H10 are outside of the curtain wall that
creates the skin of the building in the courtyard. You need to delete these columns from the
project.

10 Draw a selection box around the columns placed at grid intersections C4-C6, and press Delete.

11 Using the same method, delete columns placed at grid intersections H4-H10.

Modify column height

12 Using a selection box, select the entire floor plan.

13 Click Multi-Select tab ➤ Filter panel ➤ Filter.

You filter the selection set to include only the structural columns.

14 In the Filter dialog:

■ Click Check None.

■ Under Category, select Structural Columns.

■ Click OK.

15 Click Multi-Select tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance Properties.

You modify the properties and apply an offset to the top of the columns to accommodate the
thickness of the floor above.

16 In the Instance Properties dialog, for Top Offset, type -150 mm, and click OK.

Paste columns to upper levels

17 While the columns are still selected, click ➤ Multi-Select tab ➤ Clipboard panel, ➤ Copy.

18 On the Clipboard panel, click Paste Aligned drop-down ➤ Select Levels.
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19 In the Select Levels dialog, while pressing Ctrl, select 02 - Floor and 03 - Floor.

20 Click OK.

21 Open the {3D} view.

In a 3D view, the columns added to all 3 levels are displayed.

Delete extra columns in the pavilion

22 Use the ViewCube to orient the view to the pavilion.

23 Zoom in to the columns in the pavilion.

Even though the walls of the pavilion extend up 2 levels, it only has one floor level, so you can
delete the columns on the second and third levels.

24 Select the columns in the second and third levels of the pavilion (2 columns on each level).
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25 Press Delete.

26 Close the file with or without saving it.

Editing Floors
In this exercise, you modify the floor for the second level. The design calls for a balcony from the second
level of the main building looking into the pavilion. You created the floor object in the massing exercises
and the shape of the massing determines the element shape. You edit the existing floor to change the shape
as required.

116 | Chapter 8   Adding Basic Building Elements



Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_BBE_02_Edit_Floor_m.rvt.

Edit the floor

1 In the Project Browser, under Floor Plans, double-click 02 -Floor.

2 Position the cursor over the floor edge, press Tab until the Status Bar indicates that the floor
object is highlighted, and click to select it.

3 Click Modify Floors tab ➤ Edit panel ➤ Edit Boundary.

You modify the shape that defines the floor extents.

Draw lines for new floor shape

4 Click Modify Floors > Edit Boundary tab ➤ Draw panel ➤ Boundary Line.

5 On the Draw panel, click  (Line).

6 On the Options Bar, select Chain.
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7 Click at the intersection of grid line F.1 and the right vertical floor line.

8 Move the cursor 1200 mm to the right, and click.

9 On the Draw panel, click  (Arc passing through three points).

10 Move the cursor down to the intersection of grid line G, and click to define the endpoint of the
arc.

11 Click to define the third point of the arc, as shown. (You adjust the radius in a later step.)
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12 Click Edit Boundary tab ➤ Draw panel ➤  (Line).

13 Move the cursor to the left, and click the intersection of grid line G and the existing floor line.

14 Click Modify.

15 Select the curved boundary line for the balcony, click the dimension, type 3500, and press Enter.

16 Press Esc.

With the shape complete, you modify the existing lines in order to form a closed loop for the
boundary. Boundary shapes must be closed loops in order to create the object from the boundary.

Editing Floors | 119



Create a closed loop boundary

17 Click Modify Floors > Edit Boundary tab ➤ Edit panel ➤ Split.

18 Click near the midpoint of the vertical floor within the balcony shape, as shown.

19 Click Modify Floors > Edit Boundary tab ➤ Edit panel ➤ Trim.

20 Trim the lines to form a closed boundary incorporating the new balcony floor shape, as shown.

21 Click Edit Boundary tab ➤ Floor panel ➤ Finish Floor.

The shape of the floor is modified to represent the new design.

22 In the Project Browser, under 3D Views, double-click {3D}.

23 Use the ViewCube to orient the view to the pavilion, where you can see the new balcony.
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24 Close the file with or without saving it.

Editing a Flat Roof
In this exercise, you slope the roof slab of the building to allow for roof drainage conditions. For this exercise,
you only modify one section of the roof.

You modify the slab construction to more accurately reflect the actual construction of the roof and the way
the slope will be accommodated in the insulation of the roof.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_BBE_03_Edit_Roof_m.rvt.
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Draw ridge lines

1 With the 3D view open, select the roof slab.

2 Click Modify Roofs tab ➤ Shape Editing panel ➤ Add Split Line.

In this exercise, you work on a specific area of the slab. You add ridge lines to the slab to
accommodate conditions, as required.

3 Draw a ridge line to separate the shorter wing of the building, as shown.

In addition to ridge lines, you can also place points on the slab surface. You can then use both
ridge lines and points to modify the shape of the roof slab.

Place points

4 On the Shape Editing panel, click Add Point.
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5 Click to add a point to the middle of the section of roof over the shorter wing to represent the
roof drain location. (Exact placement is not important for this exercise.)

Modify roof edge elevation

6 On the Shape Editing panel, click Modify Sub Elements.

Now, you can alter the elevations of edges, ridges, and points to create a shaped slab. In this
case, you raise the edges around a drainage point from the original roof position.

7 Place the cursor over the shorter wing roof edge, press Tab until Chain of walls or lines displays
in the Status Bar, and click to select the chain of roof edges.

8 On the Options Bar, for Elevation, type 150 mm, and press Enter.

9 Click in the drawing area, and press Esc.

The roof slab displays with edges representing the sloping faces leading down to the roof drain.
You can use the same method to modify the remainder of the roof to accommodate the drainage
conditions.

Editing a Flat Roof | 123



Create a section

10 In the Project Browser, under Floor Plans, double-click Roof.

11 Click View tab ➤ Create panel ➤ Section.

You create a section through the building near the low point on the sloped section of the roof.

12 Draw a vertical section between grid lines 4 and 5 through the shorter wing of the building.
(Exact placement is not important.)

13 Press Esc.

14 Double-click the section head to view the section.
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In the section view you can see that the slab is warped. The design specifies that the slab is flat
along the bottom edge and the slope is created using tapered insulation. You modify the slab
construction to reflect this design.

Modify slab structure

15 Select the roof.

16 On the Element panel, in the Type Selector, select Warm Roof - Concrete.

The roof type you need is not in the Type Selector. Because a roof type is a system family and
cannot be loaded into the project, you must create it or transfer it from an existing project. To
create the roof type, you select a roof family that closely matches the required type, duplicate
it, and modify its properties as needed.

NOTE For more information on transferring a system family (for example, a roof type) from an existing
project, see Transferring Project Standards in the Revit Architecture Online Help.

17 On the Element panel, click Element Properties drop-down ➤ Type Properties.

18 In the Type Properties dialog, click Duplicate.

19 In the Name field, type Concrete Deck - Tapered Insulation, and click OK.

20 In the Type Properties dialog, for Structure, click Edit.

21 Change the thickness and material properties:

■ In the Edit Assembly dialog, select Layer 3 Thermal/Air Layer [3], Material Roofing - Asphalt,
and click Delete.

■ Using the same method, delete Membrane Layer and Substrate [2].
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■ In the Edit Assembly dialog, for Layer 1 Finish 1 [4], click the Material field, and click  .

■ In the Materials dialog, select Roofing - EPDM Membrane, and click OK.

■ For the Finish layer Thickness, type 2 mm.

■ For the Structure layer Thickness, type 190 mm.

■ In the Edit Assembly dialog, for Layer 2 (Thermal/Air Layer), select Variable.
Selecting this option specifies that the insulation and all layers above the insulation slope
while the other layers of the roof remain horizontal.

■ Click OK twice.

Change the view level detail

22 On the View Control Bar, click Detail Level ➤ Fine.

23 Zoom in to see how the insulation layer is sloping.

24 Close the file with or without saving it.

Creating a Sloped Roof
In this exercise, you add a butterfly roof to the pavilion of the building. You use the Roof by Footprint tool
and define the slopes as negative values to establish the butterfly shape.

NOTE A butterfly roof is created by inverting the roof gable so it dips in the middle and resembles the wings of
a butterfly.

126 | Chapter 8   Adding Basic Building Elements



Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_BBE_04_Sloped_Roof_m.rvt.

Create a roof by footprint

1 In the Project Browser, under Floor Plans, double-click 03 - Floor.

By selecting the third floor as the view to use in drawing the roof, the roof will be associated
with Level 3. You choose this level because it is the closest level to where the roof of the pavilion
will be located.

2 Zoom in to the pavilion area.

3 Click Home tab ➤ Build panel ➤ Roof drop-down ➤ Roof By Footprint.

4 On the Options Bar, for Overhang, type 600 mm, and verify that Defines slope is selected.

5 On the Draw panel, verify that  (Pick Walls) is selected.

Using the Pick Walls option allows you to use the existing walls as a guide to create the roof
geometry.

6 Click the upper and lower horizontal pavilion walls so that the offset is to the outside.

7 On the Options Bar, clear Defines slope, and for Overhang, type 300 mm.

You change the overhang value for the gable end edge.

8 Click the right vertical wall of the pavilion so the overhang is to the right.
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9 Click Create Roof Footprint tab ➤ Draw panel ➤  (Line).

Use the Line option for the last edge closing the loop. The wall at this location is longer than
required. Using the Lines option instead of the Pick Walls option avoids the need to trim the
lines to close the loop.

10 Click the left endpoint of the top line, move the cursor down, and click the left endpoint of the
bottom line to close the boundary.

11 Click Modify.

Change the roof slope

12 Select the top horizontal edge line, select the slope dimension, type -20, and press Enter.

A negative slope is defined to the edges, creating a butterfly shape.

13 Using the previous method, change the slope for the bottom boundary line.

14 Click Create Roof Footprint tab ➤ Roof panel ➤ Finish Roof.
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15 In the prompt dialog, click No.

You do not attach the walls to the roof now because the long wall from the main building is in
the selection set. At this point, there is no way to deselect a specific wall. You attach the walls
of the pavilion to the roof manually in later steps.

Open a 3D view

16 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Default 3D, and zoom in to the butterfly
roof.

Attach the walls to the roof

17 Select the 3 curtain walls for the pavilion.

18 Click Modify Walls tab ➤ Modify Wall panel ➤ Attach.

19 Click the roof.

20 Press Esc.

Creating a Sloped Roof | 129



21 Close the file with or without saving it.

Adding Walls
In this exercise, you add interior walls to one wing of the entry level. You can apply the same concepts you
use to lay out this section of the building to the overall interior building design. (For this exercise, you only
work with one section of the building.)

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_BBE_05_Add_Walls_m.rvt.

Lay out the corridor walls

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.

You lay out the major corridor walls of the building. You use the exterior walls as a guide and
an offset value to place the main corridor wall.
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3 Click Place Wall tab ➤ Element panel ➤ Type Selector drop-down, and select Interior - 138mm
Partition (1-hr).

The exact wall construction has not been determined. However, the generic wall will resemble
the final wall construction. After the wall construction is decided, the wall type can be changed
to a more accurate wall type.

4 On the Options Bar, for Location Line, select Finish Face: Exterior.

5 On the Options Bar, for Offset, type 8350, and press Enter.

The offset value is the measurement from the exterior wall to the location of the new corridor.

6 Starting in the upper right corner of the exterior wall, click to snap to the endpoint.

You use the endpoint snaps at the exterior walls when laying out the corridor wall. Use the
Zoom and Pan tools to highlight the endpoints as necessary.

7 Moving counter-clockwise, click the following endpoints in the exterior wall:

NOTE You need to select the points in a counter-clockwise movement because the offset value is
positive and you want to position the corridor inside of the building.

■ Upper left corner.

■ Lower left corner.

■ Lower right corner.

8 Click Modify.
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Lay out the interior walls

9 Zoom in to the shorter wing of the building to place walls for an interior layout.

10 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.

11 On the Options Bar:

■ For Location Line, select Wall Centerline.

■ Clear Chain.
When you draw with the Chain option selected, line segments are connected (chained) so
that the last point on the previous line becomes the first point on the next line. In this case,
you clear the Chain option because you want to draw individual walls.

■ For Offset, verify 0.0.

12 Create 4 vertical walls from the exterior wall to the corridor, as shown:

(Exact placement is not important because the wall positions will be adjusted in the next steps.)

■ To the right of grid line 3.

■ To the left of grid line 4.

■ To the left of grid line 5.

■ To the left of grid line 6.

13 Click Modify.

14 Select the first vertical wall on the left.

15 Click the left witness line control for the temporary dimension, and drag it to the left to align
it to grid line 3.

132 | Chapter 8   Adding Basic Building Elements



16 Click the left temporary dimension, type 1575, and press Enter.

17 Using the previous method, and working from left to right, adjust the other 3 wall positions
(walls 2 - 4). Select each wall, and modify the left temporary dimension. Refer to the following
table for dimension values:

DimensionWall (from left to right)

39602

60203

60204
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18 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall, and place additional walls. (Exact
placement is not important.)

Add walls to create an entry

19 With the Place Wall tab still active, in the Type Selector, select Generic - 200 mm.

20 On the Options Bar, for Location Line, select Finish Face: Interior.

You use the interior finish face for the location line of the wall because it is the most logical
placement of the wall in relationship to the other walls.

21 For Height, select 02 - Floor.

Specify the height to go to the second floor level.

22 Draw a horizontal wall from the upper left corner of the corridor to the external wall on the left
to create a larger room.

You may need to zoom in to select the endpoint of the interior face of the wall.
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23 Click Modify.

24 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.

25 On the Options Bar, for Location Line, select Finish Face: Exterior, and for Offset, type 610 mm.

You use an existing grid line as a layout tool for the wall and specify an offset for placement.

26 Draw a horizontal wall from the corridor to the left external wall along grid line E, placing the
wall below the grid line.

27 Click Modify.

Add a wall opening

28 Click Modify tab ➤ Edit Geometry panel ➤ Openings drop-down ➤ Wall Opening.

To meet the design requirements, you add a wall opening to the external wall between grid lines
B and E that extends to the second level.

29 Click the left exterior wall.

30 Click the lower face of the horizontal wall near grid line B, and click the upper face of the wall
near grid line E.
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NOTE Use the Align tool on the Edit panel to align the edges of the opening with the adjacent walls.

31 Click Modify.

32 Select the opening, and on the Element panel, click Element Properties drop-down ➤ Instance
Properties.

NOTE Even though the opening is not visible, when you place the cursor near the opening, the
element highlights and can be selected.

33 Specify options in the Instance Properties dialog:

■ For Top Constraint, select Up to level: 02 - Floor.

■ For Top Offset, type 0.

■ For Unconnected Height, verify 3800 mm.

■ Click OK.

Add a curtain wall

34 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.

35 On the Element panel, in the Type Selector, select Curtain Wall.

You add a curtain wall for the vestibule wall. You use the existing corridor wall and the offset
option as a layout guide.
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36 On the Options Bar, for Offset, type 2500 mm.

37 Click the lower endpoint of the opening at the corridor.

NOTE You must draw from the bottom up because the offset value is positive. If necessary, zoom in
to select the endpoint.

38 Click the top endpoint of the opening to place the wall to the left of the corridor.

39 Click Modify.
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40 Close the file with or without saving it.

Placing Windows and Doors
In this exercise, you add windows and doors to the layout created in the previous steps. You load a door
family into the project and place instances of this family in the building.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_BBE_06_Doors_Windows_m.rvt.

Add windows

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Click Home tab ➤ Build panel ➤ Window.

3 On the Element panel, in the Type Selector, select 0915 x 1220 mm.

4 On the Options Bar, clear Tag on Placement.

Tags can be added automatically when the object is placed; however, for this exercise, place the
windows without tags.

5 Place 6 windows in the upper external wall of the short wing between grid lines 3 and 5, as
shown (exact placement is not important).

NOTE As you place the window, the exterior side of the window is placed on the side of the wall
nearest to the cursor at the time of placement.
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6 Click Modify.

Dimension and constrain the windows

7 Click Annotate tab ➤ Dimension panel ➤ Aligned.

You use the dimension tool to position the window elements equally.

8 For the windows in the left room, click the left wall, then the center of the 2 windows, then the
right wall, and click to place the dimension.

9 Click EQ to equalize the dimensions.

The EQ symbol represents an equality constraint element applied to the references for this
dimension. The references (walls and windows in this case) remain at equal distances from one
another while this constraint is active. For example, if you select one of the windows and move
it, all of the windows move together at a fixed distance.
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10 Using the previous method, dimension and equalize the 4 windows in the room to the right.

11 Click Modify.

12 Select the dimension strings, and press Delete.

13 In the warning dialog, click OK to keep the constraints applied to the window positions.

You can delete the dimension string, but retain the constraints. If you select Unconstrain in the
warning dialog, the windows will remain in the current positions, but will not be equally
constrained.

Add doors

14 Click Home tab ➤ Build panel ➤ Door.

15 On the Element panel, in the Type Selector, under M_Single-Flush, select 0915 x 2134mm.

16 Place 9 doors, as shown.

NOTE The opening direction for the door is determined by which side of the wall the cursor is closest
to at the time of placement. The hinge side of the door can be flipped by pressing the Spacebar
during placement.

If the door was placed incorrectly, the door can be flipped (both opening direction and hinge
side) by using the flip controls that display when the door is selected.
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17 Click Modify.

Load a door family

18 Click Home tab ➤ Build panel ➤ Door.

19 Click Place Door tab ➤ Model panel ➤ Load Family.

You load a new door family that is not in the project. You can then change an existing door to
use the new door family style.

20 In the left pane of the Load Family dialog, click Training Files, and open
Metric\Families\M_Double-Flush.rfa.

21 Click Modify.

Change an existing door

22 Select the second door from the left that opens into the corridor.

23 On the Element panel, in the Type Selector, under M_Double-Flush, select 1830 x 2134mm.

You change the selected door to use the double door family.

24 Close the warning that displays.

You ignore the warning because you will adjust the door position in the next step.

25 Select the upper-left temporary dimension, type 1220, and press Enter.
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26 Press Esc.

27 Close the file with or without saving it.

Adding Ceilings
In this exercise, you add ceilings. Again, the work is focused on the entry level of the short wing of the
building. You can add ceilings by automatic detection of boundaries or by drawing the boundary. You use
both methods in this exercise.

The process of creating and modifying a ceiling is similar to the process you used to create a roof type in a
previous exercise.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_BBE_07_Add_Ceilings_m.rvt.

Place a ceiling by boundary selection

1 In the Project Browser, under Ceiling Plans, double-click 01 - Entry Level.

2 Click Home tab ➤ Build panel ➤ Ceiling.
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3 Click Place Ceiling tab ➤ Element panel ➤ Type Selector drop-down, and select 600 x 600mm
Grid.

NOTE There are 2 types of ceilings: Basic and Compound. Use Basic ceilings only for pattern since
they have no depth. They are represented in section as a single line. Compound ceilings have
construction layers similar to floors, roofs, and walls.

4 Click to place ceiling objects in the 4 rooms in the shorter wing, as shown.

Notice that when you place the ceiling, the boundary is automatically detected and highlighted,
and grids are centered in the space.

5 In the Type Selector, select Plain.

6 Click in the 2 rooms to the left of grid line 4 to place additional ceilings, as shown:

Notice that this ceiling type does not have a grid pattern.
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Create a ceiling by drawing a boundary

7 In the Type Selector, select 600 x 600mm Grid.

You create a cloud ceiling in the large room in the upper left corner.

8 Click Place Ceiling tab ➤ Ceiling panel ➤ Sketch Ceiling.

For part of the boundary, you use existing walls as a layout tool. You use the Pick Lines option
and define an offset for the line.

9 Click Create Ceiling Boundary tab ➤ Draw panel ➤  (Pick Lines).

10 On the Options Bar, for Offset, type 915 mm.

11 Click the upper horizontal wall so the boundary line is positioned inside the room.

12 Using the previous method, select the right vertical, and lower horizontal walls.

13 On the Edit panel, click Trim, and use the Trim tool to clean up the overhanging edges.
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14 On the Draw panel, click Boundary Line, and click  (Arc passing through three points).

You create an arc segment to close the boundary on the left side.

15 Select 3 points to create the arc segment:

■ Click to specify the first point of the arc close to the midpoint between grid line 1 and 1.1
on the upper edge line. (Exact placement is not important.)

■ Move the cursor down, and click to position the second point at the lower ceiling line.

■ Click to specify the third point, which is the intermediate point, to define the arc on the
left. (The radius drawn at this point is not important. The line snaps to the point where the
arc is 180 degrees.)

16 Use the Trim tool to clean up the boundary and close the loop.

17 Click Create Ceiling Boundary tab ➤ Ceiling panel ➤ Finish Ceiling.

18 Press Esc.

Modify the ceiling grids

19 Select a vertical grid line in the large ceiling.

20 Click Modify Ceilings tab ➤ Modify panel ➤ Rotate.
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You can modify grid lines of ceilings using the Move and Rotate tools. The entire grid of the
ceiling responds to any modifications made to 1 line. In this case, you rotate the grid.

21 Click vertically above the ceiling.

22 Click to the left to specify the angle for rotation. (The exact angle is not important.)

23 Press Esc.

24 Close the file with or without saving it.
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Exporting a Revit
Architecture Building
Model to Green Building
Studio

Using the Autodesk® Green Building Studio® web-based energy analysis service, you can evaluate how alternative design
schemes impact energy consumption, and improve a project’s economic and environmental performance early in the
design process.

In this lesson, you learn how to prepare a building model in Revit Architecture to achieve the best results when exporting
the model to a gbXML file for analysis in Green Building Studio. You learn to:

■ Specify settings to provide required information on the building model for export to a gbXML file.

■ Modify building model geometry to create an accurate analytical model.

■ Visually audit the analytical model for potential problems before exporting to gbXML.

Simple building model used for exporting to gbXML

9

147



View of analytical surfaces before export

Best practices for creating the model

■ Keep the Revit Architecture model as simple as possible. A simple model allows you to compare forms, gross amounts
of glazing, orientation, and shading. Testing many design alternatives early in the design can provide critical decision
making information. Green Building Studio only requires surfaces, openings, and rooms to simulate the building.

■ Only model major spaces and combine smaller spaces that represent key programmatic requirements of the project,
such as office space or service cores. Do no include all interior partitions that will eventually be part of the final building.

■ Model floors, ceilings, and roofs, in addition to walls and windows. These are essential items when it comes to whole
building energy analysis.

■ Model the windows and skylights that are possibilities. Glazed areas contribute the most to energy use.

■ Connect all walls, roofs, slabs, and ceilings. Be sure that the walls connect to each other as well as to their respective
slabs, ceilings, and roofs. Do not leave gaps in the model because they can cause surfaces in the analytical model to
be assigned incorrect properties.

NOTE Only metric training files are provided for this lesson. The procedures and concepts presented in this lesson
are not dependent on project units or specific building content.

Specifying Settings for Exporting to gbXML
In this exercise, you modify project settings to prepare the building model for export to a gbXML file. You
specify the following information:

■ Project location to provide weather and climate data.

■ Building type and ground plane information to provide data on energy use.

■ Room volume calculations to provide data required to generate the analytical model.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_GBS_01_Setup_m.rvt.
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Specify the project location

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Click Manage tab ➤ Project Location panel ➤ Location.

First, you establish the location of the Revit Architecture project. This information is saved in
the gbXML file and helps the analysis package determine weather and climate data for the
exported model.

3 On the Place tab of the Manage Place and Locations dialog:

■ For City, select Manchester, NH.
When you type in the City field, the auto-complete feature helps you quickly select a city
from the prepopulated list. If a city close to the location of the project is not included in the
list, you can specify longitude and latitude values for the project.

■ Select Automatically adjust clock for daylight savings changes.

■ Click OK.

Specify the energy data for the building

4 Click Manage tab ➤ Project Settings panel ➤ Project Information.

Specify additional energy data for the project. This information establishes defaults for the
energy use of the building in the gbXML model, as well as other settings used when the analytical
gbXML model is created.

5 In the Instance Properties dialog, under Energy Analysis, for Energy Data, click Edit.

6 In the Type Properties dialog:

■ For Building Type, select School or University.
Specify the building type to establish building use patterns and typical operation settings.
The building type choices are preset in Revit Architecture and cannot be edited. Select the
use that most closely matches the building type. In the analysis application, you can modify
the defaults to more closely match the specific building.

■ For Postal Code, type 03104.
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The Postal Code provides information about typical weather conditions at the building
location to the gbXML file. Again, this value can be modified in the analysis software if the
default values are not as needed.

■ For Ground Plane, select 01 - Entry Level.
The gbXML file calculates subterranean spaces and at grade conditions based on the ground
plane specification.

7 Click OK twice.

Switch on room volume calculations

8 Click Home tab ➤ Room & Area panel ➤ Room & Area drop-down ➤ Area and Volume
Computations.

The room volumes must be calculated in order for the gbXML file to generate an analytical
model from the Revit Architecture geometry.

9 In the Area and Volume Computations dialog:

■ Under Volume Computations, select Areas and Volumes.
Having this setting enabled while working with the Revit Architecture model can affect
performance. Select the Areas and Volumes computation for exporting, and then switch it
off if room volume information is no longer needed.

■ Optionally, under Room Area Computation, select At wall center.
This setting allows for better visualization of the room volumes in plan and section views.
If volume calculation to a different location is important, this step is not critical. The analytical
model will be calculated at wall center regardless of this setting. This is for visualization
purposes only.

■ Click OK.

10 Close the warning message dialog.

Because the rooms were laid out without consideration to volumes, error conditions may result.
In another exercise, you correct these conditions because they will cause errors in the gbXML
file during export.

11 Close the file with or without saving it.

Modifying the Geometry
In this exercise, you modify the geometry of the Revit Architecture building model in order to provide a
good analytical model to export to gbXML.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_GBS_02_Geometry_m.rvt.

Specify the room height

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

You must set the rooms in the model so they do not overlap one another and so that they
establish adjacent surfaces for the analytical model. Select all of the objects on the first level,
and filter the selection to only include rooms.

2 Draw a selection window around the floor plan to select all of the rooms.
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3 Click Multi-Select tab ➤ Filter panel ➤ Filter.

4 In the Filter dialog, click Check None.

5 Under Category, select Rooms, and click OK.

6 Click Multi-Select tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance Properties.
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7 In the Instance Properties dialog, for Upper Limit, select 02 - Floor.

Set the properties of the rooms so that the height is determined by the level above. This ensures
that the room boundary is defined by the floor above and the ceiling is fully enclosed in the
room object. If the top of the space does not go to the floor above, gaps in the analytical model
are created between the floors. These gaps are interpreted in the analytical model as exterior
space.

In the analytical model, a surface is determined to be interior or exterior based on space adjacency.

■ If rooms are found on both sides of the surface, it is considered interior.

■ If a room is found on only one side of a surface, it is considered exterior.

■ If a room is not found on either side of a room bounding object, it is considered a shading
surface.

8 For Limit Offset, type 0.

9 Click OK.

10 In the Project Browser, under Floor Plans, double-click 02 - Floor.

11 Using the previous method:

■ Draw a selection window to select the floor plan.

■ Filter out everything except Rooms.

■ Specify Instance Properties:

■ For Upper Limit, select 03 - Floor.

■ For Limit Offset, type 0.

NOTE If you originally created rooms with the above properties specified, this step is not necessary.
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12 Open the 03 - Floor plan view.

13 Using the previous method:

■ Draw a selection window to select the floor plan.

■ Filter out everything except Rooms.

■ Specify Instance Properties:

■ For Upper Limit, select Roof.

■ For Limit Offset, type 4000.

A Limit Offset that extends beyond the highest point of the roof is required on the top floor to
establish the roof as a roof surface in the analytical model. Specifying the Limit Offset value for
the rooms on the top floor extends their boundary past the roof objects. This is important to
establishing the roof as a roof object in the analytical model.

Verify that rooms are enclosed

14 Open the Section 1 view.

It is a good idea to verify that rooms are enclosed and bound in multiple section views. It is
possible that the room appears enclosed in a plan view, but may have issues in a section view.

15 Zoom to fit the view in the window.
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16 In the Project Browser, under Sections (Building Section), right-click Section 1, and click
Properties.

17 In the Instance Properties dialog, for Visibility/Graphics Overrides, click Edit.

18 In the Visibility/Graphic Overrides for Section: Section 1, expand Rooms, and select:

■ Color Fill.

■ Interior Fill.

■ Reference.

Switch on the interior fill and reference mark so you can visually inspect the rooms for enclosure
in a section view.

19 Click OK twice.

All of the rooms are enclosed, as expected. For some rooms, the ceiling is set to room bounding,
preventing it from extending to the floor above. When exporting to gbXML, the space between
a ceiling and the floor above is considered an unconditioned plenum space if the space is less
than 2m. If the plenum space is greater than 2m or intended to be conditioned, set the ceiling
as non-room bounding, or add a room to account for the plenum space.

TIP If your model includes ceilings, consider selecting all of the ceiling objects using a filter, and
setting the objects to non-room bounding to ensure the best results.

20 In the drawing area, select one of the spaces in the upper floor.

Verify that the top offset is placed beyond any roof objects. This ensures that the roof will be
generated correctly in the gbXML file. In this case, you can see the color fill of the room going
into the skylight objects.

Modify a double-height room

21 Open the Section 2 view, and select the 02 - Floor level room.

This section of the building includes a double-height room (pavilion). This space is unique
because it has an overhang (second level balcony) protruding into it. If the space on the first
level is extended up past the roof, the protruding object would produce a gap and exterior
surfaces in the analytical model. Because of this condition, a separate space must be defined at
the second level. Modify the room on the second level so that the roof over the pavilion is
calculated as a roof.
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22 Click and drag the top control above the roof of the pavilion (not above roof level), as shown.

Dragging this control up changes the upper limit offset of the room.

23 Open the 01 - Entry Level floor plan view.

24 In the Project Browser, right-click 01 - Entry Level, and click Properties.

25 In the Instance Properties dialog, for Visibility/Graphics Overrides, click Edit.

26 In the Visibility/Graphic Overrides for Floor Plan: 01 - Entry Level, expand Rooms, and select:

■ Color Fill.

■ Interior Fill.

■ Reference.

Switch on room fill and reference makers to verify that all rooms are enclosed properly.

NOTE In this model, rooms are defined at the programmatic/use level. This level of room definition
in the analysis model is adequate for Green Building Studio analysis and makes it easier to test
modifications and design alternatives in Green Building Studio.

27 Click OK twice.
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Specify sliver space tolerance value

28 Zoom in to the middle of the longer wing of the building.

Some areas in a building model are not typically assigned a room object, for example, the chase
wall and elevator shaft in this example. The analytical model uses space adjacency to determine
exterior walls. Small unfilled spaces such as these can cause the analytical model to assign exterior
wall faces to the adjacent rooms. Specify settings in the energy data for the project to resolve
these issues.

29 Click Manage tab ➤ Project Settings panel ➤ Project Information.

30 In the Instance Properties dialog, for Energy Data, click Edit.

31 In the Type Properties dialog, for Sliver Space Tolerance, type 600.

The Sliver Space Tolerance field can be used to have small spaces (smaller than the sliver space
tolerance) ignored when the gbXML model is created. Increasing this value to 600mm will allow
the chase walls in the project to be ignored.

32 For Export Complexity, verify that Simple with Shading Surfaces is selected.

With this option selected, shaded values are calculated in the gbXML model.
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33 Click OK twice.

Place a room in the elevator shaft

The Sliver Space Tolerance value may not encompass all of the small spaces in the project. In this case, you
still need to add a room to the elevator shaft to remove the void area within the analytical model.

34 Click Home tab ➤ Room & Area panel ➤ Room drop-down ➤ Room.

35 On the Options Bar, clear Tag on placement, and for Upper Limit, select Roof.

36 Click in the elevator shaft space to place the room.

37 Click Modify.

Verify shading devices in the model

38 On the Quick Access toolbar, click  (3D View).

When shading is important to the energy modeling of the building, it is important to model
the shading devices with a family that can be room bounding. Typically, this means that shading
devices need to be modeled as floors, ceilings, or roofs. These families, when placed without
adjacent spaces, are considered shading surfaces. Verify that the shading devices in the model
are created correctly.

39 In the drawing area, select one of the horizontal planes on the exterior of the building.

Notice in the Status Bar that the object is a floor family. In the Type Selector, notice that this
shading device was modeled with a floor object and it will be calculated as a shading device.

NOTE The support condition for this shade is not modeled because the scale and size of the support
would not significantly impact the analysis.
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40 Press Esc.

Specify non-room bounding for columns

41 Open the 01 - Entry Level plan view, and zoom in to view the columns.

42 Select a column.

Column objects can be room bounding. When creating an analytical model, setting columns
to room bounding will result in many gaps in the analytical model. The gaps caused by the
columns will create many false exterior surfaces. These false exterior surfaces cause errors in
calculation, as well as increase the processing time. Therefore, it is a good practice to specify all
columns in the model as non-room bounding for export to gbXML.

43 Click Modify Structural Columns tab ➤ Element panel ➤ Element Properties
drop-down ➤ Instance Properties.

44 In the Instance Properties dialog, under Constraints, clear Room Bounding, and click OK.

45 With the column selected, right-click, and click Select All Instances.

46 Click Modify Structural Columns tab ➤ Element panel ➤ Element Properties
drop-down ➤ Instance Properties.

47 In the Instance Properties dialog, under Constraints, clear Room Bounding, and click OK.

IMPORTANT Remember to switch on the room bounding property for the columns after the gbXML
export process is complete to ensure the correct area calculations for rooms.
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Create exterior slab

The floor slabs in the model are placed generically. By default, floors are assumed to be interior objects. To
ensure the best results during analysis, you should specifically define floor objects as exterior, as required.

48 Open the Section 1 view.

49 Select the entry level floor object. (Check the Status bar to make sure you select the floor and
not the topography.)

50 Click Modify Floors tab ➤ Element panel ➤ Element Properties drop-down ➤ Type Properties.

51 In the Type Properties dialog, click Duplicate.

52 In the Name dialog, enter Generic 150mm - Exterior, and click OK.

53 In the Type Properties dialog, under Construction, for Function, select Exterior, and click OK.

The building model is prepared for export to gbXML or for upload to Green Building Studio.

Export to gbXML

54 Click  ➤ Export ➤ gbXML.

In the Export gbXML dialog, you can visually audit the analytical model for potential problems
before exporting to gbXML.
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55 In the Export gbXML dialog, click the Details tab, and select Analytical Surfaces.

On the Details tab, you can inspect both rooms and analytical surfaces.

56 Click Export.

57 In the Export gbXML save dialog, click Save.

The resulting gbXML file can then be imported into an analytical software package, such as
Autodesk Green Building Studio.

58 Close the file with or without saving it.
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Adding Stairs and Railings

In this lesson, you add stair and railing objects to the basic building layout. You learn to create a:

■ Multi-story straight stair.

■ Multi-story U-shaped stair.

■ Family type for wall-mounted railings, and apply this type to the U-shaped stair.

■ Guardrail for the balcony over the pavilion.

Adding a Straight Stair
In this exercise, you add a straight run stair to the project. You then modify it, creating a multi-story stair
by adding a stair from the second to the third floor.

10
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_SR_01_Straight_Stair_m.rvt.

Create the stair

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Zoom in to the opening in the lower area of the main concourse.

The dashed lines represent the opening in the floor above for the stairs.

3 Click Home tab ➤ Circulation panel ➤ Stairs.

4 Click Create Stairs Sketch tab ➤ Element panel ➤ Stairs Properties.

You verify that the correct stair family type is selected, and then specify the stair width.

5 Specify parameters in the Instance Properties dialog:

■ For Type, verify that 150mm max riser 300mm tread is selected.

■ Under Dimensions, for Width, type 1625mm.

■ Click OK.

6 On the Draw panel, verify that Run is selected.
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When you use the Run option, the risers are drawn according to the calculation rules in the
stair type properties. Because you are not yet sure how long the stair should be, you draw the
stair at a distance from the opening, and then move it into the correct position.

7 Click to the right of the opening to specify the start point for the stair.

As you draw the run, the dynamic indicator displays the number of risers created and the number
remaining.

8 Move the cursor up to draw 13 risers, and click to specify the endpoint of the stair.

You end the stair so you can create a landing.

9 Move the cursor up until the second guide (horizontal dashed line) displays, and click to begin
the second flight of stairs.

When creating landings, guides help you place the stair run. In this example, you create a landing
the same length as the width of the stair.

10 Move the cursor up until 1 riser is remaining, and click to end the second flight.

You end the flight at this point so that it meets the edge of the floor above. In this example,
the floor edge will be used and will count as the final riser.
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11 Click Modify.

12 Draw a selection box around the stair.

You select the stair and move it into position in the center of the floor opening.

13 Click Create Stairs Sketch tab ➤ Modify panel ➤ Move.

14 Select the top center endpoint of the second flight of stairs.

15 Select the midpoint of the top of the opening to reposition the stair.
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16 Press Esc.

17 Click Create Stairs Sketch tab ➤ Stairs panel ➤ Finish Stairs.

18 Close the warning that displays. (The floor edge will count as the final riser.)

Create a section view

19 Click View tab ➤ Create panel ➤ Section.

20 Click above the stair (at the horizontal midpoint of the stair) to specify the section start point,
and click below the stair to specify the endpoint.
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21 Press Esc.

22 Double-click the section head (at the top of the section line) to open the section view.

Modify the stair object to reach the third floor

23 Select the stair.

24 Click Modify Stairs tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance Properties.

25 In the Instance Properties dialog, for Multistory Top Level, select 03 - Floor, and click OK.

By making a stair multi-story, the geometry of the stair is duplicated as needed to reach the
specified floor.
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26 Press Esc.

27 Close the file with or without saving it.

Adding a U-Shaped Stair
In this exercise, you add a U-shaped stair to the project at one of the stair tower locations. You modify the
stair from single- to multi-story, and extend it to the third floor.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_SR_02_U_Stair_m.rvt.

Place the stair

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Zoom in to the stair tower area at the right end of the longer wing of the building.

3 Click Home tab ➤ Circulation panel ➤ Stairs.

4 Click Create Stairs Sketch tab ➤ Element panel ➤ Stairs Properties.

5 Specify values in the Instance Properties dialog:

■ For Type, select 150mm max riser 300mm tread.

■ For Multistory Top Level, select 03 - Floor.
You create the stair up to the third floor.

■ Under Dimensions, for Width, type 1140mm.

■ Click OK.
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6 Using the reference planes as a guide, place the stair:

■ Press Tab to highlight the upper-left endpoint of the left reference plane, and click to specify
the first point of the stair run.

■ Move the cursor down, and click the bottom endpoint of the left reference plane.

The first flight of stairs is placed.

■ Using the previous method, and starting at the bottom of the right reference plane, place
the second flight of stairs.
Notice that the landing is automatically created, forming a U-shaped stair.

The stair ends with 1 riser remaining because the last riser is the floor edge.
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7 Click Create Stairs Sketch tab ➤ Stairs panel ➤ Finish Stairs.

8 Close the warning that displays.

Create a section view

9 Click View tab ➤ Create panel ➤ Section.

10 Click above the left flight of stairs (at the horizontal midpoint of the flight) to specify the section
start point, and click below the stair to specify the endpoint.
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11 Press Esc.

12 Double-click the section head (at the top of the section line) to open the section view.

13 Close the file with or without saving it.

Modifying Railings
In this exercise, you change the handrails used for the stairs throughout the project to a different type. You
create a family type used for wall-mounted railings and apply it to the U-shaped stair.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_SR_03_Modify_Railing_m.rvt.

Create a wall-mounted handrail type

1 With the section view for the U-shaped stair (Section 2) open, select a railing.

2 Right-click, and click Select All Instances to select all railings of the same type in the entire
project (not just this view).

3 Click Modify Railings tab ➤ Element panel ➤ Type Selector drop-down, and select 900mm Pipe.

4 Click in the drawing area to clear the selection.
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5 Select the handrail at the landing of the stair.

You change the structure of this handrail into a type that is wall-mounted. Handrail extensions
will also be added to the wall-mounted handrail type.

6 On the Element panel, click Element Properties drop-down ➤ Type Properties.

7 In the Type Properties dialog, click Duplicate.

NOTE By duplicating an existing type of an object, you can create variations of family types.
Duplicating a type similar to what you need can give you a headstart in creating family types.

8 In the Name dialog, type Handrail - Pipe Wall Mounted, and click OK.

9 In the Type Properties dialog, for Rail Structure, click Edit.

You delete the unnecessary rails from the new wall-mounted handrail type, leaving only the
single handrail.

10 In the Edit Rails dialog, select Rail 2, and click Delete.

11 Using the previous method, delete all rails except Rail 1.

12 Click OK twice.
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13 Press Esc.

Load baluster families

14 Click Insert tab ➤ Load from Library panel ➤ Load Family.

You replace the vertical balusters of the railing type with wall brackets and handrail extensions.
You load these baluster families into the project to use in the railing type.

15 In the left pane of the Load Family dialog, click Training Files, and navigate to Metric\Families.

16 Open the following families:

■ Handrail - Bracket.rfa

■ Handrail - Round w Extension - End.rfa

■ Handrail - Round w Extension - Start-Offset.rfa

NOTE While pressing Ctrl, select all 3 families, and load them at the same time.

Replace baluster and post types

17 Select the handrail at the landing of the stair.

18 On the Element panel, click Element Properties drop-down ➤ Type Properties.

19 In the Type Properties dialog, for Baluster Placement, click Edit.

20 Specify types in the Edit Baluster Placement dialog:

■ In the Main pattern section, for the Regular baluster, Baluster Family, select Handrail - Bracket
: Handrail - Bracket.
The vertical post used through the main body of the rail is replaced with a handrail bracket.

■ In the Posts section, for the Start Post Baluster Family, select Handrail - Round w Extension
- Start-Offset : 1 1/2'' Handrail.

■ For the Corner Post Baluster Family, select Handrail - Bracket - Handrail - Bracket.

■ For the End Post Baluster Family, select Handrail - Round w Extension - End : 1 1/2'' Handrail.

The posts placed at the beginning, end, and corners of the railings are replaced with the respective
families that you loaded into the project in the previous steps.

21 Click OK twice.
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Edit the railing

22 In the Project Browser, under Floor Plans, double-click 01 - Entry Level, and zoom in to the stair
in the longer wing.

You do not need to run the railing running along the wall around the landing of the stair. Edit
the railing so each flight has a single wall-mounted rail.

23 Select the outside railing, and click Modify Railings tab ➤ Edit panel ➤ Edit Path.

24 While pressing Ctrl, select the railing segments on the landing and the left stair flight, and press
Delete.

Railings must be drawn as a single line; therefore, they cannot be placed as broken segments.
You create the rail on the left flight of stairs as a separate railing object.

25 Click Modify Railings tab ➤ Railing panel ➤ Finish Railing.

Add a railing to the left stair

26 Click Home tab ➤ Circulation panel ➤ Railing.

27 Select the upper left endpoint of the left stair, and select the lower left endpoint of the stair.

NOTE When selecting the endpoints, make sure to click the interior stringer edge; otherwise, the
railing will be created in the wall.
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28 Click Create Railing Path tab ➤ Tools panel ➤ Set Railing Host.

You must specify the stair object as the railing host to place the railing at the correct angle on
the wall.

29 Select the stair.

30 Click Create Railing Path tab ➤ Element panel ➤ Railing Properties.

31 In the Instance Properties dialog, for Type, select Handrail - Pipe Wall Mounted, and click OK.

32 Click Create Railing Path tab ➤ Railing panel ➤  Finish Railing.

View the railing

33 Select the section.

34 Click the Flip Section control.

176 | Chapter 10   Adding Stairs and Railings



35 Press Esc.

36 Double-click the section head.

37 Close the file with or without saving it.

Placing Railings
In this exercise, you place a guardrail on the balcony at the pavilion overlook. You can place railings
independently of a stair.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_SR_04_Place_Railing_m.rvt.

Create a stair

1 In the Project Browser, under Floor Plans, double-click 02 - Floor, and zoom in to the balcony
near the center of the building.

2 Click Home tab ➤ Circulation panel ➤ Railing.

3 Click Create Railing Path tab ➤ Element panel ➤ Railing Properties.

4 In the Instance Properties dialog, for Type, select Guardrail - Pipe, and click OK.

5 Click Create Railing Path tab ➤ Draw panel ➤  (Pick Lines).

6 On the Options Bar, for Offset, type 100mm.

You use the floor slab edge as the basis for the geometry of the railing.

7 Click the 3 balcony floor edges so the offset is to the inside.

NOTE To avoid having to trim the drawing, make sure you select the floor edge for the vertical lines
rather than the curtain wall.
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8 Click Create Railing Path tab ➤ Railing panel ➤ Finish Railing.

9 Press Esc.

Create a 3D view

10 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Camera.

Place a camera to see the railing that has been placed in a 3D view.

11 Click to place the eye position, and click to place the view target, as shown.

12 Press Esc, and view the railing in the 3D view.
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13 Close the file with or without saving it.
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Adding Other Design
Elements

In this lesson, you add objects and design elements to the basic building layout. You learn to:

■ Create room separation lines and place rooms.

■ Define a color scheme based on area and apply it to the view.

■ Create area plans and define a schedule to analyze building use.

■ Add a furniture layout to the plan view and schedule the components.

Color scheme and color fill legend applied to the view

Placing Rooms
In this exercise, you place rooms in the project. You add room separation lines to divide the public circulation
area into 3 separate areas to allow for 3 separate rooms.

11
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_ODE_01_Place_Rooms_m.rvt.

Place rooms

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Click Home tab ➤ Room & Area panel ➤ Room drop-down ➤ Room.

3 On the Options Bar, clear Tag on placement.

Tags can be added to rooms as they are placed into the model. However, for this tutorial, you
add room tags in a separate exercise.

4 Click to place a room in the vestibule, as shown.

5 Click to the right in the public circulation area.

Because the room boundaries are determined by walls, the entire public circulation space is
detected and defined as 1 room. The design intent is to have the space divided into 3 rooms.
You use room separation lines to divide the space.
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6 On the Quick Access toolbar, click  (Undo) to remove the room in the public circulation
area.

Add room separation lines to the corridor

7 Click Home tab ➤ Room & Area panel ➤ Room drop-down ➤ Room Separation Line.

8 Add room separation lines for the corridors of each wing:

■ Click the interior corner of the corridor in the short wing, move the cursor up, and click the
wall, as shown.

■ Using the previous method, add a separation line for the corridor in the longer wing.
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Place all rooms on the entry level

9 Click Home tab ➤ Room & Area panel ➤ Room drop-down ➤ Room.

10 On the Options Bar, clear Tag on placement.

11 Click to place rooms into the model, as shown.

12 Close the file with or without saving it.

Defining an Area Color Scheme
In this exercise, you define a color scheme based on area size ranges. After applying the color scheme to the
floor plan, you add a color fill legend to the view.

Training File

■ Click  ➤ Open.
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■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_ODE_02_Color_Scheme_m.rvt.

Define a color scheme by area

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 In the Project Browser, under Floor Plans, right-click 01 - Entry Level, and click Properties.

3 In the Instance Properties dialog, for Color Scheme, click <none>.

4 In the Edit Color Scheme dialog, under Schemes, select Name.

You copy an existing color scheme and modify the scheme definition to use the Area parameter.

5 Click  (Duplicate).

6 In the New color scheme dialog, type Area, and click OK.

7 Under Scheme Definition, for Color, select Area.

8 In the informational dialog, click OK.

9 To the right of the Color field, select By range.

When first created, the color scheme is set to By value. This creates a separate color for each
value, in this case Area. You want to create this color scheme by range rather than value.

10 Define the area ranges you would like to see separated by 40 m2 increments:

■ In the second row, At Least field, type 40, and press Enter.

■ With the second row selected, click  (Add Value).
This adds another range using the40 m2 increment.

■ Using the previous method, add 40 m2 increment ranges up to 360 m2, as shown.
Select the highest value in the table before adding a new value to maintain the desired
increment.

11 Click OK twice.

The color scheme is applied to the view.
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Add a color scheme legend

12 Click Home tab ➤ Room & Area panel ➤ Legend.

13 Click in the courtyard to place the legend.

14 Zoom in to the legend.

The color fill legend has properties and shape handles you use to control the layout and size of
the legend.
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15 Close the file with or without saving it.

Creating an Area Plan
In this exercise, you create an area plan. You define the areas as Administration, Service, Circulation, and
Instruction.

After the area plans are defined, you create a schedule to analyze building use.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_ODE_03_Area_Plan_m.rvt.
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Create area plan

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Click Home tab ➤ Room & Area panel ➤ Area drop-down ➤ Area Plan.

You create an area plan for the first floor, using the Gross Building area plan type.

3 In the New Area Plan dialog, under Area Plan views, select 01 - Entry Level.

4 For Type, select Gross Building.

5 Click OK.

6 In the prompt dialog, click Yes to automatically create area boundary lines associated with
external walls.

7 If an error dialog displays, click Delete Element(s).

8 In the Project Browser, expand Area Plans (Gross Building), right-click 01 - Entry Level, and click
Properties.

You modify the visibility and graphics of the area plan to hide planting and topography.

Hide planting and topography

9 In the Instance Properties dialog, for Visibility/Graphics Overrides, click Edit.

10 In the Visibility/Graphic Overrides for Area Plan (Gross Building) dialog, clear Topography, and
clear Planting.

11 Click OK twice.
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Modify area boundaries

12 Click Modify tab ➤ Edit panel ➤ Trim.

You modify and place area boundaries so that you can place area objects. Typically, an area
boundary will contain more than one room/space.

13 Click the bottom left boundary of the upper room.

14 Click the right vertical boundary to enclose the area.

The shorter wing is now one large area.

15 Click Home tab ➤ Room & Area panel ➤ Area drop-down ➤ Area Boundary Line.

16 Zoom in to the short wing of the building.

17 On the Draw panel, click  (Line).
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18 Draw an area boundary separating the shorter wing into 2 areas, along the vertical wall, as
shown.

19 Click Modify.

20 Click Home tab ➤ Room & Area panel ➤ Area drop-down ➤ Area.

21 Click to add 2 areas in the shorter wing, as shown.

22 Click Modify.

23 Click the area tag for the area on the right and drag the tag to the center of the area.

Edit area tags

24 Click the tag, and click the text label to select the tag in the left area.

25 Type Service, and press Enter.

The names you apply to the areas will be used to create a color fill and area schedule for the
project.

26 Using the previous method, change the area tag in the right area to Administration.

Define a color fill

27 In the Project Browser, under Area Plans (Gross Building), right-click 01 - Entry Level, and click
Properties.

28 In the Instance Properties dialog, for Color Scheme, click <none>.

29 In the Edit Color Scheme dialog, under the Schemes section, select Gross Building Area, and in
the Scheme Definition section, for Color, select Name.

You define a color fill for the view where the area name is used as the parameter to assign the
color.
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30 In the informational dialog, click OK.

31 Click OK twice.

The area plan can be refined as required by the project. (For this exercise, a completed training
file has been provided where area plans are already defined.)

32 Close the file with or without saving it.

Open the completed training file

33 Open the completed training file:

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_ODE_04_Area_Plans_Complete_m.rvt.

34 Optionally, in the Project Browser, expand Area Plans (Gross Building), and open the prepared
area plans.

Create a schedule to analyze area plans

35 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.

36 In the New Schedule dialog, for Category, select Areas (Gross Building), and click OK.

37 In the Schedule Properties dialog, for Available fields, select Name, and click Add.

38 Using the previous method, add Area.

39 Specify options on the Sorting/Grouping tab:

■ Select Grand totals.

■ Clear Itemize every instance.

■ For Sort by, select Name.

40 On the Formatting tab, under Fields, select Area.

41 Under Field formatting, select Calculate totals, and click OK.

42 Close the file with or without saving it.
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Adding Furniture
In this exercise, you add furniture components to the project. The process is similar for adding any other
components to a project.

You also create a schedule to track the components added to the project.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_ODE_05_Add_Furniture_m.rvt.

Add tables and chairs

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Zoom in to the left side of the shorter wing.

3 Click Insert tab ➤ Load from Library panel ➤ Load Family.

You add a dining table and chairs to the cafeteria area. Because this family is not currently loaded
into the project, you load it from an external library.

4 In the left pane of the Load Family dialog, click Training Files, and open
Metric\Families\M_Table-Dining Round w Chairs.rfa.

5 Click Home tab ➤ Build panel ➤ Component drop-down ➤ Place a Component.

6 In the Type Selector, verify that Table-Dining Round w Chairs 0915mm Diameter is selected.
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7 Click to place an instance of the table and chairs in the upper-left corner of the cafeteria.

8 Place 2 additional tables/chairs, as shown.

9 Click Modify.

Array the tables and chairs

10 While pressing Ctrl, select the 3 table/chairs components.

11 On the Modify panel, click Array.

You use the Array command to quickly fill the room with the table layout.

12 Press Tab to highlight, and click to select the midpoint of the top table, move the cursor to the
right, and click to specify the array direction. (The exact distance is not important.)

13 Select the array number, and type 7.
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Press Enter.

Delete extra furniture

14 While pressing Ctrl, select the columns of tables 4-7, and on the Group panel, click Ungroup.

Ungroup the elements of the array to erase the unnecessary tables and chairs from the layout.

15 Press Esc.

16 While pressing Ctrl, select the bottom table in columns 4-6, and the entire column 7 of tables,
as shown.

Press Delete.
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Change the color scheme to foreground

17 In the Project Browser, under Floor Plans, right-click 01 - Entry Level, and click Properties.

18 In the Instance Properties dialog, for Color Scheme Location, select Foreground, and click OK.

The color file can be switched from background (as shown) to foreground, as required by the
project.

Create a furniture schedule

19 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.

You create a schedule to count furniture items and calculate the total cost.

20 In the New Schedule dialog, for Category, select Furniture, and click OK.

21 In the Schedule Properties dialog, specify options:

■ Under Available fields, select Family and Type, and click Add.

■ Using the previous method, add Count and Cost to the schedule.

■ On the Sorting/Grouping tab:

■ For Sort by, select Family and Type.

■ Select Grand totals.

■ Clear Itemize every instance.

■ On the Formatting tab:

■ Under Fields, select Cost.

■ Under Field formatting, select Calculate totals.
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The cost of the items is calculated as a running total.

■ Click OK.

22 Double-click the heading column dividers to expand the columns to fit the entries.

No cost information is being reported because values have not been specified for this parameter
in the family. You add a cost value for the component in the family parameters so the total cost
can be calculated.

Add cost values to the furniture families

23 In the Project Browser, Expand Families/Furniture/M_Chair-Breuer, and double-click
M_Chair-Breuer.

24 In the Type Properties dialog, for Cost, type 45, and click OK.

25 Using the previous method, for the M_Table-Dining Round w Chairs/0915mm Diameter family,
specify a cost of 300.

The schedule updates with the cost values.

26 Close the file with or without saving it.
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Refining the Building
Model

In this lesson, you make changes to the building model by adding details and exchanging component types to meet the
design requirements. You learn to:

■ Create a wall type and replace the exterior walls with the new type.

■ Define a curtain wall pattern and apply it to the curtain walls.

■ Load a door family and change the door type of existing doors in the project.

■ Create a double-door entry in the curtain wall by removing and replacing panels.

■ Add a sweep as part of the wall family used for the parapet walls.

■ Add an in-place reveal to the exterior walls.

■ Identify how to use parametric relationships to control the behavior of objects when there are changes in the model.

Double door entry in the curtain wall

12
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Sweep and reveals added to the exterior

Modifying Wall Components
You used generic placeholder elements during the initial building layout. Now, you can refine these elements
to meet design requirements. In this exercise, you create a wall type and replace the exterior walls with this
new type.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_RM_01_Modify_Wall_m.rvt.

Duplicate a wall type

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.
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3 Click Place Wall tab ➤ Element panel ➤ Type Selector drop-down, and select Exterior - Brick on
Mtl. Stud.

To make it easier to create the wall, select a wall that has a similar construction to the wall you
need to create.

4 Click Place Wall tab ➤ Element panel ➤ Element Properties drop-down ➤ Type Properties.

5 In the Type Properties dialog, click Duplicate.

6 In the Name dialog, type Exterior - Insulation on Masonry, and click OK.

Modify the wall structure

7 In the Type Properties dialog, under Construction, for Structure, click Edit.

8 Make modifications in the Edit Assembly dialog:

■ Select Layer 2 (Thermal/Air Layer [3]), and click Delete.

■ Select Layer 3 (Substrate 2), and click Delete.

■ Select Layer 1 (Finish 1 [4]), click the Material field, and click  .

■ In the Materials dialog, select Insulation/Thermal Barriers - External Wall Insulation.

■ On the Graphics tab of the Materials dialog, for Surface Pattern, click  .

■ In the Fill Patterns dialog, select Sand, and click OK.

■ In the Materials dialog, under Shading, select Use Render Appearance for Shading, and
click OK.
By modifying the fill pattern and material parameters, you change the way the wall
displays in views.

■ For Layer 1 (Finish 1 [4]), for Thickness, type 100 mm.

■ For Layer 4 (Structure [1]), click the Material field, and click  .

■ In the Materials dialog, select Masonry - Concrete Block.

■ Under Shading, select Use Render Appearance for Shading, and click OK.

■ For Layer 4 (Structure [1]), for Thickness, type 190 mm.

Modified wall structure

9 Click OK twice.

10 Click Modify.
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Change the exterior wall type

11 Zoom in to the shorter wing of the building.

12 Select the top and right exterior walls.

13 Click Modify Walls tab ➤ Element panel ➤ Type Selector drop-down, and select Exterior -
Insulation on Masonry.

14 In the error dialog, click Delete Element(s).

15 Press Esc.

16 On the View Control Bar, click Detail Level ➤ Medium.

Changing the detail level of the view displays the material layers assigned to the wall.

17 Zoom in to the right wall in the shorter wing near the corridor.

You can modify wall cleanup conditions after making changes to the wall structure. In this case,
notice that just below the door, the edge of the curtain wall no longer meets the wall edge.

Clean up wall conditions

18 Click Modify tab ➤ Edit panel ➤ Align.

19 Click the interior face of the basic wall.
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20 Click the right edge of the horizontal curtain wall.

21 In the error dialog, click Delete Element(s).

22 Click Modify.

23 Close the file with or without saving it.

In this exercise, you changed only 2 exterior walls. You could use the previous method to change all of the
walls in the project.

Defining a Curtain Wall
In this exercise, you define a pattern for the exterior curtain wall of the building. After you specify the pattern
for the curtain wall type, you apply it to all of the curtain walls. Finally, you modify the cut plane of the
view so that the vertical mullions are visible when cut.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_RM_02_Curtain_Wall_m.rvt.

Modify the curtain wall

1 With the 01 Entry Level view open, select the curtain wall at the bottom of the longer wing of
the building.

2 Click Modify Walls tab ➤ Element panel ➤ Element Properties drop-down ➤ Type Properties.

You modify the curtain wall to match the design requirements.

NOTE By modifying an existing type, all instances already placed in the model will reflect the changes.
In this case, the changes are made to all of the building curtain walls.

3 In the Type Properties dialog, click Rename.

4 In the Rename dialog, for New, type Exterior Curtain Wall, and click OK.

The new name is more specific to the project.

5 In the Type Properties dialog, for Curtain Panel, select System Panel : Glazed.

You define the default panel for all grid infills. This is only a default; you can change the panels
after they are in place.

6 For Join Condition, select Vertical Grid Continuous.

In this case, the vertical mullions will be continuous when drawn on the curtain wall.
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Define the vertical and horizontal grid pattern

7 Under Vertical Grid Pattern:

■ For Layout, select Fixed Distance.

■ For Spacing, type 2000 mm.

■ Clear Adjust for Mullion Size.

8 Under Horizontal Grid Pattern:

■ For Layout, select Fixed Distance.

■ For Spacing, type 1260 mm.

■ Clear Adjust for Mullion Size.

Define mullion types

9 Under Vertical Mullions, select Rectangular Mullion : 50 x 150mm rectangular for each of the
following types:

■ Interior Type

■ Border 1 Type

■ Border 2 Type

In this example, all mullions will be the same.

10 Under Horizontal Mullions, select the same mullion type for all of the horizontal mullions.

11 Click OK.

View the curtain wall

12 On the Quick Access toolbar, click  (3D View).

13 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

14 Zoom in to the building to view the curtain wall.
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15 In the Project Browser, under Floor Plans, double-click 01 - Entry Level, and zoom in to see the
plan representation of the curtain wall.

16 Close the file with or without saving it.

Changing Family Types
Like walls, you can exchange other content families for a different family in the same category. In this
exercise, you load a door family into the project, and then assign this type to an existing door.

If you need parameter changes for a family already loaded into the project, create a type with the parameters
you need. You create a rated door type in the project.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_RM_03_Family_Types_m.rvt.
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Load door family

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Click Home tab ➤ Build panel ➤ Door.

3 Click Place Door tab ➤ Model panel ➤ Load Family.

NOTE Some door families are shipped with Revit Architecture, but additional families can be
downloaded from resources on the Internet and also can be created by users.

4 In the left pane of the Load Family dialog, click Training Files, and open
Metric\Families\M_Single-Flush-Dbl Acting.rfa.

5 Click Modify.

6 In the upper-right corner of the cafeteria, select the door.

7 Click Place Door tab ➤ Element panel ➤ Type Selector drop-down, and under M_Single-Flush-Dbl
Acting, select 0915 x 2134 mm.

8 Press Esc.

The family graphics for the plan representation change to reflect the new door family.

Create a door type from an existing door

9 Select the door to the left of the double door, as shown.
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10 Click Place Door tab ➤ Element panel ➤ Element Properties drop-down ➤ Type Properties.

You select the door that will be assigned a new type. You create a new type when you need a
different value for one or more of the parameters associated with the door type.

11 In the Type Properties dialog, click Duplicate.

You duplicate the type to create and make changes to the parameters, as needed.

12 In the Name dialog, type 0915 x 2134mm 20 Minute Rated, and click OK.

13 In the Type Properties dialog, under Identity Data, for Fire Rating, type 20 Minute.

14 Click OK.

15 Press Esc.

The graphics for the door do not change. However, the parameters of the door change. You see
the results of this change when you create a door schedule in another exercise.

16 Close the file with or without saving it.

Adding Curtain Wall Doors
In this exercise, you modify a curtain wall to contain a door. You modify the grids and then insert a
replacement curtain panel, in this case, a double door.

206 | Chapter 12   Refining the Building Model



Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_RM_04_Curtain_Wall_Doors_m.rvt.

Create an elevation view

1 With the 01 - Entry Level floor plan open, zoom in to the area around the building entrance.

2 Click View tab ➤ Create panel ➤ Elevation drop-down ➤ Elevation.

You use the Elevation tool to create an elevation view to facilitate the modifications to the
curtain wall. In many cases, you might create additional views of the model to accomplish a
specific task and then subsequently delete them because they are not needed for documentation.

3 Click to place an elevation marker in the entrance area, as shown.

4 Click Modify.

5 Double-click the elevation marker head (arrow) to open the view.
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You create the doors in the lower curtain wall segments between grid lines C and D. First you
need to remove the mullions and curtain grid sections so the panel at this location can be
changed for a double door curtain panel family.

Remove curtain wall segments

6 Position the cursor over a horizontal curtain wall mullion in the second row from the bottom,
press Tab until the Status Bar indicates that the curtain wall grid line is highlighted, and click
to select it.

7 Click Modify Curtain Wall Grids tab ➤ Curtain Grid panel ➤ Add/Remove Segments.

Removing sections of the curtain grid at this location makes the panel 2 units high.

8 Select the 2 horizontal curtain grid segments, as shown, to remove them.

9 Press Esc.

By removing segments from a curtain wall grid, the regular pattern can be broken to accommodate
design requirements.
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Load a curtain panel family

10 Click Home tab ➤ Build panel ➤ Door.

11 Click Place Door tab ➤ Model panel ➤ Load Family.

You load the double door curtain panel family into the project so that it can be used as a
replacement for the default glass panel.

12 In the left pane of the Load Family dialog, click Training Files, and open
Metric\Families\M_Curtain Wall Dbl Glass.rfa.

13 Click Modify.

Replace the curtain panel

14 Place the cursor near the edge of the left panel, press Tab until the curtain panel on the left is
highlighted, and click to select it.

15 Click the pin.

Pinned objects cannot be modified, so you unpin the curtain panel to replace it with the double
door panel.

16 On the Element panel, in the Type Selector, select M_Curtain Wall Dbl Glass.
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17 Place the cursor near the mullion at the bottom of the double door, press Tab until the mullion
is highlighted, and click to select it.

18 Click the pin.

19 Press Delete.

20 Using the previous methods, place a double-door to the right of the one you just placed, and
delete the bottom mullion.

Copy the exterior curtain wall

21 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

The design requirements also call for a double door entry in the interior curtain wall.
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22 Select the curtain wall that you just modified (with the double doors), and on the Modify panel,
click Copy.

You copy the exterior curtain wall, delete the existing interior curtain wall, and position the
copy of the wall in the correct location. Copying the wall is easier than making the same
modifications to the interior curtain wall.

23 Click the midpoint of the exterior curtain wall to enter a start point, move the cursor to the
right, and click to place the copy.

24 Select the existing interior curtain wall, as shown (to the right of the copied wall).
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25 Press Delete.

26 Click Modify tab ➤ Edit panel ➤ Align.

27 On the Options Bar, for Prefer, select Wall centerlines.

You align the centerlines of the adjacent wall and the copy of the curtain wall.

28 Click the basic wall, as shown.
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29 Click the copy of the curtain wall.

30 Click Modify.

Glass double-doors are added to the building entrance creating a foyer.

31 Close the file with or without saving it.

Adding a Wall Sweep and Adding Reveals
In this exercise, you add a sweep and 2 reveals to the building model. You can add sweeps or reveals as part
of the wall type or you can add them in place.

Adding a Wall Sweep and Adding Reveals | 213



Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_RM_05_Wall_Sweep_m.rvt.

Edit the wall properties

1 In the Project Browser, under 3D Views, double-click {3D}.

You add a parapet cap to the wall with the sweep as part of the type definition.

2 Select a parapet wall.
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3 Click Modify Walls tab ➤ Element panel ➤ Element Properties drop-down ➤ Type Properties.

4 In the Type Properties dialog, under Construction, for Structure, click Edit.

5 In the Edit Assembly dialog, click Preview.

The sweeps and reveals button in the Edit Assembly dialog is active when you expand the preview
of the wall and specify a sectional view.

6 In the Preview area, for View, select Section: Modify type attributes.

7 In the Edit Assembly dialog, under Modify Vertical Structure, click Sweeps.

Load the profile family

8 In the Wall Sweeps dialog, click Load Profile.

The shapes of the sweeps and reveals are controlled by profile family. In this case, you load the
profile family into the project.

9 In the left pane of the Open dialog, click Training Files, and open Metric\Families\M_Metal
Parapet Cap.rfa.

Add the sweep and specify the profile

10 In the Wall Sweeps dialog, click Add.

11 In the Profile field, select M_Metal Parapet Cap : M_Metal Parapet Cap.

You can also control the material and position of the sweep.

12 Click the Material field, and click  .

13 In the Materials dialog, click Metal - Aluminum, and click OK.

14 For From, select Top.

15 Click OK 3 times to close all dialogs.

16 Press Esc.

17 Zoom in to see the sweep in more detail.

The sweep is added to the parapet wall.
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Add reveals in place

You can add sweeps or reveals in place. When you add elements in place, you can place them vertically or
horizontally.

18 In the Project Browser, under Elevations (Building Elevations), double-click South.

To make placing the reveals easier, place them in an elevation view.

19 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Reveal.

20 Click Place Reveal tab ➤ Profile panel ➤ Vertical.

21 Click grid line 3 to place the reveal just to the right of it.

22 Click Place Reveal tab ➤ Profile panel ➤ Finish Current.

23 Click Place Reveal tab ➤ Profile panel ➤ Horizontal.

You place a horizontal reveal near the level 2 marker line.

24 Select the Level 2 marker line so the reveal is placed just below the line.
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25 Click Place Reveal tab ➤ Profile panel ➤ Finish Current.

26 Click Modify.

Now, you can select the reveals and modify the endpoints, as needed.

Modify reveal endpoints

27 Select the reveal along grid line 3.

28 Select the top wall sweep endpoint, and drag it down to shorten the reveal.

29 Select the horizontal reveal along Level 2, select the right wall sweep endpoint, and drag it to
the left.
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30 Press Esc.

31 On the Quick Access toolbar, click  (3D View).

32 Close the file with or without saving it.

Adding Parametric Relationships
In this exercise, you establish parametric relationships between model objects. You can use these relationships
to control the behavior of the objects when changes are made to the model. In this case, you use constraints
to establish a relationship between doors and the adjacent wall.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_RM_06_Parametric_Relationships_m.rvt.

Align the interior wall with the curtain wall mullion

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Zoom in to the middle of the longer wing of the building.

3 Click Modify tab ➤ Edit panel ➤ Align.

4 On the Options Bar, for Prefer, select Wall centerlines.

You align the center of the interior wall between grid lines 5 and 6 with the curtain wall mullion
to the right of the interior wall.

5 Click the center of the curtain wall mullion to the right of the bottom of the interior wall (located
between grid lines 5 and 6), as shown.

6 Click the center of the interior wall, as shown.
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Now, the interior wall is aligned. However, it intersects the door in the corridor wall.

7 Close the warning message dialog.

8 Click Modify.

9 On the Quick Access toolbar, click  (Undo).

To resolve this problem, you establish a parametric relationship between the doors and the
adjacent wall. First, you dimension from the centerline of the door to the centerline of the wall.

Dimension the doors and wall

10 Click Annotate tab ➤ Dimension panel ➤ Aligned.

You dimension the doors and interior wall that you attempted to align previously.

11 Click the midpoint of the door on the left, the center of the wall, and the midpoint of the door
on the right. Click just below the doors to place the dimension.
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12 Click  for both dimensions.

The lock establishes a constraint between the doors and the wall.

13 Click Modify.

Now, you can delete the dimension from the project, while maintaining the relationship.

14 Select the dimension string, and press Delete.

15 In the warning dialog, click OK.

The message warns that a relationship will remain without the dimensions. Close the warning
box, keeping the constraint.

Align the wall and mullion

16 Using the previous method, align the center of the wall to the mullion.

17 Click Modify.

Notice that the lock also appears after you use the align tool. Now, you can create a relationship
between the curtain wall and the interior wall.
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Now when the objects are moved, both doors maintain the relationship you established.

18 Close the file with or without saving it.
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Documenting a Project

In this tutorial, you learn how to use the tools in Autodesk Revit Architecture 2010 to document a building information
model project.
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Adding Views and Sheets
to a Project

In this lesson, you learn how to create views from a building model and place them on documentation sheets. You learn
to create:

■ Views by duplicating and modifying existing views.

■ Section and elevation views.

■ Views from callouts that you place in other views.

■ Sheets composing the document set.

Section view of the main stair

Wall detail view

13
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Sheet with section views

Duplicating and Modifying Views
In this exercise, you create a plan view of the building model by copying an existing view and then modifying
the copied view. You control the visibility of categories in the Visibility and Graphics dialog for the view.
You can also control visibility directly by manipulating the objects, using options on the context menu.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_AVS_01_Duplicate_View_m.rvt.

Create a furniture layout view

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.
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2 In the Project Browser, right-click 01 - Entry Level, and click Duplicate View ➤ Duplicate with
Detailing.

You duplicate the plan view to create a Furniture layout plan. Use the Duplicate with Detailing
option because detail lines required in the furniture layout plan were added to this floor plan
view. If only model elements are required, you use the Duplicate option.

3 In the Project Browser, right-click Copy of 01 - Entry Level, and click Rename.

4 In the Rename dialog, type 01 - Entry Level - Furniture Layout, and click OK.

Turn off visibility of grids and elevation markers

5 In the Project Browser, right-click the new view, and click Properties.

You access the Visibility and Graphics controls for the view in the Instance Properties dialog.

6 In the Instance Properties dialog, for Visibility/Graphics Overrides, click Edit.

All Revit Architecture categories are listed. You can control the categories for this view. In this
case, you want to hide the grids and the elevation markers in the furniture layout plan.

7 On the Annotation Categories tab of the Visibility/Graphics Overrides dialog, under Visibility,
clear Grids and clear Elevations.

8 Click OK twice.

The grid lines and elevation markers no longer display in this view. However, they are still part
of the project.
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Hide an element category

9 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

Now, you turn off the visibility of the furniture category in this view. You can control the
visibility of an object category using the context menu for the object itself, as well as in the
Visibility/Graphics Overrides dialog.

10 Select a table/chair object.

11 Right-click, and click Hide in view ➤ Category.

12 On the View Control Bar, click  (Reveal Hidden Elements).

To quickly see elements you turned off in a view, click the Reveal Hidden Elements tool on the
View Control Bar. Hidden elements in the view are highlighted and can be selected and modified.
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13 On the View Control Bar, click  (Close Reveal Hidden Elements).

14 Close the file with or without saving it.

Creating Section and Elevation Views
In this exercise, you create a section view through the main stair of the building. You split the section so it
also cuts through the building elevator shaft. Also, you create an elevation view of the southern wing of the
building by placing an elevation marker, and modifying the extents of the elevation plane.

Section view of the main stair

Courtyard elevation view

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_AVS_02_Section_Elevation_m.rvt.
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Create a section view

1 With the 01 - Entry Level plan view open, click View tab ➤ Create panel ➤ Section.

2 Draw a vertical section between grid lines 2 and 3, cutting through the stair, as shown.

NOTE After drawing the section line, if it is not cutting through the main stairs of the building, use
the Move tool (click Modify Views tab ➤ Modify panel ➤ Move) to adjust it. (If the section line is not
selected, click the section line to display the Modify Views tab.)

3 Click the Cycle Section Head control 3 times to view the section head symbol options.
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4 Drag the right section control to the left until it is just to the right of the pavilion. (If the section
line is not selected, click the section line to display the drag controls.)

You adjust the depth of the section to include only what you want to display in the section.

5 On the Section panel, click Split Segment.

Use the Split Segment option to break the section line and move a portion of the section so it
passes through the elevator shaft of the building.

6 Click the section line below the lower flight of stairs, move the cursor to the right so the section
line cuts through the elevator shaft, and click to place the section, as shown.
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7 Press Esc twice.

Modify element visibility in the view

8 Double-click the section head to open the section view.

Depending on where the section was cut, a tree may be visible in the section view.

Optionally, you can turn off the display of the planting category in this view.

9 Optionally, select the tree on the right, right-click, and click Hide in view ➤ Category.

10 Select the crop region boundary, and adjust the boundaries by dragging the controls.

11 On the View Control Bar, click  (Hide Crop Region).
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Rename the view

12 In the Project Browser, expand Sections (Building Section), right-click Section 1, and click
Rename.

13 In the Rename View dialog, type Section Through Main Stair, and click OK.

Create an elevation view

14 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

15 Click View tab ➤ Create panel ➤ Elevation drop-down ➤ Elevation.

16 In the Type Selector, verify that Building Elevation is selected.

When you place an elevation marker, the context of the model is detected. Be sure the arrow
side of the elevation marker points towards the south wing of the building.

17 Click to place the marker (pointing south) above the longer wing of the building, as shown.

18 Click Modify.

19 Select the arrow portion of the elevation marker.

20 Adjust the position and extents of the elevation plane, as shown.

Rename the view

21 In the Project Browser, under Elevations (Building Elevation), right-click Elevation 1 - a, and
click Rename.

22 In the Rename View dialog, type Courtyard Elevation - South Wing, and click OK.

23 In the Project Browser, double-click the new elevation view to open it.
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24 On the View Control Bar, click  (Hide Crop Region).

25 Close the file with or without saving it.

Creating Callout Views
In this exercise, you create views from callouts: a wall section view and a wall detail view. You create each
view by drawing a callout around the geometry in another view to specify the contents of each new callout
view.

Wall section view
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Wall detail view

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_AVS_03_Callout_Views_m.rvt.

Create a callout for a wall section

1 In the Project Browser, under Sections (Building Section), double-click Section Through Main
Stair.

2 Click View tab ➤ Create panel ➤ Callout.

3 On the Element panel, in the Type Selector, select Wall Section.

The type of callout determines where the view being created will be placed in the Project Browser.

4 On the Options Bar, for Scale, select 1 : 10.

You can select a scale for the resulting view before placing the callout.

5 To draw a callout around the right wall of the building, click to specify the lower-left corner of
the callout, and click to specify the upper-right corner, as shown.
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6 Adjust the callout head position:

■ Select the callout.

■ Click and hold the Drag Head control and move the callout head to the upper-right corner
of the callout.

■ Click and hold the Drag control and move it up to add a shoulder to the leader, as shown.

7 Press Esc.

Open the callout view

8 Double-click the view reference (callout head) to open the callout view.

9 If you do not see the material patterns in the callout view, on the View Control Bar, change the
detail level to Medium.
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10 On the View Control Bar, for Scale, select 1 : 20.

After the view opens, you can change the scale as you would in any other view.

11 On the View Control Bar, click  (Hide Crop Region).

Create a detail callout

12 Click View tab ➤ Create panel ➤ Callout.

You create a detail callout for the grade condition.

13 In the Type Selector, under Detail View, select Detail.
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14 On the Options Bar, for Scale, select 1 : 10.

15 Draw a callout around the bottom of the wall, including the grade, and adjust the callout head
position, as shown.

16 Press Esc.

17 Zoom in to the callout area.

The lineweight of the callout boundaries is not as wide as required for office standards. You can
modify the boundaries of callouts (or other objects) by changing their lineweight in the Object
Styles dialog.

Modify the lineweight of the callout boundary

18 Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Object Styles.

19 In the Object Styles dialog, click the Annotation Objects tab.

20 For Callout Boundary, for Line Weight Projection, select 7, and click OK.
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21 Double-click the view reference to open the callout view.

Rename the callout views

22 In the Project Browser, under Sections (Wall Section), right-click Callout of Section Through
Main Stair, and click Rename.

23 In the Rename View dialog, type Typical Wall Section, and click OK.

24 Using the previous method, under Detail Views, rename Detail 0 to Detail At Grade.

25 Close the file with or without saving it.

Creating Sheets
In this exercise, you add documentation sheets to the project. After you create the sheets, you place views
from the Project Browser on the sheets composing the document set. Views can easily be moved from one
sheet to another, as required by the project.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_AVS_04_Create_Sheets_m.rvt.

Create a sheet

1 In the Project Browser, right-click Sheets (all), and click New Sheet.

2 In the Select a Titleblock dialog, click Load.

Titleblocks can be created as families and then loaded into projects to create sheets. In this
example, the correct size titleblock has not been loaded into the project.

3 In the left pane of the Open dialog, click Training Files, and open Metric/Families/A0 metric.rfa.

4 In the Select a Titleblock dialog, verify that A0 metric is selected, and click OK.

5 In the Project Browser, expand Sheets (all), right-click A101 - Unnamed, and click Rename.

You can renumber and rename the sheet to match project or office standards.

6 In the Sheet Title dialog, for Number, type A1, for Name, type Floor Plan, and click OK.
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Create a second sheet

7 Using the previous method, create a second sheet. (Use the same titleblock, and name the sheet
Sections.)

The second sheet continues the numbering sequence established for the first sheet. You do not
need to assign a number.

8 Close the file with or without saving it.

Placing Views
In this exercise, you add views to the sheets you created in a previous exercise. To place a view on a sheet,
you drag it from the Project Browser and place it on the sheet.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_AVS_05_Place_Views_m.rvt.

Add a plan view to a sheet

1 In the Project Browser, under Sheets (all), double-click A1 - Floor Plan.

2 In the Project Browser, click the 01 - Entry Level floor plan, drag it to sheet A1, and click to place
it in the center of the sheet.

Before you click to place the view, move the cursor, positioning the view on the sheet, as required.
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3 Zoom in to the view title on the sheet (lower-left corner).

The view title is composed of the view name from the Project Browser and the scale specified
in the view.

Add section views to a sheet

4 In the Project Browser, under Sheets (all), double-click A2 - Sections.

5 Using the method you just learned, place the following section views on the sheet:

■ Section Through Main Stair

■ Typical Wall Section

■ Detail At Grade

Notice that when you place the Detail At Grade view next to the Typical Wall Section view,
guide lines display, helping you position the views so the view titles are aligned.
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6 Zoom in to the callout on the Section Through Main Stair view.

The callout head displays the correct sheet and view number references.

7 In the Project Browser, under Sheets (all), double-click A1 - Floor Plan.

8 Zoom in to the section mark at the top of the plan view.

The section mark displays the correct sheet and view number references.
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9 Close the file with or without saving it.
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Annotating and
Dimensioning

In this lesson, you create permanent dimensions for controlling and documenting the building model. You learn to:

■ Create dimensions by clicking points in the model.

■ Modify dimension options and create automatic wall dimensions.

■ Adjust the placement of witness lines in dimensions.

■ Modify a dimension value by adding text below the dimension.

■ Create and add text annotation to the plan.

Creating Dimensions
In this exercise, you dimension the grid lines on the north wing of the building.

14
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_AD_01_Create_Dimensions_m.rvt.

Dimension the north wing

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level, and zoom in to the
shorter (north) wing of the building.

2 Click Annotate tab ➤ Dimension panel ➤ Aligned.

Place an overall dimension between grid lines 1 and 6.

3 To place the dimension:

■ Click grid line 1.

■ Click grid line 6.

■ Move the cursor above the building model.

■ Click to place the dimension.
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4 Using the same method, place a string of dimensions by clicking each grid line, from left to
right, as shown.

Notice that when you place the dimension string, it snaps into position in relation to the first
dimension string placed.

5 Click Modify.

6 Close the file with or without saving it.

Creating Automatic Wall Dimensions
In this exercise, you place dimensions using the Entire Walls option. Using this option, you can automatically
dimension the wall and all of the inserts, intersecting walls, and intersecting grids.

To add clarity to the placed dimension, you move a witness line to a new wall reference, and control the
gap between the witness line and the element it is referencing. After you add a dimension to the walls in
the stairwell, you use the Dimension Text options to add an override to the dimension value.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_AD_02_Auto_Wall_Dimensions_m.rvt.

Open the Entry level floor plan view

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

You dimension the upper-right exterior wall of the north wing.

Select automatic dimensioning options

2 Click Annotate tab ➤ Dimension panel ➤ Aligned.

3 On the Options Bar:

■ For Pick, select Entire Walls.

■ Click Options.

4 In the Auto Dimension Options dialog:

■ Under Select references, select Openings, and select Widths.

■ Click OK.
These options ensure that the wall dimension includes the openings, and that the overall
dimension string references the opening widths.

Place the dimension

5 Select the top exterior wall.

6 Move the cursor above the plan view, and click to place the automatic dimension string.

Notice that the dimension string snaps into position under the existing dimension strings.

7 Click Modify.

Modify the position of dimension text

8 Select the dimension string.
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9 Select the drag text control for the third dimension text from the left, and drag it down and to
the right, making it easier to read.

10 Zoom in to the right end of the dimension string.

Align the witness line to a new reference

11 Select the Move Witness Line control on the last dimension line on the right, and move the
dimension line to the right until it aligns with the exterior face of the core layer of the Basic
Wall (Exterior - Insulation on Masonry), as shown.

NOTE Move the cursor down until the exterior wall is highlighted, press Tab until the exterior face
of the wall core is highlighted, and click to select it.

The dimension aligns to the face of the structural core of the wall.
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12 Press Esc.

You adjust the endpoint of the witness line so it is not touching the wall.

13 Select the right dimension line, select the bottom endpoint, and drag it up to set the gap between
the line and the witness reference, as shown.

Add a dimension to the walls in the stairwell

14 Click Annotate tab ➤ Dimension panel ➤ Aligned.

15 On the Options Bar:

■ For Place Dimensions, select Wall faces.

■ For Pick, select Individual References.

You changed the options to select the faces of walls and individual references.

16 In the Drawing area, position the cursor over the left wall in the opening for the stair, press Tab
until the Status Bar indicates that the wall is highlighted, and click to select it.

17 Using the previous method, select the right wall in the opening for the stair, and click to place
the dimension.
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18 Click Modify.

Add text to the dimension value

19 Double-click the dimension text.

20 In the Dimension Text dialog, for Below, type Clear, and click OK.

You use the options in the Dimension Text dialog to replace or append dimensions values with
text. The values do not affect the model geometry.

21 Press Esc.

22 Close the file with or without saving it.

Creating Text Annotation
In this exercise, you add a text note to a floor plan view. You can add notes with or without leaders. You
can also add or remove leaders from a text note after you place the text.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_AD_03_Text_m.rvt.

Add a text note

1 With the 01 - Entry Level view open, zoom into the canopy area over the entrance on the left.

2 Click Annotate tab ➤ Text panel ➤ Text.

3 In the Type Selector, select 2.5mm Arial.

You can add text family types for different text sizes or styles, such as italics, underline, and so
on.

4 On the Leader panel, click Two Segments.

5 Add a text annotation at the entrance canopy:

■ Click the curved line for the canopy.

■ Click above and to the left to specify the first segment.

■ Move the cursor horizontally to the left, and click to specify the second segment.
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6 In the text box, type Exterior overhead canopy. See structural sheets for additional
information/details.

7 Click Modify.

Modify the text bounding box

8 Select the text bounding box, select the left endpoint and drag it to the right to make the box
smaller and cause the text to wrap.

You can modify the size of the text bounding box, as required. The text automatically wraps to
fit in the bounding box.

Add a right leader

9 On the Leader panel, click Add Leader: Right Straight.
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10 Drag the endpoint of the new leader to the curved line, and click to place the leader, as shown.

11 Press Esc.

12 Close the file with or without saving it.
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Tagging Objects

In this lesson, you use annotation tools to tag rooms and other objects in a building model view. You learn to:

■ Sequentially place and tag rooms on a floor plan.

■ Tag rooms that have already been placed.

■ Tag doors and windows automatically with the Tag All Not Tagged function.

■ Tag walls manually with the By Category function.

■ Modify a tag value for a window type.

Sequentially Placing and Tagging Rooms
In this exercise, you sequentially place and tag the rooms on the third floor plan. By using the Room
command with the Tag on placement option, you can use one command to place and tag rooms. The rooms
number sequentially as they are placed into the project. You can also add tags to rooms after the rooms are
placed, tagging one at a time, or using the Tag All Not Tagged option.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_TO_01_Room_Tags_m.rvt.

Add rooms to the third floor plan

1 In the Project Browser, under Floor Plans, double-click 03 - Floor.

2 Zoom in to the right side of the longer wing of the building.

3 Click Home tab ➤ Room & Area panel ➤ Room drop-down ➤ Room.
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4 On the Options Bar, verify that Tag on placement is selected. When you place the room, a
number is automatically assigned.

5 Click in the room for the stairs.

The crosshair graphic represents the room area being tagged, and the rectangle contains the
room tag.

6 Click Modify.

You can change the numbering sequence by modifying the number for the room you just placed.
However, the room number for the next room you place will continue the sequence established
by this number.

Modify the numbering sequence and room name

7 Double-click the room number, type 301, and press Enter.

8 Click the room name, type Stair, and press Enter.

Add rooms

9 Click Home tab ➤ Room & Area panel ➤ Room drop-down ➤ Room.

10 Place rooms to the left, as shown. The room numbering is resequenced. (Sequential letters are
also supported.)
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NOTE You can align the tags by moving the cursor until a dashed blue line displays between the
placed tag and the one that displays at the tip of the cursor.

11 Optionally, place all rooms in the layout.

After placing the rooms in the third level, open the first level plan view to add room tags to
rooms that are already placed.

Manually add room tags to the first level floor plan

12 Open the 01 - Entry Level floor plan.

13 Click Home tab ➤ Room & Area panel ➤ Tag drop-down ➤ Tag Room.

14 In the entry area, click the vestibule and the lobby to add room tags.
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15 Click Modify.

16 Zoom to fit the plan in the view.

Automatically tag all remaining rooms

17 Click Annotate tab ➤ Tag panel ➤ Tag All.

18 In the Tag All Not Tagged dialog, for Category, select the Room Tags entry with the Loaded Tags
value M_Room Tag, and click OK.

All remaining rooms are tagged.

19 Close the file with or without saving it.

Tagging Doors, Windows, and Walls
In this exercise, you add tags to doors and windows using the Tag All Not Tagged option. You modify tag
values by clicking the tag and typing values. You use the Tag option to manually tag individual walls in the
model.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_TO_02_Tag_Doors_Walls_Windows_m.rvt.

Tag doors and windows

1 In the Project Browser, under Floor Plans, double-click 01 - Entry Level.

2 Click Annotate tab ➤ Tag panel ➤ Tag All.

3 In the Tag All Not Tagged dialog, while pressing Ctrl, select Door Tags and select Window Tags.

4 Click OK.

The doors and windows are tagged automatically.

Modify tag text

5 Zoom in to the right side of the shorter wing of the building.
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6 Select the tag for the door leading to the stair.

A value is not assigned to this door because it is in a curtain wall, and was placed as a panel.
When the panel was placed, a mark value was not assigned, as it is when you place a door family.

7 Select the tag value, type 130A, and press Enter.

8 Press Esc.

Tag walls individually

9 Click Annotate tab ➤ Tag panel ➤ Tag by Category.

You select each wall to be tagged individually.

10 In the drawing area, select the right wall of the cafeteria.

11 Press Esc.
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12 Select the tag, click the tag value, type A1, and press Enter.

NOTE The tag symbol and text size are determined by the tag family.

13 In the warning dialog, click Yes.

The warning dialog displays because this tag is associated with a type parameter. Changing a
type parameter on an object can affect many objects in a model, so you must do this carefully.

14 Press Esc.

15 Click Annotate tab ➤ Tag panel ➤ Tag by Category.

16 Click the right wall of the Conference room.

This time the tag value is displayed automatically because the type parameter was defined in
the previous steps.
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17 Close the file with or without saving it.
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Defining Schedules

In this lesson, you define door and room schedules. You learn to:

■ Create a door schedule, sorted by door number.

■ Group schedule headers for clarity.

■ Generate a key schedule to add door hardware groupings to the door schedule.

■ Create a room finish schedule.

■ Create rooms in the room schedule and add them to the project.

NOTE In some cases in these exercises, only partial schedule images are shown for clarity.

Door Schedule with hardware group column generated from a key schedule

Creating a Door Schedule
In this exercise, you create a door schedule. After creating the fields, you specify a sorting order and reformat
the headers to clarify the schedule organization.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_DS_01_Door_Schedule_m.rvt.

Create a door schedule

1 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.

2 In the New Schedule dialog, under Category, select Doors, and click OK.

3 On the Fields tab of the Schedule Properties dialog, under Available fields, select Mark, and click
Add.

4 Using the previous method, add the following fields to the schedule in this order:

■ Width

■ Height

■ Operation

■ Frame Type

■ Frame Material

■ Fire Rating

■ Comments

5 On the Sorting/Grouping tab, for Sort by, select Mark.

The schedule will be sorted by door number.

6 On the Formatting tab, under Fields, select Mark, and for Heading, type Door #.

7 Under Fields, select Frame Type, and for Heading, type Type.

Later, Frame Type and Frame Material will be grouped together in the schedule under the heading
Frame, so you delete the word ''frame'' from the individual headers.

8 Using the previous method, change the heading for Frame Material to Material.

9 Click OK.

The schedule is created and displayed. Values already assigned to the objects in the projects
automatically populate the door schedule.
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Group the schedule headers

You group the headers for the frame columns and the door size columns.

10 Click and drag the cursor to select both the Type and Material column headings.

11 On the Schedule panel, for Headers, click Group.

12 Click in the new header, and type Frame.

13 Using the previous method, group the Width and Height columns, and in the header, type Size.

14 Close the file with or without saving it.

Creating a Key Schedule
In this exercise, you use a key schedule to add door hardware groupings to the door schedule. You replace
the Operation column in the door schedule with the Hardware Group column generated from the key
schedule. Creating and using the key schedule, you can simplify data entry in the larger Hardware Schedule.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_DS_02_Key_Schedule_m.rvt.

Create a key schedule

1 In the Project Browser, under Schedule/Quantities, double-click Door Schedule.

2 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.

3 In the New Schedule dialog:

■ Under Category, select Doors.

■ For Name, type Hardware Schedule.

■ Select Schedule keys.

■ For Key name, type Hardware Group.

■ Click OK.

Add parameters to the key schedule

4 In the Schedule Properties dialog, click Add Parameter.

You add parameters to the key schedule for the hardware components that will be grouped
together.

5 In the Parameter Properties dialog:

■ Under Parameter Data, for Name, type Hinge Set.

■ For Type of Parameter, verify that Text is selected.

■ Click OK.

Hinge Set is listed below Key Name, under Scheduled fields (in order).

6 Using the previous method, add another text parameter, and name it Lock Function.

7 Using the previous method, add the following Yes/No parameters (for Type of Parameter, select
Yes/No):

■ Egress Hardware

■ Closer

■ Stop

■ Kickplates

■ Hold Open
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8 In the Schedule Properties dialog, click OK.

The Hardware Schedule displays.

Add rows to create hardware grouping

9 On the Schedule panel, for Rows, click New 4 times.

10 Define 4 groups with the specifications, as shown.

Only 4 groups are defined for simplicity. You can create hardware components and additional
group configurations later, as required by the project.

You can type entries to populate fields in the schedule, or select an entry from a drop-down list
in the field. For example, after you enter 3 Butt in the first Hinge Set field, that value is available
from a drop-down list in the other Hinge Set fields.

NOTE The checkboxes (yes/no fields) can be selected and cleared even though they initially display
in a grey color. For a field with a checkbox, click to select the field, click to enable the checkbox, and
click again to clear or select the checkbox.

Add the key schedule field to the door schedule

11 Open the Door Schedule.

You replace the Operation column in the Door Schedule with the key schedule field, Hardware
Group.
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12 In the Project Browser, right-click Door Schedule, and click Properties.

13 In the Instance Properties dialog, for Fields, click Edit.

14 In the Schedule Properties dialog, under Scheduled fields (in order), select Operation, and click
Remove.

15 Under Available fields, select Hardware Group, and click Add.

16 Click Move Up so the Hardware Group is positioned above Frame Type.

17 Click OK twice.

Assign groups by door function

18 In the Door Schedule, for Door 101A, Hardware Group, select 3.

You can create and assign additional groups later. In this exercise, only 1 group is shown.

19 Close the file with or without saving it.

Creating a Room Finish Schedule
In this exercise, you create a room finish schedule. You can also use a room schedule as a project program
and create rooms before they are placed in the project. Then, you add the rooms to the schedule, and place
them in the project. Finally, you use a filter to modify the room schedule so it only includes rooms from
the 02 - Floor level.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_DS_03_Finish_Schedule_m.rvt.

Create a room finish schedule

1 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.

2 In the New Schedule dialog, under Category, select Rooms.

3 For Name, type Room Finish Schedule, and click OK.

4 On the Fields tab of the Schedule Properties dialog, under Available fields, select Number, and
click Add.

The Number field displays under Scheduled fields.

5 Using the previous method, add the following fields to the schedule in order:

■ Name

■ Base Finish

■ Floor Finish

■ Wall Finish

■ Ceiling Finish

■ Area

■ Comments

■ Level

6 On the Sorting Grouping tab, for Sort by, select Number.

7 On the Formatting tab, under Fields, select Base Finish.

8 Under Heading, delete the word Finish.

Later, the finish fields will be grouped in the schedule under the heading Finishes, so you can
remove the word Finish from the individual heading.

9 Using the previous method, select the Floor Finish, Wall Finish, and Ceiling Finish fields, and
remove the word Finish from each heading.

10 In the Schedule Properties dialog, click OK.

The Room Finish Schedule displays.
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Group the finish fields

11 Click and drag the cursor to select the Base, Floor, Wall, and Ceiling headers.

12 On the Schedule panel, for Headers, click Group.

13 Click in the new header, and type Finishes.

Add rooms to the schedule

14 On the Schedule panel, for Rows, click New.

You can add new rows to the schedule. These new rows are rooms added to the project, but they
are not yet placed in the project. Notice that when you first create a room, it is listed as Not
Placed in the Area and Level columns.

15 Using the previous method, add 3 more rooms.

Rename the rooms

16 Rename the 4 rooms to reflect the building design:

■ Lounge

■ Copy/Print

■ Drafting

■ Computer Lab

NOTE You can type the name, or select it from a drop-down list if a room of that name already exists
in the project.
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Place the new rooms

17 In the Project Browser, under Floor Plans, double-click 02 - Floor.

18 Zoom in to the longer wing of the building.

Notice the 4 spaces without a room label. Place the 4 rooms created in the previous steps into
these spaces.

19 Click Home tab ➤ Room & Area panel ➤ Room drop-down ➤ Room.

20 On the Options Bar, verify that Tag on placement is selected, and for Room, select Lounge.

By selecting rooms on the Options Bar, you can place a room that is already defined in the
project, but not placed.

21 Click in the room to the left of the Instruction 205 room, to place the Lounge.

22 Click Modify.

23 Select the room tag for the Lounge, click the room number value, type 206, and press Enter.
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24 Using the previous method, place and number the rooms as shown:

■ Copy/Print 207

■ Drafting 208

■ Computer Lab 209

Filter the schedule

25 Open the Room Finish Schedule.

Notice that now the information displays for the rooms numbered 206 - 209.

26 In the Project Browser, right-click Room Finish Schedule, and click Properties.

Using a filter, you modify the Room Finish Schedule to include only rooms from the second
floor.

27 In the Instance Properties dialog, for Filter, click Edit.

28 On the Filter tab of the Schedule Properties dialog:

■ For Filter by, select Level.

■ In the second field, verify that equals is selected.

■ In the third field, select 02 - Floor.

Hide the filter field in the schedule

29 On the Formatting tab, for Fields, select Level, and on the right, select Hidden field.
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Specify that you want to hide the Level field. The field must be included in the schedule so the
schedule can filter based on Level; however, the field does not need to be visible in the final
schedule.

30 Click OK.

Rename the schedule

31 In the Instance Properties dialog, in the View Name field, type 02 Floor - Room Finish Schedule,
and click OK.

You rename the schedule to indicate that it includes only rooms from the second floor.

32 Close the file with or without saving it.
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Detailing

In Revit Architecture, details are either based on the geometry of the building model as a detail view, or referenced as a
drafting view with parametric tags that automatically track and display detail view and drawing sheet placement.

In this lesson, you learn to:

■ Use detail components to define a wall section.

■ Use text notes to annotate a detail.

■ Create a model-based detail view.

■ Use keynotes to annotate a detail.

■ Create a detail callout and reference a drafting view.

■ Create a drafting view detail by importing a DWG file.

Detail with keynotes and callout reference

17
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Detailing the View and Adding Text Annotation
In this exercise, you add detail elements to the section view created in a previous exercise. To complete the
detail, you add filled regions, detail lines, and text notes with leaders.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_D_01_Detail_View_m.rvt.

Modify element visibility

1 In the Project Browser, under Detail Views (Detail), double-click Detail At Grade.
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2 Select the 01 - Entry Level marker.

The level marker and crop region of the view are not required for the detail view, so you hide
these elements.

3 Right-click, and click Hide in view ➤ Category.

4 On the View Control Bar, click  (Hide Crop Region).
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Add break lines to the view

Break lines are detail component families. Detail component families resemble other Revit Architecture
families, except that they are visible only in the view in which they are placed.

5 Click Annotate tab ➤ Detail panel ➤ Component drop-down ➤ Detail Component.

6 On the Detail panel, click Load Family.

The break line component family has not been loaded into the project.

7 In the left pane of the Load Family dialog, click Training Files, and open Metric\Families\M_Break
Line.rfa.

8 Click to place a break line at the top of the wall. (Exact placement is not important.)

9 Press the Spacebar, and click to place a break line at the slab edge on the left.

NOTE Press the Spacebar to rotate the component while placing it. Each time you press the Spacebar,
the component rotates 90 degrees.
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10 If necessary, use the blue shape handles to cover the model correctly. (For example, click and
drag the down arrow shape handle to extend the break line to the bottom of the model.)

Create a repeating detail

The detail of the model display of the CMU wall is not satisfactory. You can place detail components on
top of model elements to further define the detail. Because you need to place more than one block, you
create a repeating detail, based on the CMU detail component. Repeating details can save time if you need
to place multiple items of the same type in a linear way.

11 Click Annotate tab ➤ Detail panel ➤ Component drop-down ➤ Repeating Detail.

12 On the Element panel, click Element Properties drop-down ➤ Type Properties.

You create a repeating detail type, based on the CMU detail component.

13 In the Type Properties dialog, click Duplicate.

14 In the Name dialog, type Concrete Block, and click OK.

15 Define properties for the detail type:

■ For Detail, select M_CMU-2 Core-Section : 200x200x400mm.

■ For Spacing, type 200, and press Enter.
Specify spacing that corresponds with the selected detail component.

■ Click OK.

Place the repeating detail

16 Click to start the detail at the inner left endpoint at the bottom of the wall, as shown.
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17 Move the cursor up, and click above the break line to end the detail.

As you move the cursor away from the origin point, the detail component arrays according to
the spacing defined for the type.

18 Click Modify.

Notice that the repeating detail displays on top of the model. It is also on top of the break line
symbol. You adjust the display order in the next steps.
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Add detail groups

To keep the exercise brief, detail groups were created earlier and loaded into the project. The groups were
created by placing individual detail components, filled regions, and detail lines, then the elements were
grouped so they could be placed as one item. You can ungroup detail groups after placement, and manipulate
individual elements, as required.

19 In the Project Browser, expand Groups\Detail, right-click Under Slab, and click Create Instance.

This detail group consists of 2 filled regions. The first region represents the fill under the slab,
and the second one represents the rigid insulation.

20 Click the lower left endpoint of the foundation.

21 Click Modify.

22 In the Project Browser, right-click Reinforcing, and click Create Instance.

The detail group consists of 3 reinforcement detail families, each representing a different
reinforcement condition.

23 Click the lower-left endpoint of the foundation.
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24 Click Modify.

25 In the Project Browser, right-click Starter Track, and click Create Instance.

This grouping consists of detail lines representing flashing and membrane elements. It also
contains a masking region used to hide a portion of the insulation in the model. The masking
region provides a clear space in which to detail the flashing system.

26 Click the right endpoint of the floor.
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27 Click Modify.

Add a filled region

28 Zoom in to the concrete block section of the detail.

29 Click Annotate tab ➤ Detail panel ➤ Region drop-down ➤ Region.

Add a filled region with invisible edges and a transparent fill to represent solid grout.

30 Click Create Filled Region Boundary tab ➤ Element drop-down ➤ Region Properties.

31 In the Instance Properties dialog, click Edit Type.
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32 In the Type Properties dialog, click Duplicate.

33 In the Name dialog, type Concrete, and click OK.

34 Under Graphics, click the value for Fill Pattern, and click  .

35 In the Fill Patterns dialog, select Concrete, and click OK.

36 For Background, select Transparent.

Using the transparent background, the underlaying drawing is visible through the white portions
of the fill pattern.

37 Click OK twice.

38 In the Type Selector, select <Invisible lines>.

You specify invisible lines for the edges of the filled region to prevent confusion with other
portions of the detail.

39 On the Draw panel, click  (Rectangle).

40 Click the lower-left corner and click the upper-right corner to draw the border of the filled
region. Draw the region close to the inside edge of the core of the concrete blocks, without
touching the edge of the core, approximately as shown.

The filled region is selected in the following image for illustration purposes.

41 On the Region panel, click Finish Region.
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The filled region may not be visible because of the draw order of the objects.

42 Zoom out, and select the repeating detail of concrete blocks.

43 On the Arrange panel, click Send to Back drop-down ➤ Send to Back.

The detail is complete.
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Annotate the detail

44 Click Annotate tab ➤ Text panel ➤ Text.

You place text with leaders to annotate portions of the detail.

45 On the Leader panel, click Two Segments.

46 Click the gypsum board to the left of the concrete block detail, click to the right of the drawing
to specify the first segment of the leader, and click again to specify the second segment, as
shown.

47 Type 13mm Gypsum Board, and click outside the text box.

48 Close the warning dialog that displays.

If a note is placed and is not visible, you may need to modify the annotation crop region of the
view. Turn the crop region on and modify the annotation crop boundary of the view.

49 Click Modify.

50 On the View Control Bar, click  (Show Crop Region).

51 Move the cursor over the crop region boundary.

The dashed line of the crop region represents the annotation crop region. You must place any
annotation in this view completely inside the annotation crop region. Otherwise, it is hidden.
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52 Select the crop region (the inner border around the drawing), select the control for the annotation
crop boundary on the right, and drag it to the right to reveal the annotation text.

53 Optionally, use the previous method to annotate the detail, as shown.
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54 On the View Control Bar, click  (Hide Crop Region) to prepare the detail for printing.
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55 Close the file with or without saving it.

Creating a Detail and Adding Keynote Annotations
In this exercise, you create a detail for the parapet of the wall. You use an underlay display of the model
objects to layout the detail elements. After you add the detail components, you turn off the visibility of the
model objects. Finally, you add keynote annotations to the view.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_D_02_Detail_Keynote_m.rvt.

Add a repeating detail

1 In the Project Browser, under Detail Views, double-click Detail At Parapet.

Some components were already placed in this view. Notice that the model objects display as an
underlay (grey tone), making it easier to lay out the detail components.
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2 Click Annotate tab ➤ Detail panel ➤ Component drop-down ➤ Repeating Detail.

You place a repeating detail of CMU blocks made in the previous exercise to complete the detail.

3 In the Type Selector, select Concrete Block.

4 At the lower-left corner of the exterior wall, click the second endpoint from the left, move the
cursor up, and when 3 concrete blocks display, click to end the detail.

5 Click Modify.

Align the detail to the roof

6 Click Modify tab ➤ Edit panel ➤ Align.

You use the Align tool to align the top of the concrete blocks with the Roof level.

7 Click the Roof level, and click the top horizontal line of the repeating detail.

8 If necessary, use the previous method to align the blocks within the walls, aligning to the inside
face of the insulation.
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9 Click Modify.

Add a break line

10 Click Annotate tab ➤ Detail panel ➤ Component drop-down ➤ Detail Component.

11 In the Type Selector, select M_Break Line.

12 Press the Spacebar 2 times to place the masking portion of the break line towards the bottom of
the wall, and click to place the component.

13 Click and drag the blue shape handles to extend the break line to mask the width of the detail.

14 Click Modify.

The detail components are complete.
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Hide the model elements

15 In the Project Browser, right-click Detail At Parapet, and click Properties.

16 In the Instance Properties dialog, for Display Model, select Do not display, and click OK.

In this example, the finished detail is composed only of detail components. The model was used
for layout purposes only. Depending on project requirements and individual preference, other
details may include the model in the finished detail.

Add keynotes

17 Click Annotate tag ➤ Tag panel ➤ Keynote drop-down ➤ Element.

You can add keynotes to detail components. Parameters in the detail component family generate
the keynote tag values.

18 Click to select the Coping-Section, click to specify the first segment of the leader, and click again
to specify the second segment.
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19 Optionally, use the previous method to add keynotes, as shown.

Select keynote value

Some detail components do not have the keynote parameters specified. If this is the case, you can select the
keynote value as you place the keynote.

20 Using the method you learned previously, add a keynote for the Cant Strip-Wood-Section at
the parapet level.
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21 In the keynotes dialog, expand Division 000600\06100\06110, and select 061100.A2 Wood
Blocking As Required, and click OK.

The keynotes dialog opens because the component family you selected does not contain keynote
information. Select the correct value in the keynote file.

22 Click Modify.

Change the keynote type

Depending on the keynote tag family you select, keynotes display the text description from the keynote file,
the keynote number, or both.

23 Draw a selection box to select the drawing and keynotes.

24 On the Filter panel, click Filter.

25 In the Filter dialog, select Keynote Tags, clear all other options, and click OK.

26 In the Type Selector, select Keynote Text.

Keynotes are hidden on the right side of the drawing.
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27 On the View Control Bar, click  (Show Crop Region).

28 Move the cursor over the crop region boundary.

The dashed line of the crop region represents the annotation crop region. You must place any
annotation in this view completely inside the annotation crop region. Otherwise, it is hidden.

29 Select the crop region border.

30 Select the control for the annotation crop boundary on the right, and drag it to the right to
reveal the keynotes.
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31 On the View Control Bar, click  (Hide Crop Region).

32 Using the filtering method you used previously, select the keynote tags.

33 In the Type Selector, select Keynote Tag : Keynote Number - Boxed.

34 Press Esc.
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Place a callout

35 Click View tab ➤ Create panel ➤ Callout.

You can place callouts and reference marks without creating a new model view. With a callout,
you can create and reference a drafting view. You can use drafting views for documenting a
condition that will only be shown in a detail format, or for importing DWG files as details.

36 On the Options Bar, select Reference other view, and in the drop-down list, select <New Drafting
View>.

You place a callout referencing a drafting view for the roofing termination detail. You add the
detail to the project in another exercise.

37 Draw a callout around the roofing termination area, as shown.

38 Select the callout, and drag the control to move the reference to the upper left.
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39 Press Esc.

40 Close the file with or without saving it.

Importing a Detail into a Drafting View
In this exercise, you import a DWG file and use it as a detail in a drafting view, which was created from a
callout in the previous exercise.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_D_03_Import_Detail_m.rvt.

Import a DWG file

1 In the Project Browser, under Drafting Views (Detail), double-click Callout of Detail At Parapet.
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You import the DWG file into a blank drafting view. A drafting view could also contain only
drafting objects created in Revit Architecture. Use drafting views to create details or drawings
that have no connection to the project model.

2 Click Insert tab ➤ Import panel ➤ Import CAD.

3 In the left pane of the Import CAD Formats dialog, click Training Files, and select
Common\Roofing Detail.dwg.

4 For Colors, select Black and White to import the drawing colors in black and white.

5 Click Open.

The drawing is imported quickly, but it does not display until you zoom to fit the view in the
window.

6 Zoom to fit the drawing in the view.

Modify the line weight

7 Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Object Styles.

You can assign line weights per layer in the imported DWG file. Open the Object Styles dialog
to make changes to the line weights.

8 In the Object Styles dialog, click the Imported Objects tab.

9 Specify line weights for Roofing Detail.dwg:

■ For the Medium category, Line Weight Projection, select 3.

■ For the Wide category, Line Weight Projection, select 5.

10 Click OK.
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Change the view scale

11 On the View Control Bar, for Scale, select 1 : 2.

Specify a scale at which you can view the detail correctly.

Rename the view

12 In the Project Browser, right-click Callout of Detail At Parapet, and click Rename.

13 In the Rename View dialog, type Roofing Termination Detail, and click OK.

Place the view on a sheet

14 Open the A2 - Sections sheets view.
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15 Click and drag the Roofing Termination Detail view from the Project Browser to the sheet, and
click to place it.

16 Zoom in to see the Roofing Termination Detail.
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Zoom in to the see the callout from the Detail at Parapet.

17 Close the file with or without saving it.
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Presenting a Project

In this tutorial, you learn to use the rendering features in Autodesk Revit Architecture 2010 to create rendered interior
and exterior views of a building information model. You also learn how to create and record animated walkthroughs of
a model.
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Rendering an Exterior View

In this lesson, you create an exterior perspective view of the building model and create a daytime rendering of the view.
You learn to:

■ Create and apply materials to the building model.

■ Place a camera to create a perspective view.

■ Adjust the view borders and depth.

■ Specify time and location settings and render a daytime view.

■ Export the rendered image to an external file.

Perspective view

Rendered view

18
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Applying Materials and Textures to the Building Model
In this exercise, you modify the materials used in the model to prepare it for rendering. The site material
assigned is currently an earth material, and you change the assignment to a grass material. You also create
a black anodized aluminum material and apply it to the curtain wall mullions and the parapet coping.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_REV_01_Material_Texture_m.rvt.

View the material assigned to the site

1 In the Project Browser, expand 3D Views, and double-click {3D}.

2 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

3 Select the topography, and on the Element panel, click Element Properties drop-down ➤ Instance
Properties.

In the Instance Properties dialog, notice that the material value is <By Category>. This means
that the material for this type of object is specified at the project level. (The same material is
applied to all objects in the topography category.) Changing the material in this dialog would
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change the material only for this instance of the object. To change the material at the category
level, you open the Object Styles dialog.

4 Click OK.

Change the material assigned to an object category

5 Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Object Styles.

6 In the Object Styles dialog, scroll and select the Topography category.

7 For Material, click the value, and click  .

8 In the Materials dialog, select Site - Grass.

9 For Cut Pattern, select Earth.

The Site - Grass material does not have a cut pattern assigned to it, so you need to assign one
to retain the pattern shown in views where the topography is cut.

10 Click OK twice.

Create a material

11 Zoom in to the building so you can see the material on the curtain wall mullions.

Create a material in the project and assign it to the mullions. Material definitions are stored in
the project, not in an external library.
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12 Click Manage tab ➤ Project Settings panel ➤ Materials.

13 In the Materials dialog, select Metal - Aluminum.

14 Click  (Duplicate).

You duplicate a material that has properties similar to the one you need to create.

15 In the Duplicate Revit Material dialog, type Metal - Aluminum, Black-Anodized, and click OK.

16 On the Graphics tab, under Shading, verify that Use Render Appearance for Shading is selected.

17 Click the Render Appearance tab.

18 Click Replace.

Select a different render appearance for the material.

19 In the Render Appearance Library dialog, click Aluminum Anodized Black, and click OK.

20 In the Materials dialog, click OK.

Assign a material to the mullions

21 Press Tab to highlight, and click to select a curtain wall mullion.

22 On the Element panel, click Element Properties drop-down ➤ Type Properties.
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23 In the Type Properties dialog, for Material, select the value, and click  .

24 In the Materials dialog, select Metal - Aluminum, Black-Anodized.

25 Click OK twice.

26 Press Esc.

You also need to change the material assignment for the corner mullion family. If a corner
mullion is not in the view, you can select the family in the Project Browser.

27 In the Project Browser, expand Families\Curtain Wall Mullions\L Corner Mullion, and
double-click L Mullion 1.

28 Using the method you just learned, change the material to Metal - Aluminum, Black-Anodized.

Assign a material to the coping sweep

29 Select the parapet wall, and on the Element panel, click Element Properties drop-down ➤ Type
Properties.

30 In the Type Properties dialog, click Preview.

31 In the Preview pane of the Type Properties dialog, for View, select Section: Modify type attributes.

32 In the right pane, under Construction, for Structure, click Edit.

33 Under Modify Vertical Structure (Section Preview only), click Sweeps.
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34 In the Wall Sweeps dialog, for Metal Parapet, click the Material value, and click  .

35 In the Materials dialog, select Metal - Aluminum, Black-Anodized.

36 Click OK 4 times to close all dialogs.

37 Press Esc.

38 Close the file with or without saving it.

Creating a Perspective View
In this exercise, you create a perspective view of the exterior of the building. You modify the crop region
and view angle to compose the view, as required for presentation.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_REV_02_Create_Perspective_m.rvt.

Place a camera in the site view

1 In the Project Browser, under Floor Plans, double-click Site.

You place a camera to create a perspective view from the site plan.

2 Zoom in to the lower-left corner of the site plan, including the parking area and longer wing of
the building.
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3 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Camera.

4 Click to place the eye position, and click to place the view target, approximately as shown.

NOTE Exact placement is not important because you modify the view as required.

The perspective view opens. The building is cut off in this view because of the back clipping
plane of the camera.
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Adjust the back clipping plane

5 Open the Site plan view.

NOTE If the camera is not shown in the view, in the Project Browser, right-click 3D View 1, and click
Show Camera. With the camera shown, you can adjust the triangle that represents the field of vision.

6 Drag the blue control up until it is positioned just beyond the edge of the shorter wing of the
building.

Adjust the crop region and camera angle

7 Open 3D View 1.

8 Drag the blue controls to compose the view, as shown.
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9 Zoom out, if necessary, so you can expand the crop region to view the entire face of the building.

10 Zoom to fit the perspective view in the window.

Rename the view

11 In the Project Browser, under 3D Views, right-click 3D View 1, and click Rename.

12 In the Rename View dialog, type From Parking Area, and click OK.

13 Close the file with or without saving it.

Creating a Daytime Rendering
In this exercise, you specify the time and location settings for the rendering, and render a daytime view of
the exterior. After creating the rendered image, you export the image to an external file and also save it to
the project.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_REV_03_Day_Render_m.rvt.

Display the perspective view

1 In the Project Browser, under 3D Views, double-click From Parking Area.

Specify rendering settings for a daytime view

2 On the View Control Bar, click Shadows Off ➤ Shadows On.

Switching on shadows can help you compose the view and set the time of day to achieve the
best results when rendering. It is not advisable to leave shadows on continually while working
in the project, however, since it may affect performance.

3 On the View Control Bar, click Shadows On ➤ Graphic Display Options.

Assign the location and a date and time for the shadows in the view.

4 In the Graphic Display Options dialog, for Sun Position, click  .

5 On the Still tab of the Sun and Shadows Settings dialog, click Summer Solstice.

6 Click Duplicate.

7 In the Name dialog, type Summer Solstice - Manchester NH, 3pm, and click OK.

8 In the Sun and Shadows Settings dialog, under Settings, select By Date, Time and Place.

9 For Place, click  .

10 In the Manage Place and Location dialog, for City, select, Manchester, NH, and click OK.

11 In the Sun and Shadows Settings dialog, for Date and Time, select the time value, 3:00 PM, and
click OK.

12 In the Graphic Display Options dialog, under Sun, select Use sun position for shaded display,
and click OK.

Now the view is composed and ready to render.
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Render a region

13 On the View Control Bar, click  (Show Rendering Dialog).

14 In the Rendering dialog, under Lighting, for Sun, select Summer Solstice - Manchester NH, 3pm.

You use the sun position created in the previous steps.

15 Under Background, for Style, select Sky: Cloudy.

You adjust cloud settings, as required. In this case, the sky will be a procedural sky generated
based on cloud settings and time of day.

16 Select Region (at the top of the dialog).

When first rendering a scene, you can use the Render Region option to limit the portion of the
view being rendered. A region renders quickly, allowing you to verify and adjust materials,
lighting, and composition before rendering the entire view.

17 In the drawing area, select the render region, and drag the blue controls to modify the extents
of the region, as shown.

18 In the Rendering dialog, click Render.

19 In the Rendering dialog, click Show the Model.

After you render an image, you can switch between the rendered view and the model view as
long as the Revit Architecture session is open.
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Render the view

20 In the Rendering dialog:

■ Clear Region.
After the rendering test shows acceptable results, render the entire view.

■ Under Quality, for Setting, select High.

■ Click Render.

Export the rendered image to an external file

After completing rendering, you can export the image to a variety of formats or save the image in the project.

21 In the Rendering dialog, click Export.

NOTE When exporting, the PNG and TIF formats save the background as an alpha channel, facilitating
replacement of the background with a selected image.

22 In the Save Image dialog:

■ In the left pane, click Desktop.

■ For Files of type, select Portable Network Graphics (*.png).

■ Click Save.

The image file is saved to the Desktop for later reference.

Save the image to the project

23 In the Rendering dialog, click Save to Project.

NOTE Saving the image to the project places it in the Project Browser. Saving rendered images in
the project can significantly affect the file size.

24 In the Save To Project dialog, for Name, type From Parking Area_3pm, and click OK.

25 Close the Rendering dialog.

26 In the Project Browser, under Renderings, open the From Parking Area_3pm view.

27 Close the file with or without saving it.
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Rendering an Interior View

In this lesson, you create a daytime and a nighttime rendering of the interior view of the building model.

You learn to:

■ Add ArchVision® realpeople (RPC content) to the interior.

■ Customize rendering settings.

■ Enable daylight portals (windows, curtain walls) for a daytime rendering.

■ Add a section box to limit the geometry included in the rendering.

■ Define artificial lighting for a nighttime rendering.

■ Adjust the exposure on rendered images.

Daytime rendering with daylight portals enabled

19
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Nighttime rendering with artificial lighting

Adding RPC People
In this exercise, you place entourage objects into the scene to add depth to the rendering. The entourage
objects you place are human figures created with ArchVision® RPC (Rich Photorealistic Content) People
families. In an RPC family, the geometry is replaced at the time of rendering with a photograph representing
the object.

3D representation of RPC people

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_RIV_01_RPC_People_m.rvt.

Add an RPC figure to the view

1 In the Project Browser, under Floor Plans, double-click 03 - Floor.

You place the RPC content into the scene from the plan view.

2 Zoom in to the concourse, as shown.
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3 Click Home tab ➤ Build panel ➤ Component drop-down ➤ Place a Component.

Like other Revit Architecture content, entourage objects are provided in family files. The M_RPC
Male and M_RPC Female families must be loaded into the project.

4 On the Model panel, click Load Family.

5 In the left pane of the Load Family dialog, click Training, and load Metric\Families\M_RPC
Male.rfa.

6 Different figures are contained in the family, as different types, such as Alex and Jay.

7 On the Element panel, in the Type Selector, under M_RPC Male, select Alex.

8 Click to place Alex on the right concourse near the furniture grouping, as shown.

The pointed portion of the symbol represents the front of the figure, and the line of sight of
that figure. Next, you use the rotate tool to turn the figure so it appears to be walking away from
the camera in the rendering.

9 On the Select panel, click Modify.

Rotate the figure

10 Select the figure, and on the Modify panel, click Rotate.

11 Rotate the figure:

■ Click to set the rotate start point at the line of sight.
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■ Rotate and click so that the figure is positioned, approximately as shown.

Place additional RPC figures

12 Click Home tab ➤ Build panel ➤ Component drop-down ➤ Place a Component.

13 On the Element panel, in the Type Selector, under M_RPC Male, select Jay.

14 Using the previous method, place Jay on the left concourse above the stair.

15 Press the Spacebar twice before clicking to place the RPC figure to rotate the figure 180 degrees.
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16 Using the previous methods:

■ Load the M_RPC Female family.

■ Place an instance of the figure, Florence, near Jay.

■ Rotate both Florence and Jay so they are facing each other, as if they are having a
conversation.

Enable reflective properties for RPC figures

17 Open the 03 - Floor Public 3D view.

In the 3D view, the human figures are represented in the rendering scene. You may need to
reposition the figures for image composition.
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18 Select Alex (the figure in the foreground), and on the Element panel, click Element Properties
drop-down ➤ Type Properties.

As with other Revit Architecture families, you modify parameters for RPC families in the Instance
Properties dialog.

19 In the Type Properties dialog, for Render Appearance Properties, click Edit.

20 In the Render Appearance Properties dialog, select Cast Reflections, and click OK.

In order to see the reflection of the figure, the reflective properties must be switched on for that
family type. By default, the reflection of RPC content is switched off in order to optimize
rendering performance. If reflections of RPC content are important to the rendering, select this
option. (Reflections are not really necessary for this scene, but you select them for this figure.)

21 Click OK.

22 Press Esc.

23 Close the file with or without saving it.

Adjusting Settings for Rendering
In this exercise, you adjust the settings controlling the process time and final results of the rendered image.
In addition to modifying settings, you use a section box to control the amount of geometry that is included
in the rendering. Working with these techniques, you learn to optimize the quality of the rendered image
and the amount of time it takes to complete the rendering process.
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Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_RIV_02_Adjust_Settings_m.rvt.

Create a custom setting

1 in the Project Browser, under 3D Views, double-click 03 - Floor Public.

2 On the View Control Bar, click  (Show Rendering Dialog).

3 In the Rendering dialog, under Quality, for Setting, select Edit.

By editing the rendering settings, you can modify the preset values for renderings. Then, these
custom values are only applied to this view. You must repeat this process if you want to use
custom settings in other views.

4 In the Render Quality Settings dialog, for Setting, select Medium.

5 Click Copy To Custom.

The preset schemes are read-only. Copy a preset scheme to your custom settings in order to
make changes, in this case, to switch on daylight portals. Additional settings can be modified
at this time as required, but the default settings are used for this exercise.
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Enable daylight portals

6 Scroll down in the dialog, and for Daylight Portal Options (only applies to sunlit interiors),
select Windows, Doors, and Curtain Walls, and click OK.

By default, daylighting is provided to an interior space, but you can improve the quality by
switching on the daylight portals. However, this can also significantly increase rendering time.

7 In the Rendering dialog, under Lighting, for Scheme, select Interior: Sun only.

8 Click Render.

9 In the Rendering Progress dialog, click Cancel.

Because the daylight portals are enabled, this process would take a long time to complete. Notice,
however, in the Rendering Progress dialog, that over 1000 daylight portals are selected in the
rendering. In the next steps, you use methods to reduce the number of portals included in the
rendering and shorten the process.

10 In the confirmation dialog, click Yes.

11 Close the Rendering dialog.

Add a section box to limit the geometry

The geometry selected for the rendering can be limited. Working with less geometry will reduce the rendering
time. Use a section box to control the geometry that is selected.

12 In the Project Browser, under 3D Views, right-click 03 - Floor Public, and click Properties.

13 In the Instance Properties dialog, under Extents, select Section Box, and click OK.

14 Zoom out so the section box can be selected.

15 If other views are currently open, click View tab ➤ Windows panel ➤ Close Hidden.

16 Select the section box.

With the section box selected, you open a plan view and a section view of the project. These
views will make it easier to modify the section box controlling the geometry selection for the
rendering.

17 Open the Site floor plan view, and the Section Through Main Stair section view.

18 Click View tab ➤ Windows panel ➤ Tile.

Use the Tile option to show all open windows on the screen.

328 | Chapter 19   Rendering an Interior View



19 Make adjustments to the section box in the section view, as shown. (The exact extents of the
section box are not important.)

20 Make adjustments to the plan view.

21 Maximize the 3D View.
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22 Right-click the section box, and click Hide in view ➤ Category.

Turn off the visibility of the section box in the view.

23 Zoom to fit the view in the window.

Render the view

24 On the View Control Bar, click  (Show Rendering Dialog).

25 Keeping the same settings that you specified earlier, click Render.

26 Again, cancel the rendering process.

Daylight portals are still enabled. Notice in the Rendering Progress dialog, however, that the
number of daylight portals is drastically reduced from the 1000 plus portals included in the
previous steps. The section box reduced the geometry considered for the rendering.

27 Close the Rendering dialog.

Rename the view

28 In the Project Browser, under 3D Views, right-click 03 - Floor Public, and click Rename.

This view will be rendered with daylight and also with artificial lighting. Rename the view to
reflect the daylight view. In another exercise, you duplicate the view and modify the settings
for an artificial lighting rendering.

29 In the Rename View dialog, type 03 - Floor Public - Day Rendering, and click OK.

Create a lower quality daylight rendering

30 On the View Control Bar, click  (Show Rendering Dialog).

31 In the Rendering dialog, for Setting, select Low.

It is a good practice to render scenes at a lower quality setting in order to refine lighting and
material qualities before creating a high quality rendering, which can take much longer to
complete.

32 Click Render.

33 In the Rendering Progress dialog, clear Close dialog when rendering is complete.

You may select to keep the Rendering Progress dialog open after the rendering completes. This
might be useful if a rendering was left unattended overnight. The Rendering Progress dialog
displays the duration of the rendering process, and this information could be used for planning
future project renderings.
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34 When the rendering progress is complete, review the Render Time information, and close the
dialog.

Adjust the exposure

35 In the Rendering dialog, click Adjust Exposure.

After the rendering is complete, you use the exposure controls in the Rendering dialog to adjust
the final image. In this case, the rendering is overexposed. Use the controls to darken the image
to an appropriate level.

36 In the Exposure Control, for Exposure Value, type 12.5, and click OK.

You can adjust and apply any of the exposure controls without closing the dialog. These values
are reused if you run subsequent renderings on the particular view during the session. If you
closed Revit Architecture, and you run the render again, you must reset the exposure values.

Render the view with daylight portals enabled

Optionally, complete the following steps to render the view with the Custom setting that you specified
earlier (with daylight portals enabled).

37 In the Rendering dialog, for Setting, select Custom (view specific).

38 Click Render.

NOTE Because this process produces a high quality image with realistic natural lighting, it may take
up to 2 hours to complete.
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39 After the rendering is complete, close the Rendering Progress dialog.

Notice that the adjusted exposure settings apply to the view and were automatically used for
this rendering.

NOTE You can use the Image options on the rendering dialog to export the final image or save it to
the project.

40 Close the Rendering dialog.

41 Close the file with or without saving it.

Creating a Nighttime Rendering
In this exercise, you create an interior rendering using artificial lighting. You group lights to make it easier
to switch them on and off, as required. You also make adjustments to control the output of the rendered
image before rendering, so the resulting image is the correct size and resolution.

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_RIV_03_Night_Render_m.rvt.
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Duplicate the view

1 In the Project Browser, under 3D Views, right-click 03 - Floor Public - Day Rendering, and click
Duplicate View ➤ Duplicate.

2 In the Project Browser, right-click the duplicate view, and click Rename.

3 In the Rename View dialog, type 03 - Floor Public - Night Rendering, and click OK.

Define artificial lighting

4 On the View Control Bar, click  (Show Rendering Dialog).

5 In the Rendering dialog, under Lighting, for Scheme, select Interior: Artificial only.

The Interior: Artificial only option defines a baseline for the exposure and other settings for an
interior rendering without daylight. You can adjust these settings after the rendering is complete
using the Adjust Exposure option.

6 Click Artificial Lights.

7 In the Artificial Lights dialog, under Group Options, click New.

In the Artificial Lights dialog, individual lights can be switched off and on. Lights can also be
grouped together, so many lights can be switched off at one time. Lights can be grouped in any
arrangement that is appropriate for the project. In this case, create light groups for the family
types used in the project.

8 In the New Light Group dialog, type Pendant Lights, and click OK.

After a group is created, you can move individual or multiple lights into the group.

9 Under Ungrouped Lights, select the first pendant light in the list, and while pressing Shift, select
the last pendant light. (Select all of the pendant type lights in the list.)

10 Click Move to Group.

11 In the Light Groups dialog, select Pendant Lights, and click OK.

12 Using the previous method, create groups for the Sconce Lights and the Table Lamps and move
the appropriate lights into these groups.

After you group the lights, you can switch the entire group on or off.

13 Clear the Table Lamps group to turn it off, and select the Table Lamps group to turn it back on
again.

You leave all lights on for the nighttime rendering.

14 Click OK.

Change the output size

15 In the Rendering dialog, under Output Settings, select Printer.

To change the output size from the dimensions that are currently on the screen, select Printer.

The image is 189 mm wide, but you only need an image that is 118 mm wide. You resize the
image so additional time is not spent rendering at a size that is not required.

16 Close the Rendering dialog.

17 Select the crop region in the view.

18 Click Modify Cameras ➤ Crop panel ➤ Size Crop.
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19 Select Scale (locked proportions).

Lock the proportions because the image is already composed as required and you do not want
the crop region to change. The entire region will be scaled proportionately to the input size.

20 For Width, type 100 mm, and click OK.

Because you selected to lock proportions, the height value is adjusted automatically.

Render the view

21 On the View Control Bar, click  (Show Rendering Dialog).

The image size is smaller and will render much faster. You can also change the DPI value to
change the number of pixels rendered (the higher the DPI, the longer the rendering time), but
the final size will be maintained.

22 In the Rendering dialog, click Render.

NOTE The rendering process may take 5 or more minutes to complete.

23 Close the Rendering Progress dialog when the rendering is complete.
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Adjust the exposure

24 In the Rendering dialog, under Image, click Adjust Exposure.

25 In the Exposure Control dialog, for Exposure Value, type 6.5, and click OK.

26 Close the file with or without saving it.
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Creating and Recording
Walkthroughs

In this lesson, you create and record an animated walkthrough of the building model. A walkthrough is created in a 3D
perspective view by default, but you can also create it in a 3D orthographic view.

After you create the walkthrough, you record it by exporting it to an AVI file that you can play with any available video
player.

You learn to:

■ Create a walkthrough path.

■ Select and play the walkthrough.

■ Adjust the camera view in key frames along the path.

■ Modify the location of points along the path.

■ Record the walkthrough and export it as an AVI file.

Keyframe view from the walkthrough

20
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Creating a Walkthrough Path
In this exercise, you begin to create a walkthrough for presentation purposes. The first step in creating the
walkthrough is to define the path and the overall properties of the camera, such as the field of vision and
the view depth (back clipping plane).

Walkthrough path

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_CW_01_Walkthrough_Path_m.rvt.

Create a walkthrough of the first floor of the building model

1 In the Project Browser, under Floor Plans, double-click Site.

2 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Walkthrough.

When defining the path, you can specify the camera elevation using the Offset value. In this
example, you want the camera to start high and gradually descend as it enters the building. You
can also modify the elevation of the camera after the path is drawn, but it is easier to establish
the camera elevation while placing the path.

3 To create the walkthrough in a 3D perspective view, on the Options Bar, verify that Perspective
is selected.

4 On the Options Bar, for Offset, type 15240 mm.

The Offset value specifies the camera elevation.

5 Click to the right of the drive to specify the first point, as shown.
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6 Using the previous method, and the following table as a guide, modify the offset value, and
click to specify points to define the path. (Exact placement of the points is not important.)

Click to specify a point:Set the Offset value to:

In the parking area.7620

Near the large tree in the lower left corner.3048

To the right of the trees near the lower left
corner of the building.

2440

To the right of the circular drive near the
front entrance.

1675

Just inside the front door.1675

Under the atrium window in the con-
course.

1675

Points along the walkthrough path

The points clicked while establishing the walkthrough path represent key frames in the animation.
The camera motion and target point are averaged between the key frames of the walkthrough.
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7 On the Walkthrough panel, click Finish Walkthrough.

Rename the walkthrough

8 In the Project Browser, under Walkthroughs, right-click Walkthrough 1, and click Rename.

9 In the Rename View dialog, type Fly Into Building, and click OK.

Hide the back clipping plane

10 In the Project Browser, under Walkthroughs, double-click Fly Into Building.

11 Right-click the Fly Into Building walkthrough, and click Properties.

The view of the walkthrough is cut off at the back clipping plane of the camera. In the
walkthrough properties, change the settings to switch off the back clipping plane.

12 In the Instance Properties dialog, under Extents, clear Far Clip Active, and click OK.

With Far Clip switched off, the view is unlimited.
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Edit and play the walkthrough

13 Select the crop region.

14 Click Modify Cameras tab ➤ Walkthrough panel ➤ Edit Walkthrough.

15 On the Options Bar, for Frame, type 1.

16 On the Walkthrough panel, click Play.

Use the playback options to preview the walkthrough. You can advance the walkthrough frame
by frame or key frame by key frame.

NOTE To stop playing the walkthrough at any time, press Esc.
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17 Close the file with or without saving it.

Modifying the Camera Position and the Walkthrough Path
In this exercise, you learn how to edit the walkthrough path and adjust the camera position in the
walkthrough that you created in the previous exercise.

Tiled views make it easier to modify the walkthrough

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open
Metric\RAC_CW_02_Adjust_Camera_and_Path_m.rvt.

Change the properties of the camera

1 In the Project Browser, under Walkthroughs, double-click Fly Into Building.

2 Click View tab ➤ Windows panel ➤ Close Hidden. (This step is only necessary if you have other
views open.)

342 | Chapter 20   Creating and Recording Walkthroughs



3 On the Quick Access toolbar, click  (3D View).

4 Click View tab ➤ Windows panel ➤ Tile.

By tiling views of the model, editing the walkthrough is much easier. You can make edits in any
view. In this exercise, you only open 2 views, but you could open additional views, such as a
plan and elevation.

5 Zoom to fit the walkthrough view in the window.

6 Zoom in to the building in the 3D view.

7 Select the crop region in the walkthrough, and on the Walkthrough panel, click Edit
Walkthrough.

Active Camera is selected under Controls on the Options Bar. The camera is selected and you
can adjust the target point in the 3D view.

8 Select the window for the 3D view, and on the Element panel, click Element Properties
drop-down ➤ Instance Properties.
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9 In the Instance Properties dialog, under Extents, select Far Clip Active.

The vision cone of the camera is very small and may be hard to line up when adjusting the
target of the camera. You temporarily turn on the far clipping plane of the camera so the vision
cone is larger.

10 For Far Clip Offset, enter 304800, and click OK.

Adjust the camera target

11 Use the ViewCube as necessary to orient the view.

12 Drag the camera target point so that the view is toward the longer wing of the building. (Your
camera target position may vary from the illustration.)
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Use the walkthrough perspective view to verify the camera target. You could open multiple
views to make it easier to adjust the target.

13 On the Walkthrough panel, click Next Key Frame.

14 Using the previous method, adjust the camera target in the key frame so that the view is toward
the building.
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15 Optionally, continue to advance the key frame, and adjust the camera target to edit the
walkthrough view.

NOTE Use the ViewCube where necessary to change the orientation of the view for easier editing.

Adjust the camera path

16 On the Options Bar, for Controls, select Path.

By selecting the Path option, you can adjust the control points on the camera path. Adjust the
control points by clicking the point and dragging it to a new location. You can also adjust these
points in multiple views to make editing clearer.

17 Select the point in the parking area, and drag it so the path is to the left of the trees.
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18 Using the previous method, continue to advance to each key frame in the walkthrough and
make adjustments to the path and camera target, as needed.

19 Close the file with or without saving it.

Recording the Walkthrough
In this exercise, you record the walkthrough that you created in the previous exercise by exporting it to an
AVI file. When you export the walkthrough, you can select to display the walkthrough in wireframe, hidden
line, shading, shading with edges, or rendering. This file can be reviewed and played in a media player for
presentation purposes.

Still frame from the recorded walkthrough

Training File

■ Click  ➤ Open.

■ In the left pane of the Open dialog, click Training Files, and open Metric\RAC_CW_03_Record_m.rvt.

View rendering settings for the camera

1 In the Project Browser, under Walkthroughs, double-click Fly Into Building.

2 In the walkthrough view, select the crop boundary.

3 On the Element panel, click Element Properties drop-down ➤ Instance Properties.

The rendering settings for the camera are defined in the properties for the walkthrough. This
dialog can also be used to control the number of frames rendered for the walkthrough. More
frames will make the walkthrough smoother, but increase the render time.

4 In the Instance Properties dialog, for Rendering Settings, click Edit.

If you need a rendered walkthrough, you can use the same options as for a still rendered image.
In this example, you do not change the settings to create a simple shaded walkthrough.

5 Click OK.

Adjust the walkthrough frames values

6 In the Instance Properties dialog, for Walkthrough Frames, click the value.

You can modify both the number of frames used for the walkthrough and the rate at which
they are played. Higher values for the number of frames and frames per second create a smoother
walkthrough, but also increase the rendering time.

NOTE A frame rate over 30 per second is not recommended.
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7 In the Walkthrough Frames dialog:

■ Clear Uniform Speed.

■ For KeyFrames 7 and 8, Accelerator value, type .5.
You define an accelerator value of .5 to slow down the camera at this point in the walkthrough
because the camera is close to the building and should move more slowly.

■ Click OK.

Select shadow settings

8 In the Instance Properties dialog, for Graphic Display Options, click Edit.

9 In the Graphic Display Options dialog, for Sun Position, click  .

10 On the Still tab of the Sun and Shadows Settings dialog, select Summer Solstice - Manchester
NH, 3pm, and click OK.

Specify a shadow setting that is already in the project. (You could also create a shadow setting.)

11 In the Graphic Display Options dialog, select Use sun position for shaded display.

12 Click OK twice.

13 On the View Control Bar, click Shadows Off ➤ Shadows On.

Specify to display shadows in the walkthrough.

Export the walkthrough as an AVI file

14 Click  ➤ Export ➤ Images and Annotations ➤ Walkthrough.

15 In the Length/Format dialog, for Zoom to (% of actual size), type 50, and click OK.

In this dialog, you can control the number of frames being exported, as well as the size (in
pixels). You can specify the exact pixels or a percentage zoom. Remember, a smaller number of
pixels results in a faster rendering, but a lower quality output.

16 In the Export Walkthrough dialog, for File name, type a name for the AVI file, and click Save.

17 In the Video Compression dialog, for Compressor, select Cinepak Codec by Radius, and click
OK.

Video compression reduces the file size of the finished AVI. Compressed video can also result
in a loss of quality.
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NOTE The available Compressor options are specific to the current computer system. If you are
unsure of the option to use, use the Full Frames (Uncompressed) option. It produces files that are
larger than compressed files, but that do not suffer loss due to compression quality.

18 Optionally, click Cancel to stop the export process.

IMPORTANT Because Revit Architecture renders each of the 300 frames to export the AVI, this
procedure may take a couple of hours to complete.

Play the AVI file

19 Double-click the AVI file to play the walkthrough from the location that you specified previously.

20 Close the file with or without saving it.
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