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Autodesk® MotionBuilder® 2011 
 

for Microsoft® Windows® 
Platform 

Release Notes 

These Release Notes document last minute updates to the Autodesk 
MotionBuilder 2011 software product/documentation. 

The Autodesk MotionBuilder 2011 software for Microsoft Windows is now 
available for purchase through Autodesk resellers. Go 
to http://www.autodesk.com/motionbuilder and click the “Buy” link at the top 
right of the page. 

For current MotionBuilder Subscription customers, the Autodesk 
MotionBuilder 2011 software can be downloaded through the Autodesk 
Subscription Center (Subscription with Gold Support) 
at: http://www.autodesk.com/subscription. 

For information about the MotionBuilder software, or for any downloads, go 
to: http://www.autodesk.com/motionbuilder-support. 

For updates to the MotionBuilder 2011 documentation, go 
to: http://www.autodesk.com/motionbuilder2011-documentation. 

Whether you are new to MotionBuilder, somewhat familiar with MotionBuilder, 
or an advanced MotionBuilder user/software developer, we invite you to 
consult the following Autodesk web pages. 

 http://www.autodesk.com/motionbuilder-learningpath 

 http://www.the-area.com 

 http://www.autodesk.com/fbx 

 http://www.autodesk.com/developmotionbuilder 

 http://www.autodesk.com/motionbuilder-hardware 

For information about the Autodesk Entertainment and Creation Suites, go 
to: http://www.autodesk.com/entertainmentcreationsuites. 

For information about the Autodesk featured software trials, go 
to: http://www.autodesk.com/freetrials. 
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System Requirements 
For information about the Autodesk MotionBuilder 2011 system requirements, go 
to: http://www.autodesk.com/motionbuilder-systemrequirements. 

Certified Hardware 
For information about the Autodesk MotionBuilder 2011 certified hardware, go 
to: http://www.autodesk.com/motionbuilder-hardware. 

Note: The Autodesk Entertainment Creation Suites 2011 for Microsoft include the 
MotionBuilder 2011 software product.  

For information about the Suites’ system requirements and certified hardware components, go 
to: http://www.autodesk.com/entertainmentcreationsuites. 

Installation and Registration 
Install and register your MotionBuilder 2011 software product by following the on-screen 
installation instructions.  

For detailed information about the installation, registration and licensing process, refer to the 
updated Autodesk MotionBuilder 2011 Installation and Licensing Guide posted 
to: http://www.autodesk.com/motionbuilder2011-documentation. 

The default installation path for the 32-bit version of the MotionBuilder 2011 software product 
is C:\Program Files\Autodesk\Autodesk MotionBuilder 2011 32-bit on the following system: 

 Microsoft® Windows® XP Professional 

The default installation path for the 32-bit version of the MotionBuilder 2011 software product 
is C:\Program Files (x86)\Autodesk\Autodesk MotionBuilder 2011 32-bit on the following 
systems: 

 Microsoft® Windows® XP Professional x64 

 Microsoft® Windows Vista® Business x64 Edition 

The default installation path for the 64-bit version of the MotionBuilder 2011 software product 
is C:\Program Files\Autodesk\Autodesk MotionBuilder 2011 64-bit on the following operating 
systems:  

 Microsoft Windows XP Professional x64 

 Microsoft Windows Vista Business x64 Edition 

The default installation path for the ClipArt sample files is: C:\Autodesk\MotionBuilder 
2011\ClipArt. 

Note: If you are installing the MotionBuilder software product from the DVD, the ClipArt 
sample files do not get installed by default. You need to copy the files from the DVD to your 
workstation. 
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New features and enhancements in this Release 
The following describes the new features and enhancements in the MotionBuilder 2011 
software product release. 

File I/O Support 
This release uses the FBX SDK 7.0 as the mechanism to handle file I/O, thus allowing 
optimum compatibility with other Autodesk 3D software products such as Autodesk® 
Maya® and Autodesk® 3ds Max®. The following summarizes the changes to the file 
I/O.  

 You can now open in MotionBuilder 2011 .fbx files created in earlier 
versions of MotionBuilder, however, all files saved in MotionBuilder 2011 
are saved by default in the new FBX file format (version 7.0). 

 You can save (export) .fbx files created in MotionBuilder 2011 to an earlier 
version of FBX by choosing from the main menu Python Tools > FBX Export 
> FBX 2010. 

 
Saving MotionBuilder 2011 to FBX version 2010 ensures compatibility with 
Autodesk version 2010 applications. 

See File I/O limitation. 

 You can now choose File > Open to open or import any .fbx file. As a result, 
the File menu options “FBX Plug-in Import” and “Import” have been 
removed. 

 You can now choose File > Merge to merge any .fbx file. As a result, the File 
menu option “FBX Plug-in Merge” has been removed. 

 You now import motion capture files via File > Motion File Import. As a 
result, the File menu option “Import” has been remove. 

 You now export motion capture files via File > Motion File Export. As a 
result, the File menu option “Export” has been removed. 

See File I/O limitation. 
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Animation Layers Enhancements 
The new Animation Layer editor replaces the Layer pane in the FCurves window. The 
Animation Layer editor lets you create, select, and merge layers of animation. The 
Animation Layer editor lets you manage layer order, and parent, mute, solo, and lock 
layers. It also lets you select various layer blending modes, such as Additive and 
Override, and layer accumulation modes. Each layer has a Weight value that can be 
changed and animated to determine how much of its animation plays in the result 
animation. 

The shades of green used to indicate selected layers in the Animation Layer editor and 
the current layer have been modified to improve visibility. 

In addition, Animation layer functionality is exposed through the new FBAnimationLayer 
class. 

Animation Layers Naming Convention 
The default layer naming convention for layers in the Animation Layer editor has been 
updated to ensure proper interoperability between the MotionBuilder and Maya 
software. As a result, the “Base Layer” is now named “BaseAnimation”, the “Layer 1” is 
now named “AnimLayer1”, and layers you create are now named “AnimLayer2” and so 
on. The same is true when layers are duplicated. 

Note: If you open a file containing older animation layers, the layers are not renamed. 
For example, you may still see a layer called "Layer 1". When you import to the Maya 
software, “Layer 1” is renamed “Layer_1” and when you import back to MotionBuilder, the 
layer name “Layer_1” is retained. 

Materials and Textures Enhancements 
Various enhancements have been made to the materials and textures. The following 
summarizes the main improvements. 

The material, texture, and shader assets are now grouped under the new Asset browser's 
Shading Elements directory. The Shading Elements folder contains the Material asset, as 
well as a Texture asset and a Layered Texture asset meant for use with materials. The 
Global Lighting Texture folder under the Shading Elements directory contains various 
texture and Layered texture assets meant for use with shaders. The Shaders folder under 
the same directory contains all the shaders, including any custom shaders you may have 
on your system. 
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Materials 
The Material settings include new properties and settings. The new properties are 
Displacement, Bump Map, and Normal Map. The new settings include the Intensity 
(or Factor) settings and the Texture list and button. The Intensity settings let you 
adjust and animate each property's influence on the material result. The Texture list 
and button let you attach and detach textures to each property. 

Note: To see the results of textures attached to material properties other than 
Diffuse, Bump Map, and Normal Map, use custom shaders (created using the Open 
Reality® SDK). 

The Material settings can be sorted into two categories: basic and advanced settings. 
The advanced settings require a corresponding shader to display the result in the 
Viewer. For example, to see the result of a texture attached to the Bump Map 
property, a Bump Map or Dynamic Lighting shader needs to be applied to the model. 
Some advanced settings, such as Specularity textures or Reflectivity RGB, need 
custom shaders created using the Open Reality SDK to display the result in the 
Viewer. You can use the Advanced Mode option to disable or activate the advanced 
settings. 

When a model has more than one material (such as a Multi/Sub-Object material) 
applied to it when you import it from a 3D modeling software, such as Autodesk 3ds 
Max, these materials are now listed in the Scene browser and are attached to the 
model. MotionBuilder includes all the materials imported with the model, and 
assumes that material has a corresponding polygon region (also called material IDs) 
on the model. You can modify, replace, or delete materials applied to regions. 
However these regions are set in the 3D modeling software and cannot be altered 
using MotionBuilder. 

Textures 
The material, texture, and shader assets are now organized differently in the Asset 
browser. In addition, textures are now sorted under two categories: textures to be 
used with materials, and Global Lighting textures. In previous versions of 
MotionBuilder, the Texture asset was attached directly to the model. Now, textures, 
meant to add color and detail to a model's appearance, are attached to a material 
property, such as the Diffuse and Bump Map properties. To create textures to be 
used with materials, drag the asset from the Shading Elements folder in the Asset 
browser. Either drop the texture onto a model in the Viewer, or drop it onto a 
material in the Scene browser. A menu appears to let you select the material 
property to which you want to attach the texture. 

Note: To see the results of textures attached to material properties other than 
Diffuse, Bump Map, and Normal Map, use custom shaders created using the Open 
Reality SDK. 

Global Lighting textures are applied directly to the model and are generated by or 
interact with various shaders, such as Shadow Map, Lighted, and Reflection shaders. 
To create Global Lighting textures, expand the Shading Elements folder and drag the 
asset from the Global Lighting Texture folder. 
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The new Layered Texture assets let you blend multiple textures and then adjust the 
result as if it were a single texture. The Layered Texture settings consist of the 
Texture Settings pane (which contain the usual settings), and the Layer Settings 
pane, where you add, manage, and blend multiple textures. 

In Texture settings, there is a new UV Set field that lets you select different UV sets 
(also known as Map Channels) when a model has more than one. Also, the Rotation 
settings have additional functionality. 

Note: The Use Material option has been removed, and the Texture Type menu 
remains only to indicate which type of texture you created. 

Materials and Textures Handling 
The handling of materials and textures has been updated to support the FBX geometry 
model and provide better interoperability with Autodesk Maya and 3ds Max, and to 
improve shader performance. 

The texture / material model now allows transport of currently-dropped channels, and all 
materials now contain mapping channels where you can apply textures to different 
components of the material. This change impacts the SDK as follows: FBFastTessellator 
has been removed. 

Python Tools Menu 
You can now access the Python tools via the Python Tools menu. 

 
The Python tools now include a batch tool script and an FBX Export option to save 
MotionBuilder 2011 files to FBX 2010. 

Note: The FBX 2010 files are not MotionBuilder files. Therefore, anything specific to 
MotionBuilder (such as Story information, devices, etc.) is discarded when using Python 
Tools > FBX Export or when using the FBX Converter. 
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Joint Physical Property Enhancements 
Two options have been added to the Joints solver: Disable collision and Creation type.  

Disable Collision 
The Disable collision option gives you the ability to deactivate the collision effect 
during a solve, letting you control whether the Rigid body objects strike or pass 
through each other. When you activate the Disable collision option, the Rigid body 
objects affected by the solve collide and react with each other. When you disable the 
Disable Collision option, the Rigid Body object reaction to the Joint solve is not 
affected if it collides with another Rigid body object. This ability to disable the 
collision behavior of the solve is useful when you want joint behavior from Rigid 
Body objects but do not want them to collide. 

Creation Type 
The Creation type menu has been added to the Joints solver to let you choose 
between the default Joint solve behavior or the ability to activate the Joint behavior 
only upon setting the solve to live. In previous versions of MotionBuilder, joint 
behavior was created only at the moment when the solver is set to Online. Because 
of this, you must position the affected rigid body objects correctly at the moment of 
solver initialization. To use this behavior, select At Solver Initialization from the Joint 
> Setup > Creation type menu. If you want to activate the joint solve at a specific time 
other than the start of the simulation, select At enable from the Joints > Setup > 
Creation type menu. This new Joint option lets you lets you activate the joint at a 
point in the simulation other than the start, for example when you want a character 
to catch something. This behavior is similar to being able to key and animate the 
joint behavior, much the same way you can turn a constraint on after a certain time 
has elapsed. 

Dynamic Lighting Shader 
Two settings have been added to the Dynamic Lighting shader: Transparency Factor 
slider and the Affecting Lights field.  

Transparency Factor slider 
The Transparency Factor slider lets you manipulate or animate the Transparency 
value for the Dynamic Lighting shader. The default setting is 1.00. A material's 
Transparency settings can also interact with the Dynamic Lighting shader's 
Transparency values and affect the result. 
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Affecting Lights field 
The Affecting Lights field lets you specify which lights illuminate the object to which 
the Dynamic Lighting shader is applied. Since there is a maximum of eight lights 
available in any given MotionBuilder scene due to OpenGL limitations, you can use 
the Affecting Lights field to add lights to the scene. 

Alt-drag any light in your scene into the Affecting Lights field. You can also click the 
Affecting Lights button next to the field to display the Asset list, where you can 
choose from the lights in your scene. 

Note: The Affecting Lights field has the same function as the Selective Lighting 
shader. Do not use the Selective Lighting shader with the Dynamic Lighting shader; 
this may cause problems. Use the Dynamic Lighting shader's Affecting Lights field 
instead. 

Time-independent Keyframes 
Changes have been made to preserve the Bezier-Auto and Bezier-Clamp key types when 
transferring animation in a Maya-MotionBuilder-Maya workflow. 

Bezier-Auto and Bezier-Clamp keyframe types have a new "time-independent" mode. 
When exported to Maya, the new "time-independent" key types are not converted to 
"Fixed" (User) keys. They preserve instead the exact same key type (Maya exact 
equivalent). So when "time-independent", Bezier-Auto keys are Spline in Maya, and 
Clamp keys are Clamp keys in Maya. 

The behavior of the Bezier-Auto and Bezier-Clamp keyframes created in previous 
versions of MotionBuilder is supported in this release. When exported to Maya, these 
keyframes are still converted to a "Fixed" (User) key type. 

Note: Changing the interpolation of any keyframe "resets" the key and the key uses the 
new "time-independent" mode from then on. 

Camera Back/Front Plate 
Image and video files are no longer directly attached to a camera's Back Plate or Front 
Plate. To apply an image or video clip to a camera's Back or Front Plate, drag a texture 
onto the camera or into the Background Texture field in the Camera settings. 
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New Default Layouts 
The default layouts have been revisited and updated. In addition, new default layouts 
have been added to support screen resolutions of 1920 x 1200. 

The updates to the default layouts include the following:  

 The Dynamic Editor window is replaced by the Animation Layer editor. 

 The Navigator window in the Editing layout no longer includes the Motion 
Blend tab. You can however access the Motion Blend window via the 
MotionBuilder Window menu. 

 The Creation, Animation, Editing, Preview, and Story default layouts now 
include a default layout configuration for monitors with a display resolution 
of 1920 x 1200. 

The default layouts reside in the MotionBuilder root directory under 
\bin\config\Layouts\base. These default layouts are also added under 
C:\Users\<username>\AppData\Local\Autodesk\MB2011\config\Layouts\Base after first 
launching the application. 

The custom layouts are saved under 
C:\Users\<username>\AppData\Local\Autodesk\MB2011\config\Layouts on a Vista and 
Windows 7 OS, and in the MotionBuilder root directory under \bin\config\Layouts on a 
Windows XP OS. 

Note: If you installed MotionBuilder 2011 on a Windows Vista or Windows 7 operating 
system, make sure to delete your MB2011 user data saved under 
C:\Users\<username>\AppData\Local\Autodesk before first launching MotionBuilder 
2011. Otherwise, the new default layouts will not overwrite the old default layouts saved 
in the user data. 

Motion Capture on Bones 
Motion capture sensor data can now be associated directly in the motion capture 
hardware with a character's skeleton nodes. This mechanism is demonstrated by the new 
sample Skeleton mocap: deviceskeleton. 

Python Batch Tool Script 
There is a new Python-UI-based batch tool script. The Python code (BatchTool.py) can be 
found in the MotionBuilder root directory under the bin\config\PythonStartup\ folder. 

The Python Batch Tool is accessible via the MotionBuilder Python Tools menu and via 
the Python Editor Tool Manager  button. 

New FBFCurve Functions 
With FBFCurve::KeyDelete you can delete keys within an index range, which is much 
faster than multiple uses of FBFCurve::KeyRemove. 
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Embedding .cgfx Shader Files 
When saving a file, enabling the Embed Medias option in the Save File dialog box now 
embeds CgFX shader media files in the .fbx file. When you reopen the file with the 
embedded media, the media files are extracted to an .fbm folder and the path in the 
CgFX shader settings is updated to point to this .fbm folder. 

New Shape Editing Interface 
The shape editing interface is now exposed to ORSDK & Python. For usage, see 
ShapeCreation.py. 

New function FBComponent::HardSelect() 
In the Viewer or Navigator this both selects and item and shows it in the right pane, 
ready for the user to edit. 

New Sample Code 
FBKeyingGroupLocal.py: shows how to create a cube and add translation, rotation and 
scaling properties of the cube into a custom keying group. 

Autodesk Installation and Licensing 
This release supports the standard Autodesk Installation and licensing scheme to align 
MotionBuilder with the other Autodesk software products and to improve the user-
experience. 

Additional Changes in this Release 
The following describes additional changes to this release of the MotionBuilder software 
product. 

Story Tool Optimization 
The work on Story tool optimization to improve the overall stability and performance is 
ongoing. 

The Story tool evaluation is now part of the MotionBuilder engine. 

Updated Qt Support 
This release of MotionBuilder supports Qt™ version 4.5.2. 
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Updated Python Support 
The MotionBuilder libraries are upgraded to Python® version 2.6.4 (released in October 
2009) – the same version used in the latest Autodesk Maya product. 

This release (as the previous release) of the MotionBuilder software includes the entire 
Python Package – a benefit to users who no longer need to download the entire package 
from http://www.python.org to make use of specific functions that ship with the 
standard Python install. 

NVIDIA PhysX Support 
This release support the NVIDIA® PhysX® solver plug-in. 

Note: You need the NVIDIA PhysX driver to be able to use this plug-in. 

Perforce Support 
This release supports Perforce®. 

Customer Involvement Program Support 
This release enables you to preview your CIP data. To preview your CIP data, go to the 
MotionBuilder Help menu and choose the Customer Involvement Program menu, then 
click the Preview MY CIP Data at the bottom-right corner of the Autodesk Customer 
Involvement Program window. 

Windows 7 Support 
This release of MotionBuilder is supported on the Microsoft Windows® 7 Professional 
on 64-bit Operating Systems (OS). 

IPv6 Support 
This release supports the Internet Protocol version 6 (IPv6, the successor of IPv4). IPv6 
supports the use of a 128-bit address whereas IPv4 supports only the use of a 32-bit 
address. 

Note: IPv6 is on by default. 

See the IPv6 Network limitations. 
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Resolved Issues 
The following describes the issues addressed in the MotionBuilder 2011 software product 
release. 

Plotting to a New Clip 
When you use “Process Tracks/Subtrack To New Clip”, the processed clip now contains 
all the animation from the selected clips. 

Story Custom TimeWarp Curve 
When you edit a Story clips' TimeWarp curve, the TimeWarp curve is now drawn correctly 
and matches the modified Clip In and Mark In settings.  

MotionBuilder differentiates between the length of a clip and the original animation 
data it contains. When you modify a clip, such as shortening or looping, the original 
length of the animation data is not lost. Now, short vertical lines on the TimeWarp curve, 
shown in the following figure (B), indicate the Clip In and Clip Out. 

 

Cutting Multiple Clips 
In the Story window, clicking the Razor button can now slice multiple clips at the same 
time. To razor multiple clips, place the Timeline indicator over the selected clips, then 
click the Razor button. Clips that are not selected are not sliced. 

Blend Properties in Story 
Blend properties in the Story are now saved correctly. Previously, edited blend properties 
were discarded. 

C3D File Import 
C3D files with animation on negative frames no longer cause MotionBuilder to become 
unstable. 
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CgFX Shader Parameters 
Changing the path to CgFX shaders no longer resets its parameters. The CgFX shader 
settings now include the Merge Parameters option. When loading or reloading CgFX 
shaders, activate the Merge Parameters option to keep the shader's property settings 
and references to .dds files. Disable the option to clear these settings when you load or 
reload CgFX shaders. 

Constrained Lights Selected as Affecting Lights 
When lights are part of a constraint, selecting them as the Dynamic Lighting shader's 
Affecting Lights no longer causes MotionBuilder to crash. 

Auxiliary Effectors in the Story Window 
Auxiliary effectors included in additive Character tracks in the Story window now retain 
their Reach and pinning values when the file is saved and reopened. Before, the 
influence of Auxiliary effectors was lost. 

Clip Mark In/Out Values in the Story Window 
In the Story window, when you insert a clip from the current take, and then trim and 
copy/paste the clip, the modified Mark In and Mark Out values are retained. Before, 
these values for the pasted clip were lost. 

Using Box Connectors in Relations Constraint 
In a Relations constraint, clicking a box connector and then pressing Delete no longer 
causes MotionBuilder to crash. 

Bezier Curve Box in Relations Constraint 
When you use a Bezier Curve box in a Relations constraint, switching from Global to 
Local no longer reassigns the connections. The Bezier Curve box now has Vector 
connectors instead of Translation connectors. 

Use Constant Key Reducer Option 
In the Filters preferences of the Preferences window, disabling the Use Constant Key 
Reducer option now turns off both the Constant Key reducer and the Runtime Constant 
Key Reducer. 

Selecting Takes in the Scene Browser 
When you select takes from the Navigator's Scene browser, the Zoom bar in the 
Transport Controls now remains the correct length for each Take. The Zoom bar no 
longer resizes to fit the length of the previously selected take. 
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Resizing the Zoom Bar and Merging Scenes 
When you resize the zoom bar in the Transport controls, then merge a file that contains 
a take, the Zoom bar remains the same and no longer resets to the full length of the 
timeline. 

Pose Controls and Namespace 
Stored poses now work correctly when you merge a scene containing a character with 
the same namespace. You can paste the poses on both characters and obtain the 
expected results. This fix includes poses that involve Character Extensions. 

Far Plane for Producer Top Camera 
When using the Producer Top orthographic camera, you can now use the Far Plane value 
in the Camera Settings to affect clipping beyond 4000 in the Y-axis. In previous 
versions, the maximum functioning value for the Far Plane was 4000. 

Importing Layers: Scale Additive Accumulation Mode 
Since MotionBuilder does not support Maya animation layers that use the Scale Additive 
Accumulation mode, a warning dialog now appears when you import a scene that uses 
this type of layer. You can either use Scale Multiply Accumulation mode in Maya and 
export the file again or you can bake your layers to retain the visual fidelity of your 
animation. 

Reloading Local Keying Group 
When you create a custom Local Keying Group, then save and reload the file, 
MotionBuilder no longer crashes. 

FBPlotPopup in OR SDK and Python 
The dialog that is used to set Plot options is now exposed in the OR SDK and Python. 
FBPlotPopup now displays this dialog that enables users to retrieve FBPlotOptions. 

Accessing Properties on Custom User Object 
You can now access properties on a custom C++ user objects from Python or from C++. 

OR SDK FBProgress Class 
An interrupt callback function has been exposed into the FBProgress class to enable 
users to interrupt operations. See FBProgress.py for usage. Also, Progress bars created 
with FBProgress can now be cancelled in the UI by pressing the escape key. 
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OR SDK Sample Constraint Position 
The OR SDK sample constraintposition has been modified. A change to 
SetupAllAnimationNodes()in orconstraintposition.cxx fixes an issue where local 
FBAnimationNodes could not be created on custom constraints. 

New Functions in FBFCurve 
With FBFCurve::KeyDelete you can delete keys within an index range, which is more 
efficient than multiple uses of FBFCurve::KeyRemove.New functionality is demonstrated 
in CopyAninamation.py. 

Python FBProgress Object 
The Python version of FBProgress:: ProgressDone() now resets the progress bar UI after 
finishing a task. 

FBGeometry Issues with Python Exposure 
The Python versions of FBGeometry::VertexGet and FBGeometry::VertexUVGet now 
function correctly 

FBApplication::FileAppend() 
This function did not work correctly in previous releases and is now fixed. 

BoxLayout in Python 
You can now center a control inside a BoxLayout in Python using the AddRelative 
method. This is demonstrated in the updated BoxLayout.py script. 

Auto Completion in Python Editor 
In the Python editor, the auto completion popup no longer appears off the visible screen 
area in some circumstances. 

Multibyte Characters in Python 
If you edit a script outside of MotionBuilder, it must be encoded with UTF-8 before you 
can open it in the MotionBuilder Python editor. By default, Python assumes all scripts 
are written in ASCII. To use Unicode, declare the encoding in the first or second line of 
your script according to the instructions found 
at: http://www.python.org/dev/peps/pep-0263/. 

FBVector4d in C++ 
In MotionBuilder version 2009 and version 2010, it was not possible to create custom 
properties for this type FBVector4d in C++. This is now fixed 

http://www.python.org/dev/peps/pep-0263/�
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Optical Device Template C++ sample updated 
The OR - Optical Device Template has been updated to correct a behavior in 
MotionBuilder version 2009 and version 2010 where the incoming data stream was not 
being mapped to an optical marker. 

Setting Values with FBSpread 
In previous versions of MotionBuilder, with FBSpread it was only possible to set the cell 
value with SetCellValue. It was not possible to set the value after having chosen a 
specific 'Style' enumeration. This is now fixed. 

Unresolved Issues and Limitations 
The following describes the unresolved issues as well as any limitations in the MotionBuilder 
2011 software product release deemed important to document. 

File I/O 
The following describes the File I/O limitations.  

 FBX files saved in MotionBuilder 2011 cannot be loaded in previous versions 
of MotionBuilder. 

A workaround for this limitation is to either export the MotionBuilder 2011 
.fbx files to an earlier version of FBX by choosing from the main menu 
Python Tools > FBX Export > FBX 2010 or by using the Autodesk FBX 
Converter. 

Note: You can download the latest FBX Converter 
from http://www.autodesk.com/fbx. 

 FBX files saved in MotionBuilder 2011 cannot be loaded in previous versions 
of MotionBuilder. 

 FBX files exported via Python Tools > FBX Export > FBX 2010 tool or the FBX 
Converter tool are FBX SDK files and not MotionBuilder files. This means 
that anything specific to MotionBuilder will be discarded (story 
information, Devices, etc.). 

 FBX file format version 2010 does not support the MotionBuilder 2011 
Animation layers. 

Updating Templates Directory 
Changing the Templates directory via the Asset browser prevents you from 
subsequently launching MotionBuilder. 

On a Windows 7 and Windows Vista OS, to be able to launch MotionBuilder after 
changing the Templates directory, you need to delete your MotionBuilder user data in 
C:\Documents and Settings\<user name>\Application Data\Autodesk\MB2011 or in 
C:\Users\<user name>\AppData\Local\Autodesk\MB2011 or MB2011x64 (to void the 
change to the Templates directory) before launching MotionBuilder. 

http://www.autodesk.com/fbx�
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On a Windows XP Professional OS, to be able to launch MotionBuilder after changing 
the Templates directory, you need to delete the <computername>.History.txt 
configuration file located in C:\Program Files\Autodesk\Autodesk MotionBuilder 
2011\bin\config (to void the change to the Templates directory) before launching 
MotionBuilder. 

Namespaces Specified with FBFbxOptions 
In previous versions of MotionBuilder, a namespace could be specified with 
FBApplication::FileAppend. This is now done with 
FBFbxOptions::CustomImportNamespace. 

Receiver Type Box in a Relation Constraint 
There is a problem getting animation nodes when a sender and receiver box has local 
nodes on both sides. A workaround for this issue is to set them to global. 

IPv6 Network 
The following describes issues related to IPv6 network: 

 Network server and Network client don’t work between Windows 7 and 
Windows Vista in IPv6. 

 On Windows® XP Professional OS, the Autodesk Network License 
Manager doesn’t come with IPv6 packages. 

 The license server cannot be detected when activating a network license on 
IPv6. If you are using a license server on an iPv6 network, the license server 
will not work. 

 The license server cannot be detected when activating a network license on 
IPv6. If you are using a license server on an iPv6 network, the license server 
will not work. 

A workaround for this issue is to download an updated version of the 
Autodesk Network License Manager 
from http://www.autodesk.com/nlm2011-ipv6-windows. This update enables 
the Autodesk Network License Manager to support IPv6 networks using 
Microsoft Windows Server 2008, Windows Vista 32-bit and Windows Vista 
64-bit. 

 
To install the patch: 

1. Shut down your license server. 

2. Back up the contents of the license manager files. By default, these 
are in C:\Program Files\Autodesk Network License Manager. 

3. Download the patch from http://www.autodesk.com/nlm2011-ipv6-
windows. 

http://www.autodesk.com/nlm2011-ipv6-windows�
http://www.autodesk.com/nlm2011-ipv6-windows�
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4. Unzip the patch and paste the new files over the old ones; these are 
located by default in \Program Files\Autodesk Network License 
Manager. (Four files will be overwritten.) 

5. Restart your license server. 

Autodesk Network License Manager IPv6 Support 
The following describes issues related to the updated version of the Autodesk Network 
License Manager:  

 The Autodesk Network License Manager version that ships with the 
Autodesk version 2011 products does not support early return of borrowed 
licenses. 

 The Autodesk Network License Manager version that ships with the 
Autodesk version 2011 products supports only a mixed IPv4 and IPv6 
environment. It does not support network license checkouts in an IPv6-only 
environment. 

OpenGL 
There is a maximum number of eight lights available in any given MotionBuilder scene 
due to OpenGL® limitations. 

The workaround for this limitation is to use Selective Lighting shaders to add lights to 
the scene. For example, you can use Selective Lighting shaders to set up an association 
between lights and objects to increase the number of lights in your scene to eight per 
object.  

Do not append a Selective Lighting shader on the same object to which a Dynamic 
Lighting shader is applied. To work around the OpenGL limitation, you can use the 
Dynamic Lighting shader’s Affecting Lights field instead. 

Dynamic Lighting Shader 
If you select Append to apply the Dynamic Lighting shader when the Default shader is 
also applied to the model, you may see undesirable results, such as flickering. Select 
Replace By Type or Replace All when you apply the Dynamic Lighting shader to detach 
the Default shader. 

FCurves Interpolation 
Some interpolations are lost on merge back to MotionBuilder regardless of how you set 
the Smart Plot option. 

Note: This issue does not occur when merging to a layer other than the BaseAnimation 
layer. 

Layered Textures Set to Additive 
Layered textures set to Additive become combined and clamped between 0 and 1. 
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Customizing Control Rigs and HIK 
The Control rig properties "Solid" look does not show the Extra FK Models. 

The workaround to this limitation is to use the "Default" setting in the Properties Look 
menu when customizing the look of HIK rigs. 

Appending Takes to a Scene 
If you use FBTake to append a take to a scene, the new take does not register with the 
Transport Controls, as it should. 

The workaround for this issue is to use FBTake::CopyTake. For more information, see the 
FBTake Class Reference in the Python or C++ Reference. 

NVIDIA PhysX Soft Body 
The PhysX Soft Body feature is not supported on a 64-bit OS. 

Physics Solving 
The Physics solver does not process degenerated polygons or invalid normals correctly. 
The following issues occur:  

 The Elements > Primitives folder Sphere element contains geometry that 
may produce unpredictable results during these solves. To avoid this issue, 
use the polySphere element in the Asset browser Primitives folder when 
you require a sphere model for Physics solves (such as Rigid body, Joint, or 
Ragdoll). 

 On 64-bit systems, the Physics solver cannot process objects that have 
degenerated polygons or invalid normals. When this occurs, a warning 
message appears to identify the models that have this problematic 
geometry, stating bounding boxes will be used to approximate these shapes 
instead. These bounding boxes provided by MotionBuilder in these cases 
may produce solve results that differ from the expected behavior. If 
possible, use the Cube, Capsule, or Sphere approximations to match your 
geometry with more precision. For more complex geometry, reconstruct 
the model with the degenerated geometry or invalid polygons using 3D 
software to avoid these non-standard geometry problems. 

  



Autodesk MotionBuilder  2011 

  Release Notes – March 30th 2010 

 

Page | 20 

Documentation Updates 
The following describes the updates to the documentation and learning material since the 
release of the MotionBuilder 2011 product. You can download these updated documents 
from: http://www.autodesk.com/motionbuilder2011-documentation. 

MotionBuilder Help 
The Autodesk MotionBuilder 2011 Help has been updated since the MotionBuilder 2011 
release to incorporate minor updates. 

Note: Extract the contents of the .zip file to your default Autodesk MotionBuilder 2011 
64-bit\Help directory or default Autodesk MotionBuilder 2011 32-bit\Help directory. 

MotionBuilder What’s New 
The Autodesk MotionBuilder 2011 What’s New document has been updated since the 
MotionBuilder 2011 release to include an unresolved issue pertaining to the updating of 
the Templates directory. 

MotionBuilder User’s Guide 
The Autodesk MotionBuilder 2011 User’s Guide has been updated since the 
MotionBuilder 2011 release to incorporate minor updates, resolve graphic issues, and 
optimize the file size. 

MotionBuilder Tutorials 
The Autodesk MotionBuilder 2011 Tutorials has been updated since the MotionBuilder 
2011 release to include minor updates to graphics, resolve graphic issues, and optimize 
the file size. 

MotionBuilder Installation and Licensing Guide 
The Autodesk MotionBuilder 2011 Installation and Licensing Guide has been updated 
since the MotionBuilder 2011 release to incorporate minor editorial updates and updates 
pertaining to the license borrowing. 
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