limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of the TIFF portions of this software, even if advised of the possibility of such damage. Portions of Libtiff 3.5.7 Copyright © 1988-1997 Sam Leffler. Copyright © 1991-1997 Silicon Graphics, Inc. Permission to use, copy, modify, distribute, and sell this software and its documentation for any purpose is hereby granted without fee, provided that (i) the above copyright notices and this permission notice appear in all copies of the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used in any advertising or publicity relating to the software without the specific, prior written permission of Sam Leffler and Silicon Graphics.

Portions of Libxml2 2.6.4 Copyright © 1998-2003 Daniel Veillard. All Rights Reserved. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notices and this permission notice shall be included in all copies or substantial portions of the Software.

**Government Use**
Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 12.212 (Commercial Computer Software-Restricted Rights) and DFAR 227.7202 (Rights in Technical Data and Computer Software), as applicable.
## Contents

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1</td>
<td>What's New?</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>New in Revit Structure 2011</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Introduction to Revit</td>
<td>9</td>
</tr>
<tr>
<td>Chapter 2</td>
<td>Building Information Modeling</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td>What Is Revit Structure?</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td>What Is Meant by Parametric?</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td>How Does Revit Structure Keep Things Updated?</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>Understanding Revit Terms</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>Element Behavior in a Parametric Modeler</td>
<td>14</td>
</tr>
<tr>
<td></td>
<td>Element Properties</td>
<td>15</td>
</tr>
<tr>
<td>Chapter 3</td>
<td>Licensing</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Licensing Overview</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Standalone Licensing</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Licensing Extension</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>License Transferring</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>License Borrowing</td>
<td>18</td>
</tr>
<tr>
<td>Chapter 4</td>
<td>User Interface</td>
<td>21</td>
</tr>
<tr>
<td></td>
<td>Ribbon</td>
<td>21</td>
</tr>
<tr>
<td></td>
<td>Customizing the Ribbon</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>Application Menu</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>Quick Access Toolbar</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td>Tooltips</td>
<td>26</td>
</tr>
<tr>
<td></td>
<td>Keystips</td>
<td>27</td>
</tr>
<tr>
<td></td>
<td>Project Browser</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>Using the Project Browser</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>Drawing Area</td>
<td>32</td>
</tr>
<tr>
<td>Chapter 12 Conceptual Design Environment</td>
<td>135</td>
<td></td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>-----</td>
<td></td>
</tr>
<tr>
<td>Conceptual Design Environment Overview</td>
<td>136</td>
<td></td>
</tr>
<tr>
<td>Exploring Conceptual Designs</td>
<td>136</td>
<td></td>
</tr>
<tr>
<td>Early Conceptual Study Models</td>
<td>136</td>
<td></td>
</tr>
<tr>
<td>Integrated Study Models</td>
<td>137</td>
<td></td>
</tr>
<tr>
<td>Intelligent Sub-Components</td>
<td>137</td>
<td></td>
</tr>
<tr>
<td>Conceptual Design Environment Interface</td>
<td>137</td>
<td></td>
</tr>
<tr>
<td>Conceptual Massing Family Creation</td>
<td>138</td>
<td></td>
</tr>
<tr>
<td>Switching between Conceptual Design and Project Environments</td>
<td>138</td>
<td></td>
</tr>
<tr>
<td>Template Files for the Conceptual Design Environment</td>
<td>140</td>
<td></td>
</tr>
<tr>
<td>Drawing in the Conceptual Design Environment</td>
<td>141</td>
<td></td>
</tr>
<tr>
<td>Drawing Overview</td>
<td>141</td>
<td></td>
</tr>
<tr>
<td>3D Snapping</td>
<td>141</td>
<td></td>
</tr>
<tr>
<td>3D Aligning</td>
<td>142</td>
<td></td>
</tr>
<tr>
<td>Conceptual Design Model Line Instance Properties</td>
<td>144</td>
<td></td>
</tr>
<tr>
<td>3D Work Planes</td>
<td>145</td>
<td></td>
</tr>
<tr>
<td>3D Levels</td>
<td>148</td>
<td></td>
</tr>
<tr>
<td>3D Reference Planes</td>
<td>151</td>
<td></td>
</tr>
<tr>
<td>Reference Points</td>
<td>152</td>
<td></td>
</tr>
<tr>
<td>X-Ray Mode</td>
<td>163</td>
<td></td>
</tr>
<tr>
<td>Accessing X-Ray Mode</td>
<td>163</td>
<td></td>
</tr>
<tr>
<td>Display of Elements in X-Ray Mode</td>
<td>163</td>
<td></td>
</tr>
<tr>
<td>Manipulating Forms in X-Ray Mode</td>
<td>164</td>
<td></td>
</tr>
<tr>
<td>Profiles</td>
<td>165</td>
<td></td>
</tr>
<tr>
<td>Locked Profiles</td>
<td>165</td>
<td></td>
</tr>
<tr>
<td>Locking and Unlocking Profiles</td>
<td>166</td>
<td></td>
</tr>
<tr>
<td>Forms</td>
<td>167</td>
<td></td>
</tr>
<tr>
<td>Solid and Void Forms</td>
<td>167</td>
<td></td>
</tr>
<tr>
<td>Creating Solid Forms</td>
<td>168</td>
<td></td>
</tr>
<tr>
<td>Creating Void Forms</td>
<td>170</td>
<td></td>
</tr>
<tr>
<td>Accessing Create Form Tool</td>
<td>170</td>
<td></td>
</tr>
<tr>
<td>Unconstrained and Referenced-Based Forms</td>
<td>171</td>
<td></td>
</tr>
<tr>
<td>Selecting Forms</td>
<td>172</td>
<td></td>
</tr>
<tr>
<td>Form Types</td>
<td>173</td>
<td></td>
</tr>
<tr>
<td>Modifying Forms</td>
<td>180</td>
<td></td>
</tr>
<tr>
<td>Rehosting Forms</td>
<td>184</td>
<td></td>
</tr>
<tr>
<td>Dimensioning Forms</td>
<td>184</td>
<td></td>
</tr>
<tr>
<td>Structural Floors</td>
<td>366</td>
<td></td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>-----</td>
<td></td>
</tr>
<tr>
<td>Isolated Foundations</td>
<td>361</td>
<td></td>
</tr>
<tr>
<td>Wall Foundations</td>
<td>355</td>
<td></td>
</tr>
<tr>
<td>Creating a Wall Foundation</td>
<td>355</td>
<td></td>
</tr>
<tr>
<td>Modifying a Wall Foundation</td>
<td>356</td>
<td></td>
</tr>
<tr>
<td>Default End Extensions</td>
<td>357</td>
<td></td>
</tr>
<tr>
<td>Wall Foundation Breaks Beneath Doors and Windows</td>
<td>357</td>
<td></td>
</tr>
<tr>
<td>Tagging a Wall Foundation with Elevation</td>
<td>358</td>
<td></td>
</tr>
<tr>
<td>Changing the Structural Usage of a Wall Foundation</td>
<td>358</td>
<td></td>
</tr>
<tr>
<td>Wall Foundation Properties</td>
<td>358</td>
<td></td>
</tr>
<tr>
<td>Modifying Wall Foundation Properties</td>
<td>359</td>
<td></td>
</tr>
<tr>
<td>Wall Foundation Type Properties</td>
<td>359</td>
<td></td>
</tr>
<tr>
<td>Wall Foundation Instance Properties</td>
<td>360</td>
<td></td>
</tr>
<tr>
<td>Isolated Foundations</td>
<td>361</td>
<td></td>
</tr>
<tr>
<td>Adding Isolated Foundations</td>
<td>362</td>
<td></td>
</tr>
<tr>
<td>Isolated Foundation Properties</td>
<td>363</td>
<td></td>
</tr>
<tr>
<td>Modifying Isolated Foundation Properties</td>
<td>363</td>
<td></td>
</tr>
<tr>
<td>Isolated Foundation Type Properties</td>
<td>363</td>
<td></td>
</tr>
<tr>
<td>Isolated Foundation Instance Properties</td>
<td>364</td>
<td></td>
</tr>
<tr>
<td>Structural Floors</td>
<td>366</td>
<td></td>
</tr>
<tr>
<td>Adding a Structural Floor or Deck</td>
<td>366</td>
<td></td>
</tr>
<tr>
<td>Cantilevers</td>
<td>367</td>
<td></td>
</tr>
<tr>
<td>Applying Cantilevers when Creating a Structural Floor</td>
<td>368</td>
<td></td>
</tr>
<tr>
<td>Applying Cantilevers to an Existing Structural Floor</td>
<td>368</td>
<td></td>
</tr>
<tr>
<td>Span Direction</td>
<td>369</td>
<td></td>
</tr>
<tr>
<td>Adding a Span Direction</td>
<td>370</td>
<td></td>
</tr>
<tr>
<td>Modifying Span Direction</td>
<td>371</td>
<td></td>
</tr>
<tr>
<td>Sloped Structural Floors</td>
<td>372</td>
<td></td>
</tr>
<tr>
<td>Openings in Structural Floors</td>
<td>372</td>
<td></td>
</tr>
<tr>
<td>Drop Panels</td>
<td>373</td>
<td></td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
<td></td>
</tr>
<tr>
<td>---------------------------------------------------------------</td>
<td>------</td>
<td></td>
</tr>
<tr>
<td>Modifying Structural Floors</td>
<td>375</td>
<td></td>
</tr>
<tr>
<td>Structural Floor Properties</td>
<td>376</td>
<td></td>
</tr>
<tr>
<td>Modifying Structural Floor Properties</td>
<td>376</td>
<td></td>
</tr>
<tr>
<td>Structural Floor Type Properties</td>
<td>376</td>
<td></td>
</tr>
<tr>
<td>Structural Floor Instance Properties</td>
<td>377</td>
<td></td>
</tr>
<tr>
<td>Slab Edges</td>
<td>379</td>
<td></td>
</tr>
<tr>
<td>Resizing or Flipping Slab Edges</td>
<td>380</td>
<td></td>
</tr>
<tr>
<td>Adding or Removing Segments of the Slab Edge</td>
<td>380</td>
<td></td>
</tr>
<tr>
<td>Changing Horizontal and Vertical Offsets of Slab Edges</td>
<td>380</td>
<td></td>
</tr>
<tr>
<td>Slab Edge Properties</td>
<td>380</td>
<td></td>
</tr>
<tr>
<td>Foundation Slabs</td>
<td>382</td>
<td></td>
</tr>
<tr>
<td>Adding Foundation Slabs</td>
<td>382</td>
<td></td>
</tr>
<tr>
<td>Modifying Foundation Slab Properties</td>
<td>383</td>
<td></td>
</tr>
<tr>
<td>Foundation Slab Properties</td>
<td>383</td>
<td></td>
</tr>
<tr>
<td>Shape Editing for Structural Floors, Roofs, and Floors</td>
<td>386</td>
<td></td>
</tr>
<tr>
<td>Using the Modify Sub Elements Tool</td>
<td>387</td>
<td></td>
</tr>
<tr>
<td>Using the Add Point Tool</td>
<td>388</td>
<td></td>
</tr>
<tr>
<td>Using the Add Split Line Tool</td>
<td>389</td>
<td></td>
</tr>
<tr>
<td>Using the Pick Supports Tool</td>
<td>390</td>
<td></td>
</tr>
<tr>
<td>Using the Curved Edge Condition Tool</td>
<td>390</td>
<td></td>
</tr>
<tr>
<td>Using the Reset Shape Tool</td>
<td>391</td>
<td></td>
</tr>
<tr>
<td>Deleting Shape Modifiers</td>
<td>391</td>
<td></td>
</tr>
<tr>
<td>Variable Layer Thickness for Roofs and Structural Floors</td>
<td>392</td>
<td></td>
</tr>
<tr>
<td>Concrete Modeling Concepts</td>
<td>393</td>
<td></td>
</tr>
<tr>
<td>Concrete Geometry Joins</td>
<td>393</td>
<td></td>
</tr>
<tr>
<td>Legacy Drawing Behaviors</td>
<td>394</td>
<td></td>
</tr>
<tr>
<td>Valid Concrete Element Join Combinations</td>
<td>394</td>
<td></td>
</tr>
<tr>
<td>Dominant Elements in a Concrete Join</td>
<td>395</td>
<td></td>
</tr>
<tr>
<td>Display of Hidden Lines of Structural Concrete Components</td>
<td>395</td>
<td></td>
</tr>
<tr>
<td>Chapter 14 Reinforcement</td>
<td>397</td>
<td></td>
</tr>
<tr>
<td>Reinforcement Tools</td>
<td>397</td>
<td></td>
</tr>
<tr>
<td>Valid Rebar Hosts</td>
<td>398</td>
<td></td>
</tr>
<tr>
<td>Rebar Cover</td>
<td>399</td>
<td></td>
</tr>
<tr>
<td>Rebar Cover References</td>
<td>399</td>
<td></td>
</tr>
<tr>
<td>Editing Rebar Cover</td>
<td>399</td>
<td></td>
</tr>
<tr>
<td>Modifying Rebar Cover Settings</td>
<td>400</td>
<td></td>
</tr>
<tr>
<td>Rebar Cover Element Properties</td>
<td>401</td>
<td></td>
</tr>
<tr>
<td>Rebar Shapes</td>
<td>402</td>
<td></td>
</tr>
<tr>
<td>Placing Rebar Shapes in a Host</td>
<td>403</td>
<td></td>
</tr>
<tr>
<td>Add Rebar to a Column</td>
<td>403</td>
<td></td>
</tr>
<tr>
<td>Adding Rebar to a Beam</td>
<td>405</td>
<td></td>
</tr>
<tr>
<td>Plane Placement of Rebar in Walls and Structural Floors</td>
<td>407</td>
<td></td>
</tr>
<tr>
<td>Rehosting Rebar Shapes</td>
<td>409</td>
<td></td>
</tr>
<tr>
<td>Changing the Orientation of Rebar Shapes</td>
<td>410</td>
<td></td>
</tr>
<tr>
<td>Auto-Expand Behavior of Rebar Shapes</td>
<td>411</td>
<td></td>
</tr>
<tr>
<td>Modifying Rebar Shape</td>
<td>413</td>
<td></td>
</tr>
<tr>
<td>Select a New Rebar Shape</td>
<td>415</td>
<td></td>
</tr>
<tr>
<td>Spiral Rebar</td>
<td>415</td>
<td></td>
</tr>
<tr>
<td>Select a New Rebar Bar Type</td>
<td>417</td>
<td></td>
</tr>
<tr>
<td>Modify a Rebar Sketch</td>
<td>417</td>
<td></td>
</tr>
<tr>
<td>Sketch Placement of Rebar</td>
<td>417</td>
<td></td>
</tr>
<tr>
<td>Rebar Shape Family Editing Tools</td>
<td>418</td>
<td></td>
</tr>
<tr>
<td>Rebar Line</td>
<td>419</td>
<td></td>
</tr>
<tr>
<td>Major Segment</td>
<td>419</td>
<td></td>
</tr>
<tr>
<td>Shape Status</td>
<td>419</td>
<td></td>
</tr>
<tr>
<td>Rebar Shape Parameters</td>
<td>420</td>
<td></td>
</tr>
<tr>
<td>Allowable Bar Types</td>
<td>420</td>
<td></td>
</tr>
<tr>
<td>Rebar Schedule Mark</td>
<td>420</td>
<td></td>
</tr>
</tbody>
</table>
## Contents

<table>
<thead>
<tr>
<th>Chapter 15</th>
<th>Walls</th>
<th>449</th>
</tr>
</thead>
<tbody>
<tr>
<td>Placing Walls</td>
<td>450</td>
<td></td>
</tr>
<tr>
<td>Modifying Walls</td>
<td>452</td>
<td></td>
</tr>
<tr>
<td>Wall Best Practices</td>
<td>454</td>
<td></td>
</tr>
<tr>
<td>Wall Type Properties</td>
<td>487</td>
<td></td>
</tr>
<tr>
<td>Wall Instance Properties</td>
<td>488</td>
<td></td>
</tr>
<tr>
<td>Troubleshooting Walls</td>
<td>490</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 16</th>
<th>Doors</th>
<th>491</th>
</tr>
</thead>
<tbody>
<tr>
<td>Placing Doors</td>
<td>492</td>
<td></td>
</tr>
<tr>
<td>Adding Doors to Curtain Walls</td>
<td>493</td>
<td></td>
</tr>
<tr>
<td>Door Tags</td>
<td>493</td>
<td></td>
</tr>
<tr>
<td>Changing the Door Type</td>
<td>494</td>
<td></td>
</tr>
<tr>
<td>Changing the Door Orientation</td>
<td>494</td>
<td></td>
</tr>
<tr>
<td>Moving a Door to a Different Wall</td>
<td>494</td>
<td></td>
</tr>
<tr>
<td>Door Instance Properties</td>
<td>495</td>
<td></td>
</tr>
<tr>
<td>Door Type Properties</td>
<td>496</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 17</th>
<th>Windows</th>
<th>499</th>
</tr>
</thead>
<tbody>
<tr>
<td>Placing Windows</td>
<td>499</td>
<td></td>
</tr>
<tr>
<td>Window Tags</td>
<td>500</td>
<td></td>
</tr>
<tr>
<td>Changing the Window Type</td>
<td>500</td>
<td></td>
</tr>
</tbody>
</table>

Architectural Modeling | 445 |

Building The Model | 447 |
Chapter 26  Sloped Surfaces ......................................................... 579
  Sloped Surfaces Overview ................................................. 579
  Creating a Sloped Surface Using a Slope Arrow ................. 581
  Creating a Sloped Surface Using Parallel Sketch Lines .... 583
  Creating a Sloped Surface Using a Single Sketch Line .... 583
  Slope Arrow Properties .................................................... 584
  Boundary Line Properties for Sloped Surfaces ................. 585

Chapter 27  Uniformat Assembly Codes ........................................ 587

Chapter 28  Stairs ................................................................. 591
  Creating Stairs by Sketching Runs .................................... 592
  Creating Stairs by Sketching Boundary and Riser Lines ...... 595
  Creating Spiral Staircases ............................................... 596
  Creating Arced Landings ............................................... 597
  Specifying the Railing Type for New Stairs .................... 597
  Stair Calculator ............................................................ 598
  Modifying Stairs ........................................................... 599
  Stair Properties ............................................................. 601

Chapter 29  Ramps ................................................................. 607
  Adding a Ramp ................................................................ 607
  Changing the Ramp Type .................................................. 608
  Editing a Ramp ............................................................... 608
  Ramp Properties .............................................................. 608

Chapter 30  Railings ............................................................... 611
  Adding a Railing .............................................................. 611
  Changing the Railing Type ............................................... 612
  Modifying the Railing Structure ....................................... 612
  Modifying Railing Joins .................................................... 613
  Modifying Railing Height and Slope ............................... 613
  Controlling Placement of Balusters and Posts ................. 614
  Railing Properties ........................................................... 619

Chapter 31  Curtain Elements ...................................................... 623
  Curtain Wall Workflow ..................................................... 623
  Curtain Elements Overview ............................................. 623
    Curtain Walls ............................................................... 623
    Creating Linear Curtain Walls ...................................... 625
    Merging Tips .............................................................. 626
    Creating Non-Linear Curtain Walls ............................... 627
## Chapter 32 Design Options

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design Option Overview</td>
<td>653</td>
</tr>
<tr>
<td>Design Option Workflow</td>
<td>654</td>
</tr>
<tr>
<td>Design Options Terminology</td>
<td>655</td>
</tr>
<tr>
<td>Best Practices for Design Options</td>
<td>656</td>
</tr>
<tr>
<td>Creating Design Option Sets</td>
<td>657</td>
</tr>
<tr>
<td>Adding Design Options</td>
<td>658</td>
</tr>
<tr>
<td>Working with Design Options</td>
<td>659</td>
</tr>
<tr>
<td>Editing a Design Option</td>
<td>659</td>
</tr>
<tr>
<td>Determining the Active Option</td>
<td>660</td>
</tr>
<tr>
<td>Promoting a Secondary Option to the Primary Option</td>
<td>661</td>
</tr>
<tr>
<td>Moving Elements from the Main Model to a Design Option Set</td>
<td>661</td>
</tr>
</tbody>
</table>
### Chapter 33  **Revit Families**  

**Families Overview** ............................................... 677  
**Different Kinds of Families** ........................................ 678  
**Family Editor** .......................................................... 678  
**Opening the Family Editor** ......................................... 679  
**The Families Guide** .................................................... 680  

**Working with Families** ............................................... 680  
**Viewing Families in a Project or Template** ....................... 680  
**Viewing Elements with a Specific Family Type in a Project** ...... 681  
**Creating an Element from a Family Type** .......................... 681  
**Changing the Family Type of an Element** .......................... 682  
**Modifying a Family Type** ............................................. 682  
**Editing Labeled Dimensions** ......................................... 682  
**Locking Dimensions** .................................................. 682  
**Adding a Type to a Family** .......................................... 683  
**Deleting Unused Families and Family Types** ....................... 683  

**System Families** ...................................................... 684  
**Revit System Families and Settings** ................................ 684  
**Workflow: Using System Families in Your Projects** ............... 686  
**Loading System Family Types** ....................................... 686  

**Loadable Families** .................................................... 687  
**Revit Structure Standard Loadable Families** ....................... 687  
**Workflow: Using Loadable Families in Your Projects** .............. 688  
**Loading and Saving Families** ......................................... 688  
**Creating Loadable Families** ........................................... 691  
**Modifying Families in a Project (or Nested Family)** .............. 692  
**Creating Parameters** .................................................. 692  
**Creating Family Parameter Links** .................................... 694  
**Family Category and Parameters** ..................................... 695  
**Working with Shared Components in a Project** ....................... 695  

**In-Place Elements** ................................................... 696
<table>
<thead>
<tr>
<th>Chapter 34 Rooms and Areas</th>
<th>711</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rooms and Areas Overview</td>
<td>711</td>
</tr>
<tr>
<td>Area Analysis</td>
<td>711</td>
</tr>
<tr>
<td>Area Schemes</td>
<td>711</td>
</tr>
<tr>
<td>Area Plans</td>
<td>712</td>
</tr>
<tr>
<td>Area Boundaries</td>
<td>713</td>
</tr>
<tr>
<td>Areas and Area Tags</td>
<td>714</td>
</tr>
<tr>
<td>Removing Areas</td>
<td>716</td>
</tr>
<tr>
<td>Showing Areas and Area Boundaries in Linked Models</td>
<td>718</td>
</tr>
<tr>
<td>Area Types</td>
<td>718</td>
</tr>
<tr>
<td>Area Type Rules</td>
<td>719</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 35 2D Views</th>
<th>725</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan Views</td>
<td>725</td>
</tr>
<tr>
<td>Creating a Plan View</td>
<td>725</td>
</tr>
<tr>
<td>Plan View Direction</td>
<td>725</td>
</tr>
<tr>
<td>Cutting a Plan View by the Back Clip Plane</td>
<td>727</td>
</tr>
<tr>
<td>Plan View Properties</td>
<td>729</td>
</tr>
<tr>
<td>Displaying a Plan View</td>
<td>729</td>
</tr>
<tr>
<td>Plan Region</td>
<td>729</td>
</tr>
<tr>
<td>Elevation Views</td>
<td>730</td>
</tr>
<tr>
<td>Creating an Elevation View</td>
<td>730</td>
</tr>
<tr>
<td>Displaying an Elevation View</td>
<td>731</td>
</tr>
<tr>
<td>Changing the Elevation Symbol</td>
<td>732</td>
</tr>
<tr>
<td>Changing the Clip Plane in an Elevation View</td>
<td>732</td>
</tr>
<tr>
<td>Reference Elevation</td>
<td>732</td>
</tr>
<tr>
<td>Framing Elevation Views</td>
<td>733</td>
</tr>
<tr>
<td>Creating Custom Elevation Tags</td>
<td>734</td>
</tr>
<tr>
<td>Elevation View Properties</td>
<td>737</td>
</tr>
<tr>
<td>Section Views</td>
<td>737</td>
</tr>
<tr>
<td>Creating a Section View</td>
<td>737</td>
</tr>
<tr>
<td>Section Tag Visibility</td>
<td>738</td>
</tr>
<tr>
<td>Breaking Section Lines</td>
<td>739</td>
</tr>
<tr>
<td>Controlling Section View Width and Depth</td>
<td>740</td>
</tr>
<tr>
<td>Segmented Section View</td>
<td>740</td>
</tr>
<tr>
<td>Reference Sections</td>
<td>742</td>
</tr>
<tr>
<td>Hiding the Section Annotation Symbol</td>
<td>743</td>
</tr>
<tr>
<td>Displaying a Section View</td>
<td>743</td>
</tr>
<tr>
<td>Section Heads</td>
<td>744</td>
</tr>
<tr>
<td>Section View Properties</td>
<td>745</td>
</tr>
<tr>
<td>Callout Views</td>
<td>746</td>
</tr>
<tr>
<td>Callouts Overview</td>
<td>746</td>
</tr>
</tbody>
</table>
### Chapter 36 3D Views
- Creating an Orthographic 3D View .................................................. 757
- Creating a Perspective 3D View ..................................................... 758
- Adjusting the Camera Position ..................................................... 758
  - Specifying Camera Position in a 3D View ..................................... 758
  - Modifying the Camera Position in a Perspective 3D View ............... 758
  - Turning Off the Camera in a 3D View ........................................ 760
- Displaying a 3D View ................................................................. 760
- Rotating a 3D View ..................................................................... 760
- Specifying the Background for a 3D View .................................... 761
- Change the Extents of a 3D View ................................................. 762
- 3D View Properties ..................................................................... 763

### Chapter 37 Legend Views
- Creating a Legend ........................................................................ 768
- Dimensioning Legend Components ............................................. 769
- Placing Components from a Legend into a Project View .................. 769
- Modifying Legend Component Properties .................................... 769

### Chapter 38 Schedules
- Schedule Overview ...................................................................... 771
- Creating a Schedule or Quantity ................................................ 772
- Key Schedules ........................................................................... 772
  - Creating a Key Schedule .......................................................... 773
  - Applying a Key to an Element .................................................. 773
  - Applying the Key to a Component Schedule ............................. 773
- Material Takeoff Schedules ........................................................ 774
  - Creating a Material Takeoff Schedule ....................................... 774
- Annotation Schedules (Note Blocks) .......................................... 774
  - Creating an Annotation Schedule (Note Block) ......................... 774
- Graphical Column Schedules ...................................................... 775
  - Including Off-Grid Columns .................................................... 776
  - Hiding Levels in Graphical Column Schedules ......................... 782
  - Displaying by Plan Level Range .............................................. 783
  - Displaying by Column Location Range ................................... 783
  - Displaying by Column Materials ............................................. 783
  - Changing the Text Properties of the Graphical Column Schedule 784
  - Changing the Grid Properties of the Graphical Column Schedule 784
  - Changing the Display Properties of the Columns ..................... 785
  - Splitting the Schedule into Segments ....................................... 786
  - Tag the Columns in a Schedule ............................................... 786
  - Grouping Columns by Similar Locations .................................. 786
  - Applying the Schedule to a Sheet .......................................... 787
  - View Parameters of Graphical Column Schedules .................... 787
- Specifying Schedule Properties .................................................. 788
  - Selecting Fields for a Schedule .............................................. 788
  - Limiting Data Presented in a Schedule .................................... 789
  - Sorting Fields in a Schedule ................................................... 790
  - Adding Grand Totals to a Schedule ....................................... 790
  - Adding Column Totals to a Schedule ..................................... 791
Cut a View by the Far Clip Plane .................................................... 854
Finding Referring Views .............................................................. 855
Finding a View Symbol ............................................................... 855
Customizing Project View Organization in the Project Browser ........... 855
  Sorting Views or Sheets in the Project Browser .......................... 856
  Creating a Project Browser Sort Group ...................................... 856
  Editing a Project Browser Sort Group ........................................ 857
  Adding a Filter to a Project Browser Sort Group ......................... 857
  Editing a Project Browser Filter .............................................. 857
Creating a View List ................................................................. 858
Using View Lists ........................................................................ 858
  Adding a View List to a Sheet .................................................. 859
Reusing Views and Sheets in Other Projects ................................... 859
View Settings .............................................................................. 859
  Zooming Project Views ............................................................ 860
  View Scale ............................................................................. 860
  Detail Levels and Display of Structural Components .................. 861
  Display of Hidden Lines of Structural Concrete Components ....... 861
  Showing Hidden Element Lines .............................................. 862
  Section, Elevation, and Callout View Tag Setup ............................ 862
  View Range ........................................................................... 864
  Visual Styles ........................................................................... 867
  Graphic Display Options ......................................................... 871
View Properties ........................................................................... 873

Chapter 41 Project Phasing .............................................................. 877
Phase Properties ........................................................................... 877
Creating Phases ........................................................................... 878
Combining Phases ....................................................................... 879
Phase Filters ................................................................................ 879
  Creating Phase Filters ............................................................ 880
  Applying Phase Filters ............................................................ 880
  Defining the Graphic Display for Phase Filters ......................... 880
  Defining the Graphic Display for Phase Statuses ...................... 880
Infill Elements for Phasing ............................................................ 881
Viewing Infill Elements ............................................................... 882
Changing the Structure of Infill Elements ...................................... 882
Demolishing Elements ................................................................ 883
  Using the Demolish Tool ........................................................ 885

Chapter 42 Annotating ................................................................. 887
Dimensions ................................................................................ 887
  Temporary Dimensions .......................................................... 887
  Permanent Dimensions .......................................................... 888
  Spot Dimensions .................................................................... 902
  Listening Dimensions ............................................................ 909
  Dimension Witness Lines ........................................................ 910
  Modifying Dimensions .......................................................... 912
  Dimension Properties ............................................................. 916
Text Notes .................................................................................... 926
  Adding Text Notes ................................................................. 926
  Modifying Text Notes ............................................................. 929
  Text Note Properties .............................................................. 936
Keynotes ...................................................................................... 938
  Differences Between Keynoting and Tagging a Material ............ 938
  Keynoting Settings ................................................................. 939
  Keynote Workflow ................................................................. 939
  Types of Keynotes ................................................................. 940
Assigning Keynote Values ................................................................. 941
Keynote Legend .............................................................................. 941
Adding Additional Categories .......................................................... 942
Resolving Keynote File Errors ......................................................... 944
Keynote Tag Ends ........................................................................... 944
Tags .................................................................................................. 944
  Tag Labels ...................................................................................... 944
  Multiple Tags for Families .............................................................. 945
  Applying a Tag By Category .......................................................... 945
  Applying a Tag On Placement ....................................................... 946
  Changing a Tag Instance ............................................................... 946
  Aligning Tags ................................................................................. 947
  Tag Type Properties ...................................................................... 947
  Tag Instance Properties ................................................................ 947
  Tag All Not Tagged ....................................................................... 947
  Material Tags ............................................................................... 948
  Modifying Tags ............................................................................. 949
Symbols ............................................................................................. 951
  Welding Symbols ......................................................................... 951
  Modifying Symbols ...................................................................... 952
  Annotation Symbols .................................................................... 953

Chapter 43 Detailing ........................................................................ 955
Detailing Overview .......................................................................... 955
  Types of Views for Detailing ........................................................ 955
  Creating Details .......................................................................... 955
  Sorting the Draw Order of Detail Components ................................ 958
  Saving Views ............................................................................... 959
Detail Views ....................................................................................... 959
  Sample Detail View ..................................................................... 959
  Creating a Detail View .................................................................. 960
  Detail View Properties .................................................................. 962
  Reusing Details From Callouts ..................................................... 962
Drafting Views .................................................................................. 964
  Sample Drafting View .................................................................. 964
  Creating a Drafting View ............................................................. 964
  Sketching a Detail in a Drafting View ......................................... 965
  Importing a View From Another CAD Program ........................... 965
  Drafting View Display and Filled Regions .................................... 966
  Drafting View Properties ............................................................ 966
  Reusing Drafting Views ............................................................... 966
Inserting a Detail Component ............................................................ 967
  Creating a Detail Component Family ........................................... 968
  Creating a 2D Line-Based Detail Component Family .................. 968
Detail Lines ....................................................................................... 969
Repeating Detail .............................................................................. 969
Insulation ........................................................................................... 971
  Adding Insulation ..................................................................... 971
  Increasing the Insulation Size ...................................................... 971
  Resizing the Insulation Length .................................................... 971
  Resizing the Bulge Between Insulation Lines ............................. 972
Filled Region .................................................................................... 972
  Changing Filled Region Properties ......................................... 972
  Resizing the Filled Region .......................................................... 972
  Viewing the Area of a Filled Region ............................................ 973
Masking Regions .............................................................................. 973
  Adding a Masking Region in a Project ...................................... 973
  Adding a Masking Region to a Detail Family ............................... 973
  Masking Regions in Model Families .......................................... 974
Chapter 44 Preparing Construction Documents  .................................................. 977
Construction Documents Overview ................................................................. 977
Sheets .............................................. 978
Adding a Sheet ................................. 979
Adding Views to a Sheet ................................. 980
Aligning Views on a Sheet ................................. 982
Aligning View Titles on a Sheet ................................. 984
Locking the Position of a View on a Sheet ................................. 984
Renaming a Sheet ................................. 985
Specifying Title Block Information for Sheets ................................. 985
Modifying a View on a Sheet ................................. 987
Dividing a View Across Multiple Sheets ................................. 987
Rotating a View on a Sheet ................................. 988
Creating a Title Sheet ................................. 989
Adding a Legend to a Sheet ................................. 990
Adding a Note Block to a Sheet ................................. 991
Using External Information on a Sheet ................................. 992
Sheet Properties ................................. 993
Title Blocks ........................................... 995
Creating a Title Block ................................. 995
Modifying a Title Block ................................. 996
Logos and Images in a Title Block ................................. 996
Loading a Title Block into a Project ................................. 997
Changing the Title Block Used on a Sheet ................................. 998
Revision Schedules on Title Blocks ................................. 998
Adding Custom Fields to a Title Block ................................. 1003
Importing a Title Block from Another CAD Program ................................. 1004
Viewports ........................................... 1005
Creating a Viewport Type ................................. 1006
Applying a Viewport Type ................................. 1006
Modifying Viewport Type Properties ................................. 1007
Viewport Type Properties ................................. 1007
View Titles on Sheets ........................................... 1007
Creating a View Title on a Sheet ................................. 1008
Removing a View Title from a Sheet ................................. 1009
View Title Types ................................. 1009
Schedules on Sheets ........................................... 1011
Creating a Schedule on a Sheet ................................. 1011
Filtering Schedule on a Sheet ................................. 1012
Splitting a Schedule on a Sheet ................................. 1012
Adjusting Schedule Columns on a Sheet ................................. 1014
Displaying Vertical Headings in a Schedule on a Sheet ................................. 1014
Sheet Lists ........................................... 1015
Creating a Sheet List ................................. 1015
Adding Placeholder Sheets to a Sheet List ................................. 1015
Omitting Sheets from a Sheet List ................................. 1016
Adding a Sheet List to a Sheet ................................. 1017
Organizing a Sheet List ................................. 1017
Revisions ........................................... 1018
Revision Workflow ................................. 1019
Entering Revision Information ................................. 1019
Merging Revisions ................................. 1020
Changing the Order of Revisions ................................. 1020
Chapter 48 Linked Models ................................................. 1177

Overview of Linked Models ............................................. 1177
When to Link Models .................................................... 1178
Dimensions and Constraints in Linked Models ...................... 1178
Repeating a Linked Model in the Host Model ....................... 1179
Nesting Linked Models ................................................... 1179
Phases and Linked Models .............................................. 1180
Transferring Project Standards Between Linked Models .......... 1181
Linking and Worksharing ............................................... 1181
Directory Paths for Linked Models .................................... 1181
Workflow for Linking Models .......................................... 1182
Linking Revit Models .................................................... 1183
Linking One Model to Another ......................................... 1183
Showing or Hiding Nested Models .................................... 1184
Mapping Phases Between Linked Models ............................. 1184
Copying a Linked Model in the Host Model .......................... 1185
Copying Elements from a Linked Model ............................. 1185
Selecting Elements in a Linked Model ............................... 1186
Visibility of Linked Models ............................................ 1187
Overview of Visibility of Linked Models ............................. 1187
View Filters for Linked Models ........................................ 1188
Displaying a Linked Model by Host View ............................ 1192
Displaying a Linked Model by Linked View ........................ 1192
Using Custom Settings to Display Linked Models .................. 1194
Hiding a Linked Model in a View ..................................... 1195

Collaborate with Others ................................................. 1175
Chapter 51 Interference Checking ................................................................. 1261

Chapter 52 Shared Positioning ................................................................. 1265

Chapter 53 The Structural Analytical Model .............................................. 1277

Copy/Monitor Parameters for Floors ....................................................... 1254
Stopping Element Monitoring ............................................................... 1254
Coordination Review ............................................................................. 1255
Reviewing Warnings for Monitored Elements ......................................... 1255
Creating a Coordination Review Report .................................................. 1256
Actions for Coordination Review ........................................................... 1256
Copy/Monitor Best Practices .................................................................. 1257
Troubleshooting Copy/Monitor Issues ..................................................... 1258
Cannot See Monitored Elements in View ............................................... 1258
Coordination Monitor Alert ..................................................................... 1258
Instance of Linked RVT File Needs Coordination Review ......................... 1258
Site Plan Was Deleted ............................................................................ 1259
Walls Copied to Revit Structure Are Inaccurate ....................................... 1259

Analyse the Design .................................................................................. 1275

Creating a Coordination Review Report .................................................. 1256
Actions for Coordination Review ........................................................... 1256
Copy/Monitor Best Practices .................................................................. 1257
Troubleshooting Copy/Monitor Issues ..................................................... 1258
Cannot See Monitored Elements in View ............................................... 1258
Coordination Monitor Alert ..................................................................... 1258
Instance of Linked RVT File Needs Coordination Review ......................... 1258
Site Plan Was Deleted ............................................................................ 1259
Walls Copied to Revit Structure Are Inaccurate ....................................... 1259

Chapter 53 The Structural Analytical Model .............................................. 1277

Structural Analytical Model Overview .................................................... 1277
Visualization .......................................................................................... 1279
Structural Member Analytical Models ..................................................... 1281
Analytical Model Settings ....................................................................... 1285
Physical Views and Analytical Views ....................................................... 1285
Analytical Model Continuity .................................................................... 1286
Examples of End Join Continuity ............................................................ 1287
Automatic Adjustment of the Analytical Model (Auto-Detect) ..................... 1288
Analytical Projection Rules ....................................................................... 1289
Examples of Auto-Detect ........................................................................ 1292
Auto-Detect Tolerances .......................................................................... 1294
Manual Adjustment of the Analytical Model .............................................. 1295
Walls of Unequal Width ......................................................................... 1295
Columns Offset in Plan View .................................................................... 1296
Adjusting Columns to Beams .................................................................. 1297
Adjusting Walls to Beams ....................................................................... 1299
Wall Joins ............................................................................................... 1300
Projection Plane Options for each Structural Element Type ..................... 1301
### Chapter 55 Solar Studies
- Solar Studies Overview ........................................... 1373
- Solar Studies Workflow .......................................... 1374
- Setting up and Creating Solar Studies ........................................... 1374
  - Creating Views for Solar Studies ........................................... 1374
  - Displaying Sun and Shadows ........................................... 1375
  - Creating Solar Studies ........................................... 1376
- Previewing Solar Study Animations ........................................... 1387
- Saving Solar Study Images to Projects ........................................... 1387
- Exporting Solar Studies ........................................... 1388
- Troubleshooting Solar Study Issues ........................................... 1389
- Working with Sun Settings ........................................... 1390
  - Specifying a Sun Setting ........................................... 1390
  - Using Sun Setting Presets ........................................... 1392
  - Sun Settings in Upgraded Projects ........................................... 1394

### Chapter 56 Display Styles for Analysis Add-In Applications
- Analysis Visualization Overview ........................................... 1396
- Analysis Display Styles ........................................... 1396
- Analysis Display Styles Workflow ........................................... 1397
- Styles Tools ........................................... 1397
- Analysis Results ........................................... 1401
  - Saving the Analysis Results View ........................................... 1402
  - Analysis Result and Legend Element Properties ........................................... 1402

### Chapter 57 Sketching
- Sketching Terminology ........................................... 1405
- Sketching Elements ........................................... 1406
  - Sketching a Line ........................................... 1407
  - Sketching a Rectangle ........................................... 1408
  - Sketching a Circle ........................................... 1408
  - Sketching an Inscribed Polygon ........................................... 1409
  - Sketching a Circumscribed Polygon ........................................... 1409
  - Sketching Arcs ........................................... 1410
  - Sketching Ellipses ........................................... 1414
  - Sketching a Spline ........................................... 1417
  - Modifying a Spline ........................................... 1418
  - Closing an Open Loop ........................................... 1418
- Modifying Sketched Elements ........................................... 1419
- Creating Solid and Void Geometry ........................................... 1420
  - Creating an Extrusion ........................................... 1420
  - Creating a Blend ........................................... 1422
  - Creating a Revolve ........................................... 1425
  - Creating a Sweep ........................................... 1426
  - Creating a Swept Blend ........................................... 1430
  - Cut Geometry ........................................... 1434
- Creating 2D Geometry ........................................... 1434
- Adding a Reference Line ........................................... 1436
- Troubleshooting Sketching Issues ........................................... 1437
  - Element Is Slightly Off Axis ........................................... 1437
  - Ceiling Sketch Is Invalid ........................................... 1438
  - Floor Sketch Is Invalid ........................................... 1438
  - Dimension Cannot Be Made Constraining ........................................... 1438
  - Element Is Too Small on Screen ........................................... 1438
<table>
<thead>
<tr>
<th>Chapter 58 Editing Elements</th>
<th>1439</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selecting Elements</td>
<td>1439</td>
</tr>
<tr>
<td>Basics for Selecting Elements</td>
<td>1440</td>
</tr>
<tr>
<td>Selecting Multiple Elements</td>
<td>1440</td>
</tr>
<tr>
<td>Selecting Elements Using a Filter</td>
<td>1442</td>
</tr>
<tr>
<td>Selecting Chains of Walls and Lines</td>
<td>1442</td>
</tr>
<tr>
<td>Selecting Multiple Curtain Elements</td>
<td>1447</td>
</tr>
<tr>
<td>Restoring a Selection</td>
<td>1448</td>
</tr>
<tr>
<td>Removing Elements from a Selection</td>
<td>1449</td>
</tr>
<tr>
<td>Controls and Shape Handles</td>
<td>1449</td>
</tr>
<tr>
<td>Undoing, Redoing, or Canceling an Action</td>
<td>1453</td>
</tr>
<tr>
<td>Undoing an Action</td>
<td>1454</td>
</tr>
<tr>
<td>Redoing an Action</td>
<td>1454</td>
</tr>
<tr>
<td>Canceling an Action</td>
<td>1455</td>
</tr>
<tr>
<td>Repeating Last Command</td>
<td>1455</td>
</tr>
<tr>
<td>Editing Elements in Groups</td>
<td>1455</td>
</tr>
<tr>
<td>Creating Groups</td>
<td>1456</td>
</tr>
<tr>
<td>Loading Groups</td>
<td>1458</td>
</tr>
<tr>
<td>Placing Groups</td>
<td>1459</td>
</tr>
<tr>
<td>Modifying Groups</td>
<td>1461</td>
</tr>
<tr>
<td>Converting Groups and Linked Revit Models</td>
<td>1465</td>
</tr>
<tr>
<td>Saving Groups</td>
<td>1466</td>
</tr>
<tr>
<td>Deleting Groups</td>
<td>1466</td>
</tr>
<tr>
<td>Group Properties</td>
<td>1466</td>
</tr>
<tr>
<td>Using Arrays of Elements</td>
<td>1467</td>
</tr>
<tr>
<td>Creating an Array</td>
<td>1467</td>
</tr>
<tr>
<td>Copying an Array</td>
<td>1471</td>
</tr>
<tr>
<td>Deleting Members from an Array</td>
<td>1472</td>
</tr>
<tr>
<td>Changing an Array</td>
<td>1472</td>
</tr>
<tr>
<td>Moving Elements</td>
<td>1474</td>
</tr>
<tr>
<td>Moving Elements by Dragging</td>
<td>1474</td>
</tr>
<tr>
<td>Moving Elements with Arrow Keys</td>
<td>1475</td>
</tr>
<tr>
<td>Moving Elements with the Move Tool</td>
<td>1475</td>
</tr>
<tr>
<td>Moving Elements with the Offset Tool</td>
<td>1476</td>
</tr>
<tr>
<td>Moving Elements with Cut-and-Paste</td>
<td>1477</td>
</tr>
<tr>
<td>Moving End-joined Elements</td>
<td>1478</td>
</tr>
<tr>
<td>Moving Lines and Components with Walls</td>
<td>1478</td>
</tr>
<tr>
<td>Aligning Elements</td>
<td>1479</td>
</tr>
<tr>
<td>Rotating Elements</td>
<td>1481</td>
</tr>
<tr>
<td>Flipping Elements</td>
<td>1483</td>
</tr>
<tr>
<td>Mirroring Elements</td>
<td>1483</td>
</tr>
<tr>
<td>Preventing Elements from Moving</td>
<td>1484</td>
</tr>
<tr>
<td>Resizing Elements</td>
<td>1486</td>
</tr>
<tr>
<td>Resizing Elements with Shape Handles</td>
<td>1486</td>
</tr>
<tr>
<td>Scaling Graphically</td>
<td>1486</td>
</tr>
<tr>
<td>Scaling Numerically</td>
<td>1488</td>
</tr>
<tr>
<td>Trimming and Extending Elements</td>
<td>1489</td>
</tr>
<tr>
<td>Copying Elements</td>
<td>1491</td>
</tr>
<tr>
<td>Copying Elements with the Copy Tool</td>
<td>1492</td>
</tr>
<tr>
<td>Copying Elements to the Clipboard</td>
<td>1492</td>
</tr>
<tr>
<td>Pasting Elements</td>
<td>1493</td>
</tr>
<tr>
<td>Copying Elements with the Create Similar Tool</td>
<td>1497</td>
</tr>
<tr>
<td>Modifying Elements</td>
<td>1497</td>
</tr>
<tr>
<td>Changing Element Types Using the Match Type Tool</td>
<td>1497</td>
</tr>
<tr>
<td>Changing the Line Style of Elements</td>
<td>1498</td>
</tr>
<tr>
<td>Changing the Cut Profile of Elements</td>
<td>1503</td>
</tr>
<tr>
<td>Measuring Elements</td>
<td>1505</td>
</tr>
<tr>
<td>Joining Geometry</td>
<td>1506</td>
</tr>
<tr>
<td>Unjoining Geometry</td>
<td>1508</td>
</tr>
<tr>
<td>Chapter</td>
<td>Section</td>
</tr>
<tr>
<td>---------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>59</td>
<td>Work Planes</td>
</tr>
<tr>
<td></td>
<td>Setting the Work Plane</td>
</tr>
<tr>
<td></td>
<td>Making the Work Plane Visible</td>
</tr>
<tr>
<td></td>
<td>Modifying Work Plane Grid Spacing</td>
</tr>
<tr>
<td></td>
<td>Rotating a Work Plane Grid</td>
</tr>
<tr>
<td></td>
<td>Elements Associated with Work Planals</td>
</tr>
<tr>
<td></td>
<td>Changing the Work Plane of an Element</td>
</tr>
<tr>
<td></td>
<td>Dissociating an Element from a Work Plane</td>
</tr>
<tr>
<td></td>
<td>Creating a Work Plane-based Family</td>
</tr>
<tr>
<td></td>
<td>Flip Control for Work Plane-based Families</td>
</tr>
<tr>
<td>60</td>
<td>Reference Planes</td>
</tr>
<tr>
<td></td>
<td>Adding Reference Planes</td>
</tr>
<tr>
<td></td>
<td>Naming Reference Planes</td>
</tr>
<tr>
<td></td>
<td>Hiding the Annotation in the View</td>
</tr>
<tr>
<td></td>
<td>Reference Plane Properties</td>
</tr>
<tr>
<td></td>
<td>Reference Plane Properties</td>
</tr>
<tr>
<td>61</td>
<td>Datum Extents and Visibility</td>
</tr>
<tr>
<td></td>
<td>Example of Datum Visibility in Project Views</td>
</tr>
<tr>
<td></td>
<td>Visibility of Non-Perpendicular Datums in Views</td>
</tr>
<tr>
<td></td>
<td>Visibility of Arc Grids in Views</td>
</tr>
<tr>
<td></td>
<td>Resizing Datum Extent Controls</td>
</tr>
<tr>
<td></td>
<td>Maximizing 3D Model Extents</td>
</tr>
<tr>
<td></td>
<td>Propagating 2D Datum Extents</td>
</tr>
<tr>
<td></td>
<td>Controlling Visibility of Datums Using Scope Boxes</td>
</tr>
<tr>
<td></td>
<td>Creating a Scope Box</td>
</tr>
<tr>
<td></td>
<td>Applying a Scope Box to Datums</td>
</tr>
<tr>
<td></td>
<td>Controlling Visibility of Scope Boxes</td>
</tr>
<tr>
<td>62</td>
<td>Constraints</td>
</tr>
<tr>
<td></td>
<td>Applying Constraints with Dimensions</td>
</tr>
<tr>
<td></td>
<td>Equality Constraints</td>
</tr>
<tr>
<td></td>
<td>Applying an Equality Constraint</td>
</tr>
<tr>
<td></td>
<td>Changing the EQ Label to the Dimension Value</td>
</tr>
<tr>
<td></td>
<td>Controlling Visibility of Constraints</td>
</tr>
<tr>
<td></td>
<td>Removing Constraints</td>
</tr>
<tr>
<td></td>
<td>Constraints and Worksets</td>
</tr>
<tr>
<td>63</td>
<td>Parameters</td>
</tr>
<tr>
<td></td>
<td>Shared Parameters</td>
</tr>
<tr>
<td></td>
<td>Categories Allowing Shared Parameters</td>
</tr>
<tr>
<td></td>
<td>Setting Up Shared Parameter Files</td>
</tr>
<tr>
<td></td>
<td>Adding Shared Parameters to Families</td>
</tr>
<tr>
<td></td>
<td>Shared and Family Parameters</td>
</tr>
<tr>
<td>Chapter 64</td>
<td>Formulas</td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
</tr>
<tr>
<td>Using Formulas for Numerical Parameters</td>
<td>1553</td>
</tr>
<tr>
<td>Valid Formula Syntax and Abbreviations</td>
<td>1554</td>
</tr>
<tr>
<td>Conditional Statements in Formulas</td>
<td>1554</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 65</th>
<th>Keyboard Shortcuts</th>
<th>1559</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding Keyboard Shortcuts</td>
<td>1559</td>
<td></td>
</tr>
<tr>
<td>Removing Keyboard Shortcuts</td>
<td>1560</td>
<td></td>
</tr>
<tr>
<td>Importing Keyboard Shortcuts</td>
<td>1561</td>
<td></td>
</tr>
<tr>
<td>Exporting Keyboard Shortcuts</td>
<td>1561</td>
<td></td>
</tr>
<tr>
<td>Resetting Keyboard Shortcuts</td>
<td>1562</td>
<td></td>
</tr>
<tr>
<td>Using Keyboard Shortcuts</td>
<td>1562</td>
<td></td>
</tr>
<tr>
<td>Rules for Keyboard Shortcuts</td>
<td>1563</td>
<td></td>
</tr>
<tr>
<td>Reserved Keys</td>
<td>1563</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 66</th>
<th>Project Settings</th>
<th>1565</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Information</td>
<td>1565</td>
<td></td>
</tr>
<tr>
<td>Specifying Energy Analysis (gbXML) Settings</td>
<td>1566</td>
<td></td>
</tr>
<tr>
<td>Fill Patterns</td>
<td>1566</td>
<td></td>
</tr>
<tr>
<td>Creating a Simple Fill Pattern</td>
<td>1567</td>
<td></td>
</tr>
<tr>
<td>Fill Pattern Host Orientation</td>
<td>1567</td>
<td></td>
</tr>
<tr>
<td>Creating a Custom Fill Pattern</td>
<td>1568</td>
<td></td>
</tr>
<tr>
<td>Applying a Fill Pattern</td>
<td>1569</td>
<td></td>
</tr>
<tr>
<td>Deleting a Fill Pattern</td>
<td>1569</td>
<td></td>
</tr>
<tr>
<td>Editing a Fill Pattern</td>
<td>1569</td>
<td></td>
</tr>
<tr>
<td>Working with Model Patterns</td>
<td>1569</td>
<td></td>
</tr>
<tr>
<td>Custom Pattern Files</td>
<td>1570</td>
<td></td>
</tr>
<tr>
<td>Materials</td>
<td>1573</td>
<td></td>
</tr>
<tr>
<td>Materials Overview</td>
<td>1574</td>
<td></td>
</tr>
<tr>
<td>Material Appearance Overview</td>
<td>1574</td>
<td></td>
</tr>
<tr>
<td>How Materials Are Stored</td>
<td>1575</td>
<td></td>
</tr>
<tr>
<td>Searching for a Material</td>
<td>1575</td>
<td></td>
</tr>
<tr>
<td>Applying Materials to Elements</td>
<td>1576</td>
<td></td>
</tr>
<tr>
<td>Create and Modify Material Appearances</td>
<td>1577</td>
<td></td>
</tr>
<tr>
<td>Changing the Display Properties of a Material</td>
<td>1578</td>
<td></td>
</tr>
<tr>
<td>Texture Alignment</td>
<td>1580</td>
<td></td>
</tr>
<tr>
<td>Changing the Render Appearance of a Material</td>
<td>1582</td>
<td></td>
</tr>
<tr>
<td>Changing Material Identity Data</td>
<td>1595</td>
<td></td>
</tr>
<tr>
<td>Changing Material Physical Data</td>
<td>1596</td>
<td></td>
</tr>
<tr>
<td>Creating a Material</td>
<td>1597</td>
<td></td>
</tr>
<tr>
<td>Renaming a Material</td>
<td>1598</td>
<td></td>
</tr>
<tr>
<td>Deleting a Material</td>
<td>1598</td>
<td></td>
</tr>
<tr>
<td>Importing ADSK Files</td>
<td>1599</td>
<td></td>
</tr>
<tr>
<td>Render Appearance Library</td>
<td>1599</td>
<td></td>
</tr>
<tr>
<td>Searching for a Render Appearance</td>
<td>1599</td>
<td></td>
</tr>
<tr>
<td>Entering Search Text</td>
<td>1600</td>
<td></td>
</tr>
<tr>
<td>Object Styles</td>
<td>1601</td>
<td></td>
</tr>
<tr>
<td>Contents</td>
<td>xxxiii</td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>-------</td>
<td></td>
</tr>
<tr>
<td>Creating Object Style Subcategories</td>
<td>1601</td>
<td></td>
</tr>
<tr>
<td>Modifying Object Styles</td>
<td>1601</td>
<td></td>
</tr>
<tr>
<td>Deleting an Object Style</td>
<td>1601</td>
<td></td>
</tr>
<tr>
<td>Renaming an Object Style</td>
<td>1602</td>
<td></td>
</tr>
<tr>
<td>Line Styles</td>
<td>1602</td>
<td></td>
</tr>
<tr>
<td>Creating a Line Style</td>
<td>1602</td>
<td></td>
</tr>
<tr>
<td>Deleting a Line Style</td>
<td>1602</td>
<td></td>
</tr>
<tr>
<td>Modifying Line Styles in the Family Editor</td>
<td>1603</td>
<td></td>
</tr>
<tr>
<td>Line Weights</td>
<td>1603</td>
<td></td>
</tr>
<tr>
<td>Specifying Line Weights</td>
<td>1603</td>
<td></td>
</tr>
<tr>
<td>Adding Scales to Model Line Weights</td>
<td>1603</td>
<td></td>
</tr>
<tr>
<td>Deleting Scales</td>
<td>1603</td>
<td></td>
</tr>
<tr>
<td>Line Patterns</td>
<td>1604</td>
<td></td>
</tr>
<tr>
<td>Creating a Line Pattern</td>
<td>1604</td>
<td></td>
</tr>
<tr>
<td>Editing a Line Pattern</td>
<td>1604</td>
<td></td>
</tr>
<tr>
<td>Deleting a Line Pattern</td>
<td>1604</td>
<td></td>
</tr>
<tr>
<td>Halftone/Underlay</td>
<td>1605</td>
<td></td>
</tr>
<tr>
<td>Structural Settings</td>
<td>1605</td>
<td></td>
</tr>
<tr>
<td>Structural Settings Dialog</td>
<td>1605</td>
<td></td>
</tr>
<tr>
<td>Annotation Styles</td>
<td>1609</td>
<td></td>
</tr>
<tr>
<td>Specifying Arrowhead Styles</td>
<td>1609</td>
<td></td>
</tr>
<tr>
<td>Specifying Text Note Styles</td>
<td>1610</td>
<td></td>
</tr>
<tr>
<td>Specifying Dimension Styles</td>
<td>1610</td>
<td></td>
</tr>
<tr>
<td>Modifying Reinforcement Tag Abbreviations</td>
<td>1610</td>
<td></td>
</tr>
<tr>
<td>Loading Tag Styles</td>
<td>1612</td>
<td></td>
</tr>
<tr>
<td>Specifying the Default Tag for an Element Category</td>
<td>1612</td>
<td></td>
</tr>
<tr>
<td>Project Units</td>
<td>1613</td>
<td></td>
</tr>
<tr>
<td>Setting Project Units</td>
<td>1613</td>
<td></td>
</tr>
<tr>
<td>Changing Decimal Display and Digit Grouping</td>
<td>1613</td>
<td></td>
</tr>
<tr>
<td>Snaps</td>
<td>1614</td>
<td></td>
</tr>
<tr>
<td>Setting Snap Increments</td>
<td>1614</td>
<td></td>
</tr>
<tr>
<td>Enabling and Disabling Snaps</td>
<td>1615</td>
<td></td>
</tr>
<tr>
<td>Temporarily Overriding Snap Settings</td>
<td>1615</td>
<td></td>
</tr>
<tr>
<td>Snap Points</td>
<td>1615</td>
<td></td>
</tr>
<tr>
<td>Object Snaps and Snap Shortcut Key Combinations</td>
<td>1617</td>
<td></td>
</tr>
<tr>
<td>Temporary Dimension Settings</td>
<td>1618</td>
<td></td>
</tr>
<tr>
<td>Setting Detail Level Scale Values</td>
<td>1618</td>
<td></td>
</tr>
<tr>
<td>Specifying the Detail Level for a View</td>
<td>1618</td>
<td></td>
</tr>
<tr>
<td>Managing Family Visibility and Detail Level</td>
<td>1619</td>
<td></td>
</tr>
<tr>
<td>Colors</td>
<td>1622</td>
<td></td>
</tr>
<tr>
<td>Using the Windows Color Dialog</td>
<td>1622</td>
<td></td>
</tr>
<tr>
<td>Using the PANTONE Color Picker</td>
<td>1622</td>
<td></td>
</tr>
</tbody>
</table>

Chapter 67  **Revit Options**  1623

<p>| Setting Options | 1623 |
| General Options | 1623 |
| User Interface Options | 1624 |
| Graphics Options | 1625 |
| File Location Options | 1625 |
| Places | 1626 |
| Rendering Options | 1626 |
| Additional Render Appearance Paths | 1627 |
| ArchVision Content Manager Location | 1627 |
| Spelling Options | 1628 |
| SteeringWheels Options | 1628 |
| ViewCube Options | 1630 |
| Macros Options | 1631 |</p>
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>68</td>
<td><strong>Project Templates</strong></td>
<td>1633</td>
</tr>
<tr>
<td></td>
<td>Creating a Template</td>
<td>1633</td>
</tr>
<tr>
<td></td>
<td>Project Template Settings</td>
<td>1634</td>
</tr>
<tr>
<td>69</td>
<td><strong>Transferring Project Standards</strong></td>
<td>1635</td>
</tr>
<tr>
<td>70</td>
<td><strong>View Templates</strong></td>
<td>1637</td>
</tr>
<tr>
<td></td>
<td>View Template Overview</td>
<td>1637</td>
</tr>
<tr>
<td></td>
<td>Creating a View Template</td>
<td>1637</td>
</tr>
<tr>
<td></td>
<td>Specifying and Applying a Default View Template</td>
<td>1639</td>
</tr>
<tr>
<td></td>
<td>Applying a View Template</td>
<td>1639</td>
</tr>
<tr>
<td></td>
<td>Applying a View Template to All Views on a Sheet</td>
<td>1639</td>
</tr>
<tr>
<td></td>
<td>Deleting a View Template</td>
<td>1640</td>
</tr>
<tr>
<td></td>
<td>View Template Properties</td>
<td>1640</td>
</tr>
<tr>
<td>71</td>
<td><strong>Creating Macros with Revit VSTA</strong></td>
<td>1643</td>
</tr>
<tr>
<td></td>
<td>Getting Started with Macros</td>
<td>1643</td>
</tr>
<tr>
<td></td>
<td>Upgrading Revit VSTA</td>
<td>1644</td>
</tr>
<tr>
<td></td>
<td>Revit VSTA Tools</td>
<td>1645</td>
</tr>
<tr>
<td></td>
<td>Using Macro Manager and the Revit VSTA IDE</td>
<td>1645</td>
</tr>
<tr>
<td></td>
<td>Basic Workflow for Revit VSTA Macro Development</td>
<td>1647</td>
</tr>
<tr>
<td></td>
<td>Creating Modules</td>
<td>1648</td>
</tr>
<tr>
<td></td>
<td>Creating Macros</td>
<td>1649</td>
</tr>
<tr>
<td></td>
<td>Building Macros in the Revit VSTA IDE</td>
<td>1654</td>
</tr>
<tr>
<td></td>
<td>Modifying and Removing Modules and Macros</td>
<td>1655</td>
</tr>
<tr>
<td></td>
<td>Running Macros in the Macro Manager</td>
<td>1655</td>
</tr>
<tr>
<td></td>
<td>Using the StepInto Option</td>
<td>1655</td>
</tr>
<tr>
<td></td>
<td>Macro Security</td>
<td>1656</td>
</tr>
<tr>
<td></td>
<td>Revit SDK, API Reference Documentation, VSTA Samples</td>
<td>1657</td>
</tr>
<tr>
<td></td>
<td>Using the Revit VSTA Samples</td>
<td>1658</td>
</tr>
<tr>
<td></td>
<td>Revit API Differences</td>
<td>1659</td>
</tr>
<tr>
<td></td>
<td>Integrating Macros into Revit VSTA</td>
<td>1660</td>
</tr>
<tr>
<td></td>
<td>Restoring RevitAPI.dll and RevitAPIUI.dll</td>
<td>1664</td>
</tr>
<tr>
<td></td>
<td>Migrating SDK Samples to Revit VSTA</td>
<td>1664</td>
</tr>
<tr>
<td></td>
<td>Revit Macros FAQ</td>
<td>1666</td>
</tr>
<tr>
<td></td>
<td>Related Information about Revit Macros</td>
<td>1669</td>
</tr>
<tr>
<td>72</td>
<td><strong>Memory Usage</strong></td>
<td>1671</td>
</tr>
<tr>
<td></td>
<td>3 GB Feature Considerations</td>
<td>1671</td>
</tr>
<tr>
<td></td>
<td>Enabling the 3 GB Feature on 32-Bit Machines</td>
<td>1672</td>
</tr>
<tr>
<td></td>
<td>Verifying Virtual Memory Allocation</td>
<td>1673</td>
</tr>
<tr>
<td>73</td>
<td><strong>Best Practices</strong></td>
<td>1675</td>
</tr>
<tr>
<td>74</td>
<td><strong>Troubleshoot</strong></td>
<td>1677</td>
</tr>
<tr>
<td></td>
<td>Troubleshooting</td>
<td>1677</td>
</tr>
<tr>
<td></td>
<td>Diagnostic Tools</td>
<td>1678</td>
</tr>
<tr>
<td></td>
<td>Selecting Elements by ID Number</td>
<td>1678</td>
</tr>
<tr>
<td></td>
<td>Finding an Element's ID Number</td>
<td>1678</td>
</tr>
<tr>
<td></td>
<td>Error Handling</td>
<td>1678</td>
</tr>
<tr>
<td></td>
<td>Viewing Elements Involved in Errors</td>
<td>1679</td>
</tr>
<tr>
<td></td>
<td>Viewing all Errors and Warnings Associated with an Error Message</td>
<td>1679</td>
</tr>
<tr>
<td></td>
<td>Messages and Warnings You Can Ignore</td>
<td>1680</td>
</tr>
<tr>
<td></td>
<td>Reviewing Warning Messages</td>
<td>1680</td>
</tr>
<tr>
<td></td>
<td>Warnings for Selected Elements</td>
<td>1680</td>
</tr>
</tbody>
</table>
## Chapter 75 gbXML Schema Support

- gbXML Element ............................................. 1685
- Campus Element .......................................... 1686
- DocumentHistory Element .............................. 1687
- Location Element ......................................... 1688
- Building Element ........................................ 1688
- Space Element ............................................ 1689
- ShellGeometry Element .................................. 1690
- SpaceBoundary Element ................................ 1691
- Surface Element ......................................... 1691
- Opening Element ........................................ 1693

## Glossary

- Glossary Terms ........................................... 1695

## Index

- Index .......................................................... 1779
What’s New?

This topic lists the new and enhanced features for Revit Structure.

New in Revit Structure 2011

The following features are new or enhanced for Revit Structure.

For additional detail and a more interactive listing of New Features for Revit Structure, go to the following: http://www.autodesk.com/revitstructure-features.

User Interface Enhancements

- Modeless Properties Palette
- Repeat last command / Repeat Commands recently used
- Quick Access Toolbar (QAT):
  - Single QAT per application
  - Increased number of default commands in the QAT
  - Customization options via dialog box: move command up/down, add separator, remove command
- Improved access to Worksets and Design Options on status bar

Ribbon Enhancements:

- Redesigned Modify tab:
  - Consistent modify tools - panels and buttons are always in the same order on the left side of the Modify tab. Buttons enable/ disable as necessary.
  - Modify tab name updates to reflect the active contextual tab appended.
  - Contextual tab content is appended to the right side of the Modify tab when active.
  - Modify and contextual contents are separated by a gray visual bar.
- Persistent access to core modify tools (Object-Action commands):
  - Move
Copy
Rotate
Mirror - Pick Axis
Mirror - Draw Axis
Delete

Type Selector Enhancements
Type Selector is combined with the Properties Palette. Open at all times; can be opened/closed using the Properties Palette button available in the Properties ribbon panel.

Group Edit Mode access
Panel is removed from the ribbon and will float in drawing area when invoked. Default is upper left corner of drawing area and can be moved.

Model In-Place
Project ribbon replaced with the family ribbon when an in-place model is started or edited. When you finish editing in-place, the ribbon will revert to the project ribbon.

Improved icons based on user feedback

Large Team Workflow: Linked Models
Enhancements to the Visibility Control of Worksets in workshared files:
Visibility by Default for Worksets
Ability to open/close Worksets for linked models
Ability to control visibility of linked models according to host model
Ability to apply View Filters to linked models from host model

Ability to tag elements in linked files, with the exception of rooms, spaces, and areas
Ability to automatically generate a ceiling grid from walls in a linked model
Ability to apply View Filters to linked files

Graphics
Realistic materials available in editable views
Hardware acceleration (DX9) on by default
Levels of Details (adaptive to zoom)
Ambient occlusion
Display performance improvements (over 30%)
Significant performance improvement in display of mechanical and electrical drawings (up to 200%)

Materials
Protein 2.0 appearances, in single project library
Increased interoperability with 3ds Max through:

- Export of FBX files to Max with Protein 2 appearances
- Import of DWG files and ADSK files with Protein 2 appearances

**NOTE** 3ds Max/Design 2011 is required for materials to transfer.

- Support for new realistic display style through Protein 2 materials
- New material classes available in Protein 2, including procedural appearances

**Inventor Interoperability**

- Support for oval duct, cable tray, and conduit connectors
- Support of new electrical properties (such as Motor)
- Improved performance when importing ADSK files
- Improved AEC Exchange functionality
- Support of Protein materials

**Performance Improvements**

- Graphics
- MultiCore Operations
- Sync with Central
- Model Open
- User interface reaction time
- Linked Models

**DWG Export**

- Increased visual fidelity when exporting Revit files to DWG
- Export option for True Color
- Export option for Text treatment

**Family Editor Enhancements**

- Interactive exploration of parameter values in Revit families
- Ability to lock labeled dimensions
- Reporting Parameters

**Parameter Enhancements**

- Default parameter type (length vs. text)
- Parameters groups automatically set
Temporary Dimension Enhancements
- Remembering witness lines
- Family Editor: right-click permanent dimensions to select labels
- Ability to control temporary dimension font size and background (transparent or opaque)

3D Alignment Enhancements
- Align tool now works on an element’s node, vertex, edge, surface, form, or level

Expanded Region of High Geometric Accuracy
- Previous versions of Revit were unable to maintain the expected level of geometric accuracy at locations farther than 1 mile from the project origin. Revit will now maintain a high level of geometric accuracy for elements placed within 20 miles of the project origin.

Selection Enhancements
- Select All Instances in the current view or in the entire project

Text Notes Enhancements
- Additional leader attachment points: Top Left (TL), Middle Left (ML), Bottom Left (BL), Top Right (TR), Middle Right (MR), and Bottom Right (BR).
- Ability to adjust leader end distance
- Ability to show box around text
- Ability to create bullets and numbering

Sheet Enhancements
- Create new sheet list rows to create placeholder sheets
- Convert placeholder sheets to project sheets
- Grid guide for sheets, enabling consistent sheet creation

Floor Enhancements
- Ability to set span direction for metal deck floors

Analysis
- Sun Path
  Interactive tool for visualizing the impact of natural light and shadows on buildings and sites

Structural Analysis Enhancements
- Horizontal projection from columns and beams
  You can now horizontally project from columns to the default plane or to a named reference plane. You can also horizontally project from the center line of a beam, location lines, grids, and named reference planes.
- Horizontal projection from the center of a wall core
  You can now specify the center of a wall core to accommodate varying widths in vertically compound structural walls.
■ Vertical projection auto-detect behavior of columns
  Top or bottom vertical projection of a column will now auto-detect beams when structural floors are not present.

■ Vertical projection from beams
  You can now project vertically from the location line or the bottom of a beam.

■ Manual analytical adjustment of columns
  You can now use the top or bottom of a column analytical model as a source for manual analytical adjustment.

■ Rigid Links enhancements between beams and columns
  The enhanced rigid links will be formed between beams and multiple neighboring columns, and their creation are governed by parameters on both beams and columns.

**Reinforcement Enhancements**

■ Reinforcement of spiral
■ Reinforcement project units
■ Reinforcement of slab edges
■ First and last rebar sets are now suppressible in a project
■ Additional hook bend radius for rebar
■ Concrete Host Cover Reference has configurable object style
■ Concrete Host Cover Reference Lines now remain in view when resizing and repositioning rebar
■ Major Space is now a label category parameter for area reinforcement tags

**Concrete Join/Cleanup**

■ Improved concrete end joins and cleanup for curved beam and variable beam profiles

**Slanted Column**

■ Steel and concrete end position geometry and trim
■ Beam to column joins
■ Plan view placement
■ Column end geometry position control when column is attached to a beam
■ Cut column tangent to an attached structured floor
■ Unattached column end cut appearance

**Beam System Enhancements**

■ Specify beam direction with walls and beams
■ Specify beam direction from an independent sketch line
■ Remove a beam system while retaining beam elements
Truss Enhancements
- Bottom chord attachment to structural floors and foundation slabs
- Sketch chords on attached trusses
- Remove a truss family while retaining beam elements

Connection Symbol Enhancements
- New additional load connection symbol families
- Ability to load and manage connection symbol families (from the Structural Settings dialog)

Subscription Advantage Pack

NOTE The following items were previously released exclusively to Subscription customers.

- Conditional Formatting in Schedule
- Element Section Area and Linear Weight in Schedules
- Span Direction Tool
- DWG Export enhancements (Index color and True Color support)
- Beam Coping for steel beams framed into joined beams and columns
- Text Formatting Shortcuts (Ctrl+B, Ctrl+I, and Ctrl+U)
- Beam System Tags
- Split Walls with Gap
- Keyboard Shortcut UI
- Find and Replace Text in Notes
- Convert between Line Types: Model, Detail, Symbolic
- Export to DWG with correct RGB colors
- Linked File Performance Enhancements
- New API for slope angle and elevation for x,y location in given slab with choice of top and bottom
- Insulation Tool
- Beam Placement using 3D CAD Geometry
- Control beam length tolerance
- "A" and "W" User defined parameters to be available in Schedule Field
- Countrification Content for China, Russia, and Italy
- Structure Extensions:
  - Interference of Reinforcing Bars
  - Bridge Design Modules
Revit Extensions

- Shared Parameters Converter
- Model Review
- Autodesk Revit DB Link
- Wall framing enhancements:
  - New method to choose the location of the studs (wall layers are exposed)
  - Multi-selection of walls and openings
- Steel frame generator
- Reinforcement enhancements:
  - Export and draw user-defined reinforcement or designed reinforcement in ASD
  - Export and draw the formwork of element recognized by REX in ASD
  - Exposed required reinforcement on beam and column extension
  - Leverage new mounting part content with beam, column, and wall extension
  - Provide content mapping tools to synchronize code dependent data shared between RST, RSA, and ASD
  - Generate rebar using shape codes

User Assistance (Documentation)

- Transition to Web Help, which includes improved search capabilities
- Streamlined Help reference content
- Short Tutorials in video format
- Additional Enhanced Tooltips
- New animated ToolClips
- Improved First Experience

Other Enhancements

- Custom elevation tag
- List sheets not in a project on drawing list
- Background images in renderings
- Repeat last command
- Sheet layout grid
- Removal of 4 core rendering limit
- Google Maps™ mapping service interface (Location dialog) lets you visualize project locations
Introduction to Revit
Read these topics to learn how building information modeling works and how it differs from traditional 2D design methods.

**What Is Revit Structure?**

The Revit platform for building information modeling is a design and documentation system that supports the design, drawings, and schedules required for a building project. Building information modeling (BIM) delivers information about project design, scope, quantities, and phases when you need it.

In the Revit model, every drawing sheet, 2D and 3D view, and schedule is a presentation of information from the same underlying building model database. As you work in drawing and schedule views, Revit Structure collects information about the building project and coordinates this information across all other representations of the project. The Revit parametric change engine automatically coordinates changes made anywhere—in model views, drawing sheets, schedules, sections, and plans.

**What Is Meant by Parametric?**

The term parametric refers to the relationships among all elements of the model that enable the coordination and change management that Revit Structure provides. These relationships are created either automatically by the software or by you as you work.

In mathematics and mechanical CAD, the numbers or characteristics that define these kinds of relationships are called parameters; hence, the operation of the software is parametric. This capability delivers the fundamental coordination and productivity benefits of Revit Structure: change anything at any time anywhere in the project, and Revit Structure coordinates that change through the entire project.

The following are examples of these element relationships:

- The outside of a door frame is a fixed dimension on the hinge side from a perpendicular partition. If you move the partition, the door retains this relationship to the partition.

- Rebar is spaced equally across a given elevation. If the length of the elevation is changed, the relationship of equal spacing is maintained. In this case, the parameter is not a number but a proportional characteristic.

- The edge of a floor or roof is related to the exterior wall such that when the exterior wall is moved, the floor or roof remains connected. In this case, the parameter is one of association or connection.
How Does Revit Structure Keep Things Updated?

A fundamental characteristic of a building information modeling application is the ability to coordinate changes and maintain consistency at all times. You do not have to intervene to update drawings or links. When you change something, Revit Structure immediately determines what is affected by the change and reflects that change to any affected elements.

Revit Structure uses 2 key concepts that make it especially powerful and easy to use. The first is the capturing of relationships while the designer works. The second is its approach to propagating building changes. The result of these concepts is software that works like you do, without requiring entry of data that is unimportant to your design.

Understanding Revit Terms

Most of the terms used to identify objects in Revit Structure are common, industry-standard terms familiar to most engineers. However, some terms are unique to Revit Structure. Understanding the following terms is crucial to understanding the software.

Project

In Revit Structure, the project is the single database of information for your design—the building information model. The project file contains all information for the building design, from geometry to construction data. This information includes components used to design the model, views of the project, and drawings of the design. By using a single project file, Revit Structure makes it easy for you to alter the design and have changes reflected in all associated areas (plan views, elevation views, section views, schedules, and so forth). Having only one file to track also makes it easier to manage the project.

Level

Levels are infinite horizontal planes that act as a reference for level-hosted elements, such as roofs, floors, and ceilings. Most often, you use levels to define a vertical height or story within a building. You create a level for each known story or other needed reference of the building; for example, first floor, top of wall, or bottom of foundation. To place levels, you must be in a section or elevation view.

South Elevation View of a Structure

Element

When creating a project, you add Revit parametric building elements to the design. Revit Structure classifies elements by categories, families, and types.
Category
A category is a group of elements that you use to model or document a building design. For example, categories of model elements include walls and beams. Categories of annotation elements include tags and text notes.

Family
Families are classes of elements in a category. A family groups elements with a common set of parameters (properties), identical use, and similar graphical representation. Different elements in a family may have different values for some or all properties, but the set of properties—their names and meaning—is the same. For example, a truss could be considered one family, although the web supports that compose the family come in different sizes and materials.

There are 3 kinds of families:
- Loadable families can be loaded into a project and created from family templates. You can determine the set of properties and the graphical representation of the family.
- System families include slabs, dimensions, roofs, and levels. They are not available for loading or creating as separate files.
  - Revit Structure predefines the set of properties and the graphical representation of system families.
  - You can use the predefined types to generate new types that belong to this family within the project. For example, the behavior of a wall is predefined in the system. However, you can create different types of walls with different compositions.
  - System families can be transferred between projects.
- In-place families define custom elements that you create in the context of a project. Create an in-place element when your project needs unique geometry that you do not expect to reuse or geometry that must maintain one or more relationships to other project geometry.
  - Because in-place elements are intended for limited use in a project, each in-place family contains only a single type. You can create multiple in-place families in your projects, and you can place copies of the same in-place element in your projects. Unlike system and standard component families, you cannot duplicate in-place family types to create multiple types.

Type
Each family can have several types. A type can be a specific size of a family, such as a 30" X 42" or A0 title block. A type can also be a style, such as default aligned or default angular style for dimensions.
Instance

Instances are the actual items (individual elements) that are placed in the project and have specific locations in the building (model instances) or on a drawing sheet (annotation instances).

Element Behavior in a Parametric Modeler

In projects, Revit Structure uses 3 types of elements:

- **Model elements** represent the actual 3D geometry of the building. They display in relevant views of the model. For example, structural walls, slabs, ramps, and roofs are model elements.

- **Datum elements** help to define project context. For example, grids, levels, and reference planes are datum elements.

- **View-specific elements** display only in the views in which they are placed. They help to describe or document the model. For example, dimensions, tags, and 2D detail components are view-specific elements.

There are 2 types of model elements:

- **Hosts** (or host elements) are generally built in place at the construction site. For example, structural walls and roofs are hosts.

- **Model components** are all the other types of elements in the building model. For example, beams, structural columns, and 3D rebar are model components.

There are 2 types of view-specific elements:

- **Annotation elements** are 2D components that document the model and maintain scale on paper. For example, dimensions, tags, and keynotes are annotation elements.

- **Details** are 2D items that provide details about the building model in a particular view. Examples include detail lines, filled regions, and 2D detail components.

This implementation provides flexibility for designers. Revit Structure elements are designed to be created and modified by you directly; programming is not required. If you can draw, you can define new parametric elements in Revit Structure.

In Revit Structure, the elements determine their behavior largely from their context in the building. The context is determined by how you draw the component and the constraint relationships that are established with other components. Often, you do nothing to establish these relationships; they are implied by what
you do and how you draw. In other cases, you can explicitly control them, by locking a dimension or aligning 2 walls, for example.

Element Properties

In Revit Structure, each element you place in a drawing is an instance of a family type. Elements have 2 sets of properties that control their appearance and behavior: type properties and instance properties.

Type Properties

The same set of type properties is common to all elements in a family, and each property has the same value for all instances of a particular family type.

For example, all elements that belong to the Desk family have a Width property, but its value varies according to family type. Thus every instance of the 60” x 30” family type within the Desk family has a Width value of 5’, while every instance of the “72 x 36” family type has a Width value of 6’.

Changing the value of a type property affects all current and future instances of that family type.

Instance Properties

A common set of instance properties also applies to all elements that belong to a particular family type, but the values of these properties may vary according to the location of an element in a building or project.

For example, the dimensions of a window are type properties, while its elevation from the level is an instance property. Similarly, cross-sectional dimensions of a beam are type properties, while beam length is an instance property.

Changing the value of an instance property affects only the elements in your selection set, or the element that you are about to place. For example, if you select a beam, and change one of its instance property values on the Properties palette, only that beam is affected. If you select a tool for placing beams, and change one of its instance property values, the new value applies to all beams you place with that tool.
Licensing

Licensing Overview

There are 3 options for licensing with Revit Structure:

- **Standalone.** A standalone license is associated with one machine. In addition, you can transfer a license from one computer to another with a standalone license. For more information, see License Transferring.

- **Network.** A network license is not associated with one computer. It can be installed on a network server and multiple computers on that network to run Revit Structure. In addition, you can borrow a license from the license server and use it outside the network environment for a specified time. For more information, see License Borrowing.

- **Demo.** A demo license allows you to use Revit Structure as a viewer.

Standalone Licensing

Follow this procedure to obtain a standalone license for Revit Structure. If you have not already run Revit Structure in trial mode, the Product License Activation dialog displays when you first start Revit Structure. Proceed to the Product License Activation dialog, and select Activate the Product.

If you have already run Revit Structure, click ➤ Licensing ➤ (Product and License Information).

**To enter a standalone license**

1. In the Product and License Information dialog, verify Standalone-Locked is selected. Proceed to step 4.
2. If Standalone-Locked is not selected, select Standalone-Locked and click Apply to restart Revit Structure.
3. Open the Product and License Information dialog.
4. Click Register.
5. In the Product License Activation dialog, select Activate the product.
6. In the Product Information Required dialog, enter your serial number and product key.
7. Click Next.
Select Connect now and activate, or, I have an activation code from Autodesk. If you select Connect now, the activation process completes by connecting to Autodesk over the internet. You are prompted to log into Register Once to complete the activation. The first time you do this, you will need to create an account for the activation.

If you did not select Connect now, use copy (Ctrl+C) and paste (Ctrl+V) to paste the entire activation code into the text field labeled 1.

Click Next.

Click Finish. Revit Structure displays a license confirmation dialog.

**Licensing Extension**

If you have network licensing, and a license outage occurs, you can extend your licensing long enough to save your work.

**Outage Examples**

- You were using Revit Structure, left your computer for over 2 hours but forgot to save, and all the floating licenses, including yours, are now assigned to other users.
- The machine that hosts the license server went down.

**Saving Your Work in an Outage**

If a network outage occurs, Revit continues to run for a 2-hour grace period. If the network license is not recovered during this time, messages display to inform you of how much time remains. At the end of 2 hours, a dialog prompts you to save, or exit Revit without saving.

**License Transferring**

If you are running Revit Structure with a standalone license, you can transfer that license using the License Transfer Utility. This transfers a product license from one computer to another and ensures that the product works only on the computer that has the license. To access License Transfer Utility, do one of the following:

- On Windows XP, click Start menu ➤ Programs ➤ Autodesk ➤ Autodesk Revit Structure 2011 ➤ License Transfer Utility.
- On Windows Vista or Windows 7, click Start menu ➤ All Programs ➤ Autodesk ➤ Autodesk Revit Structure 2011 ➤ License Transfer Utility.

For more information about the License Transfer Utility, see its online help.

**License Borrowing**

If you are running a network-licensed version of Revit Structure, you can borrow a license from a license server so that you can use the software for a specified time when your computer is not connected to the network. The license is returned to the license server automatically at the end of the day on the return date that you specified when you borrowed the license. You can also return a license early.

**NOTE** If you have a standalone version of the software, you cannot borrow a license. To view your product license type, click ➤ Licensing ➤  (Product and License Information).
To borrow a license

1. Click ➤ Licensing ➤ (Borrow License).
2. Click a return date on the calendar in the dialog.
   Be sure the date is within the valid range as shown in the dialog.
3. Click Borrow License.

   **NOTE** There is a limit to the number of licenses available for borrowing. If you try to borrow a license and are notified that no licenses are available, all network licenses might already be borrowed by other users. If you are unable to borrow a license, contact your network administrator.

**License Returning**

When the license-borrowing period expires, the borrowed license is returned to the license server automatically. When you reconnect your computer to the network, you may start Revit Structure normally. Successful startup of the software indicates that you have acquired the usual (online) network license. At that point, you can borrow a license again.

**NOTE** To view the expiration date for the borrowed license, click Help menu ➤ About. In the About dialog, click Product Information. In the Product Information dialog, under License expiration date, view the license return date.

**To return a license early**

- Click ➤ Licensing ➤ (Return License Early).
User Interface

The Revit interface is designed to simplify your workflow. With a few clicks, you can change the interface to better support the way that you work. For example, you can set the ribbon to one of 4 display settings. You can also display several project views at one time, or layer the views to see only the one on top.

Ribbon

The ribbon displays when you create or open a file. It provides all the tools necessary to create a project or family.

As you resize the Revit window, you may notice that tools in the ribbon automatically adjust their size to fit the available space. This feature allows all buttons to be visible for most screen sizes.
Expanded panels

An arrow next to a panel title indicates that you can expand the panel to display related tools and controls.

By default, an expanded panel closes automatically when you click outside the panel. To keep a panel expanded while its ribbon tab is displayed, click the push pin icon in the bottom-left corner of the expanded panel.

Dialog launcher

Some panels allow you to open a dialog to define related settings. A dialog-launcher arrow on the bottom of a panel opens a dialog.

Contextual ribbon tabs

When you use certain tools or select elements, a contextual ribbon tab displays tools that relate to the context of that tool or element. In many cases, the contextual tab merges with the Modify tab. A contextual ribbon tab closes when you exit the tool or clear the selection.

You can specify whether a contextual tab automatically comes into focus or the current tab stays in focus. You can also specify which ribbon tab displays when you exit a tool or clear a selection. See User Interface Options on page 1624.

Customizing the Ribbon

You can customize the ribbon by changing its display and rearranging its tabs and panels.
### To move ribbon panels

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>move a panel on the ribbon</td>
<td>drag the panel label to the desired location on the ribbon.</td>
</tr>
<tr>
<td>move a panel off the ribbon</td>
<td>drag the panel label to the drawing area or the desktop.</td>
</tr>
<tr>
<td>dock floating panels together</td>
<td>drag one panel over the other.</td>
</tr>
<tr>
<td>move docked panels as a group</td>
<td>move the cursor over the panel to display a grip on the left side. Drag the grip to the desired location.</td>
</tr>
<tr>
<td>return a floating panel to the ribbon</td>
<td>move the cursor over the panel to display a control in the upper-right corner, and click Return Panels to Ribbon.</td>
</tr>
</tbody>
</table>

### To change the ribbon display

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify the preferred method for minimizing the ribbon</td>
<td>to the right of the ribbon tabs, click the right arrow and select the desired behavior: Minimize to Tabs, Minimize to Panel Titles, Minimize to Panel Buttons, or Cycle through All.</td>
</tr>
<tr>
<td>show the full ribbon, or minimize the ribbon to show only tabs, panel titles, or panel buttons</td>
<td>to the right of the ribbon tabs, click the left arrow to change the ribbon display. It switches between displaying the full ribbon and the preferred method for minimizing the ribbon, or cycles through all display options.</td>
</tr>
<tr>
<td>hide panel titles</td>
<td>Right-click in an empty (gray) area of the ribbon, and select Show Panel Titles.</td>
</tr>
</tbody>
</table>

### To change tab behavior

You can control which tab displays after you exit a tool or clear a selection: the Modify tab, or the tab that displayed previously. You can also specify that a contextual tab does not display when you select elements.
1. Click ➤ Options.

2. On the User Interface tab of the Options dialog, under Tab Display Behavior, define the settings as desired.

**To reset the ribbon and Quick Access toolbar**

If you need to reset the ribbon to restore default settings, you can delete the UIState.dat file. UIState.dat is located in the following folder:

- **Windows XP:** %USERPROFILE%\Local Settings\Application Data\Autodesk\Revit\<product name and release>
- **Windows Vista or Windows 7:** %LOCALAPPDATA%\Autodesk\Revit\<product name and release>

**WARNING** Deleting UIState.dat also removes customizations to the Quick Access toolbar.

**Application Menu**

The application menu provides access to common file actions, such as New, Open, and Save. It also allows you to manage files using more advanced tools, such as Export and Publish.

Click to open the application menu.

To see choices for each menu item, click the arrow to its right. Then click the desired item in the list.

As a shortcut, you can click the main buttons in the application menu (on the left) to perform the default operation.

<table>
<thead>
<tr>
<th>Click the left side of...</th>
<th>to open the...</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="New" alt="New" /></td>
<td>New Project dialog</td>
</tr>
<tr>
<td><img src="Open" alt="Open" /></td>
<td>Open dialog</td>
</tr>
<tr>
<td><img src="Print" alt="Print" /></td>
<td>Print dialog</td>
</tr>
</tbody>
</table>
Click the left side of... | to open the...
---|---
 ![Publish] | DWF Publish Settings dialog
 ![Licensing] | Product and License Information dialog

**Recent Documents**

On the application menu, click the Recent Documents button to see a list of recently opened files. Use the drop-down list to change the sort order of recent documents. Use the push pins to keep documents on the list, regardless of how recently you opened them.

**Open Documents**

On the application menu, click the Open Documents button to see a list of all open views in open files. Select a view from the list to display it in the drawing area.

**Quick Access Toolbar**

The Quick Access toolbar contains a set of default tools. You can customize this toolbar to display the tools that you use most often.

![Quick Access Toolbar]

**To move the Quick Access toolbar**

The Quick Access toolbar can display above or below the ribbon. To change the setting, on the Quick Access toolbar, click Customize Quick Access Toolbar drop-down ➤ Show Below the Ribbon.

![Move Quick Access Toolbar]

**To add tools to the Quick Access toolbar**

Navigate the ribbon to display the tool that you want to add. Right-click the tool, and click Add to Quick Access Toolbar.

![Add to Quick Access Toolbar]

**NOTE** Some tools on contextual tabs cannot be added to the Quick Access toolbar.
If you removed default tools from the Quick Access toolbar, you can add them again by clicking the Customize Quick Access Toolbar drop-down, and selecting the tool to add.

**To customize the Quick Access toolbar**

To make a quick change to the Quick Access toolbar, right-click a tool on the Quick Access toolbar and select one of the following options:

- **Remove from Quick Access Toolbar** removes the tool.
- **Add Separator** adds a separator line to the right of the tool.

To make more extensive changes, on the Quick Access toolbar drop-down, click Customize Quick Access Toolbar. In the dialog, do the following:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>move tools up (left) or down (right) on the toolbar</td>
<td>in the list, select the tool. Then click ![Move Up] or ![Move Down] to move the tool to the desired location.</td>
</tr>
<tr>
<td>add a separator line</td>
<td>select the tool that will display above (to the left of) the separator line. Then click ![Add Separator].</td>
</tr>
<tr>
<td>remove a tool or separator line from the toolbar</td>
<td>select the tool or line and click ![Remove].</td>
</tr>
</tbody>
</table>

**Tool Tips**

Tool tips provide information about a tool in the user interface or an item in the drawing area, or instructions on what to do next when using a tool.

**Ribbon Tool tips**

When you hold the cursor over a tool on the ribbon, by default Revit Structure displays a tooltip. The tooltip provides a brief description of the tool. If you leave the cursor over the ribbon tool for another moment, additional information displays, if available. While the tooltip is visible, you can press F1 for context-sensitive help that provides more information about that tool.

**NOTE** If you press F1 before the tooltip displays, the default help topic opens instead of the appropriate context-sensitive help topic. Wait for the tooltip to display before pressing F1.
These tooltips are useful when you are first learning how to use the software. You can adjust the amount of information displayed in tooltips or how quickly the information displays. You can also turn off the tooltips when you no longer need them.

Some tooltips include embedded videos, called ToolClips™. These videos use motion to show how to use the tool. They play automatically when you display the tooltip. To see an example, display the tooltip for Modify tab ➤ Modify panel ➤ (Trim/Extend to Corner).

**NOTE** ToolClips™ are not supported on 64-bit computers.

**In-canvas tooltips**

When you are working in the drawing area, Revit Structure displays a tooltip near the cursor. This same information is repeated in the status bar.

- When you move the cursor over an element, the tooltip identifies the element, showing its category, family, and type.
- When you are using a tool, the tooltip provides hints on what to do next.

To turn off these tooltips, define the ToolTip assistance option as None, as described below.

**To adjust or turn off tooltips**

1. Click ➤ Options.
2. On the User Interface tab, for ToolTip assistance, select one of the following values:
   - **Minimal**: For ribbon tooltips, displays only the brief descriptions, suppressing the display of additional information. In-canvas tooltips display as usual.
   - **Normal**: (Default) For ribbon tooltips, displays a brief description when you move the cursor over a tool, followed by more information if you leave the cursor in place for another moment. In-canvas tooltips display as usual.
   - **High**: For ribbon tooltips, displays the brief description and more information about the tool (if available) at the same time, without a delay. In-canvas tooltips display as usual.
   - **None**: Turns off ribbon tooltips and in-canvas tooltips so they no longer display.

**NOTE** When you turn off tooltips, context-sensitive help (F1) is also turned off. If you want context-sensitive help to be available, set ToolTip assistance to Minimal.

**Keytips**

Keytips provide a way to access the application menu, the Quick Access toolbar, and the ribbon using the keyboard. To display keytips, press `Alt`.

You can use keytips to navigate through the ribbon. Type the keytip for a ribbon tab to bring that tab into focus and to display the keytips for its buttons and controls. If a ribbon tab has an expanded panel containing additional tools, type its keytip to display the panel and see keytips for those tools.

**Related topic**

- **Keyboard Shortcuts** on page 1559
Project Browser

The Project Browser shows a logical hierarchy for all views, schedules, sheets, families, groups, linked Revit models, and other parts of the current project. As you expand and collapse each branch, lower-level items display.

![Project Browser Image]

To change the size and location of the Project Browser

- To show the Project Browser, click View tab ➤ User Interface panel, and select the Project Browser check box.

- To hide the Project Browser, click View tab ➤ User Interface panel, and clear Project Browser, or click the Close button (the red X) at the top of the browser.

- To resize the Project Browser, drag one of its borders.

- To move the Project Browser, drag the browser’s title bar within the Revit window. As you move the cursor, an outline indicates where the browser will move to, and what its shape will be. Release the mouse button to place the browser in the desired location. You can also drag the Project Browser outside the Revit window to the desktop.

- To float the Project Browser in the drawing area, double-click its title bar. You can then move the browser to the desired location, and drag its borders to resize it.

You can customize the organization of project views in the Project Browser. See Customizing Project View Organization in the Project Browser on page 855.

Changes to the size and location of the Project Browser are saved and restored when the application is restarted.

Using the Project Browser

The Project Browser is a powerful way to navigate and manage complex projects.

Views, Schedules, Sheets

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>open a view</td>
<td>double-click the name of the view, or right-click the name and click Open from the shortcut menu. The active view name displays in bold.</td>
</tr>
</tbody>
</table>
### If you want to...  

<table>
<thead>
<tr>
<th>Action</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a view to a sheet</td>
<td>drag the view name onto the sheet name or onto the sheet in the drawing area. You can also right-click the sheet name, and click Add View on the shortcut menu. In the Views dialog, select the view to add, and click Add View to Sheet. After you perform one of these actions, the sheet is active in the drawing area, and the added view displays as a viewport. As you move the cursor, the viewport moves with it. When the viewport is in the desired location on the sheet, click to place it. See Adding Views to a Sheet on page 980.</td>
</tr>
<tr>
<td>remove a view from a sheet</td>
<td>under the sheet name, right-click the view name, and click Remove From Sheet.</td>
</tr>
<tr>
<td>create a new sheet</td>
<td>right-click the Sheets branch, and click New Sheet. See Adding a Sheet on page 979.</td>
</tr>
<tr>
<td>copy a view</td>
<td>right-click the view name, and click Duplicate View ➤ Duplicate.</td>
</tr>
<tr>
<td>copy a view with view-specific elements</td>
<td>right-click the view name, and click Duplicate View ➤ Duplicate with Detailing. View-specific elements (such as detail components and dimensions) are copied into the view. This tool is available for plan views, callout views, drafting views, and section views. You cannot copy callouts from plan views.</td>
</tr>
<tr>
<td>rename views, schedules</td>
<td>right-click the view name, and click Rename. In the Rename View dialog, enter a new name, and click OK.</td>
</tr>
<tr>
<td>rename a sheet</td>
<td>right-click the sheet name, and click Rename. In the Sheet Title dialog, enter a name and number for the sheet, and click OK.</td>
</tr>
<tr>
<td>close a view</td>
<td>right-click the view name, and click Close.</td>
</tr>
<tr>
<td>delete a view</td>
<td>right-click the view name and click Delete.</td>
</tr>
<tr>
<td>change properties</td>
<td>click the view name, and change properties in the Properties palette.</td>
</tr>
<tr>
<td>expand or collapse branches in the Project Browser</td>
<td>click + to expand, or click – to collapse. Use the arrow keys to navigate between branches.</td>
</tr>
<tr>
<td>find referring views</td>
<td>right-click the view name, and click Find Referring Views. See Finding Referring Views on page 855.</td>
</tr>
</tbody>
</table>

### Families

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new family type</td>
<td>right-click the family type name, and click Duplicate. A new type name displays in the type list. Double-click the new type to open the Type Properties dialog. See Revit Families on page 677.</td>
</tr>
<tr>
<td>rename a family</td>
<td>right-click the family name, and click Rename. Enter a new name. (You cannot rename a system family.)</td>
</tr>
<tr>
<td>If you want to...</td>
<td>then...</td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>create a new family instance in a view</td>
<td>right-click the family type name, and click Create Instance. This tool activates the appropriate tool and selects the appropriate type to create the selected family in the drawing area.</td>
</tr>
<tr>
<td>reload a family</td>
<td>right-click a loaded family, and click Reload. In the Open dialog, navigate to the family location, select it, and click Open. See Loading and Saving Families on page 688.</td>
</tr>
<tr>
<td>edit a family</td>
<td>right-click a loaded family, and click Edit. You can edit and reload the family directly into the project. See Modifying Families in a Project (or Nested Family) on page 692.</td>
</tr>
<tr>
<td>delete a family</td>
<td>right-click the family name and click Delete. If the project includes instances of that family, a dialog displays asking if you want to unload the family and delete all instances of it in the project. Click Yes to delete the family, or click No to cancel.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> This tool is not enabled for wall types.</td>
</tr>
<tr>
<td>modify type properties</td>
<td>double-click the type name under a family. For example, under the Walls family, double-click Exterior - Brick on CMU. The Type Properties dialog opens, and you can edit values.</td>
</tr>
<tr>
<td>delete a family type</td>
<td>Right-click the family type name, and click Delete. This function deletes family types that you may have created and families loaded into the project.</td>
</tr>
<tr>
<td>drag and drop family types into a project</td>
<td>select the family type, and drag it into the appropriate view. You can drag families created from loadable families and system families.</td>
</tr>
</tbody>
</table>

**Groups**

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>place a group instance in a view</td>
<td>under Groups, navigate to the desired group, then drag the group into the drawing area. See Placing Groups on page 1459.</td>
</tr>
</tbody>
</table>

30 | Chapter 4  User Interface
If you want to...  then...

modify group types  right-click the group type, and select one of the following tools:

  ■ Delete: Deletes the group type.
  ■ Rename: Renames the group type.
  ■ Select All Instances: Selects all instances of a group type in the project.
  ■ Properties: Changes type properties.

duplicate a group type  under Groups, navigate to the desired group, right-click the group name, and click Duplicate. The new group type displays in the Project Browser. See Duplicating Group Types on page 1458.

reload a group  under Groups, navigate to the desired group, right-click the group name, and click Reload. See Loading Groups on page 1458.

Revit Links

If you want to...  then...

create a new link to a Revit model  right-click the Revit Links branch, and click New Link. See Linking Revit Models on page 1183.

manage links to Revit models  right-click the Revit Links branch, click Manage Links, and click the Revit tab. See Managing Links on page 1203.

copy a linked Revit model to another project file  under Revit Links, navigate to the linked model to copy, right-click the link name, and click Create Instance. Click in the drawing area to place the new instance of the linked model. See Copying a Linked Model in the Host Model on page 1185.

unload or reload a linked Revit model  under Revit Links, navigate to the linked model, right-click the link name, and click the desired tool to unload or reload the model. See Managing Links on page 1203.

Renderings

If you want to...  then...

render an image  display a 3D view and click View tab ➤ Graphics panel ➤ ☑️ (Render).
If you want to... then...

| place rendered images onto sheets | drag the rendered image name onto the sheet in the drawing area. |

---

**Drawing Area**

The drawing area of the Revit window displays views (and sheets and schedules) of the current project. Each time you open a view in a project, by default the view displays in the drawing area on top of other open views. The other views are still open, but they are underneath the current view. Use tools of the View tab ➤ Windows panel to arrange project views to suit your work style.

The default color of the drawing area background is white; you can invert the color to black. (See instructions below.)

**To manage views in the drawing area**

- To display a project view that has not yet been opened, navigate to the view in the Project Browser, and double-click the view name.

- To see a list of open views, click View tab ➤ Windows panel ➤ Switch Windows drop-down. The bottom of the menu lists the open views. A check mark indicates the view that currently has focus in the drawing area.

- To display another open (but hidden) view in the drawing area, click View tab ➤ Windows panel ➤ Switch Windows drop-down, and click the view to display.

- To open a second window for the current view, click View tab ➤ Windows panel ➤ (Replicate). This tool is useful if you want to pan and zoom on certain areas of the design, while also viewing the entire design in another window. (Use the Tile tool to see both views at the same time.) Any changes that you make to the project in the new window also display in other windows of the project.

- To arrange all open windows in a series in the drawing area, click View tab ➤ Windows panel ➤ (Cascade).
To see all open views at the same time, click View tab ➤ Windows panel ➤  (Tile).

To close all hidden views, click View tab ➤ Windows panel ➤  (Close Hidden Windows). If more than one project is open, one window per project remains open.

To increase the size of the drawing area, click View tab ➤ Windows panel ➤ User Interface drop-down, and clear check boxes to hide interface components, such as the Project Browser and the status bar.

To invert the background color of the drawing area

1. Click ➤ Options.
2. In the Options dialog, click the Graphics tab.
3. Select or clear the Invert background color option.

To refresh the screen

Press F5.

Status Bar

The status bar is located along the bottom of the Revit window. When you are using a tool, the left side of the status bar provides tips or hints on what to do. When you are highlighting an element or component, the status bar displays the name of the family and type.

To hide the status bar

Click View tab ➤ Windows panel ➤ User Interface drop-down, and clear the Status Bar check box.
To hide only the Worksets or Design Options controls on the status bar, clear their corresponding check boxes.

The progress bar appears on the left side of the status bar when a large file is opening and indicates how much of the file has downloaded.

Several other controls appear on the right side of the status bar:

- **Worksets**: Provides quick access to the Worksets dialog for a workshared project. The display field shows the active workset. Use the drop-down list to display another open workset. See Using Worksets on page 1222.

- **Design Options**: Provides quick access to the Design Options dialog. The display field shows the active design option. Use the drop-down list to display another design option. See Working with Design Options on page 659. Use the Add to Set tool to add selected elements to the active design option.

- **Active Only**: Filters selections to select only active design option components. See Selecting Elements in Design Options and the Main Model on page 663.

- **Exclude Options**: Filters selections to exclude components that are part of a design option. See Selecting Elements in Design Options and the Main Model on page 663.

- **Press & Drag**: Allows you to drag an element without selecting it first.
Editable Only: Filters selections to select only editable, workshared components. See Filtering Non-Editable Workset Elements from Selection on page 1225.

Filter: Refines the element categories selected in a view. See Selecting Elements Using a Filter on page 1442.

Options Bar

The Options Bar is located below the ribbon. Its contents change depending on the current tool or selected element.

To move the Options Bar to the bottom of the Revit window (above the status bar), right-click the Options Bar, and click Dock at bottom.

Properties Palette

The Properties palette is a modeless dialog where you can view and modify the parameters that define the properties of elements in Revit.

Opening the Properties Palette

When you start Revit for the first time, the Properties palette is open and docked above the Project Browser on page 28 on the left side of the drawing area. If you subsequently close the Properties palette, you can reopen it using any of the following methods:

- Click Modify tab ➤ Properties panel ➤ (Properties).
- Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Properties.
- Right-click in the drawing area, and click Properties.

You can dock the palette to either side of the Revit window and resize it horizontally. You can resize it both horizontally and vertically when it is undocked. The display and location of the palette will persist from one Revit session to the next for the same user.

Typically you keep the Properties palette open during a Revit session so that you can

- Select the type of element you will place in the drawing area, or change the type of elements already placed (See Type Selector on page 35)
- View and modify the properties of the element you are placing or of elements selected in the drawing area (See Modifying Instance Properties on page 36)
- View and modify the properties of the active view (See View Properties on page 873)
- Access the type properties that apply to all instances of an element type (See Modifying Type Properties on page 38)
If no tool for placing elements is active, and no elements are selected, the palette displays the instance properties for the active view. (You can also access the instance properties of a view by selecting it in the Project Browser on page 28.)

Unless elements of different types are selected, the Edit Type button accesses a dialog where you can view and modify the type properties of the selected element (or those of the view, depending on how the properties filter is set; see Filtering the Display of Instance Properties on page 36). For more information on the distinction between instance properties and type properties, see Element Properties on page 15.

**NOTE** You can also access the type properties for the active tool or currently selected elements by clicking Modify tab ➤ Properties panel ➤ (Type Properties). When available, this button always accesses type properties for the selected element(s), or for a family type selected in the Project Browser on page 28. The Edit Type button on the palette, however, accesses type properties for the entity whose instance properties are currently displayed, which could be either the active view, the active tool, or a currently selected element type.

In most cases (see exceptions in note below), the Properties palette displays both user-editable and read-only (shaded) instance properties. A property may be read-only because its value is calculated or assigned automatically by the software, or because it depends on the setting of another property. For example, a wall’s Unconnected Height property is only editable if the value of its Top Constraint property is Unconnected. For specific dependencies, see the instance property descriptions for individual element types, such as Wall Instance Properties on page 488.

**NOTE** When you select the top node in the Project Browser (Views), or an individual family type, the Properties palette displays the associated read-only type properties. To modify the type properties, click Modify tab ➤ Properties panel ➤ (Type Properties). When you open the Family Editor, the palette displays family parameters by default.

**Type Selector**

When a tool for placing elements is active, or elements of the same type are selected in the drawing area, the Type Selector displays at the top of the Properties palette. It identifies the currently selected family type and provides a drop-down from which you can select a different type.
To make the Type Selector available when the Properties palette is closed, right-click within the Type Selector, and click Add to Quick Access Toolbar.

**Filtering the Display of Instance Properties**

Immediately below the Type Selector is a filter that identifies the category of the elements a tool will place, or the category and number of elements selected in the drawing area. If multiple categories or types are selected, only the instance properties common to all display on the palette. When multiple categories are selected, use the filter's drop-down to view only the properties for a specific category or for the view itself. Selecting a specific category does not affect the overall selection set.

**Modifying Instance Properties**

Use the Properties palette to modify the instance properties of

- the element you are about to place using a tool
- elements selected in the drawing area
- the active view
The content of the Properties palette varies according to the situation. If a tool is active, or one or more elements of the same type are selected, the Type Selector on page 35 at the top of the palette identifies the currently selected family type. In the following example, a single beam is selected.

Immediately below the Type Selector is a filter that identifies the category of the elements a tool will place, or the category and number of elements selected in the drawing area. If multiple categories or types are selected, only the instance properties common to all display on the palette. When multiple categories are selected, use the filter's drop-down to view the properties for a specific category.

If no tool for placing elements is active, and no elements are selected in the drawing area, the palette displays the instance properties of the active view.

The Properties palette displays both user-editable and read-only properties. To modify a user-editable property value, click it and either enter a new value, select one from a drop-down list, or select/clear a check box. For some properties, the value box contains a button that opens a dialog or browser window in which you define the desired value.

To commit a change you make to a property value, do any of the following:

■ Move the cursor off the palette.
■ Press Enter (twice if a new value is selected from a drop-down).
■ Click Apply.

If making multiple changes, you can press Tab to move from one property to the next, or just click the next one you want to change. You can then use any of the methods listed above to commit all your changes at once.

To cancel changes before committing them, press Esc twice. Closing the palette also cancels your changes.

For specific information about the instance properties of a particular element, see the Help topic for that element type, for example, Wall Instance Properties on page 488.
Modifying Type Properties

Use the Type Properties dialog to modify the type properties of

■ the element you are about to place using a tool
■ one or more elements of the same type selected in the drawing area
■ the active view (when no tool is active and no elements are selected)

Note that any changes you make to type properties will apply to all instances of that type within the project.

To open the Type Properties dialog, do either of the following:

■ Click Modify tab ➤ Properties panel ➤ (Type Properties).
■ On the Properties palette, click (Edit Type).

Related topics
■ Creating a New Family Type in a Project on page 38
■ Previewing Family Types on page 39

Creating a New Family Type in a Project

You can add a new type to the family and change the parameters for that type. This feature allows you to define an entire family of different-sized components within the project.

NOTE A new family type created in the project exists only in that project.

To create a new family type in a project

1 In the drawing area, select an element belonging to the desired type.
2 On the Properties palette, click (Edit Type).
3 In the Type Properties dialog, click Duplicate.
4 In the Name dialog, enter a name for the new type and click OK.
5 Specify properties for the type, as desired.
6 To preview the new element type, click Preview. See Previewing Family Types on page 39.
7 In the Type Properties dialog, click OK.

The new type displays in the Type Selector on page 35, indicating that the new type is assigned to the selected element.

Related topics
■ Revit Families on page 677
■ Working with Families on page 680
■ Loading and Saving Families on page 688
Previewing Family Types

The Type Properties dialog features a preview window that shows an image of the family type. As you set parameters and change values for the type, the image in the window updates accordingly.

To preview a family type

1. In the drawing area, select an element belonging to the desired type.

2. On the Properties palette, click \(\text{(Edit Type)}\). The Type Properties dialog displays.

3. To see (or hide) a preview of the family type, click the Preview button at the bottom of the dialog. As you change type parameters, the preview image updates to reflect the changes.

Manipulating the preview image of a family type

4. To control the appearance of the preview image, do any of the following:
   - For View, select a view name to see how this type of element will appear in a different view.
   - Use the scroll bars to move the image up, down, left, or right in the preview window.
   - Use the SteeringWheels navigation tool. If you are previewing a 3D view of the element, you can also use the ViewCube. See Navigating Views on page 818.

The following is an example of a Type Properties dialog for a wall type, with the Preview pane displayed.

View Control Bar

The View Control Bar is located at the bottom of the view window above the status bar.
It provides quick access to functions that affect the current view, including the following:

- Scale (See View Scale on page 860.)
- Detail Level (See Detail Level on page 1618.)
- Visual Style (See Visual Styles on page 867.)
- Sun Path On/Off (See Displaying Sun and Shadows on page 1375.)
- Shadows On/Off (See Displaying Sun and Shadows on page 1375.)
- Show/Hide Rendering Dialog (Available only when the drawing area displays a 3D view. See Defining Render Settings on page 1077.)
- Crop View (See Crop Regions on page 849.)
- Show/Hide Crop Region (See Showing or Hiding Crop Regions on page 850.)
- Temporary Hide/Isolate (See Temporarily Hiding or Isolating Elements or Element Categories on page 812.)
- Reveal Hidden Elements (See Revealing and Unhiding Hidden Elements on page 812.)

Recent Files

When you start Revit Structure, by default the Recent Files window displays, listing the projects and families that you opened most recently. Click a recent project or family to open it, or use one of the buttons to perform another action.

If you are already working in a Revit session, return to the Recent Files window by clicking View tab ➤ Windows panel ➤ User Interface drop-down ➤ Recent Files.

InfoCenter

You can use InfoCenter to search a variety of information sources with one query. You can also easily access product updates and announcements.

Overview of InfoCenter

You can use InfoCenter to search for information, display the Subscription Center panel for subscription services, display the Communication Center panel for product updates, and display favorites panel to access saved topics.

You can use InfoCenter to:

- Search for information through keywords (or by entering a phrase)
- Access subscription services through Subscription Center panel
- Access to product-related updates and announcements through Communication Center panel
- Access saved topics through Favorites panel
- Access topics in Help
To display the InfoCenter box in a collapsed state, click the arrow to its left.

To browse search results

➤ On the panel for Search Results, Subscription Center, Communication Center, or Favorites, on the right side of the category header, do one of the following:
   ■ Click the Next button.
   ■ Click the Previous button.

To rearrange the topics displayed on a panel

1 Display a panel by doing one of the following:
   ■ In the InfoCenter box, enter a keyword or phrase. Then press ENTER or click the Search button.
   ■ In the InfoCenter box, click the Communication Center button.
   ■ In the InfoCenter box, click the Favorites button.

2 Click and drag a category or group header to the desired position.

NOTE You can rearrange categories within a group, but you cannot move them into other groups.

Search For Information

You can enter keywords or a phrase in the InfoCenter box to search for information.

When you enter keywords or a phrase in the InfoCenter box, you search the contents of multiple Help resources as well as any additional documents that have been specified in the InfoCenter Settings dialog box or through the CAD Manager Control Utility.

NOTE You must have Internet access to display search results from the Autodesk Online category.

Keyword searches produce better results. In case of a misspelled word, spelling suggestions are displayed on the panel.

The results are displayed as links on the InfoCenter Search Results panel. Click a link to display the topic, article, or document.

To keep Search Results, Subscription Center, Communication Center, and the Favorites panel expanded, click the push pin icon in the bottom-right corner of the panel.
When you use InfoCenter to search for information, you can use the following special symbols in your query to refine or expand it. These symbols can be used alone or can be combined.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Replaces one or more characters when used at the beginning, middle, or end of a word. For example, “<em>lish”, “p</em>lish”, and “pub*” will find “publish”. Also, “anno*” will find “annotative”, “annotation”, “annoupdate”, “annoreset”, and so on.</td>
</tr>
<tr>
<td>?</td>
<td>Replaces a single character. For example, “cop?” will find “copy”, but not “copybase”.</td>
</tr>
<tr>
<td>~</td>
<td>Adds grammatical form variations to a keyword when added at the beginning or end of a word. For example, “plotting~” will find “plots”, “plotted”, and so on. Also, “~plot” will find “preplot”, “replot”, and so on.</td>
</tr>
</tbody>
</table>

When performing the exact phrase search, use double quotation marks (" ") to enclose words that must appear next to each other in the specified text string. For example, enter "specify units of measurement" to find only topics with all those words in that order. You can also use the previously mentioned symbols in a text string that is enclosed in double quotation marks.

**To search multiple sources for information**

1. In the InfoCenter box, enter a keyword or phrase.
2. Click the Search button.

The search results display in the Search Results panel.

**To search a single location for information**

1. In the InfoCenter box, enter a keyword or phrase.
2. Click the down arrow next to the Search button.
3. Select a location from the list to search.

The search results from that location display in the Search Results panel.

**To add a location to search**

1. In the InfoCenter box, click the down arrow next to the Search button.
2. Click Add Search Location.
3. In the Add Search Location dialog box, specify a document or a file location to search.
4. Click Add.

**Receive Product Updates and Announcements**

You can click the Communication Center button to display links to information about product updates and announcements, and may include links to RSS feeds.
Overview of Communication Center

To open Communication Center, click the Communication Center button in the InfoCenter box.

Communication Center provides the following types of announcements:

- **Autodesk Channels**: Receive support information, product updates, and other announcements (including articles and tips).
- **CAD Manager Channel**: Receive information (RSS feeds) published by your CAD manager.
- **RSS Feeds**: Receive information from RSS feeds to which you subscribe. RSS feeds generally notify you when new content is posted. You are automatically subscribed to several default RSS feeds when you install the program.

You can customize the items that display in the Communication Center panel.

**Communication Center Online Policy**

Communication Center is an interactive feature that must be connected to the Internet in order to deliver content and information. Each time Communication Center is connected, it sends your information to Autodesk so that you receive the correct information. All information is sent anonymously to Autodesk to maintain your privacy.

Communication Center sends the following information to Autodesk:

- Product name (in which you are using Communication Center)
- Product release number
- Product language
- Country/region (specified in the Communication Center settings)
- Your unique Customer Involvement Program (CIP) ID if you are participating in the CIP program

Autodesk compiles statistics using the information sent from Communication Center to monitor how it is being used and how it can be improved. Autodesk maintains information provided by or collected from you in accordance with the company’s published privacy policy, which is available at [http://www.autodesk.com/privacy](http://www.autodesk.com/privacy).

**Receive New Information Notifications**

Whenever new information is available, Communication Center notifies you by displaying a balloon message below the Communication Center button on the InfoCenter box.

Click the link in the balloon message to open the article or announcement.

If you don’t want to receive Communication Center notifications, in the InfoCenter Settings dialog box, turn off Balloon Notification.

**Save and Access Favorite Topics**

You can click the Favorites button to display saved links to topics or web locations.
Any link that displays on the Search Results panel, Subscription Center or Communication Center panel can be marked as a favorite.

A link marked as a favorite displays a star icon on the Search Results panel, Subscription Center panel or the Communication Center panel.

To display the InfoCenter Favorites panel

- In the InfoCenter box, click the Favorites button.

**NOTE** The links displayed on the Favorites panel are organized into the same groups or categories from which they were added.

To save a link in InfoCenter as a favorite

1. Display a panel by doing one of the following:
   - In the InfoCenter box, enter a keyword or phrase. Then press ENTER or click the Search button.
   - In the InfoCenter box, click the Subscription Center button.
   - In the InfoCenter box, click the Communication Center button.

2. Click the star icon that is displayed next to the link that you want to save as a favorite.

To remove a favorite link from the InfoCenter Favorites panel

1. In the InfoCenter box, click the Favorites button to display the Favorites panel.

2. Click the star icon that is displayed next to the link that you want to remove from the Favorites panel.

Specify InfoCenter Settings

You can specify InfoCenter Search and Communication Center settings in the InfoCenter Settings dialog box.

In the InfoCenter Settings dialog box, you can specify the following settings:

- **General.** Your current location, frequency for checking new online content and option to turn on or off animated transition effects for the InfoCenter panels.

- **Search Locations.** Locations (documents, web locations, and files) to search for information, as well as the name that displays for each location and the number of results to display for each. Also, you can add or remove search locations. The Web Locations check box provides access to important information on the Autodesk website, including the Knowledge Base and discussion groups. When you add document locations, you can specify files on your local drive.

  **NOTE** User-specified CHM (compiled help) files must be located on your local drive. InfoCenter cannot search CHM files located on network drives.

- **Communication Center.** Maximum age of the articles displayed on the Communication Center panel and the location and name of the CAD Manager Channel.
Autodesk Channels. Channels to display in the Communication Center panel as well as the number of articles to display for each channel.

Balloon Notification. Notifications for new product information, software updates, and product support announcements. Also, you can customize the transparency and the display time of the balloon.

RSS Feeds. RSS feed subscriptions. You can add or remove RSS feeds. RSS feeds generally notify you when new content is posted.

You can use the CAD Manager Control Utility to specify InfoCenter Search and Communication Center settings. Click Help in the CAD Manager Control Utility window for details about the CAD Manager Channel settings you can control.

To specify locations to search for information
1  In the InfoCenter box, click the down arrow next to the Search button.
2  Click Search Settings.
3  In the InfoCenter Settings dialog box, Search Locations panel, in the right pane, select or clear the search locations you want to include or exclude when you search for information.
4  Click OK.

NOTE With the Search All Available Languages option, you can specify whether to search the default language or all available languages, including English, Japanese, and French. Select the check box if you want to search all available languages.

To add a new location to search for information
1  In the InfoCenter box, click the down arrow next to the Search button.
2  Click Search Settings.
3  In the InfoCenter Settings dialog box, do one of the following:
   ■  On the Search Locations panel, in the right pane, click Add.
   ■  On the Search Locations panel, in the right pane, right-click anywhere in the pane. Click Add.
4  In the Add Search Location dialog box, specify a file location to search.
5  Click Add.

NOTE A warning message is displayed when you add a search location with a file size larger than 5 MB. You cannot continue to work in the application until indexing is complete.

6  Click OK.

To remove a search location
1  In the InfoCenter box, click the down arrow next to the Search button.
2  Click Search Settings.
3  In the InfoCenter Settings dialog box, do one of the following:
   ■  Select a location to remove, and then click Remove.
   ■  Right-click a search location. Click Remove.
4  In the InfoCenter - Remove Search Location dialog box, click Yes.
5 Click OK.

**To specify the CAD Manager Channel location and name**

1 Click Start menu (Windows) ➤ All Programs (or Programs) ➤ Autodesk ➤ CAD Manager Tools ➤ CAD Manager Control Utility.

2 Select the product you want to modify. Click OK.

3 In the CAD Manager Control Utility window, InfoCenter tab, select the option to enable CAD Manager Channel.

4 Under Feed Location, enter an appropriate feed.

5 Enter the display name for the CAD Manager and then click Apply. Click OK.

6 Restart your Autodesk product.

7 In the InfoCenter box, click the down arrow next to the Search button.

8 Click Search Settings.

9 In the InfoCenter Settings dialog box, in the left pane, click Communication Center.

   The CAD Manager Channel location and name are displayed.

**NOTE** A green check mark is displayed if the channel can be located and a yellow warning sign is displayed if it cannot be located.

**To specify the channels to display in the Communication Center panel**

1 In the InfoCenter box, click the down arrow next to the Search button.

2 Click Search Settings.

3 In the InfoCenter Settings dialog box, in the left pane, click Autodesk Channels.

4 In the right pane, select or clear the channels you want to display in the Communication Center panel.

5 Click OK.

**To specify InfoCenter balloon notification settings**

1 In the InfoCenter box, click the down arrow next to the Search button.

2 Click Search Settings.

3 In the InfoCenter Settings dialog box, in the left pane, click Balloon Notification.

4 In the right pane, select or clear the options to turn balloon notification on or off.

5 Enter the number of seconds to set the length of time for balloon notifications to display.

6 Enter the transparency value of the balloon or set the value using the slider.

7 Click OK.

**To add an RSS feed to Communication Center**

1 In the InfoCenter box, click the down arrow next to the Search button.

2 Click Search Settings.

3 In the InfoCenter Settings dialog box, in the left pane, click RSS Feeds.
4 In the right pane, do one of the following:
   ■ Click Add.
   ■ Right-click anywhere in the right pane. Click Add.

5 In the Add RSS Feed dialog box, enter the location of the RSS feed you want to add. Click Add.

6 In the InfoCenter - RSS Feed Confirmation dialog box, click Close.

7 Click OK.

To remove an RSS feed from Communication Center
1 In the InfoCenter box, click the down arrow next to the Search button.
2 Click Search Settings.
3 In the InfoCenter Settings dialog box, in the left pane, click RSS Feeds.
4 In the right pane, do one of the following:
   ■ Click Remove.
   ■ Right-click an RSS feed. Click Remove.

5 In the InfoCenter - Remove RSS Feed dialog box, click Yes.

6 Click OK.

Search Topics in Help
You can click the Help button to display topics in Help.

You can get much more benefit from the Help system when you learn how to use it efficiently. You can quickly find general descriptions, procedures, details about dialog boxes and palettes, or definitions of terms.

To display topics in Help
   ■ In the InfoCenter box, click the Help button.

Autodesk® Seek
Use Autodesk Seek to search for and share product design content from AutoCAD® and Revit® products. For information about sharing product design content with Autodesk Seek, see Publishing to Autodesk® Seek on page 1142.

NOTE Autodesk Seek is currently available only in the English edition of the software.

You can access Autodesk Seek in the following ways:
   ■ Click Insert tab ➤ Autodesk Seek panel to search for content.
Click ➤ Publish ➤ (Share with Autodesk Seek to share online content.)

Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Recent Files. In the Recent Files window, click Web Library.

With Autodesk® Seek you can find and share product design information with the online design community to enhance designs and to meet specific customer needs. It allows designers to search for, download, and integrate generic or manufacturer-specific building products or components and associated design information.

When you are working in a design program, you may want to include products that, for example, meet design standards for Leadership in Energy and Environmental Design (LEED) or the Americans with Disabilities Act (ADA). Autodesk Seek can help you locate such information and products, and get them into your design.

For more information about LEED green building certification, visit the U.S. Green Building Council website: http://www.usgbc.org.

For more information about ADA standards for accessible design, visit U.S. Department of Justice website: http://www.usdoj.gov/crt/ada/.

The design and product information available on Autodesk Seek depends on what content providers, both corporate partners and individual contributors, publish to Autodesk Seek. Such content could include 3D models, 2D drawings, specifications, brochures, or descriptions of products or components.

Autodesk has partnered with content aggregators such as BIMWorld™ and the McGraw-Hill Construction Sweets Network®, who maintain relationships with manufacturers, to provide and maintain product and design information within Autodesk Seek.

Autodesk® Seek also contains all files from the content libraries provided with the 2008 and later releases of the following products:

- AutoCAD®
- AutoCAD® Architecture
- AutoCAD® MEP
- Revit® Structure
- Revit® Architecture
- Revit® MEP

Currently, Autodesk Seek is intended primarily for the AEC/building industry. In the future, Autodesk Seek will expand to include product information that is more typically used in other industries.

**File Types Supported by Autodesk Seek**

The following list includes file types currently supported by Autodesk Seek.

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3DS</td>
<td>3D Studio scene file</td>
</tr>
<tr>
<td>DGN</td>
<td>MicroStation drawing file</td>
</tr>
<tr>
<td>DOC</td>
<td>Microsoft Word document</td>
</tr>
<tr>
<td>DWF</td>
<td>Autodesk’s open, secure format for sharing design information</td>
</tr>
<tr>
<td>File Type</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>DWG</td>
<td>Industry standard file format for 2D and 3D design data</td>
</tr>
<tr>
<td>DXF</td>
<td>Autodesk Drawing Exchange Format — enables data interoperability between AutoCAD and other design programs</td>
</tr>
<tr>
<td>IES</td>
<td>Photometric data file</td>
</tr>
<tr>
<td>GSM</td>
<td>ArchiCAD Graphic Description Language file</td>
</tr>
<tr>
<td>LCF</td>
<td>ArchiCAD library container file</td>
</tr>
<tr>
<td>MCD</td>
<td>Mathcad document file</td>
</tr>
<tr>
<td>MLIB</td>
<td>Revit material library file</td>
</tr>
<tr>
<td>PDF</td>
<td>Adobe portable document format</td>
</tr>
<tr>
<td>RFA</td>
<td>Revit family file</td>
</tr>
<tr>
<td>RTE</td>
<td>Revit template file</td>
</tr>
<tr>
<td>RTF</td>
<td>Rich Text Format file</td>
</tr>
<tr>
<td>RVG</td>
<td>Revit External Group file</td>
</tr>
<tr>
<td>RVT</td>
<td>Revit project file</td>
</tr>
<tr>
<td>SKP</td>
<td>SketchUp Document file</td>
</tr>
<tr>
<td>TXT</td>
<td>Text file</td>
</tr>
<tr>
<td>XLS</td>
<td>Microsoft Excel spreadsheet</td>
</tr>
<tr>
<td>ZIP</td>
<td>Compressed archive file</td>
</tr>
</tbody>
</table>

**Searching for Content with Autodesk Seek**

You can enhance your designs by acquiring product or design information published by Autodesk, partner content providers, or other designers on Autodesk Seek.

**NOTE** Autodesk Seek is currently available only in the English edition of the software.

Autodesk® Seek supports parametric searches, meaning that the search results returned are more or less specific depending on what you enter in the search text box. More search terms return fewer results.

**Filtering Search Results**

After you have searched for product information, you can reduce the number of displayed results by applying filters. On the Autodesk Seek web page, apply filters to narrow the results of a search.

Available filters depend on information supplied by content providers when the design files are added to the Autodesk Seek website.
Filters

- **Product Attributes.** Filter results by attributes common to the returned results. The attribute filters available vary depending upon the type of product searched.

- **Manufacturer.** Filter results by manufacturer. Manufacturer names are displayed in descending order by the number of results associated with each manufacturer. The Generic filter displays results for which no manufacturer information has been supplied.

- **File Type.** Filter results by file type. The file type filter excludes results that do not contain product or design information of the type selected.

- **External Catalogs.** Filter results by supplier catalog, such as BIMWorld.

- **Product Libraries.** Filter results by Autodesk product library, such as Revit Structure.

**Downloading Content from Autodesk Seek**

After you have located product or design information that you want to add to your design, you need to get it from the Autodesk Seek website and into your drawing.

**NOTE** The first time you download a file, you must agree to and accept the Autodesk Seek terms and conditions. Accepting the terms installs a cookie on your computer. If you clear your web browser’s cookies, you will need to accept the Autodesk Seek terms and conditions the next time you download a file.

**To perform a search**

1. Click Insert tab ➤ Autodesk Seek panel ➤ Find product design files online, and enter the desired search term.

   **NOTE** Autodesk Seek searches all available product information by default.

2. Press Enter or click (Search Seek Online) to search.

   The Autodesk website displays the results.

   **NOTE** To return fewer results, enter more terms in the text box. For example, a search for “window” returns more results than a search for “fixed window 3D.”

**To accept the Autodesk Seek Terms and Conditions and download a file**

1. To review the terms and conditions of use, click Terms and Conditions.

   The Autodesk Seek Terms of Use are displayed in a browser window. When ready to proceed, close the browser window to return to the Terms and Conditions page.

2. Click the I Have Read and Agree to the Terms and Conditions check box.

3. Click Accept. The File Download dialog box displays.

4. Do one of the following:

   - To display the file in its associated program, click Open.
   - To save the file, click Save. If necessary, specify a new file location and file name.

You can use Autodesk i-drop® to drag and drop content from a website into your drawing session. However, you cannot use i-drop to download ZIP files.
NOTE To enable i-drop you must first download and install it. For more information visit http://www.autodesk.com/idrop.

To i-drop a file into your drawing

1. On the Autodesk Seek website, move your cursor over an available download displaying the i-drop icon.
2. Click and drag the file.
3. Drop the file at the desired location in your drawing and, if necessary, reposition it.

Where to extract the contents from a ZIP file

1. If a Readme TXT file exists, open it to determine where you should extract each file in the ZIP file.
2. Extract the files to the locations specified in the Readme. If the family does not have a Readme, extract the files to the locations specified in the following table.

NOTE These locations are the default Windows XP, Windows Vista®, and Windows 7 paths that are set during installation. Because these paths can be changed during installation, your paths might be different.

<table>
<thead>
<tr>
<th>File Type</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Family (RFA)</td>
<td>The Revit library, which is installed by default in</td>
</tr>
<tr>
<td></td>
<td>Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk&lt;Revit release name&gt;\Imperial or Metric \Library</td>
</tr>
<tr>
<td></td>
<td>Windows Vista or Windows 7: C:\ProgramData\Autodesk&lt;Revit release name&gt;\Imperial or Metric \Library</td>
</tr>
<tr>
<td>Type catalogs (TXT) that manage parameters for families with many type variations</td>
<td>The same folder as the RFA file</td>
</tr>
<tr>
<td></td>
<td>NOTE The type catalog must have exactly the same name as its family RFA file. The names are case-sensitive.</td>
</tr>
<tr>
<td>Lookup tables (CSV) that Revit MEP components use to define instance parameters</td>
<td>Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk&lt;Revit MEP release name&gt;\LookupTables</td>
</tr>
<tr>
<td></td>
<td>Windows Vista or Windows 7: C:\ProgramData\Autodesk&lt;Revit MEP release name&gt;\LookupTables</td>
</tr>
<tr>
<td>Image files (BMP, JPG, JPEG, or PNG) used to create a custom color, design, texture, or bump map for a render appearance</td>
<td>Windows XP: C:\Program Files\Autodesk&lt;Revit release name&gt;\Data\Rendering\assetlibrary_base.fbm</td>
</tr>
<tr>
<td></td>
<td>Windows Vista or Windows 7: C:\Program Files\Autodesk&lt;Revit release name&gt;\Data\Rendering\assetlibrary_base.fbm</td>
</tr>
<tr>
<td>File Type</td>
<td>Location</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
</tr>
</tbody>
</table>
| Photometric data files (IES) for use with lighting families | Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk\<Revit release name>\IES  
Windows Vista or Windows 7: C:\ProgramData\Autodesk\<Revit release name>\IES |

**Online Help**

To access online help, do one of the following:

- In the title bar of the Revit window, click (Help).
- For context-sensitive help:
  - In a dialog, click or Help.
  - Move the cursor over a tool on the ribbon. When its tooltip displays, press F1.

**NOTE** If you turn off tooltips, context-sensitive help (F1) for ribbon tools is also turned off. If you want context-sensitive help to be available, set Tooltip assistance to Minimal. See Tooltips on page 26.

To access online help and other resources, in the title bar of the Revit window, click the arrow to the right of (Help), and select an option.

**Videos in help topics**

Some help topics provide a link to a short video. Click the link to watch the video. It opens in a separate window.

These help videos do not run on 64-bit computers. When you try to play a video, it prompts you to install Adobe® Flash®, and then the video will not run.

Currently, Adobe Flash Player does not support playback in a 64-bit browser. You can run it on 32-bit browsers installed on 64-bit computers, but by default Revit Structure uses the 64-bit browser for online help.

**To view a help video on a 64-bit computer**

1. Open the help topic that contains a video link.
2. Click the video link.
3. Right-click in the video window, and select Jump to URL.
4. Copy the text from the Current URL dialog.
5. Launch 32-bit Internet Explorer, and paste the contents into the address bar.
Start a Project
Creating a Project

When creating a project in Revit Structure, you can

- Use default settings, which are defined in a project template. Revit Structure includes a default template called *Structural Analysis-default.rte*, which contains several settings to help you begin the design process immediately. For information about changing the default template, see File Location Options on page 1625.

- Use a custom template.

Creating a Project Using Default Settings

Use this procedure when you want to use the default template. It skips the step of specifying the template to use when creating the project.

Do one of the following:

- Press Ctrl+N.
- On the Recent Files on page 40 window, under Projects, click New.

Revit Structure creates a project file, using settings in the default template. The default project name displays in the title bar of the Revit window. To assign a different file name, click ➤ (Save As).

Creating a Project Using a Template

Use this procedure when you want to be able to specify the template to use when creating the project.

1. Click ➤ New ➤ (Project).
2. In the New Project dialog, for Template file, click Browse.
3. Navigate to the location of the desired project template, select the template file (with the file type RTE), and click Open.
Revit Structure provides several project templates, which reside in the Metric Templates or Imperial Templates folder in the following location:

- **Windows XP**: C:\Documents and Settings\All Users\Application Data\Autodesk\<product name and release>\n- **Windows Vista or Windows 7**: C:\ProgramData\Autodesk\<product name and release>\n
You can use one of these templates or create your own templates as needed to maintain corporate standards or to simplify the setup process for different types of projects.

4 For Create new, click Project.
5 Click OK.

Revit Structure creates a project file using the settings defined by the specified template. The default project name appears in the title bar of the Revit window. To assign a different file name, click ➤ (Save As).

**Related topics**
- Creating a Template on page 1633
- Project Template Settings on page 1634

**Before You Begin a Project**

Before you start adding content to a Revit project, consider the following approaches to the design process:

- **Using levels and grids**. Begin the design process by defining levels and grids for the model. See Levels on page 93 and Grids on page 98.

- **Importing data**. If you started the design process using another CAD program (such as AutoCAD), you can import existing data. Revit Structure imports various CAD formats, including DWG, DXF, DGN, and ACIS SAT files, as well as SketchUp (SKP) files and Industry Foundation Classes (IFC). See Import/Link Overview on page 57.

- **Massing**. You can start a project by designing a conceptual model. After you create basic shapes with the massing tools, you can convert mass faces to building elements. See Massing Studies on page 1329 and Conceptual Design Environment on page 135.
Using Information from Other Sources

Read these topics to learn how to incorporate information from other sources into Revit projects.

Import/Link Overview

The Import and Link tools allows you to import or link to various file formats.

Different file formats may be imported with different qualities of geometry. For information about variations in imported geometry, see Suitability of Imported Geometry on page 57.

When you import files, you may need to zoom in the drawing area to see the imported data. See Zooming Project Views on page 860.

For information about linking Revit models, see Linked Models on page 1177.

Suitability of Imported Geometry

When you import a file into Revit Structure, the format of the imported file may support varying qualities of geometry. These variations are caused by the file type, the export settings, and the import settings.

Some tools and capabilities in Revit Structure require specific types of geometry. For example:

- The Join Geometry tool requires volumetric geometry.
- Rendering an image requires that faces are associated with material properties.
- The Roof by Face tool requires geometry with suitably sized faces for flat roof panels or a NURB representation of a complex, shaped roof panel.
- Masses require volumetric geometry to calculate volume, surface area, and floor area faces. See Considerations for Imported Geometry in Mass or Generic Model Families on page 1366 and Importing Massing Studies from Other Applications on page 1366.

You can import many different types of file formats into Revit Structure. When you export a file from the originating application for use with Revit Structure, you can set a variety of export options. With these many variations of file formats and export options, it is important to ensure that the exported file provides the
geometric data needed for the Revit capability that you plan to use. To optimize results with various file
formats, consult the documentation provided with the exporting applications.

Implications of Importing vs. Linking for Xrefs

Suppose you use AutoCAD to generate a DWG file that contains external references (xrefs). When you import
or link the DWG file, Revit Structure displays the geometry from the nested xrefs. The decision to import
or link a file to a Revit project affects what you can do with the xref information:

- If you **import** the file, you can explode the nested xrefs to Revit elements. However, if the xref file is
  updated after the import, Revit Structure will not automatically reflect changes to the xref file.
- If you **link** the file, Revit Structure automatically updates the geometry to reflect changes to the xref files.
  However, you cannot explode the nested xrefs to Revit elements.

For more information, see Exploding Imported Geometry on page 75.

Importing or Linking CAD Formats

Open a Revit project, and use the Import CAD or Link CAD tools to import or link vector data from other
CAD programs such as AutoCAD (DWG and DXF), MicroStation® (DGN), SketchUp (SKP and DWG), and
ACIS (SAT). Revit Structure supports importing most DGN surfaces and solids with the exceptions of cones,
B-Spline surfaces, and SmartSolids.

In addition to using the Import CAD and Link CAD tools, you can import CAD files using drag-and-drop
from Windows® Explorer onto a model, drafting, or sheet view of Revit Structure. See Importing CAD Files
Using i-drop on page 59.

You can mirror imported and linked CAD files. See Mirroring Elements on page 1483.

**NOTE** Revit Structure imports ACIS solids from SAT files. SAT file formats later than version 7.0 do not import into
Revit Structure. You should determine which version your solid modeling program is creating. Some solid modeling
products (such as form-Z®) create SAT file formats later than version 7.0 by default.

Snapping to Imported Geometry

Suppose that you import an AutoCAD® drawing into Revit Structure and then want to trace over walls in
that drawing. As you place the cursor near the lines representing the walls, it can snap to the lines or the
midpoint between the lines.

Proxy Graphics from AutoCAD Files

Revit Structure supports reading in proxy graphics from AutoCAD files. Proxy graphics are AutoCAD’s
representations of AutoCAD Architecture objects. Unlike AutoCAD Architecture objects, proxy graphics have
no intelligence.

Proxy graphics can exist for many types of data in AutoCAD, including Mechanical Desktop (MDT) parts
and AutoCAD Runtime eXtension (ARX) objects. If you set the Proxygraphics command to 1 in AutoCAD,
Revit Structure can then import ARX objects and AutoCAD Architecture objects (such as walls and floors)
in the DWG or DXF file.

Subdivision Surfaces and Solids Created in AutoCAD

Revit Structure can import DWG files containing subdivision surfaces and solids created in AutoCAD. Some
complex subdivision meshes may fail to convert to a traditional solid or surface altogether, or generate a
problematic solid or surface. Other highly complex SubD meshes may not import completely or at all.
Cutting Imported Geometry

When you import a 3D DWG file into a Revit Structure project, the imported DWG geometry will not be cut. For example, if you create a level at the elevation of a typical wall and then go to that plan view, the imported geometry will not cut at that level. However, if you import the geometry into a cuttable in-place family (such as Generic Model), the geometry will cut in accordance with Revit Structure’s cut planes.

Importing or Linking CAD Files Using the Import CAD and Link CAD Tools

1. Click Insert tab ➤ Import panel ➤ (Import CAD), or click Insert tab ➤ Link panel ➤ (Link CAD).
   
   If you link the file instead of importing it, see Implications of Importing vs. Linking for Xrefs on page 58.

2. In the Import CAD Formats or Link CAD Formats dialog, navigate to the folder that contains the file to import or link.

   TIP Make sure you import the geometric data needed for the Revit capability that you plan to use. For more information, see Suitability of Imported Geometry on page 57.

3. Select the file.

4. Specify the import or link options. See Import and Link Options for CAD Formats and Revit Models on page 63.

5. Click Open.

   NOTE If you open a DGN file, the Select View dialog displays. Select a view to open. The view corresponds exactly to the MicroStation view and imports into Revit Structure exactly as it appeared in MicroStation.

6. If you chose to manually place the imported data, it displays in the drawing area and moves with the cursor. Click to place the imported data. You may need to zoom in to see the imported data. See Zooming Project Views on page 860.

Related topics

- Importing or Linking CAD Formats on page 58
- Moving a View-Specific Import to the Foreground or Background on page 66

Importing CAD Files Using i-drop

Revit Structure supports the Autodesk i-drop® drag-and-drop feature. When i-drop objects are pulled from an i-drop–enabled web page, Revit Structure downloads the file and imports it as if it were pulled from a local file.

When you drag-and-drop a file, the file is imported with the default settings. If you want to use different settings (for example, Manual - Origin rather than Auto - Center to Center), import the file using the Import CAD tool. (See Importing or Linking CAD Files Using the Import CAD and Link CAD Tools on page 59.)
To import CAD files using i-drop

1. From an i-drop–enabled web page, click the thumbnail image of the object.
2. Drag the file from the web page into Revit Structure.
3. Release the object directly into the active view.

**Importing Files from SketchUp**

Google™ SketchUp® is a general purpose modeling and visualization tool. Revit Structure uses building information modeling (BIM), in which building elements understand their relationship to each other. When working on a design project, you can use both products to leverage the unique strengths of each. For example:

- If you want to model an initial design pass or quickly model a single element, start with SketchUp. Later, use Revit Structure to refine the design.
- If you want to design entire building masses and then associate real building elements to them, use SketchUp for the design phase. Later use Revit Structure for the detailed planning phase.

To use a SketchUp design in Revit Structure, import a SKP file from SketchUp directly into Revit Structure. As an alternative, you can use SketchUp to export a DWG file, and then import that DWG file into Revit Structure.

To incorporate a SketchUp design into a Revit project, use the following general process:

1. Use Revit Structure to create a family outside the project or an in-place family within the project.
2. Import the SketchUp file into the family.
3. If you created the family outside the project, load the family into the project.

**NOTE** Revit Structure does not support linking of SketchUp files. As a result, if you import a SketchUp file into a Revit project and later make changes to the SketchUp file, you cannot easily update the Revit project to reflect the changes. Therefore, complete as much of the design in SketchUp as possible before importing it into Revit Structure.

**Related topic**

- Importing Massing Studies from Other Applications on page 1366

**Importing SKP Files**

Before importing a SKP file from SketchUp into Revit Structure, do the following:

- Make sure you import the geometric data needed for the Revit capability that you plan to use. See Suitability of Imported Geometry on page 57.
- Review Limitations of SketchUp Data Imported to Revit Structure.

**To import SketchUp files**

1. Create an in-place family in a Revit project, or create a family in the Family Editor.
See Revit Families on page 677.

2 Click Insert tab ➤ Import panel ➤ (Import CAD).
3 In the Import CAD Formats dialog, navigate to the folder that contains the SketchUp file.
4 For Files of Type, select the SKP file type
5 Select the file to import.
6 Specify the desired import settings.
The following settings are recommended:
   ■ Colors: Preserve
   ■ Layers: All
   ■ Import Units: Auto-Detect
   ■ Positioning: Auto - Origin to Origin
   ■ Place at: Level 1 or Ref. Level
   ■ Orient to View
7 Click Open.
You may need to do the following to see the SketchUp-based form:
   ■ Switch to a 3D view.
   ■ To improve visibility, on the View Control Bar, for Visual Style, select (Shaded with Edges).
   ■ Click Home tab ➤ Work Plane panel ➤ (Set). In the Work Plane dialog, select a plane.
   ■ Type ZF (Zoom to Fit) to adjust the drawing area to show the entire mass.
   ■ If you are creating a mass family, click Architect & Site tab ➤ Conceptual Mass panel ➤ (Show Mass

Limitations of SketchUp Data Imported to Revit Structure

Revit Structure treats the data imported from SketchUp as a large block of geometry that resists being manipulated (in the ways that you can usually manipulate geometry that is native to Revit Structure). However, you can change the layer settings from SketchUp. (For example, to assign colors or materials on a by-layer basis, click Manage tab ➤ Settings panel ➤ Object Styles, and change settings on the Imported Objects tab.) When you import a SketchUp design into a Revit mass family and then load the mass family into a Revit project, you can convert mass faces (from the SketchUp design) into walls, floors, and roofs. (See Importing Massing Studies from Other Applications on page 1366.)

When creating content in SketchUp for use in Revit Structure, consider the following restrictions:
   ■ Exploding 3D data: In Revit Structure, you will not be able to explode 3D data. If you try this, 3D faces will disappear, and you will receive a warning message.
   ■ Parameters: In Revit Structure, you cannot add parameters to control geometric flexing. However, you can add some controls that manipulate imported data, such as the location of an imported element and its material assignments.
■ **Visibility/graphics:** In Revit Structure, you cannot manipulate the geometry or isolate parts of whole elements with visibility/graphics settings.

■ **Two-sided surfaces:** If a material or color is assigned to only one side of a surface in SketchUp, Revit Structure applies the material or color to both sides of the surface by default. If there is material on both sides of the surface, Revit Structure applies the Face 1 material to both sides. If faces are flipped and painted differently in SketchUp, they may not display the correct material in Revit Structure.

■ **SketchUp properties:** The following SketchUp properties are currently not supported in Revit Structure import: Texture Image Maps, Transparency, “Smooth” Curved Surfaces, Text and Dimensions, Raster Images, and saved “Pages”.

■ **Cut planes:** Imports cannot be cut by a cut plane unless imported into a cuttable family category.

■ **SketchUp and massing:** Not all SketchUp imports are appropriate to massing. See [Suitability of Imported Geometry](#) on page 57. Also see [Importing Massing Studies from Other Applications](#) on page 1366.

■ **Scaling:** Groups or components that have been scaled in their entirety with the SketchUp Scaling tool may be incorrectly scaled when imported to Revit Structure. Exploded SketchUp models should import at the correct scale.

### Importing ACIS Objects

Revit Structure supports the import of ACIS objects contained in DWG, DXF, and SAT files. (ACIS objects describe solids or trimmed surfaces.) For example, you can create ACIS objects using the AutoCAD commands Draw Solids and Draw Region. You can also import SmartSolids™ from MicroStation® into Revit Structure. To import ACIS objects, use the procedure [Importing or Linking CAD Files Using the Import CAD and Link CAD Tools](#) on page 59.

Revit Structure supports the following types of surfaces when importing ACIS objects:

■ Plane
■ Sphere
■ Torus
■ Cylinder
■ Cone
■ Elliptical cylinder
■ Elliptical cone
■ Extruded surface
■ Revolved surface
■ NURB surfaces

You can import NURB (non-uniform rational B-splines) surfaces on ACIS objects in DWG or SAT files into Revit mass or generic model families while you are creating the family. You can then use the Roof by Face and Curtain System by Face tools to create roofs and curtain systems on these imported surfaces.

To use ACIS imports for face-based host tools, import geometry into an in-place family of category Mass or Generic Model. Face-based tools work best on ACIS solids. For example, if you create walls by face on a cube, the walls join and miter correctly. If you create a curtain system by face on a solid, you can add corner mullions onto the joins between faces of the curtain system. For more information on face-based tools, see [Creating Building Elements from Mass Instances](#) on page 1356.
TIP Make sure you import the geometric data needed for the Revit capability that you plan to use. For more information, see Suitability of Imported Geometry on page 57.

Import and Link Options for CAD Formats and Revit Models

The following options apply to linked or imported CAD format files (on the Import CAD Formats and Link CAD Formats dialogs that display when you click Insert tab ➤ Import panel ➤ Import CAD, or Insert tab ➤ Link panel ➤ Link CAD). Positioning options also apply to linked Revit models (when you click Insert tab ➤ Link panel ➤ Link Revit).

<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current View Only</td>
<td>Imports a CAD drawing into the active Revit view only. For example, you might want an AutoCAD object to appear only in a Revit floor plan view and not in a 3D view. If you set this option, any text in the imported file is visible and can be cropped by the crop region of the view. If you are using worksharing, the import will belong to a view workset. If the option is not selected, only lines and geometry are imported, and the import behaves like model geometry: it can be cropped by the crop region of the view. This option is not available in 3D views. If you are using worksharing, the import will belong to a model workset.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> If you are importing data from a CAD file for use in creating a toposurface, do not select this option.</td>
</tr>
<tr>
<td>Colors</td>
<td></td>
</tr>
<tr>
<td>Invert</td>
<td>Inverts the colors of all line and text objects from the imported file to Revit-specific colors. Dark colors become lighter, and light colors become darker. This can improve readability when the file is in Revit Structure. This option is set by default.</td>
</tr>
<tr>
<td>Preserve</td>
<td>Preserves the colors defined in the imported document.</td>
</tr>
<tr>
<td>Black and White</td>
<td>Imports the document in black and white.</td>
</tr>
<tr>
<td>Layers</td>
<td></td>
</tr>
<tr>
<td>All</td>
<td>Imports or links all layers. Layers that are not visible in the link are turned off in the current view in Revit Structure.</td>
</tr>
<tr>
<td>Visible</td>
<td>Imports or links only visible layers.</td>
</tr>
<tr>
<td>Specify</td>
<td>Allows you to select the layers and levels to import or link (on the dialog that displays). Layers not selected are deleted. If you select Visible or Specify and you are linking the file, when you later reload the linked file, still only the selected or visible layers originally linked are loaded. Any layers not selected or visible are not linked. If you later want omitted layers to be linked, you must delete the link and relink the file.</td>
</tr>
<tr>
<td></td>
<td><strong>TIP</strong> If you want to be able to see and hide layers as needed, you can link to all layers, and then click View tab ➤ Graphics panel ➤ Visibility/Graphics to control the visibility of different categories in a view. (See Visibility and Graphic Display in Project Views on page 801.) Or you can link to all layers, and then query the import and hide a selected layer in the active view. (See Querying Objects in Layers on page 75.)</td>
</tr>
<tr>
<td>Option</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Import Units</td>
<td>Explicitly sets the unit of measure for imported geometry. The values are Auto-Detect, feet, inch, meter, decimeter, centimeter, millimeter, and Custom factor. If you specify Auto-Detect for an AutoCAD file created in Imperial (English), then the file imports with feet and inches as the units. If the AutoCAD file was created in metric, then the file imports into Revit Structure with millimeters as the units. For MicroStation® files, Revit Structure reads the units from the file and uses them. Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If the DGN file has custom units, then the unit in Revit Structure defaults to feet. <strong>NOTE</strong> If you import a file into a project with opposing units (for example, a metric file into an Imperial project), the units in the host project prevail. If the imported file has a custom unit, select Custom factor for Import Units. This enables the text box adjacent to the selection list so that you can enter a scale value. For example, the file has a unit called widget where one widget equals 10 meters. When importing the file, select Custom factor for Import Units and specify a value of 10 in the adjacent text box. Each unit from the source file is now equal to 10 meters in the Revit file. The value you enter here displays in the Scale Factor type property of the import symbol. If the units are known, you can select Custom factor and enter a scale factor. This can increase or decrease the size of the imported elements in Revit Structure.</td>
</tr>
<tr>
<td>Positioning</td>
<td></td>
</tr>
<tr>
<td>Auto - Center to Center</td>
<td>Revit Structure places the center of the import at the center of the Revit model. The center of a Revit model is calculated by finding the center of a bounding box around the model. If most of the Revit Structure model is not visible, this center point may not be visible in the current view. To make the point visible in the current view, set the zoom to Zoom View to Fit. This centers the view on the Revit Structure model.</td>
</tr>
<tr>
<td>Auto - Origin to Origin</td>
<td>Revit Structure places the import’s world origin at the Revit project’s internal origin. If the import object has been drawn at a large distance from its origin, it may display at a large distance from the model. To test this, set the zoom to Zoom View to Fit.</td>
</tr>
<tr>
<td>Auto - By Shared Coordinates</td>
<td>Revit Structure places the imported geometry according to its position with respect to the shared coordinates between the 2 files. If there is no current shared coordinate system between the files, Revit Structure notifies you, and uses Auto - Center to Center positioning. See Shared Positioning on page 1265. <strong>NOTE</strong> This option is for Revit files only.</td>
</tr>
<tr>
<td>Manual - Origin</td>
<td>The imported document’s origin is centered on the cursor.</td>
</tr>
<tr>
<td>Manual - Base Point</td>
<td>The imported document’s base point is centered on the cursor. Use this option only for AutoCAD files that have a defined base point.</td>
</tr>
<tr>
<td>Manual - Center</td>
<td>Sets the cursor at the center of the imported geometry. You can drag the imported geometry to its position.</td>
</tr>
<tr>
<td>Place at</td>
<td>Select the level to place the origin/base point.</td>
</tr>
<tr>
<td>Orient to View</td>
<td>Revit Structure places the import at the same orientation as the current view. This option is available only for non-view-specific imports.</td>
</tr>
</tbody>
</table>
Setting Scaling for Imported DWG or DXF Files

1. Select an import symbol and click Modify | <File Name> tab ➤ Properties panel ➤ (Type Properties).

2. In the Type Properties dialog, modify Import Units or Scale Factor.
   If you change the import units, the scale factor automatically updates. See Import and Link Options for CAD Formats and Revit Models on page 63.

   NOTE If no values display for these parameters, you must reload the link or reimport the file.

3. Click OK.

Setting Line Weights for Imported DWG or DXF Files

When you import a DWG or DXF file, each layer in the file is assigned a line weight based on the pen number-line weight settings. Revit Structure can import pen numbers from a DWG or DXF file and map them to a Revit line weight. You can then save these mappings in a text file, and they become the set mappings for the project.

Revit Structure includes the following files with pen and line weight mappings:

- importlineweights-dwg-AIA.txt
- importlineweights-dwg-BS1192.txt
- importlineweights-dwg-ISO13657.txt
- importlineweights-dwg-CP83.txt

These files reside in the Data folder of the Revit Structure installation directory.

To set line weights

1. Click Insert tab ➤ Import panel ➤ .
   The Import Line Weights dialog displays the mappings in the importlineweights-dwg-default.txt file.

2. If this is not the file that you want to edit, click Load, navigate to the correct mappings file, and open it.

3. In the dialog, match the appropriate pen to the appropriate line weight (for example: Pen Number 1 to Line Weight Number 1, Pen Number 2 to Line Weight Number 2, and so on). Set as many pen-line weight mappings as desired.

4. Click OK, or to save the mappings in a new file, click Save As.

Mapping AutoCAD SHX Fonts to TrueType Fonts

When you import AutoCAD drawings that contain text, you can map the AutoCAD SHX fonts to TrueType fonts so they appear correctly in Revit Structure. You can map to any of your existing fonts.

NOTE For SHX fonts that are not mapped, Revit Structure will use a similar font, but the results are unpredictable.
To map TrueType fonts

1. Open the shxfontmap.txt file in a text editor. This file resides in the Data folder of the Revit Structure installation directory.
2. On a new line, enter the SHX file name.
3. Press Tab.
4. Enter the name of the font to map it to.
5. Save and close the file.

You do not need to restart Revit Structure for the font mapping to take effect. If you have already imported the file, you will need to import it again.

Setting Constraint Parameters for Imported Geometry

If you have imported geometry into all views, you can set the base level for it and specify a height offset from that level.

To set constraint parameters

1. Select the imported geometry.
2. On the Properties palette, set the Base Level and Base Offset instance parameters.

Alternatively, you can select the geometry in an elevation view and move it to adjust the base offset value.

Moving a View-Specific Import to the Foreground or Background

You can move a view-specific import symbol between the foreground and the background of a view, with respect to model elements in the view. If the import symbol is in the foreground of the view, it is in front of model elements, such as walls. It is still behind detail components and annotations.

NOTE View-specific import symbols are those files that are imported with the Current View Only option selected.

1. Select the import symbol.
2. On the Properties palette, for Draw Layer, specify Background or Foreground.

Alternatively, select Background or Foreground from the Options Bar.

You can also use the sort order for detail components to move an import symbol in front of or behind detail components. For more information on sort order tools, see Sorting the Draw Order of Detail Components on page 958.

Importing Images

You can import raster images to a Revit project to use as background images or as visual aids needed during the creation of a model. By default, images are imported behind the model and annotation symbols; however, you can change the display order. You can import images into 2D views only.

You can import images using the Image tool or by dragging and dropping them from Windows® Explorer.

To import an image

1. Click Insert tab ➤ Import panel ➤ (Image).
2. In the Import Image dialog, navigate to the folder containing the image file to import.
3 Select the file, and click Open.
The imported image displays in the drawing area and moves with the cursor. The image displays symbolically, with 2 crossing lines indicating the extents of the image.

4 Click to place the image.

Related topic

■ Adding an Image to a Sheet on page 993

Modifying Imported Images

You can modify imported images using tools (such as Rotate and Copy) on the Modify Raster Images tab. This tab displays when you select an imported image in the drawing area.

NOTE These tools also affect captured, rendered 3D images.

To modify an imported image

1 Select the image so that handles display on the image, and modify the image as follows:
   ■ To scale the image, drag the corner handles.
   ■ To move the image, drag it to the desired location.
   ■ To keep width and height settings proportional while scaling, on the Properties palette, select Lock Proportions.

2 On the Properties palette, specify values for the height and width of the image.

3 If you want to rotate the image, click Modify | Raster Images tab ➤ Modify panel ➤ (Rotate). See Rotating Elements on page 1481.

4 If you want to change the draw order, select the image and use the tools on the Arrange panel of the Modify | Raster Images tab.
The draw order of raster images can be controlled in the same manner as detail elements. See Sorting the Draw Order of Detail Components on page 958.

Related topics

■ Importing Images on page 66
■ Deleting Raster Images on page 67

Deleting Raster Images

The Manage Images tool lists all raster images in the project, including any rendered images that you have captured. The tool offers the only way for you to delete an image from the project. You cannot remove an image from the project by deleting it from a view or a sheet.

To delete a raster image

1 Click Insert tab ➤ Import panel ➤ (Manage Images).
The Manage Images dialog lists all raster images in the project.
2 Select the image name, and click Delete.
3 Click OK when prompted to confirm the deletion.

**Importing Building Components**

Manufactured building components that are formatted as Autodesk Exchange (ADSK) files provide design and connection data that you can use to accurately place the component in a Revit project. These building components can be designed in mechanical applications, such as Autodesk® Inventor® and used in Revit Architecture, Revit MEP, and Revit Structure.

To open a building component ADSK file, do one of the following:

- Click ➤ Open ➤ (Building Component).
- Click Home tab ➤ Model panel ➤ Component drop-down ➤ Place a Component. Then click Modify | Place Component tab ➤ Mode panel ➤ Load Family, select the ADSK file, and place it in the project.

**Building Component ADSK Files**

A building component ADSK file provides the following information to aid in the design process:

- Physical appearance of the component in views, such as 3D, which lets you determine clearance for accurate placement
- Connectors and their placement

**NOTE** Although conduit and cable tray connectors are displayed in the Autodesk Inventor Translation report, they are not imported into Revit Structure.

- Data about the component, such as its identity data

Opening or loading an ADSK file automatically creates a family from the category that is based on the OmniClass assignment made on export.

You can also save the ADSK file as an RFA file ( ➤ Save As ➤ Family), which lets you create a family that can be used in multiple projects. See Revit Families on page 677 for more information about using families in Revit Structure.

**Working with Building Components**

Using a building component ADSK file, you can:

- View the component’s bounding box at a coarse detail level. Connectors will still display in their correct locations in the coarse scale view.
- View the component’s detailed appearance at fine and medium detail levels.
- Change the component’s graphic display by changing the detail level in the project. You can also modify the component’s visibility settings in the Family Editor to coarse, medium, or fine.
- View the component in a 3D, plan, elevation, or section view.
- Place connectors on the component using the Family Editor. See Connectors on page 696.
Create new family types from the original component by adding new parameters or changing existing ones using the Family Editor.

View or change the component's identity data.

Use the component's reference planes or some of its geometry for dimensioning.

Tag and schedule the component's parameters.

Render the component.

Restrictions to using a building component ADSK file include the following:

- The geometry of the component cannot be changed in Revit Structure. Changes to geometry can only be made in the application in which the building component was originally designed.

- Although the materials assigned in the mechanical application are not imported into Revit Structure, you can assign a material in Revit Structure that applies to the whole component.

- Currently, the workflow is only one-way from Inventor to Revit Structure. Inventor cannot open ADSK files.

**Tips for Working with Building Components**

Consider the following when working with building components:

- To optimize model performance in Revit Structure, whenever possible, work with the building component as a bounding box at coarse scale.

- Because building components can have large quantities of detailed geometry, they might take a few minutes to open. If opening the component takes too long, or if zooming and panning performance is slow, ask its creator to further simplify the model prior to exporting.

- If the component opens in Revit Structure with a different orientation than expected, either rotate the component in the Family Editor or ask its creator to create a custom Universal Coordinate System (UCS) and re-export the ADSK file using the new UCS.

- Use the Autodesk Inventor Translation report to review the export results. The report lists the contents of the ADSK file. Verify that the model elements were exported as you expected. Double-click the ADSK file to open the report in your Web browser.

**Building Component Workflow**

The following steps describe a typical workflow for using a building component in a Revit project. For example, suppose a manufacturer published the contents of a rooftop HVAC unit to its website as an ADSK file to be used by engineers and architects. You want to incorporate this building component in your model. Using the component's geometry and data, you can properly place the component in the project and also create connectors on it, so the component can be used in Revit MEP.

Your workflow looks like the following:

1. Download the building component ADSK file from the manufacturer's website.

2. To open the ADSK file in Revit Structure, click ➤ Open ➤ (Building Component).

**NOTE** You cannot open ADSK files that are associated with a later version of Revit.
3 Load the ADSK file into the project from the Family Editor.

**NOTE** You can load the ADSK file directly into the project. Click Home tab ➤ Model panel ➤ Component drop-down ➤ Place a Component. Then click Modify | Place Component tab ➤ Mode panel ➤ Load Family, select the ADSK file, and place it in the project.

4 Place the component in the project.

5 Display the component as a bounding box at a coarse level of detail.

6 Display the full geometry at medium and fine levels of detail.

7 View the component in any view.

8 Run an interference check to ensure proper clearance.

9 Tag and schedule the component using its parameters.

10 Dimension the component to its reference planes and to some of its geometry.

11 Create any extra connectors on the component in the Family Editor. When they are connected to building services in Revit MEP, the connectors can be used in flow analysis.

### Opening Industry Foundation Class (IFC) Files

Revit Structure opens Industry Foundation Classes (IFC) based on the latest International Alliance for Interoperability (IAI) IFC 2x3 data exchange standard. (If you open a file that uses an earlier standard [IFC 2x or 2x2], Revit Structure supports the format and opens it properly.) For information about the IFC file format, see Exporting to Industry Foundation Classes (IFC) on page 1132.

When you open an IFC file, Revit Structure creates a new file based on the default template. For information about selecting the default template, see Selecting a Template for IFC Files on page 70.

You can load your own IFC class mapping files and override the categories and subcategories for IFC objects.

**TIP** Make sure you import the geometric data needed for the Revit capability that you plan to use. For more information, see Suitability of Imported Geometry on page 57.

**To open an IFC file**

1 Click ➤ Open ➤ (IFC).

2 In the Open IFC File dialog, navigate to the IFC file to import.

3 Select the IFC file, and click Open.

Revit Structure creates a new file based on the default template.

### Selecting a Template for IFC Files

1 Click ➤ Open ➤ (IFC Options).

2 In the Import IFC Options dialog, click Browse.

3 In the Browse for Template File dialog, navigate to the desired IFC template file, select it, and click Open.

4 In the Import IFC Options dialog, click OK.
Loading an IFC Class Mapping File

1 Click ➤ Open ➤ (IFC Options).
2 In the Import IFC Options dialog, click Load.
3 In the Load IFC Class Mapping File dialog, navigate to an IFC class mapping file, select it, and click Open.
4 In the Import IFC Options dialog, click OK.

Overriding Categories and Subcategories for IFC Objects

1 Click ➤ Open ➤ (IFC Options).
2 In the Import IFC Options dialog, double-click in a category or subcategory, and enter a new value to override the current value.
   As an alternative, you can click Standard to reset all values to the standard (default) settings.
3 Click OK, or to save the mappings in a new file, click Save As.

Linking AutoCAD Files to a Revit Project

You can link AutoCAD files to a Revit project. For example, you may want to use linked files as follows:

- Some team members use AutoCAD to create details or elevations, but the rest of the project is created using Revit Structure. You want to link the AutoCAD drawings to the Revit project and place them on sheets. These drawings can then be included in the set of construction documents that Revit Structure generates.

- Team members from other disciplines (such as architects or electrical engineers) use AutoCAD to plan their part of the project. You want to link their AutoCAD drawings to a Revit project to use them as underlays for your project views.

For example, the following floor plan shows a linked file that will be used as an underlay to trace and create structural walls in Revit Structure.
How Linking to AutoCAD Files Works

When you link an AutoCAD file to a project, Revit Structure maintains a link to that file. Whenever you open the Revit project, Revit Structure retrieves the current, saved version of the linked file and displays it in the project. Any changes to the linked file are displayed in the Revit project. If the linked file changes while the Revit project is open, reload the file to retrieve the latest changes. (See Managing Links on page 1203.)

This ability to retrieve the latest changes to an AutoCAD file is the difference between linking and importing. When you import an AutoCAD file, Revit Structure uses the version of the file that you imported. It does not retrieve or display changes to the imported file.

When you link (or import) an AutoCAD file to a Revit project, you can do the following:

- **Query objects in the file** on page 75
- **Hide or delete selected layers in the file** on page 76.
- **Change the graphic display of layers in the file** on page 78.

When you link a file to a Revit project, you can control whether the linked file is visible only in the current view, or in all views. As a 2D drawing, the linked file is displayed only in relevant 2D Revit drawings, such as floor plans. In a 3D view, the linked file is displayed as flat, 2D shapes.

Linking to an AutoCAD File

1. Open the Revit project.
2. If you want the linked file to display only in a particular view, open that view.
3 Click Insert tab ➤ Link panel ➤ ![CAD Link icon](Link CAD).

4 Specify the file to link, as follows:
   - For Look in, navigate to the location of the file.
   - For File name, specify the name of the file.
   - For Files of type, specify DWG.

5 Specify the following options for the linked file:
   a If you want the linked file to display in the current view only, select Current view only. If you do not select this option, the linked file is displayed in all relevant 2D views, such as floor plans.
   b For Layers, select one of the following values:
      - All: Displays all linked file layers in the Revit project, including hidden layers.
      - Visible: Displays visible layers of the linked file in the Revit project. Layers that are currently hidden in AutoCAD do not display in Revit Structure.
      - Specify: Allows you to select the layers to display in the Revit project from a list. After you click Open, Revit Structure displays the list of layers from which to choose.

6 Specify the desired import options.
   For details about these options, see Import and Link Options for CAD Formats and Revit Models on page 63.

7 Click Open.

8 If, for Layers, you chose Specify, the Select Layers/Levels to Import/Link dialog lists the layers in the file. Select the desired layers, and click OK. Unselected layers are not available in the Revit project. (However, the layers still exist in the AutoCAD file.)

Revit Structure retrieves the current version of the linked file and displays it in the current Revit view.

Related topics
- Querying Objects in Layers on page 75
- Hiding and Deleting Layers on page 76
- Changing the Graphic Display of Layers on page 78
- Managing Links on page 1203

**Location of the Linked File**

Whenever you open a Revit project that is linked to a file, Revit Structure retrieves the current saved version of the linked file. The path to the linked file displays in the Saved Path column of the Manage Links dialog. See Unresolved References on page 1205.

If Revit Structure cannot locate the linked file, it displays the path to the version of the linked file that it retrieved most recently. Revit Structure is not able to update the link. To reload the linked file from a different location, use the Reload From function of the Manage Links dialog. See Managing Links on page 1203.
Use the Path Type column to indicate whether the path is absolute or relative. In general, use a relative path instead of an absolute path.

- If you use a relative path and later move the project and the linked file together to a new directory, the link is maintained. The new working directory becomes the relative path for the linked file.
- If you use an absolute path and later move the project and the linked file to a new directory, the link is broken.

Use an absolute path when you link to a workshared file, such as a central file that other users need to access. This file is likely not to move from its location on the disk.

**Linking DWF Markup Files**

1. Click Insert tab ➤ Link panel ➤ (DWF Markup).
2. In the Import/Link DWF File dialog, navigate to the DWF markup file, select it, and click Open.
   The Link Markup Page to Revit Sheets dialog opens. Under the DWF View column, the dialog displays the sheet view names that are marked up in the DWF file. The Revit View column displays the corresponding Revit sheet view. If the sheet name from the DWF file is the same as the sheet name from the Revit file, then the Revit sheet name is automatically filled in the Revit View column.
   If the Revit sheet view name changed after it was exported to DWF, the Revit View column displays <Not linked> next to the DWF sheet view.
3. If the Revit View value is <Not linked>, select a Revit sheet view by clicking the box below the Revit View column, and selecting a name from the list.
   You might also do this if you have several other sheet views in the Revit file, and you want to apply the markups to one of the other sheet views. This would make sense only if the other sheet title blocks were the same size as the original.
4. Click OK.

The DWF markups are placed on the sheet view as an import symbol. The markups are pinned, which means that you cannot modify their position or copy, rotate, mirror, delete, or group them unless they were created in Autodesk Design Review. See **Modifying DWF Markups Created in Design Review** on page 74.

**Modifying DWF Markups Created in Design Review**

If markups were created in Autodesk Design Review using its markup tools, you can modify the Status and Notes properties in Revit Structure. This feature allows you to add information to the markup or maintain information about its status.

To modify markups created in Design Review

1. Select a markup object that was created in Design Review.
A markup object might look as follows.

2 On the Properties palette, modify the Status and Notes properties as desired.

The changes are saved to the linked DWF file. The changes can be viewed in the DWF file by selecting the corresponding markup object.

Exploding Imported Geometry

When you import a drawing into Revit Structure, you are importing all the elements, such as blocks and external references (xrefs) from the drawing. (See Implications of Importing vs. Linking for Xrefs on page 58.) They are all contained inside a Revit element called an import symbol.

You can explode (disassemble) the import symbol into its next highest level elements: nested import symbols. This is a partial explode. A partial explode of an import symbol yields more import symbols, which, in turn, can be exploded into either elements or other import symbols. This is analogous to exploding in AutoCAD with nested xrefs and blocks. For example, you explode an xref into other xrefs and blocks. Those xrefs and blocks can, in turn, be exploded into more blocks and xrefs.

You can also explode the import symbol immediately into Revit text, curves, lines, and filled regions. This is a full explode.

NOTE You cannot explode linked files or an import symbol that would yield more than 10,000 elements.

To explode imported geometry

1 Select the import symbol.
2 Click Modify | <File Name> tab ➤ Import Instance panel ➤ Explode drop-down ➤ Partial Explode or Full Explode.

Resulting partial explode import symbols can be exploded again by selecting them and clicking Partial Explode. You can continue to do this until all import symbols are converted to Revit elements.

Managing Layers in Linked and Imported Files

When you import or link a CAD file to a Revit project, you can query, hide, delete, or change the graphic display of layers in the file.

Querying Objects in Layers

When you import or link a file to a Revit project, you can query the file for information about its objects. This allows you to determine the identity of an object and the layer on which it resides. You can also hide the object’s layer or delete it.
To query objects in layers

1 Open a project view in Revit Structure.
2 Highlight the import symbol for the file, and click to select it.
   When you highlight the import symbol, the status bar displays the following:
   <imported file name> : Import Symbol : location <Shared> or <Not Shared>.

3 Click Modify | <File Name> tab ➤ Import Instance panel ➤ (Query).
4 Select the object to query, as follows:
   ■ Move the cursor over the import symbol in the view.
      Revit Structure highlights lower-level objects (such as lines) first. Press Tab to switch to
      highlighting of higher-level objects, such as blocks.
   ■ Watch the status bar. When it describes the target object, click to select it.
   The Import Instance Query dialog opens and displays the following information:
      ■ Type: object type
      ■ Block Name: the block that contains the object, if applicable
      ■ Layer: the name of the layer containing the object
      ■ Style By: indicates whether the object style comes from the layer or by color

5 To hide the object’s layer in the current view, click Hide in view.
   The selected layer may still be visible in other views.

6 To delete the object’s layer from the Revit project, click Delete.
   The selected layer is no longer visible in any project views.

7 To close the Import Instance Query dialog, click OK.
   The query editor remains active so that you can select other entities.

8 Press Esc to exit the query editor.

Hiding and Deleting Layers

When you import or link a file to a Revit project, you may not want all of the file’s layers to be visible in
Revit Structure. To control the visibility of layers, you can do either of the following:

■ **Hide layers**: When you hide layers, they are still available to the Revit project, but they do not display
   in views. You can make them visible again as needed.

■ **Delete layers**: When you delete layers, they are not available to the Revit project. (However, they still
   exist in the original CAD file.) If you want to restore the layers, you must delete the file and either import
   or link it to the project again.

Related topic

■ Changing the Graphic Display of Layers on page 78
Hiding Layers

When you import or link a file, you can specify how to hide its layers in each Revit view. For example, you
can display all layers in one view, but hide some layers in another view. You can redisplay the layers later,
if needed.

If you are not sure on which layer an object resides, see Querying Objects in Layers on page 75.

To hide layers

1. Open a project view in Revit Structure.
2. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
3. Click the Imported Categories tab.
4. In the Visibility column, click to expand the DWG file name of the linked or imported file.
   Revit Structure lists the layers in the file.
5. Clear the check boxes for any layers that you want to hide in the current view.
6. Click OK.

The layers are hidden in the current view only. To redisplay hidden layers, repeat this process and select the
desired layers.

Deleting Layers

When you delete layers in either an imported file or a linked file, the layers are no longer available to the
Revit project. (However, they still exist in the original CAD file.) If you want to restore the layers, you must
delete the file from the Revit project and link to or import it again.

To delete layers in a linked or imported file, use one of the following methods:

- When you link or import the file to the Revit project, in the Import or Link dialog, for Layers, select
  Visible to display only the layers that are currently visible in AutoCAD, or select to specify the layers to
display in Revit Structure. Any omitted layers are effectively deleted. They are not available to the Revit
project.

- If you want to delete an object in a CAD file, and you are not sure on which layer it resides, see Querying
  Objects in Layers on page 75.

- Delete specified layers, as described in the following procedure.

To delete known layers

1. Open a project view in Revit Structure.
2. Highlight the import symbol for the file, and click to select it.
   The status bar displays the following:
   <imported file name>: Import Symbol: location <Shared> or <Not Shared>.
3. Click Modify | <File Name> tab ➤ Import Instance panel ➤ (Delete Layers).
4. In the Select Layers/Levels to Delete dialog, select the layers to delete, and click OK.

The deleted layers do not display in any views in the Revit project.
Changing the Graphic Display of Layers

When you import or link a file to a Revit project, you can control the graphic display of each layer in the file. For example, you can change the line color, weight, and style of the objects. For example, when using a file as an underlay, you can display the entire file in halftone to distinguish it from the Revit model.

Related topic
- Hiding and Deleting Layers on page 76

Preserving or Discarding Graphic Overrides for Linked Files

When you change the graphic display of layers in a linked file, you can specify whether Revit Structure preserves or discards the graphic overrides.

NOTE This feature is available for linked CAD files only. It is not available for imported CAD files.

When you preserve graphic overrides, Revit Structure retains any changes made to the graphic display of its layers when it reloads the linked file. Otherwise, Revit Structure discards graphic overrides when reloading the linked file. This option applies to all CAD files that are linked to the project.

To preserve or discard graphic overrides for linked files

1. Open the Revit project.
2. Click Manage tab ➤ Manage Project panel ➤ (Manage Links).
3. In the Manage Links dialog, do either of the following:
   - To retain the overrides, select Preserve graphic overrides.
   - To discard the overrides, clear Preserve graphic overrides.
4. Click OK.

Making Global Changes to the Graphic Display of Layers

When you import or link a file to a Revit project, you can control the graphic display of file layers in all views.

To make global changes to the graphic display of layers

1. Open the Revit project.
2. Click Manage tab ➤ Settings panel ➤ (Object Styles).
3. In the Object Styles dialog, click the Imported Objects tab.
4. Click to expand the DWG file name of the file.
   - Revit Structure lists the layers in the file.
5. For each layer, change the values for Line Weight, Line Color, or Line Pattern, as desired.
   - See Object Styles on page 1601.
6. Click OK.
Making View-Specific Changes to the Graphic Display of Layers

When you import or link a file to a Revit project, you can control the graphic display of its layers in individual views.

To make view-specific changes to the graphic display of layers

1. Open a project view that shows the file.

2. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).

3. Click the Imported Categories tab.

4. If you want the entire file to appear in halftone, select Halftone.
   See Halftone/Underlay on page 1605.

5. In the Visibility column, click to expand the DWG file name. Revit Structure lists the layers in the file.

6. To change the graphic display of a visible layer in the file:
   a. Click the Lines column for the layer, and click Override.
   b. In the Line Graphics dialog, specify the line weight, color, and pattern, and click OK.

7. In the Visibility/Graphic Overrides dialog, click OK.

Troubleshooting Problems with Linked Files

The following topics describe issues that you may encounter when linking files to Revit projects.

Changes in the DWG File Are Not Reflected in the Revit Project

Symptom: After linking a DWG file to a Revit project, you made changes to the DWG file in AutoCAD. However, the Revit project does not display these changes.

Issues and Solutions: This issue can have several causes:

- The linked file was changed after it was loaded into the Revit project, and the Revit project is still open. To correct this situation, reload the linked file. In Revit Structure, click Manage tab ➤ Manage Projects panel ➤ Manage Links. In the Manage Links dialog, on the CAD Formats tab, select the linked file in the list, and click Reload. Click OK. Revit Structure retrieves the most recently saved version of the linked file and displays it in the Revit project.
  See How Linking to AutoCAD Files Works on page 72.
The file was imported, not linked.
When a file is imported, Revit Structure does not retrieve or display changes to the imported file. To confirm that the file was linked and not imported, click Manage tab ➤ Manage Projects panel ➤ Manage Links. In the Manage Links dialog, the CAD Formats tab lists all linked files. It does not list files that are imported. Therefore, if the file is not listed here, then it was imported.
To correct this situation, go to the view in which the imported file displays, select it, and press Delete. Then link to the file. See Linking to an AutoCAD File on page 72.

Revit Structure cannot locate the linked file in its saved path.
If the linked file was moved, Revit Structure cannot locate it, and so it cannot retrieve the latest saved version of the file. To reload the file from a different location, use the Reload From function of the Manage Links dialog. (See Managing Links on page 1203.)

Changes to the Layer Color and Line Style Do Not Display in the Revit Project

**Symptom:** You made changes to the graphic display of layers in the linked file. After the linked file was reloaded into the Revit project, these changes disappeared.

**Issue:** To save changes to the graphic display of layers in linked files, select the Preserve Graphic Overrides option on the Manage Links dialog. If this option is not selected, Revit Structure discards graphic overrides when the linked file is reloaded.

**Solution:** See Preserving or Discarding Graphic Overrides for Linked Files on page 78.

Layers in the DWG File Do Not Display in the Revit Project

**Symptom:** Some layers in the linked file do not display in the Revit project.

**Issue:** The layers may be hidden or deleted.

**Solution:** To determine whether the layers are hidden or deleted, click View tab ➤ Graphics panel ➤ Visibility/Graphics. On the Imported Categories tab, click to expand the DWG file. Revit Structure lists the layers in the file.

Layers that are not listed here have been deleted; they are not available to the Revit project. If you want to restore the layers, you must first delete the linked file and then link it to the project again. When linking, be sure that for Layers, you select All or Select. See Linking to an AutoCAD File on page 72.

If the Visibility option for a layer is cleared, the layer is hidden in the current view. To display the layer, select the Visibility option, and click OK. Revit Structure displays the layer in the current view.

File Operations (Open, Save, Synchronize) Are Blocked or Slow

**Symptom:** In some cases, Revit cannot open, save, or synchronize with files.

**Issue:** Some antivirus software solutions lock files, preventing other applications from accessing them.

**Solution:** You or your network administrator can define the following file extensions as exceptions in your antivirus filter.

- Revit Projects (RVT)
- Revit Families (RFA)
- Revit Templates (RTE)
- Autodesk Design Package (ADSK)
- Industry Foundation Classes (IFC)
- AutoCAD drawings (DWG)
- CAD Data Transfer (DXF)
- MicroStation drawings (DGN)
- ACIS models (SAT)
- SketchUp drawings (SKP)
- Images (BMP, JPG, and PNG)
- Data (RWS and DAT)

**NOTE** It may be necessary to contact your network administrator to add these exceptions.
Opening Revit Files

To open a Revit file, use any of the following methods:

- On the Recent Files on page 40 window, under Projects or Families, click the desired option.
- Press CTRL+O.
- Click ➤ (Open).
- Click ➤ (Open), and select a Revit file type.
- Click and select a file from the Recent Documents list.
- Click (Open) on the Quick Access toolbar.

**NOTE** If you are editing a non-workshared file, other users will have read-only access to the file.

Opening a Revit Project File

1. Click ➤ Open ➤ (Project).
2. In the Open dialog, navigate to the folder where the project file resides. To see only files of a certain type, select that type from the Files of type drop-down list.
3. Select the desired options:
   - **Audit**: Scans, detects, and fixes corrupt elements in the project. This option can greatly increase the time required to open files. Use this option only for periodic maintenance of large workshared files or when you are preparing to upgrade.
   - **Detach from Central**: Opens a workshared local model separate from the central model. See Opening Workshared Files Independent of the Central Model on page 1229.
   - **Create new local**: Opens a local copy of the central model. See Creating a Local Copy of the Central Model on page 1218.
4. Select the project file, and click Open.
Opening Families and Training Files

1 Click ➤ Open ➤ (Family).
2 On the left side of the Open dialog, select a family library or folder.
3 Navigate to the appropriate directory, select the file, and click Open.

To make other directories available from the Open dialog, see Setting Options on page 1623.

NOTE If you are editing a non-workshared file, other users will have read-only access to the file.

Opening Files from the Conceptual Design Environment

The conceptual design environment contains family files and templates that you can download and use in a massing study. See Template Files for the Conceptual Design Environment on page 140.

To open files from the conceptual design environment

1 Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Recent Files.
   The New Concept Mass Model - Select Template File window opens.
3 In the browser window, navigate to the desired file, and click Open.

See Conceptual Design Environment on page 135.

Opening Files from the Web Library

To download family files or templates from the web library for use in a project, do the following:

1 Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Recent Files.
2 Under Families, click Web Library.
   The web library opens in a browser window.
3 In the browser window, navigate to the desired collection, and click the family or template to download.
4 In the File Download dialog, click Open to open the item in Revit Structure, or click Save to save it in a specified folder, from which it can be loaded into a project.
5 If you opened a family and want to immediately use it in a project, do the following:
   a Click Home tab ➤ Family Editor panel ➤ (Load into Project).
   b In the Load into Projects dialog, select the open projects to receive the family, and click OK.

You can see the new family in the Project Browser under Families.
Opening Revit Files from Windows Explorer

The following alternative methods open Revit files from Windows Explorer.

- Double-click a project or family file.
- Drag a project file from Windows Explorer into Revit Structure.
- Drag a family file from Windows Explorer into the Project Browser or drawing area of Revit Structure to load it into the project.
- Drag a family file from Windows Explorer into anywhere other than the Project Browser or the drawing area (such as the ribbon, Quick Access toolbar, or the title bar) to open the family in the Family Editor.
- Drag multiple files from Windows Explorer into an active session of Revit Structure. A dialog opens, asking whether you want to open dropped files in separate windows or load dropped families into the current project.

**NOTE** If you are editing a non-workshared file and another user attempts to open the same file, the user will be given access to the file in a read-only state.
Saving Revit Files

The Save tool saves the active file to its current name and folder.

To save a file, do any of the following:

- Click ➤ (Save).
- Press Ctrl+S.
- On the Quick Access toolbar, click ➤ (Save).

If you want to save the current file to a different file name or location, click ➤ (Save As).

If you are working in a project that has worksharing enabled and you want to save your changes to the central model, click Collaborate tab ➤ Synchronize panel ➤ Synchronize with Central drop-down ➤ (Synchronize Now). See Synchronizing with the Central Model on page 1226.

Saving a File with a Different Name or Location

1. Click ➤ (Save As).
2. Select a Project, Family, Template, or Library file type to save.
3. In the Save As dialog, navigate to the desired folder.
4. If desired, change the file name.
5. To specify save options, click Options, set the options as desired, and click OK. See Save Options on page 88.
6. Click Save.
Save Options

When using Save As from the application menu, click Options in the Save As dialog, and specify the following in the File Save Options dialog:

- **Maximum backups.** Specifies the maximum number of backup files. By default, non-workshared projects have 3 backups, and workshared projects have up to 20 backups. See **Backup and Journal Files** on page 89.

- **Make this a Central File after save:** Sets the current workset-enabled file to be the central model. See **Creating a Central Model from an Existing Workshared File** on page 1235.

- **Compact File.** Reduces file sizes when saving workset-enabled files. During a normal save, Revit Structure only writes new and changed elements to the existing files. This can cause files to become large, but it increases the speed of the save operation. The compacting process rewrites the entire file and removes obsolete parts to save space. Because it takes more time than a normal save, use the compact option when the workflow can be interrupted. See **Using Workshared Files** on page 1217.

- **Open workset default.** Sets the workset default for the central model when opened locally. From this list, you save a worksharing file to always default to one of the following options: All, Editable, Last Viewed, or Specify. See **Creating a Central Model from an Existing Workshared File** on page 1235. The only way a user can change this option is to resave a new central model by selecting "Make this a Central File after save" on the File Save Options dialog. The local model can use the Reload Latest tool to update the changed option.

  To change this setting in an existing central model, resave the file using Save As and adjust the Save Options.

  When opened locally, you can override this default setting each time the project is opened. The override only affects that work session, and will revert to defaults the next time the file is opened.

- **Preview.** Specifies the preview image that displays when you open or save a project. The default value for this option is Active View/Sheet. Revit Structure can create a preview image only from open views. If you select Regenerate if View/Sheet is not up-to-date, Revit Structure updates the preview image whenever you open or save the project. This option can consume considerable resources on a complex model. Use it only if you want the preview image to update frequently.

Setting Save Reminders

You can specify how often Revit Structure reminds you to save an open project, or you can turn off the reminder.

**To set save reminders**

1. Click ➤ Options.
2. In the Options dialog, click the General tab.
3. To change how often Revit Structure reminds you to save an open project, select a time interval for Save reminder Interval.
4. To turn off the save reminder, for Save reminder Interval, select No reminders.
5. Click OK.

Related topics

- **General Options** on page 1623
- **Revit Options** on page 1623
Backup and Journal Files

All backup operations (such as copying, purging, and so on) occur when you save changes to a project. If necessary, you can use backup files to roll back the latest changes to a project, restoring the project to a previously saved state.

NOTE This topic describes backup files for non-workshared projects. For information about backup files for workshared projects, see Workshared Project Rollback on page 1233.

When you save a non-workshared project, Revit Structure makes a backup copy of the previous version of the project (that is, the project file before the current save). This backup copy has the name <project_name>.<nnnn>.rvt, where <nnnn> is a 4-digit number indicating how many times the file has been saved. The backup file resides in the same folder as the project file.

You can specify the maximum number of backup files that Revit Structure saves. (See Specifying the Number of Backup Files on page 89.) If the number of backup files exceeds the maximum, then Revit Structure purges the oldest files. For example, if the maximum is 3 backup files, and the project folder contains 5 backup files, then Revit Structure deletes the oldest 2 backup files.

Specifying the Number of Backup Files

By default, Revit Structure saves up to 3 backup files for each project. You can change the number of backup files that Revit Structure saves for a project.

To specify the number of backup files

1 Click ➤ (Save As).
2 In the Save As dialog, click Options.
3 In the File Save Options dialog, for Maximum backups, specify the number of backup files to save.

Backup Files for Network Saves

Suppose you work on a project whose file is stored in a network location, and the project is not workshared. When you save changes to the project, Revit Structure does the following:

- Saves the current changes to the project file in the network location.
- Makes a backup copy of the saved file, and places it in the Journal folder on the local computer. (See Journal Files on page 90.)

The local backup file provides protection in case the network save fails. Revit Structure saves up to 3 local backup files. It purges older backup files.

The local backup file uses the same name as the project file, with a GMT (Greenwich Mean Time) date and time stamp appended to it. For example, when you save project.rvt, Revit Structure saves a local copy to the Journal folder, using the file name format project_YYYYMMDD-hhmss-mmm.rvt.
Journal Files

Journal files capture the actions taken by the software during a session of Revit Structure, from the time the software starts to the time it stops. These text files can be used to troubleshoot technical problems with the software.

Revit Structure creates a new journal file each time you use the software. The journal file with the highest number is the most recent file. By default, journal files reside in the following location:

C:\Program Files\<Revit product name and version>\Journals

If you encounter problems during a Revit session, your support provider may ask you to send the journal file and any backup files to help with the troubleshooting process. If you do not encounter problems during a Revit session, the journal file is of little use and can be deleted. To automate the deletion of old journal files, see General Options on page 1623.
Preliminary Design

Start designing the model by defining levels, grids, and the project location, creating a site plan, and performing a massing study.
Levels and Grids

To establish context and guidelines for the project, create levels and grids.

Levels

Use the Level tool to define a vertical height or story within a building. You create a level for each known story or other needed reference of the building (for example, first floor, top of wall, or bottom of foundation). To add levels, you must be in a section or elevation view. When you add levels, you can create an associated plan view.
Levels are finite horizontal planes that act as a reference for level-hosted elements, such as roofs, floors, and ceilings. You can resize their extents so that they do not display in certain views. For more information, see Datum Extents and Visibility on page 1527.

When you start a new project using the default template in Revit Structure, 2 levels display: level 1 and level 2.

You can hide level annotations after you add them. For more information, see Hiding Elements in a View on page 811.

**Adding Levels**

1. Open the section or elevation view to add levels to.

2. Click Home tab ➤ Datum panel ➤ (Level).

3. Place the cursor in the drawing area and click.

   **NOTE** As you place the cursor to create a level, if the cursor aligns to an existing level line, a temporary vertical dimension displays between the cursor and that level line.

4. Draw level lines by moving the cursor horizontally.

   On the Options Bar, Make Plan View is selected by default. As a result, each level you create is a story level and has an associated floor plan view and a reflected ceiling plan view. If you click Plan View Types on the Options Bar, you can choose to create only the view types that you specify in the Plan View Types dialog. If you clear Make Plan View, the level is considered to be a non-story level or a reference level; no associated plan view is created. Walls and other level-based elements can use reference levels as their top or base constraint.

   As you draw level lines, the heads and tails of the lines can align to one another. When you select a level line that is aligned with others, a lock appears to show the alignment. If you move the level line horizontally, all aligned level lines move with it.

5. Click when the level line is the correct length.

   You can change the name of the level by clicking the number to select it. You can also change the height of the level by clicking the dimension.

   Revit Structure assigns the label (for example, Level 1) and the level symbol to the new level. Use the Project Browser to rename the level, if desired. See Project Browser on page 28. If
you rename the level, the associated name for the floor plan and the reflected ceiling plan update as well.

Related topics
■ Levels on page 93
■ Modifying Levels on page 95
■ Level Properties on page 97

Modifying Levels
You can modify the appearance of levels in many ways.

Changing the Level Type
To change the level type on placement
1 Click Home tab ➤ Datum panel ➤ Level.
2 In the Type Selector on page 35, select a different level type.

To change the level type in a section or elevation view
1 Select the level line in the drawing area.
2 In the Type Selector on page 35, select a different level type.

Editing Level Lines in an Elevation View
You can change level lines in the following ways:
■ Resize level lines. Select the level line, click on the blue sizing handles, and drag the cursor left or right.
■ Raise or lower levels. Select the level line, and click the dimension value associated with it. Enter a new value for the dimension.
■ Relabel the level. Select the level and click the label box. Enter a new label for the level.

Moving Levels
You can move level lines in the following ways:
■ Select a level line. A temporary dimension displays between that level line and any level lines immediately above and below.
To move the selected level up or down, click the temporary dimension, type a new value, and press **ENTER**.

- Drag the selected level line up or down.
- To move multiple level lines, select the desired number of level lines and move them up or down.

**Offsetting a Level Line from Its Bubble**

There may be times when you sketch a level line and want to offset its bubble from the rest of the level line.

1. Sketch a level line, or select an existing level line.
   The end of the line near the bubble has drag controls.
   
   ![Selected level with drag controls](image)

2. Select and move the end drag control near the bubble to resize the level line.

3. Click the Add Elbow drag control ( ), then drag the control to the desired location to move the bubble away from the level line.
   
   ![Bubble dragged from level line](image)

When you move the bubble end out of line, the effect appears only in that view, no other views are affected. The segments created from dragging the bubble have a solid line style. You cannot change this style.

As you drag a control, the cursor snaps at points similar to the neighboring level lines. The cursor also snaps as the segments form straight lines.
Level Properties

Most parameter names, values, and descriptions for levels can be modified.

Modifying Level Properties

1 In a project view, select a level line.
2 On the Properties palette, edit instance properties.
3 To edit type properties, on the Properties palette, click (Edit Type).
   Changes made to type properties affect all level lines of that type in the project. You can click Duplicate to create a new level line type.
4 Click OK.

Level Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Elevation Base</td>
<td>If the elevation base value is set to Project, the elevation reported on a level is with respect to the project origin. If the base value is set to Shared, then the elevation reported is with respect to the shared origin. To change the shared origin, you can relocate the project. See Relocating and Mirroring a Project on page 1269.</td>
</tr>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Line Weight</td>
<td>Sets the line weight for the level type. You can change the definition of the line weight number using the Line Weights tool. See Line Weights on page 1603.</td>
</tr>
<tr>
<td>Color</td>
<td>Sets the color of the level line. You can choose from a list of colors defined in Revit Structure, or define your own color.</td>
</tr>
<tr>
<td>Line Pattern</td>
<td>Sets the line pattern of level lines. The line pattern can be solid or a combination of dashes and dots. You can choose from a list of values defined in Revit Structure, or define your own line pattern.</td>
</tr>
<tr>
<td>Symbol</td>
<td>Determines whether the head of a level line displays a level number in a bubble (Level Head–Circle), a level number but no bubble (Level Head–No Bubble), or no level number (&lt;none&gt;).</td>
</tr>
<tr>
<td>Symbol at End 1 Default</td>
<td>Places a bubble by default at the left end of the level line. When you select a level line, a check box appears next to the level bubble. Clear the check box to hide the bubble. Select it again to display the bubble.</td>
</tr>
<tr>
<td>Symbol at End 2 Default</td>
<td>Places a bubble by default at the right end of the level line.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Automatic Room Computation Height</td>
<td>Computation height for the perimeter of a room is measured at a defined distance above the base level of the room. To use the default computation height (4’ or 1200 mm above the base level of the room), select this option.</td>
</tr>
</tbody>
</table>
### Level Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Elevation</td>
<td>The vertical height of the level.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>A label for the level. You can assign any label or name you wish to this property.</td>
</tr>
<tr>
<td>Design Option</td>
<td>A read-only field that indicates the design option in which the level lines display.</td>
</tr>
<tr>
<td>Extents</td>
<td></td>
</tr>
<tr>
<td>Scope Box</td>
<td>The scope box applied to the level. See Controlling Visibility of Datums Using Scope Boxes on page 1531.</td>
</tr>
</tbody>
</table>

### Grids

Use the Grid tool to place column grid lines in the building design. You can then add columns along the column grid lines. Grid lines are finite planes. You can drag their extents in elevation views so that they do not intersect level lines. This allows you to determine whether grid lines appear in each new plan view that you create for a project. See Datum Extents and Visibility on page 1527 and Visibility of Arc Grids in Views on page 1529.

Grids can be straight lines or arcs.
You can hide grid lines after you add them. For more information, see Hiding Elements in a View on page 811.

Related topic
■ Visibility of Arc Grids in Views on page 1529

Adding Grids

1 Click Home tab ➤ Datum panel ➤ (Grid).
2 Click Modify | Place Grid tab ➤ Draw panel, and select a sketch option.
   Use (Pick Lines) to snap the grid to an existing line, such as a wall.
   For more information about sketch options, see Sketching on page 1405.
3 Click when the grid is the correct length.

Revit Structure automatically numbers each grid. To change the grid number, click the number, enter the new value, and press ENTER. You can use letters for grid line values. If you change the first grid number to a letter, all subsequent grid lines update appropriately.

As you draw grid lines, the heads and tails of the lines can align to one another. If grid lines are aligned and you select a line, a lock appears to indicate the alignment. If you move the grid extents, all aligned grid lines move with it.

Related topics
■ Grids on page 98
■ Modifying Grids on page 99
■ Grid Properties on page 105

Modifying Grids

You can modify the appearance of grids in many ways.

Changing the Grid Type

To change the grid type on placement

1 Click Home tab ➤ Datum panel ➤ (Grid).
2 In the Type Selector on page 35, select a different grid type.

To change the grid type in a project view

1 Select the grid line in the drawing area.
2 In the Type Selector on page 35, select a different grid type.

Changing Grid Value

1 Click the grid header, then click the value in the grid header.
2 Enter a new value.
You can enter a number or a letter.
You can also change the value by selecting the grid line, and on the Properties palette, entering a different value for the Name property.

**Offsetting a Grid Line from Its Bubble**

There may be times when you sketch a grid line and want to offset its bubble from the rest of the grid line.

1. Sketch a grid line, or select an existing grid line.
   The end of the line near the bubble has drag controls.
   
   ![Selected grid with drag controls]

2. To resize the grid line, select and move the end drag control near the bubble.

3. Click the Add Elbow drag control (↑), then drag the control to the desired location to move the bubble away from the grid line.

   ![Bubble dragged from grid line]

When you move the bubble end out of line, the effect appears only in that view. The segments created from dragging the bubble have a solid line style. You cannot change this style.

As you drag a control, the cursor snaps at points similar to the neighboring grids. The cursor also snaps as the segments form straight lines.

**Showing and Hiding Grid Bubbles**

You can control whether grid bubbles display at either end of a grid line. You can do this graphically for an individual grid line in a view, or for all grid lines of a particular type by changing type properties.

![Grid line with bubbles]

To show or hide individual grid bubbles

1. Open a view that displays grid lines.
2. Select a grid line.
Revit Structure displays a check box near the grid bubble. You may need to zoom in to see it clearly.

1. Click here to turn off grid bubble.

3. Clear the check box to hide the bubble, or select it to show the bubble.
   You can repeat this process to show or hide the bubble at the opposite end of the grid line.

**To show or hide grid bubbles using type properties**

1. Open a view that displays grid lines.
2. Select a grid line, and click Modify | Grids tab ➤ Properties panel ➤ (Type Properties).
3. In the Type Properties dialog, do any of the following:
   - To display grid bubbles at the start point of grid lines in a plan view, select Plan View Symbols End 1 (Default).
   - To display grid bubbles at the endpoint of grid lines in a plan view, select Plan View Symbols End 2 (Default).
   - In views other than plan views (such as elevations and sections), indicate where to display grid bubbles. For Non-Plan View Symbols (Default), select Top, Bottom, Both (top and bottom), or None.

4. Click OK.
   Revit Structure updates all grid lines of this type in all views.

**Adjusting the Center Segment of a Grid Line**

You can adjust the length of the gap or center segment in an individual grid line. For example, you may want to adjust the gap so the grid line does not display through the middle of a model element. This feature is available when the grid line uses a grid type for which the Center Segment parameter is Custom or Gap. (See Customizing Grid Lines on page 103.)
A grid line that has been adjusted to end at the wall

To adjust the center segment of a grid line

1. Select the grid line in the view.
   Revit Structure displays a blue dot on the grid line. You may need to zoom in to see it clearly.

   ![Diagram showing how to select and adjust a grid line](image)

   **NOTE** If you do not see a blue dot indicating the segment boundary, move the 3D extent for the grid line outward until the dot is visible. In addition, check the setting of the Center Segment parameter. To do this, select the grid line, click Modify | Grids tab ➤ Properties panel ➤ (Type Properties). In the Type Properties dialog, change the value for Center Segment to None or Custom.

   The default length of the end segments of a grid line is defined by the End Segments Length parameter of the grid type.

2. Drag the blue dot along the grid line to the desired position.
   The end segment adjusts its length accordingly.
Customizing Grid Lines

You can customize grid types in the following ways:

- Change the line color, weight, and pattern of the entire grid line. (Modify the Bubble grid type, or create your own. See Changing a Continuous Grid Line on page 103.)

- Hide the center segment of the grid lines to create a gap, displaying only the end segments in views. (Modify the Bubble Gap grid type, or create your own. See Creating a Grid Line with a Center Gap on page 104.)

- Display the center segment of the grid line using a different line color, weight, and pattern than the end segments. (Modify the Bubble Custom Gap grid type, or create your own. See Creating a Grid Line with a Center Segment on page 104.)

To make these customizations, you modify a grid type. In views, all grid lines of that type reflect the changes.

![Type Properties](image)

**Changing a Continuous Grid Line**

1. Open a view that displays grid lines.
2. Select a grid line, and click Modify | Grids tab ➤ Properties panel ➤ (Type Properties).
3 In the Type Properties dialog, do the following:
   ■ For Center Segment, select Continuous.
   ■ For End Segment Weight, End Segment Color, and End Segment Pattern, specify the line weight, color, and pattern of the grid line.
   ■ Use the other parameters to indicate which grid bubble to use and where it should display. See Grid Type Properties on page 105.

4 Click OK.
   Revit Structure updates all grid lines of this type in all views.

**Creating a Grid Line with a Center Gap**

1 Open a view that displays grid lines.

2 Select a grid line, and click Modify | Grids tab ➤ Properties panel ➤ (Type Properties).

3 In the Type Properties dialog, do the following:
   ■ For Center Segment, select None.
   ■ For End Segment Weight, End Segment Color, and End Segment Pattern, specify the line weight, color, and pattern of the segments to display on each end of the grid line.
   ■ For End Segments Length, enter the length of the segments (in paper space) to display on each end of the grid line.
   ■ Use the other parameters to indicate which grid bubble to use and where it should display. See Grid Type Properties on page 105.

4 Click OK.
   Revit Structure updates all grid lines of this type in all views.

**Creating a Grid Line with a Center Segment**

1 Open a view that displays grid lines.

2 Select a grid line, and click Modify | Grids tab ➤ Properties panel ➤ (Type Properties).

3 In the Type Properties dialog, do the following:
   ■ For Center Segment, select Custom.
   ■ For Center Segment Weight, Center Segment Color, and Center Segment Pattern, specify the line weight, color, and pattern of the center segment of the grid line.
   ■ For End Segment Weight, End Segment Color, and End Segment Pattern, specify the line weight, color, and pattern of the end segments of the grid line.
   ■ For End Segments Length, enter the length of the segments (in paper space) to display on each end of the grid line.
   ■ Use the other parameters to indicate which grid bubble to use and where it should display. See Grid Type Properties on page 105.

4 Click OK.
   Revit Structure updates all grid lines of this type in all views.
Grid Properties

You can change properties for individual grid lines or for grid types.

Modifying Grid Properties

1. In a project view, select a grid line.
2. On the Properties palette, edit instance properties.
   See Grid Instance Properties on page 106.
3. To edit type properties, on the Properties palette, click ✏️ (Edit Type).
   See Grid Type Properties on page 105. Changes made to type properties affect all grid lines of that type in the project. You can click Duplicate to create a new grid line type.
4. Click OK.

Grid Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Symbol</td>
<td>The symbol to use for the ends of a grid line. The symbol can display a grid number in a bubble (Grid Head–Circle), a grid number but no bubble (Grid Head–No Bubble), or no grid bubble or number (none).</td>
</tr>
<tr>
<td>Center Segment</td>
<td>The type of center segment to display in the grid line. Select None, Continuous, or Custom. See Customizing Grid Lines on page 103.</td>
</tr>
<tr>
<td>Center Segment Weight</td>
<td>If the Center Segment parameter is Custom, the line weight is used for the center segment.</td>
</tr>
<tr>
<td>Center Segment Color</td>
<td>If the Center Segment parameter is Custom, the line color is used for the center segment. Select a color defined in Revit Structure, or define your own color. See Colors on page 1622.</td>
</tr>
<tr>
<td>Center Segment Pattern</td>
<td>If the Center Segment parameter is Custom, the pattern is used for the center segment. The line pattern can be solid or a combination of dashes and dots.</td>
</tr>
<tr>
<td>End Segment Weight</td>
<td>The line weight to use for a continuous grid line, or if Center Segment is None or Custom, the line weight for the end segments.</td>
</tr>
<tr>
<td>End Segment Color</td>
<td>The line color to use for a continuous grid line, or if Center Segment is None or Custom, the line color for the end segments.</td>
</tr>
<tr>
<td>End Segment Pattern</td>
<td>The line style to use for a continuous grid line, or if Center Segment is None or Custom, the line style for the end segments.</td>
</tr>
<tr>
<td>End Segments Length</td>
<td>If the Center Segment parameter is None or Custom, the length of the end segments (in paper space).</td>
</tr>
<tr>
<td>Plan View Symbols End 1 (Default)</td>
<td>In a plan view, the default setting to display a bubble at the start point of a grid line. (That is, when you draw a grid line, the bubble displays at its start point.)</td>
</tr>
</tbody>
</table>
Table:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan View Symbols End 2 (Default)</td>
<td>In a plan view, the default setting to display a bubble at the endpoint of a grid line. (That is, when you draw a grid line, the bubble displays at its endpoint.) If desired, you can show or hide bubbles for individual grid lines in views. See Showing and Hiding Grid Bubbles on page 100.</td>
</tr>
<tr>
<td>Non-Plan View Symbols (Default)</td>
<td>In project views other than plan views (such as elevations and sections), the default location where bubbles display on the grid line: Top, Bottom, Both (top and bottom), or None. If desired, you can show or hide bubbles for individual grid lines in views. See Showing and Hiding Grid Bubbles on page 100.</td>
</tr>
</tbody>
</table>

**Grid Instance Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Center Mark Visible</td>
<td>For an arc grid line, displays its center mark.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>A value for the grid line. This can be a numeric or alphanumeric value. The first instance defaults to 1.</td>
</tr>
<tr>
<td>Design Option</td>
<td>The design option in which the grid lines display. Read-only.</td>
</tr>
<tr>
<td><strong>Extent</strong></td>
<td></td>
</tr>
<tr>
<td>Scope Box</td>
<td>The scope box applied to the grid. See Controlling Visibility of Datums Using Scope Boxes on page 1531.</td>
</tr>
</tbody>
</table>
Project Location and Orientation

When you create a project, specify the geographic location using the street address, nearest major city, or the latitude and longitude. This project-wide setting is useful for generating location-specific shadows for views that use them, such as solar studies, walkthroughs, and rendered images.

You can also rotate a view to reflect True North (instead of Project North, which is the top of the view). Rotating a view to True North ensures that natural light falls on the correct sides of the building model and that the sun’s path through the sky is accurately simulated.

Related topics
- Shared Positioning on page 1265
- Relocating and Mirroring a Project on page 1269
- Mirroring a Project on page 1270

Specifying the Project Location

1 Click Manage tab ➤ Project Location panel ➤ Location.
   The Location Weather and Site dialog opens. You can also access this dialog from the Sun Settings dialog on page 1390.
2 Click the Location tab.
3 For Define Location by, select one of the following:
   - Internet Mapping Service. When your computer is connected to the Internet, this option displays an interactive map through the Google Maps™ mapping service. Until you specify a different project location, the location is defined as <Default> and is set to the longitude and latitude of the major city specified by Revit Structure for your locale.

NOTE As its name implies, the Internet Mapping Service requires a working Internet connection in order to be fully functional. If Internet service is unavailable, you can still use this method to specify a project location; however, the corresponding longitude and latitude for the location cannot be set until your Internet connection is restored, as described in this topic.
Default City List. Displays a list of major cities from which to select a location. Until you specify a different project location, the location is defined as <Default> and is set to the longitude and latitude of the major city specified by Revit Structure for your locale. The Default City List option is recommended for HVAC sizing. No Internet connection is required.

4 Specify the project location using one of these methods:

Internet Mapping Service

a For Project Address, enter the street address, city and state, or latitude and longitude of the project, and click Search. Enter latitude and longitude coordinates as <latitude>,<longitude>. The value you enter for Project Address in this dialog does not affect the project address that displays in the title blocks of sheets for the project.

Your search results display.

b If necessary, respond to any of the following alerts as described. For additional information, see Troubleshooting Location Dialog Issues on page 109.

■ Address not found. Either refine the project address and click Search or, for a newly established address, enter a nearby address, click Search, and then drag the project location map pin to the appropriate location.

■ Multiple results found. Click one of the hyperlinked locations displayed in the project location tooltip, and click Search.

■ No Internet connection. Check your Internet connection. If no connection is available, click OK to close the Location dialog and save your project address. When a dialog notifies you of a mismatch between the project address you entered and the selected map location, click Continue. If you do not have access to the Internet at all, no further steps are needed; the project address is stored as text. If the Internet is only temporarily unavailable, when Internet service is restored, re-open the Location dialog, click Search, and continue with the steps in this procedure.

c Use the following tools to adjust the map as needed:

■ Pan. When you place the cursor over the map, the cursor changes to a hand, and you can drag the map to pan the view. You can also use these controls: (Pan up), (Pan down), (Pan left), and (Pan right).

■ Zoom. Click (Zoom in) or (Zoom out), or drag the zoom slider to adjust the zoom level.

■ Return to last result. Click if you have adjusted the map and want to restore the last search result.

■ Map views. Click a map view to select it:

■ Map. Shows street map.

■ Satellite. Shows satellite imagery.

■ Hybrid. Shows street map superimposed on satellite imagery.

■ Terrain. Default view. Shows street map superimposed on topographical map.
d Drag the project location map pin to move the project location as needed. When you move the project location pin, the Project Address field displays a searchable latitude/longitude value. Click Search to resolve the address and display it in the Project Address field. If multiple results are found, click one of the hyperlinked locations displayed in the project location tooltip, and then click Search.

**NOTE** Unlike the Google Maps™ mapping service, the Location dialog does not support adding placemarks.

e If the project is located in an area that observes daylight savings time and you want shadows to be adjusted accordingly, then select Use Daylight Savings time.

**Default City List**

a Specify the project location using one of the following methods:

- **Nearest major city.** For City, select a city from the list. The corresponding Latitude, Longitude, and Time Zone values are displayed.

- **Exact location.** Enter values for Latitude and Longitude.

b If the project is located in an area that observes daylight savings time and you want shadows to be adjusted accordingly, then select Use Daylight Savings time.

5 Click OK.

**Related topics**

- [Defining Named Positions](#) on page 1265
- [Creating Solar Studies](#) on page 1376
- [Rendering an Image](#) on page 1076

**Troubleshooting Location Dialog Issues**

The following sections provide tips to help you identify and resolve commonly encountered Location dialog alerts and issues:

**Internet service has been disrupted**

**Issue:** Either your computer is not configured for Internet access, or your Internet connection is temporarily down.

**Solution:** Check your Internet connection. If you are able to restore the connection, enter a project address, and then click Search to resolve the address. If no connection is available, enter a project address, and then click OK. When the Project Address Not Resolved dialog displays, click Close. If you do not have access to the Internet at all, no further steps are needed; the project address is stored as text. If Internet service is only temporarily unavailable, when service is restored, re-open the Location dialog, and click Search.

**Could not establish connection to Internet Mapping Service**

**Issue:** Your access to the Internet Mapping Service may be blocked by your network settings.
Solution: Check your access settings to autodesk.com. If this site is blocked by your company’s firewall or some other network security system, contact your network administrator.

Address not found

Issue: The project address you entered could not be found by the Google Maps™ mapping service.

Solution: Either refine the project address and click Search or, for a newly established address, enter a nearby address, click Search, and then drag the project location map pin to the appropriate location.

Project address not resolved

Issue: The project address you entered cannot be resolved because no Internet service is detected.

Solution: Click Close to clear the alert. Keep the Location dialog open, and check your Internet connection. If you are able to restore the connection, click Search to resolve the project address. If no connection is available, then click OK.

If you do not have access to the Internet at all, no further steps are needed; the project address is stored as text. If Internet service is only temporarily unavailable, when service is restored, re-open the Location dialog, and click Search.

Setting project address

Issue: After you enter a project address, if you click OK before you click Search, the Google Maps™ mapping service cannot resolve the address and update the map. Therefore, the project address does not match selected map location.

Solution: Select one of the options in the Setting Project Address dialog: 1) Go back to the Location dialog, and click Search to resolve the address you entered, or 2) Continue using the project address you entered, and store it as text.

Multiple results are displayed in the project location tooltip

Issue: More than one address matches your entry.

Solution: Click one of the hyperlinked locations displayed in the project location tooltip, and click Search.

Numbers display for project address

Issue: When you drag the project location map pin to a new location, the corresponding longitude and latitude display in the Project Address field.

Solution: Click Search to resolve the project address.

Rotating a View to True North

1 Open a plan view.

NOTE If you need to rotate a 3D view to True North, use the ViewCube.

2 Change the view orientation to True North, as follows:
   a Access view properties.
   b On the Properties palette, for Orientation, select True North, and click Apply.

This change allows you to see accurate shadows in the plan view. See Displaying Sun and Shadows on page 1375.
Rotate the project to True North, as follows:

**a** Click Manage tab ➤ Project Location panel ➤ Position drop-down ➤ Rotate True North.

**b** Rotate the building model, using one of the following methods:

- On the Options Bar, for Angle from Project to True North, enter a value to set the angle of rotation.
  
  For example, if the difference between Project North (the top of the view) and True North is 45 degrees, enter 45. The model rotates in the view to the specified angle.

- Click in the view to rotate the model to True North graphically (similar to using the Rotate tool).

Rotating a building model in a plan view that is oriented to True North

![Plan view with the building model rotated to True North](image)

Related topics

- Project Location and Orientation on page 107
- Shared Positioning on page 1265

**Rotating Project North**

Drafting conventions dictate that Project North is the top of the view. If you need to change Project North, use the Rotate Project North tool. This tool changes Project North for all views in the project.
1 Click Manage tab ➤ Project Location panel ➤ Position drop-down ➤ Rotate Project North.
2 In the Rotate Project dialog, select the desired option.
3 Click OK.

A message displays to indicate that the project was rotated. It also shows errors, if any. You can export errors to review and correct them. See Exporting Warnings to a File on page 1681.
Site Design

Revit Structure features several tools to help you lay out a site plan. You can start by sketching a toposurface, add property lines, a building pad, and parking and site components. You can then create a 3D view or render it for a more realistic presentation.

Site Settings

You can modify a project’s global site settings at any time. You can define contour line intervals, add user-defined contour lines, and select the section cut material.

Defining Site Settings

Concepts
You can modify a project’s global site settings at any time. You can define contour line intervals, add user-defined contour lines, and select the section cut material.
To see the results of your changes to the contour line settings, open a site plan view. To see the results of your changes to the section cut material, open a section view.

- Select At Intervals Of, and enter a value for contour line intervals. This value determines the elevation at which contour lines display.

- For Passing Through Elevation, enter a value to set the starting elevation for contour lines. By default, Passing Through Elevation is set to zero. If you set the contour interval to 10, for example, lines display at -20, -10, 0, 10, 20. If you set the Passing Through Elevation value to 5, lines display at -25, -15, -5, 5, 15, 25.

Adding Custom Contour Lines to a Site Plan

- Start. Enter the elevation where additional contour lines begin to display.

- Stop. Enter the elevation at which additional contour lines no longer display. This value is enabled when you select Multiple Values for Range Type.

- Increment. Specify the increment for each additional contour line. This value is enabled when you select Multiple Values for Range Type.

- Range Type. For one additional contour line, select Single Value. For multiple contour lines, select Multiple Values.

- Subcategory. Specify the line style for the contour line. The default styles are Hidden Lines, Primary Contours, Secondary Contours, and Triangulation Edges. To create a custom line style, see Object Styles on page 1601.

**NOTE** If you clear At Intervals of, custom contour lines still display.

Setting Section Graphics

- For Section cut material, select a material to use to display the site in a section view. Appropriate materials include Site-Earth, Site-Grass, and Site-Sand.

- For Elevation of poche base, enter a value to control the depth of the cross-section of earth, for example, –30 feet or –25 meters. This value controls the poche depth for all topography elements in your project.

Setting Property Data

- Specify an option for Angle Display. If you select Degrees, property lines display in the Property Lines bearings table using the 360-degree bearing standard. Property line tags display using the same notation.

- Specify an option for Units. If you select Decimal degrees, the angles in the Property Lines bearings table display as decimals rather than as degrees, minutes, and seconds.

**How do I get here?**

Click Architect & Site tab ➤ Model Site panel ➤ .

**Related Topics**

- Contour Line Labels on page 130
- Project Location and Orientation on page 107
- Site Settings Properties on page 115
Site Settings Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contour Line Display</td>
<td>Displays contour lines. If you clear the check box, custom contour lines still display in the drawing area.</td>
</tr>
<tr>
<td>At Intervals of</td>
<td>Sets the interval between contour lines.</td>
</tr>
<tr>
<td>Passing Through Elevation</td>
<td>Contour intervals are based on this value. For example, if you set the contour interval at 10, contour lines display at -20, -10, 0, 10, 20. If the Passing Through Elevation value is set to 5, lines display at -25, -15, -5, 5, 15, 25.</td>
</tr>
</tbody>
</table>

Additional Contours

| Start                   | Sets the elevation where additional contour lines begin.                                                                                                                                                                                                                                                                                                           |
| Stop                    | Sets the elevation where additional contour lines no longer display.                                                                                                                                                                                                                                                                                             |
| Increment               | Sets the interval for additional contour lines.                                                                                                                                                                                                                                                                                                               |
| Range Type              | Select Single Value to insert one additional contour line. Select Multiple Values to insert additional incremental contour lines.                                                                                                                                                                                                                                    |
| Subcategory             | Sets the type of contour lines to display. Select a value from the list. You can define custom contour line types using the Object Styles tool, in the Topography category.                                                                                                                                                                                                 |

Section Graphics

| Section cut material    | Sets the material that displays in a section view.                                                                                                                                                                                                                                                                                                              |
| Elevation of poche base | Controls the depth of the cross-section of earth (for example, –30 feet or –25 meters). This value controls the poche depth for all topography elements in your project.                                                                                                                                                                                                 |

Property Data

| Angle Display           | Specifies the display of angular values on property line tags.                                                                                                                                                                                                                                                                                             |
| Units                   | Specifies the units to use when displaying bearing values in the Property Lines table.                                                                                                                                                                                                                                                                     |

Toposurfaces

The Toposurface tool defines a topographical surface (a toposurface) using points. You can create toposurfaces in 3D views or site plans.

Creating a Toposurface by Picking Points

1. Open a 3D or site plan view.
2. On the Options Bar, set a value for Elevation.
   The points and their elevations are used to create the surface.
3. Next to the Elevation text box, select one of the following:
   - **Absolute Elevation.** Points display at the specified elevation. You can place points anywhere in the active drawing area.
**Relative to Surface.** Allows you to edit an existing toposurface by placing points on it at the elevation you specify. To use this option effectively, you may want to work in a shaded 3D view.

4. Click in the drawing area to place points. If needed, change the elevation on the Options Bar as you place additional points.

**How do I get here?**

Click Architect & Site tab ➤ Model Site panel ➤ (Toposurface).

**Related Topics**

- Splitting a Toposurface on page 119
- Toposurface Subregions on page 118
- Toposurface and Subregion Properties on page 122

**Create from Import**

**Creating a Toposurface from Imported 3D Data**

You can automatically generate a toposurface based on 3D contour data imported in DWG, DXF, or DGN formats. Revit Structure analyzes the 3D contour data and places a series of elevation points along the contour lines.

1. Open a 3D view of the site plan.
2. Select the imported 3D contour data in the drawing area.
   - The Add Points from Selected Layers dialog displays.
3. Select the layers to which you want to apply elevation points, and click OK.

**How do I get here?**

Click Massing & Site tab ➤ Model Site panel ➤ (Toposurface).

On the Modify | Edit Surface tab, click Tools panel ➤ Create From Import drop-down ➤ (Select Import Instance).

**Related Topics**

**Related topics**

- Splitting a Toposurface on page 119
- Toposurface Subregions on page 118
- Toposurface and Subregion Properties on page 122

**Creating a Toposurface from a Points File**

**Preparing a Points File**

A points file is typically generated by a civil engineering software application. The file provides contour data using a regularized grid of elevation points.
The points file must contain x, y, and z coordinate numbers as the first numeric values in the file. The file must also be in a comma-delimited file format (a CSV or TXT file). Additional information in the file (such as a point name) is ignored. Any additional numeric information for a point must occur after the x, y, and z coordinate values. If the file contains 2 points with the same x and y coordinates, Revit Structure uses the point with the largest z value.

1. Open a 3D or site plan view.
2. In the Open dialog, navigate to the location of the points file.
3. In the Format dialog, specify the units used to measure the points in the points file (for example, decimal feet or meters), and click OK.

   Revit Structure generates points and a toposurface from the coordinate information in the file.

**How do I get here?**

Click Architect & Site tab ➤ Model Site panel ➤ (Toposurface).

On the Modify | Edit Surface tab, click Tools panel ➤ Create From Import drop-down ➤ (Specify Points File).

**Related Topics**

- Splitting a Toposurface on page 119
- Toposurface Subregions on page 118
- Toposurface and Subregion Properties on page 122

**Best Practices**

When viewing a toposurface, consider the following:

- **Visibility.** You can control the visibility of topographic points. There are 2 topographic point subcategories, Boundary and Interior. Revit Structure classifies points automatically.

- **Triangulation edges.** Triangulation edges for toposurfaces are turned off by default. You can turn them on by selecting them from the Model Categories/Topography category in the Visibility/Graphics dialog.

**Example**

*Sample topographical surface defined by picking points in a site plan view*
Simplifying a Toposurface

Simplifying a surface can improve system performance, particularly on surfaces with a large number of points.

1. Open the site plan view and select the toposurface.
2. Enter a value for surface accuracy, and click OK.
3. Click (Finish Surface).

How do I get here?

Click Modify | Topography tab ➤ Surface panel ➤ (Edit Surface).

Click Edit Surface tab ➤ Tools panel ➤ (Simplify Surface).

Related topics

Merging Toposurfaces on page 120
Toposurface and Subregion Properties on page 122
Toposurfaces on page 115

Toposurface Subregions

Adding a Toposurface Subregion

- Click (Pick Lines) or use other sketch tools to create a subregion on the toposurface.

Changing a Toposurface Subregion

1. Select the subregion.
2. On the Subregion panel, click (Edit Boundary).
3. Click (Pick Lines) or use other sketch tools to modify a subregion on the toposurface.

Example

Toposurface subregions are areas that you sketch inside existing toposurfaces. For example, you can use subregions to draw parking lots on a graded surface, roads, or islands. Creating a subregion does not result in separate surfaces. It merely defines an area of the surface where you can apply a different set of properties, such as material.

The following image shows a toposurface that has a toposurface subregion, shown in gray.
How do I get here?

- Click Architect & Site tab ➤ Model Site panel ➤ (Subregion).

Related Topics

- Splitting a Toposurface on page 119
- Graded Regions on page 121
- Toposurface and Subregion Properties on page 122

Splitting a Toposurface

Splitting a Toposurface

1. Open a site plan or 3D view.

2. In the drawing area, select the toposurface to split.
   Revit Structure enters sketch mode.

3. Click Modify l Split Surface tab ➤ Draw panel ➤ (Pick Lines), or use other sketch tools to split the toposurface.
   You cannot pick toposurface lines with the Pick Lines tool. You can pick other valid lines, such as walls.

Sketching the Split Surface

1. Sketch a single closed loop that does not touch boundaries of the surface.
2 Sketch any number of open loops. Both ends of an open loop must lay on the boundary of the surface. No part of the open loop can intersect or be coincident with the boundary of the surface.

**Example**

You can split a toposurface into 2 distinct surfaces and then edit those surfaces independently. After splitting a surface, you can assign different materials to these surfaces to depict roads, lakes, plazas, or hills. You can also delete entire portions of the toposurface.

**Sample split surface**

![Sample split surface](image)

**How do I get here?**

Click Architect & Site tab ➤ Modify Site panel ➤ (Split Surface).

**Merging Toposurfaces**

**Merging Toposurfaces**

1. Select the primary surface.
2. Select the secondary surface.
   The 2 surfaces merge into one.

**Removing Points on Common Edges**

- Clear Remove points on common edges on the Options Bar.
  This option removes excess points that were inserted after a surface was split. The option is selected by default.

**Examples**

You can merge 2 separate toposurfaces into one surface. This tool is useful after previously splitting the surface.

The surfaces to be merged must share a common edge or overlap.

**Valid split surfaces for merging**

![Valid split surfaces for merging](image)
Invalid split surfaces for merging

How do I get here?

Click Architect & Site tab ➤ Modify Site panel ➤ (Merge Surfaces).

Graded Regions

To create a graded region, you select a toposurface, which should be an existing surface in the current phase. Revit Structure marks the original surface as demolished and makes a copy with a matching boundary. Revit Structure marks the copy as new in the current phase.

To grade a toposurface

1. In the Edit Graded Region dialog, select one of the following:
   - Create a new toposurface exactly like the existing one.
   - Create a new toposurface based on the perimeter points only.
2. Select the toposurface.
   If you are editing the surface, Revit Structure enters sketch mode.

Example

How do I get here?

Click Architect & Site tab ➤ Modify Site panel ➤ (Graded Region).

Related topics

- Reporting Cut and Fill Volumes on a Site on page 124
- Toposurface Subregions on page 118
- Toposurface and Subregion Properties on page 122
## Toposurface and Subregion Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>Select the surface material from the list. You can create your own toposurface material. Topographical surfaces do not support materials with surface patterns. See Materials on page 1573.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Projected Area</td>
<td>The projected area is the area that the surface covers when you look down on it. This is a read-only value.</td>
</tr>
<tr>
<td>Surface Area</td>
<td>Displays the total surface area. This is a read-only value.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>User-defined comments about the toposurface, which can display in schedules.</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the toposurface, which can display in schedules.</td>
</tr>
<tr>
<td>Mark</td>
<td>A unique identifier you can assign.</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>The phase when the toposurface is created.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>The phase when the toposurface is demolished.</td>
</tr>
</tbody>
</table>

## Property Lines

To create property lines, you can use the sketching tools in Revit Structure or enter survey data directly into the project. Revit Structure aligns the survey data with True North.

### Create by Sketching
1. Open a site plan view.
2. In the Create Property Line dialog, select Create by sketching.
3. Click (Pick Lines) or other sketch tools to sketch lines.
4. **Sketch** the property lines.
   - Lines should form a closed loop. If you sketch an open loop, and click Finish Property Line, Revit Structure issues a warning that it will not calculate the area. You can ignore the warning to continue, or close the loop.

### Create by Entering Distances and Bearings
1. Open a site plan view.
2. In the Create Property Lines dialog, select Create by entering distances and bearings.
3. In the Property Lines dialog, click Insert, and add the distances and bearings from your survey data.
4 (Optional) Describe a property line as an arc.

**How to**

a For Distance and Bearing, enter values that describe a line segment between 2 points on the arc.

b For Type, select Arc.

c For Radius, enter a value. The radius value must be greater than half the length of the line segment. The larger the radius, the larger the circle becomes, resulting in a flatter arc.

d For L/R, select L if the arc appears to the left of the line segment. Select R if the arc appears to the right of the line segment.

5 Insert additional lines as needed.

6 Click Up and Down to modify the order of the property lines.

7 In the drawing area, move the property lines to their exact placement, and click to place.

**NOTE** You can snap the property line to a benchmark using the Move tool.

---

**Property Lines Example**

**Property lines on a topographical surface**

---

**Options**

In addition to viewing property lines in a drawing, you can do the following with them:

- **Scheduling.** You can schedule property lines. The schedule can include the Name and Area property line parameters. (The format of the area comes from the Area Units Format type property of the property lines.) When you create the schedule, select Property Lines as the category to schedule.

- **Tagging.** You can tag property lines that can report square footage or acreage. Load the tags from the Annotations folder of the Revit Structure family library. The tags are Property Tag - Acres.rfa (acreage), Property Tag - SF.rfa (square footage), and M_Property Tag.rfa (metric).

- **Exporting.** You can export property line area information when you export your project to an ODBC database. For more information about creating an ODBC database.

---

**How do I get here?**

Click Architect & Site tab ➤ Modify Site panel ➤ (Property Line).

**Related Topic**

- **Converting Sketched Property Lines to Table-Based Property Lines** on page 124
Converting Sketched Property Lines to Table-Based Property Lines

1. Open a site plan view.
2. In the drawing area, select the sketched property line.
3. Click Modify | Property Lines tab ➤ Property Lines panel ➤ (Edit Table).
4. Read the Constraints Lost warning, and click Yes to continue.
5. In the Property Lines dialog, make any necessary changes and click OK.

Reporting Cut and Fill Volumes on a Site

Revit Structure can report cut and fill volumes on a site to aid in determining the costs of landscape modification during site development.

Revit Structure reports the values by making a comparison between a surface from one phase and, from a later phase, another surface whose boundary lies within the earlier surface. For example, Revit Structure can compare a toposurface created in Phase 1 and a toposurface created in Phase 2 that lies within the boundary of the surface from Phase 1. (See Project Phasing on page 877.)

When you select the later surface and click Element Properties, you see the following instance properties:

- The Cut value is the volume removed (where the later surface is lower than the earlier surface).
- The Fill value is the volume added (where the later surface is higher than the earlier surface).
- Net Cut/Fill value comes from subtracting the cut value from the fill value.

Viewing the Cut/Fill Volumes

This procedure is a general method of reporting cut/fill values. There are other ways to report values, including sketching a new surface within an existing surface.

1. Create a toposurface in a site plan view. See Toposurfaces on page 115.
2. Select the finished toposurface.
3. On the Properties palette, set Phase Created to a phase earlier than the view's phase. For example, when the view's phase is New Construction, set the Phase Created value to Existing.
4. To create a graded region on the toposurface, do the following:
   - Click Architect & Site tab ➤ Modify Site panel ➤ (Graded Region).
   - In the Edit Graded Region dialog, select Create a new toposurface exactly like the existing one.
   - Select the toposurface.
   - This demolishes the original surface and creates a copy that occupies the same boundary as the original.
5. Click (Finish Surface).
6. Select the toposurface copy, and notice in the Properties palette that Revit Structure lists the new cut/fill properties for the toposurface.

NOTE: You may need to press Tab to select the copied surface. You can apply a phase filter to the view to see only new elements, and not demolished ones. See Phase Filters on page 879.
Cut and Fill in a Schedule

You can create a topography schedule that includes cut, fill, and net cut/fill values. You should also name the different surfaces to distinguish them in your schedule. See Creating a Schedule or Quantity on page 772.

Cut and Fill Reporting with Building Pads

If you add a building pad to a graded surface, you will see cut and fill reported separately for the pad and the toposurface in a topography schedule. This is because the pad divides the graded surface into 2 surfaces: one is the surface under the pad (the graded surface), and one is the surface that is not under the pad (the pad surface).

You should name both the graded surface and the pad surface to distinguish them in your schedule.

To select the surface under the pad, press Tab to highlight it, or turn off the pad's visibility. See Overriding Visibility and Graphic Display of Individual Elements on page 802.

Building Pads

You can add a building pad to a toposurface and then modify the pad's structure and depth. You add a building pad by sketching a closed loop on a toposurface. After sketching the pad, you can specify a value to control the height offset from the level and other properties. You can define openings in the pad by sketching closed loops inside the perimeter of the building pad, and you can define a slope for the building pad.

You can add a building pad to a toposurface only. It is recommended that you create the building pad within a site plan. However, you can add a building pad to a toposurface in a floor plan view. The pad may not be immediately visible in the floor plan view if the view range or building pad offset are not adjusted appropriately. For example, suppose that you sketch a toposurface at an elevation of 10 meters in a floor plan view. You then sketch a pad on the surface at an offset of -20 meters from the surface. If the view depth of the plan view is not low enough, you will not see the pad. See View Range on page 864.

Adding a Building Pad

Add a Building Pad

1. Open a site plan view.
2. Use the draw tools to sketch the building pad as a closed loop.
3. On the Properties palette, set the Height Offset From Level and other properties as needed.

TIP To see the building pad in a Floor Plan view, set the building pad offset to a value higher than Level One, or adjust the view range.

Concepts

You can add a building pad to a toposurface and then modify the pad's structure and depth. You add a building pad by sketching a closed loop on a toposurface. After sketching the pad, you can specify a value to control the height offset from the level and other properties. You can define openings in the pad by sketching closed loops inside the perimeter of the building pad, and you can define a slope for the building pad.
You can add a building pad to a toposurface only. It is recommended that you create the building pad within a site plan. However, you can add a building pad to a toposurface in a floor plan view. The pad may not be immediately visible in the floor plan view if the view range or building pad offset are not adjusted appropriately. For example, suppose that you sketch a toposurface at an elevation of 10 meters in a floor plan view. You then sketch a pad on the surface at an offset of –20 meters from the surface. If the view depth of the plan view is not low enough, you will not see the pad.

**Examples**

The following image shows a section view of a building pad offset from the surface.

![Section view of building pad](image1)

The following image shows a 3D view of a building pad on a graded toposurface.

![3D view of building pad](image2)

The following image shows a 3D view of a sloped building pad on a toposurface.

![3D view of sloped building pad](image3)

**How do I get here?**

Click Architect & Site tab ➤ Modify Site panel ➤ ![Building Pad](icon)

Click the tools on the Modify | Create Pad Boundary tab ➤ Draw panel.
Modifying Building Pads

1. Open the site plan that contains the building pad.
2. Select the building pad.

   **NOTE** Use *Tab* to cycle through the selection options. Selection options are displayed on the left side of the status bar.

3. Click Modify | Pads tab ➤ Mode panel ➤ (Edit Boundary).
4. Click Modify | Pads ➤ Edit Boundary tab ➤ Draw panel ➤ (Boundary Line, and use the sketch tools to make the necessary changes.
5. To slope the building pad, use a *slope arrow*.
6. Click ✓ (Finish Edit Mode).

Modifying the Structure of a Building Pad

1. Open the site plan that contains the building pad.
2. Select the building pad.

   **NOTE** Use *Tab* to cycle through the selection options. Selection options are displayed on the left side of the status bar.

3. Click Modify | Pads tab ➤ Properties panel ➤ (Type Properties).
4. In the Type Properties dialog, for Structure, click Edit.
5. In the Edit Assembly dialog, set the function for each layer.
   
   Each layer must have a function assigned to it, so Revit Structure can match layers accurately. Layers can be assigned for the following functions:
   
   - **Structure**. A layer that supports the remainder of the building pad.
   - **Substrate**. A material that acts as a foundation for another material.
   - **Thermal/Air Layer**. A layer that provides insulation and prevents air penetration
   - **Finish 1**. A finish layer, for example, the top surface of the building pad.
   - **Finish 2**. A finish layer, for example, the bottom surface of the building pad.
   - **Membrane Layer**. A membrane of zero thickness that prevents water vapor penetration.

   **NOTE** The Wraps check box can be left unchecked.

6. Set the Material and Thickness for each layer.
7. Click Insert to add a new layer. Click Up or Down to change the layer order.
8 Click OK twice.

Related topics

- Compound Structure on page 573
- Modifying Building Pads on page 127
- Building Pad Properties on page 128

Building Pad Properties

You can change the properties of building pad types and building pad instances.

Related topic

- Slope Arrow Properties on page 584

Modifying Building Pad Properties

1 Open a site or plan view.
2 Select the building pad.

**NOTE** Use Tab to cycle through the selection options. Selection options are displayed on the left side of the status bar.

3 Modify instance and type properties:
   - To change the properties of the building pad instance, change the values in the Properties palette.
   - To change the properties of the building pad type, click (Edit Type) in the Properties palette, and change the properties as desired.

4 Property changes made to a building pad type affect all building pads of this type in the project. (To create a new building pad type, click Duplicate.)
5 When finished, click Apply on the Properties palette, or OK in the Type Properties dialog.

Building Pad Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Structure</td>
<td>Defines the building pad structure. See Modifying the Structure of a Building Pad on page 127.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Displays the total building pad thickness. This is a read-only parameter.</td>
</tr>
</tbody>
</table>

Graphics

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coarse Scale Fill Pattern</td>
<td>Sets a fill pattern for a building pad in coarse-scale view. Click in the value box to open the Fill Patterns dialog.</td>
</tr>
</tbody>
</table>
### Building Pad Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coarse Scale Fill Color</td>
<td>Applies a color to the fill pattern for a building pad in coarse-scale view.</td>
</tr>
</tbody>
</table>

### Constraints

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level</td>
<td>Sets the level of the building pad.</td>
</tr>
<tr>
<td>Height Offset From Level</td>
<td>Sets the height from which the building pad is offset from the level.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>Used to define the extents of a room.</td>
</tr>
</tbody>
</table>

### Dimensions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slope</td>
<td>The building pad slope. This is a read-only parameter.</td>
</tr>
<tr>
<td>Perimeter</td>
<td>The building pad perimeter. This is a read-only parameter.</td>
</tr>
<tr>
<td>Area</td>
<td>The area of the building pad. This is a read-only parameter.</td>
</tr>
<tr>
<td>Volume</td>
<td>The volume of the building pad. This is a read-only parameter.</td>
</tr>
</tbody>
</table>

### Phasing

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase Created</td>
<td>Sets the phase when the building pad is created.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Sets the phase when the building pad is demolished.</td>
</tr>
</tbody>
</table>

### Parking Components

You can add parking spaces to a toposurface and define the toposurface as the parking component’s host.

**To add parking components**

1. Open a view that displays the toposurface to modify.
2. Place the cursor on the toposurface and click to place the component. Place as many components as desired.
   - You can create an array of parking components.

**How do I get here?**

Click Architect & Site tab ➤ Model Site panel ➤ (Parking Component).

**To rehost parking components**

1. Select the parking components.
2. Click Modify | Parking tab ➤ Host panel ➤ (Pick New Host).
3 Select the toposurface.
   When you use the Pick Host tool, you are deliberately setting the parking component on top of the toposurface. If you move the parking component around on the toposurface, it remains attached to the toposurface.

Example

Site Components

You can place site-specific components, such as trees, utility poles, and fire hydrants, in a site plan. If no site components are loaded into your project, a message indicates that no appropriate families are loaded.

To add site components
   1 Open a view that displays the toposurface to modify.
   2 Click the Site Component tool and select the desired component from the Type Selector on page 35.
   3 Click in the drawing area to add one or more components.

Example

How do I get here?

Click Architect & Site tab ➤ Model Site panel ➤ (Site Component).

Related topics
   ■ Toposurfaces on page 115
   ■ Parking Components on page 129

Contour Line Labels

You can label contour lines to indicate their elevation. Contour labels display in site plan views.
Labeling Contour Lines

You can label contour lines to indicate their elevation. Contour labels display in site plan views.

1. Create a topographic surface with different elevations.
2. Open a site plan view.
3. Sketch a line that intersects one or more contour lines.
   If the line does not intersect a contour line, Revit Structure issues an error.

Labels display on the contour lines. (You may need to zoom in to see the labels.) The label line itself is not visible, unless you select a label.

Example
Labeled contour lines

How do I get here?

Click Architect & Site tab ➤ Modify Site panel ➤ (Label Contours).

Related topics
- Modifying the Label Line on page 132
- Changing the Appearance of Contour Line Labels on page 132
- Contour Label Type Properties on page 132
Modifying the Label Line

1. Open a site plan view.
2. Click a contour line label.
   The label line is selected and visible.
3. Drag the end controls to resize the contour label line.
   You can also move the contour label line on the toposurface to obtain different elevation values.

Changing the Appearance of Contour Line Labels

You can change the display characteristics of labels for contour lines. For example, you can use a different font, size, or typeface setting (such as bold or italics). Also, you can specify label units and whether labels display for primary contour lines only, or for both primary and secondary contour lines.

To change the appearance of contour line labels

1. Open a site plan view, and select a contour line label.
2. Click Modify | Contour Labels tab ➤ Properties panel ➤ (Type Properties).
3. In the Type Properties dialog, do either of the following:
   ■ To change parameters for the current contour label type, change the parameters as desired, and click OK.
   ■ To create a new type of contour label, do the following:
     a. Click Duplicate.
     b. Enter a name for the new contour label type, and click OK.
     c. Change the parameters as desired, and click OK.

See Contour Label Type Properties on page 132.

Revit Structure displays labels for the contour lines using the new parameters.

Contour Label Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Sets the color of label text.</td>
</tr>
<tr>
<td>Text Font</td>
<td>Sets the font for label text.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Sets the size of label text.</td>
</tr>
<tr>
<td>Bold</td>
<td>Applies bold to label text.</td>
</tr>
<tr>
<td>Italic</td>
<td>Applies italics to label text.</td>
</tr>
<tr>
<td>Underline</td>
<td>Applies underlining to label text.</td>
</tr>
<tr>
<td>Label primary contours only</td>
<td>If selected, only the primary contour lines are labeled. See Site Settings on page 113.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Units Format</td>
<td>Specifies units and rounding properties for contour lines. By default, this option uses the project settings.</td>
</tr>
<tr>
<td>Elevation Base</td>
<td>Specifies the source of the elevation base: project, shared, or relative.</td>
</tr>
</tbody>
</table>
The Revit conceptual design environment provides flexibility early in the design process for architects, structural engineers, and interior designers to express ideas and create parametric massing families that can be integrated into building information modeling (BIM). Use this environment to directly manipulate a design’s points, edges, and surfaces into buildable forms.

The designs created in the conceptual design environment are massing families that can be used in the Revit project environment as the basis from which you create more detailed architecture by applying walls, roofs, floors, and curtain systems. You can also use the project environment to schedule floor areas, and to conduct preliminary spatial analysis.

Related topics

- Revit Families on page 677
- Massing Studies on page 1329
Conceptual Design Environment Overview

The conceptual design environment is a type of family editor in which you create conceptual designs using in-place and loadable mass family elements. When a conceptual design is ready, it can be loaded into the Revit project environment (RVT file). Creating designs in this environment can accelerate the design process. See Massing Studies on page 1329.

NOTE The standard Family Editor is used when working with families outside the conceptual design environment. When a family is loaded from the conceptual design environment into a project, the standard massing tools are available.

To enter the conceptual design environment, use one of the following methods:

- **Conceptual Design Environment**
  Use the Revit user interface and create new massing families that reside outside the project environment. If desired, you can load these massing families into a project.

- **Revit Project Environment**
  Use the In-Place Mass tool in a Revit project to create or manipulate massing families. When accessed through the In-Place Mass tool, the conceptual design environment does not have 3D reference planes and 3D levels.

NOTE The Revit conceptual design environment creates new masses. Masses created using a previous release of Revit Structure use the same massing tools originally used to create them, and remain dedicated to these tools throughout the duration of the project.

Exploring Conceptual Designs

The Revit conceptual design environment is used for the following:

- Early conceptual study models. See Early Conceptual Study Models on page 136.
- Integrated study models. See Integrated Study Models on page 137.
- Intelligent sub-components. See Intelligent Sub-Components on page 137.

Early Conceptual Study Models

Create and explore models before committing to a particular design. If a decision is made to use one, integrate it into the main Revit project.

As conceptual designs are developed, they may go through several possible formations before meeting the desired project requirements. The conceptual design environment provides direct form creation and manipulation, making it easy to rapidly create different design possibilities.

1. Create a form.
2. Manipulate the form shape.
Integrated Study Models

You can reference the conceptual design into a Revit project file, and continue to modify it. For example, a design can be used to provide important reference information for the building model. Conceptual designs that have been saved as Revit project files can continue to be developed in the conceptual design environment. See Switching between Conceptual Design and Project Environments on page 138.

Intelligent Sub-Components

Use conceptual designs as intelligent sub-components that are nested in other models. For example, when the conceptual design is referenced into a larger building model, it can be used in multiple locations and regenerated.

In the conceptual design environment, you can create parametric components that have the intelligence to adapt to a divided surface. See Rationalizing Surfaces on page 190.

The following table shows a parametric component that is added to a divided surface.

<table>
<thead>
<tr>
<th>Parametric component</th>
<th>Divided surface with parametric component</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
</tbody>
</table>

Conceptual Design Environment Interface

The tools for developing conceptual designs are all accessed from the ribbon, which changes depending on what is required to accomplish an action. For example, if you draw a rectangle and select it, Create Form becomes available. The Create Form tool allows you to instantly extrude the drawing and make it a solid or void form. See Ribbon on page 21.

If you then select a surface on the form, Divide Surface becomes available. This tool allows you to divide surface areas into buildable components. See Rationalizing Surfaces on page 190.

As you work on a conceptual design, you manipulate it directly in the drawing area, using several available controls. See Manipulating Forms on page 187.
Conceptual Massing Family Creation

As you create massing families in the conceptual design environment, many of the important tools are accessed from the Home tab and the Options Bar. See Creating Solid Forms on page 168.

<table>
<thead>
<tr>
<th>This panel...</th>
<th>Contains tools that let you...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection</td>
<td>complete an action in the drawing area.</td>
</tr>
<tr>
<td>Draw</td>
<td>draw the shapes used to create forms and surfaces.</td>
</tr>
<tr>
<td>Datum</td>
<td>create 3D levels, and reference geometry.</td>
</tr>
<tr>
<td>Model</td>
<td>load families into the conceptual design environment.</td>
</tr>
<tr>
<td>Dimension</td>
<td>dimension lines and set their type properties.</td>
</tr>
<tr>
<td>Work Plane</td>
<td>set and show a work plane.</td>
</tr>
<tr>
<td>Form</td>
<td>create a solid or void form from selected lines.</td>
</tr>
<tr>
<td>Family Editor</td>
<td>load a massing family file into a Revit project file.</td>
</tr>
<tr>
<td>Family Properties</td>
<td>set the family category, parameter, and family type rules.</td>
</tr>
</tbody>
</table>

In the conceptual design environment, when forms or lines are selected, the Options Bar displays useful options. The Options Bar displays options for:

- Selecting the work plane. See 3D Work Planes on page 145.
- Making a surface from the lines. See Surface Forms on page 173.
- Enabling 3D snapping. See 3D Snapping on page 141.
- creating a chain of lines
- setting the offset value
- setting the radius

Switching between Conceptual Design and Project Environments

When a concept is ready, you can switch to the Revit project environment. For example, you may want to perform area analyses, evaluate floors, or add curtain walls. Then, if the evaluation indicates that you need more floor area on a level, you can move the design back into the conceptual design environment to make the adjustment.

The following procedures define:

- how to move a massing family between the conceptual design and project environments, and how to edit it in the conceptual design environment.
how to move an in-place massing family between the conceptual design and project environments, and how to edit it in the conceptual design environment.

TIP An easy way to switch views is to click ➤ Recent Documents, and select one of the views you have used.

Related topics
- Loadable Families on page 687
- In-Place Elements on page 696
- Revit Families on page 677

Moving Loadable Massing Families

Use the following procedure to move a loadable massing family from the conceptual design into a project. See Loading the Current Family into a Project on page 690.

1. In the contextual design environment, click Home tab ➤ Family Editor panel ➤ Load into Project. The family loads into the Revit project.

   NOTE If the family has not been placed into the project before, drag the preview image to the desired location, and click to place it. If the family has been placed, you are prompted to specify whether you want to overwrite the existing version and its parameter values.

2. Analyze the mass. See Analyzing a Conceptual Design on page 1335.

   If necessary, return to the conceptual design environment and make adjustments to the mass, as explained in the following procedure.


Editing Loadable Massing Families

Use the following procedure to edit a massing family that has been loaded into the conceptual design environment from a project.

1. In the project, select the mass that needs to be adjusted.

2. Click Modify l Mass tab ➤ Mode panel ➤ Edit Family, and select Yes from the Revit dialog. The conceptual design environment opens.

3. Adjust the mass. For example, use the drag controls to make the mass larger.

4. Click Home tab ➤ Family Editor panel ➤ Load into Project. The project environment opens, and you can continue to develop the design.

Moving In-Place Massing Families

Use the following procedure to move an in-place massing family from the project environment to the conceptual design environment.

1. Open a Revit project.

2. Click Architect & Site tab ➤ Conceptual Mass panel ➤ In-Place Mass.

3. Name the in-place mass in the Name dialog. The conceptual design environment opens.

4. (Optional) Create a form or manipulate the mass in some way using the available tools. See Forms on page 167.

5. Click Modify | Form Element tab ➤ In-Place Editor panel ➤ Finish Mass. The mass moves back to the project environment.


Editing In-Place Massing Families

Depending on how you access it, the editing tools for in-place mass manipulation are different. For example, the shape handles used while editing an in-place mass in the project environment are 2D. However, when you edit the in-place mass in the conceptual design environment, 3D controls allow you to further modify the mass by moving vertices, surfaces, edges, and points.

Use the following procedure to edit an in-place massing family that has been moved to the conceptual design environment from a project.


1. Open a project file.

2. Click Architect & Site tab ➤ Conceptual Mass panel ➤ Show Mass.

3. Select the mass.

   **NOTE** 2D shape handles are available to modify the mass.

4. Click Modify | Mass tab ➤ Model panel ➤ Edit In-Place. The conceptual design environment opens.

   **NOTE** 3D controls are available to modify the mass.

5. Modify the mass.

6. Click Model In-Place Mass tab ➤ In-Place Editor panel ➤ Finish Mass.

Template Files for the Conceptual Design Environment

The conceptual design environment provides 3 standard family template files.

- **Mass.rft**
  This template is used to create new conceptual massing families.

  To create a new massing family, click ➤ New ➤ Conceptual Mass. In the dialog, select Mass.rft.
Curtain Panel Pattern Based.rft

This template is used to create a Pattern Component Families on page 201.

To create a new component family, click ➤ New ➤ Family, and select the template from New Family Select Template dialog.

Adaptive Component

This template is used to create new adaptive component on page 207 families.

Drawing in the Conceptual Design Environment

When you access the conceptual design environment, you can immediately start to draw a concept in 3D. Select a drawing tool, such as a line, and click anywhere in the drawing area to start creating a form. See Forms on page 167.

NOTE To draw in a 2D view, open it from the Project Browser.

Drawing Overview

You draw when you are placing lines and points to create a form. You can draw on the following elements:

- 3D levels
- 3D reference planes
- reference points

3D levels and 3D reference planes are automatically detected. They highlight in the drawing area as the cursor moves over them. Click to select one of these to set it as the active work plane.

To draw in the conceptual design environment

1 Click Home tab ➤ Draw panel ➤ Line.

NOTE If you want to draw a reference-based form, click Home tab ➤ Draw panel ➤ Reference before selecting a drawing tool. See Unconstrained and Referenced-Based Forms on page 171.

Several options become available on the Options Bar. You can set the placement plane, create a surface by drawing closed profiles, draw a chain of lines, and set an offset or radius value. See Conceptual Design Environment Interface on page 137.

2 Click Modify ➤ Lines ➤ Draw panel ➤ Draw on Face to draw on a surface, or click Modify ➤ Lines ➤ Draw panel ➤ Draw on Work Plane to draw on a work plane.

3 Click in the drawing area, and draw a line.

4 Click Home tab ➤ Select panel ➤ Modify.

3D Snapping

Use 3D snapping to ensure an exact location for placing points on a model vertex. For example, you can use 3D snapping to help place a surface on a mass that you can later use in the project as a floor or a roof. To enable 3D snapping, select 3D Snapping on the Options Bar.
To create a surface using 3D snapping

1 Create 2 forms. See Forms on page 167.

2 Click Home tab ➤ Draw panel ➤ Line.
3 On the Options Bar, select 3D snapping.
4 (Optional) On the Options Bar, select Chain and a named reference from the Placement Plane list.
5 Draw a line from one vertex to the another vertex.

**NOTE** The lines snap to the vertex.

6 Select the line and click Modify | Lines tab ➤ Home tab ➤ Create Form.

### 3D Aligning

Use the align tool in 3D view to align one or more elements with a selected element. See Aligning Elements on page 1479.

Select the align tool, click on the element to use as a target (vertex, edge, face, surface, point, line, arc, reference plane, or level) and click again to pick the element to align with the target.
Side view of unaligned elements

Aerial view of unaligned elements

Click to select element face to align
Conceptual Design Model Line Instance Properties

You can modify many line properties for a conceptual design massing family. Lines have instance properties because they are not yet part of a family. Select a line and modify properties on the Properties palette.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Work Plane</td>
<td>The work plane to which the line is related.</td>
</tr>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Visible</td>
<td>Turns visibility on or off, and accesses the Associate Family Parameter dialog for viewing existing parameters and adding new ones.</td>
</tr>
<tr>
<td>Visibility/Graphics Overrides</td>
<td>Sets the 3D views for the View Specific Display and sets the Detail Levels to Coarse, Medium, or Fine.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td>The actual line length.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Identity Data</td>
<td>Sets the line subcategory to Form [projection] or Void.</td>
</tr>
<tr>
<td>Subcategory</td>
<td>Changes the unconstrained reference line to a reference line. Displays the Associate Family Parameter dialog that lists existing parameters and adds new parameters.</td>
</tr>
<tr>
<td>Is Reference Line</td>
<td>Sets the reference type to Not a Reference, Weak Reference, or Strong Reference.</td>
</tr>
<tr>
<td>Other</td>
<td>The actual type of line.</td>
</tr>
</tbody>
</table>

Related topics
- Creating Solid Forms on page 168
- Creating Void Forms on page 170

### 3D Work Planes

When you select a drawing tool in the conceptual design environment, the available 3D work planes are automatically detected as the cursor passes over them in the drawing area. You can click to select one of these work planes, or explicitly set one from the named references listed in the Placement Plane list on the Options Bar. If you have several tiled 3D views, and you change the active work plane in one of the views, it changes for every 3D view.

**NOTE** Only named reference planes are available in the Placement Planes list.

**NOTE** You can directly align elements in 3D views without selecting the work plane. See Aligning Elements on page 1479.

When a drawing tool is selected, 2 tools become available:

- Draw on Face: allows a planar surface to be the work plane.
- Draw on Work Plane: allows a level or reference plane to be explicitly set as the work plane.
- Workplane Viewer: allows editing a temporary 2D view of the current active workplane.

### Setting and Showing Work Planes

Use the Set and Show tools to set an active work plane and to display or hide the work plane. See Setting the Work Plane on page 1517.

When the work plane is not automatically detected, use the Options Bar to explicitly set a work plane.
To set and show a work plane

1. Click Home tab ➤ Work Plane panel ➤ Set.
2. Move the cursor over the drawing area to highlight available work planes.
3. Click to select the work plane when it highlights.
4. Click Home tab ➤ Work Plane panel ➤ Show. The active work plane becomes visible.

To explicitly set a work plane

1. Click Home tab ➤ Work Plane panel ➤ Set.
2. On the Options Bar, select the work plane from the Placement Plane drop-down list. Alternatively, you can click a work plane in the drawing area.

**TIP** The Placement Plane list is also available when you select a new tool from the Draw panel.

See 3D Work Planes on page 145.

**Editing with the Workplane Viewer**

Use the Workplane Viewer to modify work plane dependent elements of your conceptual model. It is a temporary view that is not maintained in the Project Browser. This is useful for editing profiles in forms, sweeps, and swept blends.

1. Select a work plane or element profile.
2 Select Modify | <Element> tab ➤ Work Plane panel ➤ Workplane Viewer. The Workplane Viewer opens to the appropriate 2D view.

3 Edit the conceptual model as needed.
Modifications in either the project views or Workplane Viewer update other views in real time.

3D Levels

In the default view for the conceptual design environment, levels display in 3D as lines around the back side of a box.
When a level is selected, the following information displays in the drawing area:

- the level elevation
- the level name
- the distances between the selected level and its surrounding levels
- the drag handles used to change the level area

Creating 3D Levels

1. Click Home tab ➤ Datum panel ➤ Level.
2. Move the cursor in the drawing area until the desired elevation displays, and click to place the level. Continue to place levels, as needed.
3. Click Place Level tab ➤ Select panel ➤ Modify to stop placing levels.

Changing the Height Between 3D Levels

To change the height between levels, drag it a level the desired height, or explicitly set the height by typing in a new height value. When you move a middle level, the top and bottom levels remain in place, and the heights of the other levels adjust between them.

1. Click a 3D level. The level highlights and displays the dimension length value.
2. Click the value.
3. Enter a new dimension in the text box.

The 3D levels adjust so that their dimensions equal the parameter value.

Changing 3D Level Elevations

1. Click a 3D level.
2. Click an elevation value in the drawing area.
Enter a new elevation value in the text box.
Press Enter.

The new 3D level elevations are set.

**Changing 3D Level Names**

1. Click a 3D level. The level name displays.
2. Click the level name. It displays in a text box.
3. Enter a new name.
4. Press Enter, or click outside the text box.
5. (Optional) If you clicked away from the text box, click Yes in the Revit dialog if you would like to rename corresponding views.

The new level name displays on the level.

**Explicitly Changing the 3D Level Area**

1. Click a 3D level. The level bounding box highlights and displays circle-shaped drag handles.
2. Drag the bounding box to the desired size.

The new 3D level area is set.

**Switching between a 3D Level and its Corresponding View**

1. Double-click the circle at the end of a 3D level. The floor plan view displays.
2. Click (3D View) on the Quick Access toolbar. The 3D view displays.

**3D Level Graphics**

You can set the 3D levels to display a level head symbol by setting parameters through the Type Properties dialog. See **Level Properties** on page 97.

**To display a level head symbol**

1. Select a level.
2. Click Modify | Levels ➤ Properties panel ➤ Symbol Type Properties.
3. Select Symbol at End 1 Default.
4. Select Symbol at End 2 Default.
3D Level Type Properties

You can modify many properties for 3D levels. Select a level, and click Modify | Levels tab ➤ Properties panel ➤ Type Properties.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Line Weight</td>
<td>Controls the thickness of the level line by selecting from a list.</td>
</tr>
<tr>
<td>Color</td>
<td>Controls the color of the level line by setting the RGB value.</td>
</tr>
<tr>
<td>Line Pattern</td>
<td>Controls the level line pattern by selecting a value from a drop-down list.</td>
</tr>
<tr>
<td>Symbol</td>
<td>Sets the level head to none or Level Head - Target.</td>
</tr>
<tr>
<td>Symbol at End 1 Default</td>
<td>Sets the control at the beginning of the level line by selecting a check box.</td>
</tr>
<tr>
<td>Symbol at End 2 Default</td>
<td>Sets the control at the end of the level line by selecting a check box.</td>
</tr>
</tbody>
</table>

3D Level Instance Properties

You can set 3D level instance properties on the Properties palette.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Elevation</td>
<td>Sets the elevation for the level.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Sets the level name.</td>
</tr>
</tbody>
</table>

3D Reference Planes

Reference planes are displayed in the conceptual design environment in the 3D view. These reference planes can be edited as 3D elements. For example, you can pin the 3D reference plane so that it cannot be moved,
and you can unpin it and drag it to change its size. When selected, the name of the reference plane displays in the 3D view.

3D reference plane, pinned, and showing circular drag handles

Reference Points

A reference point is an element that specifies a location in the XYZ work space of the conceptual design environment. You place reference points to design and plot lines, splines, and forms. In the following example, 5 reference points have been placed to define the path of a spline.

There are 3 types of reference points:

- **Free**
- **Hosted on lines and surfaces**
- **Geometry-driving**

Free Points

Unlike driving points and hosted points, free points are reference points that are placed on a work plane. Free points display 3D controls when selected, are moveable anywhere within the 3D work space, and maintain their reference to the plane on which it was placed.

To place points on a work plane

1. Open a 3D view to work in if you are drawing in the Z axis; otherwise, open a floor plan view.
2 If you are working in a 3D view, select a work plane in the drawing area of the conceptual design environment.

3 Click Home tab ➤ Draw panel ➤ Point Element.

4 Click Modify | Lines ➤ Draw panel ➤ Draw on Work Plane.

5 If it was not selected in step 2, select a work plane from the Placement Plane list on the Options Bar.
   In 3D views, you can clear Relative to force the reference point along the bottom of vertical work planes.

6 Place points along the work plane.

7 When you are finished placing points, click Modify | Lines ➤ Select panel ➤ Modify.
   The free points can be repositioned if needed.

**Hosted Points**

Hosted points are reference points placed on an existing spline, line, edge, or surface. They are smaller than driving points, and each one provides its own work plane for adding further geometry perpendicular to its host. The hosted point will move with and can move along the host element.
Hosted points are placed along any of the following elements:

- Model lines and reference lines, such as lines, arcs, ellipses, and splines (Bezier and Hermite)
- Form element edges and surfaces, including planar, ruled, resolved, cylindrical, and Hermite.
- Joined form edges (geometry combination edges and surfaces)
- Family instances (edges and surfaces)

As explained in the following topics, the procedure for placing hosted points varies depending on what type of host element.

**NOTE** If a host is deleted, hosted points will be deleted as well.

### Placing Hosted Points along a Spline

Hosted points create work planes to add additional geometry that move with the host element.

1. Open a 3D view to work in if you are drawing in the Z axis; otherwise, open a floor plan view.
2. Click Home tab ➤ Draw panel ➤ Point Element.
3. Click Modify | Lines ➤ Draw panel ➤ Draw on Work Plane.
4. Select a work plane from the Placement Plane list on the Options Bar.
   - In 3D views, you can clear Relative to force the reference point along the bottom of vertical work planes.
5. Place hosted points along a spline.
6. Click Modify | Lines ➤ Select panel ➤ Modify when complete.

A hosted point can be repositioned along the spline if needed.

### Placing Hosted Points along an Edge or Surface

Surfaces and edges of forms can be used as an alternative work plane for placing hosted points.

1. Open a 3D view to work in if you are drawing in the Z axis; otherwise, open a floor plan view.
2. Click Home tab ➤ Draw panel ➤ Point Element.
3. Click Modify | Lines ➤ Draw panel ➤ Draw on Face.
4. In the drawing area, place the cursor over an edge or a surface, and click to place hosted points.
5. Click Modify | Lines ➤ Select panel ➤ Modify when complete.
Driving Points

Driving points are reference points that control the geometry of a dependent spline. Driving points are typically created automatically when free points are used to generate a line, curve, or spline.

When selected, driving points display 3D controls.

You create driving points from placed hosted points. See Placing Hosted Points along a Spline on page 154.

To place a driving point along a spline

1. Open a 3D view to work in if you are drawing in the Z-axis; otherwise, open a floor plan view.
2. Click Home tab ➤ Draw panel ➤ Point Element.
3. Place the hosted point along a spline.
4. Click Modify | Lines ➤ Select panel ➤ Modify.
5. Select the new hosted point.
6. On the Options Bar, click Make Point Driving.

The point is now a driving point and can be used to modify the geometry of the spline as needed.

Adaptive Placement Points

Adaptive points are modified reference points that are used when designing an adaptive component.

Adaptive points can be used for component placement (Placement Point) or as shape handles (Shape Handle Point). If the adaptive points are used for placement, they will be numbered in order in which they will be placed when the component is loaded.
You create adaptive points by modifying reference points. When a reference point is made adaptive, it is a placement point by default.

**To create adaptive points**

1. Place free, hosted, or driving reference points where the adaptive point is needed.
2. Select the reference point.

The point is now adaptive. To revert the point back to a reference point, select it and click Make Adaptive again.

Notice that adaptive points are numbered in the order of their placement. Click the point number in the drawing area to change it. It will convert to an editable text box. If you enter a number that is currently being used as an adaptive point, the points will swap their numbers. You can also change adaptive point numbers on the Properties palette.

Geometry drawn using these adaptive points results in an adaptive component.

**Adaptive Point Orientation**

You can specify the vertical orientation of an adaptive point on the Properties palette. Under the Adaptive Component section, specify the Orientation property to one of the following. The examples shown are created with the following component family.

The yellow line represents top to bottom orientation; the red line represents front to back orientation; and the blue line represents left to right orientation. Note this orientation is in the adaptive component family. Notice how it changes when the orientation is set for the mass or component project environment.

**By Host Reference.** Vertically orients from the host surface of the point.
**Vertical on Placement.** Vertically projects from the location of placement.

**Auto-calculate.** Generates optimal vertical projection for closed loop geometry.

**Orthogonal on Placement.** Vertically projects to the component or mass project environment. Orientation is from Top to Bottom, Front to Back, and Right to Left.

**Vertical in Family.** Vertically projects as placed in the component family.
Adaptive Shape Handle Points

You can use an adaptive point as a shape handle, meaning the point will not be used during placement but will be available to be moved after the component is placed. Select an adaptive point and on the Properties palette, select the Shape Handle Point (Adaptive) for the Adaptive Component Point.

Once the shape handle has been specified, you can constrain its movement. On the Properties palette, specify the Constrained property to None, Center (Left/Right), Center (Front/Back), or Ref. Level.

Related Topic
- Stitching Borders of Divided Surfaces on page 207

Plotting Lines from Reference Points

There are several methods to create splines that use driving reference points. The first, most common way is to use the supplied drawing tools, which allow you to freehand splines into the design. If a more coordinate driven model is required, plotting splines from points may be preferable, because it provides the parametric relationships required to build forms.

Creating a Line from Reference Points

1. Select Home tab ➤ Select panel ➤ Modify.
2. Select 2 points.
   These points can be free, hosted, or driving.

3. Click Modify | Reference Points tab ➤ Draw panel ➤ Line.
4. Click Modify | Reference Points tab ➤ Select panel ➤ Modify.

A line is created between the 2 points. The points maintain their reference type (hosted or driving) and will modify the line when moved. Free points become driving points for the line.

Creating a Spline from Reference Points

A spline can be created from existing points. These points can be free, hosted, or driving, and be part of an existing spline, edge, or surface.
1 Select Home tab ➤ Select panel ➤ Modify.
2 Select the points that will comprise the spline.

3 Click Modify | Reference Points tab ➤ Draw panel ➤ Spline Through Points.

4 Click Modify | Reference Points tab ➤ Select panel ➤ Modify.
A spline will be created from the selected points. Free points become driving points for the line.

**NOTE** The Spline Through Points tool on the Draw panel creates reference points as you freehand a spline.

**Rehosting Reference Points**

You can rehost placed reference points from and to splines, reference planes, edges, and surfaces.

1 Select the point to be rehosted.
2 Click Modify | Reference Points tab ➤ Rehost Point panel ➤ Pick New Host.
3 Select Modify | Reference Points tab ➤ Placement panel ➤ Draw on Face or Draw on Work Plane. If you are rehosting to a work plane, select a work plane from the Placement Plane list.
4 Click to specify the location on a new host in the drawing area.

**Rehosting Hosted Points**

When you rehost a hosted point, any geometry that is applied to its work plane will move with the point.
Rehosting a hosted point that is part of a spline

Rehosting a hosted point with splines applied to its work plane

Rehosting Driving Points

When you rehost a driving point, any geometry that is dependent on it will adjust accordingly. If the new host is a spline, the driving point will become a hosted point along that spline. The spline that originally hosted the point will remain modifiable and adjust to the new host position.

When rehosting to a different plane, the point remains driving, and it only changes position and work plane orientation.
Modifying Reference Point Properties

Reference points do not have type properties, but you can modify many instance properties for reference points, such as constraints, graphics, and dimension data. The specific parameters available depend on whether the selected points are free, driving, or hosted.

1 Select the point.
2 On the Properties palette, edit reference point instance parameters.
3 Click OK.

The following table lists the reference point instance properties.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Work Plane</td>
<td>For driving points only, the plane hosting the point.</td>
</tr>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Show Reference Planes</td>
<td>Specifies when the point's reference planes are visible: Always, When Selected, or Never.</td>
</tr>
<tr>
<td>Visibility/Graphics Overrides</td>
<td>Click Edit to display the Visibility/Graphics Overrides dialog for the reference point. See Visibility and Graphic Display in Project Views on page 801.</td>
</tr>
<tr>
<td>Show Normal Reference Plane Only</td>
<td>For hosted and driving reference points, specifies whether only the reference plane perpendicular to the geometry of the host will be visible.</td>
</tr>
<tr>
<td>Visible</td>
<td>When selected, the reference point will be visible when the mass is loaded into a project. It is also important to note that reference points must not be hidden by either Category or Visibility/ Graphics</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Override settings</td>
<td>Override settings if they are to be viewed in the project.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Driving Curve(s)</td>
<td>When selected, the reference point is a driving point that affects geometry. When cleared, this parameter is read-only, and the reference point becomes free or hosted.</td>
</tr>
<tr>
<td>Driven by Host</td>
<td>When selected, the reference point is a hosted point that moves along its hosted geometry. When cleared, this parameter is read-only and the reference point is free.</td>
</tr>
<tr>
<td>Hosted Parameter</td>
<td>A ratio value (0 to 1) of the location of the reference point along a line, curve, or surface edge. This applies only to hosted reference points. Note that for circles and ellipses, the supported values are 0-2 pi and for non-periodic curves, 0-1.</td>
</tr>
<tr>
<td>Hosted U Parameter</td>
<td>The location of the reference point along the U grid. The parameter is a distance in project units from the center of the surface. This applies only to reference points hosted on a surface.</td>
</tr>
<tr>
<td>Hosted V Parameter</td>
<td>The location of the reference point along the V grid. The parameter is a distance in project units of the surface. This applies only to reference points hosted on a surface.</td>
</tr>
<tr>
<td>Offset</td>
<td>The offset distance from the reference plane of the reference point. This applies only to driving and free reference points.</td>
</tr>
<tr>
<td><strong>Adaptive Component</strong></td>
<td></td>
</tr>
<tr>
<td>Point</td>
<td>Either Reference Point, Placement Point (Adaptive), or Shape Handle Point (Adaptive). Specifies the reference point type. Placement Point (Adaptive) moves freely in a 3D environment.</td>
</tr>
<tr>
<td>Number</td>
<td>Specifies the number which determines the sequence of point placement of a curtain panel by pattern or an adaptive component.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Show Placement Number</td>
<td>Either Never, When Selected, or Always. Specifies if and when the adaptive point number is displayed as annotation.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Either By Host Reference, Auto-calculate, Vertical on Placement, Orthogonal on Placement, or Vertical in Family. Specifies the reference plane for the vertical orientation of the adaptive point.</td>
</tr>
<tr>
<td>Constrained</td>
<td>Either None, Center (Left/Right), Center (Front/Back), or Ref. Level. Specifies the range in which an adaptive shape handle point is constrained.</td>
</tr>
<tr>
<td>Other</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>User-defined name for the point. The name will appear in a tooltip when the point is highlighted by the cursor.</td>
</tr>
</tbody>
</table>

**X-Ray Mode**

X-Ray mode displays the underlying geometric skeleton of a selected form. In this mode, surfaces become transparent, allowing you to more directly interact with the individual elements that comprise the form. This mode is useful when you need to understand how a form is constructed, or when you need to select a specific part of the form element for manipulation.

X-Ray mode is available for only one form at a time in all model views. For example, if several, tiled views are displayed and you use X-Ray mode for a form in one view, the other views display X-Ray mode as well. Likewise, switching X-Ray mode off in one view switches it off in all others.

**NOTE** X-Ray mode does not persist between sessions.

**Accessing X-Ray Mode**

1 Select a form. X-Ray becomes available on the ribbon. See Selecting Forms on page 172.

2 Click Modify | Form Element tab ➤ Form Element panel ➤ X-Ray.

The form displays its geometry and nodes.

**Display of Elements in X-Ray Mode**

When X-Ray mode is enabled, it displays profiles, explicit and implicit paths, form axes, and the control nodes that were used to create a form.

X-Ray mode displays the following:

- **Profiles**
  The closed loops you drew to define the shape of extrusions, lofts, revolves, and sweeps.
Explicit paths
The line you drew to define a sweep.

Implicit paths
The line that the system creates to construct extrusions and lofts.

Axis
The line you created to define the rotation of a revolve.

Control node
The points that the system creates on the path that hosts individual profiles.

Manipulating Forms in X-Ray Mode
1 Select a form.
2 Click Modify | Form Element tab ➤ Form Element panel ➤ X-Ray. The form displays in X-Ray mode.
3 Select elements of the form and the 3D control displays.

4 Drag the 3D control arrow.

NOTE You can also select and delete profiles, edges, and vertices in X-Ray mode.

Profiles

A profile is a single line, chain of connected lines, or closed loop that can be used to generate a form. Profiles can be manipulated to change the geometry of a form.

Profiles can be added to the following forms types:

- extrusions
- lofts
- sweeps

See Adding a Profile to a Form on page 182.

Related topics

- Locked Profiles on page 165
- Locking and Unlocking Profiles on page 166

Locked Profiles

Profiles can be locked or unlocked. When profiles are locked, the form maintains a relationship between the top and bottom profiles, and is limited in the way it can be manipulated. When profiles are unlocked, the form can be manipulated in any way.

NOTE If the work plane is vertical, the constrained profile relationship would be between the left and right.
With locked profiles, when you manipulate one profile, it affects the other, and therefore, the entire shape. For example, if the top profile is selected, and you lock it, all the profiles take on the shape of the top profile.

The following graphics display an unconstrained form that locks to the selected, bottom (square) profile.

<table>
<thead>
<tr>
<th>Unconstrained form</th>
<th>Resulting locked form</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Unconstrained form" /></td>
<td><img src="image2" alt="Resulting locked form" /></td>
</tr>
</tbody>
</table>

Click Modify | Form Element tab ➤ Form Element panel ➤ Lock Profiles to make the form-type unconstrained. See Unconstrained and Referenced-Based Forms on page 171.

With unconstrained profiles, the profile edge or vertex can be manipulated.

<table>
<thead>
<tr>
<th>Initial unconstrained form</th>
<th>Lower-right vertex modified</th>
<th>Resulting unconstrained form</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image3" alt="Initial unconstrained form" /></td>
<td><img src="image4" alt="Lower-right vertex modified" /></td>
<td><img src="image5" alt="Resulting unconstrained form" /></td>
</tr>
</tbody>
</table>

Related topic

- Locking and Unlocking Profiles on page 166

**Locking and Unlocking Profiles**

**To unlock a profile**

1. Select a locked form. See Selecting Forms on page 172.

2. Click Modify | Form Element tab ➤ Modify Form panel ➤ Unlock Profiles.

**To lock a profile**

1. Select a form. See Selecting Forms on page 172.

2. Click Modify | Form Element tab ➤ Modify Form Element ➤ Lock Profiles. The selected profile controls the locked shape.

   All the form profiles are locked, including any additional profiles that may have been added after a previous unlocking of the profile.

**NOTE** Use X-Ray mode to view a form’s profiles. See X-Ray Mode on page 163.
Forms

Start to explore a building concept by creating various geometric shapes, extrusions, sweeps, and lofts. Forms are always created by drawing lines, selecting them, and clicking Create Form. Use this tool to develop any surface, 3D solid, or void form, and then directly manipulate it using the 3D form manipulation controls.

Line types that can be used to make a form include the following:
- Lines
- Reference lines
- Line by points
- Imported lines
- Edges of other form
- Lines or edges from loaded families

Solid and Void Forms

The Create Form tool provides 2 tools:
- Solid Form
  The Solid Form tool is used to create solid geometry.

- Void Form
  The Void Form tool is used to create negative shapes (voids) that cut into solid geometry.

A void cut into a solid form
3D controls on a selected void.

A void dragged to the middle of the solid form (shown in X-Ray mode).

A void dragged from the middle of the solid form to a surface, and cutting the surface geometry.

Related topics
- Profiles on page 165
- X-Ray Mode on page 163

Creating Solid Forms

1 Click Home tab ➤ Draw panel, and select one of the drawing tools. See Drawing Overview on page 141.
2 Click in the drawing area, and draw a closed loop.
3 Click Home tab ➤ Select panel ➤ Modify.
4 Select the lines.
5 Click Modify | Form Element tab ➤ Form panel ➤ Create Form. A solid form extrusion is created.
6 (Optional) Click Modify | Form Element tab ➤ Form panel ➤ Void Form to convert this form to a void.
Cutting Geometry with Solids

You can use solid forms to cut other solids as you do with voids. However, when you use a solid, you remove the overlapping area and the abutting solids remain. Cutting solid geometry with solids is available with the following:

- Form elements
- Forms with divided surfaces
- Forms with geometric combinations
- Family instances inside of the massing editor.

To cut a solid with a solid form

1. Create two adjacent solids.

2. Click Modify tab ➤ Geometry panel ➤ Cut.

3. Select the solid form to be cut.

4. Select the cutting solid form.
The solids cut accordingly and can be edited with form editing tools while maintaining the cut relationship.

NOTE When a solid cut geometry mass is imported into a project, you cannot interact with the individual solids. Similarly, if the solid cut geometry had levels applied to it, they will not be recognized in the project environment.

Creating Void Forms

1. Click Home tab ➤ Draw panel, and select one of the drawing tools. See Drawing Overview on page 141.
2. Click in the drawing area, and draw a closed loop.
3. Click Home tab ➤ Select panel ➤ Modify.
4. Select the lines.
5. Click Modify | Form Element tab ➤ Form panel ➤ Create Form drop-down ➤ Void Form. A void form extrusion is created.
6. (Optional) Click Modify | Form Element tab ➤ Form panel ➤ Solid Form to convert this form to a solid.

Related Topic
- Cut Geometry on page 1434

Accessing Create Form Tool

The Create Form tool is available in the mass family template (Mass.rft), the curtain panel pattern based family template (Curtain Panel Pattern Based.rft), and through the In-Place Mass tool in a project. See
Creating an In-Place Mass on page 1332. The access to the Create Form tool varies depending on whether the conceptual design environment is accessed through the family mass template (RFT) or a project file (RVT).

To access Create Form from a mass family template (RFT)

1. Click Home tab ➤ Draw panel, and click one of the drawing tools to sketch any type of line.
   
   **NOTE** You can also create a line by points. See Reference Points on page 152.

2. Draw the line and select it.

The Create Form tool becomes available on Modify | Form Element tab ➤ Form panel. See Creating Solid Forms on page 168.

To access Create Form from a project file (RVT)

1. Click Architect & Site tab ➤ Conceptual Mass panel ➤ In-Place Mass.

2. Name the in-place mass in the Name dialog. The conceptual design environment tools become available.


4. Click Modify | Form Element tab ➤ In-Place Editor panel ➤ Finish Mass.

Unconstrained and Referenced-Based Forms

Depending on the tools used to create them, 2 types of form are created in the conceptual design environment.

- unconstrained form
- reference-based form

The behavior of these 2 forms may differ when they are modified.

<table>
<thead>
<tr>
<th>Unconstrained form</th>
<th>Reference-based form</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displays a solid line when highlighted.</td>
<td>Displays a dashed line when highlighted.</td>
</tr>
<tr>
<td>Created when there is no need to rely on another form or type of reference.</td>
<td>Created when there is a need for a parametric relationship between the form and other geometry or references.</td>
</tr>
<tr>
<td>Created using any line in the Draw panel. Click Home tab ➤ Draw panel ➤ Line.</td>
<td>Created using reference lines, reference points, or any part of another form. Click Home tab ➤ Draw panel ➤ Reference.</td>
</tr>
</tbody>
</table>
Unconstrained form | Reference-based form
---|---
Not dependent on other objects. | Dependent on its references. When its dependent reference changes, the reference-based form changes.
Profiles are unlocked by default. | Profiles are locked by default for extrusions and sweeps.
The edges, surfaces, and vertices can be edited directly. | Edited by directly editing the reference element. For example, select a reference line and drag it using the 3D controls.

Related topic
- Form Types on page 173

**Converting Reference-based Forms to Unconstrained Forms**

1. Select the reference lines on a reference-based form.

The form is unconstrained.

Related topics
- Creating Solid Forms on page 168
- Creating Void Forms on page 170

**Selecting Forms**

You can select an entire form, or any of its edges, surface or vertices. Move the cursor over any form element to highlight it, and either click to select it, or press Tab to highlight all the form's elements, and then click to select the entire form. Pressing Tab repeatedly cycles through the selectable elements, and you can click to select the desired one when it highlights.

The following graphics display what can be selected on a form.

<table>
<thead>
<tr>
<th>Form Element</th>
<th>Selected Form Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edge</td>
<td></td>
</tr>
<tr>
<td>Form Element</td>
<td>Selected Form Element</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>Surface</td>
<td>![Surface Diagram]</td>
</tr>
<tr>
<td>Vertex</td>
<td>![Vertex Diagram]</td>
</tr>
<tr>
<td>Entire form</td>
<td>![Entire Form Diagram]</td>
</tr>
</tbody>
</table>

**Related topics**

- [Manipulating Forms](#) on page 187
- [Manipulating Forms in X-Ray Mode](#) on page 164

**Form Types**

The conceptual design environment lets you create many types of forms that are useful for developing a design concept. Every form type is created by accessing the Create Form tool. See [Accessing Create Form Tool](#) on page 170.

**Surface Forms**

In the conceptual design environment, surfaces are created from open lines or edges, rather than from closed profiles.

**NOTE** If the 2 lines are parallel, the result is a 2D surface that can be used to stitch together other models. See [3D Snapping](#) on page 141.

**To create a surface using a line**

1. Select a work plane for the surface. See [Setting and Showing Work Planes](#) on page 145.
2. Click Home tab ➤ Draw panel ➤ Line.
3. Draw a line on the work plane.
4. Select another work plane.
5 Draw a line on this work plane.
6 Select the lines.
7 Click Create Form.

To create a surface using the Options Bar

1 Click Home tab ➤ Draw panel ➤ Line.
2 On the Options Bar, select Make surface from closed loops.
3 (Optional) On the Options Bar, select Chain to create a chain of lines.
4 Draw a closed profile.

The surface is automatically created.

Related topics
- Unconstrained and Referenced-Based Forms on page 171
- Creating Solid Forms on page 168
- Creating Void Forms on page 170

Extrusions

In the conceptual design environment, an extrusion is created from closed profiles, or the surfaces derived from closed profiles.

1 Draw a closed profile, for example, using Home tab ➤ Draw panel ➤ (Rectangle).

2 Select the profile.

3 Click Modify | Form Element tab ➤ Create Form.

You can change the dimension of an extrusion by using the 3D drag controls or editing the temporary dimension in the drawing area. See Dimensioning Forms on page 184.
Related topics

- Creating Solid Forms on page 168
- Creating Void Forms on page 170

Revolves

In the conceptual design environment, a revolve is created from a line and a 2D shape that are drawn on the same work plane. The line defines the axis around which the shape is revolved to create a 3D form.

**NOTE** In Step 2, you can create a surface revolve using lines that do not form a closed loop.

1. Draw a line on a work plane.
2. Draw a closed profile on the same work plane next to the line.
3. Select the line and the closed profile.

![Diagram of revolve process]

4. Select Create Form. See Accessing Create Form Tool on page 170.

To open a revolve

1. **TIP** Using X-Ray mode helps identify the edge.

   Select the outside edge of the revolve profile.
2 Drag the orange control arrow to a new position.

Related topic
- Creating Solid Forms on page 168

Sweeps

In the conceptual design environment, a sweep is created from a 2D profile that is swept along a path. The profile consists of linework drawn perpendicular to the line or series of lines that define the path. You create a sweep by selecting the profile and the path, and then clicking Create Form.

Multi-segmented paths can be used to create a sweep if the profile is formed from closed loops. If the profile is not closed, it does not sweep along a multi-segment path. If the path is a single-line segment, use an open profile to create the sweep.

To create a multi-segmented sweep

1. Click Home tab ➤ Draw panel ➤ \( \rightarrow \) Line, and draw a series of connected lines to form a path.

2. Click Home tab ➤ Draw panel ➤ \( \bullet \) Point Element and click along the path to place a reference point.

3. Select the reference point. The work plane displays.
4 Draw a closed profile on the work plane.

5 Select the line and profiles.

6 Click Modify | Lines tab ➤ Form panel ➤ Create Form. See Accessing Create Form Tool on page 170.

Related topics
- Creating Solid Forms on page 168
- Creating Void Forms on page 170

Swept Blends

In the conceptual design environment, a swept blend is created from two or more 2D profiles that are swept along a path. The profile consists of linework drawn perpendicular to the line or series of lines that define the path.

To create a swept blend.

1 Using the tools on the Home tab ➤ Draw panel, draw a series of connected lines to form a path.
2 Click Home tab ➤ Draw panel ➤ 🟢 Point Element and place reference points for the swept blend profiles along the path.

3 Select a reference point and draw a closed profile on its work plane.

4 Similarly, draw profiles for the remaining reference points.
5 Select the path and profiles.

6 Click Modify | Lines tab ➤ Form panel ➤ Create Form. See Accessing Create Form Tool on page 170.

Related topics
- Creating Solid Forms on page 168
- Creating Void Forms on page 170

Lofts

A loft is a form that blends 2 profiles located on separate work planes.

**NOTE** Profiles can be open or closed when making lofted geometry.

To create a solid loft

1 Draw a closed profile on a work plane.
2 Click a reference plane or a level to select a different work plane.
3 Draw a new closed profile.
4 Click a reference plane or a level, to select a different work plane.
5 Draw a closed profile on the third reference plane.
6 Select all 3 profiles.
7 Click Create Form. See Accessing Create Form Tool on page 170.

Related topics
- Creating Solid Forms on page 168
- Creating Void Forms on page 170

Modifying Forms

Forms can be modified directly by using the 3D control arrows, and by adding, deleting, and modifying edges and profiles.

When a form is selected in the conceptual design environment, the following modification tools are available.

<table>
<thead>
<tr>
<th>Panel</th>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection</td>
<td>Modify</td>
<td>Complete an action in the drawing area.</td>
</tr>
<tr>
<td>Draw</td>
<td>Line tools</td>
<td>Create unconstrained and reference-based forms. See Unconstrained and Referenced-Based Forms on page 171.</td>
</tr>
<tr>
<td>Element</td>
<td>Element Properties</td>
<td>Defines instance and type properties.</td>
</tr>
<tr>
<td>Mode</td>
<td>Edit Profile</td>
<td>Modifies the sketch on which the form is based. See Modifying Form Profiles on page 183.</td>
</tr>
<tr>
<td>Form</td>
<td>Create Form</td>
<td>Creates solid forms. See Accessing Create Form Tool on page 170.</td>
</tr>
<tr>
<td>Panel</td>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>--------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Solid Form</td>
<td>Creates a solid form or changes a void form to a solid. See Creating Solid Forms on page 168.</td>
</tr>
<tr>
<td></td>
<td>Void Form</td>
<td>Creates a void form or changes a solid form to a void. Creating Void Forms on page 170.</td>
</tr>
<tr>
<td>Divide</td>
<td>Divide Surface</td>
<td>Divides a surface. See Rationalizing Surfaces on page 190.</td>
</tr>
<tr>
<td>Form Element</td>
<td>X-Ray</td>
<td>Shows/hides the underlying geometric skeleton of a form, making it easier to select form elements. See X-Ray Mode on page 163.</td>
</tr>
<tr>
<td></td>
<td>Add Edge</td>
<td>Adds edges to a form. See Adding an Edge to a Form on page 182.</td>
</tr>
<tr>
<td></td>
<td>Add Profile</td>
<td>Adds profiles to a form. See Adding a Profile to a Form on page 182.</td>
</tr>
<tr>
<td></td>
<td>Dissolve</td>
<td>Removes the surfaces of a form. See Dissolving Form Elements on page 183.</td>
</tr>
<tr>
<td></td>
<td>Lock Profiles</td>
<td>Keeps the form locked to the top and bottom profiles. See Profiles on page 165.</td>
</tr>
<tr>
<td></td>
<td>Unlock Profiles</td>
<td>Unlocks the form. See Profiles on page 165.</td>
</tr>
<tr>
<td></td>
<td>Pick New Host</td>
<td>Moves the form to a new host. See Rehosting Forms on page 184.</td>
</tr>
</tbody>
</table>

Related topics

- Manipulating Forms on page 187
- Selecting Forms on page 172

**Adding Elements to a Form**

Forms can be further modified by adding edges and profiles. The Add Edge tool is used to add edges to form elements.
The Add Profile tool is used to add profiles to form elements. Profiles can be manipulated to change the form geometry. See Profiles on page 165.

Adding an Edge to a Form

1 Select a form.

2 Click Modify | Form Element tab ➤ Modify Form panel ➤ Add Edge

3 Move the cursor over the form to display a preview image of the edge, and click to add the edge. The edge displays on the form.

4 Select the edge.

The 3D controls become available.

5 Click a 3D control arrow to manipulate the edge. The form geometry changes.

Adding a Profile to a Form

1 Select a form.

2 Click Modify | Form Element tab ➤ Form Element panel ➤ Add Profile.

3 Move the cursor over the form to preview the position the profile.

4 Click to place the profile.
Modifying Form Profiles

You can edit profiles or paths from which forms have been created.

1 Select a profile, path, or surface to edit. You can select and edit. In some cases, such as in sweeps or swept blend, this may be easier in X-Ray Mode on page 163.

2 Click Modify | Form Element ➤ Mode panel ➤ Edit Profile. The drawing area will enter a sketching mode. However, forms made from reference geometry will not have a sketch mode and will require direct modification to the reference geometry.

3 Use the drawing tools on the Modify | Form Element > Edit Profile tab to edit the profile. Particularly useful is the Workplane Viewer.

NOTE When editing locked profiles, only the main profile will be editable. Typically this is the profile hosted by a reference level or plane.

4 Click Finish Edit Mode.

Dissolving Form Elements

You can dissolve a form to its underlying editable curves. Once the curves you can recreate the form.

To dissolve a form

1 Select the form.

2 Click Modify | Form Element tab ➤ Form Element panel ➤ Dissolve.

The form drops all surfaces and leaves behind profile curves and paths.

3 Edit curves and paths as needed.
Deleting Form Elements

Surfaces, edges, and vertices can be deleted from a form. You can use Ctrl to select elements separately, or draw a pick box to select all the form elements.

NOTE Be careful not to select work planes when using a pick box, or they will be deleted.

1. Select a form.

NOTE Using X-Ray helps identify the form elements. See X-Ray Mode on page 163.

2. Move the cursor over the form, and press Tab to highlight the form elements.
3. Click to select the element.
4. Click Modify | Form Element tab ➤ Modify panel ➤ Delete.

Rehosting Forms

Forms are hosted by the work plane, level, or surface on which they were drawn. You can view the hosted work plane by clicking Home tab ➤ Work Plane panel ➤ Show.

To rehost a form

1. Select a form.
2. Click Modify | Form Element tab ➤ Form Element panel ➤ Pick New Host.
3. Select a host from the Placement Plane list on the Options Bar. The host highlights in the drawing area, and the cursor is a purple circle shape.
4. Click to rehost the form to the work plane you selected.

Related topic

■ 3D Work Planes on page 145

Dimensioning Forms

The dimensions for a form can be set in a number of ways:

■ Use 3D direct manipulation controls.
  Drag the 3D control arrows on a form until the dimension meets the required value. You can select an edge, point, or vertex to enable the 3D controls. Drag a 3D control arrow. As you drag the arrow, element dimension feedback is provided in the drawing area. See Manipulating Forms on page 187.

■ Set temporary dimensions directly in the drawing area.
  Temporary dimensions display on the surface of a selected form. You can make this dimension permanent by double-clicking the dimension and pressing Enter.

■ Select Show Dimensions on the Options Bar.

■ Set constraints on the Model Lines Properties palette. See Conceptual Design Model Line Instance Properties on page 144.
Labeled Dimensions

In the conceptual design environment, you can label dimensions by assigning parameters to them, and then use direct manipulation to explore design variations. As a labeled dimension is manipulated, all its related geometry adjusts, and the dimension labels change to reflect their new values. The dimension labels change dynamically as they are manipulated in the drawing area.

As the labeled dimension values change, the family type parameter values also update in the Family Types dialog, where you can enter formulas that define relationships between dimensions as shown.

For example, drag a labeled dimension to a new position. All the lines that are associated by formulas move with respect to their parameter settings. For example if parameter \( B = \frac{A}{2} \), the value of \( B \) is always half of the value of parameter \( A \). If the value of \( B \) changes to 8, the value of \( A \) changes to 16. You can see the parameter values change in the drawing area when you directly manipulate these lines.

The formulas assigned to a parameter display in the Label drop-down list on the Options Bar. These can be selected and applied to the labeled dimensions. When applied to a dimension, the formula displays as the new label in the drawing area.

NOTE To display all the associated dimensions, on the Options Bar, click Related Dimensions, or select a parameter in the Family Type dialog.

Labeling Dimensions

1. Select a line in the drawing area. The line’s temporary dimensions display.
2. Click (Make this temporary dimension permanent) to create a permanent dimension.
3. Click the dimension.
4. On the Options Bar, select <Add parameter> from the Label drop-down list.
5. In the Parameter Properties dialog, for Name, enter a name.
6. For Group parameter under, select Dimensions.
7. Click OK.

Associating Parameters

1. Click a dimension in the drawing area.
2. Click Modify | Dimensions tab ➤ Properties panel ➤ Family Types.
3 Under Dimensions, enter a formula for one of the parameters in the Formula column.
4 Click OK.

### Displaying Parameter Values
1 Click a dimension in the drawing area.
2 On the Options Bar, select a desired parameter value from the Label drop-down list.

### Removing Parameter Values
1 Click a dimension in the drawing area.
2 On the Options Bar, select <None> from the Label drop-down list.

### Locking Labeled Dimensions
You can maintain the parametric relationships between labeled dimensions by locking them. To lock a dimension directly in the drawing area, click next to the dimension.

When a labeled dimension is locked, all of the associated parameters also lock. This means that as the dimensions are moved in the drawing area, the associated parameters are constrained and the dimension value is preserved.

**NOTE** Locked dimensions and their associated parameters cannot be changed in the drawing area. Use the Lock column in the Family Types dialog to change them.

When a labeled dimension is unlocked, all of the referenced geometry unlocks and is unconstrained.

**To lock a labeled dimension from the Family Types dialog**
1 Click a dimension in the drawing area.
2 Click Modify | Dimensions tab ➤ Properties panel ➤ Family Types.
3 Select Lock to constrain a parameter.

### Referencing Imported Geometry
Imported ACIS solid and surface geometry can be referenced in the conceptual design environment to create a form, divide a surface, or host point elements.

The following table describes the available conceptual design environment tools that can reference imported ACIS geometry.

<table>
<thead>
<tr>
<th>ACIS Geometry Type</th>
<th>Create Form Tool</th>
<th>Divide Surface Tool</th>
<th>Hosted Reference Point</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edge</td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Curve</td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Surface</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
</tbody>
</table>

**NOTE** Unsupported references, such as a polymesh, cannot be used.
Conceptual Design Environment Model Instance Properties

To view and modify the following instance properties of a selected form, use the Properties palette. See Model Line Instance Properties on page 571.

In the conceptual design environment, forms can be specified as solid or void.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Solid/Void</td>
<td>Specifies whether the form is a solid or a void.</td>
</tr>
</tbody>
</table>

Manipulating Forms

Every reference point, surface, edge, vertex, or point in an unconstrained form has a 3D control that displays when it is selected. Use this control to directly manipulate a form by dragging it along the axes or planes defined by the local or global coordinate systems.

3D controls let you:

- switch between local and global coordinates.
- directly manipulate a form.

You can drag the 3D control arrows to adjust a form to a suitable size or location. The arrows are oriented relative to the selected form, but you can also switch this orientation between a global XYZ, and local, coordinate system by pressing the Spacebar.

Related topics

- Modifying Forms on page 180
- Dimensioning Forms on page 184
- Solid and Void Forms on page 167
### Coordinate Systems

A form’s global coordinate system is based on the North, East, South, and West coordinates of the ViewCube. When a form is reoriented and has a different relationship with the global coordinate system, it is on the local coordinate system.

<table>
<thead>
<tr>
<th>Use the...</th>
<th>To drag the object...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue arrow</td>
<td>along the global Z axis</td>
</tr>
<tr>
<td>Red arrow</td>
<td>along the global Y axis</td>
</tr>
<tr>
<td>Green arrow</td>
<td>along the global X axis</td>
</tr>
<tr>
<td>Red planar control</td>
<td>in the Y plane</td>
</tr>
<tr>
<td>Green planar control</td>
<td>in the X plane</td>
</tr>
<tr>
<td>Orange arrow</td>
<td>along a local axis</td>
</tr>
<tr>
<td>Orange planar control</td>
<td>in a local plane</td>
</tr>
</tbody>
</table>

The following graphic displays a sweep that was manipulated by dragging the control arrows to change its shape.

<table>
<thead>
<tr>
<th>Original Sweep</th>
<th>First Manipulated Sweep</th>
<th>Second Manipulated Sweep</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Original Sweep" /></td>
<td><img src="image2" alt="First Manipulated Sweep" /></td>
<td><img src="image3" alt="Second Manipulated Sweep" /></td>
</tr>
</tbody>
</table>

When forms are defined by the local coordinate system, the 3D form controls display in orange color. Only the coordinates that change to the local coordinate system display in orange color. For example, if you rotate a cube by 15 degrees, the X and Y arrows display in orange, but the Z arrow remains blue because it still has the same global Z coordinate value.

**Related topics**

- Manipulating Forms on page 187
- Sweeps on page 176
- Creating Solid Forms on page 168
- Creating Void Forms on page 170

### Manipulating Joined Forms

In the conceptual design environment, the surfaces, edges, or vertices of joined forms can be modified using the 3D controls.
To join forms

1. Click Modify | Form Element tab ➤ Geometry panel ➤ Join.
2. Click the first form.
3. Click the second form.

The form is joined. See Joining Geometry on page 1506.

To manipulate joined forms

1. Click a joined surface, edge or vertex. The 3D control arrows display.
2. Drag a 3D control arrow in any direction.

The joined form remains as one unit.

Related topics
- Manipulating Forms on page 187
- Selecting Forms on page 172
Rationalizing Surfaces

You can divide a range of surfaces (planar, ruled surfaces, revolved surfaces, and double-curved surfaces) to rationalize the surface into parametric buildable components.

Use the following work flow to rationalize a surface.

1. Divide the surface. See Dividing a Surface with UV Grids on page 190.
2. Pattern the surface. See Patterning Surfaces on page 197.
3. The surface is divided with UV grids by default. Apply a pattern component family. See Pattern Component Families on page 201.

Dividing a Surface with UV Grids

1. Select the surface.
2. Click Modify | Form Element tab ➤ Divide panel ➤ Divide Surface.
3. Adjust the spacing of the divided surface on the Options Bar. See Modifying the Spacing of UV Grids on Divided Surfaces on page 192.

NOTE When dividing the surface, remember that applied patterns have footprint requirements that may affect how many divisions a surface needs in the conceptual design. See Patterning Surfaces on page 197.

4. Adjustments can be made with the Face Manager. You can adjust UV grid spacing, rotation, and grid positioning. See Adjusting UV Grids with the Face Manager on page 192.

Understanding UV Grids

A surface can be divided by UV grids (the natural grid division of the surface). Patterns may be later applied to the divided surface. See Patterning Surfaces on page 197.
The UV grid acts as a guide in patterning the surface. Manipulating the divided surface also manipulates the parametrically dependant patterns and components. Certain parameters of the divided surface can be edited in the drawing area of the conceptual design environment.

Locations in 3D space are based on the XYZ coordinate system. This system can be applied globally to the modeling space or to a work plane.

Since surfaces are not necessarily planar, the UVW coordinate system is used to plot location. This maps a grid adjusting for the contours of a non-planar surface or form. UV grids, as used in the conceptual design environment, are comparable to XY grids.

The default division of the surface is by number: 12x12 for imperial units and 10x10 for metric units.

**Enabling and Disabling UV Grids**

The UV grids are independent of one another and can be turned on and off as needed. By default, both U and V grids are on when a surface is initially divided.

**U grids**

Click Modify | Divided Surface tab ➤ UV Grids and Intersects panel ➤ U Grid. Click again to enable.
V grids

Click Modify | Divided Surface tab ➤ UV Grids and Intersects panel ➤ V Grid. Click again to enable.

Modifying the Spacing of UV Grids on Divided Surfaces

Surfaces can be divided by a number of divisions or by distances between divisions.

When the divided surface is selected, the Options Bar displays settings for both the U and V grids. These can be set independently of one another.

Spacing grids by a specific number of divisions

Select Number and enter the number of divisions that will distribute evenly along the surface.

NOTE The number of divisions can also be set on the Properties palette or the Face Manager. See Pattern Element Instance Properties on page 213 and Adjusting UV Grids with the Face Manager on page 192.

Spacing grids by a defined distance

Select Distance and enter the distance between grids along the divided surface. The Distance drop-down list also allows for a minimum or maximum distance, rather than an absolute distance.

NOTE Spacing can also be set on the Properties palette or the Face Manager. See Pattern Element Instance Properties on page 213 and Adjusting UV Grids with the Face Manager on page 192.

Adjusting UV Grids with the Face Manager

The UV grids of the divided surface can be adjusted on the Properties palette (see Pattern Element Instance Properties on page 213) or the Face Manager. The Face Manager is an editing mode accessed by clicking the Face Manager icon at the center of the 3D Control Widget. To see this icon, select the divided surface.
Once selected, UV grid editing controls display on the surface.

**Editing Spacing between Divisions**

Spacing for the distance and number of divisions of both U and V grids are located at the ends of their respective belts. These parameters are the same as the spacing grids parameters previously seen on the Options Bar. See Modifying the Spacing of UV Grids on Divided Surfaces on page 192.

To change these, click on them and type new parameters.

**Rotating UV Grids**

You can rotate the direction of each or both UV grids. Rotation angle controls are located at the ends of their respective belts. Changing the values of these parameters will rotate the grids.

To change the rotation of a grid, click on the value field and type a new rotation angle.
To rotate the direction of both grids, click on the angle value field located at the intersection of the UV grids and type a new rotation angle.

Adjusting UV Grid Belts

Each belt represents the line along the surface from which the distance between grids is measured. The distance is measured by chords, not curve lengths. You can move the belts along their respective grids to adjust where the distance is measured. Click and drag the belt handles to reposition them.

NOTE Clicking a belt handle will slightly nudge the belt position in the respective direction of the handle.

The following image shows repositioning of one belt along the U grid.
Justifying UV Grids to the Surface Borders

The Grid Justification tool defines the origin of the grids on the surface. Both U and V grids are centered in a surface by default, but each can be repositioned to the left and right, as well as top and bottom, resulting in the following 9 possible locations for grid justification.

<table>
<thead>
<tr>
<th>Top Left</th>
<th>Top Center</th>
<th>Top Right</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Center</td>
<td>Center</td>
<td>Right Center</td>
</tr>
<tr>
<td>Bottom Left</td>
<td>Bottom Center</td>
<td>Bottom Right</td>
</tr>
</tbody>
</table>

The Grid Justification tool will snap to any of these locations on a surface. In the following illustration, notice how the positioning of the Grid Justification tool adjusts the location of the UV grids.
Dividing a Surface by Intersection

You can also divide a surface by using intersecting 3D levels, reference planes, and curves drawn on reference planes.

1. Add the necessary 3D Levels on page 148 and 3D Reference Planes on page 151. If necessary, draw curves on work planes parallel to the form.
2. Select the surface to be intersected.
3. Click Modify | Form ➤ Divide panel ➤ Divide Surface.
4. Disable the UV Grids.
5. Click Modify | Form ➤ UV Grids and Intersects panel ➤ Intersects.
6. Select all levels, reference planes, and curves sketched on reference planes that will divide the surface.

(Optional) Rather than manually selecting levels and planes, you can select them from a list of named references. Click Modify | Form ➤ UV Grids and Intersects panel ➤ Intersects List. In the Intersecting Named References dialog, select the levels and reference planes that will intersect and divide your surface.

**NOTE** Curves drawn for reference will do not display in this list because they are unnamed elements.
Removing levels or planes will remove the corresponding divisions on the surface. You can then pattern and apply pattern components to the resulting surface division.

**Patterning Surfaces**

After a surface is divided, it can be patterned. Still part of the conceptual design phase of the project, this phase enables quick preview and editing of patterned surfaces. Unlike the UV Grids, the pattern lines are
straight segments. A collection of patterns is available in the Type Selector on page 35 and can be applied onto a selected divided surface.

Patterns are family-based and can be graphically previewed in the Type Selector on page 35 before being applied.

To pattern a surface

1. Select a divided surface.
2. In the Type Selector on page 35, select the desired pattern.

Note that the divided surface is hidden when a pattern is applied. To display it again, click Modify | Divided Surface tab ➤ Surface Representation panel ➤ Surface and select the checkboxes for Surface, Nodes and UV Grids and Intersects.

Patterns become part of the surface and, depending on their shape, will require a specific number of surface cells when applied. This is an important consideration when planning divisions and patterns for component design. See Pattern Component Families on page 201.

The patterns available are as follows.

<table>
<thead>
<tr>
<th>Pattern name</th>
<th>Required number of surface cells</th>
<th>Pattern layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Pattern</td>
<td>0</td>
<td>Pattern is removed from the divided surface.</td>
</tr>
<tr>
<td>1/2 Step</td>
<td>2 (1 x 2)</td>
<td></td>
</tr>
<tr>
<td>1/3 Step</td>
<td>3 (1 x 3)</td>
<td></td>
</tr>
<tr>
<td>Pattern name</td>
<td>Required number of surface cells</td>
<td>Pattern layout</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Arrows</td>
<td>12 (3 x 4)</td>
<td><img src="image" alt="Arrows" /></td>
</tr>
<tr>
<td>Hexagon</td>
<td>6 (2 x 3)</td>
<td><img src="image" alt="Hexagon" /></td>
</tr>
<tr>
<td>Octagon</td>
<td>9 (3 x 3)</td>
<td><img src="image" alt="Octagon" /></td>
</tr>
<tr>
<td>Octagon Rotate</td>
<td>9 (3 x 3)</td>
<td><img src="image" alt="Octagon Rotate" /></td>
</tr>
<tr>
<td>Rectangle</td>
<td>1 (1 x 1)</td>
<td><img src="image" alt="Rectangle" /></td>
</tr>
<tr>
<td>Rectangle Checkerboard</td>
<td>1 (1 x 1)</td>
<td><img src="image" alt="Rectangle Checkerboard" /></td>
</tr>
<tr>
<td>Rhomboid</td>
<td>4 (2 x 2)</td>
<td><img src="image" alt="Rhomboid" /></td>
</tr>
<tr>
<td>Pattern name</td>
<td>Required number of surface cells</td>
<td>Pattern layout</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>----------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Rhomboid Checkerboard</td>
<td>4 (2 x 2)</td>
<td></td>
</tr>
<tr>
<td>Triangle (bent)</td>
<td>2 (1 x 2)</td>
<td></td>
</tr>
<tr>
<td>Triangle (flat)</td>
<td>2 (1 x 2)</td>
<td></td>
</tr>
<tr>
<td>Triangle Checkerboard (bent)</td>
<td>2 (1 x 2)</td>
<td></td>
</tr>
<tr>
<td>Triangle Checkerboard (flat)</td>
<td>2 (1 x 2)</td>
<td></td>
</tr>
<tr>
<td>Triangle Step (bent)</td>
<td>2 (1 x 2)</td>
<td></td>
</tr>
<tr>
<td>Zig Zag</td>
<td>2 (1 x 2)</td>
<td></td>
</tr>
</tbody>
</table>

**Editing the Patterned Surface**

Modify the patterned surface by changing patterns, adjusting properties with the Face Manager, and changing its border tiling.

**Changing Patterns**

Select the divided surface, and then select a new pattern from the Type Selector on page 35 drop-down. If another component or a pattern component has been previously applied to the surface, it will be replaced by the new pattern.
Modifying the Pattern with the Face Manager

Pattern spacing is controlled by the spacing of the divided surface. See *Modifying the Spacing of UV Grids on Divided Surfaces* on page 192.

Pattern orientation is controlled by the orientation of the direction of grids of the divided surface. See *Adjusting UV Grids with the Face Manager* on page 192.

Modifying Pattern Border Tiling

Patterned surfaces may have border tiles that intersect the edge of the surface and are not complete tiles. These border tile conditions can be set to be Partial, Overhanging, or Empty in the Border Tile instance property of the patterned surface. See *Pattern Element Instance Properties* on page 213. Partial border tiling is the default setting.

<table>
<thead>
<tr>
<th>Empty</th>
<th>Partial</th>
<th>Overhanging</th>
</tr>
</thead>
</table>

1 Select the patterned surface.

2 On the Properties palette, under Constraints, select Empty, Partial, or Overhanging.

3 Click OK.

When components are later applied to a surface, the border components inherit the condition of the border tile set when the surface was patterned.

Pattern Component Families

You can use the Curtain Panel by Pattern family template (Curtain Panel Pattern Based.rft) to create pattern panel components. These parametric components can be loaded into a conceptual mass family and applied to divided and patterned surfaces to populate buildable architectural components across a large variety of geometric surfaces. They can also be scheduled as curtain panels. When building a parametric component based on the Curtain Panel by Pattern template, you can apply the form-making tools to create variety of shapes. See *Forms* on page 167.

Pattern components are nested families, which are part of the larger conceptual mass family. When loaded in the conceptual design mass, they are available to be applied to a divided or a patterned surface. They may be modified individually after being applied to the divided surface.

**To create and apply pattern components**

1 Create a new pattern component family using the provided template family. See *Creating New Pattern Component Families* on page 202.

2 Determine the tile pattern for the component. See *Patterning Surfaces* on page 197.

3 Using the same modeling tools as used in the conceptual design mass, sketch and extrude geometry onto the pattern grid. See *Modeling Pattern Component Families* on page 203.

4 Load the pattern component family into the conceptual design mass. See *Loading a Pattern Component Family* on page 204.

5 Apply the pattern component family to the divided or patterned surface. See *Applying a Pattern Component Family* on page 204.
Modify the pattern component family to meet the needs of the conceptual design mass. See Modifying the Pattern Component Family on page 205.

Creating New Pattern Component Families

You create pattern component families from a provided family template file. The family can then be saved and edited as needed.

1. Click ➤ New ➤ Family.
2. In the New Family dialog, navigate to the family templates directory.
3. Select Curtain Panel Pattern Based.rft, and click Open.
4. Click ➤ Save As.
5. In the Save As dialog, navigate to the directory where you want to save your pattern component family, and click Save.

You can now design the pattern component family for the conceptual design mass.

The Pattern Component Family Template

The component template consists of a grid, reference points, and reference lines.

The default reference points are locked to allow only vertical movement as seen in the following image. This maintains the basic shape of the component so it will apply to the pattern proportionately.

Selecting the Tile Pattern Grid

Before designing the pattern component, you may need to select a tile pattern grid that matches your patterned surface. These are grids on which you sketch and create 3D forms for your pattern component. The grid layouts for pattern components are shown in the chart in Patterning Surfaces on page 197.

1. Open your pattern component family file. A square tile pattern grid displays by default.
2. Select the tile pattern grid in the drawing area.
3 In the Type Selector on page 35, select the desired pattern grid. The new tile pattern grid is applied.

NOTE Many of the predefined tile pattern grids appear identical to others, such as the Rectangle and Rectangle Checkerboard, or Rhomboid and Rhomboid Checkerboard patterns. While they appear similar, they are configured differently when applied to the conceptual design mass.

4 Click ➤ Save.

You can now design the pattern component family. See Modeling Pattern Component Families on page 203.

Modeling Pattern Component Families

Designing the pattern component is very similar to sketching the conceptual design mass. You use the same modeling tools that are used to design forms, though with the following limitations:

- There is only one floor plan (level) view, which is defined by the pattern tile grid.
- There are no elevation views.
- There are no default vertical reference planes, though reference planes can be defined by geometry.

Lines, Curves, and Splines

Draw reference points, lines, and closed loop geometry to design and modify a pattern component. While the template reference points will not move horizontally, the template reference lines can have driving points added to them to alter their geometry.

Related topics

- Drawing in the Conceptual Design Environment on page 141
- Reference Points on page 152
- Forms on page 167
Extrusions and Forms
Using sketched lines and geometry, create extrusions, forms and voids to give the component dimension.

Related topic
- Forms on page 167

Best Practices
- Divide and pattern a surface before applying components.
- Work with border tile conditions set to Empty or Overhanging when possible. When set to Partial, the size of the file and resulting memory requirements increase. Loading pattern components and modifying conceptual masses with applied pattern components in this state may take longer than anticipated.
- When working with closed forms, select patterns that will seamlessly interlock.
- Work with multiple windows to facilitate your pattern component family design workflow.

To design a pattern component
1. Open the pattern component family.
2. Open the conceptual design mass (3D view, floor plan view, or both).
3. Click View tab ➤ Windows panel ➤ Tile.

Designing in this manner allows you to work in the pattern component family and see how it displays in your conceptual design mass.

Loading a Pattern Component Family
1. Open the conceptual design mass.
2. Open the pattern component family.
3. Click Home tab ➤ Family Editor panel ➤ Load into Project.
4. If multiple projects are open, the Load into Projects dialog will open. Select which projects will receive the pattern component family, and click OK.

The new pattern component is now available to be applied to a patterned surface. See Applying a Pattern Component Family on page 204.

Applying a Pattern Component Family
1. Open the conceptual design mass.
2 Select the divided or patterned surface.
3 In the Type Selector on page 35, select the pattern component family.

The component is applied to the patterned surface.

**NOTE** The pattern component may take a few moments to load.

**Modifying the Pattern Component Family**

Pattern component families can be edited using the following tools:

- Change pattern component layout by adjusting the patterned surface. See *Editing the Patterned Surface* on page 200.
- Change pattern component family geometry by directly editing its family file. See *Modeling Pattern Component Families* on page 203.
- Change component family properties on the Properties palette. See Pattern Element Instance Properties on page 213.

**Modifying Individual Pattern Components**

Individual instances of pattern components can be replaced with other pattern components.

1. Select a single pattern component. Use the tab key if you want to select any of the adjacent pattern components.

2. Select a new pattern component in the Type Selector on page 35. Note that you will need to select a pattern component created with a similar underlying pattern grid.

The pattern component is replaced.

**To select All, Interior, or Border Pattern Components**

1. Click on the surface on which you have applied pattern components.
2. Right click to select All, All Interior or All Border Components.

You can use the selection to swap pattern components on the border or the interior of the surface.
Stitching Borders of Divided Surfaces

You can manually stitch surface borders with pattern components. Revit pattern components don’t require to be hosted on nodes of divided surface and can also address the problems of creating and placing pattern component panels (triangular, pentagonal, hexagonal, etc.) on non-rectangular and non-evenly spaced grids.

To stitch surface borders with pattern component

1. You can clean up the border conditions of applied pattern component families by using individually placed pattern components. Notice the open edges in the following example.

   ![Example of open edges](image)

   This example requires a 3-point pattern component to fill the edges that were not filled by the selected pattern component.
   1. Create a new pattern component family.
   2. Select the Triangle (flat) (a 3-point pattern component) tile pattern grid.
   3. Create a component family from the tile pattern grid.
   4. Load the component family into your adaptive component.
   5. From the Project Browser in your adaptive component, drag the component family into the drawing area. It is listed under Curtain Panel.

   ![Component family in drawing area](image)

   Notice the shape of the component family is represented on the cursor.
6 Place the three points on the component surface that will create the new panel.

![Image showing three points on a component surface]

**NOTE** The order of point placement is important. If the component family is an extrusion, the direction of the extrusion will flip when the points are placed counterclockwise.

7 You can continue placing panels as needed.

![Image showing multiple panels]

**Adaptive Components**

The Adaptive Component functionality is an adaptation of the pattern-based curtain panel. This functionality is designed to handle cases where components need to flexibly adapt to many unique contextual conditions. For example, adaptive components could be used in repeating systems generated by arraying multiple components that conform to user-defined constraints.

Adaptive points are created by modifying reference points. The geometry drawn by snapping to these flexible points results in a flexible component.

You can assign a category to adaptive components.

**NOTE** The use of adaptive components is restricted to pattern panel families and adaptive component templates. Adaptive points cannot be used in massing families, but families with adaptive points can be placed into massing. It is not possible to load the Adaptive Component template into the project environment, but it can be placed in an in-place family.
To place an adaptive component

1. You can place the adaptive model within another adaptive component, in a conceptual mass, in curtain panels, and in-place masses.

   Open a new adaptive component and design a general model using adaptive points as references.

2. Load the adaptive component into design component or mass. The following illustrations use the following general model which contains 4 adaptive points.

   ![Diagram](image1)

3. From the Project Browser in your design, drag the component family into the drawing area. It is listed under General Model.

   ![Diagram](image2)

   Notice the shape of the model is represented on the cursor.

4. Place the adaptive points of the model in the conceptual design.

   **TIP** Press Esc at any time to place the model with the current adaptive points. For example, if your model has 5 adaptive points, pressing escape after placing 2 points will place the model based on those points.
NOTE The order of point placement is important. If the component is an extrusion, the direction of the extrusion will flip when the points are placed counterclockwise.

5 You can continue placing multiple iterations of the model as needed. To manually array the model, select one and Ctrl-move to place additional instances.

6 You can go back to the adaptive component model, add additional geometry, and reload it.

**Surface Representation**

While editing a surface in the conceptual design environment, you can choose which surface elements to view with the Surface Representation tools. Select a divided surface and notice the Modify | Divided Surface tab ➤ Surface Representation panel. The corresponding Surface, Pattern, and Component tools show or hide their surface elements in the conceptual design environment.

NOTE Changes made from the Surface Representation panel will not carry into a project. To globally show or hide surface elements, click View tab ➤ Graphics panel ➤ Visibility and Appearance. See Visibility and Graphic Display in Project Views on page 801.

Each surface element has a subset of display properties for Surface Representation. To access these properties, click Modify | Divided Surface tab ➤ Surface Representation panel ➤ . The Surface Representation dialog opens with tabs for Surface, Pattern, and Component. Each tab has check boxes for surface element specific items. Clicking a check box shows the change in the drawing area. Click OK to confirm any changes.
Surface Properties Tab
These settings are used when the Surface tool on the Surface Representation panel is clicked.

■ **Original Surface.** Displays the original surface that was divided. Click ... Browse to change the surface material. See Materials on page 1573.

■ **Nodes.** Displays nodes located at the intersection of UV grids. By default, nodes are not enabled.

Notice that the surface immediately updates when a dialog check box is selected.

■ **UV Grids and Intersect Lines** Displays the UV grids and Intersects on a divided surface.

Pattern Properties Tab
These settings are used when the Pattern tool on the Surface Representation panel is clicked.

■ **Pattern Line.** Displays the outlines of the pattern shapes.

■ **Pattern Fill.** Displays the surface fill of the pattern. Click ... Browse to change the surface material. See Materials on page 1573.

Component Properties Tab
These settings are used when the Component tool on the Surface Representation panel is clicked.

■ **Pattern Component.** Displays the applied pattern component of the surface.

Pattern Element Properties
Use the following procedure to modify many properties such as constraints, grids, and application.

1 Select the patterned surface.

2 On the Properties palette, edit patterned surface instance parameters.

3 If you want to edit type properties, click Edit Type.

   Type properties affect all instances (individual elements) of that family in the project and any future instances that you place in the project. Edit type parameters and click OK.

4 Click OK.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Construction Type</td>
<td>The type of construction for the component.</td>
</tr>
<tr>
<td>Material and Finishes</td>
<td></td>
</tr>
<tr>
<td>Finish</td>
<td>Texture of the finished surface of the component.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code for the component.</td>
</tr>
<tr>
<td>Keynote</td>
<td>The component keynote. Add or edit the value. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The component manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for entering general comments about the component type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the component.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Read-only description of the assembly based on the assembly code selection.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value that designates the particular component; possibly the shop mark. This value must be unique for each element in a project. You are warned if the number is already used, but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>The pricing of the component.</td>
</tr>
<tr>
<td>OmniClass Number</td>
<td>The number from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
</tbody>
</table>
### OmniClass Title
The name from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.

### Pattern Element Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Border Tile</strong></td>
<td>Determines how a pattern intersects a surface border: empty, partial, or overhanging. See Editing the Patterned Surface on page 200.</td>
</tr>
<tr>
<td><strong>All Grid Rotation</strong></td>
<td>The rotation of both U and V grids. See Adjusting UV Grids with the Face Manager on page 192.</td>
</tr>
<tr>
<td><strong>U Grid</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Layout</strong></td>
<td>The spacing units of the U grid: Fixed Number or Fixed Distance. See Adjusting UV Grids with the Face Manager on page 192.</td>
</tr>
<tr>
<td><strong>Number</strong></td>
<td>The fixed number of divisions of the U grid. See Adjusting UV Grids with the Face Manager on page 192.</td>
</tr>
<tr>
<td><strong>Distance</strong></td>
<td>The fixed distance of divisions of the U grid. See Adjusting UV Grids with the Face Manager on page 192.</td>
</tr>
<tr>
<td><strong>Justification</strong></td>
<td>The position from which the U grid is measured: Beginning, Center, or End. See Adjusting UV Grids with the Face Manager on page 192.</td>
</tr>
<tr>
<td><strong>Grid Rotation</strong></td>
<td>The rotation of the U grid. See Adjusting UV Grids with the Face Manager on page 192.</td>
</tr>
<tr>
<td><strong>V Grid</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Layout</strong></td>
<td>The spacing units of the V grid: Fixed Number or Fixed Distance. See Adjusting UV Grids with the Face Manager on page 192.</td>
</tr>
<tr>
<td><strong>Number</strong></td>
<td>The fixed number of divisions of the V grid. See Adjusting UV Grids with the Face Manager on page 192.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Distance</td>
<td>The fixed distance of divisions of the V grid. See <em>Adjusting UV Grids with the Face Manager</em> on page 192.</td>
</tr>
<tr>
<td>Justification</td>
<td>The position from which the V grid is measured: Beginning, Center, or End. See <em>Adjusting UV Grids with the Face Manager</em> on page 192.</td>
</tr>
<tr>
<td>Grid Rotation</td>
<td>The rotation of the V grid. See <em>Adjusting UV Grids with the Face Manager</em> on page 192.</td>
</tr>
<tr>
<td><strong>Pattern Application</strong></td>
<td></td>
</tr>
<tr>
<td>Indent 1</td>
<td>The number of U grid divisions by which the pattern is shifted when applied.</td>
</tr>
<tr>
<td>Indent 2</td>
<td>The number of V grid divisions by which the pattern is shifted when applied.</td>
</tr>
<tr>
<td>Component Rotation</td>
<td>The rotation of a pattern component family in its pattern cell: 0°, 90°, 180°, or 270°.</td>
</tr>
<tr>
<td>Component Mirror</td>
<td>Mirrors the component horizontally along the U grid.</td>
</tr>
<tr>
<td>Component Flip</td>
<td>Flips the component along the W grid.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>Comments on the pattern element.</td>
</tr>
<tr>
<td>Mark</td>
<td>A mark applied to a pattern element. This can be a label that appears in a multi-category tag with the pattern element. For complete information about multi-category tagging and setting up shared parameters, see <em>Shared Parameters</em> on page 1541.</td>
</tr>
<tr>
<td><strong>Area</strong></td>
<td></td>
</tr>
<tr>
<td>Divided Surface Area</td>
<td>The total area of the selected divided surface.</td>
</tr>
</tbody>
</table>

**Conceptual Design Environment Glossary**

- **3D control**
  A manipulation control that appears when surfaces, edges, or vertices are selected. This control also displays on a selected point. See *Modifying Forms* on page 180.
■ **3D level**
A finite horizontal plane that acts as a reference for level-hosted forms and points. 3D levels display in the conceptual design environment as the cursor moves over them in the drawing area. These can be set as work planes.

■ **3D reference plane**
A 3D plane used to draw lines that create a form. 3D reference planes display in the conceptual design environment. These can be set as work planes.

■ **3D work plane**
A planar surface on which to draw lines for creating a form. 3D levels and 3D reference planes can be set as work planes. These automatically display in the conceptual design environment as the cursor moves over them in the drawing area.

■ **Form**
The 3D or 2D surface or solid created using the Create Form tool. See Forms on page 167.

■ **Loft**
The form derived from multiple lines (single segment, chain, or loop) drawn on parallel or non-parallel work planes.

■ **Profile**
A single curve, or collection of end-connected curves which are used singly or in combination to construct form element geometry, using the supported geometry construction techniques: extrude, loft, sweep, revolve, and surface.
Structural Modeling

This section contains information about the various structural tools and elements within Revit Structure.

Structural Template

A structural template is provided with the installation of Revit Structure. In this template, the view properties and ranges have been modified to specifically work with structural components.

Although you can work with structural components in projects based on non-structural templates, you will notice that you must modify view ranges in order to display the structural components within the view. This is because structural components, such as beams and columns, are placed on the level below the view you are working in. Therefore, they fall below the bottom cut plane of the view range and do not display. The structural template has been modified specifically to take this into account.

Related Topics
- Project Templates on page 1633
- View Range on page 864

Starting a Project with the Structural Template

1. Click ➤ New ➤ Project.
2. In the New Project dialog, under Template File, click Browse.
3. In the Choose Template dialog, select the structural template, and click Open.

**NOTE** The name and location of the structural template will vary depending on your install options and system settings. To view or modify file locations, click ➤ Options, and click the File Locations tab.

4. In the New Project dialog, click OK.
Loading Structural Component Families

When you load structural families, Revit Structure provides a type catalog to assist you with the family selection process. You can sort through the data and load only the specific structural family type required for your project. This helps decrease project size and minimizes the length of the Type Selector list when selecting structural types. For example, if you load the entire C-Channel family, you have to scroll through a list of dozens of C-Channel types in order to make your selection. Simplify the choices by loading a single C-Channel type, such as a C15x40.

After the family is loaded, it is saved with the project.

Loading Structural Families

1. Click Insert tab ➤ Load from Library panel ➤ Load Family.
2. Navigate to the directory containing the file you wish to open or use the web-based library of Revit families. See Opening Files from the Web Library on page 84.
   
   By default, the window displays the RFA file types.
   
   In the lower left-corner, the Type Catalog populates with family types.
4. In the Type column of the Type Catalog, select the family type or types to load. Select multiple types by holding Ctrl during selection. You can filter the list of types by selecting specific parameters from the list at the top of each column.
5. Click Open.
6. From the Type Selector, select the new family you just loaded and place it in the document window.

Structural Columns

Structural columns are used to model vertical load-bearing elements in a building. Although structural columns share many of the same properties as architectural columns, structural columns have additional properties defined by their configuration and industry standards.

Structural columns differ from architectural columns in behavior as well.

Structural elements such as beams, braces, and isolated foundations join to structural columns; they do not join to architectural columns. In addition, structural columns have an analytical model that is used for data exchange. See Structural Member Analytical Models on page 1281.

Typically, drawings or models received from an architect may contain a grid and architectural columns. You create structural columns by manually placing each column or by using the At Grids tool to add a column to selected grid intersections.

Structural columns can be created in plan or 3D views.
Adding columns in 3D View

It is helpful to set up a grid before adding structural columns, as they snap to grid lines (see Adding Grids on page 99).

Sample grid for placing structural elements

The grid lines also provide vertical planes for braces. Click Home tab ➤ Datum panel ➤ Grid.
You can place structural columns that attach to other structural elements. For more information, see Attaching Columns on page 510.

Creating a Structural Column Family

You create column families by defining what the column looks like in plan view, elevation view, and 3D view.

For detailed information about creating a family, see The Families Guide on page 680.

The following image shows what a column may look like in a 3D view.

Starting a Structural Column Family

When you start creating a column family, you see one of 3 views: a front elevation view of a lower reference level tag and an upper reference level tag with reference planes, a plan view with reference planes and 2 sets of equality dimensions, and a 3D view. The view in which you start creating geometry does not matter. You can define geometry in any of these views. You may want to add an overall width and depth dimension to the plan view and label it. This is useful if you are going to have a list of different-size columns.

When you create a column, Revit Structure automatically adds a rotation control symbol to the lower left corner of the geometry in the plan view. You notice it when you add the column to a project. You can rotate the column in the plan view by clicking Modify, selecting the column geometry, and then dragging the rotation control arrow.

The following procedure is a general procedure for creating a column family. Your steps may differ based on design intent.

1. Click ➤ New ➤ Family.
2. In the Open dialog, select column.rft from the templates folder, and click Open.
3. Create the geometry for the family. For more information on creating solid geometry, see Creating Solid and Void Geometry on page 1420.
4. If desired, label any permanent dimensions that you may have added. Place the cursor over the dimension text and right-click. Click Edit Label and enter a name for the dimension. This name
appears in the properties of the family. You can modify the name to change all occurrences of
that family type in the project or you can use it to create other family types with varying sizes.

5 Set the reference planes and sketch lines properties for Defines Origin and Is Reference properties.

6 Save the family by clicking ➤ Save. Revit Structure saves the file with an RFA extension.

Specifying How a Structural Column Displays in Plan View

For a column family, you can select the option Show family pre-cut in plan views, in the Family Category
and Parameters dialog. When you select this option and load the family into a project, the column displays
in a plan view using the cut plane specified in the plan view of the family.

1 Open a column family or start a new column family.

2 Click Home tab ➤ Properties panel ➤ Family Category and Parameters.

3 In the Family Category and Parameters dialog, under Family Parameters, select or clear the
parameter, Show family pre-cut in plan views.

When loaded into a project, if you want the column to display in plan view

<table>
<thead>
<tr>
<th>then</th>
</tr>
</thead>
</table>
| based on the cut plane of the project’s plan view, | clear the parameter, Show family pre-cut in plan views.
| consistently, regardless of the cut plane of the project’s plan view, | select the parameter, Show family pre-cut in plan views. The column displays using the cut plane specified within the Family Editor plan view.

4 Click OK.

5 Save the column family.

After you load the column family into a project, the column displays based on the parameter
settings you specified within the Family Editor.

A column with corbels family depicting “Show family pre-cut in plan views” enabled (left) and disabled (right). Notice the cut plane of the project’s plan view has no affect on the display of the column. The horizontal arrow marks the cut plane for the section views to the right.
Structural Column Family Parameters

To access the Structural Column Family Parameters in the Family Editor, click Modify | Structural Column tab ➤ Mode panel ➤ Edit Family ➤ Properties panel ➤ Family Category and Parameters. Verify that Structural Columns is selected as the Family Category. The Family Parameters display at the bottom of the dialog.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structural Material Type</td>
<td>Controls hidden view display of the structural column family. See Material Physical Type Parameters on page 1597.</td>
</tr>
<tr>
<td>Symbolic Representation</td>
<td>Determines whether the Symbolic Representation of the structural column is defined by the family or the settings of the project in which its placed. See Symbolic Representation Settings Tab on page 1605.</td>
</tr>
<tr>
<td>Always export as geometry</td>
<td>Ensures that the structural column family is exported as geometry at all times. This overrides the Export as Architectural Desktop and Building System Objects option in the Export Options dialog. See Exporting Structural Members on page 1167.</td>
</tr>
<tr>
<td>Beam cutback in plan</td>
<td>Determines whether the symbolic representation of a beam is cutback from the column bounding box or the physical geometry of the column. See Beam to Column Cutback on page 278.</td>
</tr>
<tr>
<td>Display in hidden views</td>
<td>Defines the structural column family rules for displaying edges in hidden views. See Showing Hidden Element Lines on page 862.</td>
</tr>
<tr>
<td>Shared</td>
<td>Denotes the structural column family as a shared family. See Loading Families with Shared Components into a Project on page 689.</td>
</tr>
<tr>
<td>Show family pre-cut in plan views</td>
<td>Displays the structural column family in a plan view using the cut plane specified in the plan view of the family. See Specifying How a Structural Column Displays in Plan View on page 221.</td>
</tr>
</tbody>
</table>

Placing a Vertical Structural Column

1 Click Home tab ➤ Structure panel ➤ Column drop-down ➤ Structural Column.
2 Click Modify | Place Structural Column tab ➤ Placement panel ➤ Vertical Column.
3 If a structural column family has not been previously loaded, Revit Structure prompts you to load one. See Loading Families on page 688.
4 On the Properties palette, select a column type from the Type Selector drop-down.
5 If you intend to rotate the column after placement, select Rotate after placement on the Options Bar.

6 Optionally, click Modify | Place Structural Column tab ➤ Properties panel ➤ Properties (and Type Properties when appropriate) to edit the properties of the column before adding it to your model.

**NOTE** You can create your own column family by defining specific properties based on structural requirements. For more information, see Creating a Structural Column Family on page 220. You can control how a column family displays within a project plan view. In the Family Editor, select Show family pre-cut in plan views if you want the column display to remain consistent despite the cut plan for that project plan view. For more information, see Specifying How a Structural Column Displays in Plan View on page 221.

7 The Height/Depth area of the Options Bar is shown in the following illustration.

![Height/Depth Options Bar](image)

You may pre-select the Height (top) or Depth (base) of a structural column on the Options Bar.

8 On the Options Bar, select either Height or Depth from the list.

9 In the Constraint list to the right of the Height/Depth selection, specify the constraint of the top or base of the column by Level or select Unconnected.

![Constraint List](image)

If you select Unconnected, enter the Height or Depth measurement in the text box to the right of the Constraint list. This measurement of Unconnected Height/Depth is relative to the current Level.

10 Click to place the column.

**Placing a column**

![Column Placement](image)

Columns snap to existing geometry in Revit. When you place columns at grid intersections, both grids are highlighted.
To rotate the column during placement

While placing columns, use the SPACEBAR to change the column rotation before the column is placed. Each time you press the SPACEBAR, the column rotates to align with the intersecting grids at the selected location. In the absence of any grids, press the SPACEBAR to rotate the column 90 degrees.

Rotating a column

---

Placing Slanted Structural Columns

Slanted structural columns are becoming more common in large, high profile structures. These have been implemented in Revit Structure to help engineers incorporate this functionality into their drawings and allow proper analysis calculations.

The following general rules apply to the procedures for placing slanted columns.

When placing slanted columns, the top of the column will always have a higher elevation than its base. When you place the column, the endpoint at the higher elevation is the top, and the lower elevation is the base. Once defined, the top may not be set below the base.

When placed in a 3D view, your 1st Click and 2nd Click settings define the associated levels and offset of the column. When placed in an elevation or cross section, the endpoints associate with their nearest level. The distance between the endpoint and the elevation are the offset by default.

If 3D Snapping is disabled, snap references for elements not on the current work plane display, as well as typical temporary dimensions. When you place columns with 3D snapping enabled, the 1st Click and 2nd Click level settings are used if a snap reference is not found or utilized.
Upgrade Behaviors

When you first open a project modeled in versions earlier than Revit Structure 2010, new parameters and column states will be applied to the existing elements. Browse the following references to determine the changes that will be made to your project and to understand the limited functionality of some features.

- New element properties have been implemented. See Structural Column Instance Properties on page 243.
- Slanted columns do not appear in graphical column schedules. Columns in a slanted state will not display element properties related to graphical column schedules, such as Column Location Mark.
- In some cases, slanted concrete structural columns may display end trimming aberrations at joins, and expected geometry may not be created.
- Currently, the Copy/Monitor tool does not apply to slanted columns.

Placing a Slanted Structural Column in a Plan View

You place a slanted column in a plan view with 2 clicks—one to specify the column start point and one to specify its endpoint. You define the elevation and offset of each click or use 3D snapping to join to previously placed elements.

1. Open a plan view of your project.
2. Click Home tab ➤ Structure panel ➤ Column drop-down ➤ Structural Column.
3. Click Modify | Place Structural Column tab ➤ Placement panel ➤ Slanted Column.
4. On the Properties palette, select a column type from the Type Selector drop-down.
5. On the Options Bar, for 1st Click, select the level for the column start point, and for 2nd Click, select the level for the column endpoint.
6. Select 3D snapping if you want either or both ends of the column to snap to previously placed structural elements.
7. In the drawing area, click to specify the start point of the column at the level selected for 1st Click.
8. Click to specify the endpoint of the column at the level selected for 2nd Click.
The column is placed, defined by the 2 clicks, their associated levels, and defined offsets. The following illustrations show slanted column placement from the level 2 structural plan of a project using the click locations shown in steps 8 and 9.

1st Click: Level 1 and 2nd Click: Level 2

1st Click: Level 3 and 2nd Click: Level 2

Placing a Slanted Structural Column Using 3D Snapping

1 Open a 3D view of the project.
2 Click Home tab ➤ Structure panel ➤ Column drop-down ➤ Structural Column.
3 Click Modify | Place Structural Column tab ➤ Placement panel ➤ Slanted Column.
4 On the Properties palette, select a structural column type from the Type Selector drop-down.
5 On the Options Bar, select 3D Snapping. This enables the slanted column placement to snap to points that are not within the work plane of the view, such as columns in different elevations.
6 Click along any structural element or on an element endpoint to place the first point of the column.
7 Click another structural element to place the column.

8 The column is placed between the 2 structural elements.

NOTE If either of the placement clicks is not a snap reference to a structural element, the column end location will be defined by the placement of the click and the appropriate elevation defined in the Options Bar.

Placing a Slanted Structural Column Using 2-Click 3D View Placement

1 Open a 3D view of the project.
2 Click Home tab ➤ Structure panel ➤ Column drop-down ➤ Structural Column.
3 Click Modify | Place Structural Column tab ➤ Placement panel ➤ Slanted Column.
4 On the Properties palette, select a structural column type from the Type Selector drop-down.
5 On the Options Bar, define the 1st click and 2nd click column end elevations. See Placing Slanted Structural Columns on page 224.

| Place Structural Column | 1st Click: Level 1 | 0’ 0” | 2nd Click: Level 2 | 0’ 0” | 3D Snapping |

NOTE Select 3D Snapping on the Options Bar if you want a previously placed structural element to define one end of the column. This is the most accurate placement method. See Placing a Slanted Structural Column Using 3D Snapping on page 226.

6 In the drawing area, click where the column should begin in regard to the 1st Click elevation setting on the Options Bar.
7 Click where the column should end in regard to the 2nd Click elevation setting on the Options Bar.

The column is placed, defined by the 2 clicks and their associated levels.

---

**Placing a Slanted Structural Column in Elevations or Sections**

1 Open an elevation or section view of the project.
2 Click Home tab ➤ Structure panel ➤ Column drop-down ➤ Structural Column.
3 Use the Work Plane dialog to define the column top and base if a snap reference is not available. See Setting the Work Plane on page 1517.

**NOTE** Select 3D Snapping on the Options Bar if you want a previously placed structural element to define one end of the column. This is the most accurate placement method.

4 Click Modify | Place Structural Column tab ➤ Placement panel ➤ Slanted Column.
5 On the Properties palette, select a structural column type from the Type Selector drop-down.
6 Click where the column should begin using the temporary dimensions as a reference.
Placing Multiple Columns by Grid

1 Click Home tab ➤ Structure panel ➤ Column drop-down ➤ Structural Column.
2 Click Modify | Place Structural Column tab ➤ Multiple panel ➤ At Grids.
3 Select multiple grid intersections. For more information, see Selecting Elements on page 1439.
Placing columns by grid

NOTE A column will be placed at every intersection of selected grid lines. No columns are actually created until you click Finish.

4 Press the Spacebar to rotate all of the columns that you are creating.
5 Continue pressing Spacebar until the columns are in the desired orientation.
6 To add other columns to grid intersections, hold Ctrl and drag other pick boxes.
7 Click Modify | Place Structural Column > At Grid Intersection tab ➤ Multiple panel ➤ Finish to create the columns.

Locking Columns to a Grid

You can constrain the current position of vertical columns or the tops and bases of slanted columns to a grid. This state allows you to move the grid and keep columns or ends in their respective orientation to their grid placement.

To lock vertical columns to a grid

1 Valid columns must be within a grid and have a valid column location mark (see Including Off-Grid Columns on page 776).
   To enable this state:
   Select the vertical columns to lock to the grid.
   2 On the Properties palette, under the Constraints section, select Moves with Grids.
   3 Click Apply.
   The modified columns may still be moved and modified but they will proportionately move with the grid if it is repositioned.

To lock slanted columns to a grid

1 Because the ends of a slanted column move independently from one another, it is possible to lock the column tops, bases, or both to the project grid.
To lock slanted column ends to a grid:
Select the slanted columns to be locked.

2 On the Properties palette, under the Constraints section, select Move Top With grids, Move Base With Grids, or both parameters.

Because of the unique orientation properties of slanted column ends, locking to grids requires situational guidelines.

- If both ends are locked to a grid and the grids at each end are not a subset of each other, the Column Style parameter (see Structural Column Instance Properties on page 243) of the columns will be changed to Slanted - End Point Driven.
- Movement of a grid to which an angle-driven column is locked will move the entire column.
- Movement of a grid to which an endpoint-driven column is locked will move only that end of the column. The column will lengthen or shorten to meet the new location of the grid.

Adding Structural Columns Inside Architectural Columns

1 Click Home tab ➤ Structure panel ➤ Column drop-down ➤ Structural Column.
2 On the Properties palette, select a column type from the Type Selector drop-down.
3 Click Modify | Place Structural Column tab ➤ Multiple panel ➤ At Columns.
4 Either select individual architectural columns or drag a pick box over architectural columns in the view to select multiple columns.

Selecting a single architectural column
Selecting multiple architectural columns

The structural columns snap to the centers of the architectural columns. For more information about creating a pick box, see Selecting Elements on page 1439.

5 Click Modify | Place Structural Column > At Architectural Columns tab ➤ Multiple panel ➤ Finish when complete.

NOTE You can control how a column family displays within a project plan view. In the Family Editor, select “Show family pre-cut in plan views” if you want the column display to remain consistent despite the cut plan for that project plan view. For more information, see Specifying How a Structural Column Displays in Plan View on page 221.

Adjusting Slanted Column Geometry End Position and Trim

You can modify instance properties to control the offset position and cut of end geometry of slanted columns. The following properties are located under the Constraints section of the Properties palette.

Slanted Column Geometry Alignment with Beams

Beam elevation takes precedence when a beam mid-joins to a column. If the slanted column is moved, the join position will adjust to maintain the beam elevation.

You can adjust the working point of slanted column geometry when it is attached to a beam. The working point vertically offsets the column geometry centerline when you change the Top Geometry Alignment or Base Geometry Alignment properties. Geometry alignment can specify the Location Line (of the beam), Top of beam, Bottom of Beam, or Center of Beam. Change these values to shift the position of slanted column geometry relative to its location line as illustrated below.
In the following illustrations, a blue line represents the location line of the column and beam. Orange lines represent the geometry centerline. Green arrows show the vertical offset that determines the new centerline alignment.

**Options for the Geometry Alignment Instance Property**

<table>
<thead>
<tr>
<th></th>
<th>Location Line</th>
<th>Top of Beam</th>
<th>Bottom of Beam</th>
<th>Center of Beam</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Top Geometry Alignment</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Z-justification offset</td>
<td></td>
<td></td>
<td>Z-justification offset</td>
<td>Default</td>
</tr>
<tr>
<td>beam shown</td>
<td></td>
<td></td>
<td>Z-justification offset</td>
<td>Default</td>
</tr>
</tbody>
</table>

When a column joins with a beam end, the Beam/Column Join Editor can adjust the cutback of the beam to frame into the column.

**Attachment Justification**

You can define how a column end displays when it is attached to a structural floor or foundation slab. Column end geometry is offset or cut according to the options selected for its Attachment Justification properties.

**Options for Attachment Justification Instance Property**

<table>
<thead>
<tr>
<th>Attachment Justification at Top</th>
<th>Minimum Intersection</th>
<th>Intersect Column Mid-line</th>
<th>Maximum Intersection</th>
<th>Tangent</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Attachment Justification at Base</th>
<th>Minimum Intersection</th>
<th>Intersect Column Mid-line</th>
<th>Maximum Intersection</th>
<th>Tangent</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
You can further adjust the offset of the column with the Offset From Attachment at Top and Offset From Attachment at Base properties.

**Cut Style**

You can define how a column end displays when it is not attached to an element. The column end geometry is cut according to the options selected for its Cut Style properties in relation to its location line.

<table>
<thead>
<tr>
<th>Cut Style Instance Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>Perpendicular</td>
</tr>
</tbody>
</table>
| Top Cut Style | ![Diagram of Top Cut Style](image1)
| Base Cut Style | ![Diagram of Base Cut Style](image2) |

You can offset the cut plane of the column end geometry by increasing or decreasing the Top Extension or Base Extension properties.

**Slanted Column Style Behaviors**

The Column Style parameter for slanted structural columns defines how the column parametrically adjusts to the model. The parameter value is either Slanted - Angle Driven or Slanted - End Point Driven.

Angle driven columns maintain the angle of the column when its attached elements are repositioned. End point driven columns maintain their joined end positions when their attached elements are repositioned. Depending on the column style, the column adjusts to maintain the join relationship with the beam when the beam is repositioned.

<table>
<thead>
<tr>
<th>Column style</th>
<th>Original position</th>
<th>Beam elevation raised</th>
<th>Beam elevation lowered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Angle driven</td>
<td><img src="image3" alt="Diagram of Angle Driven" /></td>
<td><img src="image4" alt="Diagram of Angle Driven" /></td>
<td><img src="image5" alt="Diagram of Angle Driven" /></td>
</tr>
</tbody>
</table>

![Diagram of Slanted Column Style Behaviors](image6)
<table>
<thead>
<tr>
<th>Column style</th>
<th>Original position</th>
<th>Beam elevation raised</th>
<th>Beam elevation lowered</th>
</tr>
</thead>
<tbody>
<tr>
<td>End point driven</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Columns Joined at Both Ends**

If both ends of a column mid-join to a beam, join another slanted column, or attach to a grid, the Column Style parameter changes to Slanted - End Point driven.

![Diagram of columns joined at both ends]

**Column Joined at Top or Base**

If one end of an angle driven column mid-joins to a beam, joins another slanted column, or attaches to a grid, the Column Style maintains its current setting. In the following examples, the top end of the concrete slanted column mid-joins to a concrete beam.

![Diagram of column joined at top or base]

If the joined element is repositioned in an angle driven relationship, the column moves with the element.
Angle driven column, mid-joined at top

<table>
<thead>
<tr>
<th>Beam elevation raised</th>
<th>Beam elevation lowered</th>
</tr>
</thead>
</table>

Beam elevation lowered

Beam elevation raised

If the joined element is moved in an end point driven relationship, only the joined end of the column moves.

End point driven column, mid-joined at top

<table>
<thead>
<tr>
<th>Beam elevation raised</th>
<th>Beam elevation lowered</th>
</tr>
</thead>
</table>

Beam elevation lowered

Beam elevation raised

Columns Attached to a Structural Floor or Roof

When an angle driven slanted column attaches to a structural floor or roof, the attached end of the column moves along the location line to determine its join location.

<table>
<thead>
<tr>
<th>Angle driven columns attached to a structural floor</th>
<th>Structural floor elevation raised</th>
<th>Structural floor elevation lowered</th>
</tr>
</thead>
</table>

Structural floor elevation lowered

Structural floor elevation raised

Structural floor elevation lowered
Conversely, the joined end of an end point driven column moves vertically when the attached element is repositioned.

<table>
<thead>
<tr>
<th>End point driven columns attached to a structural floor</th>
<th>Structural floor elevation raised</th>
<th>Structural floor elevation lowered</th>
</tr>
</thead>
</table>

Modifying Structural Columns

You can align, move, copy, and adjust structural columns using common Revit Structure tools.

Related topics

- Moving Elements on page 1474
- Copying Elements on page 1491
- Modifying Elements on page 1497
- Locking Columns to a Grid on page 230
- Structural Column Properties on page 241
- Modifying Slanted Structural Columns on page 237
- Modifying the Slant of Placed Structural Columns on page 239

Modifying Slanted Structural Columns

Slanted columns incorporate a unique implementation of dragging tools. The following controls are available when the slanted column is selected.

**NOTE** If the base is moved higher than the top, or the top is moved lower than the base, a warning dialog displays, disallowing the modification. The top and base can similarly not share the same elevation or the same warning dialog is issued.

Related topic

- Joins and Cutback on Framing Elements and Columns on page 273

**Vertical Arrow Controls**

Vertical arrow controls appear as blue arrows at either end of the endpoint-driven slanted column. Drag these controls to adjust the elevation of the top or base of the column. The column end will only move vertically.
These controls are only available when the property Column Style is set to Slanted - End Point Driven. See Structural Column Instance Properties on page 243.

Vertical arrow controls are disabled when a column is attached to a structural floor, floor, roof, reference plane, or mid-joined to or driven by a beam.

**Endpoint Controls**

Endpoint controls appear as a blue dot on either end of the column. Drag these controls to adjust the position of the top or base of the column. The column end will move freely in accordance with the current view.

**Text Controls**

The text controls directly adjust the offset parameter displayed next to the endpoint control. Clicking this control enables it to be manually edited. Enter an elevation to reposition the associated top or base. The column end will only move vertically.

Text controls are disabled when a column is attached to a structural floor, floor, roof, reference plane, or mid-joined to or driven by a beam.

The behavior of text controls is dependent on the Column Style instance parameter (see Slanted Column Style Behaviors on page 234) and is consistent with changing the Base/Top Offset parameters.

If a column is endpoint-driven, the column endpoints move vertically when dependent elements of the column are modified. If it is angle-driven, endpoints move along the dependent element to maintain its angle. In the following illustration, columns adjust to meet a base offset increase. Notice how the angle-driven column on the left maintains its angle, while the endpoint-driven column on the right adjusts vertically, regardless of its original angle. The original column orientations are highlighted in blue.
Cross-Sectional Rotation

Press the Spacebar to rotate the selected column 90° clockwise (viewed from base to top) around its center. To make more finite adjustments to this rotation on slanted columns, edit the Cross-Section Rotation property. See Structural Column Instance Properties on page 243.

Modifying the Slant of Placed Structural Columns

This procedure will slant vertical columns or adjust existing slanted columns using the Properties palette, and column modification tools.

1 Open a 3D View of your project.
2 Select the column to be modified.

3 On the Properties palette, under Constraints, select a slanted column style, Slanted - End Point Driven or Slanted - Angle Driven, to define how the slant angle can be adjusted.

NOTE Other slanted column properties are available. See Structural Column Instance Properties on page 243.

4 Click Apply.
5 Adjust the position of the top of the column with the column endpoint control. If the column is set to Slanted - End Point Driven, you adjust the elevation of the top of the column using the vertical arrow or text controls.
Angle-Driven Modification

Adjust the position of the base of the column with the column endpoint. If the column is set to Slanted - End Point Driven, you adjust the elevation of the base of the column using the vertical arrow or text controls.

Endpoint-Driven Editing

The column adjusts its length and slant based on your parameter settings and endpoint adjustments.
Adding a Splice Symbol or Plate Symbol to a Steel Structural Column

1. Select the column that is to be modified.
2. On the Properties palette, under Structural, select Top Connection (for top splice), or Base Connection (for base plate symbol), as needed.
3. Click OK.

Structural Column Properties

There are several properties for structural columns, including base level, base offset, and materials.

Modifying Structural Column Properties

To modifying structural column properties

1. Select the structural column.
2. On the Properties palette, edit structural column instance parameters as required. (See Structural Column Instance Properties on page 243.)
3. Click Apply.
4. To edit structural column type parameters, on the Properties palette, click Edit Type. (See Structural Column Type Properties - Steel on page 241 or Structural Column Type Properties - Concrete on page 243.)

NOTE Changes made to type parameters affect all structural columns of this type in the project. Click Duplicate to create a new structural column type.

Structural Column Type Properties - Steel

Properties will vary depending on the column families that are specified during the installation process. The following type properties apply to the steel column families that load during a typical installation:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structural (Family parameters)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>A</td>
<td>Section area.</td>
</tr>
<tr>
<td>W</td>
<td>Nominal weight.</td>
</tr>
</tbody>
</table>

**Dimensions (Family parameters)**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>bf</td>
<td>Flange width.</td>
</tr>
<tr>
<td>d</td>
<td>Actual depth of section.</td>
</tr>
<tr>
<td>k</td>
<td>k distance.</td>
</tr>
<tr>
<td>kr</td>
<td>kr distance, read only.</td>
</tr>
<tr>
<td>tf</td>
<td>Flange thickness.</td>
</tr>
<tr>
<td>tw</td>
<td>Web thickness.</td>
</tr>
</tbody>
</table>

**Identity Data**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the column keynote. Click the value box to open the Keynote dialog. For more information, see Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>Manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The shape manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for entering general comments about the shape type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>Specifies a link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td>Description</td>
<td>User can enter a description of the column here.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the assembly based on the assembly code selection, a read-only parameter.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value that designates the particular beam; possibly the shop mark. This value must be unique for each element in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. For more information, see Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>The pricing of the column.</td>
</tr>
<tr>
<td>OmniClass Number</td>
<td>The number from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
<tr>
<td>OmniClass title</td>
<td>The name from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
</tbody>
</table>
### Structural Column Type Properties - Concrete

Properties will vary depending on the column families that are specified during the installation process. The following type properties apply to the concrete column families that load during a typical installation:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimensions (Family parameters)</td>
<td></td>
</tr>
<tr>
<td>b</td>
<td>Column width</td>
</tr>
<tr>
<td>h</td>
<td>Column depth</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the column keynote. Click the value box to open the Keynote dialog. For more information, see Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>Manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The shape manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for entering general comments about the shape type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>Specifies a link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td>Description</td>
<td>User can enter a description of the column here.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the assembly based on the assembly code selection, a read-only parameter.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value that designates the particular beam; possibly the shop mark. This value must be unique for each element in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. For more information, see Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>The pricing of the column.</td>
</tr>
<tr>
<td>OmniClass Number</td>
<td>The number from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
<tr>
<td>OmniClass Title</td>
<td>The name from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
</tbody>
</table>

### Structural Column Instance Properties

The following instance properties apply to column families that load during a typical installation. The properties will vary depending on the column families that are specified during the installation process.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Column Location Mark</td>
<td>The coordinate location of a vertical column on the project grid.</td>
</tr>
<tr>
<td>Base Level</td>
<td>Constraining level of the column base.</td>
</tr>
<tr>
<td>Base Offset</td>
<td>Offset of base from base level.</td>
</tr>
<tr>
<td>Top Level</td>
<td>Constraining level of the column top.</td>
</tr>
<tr>
<td>Top Offset</td>
<td>Offset of top from top level.</td>
</tr>
<tr>
<td>Moves With Grids</td>
<td>Changes the vertical column constraint to the grid. See Locking Columns to a Grid on page 230.</td>
</tr>
<tr>
<td>Move Top With Grids</td>
<td>Constrains the top endpoint of the slanted column to the grid.</td>
</tr>
<tr>
<td>Move Base With Grids</td>
<td>Constrains the base endpoint of the slanted column to the grid.</td>
</tr>
<tr>
<td>Top Cut Style</td>
<td>Either Perpendicular, Horizontal, or Vertical. Specifies the cut style at the top of the column when unattached to a reference or element.</td>
</tr>
<tr>
<td>Top Extension</td>
<td>Offset of the top of the column when unattached to a reference or element.</td>
</tr>
<tr>
<td>Base Cut Style</td>
<td>Either Perpendicular, Horizontal, or Vertical. Specifies the cut style at the base of the column when unattached to a reference or element.</td>
</tr>
<tr>
<td>Base Extension</td>
<td>Offset of the base of the column when unattached to a reference or element.</td>
</tr>
<tr>
<td>Column Style</td>
<td>Either Vertical, Slanted - End Point Driven, or Slanted - Angle Driven. Specifies the slant style of the column which enables type specific modification tools. See Modifying Slanted Structural Columns on page 237.</td>
</tr>
<tr>
<td>Base Geometry Alignment</td>
<td>Either Location Line, Top of beam, Bottom of Beam, or Center of Beam. Specifies the working point along an attached beam to which the centerline of a slanted column adjusts at its base.</td>
</tr>
<tr>
<td>Top Geometry Alignment</td>
<td>Either Location Line, Top of beam, Bottom of Beam, or Center of Beam. Specifies the working point along an attached beam to which the centerline of a slanted column adjusts at its top.</td>
</tr>
<tr>
<td>Base is Attached</td>
<td>Read-only parameter specifying that the base of the column is mid-joined to a beam or attached to a structural floor or roof.</td>
</tr>
<tr>
<td>Attachment Justification At Base</td>
<td>Either Minimum Intersection, Intersect Column Midline, Maximum Intersection, or Tangent. Specifies the degree of cutback or tangential justification at the base of the column at the join.</td>
</tr>
<tr>
<td>Offset From Attachment At Base</td>
<td>Offset of the base of the column from the mid-joined beam or attached elements.</td>
</tr>
<tr>
<td>Top is Attached</td>
<td>Read-only parameter specifying that the top of the column is mid-joined to a beam or attached to a structural floor or roof.</td>
</tr>
<tr>
<td>Attachment Justification At Top</td>
<td>Either Minimum Intersection, Intersect Column Midline, Maximum Intersection, or Tangent. Specifies the degree of cutback or tangential justification at the top of the column at the join.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Offset From Attachment At Top</td>
<td>Offset of the top of the column from the mid-joined beam or attached elements.</td>
</tr>
<tr>
<td>Cross-Section Rotation</td>
<td>The clockwise rotation angle of a slanted column (viewed from top to base). This angle can be carried out to 3 decimal places. Negative numbers rotate counter-clockwise. If a slanted column is in a vertical state, then this rotation is measured from Project North. Otherwise, it is measured from the vertical position.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>Changes column constraint to room-bounding conditions.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Top Connection Symbol</td>
<td>Applies to steel columns only. Turns on the visibility of a moment or shear connection symbol. The symbols are visible only in elevations and cuts parallel to the main axis of the column in coarse view.</td>
</tr>
<tr>
<td>Base Plate Symbol</td>
<td>Applies to steel columns only. Turns on the visibility of the base plate symbol. The symbols are visible only in elevations and cuts parallel to the main axis of the column in coarse view.</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td>Column Material</td>
<td>Structural material. For more information, see <a href="#">Material Physical Type Parameters</a> on page 1597.</td>
</tr>
<tr>
<td><strong>Structural</strong></td>
<td></td>
</tr>
<tr>
<td>Top Attachment Type</td>
<td>Either Distance or Ratio. Determines if the top join of a slanted column is measured as a distance or a ratio of the length of the beam.</td>
</tr>
<tr>
<td>Top Attachment Distance</td>
<td>Distance from the referenced end of the top attached beam to the join location on the slanted column.</td>
</tr>
<tr>
<td>Top Attachment Ratio</td>
<td>The ratio of distance from the referenced end of the attached beam to the top join location on the slanted column to the total length of the beam.</td>
</tr>
<tr>
<td>Top Attachment Reference End</td>
<td>Either Start or End. Specifies the end of the top attached beam from which to calculate distance or ratio.</td>
</tr>
<tr>
<td>Base Attachment Type</td>
<td>Either Distance or Ratio. Determines if the base join of a slanted column is measured as a distance or a ratio of the length of the beam.</td>
</tr>
<tr>
<td>Base Attachment Distance</td>
<td>Distance from the referenced end of the base attached beam to the join location on the slanted column.</td>
</tr>
<tr>
<td>Base Attachment Ratio</td>
<td>The ratio of distance from the referenced end of the attached beam to the base join location on the slanted column to the total length of the beam.</td>
</tr>
<tr>
<td>Base Attachment Reference End</td>
<td>Either Start or End. Specifies the end of the base attached beam from which to calculate distance or ratio.</td>
</tr>
<tr>
<td>Rebar Cover - Top Face</td>
<td>Applies to concrete columns only. Sets the rebar cover distance from the column top face.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Rebar Cover - Bottom Face</td>
<td>Applies to concrete columns only. Sets the rebar cover distance from the column bottom face.</td>
</tr>
<tr>
<td>Rebar Cover - Other Faces</td>
<td>Applies to concrete columns only. Sets the rebar cover distance from the column to other element faces.</td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Specifies the estimated reinforcement volume of the selected element. This is a read-only parameter that only displays when rebar has been placed.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Volume</td>
<td>Volume of the selected column. A read-only value.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>User comments.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label created for the column. Possible use: shop mark. This value must be unique for each element in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. For more information, see Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Indicates in which phase the column component was created. For more information, see Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Indicates in which phase the column component was demolished. For more information, see Project Phasing on page 877.</td>
</tr>
<tr>
<td>Structural Analysis (see Structural Analytical Model Overview on page 1277)</td>
<td></td>
</tr>
<tr>
<td>Top Release</td>
<td>Either Fixed, Pinned, Bending Moment, or User-Defined. User-Defined allows you to enable/disable each of the top release conditions.</td>
</tr>
<tr>
<td>Top Fx</td>
<td>Translational release at the top end of the column along the x-axis.</td>
</tr>
<tr>
<td>Top Fy</td>
<td>Translational release at the top end of the column along the y-axis.</td>
</tr>
<tr>
<td>Top Fz</td>
<td>Translational release at the top end of the column along the z-axis.</td>
</tr>
<tr>
<td>Top Mx</td>
<td>Rotational release at the top end of the column along the x-axis.</td>
</tr>
<tr>
<td>Top My</td>
<td>Rotational release at the top end of the column along the y-axis.</td>
</tr>
<tr>
<td>Top Mz</td>
<td>Rotational release at the top end of the column along the z-axis.</td>
</tr>
<tr>
<td>Bottom Release</td>
<td>Either Fixed, Pinned, Bending Moment, or User-Defined. User-Defined allows you to enable/disable each of the bottom release conditions.</td>
</tr>
<tr>
<td>Bottom Fx</td>
<td>Translational release at the bottom end of the column along the x-axis.</td>
</tr>
<tr>
<td>Bottom Fy</td>
<td>Translational release at the bottom end of the column along the y-axis.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Bottom Fz</td>
<td>Translational release at the bottom end of the column along the z-axis.</td>
</tr>
<tr>
<td>Bottom Mx</td>
<td>Rotational release at the bottom end of the column along the x-axis.</td>
</tr>
<tr>
<td>Bottom My</td>
<td>Rotational release at the bottom end of the column along the y-axis.</td>
</tr>
<tr>
<td>Bottom Mz</td>
<td>Rotational release at the bottom end of the column along the z-axis.</td>
</tr>
<tr>
<td>Analyze As</td>
<td>Either Hanger, Gravity, Lateral, or Not for analysis. Used by external analysis applications to determine whether the column contributes to lateral analysis.</td>
</tr>
</tbody>
</table>

### Analytical Model

<table>
<thead>
<tr>
<th>Rigid Links</th>
<th>Infinitely rigid frame element with no weight. When Rigid Links is enabled, an additional analytical segment is engaged in the model between the end of the analytical model of a beam and the analytical model of a column.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontal Projection</td>
<td>Either Auto-detect, Default, Center Line, Location Line, &lt;Named Reference Plane&gt;, or &lt;Grid&gt;. Specifies the horizontal limits of the structural column analytical model.</td>
</tr>
<tr>
<td>Top Vertical Projection</td>
<td>Either Auto-detect, Bottom of Column, &lt;Named Reference Plane&gt;, or &lt;Level&gt;. Specifies the top vertical limit of the structural column analytical model. For more information, see Projection Plane Options for each Structural Element Type on page 1301.</td>
</tr>
<tr>
<td>Bottom Vertical Projection</td>
<td>Either Auto-detect, Bottom of Column, &lt;Named Reference Plane&gt;, or &lt;Level&gt;. Specifies the base vertical limit of the structural column analytical model. For more information, see Projection Plane Options for each Structural Element Type on page 1301.</td>
</tr>
</tbody>
</table>

### Beams

Beams are structural elements used for load-bearing applications. Elements of each beam are defined through the type properties of the specific beam family. In addition, various instance properties can be modified to define the functionality of the beam.

### Sample beams
You can attach beams to any structural element, including structural walls, in your project. The beams join to structural bearing walls when the Structural Usage property of the wall is set either to Bearing or to Structural Combined.

Beams attached to structural walls

To draw beams between 2 points

1. Click Home tab ➤ Structure panel ➤ Beam.
2. Click in the drawing area to specify the start point.
3. Use the mouse to sketch the beam, moving the cursor to the endpoint.
4. Click to specify the endpoint.

You can use the Grid tool to add multiple beams to selected grids when columns are also present at the working level.

Beam between points

To draw a beam to a specified length

1. Click Home tab ➤ Structure panel ➤ Beam.
2. Click in the drawing area to specify the start point.
3 Use the mouse to sketch the beam, moving the cursor toward the endpoint.
4 Type a length. A text box will appear to show your entry.
5 Click to specify the endpoint.

Use the Grid tool to add multiple beams to selected grids when columns are also present at the working level.

**Enter beam length**

You should add beams after creating a grid since beams snap to grids. Add a grid by clicking Home tab ➤ Datum panel ➤ Grid. However, structural beams can be added without an existing grid.

You can add beams using one of the following methods:

- Sketch individual beams.
- Select grid lines that lie between structural elements.
- Create a chain of beams.

**Structural Usage of Beams**

Revit Structure determines the Structural Usage property of a beam automatically, based on the structural elements that support the beam. The structural usage parameter value determines the line style of the beam in a coarse-scale view.

Structural usage can be changed before or after the beam is placed. Use the Object Styles dialog to change the structural usage. For more information, see Object Styles on page 1601. The structural usage parameter can be included in a structural framing schedule, allowing quantity calculation of girders, joists, purlins, and horizontal bracing. For more information, see Specifying Schedule Properties on page 788.

**Structural usage values for beams**

<table>
<thead>
<tr>
<th>Structural Usage</th>
<th>Beam Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structural</td>
<td>Beams</td>
</tr>
<tr>
<td>Stick Symbol</td>
<td>Center of Gravity</td>
</tr>
<tr>
<td>Start Connection</td>
<td>None</td>
</tr>
<tr>
<td>End Connection</td>
<td>None</td>
</tr>
<tr>
<td>Cut Lines</td>
<td>None</td>
</tr>
<tr>
<td>Structural Usage</td>
<td>Beam</td>
</tr>
<tr>
<td>Carbon Type</td>
<td>Steel</td>
</tr>
<tr>
<td>Number of Stubs</td>
<td>Horizontal Bracing</td>
</tr>
<tr>
<td>Dimensions</td>
<td>Steel</td>
</tr>
<tr>
<td>Length</td>
<td>Steel</td>
</tr>
</tbody>
</table>

Beams can be attached to any other structural element, including structural walls. For more information, see Structural Walls on page 345.

**NOTE** Beams will not automatically join to non-bearing walls.
The default Structural Usage setting can be changed using the Properties palette. The following table lists the default automatic Structural Usage setting for beams, based on which elements are being connected:

<table>
<thead>
<tr>
<th></th>
<th>C</th>
<th>B</th>
<th>HB</th>
<th>G</th>
<th>J</th>
<th>P</th>
<th>O</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wall</td>
<td>G</td>
<td>O</td>
<td>HB</td>
<td>G</td>
<td>J</td>
<td>P</td>
<td>O</td>
</tr>
<tr>
<td>Column</td>
<td>G</td>
<td>O</td>
<td>HB</td>
<td>G</td>
<td>J</td>
<td>P</td>
<td>O</td>
</tr>
<tr>
<td>Brace</td>
<td></td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>HB</td>
<td>HB</td>
<td>HB</td>
<td>HB</td>
<td>O</td>
</tr>
<tr>
<td>Girder</td>
<td></td>
<td>J</td>
<td>J</td>
<td></td>
<td>P</td>
<td>O</td>
<td></td>
</tr>
<tr>
<td>Joist</td>
<td></td>
<td>P</td>
<td>P</td>
<td></td>
<td>O</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Purlin</td>
<td></td>
<td></td>
<td>P</td>
<td></td>
<td>O</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O</td>
<td></td>
</tr>
</tbody>
</table>

For the properties of beams, see Beam Properties on page 267.

**Beam Tips**

- If a beam end resides on a structural wall, the Beam End Pocket Seat parameter is displayed on the Properties palette. Select this check box when the beam is supported by a structural wall. Then the beam graphics extend to the centerline of the wall.

- When you place a beam, a beam name tag appears by default with the beam. Also, you can load another tag that displays beam name, camber, and number of studs. You must specify the values for Beam Camber and Number of Studs parameters that display in a tagged beam. For information about loading a family, see Loading Families on page 688.

**Creating Beams**

You should add grids and columns before creating beams.

When adding a beam to a plan view, you must set the bottom clip plane below the current level; otherwise, the beam is not visible in the view. You may also want to use a structural template, which has view range and visibility settings. See Structural Template on page 217.

Add beams using one of the following methods:

- Sketch individual beams.
- Create a chain of beams.
- Select grid lines that lie between structural elements.
- Create a beam system. For more information, see Beam Systems on page 286.
Sketching Individual Beams

The Beam tool is the primary means with which you sketch individual instances of beams.

To sketch individual beams

1. Click Home tab ➤ Structure panel ➤ Beam.
2. Load a structural beam family, if one has not been previously loaded.
3. On the Properties palette:
   - Select a beam type from the Type Selector drop-down.
   - Modify the beam parameters.
4. On the Options Bar, select a value from the Structural Usage drop-down list.
5. Sketch the beam by clicking the start point and endpoint in the drawing area.

   The cursor snaps to other structural elements, such as the centroid of a column or the centerline of a wall, when you sketch a beam. The status bar displays where the cursor is snapping.

   Beam start point - snap to column

Using the Grid Tool to Place Beams

You can use the Grid tool to select grid lines to place beams automatically between other structural elements (columns, structural walls, and other beams). For example, you might have 2 structural columns located on a grid line. Beams are also added between columns and structural walls.

To place beams using the Grid tool

1. Click Home tab ➤ Structure panel ➤ Beam.
2. Click Modify | Place beam tab ➤ Multiple panel ➤ On Grids.
3. Select the grid to place beams.
Selecting the grid

The beams are placed between columns as shown.

To sketch beams automatically using the Grid tool

1. Click Home tab ➤ Structure panel ➤ Beam.
2. On the Properties palette:
   - Select a beam type from the Type Selector drop-down.
   - Modify the beam parameters.
3. On the Options Bar, select a value from the Structural Usage drop-down list.
4. Click Modify | Place Beam tab ➤ Multiple panel ➤ On Grids.
In the image below, you can see assorted columns, a beam, and structural walls in a plan and 3D view. In this case, you can use the Grid tool to add the majority of the beams automatically.

5 Select a grid line along which you want to place a beam.
Press and hold Ctrl to select multiple grids.
In the image shown below, grids have been selected and beams have been added automatically between all columns, walls, and beams.

6 Click Modify | Place Beam > On Grid Lines ➤ Multiple panel ➤ Finish.

**TIP** You can also draw a pick box to select multiple grid lines.

In the image below, notice how the beams were added between all columns, walls, and other supporting beams. The pre-existing beam was not cut by the beam perpendicular to it.
When Revit Structure places beams along a grid line, it uses the following conditions:

- All the possible supports that intersect the grid line, such as columns, walls, or beams, are scanned.
- If a wall is on the grid line, a beam is not placed in the wall. The ends of the wall are used as support.
- If a beam intersects and crosses the grid line, that beam is considered to be an intermediate support, because this beam supports new beams created on the grid line.
- If a beam intersects but does not cross the grid line, this beam is supported by a new beam created on the grid line.

For more information about beam structural usage, based on which elements are being created, see Structural Usage of Beams on page 249.

Related topics
- Creating Beams on page 250
- Structural Usage of Beams on page 249
- Beam Properties on page 267
- Beams on page 247

**Sketching Beams with the Chain Option**

When the Chain option is selected, Revit Structure supplies the endpoint of the last beam as the start point of the next beam.
To sketch beams using the Chain option

1 Click Home tab ➤ Structure panel ➤ Beam.
2 On the Options Bar, select Chain.
3 Place the first beam in the chain. See Sketching Individual Beams on page 251.
4 Place each additional beams by clicking the endpoints of the beams.

Sketching beams using the chain option

Curved Beam Modeling

Because the geometry of curved beams can bend, you can draw them in both plan and elevation views.

To sketch a curved beam

1 Click Home tab ➤ Structure panel ➤ Beam.
2 Click Modify | Place Beam tab ➤ Draw panel, and select a curved line tool:
   ■ Start-End-Radius Arc
   ■ Center-ends arc
   ■ Tangent end Arc
   ■ Fillet Arc
   ■ Spline
   ■ Partial Ellipse
3 Place the necessary points in the drawing area to complete your curved line selection. See Sketching Elements on page 1406.
Defining the arc of a curved beam

For information about sketching a beam, see Creating Beams on page 250.

For information about beam properties, see Beam Properties on page 267.

Curved beams have an analytical model that can be smooth or segmented. If the analytical model is segmented, you can adjust the number and location of the segments. For more information, see Segmented Analytical Model on page 1302.

Smooth analytical model
Sloped Beam Modeling

If your project contains complex sloped members for which you need to add beams, you can match beams to uneven columns, roofs, structural floors, or walls using the following procedure.

To adjust sloped beams

1. Select a beam that is connected to 2 structural members or warped model objects at different heights.
2. On the Properties palette:
   - Under Constraints, enter a value for the Start Level Offset of the beam.
   - Enter a value for the End Level Offset of the beam.
   - Click Apply.
3. Verify that you have entered the correct offset values.

Example of sloped beam modeling.
NOTE A beam that has adjusted offset values will become disassociated or free from the current work plane. Similarly, any structural element attached to a sloped beam will also become free. You attach free elements to another work plane using the Edit Work Plane or Pick New buttons on the Work Plane panel of the Modify | Structural Framing tab.

3D Snapping

You can use the 3D Snapping option to create a new beam by snapping to other structural elements in any view. This means that you can sketch beams and braces outside of the current work plane. For example, when 3D snapping is enabled, roof beams will snap to the tops of columns, regardless of elevation.

3D snapping is also useful when creating sloped beam systems. See Sloped Beam Modeling on page 257.

To use 3D snapping

1. Click Home tab ➤ Structure panel ➤ Beam.
2. On the Options Bar, select 3D Snapping.
3. Click any structural element to specify the start point for the beam.
4. Click another structural element to specify the endpoint for the beam.

NOTE With 3D Snapping enabled, you can choose the exact endpoint of any structural element regardless of the plane of the endpoint.

Editing Beams

You can edit any beam after it is placed within a project. The beam can be moved or rotated from the location where it was originally placed, or the beam can be extended or reshaped using graphical controls. For more information, see Editing Elements on page 1439.

To move a beam

1. In a project view, select the beam.
2. Drag the beam to a new location in the drawing area, or use the arrow keys on your keyboard. For more information, see Moving Elements on page 1474.

To rotate a beam

1. Select the beam in a plan view.
2. Click Modify | Structural Framing tab ➤ Modify panel ➤ Rotate.
3 Click the start point and the endpoint for the rotation. For more information, see Rotating Elements on page 1481.

**Beam Graphical Controls**

When you sketch beams, you can use available graphical controls to modify the attachment points between each beam and the structural element (column, structural wall).

You can either set the location of the controls when creating the beam or select and manually adjust it after the beam is created.

**Beam Handles**

The beam handles of a beam are the attachment points of the beam. Beam handles display as small filled circles that indicate where the end of the selected beam is attached to a column or wall.

**NOTE** Moving beam handles changes cope length.

Beam and column in plan with a beam handle at the column center

Columns have an invisible bounding box that controls the beam handle location.

The following illustration presents a section view of a beam that is attached to a wall. The beam handle is visible at the top center of the wall.
The beam is constrained by level. As a result, beam attachment can be changed in a horizontal direction only.

**Changing Beam Geometry Using Shape Handles**

The shape handle of a beam is used to change beam geometry. Shape handles display as small, filled back-to-back triangles at each beam end when the beam is selected in the drawing area.
You can adjust the endpoint location of a beam using shape handles. This lengthens or shortens the beam. The other end of the beam remains fixed.

Shape handles change geometry along the axis of the component. To move a beam out of its original axis, click and drag the beam into a new position.

Each beam shape handle provides properties that can be changed, based on the element type preferences. To access the shape handle properties, right-click the back-to-back triangles, and select Properties.

Using shape handles manually adjusts the beam cutback settings. See also Cutback on page 275.

**Moment Symbols**

The moment parameters of a beam (Connection Start or Connection End) enable the display of moment frame or cantilever connection symbols. These parameters refer to the applicable beam endpoint. The available options for these parameters are: None, Moment Frame, or Cantilever Moment.
To display a moment symbol

1 Right-click on a beam, and select Properties.
2 On the Properties palette, under Structural, select a value for Start Connection or End Connection, and click Apply.

Moment frame symbol displayed by using a moment connection parameter

Cantilever connection symbol displayed by using a moment connection parameter

You load and assign connection symbol families in the Symbolic Representation Settings Tab on page 1605.

Beam Tags

Beam tagging is an integral part of a structural framing plan. Designing a structure requires labeling from the simple to the complex. Revit beam tags provide for this informational labeling.

Structural Framing Tag Families

The structural framing tag family annotates beams. You can adjust the default positions of these tags in the Family Categories and Parameters dialog. See Family Category and Parameters on page 695.

The Structural Framing Tag category contains 2 parameters.

Rotate with component: When selected, the tag rotates with its beam. When deselected, the tag orientates itself with respect to the View Frame.

Attachment Point: Defines the initial location of the tag along a beam (start, middle, or end) and is the point the tag tracks as the beam is lengthened and shortened.

| Start | Middle | End |

When enabled, a tag leader extends from this point.
Beam Annotations Tool

The Beam Annotations tool allows you to place multiple beam tags, annotations, and spot elevations on selected beams or all beams in the current view. It is only available when working in a structural plan or ceiling plan view. Structural Framing Tags that are set to Rotate with Component must be loaded for the dialog to launch.

To access the Beams Annotations tool, click Annotate tab ➤ Tag panel ➤ Beam Annotations.

Placement

The Placement section of the Beam Annotations tool allows you to specify which beams you intend to annotate (either all in view or just the beams selected). As noted on the Beam Annotations tool, Revit Structure does not overwrite existing tags.

To place new annotations in place of others, select Remove existing beam tags and spot elevations. All tags and spot elevations will be removed from beams and replaced by those currently set in the Beam Annotations tool. When deselected, no annotations will be placed on the beams.

Placement Settings: Click the Settings button to open the Placement Settings dialog and adjust the offset of tags and spot elevations from beams.

The Horizontal End Offset and Vertical Offset settings adjust the distance of tags and spot elevations from their attachment points (see Structural Framing Tag Families on page 262) by the entered measurement. This measurement is representative of the drawing scale and its default is 0” horizontally and 3/8” vertically.

Annotation Location and Type

The lower section of the Beam Annotations tool defines the annotation types and locations specific to level and sloped beams.

Level/Sloped Beams Tabs: Both level beams and sloped beams use the same tagging options. The tabs allow you to make different annotations to either type of beam instance.

To make specific tags to level beams, make adjustments on the Level beams in plan tab.
To make specific tags to sloped beams, make adjustments on the Sloped beams in plan tab.

**Annotation Location:** At the center of the tabbed page is an image of a beam surrounded by six text fields. The fields represent the locations of the tags as they appear around the beam. The buttons open the Select Annotation Type dialog which defines and edits the tag.

**None:** Tags do not track any particular point on the beam. Changes to the length of the beam do not cause the tag to move.

**Structural Framing Tag:** See Structural Framing Tags on page 265.

**Spot Elevation:** See Spot Elevations on page 265.
**Structural Framing Tags**

This selection enables a pull down menu of available structural family tags specific to the selected location along the beam. Specific family parameters determine which tags display. Qualifying framing tags must have the following parameters (see Structural Framing Tag Families on page 262) to be a viable annotations type:

- Rotate with Component is selected.
- The Attachment Point parameter is set to <None> or matches the position of the desired tag location in the Beam Annotations tool.

For example, structural framing tags which have defined Attachment Point parameters of End are only available to the beam location settings marked <End> in this tool.

Structural framing tags with attachment points of <None> are available to only the Middle location settings provided they rotate with component.

These specifications also apply to the <Load Structural Framing Tag> option, which opens the Load Family dialog (see Loading Families on page 688).

To appear in the Structural Framing Tag list, loaded families must follow these guidelines.

**Spot Elevations**

The Spot Elevations tool allows the placement of spot elevations when the type parameter Rotate with Component is selected. This is similar to tags in that they are filtered by this parameter.

**Beam Elevation (Project)** calculates elevation from the lowest level of the project.

Create/modify types gives you the option of creating a custom spot elevation. When selected, the Family Type Properties dialog opens to edit the spot elevation tag.

**Beam Elevation (Relative)** enables the Relative Base drop-down list, which allows selection of the base relative level for elevation calculation.

**NOTE** Only one spot elevation type can be placed at a time. If you change the spot elevation type in any of the 12 locations (6 for the level and 6 for sloped), it will change all 12 spot elevation type settings in the Beam Annotations tool.
The Display Elevation drop-down list selects the location of elevation measurement on the beam.

**Actual (Selected) Elevation**

```
Level 2
10' - 0"
```

**NOTE** Actual (Selected) Elevation tags the elevation of the location line, not the beam geometry.

**Bottom Elevation**

```
Level 2
10' - 0"
```

```
B 8' - 7 3/4"
```

**Top & Bottom Elevations**

```
Level 2
10' - 0"
```

```
T 9' - 8"
B 8' - 7 3/4"
```

**Top Elevation**

```
Level 2
10' - 0"
```

```
T 9' - 8"
```

The final option available in the Select Annotation Type dialog for spot elevations is a filter for defined elevations.
This option enables a filter that prevents spot elevations from being created if it equals the entered value. The default setting is 0 units as defined by the project.

**Beam Properties**

Several properties for beams, including work plane, materials, and angle, are accessible on the Properties palette.

**Modifying Beam Properties**

To modify beam properties

1. Select the beam.
2. On the Properties palette, edit beam instance parameters. (See Beam Instance Properties on page 269.)
3. Click Apply.
4. To edit beam type parameters, on the Properties palette, click Edit Type. (See Beam Type Properties - Steel on page 267 or Beam Type Properties - Concrete on page 268.)

**NOTE** Changes made to type parameters affect all beams of this type in the project. Click Duplicate to create a beam type.

**Beam Type Properties - Steel**

Properties vary depending on the specified beam families during the installation process. The following type properties apply to the steel beam families that load during a typical installation:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>A</td>
<td>Section area.</td>
</tr>
<tr>
<td>W</td>
<td>Nominal weight.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>bf</td>
<td>Flange width.</td>
</tr>
<tr>
<td>d</td>
<td>Actual depth of section.</td>
</tr>
<tr>
<td>k</td>
<td>k distance.</td>
</tr>
<tr>
<td>k2</td>
<td>k2 distance. This is a read-only value.</td>
</tr>
<tr>
<td>tf</td>
<td>Flange thickness.</td>
</tr>
<tr>
<td>tw</td>
<td>Web thickness.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from a hierarchical list.</td>
</tr>
</tbody>
</table>
### Name | Description
--- | ---
Keynote | The beam keynote. Add or edit the value. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.
Model | The manufacturer internal number.
Manufacturer | The shape manufacturer.
Type Comments | A field for entering general comments about the shape type. This information can be included in a schedule.
URL | A link to a web page that may contain type-specific information.
Description | Description of the beam. Enter a description.
Assembly description | Description of the assembly based on the assembly code selection. This is a read-only value.
Type Mark | A value that designates the particular beam; possibly the shop mark. This value must be unique for each element in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.
Cost | The pricing of the beam.
OmniClass Number | The number from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.
OmniClass title | The name from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.

### Beam Type Properties - Concrete

Properties will vary depending on the beam families that are specified during the installation process. The following type properties apply to the concrete beam families that load during a typical installation:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>b</td>
<td>Beam width.</td>
</tr>
<tr>
<td>h</td>
<td>Beam depth.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td>Keynote</td>
<td>The beam keynote. Add or edit the value. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The shape manufacturer.</td>
</tr>
</tbody>
</table>
Beam Instance Properties

Properties will vary depending on the beam families that are specified during the installation process. The following instance properties apply to beam families that load during a typical installation:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Reference Level</td>
<td>The constraining level. This is a read-only value that is dependent on the work plane on which the beam was placed.</td>
</tr>
<tr>
<td>Work Plane</td>
<td>The current plane on which elements are placed. This is a read-only value.</td>
</tr>
<tr>
<td>Start Level Offset</td>
<td>The distance of the beam start point from the reference level. Values entered here are reset when the member is pinned. Read-only when pinned.</td>
</tr>
<tr>
<td>End Level Offset</td>
<td>The distance of the beam endpoint from the reference level. Values entered here are reset when the member is pinned. Read-only when pinned.</td>
</tr>
<tr>
<td>z-Direction Justification</td>
<td>Either center, top, bottom, or other. Selecting the option other enables an additional parameter, z-Direction offset value.</td>
</tr>
<tr>
<td>z-Direction Offset Value</td>
<td>The numeric value that offsets the geometry.</td>
</tr>
<tr>
<td>Lateral Justification</td>
<td>The location of the physical geometry (in plan) with respect to the location line. Either Side 1, Side 2 and Center. Read-only when pinned.</td>
</tr>
<tr>
<td>Orientation</td>
<td>The beam orientation to the current plane on which elements are placed. This is a read-only value.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Cross-Section Rotation</td>
<td>Parameter that controls rotating beams and braces. The angle of rotation is measured from the beam’s work plane and the direction of the center reference plane.</td>
</tr>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Start Extension</td>
<td>Applies to steel beams only. The dimension between the edge of the start end of the beam and the element to which it is connected.</td>
</tr>
<tr>
<td>End Extension</td>
<td>Applies to steel beams only. The dimension between the edge of the finish end of the beam and the element to which it is connected.</td>
</tr>
<tr>
<td>Materials and Finishes</td>
<td></td>
</tr>
<tr>
<td>Beam Material</td>
<td>The structural material. See Material Physical Type Parameters on page 1597.</td>
</tr>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Stick Symbol Location</td>
<td>Applies to steel beams only.</td>
</tr>
<tr>
<td>Moment Connection Start</td>
<td>Applies to steel beams only. A moment frame, or cantilever symbol at the start end of a beam.</td>
</tr>
<tr>
<td>Moment Connection End</td>
<td>Applies to steel beams only. A moment frame, or cantilever symbol at the finish end of a beam.</td>
</tr>
<tr>
<td>Cut Length</td>
<td>The physical length of the beam. This is a read-only value.</td>
</tr>
<tr>
<td>Structural Usage</td>
<td>Specifies the usage. Either Girder, Horizontal bracing, Joist, Other, or Purlin.</td>
</tr>
<tr>
<td>Start Attachment Type</td>
<td>Either End Elevation or Distance. Specifies the elevation orientation of the beam. End Elevation maintains the placement level and Distance orients to the join location on a column. See Beam Elevation at Column Join on page 285.</td>
</tr>
<tr>
<td>Start Attachment Distance</td>
<td>Specifies the offset of the beam start from the column connection point when Start Attachment Type is set to Distance. See Beam Elevation at Column Join on page 285.</td>
</tr>
<tr>
<td>End of Referenced Column</td>
<td>Specifies either the Top or Bottom of the beam from which the Start Attachment Distance is determined. See Beam Elevation at Column Join on page 285.</td>
</tr>
<tr>
<td>End Attachment Type</td>
<td>Either End Elevation or Distance. Specifies the elevation orientation of the beam. End Elevation maintains the placement level and Distance orients to the join location on a column. See Beam Elevation at Column Join on page 285.</td>
</tr>
<tr>
<td>End Attachment Distance</td>
<td>Specifies the offset of the beam end from the column connection point when End Attachment Type is set to Distance. See Beam Elevation at Column Join on page 285.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>End of Referenced Column</td>
<td>Specifies either the Top or Bottom of the beam from which the End Attachment Distance is determined. See <strong>Beam Elevation at Column Join</strong> on page 285.</td>
</tr>
<tr>
<td>Rebar Cover - Top Face</td>
<td>Applies to concrete beams only. The rebar cover distance from the beam top face.</td>
</tr>
<tr>
<td>Rebar Cover - Bottom Face</td>
<td>Applies to concrete beams only. The rebar cover distance from the beam bottom face.</td>
</tr>
<tr>
<td>Rebar Cover - Other Faces</td>
<td>Applies to concrete beams only. The rebar cover distance from the beam to adjacent element faces.</td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Specifies the estimated reinforcement volume of the selected element. This is a read-only parameter that only displays when rebar has been placed.</td>
</tr>
<tr>
<td>Camber Size</td>
<td>Applies to steel beams only. The beam camber.</td>
</tr>
<tr>
<td>Number of Studs</td>
<td>Applies to steel beams only. The number of studs per beam.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td>The length between beam handles. See <strong>Beam Handles</strong> on page 259. This is the analytical length of the beam. This is a read-only value.</td>
</tr>
<tr>
<td>Volume</td>
<td>The volume of the selected beam. This is a read-only value.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>User comments.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label created for the beam. Possible use: shop mark. This value must be unique for each element in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See <strong>Reviewing Warning Messages</strong> on page 1680.</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Indicates in which phase the beam component was created. See <strong>Project Phasing</strong> on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Indicates in which phase the beam component was demolished. See <strong>Project Phasing</strong> on page 877.</td>
</tr>
<tr>
<td>Structural Analysis (see Structural Analytical Model Overview on page 1277)</td>
<td></td>
</tr>
<tr>
<td>Start Release</td>
<td>Start release conditions. Either Fixed, Pinned, Bending Moment, or User Defined. User Defined allows you to enable/disable each of the start release conditions.</td>
</tr>
<tr>
<td>Start Fx</td>
<td>Translational release at the start end of the beam along the x-axis.</td>
</tr>
<tr>
<td>Start Fy</td>
<td>Translational release at the start end of the beam along the y-axis.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Start Fz</td>
<td>Translational release at the start end of the beam along the z-axis.</td>
</tr>
<tr>
<td>Start Mx</td>
<td>Rotational release at the start end of the beam along the x-axis.</td>
</tr>
<tr>
<td>Start My</td>
<td>Rotational release at the start end of the beam along the y-axis.</td>
</tr>
<tr>
<td>Start Mz</td>
<td>Rotational release at the start end of the beam along the z-axis.</td>
</tr>
<tr>
<td>End Release</td>
<td>End release conditions. Either Fixed, Pinned, Bending Moment, or User Defined. User Defined allows you to enable/disable each of the end release conditions.</td>
</tr>
<tr>
<td>End Fx</td>
<td>Translational release at the end of the beam along the x-axis.</td>
</tr>
<tr>
<td>End Fy</td>
<td>Translational release at the end of the beam along the y-axis.</td>
</tr>
<tr>
<td>End Fz</td>
<td>Translational release at the end of the beam along the z-axis.</td>
</tr>
<tr>
<td>End Mx</td>
<td>Rotational release at the end of the beam along the x-axis.</td>
</tr>
<tr>
<td>End My</td>
<td>Rotational release at the end of the beam along the y-axis.</td>
</tr>
<tr>
<td>End Mz</td>
<td>Rotational release at the end of the beam along the z-axis.</td>
</tr>
<tr>
<td>Analyze as</td>
<td>Used by external analysis applications to determine whether beam conditions contribute to lateral analysis. See Projection Plane Options for each Structural Element Type on page 1301.</td>
</tr>
</tbody>
</table>

**Analytical Model**

**Vertical Projection**

Either Auto-detect, Location Line, Top of Beam, Center of Beam, Bottom of Beam, <Named Reference Plane>, or <Level>. Extends the beam analytical model to the level specified, in the Z direction. See Automatic Adjustment of the Analytical Model (Auto-Detect) on page 1288.

**Rigid Links**

Either Yes, No, or From Column. Infinitely rigid frame element with no weight. When Rigid Links is enabled, an additional analytical segment is engaged in the model between the end of the analytical model of a beam and the analytical model of a column. From Column defines the rigid link of the beam to that of its connected column. See Rigid Link on page 1283.

**Horizontal Projection**

Either Auto-detect, Default, Center Line, Location Line, <Named Reference Plane>, or <Grid>. Specifies the horizontal limits of the beam analytical model.

**Other**

**Start Extension Calculation**

Applies to steel beams only. Specifies family parameters; defines maximum distance of start extension parameter. This is a read-only value.

**End Extension Calculation**

Applies to steel beams only. Specifies family parameters; defines maximum distance of end extension parameter. This is a read-only value.
Joins and Cutback on Framing Elements and Columns

This section details the concepts and the procedures to adjust how framing elements join and cut back from one another in Revit Structure. While most elements adhere to these approaches, they may behave differently depending on their unique instance and settings. These differences are detailed here and in the sections dedicated to framing-specific elements.

Related topics
- Structural Columns on page 218
- Beams on page 247
- Braces on page 310
- Trusses on page 320

Bounding Boxes

Before describing how structural framing elements join, attach, and cut back from one another, it is important to understand how component families are perceived in a Revit project. Each element instance is enclosed in a bounding box.

Overview

The bounding box is an invisible 3D rectangular space that contains all model elements, annotation elements, and datum elements defined in a family-based element. Datum extents are the exception. For example, a horizontal reference plane will only affect a top or bottom of the bounding box, not either of its sides. The bounding box is oriented with respect to the family definition.

Bounding boxes of columns represented in orange

The top, bottom, and sides of the bounding box rotate accordingly to maintain its relationship with the element as it rotates.
Bounding boxes rotating with elements

General purposes of the bounding box

- If a family does not have a family origin explicitly defined, the origin will default to the center of the bounding box. This origin affects placement of instances and their behavior when the instance type or family is changed. For detailed information about family origins, see The Families Guide on page 680.

- The bounding box helps define the joining and cutback of structural framing elements.

Curved Beams

Curved beams present a unique instance of the bounding box. The bounding box bends to meet the needs of the beam. This provides accurate joining and cutback with the beam.

Beam to Column Joins

The following illustration shows an example of a beam that is not centered on a column. The beam handle of the beam in the illustration remains within a bounding box. Remember, the bounding box is not visible.

If the column is moved slightly, but not completely out of its existing bounding box, the beam handle remains in position, unaffected by column movement.
However, if the column is moved out of its bounding box, the beam handles snap to the center of the column. When placed, the column will maintain a bounding box.

![Diagram of beam cutback](image)

**Cutback**

Beam cutback is the visible representative gap in beam geometry at the connection point in join relationships. Fabricated materials require spatial and placement considerations for which they will be cut to fit. This gap is evident when comparing the conceptual coarse (symbolic) view to the medium/fine view of non-concrete beams.

Revit Structure adjusts the setback and cutback for non-concrete beams based on default cutback settings. Concrete beams take precedence in mixed material joins, forcing non-concrete beams to set back and cut back.
The shortest beam in a join extends to the furthest boundary of all joined beams. All other beams cut back. See Beam to Beam Cutback on page 277.

<table>
<thead>
<tr>
<th>Coarse level of detail (symbolic)</th>
<th>Medium/Fine level of detail (physical geometry)</th>
</tr>
</thead>
</table>

**KEY**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Beam into which others are framed</td>
</tr>
<tr>
<td>B</td>
<td>Cutback beam</td>
</tr>
<tr>
<td>C</td>
<td>Common endpoint in join</td>
</tr>
<tr>
<td>D</td>
<td>Cutback</td>
</tr>
<tr>
<td>E</td>
<td>Cutback</td>
</tr>
<tr>
<td>F</td>
<td>Beam end if cutback</td>
</tr>
<tr>
<td>G</td>
<td>Setback</td>
</tr>
</tbody>
</table>

**Bounding Box Considerations**

Cutback is affected by the bounding box of an element. Notice how the beams framed into the L-beam adjust based on its rotation.

An L-beam framed into by 2 beams
The same L-beam rotated 45 degrees

The extents of the bounding box force the framing lengths of the joined beams accordingly.

**Modifying Beam Symbolic (Coarse Level of Detail) Cutback**

Change structural cutback defaults for beams, columns, and braces with the Structural Settings dialog.

1. Click Manage tab ➤ Settings panel ➤ Structural Settings.
2. Select the Symbolic Representation Settings tab.
3. In the Symbolic Cutback Distance fields, adjust for braces, beams/trusses, and columns as needed.

These global parameters adjust the structural symbolic lines used in coarse level of detail views. Changes apply to all beams, trusses, braces, and columns. See Changing Beam Geometry Using Shape Handles on page 260 to manually configure cutback.

**Modifying Beam Instance (Medium/Fine Level of Detail) Cutback**

Set default cutback settings for beam instances on the Properties palette.

1. Select a beam instance (or instances).
2. On the Properties palette, under Construction, locate the Start Extension and End Extension parameters. Adjust as needed.

These parameters adjust the cutback of beam instances used in medium/fine level of detail views. Positive dimensions entered here extend the beam, effectively reducing the cutback. Negative values increase the cutback. Adjustments do not affect symbolic representation. See Changing Beam Geometry Using Shape Handles on page 260 to manually configure cutback.

**Beam to Beam Cutback**

Setback and cutback apply when connecting beams. Beams connect at their endpoints, and multiple beams can connect to one endpoint.

An end join connection is achieved when 2 or more endpoints snap together or when the endpoint of a beam is an origin point when you draw another beam. Structural beams drawn with the Chain option also connect by their endpoints. See Sketching Beams with the Chain Option on page 254.

When 2 beams are end-joined at an angle, the shortest beam will not cut back, forcing the longer beams to cut back. The setback of the shortest beam also adjusts to meet the perceived endpoint of the longer beam. If further beams connect to the join, they will cut back from the shortest beam. If the new beam is shorter, the join reconfigures so that the longer beams frame into the shortest beam. You can edit this visual representation of a cutback with the Beam Join Editor.
Beam to Column Cutback

Setback and cutback apply when connecting beams to structural columns. The beams are independent of one another, are only associated with the common column, and will cut back from the column accordingly. The column, including its bounding box, must have overlapping geometry with the beams of the join for the beams to cut back.

Beams joined to columns always adjust for setback and cutback, yet vertical columns cannot manually be adjusted with the Beam/Column Join Editor.
Beam to Wall Cutback

Setback and cutback apply when connecting beams to structural walls. The beams are independent of one another, are only associated with the common wall, and will cut back from the wall accordingly. Recessing the beam into a beam pocket is possible by removing the cutback with the Beam Join Editor.

<table>
<thead>
<tr>
<th>Cutback Beam to Wall Join</th>
<th>Non-cutback Beam to Wall Join</th>
</tr>
</thead>
</table>

Joining a beam to a wall is achieved by drawing a beam and attaching one of its endpoints to the center of the total wall thickness.

Brace and Truss Cutback

Braces adjust for default setback and cutback through Properties or Structural Settings. Trusses only adjust with Structural Settings. The Beam Join Editor can be used on truss chords. Truss webs and braces cannot be modified by the editor.
Column Cutback

Columns can be set back and cut back using the Beam/Column Editor. With the exception of the following rules, columns act as beams in the default setback and cutback settings.

- Currently, columns cut back from beams but not from one another. Beams will frame into a column when joined at the column top.
- Mitering between beams and columns is not currently implemented.
- When multiple cutback beams share a join with a column, they will frame into the column. However, if the column is cut back, the shortest beam will extend and be framed into by others in the join.
- When a beam is framed into by a column, the symbolic line will extend one cutback distance beyond its endpoint.

Related topics

- Beam to Column Joins on page 274
- Beam to Column Cutback on page 278
- Adjusting Slanted Column Geometry End Position and Trim on page 232
Beam Joins

There are 2 types of beam end joins: square-off and miter. The Beam Join Editor adjusts both by removing or applying the visible cutback as it displays in your project.

Square-off Joins

In square-off joins, the ends of beams and braces maintain a plane perpendicular to the centerline of the element. The beam into which others frame does not cut back, while its connecting beams cut back as warranted. This beam will cut back from a neighboring beam. When cut back, a beam will adjust in a way that prevents it from being closer to any other beam participating in the join by a distance equalling the cutback.

The following examples detail both coarse and medium/fine levels of detail in a project.

<table>
<thead>
<tr>
<th>Coarse level of detail (symbolic)</th>
<th>Medium/Fine level of detail (physical geometry)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Coarse level of detail" /></td>
<td><img src="image2" alt="Medium/Fine level of detail" /></td>
</tr>
</tbody>
</table>

Miter Joins

Unlike square-off joins, miter joins do not cut back, allowing geometry to create a flush connection between 2 beams.

<table>
<thead>
<tr>
<th>Coarse level of detail (symbolic)</th>
<th>Medium/Fine level of detail (physical geometry)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image3" alt="Coarse level of detail" /></td>
<td><img src="image4" alt="Medium/Fine level of detail" /></td>
</tr>
</tbody>
</table>
The 2 beams must be co-planar to create a miter join. They must also be of the same family type. Any other beams that share the join will cut back accordingly.

Beams in a co-planar join share the same plane and have unadjusted cross-sectional rotation parameters.

Beams that share the same vertical plane must have the same cross-sectional rotation to have a miter join. The vertical plane is a plane perpendicular to the work plane. A miter join will be created by default for beams that are created within the same vertical plane. This is the case for trusses.

Other beam join considerations include the following.

- Hidden lines within the beam family do not trim or extend to a miter plane.
- Beam shape handles do not participate in extensions.
- The Beam/Column Join Editor is not available when a concrete beam is participating in the end join.
- Mitered beams are cut by the Cut Plane in Plan Views using Medium/Fine Detail Level. This continues if the miter join is removed.
Adjusting Cutback

1 Open a project to a plan or 3D view.
2 Click Modify tab ➤ Edit Geometry panel ➤ Beam/Column Joins.

The editing mode activates, showing cutback arrow controls at the end join of beams (and columns if applicable, see Column Cutback on page 280).

3 On the Options Bar, filter the visible join controls based on Steel, Wood, Precast Concrete, and Other materials if necessary.
4 Click the cutback arrow controls to change the cutback in the direction the arrow is pointing.

- If a beam is cut back, the arrow points toward the join.
- If a beam is not cut back, the arrow points away from the join.

NOTE Adjusting cutback with the Beam Join Editor will not reset or change default extension settings in Element Properties, Symbolic Cutback Distance settings, or shape handle beam geometry adjustments.

In this mode, beams without common end joins display in halftone. (Only shared end joins display arrow controls.) If a perceived end join displays in halftone, exit the Beam Join Editor and correct the endpoints. One way to determine whether beams are end-joined is to select each beam with the Modify tool. If their common endpoint appears, they are end-joined.

5 On the Quick Access toolbar, click (Modify) when complete.

Creating a Miter Join

Miter joins are created by removing the cutback from 2 end-joined beams.

1 Open a project to a plan or 3D view.
2 Click Modify tab ➤ Edit Geometry panel ➤ Beam/Column Joins.

The editing mode activates, showing cutback arrow controls at the end join of beams.
3 On the Options Bar, filter the visible join controls based on Steel, Wood, Precast Concrete, and Other materials if necessary.

4 Click the appropriate arrow controls to remove the cutback from both beams.

![Diagram of beam join controls]

**NOTE** Remember that a miter join is only available to co-planar beams of the same family and type without cross-sectional rotation. See Miter Joins on page 281.

The green line marks the plane of the miter join. Any other beams cut back to adjust from the miter join.

5 Optionally, click the Miter Lock to lock the geometry in Medium/Fine levels of detail, so you can adjust the symbolic representation.

![Diagram of locked miter joins]

When locked, the Beam Join Editor arrows do not display in Medium/Fine views but do display in Coarse view.
6 On the Quick Access toolbar, click \( \text{Modify} \).

**Beam Elevation at Column Join**

You can define how a beam parametrically repositions vertically when a joined column is resized. The beam instance properties Start Attachment Type and End Attachment Type specify how the beam ends are oriented. You can set either attachment type to End Elevation (the default) or Distance.

End Elevation orients the beam ends to the elevation on which the beam was modeled. The following illustration shows the Start Attachment Type set to End Elevation and the left column shortened.

Distance orients the beam ends to the location of the column join. The following illustration shows the Start Attachment Type set to Distance and the left column shortened.
If necessary you can specify which column end is being referenced with the End of Referenced Column instance property. This is defined as top or bottom and can be set for both the end and start attachment of the beam.

Additionally, you can offset a distance attachment type by defining the Start Attachment Distance and End Attachment Distance instance properties. This offset is determined from the End of Referenced Column property. The following illustration shows both the Start and End Attachment Distances defined.

---

**Beam Systems**

Structural beam systems create a single structural framing element that contains a series of individual beams placed in parallel. The beam system provides a quick method for framing an area of a structure that requires additional support. There are 2 ways to create a beam system, using either the one-click method or by sketching:

- The one-click beam system method is active by default. See Creating a One-Click Beam System on page 288.
- You can also sketch beam systems into a model. See Creating a Structural Beam System on page 287.
Creating a Structural Beam System

You can create a structural beam system either by picking the structural supporting elements, such as beams and structural walls, or by sketching the border. After specifying the beam system boundaries, you can specify the beam direction and beam system properties, such as spacing, justification, and beam type. For more information, see Beam System Layout Rules and Patterns on page 299.
To create a structural beam system

1. Click Home tab ➤ Structure panel ➤ Beam System.

2. Click Modify | Create Beam System Boundary tab ➤ Beam System panel ➤ Sketch Beam System.

3. Define the beam system boundary. For more information, see Defining the Boundary of a Structural Beam System on page 289.

4. Specify beam direction. For more information, see Specifying Beam Direction in a Beam System on page 295.

5. Specify beam system properties. For more information, see Modifying Beam System Properties on page 308.

6. Click Modify | Create Beam System Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

Creating a One-Click Beam System

You can create beam systems quickly, with one mouse click, as long as the following conditions are met:

- The one-click beam system can only be added in plan or ceiling view with a horizontal sketch plane. If the view or the default sketch plane is not a level and you click Beam System, you are redirected to the Create Beam System Boundary tab.

- There must be a closed loop of supporting elements (walls or beams) already drawn, or the program will automatically redirect you to the Create Beam System Boundary tab. For more information, see Beam System Layout Rules and Patterns on page 299.

**WARNING** Curved walls and beams can be used to create a loop, but cannot be the direction defining members in the Beam System.

To create a beam system, using one click

1. Click Home tab ➤ Structure panel ➤ Beam System.

2. Click Modify | Create Beam System Boundary tab ➤ Beam System panel ➤ Automatic Beam System.

   **NOTE** If you would like to sketch the beam system by hand, click Modify | Create Beam System Boundary tab ➤ Beam System panel ➤ Sketch Beam System to open the Draw panel.

3. On the Properties palette:
   - Under Pattern, select a Beam Type.
   - Under Pattern, for Layout Rule, define the beam system spacing requirements.
   - If the beam system will be sloped or uneven in relation to the level, select the 3D option.

   **NOTE** If you want the walls of the structure in your project to define the slope of the 3D beam system, from the Options Bar, select Walls Define Slope.

4. (Optional) Define beam system tags for the placed system. See Tagging Beam Systems on Placement on page 304.

5. Move your cursor to the structural members where you would like to add the beam system and click to add it.
NOTE The beam system will align its direction parallel to the nearest structural member you selected.

In the example shown above, you should not
- Add a beam system that spans multiple quadrants. The intersecting beams would not cut the beam system, therefore, any intersections between girders and joists in such a beam system would not display.
- Copy and paste the beam system from quadrant to quadrant if their area, shape, and number of supports differ significantly.

For information about Beam System Properties, see Beam System Type Properties on page 309.

**Defining the Boundary of a Structural Beam System**

To define the boundary of a structural beam system, you can pick the structural supporting elements that exist on the edge of the proposed beam system, or you can use the drawing tools to sketch the lines. Of the 2 methods, you should try to use the Pick Supports tool whenever possible. When you pick the supports, the beam system is automatically locked to those elements. Any changes to the location of the supporting elements are automatically applied to the beam system.

*Creating a beam system by picking supports*
Creating a beam system by sketching lines

You can define the beam system boundary in either a plan or 3D view. If you work in a 3D view, you should specify the work plane before picking the supports. For more information, see Setting the Work Plane on page 1517.

**TIP** Although you can sketch a beam system in a 3D view, it is recommended that you create the beam system in a plan view to achieve greater accuracy and to ensure that the lines are on a parallel plane.

After the beam system boundary is defined, the beams are placed inside the specified area according to the pattern specified in the beam system properties. For more information, see Modifying Beam System Properties on page 308.

**Picking Supports as the Beam System Boundary**

In either a plan or 3D view, you can pick structural beams and walls to define the boundary of the structural beam system.

1. Click Home tab ➤ Structure panel ➤ Beam System.
2. Click Modify | Place Structural Beam System tab ➤ Beam System panel ➤ Sketch Beam System.
3. Click Draw panel ➤ Pick Supports.

**TIP** When picking supports, the first support you pick specifies the beam direction. The beams within the beam system will be parallel to this beam. You can modify this at any time. See Modifying a Beam System on page 308.

4. Pick the first support member.
   A sketch line with 2 drag handles displays over the picked support. Two shorter parallel lines display on each side of the line, indicating the beam system direction.
5 Pick the remaining lines that define the beam system boundary.

**NOTE** The lines must result in a closed loop. Use the editing tools (Trim, Extend, and so on) on the Options Bar as necessary to create a closed loop of sketch lines. For more information, see Editing Elements on page 1439.

After specifying the beam system boundary, you can

- Modify the beam direction if necessary. For more information, see Specifying Beam Direction in a Beam System on page 295.
- Modify beam system properties if necessary. See Modifying Beam System Properties on page 308.
- Use either the Pick Support or Lines tool to sketch an opening in the beam system. For more information, see Cutting an Opening in a Beam System on page 294.

6 Click Modify I Create Beam System Boundary tab ➤ Mode panel ➤ Finish Edit Mode.
Sketching a Beam System Boundary

You can use the sketching tools to define the perimeter of a beam system. You can also use these tools to modify a beam system boundary, created using the Pick Supports method.

1. Click Home tab ➤ Structure panel ➤ Beam System.
2. Click Modify | Place Structural Beam System tab ➤ Beam System panel ➤ Sketch Beam System.
3. Click Draw panel ➤ Line to sketch, or click Draw panel ➤ Pick Lines to select existing lines.
4. Draw or pick the lines that define the beam system boundary.

Sketched beam system boundary with lines locked to supports

RELATED For more information, see Sketching on page 1405.
After specifying the beam system boundary, you can

- Modify the beam direction if necessary. For more information, see Specifying Beam Direction in a Beam System on page 295.
- Modify the beam system.
- Use either the Pick Support or Lines tool to sketch an opening in the beam system. For more information, see Cutting an Opening in a Beam System on page 294.

5 Click Modify | Create Beam System Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

Floor plan and 3D view of completed structural beam system

Creating Beam Systems for Non-Identical Boundaries

When creating a beam system, if both areas are not identical in shape and supports, then the pasted beam system area may not attach to supports as expected. In such a case, you may need to modify the beam system.

In the plan view illustrated below, notice that there are 4 distinct quadrants. Quadrants 1 and 2 are identical in area and support structure. Quadrants 3 and 4 are more complex.
In the example shown above, you could

- Add a separate beam system to each quadrant. This is the best action to take because you can ensure that the beam system boundaries are locked to the supporting members by using the Pick Supports tool.

- Add a beam system to Quadrant 1 and copy it to Quadrant 2. You can do this since the area and support structure is identical. However, make sure the pasted copy attaches to all supports. You may need to modify the pasted beam system.

- Add a beam system to Quadrants 1 and 3 and mirror it to Quadrants 2 and 4 by selecting Grid 2 as the mirror axis. This process has the same limitations as copying and pasting. You may need to modify the system and re-pick the supports to ensure that the system is locked to a supporting member.

In the example shown above, you should not

- Add a beam system that spans multiple quadrants. The intersecting beams 2 and B would not cut the beam system; therefore, any intersections between girders and joists in such a beam system would not display.

- Copy and paste the beam system from Quadrant 1 to Quadrant 3. The area, shape, and number of their supports differ significantly.

**Cutting an Opening in a Beam System**

You can cut an opening in a structural beam system by sketching a loop of lines inside the beam system boundary.

To cut an opening in a beam system

1. Select the beam system, and click Modify | Structural Beam System tab ➤ Mode panel ➤ Edit Boundary.
2. Click Modify | Structural Beam Systems tab > Edit Boundary ➤ Draw panel ➤ Line. Define the boundary of the opening.
3. Using the additional sketching tools available on the Draw panel and Options Bar, sketch a complete loop within the beam system boundary.
Specifying Beam Direction in a Beam System

When sketching a beam system boundary, you can specify the beam direction within the structural beam system. All beams within the beam system will be parallel to the boundary line you select.

**NOTE** Walls and beams curved in plan view cannot be used to define the direction of a beam system.

To specify beam direction:

1. Select the beam system, and click Mode panel ➤ (Edit Boundary) on the ribbon.
2 Click Draw panel ➤  (Beam Direction) on the ribbon.
3 Select from one of the following tools on the Draw panel of the ribbon:

<table>
<thead>
<tr>
<th>If you select...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Line]</td>
<td>sketch a line, or pick a model line, to define beam direction that is independent of the sketched boundary lines. This line has no other function than to define the direction of the beams in a beam system and therefore cannot be used to close a loop. Select the sketch line to which you want all beams to be parallel.</td>
</tr>
<tr>
<td>![Pick Lines]</td>
<td>select the sketch line to which you want all beams to be parallel.</td>
</tr>
<tr>
<td>![Pick Supports]</td>
<td>select the beams or structural walls to which you want all beams to be parallel.</td>
</tr>
</tbody>
</table>

The following image shows the selected sketch line and the resulting beam direction.

![Image of beam system with sketch line and resulting beam direction]

**Defining Beam System Justification**

After you place a beam system, you can determine the placement of the first beam in the system. Each subsequent beam is spaced a fixed distance from that point.

**To specify beam system justification:**

1. Select the beam system.
2. On the Properties palette, under Pattern, select Fixed Distance or Clear Spacing layout rule values.
3. (Optional) Specify a new direction line for the beam system direction.
4. On the Properties palette, under Pattern, select a justification: Beginning, End, Center, or Direction Line.

**NOTE** In the following illustrations, green arrows indicate the direction of justification.
If you select Beginning, the first beam at the top or to the left of the beam system is used for justification.

**Horizontal Orientation**

![Horizontal Orientation Diagram]

**Vertical Orientation**

![Vertical Orientation Diagram]

If you select End places, the first beam at the bottom or the right of the beam system is used for justification.

**Horizontal Orientation**

![Horizontal Orientation Diagram]

**Vertical Orientation**

![Vertical Orientation Diagram]
If you select Center, the first beam is placed in the center of the beam system and beams are spaced at a fixed distance on each side.

**Horizontal Orientation**

![Horizontal Orientation Diagram]

**Vertical Orientation**

![Vertical Orientation Diagram]

If you select Direction Line, the justification is set to the beam system direction line.

**Boundary Direction Line**

![Boundary Direction Line Diagram]

**Sketched Internal Direction Line**

![Sketched Internal Direction Line Diagram]
Beam System Layout Rules and Patterns

You can specify the beam system layout properties: number of beams, justification, beam type, spacing, layout rule, and slope. You can specify these values either when you create the beam system or modify them afterwards.

Specify the beam system layout rule

1 On the Properties palette, under Pattern, select a value for Layout Rule:
   - **Fixed Distance** allows you to specify the distance between centerlines of beams within the beam system. The number of beams in the beam system is calculated based on your selections.
   - **Fixed Number** allows you to specify the number of beams within the beam system. The beams are evenly spaced and centered within the beam system.
   - **Maximum Spacing** allows you to specify the maximum distance between centerlines of beams. The quantity of beams required for the beam system is calculated automatically and centered within the beam system.
   - **Clear Spacing** is similar to the Fixed Distance value, but measures spacing between the exteriors of the beams instead of between their centerlines. When you adjust the size of an individual beam in a beam system with the clear spacing layout rule value, adjacent beams move to maintain the distance between them.

Specify number of beams

2 Enter a value for the number of beams that you want in the beam system.
   This option is active only when you select the Fixed Number layout rule.

Specify spacing

3 Enter a value representing the distance between each beam.
   This option is active only when you select the Fixed Distance, Maximum Spacing, or Clear Spacing layout rule value.

Specify justification

4 Select the Justification Type. This value determines the placement of the first beam in the system. Each subsequent beam is spaced a fixed distance from that point. This option is active only when you select either the Fixed Distance or Clear Spacing layout rule value.

Specify 3D Snapping

5 Select the 3D check box if you want the beam system to slope. 3D Snapping enables the beam system to snap to points that are not within the work plane of the view such as columns in different elevations. See 3D Snapping on page 258.
Specify beam type

6 Select a value for the type of beam used in the beam system.

**NOTE** This is the same list available from the Type Selector drop-down. If the beam you require is not listed in the beam system creation tool, load the beam into the project before specifying the beam type within the beam system.

Dropping Beam Systems

You can drop a beam system from a project and leave its framing elements in place.

1 Select the beam system.

2 Click Modify | Structural Beam Systems tab ➤ Beam System panel ➤ Remove Beam System.

The beam system is removed from the project.

Creating a Cantilevered Beam System

You can use the beam system family to create various beam systems for bays of varying geometry, including arced, polygonal, and cantilevered. The following example provides a method for creating a cantilevered beam system.

Begin with a bay that is similar to the one shown in the following illustration of a partial plan view:

**Partial Plan View**

1 Click Home tab ➤ Structure panel ➤ Beam System.

2 Click Modify | Place Structural Beam System tab ➤ Beam System panel ➤ Sketch Beam System ➤ Draw panel ➤ (Pick Supports) to select the beam system boundary or (Pick Lines) to sketch the beam system boundary.
Creating a 3D Beam System

You can create non-planar beam systems in which the elevation of a beam is defined by its sketch lines.
3D beam system

Note that sketched beam lines

- Can only define slope when they are created using the Pick Supports tool.
- That have a beam as their support always define slope.
- That have a wall as their support have a Defines slope property that you can edit. The default value is true.

The elevation of the end of a beam in a beam system is determined as follows:

- If the end of the beam connects to a sketch line that defines slope, the beam is connected to the top of the associated support.
  
  **Define slope**

- If the sketch line does not define slope, then the end of the beam is elevated to a plane defined by the endpoints of the 2 nearest sketch lines that do define slope.
If there are no lines in the sketch that define slope, the beam system behaves like a 2D beam system.

**To add a 3D beam system**

1. Click Home tab ➤ Structure panel ➤ Beam System.
2. On the Properties palette, under Constraints, select 3D.
3. Click Apply.

### Tagging Beam Systems

You can tag the beam system with framing tags or with a beam system span tag.

<table>
<thead>
<tr>
<th>Beam system framing tags</th>
<th>Beam system span tags</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Framing tags" /></td>
<td><img src="image" alt="Span tags" /></td>
</tr>
</tbody>
</table>

Framing tags are structural framing tags that, by default, align parallel at the top center of the created beams in the system. You can alter these tag locations using the beam annotation tool. See Beam Annotations Tool on page 263.

Beam system span tags are unique to beam systems. This family is typically located in the following directory: Imperial or Metric Library\Annotations\Structural\Structural Beam System Tag.rfa. These tags display as a span arrow perpendicular to the created beams in the system. Their label indicates their structural framing type and their spacing within the beam system (beam type @ spacing).
Placing Beam System Tags

You can apply two separate tags to existing beam systems using the following procedures.

To place a beam system span tag

1. Click Annotate tab ➤ Symbol panel ➤ Beam.
2. On the Properties palette, select the desired beam system tag type from the Type Selector drop-down.
3. If prompted, load a beam system tag family into the project. See Tagging Beam Systems on page 303.
4. (Optional) Select Auto place on the Options Bar to center the tag on the beam system.
5. Place the cursor on a beam system in the view to highlight it.
6. If you selected Auto place, click the highlighted beam system. The tag is placed at the center of the beam system.
   If you did not select Auto place, move the cursor to the desired location on the beam system, and click to place it.

To place framing tags along individual beams

1. While pressing Ctrl, select each beam in the beam system.
   You tag the individual beams of the system as you would other beams.
2. Click Annotate tab ➤ Tag panel ➤ Beam Annotations.
3. In the Placement section of the Beam Annotations dialog, select All selected beams in current plan view.
4. In the Annotation location and type section, define the structural framing tag type and location for the selected beam tags.
   See Beam Annotations Tool on page 263.
5. Click OK.

Tagging Beam Systems on Placement

You can concurrently place tags in two ways from the Option bar when placing beam systems in an existing grid bay. See Creating a One-Click Beam System on page 288.

After you click Beam Systems to place a new beam system instance, do the following.

1. Click Modify | Place Structural Beam System tab ➤ Tag panel ➤ Tag on Placement.
2. On the Options Bar, select either System or Framing as the Tag Style.
   System tags display a beam system span tag perpendicular to the beams of the system when placed.
Framing tags display structural framing tags parallel to the individual beams of the system when placed.

See Tagging Beam Systems on page 303 for more information on system and framing tags for beam systems.

3 Place the beam system.

**Modifying Beam System Tags**

You can modify beam system tags and their labels to improve the clarity of your model annotations.

**Repositioning Beam System Tags**

To reposition a beam system tag, select the tag in the drawing area, and drag it. If moved within the beam system, the symbol retains its span extents. It moves parallel to the beams and its label moves parallel to the span symbol.

**Editing Beam System Tag Families**

You can modify beam system tags and their labels with the Family Editor.

1 Select the beam system tag in the drawing area.
2 Click Modify | Structural Beam System Tags tab ➤ Mode panel ➤ Edit Family.
3 Edit the beam system tag and label.

See Tags on page 944 and Labels on page 704.
4 Click Home tab ➤ Family Editor panel ➤ Load into Project.

**Tagging New Beams in a Beam System**

You can define a layer for future system member framing tags.

1 Select the beam system in the drawing area.

2 On the Properties palette, under Identity Data, select from the following in the Tag new members in view drop-down:
   - None
   - the current structural plan level
   - the current analytical plan level

3 Click OK.

The selection will confine tags for future members of the beam system to a specific level. New members must be added by editing the beam system. See Modifying a Beam System on page 308.

The following table shows the results of each option for Tag new members in view. New beam system members are highlighted in blue.

<table>
<thead>
<tr>
<th>Tag new members in view setting</th>
<th>Structural Plan: Level</th>
<th>Structural Plan: Level - Analytical</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td><img src="image1.png" alt="None" /></td>
<td><img src="image2.png" alt="None" /></td>
</tr>
<tr>
<td>Structural Plan: Level</td>
<td><img src="image3.png" alt="Structural Plan: Level" /></td>
<td><img src="image4.png" alt="Structural Plan: Level - Analytical" /></td>
</tr>
<tr>
<td>Structural Plan: Level - Analytical</td>
<td><img src="image5.png" alt="Structural Plan: Level - Analytical" /></td>
<td><img src="image6.png" alt="Structural Plan: Level - Analytical" /></td>
</tr>
</tbody>
</table>

Chapter 13  Structural Modeling
Resetting Structural Beam Systems

The Reset Structural Beam System tool recreates a beam system using the original beam system parameters. This tool can be used to undo changes to properties of individual beams in the system. After the beam system is reset, all beams in the system will have uniform parameters and be in the default locations. Specifically, the tool has the following reset effects:

- Beams that have been moved are returned to their original locations.
- Beams that have been deleted from the system are restored.
- Parameters that have been changed on individual beams (such as Beam Type, Offset, Angle) are reset.

Note that if the sketch of a beam system is modified, the beams of a system will remain attached to their original supports until the beam system is reset.

Original beam system

Beam system with changes

Using the Reset Structural Beam System tool

1. In the drawing area, click on the beam system you want to reset.
2. Click Modify | Structural Beam Systems tab ➤ Mode panel ➤ Edit Boundary.
3. Click Modify | Structural Beam Systems > Edit Boundary tab ➤ Adjust panel ➤ Reset System.
Modifying a Beam System

To edit a beam system

1. In the drawing area, click on the beam system you want to modify.
2. Click Modify | Structural Beam Systems tab ➤ Mode panel ➤ Edit Boundary.
3. Make any necessary changes with the available sketch tools and click Modify | Structural Beam Systems > Edit Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

Modifying Beam System Properties

You can modify many of the properties for beam systems.

To modify beam system properties

1. If you are currently sketching, click on the Properties palette.
   If you are in a project view, right-click the beam system, and select Properties.
2. On the Properties palette, edit beam system instance parameters. (See Beam System Instance Properties on page 309.)
Click Edit Type and edit beam system type parameters. (See Beam System Type Properties on page 309.)

**NOTE** Changes made to type parameters affect all beam systems of this type in the project. You can click Duplicate to create a new beam system type.

### Beam System Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>The beam keynote. Add or edit the value. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The shape manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for entering general comments about the shape type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>Description of the beam. Enter a description.</td>
</tr>
<tr>
<td>Assembly description</td>
<td>Description of the assembly based on the assembly code selection. This is a read-only value.</td>
</tr>
<tr>
<td><strong>Type Mark</strong></td>
<td>A value that designates the particular beam; possibly the shop mark. This value must be unique for each element in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td><strong>Cost</strong></td>
<td>The pricing of the beam.</td>
</tr>
</tbody>
</table>

### Beam System Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>3D</td>
<td>Creates a non-planar beam system in which the elevation of a beam is defined by its sketch lines. See Creating a 3D Beam System on page 301.</td>
</tr>
<tr>
<td>Elevation</td>
<td>The vertical offset of beam system beams from the beam system work plane.</td>
</tr>
<tr>
<td>Work Plane</td>
<td>This is a read-only value that is dependent on the work plane where the element was placed.</td>
</tr>
</tbody>
</table>
Braces

Braces are diagonal members connected to beams and columns. Like beams, you create braces by snapping the pointer to another structural element, clicking a start point, snapping to another structural element, and clicking an endpoint. For example, braces can appear between a structural column and a structural beam.

You can add braces in either a plan view or a framing elevation view. Braces attach themselves to beams and columns and adjust parametrically to changes in the building design. When attached to a beam, you can specify the type of attachment, distance, or ratio. In addition, you can set which end of the referenced element you want relative to the distance or ratio value; if the end is attached to a column or wall, you can set the level and offset for the height of the point.

You can copy, move, mirror, array, and rotate braces out of the vertical plane in which they were created. You can accomplish this in plan and 3D views.
Loading Structural Braces

You can load structural braces in several ways:

To load brace families

1. Click Home tab ➤ Structure panel ➤ Brace.
2. Click Modify | Place Brace tab ➤ Mode panel ➤ Load Family.
3. In the Open dialog, navigate to either the imperial or metric library, and open the Structural/Framing folder.
4. Select a brace type folder: either Steel, Light Gauge Steel, Concrete, or Wood, and click Open.

**NOTE** When you open a framing family, you can select multiple brace sizes. In the Specify Types dialog that displays after you click Open, press and hold the Ctrl key when selecting brace sizes. If necessary, you can filter the Catalog by clicking the arrow at the column heading.

Adding Structural Braces

You can add braces in either a plan view or in a framing elevation view.

To add a brace in a framing elevation view

1. Open a framing elevation view.
2. If necessary, load additional braces from the Structural/Framing folder under the Library folder of the Revit Structure program group. For more information, see Loading Structural Braces on page 311.
3. Click Home tab ➤ Structure panel ➤ Brace.
4. On the Properties palette, select the appropriate brace from the Type Selector drop-down.
5. To edit the properties of the brace before adding the brace to your model, click on the Properties palette.
6 In the drawing area, highlight the snapping point where you want to begin the brace, such as on a structural column. Click to place a start point.

**Snap to begin brace**

7 Move the pointer in a diagonal direction to sketch the brace and place the cursor near another structural element to snap it. Click to place the endpoint.

**Sample braces in a framing elevation view**

---

**To add a brace in a plan view**

1 Open a plan view.
2 Click Home tab ➤ Structure panel ➤ Brace.
3 On the Options Bar, specify both the Start Level and offset distance and the End Level and offset distance.
4 Click the start point and the endpoint of the brace in the project.
Modifying Braces

Controlling Brace Attachments

After adding a brace element, you can modify the brace properties to control how the brace maintains position along a beam. Each brace endpoint can be maintained positionally with a beam by either a distance or a length ratio from the beam endpoints. If you modify the position or length of the attached beam, the brace adapts to the change, depending on the brace settings you select.

Brace Property Terminology

- Start Attachment Type
- Start Attachment Distance or Ratio
- End of Referenced Element
- End Attachment Type
- End Attachment Distance or Ratio
- End of Reference Element

Brace attachment properties

To modify brace properties

1. Select a brace.
2. Click on the Properties palette. (See Brace Properties on page 314.)

To specify attachment parameters

3. On the Properties palette, under Structural, select one of the following Start Attachment Type options.
   - **Distance**: If the brace start point is placed on a beam, this value specifies the distance between the nearest end of the beam and the brace start point.
Brace Properties

You can modify many properties for braces, such as structural, dimensional, and identity data. Brace instance properties depend on whether the brace is attached to a beam or to a column.

To modify brace properties

1 Select the brace.
2 On the Properties palette, edit brace instance parameters. (See Brace Instance Properties on page 318 or Steel Brace Instance Properties (When Attached to a Beam) on page 316.)
3 Click Edit Type to edit brace type parameters. (See Steel Brace Type Properties on page 314.)

NOTE Changes made to type parameters affect all braces of this type in the project. You can click Duplicate to create a new brace type.

Steel Brace Type Properties

The following table lists the beam type properties for a typical steel brace:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>The section area.</td>
</tr>
<tr>
<td>Shape</td>
<td>Defines the shape of the selected type. Applies to HSS family type only.</td>
</tr>
<tr>
<td>W</td>
<td>The nominal weight.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Ht</td>
<td>The flange height. Applies to HSS family type only.</td>
</tr>
<tr>
<td>b</td>
<td>The flange width. Applies to HSS family type only.</td>
</tr>
<tr>
<td>kr</td>
<td>The kr distance. Applies to HSS family type only.</td>
</tr>
<tr>
<td>t</td>
<td>The flange thickness. Applies to HSS family type only.</td>
</tr>
<tr>
<td>bf</td>
<td>The flange width.</td>
</tr>
<tr>
<td>d</td>
<td>The actual depth of section.</td>
</tr>
<tr>
<td>k</td>
<td>The k distance.</td>
</tr>
<tr>
<td>k2</td>
<td>The k2 distance. This is a read-only value.</td>
</tr>
<tr>
<td>tf</td>
<td>The flange thickness.</td>
</tr>
<tr>
<td>tw</td>
<td>The web thickness.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Assembly Code</td>
<td>The Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td>Keynote</td>
<td>The keynote for the brace. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The brace manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for entering general comments about the brace type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td>Description</td>
<td>An optional description of the brace.</td>
</tr>
<tr>
<td>Assembly description</td>
<td>Description of the assembly based on the assembly code selection. This is a read-only value.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value that specifies the particular brace; possibly the shop mark. This value must be unique for each brace in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>The pricing of the brace.</td>
</tr>
<tr>
<td>OmniClass Number</td>
<td>The number from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
<tr>
<td>OmniClass title</td>
<td>The name from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
</tbody>
</table>
Steel Brace Instance Properties (When Attached to a Beam)

The following table lists the brace instance properties for a typical steel brace when attached to a beam.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Reference Level</td>
<td>The constraining level.</td>
</tr>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Start Extension</td>
<td>The dimension between the physical edge of the start end of the brace and the element to which it is connected.</td>
</tr>
<tr>
<td>End Extension</td>
<td>The dimension between the physical edge of the finish end of the brace and the element to which it is connected.</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td>Brace Material</td>
<td>Specifies the user-defined structural material. See Material Physical Type Parameters on page 1597.</td>
</tr>
<tr>
<td><strong>Structural</strong></td>
<td></td>
</tr>
<tr>
<td>Angle</td>
<td>The rotation about the longitudinal axis of the brace.</td>
</tr>
<tr>
<td>Moment Connection Start</td>
<td>The moment frame, or cantilever symbol at the start end of brace, if applicable.</td>
</tr>
<tr>
<td>Moment Connection End</td>
<td>The moment frame, or cantilever symbol at the finish end of brace, if applicable.</td>
</tr>
<tr>
<td>Cut Length</td>
<td>The physical length (not the analytical length). This is a read-only value.</td>
</tr>
<tr>
<td>Structural Usage</td>
<td>Specifies Vertical Bracing, Kicker brace, or Other.</td>
</tr>
<tr>
<td>Start Attachment Level Reference</td>
<td>Distance or Ratio (percentage relative to beam length); type of separation of brace start end to a designated beam end. Applies to the brace end attached to the beam.</td>
</tr>
<tr>
<td>Start Attachment Elevation</td>
<td>Distance from, or Ratio (percentage) of separation of brace start end to a designated beam end. Applies to the brace end attached to the beam.</td>
</tr>
<tr>
<td>End Attachment Type</td>
<td>Distance of separation of brace finish end to a designated beam end. Applies to the brace end attached to the beam.</td>
</tr>
<tr>
<td>End Attachment Ratio</td>
<td>Ratio (percentage) of separation of brace finish end to a designated beam end. Applies to the brace end attached to the beam.</td>
</tr>
<tr>
<td>End of Referenced Element</td>
<td>Designated end (start or finish) of Referenced Element (beam) to which start end of brace is attached. Applies to the brace end attached to the beam.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td>The distance between the component endpoints that define the element’s location. This is a read-only value.</td>
</tr>
<tr>
<td>Volume</td>
<td>The volume of the selected brace element. This is a read-only value.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>A field for entering comments about the brace.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label created for the brace. Possible use: shop mark. This value must be unique for each brace in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Indicates in which phase the brace component was created. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Indicates in which phase the brace component was demolished. See Project Phasing on page 877.</td>
</tr>
<tr>
<td><strong>Structural Analysis (see Structural Analytical Model Overview on page 1277)</strong></td>
<td></td>
</tr>
<tr>
<td>Start Release</td>
<td>Specifies the start release condition: either Fixed, Pinned, Bending Moment, or User Defined. User Defined allows you to enable/disable each of the start release conditions.</td>
</tr>
<tr>
<td>Start Fx</td>
<td>The translational release at the start end of the brace along the local x-axis.</td>
</tr>
<tr>
<td>Start Fy</td>
<td>The translational release at the start end of the brace along the local y-axis.</td>
</tr>
<tr>
<td>Start Fz</td>
<td>The translational release at the start end of the brace along the local z-axis.</td>
</tr>
<tr>
<td>Start Mx</td>
<td>The rotational release at the start end of the brace along the local x-axis.</td>
</tr>
<tr>
<td>Start My</td>
<td>The rotational release at the start end of the brace along the local y-axis.</td>
</tr>
<tr>
<td>Start Mz</td>
<td>The rotational release at the start end of the brace along the local z-axis.</td>
</tr>
<tr>
<td>End Release</td>
<td>Fixed, Pinned, Bending Moment or User Defined. User Defined allows you to enable/disable each of the end release conditions.</td>
</tr>
<tr>
<td>End Fx</td>
<td>The translational release at the end of the brace along the local x-axis.</td>
</tr>
<tr>
<td>End Fy</td>
<td>The translational release at the end of the brace along the local y-axis.</td>
</tr>
<tr>
<td>End Fz</td>
<td>The translational release at the end of the brace along the local z-axis.</td>
</tr>
<tr>
<td>End Mx</td>
<td>The rotational release at the end of the brace along the local x-axis.</td>
</tr>
<tr>
<td>End My</td>
<td>The rotational release at the end of the brace along the local y-axis.</td>
</tr>
<tr>
<td>End Mz</td>
<td>The rotational release at the end of the brace along the local z-axis.</td>
</tr>
<tr>
<td>Analyze As</td>
<td>Determines whether brace conditions contribute to lateral analysis. Available for use by external analysis applications. See Projection Plane Options for each Structural Element Type on page 1301.</td>
</tr>
</tbody>
</table>
**Brace Instance Properties**

The following table lists the default instance properties for a typical brace when not attached to a beam.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Reference Level</td>
<td>The constraining level.</td>
</tr>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Start Extension</td>
<td>The dimension between the edge of the start end of the brace and the element to which it is connected.</td>
</tr>
<tr>
<td>End Extension</td>
<td>The dimension between the edge of the finish end of the brace and the element to which it is connected.</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td>Brace Material</td>
<td>The user defined structural material. See Material Physical Type Parameters on page 1597.</td>
</tr>
<tr>
<td><strong>Structural</strong></td>
<td></td>
</tr>
<tr>
<td>Angle</td>
<td>The rotation about the longitudinal axis of the brace.</td>
</tr>
<tr>
<td>Moment Connection Start</td>
<td>The moment frame or cantilever symbol at the start end of brace, if applicable.</td>
</tr>
<tr>
<td>Moment Connection End</td>
<td>The moment frame or cantilever symbol at the finish end of brace, if applicable.</td>
</tr>
<tr>
<td>Cut Length</td>
<td>The physical length. This is a read-only value.</td>
</tr>
<tr>
<td>Structural Usage</td>
<td>Specifies structural usage: either Vertical Bracing, Kicker brace, or Other.</td>
</tr>
<tr>
<td>Start Attachment Level Reference</td>
<td>The constraining level of the start end of the brace.</td>
</tr>
<tr>
<td>Start Attachment Elevation</td>
<td>The elevation of the start end referenced from the start attachment level reference.</td>
</tr>
<tr>
<td>End Attachment Level Reference</td>
<td>The constraining level of the finish end of the brace.</td>
</tr>
<tr>
<td>End Attachment Elevation</td>
<td>The elevation of the finish end referenced from the end attachment level reference.</td>
</tr>
<tr>
<td>Rebar Cover - Top Face</td>
<td>Applies to concrete beams only. The rebar cover distance from the column top face.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Rebar Cover - Bottom Face</td>
<td>Applies to concrete beams only. The rebar cover distance from the column bottom face.</td>
</tr>
<tr>
<td>Rebar Cover - Other Faces</td>
<td>Applies to concrete beams only. The rebar cover distance from the column to adjacent element faces.</td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Specifies the estimated reinforcement volume of the selected element. This is a read-only parameter that only displays when rebar has been placed.</td>
</tr>
</tbody>
</table>

**Dimensions**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Length</td>
<td>The length of the brace location line. This is a read-only value.</td>
</tr>
<tr>
<td>Volume</td>
<td>The volume of the selected brace element. This is a read-only value.</td>
</tr>
</tbody>
</table>

**Identity Data**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comments</td>
<td>User comments.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label created for the brace. Possible use: shop mark. This value must be unique for each brace in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
</tbody>
</table>

**Phasing**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase Created</td>
<td>Indicates in which phase the brace component was created. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Indicates in which phase the brace component was demolished. See Project Phasing on page 877.</td>
</tr>
</tbody>
</table>

**Structural Analysis (see Structural Analytical Model Overview on page 1277)**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Release</td>
<td>Specifies the start release condition: either Fixed, Pinned, Bending Moment, or User Defined. User Defined allows you to enable/disable each of the start release conditions.</td>
</tr>
<tr>
<td>Start Fx</td>
<td>The translational release at the start end of the brace along the local x-axis.</td>
</tr>
<tr>
<td>Start Fy</td>
<td>The translational release at the start end of the brace along the local y-axis.</td>
</tr>
<tr>
<td>Start Fz</td>
<td>The translational release at the start end of the brace along the local z-axis.</td>
</tr>
<tr>
<td>Start Mx</td>
<td>The rotational release at the start end of the brace along the local x-axis.</td>
</tr>
<tr>
<td>Start My</td>
<td>The rotational release at the start end of the brace along the local y-axis.</td>
</tr>
<tr>
<td>Start Mz</td>
<td>The rotational release at the start end of the brace along the local z-axis.</td>
</tr>
<tr>
<td>End Release</td>
<td>Specifies the end release condition: either Fixed, Pinned, Bending Moment or User Defined. User Defined allows you to enable/disable each of the end release conditions.</td>
</tr>
</tbody>
</table>
### Name | Description
--- | ---
End Fx | The translational release at the end of the brace along the local x-axis.
End Fy | The translational release at the end of the brace along the local y-axis.
End Fz | The translational release at the end of the brace along the local z-axis.
End Mx | The rotational release at the end of the brace along the local x-axis.
End My | The rotational release at the end of the brace along the local y-axis.
End Mz | The rotational release at the end of the brace along the local z-axis.

**Analyze As**
Used by external analysis applications to determine whether brace conditions contribute to lateral analysis. See *Projection Plane Options for each Structural Element Type* on page 1301.

### Other

| Start Extension Calculation | Defines maximum distance of start extension parameter. Set in family parameters. |
| End Extension Calculation  | Defines maximum distance of end extension parameter. Set in family parameters. |

### Trusses

In Revit Structure, you can add a truss to your building model. Use the Truss tool, which creates the truss according to the layout and other parameters specified in the truss family type you select. For information about creating a truss family, see *Creating a Truss Family* on page 321.

The lines in the layout determine the placement of the sub elements that comprise the truss element, such as the top chord, bottom chord, and web members.

All types within a truss family share the same layout. Individual types specify other parameters, such as the structural framing families to be used for modeling chords and web members.

To use the Truss tool, select a truss family type and then specify the truss start point and endpoint in the drawing area. Then Revit Structure creates structural framing elements as necessary, placing them on the layout lines specified for the selected family.

![Truss Diagram]

**NOTE** When you move the cursor over a truss in the drawing area, the truss element displays as a set of dashed blue lines. Clicking any of these dashed blue lines selects the truss element itself. The sub elements that comprise the truss, such as the top chord, bottom chord, and web members, are individually selectable.
You create structural framing elements along each of these layout lines. You can define the structural framing elements in the truss layout family. Several different types of the same family can have different pre-set framing families using the same geometric layout.

**NOTE** Structural members associated with the truss type are included in the geometric layout. These structural members can be changed to a different size, but they must be selected from sizes available within the specific truss family. The structural framing type can be specified in the truss layout family definition file RFA file. For more information, see Creating a Truss Family on page 321.

## Creating a Truss Family

A truss layout family consists of lines that define truss elements such as chords and webs. Chord and web members are created such that their center lines (local x axis) will lie along the layout lines that you define in the truss layout family. The entire layout will be transformed such that the distance between the 2 end reference planes will be determined by the truss instance based on its shape in the project. The Length parameter may be used in your truss layout family to perform calculations to specify the exact location of vertical web members or to calculate the number of panels to create in the project environment.

**Truss family editor tools**

- Click Home tab ➤ Detail panel ➤ Top Chord to draw the location and geometric configuration of the top chord layout lines.
Click Home tab ➤ Detail panel ➤ Bottom Chord to draw the location and geometric configuration of the bottom chord layout lines.

Click Home tab ➤ Detail panel ➤ Web to draw the location of vertical and diagonal web layout lines.

Click Home tab ➤ Properties panel ➤ Family Type to select the types of structural framing families used for chords and webs.

You may create different types of the same layout family. Differences between these types include the following.

- The types of structural framing families used for chords and webs
- The member rotation of chords or webs about their local x axes
- The member end releases

Creating a New Truss Layout Family File

1. Click ➤ New ➤ Family. Navigate to the Imperial or Metric template directory and select the Structural Trusses.rft family template file. Click the Open button to open a new family file.

2. Click Home tab ➤ Properties panel ➤ Family Types. In the Family Types dialog, click New and provide a name for this truss type. Repeat this step for each planned type of this truss family. Click OK to close the dialog.

3. Click Insert tab ➤ Load from Library panel ➤ Load Framing Family.
   
   In order to specify structural framing families for the truss layout family to use, you must load them in your truss layout family. Navigate to the Imperial or Metric family directory and select the structural framing families for chords and webs. These must be structural framing families or generic annotation families. Repeat this step to specify for each type of truss.

4. Click Home tab ➤ Properties panel ➤ Family Types. For each truss family type, select the desired framing type for top chord, bottom chord, vertical webs and diagonal webs. Click OK to close the dialog.

5. Click ➤ Save As. Provide a name for the new truss family and click Save.

Adding Truss Family Parameters

1. In the Family Editor, click Home tab ➤ Properties panel ➤ Family Types.

2. Under parameters you have the option to add, modify, or remove parameters from the family type. Adjust parameter settings and click OK.

3. Enter formulas and define the parameter settings. See Creating Parameters on page 692.

   If you leave the structural framing type blank in a truss layout family, the truss will behave as follows:

   - The value for truss members in the truss type will show Set Framing Type, which means that the truss will use the default, or most recently created structural framing type in the project.

   - When set to Set Framing Type, Revit Structure will not change the values for framing members in the family type properties when a truss is created in the project environment. The value remains set to Set Framing Type, the default setting, until you change it in the family type properties.
Sketching a Truss Family Layout

The structural truss family template provides 5 permanent reference planes: top, bottom, left, center and right; the left and right planes indicate the span length of the truss. Truss layout lines which end at these planes or are coincident with them will maintain this relationship during layout transformation in the project environment.

To sketch truss chords

1. Click Home tab ▶️ Detail panel ▶️ Top Chord.
2. Sketch along the top reference plane to define the top chord. For more information, see Sketching on page 1405.
3. Click the lock symbol attached to the line to lock the chord to the plane.
4. Click Home tab ▶️ Detail panel ▶️ Bottom Chord.
5. Sketch along the bottom reference plane to define the bottom chord.
6. Again, click the lock symbol to lock the chord to the plane.

Sketch a truss web

7. Click Home tab ▶️ Detail panel ▶️ Web.
8. Sketch the panel webs.
9. If needed, place additional dimensions between sketched lines and reference planes.
10. Save this file to your Family directory. The truss type is now ready for loading into your model.
11. Click Home tab ▶️ Family Editor panel ▶️ Load into Project.

NOTE For information on loading a truss member into your model, see Loading Structural Component Families on page 218. Remember to drag the truss into a plan view, not an elevation view.

Adding a Truss

Revit Structure transforms the truss layout to fit the span of the truss and creates framing elements that correspond to lines in the transformed truss layout. For more information, see Creating a Truss Family on page 321.
To add a truss

1. Open a view of the building level where you want to add the truss.
2. Click Home tab ➤ Structure panel ➤ Truss.
3. On the Properties palette, from the Type Selector drop-down, select the truss type.
4. Click Modify | Place Truss tab ➤ Draw panel ➤ (Line) to specify the start point and endpoint for the truss, or click (Pick Lines), and then select an edge or line to which you want to constrain the truss model.

**Attaching a Truss to a Roof or Structural Floor**

Attaching a truss to a roof or structural floor will force the truss to conform its chords to that element. The following rules apply to attached trusses.

- Chord locations are dependent on their attachments and bearing chord assignments.
  - If the top chord of a truss is attached, its location line is the bottom face of the element to which it is attached.
  - If the bottom chord of a truss is attached, its location line is the top face of the element to which it is attached.
  - If only the non-bearing chord is attached, the bearing chord location will be the current location line of the unattached chord.
  - If only the bearing chord is attached, the non-bearing chord location will be the truss location line offset by the Truss Height property. The offset represents a positive distance for top chords and a negative distance for bottom chords.

- The location line of the truss chord must be below (when attaching the top chord) or above (when attaching the bottom chord) the roof or structural floor.
- The top chord must always have a higher elevation than the bottom chord. They may meet, but never cross.
The width of the roof or structural floor must equal or exceed the width of the truss. Trusses cannot be attached to structural floors or roofs that do not completely cover them.

**To attach a truss**

1. Verify that **roof and structural floor visibility** is turned on in the current view.
2. Select one or more trusses to attach.

3. On the ribbon, click \( \text{(Attach Top/Bottom)} \).
4. On the Options Bar, select Attach Trusses: Top or Bottom for the appropriate truss chord being attached.
5. Select the roof or structural floor.

<table>
<thead>
<tr>
<th>Selecting the Roof/Structural Floor</th>
<th>The Attached Truss</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top Chords</td>
<td><img src="image" alt="Top Chords" /></td>
</tr>
<tr>
<td>Bottom Chords</td>
<td><img src="image" alt="Bottom Chords" /></td>
</tr>
</tbody>
</table>

The truss is attached.
NOTE  Not all truss families properly attach to a roof or structural floor. For the chord to conform to the shape of the corresponding roof or structural floor, the layout family's chord sketch lines must coincide with the top reference plane. The roof/structural floor profile defines the transformation of the family's reference plane, not the shape of the chord. The truss profile shape is not discarded. The original profile will display if the truss is later detached.

To detach a truss

1  Select the attached truss.

2  On the ribbon, click (Detach Top/Bottom).

3  Select the roof or structural floor from which to detach.

4  (Optional) Click Detach All on the Options Bar to detach top and bottom chords.

The truss detaches, retaining its original profile shape.

Removing Truss Families

You can remove a truss family from a project and leave its chords and webs in place.

1  Select the truss.

2  Click Modify | Structural Trusses tab ➤ Modify Truss panel ➤ Remove Truss Family.

The truss family drops from the selection, leaving its framing elements in place.

Editing a Truss Profile

In non-plan and perpendicular elevation, section, or 3D views, you can edit the extents of a truss. You can create new lines, delete existing lines, and use the Trim/Edit tools to adjust the profile, as required. By editing the profile of the truss, you can modify its top and bottom chords to any shape desired.
NOTE Not all truss families properly transform into a profile sketch. For the top and bottom chords to conform to the shape of the profile, the layout family's top and bottom chord sketch lines must coincide with the top and bottom reference planes respectively. The curves drawn using Top or Bottom Chord Reference tools in a profile sketch define the transformation of the family's top and bottom reference planes, not the shape of the top or bottom chords.

To edit a truss profile

1. Select a truss to edit.

2. On the ribbon, click \( \text{Edit Profile} \).

3. Click \( \text{(Top Chord)} \) or \( \text{(Bottom Chord)} \).

4. Select a line tool.

5. Sketch the profile to which the truss will constrain.

6. Select the old plane profile, and delete it.
7 On the ribbon, click \( \checkmark \) (Finish Edit Mode).

The truss model shapes itself to fit within the constraints of the new profile. If necessary, you can edit the chords of a truss while it is attached.

If the truss is attached at an edited chord, the profile will be ignored. The attached surface of a structural floor or roof determines the chord geometry. The truss profile shape is not discarded and will display if the truss is later detached.

**TIP** Click \( \checkmark \) (Reset Profile) to reset the truss to its original profile.
Tagging a Truss

You can annotate a truss with either a structural truss tag or individual structural framing tags for the individual truss members. Tags for the truss family are typically located in the following location: Imperial or Metric Library\Annotations\Structural\Structural Truss Tag.rfa. These tags display the truss family type.

Truss Family Tag

Placing a Truss Tag

1 Click Annotate tab ➤ Tag panel ➤ Tag by Category.
2 (Optional) On the Options Bar, click Tags to select or Load the structural truss tag style. See Loading Tag Styles on page 1612.
3 (Optional) On the Options Bar, select Vertical or Horizontal for the tag orientation.
4 (Optional) On the Options Bar, select Leader to include a leader line with the tag. Enter a value for the length of the leader in the text box next to the Leader check box.
5 Click the truss.

The structural truss tag is placed. Click and reposition the tag if needed.

Placing Structural Framing Tags on Truss Elements

Structural framing tags align parallel at the top center of the created truss chords and webs.

1 While pressing Ctrl, select each chord and web in the truss.
2 Click Annotate tab ➤ Tag panel ➤ Tag All.
3 In the Tag All not Tagged dialog, select Only selected objects in the current view.
4 Click a structural framing tag category for the truss elements.
5 Click OK.

The structural framing tags are placed. Click and reposition tags if needed.

**Tagging New Webs in a Truss**

After a truss is placed, you can specify framing tag placement for new webs if the truss is resized.

**NOTE** A structural framing tag family must be loaded prior to resizing the truss.

1 Select the truss in the drawing area.
2 On the Properties palette, under Identity Data, select None or a parallel elevation view from the Tag new members in view drop-down.
3 Click Apply.

The selection will place tags for future members of the tags in a specific elevation.

New members must be added by increasing the length of the truss. Click and reposition tags if needed.
Editing Truss Tag Families

You can modify truss tags and their labels with the Family Editor.

1. Select the truss tag in the drawing area.
2. Click Modify | Structural Trusses tab ➤ Mode panel ➤ Edit Family.
3. Edit the truss tag and label.
   
   See Tags on page 944 and Labels on page 704.
4. Click Home tab ➤ Family Editor panel ➤ Load into Project.

Resetting a Truss

You can undo many of the edits to truss members and restore the predefined values from the type definition by using the Reset tool. The reset feature re-pins and sets truss members back to their default definition.

**NOTE** The Reset tool does not reset edits to the truss profile.

The Reset tool performs the following functions on trusses:

- Sets overridden members’ sizes back to the size defined in the Structural Type parameter of the Truss Object type properties.
- Restores deleted members.
- Restores any relocated members to their original locations.
- Re-pins any unpinned elements, restoring overridden instance parameters to their default settings.

**To use the Reset tool on trusses**

1. Select a truss that you wish to reset.
2. Click Modify | Structural Trusses tab ➤ Modify Truss panel ➤ Reset Truss.

Truss Properties

You can modify many of the type and instance properties for structural trusses.

**To modify truss properties**

1. Select the truss.
2. On the Properties palette, edit truss instance parameters. (See Truss Object Instance Properties on page 334 or Web Instance Properties on page 335 or Top/Bottom Chord Instance Properties on page 338.)
3. Click Edit Type to edit truss type parameters. (See Truss Object Type Properties on page 332.)

**NOTE** Changes made to type parameters affect all trusses of this type in the project. You can click Duplicate to create a new truss type.
## Truss Object Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Top Chords</strong></td>
<td></td>
</tr>
<tr>
<td>Structural Framing Type</td>
<td>Defines the structural framing type of the top chords.</td>
</tr>
<tr>
<td>Start Release</td>
<td>Defines the release conditions: either Pinned, Fixed, and Bending Moment.</td>
</tr>
<tr>
<td>End Release</td>
<td>Defines the release conditions: Available choices are Pinned, Fixed, and Bending Moment.</td>
</tr>
<tr>
<td>Angle</td>
<td>The rotation about the longitudinal axis of the shape.</td>
</tr>
<tr>
<td>Analytical Vertical Projection</td>
<td>Specifies the location for the respective analytical lines. If you select Auto-detect, the analytical models follow the same rules as beams. See <a href="#">Analytical Model Settings</a> on page 1285.</td>
</tr>
<tr>
<td><strong>Vertical Webs</strong></td>
<td></td>
</tr>
<tr>
<td>Structural Framing Type</td>
<td>Defines the structural framing type of the vertical webs.</td>
</tr>
<tr>
<td>Start Release</td>
<td>Defines the release conditions: either Pinned, Fixed, and Bending Moment.</td>
</tr>
<tr>
<td>End Release</td>
<td>Defines the release conditions: either Pinned, Fixed, and Bending Moment.</td>
</tr>
<tr>
<td>Angle</td>
<td>The rotation about the longitudinal axis of the shape.</td>
</tr>
<tr>
<td><strong>Diagonal Webs</strong></td>
<td></td>
</tr>
<tr>
<td>Structural Framing Type</td>
<td>Defines the structural framing type of the diagonal webs.</td>
</tr>
<tr>
<td>Start Release</td>
<td>Defines the release conditions: either Pinned, Fixed, and Bending Moment.</td>
</tr>
<tr>
<td>End Release</td>
<td>Defines the release conditions: either Pinned, Fixed, and Bending Moment.</td>
</tr>
<tr>
<td>Angle</td>
<td>The rotation about the longitudinal axis of the shape.</td>
</tr>
<tr>
<td><strong>Bottom Chords</strong></td>
<td></td>
</tr>
<tr>
<td>Structural Framing Type</td>
<td>Defines the structural framing type of the bottom chords.</td>
</tr>
<tr>
<td>Start Release</td>
<td>Defines the release conditions: either Pinned, Fixed, and Bending Moment.</td>
</tr>
<tr>
<td>End Release</td>
<td>Defines the release conditions: either Pinned, Fixed, and Bending Moment.</td>
</tr>
<tr>
<td>Angle</td>
<td>Rotation about the longitudinal axis of the shape.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Analytical Vertical Projection</td>
<td>Specifies the location for the respective analytical lines. If Auto-detect is chosen, the analytical models will follow the same rules as beams. See Analytical Model Settings on page 1285.</td>
</tr>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Webs Have Symbolic Cutback</td>
<td>Enables the cutback of the coarse representation of webs. The cutback distance is defined by the Braces cutback setting in the Structural Settings dialog. For more information, see Structural Settings Dialog on page 1605.</td>
</tr>
<tr>
<td>Web Orientation</td>
<td>Specifies the orientation of the web: either vertical or perpendicular. The default setting is vertical. Webs set to vertical maintain a vertical orientation in the project. If they are set to perpendicular, they maintain a 90 degree angle with respect to the bearing chord they are connected to.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Used to add or edit the truss keynote. Click in the value box to open the Keynotes dialog. For more information, see Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The truss manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for entering general comments about the truss type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td>Description</td>
<td>The description of the truss.</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>The description of the assembly, based on the assembly code selection. This is a read-only value.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value that designates a particular truss; possibly the shop mark. This value must be unique for each truss in a project. Revit Structure warns you when the number is already used, but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>The cost of the truss type.</td>
</tr>
<tr>
<td>OmniClass Number</td>
<td>The number from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
<tr>
<td>OmniClass title</td>
<td>The name from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
</tbody>
</table>
### Truss Object Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Reference Level</td>
<td>The level from which the Start and End Level Offsets are measured. This value is dependent on the work plane of the truss. If the truss is detached from its work plane, you can set this parameter.</td>
</tr>
<tr>
<td>Start Level Offset</td>
<td>Specifies the vertical offset from the Reference Level for the start point of the location line.</td>
</tr>
<tr>
<td>End Level Offset</td>
<td>Specifies the vertical offset from the Reference Level for the endpoint of the location line.</td>
</tr>
<tr>
<td><strong>Structural</strong></td>
<td></td>
</tr>
<tr>
<td>Create Top Chord</td>
<td>Creates the Top Chord. Clear the check box when you do not want the top chord to be created. This is useful for preventing overlaps when creating 3D space trusses.</td>
</tr>
<tr>
<td>Create Bottom Chord</td>
<td>Creates the Bottom Chord. Clear this check box when you do not want the bottom chord to be created. This is useful for preventing overlaps when creating 3D space trusses.</td>
</tr>
<tr>
<td>Bearing Chord</td>
<td>Specifies the chord bearing, determining the position of the truss with respect to the location line.</td>
</tr>
<tr>
<td>Rotation Angle</td>
<td>Sets truss axial rotation.</td>
</tr>
<tr>
<td>Bearing Vertical Justification</td>
<td>Sets the Vertical Justification parameter in bearing chord members. See Top/Bottom Chord Instance Properties on page 338.</td>
</tr>
<tr>
<td>Stick Symbol Location</td>
<td>Specifies the location of the coarse view plan representation of the truss: either Top Chord, Bottom Chord, or Bearing Chord.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Truss Height</td>
<td>Specifies the distance between the top and bottom reference planes in the truss layout family.</td>
</tr>
<tr>
<td>Non Bearing Offset</td>
<td>Specifies the horizontal offset of the non-bearing chord from the location line.</td>
</tr>
<tr>
<td>Span</td>
<td>Specifies the furthest extent of the truss along the location line. In many cases, this parameter does not correspond to the value of the Length parameter in the truss family.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Engineering Type</td>
<td>The text field that can be used to tag trusses. The value is non-unique.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Comments</td>
<td>A field for entering comments about the truss.</td>
</tr>
<tr>
<td>Mark</td>
<td>The standard Object parameter. The value is unique per instance.</td>
</tr>
<tr>
<td>Tag new members in view</td>
<td>Specifies the view in which to display new beam elements added to the truss.</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Indicates in which phase the brace component was created. For more information, see Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Indicates in which phase the brace component was demolished. See Project Phasing on page 877.</td>
</tr>
<tr>
<td><strong>Other</strong></td>
<td></td>
</tr>
<tr>
<td>Number Panels</td>
<td>Displays the number of truss panels, based on the Actual Panel Width. This is a read-only value.</td>
</tr>
<tr>
<td>Max Panel Width</td>
<td>Specifies the width of a single truss panel.</td>
</tr>
<tr>
<td>Actual Panel Thickness</td>
<td>Displays the width of each truss panel, based on the overall width and number of panels for the selected truss. This is a read-only value.</td>
</tr>
</tbody>
</table>

**Web Instance Properties**

<table>
<thead>
<tr>
<th>Web (Instance Pinned)</th>
<th>Web (Instance Unpinned)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name</td>
</tr>
<tr>
<td>Constraints</td>
<td>Constraints</td>
</tr>
<tr>
<td>Reference Level</td>
<td>Reference Level</td>
</tr>
<tr>
<td>Cross Section Rotation</td>
<td>Cross Section Rotation</td>
</tr>
<tr>
<td>Construction</td>
<td>Construction</td>
</tr>
<tr>
<td>Start Extension</td>
<td>Start Extension</td>
</tr>
<tr>
<td>Web (Instance Pinned)</td>
<td>Web (Instance Unpinned)</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>End Extension</td>
<td>End Extension</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td><strong>Materials and Finishes</strong></td>
</tr>
<tr>
<td>Beam Material</td>
<td>Beam Material</td>
</tr>
<tr>
<td><strong>Structural</strong></td>
<td><strong>Structural</strong></td>
</tr>
<tr>
<td>Moment Connection Start</td>
<td>Moment Connection Start</td>
</tr>
<tr>
<td>Moment Connection End</td>
<td>Moment Connection End</td>
</tr>
<tr>
<td>Cut Length</td>
<td>Cut Length</td>
</tr>
<tr>
<td>Structural Usage</td>
<td>Structural Usage</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td><strong>Dimensions</strong></td>
</tr>
<tr>
<td>Length</td>
<td>Length</td>
</tr>
<tr>
<td>Volume</td>
<td>Volume</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td><strong>Identity Data</strong></td>
</tr>
<tr>
<td>Comments</td>
<td>Comments</td>
</tr>
<tr>
<td>Mark</td>
<td>Mark</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td><strong>Phasing</strong></td>
</tr>
<tr>
<td>Web (Instance Pinned)</td>
<td>Web (Instance Unpinned)</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>Formulation, see Project Phasing on page 877.</td>
<td></td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Phase Demolished</td>
</tr>
<tr>
<td><strong>Structural Analysis</strong></td>
<td><strong>Structural Analysis</strong></td>
</tr>
<tr>
<td>Start Release</td>
<td>Start Release</td>
</tr>
<tr>
<td>Start FX</td>
<td>Start FX</td>
</tr>
<tr>
<td>Start FY</td>
<td>Start FY</td>
</tr>
<tr>
<td>Start FZ</td>
<td>Start FZ</td>
</tr>
<tr>
<td>Start MX</td>
<td>Start MX</td>
</tr>
<tr>
<td>Start MY</td>
<td>Start MY</td>
</tr>
<tr>
<td>End Release</td>
<td>End Release</td>
</tr>
</tbody>
</table>
### Web (Instance Pinned) & Web (Instance Unpinned)

<table>
<thead>
<tr>
<th>Name</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>End FX</td>
<td>End FX</td>
<td>The translational release at the end of the web along the x-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>End FY</td>
<td>End FY</td>
<td>The translational release at the end of the web along the y-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>End FZ</td>
<td>End FZ</td>
<td>The translational release at the end of the web along the z-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>End MX</td>
<td>End MX</td>
<td>The rotational release at the end of the web along the local x-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>End MY</td>
<td>End MY</td>
<td>The rotational release at the end of the web along the local y-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>End MZ</td>
<td>End MZ</td>
<td>The rotational release at the end of the web along the local z-axis. This value is read-only when pinned.</td>
</tr>
</tbody>
</table>

### Other

<table>
<thead>
<tr>
<th>Name</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Extension Calculation</td>
<td>Start Extension Calculation</td>
<td>This value is read-only.</td>
</tr>
<tr>
<td>End Extension Calculation</td>
<td>End Extension Calculation</td>
<td>This value is read-only.</td>
</tr>
</tbody>
</table>

### Top/Bottom Chord Instance Properties

<table>
<thead>
<tr>
<th>Top/Bottom Chord (Instance Pinned)</th>
<th>Top/Bottom Chord (Instance Unpinned)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name</td>
</tr>
<tr>
<td>Constraints</td>
<td>Constraints</td>
</tr>
<tr>
<td>Reference Level</td>
<td>Reference Level</td>
</tr>
<tr>
<td>Start Level Offset</td>
<td>Start Level Offset</td>
</tr>
</tbody>
</table>
| End Level Offset  | End Level Offset  | Specifies the distance of the chord end-point from the reference level. Values entered here are reset when the mem-

338 | Chapter 13  Structural Modeling
<table>
<thead>
<tr>
<th><strong>Top/Bottom Chord (Instance Pinned)</strong></th>
<th><strong>Top/Bottom Chord (Instance Unpinned)</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name</td>
<td>ber is re-pinned. This value is read-only when pinned.</td>
</tr>
<tr>
<td>z-Direction Justification</td>
<td>z-Direction Justification</td>
<td>Specifies the location of the physical geometry with respect to the truss chord layout line: either Top, Center, Bottom or Other. Changes to this parameter are reset to Center when the member is re-pinned. This value is read-only when pinned.</td>
</tr>
<tr>
<td>z-Direction Offset Value</td>
<td>z-Direction Offset Value</td>
<td>Enabled when the z-Direction Justification is set to Other. The value sets the location of the top flange of the chord with respect to the truss chord layout line. The parameter is ignored when the member is re-pinned. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Lateral Justification</td>
<td>Lateral Justification</td>
<td>Specifies the location of the physical geometry (in plan view) with respect to the location line: either Side 1, Side 2 and Center. No change to this parameter when re-pinned.</td>
</tr>
<tr>
<td>Cross Section Rotation</td>
<td>Cross Section Rotation</td>
<td>Specifies the rotation angle of the member about its location line. The parameter is reset to the value specified in the truss family for the top or bottom chord respectively. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Construction</td>
<td>Construction</td>
<td>Specifies the distance between the physical geometry and the end of the location line for the start of the member.</td>
</tr>
<tr>
<td>Start Extension</td>
<td>Start Extension</td>
<td>Specifies the distance between the physical geometry and the end of the location line for the end of the member.</td>
</tr>
<tr>
<td>End Extension</td>
<td>End Extension</td>
<td></td>
</tr>
<tr>
<td>Materials and Finishes</td>
<td>Materials and Finishes</td>
<td></td>
</tr>
<tr>
<td>Beam Material</td>
<td>Beam Material</td>
<td>A standard material parameter from the structural framing family. This parameter is not affected by re-pinning.</td>
</tr>
<tr>
<td>Structural</td>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Top/Bottom Chord (Instance Pinned)</td>
<td>Top/Bottom Chord (Instance Unpinned)</td>
<td>Description</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td><strong>Name</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Stick Symbol Location</td>
<td>Stick Symbol Location</td>
<td>Controls the location of the symbolic coarse representation of the beam, relative to the member local axis: either Top of Geometry, Center of Geometry, Bottom of Geometry, or Location Line. (The location line is the truss chord layout line.) The parameter is not changed when the member is re-pinned. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Moment Connection Start</td>
<td>Moment Connection Start</td>
<td>Controls whether a moment connection symbol displays at the start of the member coarse representation, when viewed in elevation.</td>
</tr>
<tr>
<td>Moment Connection End</td>
<td>Moment Connection End</td>
<td>Controls whether a moment connection symbol displays at the end of the member coarse representation, when viewed in elevation.</td>
</tr>
<tr>
<td>Cut Length</td>
<td>Cut Length</td>
<td>A standard read-only parameter from the structural framing family. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Structural Usage</td>
<td>Structural Usage</td>
<td>Specifies the structural usage for the member: either Girder, Horizontal Bracing, Joist, Other, Purlin, and Chord. The value is not reset when the member is re-pinned. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Camber Size</td>
<td>Camber Size</td>
<td>A standard structural framing parameter.</td>
</tr>
<tr>
<td>Number of Studs</td>
<td>Number of Studs</td>
<td>A standard structural framing parameter.</td>
</tr>
<tr>
<td>Dimensions</td>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td>Length</td>
<td>A standard read-only parameter from the structural framing family.</td>
</tr>
<tr>
<td>Volume</td>
<td>Volume</td>
<td>A standard read-only parameter from the structural framing family.</td>
</tr>
<tr>
<td>Identity Data</td>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>Comments</td>
<td>A standard structural framing parameter.</td>
</tr>
<tr>
<td><strong>Top/Bottom Chord (Instance Pinned)</strong></td>
<td><strong>Top/Bottom Chord (Instance Un-pinned)</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>-----------------------------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td><strong>Mark</strong></td>
<td><strong>Mark</strong></td>
<td>A standard structural framing parameter.</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Phase Created</td>
<td>Indicates in which phase the truss component was created. For more information, see Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Phase Demolished</td>
<td>Indicates in which phase the truss component was demolished. See Project Phasing on page 877.</td>
</tr>
<tr>
<td><strong>Structural Analysis</strong></td>
<td><strong>Structural Analysis</strong></td>
<td></td>
</tr>
<tr>
<td>Start Release</td>
<td>Start Release</td>
<td>Specify one of 3 pre-defined member end release conditions at the start of the member: either Fixed, Pinned, Bending Moment, or User Defined. Re-pinning the member will reset the parameter to the setting in the truss layout family. Refer to the analytical model settings. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Start FX</td>
<td>Start FX</td>
<td>The translational release at the start of the top/bottom chord along the x-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Start FY</td>
<td>Start FY</td>
<td>The translational release at the start of the top/bottom chord along the y-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Start FZ</td>
<td>Start FZ</td>
<td>The translational release at the start of the top/bottom chord along the z-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Start MX</td>
<td>Start MX</td>
<td>The rotational release at the start end of the top/bottom chord along the local x-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Start MY</td>
<td>Start MY</td>
<td>The rotational release at the start end of the top/bottom chord along the local y-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Start MZ</td>
<td>Start MZ</td>
<td>The rotational release at the start end of the top/bottom chord along the local z-axis. This value is read-only when pinned.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>End Release</td>
<td>Specify one of 3 pre-defined member end release conditions at the end of the member: either Fixed, Pinned, Bending Moment, or User Defined. Re-pinning the member will reset the parameter to the setting in the truss layout family. This value is read-only when pinned.</td>
<td></td>
</tr>
<tr>
<td>End FX</td>
<td>The translational release at the end of the top/bottom chord along the x-axis. This value is read-only when pinned.</td>
<td></td>
</tr>
<tr>
<td>End FY</td>
<td>The translational release at the end of the top/bottom chord along the y-axis. This value is read-only when pinned.</td>
<td></td>
</tr>
<tr>
<td>End FZ</td>
<td>The translational release at the end of the top/bottom chord along the z-axis. This value is read-only when pinned.</td>
<td></td>
</tr>
<tr>
<td>End MX</td>
<td>The rotational release at the end of the top/bottom chord along the local x-axis. This value is read-only when pinned.</td>
<td></td>
</tr>
<tr>
<td>End MY</td>
<td>The rotational release at the end of the top/bottom chord along the local y-axis. This value is read-only when pinned.</td>
<td></td>
</tr>
<tr>
<td>End MZ</td>
<td>The rotational release at the end of the top/bottom chord along the local z-axis. This value is read-only when pinned.</td>
<td></td>
</tr>
<tr>
<td>Vertical Projection</td>
<td>Specifies the location of the member’s analytical model with respect to the physical geometry: either Auto-detect, Top of beam, Center of Beam, or any of the available data (Levels or named reference planes). For more information, see the help section on the analytical model. This value is read-only when pinned.</td>
<td></td>
</tr>
<tr>
<td>Analytical Model</td>
<td>Analytical Model</td>
<td></td>
</tr>
<tr>
<td>Other</td>
<td>Other</td>
<td></td>
</tr>
<tr>
<td>Start Extension Calculation</td>
<td>This value is read-only.</td>
<td></td>
</tr>
<tr>
<td>End Extension Calculation</td>
<td>This value is read-only.</td>
<td></td>
</tr>
</tbody>
</table>
Openings in a Structural Beam, Brace, or Structural Column

You can cut openings through different structural elements such as beams, braces, or structural columns, using the Opening by Face tool. For more information, see Openings on page 561. The following behavior applies to all structural elements:

- A beam opening is applied to a face that is vertical or horizontal through the major or minor axis (typically vertical or horizontal) of the beam.

- A beam opening cuts through the entire element (for example, it cannot cut only one flange of a wide-flange beam).

- Two perpendicular planes for openings are provided by each beam, brace, or column. These planes align with the major and minor axis of the member.

**NOTE** Curved beams are not valid hosts for beam openings.

To cut an opening in a structural beam, brace, or structural column

1. Click Home tab ➤ Opening panel ➤ By Face.
2. Select the desired plane of the member to which you want to add an opening.

   Selecting the plane of the column

3. Using the Draw panel sketching tools, sketch the opening on the beam, brace, or column.
When you sketch an opening for a structural beam, brace, or structural column using the rectangle option, you can specify a radius, which allows you to sketch rectangles with fillets. This helps to avoid sharp corners on the opening that can concentrate stresses.

**Beam opening with radius**

For more information, see Sketching on page 1405.

4 On the ribbon, click Mode panel ➤ Finish Edit Mode.

**Finished sketch**
Structural Stiffeners

You use stiffeners to strengthen steel framing members, especially beams and columns in which there are openings. Stiffeners are modeled as Revit loadable families that represent the additional steel reinforcing material.

For information about openings in structural framing members, see Openings in a Structural Beam, Brace, or Structural Column on page 343.

To add a stiffener to a structural member opening

1. Click Home tab ➤ Model panel ➤ Component drop-down ➤ Place a Component.
2. On the Properties palette, select a stiffener type from the Type Selector drop-down.
   
   **NOTE** If the type of stiffener you want is not listed in the Type Selector, load additional stiffener families. (See Loading Structural Families on page 218.)

3. Click Modify | Place Component tab ➤ Placement panel ➤ Place on Face or Place on Work Plane.
   
   **NOTE** Structural stiffeners cannot be placed on structural element faces when the view is in wireframe mode.

4. Using the drawing tools, add the desired stiffener reinforcement to the beam opening. For more information about sketching, see Sketching on page 1405.

---

Structural Walls

All wall types within the Basic Wall family have an instance property called Structural Usage, which can have the following values:

<table>
<thead>
<tr>
<th>Structural Usage</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shear</td>
<td>Rigid planar surfaces that inherently resist lateral thrusts of shear.</td>
</tr>
<tr>
<td>Bearing</td>
<td>Walls that support a vertical load in addition to their own weight.</td>
</tr>
<tr>
<td>Non-bearing</td>
<td>Walls that define and divide spaces and support no vertical load except their own weight.</td>
</tr>
<tr>
<td>Structural combined</td>
<td>Walls that serve more than one purpose.</td>
</tr>
</tbody>
</table>

When you use the Wall tool, Revit Structure assumes you are placing partition walls. Whichever wall type you select, the default Structural Usage value is non-bearing. When you use the Structural Wall tool, and select the same wall type, the default Structural Usage value is bearing. In either case, the value is read-only, but you can change it after the wall is placed.
Creating a Structural Wall

1. Click Home tab ➤ Structure panel ➤ Wall drop-down ➤ Structural Wall.
2. On the Properties palette, select the family type of the wall from the Type Selector drop-down.
3. (Optional) Change the instance properties of the wall to be placed if desired by clicking on the Properties palette. See Modifying Type Properties on page 38.
   Modify the Type Parameters of the wall to be placed by clicking the Edit Type button on the Properties palette. See Structural Wall Properties on page 351.
4. The Height/Depth area of the Options Bar is shown in the following illustration.

   ![Options Bar](image)

   You may pre-select the height (top) or depth (base) of a structural wall from the Options Bar. Select either Height or Depth from the list box, then use the Constraint list to the right of Height/Depth selection to set the constraint of the top or base of the wall either by Level or as Unconnected. If you select Unconnected, specify the height or depth by entering the value to the right of the constraint list. The Unconnected Height/Depth measurement is relative to the current Level.
5. On the Options Bar, select Chain if you intend to create a series of walls.
Creating a structural wall chain

Sketch the wall

6 Sketch the shape of the wall. If the walls do not appear after you draw them, you may need to lower the view depth or create a foundation level to use as an underlay for the current level. See View Range on page 864 and View Properties on page 873.

7 Optionally, edit structural walls. See Modifying Walls on page 454 and Splitting Elements on page 1509.

8 Optionally, create arc walls. See Arc Walls on page 350.

NOTE For information about structural floors and hidden lines, see Display of Hidden Lines of Structural Concrete Components on page 395.

Related topics

- Modifying Structural Walls on page 347
- Defining Structural Wall Shapes or Openings on page 348
- Structural Walls on page 345

Modifying Structural Walls

You can modify the appearance of structural walls through their properties either before or after you place the wall.

Modifying Structural Walls

You modify wall properties, on the Properties palette. To open the dialog, do one of the following:

- Select the wall.
- Right-click the wall and click Properties. The shortcut menu also contains several options for manipulating the wall, such as changing the zoom scale.
Changing Structural Wall Types

Select a wall in the drawing area, and then select a different family type in the Type Selector at the top of the Properties palette.

Interior and Exterior Structural Wall Properties

The properties of a wall vary, depending on whether it is an interior or an exterior wall. In addition, when you modify type properties, all walls of that type are modified. When you modify instance properties, the properties of a single instance of a wall are modified.

NOTE When you modify parameters, the type names do not update. For example, if you change the width of an exterior wall from 200 mm to 250 mm, its name retains a reference to the original width.

Defining Structural Wall Shapes or Openings

When you sketch a wall by picking 2 points, Revit Structure draws a rectangular wall by default. You can modify the shape of the wall or add openings to it by editing its elevation profile. To edit a wall’s elevation profile, the view must be parallel and can be either a section or elevation view. You cannot edit the elevation profile of an arc wall.

Design with non-rectangular walls and cut openings

Modifying Structural Wall Elevation Profiles

1 In the drawing area, select a wall.

2 Click Modify I Walls tab ➤ Mode panel ➤ Edit Profile.

   If you select a wall in a plan view, the Go To View dialog displays. Select an elevation view, and click Open View.

Wall displayed as model lines
3 Edit the wall as desired:
- Delete the lines and then sketch a completely different shape.
- Split the existing lines and add arcs.
- Draw openings or holes.

Wall modified

**TIP** As you edit the rectangle, datum planes display to indicate the original shape and size of the wall. If the lines you sketch snap to the datum planes, the endpoints of the lines automatically align to the planes, unless you explicitly unlock them. If you unlock the sketched lines, you can modify them independently of the datum planes. If you exit sketch mode while the sketched lines are still aligned, as you move a datum handle, the sketched lines move with it.

Sketch lines unlocked

4 Click Modify | Walls > Edit Profile tab ➤ Mode panel ➤ Finish Edit Mode.

Modified wall displayed in 3D
**NOTE** If you want an edited wall profile to revert to its original shape, select the wall, and click Modify | Walls tab ➤ Mode panel ➤ Reset Profile.

**Tips for Defining Structural Wall Shapes or Openings**

- When you define a wall shape on a wall that is not horizontal or vertical in a plan view, you should draw a section parallel to the wall before sketching in the elevation. The Go To View dialog displays. Revit Structure suggests the section view as the optimal view for editing the sketch.

- When you edit the elevation profile of a wall attached to another element, the wall temporarily reverts to its original shape and height. For example, the profile of a wall attached to a roof assumes its unconnected height prior to being attached to the roof. As a result, you may find the wall is not at the right height to edit the elevation profile. To change the unconnected height, click on the Properties palette.

As you edit the elevation profile, keep in mind that after you finish the sketch, the wall top or bottom attaches only where horizontal lines are coincident with the reference planes in the sketch.

The sample sketched profile. Note the top sketch lines are coincident with reference planes.

The finished wall attached to roof. Non-coincident horizontal lines from the sketch did not attach.

**Arc Walls**

**Resizing Arc Walls**

You can resize arc walls using middle and end controls.

1. Select an arc wall.
2 Drag the end controls to change the arc length.

3 To change the arc radius while keeping it concentric, select Keep Concentric on the Options Bar.
   Leave this option deselected to retain existing end conditions, such as endpoint location or tangency to a straight wall.

4 Drag the middle control.

**Cutting Arc Walls**

You can cut square or rectangular openings into an arc wall by editing the elevation of the wall. See "Editing the Profile of a Wall" on page 455.

1 In either a 3D or elevation view, select an arc wall.

2 Click Modify | Walls tab ➤ Modify Wall panel ➤ Wall Opening.
   The Rectangles tool becomes active.

3 Sketch rectangular openings in the arc wall.

4 When finished, click Select panel ➤ Modify.

As you sketch the openings, permanent dimensions appear. If the wall has a top constraint set to a level, dimensions appear from both the top and base constraints. If the wall has a top constraint that is explicit, dimensions appear from the base constraint only.

**Structural Wall Properties**

You can modify many properties for structural walls, as shown in the following 2 sections:
## Structural Wall Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Structure</td>
<td>Specifies a wall layer. Select the Edit button to add, change, or delete a wall layer.</td>
</tr>
<tr>
<td>Wrapping at Inserts</td>
<td>Specifies the layer wrapping of walls at inserts. See <a href="#">Layer Wrapping</a> on page 576.</td>
</tr>
<tr>
<td>Wrapping at Ends</td>
<td>Specifies the layer wrapping of wall endcaps. See <a href="#">Setting Layer Wrapping</a> on page 576.</td>
</tr>
<tr>
<td>Width</td>
<td>Specifies the width of the wall.</td>
</tr>
<tr>
<td>Wall Function</td>
<td>Specifies the function of the wall which identifies specific properties: either Interior, Exterior, Foundation, Retaining, Soffit, or Core-shaft.</td>
</tr>
<tr>
<td>Additional Top/Exterior Offset</td>
<td>Specifies an additional offset from the top/exterior rebar cover. This allows placing multiple rebar elements together in different area reinforcement layers. See <a href="#">Rebar Cover Element Properties</a> on page 401.</td>
</tr>
<tr>
<td>Additional Bottom/Interior Offset</td>
<td>Specifies an additional offset from the bottom/interior rebar cover. This allows placing multiple rebar elements together in different area reinforcement layers. See <a href="#">Rebar Cover Element Properties</a> on page 401.</td>
</tr>
<tr>
<td>Additional Offset</td>
<td>Specifies an additional offset from the rebar cover. This allows placing multiple rebar elements together in different path reinforcement layers. See <a href="#">Rebar Cover Element Properties</a> on page 401.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Coarse Scale Fill Pattern</td>
<td>Specifies a fill pattern for a wall in a coarse-scale view. See <a href="#">View Properties</a> on page 873.</td>
</tr>
<tr>
<td>Coarse Scale Fill Color</td>
<td>Specifies a color for the fill pattern for a wall in a coarse-scale view.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Specifies or modifies the structural wall keynote. Click in the value box to open the Keynotes dialog. See <a href="#">Keynotes</a> on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The wall manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for entering general comments about the wall type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td>Description</td>
<td>A description of the wall.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>A description of the assembly based on the assembly code selection. This is a read-only value.</td>
</tr>
</tbody>
</table>
Assembly Code
A Uniformat assembly code selected from a hierarchical list.

Type Mark
A value that designates the particular wall. This value must be unique for each element in a project. Revit Structure warns you when the number is already used, but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.

Fire Rating
The fire rating of the wall.

Cost
The pricing of the wall.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Location Line</td>
<td>Specifies the position of the wall with respect to the line sketched in the project elevation. For more information, see Placing Walls on page 452. The wall location line remains the same for that wall, even if the type changes.</td>
</tr>
<tr>
<td>Base Constraint</td>
<td>Specifies the level from which the wall base is referenced.</td>
</tr>
<tr>
<td>Base Offset</td>
<td>Specifies the offset of the base of the wall from its base constraint.</td>
</tr>
<tr>
<td>Base is Attached</td>
<td>Indicates whether the base of the wall is attached to another component, such as a structural floor. This is a read-only value.</td>
</tr>
<tr>
<td>Base Extension Distance</td>
<td>Indicates the distance you have moved the base of the layers in a wall. See Compound Structure on page 573. This parameter is enabled when the layers of a wall are set to extendable.</td>
</tr>
<tr>
<td>Top Constraint</td>
<td>The name of the level to which the wall top is set.</td>
</tr>
<tr>
<td>Unconnected Height</td>
<td>If top constraint is unconnected, you may set an unconnected height of the wall. This value is read-only if there is a top constraint.</td>
</tr>
<tr>
<td>Top Offset</td>
<td>Specifies the offset of the top of the wall from its top constraint; enabled only when the top constraint is set to a level.</td>
</tr>
<tr>
<td>Top is Attached</td>
<td>Indicates whether the top of the wall is attached to another component, such as a structural floor. This is a read-only value.</td>
</tr>
<tr>
<td>Top Extension Distance</td>
<td>Indicates the distance you have moved the top of the layers in a wall. See Compound Structure on page 573. This parameter is enabled when the layers of a wall are set to extendable.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>Indicates whether the wall is part of a room boundary. This parameter is enabled after you place the wall.</td>
</tr>
<tr>
<td>Related to Mass</td>
<td>This is a read-only value.</td>
</tr>
</tbody>
</table>

Structural Wall Instance Properties
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rebar Cover - Exterior Face</td>
<td>Specifies the rebar cover distance from the wall exterior face.</td>
</tr>
<tr>
<td>Rebar Cover - Interior Face</td>
<td>Specifies the rebar cover distance from the wall interior face.</td>
</tr>
<tr>
<td>Rebar Cover - Other Face</td>
<td>Specifies the rebar cover distance from the face of adjacent element.</td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Specifies the estimated reinforcement volume of the selected element. This is a read-only parameter that only displays when rebar has been placed.</td>
</tr>
<tr>
<td>Structural Usage</td>
<td>The structural use of the wall.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td>Indicates the length of the wall. This is a read-only value.</td>
</tr>
<tr>
<td>Area</td>
<td>Indicates the area of the wall. This is a read-only value.</td>
</tr>
<tr>
<td>Volume</td>
<td>Indicates the volume of the wall. This is a read-only value.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>A field for entering comments about the wall.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label created for the wall. This value must be unique for each element in a project. Revit Structure warns you when the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Indicates in which phase the wall component was created. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Indicates in which phase the wall component was demolished. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Analytical Model</td>
<td></td>
</tr>
<tr>
<td>Enable Analytical Model</td>
<td>Changes the visibility of the wall analytical model.</td>
</tr>
<tr>
<td>Horizontal Projection</td>
<td>Either Auto-detect, Center Line, Interior Face, Center of Core, or Exterior Face. Specifies the horizontal limits of the structural wall analytical model. Specifies the horizontal plane of the wall used for analysis and design. See Projection Plane Options for each Structural Element Type on page 1301 and Analytical Projection Rules on page 1289.</td>
</tr>
<tr>
<td>Top Vertical Projection</td>
<td>The top vertical plane of the wall used for analysis and design. See Projection Plane Options for each Structural Element Type on page 1301.</td>
</tr>
<tr>
<td>Bottom Vertical Projection</td>
<td>The bottom vertical plane of the wall used for analysis and design. See Projection Plane Options for each Structural Element Type on page 1301.</td>
</tr>
</tbody>
</table>
Wall Foundations

Wall foundations are members of the structural foundation category and are hosted by walls. You can place these foundations along structural walls, in either a plan or 3D view.

Wall foundations are constrained to the walls that they support and move with them.

Related topics
- Isolated Foundations on page 361
- Foundation Slabs on page 382
- Concrete Geometry Joins on page 393

Creating a Wall Foundation

1. Open a view that contains structural walls.
2. Click Home tab ➤ Foundation panel ➤ Wall , and select a wall foundation type from the Type Selector drop-down.

   **NOTE** There are both retaining and bearing wall foundation types available.

3. Select the wall to receive the wall foundation.

   The wall foundation is placed beneath the selected walls.
NOTE The wall foundation is created at the bottom of the selected wall. If the created wall foundation is beyond the view range of the active view, you are prompted with a warning.

Modifying a Wall Foundation

You edit the lengths of wall foundations with end controls. They display as small filled circles that indicate where the end of the selected wall foundation is attached. End controls snap to other visible references.

This is useful when you need to extend a wall foundation to accommodate the needs of a building, such as a footing for a run of stairs.

Use the following steps to extend the length of a wall foundation.

1. Select the wall foundation to display its end controls.
2 Drag either end of the foundation as needed.

Plan view.

3D view.

Default End Extensions

You can define the default length that unjoined wall foundations extend beyond their host walls. This default is defined in the Wall Foundation Type Properties on page 359.

Under the Dimensions section, enter a value in the Default End Extension Length parameter. Unjoined wall foundation ends extend this distance beyond their host wall. The defined value applies to the entire project.

Wall Foundation Breaks Beneath Doors and Windows

When you create a door or window that extends to the base of the wall, the wall foundation breaks beneath the new element.

To change the default behavior, access the type properties for the wall foundation and clear the Do Not Break at Inserts option. See Wall Foundation Type Properties on page 359.
NOTE The wall opening tool will break the wall foundation if the opening extends to the base of the wall. These openings are not affected by this parameter. See Cutting Rectangular Openings in Walls on page 562.

Tagging a Wall Foundation with Elevation

You can display the bottom elevation in a view by tagging the foundation with the Structural Foundation Tag with Elevation tag. It is loaded from the family library, under Structural/Annotations. See Loading Tag Styles on page 1612.

When the Structural Foundation Tag with Elevation is applied, the bottom elevation of structural foundations (footings) is reported in a read-only instance parameter called Elevation at Bottom. See Applying a Tag By Category on page 945.

Changing the Structural Usage of a Wall Foundation

You can change the Structural Usage (either Retaining or Bearing) of a wall foundation in two ways. You can change the wall foundation to an appropriate wall foundation type or change its structural usage type properties.

To change the wall foundation type

1 Select the wall foundation.
2 Select a retaining or bearing wall foundation type from the Type Selector drop-down on the Properties palette.

To change the structural usage type properties

1 Select the wall foundation.
2 On the Properties palette, under Structural, select Retaining or Bearing for the Structural Usage parameter.

If you select Retaining, you can specify values for Toe Length, Heel Length, and Foundation Thickness. Toe and heel length define the width of the foundation. For more information, see Wall Foundation Properties on page 358.

If you select Bearing, you can specify values for Width and Foundation Thickness.

Wall Foundation Properties

There are two types of wall foundations for structural use: bearing and retaining. You can modify the properties for both types, including heel length, toe length, foundation thickness, and width.
Modifying Wall Foundation Properties

1 Select the wall foundation.
2 On the Properties palette, edit wall foundation instance parameters. (See Wall Foundation Instance Properties on page 360.)
3 Click Edit Type to edit wall foundation type parameters. (See Wall Foundation Type Properties on page 359.)

NOTE Changes made to type parameters affect all wall foundations of this type in the project. You can click Duplicate to create a wall foundation type.

Wall Foundation Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Materials and Finishes</td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>Specifies the concrete type to be used.</td>
</tr>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Structural Usage</td>
<td>Specifies the wall usage type: either Retaining or Bearing.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Toe Length</td>
<td>Retaining walls only. Specifies the distance from the edge of the host wall to the outside face of the foundation.</td>
</tr>
<tr>
<td>Heel Length</td>
<td>Retaining walls only. Specifies the distance from the edge of the host wall to the inside face of the foundation.</td>
</tr>
<tr>
<td>Width</td>
<td>Bearing walls only. Specifies the overall width of the bearing wall foundation.</td>
</tr>
<tr>
<td>Foundation Thickness</td>
<td>Specifies the foundation thickness.</td>
</tr>
<tr>
<td>Default End Extension Length</td>
<td>Specifies the distance that the foundation will extend beyond the end of the wall.</td>
</tr>
<tr>
<td>Do Not Break At Inserts</td>
<td>Specifies whether the foundation is continuous or breaks beneath inserts such as doors and windows that extend to the base of the wall.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The foundation manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for placing general comments about the foundation type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description of the wall foundation.</td>
</tr>
</tbody>
</table>
### Wall Foundation Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraint</td>
<td></td>
</tr>
<tr>
<td>Eccentricity</td>
<td>Specifies the offset from the wall center line to the bearing foundation center line.</td>
</tr>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Rebar Cover - Top Face</td>
<td>Specifies the rebar cover distance from the wall top face.</td>
</tr>
<tr>
<td>Rebar Cover - Bottom Face</td>
<td>Specifies the rebar cover distance from the wall bottom face.</td>
</tr>
<tr>
<td>Rebar Cover - Other Faces</td>
<td>Specifies the rebar cover distance from the wall to adjacent element faces.</td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Specifies the estimated reinforcement volume of the selected element. This is a read-only parameter that only displays when rebar has been placed.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td>Indicates the overall length. This is a read-only parameter.</td>
</tr>
<tr>
<td>Width</td>
<td>Indicates the overall width. This is a read-only parameter.</td>
</tr>
<tr>
<td>Volume</td>
<td>Indicates the volume of the foundation. This is a read-only parameter.</td>
</tr>
<tr>
<td>Elevation at Bottom</td>
<td>Indicates the elevation used for tagging the Bottom of Foundation. This parameter is affected by the family parameter Cap (see Family Category and Parameters on page 695). The following image shows the difference between the Cap parameter enabled (in red) and disabled (in green). The Elevation at Bottom measurement is taken from this setting. This is a read-only parameter.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Comments</td>
<td>A field for placing general comments about the foundation type.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label created for the foundation. This value must be unique for each element in a project. Revit Structure warns you when the number value is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
</tbody>
</table>

**Phasing**

<table>
<thead>
<tr>
<th>Phase Created</th>
<th>Indicates in which phase the foundation component was created. See Project Phasing on page 877.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase Demolished</td>
<td>Indicates in which phase the foundation component was demolished. See Project Phasing on page 877.</td>
</tr>
</tbody>
</table>

**Structural Analysis**

| Analyze As | Indicates the property type for structural analysis. Select either Foundation or Not for Analysis.                                           |

**Isolated Foundations**

Isolated foundations are standalone families that are part of the structural foundation category. Several types of isolated foundations can be loaded from the family library, including pile caps with multiple piles, rectangular piles, and single piles.

**Pile caps with multiple piles**
Adding Isolated Foundations

1 Click Home tab ➤ Foundation panel ➤ Isolated.
   You can load isolated foundation families by clicking Modify | Place Isolated Foundation tab ➤ Model panel ➤ Load Family.

2 On the Properties palette, select an isolated foundation type from the Type Selector drop-down.

3 Place the isolated foundation in either a plan or 3D view.
Rectangular isolated foundation

The Bottom Elevation of structural foundations (footings) is reported in a read-only instance parameter called Elevation at Bottom. You can then display this value in a view by tagging the foundation with the Structural Foundation Tag with Elevation tag. It is available from the family library, under Structural/Annotations. For more information, see Applying a Tag By Category on page 945.

**Isolated Foundation Properties**

You can use several standard types of isolated foundations: either Rectangular Footings, Concrete Pile-Caps, or Steel Pipe Piles.

**Modifying Isolated Foundation Properties**

You can edit isolated foundation properties, such as those indicating structure, dimension, and identity.

**To edit isolated foundation properties**

1. Select the isolated foundation.
2. On the Properties palette, edit isolated foundation instance parameters. (See Isolated Foundation Instance Properties on page 364.)
3. Click Edit Type to edit isolated foundation type parameters. (See Isolated Foundation Type Properties on page 363.)

**NOTE** Changes made to type parameters affect all isolated foundations of this type in the project. You can click Duplicate to create a new isolated foundation type.

**Isolated Foundation Type Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Width</td>
<td>Specifies the width of the isolated foundation type. Applies to the Pile Cap Pile family type.</td>
</tr>
<tr>
<td>Length</td>
<td>Specifies the length of the isolated foundation type. Applies to the Pile Cap Pile family type.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Specifies the foundation thickness. Applies to the Pile Cap Pile family type.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Assembly Code</td>
<td>A Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the isolated foundation keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The foundation manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for placing general comments about the foundation type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description of the foundation.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Describes the assembly based on the assembly code selection. This is a read-only parameter.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value that designates the specific foundation. This value must be unique for each element in a project. Revit Structure warns you when the number value is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>The pricing of the foundation.</td>
</tr>
<tr>
<td>OmniClass Number</td>
<td>The number from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
<tr>
<td>OmniClass title</td>
<td>The name from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
</tbody>
</table>

**Isolated Foundation Instance Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Level</td>
<td>The level to which the slab is constrained.</td>
</tr>
<tr>
<td>Host</td>
<td>The level to which the host of the isolated slab is constrained.</td>
</tr>
<tr>
<td>Offset</td>
<td>Specifies the elevation of the top of the isolated foundation relative to its level.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Moves With Grids</td>
<td>Changes the column constraint to grid.</td>
</tr>
<tr>
<td>Materials and Finishes</td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>Specifies the material of the isolated foundation.</td>
</tr>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Rebar Cover - Top Face</td>
<td>Specifies the distance of the rebar cover from the element top face.</td>
</tr>
<tr>
<td>Rebar Cover - Bottom Face</td>
<td>Specifies the distance of the rebar cover from the element bottom face.</td>
</tr>
<tr>
<td>Rebar Cover - Other Faces</td>
<td>Specifies the distance of the rebar cover from the element to adjacent element faces.</td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Specifies the estimated reinforcement volume of the selected element. This is a read-only parameter that only displays when rebar has been placed.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Elevation at Bottom</td>
<td>Indicates the elevation used for tagging the Bottom of Foundation.</td>
</tr>
<tr>
<td></td>
<td>This parameter is affected by the family parameter Cap (see Family Category and Parameters on page 695). The following image shows the difference between the Cap parameter enabled (in red) and disabled (in green).</td>
</tr>
<tr>
<td></td>
<td>The Elevation at Bottom measurement is taken from this setting.</td>
</tr>
<tr>
<td></td>
<td>This is a read-only parameter.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>A field for entering comments about the wall.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label created for the element. This value must be unique for each element in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Indicates in which phase the component was created. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Indicates in which phase the component was demolished. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Structural Analysis</td>
<td></td>
</tr>
<tr>
<td>Analyze As</td>
<td>Indicates the property type for structural analysis. Select either Foundation or Not for Analysis.</td>
</tr>
</tbody>
</table>


Structural Floors

You add structural floors to the building model using a similar interface and functionality as those used when creating floors. This functionality includes creating and editing slab edges, thickened slabs, drop panels, or ramps, as well as user selection and user creation of structural floor types.

Typical structural floors

![Typical structural floors diagram]

Related topics

- Floors on page 555
- Sloped Floors on page 556
- Slab Edges on page 379
- Ramps on page 607

Adding a Structural Floor or Deck

You create structural floors and decks by sketching them. You can sketch lines for the slab edges either by picking walls or by using the Line tool. Typically you will sketch a floor in a plan view, although you can sketch it in a 3D view, provided the work plane of the 3D view is set to the work plane in which you want to place the structural floor. The top of the structural floor is offset relative to the level at which it is placed. For information about Height Offset from Level, and other Structural Floor parameters, see Structural Floor Properties on page 376.

For information about structural floors and hidden lines, see Display of Hidden Lines of Structural Concrete Components on page 861.

To add a structural floor

1. Click Home tab ➤ Structure panel ➤ Floor drop-down ➤ (Structural Floor).
2. From the Type Selector, specify a structural floor type.
3. On the ribbon, click (Boundary Line).
4. Click (Pick Walls) and select the bounding walls.
NOTE Instead of picking walls you can sketch a structural floor. On the Draw panel of the ribbon, use the sketch tools to form the boundary of the structural floor. The sketch must form a closed loop or boundary condition.

5 Click (Span Direction).
6 (Optional) On the Options Bar:
   ■ specify an offset for slab edges.
   ■ select Extend into wall (to core).

7 On the ribbon, click ✓ (Finish Edit Mode).

NOTE To add openings to a structural floor, see Openings in Structural Floors on page 372.

Related topics
■ Cantilevers on page 367
■ Span Direction on page 369
■ Modifying Structural Floors on page 375
■ Structural Floors on page 366

Cantilevers

The Slab Cantilever property allows the sketch of the structural floor both to be constrained to its supports and its edge to be extended beyond them. Cantilevers are applied to structural floors, either before or after sketching the structural floor.

Cantilevers are created by adjusting 2 offset parameters that represent the concrete and steel deck of a structural floor.
In composite concrete and metal decks, the steel cantilever parameter will always be the lesser of the 2 offsets. In the event that the structural floor is all concrete or metal, the appropriate offsets should be set.

**Applying Cantilevers when Creating a Structural Floor**

1. Open a plan view displaying the beams or bay that will support the structural floor.
2. Click Home tab ➤ Structure panel ➤ Floor drop-down ➤ Structural Floor.
3. Click Modify | Create Floor Boundary tab ➤ Draw panel ➤ Boundary Line and then click (Pick Supports).
4. On the Properties palette, under Other, enter offset values for both Concrete Cantilever and Steel Cantilever.
5. Click Apply.
6. Select the beams that will support the structural floor.
7. Click Modify | Create Floor Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

**NOTE** The cantilever offset is applied in relation to the direction that the slab edge was created. This is applicable to line sketching, Pick Supports, or Pick Walls structural floor creation. In instances where the cantilever appears to be inside the structural floor: enter sketch mode, select the edge, and adjust the cantilever values to negative numbers.

**Applying Cantilevers to an Existing Structural Floor**

1. Select a structural floor in a plan view.
2 Click Modify | Floors tab ➤ Mode panel ➤ Edit Boundary.
3 Select the slab edge that will receive the cantilever.

4 On the Options Bar, enter cantilever offset values for both of the concrete structural floor and metal deck.

![Cantilever Values](image)

**NOTE** The cantilever is applied only to the specified selected sketch line, not the entire structural floor.

5 Repeat steps 1 through 4 for any slab edge that requires a cantilever.
6 Click Modify | Floors > Edit Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

**NOTE** The cantilever offset is applied in relation to the direction that the slab edge was created. This is applicable to line sketching, Pick Supports, or Pick Walls structural floor creation. In instances where the cantilever appears to be inside the structural floor: enter sketch mode, select the edge, and adjust the cantilever values to negative numbers.

The following section view shows a concrete structural floor with a metal deck. The cantilevered concrete edge extends beyond the supporting beam.

![Section View](image)

**Span Direction**

When you place a structural floor, a span direction component is placed in plan view along with the structural floor. The span direction component is used to change the orientation of the steel deck in the plan. Deck span direction is designated by the direction of the filled half-arrows.
You can create new span direction types for decks and for one-way structural floors. For information about creating family types, see The Families Guide on page 680.

**Adding a Span Direction**

1. Add a **structural floor** and specify boundary lines.
2. Click Modify | Create Floor Boundary tab ➤ Draw panel ➤ (Span Direction).
3. Select from one of the following tools on the Draw panel of the ribbon:

<table>
<thead>
<tr>
<th>If you select...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Line)</td>
<td>sketch a line, or pick a model line, to define <strong>metal deck span direction</strong> that is independent of the sketched boundary lines. This line has no other function than to define the direction of the flutes in a metal deck and therefore cannot be used to close a loop.</td>
</tr>
<tr>
<td>If you select...</td>
<td>then...</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------</td>
</tr>
<tr>
<td><img src="Image" alt="Pick Lines" /></td>
<td>select the sketch boundary line to which you want all metal deck flutes to be parallel.</td>
</tr>
</tbody>
</table>

4 Optionally, on the **Properties palette**, under Structure, select the Structural parameter to place a Span Direction tag when Finish Edit Mode is selected.

5 On the ribbon, click ![Finish Edit Mode](Image).

### To add a span direction to an existing structural floor

1 Click Annotate tab ➤ Symbol panel ➤ Span Direction.
2 (Optional) To place the tag in the center of the structural floor, select Auto place on the Options Bar and click a structural floor to place the direction span.
3 If you did not select Auto place, select a structural floor.
4 Move the cursor to the desired location on the structural floor and click to place the direction span.

### Modifying Span Direction

#### To rotate a span direction symbol

1 Select the span direction component.
2 Click Modify | Span Direction Symbol tab ➤ Modify panel ➤ Rotate.
3 Click a start angle for the rotation of the span direction.
4 Click an end angle to complete the angle of rotation.

The tag rotates to align with the span direction.

#### To align the span direction to a structural floor, beam, or grid line

1 Select the span direction component.
2 Click Modify | Span Direction Symbol tab ➤ Align Symbol panel ➤ Align Perpendicular.
3 Select a structural floor, beam, or grid line to which the span direction will be perpendicular.

The deck aligns to the selected element.
Sloped Structural Floors

To create a sloped structural floor, use one of the following methods:

- **Draw a slope arrow** while sketching or editing the floor boundary.
- **Specify** a value for the Offset from Base property for parallel floor sketch lines.
- **Specify** values for the Defines Slope and Slope properties for a single floor sketch line.

Related topics

- [Sloped Surfaces Overview](#) on page 579
- [Shape Editing for Structural Floors, Roofs, and Floors](#) on page 386

Openings in Structural Floors

To allow for needs such as shafts or ramps between levels, you can cut openings in structural floors and roofs.
Typical opening in a structural floor

1. Click Home tab ➤ Opening panel ➤ By Face.
2. Select a structural floor.
3. Using the sketch tools on the Modify | Create Opening Boundary tab ➤ Draw panel, sketch the structural floor opening.
4. When finished, click Modify | Create Opening Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

**Drop Panels**

You can add drop panels to reinforce a structural floor at column locations. This is achieved by sketching a second smaller structural floor.

1. Open a plan view with a structural floor over a column.
2 Click Home tab ➤ Structure panel ➤ Floor drop-down ➤ Structural Floor.

3 Click Modify | Create Floor Boundary tab ➤ Draw panel ➤ Boundary Line, and use the sketching tools to complete a sketch of the drop panel (see Sketching on page 1405). The sketch must form a closed loop or boundary condition.

4 When finished, click Modify | Create Floor Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

5 View the drop panel in an elevation or cross section view.

6 Select the new drop panel.

7 Right-click the new drop panel and select Properties.

8 On the Properties palette, adjust the Constraint parameters of the drop panel so that it is at the correct elevation in your model.
9 Click Apply.

10 Join the geometry of the elements if necessary. See Joining Geometry on page 1506.

Modifying Structural Floors

You can modify structural floors either by editing structural floor properties or by directly changing structural floor geometry in the drawing area. To modify a structural floor before you add it, you must select the structural floor type in the Type Selector. When you activate the Structural Floor tool to place structural floors, you can select different types of structural floors in the Type Selector.
Other available modifications include:

- Edit the element properties. See Structural Floor Properties on page 376.
- Edit the sketch. See Sketching on page 1405.
- Edit the shape and thickness. See Shape Editing for Structural Floors, Roofs, and Floors on page 386.
- Apply rebar cover settings. See Rebar Cover on page 399.
- Add reinforcement. See Rebar Shapes on page 402.
- Adjust span direction. See Span Direction on page 369.
- Add cantilevers. See Cantilevers on page 367.
- Add slab edges. See Slab Edges on page 379.
- Apply drop panels. See Drop Panels on page 373.

### Structural Floor Properties

You specify structural floor properties on the Properties palette. You can open this dialog in several ways, such as to right-click the structural floor and click Properties. Structural floor properties include the structural floor thickness and elevation of the structural floor relative to the associated level.

The following sections detail parameter names, values, and descriptions for structural floors.

#### Modifying Structural Floor Properties

1. Select the structural floor.
2. On the Properties palette, edit structural floor instance parameters. (See Structural Floor Instance Properties on page 377.)
3. Click Edit Type to edit structural floor type parameters. (See Structural Floor Type Properties on page 376.)

**NOTE** Changes made to type parameters affect all structural floors of this type in the project. You can click Duplicate to create a new structural floor type.

#### Structural Floor Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Structure</td>
<td>Creates the composition of a compound floor. See Compound Structure on page</td>
</tr>
<tr>
<td></td>
<td>573.</td>
</tr>
<tr>
<td>Default Thickness</td>
<td>Indicates the thickness of a floor type, which is determined by the cumulative</td>
</tr>
<tr>
<td></td>
<td>thickness of its layers. See Shape Editing for Structural Floors, Roofs, and Floors on page 386.</td>
</tr>
<tr>
<td>Function</td>
<td>Indicates whether a floor is interior or exterior. Function is used in scheduling and to create filters to simplify a model when exporting.</td>
</tr>
</tbody>
</table>
### Structural Floor Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Level</strong></td>
<td>The level to which the floor is constrained.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Height Offset from Level</td>
<td>Specifies the elevation of the top of the floor relative to the Level parameter.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>Indicates that the floor is a room-bounding element.</td>
</tr>
<tr>
<td>Related to Mass</td>
<td>Indicates the element was created from a mass element. This is a read-only value.</td>
</tr>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Structural</td>
<td>Indicates that the element has an analytical model.</td>
</tr>
<tr>
<td>Rebar Cover - Top Face</td>
<td>The rebar cover distance from the floor top face. See Rebar Cover on page 399.</td>
</tr>
<tr>
<td>Rebar Cover - Bottom Face</td>
<td>The rebar cover distance from the floor bottom face. See Rebar Cover on page 399.</td>
</tr>
<tr>
<td>Rebar Cover - Other Faces</td>
<td>The rebar cover distance from the floor to adjacent element faces. See Rebar Cover on page 399.</td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Specifies the estimated reinforcement volume of the selected element. This is a read-only parameter that only displays when rebar has been placed.</td>
</tr>
<tr>
<td>Structural Floor Shape Edit</td>
<td></td>
</tr>
<tr>
<td>Curved Edge Condition</td>
<td>Specifies the structural floor surface to either Conform to curve or Project to side. This parameter is only available to curved edge structural floors. See Using the Curved Edge Condition Tool on page 390.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Slope Angle</td>
<td>Changes the slope-defining lines to the specified value, without the need to edit the sketch. The parameter initially displays a value if there is a slope-defining line. If there is no slope-defining line, the parameter is blank and disabled.</td>
</tr>
<tr>
<td>Perimeter</td>
<td>The perimeter of the floor. This is a read-only value.</td>
</tr>
<tr>
<td>Area</td>
<td>The area of the floor. This is a read-only value.</td>
</tr>
<tr>
<td>Volume</td>
<td>The volume of the floor. This is a read-only value.</td>
</tr>
<tr>
<td>Thickness</td>
<td>The thickness of the floor. This is a read-only value, unless a shape edit has been applied and its type contains a variable layer. When the value is writable it can be used to set a uniform thickness of the floor. The entry can be blank if the thickness varies. See Shape Editing for Structural Floors, Roofs, and Floors on page 386.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments related to the floor that are not already defined in the description or type comments.</td>
</tr>
<tr>
<td>Mark</td>
<td>A user-specified label for the floor. Possible use: shop mark. This value must be unique for each element in a project. Revit Structure warns you when the number value is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
</tbody>
</table>
### Slab Edges

You apply slab edges by selecting horizontal edges of structural floors. You can also select model lines.

1. **Click Home tab ➤ Structure panel ➤ Floor drop-down ➤ Slab Edge.**
   - You can also access this tool by clicking Home tab ➤ Foundation panel ➤ Slab drop-down ➤ Slab Edge.

2. **Select horizontal edges of structural floors to place a slab edge.**
   - You can also click model lines. As you click edges, Revit Structure treats this as one continuous slab edge. If the slab edge segments are created in the same placement session and meet at corners, they miter.

3. **Click Modify | Place Slab Edge tab ➤ Placement panel ➤ Restart Slab Edge.**

   ![Slab edge added to a structural floor](image)

### Tips

- You can place slab edges in 2D views (such as plan or section views) or in 3D views. Watch the status bar to look for valid references. For example, if you are placing a slab edge on a floor, the status bar might display: Floors : Basic Floor : Reference.

- When placing a slab edge in a section view, place the cursor near the corners of the structural floor to highlight the reference.

After placing slab edges, you can modify them in several ways.
Resizing or Flipping Slab Edges

You can resize structural floors. When you select the slab edge, a drag control appears at either end of it. Click and drag this control to extend or shorten the slab edge.

You can flip structural floors by using the flip controls that appear in a 3D view, or, if you are in a 2D view (such as section), you can right-click on the structural floor and select Flip About Horizontal Axis or Flip About Vertical Axis. See Controls and Shape Handles on page 1449.

Adding or Removing Segments of the Slab Edge

1. Select an existing slab edge, and click Modify | Slab Edges tab ➤ Profile panel ➤ Add/Remove Segments.
2. Click the edge of a structural floor to add a slab edge. Click the edge again to remove a slab edge.

NOTE You may need to press Tab to highlight a reference edge in section.

Changing Horizontal and Vertical Offsets of Slab Edges

You can change the horizontal or vertical offset of a slab edge either through its properties or by graphically moving the slab edge. See Slab Edge Properties on page 380.

Horizontal Move

To move a single slab edge segment, select the slab edge, and drag it horizontally.

To move a multi-segmented slab edge, select the shape handle of the slab edge. Place the cursor over the slab edge, and press Tab to highlight the shape handle. Watch the status bar to be sure you are highlighting the shape handle. Click to select the shape handle. Move the cursor left or right to change the horizontal offset. This affects the horizontal offset of all segments of the slab edge, so the segments are symmetrical.

Moving slab edge on the left also moves slab edge on the right

Vertical Move

Select the slab edge, and drag it up or down. If the slab edge is multi-segmented, all segments move up or down the same distance.

Slab edge moving vertically in section

Slab Edge Properties

The following table shows parameter names, values, and descriptions for slab edges. You can modify values.
## Slab Edge Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Profile</td>
<td>The profile shape for the particular slab edge. Select from a list of predefined profiles, or create your own profile using the profile-hosted.rft template. For detailed information about profile families, see The Families Guide on page 680.</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>Specifies the appearance of the slab edge in various views. See Materials on page 1573.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the slab edge keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The slab edge manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for placing general comments about the slab edge type. This information can be included in a schedule.</td>
</tr>
<tr>
<td><strong>URL</strong></td>
<td>A link to a web page that may contain type-specific information.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>You may provide a description of the slab edge here.</td>
</tr>
<tr>
<td>Assembly description</td>
<td>Describes the assembly based on the assembly code selection. This is a read-only value.</td>
</tr>
<tr>
<td><strong>Assembly Code</strong></td>
<td>The Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td><strong>Type Mark</strong></td>
<td>A value to designate the specific slab edge. This value must be unique for each element in a project. Revit Structure warns you when the number value is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td><strong>Cost</strong></td>
<td>The pricing of the slab edge.</td>
</tr>
</tbody>
</table>

## Slab Edge Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Vertical profile offset</td>
<td>Moves the slab edge above or below the edge on which you created it.</td>
</tr>
<tr>
<td>Horizontal profile offset</td>
<td>Moves the slab edge forward or backward from the edge on which you created it.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td>The actual length of the slab edge.</td>
</tr>
<tr>
<td>Volume (Slab edges only)</td>
<td>The actual volume of the slab edge.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Identity Data</td>
<td>A field for placing general comments about the slab edge.</td>
</tr>
<tr>
<td>Comments</td>
<td>A label created for the slab edge. Possible use: shop mark. This value must be unique for each element in a project. Revit Structure warns you when the number value is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Mark</td>
<td>Indicates in which phase the slab edge component was demolished. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Created</td>
<td>Indicates in which phase the slab edge component was created. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Indicates in which phase the slab edge component was demolished. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Profile</td>
<td>Rotates the slab edge to the desired angle.</td>
</tr>
<tr>
<td>Angle</td>
<td></td>
</tr>
</tbody>
</table>

**Foundation Slabs**

The Foundation Slab type has 3 more foundation-specific values than a regular structural floor has. These additional values, which are instance parameters displayed in the Properties palette, are: Width, Length, and Elevation at Bottom. Using these values, an analysis tool can distinguish between a standard structural floor and a foundation slab.

Foundation slabs may be used to model structural floors on a grade, which do not require support from other structural elements. Foundation slabs may also be used to model complex foundation shapes that cannot be created using Isolated or Wall Foundation tools.

**Adding Foundation Slabs**

1. Click Home tab ➤ Foundation panel ➤ Slab drop-down ➤ Foundation Slab.
2. On the Properties palette, click Edit Type.
3. On the Type Properties dialog, specify the structural floor type, and click OK.
4. Click Modify | Create Floor Boundary tab ➤ Draw panel ➤ Boundary Line and then click (Pick Walls) to select the walls in your model.
5. On the Options Bar, click Extend into wall if you want the offset to be measured from the wall's core.
6. On the Options Bar, specify an offset for slab edges in the Offset text box.
7. Click Modify | Create Floor Boundary tab ➤ Mode panel ➤ Finish Edit Mode.
8. Click the foundation, and select the desired Foundation family type on the Family drop-down list.

**NOTE** Instead of picking walls you can sketch a foundation slab. Use the sketch tools on the Modify | Create Floor Boundary tab ➤ Draw panel to form the boundary of the foundation slab. The sketch must form a closed loop or boundary condition. See Sketching on page 1405.
NOTE Foundation slabs are added below the level in which they are drawn. Therefore, if you add a foundation slab in Level 1, it is added below Level 1 and will not be visible in the Level 1 plan view. To see the foundation slab in a plan view, create a new level below Level 1, for example, Foundation Level. When you create a new level below Level 1, you will also be able to see the foundation slab as an underlay (displayed in halftone) in Level 1.

Related topics
- Openings in Structural Floors on page 372
- Modifying Structural Floors on page 375
- Structural Floors on page 366

Modifying Foundation Slab Properties
1 Select the foundation slab.
2 On the Properties palette, edit foundation slab instance parameters. (See Foundation Slab Instance Properties on page 384.)
3 Click Edit Type to edit foundation slab type parameters. (See Foundation Slab Type Properties on page 384.)

NOTE Changes made to type parameters affect all foundation slabs of this type in the project. You can click Duplicate to create a new foundation slab type.

Foundation Slab Properties
You can specify the Structural Usage parameter of a Foundation slab: either Foundation or Slab on Grade. If set to Foundation, the slab will provide support for other elements connected to it. If set to Slab on Grade, the slab will only support itself. The Foundation Slab type also has an additional, read-only parameter, Elevation at Bottom. The Elevation at Bottom parameter is used for tagging the Bottom of the Foundation elevation. You can modify parameter names, values, and descriptions for Foundation Slabs.
### Foundation Slab Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Structure</td>
<td>Select the Edit button to add, change, or delete slab layers.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Slab thickness. This is a read-only parameter.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Coarse Scale Fill Pattern</td>
<td>Specifies a fill pattern for a slab in coarse-scale view. Click in the value box to open the Fill Patterns dialog. See View Properties on page 873.</td>
</tr>
<tr>
<td>Coarse Scale Fill Color</td>
<td>Applies a color to the fill pattern for a slab in a coarse-scale view.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the slab keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The slab manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>A field for placing general comments about the slab type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page that may contain type specific information.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter or edit the description of the slab.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Describes the assembly based on the assembly code selection. This is a read-only parameter.</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>A Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value that designates the specific slab. This value must be unique for each element in a project. Revit Structure warns you when the number value is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>The pricing of the slab.</td>
</tr>
</tbody>
</table>

### Foundation Slab Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Level</td>
<td>Specifies the level that the slab is constrained to.</td>
</tr>
<tr>
<td>Height Offset From Level</td>
<td>Specifies the elevation of the top of the slab relative to the constrained level of the slab.</td>
</tr>
<tr>
<td>Related to Mass</td>
<td>This is a read-only value.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>Structural</td>
<td>If checked, Slab has an Analytical Model and is exported to analysis packages.</td>
</tr>
<tr>
<td>Rebar Cover - Top Face</td>
<td>The rebar cover distance from the foundation slab top face. See Rebar Cover on page 399.</td>
</tr>
<tr>
<td>Rebar Cover - Bottom Face</td>
<td>The rebar cover distance from the foundation slab bottom face. See Rebar Cover on page 399.</td>
</tr>
<tr>
<td>Rebar Cover - Other Faces</td>
<td>The rebar cover distance from the foundation slab to adjacent element faces. See Rebar Cover on page 399.</td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Specifies the estimated reinforcement volume of the selected element. This is a read-only parameter that only displays when rebar has been placed.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Slope</td>
<td>Specifies the slope of the slab from the horizontal plane.</td>
</tr>
<tr>
<td>Perimeter</td>
<td>Indicates the slab perimeter. This is a read-only parameter.</td>
</tr>
<tr>
<td>Area</td>
<td>Indicates the area of the slab. This is a read-only parameter.</td>
</tr>
<tr>
<td>Volume</td>
<td>Indicates the volume of the slab. This is a read-only parameter.</td>
</tr>
<tr>
<td>Width</td>
<td>Indicates the width of the slab, if rectangular. This is a read-only parameter.</td>
</tr>
<tr>
<td>Length</td>
<td>Indicates the length of the slab, if rectangular. This is a read-only parameter.</td>
</tr>
<tr>
<td>Elevation at Bottom</td>
<td>Indicates the elevation used for tagging the Bottom of Foundation. This parameter is affected by the family parameter Cap (see Family Category and Parameters on page 695). The following image shows the difference between the Cap parameter enabled (in red) and disabled (in green).</td>
</tr>
<tr>
<td></td>
<td>The Elevation at Bottom measurement is taken from this setting. This is a read-only parameter.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>A field for placing general comments about the slab.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label created for the slab. Possible use: shop mark. This value must be unique for each element in a project. Revit Structure warns you when the number value is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Indicates in which phase the slab component was created. See Project Phasing on page 877.</td>
</tr>
</tbody>
</table>
Shape Editing for Structural Floors, Roofs, and Floors

You can use shape editing tools to manipulate the surface of either an existing horizontal structural floor, roof, or floor, by defining high and low points for drainage. By specifying the elevation of these points, you split the surface into sub-regions that can slope independently.

Shape edit examples
Use shape editing tools to slope a constant thickness structural floor or the top surface of a structural floor with a variable thickness layer, to model the following:

- A constant thickness structural floor or roof supported by sloped non-planar framing.
- A variable thickness material used to slope the surface of a horizontal plane (for example, tapered insulation).

**NOTE** Structural floors and roofs that have been shape edited will not report a true thickness. The shape editing tools were designed to allow for moderate slopes and in such cases, variances in true thickness are trivial. However, more significant slopes will increase this variance. Revit Structure will issue a warning when a slope significantly deviates from the expected thickness.

**In order to enable shape editing tools, the following conditions must be met:**

- Structural floors must be flat and on a horizontal plane.
- A roof cannot attach to another roof, and the roof cannot be a curtain roof. If either of these conditions is not met, you cannot use the slab shape edit buttons.

**NOTE** If these conditions are violated later, by element editing, the slab shape edit will cause an error with a callback, allowing the user to reset the slab shape edit.

You can use the following shape edit tools on the Modify Floors tab ➤ Shape Editing panel

- Sub Elements
- Add Point
- Add Split Line
- Pick Supports
- Reset Shape

**NOTE** Editing the shape of a structural floor, roof, or floor with these tools does not affect the shape of its analytical model. A single analytical model face, based on the original top face, remains unchanged.

**Important Considerations**

**Automatic Split Lines.** In order to maintain the accuracy of the structural floor/roof geometry, split lines are sometimes created automatically. Automatically created split lines will be deleted when the condition that caused them to be created is no longer valid. For example, when 4 non-planar vertices become planar, or when you manually create a split line.

**Warped Structural Floor/Roofs.** A surface will warp when bounded by 4 non-planar boundary edges or user-created split lines. To avoid warping, add a split line between opposite vertices.

**Using the Modify Sub Elements Tool**

You can use the Modify Sub Elements tool to manipulate one or more of the points or edges on a selected structural floor, roof, or floor.

1. Select the structural floor, roof, or floor you want to modify.
2. Click Modify | Floors tab ➤ Shape Editing panel ➤ Modify Sub Elements.
NOTE When you select the Modify Sub Elements tool, the Options Bar will display an Elevation edit box in which you can enter a common elevation value for all the selected sub elements. This value is the vertical offset between the vertices and the original top face of the structural floor.

3 Drag a point or edge to modify the location or elevation.

NOTE If you place the cursor over the structural floor, you can press Tab to pick specific sub elements. Standard selection methods also apply. See Selecting Multiple Elements on page 1440.

- Dragging a blue arrow moves the point vertically.
- Dragging a red square (shape handle) moves the point horizontally.

4 Click the text control to enter a precise height value for the selected point or edge.
The value of the height represents the offset from the original top face of the structural floor.

NOTE For an edge this means that the center is moved to the specified height, but the relative heights of the 2 ends are maintained.

Using the Add Point Tool

You can use the Add Point tool to add singular points to the element geometry. The points are used by the shape modification tools to change the element geometry.

1 Select the structural floor, roof, or floor you want to modify.

2 Click Modify | Floors tab ➤ Shape Editing panel ➤ Add Point.

NOTE The Elevation edit box displays on the Options Bar with a Relative check box next to it. If you select Relative, new points will be added at the specified value, relative to the surface on which they are added. So, with the default value of 0 the points will lie in the surface that they were created on. If you clear the check box, the value in the edit box represents the project elevation, and points will be added at this elevation.

3 Click on the face or edges of the structural floor, roof, or floor to add points that define a slope.
Using the Add Split Line Tool

You can use the Add Split Line tool to add linear edges and to split the existing face of a structural floor into smaller sub-regions.

1. Select the structural floor you want to modify.

2. Click Modify | Floors tab ➤ Shape Editing panel ➤ Add Split Line.

3. Select a vertex, edge, face or point anywhere on the structural floor to start the split line.

**NOTE** Start points and endpoints can be added anywhere on the face of the structural floor. If your cursor is over a vertex or edge, the editor will snap to 3D vertices and edges and present standard snap controls with temporary dimensions along the edges. If no vertex or edge is snapped to, then on selection, the line end will be projected to the closest point on the surface. No temporary dimensions will be created on the face.
4 Select another vertex, edge, face or point anywhere on the structural floor to end the split line. A new edge will be added to the face of the structural floor.

Using the Pick Supports Tool

You can use the Pick Supports tool to pick beams to define split lines and create constant bearing lines for the structural floor.

1 Select the structural floor, roof, or floor you want to modify.
2 Click Modify | Floors tab ➤ Shape Editing panel ➤ Pick Supports.
3 Select an existing beam.

A new split edge is created using the endpoint elevations from the picked reference. The elevations are moved up from the bottom face to the top face of the structural floor or roof using the structural floor or roof thickness.

Using the Curved Edge Condition Tool

Structural floors drawn with arc segments can be altered using structural floor shape editing tools. The Curved Edge Condition tool is an additional tool specific to curved edges. It sets them to project a flat surface to the edge or a curved surface that conforms to the arc edge of the structural floor.

1 Right-click the shape edited curved edge structural floor you want to modify and select Properties.
2 On the Properties palette, click the Curved Edge Condition button located under Structural Floor Shape Edit. This opens the Curved Edge Condition Dialog.

![Curved Edge Condition dialog](image)

3 Select either Conform to curve for a scalloped surface, or Project to side for a flat surface.

4 Click OK to apply the condition.

5 Click Apply.

**Using the Reset Shape Tool**

To remove structural floor shape modifications and reset the element geometry to its original state, click **Click Modify | Floors tab ➤ Shape Editing panel ➤ Reset Shape.**

**Deleting Shape Modifiers**

To delete shape edit elements:

1 Select the modified structural floor.

2 Click Modify | Floors tab ➤ Shape Editing panel ➤ Modify Sub Elements.

3 Click on the shape edit element to select it.

4 Either press *Delete* or right-click the element and select Delete.
The shape edit element is removed and the structural floor adjusts its geometry accordingly.

**Variable Layer Thickness for Roofs and Structural Floors**

The variable layer thickness parameter of roofs and structural floors affects the shape editing tools in the following ways:

- When there is no variable thickness layer, the whole roof or structural floor slopes and maintains constant thickness between parallel top and bottom faces.

- When there is a variable thickness layer, the top face of the roof or structural floor slopes, and the bottom stays in a horizontal plane, creating a variable thickness structural floor.

**NOTE** There is a Thickness property for structural floors. If the structural floor has a structural floor shape edit, and if the structural floor type contains a variable layer, then this parameter can be used to set the structural floor to a uniform thickness by entering a desired value.

To modify the variable thickness layer of a structural floor or roof

1. Select the structural floor or roof.
2. On the Properties palette, click Edit Type.
3 In the value box of the Structure property, click Edit.

4 In the Edit Assembly dialog, specify the material for layers and the thickness of those layers. The variable thickness parameter column will contain empty check boxes next to layers where variable thickness can be enabled. For more information about the Edit Assembly dialog, see Compound Structure on page 573.

5 Next to the desired layer of the roof or structural floor in the assembly, select the variable check box

6 Click OK until all of the dialogs are closed.

7 Click Modify | Floors tab ➤ Shape Editing panel ➤ Modify Sub Elements and make the desired changes to your roof or structural floor. For more information, see Using the Modify Sub Elements Tool on page 387.

**Concrete Modeling Concepts**

This section covers Revit Structure concrete modeling concepts that do not pertain solely to specific elements or components.

See also Reinforcement on page 397.

**Concrete Geometry Joins**

Concrete elements will automatically join each other without your intervention. They are represented in the project as a single mass in all views as anticipated. While joined, you can edit and move the individual elements within their normal ranges and limits.

**NOTE** If the Unjoin Geometry tool is used (see Unjoining Geometry on page 1508), automatic joining is disabled for the elements. Use the Join Geometry tool (see Joining Geometry on page 1506) to re-enable automatic concrete geometry joins.

**Examples of joined concrete elements**

<table>
<thead>
<tr>
<th>3D View of 2 beams and a column join</th>
<th>Cross section of a column and beam join</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cross section of a structural floor and slab edge join</td>
<td></td>
</tr>
</tbody>
</table>
Concrete beams must have either of the following properties to participate in these joins, otherwise they exhibit legacy behaviors and must be manually joined.

- Rectangular sections with a cross sectional rotations of 0, 90, 180, and 270 degrees.
- Trapezoidal, t-shaped, and l-Shaped sections with cross sectional rotations of 0 degrees.

Other join related restrictions include the following.

- Shape handles are not available for new participating elements.
- Type parameter changes will not automatically update concrete join geometry.
- Concrete elements that are reinforced will also share their cover references in a join. See Rebar Cover on page 399.

Legacy Drawing Behaviors

In order to maintain the display of existing drawings when a project is upgraded, concrete elements from legacy (upgraded) projects (created in versions earlier than Revit Structure 2009) will behave differently than newly created objects.

- Valid concrete elements that are not joined will not automatically join with each other. You can join them with the Join Geometry tool, however. See Joining Geometry on page 1506.
- Newly created elements will automatically join with upgraded legacy elements.
- Newly created concrete elements will automatically join with one another as expected.

Valid Concrete Element Join Combinations

Concrete element combinations that may automatically join with one another include:

- beam to beam
- beam to column
- isolated foundation to isolated foundation
- isolated foundation to wall foundation
- structural floor to beam
Dominant Elements in a Concrete Join

One element retains its geometry while the geometry of the elements sharing the join is cut to create the single mass. Structural floors and walls possess dominant geometry characteristics and always maintain their geometry when sharing a join with other elements. Because of this, they will not automatically join with one another. Other concrete elements take precedence as follows.

<table>
<thead>
<tr>
<th>Element</th>
<th>Element</th>
<th>Dominant Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beam</td>
<td>Beam</td>
<td>In order of creation</td>
</tr>
<tr>
<td>Beam</td>
<td>Column</td>
<td>Column</td>
</tr>
<tr>
<td>Isolated Foundation</td>
<td>Isolated Foundation</td>
<td>In order of creation</td>
</tr>
<tr>
<td>Isolated Foundation</td>
<td>Wall Foundation</td>
<td>Isolated Foundation</td>
</tr>
</tbody>
</table>

These joining rules cannot be changed and it is not possible to disable the automatic joining of geometry. However, the joins can be manually un-joined.

**NOTE** Joined geometry may impact performance.

Display of Hidden Lines of Structural Concrete Components

Revit Structure controls the appearance of structural concrete components that are in a hidden state in a view. The appearance of invisible lines of walls, floors, framing, columns, and foundation elements are controlled by the following view parameters:

- **Discipline** must be set to Structural to represent invisible lines as hidden.
- **Visual style** must be set to either Hidden or to Shaded with Edges to represent invisible lines as hidden.

**NOTE** To set the desired hidden line pattern, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Patterns. See Line Patterns on page 1604.
Structural floor and beams framed into concrete walls

Note that the on-screen display of hidden lines may not precisely match vector output. Some edges of wall ends will not show as hidden and all edges of a slab edge will show as hidden in a plan view if obstructed by the slab.
Reinforcement

Revit Structure provides tools for modeling reinforcement in concrete columns, beams, walls, foundations, and structural floors.

Reinforcing tools are available on the Reinforcement panel on either the Home tab or the appropriate Modify tab when a concrete host is selected. See Reinforcement Tools on page 397.

Reinforcement Tools

Reinforcement tools are available on the active Modify tab when you select an appropriate host, such as a concrete beam, column, structural floor, or foundation. Place reinforcement into concrete host elements using the following tools.

Place Rebar Parallel to Work Plane

To place rebar parallel to the current work plane, select Reinforcement panel ➤ Rebar drop-down ➤ Place Rebar Parallel to Work Plane. The placed element is a rebar instance with the properties of the rebar type and rebar shape that you select. To place, use the Rebar Shape Browser (see Rebar Shapes on page 402) or sketching tools (see Sketch Placement of Rebar on page 417).
Place Rebar Perpendicular to Work Plane

To place rebar perpendicular to the current work plane, select Reinforcement panel ➤ Rebar drop-down ➤ Place Rebar Perpendicular to Work Plane. The placed element is a rebar instance with the properties of the rebar type and rebar shape that you select. To place, use the Rebar Shape Browser (see Rebar Shapes on page 402) or sketching tools (see Sketch Placement of Rebar on page 417).

Cover

Click Reinforcement panel ➤ Cover to edit the rebar cover settings of an entire rebar host or an individual face. The cover settings define the offset distance for bars from the faces of the rebar host.

- Click Pick Elements on the Options Bar to configure rebar cover settings for an entire element.
- Click Pick Faces on the Options Bar to configure rebar cover settings for specific faces of an element.
- Define a cover setting type from the Cover Setting drop-down on the Options Bar.

Area

Click Reinforcement panel ➤ Area to sketch lines indicating the boundary of an area to which you want to add rebar. The finished sketch is an area reinforcement instance. For more information, see Area Reinforcement on page 433.

Path

Click Reinforcement panel ➤ Path to sketch lines to indicate the path of the evenly placed reinforcing bars that are created perpendicular to the sketch. The finished sketch is a path reinforcement instance. For more information, see Path Reinforcement on page 439.

Valid Rebar Hosts

A valid rebar host consists of any beam, brace, column, or isolated foundation whose family Structural Material Type parameter is either Concrete or Precast Concrete. Walls, structural floors, and slab edges can also be valid hosts as long as they contain a concrete layer and have their Structural Usage instance property set to something other than non-structural. See also Modifying Type Properties on page 38 and Changing Material Physical Data on page 1596.

Valid hosts include the following families:

- Structural Framing
- Structural Columns
- Structural Foundations
- Walls
- Structural Floors
- Foundation Slabs
- Wall Foundations
- Slab Edges
Rebar Cover

In Revit Structure, rebar cover is defined by a series of instance parameters that control the internal offset of the rebar from the faces of the rebar host. When a rebar shape is placed within a host, it will expand to the cover references. Rebar touching the cover reference is attached to that cover reference. The rebar cover parameters only affect the rebar that touches its reference. Changing the cover settings will not offset other rebar that you have placed within the host.

Rebar Cover References

Rebar Cover References act as a boundary for reinforcement within its host. You can define the amount of offset in the Rebar Cover settings. Rebar elements automatically find and attach to the references. Reinforcement snaps to these references during placement.

To change the appearance of host cover

1. Click View tab ➤ Graphics panel ➤ Visibility/Graphics.
2. Click Object Styles.
3. Click the Annotation Objects tab.
4. Modify the Concrete Cover References category.

<table>
<thead>
<tr>
<th>Default host cover style</th>
<th>Example modified host cover style</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Default host cover style" /></td>
<td><img src="image" alt="Example modified host cover style" /></td>
</tr>
</tbody>
</table>

Editing Rebar Cover

While working with rebar and its host, you can edit the rebar cover of either the entire element or a particular face. While using the rebar cover tools, determine the existing rebar cover settings by hovering your mouse over either an individual face or the entire element.
Set rebar cover for an entire element

1. Click Home tab ➤ Reinforcement panel ➤ Cover.
2. On the Options Bar, click Pick Elements.
3. Select the element you want to modify.
4. On the Options Bar, select a cover setting from the Cover Setting drop-down.

The new cover setting applies over the entire selected element.

Set rebar cover by face

1. Click Home tab ➤ Reinforcement panel ➤ Cover.
2. On the Options Bar, click Pick Faces.
3. Select a face on the concrete element you want to modify.
4. On the Options Bar, choose a cover setting from the Cover Setting drop-down menu.

The new cover setting applied itself over the selected element face.

NOTE If none of the cover settings in the drop-down list apply to your particular situation, click to add new cover settings. See Modifying Rebar Cover Settings on page 400.

Modifying Rebar Cover Settings

In the Rebar Cover Settings dialog, you add, remove, or modify rebar cover settings. You may also create and save multiple settings for future application.

To access the dialog box select Home tab ➤ Reinforcement panel drop-down ➤ Rebar Cover Settings or click on the Options Bar.

Modify rebar cover settings

1. Select the cover type in the dialog.
2. Adjust the description of the cover type.
3. In the Setting column, adjust the offset distance for the cover type.
Add rebar cover settings

1. Click Add or select an existing setting and click Duplicate.
2. In the Description column, enter the description of the cover type.
3. In the Setting column, enter the desired offset distance for the new cover type.
4. Click OK to finish adding cover settings, or click Duplicate to continue adding settings.

Delete rebar cover settings

1. Select a Cover Type to delete.
2. Click Delete.
3. Click OK in the warning dialog to proceed, or click Cancel to stop the delete operation.

Rebar Cover Element Properties

The following table describes cover related parameters in the Structural section of concrete element Properties palettes.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rebar Cover - Top Face</td>
<td>The cover settings for the highest face of an element instance. See the Modifying Rebar Cover Settings on page 400 for the definitions of the cover settings in this menu.</td>
</tr>
<tr>
<td>Rebar Cover - Bottom Face</td>
<td>The cover settings for the lowest face of an element instance. See the Modifying Rebar Cover Settings on page 400 for the definitions of the cover settings in this menu.</td>
</tr>
<tr>
<td>Rebar Cover - Interior Face</td>
<td>Walls only parameter. The cover settings for the interior face of a concrete wall. See the Modifying Rebar Cover Settings on page 400 for the definitions of the cover settings in this menu.</td>
</tr>
<tr>
<td>Rebar Cover - Exterior Face</td>
<td>Walls only parameter. The cover settings for the exterior face of a concrete wall. See the Modifying Rebar Cover Settings on page 400 for the definitions of the cover settings in this menu.</td>
</tr>
<tr>
<td>Rebar Cover - Other Faces</td>
<td>The default cover settings for element instances that do not qualify as highest, lowest, interior, or exterior. This cover setting applies to elements created with openings. See the Modifying Rebar Cover Settings on page 400 for the definitions of the cover settings in this menu.</td>
</tr>
<tr>
<td>Area Reinforcement Only</td>
<td></td>
</tr>
<tr>
<td>Additional Top/Exterior Offset</td>
<td>Specifies an additional offset from the top/interior rebar cover. This allows placing multiple rebar elements together in different area reinforcement layers.</td>
</tr>
<tr>
<td>Additional Bottom/Interior Offset</td>
<td>Specifies an additional offset from the bottom/interior rebar cover. This allows placing multiple rebar elements together in different area reinforcement layers.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>Path Reinforcement Only</td>
<td>Specifies an additional offset from the rebar cover. This allows placing multiple rebar elements together in different path reinforcement layers.</td>
</tr>
</tbody>
</table>

**Rebar Shapes**

In Revit Structure, rebar shapes are 2D families that define the layout of the rebar type instance in the project. When using a rebar tool the Rebar Shape Browser is active and displays the available shapes in the library. Use the Rebar Shape Editor to modify existing shapes and create custom rebar instances.

You select Rebar Shapes from the Rebar Shape browser or the Rebar Shape type drop-down on the Options Bar.

**NOTE** If you are working with a projects created in a version earlier than Revit Structure 2009, you will need to load rebar shape families prior to applying reinforcement.
Select the host in an elevation or cross section view.

Placing Rebar Shapes in a Host

The following steps provide the general workflow for adding rebar shapes to a concrete element.

1. In an elevation or cross section view, select the host to receive reinforcement.
2. Click Modify <Element> tab ➤ Reinforcement panel ➤ Rebar drop-down ➤ Place Rebar Perpendicular to Work Plane or Place Rebar Parallel to Work Plane.
3. In the Type Selector on page 35 at the top of the Properties palette, select the desired rebar type.
4. In either the Type Rebar Shape type drop-down on the Options Bar or the Rebar Shape Browser, select the desired rebar shape.
5. Place the rebar in the host.

Add Rebar to a Column

Place rebar perpendicular to the work plane

1. Select the column in a section view.
2. Click Modify Structural Columns tab ➤ Reinforcement panel ➤ Rebar drop-down ➤ Place Rebar Perpendicular to Work Plane.
3. In the Type Selector on page 35 at the top of the Properties palette, select the desired rebar type.
4. In either the Type Rebar Shape type drop-down on the Options Bar or the Rebar Shape Browser, select the desired rebar shape.
5. Hover over the rebar host and notice that as you move the cursor, the representation of the rebar moves with it.
   The rebar shape moves and changes orientation to accurately add rebar to the host. Stirrup shapes freely rotate and move within the cover reference. Standard shapes flip their orientation.
6. Click the host to add the rebar shape in its current orientation.
Rebar lengths default to the length of the column or to other host elements within the constraints of the cover reference. To edit lengths, change to either a plan or an elevation view, select the rebar instance and revise the endpoints as needed. See Rebar Cover on page 399.

NOTE You can apply various predefined hooks to the ends of your rebar shape. For information on how to change rebar hook types, see Rebar Hooks on page 426.

Place rebar parallel to the work plane

1 Select the column in a section view.

2 Click Modify Structural Columns tab ➤ Reinforcement panel ➤ Rebar ➤ Place Rebar Parallel to Work Plane.

3 In the Type Selector on page 35 at the top of the Properties palette, select the desired rebar type.

4 In either the Type Rebar Shape type drop-down on the Options Bar or the Rebar Shape Browser, select the desired rebar shape.

5 Hover over the rebar host and notice that as you move the cursor, the representation of the rebar moves with it.

The rebar shape moves and changes orientation to accurately add rebar to the host. Stirrup shapes freely rotate and move within the cover reference. Standard shapes flip their orientation.

6 Click the host to add the rebar shape in its current orientation.
NOTE You can apply various predefined hooks to the ends of your rebar shape. See Rebar Hooks on page 426.

Adding Rebar to a Beam

Place rebar perpendicular to the work plane

1 Select the beam in a section view.

2 Click Modify Structural Framing tab ➤ Reinforcement panel ➤ \U00002714 Place Rebar Perpendicular to Work Plane.

3 In the Type Selector on page 35 at the top of the Properties palette, select the desired rebar type.

4 In either the Type Rebar Shape type drop-down on the Options Bar or the Rebar Shape Browser, select the desired rebar shape.

5 Hover over the rebar host and notice that as you move the cursor, the representation of the rebar moves with it.

The rebar shape moves and changes orientation to accurately add rebar to the host. Stirrup shapes freely rotate and move within the cover reference. Standard shapes flip their orientation.

6 Click the host to add the rebar shape in its current orientation.

Rebar lengths default to the length of the beam or to other host elements within the constraints of the cover reference. To edit lengths, change to either a plan or an elevation view, select the rebar instance and revise the endpoints as needed. See Rebar Cover on page 399.
Rebar placed perpendicular in a beam section view

Place rebar parallel to the work plane

1 Select the beam in a section view.

2 Click Modify Structural Framing tab ➤ Reinforcement panel ➤ Place Rebar Parallel to Work Plane.

3 In the Type Selector on page 35 at the top of the Properties palette, select the desired rebar type.

4 In either the Type Rebar Shape type drop-down on the Options Bar or the Rebar Shape Browser, select the desired rebar shape.

5 Hover over the rebar host and notice that as you move the cursor, the representation of the rebar moves with it. The rebar shape moves and changes orientation to accurately add rebar to the host. Stirrup shapes freely rotate and move within the cover reference. Standard shapes flip their orientation.

6 Click the host to add the rebar shape in its current orientation.
Plane Placement of Rebar in Walls and Structural Floors

Concrete walls and structural floors do not require section views to reinforce in Revit Structure. You can place rebar in these elements using the Placement Plane drop-down on the Options Bar and an appropriate elevation or structural plan view.

Place rebar in a wall using an elevation view

1 Open an appropriate elevation view that is parallel to the wall.
2 Click Home tab ➤ Reinforcement panel ➤ Rebar drop-down ➤ 🔄 Place Rebar Parallel to Work Plane.
3 From the Placement Plane drop-down on the Options Bar, select either of the following:
   - Far Cover Reference for the wall face furthest from your view.
   - Near Cover Reference for the wall face nearest to your view.
4 Click along the wall face to place the rebar.

Place rebar in a structural floor using a structural plan view

1 Open an appropriate structural plan view that is parallel to the structural floor.
2 Click Home tab ➤ Reinforcement panel ➤ Rebar drop-down ➤ 🔄 Place Rebar Parallel to Work Plane.
3 From the Placement Plane drop-down on the Options Bar, select either of the following:
   - Far Cover Reference for the structural floor face furthest from your view.
   - Near Cover Reference for the structural floor face nearest to your view.
4 Click along the structural floor face to place the rebar.

In the following image, three rebar instances are placed. They were placed (from top to bottom) in a Near/Far/Near plane placement pattern.

South Elevation View

West Elevation View

In the following image, three rebar instances are placed. They were placed (from top to bottom) in a Far/Near/Far plane placement pattern.

Structural Plan View
Rehosting Rebar Shapes

1. Select the rebar to be rehosted.
2. Click Modify Structural Rebar tab ➤ Rebar panel ➤ [button] Pick New Host.
3. Select a new host to relocate the rebar.

See Valid Rebar Hosts on page 398.
Changing the Orientation of Rebar Shapes

Press the SPACEBAR during placement to proceed through the orientation of the rebar shape within the bounding box. Orientation can be shifted after placement by selecting the rebar and using the SPACEBAR similarly.

**Full Symmetry**

**Vertical or Horizontal Symmetry**

**Diagonal Symmetry**
Auto-Expand Behavior of Rebar Shapes

The auto-expand behavior of rebar shapes causes the rebar to fill the space provided within a concrete element. For example, a linear shape, such as a single segment bar with or without hooks, expands in both directions until it finds the cover references. Also, a multi-segment shape expands in each cardinal direction until it finds references.

See Rebar Cover References on page 399.

The following chart shows how the auto-expansion works with different rebar shapes and mouse positions. The green dashed line represents the rebar cover and general shape of the host. The black arrows depict the range of movement of the mouse. The black framed rectangles with gray arrows represent the expanding bounding box into which the rebar shape adjusts and resizes.

<table>
<thead>
<tr>
<th>Cross section shape of host</th>
<th>Mouse cursor position</th>
<th>Expanding bounding box</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Cross section shape of host" /></td>
<td><img src="image2" alt="Mouse cursor position" /></td>
<td><img src="image3" alt="Expanding bounding box" /></td>
</tr>
<tr>
<td>Cross section shape of host</td>
<td>Mouse cursor position</td>
<td>Expanding bounding box</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td><img src="image1" alt="Cross section shape" /></td>
<td><img src="image2" alt="Mouse cursor position" /></td>
<td><img src="image3" alt="Expanding bounding box" /></td>
</tr>
<tr>
<td><img src="image4" alt="Cross section shape" /></td>
<td><img src="image5" alt="Mouse cursor position" /></td>
<td><img src="image6" alt="Expanding bounding box" /></td>
</tr>
<tr>
<td><img src="image7" alt="Cross section shape" /></td>
<td><img src="image8" alt="Mouse cursor position" /></td>
<td><img src="image9" alt="Expanding bounding box" /></td>
</tr>
<tr>
<td><img src="image10" alt="Cross section shape" /></td>
<td><img src="image11" alt="Mouse cursor position" /></td>
<td><img src="image12" alt="Expanding bounding box" /></td>
</tr>
<tr>
<td><img src="image13" alt="Cross section shape" /></td>
<td><img src="image14" alt="Mouse cursor position" /></td>
<td><img src="image15" alt="Expanding bounding box" /></td>
</tr>
<tr>
<td><img src="image16" alt="Cross section shape" /></td>
<td><img src="image17" alt="Mouse cursor position" /></td>
<td><img src="image18" alt="Expanding bounding box" /></td>
</tr>
</tbody>
</table>
### Modifying Rebar Shape

You adjust rebar shapes with rebar shape controls. To use these controls, select the rebar instance.

<table>
<thead>
<tr>
<th>Cross section shape of host</th>
<th>Mouse cursor position</th>
<th>Expanding bounding box</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Cross section shape of host" /></td>
<td><img src="image2" alt="Mouse cursor position" /></td>
<td><img src="image3" alt="Expanding bounding box" /></td>
</tr>
<tr>
<td><img src="image4" alt="Cross section shape of host" /></td>
<td><img src="image5" alt="Mouse cursor position" /></td>
<td><img src="image6" alt="Expanding bounding box" /></td>
</tr>
<tr>
<td><img src="image7" alt="Cross section shape of host" /></td>
<td><img src="image8" alt="Mouse cursor position" /></td>
<td><img src="image9" alt="Expanding bounding box" /></td>
</tr>
<tr>
<td><img src="image10" alt="Cross section shape of host" /></td>
<td><img src="image11" alt="Mouse cursor position" /></td>
<td><img src="image12" alt="Expanding bounding box" /></td>
</tr>
</tbody>
</table>

The triangle controls adjust the segment of the shape only in the direction they are pointing. The dot controls are multi-directional and adjust the end or intersection location of the adjacent segments.

Segments snap and attach to the host cover when moved.

**Rebar Shape Snapping Behaviors**

Due to the nature of cover references and how rebar is placed, rebar does not snap to its relative Revit Structure environment, such as snap points and snap lines. Resizing and other modifications to rebar will react only to the cover reference of the host in which it is placed.

<table>
<thead>
<tr>
<th>Cross section of concrete host showing cover reference</th>
<th>Default placement of rebar in the cover reference</th>
<th>Snap position to cover reference using Rebar Shape Controls</th>
</tr>
</thead>
</table>

To edit rebar in relation to its Revit Structure environment, overriding the cover reference snapping behaviors, you can select individual elements of the rebar for adjustment.

Hover over the element of the rebar and press TAB. You can now edit the element with typical snapping behavior.

**Snap position to joined element edge using rebar line segment selection**
Select a New Rebar Shape

1 Select the rebar to be modified.
2 Select a new shape from the Rebar Shape Type drop-down on the Options Bar.
3 Optional. To select from the Rebar Shape browser, click … on the Options Bar.

Rebar will retain its constraints to its host. However, significant shape changes can extend rebar beyond the cover reference of the host.

Spiral Rebar

Spiral rebar is a unique rebar shape family in that it is non-planar and cannot be edited. However, because it is fully dimensional, spiral rebar can be scaled, rotated, and resized with its own shape handles and controls within a project.

Adjusting the Height of Spiral Rebar

To change the length of the spiral, use the triangle shape controls at the top and base of the rebar spiral. Drag the arrows accordingly to lengthen or shorten the spiral.

These controls do not stretch the spiral. They add the proportionate number of coils required to maintain the specified height of the spiral rebar.

Scaling the Diameter of Spiral Rebar

To scale the width of the spiral rebar coils, locate the scaling control opposite the rotation control which is at the end of the actual rebar coil. Drag the control to adjust the diameter of the spiral.
Rotating Spiral Rebar

The positioning of the spiral rebar can be rotated to align the end of the rebar as needed. Drag the rotation control at the end of the top rebar coil to rotate the position of the end of the rebar.

Spiral Rebar Instance Properties

The following instance properties are unique to spiral rebar in the Instance Properties palette

**Base Finishing Turns.** Specifies a number of complete coils to close the spiral base.

**Top Finishing Turns.** Specifies a number of complete coils to close the spiral top.

**Height.** Specifies the total height of the spiral rebar.

**Pitch.** Specifies the distance between rebar coils in the spiral.
Select a New Rebar Bar Type

1 Select the rebar to be modified.
2 In the Type Selector on page 35 at the top of the Properties palette, select the desired rebar type.

Rebar size can alter the rebar shape, possibly causing it to fail if the bend (fillet) radius of the bar is too big for the current configuration.

Modify a Rebar Sketch

1 Select the rebar to be modified.
2 Click Modify | Structural Rebar tab ➤ Mode panel ➤ Edit Sketch.
The selected rebar is in sketch mode.
3 Using the tools on the Modify | Structural Rebar > Edit Rebar Sketch tab, adjust the rebar sketch.
4 Click Modify Structural Rebar > Edit Rebar Sketch tab ➤ Mode panel ➤ Finish Edit Mode.

Sketch Placement of Rebar

Sketch tools are available for manual placement of a rebar shape within a valid host. Rebar sketches will map to an existing shape when they share the following attributes:

- Number of line segments
- The shape of the joined line segments
- The number of hooks
- The direction of the hooks
- The bend dimensions of the hooks
- Shape type: either standard or stirrup

If the sketch does not match an existing shape, a new shape will be created in the Rebar Shape browser and Rebar Shape type drop-down in the Options Bar.

Place rebar with sketching tools

1 View a valid concrete host in a section view.
2 Click Home tab ➤ Reinforcement panel ➤ Rebar drop-down ➤ Place Rebar Parallel to Work Plane.
3 Click Modify | Place Rebar tab ➤ Sketch panel ➤ Sketch Rebar.
4 When prompted, select the element that will host the rebar.
5 Use the sketching tools to sketch the rebar shape.
6 Add hooks to the ends of your rebar shape.

7 Position and orient the rebar hooks with the Rebar Hook Graphical Controls on page 429.

8 Click Modify | Create Rebar Sketch tab ➤ Mode panel ➤ ✔ Finish Edit Mode to accept the sketch and place the new shape. The new rebar shape adjusts its shape by snapping to the cover reference.

Rebar Shape Family Editing Tools

Rebar Shape families possess additional tools for editing which have several requirements and limitations. These include the following:

- Rebar does not flex when its parameter values are adjusted.
- Rebar does not move in the family environment as it does in the project environment.
- Rebar has a single level of detail. Changing between Coarse, Medium, or Fine levels of detail have no effect on its appearance.
Reference planes and dimensions that are not used to define the rebar shape will be silently removed from the family.

The tools described in this section are available when a shape family is opened for editing.

**Rebar Line**

In the Family Editor, click Home tab ➤ Draw panel ➤ Rebar Line and select a line tool from the gallery.

Use the Rebar Line tool to sketch lines and define the geometry of the family. This tool is similar to the Model Lines command in the Family Editor on page 678. See The Families Guide on page 680.

**Major Segment**

In the Family Editor, click Home tab ➤ Draw panel ➤ Major Segment.

Use the Major Segment tool to select one segment of the rebar shape that will maintain its general position in rotation and auto-expansion behaviors. A major segment adjusts its length to compensate the host, but its orientation within the shape remains unchanged.

**TIP** All similar shapes should have the same Major Segment. This ensures they remain in the same position during a shape change.

When selected, the major segment appears tagged with two parallel lines when viewed in the Rebar Shape editor.

**TIP** Create symmetrical shapes about the center reference lines in a sketch.

**Shape Status**

In the Family Editor, click Home tab ➤ Family Editor panel ➤ Shape Status.

The Shape Status tool supplies two means of validating a rebar shape. First, it indicates whether the current state of the shape is a valid rebar shape. If the control is disabled, the shape is valid and you can load it into projects. If the Shape Status control is active, something is wrong with the current shape. See Warnings for Selected Elements on page 1680.

Second, when active (indicating an error), click it to launch an error dialog. This dialog is similar to the Review Warnings command, displaying all current errors within the shape.
Rebar Shape Parameters

In the Family Editor, click Home tab ➤ Properties panel ➤ Family Types.

Use the Rebar Shape Parameters dialog to define the base attributes (parameters) of the rebar shape. The parameters become the default settings in the rebar shape types when placed in a project.

The following table describes the editable properties of the Rebar Shape Parameters dialog:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Style</td>
<td>Select: &lt;Standard&gt; to use Bend Diameter or Stirrup/Tie to use the Stirrup/Tie Bend Diameter.</td>
</tr>
<tr>
<td>Start Hook Offset</td>
<td>Specifies the length of the Start Hook offset.</td>
</tr>
<tr>
<td>Start Hook Length</td>
<td>Specifies the length of the Start Hook.</td>
</tr>
<tr>
<td>Hook at Start</td>
<td>Lists appropriate hook angles defined by the Style selection.</td>
</tr>
<tr>
<td>Hook at End</td>
<td>Lists of appropriate hook angles defined by the Style selection.</td>
</tr>
<tr>
<td>End Hook Offset</td>
<td>Specifies the length of End Hook offset.</td>
</tr>
<tr>
<td>End Hook Length</td>
<td>Specifies the length of End Hook.</td>
</tr>
<tr>
<td>Bend Diameter (default)</td>
<td>Specifies the diameter of the bend of the bar type.</td>
</tr>
<tr>
<td>Bar Diameter (default)</td>
<td>Specifies the diameter of the bar.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>A, B, C,... (default)</td>
<td>Specifies variable lengths whose quantities, parameters, and formula names are defined by the content of the shape.</td>
</tr>
</tbody>
</table>

Allowable Bar Types

In the Family Editor, click Home tab ➤ Rebar Types panel ➤ Allowable Bar Types.

Use the Allowable Rebar Bar Types dialog to define the allowable rebar sizes of the shape. These settings filter the displayed size options of the shape throughout the Revit Structure user interface.

In the dialog select the valid bar types in the Allowed column.

**NOTE** Shapes previously placed in a project do not update automatically. Verify all pre-existing instances after adjusting Allowable Bar Types.

Rebar Schedule Mark

You flag rebar instances with a rebar schedule mark for both the scheduling and organization of logically grouped reinforcement.
Enter or add a schedule mark to rebar shapes

1 Select all rebar instances and rebar sets to be marked. To select multiple instances, hold down the CTRL key while selecting.

2 On the Properties palette, find the Schedule Mark parameter in the Construction section. Enter a new schedule mark or select a mark from the drop-down.

NOTE New schedule marks are available for all rebar instances in the project.

Selecting all rebar with similar schedule marks

1 Right click a rebar instance.

2 Click Select Rebar by Schedule Mark from the drop-down list. Group the selection or mass edit using the Properties palette.

NOTE By default, the lowest numerical schedule mark available is assigned to the rebar. Typically, this mark is 1, though modified projects can be different. Rebar in projects created in versions of Revit Structure earlier than 2009 do not update with the lowest schedule mark. Therefore, rebar in these legacy projects have an empty field in their schedule mark parameter.

Rebar View Visibility States

By default, rebar elements in a 3D solid model are contained within host elements, and in hidden line view they are obscured by the host. You can set overrides for each view in a project, so the rebar design can be documented. Each rebar element has a view visibility setting, which is an instance property.

View Visibility settings for new rebar defaults are as follows:

■ On in the current view.
■ On in all section views in the project.
■ Off in all other views in the project.

In all cases, rebar must be located between the top view range and the view depth in order for it to be visible. Portions of the bar that are outside of the view range are not visible.

To access the Rebar Element View Visibility States dialog, select a rebar instance, and on the Properties palette, click the View Visibility States Edit button. Select one or both of the visibility states for each view in the project.

View Unobscured

This view parameter displays the selected rebar, regardless of its visual style. The rebar cannot be obscured by other elements and is visible in front of all obscuring elements. Rebar elements that are cut by the cut plane are always visible. This setting has no effect on the visibility of these rebar instances.
Disable this parameter to hide the rebar in all Visual style views other than Wireframe.

<table>
<thead>
<tr>
<th>Obscured (default setting)</th>
<th>Unobscured</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Obscured Image]</td>
<td>![Unobscured Image]</td>
</tr>
</tbody>
</table>

**View Solid**

This parameter displays rebar in its true volumetric representation when the view level of detail is set to fine. This view parameter is for 3D views only.

<table>
<thead>
<tr>
<th>Default 3D view of rebar</th>
<th>Rebar as a solid</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Default 3D View]</td>
<td>![Rebar as a solid]</td>
</tr>
</tbody>
</table>

**Changing Rebar View Visibility**

1. Select all rebar instances and rebar sets to be made visible. To select multiple instances, hold down the CTRL key while selecting.
2. On the Properties palette, click the View Visibility States Edit button.
3. In the Rebar Element View Visibility States dialog, select the views in which you want the rebar to be viewed unobscured.
4. Optionally, select the 3D views in which you want the rebar to be viewed as solid.
## Rebar Type Properties

The following table describes each parameter contained in the Rebar Type Properties dialog. To access this table, select a rebar instance and then select Modify | Structural Rebar tab ➤ Properties panel ➤ Type Properties.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Subcategory</td>
<td>Used to provide graphic overrides of rebar by subcategory. To create a new subcategory, click Manage tab ➤ Settings panel ➤ Object Styles. In the Structural Rebar category add new subcategories beneath the main category.</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Bar Diameter</td>
<td>Specifies the diameter of the selected bar type. Refer to the images in Rebar Hook Length Parameters on page 427.</td>
</tr>
<tr>
<td>Standard Bend Diameter</td>
<td>Specifies the diameter of non-hook bends for the selected bar type. Refer to the images in Rebar Hook Length Parameters on page 427. This parameter does not affect rebar shape.</td>
</tr>
<tr>
<td>Standard Hook Bend Diameter</td>
<td>Specifies the diameter of hook bends for the selected bar type. Refer to the images in Rebar Hook Length Parameters on page 427. This parameter does not affect rebar shape.</td>
</tr>
<tr>
<td>Stirrup/Tie Bend Diameter</td>
<td>Specifies a rebar bend diameter that can be either a standard bend or stirrup/tie bend. This parameter defines the radii for the selected bend type. Refer to the images in Rebar Hook Length Parameters on page 427.</td>
</tr>
<tr>
<td>Hook Lengths</td>
<td>Specifies hooks based on a specific bar type. Click Edit to open the Rebar Hook Length dialog. Refer to the images in Rebar Hook Length Parameters on page 427.</td>
</tr>
<tr>
<td>Maximum Bend Radius</td>
<td>Specifies the Maximum Bend Radius for rebar schedules. Its purpose is to compensate for rebar that is bent in the field due to larger bend diameters.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>The keynote text.</td>
</tr>
<tr>
<td>Model</td>
<td>The manufacturer internal number.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The rebar manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>General comments about the rebar type. You can include this information in a schedule.</td>
</tr>
</tbody>
</table>
Rebar Instance Properties

The following table describes each parameter contained on the Properties palette. They consist of the combined parameters of bar type, shape type, and hook type.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td><strong>URL</strong></td>
<td>Specifies a link to a web page that contains type-specific information. Click the icon to establish a link.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>An optional description of the rebar type.</td>
</tr>
<tr>
<td><strong>Assembly Description</strong></td>
<td>The uniformat classification for the currently selected assembly code.</td>
</tr>
<tr>
<td><strong>Assembly Code</strong></td>
<td>Specifies the uniformat assembly code.</td>
</tr>
<tr>
<td><strong>Type Mark</strong></td>
<td>A type-specific label used, for example, as a shop mark. This value must be unique for each element in a project. Revit Structure warns you if the value is in use, but allows you to continue using it. You can see the warning using the Review Warnings command. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td><strong>Cost</strong></td>
<td>The user-defined cost of the rebar.</td>
</tr>
</tbody>
</table>

**Rebar Instance Properties**

The following table describes each parameter contained on the Properties palette. They consist of the combined parameters of bar type, shape type, and hook type.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Schedule Mark</td>
<td>Specifies rebar instances with a rebar schedule mark. The mark improves scheduling and organization.</td>
</tr>
<tr>
<td><strong>Style</strong></td>
<td>Specifies the bend radii control, either Standard or Stirrup/Tie. See Rebar Type Properties on page 423.</td>
</tr>
<tr>
<td><strong>Shape</strong></td>
<td>Specifies the identification number of the rebar shape.</td>
</tr>
<tr>
<td><strong>Hook at Start</strong></td>
<td>Lists appropriate rebar hook types for the selected style.</td>
</tr>
<tr>
<td><strong>Hook at End</strong></td>
<td>Lists appropriate rebar hook types for the selected style.</td>
</tr>
<tr>
<td><strong>Base Finishing Turn</strong></td>
<td>Spiral rebar only. Specifies the number of complete coils to close the spiral base.</td>
</tr>
<tr>
<td><strong>Top Finishing Turn</strong></td>
<td>Spiral rebar only. Specifies the number of complete coils to close the spiral top.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Height</td>
<td>Spiral rebar only. Specifies the total height of the spiral rebar.</td>
</tr>
<tr>
<td>Pitch</td>
<td>Spiral rebar only. Specifies the distance between rebar coils in the spiral.</td>
</tr>
<tr>
<td>Rebar Set</td>
<td></td>
</tr>
<tr>
<td>Spacing</td>
<td>Specifies the spacing for the rebar placed in the major direction. This parameter is only accessible</td>
</tr>
<tr>
<td></td>
<td>with the Maximum Spacing Layout Rule.</td>
</tr>
<tr>
<td>Quantity</td>
<td>Specifies the number of rebar instances within the reinforcement. This parameter is only accessible</td>
</tr>
<tr>
<td></td>
<td>with the Fixed Number Layout Rule.</td>
</tr>
<tr>
<td>Layout Rule</td>
<td>Specifies the type of rebar layout. Select either Maximum Spacing or Fixed Number. See Rebar Sets on</td>
</tr>
<tr>
<td></td>
<td>page 432.</td>
</tr>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>View Visibility States</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Accesses rebar view visibility states. Click Edit to either view or edit the state. See Rebar View</td>
</tr>
<tr>
<td></td>
<td>Visibility States on page 421.</td>
</tr>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Estimated Reinforce-</td>
<td></td>
</tr>
<tr>
<td>ment Volume</td>
<td>Displays the calculated estimate for reinforcement volume (read-only).</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Bar Length</td>
<td>Displays the length of individual rebar (read-only).</td>
</tr>
<tr>
<td>Total Bar Length</td>
<td>Displays the total length of all individual rebar in a set (read-only).</td>
</tr>
<tr>
<td>A, B, C,...</td>
<td>Specifies the variable lengths whose quantities, parameters, and formula names are defined by the</td>
</tr>
<tr>
<td></td>
<td>content of the shape.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>General comments about the rebar instance. You can include this information in a schedule.</td>
</tr>
<tr>
<td>Mark</td>
<td>An instance-specific label used, for example, as a shop mark. This value must be unique for each</td>
</tr>
<tr>
<td></td>
<td>element in a project. Revit Structure warns you if the value is in use, but allows you to continue</td>
</tr>
<tr>
<td></td>
<td>using it. You can see the warning using the Review Warnings command. See Reviewing Warning Messages</td>
</tr>
<tr>
<td></td>
<td>on page 1680.</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Indicates the creation phase of the host element. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Indicates the demolition phase of the host element. See Project Phasing on page 877.</td>
</tr>
</tbody>
</table>

## Rebar Hooks

Rebar hooks have a matrix relationship between the hook angle and rebar size. The rebar hook type comprises a defined hook angle and initial hook length, as explained in Rebar Hook Type Properties on page 431. You can change the hook lengths for the rebar type, as explained in Rebar Type Properties on page 423. After the placement of rebar, Revit Structure provides graphical controls to modify the rebar orientation, as explained in Rebar Hook Graphical Controls on page 429.

### Place rebar hooks

1. Select either a rebar instance or a rebar set. This will require a section view or unobscured rebar visibility settings.
2. On the Properties palette, add hooks as needed under the Construction section:
   - Select a hook type from the Hook at Start parameter.
   - Select a hook type from the Hook at End parameter.

### Define a rebar hook type

1. In the Project Browser, navigate to Families ➤ Structural Rebar ➤ Rebar Hook.
2. Right-click a hook, and select Duplicate.
3. Double-click the new copy.
4. Define the Style, Hook Angle, and Extension Multiplier in Rebar Hook Type Properties on page 431.
5. Click OK.
6. Right-click the new hook type, and select Rename. Enter a name for the hook type.

You can now apply this hook type to instances within the project. For example, associate the hook with all rebar instances to ensure accurate scheduling.

### Applying new hook types

1. In the Project Browser, again navigate to Rebar Hook.
2. Double-click a rebar type.
3. Click the Hook Lengths Edit button in the Dimensions section to define the Rebar Hook Length Parameters on page 427.
4. Select a hook type and adjust length parameters as needed.
5. Click OK.
6. Repeat steps 7-11 for all rebar instances that use the new hook.
Rebar Hook Length Parameters

You define hook length parameters for a rebar type with the Rebar Hook Length Parameter dialog. Access the dialog by clicking the Hook Lengths Edit button in Rebar Type Properties. See Rebar Type Properties on page 423.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rebar Hook Type</td>
<td>This is a self-populated list of valid rebar hooks for this rebar type. Selecting the check box indicates that the hook type is visible in the Hook at Start or Hook at End parameters of the rebar. See Rebar Instance Properties on page 424.</td>
</tr>
<tr>
<td>Auto Calculation</td>
<td>Clear this check box to override the automatic calculation of Hook Length and Offset Length.</td>
</tr>
<tr>
<td>Hook Length</td>
<td>Displays the length of the hook type.</td>
</tr>
<tr>
<td>Offset Length</td>
<td>Displays the offset length of the hook type. Use this optional parameter primarily for scheduling.</td>
</tr>
</tbody>
</table>

Rebar Hook Definitions

The following images depict the parameters that define a rebar hook.

45° Hook
90° Hook

135° Hook

180° Hook
Rebar Hook Graphical Controls

When sketching rebar in place or for a family, you can use the following graphical controls to modify the rebar hook orientation and location. See Sketch Placement of Rebar on page 417 and Rebar Shape Family Editing Tools on page 418.

- 🔄 Toggle Hook Orientation: With rebar selected, separate controls display at each end of the rebar. Click this control to toggle the hook up or down.
- ⬆️ Swap Hooks: With rebar selected, click this control to swap the hooks at each end of the placed rebar.

Moving Hooks

Toggle the SPACEBAR to move the hooks of ties and stirrups.

Moving tie and stirrup hooks

1 Select the rebar.

2 Press the SPACEBAR to toggle the rebar shape (and hook) orientation as detailed in Changing the Orientation of Rebar Shapes on page 410.

Toggling Hook Orientation

A toggle hook orientation control is available at each end of the rebar. You access these controls through sketch mode.
Change Hook Orientation

1 Select the rebar.

2 Click Modify | Structural Rebar tab ➤ Mode panel ➤ Edit Sketch.

3 Click to toggle the hook orientation down.

4 Click Modify | Structural Rebar > Edit Rebar Sketch tab ➤ Mode panel ➤ Finish Edit Mode. to view the orientation of the hook.
NOTE You can also reorient hooks using the SPACEBAR. Press the SPACEBAR to toggle the rebar shape (and hook) orientation as explained in Changing the Orientation of Rebar Shapes on page 410.

Swapping Hooks

Use the swap hook control to change the position of the rebar hook. Access these controls through sketch mode.

Swap Hooks on Rebar

1 Select the rebar.

2 Click Modify | Structural Rebar tab ➤ Mode panel ➤ Edit Sketch.

Notice the hook orientation controls.

3 Click the Swap Hook Control to swap the hooks at each end of the placed rebar.

Rebar Hooks Swap Sides

4 Click Modify | Structural Rebar > Edit Rebar Sketch tab ➤ Mode panel ➤ Finish Edit Mode.

NOTE You can also swap hooks using the SPACEBAR. Press the SPACEBAR to toggle the rebar shape (and hook) orientation as explained in Changing the Orientation of Rebar Shapes on page 410.

Rebar Hook Type Properties

The following table describes each parameter contained in the Hook Type Properties dialog. To access this table, double-click the desired rebar hook family in the Project Browser.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Style</td>
<td>Specifies which of the 2 bend radii of the Standard or Stirrup/Tie to use for bending the specified hook.</td>
</tr>
<tr>
<td>Hook Angle</td>
<td>Specifies the angle (0 - 180 degrees) of the hook for the selected hook type.</td>
</tr>
<tr>
<td>Extension Multiplier</td>
<td>Aids the calculation of the hook length of the rebar type until you override the value for the rebar hook lengths. See Rebar Type Properties on page 423.</td>
</tr>
</tbody>
</table>

**Rebar Sets**

The rebar sets feature turns a single rebar element into a linear set. You create rebar sets perpendicular to the sketch plane of the rebar and define the number of bars and bar spacing. Using rebar sets speeds up the process of adding rebar by providing a quantity of identical bars. You tag and schedule rebar sets as a single object that contains quantity and spacing information. Rebar sets provide better performance than standard arrays of rebar.

**Creating Rebar Sets**

1. Select an existing rebar instance.

![Rebar Set Layout Properties](image)

The rebar set layout properties display on the Options Bar.

2. Select a type of rebar layout from the Layout drop-down on the Options Bar.

   - **Fixed Number**: The spacing between the rebar is adjustable, but the number of bars is constant, based on your input.
   - **Maximum Spacing**: You specify the maximum distance between rebar, but the number of rebar changes, based on the distance between the first and last bars.
   - **Number with Spacing**: You specify constant values for quantity and spacing.
   - **Minimum Clear Spacing**: You specify the minimum distance between rebar, and the quantity of rebar changes, based on the distance between the first and last bars. This spacing maintains even if the rebar size changes.

3. Based on your selection, enter a value for Quantity or Spacing, or for both.

4. Press ENTER to complete the procedure.

![Rebar Set Layout Properties](image)

**To suppress the first and last bars of a rebar set**

5. In either a section or 3D view, select the rebar set. Check boxes display on both sides of the rebar set.

![Check Boxes on Rebar Set](image)

6. Deselecting a check box will hide the respective bar.
The bar is hidden and not removed from the set. It responds to rebar cover and rebar set shape handles.

Rebar Sets Shape Handles

You can resize rebar sets when the selected layout rule is either Fixed Number, Maximum Spacing, or Minimum Clear Spacing. Select the rebar set by clicking any rebar instance in the set. Shape handles display on the set.

Based on the layout rule, modifying the set by using shape handles has different results:

- **Fixed Number**: Dragging the shape handles modifies the distance between the rebar instances in the set.
- **Maximum Spacing**: Dragging the shape handles modifies the number of rebar instances in the set, while maintaining a distance that is no larger than the maximum spacing you defined.
- **Minimum Clear Spacing**: Dragging the shape handles modifies the number of rebar instances in the set, while maintaining a distance that is no smaller than the minimum amount of clear spacing you defined.

Area Reinforcement

Use the Sketch Area Reinforcement tool to place large amounts of evenly spaced reinforcing bars in structural floors and walls. Area reinforcement creates up to four layers of reinforcing bars in the host. You can create two layers of rebar perpendicular to each adjacent face (top and bottom faces for structural floors, interior and exterior faces for walls). You can define the bar size and spacing for each layer.

A sketched boundary defines the extents of the reinforcing bars. Apply rebar hook types to each layer using the Properties palette. If you edit the properties of the area reinforcement sketch line, you can use hook overrides.

*Area reinforcement in a structural floor*
The instance properties of the host control the rebar cover settings (offset distance from the edge/face of the host to the rebar) for each area reinforcement instance. Different rebar types require different coverage. See Modifying Rebar Cover Settings on page 400.

Sketching Area Reinforcement

Sketch area reinforcement in structural floors and walls for large areas that need reinforcement.

1 Click Home tab ➤ Reinforcement panel ➤ Area.
2 Select the floor or wall to receive area reinforcement.
3 Click Modify | Create Reinforcement Boundary tab ➤ Draw panel ➤ Rebar Line.
4 Click once to select a starting point for the area reinforcement sketch.
5 Continue to select points until you form a closed loop.

A parallel line symbol indicates the major direction edge of the area reinforcement.

6 Click Modify | Create Reinforcement Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

Revit places an area reinforcement symbol and tag on the completed sketch at the center of the area reinforcement. For more information, see Tagging Area Reinforcement on page 438.

**NOTE** When you place area reinforcement, the rebar elements are not visible unless you create a section view of the host element. For more information, see Viewing Area Reinforcement in a Cross Section on page 435.

Whole Host Area Reinforcement

You can place reinforcement that spans the full extents of the host element. This method does not allow for individual control of the rebar hooks.
1 Open a 3D view of a structural floor or wall.
2 Click Home tab ➤ Reinforcement panel ➤ Area.
3 Select the host (such as a structural floor or wall) to receive reinforcement.
4 Click Modify | Create Reinforcement Boundary tab ➤ Draw panel ➤ Major Direction.
5 Using the tools in the sketch gallery, sketch a line along one edge of the host element to establish the direction of reinforcement.

6 Click Modify | Create Reinforcement Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

NOTE When you place area reinforcement, the rebar elements are not visible unless you create a section view of the host element. For more information, see Viewing Area Reinforcement in a Cross Section on page 435.

Viewing Area Reinforcement in a Cross Section

1 Sketch a section view, either parallel or perpendicular to the major direction of the area reinforcement.

Create a section view of an area reinforcement
2 In the Project Browser, double-click the section view that you created to see a graphical representation of the rebar area reinforcement.

### Area Reinforcement Type Properties

**NOTE** Area Reinforcement Type properties are not available in Revit Structure 2009 or later releases. Newly created area reinforcement instances will not have these properties. However, legacy projects maintain the properties for editing purposes. View non-legacy rebar cover reference settings in the Structural section of Instance Properties of a host. See Modifying Rebar Cover Settings on page 400.

The following table describes each parameter contained in the Area Reinforcement Type Properties dialog. Select the legacy area reinforcement and then select Modify | Structural Area Reinforcement tab ➤ Properties panel ➤ to access this table.

Area reinforcement properties for structural walls are identified as either exterior or interior to reflect the vertical orientation of the rebar. Properties for structural floors are identified as either top or bottom to reflect the horizontal orientation.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Rebar Cover Top/Exterior</td>
<td>Specifies the offset from the top/exterior face of the host to the rebar.</td>
</tr>
</tbody>
</table>
### Area Reinforcement Instance Properties

The following table describes each parameter contained on the Area Reinforcement Properties palette. Area reinforcement properties for structural walls are identified as either exterior or interior to reflect the vertical orientation of the rebar. Properties for structural floors are identified as either top or bottom to reflect the horizontal orientation.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Layout Rule</td>
<td>Specifies the type of rebar layout. Select either Maximum Spacing or Fixed</td>
</tr>
<tr>
<td></td>
<td>Number. See Rebar Sets on page 432.</td>
</tr>
<tr>
<td><strong>Structural</strong></td>
<td></td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Calculates and displays the reinforcement volume (read-only).</td>
</tr>
<tr>
<td><strong>Layers</strong></td>
<td></td>
</tr>
<tr>
<td>Top Major Direction</td>
<td>Creates rebar in this layer. Clear this box to disable rebar in this layer.</td>
</tr>
<tr>
<td>Top Major Bar Type</td>
<td>Specifies the type for rebar placed in the major direction.</td>
</tr>
<tr>
<td>Top Major Hook Type</td>
<td>Specifies the hook type for rebar placed in the major direction.</td>
</tr>
<tr>
<td>Top Major Hook Orientation</td>
<td>Specifies the orientation of the hook for rebar placed in the major direction.</td>
</tr>
<tr>
<td>Top Major Spacing</td>
<td>Specifies the spacing for rebar placed in the major direction. You can access this parameter with the Maximum Spacing Layout Rule.</td>
</tr>
<tr>
<td>Top Major Number of Lines</td>
<td>Specifies the number of rebar instances within the reinforcement. You can access this parameter with the Fixed Number Layout Rule.</td>
</tr>
<tr>
<td>Top Minor Direction</td>
<td>Creates rebar in this layer. Clear this box to disable rebar in this layer.</td>
</tr>
<tr>
<td>Top Minor Bar Type</td>
<td>Specifies the type for rebar placed in the minor direction.</td>
</tr>
<tr>
<td>Top Minor Hook Type</td>
<td>Specifies the hook type for rebar placed in the minor direction.</td>
</tr>
<tr>
<td>Top Minor Hook Orientation</td>
<td>Specifies the orientation of the hook for rebar placed in the minor direction.</td>
</tr>
<tr>
<td>Top Minor Spacing</td>
<td>Specifies the spacing for rebar placed in the minor direction.</td>
</tr>
<tr>
<td>Top Minor Number of Lines</td>
<td>Specifies the number of rebar instances within the reinforcement. You can access this parameter with the Fixed Number Layout Rule.</td>
</tr>
<tr>
<td>Bottom Major Direction</td>
<td>Creates rebar in this layer. Clear this box to disable rebar in this layer.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Bottom Major Bar Type</td>
<td>Specifies the type for rebar placed in the major direction.</td>
</tr>
<tr>
<td>Bottom Major Hook Type</td>
<td>Specifies the hook type for rebar placed in the major direction.</td>
</tr>
<tr>
<td>Bottom Major Hook Orientation</td>
<td>Specifies the orientation of the hook for rebar placed in the major direction.</td>
</tr>
<tr>
<td>Bottom Major Spacing</td>
<td>Specifies the spacing for rebar placed in the major direction. You can access this parameter with the Maximum Spacing Layout Rule.</td>
</tr>
<tr>
<td>Bottom Major Number of Lines</td>
<td>Specifies the number of rebar instances within the reinforcement. You can access this parameter with the Fixed Number Layout Rule.</td>
</tr>
<tr>
<td>Bottom Minor Direction</td>
<td>Creates rebar in this layer. Clear this box to disable rebar in this layer.</td>
</tr>
<tr>
<td>Bottom Minor Bar Type</td>
<td>Specifies the type for rebar placed in the minor direction.</td>
</tr>
<tr>
<td>Bottom Minor Hook Type</td>
<td>Specifies the hook type for rebar placed in the minor direction.</td>
</tr>
<tr>
<td>Bottom Minor Hook Orientation</td>
<td>Specifies the orientation of the hook for rebar placed in the minor direction.</td>
</tr>
<tr>
<td>Bottom Minor Spacing</td>
<td>Specifies the spacing for rebar placed in the minor direction.</td>
</tr>
<tr>
<td>Bottom Minor Number of Lines</td>
<td>Specifies the number of rebar instances within the reinforcement. You can access this parameter with the Fixed Number Layout Rule.</td>
</tr>
</tbody>
</table>

**Identity Data**

<table>
<thead>
<tr>
<th>Comments</th>
<th>User comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mark</td>
<td>A label used, for example, as a shop mark. This value must be unique for each element in a project. Revit Structure warns you if the value is in use, but allows you to continue using it. You can see the warning using the Review Warnings command. See Reviewing Warning Messages on page 1680.</td>
</tr>
</tbody>
</table>

**Phasing**

<table>
<thead>
<tr>
<th>Phase Created</th>
<th>Indicates the creation phase of the host element. See Project Phasing on page 877.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase Demolished</td>
<td>Indicates the demolition phase of the host element. See Project Phasing on page 877.</td>
</tr>
</tbody>
</table>

**Tagging Area Reinforcement**

You can annotate the area reinforcement region using custom symbols and tags. This provides information about the type of reinforcement and specific boundary details.

**Place an Area Reinforcement Symbol**

1. Click Annotate tab ➤ Symbol panel ➤ Area Reinforcement Symbol.
NOTE You can load reinforcement symbols from the Library if none exist in the project. See Symbols on page 951.

2 Select the area reinforcement on which to place the symbol.

3 Position and click to place the area reinforcement symbol.

Place an Area Reinforcement Tag

4 Select Annotate tab ➤ Tag panel ➤ Tag By Category.

NOTE You can load reinforcement tags from the Library if none exist in the project. See Tags on page 944.

5 Select the area reinforcement on which to place the tag.

You can include major spacing properties by editing the tag label. Bottom/Interior Major Spacing and Top/Exterior Major Spacing are available Category Parameters.

6 Press ESC to exit the Tag tool.

NOTE To resolve rounding errors that may manifest when tagging area reinforcement, you can modify the units of measurement for reinforcement volume and length. Click Manage tab ➤ Settings panel ➤ (Project Units). Under Reinforcement Volume or Reinforcement Length, adjust the units, rounding, and symbol representation as needed.

See Modifying Reinforcement Tag Abbreviations on page 1610 for information about custom reinforcement tags.

Path Reinforcement

Use the Sketch Path Reinforcement tool to lay out a large amount of rebar along a path. These bars have the same length, but are not all parallel to each other. The rebar is perpendicular to the boundary you specify. The hooked end of the rebar is near the specified boundary and the bars extend to one side of the path.
The instance properties of the host control the rebar cover settings (the offset distance from the edge/face of the host to the rebar) for each path reinforcement instance. Different rebar types require different coverage. See Modifying Rebar Cover Settings on page 400.

**Sketching Path Reinforcement**

1. Click Home tab ➤ Reinforcement panel ➤ Path.
2. Sketch the path for reinforcement on a concrete host, making sure not to form a closed loop.
3. Press ESC.
4. If necessary click on the Options Bar and click Flip Control, so the rebar extends to the opposite side of the path.
5. Click Modify | Create Reinforcement Path tab ➤ Mode panel ➤ Finish Edit Mode.

---

**NOTE** The boundary of the path reinforcement is on by default. Turn it off by clicking View tab ➤ Graphics panel ➤ Visibility Graphics and clearing the Boundary Visibility parameter under Structural Path Reinforcement.

Revit Structure places a Path Reinforcement symbol and a Path Reinforcement tag on the completed sketch at the center of the longest segment of the path. See Tagging Path Reinforcement on page 443.

**NOTE** When you sketch path reinforcement, the rebar elements are not visible unless you create a section view of the host element. For more information, see Viewing Path Reinforcement in Cross Section on page 441.
Viewing Path Reinforcement in Cross Section

1 Sketch a section view, either parallel or perpendicular to the sketch line of the path reinforcement.
2 Open the section view to see the path reinforcement.

Path reinforcement in section

NOTE The boundary of the path reinforcement is on by default. Turn it off by clicking View tab ➤ Graphics panel ➤ Visibility Graphics and clearing the Boundary Visibility parameter under Structural Path Reinforcement.

Path Reinforcement Type Properties

NOTE Path Reinforcement Type properties are not available in Revit Structure 2009 or later releases. Newly created path reinforcement instances will not have these properties. However, legacy projects maintain the properties for editing purposes. View non-legacy rebar cover reference settings in the Structural section of Instance Properties of a host. See Modifying Rebar Cover Settings on page 400.

The following table describes each parameter contained in the Path Reinforcement Type Properties dialog. Select the legacy path reinforcement and then select Modify | Structural Path Reinforcement tab ➤ Properties panel ➤ Type Properties to access this table.

Path reinforcement properties for structural walls are identified as either exterior or interior to reflect the vertical orientation of the rebar. Properties for structural floors are identified as either top or bottom to reflect the horizontal orientation.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Rebar Cover Top/Exterior</td>
<td>Specifies the offset from the top/exterior face of the host to the rebar.</td>
</tr>
<tr>
<td>Rebar Cover Bottom/Interior</td>
<td>Specifies the offset from the bottom/interior face of the host to the rebar.</td>
</tr>
<tr>
<td>Rebar Cover Side/Edge</td>
<td>Specifies the offset from the side/edge of the host to the rebar.</td>
</tr>
</tbody>
</table>
Path Reinforcement Instance Properties

The following table describes each parameter contained on the Path Reinforcement Properties palette.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Layout Rule</td>
<td>Specifies the type of rebar layout. Select either Maximum Spacing or Fixed Number. See Rebar Sets on page 432.</td>
</tr>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Calculates and displays reinforcement volume (read-only).</td>
</tr>
<tr>
<td>Layers</td>
<td></td>
</tr>
<tr>
<td>Face</td>
<td>Specifies the face justification, either top or bottom.</td>
</tr>
<tr>
<td>Bar Spacing</td>
<td>Specifies the spacing for rebar placed in the major direction. This parameter is only accessible with the Maximum Spacing Layout Rule.</td>
</tr>
<tr>
<td>Number of Bars</td>
<td>Specifies the number of rebar instances within the reinforcement. You can access this parameter with the Fixed Number Layout Rule.</td>
</tr>
<tr>
<td>Primary Bar - Type</td>
<td>Specifies the bar type.</td>
</tr>
<tr>
<td>Primary Bar - Length</td>
<td>Specifies the length of the rebar.</td>
</tr>
<tr>
<td>Primary Bar - Start Hook Type</td>
<td>Specifies the type of hook (either Standard or Stirrup/Tie) and the angle for the start of the path reinforcement.</td>
</tr>
<tr>
<td>Primary Bar - End Hook Type</td>
<td>Specifies the type of hook (either Standard or Stirrup/Tie) and the angle for the end of the path reinforcement.</td>
</tr>
<tr>
<td>Primary Bar - Hook Orientation</td>
<td>Specifies the orientation of the rebar hook, either up or down.</td>
</tr>
<tr>
<td>Alternating Bars</td>
<td>When selected, enables alternate bar type.</td>
</tr>
<tr>
<td>Alternating Bar - Type</td>
<td>Specifies the bar type. Selecting the Alternating Bars parameter enables this parameter.</td>
</tr>
<tr>
<td>Alternating Bar - Length</td>
<td>Specifies the length of the rebar. Selecting the Alternating Bars parameter enables this parameter.</td>
</tr>
<tr>
<td>Alternating Bar - Offset</td>
<td>Specifies the offset distance from the primary bar. Selecting the Alternating Bars parameter enables this parameter.</td>
</tr>
<tr>
<td>Alternating Bar - Start Hook Type</td>
<td>Specifies the type of hook (either Standard or Stirrup/Tie) and the angle for the start of the path reinforcement. Selecting the Alternating Bars parameter enables this parameter.</td>
</tr>
<tr>
<td>Alternating Bar - End Hook Type</td>
<td>Specifies the type of hook (either Standard or Stirrup/Tie) and the angle for the end of the path reinforcement. Selecting the Alternating Bars parameter enables this parameter.</td>
</tr>
</tbody>
</table>
### Name | Description
---|---
**Alternating Bar - Hook Orientation** | Specifies the orientation of the rebar hook, either up or down. Selecting the Alternating Bars parameter enables this parameter.

### Identity Data

<table>
<thead>
<tr>
<th>Comments</th>
<th>User comments</th>
</tr>
</thead>
</table>

**Mark** | A label used, for example, as a shop mark. This value must be unique for each element in a project. Revit Structure warns you if the value is in use, but allows you to continue using it. You can see the warning using the Review Warnings command. See Reviewing Warning Messages on page 1680.

### Phasing

| Phase Created | Indicates the creation phase of the host element. See Project Phasing on page 877. |
| Phase Demolished | Indicates the demolition phase of the host element. See Project Phasing on page 877. |

---

**Tagging Path Reinforcement**

You can annotate the path reinforcement region using custom symbols and tags. This provides information about the type of reinforcement and specific boundary details.

**Place a Path Reinforcement Symbol**

1. Click Annotate tab ➤ Symbol panel ➤ Path Reinforcement Symbol.

2. **NOTE** You can load reinforcement symbols from the Library if none exist in the project. For more information, see Symbols on page 951.

3. Select the path reinforcement on which to place the symbol.

4. Position and click to place the path reinforcement symbol.

---

**Place a Path Reinforcement Tag**

5. Select Annotate tab ➤ Tag panel ➤ Tag By Category.
NOTE You can load reinforcement tags from the Library if none exist in the project. For more information, see Tags on page 944.

6 Select the path reinforcement on which to place the tag.

7 Press ESC to exit the Tag tool.

See Modifying Reinforcement Tag Abbreviations on page 1610 for information about custom reinforcement tags.
Architectural Modeling

Revit Structure provides various familiar components for building design. No programming language or coding is required to create these components.
Building The Model
Walls

Like other basic elements in a Revit Structure building model, walls are instances of predefined system family types, which represent standard varieties of wall function, composition, and thickness. You can customize these characteristics by modifying a wall's type properties to add or remove layers, divide them into regions, and change their thickness or assigned material.

After you place a wall in a drawing, you can add sweeps or reveals, edit the wall's profile, and insert hosted components such as doors and windows.

This topic covers 2 of the 3 Revit wall families: Basic Wall and Stacked Wall. For information on the Curtain Wall family, see Curtain Elements on page 623.

3D view of walls
Walls Overview

You add walls to a Revit Structure building model by clicking the Wall tool, selecting the desired wall type, and placing instances of that type in a plan view or 3D view.

To place an instance, you select one of the draw tools on the ribbon, and either sketch the linear extents of the wall in the drawing area, or define them by picking an existing line, edge, or face. The position of the wall relative to the path you sketch or the existing element you select is determined by the value of one of the wall’s instance properties: Location Line.

Location Line

A wall’s Location Line property specifies which of its vertical planes is used to position the wall in relation to the path you sketch or otherwise specify in the drawing area. When laying out compound walls that join, you can place them precisely with respect to a particular material layer of interest, such as the concrete masonry units.

Regardless of the wall type, you can select any of the following planes, either on the Options Bar (before placing the wall) or on the Properties palette (before or after):

■ Wall Centerline (default)
■ Core Centerline
■ Finish Face: Exterior
■ Finish Face: Interior
■ Core Face: Exterior
■ Core Face: Interior

NOTE In Revit terminology, the core of a wall refers to its main structural layer or layers. In a simple brick wall, the Wall Centerline and Core Centerline planes would coincide, whereas they would likely differ in a compound wall. When you draw a wall from left to right, its exterior face (Finish Face: Exterior) is at the top by default.

In the following example, with the Location Line value specified as Finish Face: Exterior, the cursor is placed on a dashed reference line, and the wall is drawn from left to right.

If you change the Location Line value to Finish Face: Interior, and draw another segment along the reference line in the same direction, the new segment is placed above the reference line.

When you select a single wall segment, the blue dots (Drag Wall End controls) indicate its location line.
Once a wall is placed, its location line persists, even if you modify the structure of its type or change to a different type. Changing the value of the Location Line property for an existing wall does not change the wall’s position. However, when you use the Spacebar or on-screen flip controls to switch the interior/exterior orientation of a wall, the location line is the axis around which the wall flips. So if you change the Location Line value and then change the orientation, it may change the wall position as well.

Note that the position of the blue dots does not change until you deselect and reselect the wall.

**Wall Function**

All wall types within the Basic Wall and Stacked Wall families have a type property called Function, which can have the following values:

- Interior
- Exterior
- Foundation
- Retaining
- Soffit
- Core-Shaft

You can filter the display of walls in a view to show/hide only those walls that serve a particular function. When creating a wall schedule, you can also use this property to include or exclude walls according to function.

**Related Topics**

- [Function of Walls, Floors, and Building Pads](#) on page 1138
- [Schedules](#) on page 771

**Compound Walls**

Just as roofs, floors, and ceilings in Revit can consist of multiple horizontal layers, walls can consist of more than one vertical layer or region. The position, thickness, and material for each layer and region are defined through the type properties of the wall. You can add, delete, or modify individual layers and regions, or add sweeps and reveals to customize the wall type.

For basic information common to multi-layer elements in Revit, see [Compound Structure](#) on page 573. For information specific to compound walls, see [Working with Compound Walls](#) on page 465.

**Stacked Walls**

In addition to the Basic Wall and Curtain Wall families, Revit includes a Stacked Wall family for modeling walls that consist of 2 or more distinct subwalls stacked on top of each other.

**Structural Walls**

All wall types within the Basic Wall family have an instance property called Structural Usage, which specifies whether the wall is non-bearing or one of 3 kinds of structural wall (bearing, shear, or structural combined).
When you use the Wall tool, Revit assumes you are placing partition walls. Whichever wall type you select, the default Structural Usage value is non-bearing. When you use the Structural Wall tool, and select the same wall type, the default Structural Usage value is bearing. In either case, the value is read-only, but you can change it after the wall is placed.

Documentation for structural walls is provided separately under Structural Modeling on page 217.

Embedded Walls

Walls can be embedded into a host wall, so that the embedded wall is associated with the host wall. For example, a curtain wall can be embedded into an exterior wall, or a wall can be embedded into a curtain panel. Like doors or windows in the host wall, the embedded wall does not resize if you resize its host. If you move the host wall, the embedded wall moves with it.

Curtain wall embedded in host wall

For more information, see Embedding Curtain Walls on page 629.

Wall Joins

When walls intersect, Revit creates a butt join by default and cleans up the display in plan view by removing visible edges between the walls and their corresponding component layers. The view's Wall Join Display instance property controls whether the cleanup applies to all wall types or only to walls of the same type.

You can change how the join displays in a plan view by selecting a different join option (Miter or Square-off) or by specifying which one of the walls butts up or squares off against the other(s). You can also specify whether the join cleans up, does not clean up, or cleans up according to the default setting for the view. For more information, see Changing the Configuration of a Wall Join on page 458.

Placing Walls

Use this procedure to place one or more instances of a specific type of partition wall in your building model.

1. In a floor plan view or 3D view, click Home tab ➤ Structure panel ➤ Wall drop-down ➤ Partition Wall.
2. If you want to place a wall type other than the one displayed in the Type Selector on page 35 at the top of the Properties palette, select a different type from the drop-down.
   You can use the bottom part of the Properties palette to modify some of the instance properties for the selected wall type before you start placing instances. To open a dialog where you can edit the type properties, click Edit Type. Any changes you make in the Type Properties dialog will apply to all existing instances of the current wall type as well as the ones you are about to place.
3 On the Options Bar, specify the following:

- **Level.** (3D views only) Select a level for the wall’s base constraint. You can choose a non-story level. See *Levels* on page 93.

- **Height.** Select a level for the wall’s top constraint, or enter a value for the default setting of Unconnected.

- **Location Line.** Select which vertical plane of the wall you want to align with the cursor as you draw, or with the line or face you will select in the drawing area. For examples, see *Location Line* on page 450.

- **Chain.** Select this option to draw a series of wall segments connected at endpoints.

- **Offset.** Optionally enter a distance to specify how far the wall’s location line will be offset from the cursor position or from a selected line or face (as described in the next step).

4 On the Draw panel, select a draw tool to place the wall using one of the following methods:

- **Draw the wall.** Use the default Line tool to place a straight wall segment by specifying both a start point and an endpoint in the drawing. Alternatively, you can specify the start point, move the cursor in the desired direction, and then enter a value for the wall length. Other tools on the Draw panel let you sketch rectangular, polygonal, circular, or arced layouts. For detailed descriptions of these tools, see *Sketching Elements* on page 1406.

  As you are drawing a wall with any of these tools, you can press the *Spacebar* to flip the interior/exterior orientation of the wall in relation to its location line.

- **Place the wall along an existing line.** Use the Pick Lines tool to place wall segments along lines you select in the drawing. The lines can be model lines, reference planes, or edges of elements, such as roofs, curtain panels, and other walls.

  **TIP** To place walls simultaneously on an entire chain of lines, move the cursor over a line segment, press *Tab* to highlight them all, and then click.

- **Place the wall on an existing face.** Use the Pick Faces tool to place a wall on a massing face or a generic model face that you select in the drawing. See *Modeling by Face* on page 1356.

  **TIP** To place walls simultaneously on all vertical faces on the mass or generic model, move the cursor over one of faces, press *Tab* to highlight them all, and then click.

5 To exit the Wall tool, click *Modify.*

You can now add dimensions if desired (see *Placing Permanent Dimensions* on page 889), or adjust the layout and geometry of walls using the tools described under *Editing Elements* on page 1439. For information on wall-specific modifications, such as changing the physical structure of walls or editing joins, see *Modifying Walls* on page 454.

**Attaching Walls to Other Elements**

After placing a wall, you can override its initial top and base constraints by attaching its top or base to another element in the same vertical plane. The other element can be a floor, a roof, a ceiling, a reference plane, or another wall that is directly above or below. The height of the wall then increases or decreases as necessary to conform to the boundary represented by the attached element.

By attaching a wall to another element, you can avoid having to manually edit the wall’s profile when your design changes. In the following example, the image on the left shows a roof placed on walls that have been
drawn with their top constraint specified as Level 2. The middle image shows the effect of attaching the
walls to the roof. The image on the right shows how the wall profile changes accordingly when the pitch
of the attached roof is changed.

Effect of attaching walls to a roof

The following guidelines apply:

- You can attach wall tops to non-vertical reference planes.
- You can attach walls to in-place roofs or floors.
- If a wall’s top is currently attached to a reference plane, attaching the top to a second reference plane
detaches it from the first.
- You can attach walls that are parallel in the same vertical plane; that is, directly above or below one
another.

To attach walls to other elements

1. In the drawing area, select one or more walls you want to attach to other elements.
2. Click Modify | Walls tab ➤ Modify Wall panel ➤ Attach Top/Base.
3. On the Options Bar, for Attach Wall, select either Top or Base.
4. Select the elements to which the wall will attach.

To detach walls from other elements

1. In the drawing area, select the walls to detach.
2. Click Modify | Walls tab ➤ Modify Wall panel ➤ Detach Top/Base.
3. Select the individual elements from which to detach the walls. Alternatively, if you want to
detach the selected walls from all other elements at once (or you are not sure which elements
are attached), click Detach All on the Options Bar.

Modifying Walls

After placing walls in the drawing area, you can modify their layout and geometry using tools common to
most elements, as described under Editing Elements on page 1439. The current topic addresses wall-specific
modifications, such as changing the physical structure of walls or editing joins.

Changing the Type of a Wall

When you activate the Wall tool to place walls, you select the desired wall type from the Type Selector on
page 35 drop-down. You can also change the wall type after placement, by selecting the wall in the drawing
area and then changing the Type Selector setting. Alternatively you can select an existing wall and convert
other selected walls to the same type, as described under Changing Element Types Using the Match Type Tool on page 1497

**Editing the Profile of a Wall**

In most cases, when you place a straight wall, it has a rectangular profile when viewed in elevations parallel to its length. If your design calls for a different shape of profile, or for openings in the wall, use the following procedure to edit the wall’s elevation profile in either a section or elevation view.

**Design with non-rectangular walls and cut openings**

**NOTE** You cannot edit the elevation profile of an arc wall. To place rectangular openings in an arc wall, use the **Wall Opening tool**, which can also be used to place openings in straight walls.

**To edit the profile of a wall**

1. In the drawing area, select the wall.

2. Click **Modify | Walls tab ➤ Mode panel ➤ Edit Profile**.
   
   If the active view is a plan view, the Go To View dialog displays, prompting you to select an appropriate elevation or section view. For example, for a north wall, you could select either the North or South elevation view.
   
   When an appropriate view is open, the profile of the wall displays in magenta model lines, as shown.

3. Use the tools on the Modify and Draw panels to edit the profile as needed.
   - Delete the lines and then sketch a completely different shape.
   - Split the existing lines and add arcs.
   - Draw openings or holes.

**Wall modified**
TIP As you move and edit the rectangle, datum planes appear to indicate the original shape and size of the wall when you entered sketch mode. If the sketched lines snap to the datum planes, the endpoints of the lines automatically align to the planes, unless you explicitly unlock them. If you unlock the sketched lines, you can modify them independently of the datum planes. If you exit sketch mode with the sketched lines still aligned, then as you move a datum handle, the sketched lines move with it.

Sketch lines unlocked

4 When you are finished, click Finish Edit Mode.

NOTE If you want to restore an edited wall to its original shape, select it, and click Modify | Walls tab ➤ Mode panel ➤ Reset Profile.

Creating Mid-End Faces

When you edit the elevation profile of a wall that spans multiple levels and create notches such as those shown below, the new vertical edges represent jambs that are referred to in Revit as mid-end faces. Other walls can form corner joins with mid-end faces. See Joining Walls to Mid-End Faces on page 461

Wall elevation profile edited to create notches
Edited wall in 3D view

You can also create mid-end faces using the Wall Opening tool. See Cutting Rectangular Openings in Walls on page 562.

**Working with Wall Joins**

When walls intersect, Revit Structure creates a butt join by default and cleans up the display in plan view, removing visible edges between the joined walls and their corresponding component layers.

**Butt join with and without cleanup at coarse level of detail**

![Butt join with and without cleanup at coarse level of detail](image)

**Butt join with and without cleanup at fine level of detail**

![Butt join with and without cleanup at fine level of detail](image)

You can change how the join displays in a plan view by selecting a join option other than Butt (Miter or Square-off) or by specifying a different order in which the walls butt up or square off against one another. For detailed instructions, see Changing the Configuration of a Wall Join on page 458.

You can also specify whether the join cleans up, does not clean up, or cleans up according to the default setting for the view. See Specifying Wall Join Cleanup Options on page 459.
Changing the Configuration of a Wall Join

Use this procedure to change the configuration of a join involving 4 walls or fewer by changing the type of join or the order in which the walls join.

**NOTE** To edit a wall join with more than 4 walls, a wall join that spans multiple floors, or a wall join that is in more than one workset, see Editing Complex Wall Joins on page 463.

1. Click Modify tab ➤ Geometry panel ➤ (Wall Joins).
2. Move the cursor over the wall join, and click within the gray square that displays.
3. On the Options Bar, select one of the available join types:
   - **Butt** (the default join type)
   - **Miter**
   - **Square off**: Squares a wall end to 90 degrees.
4 If the selected join type is Butt or Square off, you can click the Next and Previous buttons to cycle through previews of the possible join orders. For the squared-off join shown above, the following alternative order would be available.

NOTE You cannot square off or miter the join between a wall and the interior of another wall, nor change the order of the butt join, because only one configuration of butt join is possible. An example of this layout is shown below (with the Don’t Clean Join option selected).

5 When the desired configuration is displayed, click Modify to exit the tool.

**Specifying Wall Join Cleanup Options**

Use the following procedure to specify whether and how a wall join cleans up in an active plan view.
1 Click Modify tab ➤ Geometry panel ➤ (Wall Joins).

2 Move the cursor over the wall join, and click within the gray square that displays.

3 On the Options Bar, for Display, select one of the following options:
   - **Clean Join.** Displays a smooth join. While the join is selected for editing, temporary solid lines indicate where the wall layers actually end, as shown below; these lines disappear when you exit the Wall Joins tool and do not print.

   ![Clean Join Example](image1)

   - **Don't Clean Join.** Displays the wall ends butting up against one another as shown.

   ![Don't Clean Join Example](image2)

   - **Use View Setting.** Cleans wall joins according to the view’s Wall Join Display instance property (see View Properties on page 873). This property controls whether the cleanup applies to all wall types or only to walls of the same type.

4 Click Modify to exit the tool.
Joining Parallel Walls

Revit Structure automatically creates joins between intersecting walls. Use the following procedure to join the geometry of closely-spaced parallel walls.

1 In a plan view, place the walls less than 6 inches apart.

2 Click Modify tab ➤ Geometry panel ➤ Join drop-down ➤ Join Geometry.

3 Select the walls to join.

   If either wall has an insert (such as a window), it cuts through the joined wall. Any geometry around the insert, such as a frame, does not display on the joined wall.

   Parallel walls before geometry is joined

   ![Parallel walls before geometry is joined](image)

   Parallel walls after geometry is joined

   ![Parallel walls after geometry is joined](image)

Joining Walls to Mid-End Faces

Use this procedure to place a wall that is joined to a mid-end face in another wall. When you drag either of the joined walls, the join is maintained, and the other wall lengthens or shortens accordingly.

1 Open a plan view in which the mid-end face is visible.

   TIP If only the ends of the wall with the mid-end face are visible, you may need to adjust the cut plane height. For more information, see View Range on page 864.

2 Click Home tab ➤ Structure panel ➤ Partition Wall, and select the desired wall type from the Type Selector on page 35.

3 Move the cursor over the mid-end face until an endpoint displays, and then click to specify the new wall start point.

4 Move the cursor in the desired direction.
Sketching a wall with its start point at a mid-end face

5 Click to specify the new wall’s endpoint. The join between the walls cleans up as shown.

When you drag either of the joined walls, the wall join moves with it.

Wall join moves with the preview of the wall being moved

NOTE When you edit the elevation profile of a wall with a mid-end face that is joined to another wall, the vertical line representing the mid-end face is aligned to the center line of the joined wall, not the actual face of the wall. When you cancel edit mode, the join cleans up and the vertical line moves to coincide with the face of the joined wall.

Sketch line indicating mid-end face displays in the middle of the joined wall in edit mode
Joins with Non-Editable Walls

When you are working in a team environment and have enabled worksharing, you can specify whether the elements in a workset are editable (see Setting Up Worksets on page 1212). Non-editable walls can be joined and unjoined according to the following guidelines:

■ You can join or unjoin an editable wall and the side face of a non-editable wall or a corner where 2 or more non-editable walls are already joined.

■ You can delete an editable wall that is joined to a non-editable wall, except as noted below.

■ You cannot join or unjoin an editable wall to a non-editable wall if that would change the shape of the non-editable wall.

■ You cannot join an editable wall to the end of a non-editable wall. Revit Structure keeps the walls close together but does not join them and issues a warning. (You can make both walls editable later and join them.)

■ A wall can resize, even if it is not editable, as happens if you move the wall to which it is joined.

Editing Complex Wall Joins

The Wall Joins tool is not recommended for editing wall joins that involve more than 4 walls, span multiple floors, or exist in more than one workset. For these more complex joins, use the following basic procedure to edit individual walls as needed.

NOTE Complex wall joins can have many possible configurations. You may have to step through hundreds of them to find the desired one.

1. If applicable, set all involved worksets to editable. See Making Worksets Editable on page 1223.
2. Select one of the joined walls, and use its Drag Wall End control to move it out of the join.
3. Drag the wall end back to a different location within the join.

   TIP Use snap points, snap lines, and the feedback on the status bar to help pinpoint the new location.

4. If the automatically created join does not produce the desired configuration, you can disallow joins for the joined end of the selected wall, move it again, and then re-create the join using the Join Geometry tool.
5. Repeat the previous 3 steps as needed for the selected wall and others in the join.

Allowing/Disallowing Wall Joins

By default, Revit Structure creates a join where 2 walls intersect. But you can disallow joins for a selected wall whenever necessary. For example, if you want to keep small expansion spaces between walls, you can do so by disallowing joins for either of the adjacent wall ends.

2 horizontal walls with 3/8-inch expansion space between them

Disallowing joins is also useful for resolving complex joins. For example, if you add a wall to a complex join and it produces undesired results, you can disallow joins on the added wall and then use the Join Geometry tool to clean the join between this wall and other walls.
The procedure for disallowing joins varies slightly for the ends of a wall as opposed to any of its mid-end faces.

**To disallow/allow joins for a wall end**

1. Select the wall.
2. Right-click the wall end control where you want to disallow the join, and click Disallow Join. The end of the wall now cannot join to another wall. If you want to allow joins again, right-click the wall end control, and click Allow Join, or click (Allow Join) above the end of the wall.

**To disallow a join on a mid-end face**

1. Open a plan view in which the mid-end face is visible, and select the wall.

   **TIP** If only the ends of the wall with the mid-end face are visible, you may need to adjust the cut plane height. For more information, see View Range on page 864.

2. Click (Disallow Join) above the mid-end face, or right-click, and click Disallow Join. Notice that changes to . The mid-end face now cannot join to another wall.
Working with Compound Walls

The structure of vertically compound walls is defined using either layers or regions. The following image shows the Edit Assembly dialog.

Just as roofs, floors, and ceilings in Revit can consist of multiple horizontal layers, walls can consist of more than one vertical layer or region. The position, thickness, and material for each layer and region are defined in the Edit Assembly dialog, which is accessed through the type properties of the wall. You can add, delete, or modify individual layers and regions, or add sweeps and reveals to customize the wall type.

For basic information common to multi-layer elements in Revit, see Compound Structure on page 573.

NOTE To access the Edit Assembly dialog, select a wall, and on the Properties palette, click Edit Type. In the Type Properties dialog, for the Structure parameter, click Edit.

Layer rows: correspond to wall layers or regions

A layer is assigned to one row. It has a constant thickness and extends the height of the wall. You can change its thickness in the row assigned to it.
Wall layer: constant thickness and extends the height of the wall

A region is any shape in the wall that does not meet the criteria of a layer. Regions can have either constant or variable thickness. In a row assigned to a region, if region has a constant thickness, a numeric value appears for it. If the region has a variable thickness, the value is variable. You cannot change a region’s thickness in the row that is assigned to it. Note that the thickness value appears shaded, indicating that it is unavailable for modification. You can only change its thickness and height graphically in the preview pane.

Regions: neither region extends the full height of the wall

Because core thickness can vary in vertically compound walls, the core centerline and core face location lines are determined by the core thickness at the bottom of the wall. For example, if the wall core is thicker at the top than at the bottom, and you specify the location line as Core Centerline, the centerline of the core is measured between the core boundaries at the bottom.

You can add wall sweeps or reveals to vertically compound walls. See Wall Sweeps on page 476 and Wall Reveals on page 482.

You can use various tools to modify the structure of vertically compound walls.

**Accessing Vertically Compound Wall Tools**

1. In the drawing area, select the wall.

2. On the Properties palette, click Edit Type.

3. In the Type Properties dialog, click Preview to open the preview pane. All changes you make to the wall occur in the preview pane.

4. Below the preview pane, for View, select Section: Modify type attributes.

5. For the Structure parameter, click Edit.
Notice the tools that display at the bottom right of the Edit Assembly dialog under Modify Vertical Structure.

**NOTE** The vertically compound wall tools are available in the section preview only. Use them to modify the wall type only, not an actual wall instance.

---

### Sample Height

The sample height is the height of the wall in the preview pane only. You can specify any value for the sample height, but it should be high enough to allow you to create the desired wall structure. The sample height does not affect the height of any walls of that type in the project.

### Modify Tool

To change a vertically compound wall, in the Edit Assembly dialog, click Modify. (See Accessing Vertically Compound Wall Tools on page 466.) Then highlight and select either outer boundaries of the sample wall or borders between regions in the preview pane. Watch for tools and status bar messages that indicate what you are highlighting.

After you select a boundary, you can change thickness, set layer extension, or constrain a region's distance from the top or bottom of the wall.

#### Changing Thickness

If you select an outer vertical boundary of the sample wall, a temporary dimension displays. If you change the value of the temporary dimension, the thickness of the layer or region immediately adjacent to the boundary changes.

If you select a vertical border between regions, 2 temporary dimensions appear which control the thickness of the regions to the left and right of the border.

#### Allowing Layer Extension

If you select the horizontal outer boundary at the top or bottom of a layer, you can specify whether that layer can be extended.

Select a horizontal boundary at the top of the wall, and a padlock displays. A locked padlock indicates that the selected layer cannot be extended. Click the padlock to unlock it, and the layer can be extended.

**Unlocked layer indicating extendability**

When you unlock layers for extension, 2 instance properties of the wall become enabled: Top Extension Distance (for layers at the top of the wall) or Base Extension Distance (for layers at the bottom of the wall). You can enter values for these properties in the selected wall's Element Properties, or you can drag the unlocked wall layers in a view.

**NOTE** Unlocked layers must be adjacent. For example, you cannot have one layer locked and its adjacent layers unlocked.

To drag wall layers, modify them in section, 3D, and elevation views.
To drag wall layers

1. Place the cursor at the top or bottom of the wall and press *Tab* until you highlight the shape handle for the extendable layers. Watch the status bar to be sure you are highlighting the shape handle.

2. Click to select the shape handle.

3. Drag the shape handle up or down.

**Dragging layers with the shape handle**

---

**TIP** If you join 2 walls and they both have a vertical extension, the extended portions will be horizontally joined. The extension joins must be the same, top-to-top or bottom-to-bottom.

---

**Constraining a Region**

To constrain a region a certain distance from the top or bottom of a wall, click the horizontal border between 2 regions. A blue control arrow displays. Clicking the arrow alternates the constraint from the top to the bottom and displays a temporary dimension that you can edit.

When a region is constrained to the bottom of a wall, the region is always the same distance from the bottom regardless of how high the wall becomes. Likewise, when a region is constrained from the top, the region is always the same distance from the top.

Use constraints to keep a trim border or a brick soldier course at a specific height at the top of a building or a CMU a specific distance from the base of the building. See *Split Region Tool* on page 469.

**Soldier Course Constrained to Top of Wall**
Split Region Tool

When editing vertically compound walls, use the Split Region tool to divide a wall layer (or regions) horizontally or vertically into new regions. When you split a region, the new regions assume the same material as the original.

■ To split a layer or region horizontally, highlight one of the borders. A preview split line displays when you highlight a border.

Horizontal split preview

After you split a region or layer horizontally, click the border between the regions. A blue control arrow displays with a temporary dimension. If you click the arrow, it switches the constraint and its temporary dimension between the top and bottom of the wall. See Modify Tool on page 467.

Blue control arrow displayed when border is selected

■ To split a layer or region vertically, highlight and select a horizontal boundary. That boundary can be the outside boundary, or an inside boundary created if you previously split horizontally.

Vertical split preview

TIP Zoom in on the outer horizontal boundary to split it vertically.

Merge Regions Tool

When editing vertically compound walls, use the Merge Regions tool to merge wall regions together horizontally or vertically into new regions. Highlight a border between regions and click to merge them.

When you merge regions, the position of the cursor when you highlight a border determines which material prevails after the merge.

The material from the right region prevails when you merge
The material from the left region prevails when you merge

Assign Layers Tool

When editing vertically compound walls, use the Assign Layers tool to assign a row to a layer or region. (It assigns the number, material, and function of that row.)

It is more useful to assign layers to regions vertically, rather than horizontally. For example, you might split finish layer 1 into several regions. Then you could assign another finish row to some of those regions and create an alternating pattern, such as brick over concrete.

You should familiarize yourself with the layer functions of compound walls. See Applying a Function to a Layer of a Compound Structure on page 574. Also see Layer Assignment Rules on page 470.

To assign wall layers:

1 Click a row number to select it.
   All regions currently assigned to that row are highlighted in the preview pane.

   **NOTE** If the row does not have any regions assigned to it, it displays as a line in the preview pane, and its thickness is 0.

2 Click Assign Layers.
3 Click the boundary of a region to assign the row to that region.
4 Continue clicking other regions to continue assigning, or click Assign Layers to exit.

Layer Assignment Rules

When assigning layers in walls, consider the following guidelines:

- Rows of the sample wall in the preview pane must remain in a sequential order from left to right. To test the sample wall, select row numbers sequentially and observe the selection in the preview pane. If the layers do not highlight in an order from left to right, Revit Structure cannot produce this wall.

- A row cannot be assigned more than one layer.

- You cannot have the same row assigned to regions on both sides of the core.

- You cannot apply a thickness to a membrane layer.

- Non-membrane layers cannot have a thickness smaller than 1/8" or 4 mm.

- A layer in the core must have a thickness greater than 0. You cannot specify a layer in the core as a membrane layer.

- The exterior and interior core boundaries and the membrane layer cannot rise up and down.
Invalid boundary for core boundaries or membrane layers

- You can add thickness only to a layer that is straight from the top of the wall to the bottom. You cannot add thickness to a complex layer, such as the one shown in the following image.

- You cannot split a wall horizontally and then move the outside boundary of one of the regions independently of the other. For example, if you select the left outer boundary of the lower region, the left outer boundary of the upper region is also selected.

- Layer function priorities cannot ascend from the core boundary to the finish face. For example, you cannot have a finish layer in the core boundary and then a structure layer at the exterior side.

**Sweeps and Reveals Tools**

When editing **vertically compound walls**, use the Sweeps and Reveals tools to control placement and display of sweeps or reveals on all walls of that type.

**To add a sweep to the wall type**

1. In the Edit Assembly dialog, click Sweeps.
2. In the Wall Sweeps dialog, click Add.
3. Click in the Profile column, and select a profile from the drop-down.
4. Specify a material for the sweep.
5. For Distance, specify the distance from either the top or base of the wall (select top or base in the From column).
6. For Side, specify the interior or exterior of the wall.
7 Specify a value, if necessary, for Offset. A negative value moves the sweep toward the wall core.

8 Select Flip to measure the distance from the top of the sweep profile rather than the bottom.
9 For Setback, specify the sweep setback distance from inserts, such as windows and doors.
10 Select Cuts Wall if you want the sweep to cut geometry out of the host wall. When a sweep is offset and embedded in the wall, it cuts the geometry from the wall. In complex models with many sweeps, you can increase performance by clearing this option.
11 Select Cuttable if you want the sweep to be cut by wall inserts, as shown.

12 Click OK.

**To add a reveal to the wall type**

1 In the Edit Assembly dialog, click Reveals.
2 In the Reveals dialog, click Add.
3 Select a profile from the list.

**NOTE** There is no material choice for reveals. The material for the reveal is the same as the material it is cutting.

4 For Distance, specify the distance from either the top or base of the wall (select top or base in the From column).
5 For Side, specify the interior or exterior of the wall.
6 Specify a value, if necessary, for Offset.
   A negative value moves the reveal toward the wall core.
7 Select Flip to measure the distance from the top of the reveal profile rather than the bottom.
8 For Setback, specify the reveal setback distance from inserts, such as windows and doors.
9 Click OK.

**Working with Stacked Walls**

Revit Structure includes a Stacked Wall system family for modeling walls that comprise 2 or more subwalls stacked on top of each other. The subwalls can have different wall thicknesses at different heights. All the subwalls in a stacked wall are attached and their geometry is joined.
Only wall types in the Basic Wall system family can function as subwalls. For example, you can have a stacked wall comprising an Exterior Brick on Metal Stud and an Exterior CMU on Metal Stud that are attached and joined.

Using stacked wall types, you can define different wall thicknesses at different heights. You define its structure using Type Properties.

**Defining the Stacked Wall Structure**

You can make various changes to a stacked wall to change its structure:

- You can add or delete walls.
- You can move subwalls up or down the height of the stacked wall.
- You can define a reference line for the entire stacked wall, and then offset each subwall from that reference line.

**IMPORTANT** Define the structure of vertically stacked walls before placing any instances in the project. Height conflicts may occur when previously placed instances are lower than the defined height of the type.

**To define the structure of a stacked wall:**

1. Access the wall’s type properties using one of the following methods:
   For example, in the Project Browser, under Families ➤ Walls ➤ Stacked Wall, right-click a stacked wall type, and click Properties. Alternatively, if you have placed a stacked wall in the project, select it in the drawing area, and on the **Properties palette**, click **Edit Type**.

2. In the Type Properties dialog, click Preview to open the preview pane, which shows a section view of the selected wall type. All changes you make to the wall display in the preview pane.
3 For the Structure parameter, click Edit to open the Edit Assembly dialog. Each row in the Types table defines a subwall within the stacked wall.

4 For Offset, select the plane that will be used to align the subwalls. (This value is used for the Location Line instance property for each subwall.)

5 For Sample Height, specify the height for the wall in the preview pane. This value changes if you insert subwalls whose unconnected height is greater than the sample height.

6 In the Types table, click a number in the left column to select the row defining a subwall, or click Insert to add a new subwall.

7 In the Name column, click the value, and select the desired subwall type.

8 In the Height column, specify an unconnected height for the subwall.

**NOTE** One subwall must have a variable, non-editable height that changes relative to the heights of the other subwalls. To change the height of the variable subwall, change another subwall to variable by selecting its row and clicking Variable.

9 In the Offset column, specify the distance to offset the location line of the subwall from the reference line (Offset) of the main wall. A positive value moves the subwall toward the exterior side (left side in the preview pane) of the main wall.

10 If the subwall is unlocked at the top or bottom, you can enter a positive value in the Top or Base column to specify a distance to raise the subwall, or a negative value to lower it. These values determine the subwall’s Top Extension Distance and Base Extension Distance instance properties respectively.

   For more information on unlocking layers, see Allowing Layer Extension on page 467.

   If you specify an extension distance for a subwall, the subwall below it attaches to it. For example, if you specify a Base value of 2 feet for the top subwall, the top of the next subwall down moves up to attach to the modified wall above it. The value in the Top column for the lower subwall changes to Attach. The top wall shown below (highlighted in red) has a positive base extension distance. The lower subwall attaches to it.

11 To flip the subwall about the reference line (Offset) of the main stacked wall, select Flip.

12 To rearrange rows, select a row and click Up or Down.

13 To delete a subwall type, select its row and click Delete.
If you delete a subwall with an explicit height, the variable subwall extends to the height of the other subwalls. If you delete a variable subwall, the subwall above it becomes variable. If there is only one subwall, you cannot delete it.

14 Click OK.

**Breaking Up a Vertically Stacked Wall**

To independently control subwalls within a stacked wall, right-click it, and click Break Up.

Once a stacked wall is broken up, the subwalls become independent walls. There is no reassemble tool to restack them. The base constraint and base offset of each subwall are the same as for the stacked wall. You can edit instance properties for any of the walls.

**Instance Properties for Subwalls**

When you define/modify the structure of a stacked wall type, you indirectly change instance properties of the individual subwalls that compose the stacked wall. When you specify the height, offset, top, and base of the stacked wall’s subwalls in the Edit Assembly dialog, you are also specifying the corresponding instance properties of the subwalls: Unconnected Height, Location Line Offset, Top Extension Distance, and Base Extension Distance, respectively. The only instance properties you can directly specify for subwalls are Room Bounding and Structural Usage. The remaining properties are inherited from the stacked wall type and are read-only.

**To access the instance properties of a subwall within a stacked wall**

1. Select the stacked wall in a section or elevation view.
2. Press Tab as many times as needed to highlight the subwall.
3. When the desired subwall is highlighted, click to display its instance properties on the Properties palette.

**Vertically Stacked Wall Notes**

When using vertically stacked walls, consider the following guidelines:

- All subwalls use the same base constraint and base offset as the stacked wall. This means that a subwall can be on a certain level, but is actually based on the same level as its associated stacked wall. For example, if a stacked wall is based on Level 1 but one of its subwalls is on Level 7, the Base Level of that subwall is Level 1.

- You can edit the type properties of a basic wall that is also a subwall. To access the type properties of the basic wall, in the Type Selector, select the basic wall type, and click Element Properties drop-down ▶ Type Properties.

- When you create a wall schedule, the vertically stacked wall does not schedule, but its subwalls do.

- When you edit the elevation profile of a stacked wall, you edit one main profile. If you break up the stacked wall, each subwall retains its edited profile.

- When you highlight a vertically stacked wall in the drawing area, the entire wall highlights first. Press Tab as needed to highlight individual subwalls. Using a pick box selects only the stacked wall.

- You can embed a vertically stacked wall in another wall or a curtain panel.

- Subwalls can host wall sweeps; stacked walls cannot.
- Subwalls cannot be in different phases, worksets, or design options from that of the stacked wall.

- To place inserts in a vertically stacked wall, you may need to use the Pick Primary Host tool to switch between the vertically stacked wall and one of the walls that compose it. For example, the door panel in the following illustration is outside the upper wall because the main host of the door is the bottom subwall.

![Door panel outside upper wall](image)

To place the door properly, select it, and click Modify | Doors tab ➤ Host panel ➤ Pick Primary Host. Place the cursor on the wall, and select one of the component walls. You may need to press Tab to select the desired wall.

![Door panel properly placed](image)

**Wall Sweeps**

This section describes using the Wall Sweep tool to add a baseboard, crown molding, or other type of decorative horizontal or vertical projection to a wall. You can add a wall sweep to a wall from a 3D or elevation view. To add a sweep for all walls of a type, you modify the wall structure in the wall’s type properties. See Sweeps and Reveals Tools on page 471.
You can schedule wall sweeps. Integral wall sweeps, which are part of the wall type definition, cannot be scheduled independently. For more information on creating schedules, see Schedule Overview on page 771.

NOTE If you create wall sweeps at different heights and then later set them to the same height, the sweeps miter at the joins.

Adding Wall Sweeps

1. Open a 3D or elevation view containing the wall to which you want to add the sweep.

2. Click Home tab ➤ Structure panel ➤ Wall drop-down ➤ Wall Sweep.

3. In the Type Selector on page 35 at the top of the Properties palette, select the desired type of wall sweep.

4. Click Modify | Place Wall Sweep ➤ Placement panel, and select the orientation of the wall sweep: Horizontal or Vertical.

5. Place the cursor over the wall to highlight the wall sweep location. Click to place the wall sweep.

6. Add the wall sweep to adjacent walls, if needed.

   Revit Structure preselects the wall sweep location on each adjacent wall.

   If you are in a 3D view, you can add a wall sweep to all exterior walls by using the ViewCube to rotate the view. For more information, see ViewCube on page 819.

7. To start a wall sweep in a different location, click Modify | Place Wall Sweep tab ➤ Placement panel ➤ Wall Sweep Restart. Move the cursor to the desired location on the wall, and click to place the wall sweep.

8. To finish placing wall sweeps, click Modify.
Changing the Wall Sweep Profile

Use this procedure to change the profile of an existing wall sweep or of one you are about to place.

1 Select a wall sweep in a 3D or elevation view, or click Home tab ➤ Structure panel ➤ Wall drop-down ➤ Wall Sweep.

2 On the Properties palette, click Edit Type, or click Modify | Place Sweep tab ➤ Properties panel ➤ Type Properties.

3 In the Type Properties dialog, for Profile, select the desired profile type.

4 Click OK.

Returning Wall Sweeps Back to the Wall

After placing a wall sweep, you can return its ends back toward the wall.

NOTE This procedure is also available for wall reveals.

1 In a 3D or elevation view, select the wall sweep segment. Be sure it is not already joined to another segment.

2 Click Modify | Wall Sweeps tab ➤ Wall Sweep panel ➤ Modify Returns. The Straight Cut and Return options display on the Options Bar. The Straight Cut is a perfectly squared off edge. This option is not available if the sweep end is already in this state.

3 Select Return, and enter a value for Angle.
NOTE A positive return angle moves the sweep end toward the wall. A negative value moves the sweep end away from the wall. For reveals, a positive return value moves the reveal end away from the wall, and a negative value moves the end toward the wall.

4 Highlight the wall sweep end.

Highlighted wall sweep end

5 Click to apply the new return value.

Applied return value

In this example, the option Straight Cut becomes available. Select that option, and click the sweep end to apply a straight cut to the sweep.

After you change the return, you can drag the end of the sweep or reveal to extend the return. Select the wall sweep, and use the blue dot drag control.

Drag the right blue control

Changing the Wall Sweep Type

1 In the drawing area, select a wall sweep.

2 In the Type Selector on page 35 at the top of the Properties palette, select the desired wall sweep type.

Adding or Removing Segments from a Wall Sweep

You can continue an existing sweep onto new walls, or remove segments from existing wall sweeps.

1 Open a 3D view and select the desired wall sweep.

2 Click Modify | Wall Sweeps tab ➤ Wall Sweep panel ➤ Add/Remove Walls.

3 Select the walls to continue adding to or removing from the wall sweep.
Resizing Unconnected Wall Sweeps

1. In a 3D or elevation view, select the wall sweep.
2. Drag the wall sweep end to resize it.

Dimensioning to a Wall Sweep

1. Place a dimension between the wall sweep end face reference and another reference.
   Dimension references between wall sweep end face and wall
2. To change the dimension value, drag the wall sweep’s shape handle.
   The dimension value adjusts accordingly.
   Selected shape handle on sweep

Changing a Wall Sweep’s Horizontal or Vertical Offset

To move a single wall sweep segment
1. Select the segment.
2. Move it up or down (horizontal wall sweeps) or side to side (vertical wall sweeps).

To move a multi-segmented wall sweep
1. Place the cursor over the wall sweep and press \textit{TAB} to select the shape handle of the wall sweep.
   Watch the status bar to know when you are highlighting the shape handle.
2. Click to select the shape handle.
3. Move the wall sweep up or down (horizontal wall sweeps) or side to side (vertical wall sweeps).
   This affects the offset of all segments of the wall sweep, so the segments are symmetrical.
**Wall Sweep Type Properties**

To modify a type property of a wall sweep, you change the value of the corresponding parameter as described under Modifying Type Properties on page 38.

**NOTE** Changing a wall sweep type property will affect all wall sweeps of that type in the project. Note also that the type name does not update when you change type parameter values. For example, you could use the type parameter Structure to change the width of the Generic - 6” wall type to 6.5”, but the type name will remain Generic - 6”. If you want to create a new wall sweep type, click Duplicate. For more information, see Creating a New Family Type in a Project on page 38.

Common type properties for wall sweeps are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Cuts Wall</td>
<td>Specifies whether the sweep will cut geometry out of the host wall if there is an overlap. Clearing this parameter can increase performance on large building models with many sweeps.</td>
</tr>
<tr>
<td>Cut by Inserts</td>
<td>Specifies whether inserts such as doors and windows cut geometry out of the sweep. See Sweeps and Reveals Tools on page 471.</td>
</tr>
<tr>
<td>Default Setback</td>
<td>This value specifies the distance the sweep is set back from each intersecting wall insert.</td>
</tr>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Profile</td>
<td>Specifies the profile family used to create the wall sweep.</td>
</tr>
<tr>
<td>Materials and Finishes</td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>Sets the material of the wall sweep.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Subcategory of Walls</td>
<td>By default, wall sweeps are set to the Wall Sweep subcategory of walls. In the Object Styles dialog, you can create new Wall subcategories and subsequently select one here. This allows you to modify wall sweep style at a project level using the Object Styles dialog.</td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the wall sweep keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The model type of the wall sweep.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The manufacturer for the wall sweep’s materials</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Specific building or design comments.</td>
</tr>
<tr>
<td>URL</td>
<td>Link to a web page (such as a manufacturer’s web page).</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the wall sweep.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the assembly based on the assembly code selection.</td>
</tr>
</tbody>
</table>
### Uniformat Assembly Code

**Name:** Uniformat assembly code selected from a hierarchical list.

**Description:**

A value to designate the particular wall sweep. This value must be unique for each wall sweep in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See **Reviewing Warning Messages** on page 1680.

**Cost**

Cost of the materials for constructing the wall sweep. This information can be included in a schedule.

---

### Wall Sweep Instance Properties

To modify an instance property of a wall sweep, you change the value of the corresponding parameter, as described under **Modifying Instance Properties** on page 36.

Common instance properties for wall sweeps are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Offset From Wall</td>
<td>The distance from the wall face.</td>
</tr>
<tr>
<td>Level</td>
<td>The level of the wall sweep. This property only appears for horizontal wall sweeps.</td>
</tr>
<tr>
<td>Offset From Level</td>
<td>The wall sweep's offset from the level. This property only appears for horizontal wall sweeps.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Dimensions</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Length</td>
<td>The length of the wall sweep. This is a read-only parameter.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Identity Data</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Comments</td>
<td>Enter comments for the wall sweep.</td>
</tr>
<tr>
<td>Mark</td>
<td>A value to designate the particular wall sweep. This value must be unique for each wall sweep in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See <strong>Reviewing Warning Messages</strong> on page 1680.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Phasing</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase Created</td>
<td>The phase when the wall sweep was created.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>The phase when the wall sweep was demolished.</td>
</tr>
</tbody>
</table>

### Wall Reveals

This section describes using the Reveal tool to add a decorative horizontal or vertical cutout to a wall in an elevation or 3D view. To add a reveal for all walls of a type, you modify the wall structure in the wall’s type properties. See **Sweeps and Reveals Tools** on page 471.
Adding a Wall Reveal

1 Open a 3D or non-parallel elevation view.

2 Click Home tab ➤ Structure panel ➤ Wall drop-down ➤ Reveal.

3 In the Type Selector on page 35 at the top of the Properties palette, select the desired type of wall reveal.

4 Click Modify | Place Wall Reveal ➤ Placement panel, and select the orientation of the wall reveal: Horizontal or Vertical.

5 Place the cursor over the wall to highlight the wall reveal location. Click to place the reveal.

6 Add the reveal to adjacent walls if needed.
   Revit Structure preselects the reveal location on each adjacent wall.

7 To finish placing wall reveals, click in the view away from the wall.

Related topics
- Changing the Wall Reveal Profile on page 484
- Moving Wall Reveals Away from or Towards the Wall on page 484
- Changing the Wall Reveal Type on page 484
Adding or Removing Segments from a Wall Reveal

You can continue an existing reveal onto new walls, or remove segments from a reveal.

1. Open a view that displays the reveal, and select the reveal.
2. Click Modify | Reveals tab ➤ Reveal panel ➤ Add/Remove Walls.
3. Select the walls to continue adding to or removing from the reveal.
4. Click Modify to exit the tool.

Changing the Wall Reveal Profile

Use this procedure to change the profile of an existing wall reveal or of one you are about to place.

1. Select a wall reveal in a 3D or elevation view, or click Home tab ➤ Structure panel ➤ Wall drop-down ➤ Reveal.
2. On the Properties palette, click Edit Type, or click Modify | Place Reveal tab ➤ Properties panel ➤ Type Properties.
3. In the Type Properties dialog, for Profile, select the desired profile type.
4. Click OK.

Moving Wall Reveals Away from or Towards the Wall

After placing a wall reveal, you can move its ends away from or toward the wall. The procedure is the same as moving wall sweeps back to the wall. See Returning Wall Sweeps Back to the Wall on page 478.

Changing the Wall Reveal Type

1. In the drawing area, select a wall reveal.
2. In the Type Selector on page 35 at the top of the Properties palette, select the desired wall reveal type.

Wall Reveal Type Properties

To modify a type property of a wall reveal, you change the value of the corresponding parameter as described under Modifying Type Properties on page 38.

NOTE Changing a wall reveal type property will affect all wall reveals of that type in the project. Note also that the type name does not update when you change type parameter values. For example, you could use the type parameter Structure to change the width of the Generic - 6" wall type to 6.5", but the type name will remain Generic - 6". If you want to create a new wall reveal type, click Duplicate. For more information, see Creating a New Family Type in a Project on page 38.
Common type properties for wall reveals are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Default Setback</td>
<td>A length value whose default is 0.0. When set to positive or negative values, the ends of the wall reveal curve pull back or push forward by the designated amount when they are interrupted at an insert. This allows you to quickly set wall reveals properly near window or door trims. This value is overwritten when you pull the ends manually.</td>
</tr>
</tbody>
</table>

**Construction**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profile</td>
<td>The profile family used to create the reveal.</td>
</tr>
</tbody>
</table>

**Wall Reveal Instance Properties**

To modify an instance property of a wall reveal, you change the value of the corresponding parameter, as described under Modifying Instance Properties on page 36.

Common instance properties for wall reveals are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Offset from wall</td>
<td>The distance from the wall face. This setting changes the depth of the reveal.</td>
</tr>
<tr>
<td>Level</td>
<td>The reveal’s level. This property only appears with horizontal reveals.</td>
</tr>
<tr>
<td>Offset from level</td>
<td>The reveal’s offset from the level. This property only appears with horizontal reveals.</td>
</tr>
</tbody>
</table>

**Dimensions**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Length</td>
<td>The length of the reveal.</td>
</tr>
</tbody>
</table>

**Wall Best Practices**

This section includes tips with working with Revit in the most efficient way.


**Tips for Adding Walls**

- When creating the exterior walls of a multi-level building to which you want to add windows before adding the roof, specify Unconnected Height as the height of the wall on the next level. This ensures that the wall is high enough to add windows and doors.

- To flip the orientation of the wall between exterior and interior, select the wall and click the blue flip controls that are displayed near it. The flip controls always are displayed on the side that Revit Structure interprets as the exterior side.
Walls do not automatically attach to other modelling components, such as roofs and ceilings. You must explicitly attach them using the Attach and Detach tools. See Attaching Walls to Other Elements on page 453.

As you draw a wall, you can offset it from the cursor by specifying a value for Offset on the Options Bar. You can specify to which location line the offset is measured.

You can access wall type properties from the Project Browser. In the Project Browser, expand Families, expand Walls, expand a wall family, and right-click wall type. Click Properties to access the Type Properties dialog, where you can modify wall properties.

If you rename or create a wall type, indicate the function in the name and specify the Function Type property (interior, exterior, foundation, retaining, soffit, or core-shaft) in the Type Properties dialog.

The top constraint for interior partition walls is set, by default, to the level above.

You can drag inserts, such as windows and doors, between 2 walls.

![Window placed at a join between 2 walls](image)

When an insert is placed between hosts of unequal thickness (as shown above), you can resize the thickness of the insert relative to its hosts. Select the insert and click Pick Primary Host. Select the host you want the insert to resize to match. The insert resizes to the selected host’s thickness. If you later delete the host, you delete the insert as well.

If you select Radius on the Options Bar, and then join the end of a straight wall to the end of another straight wall, a fillet is created between the walls at the specified radius.

**Tips for Defining Wall Shapes or Openings**

If you are defining a shape on a wall that is not horizontal or vertical in a plan view, you should draw a section parallel to the wall before going into the elevation sketch mode. When you go into sketch mode, the Go To View dialog appears. Revit Structure suggests the section view as the optimal view for editing the sketch. Click Open View to open that view.

You cannot edit the elevation profile of an arc wall.

While you edit the elevation profile of a wall that is attached to another element, the wall temporarily reverts to its original shape and height. For example, if you edit the profile of a wall attached to a roof, the wall assumes its unconnected height prior to attaching to the roof. As a result, you may find the wall is not at the right height to complete the elevation profile edits. To change the height, while in sketch mode, change the value of the Unconnected Height parameter on the Properties palette. As you edit the elevation profile, keep in mind that after you finish the sketch, the wall top or bottom attaches only where horizontal lines are coincident with the reference planes in the sketch.
Sample edited profile in sketch mode (note top sketch lines that are coincident with reference planes)

Finished wall attached to roof (non-coincidental horizontal lines from sketch did not attach)

Tips for Models and Files

■ Avoid over-modeling or over-constraining your model (and walls) to keep the size smaller and less complicated.
■ Be judicious in showing wall layer information in views, and minimize the level of detail whenever possible.

Wall Type Properties

To modify a type property of a wall, you change the value of the corresponding parameter as described under Modifying Type Properties on page 38.

NOTE Changing a wall type property will affect all walls of that type in the project. Note also that the type name does not update when you change type parameter values. For example, you could use the type parameter Structure to change the width of the Generic - 6” wall type to 6.5”, but the type name will remain Generic - 6”. If you want to create a new wall type, click Duplicate. For more information, see Creating a New Family Type in a Project on page 38.

Common type properties for walls are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Structure</td>
<td>Click Edit to create compound walls. See Compound Structure on page 573.</td>
</tr>
<tr>
<td>Wrapping at Inserts</td>
<td>Sets the layer wrapping of walls at inserts. See Layer Wrapping on page 576.</td>
</tr>
<tr>
<td>Wrapping at Ends</td>
<td>Sets the layer wrapping of wall end caps. See Setting Layer Wrapping on page 576.</td>
</tr>
<tr>
<td>Width</td>
<td>Sets the width of the wall.</td>
</tr>
</tbody>
</table>
**Name** | **Description**
---|---
Function | Categorizes the wall as Exterior, Interior, Retaining, Foundation, Soffit, or Core-shaft. The value should be set to Soffit when the wall is attached to a ceiling. In this case, the attachment is made to the surface of the ceiling, regardless of the shape of the ceiling. Function can also be used in scheduling and to create filters that simplify a model when exporting.

**Graphics**

Coarse Scale Fill Pattern | Sets a fill pattern for a wall in a coarse-scale view. See View Properties on page 873.
---|---
Coarse Scale Fill Color | Applies a color to the fill pattern for a wall in a coarse-scale view.

**Identity Data**

Model | Generally, this is not an applicable property for walls.
---|---
Manufacturer | Generally, this is not an applicable property for walls.
Type Comments | A field for placing general comments about the wall type.
URL | Link to a web page.
Description | Description of the wall.
Assembly Description | Description of the assembly based on the assembly code selection.
Assembly Code | Uniformat assembly code selected from hierarchical list.
Type Mark | A value to designate the particular wall. Generally, this is not an applicable property for walls. This value must be unique for each wall in a project. Revit Structure warns you if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.
Fire Rating | Fire rating of the wall.
Cost | Cost of the materials for constructing the wall.

**Wall Instance Properties**

To modify an instance property of a wall, you change the value of the corresponding parameter, as described under Modifying Instance Properties on page 36.

Common instance properties for walls are described below.

**Name** | **Description**
---|---
Constraints

**Location Line** | A location line for the wall at the specified plane. The wall location line remains the same for that wall, even if the type changes.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location Line Offset (for walls used as panels only)</td>
<td>Offsets the wall panel the specified distance and in a direction perpendicular to the face of the curtain wall.</td>
</tr>
<tr>
<td>Base Constraint</td>
<td>The base level of the wall. For example, Level 1.</td>
</tr>
<tr>
<td>Base Offset</td>
<td>The wall’s height from its base constraint. This property is available only when the Base Constraint is set to a level.</td>
</tr>
<tr>
<td>Base Is Attached</td>
<td>Indicates whether the base of the wall is attached to another model component, such as a floor (read-only).</td>
</tr>
<tr>
<td>Base Extension Distance</td>
<td>The distance you have moved the base of the layers in a wall. See Compound Structure on page 573. This parameter is enabled when layers of a wall are extendable.</td>
</tr>
<tr>
<td>Top Constraint</td>
<td>Wall height extends to value specified in Unconnected Height.</td>
</tr>
<tr>
<td>Unconnected Height</td>
<td>The height of the wall when it is sketched.</td>
</tr>
<tr>
<td>Top Offset</td>
<td>The offset of the wall from the top level. This parameter is enabled only when the Top Constraint is set to a level.</td>
</tr>
<tr>
<td>Top is Attached</td>
<td>Indicates whether the wall top is attached to another model component, such as a roof or ceiling (read-only).</td>
</tr>
<tr>
<td>Top Extension Distance</td>
<td>The distance you have moved the top of the layers in a wall. See Compound Structure on page 573. This parameter is enabled when layers of a wall are extendable.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>If selected, the wall is part of a room boundary. If cleared, the wall is not part of a room boundary. This property is read-only before creating a wall. After you draw the wall, you can select it and then modify this property.</td>
</tr>
<tr>
<td>Related to Mass</td>
<td>Indicates that the element was created from a mass element. This is a read-only value.</td>
</tr>
<tr>
<td>Structural</td>
<td>The structural usage of the wall. This property is read-only before creating a wall. After you draw the wall, you can select it and then modify this property.</td>
</tr>
<tr>
<td>Dimensions</td>
<td>The length of the wall (read-only).</td>
</tr>
<tr>
<td>Length</td>
<td>The area of the wall (read-only).</td>
</tr>
<tr>
<td>Area</td>
<td>The volume of the wall (read-only).</td>
</tr>
<tr>
<td>Volume</td>
<td></td>
</tr>
<tr>
<td>Identity Data</td>
<td>Specific comments added to describe the wall.</td>
</tr>
<tr>
<td>Comments</td>
<td>A label applied to a wall. Usually a numeric value. This value must be unique for each wall in a project. Revit Structure warns you if the number is already used but</td>
</tr>
</tbody>
</table>
Troubleshooting Walls

Slow Performance

In Revit 2010, multi-threaded methods for printing and wall join cleanup have been made available. Multi-threaded hidden line removal for printing has been enabled by default.

- Due to the operating system overhead of maintaining multiple threads, multiprocessing of wall join cleanups can experience a minor degradation when only 2 CPU cores are present, but up to a 27% performance increase when 4 hyper-threaded CPU cores are present. Because 2 CPU core systems remain the most common configuration of Revit systems as reported by CIP data, multiprocessing of this features is OFF by default.

- To enable multiprocessing for wall join cleanup, add the following entries to the Revit.ini file:
  
  [PerformanceOptimizations] ParallelWallJoins=ON

- To disable multiprocessing for wall join cleanup, you may omit any entries in the [PerformanceOptimizations] section of the Revit.ini file, or explicitly set the state of either one or both multiprocessing optimizations:
  
  [PerformanceOptimizations] ParallelWallJoins=OFF
  ParallelPrintProcessing=OFF

Avoid File Corruption

After creating walls, audit files so Revit will review data structures and correct problems found within the model.
Doors

In Revit Structure, doors are hosted components that you can add to any type of wall. Doors can be added in plan, section, elevation, or 3D views. You select the type of door to add, and then specify its location on the wall. Revit Structure automatically cuts the opening and places the door.
Placing Doors

1 Open a plan, section, elevation, or 3D view.

2 Click Architect & Site tab ➤ Architect panel ➤ Door.

3 If you want to place a door type other than the one displayed in the Type Selector on page 35 at the top of the Properties palette, select a different type from the drop-down.

**NOTE** To load additional door types from the Revit library, click Place Door tab ➤ Model panel ➤ Load Family, navigate to the Doors folder, and open the desired family file. You can also download door families from the Autodesk® Seek website (http://seek.autodesk.com).

4 If you want to tag doors automatically as you place them, click Modify | Place Door tab ➤ Tag panel ➤ Tag on Placement. Then specify the following tagging options on the Options Bar:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the orientation of the tag</td>
<td>select Horizontal or Vertical.</td>
</tr>
<tr>
<td>load additional tags</td>
<td>click Tags (see Loading Tag Styles on page 1612).</td>
</tr>
<tr>
<td>include a leader line between the tag and the door</td>
<td>select Leader.</td>
</tr>
<tr>
<td>change the default length of the leader</td>
<td>enter a value in the text box to the right of the Leader check box.</td>
</tr>
</tbody>
</table>

5 Move the cursor over a wall to display a preview image of the door.

When placing the door in plan view, press the Spacebar to flip the door hand from left to right. To flip the door facing (make it swing in or out), move the cursor closer to the inner or outer wall edge.

By default, the temporary dimensions indicate the distances from the door centerline to the centerlines of the nearest perpendicular walls. To change these settings, see Temporary Dimension Settings on page 1618.

6 When the preview image is at the desired location on the wall, click to place the door.

Related topics

- Adding Doors to Curtain Walls on page 493
- Door Tags on page 493
- Changing the Door Type on page 494
- Changing the Door Orientation on page 494
- Moving a Door to a Different Wall on page 494
- Door Instance Properties on page 495
- Door Type Properties on page 496
Adding Doors to Curtain Walls

In Revit Structure, you add a door to a curtain wall by customizing a curtain panel so that it schedules as a door.

1. Open a plan, elevation, or 3D view of the curtain wall.
2. Move the cursor over an edge of the curtain panel to be customized until one of its mullions or the curtain wall highlights.
3. Press Tab until the panel highlights, and then click to select it and display the pin icon.
4. Click the pin icon to unpin the panel.
5. In the Type Selector on page 35 at the top of the Properties palette, select a curtain wall door to replace the panel. Only curtain wall doors can replace a curtain wall panel.
   If necessary, you can load a curtain wall door by clicking Insert tab ➤ Load from Library panel ➤ Load Family. In the Load Family dialog, open the Doors folder, select any door family with curtain wall in its name, and click Open to load the family into the project.
6. Highlight the mullion under the door, and click to display its pin icon.
7. Click the pin icon to unpin the mullion, and then press Delete.
   To delete a curtain wall door, select it and change it back to a curtain wall panel using the Type Selector.

Curtain wall door

Door Tags

Door tags are annotations that are generally used to enumerate instances of doors within a project by displaying the value of the door’s Mark property. This value is equal to 1 for the first door you place, and it increases by 1 for each subsequent door, regardless of type. You can specify that the tags are attached automatically as you place the doors (see Placing Doors on page 492) or you can attach them later, either individually (see Applying a Tag By Category on page 945) or all at once (see Tag All Not Tagged on page 947).
A door tag does not display if any part of the tagged door is outside the annotation crop region. For more information, see Crop Regions on page 849.

To delete a door tag, select the tag in the drawing area, and press Delete.

**Changing the Door Type**
1. In the drawing area, select the door.
2. In the Type Selector on page 35 at the top of the Properties palette, select a different type from the drop-down.

**Changing the Door Orientation**
Use the following procedure to change a door’s hinge side (hand) or swing (facing).
1. In a plan view, select the door.
2. Right-click, and click the desired option:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then select…</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the side (right or left) on which the door is hinged</td>
<td>Flip Hand. This option is available only for door families created with horizontal controls.</td>
</tr>
<tr>
<td>change the direction (in or out) in which the door swings</td>
<td>Flip Facing. This option is available only for door families created with vertical controls.</td>
</tr>
</tbody>
</table>

Alternatively, you can click either of the corresponding flip controls (Flip the instance hand or Flip the instance facing) that display in the drawing when a door is selected.

**Moving a Door to a Different Wall**
Note that the following procedure does not apply to curtain wall doors, which are created by customizing curtain wall panels. For more information, see Adding Doors to Curtain Walls on page 493.
1. Select the door.
2. Click Modify | Doors tab ➤ Host panel ➤ Pick New Host.
3. Move the cursor over another wall, and when the preview image is in the desired location, click to place the door.
Door Instance Properties

To modify an instance property of a door, you change the value of the corresponding parameter, as described under Modifying Instance Properties on page 36.

Common instance properties for doors are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Level</td>
<td>Indicates the level on which this instance is placed.</td>
</tr>
<tr>
<td>Sill Height</td>
<td>Specifies the height of the sill in relation to the level on which this</td>
</tr>
<tr>
<td></td>
<td>instance is placed. Changing this value does not change the instance size.</td>
</tr>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Frame Type</td>
<td>Specifies the type of frame around the door.</td>
</tr>
<tr>
<td></td>
<td>You can enter a value or select a previously entered value from the drop-down list.</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td>Frame Material</td>
<td>Specifies the material used for the frame.</td>
</tr>
<tr>
<td></td>
<td>You can enter a value or select a previously entered value from the drop-down list.</td>
</tr>
<tr>
<td>Finish</td>
<td>Specifies the finish applied to the frame and door.</td>
</tr>
<tr>
<td></td>
<td>You can enter a value or select a previously entered value from the drop-down list.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>Displays a comment that you enter or select from the drop-down list.</td>
</tr>
<tr>
<td></td>
<td>Once entered, a comment can be selected for other instances of elements in the same category, regardless of type or family.</td>
</tr>
<tr>
<td>Mark</td>
<td>Identifies or enumerates a particular instance as specified by the user.</td>
</tr>
<tr>
<td></td>
<td>For doors, this property enumerates instances within a category by increasing the value by 1 for each instance placed. For example, the first door you place in a project will have a Mark value of 1 by default. The next door you place, regardless of type, will have a Mark value of 2. If you change this value to one that is already used by another door, Revit Structure warns you, but allows you to continue using it. The Mark property of the next door you place will then be assigned the next highest unused number.</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Specifies the phase when this instance was created.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Specifies the phase when this instance was demolished.</td>
</tr>
<tr>
<td><strong>Other</strong></td>
<td></td>
</tr>
<tr>
<td>Head Height</td>
<td>Specifies the height of the top of the instance in relation to the level on which the instance is placed. Changing this value does not change the instance size.</td>
</tr>
</tbody>
</table>
Door Type Properties

To modify a type property of a door, you change the value of the corresponding parameter as described under Modifying Type Properties on page 38.

**NOTE** Changing a door type property will affect all doors of that type in the project. Note also that the type name does not update when you change type parameter values. For example, you could use the type parameter Structure to change the width of the Generic - 6” wall type to 6.5”, but the type name will remain Generic - 6”. If you want to create a new door type, click Duplicate. For more information, see Creating a New Family Type in a Project on page 38.

Common type properties for doors are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Wall Closure</td>
<td>The layer wrapping around the door. It overrides any settings in the host.</td>
</tr>
<tr>
<td>Construction Type</td>
<td>The type of construction for the door.</td>
</tr>
<tr>
<td>Function</td>
<td>Indicates whether a door is interior (default value) or exterior. Function is used in scheduling and to create filters to simplify a model when exporting.</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td>Door Material</td>
<td>The material for the door (for example, metal or wood)</td>
</tr>
<tr>
<td>Frame Material</td>
<td>The material for the door frame.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Thickness</td>
<td>The thickness of the door.</td>
</tr>
<tr>
<td>Height</td>
<td>The height of the door.</td>
</tr>
<tr>
<td>Trim Projection Ext</td>
<td>The exterior trim projection.</td>
</tr>
<tr>
<td>Trim Projection Int</td>
<td>The interior trim projection.</td>
</tr>
<tr>
<td>Trim Width</td>
<td>The width of the door trim.</td>
</tr>
<tr>
<td>Width</td>
<td>The width of the door.</td>
</tr>
<tr>
<td>Rough Width</td>
<td>Can be scheduled or exported.</td>
</tr>
<tr>
<td>Rough Height</td>
<td>Can be scheduled or exported.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the door keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The name of the model type of the door.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The name of the door manufacturer.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Comments about the door type. Information can appear in a schedule.</td>
</tr>
<tr>
<td>URL</td>
<td>Sets a link to a manufacturer web page.</td>
</tr>
<tr>
<td>Description</td>
<td>Provides a description for the door.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the assembly based on the assembly code selection.</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from hierarchical list.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value to designate the particular door. This value must be unique for each door in a project. Revit Structure warns you if the number is already used, but allows you to continue using it. (You can see the warning using the Review Warnings tool. See <em>Reviewing Warning Messages</em> on page 1680.) Marks are assigned sequentially. See <em>Creating Sequential Door or Window Tags</em> on page 950.</td>
</tr>
<tr>
<td>Fire Rating</td>
<td>The fire rating of the door.</td>
</tr>
<tr>
<td>Cost</td>
<td>The cost of the door.</td>
</tr>
<tr>
<td>OmniClass Number</td>
<td>The number from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
<tr>
<td>OmniClass Title</td>
<td>The name from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
<tr>
<td>IFC Parameters</td>
<td>The operation of the door, as defined by the current IFC description (for example, single_swing_left or double_door_double_swing). These values are case-insensitive, and underscores are optional. (SINGLE_SWING_LEFT and SingleSwingLeft are the same.)</td>
</tr>
</tbody>
</table>
In Revit Structure, windows are hosted components that you can add to any type of wall (or to an in-place roof, in the case of a skylight). Windows can be added in plan, section, elevation, or 3D views. You select the type of window to add, and then specify its location on the host element. Revit Structure automatically cuts the opening and places the window.

Placing Windows

Use this procedure to add a window to any kind of wall (or to add a skylight to an in-place roof). To add a window to a curtain wall panel, you must first change the panel to a wall (see Wall Panels in Curtain Walls on page 630).

1. Open a plan, elevation, section, or 3D view.

2. Click Architect & Site tab ➤ Architect panel ➤ Window.

3. If you want to place a window type other than the one displayed in the Type Selector on page 35 at the top of the Properties palette, select a different type from the drop-down.
NOTE To load additional window types from the Revit Library, click Modify | Place Window tab ➤ Mode panel ➤ Load Family, navigate to the Windows folder, and open the desired family file. You can also download window families from the Autodesk® Seek website (http://seek.autodesk.com).

4 If you want to tag windows automatically as you place them, click Modify | Place Window tab ➤ Tag panel ➤ Tag on Placement. Then specify the following tagging options on the Options Bar:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the orientation of the tag</td>
<td>select Horizontal or Vertical.</td>
</tr>
<tr>
<td>load additional tags</td>
<td>click Tags (see Loading Tag Styles on page 1612).</td>
</tr>
<tr>
<td>include a leader line between the tag and the window</td>
<td>select Leader.</td>
</tr>
<tr>
<td>change the default length of the leader</td>
<td>enter a value in the text box to the right of the Leader check box.</td>
</tr>
</tbody>
</table>

5 Move the cursor over a wall to display a preview image of the window. By default, the temporary dimensions indicate the distances from the window centerline to the centerlines of nearest perpendicular walls. To change these settings, see Temporary Dimension Settings on page 1618.

6 When the preview image is at the desired location on the wall, click to place the window.

Related Topics
- Changing the Window Type on page 500
- Window Tags on page 500
- Changing the Window Orientation on page 501
- Moving a Window to a Different Wall on page 501
- Window Instance Properties on page 501
- Window Type Properties on page 502

Window Tags
Window tags are annotations that generally identify particular types of windows in a drawing by displaying the value of the window’s Type Mark property. You can specify that window tags are attached automatically as you place windows (see Placing Windows on page 499) or you can attach them later, either individually (see Applying a Tag By Category on page 945) or all at once (see Tag All Not Tagged on page 947).

A window tag does not display if any part of the tagged window is outside the annotation crop region. For more information, see Crop Regions on page 849.

To delete a window tag, select the tag in the drawing area, and press Delete.

Changing the Window Type
1 In the drawing area, select the window.
2 In the **Type Selector** on page 35 at the top of the **Properties palette**, select a different type from the drop-down.

### Changing the Window Orientation

Use the following procedure to change a window’s horizontal orientation (hand) or vertical orientation (facing).

1 In a plan view, select the window.
2 Right-click, and click the desired option:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then select…</th>
</tr>
</thead>
<tbody>
<tr>
<td>flip the window horizontally</td>
<td>Flip Hand. This option is available only for window families created with horizontal controls.</td>
</tr>
<tr>
<td>flip the window vertically</td>
<td>Flip Facing. This option is available only for window families created with vertical controls.</td>
</tr>
</tbody>
</table>

Alternatively, you can click either of the corresponding flip controls (Flip the instance hand or Flip the instance facing) that display in the drawing when a window is selected.

![Window flip controls in plan view and window in 3D view](image)

### Moving a Window to a Different Wall

1 Select the window.

2 Click **Modify | Windows tab ➤ Host panel ➤ Pick New Host.**
3 Move the cursor over another wall, and when the preview image is in the desired location, click to place the window.

### Window Instance Properties

To modify an instance property of a window, you change the value of the corresponding parameter, as described under **Modifying Instance Properties** on page 36.

Common instance properties for walls are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Level</td>
<td>Indicates the level on which this instance is placed.</td>
</tr>
</tbody>
</table>
### Sill Height

Specifies the height of the sill in relation to the level on which this instance is placed. Changing this value does not change the instance size.

### Identity Data

#### Comments
Displays a comment that you enter or select from the drop-down list. Once entered, a comment can be selected for other instances of elements in the same category, regardless of type or family.

#### Mark
Enumerates instances within a category by increasing this value by 1 for each instance placed. For example, the first window you place in a project will have a Mark value of 1 by default. The next window you place, regardless of type, will have a Mark value of 2. If you change this value to one that is already used by another window, Revit Structure warns you, but allows you to continue using it. The Mark property of the next window you place will then be assigned the next highest unused number.

### Phasing

#### Phase Created
Specifies the phase when this instance was created. See Creating Phases on page 878.

#### Phase Demolished
Specifies the phase when this instance was demolished. See Demolishing Elements on page 883.

### Other

#### Head Height
Specifies the height of the top of the instance in relation to the level on which the instance is placed. Changing this value does not change the instance size.

### Window Type Properties

To modify a type property of a window, you change the value of the corresponding parameter as described under Modifying Type Properties on page 38.

**NOTE** Changing a window type property will affect all windows of that type in the project. Note also that the type name does not update when you change type parameter values. For example, you could use the type parameter Structure to change the width of the Generic - 6” wall type to 6.5”, but the type name will remain Generic - 6”. If you want to create a new window type, click Duplicate. For more information, see Creating a New Family Type in a Project on page 38.

Common type properties for windows are described below.

### Name | Description
--- | ---
**Construction**

#### Wall Closure
This parameter sets the layer wrapping around the window. It overrides any settings in the host.

#### Construction Type
The type of construction for the window.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Glass Pane Material</td>
<td>The material for the glass panes in the window.</td>
</tr>
<tr>
<td>Sash Material</td>
<td>The material for the window sash.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>The height of the opening of the window.</td>
</tr>
<tr>
<td>Default Sill Height</td>
<td>The height of the bottom of the window above the level.</td>
</tr>
<tr>
<td>Width</td>
<td>The width of the window.</td>
</tr>
<tr>
<td>Window Inset</td>
<td>The inset of the window into the wall.</td>
</tr>
<tr>
<td>Rough Height</td>
<td>The height of the rough opening for the window. Can be scheduled or exported.</td>
</tr>
<tr>
<td>Rough Width</td>
<td>The width of the rough opening for the window. Can be scheduled or exported.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Assembly code</td>
<td>Uniformat assembly code selected from hierarchical list.</td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the window keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The model number of the window.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The manufacturer of the window.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Specific comments about the window type.</td>
</tr>
<tr>
<td>URL</td>
<td>The link to the manufacturer's web page.</td>
</tr>
<tr>
<td>Description</td>
<td>A specific description of the window type.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the assembly based on the assembly code selection.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A specific value to designate the particular window. This value must be unique for each window in a project. Revit Structure warns you if the number is already used, but allows you to continue using it. (You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.) Values are assigned sequentially. See Creating Sequential Door or Window Tags on page 950.</td>
</tr>
<tr>
<td>Cost</td>
<td>Cost of the window.</td>
</tr>
<tr>
<td>OmniClass Number</td>
<td>The number from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
<tr>
<td>OmniClass Title</td>
<td>The name from Table 23 of the OmniClass Construction Classification System that best categorizes the family type.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Operation</td>
<td>The operation of the window, as defined by the current IFC description (for example, single_panel or triple_panel_horizontal). These values are case-insensitive, and underscores are optional. (SINGLE_PANEL and SinglePanel are the same.)</td>
</tr>
</tbody>
</table>
Components

In Revit Structure, components are used to model building elements that are usually delivered and installed on site, such as doors, windows, furniture, and so on. Components are instances of loadable families and are hosted by other elements, which are instances of system families. (For more information, see Different Kinds of Families on page 678.) For example, a door is hosted by a wall, while a freestanding component such as a desk is hosted by a floor or a level.

Revit Structure comes with many components already defined. To create additional components, you define them using the Family Editor. See The Families Guide on page 680.

This topic describes how to place and move components other than doors and windows, which are placed using different tools (see Doors on page 491 and Windows on page 499).

Related Topics

- Placing Components on page 506
- Moving Components to Different Hosts on page 507
- Moving Lines and Components with Walls on page 1478
Placing Components

Use this procedure to place freestanding components (such as furniture, plumbing fixtures, or plantings) into a project view.

1 Open a project view appropriate for the type of component you want to place. For example, you can place a desk in a plan or 3D view, but not in a section or elevation.

2 Click Home tab ➤ Model panel ➤ Component drop-down ➤ Place a Component.

3 In the Type Selector at the top of the Properties palette, select the desired component type. If the desired component family has not yet been loaded into the project, click Modify | Place Component tab ➤ Mode panel ➤ Load Family. Then navigate to the appropriate category folder in the Load Families dialog, select the family, and click Open to add the family to the Type Selector.

4 If the selected component family has been defined as face-based or work plane-based (see the Note following this procedure), click one of the following options on the Placement panel, which displays on the Modify | Place Component tab:

   ■ **Place on Vertical Face.** This option is only available for some components and allows placement only on vertical faces.

   ![Place on Vertical Face](image1)

   ■ **Place on Face.** This option allows placement on faces regardless of orientation.

   ![Place on Face](image2)

   ■ **Place on Work Plane.** This option requires an active work plane to be defined in the view (see Setting the Work Plane on page 1517). You can place the component anywhere on the work plane.

   ![Place on Work Plane](image3)
5 In the drawing area, move the cursor until the preview image of the component is in the desired location.

6 If you want to change the orientation of the component, press the Spacebar to rotate the preview image through its available positioning options.

7 When the preview image is in the desired location and orientation, click to place the component. After you place a component, you can specify that it moves when a nearby wall moves. See Moving Lines and Components with Walls on page 1478.

NOTE How you can place a component depends on how the component family was originally defined. See The Families Guide on page 680 for information about the different types of family templates.

Moving Components to Different Hosts

You can move a hosted component or element from its current host to another host using the Pick Host tool. The procedure varies slightly according to whether the component is work plane-based or face-based as opposed to level-based. This distinction depends on how the component family was defined. See The Families Guide on page 680 for information about the different types of family templates.

Moving Work Plane-Based or Face-Based Elements and Components to Different Hosts

Use the following procedure to move a work plane-based or face-based component or element to a different work plane or face. Work plane-based elements include lines, beams, and family geometry.

1 In the drawing area, select the work plane-based or face-based element or component.

2 Click Modify | <family category> tab ➤ Work Plane panel ➤ Pick New.

3 On the Placement panel, select one of the following options:

   ▪ **Vertical Face (Place on Vertical Face).** This option is only available for some components and allows placement only on vertical faces.
Face (Place on Face). This option allows placement on faces regardless of orientation.

Work Plane (Place on Work Plane). This option requires an active work plane to be defined in the view (see Setting the Work Plane on page 1517). You can place the component anywhere on the work plane.

4 In the drawing area, move the cursor until the desired new host (face or work plane) is highlighted and the preview image of the component is in the desired location, and then click to complete the move.

Moving Level-Based Components to Different Hosts

Use the following procedure to move a level-based component to a different level, floor, or surface. Examples of level-based components include furniture, plantings, and plumbing fixtures. When you place a level-based component on a host, it remains on the host’s infinite plane. For example, when you place a desk on a floor, and then drag the desk beyond the confines of the floor, the desk remains on the same plane as the floor.

1 In a section or elevation view, select the level-based component.

2 Click Modify | <family category> ➤ Host panel ➤ Pick New Host.

3 In the drawing area, highlight the desired new host (floor, surface, or level), and click to complete the move.
Architectural Columns

This topic describes how to add architectural columns to a project. You can use architectural columns to model column box-outs around structural columns and for decorative applications.

Adding a Column

You can add columns in plan view. The height of the column is defined in the properties of the component. Using the properties, you can define the Base Level and the Top Level, as well as offsets.
1 Click Home tab ➤ Structure panel ➤ Column drop-down ➤ Architectural Column.
2 Click in the drawing area to place the column.

TIP Typically, you align columns when placing them by selecting a grid line or wall. If you randomly placed them and you want to align them, click Modify tab ➤ Modify panel ➤ Align, and select the columns to align.

In the middle of the columns are 2 perpendicular reference planes that you can select for alignment.

Attaching Columns

Columns do not automatically attach to roofs, floors, and ceilings. When you select a column (or multiple columns) you can attach it to roofs, floors, ceilings, reference planes, structural framing members, and other reference levels.

To attach columns

1 In the drawing area, select one or more columns.
2 Click Modify | Columns tab ➤ Modify Column panel ➤ Attach Top/Base.
3 On the Options Bar:
   ■ For Attach Column, select Top or Base to specify which part of the column you are attaching.
   ■ For Attachment Style, select Cut Column, Cut Target, or Do Not Cut. See Cut Column Examples on page 510 and Cut Target Examples on page 513.
   ■ For Attachment Justification, select Minimum Intersection, Intersect Column Midline, or Maximum Intersection. The target (roofs, floors, ceilings) can be cut by the column, the column can be cut by the target, or neither can be cut. After a column is attached to a target, you can edit its properties and reset the values for the Attachment Justification at Top and Offset from Attachment at Top instance parameters.
   ■ Specify Offset from Attachment. Offset from Attachment sets a value to be offset from the target.

NOTE If the column and target are both structural concrete, they will be cleaned instead of cut. If the column is structural and the target is non-structural, a warning message appears.

4 In the drawing area, select the target (for example, roof or floor) you want to attach the column to.

Cut Column Examples

Following are examples of the cut column attachment style with different attachment justifications and offsets from attachment.

■ Attachment Style: Cut Column
  Attachment Justification: Minimum Intersection
Attachment Style: Cut Column
Attachment Justification: Maximum Intersection

Attachment Style: Cut Column
Attachment Justification: Minimum Intersection
Offset from Attachment: 0’ 6”
Level 2
10' - 0"

Level 1
0' - 0"

Attachment Style: Cut Column
Attachment Justification: Intersect Column Midline
Cut Target Examples

Following are examples of the cut target attachment style with different attachment justifications and offsets from attachment.

- Attachment Style: Cut Target
  - Attachment Justification: Minimum Intersection

-Attachment Style: Cut Target
  - Attachment Justification: Maximum Intersection
Attachment Style: Cut Target
Attachment Justification: Minimum Intersection
Offset from Attachment: On
**Detaching Columns**

1. In the drawing area, select the column you want to detach. You can select multiple columns.

2. Click Modify Columns tab ➤ Modify Column panel ➤ Detach Top/Base.

3. Click the target you want to detach the column from.
   If the column is attached to the target by its top and bottom, click Detach All on the Options Bar to detach the top and bottom of the column from the target.

**Coarse-Scale Cut Patterns**

If you join a wall and an architectural column, and the wall has a coarse-scale fill pattern defined, the joined column assumes that pattern. See Wall Type Properties on page 487. This behavior is evident in coarse-scale plan and section views. The section view plane must cut through the joined face of the 2 elements.

Wall and column joined (column assumes the fill pattern of the wall)

---

**NOTE** Structural columns do not assume the walls fill pattern, even when joined.
Modifying Architectural Columns

Changing Column Types

When you activate the Column tool to place columns, you can select different types of columns in the Type Selector on page 35.

Moving a Column

You can move the column by selecting the column and dragging it to the new location.

Architectural Column Type Properties

To modify a type property of an architectural column, you change the value of the corresponding parameter as described under Modifying Type Properties on page 38.

**NOTE** Changing an architectural column type property will affect all architectural columns of that type in the project. Note also that the type name does not update when you change type parameter values. For example, you could use the type parameter Structure to change the width of the Generic - 6” wall type to 6.5”, but the type name will remain Generic - 6”. If you want to create a new architectural column type, click Duplicate. For more information, see Creating a New Family Type in a Project on page 38.

Common type properties for architectural columns are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Coarse Scale Fill Color</td>
<td>Specifies the color of the Coarse Scale Fill Pattern in any coarse plan view.</td>
</tr>
<tr>
<td>Coarse Scale Fill Pattern</td>
<td>Specifies the cut pattern that displays within the column in any coarse plan view.</td>
</tr>
<tr>
<td>Materials and Finishes</td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>The material of the column.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Depth</td>
<td>Sets the depth of columns when placed.</td>
</tr>
<tr>
<td>Offset Base</td>
<td>Sets the offset of the column base.</td>
</tr>
<tr>
<td>Offset Top</td>
<td>Sets the offset of the column top.</td>
</tr>
<tr>
<td>Width</td>
<td>Sets the width of columns when placed.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the column keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
</tbody>
</table>
### Architectural Column Instance Properties

To modify an instance property of an architectural column, you change the value of the corresponding parameter, as described under *Modifying Instance Properties* on page 36.

Common instance properties for architectural columns are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Base Level</td>
<td>Specifies the level on which the base of the column rests. The default is Level 1.</td>
</tr>
<tr>
<td>Base Offset</td>
<td>Specifies distance from the base level. The default is 0.</td>
</tr>
<tr>
<td>Top Level</td>
<td>Specifies the level that the top of the column reaches. The default is 1.</td>
</tr>
<tr>
<td>Top Offset</td>
<td>Specifies distance from the top level. The default is 0.</td>
</tr>
<tr>
<td>Moves With Grids</td>
<td>Columns move when grid lines are moved.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>Determines whether the column is room-bounding.</td>
</tr>
<tr>
<td>Top is Attached</td>
<td>Read-only parameter specifying that the top of the column is attached to a structural floor or roof. See <em>Attaching Columns</em> on page 510.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Attachment Justification At Top</td>
<td>When the column is attached to a surface, sets the top justification for the condition. Choices are: Minimum Intersection, Intersect Column Midline, Maximum Intersection.</td>
</tr>
<tr>
<td>Offset From Attachment At Top</td>
<td>When the column is attached to a surface, specifies an offset value for cut target/column conditions.</td>
</tr>
<tr>
<td>Base is Attached</td>
<td>Read-only parameter specifying that the base of the column is attached to a surface. See Attaching Columns on page 510.</td>
</tr>
<tr>
<td>Attachment Justification At Base</td>
<td>When the column is attached to a surface, sets the base justification for the condition. Choices are: Minimum Intersection, Intersect Column Midline, Maximum Intersection.</td>
</tr>
<tr>
<td>Offset From Attachment At Base</td>
<td>When the column is attached to a surface, specifies an offset value for cut target/column conditions.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments for the column instance.</td>
</tr>
<tr>
<td>Mark</td>
<td>Applies a tag to any column for reference purposes. This value must be unique for each column in a project. Revit Structure warns you if the number is already used but allows you to continue using it. (You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.)</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>The phase when the column was created.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>The phase when the column was demolished.</td>
</tr>
</tbody>
</table>
In Revit Structure, you can create a roof from a building footprint, as an extrusion, or from a mass instance. A roof cannot cut through windows or doors.

**Roofs Overview**

**Adding a roof by footprint**
- 2D closed-loop sketch of the roof perimeter
- Created when you select walls or draw lines in plan view
- Created at level of view in which it was sketched
- Height is controlled by Base Height Offset property
- Openings are defined by additional closed loops
- Slopes are defined when you apply a slope parameter to sketch lines
Roof by footprint

Adding a roof by extrusion

■ Open-loop sketch of the roof profile
■ Created when you use lines and arcs to sketch the profile in an elevation view
■ Height is controlled by the location of the sketch in elevation view
■ Depth is calculated by Revit Structure based on size of sketch, unless you specify start and end points.

It is helpful to use reference planes when sketching the profile of an extruded roof. For example, sketch 3 vertical reference planes parallel to one another, and then sketch a horizontal reference plane that intersects all 3 vertical planes.

Roof by extrusion

The Roof by Extrusion tool lets you create a roof with simple slopes. To create a roof with complex slopes, you can use massing.

After you create a roof by extrusion, you can rehost the roof or edit the work plane of the roof.

Adding sloped glazing

You can create sloped glazing using the footprint or extrusion method. Sloped glazing has one or more slope-defining lines and can join to curtain walls and basic wall types.
Creating a Roof

Add a roof using one of the following methods:

**Sketch a roof by footprint**

1. Display a floor plan view or a reflected ceiling plan view.

2. Click Architect & Site tab ➤ Architect panel ➤ Roof drop-down ➤ (Roof by Footprint).

**NOTE** If you try to add a roof on the lowest level, a dialog prompts you to move it to a higher level. If you choose not to move the roof to a different level, Revit Structure notifies you later if the roof is too low.

3. On the Draw panel, select a sketch or pick tool.
   To edit roof properties before sketching, use the Properties palette.

   **TIP** When using Pick Walls, you can specify the overhang before you sketch the roof. On the Options Bar, select Extend to wall core if you want the overhang to be measured from the core of the wall, and then specify a value for Overhang.

4. Sketch, or pick, a closed loop for the roof.

5. Specify slope defining lines.
   To change the slope definition of a line, select the line and, on the Properties palette, click Defines Roof Slope. You can then change the slope value.

   When a roof line is set to slope defining, this symbol appears adjacent to it.

6. Click (Finish Edit Mode), and then open a 3D view.

   *Completed gable roof with overhang*
Sketch a roof by extrusion

1. Display an elevation, 3D, or section view.

2. Click Architect & Site tab ➤ Architect panel ➤ Roof drop-down ➤ (Roof by Extrusion).

3. Specify the work plane.

4. In the Roof Reference Level and Offset dialog, select a value for Level. The highest level in the project is selected by default.

5. To raise or lower the roof from the reference level, specify a value for Offset. Revit Structure places a reference plane at the specified offset. Using the reference plane, you can control the position of the extruded roof in relation to a level.

6. Sketch the profile of the roof as an open loop.

   Roof profile sketched using spline tool

7. Click (Finish Edit Mode), and then open a 3D view.

   Completed extruded roof

Attach walls to the roof, if desired.

After you create a roof by extrusion, you can rehost the roof or edit the work plane of the roof.
Sketch sloped glazing

1 Click Architect & Site tab ➤ Architect panel ➤ Roof drop-down ➤ (Roof by Footprint) or (Roof by Extrusion).

**NOTE** If you try to create a roof on the lowest level, a dialog prompts you to move it to a different level, ensuring that the roof is higher than any walls joining to it. If you choose not to move the roof to a different level, Revit Structure notifies you later if the roof is too low.

2 Sketch the roof.

3 If the roof is based on a footprint, specify roof boundary lines as slope-defining, or use the roof slope arrow to define the slope.

4 Click (Finish Edit Mode).

5 Select the roof, and in the Type Selector, select Sloped Glazing.
   You can place curtain grids on the curtain panels of the sloped glazing. Press Tab to switch between horizontal and vertical grids.

![Sloped glazing with mullions and grid lines](image)

Add a roof to another roof

1 To cut off a roof in order to sketch another roof on top of it, select the roof in the drawing area.

2 On the Properties palette, specify a Cutoff Level, and then specify a height for Cutoff Offset. This property specifies the distance above or below the level at which the roof is cut off.

3 Sketch the new roof on top of the existing roof.

Create a conical roof

If a roof includes a slope-defining arc line, you can specify the number of segments for the line.

1 In the drawing area, select the arc line.

2 On the Properties palette, specify a value for Number of Full Segments. By default, 4 segments are created. If you specify zero segments, a conical roof is created.

Start and End Points for Extruded Roofs

The extrusion of a roof can extend in either a positive or a negative direction along the plane perpendicular to the face of a solid component (such as a wall), as shown.
You can edit the start and end points using the roof properties.

Modifying Roofs

After completing a roof, you can modify its physical structure, change its properties, or join it with another roof.

Edit the roof sketch

1. In the drawing area, select the roof.
2. Depending on how the roof was created, click Modify | Roofs tab ➤ Mode panel ➤ (Edit Footprint) or (Edit Profile).
3. Make necessary changes. If you want to change the position of the roof, use the Properties palette to edit the Base Level and Offset properties to change the position of the reference plane. If you’re warned that the roof geometry cannot move, edit the roof sketch, and check for constraints on the sketch, such as between a level line and a sketch line of the roof.
4. Click (Finish Edit Mode).

Change the roof type

Use one of the following methods to change the roof type:

In sketch mode

1. On the Properties palette, click (Edit Type).
2. In the Type Properties dialog, select a roof type from the Type list.
3. Click OK.

In a project view

1. Select the roof in the project view.
2. In the Type Selector, select a different roof type.

Resize the roof using shape handles

Use this method to resize roofs that were created by footprint or by face.

1. In an elevation or 3D view, select the roof.
2. Drag the shape handle, as desired.
**Change the roof overhang**

When editing the footprint of a roof, modify properties of its boundary lines to change the roof overhang.

1. In **sketch mode**, select a boundary line for the roof.
2. On the **Properties palette**, enter a value for Overhang.

3. Click **(Finish Edit Mode)**.

![Diagram of roof with overhang]

**Cut openings in an extruded roof**

1. Select the extruded roof, and click **Modify | Roofs tab ➤ Opening panel ➤ (Vertical)**.
2. If the Go to View dialog displays, select the appropriate plan view in which to edit the profile. A plan view representation of the roof displays. Reference planes define the boundary of the roof.
3. **Sketch** closed-loop openings.

   **Closed-loop sketches in sketch mode**

![Diagram of closed-loop sketch]

4. Click **(Finish Edit Mode)**.

   **Closed-loop sketches become vertical cuts in the roof**

![Diagram of roof with cut openings]
Align roof ridges

You can align roof ridges in 3D and elevation views. To align roof ridges in an elevation view, use the **Align tool**.

1. In a plan view, add a reference plane:
   a. Click Home tab ➤ Work Plane panel ➤ (Ref Plane).
   b. In the drawing area, sketch a reference plane that is not perpendicular to the roof ridges.

   ![Reference plane in plan view](image)

   c. Select the reference plane, and on the Properties palette, enter a name for the plane.

2. Open the 3D view, and click Home tab ➤ Work Plane panel ➤ (Set).

3. In the Work Plane dialog, select the reference plane name you just created, and click OK.

4. To align roof ridges, use the **Align tool**.

   ![Unaligned roof ridges](image)
Joining and Unjoining Roofs

You can join roofs to other roofs or walls, or unjoin them if they were previously joined. This is useful if you have already sketched roofs and walls and then want to change your design by adding smaller roofs to create dormers or awnings.

Joining Roofs

NOTE This is a general procedure for joining roofs. You may have variations based on design intent.

1 After you sketch walls and a roof for your design, sketch another roof that you want to join to the original roof.
   Note that you cannot add the second roof by editing the sketch of the first.
2 If desired, set the lines of the second roof to be slope defining, except the roof line that will be coincident with the first roof or the wall. See Roof Slope on page 528.
3 Click View tab ➤ Create panel ➤ (Default 3D View).
4 On the View Control Bar, for Visual Style, select Shaded.
5 If necessary, spin the design to facilitate selecting the wall or roof edges.
6 Click Modify tab ➤ Geometry panel ➤ (Join/Unjoin Roof).
7 Select an edge of the roof that you want to join, and then select the wall or roof to which you want to join the roof.

Unjoining Roofs

The Unjoin tool lets you unjoin geometry with a single click in the drawing area.
1 Click Modify tab ➤ Geometry panel ➤ (Join/Unjoin Roof).

2 Select the roof that you want unjoined from everything. Revit Structure unjoins the roof.

**Tips for Joining Roofs**

- The Join/Unjoin Geometry tool does not attach a wall to a roof.
- You cannot join a roof to more than one top face of another roof.
- You can join a roof to the top face of another roof and the wall below that roof if you select the wall as the target. The wall must be attached to the target roof and the target roof must be a footprint roof.

![Roof joined to other roof and wall](image)

**Roof Slope**

You can define the slope of a roof using the following methods:

- Defines Slope property
- Slope arrows

**Related topics**

- Dormers on page 536
- Sloped Surfaces Overview on page 579
- Spot Slopes on page 908

**Creating a Roof Slope Using the Defines Slope Property**

By applying the Defines Slope property to lines of a roof boundary, you can create different types of roof lines. (See Examples on page 529.)

1 In sketch mode, select a roof boundary line that defines slope (indicated by △).
2 On the Properties palette, select or clear Defines Roof Slope.
3 To specify roof pitch, select a slope-defining boundary line, click the numeric slope definition in the drawing area, and enter a value for the slope.

You can specify the format of the Slope property in the Project Units dialog.

Examples
One sloped line forms a flat roof

Two opposite sloped lines form a gable

Three or four sloped lines form a hip roof

Other roof footprints and sloped lines yield different results

Related topics
■ Creating a Roof Slope Using Slope Arrows on page 530
■ Aligning Eaves on page 535
Creating a Roof Slope Using Slope Arrows

You can use slope arrows to create slopes on a roof. See Creating a Sloped Surface Using a Slope Arrow on page 581.

The following example shows a roof that you can create in Revit Structure using a slope arrow.

Creating a Roof with Different Eave Heights

You can create a roof with slope-defined lines at different elevations by joining 2 separate roofs.

TIP This procedure works best with a multi-level building.

1 Create a footprint roof sketch similar to the following:

2 On the Properties palette, specify a cutoff level for the roof. For example, if you are sketching the roof on level 2, you might specify level 4 as the cutoff level.

3 Click (Finish Edit Mode).

4 Create another footprint roof sketch at a higher level, similar to the following:

5 Click (Finish Edit Mode).
6 In a 3D view, select both roofs, and click Modify tab ➤ Geometry panel ➤ (Join/Unjoin Roof).

7 View the 2 roofs in a plan view:

You now have a single roof with different eave heights.

Creating a Four-Sided Gable Roof
Use slope arrows to create a 4-sided gable roof.
1 Create a square footprint sketch and designate all sketch lines as non-slope-defining.

2 Click Modify > Create Roof Footprint tab > Draw panel > (Slope Arrow).

3 On the Properties palette, select New <Sketch> from the filter list.

4 Under Constraints, for Specify, select Slope.

5 Under Dimensions, for Slope, enter 9" (or the metric equivalent).

6 Sketch slope arrows as shown.

7 Click (Finish Edit Mode).

8 Open the roof in 3D.
Adding Elements to Roofs

Add elements to a roof in order to complete the roof design.

Eaves

When you sketch a roof, you create eaves by specifying an overhang value. After you complete the sketch of the roof, you can align eaves and change the eave cut.

Eaves can be cut as
Plumb cut eave

2-cut plumb eave
Creating a Plumb Cut, Two-Cut Plumb, or Two-Cut Square Eave

1. In the drawing area, select the roof.
2. On the Properties palette, for Rafter Cut, select Plumb Cut, Two Cut - Plumb, or Two Cut - Square.
3. For Two Cut - Plumb and Two Cut - Square, specify a value for Fascia Depth between zero and the thickness of the roof.

Aligning Eaves

Use the Align Eaves tool to realign eave heights of different boundary lines of a roof.

1. While in sketch mode, click Modify | Roofs > Edit Footprint tab ➤ Tools panel ➤ (Align Eaves).
   Dimensions display near the eaves to indicate their height.
2. Select a roof eave line, and then select an option for adjusting eave properties:
   - Adjust Height changes the Plate height from roof base or Offset from roof base value.
   - Adjust Overhang changes the eave height by adjusting the Overhang value.
3. Select the eave that is at the desired overhang/height.
4. Select remaining eaves whose overhang/height is to be adjusted to match the first eave.
   As you select the remaining eaves, you can choose between adjusting the height or the overhang if you created the roof lines using Pick Walls. If you used the sketch tools to draw the lines, only Adjust Height is available.
5. Click (Finish Edit Mode).
   The results of adjusting the overhang are visible after you finish the roof.
Changing the Eave Height

After you complete a roof sketch, you can change the height of the eaves so that you create eaves of varying heights.

1. While in sketch mode, select a slope-defining boundary line.
2. On the Properties palette, specify a value for Offset From Roof Base or Plate Offset From Base.
3. Click (Finish Edit Mode).

Dormers

Creating a Dormer Using Slope Arrows

1. Sketch a roof footprint, including slope-defining lines.
2. While in sketch mode, click Modify | Create Roof Footprint tab ➤ Modify panel ➤ (Split Element).
3. Split one of the lines in the footprint at 2 points, creating a middle line segment (the dormer segment), and then click Modify.
4. If the dormer segment is slope-defining ( ), select the line, and on the Properties palette, clear Defines Roof Slope.
5. Click Modify | Create Roof Footprint tab ➤ Modify panel ➤ (Slope Arrow), and sketch a slope arrow from one end of the dormer segment to its midpoint.
6. Click Slope Arrow again, and sketch a second slope arrow from the other end of the dormer segment to its midpoint.
Properly sketched slope arrows

7 Click (Finish Edit Mode), and open a 3D view to see the results.

Hip roof with dormer

Creating a Dormer Opening in a Roof

1 Start with a building model in which a dormer has been created.

2 Open a plan view or an elevation view in which you can see the dormer roof and the attached walls. If the roof is extruded, open an elevation view.
3 Click Architect & Site tab ➤ Architect panel ➤ Roof drop-down ➤ (Dormer Opening).
4 Highlight the main roof on the building model, and click to select it.
   Watch the status bar to be sure that you are highlighting the main roof.
   The Pick Roof/Wall Edges tool is active so that you can pick the boundaries that compose the dormer opening.

5 Place the cursor in the drawing area.
   Valid boundaries are highlighted. Valid boundaries are a joined roof or its bottom face, a side face of a wall, a bottom face of a floor, an edge of the roof to be cut, or a model line on the face of the roof to be cut.
   In this example, side faces of walls and joined faces of the roof were selected. Note that you do not need to trim the sketch lines to have a valid boundary.

6 Click (Finish Edit Mode).
7 Create a section view through the dormer to see how it cuts the main roof.

Revit Structure makes both vertical and horizontal cuts in the roof.
Fascia

You can add fascia to edges of roofs, soffits, and other fascias. You can also add fascia to model lines.

Adding Roof Fascia

1 Click Architect & Site tab ➤ Architect panel ➤ Roof drop-down ➤ (Fascia).
2 Highlight edges of roofs, soffits, other fascia, or model lines, and click to place the fascia. Watch the status bar for information about valid references. As you click edges, Revit Structure treats this as one continuous fascia. If the fascia segments meet at corners, they miter.

3 Click Modify | Place Fascia tab ➤ Placement panel ➤ (Restart Fascia) to finish the current fascia and start a different fascia.
4 Move the cursor to a new edge and click to place. This different fascia does not miter with other existing fascias, even if they meet at the corners.
5 Click onto white space in the view to finish placing roof fascias.
Crown molding fascia

NOTE  Fascia profiles miter correctly only around a square cut roof. The roof in this image was created by running a fascia along the edge of a roof with a Two-Cut Square rafter cut. For information on setting this property, see Creating a Plumb Cut, Two-Cut Plumb, or Two-Cut Square Eave on page 535.

Resizing or Flipping Roof Fascias

To resize roof fascia
1  In the drawing area, select the fascia.
2  Move the drag controls to the desired location.

To flip roof fascia
1  In the drawing area, select the fascia.
2  If you are in a 3D view, click the flip controls that appear to flip the fascia around the vertical or horizontal axis.
   If you are in a 2D view, right-click the fascia, and click Flip About Horizontal Axis or Flip About Vertical Axis.

Adding or Removing Segments of the Fascia
1  In the drawing area, select the fascia.
2  Click Modify | Fascias tab ➤ Roof Fascia panel ➤ (Add/Remove Segments).
3  Click a reference edge to add a fascia or remove a fascia. Watch the status bar for information about valid references.

Changing Mitering Options for Roof Fascia
1  In the drawing area, select the fascia.
2  Click Modify | Fascias tab ➤ Roof Fascia panel ➤ (Modify Mitering).
3  On the Mitering panel, select a mitering option:
   - Vertical
   - Horizontal
   - Perpendicular
4  Click on the end face of the fascia to change the miter option.
Vertical miter

Horizontal miter

Perpendicular miter

5 Press Esc to exit the Modify Mitering tool.

Roof fascias can miter between the eave and rake edges of a plumb-cut gable roof.

Changing Horizontal and Vertical Offset of Roof Fascia

You can change the horizontal or vertical offset of a fascia either through its properties or by graphically moving the fascia.

**Horizontal Move**

1. Place the cursor over the fascia and press Tab to highlight the shape handle. The status bar indicates when you are highlighting the shape handle.

2. Click to select the shape handle.
3 Move the cursor left or right to change the horizontal offset.

**Vertical Move**
Select the fascia and drag it up or down. If the fascia is multi-segmented, then all segments move up or down the same distance.

**Fascia moving vertically in section**

---

**Roof Soffits**
Use the Roof Soffit tool to create roof soffits.

---

**Adding Roof Soffits**
Design intent for creating roof soffits can vary widely. This procedure creates a soffit from a 2-loop sketch between a wall and a roof. The soffit is associated with the walls and the roof. To create non-associative soffits, use the Lines tool while in sketch mode.

1 Click Architect & Site tab ➤ Architect panel ➤ Roof drop-down ➤ ![Roof Soffit].
2 Click Modify | Create Roof Soffit Boundary tab ➤ Draw panel ➤ ![Pick Roof Edges].
This tool creates a locked sketch line.
3 Highlight the roof, and click to select it.
4 Click Modify | Create Roof Soffit Boundary tab ➤ Draw panel ➤ (Pick Walls), highlight the outside faces of the wall beneath the roof, and click to select.

Wall highlighted for soffit line

5 Trim the excess sketch lines and close the sketch loop.
6 Click *(Finish Edit Mode).*

To see the soffit better, create a section view through the plan view that shows the wall meeting the roof.

**Roof, soffit, and wall in section view**

![Roof, soffit, and wall in section view](image)

**NOTE** The Join Geometry tool was used to join the soffit and the roof in the previous illustration. To complete the image, join the soffit to the wall, and the wall to the roof.

You can create a sloping soffit by drawing a slope arrow or changing properties of the boundary line. See Sloped Surfaces on page 579.

**Related topic**

- Roof Soffit Examples on page 544

**Roof Soffit Examples**

**Soffit selected in elevation view**

![Soffit selected in elevation view](image)
Roof Gutters

You can add gutters to edges of roofs, soffits, and fascia. You can also add gutters to model lines.

You can place gutters in 2D views, such as plan or section views, or 3D views.

Adding Roof Gutters

1. Click Architect & Site tab ➤ Architect panel ➤ Roof drop-down ➤ (Gutter).
2. Highlight horizontal edges of roofs, soffits, fascias, or model lines, and click to place the gutter.
   Watch the status bar for information about valid references.
   As you click edges, Revit Structure treats this as one continuous gutter.
3 Click Modify | Place Gutter tab ➤ Placement panel ➤ (Restart Gutter) to finish the current gutter and start a different gutter.

4 Move the cursor to a new edge, and click to place.

5 To finish placing gutters, click on white space in the view.

Gutter in section

Related topics

- Resizing or Flipping Roof Gutters on page 546
- Adding or Removing Segments of the Gutter on page 546
- Changing Horizontal and Vertical Offset of Gutters on page 547
- Roof Gutters on page 545

Resizing or Flipping Roof Gutters

To resize roof gutters

1 In the drawing area, select the gutter.
2 Move the drag controls to the desired location.

To flip roof gutters

1 In the drawing area, select the gutter.
2 If you are in a 3D view, click the flip controls to flip the gutter around the vertical or horizontal axis.
   If you are in a 2D view, right-click the gutter and select Flip About Horizontal Axis or Flip About Vertical Axis.

Adding or Removing Segments of the Gutter

1 In the drawing area, select the gutter.

2 Click Modify | Gutters tab ➤ Profile panel ➤ (Add/Remove Segments).
3 Click a reference edge to add a gutter or remove a gutter. Watch the status bar for information about valid references.
Changing Horizontal and Vertical Offset of Gutters

You can change the horizontal or vertical offset of a gutter through its properties or by graphically moving the gutter.

**Horizontal Move**

To move a single gutter segment, select the gutter and drag it horizontally.

To move a multi-segmented gutter, you need to select the shape handle of the gutter. Place the cursor over the gutter and press `Tab` to highlight the shape handle. Watch the status bar to be sure you are highlighting the shape handle. Click to select the shape handle. Move the cursor left or right to change the horizontal offset. This affects the horizontal offset of all segments of the gutter, so that the segments are symmetrical.

**Moving gutter on the left also moves gutter on the right**

![Gutter Offset Diagram]

**Vertical Move**

Select the gutter and drag it up or down. Note that if the gutter is multi-segmented, then all segments move up or down the same distance.

**Gutter moving vertically in section**

![Gutter Offset Diagram]

**Roof Properties**

You can modify several properties for roofs, including slope and structure. You can also modify parameters for roof boundary lines, roof fascia, and roof gutters.

**Modifying Roof Properties**

1. If you are in sketch mode, use the Properties palette to edit roof instance properties as desired.

2. To edit roof type properties, on the Properties palette, click (Edit Type). Change the roof type parameters as desired, and click OK.

**NOTE** Changes made to type parameters affect all roofs of this type in the project. You can click Duplicate to create a new roof type.

**Roof Type Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Structure</td>
<td>Defines the composition of a compound roof. See Compound Structure on page 573.</td>
</tr>
<tr>
<td>Default Thickness</td>
<td>Indicates the thickness of the roof type, which is determined by the cumulative thickness of its layers. This is a read-only property.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Coarse Scale Fill Pattern</td>
<td>The fill pattern for a roof displayed at a coarse detail level.</td>
</tr>
<tr>
<td>Coarse Scale Fill Color</td>
<td>Applies a color to the fill pattern for a roof in a coarse-scale view.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the roof keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The model type for the roof.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The manufacturer of the roof.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Comments about the roof.</td>
</tr>
<tr>
<td>URL</td>
<td>Link for a manufacturer web page.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the roof.</td>
</tr>
<tr>
<td>Assembly description</td>
<td>Description of the assembly, based on the assembly code selection.</td>
</tr>
<tr>
<td>Assembly code</td>
<td>Uniformat assembly code selected from hierarchical list.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value to designate the particular roof. This value must be unique for each roof in a project. Revit Structure issues a warning if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>Cost of the roofing material. The cost can be included in a schedule.</td>
</tr>
</tbody>
</table>

---

**Roof Instance Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Work Plane</td>
<td>The work plane with which an extruded roof is associated.</td>
</tr>
<tr>
<td>Base Level</td>
<td>Sets the level for the footprint or extruded roof.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>If selected, it means the roof is part of a room boundary. If not selected, it means the roof is not part of a room boundary. This property is read-only before creating a roof. After you draw the roof, you can select it and then modify this property.</td>
</tr>
<tr>
<td>Related to Mass</td>
<td>Indicates the element was created from a mass element. This is a read-only value.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Base Offset From Level</td>
<td>Sets the height of the roof above or below the level where it is being sketched. This property is enabled only when creating a roof by footprint.</td>
</tr>
<tr>
<td>Cutoff Level</td>
<td>Specifies a level above which all footprint roof geometry will be not shown. Roofs cut in this manner can be combined with another roof to form Dutch Hip, Mansard, or other roof styles.</td>
</tr>
<tr>
<td>Cutoff Offset</td>
<td>Height of the cutoff above or below the level specified in Up to Level.</td>
</tr>
<tr>
<td>Extrusion Start</td>
<td>Sets the start point of the extrusion. For example, if you pick the outer edge of the wall during creation of the extrusion, the start point starts the extrusion to some point traveling out from the outer edge of the wall. This parameter is only enabled for extruded roofs.</td>
</tr>
<tr>
<td>Extrusion End</td>
<td>Sets the end point of the extrusion. For example, if you pick the outer edge of the wall during creation of the extrusion, the end point ends the extrusion at some point out from the outer edge of the wall. This parameter is only enabled for extruded roofs.</td>
</tr>
<tr>
<td>Reference Level</td>
<td>The reference level for the roof. The default is the highest level in the project. This parameter is only enabled for extruded roofs.</td>
</tr>
<tr>
<td>Level Offset</td>
<td>Raises or lowers the roof from the reference level. This parameter is only enabled for extruded roofs.</td>
</tr>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Fascia Depth</td>
<td>The length of the lines defining the fascia.</td>
</tr>
<tr>
<td>Rafter Cut</td>
<td>Defines the rafter cut on an eave. See Creating a Plumb Cut, Two-Cut Plumb, or Two-Cut Square Eave on page 535.</td>
</tr>
<tr>
<td>Rafter or Truss</td>
<td>This property is a switch for the Plate Offset from Base property. If you choose Rafter, the Plate Offset from Base is measured from the inside of the wall. If you choose Truss, the Plate Offset from Base is measured from the outside of the wall. To see the effects of this property more clearly, set a value for Plate Offset from Base other than 0. (See Roof Boundary Line Properties on page 550.) This property only affects roofs created by picking walls.</td>
</tr>
<tr>
<td>Maximum Ridge Height</td>
<td>The maximum height of the top of the roof above the base level of the building. You can set a maximum allowable ridge height using the Max Ridge Height tool. This is a read-only value. This property is enabled only when creating a roof by footprint.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Slope</td>
<td>Changes the value of the slope-defining line to the specified value, without the need to edit the sketch. The parameter initially displays a value if there is a slope-defining line. If there is no slope-defining line, the parameter is blank and disabled.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Indicates the thickness of the roof. This is typically a read-only value, unless a shape edit has been applied and its type contains a variable layer. When the value is writable, it can be used to set a uniform thickness of the roof. The entry can be blank if the thickness varies. See Variable Layer Thickness for Roofs and Structural Floors on page 392.</td>
</tr>
</tbody>
</table>
### Identity Data

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comments</td>
<td>Comments about a particular roof.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label applied to a roof. Usually a numeric value. This value must be unique for each roof in a project. Revit Structure issues a warning if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
</tbody>
</table>

### Phasing

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase Created</td>
<td>The phase when the roof was created.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>The phase when the roof was demolished.</td>
</tr>
</tbody>
</table>

### Roof Boundary Line Properties

You can change the properties of a roof boundary line when editing the roof footprint.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Defines Roof Slope</td>
<td>For footprint roofs, specifies a roof line to be a slope-defining line.</td>
</tr>
<tr>
<td>Overhang</td>
<td>Adjusts the horizontal offset of the line from its associated wall. Available only when picking walls.</td>
</tr>
<tr>
<td>Plate Offset From Base</td>
<td>The height above the base level at which the wall and the roof meet. This height is relative to the base level of the roof. The default value is 0. This parameter is enabled when a roof boundary line is created using Pick Walls. If a sloped footprint roof line has an overhang, the height of the roof at the eave will be different from the height at the wall. With this property, you can specify the height at the wall rather than at the eave.</td>
</tr>
<tr>
<td>Offset From Roof Base</td>
<td>Specifies the offset of the slope line from the base of the roof. This parameter is enabled when a line is set as slope-defining and it is not associated with a wall.</td>
</tr>
<tr>
<td>Extend into wall (to core)</td>
<td>Specifies the overhang dimension from the roof edge to the exterior core wall. By default, the overhang dimension is measured from the exterior finish face of the wall.</td>
</tr>
</tbody>
</table>

### Dimensions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slope</td>
<td>Specifies the pitch of the roof. This property specifies the slope angle for slope-defining lines.</td>
</tr>
<tr>
<td>Length</td>
<td>The actual length of the roof boundary line. This is a read-only value.</td>
</tr>
</tbody>
</table>
# Roof Fascia and Gutter Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Profile</td>
<td>The profile shape for the fascia or gutter. Choose from a list of predefined profiles, or create your own profile using the profile-hosted.rft template. For information about creating your own profiles, see The Families Guide on page 680.</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>Specifies the look of the fascia or gutter in various views, including a raytraced model. For more information on setting a material, see Materials on page 1573.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the fascia or gutter keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The model type for the fascia or gutter.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The manufacturer of the fascia or gutter material.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Comments about the fascia or gutter type.</td>
</tr>
<tr>
<td>URL</td>
<td>Link for a manufacturer web page.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the fascia or gutter.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the assembly, based on the assembly code selection.</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from hierarchical list.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value to designate the particular fascia or gutter. This value must be unique for each fascia or gutter in a project. Revit Structure issues a warning if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>Cost of the fascia or gutter. Can be included in a schedule.</td>
</tr>
</tbody>
</table>

# Roof Fascia and Gutter Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Vertical Profile Offset</td>
<td>Moves the fascia or gutter above or below the edge on which you created it. For example, if you chose a horizontal roof edge, a fascia moves above or below that edge.</td>
</tr>
<tr>
<td>Horizontal Profile Offset</td>
<td>Moves the fascia or gutter forward or backward from the edge on which you created it.</td>
</tr>
</tbody>
</table>
### Roof Soffit Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Structure</td>
<td>Defines the composition of a soffit. See Compound Structure on page 573.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Indicates the thickness of the soffit, which is determined by the cumulative thickness of its layers. This is a read-only property.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Coarse Scale Fill Pattern</td>
<td>The fill pattern for a soffit displayed at a coarse detail level.</td>
</tr>
<tr>
<td>Coarse Scale Fill Color</td>
<td>Applies a color to the fill pattern for a soffit in a coarse-scale view.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the soffit keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The model type for the soffit.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The manufacturer of the soffit material.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Comments about the soffit type.</td>
</tr>
<tr>
<td>URL</td>
<td>Link for a manufacturer web page.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the soffit.</td>
</tr>
</tbody>
</table>
### Name | Description
---|---
Assembly Description | Description of the assembly, based on the assembly code selection.
Assembly Code | Uniformat assembly code selected from hierarchical list.
Type Mark | A value to designate the particular soffit. This value must be unique for each soffit in a project. Revit Structure issues a warning if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.
Cost | Cost of the soffit. Can be included in a schedule.

### Roof Soffit Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Level</td>
<td>Specifies the level on which to place the soffit.</td>
</tr>
<tr>
<td>Height Offset From Level</td>
<td>Sets the height of the soffit above or below the level where it is being sketched.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>If selected, it means the soffit is part of a room boundary. If not selected, it means the soffit is not part of a room boundary. This property is read-only before creating a soffit. After you draw the soffit, you can select it and then modify this property.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Slope</td>
<td>Changes the value of the slope-defining line to the specified value, without the need to edit the sketch. The parameter initially displays a value if there is a slope-defining line. If there is no slope-defining line, the parameter is blank and disabled.</td>
</tr>
<tr>
<td>Perimeter</td>
<td>Indicates the perimeter of the soffit.</td>
</tr>
<tr>
<td>Volume</td>
<td>The volume of the soffit. This is a read-only value.</td>
</tr>
<tr>
<td>Area</td>
<td>The area of the soffit. This is a read-only value.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>Comments about the roof soffit.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label applied to roof soffits. Usually a numeric value. This value must be unique for each soffit in a project. Revit Structure issues a warning if the number is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>The phase when the soffit was created.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>The phase when the soffit was demolished.</td>
</tr>
</tbody>
</table>
Troubleshooting Roofs

Read the following topics to learn about issues with roofs and related elements.

Can’t Create Curtain Panel

**Error:** Can’t create curtain panel. A panel or a mullion is probably too small.

**Issue:** Typically, this problem occurs in a panel on a sloped glazing. A horizontal and vertical curtain grid on a panel are not meeting exactly at a point, creating a small triangular panel within the main panel. The triangular panel cannot be accurately regenerated, because it is too small. This error can result from placing curtain grids, or moving one in such a way that the small triangular panel displays. Also, the triangle can display, if you created vertical grids and then placed a horizontal grid that did not snap to the vertical grids.

**Solution:** Cancel the placement and/or the movement of the grid. When dividing the panels in a sloped glazing, it is best to start with the placement of horizontal curtain grids and then snap vertical grids to the horizontal grid.

Cannot Create Curtain Panel in Opening

**Error:** Cannot create curtain panel in opening. The opening is probably too small.

**Issue:** Typically, this problem occurs in a sloped glazing. A horizontal and vertical curtain grid are not meeting exactly at a point, creating a small triangular panel, which cannot support mullions.

**Solution:** Cancel the placement of the mullion. When dividing the panels in a sloped glazing, it is best to start with the placement of horizontal curtain grids and then snap vertical grids to the horizontal grid.

Extruded Roof Must Face Upward

**Warning:** All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.

**Issue:** You have sketched an extruded roof in such a way that a part of the roof will lay under another part. Or you may have drawn vertical lines as part of your roof.

**Solution:** Sketch the roof edge such that lines join, but do not pass underneath one another. Also, remove any vertical lines in the sketch.
Floors

You create floors by sketching them, either by picking walls or by using the Line tool. Typically, you sketch a floor in a plan view, although you can use a 3D view if the work plane of the 3D view is set to the work plane of a plan view. Floors are offset downward from the level on which they are sketched.

In a conceptual design, you can use floor area faces to analyze masses, and create floors from a mass. For more information, see Analyzing a Conceptual Design on page 1335 and Creating Floors from Mass Floors on page 1362.

Adding Floors

1. Click Home tab ➤ Structure panel ➤ Floor drop-down ➤ Architectural Floor.
2. Draw the floor boundaries, using one of the following methods:
   - **Pick walls**: By default, Pick Walls is active. (If it is not active, click Modify | Create Floor Boundary tab ➤ Draw panel ➤ (Pick Walls).) Select walls in the drawing area to use as floor boundaries.
Sketch boundaries: To sketch the profile of the floor, click Modify | Create Floor Boundary tab ➤ Draw panel, and select a sketching tool. See Sketching on page 1405.

The floor boundary must be a closed loop (profile). To create an opening in the floor, you can sketch another closed loop where you want the opening to appear.

3 On the Options Bar, for Offset, specify an offset for the floor edges.

NOTE When you are using Pick Walls, select Extend into wall (to core) to measure the offset from the wall’s core.

4 Click Finish Edit Mode.

Changing the Floor Type

To change the floor type in sketch mode

1 On the Properties Palette on page 34, click Edit Type.
2 In the Type Properties dialog, for Type, select a different floor type.
3 Click OK.

To change the floor type in a project view

1 Select the floor in the project view. Watch the tooltip and the status bar to be sure you select the floor, not another element. If desired, you can use a filter to select the floor. See Selecting Elements Using a Filter on page 1442.
2 In the Type Selector on page 35 select the desired floor type from the drop-down.

Editing a Floor Sketch

1 In a plan view, select the floor. Watch the tooltip and the status bar to be sure you select the floor, not another element. If desired, you can use a filter to select the floor. See Selecting Elements Using a Filter on page 1442.

2 Click Modify | Floors tab ➤ Mode panel ➤ Edit Boundary.
3 Make any necessary changes.
   See Sketching on page 1405.

4 Click Finish Edit Mode.

Sloped Floors

To create a sloped floor, use one of the following methods:

■ Draw a slope arrow while sketching or editing the floor boundary.
Specify a value for the Offset from Base property for parallel floor sketch lines.

Specify a value for the Defines Slope and Slope properties for a single floor sketch line.

A sloped floor in a cinema

Related topics

- Sloped Surfaces Overview on page 579
- Sloped Structural Floors on page 372

Multi-layer Floors

In a multi-layer floor, the graphic display of the lines (or edges) between the floor layers can be controlled through the floor subcategories and by overriding the host layers of the floor.

The Common Edges subcategory specifies the graphic display of the lines between layers in a multi-layer floor. The Interior Edges subcategory is applied to edges between adjacent layers that have the same override style.

You can edit the graphic display of floor subcategories from the Visibility/Graphics dialog. See Overriding Graphic Display of Element Categories on page 803. To edit host layers, see Override Cut Line Styles on page 814.

Floor Properties

You can modify several properties for floors, including the slope and the level.

Related topics

- Slope Arrow Properties on page 584
- Boundary Line Properties for Sloped Surfaces on page 585

Modifying Floor Properties

1 Modify the instance properties of a floor by changing corresponding parameter values on the Properties palette.
To access/modify the floor type properties, on the Properties palette, click Edit Type. See Floor Type Properties on page 558.

**NOTE** Changes made to type parameters affect all floors of this type in the project. You can click Duplicate to create a new floor type.

## Floor Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Structure</td>
<td>Creates the composition of a compound floor. See Compound Structure on page 573.</td>
</tr>
<tr>
<td>Default Thickness</td>
<td>Indicates the thickness of a floor type, which is determined by the cumulative thickness of its layers. See Shape Editing for Structural Floors, Roofs, and Floors on page 386.</td>
</tr>
<tr>
<td>Function</td>
<td>Indicates whether a floor is interior or exterior. Function is used in scheduling and to create filters to simplify a model when exporting.</td>
</tr>
<tr>
<td>Additional Top/Exterior Offset</td>
<td>Specifies an additional offset from the top/exterior rebar cover. This allows placing multiple rebar elements together in different area reinforcement layers. See Rebar Cover Element Properties on page 401.</td>
</tr>
<tr>
<td>Additional Bottom/Interior Offset</td>
<td>Specifies an additional offset from the bottom/interior rebar cover. This allows placing multiple rebar elements together in different area reinforcement layers. See Rebar Cover Element Properties on page 401.</td>
</tr>
<tr>
<td>Additional Offset</td>
<td>Specifies an additional offset from the rebar cover. This allows placing multiple rebar elements together in different path reinforcement layers. See Rebar Cover Element Properties on page 401.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Coarse Scale Fill Pattern</td>
<td>Specifies a fill pattern for a floor in a coarse-scale view. See View Properties on page 873.</td>
</tr>
<tr>
<td>Coarse Scale Fill Color</td>
<td>Applies a color to the fill pattern for a floor in a coarse-scale view.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the floor keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The model type of the floor.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>The manufacturer of the flooring material.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Comments about the floor type. This information can be included in a schedule.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>URL</td>
<td>Link for a manufacturer web page.</td>
</tr>
<tr>
<td>Description</td>
<td>Provides a description of the floor.</td>
</tr>
<tr>
<td>Assembly description</td>
<td>Describes the assembly based on the assembly code selection. This is a read-only value.</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value to designate the specific floor. This value must be unique for each element in a project. Revit Structure warns you when the number value is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Cost</td>
<td>Cost of the flooring. This can be included in a schedule.</td>
</tr>
</tbody>
</table>

**Floor Instance Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Level</td>
<td>The level to which the floor is constrained.</td>
</tr>
<tr>
<td>Height Offset from Level</td>
<td>Specifies the elevation of the top of the floor relative to the Level parameter.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>Indicates that the floor is a room-bounding element.</td>
</tr>
<tr>
<td>Related to Mass</td>
<td>Indicates the element was created from a mass element. this is a read-only value.</td>
</tr>
<tr>
<td>Structural</td>
<td></td>
</tr>
<tr>
<td>Structural</td>
<td>Indicates that the element has an analytical model.</td>
</tr>
<tr>
<td>Rebar Cover - Top Face</td>
<td>The rebar cover distance from the floor top face. See Rebar Cover on page 399.</td>
</tr>
<tr>
<td>Rebar Cover - Bottom Face</td>
<td>The rebar cover distance from the floor bottom face. See Rebar Cover on page 399.</td>
</tr>
<tr>
<td>Rebar Cover - Other Faces</td>
<td>The rebar cover distance from the floor to adjacent element faces. See Rebar Cover on page 399.</td>
</tr>
<tr>
<td>Estimated Reinforcement Volume</td>
<td>Specifies the estimated reinforcement volume of the selected element. This is a read-only parameter that only displays when rebar has been placed.</td>
</tr>
</tbody>
</table>

**Structural Floor Shape Edit**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Curved Edge Condition</td>
<td>Specifies the structural floor surface to either Conform to curve or Project to side. This parameter is only available to curved edge structural floors. See Using the Curved Edge Condition Tool on page 390.</td>
</tr>
</tbody>
</table>

**Dimensions**
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slope Angle</td>
<td>Changes the slope-defining lines to the specified value, without the need to edit the sketch. The parameter initially displays a value if there is a slope-defining line. If there is no slope-defining line, the parameter is blank and disabled.</td>
</tr>
<tr>
<td>Perimeter</td>
<td>The perimeter of the floor. This is a read-only value.</td>
</tr>
<tr>
<td>Area</td>
<td>The area of the floor. This is a read-only value.</td>
</tr>
<tr>
<td>Volume</td>
<td>The volume of the floor. This is a read-only value.</td>
</tr>
<tr>
<td>Thickness</td>
<td>The thickness of the floor. This is a read-only value, unless a shape edit has been applied and its type contains a variable layer. When the value is writable it can be used to set a uniform thickness of the floor. The entry can be blank if the thickness varies. See Shape Editing for Structural Floors, Roofs, and Floors on page 386.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments related to the floor that are not already defined in the description or type comments.</td>
</tr>
<tr>
<td>Mark</td>
<td>A user-specified label for the floor. Possible use: shop mark. This value must be unique for each element in a project. Revit Structure warns you when the number value is already used but allows you to continue using it. You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.</td>
</tr>
<tr>
<td>Design Option</td>
<td>If design options have been created, this property indicates the design option in which the element exists. For more information see Design Options on page 653.</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>The phase when the floor was created. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>The phase when the floor was demolished. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Structural Analysis</td>
<td></td>
</tr>
<tr>
<td>Structural Usage</td>
<td>Specifies the structural usage of the floor.</td>
</tr>
<tr>
<td>Analytical Model</td>
<td></td>
</tr>
<tr>
<td>Vertical Projection</td>
<td>The plane of the floor used for analysis and design. See Projection Plane Options for each Structural Element Type on page 1301.</td>
</tr>
</tbody>
</table>
Openings

Use the Opening tool to cut openings in walls, floors, ceilings, roofs, structural beams, braces, and structural columns.

- When you cut a floor, ceiling, or roof, you can choose to cut vertically or perpendicular to the surface. You can also sketch complex shapes using the drawing tools.
- When cutting an opening in a wall, you can sketch a rectangular opening in a straight or arc wall. (For walls, you can create rectangular openings only. You cannot create round or polygon shapes.)

For information on cutting openings in structural beams, braces, and structural columns, see Openings in a Structural Beam, Brace, or Structural Column on page 343.

You can also cut openings in structural floors and decks. For more information, see Openings in Structural Floors on page 372.

When creating a family, you can sketch an opening in family geometry. See The Families Guide on page 680.

Examples of a roof opening, a dormer cut, and a stairway opening through the floor and ceiling
Cutting Rectangular Openings in Walls

Use this procedure to cut rectangular openings in a straight or curved wall. (To cut round or polygon openings, see Editing the Profile of a Wall on page 455.)

View of an opening in a wall

To cut a rectangular opening in a wall

1 Open an elevation or section view where you can access the wall that will host the opening.

2 Click Home tab ➤ Opening panel ➤ Wall Opening.
3 Select the wall that will host the opening.
4 Sketch a rectangular opening.
   Wall elevation view with opening being sketched

After you specify the final point of the opening, the opening displays.

5 To modify an opening, click Modify, and select the opening.
You can use the drag controls to modify the size and location of the opening. You can also drag it to a new location on the same wall, and add dimension to the opening.

Cutting Openings in Floors, Roofs, and Ceilings

Use this procedure to cut an opening in a roof, floor, or ceiling (for example, to accommodate a chimney). You can cut openings in the faces of these elements, or you can select the entire element to make a vertical cut.

1 Click Home tab ➤ Opening panel, and select By Face or Vertical. Use the By Face option when you want the opening to be perpendicular to the selected face. Use the Vertical option when you want the opening to be perpendicular to a level.

2 If you chose By Face, select a face in the floor, ceiling, or roof. If you chose Vertical, select the entire element.

Selected face for opening by face

Selected element for vertical cut
Revit Structure enters sketch mode, where you can create an opening of any shape. For more information about sketching, see Sketching on page 1405.

3 Click Finish Opening.

**Cutting Shaft Openings**

Use this procedure to place an opening that extends through the entire height of a building (or through selected levels) cutting through the faces of roofs, floors, or ceilings simultaneously.

1 Click Home tab ➤ Opening panel ➤ Shaft.

2 Sketch a shaft opening by drawing lines or by picking walls.

   **TIP** Typically you will want to sketch the shaft on a host element, such as a floor, in a plan view.

3 If desired, add symbolic lines to the opening.

4 When you are done sketching the shaft, click Finish Opening.

   *Shaft opening with symbolic lines*

5 To adjust the levels that the opening cuts, select it, and make the following adjustments on the Properties palette:
   - For Base Constraint, specify a level for the start point of the shaft.
   - For Top Constraint, specify a level for the end point of the shaft.

6 Click Apply.

   The shaft cuts through and is visible on all intermediate levels. If you move the shaft on any level, it moves on all levels. The symbolic lines are visible on all levels too.
Model Text

Model text is a work plane-based 3D element that you can use for signs or lettering on a building or wall.

You can add model text in a project view and in the Family Editor for families that can be represented in 3D, such as walls, doors, windows, and furniture. Model text is not available for families that can only be represented in 2D, such as annotations, detail components, and profiles.

You can specify many properties for model text, including font, size, and material.

Effect of Cut Plane on Model Text

If model text intersects the cut plane of a view, it is shown as cut in a plan view. See View Range Properties on page 867.

If a family is shown as cut, the model text saved with a family is cut in plan or reflected ceiling plan views. If the family is not cuttable, it is not shown as cut. For more information on which families can be shown cut, see Managing Family Visibility and Detail Level on page 1619.
Adding Model Text

1 Set the work plane where you want the text to display.
   See Work Planes on page 1517.

2 Click Home tab ➤ Model panel ➤ Model Text.

3 In the Edit Text dialog, enter the text, and click OK.

4 Place the cursor in the drawing area.
   A preview image of the model text displays as you move the cursor.

5 Move the cursor to the desired location, and click to place the model text.

Related topics

■ Editing Model Text on page 566
■ Moving Model Text on page 566
■ Model Text Instance Properties on page 567
■ Model Text Type Properties on page 568

Editing Model Text

1 In the drawing area, select the model text.

2 Click Modify | Generic Models tab ➤ Text panel ➤ Edit Text.

3 In the Edit Text dialog, change the text as desired.

4 Click OK.

Moving Model Text

Move model text to a new location in the same work plane

1 In the drawing area, select the model text.

2 Drag the model text to a new location.

Move model text to a new work plane

1 In the drawing area, select the model text.

2 Click Modify | Generic Models tab ➤ Work Plane panel ➤ Edit Work Plane. See Work Planes on page 1517.

Move model text to a new host

1 In the drawing area, select the model text.
2 Click Modify | Generic Models tab ➤ Work Plane panel ➤ Pick New.
See Moving Components to Different Hosts on page 507.

**Model Text Instance Properties**

To modify an instance property of model text, you change the value of the corresponding parameter, as described under Modifying Instance Properties on page 36.

Common instance properties for model text are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Work Plane</td>
<td>Identifies the work plane on which this instance is placed.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Text</td>
<td>Opens the Edit Text dialog when you click Edit.</td>
</tr>
<tr>
<td>Horizontal Align</td>
<td>Specifies the justification of the text when there are multiple lines. Lines justify to each other.</td>
</tr>
<tr>
<td><strong>Materials and Finishes</strong></td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>Opens the Materials dialog when you click the button to the right of the current value. For more information, see Applying Materials to Elements on page 1576.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Depth</td>
<td>Specifies the depth of the typeface.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments about the model text.</td>
</tr>
<tr>
<td>Mark</td>
<td>Enumerates instances within a category. If you change this value to one that is already used by another model text instance, Revit Structure warns you, but allows you to continue using it.</td>
</tr>
<tr>
<td>Subcategory</td>
<td>Displays the default category (Generic Models) or a subcategory you select from the drop-down list if you have defined subcategories for using Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Object Styles. When defining object styles for the subcategory, you can define its color, line weight, and other properties. You can then control the display of the model text by turning the visibility of the subcategory on or off using View tab ➤ Graphics panel ➤ Visibility/Graphics. See Object Styles on page 1601 and Visibility and Graphic Display in Project Views on page 801.</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Specifies the phase when this instance was created. See Creating Phases on page 878.</td>
</tr>
</tbody>
</table>
### Model Text Type Properties

To modify a type property of model text, you change the value of the corresponding parameter as described under **Modifying Type Properties** on page 38.

**NOTE** Changing a model text type property will affect all model text of that type in the project. Note also that the type name does not update when you change type parameter values. For example, you could use the type parameter Structure to change the width of the Generic - 6” wall type to 6.5”, but the type name will remain Generic - 6”. If you want to create a new model text type, click Duplicate. For more information, see **Creating a New Family Type in a Project** on page 38.

Common type properties for model text are described below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text</strong></td>
<td></td>
</tr>
<tr>
<td>Text Font</td>
<td>Sets the model text font.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Sets the text size.</td>
</tr>
<tr>
<td>Bold</td>
<td>Sets the typeface to bold.</td>
</tr>
<tr>
<td>Italic</td>
<td>Sets the typeface to italic.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the model text keynote. Click in the value box to open the Keynotes dialog. See <strong>Keynotes</strong> on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>Definition of the model text model.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Definition of the model text manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Model text comments.</td>
</tr>
<tr>
<td>URL</td>
<td>Sets applicable URL.</td>
</tr>
<tr>
<td>Description</td>
<td>Model text description.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the assembly based on the assembly code selection.</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from a hierarchical list.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>Sets the model text type mark.</td>
</tr>
<tr>
<td>Cost</td>
<td>The model text cost.</td>
</tr>
</tbody>
</table>
Model Lines

Model lines are work plane-based elements that exist in 3D space and are visible in all views. They can be drawn straight or curved, either singly or in chains, or in the shape of a rectangle, circle, ellipse, or other polygon. (For detailed instructions on the available sketching options, see Sketching Elements on page 1406.) Because they exist in 3D space, you can use model lines to represent geometry such as cords or cables supporting a tarp.

In contrast to model lines, detail lines exist only in the view they are drawn in (see Detail Lines on page 969). You can convert model lines to detail lines, and vice-versa. See Converting Line Types on page 570.

Placing Model Lines

1. Click Home tab ➤ Model panel ➤ Model Line.

2. Click Modify | Place Lines tab ➤ Draw panel, and select a sketching option or Pick Lines to create lines by selecting lines or walls within the model.

3. If you want to use a different line style than the one shown on Line Style panel, select one from the Line Style drop-down.
   For information about creating additional line styles, see Line Styles on page 1602. Note that line styles are not available for model lines created in sketch mode.
4 On the Options Bar, specify the following options as appropriate for the type of model line you are drawing:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>draw the model line on a plane other than the current value of Placement Plane</td>
<td>select a different level or plane from the drop-down. If the desired plane is not listed, select Pick, and use the Work Plane dialog to specify a plane. See Setting the Work Plane on page 1517.</td>
</tr>
<tr>
<td>draw multiple connected line segments</td>
<td>select Chain.</td>
</tr>
<tr>
<td>offset the model line, either from the cursor position or from an edge you select in the drawing area</td>
<td>enter a value for Offset.</td>
</tr>
<tr>
<td>specify a radius for a circle or curved model line or for filleted corners on a rectangle or filleted joins between chained lines</td>
<td>select Radius, and enter a value.</td>
</tr>
</tbody>
</table>

For more information on these options, see Sketching Elements on page 1406.

5 In the drawing area, draw the model line, or click an existing line or edge, depending on the sketching option you are using.

**TIP** After you click to specify the start point of a straight model line, you can quickly set its length by typing a value for the temporary dimension that displays with the line. Likewise, you can enter a radius value for circles or curves, 2 radius values for ellipses, or —for polygons— the distance from the center to the vertices or sides.

Like components, model lines can move with nearby elements, provided they are sketched parallel to that element. For example, if you draw a wall and then draw a line parallel to that wall, the line can move with the wall if you select the Moves With Nearby Elements option on the Options Bar, or choose it from the properties of the line. An arc line can move with an arc wall if the 2 are concentric. See Moving Lines and Components with Walls on page 1478.

**Related topics**
- Converting Line Types on page 570
- Model Line Instance Properties on page 571
- Detail Lines on page 969

**Converting Line Types**

When you import a file and explode it in Revit Structure, the import lines are converted to model lines. If this is not the line type you want to work with, you can use the Convert Lines tool to convert model lines to detail lines. Then, using Convert Lines, you can convert the lines back to their original line type. In families, you can convert symbolic lines to model lines, and vice-versa.

Convert Lines is also useful if you want to convert lines that were mistakenly drawn as the wrong line type. During conversion, Revit Structure remaps the styles of, and references to, the lines being converted. See Exploding Imported Geometry on page 75 for more information about importing files into Revit Structure.
NOTE When using Convert Lines, the active view must support the new line type.

To convert a line type

1 Make sure the active view supports the line type to which you are converting.
2 In the drawing area, select the lines to be converted (model, detail, or symbolic).

3 Click Modify Lines tab ➤ Edit panel ➤ Convert Lines.

NOTE If your current selection has both model and detail or symbolic lines, the Specify Lines to Convert dialog displays, and prompts you to specify which type of line you want to convert.

Model Line Instance Properties

To modify model line instance properties, see Modifying Instance Properties on page 36.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Work Plane</td>
<td>Identifies the work plane on which this line is placed.</td>
</tr>
<tr>
<td>Moves With Nearby Elements</td>
<td>Determines whether the line moves when a nearby element is moved.</td>
</tr>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Line Style</td>
<td>Specifies the line style type as defined in the Object Styles dialog. See Object Styles on page 1601.</td>
</tr>
<tr>
<td>Center mark visible</td>
<td>Indicates whether the center mark displays for an arc, circle, tangent or fillet model line. You can dimension to the center mark.</td>
</tr>
<tr>
<td>Detail Line</td>
<td>Indicates whether the line is a detail line.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td>Specifies the actual length of the line.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Design Option</td>
<td>Indicates the design option in which this element exists, if applicable. For more information, see Design Options on page 653.</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>Specifies the phase when this instance was created. See Creating Phases on page 878.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Specifies the phase when this instance was demolished. See Demolishing Elements on page 883.</td>
</tr>
</tbody>
</table>
Walls, floors, ceilings, and roofs can be composed of parallel layers. A layer can consist of a single continuous plane of material (such as plywood) or multiple materials (such as gypsum board, studs, insulation, air spaces, bricks, and sheathing). In addition, each layer within the component serves a particular purpose. For example, some layers provide structural support, while others act as thermal barriers. Revit Structure considers the function of each layer and matches the layers appropriately.

You can represent each layer by setting the layer's material, thickness, and function. You typically see compound geometry in floor plans, reflected ceiling plans, and sections. They display in hidden line and wireframe views. See Hidden Line Visual Style on page 869 and Wireframe Visual Style on page 868.

Materials in Compound Geometry

Each layer in a compound structure is typically displayed with some type of material. For example, one layer might be the air infiltration barrier, another is plywood, followed by a layer of wood. Revit Structure has several predefined materials, or you can create your own using the Materials tool. See Materials on page 1573.

Layer Pattern Display

The material on layers displays with fill patterns. To see the fill pattern in a coarse-scale view, set the Coarse Scale Fill Pattern and Coarse Scale Fill Color properties of the compound structure. To see the fill pattern in a medium or fine detail level, change the Detail Level parameter of the View Properties to medium or fine. See View Properties on page 873.

Layer Join Cleanup

Compound layer joins clean up only if the layers share the same material. For example, a compound floor layer can join to a compound wall layer if both layers are drywall. If the layers do not clean up, then a solid line appears between them in the join. See Materials on page 1573.
Applying a Function to a Layer of a Compound Structure

You assign each layer a specific function so the layer can join to its corresponding functional layer. Layer functions have an order of precedence.

Rules for Layer Joins

■ The structure layer has the highest priority, Priority 1.

■ Finish 2 has the lowest priority, Priority 5.

■ Revit Structure connects high priority layers before connecting layers with the lowest priority. For example, suppose that you join 2 compound walls. A layer in the first wall with Priority 1 joins to a layer with Priority 1 in the second wall. That Priority 1 layer can pass through lower priority layers before joining to the other Priority 1 layer. A layer with a lower priority cannot pass through a layer of equal or higher priority.

The following illustration shows higher priority layers joining before lower priority layers. The Priority 1 CMU layer of the horizontal wall passes through all layers, until it reaches the Priority 1 stud layer of the vertical wall. Note that the insulation in the horizontal wall does not pass through the air space in the vertical wall, because they are both Priority 3 and are outside the core layer.

■ When layers join, the join cleans up if the 2 layers have the same material. If the 2 layers have different materials, a line appears at the join.

■ Each layer must have a function assigned to it for Revit Structure to match layers accurately.

■ Layers inside the core of one wall pass through layers of higher priority that are outside the core of the joined wall. The layers in the core extend to the core of a joined wall, even if the core layers are set to Priority 5.
The following illustration shows how a layer of lower priority inside the core passes through layers of higher priority outside the core. The insulation layer of the horizontal wall has moved inside the core. The insulation layer can now pass through any layer outside the core, regardless of its priority.

Layer Functions

Layers can be assigned the following functions:

- **Structure [1]**: Layer that supports the remainder of the wall, floor, or roof.
- **Substrate [2]**: Material, such as plywood or gypsum board, which acts as a foundation for another material.
- **Thermal/Air Layer [3]**: Provides insulation and prevents air penetration.
- **Membrane Layer**: A membrane that commonly prevents water vapor penetration. The membrane layer should have zero thickness.
- **Finish 1 [4]**: Finish 1 is typically the exterior layer.
- **Finish 2 [5]**: Finish 2 is typically for the interior layer.

Inserting Layers into a Compound Structure

1. Access the type properties of the compound element.
2. For Structure, click Edit.
   The Edit Assembly dialog appears, allowing you to specify the material for layers and the thickness of those layers.
   
   **TIP**: If desired, create a new type in the Type Properties dialog by clicking New and entering a name for the type.

3. Click Insert to insert layers.
4. For Function, select a function for a layer.
5. For Material, select a material for a layer.
NOTE If you wish to create a new material for the list, see the Materials tool. Among other settings, the Materials tool includes options for specifying cut patterns. For more information about materials, see Materials on page 1573. For more information about creating and setting cut patterns, see Fill Patterns on page 1566. You cannot choose material or thickness for core boundary layers.

6 For Thickness, specify a thickness for a layer.
7 If you want to move the position of the layer, select the layer, and click Up or Down.
8 Set the detail level of the view: Click View tab ➤ Graphics panel ➤ View Properties. Set the Detail level property value to medium or fine.

Layer Wrapping

Compound wall layers can wrap at inserts and at the end caps of the wall. Wrapping is visible in plan view only.

Compound wall with no end-cap wrapping

Exterior wrapping at a wall’s end caps

Interior wrapping at the end caps

Wrapping Around Complex Inserts

Layers can wrap around complex inserts, such as non-rectangular shapes.

Setting Layer Wrapping

You can set layer wrapping using the type properties of the wall or by editing its structure.

To set layer wrapping using type properties

1 Select a compound wall, and click Modify Walls tab ➤ Element panel ➤ Element Properties drop-down ➤ Type Properties.
2 If you want wrapping at inserts, for Wrapping at Inserts, select Exterior, Interior, or Both.
3 If you want end cap layer wrapping, for Wrapping at Ends, select Exterior or Interior.
4 To set individual layers to wrap, select the Wraps check box at the end of each layer.

To set layer wrapping by editing the structure

1 For Structure, click Edit.
2 If you want wrapping at inserts, for Wrapping at Inserts, select Exterior, Interior, or Both.
3 If you want end cap layer wrapping, for Wrapping at Ends, select Exterior or Interior.
4 Click OK.
Previewing the Compound Geometry

To preview the appearance of the wall as you add layers, click Preview in the Type Properties dialog or in the Edit Assembly dialog. The preview image updates as you edit the layers of the wall.

Layers as References

You can select a layer to be a reference point for dimensioning or alignment. Place the cursor on the layer line to use as a reference. Press Tab to select the layer.

By default, each compound component type has 2 layers called Core Boundary. These layers are not modifiable, and they have no thickness. They are references for dimensions.

![Preview of compound geometry with Core Boundaries indicated in red](image)

Compound Walls Joined to Columns

The compound structure of a wall extends to columns when you join the wall to the column.

![Compound wall joining to column](image)

Resulting join of column to wall

Editing Layers

In the Type Properties dialog, you can click Edit for the Structure property. The Edit Assembly dialog opens inside the Type Properties dialog. You can also preview the effects of edits to the layers by clicking Preview.

Flipping Orientation of Compound Walls

As you are placing a compound wall in a plan view, you can press the Spacebar to flip its orientation. You can also select an existing wall in a plan view, and control arrows appear: ⬆️. If you click on the arrows, the first and last layers of the wall change position.

**NOTE** Any cutouts in the wall do not flip their orientation.
Compound wall as seen in plan view before flipping

Compound wall after flipping (the first and last layers have changed position)
Sloped Surfaces

You can create sloped surfaces for the following elements:

- Roofs
- Soffits
- Floors
- Structural floors
- Building pads

To create a sloped surface, draw a slope arrow in the drawing area or change properties of boundary lines.

Related topics

- Shape Editing for Structural Floors, Roofs, and Floors on page 386
- Spot Slopes on page 908

Sloped Surfaces Overview

To create a sloped surface, edit the boundary of the element in a plan view or a 3D view. Then use one of the following methods:

- **Slope arrow**: Draw a slope arrow on the element. Use slope arrow properties to further define the slope.
- **Boundary line properties**: Define the slope of the surface by changing properties of its boundary lines.

**How slope properties are measured**

Slope-related properties are measured from the bottom face or top face of the element, depending on the type of element:

- For roofs and soffits, slope-related properties are measured from the bottom face. For example, Height Offset From Level specifies the distance between the level and the bottom face of a roof.
For building pads, floors and structural floors, slope-related properties are measured from the top face. For example, Height Offset From Level specifies the distance between the level and the top face of a floor.

Modeling multiple slopes

With the exception of roofs, Revit elements can slope in one direction only. To create a surface with multiple slopes, create multiple elements, each with its own slope. Then align and lock the elements together.

**NOTE** For floors, structural floors, and roofs, you can also use shape editing tools to split a surface into subregions that slope independently. See *Shape Editing for Structural Floors, Roofs, and Floors* on page 386.

**Slope Arrow**

The Slope Arrow tool creates sloped surfaces. You can use a slope arrow for roofs, soffits, building pads, floors, and structural floors.

For example, to create a flat sloping roof, draw a slope arrow from the lower edge to the upper edge of the roof boundary.

When you draw a slope arrow, you can enter property values to specify the height at its head and tail, or a slope value. The tail of the slope arrow must be on one of the sketched lines that defines the boundary. This sketched line cannot be slope-defining (unless the slope arrow is at a vertex), because that would specify conflicting slopes for the same segment.

The following example shows a hip on a gable roof. The slope arrow properties are defined as Specify = Slope, Height Offset at Tail = 4’ 0”, and Slope = 9"/12".
When to use a slope arrow
Use a slope arrow when
■ you want to draw the slope in a plan view.
■ you know the height at the top and bottom of the element plane, rather than the slope angle. For example, you can use slope arrows to adjust a flat roof to satisfy a particular height at a drainage point.
■ the slope is diagonal across the surface or not square to an edge.
■ the slope starts and ends at atypical points on the surface.
■ you want to create a dormer.

Related topics
■ Creating a Sloped Surface Using a Slope Arrow on page 581
■ Slope Arrow Properties on page 584

Sloping with Boundary Line Properties
You can create a sloped surface by changing properties of its boundary lines. You can use this method for roofs, soffits, floors, and structural floors.

If you know the starting height of the slope ① and the pitch ③, specify properties for a single sketch line. Revit Structure calculates the position of the opposite edge of the sloped surface.

If you know the height of the lower edge ④ and upper edge ② of the sloped surface, but not its pitch ③, specify properties for parallel sketch lines. Revit Structure calculates the pitch.

Related topic
■ Boundary Line Properties for Sloped Surfaces on page 585

Creating a Sloped Surface Using a Slope Arrow
You can use this method to create a sloped surface on a roof, soffit, building pad, floor, or structural floor.

1 If you are not already in sketch mode, select the element in a plan view, and click Modify | <Elements> tab ➤ Mode panel ➤ (Edit Boundary/Footprint/Sketch).

2 Click Modify | Create/Edit Boundary ➤ Draw tab ➤ (Slope Arrow).

3 Draw the slope arrow in the drawing area: click once to specify its start point (tail); click again to specify its endpoint (head).
   The slope arrow must start on an existing sketch line. For more examples and tips, see Slope Arrow on page 580.
4 (Optional) Refine the sloped surface using one of the following methods:

**Specify the height of the sloped surface at its top and bottom**

a  With the slope arrow selected, access the Properties palette.
b  For Specify, select Height at Tail.
c  Enter values for Level at Tail 1, Height Offset at Tail 2, Level at Head 3, and Height Offset at Head 4.

**Specify the slope (rise/run)**

a  With the slope arrow selected, access the Properties palette.
b  For Specify, select Slope.
c  Enter values for Level at Tail 1, Height Offset at Tail 2, and Slope 3.

5 On the ribbon, click ✓ (Finish Edit Mode).
To see the resulting sloped surface, open a 3D view.
Creating a Sloped Surface Using Parallel Sketch Lines

You can use this method to create a sloped surface on a soffit, floor, or structural floor.

NOTE To slope a building pad, use a slope arrow. To create a sloped roof, see Roof Slope on page 528.

1 If you are not already in sketch mode, select the element in a plan view, and click Modify | <Elements> tab ➤ Mode panel ➤ (Edit Boundary/Footprint/Sketch).
2 Select one boundary line, and, on the Properties palette:
   ■ Select Defines Constant Height.
   ■ Enter values for Level and Offset From Base.
3 Select a parallel boundary line, and, using the same method, specify the properties for Level and Offset From Base.
4 On the ribbon, click (Finish Edit Mode).

To see the resulting sloped surface, open a 3D view or a section view.

Related topics

■ Creating a Sloped Surface Using a Slope Arrow on page 581
■ Creating a Sloped Surface Using a Single Sketch Line on page 583

Creating a Sloped Surface Using a Single Sketch Line

You can use this method to create a sloped surface on a soffit, floor, or structural floor.

NOTE To slope a building pad, use a slope arrow. To create a sloped roof, see Roof Slope on page 528.

1 If you are not already in sketch mode, select the element in a plan view, and click (Edit Boundary/Footprint/Sketch).
2 Select one boundary line and, on the Properties palette:
   a Select Defines Constant Height.
   b Select Defines Slope.
   c Enter a value for Slope.
   d (Optional) Enter values for Level and Offset From Base.

3 On the ribbon, click (Finish Edit Mode).

Related topics
- Creating a Sloped Surface Using a Slope Arrow on page 581
- Creating a Sloped Surface Using Parallel Sketch Lines on page 583

### Slope Arrow Properties

When you draw a slope arrow to create a sloped surface, you can specify the following properties on the Properties palette. See also How slope properties are measured on page 579.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Specify</td>
<td>Selects the method for defining the slope of the surface.</td>
</tr>
<tr>
<td></td>
<td>To define its pitch, select Slope. Then enter a value for the Slope property.</td>
</tr>
<tr>
<td></td>
<td>To define the slope by specifying the height at the tail and head of the slope arrow, select Height at Tail. Then enter values for Level at Tail, Height Offset at Tail, Level at Head, and Height Offset at Head.</td>
</tr>
<tr>
<td>Level at Tail</td>
<td>Specifies the level associated with the tail of the slope arrow.</td>
</tr>
<tr>
<td>Height Offset at Tail</td>
<td>Specifies the starting height of the sloped surface in relation to the Level at Tail. To start below the level, enter a negative number.</td>
</tr>
<tr>
<td>Level at Head</td>
<td>Specifies the level associated with the head of the slope arrow. This property is enabled when Specify is defined as Height at Tail.</td>
</tr>
<tr>
<td>Height Offset at Head</td>
<td>Specifies the ending height of the sloped surface in relation to the Level at Head. To end below the level, enter a negative number. This property is enabled when Specify is defined as Height at Tail.</td>
</tr>
</tbody>
</table>
Boundary Line Properties for Sloped Surfaces

When creating or editing a boundary line for a floor, structural floor, or soffit, you can define the slope of the surface by changing properties of the line on the Properties palette. See also How slope properties are measured on page 579.

### Name Description

**Dimensions**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slope</td>
<td>Specifies the pitch (rise/run) of the sloped surface.</td>
</tr>
<tr>
<td>Length</td>
<td>Indicates the actual length of this line. (Read-only)</td>
</tr>
</tbody>
</table>

**Constraints**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level</td>
<td>Indicates the level with which this line is associated.</td>
</tr>
<tr>
<td>Defines Slope</td>
<td>Indicates that the selected boundary line is one edge of a sloped surface.</td>
</tr>
<tr>
<td></td>
<td>This property is active only when Defines Constant Height is selected.</td>
</tr>
<tr>
<td>Defines Constant Height</td>
<td>Specifies whether the entire line is at the same height in relation to its associated level.</td>
</tr>
<tr>
<td>Offset from Base</td>
<td>Specifies the distance this line is offset from its associated level.</td>
</tr>
<tr>
<td></td>
<td>To start below the level, enter a negative number.</td>
</tr>
<tr>
<td></td>
<td>This property is active only when Defines Constant Height is selected.</td>
</tr>
</tbody>
</table>

**Graphics**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center Mark Visible</td>
<td>If the boundary line is an arc, specifies whether the center mark for the arc displays. You can dimension to the center mark of an arc.</td>
</tr>
</tbody>
</table>

**Dimensions**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slope</td>
<td>Specifies the pitch (rise/run) of the sloped surface.</td>
</tr>
<tr>
<td></td>
<td>This property is active only when Defines Slope is selected.</td>
</tr>
<tr>
<td>Length</td>
<td>Indicates the actual length of this line. (Read-only)</td>
</tr>
</tbody>
</table>

**Related topics**

- [Creating a Sloped Surface Using a Single Sketch Line](#) on page 583
- [Creating a Sloped Surface Using Parallel Sketch Lines](#) on page 583
All model elements in Revit Structure have Assembly Code and Assembly Description type properties based on the hierarchical list of Uniformat codes assigned by R.S. Means. You can add or change a Uniformat assembly code for a selected element type. The read-only Assembly Description property updates to match the assigned code.

Both the Assembly Code and Assembly Description fields are available for creating a schedule that groups components by Uniformat code.

To add or change a Uniformat assembly code for an element type

1. Select an instance of the element type in the drawing area.

2. On the Properties palette, click Edit Type.

3. For the Assembly Code parameter, click the value box, and then click .

4. In the Choose Assembly Code dialog, navigate the Uniformat Classification hierarchy, and select a code.

   **TIP**: If you are looking at the type properties of a wall, you see only the Uniformat codes related to walls. You can select a different category of codes from the drop-down at the top of the dialog.

5. Click OK.

The Assembly Description parameter updates to display the description for the new code.
Circulation
Stairs

You create stairs in a plan view by defining the run of the stairs or by sketching riser lines and boundary lines. You can define straight runs, L-shaped runs with a platform, U-shaped stairs, and spiral stairs. You can also modify the outside boundary of the stairs by modifying the sketch. The risers and runs update accordingly. Revit Structure also generates railings automatically for the stairs. In multi-story buildings, you can design one set of stairs and extend identical sets up to the highest level you define in the stair properties.

The number of treads for a stair run is based on the distance between floors and the maximum riser height defined in the stair properties. A rectangle is displayed in the drawing area, representing the footprint of the run of the stairs.

When creating new stairs, you can also specify the railing type to be used. See Specifying the Railing Type for New Stairs on page 597.

You can schedule stairs with parameters that include Actual Rise (riser), Actual Number of Risers, Run, and Width. See Creating a Schedule or Quantity on page 772. You can also tag stairs with the stair tag family. The stair tag is available from the Annotations folder of the Revit Structure family library. For more information, see Tags on page 944.
Creating Stairs by Sketching Runs

Sketching a run is the easiest way to create stairs. The boundaries and risers are generated automatically as you sketch the run. When you finish the sketch, a railing is applied automatically. The Run tool limits the design of your stairs to straight runs, straight runs with landings, and spiral staircases. For more control when designing stairs, sketch the run by sketching the boundary and riser lines.

To sketch a run

1. Open a plan or 3D view.

2. Click Home tab ➤ Circulation panel ➤ Stairs.

3. Click Modify | Create Stairs Sketch tab ➤ Draw panel ➤ Run.
   The Line tool is selected by default. Select a different tool on the Draw panel if desired.

4. Click to start the run.
   Click start point on left side

5. Click to end the run.
   Click endpoint on right end

6. Click  (Finish Edit Mode).
Completed stairs in 3D with default railings and balusters

To create **stairs** with a landing

1. Click Home tab ➤ Circulation panel ➤ Stairs.

2. Click Modify | Create Stairs Sketch tab ➤ Draw panel ➤ Run.
   - The Line tool is selected by default. Select a different tool on the Draw panel if desired.

3. Click to start the run.

4. Click to position the landing when the desired number of risers have been reached.

5. Drag the cursor along the extension line and click to start drawing the remaining risers.

6. Click to finish the remaining risers.

7. Click (Finish Edit Mode).

**First run of stairs- 9 risers created with 9 remaining**
You can modify a stair footprint that you have sketched using one of the drawing tools.

**To modify a run of stairs**

1. Select the stairs.

2. Click **Modify | Stairs** tab ➤ Mode panel ➤ Edit Sketch.

3. Click **Modify | Stairs** > Edit Sketch tab ➤ Draw panel, and select the appropriate drawing tool to make your changes.

In the next figure, the sketch of the landing was modified using the Start-End-Radius Arc drawing tool.

**Modifying a run of stairs**

Also, you can modify the stairs you sketched by changing their instance properties on the **Properties palette**.

To access the type properties, click **Edit Type** on the Properties palette.
For a description of stair properties and their values, see Stair Properties on page 601.

Creating Stairs by Sketching Boundary and Riser Lines

You can define your stairs by sketching boundaries and risers instead of having Revit Structure calculate the stair run automatically. This method gives you more control when sketching the footprint of the stairs.

1. Open a plan or 3D view.

2. Click Home tab ➤ Circulation panel ➤ Stairs.

3. Click Modify | Create Stairs Sketch tab ➤ Draw panel ➤ Boundary.
   Sketch the boundaries using one of the drawing tools.

4. Click Riser.
   Sketch the risers using one of the drawing tools.

5. Click (Finish Edit Mode).
   Revit Structure generates the staircase with the railings automatically applied.

Stairs sketched using Boundary and Riser tools

3D view of stairs sketched using Boundary and Riser Tools

Stairs with Landings

When a landing is included in the stairs that you create by sketching boundary and riser lines, split the boundary lines where they meet the landing so the railing accurately follows the landing and the slope of the stairs.
1 After you have sketched the stairs and are still in sketch mode, click Modify | Create Stairs Sketch tab ➤ Modify panel ➤ Split.

2 Split the boundary lines where they meet the landing.

Modifying Stairs Sketched with Boundary and Riser Lines

You can modify stairs that you sketch using boundary lines and risers the same way you can modify the stairs that you sketched using the Run tool. You can use the drawing tools to change the footprint and the instance and type parameters to change the stair properties.

**Tips**

- Do not connect left and right boundary lines to each other. You can sketch them as single lines or multi-segmented lines (for example, straight lines and arcs connected).
- Connect riser lines between the left and right boundaries.
- The top riser line on a run of stairs represents the actual riser without a tread.

Creating Spiral Staircases

1 Open a plan or 3D view.

2 Click Home tab ➤ Circulation panel ➤ Stairs.

3 Optionally, click Home tab ➤ Work Plane panel ➤ Set, to select a different work plane for the stairs. See **Work Planes** on page 1517.

4 Click Modify | Create Stairs Sketch tab ➤ Draw panel ➤ (Center-ends Arc).

5 In the drawing area, click to select a center point for the spiral.

6 Click a start point.

7 Click an end point to complete the spiral.

**Completed spiral staircase**
The spiral is limited to fewer than 360 degrees. If you overlap spiral runs, a warning is displayed; the stringers and railings are not placed accurately.

Click \( \surd \) (Finish Edit Mode).

**TIP** To create a spiral staircase to multiple levels, on the Properties palette, under Constraints, specify the top level for the Multistory Top Level parameter.

---

**Creating Arced Landings**

You can create arced landings if you sketch arced runs that share a center and a radius value.

Spiral arcs with the same radius and center

---

**Specifying the Railing Type for New Stairs**

When sketching new stairs, you can specify the railing type to use. Click Modify | Create Stairs Sketch tab ➤ Tools panel ➤ Railing Type. This tool is available only when sketching new stairs. When you select...
Railing Type, you are prompted to select the railing type from the list of existing types in the project. You also have the option to select None or Default.

To specify a railing type

1 Click Home tab ➤ Circulation panel ➤ Stairs.

2 Click Modify | Create Stairs Sketch tab ➤ Tools panel ➤ Railing Type.

3 In the Railings Type dialog, select a rail type.
   If the desired type does not display in the list, you can quit the Stairs tool, create the railing type, and then restart the Stairs tool. Also, you can create the stairs with any railing type, and change the type after you have created the desired railings. For more information, see Railings on page 611.

4 Click OK.

**NOTE** The default railing type is the railing type specified in the Type Selector on page 35 when you are in the Railing sketch mode. You can change the default railing by selecting a new railing type in the Type Selector on page 35. For more information, see Railings on page 611.

### Stair Calculator

Use the stair calculator to calculate the tread depth of stairs. The calculator applies a common, rule-of-thumb formula, such as a formula specified in the Architectural Graphic Standards. Before using the stair calculator, specify the values for the minimum tread depth and maximum riser height. See Stair Properties on page 601.

#### Using the Stair Calculator

1 In the drawing area, select the stairs.

2 On the Properties palette, click Edit Type.

3 In the Type Properties dialog, under Construction, for Calculation Rules, click Edit.

4 In the Stair Calculator dialog, select Use Stair Calculator for slope calculation.

5 Under Calculation Rule for target slope, enter a value to multiply by Rise.

6 Enter a value to multiply by tread Depth.

7 Enter a Maximum Result and a Minimum Result for the stair calculator.

**NOTE** The stair calculator uses the tread depth you specified in the instance properties of the stairs. If the value you specified causes the calculator to produce values that are outside the range of the acceptable results, a warning is displayed.

8 Click OK.

The stair calculator computes the tread depth for new stairs only; existing stairs are not affected.
Rule-of-Thumb Formulas

The following is a rule-of-thumb formula for interior stairs, as specified in the Architectural Graphic Standards.

- Riser + Tread = 17.5 inches: 7.5 inches for the riser height; 10 inches for the tread depth.
- Riser * Tread = 75 inches.
- 2(Riser) + Tread is greater than or equal to 24 inches (minimum threshold) or less than or equal to 25 inches (maximum threshold).

Modifying Stairs

You can modify stairs in several ways including the stair boundaries, risers, and run lines, railings, labels, direction, and tread thickness for monolithic stairs.

Boundaries and Riser and Run Lines

Stair boundaries, as well as riser and run lines, can be modified to shape the stairs in the desired manner. For example, you can select the run line and drag it to add or remove risers.

Modifying Stair Railings

When you add stairs, stair railings are added automatically. You can modify stair railings at any time after their creation.

1 Select a railing.
   If you are working in a plan view, it may be helpful to use the Tab key to select the railing.
   
**TIP** Modifying railings in a 3D view allows for easier selection and better view of your changes.

2 Modify instance properties of the railing as needed on the Properties palette, or click Edit Type to access its type properties.

3 To modify the sketch line of the railing, click Modify | Railings tab ➤ Mode panel ➤ Edit Path.
   The railing line is selected, as follows.

4 Edit the selected line as desired.
   You are in sketch mode, so you can modify the shape of the line to suit your design. The railing line can consist of connected straight and arced segments, but it cannot form a closed loop. You
can resize it by dragging the blue controls. See Controls and Shape Handles on page 1449 and Splitting Elements on page 1509. You can move the railing line to a new location, such as the center of the staircase. You cannot draw multiple railings in the same sketch session. For each railing you sketch, you must first finish the sketch, before you can draw another railing.

Modified stairs with center railing

Extending Stair Railings

If you extend stair railings (for example, to extend onto a floor), you need to split the railing line so that the railing changes its slope and meets the floor properly. See Splitting Elements on page 1509.

Split the rail line as shown in the picture.

Finished result of extending railing
Moving Stair Labels

You can drag the Up or Down label that displays in plan views with a run of stairs using any of 3 methods.

To move the stair label

1. Place the cursor over the stair text label.
   A drag control displays next to the label.
2. Drag the control to move the label.

Method 2

1. Select the run of stairs.
   A blue drag control displays.
2. Drag the control to move the label.

Method 3

1. Highlight the entire run of stairs, and press Tab to select the shape handle.
   Watch the status bar as you press Tab until it indicates that the shape handle is highlighted.
2. Drag the label to a new position.

Changing the Stair Direction

You can change the direction of the stairs after you have completed the stair sketch.

1. Select the stairs in a project view.
2. Click the blue flip control arrows.

Zero Tread Thickness for Monolithic Stairs

You can set the tread thickness of monolithic stairs to 0. Monolithic stairs have their stringers, treads, and risers all made from the same material, such as concrete stairs.

1. In the drawing area, select the stairs.
2. On the Properties palette, click Edit Type.
3. In the Type Properties dialog, under Construction, select Monolithic Stairs.
4. Under Risers, clear the End with Riser parameter.
5. For Riser Thickness, enter 0.
6. For Tread Thickness, enter 0.

Stair Properties

You can modify several properties for stairs, including the top and base levels, calculation rules, and stair labels.
NOTE If you are upgrading stairs from a previous release of Revit Structure, and you do not see all the parameters listed here, duplicate your stair type from the Type Properties dialog, and then you should see all of the parameters.

Modifying Stair Properties

1 Modify the instance properties of a stair by changing corresponding parameter values on the Properties palette.

See Stair Instance Properties on page 605.

2 To access/modify the stair type properties, on the Properties palette, click Edit Type.

See Stair Type Properties on page 602.

NOTE Changes made to type parameters affect all stairs of this type in the project. You can click Duplicate to create a new stair type.

Stair Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Calculation Rules</td>
<td>Click Edit to set the stair calculation rules. See Stair Calculator on page 598.</td>
</tr>
<tr>
<td>Extend Below Base</td>
<td>Extends stringers below the base level of the stair. This is useful for cases where the stringer attaches to the face of a floor opening rather than resting on the surface of a floor. To extend the stringer below the floor, enter a negative number.</td>
</tr>
<tr>
<td>Monolithic Stairs</td>
<td>Specifies that the stairs are to be made of one material.</td>
</tr>
<tr>
<td>Landing Overlap</td>
<td>Enabled when stairs are set to monolithic. When a monolithic stair has a winder, the bottom of the stair can be a smooth shape or stepped. If it is stepped, this parameter controls the distance between the riser face and the vertical face of the corresponding step on the underside.</td>
</tr>
<tr>
<td>Underside of Winder</td>
<td>Enabled when stairs are set to monolithic. If a monolithic stair has a winder, the bottom of the stair can be a smooth shape or stepped.</td>
</tr>
<tr>
<td>Function</td>
<td>Indicates whether the stairs are interior (default value) or exterior. Function is used in scheduling and to create filters to simplify a model when exporting.</td>
</tr>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Break Symbol in Plan</td>
<td>Specifies whether the cutline of the stairs in plan view has a break line.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Changes the size of the UP-DN symbol in a plan view.</td>
</tr>
<tr>
<td>Text Font</td>
<td>Sets the font of the UP-DN symbol.</td>
</tr>
<tr>
<td>Materials and Finishes</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Tread Material</td>
<td>Click the button to open the Materials dialog. See Materials on page 1573 for more information on creating a material.</td>
</tr>
<tr>
<td>Riser Material</td>
<td>See Tread Material description.</td>
</tr>
<tr>
<td>Stringer Material</td>
<td>See Tread Material description.</td>
</tr>
<tr>
<td>Monolithic Material</td>
<td>See Tread Material description.</td>
</tr>
</tbody>
</table>

**Treads**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum Tread Depth</td>
<td>Sets the initial value for the Actual Tread Depth instance parameter. If the Actual Tread Depth value exceeds this value, Revit Structure issues a warning.</td>
</tr>
<tr>
<td>Tread Thickness</td>
<td>Sets the thickness of the tread.</td>
</tr>
<tr>
<td>Nosing Length</td>
<td>Specifies the amount of the tread depth that overhangs the next tread.</td>
</tr>
<tr>
<td>Nosing Profile</td>
<td>The profile for a sweep added to the front of the tread. See The Families Guide on page 680. Also see Creating a Sweep on page 1426. Revit Structure has predefined profiles to use for the sweep.</td>
</tr>
<tr>
<td>Apply Nosing Profile</td>
<td>Specifies 1-sided, 2-sided, or 3-sided tread nosing.</td>
</tr>
</tbody>
</table>

**Risers**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum Riser Height</td>
<td>Sets the maximum height of each riser on the staircase.</td>
</tr>
<tr>
<td>Begin with Riser</td>
<td>If selected, Revit Structure adds a riser to the beginning of the stairs. If you clear the check box, Revit Structure removes the beginning riser. Note that you may receive a warning about the actual number of risers exceeding the desired number of risers if you clear this check box. To resolve this, either select End with Riser, or change the desired number of risers.</td>
</tr>
<tr>
<td>End with Riser</td>
<td>If selected, Revit Structure adds a riser to the end of the stairs. If you clear the check box, Revit Structure removes the end riser.</td>
</tr>
<tr>
<td>Riser Type</td>
<td>Creates straight or slanted risers, or no riser.</td>
</tr>
<tr>
<td>Riser Thickness</td>
<td>Sets the thickness of the riser.</td>
</tr>
<tr>
<td>Riser to Tread Connection</td>
<td>Switches the connection of the riser and tread in relation to each other. The riser can extend behind the tread, or the tread can extend under the riser.</td>
</tr>
</tbody>
</table>

**Stringers**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trim Stringers at Top</td>
<td>Trim Stringers at Top affects the top end of stringers on a stair run. If you select Do Not Trim, the stringer is cut with a single vertical cut resulting in a point at the top. If you select Match Level, the stringer is cut horizontally, making the top of the stringer flush with the top level. If you select Match Landing Stringer, a horizontal cut is made at the same height as the stringer top on landings. To see the effects of this parameter clearly, you may want to clear the check box for End with Riser.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Right Stringer</td>
<td>Sets the type of stringer for the right side of the stairs. None means there is no stringer. A closed stringer encases the treads and risers. An open stringer exposes the treads and risers.</td>
</tr>
<tr>
<td>Left Stringer</td>
<td>See description for Right Stringer.</td>
</tr>
<tr>
<td>Middle Stringers</td>
<td>Sets the number of stringers that appear underneath the stairs between the left and right of the stairs.</td>
</tr>
<tr>
<td>Stringer Thickness</td>
<td>Sets the thickness of the stringers.</td>
</tr>
<tr>
<td>Stringer Height</td>
<td>Sets the height of the stringers.</td>
</tr>
<tr>
<td>Open Stringer Offset</td>
<td>Enabled when the stairs have an open stringer. Moves an open stringer from side to side. For example, if you offset an open right stringer, it moves toward the left stringer.</td>
</tr>
<tr>
<td>Stringer Carriage Height</td>
<td>Controls the relationship between the side stringers and treads. If you increase the number, the stringer moves down from the treads. Treads do not move. Railings do not change height relative to treads, but the balusters extend down to meet the stringer top. This height is measured from the tread end (lower corner) to the bottom side of the stringer, perpendicular to the stringer.</td>
</tr>
<tr>
<td>Landing Carriage Height</td>
<td>Allows stringers to have a different height relationship to landings than they do to sloped runs. For example, it lowers a horizontal stringer toward a landing on u-shaped stairs.</td>
</tr>
</tbody>
</table>

### Identity Data

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type Mark</td>
<td>A value to designate the particular stairs. Useful if you need to identify more than one set of staircases. This value must be unique for each stairway in a project. Revit Structure warns you if the number is already used but allows you to continue using it. (You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.)</td>
</tr>
<tr>
<td>Keynote</td>
<td>Adds or edits the stairs keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The model type for the stairs. May not be applicable.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Manufacturer for the stair materials. May not be applicable.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Specific comments on the stair type.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page for the manufacturer or other appropriate link.</td>
</tr>
<tr>
<td>Description</td>
<td>A description for the stairs, such as circular.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the assembly based on the assembly code selection.</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from hierarchical list.</td>
</tr>
<tr>
<td>Cost</td>
<td>Material cost.</td>
</tr>
</tbody>
</table>
### Stair Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Base Level</td>
<td>Sets the base of the stairs.</td>
</tr>
<tr>
<td>Base Offset</td>
<td>Sets the stairs' height from its base level.</td>
</tr>
<tr>
<td>Top Level</td>
<td>Sets the top of the stairs.</td>
</tr>
<tr>
<td>Top Offset</td>
<td>Sets the stairs' offset from the top level.</td>
</tr>
<tr>
<td>Multistory Top Level</td>
<td>Sets the top of the stairs in a multi-story building. The advantage to using this parameter (as opposed to sketching individual runs) is that if you change the railing on one run, that railing is changed on all the runs. Also, if you use this parameter, the Revit Structure project file size does not change as significantly as it would if you sketched individual runs. Note: The levels in a multi-story building should be a uniform distance apart. For example, each level should be 4 meters apart.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Up Text</td>
<td>Sets the text for the Up symbol in plan. The default value is UP.</td>
</tr>
<tr>
<td>Down Text</td>
<td>Sets the text for the Down symbol in plan. The default value is DN.</td>
</tr>
<tr>
<td>Up Label</td>
<td>Displays or hides the Up label in plan.</td>
</tr>
<tr>
<td>Up Arrow</td>
<td>Displays or hides the Up arrow in plan.</td>
</tr>
<tr>
<td>Down Label</td>
<td>Displays or hides the Down label in plan.</td>
</tr>
<tr>
<td>Down Arrow</td>
<td>Displays or hides the Down arrow in plan.</td>
</tr>
<tr>
<td>Show Up arrow in all views</td>
<td>Displays the Up arrow in all project views.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>Width of the stairs.</td>
</tr>
<tr>
<td>Desired Number of Risers</td>
<td>The number of risers is calculated based on the height between levels.</td>
</tr>
<tr>
<td>Actual Number of Risers</td>
<td>Normally, the same as Desired Number of Risers. However, it may be different if you do not complete adding the correct number of risers for the given run of the stairs. This is a read-only value.</td>
</tr>
<tr>
<td>Actual Riser Height</td>
<td>Displays the actual riser height. The value is equal to or less than the value specified in Maximum Riser Height. This is a read-only value.</td>
</tr>
<tr>
<td>Actual Tread Depth</td>
<td>You can set this value to change the tread depth without having to create a new stair type. Also, the Stair Calculator can change this value to satisfy the stair equation.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments on the staircase.</td>
</tr>
<tr>
<td>Mark</td>
<td>A label created for the stairs. This value must be unique for each stairway in a project. Revit Structure warns you if the number is already used but allows you to continue using it. (You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.)</td>
</tr>
</tbody>
</table>

**Phasing**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase Created</td>
<td>The phase when the stairs were created.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>The phase when the stairs were demolished.</td>
</tr>
</tbody>
</table>
Ramps

You use the same tools and procedures for sketching ramps that you use to sketch stairs. You can create ramps in a plan or 3D view by sketching the run of the ramp or by sketching boundary lines and riser lines. Just like stairs, you can define straight runs, L-shaped runs, U-shaped ramps, and spiral ramps. You can also modify the outside boundary of the ramp by modifying the sketch.

Finished ramp

Adding a Ramp

The easiest way to add a ramp is to sketch a run. However, the Run tool limits the design of your ramp to straight runs, straight runs with landings, and spiral ramps. For more control when designing ramps, sketch the run of the ramp using the Boundary and Riser tools.

1 Open a plan or 3D view.

2 Click Home tab ➤ Circulation panel ➤ Ramp. Revit Structure enters sketch mode, and the Run tool is active.

3 Optionally, click Home tab ➤ Work Plane panel ➤ Set, to select a different work plane. See Work Planes on page 1517.

4 Click Modify | Create Ramp Sketch tab ➤ Draw panel, and select either (Line) or (Center-ends Arc).

5 Place the cursor in the drawing area, and drag to sketch the ramp run.

6 Click (Finish Edit Mode).
TIP  The default settings for the Top Level and Top Offset properties may make the ramp too long. Try setting the Top Level to the current level, and the Top Offset to a lower value.

Changing the Ramp Type

To change the ramp type in sketch mode

1 On the Properties Palette on page 34, click Edit Type.
2 In the Type Properties dialog, for Type, select a different ramp type.

To change the ramp type in a project view

1 Select the ramp in a plan or 3D view.
2 In the Type Selector on page 35, select the desired ramp type from the drop-down.

Editing a Ramp

1 Select the ramp in a plan or 3D view.

2 Click Modify | Ramps tab ➤ Mode panel ➤ Edit Sketch.

Ramp Properties

You can modify several properties for ramps, including thickness, slope, and base level.

Modifying Ramp Properties

1 Modify the instance properties of a ramp by changing corresponding parameter values on the Properties palette.
   See Ramp Instance Properties on page 609.

2 To access/modify the ramp type properties, on the Properties palette, click Edit Type.
   See Ramp Type Properties on page 608.

NOTE  Changes made to type properties affect all ramps of this type in the project. You can click Duplicate to create a new ramp type.

Ramp Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Thickness</td>
<td>Sets the thickness of the ramp. This property is enabled only when the Shape property is set to thick.</td>
</tr>
</tbody>
</table>
### Ramp Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
</tbody>
</table>

---

### Description

**Function**
- Indicates whether a ramp is interior (default value) or exterior. Function is used in scheduling and to create filters that simplify a model when exporting.

**Graphics**
- **Text Size**: The size of the font for the ramp’s up text and down text.
- **Text Font**: The font for the ramp’s up text and down text.

**Materials and Finishes**
- **Ramp Material**: Material applied to the surface of the ramp for rendering.

**Dimensions**
- **Maximum Incline Length**: Specifies the maximum amount of consecutive rise in a ramp before a landing is required.

**Identity Data**
- **Keynote**: Add or edit the ramp keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.
- **Model**: Defines the ramp model.
- **Manufacturer**: Defines the ramp manufacturer.
- **Type Comments**: Ramp comments.
- **URL**: Sets applicable URL.
- **Description**: Ramp description.
- **Assembly description**: Description of the assembly based on the assembly code selection.
- **Assembly code**: Uniformat assembly code selected from hierarchical list.
- **Type Mark**: Sets the ramp type mark.
- **Cost**: Ramp cost.

**Other**
- **Ramp Max Slope (1/x)**: Sets the maximum slope for the ramp.
- **Shape**: Applies a shape to the ramp for display purposes.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base Level</td>
<td>Sets the base of the ramp.</td>
</tr>
<tr>
<td>Base Offset</td>
<td>Sets the ramp's height from its base level.</td>
</tr>
<tr>
<td>Top Level</td>
<td>Sets the top of the ramp.</td>
</tr>
<tr>
<td>Top Offset</td>
<td>Sets the ramp's offset from the top level.</td>
</tr>
<tr>
<td>Multistory Top Level</td>
<td>Sets the top of the ramp in a multi-story building.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Up text</td>
<td>Specifies the up text.</td>
</tr>
<tr>
<td>Down text</td>
<td>Specifies the down text.</td>
</tr>
<tr>
<td>Up label</td>
<td>Indicates whether the up text appears.</td>
</tr>
<tr>
<td>Down label</td>
<td>Indicates whether the down text appears.</td>
</tr>
<tr>
<td>Show Up arrow in all views</td>
<td>Indicates whether the up arrow appears in all views.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>Width of the ramp.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments about the ramp.</td>
</tr>
<tr>
<td>Mark</td>
<td>A unique identifier for the ramp.</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>The phase when the ramp was created. See Creating Phases on page 878.</td>
</tr>
</tbody>
</table>
| Phase Demolished            | The phase when the ramp was demolished. See Demolishing Elements on page 883.
Railings

You can add railings as free-standing components to levels, or attach them to hosts (such as floors, ramps, or stairs).

When you sketch a railing, rails and balusters are automatically placed on the railing at evenly spaced intervals. For information on editing baluster and post placement, see Controlling Placement of Balusters and Posts on page 614. The shapes of rails and balusters are determined by the profile families loaded in the project. See Railing Properties on page 619.

Adding a Railing

1. Click Home tab ➤ Circulation panel ➤ Railing.
2. If you are not in a view where you can sketch a railing, you are prompted to pick a view. Select a view from the list, and click Open View.

3. To set the host for the railing, click Modify | Create Railing Path tab ➤ Tools panel ➤ Pick New Host, and place the cursor near the host (for example, a floor or staircase). As you move the cursor, the appropriate hosts highlight.

   **NOTE** To select a level, just click in the drawing area to start drawing the railing.
4 Click on the host to select it.
5 Sketch the railing.
   If you are adding a railing to a run of stairs, the railing must be sketched along the inside line of the stair stinger in order for the railing to host and slope correctly.
   For more information on sketching, see Sketching on page 1405.

6 Modify instance properties as needed on the Properties palette, or click Edit Type to access and modify type properties.
   For more information, see Railing Properties on page 619.

7 Click Finish Edit Mode.
8 Change to a 3D view to see the railing.

Related topics
- Modifying the Railing Structure on page 612
- Modifying Railing Height and Slope on page 613
- Controlling Placement of Balusters and Posts on page 614
- Railing Properties on page 619

Changing the Railing Type

To change the railing type in sketch mode

1 On the Properties palette, click Edit Type.
2 In the Type Properties dialog, for Type, select a different railing type.

To change the railing type from a project view

1 Select the railing in the project view.
2 In the Type Selector on page 35, select the desired railing type from the drop-down.

Modifying the Railing Structure

You can change the height, offset, profile, material, and number of rails within a railing type.

1 On the Properties palette, click Edit Type.
2 In the Type Properties dialog, for Rail Structure, click Edit.

**NOTE** Changes made to type properties affect all railings of this type in the project. You can click Duplicate to create a new railing type.

3 In the Edit Rails dialog, for each rail, specify the following:
   - The height and offset.
A rail profile. To create your own rail profile, see The Families Guide on page 680.

A material. To create your own rail material, see Materials on page 1573.

4 To create an additional rail, click Insert. Enter a name for the rail, and the height, offset, profile, and material properties.

5 Click Up or Down to adjust the railing position.

6 When you are finished, click OK.

**Modifying Railing Joins**

Use the following procedure to override joins for a railing on a join-by-join basis.

1 Open the plan or 3D view where the railing is located.

2 Select the railing, and click Modify | Railings tab ➤ Mode panel ➤ Edit Path.

3 Click Modify | Railings > Edit Path tab ➤ Tools panel ➤ Edit Rail Joins.

4 Move the cursor along the path of the railing. A box displays around the join as you move your cursor over it on the path.

5 Click to select the join. When the join is selected, an X displays on the join.

6 On the Options Bar, for Rail Join, select a join method. Join methods are set by the Angled Joins and Tangent Joins parameters for the railing type. For more information about these parameters and join methods, see Railing Type Properties on page 620.

7 Click Finish Edit Mode.

**Related topics**

- Modifying the Railing Structure on page 612
- Modifying Railing Height and Slope on page 613
- Controlling Placement of Balusters and Posts on page 614
- Railings on page 611

**Modifying Railing Height and Slope**

You can control the height and slope of individual rail sketch lines. For example, on a set of U-shaped stairs, you may want to set the inner railing to a different height than the outer railing. With slope adjustment, you can control how the railing segment follows the slope of the stairs. You may want the segment to be flat at some points or sloped at other points.

**To modify railing height and slope**

1 Open the plan view where the railing is located.
2 Select the railing, and click Modify | Railings tab ➤ Mode panel ➤ Edit Path.

3 Select a railing sketch line.
   On the Options Bar, note that Height Correction is set to By Type, indicating that height adjustment is controlled by the railing type.

4 For Height Correction, select Custom.
5 Enter a value in the adjacent text box.
6 For Slope, select one of the following values:
   - **By Host.** The railing segment follows the slope of its host (for example, stairs or ramps).

[Diagram of railing following stairs]

   - **Flat.** The railing segment is horizontal, even if the host is sloped. For railings similar to those in the following illustration, you may need to use height correction or edit the railing join to join the railing where the stairs turn.

[Diagram of railing horizontally aligned]

   - **Sloped.** The railing segment is sloped, such that it makes a non-interrupted connection with adjacent segments.

[Diagram of sloped railing]

### Controlling Placement of Balusters and Posts

You can control how balusters and posts are arranged along a railing. A simple baluster pattern is provided with the default project template. You can use this pattern, modify it, or create a more complex pattern.
NOTE If you start a new project using a template, when you sketch a railing, balusters and posts are added by default. If you start a project without a template, balusters and posts are not placed by default when you sketch a railing.

Creating a Custom Baluster Pattern

1. In a plan view, select a railing.

2. On the Properties palette, click Edit Type.

3. In the Type Properties dialog, for Baluster Placement, click Edit.

   **NOTE** Changes made to the type properties affect all railings of this type in the project. You can click Duplicate to create a new railing type.

4. Enter a name for the first part of the baluster pattern.

5. For Baluster Family, do the following:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>show rails and posts, but no balusters</td>
<td>select None.</td>
</tr>
<tr>
<td>use a baluster family that exists in your drawing</td>
<td>select one of the balusters from the list.</td>
</tr>
<tr>
<td>use a baluster family that is not in your drawing</td>
<td>load additional baluster families before making any selection. For more information on loading families, see Loading Families on page 688.</td>
</tr>
</tbody>
</table>

6. For Base, do the following:

<table>
<thead>
<tr>
<th>If you want to specify the base as…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the floor edge, stair tread, level, or ramp</td>
<td>select Host.</td>
</tr>
<tr>
<td>one of the existing rail structures in the drawing</td>
<td>select the named rail from the list.</td>
</tr>
<tr>
<td>a rail structure that is not defined in your drawing</td>
<td>select Cancel, and click Edit for Rail Structure in the Type Properties dialog.</td>
</tr>
</tbody>
</table>

7. For Base Offset, enter a value.

8. Select the Top. Refer to the previous table.

9. Enter a value for Top offset.

10. Enter a value for Dist. from previous.

11. Enter a value for Offset.

12. For Break Pattern, do the following:

<table>
<thead>
<tr>
<th>If you want the baluster pattern…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>spread along the length of each railing segment</td>
<td>select Each Segment End.</td>
</tr>
</tbody>
</table>
If you want the baluster pattern...

<table>
<thead>
<tr>
<th>If you want the baluster pattern...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>to break and place a post at the turn angle of the railing</td>
<td>select Angles Greater Than, and enter a value for Angle. If the railing turns at an angle that is equal to or greater than this value, the pattern breaks and a post is added. Typically, this value remains at 0. Turn angles are measured in the plan view. Segment breaks in the railing that do not occur at a turn are ignored.</td>
</tr>
<tr>
<td>to remain unbroken regardless of any separations or turns in the railing</td>
<td>select Never. The balusters are located along the entire length of the railing.</td>
</tr>
</tbody>
</table>

13 Specify justification.
Refer to the description of Justify in Baluster Pattern Properties on page 616.

14 Select Excess Length Fill if you selected Beginning, End, or Center for Justify.
Refer to the description of Excess Length Fill in Baluster Pattern Properties on page 616.

15 Click OK.

**Overriding the Main Baluster Pattern for Stairs**

You can override the main baluster pattern and set a specific pattern for stairs.

1 In a plan view, select a railing.

2 On the Properties palette, click Edit Type.

3 In the Type Properties dialog, for Baluster Placement, click Edit.

4 In the Edit Baluster Placement dialog, select Use Baluster Per Tread on Stairs.

5 Specify the number of balusters on each tread.

6 Specify the baluster family for the stairs.

7 Click OK.

**Baluster Pattern Properties**

The following are the main pattern display properties for balusters.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of a specific baluster within the pattern.</td>
</tr>
<tr>
<td>Baluster Family</td>
<td>The style of the baluster or post family. If you select None, no balusters or posts display in that portion of the pattern.</td>
</tr>
<tr>
<td>Base</td>
<td>Specifies where the bottom of the baluster is placed: at the top of the rail, bottom of the rail, or top of the host. A host can be a level, floor, stair, or ramp.</td>
</tr>
<tr>
<td>Base offset</td>
<td>The negative or positive vertical distance between the bottom of the baluster and the base.</td>
</tr>
<tr>
<td>Top</td>
<td>Specifies where the top of the baluster is placed (usually a rail). Values are the same as Base.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Top offset</td>
<td>The negative or positive vertical distance between the top of the baluster and the Top.</td>
</tr>
<tr>
<td>Dist. from previous</td>
<td>The distance between the start of the pattern and the first baluster, or for subsequent balusters, the distance between the previous baluster in the pattern.</td>
</tr>
<tr>
<td>Offset</td>
<td>The distance to the inside or the outside of the railing path.</td>
</tr>
<tr>
<td>Break Pattern at</td>
<td>The point along a railing segment at which the baluster pattern stops.</td>
</tr>
<tr>
<td>Angle</td>
<td>A value specifying the angle at which a pattern breaks. This property is available when Angles Greater Than is selected for Break Pattern At.</td>
</tr>
<tr>
<td>Pattern Length</td>
<td>The sum of all values listed in the Dist. From Previous column.</td>
</tr>
<tr>
<td>Justify</td>
<td>Balusters in a pattern are justified along the length of a railing segment.</td>
</tr>
<tr>
<td>■ Beginning starts the pattern at the beginning of the railing segment. If the pattern length is not an exact multiple of the railing length, then there is excess space between the last pattern instance and the end of the railing segment.</td>
<td></td>
</tr>
<tr>
<td>■ End starts the pattern from the end of the railing segment. If the pattern length is not an exact multiple of the railing length, then there is excess space between the last pattern instance and the beginning of the railing segment.</td>
<td></td>
</tr>
<tr>
<td>■ Center places the first baluster pattern at the center of the railing segment and any excess space appears evenly at the beginning and end of the railing segment.</td>
<td></td>
</tr>
<tr>
<td>■ Spread Pattern to Fit spreads the pattern evenly along the length of the railing segment. No excess space occurs, and the actual placement value of the pattern differs from the value indicated in Pattern Length.</td>
<td></td>
</tr>
<tr>
<td>How Revit Structure determines the beginning and end depends on which way you drew the railing, right to left, or left to right.</td>
<td></td>
</tr>
<tr>
<td>Excess Length Fill</td>
<td>If there is extra space along the railing segment, but it cannot be filled with a pattern, you can specify how to fill that space. You can specify that a specific baluster family fill the excess space and set a spacing increment for it. You can specify that the baluster pattern be truncated to fill the excess length, or you can specify none so that the excess space remains open. This property is available if Justify is set to Beginning, End, or Center.</td>
</tr>
<tr>
<td>Spacing</td>
<td>The distance between balusters that fill any excess length along the railing segment. This property is available if a baluster or post family is selected for the Excess Length Fill property.</td>
</tr>
</tbody>
</table>

**Specifying Start, Corner, and End Posts**

1. In a plan view, select a railing.

2. On the Properties palette, click Edit Type.

3. In the Type Properties dialog, for Baluster Placement, click Edit.

4. Specify a family for the start, corner, and end posts. Select None if you do not want a post to appear at the start, corner, or end of the railing.

   Baluster families are trimmed by default so they do not intersect a rail. The following figure illustrates this: This may not be your intent for posts. To set posts to intersect rails, right-click the family type in the Project Browser, and click Properties. Select the Post property.
5 Specify a base for each post.
6 Optionally, enter a value for Base offset for each.
7 Specify a top for each.
8 Optionally, enter a value for Top offset.
9 Optionally, enter a value for Space.
10 Optionally, enter a value for Offset.
11 Select the location of corner posts, as follows:

<table>
<thead>
<tr>
<th>If you…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>want to place a corner post at the end of each segment of the railing</td>
<td>select Each Segment End.</td>
</tr>
<tr>
<td>want to place a corner post when a railing segment makes a turn greater than a given value</td>
<td>select Angles Greater Than, and enter a value for Angle. If the railing turns at an angle that is greater than this value, a post is placed at the turn. Typically, this value remains at 0. Turn angles are measured in the plan view. Segment breaks in the railing that do not occur at a turn are ignored.</td>
</tr>
<tr>
<td>do not want to place a post regardless of any separations or turns in the railing</td>
<td>select Never.</td>
</tr>
</tbody>
</table>

12 Click OK.

**Post Pattern Properties**

The following are the Main Pattern display properties for posts.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of a specific post within the baluster.</td>
</tr>
<tr>
<td>Baluster Family</td>
<td>The post family. Alternately, you can select None or Default.</td>
</tr>
<tr>
<td>Base</td>
<td>Specifies where the bottom of the post is placed: at the top of the rail, bottom of the rail, or top of the host. A host can be a level, floor, stair, or ramp.</td>
</tr>
<tr>
<td>Base offset</td>
<td>The negative or positive vertical distance between the bottom of the post and the base.</td>
</tr>
<tr>
<td>Top</td>
<td>Specifies where the top of the post is placed (usually a rail). Values are the same as Base.</td>
</tr>
<tr>
<td>Top offset</td>
<td>The negative or positive vertical distance between the top of the post and the top.</td>
</tr>
</tbody>
</table>
### Deleting Balusters and Posts

1. In a plan view, select a railing.

2. On the Properties palette, click Edit Type.

3. In the Type Properties dialog, for Baluster Placement, click Edit.

   **NOTE** Changes made to type properties affect all railings of this type in the project. You can click Duplicate to create a new railing type.

4. In the Edit Baluster Placement dialog, select the baluster or post to remove in Main Pattern.

5. To delete the baluster or post from the pattern, click Delete.

   To leave a space in the pattern where a baluster or post currently exists, for Baluster Family, change the value to None.

6. Click OK.

### Railing Properties

You can modify several properties for railings, including railing height, railing structure, and baluster placement.

**NOTE** If you are upgrading railing types from a previous release of Revit Structure and you do not see all of the properties listed, you can duplicate the railing type, and then all properties should be available.

### Modifying Railing Properties

1. Modify the instance properties of a railing by changing corresponding parameter values on the Properties palette.

2. To access/modify the railing type properties, on the Properties palette, click Edit Type.

   **NOTE** Changes made to type properties affect all railings of this type in the project. You can click Duplicate to create a new railing type.
## Railing Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Railing Height</td>
<td>The height of the top-most rail in the railing structure.</td>
</tr>
<tr>
<td>Rail Structure</td>
<td>Opens a separate dialog where you set the number of rails, height, offset, material, and profile family (shape) for each rail. See Modifying the Railing Structure on page 612.</td>
</tr>
<tr>
<td>Baluster Placement</td>
<td>Opens a separate dialog where you define baluster patterns. See Controlling Placement of Balusters and Posts on page 614.</td>
</tr>
<tr>
<td>Baluster Offset</td>
<td>Offsets the balusters from the rail sketch line. By setting a value for this property and rail offsets, you can create different combinations of rails and balusters.</td>
</tr>
<tr>
<td>Use Landing Height Adjustment</td>
<td>This parameter controls the height of railings at landings. If set to No, railings at landings use the same height as they do over stair runs. If set to Yes, the railing height is adjusted up or down by the amount set for Landing Height Adjustment. To get smooth railing connections, set the Tangent Joins parameter to Extend Rails to Meet.</td>
</tr>
<tr>
<td>Landing Height Adjustment</td>
<td>Raises or lowers the height of the railing from the value indicated in the Railing Height parameter at intermediate or top landings.</td>
</tr>
<tr>
<td>Angled Joins</td>
<td>If 2 railing segments meet at an angle in plan but do not connect vertically, Revit Structure can add vertical or horizontal segments to create a join or add no connector, leaving a gap. This can be used to create a continuous railing where the start of a stair run leading up from a landing cannot be displaced by one tread width. Join methods can be overridden on an connection-by-connection basis. See Modifying Railing Joins on page 613.</td>
</tr>
<tr>
<td>Tangent Joins</td>
<td>If 2 tangent railing segments are collinear or tangent in plan but do not connect vertically, Revit Structure can add vertical or horizontal segments to create a join, extend segments to meet, or add no connector leaving a gap. This can be used to create a smooth junction when the railing height is modified at a landing or the railing turns out at the bottom of a stair. Join methods can be overridden on a connection-by-connection basis. See Modifying Railing Joins on page 613.</td>
</tr>
<tr>
<td>Rail Connections</td>
<td>When connections are made between railing segments, Revit Structure tries to create mitered joins. If it cannot make a mitered join, then segments can be trimmed, which means they are cut with a vertical plane, or they can be welded, which means they are joined in a manner as close to a miter as possible. Welded connections work best for circular rail profiles.</td>
</tr>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the railing keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>Defines the railing model.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Defines the railing manufacturer.</td>
</tr>
</tbody>
</table>
## Name | Description
---|---
Type Comments | Railing comments.
URL | Sets applicable URL.
Description | Railing description.
Assembly Description | Description of the assembly based on the assembly code selection.
Assembly Code | Uniformat assembly code selected from hierarchical list.
Type Mark | Sets the railing type mark.
Cost | Railing cost.

## Railing Instance Properties

**Name | Description**
---|---
**Constraints**
Base Level | Sets the base level for the railing. You can change this value to any level in the project.
Base Offset | Offsets the railing to a specified distance above or below the base level.

**Dimensions**
Length | The actual length of the railing.

**Identity Data**
Comments | Comments on the railing.
Mark | A mark applied to a railing. This can be a label that appears in a multi-category tag with the railing. For complete information about multi-category tagging and setting up shared parameters, see Shared Parameters on page 1541.

**Phasing**
Phase Created | The phase when the railing was created. See Creating Phases on page 878.
Phase Demolished | The phase when the railing was demolished. See Demolishing Elements on page 883.
Curtain Elements

Use Revit Structure to create building facades. Model these facades using the supplied curtain wall types, and modify them to suit your needs. Curtain walls and systems can be as simple or complicated as required.

This section provides information about curtain walls, curtain grids, mullions, curtain systems, and setting properties to create the desired look.

Curtain Wall Workflow

You can use the default Revit Structure curtain wall types to set up curtain walls. These wall types provide 3 levels of complexity, upon which you can simplify or enhance:

- Curtain Wall 1 -- has no grids or mullions. There are no rules associated with this wall type. This wall type provides the most flexibility.

- Exterior Glazing -- has preset grids. The grid rules can be changed if the setting is not suitable.

- Storefront -- has preset grids and mullions. The grid and mullion rules can be changed if the settings are not suitable.

Curtain Wall 1, Exterior Glazing, Storefront Wall Types

Curtain Elements Overview

When you place a curtain wall, you can draw grid lines on it to define where the mullions are placed. Mullions are the structural elements that divide adjacent window units. You can modify a curtain wall by
selecting the wall and right-clicking to access a shortcut menu. On the shortcut menu are several choices for manipulating the curtain wall, such as selecting panels and mullions.

Curtain wall

Curtain Grid
Curtain Walls

A curtain wall is any exterior wall that is attached to the building structure and which does not carry the floor or roof loads of the building. In common usage, curtain walls are often defined as thin, usually aluminum-framed walls containing in-fills of glass, metal panels, or thin stone. When you draw the curtain wall, a single panel is extended the length of the wall. If you create a curtain wall that has automatic curtain grids, the wall is subdivided into several panels.

Creating Linear Curtain Walls

1. Click Home tab ➤ Structure panel ➤ Wall drop-down ➤ Partition Wall.
2. Select a curtain wall type from the Type Selector drop-down.
3. To create a wall with automatic horizontal and vertical curtain grids, specify the Vertical and Horizontal Layout properties for the wall type.

For more information, see Type-Driven Curtain Element Layout on page 648.
IMPORTANT You cannot move automatic curtain grids after drawing a wall, unless you make them independent. To do this, select a curtain grid and on the Properties Palette on page 34, under Other, select Independent for Type Association. Alternatively, you can select the grid, and click the pin that is displayed. When an automatic grid is independent, its position remains fixed if you resize the wall or change the grid layout using the type properties of the curtain wall. This parameter allows you to adjust the position of certain grids after creating even-grid spacing. If you had placed the grid on the curtain wall, it would not be part of the grid layout calculation.

4 Create the wall, using one of the following methods:

- **Draw the wall**: By default, Line is active. (If it is not active, click Modify | Place Wall tab ➤ Draw panel ➤ (Line), or select another draw tool.) See Sketching on page 1405. As you draw a wall, you can quickly set its length by entering a value on the keyboard, taking advantage of the listening dimension feature. See Listening Dimensions on page 909. If you want to flip the orientation of the wall about its location line, press the Spacebar as you draw the wall. This works for all wall drawing tools, such as rectangles, circles, and 3-point arcs.

- **Pick Lines** ( ): Select existing lines. Lines can be model lines or edges of elements, such as roofs, curtain panels, and other walls.

- **Pick Faces** ( ): Select either a massing face or a generic model face. The generic model could be created as in-place or family file based. See Modeling by Face on page 1356.

  **TIP** To highlight all vertical faces on the mass or generic model, press Tab. Click to place walls simultaneously on each highlighted face.

To exit the Wall tool, press Esc twice.

5 To change a panel type, do the following:

a. Open an elevation or a view where you can see the curtain wall panels.

b. Select a panel. Move the cursor over a panel edge, and press Tab until the panel is selected. Watch the status bar for information, and then click to select it.

c. Select the appropriate panel type from the Type Selector drop-down.

6 If you sketched a curtain wall without automatic grids (Type-Driven Curtain Element Layout on page 648), you can add grids manually. See Adding Curtain Grids on page 627.

7 If needed for the design, add mullions to the grids.

Completed curtain wall

Merging Tips

- You can make linear curtain wall panels with the system panel type only.

- If you join panels of different types, the resulting panel is of the type you first selected.
Use hidden line view to clearly see which panels are joined. See Hidden Line Visual Style on page 869.

Creating Non-Linear Curtain Walls

To create non-rectangular curtain walls, sketch a straight curtain wall and then edit its elevation profile, or join a straight curtain wall to any roof. See Defining Structural Wall Shapes or Openings on page 348.

1 Click Home tab ➤ Structure panel ➤ Wall drop-down ➤ Partition Wall.
2 Select a Curtain Wall type from the Type Selector drop-down.
3 Create the wall, using one of the following methods:
   - **Draw the wall**: By default, Line is active. (If it is not active, click Modify | Place Wall tab ➤ Draw panel ➤ (Line), or select another draw tool.) See Sketching on page 1405. As you draw a wall, you can quickly set its length by entering a value on the keyboard, taking advantage of the listening dimension feature. See Listening Dimensions on page 909.
     If you want to flip the orientation of the wall about its location line, press the Spacebar as you draw the wall. This works for all wall drawing tools, such as rectangles, circles, and 3-point arcs.
   - **Pick Lines**: Select existing lines. Lines can be model lines or edges of elements, such as roofs, curtain panels, and other walls.
   - **Pick Faces**: Select either a massing face or a generic model face. The generic model could be created as in-place or family file based. See Modeling by Face on page 1356.

TIP To highlight all vertical faces on the mass or generic model, press Tab. Click to place walls simultaneously on each highlighted face.

4 Select the wall, and edit its elevation profile or join it to a roof.
5 Add curtain grids and mullions, as desired.

Changing the Orientation of Curtain Walls

As you place a curtain element or select one in a plan view, control arrows display . Click the arrows to flip the interior and exterior surfaces of the wall.

Curtain wall before flipping

|   |   |   |   |   |

Curtain wall after flipping (the black surface line is now on top)

|   |   |   |   |   |

Adding Curtain Grids

If you sketched a curtain wall without automatic grids (Type-Driven Curtain Element Layout on page 648), you can add grids manually.

1 Open a 3D view or an elevation view.
2 Click Architect & Site tab ➤ Architect panel ➤ Curtain Grid.
3 Click Modify | Place Curtain Grid tab ➤ Placement panel, and select a placement type. See Curtains Grid Placement on page 633.

4 Place the cursor along wall edges; a temporary grid line displays.

5 Click to place the grid lines.

   Each section of the grid (design unit) is filled with a separate curtain wall panel of the selected type.

6 Click Esc when you are done.

7 Add additional grid lines, if necessary, or click Modify to exit the tool.

**Curtain grid snapping**

When you place curtain grids, they snap to evenly spaced intervals on the curtain wall. For example, as you drag the cursor over a panel, it snaps to the midpoint or to the 1/3 mark of the panel.

When you place curtain grids on walls, sloped glazing, and curtain systems, the curtain grids snap to visible levels, grids, and reference planes. In addition, curtain grids snap to other curtain grids when you select a common corner edge. For example, if you place the cursor on a joined edge between 2 curtain walls, the new curtain grid snaps to an existing curtain grid.

To place mullions on grid lines, see Placing Mullions on page 635.

**Related topics**

- Curtain Grid Placement on page 633
- Excluding Grids from Curtain Panels on page 633
- Creating Varied Surface Grid Layouts on page 633
- Locking the Position of Mullions and Curtain Grids on page 635
- Modifying Surface Grid Layout on page 634

**Modifying Curtain Walls**

You can modify the appearance of curtain walls through their properties. Curtain wall properties are modifiable before or after you draw the walls.

To specify curtain wall properties, you can access properties on the Properties palette.

- Select the wall, and then change properties on the Properties palette.

**Merging Curtain Wall Panels**

Curtain walls frequently contain non-continuous grid lines and mullions. Your design may require that grid lines be staggered, rather than continuous. You can merge curtain wall panels to accommodate these design requirements. Also, merging panels allows you to include a door or other large insert in a curtain wall.

Curtain wall with merged panels
Embedding Curtain Walls

Walls can be embedded into a host wall, so that the embedded wall is associated with the host wall. The behavior of an embedded wall is similar to that of a window; the embedded wall does not resize if you resize the host wall. If you rotate the host wall, the embedded wall moves with it. To embed walls, you do not have to edit the profile of the host wall, cut a hole in it, and then insert a wall into that hole; you can use the Cut Geometry tool.

Embedded walls are useful when, for example, you need to create storefronts on the exterior walls of the building. When embedding walls, consider the following:

- A curtain wall can be embedded into another wall, provided that it is parallel to the host wall and the walls are within 6 inches of each other.
- Walls can be embedded into other walls using the Cut Geometry tool. Some curtain wall types automatically embed into a wall. To determine whether the curtain wall type automatically embeds into another wall, check the type properties of the wall. Select the Automatically Embed parameter if it is not already selected.
- You can embed a wall into a curtain panel and then embed a curtain wall into that embedded wall. You can repeat this process as many times as desired.
- If you edit the elevation profile of the embedded wall, the opening in the host wall is adjusted automatically, and the host wall's material fills in the adjusted opening. You do not have to edit the elevation profile of the host wall to follow the opening of the embedded wall.

Embedding a Wall into Another Wall

1. Sketch a host wall of any type in the drawing area. The host wall can be a straight wall or an arc wall. Keep in mind the following when you are sketching the wall:
   - If the host wall is an arc wall, the embedded wall must be a concentric arc.
   - Be sure the embedded wall is shorter in length than the host wall.
   - If the embedded wall is within the boundary of the host wall, Revit Structure issues a warning and advises you to use the Cut Geometry tool.

2. Click Modify | Place Wall tab ➤ Geometry panel ➤ Cut.
   When using the Cut Geometry tool, do not select the shorter wall first and then the larger host.

3. Select the host wall.

4. Select the wall to embed into the host wall.
   The wall is now embedded. If necessary, resize the embedded wall by selecting it and using the drag controls.

Separating an Embedded Wall from Its Host

1. Click Modify tab ➤ Geometry panel ➤ Cut drop-down ➤ Uncut Geometry.
2. Select the host wall.
3. Select the embedded wall.
   Each wall can now be moved independently.
Cleaning Curtain Wall Joins

By default, curtain walls attach to the face of adjoining walls. Use the shape handle to separate a curtain wall join from other curtain walls or exterior and interior walls. This allows more control over curtain wall joins and mullion placement to ensure proper design intent.

Default curtain wall installation to the face of a joined wall

To separate the join, select the curtain wall join shape handle; press Tab and watch the status bar to be sure you have selected the handle. Drag the handle to separate the curtain wall from the adjoining wall. This does not break the join between the 2 walls.

Curtain wall shape handle selected for dragging

TIP You can achieve the same effect by using the Align tool to align the edge of the curtain wall with the center or edge of the joined wall. See Aligning Elements on page 1479.

Wall Panels in Curtain Walls

You can change a curtain wall panel to any type of wall. Select a panel, and then select a wall type in the Type Selector. You cannot explicitly control the size of a panel with drag controls, or by its properties; the panel is resized when the curtain wall is changed.

Changing the location line of the wall panel changes how it is placed in the curtain wall.

Curtain wall with masonry wall panel type

Schedule as Panels or Walls

To control whether the wall schedules as a curtain panel or as a wall, select the panel, change its type on the Type Selector to another wall type, then change the value of Categorize as.
Add Inserts to Wall Panels
You can add inserts, such as windows, into wall panels; the position of inserts is relative to the entire curtain wall. If you resize a wall panel by moving curtain grids, the insert does not move with the panel. Its position remains fixed with respect to the curtain wall.

Inserts in masonry wall panels

Split Wall Panels with Curtain Grids
You can split wall panels by adding curtain grids to the curtain wall. You can also add mullions to the curtain grids on the panel.

Split curtain wall panels

Curtain Wall as Wall Panel
A curtain wall type can be applied to a wall panel, which has the effect of nesting a curtain wall within a curtain wall.

Curtain wall with curtain wall panel
Changing Curtain Wall Panel Type

You can change the panel type applied to a curtain wall by selecting an individual panel and then selecting a different type from the Type Selector. If there are not enough wall types loaded, load more families using the Load Family tool. For more information, see Loading Families on page 688.

Reshaping Curtain Wall Panels

A curtain wall panel may need an opening in it, such as a vent. You can create an opening by editing the panel as an in-place family.

1 Select a curtain wall panel and click Modify | Curtain Panels tab ➤ Model panel ➤ Edit In-Place.

2 Select the panel.

3 To edit the shape of the panel, click Modify | Glass tab ➤ Mode panel ➤ Edit Extrusion.

4 In sketch mode, reshape the panel as desired.
   For example, you could add a door-like opening to the panel.

5 Click Finish Edit Mode.

Joining Curtain Wall Panels

1 Create the curtain wall panels.
   See Curtain Elements Overview on page 623.

2 Add curtain grids.

3 Select a curtain grid.

4 Click Modify | Curtain Wall Grids tab ➤ Curtain Grid panel ➤ Add/Remove Segments.

5 Click on a curtain grid segment to remove it.
   As you remove segments, adjacent panels join.

6 Click in white space in the drawing area.

Unjoining Curtain Wall Panels

To separate panels, you add curtain grid segments back.

1 Select a curtain grid.
2 Click Modify | Curtain Wall Grids tab ➤ Curtain Grid panel ➤ Add/Remove Segments.

3 Click the dashed segment to restore the curtain grid segment.

The dashed lines indicate a segment that was removed previously. The joined panels revert back to their unjoined state.

Curtain Grid Placement

As you place curtain grids on curtain panels, a preview image of the grid is displayed on the panels. You can control the location of the preview and thus the location of the curtain grid using one of the options for the grid segments:

- All Segments: places grid segments on all panels where the preview appears.
- One Segment: places one grid segment on one panel where the preview appears.
- All Except Picked: places a grid segment on all panels except those you select to exclude.

Excluding Grids from Curtain Panels

1 Click Architect & Site tab ➤ Architect panel ➤ Curtain Grid.

2 Click Modify | Place Curtain Grid tab ➤ Placement panel ➤ All Except Picked.

3 Place the cursor on a curtain wall, so that a preview of the curtain appears.

4 Click to place the curtain grid.

   The curtain grid line is displayed in red.

5 Click segments of the curtain grid to exclude them from panels.

   When you click the segments, they are displayed as dashed lines.

6 When you finish excluding segments, click Finish Current to place a new curtain grid.

Creating Varied Surface Grid Layouts

You can create various grid layouts on the faces of curtain elements. For example, if a sloped glazing with 4 faces requires 4 different grid layouts, you can specify grid layout by face, which is similar to changing an element instance.
To change curtain grid layouts on a face, select the curtain grid element and then click (Configure Grid Layout), which displays on each face of the curtain element. You can change the layout either by accessing the Element Properties or by graphically modifying the curtain grid layout interface.

The following are instance properties that you can set by face for a curtain element:

- Number
- Justification
- Offset
- Angle

For a description of these properties, see Type-Driven Curtain Element Layout on page 648.

**Modifying Surface Grid Layout**

When you select a curtain grid element face, you click the control that is displayed; a curtain grid layout interface is opened over the curtain grid face. The interface lets you graphically change the instance parameter values of the face.

**Layout interface controls:**

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Justification Origin" /></td>
<td>The justification origin. Click the arrows to change the justification scheme of the grids. The horizontal arrow changes Justification (Vertical Grid); the vertical arrow changes Justification (Horizontal Grid).</td>
</tr>
<tr>
<td><img src="image" alt="Origin and Angle" /></td>
<td>Origin and angle (Vertical Curtain Grid). Click the controls to change their values.</td>
</tr>
</tbody>
</table>
Locking the Position of Mullions and Curtain Grids

Mullions and curtain grids can be pinned (locked) on a curtain element only if that element has a type-driven curtain grid layout. If the mullion or curtain grid is locked on a curtain element, the type properties of the curtain element define the mullion or curtain grid type.

**Mullions**

When you add mullions to a grid, the mullions resize to fit the grid. If you add a mullion to an inside grid, the mullion is centered on the grid. If you add a mullion to a perimeter grid, the mullion aligns so its border is flush with the outside of the wall.

**Curtain wall with curtain grids and mullions**

---

### Placing Mullions

After creating a curtain grid, you can place mullions on grid lines.

1. Add a curtain grid to a curtain wall or curtain system. See Adding Curtain Grids on page 627.
2. Click Architect & Site tab ➤ Architect panel ➤ Mullion.
3. Select the desired mullion type in the Type Selector.
4. On the Modify | Place Mullion tab ➤ Placement tab, select one of the following tools:
   - **Grid Line**: When you click a grid line in the drawing area, this tool places a mullion across the entire grid line.
   - **Grid Line Segment**: When you click a grid line in the drawing area, this tool places a mullion on the individual segment of the grid line that you click.
   - **All Grid Lines**: When you click any grid line in the drawing area, this tool places mullions on all grid lines.
5. Click in the drawing area to place mullions on grid lines as desired.
6. Click Modify.

Mullions resize to the grid line, and automatically split at an intersection with another mullion. You can change the properties of mullions. For a complete list of mullion properties and their values, see Common Mullion Type Properties on page 645.
Angle and Position of a Mullion

Mullions can be perpendicular to the face of the curtain panel or parallel to the ground plane. The latter choice is more appropriate for sloping curtain panels. After changing the position of the mullion, you can change the angle of the mullion; acceptable values are between –90 and 90 degrees.

The angle and position are type properties of the mullion. For more information, see Common Mullion Type Properties on page 645.

Controlling Mullion Joins

You can control mullion joins after you place mullions on a curtain grid.

1. In the drawing area, select a mullion.
2. Click Modify | Curtain Wall Mullions tab ➤ Mullion panel ➤ Make Continuous or Break at Join.

- Use Make Continuous to extend the ends of mullions at a join, so that they display as one continuous mullion.

- Use Break at Join to trim the ends of mullions at a join, so that they display as separate mullions.

Cleaning Mullion Joins

You can switch mullion joins between cleaned and uncleaned by selecting a mullion and clicking the toggle control that is displayed. Mullions clean up at the join only if there 4 or fewer mullions meeting at the join, all of them are straight, and all are parallel to the grid lines.
Corner Mullions

Corner mullions are single mullions that you can place between the end points of 2 curtain walls, between the ridges of sloped glazing, or on any internal mullion on a curved curtain element, such as an arc curtain wall.

Arc curtain wall with internal mullions

Corner Mullion Types

Revit Structure includes 4 types of corner mullions:

- **L Corner Mullion**: Panels of curtain walls or sloped glazing meet the ends of the mullion legs. You can specify the length and thickness of the mullion legs in the type properties of the mullion. See Corner Mullion Type Properties on page 647.
L corner mullion between 2 curtain walls

- **V Corner Mullion**: Panels of curtain walls or sloped glazing meet the sides of the mullion legs. You can specify the length and thickness of the mullion legs in the type properties of the mullion.

- **Trapezoid Corner Mullion**: Panels of curtain walls or sloped glazing meet at the sides of the mullion. You can specify the center width and length along the sides that meet the panels in the type properties of the mullion.

- **Quad Corner Mullion**: Panels of curtain walls or sloped glazing meet at the sides of the mullion legs. You can specify the depth of the mullion in 2 segments. 
  - If the 2 mullion segments are equal and the join is not 90 degrees, the mullion has a kite shape:
  - If the join angle is 90 degrees and the segments are unequal, the mullion is a rectangle:
  - If the 2 segments are equal and the join angle is 90 degrees, the mullion is a square:
NOTE The quad corner mullion differs from a rectangular non-corner mullion because the curtain panels join at adjacent sides of the quad corner mullion.

TIP The offset for corner mullions is relative to the panels.

Mitered Mullions on Curtain Walls

If you join 2 curtain walls with horizontal mullions, the mullions miter at the join.

Mitered mullions on arc curtain wall

Mitered mullions between 2 joined curtain walls

NOTE Mullions also miter on sloped glazings.

Changing Mullion Material

1 In the drawing area, select a mullion.
2 On the Properties palette, click Edit Type.
3 Select a mullion material from Materials and Finishes.
   You can create a new mullion material if one does not exist. See Materials on page 1573.
4 Click OK.

NOTE Changing the material for a mullion family type changes the material for all mullions of that type. If the material changes affect the mullions on only one curtain wall, create and apply a new mullion family type.
Mullion Profiles

You can vary the shape of mullions by loading new mullion profiles into a project. Also, you can create a custom profile.

Revit Structure provides some templates for mullion profile families. By default, these templates reside in the following location:

- **Windows XP**: `C: \ Documents and Settings \ All Users \ Application Data \ Autodesk \ <product and release> \ <Metric or Imperial> \ Library \ Profiles \ Curtain Wall`
- **Windows Vista or Windows 7**: `C: \ ProgramData \ Autodesk \ <Revit release name> \ <Imperial or Metric> \ Library \ Profiles \ Curtain Wall`

For more information, see The Families Guide on page 680.

Applying a Mullion Profile

1. In the drawing area, select a mullion on the model, or click Architect & Site tab ➤ Architect panel ➤ Mullion.
2. On the Properties palette, click Edit Type.
3. In the Type Properties dialog, under Construction, select a profile, and click OK.

Creating a Mullion Profile

You can create a custom profile for a mullion. For more information about creating a profile family, see The Families Guide on page 680.

Mullion profile families can include detail components that are displayed when the mullion intersects the cut plane of the view. You can specify the visibility of the detail components to display at various detail levels.

For example, you might specify the detail component to display at fine and medium detail levels. When you load the mullion into the project and place it in a plan view with a coarse detail level, the plan view might show only the profile sketch. You could then create a section detail of the mullion and specify its detail level as fine. The detail components would be displayed in this view, offering greater detail of the construction of the mullion. For more information, see Managing Family Visibility and Detail Level on page 1619.

Detail components are shown only when the mullion is cut by the view plane in floor/ceiling plan views and section/elevation views.

**TIP** When you use a profile in a project, the curtain panels are trimmed to where the profile sketch intersects the center (front/back) reference plane in the profile family. To change where the curtain panels stop, you can move this plane to cut the profile at the desired width, and reload the family.

Curtain Systems

A curtain system is a component that comprises panels, curtain grids, and mullions. It usually does not have a rectangular shape. You can create a curtain system by selecting element faces. After you create a curtain system, you can add curtain grids and mullions using the same technique as curtain walls.
You cannot create a wall or a roof as a curtain system.

**Curtain Systems by Face**

To create a curtain system by face, you select the faces of massing elements or a generic model family. For more information, see *Modeling by Face* on page 1356.

**Adding Curtain Grids to a Curtain System**

**NOTE** This procedure assumes that you have created a curtain system without automatic grid creation. To use automatic grid creation, see *Type-Driven Curtain Element Layout* on page 648.

1. Click Architect & Site tab ➤ Architect panel ➤ Curtain Grid.
2. Open a 3D view.
3. As you place the cursor along system edges, a temporary grid line is displayed; click to place the grid lines.

**TIP** When you place curtain grid lines on a curtain system, the cursor snaps to the intersection of the boundary lines and any other line or reference plane.

Revit Structure automatically fills in each section of the grid (design unit) with a separate curtain wall panel.

**Adding Mullions to a Curtain System**

Add mullions to a grid if needed for the design.

1. Click Architect & Site tab ➤ Architect panel ➤ Mullion.
2. Highlight the grid line to which to add the mullions, and click to select it.
**TIP** Hold *Shift* to place a mullion only on the selected segment. Or hold *Ctrl* to place mullions on all open grid segments.

The mullion is sized to the grid line, and is split at intersections with mullions.

You can change the properties of mullions. For a complete list of mullion properties and their values, see **Common Mullion Type Properties** on page 645. See also **Mullions** on page 635.

### Curtain Element Properties

### Curtain Wall Properties

Parameter names, values, and descriptions for curtain walls. Values are modifiable.

<table>
<thead>
<tr>
<th>Curtain Wall Type Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Construction</strong></td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Indicates the purpose of a wall: exterior, interior, retaining, foundation,</td>
</tr>
<tr>
<td></td>
<td>soffit, or core-shaft. Function can be used in scheduling and to create</td>
</tr>
<tr>
<td></td>
<td>filters that simplify a model when exporting.</td>
</tr>
<tr>
<td>Automatically Embed</td>
<td>Indicates whether the curtain wall automatically embeds into the wall.</td>
</tr>
<tr>
<td>Curtain Panel</td>
<td>Sets the curtain panel family type for the curtain element.</td>
</tr>
<tr>
<td>Join Condition</td>
<td>Controls which mullions break at intersections on a curtain element type.</td>
</tr>
<tr>
<td></td>
<td>For example, this parameter makes all horizontal or vertical mullions on a</td>
</tr>
<tr>
<td></td>
<td>curtain wall continuous, or it can make mullions on Grid 1 or Grid 2</td>
</tr>
<tr>
<td></td>
<td>continuous on a curtain system or sloped glazing.</td>
</tr>
<tr>
<td><strong>Vertical/Horizontal Grid Pattern</strong></td>
<td></td>
</tr>
<tr>
<td>Layout</td>
<td>Sets an automatic vertical/horizontal layout for curtain grid lines along</td>
</tr>
<tr>
<td></td>
<td>the length of a curtain wall. When set to a value other than None, Revit</td>
</tr>
<tr>
<td></td>
<td>Structure automatically adds vertical/horizontal grid lines to a curtain</td>
</tr>
<tr>
<td></td>
<td>wall. Fixed Distance indicates that the curtain grids are placed at the</td>
</tr>
<tr>
<td></td>
<td>exact value specified for Vertical/Horizontal Spacing. If the spacing is</td>
</tr>
<tr>
<td></td>
<td>not an even factor of the wall’s length, Revit Structure inserts space at</td>
</tr>
<tr>
<td></td>
<td>one or both ends of the wall, depending on the justification parameter.</td>
</tr>
<tr>
<td></td>
<td>For example, if the wall is 46 feet and the vertical spacing is 5 feet and</td>
</tr>
<tr>
<td></td>
<td>the justification is set to beginning, Revit Structure adds 1 foot from the</td>
</tr>
<tr>
<td></td>
<td>beginning of the wall before placing the first grid. See the Vertical/</td>
</tr>
<tr>
<td></td>
<td>Horizontal Justification instance property description for more information</td>
</tr>
<tr>
<td></td>
<td>on justification. Fixed Number indicates that you can set different numbers</td>
</tr>
<tr>
<td></td>
<td>of curtain grids for different curtain wall instances. See the Vertical/</td>
</tr>
<tr>
<td></td>
<td>Horizontal Number instance property description for more information.</td>
</tr>
<tr>
<td></td>
<td><strong>Maximum Spacing</strong> indicates that the curtain grids are placed at even</td>
</tr>
<tr>
<td></td>
<td>intervals along the length of the curtain wall at a distance up to the</td>
</tr>
<tr>
<td></td>
<td>value specified for Vertical/Horizontal Spacing.</td>
</tr>
<tr>
<td>Spacing</td>
<td>Enabled when Layout is set to Fixed Distance or Maximum Spacing. When the</td>
</tr>
<tr>
<td></td>
<td>layout is set to a fixed distance, Revit Structure uses the exact value for</td>
</tr>
<tr>
<td></td>
<td>Spacing.</td>
</tr>
</tbody>
</table>

642 | Chapter 31  Curtain Elements
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>When the layout is at a maximum spacing, Revit Structure uses up to the specified value to lay out the grids.</td>
</tr>
<tr>
<td>Adjust for Mullion Size</td>
<td>Adjusts the position of type-driven gridlines to ensure that curtain panels are of equal size, whenever possible. Sometimes when mullions are placed, particularly on borders of curtain hosts, it can result in panels of unequal size, even if the Layout is set to Fixed Distance.</td>
</tr>
<tr>
<td>Vertical Mullions</td>
<td></td>
</tr>
<tr>
<td>Interior Type</td>
<td>Specifies the mullion family for interior vertical mullions.</td>
</tr>
<tr>
<td>Border 1 Type</td>
<td>Specifies the mullion family for vertical mullions on the left border.</td>
</tr>
<tr>
<td>Border 2 Type</td>
<td>Specifies the mullion family for vertical mullions on the right border.</td>
</tr>
<tr>
<td>Horizontal Mullions</td>
<td></td>
</tr>
<tr>
<td>Interior Type</td>
<td>Specifies the mullion family for interior horizontal mullions.</td>
</tr>
<tr>
<td>Border 1 Type</td>
<td>Specifies the mullion family for horizontal mullions on the left border.</td>
</tr>
<tr>
<td>Border 2 Type</td>
<td>Specifies the mullion family for horizontal mullions on the right border.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the curtain wall keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>The model type for the curtain wall. May not be applicable.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Manufacturer for the stair materials. May not be applicable.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Specific comments on the curtain wall type.</td>
</tr>
<tr>
<td>URL</td>
<td>A link to a web page for the manufacturer or other appropriate link.</td>
</tr>
<tr>
<td>Description</td>
<td>A description for the curtain wall.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the assembly based on the assembly code selection.</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code selected from hierarchical list.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>A value to designate the particular curtain wall. Useful if you need to identify more than one curtain wall. This value must be unique for each curtain wall in a project. Revit Structure warns you if the number is already used but allows you to continue using it. (You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.)</td>
</tr>
<tr>
<td>Fire Rating</td>
<td>The fire rating of the curtain wall.</td>
</tr>
<tr>
<td>Cost</td>
<td>Material cost.</td>
</tr>
</tbody>
</table>
## Curtain Wall Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Base Constraint</td>
<td>The base level of the curtain wall. For example, Level 1.</td>
</tr>
<tr>
<td>Base Offset</td>
<td>Sets the curtain wall's height from its base constraint. This property is available only when the Base Constraint is set to a level.</td>
</tr>
<tr>
<td>Base is Attached</td>
<td>Indicates whether the base of the curtain wall is attached to another model component, such as a floor. This is a read-only value.</td>
</tr>
<tr>
<td>Top Constraint</td>
<td>Curtain wall height extends to the value specified in Unconnected Height.</td>
</tr>
<tr>
<td>Unconnected Height</td>
<td>The height of the curtain wall when it is sketched.</td>
</tr>
<tr>
<td>Top Offset</td>
<td>Sets the curtain wall's offset from the top level.</td>
</tr>
<tr>
<td>Top is Attached</td>
<td>Indicates whether the curtain wall top is attached to another model component, such as a roof or ceiling. This is a read-only value.</td>
</tr>
<tr>
<td>Room Bounding</td>
<td>If selected, the curtain wall is part of a room boundary. If not selected, the curtain wall is not part of a room boundary. This property is</td>
</tr>
<tr>
<td></td>
<td>read-only before creating a curtain wall. After you draw the wall, you can select it and then modify this property.</td>
</tr>
<tr>
<td>Related to Mass</td>
<td>Indicates that the element was created from a mass element. This is a read-only value.</td>
</tr>
<tr>
<td><strong>Vertical/Horizontal Grid Pattern</strong></td>
<td></td>
</tr>
<tr>
<td>Number</td>
<td>If Layout (under Vertical/Horizontal Grid Pattern) is set to Fixed Number, enter a value here for the number of curtain grids on the curtain</td>
</tr>
<tr>
<td></td>
<td>instance. The maximum value is 200.</td>
</tr>
<tr>
<td>Justification</td>
<td>Determines how Revit Structure adjusts the spacing of grids along the curtain element face, when the grid spacing does not divide evenly into</td>
</tr>
<tr>
<td></td>
<td>the length of the face. Justification also determines which gridlines are first removed or added when gridlines are added or removed because</td>
</tr>
<tr>
<td></td>
<td>of parameter changes or changes to the size of the face. <strong>Beginning</strong> adds space to the end of the face before placing the first grid. **</td>
</tr>
<tr>
<td></td>
<td>Center** adds an even amount of space at both the beginning and end of the face. <strong>End</strong> adds space from the beginning of the face before</td>
</tr>
<tr>
<td></td>
<td>placing the first grid.</td>
</tr>
<tr>
<td>Angle</td>
<td>Rotates the curtain grids to the specified angle. You can also specify this value for individual faces. If you specify this parameter for a</td>
</tr>
<tr>
<td></td>
<td>face, then no value displays in this field. Valid values are between 89 and –89.</td>
</tr>
<tr>
<td>Offset</td>
<td>Starts grid placement at the specified distance from the justification point of the grids. For example, if Justification is specified as</td>
</tr>
<tr>
<td></td>
<td>Beginning and you enter a value of 5 feet here, Revit Structure places the first grid 5 feet from the beginning of the face. Note that you can</td>
</tr>
<tr>
<td></td>
<td>also set this value for individual faces. If you specify this parameter for a face, then no value displays in this field.</td>
</tr>
</tbody>
</table>
Name | Description
--- | ---
Structural

Structural Usage | Sets the structural usage of the curtain wall. This property is read-only before creating a curtain wall. After you draw the curtain wall, you can select it and then modify this property.

Dimensions

Length | The length of the curtain wall. This is a read-only value.
Area | The area of the curtain wall. This is a read-only value.

Identity Data

Comments | Specific comments about the curtain wall.
Mark | Sets a label for the curtain wall. This value must be unique for each curtain wall in a project. Revit Structure warns you if the number is already used but allows you to continue using it. (You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.)

Phasing

Phase Created | The phase when the curtain wall was created.
Phase Demolished | The phase when the curtain wall was demolished.

Common Mullion Type Properties

Name | Description
--- | ---
Material | Sets the mullion material type.

Constraints

Angle (not available for corner mullions) | Rotates the mullion profile. Works as an adjustment to the Position parameter. Note that this parameter is not enabled for circular mullions.
Offset | Sets the offset from the panels in the curtain element.

Construction

Profile (not available for corner mullions) | Sets a profile for the mullion. You can create a custom profile family. See The Families Guide on page 680.
Position (not available for corner mullions) | Rotates the mullion profile. Normal to Face is the usual condition. Parallel to Ground is appropriate for sloped curtain panels, such as in a sloped glazing or a sloped curtain system.
## Circular Mullion Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offset</td>
<td>Sets the offset from the panels in the curtain element.</td>
</tr>
<tr>
<td>Radius</td>
<td>Sets the radius for the circular mullions.</td>
</tr>
</tbody>
</table>

## Rectangular Mullion Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Angle</td>
<td>Rotates the mullion profile. Works as an adjustment to the Position parameter.</td>
</tr>
<tr>
<td>Offset</td>
<td>Sets the offset from the panels.</td>
</tr>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Profile</td>
<td>Sets a profile for the mullion. You can create a custom profile family. See The Families Guide on page 680.</td>
</tr>
<tr>
<td>Position</td>
<td>Rotates the mullion profile. Normal to Face is the usual condition. Parallel to Ground is appropriate for sloped curtain panels, such as in a sloped glazing or a sloped curtain system.</td>
</tr>
<tr>
<td>Corner Mullion</td>
<td>Indicates whether the mullion is a corner mullion. See Corner Mullions on page 637.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Sets the thickness. If you have a loaded a custom profile, this value is calculated from the mullion profile.</td>
</tr>
<tr>
<td>Materials and Finishes</td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>The material for the mullion.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Width on side 2</td>
<td>Sets the width of side 2. If you have a loaded a custom profile, this value is calculated from the mullion profile.</td>
</tr>
<tr>
<td>Width on side 1</td>
<td>Sets the width of side 1. If you have a loaded a custom profile, this value is calculated from the mullion profile.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Add or edit the mullion keynote. Click in the value box to open the Keynotes dialog. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>Definition of the mullion.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Definition of the mullion manufacturer.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Mullion comments.</td>
</tr>
</tbody>
</table>
Corner Mullion Type Properties

This topic contains information on the properties for L and V corner, trapezoid corner, and quad corner mullions.

L and V Corner Mullions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corner Mullion</td>
<td>Sets the mullion to corner mullion. This is a read-only value.</td>
</tr>
<tr>
<td>Leg 2</td>
<td>Length of second leg of mullion.</td>
</tr>
<tr>
<td>Leg 1</td>
<td>Length of first leg of mullion.</td>
</tr>
<tr>
<td>Offset</td>
<td>Sets the offset from the panels.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Sets the thickness.</td>
</tr>
</tbody>
</table>

Trapezoid Corner Mullions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corner Mullion</td>
<td>Sets the mullion to corner mullion. This is a read-only value.</td>
</tr>
<tr>
<td>Center Width</td>
<td>Width of mullion at the center.</td>
</tr>
<tr>
<td>Depth</td>
<td>Length of the sides of the mullion that meet the panels.</td>
</tr>
<tr>
<td>Offset</td>
<td>Sets the offset from the panels.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Sets the thickness.</td>
</tr>
</tbody>
</table>
### Quad Corner Mullions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corner Mullion</td>
<td>Sets the mullion to corner mullion. This is a read-only value.</td>
</tr>
<tr>
<td>Depth 2</td>
<td>Length of second leg of mullion.</td>
</tr>
<tr>
<td>Depth 1</td>
<td>Length of first leg of mullion.</td>
</tr>
<tr>
<td>Offset</td>
<td>Sets the offset from the panels.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Sets the thickness.</td>
</tr>
</tbody>
</table>

### Mullion Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comments</td>
<td>Specific comments about the mullions.</td>
</tr>
<tr>
<td>Length</td>
<td>Maximum length of the mullion. For example, on a mitered mullion, the value is the pre-cut length. This is a read-only value.</td>
</tr>
<tr>
<td>Mark</td>
<td>Sets a label for the mullions. This value must be unique for each mullion in a project. Revit Structure warns you if the number is already used but allows you to continue using it. (You can see the warning using the Review Warnings tool. See Reviewing Warning Messages on page 1680.)</td>
</tr>
</tbody>
</table>

### Type-Driven Curtain Element Layout

You can specify a curtain element layout for walls, sloped glazing, and curtain systems. By specifying the layout by type, you can place many instances that already have panels, grids, and mullions on them.

You create a curtain grid layout by specifying a combination of type and instance parameters that affect the faces of the curtain element, as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Automatically Embed (curtain walls only)</td>
<td>Determines whether the curtain wall embeds into other walls.</td>
</tr>
<tr>
<td>Curtain Panel</td>
<td>Specifies the curtain panel family type for the curtain element.</td>
</tr>
<tr>
<td>Join Condition</td>
<td>Controls which mullions break at intersections on a curtain element type.</td>
</tr>
<tr>
<td></td>
<td>For example, use this parameter to make all horizontal or vertical mullions on a curtain wall continuous, or to make mullions on grid 1 or grid 2 continuous on a curtain system or sloped glazing.</td>
</tr>
</tbody>
</table>

*Vertical Grid Pattern* (for curtain walls) or *Grid 1 Pattern* (for curtain systems and sloped glazing)
NOTE These descriptions apply to the Horizontal Grid Pattern or Grid 2 Pattern.

**Layout**
规定的自动布局沿长度方向沿幕面的网格线。当你指定除None外的值时，Revit Structure将自动为幕元素添加网格线。**Fixed Distance**表示网格线被放置在指定的间距参数Spacing的精确值。如果间距不是长度的整数倍，Revit Structure根据对齐参数在面的两端插入一个或多个空格。

**Spacing**
当布局设置为固定距离或最大间距时，启用。当布局设置为固定距离时，Revit Structure使用间距参数Spacing指定的精确值。当布局设置为最大间距时，Revit Structure使用最大间距值来布局网格。

**Adjust for Mullion Size**
调整类型驱动网格线的位置，以确保幕面板尽可能相等。有时，当梁被放置在幕主机的边界上时，可以导致面板不相等，即使布局设置为固定距离。

**Vertical Mullions** (for curtain walls) or **Grid 1 Mullions** (for curtain systems and sloped glazing)

- **Interior Type**
  指定内部垂直梁的梁族。

- **Border 1 Type**
  指定左侧边界垂直梁的梁族。

- **Border 2 Type**
  指定右侧边界垂直梁的梁族。

**Horizontal Mullions** (for curtain walls) or **Grid 2 Mullions** (for curtain systems and sloped glazing)

- **Interior Type**
  指定内部水平梁的梁族。

- **Border 1 Type**
  指定左侧水平梁的梁族。

- **Border 2 Type**
  指定右侧水平梁的梁族。

**Instance Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Vertical Grid Pattern</strong></td>
<td></td>
</tr>
</tbody>
</table>

**NOTE** 这些参数描述适用于Horizontal Grid Pattern实例参数。

- **Number**
  如果布局设置为Fixed Number，则输入幕实例的网格数。最大值为200。
Determines the spacing of grids along the curtain element face, when grid spacing does not divide evenly into the face length value. Justification also determines which grid lines are first removed or added when the number of grid lines changes because of parameter changes or changes to the size of the face. **Beginning** adds space to the end of the face before placing the first grid. **Center** adds an even amount of space at both the beginning and end of the face. **End** adds space from the beginning of the face before placing the first grid.

**Angle**
Rotates the curtain grids to the specified angle. If you specify this value for individual faces, no value is displayed in this field. Valid values are between 89 and –89.

**Offset**
Starts grid placement at the specified distance from the justification point of the grids. For example, if Justification is specified as Beginning and you enter 5’ for offset, the first grid is placed 5’ from the beginning of the face. If you specify offset for a face, no value is displayed in this field.

**Measurement Line (curtain system only)**
An imaginary line that defines the point from which to measure grid spacing on faces where grid spacing may not be the same across the length of grid lines. Where grids intersect this line, the distance between the grids is equal to the grid spacing value (for Fixed Distance layouts) or up to the grid spacing value (for Maximum Spacing layouts). Where the grids do not intersect this line, the grids can be placed at values either higher or lower than the value for Spacing.

### Troubleshooting Curtain Elements

Read the following topics to learn about issues with curtain walls, mullions, curtain panels, and other curtain elements.

### Switching Wall Type to Family Curtain Wall

**Warning**: Switching wall type to family curtain wall. All dimension references to the side faces of the wall will be deleted.

**Issue**: You have placed permanent linear dimensions between wall faces and then changed one of the walls to a curtain wall. You lose those dimensions.

**Solution**: You will not lose dimensions between wall centerlines, if you change one wall to a curtain wall. See **Placing Permanent Dimensions** on page 889.

### Invalid Curtain Panel

**Warning**: There is an invalid curtain panel in the model. This is probably caused by two grid lines almost meeting at a border of the curtain wall or sloped glazing, but not exactly at a point. The curtain panel cannot be displayed.

**Issue**: Typically, this problem occurs in a panel on a sloped glazing. A horizontal and vertical curtain grid on a panel are not meeting exactly at a point, creating a small triangular panel within the main panel; the triangular panel cannot be accurately regenerated because it is too small. This message displays when the program regenerates the curtain panel.
**Solution:** Cancel the placement and/or the movement of the panel. When dividing the panels in a sloped glazing/wall, it is best to start with the placement of horizontal curtain grids and then snap vertical grids to the horizontal grid. This ensures the grids meet at a point and eliminates the creation of a small panel.

**No Curtain Panel Families Loaded**

**Error:** No curtain panel families loaded. Cannot make arced curtain wall.

**Issue:** You are sketching a curtain wall and then try to unload it as you are creating it, or you sketch a curtain wall and with the wall tool active, you unload curtain walls.

**Solution:** If you unload curtain walls, you may be unable to draw another wall, until you reload at least one curtain wall panel.

**Non-System Panel Families**

**Warning:** Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.

**Issue:** A non-system panel, such as a glazed or empty panel, cannot have a non-rectangular shape.

**Solution:** This problem might occur if a curtain wall with non-system panels joins to a roof, and the curtain wall does not have a rectangular shape. It would also occur if you create a non-rectangular wall profile and then change that wall to a curtain wall with non-system panels.

**Cannot Divide Curtain Grid by Grid Line**

**Error:** Cannot divide curtain grid by grid line.

**Issue:** You placed a curtain grid on a sloped glazing, such that the curtain grid division results in a complex piece of geometry that Revit Structure cannot produce.

**Solution:** There is no work-around. You must cancel the action.

**Supported for Non-Rectangular Curtain Walls**

**Warning:** Currently, only straight walls with straight or arc edges are supported for non-rectangular curtain walls.

**Issue:** A curtain wall contains an ellipse in one of its sides. This problem could happen if the wall joins to a roof with an ellipse.

**Solution:** Cancel the action. This type of curtain wall is not supported.
Design Options

After designing the majority of a project, use design options to develop alternative designs in the project. For example, you can use design options to adapt to changes in project scope, review other designs, or show variations to a client.

Design Option Overview

With design options, a team can develop, evaluate, and redesign building components and rooms within a single project file. Some team members can work on specific options, such as variations of a lobby, while the rest of the team continues with the main model.

Design options can vary in complexity. For example, a designer may want to explore alternatives for entry designs or structural systems for a roof. Design options tend to become more focused and simplified as a project progresses. They are typically used as follows:

- Changing the entry design
- Exploring different layouts for rooms or furniture
- Trying different window configurations
- Developing sustainable design alternatives

You can use design options to explore multiple designs as the project develops. At any time in the design process, you can have multiple sets of design options. Typically, each set of design options addresses a particular issue or area. For example, to explore possibilities for a pergola and sunshade for a roof terrace, you can create an option set called Roofing with multiple roofing designs (Sunscreens or Louvers). In addition, you can create an option set called Roof Structure with multiple structural designs (Brackets or Beams). After the final design is chosen, you can incorporate the chosen options into the main model and remove the alternatives.
Design Option Workflow

In general, the process of using design options is as follows:

1. Decide on the areas for which you want to develop design options.
Example: You want to create one set of design options for the entry of a building and a second set of design options for the roof.

2 Create the building model, including all elements that will be common to all of the design options. (This is the main model.)
Example: Create the building first, including the foundation, floor, walls, and other parts of the building. Do not include any elements that will belong to the entry or the roof; those elements will be added using design options.

**NOTE** If you add elements to a building and later decide that those elements should be part of a design option, you can move them to the design option. See Moving Elements from the Main Model to a Design Option Set on page 661.

3 Create a design option set for each area.
Example: You create one design option set named Entry and another design option set named Roof. For instructions, see Creating Design Option Sets on page 657.

4 For each design option set, edit the primary option.
When you create a design option set, Revit Structure also creates a primary option for the set. The primary option is typically the preferred design or the design that you think will be chosen. It will be displayed in project views by default. Other design options will appear in views only when you specify. Edit the primary option to add elements to the design as desired. (See Editing a Design Option on page 659.) For an alternative approach, see Viewing the Main Model Without Design Options on page 668.

5 Create secondary options for each design option set.
You can create one or more secondary options for each set. See Adding Design Options on page 658.
Example: For the Entry option set, you create secondary options named Revolving Door and Two Double Doors.
In general, any elements that will be modified or referenced in an option should belong to the design option instead of the main model. See Referencing Elements in Design Options on page 670 and Moving Elements from the Main Model to a Design Option Set on page 661.

6 Create views that display each design option.
By default, all project views display the main model with primary design options only. To see secondary options, create project views that show them. (These are called dedicated views.) You can then place these views on sheets to present the designs to clients. See Dedicating Views to Design Options on page 667.

7 Incorporate a design option into the main model.
After the client has selected the desired option for each option set, you can incorporate the selected designs into the main model. This process deletes the design option set, so the other options in the set are no longer available, and the selected option becomes part of the building model. See Incorporating a Design Option into the Main Model on page 666.

---

### Design Options Terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main model</td>
<td>The parts of the building model that are not defined using design options. The main model is the entire building model, excluding any design options.</td>
</tr>
<tr>
<td>Design option set</td>
<td>A collection of alternatives that addresses a particular design problem, such as a lobby or a floor layout. See Creating Design Option Sets on page 657.</td>
</tr>
</tbody>
</table>
### Best Practices for Design Options

When implementing design options, consider the following strategies:

**To prepare the main model for design options**

In the main model create as much of the model as possible before adding any design options. Include elements that will be common to all design options. Use design options for only those parts of the model that will vary.

**To create a design option**

1. Create a design option set. See *Creating Design Option Sets* on page 657.
2. Add the design option. See *Adding Design Options* on page 658.
3. Add elements to the design option. See *Editing a Design Option* on page 659.

**To facilitate cleanup**

If main model elements need to clean up connections with secondary design option elements, move those elements from the main model to one or more design options in the set. You cannot join the geometry of elements that are part of a secondary option with elements that are part of the main model. For example, if walls in the main model need to attach to a roof in Roof Option 2, move the walls from the main model into Roof Option 2.

See *Design Options and Wall Joins* on page 671, *Referencing Elements in Design Options* on page 670, and *Moving Elements from the Main Model to a Design Option Set* on page 661.
To see and compare design options

Do either of the following:

- Change the design option settings for a view. See Checking the Design Option Settings for a View on page 669.
- For each design option that you want to compare, dedicate a view to the option. You can place these views on sheets for side-by-side comparisons or to show the design options to clients. See Dedicating Views to Design Options on page 667 and Viewing Multiple Design Options on page 668.

To detail or annotate a design option

Dedicate a view to the option. Then add details or annotations to the view. Details and annotations are view-specific; they belong to a view, not to a design option. See Annotating and Detailing Design Options on page 664.

To create schedules for design options

Create the desired schedule, duplicate it, and dedicate one schedule to each design option. Each schedule lists elements from the main model and elements from the specified design option. You create schedules that are dedicated to design options in the same way that you create dedicated views. See Dedicating Views to Design Options on page 667.

To incorporate a design option

After a design option is selected for implementation, incorporate it into the main model and delete all other options using the Accept Primary function. See Incorporating a Design Option into the Main Model on page 666.

Creating Design Option Sets

You begin the design option process by creating design option sets. A design option set is a collection of alternatives that address a particular design problem. For example, you can create one design option set to show different designs for the entry of a building. You can create another design option set for alternative roof configurations. Each design option set contains one primary option and one or more secondary options.

To create a design option set

1 Click Manage tab ➤ Design Options panel ➤ (Design Options).
2 In the Design Options dialog, under Option Set, click New.
   By default, Revit Structure names the new set Option Set 1 and creates a primary option in the set.
3 To rename the option set, select the option set name, and under Option Set, click Rename. Enter a name, and click OK.
4 To rename the primary option, select its name, and under Option, click Rename. Enter a name, and click OK.
5 Click Close.

Now you can edit the primary design option to add elements to it, and create secondary options for the design option set. See Editing a Design Option on page 659 and Adding Design Options on page 658.

By default, project views show the main model with the primary option for each set. If you want project views to show the main model only, with no design options, see Viewing the Main Model Without Design Options on page 668. To see a list of design option sets and design options defined for a project, click the Design Options drop-down list on the status bar.

Adding Design Options

A design option is one possible solution for a particular design issue. Each design option set contains one primary option and one or more secondary options. When you create a set, Revit Structure also creates a primary option, which you must edit to add its elements. (See Editing a Design Option on page 659.) Use the following procedure to add secondary design options.

To add a design option

1 Click Manage tab ➤ Design Options panel ➤ (Design Options).
2 In the Design Options dialog, in the left-hand list, select the design option set to which you want to add an option.
3 Under Option, click New.
   The default option name displays under the option set.
4 To rename the option, select the option name, and under Option, click Rename. Enter a name, and click OK.
5 If you want this design option to be the primary option for the design set, click Make Primary.
   The Make Primary button promotes a secondary option to the primary option. The former primary option becomes a secondary option.

NOTE Use caution with Make Primary, because references from the main model to the former primary option can be lost. After using Make Primary, check dimension references and tags to be sure they are referencing the correct elements. See Referencing Elements in Design Options on page 670.
To open the design option for editing, do the following:

a Select the design option in the list, and click Edit Selected.

b Click Close.

In the current view, elements in the main model display in halftone to distinguish them from the design option that you are editing. For further instructions, see Editing a Design Option on page 659.

TIP If the current view does not show the active option, check its design option settings. (See Checking the Design Option Settings for a View on page 669.) For the appropriate design option set, specify Automatic, or select the desired design option.

If the design option that you just created is a primary option, by default it displays in all project views that are not dedicated to other design options. If the option is secondary, it does not appear in any project views by default. See Viewing Design Options on page 667.

Working with Design Options

The following topics describe how to modify and work with design options.

Editing a Design Option

1 In the Project Browser, open a view where you can add the desired elements for the design option.

2 Prepare the view to show the active design option:

a Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).

b In the Visibility/Graphics dialog, click the Design Options tab.

c For the appropriate design option set, in the Design Option column, select Automatic.

d Click OK.

3 Open the design option for editing.

To open a design option for editing

Do one of the following:

■ On the status bar, select the design option from the drop-down list.
  If the status bar does not display the active design option, enable this feature by clicking View tab ➤ Windows panel ➤ User Interface drop-down ➤ Status Bar - Design Options.

■ Click Manage tab ➤ Design Options panel ➤ (Design Options). In the Design Options dialog, select the design option from the list, click Edit Selected, and click Close.

■ Click Manage tab ➤ Design Options panel, and select the desired design option from the drop-down list.
Click Manage tab ➤ Design Options panel ➤ (Pick to Edit), and select an element contained in the design option. Revit Structure determines the design option to which the selected element belongs, and makes that design option active for editing.

4 Edit the design option as desired.

The model elements that you add now belong to the active option. For tips on using design options in various ways, see Considerations When Using Design Options on page 670.

**NOTE** You cannot add view-specific elements (such as keynotes, dimensions, and tags) to a design option. Instead, dedicate a view to the design option, and add the view-specific elements to the dedicated view. See Annotating and Detailing Design Options on page 664.

While you are editing the design option, you can move among project views as needed. When you change to a different view, you may need to change the design option settings for the view to see the active option. (See Checking the Design Option Settings for a View on page 669.)

5 When you are finished editing the design option, select Main Model from the Design Options drop-down list on the status bar.

**Related topics**

- Viewing Design Options on page 667
- Working with Design Options on page 659
- Best Practices for Design Options on page 656
- Considerations When Using Design Options on page 670

**Determining the Active Option**

The active option is the design option that is currently being edited. If you are editing an option, the current view displays the main model and the active option.

**TIP** If the current view does not show the active option, check its design option settings. (See Checking the Design Option Settings for a View on page 669.) For the appropriate design option set, specify Automatic, or select the desired design option.

To determine whether you are currently editing a design option, use one of the following methods:

- **Status bar:** Check the status bar. It indicates the active design option. If the status bar displays Main Model, you are not currently editing a design option.

  ![B-331](image)

  If the status bar does not display the active design option, enable this feature by clicking View tab ➤ Windows panel ➤ User Interface drop-down ➤ Status Bar - Design Options.

- **Ribbon:** Click Manage tab ➤ Design Options panel. The drop-down list indicates the design option that is currently being edited. Changes that you make will affect the active option.
If the drop-down list displays Main Model, you are not currently editing a design option.

Related topics
- Editing a Design Option on page 659
- Selecting Elements in Design Options and the Main Model on page 663

Promoting a Secondary Option to the Primary Option

The primary option is the preferred design option in the set. Elements in the main model and in the primary option can reference each other. (See Referencing Elements in Design Options on page 670.)

Only one design option in a set can be the primary option. All other options are secondary. By default, each project view displays both the main model and the primary option for each set.

If you want to promote a secondary option to be the primary option, be aware that Revit Structure attempts to move relationships from the former primary option to the new primary option. For example, suppose you create a dimension from a main model wall to a primary option wall. In a secondary option, the same wall has been moved slightly. When you promote the secondary option to be the primary option, Revit Structure displays the same dimension between the main model wall and the moved wall. The dimension is updated to show the correct distance between the walls.

To promote a secondary option to be the primary option

1. Click Manage tab ➤ Design Options panel ➤ (Design Options).
2. In the Design Options dialog, select the secondary design option to promote.
3. Under Option, click Make Primary.

Revit Structure promotes the selected secondary option to be the primary option. The Design Options dialog lists the design option with **(primary)** after its name. The former primary option is now a secondary option.

**NOTE** If you encounter the error message Elements in main model will be deleted, see Troubleshooting Issues with Design Options on page 673 for instructions.

4. Click Close.
5. In project views that display the main model with the new primary option, check dimension references and tags to be sure they are referencing the correct elements.

Moving Elements from the Main Model to a Design Option Set

The main model consists of the entire building model, excluding elements in any design options.
Elements in the main model cannot host or reference elements in secondary options. Therefore, elements in the main model do not change their shape or properties when you are looking at a view for a secondary option. For example:

- If you sketch 4 walls in the main model and then sketch a roof in a secondary option, you cannot attach the walls to the roof.
- To add a skylight to a design option, the host roof must also be part of the design option.

If main model elements need to reference and update with elements in a secondary option, you must move the main model elements into that design option. Then you can edit the design option to modify those elements as desired. (See Referencing Elements in Design Options on page 670.)

**To move elements from the main model to a design option set**

1. Open a project view that shows the elements to be moved.
2. Click Manage tab ➤ Design Options panel, and select Main Model from the drop-down list.
3. Select the main model elements to move.
4. Click Manage tab ➤ Design Options panel ➤ (Add to Set).
5. In the Add to Design Option Set dialog, for Add selection to, select the desired set.
6. Select one or more design options to which you want to add the elements.
   - If you clear a check box, the elements are not added to the corresponding design option.
7. Click OK.

Copies of the original elements are now in all selected design options in the set. The original elements are no longer part of the main model.

**TIP** You can also add elements to a single design option by cutting the elements from the main model and pasting them into the same place in the design option. Use the Cut and Paste Aligned tools, as described in Moving Elements from One Design Option to Another on page 662.

---

**Moving Elements from One Design Option to Another**

**NOTE** You can also use this technique to move an element from the main model to a design option, as an alternative to the method described in Moving Elements from the Main Model to a Design Option Set on page 661.

1. Open a project view that will show the elements to move.
   - If the elements belong to a secondary option, they may not be visible yet.
2. Prepare the view to show the active design option:
   a. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
   b. In the Visibility/Graphics dialog, click the Design Options tab.
   c. For the appropriate design option set, in the Design Option column, select Automatic.
   d. Click OK.
3 Click Manage tab ➤ Design Options panel. From the drop-down list, select the design option in which the elements reside.

4 In the drawing area, select one or more elements, and press Ctrl+X (Cut).

See Selecting Elements in Design Options and the Main Model on page 663 and Selecting Elements on page 1439.

5 Click Manage tab ➤ Design Options panel. From the drop-down list, select the design option to which you want to add the elements.

6 Click Modify <Element> tab ➤ Clipboard panel ➤ Paste drop-down ➤ (Aligned to Same Place).

Revit Structure moves the selected elements to the active option.

7 To finish editing the active option, click Manage tab ➤ Design Options panel, and select Main Model from the drop-down list.

Selecting Elements in Design Options and the Main Model

To avoid unintended results or confusion, when you are editing a design option, Revit Structure prevents you from selecting elements in the main model. Similarly, when you are editing the main model, the software prevents you from selecting elements in a design option. However, you can explicitly allow these functions, if needed (for example, to add dimensions between a main model element and a design option element).

To select elements in design options when editing the main model

■ On the status bar, clear Exclude Options. Now you can select the desired elements from the design option.

This option is available when you are viewing the main model and a design option but not editing the design option.

To select elements in the main model when editing a design option

■ On the status bar, clear Active Only. Now you can select elements in the main model and other option sets.

This option is available when you are editing a design option.

To determine the design option to which an element belongs

1 Move the cursor over the element to highlight it.
2 If the element does not highlight when you move the cursor over it, on the status bar, clear Exclude Options or Active Only. Then move the cursor over it again.

The status bar and tooltip for the highlighted element indicate the category, family, and type of the element. If the element belongs to a design option, they also indicate the design option set and the design option to which the element belongs, using the following format:

(<design option set> : <design option>) : <category> : <family> : <type>

If the element belongs to the main model, the status bar and the tooltip do not show design option information.
Duplicating a Design Option

Suppose you are creating a series of design options, and several elements will be common to many of them. In this case, you can create a design option that contains all of the common elements, then create copies of it, and modify the individual design options to develop each design further. This strategy can streamline the process of developing design options and reduce duplication of effort.

To duplicate a design option

1. Create the design option and add the elements that will be common to multiple design options. See Adding Design Options on page 658.

2. Click Manage tab ➤ Design Options panel ➤ (Design Options).

3. In the Design Options dialog, select the design option from the list.

4. Under Option, click Duplicate.

   Revit Structure creates a copy of the selected design option named Copy of <design option>.

5. To rename the duplicate design option, select the option name, and under Option, click Rename. Enter a name, and click OK.

6. If needed, repeat steps 4 and 5 to create more copies of the design option.

Now you can edit the duplicate design options to modify them as desired. Changes made to a duplicate design option affect only that design option. See Editing a Design Option on page 659.

Annotating and Detailing Design Options

Annotations and details (such as keynotes, dimensions, and tags) are view-specific elements. They cannot be part of a design option. To document a design option, first dedicate one or more views to the option. (See Dedicating Views to Design Options on page 667.) Then add the desired annotations and details to the dedicated views. (See Annotating on page 887.)

If you want similar views for each option to have similar documentation and details, use the following procedure.

To create duplicate detailed views for design options

1. In a view that shows the main model and a design option, add the annotations and details that you want to appear in similar views for all design options.

2. With the view active in the drawing area, click View tab ➤ Create panel ➤ Duplicate View drop-down ➤ (Duplicate with Detailing).

   This tool creates a copy of the view, including annotations and details. Repeat this step to create a copy of the view for each design option.

3. Dedicate each duplicate view to a different design option. (See Dedicating Views to Design Options on page 667.)

4. Rename each duplicate view to indicate the design option that it displays. (See Renaming Views on page 817.)

5. In the view for each design option, modify the annotations and details as appropriate.

   If you add a new annotation or detail to a dedicated view, it displays in that view only.

6. (Optional) For side-by-side comparisons of the design options, add a sheet, and add the views to the sheet.
Deleting Design Options and Option Sets

When you delete a single design option, Revit Structure removes the following from the project:

- All elements that belong to the design option.
- All views whose Visible in Option property specifies the design option. (See Deleting Views Associated with Design Options on page 666.)
- (Optional) Views that are dedicated to the design option; that is, views whose design option settings include the design option. (See Checking the Design Option Settings for a View on page 669.) When you delete a design option, Revit Structure displays a list of these dedicated views. You can instruct Revit Structure to delete these views or to preserve them.

When you delete a design option set, Revit Structure removes all of its design options, their elements, and associated views (as for deleting a design option).

If you are ready to incorporate a design option into the main model, do not use these Delete procedures for the undesired options. Instead, see Incorporating a Design Option into the Main Model on page 666 for instructions.

**NOTE** You cannot delete a primary option. If you want to delete a primary option, you must first demote it to a secondary option (by promoting a secondary option to be primary). When the undesired option is a secondary option, you can then delete it. See Promoting a Secondary Option to the Primary Option on page 661. If you want to delete a primary option, and it is the only option in the set, delete the design option set.

**To delete a design option**

1. Click Manage tab ➤ Design Options panel ➤ (Design Options).
2. If you are currently editing a design option, click Finish Editing.
3. In the Design Options dialog, select the design option to delete.
4. Under Option, click Delete.
5. If the design option has one or more dedicated views (or views for which the Visible in Option property is set), the Delete Dedicated Option Views dialog lists the associated views. Do the following:
   a. Clear the check boxes for any views that you do not want to delete.
      For these views, the design option settings on the Visibility/Graphics dialog will be changed to Automatic for the related design option set.
   b. Click Delete to delete the design option and the selected views.

Revit Structure deletes the selected design option and the selected views.
To delete a design option set

1. Click Manage tab ➤ Design Options panel ➤ (Design Options).
2. If you are currently editing a design option, click Finish Editing.
3. In the Design Options dialog, select the design option set to delete.
4. Under Option Set, click Delete.
5. At the confirmation prompt, click Yes.
6. If the design options in the set have dedicated views (or views for which the Visible in Option property is turned on), the Delete Dedicated Option Views dialog lists the associated views. Do the following:
   a. Clear the check boxes for any views that you do not want to delete.
   b. Click Delete to delete the design options in the set and the selected views.

Revit Structure deletes the entire design option set, including all of its design options, their elements, and the selected views.

Deleting Views Associated with Design Options

To indicate that a view should be deleted when a design option is deleted, specify the Visible in Option property for the view. The Visible in Option property provides a way to associate a view with a particular design option, even when the view's design option settings specify multiple design options (one for each set).

When you delete a design option, Revit Structure displays a list of the views to be deleted. See Deleting Design Options and Option Sets on page 665.

To set the Visible in Option property for a view

1. In the Type Selector of the Properties palette, select the view name.
2. Under Graphics, locate the Visible in Option property.
3. For Visible in Option, click in the Value column, and select the desired design option from the list.

You can select only one design option for one set.

Incorporating a Design Option into the Main Model

After choosing a design option to implement, you can incorporate it into the main model and delete other options that are no longer necessary.

NOTE Accepting the primary option deletes all secondary options and the design option set. You can undo this action, but you should be sure that you do not need any other options. Consider making a backup copy of the project before proceeding.

To incorporate a design option into the main model

1. Click Manage tab ➤ Design Options panel ➤ (Design Options).
2. If you are currently editing a design option, click Finish Editing.
3. In the Design Options dialog, select the design option set that includes the desired option.
4 If the desired option is secondary, select the design option in the list, and click Make Primary to promote it to the primary option.

5 Under Option Set, click Accept Primary to incorporate the primary option into the main model. Revit Structure prompts you to confirm this action.

6 Click Yes.

   Revit Structure incorporates the primary option into the main model and deletes the design option set.

7 Click Close.

   If you need to undo this action, on the Quick Access toolbar, click (Undo).

### Viewing Design Options

When you create a design option set, Revit Structure displays the main model and the primary option in all project views by default. To see secondary options with the main model, you must do one of the following:

- Edit the option.
- Change a view’s display option settings.
- Dedicate views to the design option.

### Dedicating Views to Design Options

To see secondary options with the main model, create duplicate views that are dedicated to those options. These views are called dedicated views. A dedicated view typically displays a specified design option for each set.

You can dedicate all kinds of views (including schedules) to a specified design option. For example, you can create one schedule for the primary option and another schedule for a secondary option. Each schedule lists elements that are in the main model as well as elements that are in the specified design option.

#### To create a dedicated view

1. Open a view that you want to dedicate to a design option.

   By default, the view displays the primary option with the main model.

2. In the Project Browser, right-click the view name, and do the following.

<table>
<thead>
<tr>
<th>If you want the duplicate view to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>include model elements only, with no annotations or detailing,</td>
<td>click Duplicate View ➤ Duplicate.</td>
</tr>
<tr>
<td>include model elements as well as annotations and details from the original view,</td>
<td>click Duplicate View ➤ Duplicate with Detailing.</td>
</tr>
</tbody>
</table>

   Revit Structure creates a duplicate view.

3. Rename the duplicate view, using a name that indicates the design options displayed in the view.

   For example, the following 3D view names indicate the design options that will be displayed in each view. (See Renaming Views on page 817.)
4 Specify design options for the view, as follows:
   a  In the Project Browser, right-click the duplicate view name, and click Properties.
   b  In the Properties palette, for Visibility/Graphics Overrides, click Edit.
      The Visibility dialog displays the Design Options tab. It lists each design option set, and, for each set, the design option that the view is currently displaying.
      A value of Automatic indicates the following:
         ■ When no design option is being edited, the view displays the primary option.
         ■ When a design option is being edited, the view displays the active option.
   c  For each design option set, select the design option to display in this view.
      If you have created multiple design option sets, the view displays one option for each set.
      The view displays the main model and a selected design option for each set.

5 Repeat Steps 2–4 for each combination of design options that you want to show in individual views.

For each dedicated view, you can now do the following:
   ■ Modify the view, for example, to add annotations and details for design options. See Annotating on page 887.
   ■ Modify a design option. See Editing a Design Option on page 659.
   ■ Place the view on a sheet to share the design options with clients. See Sheets on page 978.

Related topics
   ■ View Tags in Dedicated Views for Design Options on page 669
   ■ Deleting Views Associated with Design Options on page 666

Viewing the Main Model Without Design Options

If you want to be able to view the main model only, with no design options, create an empty design option and make it the primary option. (See Adding Design Options on page 658.) If you are using multiple design option sets, create an empty option for each set, and make it the primary option for each set.

By default, all project views will then display the main model only. To display other design options, see Viewing Design Options on page 667.

Viewing Multiple Design Options

A project view can display only one design option for each set. To view and compare design options side-by-side, dedicate a view to each design option. (See Dedicating Views to Design Options on page 667.) Then place the views on a sheet. (See Adding Views to a Sheet on page 980.)
Checking the Design Option Settings for a View

1 Open a project view in which you want to see or edit a design option.
2 Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
3 In the Visibility/Graphics dialog, click the Design Options tab.
   The tab lists each design option set, and, for each set, the option that the view is currently displaying.
   A value of Automatic indicates the following:
   ■ When no design option is being edited, the view displays the primary option.
   ■ When a design option is being edited, the view displays the active option.
4 If the desired design options are not selected, select the appropriate design option for each set, and click OK.
   The view is now dedicated to the selected design options.

View Tags in Dedicated Views for Design Options

View tags are the symbols that represent other views or drawings, such as elevations, callouts, and sections. For example, in a floor plan, the following symbol indicates an elevation. (For more information about view tags, see Section, Elevation, and Callout View Tag Setup on page 862.)

You can control whether these tags are visible in views based on design options. For example, if a section view applies only to Option 1, the section tag should not appear in a view that is dedicated to Option 2.

The visibility of a view tag is determined by a property called Visible in Option.

■ If you create a view while editing the main model, Visible in Option (for the view tag) is set to All. The tag is visible in the view for all design options.
■ If you create a view while you are editing a design option, the view tag’s Visible in Option property is set to the active option. If you change the value of Visible in Option, the view tag is visible in views for the specified option only.

For example, if you create an elevation to display a particular design option, you may want to specify that its elevation tag is visible in a floor plan that is dedicated to the design option.

Changing the Visibility of a View Tag for Design Options

1 Open a project view in which the view tag displays.
2 Check the design option settings for the view. (See Checking the Design Option Settings for a View on page 669.) For the design option set, select the design option that you plan to assign to the view tag.
3 In the project view, select the view tag to display its properties in the Properties palette.

NOTE: If the Visible in Option property does not display in the Properties palette, you may not have selected the entire view tag. See Selecting View Tags on page 863.
For Visible in Option, do the following:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>make the view tag visible for all design options</td>
<td>select All.</td>
</tr>
<tr>
<td>make the view tag visible for one option only</td>
<td>select that design option.</td>
</tr>
</tbody>
</table>

## Considerations When Using Design Options

The following topics describe important considerations when working with design options.

### Unsupported Elements for Design Options

**Levels:** You cannot add levels to a design option. If you add a level to a building model while you are editing a design option, Revit Structure adds the level to the main model. The level displays in halftone, indicating that it is not part of the design option. (See Halftone/Underlay on page 1605.)

**Views:** You cannot add views to a design option. However, you can dedicate views to design options.

**Annotations and details:** You cannot add view-specific elements (such as annotations and details) to a design option. View-specific elements belong to the views in which they are created.

If you add a view-specific element while you are editing a design option, Revit Structure adds the element to the current view, not to the design option. The view-specific element displays in halftone, indicating that it is not part of the design option. To see the view-specific element and the design option, change the design option settings for the view. (See Checking the Design Option Settings for a View on page 669.)

To annotate or detail a design option, dedicate a view to the option. Then add annotations and details to the view. (See Annotating and Detailing Design Options on page 664.) View-specific elements can reference elements in a design option. For example, you can dimension elements in a design option.

### Referencing Elements in Design Options

In Revit Structure, elements can reference each other in many ways, including the following:

- Explicit constraints (such as locked alignments and dimensions) guarantee that the defined relationships will be maintained. Conflicts cause errors and must be resolved.
- Looser constraints (such as dimensions and alignments that are not locked) are often maintained unless a conflict occurs, in which case these constraints may be removed without notice.
- Implied constraints (such as a wall attached to a roof, or 2 walls joined at a corner) are also maintained unless a conflict occurs.

These explicit and implied constraints require that each element knows about the other. That is, one element must reference the other element.

When you are referencing elements in design options, consider the following guidelines:

- Elements in the main model and in the primary option can reference each other.
- Elements in a secondary option can reference elements in the main model. See Selecting Elements in Design Options and the Main Model on page 663.
- Elements in the main model cannot reference elements in a secondary option. Therefore, elements in the main model do not change their shape or properties when you are editing a secondary option.
example, if you sketch 4 walls in the main model and then sketch a roof in a secondary option, the walls do not regenerate and attach to the roof.

- If main model elements need to update with and reference elements in secondary options, move the main model elements into each design option (or selected options) in the design option set. Then edit each design option to modify those elements as desired for each design. See Moving Elements from the Main Model to a Design Option Set on page 661.

- View-specific elements can reference elements in design options. For example, you can dimension elements in a view that is dedicated to a design option. See Annotating and Detailing Design Options on page 664.

**Interdependent Elements in Design Options**

Elements that depend on another element must be in the same design option. Interdependent elements include the following:

- Inserts that cut their hosts
- Host sweeps and their hosts (such as wall sweeps and walls)
- Topographical surfaces and building pads
- Curtain panels, mullions, and grids

If you add the host to a design option, the hosted element is automatically included. If you try to add the hosted element without the host, Revit Structure warns you that the host must also be added.

When you create groups or arrays, selected elements must be in the active option. If no design option is active, they must be in the main model.

If you add elements to a group, the elements must be in the same design option as the group.

**Design Options and Worksets**

You can enable worksharing so that team members can work on different parts of a project at the same time. For a workshared project, all design options and design option sets are included in a Project Standards workset called Design Options. (See Setting Up Worksets on page 1212.)

To edit an element in a design option, the element and its design option must be editable. See Borrowing Elements on page 1219.

**Design Options and Wall Joins**

The cleanup of joins between walls in the main model and walls in the primary option works the same way as when all walls are in the main model. To avoid incorrect wall joins between the main model and secondary options, move the wall from the main model to the design option set. See Moving Elements from the Main Model to a Design Option Set on page 661.
Walls in the main model

A wall added in the primary option; join cleans up properly

A wall in a secondary option joined to the main model

To avoid the above problem with wall joins in a secondary option, add the horizontal wall to that option. The wall join then cleans up properly, as shown. See *Working with Wall Joins* on page 457.
Troubleshooting Issues with Design Options

The following topics provide information about issues, errors, and warnings that you may encounter when working with design options.

Elements in Main Model Will Be Deleted

**Issue:** This error may occur when you attempt to promote a secondary option to be the primary option. An element (or dimension or other object) in the main model conflicts with an object in the secondary option that is being promoted.

**Solution:**

1. In the error dialog, click Expand, and then expand the error messages until you can identify the objects that are causing the error.
2. Select the check boxes for the objects.
3. At the bottom of the error dialog, click Delete and Make Primary.

Following this procedure usually resolves the conflicts by deleting the objects and replacing them with the same or similar objects defined in the newly promoted design option. If you continue to have problems, contact customer support.

Highlighted Elements Overlap

**Issue:** This warning may occur when you copy an element from the main model to a design option. In this case, the element exists in the main model and in the design option. As a result, these 2 elements overlap.

**Solution:** To resolve the issue, delete the element from the main model or from the design option.

If you tried to move an element from the main model to a design option, cut the element from the model (instead of copying the element), or use the Add to Set tool. See Moving Elements from One Design Option to Another on page 662 or Moving Elements from the Main Model to a Design Option Set on page 661.

Incorrect Wall Joins

**Issue:** Walls in the main model can join with walls in a primary option. However, main model walls cannot join with walls in a secondary option.

**Solution:** If wall joins are not behaving as expected, consider whether the walls need to be moved from the main model to one or more secondary options.

See Design Options and Wall Joins on page 671 and Moving Elements from the Main Model to a Design Option Set on page 661.

Inserts in Design Options

**Issue:** The following message displays: An insert in a design option cannot be hosted by an element in the main model.

This error occurs when you try to add a hosted component to a design option without its host. In order for a hosted component to be part of a design option, its host must also be part of the design option. The host cannot belong to the main model.
The error can also appear when you try to move a hosted component from the main model to a design option without its host. (See Interdependent Elements in Design Options on page 671 and Moving Components to Different Hosts on page 507.)

**Solution:** To resolve the issue, move the host element to the design option. Then you will be able to add the hosted component to the design option. See Moving Elements from the Main Model to a Design Option Set on page 661.

If you later incorporate the selected design option into the main model, the host element again becomes part of the main model. See Incorporating a Design Option into the Main Model on page 666.

---

**None of the Created Elements Are Visible in This View**

**Issue:** This error occurs when you add an element to a design option, but the element will not be visible in the current view. This may be due to visibility of elements for the view or design option settings for the view.

**Solution:** To resolve the issue, try the following:

- **Check visibility of elements in the view.**
  
  Click View tab ➤ Graphics panel ➤ (Visibility/Graphics). On the Model Categories tab and Annotation Categories tab, check the Visibility settings for the types of elements that you added. If visibility for these elements is turned off, select the Visibility check box to make them visible. See Visibility and Graphic Display in Project Views on page 801.

- **Check design option settings for the view.**
  
  Click View tab ➤ Graphics panel ➤ (Visibility/Graphics). On the Design Options tab, check the settings for each design option set. If they are not set to Automatic or to the active option, change the settings. See Checking the Design Option Settings for a View on page 669.

---

**None of the Selected Elements Can Be Added to This Option Set**

**Issue:** This error appears when you have attempted to move an element from the main model to one or more design options.

**Solution:** Expand the error message to determine a more specific cause and possible solutions.

---

**Option Conflict Between Rooms**

**Issue:** This warning appears when either of the following occurs:

- You add a room to the primary option, and the main model already contains a room in the same space.
- You add a room to the main model, and the primary option already contains a room in the same space.

**Solution:** To resolve the issue, delete the room from the main model or from the primary option. If the room should be defined in the primary option instead of the main model, see Moving Elements from the Main Model to a Design Option Set on page 661.
Room Option Conflict

**Issue:** This message appears in a drawing when conflicts occur between rooms in the main model and rooms in a secondary design option.

For example, if the main model contains rooms, and you place rooms into the same space in a design option, the boundaries of the rooms in the main model might overlap the boundaries of the rooms in the design option.

For example, suppose the main model contains the following room.

When a room is added to a design option, the room tag reports an option conflict.

**NOTE** If you have created a room schedule, the Room Area column in the schedule also displays an Option Conflict.

To learn the cause of the option conflict, select the room tag in the plan view, or, in a room schedule, select a cell in a row that shows a conflict. Then click Modify | Room Tags tab ➤ Warning panel ➤ (Show Related Warnings). A warning dialog displays, which you can expand to read about the conflict and learn possible remedies for it.

**Solution:** In general, to correct room option conflicts, add the conflicting main model room to the design option set. This removes the room from the main model and resolves the conflict. See Moving Elements from the Main Model to a Design Option Set on page 661.
Revit Families

All of the elements that you add to your Revit projects – from the structural members, walls, roofs, windows, and doors that you use to assemble a building model to the callouts, fixtures, tags, and detail components that you use to document it – are created with families.

By using predefined families and creating new ones in Revit Structure, you can add both standard and custom elements to your building models. Families also provide a level of control over elements that are similar in use and behavior, allowing you to easily make design changes and manage your projects more efficiently.

For complete information about creating, modifying, and working with families, download the Revit Structure Families Guide, which contains detailed conceptual information, tutorials, and information about best practices. For more information, see The Families Guide on page 680.

Families Overview

A family is a group of elements with a common set of properties, called parameters, and a related graphical representation. Different elements belonging to a family may have different values for some or all of their parameters, but the set of parameters (their names and meanings) is the same. These variations within the family are called family types or types.

For example, the Structural Column category includes families and family types that you can use to create different wide flanged, precast concrete, angle, and other columns. Although these families serve different purposes and are composed of different materials, they have a related use. Each type in the family has a related graphical representation and an identical set of parameters, called the family type parameters.

When you create an element in a project with a specific family and family type, you create an instance of the element. Each element instance has a set of properties, in which you can change some element parameters independent of the family type parameters. These changes apply only to the instance of the element, the single element in the project. If you make any changes to the family type parameters, the changes apply to all element instances that you created with that type.

For complete information about creating, modifying, and working with families, download the Revit Structure Families Guide, which contains detailed conceptual information, tutorials, and information about best practices. For more information, see The Families Guide on page 680.
Different Kinds of Families

There are 3 kinds of families in Revit Structure:

- system families
- loadable families
- in-place families

Most elements that you create in your projects are system families or loadable families. Loadable families can be combined to create nested and shared families. Non-standard or custom elements are created using in-place families.

System Families

System families create basic building elements such as walls, roofs, ceilings, floors, and other elements that you would assemble on a construction site. System settings, which affect the project environment and include types for levels, grids, drawing sheets, and viewports, are also system families.

System families are predefined in Revit Structure. You do not load them into your projects from external files, nor do you save them in locations external to the project.

Loadable Families

Loadable families are families used to create both building components and some annotation elements. Loadable families create the building components that would usually be purchased, delivered, and installed in and around a building. They also include some annotation elements that are routinely customized, such as symbols and title blocks.

Because of their highly customizable nature, loadable families are the families that you most commonly create and modify in Revit Structure. Unlike system families, loadable families are created in external RFA files and imported, or loaded, in your projects. For loadable families that contain many types, you can create and use type catalogs, which allow you load only the types that you need for a project.

In-Place Families

In-place elements are unique elements that you create when you need to create a unique component that is specific to the current project. You can create in-place geometry so that it references other project geometry, resizing or adjusting accordingly if the referenced geometry changes. When you create an in-place element, Revit Structure creates a family for the in-place element, which contains a single family type.

Creating an in-place element involves many of the same Family Editor tools as creating a loadable family. For detailed information about Revit Structure families, see The Families Guide on page 680.

Family Editor

The Family Editor is a graphical editing mode in Revit Structure that allows you to create and modify families to include in your project. When you start creating a family, you open a template to use in the editor. The template can include multiple views, such as plans and elevations. The Family Editor has the same look and feel as the project environment in Revit Structure, but it features different tools. The availability of tools depends on the type of family you are editing.
Before you use the Family Editor to edit or create a family, you should learn about families. See The Families Guide on page 680.

To learn how to start the Family Editor, see Opening the Family Editor on page 679.

Opening the Family Editor

You use the Family Editor to make changes to existing families or to create new families. The method you use for opening the Family Editor depends on what you want to do.

You use the Family Editor to create and edit loadable families and in-place elements. The tabs and panels change depending on the type of family that you are editing. You do not use the Family Editor to edit system families.

Before you edit or create a family, you should become familiar with families. See The Families Guide on page 680.

To edit a family from a project

Do one of the following:

- Select an instance of the family in the drawing and click Modify | <Element> tab ➤ Mode panel ➤ (Edit Family).
- In the Project Browser, right-click the family and click Edit.
To edit a loadable family outside a project

1. Click ➤ Open ➤ Family.
2. Browse to the file containing the family, and click Open.

To create a loadable family from a template file

1. Click ➤ New ➤ Family.
2. Browse to the template file, and click Open.

To create an in-place element

1. Click Home tab ➤ Model panel ➤ Component drop-down ➤ (Model In-Place).
2. In the Family Category and Parameters dialog, select the family category, and click OK.
3. Enter a name for the in-place element family, and click OK.

To edit an in-place element

1. Select the in-place element in the drawing.
2. Click Modify | <Element> tab ➤ Model panel ➤ (Edit In-Place).

The Families Guide

The Revit Structure Families Guide provides detailed information about working with families and creating custom content. The Families Guide includes the following information:

- how to use families in your projects
- concepts of parametric design and family creation
- best practices to use when creating your own families

The Families Guide contains conceptual explanations, procedures, and reference information.

To access the Revit Structure Families Guide, click (Help) drop-down ➤ Documents on the Web.

Working with Families

This topic covers tasks that are commonly performed when working with families. For detailed information about families, see The Families Guide on page 680.

Viewing Families in a Project or Template

You can view all the families that are available in a project using the Project Browser on page 28. Families are listed by category and type in the Project Browser.

For detailed information about families, see The Families Guide on page 680.

To view the families in a project or template

1. Open a project or a template.
2 In the Project Browser, expand Families.
   A list of all families in the project (or template) displays. The list includes system families,
   loadable families, and in-place families.

3 Expand the family category that contains the family types that you want to view.
   In most cases, one or more families display under the family category.

4 Expand the family to view the family types.

Viewing Elements with a Specific Family Type in a Project

You can highlight all the elements in a view or in the entire project that use a specific family type.

1 Open a project view.
2 In the Project Browser, expand Families.
3 Expand the component category and family that contains the type that you want to select.
4 Select the desired type, right-click, and click one of the following:
   ■ Select All Instances ➤ In Entire Project.
   ■ Select All Instances ➤ Visible in View.

NOTE If the current project does not contain any elements that use that family type, the Select All
   Instances tool is unavailable.

All elements in the view that use the family type are highlighted.
In the lower-right corner of the Revit window, the number of selected elements in the project
displays.

5 If you selected to view all instances in the entire project, open other project views.
   Any of the elements that use the family type are highlighted.

6 Press Esc to restore the original display of the elements.

Creating an Element from a Family Type

Use this procedure to create an instance of a system family or loadable family using the Project Browser. For
information about creating an element from an instance in a project, see Copying Elements with the Create
Similar Tool on page 1497.

For detailed information about creating families and family elements, see The Families Guide on page 680.

To create an element from a family type

1 Do one of the following:
   ■ On the Home tab, click the element that you want to create.
   ■ Select the family type in the Project Browser, and drag it to the drawing area.
   ■ Select the family type in the Project Browser, right-click, and click Create Instance.

2 In the Type Selector, select the type of element that you want to create.
   The list displays the available family types first by family or subfamily and then by type, separated
   by a colon.

3 On the Options Bar, specify any necessary values or selections.
4 In the drawing area, click to place the element.

5 Create another element, or click Modify.

Changing the Family Type of an Element

To change the family type of an element in the drawing area of a project, do one of the following:

- Select the element and change the family type using the Type Selector on page 35.
- Change the family type using the Match Type Properties tool. See Changing Element Types Using the Match Type Tool on page 1497.

For detailed information about families and family types, see The Families Guide on page 680.

Modifying a Family Type

You can access the properties of a family type in the Project Browser or from an element that uses that type in a current project. For detailed information about modifying families, see The Families Guide on page 680.

To modify a family type

1 Do one of the following:
   - In the Project Browser, under Families, right-click the family type, and click Properties.
   - Select an element in the project, and on the Properties palette, click Edit Type.

2 In the Type Properties dialog:
   - Change parameter values as desired.
     The parameters that display vary depending on the family type that you are modifying.
   - If desired, in the upper-right corner, click Rename, and enter a new name.

3 Click OK to exit.

If you are modifying a family type in a project, any instances of elements with the same family type in the project update to reflect your modifications.

Editing Labeled Dimensions

In the Family Editor, you can label dimensions in the drawing area by assigning parameters to them. Dimensioned labels are dynamic; when geometry is edited directly in the drawing, its dimension label adjusts and updates the related family type parameter.

You can also assign parameters to dimensions in the conceptual design environment. See Labeled Dimensions on page 185.

Locking Dimensions

In the Family Editor, you can lock labeled dimensions to maintain the parametric relationships between labeled dimensions. This ability is also available in the conceptual design environment. See Locking Labeled Dimensions on page 186.

To lock a dimension in the drawing area, click next to the dimension.
Adding a Type to a Family

After loading a family into a project, you can create different family types from within the project.

To add a type to a family using the Project Browser

1. In the Project Browser, expand Families.
2. Expand the family category.
3. Expand the family.
4. Do either of the following:
   - Select the family, right-click, and click New Type.
   - Select a type, right-click, and click Duplicate.

   **BEST PRACTICE** To minimize type property editing, duplicate the family type that most resembles the type that you want to create.

5. Enter a new name for the type.
6. Select the type, right-click, and click Properties.
7. In the Type Properties dialog, enter new parameter values, and click OK.

To create a family type from an element in a project, see Creating a New Family Type in a Project on page 38.

Deleting Unused Families and Family Types

You can delete unused families or unused family types from your projects and templates using either of 2 methods: you can select and delete the families and types in the Project Browser, or you can run the Purge Unused tool.

Select and delete families and types when you have only a few families or types that you need to delete. Use the Purge Unused tool when you need to "clean up" your projects. Removing all of the unused families and types usually decreases the project file size.

Whichever method you use, you cannot delete the following:

- Family types that have dependencies (such as those that host other families)
- Families with types that are in use in the current project or template

For more information about deleting families, see The Families Guide on page 680.

To select and delete families and types in the Project Browser

1. In the Project Browser, expand Families.
2. Expand the category that contains the family or type that you want to delete.
3. If you want to delete a loadable family type, expand the family.
4. Select the family or type to delete.

   **TIP** To select more than one family or type, press and hold Ctrl while selecting.

5. Do either of the following:
   - Right-click, and click Delete.
   - Press Delete.
The family or type is deleted from the project or template.
If you are deleting a family or type from a project, and the project contains one or more instances of a family type, a warning displays.

To delete families and types using the Purge Unused tool

1 Click Manage tab ➤ Settings panel ➤ (Purge Unused).
The Purge unused dialog lists all the families and family types that you can unload from the project, including system and in-place families. By default, all unused families are selected for purging.

IMPORTANT If the project is workset-enabled, all worksets must be open to use this tool.

2 Do either of the following:
   ■ To purge all unused family types, click OK.
   ■ To purge only the types that you select, click Check None, expand the families and subfamilies that contain the types that you want to purge, select the types, and click OK.

System Families

System families contain family types that you use to create basic building elements such as walls, floors, ceilings, and stairs in your building models. System families also include project and system settings, which affect the project environment and include types for elements such as levels, grids, sheets, and viewports.

System families are predefined in Revit Structure and saved in templates and projects, not loaded into templates and projects from external files. You cannot create, copy, modify, or delete system families, but you can duplicate (copy) and modify the types within system families to create your own custom system family types. You can delete all but one system family type in a system family, because you need at least one type per family to create new system family types.

Although you cannot load system families into templates and projects, you can copy and paste or transfer system family types between projects and templates. You can copy and paste any number of individual types, or use a tool to transfer all types in the system families that you specify.

System families can also host other kinds of families, usually loadable families. For example, a wall system family may host a standard door/window assembly.

For detailed information about system families, see The Families Guide on page 680.

Revit System Families and Settings

Revit Structure includes the following system families and project and system settings.

System Families:

■ Ceilings
■ Curtain Systems
■ Curtain Wall Mullions
■ Detail Items
■ Floors
■ Fluids (a Revit MEP-specific family)
- Model Text
- Railings
- Ramps
- Roofs
- Site (Pad)
- Stairs
- Structural Columns
- Structural Foundations
- Structural Framing
- Structural Loads
- Structural Rebar
- Walls

**Project/System Settings:**
- Area and Volume Calculations
- Arrowheads
- Color Fill Schemes
- Detail Level
- Dimensions
- Drawing Sheets
- Elevations
- Filled Regions/Fill Patterns
- Filters
- Grids
- Keynoting
- Levels
- Lines
- Load Types
- Match Lines
- Materials
- Model Text
- Object Styles
- Phases
- Project Browser Organization
- Project Units
Workflow: Using System Families in Your Projects

System families are predefined in Revit Structure and saved in templates and projects, not loaded into templates and projects from external files. You can duplicate (copy) and modify the types within system families to create your own custom system family types.

For detailed information about system families, see The Families Guide on page 680.

Before you begin a project, use the workflow that follows to determine whether you can use existing system family types, or whether you need to create your own custom system family types.

1. Determine the system family types that your project requires.
2. Search existing system families and determine if you can find the system family types that you need in Revit Structure templates or in your office templates.
3. If you can find a system family type that is similar to the family type that you need, save design time by modifying it to meet your needs.
4. If you cannot find the system family type that you need and you cannot modify a similar family type to fit your needs, create your own system family type.

Loading System Family Types

Because system families are predefined in Revit Structure, you can only load system family types in projects or templates.

To load system family types, you can:

- copy and paste one or more selected types from one project or template to another
- transfer all system family types of a selected system family or families from one project to another

Copy and paste system family types when you only have a few system family types that you need to load between projects or templates.

Transfer system family types when you are creating a new template or project, or anytime that you need to transfer all the types of a system family or families.
NOTE When you transfer system family types, you use the Transfer Project Standards tool. You can also transfer system settings with this tool.

For information about the Transfer Project Standards tool, see Transferring Project Standards on page 1635. For detailed information about loading, copying, and transferring system family types, see The Families Guide on page 680.

Loadable Families

Loadable families are families used to create both building components and some annotation elements. Loadable families create the building components that would usually be purchased, delivered, and installed in and around a building, such as windows, doors, casework, fixtures, furniture, and planting. They also include some annotation elements that are routinely customized, such as symbols and title blocks.

Because of their highly customizable nature, loadable families are the families that you most commonly create and modify in Revit Structure. Unlike system families, loadable families are created in external RFA files and imported (loaded) in your projects. For families that contain many types, you can create and use type catalogs, which allow you load only the types that you need for a project.

When you create a loadable family, you begin with a template that is supplied in the software and contains information about the family that you are creating. You sketch the geometry of the family, use parameters to establish relationships between family components, create the variations or family types that it includes, and determine its visibility and detail level in different views. When you finish the family, you test it in a sample project before using it to create elements in your projects.

Revit Structure includes a library of content in which you can access loadable families that are supplied by the software and save the families that you create. You can also access loadable families from various sources on the Web.

Nesting and Sharing Families

You can load instances of families in other families to create new families. By nesting existing families inside other families, you can save modeling time.

Depending on how you want instances of these families to act when you add them to your projects (as a single element or as individual elements), you can specify whether the nested families are shared or not shared.

For detailed information about loadable families, see The Families Guide on page 680.

Revit Structure Standard Loadable Families

Revit Structure includes the following standard loadable families:

- Annotations
- Detail Components
- Doors
- Profiles
- Site
- Structural
- Titleblocks
- Windows
Workflow: Using Loadable Families in Your Projects

Loadable families are the most extensive and customizable families in Revit Structure. You can create your own custom families, but a number of families are ready for use in the family library and on the Web.

Before you begin a project, use the following workflow to determine whether you can use existing families, or whether you need to create your own custom families.

1. Determine the families that your project requires.
2. Search existing loadable families and determine whether you can find the families that you need in the library, on the Web, in Revit templates, or in your office templates.
3. If you find an appropriate family but not the specific type that you need, create a new type.
4. If you can find families that are similar to the families that you need, save design time by modifying existing families to your needs.
5. If you cannot find the families that you need or modify similar families to fit your needs, create your own families.

For detailed information about loadable families, see The Families Guide on page 680.

Loading and Saving Families

To use loadable families in your projects or templates, you must load (import) them with the Load Family tool. After you load a family into a project, it is saved with that project.

Some families are preloaded in the templates that are included with Revit Structure. Any projects that you create with these templates include the families loaded in the template.

You can find, preview, and load other families from the following sources:

- the Revit Structure library that is installed with the software
- other local or networked libraries
- the Revit Web Content Library (see Opening Files from the Web Library on page 84)
- Autodesk Seek (see Autodesk® Seek on page 47)
- manufacturers’ websites
- other third-party websites

Most of the families that you load from the Revit Structure library, the Revit Web Content Library, and Autodesk Seek are fully editable.

When loading large families that contain many types into a project, you can use a type catalog to load only the types that you need. Type catalogs are easy to create. By allowing you to load only selected family types, they help to keep your project sizes from growing needlessly large.

For more information about working with loadable families, see The Families Guide on page 680.

Loading Families

When you load families into a project, the Revit Structure imperial or metric family library (located in C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial or Metric Library) is accessed by default.
If your office is using a different library of content in another location, your system may access that library by default. Contact your CAD Manager for more information.

Use the following procedure to load families. For more information about loadable families, see The Families Guide on page 680.

To load families

1. Click Insert tab ➤ Load from Library panel ➤ (Load Family).
   Depending on the current drawing units (imperial or metric), the Load Family dialog lists the family categories in either the Imperial or Metric Library.

2. In the Load Family dialog, double-click the category of the family that you want to load.

3. Preview any of the families (RFA) in the category:
   - To preview a single family, select it from the list.
     At the top right of the dialog, under Preview, a thumbnail image of the family displays.
   - To display a thumbnail image in the list for all families in the category, at the top right corner of the dialog, click Views ➤ Thumbnails.

4. Select the family that you want to load, and click Open.
   The family type is now available to place in the project. It displays in the appropriate component category under Families in the Project Browser.

Related topics

- Revit Families on page 677
- Loadable Families on page 687
- Loading Families with Shared Components into a Project on page 689
- Loading a Family with a Type Catalog on page 690

Loading Families with Shared Components into a Project

You load families that contain nested components or nested and shared components into a project using the same methods as any other family. When you load a family comprised of nested components or nested and shared components into a project, the following rules apply:

- The host family, along with all nested and shared components, is loaded into the project. Each nested component is available within the Project Browser under its respective family category.
- A nested family can exist within a project and be shared by more than one host family.
- When loading shared families, if a version of one of the families already exists within the project, you have the option to use the version from the project or from the family you are loading.

**IMPORTANT** After a shared family is loaded into a project, you cannot reload an unshared version of the same family and overwrite it. You must delete the family and reload it.

To load families with shared components into a project

1. Open the project into which you want to load the family.

2. Click Insert tab ➤ Load from Library panel ➤ (Load Family).

3. In the Load Family dialog, select the family to load, and click Open.
4 Add instances of the family to your projects.

Loading a Family with a Type Catalog

When you load a family with many types into a project, using a type catalog allows you to select and load only those types that you need. The type catalog provides a dialog that lists the available family types that you can sort through and select before you load types into a project.

For information about creating a type catalog, see The Families Guide on page 680.

After you create a type catalog for a family, you can use it to load only the family types that you need into projects and templates.

To load a family with a type catalog

1 Create and place the type catalog in the same location (directory) as the family that you want to load.
2 In a Revit project or template, click Insert tab ➤ Load From Library panel ➤ (Load Family).
3 Navigate to the directory containing the family you want to open.
4 Select the family (RFA file) to load.
   The Type Catalog displays.
5 In the Type column of the Type Catalog, select the family type or types to load.
   You can select multiple types by pressing Ctrl during selection. You can also narrow the range of search items by selecting specific parameters from the list at the top of each column.
6 Click Open.

Loading the Current Family into a Project

After working in the Family Editor to create or modify a family, you can load the family into one or more open projects.

NOTE The projects into which you want to load the family must be open.

1 In the Family Editor, click Home tab ➤ Family Editor panel ➤ (Load into Project).
   If only one project is currently open, the family is loaded into that project, and the project displays in the drawing area.
2 If multiple projects are open, the Load into Projects dialog displays. Select the open projects to receive the family, and click OK.

Saving Loaded Families

You can save a family that is loaded in the current project or template as an RFA file in a location that you specify. You can save the family to a location on your system or to a network location. All family types are saved with the family.

1 Do either of the following:

   - Click ➤ Save As ➤ Library ➤ Family.
   - Right-click a family in the Project Browser, and click Save.
In the Save Family dialog:

- If you are using Save As ➤ Library ➤ Family, for Family to save, select the family from a list of families loaded in the project.
- For Save in, navigate to the location in which you want to save the family.
- Specify the name and file type for the family, and click Save.

**Reloading a Family into a Project**

1. Click Insert tab ➤ Load from Library panel ➤ (Load Family).
2. Navigate to the directory containing the family file to reload.
3. Select the family file or files and click Open. The Family Already Exists dialog displays.
4. Do one of the following:
   - Click Overwrite the existing version.
   - Click Overwrite the existing version and its parameter values. The parameter values of the existing family are overridden by the parameter values of the family you are loading.

**IMPORTANT** If the family is used in the building model and you override the parameter values of existing types, the family will update throughout the project with the new values.

- Click Cancel.

**Creating Loadable Families**

For detailed information about creating loadable families, see The Families Guide on page 680.

Depending on the complexity of the family, the creation process can be time-consuming. If you can identify a family that is similar to the one you want to create, you can save time and effort by copying, renaming, and modifying the family to create the new family.

For best results when creating a family, use the following workflow.

1. Before beginning family creation, plan your family. Identify requirements regarding family sizes, how the family displays in different views, whether a host is required, the detail level to be modeled, and the origin of the family.
2. Create a new family file with the appropriate family template.
3. Define subcategories for the family to help control the visibility of the family geometry.
4. Create the family skeleton, or framework:
   - Define the origin (the insertion point) of the family.
   - Lay out reference planes and reference lines to aid in sketching component geometry.
   - Add dimensions to specify parametric relationships.
   - Label dimensions to create type or instance parameters or 2D representation.
   - Test, or flex, the skeleton.
5. Define family type variations by specifying different parameters.
6. Add a single level of geometry in solids and voids, and constrain the geometry to reference planes.
7 Flex the new model (types and hosts) to verify correct component behavior.
8 Repeat previous steps until the family geometry is complete.
9 Specify 2D and 3D geometry display characteristics with subcategory and entity visibility settings.
10 Save the newly defined family, and then load it into a project for testing.
11 For large families that include many types, create a type catalog.

Modifying Families in a Project (or Nested Family)

For detailed information about modifying loadable families, see The Families Guide on page 680.

Within a project or family, you can edit a loaded family and reload it into the same project or any other open projects or families. Before or after reloading the family into the project, you can save the family to a library with the same name or a new name.

1 In the drawing area, select the family to edit.
2 Do either of the following:
   - Click Modify <Element> tab ➤ Mode panel ➤ (Edit Family).
   - In the drawing area or the Project Browser, right-click the family, and click Edit.
     The family opens in the Family Editor. The original project is still open in the background.
3 Modify the family.
4 If you want to save a copy of the modified family, click ➤ Save.
5 To load the family into any open projects, on any tab, click Family Editor panel ➤ (Load into Project).
6 In the Load into Projects dialog, select the projects in which you want to load the family, and click OK.
   If the family is already loaded into the project, the Family Already Exists dialog displays. Do one of the following:
   - Click Overwrite the existing version.
   - Click Overwrite the existing version and its parameter values.
     The parameter values of the existing family are overridden by the parameter values of the family you are loading.

**IMPORTANT** If the family is used in the building model and you override the parameter values of existing types, the family will update throughout the project with the new values.

- Click Cancel.

**TIP** When reloading multiple families, you can select Do this for all loading families.

7 Close the family file.

Creating Parameters

You can create new instance parameters or type parameters for any family type. By adding new parameters, you have more control over the information contained in each family instance or type. You can create dynamic family types for increased flexibility within the model.
For detailed information about family parameters, see The Families Guide on page 680.

**To create parameters**

1. In the Family Editor, click Home tab ➤ Properties panel ➤ (Family Types).
2. In the Family Types dialog, click New, and enter a name for the new type.
   This creates a new family type that will be available in the Type Selector when you load it into a project.
3. Under Parameters, click Add.
4. In the Parameter Properties dialog, under Parameter Type, select Family parameter.
5. Enter a name for the parameter.
6. Select a discipline.
7. For Type of Parameter, select the appropriate parameter type.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Completely customizable. Can be used to collect unique data.</td>
</tr>
<tr>
<td>Integer</td>
<td>A value that is always expressed as an integer.</td>
</tr>
<tr>
<td>Number</td>
<td>Used to collect miscellaneous numeric data. Can be defined by a formula. Can also have real numbers.</td>
</tr>
<tr>
<td>Length</td>
<td>Can be used to establish the length of an element or subcomponent. Can be defined by a formula. This is the default type.</td>
</tr>
<tr>
<td>Area</td>
<td>Can be used to establish the area of an element or subcomponent. Formulas can be used in this field.</td>
</tr>
<tr>
<td>Volume</td>
<td>Can be used to establish the length of an element or subcomponent. Formulas can be used in this field.</td>
</tr>
<tr>
<td>Angle</td>
<td>Can be used to establish the angle of an element or subcomponent. Formulas can be used in this field.</td>
</tr>
<tr>
<td>Slope</td>
<td>Can be used to create parameters that define slope.</td>
</tr>
<tr>
<td>Currency</td>
<td>Can be used to create currency parameters.</td>
</tr>
<tr>
<td>URL</td>
<td>Provides web link to user defined URL.</td>
</tr>
<tr>
<td>Material</td>
<td>Establishes parameters in which a specific material can be assigned.</td>
</tr>
<tr>
<td>Yes/No</td>
<td>Used most often for instance properties when the parameter is defined with either a Yes or No.</td>
</tr>
<tr>
<td>Family Type</td>
<td>Used with nested components and allows you to swap components after the family is loaded into a project.</td>
</tr>
</tbody>
</table>

8. For Group parameter under, select a value.
   After the family is loaded into a project, this value determines which group header the parameter displays under on the Properties palette.
9 Select either Instance or Type. This defines whether the parameter is an Instance or Type parameter.

10 Optionally, if you selected Instance in step 9, you can select Reporting Parameter. See Reporting Parameters on page 1550.

11 Click OK.

NOTE To assign a material to a family element, save the family and load it into a project. Place the family in the project and select it. On the Family Properties panel, click Types and set a value for the material parameter.

Creating Family Parameter Links

By linking family parameters, you can control the parameters of families nested inside host families from within a project view. You can control instance parameters or type parameters.

To link parameters, they must be the same type. For example, link a text parameter in the host family to a text parameter in the nested family.

You can link a host-family parameter to more than one nested family parameter of the same type. Also, you can link this parameter to multiple nested families.

To create family parameter links

1 Create a family with instance parameters or type parameters of the available types.
2 Save the family and load it into a host family.
3 With the new family open, click Home tab ➤ Model panel ➤ (Component), and place as many instances of the loaded family as desired.
4 Click Modify tab ➤ Properties panel ➤ (Family Types).
5 In the Family Types dialog, under Parameters, click Add.
6 Follow the steps for creating a new parameter of the same type as the parameter you want to control in the nested family.
7 Click OK to close the Family Types dialog.
8 Select an instance of the loaded family in the host family.
9 To edit an instance property, use the Properties palette on page 34. To edit a type property, click Modify <Element> tab ➤ Properties panel ➤ (Type Properties).

For instance properties and type properties, the column on the right has an equal sign (=) in the column heading. Gray buttons next to certain parameters indicate that they can be linked to other parameters.

10 Click the button next to a parameter that is of the same type as the one you created in Step 6. For example, if you created a text parameter, you must select a text parameter here.
11 In the dialog that displays, select the parameter you created in Step 6 to associate it with the current parameter, and click OK.

NOTE When you associate 2 parameters, an equal sign appears on the button: =

12 Click Apply in the Properties palette, or OK to close the Type Properties dialog.
13 Continue creating the host family, and save it.
14 Load the family into a project, and place a few instances of it.
15 Select an instance of the family.
16 Locate the type or instance property you created.
   To edit an instance property, use the Properties palette on page 34. To edit a type property, click Modify <Element> tab ➤ Properties panel ➤ (Type Properties).
17 Specify the desired value, and click Apply in the Properties palette or OK in the Type Properties dialog.
   The nested family changes according to the value you entered.

Family Category and Parameters

The Family Category and Parameters tool assigns the properties of a predefined family category to the component you are creating. The tool is only available within the Family Editor. If the Always Vertical parameter is selected, this means the family always appears vertical at 90 degrees, even if it is on a sloping host.

1 In the Family Editor, click Home tab (or Modify tab) ➤ Properties panel ➤ (Family Category and Parameters).
2 From the dialog, select a family category whose properties you want to import into the current family.
3 Specify the family parameters.

   NOTE Family parameter options vary depending on family category.

4 Click OK.

Related Topics

- Structural Column Family Parameters on page 222
- Structural Framing Tag Families on page 262

Working with Shared Components in a Project

A family that contains nested and shared families works as any other family within a project. However, you can press Tab to toggle to the nested and shared components.

If you select a nested instance, you can do the following:

- On the Properties palette on page 34, modify some parameters, such as Mark and Comments.
- On the Properties palette, click (Edit Type), and modify type properties. When you do this, all instances of that type also update to reflect the changes.

If you select a nested instance, you cannot do the following:

- Select and delete a nested instance.
- Mirror, copy, move, or array a nested instance.
  If you do this, the entire host family adapts, not just the nested instance.
- Modify the position, the size, or shape of a nested instance.
In-Place Elements

In-place elements are custom elements that you create in the context of a project. Create an in-place element when your project needs unique geometry that you do not expect to reuse or geometry that must maintain one or more relationships to other project geometry.

You can create multiple in-place elements in your projects, and you can place copies of the same in-place element in your projects. Unlike system families and loadable families, however, you cannot duplicate in-place family types to create multiple types.

Although you can transfer or copy in-place elements between projects, you should do so only when necessary, because in-place elements can increase file size and degrade software performance.

Creating an in-place element involves many of the same Family Editor tools as creating a loadable family. For detailed information about creating in-place elements, see The Families Guide on page 680.

Workflow: Working with In-place Elements

In-place elements are custom elements that you create in the context of a project. Create an in-place element when a project requires unique geometry that you do not expect to reuse or geometry that must maintain one or more relationships to other project geometry.

For detailed information about in-place elements, see The Families Guide on page 680.

1. Identify any unique or single-use element that your project requires. If your project requires an element that will be used in more than one project, create it as a loadable family.
2. If your project requires an in-place element that exists in another project (or is similar to one that exists in another project) you can copy the in-place element into your project or load it into your project as a group.
3. If you cannot find an in-place element that meets your needs, create a new in-place element in the project.

Creating an In-Place Element

For detailed information about creating in-place elements, see The Families Guide on page 680.

1. In a project, click Home tab ➤ Model panel ➤ Component drop-down ➤ (Model In-Place).
2. In the Family Category and Parameters dialog, select a category for the element, and click OK.
   The category that you choose will be the category under which the family for the in-place element will display in the Project Browser, in which it will schedule, and in which you can control its visibility.
3. In the Name dialog, type a name, and click OK.
   The Family Editor opens.
4. Use the Family Editor tools to create the in-place element.
5. When you finish creating the in-place element, click Finish Model.

Connectors

Knowing how to add and remove connectors to loadable families can be useful to architects when using building components, such as manufactured items from Inventor®, or when exporting a building site to civil engineering applications, such as Civil 3D®. For example, you might want to add, move, or delete a
connector for a pipe that connects a custom vanity designed in Inventor to a plumbing system in Revit MEP. Or, you might want to modify the connectors on site utilities, such as gas or water connections, before they are exported with the building site. After the building site is imported into Civil 3D, the connectors on the site utilities become fully functional.

When you add connectors to a family, you can specify one of the following disciplines:

- **Duct connectors** are associated with ductwork, duct fittings, and other elements that are part of the air handling systems.

- **Electrical connectors** are used for any type of electrical connections, including power, telephone, alarm systems, and others.

- **Pipe connectors** are used for piping, pipe fittings, and other components that are meant for transmitting fluids.

- **Cable tray connectors** are used for cable tray, cable tray fittings, and other components that are meant for wiring.

- **Conduit connectors** are used for conduit, conduit fittings, and other components that are meant for wiring. A conduit connector can be an individual connector or a surface connector. The individual connector is used for connecting only one conduit. The surface connector is used for connecting more than one conduit to a surface.

**NOTE** The term fluid does not necessarily limit the use of piping systems to liquids. Steam, medical gases and other non-fluid materials are often transmitted using piping systems.

Selecting the correct discipline is critical to the content working correctly. After this selection is made, it cannot be changed without first deleting the connector and adding it again with the correct discipline.

Before you begin creating Revit families that include connectors, you should learn how to create families. For more information, see The Families Guide on page 680.

For information about working with other applications and Revit Structure families with connectors, see Importing Building Components on page 68.

### Working with Connectors

You can place connectors using one of the following methods:

- **Place on Face**
  This option (Edge loop centered=true) maintains its point at the center of the edge loop. In most cases, this is the preferable method for placing a connector. Typically the Place on Face option is easier to use, and is suitable for most cases.

- **Place on Work Plane**
  This option allows placement of the connector on a selected plane. For many cases, you can imitate the Place on Face option by specifying a plane and using dimensions to constrain the connector to the desired location. However, this method generally requires additional parameters and constraints to be used effectively.

### Connector Orientation

Fittings (pipe and duct fittings) expect the instance origin of the family to be the intersection of the connectors. In most cases for fittings, there is a point on the fitting where all of the connectors (if extended into the fitting) will collide. Fittings expect this collision to be placed at the original intersection of the Center (Front / Back), Center (Left / Right), and Reference Level work planes. For this reason, it is good practice to pin these reference planes before beginning to build the family.
When you place fitting connectors, the primary connector must be placed on the face that is on the X-axis. Crosshairs display indicating that this is the primary connector. You can verify this by viewing the face in a floor plan view. Unexpected behavior can result if the primary connector is not properly placed relative to the other connectors, and if all connectors are not properly rotated and linked.

Connector rotation is a critical part of connector placement. The connector orientation determines the correct orientation of the objects that are automatically inserted on the part. Although this is not as important for round connectors, it is extremely important for rectangular connectors such as those on rectangular duct fittings. For rectangular connectors, the rectangular connector must be oriented so that the width is assigned to the face that is on the X and Y axes. The height is not on these axes. If rectangular connectors are not rotated properly, the rectangular duct fitting will be inserted improperly, creating an unexpected result. You may find it easier to rotate connectors in a 3D view, where the part geometry is clearly visible.

Connector arrows indicate the direction of a duct or pipe (extrusion) when it is being created to complete a connection. It does not indicate flow direction. In most instances, a connector arrow points outward away from the object to which the connector is associated. Otherwise, the duct or pipe when created will pass through the object geometry instead of away from it. You can modify the connector arrow direction by selecting the connector and clicking the flip arrows.
Placing a Connector

Place a Connector on a Face

1. In the Family Editor, in the Project Browser, double-click Views (all) ➤ 3D Views ➤ 3D, and spin the model to view the face where you want to place a connector. The first connector that you place for a specific type is assigned as the primary connector. You can change the assignment later.

2. Click Home tab ➤ Connectors panel, and click a connector type, such as Duct Connector.

3. Place the cursor over the face that is on the X axis. After the edges highlight, click to place the primary connector. (By default, is already selected.) The primary connector is placed.

4. Select the connector and specify instance properties as needed. The sizes and orientation that you specify determines how connections are made with compatible components. You can enter parameter values or associate them with family parameters for the component.

Place a Connector on a Work Plane

1. In the Family Editor, open a plan view and a 3D view where you want to place a connector. The first connector that you place for a specific type is assigned as the primary connector. You can change the assignment on page 700 later.

2. Click Home tab ➤ Connectors panel, and click a connector type (Electrical, Duct, Pipe, Cable Tray, or Conduit). For example, click Electrical Connector, and click Modify | Place Electrical Connector tab ➤ Placement panel ➤ (Work Plane).

3. In the Work Plane dialog, select the work plane where you want to place the connector, and click OK. In this example, an electrical connector is placed on the top work plane of a junction box.
Select the connector, move it, and specify instance properties as needed.
You can enter parameter values or associate them with family parameters for the component.

Selecting a Primary Connector

The first connector that you place for a specific type is assigned as the primary connector. However, you can change the connector assignment at any time. You select the connector that is placed on the X-axis as the primary connector.

1 In the Family Editor, open a view that allows you to select the connector that will be assigned as primary.
2 Select a connector on the component, and click Modify | Connector Element tab ➤ Primary Connector panel ➤ (Re-assign Primary).
   Crosshairs display on the primary connector.

Orienting a Connector

When connectors are added, you must verify that connector arrows point in the direction from which other components can connect, and that the width and height are properly oriented with respect to the component dimensions.

1 In the Family Editor, in the Project Browser, open a 3D view that allows you to select the connector that will be oriented.
2 To specify the direction for the connector arrow, select the connector, and click the flip control.
3 To rotate the connector, select the connector, and click Modify | Connector Element tab ➤ Modify panel ➤ (Rotate).

Linking Connectors

1 In the Family Editor, open a view containing the connectors being linked.
2 Select a connector.
3 Click Modify | Connector Element tab ➤ Connector Links panel ➤ (Link Connectors). Then select the connector that will be linked to the first connectors.
4 Select either of the linked connectors.
   Arrows display between the connectors to indicate the link.
Unlinking Connectors

1. In the Family Editor, open a view containing the connector being unlinked.
2. Select either of 2 linked connectors.
3. Click Modify | Connector Element tab ➤ Connector Links panel ➤ (Remove Link).
   The link is removed.

Deleting a Connector

1. In the Family Editor, open a view containing the connector being deleted.
2. Select the connector, and press Delete or click Modify | Connector Element tab ➤ Modify panel ➤ (Delete).

Connector Properties

The discipline assigned to a connector determines its properties. The following tables show the different connector parameters, by property group, for each discipline and a brief description of their functionality.

<p>| Electrical |
| Con | Constraints |
|----------------------------------|
| Edge loop centered | Connector placement method (read only). |
| Graphics |
| Size on screen | Size of the connector display inside the Family Editor. |
| Electrical - Loads |
| True Load Phase 3 | Calculated based on (Apparent Load Phase 3) x (Power Factor). |
| True Load Phase 2 | Calculated based on (Apparent Load Phase 2) x (Power Factor). |
| True Load Phase 1 | Calculated based on (Apparent Load Phase 1) x (Power Factor). |
| Power Factor | Percentage of power attributed to this connector. Active only when Power is specified as System Type. |</p>
<table>
<thead>
<tr>
<th>Apparent Load Phase 3</th>
<th>Calculated based on (Voltage) x (Current - Phase 3). Active only when Balanced Load is False and System Type is Power, and Number of Poles &gt;2.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apparent Load Phase 2</td>
<td>Calculated based on (Voltage) x (Current - Phase 2). Active only when Balanced Load is False and System Type is Power, and Number of Poles &gt;1.</td>
</tr>
<tr>
<td>Apparent Load Phase 1</td>
<td>Calculated based on (Voltage) x (Current - Phase 1). Active only when Balanced Load is False and System Type is Power.</td>
</tr>
<tr>
<td>Apparent Load</td>
<td>Calculated based on (Voltage) x (Current). Active only when Balanced Load is True and System Type is Power.</td>
</tr>
<tr>
<td>Voltage</td>
<td>The voltage specified on the connector. Active only when the System Type is Power.</td>
</tr>
<tr>
<td>System Type</td>
<td>Possible values are: Data, Power - Balanced, Power - Unbalanced, Telephone, Security, Fire Alarm, Nurse Call, Controls, Communication.</td>
</tr>
<tr>
<td>Load Classification</td>
<td>Possible values are: HVAC, Lighting, Power, Other.</td>
</tr>
<tr>
<td>Power Factor State</td>
<td>Possible values are: Lagging, Leading.</td>
</tr>
<tr>
<td>Number of Poles</td>
<td>Possible values are: 1, 2, or 3.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Index</td>
<td>A unique identifier for a connector in a family (read only).</td>
</tr>
<tr>
<td>Primary Connector</td>
<td>Possible values are: True or False (read only). A single connector of each discipline is allowed to be primary in each family. The family's electrical data that displays in a schedule is derived from the primary connector.</td>
</tr>
<tr>
<td>Connector Description</td>
<td>A description of the connector.</td>
</tr>
<tr>
<td>Utility</td>
<td>Indicates whether the connector is exported on a site utility to an Autodesk Exchange file (ADSK). See Importing Building Components on page 68.</td>
</tr>
</tbody>
</table>

**Mechanical (HVAC)**

**Constraints**

<table>
<thead>
<tr>
<th>Edge loop centered</th>
<th>Connector placement method (read only).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Angle</td>
<td>Used for adjustable angle families (such as elbows and adjustable tees) to push the angle value into the family from connected components.</td>
</tr>
</tbody>
</table>

**Graphics**

| Size on screen | Size of the connector display inside the Family Editor. |

**Mechanical**

<p>| Flow Factor | Percentage of the system flow attributed to this connector. Active only when the Flow Configuration is System. |</p>
<table>
<thead>
<tr>
<th><strong>Loss Coefficient</strong></th>
<th>Active only when the Loss Method is Coefficient.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Flow Configuration</strong></td>
<td>Possible values are: Calculated, Preset, System.</td>
</tr>
<tr>
<td><strong>Flow Direction</strong></td>
<td>Possible values are: In, Out, Bidirectional.</td>
</tr>
<tr>
<td><strong>System Type</strong></td>
<td>Possible values are: Supply, Return, Exhaust, Other, Undefined.</td>
</tr>
<tr>
<td><strong>Loss Method</strong></td>
<td>Possible values are: Not Defined, Coefficient, Specific Loss.</td>
</tr>
</tbody>
</table>

**Mechanical - Airflow**

| **Pressure Drop** | Active only when the Loss Method is Specific Loss. |
| **Flow** | The amount of air flowing at this connector. |

**Dimensions**

| **Shape** | Possible values are: Rectangular or Round. |
| **Height** | The height of the connector when the Shape is defined to be rectangular. |
| **Width** | The width of the connector when the Shape is defined to be rectangular. |
| **Radius** | The radius of the connector when the Shape is defined to be round. |

**Identity Data**

| **Index** | A unique identifier for a connector in a family (read only). |
| **Primary Connector** | Possible values are: True or False (read only). A single connector of each discipline is allowed to be primary in each family. The family's HVAC data that displays in a schedule is derived from the primary connector. |
| **Link Connector Index** | The index of the linked connector, -1 if none. (read only). |
| **Connector Description** | A description of the connector. |
| **Utility** | Indicates whether the connector is exported on a site utility to an Autodesk Exchange file (ADSK). See Importing Building Components on page 68. |

**Mechanical (Piping)**

**Constraints**

| **Edge loop centered** | Connector placement method (read only). |
| **Angle** | Used for adjustable angle families (such as elbows and adjustable tees) to push the angle value into the family from connected components. |

**Graphics**

| **Size on screen** | Size of the connector display inside the Family Editor. |
### Mechanical

<table>
<thead>
<tr>
<th>Mechanical Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Fixture Units</strong></td>
<td>Active only when the System Type is Sanitary, Domestic Hot Water, or Domestic Cold Water and the Flow Configuration is Fixture Units.</td>
</tr>
<tr>
<td><strong>K Coefficient</strong></td>
<td>K Coefficient (K Factor) is only editable if Loss Method is specified as “K Coefficient”.</td>
</tr>
<tr>
<td><strong>Flow Factor</strong></td>
<td>Percentage of the system flow attributed to this connector. Active only when the Flow Configuration is System.</td>
</tr>
<tr>
<td><strong>Flow</strong></td>
<td>Volumetric flow rate of fluid through connector.</td>
</tr>
<tr>
<td><strong>Pressure Drop</strong></td>
<td>Active only when the Loss Method is Specific Loss</td>
</tr>
<tr>
<td><strong>Flow Configuration</strong></td>
<td>Possible values are: Calculated, Preset, System.</td>
</tr>
<tr>
<td><strong>Flow Direction</strong></td>
<td>Possible values are: In, Out, Bidirectional. Bidirectional is active only when the Flow Configuration is Calculated.</td>
</tr>
<tr>
<td><strong>Loss Method</strong></td>
<td>Possible values are: Not Defined, K Coefficient from Table, K Coefficient, Specific Loss.</td>
</tr>
<tr>
<td><strong>Allow Slope Adjustments</strong></td>
<td>Possible values are: Checked or unchecked.</td>
</tr>
<tr>
<td><strong>System Type</strong></td>
<td>Possible values are: Undefined, Hydronic Supply, Hydronic Return, Sanitary, Domestic Cold Water, Domestic Hot Water, Fire Protection, Other.</td>
</tr>
<tr>
<td><strong>K Coefficient Table</strong></td>
<td>Possible values are: Bell Mouth Inlet or Reducer, Inward Projecting Pipe, Outlet, Square Edged Inlet. Active only when the Loss Method is K Coefficient from Table.</td>
</tr>
</tbody>
</table>

### Dimensions

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Radius</strong></td>
<td>The nominal size of the connector.</td>
</tr>
</tbody>
</table>

### Identity Data

<table>
<thead>
<tr>
<th>Identity Data Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Index</strong></td>
<td>A unique identifier for a connector in a family (read only).</td>
</tr>
<tr>
<td><strong>Primary Connector</strong></td>
<td>Possible values are: True or False (read only). A single connector of each discipline is allowed to be primary in each family. The family’s piping data that displays in a schedule is derived from the primary connector.</td>
</tr>
<tr>
<td><strong>Link Connector Index</strong></td>
<td>The index of the linked connector, -1 if none. (read only).</td>
</tr>
<tr>
<td><strong>Connector Description</strong></td>
<td>A description of the connector.</td>
</tr>
<tr>
<td><strong>Utility</strong></td>
<td>Indicates whether the connector is exported on a site utility to an Autodesk Exchange file (ADSK). See Importing Building Components on page 68.</td>
</tr>
</tbody>
</table>

### Labels

A label is a text placeholder added to tags or titleblocks. You create a label as part of a tag or titleblock family while in the Family Editor. When you place the tag or titleblock in the project, you place substitution text for the label, and the text appears as part of the family.
1 Click ➤ New ➤ Annotation Symbol or Title Block.
2 In the displayed dialog, select the appropriate template for the family you are creating.
3 In the Family Editor, click Home tab ➤ Text panel ➤ (Label).
4 In the Type Selector on page 35, select the label type.
5 On the Format panel, select the vertical and horizontal justification.
6 In the drawing area, click to position the tag. For example, in a generic model tag template, place the cursor at the intersection of the two reference planes. The Edit Label dialog opens.
7 Edit the label parameters. See Editing Multi-parameter Labels on page 705.

Editing Multi-parameter Labels

You assign single or multiple parameters to labels with the Edit Label dialog.

![Edit Label dialog]

The Category Parameters window contains the label parameters related to the tag type. The Label Parameters window contains the Category Parameters that display in the label. Typically, this is a single parameter, but you can detail more complex, concatenated labels.

Building a Label

You add and remove parameters by moving them between the windows:

- Highlight a parameter in the Category Parameters window and click (Add Parameter) to move it into the Label Parameters window.

- Highlight a parameter in the Label Parameters window and click (Remove Parameter) to move it into the Category Parameters window.

Labels display their parameters from the first to the last (top to bottom) as listed in the Label Parameters window. You reorder the label by highlighting a parameter and shift its position using (Move Parameter Up) and (Move Parameter Down).
Shared Label Parameters

You can configure the label with shared external parameters of other families. You configure shared parameters before moving them over to the Label Parameters window. The Category Parameters controls aid in this integration:

- **Add Parameter.** Click this button to enter the Parameter Properties dialog. See Adding Shared Parameters to Families on page 1545.
  For Generic Annotation families, you can use the Add Parameter button to introduce new Family Parameters to the Generic Annotation family. See Creating Parameters on page 692 and Parameters on page 1541.

- **Edit Parameter.** Click this button to enter the Parameter Properties dialog to edit a selected parameter. See Viewing, Moving, and Deleting Shared Parameters on page 1544.

- **Delete Parameter.** Click this button to delete a selected family parameter.
  To delete a shared parameter, see Viewing, Moving, and Deleting Shared Parameters on page 1544.

**NOTE** Deleted shared parameters are removed from all sharing labels.

Label Parameter Options

The columns in the Label Parameters window display annotation options for the label. The parameter names are listed in order in the first column.

- **Spaces.** You increase or decrease the spacing between parameters in the label by entering a representative number of spaces (zero or greater). This option disables if the Break option is selected.

- **Prefix.** You can add a prefix to the parameter value by adding a text string in this option.

- **Sample Value.** You can change how the place-holding text appears in the parameter.

- **Suffix.** You can add a suffix to the parameter value by adding a text string in this column.

- **Break.** You force a line break immediately after the parameter by checking this box. Otherwise, the text wraps within the label boundary.

- **Wrap between parameters only.** You force text wrapping in the label to break at the end of parameters by checking this box. If not selected, text wraps at the first word reaching the boundary.

<table>
<thead>
<tr>
<th>Unadjusted label text</th>
<th>Wrapping label text</th>
<th>Breaking label text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Family: W-Wide Flange Name: W18X40 Material: Steel</td>
<td>Family: W-Wide Flange Name: W18X40 Material: Steel</td>
<td></td>
</tr>
</tbody>
</table>

Edit Label Unit Formats

If you create a label with a length, area, volume, angle, number, currency, or slope parameter, you can format the appearance of the parameter.
1 In the Edit Label dialog, choose a length or area parameter, such as Room area.

2 Click ✖. The Format dialog displays.

3 Clear Use project settings.

4 From the Units menu, select an appropriate unit.

5 From the Rounding menu, select a decimal place value. If you choose Custom from the menu, enter a value in the Rounding increment text box.

6 If applicable, select a Unit suffix from the menu.

7 Select Suppress 0 feet to hide leading zeros on dimensions, such as 0' 6". This option is available only for feet and fractional inches.

8 Click OK.

---

**Label Type Properties**

You can modify the Type Properties of labels.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Color</td>
<td>Sets the color of the text and the leader line.</td>
</tr>
<tr>
<td>Line weight</td>
<td>Sets the thickness of the line that surrounds the text when you select the text and the thickness of the leader line. You can change the definition of the line weight numbers using the Line Weights tool. See Line Weights on page 1603.</td>
</tr>
<tr>
<td>Background</td>
<td>Sets the background for the text note. With Opaque, the background of the note itself covers material behind it. Transparent allows you to see material behind the note. This is useful with text notes placed in color-defined rooms.</td>
</tr>
<tr>
<td>Show Border</td>
<td>Displays a border around the text. See Displaying the Text Box Border on page 930.</td>
</tr>
<tr>
<td>Leader/Border Offset</td>
<td>Sets the distance between the leader/border and the text. See Modifying the Leader/Border Offset on page 931.</td>
</tr>
</tbody>
</table>
### Text Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Font</td>
<td>Sets the Microsoft® True Type fonts for the text note. The default font is Arial.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Sets the size of the typeface.</td>
</tr>
<tr>
<td>Tab Size</td>
<td>Sets tab spacing in a text note. When you create a text note, you can press Tab anywhere in the text note, and a tab appears at the specified size.</td>
</tr>
<tr>
<td>Bold</td>
<td>Sets the text typeface to bold.</td>
</tr>
<tr>
<td>Italic</td>
<td>Sets the text typeface to italic.</td>
</tr>
<tr>
<td>Underline</td>
<td>Underlines the text.</td>
</tr>
<tr>
<td>Width Factor</td>
<td>1.0 is the default for regular text width. The font width scales proportionately to the Width Factor. Height is not affected.</td>
</tr>
</tbody>
</table>

### Label Instance Properties

You can modify the Instance Properties of labels.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Sample Text</td>
<td>Read-only field that displays the Sample Value from the Edit Label dialog.</td>
</tr>
<tr>
<td>Label</td>
<td>Launches the Edit Label dialog.</td>
</tr>
<tr>
<td>Wrap between parameters only</td>
<td>Forces text wrapping to break at the end of parameters. If not selected, text wraps at the first word reaching the label boundary.</td>
</tr>
<tr>
<td>Vertical Align</td>
<td>Orient text at the Top, Middle, or Bottom of the label boundary.</td>
</tr>
<tr>
<td>Horizontal Align</td>
<td>Justifies text to the Left, Center, or Right of the label boundary.</td>
</tr>
<tr>
<td>Keep Readable</td>
<td>Text in the label remains readable whenever you rotate it. It never displays upside-down.</td>
</tr>
<tr>
<td>Visible</td>
<td>Sets whether the label is visible in a project.</td>
</tr>
</tbody>
</table>

### Applying the Label to a Tag in a Project

1. In a project, click Insert tab ➤ Load from Library panel ➤ ![Load Family](Load Family).
2. Navigate to the family you want to load, and click Open. If prompted to replace a family of the same type, click Yes.
3. If you created a window, door, or room tag, place one of those components to see the new tag you created.
4. If the element does not already have a tag associated with it, place the element, then click Annotate tab ➤ Tag panel ➤ Tag drop-down ➤ ![By Category](By Category) to place a tag with the element.
5 Select the element that you placed, for example, a window.

6 On the Properties palette, locate the parameter that you chose when creating the label in either
the instance or type properties. For example, if you defined the label to include the Manufacturer
parameter, click Edit Type to open the Type Properties dialog.

7 Enter a value for the parameter and click OK (if entering a type property).
   The label value displays in the tag.

Applying the Label to a Titleblock in a Project

1 In a project, click Insert tab ➤ Load from Library panel ➤ (Load Family).

2 Create a sheet using the titleblock. See Sheets on page 978.
   The new sheet view opens with the label you created in the titleblock family.

3 Select the label.

4 On the Properties palette, locate the parameter you defined for the family and enter a value for
   it.
Rooms and Areas

Architects, designers, and structural engineers use areas to plan occupancy and usage of a building, and to perform basic analysis of a design.

Rooms and Areas Overview

An area is a subdivision of space within a building model, typically on a larger scale than individual rooms. However, areas are not necessarily bounded by model elements. You can draw area boundaries or pick model elements to use as boundaries.

When you add model elements, the area boundaries do not necessarily change automatically. You can specify how area boundaries behave:

- Some area boundaries are static. That is, they do not change automatically and must be changed manually.
- Some area boundaries are dynamic. They stay connected with underlying model elements. If the model elements move, the area boundaries move with them.

Area Analysis

Use area analysis tools to define spatial relationships in the building model.

Related topics

- Rooms and Areas Overview on page 711
- Analyzing a Conceptual Design on page 1335

Area Schemes

Area schemes are definable spatial relationships. For example, you can have an area scheme showing the relationship between core and circulation spaces in a floor plan.

You can create multiple area schemes. By default, Revit Structure creates 2 area schemes:

- Gross Building: Total constructed area of a building.

You cannot edit or delete the Gross Building area scheme. The Rentable area scheme is modifiable. You can create additional area schemes as needed.

### Area Schemes and Schedules

You can create schedules for area schemes. For more information about defining a schedule for an area scheme, see *Creating a Schedule or Quantity* on page 772.

**Related topic**

- **Including Project Parameters or Area Schemes from Linked Models in a Schedule** on page 1197

### Creating an Area Scheme

1. Click Architect & Site tab ➤ Area panel ➤ .
2. In the Area and Volume Computations dialog, click the Area Schemes tab.
3. Click New.
4. For Name, enter a name for the new area scheme.
5. For Description, enter a description of the new area scheme.
6. Click OK.

### Deleting an Area Scheme

**NOTE** If you delete an area scheme, all area plans associated with that scheme are also deleted.

1. Click Architect & Site tab ➤ Area panel ➤ .
2. In the Area and Volume Computations dialog, click the Area Schemes tab.
3. Select the area scheme.
4. Click Delete.
5. Click OK.

### Area Plans

Area plans are views that show spatial relationships based on area schemes and levels in your model. You can have multiple area plans for every area scheme and level. Each area plan can have distinct area boundaries, tags, and color schemes.

Area plans are listed in the Area Plans node of the Project Browser. You can rename area plans. In the Project Browser, the area plan name indicates the level associated with the plan.

Create area schemes before creating area plans. See *Creating an Area Scheme* on page 712.
Creating an Area Plan

1 Click View tab ➤ Create panel ➤ Plan Views drop-down ➤ (Area Plan).
2 In the New Area Plan dialog, for Type, select an area scheme.
3 Select a level for the area plan view.
   If you select more than one level, Revit Structure creates a separate area plan for each level and groups them by area scheme in the Project Browser.
4 To create unique area plan views, select Do not duplicate existing views.
   To create copies of existing area plan views, clear Do not duplicate existing views.
5 For Scale, select the area plan scale.
6 Click OK.
   Revit Structure prompts you to automatically create area boundary lines associated with all external walls. See Area Boundaries on page 713.
7 Select one of the following:
   ■ Yes: Revit Structure places the boundary lines along the exterior walls of a closed loop.
   ■ No: You sketch the area boundary lines.

   TIP Revit Structure cannot automatically create area boundary lines in external walls that are not closed in a loop.

   TIP If the project includes a ruled curtain system within the exterior wall loop, you must sketch the area boundary, because ruled curtain systems are not walls.

8 Add more area boundaries, as needed.
   See Creating Area Boundaries on page 713.

Related topics
■ Area Plans on page 712
■ Area Schemes on page 711
■ Areas and Area Tags on page 714

Area Boundaries

Area boundaries define usable space in buildings. You can define these areas by drawing them or by picking walls.

If you select the Apply Area Rules option, Revit Structure automatically changes the wall boundary position when you change the area type. (See Area Types on page 718.) For example, office area is measured at the wall centerline, while exterior area is measured to the exterior wall face. By applying area rules, the area boundary position updates in accordance with area type changes.

Creating Area Boundaries

1 Open an area plan view.
   Area plan views are listed in the Project Browser under Area Plans. See Area Plans on page 712.
2 Click Architect & Site tab ➤ Area panel ➤ (Boundary).
3 Draw or pick the area boundaries. (Use Pick Lines to apply area rules.)
   See the following procedures for details.

To pick area boundaries

1 Click Modify | Place Area Boundary tab ➤ Draw panel ➤ (Pick Lines).
2 If you do not want Revit Structure to apply area rules, on the Options Bar, clear Apply Area Rules, and specify the offset.
   NOTE If you apply area rules, the area boundary position is dependent on the area type parameter of the area tag. You must place an area tag in the boundary to change the area type.
3 Select the boundary defining walls.

To draw area boundaries

1 Click Modify | Place Area Boundary tab ➤ Draw panel, and select a sketch tool.
2 Use the sketch tools to complete the boundary.
   See Sketching on page 1405.

Areas and Area Tags

Areas and area tags are separate but related Revit Structure components. Areas are model elements in Revit Structure, like walls and doors. Area tags are annotation elements that you can add to area plan views.
When creating an early design, before you define walls or other bounding elements in a project, you can create an area schedule. In the schedule, add information about the areas that you plan to use. Later, you can place these predefined areas in an area plan of the project.

Creating an Area

You can create areas using 2 methods:

■ Add rows to an area schedule. This allows you to predefine areas in an early design of the project. See Creating a Schedule or Quantity on page 772. You can later use the Area tool to place the predefined areas in an area plan.
■ Use the Area tool in an area plan view, as follows.

To create an area

1 Open an area plan view.
   See Area Plans on page 712.
2 Create area boundaries.
   See Area Boundaries on page 713.
3 Click Architect & Site tab ➤ Area panel ➤ (Area).
4 To display an area tag with the area, do the following:
   ■ Make sure that Tag on Placement is selected: Modify | Place Area tab ➤ Tag on Placement panel ➤ (Tag on Placement).
   To omit a tag when you place the area, turn off this option.
   ■ On the Options Bar, indicate the desired orientation of the area tag.
   ■ To include a leader line with the area tag, select Leader on the Options Bar.

5 On the Options Bar, for Area, select New to create a new area, or select an existing area from
   the list.

6 Click in the area plan to place the area.

If you place an area inside area boundaries, it expands to the extents of the boundaries. You can also place
an area in a free space or one that is not entirely bounded, and then draw area boundaries later. The area
expands to the boundaries.

To make the area visible in the view, click View tab ➤ Graphics panel ➤ Visibility/Graphics. On the Model
Categories tab, expand Area, and select Interior Fill or Reference (or both). See Overriding Graphic Display
of Element Categories on page 803.

Adding an Area Tag

Area tags display the total area within an area boundary. When you place an area tag, you can assign a
unique name to the area.

Before you can add area tags, you must add areas to the area plan. See Creating an Area on page 714. If you
do not use the Tag on placement option when creating areas, you can use the following procedure to add
area tags later.

NOTE As an alternative, use the Tag All Not Tagged tool to tag untagged areas. See Tag All Not Tagged on page
947.

To add an area tag

1 Open an area plan view.

2 Click Architect & Site tab ➤ Area panel ➤ (Tag).
   Revit Structure highlights defined areas in the area plan.

3 On the Options Bar, do the following:
   ■ Indicate the desired orientation of the area tag.
   ■ To include a leader line with the area tag, select Leader.

4 Click in an area to place the tag.

Deleting Areas and Area Tags

When you delete (unplace) an area in an area plan view, its tag is also deleted. However, the area is still
defined in the project. (See Removing Areas on page 716.)

When you delete an area tag from an area plan view, only the area tag is deleted. The area remains in the
area plan view and the schedule view.
Area Properties

Parameter names, values, and descriptions for areas. Some values are modifiable.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Level</td>
<td>The level on which the area resides. This is a read-only value.</td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Area</td>
<td>Total area within area boundaries. This is a read-only value.</td>
</tr>
<tr>
<td>Perimeter</td>
<td>The perimeter of the area boundaries. This is a read-only value.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Number</td>
<td>The value for this parameter is automatically generated when you add an area to a project. You can modify the value of this parameter using numbers, characters, or a combination of numbers and characters. You will receive a duplicate value message if the same value for the number parameter is used for 2 areas in an area scheme. You can add this parameter to a schedule, and it can display in an area tag.</td>
</tr>
<tr>
<td>Name</td>
<td>Area name.</td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments about the area.</td>
</tr>
<tr>
<td>Other</td>
<td></td>
</tr>
<tr>
<td>Area Type</td>
<td>Type of area.</td>
</tr>
</tbody>
</table>

NOTE Changing the area type alters the position of area boundaries created with the Apply Area Rules options. See Area Types on page 718 for type rules.

Removing Areas

After creating areas, you can remove areas from a building model in the following ways:

- **Unplace**: Removes the area from its location in the area plan, but the project still contains information about the area. Then you can place the area in another location later during a project redesign. See Unplacing or Moving Areas on page 716.

- **Delete**: Completely removes the area (including all information about the area) from the project. See Deleting Areas on page 718.

Unplacing or Moving Areas

When you add an area to a floor plan, the project stores information about the area. This can include information that you add using area properties, such as the area name, usage, and so on. (See Area Properties on page 716.) You can see information about areas in an area schedule. If you want to retain information about an area but remove it from its current location in the building model, unplace the area as follows.
**To unplace an area**

1. Open an area plan view that shows the area.
2. Select the area.
   
   Check the status bar to be sure that you are selecting the area and not the area tag.
3. Delete the area from the plan view using any of the following methods:
   - Press *Delete* or *Ctrl+X*.
   - Right-click the area, and click Delete.
   - Click Modify Areas tab ➤ Modify panel ➤ Delete.

The area is removed from its location in the building model. However, the project still contains the information about the area. In an area schedule, the area is listed as Not Placed. If desired, you can place the area in another location.

**Placing an Unplaced Area**

1. Open the area plan view where you want to place the area.
2. Click Architect & Site tab ➤ Area panel ➤ (Area).
3. On the Options Bar, for Area, select the desired area from the list.
4. In the drawing area, click to place the selected area in the desired location.

Area schedules update automatically to reflect the new location of the area.

**Viewing a List of Unplaced Areas**

1. If the project does not include an area schedule, create one.
   
   See *Creating a Schedule or Quantity* on page 772.
2. Display the area schedule in the drawing area.
   
   The area schedule lists areas defined in the building model. For any areas that are currently unplaced, the schedule displays Not Placed for any read-only fields, including: Area, Perimeter, Level, Upper Limit, and Volume.
3. Click Modify Schedule/Quantities tab ➤ Filter Not Placed & Unenclosed Items panel ➤ (Isolate).
   
   This tool filters the schedule so that it lists only the areas that are not placed or enclosed. You may want to save this schedule that you can quickly determine which areas need to be placed or enclosed.

**Hiding Unplaced Areas in an Area Schedule**

1. Display the area schedule in the drawing area.
   
   The area schedule lists areas defined in the building model. For any areas that are currently unplaced, the schedule displays Not Placed for any read-only fields, including: Area, Perimeter, Level, Upper Limit, and Volume.
2 Click Modify Schedule/Quantities tab ➤ Filter Not Placed & Unenclosed Items panel ➤ (Hide).
This tool filters the schedule so that it lists only the areas that are currently placed (and enclosed).
To redisplay the areas that are not placed or enclosed in the schedule, click Show.

Deleting Areas

Delete selected areas from a project when you no longer want to retain any information about the areas.

To delete one or more areas

1 If the project does not include an area schedule, create one.
   See Creating a Schedule or Quantity on page 772.
2 Display the area schedule in the drawing area.
3 To delete one area, place the cursor in the schedule row for that area.
4 To delete multiple areas, do the following:
   a Click Modify Schedule/Quantities tab ➤ Filter Not Placed & Unenclosed Items panel ➤
      (Isolate).
      This tool filters the schedule so that it lists only the areas that are not placed or enclosed.
   b Drag the cursor across the schedule rows for the areas to delete.
5 Click Schedule panel ➤ (Delete).
6 At the warning message, click OK.
The selected areas are deleted from the project. The project no longer stores any information about the areas.

Showing Areas and Area Boundaries in Linked Models

1 Open the plan view that contains the linked model.
2 Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
3 Click the Revit Links tab.
4 Select the row for the linked model to display areas and area boundaries, and click the button
   in the Display Settings column.
5 On the Basics tab of the RVT Link Display Settings dialog, select By Linked view.
6 For Linked view, select the area plan.
7 Click OK twice.

Area Types

Area types are an instance property of area tags. Area types contain area measurement rules that Revit
Structure applies to area boundaries. See Area Type Rules on page 719.
Area type values come from the default area schemes: Gross Building and Rentable. The Gross Building area scheme has 2 area type values: Gross Building Area, and Exterior Area. The Rentable Area scheme has 6 type values: building common area, office area, exterior area, floor area, major vertical penetration, and store area.

When you create a new area scheme, it uses the type values from the Rentable area scheme. See Area Schemes on page 711.

### Gross Building Area Types

<table>
<thead>
<tr>
<th>Area Type Selected</th>
<th>Definition and Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gross Building Area</td>
<td>The total constructed area of a building. It is any area inside the outer face of the building’s exterior walls.</td>
</tr>
<tr>
<td>Exterior Area</td>
<td>Any area outside the outer face of a building’s external walls, for example, an exterior courtyard enclosed by 4 walls.</td>
</tr>
</tbody>
</table>

### Rentable Area Types

<table>
<thead>
<tr>
<th>Area Type Selected</th>
<th>Definition and Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Building Common Area</td>
<td>Lobbies, atriums, conference rooms, lounges, vending area, security desks, concierge areas, food service facilities, health or fitness centers, day care facilities, locker or shower facilities, and mail rooms.</td>
</tr>
<tr>
<td>Office Area</td>
<td>Area where a tenant normally houses personnel, furniture, or both.</td>
</tr>
<tr>
<td>Exterior Area</td>
<td>Any area outside the external walls of a building.</td>
</tr>
<tr>
<td>Floor Area</td>
<td>Washrooms, janitorial closets, electrical rooms, telephone rooms, mechanical rooms, elevator lobbies, public corridors, and other areas that are available primarily for the use of the tenants on that floor.</td>
</tr>
<tr>
<td>Major Vertical Penetration</td>
<td>Stairs, elevator shafts, flues, pipe shafts, vertical ducts, and their enclosing walls.</td>
</tr>
<tr>
<td>Store Area</td>
<td>Area of an office building suitable for retail occupancy.</td>
</tr>
</tbody>
</table>

### Area Type Rules

The following table shows area measurement rules. Rules are determined by one type of space bordering another space. To find the appropriate measurement rule, find the selected Area Type and the corresponding Bordering Area Type.

**Related topic**

- Area Types on page 718

### Gross Building Area Scheme Types

<table>
<thead>
<tr>
<th>Area Type Selected</th>
<th>Bordering Area Type</th>
<th>Measurement Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gross Building Area</td>
<td>None</td>
<td>Area Boundary measured to the outside surface of building.</td>
</tr>
</tbody>
</table>
## Gross Building Area Scheme Types

<table>
<thead>
<tr>
<th>Area Type Selected</th>
<th>Bordering Area Type</th>
<th>Measurement Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gross Building Area</td>
<td>Exterior Area</td>
<td>Area Boundary measured from outside surface of building.</td>
</tr>
</tbody>
</table>

### Exterior Area

<table>
<thead>
<tr>
<th>Exterior Area</th>
<th>Exterior Area</th>
<th>Area Boundary measured from wall centerline.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exterior Area</td>
<td>Gross Building Area</td>
<td>Area Boundary measured from outside surface of building.</td>
</tr>
</tbody>
</table>

## Rentable Area Scheme Types

**NOTE** Windows in Rentable Area Scheme Types: If you place windows within the exterior walls, Revit Structure places the area boundary lines according to the following rules based on the height of the windows: If window height is greater than 50% of wall height, area boundary lines go to face of glass. If window height is less than 50% of wall height, area boundary lines go to interior face of the exterior walls.

<table>
<thead>
<tr>
<th>Area Type Selected</th>
<th>Bordering Area Type</th>
<th>Measurement Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Building Common Area</td>
<td>Building Common Area, Office, Store</td>
<td>Area Boundary measured from wall centerline.</td>
</tr>
<tr>
<td>Building Common Area</td>
<td>Exterior, Major Vertical Penetration</td>
<td>Area Boundary measured from wall face bordering Building Common Area.</td>
</tr>
</tbody>
</table>

### Office Area

<table>
<thead>
<tr>
<th>Office Area</th>
<th>Building Common Area, Office, Store</th>
<th>Area Boundary measured from wall centerline.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Office Area</td>
<td>Exterior, Major Vertical Penetration</td>
<td>Area Boundary measured from wall face bordering the office area.</td>
</tr>
</tbody>
</table>

### Exterior Area

<table>
<thead>
<tr>
<th>Exterior Area</th>
<th>Exterior</th>
<th>Area Boundary measured from wall centerline.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exterior Area</td>
<td>Store</td>
<td>Area Boundary measured from wall face bordering Exterior Area.</td>
</tr>
<tr>
<td>Exterior Area</td>
<td>Any other areas</td>
<td>Area Boundary measured from the wall face bordering the other area.</td>
</tr>
</tbody>
</table>

### Floor Area

<table>
<thead>
<tr>
<th>Floor Area</th>
<th>Office, Store or Building Common Area</th>
<th>Area Boundary measured from wall face bordering other area.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Floor Area</td>
<td>Exterior, Major Vertical Penetration</td>
<td>Area Boundary measured from the wall face bordering the floor area.</td>
</tr>
</tbody>
</table>
### Rentable Area Scheme Types

<table>
<thead>
<tr>
<th>Area Type Selected</th>
<th>Bordering Area Type</th>
<th>Measurement Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Floor Area</td>
<td>Floor Area</td>
<td>Area Boundary measured from the wall centerline.</td>
</tr>
<tr>
<td><strong>Major Vertical Penetration</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Major Vertical Penetration</td>
<td>Major Vertical Penetration</td>
<td>Area Boundary measured from the wall centerline.</td>
</tr>
<tr>
<td>Major Vertical Penetration</td>
<td>Exterior</td>
<td>Area Boundary measured from the wall face bordering the Major Vertical Penetration area.</td>
</tr>
<tr>
<td>Major Vertical Penetration</td>
<td>Any other area (except Exterior)</td>
<td>Area Boundary measured from the wall face bordering the other area.</td>
</tr>
<tr>
<td><strong>Store Area</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Store Area</td>
<td>Major Vertical Penetration, Floor</td>
<td>Area Boundary measured from the wall face bordering the Store area.</td>
</tr>
<tr>
<td>Store Area</td>
<td>Exterior</td>
<td>Area Boundary measured from the wall face bordering the Exterior area.</td>
</tr>
<tr>
<td>Store Area</td>
<td>Building Common Area, Office, Store</td>
<td>Area Boundary measured from the wall centerline.</td>
</tr>
</tbody>
</table>
Document the Project
2D Views

Plan Views

The structural plan view is the default view in a new project. Most projects include at least one structural plan.
Structural plan views are created automatically as you add new levels to your project.

NOTE For information on structural analytical views, see Visualization on page 1279.

Creating a Plan View

1 Click View tab ➤ Create panel ➤ Plan Views drop-down ➤ (Structural Plan).
2 In the New Plan dialog, select one or more levels for which you want to create a plan view.
3 If you want to create a plan view for a level that has an existing plan view, clear Do not duplicate existing views.
4 For Scale, select an appropriate view scale for the new view.
5 Click OK.

NOTE If you create duplicate plan views, the duplicate view displays in the Project Browser with the following notation: Level 1(1), where the value in parentheses increases with the number of duplicates.

Plan View Direction

Engineers view plans at different orientations in different countries. Revit Structure provides for this variation with the View Direction Type parameter for Structural Plans. This parameter makes it possible for you to select Up or Down for View direction.
To set view direction

1. In the Project Browser, select a view that is an element of the Structural Plan Family.
2. On the Properties palette, click (Edit Type).
3. In the Type Properties dialog, for View Direction, select Up or Down.
4. Click OK.

You can set the view direction for individual structural plan views, allowing multiple view directions within a project. Typically, foundation views are viewed Down to show structural floors, wall foundations, and footings, for example. Framing views can be viewed Up for a view of structural framing elements unobscured by structural floors.

<table>
<thead>
<tr>
<th>View direction Down</th>
<th>View direction Up</th>
</tr>
</thead>
</table>

NOTE It may be necessary to adjust the view range cut plane when switching view direction settings. See View Range on page 864.
Cutting a Plan View by the Back Clip Plane

You may want to cut a plan view at the back clip plane when you have an element (such as a slanted wall) that spans multiple levels. If you only want the wall visible in the plan view as it appears in the view range of level 3, you can clip the wall from view using the Depth Clipping parameter. The following image illustrates this.

![Diagram showing cut plane and view depth for a plan view](image)

You activate this feature using the Depth Clipping parameter for the plan view. The back clip plane is defined by the View Depth parameter, which is part of the view's View Range properties.

**NOTE** Plan views include structural plan views, detail plan views, and callout plan views.

The following image shows the cut plane and view depth for this model and the resulting plan view representations for the Depth Clipping parameter options (Clip without line, Clip with line, and No clip).
Plan regions respect the Depth Clipping parameter setting of their parent view, but follow their own View Range settings.

Elements that have symbolic representation in certain views (such as structural beams) and non-cuttable families are not affected when you cut a plan view by the back clip plane. They will display and are not cut. This property does affect printing.

**To cut by the back clip plane:**

1. In the Project Browser, select the plan view you want to cut by the back clip plane.
2. On the Properties palette, under Extents, find the Depth Clipping parameter. The Depth Clipping parameter is available for plan and site views.
3. Click the button in the value column. The Depth Clipping dialog displays.
4. In the Depth Clipping dialog, select an option and click OK.
5. Optionally, click View Range, and modify the View Depth setting if necessary. The level you select for View Depth is where the view will be clipped, when the Depth Clipping property is active.
Plan View Properties

Each plan view has type properties for callout tags and reference labels. The reference label parameter sets the text displayed in a callout tag when a reference callout is made to the plan view. To define the look of callout tags click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Callout Tags). See View Properties on page 873.

Displaying a Plan View

- Double-click the view name in the Project Browser.
- If the view is open but hidden behind another view, click View tab ➤ Windows panel ➤ Switch Windows drop-down ➤ <view name>.

Plan Region

The Plan Region tool lets you define a region within a plan view that has a different view range from the overall view. Plan regions are useful for split level plans or for displaying inserts above or below the cut plane. Plan regions are closed sketches and cannot overlap each other. They can have coincident edges.

Plan regions are view-specific. You can copy and paste them into the same view or different views. When you copy a plan region into a different view, the view range settings are maintained from the previous view.

Plan regions export and print when they are visible in a view.

Creating a Plan Region

1. Open a plan view.
2. Click View tab ➤ Create panel ➤ Plan Views drop-down ➤ (Plan Region).
3. Sketch a closed loop using lines, rectangles, or polygons. For more information, see Sketching on page 1405.
4. On the Properties palette, for View Range, click Edit.
5. In the View Range dialog, specify the primary range and view depth.
   - If the value for Cut Plane is specified as Parent View’s Level, then the level used to define all the clip planes (Top, Bottom, Cut, and View Depth) is the same as for the entire plan view.

   **NOTE** Values for offsets need to make sense with respect to each other. For example, the top offset cannot be lower than the cut plane offset, and the cut plane offset cannot be lower than the bottom offset.

   For more details about view range options, see View Range on page 864.
6. Click OK to exit the View Range dialog.
7. On the Mode panel, click (Finish Edit Mode).

You do not have to enter sketch mode to edit the shape of a plan region. Each boundary line of the plan region is a shape handle, as shown in the following image. Select the shape handle and drag it to modify the size.
Related topics

- Plan Region on page 729
- Controlling Visibility of Plan Regions on page 730
- Cutting a Plan View by the Back Clip Plane on page 727

Controlling Visibility of Plan Regions

1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics), or type the shortcut key combination VG.
2. In the Visibility/Graphics dialog, click the Annotation Categories tab.
3. Scroll to the Plan Region category.
4. Select or clear the check box to show or hide the plan region.
5. Click in the Projection/Surface Lines column, and click Override to make changes to the line weight, line color, and line pattern of the plan region.
6. Click OK.

Elevation Views

Elevation views are part of the default template in Revit Structure. When you create a project with the default template, 4 elevation views are included: north, south, east, and west. It is in elevation views where you sketch level lines. For each level line that you sketch, a corresponding plan view is created.

You can create additional exterior elevation views and interior elevation views. Interior elevation views depict detailed views of interior walls and show how the features of the wall should be built. Examples of rooms that might be shown in an interior elevation are kitchens and bathrooms.

Elevation Tags

You designate elevations with an elevation tag . The tag snaps to walls as you drag it around with the cursor. You can set different properties for the tag. See Modifying Elevation Symbol Properties on page 737.

The elevation view arrowhead is visible in a plan view, provided the elevation view’s crop region intersects the view range of the plan view. If you resize the crop region of the elevation such that it no longer intersects the view range, the arrowhead is not visible in the plan view.

Creating an Elevation View

1. Open a plan view.
2 Click View tab ➤ Create panel ➤ Elevation drop-down ➤ (Elevation).
   The cursor appears with the elevation symbol.

3 On the Options Bar, select a view scale.
4 Place the cursor near a wall, and click to place the elevation symbol.

   **NOTE** As you move the cursor, you can press *Tab* to change the position of the arrowhead. The arrowhead snaps to perpendicular walls.

5 To set different interior elevation views, highlight the square shape of the elevation symbol, and click.
   The elevation symbol displays with check box options for creating views, as the following image shows.

   ![Elevation symbol with check boxes](image)

   **TIP** The rotation control is useful for aligning to angled elements in the plan.

6 Select the check boxes to indicate where you want to create elevation views.
7 Click away from the elevation symbol to hide the check boxes.
8 Highlight an arrowhead on the symbol to select it.
9 Click the arrowhead once to view the clip plane:

   ![Elevation symbol with clip plane](image)

   The end points of clip planes snap and join to walls. You can resize the width of the elevation by dragging the blue controls. If the blue controls do not display in the view, select the clip plane and click Modify Views tab ➤ Element panel ➤ Element Properties. In the Instance Properties dialog, select the Crop View parameter, and click OK.

10 In the Project Browser, select the new elevation view.
   The elevation view is designated by a letter and number, for example, Elevation: 1 - a.

**Related topics**

- Displaying an Elevation View on page 731
- Changing the Clip Plane in an Elevation View on page 732
- Changing the Elevation Symbol on page 732
- Framing Elevation Views on page 733

**Displaying an Elevation View**

There are several ways to display an elevation view.

- Double-click the view name in the Project Browser.
- Double-click the arrowhead on the elevation symbol.
Select the elevation symbol arrowhead, right-click, and select Go to Elevation View.

**Changing the Elevation Symbol**

1. Select the elevation tag arrowhead.
2. Click Modify | Views tab ➤ Properties panel ➤ (Type Properties).
3. Modify the appropriate property values by clicking in the Value fields.
4. Click OK.

**Changing the Clip Plane in an Elevation View**

Clip planes define the boundaries for an elevation view. The end points of clip planes snap and join to walls. You can resize the viewing area of an elevation by resizing the clip planes.

1. In a plan view, select the elevation tag arrowhead.

   **NOTE** If the far clip plane (the dotted green line) is not visible, on the Properties palette, select an option for the Far Clipping parameter. For more information, see Cut a View by the Far Clip Plane on page 854.

2. Drag the blue dots or the arrows to resize the clip plane.

**Reference Elevation**

Reference elevations are elevations that reference an existing elevation or drafting view. They do not create a new view when you add them to your project.

You can place a reference elevation in a plan or callout view.

**Placing a Reference Elevation**

1. Open a plan or callout view.
2. Click View tab ➤ Create panel ➤ Elevation drop-down ➤ (Elevation).
3. On the Options Bar, select Reference other view.
4. Select a reference view from the adjacent menu. If there are no existing views to reference, you can select <New Drafting View> from the menu. This creates an empty drafting view that is added to the Project Browser under Drafting Views. The default name is Elevation of <level name>. You can edit this view as necessary and rename it.

   **NOTE** If a view from the menu list is on a sheet, the detail number and sheet number display next to the view. For example, if you choose a drafting view, and it is on a sheet, its name displays as Drafting View: Drafting 1 (1/A101), where the values in the parentheses represent the detail number and sheet number.

5. Place the cursor in the drawing area and click to place the reference elevation.
The reference elevation displays in the drawing area with the default reference label, as shown in the following image.

To change the label text, select the reference elevation symbol, and on the Properties palette, click (Edit Type). Edit the Reference Label type parameter and click OK.

Optionally, select the elevation symbol, and add check marks where you want to create additional reference elevations.

When you select a check box, the Select View to Reference dialog opens. Select the view to reference and click OK.

### Framing Elevation Views

Framing elevation views are useful for adding vertical bracing to your model, or for any task that requires quick work plane alignment to a grid or to a named reference plane. When you add a framed elevation, Revit Structure automatically sets the work plane and view range at the selected grid or reference plane. The crop region is also confined to the region between adjacent grid lines that are perpendicular to the selected grid line.

### Creating a Framing Elevation View

**NOTE** You must have a grid in your view, before you can add a framing elevation view. See Grids on page 98 for information on drawing a grid.

1. Click View tab ➤ Create panel ➤ Elevation drop-down ➤ (Framing Elevation).
2. Place the framing elevation symbol perpendicular to the selected grid line and in the direction of view to display, and click to place it.
3 Press Esc to finish.
4 Double-click the elevation arrowhead to open the framing elevation.

The view represents a full-height view of the area at the work plane of the grid or of the reference plane. The view is constrained to the surrounding grids or limits of the reference plane.

Related topics

- Framing Elevation Views on page 733
- Elevation Views on page 730
- Reference Elevation on page 732

Creating Custom Elevation Tags

You can create elevation tags that have any shape, and any number of arrows pointing in any direction relative to the tag body.

Sample elevation tag
Creating a Custom Elevation Tag

You can create a custom elevation tag by nesting a custom pointer family into a custom tag body family.

1. Click ➤ New ➤ Family.
2. In the New Family - Select Template File, navigate to the Annotations folder, and open Elevation Mark Body.rft.
3. Click Modify tab ➤ Properties panel ➤ (Family Category and Parameters).
4. For Family Category, select Elevation Marks.
5. Under Family Parameters, for Elevation Mark Use, select Body.
6. Draw the tag body, and place label(s).

7. Save the family as <elevation tag>.rfa.
8. Repeat steps 2-4, open Elevation Mark Pointer.rft, set Pointer for Elevation Mark Use, draw the pointer, and save the family as <pointer>.rfa.
   Ensure the pointer arrow you create points up as shown here. You can rotate it later in the process, if necessary.

9. From any tab, on the Family Editor panel, click (Load into Project), and load the <pointer>.rfa into the <elevation tag>.rfa.
   Now the pointer family is nested into the body family. Place instances of the pointer family until all directions that you wish to be available in the project are displayed.
Loading the Custom Elevation Tag into a Project

10 Click Insert tab ➤ Family editor panel ➤ (Load into Project) to load the <elevation tag>.rfa into a project.

11 In the project, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Elevation Tags).

12 Duplicate a type, and set the Type Parameter Elevation Mark to use the new elevation tag you loaded previously.

13 Click View tab ➤ Create panel ➤ Elevation drop-down ➤ (Elevation).

14 Click Modify | Elevation tab ➤ Properties panel ➤ (Type Properties).

15 Duplicate the active type.

16 Set the Elevation Tag type parameter to the new type, and click OK.

17 Place an elevation view in the project.

18 Double-click the pointer to open the elevation view or select the elevation body to enable other arrows that exist in the family.

Selected elevation tag in project
Elevation View Properties

Each elevation has type properties for elevation tags, callout tags, and reference labels. To define the look of elevation tags and callout tags, click Manage tab ➤ Settings panel ➤ Advanced Settings drop-down ➤  (Callout Tags) or  (Elevation Tags). The Reference Label parameter sets the text displayed next to the elevation tag when the elevation is a reference elevation.

Modifying Elevation Symbol Properties

You can set various parameters to modify the display of the elevation symbols.

1 Click Manage tab ➤ Settings panel ➤ Advanced Settings drop-down ➤  (Elevation Tags).
2 In the Type Properties dialog, make the necessary changes to the elevation symbol properties.
3 Click OK.

Section Views

Sections views cut through the model. You can draw them in plan, section, elevation, and detail views. Section views display as section representations in intersecting views.

You can create building, wall, and detail section views. Each type has a unique graphical display, and each is listed in a different location in the Project Browser. Building and wall section views display in the Sections (Building Section) branch and Sections (Wall section) branch of the Project Browser. Detail sections appear in the Detail Views branch.

You can cut a section view at the far clip plane. For more information, see Cut a View by the Far Clip Plane on page 854.

Considerations for Section Views in the Family Editor

- You can create a section view in the Family Editor.
- Section views are not available for in-place families.
- If the section symbol appears without a head, you need to load the section head. See Changing the Section Head on page 745.

Creating a Section View

1 Open a plan, section, elevation, or detail view.
2 Click View tab ➤ Create panel ➤  (Section).
3 In the Type Selector on page 35, select Detail, Building Section, or Wall Section.
4 On the Options Bar, select the view scale.
5 Place the cursor at the starting point of the section, and drag through the model or family.

**NOTE** You can snap a section line parallel or perpendicular to a non-orthogonal datum or wall. Snapping to a wall is available in plan views.

6 Click when you reach the end point of the section.
   The section line and the crop region appear and are selected, as the following image shows.

7 If desired, resize the crop region by dragging the blue controls. The depth of the section view changes accordingly.
8 Click Modify or press Esc to exit the Section tool.
9 To open the section view, double-click the section header, or select the section view from the Sections grouping of the Project Browser.
   The section view changes when the design changes or the section line is moved.

**Related topics**
- **Displaying a Section View** on page 743
- **Controlling Section View Width and Depth** on page 740
- **Breaking Section Lines** on page 739
- **Changing the Section Head** on page 745

**Section Tag Visibility**

The section tag is visible in plan, elevation, and other section views, provided its crop region intersects the view range. For example, if you resize the crop region of the section view, so that it no longer intersects the plan view’s view range, the section symbol does not appear in the plan view.

**TIP** The section instance parameter Hide at Scales Coarser Than establishes a scale at which sections are either shown or hidden in other views. For example, a section tag can be hidden at scales coarser than 1/4"=1'0".

Section symbols can display in elevation views even if their crop boundary is turned off. The section displays in elevation if the section line intersects the elevation clip plane. To view and modify the position of the elevation clip plane, select the arrowhead of an elevation symbol in a plan view, and the clip plane appears with drag controls on it. If you resize the clip plane such that it no longer intersects the section line, the section is not visible in the elevation view.

**Related topic**
- **View Tags in Dedicated Views for Design Options** on page 669
Breaking Section Lines

Breaking section lines is useful when you want to create a section view, but you do not want the section line to appear across the drawing. Breaking a section line has no effect on what displays in the section view.

You can break section lines by clicking the break control ( ▼ ) and adjusting the length of the section line segments. The section break is in the middle of the section line. The following images show the same section, whole and broken.

To rejoin the section line, click the break control again.

NOTE A break in a section line is view-specific. It affects the display of the section only in the view where the break was made.

Controlling the Line Style of Broken Section Lines

1 Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Section Tags).
2 Change the value of the Broken Section Display Style property to Continuous or Gapped.
Gapped is the default. If you select Continuous, the section line displays according to the Broken Section Line style defined in the Object Styles dialog. For more information on the Object Styles dialog, see Object Styles on page 1601.

**Controlling Section View Width and Depth**

When you create a section view, Revit Structure sets a default view depth and width. By selecting a section and resizing its crop region, you can control more accurately what displays in the section view.

The following image shows a section and its crop region.

![Section View](image)

Drag the controls on the crop region to resize the width and the depth of the section view, as necessary. The following image shows the same section as above, but with a resized crop region.

![Resized Section View](image)

**Segmented Section View**

You can split sections into segments that are orthogonal to the view direction. This allows you to vary a section view to show disparate parts of the model without having to create a different section.

In the following figure, a typical section is drawn on the model.

![Segmented Section View](image)
The section produces the following view.

Modify the section as shown and the resulting section view changes.

**Segmenting a Section View**

1. Sketch a section in a view, or select an existing section.

2. Click Modify | Views tab ➤ Section panel ➤ (Split Segment).

3. Place the cursor on the section line at the point it is to be segmented, and click.

4. Move the cursor to the side of the split to move, and move the cursor in a direction orthogonal to the view direction.

5. Click to place the section.
The new segmented section has several controls on it. Controls for resizing the crop region display as a dashed green line. All segments share the same far clip plane.

There are controls for moving the segments of the section line.

There is also a break control that divides the section into smaller segments. The break control displays as a Z on the section line. Click it to break up the section even further. When you do, the section has more controls for resizing segments.

**Merging Segmented Section Views**

To change the segmented line into a continuous line, move segments toward one another so that they form a continuous line and merge.

**Reference Sections**

Reference sections are sections that reference an existing view. They do not create a new view when you add them to your project.
You can place reference sections in plan, elevation, section, drafting, and callout views. Reference sections can reference section views, callouts of section views, and drafting views.

To create a reference section:

1. Click View tab ➤ Create panel ➤ (Section).
2. On the Options Bar, select Reference other view, and select a section, callout of a section, or drafting view name from the drop-down menu next to it. If there are no existing views to reference, you can select <New Drafting View> to create a new drafting view; the reference section then references this new drafting view.

**NOTE** If a view from the menu list is on a sheet, the detail number and sheet number display next to the view. For example, if you select a drafting view to be referenced and it is on a sheet, its name displays as Drafting View: Drafting 1 (1/A101), where the values in parentheses represent the detail number and sheet number.

3. Sketch the section line.

**Reference Section Tips**

- There is no parametric relationship between the reference section and the referenced view. Resizing the clip planes of a reference section has no effect on the crop region of the referenced view.
- If you double-click the reference section head, the referenced view opens.
- The reference section head includes a label. To change the label text, edit the Reference Label parameter. It is a type parameter of the section family.
- Any sections placed in a drafting view must be reference sections. They do not create a new section view. The Reference other view option is always selected and cannot be cleared.

**Hiding the Section Annotation Symbol**

You can hide the annotation line and bubble from the current view by selecting the annotation, right-clicking, and selecting Hide in view ➤ Elements (to hide only that section annotation) or Category (to hide all section annotations) from the shortcut menu. To display the annotation again, click (Reveal Hidden Elements) from the View Control Bar, right-click the section annotation symbol and click Unhide in view ➤ Elements or Category.

**Displaying a Section View**

There are several ways to display a section view.

- Select it from the Project Browser. See Project Browser on page 28.
- Double-click the section head.
- Select the section line, right-click on it, and select Go to View from the shortcut menu.
Section Heads

The Section Head Family creates the symbol that displays at the end of the section line. Revit Structure designates a default symbol, but you may want to use your own symbols to define different sections. By specifying a family for section heads, your project can include more than one symbol.

Before reading this topic, you should be familiar with families. See The Families Guide on page 680.

Starting a Section Head Family

When creating a section head family, you define the section head symbol. The section head symbol you create should indicate the viewing direction. You set a viewing direction by sketching an arrow head. The symbol should also include a set of double arrow mirror controls to reverse the viewing direction, if necessary.

Setting Parameters for the Section Head

There are 2 parameters you can set for the symbol: the Drawing Number and the Sheet Number. You can set them by placing Tag Text. The Drawing Number is the number of the view on a sheet. The Sheet Number is the number of the drawing sheet. If you add these parameters to a symbol, they automatically fill in when you add the section view to a project.

The following procedure is a general procedure for creating a section head family. Your steps may differ based on design intent.

1. Click ➤ New ➤ Annotation Symbol.
2. In the Open dialog, select Section Head.rft from the templates folder and click Open.
3. The section head template includes a predefined head. You can use this head or click Home tab ➤ Detail panel ➤ (Line) to create a different one.
4. If desired, add text to the symbol by clicking Text panel ➤ (Text).
Changing the Section Head

1 In the project, click Insert tab ➤ Load From Library panel ➤ (Load Family).
2 Double-click the Annotations folder, and select one or more section head families.
3 Click Open to load the families.
4 Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Section Tags).
5 In the Type Properties dialog, click Duplicate.
6 Enter a name for the new section head, and click OK.
7 Click in the value box for the Section Head parameter and select the section head family you just loaded.
8 Click OK.
9 Click View tab ➤ Create panel ➤ (Section).
10 Click Modify | Section tab ➤ Properties panel ➤ (Type Properties).
11 Click in the value box for the Section Tag parameter, and select a tag from the list.
12 Click OK to save your changes.

Tip for Creating a Section Head Family

The intersection of the 2 perpendicular reference planes represents the origin of the symbol. The origin is the point at which the symbol attaches to the section line. Sketch the lines accordingly.

Section View Properties

Each section has type properties for section tags, callout tags, and reference labels. To define the look of section tags and callout tags, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Callout Tags) or (Section Tags). The Reference Label parameter sets the text displayed next to the section bubble when the section is a reference section.

Modifying Section View Properties

1 Select the section line.
2 On the Properties palette, edit Instance properties as desired.
3 On the Properties palette, click (Edit Type) to edit Type properties.
4 When finished, click OK.

NOTE You cannot modify the Detail Number and Sheet Number properties for a section. These values are automatically filled in when the section view is added to a sheet.
Callout Views

A callout shows part of another view at a larger scale. In a construction document set, use callouts to provide an orderly progression of labeled views at increasing levels of detail.

Callouts Overview

You can add a callout to a plan, section, detail, or elevation view. In these views, the callout tag is linked to the callout view. The callout view shows an enlarged version of part of the parent view, and provides more information or details about that part of the building model.

The view in which a callout is drawn is the parent of the callout view. If the parent view is deleted, the callout is also deleted.

Callout Tag Parts

A callout tag is an annotation element that marks the location of a callout in a parent view.

The callout tag consists of the following parts:

- **Callout bubble.** The line drawn around part of the parent view to define the callout area.
- **Callout head.** A symbol that identifies the callout. When you place the callout on a sheet, the callout head displays the corresponding detail number and sheet number by default.
- **Leader line.** A line that connects the callout head to the callout bubble.
- **Reference label.** For reference callouts only. Text displayed in a callout tag to provide information about the callout.

You can change all parts of the callout tag. See Callout Tags on page 750.

Callout Types

In Revit Structure, you can create reference callouts, detail callouts, and view callouts.
Reference callouts
Use multiple callout tags in different views to refer to one callout view. See Reference Callouts on page 753.

Detail callouts
Use a detail callout when you want to provide details about a part of the building model. The detail callout provides more granular information than the parent view. You can add details and annotations to the detail callout. These details do not display in the parent view.

When you add a detail callout to a view, Revit Structure creates a detail view. (See Detail Views on page 959.) The detail view displays in the Project Browser under Views (all) ➤ Detail Views.

For a detail callout, you can specify whether its callout tag displays in the parent view only or displays in the parent view and intersecting views. For intersecting views, you can automatically hide the callout tag if the scale is coarser than a specified value.

Furthermore, you can specify whether the detail view uses the style and offset that you specify in the detail view parameters, or the same clipping as the parent view. (Elevation and section views use the Far Clipping parameter. Plan views use the Depth Clipping parameter.)

Related topics

- Creating a Callout View on page 747
- Detailing Overview on page 955
- Cutting a Plan View by the Back Clip Plane on page 727
- Cut a View by the Far Clip Plane on page 854

View callouts
Use a view callout when you want to provide more or different information about a part of the parent view.

When you add a view callout to a view, Revit Structure creates a view that has the same view type as the parent view. For example, if you add a callout tag to a structural plan view, the callout view is also a structural plan view, and displays in the Project Browser under Views (all) ➤ Structural Plans.

A view callout offers the same capabilities as its parent view. For example, you can specify another view to use as an underlay, assign a color scheme, and specify a view range. Use properties of the callout view to specify these parameters.

See Creating a Callout View on page 747.

Callouts and Sheets
Callouts are tools for making coherent document sets. They are designed to send the user (builder, contractor, installer) from one view to another. Plan your use of views and callouts to provide a logical sequence that moves the user from large-scale plans to views with greater levels of detail.

You can place callouts on the same sheet as the parent view, or place details on sheets by category. You can use standard details in drafting views as references for multiple callouts that detail the same condition.

Creating a Callout View
You can add a detail callout or a view callout to a plan, section, detail, or elevation view. (See Callout Types on page 746.) When you draw the callout bubble in a view, Revit Structure creates a callout view. You can then add details to the callout view to provide more information about that part of the building model.
1 In a project, click View tab ➤ Create panel ➤ (Callout).
2 In the Type Selector on page 35, select the type of callout to create: a detail callout or a view callout (a callout view that has the same view type as the parent view).
   See Callout Types on page 746.
3 On the Options Bar, for Scale, select a scale for the callout view.
4 To define the callout area, drag the cursor from the upper-left to the lower-right, creating a callout bubble as shown by the dashed line enclosing the upper-left corner of the grid.
5 To see the callout view, double-click the callout head . The callout view displays in the drawing area.

Related topics
■ Opening a Callout View on page 748
■ Creating Details on page 955
■ Modifying a Callout on page 748
■ Visibility of Callouts on page 753

Opening a Callout View
To open a callout view, use any of the following methods:
■ In the Project Browser, double-click the name of the callout view.
■ In the parent view, double-click the callout head.
■ In the parent view, right-click the callout head, and click Go to View.

Modifying a Callout
After creating a callout, you can change it in the following ways.

If you want to... then
change the type of callout tag assigned to a callout see Changing the Callout Tag for a Callout on page 749.
enlarge or reduce the area shown in a callout view see Changing the Boundaries of a Callout on page 749.
If you want to... then
change the format of the callout head, or the information that it displays see Creating a Callout Head Family on page 751.

For a callout bubble:
change the line color, weight, or style see Changing Display Properties for Callout Tags on page 752.
change the radius of the corners see Creating a Callout Tag on page 752.

For the leader line:
change the line color, weight, or style see Changing Display Properties for Callout Tags on page 752.
change the location of the leader line see Adjusting the Callout Leader Line on page 750.

Changing the Callout Tag for a Callout

The callout tag consists of the callout head, callout bubble, and leader line. (See Callout Tag Parts on page 746.) You define the style of the callout head and the radius of the corners of the callout bubble in the callout tag. (See Creating a Callout Tag on page 752.) To assign a callout tag to an existing callout, use the following procedure.

NOTE Define the line weight, color, and style for the callout bubble and the leader line in the project. See Changing Display Properties for Callout Tags on page 752.

To change the callout tag

1 In the parent view, select the callout bubble.
2 On the Properties palette, click (Edit Type).
3 In the Type Properties dialog, for Callout Tag, select the callout tag to use.
   If the desired callout tag is not listed, you can create a new callout tag. See Creating a Callout Tag on page 752.
   You can specify the reference label for a reference callout in the Type Properties dialog. (See Reference Callouts on page 753.) If the callout view is a detail view, you can also specify the section tag to use for this callout.
4 Click OK to save your changes.

Changing the Boundaries of a Callout

The boundaries of the callout bubble define the part of the building model that displays in the callout view.
To change the callout boundaries, do either of the following:
- In the callout view, drag the crop region boundaries.
- In the parent view of the callout, select the callout bubble. Drag a blue dot to change a boundary of the callout.
If you change a callout boundary in one view, Revit Structure automatically updates the other view with the same changes.

**NOTE** You can change the boundaries of a detail callout or a view callout. Resizing the boundaries of a reference callout does not affect the crop region of the referenced view.

### Adjusting the Callout Leader Line

In the parent view of a callout, you can move the leader line to any point on the callout bubble.

**To adjust the callout leader line**

1. In the parent view that displays the callout bubble, select the leader line. A blue elbow control displays in the middle of the line.

   **NOTE** You may need to zoom in on the callout bubble to see the blue controls.

2. Drag the elbow control to the desired location, or drag the blue control near the callout head. As you move the control, notice that the leader line attaches to different points on the callout bubble. The leader line segments snap to vertical and horizontal planes.

### Callout Tags

The callout tag consists of the callout head, callout bubble, and leader line. (See Callout Tag Parts on page 746.) Use the Family Editor to create a callout head family to define the shape of the callout head and the information that it contains. In a project, create a callout tag to specify the callout head family to use and the radius of the corners of the callout bubble. To define the line weight, color, and style for the callout bubble and leader line, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down, and select the appropriate tool.
Creating a Callout Head Family

The callout head is the symbol that displays to identify a callout bubble in a parent view. You can create a callout head family to specify a desired format or to include specific information.

**Callout tags that use different callout heads**

To create a callout head family

1. Click ➤ New ➤ Annotation Symbol.
2. In the Open dialog, select Callout Head.rft or M_Callout Head.rft.
3. Click Home tab ➤ Detail panel ➤ (Line), and sketch the shape of the callout head. See Sketching Elements on page 1406.
4. If desired, click (Text) to add text to the callout head. This text remains constant for each callout that uses this family.
5. Add labels to the callout head.
   A label represents a variable field value that displays in the callout head. For example, the default callout head includes a detail number and sheet number. When you place the callout view on...
a sheet, the callout head in the parent view updates to show the detail number and the sheet number for the callout.

To add a label to the callout head, do the following:

a Click Home tab ➤ Text panel ➤ (Label).

b Move the cursor to the drawing area, and click where you want the information to display in the callout head.

c In the Edit Label dialog, under Category Parameters, select the field to place in the callout head.

d Click (Add parameters to label).

e Click OK.

6 If desired, add filled regions, masking regions, or other details to the callout head.

7 On the Quick Access toolbar, click (Save), and specify a name and location for the new callout head family.

8 To load the callout head family into open projects, click (Load into Project).

Creating a Callout Tag

When creating a callout tag, you can specify the following:

■ The type of callout head to use. See Creating a Callout Head Family on page 751.

■ The radius of the callout bubble.

To specify the line weight, color, and style of the callout bubble or leader line, see Changing Display Properties for Callout Tags on page 752.

To create a callout tag

1 In a project, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Callout Tags).

2 In the Type Properties dialog, for Callout Head, specify the type of callout head to use.

3 For Corner Radius, specify the radius of the corners for the callout bubble.

If your organization uses round callouts, set the radius to a large value.

4 Click OK.

Changing Display Properties for Callout Tags

You can control the line weight, color, and pattern used for callout bubbles and leader lines. The settings that you specify here apply to all callouts in the project.
To change the line styles for callout bubbles and leader lines

1. In a project, click Manage tab ➤ Settings panel ➤ (Object Styles).
2. Click the Annotation Objects tab.
3. Under Category, expand Callout Boundary.
4. Use the Line Weight, Line Color, and Line Pattern columns to specify the desired settings for callout boundaries, callout leader lines, and callout heads.
5. Click OK.

Visibility of Callouts

Revit Structure offers several ways to control the visibility of callout bubbles in a view. If you cannot see callout tags in a view as expected, check the following:

- **Visibility/Graphics setting.** Open the view in which you want to see the callout tag. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics). On the Annotation Categories tab, under Visibility, make sure that Callouts is selected. (To hide all callout tags in the view, clear this option.)

- **Crop region.** If a callout tag does not display in the parent view, check whether the callout tag is outside the parent view’s crop region. In the parent view, on the View Control Bar, click (Show Crop Region). Expand the crop region to the limits of the drawing to find the callout tag. If needed, adjust the crop region to include the callout tag.

- **Hide at scales coarser than.** This view parameter can control whether the tag for a detail callout displays in other views. In the View Properties on page 873 for the callout detail view, the Show in parameter controls the Hide at scales coarser than value. When the Show in value is Parent View Only, Hide at scales coarser than is read-only. When the Show in value is Intersecting Views, you can change the value of the Hide at scales coarser than parameter. As a result, Revit Structure displays the callout tag in any views that intersect the parent view perpendicularly, as long as the view scale is more detailed than the scale specified by Hide at scales coarser than.

Reference Callouts

A reference callout is a callout that refers to an existing view. When you add a reference callout, Revit Structure does not create a view in the project. Instead, it creates a pointer to a specified, existing view. Multiple reference callouts can point to the same view.

Reference Callouts Overview

You can place reference callouts in plan, elevation, section, callout, and drafting views. Multiple reference callouts can point to the same view.
When using reference callouts, consider the following:

- Reference callouts in section, plan, elevation, or callout views can reference cropped views of the same type as the view in which the reference callout is placed.

- Reference callouts in drafting views can reference any plan, section, elevation, or callout view if the crop region displays in these views. Drafting views must use reference callouts; they cannot use detail callouts or view callouts. (See Callout Types on page 746.)

Check the properties of the referenced view to be sure that the Crop View parameter is turned on. See View Properties on page 873.

A reference callout does not have a parametric relationship with the referenced view. Therefore, if you change or resize a reference callout, the changes do not affect the original referenced view. For example, resizing the boundaries of a reference callout does not affect the crop region of the referenced view.

### Creating a Reference Callout

**NOTE** To create a detail callout or a view callout, see Creating a Callout View on page 747.

1. Open the view in which you want to add a callout to a drafting view.

2. Click View tab ➤ Create panel ➤ (Callout).

3. On the Options Bar, select Reference other view, and select a reference view name.

   If there are no existing views to reference, select <New Drafting View> to create a new drafting view. The reference callout will then point to this new drafting view.

   **NOTE** If the Reference Other View list includes a view on a sheet, the detail number and sheet number display next to the view name.

4. To define the callout area, drag the cursor from the upper-left to the lower-right, creating a callout bubble as shown by the dashed line enclosing the upper-left corner of the grid.

5. To see the callout view, double-click the callout head. The callout view displays in the drawing area.

   If you created a new drafting view for the reference callout, the new view displays in the Project Browser under Views (all) ➤ Drafting Views. Create the drafting view as desired. For instructions, see Drafting Views on page 964.
Changing the Reference Label

By default, the callout head for a reference callout includes a label (such as Sim, an abbreviation of Similar). You can change this label to meet project needs or corporate standards. For example, you can use Mirror or Reverse as the reference label.

To change the reference label

1. In the parent view, select the callout bubble.
2. On the Properties palette, click (Edit Type).
3. In the Type Properties dialog, for Reference Label, enter the desired text.
4. Click OK to save your changes.

You can change the way that the reference label displays in the callout tag, or add the referencing detail or sheet numbers to the callout head. To do so, create a callout head family, and add labels that use these parameters. See Creating a Callout Head Family on page 751.

Modifying Callout Properties

1. In the Project Browser, select the callout view.
2. On the Properties palette, click in the Value text boxes to see the detail and sheet numbers. You can also change the view name and scale, and manage crop regions.
3. Click Apply.

Related topics

- Detail View Properties on page 962
- View Properties on page 873
3D Views

You can create perspective and orthographic 3D views in Revit Structure.

**Perspective 3D Views**
Perspective 3D views show the building model in a 3D view where components that are further away appear smaller, and components that are closer appear larger.

You can select elements in a perspective view and modify their type and instance properties. When you create or view a perspective 3D view, the View Control Bar indicates that the view is a perspective view.

**Orthographic 3D Views**
Orthographic 3D views show the building model in a 3D view where all components are the same size regardless of the camera's distance.

**Creating an Orthographic 3D View**

1. Open a plan, section, or elevation view.
2. Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Camera.
3. On the Options Bar, clear the Perspective option.
4. Click once in the drawing area to place the camera, and click again to place the target point.

**Place Camera Above Southeast Corner of Model**

Click View tab ➤ Create panel ➤ 3D View.

This places the camera above the southeast corner of the model with the target positioned on the center of the ground floor.

**Concepts**
An unnamed 3D view of the current project opens and displays in the Project Browser. If an unnamed view already exists in the project, the 3D tool opens the existing view.

You can rename the default 3D view by right-clicking the view name in the Project Browser, and clicking Rename. Named 3D views are saved with the project. When you rename the default, unnamed 3D view, the next time you click the 3D tool, Revit Structure opens a new unnamed view.
You can use a section box to limit the viewable portion of a 3D view.

**Example**

Orthographic 3D views show the building model in a 3D view where all components are the same size regardless of the camera’s distance.

## Creating a Perspective 3D View

Drag the cursor to the desired target and click.

Revit Structure creates a perspective 3D view and assigns a name to the view: 3D View1, 3D View2, and so on. To rename the view, in the Project Browser right-click it, and select Rename.

**NOTE** When used in a workshare enabled file, the 3D view command creates a default 3D view per user. The assigned name to this view is (3D - username).

You can use a section box to limit the viewable portion of a 3D view.

**Example**

**Creating an Orthographic 3D View**

Orthographic 3D views show the building model in a 3D view where all components are the same size regardless of the camera’s distance.

**NOTE** If you clear the Perspective option on the Options Bar, the view that is created is an orthographic 3D view and not a perspective view.

## Adjusting the Camera Position

### Specifying Camera Position in a 3D View

You can set the position of the camera in a 3D view. Changes made to the orientation or position of the 3D camera are considered temporary until they are saved.

1. Open a 3D view.
2. Right-click the ViewCube, and click Orient to View or Orient to a Direction.
   
   Orient to View allows you to select another view. The camera moves to the same location as in the view you specify, and a section box is placed around the model that emulates the extents of the selected view.

   **NOTE** To turn off the section box, in the Project Browser right-click the view name, and select Properties. On the Properties Palette on page 34, clear the Section Box check box.

   Orient to a Direction includes options to orient the camera north, south, east, west, northeast, northwest, southeast, southwest, or top (places the camera at the top of the model).

### Modifying the Camera Position in a Perspective 3D View

**NOTE** Changes made to the orientation or position of the 3D camera are considered temporary until they are saved. For information on saving a 3D view, see Saving a 3D View Orientation as a Project View on page 843.
1 Open the perspective 3D view.
2 In the Project Browser, right-click the perspective 3D view name, and select Show Camera.

The camera is selected in all views where the camera is visible, such as plan, elevation, and other 3D views.

Selected camera in plan view

Selected camera in 3D view
3 In the Project Browser, double-click the view in which you want to modify the camera position (for example plan or elevation).
4 Drag the camera to move it. The view updates according to the new camera position.
5 Drag the target to move it. The view updates according to the new target point.
6 Select the perspective view. Drag the handles to vary the field of view (FOV).

**Turning Off the Camera in a 3D View**

Turning off the camera in a 3D view is the same as showing or hiding the crop region. See [Showing or Hiding Crop Regions](#) on page 850.

To turn off the camera in any other view type, click a blank area in the drawing area.

**Displaying a 3D View**

- Double-click the 3D view name in the Project Browser.
- If the view is open but hidden behind another view, click View tab ➤ Windows panel ➤ Switch Windows drop-down ➤ <view name>.

**Rotating a 3D View**

The target point defines the axis of rotation for a 3D view. You can rotate a 3D view about this axis by modifying the camera level and its focal point. You can tile your project views to see the effects of the rotation in different views.

1 Open the 3D view and any other views where you want to see the effects of rotation.
2 Click View tab ➤ Windows panel ➤ (Tile).
3 In the Project Browser, right-click the 3D view name, and select Show Camera.

**Camera for perspective 3D view**
Camera for orthographic 3D view

The hollow blue dot is the focal point and the pink dot is the target point.

4 Drag the camera to modify the camera level. Drag the hollow blue dot to modify the focal point around the axis of rotation (the target point).

Specifying the Background for a 3D View

After creating a 3D view, you can specify a gradient background for it, with different colors for the sky, horizon, and ground.

In an orthographic view, the gradient is a blend between the horizon color and the sky or ground color. In an orthographic view that is oriented to an elevation view or in a perspective view in which the horizon is visible, the sky meets the ground at the ground plane and blends with the horizon color. The horizon is set to the ground plane for the view (Level 1, by default).

NOTE When you render a 3D view, you can specify clouds and haze for the background of the rendered image, or you can insert a custom image. See Specifying the Background for a Rendered Image on page 1085.

When you export the view to an image or to a 2D DWF file, the gradient background is included. When you export the view to a 3D DWF file, the gradient background is not included.

When you print a 3D view with a gradient background, you can print only using raster processing. To print the view using vector processing, you must first turn off the gradient background.

If you create a view template for a 3D view, the gradient background settings are stored as part of the template under Graphic Display Options.

To specify the background for a 3D view

1 Open the 3D view.

2 Click View tab ➤ Graphics panel ➤ (Graphic Display Options).

3 Under Background, select Gradient background.

4 Select the desired colors for the sky, horizon, and ground.

5 (Optional) If the horizon will be visible in the view, specify the ground level:

   a In the Graphic Display Options dialog, for Sun Position, click … (Browse).

   b In the Sun and Shadow Settings dialog, select Ground Plane at Level, and specify the level to use for the ground plane.

   c Click OK.

6 In the Graphic Display Options dialog, click OK.

The view displays the gradient background, and the horizon and ground, if visible.

Specifying the Background for a 3D View | 761
Change the Extents of a 3D View

You can use a section box to clip the viewable portion of a 3D view. When you enable a section box in a 3D view, the only change to the view is the addition of the section box. The following image shows a 3D view with a section box enabled.

After you enable the section box, you can modify its extents using drag controls in the 3D view, or you can modify extents from other views, for example a plan or elevation view. Section box extents are not cropped by the view's crop region.

To enable a section box:

1. Open a 3D view.
2. On the Properties Palette on page 34, under Extents, select the Section Box option.
3. Click OK.
4. Select the section box and use the drag controls to modify the extents, as necessary.

The following image shows the section box selected with the blue arrow drag controls visible. The section box extents have been modified to cut into the stair tower.
To modify section box extents outside of the 3D view:

1. Enable the section box in a 3D view.
2. Open an associated view, for example a plan or elevation view.
3. In the Project Browser, right-click the 3D view name, and click Show Section Box.
4. Drag the blue arrow controls to resize the section box.

To control visibility of section box extents:

1. Click View tab ➤ Graphics panel ➤ Visibility/Graphic (Visibility/Graphics).
2. In the Visibility/Graphics dialog, click the Annotation Categories tab.
3. Clear the check box for Section Boxes, and click OK to hide the section box extents in the view. Select the check box to show the extents.

### 3D View Properties

Parameter names, values, and descriptions for 3D views.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>View Scale</td>
<td>The scale of the 3D view.</td>
</tr>
<tr>
<td>Scale Value</td>
<td>A ratio derived from the view scale. For example, if the view scale is 1:100, the scale value is the ratio of 100/1 or 100. If you select a value of Custom for the view scale, you can enter a ratio in the value field for this property.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Detail level</td>
<td>Applies the detail level setting to the view: coarse, medium, or fine.</td>
</tr>
<tr>
<td>Visibility/Graphics Overrides</td>
<td>Opens the Visibility/Graphics dialog, where you can set visibility options for the view.</td>
</tr>
<tr>
<td>Visual Style</td>
<td>Changes the display to Hidden Line, Wireframe, Shaded, or Shaded with Edges.</td>
</tr>
<tr>
<td>Graphic Display Options</td>
<td>Click Edit to access the Graphic Display Options dialog, which controls shadows and silhouette lines.</td>
</tr>
<tr>
<td>Discipline</td>
<td>Select the discipline for the view from the list. Select Structural to hide non-load-bearing walls from the view.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>View Name</td>
<td>A name you define for the 3D view.</td>
</tr>
<tr>
<td>Title on Sheet</td>
<td>The name of the view as it appears on the sheet; it supersedes any value in the View Name property.</td>
</tr>
<tr>
<td>Default View Template</td>
<td>Identifies the default view template for the view. See View Templates on page 1637.</td>
</tr>
<tr>
<td>Extents</td>
<td></td>
</tr>
<tr>
<td>Crop View</td>
<td>Applies top, bottom, right, and left clip planes to the model. As you move the clip plane, part of the model is either hidden or shown.</td>
</tr>
<tr>
<td>Crop Region Visible</td>
<td>Turns on or off the visibility of the crop region.</td>
</tr>
<tr>
<td>Annotation Crop</td>
<td>Shows or hides the annotation crop.</td>
</tr>
<tr>
<td>Far Clip Active</td>
<td>Shows or hides the far clip plane.</td>
</tr>
<tr>
<td>Section Box</td>
<td>Turns on or off the visibility of the section box around a 3D view. The box is different from the crop region in that if you rotate the box, the model moves with it. The viewing area does not change. You can use the section box to clip the viewable portion of a 3D model; to see the clipping, when the section box is visible, you can resize it and rotate it with the handles.</td>
</tr>
<tr>
<td>Camera</td>
<td></td>
</tr>
<tr>
<td>Render Settings</td>
<td>Settings used to create a rendered image of the 3D view. See Changing Render Settings for a View on page 1088.</td>
</tr>
<tr>
<td>Perspective</td>
<td>Indicates whether the 3D view is a Perspective view. See Creating a Perspective 3D View on page 758. This is a read-only value.</td>
</tr>
<tr>
<td>Eye Elevation</td>
<td>Height of the camera.</td>
</tr>
<tr>
<td>Target Elevation</td>
<td>Height of the target point.</td>
</tr>
<tr>
<td>Phasing</td>
<td></td>
</tr>
<tr>
<td>Phase Filter</td>
<td>Phase Filter name applied to the view. See Phase Filters on page 879.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Phase</td>
<td>The Phase name applied for the view. See Project Phasing on page 877.</td>
</tr>
<tr>
<td><strong>Type Properties</strong></td>
<td></td>
</tr>
<tr>
<td>Coarse poche material</td>
<td>Defines the material applied to capped faces in coarse-scale views. In coarse scale views, the default material is Poche. In medium and fine views, the capped faces of hosts display the layered structure of the host.</td>
</tr>
</tbody>
</table>
Legend Views

Legends provide a way to display a list of the various building components and annotations used in a project.

Some typical legends include:

- **Annotation Legend.** Displays sheet annotations such as section heads, level markers, spot elevation marks, elevation symbols, keynote symbol, revision tag, element tags, and other symbols that do not represent model objects. Each symbol has an associated piece of descriptive text. All symbols are shown at printed size.

- **Model Symbol Legend.** Displays symbolic representations of model objects with some descriptive text.

- **Line Styles Legend.** Displays a line in a selected line style and text identifying what that line style represents on drawings.

- **Materials Legend.** Displays a sample of a cut or surface pattern and text identifying the material associated with that pattern.

- **Phasing.** Shows a section of wall drawn with a selected graphic override and identifying text.
Legends can be added to multiple sheets. Any elements that can be placed in drafting views, such as detail lines, text, dimensions, and filled regions, can be placed in a legend.

Legend views are unique to each project, and therefore cannot be transferred from one project to another.

**NOTE** A component that is placed in a legend does not count as an additional instance of the component in the building model, and thus is not added to the number of instances of that component listed on a schedule or note block.

### Visibility of Elements in Legends

You can modify legend views by turning off the visibility of subcategories in the view. For more information on category visibility, see *Visibility and Graphic Display in Project Views* on page 801.

### Creating a Legend

1. Click View tab ➤ Create panel ➤ Legends drop-down ➤ (Legend).
2. In the New Legend View dialog, enter a name for the legend view and select the view scale.
3. Click OK.

   The legend view opens and is added to the Project Browser list.

4. Add the desired element symbols to the view using any of the following methods:
   - Drag model and annotation family types from the Project Browser into the legend view. They display as view-specific symbols in the view.
   - Alternate method for adding model family symbols:
     a. Click Annotate tab ➤ Detail panel ➤ Component drop-down ➤ (Legend Component).
     b. On the Options Bar, for Family, select a model family symbol type.
     c. Specify the view direction for the symbol. Some symbols have more options than others.
     d. Place the symbol in the view.
   - Alternate method for adding annotation symbols:
     a. Click Annotate tab ➤ Symbol panel ➤ (Symbol).
     b. From the Type Selector, select an annotation type and place the symbol in the view.

5. Click Annotate tab ➤ Text panel ➤ (Text).

   **NOTE** If the text size you want to use is not listed, click Modify | Place Text tab ➤ Properties panel ➤ Type Properties. In the Type Properties dialog click Duplicate to create a new text type.

6. From the Type Selector, select an annotation type and place the symbol in the view
7. Place the necessary text in the legend.

   For more information about placing text, see *Text Notes* on page 926.
Dimensioning Legend Components

You can add dimensions to individual legend components using the Dimension tool. See Dimensions on page 887 for more information.

You can dimension to most lines within a legend component. However, you cannot dimension to host components, such as walls, ceilings, and floors. Likewise, you cannot dimension system family components within a legend.

Structural component legend with third wide-flange column dimensioned

Placing Components from a Legend into a Project View

You can use legend views as graphical palettes. This means that you can select a component in a legend view and use the Create Similar or Match tools to place the component in another view.

For more information on these tools, see Copying Elements with the Create Similar Tool on page 1497 and Changing Element Types Using the Match Type Tool on page 1497.

Modifying Legend Component Properties

1 Open a legend view.
2 Select a legend component, and on the Properties Palette on page 34, specify the view direction, host length (if applicable), detail level, and component type.

By default, the legend component acquires its detail level from the project view. If the model family type was created to show different geometry at varying detail levels, you can change the look of the model symbol by specifying different detail levels for the view or the symbol itself.
Schedules

In Revit Structure, a schedule is just another way to represent or look at a project.

Schedule Overview

A schedule is a tabular display of information, extracted from the properties of the elements in a project. A schedule can list every instance of the type of element you are scheduling, or it can collapse multiple instances onto a single row, based on the schedule’s grouping criteria.

You can create a schedule at any point in the design process. As you make changes to the project that affect the schedule, it automatically updates to reflect those changes. You can add a schedule to a drawing sheet. See Adding a Schedule to a Sheet on page 1011.

You can export a schedule to another software program, such as a spreadsheet program.

Types of Schedules

You can create several types of schedules:

- Schedules (or Quantities)
- Key Schedules
- Material Takeoffs
- Annotation Schedules (or Note Blocks)
- Graphical Column Schedules
- Revision Schedules (see Revision Schedules on Sheets on page 1028)
- View Lists (see Using View Lists on page 858)
- Drawing Lists (see Sheet Lists on page 1015)

Formatting Schedules

You have several choices available for formatting the look of the schedule. You can

- Specify the order and type of properties to display
- Create totals
• Create your own custom properties, which you can then include in the schedule
• Apply phases to a schedule
• Set conditions to apply background color to cells in the schedule in order to verify design parameters are met.

Schedule Tips
• Mouse-wheel scrolling is available in schedule views. Move the mouse wheel to scroll vertically. Hold Shift and move the wheel to scroll horizontally.
• You can select an element in a non-schedule view from a schedule view. This works best if you are tiling windows. (To tile windows, click View tab ➤ Windows panel ➤ Tile.) To view an element in a non-schedule view, click in the element’s cell in the schedule, and then click Modify Schedule/Quantities tab ➤ Schedule panel ➤ Highlight in Model. The Show Elements in View dialog displays. You can continue to click Show in this dialog to open other views that show the element.

Creating a Schedule or Quantity

1 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.
2 In the New Schedule dialog, select a component from the category list. A default name appears in the Name text box, which you can change as necessary.
3 Select Schedule building components.

   **NOTE** Do not select Schedule keys. If you want to create a key schedule, see Key Schedules on page 772.

4 Specify the phase.
5 Click OK.
6 In the Schedule Properties dialog, specify the schedule properties. See Specifying Schedule Properties on page 788.
7 Click OK.

Related topics
• Modifying Schedules on page 795
• Linked Models in Schedules on page 1195

Key Schedules

Schedules can comprise multiple items that have the same characteristics. For example, a room schedule might have 100 rooms with the same floor, ceiling, and base finishes. Rather than enter all this information manually for all 100 rooms in the schedule, you can define keys that automatically fill in information. If a room has a defined key, then as that room is added to a schedule, fields in the schedule automatically update, reducing the time required to produce the schedule.
You define keys using key schedules. Key schedules look very similar to component schedules, except that you define them to your specifications. When you create a key, it is listed as an instance property for the element. When you apply a value for the key, then the key's attributes are applied to the element.

**Creating a Key Schedule**

1. Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.
2. In the New Schedule dialog, select the schedule key category.
3. Select Schedule keys.
   - Revit Structure automatically fills in the Key name. This is the name that appears among the element's instance properties. If desired, enter a new name.
4. Click OK.
5. In the Schedule Properties dialog, add the predefined fields for the style. For example, add ceiling finish, floor finish, and wall finish.
6. Click OK.
   - The key schedule opens.
7. Click Modify Schedule/Quantities tab ➤ Rows panel ➤ New to add rows to the table.
   - Each row creates a new value for the key. For example, if you are creating a room key schedule, you can create key values for executive conference room, small conference room, large conference room, executive office, standard office, and so on.
8. Fill in the appropriate information for each of the key values.

**Applying a Key to an Element**

1. Select an element that has a predefined key. For example, you might select a room in a plan view.
2. On the Properties palette, find the key name (for example, Room Style), and click in the value column.
3. Select a value for the property from the list.
   - When you apply the new style, the properties defined in the key schedule display as read-only instance properties.

**Applying the Key to a Component Schedule**

1. Create a schedule for the appropriate element (such as a room schedule).
2. Include in the scheduled fields the key name you created. For example, if you created a key name called Room Style, add this key to the schedule.
3. In the schedule, select values for the newly added key. For example, if the key is called Room Style, you add values for it by selecting them from the menus that appear under the key heading.
   - Scheduled fields update automatically with the information you define in the key schedule. If you edit and modify any values in the key schedule, they update automatically in the component schedule.
   - When you apply a key value to a schedule row, you cannot modify any fields defined in the key schedule.
Material Takeoff Schedules

Material takeoff schedules list the sub-components or materials of any Revit Structure family. Material takeoff schedules have all the functionality and characteristics of other schedule views, but they allow you to show more detail about the assembly of a component. Any material that is placed in a component within Revit Structure can be scheduled.

<table>
<thead>
<tr>
<th>Family and Type</th>
<th>Material</th>
<th>Name</th>
<th>Area</th>
<th>Volume</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Wall: Foundation - 11/2” Concrete</td>
<td>Concrete - Cast-in-Place Concrete</td>
<td>1973 SF</td>
<td>132.79 CF</td>
<td></td>
</tr>
<tr>
<td>Basic Wall: Foundation - 3” Footing</td>
<td>Concrete - Cast-In-Place Concrete</td>
<td>1772 SF</td>
<td>131.24 CF</td>
<td></td>
</tr>
<tr>
<td>Basic Wall: Exterior - Brick on CMU</td>
<td>Concrete - Precast Concrete</td>
<td>975 SF</td>
<td>79.14 CF</td>
<td></td>
</tr>
<tr>
<td>Basic Wall: Exterior - Brick on CMU - Batten</td>
<td>Concrete - Precast Concrete</td>
<td>978 SF</td>
<td>79.44 CF</td>
<td></td>
</tr>
<tr>
<td>Penthouse Screen Wall: Penthouse Screen Wall</td>
<td>Wall Finishes - Exterior - Metal Panel</td>
<td>1956 SF</td>
<td>135.38 CF</td>
<td></td>
</tr>
</tbody>
</table>

**NOTE** When Revit Structure computes the volume of materials for individual layers within a wall, some approximations are made to maintain performance. Minor discrepancies might appear between the volumes visible in the model and those shown in the material takeoff schedule. These discrepancies tend to occur when you add a sweep or a reveal to a wall, or under certain join conditions.

Creating a Material Takeoff Schedule

1. Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Material Takeoff.
2. In the New Material Takeoff dialog, click a category for the material takeoff schedule, and click OK.
3. In the Material Takeoff Properties dialog, for Available Fields, select the material attributes.
4. Optionally, sort and group, or format the schedule. See Specifying Schedule Properties on page 788.
5. Click OK to create the material takeoff schedule.

The material takeoff schedule displays, and the view is listed in the Project Browser under Schedules/Quantities.

Annotation Schedules (Note Blocks)

Annotation schedules, or note blocks, list all instances of annotations that you can add using the Symbol tool. See Creating an Annotation Symbol Family on page 953.

Note blocks are useful for listing notes that are applied to elements in your project. For example, you might want to attach a note to several walls, and that note might have a building description for each of the walls.

Creating an Annotation Schedule (Note Block)

1. Load the generic annotation family or families into your project and place them where desired.
   Be sure to enter meaningful information in the parameter values for the annotation. For example, enter some comments for the Description parameter.
2 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Note Block.
3 In the New Note Block dialog, for Family, select a generic annotation.
4 For Note Block Name, enter a name for the new note block, if desired.
5 Click OK.
6 In the Note Block Properties dialog, for Available Fields, select the parameters to set, and then click Add to add them to Scheduled Fields list.
7 Complete any information in the additional Note Block properties tabs. For more information about the tabs, see Specifying Schedule Properties on page 788.
8 Click OK when finished.

**Graphical Column Schedules**

Structural Columns are identified in a Column Schedule by intersecting grid lines and by their top and bottom constraints and offsets. They are placed into the Column schedules according to these identifications.

To view the Structural Column Schedule of a Project, click View tab ➤ Create panel ➤ Schedules drop-down ➤ Graphical Column Schedule. A new view is created, and this view will appear in the Project Browser.

**Columns identified by intersections with splicing and base plates visible**

You can perform the following tasks with Graphical Column Schedules:

- Include off-grid columns. See Including Off-Grid Columns on page 776.
- Filter columns to view.
  - Select specific levels not to display. See Hiding Levels in Graphical Column Schedules on page 782.
  - Define the range of plan levels to display. See Displaying by Plan Level Range on page 783.
Define the range of column locations to display. See Displaying by Column Location Range on page 783.

Filter the columns to view by material. See Displaying by Column Materials on page 783.

Adjust the appearance of the schedule.

Change text properties. See Changing the Text Properties of the Graphical Column Schedule on page 784.

Change the schedule grid display properties. See Changing the Grid Properties of the Graphical Column Schedule on page 784.


Split the schedule. See Splitting the Schedule into Segments on page 786.

Tag the columns in the schedule. See Applying a Tag By Category on page 945 and Tag All Not Tagged on page 947.

Group similar column locations. See Grouping Columns by Similar Locations on page 786.

Apply the schedule to a sheet. See Adding a Sheet on page 979.

Including Off-Grid Columns

Off-Grid columns do not associate with an intersection of two or more grid lines. These columns touch single grid lines or lie completely out of the grid.

Four highlighted off-grid columns (All but A-1 and B-1)

To include off-grid columns in a graphical column schedule:
1 Select the schedule.
2 On the Properties palette, under Graphics, select the Include Off-Grid Columns parameter.
3 Click OK.

Columns relate to the Graphical Column Schedule by their Column Location Marks which are essentially their grid coordinates.
Determining Off-grid Column Location Marks

Off-Grid columns do not align themselves to the typical alpha-numeric plotting because they fall outside of the grid intersections. Revit Structure compensates by calculating and displaying their offsets to nearby grid columns. The determination of positive and negative signs is based on both the columns location in relation to the intersection, and the type of grid lines to which they associate.

<table>
<thead>
<tr>
<th>Column Instance</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right +, Left -</td>
<td>Grid lines parallel to north</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Above +, Below -</td>
<td>Grid lines perpendicular to north</td>
</tr>
</tbody>
</table>

![Diagram showing column location marks]
<table>
<thead>
<tr>
<th>Column Instance</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right +, Left -</td>
<td>Grid lines at 42.686° angle or less</td>
</tr>
<tr>
<td>Above +, Below -</td>
<td>Grid lines at 42.687° angle or greater</td>
</tr>
<tr>
<td>In -, Out +</td>
<td>Grid lines with an arc or circle</td>
</tr>
</tbody>
</table>

If a column lies equidistant to two or more grid intersections, you can select the intersection as you would in a multiple grid line intersection.

See Column Instances in Multiple Grid Line Intersections on page 781.
With those associations in place, notice how the Column Location Mark generates for an off-grid column.

<table>
<thead>
<tr>
<th>Column Instance</th>
<th>Column Location Mark</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Diagram" /></td>
<td>B(1' - 6&quot;)-1</td>
</tr>
<tr>
<td><img src="image2" alt="Diagram" /></td>
<td>A-2(1' - 8 3/8&quot;)</td>
</tr>
<tr>
<td><img src="image3" alt="Diagram" /></td>
<td>C(-1' - 8&quot;)-1(1' - 8&quot;)</td>
</tr>
<tr>
<td>Column Instance</td>
<td>Column Location Mark</td>
</tr>
<tr>
<td>-----------------</td>
<td>----------------------</td>
</tr>
<tr>
<td><img src="image" alt="Column Diagram" /></td>
<td>D-2(-1' - 8 3/8&quot;)</td>
</tr>
<tr>
<td><img src="image" alt="Equidistant Column Diagram" /></td>
<td>Equidistant Column: C-2(-5' - 0&quot;) or C-3(5' - 0&quot;)</td>
</tr>
</tbody>
</table>
Column Instances in Multiple Grid Line Intersections

Columns may be placed at a junction of three or more grid lines. You define the Column Location Marks in the Instance Properties of the column, located under Constraints. The drop-down lists the possible marks for the column.

<table>
<thead>
<tr>
<th>Column Instance</th>
<th>Possible Column Location Marks</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Diagram 1]</td>
<td>E-4 E-5 E F-4 F-5 4-5</td>
</tr>
<tr>
<td>![Diagram 2]</td>
<td>E-4 E-5 F-5 4-5</td>
</tr>
</tbody>
</table>

Including Off-Grid Columns | 781
Hiding Levels in Graphical Column Schedules

To hide one or more levels in the Graphical Column Schedule View, edit the Hidden Levels parameter in the Instance Properties of the schedule.

1. Be sure that the Graphical Column Schedule is visible in the Project Browser.

2. On the Properties palette, under Hidden Levels, click Edit for Value.
   The Levels Hidden dialog opens and lists all levels in the project.

3. Select the levels to hide by clicking the check box next to the corresponding level names.

4. **NOTE** In order for a level to be displayed in the Graphical Column Schedule, it must be left unchecked, and be within the Top/Bottom Level constraints of the Graphical Column Schedule view. For more information on Top/Bottom Level constraints, see View Parameters of Graphical Column Schedules on page 787.

5. Click OK to accept the selections and close the Levels Hidden in Graphical Column Schedules dialog.

6. On the Properties palette, click Apply.
Notice the changes made to the Graphical Column Schedule.

**Displaying by Plan Level Range**

You can select a range of plan levels to display in the Graphical Column Schedule. On the Properties palette, under the Other section, define the range in the Top Level and Bottom Level from the pull-down lists. Their settings are <Top> and <Bottom> by default.

**Displaying by Column Location Range**

You can select a range of column locations to display in the Graphical Column Schedule. On the Properties palette, under the Other section, define the range in the Column Locations Start and Column Locations End from the pull-down lists. They are empty by default.

**Displaying by Column Materials**

You can select which column materials to display in the Graphical Column Schedule. On the Properties palette, under the Other section, click the Material Types Edit button.
Select each material you want to display and click OK. They are all selected by default.

**Changing the Text Properties of the Graphical Column Schedule**

You can adjust the text formatting in the Graphical Column Schedule. On the Properties palette, under the Text section, click the Text Appearance Edit button.

Change the formatting for the three text styles in the schedule: Title, Level, and Column Location and click OK.

**Changing the Grid Properties of the Graphical Column Schedule**

You can adjust the grid formatting in the Graphical Column Schedule. On the Properties palette, under the Graphics section, click the Grid Appearance Edit button.
**For Column Locations**: Width of the Column Locations columns.

**For Level Names**: Width of the Level heading column.

**Above Top Level**: Margin above the top level.

**Below Bottom Level**: Margin below the bottom level.

**Between Segments**: The minimum space between schedule segments.

Adjust the properties and click OK.

---

**Changing the Display Properties of the Columns**

You can define the column instances Level of Detail and Model Graphics Style in the Graphical Column Schedule.

On the Properties palette:

- Under the Graphics section, locate the Detail Level parameter. Select from Coarse, Medium, and Fine.
- Under the Graphics section, locate the Visual Style parameter. Select from Wireframe, Hidden Line, Shading, and Shading w/ Edges.
Splitting the Schedule into Segments

You can split the Graphical Column Schedule by defining a maximum number of columns to display per segment. On the Properties palette, under the Graphics section, enter the number of columns for each segment. The schedule breaks into a new segment when that number of columns is met.

Tag the Columns in a Schedule

You can tag the columns within the Graphical Column Schedule. See Applying a Tag By Category on page 945 and Tag All Not Tagged on page 947.

NOTE You can tag the columns with their locations by selecting Column Location Mark category in the label of the tag.

Grouping Columns by Similar Locations

Locations that are similar have the same type, top levels, bottom levels, offsets, materials, symbolic representation types, and phasing graphics. You can display the Graphical Column Schedule in groups of Similar Locations rather than individual Locations. On the Properties palette, under the Graphics section, select Group Similar Locations.
Applying the Schedule to a Sheet

You can use the Graphical Column Schedule in a construction document sheet. See Adding a Sheet on page 979.

View Parameters of Graphical Column Schedules

You can edit many of the parameters for graphical column schedules directly in the Properties palette. You can adjust which columns display, add titles to rows, and edit the appearance of text and the grid.

Open a graphical column schedule in your project to adjust its view parameters.

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Total Column Locations</td>
<td>This read-only parameter displays the total number of column locations on the schedule.</td>
</tr>
<tr>
<td>Column Location Per Segment</td>
<td>Defines the number of column locations per row. The default setting is 50.</td>
</tr>
<tr>
<td>Group Similar Locations</td>
<td>Groups similar column locations in the view. Column locations are similar if there is a one-to-one correspondence between columns. Similar columns have the same: type, top and bottom levels, offsets, materials, symbolic representation types, and phasing graphics.</td>
</tr>
<tr>
<td><strong>Grid Appearance</strong></td>
<td>The Grid Appearance Edit button opens the Graphical Column Schedule Properties dialog. The Grid Appearance tab displays five parameters for adjusting the Horizontal Widths and Vertical Heights of the grid. See Changing the Grid Properties of the Graphical Column Schedule on page 784.</td>
</tr>
</tbody>
</table>

Notice the locations that the various parameters can adjust.

Include Off-Grid Locations | When checked, grids not aligned at grid intersections are included in the schedule. See Including Off-Grid Columns on page 776. |
| Off-Grid Units Format | This button displays the current dimension format for the schedule. You can click the button to apply custom dimension settings. See Setting Project Units on page 1613. |

**Text**

<p>| Text Appearance | The Text Appearance Edit button opens the Graphical Column Schedule Properties dialog. The text types used in a Graphical Column Schedule are: Title text, Level text, and Column Location text. See Changing the Text Properties of the Graphical Column Schedule on page 784. |</p>
<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Filter</td>
<td>Select the phase of construction that this GCS is to get its data from. If left blank, the GCS generates from all columns throughout the project.</td>
</tr>
<tr>
<td>Phase</td>
<td>Select a phase of construction (for example: New Construction, Existing, or All by leaving the field blank).</td>
</tr>
<tr>
<td><strong>Other</strong></td>
<td></td>
</tr>
<tr>
<td>Hidden Levels</td>
<td>Opens the Levels Hidden in Graphical Column Schedules dialog to select levels not meant for the schedule. See Hiding Levels in Graphical Column Schedules on page 782.</td>
</tr>
<tr>
<td>Top Level</td>
<td>This parameter defaults to &lt;Top&gt;, but can specify any level in the project as the top.</td>
</tr>
<tr>
<td>Bottom Level</td>
<td>This parameter defaults to &lt;Bottom&gt;, but can specify any level in the project as the bottom.</td>
</tr>
<tr>
<td><strong>NOTE</strong></td>
<td>Columns out of the range defined by the Top Level and Bottom Level parameters do not display. The view of graphical column schedule sizes accordingly.</td>
</tr>
<tr>
<td>Column Locations Start</td>
<td>Specifies the column in which the view starts.</td>
</tr>
<tr>
<td>Column Locations End</td>
<td>Specifies the column in which the view ends.</td>
</tr>
<tr>
<td>Material</td>
<td>Click the edit button, and a dialog with five options appears: Steel, Concrete, Precast Concrete, Wood, and Other. Only columns with materials matching the ones checked display.</td>
</tr>
</tbody>
</table>

### Specifying Schedule Properties

After you have specified the desired type of schedule, you need to specify the information to include on the schedule and how the information should display.

You set schedule properties in the Schedule Properties dialog, which displays automatically during schedule creation. To access this dialog subsequently, click the schedule name in the Project Browser. Then, on the Properties palette, click Edit for any of the parameters in the Other category.

### Selecting Fields for a Schedule

On the Fields tab of the Schedule Properties dialog, you can select the fields that appear in the schedule. The following table lists the tasks you can complete from this tab.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a field to the Scheduled Fields list</td>
<td>click a field name in the Available Fields box, and click Add. The order of the fields in the Scheduled Fields box shows the order in which they appear in the schedule.</td>
</tr>
<tr>
<td>remove a name from the Scheduled Fields list</td>
<td>select it from the Scheduled Fields list, and click Remove.</td>
</tr>
<tr>
<td>move a field up or down in the list</td>
<td>select the field, and click Move Up or Move Down.</td>
</tr>
</tbody>
</table>
If you want to... then...

add a custom field

click Add Parameter, and select whether to add a project parameter or shared parameter. For more information, see Parameters on page 1541.

modify a custom field

select the field, and click Edit. In the Parameter Properties dialog, enter a new name for the field. Click Delete to delete a custom field.

create a field whose value is calculated from a formula

click Calculated Value. Enter a name for the field, set its type, and enter the formula for it using existing fields in the schedule.

For example, if you want to calculate an occupancy load based on the area of a room, you could add a custom field called Occupancy Load that is calculated from the Area field. Formulas support the same mathematical functions as in the Family Editor. For more information on creating formulas, see Using Formulas for Numerical Parameters on page 1553.

create a field that is a percentage of another field

click Calculated Value. Enter a name for the field, set its type to percentage, and enter the name of the field to take a percentage of.

By default, percentages are calculated based on the total for the entire schedule. If you set grouping fields in the Sorting/Grouping tab, you can choose one of those fields here. For example, if you group a room schedule by level, you can display what percentage of the total area of the level the room occupies.

add room parameters to a non-room schedule

for Select Available Fields From, click Room. This changes the list of fields in the Available Fields box to a list of room parameters. You can then add those room parameters to the list of scheduled fields.

include elements from linked models

select Include elements in linked files. For more information, see Linked Models in Schedules on page 1195

Limiting Data Presented in a Schedule

On the Filter tab of the Schedule Properties dialog, you can create filters that limit the display of data in a schedule. You can create up to 4 filters, and all filters must be satisfied for the data to display. See Schedule Overview on page 771.

Many types of scheduled fields can be used to create filters. Types include text, number, integer, length, area, volume, yes/no, level, and key schedule parameters.

Filtering is not supported for the following scheduled fields:

- Family
- Type
- Family and Type
- Area Type (in area schedules)
From Room, To Room (in door schedules)

Material parameters

You create a filter based on fields in the project. To create a filter based on a field that does not display in the schedule, you add the field to the Scheduled Fields list, then hide it on the Formatting tab.

Sorting Fields in a Schedule

On the Sorting/Grouping tab of the Schedule Properties dialog, you can specify sorting options for rows in a schedule, and add headers, footers, and blank lines to sorted rows.

You can also choose to show every instance of an element type, or collapse multiple instances onto a single row.

You can sort by any field in a schedule, except Count.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then select...</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify a sort field</td>
<td>a field for Sort By, and select Ascending or Descending. Select additional sort fields for Then By, if necessary.</td>
</tr>
<tr>
<td>add the sorting parameter value as a header for the sort group</td>
<td>Header.</td>
</tr>
<tr>
<td>add footer information below the sort group</td>
<td>Footer. When you select Footer, you can select the information to display.</td>
</tr>
<tr>
<td></td>
<td>■ Title, count, and totals: Title shows the header information. Count shows the number of elements in the group. Both title and count appear left-justified below the group. Total shows the subtotal below a column that can have a total. Examples of columns having subtotals are Cost and Count. You can have totals calculated for these columns on the Formatting tab.</td>
</tr>
<tr>
<td></td>
<td>■ Title and totals: Displays title and subtotal information.</td>
</tr>
<tr>
<td></td>
<td>■ Count and totals: Displays both count values and subtotals.</td>
</tr>
<tr>
<td></td>
<td>■ Totals only: Displays subtotals only for columns that can have them.</td>
</tr>
<tr>
<td>insert a blank line between sort groups</td>
<td>Blank Line.</td>
</tr>
<tr>
<td>itemize every instance of an element in the schedule</td>
<td>Itemize every instance. This option displays all instances of an element in individual rows. If you clear this option, multiple instances collapse to the same row based on the sorting parameter. If you do not specify a sorting parameter, all instances collapse to one row.</td>
</tr>
</tbody>
</table>

Adding Grand Totals to a Schedule

1 In the Project Browser, select the schedule name.
2 On the Properties palette, for Sorting/Grouping, click Edit.
3 On the Sorting/Grouping tab, select Grand Totals to display the sum of the elements from all the groups.
Grand totals also display the sum of any columns with subtotals.

4 Select a display option from the drop-down menu:

- **Title, count, and totals.** Title shows the header information. Count shows the number of elements in the group. Both title and count appear left-justified below the group. Total shows the subtotal below a column that can have a total. Examples of columns having subtotals are Cost and Count. You add these columns using the Formatting tab.

- **Title and totals.** Displays title and subtotal information.

- **Count and totals.** Displays count values and subtotals.

- **Totals only.** Displays subtotals only for those columns that can have them.

5 Click OK.

### Adding Column Totals to a Schedule

1 In the Project Browser, select the schedule name.
2 On the Properties palette, for Formatting, click Edit.
3 Select the field to add a column total for, and select Calculate Totals.

**NOTE** Column totals will not appear if the Grand Totals option on the Sorting/Grouping tab is not selected. For information on grand total display options, see Adding Grand Totals to a Schedule on page 790.

4 Click OK.

### Formatting a Schedule

On the Formatting and Appearance tabs of the Schedule Properties dialog, you can specify various formatting options, such as column orientation and alignment, grid lines, borders, and font style. Options you select on the Appearance tab display when you add a schedule to a sheet view.

#### Formatting Tab Options

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>edit the title that appears above a column in a schedule</td>
<td>select a field to display it in the Heading text box. You can edit each column name.</td>
</tr>
<tr>
<td>specify the orientation of a column heading on a sheet only</td>
<td>select a field. Then for Heading Orientation, select an orientation option.</td>
</tr>
<tr>
<td>align text in the rows under a column heading</td>
<td>select a field, then select an alignment option from the Alignment drop-down menu.</td>
</tr>
<tr>
<td>format the appearance of numeric fields</td>
<td>see Formatting Units and Number Fields in a Schedule on page 792.</td>
</tr>
<tr>
<td>format the appearance of currency fields</td>
<td>see Formatting Currency Fields in a Schedule on page 793.</td>
</tr>
<tr>
<td>display subtotals for a numeric column in a group</td>
<td>select the field, then select Calculate Totals. This setting is available only for fields that can be totaled, such as room area, cost, count, or room perimeter. If you clear the Grand Totals option on the Sorting/Grouping tab, no totals display.</td>
</tr>
</tbody>
</table>
If you want to... | then...
---|---
hide a field in a schedule | select the field, then select Hidden field. This option is useful when you want to sort the schedule by a field, but you do not want that field to display in the schedule.
highlight a cell in a schedule based on a set of conditions | see Formatting Cells Based on Set of Conditions in a Schedule on page 794.

TIP You can show or hide any columns while in the schedule view. To hide a column, select a cell in the column, and then right-click. From the shortcut menu, select Hide Column(s). To display all hidden columns, right-click in the schedule view, and select Unhide All Columns.

### Appearance Tab Options

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then select...</th>
</tr>
</thead>
<tbody>
<tr>
<td>display grid lines around schedule rows</td>
<td>Grid lines, and then select the grid line style from the list.</td>
</tr>
<tr>
<td>extend vertical grid lines into headers, footers, and spaces</td>
<td>Grid in headers/footers/spacers.</td>
</tr>
<tr>
<td>display a border around the schedule</td>
<td>Outline, and then select a line style from the list. The border displays when you add a schedule to a sheet view. If you clear this option, but the Grid lines option is still selected, the grid line style is used as the border style.</td>
</tr>
<tr>
<td>specify the font for the heading text</td>
<td>a font from the list, enter a font size, and select bold or italic attributes.</td>
</tr>
<tr>
<td>display the title of the schedule</td>
<td>Title. To create a different underscore line style, select Underline, and then select the line style from the list.</td>
</tr>
<tr>
<td>display the scheduled fields as column titles</td>
<td>Column headers. To create a different underscore line style, select Underline, and then select the line style from the list.</td>
</tr>
<tr>
<td>insert a blank row before the data rows</td>
<td>Blank row before data. This option affects both the schedule segment on the sheet and the schedule view.</td>
</tr>
<tr>
<td>specify the font for the body text</td>
<td>a font from the list, enter a font size, and select bold or italic attributes.</td>
</tr>
</tbody>
</table>

### Formatting Units and Number Fields in a Schedule

1. In the Project Browser, select the schedule name.
2. On the Properties palette, for Formatting, click Edit.
3. In the Schedule Properties dialog, select a length (includes height fields), area, volume, angle, or Number field from the Fields list.
NOTE A Number field is a project parameter or calculated value that was created as a Number type. When you create a calculated value on the Fields tab of the Schedule Properties dialog, you see the Calculated Value dialog, where you can select the type. The following image shows this dialog with the Number type selected.

4 Click Field Format.

The Format dialog opens with the Use project settings option selected by default, meaning that values display according to the units setting in the project.

5 Clear the Use project settings option.

6 If you selected a length, area, volume, or angle field:
   a For Units, select an appropriate unit.
   b For Rounding, select an appropriate value. If you select Custom, enter a value in the Rounding increment text box.
   c If applicable, select a Unit symbol.

7 If you selected a Number field, select one of the following formatting options:
   ■ **General.** Displays values with up to 6 decimal places, and removes trailing zeros.
   ■ **Fixed.** Allows you to specify rounding, and preserves trailing zeros.
   ■ **Percentage.** Multiplies the value by 100, and inserts a percent sign (%) adjacent to the value.

8 Click OK.

**Formatting Currency Fields in a Schedule**

1 In the Project Browser, select the schedule name.
2 On the Properties palette, for Formatting, click Edit.
3 Select the Cost field or a Currency field from the Fields list.
NOTE A Currency field is a parameter or calculated value that was created as a Currency type.

4 Click Field Format.
5 Clear the Use project settings option.
6 For Rounding, select an appropriate value. If you select Custom, enter a value in the Rounding increment text box.
7 For Unit symbol, select the appropriate currency symbol.
8 Optionally, select Suppress trailing 0’s if you do not want trailing zeros to display (for example, 123.400 displays as 123.4).
9 Optionally, select Use digit grouping.
   When selected, the Decimal symbol/digit grouping option specified in the Project Units dialog is applied to the unit value.
10 Click OK.

**Formatting Cells Based on Set of Conditions in a Schedule**

You can use conditional formatting in schedules to visually identify parameters that meet or do not meet design standards. For example, you can set a condition to indicate that an area has a square footage under a specified minimum.

1 In the Project Browser, select the schedule name.
2 On the Properties palette, for Formatting, click Edit.
3 For Field, select a field to format.

**NOTE** Ensure that you select the field to format in this dialog. If you select a new field in the Conditional Formatting dialog, you are not specifying a new condition but are adding an additional condition to the field selected in step 3.

4 Click Conditional Format.
   The Conditional Formatting dialog opens.
5 For Field, the field that you selected in step 3 displays. The Field drop-down contains the list of fields that are in the schedule.

6 For Test, click the drop-down to select the formatting rule.

7 Specify the conditional value(s).

   The value fields become a single field for any condition other than Between or Not Between.

8 For Background Color, click the color swatch.

   The Color Selection dialog appears.

9 Specify the background color for the cell and click OK.

10 Optionally, to apply additional conditions to the field specified in step 3, select the Field drop-down. Then for Test, select the rule. This new condition applies to the field (row).

   The Conditions to Use box displays the specified conditions. Press Clear All to delete the specified conditions if you want to start over and add new conditions.

11 Click OK twice.

   In the Schedule, the affected cells display background color when conditions are met.

### Applying a Phase to a Schedule

1 In the Project Browser, select the schedule name.

2 On the Properties palette, under Phasing, select values for the Phase Filter and Phase parameters.

3 Click Apply.

   For more information on phases, see Project Phasing on page 877.

### Modifying Schedules

There are various ways to modify schedules to improve the readability and to keep them up to date with changes in your project.

#### Schedule Updates

All schedules update automatically when you modify the project. For example, if you move a wall, the square footage updates in a room schedule accordingly.
When you change the properties of building components in the project, the associated schedule updates automatically.

**Editing Cells in a Schedule**

You can edit the cells in a schedule by clicking in them. You can either select a value from a list (if available) or enter text. As you add new values, they become available in that field's list.

To enter carriage returns in a text cell, press `Ctrl+Enter`. Carriage returns display when you place the schedule on a sheet.

For schedules grouped by type, changes to a type are propagated to all instances of that type within the project.

**Grouping Column Headings in a Schedule**

After you create a schedule, you may want to change its organization and structure by grouping columns. You can create several layers of headings and subheadings to provide more detail in your schedule.

1. Open a schedule view.
2. In the group header rows, drag the cursor across the headings to group.
   
   Be sure the cursor appears as an arrowhead as you select the headings, as shown in the following image.

3. Click Modify Schedule/Quantities tab ➤ Headers panel ➤ Group, or right-click the selected headings, and click Group Headers.
   
   A new heading row displays above the grouped column headings, as shown in the following image.

4. Enter text in the new row as necessary.
   
   Text in the new heading row is centered.

To modify the text in a column group heading, click the heading field and edit the text. To delete the column heading row, select the heading and, click Modify Schedule/Quantities tab ➤ Headers panel ➤ Ungroup, or right-click in the heading cell, and click Ungroup Headers.

**Hiding Schedule Columns**

1. Open a schedule view.
2. Right-click a column, and click Hide Column.

**Deleting Schedule Rows**

1. Open a schedule view.
2. Select a row in the schedule.
3. Click Modify Schedule/Quantities tab ➤ Rows panel ➤ Delete.
Reusing Schedule Views

Schedule formatting can be saved as a view template and applied to or reused in another project. Templates can be applied to selected schedules or to all schedules on selected sheets. By default, new schedules can be based on a template through a setting on the Apply View Template dialog.

For more information on view templates, see View Templates on page 1637.

Saving Schedule Views to an External Project

Use the following procedure to save the format of a schedule view to an external Revit Structure file for use in another Revit Structure project.

1. In the Project Browser, right-click the schedule view name, and click Save to New File.
2. In the Save As dialog, enter a name for the file, and click Save.

This procedure saves the formatting of the schedule, but not the actual scheduled components.

Related topics
- Inserting Schedule Views from Another Project on page 797
- Exporting a Schedule on page 798

Inserting Schedule Views from Another Project

1. Click Insert tab ➤ Import panel ➤ Insert from File drop-down ➤ Insert Views from File.
2. Select a Revit Structure project that contains the views to insert, and click Open.
   All the views that are saved with the project, display in the Insert Views dialog.
3. Select the views to display from the list.
4. Check the views you would like to insert, and click OK.

A new schedule view is created in the Project Browser with all the saved formatting of the original schedule, and all the parameter fields that may have been customized for that schedule.

Related topics
- Saving Schedule Views to an External Project on page 797
- Inserting a Drafting View from Another Project on page 967
- Inserting Detail Components from a Saved Detail View on page 963

Foundation Footings Schedule Example

In this example, a footing schedule is created. The following illustration is used for the example.
Sample structural foundation plan used for creating schedule

1 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.
2 In the New Schedule dialog, select Structural Foundation for Category.
3 For Name, enter Foundation Schedule.
4 Click OK.
5 In the Schedule Properties dialog, add the following available fields (in this order) to the Scheduled Fields list: Type, Length, Width, Volume, Count, and Comments.
6 Click the Sorting/Grouping tab.
7 Set the first Sort By list to Type.
8 Clear the Itemize every instance option.
9 Click OK.
10 You may add this schedule to a sheet. See Adding a Schedule to a Sheet on page 1011.

Exporting a Schedule

You can export a schedule as a delimited text file, which can be opened in many spreadsheet programs. If you add a schedule to a sheet, you can export it as a CAD format.

To export a schedule:

1 Open a schedule view.
2 Click ➤ Export ➤ Reports ➤ Schedule.
3 In the Export Schedule dialog, specify a name and directory for the schedule, and click Save. The Export Schedule dialog appears.
4 Under Schedule appearance, select export options:
- Export column headers: specifies whether Revit Structure column headers export.
  - One row: only the bottom column header exports.
  - Multiple rows, as formatted: all column headers export, including grouped column header cells.
- Export group headers, footers, and blank lines: specifies whether sort group header rows, footers, and blank lines export.

5 Under Output options, specify how you want to display the data in the output file:
- Field delimiter: specifies whether fields in the output file are separated by tabs, spaces, commas, or semi-colons.
- Text qualifier: specifies whether the text in each field of the output file should be enclosed by a single or double quote, or no annotation.

6 Click OK.

Revit Structure saves the file as delimited text, a format that can be opened in spreadsheet programs, such as Microsoft® Excel or Lotus® 123.
Visibility and Graphic Display in Project Views

You can override the visibility and graphic display of model elements, annotation elements, imported elements, linked Revit model elements, and workset elements for each view in a project. The settings that you are overriding are those specified at the project level. Project level settings are specified in the Object Styles dialog. See Object Styles on page 1601.

You can override the cut, projection, and surface display for model categories and filters. For annotation categories and imported categories, you can edit the projection and surface display. In addition, for model categories and filters, you can apply transparency to faces. You can also specify visibility, half-tone display, and detail level of an element category, filter, or individual element.

Related topics

- Changing the Line Style of Elements on page 1498
- Defining the Graphic Display for Phase Statuses on page 880

Overview of Visibility and Graphic Display

Most overrides for visibility and graphic display are made in the Visibility/Graphics dialog. The exception is for individual element overrides; these are made in the View-Specific Element Graphics dialog.

From the Visibility/Graphics dialog, you can view overrides that have already been applied to a category. If the graphic display of a category has been overridden, the cell displays a preview of the graphic. If no overrides have been made to a category, the cell is blank, and the element displays as specified in the Object Styles dialog.

In the following image, the doors category has overrides for projection/surface lines and for cut pattern.
For information on visibility settings for elements in linked Revit models and elements in worksets, see Visibility of Linked Models on page 1187 and Changing the Visibility of a Workset in a View on page 1231.

**Creating Views for Specific Purposes**

Because you can control element visibility and graphic display by view, you can create views for specific purposes.

**Overriding Visibility and Graphic Display of Individual Elements**

*NOTE* If you need to override the visibility and graphic display for element categories, see Overriding Graphic Display of Element Categories on page 803 and Specifying Element Category Visibility on page 805. You can also override the graphic display of individual elements using the Linework tool. See Changing the Line Style of Elements on page 1498.

1. Open the view in which you want to override the visibility or graphic display of individual elements.
2. In the drawing area, right-click the element you want to override, and click Override Graphics in View ➤ By Element.
   The View-Specific Element Graphics dialog opens and displays the current visibility and graphic display settings for the element. You may need to expand the categories to view setting details.
3 In the View-Specific Element Graphics dialog, make your edits.

**NOTE** For annotation, import, and detail elements, only relevant override options display.

- Visible: show or hide the element in the view.
- Halftone: blend the line color of an element with the background color of the view. All line graphics (including fill patterns) and solid fills are drawn halftone when this option is selected. Halftone has no effect on material color in shaded views. See Halftone/Underlay on page 1605.
- Transparent: display only lines for the element and not surfaces. When elements are transparent, only edges and fill patterns (including solid fills) are drawn on element faces. The faces between pattern lines are not drawn. In Hidden Line view and Shaded with Edges view, parts of edges are hidden. An edge can be hidden by the face of any non-transparent element and by a face of its own element (even when it is marked transparent). Edges are not hidden by other transparent elements.
- Projection Lines: edit the line weight, color, and pattern.
- Surface Patterns: edit visibility, color, and pattern.
- Cut Lines: edit the line weight, color, and pattern.
- Cut Patterns: edit visibility, color, and pattern.

After you edit any of the above, you can click Apply to keep the View-Specific Element Graphics dialog open and instantly see how the change affects the model.

4 When finished, click OK.

**NOTE** Individual element overrides are not stored in view templates.

### Overriding Graphic Display of Element Categories

**NOTE** If you need to override the visibility or graphic display for an individual element, see Overriding Visibility and Graphic Display of Individual Elements on page 802.

1 Open the view in which you want to override the graphic display of element categories.
2 Right-click an element in the drawing area, and click Override Graphics in View ➤ By Category. When you use this method, the element’s category is already highlighted when the Visibility/Graphics dialog opens.

Alternatively, you can click View tab ➤ Graphics panel ➤ Graphics (Visibility/Graphics).

**NOTE** If you open the Visibility/Graphics dialog from a drafting view, only those categories that can appear in a drafting view display.

3 If necessary, click the appropriate tab in the Visibility/Graphics dialog (Model Categories, Annotation Categories, or Imported Categories).

**If you are overriding element categories in a linked Revit model**

- a Click the Revit Links tab.
- b Click the button in the Display Settings column.
- c In the RVT Link Display Settings dialog, click Custom.
d Click the appropriate tab (Model Categories, Annotation Categories, or Imported Categories).
e Select Custom from the drop-down menu.

4 Highlight a category row.
5 Click the Override button for the line or pattern to edit.

**NOTE** For annotation and imported categories, you can only override projection and surface display.

6 For lines, edit the line weight, line color, and line pattern. For patterns, edit the fill color and fill pattern.
7 (Optional) Select the Halftone check box next to a category to blend the line color of an element with the background color of the view. This produces a lighter shade for the line color. (See **Halftone/Underlay** on page 1605.)
8 For model categories, you can also select a detail level at which to display the element category. The detail level of the category overrides the detail level of the view. For example, you can set a wall to display at medium or fine detail level to see its structure, even if the view detail level is set to coarse.
   You cannot set the detail level for subcategories. They inherit it from their parent category.
9 Click Apply to view your changes, and click OK to exit the Visibility/Graphics dialog.

**Related topics**
- Controlling Visibility and Graphic Display of Elements Using Filters on page 806
- Removing Graphic Display Overrides for Element Categories on page 804
- Applying Transparency to Faces of Model Element Categories on page 806

**Removing Graphic Display Overrides for Element Categories**

1 Open the view in which you want to remove graphic overrides.
2 Right-click an element in the drawing area, and click Override Graphics in View ➤ By Category. When you use this method, the element’s category is already highlighted when the Visibility/Graphics dialog opens.
   Alternatively, you can click View tab ➤ Graphics panel ➤ (Visibility/Graphics).

**NOTE** If you open the Visibility/Graphics dialog from a drafting view, only those categories that can be shown in a drafting view display.

3 If necessary, click the appropriate tab in the Visibility/Graphics dialog (Model Categories, Annotation Categories, or Imported Categories).
   If you are editing element categories in a linked Revit model:
   a Click the Revit Links tab.
   b Click the button in the Display Settings column.
   c In the RVT Link Display Settings dialog, click Custom.
   d Click the appropriate tab (Model Categories, Annotation Categories, or Imported Categories).
   e Select Custom from the drop-down menu.
4 Highlight a category row or rows.
5 Click the Override button for the line or pattern to edit.
6 Click Clear Overrides.
7 Click Apply to view your changes, and click OK to exit the Visibility/Graphics dialog.

When you remove a graphic display override, the element category displays in the view according to the settings specified in the Object Styles dialog. For more information, see Object Styles on page 1601.

### Specifying Element Category Visibility

**NOTE** For information about visibility settings for element categories in linked Revit models and worksets, see Visibility of Linked Models on page 1187 and Changing the Visibility of a Workset in a View on page 1231.

1 Right-click an element in the drawing area, and click Override Graphics in View ➤ By Category. When you use this method, the element’s category is already highlighted when the Visibility/Graphics dialog opens.

Alternatively, you can click View tab ➤ Graphics panel ➤ (Visibility/Graphics).

**NOTE** If you open the Visibility/Graphics dialog from a drafting view, only those categories that can be shown in a drafting view display.

2 Click the Model Categories, Annotation Categories, or Imported Categories tab.

3 To set category visibility, select or clear the check box next to the category or subcategory. If you clear the check box for a category, all subcategories for that category will not be visible in the view.

4 To hide all categories, clear the check box at the top of the tab. For example, to hide all model categories, clear the Show model categories in this view check box.

By default, the Visibility/Graphics dialog lists only those element categories that are appropriate to the particular discipline of Revit you are working with (for example, Revit Structure). To list categories from all disciplines, select the Show categories from all disciplines check box.

5 Click Apply to view your changes, and click OK to exit the Visibility/Graphics dialog.

### Controlling Category Selection

- Click All to select all rows in the table. If the visibility of all categories is selected, you can clear it for all categories by clearing one category.

- Click None to clear the selection of any selected rows.

- Click Invert to change the selection of rows between the ones that are selected and the ones that are not. For example, if 6 rows are selected and you click Invert Selection, those 6 rows are no longer selected and all others are.

- Click Expand All to expand the entire category tree and make all subcategories visible. This makes it easier to select all categories and subcategories, using the All tool.

- Select a cell with a check box and press `Spacebar` to select or clear the check box.

- Select a category row with focus in the Visibility cell. Press `Right Arrow` to expand the category tree. Press `Left Arrow` to collapse the tree.
Applying Transparency to Faces of Model Element Categories

NOTE If you need to apply transparency to an individual model element face, see Overriding Visibility and Graphic Display of Individual Elements on page 802.

1. Open the view in which you want to apply transparency to model category faces.
2. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics), or right-click an element in the drawing area, and click Override Graphics in View ➤ By Category.
3. In the Visibility/Graphics dialog, click the Model Categories tab.
   If you are editing model categories for elements in a linked Revit model:
   a. Click the Revit Links tab.
   b. Click the button in the Display Settings column.
   c. In the RVT Link Display Settings dialog, click Custom.
   d. Click the Model Categories tab.
   e. Select <Custom> from the drop-down menu.
4. Highlight a category row or rows.
5. In the Transparent column, select the check box.
6. Click Apply to view your changes, and click OK to exit the Visibility/Graphics dialog.

When elements are transparent, only edges and fill patterns (including solid fills) are drawn on element faces. The faces between pattern lines are not drawn. In Hidden Line view and Shaded with Edges view, parts of edges are hidden. An edge can be hidden by the face of any non-transparent element, and by a face of its own element (even when it is marked transparent). Edges are not hidden by other transparent elements.

Controlling Visibility and Graphic Display of Elements Using Filters

Filters provide a way to override the graphic display and control the visibility of elements that share common properties in a view.

Creating a Criteria-Based Filter

1. Click View tab ➤ Graphics panel ➤ (Filters).
2. In the Filters dialog, click New.
3. Enter a name for the filter.
4. Select one of the following options:
   ■ Define Criteria - Opens the Filters dialog where you can create a filter.
     a. In the Filters dialog, click (New), or select an existing filter and click (Duplicate).
     b. If you are creating a new filter, in the Filter Name dialog, enter a name for the filter.
        If you are duplicating an existing filter, the new filter displays in the filters list. For example, if you are duplicating a filter called Column Filter, the name Column Filter 1 displays in the Filters list. To rename the filter, click the name, and click (or right-click the name, and click Rename).
c Click OK.

d Under Categories, click one or more categories to include in the filter. The categories that you select determine the parameters that are available in the Filter By lists. The parameters that display are those that are common to all selected categories.

e From the Filter By list, select the parameter to filter by. If the parameter that you want to filter by is not in the list, click More Parameters to view additional parameters or to create a custom parameter. To create a custom parameter (for example, NIC [not in contract]):

a In the Project Parameters dialog, click Add.

b In the Parameter Properties dialog, enter the parameter data. In this example, the parameter name is NIC, the discipline is Common, the Type of Parameter is Yes/No, the parameter is grouped on the Properties palette under Other, the parameter is an instance parameter, and the parameter only applies to elements in the Casework and Furniture categories.

c Click OK.

d If elements are selected in the drawing area, the Parameter Value dialog opens. Specify a parameter value for the selected elements, and click OK.

e In the Project Parameters dialog, click OK.

f In the Filters dialog, select the parameter from the Filter By list.

For more information on creating custom parameters, see Parameters on page 1541.

f Select the filter operator from the following options:

- Equals: The characters must match exactly.
- Does not equal: Excludes everything that does not match the value you enter.
- Is greater than: Looks for values greater than the value you enter. If you enter 23, values greater than but not equal to 23 are returned.
- Is greater than or equal to: Looks for values greater than or equal to the value you enter. If you enter 23, values of 23 and greater are returned.
Is less than: Looks for values less than the value you enter. If you enter 23, values less than but not equal to 23 are returned.

Is less than or equal to: Looks for values less than or equal to the value you enter. If you enter 23, values of 23 and lower are returned.

Contains: Selects a character anywhere in a string. If you enter the character H, all attributes that contain the character H are returned.

Does not contain: Excludes a character anywhere in a string. If you enter the character H, all attributes that contain the letter H are excluded.

Begins with: Selects a character at the beginning of a string. If you enter the character H, all attributes that begin with H are returned.

Does not begin with: Excludes a character at the beginning of a string. If you enter the character H, all attributes that begin with H are excluded.

Ends with: Selects a character at the end of a string. If you enter the character H, all attributes that end with H are returned.

Does not end with: Excludes a character at the end of a string. If you enter the character H, all attributes that end with H are excluded.

g Enter a value for the filter, or select a value from the list (available for some parameter types).

NOTE If you select the equals operator, the value that you enter must match the search value. The search is case-sensitive.

h Enter additional filter criteria as necessary. You can add up to 3 additional criteria. When you enter more than one filter criterion, elements must meet all criteria to be selected.

i Click OK.

Select - Opens the Edit Selection Set mode. In the drawing area, select an element (or elements) to filter on. Click ✅ (Finish Selection) to finish the selection, or click ❌ (Cancel Selection) to return to the Filter dialog.

NOTE Be sure to carefully select elements in Edit Selection Set mode. Sometimes unintended elements such as marks and text notes are selected, and must then be edited from the filter.

Use Current Selection - This works like the Select option. It creates the filter based on the elements currently selected in the drawing area (highlighted in red, or the color you specified for selected elements).

5 Click OK when you are done creating filter criteria. The new filter appears in the Filters dialog. You can edit, rename, or delete a filter at any time.

6 Click OK to close the Filters dialog.

Applying a Filter

How do I get here?

- Click View tab ➤ Graphics panel ➤ (Visibility/Graphics), and click the Filters tab.
Select an element in the drawing area, and click Modify | <Element> tab ➤ View panel ➤ Override Graphics in View drop-down ➤ (Override By Filter).

Select an element in the drawing area, and click Modify | <Element> tab ➤ View panel ➤ Hide in View drop-down ➤ (Hide By Filter).

1 On the Filters tab of the Visibility/Graphic Overrides dialog, click Add.
   The Filters dialog opens, which contains a list of filters created in the project. If no filters exist
   in the project, click Edit/New to create a filter.
   For details on creating a filter, see Creating a Criteria-Based Filter on page 806.

2 Select a filter, and click OK.

3 Select or clear the Visibility check box to turn visibility of the filtered object on or off.

4 Override the projection, surface, and cut line styles and projection patterns as necessary.

5 Check the Halftone option to make filtered objects appear at halftone.
   See Halftone/Underlay on page 1605.

6 Check the Transparent option to make filtered objects transparent.

7 Click OK or Apply to activate the filter for that view.
   Filters are view-specific. OK activates the filter and closes the dialog. Apply activates the filter
   and keeps the dialog open.

NOTE If multiple selection filters are applied to the same view, the order in which they are listed
   denotes priority. The selection filter nearest the top of the list takes precedence.

Related topics

- Controlling Visibility and Graphic Display of Elements Using Filters on page 806
- Overriding Visibility and Graphic Display of Individual Elements on page 802
- Overriding Graphic Display of Element Categories on page 803
- Managing Selection-Based Filters on page 809

Managing Selection-Based Filters

To access selection filters:

1 Click Manage tab ➤ Selection panel ➤ (Edit).

2 In the Filters dialog, you can edit, create new, rename, and delete filters. See Creating a
   Criteria-Based Filter on page 806.

To create a filter based on a single selection:

1 Click an element in the drawing area to filter.

2 Click Manage tab ➤ Selection panel ➤ (Save).

3 In the Save Selection dialog, enter a name for the filter.

4 Click OK.
To create a filter based on multiple selections:

1. Click Manage tab ➤ Selection panel ➤ (Edit).
2. In the Filters dialog, click New.
3. In the Filter Name dialog, enter a name for the filter, select Select, and click OK to enter Edit Selection mode.
4. In the drawing area, use the following tools to define your filters.
   - Click Edit Selection Set tab ➤ Edit Selection panel ➤ (Add To Selection) to select elements
   - Click Edit Selection Set tab ➤ Edit Selection panel ➤ (Remove From Selection) to deselect an element.
5. When complete, use the following tools to exit Selection mode.
   - Click Edit Selection Set tab ➤ Selection Mode panel ➤ (Finish Selection) to save the selected elements for the filter.
   - Click Edit Selection Set tab ➤ Selection Mode panel ➤ (Cancel Selection) to exit selection mode without saving the selected elements for the filter.

**NOTE** Select Multiple on the Options Bar to select multiple elements. Click Finish on the Options Bar to accept the multiple elements, or Cancel to deselect them.

6. Click OK in the Filters dialog.

To use a previously saved selection filter:

1. Click Manage tab ➤ Selection panel ➤ (Load).
2. In the Retrieve Filters dialog, select the name of the filter to use.
3. Click OK.

To modify a previously saved selection filter:

1. Click Manage tab ➤ Selection panel ➤ (Edit).
2. In the Filters dialog, select a filter and click Edit.
3. In the drawing area, use the following tools to define your filters.
   - Click Edit Selection Set tab ➤ Edit Selection panel ➤ (Add To Selection) to select elements
   - Click Edit Selection Set tab ➤ Edit Selection panel ➤ (Remove From Selection) to deselect an element.
4. When complete, use the following tools to exit Selection mode.
   - Click Edit Selection Set tab ➤ Selection Mode panel ➤ (Finish Selection) to save the selected elements for the filter.
   - Click Edit Selection Set tab ➤ Selection Mode panel ➤ (Cancel Selection) to exit selection mode without saving the selected elements for the filter.
NOTE Select Multiple on the Options Bar to select multiple elements. Click Finish on the Options Bar to accept the multiple elements, or Cancel to deselect them.

5 Click OK in the Filters dialog.

To assign visibility parameters to selection filters:

1 Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
2 In the Visibility/Graphics dialog, click the Filters tab.
3 Insert, delete, or modify the visibility parameters of selection filters. For more information, see Applying a Filter on page 808.

Modifying Filter Criteria

1 Click View tab ➤ Graphics panel ➤ (Filters).

Alternatively, click View tab ➤ Graphics panel ➤ (Visibility/Graphics), click the Filters tab, and then click Edit/New.

2 In the Filters dialog, select the rule-based filter you want to modify from the filters list, and click Edit.

3 To rename the filter, click . Enter a new name for the filter, and click OK.

4 To delete the filter, click . Click Yes to confirm the deletion.

5 Modify the categories and filter rules, as necessary.

6 Click OK.

Modifying Filter Visibility and Graphics Settings

1 Click View tab ➤ Graphics panel ➤ (Visibility/Graphics), or type VV or VG to open the Visibility/Graphics dialog, and click the Filters tab.

Alternatively, right-click an element in the drawing area, and click Override Graphics in View ➤ By Filter.

2 For Name, select the filter to modify.

3 Modify visibility, projection, surface, and cut line patterns and styles, halftone, and transparency, as necessary.

4 Click OK.

Hiding Elements in a View

You can hide individual elements or categories of elements in a view permanently or temporarily. When you hide an element that is used as a reference for a tag or a dimension, the tag or dimension is also hidden. Hiding a revision cloud does not affect the revision table.

Hiding Elements

1 In the drawing area, select the element to hide.
2 Click Modify | <Element> tab ➤ View panel ➤ (Hide in View) drop-down ➤ (Hide Elements), (Hide Category), or (Hide by Filter).

Alternatively, right-click the element, and click Hide in View ➤ Elements, Category, or By Filter.

If you select Element, the element is hidden in the view. If you select By Category, all elements of that category are hidden in the view. If you select By Filter, the Filters tab on the Visibility/Graphic Overrides dialog displays for modifying, adding, or removing filters.

Related topics

- Revealing and Unhiding Hidden Elements on page 812
- Temporarily Hiding or Isolating Elements or Element Categories on page 812
- Applying Transparency to Faces of Model Element Categories on page 806
- Controlling Visibility and Graphic Display of Elements Using Filters on page 806

Revealing and Unhiding Hidden Elements

1 On the View Control Bar, click (Reveal Hidden Elements).

The Reveal Hidden Elements icon displays with a color border to indicate that you are in Reveal Hidden Element mode. All hidden elements display in color, and visible elements display in half-tone.

To unhide hidden elements:

2 Select the element.

3 Do one of the following:

- Click Modify | <Element> tab ➤ Reveal Hidden Elements panel ➤ (Unhide Element) or (Unhide Category).

- Right-click the element, and click Unhide in View ➤ Elements or Category.

**NOTE** The Unhide Element and Unhide Category options become active when you select an element that was hidden by element or, a category that was hidden by category.

4 On the View Control Bar, click to exit Reveal Hidden Elements mode.

Temporarily Hiding or Isolating Elements or Element Categories

Temporarily hiding or isolating elements or element categories may be useful when you want to see or edit only a few elements of a certain category in a view. The Hide tool hides the selected elements in the view, and the Isolate tool shows the selected elements and hides all other elements in the view. The tool affects only the active view in the drawing area.

Element visibility reverts back to its original state when you close the project, unless you make the changes permanent. Temporary Hide/Isolate also does not affect printing.

**To temporarily hide or isolate elements or element categories:**

1 In the drawing area, select one or more elements.
On the View Control Bar, click (Temporary Hide/Isolate) and then select one of the following:

- **Isolate Category**
- **Hide Category**. Hides all selected categories in the view.
- **Isolate Element**. Isolates only the selected elements.
- **Hide Element**. Hides only the selected elements.

When you temporarily hide an element or element category, the Temporary Hide/Isolate icon displays with a border ( ).

**To exit temporary hide/isolate mode without saving changes:**

1. On the View Control Bar, click , and then click Reset Temporary Hide/Isolate.
   All temporarily hidden elements are restored to the view.

**To exit temporary hide/isolate mode and make changes permanent:**

1. On the View Control Bar, click , and then click Apply Hide/Isolate to View.
   If you make temporarily hidden elements permanent, you can reveal them at a later time, and unhide them if necessary. For information, see Revealing and Unhiding Hidden Elements on page 812.

**Overriding Individual Lines in an Element**

You can use the Linework tool to override the line style of individual element lines. For more information, see Changing the Line Style of Elements on page 1498.

**Overriding Host Layers**

Using overrides, you can control the visibility of cut edges in host layers in plan and section views. The hosts to which you can apply an override are walls, roofs, floors, and ceilings. You can assign line weight, line color, and line pattern to each of the layer functions: Structure, Substrate, Thermal/Air, Finish 1, and Finish 2. You can also control the line styles for common edges, which occur when a line is common to 2 layers of differing functions. If both layers are drawn in line styles with the same pen weight, the properties assigned to common edges are used.

You can also select from the following core layer clean-up options:

- **Default**. This is the current behavior.
- **Use Function**. Ignores the material settings (the line is never invisible) and sets the style of the separating line based on the layers' functional priorities. The style of a separating line is determined by the layer with the higher functional priority.
- **Use Common Edge Style**. Ignores the functional priorities and material settings, and always uses the common edge style.
- **No Edge**. Sets the separating line to invisible whenever the layers have the same fill pattern.

The line styles that you assign to the host structure are view-specific; they are visible only in the view in which you create them. The overrides are applied to the cut edges of all hosts in the view.
Override Cut Line Styles

Use the override feature to assign different line weights to the cut lines and structural core lines of a wall in plan view.

1. Open a plan view.
2. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
4. In the Host Layer Line Styles dialog, assign line weights, line colors, and line patterns to host layers, as desired.
5. For Core layer clean-up, select an option. See Overriding Host Layers on page 813.
6. Click OK.
7. In the Visibility/Graphics dialog, click OK.

Troubleshooting View and Visibility Issues

Typically, when an object cannot be seen or does not display as expected in a view, the issue is an incorrect visibility setting. It is best to try to recreate the error in a new empty project. This process helps isolate the many crossover visibility issues that arise in phasing and family creation.

The following sections provide tips to help you identify and resolve commonly encountered view and visibility issues.

An Object Seems To Be Misdrawn

To update and refresh the current display, cut the object from the view, and then paste it aligned to the same place. This action forces a refresh on single-instance geometry drawing issues.

See Pasting Aligned Elements on page 1496.

Elevation and Section Marks Do Not Display Correctly

Try the following actions to resolve elevation and section mark display issues.

- Reduce the view scale of your drawing. See View Scale on page 860.
- In the instance parameter of the elevation or section, change the parameter value for Hide at scales coarser than. See Section Tag Visibility on page 738 and Hiding Elevation Tags on page 863.

Gridlines or Reference Planes Are Not Visible

Try the following actions to resolve gridline and reference plane display issues.

- Gridlines and reference planes must be perpendicular to the view in which they are displayed. Switch to an appropriate elevation or plan view to see them. See Using the Project Browser on page 28.
- Gridlines and reference planes must be below the cut plane of a view in which they are to display. Verify that the cut plane is not set at too low a depth in the view range. See Modifying the View Range on page 867.

Objects Are Not Visible

Try the following actions to resolve object display issues.

- On the View Control Bar, reveal hidden elements in the view. See Revealing and Unhiding Hidden Elements on page 812.
On the View Control Bar, change the detail level of the view. Some geometry does not display at certain detail levels. See Specifying the Detail Level for a View on page 1619.

Verify that the View Range settings are accurate. See Modifying the View Range on page 867. If you are unsure, apply a default view template to resolve potential view range issues. See Specifying and Applying a Default View Template on page 1639.

In the Visibility/Graphic Overrides dialog, verify that the visibility of the objects is enabled. See Overview of Visibility and Graphic Display on page 801.

In the Visibility/Graphic Overrides dialog, click the Filter tab and turn off any applied filters. See Controlling Visibility and Graphic Display of Elements Using Filters on page 806.

If the project is workshared, in the Visibility/Graphic Overrides dialog, click the Worksets tab and turn off any applied filters. See Changing the Visibility of a Workset in a View on page 1231.

If you see an entire category of halftoned objects that are not set to display as halftoned (see Overview of Visibility and Graphic Display on page 801), try changing the view discipline. The Discipline setting determines how different object categories display in discipline-specific views. Also, select Coordination to show all object lines as solid without half tones. See View Properties on page 873.

If your project uses phases, select None for the Phase Filter parameter. Phases and Phase Filters both impact the displays of objects within views. See Applying Phase Filters on page 880.

NOTE Verify that instances of demolished elements are Phase states and not individual Phases. See Demolishing Elements on page 883.
Use and Manage Views

Renaming Views

Revit Structure uses default names for project views. You can change view names at any time to better reflect their content or to simplify project management.

To rename a view from the Project Browser

1. In the Project Browser, right-click the view name, and click Rename.
2. In the Rename View dialog, enter a new name for the view, and click OK.

To rename a view using view properties

1. Access view properties, using either of the following methods:
   - In the Project Browser, right-click the view name, and click Properties.
   - In the drawing area of the view, right-click, and click View Properties.
2. On the Properties Palette on page 34 for the view, under Identity Data, for View Name, enter a new name for the view.
3. Click OK.

Navigating Primary and Dependent Views

Use any of the following methods to navigate between primary and dependent views.

- To go to the primary view from a dependent view, right-click a dependent view crop boundary, and click Go to Primary View.
- To go to a dependent view from the primary view, right-click the crop boundary of the view you want to go to, and click Go to View.
- If there is a view reference, double-click it to open the view that it references. The following image shows view references (1/S.1 and 1/S.2) on the matchline.
A view reference is a symbol. You can create a view reference family in the Family Editor. View reference families can contain lines, filled regions, text and labels for the view number and sheet number parameter values.

To add a view reference:

1. Open the view to which you want to add a reference.
   - **NOTE** If the view is on a sheet, right-click the view, and click Activate View.
2. Click Annotate tab ➤ Tag panel ➤ View Reference.
3. On the Options Bar, select the target view.
   - Alternatively, click the crop region of the view you want to reference. If crop regions are not visible click (Show Crop Region) on the View Control Bar.
4. Click in the drawing area to place the reference.
   - View references display in the primary view and all related dependent views (except for the view that it is referencing). For example, if you have a view split into 2 dependent views (left and right), and you add a view reference to the right view to reference the left, the view reference appears in the primary view and in the right view, but not in the left view.

To hide view references

1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
2. Click the Annotation Categories tab.
3. Clear the check box for View Reference.

Related topics

- Duplicate Dependent Views on page 843
- Adding Views to a Sheet on page 980

Navigating Views

Use the ViewCube to navigate 3D views. Use SteeringWheels to navigate 2D and 3D views.
ViewCube

Autodesk® ViewCube® navigation tool provides visual feedback of the current orientation of a model. You can use the ViewCube tool to adjust the viewpoint of the model.

Overview of the ViewCube

The ViewCube tool is a persistent, clickable and draggable interface that you use to switch between standard and isometric views of your model. When you display the ViewCube tool, it is shown in one of the corners of the window over the model in an inactive state. The ViewCube tool provides visual feedback about the current viewpoint of the model as view changes occur. When the cursor is positioned over the ViewCube tool, it becomes active. You can drag or click the ViewCube, switch to one of the available preset views, roll the current view, or change to the Home view of the model.

Control the Appearance of ViewCube

The ViewCube tool is displayed in one of two states: inactive and active. When the ViewCube tool is inactive, it appears partially transparent by default so that it does not obscure the view of the model. When active, it is opaque and may obscure the view of the objects in the current view of the model.

In addition to controlling the inactive opacity level of the ViewCube tool, you can also control the following properties for the ViewCube tool:

■ Size
■ Position
■ Default orientation
■ Compass display

Using the Compass

The compass is displayed below the ViewCube tool and indicates which direction North is defined for the model. You can click a cardinal direction letter on the compass to rotate the model, or you can click and drag one of the cardinal direction letters or the compass ring to interactively rotate the model around the pivot point.

To control the size of the ViewCube tool

1. Right-click the ViewCube tool, and click Options.
2. In the Options dialog box, under ViewCube Appearance, select a size from the ViewCube size drop-down list.
3 Click OK.

**To control the inactive opacity of the ViewCube tool**
1 Right-click the ViewCube tool, and click Options.
2 In the Options dialog box, under ViewCube Appearance, select an option from the Inactive opacity drop-down list.
3 Click OK.

**To display the compass below the ViewCube tool**
1 Right-click the ViewCube tool, and click Options.
2 In the Options dialog box, under Compass, select Show the compass with the ViewCube (current project only).
   The compass is displayed below the ViewCube tool and indicates the direction of North for the model.
3 Click OK.

Autodesk® ViewCube® navigation tool provides visual feedback of the current orientation of a model. You can use the ViewCube tool to adjust the viewpoint of the model.

**Displaying the ViewCube Compass**

**To display the compass below ViewCube**
Right-click the ViewCube, and click Show Compass. The compass reflects the current orientation of the view. For more information, see **Relocating and Mirroring a Project** on page 1269.

1 Right-click ViewCube and click Options.
2 In the Options dialog, under Compass, select Show the Compass with the ViewCube (current project only).
   The compass is displayed below the ViewCube and indicates the direction of North for the model.
3 Click OK.

**ViewCube Menu**

Use the ViewCube menu to restore and define the Home view of a model, switch between view projection modes, and change the interactive behavior and appearance of the ViewCube.

The ViewCube menu has the following options:

- **Go Home.** Restores the Home view saved with the model.
- **Lock to Selection.** Uses the selected objects to define the center of the view when a view orientation change occurs with the ViewCube.

**NOTE** If you click Home on the ViewCube, the view returns to the Home view even if Lock to Current Selection is selected.

- **Set Current View as Home.** Defines the Home view of the model based on the current view.
- **Reset Front.** Resets the Front view of the model to its default orientation.
- **Options.** Displays the dialog which allows you to adjust the appearance and behavior of the ViewCube.
- **Help.** Launches the online Help system and displays the topic for the ViewCube.

**Show or Hide the ViewCube**

In a 3D view, click View tab ➤ Windows panel ➤ User Interface drop-down ➤ ViewCube.

Alternatively, click ➤ Options. Click the ViewCube tab, deselect Show the ViewCube, and click OK.

**Reorient the View of a Model with the ViewCube**

ViewCube is used to reorient the current view of a model. You can reorient the view of a model with the ViewCube by clicking pre-defined areas to set a preset view current, click and drag to freely change the view angle of the model, and define and restore the Home view.

**Reorient the Current View**

The ViewCube provides twenty-six defined areas you can click to change the current view of a model. The twenty-six defined areas are categorized into three groups: corner, edge, and face. Of the twenty-six defined areas, six of the areas represent standard orthogonal views of a model: top, bottom, front, back, left, and right. Orthogonal views are set by clicking one of the faces on the ViewCube.

**NOTE** When the cursor is over one of the clickable areas of the ViewCube, the cursor changes to an arrow with a small cube to indicate the cursor is over the ViewCube. In addition to the cursor changing, a tooltip is also displayed. The tooltip describes the action that can be performed based on the location of the cursor over the ViewCube.

You use the other twenty defined areas to access angled views of a model. Clicking one of the corners on the ViewCube reorients the current view of the model to a three-quarter view, based on a viewpoint defined by three sides of the model. Clicking one of the edges reorients the view of the model to a half view based on two sides of the model.

You can also click and drag the ViewCube to reorient the view of a model to a custom viewpoint other than one of the twenty-six predefined viewpoints that are available. As you drag, the mouse pointer changes to indicate that you are reorienting the current view of the model. If you drag the ViewCube close to one of the preset orientations and it is set to snap to the closest view, the ViewCube rotates to the closest preset orientation.

The outline of the ViewCube helps you identify the view orientation. When a view is oriented to one of the twenty-six pre-defined ViewCube orientations, the ViewCube is outlined in a solid continuous line. When a view is not constrained to one of the twenty-six pre-defined orientations, its outline is displayed as dashed.
Roll a Face View

When you view a model from one of the face views, two roll arrow buttons are displayed near the ViewCube. Use the roll arrows to rotate the current view 90 degrees clockwise or counterclockwise around the center of the view.

Switch to an Adjacent Face

When the ViewCube is active while viewing a model from one of the face views, four orthogonal triangles are displayed near the ViewCube. You use these triangles to switch to one of the adjacent face views.

Front View

You can define the Front view of a model to specify the direction of the face views on the ViewCube. Along with the Front view, the Up direction of a model is also used to specify the direction of the face views on the ViewCube.

To reorient the current view to a preset orientation

- Click one of the faces, edges or corners on the ViewCube.

To view an adjacent face

**NOTE** Make sure a face view is current.

- Click one of the triangles displayed near the edges of the ViewCube.

To interactively reorient the view

- Click the ViewCube, hold down the left mouse button on your pointing device and drag to orbit the model. Drag in the direction that you want to orbit the model.

To use animated transitions when reorienting a view to a preset orientation

1. Right-click the ViewCube, and click Options.

2. In the Options dialog, under When Clicking on the ViewCube, click Use Animated Transition when Switching Views.
   When checked, transitions from one view to another appear animated when clicking a pre-defined area on the ViewCube.
3  Click OK.

**To automatically fit the model after a view orientation**

1  Right-click the ViewCube, and click Options.

2  In the Options dialog, under When Clicking on the ViewCube, click Fit-to-View On View Change. When checked, clicking on a pre-defined area of the ViewCube reorients the model and fits the model to the window.

3  Click OK.

**To roll a face view**

---

NOTE Make sure a face view is displayed.

- Click one of the roll arrows displayed above and to the right of the ViewCube. The left roll arrow rotates the view 90 degrees counterclockwise, while the right roll arrow rotates the view 90 degrees clockwise.

**To define the Front view**

- Right-click on the ViewCube and click Set Front to, and select (Current View).

---

NOTE The Front view can only be set to the current view or to an existing elevation view in the project.

**To restore the Front view**

- Right-click on the ViewCube and click Reset Front.

---

**Home View**

The Home view is a special view stored with a model that makes it easy to return to a known or familiar view. You can define any view of the model as the Home view. The saved Home view can be applied to the current view by clicking the Home button near the ViewCube or from the ViewCube menu.

**To define the Home view**

- Right-click the ViewCube and click Set Current View as Home.

**To reorient the model to the Home view**

Use one of the following methods:

- Click the Home button ( ) located near the ViewCube.
- Right-click the ViewCube and click Go Home.

---

**Examine Individual Objects with the ViewCube**

You can lock the ViewCube to one or more selected objects by clicking the Lock to Selection option from the ViewCube shortcut menu. Locking a selection of objects to the ViewCube specifies the center of the current view and the distance from center for the view based on the selected objects. Lock to Selection is
enabled until it is unchecked from the ViewCube shortcut menu or by clicking the Lock to Selection icon (next to the Home view icon).

Selecting and deselecting objects after Lock to Selection is enabled has no effect on the center or distance from the center of the view when a view orientation change occurs with the ViewCube tool. Zooming to the extents of a model will not occur when Lock to Selection is enabled, even if the ViewCube tool is set to zoom to extents after each view orientation change.

To lock to the current selection

- Right-click the ViewCube and click Lock to Selection.
  - If Lock to Selection is checked when a view orientation change occurs, the ViewCube uses the selected objects to calculate the center of the view and zooms to the extents of the selected objects. When the option is unchecked, the ViewCube uses the selected objects to calculate the center of the view and zooms to the extents of the model.

To examine an individual object with the ViewCube

1. In the model, select one or more objects to define the center point of the view.
2. Click one of the preset locations on the ViewCube, or click and drag the ViewCube to reorient the view of the model.
   - The ViewCube reorients the view of the model based on the center point of the selected objects.

Navigation Bar

The navigation bar provides access to navigation tools, including Autodesk® ViewCube® and SteeringWheels. The navigation bar displays in the drawing area, along one of the sides of the current model’s window. The navigation bar is activated by default.

The navigation tools are organized into separate areas of the navigation bar and provide access to tools based on the currently active view (2D or 3D). You launch navigation tools by clicking one of the buttons on the navigation bar or selecting a tool from the drop-down at the bottom of the navigation bar.

To activate or deactivate the navigation bar, click View tab ➤ Windows panel ➤ User Interface drop-down, and select or clear Navigation Bar.

The following navigation tools are available from the navigation bar:

- **ViewCube.** Indicates the current orientation of a model and is used to reorient the current view of a model.

- **SteeringWheels.** Collection of wheels that offer rapid switching between specialized navigation tools.

- **Pan.** Moves the view parallel to the screen.

- **Zoom tools.** Set of navigation tools for increasing or decreasing the magnification of the current view of a model.
Navigation Bar Customize Menu

Options on the navigation bar customize menu allow you to select tools and reposition the navigation bar in the view.

Control the Display of Navigation Tools on the Navigation Bar

You can control which navigation tools are displayed on the navigation bar with the Customize menu. The Customize menu is displayed by clicking the Customize button. From the Customize menu, you click the navigation tools that you want displayed on the navigation bar. The position of the navigation tools on the navigation bar is predefined and cannot be changed.

To display a navigation tool on the navigation bar

1. On the navigation bar, click Customize.
2. On the Customize menu, click the navigation tool you want to display on the navigation bar.
   A check mark next to a navigation tool’s name indicates that it displays on the navigation bar.

To remove a tool from the navigation bar do one of the following:

- Right-click the tool you want to remove, and click Remove from Navigation Bar.
- On the navigation bar, click Customize. On the Customize menu, click the tool you want to remove.

Reposition and Reorient the Navigation Bar

The position and orientation of the navigation bar can be adjusted by linking it to the ViewCube tool, docking it when the ViewCube tool is not displayed, or freely positioning it along one of the edges of the current window. When the navigation bar is linked to the ViewCube tool, it is positioned above or below the ViewCube tool and in a vertical orientation. When not linked or docked, the navigation bar can be freely aligned along one of the edges of the current model’s window.

You specify how the navigation bar can be repositioned from the Customize menu. When the navigation bar is not linked to the ViewCube tool or docked, a grip handle is displayed. Drag the grip handle to reposition the navigation bar along one of the sides of the current model’s window.

If the side of the window is not long enough to show the entire navigation bar, it is truncated to fit. When truncated, a More Controls button is displayed and replaces the Customize button. When you click the More Controls button, a menu is displayed that contains the navigation tools that are not currently being displayed.

To reposition the navigation bar and ViewCube

1. On the navigation bar, click Customize.
2. Click Customize menu ➤ Docking Positions ➤ Link to ViewCube.
When Link to ViewCube is checked, both the navigation bar and ViewCube are repositioned together around the current window. When ViewCube is not displayed, the navigation bar is docked in the same location in which ViewCube would be instead.

3 Click Customize.

4 Click Customize menu ➤ Docking Positions ➤ an available docking position.
   The navigation bar and ViewCube are repositioned.

To link the position of the navigation bar to ViewCube

1 On the navigation bar, click Customize.

2 Click Customize menu ➤ Docking Positions ➤ Link to ViewCube.
   When Link to ViewCube is checked, both the navigation bar and ViewCube are repositioned together around the current window.

Link the Navigation Bar and ViewCube

When the navigation bar is linked to the ViewCube, you can freely reposition the navigation bar along the edge of the current window.

1 On the navigation bar, click Customize.

2 Click Customize menu ➤ Docking Positions ➤ Link to ViewCube.
   The grip handle for the navigation bar is displayed along the top of the navigation bar.

3 Click the grip handle and drag the navigation bar along the edge of the window where you want it displayed. Release the button on the pointing device to orient the navigation bar along the edge of the window.
   Dragging the navigation bar to the top or bottom of the window orients it horizontally, dragging it to the left or right side of the window orients it vertically.

4 Drag the navigation bar along the window’s edge to adjust its position along the window’s edge.

SteeringWheels

SteeringWheels are tracking menus (that follow your cursor) from which you can access different 2D and 3D navigation tools from a single tool.
Overview of Steering Wheels

SteeringWheels, also known as wheels, can save you time by combining many of the common navigation tools into a single interface. Wheels are task specific from which you can navigate and orient a model in different views.

2D Steering Wheel

Full Navigation Wheel View Object Wheel (Basic Wheel) Tour Building Wheel (Basic Wheel)

Mini View Object Wheel Mini Tour Building Wheel Mini Full Navigation Wheel

First Contact Balloon

When you display, SteeringWheels the first time and a 3D view is current, the First Contact balloon for the wheels is displayed. The First Contact balloon serves as an introduction to the purpose of the wheels and shows how to use them.
Display and Use Wheels

Pressing and dragging on a wedge of a wheel is the primary mode of interaction. After a wheel is displayed, click one of the wedges and hold down the button on the pointing device to activate the navigation tool. Drag to reorient the current view. Releasing the button returns you to the wheel.

Appearance of the Wheels

You can control the appearance of the wheels by switching between the different styles of wheels that are available, or by adjusting the size and opacity. Wheels (except the 2D Navigation wheel) are available in two different styles: big and mini.

The size of a wheel controls how large or small the wedges and labels appear on the wheel; the opacity level controls the visibility of the objects in the model behind the wheel.

Wheel Tooltips, Tool Messages, and Tool Cursor Text

Tooltips are displayed for each button on a wheel as the cursor is moved over them. The tooltips appear below the wheel and identify what action will be performed if the wedge or button is clicked.

Similar to tooltips, tool messages and cursor text are displayed when you use one of the navigation tools from a wheel. Tool messages are displayed when a navigation tool is active; they provide basic instructions about using the tool. Tool cursor text displays the name of the active navigation tool near the cursor. Disabling tool messages and cursor text only affects the messages that are displayed when using the mini wheels or the big Full Navigation wheel.

Use one of the following methods to display a wheel:

To display the currently selected SteeringWheel style:

On the navigation bar, click or .

To display a selected SteeringWheel style:

On the navigation bar, click the arrow below the SteeringWheel, and select a SteeringWheel style from the shortcut menu.

To close a wheel

Use one of the following methods to close a wheel:

- Press the Esc.
- Click the small x in the upper right-hand corner of the wheel.
Right-click on the wheel and click Close Wheel.
Press F8.

NOTE For the following procedures, you can also click ➤ Options to access the Options dialog.

To change the size of the wheels
1 Display a wheel.
2 Right-click on the wheel, and click Options.
3 In the Options dialog, click the SteeringWheels tab, and under Big Wheel Appearance/Mini Wheel Appearance, for Size, select Small, Normal, or Large.
4 Click OK.

To change the opacity of the wheels
1 Display a wheel.
2 Right-click on the wheel, and click Options.
3 In the Options dialog, click the SteeringWheels tab, and under Big Wheel Appearance/Mini Wheel Appearance, select the level of transparency.
   Select 90% to display SteeringWheels at the greatest opacity. The default setting is 50%.
4 Click OK.

To enable tooltips for wheels
1 Display a wheel.
2 Right-click on the wheel, and click Options.
3 In the Options dialog, on the SteeringWheels tab, click Show tooltips.
   Tooltips are displayed for each wedge and button on a wheel when the cursor moves over the wheel.
4 Click OK.

To enable cursor text for wheels
1 Display a wheel.
2 Right-click on the wheel, and click Options.
3 In the Options dialog, on the SteeringWheels tab, click Show tool cursor text.
   Text labels are displayed while selected tools are being used.
4 Click OK.

To enable messages for wheels
1 Display a wheel.
2 Right-click on the wheel, and click Options.
3 In the Options dialog, on the SteeringWheels tab, click Show tool messages.
   Messages are displayed when you use the navigation tools.
Wheel Menu

Use the Wheel menu to switch between the big and mini wheels that are available, go to the Home view, change the preferences of the current wheel, and control the behavior of the orbit, look, and walk 3D navigation tools. The menu items available on the Wheel menu are dependent on the current wheel and program.

The Wheel menu has the following options:

- **Mini View Object Wheel.** Displays the mini View Object wheel.
- **Mini Tour Building Wheel.** Displays the mini Tour Building wheel.
- **Mini Full Navigation Wheel.** Displays the mini Full Navigation wheel.
- **Full Navigation Wheel.** Displays the big Full Navigation wheel.
- **Basic Wheels.** Displays the big View Object or Tour Building wheel.
- **Go Home.** Goes to the Home view saved with the model.
- **Fit to Window.** Resizes and centers the current view to display all objects.
- **Restore Original Center.** Restores the center point of the view to the extents of the model.
- **Orient to View.** Orients the camera to match the view angle of the selected view (a plan, elevation, section, or 3D view).
- **Orient to a Plane.** Adapts the view according to a specific plane.
- **Save View.** Saves the current view orientation with a unique name.
  
  **NOTE**  Save View only allows you to save a 3D view with a unique name when you are viewing the default 3D view. If you are viewing a previously saved orthographic 3D view or a perspective (camera) 3D view, the view is simply saved with the new orientation and you are not prompted to supply a unique name.

- **Increase/Decrease Focal Length.** Acts as a zoom lens on the model, because it changes the focal length of the camera in a perspective view.
- **Move Crop Boundary.** Moves the position of the crop boundary around in a perspective view.
- **Re-center Crop Boundary.** Repositions the crop boundary to the center of the perspective view.
- **Help.** Launches the online Help system and displays the topic about the wheels.
- **Properties.** Displays the dialog box where you can adjust the preferences for the wheels.
- **Close Wheel.** Closes the wheel.
Navigation Wheels

Wheels are available in two configurations: big and mini. The big wheel is larger than the cursor, with a label on each wedge. The mini wheel is about the same size as the cursor, with no labels displayed on the wheel wedges. The 2D Navigation wheel is only available in a big version.

2D Navigation Wheel

With this wheel you can access basic 2D navigation tools; it is particularly useful when you do not have a pointing device with a scroll wheel. The wheel includes the Pan and Zoom tools.

![2D Navigation Wheel Diagram]

The 2D Navigation wheel wedges have the following options:

- **Pan.** Repositions the current view by panning.
- **Zoom.** Adjusts the magnification of the current view.
- **Rewind.** Restores the most recent view orientation. You can move backward or forward by clicking and dragging left or right.

View Object Wheels

With the View Object wheels (big and mini), you can view individual objects or features in a model. The big View Object wheel is optimized for new 3D users while the mini View Object wheel is optimized for experienced 3D users.

![View Object Wheel Diagram]

To switch to the big View Objects wheel

- Right-click on the wheel and click Basic Wheels ➤ View Object Wheel.

To switch to the mini View Objects wheel

- Right-click on the wheel and click Mini View Object Wheel.

Tour Building Wheels

With the Tour Building wheels (big and mini), you can move through a model, such as a building, an assembly line, ship, or oil rig. You can also walk through and navigate around a model. The big Tour Building wheel is optimized for new 3D users while the mini Tour Building wheel is optimized for experienced 3D users.
Big Tour Building Wheel

The big Tour Building wheel wedges have the following options:

- **Forward**. Adjusts the distance between the current point of view and the defined pivot point of the model. Clicking once moves forward half the distance as far as the object you clicked.
- **Look**. Swivels the current view.
- **Rewind**. Restores the most recent view. You can move backward or forward by clicking and dragging left or right.
- **Up/DownTool**. Slides the current view of a model along the Z axis of the model.

Mini Tour Building Wheel

The mini Tour Building wheel wedges have the following options:

- **Walk (Top wedge)**. Simulates walking through a model.
- **Rewind (Right wedge)**. Restores the most recent view. You can move backward or forward by clicking and dragging left or right.
- **Up/Down (Bottom wedge)**. Slides the current view of a model along the Z axis of the model.
- **Look (Left wedge)**. Swivels the current view.

**NOTE** When the mini wheel is displayed, you can press and hold the middle mouse button to pan, scroll the wheel button to zoom in and out, and hold the SHIFT key while pressing and holding the middle mouse button to orbit the model.

To switch to the big Tour Building wheel

- Right-click the wheel, and click Basic Wheels ➤ Tour Building Wheel.

To switch to the mini Tour Building wheel

- Right-click the wheel, and click Mini Tour Building Wheel.

Full Navigation Wheels

The Full Navigation wheels (big and mini) contain common 3D navigation tools used for both viewing an object and touring a building. The big and mini Full Navigation wheels are optimized for experienced 3D users.
NOTE When one of the Full Navigation wheels is displayed, you can press and hold the middle mouse button to pan, scroll the wheel button to zoom in and out, and hold the SHIFT key while pressing and holding the middle mouse button to orbit the model.

**To switch to the big Full Navigation wheel**

- Right-click on the wheel and click Full Navigation Wheel.

**To switch to the mini Full Navigation wheel**

- Right-click on the wheel and click Mini Full Navigation Wheel.

**Navigation Tools**

Each wheel is divided into different wedges. Each wedge contains a navigation tool used to reorient the current view of a model. The availability of the navigation tools depends on which wheel is active.

**Center Tool**

With the Center tool, you can define the center of the current view of a model. To define the center, drag the cursor over your model. A sphere (pivot point) is displayed in addition to the cursor. The sphere indicates that the point below the cursor in the model will be the center of the current view when you release the mouse button. The model is centered on the sphere.

**Forward Tool**

You use the Forward tool to change the magnification of the model by increasing or decreasing the distance between the current point of view and the pivot point. The distance that you can move forward or backward is limited by the position of the pivot point.

**NOTE** In orthographic views, the Forward tool is limited to the distance between the current position and the pivot point. In perspective views, it is not limited, so you can move the cursor through the pivot point.

To adjust the distance between the current point of view and the pivot point you use the Drag Distance indicator. The Drag Distance indicator has two marks on it that show the start and destination distances.
from the current point of view. The current traveled distance is shown by the orange position indicator. Slide the indicator forward or backwards to decrease or increase the distance towards the pivot point.

**To reorient a view by moving towards or away from the model**

1. Display the big Tour Building wheel.
2. Click and hold down the Forward wedge. The Drag Distance indicator is displayed.

   **NOTE** If you click the Forward wedge once, the model moves forward 50% of the distance between the current location and the pivot point.

3. Drag the cursor up or down to change the distance from which you view the model.
4. Release the button on your pointing device to return to the wheel.

**Look Tool**

With the Look tool, you can rotate the current view vertically and horizontally. When rotating the view, your line of sight rotates about the current eye position, like turning your head. The Look tool can be compared to you standing in a fixed location, and looking up or down while turning your head left or right.

When using the Look tool, you adjust the view of the model by dragging the cursor. As you drag, the cursor changes to the Look cursor and the model rotates around the location of the current view.

In addition to using the Look tool to look around a model, you can also use the tool to pan the current view to a specific face on the model. Press and hold the *SHIFT* key before selecting the Look tool on one of the Full Navigation wheels.

**Walking through a Model**

When using the Look tool from the big Full Navigation wheel, you can walk through a model by using the arrow keys on the keyboard. Use the Options dialog for the SteeringWheels to adjust the walk speed.

**Invert Vertical Axis**

When you drag the cursor upward, the target point of the view raises; dragging the cursor downward lowers the target point of the view. Use the Options dialog for the SteeringWheels to invert the vertical axis for the Look tool.

**To look around a view with the Look tool**

1. Display one of the Full Navigation wheels or the mini Tour Building wheel.
2. Click and hold down the Look wedge. The cursor changes to the Look cursor.
3. Drag the pointing device to change the direction in which you are looking.
4 Release the button on your pointing device to return to the wheel.

**To look at a face in the model with the Look tool**

1 Display one of the Full Navigation wheels.
2 Press and hold down the `SHIFT` key.
3 Click and hold down the Look wedge.
   The cursor changes to the Look At cursor.
4 Drag over the objects in the model until the face highlights that you want to look at.
5 Release the button on your pointing device to return to the wheel.

**To look around and walk through a model with the Look tool**

1 Display the big Full Navigation wheel.
2 Click and hold down the Look wedge.
   The cursor changes to the Look cursor.
3 Drag to change the direction in which you are looking.
4 While holding down the button on your pointing device, press the arrow keys to walk in the model.
5 Release the button on your pointing device to return to the wheel.
6 Click Close to exit the wheel.

**To invert the vertical axis for the Look tool**

1 Display a wheel.
2 Right-click the wheel, and click Options.
3 In the Options dialog, for Look Tool Behavior select Invert Vertical Axis.
   Dragging downward and upward lowers and raises the target point of the current view.
4 Click OK.

**Orbit Tool**

You use the Orbit tool to change the orientation of a model. The cursor changes to the Orbit cursor. As you drag the cursor, the model rotates around a pivot point while the view remains fixed.
Specify the Pivot Point

The pivot point is the base point used when rotating the model with the Orbit tool. You can specify the pivot point in the following ways:

- **Default pivot point.** When you first open a model, the target point of the current view is used as the pivot point for orbiting the model.

- **Select objects.** You can select objects before the Orbit tool is used to calculate the pivot point. The pivot point is calculated based on the center of the extents of the selected objects.

- **Center tool.** You can specify a point on the model to use as the pivot point for orbiting with the *Center tool*.

- **CTRL+Click and drag.** Press and hold down the Ctrl key before clicking the Orbit wedge or while the Orbit tool is active; then drag to the point on the model you want to use as the pivot point. This option is only available when using the big and mini Full Navigation wheels or the mini View Object wheel.

**NOTE** While the Orbit tool is active, you can be press and hold the Ctrl key at anytime to move the pivot point used by the Orbit tool.

Maintain Up Direction

You can control how the model orbits around the pivot point by choosing to maintain the up direction of the model. When the up direction is maintained, orbiting is constrained along the XY axis and in the Z direction. If you drag horizontally, the camera moves parallel to the XY plane. If you drag vertically, the camera moves along the Z axis.

If the up direction is not maintained, you can roll the model using the roll ring which is centered around the pivot point. Use the Options dialog for the SteeringWheels to control whether the up direction is maintained or not for the Orbit tool.

**To orbit a model with the Orbit tool**

1. Display one of the View Object or Full Navigation wheels.
2. Click and hold down the Orbit wedge.
   - The cursor changes to the Orbit cursor.
3. Drag to rotate the model.

**NOTE** Use the Center tool to re-center the model in the current view, if you are using one of the Full Navigation or View Object wheels.

4. Release the button on your pointing device to return to the wheel.

**To orbit around an object with the Orbit tool**

1. Press Esc to make sure no tools are active and to clear any previously selected objects.
2. Select the objects in the model for which you want to define the pivot point.
3. Display one of the View Object or Full Navigation wheels.
4. Click and hold down the Orbit wedge.
   - The cursor changes to the Orbit cursor.
5. Drag to rotate the model.
6. Release the button on your pointing device to return to the wheel.
To maintain the up direction for the Orbit tool

1. Display the mini View Object wheel or one of the Full Navigation wheels.
2. Right-click the wheel, and click Options.
3. In the Options dialog, select Keep Scene Upright for Orbit Tool.
4. Click OK.
   Orbiting the model is constrained along the XY plane and Z directions.

To roll the model around the pivot point with the Orbit tool

1. Display the mini View Object Wheel or one of the Full Navigation wheels.
2. Right-click the wheel, and click Options.
3. In the Options dialog, clear the check mark from Keep Scene Upright for Orbit Tool.
4. Click OK.
5. Click and hold the Orbit wedge.
   The cursor changes to the Orbit cursor.
6. Press and hold the Shift key to display the roll ring. Drag to roll the model.
7. Release the button on your pointing device to return to the wheel.

To start the Orbit tool with the middle mouse button

1. Display one of the wheels other than the big View Object or Tour Building wheels.
2. Press and hold down the Shift key.
3. Press and hold down the scroll wheel or middle button on your pointing device and drag to orbit the model.
4. Release the button on your pointing device to return to the wheel.

Pan Tool

When the pan tool is active, the Pan cursor (a four-sided arrow) is displayed. Dragging the pointing device moves the model in the same direction. For example, dragging upward moves the model up while dragging downward moves the model down.

In a 3D context, primarily when using 3D SteeringWheels, pan dollies the camera left and right. In a 2D context, pan scrolls the view. If you are using pan with an active view on a sheet, pan scrolls the sheet view, not the active view on the sheet.
TIP  If the cursor reaches the edge of the screen, you can continue panning by dragging further to force it to wrap around the screen.

To pan the view with the Pan tool
1  Display the 2D Navigation wheel, one of the Full Navigation wheels, or the mini View Object wheel.
2  Click and hold the Pan wedge.
   The cursor changes to the Pan cursor.
3  Drag to reposition the model.
4  Release the button on your pointing device to return to the wheel.

To start the Pan tool with the middle button
1  Display the 2D Navigation wheel, the Full Navigation wheel, or one of the mini wheels.
2  Press and hold down the scroll wheel or middle button.
   The cursor changes to the Pan cursor.
3  Drag to reposition the model.
4  Release the wheel or button on your pointing device to return to the wheel.

Rewind Tool

As you use the navigation tools to reorient the view of a model, the previous view is saved to the navigation history. The navigation history holds a representation of the previous views of the model along with a thumbnail. A separate navigation history is maintained for each window; it is not maintained after the window is closed. Rewind navigation history is view-specific.

With the Rewind tool, you can retrieve previous views from the navigation history. From the navigation history, you can restore a previous view or scroll through all of the saved views.

When you hold down the button on the pointing device over the Rewind tool on the wheel, the Rewind History panel is displayed. You can scroll through the navigation history. To restore one of the previous views in the navigation history, drag the bracket to the left in the Rewind History panel.

NOTE  Rewind history is not saved between sessions.

To restore the previous view
1  Display a wheel.
2  Click the Rewind wedge.
To restore a previous view with the Rewind History panel

1. Display a wheel.
2. Click and hold the Rewind wedge.
   The Rewind History panel is displayed.
3. While holding down the button on your pointing device, drag to the left or to the right to restore a previous view.
   Dragging to the left restores an older previous view. Dragging to the right restores a view that is newer than the one you are currently viewing. You must have previously used the Rewind tool to see views available on the right. The current position in the navigation history is indicated by the orange box that is dragged along the Rewind History panel.

Up/Down Tool

Unlike the Pan tool, you use the Up/Down tool to adjust the height of the current viewpoint along the model's Z axis. To adjust the vertical elevation of the current view, you drag up or down. As you drag, the current elevation and the allowed range of motion is displayed on a graphical element called the Vertical Distance indicator.

The Vertical Distance indicator has two marks that show the highest (Top) and lowest (Bottom) elevation the view can have. When you are changing the elevation with the Vertical Distance indicator, the current elevation is shown by the bright orange indicator, while the previous elevation is shown by the dim orange indicator.

To change the elevation of a view

1. Display one of the Full Navigation wheels or the Tour Building wheels.
2. Click and hold down the Up/Down wedge.
   The Vertical Distance indicator is displayed.
3. Drag up or down to change the elevation of the view.
4. Release the button on your pointing device to return to the wheel.

Walk Tool

With the Walk tool, you can navigate through a model as if you were walking through it. Once you start the Walk tool, the Center Circle icon is displayed near the center of the view and the cursor changes to display a series of arrows. To walk through the model, you drag in the direction in which you want to move.

Constrain the Walk Angle

When walking through a model, you can constrain the movement angle to the ground plane. If the Move parallel to ground plane option is enabled, you can freely walk around while maintaining a constant camera
viewpoint elevation; if the walk angle is not constrained, you will “fly” in the direction you are looking. Use the Options dialog for the SteeringWheels to constrain the movement angle to the ground plane for the Walk tool.

**Movement Speed**

As you walk or “fly” through a model, you can control the movement speed. Movement speed is controlled by the distance in which the cursor is moved from the Center Circle icon and the current movement speed setting. You can adjust the movement speed setting permanently and temporarily as you use the Walk tool. To permanently adjust the movement speed, use the Options dialog for the SteeringWheels or the < and > keys when the Walk tool is active. To temporarily increase movement speed, press and hold the + (plus) key while using the Walk tool.

**Change the Elevation**

As you use the Walk tool, you can adjust the camera elevation by holding down the SHIFT key. This temporarily activates the Up/Down tool. With the Up/Down tool active, drag up or down to adjust the elevation of the camera. You can also use the UP ARROW and DOWN ARROW keys as you walk to adjust the height of the view.

**To use the Walk tool to move through the model**

1. Display one of the Full Navigation wheels or the mini Tour Building wheel.
2. Click and hold down the Walk wedge.
   The cursor changes to the Walk cursor and the Center Circle icon is displayed.
3. Drag in the direction you want to walk.

   **NOTE** While walking, press and hold down the + (plus) key to temporarily increase your movement speed.
4. Release the button on your pointing device to return to the wheel.

**To change the movement speed for the Walk tool**

1. Display a wheel.
2. Right-click the wheel, and click Options.
3. In the Options dialog, under Walk Tool, drag the Speed Factor slider to the left to decrease the walking speed or to the right to increase the walking speed.
4. Click OK.

**To constrain the Walk tool to the ground plane**

1. Display a wheel.
2. Right-click the wheel, and click Options.
3. In the Options dialog, under Walk Tool, select Move parallel to Ground Plane.
4. Click OK.
   Movement when walking is done parallel to the ground plane of the model.

**To adjust the height of the current view from the Walk tool**

1. Display one of the Full Navigation wheels or the mini Tour Building wheel.
2. Click and hold down the Walk wedge.
   The cursor changes to the Walk cursor and the Center Circle icon is displayed.
3 Do one of the following:
   ■ Press and hold down the \textit{SHIFT} key to enable the Up/Down tool; drag up or down.
   ■ Press and hold down the \textit{UP ARROW} or \textit{DOWN ARROW} key.

4 Release the button on your pointing device to return to the wheel.

\textbf{Zoom Tool}

You use the Zoom tool to change the zoom magnification of a model. The following mouse click and key combinations are available to control how the Zoom tool behaves:

■ \textbf{Click}. If you click the Zoom tool on a wheel, the current view is zoomed in by a factor of 25 percent. If you are using the Full Navigation wheel, incremental zoom must be enabled in the Options dialog for the SteeringWheels.

■ \textbf{SHIFT+click}. If you hold down the \textit{SHIFT} key before you click the Zoom tool on a wheel, the current view is zoomed out by a factor of 25 percent. Zooming is performed from the current location of the cursor, and not the current pivot point.

\textbf{NOTE} When you start the Zoom tool from the Full Navigation wheel, incremental zooming must be enabled in the Options dialog for the SteeringWheels in order to use \textit{CTRL}+click and \textit{SHIFT}+click.

■ \textbf{CTRL+click}. If you hold down the \textit{CTRL} key before you click the Zoom tool on a wheel, the current view is zoomed in by a factor of 25 percent. Zooming is performed from the current pivot point, and not the location of the cursor.

■ \textbf{Click and drag}. If you click the Zoom tool and hold down the button on your pointing device, you can adjust the magnification of the model by dragging up and down.

■ \textbf{CTRL+click and drag}. When using the Full Navigation wheels or the mini View Object wheel, you can control the target point used by the Zoom tool. When you hold down the Ctrl key, the Zoom tool uses the location of the previous pivot point defined by the Zoom, Orbit, or Center tool.

■ \textbf{SHIFT+click and drag}. When using the Full Navigation wheels or the mini View Object wheel, you can zoom in to an area of the model by dragging a rectangular window around the area you want to fit in the window. Hold down the Shift key and then click and drag a window around the area in which you want to zoom.

\textbf{NOTE} If you hold down the Ctrl key along with the Shift key, you can zoom in to an area of a model using a center-based window instead of one defined by opposite corners.

■ \textbf{Mouse wheel}. When a wheel is displayed, scroll the mouse wheel up or down to zoom the view of the model in or out.

\textbf{NOTE} When you use the Zoom tool from the Full Navigation wheel or the View Object wheel, the point in the view where you click to zoom becomes the Center point for future Orbit operations until you either use the Zoom tool again or use the Center tool. If you press \textit{Ctrl} before you click the Zoom wedge, the Center point does not change.
Zoom Constraints

When changing the magnification of a model with the Zoom tool, you cannot zoom in any further than the focus point or out past the extents of the model. The direction you can zoom in and out is controlled by the center point set by the Center tool.

**NOTE** Unlike the Zoom tool on the big View Object wheel, the Zoom tool on the mini View Object wheel and the Full Navigation wheels is not constrained.

**To zoom the view with a single click**

You must have enabled incremental zoom when using the Full Navigation wheels. The setting can be changed from the Options dialog for the SteeringWheels.

1. Do the following to make sure this option is selected:
   - Display the Full Navigation wheel.
   - Right-click on the wheel and click Options.
   - In the Options dialog, under Zoom Tool, select Zoom in one increment with each mouse click.
   - Click OK.

2. Display the 2D Navigation wheel, one of the Full Navigation wheels, or the mini View Object wheel.

3. Click the Zoom wedge.
   The magnification of the model is increased and you are zoomed in closer to the model. If you hold down the SHIFT key while clicking the Zoom wedge, the model is zoomed out; you can hold down the CTRL key to zoom in.

**To zoom a view in and out by dragging**

1. Display the 2D Navigation wheel, one of the Full Navigation wheels, or the mini View Object wheel.

2. Click and hold down the Zoom wedge.
   The cursor changes to the Zoom cursor.

3. Drag vertically to zoom in or out.

4. Release the button on your pointing device to return to the wheel.

**To zoom in to an area of the model by specifying window**

1. Display one of the Full Navigation wheels or the mini View Object wheel.

2. Press and hold down the SHIFT key.

3. Click and hold down the Zoom wedge.
   The cursor changes to the Zoom cursor.
Drag the pointing device to define the opposite corner of the window that defines the area in which you want to zoom.

NOTE Holding down the CTRL key while defining the second point of the window determines if the first point of the window is used as the corner or center of the window being dragged. When the CTRL key is held down, the first point defines the center of the window.

5 Release the button on your pointing device to return to the wheel.

To zoom in and out by scrolling the mouse wheel when a SteeringWheel is displayed

1 Display one of the wheels other than the big Tour Building wheel.
2 Scroll the wheel forward or backward to zoom in or out.
3 Release the button on your pointing device to return to the wheel.

Saving a 3D View Orientation as a Project View

1 If SteeringWheels are not displayed in the drawing area, click (Full Navigation Wheel) on the navigation bar.
2 Right-click the SteeringWheels, and click Save View.
3 Enter a name for the new 3D view, and click OK.

NOTE You are only prompted to enter a name for the view if you are saving the default 3D view (named in the Project Browser {3D}). If you are saving a 3D view other than the default 3D view, the view is saved using the current name.

The new view displays in the Project Browser under 3D Views.

Duplicate Dependent Views

You can create multiple copies of a view that are dependent on the primary view. All copies, known as dependent views, remain synchronous with the primary view and all other dependent views, so that when view-specific changes (such as view scale and annotations) are made in one view, they are reflected in all views.

Creating dependent views may be useful in the following scenarios:

- You are working on a large project with an extensive floor plate, and you want to crop the view into smaller segments so you can place them on sheets. When you make changes to dependent segments of the view, you can quickly see how they affect the view as a whole by looking at the primary view.
- You need to place a view on more than one sheet.

Dependent views display in the Project Browser under the primary view. You can insert matchlines to indicate where the view is split, and view references to link views.

The following image shows a project view, Level 1, that has been split into 2 dependent views: Left and Right. Level 1 is the primary view and is shown in the drawing area with its crop region and the crop regions for the dependent views visible, a matchline indicating where the view is split (dashed blue line), and view references (1/A102 and 1/A101).
NOTE In the following image, the graphic display of the matchline has been overridden. The default graphic display of a matchline is a dashed black line.

Supported View Types for Dependent Views

You can create dependent views for plan views, elevation views, section views, and callout views. When you create dependent section, elevation, or callout views, a new section, elevation, or callout symbol is generated on top of the original symbol. You can move the new symbol independently.

Visibility and Graphic Settings for Dependent Views

When you add view-specific information to a primary view or a dependent view, it is visible in all related views. You can specify visibility and graphic overrides to individual elements on a per-view basis. This allows you to clean up areas where there is overlap between related views. For more information, see Hiding Elements in a View on page 811.

Dependent Views and View Properties

A dependent view inherits view properties and view-specific elements from the primary view. Synchrony is kept between the primary view and dependent views for the following view properties:

■ View Scale
■ Display model
■ Detail Level
■ Visibility settings
■ Visual Style
■ Graphic Display Options
■ Hide at scales coarser than
■ Underlay
■ Underlay orientation
■ Wall Join Display
The following properties can vary between the primary view and dependent views:

- **Orientation**
- **Identity Data properties (with the exception of the Default View Template property)**
- **Extent properties (with the exceptions of View Range and Associated Level)**
- **Scope Box**
- **Project parameters**
- **Shared parameters**

### Adding Matchlines for Dependent Views

Matchlines are sketch lines that you can add to a view to indicate where a view is split, as shown in the following image.

You can customize the look of matchlines by editing the line weight, color, and pattern in the Object Styles dialog. See **Object Styles** on page 1601. You can add view references near a matchline to link views. See **Navigating Primary and Dependent Views** on page 817.
Adding a Matchline

1. Open the primary view from which your dependent views were created.
2. If crop regions are not visible, click (Show Crop Region) on the View Control Bar. The crop region for the primary view and the crop regions for dependent views are visible.
3. Click View tab ➤ Sheet Composition panel ➤ (Matchline).
4. Sketch the matchline.

![Matchline Image 2]

5. When finished, click Finish Matchline.

Modifying a Matchline

To edit the matchline sketch:

1. Open any view in which the matchline is visible, and select the matchline.
2. Click Modify | Matchline tab ➤ Mode panel ➤ (Edit Sketch).
3. Edit the sketch line as necessary.
4. When finished, click Finish Edit Mode.

To override matchline graphic format in a view:

1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
2. Click the Annotation Categories tab.
3. Select Matchline from the list.
4. Click Override in the Lines column.
5. In the Line Graphics dialog, select values for Line Weight, Line Color, and Line Pattern, and click OK.
6. Click Apply to see your changes, and click OK to exit the Visibility/Graphics dialog.

Matchline Properties

The following matchline properties are available for matchlines drawn in plan and callout views.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
</tbody>
</table>

NOTE Matchline properties are not available in elevation or sections views, because specifying top and bottom level constraints do not apply in these view types.
Propagating Dependent View Configuration

After you have set up dependent view configuration for one view, you can propagate the view and crop region configuration to parallel views of the same scale. New dependent views display in the Project Browser under the primary view, but are not placed on sheets.

To propagate dependent view configuration:

1. In the Project Browser, select the primary view to propagate.
2. Right-click the view name, and click Apply Dependent Views.
   - The Select Views dialog opens and displays parallel views of the same scale that do not already have dependent views.
3. Click to select the appropriate views.
4. Click OK.

The new dependent views display in the Project Browser under their primary view. Right-click the view, and click Rename to change the name, as necessary. Associativity is not maintained between the original set of views and the new set of views after the configuration is propagated.

Making a Dependent View Independent

In the Project Browser, right-click a dependent view, and click Convert to independent view.

Deleting Dependent Views

When you delete a view that has dependent views, all dependent views are also deleted. When you delete a dependent view, the view and all view references for that view are deleted.

1. In the Project Browser, select the view.
2. Right-click, and select Delete.

Creating Dependent Views

1. In the Project Browser, select the view for which you want to create dependent views.

   NOTE You cannot create a dependent view from another dependent view.

2. Click View tab ➤ Create panel ➤ Duplicate View drop-down ➤ Duplicate as Dependent, or right-click the view name, and click Duplicate View ➤ Duplicate as a Dependent.
The dependent view opens. In the default Project Browser organization, the dependent view displays under the primary view. If you customize the Project Browser display, dependent views can be grouped and filtered like other view types.

3 Optionally, in the Project Browser, right-click the dependent view name, and click Rename. Enter a new name for the view, and click OK.

4 Select the crop boundaries and resize as necessary to show only the necessary portion of the view.

   If crop regions are not visible click (Show Crop Region) on the View Control Bar. You can display model and annotation crop regions. For more information, see Crop Regions on page 849.

Rotating Views

You can rotate section views, scope boxes, and viewports using the Rotate tool. You can also rotate a crop region, which in effect rotates a view.

For information on rotating a project to True North, see Rotating a View to True North on page 110.

Rotating a Section View or Scope Box

1 Open the project view that contains the section (callout) or scope box to rotate.
2 Select the section (callout) or scope box.
3 Click Modify <view type> tab ➤ Modify panel ➤ (Rotate).
4 Rotate the view.

   For more information about the Rotate tool, see Rotating Elements on page 1481.

Rotating a Viewport on a Sheet View

1 Open the sheet view that contains the viewport to rotate.
2 Select the viewport.
3 On the Options Bar, select a value for Rotation on Sheet.
   The view rotates, and the value is propagated to the viewport's View Rotation on Sheet instance parameter.

   When you rotate a viewport, the view title also rotates.

Rotating a View by the Crop Region

When you rotate a view by rotating the crop region, the model rotates in the opposite direction of the crop region.
To rotate a view by its crop region:

1. Open the project view to rotate.
2. On the View Control Bar, click (Show Crop Region).
   The crop region displays in the view. You may need to zoom out to see it.
3. Select the crop region.
4. Click Modify <view type> tab ➤ Modify panel ➤ (Rotate).
5. Rotate the view.
   For more information about the Rotate tool, see Rotating Elements on page 1481.

Crop Regions

The crop region defines the boundaries for a project view. You can display a model crop region and an annotation crop region in all graphical project views. Perspective 3D views do not support the annotation crop region.

The following image shows a plan view with the model and annotation crop regions visible. The annotation crop is the exterior crop region, and the model crop is the interior crop region.

You can show or hide model and annotation crop regions. See Showing or Hiding Crop Regions on page 850. You can also resize a crop region by dragging the blue controls or by explicitly setting the size. See Resizing Crop Regions Graphically on page 850 and Resizing Crop Regions Explicitly on page 853.

Model Crop Region

The model crop region crops model elements, detail elements (such as insulation and detail lines), section boxes, and scope boxes at the model crop boundary. Visible crop boundaries of other related views are also cropped at the model crop boundary.

Annotation Crop Region

An annotation crop region fully crops annotation elements when it touches any portion of the annotation element, so that no partial annotations are drawn. Annotations (such as symbols, tags, keynotes, and dimensions) that reference hidden or cropped model elements do not display in the view, even if they are inside the annotation crop region. For example, if a door has been cropped from the view by the model crop, the door tag will not be visible even if it is positioned inside the annotation crop.
Datum elements (grids and levels) that cross the model crop region display their heads and tails so that they are visible inside the annotation crop boundary. Datum elements are not resized when you turn off the crop region, (the Do Not Crop View option) datum display at the original size they were drawn.

The annotation crop does not display by default when you show crop regions in a primary view. The annotation crop does display by default when you show crop regions in dependent views. For more information on primary and dependent views, see Duplicate Dependent Views on page 843.

**Cropping a View**

1. If the crop region is not visible, click **Show Crop Region** on the View Control Bar.
2. Resize the crop region as necessary by using the drag control or setting the size explicitly.
   - For more information, see Resizing Crop Regions Graphically on page 850 and Resizing Crop Regions Explicitly on page 853.
3. On the View Control Bar, click **Crop View**.

**Showing or Hiding Crop Regions**

On the View Control Bar, click **Show Crop Region or Hide Crop Region**.

**To show or hide the annotation crop:**

1. After you show crop regions, if the annotation crop region is hidden, right-click in the drawing area, and click View Properties.
2. On the Properties palette, select (or clear) the check box for Annotation Crop.

In the drawing area, select the crop region, and both annotation and model crops display. The interior crop is the model crop, and the exterior crop is the annotation crop.

**Resizing Crop Regions Graphically**

You can use drag controls and break line controls to resize a crop region. Break line controls remove portions of the view. If you need to show the crop region, see Showing or Hiding Crop Regions on page 850.

**To resize a crop region using drag controls:**

1. Select the crop region.
2. Drag the blue arrow controls to the desired size.

**To resize a crop region using break line controls:**

1. Select the crop region.
2 Move the cursor near a break line control ( ).
As you place the cursor near a break line control, the portion of the view that will be removed is indicated by the X.
3 Click the control to break the view into separate regions.
Two new crop regions created

You can resize the split crop regions using the drag controls and the break line controls. You can consolidate the split crop regions by dragging the boundary of one crop region on top of the other. A message indicates that the regions will be consolidated.

**NOTE** If you turn off the crop region in the view, all split crop region information is lost. If you later turn on the crop region, you need to recreate the split crop regions. Turning off the crop region is not the same as hiding the crop region. When you turn off the crop region, a message notifies you that split crop region information will be lost. If you can hide a crop region and then show it again, the split crop region information is retained.

**Resizing Crop Regions Explicitly**

You can explicitly set the height and width of a crop region in paper space. This means the size of the region in the view is the same size as the region on a sheet. You can also specify the offset of the annotation crop region from the model crop region.

1. In the drawing area, select the crop region.

2. Click Modify <view type> tab ➤ Crop panel ➤ (Size Crop).
   
   The Crop Region Size dialog opens.

3. If you are modifying a crop region in a perspective 3D view, select either Field of view or Scale (locked proportions). Examples of these modes are provided at the end of this procedure.

4. Modify the values for width and height.

   **NOTE** If you selected Scale for a perspective 3D view, you can modify only height or width, because the values are locked.
5 Modify the offset values for the annotation crop.
   Annotation crop options are not available for perspective 3D views.

6 Click Apply to make the changes, or click OK to make the changes and close the dialog.

There are 2 modes for resizing the crop region: Field of View mode and Scale mode.

- In Field of View mode, you are stretching the crop region to the specified size. For example, if you change a crop region from 100 mm wide by 75 mm high to 50 mm wide by 25 mm high, the crop region updates accordingly. Field of View mode is for perspective and non-perspective views.

- In Scale mode, you change either the height or the width, and Revit Structure maintains the aspect ratio. When you change the value, the view scales, but the field of view remains the same. Scale mode is for perspective views only.

**Cut a View by the Far Clip Plane**

You can cut an elevation, section, or callout view at the far clip plane. You activate this feature using the Far Clipping parameter for the view. The far clip plane is defined with the Far Clip Offset parameter.

The following image shows the clip plane for the model and the resulting elevation view representations for the Far Clipping parameter options (Clip without line, Clip with line, and No clip).

Elements that have symbolic representation in certain views (such as structural beams) and non-cuttable families are not affected when you cut an elevation, section, or callout view by the far clip plane. They will display and are not cut.

This property does affect printing.

**To cut by the far clip plane:**

1 In the Project Browser, right-click the view you want to cut by the far clip plane, and click Properties.
   Alternatively, if the view is active in the drawing area, right-click and click View Properties.

2 On the Properties palette, locate the Far Clipping parameter.
   The Far Clipping parameter is available for elevation, section, and callout views. To use this parameter in a callout view, for the Far Clip Settings parameter, specify Independent.

3 Click the button in the value column.
The Far Clipping dialog displays.

4 In the Far Clipping dialog, select an option, and click OK.
5 Enter a value for Far Clip Offset to specify where the view will be clipped when the Clipping property is active.

Finding Referring Views

The Find Referring Views tool locates all views where the view annotation symbol is visible. For example, if you activate this tool for an elevation view, the Go to View dialog opens and lists all views where the elevation symbol is currently visible.

You can activate this tool from the Project Browser or in the drawing area.

Finding a View Symbol

1 In the Project Browser, right-click the view for which you want to locate view annotation symbols. You can also open the view, and right-click in the drawing area.
2 Select Find Referring Views.
3 In the Go To View dialog, select a view.
4 Click Open View.
   The view opens with the view symbol selected.

Customizing Project View Organization in the Project Browser

You can sort views and sheets in the Project Browser using any of the property values for the view or sheet. For example, the following image shows views in the Project Browser organized by discipline, then by phase, and then by view type. The top level of the Views branch also shows the name of the sort group currently applied (in this case, Discipline).
In addition to sorting views, you can also limit the views that display in the Project Browser by applying a filter. This is useful when you have a project with a large number of views or sheets, and you only want to view a specific set in the Project Browser.

The properties that you can choose from when creating a sort group or applying a filter to the Project Browser include project parameters and shared parameters. For more information about project and shared parameters, see Project Parameters on page 1549.

By default, the Project Browser displays all views (by view type) and all sheets (by sheet number and sheet name).

### Sorting Views or Sheets in the Project Browser

1. Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Browser Organization.
2. In the Browser Organization dialog, click the Views tab to apply a sort to project views, or click the Sheets tab to apply a sort to sheets.
3. Select a sort group.
   
   To view the properties of an existing sort group, select it, and click Edit.
   
   For information on creating a sort group or editing an existing sort group, see Creating a Project Browser Sort Group on page 856 and Editing a Project Browser Sort Group on page 857.
4. Click Apply, then click OK.

### Creating a Project Browser Sort Group

1. Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Browser Organization.
2. In the Browser Organization dialog, click the Views tab to create a sort group for project views, or click the Sheets tab to create a sort group for sheets.
3. Click New.
4. Enter a name for the sort group, and click OK.
5. In the Browser Organization Properties dialog, click the Folders tab.
For the first Group By list, select the view or sheet property to group by.

**NOTE** Values for the selected property must be defined for each view or sheet for the sort to work correctly. To edit view or sheet properties, in the Project Browser, right-click the view or sheet name, and select Properties.

If you want only the first few characters of the property value to be considered, select Leading characters, and specify a value.

Optionally, select 2 additional groupings.

In the Sort By list, select the order for views or sheets to display in the lowest level grouping, and select ascending or descending order.

Click OK.

---

**Editing a Project Browser Sort Group**

1. Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Browser Organization.
2. In the Browser Organization dialog, click the Views tab to edit a sort group for project views, or click the Sheets tab to edit a sort group for sheets.
3. Select a sort group.
4. To rename the sort group, click Rename.
5. To edit the sort group properties, click Edit. In the Browser Organization Properties dialog, make the necessary changes.
6. Click OK.

**Adding a Filter to a Project Browser Sort Group**

1. Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Browser Organization.
2. In the Browser Organization dialog, click the Views tab to apply a filter to project views, or click the Sheets tab to apply a filter to sheets.
3. Select a sort group, and click Edit.
4. In the Browser Organization Properties dialog, click the Filters tab.
5. Select the following:
   a. The view or sheet property as the filter.
   b. The filter operator.
   c. The filter operator value.

   For example, to show only those project views associated with Level 1, you can create a filter by Associated Level, Equal to, Level 1.
6. Optionally, add 2 additional filters.
7. Click OK.

**Editing a Project Browser Filter**

1. Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Browser Organization.
2. In the Browser Organization dialog, click the Views tab to edit a filter that is in a project views sort group, or click the Sheets tab to edit a filter that is in a sheets sort group.
3. Select a sort group, and click Edit.
4 In the Browser Organization Properties dialog, click the Filters tab.
5 Make the necessary changes, and click OK.

Creating a View List

1 In a project, click View tab ➤ Create panel ➤ Schedules drop-down ➤ (View List).
2 On the Fields tab of the View List Properties dialog, select the fields to include in the view list. See Selecting Fields for a Schedule on page 788.
3 (Optional) To create user-defined fields, click Add Parameter.
   For further instructions, see Shared Parameters on page 1541.
4 Specify the remaining schedule properties using the Filter, Sorting/Grouping, Formatting, and Appearance tabs. See Specifying Schedule Properties on page 788.
   By default, all project views are included in the view list. Use the Filter tab to omit views from the list based on their properties.
5 Click OK.

The resulting view list displays in the drawing area. In the Project Browser, it displays under Schedules/Quantities.

Using View Lists

A view list is a schedule of the views in a project. In a view list, you can sort and group views by type, level, sheet, or other parameters. If desired, you can include view lists on sheets. (See Schedules on Sheets on page 1011.)

View lists can help you to do the following:

■ Manage views in a project
■ Track the status of views
■ Ensure that important views display on sheets in the construction document set
■ Ensure that views are using consistent and appropriate settings

You can use a view list to see and modify parameters for multiple views at once. For example, suppose you include the Detail Level and Scale parameters in a view list. From the view list, you can change the detail levels of selected views to coarse, medium, or fine, or change view scales to use consistent settings. You can also change the view name or view title that displays on sheets. By using a view list in this way, you can identify and correct inconsistent view settings from one location.

<table>
<thead>
<tr>
<th>View Name</th>
<th>Sheet Number</th>
<th>Sheet Title</th>
<th>Detail Level</th>
<th>Scale Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Building E</td>
<td>A4</td>
<td>Sections</td>
<td>Medium</td>
<td>96</td>
</tr>
<tr>
<td>Cap Planig</td>
<td>A5</td>
<td>Details</td>
<td>Fine</td>
<td>4</td>
</tr>
<tr>
<td>Changing D</td>
<td>A6</td>
<td>Interiors</td>
<td>Coarse</td>
<td>98</td>
</tr>
<tr>
<td>Clearing R</td>
<td></td>
<td></td>
<td>Coarse</td>
<td>96</td>
</tr>
<tr>
<td>Clearing R</td>
<td></td>
<td></td>
<td>Coarse</td>
<td>96</td>
</tr>
<tr>
<td>Computer C</td>
<td>A6</td>
<td>Interiors</td>
<td>Medium</td>
<td>96</td>
</tr>
<tr>
<td>Cubicles</td>
<td>A6</td>
<td>Interiors</td>
<td>Medium</td>
<td>96</td>
</tr>
<tr>
<td>Main Elev</td>
<td>A2</td>
<td>Interiors</td>
<td>Fine</td>
<td>96</td>
</tr>
<tr>
<td>Elevator</td>
<td>F1</td>
<td></td>
<td>Fine</td>
<td>96</td>
</tr>
<tr>
<td>Entry Elev</td>
<td>A2</td>
<td>Interiors</td>
<td>Coarse</td>
<td>96</td>
</tr>
<tr>
<td>Fire Plan</td>
<td>A2</td>
<td>Plan/Schedules</td>
<td>Medium</td>
<td>96</td>
</tr>
<tr>
<td>Floor Plan</td>
<td>A2</td>
<td>Plan/Schedules</td>
<td>Medium</td>
<td>96</td>
</tr>
<tr>
<td>Plan Setting</td>
<td>T</td>
<td>Title Sheet</td>
<td>Medium</td>
<td>16</td>
</tr>
<tr>
<td>Plan Setting</td>
<td>T</td>
<td>Title Sheet</td>
<td>Medium</td>
<td>16</td>
</tr>
</tbody>
</table>

Related topic

■ Sheet Lists on page 1015
Adding a View List to a Sheet

To add a view list to a sheet, use the procedure for adding a schedule to a sheet. See Adding a Schedule to a Sheet on page 1011.

When you add a view list to a sheet, you can perform the same functions as for schedules on sheets, including the following:

- Formatting the view list
- Splitting the view list
- Adjusting the width of columns
- Displaying column headings vertically instead of horizontally

For instructions, see Schedules on Sheets on page 1011.

Reusing Views and Sheets in Other Projects

If another project contains a view or sheet that you want to reuse in the current project, use the Insert Views from File tool. This tool can copy the following types of views into the current project:

- Schedules
- Drafting views
- Rendered images
- Sheets that contain only drafting views

To reuse views and sheets

1. Open the project where you want to reuse existing views or sheets.
2. Click Insert ➤ Import panel ➤ Insert from File drop-down ➤ (Insert Views from File).
3. In the Open dialog, navigate to the project that contains the desired views or sheets, select it, and click Open.
4. In the Insert Views dialog, select the views or sheets to include in the current project, and click OK.

Revit Structure copies the selected views or sheets to the current project, and lists them in the Project Browser.

Related topics

- Adding Views to a Sheet on page 980
- Reusing Drafting Views on page 966
- Reference Callouts on page 753

View Settings

Related topic

- Detail Level on page 1618
Zooming Project Views

The Zoom tool changes the viewable area in the window.

The following Zoom options are available on the navigation bar:

■ Zoom in Region
■ Zoom Out (2X)
■ Zoom to Fit
■ Zoom All to Fit
■ Zoom Sheet Size
■ Previous Pan/Zoom
■ Next Pan/Zoom

If the navigation bar is hidden in your view, click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Navigation Bar.

You can also zoom project views using the SteeringWheels. See Navigating Views on page 818.

Maintaining Line Thickness when Zooming

The Thin Lines tool maintains the true thickness of lines relative to the zoom of the view. Typically, when you zoom in on a model in a small scale view, element lines appear much thicker than they actually are.

When you activate the Thin Lines tool, it affects all views but does not affect printing or print preview.

To activate the tool, click View tab ➤ Graphics panel ➤ Thin Lines.

View Scale

The view scale is the proportional system used to represent objects in a drawing. You can assign a different scale to each view in a project. You can also create custom view scales.

To assign a view scale

Use one of the following methods:

■ In the Project Browser, right-click the view, and click Properties. On the Properties palette, for View Scale, select a value.

■ Select a scale from the View Control Bar.
To create a custom view scale

1 On the View Control Bar, click the view scale, and select Custom.

2 In the Custom Scale dialog, enter a value for Ratio.
3 (Optional) Select Display Name, and enter a custom name for the scale.
4 Click OK.

NOTE Custom view scales cannot be applied to other views in the project.

Related topics

- Setting Detail Level Scale Values on page 1618
- View Properties on page 873

Detail Levels and Display of Structural Components

The display of structural components differs based on the detail level of the view. For example, structural framing appears as sticks in coarse detail level, but has much more detail at medium or fine detail level.

Detail Level is a view instance parameter; therefore every view can have a different setting for this parameter. Detail Level is also view scale dependent. For information on setting scales with detail level and the Detail Level tool, see Detail Level on page 1618.

Display of Hidden Lines of Structural Concrete Components

Revit Structure provides the ability to control the display of structural concrete components that are in a hidden state in a view. The display of invisible lines of walls, floors, framing, columns, and foundation elements is controlled by the following view parameters:

- Discipline
  Discipline must be set to Structural for invisible lines to be represented as hidden.

- Visual Style
  By setting Model Graphics to either Hidden or to Shaded with Edges, invisible lines are represented as hidden.

NOTE You set the pattern of hidden lines in the Visibility/Graphics dialog. See Visibility and Graphic Display in Project Views on page 801.
Showing Hidden Element Lines

Model and detail elements that are obscured by other elements can be displayed using the Show Hidden Lines tool. You can use the Show Hidden Lines tool on all elements that have the Hidden Lines subcategory. The Remove Hidden Lines tool is the inverse of the Show Hidden Lines tool.

1. Click View tab ➤ Graphics panel ➤ Show Hidden drop-down ➤ (Show Hidden Lines).
2. Place the cursor on an element that is hiding another element, and click to select it. For example, select a filled region that is overlapping a wall.
3. Place the cursor on the element with lines to be shown, and click to select it. The lines of this element display in a hidden line style through the overlapping element. To change the hidden line style of the element, use the Object Styles tool.
4. To reverse the effects of this tool, click View tab ➤ Graphics panel ➤ Show Hidden drop-down ➤ (Remove Hidden Lines).
5. Select the element that will hide the other element.
6. Select the other element to be hidden.

Section, Elevation, and Callout View Tag Setup

You can define the look of view tags used for sections, elevations, and callouts by editing their properties.

Editing Type Properties for View Tags

1. Click Manage tab ➤ Project Settings panel ➤ Settings drop-down ➤ Callout Tags, Elevation Tags, or Section Tags.
2. In the Type Properties dialog, edit type properties as necessary.
Selecting View Tags

Each view tag has several components. If you want to modify a view tag’s element properties or make other changes, you must be sure to select the entire view tag. If you select only a portion of it, you may not be setting properties for or changing the correct object.

- To select a section tag, click the section line.

- To select an elevation tag, click the square part of the tag.

- To select a callout tag, click the dotted line (bubble) that defines the callout area.

To see the properties of the view, right-click the selected view tag, and click Properties.

Hiding Elevation Tags

You can set the view scale at which elevation tags are hidden in project views. Each elevation tag instance can have a different view scale at which it is hidden.

To hide elevation tags

1. In the drawing area, select the triangle on the elevation tag.
2. On the Properties palette, select a value for the Hide at Scales Coarser Than parameter.
3. Click OK.

Callout Tag Properties

You can set the following parameters for callout tags. See also Callout Tags on page 750.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Callout Head</td>
<td>The head used for the callout.</td>
</tr>
<tr>
<td>Corner Radius</td>
<td>Sets the angle of the corners of the callout.</td>
</tr>
</tbody>
</table>
Elevation Tag Properties

You can set the following parameters for elevation tags.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape</td>
<td>Specifies the shape of the elevation symbol.</td>
</tr>
<tr>
<td>Text Position</td>
<td>Specifies the text position for the elevation view.</td>
</tr>
<tr>
<td>Arrow Angle</td>
<td>Sets the thickness of the arrowhead.</td>
</tr>
<tr>
<td>Filled</td>
<td>Specifies whether the arrowhead is filled in.</td>
</tr>
<tr>
<td>Show View Name</td>
<td>Shows the elevation name with the arrowhead.</td>
</tr>
<tr>
<td>View Name Position</td>
<td>Aligns the view name with the elevation view arrowhead.</td>
</tr>
<tr>
<td>Reference Label Position</td>
<td>Aligns the reference label with the elevation view arrowhead.</td>
</tr>
<tr>
<td>Line Weight</td>
<td>Sets the line weight of the elevation symbol. You can change the definition of the line weight value using the Line Weights tool.</td>
</tr>
<tr>
<td>Color</td>
<td>Sets the color of the symbol.</td>
</tr>
<tr>
<td>Line Pattern</td>
<td>Sets a line pattern for the elevation symbol. You can use a preset line pattern or define your own. See Line Patterns for more information.</td>
</tr>
<tr>
<td>Text Font</td>
<td>Specifies the typeface for the elevation symbol.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Specifies the size of the text with respect to the scale of the drawing.</td>
</tr>
<tr>
<td>Width</td>
<td>Specifies the width of the interior elevation symbol.</td>
</tr>
</tbody>
</table>

Section Tag Properties

You can set the following parameters for section tags.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Section Head</td>
<td>Specifies the shape of the section head.</td>
</tr>
<tr>
<td>Section Tail</td>
<td>Specifies the shape of the section tail.</td>
</tr>
<tr>
<td>Broken Section Display Style</td>
<td>Specifies the line pattern of a segmented section. For more information, see Segmented Section View on page 740.</td>
</tr>
</tbody>
</table>

View Range

Every plan has a view property called View Range, also known as a visible range. The view range is a set of horizontal planes that control object visibility and display in the view. The horizontal planes are Top, Cut Plane, and Bottom. The top and bottom clip planes represent the topmost and bottommost portion of the view range. The cut plane is a plane that determines at what height certain elements in the view are shown cut. These 3 planes define the primary range of the view range.
View depth is an additional plane outside of the primary range. You can set the level of view depth to show elements below the bottom clip plane.

The following image shows the view range of a plan view from an elevation view standpoint: Top 1, Cut plane 2, Bottom 3, Offset 4, Primary Range 5, and View Depth 6.

The following image shows the actual plan view for this section view range.

Elements outside of the view range do not display in the view. The exception to this is if you set the view underlay to a level outside the view range. For more information on the Underlay view property, see View Properties on page 873.

**How are elements drawn with respect to the view range?**

- Elements within the boundaries of the primary range that are not cut are drawn in the element's projection line style.
- Elements that are cut are drawn in the element's cut line style.
NOTE Not all elements can display as cut.

- Elements that are within the view depth are drawn in the beyond line style.

You can change the display of cut and projection line styles through the **Object Styles** tool. You can change the display of the beyond line style through the **Line Styles** tool.

### Additional View Range Rules

- Model elements located outside of the view range generally are not shown in the view. The exceptions are floors, stairs, ramps, and components that stay or are mounted on the floor (like furniture). These are shown even when slightly below the view range. In addition, slab edges are shown when their bottoms are within a tolerance of the primary view range bottom. Foundation slabs and structural floors located outside the view range use an adjusted range that is 4 feet (approximately 1.22 meters) below the bottom of the primary range. Floors are drawn with the Beyond line style if the floor exists within this adjusted range.

- Elements that are strictly below the cut plane, but are at least partially within the view range, are shown as viewed from above. Components display according to Family Element Visibility Settings for Plan/RCP. See **Managing Family Visibility and Detail Level** on page 1619.

- Walls shorter than 6 feet (approximately 1.83 meters) are not cut, even if they intersect the cut plane. The 6 feet are measured from the top of the bounding box to the bottom of the primary view range. For example, if you create a wall with a sloped top face, when the top of the wall is 6 feet away from the bottom of the primary view range, the wall is cut at the cut plane. When the top of the wall is less than 6 feet, the entire wall shows as projection even where it intersects the cut plane. This behavior always occurs when the Top Constraint property for the wall is specified as Unconnected.
There are a few categories for which an element located above the cut plane but partially below the top clip is shown in plan. These categories include windows, casework, and generic models. These objects are shown as viewed from above.

Modifying the View Range

1. Open a plan view.
2. On the Properties palette, locate the View Range parameter, and click Edit.
3. In the View Range dialog, modify view range properties as necessary. See View Range Properties on page 867.

In the View Range dialog, levels used to define the visible range are absolute to the current level of the view. For example, if you are in the Level 2 structural plan of a multi-story building and you select Level 4 as the top, Revit Structure keeps Level 4 as the top, even if you add levels between Level 2 and Level 4. If you were to delete Level 4, then the clip plane would revert back to the default level with which the view is associated. In this example, it would revert to Associated Level (Level 2). Values, such as Level Above and Level Below, always have a specific level name associated with them. For example, if you are setting the view range for Level 1, the Level Above value would read Level Above (Level 2).

4. Click Apply to view changes.

View Range Properties

Parameter names, values, and descriptions for view ranges. Values are modifiable.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>Sets the upper boundary of the primary range. The upper boundary is defined as a level and an offset from that level. Elements display as defined by their object styles. Elements above the offset value do not display.</td>
</tr>
<tr>
<td>Cut plane</td>
<td>Sets a height at which elements in a plan view are cut, such that building components below the cut plane display in projection, and others that intersect it display as cut. Building components that display as cut include walls, roofs, ceilings, floors, and stairs. A cut plane does not cut components.</td>
</tr>
<tr>
<td>Bottom</td>
<td>Sets the level of the Primary Range's lower boundary. If you access View Range while viewing the lowest level of your project and set this property to level below, you must specify a value for Offset, and you must set View Depth to a level below it.</td>
</tr>
<tr>
<td>View Depth</td>
<td>Sets a vertical range for the visibility of elements between specified levels. In a structural plan, View Depth is either below or above the cut plane, depending on View Direction. View Depth is below the cut plane when View Direction is down, and above the cut plane when View Direction is up. See Plan View Direction on page 725. For example, if you are designing a multi-story building, you might have a floor plan for the 10th floor that had a depth to the first level. Specifying view depth lets you display visible objects below the primary range with Beyond line style. The view can also be cut at the View Depth plane.</td>
</tr>
</tbody>
</table>

Visual Styles

You can specify many different graphic styles for a project view. Visual styles are grouped into models graphics and graphic display options.
Model graphics options are

- Wireframe
- Hidden line
- Shaded
- Shaded with Edges
- Consistent Colors
- Realistic

Graphic display options are

- Sun Setting
- Sun Intensity
- Indirect Light
- Cast Shadows
- Ambient Occlusion
- Silhouette Style
- Gradient Background

**Specifying a Visual Style**

On the View Control Bar at the bottom of the drawing area, click the Visual Style icon, and select an option.

To save a view with an applied visual style

In a 3D view, click on the navigation bar. SteeringWheels display in the drawing area. Right-click SteeringWheels, and click Save View. Enter a name for the new 3D view, and click OK.

**NOTE** If the navigation bar is hidden in your view, click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Navigation Bar.

The new view appears in the Project Browser under 3D Views.

**Wireframe Visual Style**

The Wireframe style displays the image of the model with all edges and lines drawn, but with no surfaces drawn. This tool affects the current view only.

**NOTE** When a view displays the wireframe visual style, you can apply materials to selected element types, but those materials do not display in the wireframe view. Also, you cannot place material keynotes in a wireframe view.
Hidden Line Visual Style

Hidden Line style displays the image with all edges and lines drawn except those obstructed by surfaces. This style affects the current view only.

Displaying Intersecting Geometry with Hidden Lines

If the model includes intersected geometry (for example, an extrusion passing through a wall surface), Revit Structure does not create new edges along the lines of the intersection. This may result in incorrect hidden line removal during export. If you attempt to export a view of the design with hidden lines turned on, you may see unexpected results when you open the view in another CAD application. See Hidden Line Visual Style on page 869.

To see all visible lines, Revit Structure recommends that you first create an opening in one surface before passing another surface through it. See Editing the Profile of a Wall on page 455.

Shaded Visual Style

The Shaded style displays the image in shaded mode, and has the option of displaying ambient occlusion. Select Ambient Occlusion from the Graphics Display Option dialog to simulate the blocking of ambient (diffused) light. A default light source provides illumination for the shaded elements. The number of colors that can display for shading depend on the number of colors you have configured to display in Windows. This setting affects the current view only.
Shaded with Edges Visual Style

The Shaded with Edges style displays the image in shaded mode, and has the option of displaying ambient occlusion. Select Ambient Occlusion from the Graphics Display Option dialog to simulate the blocking of ambient (diffused) light. A default light source provides illumination for the shaded elements. This setting affects the current view only.

Consistent Colors Visual Style

The Consistent Colors style displays the image with all surfaces shaded according to their material color settings. This style maintains a consistent shading color so that a material is always displayed in the same color no matter how it is oriented to the light source.
Realistic Visual Style

With Hardware Acceleration enabled from the Options dialog, the Realistic style displays material appearances in editable views. As you rotate the model, the surfaces display as they may appear in various lighting conditions. Select Ambient Occlusion from the Graphics Display Option dialog to simulate the blocking of ambient (diffused) light. See Changing the Render Appearance of a Material on page 1582.

**NOTE** Artificial lighting does not display in Realistic views.

---

Graphic Display Options

The settings on the Graphics Display Options dialog are used to enhance the visual result of your model view. For example, when creating a model in real-time, using the Realistic visual style, you can enable Ambient Occlusion to give your model more realistic shading and depth. The Graphic Display Options dialog is accessed from the Shadows On/Off tool on the View Control Bar.

<table>
<thead>
<tr>
<th>Graphic Display Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lighting</td>
<td></td>
</tr>
</tbody>
</table>
## Graphic Display Option

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sun Setting</td>
<td>Select from predefined sun settings for dates and times of interest, such as Summer Solstice, or Fall Equinox.</td>
</tr>
<tr>
<td>Sun Intensity</td>
<td>Move the slider or enter a value between 0 and 100 to change the brightness of the direct light.</td>
</tr>
<tr>
<td>Indirect Light</td>
<td>Move the slider or enter a value between 0 and 100 to change the brightness of the ambient light.</td>
</tr>
<tr>
<td>Cast Shadows</td>
<td>Move the Shadow slider or enter a value between 0 and 100 to change the darkness of the shadows.</td>
</tr>
<tr>
<td>Ambient Occlusion</td>
<td>Select this option to simulate the blocking of diffused (ambient) light. Available with shaded visual styles, elevations, sheets, and sections. Not available in the Family Editor, or in detail views.</td>
</tr>
</tbody>
</table>

**NOTE** Ambient Occlusion is available when Hardware Acceleration is enabled from the Graphics tab on the Options dialog.

## Edges

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Silhouette Style</td>
<td>Select from a number of line styles that create a silhouette.</td>
</tr>
<tr>
<td>Background</td>
<td>(available in 3D views)</td>
</tr>
<tr>
<td>Gradient Background</td>
<td>Select this option to enable the sky, horizon, and ground color options.</td>
</tr>
</tbody>
</table>

## Related topics

- [Real-time Rendering Overview](#) on page 1032
- [Creating Solar Studies](#) on page 1376

---

### Applying or Removing a Line Style for a Silhouette Edge

Revit Structure can automatically apply a line style to silhouette edges. Silhouette edges are view-specific.

After you have applied silhouette edges to the model, there may be edges you do not want to display in silhouette. You can remove these lines as necessary.

**To apply a line style to a silhouette edge:**

Silhouette edges are not available for Wireframe or Shaded model graphic styles.

2 On the View Control Bar, click 🕶 (Shadows Off/On) ➤ Graphic Display Options.
3 In the Graphic Display Options dialog, in the Edges panel, select a Silhouette style (for example, Wide Lines).
4 Click OK.

To remove a line style from a silhouette edge:

1 Click Modify tab ➤ View panel ➤ 🏛️ (Linework).
2 In the Type Selector, select <Not Silhouette>.
3 Select the edges in silhouette, and the silhouette is removed.

For more information about the Linework tool, see Changing the Line Style of Elements on page 1498.

View Properties

To see or change view properties

➤ On the Properties Palette on page 34, do one of the following:
- Use the properties filter (below the Type Selector) to select the current view.
- With the view open in the drawing area, click in an empty part of the view.
- In the Project Browser, click the view name.

The following properties are common to most view types.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Scale</td>
<td>Changes the scale of the view as it appears on the drawing sheet. Select a scale value from the list.</td>
</tr>
<tr>
<td>Scale Value</td>
<td>Defines a custom scale value. This property is enabled when Custom is selected for View Scale.</td>
</tr>
<tr>
<td>Display Model</td>
<td>Hides the model in detail view. The Normal setting displays all elements normally. It is intended for all non-detail views. The Do Not Display setting shows only detail-view–specific elements. These elements include lines, regions, dimensions, text, and symbols. Elements in the model do not display. The Halftone setting displays all detail-view–specific elements normally, while model elements are displayed in halftone. You can use the halftone model elements as references for tracing lines, dimensioning, and aligning.</td>
</tr>
</tbody>
</table>
| Detail Level     | Applies a detail level setting to the view scale: coarse, medium, or fine. This setting overrides the automatic detail level setting for the view. When you apply a detail level to a view, you enable the visibility of certain types of geometry:
  - The compound structure of walls, floors, and roofs displays at medium and fine detail levels.
  - Family geometry changes depending on the detail levels. |
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structural framing changes</td>
<td>Depending on detail level. At coarse levels, it appears as lines. At medium and fine levels, it displays with more geometry.</td>
</tr>
<tr>
<td>Visibility/Graphics Overrides</td>
<td>Click Edit to access the Visibility/Graphics dialog.</td>
</tr>
<tr>
<td>Visual Style</td>
<td>Changes the display to Hidden Line, Wireframe, Shaded, or Shaded with Edges. See Visual Styles on page 867.</td>
</tr>
<tr>
<td>Graphic Display Options</td>
<td>Click Edit to access the Graphic Display Options dialog, which controls shadows and silhouette lines. See Visual Styles on page 867.</td>
</tr>
<tr>
<td>Underlay</td>
<td>Displays another slice of the model under the current plan view. That slice of the model can be from above or below the current level. The underlay appears dimmed and is visible even in hidden line. The underlay is useful to understand the relation of components on different floors. Normally, you would turn off the underlay before exporting or printing the view. You set an underlay by specifying a level. The slice of the model between that level and the next level up displays. Three of the underlay options (Current Level, Level Above, and Level Below) are relative to the current level. All other choices are absolute. See Halftone/Underlay on page 1605. TIP A level that is actually higher than the current level can be the underlay view. For example, the basement level could have Level 2 as its underlay.</td>
</tr>
<tr>
<td>Underlay Orientation</td>
<td>Controls the display of the underlay in Hidden Line mode. If the value is specified as Plan, then the underlay displays as if you are viewing it from above, like a plan view. If the value is specified as Reflected Ceiling Plan, then the underlay displays as if you are viewing it from below, like a reflected ceiling plan.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Switches the orientation of the project in the view between Project North and True North. See Project Location and Orientation on page 107.</td>
</tr>
<tr>
<td>Wall Join Display</td>
<td>Sets the default behavior for cleaning wall joins. If you set this property to Clean All Wall Joins, then Revit Structure automatically cleans all wall joins. If you set this property to Clean Same Type Wall Joins, Revit Structure only cleans wall joins of the same wall type. If you join different wall types, Revit Structure does not clean them. You can override this setting using the Edit Wall Joins tool.</td>
</tr>
<tr>
<td>Discipline</td>
<td>Specify the discipline for the project view, Architectural, Structural, or Coordination. The discipline specified determines the organization of views in the Project Browser. Coordination combines Architectural and Structural. Select Structural to hide non-load-bearing walls from the view.</td>
</tr>
<tr>
<td>Color Scheme Location</td>
<td>In a structural plan view or section view, select Background to apply the color scheme to the background of the view (the floors of a structural plan, or the background walls of a section). Select Foreground to apply the color scheme to all model elements in the view. See .</td>
</tr>
<tr>
<td>View Name</td>
<td>The name of the active view. The view name displays in the Project Browser and in the title bar of the view. It also displays as the name of the viewport on a sheet, unless you define a value for the Title on Sheet parameter.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Title on Sheet</td>
<td>The name of the view as it appears on the sheet; it supersedes any value in the View Name property. This parameter is not available for sheet views.</td>
</tr>
<tr>
<td>Referencing Sheet</td>
<td>See the description for Referencing Detail that follows. From the example, the referencing sheet is A101.</td>
</tr>
<tr>
<td>Referencing Detail</td>
<td>This value comes from the referencing view that is placed on a sheet. For example, you create a section in a plan view. You place that plan view as the first detail on a sheet numbered A101. The referencing detail number for the section view is 1.</td>
</tr>
<tr>
<td>Default View Template</td>
<td>Identifies the default view template for the view. See View Templates on page 1637.</td>
</tr>
<tr>
<td>Crop View</td>
<td>Select the Crop View check box to enable a crop boundary around the model. Select the boundary and resize it using the drag controls. As you resize the boundary, the visibility of the model changes. To turn off the boundary and maintain the cropping, clear the Crop Region Visible check box. See Crop Regions on page 849.</td>
</tr>
<tr>
<td>Crop Region Visible</td>
<td>Shows or hides the crop region. View cropping is not available in sheet and schedule views.</td>
</tr>
<tr>
<td>Annotation Crop</td>
<td>Shows or hides the annotation crop when crop regions are visible in the project view.</td>
</tr>
<tr>
<td>View Range</td>
<td>Within the view properties of any plan view, you can set the View Range. With View Range, you can control the specific geometric planes that define the boundaries of each view. These boundaries are set by defining the exact cut plane as well as the top and bottom clip planes.</td>
</tr>
<tr>
<td>Associated Level</td>
<td>The level associated with the plan view. This is a read-only property.</td>
</tr>
<tr>
<td>Scope Box</td>
<td>If you draw a scope box in a view, you can associate the view's crop region with that scope box, so the crop region is visible and matches the scope box extents. This property is available for plan, elevation, and section views. When you select a scope box value for this property, the Crop Region and Crop Region Visible properties become read-only.</td>
</tr>
<tr>
<td>Phase Filter</td>
<td>The specific phase filter applied to the view.</td>
</tr>
<tr>
<td>Phase</td>
<td>The specific phase of the view. Along with the Phase Filter, it determines which model components (phase-wise) are visible in the view and how they appear graphically. When you create new model components in a view, these components assume the view phase as their creation phase.</td>
</tr>
</tbody>
</table>
Many projects, such as renovations, proceed in phases, each representing a distinct time period in the life of the project. Revit Structure tracks the phase in which views or elements are created or demolished. It lets you create phases and phase filters that you can apply to views, which define how the project appears during various stages of work. You can also use phase filters to control the flow of building model information into views and schedules. This allows you to create phase-specific project documentation, complete with schedules.

You can apply phases to schedules. For example, in a large renovation project, a door schedule would usually list all doors created in the project. In a building with hundreds of doors, the schedule could become difficult to work with, because the demolished doors would be listed with the post-renovation doors. Instead of working with a schedule in which half of the doors are eventually demolished, you could create one pre-demolition schedule and one post-renovation schedule, applying the appropriate phase to each. See Applying a Phase to a Schedule on page 795.

Phase Properties

You can create as many phases as necessary and assign building model elements to specific phases. You can also make multiple copies of a view and apply different phases and phase filters to the different copies.

Phase Properties for Views

Each view in Revit Structure has a Phase property and a Phase Filter property.

- The Phase property is the name of the view phase. When a view is opened or created, it automatically has a Phase value. You can copy a view and then select a different phase value for that view. For example, the original view has Phase 1; the copy has Phase 2. You create an element in Phase 1 and demolish it in Phase 2. The element displays as new in the original and as demolished in the copy. See Creating Phases on page 878.

- The Phase Filter property lets you control the display of elements in a view. For example, demolished walls may display in blue dashed lines, while existing elements display in solid black lines. You can apply a phase filter to a view to see elements from one or more specified phases. See Phase Filters on page 879.

Phase Properties for Elements

Each element that you add to a project has a Phase Created property and a Phase Demolished property.

- The Phase Created property identifies the phase in which the element was added to the building model. The default value for this property is the same as the Phase value for the current view. You can specify a different value as needed.
The Phase Demolished property identifies the phase in which the element was demolished. The default value is None. When you demolish an element, this property updates to the current phase of the view in which you demolished the element. You can also demolish an element by setting the Phase Demolished property to a different value. See Demolishing Elements on page 883.

Creating Phases

1. Click Manage tab ➤ Phasing panel ➤ (Phases). The Phasing dialog opens, displaying the Project Phases tab. By default, each project has phases called Existing and New Construction.

2. Click the number box adjacent to a phase. Revit Structure selects the entire phase row. The following image shows the New Construction phase selected.

3. Insert a phase. **IMPORTANT** You cannot rearrange the order of phases after you add them, so be aware of placement.

   To insert a phase before or after the selected phase, under Insert, click Before or After. Revit Structure names the phases sequentially as you add them. For example: Phase 1, Phase 2, Phase 3, and so on.

4. If desired, click the Name text box of a phase to rename it. Similarly, click the Description text box to edit the description.

5. Click OK.

Related topics

- Combining Phases on page 879
- Phase Filters on page 879
- Phase Properties on page 877
Combining Phases

When you combine phases, the selected phase is deleted. All elements with that phase value for their Phase Created and Phase Demolished properties update to show the new combined phase value.

To combine phases

1. Click Manage tab ➤ Phasing panel ➤ (Phases).
2. Click the number box adjacent to the phase to combine with another phase.
3. Under Combine with, click Next or Previous.
4. Click OK.

Phase Filters

A phase filter is a rule that you apply to a view to control the display of elements based on their phase status: new, existing, demolished, or temporary.

Default Phase Filters

Each Revit project contains the following default phase filters:

- **Show All.** Shows new elements (using the graphics settings defined for that category of elements) and existing, demolished, and temporary elements (using the Graphic Overrides settings for each phase defined using Manage tab ➤ Phasing panel ➤ Phases ➤ Graphic Overrides tab).
- **Show Demo + New.** Shows demolished elements and all new elements added to the building model.
- **Show New.** Shows all new elements added to the building model.
- **Show Previous + Demo.** Shows existing elements and demolished elements.
- **Show Previous + New.** Shows all original elements that were not demolished (Show Previous) and all new elements added to the building model (+ New).
- **Show Previous Phase.** Shows all elements from the previous phase. In the first phase of a project, existing elements are new to that phase, so applying the Show Previous Phase filter causes no elements to be displayed.

**NOTE** To show all elements from all phases, do not apply a phase filter to the view.

Phase Status

Each view can show one or more phases of the construction. You can specify different graphic overrides for each phase status.

- **New.** Element was created in the phase of the current view.
- **Existing.** Element was created in an earlier phase and continues to exist in the current phase.
- **Demolished.** Element was created in an earlier phase and demolished in the current phase.
- **Temporary.** Element was created and demolished during the current phase.
Creating Phase Filters

1 Click Manage tab ➤ Phasing panel ➤ (Phases).

2 In the Phasing dialog, click the Phase Filters tab.

3 Click New to insert a new phase filter. The filter is assigned a default name.

4 (Optional) Click in the Filter Name box to edit the name.

5 For each phase status column (New, Existing, Demolished, and Temporary), specify how you want to display the elements:
   ■ **By Category**. Displays elements as defined in the Object Styles dialog. See Object Styles on page 1601.
   ■ **Overridden**. Displays elements as specified in the Graphic Overrides tab of the Phasing dialog. See Defining the Graphic Display for Phase Statuses on page 880.
   ■ **Not Displayed**. Does not display the elements.

6 Click OK.

Applying Phase Filters

1 Access view properties for the view.

2 On the Properties palette, for Phase Filter, select one of the following:
   ■ A default phase filter. See Default Phase Filters on page 879.
   ■ A phase filter that you created. See Creating Phase Filters on page 880.
   ■ None to apply no phase filter to the view. (All elements are shown in the view without any graphic overrides.)

Defining the Graphic Display for Phase Filters

You define graphic overrides to change the display of elements in views that use phase filters.

**To define the graphic display for phases**

1 Click Manage tab ➤ Phasing panel ➤ (Phases).

2 In the Phasing dialog, click the Graphic Overrides tab.

3 Click the appropriate boxes to define the display for new, temporary, demolished, and existing elements. See Defining the Graphic Display for Phase Statuses on page 880.

4 Click the Phase Filters tab.

5 For each filter, specify how you want to display the elements for each phase status (New, Existing, Demolished, and Temporary). For phases that use the graphic override settings, select Overridden. See Creating Phase Filters on page 880.

6 Click OK.

Defining the Graphic Display for Phase Statuses

You can apply a different graphic display or override to the elements in a phase status.
To specify a graphic override to the elements in a phase status

1 Click Manage tab ➤ Phasing panel ➤ (Phases).
2 In the Phasing dialog, click the Graphic Overrides tab.
3 Click Lines to specify the weight, color, and line pattern for projection lines and cut lines.
4 Click Patterns to specify color, and fill pattern for surface and cut patterns, and to turn the visibility of the pattern on or off.
   ■ To display no fill pattern for the Phase Status, clear the Visibility selection.
   ■ To display the fill pattern according to the Object Styles defined under Settings, select No Override.
5 Click Halftone to blend the line color with the background color of the view. See Halftone/Underlay on page 1605.
   ■ When you select this option, all line graphics (including fill patterns) and solid fills are drawn with halftone.
   ■ Halftone has no effect on material color in shaded views.
6 Click Material to specify the shading for shaded views and for the render appearance on the Graphics tab.
   NOTE Shading and Render Appearance are the only valid options you can select from the Graphics tab of the Material dialog. The surface pattern and cut pattern are settings you specified on the Graphics Overrides tab of the Phasing dialog.
7 Click OK.

Infill Elements for Phasing

If an insert (such as a window) and its host (such as a wall) do not have the same values for the Phase Created and Phase Demolished properties, Revit Structure automatically places an infill element in the host to patch the hole created by the demolished insert.

The infill element lets you place inserts in one phase, demolish them, and then place new inserts in the same location. The infill element assumes the same structure as its host. In certain cases, you can modify the structure of the infill element by changing its type.

Infill elements for roofs and floors project down from the top face, and infill elements for ceilings project up from the bottom face.

You cannot drag, move, mirror, rotate, copy, or paste an infill element.

Infill Elements for Earlier Phases

If you place an insert into a host in a phase later than the host’s creation phase, Revit Structure creates an infill element for earlier phases.

For example, you create a roof in Phase 1. You add a skylight to the roof in Phase 2. You look at the roof and skylight in a 3D view. If you set the 3D view’s phase to Phase 1, an infill element replaces the skylight. You can view this infill element in a section view.

Infill Elements for Demolished Host Elements

When you demolish an insert in a host element, the insert becomes an infill element.
Demolished window becomes infill element

Next, you place a new insert near the demolished insert.

New window placed near demolished window

Then, if you apply a phase filter to the view that does not show demolished elements (such as Show Previous + New), you see only the new insert.

New window only

**Viewing Infill Elements**

To see an infill element, create a section view whose cut plane runs through the demolished insert and the host.

Sample section passing through wall and demolished window

**Changing the Structure of Infill Elements**

If you demolish an insert in a phase later than the host's creation phase, you can change the structure of the infill element. You can use this technique to represent different materials and thicknesses in the host.
NOTE You cannot change the structure of an infill element created for phases earlier than the insert’s phase.

To change the structure of an infill element

1. Open a section view that passes through the demolished insert.
2. Access view properties.
3. On the Properties palette, for Phase Filter, select Show Previous + New.
   This filter shows all original elements that were not demolished and all new elements added to
   the building model.
4. Select the infill element in the view.
   You may need to move the cursor along a face of the element until it highlights. (Watch the
   status bar for information about highlighted elements.) The following image shows a selected
   infill element.

5. Select the desired host element type from the Type Selector on page 35.
   The infill element updates accordingly, as shown in the following section view.

Demolishing Elements

Use the Demolish tool to mark elements as demolished in the current phase. If you demolish an element
in one view, it is marked as demolished in all views that have the same phase.

When you demolish an element, its display changes based on the phase filter setting for the view. For
element, if you apply the Show Demo + New phase filter to the view, any demolished elements display as
black, dashed lines. If you turn off the display of the demolished elements in that phase filter, then demolished
elements are hidden in the view when you click them.
NOTE  If you build and demolish an element in the same phase, it is considered to be a temporary element. It displays in the view according to the phase filter's setting for temporary elements.

The following images show a view whose phase filter determines that existing elements display as blue solid lines and demolished elements display as red dashed lines.
Demolished walls display in red

Using the Demolish Tool

1 Open the view in which you want to demolish elements.

2 Click Manage tab ➤ Phasing panel ➤ (Demolish).
   The cursor changes to a hammer.

3 Click the elements to demolish.
   Elements that can be demolished highlight as you move the cursor over them.
   The graphical display of demolished elements updates based on the phase filter setting. See Phase Filters on page 879.

4 To exit the Demolish tool, click Manage tab ➤ Selection panel ➤ (Modify).

Related topics

- Demolishing Elements on page 883
- Phase Filters on page 879
- Project Phasing on page 877
Dimensions

Dimensions are view-specific elements that show sizes and distances in a project. There are 2 types of dimensions: temporary and permanent.

Revit Structure places temporary dimensions as you place components. You create permanent dimensions to define a particular size or distance. Each dimension type can be modified, and the component that is dimensioned updates accordingly.

Temporary and permanent dimensions, by default, use the unit settings specified for the project. For permanent dimensions, you can create custom dimension types that override the default unit settings.

Temporary Dimensions

As you create or select geometry, Revit Structure displays temporary dimensions around the component. This is useful for placing the component in the proper place.

Temporary dimensions are created to the nearest perpendicular component and increment by the set value. For example, if you set the snap to 6 cm, the dimension increments in values of 6 cm as you move the component to place it. For information on changing the dimension snap value, see Setting Snap Increments on page 1614.

After you place a component, Revit Structure displays the temporary dimensions. When you place another component, the temporary dimensions for the previous component no longer display. To view the temporary dimensions of a component, click Modify and select the component. Remember, the temporary dimensions are to the nearest component, so the dimensions you see may be different from the original temporary dimensions. If there are dimensions you want displayed at all times, create permanent dimensions.

You can modify temporary dimensions to reference the components you want by moving the witness lines. You can also specify the display and placement of temporary dimensions.

Showing Temporary Dimensions When Multiple Elements are Selected

When you select multiple elements in Revit Structure, temporary dimensions and constraints do not display.

1 Select multiple elements in the drawing area.
2 On the Options Bar, click Activate Dimensions.

**NOTE** System performance can significantly increase when the temporary dimensions and constraints are not displayed.

### Changing Temporary Dimensions to Permanent Dimensions

1. Select a component in the drawing area.
2. Click the dimension symbol that appears near the temporary dimension. You can then modify the properties of the new dimension and change its type.

### Specifying Temporary Dimensions Appearance

1. Click ➤ Options.
2. In the Revit Options on page 1623 dialog, click the Graphics tab.
3. For Temporary Dimension Text Appearance, specify the font size and background.

### Permanent Dimensions

A permanent dimension is a dimension that you specifically place. Permanent dimensions can display in 2 different states: modifiable and non-modifiable. You can modify a permanent dimension when the geometry that it references is selected.

If the geometry that a permanent dimension references is not selected for modification, the dimension displays at its true size and is not available for modification. This is done to eliminate crowding of dimensions when they are not needed for modification.

*Permanent dimension in a non-modifiable state*

When dimensioning components such as doors and windows, you can select either the edge of the opening to dimension or you can select the center of the component to dimension.
NOTE Dimensions are like other annotation elements; they are view-specific. They do not appear in all other views automatically.

Placing Permanent Dimensions

The Dimension tool lets you place permanent dimensions on components in your project or family. You can select from aligned, linear (horizontal or vertical projection of a component), angular, radial, or arc length permanent dimensions.

To view a dimension value after placing it, select one of the components that it references.

Before placing dimensions in Revit Structure, you may want to edit the properties for dimensions and predefine aligned, linear, angular, radial, and arc length dimensions.

Aligned Dimensions

You can place aligned dimensions between 2 or more parallel references or 2 or more points, such as wall ends.

1 Click Annotate tab ➤ Dimension panel ➤ (Aligned).
   Options are Wall centerlines, Wall faces, Center of core, and Faces of core. For example, if you select wall centerlines, the cursor first snaps to the centerline of a wall when you place it over the wall.

2 On the Options Bar, for Pick, select Individual References.

3 Place the cursor at a reference point on an element, such as a wall.
   The reference point highlights if you can place the dimension there.

   TIP You can cycle through the different reference points for walls by pressing Tab. Intersections of internal wall layer boundaries provide references for aligned dimensioning. A gray square reference displays at any intersection of internal wall layers.

4 Click to specify the reference.

5 Place the cursor on the desired location of the next reference point, and click.
   As you move the cursor, a dimension line displays. You can continue to select multiple references, if desired.

6 When you have reached the last reference point, move the cursor away from the last component and click.
   The permanent aligned dimension displays.
Automatic Aligned Dimensions with Walls

With automatic aligned dimensions, you can place a dimension on a wall with one click, eliminating the need to pick all references. You can dimension an entire wall, a wall with intersecting walls, or a wall with openings.

1. Click Annotate tab ➤ Dimension panel ➤ (Aligned).
2. On the Options Bar, for Pick, select Entire Walls.
3. Click Options.
4. In the Auto Dimension Options dialog, select:
   - Openings to dimension a wall and its openings. Select Centers or Widths to set the references for the openings. If you select Centers, the dimension string uses the opening’s center as a reference. If you select Widths, the dimension string measures the width of the opening.
   - Intersecting Walls to dimension a wall and its intersecting walls. When you select a wall to place a dimension, a multi-segmented dimension string displays automatically.
   - Intersecting Grids to dimension a wall and its intersecting grids. When you select a wall to place a dimension, the multi-segmented dimension string displays automatically and references the perpendicular grids that intersect the wall centerline.

   **NOTE** If a grid line is coincident with another wall reference point (for example, the wall end point), then a witness line is not created for the grid. This avoids the creation of zero-length dimension segments.

5. Click OK.
6. Place the cursor on a wall so that the wall highlights, and click. If desired, continue to highlight other walls to add them to the dimension string.
7. Move the cursor away from the walls so that a dimension line displays, and then click to place the dimension.

Aligned Dimensions with Arc Wall Centers

You can place aligned dimensions from the center of arc walls to other walls or lines.

1. Click Annotate tab ➤ Dimension panel ➤ (Aligned).
2. Move the cursor over the arc wall until the center mark (+ symbol) displays. You may need to zoom in to see the + symbol.

   **NOTE** By default, the arc center mark is invisible. You can dimension to it without displaying it by moving the cursor over the arc until the center mark highlights. Arc center marks are only visible in a plan view.

3. Click to start the dimension.
4. Place the dimension between the arc wall center and any other component you wish to dimension.
Linear Dimensions

Linear dimensions are placed between selected points. The dimensions are aligned to the horizontal or vertical axis of the view. The selected points are endpoints of elements or the intersection of references (for example, the join of 2 walls).

You can use arc end points as references when placing linear dimensions.

Horizontal and vertical dimensions are available in the project environment only. You cannot create them in the Family Editor.

The following illustration shows horizontal and vertical linear dimensions on an irregular-shaped building.

Placing Linear Dimensions

1 Click Annotate tab ➤ Dimension panel ➤ (Linear).
2 Place the cursor at a reference point on an element, such as a wall or a line, or at the intersection of references, such as a join between 2 walls.
   The reference point highlights if you can place the dimension there. You can switch through the different reference points of intersections by pressing Tab.
3 Click to specify the reference.
4 Place the cursor on the desired location of the next reference point, and click.
   As you move the cursor, a dimension line appears. You can continue to select multiple references, if desired.
5 After selecting a second reference point, press Spacebar to align the dimension to the vertical or horizontal axis.
6 When you have reached the last reference point, move the cursor away from the last element, and click.
   The dimension displays.
Angular Dimensions

Angular dimensions can be placed on multiple reference points sharing a common intersection. You cannot drag the dimension arc to display a full circle.

1 Click Annotate tab ➤ Dimension panel ➤ (Angular).
2 Place the cursor on a component and click to create a start point for the dimension.

   **TIP** You can switch the reference point for the dimension between a wall face and a wall centerline by pressing Tab.

3 Place the cursor on a component not parallel to the first, and click.

   **TIP** You can select multiple reference points for the dimension. Each element you are dimensioning must pass through a common point. For example, to create a multiple-reference angular dimension among 4 walls, each of the 4 walls must pass through a common point.

4 Drag the cursor to size the angular dimension. Select the sector where you want the dimension to display:

   **Wall join with 4 distinct sectors**

5 When the dimension is sized properly, click to place it.

Radial Dimensions

1 Click Annotate tab ➤ Dimension panel ➤ (Radial).
2 Place the cursor on the arc and click.
   A temporary dimension displays.
TIP You can switch the reference point for the dimension between a wall face and a wall centerline by pressing Tab.

3 Click again to place the permanent dimension.

**Changing Radial Dimension References on Arcs**

You can change the reference of an existing radial dimension from one arc to another, provided the new arc is concentric with the original arc.

1 Select a radial dimension.
   A blue square drag control displays at the end of the dimension.
2 Drag the control to another arc.
   A valid concentric arc highlights when you place the cursor over it.

**Arc Length Dimensions**

You can dimension arc walls to obtain the overall length of the wall.

1 Click Annotate tab ➤ Dimension panel ➤ (Arc Length).
2 On the Options Bar, select a snap option.
   For example, select Wall faces to have the cursor snap to the inside or outside wall face. This aids in selecting the radial point.
3 Place the cursor on the arc, and click to select the radial point.
4 Select the end points of the arc, and move the cursor up and away from the arc wall.
5 Click to place the arc length dimension.

**Baseline and Ordinate Dimensions**

Baseline dimensions are multiple dimensions measured from the same baseline.

Ordinate dimensions measure the perpendicular distance from an origin point called the datum to an element. These dimensions prevent escalating errors by maintaining accurate offsets of the features from the datum.
You can create baseline and ordinate dimensions for linear dimension styles. Linear dimension styles include aligned, horizontal, and vertical dimensions. To create a baseline or ordinate dimension for these linear dimension styles, you need to edit the Dimension String type parameter. Since this is a type parameter, you may want to create a new baseline or ordinate linear dimension style so that any continuous dimensions in the project are not affected when you edit the parameter.

Baseline and ordinate dimensions export to CAD formats.

**IMPORTANT** Arc length dimensions are linear dimensions and have parameters (Dimension String Type and Ordinate Dimension Settings) for creating baseline and ordinate dimensions, but these parameters have no effect on arc length dimensions.

### Creating a Baseline Linear Dimension Style

1. Click Annotate tab ➤ Dimension panel ➤ (Aligned) or (Linear).
   These are both linear dimension styles.

2. Click Modify | Place Dimensions tab ➤ Properties panel ➤ (Type Properties).

3. In the Type Properties dialog, click Duplicate.

4. In the Name dialog, enter a name for the dimension, such as Baseline Linear-3/32” Arial, and then click OK.

5. In the Type Properties dialog, for Dimension String Type, select Baseline, and then click OK.

The new dimension style displays in the Type Selector.

### Creating an Ordinate Linear Dimension Style

1. Click Annotate tab ➤ Dimension panel ➤ (Aligned) or (Linear).
   These are both linear dimension styles.

2. Click Modify | Place Dimensions tab ➤ Properties panel ➤ (Type Properties).

3. In the Type Properties dialog, click Duplicate.

4. In the Name dialog, enter a name for the dimension, such as Ordinate Linear-3/32” Arial, and then click OK.

5. In the Type Properties dialog, for Dimension String Type, select Ordinate.

6. For Ordinate Dimension Settings, click Edit.

7. In the Ordinate Dimension Settings dialog, specify settings for the ordinate dimension.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Orientation</td>
<td>Specify where to align the dimension text, with the witness line or the dimension line. This setting is dis-</td>
</tr>
</tbody>
</table>
### Setting | Description
--- | ---
| | abled when the Read Convention parameter is Horizontal.
| Text Position | Specify the text position, at the end of the witness line or next to the witness line.
| Origin Visibility | Specify visibility of the origin witness line for the ordinate dimension (this is the first witness line in the string). Options are:
- **None.** Does not show the origin witness line, tick mark, or text (0'-0”).
- **Witness Line with Text.** Shows the origin witness line, tick mark and text (0'-0”).
- **Witness Line only.** Shows the origin witness line and tick mark.
| Origin Tick Mark | Specify the tick mark for the dimension origin. This setting is disabled when Origin Visibility is set to None.
| Dimension Line Style | Specify the dimension line style. Options are:
- **Continuous.** Displays the dimension line as continuous.
- **Segmented.** Segments the dimension line. Specify the length of the segments with the Length of Segment settings.
- **None.** Shows no dimension line. When you select the dimension line in the drawing area, a hidden line displays.
| Length of Segments | Specify the dimension line segment length. This setting is enabled when Dimension Line Style is Segmented.

8 Click OK twice.

The new dimension style displays in the Type Selector.

### Placing Baseline Dimensions

1 Click Annotate tab ➤ Dimension panel ➤ ![Aligned](image-url) (Aligned) or ![Linear](image-url) (Linear).
2 In the **Type Selector**, select a baseline dimension style.
   For more information, see [Creating a Baseline Linear Dimension Style](#) on page 894.
3 In the drawing area, select the first point (origin) for the dimension.
4 Continue to select the necessary reference points.
5 When you have reached the last reference point, move the cursor away from the last element, and click.
   The baseline dimension displays.
6 To customize display of the baseline dimension:
   a  In the drawing area, select the dimension.
   b  Click the flip controls ( ▲ ) to flip the dimension direction.
   c  Press Spacebar to change the baseline dimension stacking. You can use the spacebar to change the baseline dimension stacking before or after placement.

Placing Ordinate Dimensions

1 Click Annotate tab ➤ Dimension panel ➤ (Aligned) or (Linear).
2 In the Type Selector, select an ordinate dimension style.
   For more information, see Creating an Ordinate Linear Dimension Style on page 894.
3 In the drawing area, select the first point (origin) for the dimension.
4 Continue to select the necessary reference points.
5 When you have reached the last reference point, move the cursor away from the last element, and click.
   The ordinate dimension displays.

Locking Permanent Dimensions

When you place permanent linear or angular dimensions, a lock control appears with the dimension. Locks appear when you select

- A permanent dimension.
- An element constrained by a dimension. An element is constrained if it is referenced by a locked segment or is a reference in an equality dimension.

If the lock is unlocked, the dimension value is modifiable and the element that it references is free to move in any direction. You can click the dimension value and change it.

If the lock is locked, the dimension value is fixed, preventing any change to the distance between its referenced components. You cannot click the dimension value to change it.
Clicking on the lock switches it between the locked and unlocked states. Once a dimension is locked, you must unlock it to change its value.

**TIP** You can also switch the locked/unlocked state of the lock by right-clicking on it and choosing Toggle.

Also see Applying Constraints with Dimensions on page 1537.

**Anchoring Elements Referenced in Multi-Segmented Dimensions**

In a multi-segmented, equality constrained dimension, you can use the anchor symbol to designate the anchored element. The element that is anchored remains stationary while you move other elements in a dimension.

1. **Create** a multi-segmented dimension.

2. In the drawing area select the dimension, and click the Dimension Equality symbol ( ) to make the dimension equally constrained.

3. Select any element the dimension references, except the one you want to anchor.
4 Click and hold the anchor symbol. A witness line appears for the anchor.
5 Drag the anchor symbol to the element you want to anchor.
6 Move any of the unanchored elements referenced in the dimension.
   The element accompanied by the anchor does not move.

**NOTE** If you select the element the anchor is currently attached to, this also moves the position of the anchor.

### Distinguishing a Dimension Lock’s Related Element

In large-scale projects with many dimensions and alignments, it can be difficult to distinguish which dimension locks refer to which elements.

1 In the drawing area, right-click a dimension lock.
2 Select Show Related from the shortcut menu.
   The appropriate element highlights and a dialog identifies the element.
3 Click the arrow buttons to switch between the elements constrained by the lock.

### Overriding Dimension Text

You can add supplemental text above, below, to the left of, or to the right of a permanent dimension value.

1 In the drawing area, select the dimension you want to edit.
2 Click the dimension value.
3 In the Dimension Text dialog, for Dimension Value, select Use Actual Value.
   Enter the text you want to display in the Above, Below, Prefix, and/or Suffix text fields.

**NOTE** You do not need to enter text in all fields, only those you require.

4 Click OK.
Replacing Permanent Dimension Values with Text

You can replace a permanent dimension value with text, as shown in the following image.

You can also replace a dimension value with variations within a class of element, as shown below.

You cannot replace a permanent dimension value with a numeric value.

1 In the drawing area, select the dimension you want to edit.
2 Click the dimension value.
3 In the Dimension Text dialog, for Dimension Value, select Replace With Text.
4 In the text box, enter the text you want to display in place of the dimension value.
5 Optionally, enter text in the Above and/or Below text fields.
6 Click OK.

Related topics
- Overriding Dimension Text on page 898
- Modifying Dimensions on page 912
- Dimension Properties on page 916

Creating Custom Dimension Units

When you create a project, by default Revit Structure assigns specific units and accuracy to dimension styles based on the project units settings.

You can create custom dimension types that override these default settings. For each custom dimension type you create, you can define the unit and accuracy settings. For example, in a project that uses Imperial units, you can create a dimension type that displays a metric unit. You can also create dimension types that have different rounding options so, for example, you can show dimensions that round to 1/8" in a plan view and 1/32" in a detail view.

To create a custom dimension type:

1 Click Annotate tab ➤ Dimension panel.
2 On the Dimensions panel drop-down, click the appropriate dimension tool. For example, if you want to apply custom accuracy to a linear dimension, click Linear Dimension Types.
3 In the Type Properties dialog, click Duplicate. Enter a name for the new dimension style, and click OK.
4 Under Text, for Units Format, click the value button.
5 In the Format dialog, clear Use project settings.
6 For Units, select an appropriate unit.
7 For Rounding, select an appropriate value. If you select Custom, enter a value for Rounding increment.
8 If applicable, select a Unit symbol.
9 Click OK twice.

Dimensioning to Core in Compound Structures

When constructing a compound wall with inserts, builders often want to know the dimensions of unfinished structural openings for the inserts. You can dimension a structural opening by choosing references on the outer boundary of the core layer in the wall. The structural layer is typically within the core boundary of a wall.

Inserts can be perpendicular or non-perpendicular to the core boundary.

NOTE If you want to dimension to the structural layer of a wall at an insert, be sure that the cut plane offset of the view is set at or lower than the cut plane offset of the insert family.
**Dimensioning to Core**

1. Draw a compound wall and place an insert into the wall.

2. On the View Control Bar, click ▶ (Detail Level) ➤ Fine so that you can view the layers of the wall.

3. Select the wall and on the Properties palette, click ✉ (Edit Type).

4. For Wrapping at Inserts, select Both.

5. Click OK.

6. Click Annotate tab ➤ Dimension panel ➤ (Aligned).

7. On the Options Bar, select Faces of core.

8. Select the outer core boundary as the reference for the dimension.

   *Dimension references for perpendicular insert*

   ![Diagram of perpendicular insert](image)

   *Dimension references for non-perpendicular insert*

   ![Diagram of non-perpendicular insert](image)

---

**Applying a Label to Dimensions**

In the Family Editor or Conceptual Design Environment, you can edit a permanent dimension in the drawing or on the Options Bar.

In the drawing, select the permanent dimension and do one of the following:

- Right-click and click Label, and then select an existing parameter or Add Parameter. See Creating Parameters on page 692.
Spot Dimensions

Spot dimensions can be placed as spot elevations, spot coordinates, or spot slopes. Spot elevations can display the elevation of a selected point or the top and bottom elevation of an element. Spot coordinates display the North/South, East/West coordinates of a selected point, and can also display the elevation of the selected point. Spot slopes can display the slope at a specific point on a face or an edge of an element.
Spot Elevations

Spot elevations display the actual elevation of a selected point. Spot elevations can also display the top and/or bottom elevation of elements with a thickness. Top and bottom elevations are available for elements in plan views.

You can place spot elevations on non-horizontal surfaces and non-planar edges. You can place them in plan, elevation, and 3D views. Spot elevations are typically used to obtain a point of elevation for ramps, roads, toposurfaces, and stair landings.

Placing a Spot Elevation Dimension

1. Click Annotate tab ➤ Dimension panel ➤ (Spot Elevation).
2. In the Type Selector, select the type of spot elevation to place.
3. On the Options Bar:
   a. Select or clear Leader.
   b. If Leader is selected, optionally select Shoulder to add a bend to the spot elevation leader.
c If you are placing a relative spot elevation, select a level for Relative Base.

d Select an option for Display Elevations (enabled when you place a spot elevation in a plan view):
- Actual (Selected) Elevation displays the elevation of the selected point on the element.
- Top Elevation displays the top elevation of the element.
- Bottom Elevation displays the bottom elevation of the element.
- Top & Bottom Elevations displays the top and bottom elevations of the element.

4 Select an edge of an element, or select a point on a toposurface.
When you move the cursor over an element on which you can place the spot elevation, the value of the spot elevation displays in the drawing area.

5 If you are placing a spot elevation:
- without a leader, click to place it.
- with a leader, move the cursor away from the element, and click to place the spot elevation.
- with a leader and a shoulder, move the cursor away from the element. Click once to place the leader shoulder. Move the cursor again and then click to place the spot elevation.

6 To finish, press Esc twice.
If you select a spot elevation after placing it, you can move it using the drag controls. If you delete an element that is referenced or turn off its visibility, the spot elevation is removed.

Related topics
- Adding Supplementary Text to Spot Elevation Dimensions on page 904
- Changing Elevation Reporting on page 905
- Changing Spot Elevation Arrowhead Style on page 905
- Dimension Properties on page 916

Adding Supplementary Text to Spot Elevation Dimensions

You can add supplementary text to spot dimensions. By editing the type parameters for the spot elevation, you can add text for the elevation indicator, top indicator, and bottom indicator. This text can appear as a suffix or a prefix to the spot elevation value.

In addition, you can edit the instance parameters for a spot elevation to add supplementary prefix and/or suffix text to the single (or upper) value and the lower value.

Order of appearance for text relative to the spot elevation value:
- Single/Upper Value Prefix or Lower Value Prefix (instance parameters)
Top Indicator or Bottom Indicator when set as Prefix (type parameters)
- Elevation Indicator when set as Prefix (type parameter)
- **Spot elevation value**
- Elevation Indicator when set as Suffix (type parameter)
- Top Indicator or Bottom Indicator when set as Suffix (type parameters)
- Single/Upper Value Suffix or Lower Value Suffix (instance parameters)

For more information, see *Spot Elevation Type Properties* on page 919 and *Spot Elevation Instance Properties* on page 921.

**Changing Elevation Reporting**

A spot elevation can report elevations relative to project origin, shared origin, or a specified level.

1. Place a spot elevation, and then select it.
2. On the Properties palette, click (Edit Type).
3. Under Text, specify a value for Elevation Origin. For more information about the values, see *Spot Elevation Type Properties* on page 919.
4. If you selected Relative, click OK and, on the Properties palette, select the value for Relative Base.

**Changing Spot Elevation Arrowhead Style**

1. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Arrowheads).
2. In the Type Properties dialog, for Type, select Filled Elevation Target 3/16”.
3. Under Graphics, for Arrow Style, select Elevation Target.
4. If desired, select Fill Tick. If you select this option, the arrowhead looks like the filled elevation symbol: . If you do not select this option, the arrowhead is a crosshairs symbol: .
5. Click OK.
6. Place a spot elevation.
7. Select the spot elevation, and on the Properties palette, click (Edit Type).
8. For Type, select Target Leader (Project).
9. Under Graphics, for Leader Arrowhead, select Filled Elevation Target 3/16”.

**NOTE** The Filled Elevation Target type is available for other annotations, such as text note leaders.

10. Click OK.

**Spot Coordinates**

Spot coordinates report the North/South and East/West coordinates of points in a project.
You can also display the elevation of the selected point and indicator text in addition to the coordinates.

<table>
<thead>
<tr>
<th>N/S -348</th>
</tr>
</thead>
<tbody>
<tr>
<td>E/W 680</td>
</tr>
<tr>
<td>Elev: 1600</td>
</tr>
</tbody>
</table>

Coordinates are reported with respect to the shared coordinate system.

Spot coordinates can be placed on floors, walls, toposurfaces, and boundary lines. You can also place spot coordinates on non-horizontal surfaces and non-planar edges. When you display the elevation of the selected point in addition to the spot coordinates, you can place the spot coordinate in the same locations you can place a spot elevation.

To place spot coordinates:

1. Click Annotate tab ➤ Dimension panel ➤ (Spot Coordinate).
2. In the Type Selector, select the type of spot coordinate to place.
3. On the Options Bar, select or clear Leader. If Leader is selected, optionally select Shoulder in order to add a bend to the spot elevation leader.
4. If you want the elevation to display in addition to the spot coordinates:
   a. On the Properties palette, click (Edit Type).
   b. Under Text, select Include Elevation.
5. Select an edge of an element or a point on a toposurface.
   When you move the cursor over an element on which you can place the spot coordinate, the spot coordinate value displays in the drawing area.
6. If you are placing a spot coordinate:
   ■ without a leader, click to place it.
   ■ with a leader, move the cursor away from the element, and click to place the spot coordinate.
   ■ with a leader and a shoulder, move the cursor away from the element. Click once to place the leader shoulder. Move the cursor again and then click to place the spot coordinate.
7. To finish, press Esc twice.
If you select a spot coordinate after placing it, you can move it using the drag controls. If you delete an element that is referenced or turn off its visibility, the spot coordinate is removed.

To modify the appearance of the spot elevation, select it and modify its properties.

Adding Supplementary Text to Spot Coordinate Dimensions

You can add supplementary text to spot dimensions. By editing the type parameters for the spot coordinate, you can add text for the North/South indicator, East/West indicator, and elevation indicator. This text can appear as a suffix or a prefix to the spot coordinate values.

N/S -348  
E/W 680  
Elev: 1600

In addition, you can edit the instance parameters for a spot coordinate to add supplementary prefix and/or suffix text to the top, bottom, and elevation values.

Order of appearance for text relative to the top spot coordinate value:
- Top Value Prefix (instance parameter)
- Indicator when set as Prefix (type parameter)
- **Top spot coordinate value**
- Indicator when set as Suffix (type parameter)
- Top Value Suffix (instance parameter)

Order of appearance for text relative to the bottom spot coordinate value:
- Bottom Value Prefix (instance parameter)
- Indicator when set as Prefix (type parameter)
- **Bottom spot coordinate value**
- Indicator when set as Suffix (type parameter)
- Bottom Value Suffix (instance parameter)

Order of appearance for text relative to the elevation spot coordinate value:
- Elevation Value Prefix (instance parameter)
- Elevation Indicator when set as Prefix (type parameter)
- **Elevation spot coordinate value**
- Elevation Indicator when set as Suffix (type parameter)
- Elevation Value Suffix (instance parameter)
For more information, see Spot Coordinate Type Properties on page 922 and Spot Coordinate Instance Properties on page 924.

Spot Slopes

A spot slope displays the slope at a specific point on a face or an edge of a model element. You can place spot slopes in plan views, elevation views, and section views. The following illustration show the 2 spot slope types.

Objects using spot slopes most commonly include roofs, beams, and piping.

Placing a Spot Slope Dimension

1. Click Annotate tab ➤ Dimension panel ➤ (Spot Slope).
2. In the Type Selector, select the type of spot slope to place.
3. (Optional) Change the following on the Options Bar:
   a. For Slope Representation (enabled in an elevation or section view), select Arrow or Triangle.
   b. Enter a value for Offset from Reference.
      This value moves the spot slope closer to or further from the reference.
4. Click the edge or slope where you will place the spot slope.
5. Click to place the spot slope, which can be either above or below the slope.
   When you move the cursor over an element on which you can place the spot slope, the value of the spot slope displays in the drawing area.

6. When you are placing a spot slope, you can also do the following:
   ■ Click the flip controls ( ) to flip the spot slope dimension direction.
The slope representation has two representations: arrow or triangle. The same information exists in both representations although it displays differently. The triangle is not available for use in plan views.

Spot slope with triangle representation

7 To finish, press Esc twice.

Related topics
- Spot Dimensions on page 902
- Dimension Properties on page 916

Listening Dimensions

When you are sketching, you can explicitly enter a value for the sketch line by typing a number, called a listening dimension, after you begin the sketch line.

Typically, listening dimensions specify linear dimensions such as length of a line, length of a chord (when drawing the second point of a 3-point arc), length of a radius (when drawing an arc, circle, or polygon). If there is no linear dimension, you can enter an angular dimension, if applicable.

Listening dimensions are not available for some elements, such as splines and rectangles.

Use listening dimensions to specify line length

1 Begin sketching a line.

2 Type the length value (for 8 feet 6 inches, type 8 6). When you type a number, a text box appears, as shown.

3 Press Enter.
The sketch line is drawn the specified length.
Dimension Witness Lines

You can move witness lines to new references for temporary and permanent dimensions. You can also control the gap between the witness line and the element for permanent dimensions. Properties for witness lines are included with the type properties for permanent dimensions.

Moving the Witness Line for Temporary Dimensions

1 Select an element.
2 Do one of the following:
   ■ Drag the control (blue square) to a different reference.
   ■ Right-click the witness line control, and click Move Witness Line. You can then move the witness line to a new reference.

NOTE Modifications to temporary dimension witness lines are saved on a per-session basis. For example, if a default temporary dimension measures the distance between the centers of two walls and the witness line is moved to measure to the faces of the walls, subsequent selection of the wall preserves the location of the edited witness line for that session.

Moving the Witness Line for Permanent Dimensions

1 Select a permanent dimension.
2 Right-click the blue square control in the middle of the witness line, and click Move Witness Line.
3 Drag the witness line to the element to be referenced.

Related topics
   ■ Moving the Witness Line for Temporary Dimensions on page 910
   ■ Controlling Witness Line Gaps for Permanent Dimensions on page 911
Controlling Witness Line Gaps for Permanent Dimensions

By selecting a linear dimension, you can control its distance from the element it is referencing and the reference point for the dimension.

1. Create a linear dimension between 2 or more elements (for example, between 2 walls).
2. Select a dimension line.
   Blue controls display on the witness lines.

3. Place the cursor on one of the blue square controls at the end of the witness line, and drag to resize the gap between the witness line and the element. If desired, select other controls to resize the dimension gap. Parallel dimension lines snap to the same gaps.

   **TIP** As you move the element referenced by the dimension line, the distance of the gap remains constant.

Related topics
- Moving the Witness Line for Permanent Dimensions on page 910
- Adding Witness Lines to a Permanent Dimension on page 911
- Deleting Witness Lines on page 912

Adding Witness Lines to a Permanent Dimension

1. Select the dimension.

2. Click Modify | Dimensions tab ➤ Witness Lines panel ➤ (Edit Witness Lines).

3. Click the element for which you want to add a new witness line, and then click in the drawing area.

4. When you are finished, press Esc.
Deleting Witness Lines

1 Select a permanent dimension.
2 Right-click the blue square control in the middle of a witness line, and click Delete Witness Line.

Modifying Dimensions

Revit Structure gives you the capability to customize the look of dimensions.

Changing a Dimension Value

1 Select an element that the dimension references.
2 Click the dimension value.
   If the dimension is locked, the lock control appears next to it. Click the lock control to unlock the dimension so that you can change it.
3 In the edit box, type a new value for the dimension, and press Enter.
   The element moves to satisfy the new dimension requirement.

Moving Dimension Line Text

When dimensions display close together, making them difficult to read, you can drag text away from the dimension line to improve clarity. Dimension text controls are available only for permanent dimensions.

1 Select a dimension.

2 Place the cursor on the blue handle below the dimension text, and drag the text to a new location.
   If the dimension text crosses the path of one of the witness lines of the dimension, and it does not cross the center of the dimension segment it is on, an arc leader line displays. You can turn off the leader by clearing Leader on the Options Bar.
3 To return the dimension text to its original position, drag the handle back toward the dimension line, and it snaps to its original position.

### Changing the Dimension Line Tick Mark

You can change the tick mark that displays at the ends of the dimension line.

1. In the drawing area, select a dimension.

2. On the Properties palette, click \( \text{Edit Type} \).  

3. In the Type Properties dialog, under Graphics, select a value for Tick Mark, and then click OK.

If you select an arrow tick mark, see Controlling the Display Behavior of Dimension Arrows on page 913 for information on the behavior of arrow type tick marks.

### Controlling the Display Behavior of Dimension Arrows

When a dimension segment is too small to accommodate arrow tick marks for dimension lines on the interior of the dimension line, the arrows automatically flip to the exterior of the dimension line. This occurs for linear, angular, and radial dimensions. For radial dimensions, arrows flip when the dimension line (the radius) is shorter than the length of the arrow.

The following image shows 2 dimensions with arrow tick marks. The larger dimension shows arrows displayed on the interior of the dimension line when the line is large enough to accommodate them. The smaller dimension shows dimension arrows on the exterior of the dimension line when the line is too small to accommodate them.
In addition, multi-segment dimension lines recognize when adjacent segments are too small for arrows to fit. When this occurs, the ends of the short-segment string flip, and the inner witness lines display the interior tick mark type designated in the dimension properties. In the following image, the dimension arrows flip to the exterior of the dimension line and the witness lines display the designated tick mark (diagonal).

For information on changing the tick mark for a dimension line, see Changing the Dimension Line Tick Mark on page 913.

**To control the display behavior of dimension arrow tick marks:**

1. In the drawing area, select a dimension.

2. On the Properties palette, click (Edit Type).
3 In the Type Properties dialog, under Graphics, edit the following:

- **Flipped Dimension Line Extension**: when dimension arrows flip, this controls the length of the dimension line beyond the flipped arrows. Length is measured from the end of the arrow head.

- **Interior Tick Mark**: designates the tick mark display for inner witness lines when adjacent segments of a dimension line are too small for arrows to fit. When this occurs, the ends of the short-segment string flip, and the inner witness lines display the designated interior tick mark.

**NOTE** These parameters are only enabled when the tick mark type is an arrow.

4 Click OK.

---

**Rotating Spot Coordinates and Spot Elevations with Components**

When spot elevations or spot coordinates are applied to line-based host components, you can specify that they orient to the component and not the horizontal default. Line-based host components are those elements placed by defining a start point and an end point, such as structural walls, walls, beams, braces, and trusses. The Rotate with Component parameter must be selected to enable this tool.

**To set spot coordinates and spot elevations to Rotate with Component:**

1 In the drawing area, select the spot dimension (coordinate or elevation).

2 On the Properties palette, click (Edit Type).

3 In the Type Properties dialog, under Constraints, select Rotate with Component.

4 Click OK.

The spot coordinate will not rotate with a component as shown in the images below.

**Spot coordinate on a beam**
Dimension Properties

You can change many properties of permanent and spot dimensions.

NOTE Permanent dimension type properties include properties for witness lines.

Modifying Permanent or Spot Dimension Properties

1. In a project view, select a permanent or spot dimension.
2. On the Properties palette, edit the instance properties.
3. To edit type properties, click (Edit Type).

NOTE Changes made to type properties affect all permanent dimensions or spot dimensions of that type in the project. You can click Duplicate to create a new permanent or spot dimension type.

4. When you are finished, click OK.

Related topics

- Modifying Dimensions on page 912
- Dimension Properties on page 916
### Permanent Dimension Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Dimension String Type</td>
<td>Specify the formatting method for a string of dimensions. This parameter is available for linear dimension styles.</td>
</tr>
</tbody>
</table>

**NOTE** Arc length dimensions are linear dimensions and have parameters (Dimension String Type and Ordinate Dimension Settings) for creating baseline and ordinate dimensions, but these parameters have no effect on arc length dimensions.

Options include:
- **Continuous.** Places multiple dimensions end to end.
- **Baseline.** Places stacked dimensions measured from the same baseline.
- **Ordinate.** Places a dimension string with values measured from the dimension origin.

<table>
<thead>
<tr>
<th>Tick Mark</th>
<th>The name of the tick mark style.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Weight</td>
<td>Sets the line weight number that designates thickness of the dimension line. You can select from a list of values defined in Revit Structure or define your own. You can change the definition of the line weights by clicking Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Line Weights). See Line Weights on page 1603.</td>
</tr>
<tr>
<td>Tick Mark Line Weight</td>
<td>Sets the line weight that designates thickness of the tick mark. You can select from a list of values defined in Revit Structure or define your own.</td>
</tr>
<tr>
<td>Dimension Line Extension</td>
<td>Extends the dimension line beyond the intersection of the witness lines to the specified value. When you set this value, this is the size at which the dimension line plots, if you are printing at 100 percent.</td>
</tr>
<tr>
<td>Flipped Dimension Line Extension</td>
<td>Controls the extent of the dimension line beyond the flipped arrow if the arrow flips on the ends of the dimension string. This parameter is only enabled when the tick mark type parameter is set to an arrow type. See Changing the Dimension Line Tick Mark on page 913.</td>
</tr>
<tr>
<td>Witness Line Control</td>
<td>Switches between the fixed gap functionality and the fixed dimension line functionality.</td>
</tr>
<tr>
<td>Witness Line Length</td>
<td>If Witness Line Control is set to Fixed to Dimension Line, this parameter becomes available. Specifies the length of all witness lines in the dimensions. When you set this value, this is the size at which the witness line plots, if you are printing at 100 percent.</td>
</tr>
<tr>
<td>Witness Line Gap to Element</td>
<td>If Witness Line Control is set to Gap to Element, this parameter sets the distance between the witness line and element being dimensioned.</td>
</tr>
<tr>
<td>Witness Line Extension</td>
<td>Sets the extension of a witness line beyond the tick mark. When you set this value, this is the size at which the witness line plots, if you are printing at 100 percent.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Centerline Symbol</td>
<td>You can select any of the annotations symbols loaded in the project. The centerline symbol appears above the witness lines that reference the centerlines of family instances and walls. If the witness line does not reference a center plane, you cannot place a centerline symbol above it.</td>
</tr>
<tr>
<td>Centerline Pattern</td>
<td>Changes the line pattern of the witness lines of the dimension, if the dimension references are the centerlines of family instances and walls. If the references are not at the centerline, this parameter does not affect the witness line pattern.</td>
</tr>
<tr>
<td>Centerline Tick Mark</td>
<td>Changes the tick mark at the ends of the centerline of a dimension.</td>
</tr>
<tr>
<td>Interior Tick Mark</td>
<td>Designates the tick mark display for inner witness lines when adjacent segments of a dimension line are too small for arrows to fit. When this occurs, the ends of the short-segment string flip, and the inner witness lines display the designated interior tick mark. This parameter is only enabled when the tick mark type parameter is set to an arrow type. See Changing the Dimension Line Tick Mark on page 913.</td>
</tr>
<tr>
<td>Ordinate Dimension Settings</td>
<td>Specify settings for ordinate dimensions. This parameter is available when the Dimension String Type parameter is set to Ordinate. For more information, see Creating an Ordinate Linear Dimension Style on page 894.</td>
</tr>
<tr>
<td>Color</td>
<td>Sets the color of dimension lines. You can select from a list of colors defined in Revit Structure or define your own. The default value is black.</td>
</tr>
<tr>
<td>Dimension Line Snap Distance</td>
<td>To use this parameter, set the Witness Line Control parameter to Fixed to Dimension Line. With these parameters set, additional snapping is available that aids in stacking linear dimensions at even intervals. This value should be greater than the distance between the text and the dimension line, plus the height of the text.</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td></td>
</tr>
<tr>
<td>Width Factor</td>
<td>Specify a ratio to define the elongation of the text string. A value of 1.0 has no elongation.</td>
</tr>
<tr>
<td>Underline</td>
<td>Underlines the permanent dimension value and text.</td>
</tr>
<tr>
<td>Italic</td>
<td>Applies italic formatting to the permanent dimension value and text.</td>
</tr>
<tr>
<td>Bold</td>
<td>Applies bold formatting to the permanent dimension value and text.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Specify the size of the typeface for the dimension.</td>
</tr>
<tr>
<td>Text Offset</td>
<td>Specify the offset of the text from the dimension line.</td>
</tr>
<tr>
<td>Read Convention</td>
<td>Specify the read convention for the dimension text.</td>
</tr>
<tr>
<td>Text Font</td>
<td>Sets the Microsoft® True Type fonts for the dimensions.</td>
</tr>
<tr>
<td>Text Background</td>
<td>If you set the value to opaque, the dimension text is surrounded by a box that overlaps any geometry or text behind it in the view. If you set the value to transparent, the box disappears and everything not overlapped by the dimension text is visible.</td>
</tr>
</tbody>
</table>
Click the button to open the Format dialog. You can then set the format of the units with the dimension. See Setting Project Units on page 1613.

Place a dimension whose witness lines reference the same insert (window, door, or opening) in a plan view. If you select this parameter, the dimension includes a label that shows the height of the opening for the instance. The value appears below the dimension value you initially placed.

Shows or hides the radial dimension center mark.

Sets the size of the radial dimension center mark. This property is enabled when Center Marks is selected.

Shows or hides prefix (R) for radial dimensions.

Specify an offset value for successive baseline dimensions. This parameter is available when the Dimension String Type type parameter is set to Baseline.

All linear and angular continuous dimensions have an Equality Display property. It is set to EQ by default if there is an equality constraint and to Value by default otherwise. For more information about this property see Changing the EQ Label to the Dimension Value on page 1538.

This property is not available when the Dimension String Type type parameter is Baseline or Ordinate.

When selected, the spot elevation rotates with the component.

Sets the appearance of the leader arrowhead. The value None removes the arrowhead. See Specifying Arrowhead Styles on page 1609.

Sets the weight of the leader line. The higher the value, the thicker the line.

Sets the arrowhead line weight. The higher the value, the thicker the arrowhead line.

Click the button to open the color picker. Sets the color of the spot elevation.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbol</td>
<td>Changes the look of the symbol head with the spot elevation.</td>
</tr>
<tr>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Width Factor</td>
<td>Specify a ratio to define the elongation of the text string. A value of 1.0 has no elongation.</td>
</tr>
<tr>
<td>Underline</td>
<td>Underlines the spot elevation value and text.</td>
</tr>
<tr>
<td>Italic</td>
<td>Applies italic formatting to the spot elevation value and text.</td>
</tr>
<tr>
<td>Bold</td>
<td>Applies bold formatting to the spot elevation value and text.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Sets the size of the elevation text.</td>
</tr>
<tr>
<td>Text Offset from Leader</td>
<td>Offsets the text from the leader line.</td>
</tr>
<tr>
<td>Text Font</td>
<td>Sets the font for the elevation text.</td>
</tr>
<tr>
<td>Text Background</td>
<td>If you set the value to opaque, the dimension text is surrounded by a box that overlaps any geometry or text behind it in the view. If you set the value to transparent, the box disappears and everything not overlapped by the dimension text is visible.</td>
</tr>
<tr>
<td>Units Format</td>
<td>Click the button to open the Format dialog. Clear the Use Project Settings option and set the appropriate values. See Setting Project Units on page 1613.</td>
</tr>
<tr>
<td>Text Offset from Symbol</td>
<td>Offsets the text from the symbol. Positive values move text toward the leader and negative values move text away from the leader.</td>
</tr>
<tr>
<td>Text Orientation</td>
<td>Changes the position of the text. Specify horizontal</td>
</tr>
</tbody>
</table>

<p>| <img src="image1.png" alt="Diagram" /> |
| <img src="image2.png" alt="Diagram" /> |
| <img src="image3.png" alt="Diagram" /> |</p>
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Location</td>
<td>Specify the position of the spot elevation with respect to the leader. Options include Above Leader, Below Leader, or In-line with Leader. When you specify In-line with Leader, the elevation symbol does not display for the spot elevation. In addition, the Text Offset from Leader, Text Offset from Symbol, and Symbol properties are disabled.</td>
</tr>
<tr>
<td>Elevation Indicator</td>
<td>A text string you enter with the spot elevation. Can be displayed as a prefix or suffix.</td>
</tr>
<tr>
<td>Elevation Origin</td>
<td>If the origin value is set to Project, then the elevation reported is with respect to the project origin. If set to Shared, then the elevation reported is with respect to the shared origin. If the base value is set to Relative, then the elevation reported is with respect to the level in the Relative Base instance parameter. You can change the shared origin by relocating the project. See Relocating and Mirroring a Project on page 1269.</td>
</tr>
<tr>
<td>Elevation Indicator as Prefix/Suffix</td>
<td>Specify the placement of the elevation indicator as a prefix or a suffix.</td>
</tr>
<tr>
<td>Top Indicator</td>
<td>When you set the Display Elevations instance parameter to Top &amp; Bottom Elevations or Top Elevation, you can enter text to indicate that this value represents the top elevation of the element. This text can be displayed as either a prefix or a suffix to the elevation value.</td>
</tr>
<tr>
<td>Bottom Indicator</td>
<td>When you specify the Display Elevations instance parameter to Top &amp; Bottom Elevations or Bottom Elevation, you can enter text to indicate that this value represents the bottom elevation of the element. This text can be displayed as either a prefix or a suffix to the elevation value.</td>
</tr>
<tr>
<td>Top Indicator as Prefix/Suffix</td>
<td>Specify placement of the top indicator as a prefix or a suffix.</td>
</tr>
<tr>
<td>Bottom Indicator as Prefix/Suffix</td>
<td>Specify placement of the bottom indicator as a prefix or a suffix.</td>
</tr>
</tbody>
</table>

**Spot Elevation Instance Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Relative Base</td>
<td>The level from which the elevation is reported. This property can be edited for relative spot elevations, and is a read-only value for project spot elevations.</td>
</tr>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Leader</td>
<td>If selected, the spot elevation includes a leader line. When not selected, no leader line displays.</td>
</tr>
<tr>
<td>Leader Shoulder</td>
<td>When Leader is selected, you can add a shoulder (a bend) to the leader line.</td>
</tr>
<tr>
<td>Text</td>
<td></td>
</tr>
</tbody>
</table>
**Display Elevations**

- **Actual (Selected) Elevation.** Displays the elevation of the selected point on the element.
- **Top Elevation.** Displays the top elevation of the element.
- **Bottom Elevation.** Displays the bottom elevation of the element.
- **Top & Bottom Elevation.** Displays the top and bottom elevations of the element.

This parameter is enabled when you place a spot elevation in a plan view.

- **Single/Upper Value**
  - The actual elevation of the selected point or the upper elevation value. This is a read-only value.
- **Single/Upper Value Prefix**
  - Add prefix text to the single or upper dimension value.
- **Single/Upper Value Suffix**
  - Add suffix text to the single or upper dimension value.
- **Lower Value**
  - The actual lower elevation value reported. This is a read-only value.
- **Lower Value Prefix**
  - Add prefix text to the lower dimension value.
- **Lower Value Suffix**
  - Add suffix text to the lower dimension value.

**Spot Coordinate Type Properties**

You can specify various parameters to change the appearance of the spot coordinate.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Rotate with Component</td>
<td>When selected, the spot coordinate rotates with the component.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Leader Arrowhead</td>
<td>Sets the appearance of the leader arrowhead. The value None removes the arrowhead. To define an arrowhead, see Specifying Arrowhead Styles on page 1609.</td>
</tr>
<tr>
<td>Leader Line Weight</td>
<td>Sets the weight of the leader line. The higher the value, the thicker the line.</td>
</tr>
<tr>
<td>Leader Arrowhead Line Weight</td>
<td>Sets the arrowhead line weight. The higher the value, the thicker the arrowhead line.</td>
</tr>
<tr>
<td>Color</td>
<td>Sets the color of the spot coordinate. Click the button to open the color picker.</td>
</tr>
<tr>
<td>Symbol</td>
<td>Changes the look of the symbol head with the spot coordinate.</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td></td>
</tr>
<tr>
<td>Width Factor</td>
<td>Specify a ratio to define the elongation of the text string. A value of 1.0 has no elongation.</td>
</tr>
<tr>
<td>Underline</td>
<td>Underlines the spot coordinate value and text.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Italic</td>
<td>Applies italic formatting to the spot coordinate value and text.</td>
</tr>
<tr>
<td>Bold</td>
<td>Applies bold formatting to the spot coordinate value and text.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Sets the size of the elevation text.</td>
</tr>
<tr>
<td>Text Offset from Leader</td>
<td>Offsets the text from the leader line.</td>
</tr>
<tr>
<td>Text Font</td>
<td>Sets the font for the elevation text.</td>
</tr>
<tr>
<td>Text Background</td>
<td>Sets the background for the text. With opaque, the background of the text itself covers objects behind it. Transparent allows you to see objects behind the text.</td>
</tr>
<tr>
<td>Units Format</td>
<td>Click the button to open the Format dialog. Clear the Use Project Settings option, and set the appropriate values. See Setting Project Units on page 1613.</td>
</tr>
<tr>
<td>Text Offset from Symbol</td>
<td>Offsets the text away from the symbol.</td>
</tr>
<tr>
<td>Text Orientation</td>
<td>Changes the position of the text to read horizontally</td>
</tr>
<tr>
<td></td>
<td>Positive values move text toward the leader and negative values move text away from the leader.</td>
</tr>
<tr>
<td></td>
<td>Changes the position of the text to read vertically.</td>
</tr>
<tr>
<td></td>
<td>When Rotate with Component is enabled, text orientation is relative to the host element.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Text Location</td>
<td>Specify the position of the spot coordinate with respect to the leader. Options include Above Leader, Below Leader, or In-line with Leader. When you specify In-line with Leader, the elevation symbol does not display for the spot coordinate. In addition, the Text Offset from Leader, Text Offset from Symbol, and Symbol properties are disabled.</td>
</tr>
<tr>
<td>Elevation Indicator</td>
<td>A text string you enter with the spot elevation. Can be displayed as a prefix or suffix with the Indicator as Prefix/Suffix parameter.</td>
</tr>
<tr>
<td>Coordinate Origin</td>
<td>Indicates that the coordinates are shared. This is a read-only value.</td>
</tr>
<tr>
<td>Top Value</td>
<td>Determines which coordinate value is placed on top.</td>
</tr>
<tr>
<td>Bottom Value</td>
<td>Determines which coordinate value is placed on the bottom.</td>
</tr>
<tr>
<td>North/South Indicator</td>
<td>Lets you specify how to label the north/south direction. For instance, you might enter X.</td>
</tr>
<tr>
<td>East/West Indicator</td>
<td>Lets you specify how to label the east/west direction. For instance, you might enter Y.</td>
</tr>
<tr>
<td>Include Elevation</td>
<td>Displays the spot elevation in addition to the spot coordinates.</td>
</tr>
<tr>
<td>Indicator as Prefix / Suffix</td>
<td>Specifies placement of the North/South, East/West, and Elevation indicators.</td>
</tr>
</tbody>
</table>

### Spot Coordinate Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td>If selected, the spot coordinate includes a leader line. When not selected, no leader line displays.</td>
</tr>
<tr>
<td>Leader</td>
<td>If selected, the spot coordinate includes a leader line. When not selected, no leader line displays.</td>
</tr>
<tr>
<td>Leader Shoulder</td>
<td>When Leader is selected, you can add a shoulder (a bend) to the leader line.</td>
</tr>
<tr>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Top Value Prefix</td>
<td>Specify prefix text for the top spot coordinate.</td>
</tr>
<tr>
<td>Top Value Suffix</td>
<td>Specify suffix text for the top spot coordinate.</td>
</tr>
<tr>
<td>Bottom Value Prefix</td>
<td>Specify prefix text for the bottom spot coordinate.</td>
</tr>
<tr>
<td>Bottom Value Suffix</td>
<td>Specify suffix text for the bottom spot coordinate.</td>
</tr>
<tr>
<td>Elevation Value Prefix</td>
<td>Specify prefix text for the spot elevation. This parameter is enabled when the Include Elevation type parameter is selected.</td>
</tr>
<tr>
<td>Elevation Value Suffix</td>
<td>Specify suffix text for the spot elevation. This parameter is enabled when the Include Elevation type parameter is selected.</td>
</tr>
</tbody>
</table>
**Spot Slope Type Properties**

You can specify various parameters to change the appearance of the spot slope.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Constraints</strong></td>
<td></td>
</tr>
<tr>
<td>Rotate with Component</td>
<td>When selected, the spot slope rotates with the component.</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Leader Arrowhead</td>
<td>Sets the appearance of the leader arrowhead. The value None removes the arrowhead. To define an arrowhead, see Specifying Arrowhead Styles on page 1609.</td>
</tr>
<tr>
<td>Leader Line Weight</td>
<td>Sets the weight of the leader line. The higher the value, the thicker the line.</td>
</tr>
<tr>
<td>Leader Arrowhead Line Weight</td>
<td>Sets the arrowhead line weight. The higher the value, the thicker the arrowhead line.</td>
</tr>
<tr>
<td>Color</td>
<td>Sets the color of the spot slope. Click the button to open the color picker.</td>
</tr>
<tr>
<td>Slope Direction</td>
<td>Sets the direction of the spot slope. Default setting is Down.</td>
</tr>
<tr>
<td>Leader Line Length</td>
<td>Sets the leader line length.</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td></td>
</tr>
<tr>
<td>Width Factor</td>
<td>Specify a ratio to define the elongation of the text string. A value of 1.0 has no elongation.</td>
</tr>
<tr>
<td>Underline</td>
<td>Underlines the spot slope value and text.</td>
</tr>
<tr>
<td>Italic</td>
<td>Applies italic formatting to the spot slope value and text.</td>
</tr>
<tr>
<td>Bold</td>
<td>Applies bold formatting to the spot slope value and text.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Sets the size of the elevation text.</td>
</tr>
<tr>
<td>Text Offset from Leader</td>
<td>Offsets the text from the leader line.</td>
</tr>
</tbody>
</table>

![N/S -200

E/W 645](image)

| Text Font                 | Sets the font for the elevation text.                                        |
| Text Background           | Sets the background for the text. With opaque, the background of the text itself covers objects behind it. Transparent allows you to see objects behind the text. |
| Units Format              | Click the button to open the Format dialog. Clear the Use Project Settings option, and set the appropriate values. See Setting Project Units on page 1613. |
Spot Slope Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td>Allows you to specify how the spot slope displays when in elevation and section views.</td>
</tr>
<tr>
<td>Slope Representation</td>
<td>Lets you set how the slope representation displays from its reference.</td>
</tr>
<tr>
<td>Offset from Reference</td>
<td>Lets you set the offset of the slope representation from its reference.</td>
</tr>
<tr>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Prefix</td>
<td>Specify prefix text for the spot slope.</td>
</tr>
<tr>
<td>Suffix</td>
<td>Specify suffix text for the spot slope.</td>
</tr>
</tbody>
</table>

Text Notes

You can insert wrapping or non-wrapping text notes, which are measured in paper space and automatically scale with the view. For example, a 1/4" text note indicates that the text note will display as 1/4" high on a sheet. If you reduce the size of the view scale, the text automatically resizes.

Adding Text Notes

1. Click Annotate tab ➤ Text panel ➤ (Text).
The cursor changes to the text tool.

2 On the Format panel, select a Leader line option:
   - No Leader (default)
   - One Segment
   - Two Segments
   - Curved - to change the curve shape, drag the elbow control.

   **TIP** When you place a text note with a leader, the last leader point snaps to all possible leader attachment points from nearby text notes. When you place a text note without a leader, it snaps to the text origins from nearby text notes or labels. Origin is a point that depends on the text alignment (left, right, or center).

3 Select a left attachment point and a right attachment point.

   **NOTE** The default attachment points are top left and bottom right, but you can change the defaults.

4 Select a horizontal alignment (Left, Center, or Right).

5 Do one of the following:
   - **For non-wrapping text.** Click once to place the note. Revit Structure inserts a text box in which to type.
   - **For wrapping text.** Click and drag to form a text box.
   - **For a text note with a one-segment or a curved leader.** Click once to place the leader end, draw the leader, and then click the cursor (for non-wrapping text) or drag it (for wrapping text).
   - **For a text note with a two-segment leader.** Click once to place the leader end, click where you want to place the leader elbow, and then finish the leader by clicking the cursor (for non-wrapping text) or dragging it (for wrapping text).

6 (Optional) On the Format panel, select attributes for the text: Bold, Italic, and Underline (or press Ctrl+B, Ctrl+I, or Ctrl+U).

7 (Optional) To create a list in the note, click (Paragraph Format), and select a list style.

8 Enter text, and then click anywhere in the view to finish it.

   The text note controls remain active so that you can change the note’s position and width.

9 Press Esc twice to end the command.

---

Contractor is to provide to the owner a list of all subcontractors used, complete with addresses, phone numbers and copies of all warranties and operations and maintenance manuals.
Creating a List in a Text Note

When you create a bulleted or numbered list in a text note, Revit Structure indents the list text based on the Tab Size type property. Pressing Tab will indent the text, but not the bullet or number. Only single-level lists can be created.

NOTE If the printed length of the bullet or alphanumeric character is greater than the Tab Size value, the first line in a multi-line list item will be indented 1 space rather than 1 tab length. All other lines in the list will be indented 1 tab length.

1. Contractor is to provide to the owner a list of all subcontractors used.
2. The term “contractor” as used in these notes shall refer to the general contractor or to the subcontractors. The owner may elect to contract directly with a sub-contractor for any part of the work.

To create a list in a new text note

1. Begin a text note, but before typing text, click (Paragraph Format), and select a list style. You can create a list without indicators, or one with bullets, numbers, lowercase letters, or uppercase letters.

   1. Contractor shall supervise and direct the work and shall be solely responsible for all construction means, methods, techniques and safety procedures and for coordinating all portions of the work.
   2. Owner shall pay all taxes, secure all permits and pay all fees incurred in the completion of the project.
   3. Insurance: workmen’s compensation, as required by law, and public liability shall be carried by the contractor.

2. Enter text, and then click anywhere in the view to finish it.
TIP When you copy text into a note, the paragraph format of the note is applied to the text. For example, if you copy text into a bulleted list, the copied text is also bulleted.

To create a list from existing text

1 Select the text you want to format.

2 On the ribbon, click (Paragraph Format), and select a list style.

3 Press Esc twice to end the command.

Changing the Default Leader Attachment Points

When you start a new text note, select new leader attachment points before you click in the drawing area. After you complete the text note, the attachment points that you specified become the default locations for leaders in subsequent notes for the current session of Revit.

Modifying Text Notes

You can modify text notes by changing the font type and style, moving the text note, and changing the type of text note.

Changing the Text Note Type

To change the text note type on placement

With the Text tool active, select the desired type from the Type Selector on the Properties palette.

To change an existing text note type

1 Select the text note in the drawing area.

2 On the Properties palette, select the desired type from the Type Selector.

Editing the Text Note

To edit a text note, select the text note in the drawing area, and then:

- **Add a leader.** Click Modify | Text Notes tab ➤ Format panel, and select a leader style. Specify an attachment point, drag the leader points as necessary, and then click anywhere in the view to finish editing.

  **NOTE** For text notes created in Revit Structure prior to version 2011, the default leader attachment points are top left and top right.

- **Move a leader.** Click Modify | Text Notes tab ➤ Format panel, and select a new leader attachment point.

- **Change the paragraph format.** Select the note text, and on the Modify | Text Notes tab ➤ Format panel, select a style from the (Paragraph Format) drop-down.
- **Move the note.** To move the text box without moving the arrowhead on the leader line, drag the cross-shaped control. To move a leader line, drag one of the blue circular controls in the desired direction. If you want to create an elbow on the leader line, drag the center control on the line.

- **Resize the note.** Drag one of the circular controls on the text box to change its width. If you resize the text box on a non-wrapping text note, the text note becomes wrapping.

- **Rotate it.** Use the rotate control to rotate the note.

- **Change text alignment.** Click Modify | Text Notes tab ➤ Format panel, and select an alignment option (Align Left, Align Center, or Align Right). Alternatively, you can edit the Horizontal Align property on the Properties palette.

- **Change the typeface.** Select the note text, and on the Format panel, select Bold, Italic, and/or Underline (or press Ctrl+B, Ctrl+I, or Ctrl+U).

- **Edit the text.** Select text in the note, and then edit as desired.

- **Change the background of the note.** On the Properties palette, click Edit Type. In the Type Properties dialog, specify the Background value as either Opaque or Transparent.

### Displaying the Text Box Border

Using the type properties of a text note, you can specify whether to show the graphic representation of the text box border.

1. In the drawing area, select a text note for which you want to display a border.

2. On the Properties palette, click (Edit Type).

3. In the Type Properties dialog, under Graphics, select Show Border, and then click OK. Because you modified a type property, borders display for all notes of that type.

| 1. Contractor shall supervise and direct the work and shall be solely responsible for all construction means, methods, techniques and safety procedures and for coordinating all portions of the work. |
| 2. Owner shall pay all taxes, secure all permits and pay all fees incurred in the completion of the project. |
| 3. Insurance: workmen’s compensation, as required by law, and public liability shall be carried by the contractor. |

**NOTE** The color of the text box border is specified by the Color parameter under Graphics in the Type Properties dialog. The color you specify is applied to all text annotation components (text, leaders, and borders).
Modifying the Leader/Border Offset

Using the type properties of a text note, you can specify the distance between the text box border and the edge of the annotation text.

1. In the drawing area, select the text note for which you want to modify the margin.

2. On the Properties palette, click (Edit Type).

3. In the Type Properties dialog, under Graphics, enter a value for Leader/Border Offset, and then click OK.

Because you modified a type property, the specified offset is applied to all notes of that type.

Default leader/border offset (5/64")

Modified leader/border offset (1/4")

NOTE The offset value is the size the margin will be when the sheet is printed.
Leader behavior

Depending on the leader attachment points, the offset value, and the display of the text box border, leaders will behave as follows:

- If attachment points are top or bottom on either side, leaders will extend into the note text.

- If attachment points are middle on either side, leaders will not extend past the text box border location, even if the border display is turned off.

- If text box border is turned on, leaders will not extend past the border.

Finding and Replacing Text Notes

The text in notes and detail groups can be searched for in an open project, and replaced with new text using the Find/Replace tool. You can also pass control between worksets users. See Finding and Replacing Text in a Detail Group on page 933.

NOTE The Find/Replace function is not available for keynotes.
The Find/Replace function is available for searching:

- current selection - searches for text in the text notes currently selected
- current view - searches for text in the view that is open
- entire project - searches for text in the entire project

Detail group text can only be replaced from Modify | Detail Groups tab ➤ Group panel ➤ (Edit Group). See Finding and Replacing Text in a Detail Group on page 933. When text is replaced using Edit Group, it is replaced in all group instances.

When you search, the Find/Replace dialog displays the results in a table. Each row displays a single search result under columns labeled:

- Match - displays text search result
- Found in - displays the view or group name, such as Level 1, North, Detail Group 1
- View Type - displays the view in which the search result is located, such as floor plan or elevation

When a row is highlighted, the Context field displays text that identifies the particular text string's exact location. For example, you may have created text in a project's planning stage that you plan to replace with more meaningful text as the project progresses. If you used "SEALANT - TBD" in 20 places in the project, and want to replace that text with "GAF 1051 SEALANT", 20 rows display in the search results table. When one of the rows is highlighted, the Context field displays what text is adjacent to the search result. This lets you determine if it is, for example, "Wall: SEALANT - TBD" or a “Tub: SEALANT - TBD”.

To find and replace text in a text note

1 Select Annotate tab ➤ Text panel ➤ (Find/Replace).
2 In the Find/Replace dialog, for Find, enter the text you want to replace.
3 For Replace with, enter the new text.
4 Under Scope, select the appropriate fields.
5 Click Find Next, or Find All.

**NOTE** If your search term is found in a detail group in your project, a warning informs you that changes cannot be made to detail group text until you open the detail group for editing. See Finding and Replacing Text in a Detail Group on page 933

6 If the Term Found in Detail Group(s) warning displays, note which detail groups contain your search term, and then click Close.
7 Click Find Next to highlight the individual results. When a result is highlighted, its context displays in the Context field.
8 Click Replace to replace the highlighted result text, or Replace All to replace all instances.

**Finding and Replacing Text in a Detail Group**

1 Select a detail group in the drawing area.
2 Click Modify | Detail Groups tab ➤ Group panel ➤ (Edit Group).

3 Click Annotate tab ➤ Text panel ➤ (Find/Replace).
4 In the Find/Replace dialog, for Find, enter the text you want to replace.
5 For Replace with, enter the new text.
6 Under Scope, select the appropriate fields.
7 Click Find All.
   A list of all terms found displays.
8 Click Find Next to highlight each row in the results list.
9 Click Replace to replace the highlighted result text, or Replace All to replace all instances.
10 Click Close, and then click (Finish).

Finding and Replacing Text in Worksets
1 Select a workset text note. See Setting Up Worksets on page 1212.

2 Click Modify | Text Notes tab ➤ Tools panel ➤ (Find/Replace).
3 In the Find/Replace dialog, for Find, enter the text you want to replace.
4 For Replace with, enter the new text.
5 Under Scope, select the appropriate fields.
6 Click Find All.
   A list of all terms found displays.
7 Click Replace or Replace All.
8 If the workset is reserved under another user's control, the text cannot be replaced, and an error displays. Click Show to highlight which workset is reserved.
9 Click Place Request to notify the user that you need them to relinquish control, and click Check Now in the Check Editability Grants dialog to check on the status.
10 Click Continue.
11 Click Close.

Checking Text Note Spelling
The Spelling tool checks the spelling of text notes in a selection or in the current view or sheet. This tool does not check the spelling of other types of text, such as text in element properties.

To check the spelling of text notes with worksets, be sure that all the view and sheet worksets are editable. If you make a view editable by right-clicking it in the Project Browser and clicking Make Workset Editable, be sure that you have the view activated, not the Project Browser.

TIP If you have text notes in views on a sheet, and you want to check their spelling but the sheet workset is not editable, use the Make Workset Editable with All Views option on the shortcut menu.
Text notes in groups are ignored by the Spelling tool unless you are editing the group. The Spelling tool notifies you if any groups were skipped when it finishes. If you are editing a group of text notes, the Spelling tool tests only the notes in that group.

**To check the spelling of text notes, do one of the following**

- Click Annotate tab ➤ Text panel ➤ ![Spelling](image).
- Press F7.

**To view or modify spelling settings**

1. Click ![Options](image) ➤ Options.
2. In the Options dialog, click the Spelling tab.
3. Specify Settings, the language for the main dictionary, and any additional dictionaries to use during spell check operations.
4. Click OK.

**Adding a Special Character from the Windows® Character Map®**

1. On the Windows Start menu, click Start ➤ Run.
2. In the Run dialog, enter `charmap`, and click OK.
3. In the Character Map dialog, select a character, and click Select.

   **NOTE** If the font for characters doesn’t match the font of the text note, the selected characters may not display as expected in the note.

4. Click Copy.
5. In Revit Structure, select a text note, and click ![Clipboard](image) ➤ ![Paste](image), or press Ctrl+V.

   The special character displays in the text box.

**Adding or Removing Leader Lines from a Text Note**

1. Select the text note.
2. To add leaders, click Modify | Text Notes tab ➤ Format panel, and click the desired tool:

   - ![Left Side Straight Leader](image) (Add Left Side Straight Leader)
   - ![Right Side Straight Leader](image) (Add Right Side Straight Leader)
   - ![Left Side Arc Leader](image) (Add Left Side Arc Leader)
3 Click as many times as desired to place leaders.

**TIP** To convert a text note's leader to an arc leader, select the text note, and on the Properties palette, select Arc Leaders.

4 To remove the leader line that you added most recently, click Modify | Text Notes tab ➤ Format panel ➤ (Remove Last Leader). Click as many times as desired. As you click, leader lines are removed in the order they were added.

**Related topics**
- Specifying Arrowhead Styles on page 1609
- Text Note Properties on page 936

**Text Note Properties**

You can modify many parameter values for text notes.

**Modifying Text Note Properties**

1 In a project view, select a text note.
2 On the Properties palette, edit text note instance properties.
3 To change text note type properties, click (Edit Type).

**NOTE** Changes made to type properties affect all text notes of that type in the project. To create a new text note type, click Duplicate.

4 Click OK.

**Related topics**
- Specifying Text Note Styles on page 1610
- Leader Arrowhead Properties on page 938

**Text Note Type Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Color</td>
<td>Sets the color of the text and the leader line.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Line Weight</td>
<td>Sets the thickness of the border and of the leader line. You can change the definition of the line weight numbers using the Line Weights tool. See Line Weights on page 1603.</td>
</tr>
<tr>
<td>Background</td>
<td>Sets the background for the text note. With Opaque, the background of the note itself covers material behind it. Transparent allows you to see material behind the note. This is useful with text notes placed in color-defined rooms.</td>
</tr>
<tr>
<td>Show Border</td>
<td>Displays a border around the text.</td>
</tr>
<tr>
<td>Leader/Border Offset</td>
<td>Sets the distance between the leader/border and the text.</td>
</tr>
<tr>
<td>Leader Arrowhead</td>
<td>Sets the arrowhead style for the leader as defined by the Arrowheads tool. See Specifying Arrowhead Styles on page 1609.</td>
</tr>
</tbody>
</table>

**Text**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Font</td>
<td>Sets the Microsoft® True Type fonts for the text note. The default font is Arial.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Sets the size of the typeface.</td>
</tr>
<tr>
<td>Tab Size</td>
<td>Sets tab spacing in a text note. When you create a text note, you can press Tab anywhere in the text note, and a tab appears at the specified size. Also determines the indent for text lists.</td>
</tr>
<tr>
<td>Bold</td>
<td>Sets the text typeface to bold.</td>
</tr>
<tr>
<td>Italic</td>
<td>Sets the text typeface to italic.</td>
</tr>
<tr>
<td>Underline</td>
<td>Underlines the text.</td>
</tr>
<tr>
<td>Width Factor</td>
<td>The default for regular text width is 1.0. The font width is scaled proportionately to the Width Factor. Height is not affected.</td>
</tr>
</tbody>
</table>

**Text Note Instance Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphics</td>
<td></td>
</tr>
<tr>
<td>Arc Leaders</td>
<td>Converts a text note’s leader to an arc leader.</td>
</tr>
<tr>
<td>Left Attachment</td>
<td>Specifies placement of a leader (Top, Middle, or Bottom) attached to the left side of a text note.</td>
</tr>
<tr>
<td>Right Attachment</td>
<td>Specifies placement of a leader (Top, Middle, or Bottom) attached to the right side of a text note.</td>
</tr>
<tr>
<td>Horizontal Align</td>
<td>Sets the justification of the text (Left Center, or Right).</td>
</tr>
<tr>
<td>Keep Readable</td>
<td>Text in the note remains readable (never displays upside-down) whenever you rotate it.</td>
</tr>
</tbody>
</table>
Leader Arrowhead Properties

Parameter names, values, and descriptions for text note leader arrowheads. Many values are modifiable.
Settings are global for the project.

To access properties for leader arrowhead types, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Arrowheads).

**Arrowhead Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow Style</td>
<td>Sets the arrowhead shape on the leader line.</td>
</tr>
<tr>
<td>Fill Tick</td>
<td>Fills the arrowhead.</td>
</tr>
<tr>
<td>Arrow Width Angle</td>
<td>Sets the width of the arrowhead. The larger the angle value, the wider the arrowhead.</td>
</tr>
<tr>
<td>Tick Size</td>
<td>Sets the overall size of the arrowhead.</td>
</tr>
<tr>
<td>Heavy End Pen Weight</td>
<td>If Arrow Style is set to Heavy End Tick Mark, this setting specifies the size of the mark or dot on the opposite end of the text note.</td>
</tr>
</tbody>
</table>

Keynotes

A keynote parameter is available for all model elements (including detail components) and materials. You can tag each of these elements using a keynote tag family. The keynote value is derived from a separate text file that contains a list of keynotes.

If an element already contains a value for a keynote, it displays in a tag automatically. If not, you can select the keynote value directly. Revit Structure provides 2 sample text files for keynoting. See Keynote Workflow on page 939.

Keynotes assigned in a project are linked to their source keynote table. When the keynote table is changed, keynotes in the project will reflect the changes when the project is closed and reopened.

Differences Between Keynoting and Tagging a Material

The difference between keynoting and tagging a material is the information that is displayed in the tag and which tag family Revit Structure uses. Revit Structure has separate categories for keynotes and material tags.

Using keynotes

- If you click Annotate tab ➤ Tag panel ➤ Keynote drop-down ➤ (Material Keynote), Revit Structure looks for a tag family assigned to the keynote category. If the tag is not loaded in the project, you are prompted to load one.
- The keynote family displays one or both of the values available from the keynote table. See Keynoting Settings on page 939.
Using tags

- If you click Annotate tab ➤ Tag panel ➤ Tag drop-down ➤ Material, Revit Structure uses a tag family assigned to the material category.
- The default tag displays the value stored for the Description parameter, if it is assigned.

Keynoting Settings

To access the Keynoting Settings dialog, click Annotate tab ➤ Tag panel drop-down ➤ (Keynoting Settings).

**Keynote Table**

- **Full Path** Displays the entire path of the keynote file.
- **Saved Path** Displays the file name of the keynote file that is loaded.
- **View** Opens the Keynotes dialog. This dialog does not permit editing the keynote table.

**Path Type**

- **Absolute** Identifies a specific folder located on your local PC or a network server. The path could be stored in the Uniform Naming Convention (UNC) format such as \servername\share\folder\keynote.txt.
- **Relative** Finds the keynote file where the project file or central model is located. If the file is moved to a new location, Revit Structure expects to find the keynote file in this new folder location as well.
- **At Library Locations** Finds the keynote file where the stand-alone installation or network deployment specified.

**Numbering Method**

- **By keynote** Determines the keynote value by the value stored in the keynote parameter or selected from the keynote table. This value displays in the keynote as well as filling in the keynote parameter.
- **By sheet** Numbers keynotes according to their order of creation. A value for the keynote parameter is still stored if one has been chosen.

A Keynote Legend displays the Keynote Number according to the order it was created instead. No number appears in the tag until the view bearing Keynote Tags is placed on a sheet view.

Keynote Workflow

The default keynoting data provided in Revit Structure is based on the 1995 Construction Specification Institute (CSI) Master format system, which uses 16 divisions to organize construction process and materials. This is a widely used system in the United States. See Keynote File Versions on page 943.

A more recent version of this system has not yet seen wide-spread adoption. This newer version is based upon 50 divisions and was introduced in 2004. Support for this new format can be accomplished by adding the additional divisions to the default keynote data files as needed. See Adding Additional Categories on page 942.

This system is most effective when objects that are used throughout a project are already assigned their respective keynote values. When these values are not supplied, you can assign a value as you place a keynote tag. Materials, system and component families, and detail components can have keynote parameters entered in advance.
Placing a Keynote

1 Click Annotate tab ➤ Tag panel ➤ Keynote drop-down, and select a keynote type (Element, Material, or User).

2 On the Properties palette:
   - In the Type Selector, select a keynote style (Number, Number - Boxed [Large or Small], or Text).
   - Select the Leader check box to show or hide the keynote tag leader.
   - Specify the keynote tag orientation (horizontal or vertical).

3 In the drawing area, click the relevant element or material to identify which element to tag. An arrowhead appears at this location.

4 Click the second point of the first segment for leader.

5 Click the final point for the end of the second segment of leader and location of keynote tag.

If the element or material already has a value entered for the parameter keynote, it appears in the tag automatically. If it does not, the Keynotes dialog opens, where you can select the keynote value.

To add or create your own keynote data, see Adding Additional Categories on page 942.

Keynote Placement Tips

- For Revit Structure to keynote a material, the element must be visible in the view, and the material must be displayed by setting the detail level to medium or fine.
  For example, if a door panel is not visible in plan view, you will not be able to keynote the material of the panel. The same door family can have a keynote or tag attached to the door panel’s material in an elevation view, because the solid geometry is visible in the view.

- If you are not able to keynote or tag an element in a particular view, check the settings of the family. Nested family components need to be shared in order to place or display a keynote value. For more information about nested families, see The Families Guide on page 680.

Expected Keynote Behavior

If a family is created using a keynote table that is different from the one the project is using and

- The same value exists in each keynote table, the project’s keynote file values are used.

- There are different values in each keynote table, or there is no corresponding value for the keynote in the project, the keynote number will display, but the text for the keynote will not display.

To resolve these issues, you can select a new keynote value that is part of the project’s keynote table, or add the keynote value to the keynote table. See Adding Additional Categories on page 942.

Types of Keynotes

- **Element.** A keynote can be applied to an entire element, such as a wall, detail component, or door.

- **Material.** A keynote can be assigned to a material that has been painted on a surface, and to materials assigned to the component layers of an element. Material keynotes are not supported for the insulation drafting tool, the detail components line and filled region, or wireframe views.
This option provides a way to use commonly used notes or phrases to address documentation issues. These additional user notes must be added to the provided keynote text files or included in one that you create. See Adding Additional Categories on page 942.

Assigning Keynote Values

Assigning Keynote Values to Materials

Keynote selection can be applied to materials. Keynotes are assigned to materials on the Identity Tab of the Materials dialog. To access the Materials dialog, click Manage tab ➤ Settings panel ➤ (Materials).

When materials are assigned a keynote value, the objects that use these materials inherit the keynote value accordingly.

A great deal of time can be saved if the materials of a project have their keynote values applied before you apply keynote tags to materials. See Changing Material Identity Data on page 1595.

Assigning Keynote Values to Elements

All elements have a Keynote Type parameter. These can be supplied in advance using the Type Properties dialog (see Element Properties on page 15), or selected when the tag is placed.

Assigning Keynote Values Using Tags

After you apply a keynote tag to an element, you can select the keynote tag and click over the keynote value or empty value to open the Keynotes dialog. Select the desired keynote for the element.

NOTE If you click OK, Revit Structure uses the keynote value that is currently selected. If you click Cancel, the keynote value remains empty.

Keynote Legend

You can access the Keynote Legend tool by clicking View tab ➤ Create panel ➤ Legends drop-down ➤ (Keynote Legend). There are 2 parameters predefined in the Scheduled fields list: Key Value and Keynote Text. The remaining tabs (Filter, Sorting/Grouping, Formatting, and Appearance) are all available as they are for other schedules. See Specifying Schedule Properties on page 788.
With careful use of keynote headings and filtering, it is possible to create keynote legends that group common types of keynotes together.

Keynote legends can be placed on multiple sheet views.

Filtering Keynotes by Sheet

The Filter by Sheet option causes the schedule to only display those keynotes that are visible in views on the sheet where the schedule is placed. Use the following procedure to select this option.

1. Open the keynote legend from the Legends category in the Project Browser.
2. On the Properties palette, for Filter, click Edit.
3. In the Keynote Legend Properties dialog, click Filter by Sheet, and click OK.

Filtering Keynotes by CSI Heading

To filter keynotes scheduled to one main category of keynotes

1. Open the keynote legend from the Legends category in the Project Browser.
2. On the Properties palette, for Filter, click Edit.
3. In the Keynote Legend Properties dialog, for Filter By, click an option from the list.
   For example, to filter by CSI Division 15, click Key Value.
4. Next to Filter By, a list of operators displays. The data must match or abide by the operator and value you enter for it to appear in the schedule.
   For example, the value of the CSI Division 15’s main heading is 15000. To display all keynote values that begin with 15, select the Begins With operator, and enter '15' in the text box.

Adding Additional Categories

Keynotes are defined in a tab-delimited text file. The first portion of the text file is reserved for major headings/categories (the parent values). The remainder of the file is for sub-headings/categories (the child values). A tab-delimited file requires the use of the 'Tab' key to create spaces between data entries.

Changes made to the keynote table are not available in the current project session of Revit Structure. Changes are available when the project is closed and reopened.
You can use Microsoft® Excel or a similar spreadsheet application to manage the data, then export it to a tab-delimited file format.

**Sample Keynote Text File**

CSI Main Category/Heading (parent value)
11000 [tab] Division 11 - Equipment

CSI Master format sSb-Category/Heading [tab] Sub-Category/Heading Description [tab] CSI Masterformat Main Category/Heading Value (parent value)
11060 [tab] Theater and Stage Equipment [tab] 11000
11061 [tab] Acoustical Shells [tab] 11000
For sub-categories of sub-categories

**Sample User Keynote Text File**

For User Keynotes you can place them in front of the CSI structure by using the following format:
Main/Heading/Parent Category
00000 [tab] Division 00 - User Notes
Sub-Category/Heading/Child
00001 [tab] User Note 1 [tab] 00000
00002 [tab] User Note 2 [tab] 00000
For sub-categories of sub-categories

**Keynote File Locations**

Keynote files for a standalone installation reside in the Revit library, which is located by default in

- Windows® XP: C:\Documents and Settings\All Users\Application Data\Autodesk\<Revit release name>\<Imperial or Metric> Library
- Windows Vista or Windows 7: C:\ProgramData\Autodesk\<Revit release name>\<Imperial or Metric> Library

The file can be located on a network server so that it is available to all users. See Keynoting Settings on page 939 for information on assigning file locations.

**Keynote File Versions**

The following files are provided and installed during deployment:

- RevitKeynotes_Imperial.txt
- RevitKeynotes_Metric.txt
Resolving Keynote File Errors

When the keynote file cannot be located, Revit Structure displays the following message when any action that attempts to display the keynote selection dialog occurs:

Unable to Load Keynote data. Check keynote table locations in Keynoting Settings.

Use the following procedure to resolve the issue.

To specify the location of the keynote text file

1. Click Annotate tab ➤ Tag panel drop-down ➤ (Keynoting Settings).
2. In the Keynoting Settings dialog, click Browse, and navigate to the appropriate keynote text file.

Keynote Tag Ends

For keynote tags that are associated with elements, the end of the leader is free to be relocated to another location and not connected to just the boundary of an element. Therefore, when placing a keynote, you can select the leader option Free End or Attached End.

Material tags are assigned Free End and cannot be assigned Attached End. A material keynote tag's leader end identifies the material as you move it over different materials. The keynote value automatically displays the appropriate keynote value, if one is assigned.

The leader end for tags associated with
- An element is attached to the boundary edge of the element.
- A material is attached to the center of the selected material.

Tags

Use the Tag tool to attach a tag to a selected element. A tag is an annotation for identifying elements on a drawing. Properties associated with a tag can display in schedules.

Every category in the family library has a tag. Some tags automatically load with the default Revit Structure template, while others you need to load. If desired, you can make your own tag in the Family Editor. See Creating an Annotation Symbol Family on page 953.

Related topics
- Areas and Area Tags on page 714
- Tagging Elements in Linked Models on page 1200

Tag Labels

When a tag is created, labels are added to display the text value of desired element parameters. See Labels on page 704. These labels display the values for the object’s corresponding parameters after the tag is loaded and placed in the project. For example, if the label is set to display "element type name", the tag displays the type name of each tagged element. Some parameters (such as type name) are automatically updated by Revit Structure, while other parameters (such as comments) are user-defined.
Related topics
- Structural Framing Tag Families on page 262
- Beam Annotations Tool on page 263
- Structural Framing Tags on page 265
- Spot Elevations on page 265
- Labels on page 704

Editing the Label of a Placed Tag
Tags are edited in the Family Editor. Select the tag and click Modify | <element> Tags tab ➤ Mode panel ➤ (Edit Family) to open the Family Editor, where you can edit the labels in this tag’s family.

Editing Parameter Values Using the Tag Label
Edit the value of an element parameter on the Properties palette, or, if a parameter in the tag’s label is editable, the tag becomes a control when selected. Click the selected tag to edit the parameter value.

Sample in-place editing of a furniture tag

If the tag contains a multi-parameter label, click the selected tag to open the Change Parameter Values dialog and modify the associated parameters. See Label Parameter Options on page 706.

Multiple Tags for Families
Families can have multiple tags. To load multiple tags for a family, see Loading Tag Styles on page 1612.

Applying a Tag By Category
Before attempting this procedure, load the necessary tags for elements that need a tag. See Loading Tag Styles on page 1612.

1 Click Annotate tab ➤ Tag panel ➤ (Tag by Category).
2 On the Options Bar:
   - To set the orientation of the tag, select Vertical or Horizontal.
     After you place the tag, you can change its orientation by selecting the tag and pressing Spacebar.
   - If you want the tag to have a leader line, select Leader.
   - Specify whether the leader should have an Attached End or a Free End.
   - If desired, enter a value for the length of the leader in the text box next to the Leader check box.
3 Highlight the element to tag, and click to place the tag. After the tag is placed, it is in edit mode and can be repositioned. You can move the leader, text, and tag head arrow.

Related topics
- Tag All Not Tagged on page 947
- Modifying Tags on page 949
- Material Tags on page 948
- Tag Instance Properties on page 947

Applying a Tag On Placement

When you tag an element as you place it and there is no tag loaded for the element, you are prompted to load an appropriate tag. See Loading Tag Styles on page 1612.

1 On the ribbon, select an element to place.

2 On the Modify | Place <Element> ➤ Tag panel, verify that (Tag on Placement) is highlighted, indicating that it’s active.
   If no appropriate tag is loaded, you are prompted to load a tag for the category. Click Yes and load the tag.

3 On the Options Bar:
   - To set the orientation of the tag, select Vertical or Horizontal.
     After you place the tag, you can change its orientation by selecting the tag and pressing Spacebar.
   - If you want the tag to have a leader line, select Leader.
   - Specify whether the leader should have an Attached End or a Free End.
   - If desired, enter a value for the length of the leader in the text box next to the Leader check box.

4 Click to place the element.
   The tag displays as specified.

Related topics
- Tag All Not Tagged on page 947
- Modifying Tags on page 949
- Material Tags on page 948
- Tag Instance Properties on page 947

Changing a Tag Instance

1 Select the tag in the drawing area.
2 In the Type Selector, select another tag style.
Aligning Tags

You can align tags with other similar tags by dragging them. For example, a room tag can align with another room tag, and a generic annotation can align with another generic annotation. As you drag a tag, dashed blue lines display to show when the tag is aligned with another tag:

Tag Type Properties

To access type properties for a tag, select the tag, and in the Properties palette, click (Edit Type).

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Leader Arrowhead</td>
<td>Sets the arrowhead shape on the leader line. The value is the name of the arrowhead style defined by the Arrowheads tool.</td>
</tr>
</tbody>
</table>

Tag Instance Properties

To modify instance properties for a tag, select the tag, and use the Properties palette to change the appropriate parameters.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Leader Line</td>
<td>Specifies whether the tag has a leader line. The default is for the leader to have an attached end, but you can specify a free end on the Options Bar.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Specifies whether the tag displays horizontally or vertically. Alternatively, select the tag and press the Spacebar to change the orientation.</td>
</tr>
</tbody>
</table>

Tag All Not Tagged

If some or all elements in a view do not have tags, you can apply tags to untagged elements in one operation.

**NOTE** The desired tag families must be loaded into the project before using the Tag All Not Tagged tool. See Loading Tag Styles on page 1612.
To tag untagged elements

1 Open the view in which you want to tag elements.
2 (Optional) Select one or more elements to tag.
   If you do not select elements, the Tag All Not Tagged tool will tag all elements in the view that
   are not already tagged.
3 Click Annotate tab ➤ Tag panel ➤ (Tag All).
   The Tag All Not Tagged dialog displays.
4 Specify the elements to tag.
   ■ To tag all visible elements in the current view that do not have tags, select All objects in
     current view.
   ■ To tag only those elements you have selected in the view, select Only selected objects in
     current view.
   ■ To tag elements in linked files, select Include elements from linked files.
5 Select one or more tag categories.
   By selecting multiple tag categories, you can tag different types of elements (such as detail items
   and generic models) in one operation. To select multiple categories, while pressing Shift or Ctrl,
   select the desired categories.
6 To attach a leader to each tag, do the following:
   ■ Under Leader, select Create.
   ■ For Length, enter a default leader length.
7 For Orientation, select Horizontal or Vertical.
8 Click OK.

**NOTE** If the visibility of the tag category or its object type is turned off, a message displays. Click OK
 to allow Revit Structure to turn on visibility before that category is tagged.

Revit Structure tags elements of the selected family categories.

**Related topics**

■ Modifying Tags on page 949
■ Material Tags on page 948
■ Tag Instance Properties on page 947

**Material Tags**

Use a material tag to identify the type of material used for an element or a layer of an element. Revit Structure
stores this information in the Description field of the Identity tab of the Materials dialog. (See Changing
Material Identity Data on page 1595.)

Before using this procedure, load the necessary material tags for those elements that need a tag. You can
also keynote materials, see Differences Between Keynoting and Tagging a Material on page 938.
1 Click Annotate tab ➤ Tag panel ➤ (Material Tag).

2 On the Options Bar:
   - To set the orientation of the tag, select Vertical or Horizontal.
     After you place the tag, you can change its orientation by selecting the tag and pressing Spacebar.
   - If you want the tag to have a leader line, select Leader.

3 Highlight the material to tag within the element, and click to place the tag.
   You can move the end of the leader to a new material, and the new material will display in the material tag.

   **NOTE** You can highlight the material before you select it by moving the cursor over the material. The material must be displayed by setting the detail level to medium or fine. If the material is not visible, the tag will not display properly.

If the material tag displays a question mark (?), the Description field of the Identity tab for the element’s material is blank. You can double-click the question mark and enter a description of the material. Revit Structure automatically completes the Description field with this value.

**Related topics**
- Modifying Tags on page 949
- Tags on page 944

### Modifying Tags

You can modify the appearance of tags through their instance properties and their type properties. You can change tag properties before or after placing a tag.

### Changing the Tag Leader

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the length of the leader</td>
<td>select the tag, then use the cross-shaped drag control to move the tag.</td>
</tr>
<tr>
<td>add an arrowhead to the leader line</td>
<td>select the tag, and on the Properties palette, click (Edit Type). In the Type Properties dialog, select a value for Leader Arrowhead.</td>
</tr>
</tbody>
</table>
If you want to... Then...

change the color, weight, and pattern of the leader

click Manage tab ➤ Settings panel ➤ (Object Styles). In the Object Styles dialog, click the Annotation Objects tab, scroll to the appropriate tag, and specify values for Line Weight, Line Color, and Line Pattern.

Rehosting a Tag

If needed, you can change the element to which a tag applies. The new element must belong to the same category as the original element for the tag.

1 In the project view, select the tag to rehost.

2 Click Modify | <Element> Tags tab ➤ Host panel ➤ (Pick New Host).
3 Select the element to host the tag.
4 Drag the tag to move it near the new host element.
   Adjust the tag leader and elbow, if needed.

Information displayed in the tag may change to reflect the newly assigned host element.

Sequential Tag Numbering

As you place rooms, doors, and windows in a project, you can use tags that sequentially number the elements. The tags automatically number based on parameters that you specify for each element. Values can be alphabetical, numerical, or alphanumeric sequences.

Creating Sequential Door or Window Tags

To number window and door tags, you enter a unique value for the Mark parameter.

1 Place a door or window.
2 Click Modify, and then select the element.
3 On the Properties palette, enter a value for Mark.
4 Place more instances of the element as desired.

All subsequent instances are numbered sequentially.

**NOTE** All doors and windows number sequentially regardless of type. For example, you place a French door and then a single-flush door into a plan view. The French door is number 1; the single-flush door is number 2.

---

**Symbols**

A symbol is a graphic representation of an annotation element or other object. Symbols are sometimes referred to as tags. For example, the following symbol legend identifies the annotation symbols that are used in a set of construction documents. Revit Structure also uses symbols for moment frames, cantilever connections, and other elements.

Use the Symbol tool to place 2D annotation drawing symbols into the project.

---

**Welding Symbols**

The Symbol tool places welding symbols into the project.

**To place welding symbols**

1 If necessary, create the welding symbol family in the Family Editor, and load it into the project. To create the welding symbol family, use the Generic Annotation template. See [Opening the Family Editor](#) on page 679 and [Loading and Saving Families](#) on page 688.

As you create a welding symbol family, you notice that you can only see it in one view. Like other annotations, it is view-specific.

You can place the following types of welding symbols:

- Fillet
- Flare Bevel
- Bevel
You can specify the following welding symbol properties:
- Top symbol type, size, and length
- Bottom symbol type, size, and length
- Contour symbol type
- Leader configuration
- Tail and tail note display
- Weld all-around and field weld symbol display
- Left or right symbol orientation

2 Click Annotate tab ➤ Symbol panel ➤ (Symbol).
3 In the Type Selector, select the appropriate welding symbol.
4 Click in the drawing area where you want the symbol to appear.
5 Click Modify, and then select the welding symbol.
6 On the Properties palette, specify the desired properties for the welding symbol.
   You can also edit various welding symbol parameters by selecting the welding symbol, then clicking the appropriate blue text value. Type the desired value in the edit box, and press Enter.

**Modifying Symbols**

You can modify the appearance of symbols through their properties. You can change properties before or after you place the symbol. See Symbols on page 951.

To edit symbol properties, do one of the following:
- Select the symbol, and use the Properties palette to modify instance properties.
Select the symbol, and on the Properties palette, click 
>Edit Type\), to modify type properties.

Read about element properties before modifying symbols. See Element Properties on page 15.

Annotation Symbols

An annotation symbol is a tag or symbol applied to a family to uniquely identify that family in a project. The tag can also include properties that appear on schedules. See Creating a Schedule or Quantity on page 772.

You create annotation symbols by selecting the family category with which you want to associate the symbol, sketching the symbol, and applying values to its properties. Some annotation families are for tag purposes. Others are generic annotations used for varying purposes.

Before reading this topic, you should familiarize yourself with families. See The Families Guide on page 680.

Creating an Annotation Symbol Family

This is a general procedure for creating an annotation symbol. Your steps may differ based on design intent.

1. Click 
\(\text{New} \rightarrow \text{Annotation Symbol}\).

2. In the New Annotation Symbol dialog, select the Annotation Symbol template for the project, and click Open.

   The templates are all very similar. Some may already have predefined properties and values.

   Revit Structure opens the Family Editor.

3. Click Home tab \(\rightarrow\) Properties panel \(\rightarrow\) Family Category and Parameters.

   See Family Category and Parameters on page 695.

4. In the Family Category and Parameters dialog, select a category, such as Generic Annotations.

5. Specify the Family Parameters, and click OK.

   **NOTE**: Parameter options vary depending on family category.

6. Click Home tab \(\rightarrow\) Text panel \(\rightarrow\) Label.

7. In the Type Selector, select the label type.

8. Select the vertical and horizontal justification.

9. In the drawing area, click to position the label.

   For example, in a generic model tag template, place the cursor at the intersection of the 2 reference planes.

10. In the Edit Label dialog, under Category Parameters, select the parameter you want in the label, and click \(\text{Add parameter(s) to label}\). If necessary, you can add a new parameter.

   If you select a numerical or dimension value, you can specify the formatting of the value.
11 Click OK.
12 To modify the placement of the label, click Modify, select the label, and then drag it to the new location.

### Specify sample text

13 Select the label, and click Modify | Label tab ➤ Label panel ➤ (Edit Label).
14 In the Edit Label dialog, edit the Sample Value for the Description parameter, and click OK.

15 Sketch the shape of the tag symbol, such as a circle. Click Home tab ➤ Detail panel ➤ (Line), and then select a sketching tool.
16 Save the annotation.

**NOTE** Generic annotations have multiple leader options when loaded into a project.
Detailing Overview

Types of Views for Detailing

There are 2 main types of views you can create for detailing: detail views and drafting views. A detail view contains elements from the building information model. A drafting view is a sheet of paper that is not directly associated with the building information model.

Creating Details

After you have created a view for detailing, you can use additional resources provided with Revit Structure to create details and complete the view for inclusion in construction documents. For information on creating views for detailing, see Types of Views for Detailing on page 955.

Detailing Library

You can add additional detail components by loading them from the family library, or you can create or edit existing ones in the Family Editor. Click on the Detail Components folder, and then select the appropriate CSI (Construction Specifications Institute) section to see specific components under that section.

Revit Structure contains over 500 Detail Component Families. They are organized by the 16 CSI divisions.

Detailing Tools

- **Callouts.** Create a callout first to get a close-up view of a plan or elevation view. All detail annotations are added to the callout view. See Callout Views on page 746.

- **Detail Lines.** Use detail lines to add information or sketch over existing elements. See Detail Lines on page 969.

- **Dimensions.** Apply specific dimensions to the detail. See Placing Permanent Dimensions on page 889.

- **Text Notes.** Use text notes to specify construction methods. See Text Notes on page 926.
■ **Detail Components.** Create and load custom detail components to place in the detail. Detail components might be actual construction components, such as structural steel, jambs, or metal studs. See Creating a Detail Component Family on page 968.

■ **Symbols.** Place a symbol, such as a direction arrow or a break mark symbol to indicate omitted information. See Symbols on page 951.

■ **Masking Region.** Create masking regions to obscure elements in a view. See Masking Regions on page 973.

■ **Filled Region.** Create detail filled regions and give them a fill pattern to represent various surfaces, including concrete or compacted earth. You draw regions on the default work plane. It is not necessary to select a work plane for them. You can apply a fill pattern to the region. To do this, select the region and click Modify | Create Filled Region tab ➤ Properties panel ➤ (Type Properties). Set a value for the Fill Pattern property. The different fill patterns are defined by the Fill Patterns tool. See Filled Region on page 972 and Fill Patterns on page 1566.

■ **Insulation.** Place insulation in a wall detail that shows all the material for the wall. For example, an exterior wall might include a layer of gypsum, insulation, metal studs, sheathing, air space, and brick. See Insulation on page 971.

**Fill Pattern Category**

A filled region created for a detail view is part of the Detail Items category. Revit Structure lists the region in the Project Browser under Families ➤ Detail Items ➤ Filled Region. If you create a filled region as part of an annotation family, Revit Structure identifies it as a Filled Region, but does not store it in the Project Browser.
Detail Editing

Detail Component Positioning

Every detail component, detail line, and filled region has a graphic draw order within the overall detail. Think of it as a stack of papers on your desk that overlap each other. You can send the detail component to the back of the detail. This is like taking the top paper and placing it at the bottom of the pile. You can also send the detail component back one step at a time. Think of this as taking the top piece paper and placing it behind the next piece of paper in the stack. Of course, you can do the reverse as well. You can bring the detail to the top of the stack or bring it forward one step at a time.

**NOTE** Detail components always appear on top of model geometry. You cannot send a detail component behind model geometry. The current positioning only works with detail components, insulation, detail lines, detail groups, repeating details, and filled regions.

For more information on graphic draw order, see Sorting the Draw Order of Detail Components on page 958.

Show Hidden Lines

After you put detail components in the correct graphic draw order, you can use the Show Hidden Lines tool to obscure the lines behind a detail component.

1. Select View tab ➤ Graphics panel ➤ (Show Hidden Lines).
2. Select the elements that you want to show hidden lines through. Lines from obscured elements will show through these elements.
3. Select one or more elements for which you want hidden lines displayed. Obscured edges and lines for these elements will appear as hidden lines.

**NOTE** The object must be in the correct order. You cannot hide the lines of a bolt that is on top of a 4x6 stud. The bolt must first be sent behind the 4x6 stud to be obscured. To show the bolt as hidden lines, select the 4x6 stud, and then select the bolt. See Remove Hidden Lines on page 957.

Remove Hidden Lines

The Remove Hidden Lines tool reverses the effects of the Show Hidden Lines tool. The following example illustrates the results after selecting View tab ➤ Graphics panel ➤ (Remove Hidden Lines), and then selecting the 4x6 stud and the bolt. This procedure removes the hidden lines, and the 4x6 stud completely obscures the bolt.
You can sort the draw order of detail components in a view. Draw order options are available when you select detail components in the view.

This functionality is also available in the Family Editor (for detail components in the Detail and Profile families), and for raster images.

To specify element draw order

1 In the drawing area, select a detail component.
   The following tools become available on the Modify <element> tab ➤ Arrange panel.

   ■ (Bring to Front). Immediately places the detail component in front of all detail components in the view.

   ■ (Send to Back). Immediately places the detail component behind all detail components in the view.

   ■ (Bring Forward). Moves the detail component one step closer to the front of all other detail components.

   ■ (Send Backward). Moves the detail component one step closer to the back of all other detail components.

2 Click the desired option to move the component.
Saving Views

You can save 2D views to create a detail library for later use in other projects. This allows for reuse and saves duplication of work. You can save views that contain only view-specific elements, such as drafting views.

To save 2D views, do either of the following:

■ To save a single view, in the Project Browser, right-click the view and click Save to New File. Navigate to the desired location, enter a file name, and click Save.

■ To save several views from the project, select ➤ Save As ➤ Library ➤ View. In the Save Views dialog, select the views to save, and click OK. Navigate to the desired location, enter a file name, and click Save.

For more information, see Reusing Details From Callouts on page 962 and Reusing Drafting Views on page 966.

Detail Views

A detail view is a view of the model that appears as a callout or section in other views. This type of view typically represents the model at finer scales of detail than in the parent view. It is used to add more information to specific parts of the model.

Visibility of a detail view tag depends on the scale of the parent view and whether the crop boundary of the detail view intersects or is entirely within that of the parent view. The detail view parameter Hide at Scales Coarser Than establishes a scale at which details are either shown or hidden in other views. For example, if a detail tag is set to hide at scales coarser than 1/4"=1'-0", then a view with a scale set to 1/8" = 1'-0" would not show the detail tag.

A detail view can be created as a section or a callout. It can have both section and callout annotations assigned to it. That is, a detail view made as a callout can also show up as a section in views that intersect the callout view extents. For example, you may call out a detail view of a wall intersection. This same callout can appear as a section view with annotations within the overall building section view. For annotations to display in the overall building section view, you must select the Intersecting Views option for the Show In instance parameter. You set this parameter in the Properties Palette on page 34.

All detail views, regardless of whether you draw them as a callout or section, show up in the Project Browser as a detail view.

Sample Detail View

The following image shows a sample of a Wall Section Detail with model geometry as the underlay and additional 2D detail components added.
Creating a Detail View

You can create a callout from a plan, section, or elevation view and then add detail components while using the model geometry as a base. When you create a callout or section detail, you can reference another detail or drafting view in the project.

The following is a general procedure for creating a callout or section detail from a Revit Structure view. Your design intentions may differ. You can also use this procedure for imported drawings. See Import/Link Overview on page 57.

1. Do one of the following to activate the view creation tool:
   - Click View tab ➤ Create panel ➤ (Callout).
   - Click View tab ➤ Create panel ➤ (Section).

2. From the Type Selector, select Detail View: Detail.

3. On the Options Bar, select an appropriate detail scale.

4. To reference another detail or drafting view, on the Options Bar, click Reference other view, and select a view from the list.

5. Choose 2 points on the plan view to define where the section is cutting.

   **NOTE** If this is a callout view, select the area to include in the callout view.

6. On the Properties Palette on page 34, for Display Model, select Halftone, and click OK.

   Model elements in the callout view display in halftone, allowing you to visually see the difference between the model geometry and added detail components. (See Halftone/Underlay on page 1605.)
7 Click Annotate tab ➤ Detail panel ➤ (Detail Line).
8 Sketch along lines of the halftone elements or use them as part of your detail. As you sketch lines, the cursor snaps to the model geometry in that view.
9 Sketch lines that provide applicable construction details.
10 If desired, create filled regions. You might create a region to show concrete, grass, or sealant. As you sketch the lines for the region, you can change the line style on the Properties Palette on page 34 by selecting a different value for the Subcategory property. For example, you might want the region boundary to have invisible lines.
11 Add detail components to the detail. See Creating a Detail Component Family on page 968.
12 If desired, add text notes, dimensions, and symbols.
Detail View Properties

Detail View Type Properties

Each detail view has type properties for section tags, callout tags, and reference labels. You can define the appearance of section tags and callout tags. The Reference Label parameter defines the text displayed next to the detail tag when the detail is a reference detail.

Detail View Properties

In addition to many of the properties described under View Properties on page 873, detail views have the following properties, which control the display of the detail view tag.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show in</td>
<td>Indicates whether the detail view tag also displays in views that intersect the parent view.</td>
</tr>
<tr>
<td></td>
<td>A detail view created as a callout displays as a section in intersecting views.</td>
</tr>
<tr>
<td>Hide at scales coarser than</td>
<td>Specifies the scale defining the level of coarseness beyond which the detail view tag is hidden in intersecting views.</td>
</tr>
</tbody>
</table>

Reusing Details From Callouts

Duplicating a Detail View

To copy the model geometry from an existing view into a new view, right-click the existing view in the Project Browser, and click Duplicate View ➤ Duplicate.

If you right-click, and click Duplicate View ➤ Duplicate with Detailing, both the model geometry and the detail geometry are copied into the new view. Detail geometry includes detail components, detail lines, repeating details, detail groups, and filled regions.

NOTE Hidden view-specific elements will not be created in the new view. Hidden model elements and datum will be created in the new view and will remain hidden. For more information on element visibility, see Visibility and Graphic Display in Project Views on page 801.

See also:

- Duplicate Dependent Views on page 843

Referencing a Callout View

When you create a detail callout from a section, plan, or elevation view, on the Options Bar, click Reference Other View to reference any detail or drafting view from the Project Browser. In this way, you can link the view to a particular area of the building information model.

NOTE The Reference Other View option appears when you activate the section or callout view creation tool. Before defining the callout or section, select this option and select the view to reference. See Creating a Detail View on page 960.
The View Name property on the Properties Palette on page 34 shows the name of the view, or if the detail is referencing another view, the name of the referenced view.

**Saving Views to an External Project**

Use the following procedure to save a view to an external Revit Structure project. This operation will save the view and all elements (model elements and view-specific elements) visible in that view to a new project file.

1. Select a view in the Project Browser.
2. Right-click the view name, and click Save to New File.
3. Enter a new name for the Revit Structure file.

**Inserting Detail Components from a Saved Detail View**

1. Click Insert tab ➤ Import panel ➤ Insert from File drop-down ➤ (Insert 2D Elements from File).
2. In the Open dialog, select a project that was saved as a detail view and click Open.
3. In the Insert 2D Elements dialog, select a view that contains the 2D elements you wish to insert.

This copies the 2D Detail Components (repeating details, detail lines, insulation, and filled regions) to the new detail view. Although model geometry is not copied, Revit Structure tries to map the detail components to the new host geometry in the current project. You will probably need to change and edit some of the 2D geometry, but this will give you a head start on your current detail.

The following view-specific elements will not be inserted:
- Edit cut profile elements
- Elements that cannot be grouped (for example, callout elements that create callout views)
- Elements that reference stair railing elements
- Elements that reference toposurface elements
- Elements that reference in-place families
- Elements that reference any elements in this list (for example, dimensions)
Drafting Views

During the course of a project, you may want to create details in a view that are not directly associated with the model. Rather than create a callout and then add details to it, you may want to create detail conditions where the model is not needed (for example, a carpet-transition detail which shows where carpet switches to tile, or roof-drain details not based on a callout on the roof).

You create this unassociated, view-specific detail in a drafting view. The drafting view is not associated with the model. In a drafting view, you create details at differing view scales (coarse, medium, or fine) and use 2D detailing tools: detail lines, detail regions, detail components, insulation, reference planes, dimensions, symbols, and text. These are the exact same tools used in creating a detail view. However, drafting views do not display any model elements. When you create a drafting view in a project, it is saved with the project.

When using drafting views, consider the following:

■ Similar to other views, drafting views are listed in the Project Browser under Drafting Views. See Project Browser on page 28.
■ All of the detailing tools used in detail views are available to you in drafting views. See Detailing Tools on page 955.
■ Any callouts placed in a drafting view must be reference callouts. See Reference Callouts on page 753.
■ Although not associated with the model, you can still drag the drafting views from the browser onto a drawing sheet. See Adding Views to a Sheet on page 980.

Sample Drafting View

The following is a sample drafting view created using the 2D detailing tools in Revit Structure. This is not a 3D view.

Creating a Drafting View

1. Click View tab ➤ Create panel ➤ (Drafting View).
2. In the New Drafting View dialog, enter a value for Name, and select a value for Scale.
If you select Custom, enter a value for Scale value 1.

3 Click OK.
The drafting view opens in the drawing area.

4 In the Project Browser, expand Drafting Views to see the newly created drafting view listed.

5 To create the drafting view, use the detailing tools on the Annotate tab.
The detailing tools include Detail Lines, Insulation, Masking Region, Filled Region, Text, Symbol, and Dimension. See Detailing Tools on page 955.

## Sketching a Detail in a Drafting View

You can sketch a detail in a drafting view with the tools provided with Revit Structure.

1 Click View tab ➤ Create panel ➤ (Drafting View).
2 Enter a name and appropriate scale for the new drafting view.
3 Use Detail Lines, Repeating Details, Detail Components, Masking Regions, and Filled Regions to construct the geometry in this view. See Detailing Tools on page 955.

Also see Drafting Views on page 964 and Sketching on page 1405.

## Importing a View From Another CAD Program

You can import a view from another CAD program and create a detail from that view.

1 Click View tab ➤ Create panel ➤ (Drafting View).
2 Enter a name and appropriate scale for the new drafting view.

3 Click Insert tab ➤ Import panel ➤ ![Import CAD](image)

4 Select the detail and CAD format.
5 Select the Current View Only option if you are in a detail view.

**NOTE** This is automatically selected if you are in a drafting view.

6 Click Open to place the CAD detail.
7 Drag and drop this view on a sheet, if desired.
8 Reference to this view when placing a callout or section, if desired.

### Sample of an Imported Drafting View

The following image shows a sample of imported CAD detail to a drafting view.
Drafting View Display and Filled Regions

The behavior of filled regions changes in drafting views, depending on the display setting.

By default, drafting views display in hidden line. See Hidden Line Visual Style on page 869. You can change the display to wireframe if desired. See Wireframe Visual Style on page 868.

When the drafting view is in hidden line, filled regions with fill patterns hide all elements behind them. For example, if the filled region has a diagonal crosshatch pattern, and the view is in hidden line, you cannot see an element between the openings of the pattern.

If you change the display to wireframe, elements are visible behind openings in the pattern.

Drafting View Properties

Each drafting view has type properties for section tags, callout tags, and reference labels. You can define the look of section tags and callout tags. When the drafting view is a reference view, the Reference Label parameter sets the text displayed next to the view tag.

Reusing Drafting Views

Referencing a Drafting View

When you create a detail callout from a section, plan, or elevation view, you can click Reference Other View on the Options Bar to reference any detail or drafting view from the Project Browser. In this way, you can link the view to a particular area of the building information model.

NOTE The Reference Other View option appears when you activate the section or callout view creation tool. Before defining the callout or section, select this option and select the view to reference. See Creating a Detail View on page 960.

You can link or import standard details from your CAD library into a drafting view. Then you can create a callout in a section, plan, or elevation view that references or points to this drafting view. View tags and annotations will display correctly.
Saving Drafting Views to an External Project

Use the following procedure to save drafting views to an external Revit Structure project for use in another Revit Structure project. You can also use this procedure to save sheet views and schedule views to an external project. For information on sheet views and schedule views, see Sheets on page 978 and Schedule Overview on page 771.

1 Select a drafting view in the Project Browser.
2 Right-click the view name, and click Save to New File.
3 Enter a new name for the project.

This creates a new Revit Structure project file that contains the selected view and the contents of that view.

Inserting a Drafting View from Another Project

1 Click Insert tab ➤ Import panel ➤ Insert from File drop-down ➤ Insert Views from File.
2 In the Open dialog, select a project file, and click Open.

The Insert Views dialog opens, which displays views that are saved in the project.

3 From the list, select an option for views to display.
4 Select the views to insert, and click OK.

Revit Structure creates a new drafting view with all the 2D components and text. If you have duplicate type names, the type name and properties from the current project are used, and a warning message displays.

Related topics

- Inserting Schedule Views from Another Project on page 797
- Inserting Detail Components from a Saved Detail View on page 963
- Saving Views to an External Project on page 963

Inserting a Detail Component

The Detail Component tool places a detail component into a detail or drafting view. A detail component is visible in that view only. You can keynote detail components. See Keynotes on page 938.

To insert a detail component

1 Click Annotate tab ➤ Detail panel ➤ Component drop-down ➤ (Detail Component).
2 From the Type Selector, select the appropriate detail component to place.
3 Press SPACEBAR to rotate the detail component through its different snap points to other elements.
4 Place the detail component in the detail view.

You can add additional detail components by loading them from the family library, or you can create or edit existing ones in the Family Editor. Revit Structure contains over 500 Detail Component Families. They are organized by the 16 CSI (Construction Specifications Institute) divisions.

Detail components can be tagged using detail item tags. To load tags into the project, click Insert tab ➤ Load from Library panel ➤ (Load Family).
Creating a Detail Component Family

A detail component family consists of components added to detail or drafting views, and they are visible only in those views. They scale with the model, rather than the sheet. Detail components could include a 2X4, a metal stud, or a shim.

Before reading this topic, familiarize yourself with families. See The Families Guide on page 680.

The following procedure is a general procedure for creating a detail component family. Your steps may differ depending on your design intent.

1. In the Family Editor, sketch reference planes for placing the detail component.
2. Use tools on the Create tab to create the shape of the detail component. A detail component is displayed in a symbolic form and is not shown in 3D. Click the Line tool to sketch the symbol.

   TIP You can change the sorting order of objects in the family by using the detail component draw order tools. For more information, see Sorting the Draw Order of Detail Components on page 958.

3. For lines, select the line and click Modify | Lines tab ➤ Mode panel ➤ (Visibility Settings), and select the views in which the object will be visible.
   For filled regions, select the filled region and click Modify | Detail Items tab ➤ Mode panel ➤ (Visibility Settings), and select the views in which the object will be visible.
4. Save the detail component.

Creating a 2D Line-Based Detail Component Family

Detail components are pre-drawn line-based 2D elements that you can add to detail or drafting views. They are visible only in those views. They scale with the model, rather than the sheet.

For example, in the following drafting view, the studs, insulation, and siding are detail components.

Revit Structure allows you to create a 2D detail component based on a line. By selecting the start and end of the line, you can place the detail. Suppose you want to place a plywood fill pattern in a section. By selecting the start and end points of the detail component, you can place the detail with the thickness and fill pattern that was created in the 2D detail component. For example, if the plywood is drawn at 1/2” in the 2D detail component, this procedure would place a piece of plywood along the length of the drawn line at 1/2”. If you wanted to adjust the thickness of the plywood, you would first have to edit the 2D detail component.

Before reading this topic, familiarize yourself with families. See The Families Guide on page 680.
The following is the general procedure for creating a 2D line-based detail component family. Your steps may differ depending on your design intent.

1. Create a new family using the Detail Component line-based template.
2. Use tools on the Create tab to create the shape of the detail component. A detail component is displayed in a symbolic form and is not shown in 3D. Click the Line tool to sketch the symbol. Create the component between the 2 reference planes to have elements contract or expand based on the length.

**TIP** You can change the sorting order of objects in the family by using the detail component draw order tools. For more information, see *Sorting the Draw Order of Detail Components* on page 958.

3. For lines, select the line and click Modify | Lines tab ➤ Mode panel ➤ (Visibility Settings), and select the views in which the object will be visible.
   For filled regions, select the filled region and click Modify | Detail Items tab ➤ Mode panel ➤ (Visibility Settings), and select the views in which the object will be visible.
4. Save the detail component.

**Detail Lines**

The Detail Line tool creates detail lines for detailing drawings. Detail lines are visible only in the view in which they are drawn. Often they are drawn over the model view. You can convert detail lines to model lines. See *Converting Line Types* on page 570.

**NOTE** If you want to sketch lines that exist in 3D space and display in all views, see *Model Lines* on page 569.

The Detail Line tool has the same line styles as the Line tool, but detail lines are view-specific, like detail components and other annotations.

Detail lines are drawn in the view’s sketch plane. They can be used to detail a view with part of the model visible, such as in a wall section or callout. Or detail lines can be used in a drafting view to draft lines with no reference to the model. Some examples of detail lines in a drafting view are signage or typical details that have no reference to the model.

You can also use detail lines for tracing over underlay elements. See *View Properties* on page 873 for more information on setting elements as underlays.

Before using this tool, you should read *Creating Details* on page 955.

1. Click Annotate tab ➤ Detail panel ➤ (Detail Line).
2. Sketch lines as appropriate.

**Repeating Detail**

With the Repeating Detail tool, you sketch a path defined by 2 points. The path is then filled in with a pattern of detail components. The pattern is a family type called a repeating detail. You can control the appearance of the family through its type properties. The type properties include the detail component family that is applied to the repeating detail, and the spacing of the individual detail components that compose the repeating detail. A repeating detail is essentially an array of a detail component. Like other detailing tools, a repeating detail is visible only in the view in which it is drawn.

Repeating details are primarily useful in plan and section views.
To create a repeating detail

1. Click Annotate tab ➤ Detail panel ➤ Component drop-down ➤ (Repeating Detail).
2. Sketch the repeating detail, and then click Modify.
3. Click Modify ➤ Detail Items tab ➤ Properties panel ➤ (Type Properties).
4. In the Type Properties dialog, click Duplicate, and enter a name for the repeating detail type.
5. Select a detail component for the Detail parameter.
   If desired, load more detail components from the standard Revit Structure library, or create your own. See Loading Families on page 688 for more information about loading a detail component family. See Creating a Detail Component Family on page 968 for more information about creating a detail component family.
6. Set the Layout for the repeating detail:
   - Fill Available Space indicates that the detail component is repeated along the length of the path, such that the spacing is equal to the width of the component.
   - Fixed Distance indicates that the detail component is spaced at the exact value specified for the Spacing parameter, starting from the beginning of the path. See the description for Spacing below.
   - Fixed Number indicates that a defined number of detail components are placed along the path, while the spacing is adjusted to maintain this number. After setting this type parameter, you need to define the Number parameter in the family’s instance properties.
   - Maximum Spacing indicates that the detail component is spaced at an even interval along the length of the path and at a distance up to the value specified for Spacing. The actual spacing used may be less to ensure a complete component at either end of the path.
7. Select the Inside parameter to confine the spacing of the detail components to within the length of the path.
   If you do not select this parameter, the first and last detail components are placed according to the defined origin of the detail component family. This means that the first and last detail components can extend beyond the length of the path.
8. If you set Layout to Fixed Distance or Maximum Spacing, the Spacing parameter becomes enabled. Enter a value for this parameter.
9. If desired, indicate how you want the detail component to be rotated in the pattern.
10. Click OK to close the Type Properties dialog.
11. If you set the Layout parameter to Fixed Number, on the Properties Palette on page 34 and enter a value for Number parameter.
12. From the Type Selector, select the repeating detail that you created.
13. Sketch the repeating detail component in the family by clicking once for a start point, dragging the mouse, and clicking again for an end point.
   The following image shows the addition of a welded wire fabric family to a concrete slab in section view.

The following image shows the addition of a welded wire fabric family to a concrete slab in section view.
The following image shows a repeating pattern placed between 2 walls. The pattern has a fixed number of 10 and a length of 6 feet.

**Insulation**

The Insulation tool places a batt insulation graphic for detail views.

**Adding Insulation**

1. Click Annotate tab ➤ Detail panel ➤ (Insulation).
2. Sketch the insulation in a detail view.
   - Insulation is sketched similar to lines. You can set an offset from the cursor, and you can pick a line on which to sketch the insulation. See Model Lines on page 569.

**Increasing the Insulation Size**

1. Select the insulation.
2. On the Properties Palette on page 34, specify a value for Insulation Width.

**Resizing the Insulation Length**

1. Select the insulation.
2 Click and drag one of the blue dot controls that appear on the ends of the insulation. See Controls and Shape Handles on page 1449.

Resizing the Bulge Between Insulation Lines
1 Select the insulation.
2 On the Properties Palette on page 34, specify a value for the Insulation Bulge to Width Ratio (1/x).
   A smaller value increases the bulge, while a larger value decreases it.

Filled Region
The Filled Region tool creates a 2-dimensional, view-specific graphic with a boundary line style and fill pattern within the closed boundary. The filled region is parallel to the view's sketch plane. The tool is useful for defining a filled area in a detail view or for adding a filled region to an annotation family.

Filled regions contain a fill pattern. Fill patterns are of 2 types: Drafting or Model. Drafting fill patterns are based on the scale of the view. Model fill patterns are based on the actual dimensions in the building model.

The following procedure is a general method for creating a filled region. Steps may vary depending on your design intent.

1 Click Modify | Create Filled Region Boundary tab ➤ Line Style panel, and select a boundary line style from the Line Styles drop-down.
2 Sketch the region using the sketch tools on the Draw panel.
   For example, you might sketch a square region. For more information about the sketching tools, see Sketching on page 1405.
3 To give the region a fill pattern, on the Properties Palette on page 34, click Edit Type and then select a fill for the Fill Pattern property.
4 To set different line styles for the region lines, select the lines, and on the Properties Palette on page 34, change the value for the Subcategory property.
5 Click Finish Edit Mode to complete your sketch.

Changing Filled Region Properties
1 Select the completed detail filled region.
2 Click Modify | Detail Items tab ➤ Properties panel ➤ (Type Properties).

TIP You can also open properties through the Project Browser. In the browser under Families, expand Detail Items. Expand Filled Region. Right-click the region type name (for example, Filled Region 1) and click Properties.

3 You can set Fill pattern, Background, Line Weight Number, and Color for the region. With Background, you can set it to opaque or transparent.

Resizing the Filled Region
1 In the drawing area, select the filled region.
   This displays shape handles on the region.
2 Click to select the shape handle.
3 Drag the handles to resize the region.

Viewing the Area of a Filled Region

1 Select the filled region in the drawing area.
2 On the Properties Palette on page 34, view the Area instance parameter.

The area value is the area of the region’s closed perimeter loop, less the area of any closed loops within the perimeter. The area property is reported in the project units (for example, square meters or square feet). The area property is read-only and cannot be scheduled or tagged.

Masking Regions

Masking regions provide a way to obscure elements in a view. Masking regions may be useful in scenarios like the following:

■ You need to obscure elements in a project.
■ You are creating a detail family or a model family and need the background of the element to mask the model and other detail components when it is loaded into a project.
■ You need to create a model family (from imported 2D DWG files) that obscures other elements when placed in a view.

You can create 2D and 3D masking regions. 2D masking regions can be created in a project and in the Family Editor when you are creating a 2D family (annotation, detail, or title block). 3D masking regions can be created in the Family Editor when you are creating a model family.

Masking regions do not participate in shading; they are always drawn the background color of the drawing area. Masking regions cannot be applied to element subcategories.

Exporting Masking Regions to DWG

When you export a project or family that contains a masking region, any lines that intersect the masking region terminate at the masking region so that graphical intent is maintained in the DWG file.

Adding a Masking Region in a Project

1 Click Modify | Create Filled Region Boundary tab ➤ Line Style panel, and select the boundary line style from the Line Styles drop-down list.
2 Sketch the masking region (or regions). Masking region sketches must be closed loops.
   For more information on sketching, see Sketching on page 1405.
3 When finished, click Finish Edit Mode.

After you add a masking region, you can sort the draw order. For more information, see Sorting the Draw Order of Detail Components on page 958.

Adding a Masking Region to a Detail Family

1 In the Family Editor, click Create tab ➤ Detail panel ➤ (Masking Region).
2 Click Modify | Create Filled Region Boundary tab ➤ Line Style panel, and select the boundary line style from the Line Styles drop-down.
3 On the Properties Palette on page 34, specify properties for the masking region:
   ■ **Visible**. Specify if the masking region is visible when the family is loaded into a project and placed in the drawing area.
   ■ **Visibility/Graphics Overrides**. Specify the detail levels at which the masking region is visible (coarse, medium, or fine).

4 Sketch the masking region (or regions). Masking region sketches must be closed loops.
   For more information on sketching, see Sketching on page 1405.

5 When finished, click Finish Edit Mode.

The following is a sample detail family with a masking region applied. You can view this detail family by opening the Nominal Cut Lumber-Section family in the following directory:

Imperial (or Metric) Library\Detail Components\Div 06 - Wood and Plastic\06100 - Rough Carpentry\06110 - Wood Framing

After you add a masking region, you can sort the draw order. For more information, see Sorting the Draw Order of Detail Components on page 958.

### Masking Regions in Model Families

When you add a masking region to a model family, several parameters allow you to control the visibility of the masking region and where the masking region is drawn. You can specify the following properties for masking regions in model families:

■ If the masking region is visible when the family is loaded into a project and placed in the drawing area.

■ The detail levels at which the masking region is visible (coarse, medium, or fine).

■ Where the masking region is drawn. This is controlled by the Draw in Foreground parameter. When this parameter is selected, the masking region is drawn at the detail plane of the view (the plane that is closest to you as you look at the view). When this option is not selected, the masking region is drawn on the work plane on which it was sketched.

#### Adding a Masking Region to a 2D Element in a Model Family

If you create a model family that only contains 2D elements (for example, a 2D toilet fixture) and you want to apply a masking region to the 2D element, you must include an invisible line to represent the Z dimension, which is where the masking region is drawn. The invisible line must be drawn above the level and must be a minimal length (such as 1/8") so that the masking region does not obscure any other elements in the view.

### Adding a Masking Region to a Model Family

1 In the Family Editor, click Create tab ➤ Detail panel ➤ (Masking Region).

2 Click Modify | Create Filled Region Boundary tab ➤ Line Style panel, and select the boundary line style from the Line Styles drop-down list.

3 On the Properties Palette on page 34, specify properties for the masking region:
   ■ **Draw in Foreground**. Specify where you want the masking region drawn. When this parameter is selected, the masking region is drawn at the detail plane of the view (the plane that is closest to you as you look at the view). When this option is not selected, the masking region is drawn on the work plane on which it was sketched. For more information on using the Draw in Foreground parameter, see Masking Regions in Model Families on page 974.
Visible. Specify whether the masking region is visible when the family is loaded into a project and placed in the drawing area.

Visibility/Graphics Overrides. Specify the detail levels at which the masking region is visible (coarse, medium, or fine).

4 Sketch the masking region (or regions). Masking region sketches must be closed loops.
   For more information on sketching, see Sketching on page 1405.

   IMPORTANT If your model family only contains 2D elements (for example, a 2D toilet fixture) and you want to apply a masking region to the 2D element, you must include an invisible line to represent the Z dimension, which is where the masking region is drawn. The invisible line must be drawn above the level and must be a minimal length (such as 1/8") so that the masking region does not obscure any other elements in the view.

5 When finished, click Finish Edit Mode.

Creating a Model Family with Masking Regions from 2D DWG Files

1 Click ➤ New ➤ Family.
2 In the New Family dialog, select a default family template (for example, Plumbing Fixture wall based.rft), and click Open.
3 Open the view to import the DWG file into.
   For example, if you have a DWG file for a plan representation, open the plan view.

4 Click Insert tab ➤ Import panel ➤ (Import CAD).
5 In the Import CAD Formats dialog, navigate to the DWG file.
   If you only want the representation to be visible in plan view, select the Current View Only option. Also, if you are unsure of the original coordinates of the DWG file, for Positioning, select Manual - Center.
6 Click Open.
7 Click in the drawing area to place the import symbol.
8 Modify the position of the import symbol as necessary, and lock the symbol to the necessary reference planes.
9 Sketch the masking region.

   IMPORTANT When a model family only contains 2D elements and you are adding a masking region to a 2D element, you must include an invisible line to represent the Z dimension, which is where the masking region is drawn. The invisible line must be drawn above the level and must be a minimal length (such as 1/8") so that the masking region does not obscure any other elements in the view.

10 Add any other 2D view representations (for example, front elevation and side elevation) and masking regions, as necessary.
11 When finished, click on the Quick Access toolbar to save the family.
12 If you need to load the family into a project, click Create tab ➤ Family Editor panel ➤ (Load into Project).
   If you have only one project open, the family loads into that project. If you have multiple projects open, the Load into Projects dialog opens where you can select the projects to load the family into.
When you load the family into a project and place it in the drawing area, it obscures surface patterns in orthogonal views.

**Masking Region Properties**

### Properties for Masking Regions in Projects

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Area</td>
<td>The area of the masking region. This is a read-only value.</td>
</tr>
</tbody>
</table>

### Identity Data

| Comments      | Comments for the masking region.                                             |

### Properties for Masking Regions in 2D and 3D Families

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Draw in Fore-ground</td>
<td>Draws the masking region on the closest work plane in the view. This property is only available in the Family Editor when you are creating or modifying a 3D family. For more information, see Masking Regions in Model Families on page 974.</td>
</tr>
<tr>
<td>Work Plane</td>
<td>The work plane of the masking region. This is a read-only value and is only available in the Family Editor.</td>
</tr>
</tbody>
</table>

### Graphics

<table>
<thead>
<tr>
<th>Visible</th>
<th>Determines whether the masking region is visible when the family is loaded into a project, and then placed in the drawing area. This property is only available when you are creating or modifying a masking region in the Family Editor.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visibility/Graphics Overrides</td>
<td>Select the detail level at which you want the masking region to display in a project: Coarse, Medium, or Fine. Detail levels are dependent on the view scale. This property is only available in the Family Editor.</td>
</tr>
</tbody>
</table>

### Dimensions

| Area         | The area of the masking region. This is a read-only value.                  |

### Identity Data

| Comments      | Comments for the masking region.                                             |
Preparing Construction Documents

To create a construction document set in Revit Structure, you create sheets, and add drawings and schedules to the sheets. Then you can print the sheets or publish them in another format, such as DWF, for electronic sharing and review. You can send the construction documents to the field, where clients or reviewers can mark up the designs for revisions. Revit Structure provides tools for tracking the revisions.

Related topics
- Document the Project on page 723
- Dimensions on page 887
- Annotating on page 887

Construction Documents Overview

Construction documents are the records that you share with clients, engineers, and construction professionals to communicate a design. For example, clients need to see floor plans, elevations, and 3D drawings of the design for approval. Engineers from other disciplines will want to see those drawings, as well as more detailed drawings, to help them understand the building model and how it affects their work. Construction professionals need all of these drawings, as well as schedules and material takeoffs, to build the design.

A construction document set (also called a drawing set or a sheet set) consists of several sheets. Each sheet contains one or more drawings and schedules for the building design.
Sheets

In Revit Structure, you create a sheet view for each sheet in a construction document set. You can then place multiple drawings or schedules on each sheet.

Sheets Overview

A sheet (also called a drawing sheet) is an individual page of a construction document set. In Revit Structure, you create a sheet view for each sheet in the construction document set. You can then place multiple drawings or schedules on each sheet view.
Parts of a sheet

When you add sheets to a Revit project, they are listed in the Project Browser under Sheets (all).

As you move a drawing or schedule onto a sheet, a viewport displays. A viewport is a representation of the drawing or schedule when it is placed on a sheet.

Sheets in Project Templates

When creating a project template, you can include sheets in the template. Start with a blank project file, and create the standard views and levels that each project should include. Leave the views empty, but assign standard names to them. To create a standard set of construction documents, create sheets using the desired title blocks. Add views to the sheets, using the desired viewport templates and view title types. Then save the empty project as a project template. (See Project Templates on page 1633.)

When you create a project using this project template, all of the views and sheets are already created and listed in the Project Browser. As you start to draw the building model in the project views, the views on the sheets update automatically. This technique streamlines the project documentation process and maintains organizational standards.

Adding a Sheet

1 Open the Revit project.

2 Click View tab ➤ Sheet Composition panel ➤ (Sheet).

3 Select a title block, as follows:
   a In the New Sheet dialog, select a title block from the list.
If the list does not show the desired title block, click Load. In the Library folder, open the Titleblocks folder, or navigate to the folder where the title block resides. Select the title block to load, and click Open.

Select None to create a Sheet without a title block.

b Click OK.

For information about title blocks, see Title Blocks on page 995.

4 Enter information in the title block of the sheet.
See Specifying Title Block Information for Sheets on page 985.

5 Add views to the sheet.
See Adding Views to a Sheet on page 980.

6 Change the default number and name that Revit Structure assigned to the sheet.
See Renaming a Sheet on page 985. The sheet number and name display in the Project Browser under Sheets (all).

NOTE To track printing times, Revit Structure displays a date and time stamp on sheets. To format the display of this stamp, modify the regional and language settings on your computer.

Related topics
■ Sheets Overview on page 978
■ Creating a Title Sheet on page 989
■ Sheet Properties on page 993

Adding Views to a Sheet

You can add one or more views of a building to a sheet, including floor plans, site plans, ceiling plans, elevations, 3D views, sections, detail views, drafting views, and rendered views. Each view can be placed on one sheet only. To add a particular view to multiple sheets in a project, create duplicate views, and place each one on a different sheet.

NOTE You can also place legends and schedules (including view lists and sheet lists) on sheets. Legends and schedules can be placed on multiple sheets. See Adding a Schedule to a Sheet on page 1011.

To add views to a sheet

1 Open the sheet.
2 To add a view to the sheet, use one of the following methods:
   ■ In the Project Browser, expand the list of views, locate the view, and drag it onto the sheet.
   ■ Click View tab ➤ Sheet Composition panel ➤ (Place View). In the Views dialog, select a view, and click Add View to Sheet.

3 As you move the cursor over the sheet in the drawing area, a viewport for the selected view moves with it. Click to place the viewport in the desired location. Use the Guide Grid for precise placement on sheets.
4 Repeat Steps 2 and 3 to add more views to the sheet, if desired.
If needed, you can modify the individual views on the sheet as follows:

- To change the view title that displays on the sheet, double-click the title, and edit it. See View Titles on Sheets on page 1007.
- To move the view to a new location on the sheet, select its viewport, and drag it. You can align views to grid lines for precise placement. See Aligning Views on a Sheet on page 982.

You can now do any of the following, as explained in Modifying a View on a Sheet on page 987:
- Change the scale of the view.
- Add dimensions to the view.
- Add text notes to the view.
- Pan the view.

Related topics
- Aligning View Titles on a Sheet on page 984
- Locking the Position of a View on a Sheet on page 984
- Dividing a View Across Multiple Sheets on page 987
- Rotating a View on a Sheet on page 988

Hiding Parts of a View on a Sheet

When placing a particular view on a sheet, you can use the following techniques to hide parts of the view to focus on one area:

- **Crop region**: Use the crop region to focus the view on a particular area of the building model. See Crop Regions on page 849.

- **Masking regions**: Use masking regions to hide areas of the view (within the rectangular crop region) that are not relevant. See Masking Regions on page 973.
Applying Standard Settings to a View on a Sheet

You can apply standard settings to a view on a sheet by using a viewport type. For example, you can create a viewport type that does not display a view title on a sheet, or that uses a different color and weight for the line that separates the drawing from its title. See Viewport Types on page 1006.

Aligning Views on a Sheet

You can add guide grids to sheets to align views so that they appear in the same location from sheet to sheet. You can display the same guide grid in different sheet views. Guide grids can be shared between sheets. When new guide grids are created, they become available in the instance properties of sheets and can be applied to sheets. It is recommended to create only a few guide grids and then apply them to sheets. When you change the guide grid's properties/extent in one sheet, all the sheets which use that grid are updated accordingly.

To align views to grid lines on the current sheet

1. Open a sheet view.
2. Click View tab ➤ Sheet Composition panel ➤ (Guide Grid).
3. In the Guide Grid Name dialog, enter a name, and click OK.
4 Click and drag the extent controls to specify the extents of the guide grid.

The default guide grid extents match the sheet extents plus an offset. If the sheet is empty, the extents will be 36" by 24" 900 mm by 600 mm.

5 (Optional) Drag additional views onto the sheet.

6 Select a placed viewport, and on the ribbon click (Move).

7 Snap to the crop regions or datums in the viewports and move them into alignment with the guide grid lines to specify a precise location on the sheet.

No constraints will be created between the guide grid and other elements on the sheet.

To apply a guide grid to a sheet

1 Open a sheet view.
2 On the Properties palette, for Guide Grid, select a guide grid to add to the sheet.

To change the line styles for guide grids

1 In a project, click Manage tab ➤ Settings panel ➤ (Object Styles).
2 Click Annotation Objects tab.
3 Under Category, select Guide Grid.
4 Use the Line Weight, Line Color, and Line Pattern columns to specify the desired settings.
5 Click OK.

To modify guide grids

1 Select a guide grid.
2 Click Modify Guide Grid tab ➤ Properties panel ➤ (Properties).
4 Under Identity Date, specify the guide grid Name.
Aligning View Titles on a Sheet

When positioning views on a sheet, you can align the view titles. The view titles stay aligned even if the size of a viewport changes.

**NOTE** This method of aligning views on a sheet does not apply to schedules.

**To align views on a sheet**

1. In a project, add 2 or more views to a sheet.
   
   See *Adding Views to a Sheet* on page 980.

2. Drag a view to the desired location on the sheet.

3. If desired, change the length of the horizontal line that displays in the view title.
   
   See *Modifying a View Title on a Sheet* on page 1008.

4. Drag the second sheet to the desired location.
   
   When the view title of the second sheet aligns (vertically or horizontally) with the view title of the first sheet, Revit Structure displays a dashed line.

5. *(Optional)* Lock the views in place on the sheet.
   
   See *Locking the Position of a View on a Sheet* on page 984.

Locking the Position of a View on a Sheet

After placing a view (or schedule) on a sheet and positioning it as desired, you can lock it in place so that it cannot be moved inadvertently.

**To lock a view on a sheet**

1. Open the sheet.

2. Select the view to lock in place on the sheet.

3. Click Modify | Viewports tab ➤ Modify panel ➤ (Pin).

4. The pin icon displays on the view, indicating that it is locked in place.
To unlock a view on a sheet

1 On the sheet, select the locked view.
   The pin icon displays on the view, indicating that it is locked in place.
2 Click the pin icon.
   The pin icon changes, indicating that the view is no longer locked in place. To move the view
   on the sheet, drag it to a new location.

Renaming a Sheet

1 In the Project Browser, under Sheets (all), right-click the sheet name, and click Rename.
2 In the Sheet Name dialog, enter a new number and name for the sheet, and click OK.
   Changes to the sheet number and name are propagated throughout the project, so that all references to the
   sheet are accurate.
   As an alternative, you can change the sheet number and name as follows: on the Properties palette for the
   sheet, change the values of the Sheet Number and Sheet Name properties.

Specifying Title Block Information for Sheets

A title block typically displays information about the project, as well as information about individual sheets. Use the following procedures to specify the information that you want to display in the title blocks of sheets in a project.

**NOTE** To add custom fields to a title block, see Adding Custom Fields to a Title Block on page 1003.
Entering Project-Specific Information

Project-specific information is data that remains the same on all sheets of a project. Examples include the project issue date and status, the client name, and the project’s address, name, and number.

To update the title block of a sheet with project-specific information, open the project, and use either of the following methods:

■ Enter the information directly on a sheet. Open a sheet. Click on the placeholder text for project-specific information in the title block. Update the text as desired.

■ Change project information settings. Click Manage tab ➤ Settings panel ➤ (Project Information). Under Other, enter values for the project information parameters. Click OK.

Revit Structure updates all sheets in the project with the new information.

Entering Sheet-Specific Information

Sheet-specific information is data relating to an individual sheet in a project, such as the sheet name and number, designer, and reviewer.

To update the title block of a sheet with sheet-specific information, open the project, and use either of the following methods:

■ Enter the information directly on a sheet. Open a sheet. Click on the placeholder text for sheet-specific information in the title block. Update the text as desired.

■ Change sheet properties. Open a sheet. On the Properties palette for the sheet, change the values of the sheet-specific parameters that display in the title block.
Modifying a View on a Sheet

1 Open the sheet.
2 In the drawing area, select a view on the sheet.

TIP If views on the sheet overlap, press Tab until the correct view highlights. Watch the status bar for the description of the viewport.

3 Click Modify | Viewports tab ➤ Viewport panel ➤ (Activate View).
Revit Structure displays the sheet title block and its contents in halftone. Only the contents of the active view display normally. You can now edit the view as desired. You can zoom in to the drawing area to see the elements more clearly.

4 Modify the view as desired.
For example, you can do the following:
- Add dimensions. See Placing Permanent Dimensions on page 889.
- Add text notes. See Adding Text Notes on page 926.
- Pan the view within its viewport, so that only a portion of the view is visible on the sheet. The crop region for the view does not move. Right-click the activated view, and click Pan Active View. Drag the cursor to pan the view.
- Change the scale of the view. On the View Control Bar, for Scale, select the desired scale.

5 To deactivate the view on the sheet, click View tab ➤ Sheet Composition panel ➤ Viewports drop-down ➤ (Deactivate View).

Dividing a View Across Multiple Sheets

Sometimes a large view does not fit on a single sheet. In this case, you must create multiple sheets for the view, divide the view into parts, and show one part on each sheet. Or perhaps a view is too tall or wide for a sheet, and you want to show parts of the view next to each other on the same sheet.

To address these issues, use dependent views as follows.

To divide a view across multiple sheets

1 In a project, create and prepare the view that you want to divide into parts.
Add all annotations, details, dimensions, and other information required. See Document the Project on page 723.

2 Create dependent views.
   See Creating Dependent Views on page 847.
   - In each dependent view, use crop regions to show the part of the model to display in that view, and the annotations to include. If any unwanted annotations or model elements display in a dependent view, right-click the element, and click Hide in view ➤ Elements.
   - In the primary view, add matchlines to indicate where the view is split.
     See Adding Matchlines for Dependent Views on page 845.

3 Create the sheets on which to place the dependent views.
   See Adding a Sheet on page 979.

4 Add the dependent views to their respective sheets.
   See Adding Views to a Sheet on page 980.

5 (Optional) Add view references to the primary view.
   View references indicate the sheet on which each dependent view displays. For instructions, see Navigating Primary and Dependent Views on page 817.

---

Rotating a View on a Sheet

You can rotate a view (or a schedule) on a sheet 90 degrees in either direction (clockwise or counterclockwise).

To rotate a view on a sheet

1 In a Revit project, open the sheet.
2 On the sheet, select the view to rotate.

**NOTE** You cannot rotate an active view. If the title block displays in halftone and you can select elements in the view, the view is active. Right-click the view, and click Deactivate View.

3 On the Options Bar, for Rotation on Sheet, select the desired rotation option.

The view rotates on the sheet.

### Creating a Title Sheet

A construction documentation set usually includes a title sheet (also called a cover sheet). The title sheet typically includes a rendering, 3D drawing, or other view of the building model. It may also include the following types of information:

- Table of contents (also called a sheet list, drawing index, or sheet index)
- Project name and address
- Client information
- Vicinity plan
- Zoning information
- Code compliance information
- List of project team members
- Legal description of the property and its boundaries
- General notes

Because it includes different types of information than other sheets in the set, the title sheet typically uses a different format. You may need to create a title block specifically designed for the title sheet. See **Title Blocks** on page 995.
To create a title sheet

1. Add a sheet to the project, using the appropriate title block.
   See Adding a Sheet on page 979.

2. Rename the sheet to indicate that it is the title sheet.
   See Renaming a Sheet on page 985.

3. Add the desired view to the sheet.
   See Adding Views to a Sheet on page 980.

4. Create a sheet list, omit the title sheet from the list, and add the sheet list to the sheet.
   See Sheet Lists on page 1015.

5. Add the required information to the title sheet.
   The title block for the title sheet typically includes fields where you enter information about
   the project. Click the text areas to enter text. See Specifying Title Block Information for Sheets
   on page 985.

Adding a Legend to a Sheet

Like a map legend, a legend on a sheet helps the building professional to interpret the drawings correctly.

Types of legends

In a construction document set, you can include the following types of legends:

- **Component legend**: A list of components used in the building model, with details about their structure,
  representation in drawings, or visual appearance. For a sample component legend, see Legend Views on
  page 767.

- **Keynote legend**: A list of keynotes used to document the building model. See Keynote Legend on page
  941.

- **Symbol legend**: A list of the symbols that are used in drawings, similar to the following.

```
SYMBOLS:

SECTION DESIGNATION
- INDICATES SECTION OR DETAIL
SHEET NUMBER WHERE SECTION APPEARS

X
- INDICATES FINISH CONCRETE SLAB ELEVATION.

■
- INDICATES SQUARE HSS STEEL COLUMN.

I
- INDICATES WIDE FLANGE STEEL COLUMN.

X
- INDICATES COLUMN GRID.
```

To add a legend to a sheet

1. Create the legend view in the project.
   For component legends and symbol legends, see Legend Views on page 767. For keynote legends,
   see Keynote Legend on page 941.
2 Open the sheet on which you want to place the legend view.
3 In the Project Browser, expand Legends, click the name of the legend view, drag it into the drawing area, and click to place it on the sheet.
   You can place a legend view on multiple sheets.
4 (Optional) For a component legend or symbol legend, hide the view title.
   See Removing a View Title from a Sheet on page 1009.
5 (Optional) For a keynote legend, do the following:
   ■ Filter the legend based on the views included on the sheet. See Filtering Keynotes by Sheet on page 942.
   ■ Modify the way the keynote legend displays on the sheet. See Schedules on Sheets on page 1011.

Adding a Note Block to a Sheet

A note block (also called an annotation schedule) is a list of construction notes for a drawing. You can create a note block and place it on a sheet to document the building model.

You can also document a building model using keynote legends. See Adding a Legend to a Sheet on page 990.

To add a note block to a sheet

1 In the project, create the project view to annotate.
   See Document the Project on page 723.
2 Add notes to the view, and create the note block.
   See Creating an Annotation Schedule (Note Block) on page 774.
3 Add a sheet.
   See Adding a Sheet on page 979.
4 Place the note block on the sheet, as follows:
   a In the Project Browser, expand Schedules/Quantities.
   b Select the name of the note block, drag it onto the sheet, and click to place it.
Using External Information on a Sheet

You can include information that is external to a Revit project on the sheets that Revit Structure generates. You can use external text, spreadsheets, and images on Revit sheets.

Adding Text from a File to a Sheet

1. In the Revit project, open the sheet.
2. Click Annotate tab ➤ Text panel ➤ (Text).
3. Click Modify | Place Text tab ➤ Format panel ➤ (No Leader).
4. Click in the drawing area to place the text insertion point.
5. On the Windows desktop, open the text document, and copy its contents to the clipboard.
6. In Revit Structure, press Ctrl+V, or click Modify | Place Text tab ➤ Clipboard panel ➤ Paste drop-down ➤ (Paste from Clipboard).

The text box expands to contain the copied text. You can move the text box on the sheet, and edit its contents directly. (Editing its contents does not change the original document from which it was copied.) See Modifying Text Notes on page 929.

Adding a Spreadsheet to a Sheet

1. In the spreadsheet application, open the spreadsheet. Display the data as you want it to display on the Revit sheet.
2. Use a screen capture utility to take a screenshot of the spreadsheet.
   For example, you can use a screen capture utility such as SnagIt® by TechSmith Corporation or !Quick Screen Capture by Etrusoft, Inc.
   Save the image using one of the following file types: BMP (bitmap), JPEG, JPG, PNG (portable network graphics), and TIFF.
3 Add the spreadsheet image to the Revit sheet.
See Adding an Image to a Sheet on page 993.

Adding an Image to a Sheet

1 Prepare the image file.
   Revit Structure supports the following image file types: BMP (bitmap), JPEG, JPG, PNG (portable network graphics), and TIFF.

2 In the Revit project, open the sheet.

3 Click Insert tab ➤ Import panel ➤ (Image).

   **NOTE** If the legacy details are stored using a CAD format, such as DWG, click Insert tab ➤ Import panel ➤ (Import CAD).

4 In the Import Image dialog, navigate to the location of the image file.
5 Select the image file, and click Open.
6 Click in the drawing area to place the image on the sheet.

To reposition the image, drag it to the desired location on the sheet. To resize the image, select it and drag a blue corner dot, or enter the desired height and width on the Properties palette.

Sheet Properties

Use sheet properties to control the appearance and behavior of a sheet. For example, you can specify the sheet name and number, and whether the sheet is included in the sheet list. You can also use sheet properties to define information that displays on the sheet, such as the issue date, designer, and reviewer.

**NOTE** To track printing times, Revit Structure displays a date and time stamp on sheets. To format the display of this stamp, modify the regional and language settings on your computer.

Modifying Sheet Properties

To modify sheet properties, do either of the following:

- In the Project Browser, right-click the sheet name, and click Properties.

- Open the sheet and click in the drawing area. The Properties palette displays sheet properties.

You can modify the properties of multiple sheets in one operation. For example, you can change the Sheet Issue Date for several sheets in one step. In the Project Browser, while pressing Ctrl, click to select non-adjacent sheet names, or while pressing Shift, click to select adjacent sheet names. Then right-click, and click Properties. When you use this method, changes that you make to the sheet properties affect all selected sheets.
# Sheet Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visibility/Graphics Overrides</td>
<td>Click Edit to display the Visibility/Graphics Overrides dialog for the sheet. See Visibility and Graphic Display in Project Views on page 801.</td>
</tr>
<tr>
<td>Scale</td>
<td>The scale of the views on the sheet. If the sheet contains multiple views displayed at different scales, this parameter shows the value As indicated.</td>
</tr>
<tr>
<td>Dependency</td>
<td>Indicates whether views on the sheet are dependent on other views. See Duplicate Dependent Views on page 843.</td>
</tr>
<tr>
<td>Referencing Sheet</td>
<td>See the description for Referencing Detail, which follows. From the example, the referencing sheet is A101.</td>
</tr>
<tr>
<td>Referencing Detail</td>
<td>This value comes from the referencing view that is placed on a sheet. For example, you create a section in a plan view and place the plan view as the first detail on a sheet numbered A101. The referencing detail number for the section view is 1. See Referencing a Drafting View on page 966 and Referencing a Callout View on page 962.</td>
</tr>
<tr>
<td>Current Revision Description</td>
<td>If the project has revisions, the description of the most recent revision displayed on the sheet. See Revisions on page 1018.</td>
</tr>
<tr>
<td>Current Revision</td>
<td>If the project has revisions, the sequence number of the most recent revision displayed on the sheet. See Revisions on page 1018.</td>
</tr>
<tr>
<td>Approved By</td>
<td>The person who approved the plans.</td>
</tr>
<tr>
<td>Designed By</td>
<td>The person who designed the plans.</td>
</tr>
<tr>
<td>Checked By</td>
<td>The person who checked the drawing.</td>
</tr>
<tr>
<td>Sheet Number</td>
<td>A unique identifier for the sheet in the construction document set.</td>
</tr>
<tr>
<td>Sheet Name</td>
<td>Brief description of the sheet. This name displays in the Project Browser, sheet lists, and other areas of Revit Structure.</td>
</tr>
<tr>
<td>Sheet Issue Date</td>
<td>An issue date for the sheet. This value is separate from the Project Issue Date label contained in the title block.</td>
</tr>
<tr>
<td>Appears in Sheet list</td>
<td>Default value is selected. If you clear the check box, the sheet is excluded from sheet lists.</td>
</tr>
<tr>
<td>Revisions on Sheet</td>
<td>Click Edit to select the revisions to list in the revision schedule on this sheet. See Specifying the Revisions to Include in a Revision Schedule on page 1028.</td>
</tr>
<tr>
<td>File Path</td>
<td>Location of the project file.</td>
</tr>
<tr>
<td>Drawn By</td>
<td>The person who drew the plans.</td>
</tr>
<tr>
<td>Guide Grid</td>
<td>Selects the guide grid for the sheet instance. To hide a guide grid after aligning views on the sheet, select None.</td>
</tr>
</tbody>
</table>
Title Blocks

A title block is a template for a sheet. It generally includes a border for the page and information about the design firm, such as its name, address, and logo. The title block can also display information about the project, client, and individual sheets, including issue dates and revision information.

Title Blocks Overview

Title blocks define the size and appearance of a drawing sheet. Think of them as templates for the drawing sheet. You create a title block family using the Family Editor. For each title block, you specify the sheet size and add borders, a company logo, and other information. You save the title block family as a separate file with an RFA extension.

Typically, you create custom title blocks and save them in the Library\Titleblocks folder of the Revit Structure program group. You then add these title blocks to a default project template, so they automatically load when you create a project.

If the custom title blocks are not included in the project template, you can load title blocks into a project. See Loading a Title Block into a Project on page 997.

Creating a Title Block

1. Click ➤ New ➤ (Title Block).
2. In the New Title Block dialog, select one of the predefined title block sizes, or select New Size.rft to create a title block with a new size. Click Open.
   The Family Editor opens.
3. Add lines and text to the title block.
   For detailed instructions on how to use the Family Editor, see The Families Guide on page 680.
   You can also add the following to a title block:
   - Images or corporate logos. See Logos and Images in a Title Block on page 996.
■ Custom fields. See Adding Custom Fields to a Title Block on page 1003.
■ A revision schedule. See Adding a Revision Schedule to a Custom Title Block on page 999.

4 To save the title block, click ➤ (Save). Specify a location and file name, and click Save.
5 Load the title block into a project.
See Loading a Title Block into a Project on page 997.

Modifying a Title Block

Modify a title block to change the border and standard information that displays on a sheet.

To modify a title block

1 Open a title block for editing, using one of the following methods:
   ■ Open a project that contains sheets that use the title block (or a project into which you have loaded the title block). In the Project Browser, expand Families ➤ Annotation Symbols. Right-click the name of the title block to modify, and click Edit.
   ■ In the Revit window, click ➤ Open ➤ Family. Navigate to the location of the title block family (RFA) file. Select the file, and click Open.

   The Family Editor opens, displaying the title block in the drawing area.

2 Modify the title block as desired.
   ■ To rotate text or a label in a title block, select the text or label, and drag the rotation controls.
   ■ To change text in the title block, double-click the text, and edit it.
   ■ To create custom fields that display information on a title block, see Adding Custom Fields to a Title Block on page 1003.

   NOTE To update project-specific information or sheet-specific information that displays within the title block of sheets in a project, see Specifying Title Block Information for Sheets on page 985.

3 To save the title block, on the Quick Access toolbar, click ➤ (Save).
4 Load the new or changed title block into a project.
See Loading a Title Block into a Project on page 997.

Logos and Images in a Title Block

To include a corporate logo or image in a title block, you can import an image file into a title block family. Revit Structure supports the following image file types: BMP (bitmap), JPEG, JPG, PNG (portable network graphics), and TIFF.
To import an image into a title block

1. Prepare the image or logo, and save it in a supported file format.
   
   **TIP** Import the file using the image size at which you want it to display in the title block. If you load and resize a large image file in the title block, Revit Structure retains the large file size, which can degrade performance. To improve performance, use the smallest acceptable image file.

2. Open the title block in the Family Editor.
   
   See **Modifying a Title Block** on page 996.

3. Click Insert tab ➤ Import panel ➤ ![Image](Image).

4. In the Import Image dialog, navigate to the location of the image file.

5. Select the image file, and click Open.

6. Click in the drawing area to place the image.

To reposition the image, drag it to the desired location on the sheet. To resize the image, select it and drag a blue corner dot, or enter the desired height and width on the **Properties palette**.

### Loading a Title Block into a Project

You can load a title block into a project as follows:

- **When creating or modifying a title block.** After saving changes to the title block family, in the Family Editor, click ![Load into Project](Load into Project). If multiple projects are currently open, select the open projects into which you want to load the title block, and click OK. If only one project is open, Revit Structure loads the title block into that project without further input.

- **When adding a sheet to a project.** See **Adding a Sheet** on page 979.

- **Using the ribbon in a project.** Use the following procedure.
To load a title block using the ribbon

1 Open a project.

2 Click Insert tab ➤ Load from Library panel ➤ (Load Family).

3 In the Load Family dialog, navigate to the location of the title block family file.

4 Select the title block family file, and click Open.

Revit Structure loads the title block family into the project. In the Project Browser, title blocks display under Families ➤ Annotation Symbols.

Changing the Title Block Used on a Sheet

To change the title block that displays on a sheet, use one of the following methods:

Select and change

1 Open the sheet.

2 In the drawing area, select the title block.

3 On the Properties palette, select the desired title block from the Type Selector.
   (If the desired title block is not included in the list, load it.)

Delete and drag

1 Open the sheet.

2 In the drawing area, select the title block, and press DELETE.
   (If the sheet contains views and schedules, they remain in place in the drawing area.)

3 In the Project Browser, under Families ➤ Annotation Symbols, expand the desired title block.

4 Drag the title block from the Project Browser to the sheet, and click to place it.

Place title block

This method is useful when you have deleted the title block from a sheet and then performed other tasks without immediately placing a new title block on the sheet. To place a title block on an existing sheet that does not have one, do the following:

1 Open the sheet.

2 Click View tab ➤ Sheet Composition panel ➤ (Title Block).

3 On the Properties palette, select the desired title block from the Type Selector.

4 Click in the drawing area to place the title block on the sheet.

Revision Schedules on Title Blocks

When designing a title block, you can include a revision schedule. You can specify the information to include in the revision schedule. You can also specify its layout, height, and placement on the title block. When you add a sheet to a project, the revision schedule displays information about revisions in that project.
Adding a Revision Schedule to a Custom Title Block

1. Open a title block for editing.
   See Modifying a Title Block on page 996.

2. (Optional) In the title block, sketch a border for the revision schedule area.

3. Click View tab ➤ Create panel ➤ (Revision Schedule).

4. On the Fields tab of the Revision Properties dialog, add the fields to include in the schedule.
   These fields correspond to columns of the Sheet Issues/Revisions dialog for a project. (See Entering Revision Information on page 1019.)
   The Revision Sequence field corresponds to the Sequence column of the dialog. This field indicates the overall sequence of revisions in a project, regardless of their assigned revision numbers.
   See Selecting Fields for a Schedule on page 788.

5. Specify sorting for the revision schedule, as follows:
   a. Click the Sorting/Grouping tab of the Revision Properties dialog.
   b. For Sort by, select Revision Sequence, and specify Ascending or Descending.
   c. Ensure that Itemize every instance is selected.

6. Specify formatting for column headings in the revision schedule, as follows:
   a. Click the Formatting tab of the Revision Properties dialog.
   b. In the Fields list, select a field.
   c. Specify the heading, orientation, and alignment for the field.
   d. If you want to omit the selected field from the revision schedule, select Hidden field.
      Use the Hidden field option, for example, if you want to use the field for sorting or grouping but do not want it to display in the revision schedule.

   Repeat these steps for each field in the revision schedule.

7. Specify display attributes for lines, text fonts, and schedule order and height, as follows:
   a. Click the Appearance tab of the Revision Properties dialog.
   b. For Build schedule, specify whether the revision schedule builds from the bottom up or the top down.
      See Building a Revision Schedule from the Top Down or Bottom Up on page 1002.
   c. For Height, specify whether the height of the revision schedule is user defined (fixed) or variable.
See Defining the Height of the Revision Schedule on page 1001.

d Use the remaining options of the Appearance tab to define attributes for grid lines, header text, and body text.

See Formatting a Schedule on page 791.

8 Click OK.
Revit Structure creates the revision schedule and displays it in the drawing area.

9 In the Project Browser, double-click the empty node under Sheets (all).
The title block displays in the drawing area.

10 In the Project Browser, under Views (all) ➤ Schedules, select the revision schedule, and drag it to the drawing area.

11 Place the revision schedule in the desired location on the title block.
To change the width of columns, select the revision schedule, and drag the blue triangles between column headers.

12 (Optional) To rotate the revision schedule on the title block, see Rotating a Revision Schedule on page 1000.

13 To save the title block, on the Quick Access toolbar, click (Save).

14 Load the title block into one or more open projects.
See Loading a Title Block into a Project on page 997.

Rotating a Revision Schedule

You can rotate a revision schedule 90 degrees clockwise or counterclockwise on a title block. To rotate a revision schedule, modify the title block family. You cannot rotate a revision schedule on a particular sheet in a project.

A horizontal revision schedule (left), and a rotated revision schedule (right)

To rotate a revision schedule

1 Open the title block for editing.
See Modifying a Title Block on page 996.

2 In the drawing area, select the revision schedule of the title block.

3 On the Options Bar, for Rotation on Sheet, select the desired rotation option.
4 Reposition the rotated revision schedule on the title block, if needed.
5 (Optional) Define a fixed height for the revision schedule.
   Defining a fixed height ensures that the revision schedule does not expand beyond the boundaries
   of a sheet. See Defining the Height of the Revision Schedule on page 1001.
6 To save the title block, on the Quick Access toolbar, click (Save).
7 Load the title block into a project.
   See Loading a Title Block into a Project on page 997.

**Defining the Height of the Revision Schedule**

By default, revision schedules use a variable height, so that the schedules can expand to accommodate all
of the revisions for a sheet.

If needed, you can specify that a revision schedule has a fixed (user defined) height. On a sheet in a project,
the schedule displays only the revisions that can fit in the allotted space. If the sheet refers to more revisions
than can fit in the schedule, Revit Structure shows the most recent revisions and omits the rest.

To specify a fixed height, modify the revision schedule in the title block family, and use the Height option
of the Revision Properties dialog, as follows.

**To define a fixed height for a revision schedule**

1 Open the title block for editing.
   See Modifying a Title Block on page 996.
2 Modify the revision schedule properties, as follows:
   a In the Project Browser, under Views (all) ➤ Schedules, click Revision Schedule.
   b On the Properties palette, for Appearance, click Edit.
   c On the Appearance tab of the Revision Properties dialog, for Height, select User defined.
   d Click OK.
3 In the drawing area, select the revision schedule of the title block.
   The bottom of the revision schedule displays a blue dot. Grid lines display to indicate the amount
   of space required for each row of revision information (assuming one line per revision row; in
   a sheet, long values wrap to the next line). In this mode, these grid lines display regardless of
   whether the revision schedule is set to display grid lines.
4 Drag the blue dot up or down until the revision schedule is the desired height.
   The blue dot indicates the bottom boundary of the revision schedule. If a sheet in a project has
   more revisions than can fit in this space, Revit Structure omits the oldest revisions from the
   schedule.
To save the title block, on the Quick Access toolbar, click (Save).

6 Load the title block into a project.
   See Loading a Title Block into a Project on page 997.

Building a Revision Schedule from the Top Down or Bottom Up

Revision schedules can display information in various ways. Some design firms use a top-down approach, with column headings and revision rows starting at the top of the schedule. Other design firms use a bottom-up approach, with column headings and revision rows starting at the bottom of the schedule. In either case, the revision schedule sorts the rows using the settings specified on the Sorting/Grouping tab of the Revision Properties dialog. (See Adding a Revision Schedule to a Custom Title Block on page 999.)

<table>
<thead>
<tr>
<th>Revisions</th>
<th>ID</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>9.14</td>
<td>Wall Type Change</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>9.24</td>
<td>Accessible Modifications</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>10.15</td>
<td>Owner Request</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>11.02</td>
<td>Add Vision Lites</td>
<td></td>
</tr>
</tbody>
</table>

To change the way that revision schedules display information

1 Open the title block for editing.
   See Modifying a Title Block on page 996.

2 In the Project Browser, under Views (all) ➤ Schedules, click Revision Schedule.

3 On the Properties palette, for Appearance, click Edit.

4 On the Appearance tab of the Revision Properties dialog, for Build schedule, select one of the following values:
   - **Top-down**: Column headings display at the top of the revision schedule. Revision rows start at the top of the schedule and go down.
   - **Bottom-up**: Column headings display at the bottom of the revision schedule. Revision rows start at the bottom of the schedule and go up.

5 Click the Sorting/Grouping tab of the Revision Properties dialog. Make sure that the revision schedule is sorted as desired.

6 Click OK.

7 If needed, adjust the position of the revision schedule on the title block.
   a In the drawing area, select the revision schedule of the title block.
   b Drag the revision schedule to the desired location.

8 To save the title block, on the Quick Access toolbar, click (Save).

9 Load the title block into a project.
   See Loading a Title Block into a Project on page 997.
Adding Custom Fields to a Title Block

In general, a title block contains placeholders for 2 types of information:

- **Project-specific information.** This information applies to all sheets in the project. Examples: project name, client information, project address.

- **Sheet-specific information.** This information differs for each sheet within a project. Examples: sheet name, sheet number, reviewer, sheet issue date.

When you add a sheet to a project, the project-specific information in the title block displays the appropriate information. You can enter the sheet-specific information directly on the sheet.

Revit Structure provides default title block families. These title blocks include some project-specific information fields and some sheet-specific information fields. If you want to add more information (custom fields) to a title block, use shared parameters.

**NOTE** Use shared parameters (not project parameters) so that they are available to the title block families and the projects that use them.

To add custom fields to a title block

1. Create (or edit) a shared parameter file, and add shared parameters to the file.

   Click Manage tab ➤ Settings panel ➤ (Shared Parameters). Add one shared parameter for each new project-specific or sheet-specific field. See Shared Parameters on page 1541.

2. Add the shared parameters to the project.

   See Creating Shared Project Parameters on page 1550.

   When adding each parameter using the Parameter Properties dialog, under Categories, select one of the following:

   - **Drawing Sheets** for a sheet-specific field
   - **Project Information** for a project-specific field

   Now these fields are available to the project.

3. Add the shared parameters to a title block using labels.

   See Labels on page 704.

   **NOTE** You can add static text to describe a parameter in the title block. See Text Notes on page 926.

4. To save the title block, on the Quick Access toolbar, click (Save).

   After loading the title block into a project and adding sheets, you can see the custom fields on the sheets.

   - **Project-specific fields:** Click Manage tab ➤ Settings panel ➤ (Project Information) to display the shared parameters that belong to the Project Information category. You can change these values in that dialog or on a sheet. Whenever you change project-specific information, Revit Structure updates all sheets in the project with the changes. See Entering Project-Specific Information on page 986.

   - **Sheet-specific fields:** The shared parameters that belong to the Drawing Sheets category display on the Properties palette for the sheet. You can change these values on the Properties palette or on a sheet. These changes apply only to the individual sheet. See Entering Sheet-Specific Information on page 986.
Importing a Title Block from Another CAD Program

If you created a title block using another CAD application, you can import it into Revit Structure. Some text in the imported title block may reflect information that is specific to the project or sheet. Replace this text with Revit parameters so that the information can update automatically.

To import a title block

1 In the CAD application, do the following:
   a Prepare the title block. For example, remove unwanted text, or text that you plan to replace with Revit parameters.
   b Export the title block to a DXF or DWG file.

2 In Revit Structure, create the title block, as follows:
   a Click ➤ New ➤ (Title Block).
   b In the New Title Block dialog, select the appropriate sheet size for the title block, and click Open.
      If the imported title block uses a non-standard size, select New Size.rft, and click Open.

3 Import the title block, as follows:
   a Click Insert tab ➤ Import panel ➤ (Import CAD).
   b In the Import CAD Formats dialog, navigate to the location of the title block file to import.
   c For Files of type, select the type of file to import.
   d For File name, specify the file to import.
   e Specify the desired import options.
      See Import and Link Options for CAD Formats and Revit Models on page 63.
   f Click Open.

      If you cannot see the imported title block in the drawing area, type ZF (Zoom to Fit).

4 If needed, adjust the defined print area.
   When you selected a title block size in the New dialog, Revit Structure placed lines in the drawing area. These lines define the size of the printed page (the print area) for the sheet. If the imported title block is larger or smaller than the selected title block size, drag the lines to the edges of the title block.

5 If needed, explode the imported file.
   If the imported title block includes text, perform a full explode to separate the imported object into its component objects. (See Exploding Imported Geometry on page 75.) Then you can
delete the text in the title block and replace it with Revit labels. (When you add a sheet to a project, these labels update to display project-specific or sheet-specific information.)

To explode the imported file:

a In the drawing area, select the imported title block.
The status bar displays the following:
Imports in Families : Import Symbol : location <Not Shared>.

b Click Modify | Imports in Families tab ➤ Import Instance panel ➤ Explode drop-down ➤ Full Explode.

You can now select individual lines or pieces of text to move or delete them.

6 Replace project-specific or sheet-specific text from the imported title block with Revit labels.
For example, if the imported title block includes the text Client Name as a placeholder, select this text and delete it. Then replace it with the Project Name parameter that Revit Structure provides, or another parameter that you have defined. See Adding Custom Fields to a Title Block on page 1003.

7 Make any other changes required.

8 To save the title block, on the Quick Access toolbar, click (Save).

9 Load the title block into a project template or a project where you want to use it.
See Loading a Title Block into a Project on page 997.

**Viewports**

When you add a view to a sheet, a viewport displays on the sheet to represent the view. The viewport is like a window through which you can see the actual view. If desired, you can activate the view and modify the building model from the sheet. (See Modifying a View on a Sheet on page 987.)

**NOTE** Viewports apply only to project drawings, such as floor plans, elevations, sections, and 3D views. They do not apply to schedules.
Viewport Types

Viewport types (also known as title marks) define settings for viewports. These settings control display attributes of the view title (for example, whether the view title and its horizontal line display on a sheet). You can apply viewport types to views on a sheet.

NOTE To change the information included in a view title or its display attributes, create or edit a view title type. See View Title Types on page 1009.

Creating a Viewport Type

The following procedure assumes that you have created sheets in a project, and placed views on the sheets.

To create a viewport type

1. Open a sheet.
2. Select a viewport for a view on the sheet.
3. On the Properties palette, click Edit Type.
4. In the Type Properties dialog, click Duplicate.
5. In the Name dialog, enter a name for the new viewport type, and click OK.
6. Complete the parameters for the viewport type.
   See Viewport Type Properties on page 1007.
7. Click OK.

Revit Structure applies the new viewport type to the selected viewport.

Applying a Viewport Type

After creating a viewport type, you can apply it to viewports on sheets in a project. The following procedure assumes that you have created sheets in a project, placed views on the sheets, and created one or more viewport types.

To apply a viewport type to a view on a sheet

1. Open a sheet.
2. Select a viewport.
In the Type Selector on the Properties palette, select the viewport type to apply to the viewport.

Modifying Viewport Type Properties

1. On a sheet, select a viewport.
2. On the Properties palette, click Edit Type.
3. Edit viewport type properties.
   See Viewport Type Properties on page 1007.

Viewport Type Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Specifies the type of view title to use. The view title type specifies the information that is displayed in a view title and its text attributes. Select a view title type from the list, or, to omit a view title, select none. See View Title Types on page 1009.</td>
</tr>
<tr>
<td>Show Title</td>
<td>Controls the display of the view title. Use one of the following values: ■ Yes: Display view titles. ■ No: Do not display view titles. ■ When multiple viewports: Display view titles only when a sheet contains multiple views. If a sheet contains a single view, do not display the view title.</td>
</tr>
<tr>
<td>Show Extension Line</td>
<td>Shows or hides an extension line for the view title. The extension line displays only if the view title displays. See View Titles on Sheets on page 1007. To change the length of the line for an individual view title, see Modifying a View Title on a Sheet on page 1008.</td>
</tr>
<tr>
<td>Line Weight</td>
<td>Specifies the weight of the horizontal line for the view title.</td>
</tr>
<tr>
<td>Color</td>
<td>Specifies the color of the horizontal line for the view title.</td>
</tr>
<tr>
<td>Line Pattern</td>
<td>Specifies the pattern of the horizontal line for the view title.</td>
</tr>
</tbody>
</table>

View Titles on Sheets

When you place a view on a sheet, by default Revit Structure displays a view title. You can specify text attributes for view titles, define the information to include in a view title, or omit view titles from sheets. You can define these attributes for individual view titles on sheets. You can also define view title types and use them to apply standard settings to view titles.

To change the weight, color, or pattern of the horizontal line in a view title, or omit the line from the view title, create or modify a viewport type. See Viewport Types on page 1006. To change the length of the horizontal line for an individual view title, see Modifying a View Title on a Sheet on page 1008.

NOTE View titles display only for views, such as floor plans, elevations, sections, and 3D views. View titles do not display for schedules.
Modifying a View Title on a Sheet

The following procedure assumes that you have created sheets in a project, and added views to the sheets.

To modify an individual view title

1. Open a sheet.
2. Select the viewport for the view whose title you want to change.
3. To change the view title on the sheet, do either of the following:
   ■ Rename the view. This method changes the name of the view in the Project Browser and on the sheet. See Renaming Views on page 817.
   ■ Change the view title. This method retains the current view name in the Project Browser, but specifies a different view title to display on the sheet.
      a. Select the viewport.
      b. On the Properties palette, under Identity Data, for Title on Sheet, enter the view title to display on the sheet.

   If you want to change the display attributes for the view title, create or modify a view title type. See View Title Types on page 1009.
4. To change the length of the horizontal line that displays with the view title, do the following:
   a. Zoom in on the view title until you can clearly see the blue drag controls.
      
      NOTE Be sure that you have selected the viewport for the view on the sheet. If you try to select the view title without selecting the viewport, the blue drag controls for the horizontal line do not display.
   b. Drag the controls to shorten or lengthen the horizontal line.

If you want to change or omit the horizontal line in a view title, create or modify a viewport type. See Viewport Types on page 1006.
Removing a View Title from a Sheet

If you do not want to display a view title on a sheet, create a viewport type that omits view titles. Then apply the viewport type to that view on the sheet.

The following procedure assumes that you have created sheets in a project, and added views to the sheets.

To remove a view title from a sheet

1. Open the sheet.
2. Select the viewport for a view whose title you want to remove.
   - On the Properties palette, the Type Selector displays the viewport type that applies to the selected viewport.
3. On the Properties palette, click Edit Type.
4. If you want to create a viewport type, click Duplicate, and enter a name (for example, Viewport – No Title).
   - Otherwise, you are editing the viewport type. Changes will apply to all views that use this viewport type on sheets in the project.
5. For Show Title, select No.
6. Click OK.

The view title is removed from the selected view on the sheet. If needed, you can apply the same viewport type to other views. See Applying a Viewport Type on page 1006.

View Title Types

View title types provide standard settings for view titles on sheets. Use view title types to do the following:

- Define the type of information that displays in view titles on sheets (such as the view name, number, and scale).
- Define the font, text size and color, and other attributes for parts of the view title.

NOTE To control whether the view title and its horizontal line displays on a sheet, use viewport types. See Viewport Types on page 1006.

You create and edit view title types using the Family Editor. Revit Structure provides several view title types. Some default view title types include sheet numbers and referencing sheet numbers to provide cross-referencing information between views and sheets.

The default view title types contain View Title in their file names. They reside in the following default location:

- **Windows XP**: C:\Documents and Settings\All Users\Application Data\Autodesk\<product and release>\Imperial or Metric Library\Annotations
- **Windows Vista or Windows 7**: C:\ProgramData\Autodesk\<product and release>\Imperial or Metric Library\Annotations
Modifying a View Title Type

1 Open the view title type for editing, using one of the following methods:
   ■ Open a project that contains sheets that use the view title type (or a project into which you have loaded the view title type). In the Project Browser, expand Families ➤ Annotation Symbols. Right-click the name of the view title type to modify, and click Edit.

   ■ Click ➤ Open ➤ (Family). Navigate to the location of the view title type (RFA) file. Select the file, and click Open.

   The Family Editor opens, displaying the view title type in the drawing area.

2 Modify the view title type as desired.
   ■ To rotate text or a label in a view title, select the text or label, and drag the rotation controls.
   ■ To change text in the view title, double-click the text, and edit it.
   ■ To change the type of text used to display a label, select the label in the drawing area. On the Properties palette, select another label type from the Type Selector. Or, to edit text parameters for the current label type, click Edit Type.

3 To save the view title type, on the Quick Access toolbar, click (Save).

4 Load the view title type into a project.
   See Loading a View Title Type into a Project on page 1010.

Loading a View Title Type into a Project

You can load a view title type into a project as follows:

■ When creating or modifying a view title type. After saving changes to the view title type in the Family Editor, click Family Editor panel ➤ (Load into Project). Select the open projects into which you want to load the view title type, and click OK.

■ Using the ribbon in a project. The view title type is then available when you edit viewport types within the project. Use the following procedure.

To load a view title type using the ribbon

1 Open a Revit project.

2 Click Insert tab ➤ Load from Library panel ➤ (Load Family).

3 In the Load Family dialog, navigate to the location of the view title type file.

   The default view title types contain View Title in their file names. They reside in the following default location:

   ■ Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk\<product and release>\Imperial or Metric Library\Annotations

   ■ Windows Vista or Windows 7: C:\ProgramData\Autodesk\<product and release>\Imperial or Metric Library\Annotations

4 Select the view title type file, and click Open.
Revit Structure loads the view title type into the project. In the Project Browser, the view title type displays under Families ➤ Annotation Symbols.

Applying a View Title Type to a Viewport Type

After creating or modifying a view title type to display the desired information and text attributes, apply it to a viewport type. All views (on sheets) that use this viewport type then display titles using that view title type.

To apply a view title type to a viewport type

1. On a sheet, select the viewport to which you want to apply a different view title type.
2. On the Properties palette, the Type Selector displays the viewport type that currently applies to the selected viewport.
3. On the Properties palette, click Edit Type.
4. In the Type Properties dialog, for Title, select the desired view title type from the list.

**NOTE** If the list does not include the desired view title type, click Cancel. Load the desired view title type. (See Loading a View Title Type into a Project on page 1010.) Then repeat this procedure to apply the view title type to the viewport type.

4. Click OK.

Schedules on Sheets

You can place schedules on sheets in a construction document set. The same schedule can reside on multiple sheets.

Adding a Schedule to a Sheet

1. In a project, open the sheet to which you want to add a schedule.
2. In the Project Browser, under Schedules/Quantities, select the schedule, and drag it onto the sheet in the drawing area. Release the mouse button when the cursor is over the sheet. Revit Structure displays a preview of the schedule at the cursor.
3. Move the schedule to the desired location, and click to place it on the sheet.
You can modify the schedule after placing it on the sheet. In the sheet view, right-click the schedule, and click Edit Schedule. The schedule view displays. You can now edit the cells of the schedule. See Editing Cells in a Schedule on page 796. You can also rotate the schedule on the sheet. See Rotating a View on a Sheet on page 988.

**Formatting a Schedule on a Sheet**

You can change the attributes that control the display of a schedule on the sheet, including grid lines and text attributes.

The following procedure assumes that you have added a sheet to a project and placed a schedule on the sheet. See Adding a Sheet on page 979 and Adding a Schedule to a Sheet on page 1011.

**To format a schedule on a sheet**

1. In the Project Browser, under Schedules/Quantities, click the schedule name.
2. On the Properties palette, for Appearance, click Edit.
3. On the Appearance tab of the Schedule Properties dialog, define the settings as desired.

   The Appearance options affect the display of the schedule on sheets only. They do not affect the display in the schedule view.

   For information and examples of how to set the Appearance options, see Formatting a Schedule on page 791.

4. Click OK.
5. Open the sheet to see the results.

**Splitting a Schedule on a Sheet**

When you place a schedule on a sheet, you can split the schedule into 2 or more sections to fit the space on the sheet.

**NOTE** You cannot split a schedule across multiple sheets.

The following procedure assumes that you have added a sheet to a project and placed a schedule on the sheet. See Adding a Sheet on page 979 and Adding a Schedule to a Sheet on page 1011.

**To split a schedule on a sheet**

1. Open the sheet.
2. Select the schedule on the sheet.

   Blue controls allow you to move and manipulate the schedule. The Z break control in the middle of the right border splits the schedule.

3. Click the Z break control.

   The schedule divides into 2 sections, splitting at the approximate location of the Z break control.
To split a section of the schedule further, click the Z break control again.

**NOTE** You cannot delete schedule sections from a sheet. You cannot drag schedule sections from one sheet to another.

To adjust the number of rows in a section of the schedule, drag the blue dot at the bottom of the first section.
If you shrink the schedule section, rows that do not fit automatically move to the next section. The last section contains the remaining rows, so you cannot resize it.

### Moving Schedule Sections

The following procedure assumes that you have added a sheet to a project, created a schedule and placed it on the sheet, and split the schedule.

To move a schedule section

1. Select the schedule section on the sheet.
2. Click the blue arrow control in the center of the schedule section, and drag it to a new location on the sheet.

### Joining Split Schedules

You can rejoin the sections of a split schedule on a sheet. Schedule sections are sequential: you can join a section with its previous or subsequent section. For example, if you split a schedule into 4 sections, you can rejoin section 2 with section 1 or 3.

To rejoin schedule sections

1. On a sheet that displays a split schedule, drag the blue arrow control in the center one schedule section over the other section.
2. Release the mouse button.
   The split schedule sections rejoin into one section.
Adjusting Schedule Columns on a Sheet

When you place a schedule on a sheet, text that does not fit within a column wraps to a new line. To adjust
the column width, select the schedule. A blue triangle displays to the upper right of each column. Drag a
blue triangle to the left or right.

**NOTE** If the schedule is split into multiple sections, adjusting the width in one section changes the width in all
sections.

Split schedules after column width adjustment

Related topic

■ **Modifying Schedules** on page 795

Displaying Vertical Headings in a Schedule on a Sheet

When you place a schedule on a sheet, you can specify that one or more column headings display vertically
instead of horizontally, as shown here.

The following procedure assumes that you have added a sheet to a project, created a schedule, and placed
it on the sheet.

To display vertical column headings for a schedule on a sheet

1. In the Project Browser, under Schedules/Quantities, click the schedule name.
2. On the **Properties palette**, for Formatting, click Edit.
3. For each field whose column heading is to display vertically in the sheet, do the following:
   a. On the Formatting tab of the Schedule Properties dialog, under Fields, select the field.
   b. For Heading orientation, select Vertical.
      This setting affects the column heading on a sheet only. It does not affect its display in the
      schedule view.
4. Click OK.
5. Open the sheet to see the results.
In the schedule, the column headings for the selected fields display vertically instead of horizontally. See Adjusting Schedule Columns on a Sheet on page 1014.

Sheet Lists

A sheet list is a schedule of the sheets in a project. A sheet list can also be referred to as a drawing index or a sheet index. You can use a sheet list as a table of contents for a construction document set. The sheet list is typically placed on the title sheet.

**DRAWING INDEX**

S0.0  COVER SHEET  
S0.1  LOADING PLAN  
S1.0  FOUNDATION PLAN  
S1.1  FRAMING PLAN  
S2.0  ELEVATIONS  
S3.0  COLUMN SCHEDULE  
S4.0  WOOD CONNECTION DETAILS

Creating a Sheet List

1. In a project, click View tab ➤ Create panel ➤ Schedules drop-down ➤ (Sheet List).
2. On the Fields tab of the Sheet List Properties dialog, select the fields to include in the sheet list. See Selecting Fields for a Schedule on page 788.
3. (Optional) To create user-defined fields, click Add Parameter. For further instructions, see Parameters on page 1541.
4. In the Sheet List Properties, in the Fields tab, select Include elements in linked files to associate any number of placeholder sheets with the Project Browser. Click OK.
5. Specify the remaining schedule properties using the Filter, Sorting/Grouping, Formatting, and Appearance tabs. See Specifying Schedule Properties on page 788.
6. Click OK.

The resulting sheet list displays in the drawing area. In the Project Browser, it displays under Schedules/Quantities.

Adding Placeholder Sheets to a Sheet List

You can add new rows in a Sheet List to create placeholder sheets. You can leave these placeholder sheets as-is to represent consultant sheets, or you can convert them into project sheets using the New Sheet dialog.

To add placeholder sheets to a sheet list

1. Open a sheet list schedule.
On the Modify Sheet List tab, you can add or delete sheets, or filter unused placeholder sheets.

2 Click Modify Sheet List tab ➤ Rows panel ➤ (New). This adds a new row representing a placeholder sheet to the Sheet List, but note that the placeholder is not associated with the Project Browser.

3 To add placeholder sheets to the Project Browser, you can create a new sheet from a placeholder sheet and associate it to the Project Browser.

   On the ribbon, click (Sheet).

4 In the New Sheet dialog, under Select placeholder sheets, select the placeholder sheets that you want to convert to actual sheets.

   NOTE If desired, under Select titleblocks you can select None to create a sheet that does not include a title block.

5 Click OK.

   The new external sheets are created and display in the Project Browser.

Filtering Placeholder Sheets on a Sheet List

You can filter the display of placeholder sheets from the sheet list. For example, you may want to display only the placeholder sheets in the sheet list.

1 Open a Sheet List schedule.

2 On the Filter Placeholder Sheets panel, do one of the following:
   ■ click Show to display all sheets in the list
   ■ click Hide to hide the placeholder sheets
   ■ click Isolate to display only the placeholder sheets.

Omitting Sheets from a Sheet List

You can omit sheets from the sheet list. For example, you may not want the cover sheet to display in the sheet list.

To omit a sheet from a sheet list

1 In the Project Browser, click the name of the sheet to omit.

2 On the Properties palette, clear Appears In Sheet List.
This option is selected for all sheets by default.

Revit Structure updates the sheet list to exclude the sheet.

Adding a Sheet List to a Sheet

To add a sheet list to a sheet, use the procedure for adding a schedule to a sheet. See Adding a Schedule to a Sheet on page 1011.

When you add a sheet list to a sheet, you can perform the same functions as for schedules on sheets, including the following:

- Formatting the sheet list
- Splitting the sheet list
- Adjusting the width of columns
- Displaying column headings vertically instead of horizontally

For instructions, see Schedules on Sheets on page 1011.

Organizing a Sheet List

If you want the sheets in a sheet list to display in a particular order, you can create a custom Sheet Order parameter and add it to the sheet list properties.

The following procedure assumes that you have created a sheet list and added multiple sheets to the project. See Creating a Sheet List on page 1015 and Adding a Sheet on page 979.

To organize a sheet list

1. Open the sheet list.
2. In the Project Browser, under Schedules/Quantities, click the sheet list name.
3. On the Properties palette, for Fields, click Edit.
4. Add a custom field named Sheet Order, as follows:
   b. In the Parameter Properties dialog, under Parameter Type, select Project parameter.
   c. Under Parameter Data, for Name, enter Sheet Order.
   d. Click OK.

On the Sheet List Properties dialog, the Sheet Order field displays in the list of scheduled fields.

5. Use the Sheet Order field to sort the sheet list, as follows:
   a. Click the Sorting/Grouping tab.
   b. For Sort by, select Sheet Order. Make sure that Ascending is selected.
   c. Click OK.

The sheet list displays a column titled Sheet Order. In a later step, you will hide this column so it does not display in the sheet list. First, however, you must assign a sheet order to each sheet in the list.
6 For each sheet in the list, click in the Sheet Order column, and enter a number to indicate its order in the sheet sequence.

As you enter sheet order numbers, Revit Structure re-sorts the list to place the rows in order.

<table>
<thead>
<tr>
<th>Drawing List</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Sheet Number</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sheet Name</td>
<td></td>
<td></td>
</tr>
<tr>
<td>S0.0</td>
<td>COVER SHEET</td>
<td></td>
</tr>
<tr>
<td>S0.1</td>
<td>LOADING PLAN</td>
<td></td>
</tr>
<tr>
<td>S1.0</td>
<td>FOUNDATION PLAN</td>
<td></td>
</tr>
<tr>
<td>S1.1</td>
<td>FRAMING PLAN</td>
<td></td>
</tr>
<tr>
<td>S1.2a</td>
<td>FRAMING PLAN (EAST)</td>
<td></td>
</tr>
<tr>
<td>S1.2b</td>
<td>FRAMING PLAN (WEST)</td>
<td></td>
</tr>
<tr>
<td>S2.0</td>
<td>ELEVATIONS</td>
<td></td>
</tr>
<tr>
<td>S3.0</td>
<td>COLUMN SCHEDULE</td>
<td></td>
</tr>
</tbody>
</table>

7 To hide the Sheet Order field, right-click the column in the sheet list, and click Hide Column(s). Revit Structure hides the Sheet Order column in the sheet list.

<table>
<thead>
<tr>
<th>Drawing List</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Sheet Number</td>
<td></td>
</tr>
<tr>
<td>Sheet Name</td>
<td></td>
</tr>
<tr>
<td>S0.0</td>
<td>COVER SHEET</td>
</tr>
<tr>
<td>S0.1</td>
<td>LOADING PLAN</td>
</tr>
<tr>
<td>S1.0</td>
<td>FOUNDATION PLAN</td>
</tr>
<tr>
<td>S1.1</td>
<td>FRAMING PLAN</td>
</tr>
<tr>
<td>S1.2a</td>
<td>FRAMING PLAN (EAST)</td>
</tr>
<tr>
<td>S1.2b</td>
<td>FRAMING PLAN (WEST)</td>
</tr>
<tr>
<td>S2.0</td>
<td>ELEVATIONS</td>
</tr>
<tr>
<td>S3.0</td>
<td>COLUMN SCHEDULE</td>
</tr>
</tbody>
</table>

NOTE To redisplay the Sheet Order column, right-click in the sheet list, and click Unhide All Columns.

You can place the sheet list on a sheet and format it as desired. See Adding a Schedule to a Sheet on page 1011 and Formatting a Schedule on a Sheet on page 1012.

Revisions

When working on building projects, you must often make changes to meet client or regulatory requirements. These revisions need to be tracked for future reference. For example, you may want to check the revision history to identify when, why, and by whom a change was made. Revit Structure provides tools that enable you to track revisions and include revision information on sheets in a construction document set.
Revision Workflow

Revision tracking is the process of recording changes made to a building model after sheets have been issued. In Revit Structure, you display and track revisions using revision clouds, tags, and schedules.

Typically you manage the revision process as follows:

1. Enter information about the revision in the Sheet Issues/Revisions dialog. See Entering Revision Information on page 1019.

2. Update the Revit project to implement the change.

3. In one or more project views, draw revision clouds to indicate the areas that changed. See Adding a Revision Cloud on page 1024.

4. Assign a revision to each cloud. See Assigning a Revision to a Revision Cloud on page 1025.

5. Tag the revision clouds to identify the assigned revisions. See Tagging a Revision Cloud on page 1026.

6. Check sheets to make sure that the revision schedules show the desired information. See Specifying the Revisions to Include in a Revision Schedule on page 1028.

7. Issue the revisions. See Issuing a Revision on page 1029.

Entering Revision Information

When you revise the building model, enter information about the revision in the project. When you later add revision clouds to a drawing, you can assign the revision to one or more clouds.

NOTE Before entering revision information in a project, decide how revision clouds will be numbered on sheets. See Revision Cloud Numbering by Project or by Sheet on page 1021.

To enter revision information

1. In the project, click View tab ➤ Sheet Composition panel ➤ (Sheet Issues/Revisions). The Sheet Issues/Revisions dialog displays.

2. To add a new revision, click Add.
For your first revision, edit the values for the existing (default) revision row.

3 In the revision row, for Numbering, select Numeric, Alphabetic, or None.
   See Numbering for Revisions on page 1022.

4 For Date, enter the date on which the revisions are made or will be sent for review.

5 For Description, enter the description of the revision to display in revision schedules on sheets.

6 If the revision has been issued, enter values for Issued to and Issued by, and then select Issued.
   See Issuing a Revision on page 1029.

7 For Show, select one of the following values. (These values apply after you assign the revision to one or more clouds.)
   - None: Does not display the revision cloud and the revision tag in the drawing.
   - Tag: Displays the revision tag and draws the revision cloud, but does not display the cloud in the drawing. (To move or edit the cloud in the drawing, move the cursor over the cloud area to highlight and select the cloud.)
   - Cloud and Tag: Displays the revision cloud and the revision tag in the drawing. This option is the default.

8 Click OK.

Merging Revisions

You can merge (combine) revisions into a single entry. For some projects, you may want to merge all revisions from a particular stage of the project. All new revisions for the next project stage are then listed individually.

When you merge revisions, the target revision (the revision being merged to) remains. Information about the revision being merged is lost.

**NOTE** You cannot delete revisions in the Sheet Issues/Revisions dialog, but you can merge them.

To merge revisions

1 In the project, click View tab ➤ Sheet Composition panel ➤ (Sheet Issues/Revisions).

2 In the Sheet Issues/Revisions dialog, click the sequence number for the revision to merge with another.

**NOTE** The information for the selected revision row (including the Date, Description, Issued to, and Issued by values) will be lost when you merge it with another revision.

3 To merge the selected revision with the one above or below it in the list, under Row, click Merge Up or Merge Down.

4 Click OK.

Changing the Order of Revisions

When you change the sequence of revisions on the Sheet Issues/Revisions dialog, the number assigned to each revision changes accordingly. If you use a mix of alphabetic and numeric numbering for revisions, the revision numbers change to reflect their new positions in the overall sequence.
To change the order of revisions

1. In the project, click View tab ➤ Sheet Composition panel ➤ (Sheet Issues/Revisions).
2. In the Sheet Issues/Revisions dialog, click the sequence number for the revision to move.
3. Under Row, click Move Up or Move Down.
   If needed, click Move Up or Move Down multiple times to move the selected revision to the desired location in the revision sequence.
4. Click OK.

In views and sheets, the revision numbers in tags and revision schedules update to reflect the new sequence.

Revision Cloud Numbering by Project or by Sheet

Before entering information about revisions, carefully consider how you want to number revision clouds on sheets: by project or by sheet. Use the Numbering setting in the Sheet Issues/Revisions dialog to control the display of revision numbers for clouds in tags and schedules. If you change this setting after creating revisions, revision numbers of all revision clouds may change.

- **Numbering Per Project**: (default) Revit Structure numbers revisions according to the sequence of revisions in the Sheet Issues/Revisions dialog. For example, suppose you create clouds for revisions 2, 3, and 4. When you add those clouds to a sheet, the numbering in the tags and the revision schedule display 2, 3, and 4. You cannot modify the sequence number.

- **Numbering Per Sheet**: Revit Structure numbers clouds relative to the sequence of other clouds on the sheet. For example, suppose you create revisions 5, 6, and 7, and tag revision clouds for them. When you add views (containing the revision clouds) to a sheet, the cloud created for revision 5 is numbered 1, the cloud created for revision 6 is numbered 2, and the cloud created for revision 7 is numbered 3.

The following diagram illustrates cloud numbering by project. The number in the cloud is the project-based revision number. The number in the tag is the revision number assigned to the cloud on the sheet.

![Diagram of Cloud Numbering by Project](image)

The following diagram illustrates cloud numbering by sheet. The number in the cloud is the project-based revision number. The number in the tag is the revision number assigned to the cloud on the sheet.

![Diagram of Cloud Numbering by Sheet](image)
Specifying Revision Cloud Numbering by Project or by Sheet

NOTE If you change the Numbering setting after creating revisions, revision numbers of all revision clouds may change. Specify the desired setting before entering revision information for the project.

1 In the project, click View tab ➤ Sheet Composition panel ➤ (Sheet Issues/Revisions).
2 In the Sheet Issues/Revisions dialog, for Numbering, select the revision numbering method for clouds on a sheet: Per Project or Per Sheet.
   See Revision Cloud Numbering by Project or by Sheet on page 1021.
3 Click OK.

Numbering for Revisions

Revit Structure provides flexibility in how it displays the sequence of revisions in a project. You can track revisions using the following numbering schemes:

- Numbers
- Letters or a user-defined sequence of letters or other characters
- No number or letter

Use the Sheet Issues/Revisions dialog to specify the numbering scheme to use for each revision. You can also specify the letters or other characters to use for a user-defined sequence.

You can start the project using one numbering scheme (such as numeric). Later in the project, you can use a different numbering scheme to indicate a different stage of the project. The Sequence number listed in the Sheet Issues/Revisions dialog maintains an overall, project-based sequence for all revisions, regardless of their individual numbering schemes.
Assigning a Numbering Scheme to a Revision

You can assign a numbering scheme to a revision when you first add it to the project. (See Entering Revision Information on page 1019.) You can also change the numbering scheme later.

To assign a numbering scheme to a revision

1. In the project, click View tab ➤ Sheet Composition panel ➤ (Sheet Issues/Revisions).
2. In the Sheet Issues/Revisions dialog, for the revision whose numbering scheme you want to change, click in the Numbering column.
3. From the list, select Numeric, Alphabetic, or None.
   For more information, see Defining an Alphabetic Sequence for Revisions on page 1023 and Revisions with No Numbering Scheme on page 1024.
4. Click OK.

Defining an Alphabetic Sequence for Revisions

If you use an alphabetic sequence for revision numbers, you can specify the characters and the order in which they occur. You can specify one alphabetic sequence per project.

To define an alphabetic sequence

1. In the project, click View tab ➤ Sheet Composition panel ➤ (Sheet Issues/Revisions).
2. In the Sheet Issues/Revisions dialog, under Alphabetic Sequence, click Options.
3. In the Sequence Options dialog, enter the characters to use for the sequence.
   The sequence can include letters and other characters (such as *, & and %). It cannot include spaces, numbers, or repeated characters.
   If the project contains more revisions than the number of characters in the sequence, Revit Structure uses double characters. For example, if you define the sequence abcdéfghij, and a project has more than 10 revisions, Revit Structure numbers the later revisions using aa, bb, cc, and so on.
4 Click OK.

Revisions with No Numbering Scheme

In some cases, you may want a revision to use no numbering scheme. For example, an unnumbered revision can indicate a project milestone or a document issuance. When assigning a numbering scheme to the revision, select None. (See Assigning a Numbering Scheme to a Revision on page 1023.)

Revision Clouds

Use revision clouds to indicate design areas that have changed in a project. You can sketch revision clouds in all views except 3D views. The cloud is visible in the view where it resides and on sheets that include the view.

After entering revision information, you can assign a revision to one or more clouds. Use tags to identify the revisions assigned to clouds. On sheets, revision clouds and tags can display in their views, if desired. For each sheet, the revision schedule includes information for the revisions represented by the clouds that are displayed in the views on the sheet.

Related topics

- Revision Workflow on page 1019
- Entering Revision Information on page 1019

Adding a Revision Cloud

1 In the project, open a view in which you want to indicate changes. You can sketch revision clouds in all views except 3D views.

2 Click Annotate tab ➤ Detail panel ➤ (Revision Cloud).
Revit Structure enters sketch mode.

3 Sketch a cloud, as follows:
   a In the drawing area, place the cursor near the part of the view that has changed.
   b Click and move the cursor in a clockwise direction to create a segment of the cloud.
   c Click to stop that segment and start a new segment.
   d Continue creating cloud segments until the cloud encompasses the changed area.

4 Sketch additional clouds, if needed.

5 Click Modify | Create Revision Cloud Sketch tab ➤ Mode panel ➤ (Finish Edit Mode).

By default, Revit Structure assigns to the clouds the latest revision assigned to any view on that view’s sheet. (In the sheet properties, the Current Revision parameter identifies this revision.) To assign a different revision, see Assigning a Revision to a Revision Cloud on page 1025.

Related topics
■ Revisions on page 1018
■ Revision Clouds on page 1024
■ Revision Workflow on page 1019

Assigning a Revision to a Revision Cloud

When you add a revision cloud to a view, by default Revit Structure assigns the most recent revision to the cloud. If needed, you can assign a different revision to the cloud. You can assign one revision to each cloud, or assign the same revision to multiple clouds.

To assign a revision to a cloud
   1 In a project view, select the revision cloud.
   2 On the Properties palette, for Revision, select the desired revision from the list.
   If you have not yet entered information for the revision that you want to assign to the cloud, see Entering Revision Information on page 1019.

Modifying a Revision Cloud

You can change the boundaries of a revision cloud. You can also change the line weight, color, and style of one cloud or all clouds in the project.

To change the boundaries and appearance of a revision cloud
   1 In a project view, select the revision cloud.
   2 To change its boundaries, do the following:
      a Click Modify | Revision Clouds tab ➤ Mode panel ➤ (Edit Sketch).
      Revit Structure enters sketch mode.
      b Select segments of the revision cloud, and drag the endpoints to adjust its boundaries.
Click Modify Revision Clouds > Edit Sketch tab ➤ Mode panel ➤ (Finish Edit Mode).

3 To change the appearance of the cloud, do the following:
   a Right-click the cloud, and click Override Graphics in View ➤ By Element.
   b Change the values for the Weight, Color, and Pattern of the cloud lines.
   c Click OK.

To change the appearance of all revision clouds

1 In the project, click Manage tab ➤ Settings panel ➤ (Object Styles).
2 Click the Annotation Objects tab.
3 For Revision Clouds, change the values for Line Weight, Line Color, and Line Pattern.
4 Click OK.

These changes apply to all revision clouds in the project.

Tagging a Revision Cloud

A revision tag identifies the revision assigned to each cloud in a view. (You enter revision information on the Sheet Issues/Revisions dialog. See Entering Revision Information on page 1019.)

To tag revision clouds

1 If the revision tag family is not yet loaded into the project, load it.
   A project created using the default project template includes the Revision Tag or M_Revision Tag family. To check whether another revision tag family is loaded, in the Project Browser, under Families ➤ Annotation Symbols, look for the revision tag family name. To load a revision tag family, see Loading Families on page 688 for instructions.
2 Open the view that contains revision clouds.
3 Click Annotate tab ➤ Tag panel ➤ (Tag By Category).
4 In the drawing area, select the revision clouds to tag.
   As you select each cloud, Revit Structure displays a revision tag next to it. Numbers in the tags reflect the revisions assigned to the clouds. (See Assigning a Revision to a Revision Cloud on page 1025.) On sheets, these tag numbers can differ. (See Revision Cloud Numbering by Project or by Sheet on page 1021.)
5 If desired, adjust the positions of the tags and their leader lines, as follows:
   a Press Esc to exit the Tab by Category tool.
   b Select a revision tag.
      You may need to zoom in to see the controls for the revision tag.
   c To reposition the tag, drag the blue arrows.
   d To adjust the elbow in its leader line, drag the blue dot.
To remove the leader line, on the Options Bar, clear Leader.

To assign the tag to a different revision cloud, click Modify | Revision Cloud Tags tab ➤ Host panel ➤ Pick New Host. In the drawing area, select the desired revision cloud for the tab.

For more information about applying a tag to an element, see Tags on page 944.

**Hiding a Revision Cloud**

You can hide revision clouds in a view. The method you use to hide revision clouds can determine whether the revision information (for the hidden clouds) displays in the revision schedule of a sheet.

To hide revision clouds but include their revisions in a revision schedule, use either of the following methods:

- **Sheet Issues/Revisions dialog.** (See Entering Revision Information on page 1019.) Use the Show column to indicate whether revision clouds and tags display for each revision. This setting affects all views in the project.

- **Hide in View > Category.** In a view, select one or more revision clouds, right-click, and click Hide in View ➤ Category. This tool hides all clouds in the view.

To hide revision clouds and omit their revisions from a revision schedule, use either of the following methods. By default the revision schedule of the view’s sheet does not include the revision information for these clouds. However, you can force the sheet to list the revisions, if desired. See Specifying the Revisions to Include in a Revision Schedule on page 1028.

- **Crop region.** If all or part of a revision cloud is outside the model crop region of a view, the cloud does not display in the view. See Crop Regions on page 849.

- **Hide in View > Elements.** In a view, select one or more revision clouds, right-click, and click Hide in View ➤ Elements.

**Revision Cloud Properties**

The following table describes properties for revision clouds. To see or change these properties, select a revision cloud in a view, and see the Properties palette.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revision</td>
<td>The revision assigned to the cloud. To change the assigned revision, select a revision from the list. (See Entering Revision Information on page 1019 and Assigning a Revision to a Revision Cloud on page 1025.)</td>
</tr>
<tr>
<td>Revision Number</td>
<td>A number assigned to the cloud, which displays in a revision tag and a revision schedule on a sheet. Its value depends on the assigned revision and the cloud numbering method. (See Revision Cloud Numbering by Project or by Sheet on page 1021.) This value is read-only.</td>
</tr>
<tr>
<td>Revision Date</td>
<td>The date of the assigned revision, based on the Date column of the Sheet Issues/Revisions dialog. This value is read-only.</td>
</tr>
<tr>
<td>Issued to</td>
<td>For the assigned revision, the value of the Issued to column of the Sheet Issues/Revisions dialog. This value is read-only.</td>
</tr>
<tr>
<td>Issued by</td>
<td>For the assigned revision, the value of the Issued by column of the Sheet Issues/Revisions dialog. This value is read-only.</td>
</tr>
</tbody>
</table>
Revision Schedules on Sheets

Most title blocks for sheets include a revision schedule. When you place a view on a sheet and the view includes revision clouds, the revision schedule automatically displays information about those revisions. If desired, you can specify that other revisions (not represented by revision clouds in the view) are to display in the revision schedule.

To display a revision schedule on a sheet, use a title block that includes a revision schedule. When designing the revision schedule, you can specify its format, orientation on the page, information that it displays, and sort order. You control these attributes of the revision schedule by modifying the title block family. See Revision Schedules on Title Blocks on page 998.

<table>
<thead>
<tr>
<th>ID</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>9/14</td>
<td>Wall Type Change</td>
</tr>
<tr>
<td>2</td>
<td>9/24</td>
<td>Accessible Modifications</td>
</tr>
<tr>
<td>3</td>
<td>10/15</td>
<td>Owner Request</td>
</tr>
<tr>
<td>4</td>
<td>11/02</td>
<td>Add Vision Lites</td>
</tr>
</tbody>
</table>

Specifying the Revisions to Include in a Revision Schedule

By default, the revision schedule on a sheet lists the revisions relating to revision clouds in the views of the sheet. Use the following procedure to list more revisions on the revision schedule.

This procedure assumes that you have created a project with views and sheets that include revision schedules, entered revision information, added revision clouds to views, and tagged the clouds.

To specify the revisions to include in a revision schedule

1. Open a sheet.
2. Zoom in on the revision schedule in the title block for the sheet.
3. Click in the drawing area to display sheet properties on the Properties palette.
4. On the Properties palette, for Revisions on Sheet, click Edit.

The Revisions on Sheet dialog lists all revisions entered in the Sheet Issues/Revisions dialog. Revisions assigned to clouds in views on the sheet are already selected, and they are read-only.
5 Select Shown in Revision Schedule for each revision that you want to include in the revision schedule on this sheet.

6 Click OK.

The revision schedule on the sheet updates to include the selected revisions.

Issuing a Revision

After you have completed revisions to a project and added the revised views to a sheet, you can issue the revision. In Revit Structure, marking a revision as Issued means the following:

- On the Sheet Issues/Revisions dialog, you can no longer change information for that revision.
- In project views, you can no longer assign the issued revision to additional (new) revision clouds.
- You cannot edit revision clouds to which the issued revision is assigned.

To issue a revision

1 In the project, click View tab ➤ Sheet Composition panel ➤ (Sheet Issues/Revisions).
2 In the Sheet Issues/Revisions dialog, do the following:
   a For Issued to, indicate the person or organization to whom the revisions will be issued.
   b For Issued by, indicate the person or organization who will issue the revision.
   c Check the other values for the revision row (such as Date and Description). Update them if needed.
   d Select Issued.
      Most of the revision row displays as read-only. After selecting Issued, you cannot make further changes to the revision information.

**NOTE** If you must change any revision information after issuing the revision, clear Issued, make the changes, and then select Issued again.

   e Click OK.
3 Print or publish the revised sheets. See Print on page 1146 or Publish on page 1142.
You can use Revit Structure to generate a real-time rendered view of a building model using the Realistic visual style, or you can create a photorealistic image of the model using the Rendering tool. Revit Structure renders 3D views with various effects and content, such as lighting. The real-time rendering view displays realistic materials and textures. Either of these rendering styles can be used to present the design to clients or share with team members. See Real-time Rendering Overview on page 1032.

As an alternative, you can export a 3D view, and use another software application to render the image. See Exporting to 3ds Max on page 1139.

Rendering Workflow

In Revit Structure, the process of rendering a 3D view is as follows. (The first 4 steps can be performed in any order.)

1. Create a 3D view of the building model.
See 3D Views on page 757.

2 Specify render appearances for materials, and apply materials to model elements.
   See Materials on page 1573.

3 Define lighting for the building model.
   □ If the rendered image will use artificial lights, add them to the building model. See Lights on page 1033.
   □ If the rendered image will use natural light, define sun and shadow settings.

4 Define render settings.

5 Render the image.

6 Save the rendered image.
   See Saving the Rendered Image as a Project View on page 1088 or Exporting the Rendered Image to a File on page 1088.

Real-time Rendering Overview

You can create a real-time rendering to display a Revit Structure model using the Realistic visual style, or you can create a photorealistic image of the model using the Rendering tool. The following images illustrate these rendering types.

<table>
<thead>
<tr>
<th>Realistic (uses Realistic visual style)</th>
<th>Photorealistic (uses Rendering tool)</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Realistic Image]</td>
<td>![Photorealistic Image]</td>
</tr>
</tbody>
</table>

The Realistic visual style instantly displays realistic material appearances in the model view. With the shadow and depth settings applied, you can rotate the model to display its surfaces as they would appear in different lighting situations. See Realistic Visual Style on page 871.

The process to create a real-time rendering view is as follows:

■ Create a model element, or open an existing model.

■ Specify realistic material appearances for the element. See Materials on page 1573.

■ Specify display options. See Graphic Display Options on page 871.

■ Open view that you can edit.

**NOTE** Real-time rendered views are not available in Drafting views, Schedules, or Legends.

■ Specify the Realistic visual style on the View Control Bar.
In order to display materials using the Realistic visual style, the Use Hardware Acceleration (Direct3D®) option is turned on by default. When you start Revit, if your computer's video card and driver have not been tested with Revit, or if they do not meet minimum requirements, a warning displays that describes the issue. The warning has a hyperlink to an Autodesk website that lists the tested video cards and drivers. Because materials can only render with hardware acceleration, if Hardware Acceleration is turned off, the Realistic visual style will look the same as the Shaded visual style. Click Options ➤ Graphics tab ➤ Use Hardware Acceleration (Direct3D®) to access the hardware acceleration setting.

Related topic
■ Visual Styles on page 867

Lights

When designing a building, you can place artificial lights on its exterior and interior to address lighting needs and plan the visual impact of lights. You can define lighting fixtures and their light sources, placing them in the building model for best effect. When you render a 3D view, you can specify whether the artificial lights, natural light, or both, will display in the rendered image.

Related topic
■ Specifying a Sun Setting on page 1390

Lights Overview

Lighting is an important factor in conveying the design intent. When rendering a 3D view of a building model, you can use natural light, artificial light, or both to illuminate the building.

For natural light, you specify the direction of the sunlight, or the location, date, and time of day to achieve a realistic representation of sunlight on the building. For artificial light, you add lighting fixtures to the building model, organizing them into light groups if desired. Before rendering, you can turn on or off individual lighting fixtures or light groups to achieve the desired effect. The resulting rendered image shows the effects of lighting on the design.
Lighting Fixtures

In Revit Structure, a lighting fixture is a model element that emits light from one or more light sources. A lighting fixture is defined by a Revit lighting fixture family. (See Revit Families on page 677.)

Revit Structure provides several lighting fixture families for wall lights, ceiling lights, table lamps, floor lamps, exterior lighting, and other types of lighting fixtures. You can use the Family Editor to design your own lighting fixtures. You can also download additional lighting fixture families from the Revit Web Content Library and other sources.

Related topics
- Creating and Modifying Lighting Fixtures on page 1038
- Using Lighting Fixtures in a Building Model on page 1059

Light Sources

A light source is the part of a lighting fixture that emits light (such as a light bulb). In general, each lighting fixture family has one light source. To create a lighting fixture that uses multiple light sources (such as a chandelier or a set of track lights), create a nested family.

For each light source, you can specify the shape of the light element (point, line, rectangle, or circle), and the light distribution (spherical, hemispherical, spot, or photometric web). You can also define photometric characteristics, such as Light Loss Factor, Initial Intensity, and Initial Color Control. In a project, you can adjust the position and brightness of each light source to achieve the desired lighting effects.
Photometrics and IES Files

In Revit Structure, photometrics are parameters for creating realistic lighting fixture families. Photometrics help to define the visible light that displays in a rendered image of a building model.

The photometrics that are available for a particular lighting fixture depend on its light source definition. They include parameters such as Light Loss Factor, Initial Intensity, and Initial Color Control.

When you specify that the light distribution of a light source is Photometric Web, you can specify an IES file. An IES file is a text file provided by a lighting manufacturer. It describes the intensity of a light source at points on a spherical grid. It also describes the geometry of how the light comes out of the lighting fixture (the photometric web).
Revit Structure uses the IES file to make a photometric web to represent the light source. In general, IES files result in more accurate lighting results in rendered images. For information about the IES file format, go to http://www.iesna.org. See Specifying an IES File for a Light Source on page 1047.

**Lighting Best Practices**

To get the most accurate results in shaded views and rendered images, use the following best practices.

**Related topic:**
- Render Performance and Lighting on page 1091

**Use IES Files**

When specifying photometric properties for a lighting fixture, set the light distribution to Photometric Web, and use the manufacturer's IES file, if one is available. Because an IES file provides a more accurate representation of the light source, you get better results in a rendered image.

To obtain an IES file, go to the website of the lighting manufacturer, and search for ies. Locate the IES file for the desired lighting product, and save it to your computer. See Specifying an IES File for a Light Source on page 1047.

**Leave Connectors in Place**

When displayed in the Family Editor, some lighting fixtures include a connector. In the drawing area, a connector typically displays a green outline with an orange lighting bolt at the origin.
These connectors are used in Revit MEP. They allow electrical engineers to connect the lighting fixtures to circuits in an electrical plan.

If you are not working with an electrical engineer, you can delete these connectors from their lighting fixture families, or hide them in views. (See Hiding Elements in a View on page 811.) Otherwise, leave the connectors in place.

Related topic

- Connectors on page 696

**Adjust Light Sources Before Rendering**

A common goal of rendering an image is to check the effect of lighting on the building model. For example, suppose you want to evenly illuminate the facade of a building. After placing lighting fixtures, you want to make sure that the lights provide the desired result.

However, the rendering process can be resource-intensive. Before rendering, therefore, do as much as possible to plan the placement of lighting fixtures for maximum effect. In Revit Structure, you can use 2D and 3D
views to plan the appropriate spacing, angle, and setback of lighting fixtures in the building model. For the view’s visual style, use Shaded or Shaded with Edges to see how the light hits a wall or other surface.

Creating and Modifying Lighting Fixtures

In Revit Structure, lighting fixtures are model elements that are defined by Revit families. Revit Structure provides several lighting fixture families, which you can use in projects or as the basis for custom lighting fixtures. To create or modify a lighting fixture family, use the Family Editor.

Creating a Lighting Fixture with One Light Source

1. Click ➤ New ➤ Family.
2. In the New Family - Select Template File dialog, select a light fixture template.
The names of all lighting fixture templates include the words Lighting Fixture. Be sure to select the appropriate template for the type of lighting fixture that you want to create. For example, to create a ceiling-based fixture for metric projects, use Metric Lighting Fixture ceiling based.rft.

Revit Structure opens the Family Editor. The template defines reference planes and a light source. For ceiling-based and wall-based fixtures, the template includes a ceiling or wall to host the fixture. See Family Editor on page 678.

3 Define the geometry of the light source for the lighting fixture.
See Defining the Geometry of a Light Source on page 1050.

4 Sketch solid geometry for the lighting fixture.
See Creating Solid and Void Geometry on page 1420.

TIP If you want the surface of the light bulb to display in a rendered image, create geometry for it. Then apply a material to it, and, for its render appearance, select Light Bulb - On from the Render Appearance Library. This render appearance models the surface of a light bulb that is turned on. It is white, shiny, and emits the appropriate amount of light.

5 Click Home tab ➤ Properties panel ➤ Family Types.
6 In the Family Types dialog, specify values for the parameters.
See Parameters for Lighting Fixtures and Light Sources on page 1052.

7 Click OK.
8 Click Load into Project to load the light fixture into the current project, or save the fixture and exit the Family Editor.

Creating Lighting Fixtures with Multiple Light Sources

To create a lighting fixture that uses multiple light sources (such as a chandelier or a set of track lights), create a nested family. The host family represents the hardware that supports the light sources (for example, the hardware for a chandelier, or the track for a set of track lights). Then you create another lighting fixture family that defines the light source (for example, the candles in a chandelier, or the can lights for a set of track lights). This family is nested into the host family. For more information about nested families, see The Families Guide on page 680

A nested chandelier family

A nested track light family

The nested family (that defines the light sources) can be shared or not shared, depending on whether you want to be able to schedule the light sources and control their photometric parameters individually. See Sharing a Lighting Fixture Family on page 1040.
Sharing a Lighting Fixture Family

The nested family that defines the light sources in a chandelier or set of track lights can be shared or not shared. Sharing the nested family affects how the lighting fixture is scheduled, and how parameters for the family can be changed, as follows. (For information about creating a nested family of shared components, see The Families Guide on page 680.)

<table>
<thead>
<tr>
<th>Nested family is...</th>
<th>Impact on scheduling</th>
<th>Impact on changing family parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shared</td>
<td>Individual light sources can be listed separately in a lighting fixture schedule. For example, for a set of track lights, can lights can be listed individually, grouped, or totalled.</td>
<td>If needed, each light source in the fixture can have different settings. For example, you can change the initial intensity of each can light in a set of track lights.</td>
</tr>
<tr>
<td>Not shared</td>
<td>In a lighting fixture schedule, the entire fixture (and its light sources) are listed as one item. For example, for a chandelier, the individual candles cannot be listed individually, grouped, or totalled.</td>
<td>You can change settings for the entire lighting fixture as a whole, but you cannot change settings for individual light sources. For example, you can change the initial intensity for the entire chandelier, but not for its individual candles.</td>
</tr>
</tbody>
</table>

To share a lighting fixture family

1. Open the lighting fixture family in the Family Editor.
2. Click Home tab ➤ Properties panel ➤ Family Category and Parameters.
3. Under Family Parameters, select Shared.
4. Click OK.

To make a lighting fixture family not shared

1. Open the lighting fixture family in the Family Editor.
2. Click Home tab ➤ Properties panel ➤ Family Category and Parameters.
3. Under Family Parameters, clear Shared.
4. Click OK.

Creating Track Lights

The following procedure describes a general method for creating a set of track lights. You can also use this procedure to create a lighting fixture family that has multiple light sources that you want to schedule individually or to control lighting parameters individually. The specific steps required will vary, depending on your needs and design intent.
To create a set of track lights

1 Create a lighting fixture family to represent the light source.
   For example, create a family that describes a can light in a set of track lights. Create the geometry
   for the can fixture, and define its light source.
   See Creating a Lighting Fixture with One Light Source on page 1038.
   In the following steps, this family is referred to as the light source family.

2 For the light source family, turn on the Light Source and Shared parameters, as follows:
   a Click Home tab ➤ Properties panel ➤ Family Category and Parameters.
   b In the Family Category and Parameters dialog, under Family Parameters, select Light Source.
      Turning on the light source allows you to specify photometric parameters for it.
   c Select Shared.
      Sharing the light source family ensures that a lighting fixture schedule can display
      information for individual lights, and that you can adjust lighting parameters for individual
      lights. (See Sharing a Lighting Fixture Family on page 1040.)
   d Click OK.
   e Save the light source family.

3 Create the host lighting fixture family, as follows:
   a Create the geometry for the lighting fixture.
      For example, for a set of track lights, create the track on which the can lights will be
      mounted. See Creating a Lighting Fixture with One Light Source on page 1038.

   b Create reference planes that can be used to position the light sources and lock them to the
      lighting fixture (the track).
      See Reference Planes on page 1523.
For the host lighting fixture family, turn off the Light Source and Shared parameters, as follows:

a. Click Home tab ➤ Properties panel ➤ Family Category and Parameters.
b. In the Family Category and Parameters dialog, under Family Parameters, clear Light Source. When you turn off the light source for the host lighting fixture family, photometric parameters are not available for it. Instead, you define the photometric parameters in the light source family (for example, for the can lights).
c. Clear Shared.
d. Click OK.
e. Save the lighting fixture family.

5 Load the light source family (the can lights) into the host lighting fixture family (the track). See Modifying Families in a Project (or Nested Family) on page 692.

6 Place one or more instances of the light source family into the host lighting fixture family, as follows:
   a. If needed, open the host lighting fixture family in the Family Editor.

b. Click Home tab ➤ Model panel ➤ (Component).
c. Select the light source family from the Type Selector on page 35.
d. Click in the drawing area to place instances of the light source (the can light) in the lighting fixture (the track). Use the reference planes to position the light sources correctly.
e. Lock the light sources to the reference planes.
   See Using Pins to Lock Elements in Place on page 1485.
Save changes to the host lighting fixture family.

Now you can place instances of the lighting fixture (the track light set containing multiple can lights) in the building model. See Using Lighting Fixtures in a Building Model on page 1059.

Creating a Chandelier

The following procedure describes a general method for creating a chandelier. You can also use this procedure to create a lighting fixture family that has multiple light sources, and for which you do not want to schedule the light sources or control their lighting parameters individually. The specific steps required will vary, depending on your needs and design intent.

To create a chandelier

1 Create the host chandelier family, as follows:
   a Create the geometry (hardware) for the chandelier.
      See Creating a Lighting Fixture with One Light Source on page 1038.
b Create reference planes that can be used to position the candles in place and lock them to the chandelier.
See Reference Planes on page 1523.

2 For the host chandelier family, define parameters as follows:
   a Click Home tab ➤ Properties panel ➤ Family Category and Parameters.
   b In the Family Category and Parameters dialog, under Family Parameters, select Light Source.
   c Clear Shared.
   d Click OK.

3 In the host chandelier family, create one candle (light source) as follows:
   a Create geometry for the candle.
   b Put the candle in the desired position on the chandelier, and lock it in place.
   c Define the geometry of the light source.
      See Defining the Geometry of a Light Source on page 1050.
   d Define its parameters.
      See Defining Parameters for Lighting Fixtures and Light Sources on page 1051.
   e In the drawing area, move the light source symbol to align it with the candle as appropriate, and lock it in place.

4 Create a lighting fixture family to represent a candle of the chandelier, as follows:
NOTE You will nest this family into the host chandelier family, and place multiple instances of this family (that is, multiple candles) in the chandelier. So this family should represent a single light source or candle.

a In this family, create the geometry of the candle. If desired, you can copy and paste the candle geometry that you created in the host chandelier family.

NOTE In the sample chandelier shown previously, the candle does not have any geometry. Instead, it defines the light source only.

b Define family parameters: Click Home tab ➤ Properties panel ➤ Family Category and Parameters. Under Family Parameters, select Light Source, clear Shared, and click OK.

c Define the geometry of the light source.

See Defining the Geometry of a Light Source on page 1050.

Geometry of the light source for the chandelier candle

d Define parameters for the light source.

See Defining Parameters for Lighting Fixtures and Light Sources on page 1051.

e Save the light source family.

In the following steps, this family is referred to as the candle family.

5 Load the candle family into the host chandelier family.

See Modifying Families in a Project (or Nested Family) on page 692.

6 Place one or more instances of the candle family into the host chandelier family, as follows:

a Open the host chandelier family in the Family Editor.

b Click Home tab ➤ Model panel ➤ (Component).

c Select the light source family from the Type Selector on page 35.

d Click in the drawing area to place instances of the light source (candles) in the chandelier. Use the reference planes to position the candles correctly.

e Lock the candles to the reference planes.

See Using Pins to Lock Elements in Place on page 1485.
7 Link the Initial Intensity parameter of the candle family to the Initial Intensity parameter of the host chandelier family.

When you link these parameters and add a chandelier to a building model, in the project you can adjust the Initial Intensity parameter (or other linked parameters) for the chandelier as a whole. You cannot change the Initial Intensity of individual candles in a chandelier.

a In the host chandelier family, select one of the candles from the candle family.

b Click Modify ‹Elements› tab ‹Properties panel› (Type Properties).
The Type Properties dialog displays a column with an equal sign in the column heading . A gray button displays in this column for each type parameter that you can link to other parameters.

c Click the gray button in the column for the Initial Intensity parameter (or any other parameter that you want to be able to change for the chandelier in a project).
In the Associate Family Parameter dialog, select Initial Intensity (or the parameter that corresponds to the type parameter that you selected), and click OK.

8 Save changes to the host chandelier family. Now you can place instances of the chandelier family in the building model. See Using Lighting Fixtures in a Building Model on page 1059.

Specifying an IES File for a Light Source

An IES file is a text file that describes the intensity of a light source at points on a spherical grid. It provides more photorealistic lighting effects in rendered images than other types of light distribution. See Photometrics and IES Files on page 1035.

Specifying an IES file for a light source is a 2-step process. First, in the light source definition, you must specify Photometric Web for its light distribution. (To perform this step, you edit the lighting fixture family.) Second, you must specify the particular IES file to use. (You can perform this step when editing the lighting fixture family, or when modifying type parameters for particular lighting fixture in a project.)

To specify an IES file for a light source

1 Obtain the desired IES file.

You can obtain an IES file directly from the manufacturer, or use an IES file provided by Revit Structure. The Revit IES files reside in the following location, by default:

Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk<Revit release name>\IES

Windows Vista or Windows 7: C:\ProgramData\Autodesk<Revit release name>\IES
2 Specify Photometric Web light distribution, as follows:
   a Open the lighting fixture family in the Family Editor.
      See Modifying a Lighting Fixture Family on page 1049.
   b In the drawing area, select the light source.
   c Click Modify | Light Source tab ➤ Lighting panel ➤ (Light Source Definition).
   d In the Light Source Definition dialog, for Emit from Shape, select the desired shape.
   e For Light distribution, select (Photometric Web).
   f Click OK.
   g Save changes to the lighting fixture family.

3 Specify the IES file to use, as follows:
   a If you want the IES file to define light distribution for the entire lighting fixture family,
      keep the lighting fixture family open in the Family Editor. Click Properties panel ➤
      (Family Types). For Name, select the family type to modify.
   b If you want the IES file to define light distribution for selected instances of the lighting
      fixture family, open a project that uses it, and select a lighting fixture in the project. Click
      Modify | Lighting Fixtures tab ➤ Properties panel ➤ (Type Properties). Click
      Duplicate, specify a name for the new family type, and click OK.
   c In the list of parameters, scroll down to Photometrics.
   d For Photometric Web File, click in the Value column.
   e Click (Browse).

      ![Photometric Web File](image)

      NOTE The Browse button displays after you click in the field.
   f Navigate to the desired IES file, select it, and click Open.
   g Click OK.
   h Save changes to the project or the lighting fixture family.

In the drawing area, the shape of the light source reflects the specified IES file. (To see the light source in a
project view, you must make light sources visible. See Displaying Light Sources in a View on page 1062.)
Modifying a Lighting Fixture Family

Use the Family Editor to modify a lighting fixture family to change the design of the fixture or to define its light source.

To modify a lighting fixture family

1. Open a lighting fixture family for editing, using one of the following methods:
   - Open a project that contains instances of the lighting fixture. In the Project Browser, expand Families ➤ Lighting Fixtures. Right-click the name of the lighting fixture family to modify, and click Edit.
   - In the Revit window, click ➤ Open ➤ Family. Navigate to the location of the lighting fixture family (RFA) file. Select the file, and click Open.

   The Family Editor opens, displaying the lighting fixture family in the drawing area.

2. Modify the lighting fixture family as desired.
   - To change the hardware of the lighting fixture, edit its geometry.
     See Family Editor on page 678.
   - To change the light source definition, select the light source in the drawing area. Click Modify ▶ Light Source tab ➤ Lighting panel ➤ (Light Source Definition). Select the desired Emit from Shape and Light distribution values, and click OK.
     See Defining the Geometry of a Light Source on page 1050.
   - To change parameters for the lighting fixture (including photometrics), click Properties panel ➤ (Family Types). For Name, select the family type to modify. Change the parameters, and click OK.
     See Parameters for Lighting Fixtures and Light Sources on page 1052.

3. To save changes to the lighting fixture, click ➤ Save.

4. Load the lighting fixture into a project.
   See Loading Families on page 688.

Defining a Light Source

The light source is the part of a lighting fixture that emits light. (See Light Sources on page 1034.) To ensure that a lighting fixture emits light and to define the type of light, use the following procedure.

The following procedure assumes that the lighting fixture family is open for editing in the Family Editor.

To define a light source

1. For the lighting fixture family, turn on the Light Source parameter, as follows. (This parameter is usually turned on by default.)
   - Click Home tab ➤ Properties panel ➤ (Family Category and Parameters).
   - In the Family Category and Parameters dialog, under Family Parameters, select Light Source.
2 Define the geometry of the light source (that is, the shape of the light that emits from the fixture).
See Defining the Geometry of a Light Source on page 1050.

3 Define parameters for the light source.
See Parameters for Lighting Fixtures and Light Sources on page 1052.

Defining the Geometry of a Light Source

The geometry of a light source determines the shape of the light that emits from the lighting fixture. For example, the following image shows 2 different geometries for light sources.

NOTE The Family Editor is the only place where you can define the geometry of a light source in a lighting fixture family. You cannot change the geometry of a light source for a lighting fixture in the context of a project.

To define the geometry of a light source

1 Create a lighting fixture family, or open a lighting fixture family for editing.
   See Creating a Lighting Fixture with One Light Source on page 1038 or Modifying a Lighting Fixture Family on page 1049.

2 In the drawing area, select the light source.
   In the Family Editor, the light source is generally represented by a yellow outline or shape.

NOTE If the light source does not display in the Family Editor, the light source is not turned on. To turn it on, click Home tab ➤ Properties panel ➤ Family Category and Parameters, select Light Source, and click OK.

3 Click Modify | Light Source tab ➤ Lighting panel ➤ (Light Source Definition).
As an alternative, on the Properties palette, for Light Source Definition, click Edit. The Light Source Definition dialog displays.

4 For Emit from Shape, select the shape of the light to emit from the light source: Point, Line, Rectangle, or Circle.

5 For Light distribution, select the pattern of light distribution for the light source: Spherical, HemiSpherical, Spot, or Photometric Web.

**TIP** If you plan to specify an IES file to define the photometric shape of the light source, select Photometric Web. See Specifying an IES File for a Light Source on page 1047.

The middle image changes to illustrate the combined settings. These settings determine the parameters that are available for the light source. See Defining Parameters for Lighting Fixtures and Light Sources on page 1051.

6 Click OK.

The outline shape for the light source may change in the drawing area, depending on the selected light source definition settings.

7 Save changes to the lighting fixture family.

### Defining Parameters for Lighting Fixtures and Light Sources

The parameters that you can define for a lighting fixture and its light source vary, depending on the light source definition settings that you specify. (See Defining the Geometry of a Light Source on page 1050.)

**NOTE** In addition to defining these parameters for a lighting fixture family in the Family Editor, you can also change many of them for an instance or type of lighting fixture in a project. See Changing a Lighting Fixture in a Building Model on page 1061.

**To define parameters for a lighting fixture and its light source**

1 Create a lighting fixture family, or open a lighting fixture family for editing.

See Creating a Lighting Fixture with One Light Source on page 1038 or Modifying a Lighting Fixture Family on page 1049.
2 Click Home tab ➤ Properties panel ➤ (Family Types).

3 In the Family Types dialog, for Name, select the family type to modify.
   You can define different parameter values for different family types. For more information, see The Families Guide on page 680.

4 Define parameters as desired.
   See Parameters for Lighting Fixtures and Light Sources on page 1052.

5 Click Apply.

6 (Optional) Repeat this process for other family types defined for the lighting fixture family: For Name, select another family type. Define its parameters. Click Apply.

7 Click OK.

8 Save changes to the lighting fixture family.

Parameters for Lighting Fixtures and Light Sources

You can change parameters for lighting fixtures and their light sources when defining a lighting fixture in the Family Editor, or when modifying a lighting fixture in a building model. (See Modifying a Lighting Fixture Family on page 1049 or Changing a Lighting Fixture in a Building Model on page 1061.)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Electrical - Lighting</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calculate Coefficient of Utilization (default)</td>
<td>A value used by Revit MEP to indicate that the Coefficient of Utilization will be calculated for the lighting fixture by default. In a project, you can change this default behavior by changing instance properties.</td>
<td></td>
</tr>
<tr>
<td>Coefficient of Utilization (default)</td>
<td>A value used by Revit MEP to define the efficiency of a lighting fixture in transferring luminous energy to the work plane in a particular area. This value shows the percentage of lumens that reach the work plane after light is lost due to the fixture’s efficiency at transmitting light, the room proportions, and the ability of room surfaces to reflect light. If you select Calculate Coefficient of Utilization (default), this parameter is read-only. If you clear Calculate Coefficient of Utilization (default), you can enter a value between 0 and 1, or enter a formula. In a family, this parameter defines the default value for the lighting fixture. In a project, you can change the default in instance properties.</td>
<td></td>
</tr>
<tr>
<td>Electrical - Loads</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Apparent Load</td>
<td>A value used by Revit MEP to define the real and reactive power used by a fixture. To determine Apparent Load, multiply the apparent current by the voltage. This parameter is measured in volt amps (VA).</td>
<td></td>
</tr>
<tr>
<td>Dimensions: These parameters do not affect rendered images.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Light Source Symbol Size</td>
<td>The size of the symbol that represents the light source in 2D and 3D views, extending from the boundary of the Emit from Shape outwards. For example, suppose you define a light source with an Emit from Shape of circle and an Emit from Circle Diameter of 500 mm. If you specify a Light Source Symbol Size of 200 mm, in a 2D view, Revit Structure shows a light source symbol that is 900 mm in diameter</td>
<td></td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>(200+500+200). This parameter is available when the Emit from Shape setting is Circle or Rectangle. (See Defining the Geometry of a Light Source on page 1050.) This parameter does not affect the light in a rendered image.</td>
<td>Light Source Symbol Length The length of the symbol that represents a spotlight in 2D and 3D views, extending from the spotlight outwards. This parameter is available when the light distribution setting is Spot. (See Defining the Geometry of a Light Source on page 1050.) This parameter does not affect the light in a rendered image.</td>
<td></td>
</tr>
</tbody>
</table>

### Identity Data

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keynote</td>
<td>Keynote for the lighting fixture. Enter text or click ... to select a standard keynote. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>Model number or code assigned to the lighting fixture by the manufacturer or vendor.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Name of the manufacturer of the lighting fixture.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>User-defined comments or other information about this family type for the lighting fixture family.</td>
</tr>
<tr>
<td>URL</td>
<td>URL of the Web site for the manufacturer or vendor.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the lighting fixture.</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code for the lighting fixture.</td>
</tr>
<tr>
<td>Cost</td>
<td>Cost of the lighting fixture.</td>
</tr>
</tbody>
</table>

**Electrical:** These parameters do not affect rendered images.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ballast Voltage</td>
<td>Voltage required to operate the ballast. A ballast is an electrical device that provides the starting voltage and limits the current to sustain lamp operation. (This information is used by Revit MEP.)</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ballast Number of Poles</td>
<td>The number of leads in the circuit. Enter 1, 2, or 3. (This information is used by Revit MEP.)</td>
</tr>
<tr>
<td>Lamp</td>
<td>Number and type of light bulbs used in the lighting fixture. (This information can be useful in schedules.)</td>
</tr>
<tr>
<td>Wattage Comments</td>
<td>User-defined information about wattage requirements for the lighting fixture.</td>
</tr>
</tbody>
</table>

**Photometrics:** The following parameters affect rendered images. You may be able to obtain parameter values from the manufacturer of the light source. Check the manufacturer’s website.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Photometric Web File</td>
<td>The IES file that defines the light emitted from the light source. This parameter is available when the Light distribution setting is Photometric Web. (See Specifying an IES File for a Light Source on page 1047.)</td>
</tr>
<tr>
<td></td>
<td>To specify a file, click in the Value column, and click ... . Navigate to the IES file, and click Open.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> Revit Structure does not maintain a link to the IES file. If you change or update the IES file on disk, you must also update this parameter by navigating to the new version of the file.</td>
</tr>
<tr>
<td>Spot Tilt Angle</td>
<td>The angle to tilt the light source to direct its light. (See Angles for Spotlights on page 1065.) Enter a value between 0 and 160. This parameter is available when the Light distribution setting is Spot or Photometric Web. (See Defining the Geometry of a Light Source on page 1050.)</td>
</tr>
<tr>
<td>Spot Field Angle</td>
<td>The angle at which the light intensity reaches 10% of the peak intensity. Enter a value between 0 and 160. This parameter is available when the Light distribution setting is Spot. (See Angles for Spotlights on page 1065.)</td>
</tr>
<tr>
<td>Spot Beam Angle</td>
<td>The angle at which the light intensity reaches 50% of the peak intensity. This parameter is available when the Light distribution setting is Spot. (See Angles for Spotlights on page 1065.)</td>
</tr>
<tr>
<td>Light Loss Factor</td>
<td>A value used to calculate the amount of light lost (or gained) due to environmental factors, such as dust and ambient temperature. Click in the Value field to display the Light Loss Factor dialog. See Light Loss Factor Parameters on page 1056.</td>
</tr>
<tr>
<td>Initial Intensity</td>
<td>Brightness of the light before environmental factors reduce or change the quality of the light. Click in the Value field to display the Initial Intensity dialog. See Initial Intensity Parameters on page 1058.</td>
</tr>
<tr>
<td>Initial Color</td>
<td>The color of the light source before it is affected by color filters and environmental factors. Click in the Value field to display the Initial Color dialog. See Initial Color Parameters on page 1059.</td>
</tr>
<tr>
<td>Emit from Circle Diameter</td>
<td>The diameter of the light source that emits light in a rendered image. This parameter is available when the Emit from Shape setting is Circle. (See Defining the Geometry of a Light Source on page 1050.)</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Emit from Rectangle Width</td>
<td>The width of the rectangle that represents the light source in a rendered image. This parameter is available when the Emit from Shape setting is Rectangle. (See Defining the Geometry of a Light Source on page 1050.)</td>
</tr>
<tr>
<td>Emit from Rectangle Length</td>
<td>The length of the rectangle that represents the light source in a rendered image. This parameter is available when the Emit from Shape setting is Rectangle.</td>
</tr>
<tr>
<td>Emit from Line Length</td>
<td>The length of the line that represents the light source in a rendered image. This parameter is available when the Emit from Shape setting is Line. (See Defining the Geometry of a Light Source on page 1050.)</td>
</tr>
<tr>
<td>Emit Shape Visible in Rendering</td>
<td>Select this option to make the shape of the light visible as a self-luminous surface (glow) when the camera (of the 3D view) is aimed directly at the light source. This parameter is available when the Emit from Shape setting is Rectangle or Circle. (See Defining the Geometry of a Light Source on page 1050.) In addition to setting this parameter, when defining render settings, you must select the Soft Shadows option on the Render Quality Settings dialog. See Defining a Custom Render Quality on page 1081 and Render Quality Settings on page 1081.</td>
</tr>
<tr>
<td>Dimming Lamp Color Temperature Shift</td>
<td>Specify whether the color and intensity of a dimmed light source change based on predefined curves. For example, incandescent lights typically become more yellow when dimmed. Select Incandescent Lamp Curve or none. To see the effect of this parameter, you must dim lights in the building model. See Dimming Lights on page 1066.</td>
</tr>
<tr>
<td>Color Filter</td>
<td>Color used to change the light emitted from the light source. Click in the Value column. In the Color dialog, select the desired color, and click OK. See Colors on page 1622.</td>
</tr>
</tbody>
</table>

### Defining the Light Loss Factor

The light loss factor is a value used to calculate the amount of light lost due to environmental factors, such as dust and ambient temperature.

You can define the light loss factor for a lighting fixture family file (as follows). In a project, you can change the light loss factor of an individual lighting fixture. (See Changing the Light Loss Factor for a Light Source on page 1066.)

**To define the light loss factor**

1. Open the lighting fixture family.
2. Click Home tab ➤ Properties panel ➤ (Family Types).
3 For Name, select the family type to modify.
4 Scroll down the list to locate the Light Loss Factor parameter, and click in its Value column. The Light Loss Factor dialog displays.
5 Specify the calculation method for Light Loss Factor:

**Simple calculation**
- Specify as follows:
  a For Method, select Simple.
  b For Total Light Loss Factor, move the slider to adjust the value between Dimmer and Brighter.
  c Click OK.

**Advanced calculation**
- Specify as follows:
  a For Method, select Advanced.
  b Under Value, adjust the sliders for each parameter, or enter a value in the text box.
    See Light Loss Factor Parameters on page 1056.
  c Click OK.

The Family Types dialog displays the new Light Loss Factor value.
6 Click OK.
7 Save changes to the lighting fixture family.

**Light Loss Factor Parameters**

When you turn on a lighting fixture, light travels through the light source (lamp or ballast) and the lighting fixture (such as a lamp shade or lensed troffer), until it reaches the work plane where it is needed. Along the way, the amount of transmitted light is reduced, obscured by the light source, the lighting fixture, and other environmental factors. The Light Loss Factor measures the reduction of light as it travels from the light source.

When defining the Light Loss Factor for a light, define the parameters as follows. Check with the lamp manufacturer for the appropriate Light Loss Factor values for a particular type of lamp.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temperature Loss/Gain Factor</td>
<td>For fluorescent light sources, a measure of the amount of light lost or gained due to deviations above or below the ideal operating temperature. Valid values are between 0 and 2. A value of 1.0 indicates that no light is lost or gained due to temperature changes. Values greater than 1.0 indicate an increase in light. Values less than 1.0 indicate a loss of light.</td>
</tr>
<tr>
<td>Voltage Loss/Gain Factor</td>
<td>A measure of the amount of light lost or gained due to fluctuations in voltage delivered to the light source. Valid values are between 0 and 2. A value of 1.0 indicates that no light is lost or gained due to voltage changes. Values greater than 1.0 indicate an increase in light. Values less than 1.0 indicate a loss of light.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ballast Loss Factor</td>
<td>Lamps and ballasts experience losses when operating together as a system. The Ballast Loss Factor is the percentage of a lamp’s initial rated lumens that is produced by a given ballast. Valid values are between 0 and 1. For example, a value of 0.95 indicates that the ballast produces 95% of its initial lumens and loses 5%.</td>
</tr>
<tr>
<td>Lamp Tilt Loss Factor</td>
<td>For metal halide lamps, a measure of the amount of light lost due to the position of the lamp. A decrease in light occurs when the angle of the lamp shifts the cold spot of the bulb. Values less than 1.0 indicate a loss of light.</td>
</tr>
<tr>
<td>Surface Depreciation Factor</td>
<td>A measure of the amount of light lost due to deterioration of the surfaces of the lighting fixture as it ages. For example, blemishes and discolored shielding materials change the amount of light emitted. Values less than 1.0 indicate a loss of light.</td>
</tr>
<tr>
<td>Lamp Lumen Depreciation</td>
<td>As a lamp ages, it produces decreasing amounts of light on a predictable curve. A typical strategy is to use an average Lamp Lumen Depreciation (LLD) value at 40% of its life. Valid values are between 0 and 1. For example, a compact fluorescent has an LLD factor of 0.85, indicating an average output at 85% of its initial lumens, losing an average of 15% over its life as the lamp ages.</td>
</tr>
<tr>
<td>Luminaire Dirt Depreciation</td>
<td>A measure of the amount of light lost due to environmental dirt and dust that is trapped by the lighting fixture. Valid values are between 0 and 1. For example, a value of 0.9 indicates that the fixture produces 90% of its initial lumens and loses 10% due to trapped dust and dirt.</td>
</tr>
<tr>
<td>Total Light Loss Factor</td>
<td>A measure of the amount of light produced by a lamp, taking into account various environmental factors that obscure or reduce the emitted light. When the Method is Simple, use the slider or text box to specify a value. When the Method is Advanced, this parameter displays a read-only value, which is calculated by multiplying the values of the other parameters. Valid values are between 0 (total light loss) and 4 (light gain up to 400%). A value of 1 indicates no light loss (100% of initial light intensity).</td>
</tr>
</tbody>
</table>

**Defining the Initial Intensity**

When defining a lighting fixture, you can specify the initial intensity of its light source. The initial intensity is a measure of how much light is produced by the light source in ideal conditions. (The actual light emitted by a light source may be reduced by light loss factors. See Light Loss Factor Parameters on page 1056.)

You can define the initial intensity of a light source in a lighting fixture family file (as follows). In a project, you can change the initial intensity of an individual lighting fixture. (See Changing the Initial Intensity of a Light Source on page 1066.)

**To define the initial intensity of a lighting fixture family**

1. Open the lighting fixture family.

2. Click Home tab ➤ Properties panel ➤ (Family Types).

3. For Name, select the family type to modify.

4. Scroll down the list to locate the Initial Intensity parameter, and click in its Value column.
5 In the Initial Intensity dialog, specify values for the parameters. See Initial Intensity Parameters on page 1058.

6 Click OK.
The Family Types dialog displays the new Initial Intensity value.

7 Click OK.
8 Save changes to the lighting fixture family.

Initial Intensity Parameters

When defining the Initial Intensity of a light source, define the parameters as follows.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wattage</td>
<td>A measurement of the electrical power consumed by a light source.</td>
</tr>
<tr>
<td><strong>TIP</strong></td>
<td>When adjusting Wattage, it is also important to consider Efficacy. If you change Wattage alone, you may make the light source unintentionally bright. Luminosity is defined as Wattage (W) times Efficacy (W/lm). Luminous Efficacy for a 100 W tungsten incandescent (110 V) is 175, while a 32 W fluorescent tube (T8) is 60.</td>
</tr>
<tr>
<td>Efficacy</td>
<td>The amount of light (luminous flux, measured in lumens) produced by a light source as a ratio of the amount of energy consumed to produce it (measured in watts).</td>
</tr>
<tr>
<td>Luminous Flux</td>
<td>The quantity of light energy per unit of time arriving, leaving, or going through a surface. The lumen (lm) is the unit of luminous flux in both the International System (SI) of units and in the American System (AS) of units. If you think of light as particles (photons) moving through space, then the luminous flux of a light beam arriving at a surface is proportional to the number of particles hitting the surface during a time interval of 1 second. <strong>TIP</strong> In general, Luminous Flux provides more accurate lighting in rendered images than Wattage and Efficacy.</td>
</tr>
<tr>
<td>Luminous Intensity</td>
<td>The light energy per unit of time emitted by a point source in a particular direction. Luminous intensity is used to describe the directional distribution of a light source, that is, to specify how the luminous intensity of a light source varies as a function of the outgoing direction. The Candela (cd) is the unit of luminous intensity.</td>
</tr>
<tr>
<td>Illuminance</td>
<td>The luminous flux incident on a surface of unit area. Illuminance measures how much energy has fallen on a surface. This quantity is useful for describing the level of illumination incident on a surface without making the measurement dependent on the size of the surface itself. The lux (lx) is the International System (SI) unit of illuminance. The American System (AS) unit for illuminance is the footcandle (fc), equivalent to 1 lumen per square foot.</td>
</tr>
<tr>
<td>At a distance of</td>
<td>Illuminance is a function of the distance from the light source. Specify the distance at which the illuminance is measured.</td>
</tr>
</tbody>
</table>

Defining the Initial Color

When defining a lighting fixture, you can specify the initial color of its light source. The initial color is the color appearance of the emitted light, before it is affected by color filters or environmental factors.
To define the initial color of a light source

1. Open the lighting fixture family.

2. Click Home tab ➤ Properties panel ➤ (Family Types).

3. For Name, select the family type to modify.

4. Scroll down the list to locate the Initial Color parameter, and click in its Value column.

5. In the Initial Color dialog, specify values for the parameters. See Initial Color Parameters on page 1059.

6. Click OK.

   The Family Types dialog displays the new Initial Color value.

7. Click OK.

8. Save changes to the lighting fixture family.

**Initial Color Parameters**

When defining the Initial Color for the light source of a lighting fixture, define the parameters as follows.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color Preset</td>
<td>Select a value from the list, or select Custom to specify a Color Temperature.</td>
</tr>
<tr>
<td>Color Temperature</td>
<td>The color appearance of the light produced by the light source, expressed on the Kelvin scale (K).</td>
</tr>
</tbody>
</table>

**Using Lighting Fixtures in a Building Model**

After using the Family Editor to define lighting fixtures, you can add lighting fixtures to the building model. When you render an image, you can specify whether Revit Structure is to include artificial lights in the image, and which lights are turned on and off or dimmed.
Adding a Lighting Fixture to a Building Model

1. Load into the project the lighting fixture families that you want to use in the building model. See **Loading Families** on page 688.
2. In the project, open a view that displays the surface on which you can place the lighting fixture. For example, to place a ceiling-based lighting fixture, open a reflected ceiling plan. To place a wall-based lighting fixture, open a section or an elevation. To place a table lamp or a floor lamp, open a floor plan or a section.

3. Click Home tab ➤ Model panel ➤ Component drop-down ➤ (Place a Component).
4. Select the lighting fixture from the **Type Selector** on page 35.
5. In the drawing area, click to place instances of the lighting fixture in the desired locations.
6. To exit the Component tool, press **ESC** twice.

When placing the lighting fixture, consider the following:

- To see the light source symbol in a view, in addition to the lighting fixture geometry, make the light source visible. See **Displaying Light Sources in a View** on page 1062.
- If you want to place a table lamp on an elevated surface such as a desk or table, do so in a section view (or use the Offset parameter on the **Properties palette** to specify its height above the floor). If you place the lamp on a desk in a floor plan view, the lamp may be placed under the desk.
- In a floor plan view, wall-based lighting fixtures (such as sconces) may not display if the cut plane of the floor plan view occurs below the height at which the fixture is mounted to the wall. To correct this issue, see **Displaying a Wall-Based Lighting Fixture in a Floor Plan** on page 1060.

Displaying a Wall-Based Lighting Fixture in a Floor Plan

In a floor plan view, wall-based lighting fixtures (such as sconces) may not display if the cut plane of the floor plan view occurs below the height at which the fixture is mounted to the wall. For example, if the cut plane for a floor plan view is 1200 mm and the lighting fixture is mounted to the wall at 2000 mm, the floor plan view does not display the fixture.

To force Revit Structure to display these lighting fixtures in floor plans, add an invisible model line to the lighting fixture family.

**To display a wall-based lighting fixture in a floor plan**

1. In the project, open the section view or elevation view in which the wall-based lighting fixture displays.
2. Select the lighting fixture.

3. Click **Modify | Lighting Fixtures tab ➤ Mode panel ➤ (Edit Family).**
   Revit Structure opens the lighting fixture family in the Family Editor.
4 Name a reference plane that is parallel to the wall, as follows:
   - In the Project Browser, under Views (all) ➤ Floor Plans, double-click Ref. Level (or a floor plan view that shows reference planes for the lighting fixture).
   - In the drawing area, select a reference plane that is near the wall and parallel to it. If the lighting fixture family does not include a reference plane that is parallel to the wall, add one. See Adding Reference Planes on page 1523.
   - On the Properties palette, for Name, enter a name for the reference plane (wall plane, for example).

5 Add an invisible model line to the lighting fixture, using the named reference plane, as follows:
   - In the Project Browser, under Views (all) ➤ Elevations, double-click Front or Placement Side (or an elevation view that shows the front of the lighting fixture).
   - Click Home tab ➤ Model panel ➤ (Model Line).
   - In the Work Plane dialog, for Specify a new Work Plane, select Name.
   - In the pull-down list for Name, select the wall plane.
   - Click OK.
   - Click Modify | Place Lines tab ➤ Subcategory panel, and select Invisible lines from the drop-down.
   - In the drawing area, sketch a vertical line that extends from the center of the lighting fixture to the floor (or reference level).
   - Press ESC twice.

6 Save changes to the lighting fixture family.

7 Load the updated family into the project, replacing the existing family with the same name.

8 Open a floor plan view for the level on which the wall-based lighting fixture resides.

The wall-based lighting fixture now displays in the floor plan, because the cut plane intersects the invisible model line.

### Changing a Lighting Fixture in a Building Model

Many parameters for lighting fixtures and their light sources are defined by the lighting fixture family. Some of these parameters can be changed for individual instances in the building model. Other parameters must be changed in the family type or family.

**To change a lighting fixture in a building model**

1 In a project view, select the lighting fixture.
2 On the Properties palette, change the values of the parameters, as needed. The instance parameters that are available vary depending on the lighting fixture family and how its family parameters are defined.
3 To change type parameters, do the following:
   - On the Properties palette, click Edit Type.
   - In the Type Properties dialog, change parameter values as desired.
The type parameters that are available vary depending on the lighting fixture family and how its family parameters are defined. See Parameters for Lighting Fixtures and Light Sources on page 1052.

To specify an IES file for the light source, see Specifying an IES File for a Light Source on page 1047.

**Displaying Light Sources in a View**

When adding lighting fixtures to a building model, you can display the light sources. By making light sources visible, you can more easily plan their placement for maximum effect.

Spotlights in an elevation view with light sources displayed and Shaded with Edges turned on

![Spotlights in an elevation view with light sources displayed and Shaded with Edges turned on](image)

**NOTE** For spotlights, the length of a light source symbol in a view does not indicate the extent of the intensity of the light. However, the spot beam angle and spot field angle render as shown in views. See Angles for Spotlights on page 1065.

**To display light sources in a view**

1. Add lighting fixtures to the building model.  
   See Adding a Lighting Fixture to a Building Model on page 1060.

2. Open a view in which you can plan the placement of the lighting fixtures.  
   For example, to position spotlights that illuminate a wall, open a section view, elevation view, or 3D view.

3. Turn on the visibility of light sources, as follows:
   a. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
   c. Select Light Source.

   **NOTE** To hide light sources in views, clear Light Source.

4. (Optional) On the View Control Bar, for Visual Style, click Shaded or Shaded with Edges.  
   Shading allows you to see the difference between the beam angle and the field angle for spotlights. (See Angles for Spotlights on page 1065.)
Aiming a Spotlight

In a building model, you can control the position of a spotlight to achieve the desired lighting effects. To position a spotlight, use its angle parameters and the Rotate tool.

To aim a spotlight

1 Add spotlights to the building model, placing them in their approximate locations. See Adding a Lighting Fixture to a Building Model on page 1060.

2 Set up views, as follows:
   a Leave open (or re-open) the view in which you added the lighting fixtures. (For this procedure, this view is referred to as the placement view.) Zoom in on the fixtures, so you can easily select them for rotating or repositioning. Turn on the display of light sources. (See Displaying Light Sources in a View on page 1062.)

   b Click View tab ➤ Windows panel ➤ (Close Hidden) to close all other project views.

   c Open a second view in which you will be able to see the light cast on surfaces (such as an elevation view, section view, or 3D view). (For this procedure, this view is referred to as the lighting view.) On the View Control Bar, for Visual Style, select Shaded or Shaded with Edges. Turn on the display of light sources. (See Displaying Light Sources in a View on page 1062.)

   Spotlights in an elevation view with light sources displayed and Shaded with Edges turned on

   d To tile the windows, so you can see both views at the same time, click View tab ➤ Windows panel ➤ (Tile).

3 In the placement view, rotate the spotlights to aim their light in the desired direction. Use the Rotate tool. See Rotating Elements on page 1481.
To tilt a spotlight and control the size of its beam, do the following:

**a** In either view, select a spotlight, and click Modify | Lighting Fixtures tab ➤ Properties panel ➤ (Type Properties).

**b** Click Duplicate to create a new type.

**c** Enter a name for the type, and click OK.

**d** In the Type Properties dialog, scroll down to locate the Tilt Angle, Spot Field Angle, and Spot Beam Angle parameters.

**e** Enter the desired values for each parameter.

See Angles for Spotlights on page 1065.

**f** Click OK.

**g** Check the results in the lighting view.

For example, in the following image, the left spotlight has a smaller beam angle and field angle. For the right spotlight, the tilt angle was changed from 60 degrees to 45 degrees.

Repeat this step for each spotlight that needs to be tilted.

If necessary, make adjustments to achieve the desired result.

For example, you may need to add or remove spotlights, adjust their positions, and change their rotation angles and tilt, field, and beam angles to obtain the desired lighting effects.

**TIP** To evenly illuminate a surface, position the lighting fixtures so the beam angles overlap each other slightly.
Angles for Spotlights

When defining a spotlight, you can specify the following angles:

- **Beam angle**: The angle at which light intensity reaches 50% of the peak intensity. Enter a value between 0 and 160 degrees. To make a spot that is small and bright, enter a smaller value.

- **Field angle**: The angle at which light intensity reaches 10% of the peak intensity. Enter a value between 0 and 160 degrees. To limit the spread of the spotlight, enter a smaller value.

- **Tilt angle**: The angle that the spotlight is tilted from its origin. You can adjust the tilt angle of a spotlight to aim its light in the desired direction.

Controlling the Brightness of a Light Source

In a project, you can change the brightness of a light source using the following methods:

- **Change the Initial Intensity**. For example, if you want to change the bulb in a table lamp from a 60 watt bulb to a 100 watt bulb, change its Initial Intensity value in the type properties.

- **Change the Light Loss Factor**. To enhance or reduce light output to reflect environmental factors in the project, change this value in the type properties for the lighting fixture.
Dim the light. Use this method, for example, if you want to represent a ceiling light that is dimmed to create mood lighting in a rendered image.

Changing the Initial Intensity of a Light Source

When you change the initial intensity of a light source, the change affects all relevant project views.

1 In a project view, select a lighting fixture, and click Modify | Lighting Fixtures tab ➤ Properties panel ➤ (Type Properties).
2 Click Duplicate to create a new type.
3 Enter a name for the type, and click OK.
4 In the Type Properties dialog, for Initial Intensity, click in the Value column.
5 In the Initial Intensity dialog, specify the desired value.
See Initial Intensity Parameters on page 1058.

Changing the Light Loss Factor for a Light Source

When you change the Light Loss Factor for a light source, the change affects all relevant project views.

1 In a project view, select a lighting fixture, and click Modify | Lighting Fixtures tab ➤ Properties panel ➤ (Type Properties).
2 Click Duplicate to create a new type.
3 Enter a name for the type, and click OK.
4 In the Type Properties dialog, for Light Loss Factor, click in the Value column.
5 In the Light Loss Factor dialog, specify the desired value.
See Light Loss Factor Parameters on page 1056.

Dimming Lights

When you dim lights in a 3D view for rendering, the settings are saved as part of the view properties, and the lights are dimmed for that view only. The dimmed light settings do not affect rendered images for any other 3D views.

NOTE To specify the color temperature shift for dimmed lights, change type properties for the lighting fixtures. Modify the value of Dimming Lamp Color Temperature Shift. See Changing a Lighting Fixture in a Building Model on page 1061.

To dim lights

1 Open the 3D view to render.
2 Define render settings.
   See Defining Render Settings on page 1077.
3 In the Rendering dialog, under Lighting, for Scheme, select a setting that includes artificial lights.
4 Click Artificial Lights.
5 In the Artificial Lights dialog, in the Dimming column, enter dimming values for light groups or individual lighting fixtures.
   Enter a value between 0 and 1 to indicate the relative amount of dimming. A value of 1 means that the light is completely on (not dimmed). A value of 0 means that the light is completely dimmed (off).

   **NOTE** If a lighting fixture is a nested family that contains multiple light sources but is not shared, you cannot dim individual light sources in the fixture. See Sharing a Lighting Fixture Family on page 1040.

6 Click OK.
7 To see the effects of dimming the lights, render the image.
   See Creating the Rendered Image on page 1086.

Light Groups

You can create groups of artificial lights in a building model. For example, you may want to create groups for functional areas of a building, such as exterior lights, kitchen lights, hallway lights, and so on. Light groups can include one or more lighting fixtures of multiple types.

When you render an image, you can use light groups to turn on or off entire sets of lights, rather than controlling lighting fixtures individually. You can also use light groups to control dimming of lights in a rendered image.

Light groups are available in all relevant areas of Revit Structure. However, settings to dim or turn on or off light groups (or individual lighting fixtures) apply to individual 3D views only.

   **NOTE** The number of lights in a 3D view to be rendered can significantly increase render time. Use light groups to turn off unnecessary lights in the view. See Render Performance and Lighting on page 1091.

Opening the Artificial Lights Dialog

The Artificial Lights dialog lists all lighting fixtures in the building model, including ungrouped lights and grouped lights. Use this dialog to create and modify light groups, and to add or remove individual lighting fixtures in groups.

When you open this dialog from a 3D view, you can also use it to dim or turn on or off light groups or individual lighting fixtures for rendering. See Dimming Lights on page 1066 and Turning Lights On and Off on page 1070.

You can open the Artificial Lights dialog from the Rendering dialog or from any view that contains lighting fixtures.

To open the Artificial Lights dialog from a view

1 In a Revit Structure project, open a view that contains one or more lighting fixtures.
2 Select a lighting fixture.
3 On the Options Bar, for Light Group, select Edit/New.

To open the Artificial Lights dialog from the Rendering dialog

1 In a Revit Structure project, open a 3D view.
2 Open the Rendering dialog.
   See Opening the Rendering Dialog on page 1078.
3 Under Lighting, for Scheme, select a setting that includes artificial lights.
4 Click Artificial Lights.

Creating a Light Group
1 Open the Artificial Lights dialog.
2 Under Group Options, click New.
3 In the New Light Group dialog, enter a name for the light group, and click OK.
   In the Artificial Lights dialog, the new light group name displays in the list under Grouped Lights.
4 Add lights to the group.
   See Adding and Removing Lights in a Light Group Using the Artificial Lights Dialog on page 1068.
5 (Optional) Turn the light group on or off for rendering.
   See Turning Lights On and Off on page 1070.

Adding and Removing Lights in a Light Group
You can add and remove lights in a light group in several ways, depending on your current point in the software.

Adding and Removing Lights in a Light Group from a View
1 Open a project view that displays lighting fixtures.
2 Select a lighting fixture.
3 To add the lighting fixture to a light group, do the following:
   a On the Options Bar, for Light Group, select the desired group.
      If the light group does not yet exist, select Edit/New, and create a group. See Creating a Light Group on page 1068.
      b At the prompt, click OK.
4 To remove the lighting fixture from a light group, do the following:
   a On the Options Bar, for Light Group, select None.
   b At the prompt, click OK.

Adding and Removing Lights in a Light Group Using the Artificial Lights Dialog
1 Open the Artificial Lights dialog.
   See Opening the Artificial Lights Dialog on page 1067.
2 To add an individual lighting fixture to a light group, do the following:
   a In the Artificial Lights dialog, under Ungrouped Lights, select the lighting fixture.
   b Under Fixture Options, click Move to Group.
   c In the Light Groups dialog, select the desired light group, and click OK.
In the Artificial Lights dialog, the selected lighting fixture displays under the selected light group name.

3 To remove an individual lighting fixture from a light group, do the following:
   a. In the Artificial Lights dialog, under Grouped Lights, expand the light group name.
   b. Select the lighting fixture to remove from the group.
   c. Under Fixture Options, click Remove from Group.

In the Artificial Lights dialog, the selected lighting fixture displays under Ungrouped Lights.

4 When you are finished in the Artificial Lights dialog, click OK.

Adding and Removing Lights in a Light Group Using the Light Group Editor

1 Open the Light Group Editor, using either of the following methods:
   ■ In a project view, select a lighting fixture. On the Options Bar, for Light Group, click Edit.

   **NOTE** If Light Group displays None, select the light group to which you want to add the selected lighting fixture. Then click Edit.

   ■ Open the Artificial Lights dialog. In the Artificial Lights dialog, select the group name. Under Group Options, click Edit.

Revit Structure enters light group edit mode. The Light Group panel displays in the drawing area. (You can drag it to the desired location or place it on the ribbon. See To move ribbon panels on page 23.) Model elements and lighting fixtures that belong to another light group display in halftone. Lighting fixtures that belong to the selected light group display in green. Lighting fixtures that are not currently assigned to a light group display normally.

2 If necessary, use the Project Browser to open any view in which you can see the lighting fixtures to add or remove in the group.
3 To add lighting fixtures to the group, do the following:

   a  Click Light Group panel ➤ (Add).
       Revit Structure highlights lighting fixtures that are not currently assigned to a light group.
       All other model elements continue to display as halftone, indicating that you cannot select
       them.

   b  Select each lighting fixture that you want to add to the group.
       When you select a lighting fixture, Revit Structure displays it as green to indicate that it is
       being added to the group.

   c  If necessary, you can open another project view, click Light Group panel ➤ Add, and select
       more lighting fixtures to add to the group.

4 To remove lighting fixtures from the group, do the following:

   a  Click Light Group panel ➤ (Remove).
       The lighting fixtures that are currently assigned to a light group display as green.

   b  Select each lighting fixture that you want to remove from the group.
       After you select a lighting fixture, it displays normally, indicating that it is no longer part
       of the group.

   c  If necessary, you can open another project view, click Light Group panel ➤ (Remove),
       and select more lighting fixtures to remove from the group.

5 When you are finished adding and removing lights for the current light group, click Light Group
   panel ➤ (Finish).

**Turning Lights On and Off**

Individual lighting fixtures or entire light groups can be turned on or off to achieve the desired lighting
effects in a rendered image. When you turn on or off lights in a 3D view, the settings are saved as part of
the view properties, and they affect that view only. They do not affect rendered images for any other 3D
views.

If a lighting fixture is a nested family that is not shared, you cannot control individual light sources in the
fixture. Instead, you turn the entire lighting fixture on or off. See Sharing a Lighting Fixture Family on page
1040.

**NOTE**  Render time is directly proportional to the number of lights in the scene. See Render Performance and
Lighting on page 1091.

To turn lights on or off

1 In a Revit Structure project, open a 3D view.

2 On the View Control Bar, click (Show Rendering Dialog).
3 In the Rendering dialog, under Lighting, for Scheme, select a setting that includes artificial lights.
4 Click Artificial Lights.
5 In the Artificial Lights dialog, under On/Off, select individual lighting fixtures or light groups to include them in the rendered image. Clear the check boxes to omit the lights in the rendered image.
   You can also enter values in the Dimming column to dim individual lighting fixtures or entire light groups. See Dimming Lights on page 1066.
6 Click OK.
7 To see the results, render the image.
   See Rendering an Image on page 1076.

Renaming a Light Group

1 Open the Artificial Lights dialog.  
   See Opening the Artificial Lights Dialog on page 1067.
2 In the Artificial Lights dialog, select the group name.
3 Under Group Options, click Rename.
4 In the Rename dialog, enter a new group name.
5 Click OK.

Deleting a Light Group

1 Open the Artificial Lights dialog.  
   See Opening the Artificial Lights Dialog on page 1067.
2 In the Artificial Lights dialog, select the group name.
3 Under Group Options, click Delete.
   Revit Structure deletes the light group. All of the lighting fixtures that belonged to that group are listed under Ungrouped Lights.

Decals

Use the Place Decal tool to place images on surfaces of a building model for rendering. For example, you can use decals for signs, paintings, and billboards. For each decal, you can specify an image and its reflectivity, luminance, and texture (bump-mapping). You can place decals on flat surfaces and cylindrical surfaces.  

NOTE In Revit Structure, you can only define decal types. To place decals, use Revit Architecture or Revit MEP.
Creating a Decal Type

1 Click Insert tab ➤ Link panel ➤ (Decal Types).

2 In the Decals Types dialog, click (Create new decal).

3 In the New Decal dialog, enter a name for the decal, and click OK.
   The Decal Types dialog displays the new decal name and its attributes.

4 For Image File, specify the file to use.
   Click (Browse) to navigate to the file. Revit Structure supports image files of the following types: BMP, JPG, JPEG, and PNG. See Best Practice for Storing Image Files on page 1627.

5 Specify the remaining attributes of the decal.
   See Decal Attributes on page 1075.

6 Click OK.

In Revit Structure, you can only define decal types. To place decals, use Revit Architecture or Revit MEP.

Related topics

- Renaming a Decal Type on page 1073
- Duplicating a Decal Type on page 1073
- Sharing Decals Between Projects on page 1074
- Decal Properties on page 1074
Modifying a Placed Decal

1 In a project view, select the decal.
2 To move the decal, drag it to a new location.
3 To resize the decal, drag its blue grips, or on the Options Bar, enter new values for Width and Height. To maintain the aspect ratio between these dimensions, select Lock Proportions.
4 To return the decal to its original size, on the Options Bar, click Reset.
5 To rotate the decal, use the Rotate tool.
   See Rotating Elements on page 1481.
6 To change the decal’s properties, use the Properties palette.
   See Decal Properties on page 1074.

NOTE You can also change the decal image and its attributes by clicking Insert tab ➤ Link panel ➤ Decal Types.

Renaming a Decal Type

1 Click Insert tab ➤ Link panel ➤ (Decal Types).
2 In the decals list, select the decal type to rename.
3 Click (Rename).
4 In the Rename dialog, enter a new name, and click OK.

Duplicating a Decal Type

1 Click Insert tab ➤ Link panel ➤ (Decal Types).
2 In the decals list, select the decal type to copy.
3 Click (Duplicate).
4 In the Duplicate Decal dialog, enter a name for the new decal type, and click OK.
5 Under Settings, specify an image file and attributes for the new decal type.
   See Decal Attributes on page 1075.
6 Click OK.

Deleting a Decal Type

1 Click Insert tab ➤ Link panel ➤ (Decal Types).
2 In the decals list, select the decal type to delete.
3 Click (Delete).
4 To confirm that you want to delete the selected decal type, click Yes at the prompt.
Sharing Decals Between Projects

If you create several decals in one project, you can use them in another project. To do this, click Manage tab ➤ Settings panel ➤ (Transfer Project Standards). In the Select Items to Copy dialog, select Decal Types. See Transferring Project Standards on page 1635.

Make sure that the image files for the decals are available to the target project. When Revit Structure needs to access the image file, first it looks in the location specified for the file, using the absolute path. If it cannot find the file in that location, Revit Structure then searches the paths specified on the Rendering tab of the Options dialog. See Setting Options on page 1623.

If you send the project file to another team member, you must also send the image files for the decals. See Best Practice for Storing Image Files on page 1627.

Decal Properties

You can modify properties for each decal instance and decal type. You can also change attributes of the decal image.

Modifying Decal Properties

1. In a project view, select the decal.
2. On the Properties palette, edit the instance parameters. See Decal Instance Properties on page 1074.
3. To edit decal type parameters, on the Properties palette, click Edit Type. See Decal Type Properties on page 1075.
4. To change the decal image and its attributes, in the Type Properties dialog, for Decal Attributes, click Edit. See Decal Attributes on page 1075.

NOTE You can also change the decal image and its attributes by clicking Insert tab ➤ Link panel ➤ Decal Types.

Decal Instance Properties

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>Physical width of the decal.</td>
</tr>
<tr>
<td>Height</td>
<td>Physical height of the decal.</td>
</tr>
<tr>
<td>Lock Proportions</td>
<td>Whether the ratio between the height and width is maintained. Clear this option to change the Width or Height without also affecting the other dimension.</td>
</tr>
</tbody>
</table>

Identity Data

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comments</td>
<td>Text that describes the decal.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Mark</td>
<td>User-specified identifier for this particular decal.</td>
</tr>
<tr>
<td>Subcategory</td>
<td>Subcategory for the geometry of the decal. The subcategory controls the line weight, color, and pattern in 2D and 3D views. Select a Generic Model subcategory from the list, or create one. See Creating Object Style Subcategories on page 1601.</td>
</tr>
</tbody>
</table>

**Phasing**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase Created</td>
<td>Phase during which the decal is created. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>Phase during which the decal is demolished. See Project Phasing on page 877.</td>
</tr>
</tbody>
</table>

**Decal Type Properties**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decal Attributes</td>
<td>Image for and attributes of the decal. Click Edit to change them. See Decal Attributes on page 1075.</td>
</tr>
<tr>
<td>Keynote</td>
<td>Keynote for the decal. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Model</td>
<td>Manufacturer’s model number or code for the decal.</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Manufacturer of the decal.</td>
</tr>
<tr>
<td>Type Comments</td>
<td>Comments or information about this type of decal.</td>
</tr>
<tr>
<td>URL</td>
<td>URL of the website for the manufacturer or vendor.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the decal.</td>
</tr>
<tr>
<td>Assembly Description</td>
<td>Description of the selected assembly code. (read-only)</td>
</tr>
<tr>
<td>Assembly Code</td>
<td>Uniformat assembly code for the decal.</td>
</tr>
<tr>
<td>Type Mark</td>
<td>User-specified identifier for this type of decal.</td>
</tr>
<tr>
<td>Cost</td>
<td>Cost of the decal.</td>
</tr>
</tbody>
</table>

**Decal Attributes**

The following properties display in the Decal Types dialog when you create or modify a decal type. See Creating a Decal Type on page 1072.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image File</td>
<td>Image file to display for the decal. Click ... (Browse) to navigate to the file. Revit Structure supports image files of the following types: BMP, JPEG, JPEG, and PNG. See Best Practice for Storing Image Files on page 1627.</td>
</tr>
<tr>
<td>Brightness</td>
<td>Perception of the luminance of the decal. Brightness is a multiplier, so a value of 1.0 makes no change. If you specify 0.5, its brightness is reduced by half.</td>
</tr>
</tbody>
</table>
### Property Description

**Reflectivity**
Measurement of how much light the decal reflects from its surface. Enter a value between 0 (no reflections) and 1 (maximum reflections). See Transparency and Translucency on page 1593.

**Transparency**
Measurement of how much light passes through the decal. Enter a value between 0 (completely opaque) and 1 (completely transparent).

**Finish**
Texture of the decal surface.

**Luminance (cd/m²)**
Light emitted by the surface, measured in candelas per square meter. Select a pre-defined value, or select Custom to enter a value.

**Bump Pattern**
Bump pattern (additional texture) to use on the decal surface. See Specifying an Image File for a Render Appearance on page 1593. This texture is layered on top of any texture already applied to the surface on which the decal is placed. For example, if you place a decal on a brick wall, the texture of the brick wall affects the decal, in addition to the decal texture specified here.

**Bump Amount**
Relative amplitude of the bumps. Enter 0 to make the surface flat. Enter higher decimal values (up to 1.0) to increase the depth of the surface irregularities.

**Cut-outs**
Shapes cut into the surface of the decal. Select a shape, or select Custom to define cut-outs using an image. See Specifying an Image File for a Render Appearance on page 1593.

---

**Rendering an Image**

You can use Revit Structure to render 3D views. You can then place rendered images on sheets to present designs to clients. The rendering interface uses intelligent defaults so that you can easily generate a quality rendered image without in-depth understanding of rendering technology. The interface also offers advanced settings for users with more rendering experience.

As an alternative, you can export a 3D view, and use another software application to render the image. See Exporting to 3ds Max on page 1139.
Defining Render Settings

1 Open the Rendering dialog.
2 Define the view area to render.
3 In the Rendering dialog, under Quality, specify the render quality.
4 Under Output, specify the following:
   ■ Resolution: To generate a rendered image for screen display, select Screen. To generate a rendered image for printing, select Printer.
   ■ DPI: When Resolution is Printer, specify the DPI (dots per inch) to use when printing the image. (If the project uses metric units, Revit Structure converts the metric values to inches before displaying the DPI or pixel size.) Select a predefined value, or enter a custom value.

   The Width, Height, and Uncompressed image size fields update to reflect the settings. See Render Performance and Image Size/Quality on page 1093.
5 Under Lighting, specify lighting settings for the rendered image.
6 Under Background, specify a background for the rendered image.
7 (Optional) Adjust exposure settings for the rendered image.

If you know the exposure settings that you want to use, you can set them now. Otherwise, wait to see the results of the current render settings, and, if needed, adjust the exposure settings after rendering the image. See Adjusting the Exposure of a Rendered Image on page 1087.

These render settings are view-specific. They are saved as part of the view properties. To apply these settings to other 3D views, use a view template.

When you finish defining render settings, create the rendered image.

Opening the Rendering Dialog

1 Open the 3D view to render.

You can render 3D views only.

TIP To render a 2D view, create a 3D view that is oriented to a 2D view (such as a section view or elevation view). Right-click the ViewCube, and click Orient To View or Orient to a Direction. For details, see Specifying Camera Position in a 3D View on page 758.

If the Rendering dialog was open when the 3D view was last open in the current session, the dialog redisplays.

2 If the Rendering dialog does not open automatically,

■ On the View Control Bar, click (Show Rendering Dialog).

■ Click View tab ➤ Graphics panel ➤ (Render).
Defining the View Area to Render

You can render part of a 3D view. You might use this strategy for the following reasons:

■ To focus on a particular part of the 3D view.

■ To test render appearances for materials applied to model elements. 
   See Applying Materials to Elements on page 1576.

■ To reduce the amount of time required to render the image. 
   See Rendering Best Practices on page 1090.

■ To reduce the size of the resulting image file. 
   See Controlling the Size of the Rendered Image on page 1084.

When you click Render, Revit Structure renders only the specified part of the building model.

To define the view area to render, use one or more of the following methods:

■ **Crop region**: Open the 3D view, and apply a crop region to define the area to render. See Cropping a View on page 850. To check or change the size of the cropped view, select the crop region, and click Modify | Cameras tab ➤ Crop panel ➤ (Size Crop).

■ **Render region**: Open the Rendering dialog, and click Region. In the 3D view, Revit Structure displays the render region boundary. Select the render region, and use the blue grips to adjust its size. For orthographic views, you can also drag the render region to move its location in the view. If the view uses a crop region, the render region must reside within the crop region boundaries.
Camera clipping plane: The camera clipping plane defines the depth of the 3D view to render. When you reduce this clipping plane, Revit Structure has fewer model elements to process when producing the rendered image. As a result, the rendering process requires fewer resources, takes less time, and produces a smaller image file. See Modifying the Camera Position in a Perspective 3D View on page 758.

Section box: A crop region and a render region define a 2D portion of a 3D view to render. A section box, however, allows you to define a 3D portion of the view to render. By using a section box, you can omit many model elements from the rendering process, thus reducing the number of calculations and the processing time required. See Change the Extents of a 3D View on page 762.

NOTE When using a section box, be careful about the parts of the building geometry that you exclude from the view. For example, if a section box excludes an exterior wall for an interior 3D view, sunlight may illuminate the entire room, affecting the rendered image and increasing render time. See Render Performance and Lighting on page 1091.

Specifying the Render Quality

To present a design to clients, you typically want a high quality rendered image. However, high quality rendered images can be slow to generate. For testing purposes, you may want to generate a draft quality image quickly. Use the Quality Setting on the Rendering dialog to specify the desired quality for the rendered image.

<table>
<thead>
<tr>
<th>Quality</th>
<th>Relative Render Speed</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draft</td>
<td>Fastest</td>
<td>Render as quickly as possible to get a general idea of the rendered image. The image contains many artifacts (small inaccuracies or imperfections in the rendered image).</td>
</tr>
<tr>
<td>Low</td>
<td>Fast</td>
<td>Render quickly with a better level of quality and several artifacts.</td>
</tr>
<tr>
<td>Medium</td>
<td>Medium</td>
<td>Render with a quality that is usually satisfactory for presentations, with few artifacts.</td>
</tr>
<tr>
<td>High</td>
<td>Slow</td>
<td>Render with high quality that is satisfactory for most presentations, with very few artifacts. This render quality requires a long time to produce.</td>
</tr>
<tr>
<td>Best</td>
<td>Slowest</td>
<td>Render with very high quality and a minimum of artifacts. This render quality requires the most time to produce.</td>
</tr>
<tr>
<td>Custom</td>
<td>Varies</td>
<td>Use the settings specified in the Render Quality Settings dialog. Render speed depends on the custom settings. See Defining a Custom Render Quality on page 1081.</td>
</tr>
</tbody>
</table>
Defining a Custom Render Quality

1 In the Rendering dialog, under Quality, for Setting, select Edit. The Render Quality Settings dialog displays.

2 For Setting, select the predefined setting to use as a starting point for your custom settings, and click Copy to Custom.

3 Under Advanced Render Settings, specify the desired parameter values. See Render Quality Settings on page 1081.

4 Click OK.

5 Continue to define other render settings.

Render Quality Settings

Use the following parameters to define advanced render settings. (See Defining a Custom Render Quality on page 1081.) In general, increasing (or turning on) any one of these settings increases the quality of the rendered image. However, it also increases the time required to generate the image. Increasing the values of multiple settings may increase render time exponentially. See Rendering Best Practices on page 1090.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td></td>
</tr>
<tr>
<td>Image Precision (Antialiasing)</td>
<td>Increase this value to smooth jagged edges in the rendered image. Enter a value between 1 (most jagged) and 10 (smoothest). See Render Performance and Image Size/Quality on page 1093.</td>
</tr>
<tr>
<td>Setting</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Reflection and Transparency Options</td>
<td></td>
</tr>
<tr>
<td>Maximum Number of Reflections</td>
<td>Increase this value when objects are missing from reflections in the rendered image. Enter a value between 0 (no reflections) and 100 (most reflections). See How Refractions and Reflections Affect Render Performance on page 1093.</td>
</tr>
<tr>
<td>Maximum Number of Refractions</td>
<td>Increase this value when you cannot see objects through multiple panes of glass. Enter a value between 0 (completely opaque) and 100 (completely transparent). See How Refractions and Reflections Affect Render Performance on page 1093.</td>
</tr>
<tr>
<td>Blurred Reflections Precision</td>
<td>Increase this value when the edges or surfaces of objects in blurred reflections are speckled. Enter a value between 1 (speckled) and 11 (smoothest).</td>
</tr>
<tr>
<td>Blurred Refractions Precision</td>
<td>Increase this value when the edges of objects seen through rough glass are speckled. Enter a value between 1 (speckled) and 11 (smoothest).</td>
</tr>
<tr>
<td>Shadow Options</td>
<td></td>
</tr>
<tr>
<td>Enable Soft Shadows</td>
<td>Select this option to make shadow edges blurred. Clear it to make shadow edges sharp and distinct. See Soft shadows on page 1091.</td>
</tr>
<tr>
<td>Soft Shadow Precision</td>
<td>Increase this value when the edges of soft shadows are speckled instead of smooth. Enter a value between 1 (speckled shadows) and 10 (smoothest shadows).</td>
</tr>
<tr>
<td>Indirect Illumination Options</td>
<td></td>
</tr>
<tr>
<td>Compute Indirect and Sky Illumination</td>
<td>Select this option to include light from the sky and light that bounces off other objects. Clear it to omit these light sources from the rendered image. See Indirect illumination on page 1091.</td>
</tr>
<tr>
<td>Indirect Illumination Precision</td>
<td>Increase this value to achieve more detailed indirect illumination (the level of detail that is visible in indirect light) and shadows. Greater precision yields smaller subtle effects, usually in corners or below objects. Enter a value between 1 (less detail) and 10 (more detail).</td>
</tr>
<tr>
<td>Indirect Illumination Smoothness</td>
<td>Increase this value when indirect illumination looks splotchy or scaly. Greater precision yields smaller subtle effects, usually in corners or below objects. Enter a value between 1 (most splotchy) and 10 (least splotchy).</td>
</tr>
<tr>
<td>Indirect Illumination Bounces</td>
<td>Increase this value when areas of the scene that should be indirectly illuminated do not display as desired. This setting determines the number of times that indirect light bounces off objects in the scene. It controls the amount of realism in indirect lighting. With more bounces, light can penetrate further into a scene, resulting in more physically correct lighting and a brighter scene. Enter a value between 1 (less indirect illumination) and 100 (most indirect illumination). Typically, 3 bounces achieve sufficient results for indirect illumination.</td>
</tr>
</tbody>
</table>
Further bounces can add more subtle effects, but they are often not significant.

**Daylight Portal Options (only applies to sunlit interiors):** These settings are available only for interior views that include daylight. See [Daylight Portals](#) on page 1083.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>Whether the rendering engine calculates daylight portals for windows.</td>
</tr>
<tr>
<td></td>
<td>By default, this setting is turned off.</td>
</tr>
<tr>
<td>Doors</td>
<td>Whether the rendering engine calculates daylight portals for doors that</td>
</tr>
<tr>
<td></td>
<td>contain glass. By default, this setting is turned off.</td>
</tr>
<tr>
<td>Curtain Walls</td>
<td>Whether the rendering engine calculates daylight portals for curtain walls.</td>
</tr>
<tr>
<td></td>
<td>By default, this setting is turned off.</td>
</tr>
</tbody>
</table>

**Daylight Portals**

During the rendering process, daylighting is performed automatically. For advanced lighting quality in interior views, you can enable daylight portals, if needed. Daylight portals improve the quality of light that shines through windows, doors that contain windows or glass, and curtain walls.

*Rendered image without daylight portals*

![Rendered image without daylight portals](image1.png)

*Rendered image with daylight portals*

![Rendered image with daylight portals](image2.png)

Daylight portals are useful only for interior views that include sunlight. That is, on the Rendering dialog, under Lighting, the selected Scheme must be Interior: Sun only, or Interior: Sun and Artificial. (See [Controlling Lighting in a Rendered Image](#) on page 1084.)

By default, daylight portals are turned off. If a rendered image shows sunlight reflecting off surfaces, and the sunlight is speckled or splotchy, you may be able to improve the image by turning on daylight portals.
NOTE The use of daylight portals can significantly increase render time.

To turn on daylight portals for an interior view that includes sunlight, use the Render Quality Settings dialog. See Defining a Custom Render Quality on page 1081 and Render Quality Settings on page 1081.

Controlling the Size of the Rendered Image

Before rendering a 3D view, you can use the following techniques to control its print size (in pixels) and file size (in bytes). The width and height of the rendered image display on the Rendering dialog under Output.

- **Render part of the 3D view**: Use a render region, a crop region, or a section box. See Defining the View Area to Render on page 1079.
- **Zoom in or out**: When creating a rendered image for screen output, you can zoom in or out to make the rendered image larger or smaller. See Zoom Tool on page 841.
- **Change the output resolution**: When creating a rendered image for printing, you can specify the image resolution in DPI (dots per inch). See Defining Render Settings on page 1077.
- **Change the view scale**: When rendering an image for printing, you can change the view scale to reduce the image size. See View Scale on page 860.

NOTE Higher resolution and larger image size increase render time. See Render Performance and Image Size/Quality on page 1093.

Controlling Lighting in a Rendered Image

1. In the Rendering dialog, under Lighting, for Scheme, select the desired setting.

2. If you selected a lighting scheme that uses sunlight, for Sun Setting, select the desired sun position.

   To define new sun and shadow settings for the rendered image, click (Browse). Click OK or Cancel to return to the Rendering dialog.

3. If you selected a lighting scheme that uses artificial light, click Artificial Lights to control artificial light in the rendered image.

   You can create light groups and add lighting fixtures to light groups. You can also dim or turn on or off light groups or individual lighting fixtures. Click OK or Cancel to return to the Rendering dialog.

   **TIP** To improve render performance, turn off any lights that are not required for the rendering.

4. If the lighting scheme is Interior: Sun only or Interior: Sun and Artificial, consider whether you want to turn on daylight portals.

   During the rendering process, daylighting is performed automatically. For advanced lighting quality in interior views, you can enable daylight portals, if needed. Daylight portals improve
the quality of the rendered image, but they can also increase render time. By default, daylight portals are turned off. See Daylight Portals on page 1083.

5 Continue to define other render settings.

Specifying the Background for a Rendered Image

In the Rendering dialog, use the Background settings to specify a background for a rendered image. The background can display a solid color, sky and clouds, or a custom image.

**NOTE** When you create an interior view that includes natural light, the sky and cloud background can affect the quality of light in the rendered image. For more diffuse natural light, use more clouds.

To specify a solid color

1. In the Rendering dialog, under Background, for Style, select Color.
2. Click the color swatch.
3. In the Color dialog, specify the background color for the rendered image.
4. Click OK.
5. Continue to define other render settings.

To specify a background with sky and clouds

1. In the Rendering dialog, under Background, for Style, select a Sky option that indicates the desired number of clouds.
2. For Haze, drag the slider between Clear and Hazy.
3. Continue to define other render settings.

To specify a custom image

1. In the Rendering dialog, under Background, for Style, select Image.
2. Click Customize Image.
3. In the Background Image dialog, click Image.
4 Navigate to the location where the image file resides, select the image, and click Open.
5 In the Background Image dialog, specify Scale and Offset, and click OK.
6 Continue to define other render settings.

Creating the Rendered Image

Before starting the render process, see Rendering Best Practices on page 1090 for information about how you can improve performance.

After preparing the 3D view and using the Rendering dialog to select desired settings, click Render to render the image.

Revit Structure begins the rendering process, rendering one block of the image at a time. Revit Structure displays a progress dialog, which shows information about the rendering process, including the numbers of daylight portals and artificial lights.

NOTE To cancel the rendering process before it completes, click Cancel.

When the rendering process is complete, Revit Structure displays the rendered image in the drawing area. You can then do the following:

- **Change** render settings, and render the image again.
- **Adjust** exposure settings.
- **Save** the rendered image as a project view.
- **Export** the rendered image to a file.
- Display the building model in the drawing area.
  In the Rendering dialog, click Show the model. To display the rendered image again, click Show the rendering.
Adjusting the Exposure of a Rendered Image

After rendering an image, you can adjust exposure settings to improve the image. If you know the desired exposure settings, you can set them before rendering the image. When you select a lighting scheme, the software uses default exposure settings, optimized for the type of light in the view.

If you adjust the exposure settings, the settings are saved as part of the view properties. The next time you render this view, the same exposure settings are used.

To adjust the exposure of a rendered image

1. In the Rendering dialog, under Image, click Adjust Exposure.
2. In the Exposure Control dialog, specify the desired settings.
   
   See Exposure Control Settings on page 1087.
3. Click Apply to see the results of the changes in the rendered image.
4. To return to the default exposure settings, click Reset to Default.
   
   The default Exposure Value is optimized for the selected lighting scheme. Other exposure settings have neutral settings.
5. Click OK to return to the Rendering dialog.

Exposure Control Settings

When rendering an image, exposure control (or tone mapping) is just as important as the lighting and materials used. Exposure control helps to convert real-world luminance values into a realistic image. It mimics the human eye response to luminance values with regard to color, saturation, contrast, and glare. Use the following settings to adjust the exposure of a rendered image.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exposure Value</td>
<td>Overall brightness of the rendered image. This setting is comparable to the exposure compensation setting in cameras with automatic exposure. Enter a value between –6 (brighter) and 16 (darker). The default value is different for each lighting scheme.</td>
</tr>
<tr>
<td>Highlights</td>
<td>Light level for the brightest areas of the image. Enter a value between 0 (darker highlights) and 1 (brighter highlights). The default is 0.25.</td>
</tr>
<tr>
<td>Mid Tones</td>
<td>Light level for areas of the image whose brightness lies between the highlights and the shadows. Enter a value between 0.1 (darker mid tones) and 4 (brighter mid tones). The default is 1.</td>
</tr>
<tr>
<td>Shadows</td>
<td>Light levels for the darkest areas of the image. Enter a value between 0.1 (lighter shadows) and 4 (darker shadows). The default is 0.2.</td>
</tr>
<tr>
<td>White Point</td>
<td>Color temperature of the light sources that should display as white in the rendered image. This setting is similar to the White Balance setting on digital cameras. If the rendered image looks too orange, reduce the White Point value. If the rendered image looks too blue, increase the White Point value. If the scene is illuminated with daylight, use a value of 6500. If the scene is illuminated with incandescent lights, match the White Point value to the color temperature of the lights (see Initial Color Parameters on page 1059), or start with a value of 2800 and adjust it up or down as necessary to achieve the desired results.</td>
</tr>
<tr>
<td>Saturation</td>
<td>Intensity of colors in the rendered image. Enter a value between 0 (gray/black/white) and 5 (more intense colors). The default is 1.</td>
</tr>
</tbody>
</table>
**Saving the Rendered Image as a Project View**

After rendering an image, you can save the image as a project view. In a project, rendered images display in the Project Browser under Views (all) ➤ Renderings. You can then place the rendered view on a sheet in a construction document set.

**To save the rendered image as a project view**

1. In the Rendering dialog, under Image, click Save to Project.
2. In the Save to Project dialog, enter a name for the rendered view, and click OK.
3. (Optional) Place the rendered view on a sheet. See Adding Views to a Sheet on page 980.

**Exporting the Rendered Image to a File**

After rendering an image, you can export the image to a file. This file is stored outside the project in the specified location. Revit Structure supports the following image file types: BMP, JPEG, JPG, PNG, and TIFF.

**NOTE** To preserve the alpha channel for transparency, use the PNG or TIFF file format. If you plan to use the exported image in Adobe® Photoshop®, export to TIFF for best results. (If you export to PNG and open the file in Adobe® Photoshop®, the background sky and clouds may not display.)

**To export the rendered image**

1. In the Rendering dialog, under Image, click Export.
2. In the Save Image dialog, for Save in, navigate to the desired location.
3. For Files of type, select a file type.
4. For File name, enter a name for the image file.
5. Click Save.

**Changing Render Settings for a View**

You can define render settings for a 3D view before or after rendering an image. These settings are saved as part of the view properties.

**To change render settings for a view**

1. In the Project Browser, under Views (all) ➤ 3D Views, select the view name.
2. On the Properties palette, under Camera, for Rendering Settings, click Edit.
   - The Rendering Settings dialog displays a subset of the settings in the Rendering dialog.

**TIP** These settings can be saved in a view template and applied to other 3D views. See View Templates for Render Settings on page 1089.

3. Specify the desired settings, as follows:
   - Quality
   - Lighting
   - Background
   - Image
4 Click OK.

**View Templates for Render Settings**

A view template is a collection of properties that you define for views of a particular type. After *defining render settings* for a 3D view, you can store those settings in a view template. When you want to use the same render settings for another 3D view, apply the view template to that view.

A 3D view template can store the following render settings:

- Quality
- Lighting scheme and sun position
- Settings for artificial lights that are dimmed and turned on and off
- Background color or sky and cloud settings
- Exposure settings

**Creating a View Template for Render Settings**

The following is a basic procedure for creating a 3D view template for render settings, and applying it to other 3D views. For more information about view templates, see View Templates on page 1637.

**To create a view template for render settings**

1. Open a 3D view, and *define* the render settings as desired.
2. Click View tab ➤ Graphics panel ➤ View Templates drop-down ➤ Create Template from Current View.
3. In the New View Template dialog, enter a name, and click OK. The View Templates dialog displays the new view template name and its view properties.
4. (Optional) To check or change render settings for the view template, under View Properties, for Rendering Settings, click Edit. Change the settings as desired, and click OK.
   Specify the desired settings, as follows:
   - **Quality**
   - **Lighting Background**
   - **Image**
5. Check the other view properties that are included in the view template. Change properties as desired. For any properties that you want to exclude from this view template, clear the Include option.
6. Click OK.

Now you can *apply* the view template to other 3D views, as desired.
View Properties for Renderings

When you save a rendered image in the project, Revit Structure stores properties for the image. To change its properties, under Views (all) ➤ Renderings, and click the image name. On the Properties palette, change the parameters as desired.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>View Name</td>
<td>The name of the view, as it displays in the Project Browser and other areas of Revit Structure.</td>
</tr>
<tr>
<td>Title on Sheet</td>
<td>The view title to display on sheets. See View Titles on Sheets on page 1007</td>
</tr>
<tr>
<td>Default View Template</td>
<td>The view template to apply to the rendering. See View Templates on page 1637</td>
</tr>
</tbody>
</table>

Rendering Best Practices

The mental ray® rendering engine uses complicated algorithms to produce a photorealistic image from a 3D view of a building model. The amount of time required to generate the rendered image varies depending on many factors, such as the numbers of model elements and artificial lights, the complexity of the materials, and the size or resolution of the image. Furthermore, the interplay of other factors can affect render performance. For example, reflections, refractions, and soft shadows can increase render time.

Ultimately, render performance is a balance between the quality of the resulting image and the resources (time, computing power) that can be devoted to the effort. Low quality images are generally quick to produce, while high quality images can require significantly more time.

Before rendering an image, consider whether you need a high quality image or a draft quality image. In general, start by rendering a draft quality image to see the results of the initial settings. Then refine materials, lights, and other settings to improve the image. As you get closer to the desired result, you can use the low or medium quality setting to produce a more realistic image. Use the high quality setting to produce a final image only when you are sure that the material render appearances and the render settings will give the desired result.

The following topics describe some features and settings that can affect render performance.

The Rendering Process

In the Windows Task Manager, the rendering process is named fbxooprender.exe. When you render an image, the rendering process will use up to 4 CPUs. If other processes are also running, the rendering process releases some of the existing capacity to support those processes.

Before rendering an image, turn off active screen savers, and shut down any non-essential processes that use processor power. (For example, some web pages that use Flash graphics may slow down the rendering process.) Doing so makes more CPU capacity available to the rendering process and can reduce render time.

While rendering an image, you may want to use the Windows Task Manager to monitor processes. If fbxooprender.exe is not using close to 99% of processor power, other active processes may be interfering with the rendering process. Shut down non-essential tasks to make more processor power available for the rendering process.
Render Performance and the Building Model

One of the most effective ways to reduce the amount of time required to render an image is to reduce the number of model elements that the rendering engine must consider. Use one or more of the following strategies.

**Hide unnecessary model elements**

For example, if a rendered image will not show furniture that exists on the far side of an interior wall, hide the furniture in the view before rendering. By doing so, you reduce the number of elements that the rendering engine must consider during the rendering process. See Hiding Elements in a View on page 811.

**Change the detail level**

Change the view’s detail level to coarse or medium. By reducing the amount of detail in the 3D view, you reduce the number of objects to render, and thus reduce render time. See Specifying the Detail Level for a View on page 1619.

**Reduce the view area to render**

Render only the part of the 3D view that you need to show in the image, omitting areas that are not required. You can do this using a section box, a crop region, the camera clipping plane, or a render region. See Defining the View Area to Render on page 1079.

Render Performance and Lighting

The rendering process involves the simulation of light interactions with materials. As a result, render performance is significantly affected by lighting calculations. When preparing to render an image, consider the following.

**Number of lights**

Render time is directly proportional to the number of lights in the scene. In general, mental ray requires more time to render more lights. Consider turning off lights that are not required for the rendered image. See Turning Lights On and Off on page 1070.

In general, an interior view takes longer to render than an exterior view. An exterior view with no natural light (that is, at nighttime) that shows many interior lights turned on takes a long time to render.

**Light source shape**

More accurate lights require more render time. The Emit from Shape setting for a light source can impact render time. For example, point lights render faster than the other shapes. Line lights are slower. Rectangle and circle lights are slowest to render. See Defining the Geometry of a Light Source on page 1050.

**Soft shadows**

Revit Structure uses area light sources to produce more realistic images. However, area shadows are expensive to compute. If you increase the quality of soft shadows, render time increases. (In the Render Quality Settings dialog, use the Soft Shadow options. See Render Quality Settings on page 1081.)

**Indirect illumination**

Indirect illumination simulates the interaction of light with the environment by bouncing light off surfaces, including surfaces that are not directly exposed to a light source. If you increase the precision of indirect illumination and the number of bounces, you can improve the smaller, subtle effects of lighting, and the amount of light in a scene. However, increasing the amount of indirect illumination also increases the time...
required to render the image. (In the Render Quality Settings dialog, use the Indirect Illumination options. See Render Quality Settings on page 1081.)

Section boxes and light groups
When you use section boxes to limit the geometry being rendered, you can significantly reduce the amount of time required to render an image. (See Defining the View Area to Render on page 1079.) You can also use light groups to turn off lighting fixtures, thus reducing the number of lights that will impact the rendered image. (See Light Groups on page 1067. Remember, however, that lights that are not within the view can still have a significant impact on the quality of the rendered image.) Section boxes exclude lights that are clipped. When planned carefully and with forethought, the combined use of section boxes and light groups can greatly reduce the amount of time required to render an image.

Render Performance and Materials
Materials simulate various effects such as reflections and textures. You specify the render appearance for each material using the Materials dialog. (See Changing the Render Appearance of a Material on page 1582.) When mental ray renders materials, its performance depends on the effects being simulated. In fact, complicated render appearances for materials can slow down the rendering process more than complicated geometry in the building model.

When preparing to render an image, consider the following.

How Colors and Patterns Affect Render Performance
The complexity and size of a color or pattern affect render speed. More complex patterns require the rendering engine to calculate more samples so it can capture the details. The rendering engine works best when it can identify areas of similar surface treatment and can estimate appearances over large homogeneous areas.

For example, a smooth monochrome surface renders more quickly than a smooth patterned surface. A large-scale pattern renders more quickly than a dense, intricate pattern. A detailed, perforated surface renders more slowly than a simple surface.

The material render appearances that require the most time to render are (from slower to slowest): metallic paint, flecked metal, hammered metal, water, frosted glass, and perforated metal. Slower render times for these materials are proportional to how much of the scene they cover.

At the draft to medium quality settings, complicated materials may show many artifacts (small inaccuracies or imperfections in the rendered image). Imperfectly reflective materials (such as wood floors and metal mullions) appear speckled. These issues can be improved by adjusting the Blurred Reflection Precision value. (See Render Quality Settings on page 1081.)

To improve the appearance of patterned surfaces and silhouettes without significantly increasing render time, adjust the Image Precision (Antialiasing) value. (See Render Quality Settings on page 1081.) To produce images with little lighting depth but crisp geometry, use the draft quality setting with a high value for Image Precision (Antialiasing), such as 6.

How Reflection Types Affect Render Performance
The render appearance of a material specifies its reflectivity. Revit Structure can render matte reflections quickly. However, any material characteristic that causes visual distortions (such as blurred reflections or transparencies) requires more work to render, and so requires more render time.

Shiny and mirrored reflections are slightly more difficult to render than matte reflections. A fritted surface is more difficult to render than a smooth, glossy surface. Water is more difficult to render than glass. Metal with a patina or a hammered surface is more difficult to render than polished metal.
Blurred reflections are the most difficult to calculate. However, you can control the quality of blurred reflections to reduce the impact on render performance. (Use the Reflections and Transparency options. See Render Quality Settings on page 1081.)

How Refractions and Reflections Affect Render Performance

Refractive materials, like glass, usually involve reflections as well. As a result, these materials are more expensive (in time and resources) to render than others. Also, the average pane of glass has 2 layers or sides, requiring multiple layers of refraction. When rendering an image, all of the layers must be calculated so you can see through the glass. For example, you need at least 6 refractions to see through 3 panes of solid glass.

When rendering an image, you can specify the number of bounces off reflective surfaces (Maximum Number of Reflections), and the number of panes of glass for refractions (Maximum Number of Refractions). Higher settings generally result in longer render times. Blurry refractions increase render time further. (In the Render Quality Settings dialog, use the Reflections and Transparency options. See Render Quality Settings on page 1081.)

Render Performance and Image Size/Quality

The image size or resolution of a rendered image has a predictable effect on render time. The Image Precision (Antialiasing) setting affects render time in a similar way. (See Render Quality Settings on page 1081.) Higher values for image size, resolution, or precision require more time to generate the rendered image.

Effect of Increasing Image Resolution

If you double the image resolution (for example, from 75 dpi to 150 dpi) without changing other settings, render time can increase by 2 to 4 times. (Depending on the complexity of the image being rendered, the increase in render time can vary from 1.9 to 3.9 times, with an average of 2.7 times the render time of the original 75-dpi image.)

If you double the resolution again (from the original 75 dpi to 150 dpi, then to 300 dpi), each jump in resolution increases render time by 2.7 times. Therefore, if you increase the resolution from 75 dpi to 300 dpi, the render time is typically increased 2.7 x 2.7 times, or about 7.3 times the original 75-dpi render time. If you increase the resolution from 75 dpi to 600 dpi, the render time is typically increased 2.7 x 2.7 x 2.7 times, or about 19.7 times the original 75-dpi render time.

Checking the Image Size

When defining the view area to render, check that the image size is appropriate and reasonable. If you specify a very large image size, the render speed may be very slow.

- **Crop region**: When using a crop region to define the view area to render, you can specify the height and width of the crop region. (See Resizing Crop Regions Explicitly on page 853.) The crop region size defines the paper size of the rendered image.

- **Render region**: When using a render region to define the view area to render in an orthographic view, you can drag the render region boundary. (Defining the View Area to Render on page 1079.) The resulting height and width display in the Rendering dialog under Output.

See Controlling the Size of the Rendered Image on page 1084.

Troubleshooting Issues with Rendering

When rendering a 3D view, you may encounter the following issues.
Press Render to Update the Image

Error: Changes you have made to the rendering are not shown in this image. Press Render to update the image.

Issue: This message displays in the drawing area when you render an image and then change the render settings or the building model. It indicates that the rendered image is out of date.

Solution: To update the rendered image, click Render in the Rendering dialog.

Missing Images

Warning: The following render appearance images are missing.

NOTE If you see this warning during the rendering process, copy and paste the list of missing files into a text file or document. This strategy enables you to check on the status of these missing files later.

Issue: When mental ray cannot locate files used in render appearances, it continues the rendering process, and it renders that part of the view as black. (Click Cancel if you want to cancel the rendering process instead of proceeding.) For example, if an image file that defines a custom color or texture is missing, elements to which that material is applied display as black in the rendered image.

Solution: Check the render appearances of the relevant materials. (See Changing the Render Appearance of a Material on page 1582.)

When you move the mouse over the Image File field for a color or bump pattern, Revit Structure displays the path of the image file. Check whether the image file resides in the specified location. If not, check whether the image file resides in a path specified on the Rendering tab of the Options dialog. (See Additional Render Appearance Paths on page 1627.) If the Revit project was sent to you by another team member, you may need to request the relevant image files.

Not Enough Memory to Create the Rendered Image

Error: There is not enough memory to create the rendered image.

Issue: This message displays when you try to render an image, but the computer has insufficient memory to perform the operation.

Solution: To make more memory available for the rendering process, use one or more of the following strategies:

■ Reduce the size of the image to be rendered. See Controlling the Size of the Rendered Image on page 1084 and Render Performance and Image Size/Quality on page 1093.

■ Close unnecessary views in the Revit project.

■ Close unnecessary applications.

Disk Space Insufficient for Rendering

Error: There is not enough space on drive X to create the temporary files that the rendering process needs.

Issue: This message displays when you try to render an image, but the disk drive has insufficient space or the image file size is too large.
**Solution:** To make more disk space available for the rendering process, use one or more of the following strategies:

- Reduce the size of the image to be rendered. See Controlling the Size of the Rendered Image on page 1084 and Render Performance and Image Size/Quality on page 1093.
- Make more disk space available on the disk drive.

**Rendering Process Is Taking Too Long**

**Symptom:** The rendering process is taking too long, or is taking longer than expected.

**Issue:** Many factors can affect the amount of time required to render an image, including image size, resolution, render quality settings, lighting, complex materials, and more.

**Solution:** See Rendering Best Practices on page 1090. That section describes many of the factors that affect render time. It also provides recommendations and tips on how to balance the need for a quality image with the amount of time required to render it.

**Rendered Image Is Black**

**Symptom:** All or part of the rendered image is black.

**Issues and Solutions:** If parts of the rendered image are black, some image files used by render appearances may be missing. See Missing Images on page 1094.

If the rendered image is all black, it could be caused by the following:

- **No lights:** The render settings do not include natural or artificial light. For example, suppose you specify an interior lighting scheme that uses artificial lights only, but all interior lights are turned off. To correct this situation, in the Rendering dialog, check the lighting settings. Change them to include natural light or artificial light, or both. If needed, turn on artificial lights.

- **Exposure settings:** The exposure settings are not defined correctly.
  To correct this situation, check the exposure settings. In the Rendering dialog, under Image, click Adjust Exposure. See Exposure Control Settings on page 1087.

**Rendered Image Is Washed Out or Faded**

**Symptom:** The rendered image shows too much light, so it looks washed out or faded.

**Issues and Solutions:** To solve the problem, try the following:

- **Exposure:** Check the exposure setting. Try using a darker exposure. See Adjusting the Exposure of a Rendered Image on page 1087.

- **Initial Intensity:** The Initial Intensity settings for the light sources may be incorrect. In general, Luminous Flux (lumens) provides more accurate lighting in a rendered image than Wattage. Determine the manufacturer value for lumens, and enter this value for the Luminous Flux parameter of the Initial Intensity dialog. (See Changing the Initial Intensity of a Light Source on page 1066.)

- **Wattage and Efficacy:** If you specify a Wattage value on the Initial Intensity dialog, be sure to also specify a value for Efficacy. (If you change Wattage alone, you may make the light source unintentionally bright.) Efficacy is the amount of light (luminous flux, measured in lumens) produced by a light source as a ratio of the amount of energy consumed to produce it (measured in watts).
  Examples: For a 100 watt tungsten incandescent (110 V), efficacy is 175. For a 32-watt fluorescent tube (T8), efficacy is 60.
After changing the Efficacy value, render the image again. Try adjusting the Efficacy value until you achieve the desired result in the rendered image.

**Elements Are Gray in Rendered Image**

Symptom: In the rendered image, some of the elements display as gray. They do not display render appearances as expected.

Issue: This problem occurs when you upgrade a Revit 2008 (or an earlier release) project that uses custom materials. During the upgrade process, Revit Structure upgrades all standard materials to use the new render appearances. However, it cannot upgrade any custom materials.

Solution: Assign render appearances to the custom materials. See Changing the Render Appearance of a Material on page 1582.

**Glass is Too Light or Too Dark**

Symptom: Areas of glass or glazing in the rendered image appear darker or lighter than expected.

Issue: The render appearance for the glazing may not indicate the actual number of glass panes that are modeled in the geometry and rendered in the image.

Solution: Change the render appearance of the glazing material to increase or decrease the Sheets of Glass parameter. See Changing the Render Appearance of a Material on page 1582 and Glazing Properties on page 1589.

**Rendered Image Is Poor Quality**

Symptom: The rendered image has one or more of the following issues:

- It contains artifacts (small inaccuracies or imperfections in the rendered image).
- In some places, light reflecting on surfaces looks splotchy or speckled.
- Edges of model elements and their shadows are not crisp. Instead, the edges are soft and fuzzy.

Issue: These issues may be caused by inappropriate render quality settings, or the use of default settings.

Solution: Try adjusting the render quality settings to obtain the desired result. See Render Quality Settings on page 1081 and Rendering Best Practices on page 1090.

**Rendered Image is Wrong Color**

Symptom: In the rendered image, the lighting looks too blue or too orange.

Issue: This problem occurs when the white point needs to be adjusted.

Solution: Adjust exposure settings for the rendered image. See Adjusting the Exposure of a Rendered Image on page 1087.

- If the image looks too orange, reduce the White Point value.
- If the image looks too blue, increase the White Point value.
Light Source Shapes Do Not Display in Rendered Image

**Symptom:** The light does not display a self-luminous surface (glow) in the rendered image.

**Issue:** In the lighting fixture family, you specified an Emit from Shape of Circle or Rectangle. (See Defining the Geometry of a Light Source on page 1050.) In the lighting fixture parameters, you selected Emit Shape Visible in Rendering. (See Parameters for Lighting Fixtures and Light Sources on page 1052.) Therefore, you expect the light to display a self-luminous surface in the rendered image. However, the luminous surface does not display because the Soft Shadows option is turned off.

**Solution:** Select the Soft Shadows option on the Render Quality Settings dialog. (See Defining a Custom Render Quality on page 1081 and Render Quality Settings on page 1081.) Then render the image again.
Walkthroughs

Walkthrough Overview

A walkthrough is a camera that follows a path that you define. The path comprises frames and key frames. A key frame is a modifiable frame where you can change the direction and position of the camera. A walkthrough path might look something like the following image. The red dots indicate key frames.

By default, walkthroughs are created as a series of perspective views, but you can also create them as orthographic 3D views.

Creating a Walkthrough Path

1 Open a view in which to place the walkthrough path.

   **NOTE** Typically, the view is a plan view, but you can also make a walkthrough in other views, including 3D, elevation, and section views.

2 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ (Walkthrough).
3 If desired, on the **Options Bar** on page 34, clear the Perspective option to create a walkthrough as an orthographic 3D view. Also select a view scale for the 3D view.

4 If you are in a plan view, you can vary the height of the camera by offsetting it from a selected level. Enter a height in the Offset text box and select a level from the From menu. This can give you the effect that the camera is going up a flight of stairs.

5 Place the cursor in a view, and click to place a key frame.

6 Move the cursor in the desired direction to draw the path.

7 Click again to place another key frame. You can place key frames anywhere, but you cannot change their position during creation of the path. You can edit the key frames after you finish the path.

8 To finish the walkthrough path, you can do any of the following:
   - Click Finish Walkthrough.
   - Double-click to end the path.
   - Press **Esc**.

After you finish placing camera key frames, Revit Structure creates a walkthrough view under the Walkthroughs branch of the **Project Browser** on page 28 and assigns it the name Walkthrough 1.

**Editing a Walkthrough Path**

1 In the Project Browser, right-click the walkthrough view name, and select Show Camera.

2 To move the entire walkthrough path, drag the path to the desired location. You can also use the Move tool. See **Moving Elements with the Move Tool** on page 1475.

3 To edit the path, click Modify | Cameras tab ➤ Walkthrough panel ➤ ![Edit Walkthrough](image) (Edit Walkthrough). You can select which control in the path you want to edit from the drop-down menu. Controls affect the position and direction of the camera.

**Dragging the Camera to a New Frame**

1 For Controls, select Active Camera.

2 Drag the camera along the path to the desired frame or key frame. The camera snaps to key frames.

3 You can also type the frame number in the Frame text box.

4 While the camera is active and located at a key frame, you can drag the target point of the camera and the far clip plane. If the camera is not at a key frame, you can change only the far clip plane.

**Changing the Walkthrough Path**

1 For Controls, select Path. The key frames become controls along the path.

2 Drag a key frame to the desired location. Notice that the value in the Frame text box stays constant.

**Adding Key Frames**

1 For Controls, select Add Key Frame.

2 Place the cursor along the path, and click to add a key frame.
Removing Key Frames

1. For Controls, select Remove Key Frame.
2. Place the cursor on an existing key frame on the path, and click to remove it.

Displaying the Walkthrough View when Editing

As you edit a walkthrough path, you may want to see the results of your changes on the actual view. To open the walkthrough view, click Modify | Cameras tab ➤ Walkthrough panel ➤ (Open Walkthrough).

Editing Walkthrough Frames

1. Open the walkthrough.
2. Click Modify | Cameras tab ➤ Walkthrough panel ➤ (Edit Walkthrough).
3. On the Options Bar, click the Walkthrough frame edit button .
   The Walkthrough Frames dialog has 5 columns that show the frame properties:
   - The Key Frame column displays the total number of key frames in the walkthrough path. Click a key frame number to display where that key frame appears on the walkthrough path. A camera icon displays at the selected key frame.
   - The Frame column displays the frame at which the key frame displays.
   - The Accelerator column displays numerical controls for changing the speed of the walkthrough playback at a specific key frame.
   - The Speed column displays the speed at which the camera travels along the path at each key frame.
   - Elapsed Time displays the amount of time that has elapsed since the first key frame.
4. By default, there is a uniform speed at which the camera travels along the entire walkthrough path. You can change the speed by increasing or decreasing the total number of frames or by increasing or decreasing the number of frames per second. Enter the desired value for either.
5. To change the accelerator value for key frames, clear the Uniform Speed check box, and enter a value for the desired key frame in the Accelerator column. Valid values for the Accelerator are between 0.1 and 10.

Cameras Along Path

To help you visualize the distribution of frames along the walkthrough path, select Indicators. Enter a value for the increment at which you want to see camera indicators.

Resetting Target Points

You can move the position of the camera’s target point at a key frame, for example, to create the effect that the camera is looking side to side. To reset the target points back to following the path, click Modify | Cameras tab ➤ Walkthrough panel ➤ (Reset Cameras).
Controlling Walkthrough Playback

Several tools are available to control playback of a walkthrough while you are editing it. See Editing a Walkthrough Path on page 1100.

- Click \( \text{\textbullet} \) to move the camera position back one key frame.
- Click \( \text{\textbullet} \) to move the camera position back one frame.
- Click \( \text{\textbullet} \) to move the camera position forward one frame.
- Click \( \text{\textbullet} \) to move the camera position forward one key frame.
- Click \( \text{\textbullet} \) to move the camera from its current frame to the last frame.
- To stop play back, click Cancel next to the Progress Bar or press $\text{Esc}$ . Click Yes at the prompt.

Related topics
- Editing Walkthrough Frames on page 1101
- Editing a Walkthrough Path on page 1100
- Exporting a Walkthrough on page 1102
- Walkthrough Overview on page 1099

Exporting a Walkthrough

You can export a walkthrough to an AVI or image file. When you export a walkthrough to an image file, each frame of the walkthrough is saved as an individual file. You can export all frames or a range of frames.

To export a walkthrough:

1. Open the walkthrough view.
2. Click \( \text{\textbullet} \) Export \( \text{\textbullet} \) Images and Animations \( \text{\textbullet} \) Walkthrough. The Length/Format dialog opens.
3. Under Output Length, specify:
   - All frames to include all frames in the output file(s).
   - Frame range to export only a specific range of frames. For this option, enter the frame range in the entry boxes.
   - Frames/second. As you change the number of frames per second, the total time automatically updates.
4. Under Format, specify Visual Style, Dimensions on page 887, and Zoom to the desired values.
5. Click OK.
6. Accept the default output file name and path, or browse to a new location and enter a new name.
7. Select the file type, either AVI or an image file (JPEG, TIFF, BMP, or PNG).
8. Click Save.
9 In the Video Compression dialog, choose a video compressor from the list of compressors you have installed on your computer.

10 To stop recording the AVI file, click Cancel next to the progress indicator at the bottom of the screen or press Esc.
Share the Design

You can share Revit Structure projects and files with clients, consultants, and other team members.

Export

Exporting converts one or more Revit Structure views (or sheets) to various formats for use with other software.

Related topics

- Exporting a Walkthrough on page 1102
- Exporting Solar Studies on page 1388
- Exporting a Schedule on page 798

Exporting to CAD Formats

Revit Structure supports exporting to CAD (DWG and DXF), ACIS (SAT), and MicroStation® (DGN) file formats.

- DWG (drawing) format is supported by AutoCAD and other CAD applications.
- DXF (data transfer) is an open format that is supported by many CAD applications. A DXF file is a text file that describes a 2D drawing. The text is not encoded or compressed, so DXF files are generally large. If you use DXF for 3D drawings, you may need to perform some cleanup to make the drawing display correctly.
- SAT is the format for ACIS, a solid modeling technology that is supported by many CAD applications.
- DGN is the file format supported by MicroStation of Bentley Systems, Inc.

If you use the Export tool while in a 3D view, Revit Structure exports the actual 3D model, not a 2D representation of the model. Exporting in 3D ignores all view settings, including hidden line mode. To export a 2D representation of the 3D model, add the 3D view to a sheet and export the sheet view. You can then open a 2D version of the view in AutoCAD.

NOTE You cannot export to CAD formats while in Demo mode.
Before exporting a Revit model, you may want to:

■ Reduce the amount of model geometry to be exported. See Limiting Model Geometry Before Exporting on page 1106.

■ Create a layer mapping file to control the export process. To preserve information about a project, Revit Structure automatically maps categories and subcategories to preconfigured layer names. These layers are used by AutoCAD and other applications. Before exporting a Revit Structure project, you may want to change the mappings to the desired layer names. See Exporting Layers on page 1125.

■ Adjust the view scale to control the precision/performance ratio. When you export to 2D DWG or DXF, you export a scaled 2D view of the model. The view scale you apply determines whether the resulting view is exported for precision or for performance. For example, if your model contains 2 lines that are 1/4" apart and the view scale is 100, the lines will be considered to be within tolerance, and the exported DWG will contain a single line (exported for performance). If the view scale is 20, the exported DWG will contain separate lines (exported for precision).

Limiting Model Geometry Before Exporting

In Revit Structure, a view of the building model contains many objects and a lot of data. When exporting a file for use in another software application, Revit Structure exports only the objects that are visible in the view (or views) being exported. By reducing the amount of model geometry (and its underlying data) that is exported, you can:

■ Improve performance of the export process.

■ Reduce the size of the exported file.

■ Improve performance of the importing application.

■ Reduce clutter (non-essential items) in the exported file, and hence the amount of work required to delete these objects from the file in the importing application.

Use the following techniques to reduce the amount of geometry to be exported.

Turn off visibility of graphics

To turn off visibility of graphics in a view, click View tab ➤ Graphics panel ➤ (Visibility/Graphics). See Visibility and Graphic Display in Project Views on page 801.

Turn off visibility for categories of elements in the view, as appropriate. For example, you might want to omit topography from a 3D view to be exported. If you want to render an exterior scene, turn off any elements that appear in the interior of the building. This reduces the number of objects and the amount of data that is exported from Revit Structure and imported into another application, thus improving performance.

Use a section box or crop region

To define the specific part of the project to export, use a section box in a 3D view or a crop region in a 2D view. Elements that are completely outside the section box or crop region are not included in the export file. This technique is particularly useful on large models. For example, for an interior rendering of a conference room in an office building, use a section box to export a 3D view of the conference room and omit the rest of the building.
Specify the detail level

To specify the detail level for a view, on the View Control Bar at the bottom of the drawing area, click the Detail Level button, and select the desired detail level: coarse, medium, or fine.

Specify either coarse or medium in order to reduce the amount of detail in the Revit view. As a result, you reduce the number of objects exported, and the size of the exported file. This results in better performance in the importing application.

Exporting to DWG

1 Click ➤ Export ➤ CAD Formats ➤ (DWG files).
2 In the Export CAD Formats dialog, determine which views and sheets are to be exported to the DWG file.
   If you are exporting a single view, select Current View/Sheet Only from the Export list on the View/Sheet Set tab.
   If you are exporting multiple views and sheets:
      a On the View/Sheet Set tab, for Export, select In session view/sheet set.
      b Select the views and sheets to export. See Creating View and Sheet Sets on page 1110 and Selecting Views to Print on page 1150.
3 On the DWG Properties tab, specify export options:
   ■ Layers and Properties on page 1113
   ■ Colors on page 1115
   ■ Linetype Scaling on page 1115
   ■ Coordinate System Basis on page 1116
   ■ One DWG Unit Is on page 1116
   ■ Text Treatment on page 1116
   ■ Solids (3D Views Only) on page 1117
   ■ Export Rooms and Areas as Polylines on page 1117
4 Click Next.
   NOTE To save the current export settings and close the dialog without exporting, click Save Settings.
5 In the Export CAD Formats dialog, navigate to the target folder for the exported files.
6 For Files of type, select an AutoCAD version for the exported DWG file.
7 For Naming, select Automatic - Long (Specify prefix) or Automatic - Short to define the automatically generated file name.
Optionally, to prohibit Revit Structure from creating external references, clear Xref views on sheets. Any Revit or DWG links in the project are exported to a single file rather than several files that reference each other.

Click OK.

Revit Structure exports the selected views and sheets to DWG files and places them in the target folder.

When you export a 3D view to a DWG file, colors are treated as follows:

- Edge colors: because they are not rendered in AutoCAD, edge colors are ignored on export. This will result in correct shaded/realistic views (edge overrides will no longer be assigned to the entire model).
- Phase colors: color overrides on solid fills are supported on export, but color overrides on patterns are not.

When you export a 2D view to a DWG file, lines are treated as follows:

- If 2 lines overlap in the drawing, the thicker of the lines is retained. The thinner line is shortened or removed.
- If a thick line is shorter than a thin line and its start point and endpoint fall within the thin line, no action occurs.
- If 2 collinear lines with the same visual parameters overlap, they are merged into one.
- When walls become lines in the DWG file, no short collinear lines are produced.

**Exporting to DXF**

1. Click ➤ Export ➤ CAD Formats ➤ DXF (DXF files).

2. In the Export CAD Formats dialog, determine which views and sheets are to be exported to the DXF file.

   - If you are exporting a single view, select Current View/Sheet Only from the Export list on the View/Sheet Set tab.
   - If you are exporting multiple views or sheets:
     a. On the View/Sheet Set tab, for Export, select In session view/sheet set.
     b. Select the views or sheets to export. See Creating View and Sheet Sets on page 1110 and Selecting Views to Print on page 1150.

3. On the DXF Properties tab, specify export options:

   - Layers and Properties on page 1113
   - Colors on page 1115
   - Linetype Scaling on page 1115
   - Coordinate System Basis on page 1116
   - One DWG Unit Is on page 1116
   - Text Treatment on page 1116
   - Solids (3D Views Only) on page 1117
   - Export Rooms and Areas as Polylines on page 1117
4 Click Next.

**NOTE** To save the current export settings and close the dialog without exporting, click Save Settings.

5 In the Export CAD Formats dialog, navigate to the target folder for the exported files.

6 For Files of type, select an AutoCAD version for the exported DXF file.

7 For Naming, select Automatic - Long (Specify prefix) or Automatic - Short to define the automatically generated file name.

8 Click OK.

Revit Structure exports the selected views and sheets to DXF files and places them in the target folder. When you export a 3D view to a DXF file, colors are treated as follows:

- **Edge colors**: because they are not rendered in AutoCAD, edge colors are ignored on export. This will result in correct shaded/realistic views (edge overrides will no longer be assigned to the entire model).
- **Phase colors**: color overrides on solid fills are supported on export, but color overrides on patterns are not.

### Exporting to DGN

1 Click ➤ Export ➤ CAD Formats ➤ (DGN files).

**NOTE** The DGN file format supports MicroStation version 7. If you are using a later version, export to DWG format. See Exporting to DWG on page 1107.

2 In the Export CAD Formats dialog, determine which views and sheets are to be exported to the DGN file.

   If you are exporting a single view, select Current View/Sheet Only from the Export list on the View/Sheet Set tab.

   If you are exporting multiple views and sheets:
   
   a On the View/Sheet Set tab, for Export, select In session view/sheet set.

   b Select the views and sheets to export. See Creating View and Sheet Sets on page 1110 and Selecting Views to Print on page 1150.

3 On the DGN Properties tab, specify export options:

   - **Layer Settings** on page 1113

   - **Enable DGN Template File** on page 1118

**NOTE** When you export (to DGN format) a 3D view that contains solid geometry, the geometry always exports as a polymesh.

4 Click Next.

**NOTE** To save the current export settings and close the dialog without exporting, click Save Settings.

5 In the Export CAD Formats dialog, navigate to the target folder for the exported files.

6 For Naming, select Automatic - Long (Specify prefix) or Automatic - Short to define the automatically generated file name.
7 Click OK.
Revit Structure exports the selected views and sheets to DGN files and places them in the target folder.

Exporting to SAT

1 Click ➤ Export ➤ CAD Formats ➤ (ACIS (SAT) files).
2 In the Export CAD Formats dialog, determine which views and sheets are to be exported to the SAT file.
   If you are exporting a single view, select Current View/Sheet Only from the Export list on the View/Sheet Set tab.
   If you are exporting multiple views and sheets:
   a On the View/Sheet Set tab, for Export, select In session view/sheet set.
   b Select the views and sheets to export. See Creating View and Sheet Sets on page 1110 and Selecting Views to Print on page 1150.

NOTE When you export (to SAT format) a 3D view that contains solid geometry, the geometry always exports as ACIS solids.

3 Click Next.

NOTE To save the current export settings and close the dialog without exporting, click Save Settings.

4 In the Export CAD Formats dialog, navigate to the target folder for the exported files.
5 ForNaming, select Automatic - Long (Specify prefix) or Automatic - Short to define the automatically generated file name.
6 Click OK.
Revit Structure exports the selected views and sheets to SAT files and places them in the target folder.

Creating View and Sheet Sets

When you export to various formats, you use the View/Sheet Set tab from the appropriate Export/Publish Settings dialogs to specify which project views and sheets to output. This tab consists of the following tools, which you can use to create and select views and sheets to include in the output file. These selected views can be saved as a set for future use.
Export. Determines the set that will display in the View/Sheet list. This list contains all user-defined sets and the following default sets.

- **<Current View/Sheet Only>**. Displays the currently active view or sheet.
- **<In session view/sheet set>**. Enables Show in list, so that you can filter views and sheets for the entire project or established set.

Show in list. Contains filters to broaden and narrow the available views and sheets of the selected set to output:

- Views in the Set
- Sheets in the Set
- All views and sheets in the Set
- Views in the Model
- Sheets in the Model
- All views and sheets in the Model

The model-based filters list views and sheets from the project, disregarding the chosen set.

Check all/Check none. Select or deselect the listed views and sheets.

Set Manager tools. Buttons that create, modify, and delete sets:

- [New Set]. Creates an empty set.
- [Duplicate Set]. Creates a copy of the active set.
- [Rename Set]. Prompts to rename the active set.
- [Delete Set]. Deletes the active set.

View/Sheet List. This table contains the views and sheets that have been filtered by the Export and Show in list options detailed above. The table consists of sortable columns that define the view list.
NOTE: Click a column header to sort the list by the selected parameter.

- **Include.** When selected, the associated view will be output with the new file.
- **Type.** Displays an icon representing the view type. These include plan views, sections, elevations, 3D views, and sheets.
- **Name.** The name of the view as recognized by Revit Structure. Double-click the name to see a thumbnail of the view in the preview pane to the left of the View/Sheet Set tab.

### Defining View and Sheet Sets

Using the tools available on the View/Sheet Set tab, you can identify views and sheets to include in the exported file.

#### To use the current view to export

For Export, select **<Current View/Sheet Only>**. Notice that the only view listed and selected is the currently active view. The view is selected by default and will be output with the exported file.

**NOTE** Sets do not need to be saved or validated. They maintain their last configured status at all times.

#### To create a new set to export

1. Click **(New Set).**
2. Enter a name in the New Set dialog and click OK.
   The new set will display for Export.
3. To filter your view choices, for Show in list, select Views in the Model, Sheets in the Model, or All views and sheets in the Model.
4. To specify views for the set, select Include for each view desired.
   The set is now available for use and may be selected from the Export drop-down list.

#### To create a new set by duplicating another

1. For Export, select the set to be duplicated.
2. Click **(Duplicate Set).**
3. Enter a name in the Duplicate Set dialog and click OK.
   The new set will display for Export.
   The set is now available for use and may be selected from the Export drop-down list. If the set is to be adjusted with different views and sheets, proceed with the following steps.
4. To filter your view choices, for Show in list, select Views in the Set, Sheets in the Set, or All views and sheets in the Set.
5. To specify views for the set, select or clear Include for each view in the set.

### Modifying View and Sheet Sets

Modifying the views and sheets in an existing set is a matter of adjusting their Include status in the list.

1. On the View/Sheet Set tab, for Export, select the set to be modified.
2. For Show in list, select from the Set and Model filters to narrow and broaden your choices.
To specify views for the set, select or clear Include for each view in the set.

**NOTE** When modifying view and sheet sets, changes are immediate and do not need to be saved or validated. They maintain their last configured status at all times.

**To rename a set**

1. For Export, select the set to be renamed.
2. Click (Rename Set).
3. Enter a name in the Rename Set dialog and click OK.
   The new name is immediately displayed for Export.

**To delete a set**

1. For Export, select the set to be deleted.
2. Click (Delete Set).

The set is immediately removed.

### Exporting to CAD Format Properties

When exporting to a CAD format, you can use the format properties tab on the Export CAD Formats dialog to specify various options. Each format properties tab is named by its specific format, such as DWG Properties.

**Related Topic**

- Exporting to CAD Formats on page 1105

### Layer Settings

1. Click > Export > CAD Formats > DWG, DXF, or DGN.
2. In the Export CAD Formats dialog, click the <Format> Properties tab.
3. Next to Layers and properties, click (Browse).
   From the Export Layers dialog, you load an existing layer mapping file, create a standard layer mapping file, or customize layer mappings. For more information, see Exporting Layers on page 1125.

### Layers and Properties

Select a value from the Layers and Properties list to control how to export object styles from Revit Structure to AutoCAD (or other CAD applications).

**NOTE** You can define layers and properties when exporting to DXF or DWG. These options are not available when exporting to DGN or SAT.

When you export a Revit view to DWG or DXF, each Revit category is mapped to an AutoCAD layer, as specified in the Export Layer dialog. In AutoCAD, the layer controls the display of the entities (Revit elements), including their colors, line weights, and line styles. In Revit Structure, you define object styles in the Object
Styles dialog. (See Object Styles on page 1601.) The Layers and Properties setting determines what happens to a Revit element if it has attributes (object styles) that differ from those defined for its category. In AutoCAD and in Revit Structure, view-specific element graphics are referred to as overrides.

Select one of the following values:

- **Category properties BYLAYER, overrides BYENTITY.** When a Revit element with view-specific graphics is exported, in AutoCAD those differences (overrides) are applied to the individual entity, but the entity resides on the same layer as other entities in the same Revit category or AutoCAD layer.

- **All properties BYLAYER, no overrides.** When a Revit element with view-specific graphics is exported, in AutoCAD those differences (overrides) are ignored. The entity resides on the same layer as other entities in the same Revit category or AutoCAD layer, and it loses its unique attributes. This option forces all entities to follow visual properties as defined by their layer. It produces the least number of layers and provides by-layer control over the exported DWG file.

- **All properties BYLAYER, new layers for overrides.** When a Revit element with view-specific graphics is exported, in AutoCAD the entity is placed on its own layer. This option provides by-layer control over the exported DWG file, and preserves graphical intent. However, it increases the number of layers in the exported DWG file.

For example, suppose that, in a Revit Structure project, most walls display with solid black lines, with a line weight of 5. In a floor plan, however, you have changed the view-specific element graphics for one wall to use dashed blue lines, with a line weight of 7.

![Diagram of wall changes](image)

When you export this view to DWG or DXF and, for Layers and Properties, select:

- **Category properties BYLAYER, overrides BYENTITY:** All walls in this Revit category, including the blue wall, are assigned to one layer in AutoCAD. The blue wall, however, retains its unique attributes (blue, dashed, line weight = 7) because AutoCAD defines them *by entity* for that wall.

- **All properties BYLAYER, no overrides:** All walls in this Revit category, including the blue wall, are assigned to one layer in AutoCAD, and the blue wall does not retain its unique characteristics. In AutoCAD, it looks the same as the other walls in the layer.

- **All properties BYLAYER, new layers for overrides:** All walls in this Revit category, except for the blue wall, are assigned to one layer in AutoCAD. The blue wall retains its unique attributes, but it is assigned to its own layer.
Colors

Select either of the following options from the Colors list to specify how colors are exported to DWG or DXF files:

- **Index Color (255 Colors).** Uses the indexed colors and pen widths, as specified in the Export Layers dialog, for colors that are set by category. When colors are not set by category and the override is preserved in the export, Revit Structure uses the closest match from the 255 indexed colors and thus may not provide an exact match for RGB and Pantone® colors.

- **True Color (RGB Values).** Uses the RGB value from Revit Structure for the ByLayer and ByEntity parameters, rather than the indexed color from the Export Layers dialog. For example, when you export room (or space) color fills, the colors in the exported file exactly match those in the original file.

Linetype Scaling

Select a value from the Linetype Scaling list to control the LTSCALE and PSLTSCALE settings in AutoCAD and to control how linetype definitions are exported from Revit Structure.

**NOTE** You can define Linetype Scaling when exporting to DXF or DWG. This option is not available when exporting to DGN or SAT.

Linetypes determine the particular dash-dot sequence, the relative lengths of dashes and blank spaces, and the characteristics of any included text or shapes in lines. In Revit Structure, these are defined by object styles for categories (Manage tab ➤ Settings panel ➤ Object Styles) or as view-specific element graphics for individual elements. (See Object Styles on page 1601 or Overriding Visibility and Graphic Display of Individual Elements on page 802.)

In AutoCAD, the PSLTSCALE parameter controls paper space linetype scaling. A value of 0 indicates no special linetype scaling. Linetype dash lengths are based on the drawing units of the space (model or paper) in which the objects were created. A value of 1 indicates that viewport scaling governs linetype scaling.

In Revit Structure, the Linetype Scaling setting changes the default behavior of the exported DWG files. Some lines that you would expect to be dashed may now appear solid or in a different scale in either Model or Sheet View in AutoCAD. Regardless of the option you choose, the DWG linetype definitions are created so that a dashed line always begins and ends with a dash.
Select one of the following values:

- **Scaled Linetype definitions.** This option exports linetypes the same as they were previously scaled by view scale. This option preserves graphical intent.

- **Modelspace (PSLTSCALE = 0).** This option specifies the LTSCALE parameter to view scale and the PSLTSCALE to 0.

- **Paperspace (PSLTSCALE = 1).** This option specifies the value 1 for both LTSCALE and PSLTSCALE. Revit Structure linetype definitions are scaled to reflect project units, but otherwise they are exported as is.

### Coordinate System Basis

Select a value from the Coordinate system basis list to indicate whether the exported file will use the internal coordinates of the Revit project, or coordinates that are shared with other linked models. See Linking Revit Models on page 1183 and Shared Positioning on page 1265.

**NOTE** You can define the Coordinate System Basis when exporting to DXF or DWG. This option is not available when exporting to DGN or SAT.

Select one of the following values:

- **Project internal.** This option sets the origin of the exported file to the internal coordinates of the Revit project. Use this option when the Revit project is a stand-alone project that is not linked to other models, or when its particular position is irrelevant for the intended use of the exported file.

- **Shared.** This option sets the origin (0,0,0) of the exported file to the shared position of the Revit project. All geometry is exported relative to the shared coordinates. Use this option when you want to maintain the specific position of the project being exported.

  When exporting to DWG, it is necessary to specify views and not sheets for shared coordinates to work correctly.

### One DWG Unit Is

Select a default unit of measurement for the exported drawing: foot, inch, meter, centimeter, or millimeter. For imperial projects, the default unit is inches. For metric projects, the default unit is meters.

**NOTE** You can define One DWG Unit Is when exporting to DXF or DWG. This option is not available when exporting to DGN or SAT.

### Text Treatment

Determines how text notes are to be exported.

- **Maintain visual fidelity:** exported text will look exactly as it does in Revit Structure (exact line wrapping). However, if the text includes bulleted or numbered lists, that paragraph functionality is lost on export (pressing Enter within a formatted paragraph will not produce a subsequent formatted paragraph).

- **Maintain functional fidelity:** if exported text includes bulleted or numbered lists, that paragraph functionality is maintained when the text is edited (pressing Enter within a formatted paragraph will produce a subsequent formatted paragraph). However, the visual appearance of the text may vary from the original, whether or not the note contains a list (wrapping may vary).
**Solids (3D Views Only)**

Indicates how solid geometry is to be exported. This option is available only when you are exporting a 3D view.

**NOTE** You can define Solids (3D Views Only) when exporting to DXF or DWG. When exporting to SAT, geometry always exports as ACIS solids. When exporting to DGN, geometry always exports as polymeshes.

Modeling programs generally represent 3D shapes using either of the following technologies:

- **ACIS** is a solid modeling technology. For example, ACIS represents a cube as a single object or shape with 6 sides.

- A polymesh is a 3D shape consisting of multiple polygons that are meshed (joined) together. For example, a polymesh cube consists of 6 square surfaces that are joined together to form the cube shape. This is referred to as face-based geometry.

Select one of the following values:

- **Export as polymesh.** This option exports all visible Revit geometry as polymeshes.

- **Export as ACIS solids.** This option exports all visible Revit geometry as ACIS 3D solids. Any elements that are already polymeshes remain as polymeshes, such as toposurfaces and import symbols that contain polymeshes.

### Export Rooms and Areas as Polylines

Indicates whether rooms and areas are exported as closed polylines. You can use this option only when rooms or areas are defined in the views to be exported.

For rooms, the exported polylines match the boundaries of rooms in Revit Structure. The room boundaries are exported onto a single layer, and that layer is turned off by default in the AutoCAD file. The polylines include the following XDATA information for room boundaries: Name, Number, Occupancy, Occupant, Department, and Comments.
For areas, the polylines include the following information for area boundaries: Name and Comments.

**NOTE** You can select Export Rooms and Areas as Polylines when exporting to DXF or DWG. This option is not available when exporting to DGN or SAT. These room and area features are primarily intended for Revit Architecture and Revit MEP users.

---

**Enable DGN Template File**

Select this when you want to use a template (a MicroStation seed file) for the exported DGN file. Then click ...
(Browse) to navigate to and load the template. Revit Structure exports the project to a DGN file using the settings in the specified template.

If you do not use a DGN template file, Revit Structure exports the project to a DGN file using default settings.

**NOTE** You can select Enable DGN Template File when exporting to DGN only. This option is not available when exporting to DWG, DXF, or SAT.

---

**File Names for Exported Files**

When exporting to a CAD format or DWF, you can specify a name or prefix for the exported files. In the Export dialog, under Naming, use the options to name the exported files:

- **Automatic - Long (Specify prefix).** Manually specify a prefix in the File name/prefix field or accept the default, which uses the format:
  
  Revit Sheet/View: Project Name-View Type-View Name

- **Automatic - Short.** Revit Structure determines the name automatically and adds a prefix to the file name of the current view or multiple views and sheets. The format is:
  
  Revit Sheet: Sheet Name or Revit View: View Type-View Name

When exporting multiple files, for File Name, enter a common prefix for the exported files. For example, if you are exporting the Level 1 floor plan and north elevation views to DWG files and you enter the prefix Country House, the resulting exported file names are Country House Elevation North.dwg and Country House Floor Plan Level 1.dwg.

---

**Exporting Part of a 2D View**

To export part of a 2D view, copy the view and use a crop region to show the desired portion, as described in the following procedure. Then export the view to the appropriate format.

**To create a duplicate view**

1. In the Project Browser, right-click the view to export, and click Duplicate View ▶ Duplicate or Duplicate with Detailing.
   
   The Duplicate tool copies the view. The Duplicate with Detailing tool copies the view and includes view-specific elements, such as detail components and dimensions.
   
   The duplicate view displays in the drawing area. In the Project Browser, the duplicate view is named Copy of <View Name>.

2. Rename the duplicate view: in the Project Browser, right-click the duplicate view, and click Rename. Enter a new name, and click OK.
Add a crop region

3 On the View Control Bar, click (Show Crop Region).
In the drawing area, the crop region appears as a box around the view.

4 To crop the view to show the desired portion, click the crop region box, and drag the handles.
You may need to zoom out to see the borders and handles of the crop region box.

Export the 2D view defined by the crop box

5 Click ➤ Export, and select an export option. See Export on page 1105.

Exporting Part of a 3D View

To export part of a 3D view, use a section box to define the part of the 3D view to export. By applying a section box, you are limiting the amount of the model that is exported. Elements that are completely outside the section box are not included in the export file.

The section box is particularly useful for large models. For example, for an interior rendering of a conference room in an office building, use a section box to export the conference room and omit the rest of the building.

NOTE For 3D views, crop region boundaries are not exported, so you cannot use crop regions to limit model geometry. Instead, use section boxes as described here. (You can, however, use crop regions to export part of a 2D view.)

To create a duplicate view

1 In the Project Browser, right-click the 3D view to export, and click Duplicate View ➤ Duplicate.
The duplicate view displays in the drawing area. In the Project Browser, the duplicate view is named Copy of <View Name>.

2 Rename the duplicate view: in the Project Browser, right-click the duplicate view, and click Rename. Enter a new name, and click OK.
This is the 3D view that you will export. Saving the view allows you to easily export it again later if you make revisions to the model.

Add a section box

3 On the Properties palette, under Extents, select Section Box, and click Apply.
The section box displays in the drawing area.

4 Select the section box to see its handles. Drag the handles to change the shape and size of the box.
It may be easier to control the size, shape, and position of the section box from another view (such as a floor plan), as follows:
   a With the section box still selected in 3D, open a floor plan view.
   b Drag the section box handles to change its size and shape.

5 Return to the 3D view and make any further adjustments required.
6 Hide the section box so that it does not appear in the exported file:
   a Click View tab ➤ Graphics panel ➤ (Visibility/Graphic).
b In the Visibility/Graphics dialog, click the Annotation Categories tab.

c Clear the check box for Section Boxes, and click OK.

Export the 3D view defined by the section box

7 Click ➤ Export, and select an export option. See Export on page 1105.

For more information about section boxes, see Change the Extents of a 3D View on page 762.

Exporting Intersecting Geometry

If the model includes intersecting geometry (such as an extrusion passing through a wall surface), Revit Structure does not create new edges along the lines of the intersection. As a result, Revit Structure may incorrectly remove hidden lines during export. If you export a view of the design with hidden lines turned on, you may see unexpected results when you open the view in another CAD application. See Hidden Line Visual Style on page 869.

To see all visible lines, create an opening in one surface before passing another surface through it, or join geometry to create an edge.

Intersected wall and extrusion in hidden line mode (no edges at the intersection of the surfaces)

Exporting to DWF Format

DWF™ is the Autodesk method of publishing design data. It offers an alternative to printing to PDF (Portable Document Format).

DWF files let you share design information securely and easily. Using the DWF format, you can avoid unintended changes to project files, and you can share project files with clients and others who do not have Revit Structure. DWF files are significantly smaller than the original RVT files, making them easy to send by electronic mail or post to a web site.

DWF files can be viewed by recipients using Autodesk® Design Review, which is available for free download from http://www.autodesk.com/designreview.

About DWFx

The meaning of the term DWF has expanded to include DWFx. DWFx is based on the XML Paper Specification (XPS) from Microsoft, making it easier to share design data with reviewers who do not have Design Review installed. DWF and DWFx files contain the same data (2D and 3D); the only difference is the file format.

DWFx files can be opened and printed using the free Microsoft XPS Viewer, which comes pre-installed on computers using the Microsoft Windows Vista™ operating system. (For the Windows XP operating system, the Microsoft XPS Viewer can be downloaded directly from Microsoft.) Unlike DWF files, DWFx files include additional information to display design data in the Microsoft XPS Viewer. As a result, DWFx files are larger than corresponding DWF files.
Currently, the Microsoft XPS Viewer does not support views containing 3D content, password-protected content, restricted content, or georeferenced map coordinates. In the Microsoft XPS Viewer, when attempting to open views containing any of these unsupported features, a warning directs you to view the DWFx file in Design Review.

**NOTE** All references to DWF in this documentation implicitly include DWFx, unless specified otherwise.

---

### 2D DWF Files

You can export all Revit views or sheets to 2D DWF files. If you export multiple views in a project to one DWF, in Autodesk Design Review you can click a link to jump to a related view.

### 3D DWF Files

You can export 3D views to 3D DWF files. Using Autodesk Design Review, you can open a 3D DWF file and manipulate the 3D representation of the building. You can rotate the building, zoom in on a portion of it, select an element (such as a roof), make it transparent to see what is beneath or behind it, and so on.

**NOTE** Although most lines are exported to 3D DWF files, hatch lines are not exported.

---

### Object Data and Exported 2D or 3D DWF Files

When you export to 2D or 3D DWF, a unique, consistent ID is generated for each object. This ID consists of the GUID (Globally Unique Identifier) and the element ID. This ID scheme virtually eliminates duplicate element IDs when DWF files are merged from multiple sources outside Revit Structure.

When you export object data to 2D DWF, any property with an assigned unit of measurement exports user-visible and invisible information. This information is available when you import 2D DWF into Autodesk® FMDesktop™. User-visible information consists of formatted values. Invisible information consists of 2 additional fields: an unformatted, raw value, and a field that describes the unit type or data type.

---

### Viewing Object Data in a DWF file

When viewing a DWF file, you can access information (object data) about elements in the design.

---

Revit Structure automatically includes object data for elements in 3D DWF files. To include this element-specific information in a 2D DWF file, you must do the following:

- Ensure that the **visual style** for selected views is set to Hidden Line or Wireframe.
When exported to DWF, views set to Shaded or Shaded with Edges use raster processing for images, so you cannot select individual elements in the DWF file.

■ When exporting to DWF, select the option to export object data for Element properties.

### Exporting to DWF

1. Click ➤ Export ➤ (DWF/DWFx).
2. In the DWF Export Settings dialog, determine which views and sheets are to be exported to the DWF file.
   - If you are exporting a single view, select Current View/Sheet Only from the Export list on the View/Sheet Set tab.
   - If you are exporting multiple views and sheets:
     a. On the View/Sheet Set tab, for Export, select In session view/sheet set.
     b. Select the views and sheets to export. See Creating View and Sheet Sets on page 1110 and Selecting Views to Print on page 1150.
3. On the DWF Properties tab, specify export options.
4. To edit or add project related metadata, click the Project Information tab. If this information is changed, the data is saved to the exported DWF files and the project. See Project Information on page 1565.
5. Click Next.
6. To save the current export settings and close the dialog without exporting, click Save Settings.

### NOTE
- In the Export DWF dialog, navigate to the target folder for the exported files.
- For Files of type, select DWF or DWFx.
- For Naming, select Manual (Specify file name), Automatic - Long (Specify prefix), or Automatic - Short to define the file name.
- Click OK.

Revit Structure exports the selected views and sheets to DWF files and places them in the target folder.
Exporting to DWF Options

When exporting to DWF format, you use the DWF Properties tab on the DWF Export Settings dialog to specify various options.

Export Object Data

Specify the object data to export to the DWF file:

- **Element properties.** Exports the instance and type properties of the objects in the exported views.
- **Rooms and Areas in a separate boundary layer.** Exports the room and area properties to a layer separate from the geometric representation. With this option, you can view individual rooms and room data when you are exporting a project or a view for use with facility management software (such as Autodesk® FMDesktop), or DWF markup software (such as Autodesk® Design Review).

You can export object data only for views whose visual style is set to Wireframe or Hidden Line. See Viewing Object Data in a DWF file on page 1121.

Graphics Settings

Select either of the following graphic formats for the export of images:

- **Use standard format.** This default setting exports images as PNG files.
- **Use compressed raster format.** Exports images using a compressed JPG format. Limiting image quality reduces image file size in most cases.

Print Setup

The Print Setup Name displays the name of the current Revit DWF Exporter settings. Click the Print Setup button to modify settings. See Print Setup on page 1147.

Linking DWF Markups

When creating construction documents, a typical workflow is to print out a sheet, have it reviewed and marked up by the project architect or other professional, and then return it to the originator of the sheet to have the requested changes made.

Revit Structure enhances this process by allowing you to export sheet views as DWF files. The DWF files can be marked up electronically using a program such as Autodesk® Design Review. Then the markups can be linked back into Revit Structure to see the desired changes. Because they are linked, the Revit Structure file and the DWF file remain synchronized with regard to the markups.


The following steps outline the process for handing off the Revit Structure sheet view, marking it up, and then bringing it back into Revit Structure. This process is often referred to as round-tripping.

**NOTE** To use the markup functionality, you must export Revit Structure sheet views. See Sheets on page 978.

To link DWF markups

1. In Revit Structure, open a sheet view and export it to DWF by clicking ➤ Export ➤ (DWF/DWFx). See Exporting to DWF on page 1122.
2. Use a DWF-compatible program (such as Autodesk® Design Review) to mark up the DWF file.
When you mark up the DWF file, you are marking on top of the plotted views from Revit Structure, as if you used a red marker on a printout. After you have marked up the DWF, you can link it back into Revit Structure.

**Link the markups in Revit Structure**

3 Return to Revit Structure.

4 Click Insert tab ➤ Link panel ➤ (DWF Markup).

5 In the Import/Link DWF File dialog, navigate to the marked-up DWF file, select it, and click Open.

   The Link Markup Page to Revit Sheets dialog displays. The DWF View column displays the sheet view names that are marked up in the DWF file. The Revit View column displays the corresponding sheet view. If the sheet name from the DWF file is the same as the sheet name from the Revit Structure file, then the Revit Structure sheet name is automatically filled in the Revit View column.

   If the Revit Structure sheet view name has changed since it was exported to DWF, the Revit View column displays <Not linked> next to the DWF sheet view.

6 If the Revit View value is <Not linked>, select a Revit Structure sheet view. (Click the box below the Revit View column, and select a name from the list.)

   **NOTE** You might also do this if you have several other sheet views in the Revit Structure file, and you want to apply the markups to one of the other sheet views. This would make sense only if the other sheet view title blocks were the same size as the original.

7 Click OK.

   The DWF markups are placed on the sheet view as an import symbol. The markups are pinned, which means that you cannot modify their position, and you cannot copy, rotate, mirror, delete, or group them.

   If markups were created in Design Review using its markup tools, then you can modify some markup properties in Revit Structure.

**Change status and add notes for markup**

8 Select a markup object that was created in Design Review.

   A markup object might look as follows.

   ![Markup Object]

9 On the Properties palette, modify the Status and Notes properties if desired.

10 Click Apply.

11 Save the Revit Structure file.

The changes are saved to the linked DWF file. The changes can be viewed in the DWF file by selecting the corresponding markup object.
Managing DWF Markup Links

1 Click Manage tab ➤ Manage Project panel ➤ (Manage Links).

2 In the Manage Links dialog, click the DWF Markups tab.
   The tab lists all the linked, marked-up DWF files.

3 Select a linked DWF file.

4 Click Save Markups.
   The next time the DWF file is opened, it will contain the changes to the markup objects.

5 Click Located In to see the sheet view to which the DWF file is linked.
   Other tools on this tab work similarly to the tools on the other Manage Links tabs. For more information, see Managing Links on page 1203.

Exporting Layers

When exporting a project to another format (such as DWG or DGN), you want the exported file to contain as much information about the project as possible. Revit Structure stores a wealth of project information in its categories and subcategories. In CAD software, this type of information is stored in layers (or levels in MicroStation). To ensure that information about Revit categories is properly converted to CAD layer names, use the Export Layers tool to define a layer mapping file.

The layer mapping file is a text file that maps each Revit category or subcategory to a preconfigured layer name for the CAD software. For example, a Revit door object automatically maps to A-DOOR layer in AutoCAD. The layer names are preconfigured in the text file, but you can change them.

You can load an existing layer mapping file and manually change values for it, or you can generate a file using any of the following mapping standards:

- American Institute of Architects (AIA)
- ISO standard 13567
- Singapore standard 83
- British standard 1192

When you use the Export Layers tool to generate a layer mapping file, by default the file is named as follows: exportlayers-<format>-<standard>.txt

where <format> is DWG or DGN (to indicate the selected export format), and <standard> reflects the selected Export Layers standard (such as AIA or BS1192).

The layer mapping file resides in C:\Documents and Settings\All Users\Application Data\Autodesk\<product>. (For Windows® Vista and Windows 7, the layer mapping file location is C:\ProgramData\Autodesk\<product>.) When you export a project, its layer mapping file is exported (along with the project) into the appropriate format for the target CAD program.

Creating or Modifying a Layer Mapping File

1 Click ➤ Export ➤ Options ➤ (Export Layers DWG/DXF) (for AutoCAD) or (Export Layers DGN) (for MicroStation).
In the Export Layers dialog, Revit Structure displays values from a layer mapping file, using the appropriate standard for the current locale.

2 To use a different standard or edit an existing mapping file:
   - To load an existing mapping file, click Load, navigate to the file, and click Open.
   - To create a new mapping file, click Standard, and select a standard from the dialog.

3 Edit mapping values as desired.
   To change a Projection or Cut value, click in the Layer Name or Color ID column for the appropriate category, and enter the new value.

   **NOTE** Color ID corresponds to an AutoCAD or MicroStation color ID. For Export Layers DGN, the columns are labeled Level Number (corresponding to MicroStation levels, instead of AutoCAD layers) and Color ID.

4 To save the settings:
   - To save the settings in a new layer mapping file, click Save As, navigate to the target folder, and enter a new file name.
   - To save the changed settings in the existing layer mapping file (whose file name appears in the dialog’s title bar), click OK.

When exporting a project from Revit Structure, you specify the layer mapping file to use on the <Format> Properties tab of the Export dialog. See Exporting to CAD Format Properties on page 1113.

**Related topics**
- Exporting Layers on page 1125
- Custom Layer Mapping Files on page 1126
- Exporting to CAD Formats on page 1105

**Custom Layer Mapping Files**

You can use the Export Layers tool to create a layer mapping file for various consultant office standards. To create a custom layer mapping file, follow the procedure in Creating or Modifying a Layer Mapping File on page 1125, and use the ➤ Save As feature to save the file with a unique name.

**Exporting to ODBC**

You can export model component data to an ODBC (Open Database Connectivity) database. The exported data can include project parameters that have been assigned to one or more element categories in the project. For each element category, Revit Structure exports a database table for model types and another table for model instances. For example, Revit Structure creates a table listing all structural column types and another table listing all structural column instances.

ODBC export uses metric units only. If a project uses Imperial units, Revit Structure converts all measurements to metric units before exporting to ODBC. When you use data from the resulting database, remember that the measurements reflect metric units. Use a database function to convert the measurements back to Imperial units if necessary.
Using ODBC, Revit Structure creates tables for the following elements:

- Model Objects: Types and Instances
- Levels and Rooms: Instances only
- Key Schedules
- Assembly Codes: A single table containing assembly code data for the entire project

ODBC export creates specific relationships between tables in the database using primary keys and reference values. See Table Relationships Within the Database on page 1129.

Revit Structure can export to the same database multiple times. When exporting to an empty database, Revit Structure creates new tables. When you export a project to a populated database, Revit Structure updates table information to match the project. This allows you to customize the database and re-export data as the project changes.

**IMPORTANT** Do not export different projects to the same database. Use a unique database for each project.

**Supported ODBC Drivers**

ODBC is a general export tool that works in conjunction with many software drivers. Revit Structure has been tested with the following ODBC drivers:

- Microsoft® Access
- Microsoft® Excel
  - An ODBC export to Excel creates one table per worksheet.
  - You can export to an Excel file only once. Multiple exports to Excel are not supported.
- Microsoft® SQL Server
  - The Microsoft® Text Driver is not supported by Revit Structure.

Revit Structure may be able to work with other ODBC drivers, depending on the features supported by the driver. If you need assistance with a particular software driver, contact your local IT department or Autodesk Product Support.

**Exporting to an ODBC Database**

The first time that you export a Revit project to an ODBC database, use the following procedure. If you have already exported the project and want to re-export it, see Exporting Multiple Times to the Same ODBC Database on page 1128.

**To export to an ODBC database**

1. In Revit Structure, open the project to export.
2. Click ➤ Export ➤ (ODBC Database).
3. In the Select Data Source dialog, click New to create a new Data Source Name (DSN).
4. In the Create New Data Source dialog:
   - Select a driver, and click Next.
This driver is associated with the software program you export to (for example, Microsoft® Access, dBase, or Paradox).

b Enter a DSN name, or navigate to the target folder and specify a file name. Click Next.
c A confirmation dialog displays. If any information is incorrect, click Back and correct it.
d Click Finish.

5 Create the database file.
Depending on the driver selected, a dialog displays, requesting information about the database file to which you’re exporting. Use the dialog to specify the database to use or to create a new one. For example:
- For Microsoft® Access, click Select to select an existing database, or click Create to create a new, empty database to export data to.
- For Microsoft® Excel, first use Excel to create a new, empty workbook with the desired name. Then on the dialog, click Select Workbook, and navigate to the new workbook.

6 In the Select Data Source dialog, click OK.
7 In the ODBC Setup dialog, click OK.

NOTE If the export fails with an error regarding a read-only database, click Options in the ODBC Microsoft Setup dialog. Clear the Read Only check box. Then try the export again.

Related topics
- Exporting to ODBC on page 1126
- Supported ODBC Drivers on page 1127
- Editing the Database After Export on page 1128
- Table Relationships Within the Database on page 1129

Exporting Multiple Times to the Same ODBC Database
1 In Revit Structure, open the project to export.

2 Click ➤ Export ➤ (ODBC Database).
3 In the Select Data Source dialog, select the desired data source, and click OK.
4 In the ODBC Setup dialog, click OK to export to the same database.

Editing the Database After Export
Do not edit data in the database columns exported by Revit Structure. Any changes to those columns are overwritten the next time the project is exported.
However, you can add columns to the tables created by Revit Structure. The next time the project is exported, any data in the added columns is preserved.
Table Relationships Within the Database

When Revit Structure creates database tables during ODBC export, it adds relationships to the data tables using primary keys and reference values. In relational databases, a primary key is a unique value that identifies a record (row) in a table of the database. Reference values are columns in a table that refer to other tables.

**NOTE** Database programs (such as Microsoft® Access) can interpret the table relationships. In spreadsheet programs like Microsoft® Excel, relationships are not supported, so Revit Structure creates simple, unrelated tables.

The primary key in each element table is the column labeled “Id”. The following table illustrates how primary keys and reference values create relationships among tables in the database.

<table>
<thead>
<tr>
<th>Column (Field) of a Structural Column Instance Table</th>
<th>Corresponds to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>None. This is the unique identifier for this instance of a structural column.</td>
</tr>
<tr>
<td>Type Id</td>
<td>Id column of the structural column Types table</td>
</tr>
<tr>
<td>Level</td>
<td>Id column of the Levels table</td>
</tr>
<tr>
<td>Room</td>
<td>Id column of the Rooms table</td>
</tr>
<tr>
<td>Key schedule</td>
<td>Id column of the Key Schedules table</td>
</tr>
</tbody>
</table>

The primary key in the Assembly Codes table is the Assembly Code column. The Assembly Code column in type tables references the Assembly Code column in the Assembly Codes table.

Revit Structure does not create a reference for the Host Id column because the host may be a wall, floor, roof, or other such host, so there is no unique table to reference.

The relationships between tables are established only when Revit Structure first creates the tables; if you use Revit Structure to re-export to an existing database, no new relationships are created.

Exporting a View to an Image File

When you export an image, Revit Structure prints any view directly to a raster image file. You can then use this image for online presentations or printed materials.

To export a view to an image file

1. Click ➤ Export ➤ Images and Animations ➤ ![Image](Image).
2. In the Export Image dialog, click Change to change the default path and file name for the image, if desired.
3. Under Export Range, indicate the images to export:
   - **Current window**. This option exports the entire contents of the drawing area, including parts that are outside the current viewing area.
   - **Visible portion of current window**. This option exports whatever is currently visible in the drawing area.
   - **Selected views/sheets**. This option exports the specified sheets and views. Click Select. In the View/Sheet Set dialog, select the views and sheets to export, and click OK.

Exporting a View to an Image File | 1129
Under Image Size, specify image display properties:

- To specify a print size and orientation for the image, select Fit To and enter a pixel value. For Direction, select Horizontal or Vertical. Revit Structure fits the image horizontally or vertically into the specified number of pixels.

- To magnify or reduce the image, select Zoom To and enter a percentage. Revit Structure prints the image at the specified zoom setting.

Under Options, select the desired print options:

- By default, links in the exported image display in black. To display blue links, select View Links in Blue.

- To hide unwanted parts of the drawing in the exported view, select any of the following: Hide Ref/Work Planes, Hide Scope Boxes, Hide Crop Boundaries, and Hide Unreferenced View Tags.

Under Format, select an output format for shaded views and non-shaded views. If you specified a Zoom To percentage for Image Size, select a DPI (dots per inch) value for Raster Image Quality.

Click OK.

The selected sheets or views are exported as images in the specified file.

Exporting Project Views to HTML

You can create a web page that links HTML versions of views and sheets in a Revit project.

To export project views to HTML

1 Click Export Images and Animations (Image).
2 In the Export Image dialog, under Export Range, select Selected Views/Sheets.
3 Click Select.
4 In the View/Sheet Set dialog, select the views and sheets to export, and click OK.
5 Under Output:

- For Name, specify the desired path and a prefix for resulting file names.
- Select Create Browsable Web Site with a Linked HTML Page for Each View.

6 Specify Image Size, Options, and Format settings as desired.

For details about these settings, see Exporting a View to an Image File on page 1129.

7 Click OK.

Revit Structure creates a web page. From the web page, you can open the views from a table of contents. View tags are hyperlinks. For example, suppose you export the Level 1 view and the North Elevation view. In the web page, when viewing the North Elevation view, you can click the Level view tag to link to the Level 1 view.

In the folder where the web page resides, Revit Structure creates a folder containing the source HTML files and images. The folder also contains a cascading style sheet (CSS file). Edit this file to change the format of the web page.
Creating Room/Area Reports

You can create a detailed report that describes areas defined in plan views (floor plans and area plans). For a floor plan, Revit Structure generates a room report. For an area plan, Revit Structure generates an area report. These reports contain information about all rooms or areas with floors on the corresponding level. Each report is generated as an HTML file.

When creating a room/area report, you can choose from the following formats:

- **Revit room area triangulation report.** For each room or area in the selected plan, the report contains images of room boundaries or area boundaries, which are triangulated and annotated. Following each image, a table shows calculations for the triangulated areas, as well as total room area and total window area.

- **Revit room area numerical integration report.** For each room or area in the selected plan, the report contains a table that lists segments, sub-areas, and their dimensions. Each table is followed by the total room area and total window area.

You can create triangulation reports that exclude areas bounded by multiple curve loops (such as a room with columns or closets in the middle). When a room/area report excludes these areas, triangulation is performed, reported, and displayed separately for each bounding loop. (This option only applies to Revit room area triangulation reports; it is ignored for Revit room area numerical integration reports.)

This functionality is primarily intended for European users.

**NOTE** This feature is primarily intended for Revit Architecture and Revit MEP users.

Exporting a View as a Room/Area Report

1. Click ➤ Export ➤ Reports ➤ (Room/Area Report).
2. In the Export Room Area Report dialog, for Files of Type, select the type of report to create: triangulation or numerical integration.
3. If you are exporting a single view:
   a. Under Range, select Current View.

   **NOTE** If you have a 3D view currently displayed in the drawing area, the Current View option will not be available.

   b. If the current view is a floor plan or an area plan, the File Name text box displays a default file name. If desired, change the file name, and navigate to a target folder.

4. If you are exporting multiple views:
   a. Under Range, click Select Views.
   b. In the Views dialog, select the views to export, and click OK.
   c. For File Name, enter a prefix for the names of the exported files.

5. Click Options.
6. In the Area Report Settings dialog:
   a. If desired, change settings for text format, label prefixes for triangles and arc sectors, line colors, unit format, and image sizes.
For a triangulation report, select Use Triangulation with Exclusions if you want to exclude areas bounded by multiple curve loops. (This setting has no effect for numerical integration reports.)

c To report window area as a percentage of total area, select Report Window Area as a Percentage of Room Area. By default, the report calculates the total window area.

d Click OK.

7 Click Save.

Revit Structure generates the report as an HTML file and places it in the target folder.

Related topics
- Creating Room/Area Reports on page 1131
- Rooms and Areas on page 711

Exporting to Industry Foundation Classes (IFC)

You can export Revit building modeling information to the Industry Foundation Classes (IFC) file format.

About the IFC File Format

The Industry Foundation Classes (IFC) file format was developed by the International Alliance of Interoperability (IAI). IFC provides an interoperability solution between different software applications. The format establishes international standards to import and export building objects and their properties.

IFC improves communication, productivity, delivery time, and quality throughout the life cycle of a building. It reduces the loss of information during transmission from one application to another, with established standards for common objects in the building industry.

For more information about the IFC file format, visit http://www.iai-international.org.

Revit Structure and IFC

Revit Structure provides IFC import and fully certified export based on the latest IAI IFC2x3 data exchange standard. When you export a Revit building information model to IFC format, the information can be used directly by other building specialists, such as structural and building services engineers.

For example, building information models developed with Revit Structure are saved to the RVT file format. You can export the building model using the IFC format to an IFC-certified application that does not use the RVT file format. The drawing can be opened and worked on in the non-native application. Similarly, in Revit Structure you can import an IFC file, create a RVT file, and work on the building model in Revit Structure.

IFC uses architecturally meaningful containers to describe real-world building objects. Those containers include parameters that have meaningful values. Many standard Revit elements have corresponding IFC containers. These do not require any specific user action to export them. (For example, Revit walls export as IFCwalls.) Other Revit families (such as escalators) require that you map them to IFC containers before exporting. See Loading and Modifying an IFC Mapping File on page 1133.

Revit Structure makes available the following IFC-specific files to assist you:

- IFC Metric Template.rte. This file allows you to create new projects that are already set to the IFC standard.
- IFC Parameter Upgrade.rvt. This file enables you to upgrade an existing project to contain IFC parameters by reading the instructions contained in the IFC Parameter Upgrade.rvt file.
IFC Shared Parameters.txt. This file contains the shared IFC parameters if you want to manually update an existing project to contain all or some of these parameters.

**NOTE** It is recommended to use the IFC Parameter Upgrade.rvt file instead, for performance reasons.

See **IFC-Specific Files** on page 1136 for more information about these files.

**Related topic**

- **Opening Industry Foundation Class (IFC) Files** on page 70

### Supported IFC Classes

Before exporting a Revit project to IFC, make sure that Revit Structure supports the desired IFC classes. To see a complete list of classes, use the following procedure.

**To see a list of supported IFC classes**

1. Click ➤ Export ➤ Options ➤ IFC Options.
2. In the IFC Export Classes dialog, click Standard.

The IFC Class Name column lists the supported IFC classes.

### Loading and Modifying an IFC Mapping File

Before exporting a Revit project to IFC, you may need to map generic family instances to IFC containers (element types). You do this by creating a new IFC mapping file or editing an existing one. Also, you can use the following procedure to load the desired IFC mapping file before exporting a Revit project to IFC.

**To load and modify an IFC mapping file**

1. Click ➤ Export ➤ Options ➤ (IFC Options).
2. In the IFC Export Classes dialog:
   - To create a new IFC mapping file based on the IAI standard, click Standard. Revit Structure creates an IFC mapping file named exportlayers-ifc-IAI.txt.
   - To load an existing IFC mapping file, click Load, navigate to the file, and click Open.

Each row in the dialog represents an element category or subcategory. For standard building elements, an assigned class name appears in the IFC Class Name column. For building elements that do not have automatic mapping to IFC export classes, “Not Exported” appears in the IFC Class Name column.

3. For each category or subcategory to export:
   - For IFC Class Name, enter the name of the IFC class for the particular category/sub-category pair.
   - For Type, enter the type of object within that subclass.

Appropriate values are set according to the IFC standard definition. Selecting Not Exported prevents elements of that category or sub-category from being exported.
If the values for a category or subcategory are blank, Revit Structure will try to determine the appropriate category. If it cannot make a match and the object has geometry, it is exported as a proxy object.

4 To save the settings:
   ■ To save the settings in a new IFC mapping file, click Save As, navigate to a target folder, and enter a new file name. Click OK.
   ■ To save the changed settings in the existing IFC mapping file (whose file name appears in the dialog’s title bar), click OK.

When you export a Revit project to IFC, Revit Structure automatically uses the appropriate IFC mapping file.

**Exporting a Project to IFC**

1 Load the IFC mapping file that you want to use for the export to IFC.
   See Loading and Modifying an IFC Mapping File on page 1133. You can also use this procedure to modify the mapping file or to map non-standard Revit Structure families to IFC containers.

2 Click ➤ Export ➤ (IFC).

3 In the Export IFC dialog, for Save In, navigate to the target folder for the IFC file.

4 For Files of Type, select the desired file type:
   ■ IFC 2x2 (*.ifc)
   ■ IFC 2x3 (*.ifc): This is the default certified version of export, and the latest version generally supported by other systems.
   ■ IFC BCA ePlan Check (*.ifc): This is a certified variant of IFC 2x2 used for submitting files to the Singapore BCA ePlan Check Server. When exporting to this file type, you should make sure that all room-bounding elements are selected.

5 Select export options:
   ■ **Current view only** allows you to export elements that are visible in the current view. Visible elements include those that are hidden by hidden line or shaded mode, any underlays in the view, and elements that are cropped from view by the crop region. Elements temporarily hidden using temporary hide/isolate will not be exported. Categories marked as Not Exported in the IFC Export Classes dialog will not be exported. See Loading and Modifying an IFC Mapping File on page 1133.
   ■ **Split walls and columns by level** allows you to divide multi-level walls and columns by level.
   ■ **Export base quantities** includes base quantities for model elements in the export data. Base quantities are generated from model geometry to reflect actual physical quantity values, independent of measurement rules or methods.

6 For File Name, enter a name for the IFC file.

7 Click Save.

**Related topics**

■ Exporting to Industry Foundation Classes (IFC) on page 1132
■ Supported IFC Classes on page 1133
■ Specifying IFC Entities for Families on page 1135
Specifying IFC Entities for Families

Revit Structure exports building elements to an IFC file based on the categories (and subcategories) to which the elements belong. For example, Revit Structure exports a wall to the IFC entity IfcWallStandardCase, because the wall is an element from the wall category. In many cases, exporting elements from Revit Structure to IFC is straightforward and simple, and the default settings make sense.

In some cases, however, you may want to specify the IFC entity to which elements from a particular family should belong. For example, suppose you design an escalator family. It belongs to the Generic Model category, and you create for it a subcategory called Escalator. You want to ensure that when you export a project to IFC, an escalator is properly (and automatically) mapped to the class IfcTransportElement and the type IfcTransportElementType.

To map a family to an IFC entity

1. Create shared parameters named IFCExportAs and IFCExportType. See Shared Parameters on page 1541.
   Save these shared parameters to a file that resides in a network location, so that you can add the parameters to other families and projects. You can also use the shared parameter file that Revit Structure makes available (IFC Shared Parameters.txt). See IFC-Specific Files on page 1136 for information on how to access this file.
   For example, in a folder where you store other corporate standard files, create a parameter file named IFCexportParameters.txt. You only need to create these shared parameters once. You can reuse them in multiple families.

2. Use the Family Editor to create a new family or to modify an existing family. See Revit Families on page 677.

Add the shared parameters to the family

3. In the Family Editor, click Home tab ➤ Properties panel ➤ (Family Types).
4. In the Family Types dialog, for Name, select a family type.
5. Under Parameters, click Add.
6. In the Parameter Properties dialog, under Parameter Type, click Shared parameter, and click Select.
7. Navigate to the shared parameters file that defines IFCExportAs and IFCExportType (for example, IFCexportParameters.txt), and open the file.
8. In the Shared Parameters dialog, under Parameters, select IFCExportAs, and click OK.
9. In the Parameter Properties dialog, under Parameter Data, for Group parameter under, select IFC Parameters.
10. Make sure that Type is selected, and click OK.
   In the Family Types dialog, IFCExportAs displays in the parameter list.
11. Under Parameters, click Add.
12. In the Parameter Properties dialog, under Parameter Type, click Shared parameter, and click Select.
13. In the Shared Parameters dialog, under Parameters, select IFCExportType, and click OK.
14. In the Parameter Properties dialog, under Parameter Data, for Group parameter under, select IFC Parameters.
15 Make sure that Type is selected, and click OK. In the Family Types dialog, IFCExportType appears in the parameter list.

**Specify values for IFCExportAs and IFCExportType**

When you add the shared parameters to one family type, Revit Structure automatically adds them to all types in that family. Next, you can specify values for each parameter in each family type.

16 In the Family Types dialog:
   a For Name, select a family type.
   b For IFCExportAs, specify the desired IFC class.
   c For IFCExportType, specify the desired IFC type.
   d Click Apply.

17 Repeat Step 16 for each of the remaining types in this family.

18 When you have defined values for all family types, click OK.

19 Save changes to the family.

20 If you want to load the updated family into a project, open the project. Then return to the Family Editor, and click Home tab ➤ Family Editor panel ➤ (Load into Project).

**Check parameter values in a project (optional)**

You can verify the IFC export parameter values assigned to an element in a project.

21 In the project, select an element that belongs to a family to which you added the shared parameters IFCExportAs and IFCExportType.

22 On the Properties palette, click (Edit Type).

23 In the Type Properties dialog, scroll down to the IFC Parameters group. The IFCExportAs and IFCExportType parameters display the values that you specified for the family type. When you export the project to IFC, elements in this family will be mapped to the specified IFC class and type.

**IFC-Specific Files**

Revit Structure makes available the following IFC-specific files:

- **IFC Metric Template.rte.** This file allows you to create new projects that are already set to the IFC standard.
- **IFC Parameter Upgrade.rvt.** This file enables you to upgrade an existing project to contain IFC parameters by reading the instructions contained in the IFC Parameter Upgrade.rvt file.
- **IFC Shared Parameters.txt.** This file contains the shared IFC parameters if you want to manually update an existing project to contain all or some of these parameters.

**NOTE** It is recommended to use the IFC Parameter Upgrade.rvt file instead, for performance reasons.

To access the IFC-specific files

2 Click Revit Instruction & Help Samples.
3 Click IFC.
   The web page displays a list of the available IFC files.
4 To download the IFC files, click Download Directory. On the File Download dialog, click Save, and navigate to the target folder.
5 In Windows Explorer, navigate to the target folder, and double-click IFC.exe to extract the downloaded files.

The downloaded files include parameter upgrade instructions.

Exporting Your Design to gbXML

After you have placed room components in all the areas in a plan, you can export your design as a gbXML file and use a third-party load analysis software application to perform a load analysis.

NOTE The gbXML file contains all of the heating and cooling information for a project according to the gbXML file structure which is based on a gbXML schema. The gbXML schema was created to help building designers get information about the energy consumption characteristics of their building projects. Refer to gbXML Schema Support on page 1685 for more information about gbXML elements and attributes that are supported by Revit Structure. You can also visit http://www.gbxml.org for more information about the gbXML schema.

1 Click ➤ Export ➤ gbXML.
   If asked to turn on the Areas and Volumes setting, click Yes.

Examine the volume in the analytical model

2 In the Export gbXML dialog, click the Details tab.
3 In the right pane, expand the Building Model, levels and rooms.

TIP You can right-click a level to expand all or select all rooms on the level.

4 If warnings display for the building, a level, or a room, select the item, and click (Show Related Warnings) to learn the cause. Then cancel the Export gbXML dialog and correct the problem in the building model. Review and correct warnings until all of the warnings have been resolved throughout the model.

5 In the preview of the Export gbXML dialog, zoom in, pan and spin the analytical model to examine the volume for the rooms in the building.
   An effective energy analysis can only be performed if the entire volume of the building model is included in exported data. Color should completely fill the volume for all of the rooms in the model. If you detect rooms without fill, you should cancel the Export gbXML dialog, and resolve the unshaded areas. When areas are too small to place a room, merge the volume for cavities, shafts, and chases with a tangent room.

NOTE Sliver spaces display (as shaded) in the analytical model. Sliver spaces do not display in plan or section views.

6 On the Details tab, specify energy data as needed.

Examine analytical surfaces

7 In the preview of the Export gbXML dialog, on the Details tab, click Analytical Surfaces, and expand the levels and rooms in the building model.
The hierarchy expands to display Roofs, Interior and Exterior Walls, Floors and Slabs, Windows, Doors and Openings. These can be further expanded to display the individual surfaces and openings for a room. See Surface Element on page 1691 for information about surface and opening names.

**TIP** You can right-click a level to expand all or select all spaces in the zone.

8 In one of the rooms, select a surface type (for example, Interior Walls), and click \(\text{(Isolate)}\). You can also select individual surfaces from within the surface type folder for a room.

9 Zoom in, pan, and spin the analytical model as needed to examine all surfaces in the model, checking to be sure that each surface is correctly identified.

If you detect surfaces that are incorrectly identified, you must cancel the gbXML Export dialog, and fix the problem in the building model.

10 If you are satisfied with the integrity of the analytical model, click Next.

11 In the Export gbXML dialog, navigate to a folder where you want to save the gbXML file.

12 Enter a name for the gbXML file, and click Save.

---

**Function of Walls, Floors, and Building Pads**

When you export analytical surfaces to gbXML, the Function type parameter affects walls, floors, and building pads as follows.

**Exterior surfaces**

If a wall has 2 adjacent spaces and its function is Exterior, Foundation, Retaining, or Soffit, the wall is displayed as an interior surface. If the wall has one adjacent space, it is displayed as an exterior surface.

**NOTE** If the wall is located below the ground plane, it is displayed as an underground surface, regardless of function.

**Interior surfaces**

If its function is Interior or Core Shaft, a wall is displayed as an interior surface, regardless of the number of adjacent spaces.

**Slab surfaces**

If its function is Exterior, a floor or building pad is displayed as a slab surface.

**NOTE** If a surface is located below the ground plane and is adjacent to one space and earth, the surface should be an underground surface, regardless of its function.

**Floor surfaces**

If its function is Interior, a floor or building pad is displayed as a floor surface.

**Shading surfaces**

If its function is Exterior, Foundation, Retaining, or Soffit, a wall, floor, or building pad creates shading surfaces.

If its function is Interior or Core Shaft, a wall, floor, or building pad does not create any shading surfaces.
Exporting to AutoCAD Architecture

NOTE This feature can only be used for exporting to AutoCAD Architecture 2007 and later.

You can save a 3D view of the building structure and export it to the AutoCAD DWG format.

To export DWG for AutoCAD Architecture

1. Open the 3D view of the project to export.
2. Click ➤ Export ➤ CAD Formats ➤ (DWG files).
3. In the Export CAD Formats dialog, click the DWG Properties tab.
4. For Solids (3D Views Only), select Export as AutoCAD Architecture and AutoCAD MEP Objects.
5. For Prefer:
   - If you want the exported DWG to... Then...
     - keep its structural properties intact, but not maintain geometric accuracy select AutoCAD Architecture objects.
     - maintain geometric accuracy, but not keep structural properties intact select Geometry.
6. Click Next.
7. For Save In, navigate to the target folder for the file.
8. Click OK.

The file is exported to DWG format and is ready for use with AutoCAD Architecture.

Exporting to 3ds Max

When you have completed the initial design, layout, and modeling of a project in Revit Structure, you can use Autodesk® 3ds Max® or Autodesk® 3ds Max® Design to produce high-end renderings and add final details.

- **3ds Max** is a professional 3D animation package that provides additional animation, modeling, and workflow functionality for the most complex problems in design visualization and visual effects.
- **3ds Max Design** is a 3D design visualization solution for architects, engineers, designers, and visualization specialists. It is designed for interoperability with FBX® files from Revit Structure, preserving model geometry, lights, materials, camera settings, and other metadata from a Revit project. With Revit Structure and 3ds Max Design working together, designers can extend the building information modeling process to include design visualization.

NOTE For simplicity, the following topics refer to 3ds Max, but this information also applies to 3ds Max Design.

You can export a 3D view from a Revit project to an FBX file, and import the file into 3ds Max. In 3ds Max, you can then create sophisticated renderings of the design to share with clients. The FBX file format passes rendering information to 3ds Max, including lights, render appearances, sky settings, and material assignments for the 3D view. By preserving this information during the export process, Revit Structure maintains a high degree of fidelity and reduces the amount of work required in 3ds Max.
Before Exporting a 3D View to 3ds Max

Revit Structure is designed to provide a high degree of interoperability with 3ds Max. However, you can take steps to further improve performance and ensure satisfactory results. Before exporting a 3D view from a Revit project for import to 3ds Max, use the following strategies.

**TIP** To export a 2D view, first create a 3D view that is oriented to a 2D view (such as a section view or elevation view). In a 3D view, right-click the ViewCube and click Orient to View ➤ <view type> ➤ <view name>. For details, see Specifying Camera Position in a 3D View on page 758.

Complete the Design Work in Revit Structure

To ensure that Revit Structure remains the single repository of data for the project, make all changes to the building model in the Revit project. Do not make changes to the building model in 3ds Max.

If you update the project in Revit Structure, export the 3D view to an FBX file. Then import it into 3ds Max, and regenerate the rendered image.

Limit Model Geometry

To limit the model geometry that is exported to 3ds Max, consider doing any or all of the following in the 3D view that you plan to export from Revit Structure:

- Hide elements that are not required in the view.
- Use a section box.
- Specify the detail level.

For more information about these strategies, see Limiting Model Geometry Before Exporting on page 1106.

Prepare the 3D View for Rendering

Before exporting a 3D view to FBX, apply materials to model elements, and specify the desired render appearances. See Materials on page 1573.

Also, check the placement of lights in the view, and dim or turn lights on or off to achieve the desired result. See Using Lighting Fixtures in a Building Model on page 1059 and Turning Lights On and Off on page 1070.

In addition, follow best practices for rendering to optimize the results. See Rendering Best Practices on page 1090. Before exporting to FBX to render in 3ds Max, you may want to generate an initial rendering using the native Revit rendering engine. By rendering in Revit Structure first, you can check lighting and material render appearances, and refine them as needed before exporting. See Rendering an Image on page 1076.

Read 3ds Max Documentation

Read the 3ds Max FBX Plug-In Help for information about importing Revit projects. That documentation includes suggested settings for importing Revit projects and other tips. By reading this information before exporting a Revit project, you may be able to take advantage of 3ds Max functions that will streamline the process and help you achieve the desired results faster and with less effort.
Exporting to FBX

1. In Revit Structure, open a 3D view, and prepare it for export. See Before Exporting a 3D View to 3ds Max on page 1140.

2. Click ➤ Export ➤ (FBX).

   **TIP** If FBX displays as gray, open a 3D view of the project, and then try again.

3. In the Export 3ds Max (FBX) dialog, for Save in, navigate to the target folder for the exported file.

4. For Naming, do one of the following:
   - To specify a file name manually, select Manual (Specify file name). For File name/prefix, specify the name of the output file.
   - To use an automatically generated file name, select Automatic – Long (Specify prefix), or Automatic – Short. See File Names for Exported Files on page 1118.

5. Click Save.

Revit Structure generates the FBX file and places it in the target location.

You can now import the FBX file into 3ds Max, using the 3ds Max FBX plug-in. For more information, refer to the 3ds Max Plug-in documentation.

3ds Max provides additional control over materials, beyond the capabilities of Revit Structure. To activate the Revit material assignments and lights in 3ds Max, specify mental ray® as the rendering engine. This is the default render setting for 3ds Max Design. For more information, refer to the 3ds Max documentation.

Troubleshooting Exports to 3ds Max

When you export a 3D view from Revit Structure and import it to 3ds Max, you may encounter the following issues.

**Slow performance when exporting from Revit Structure and importing to 3ds Max**

Performance may be slow for large projects that contain lots of objects and their data. To improve performance, limit the model geometry being exported. In Revit Structure you can use a section box, hide categories of model elements that you do not need for the scene, and set the detail level as appropriate. See Limiting Model Geometry Before Exporting on page 1106 and Rendering Best Practices on page 1090.

**Multiple cameras not exported to 3ds Max**

Revit Structure exports to FBX only one camera, which corresponds to the active 3D view. As a result, only the current Revit 3D view or camera will be imported into 3ds Max as a 3D camera view.

**Incorrect camera angle in 3ds Max**

**Symptom:** When you export a Revit 3D view to FBX and import it into 3ds Max, the camera angle may not reflect the angle of the Revit view.

**Issue:** 3ds Max does not support the cropping region and optical center of Revit cameras. However, the field of view (FOV) or perspective of the Revit cameras will be correct in 3ds Max. If you modify the Revit camera by resizing or offsetting the cropping region of the 3D view in Revit Structure, 3ds Max does not translate the change precisely.

**Solution:** In 3ds Max, adjust the camera angle as needed to achieve the desired result.
Publish
You publish projects to Buzzsaw (using DWG or DWF files) and families to Autodesk® Seek.

Publishing to Autodesk® Seek
From Revit Structure, you can publish families, products, or design information directly to the Autodesk Seek web site. The published item can be shared with others who are searching for manufacturer-specific or generic building products online. This process is known as Sharing with Autodesk Seek.

NOTE Autodesk Seek is currently available only in the English edition of the software.

Publishing for Manufacturers
If you are a manufacturer who wants to share content on Autodesk Seek, see the Manufacturer Home http://seek.autodesk.com/manufacturer.htm to learn how best to create and share your product content with the online design community.

NOTE Autodesk Seek is currently available only in the English edition of the software.

Preparing Content for Sharing
Before sharing content with Autodesk Seek, you need to decide:

■ Whether to assign an OmniClass code to the family.
■ Whether the family requires associated files to be included for proper display and functioning.

NOTE Autodesk Seek is currently available only in the English edition of the software.

Assigning OmniClass codes
OmniClass is a new classification system for the construction industry. The Autodesk Seek web site uses codes from OmniClass Table 23 to filter and identify shared content. A code consists of an OmniClass number and title.

If an OmniClass code is not already assigned to a family, you are prompted to assign one during the sharing process. However, you can continue to share with Autodesk Seek without defining one. All Revit families (except the System and Annotation families) have parameters for assigning an OmniClass code.

You can access the OmniClass Number and OmniClass Title parameters in the Family Category and Parameters dialog under Family Parameters. See Family Category and Parameters on page 695.

Determining how to share the family
If the family you are sharing to Autodesk Seek works correctly and has been tested, no additional setup is required. However, if the family was saved to a different location for sharing, you must ensure that Revit Structure can find any associated files needed for the proper display and functioning of the family.
Revit Structure uses the default installation paths on Windows XP and Windows Vista® to look for content as shown in the following table. Because these paths can be changed during installation, your paths might be different.

<table>
<thead>
<tr>
<th>File Type</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type catalogs (TXT) that manage parameters for families with many type variations</td>
<td>Same folder as the RFA file</td>
</tr>
<tr>
<td><strong>NOTE</strong> The type catalog must have exactly the same name as its family RFA file. The names are case-sensitive.</td>
<td></td>
</tr>
<tr>
<td>Lookup tables (CSV) that Revit MEP components use to define instance parameters</td>
<td>Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk&lt;Revit MEP release name&gt;\LookupTables</td>
</tr>
<tr>
<td></td>
<td>Windows Vista: C:\Program-Data\Autodesk&lt;Revit MEP release name&gt;\LookupTables</td>
</tr>
<tr>
<td>Image Files (BMP, JPG, JPEG, or PNG) that create a custom color, design, texture, or bump map for a render appearance</td>
<td>Folders in the Revit Render Appearance Library installed by default at:</td>
</tr>
<tr>
<td></td>
<td>Windows XP: C:\Program Files\Autodesk&lt;br&gt;Release name&gt;\Data\Rendering\assetlibrary_base.fbm</td>
</tr>
<tr>
<td></td>
<td>Windows Vista: C:\Program Files\Autodesk&lt;Revit release name&gt;\Data\Rendering\assetlibrary_base.fbm</td>
</tr>
<tr>
<td>Photometric data files (IES) for use with lighting families</td>
<td>Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk&lt;Revit release name&gt;\IES</td>
</tr>
<tr>
<td></td>
<td>Windows Vista: C:\Program-Data\Autodesk&lt;Revit release name&gt;\IES</td>
</tr>
</tbody>
</table>

### Sharing with Autodesk Seek

**NOTE** Autodesk Seek is currently available only in the English edition of the software.

1. In the Family Editor, click ➤ Publish ➤ (Share with Autodesk Seek).
2. In the Share family with Autodesk Seek dialog, specify whether to share the current family or browse for one, and click OK.

**BEST PRACTICE** Use the 3D view of the family. There should not be any dimensions, reference planes, or lines visible in the preview.
In the Set OmniClass Code dialog, specify whether to apply an OmniClass code to your family or continue with publishing.

If you select Apply an OmniClass code, the OmniClass Table 23 Product Classification dialog displays, from which you assign a code that is appropriate for your content. Select a code, click OK, and click Save to save the OmniClass code to your family.

Revit Structure displays a progress bar showing that it is packaging and then uploading the family.

After the Seek Upload Successful dialog displays, click Show details to view the list of contents published to the Autodesk Seek site.

Click Close to dismiss the dialog and open the Autodesk Seek web site in your default Web browser.

Follow the prompts on the web page to complete the Share with Autodesk Seek process.

### Publishing to Buzzsaw

Autodesk® Buzzsaw® is an online collaboration service that allows you to store, manage, and share project documents from any Internet connection, thus enhancing team productivity and reducing costs. You can use the Publish to Buzzsaw tools to export sheets and views to a DWG or DWF file, and then upload these to a Buzzsaw project site in one step. For information about DWG files, see Exporting to CAD Formats on page 1105. For information about DWF files, see Exporting to DWF Format on page 1120.

To be able to publish to Buzzsaw, the projects and folders to which you want to publish files must already exist. In addition, you must have Buzzsaw Administrator permission or Edit permission to add files to a folder. Consult your Buzzsaw administrator for details.

### Publish DWG to Buzzsaw

1. Click ➤ Publish ➤ (DWG to Buzzsaw).
2. In the Publish to Buzzsaw (DWG) dialog, determine which views and sheets are to be published in the DWG file.
   - If you are publishing a single view, select Current View/Sheet Only from the Export list on the View/Sheet Set tab.
   - If you are publishing multiple views and sheets:
     a. On the View/Sheet Set tab, for Export, select In session views/sheet set.
     b. For Show in list, specify the views and sheets to show in the list, and then select the views to publish. See Selecting Views to Print on page 1150.
3. On the DWG Properties tab, specify publishing options:
   - Layers and Properties on page 1113
   - Colors on page 1115
   - Linetype Scaling on page 1115
   - Coordinate System Basis on page 1116
   - One DWG Unit Is on page 1116
   - Text Treatment on page 1116
4 Click Publish.
5 Under Buzzsaw Sites, select the site to which you want to publish project files.
   If you need to add a new Buzzsaw location, click Add. For instructions, see Adding a New Buzzsaw Location on page 1146.
6 Enter a name, or accept the default name, for the exported file.
7 For Files of type, select an AutoCAD version of the published DWG file.
8 For Naming, select Automatic - Long (Specify prefix) or Automatic - Short to define the automatically generated file name. See File Names for Exported Files on page 1118.
9 Optionally, to prohibit Revit Structure from creating external references, clear Xref views on sheets. Any Revit or DWG links in the project are published to a single file rather than several files that reference each other.

Revit Structure generates a DWG file and posts it on the specified Buzzsaw site.

## Publish DWF to Buzzsaw

1 Click ➤ Publish ➤ (DWF to Buzzsaw).
2 In the DWF Publish Settings dialog, determine which views and sheets are to be published in the DWF file.
   If you are publishing a single view, select Current View/Sheet Only from the Export list on the View/Sheet Set tab.
   If you are publishing multiple views and sheets:
   a On the View/Sheet Set tab, for Export, select In session view/sheet set.
   b For Show in list, specify the views and sheets to show in the list, and then select the views to publish. See Creating View and Sheet Sets on page 1110 and Selecting Views to Print on page 1150.
3 On the DWF Properties tab, specify publishing options.
4 To edit or add project-related metadata, click the Project Information tab. If this information is changed, the data is saved to the published DWF files and the project.
5 Click Publish.

   **TIP** To save the current publish settings and close the dialog without publishing, click Save Settings.

6 In the Publish DWF to Buzzsaw dialog, under Buzzsaw Sites, select the site to which you want to publish project files.
   If you need to add a new Buzzsaw location, click Add. For instructions, see Adding a New Buzzsaw Location on page 1146.
7 For Files of type, select DWF or DWFx.
8 For Naming, select Automatic - Long (Specify prefix) or Automatic - Short. See File Names for Exported Files on page 1118.
9 Click Publish.

Revit Structure generates a DWF file and posts it on the specified Buzzsaw site.
Adding a New Buzzsaw Location

When publishing project files to Buzzsaw, you can add a Buzzsaw location. This process defines the location to Revit Structure and provides access to the site for uploading the project files. However, the location that you specify (including the Buzzsaw site, project, and folders) must exist before you add it to Revit Structure. Consult your Buzzsaw administrator for details.

To add a new Buzzsaw location

1. Click ➤ Publish ➤ (DWG to Buzzsaw) or (DWF to Buzzsaw).
2. In the first dialog, click Publish.
3. In the Publish to Buzzsaw dialog, click Add.
4. In the Add a New Buzzsaw Location dialog, for Name, enter a descriptive name for this Buzzsaw location.
5. For Site, enter the Buzzsaw site URL for the project. The Buzzsaw site URL is https://webdav.buzzsaw.com/<site_name>, where <site_name> is the name of your project site. For example, if the project site is named Palace, enter the following: https://webdav.buzzsaw.com/Palace
6. For Folder, specify the folder to which you want to upload Revit project files. A Buzzsaw project can contain a hierarchy of project folders (which contain administrative information only) and standard folders (which contain data). If the target folder is a subfolder, specify the path from the project site. For example, if you want to upload project files to the Fountain subfolder in the Courtyard project folder of the Palace project site, enter the following: Courtyard/Fountain
7. Under Security, specify the user name and password to use to log in to the Buzzsaw project site.
8. Click OK.

The new Buzzsaw location is included in the list of Buzzsaw sites on the Publish dialog.

Print

The Print tool prints the current window, a visible portion of the current window, or selected views and sheets. You can send the desired drawings to the printer, to a PRN or PLT file, or to a PDF file.
Printed output in Revit Structure is What You See Is What You Get (WYSIWYG), with a few exceptions:

- The background color on the print job is always white.
- By default, reference planes, work planes, crop boundaries, unreferenced view tags, and scope boxes do not print. To include them in the print job, in the Print Setup dialog, clear the corresponding Hide options.
- The print job includes elements that have been hidden from a view using the Temporary Hide/Isolate tool.
- Line weights modified by the Thin Lines tool print at their default line weight.

Related topics
- Exporting to CAD Formats on page 1105
- Exporting to DWF Format on page 1120
- Publishing to Buzzsaw on page 1144

Printing Tips

- Keyboard shortcut: Ctrl+P.
- Before printing, be sure that you have installed the most recent version of the printer driver. Consult with the printer manufacturer.
- To print to PDF, see Printing to PDF on page 1151.
- To print many views and sheets unattended, use Batch Print for Revit. See Batch Printing on page 1153.

- To generate DWF or DWFx files, click ➤ Export ➤ (DWF). See Exporting to DWF Format on page 1120.
- If the print job is of substantial size, the status bar displays a Cancel button. The file size necessary to trigger this option depends on system speed and amount of memory.
- See Printing FAQs on page 1152.

Print Setup

You can specify various options for a print job in Revit Structure.

1. Click ➤ Print ➤ (Print Setup).
   Or, if the Print dialog is already open, click Setup.
2. In the Print Setup dialog, for Name, select the saved print settings to use, if any.
   See Saving Print Settings on page 1148.
4. Under Orientation, select Portrait or Landscape.
5. Under Paper Placement, specify where the view prints on the sheet.
   If, for Offset from Corner, you select User Defined, enter X and Y offset values.
6 Under Hidden Line Views, choose an option to increase print performance for hidden line views in elevations, sections, and 3D views. Vector processing times vary depending on the number of views processed and on view complexity. Raster processing times depend on the dimensions of the view and on the amount of graphics. Vector processing typically produces much smaller print files than raster processing.

7 Under Zoom, specify whether to fit the drawing to the size of the page or zoom to a percentage of the original size.

8 Under Appearance, specify a value for Raster Quality. This option controls the resolution of the raster data being sent to the print device. A higher quality results in a longer print time.

9 For Colors, select an option:
   - **Black Lines**: All text, non-white lines, pattern lines, and edges print in black. All raster images and solid patterns print in grayscale. (This option is not available for publishing to DWF.)
   - **Grayscale**: All colors, text, images, and lines are printed in grayscale. (This option is not available for publishing to DWF.)
   - **Color**: All colors in the project are maintained and printed, provided the printer supports colors.

10 Under Options, specify additional print settings:
   - View links print black by default, but you can choose to print them in blue.
   - When printing, you can hide the following elements: scope boxes, work planes, reference planes, and crop boundaries.
   - Hide unreferenced view tags. Select this option if you do not want to print section, elevation, and callout tags that are not on sheets.
   - If views display some elements in halftone, you can replace the halftone drawings with thin lines. (See Halftone/Underlay on page 1605.)

11 Click OK.

**Saving Print Settings**

You can save print settings in a project, so that they are available for reuse. You can also change saved print settings, revert changes, and rename or delete print settings.

To access the Print Setup dialog, click ➤ Print ➤ (Print Setup).

To save print settings

1 In the Print Setup dialog, specify print options. See Print Setup on page 1147.
2 To save the print settings to a new name, click Save As.
3 Enter a name for the print settings, and click OK.
4 Click OK.

**TIP** You can transfer print settings to another project using Transfer Project Standards. Click Manage tab ➤ Settings panel ➤ (Transfer Project Standards), and in the Select Items To Copy dialog, select Print Settings. See Transferring Project Standards on page 1635.
To change a saved print setting

1 In the Print Setup dialog, for Name, select a saved print setting.
2 Make the desired print setting changes.
3 Click Save.

**NOTE** If you click OK before clicking Save, your changes are not saved to the selected print setting. The first time you click OK, however, you are prompted to save your changes to the modified print setting. If you click No, the changed settings are applied to the in-session print setting. Any future changes you make without saving are also applied to the in-session setting. These changes are lost when you exit the Revit Structure session.

To revert print settings

1 In the Print Setup dialog, for Name, select a saved print setting.
2 Click Revert.

The settings revert back to their original saved state or in-session state.

To rename print settings

1 In the Print Setup dialog, for Name, select a saved print setting.
2 Click Rename.
3 Enter a new name for the settings, and click OK.

To delete print settings

1 In the Print Setup dialog, for Name, select a saved print setting.
2 Click Delete.

---

**Print Preview**

Use Print Preview to see a draft version of a view or sheet before printing it. Print Preview is not available if you are printing multiple sheets or views.

To see a print preview, click ➤ Print ➤ (Print Preview).

**NOTE** If the print job is of substantial size, the status bar displays a Cancel button. The file size necessary to trigger this option depends on system speed and amount of memory.

---

**Printing Views and Sheets**

Use the Print tool to print one or a few views and sheets. If you must print a large number of views and sheets, consider using the Revit Batch Print utility. See Batch Printing on page 1153.

**To print construction documents**

1 Click ➤ (Print).
2 In the Print dialog, for Name, select a printer.
3 (Optional) Click Properties to configure the printer.
4 (Optional) Select Print to File. You can save the print job as a PRN or PLT file.

5 Under Print Range, specify whether you are printing the current window, a visible portion of current window, or selected views/sheets. If you are printing selected views and sheets, click Select, select the views and sheets to print, and click OK.

When you are printing selected views and sheets to a file, Revit Structure creates one file per view or sheet. If you want to create a single file that contains all selected views and sheets, print to PDF. See Printing to PDF on page 1151.

6 Under Options, specify the number of copies to print and whether to print a view/sheet set in reverse order. You can select Reverse Print Order for a multiple-page print job so that the last page is printed first.

7 To print a complete copy of the project before the first page of the next copy is printed, select Collate. To print all copies of the first page and then print all copies of each subsequent page, clear Collate.

8 To change print settings, under Settings, click Setup.

See Print Setup on page 1147.

9 To preview the print job before printing, click Preview.

While in print preview mode, you can zoom the image and flip through pages if the print job involves multiple pages. To exit print preview, click Close on the Options Bar. To return to the Print dialog, click Print.

10 When you are ready to print, click OK.

**Selecting Views to Print**

When you are printing project views or sheets, you can specify which views and sheets are to be included.

**To select views or sheets**

1 Under Print Range or Range, select Selected Views/Sheets, and click Select.

2 In the View/Sheet Set dialog, select the views and sheets to print or export.

3 To quickly select all sheets or views, click Check All. Click Check None to clear all selections.

4 To save this view/sheet set for later reuse, click Save As, and enter a name.

5 Click OK. If you have not named the view/sheet set, you are prompted to name it.

**NOTE** You cannot transfer this view/sheet set to other projects.

**To change a saved view/sheet set**

1 Under Print Range or Range, select Selected Views/Sheets, and click Select.

2 In the View/Sheet Set dialog, for Name, select a view/sheet set name from the list.

3 Add or remove the desired views.

4 Click Save.

**NOTE** If you click OK before clicking Save, your changes are not saved to the selected view/sheet set. The first time you click OK, however, you are prompted to save your changes to the modified set. If you click No, the changed settings are applied to the in-session set. Any future changes you make without saving are also applied to the in-session set. These changes are lost when you exit the Revit Structure session.
To revert view/sheet set settings
1 In the View/Sheet Set dialog, for Name, select a saved set.
2 Click Revert.
   The settings revert to their original saved state or in-session state.

To delete view/sheet sets
1 In the View/Sheet Set dialog, for Name, select a saved set.
2 Click Delete.

Printing to PDF
You can print construction documents to PDF (Portable Document Format). The resulting PDF files can be shared with other team members, viewed online, or printed. When printing multiple views and sheets to PDF, you can specify whether each view or sheet is saved in a separate PDF file, or one PDF file contains all selected views and sheets.

TIP You can also export construction documents to DWF. DWF files are smaller in size than PDF files, and they can be easily shared with colleagues for online review. See Exporting to DWF Format on page 1120.

To print to PDF
1 Click ➤ (Print).
2 In the Print dialog, for Name, select your PDF print driver.
   If the list does not include a PDF print driver, talk to your system administrator about installing one on your system. See Changing Your System’s PDF Print Settings on page 1152.
3 Click Properties.
4 In the Properties dialog, define settings for the PDF print driver as desired, and click OK.
5 To print only the sheet or view in the drawing area:
   a Under Print Range, select Current Window to print the entire view or sheet that currently displays in the drawing area, or select Visible Portion of Current Window to print the part of the view or sheet that currently displays in the drawing area.
   b Under File, for Name, specify the name and location of the resulting PDF file. If needed, click Browse and navigate to the target folder.
6 To print multiple views and sheets:
   a Under Print Range, select Selected Views/Sheets.
   b Click Select.
   c In the View/Sheet Set dialog, select the views and sheets to print to PDF, and click OK.
   d Under File, to generate a single PDF file that contains all of the selected views and sheets, select Combine Multiple Selected Views/Sheets into a Single File. To generate one PDF file for each selected view and sheet, select Create Separate Files.
   e For Name, specify the name and location of the resulting PDF file. If needed, click Browse and navigate to the target folder.
      If you are generating multiple PDF files, the specified file name is used as a prefix. It is appended with the names of the selected views and sheets.
If you are printing multiple pages and you want them to print in reverse order, under Options, select Reverse Print Order.

To change print settings, under Settings, click Setup. See Print Setup on page 1147.

When you are ready to print, click OK.

Some PDF print drivers may display another dialog requesting a location and name for the PDF file. Provide the information requested, and click OK.

Changing Your System’s PDF Print Settings

In some cases, the default PDF print settings request a file name for each PDF file being created. If you are using Revit Structure to create PDF files for several views or sheets, this default setting means that you must provide a file name for each PDF file as it is created.

To avoid the need to provide individual file names for PDFs, change your system’s default PDF settings. The following procedure describes how to change this setting for Adobe PDF. The steps may vary for other PDF drivers.

To change the default Adobe® PDF print settings

1. On the Windows desktop, click Start menu ➤ Settings ➤ Printers and Faxes.
2. In the Printers and Faxes window, right-click Adobe PDF, and click Properties.
3. In the Adobe PDF Properties dialog, on the General tab, click Printing Preferences.
4. In the Adobe PDF Printing Preferences dialog, on the Adobe PDF Settings tab, for Adobe PDF Output Folder, select My Documents\*.pdf.
5. Clear View Adobe PDF results.
6. Click OK.

Printing FAQs

How are drawings printed to scale with a titleblock in Revit Structure?

Create a new sheet view, and add a titleblock to it.

Add any views (plans, elevations, sections) to the sheet. After you add a view, change its view scale through the view properties.

You can plot multiple views at different scales on the same sheet.

Only a portion of a print job comes out on a sheet

Several printers have limited on-board memory to process print data.

When plotting large format sheet sizes to plotters such as the HP DesignJet, change the plotter's settings so that the data is processed in the computer.

To change the settings, click ➤ (Print). Select the correct printer, and click Properties. In the dialog, click the Advanced tab. Select the option to process the document in the computer, and click OK.
**My reference planes, crop boundaries, and scope boxes do not print**

Reference planes, crop boundaries, and scope boxes are hidden for printing by default. To show them when you print, click ➤ Print ➤ (Print Setup). In the Print Setup dialog, clear the options for reference planes, crop boundaries, and scope boxes.

**My reference planes are printing. I don't want them to print**

Click ➤ Print ➤ (Print Setup). In the Print Setup dialog, select Hide ref/work planes.

**Can the colors in a drawing be overridden so they print in solid black and white?**

Click ➤ Print ➤ (Print Setup). In the Print Setup dialog, under Appearance, for Colors, select Black Lines.

This ensures that a black and white printer properly processes colors in a project. This option does not produce grayscale. All colors are converted to black.

**How do I increase print speed in elevation, section, and perspective views?**

Be sure that the Far Clipping property is active for the view. Go to the view properties of the view, and select an option for Far Clipping.

**I choose black lines or gray scale in Revit Structure, but my printer still prints in colors**

Some printer drivers override the Colors setting that you specified in Revit Structure. To get the desired color output, manually set the color through your printer’s properties.

---

**Batch Printing**

Batch Print for Revit provides an easy way to print a large number of drawings (views and sheets) from a Revit project unattended.

After preparing the default printer and the Revit project, use Batch Print to send any number of drawings to the printer and to control the order in which they print. When you start the print job, Batch Print manages the printing of the drawings, requiring no further interaction from you. If desired, you can monitor the progress of the print job using a status dialog.

Batch Print is available to Revit subscription customers. To use this utility:

1. Download Batch Print from the Autodesk customer subscription Web page.
2. Install Batch Print.
3. Open a Revit project, and click Add-Ins tab ➤ External Tools drop-down ➤ Batch Print.
4. In the Batch Print dialog, click Help to learn how to use the utility.
### Print Troubleshooting

**When I print, surface patterns are partially submerged into the concave side of a wall's surface**

Click ➤ Print ➤ (Print Setup). In the Print Setup dialog, under Hidden Line Views, select Vector Processing.

**The printed output of imported images is different than the on-screen display**

Click ➤ Print ➤ (Print Setup). In the Print Setup dialog, under Hidden Line Views, select Raster Processing.

**Problems printing raster images with a XES Synergix 8830 plotter**

In the properties dialog for the XES Synergix 8830, on the Graphics tab, there is a check box for Enable RTL native mode resolution. Clear the check box, and the raster images should print correctly.

**How do I plot to Reprodesk?**

If the PRN file has been changed to a PLT file and the processing of the file still produces a black screen, after the file has been sent to Reprodesk, change the pen setting from standard (the default) to asinfile pen.

**Other Plotting Considerations**

Always use a color cartridge in the plotter when the Windows driver is set to use color mapping. Use a monochrome cartridge in the plotter when the Windows driver is set to use either grayscale or black mapping. (A color cartridge may be used, but only the black ink will be used).

### Structural Interoperability with AutoCAD Architecture and AutoCAD MEP

You can import and export structural members between Revit Structure and AutoCAD Architecture or AutoCAD MEP. This lets you take advantage of the particular strengths of each application to enhance the workflows for the architectural and structural phases of a project.

A typical workflow using both applications might consist of an architect creating a model in AutoCAD Architecture or AutoCAD MEP and then passing it on to a structural engineer, who will add the structural design in Revit Structure. After importing the model into Revit Structure, the structural engineer deletes all layers that do not contain relevant information for the structural design and creates levels. Then, using a partial explode of the imported drawing to access vital information about the imported objects, the engineer can use it as a reference to re-create those objects in Revit Structure. The imported AutoCAD Architecture or AutoCAD MEP geometry can then be deleted, or retained in the drawing if the model needs to be exported back to the original application.

If a structural design is to be exported from Revit Structure to AutoCAD Architecture or AutoCAD MEP, Revit structural members are automatically converted to AutoCAD Architecture or AutoCAD MEP structural members of corresponding types. Properties of the Revit elements are mapped to the generated AutoCAD Architecture or AutoCAD MEP members.

### Importing Structural Elements from AutoCAD Architecture and AutoCAD MEP

You can import an architectural model from AutoCAD Architecture or AutoCAD MEP and use it as reference for your structural design in Revit Structure. Columns, beams, braces, and grids in the imported model will
be used as a reference for the user to retrace and recreate them directly in Revit Structure. You can then create structural plans, export the structural data to an analysis and design application, or export the structural data back to AutoCAD Architecture or AutoCAD MEP.

**Importing AutoCAD Architecture and AutoCAD MEP Layers**

In AutoCAD Architecture and AutoCAD MEP, object components are placed on layers. A wall, for example, can be placed on layer A-Wall-G, whereas a door in the wall would be placed on layer A-Door-G. Layers can be created according to architectural standards like the AIA layer standard, or they can be user-defined. When an AutoCAD Architecture or AutoCAD MEP drawing is imported into Revit Structure, the layer information of the imported objects is retained. Revit Structure does not use layers internally, but it can map layers to object categories. When an imported drawing is exported back to AutoCAD Architecture or AutoCAD MEP, the layer settings of exported objects are exported with the objects. Revit objects that were added get a layer assigned based on the mapping of the object categories to layers in the layer mapping file. For example, if objects of the category Railing Balusters have been assigned to the layer A-FLOR-HRAL, they will appear on that layer when exported to AutoCAD Architecture or AutoCAD MEP. For more information, see Exporting Layers on page 1125.

When AutoCAD Architecture or AutoCAD MEP drawings are imported into Revit Structure, you can import all layers, or select individual layers to import. For example, if you are importing a floor plan and want only the structural members to display, you can select only the layers S-Column-G, S-Brace-G, and S-Beam-G. Only those layers will be imported, and as a consequence you will not see any walls, doors, or annotation objects in Revit Structure. For detailed information, see Import and Link Options for CAD Formats and Revit Models on page 63.

**Exploding Imported Objects**

When you import an AutoCAD Architecture or AutoCAD MEP drawing into Revit Structure, the complete drawing is imported or linked as an Import Symbol. You can work more efficiently with the imported data by performing a partial explode on the imported drawing. This is the only way in which you can access the AutoCAD Architecture or AutoCAD MEP properties of individual objects. A partial explode breaks up the imported drawing into individual object blocks, but not into Revit lines and text elements. For more information, see Exploding Imported Geometry on page 75.

You can explode or partially explode an imported drawing only using the Import tool in Revit Structure. You can never explode or partially explode a linked drawing.

**Removing Imported Objects from Revit Structure**

After you have imported structural members from AutoCAD Architecture or AutoCAD MEP and created corresponding Revit objects from them, you can keep the imported objects in the drawing or remove them in one of the following ways, depending on your requirements:

- **Delete.** If you have no further use for the imported objects, you can delete them from the Revit file.

- **Unload.** If you have linked to the AutoCAD Architecture or AutoCAD MEP drawing instead of importing it, you can unload the link in Revit Structure. The drawing will no longer appear, but it can always be reloaded if needed, giving you the most up-to-date version. (If you want the objects to be frozen, you should import the drawing rather than link to it.)

- **Delete individual layers.** When an AutoCAD Architecture or AutoCAD MEP drawing is imported into Revit Structure, the information about its drawing layers persists. As a result, you can selectively delete individual layers and the objects contained on them.

**Importing Grids**

Grids are constructions that are used to anchor structural columns, beams, and braces. Grids can be created in AutoCAD Architecture, imported to Revit Structure, and converted to Revit grids.
The following properties of an AutoCAD Architecture grid are maintained when it is imported to Revit Structure:

- Grid lines
- Grid bubbles
- Grid type (Column Grid)
- Grid bubble type (Multi-View Bock Reference)
- Grid bubble layer
- Grid line layer

The following properties are added to the imported grid:

- Base level
- Base offset
- Instance scale (defined on import)
- Instance name (name of the imported DWG file)

**To import a grid from AutoCAD Architecture**

1. Create or open the Revit project into which you want to import the AutoCAD Architecture drawing.
2. In the Project Browser, select the view in which you want the imported grid to display.
3. Import the AutoCAD Architecture drawing into Revit Structure, as described in Importing or Linking CAD Formats on page 58.

When you import a DWG/DXF file into Revit Structure, you can import all layers, all visible layers, or selected layers. After they are imported, layers can be selectively deleted from Revit Structure at any time.

The imported drawing displays as a single import symbol.
For more information about the imported objects, select the Import symbol, click Modify | <File Name> tab ➤ Import Instance panel ➤ (Query), and select grid lines or grid bubbles to query.

A query displays the object type, block name (identical to the imported drawing name), layer, and style name, if applicable.

To exit Query mode, press Esc.

NOTE The imported drawing can be exploded or partially exploded. To access the imported read-only AutoCAD Architecture objects, perform a partial explode.

5 Click Modify | <File Name> tab ➤ Import Instance panel ➤ Explode drop-down ➤ (Partial Explode).

A partial explode on an imported grid allows you to select the grid independently from the grid bubbles.

6 To create a Revit Structure grid, click Home tab ➤ Datum panel ➤ (Grid).

7 Click Modify | Place Grid tab ➤ Draw panel ➤ (Pick Lines).

8 Move the cursor over the imported grid until one grid line is highlighted.

9 Do one of the following:

■ To create a single Revit grid line, select the imported grid line. Repeat for each line in the grid, and then press Esc to end the grid tool.

■ To create a Revit grid in one step, select an imported grid line, press Tab to select all of the imported grids together, and click to place the grids.

NOTE If the AutoCAD Architecture grid that you are tracing contains grid bubbles, the resulting Revit grid will duplicate these bubbles. The text and numbers contained in the bubbles will be used as the names of the associated grid lines.

Revit grid created from AutoCAD Architecture grid

10 If the drawing will not be exported back to AutoCAD Architecture and you have no further need for the imported geometry, delete it using one of the following methods:

■ Select the import symbol of the imported grid, and press Delete.
This option works best if you have not partially exploded the imported grid. If the imported grid has been exploded, select the import symbols for the grid and grid bubbles independently.

- Click Modify | <File Name> tab ➤ Import Instance panel ➤ (Delete Layers), and delete all or selected layers of the imported drawing.
- If the drawing was linked into Revit Structure, click Manage tab ➤ Manage Project panel ➤ (Manage Links), and unload the linked drawing from Revit Structure.

**NOTE** You can reload the file later, if necessary.

### Importing Structural Members

Columns, beams, and braces are the structural members in a building. They can be created in AutoCAD Architecture and imported to Revit Structure for reference. You can access limited information about the partially exploded AutoCAD Architecture members, which are read-only and cannot be manipulated. Use them as reference for tracing and re-creating members in Revit Structure.

#### Columns in AutoCAD Architecture

The following properties of an AutoCAD Architecture structural member are maintained when it is imported to Revit Structure:

- Component Description
- Roll angle
- Member length
- AutoCAD Architecture style name
- Structural Type name (Column/Beam/Brace)
- Type name (Structural Member)
The following properties are added to the imported member:

- Base level
- Base offset
- Instance scale (defined on import)
- Instance name (name of the imported DWG file)

**To import structural members from AutoCAD Architecture**

1. Create or open the Revit project into which you want to import the AutoCAD Architecture structural members.
2. In the Project Browser, select the view in which you want the imported members to display.
3. Import the AutoCAD Architecture drawing into Revit Structure, as described in Importing or Linking CAD Formats on page 58.
   
   When you import a DWG/DXF file into Revit Structure, you can import all layers, all visible layers, or selected layers. After they are imported, layers can be selectively deleted from Revit Structure at any time.
   
   The imported drawing displays as a single import symbol.

4. For more information about the imported objects, select the Import symbol, click Modify | <File Name> tab ➤ Import Instance panel ➤ (Query), and select structural member blocks to query.
   
   A query displays the object type, block name (identical to imported drawing name), layer, and style name, as applicable.
   
   To exit Query mode, press Esc.

**NOTE** The imported drawing can be exploded or partially exploded. To access the imported read-only AutoCAD Architecture objects, perform a partial explode.

5. Click Modify | <File Name> tab ➤ Import Instance panel ➤ Explode drop-down ➤ (Partial Explode).
   
   A partial explode on an imported drawing allows you to display the individual object’s properties.
6 To create a Revit structural member, click Home tab ➤ Structure panel, and click (Beam), (Column), or (Brace).

7 Move the cursor over the imported member, and create the new structural member in one of the following ways:

- If you are creating a structural column, use the preview image of the column to position the Revit column inside the imported AutoCAD Architecture column, and then click to place it.

- If you are creating a beam or a brace, trace over the imported object to create the new object.

8 If necessary, adjust the dimensions of the new member to match the imported object more exactly.

9 If the drawing will not be exported back to AutoCAD Architecture and you have no further need for the imported geometry, delete it using one of the following methods:

- Select the import symbol of the imported object, and press Delete.

- Select the import symbol, and click Modify | <File Name> tab ➤ Import Instance panel ➤ (Delete Layers), and delete the relevant layers of the imported drawing.

- If the drawing was linked into Revit Structure, click Manage tab ➤ Manage Project panel ➤ (Manage Links), and unload the imported drawing from Revit Structure.

**NOTE** You can reload the file later, if necessary.
Importing Walls

Walls can be created in AutoCAD Architecture, imported to Revit Structure, and used as a reference to manually retrace or recreate the structural walls.

**NOTE** If you want to retrace or recreate a wall directly in Revit Structure, keep in mind that architectural objects are drawn from the ground up, whereas structural objects are drawn from the top down. If you are working with a structural template, architectural walls will not be visible unless you adjust the view range of the project view accordingly. For more information, see View Range on page 864.

**Wall in AutoCAD Architecture**

The following properties of an AutoCAD Architecture wall are maintained when it is imported to Revit Structure:

- Component Description: list of wall components, their materials and size
List of AutoCAD Architecture wall components, materials, and sizes in Revit Structure

- Wall length
- Wall width
- Wall height
- AutoCAD Architecture style name
- Type name (Wall)

The following properties are added to the imported wall:

- Base level
- Base offset
- Instance scale (defined on import)
- Instance name (name of the imported DWG file)

To import walls from AutoCAD Architecture

1. Create or open the Revit project into which you want to import the AutoCAD Architecture walls.
2. In the Project Browser, select the view in which you want the imported walls to display.
3. Import the AutoCAD Architecture drawing into Revit Structure, as described in Importing or Linking CAD Formats on page 58.

When you import an DWG or DXF file into Revit Structure, you can import all layers, all visible layers, or selected layers. After they are imported, layers can be selectively deleted from Revit Structure at any time.

The imported drawing displays as a single import symbol.

4. For more information about the imported objects, select the Import symbol, click Modify | <File Name> tab ➤ Import Instance panel ➤ (Query), and select wall blocks to query.

A query displays the object type, block name (identical to imported drawing name), layer, and style name, as applicable.

To exit Query mode, press Esc.

**NOTE** The imported drawing can be exploded or partially exploded. To work with imported structural objects, perform a partial explode.

5. Click Modify | <File Name> tab ➤ Import Instance panel ➤ Explode drop-down ➤ (Partial Explode).
A partial explode on an imported drawing allows you to display the individual object’s properties.

**Partially exploded AutoCAD Architecture wall in Revit Structure**

6 To create a Revit structural wall, click Home tab ➤ Structure panel ➤ (Wall).

7 Click Modify | Place Structural Wall tab ➤ Draw panel ➤ (Pick Lines).

**NOTE** The Pick Faces option is primarily designed for use with the Revit massing tool.

8 Move the cursor over the imported wall, and click once to place the structural wall.

9 If necessary, adjust the position of the new wall to match the imported wall more exactly.

10 If the drawing will not be exported back to AutoCAD Architecture and you have no further need for the imported geometry, delete it using one of the following methods:

- Select the Import symbol of the imported wall, and press *Delete*.

- Click Modify | <File Name> tab ➤ Import Instance panel ➤ (Delete Layers), and delete all wall layers.

- If the drawing was linked into Revit Structure, click Manage tab ➤ Manage Projects panel ➤ (Manage Links), and unload the linked drawing from Revit Structure.

**NOTE** You can reload the file later, if necessary.

### Importing Slabs

Slabs are often used as floor and foundation components. You can create slabs in AutoCAD Architecture, and use them as reference in Revit Structure to retrace or recreate the slabs.

The following properties of an AutoCAD Architecture slab are maintained when it is imported to Revit Structure:

- Component Description: list of slab components, their materials and sizes

---

**Importing Structural Elements from AutoCAD Architecture and AutoCAD MEP | 1163**
Slab thickness
AutoCAD Architecture style name
Type name (Slab)

The following properties are added to the imported slab:

- Base level
- Base offset
- Instance scale (defined on import)
- Instance name (name of the imported DWG file)

To import a slab from AutoCAD Architecture

1. Create or open the Revit project into which you want to import the AutoCAD Architecture slab.
2. In the Project Browser, select the view in which you want the imported slab to display.
3. Import the AutoCAD Architecture drawing into Revit Structure as described in Importing or Linking CAD Formats on page 58.

   When you import a DWG or DXF file into Revit Structure, you can import all layers, all visible layers, or selected layers. After they are imported, layers can be selectively deleted from Revit Structure at any time.

   The imported drawing displays as a single import symbol.

4. For more information about the imported objects, click Modify | <File Name> tab ➤ Import Instance panel ➤ (Query), and select slab blocks to query.

   A query displays the object type, block name (identical to imported drawing name), layer, and style name, as applicable.

   To exit Query mode, press Esc.

   **NOTE** The imported drawing can be exploded or partially exploded. To work with imported structural objects, perform a partial explode.

5. Click Modify | <File Name> tab ➤ Import Instance panel ➤ Explode drop-down ➤ (Partial Explode).

   A partial explode on an imported drawing allows you to display the individual object’s properties.
Partially exploded AutoCAD Architecture slab in Revit Structure

6. To create a Revit Structure slab, click Home tab ➤ Foundation panel ➤ (Slab).

7. Click Modify | Create Floor Boundary tab ➤ Draw panel ➤ (Line).

8. Trace over the imported slab shape.

9. Click (Finish Edit Mode).

10. If the drawing will not be exported back to AutoCAD Architecture and you have no further need for the imported geometry, delete it using one of the following methods:

   - Select the Import symbol of the imported slab, and press Delete.
   - Select the import symbol, and click Modify | <File Name> tab ➤ Import Instance panel ➤ (Delete Layers), and delete all slab layers.
   - If the drawing was linked into Revit Structure, click Manage tab ➤ Manage Project panel ➤ (Manage Links), and unload the linked drawing from Revit Structure.

**NOTE** You can reload the file later, if necessary.

---

**Exporting Structural Elements to AutoCAD Architecture**

You can export beams, braces, columns, and grids from Revit Structure to AutoCAD Architecture, where they are converted automatically to native AutoCAD Architecture structural elements. Structural walls, structural floors, footings, in-place families, and other Revit objects can also be exported to AutoCAD Architecture, where they are converted to AutoCAD Architecture mass elements.

**IMPORTANT** You can export only Revit Structure 3D views as AutoCAD Architecture objects.
AutoCAD Architecture Styles and Revit Families

The display of a structural object in AutoCAD Architecture is controlled by its style. A style is a collection of properties that determine the visibility and shape of individual object components, layer assignments, linetype settings, and more. Instead of styles, Revit Structure uses the concept of families, which determine not only the display of objects but also physical properties, like sizes and dimensions.

Exporting Grids

Revit grids can be exported to AutoCAD Architecture.

The AutoCAD Architecture grid is created in the plane of the lowest level of the Revit model that is not lower than the bottom of the view model outline. The multi-view blocks for the grid bubbles are anchored to the ends of the grid lines and will be created in the same plane. The attribute text in each grid bubble is defined by the Revit grid name. The shape of the grid bubble is generated from the Revit grid head symbol. The scale of the generated grid bubble and text in AutoCAD Architecture is the scale of the current Revit 3D view.

Revit grid components are converted to AutoCAD Architecture grid components as follows:

<table>
<thead>
<tr>
<th>Revit Structure Component</th>
<th>AutoCAD Architecture Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>grid lines</td>
<td>custom grid object</td>
</tr>
<tr>
<td>grid bubbles</td>
<td>multi-view blocks anchored to custom grid</td>
</tr>
<tr>
<td>grid bubble text</td>
<td>attribute value in multi-view blocks</td>
</tr>
</tbody>
</table>

**NOTE** The attribute value is editable in AutoCAD Architecture.

To export a Revit grid to AutoCAD Architecture

1. Create a grid in Revit Structure.
2. Click ➤ Export ➤ CAD Formats ➤ (DWG files).
3. In the Export CAD Formats dialog, for Export, select <In session view/sheet set>.
4. Select a 3D view to export. See Creating View and Sheet Sets on page 1110 and Selecting Views to Print on page 1150.
5. On the DWG Properties tab, specify export options.
6 Click Next.
7 In the Export CAD Formats dialog, for Files of type, verify that AutoCAD DWG Files (*.dwg) is selected.
8 Click OK.
   The selected view is exported as a DWG file.

Open the exported grid in AutoCAD Architecture

9 Open AutoCAD Architecture.
10 Click ➤ Open ➤ Drawing, and open the exported DWG file.

If necessary, you can modify the grid in AutoCAD Architecture. For more information, see “Grids” and “Multi-View Blocks” in the AutoCAD Architecture help.

Exporting Structural Members

Revit columns, beams, and braces can be exported to AutoCAD Architecture, where each is converted to the corresponding type of AutoCAD Architecture structural member. The profile and curve are exported without cutbacks (see Cutback on page 275), cuts, holes, and other such modifications. In cases when there is no uniform profile, an AutoCAD Architecture mass element is created instead of a structural member. For every family type exported from Revit Structure, a custom AutoCAD Architecture style is created and assigned to the structural member. Objects from the same family type in Revit Structure will have the same style in AutoCAD Architecture.

NOTE Revit family profiles will not be mapped to standard AutoCAD Architecture member profiles.

AutoCAD Architecture properties are generated from Revit properties as follows:

<table>
<thead>
<tr>
<th>AutoCAD Architecture Property</th>
<th>Revit Structure Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Comments (Identity Data)</td>
</tr>
<tr>
<td>Layer</td>
<td>Revit layer mapping file. For more information, see Exporting Layers on page 1125.</td>
</tr>
<tr>
<td>Style</td>
<td>Type</td>
</tr>
<tr>
<td>Member Type (Beam/Brace/Column)</td>
<td>Revit object type</td>
</tr>
<tr>
<td>Start Offset</td>
<td>Beams/Braces: Cutback is calculated automatically by Revit Structure for start point</td>
</tr>
<tr>
<td>AutoCAD Architecture Property</td>
<td>Revit Structure Property</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td><strong>Beam</strong></td>
<td><strong>Beam</strong></td>
</tr>
<tr>
<td>■ Columns: Base offset</td>
<td>■ Cutback</td>
</tr>
<tr>
<td>End Offset</td>
<td>■ Beams/Braces: Cutback is calculated automatically by Revit Structure for endpoint</td>
</tr>
<tr>
<td>■ Columns: Top offset</td>
<td>■ Beams: Length</td>
</tr>
<tr>
<td>Logical length</td>
<td>■ Columns: not applicable</td>
</tr>
<tr>
<td>Roll</td>
<td>0 (Default value)</td>
</tr>
<tr>
<td>Justify</td>
<td>■ Beams/Columns: Top Center (Default value)</td>
</tr>
<tr>
<td>■ Brace</td>
<td>■ Brace: Middle Center (Default value)</td>
</tr>
<tr>
<td>Justify using overall extents</td>
<td>Yes (Default value)</td>
</tr>
<tr>
<td>AutoCAD Architecture Property</td>
<td>Revit Structure Property</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>Start Point X/Y/Z</td>
<td>X/Y/Z coordinates of start point curve</td>
</tr>
<tr>
<td>End Point X/Y/Z</td>
<td>X/Y/Z coordinates of endpoint curve</td>
</tr>
<tr>
<td>Rotation</td>
<td>Beams/Braces: Angle</td>
</tr>
<tr>
<td></td>
<td>Columns: Orientation of the column in the global coordinate system</td>
</tr>
<tr>
<td>Elevation</td>
<td>no corresponding property; calculated by AutoCAD Architecture based on the X/Y/Z coordinates of curve</td>
</tr>
<tr>
<td>Additional Information (Location)</td>
<td>no corresponding property</td>
</tr>
<tr>
<td>Trim Planes</td>
<td>no corresponding property</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>no corresponding property</td>
</tr>
<tr>
<td>Notes</td>
<td>no corresponding property</td>
</tr>
<tr>
<td>Reference documents</td>
<td>no corresponding property</td>
</tr>
</tbody>
</table>

To export Revit structural members to AutoCAD Architecture

1 Create structural members in Revit Structure.

2 Click ➤ Export ➤ CAD Formats ➤ (DWG files).

3 In the Export CAD Formats dialog, for Export, select <In session view(sheet set)>

4 Select a 3D view to export. See Creating View and Sheet Sets on page 1110 and Selecting Views to Print on page 1150.

5 Click the DWG Properties tab.

6 Under Solids (3D views only), select Export as AutoCAD Architecture and AutoCAD MEP Objects.

**NOTE** This option can only be selected if you have selected a 3D view to export.

7 Under Prefer, select AutoCAD Architecture Objects or Geometry.

If a Revit structural member being exported is not a plain extrusion (for example, it has coping, cutouts, holes, or a shape changed because of a concrete join cleanup), you can choose to create an AutoCAD Architecture object that looks approximately the same as the Revit structural member. In this case, select AutoCAD Architecture Objects.
If you want to preserve the exact geometry of the Revit structural member and create an AutoCAD Architecture mass object, select Geometry.

**Always Export as Geometry**

A setting in the Family Editor for a structural member family overrides this option.

You can set structural member families to be exported as geometry at all times. Open or start creating a structural member family in the Family Editor. Click Home tab ➤ Properties panel ➤ (Family Category and Parameters). Select the parameter Always Export as Geometry, and click OK.

8 Specify export options, as described in Exporting to CAD Format Properties on page 1113.
9 Click Next.
10 In the Export CAD Formats dialog, verify that AutoCAD DWG Files (*.dwg) is selected for Files of type.
11 Click OK.

The selected view is exported as a DWG file.

Open the exported drawing in AutoCAD Architecture

12 Open AutoCAD Architecture.

13 Click ➤ Open ➤ Drawing, and open the exported DWG file.

If necessary, you can modify the structural members in AutoCAD Architecture. For more information, see “Structural Members” in the AutoCAD Architecture help.

**Exporting Walls, Structural Floors, Floors, and Non-Structural Elements**

Walls, structural floors, and all non-structural elements are exported to AutoCAD Architecture as free-form mass elements. Mass elements can be converted to the following objects within AutoCAD Architecture:

- Walls
Walls, Doors, and Windows

You can export structural walls and architectural walls to AutoCAD Architecture. Walls are converted to free-form mass elements, which can be converted to AutoCAD Architecture walls. Windows and doors in a wall are exported as simple openings, into which AutoCAD Architecture windows and doors can be inserted. A physical representation of the window or door is also exported as an AutoCAD block reference.

Structural Floors, Floors, and Foundations

Structural floors, floors, and foundations in Revit Structure can be exported to AutoCAD Architecture as free-form mass elements.

1. Create walls, structural floors, and other non-structural elements in Revit Structure.

2. Click ➤ Export ➤ CAD Formats ➤ (DWG files).

3. In the Export CAD Formats dialog, for Export, select <In session view/sheet set>.

4. Select a 3D view to export. See Creating View and Sheet Sets on page 1110 and Selecting Views to Print on page 1150.

5. Click the DWG Properties tab.

6. Specify export options, as described in Exporting to CAD Format Properties on page 1113.

7. Click Next.

8. In the Export CAD Formats dialog, verify that AutoCAD DWG Files (*.dwg) is selected for Files of type.

9. Click OK.
The selected view is exported as a DWG file.

Open the exported drawing in AutoCAD Architecture

10 Open AutoCAD Architecture.

11 Click ➤ Open ➤ Drawing, and open the exported DWG file.

If necessary, you can modify the resulting free-form mass elements in AutoCAD Architecture, or convert them to walls, structural floors, roof slabs, spaces or AutoCAD 3D solids. For more information, see “Converting a Mass Element to a Wall”, “Converting a Mass Element to a Slab or Roof Slab”, “Converting a Mass Element to a Space” and “Converting a Mass Element to a 3D Solid” in the AutoCAD Architecture help.

Placing 3D Beams from Geometry References in Imported 3D Drawings

You can place 3D beams using 3D lines, curves, and edges from geometry imported with CAD files. This allows the engineer to model complex dimensional framing from the data of a 3D architectural drawing. This eliminates the need to recreate designs from the beginning in Revit Structure.

To place beams using imported drawings

1 Import the CAD model. See Importing or Linking CAD Formats on page 58.
2 Open a 3D view in which to place the beams.

TIP Change the Visual Style to Wireframe to view all lines of the model.

3 Click Home tab ➤ Structure panel ➤ (Beam).
4 In the Type Selector, select a beam type.
5 On the Properties palette, modify beam parameters.
6 Click Modify | Place Beam tab ➤ Draw panel ➤ (Pick Lines).
7 On the Options bar, select:
   ■ the appropriate placement plane in which to place the beams. Endpoint z-direction offsets are calculated from this level.
   ■ a structural usage
   ■ 3D Snapping
8 Move the cursor over the imported drawing. When you place the cursor over valid 3D lines, curves, and edge references, they will highlight.

9 Click valid lines, curves, and edges to place beams.

Beams sharing common endpoints are joined to one another and subject to join and cutback principles of behavior. See Joins and Cutback on Framing Elements and Columns on page 273.

Once placed, 3D beams are independent of the imported drawing. The drawing can be unlinked or removed from the Revit project without affecting the orientation of the placed beams.
Collaborate with Others

Read these topics for information about different ways to work with other team members on Revit projects.
Linked Models

You can link different file formats in a Revit project, including other Revit files (Revit Architecture, Revit Structure, Revit MEP), CAD formats (DWG, DXF, DGN, SAT, SKP), and DWF markup files.

This topic contains information about linking Revit models. For information about linking CAD formats and DWF, see Importing or Linking CAD Formats on page 58 and Linking DWF Markup Files on page 74.

Overview of Linked Models

You can link Revit Architecture, Revit Structure, and Revit MEP models. Linking Revit models is primarily intended for linking separate buildings, such as those that compose a campus. For example, the following site plan shows 4 building models linked to one model.

When you link a Revit model into a project, Revit Structure opens the linked model and keeps it in memory. The more links a project contains, the longer it can take to open.

Linked Revit models are listed in the Revit Links branch of the Project Browser.

You can convert linked Revit models to groups, and you can convert groups to linked Revit models. See Converting Groups and Linked Revit Models on page 1465. You can also mirror linked Revit models. See Mirroring Elements on page 1483.
When to Link Models

It is recommended to use linked Revit models for

■ Separate buildings on a site or campus
■ Parts of buildings which are being designed by different design teams or designed for different drawing sets
■ Coordination across different disciplines (for example, an architectural model and a structural model)

Linked models may also be appropriate for the following situations:

■ Townhouse design when there is little geometric interactivity between the townhouses
■ Repeating floors of buildings at early stages in the design, where improved Revit model performance (for example, quick change propagation) is more important than full geometric interactivity or complete detailing

The Revit project can consist of many individual linked Revit models to create an aggregate model of all the data. Before breaking up a Revit project into multiple models, however, carefully consider the following limitations and workflows:

■ Limited joining and interaction between elements in the host project and elements in the linked models will prevent elements from cleaning up or joining with elements in linked models. However, some elements, like rooms and ceiling outlines, can be generated from the geometry located within the individual linked models.
■ The challenge of managing element names, numbers, and identity data between the host project and the linked models can result in duplicate names or numbers. This challenge is especially true for multiple or repeating units that are linked to a project, such as hospital operating rooms and hotel rooms. In these cases, use a group to define the repeating unit, instead of a linked model. See Editing Elements in Groups on page 1455.
■ Separate project standards for the host project and linked models can cause models to become unsynchronized.
■ In order to maintain control, linked models need to be carefully managed.

Dimensions and Constraints in Linked Models

You can use elements in the linked model as references for dimensions and alignment. For example, you can create a dimension between a wall in the host project and a wall in the linked model. See Permanent Dimensions on page 888 and Aligning Elements on page 1479.

You can also create constraints between elements in the host model and elements in a linked model. For example, you can constrain a linked building to a property line in the host model or a linked floor to a level in the host model. Linked models move as an entire entity when the element to which they are constrained moves. Constraints on a linked model (or an element in a linked model) only move the linked model, they do not move elements in the host model. Constraints to links using shared positions are not permitted.

Revit Structure attempts to retain and rehost dimensions and constraints when you reload (or unload and reload) a link.
Repeating a Linked Model in the Host Model

A linked model can be copied any number of times in a host project. For example, a housing development may have multiple designs that repeat many times throughout the site. For each copy of a linked model that you place in a project, a unique name is automatically generated. This name helps to identify elements from linked models in a schedule.

You can modify the name for a linked model instance through its properties. You can also override visibility and graphics settings for each linked model instance. See Visibility of Linked Models on page 1187.

You can copy linked Revit models using the standard copy and paste procedures (see Copying Elements on page 1491) or you can drag a linked Revit model from the Project Browser into a project view.

In addition, you can copy a linked Revit model between projects within the same Revit session. When you copy a linked Revit model to another project, the link path, shared positioning settings, visible nested links, and the link instance name are copied to the new project. If the link instance name already exists in the project, the link is automatically renamed. Partially loaded files are maintained as partially loaded. Visibility and graphic override settings are not preserved.

Related topics
- Copying a Linked Model in the Host Model on page 1185
- Copying Elements from a Linked Model on page 1186

Nesting Linked Models

When you link a model that contains other linked models, the links become nested. You can show or hide nested linked models in the host model. The nested links display according to their Reference Type setting in the parent model:

- **Overlay** does not load nested models into the host model, so they do not display in the project.
- **Attachment** loads nested linked models in the host model and displays them in the project.

The following image shows that Project A is linked into Project B (so Project B is the parent model for Project A). The Reference Type setting for Project A is set to Overlay within its parent model (Project B). When Project B is imported into Project C, Project A does not display.

If you change the Reference Type setting for Project A (within its parent model, Project B) to Attachment, when you import Project B into Project C, the nested link (Project A) displays.
When a nested model can display in the host model, you can indicate whether the nested model displays in a view using a filter from the host model, the filter applied to a view in the linked model or the nested model, or no filters. See View Filters for Linked Models on page 1188.

When a nested link is visible, you can use Tab to select nested link instances and view properties of elements in the nested link, as you can with other linked models. In addition, the Interference Check tool checks for interference in the nested linked models as well as the parent linked model. (See Interference Checking on page 1261.)

Nested links that are visible in the project display in the Revit Links branch of the Project Browser under their parent link. Nested links do not display in the Manage Links dialog. (See Manage Links Dialog on page 1206.)

**Phases and Linked Models**

When you link a Revit model that has more than one phase, phases in the host model automatically map to phases in the linked model. When this initial mapping occurs, Revit Structure maps phases by matching phase names.

You can manually set up a correspondence between phases in the host model and phases in the linked model. To do this you set up a phase map in the properties of the linked model, and then apply the phase map in the host model.

**NOTE** Phase maps must occur in chronological order. For example, a phase map cannot be set up like the following table. Since phase 1 occurs before phase 3, phase 3 cannot be mapped to phase 1.

<table>
<thead>
<tr>
<th>Phase from linked file</th>
<th>Phase from linked file</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase 1</td>
<td>Phase 1</td>
</tr>
<tr>
<td>Phase 2</td>
<td>Phase 2</td>
</tr>
<tr>
<td>Phase 3</td>
<td>Phase 1</td>
</tr>
</tbody>
</table>

Phase mapping is always maintained, unless phases in either the host or linked models are combined. If phases are combined, the existing phase map of the remaining phase is used.

**Related topics**

- Mapping Phases Between Linked Models on page 1185
- Project Phasing on page 877
Transferring Project Standards Between Linked Models

If you open the host model, you cannot open the linked model in the same Revit Structure session. However, you can transfer project standards from the linked model to the host model using the Transfer Project Standards tool. See Transferring Project Standards on page 1635.

Linking and Worksharing

If you enable worksharing, your links are contained in worksets. If you update a linked file and want to reload the link, the workset in which the link is located must be editable. If it is not, an error message appears indicating that the link could not be updated because of the workset’s non-editable status. See Making Worksets Editable on page 1223.

It is good practice to assign a team member to track links and be sure the appropriate worksets are editable. After updating the link, the team member should synchronize with central so that all team members have the updated link. See Saving Workshared Files on page 1225.

Also, you may want to create a workset exclusively for links, so that workflow is not interrupted. See Setting Up Worksets on page 1212.

Directory Paths for Linked Models

A relative path defines the position of a linked file in a working directory such as a project folder. Its position is defined by its relative location. An absolute path defines the location of a linked file on a disk or network drive.

In general, you should use a relative path instead of an absolute path.

- If you use a relative path and later move the project and the linked file together to a new directory, the link is maintained. Revit Structure tries to find the linked model by its relative position to the working directory.

- If you use an absolute path and later move the project and the linked file to a new directory, the link is broken. Revit Structure tries to find the linked model in the specified directory.

An absolute path may be preferable when you link in a workshared project, such as a central model that other users need to access. This file is likely not to move from its location on disk.

In the following image, a simple directory structure is used as an example.
In this instance, absolute and relative paths are defined as follows. Note the folder Working Directory. This has been named as such for illustrative purposes. A working directory can possess any name.

<table>
<thead>
<tr>
<th>File</th>
<th>Absolute Path</th>
<th>Relative Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>sourcefile.rvt</td>
<td>C:\My Revit\Working Directory\source-file.rvt</td>
<td>source-file.rvt</td>
</tr>
<tr>
<td>file_01.rvt</td>
<td>C:\My Revit\Reference\file_01.rvt</td>
<td>..\Reference\file_01.rvt</td>
</tr>
<tr>
<td>file_02.rvt</td>
<td>C:\My Revit\Working Directory\Support Files\Detailing\file_02.rvt</td>
<td>Support Files\Detailing\file_02.rvt</td>
</tr>
</tbody>
</table>

If the working directory is moved or renamed, paths can become unresolved (broken). In the following image, the working directory has been moved to the My Documents directory to illustrate this.

Now all of the original absolute paths are unresolved because they point to a specific location. The relative path to file_01.rvt is also broken as it resided outside of the working directory and didn't move with it.

**Workflow for Linking Models**

The following is a typical workflow for using linked models. Your implementation may differ depending on your project needs.

**To link models**

1. Create a project for each individual piece of the larger project.
   For example, for a campus, create a separate project for each campus building. For a large building, create a project for each separately managed piece of the project. If a large building has 2 towers, for instance, create a separate project for each tower.

2. Create another project to act as the main project that will link to the other projects.
3 Open the main project, and link in the projects containing the individual pieces. See Linking One Model to Another on page 1184.

4 Place the linked models in the desired positions.
   When you link models to the main project, you can share the coordinates of the project so that you can correctly position the model. See Shared Positioning on page 1265.

Related topics
- Overview of Linked Models on page 1177
- Linking Revit Models on page 1183
- Visibility of Linked Models on page 1187

Linking Revit Models

You can link Revit models to another model to more easily manage the individual parts or to improve performance when working on a large project.

Related topics
- Overview of Linked Models on page 1177
Linking One Model to Another

1. Open an existing project or start a new project.
   You will link another project into this project.

2. Click Insert tab ➤ Link panel ➤ (Link Revit).

3. In the Import/Link RVT dialog, select the Revit model to link.

4. For Positioning, specify the desired option.
   In most cases, you should select Auto - Origin to Origin.
   If the current project uses shared coordinates, select Auto - By Shared Coordinates. See Shared Positioning on page 1265.
   See Import and Link Options for CAD Formats and Revit Models on page 63.

5. Click Open.

If you cannot see the linked project in the drawing area, do the following:

1. In the view properties, for Discipline, select Coordination.
   This setting ensures that the view displays elements for all disciplines (architectural, structural, mechanical, and electrical).

2. (Optional) To display the linked project in half-tone, for Visibility/Graphics Overrides, click Edit. On the Revit Links tab, for the linked project, select Halftone, and click OK.

You can select the linked model in a view and drag, copy, paste, move, and rotate it. You can also monitor grids, levels, and other essential elements in the linked project. See Multi-Discipline Coordination on page 1239.

Showing or Hiding Nested Models

When linked models are nested, you can control the display of the nested models. See Nesting Linked Models on page 1179.

1. Open the parent model to which the nested model is linked.

2. Click Manage tab ➤ Manage Project panel ➤ (Manage Links).

3. In the Manage Links dialog, click the Revit tab.

4. In the Reference Type column, change the value for the linked model to one of the following:
   - Attachment. Makes the linked model visible when its host is linked into another model.
   - Overlay. Does not load the linked model when its host is linked into another model. This is the default setting. When the Overlay option is selected and you import a model that contains nested links, a message displays indicating that the imported model contains nested links and that they will not be visible in the host model.

5. Save and close the file.
Related topics

- Visibility of Linked Models on page 1187
- Using Custom Settings to Display Linked Models on page 1194

Mapping Phases Between Linked Models

You can manually set up a correspondence between phases in the host model and phases in the linked model. See Phases and Linked Models on page 1180.

**To map phases in the linked model**

1. In the drawing area of the host model, select the linked Revit model.
2. Click Modify | RVT Links tab ➤ Properties panel ➤ (Type Properties).
3. In the Type Properties dialog, find the Phase Mapping parameter and click Edit.
4. In the Phases dialog, select the appropriate mapping options for each phase, and click OK.
5. Click OK to exit the Type Properties dialog.

**To apply phase mapping in the host model**

1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
2. In the Visibility/Graphics dialog, click the Revit Links tab.
3. Click the button in the Display Settings column for the linked Revit model.
4. In the RVT Link Display Settings dialog, on the Basics tab, select By Host View or Custom.
   - If you select Custom, for Phase, select By Host View.
5. Click OK twice to exit the Visibility/Graphics dialog.

Copying a Linked Model in the Host Model

You can copy a linked model to create multiple instances in the host model. For example, in the following image, building 2 and building 3 are copies of the same linked model.
To copy a linked Revit model to another project file

1. Open the project file that contains the link to copy, and open the file to copy it into.
2. Select the linked model in the drawing area.

3. Click Modify | RVT Links ➤ Clipboard panel ➤ (Copy to Clipboard).
4. Click View tab ➤ Windows panel ➤ Switch Windows drop-down, and select the project name to copy the linked model into.

5. Click Modify tab ➤ Clipboard panel ➤ Paste drop-down ➤ (Paste from Clipboard).
6. Click in the drawing area to place the linked model.

7. Click Edit Pasted panel ➤ (Finish) to complete the paste operation.
   
If you want to edit the pasted linked model, click Edit Pasted Elements. See Editing Pasted Elements on page 1495.

Copying Elements from a Linked Model

Elements from linked Revit models can be copied to the clipboard and then pasted into the host model.

To copy and paste elements from linked Revit models

1. In the drawing area of a view of the host model, move the cursor over the element in the linked model.
2. Press Tab until the element to copy is highlighted, and click to select it.

3. Click Modify | RVT Links ➤ Clipboard panel ➤ (Copy to Clipboard).
4. Navigate to the position in the project where you want to paste the element.

5. Click Modify tab ➤ Clipboard panel ➤ Paste drop-down ➤ (Paste from Clipboard).
   
Alternatively, you can click Modify tab ➤ Clipboard panel ➤ Paste drop-down ➤ Aligned to Same Place to paste the element into the same place from where you copied it. For more information on paste options, see Pasting Elements on page 1493.

6. Click in the drawing area to place the element.

7. Click Edit Pasted panel ➤ (Finish) to complete the paste operation.

Selecting Elements in a Linked Model

1. In the drawing area of a view of the host model, move the cursor over the element in the linked model.
2. Press Tab until the desired element is highlighted, and click to select it.
Visibility of Linked Models

When a host model includes linked models and nested linked models, you can control

- whether linked models and nested models display in the host model overall
- whether linked models and nested models display in specific views of the host model
- the graphics used to display linked models and nested models in views

Related topic
- Visibility and Graphic Display in Project Views on page 801

Overview of Visibility of Linked Models

Parameters that control the visibility and graphics of linked Revit models are grouped under their own tab, Revit Links, in the Visibility/Graphics dialog. This dialog is arranged in a tree structure with the parent nodes referring to separate files (the primary linked model), and the child nodes referring to instances (copies) of the model in the project. Changing the parent node affects all instances, while changing a child node affects only that instance.

The Revit Links tab in the Visibility/Graphics dialog contains the following columns:

- **Visibility**: Select the check box to show the linked model in the view, or clear the check box to hide the linked model.
- **Halftone**: Select the check box to draw the linked model in halftone. (See Halftone/Underlay on page 1605.)
- **Display Settings**: Options to override additional settings for each linked model in the current host view. The button displays the current display setting state (By Host View, By Linked View, or Custom). See Using View Filters for Linked Models on page 1188.

Visibility for linked Revit models is controlled by view. You can use a view template to save the visibility settings of a particular view and then apply it to other views. See View Templates on page 1637.

Related topic
- Changing Line Styles in a Linked Model on page 1501
**View Filters for Linked Models**

You can control the visibility and graphics of linked models and nested linked models in a view of a host model.

For a host view, you can indicate whether linked models and nested models display using

- A filter from the host model
- The filter applied to a view in the linked model or the nested model
- No filters

You can also control the display of instances of linked models in a host view. For example, if a model is linked to the host model multiple times, you can control the display of each linked instance individually. The view filter functions that apply to linked models also apply to instances of linked models.

**Related topics**

- Controlling Visibility and Graphic Display of Elements Using Filters on page 806
- Displaying a Linked Model by Host View on page 1192
- Displaying a Linked Model by Linked View on page 1193
- Using Custom Settings to Display Linked Models on page 1194

**Using View Filters for Linked Models**

To control the use of filters for linked models in a host view, use settings on the RVT Link Display Settings dialog.

### RVT Link Display Settings

<table>
<thead>
<tr>
<th>Settings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>By host view</td>
<td>Applies the filter (and other visibility/graphics settings) for the host view to elements in the host model, the linked model, and any nested models.</td>
</tr>
</tbody>
</table>
### Setting | Description
--- | ---
By linked view | Applies the filter (and other visibility/graphics settings) for the host view to the host model only. The linked model and any nested models display as defined by the specified linked view.

Custom | Allows more customization of visibility and graphics settings for linked models and nested models in the host view.

Linked view | Available only for Custom or By linked view. Specifies the view in the linked model whose settings are to be used to display the linked model (and nested models, unless other settings specify otherwise) in the host view.

View filters | Available only for Custom. Specifies whether the linked model displays using the filter applied to the linked view or the host view. Does not control the display of nested models.

Nested links | Available only for Custom. Specifies how nested linked models display in the host view.

### Related topics
- Displaying a Linked Model by Host View on page 1192
- Displaying a Linked Model by Linked View on page 1193
- Using Custom Settings to Display Linked Models on page 1194

### Examples of Using View Filters for Linked Models
In the following examples, host model C contains square walls, linked model B contains circular walls, and nested linked model A contains triangular walls.

<table>
<thead>
<tr>
<th>Host model C</th>
<th>Linked Model B</th>
<th>Nested Model A</th>
<th>Host model C displaying linked model B and nested model A</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Host model C" /></td>
<td><img src="image2" alt="Linked Model B" /></td>
<td><img src="image3" alt="Nested Model A" /></td>
<td><img src="image4" alt="Host model C displaying linked model B and nested model A" /></td>
</tr>
</tbody>
</table>

With the diagonal blue filter applied | With the solid orange filter applied | With the horizontal green filter applied | With all 3 filters displayed in the host view
You can apply a filter to a view of host model C, and also apply it to linked model B and nested model A. Or you can specify that linked model B and nested model A should display in host model C using a filter applied in models B or A, or using no filters at all.

The following examples demonstrate these different effects by applying filters that change wall colors and patterns. However, you can use these same strategies to show, hide, or change any view-specific settings that filters can control.

In the following table, the In Host Model C column shows settings that you must specify on the Basics tab of the RVT Link Display Settings dialog when you open host model C in Revit Structure. The In Linked Model B column shows settings that you must specify on the Basics tab of the RVT Link Display Settings dialog when you open linked model B.

<table>
<thead>
<tr>
<th>Goal</th>
<th>Result</th>
<th>In Host Model C</th>
<th>In Linked Model B</th>
</tr>
</thead>
<tbody>
<tr>
<td>The filter applied to a view of host model C also applies to linked model B and nested model A.</td>
<td>By host view.</td>
<td>(none required)</td>
<td></td>
</tr>
<tr>
<td>The filter applied to a view of host model C applies to that model only. Linked model B and nested model A display with a filter applied to a view in linked model B.</td>
<td>By linked view. Linked view: Select a view in the linked model to which a filter (solid orange) was applied.</td>
<td>Its linked model (nested model A) is displayed by host view.</td>
<td></td>
</tr>
<tr>
<td>The filter applied to a view of host model C applies to that model only. Linked model B displays with a filter applied to a view in linked model B.</td>
<td>By linked view. Linked view: Select a view</td>
<td>Its linked model (nested model A) is displayed by host view.</td>
<td></td>
</tr>
<tr>
<td>Goal</td>
<td>Result</td>
<td>In Host Model C</td>
<td>In Linked Model B</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Nested model A displays with a filter applied to a view in nested model A.</td>
<td>in the linked model to which a filter (solid orange) was applied.</td>
<td>Custom. Linked view: Select a view in the linked model to which a filter was applied. View filters: By host view. Nested links: By linked view.</td>
<td>Its linked model (nested model A) is displayed by linked view. In nested model A, a horizontal green filter is applied to the view.</td>
</tr>
<tr>
<td>The filter applied to a view of host model C also applies to linked model B. Nested model A displays with a filter applied to a view in linked model B.</td>
<td>Custom. Linked view: Select a view in the linked model to which a filter (solid orange) was applied. View filters: By host view. Nested links: By linked view.</td>
<td>View filters: By host view. Nested links: By linked view.</td>
<td>Its linked model (nested model A) is displayed by host view.</td>
</tr>
<tr>
<td>The filter applied to a view of host model C also applies to linked model B. Nested model A displays as it does in a view of nested model A.</td>
<td>Custom. Linked view: Select a view in the linked model in which a filter (horizontal green) was applied to nested model A. View filters: By host view. Nested links: By linked view.</td>
<td>(none required)</td>
<td></td>
</tr>
<tr>
<td>The filter applied to a view of host model C applies to that model only. Linked model B and nested model A display according to a view in linked model B, but with no filters applied to it.</td>
<td>Custom. Linked view: Select a view in the linked model. View filters: None.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Goal</td>
<td>Result</td>
<td>In Host Model C</td>
<td>In Linked Model B</td>
</tr>
<tr>
<td>------</td>
<td>--------</td>
<td>----------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Nested links: By parent link.</td>
<td>Custom. Linked view: Select a view in the linked model. View filters: None. Nested links: By linked view.</td>
<td>Its linked model (nested model A) is displayed by linked view.</td>
<td></td>
</tr>
</tbody>
</table>

The filter applied to a view of host model C applies to that model only. Linked model B displays according to a view in linked model B, but with no filters applied to it. Nested model A displays according to a view in nested model A.

**Related topics**

- Displaying a Linked Model by Host View on page 1192
- Displaying a Linked Model by Linked View on page 1193
- Using Custom Settings to Display Linked Models on page 1194

### Displaying a Linked Model by Host View

To specify that a filter and other graphic overrides applied to a view of the host model should also apply to linked models and nested models in the view, use the By Host View setting (the default).

1. Open the view in the host model.

2. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).

3. On the Visibility/Graphic Overrides dialog, do the following, as desired:
   - Specify **overrides** for model categories, annotation categories, and imported categories in the view.
   - Add a **filter** to apply to the host view.

4. On the Revit Links tab, for the linked model, do the following:
   - In the Visibility column, select the check box.
   - In the Display Settings column, make sure that By Host View displays.

If By Host View does not display, click in the Display Settings column. On the Basics tab of the RVT Link Display Settings dialog, select By host view, and click OK.
5 Click OK.

The specified view filter applies to the host model, the selected linked model, and its nested linked models (that is, any models that are linked to the linked model).

Related topics

- Examples of Using View Filters for Linked Models on page 1189
- Displaying a Linked Model by Linked View on page 1193
- Using Custom Settings to Display Linked Models on page 1194

Displaying a Linked Model by Linked View

If you want a linked model to display in a host view as it would appear in the linked model, use the By Linked View setting.

1 Open the view in the host model.

2 Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).

3 On the Revit Links tab, for the linked model, do the following:
   a In the Visibility column, select the check box.
   b Click in the Display Settings column.

4 In the RVT Link Display Settings dialog, on the Basics tab, do the following:
   a Select By linked view.
   b For Linked view, select the view in the linked model whose display settings you want to use for the linked model in the current host view.

   ![RVT Link Display Settings dialog](image)

   For example, if the selected view has a filter applied, then that filter will apply to the linked model in the current host view, too.

5 Click OK twice.

If the linked model contains another linked model (a nested model), then the nested model displays in the host model according to the settings defined for the linked view.

Related topics

- Examples of Using View Filters for Linked Models on page 1189
- Displaying a Linked Model by Host View on page 1192
- Using Custom Settings to Display Linked Models on page 1194
Using Custom Settings to Display Linked Models

You can change various display settings for a linked model in a host view. To understand the effects of various filter-related settings on linked models and nested models, see Examples of Using View Filters for Linked Models on page 1189.

1 Open the view in the host model.

2 Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
3 On the Revit Links tab, for the linked model, do the following:
   a In the Visibility column, select the check box.
   b Click in the Display Settings column.
4 In the RVT Link Display Settings dialog, on the Basics tab, do the following:
   a If you selected a linked model instance, select Override display settings for this instance.
   b Select Custom.
   c For Linked view, select the view in the linked model whose display settings you want to use for the linked model in the current host view.
   d For View filters, select one of the following values to affect the linked model (but not nested linked models):
      ■ By host view. Display the linked model using filters applied to the current view of the host model.
      ■ By linked view. Display the linked model using filters applied to the specified linked view.
      ■ None. Do not apply filters to the linked model in the current view of the host model.
   e For Nested links, select one of the following values:
      ■ By parent link. Display nested linked models using the visibility and graphic override settings specified for its parent linked model.
      ■ By linked view. Display nested linked models using the visibility and graphic override settings specified in the top-level nested linked model.
5 For the remaining options, select the desired value to control graphic display of the linked model:
- By host view. Display the linked model using the visibility and graphic settings specified for the host view.
- By linked view. Display the linked model using the visibility and graphic settings for the specified linked view.

6 To override visibility settings for model categories, annotation categories, import categories, or design options, click the tab, and select Custom from the drop-down list.

Related topics
- Displaying a Linked Model by Host View on page 1192
- Displaying a Linked Model by Linked View on page 1193

Hiding a Linked Model in a View

After linking a model to a project, you can change a visibility setting so the linked model does not display in a particular view.

1 Open the view where you want to hide the linked model.

2 Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
3 In the Visibility/Graphic Overrides dialog, click the Revit Links tab.
4 In the Visibility column, clear the check box for the linked model.
5 Click OK.

Displaying a Linked Model in Halftone

After linking a model to a project, you can change a visibility setting so the linked model displays in halftone in the current view.

1 Open the view where you want to change the display of the linked model.

2 Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
3 In the Visibility/Graphic Overrides dialog, click the Revit Links tab.
4 In the Halftone column, select the check box for the linked model.
5 Click OK.

Linked Models in Schedules

To include data from linked models in schedules, do the following:

1 Enable elements from linked models to be included in the schedule.
2 Specify which linked models should be visible in the schedule.
3 (Optional) Include project parameters or area schemes from linked models in the schedule.
Overview of Linked Models in Schedules

You can include elements from linked models in schedules of model elements (such as walls, floors, and roofs) and in drawing lists. They are not supported for note blocks, view lists, or key schedules.

All fields that are available for elements in the host project are available for elements in linked models. The behavior of some fields changes when you add elements from linked models to a schedule. For example, the Family, Type, Family and Type, Level, and Material parameters become read-only for elements in both the host and linked models. You also cannot filter a schedule by the Family, Type, Family and Type, Level, or Material parameters.

You can include project information (such as the client name or the project address) and information about the linked Revit model (such as the instance name or the file name) in a schedule. Including information about the linked Revit model is useful when you have multiple copies of a linked model in your project (for example, multiple identical buildings on a site or multiple identical floors in a building) and you need to identify in the schedule which instance of the linked model each element comes from.

Related topics
- Including Elements from Linked Models in a Schedule on page 1196
- Controlling Visibility of Linked Models in a Schedule on page 1197
- Including Project Parameters or Area Schemes from Linked Models in a Schedule on page 1197
- Schedule Overview on page 771

Including Elements from Linked Models in a Schedule

1. Open the schedule in the host project.
2. On the Properties palette, for Fields, click Edit.
3. Select Include elements in linked files.
   Information about model elements in linked models is now available to the schedule.
4. To include project information from a linked model, for Select Available Fields From, select Project Information. Add the desired fields from the Available Fields list to the Scheduled Fields list.
5. To include the linked model instance name or file name, for Select Available Fields From, select RVT Links. Add the desired fields from the Available Fields list to the Scheduled Fields list.

   **NOTE** In the schedule, the file name does not include the file path or the file extension. In addition, if there are visible nested links in a linked model, the file name that displays for elements in the nested link is the parent link.

6. Click OK.

Now you can specify which linked models should be visible in the schedule.

Related topics
- Overview of Linked Models in Schedules on page 1196
- Including Project Parameters or Area Schemes from Linked Models in a Schedule on page 1197
- Schedule Overview on page 771
Controlling Visibility of Linked Models in a Schedule

1 Open a schedule view.

2 Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).

   **NOTE** If Visibility/Graphics is disabled, allow elements from linked models to be included in the schedule. Then try again.

3 In the Visibility for Schedule dialog, do one of the following:
   - To omit a linked model or instance from the schedule, clear its check box in the Visibility column.
   - To include a linked model or instance in the schedule, select its check box in the Visibility column. Then click in the Display Settings column. On the Basics tab of the RVT Link Display Settings dialog, select By Host View, By Linked View, or Custom. Then specify values for other options to control the display of model elements from the linked model (and its nested models) in the schedule of the host model.

4 If the linked file includes design options, select design options to include in the reported schedule data. On the Design Options tab of the Visibility for Schedule dialog, for each design option set, select the desired design option from the drop-down list.

Related topics
- Overview of Linked Models in Schedules on page 1196
- Including Elements from Linked Models in a Schedule on page 1196
- Including Project Parameters or Area Schemes from Linked Models in a Schedule on page 1197
- Schedule Overview on page 771

Including Project Parameters or Area Schemes from Linked Models in a Schedule

1 In the linked model, create a schedule that contains a project parameter or area schemes. Be sure that the schedule has a unique name (one that is different from any schedules that currently exist in the host project).

2 Add the schedule to a sheet.

3 Select the schedule on the sheet, and click Modify | Schedule Graphics tab ➤ Clipboard panel ➤ (Copy to Clipboard).

4 Open the host project.

5 If needed, **unload** the linked model.

6 In the host project, open a sheet view.

7 Click Modify tab ➤ Clipboard panel ➤ Paste drop-down ➤ (Paste from Clipboard).

8 If you unloaded the linked Revit model, **reload** it.

The project parameters or area schemes are now available for scheduling in the host project.
Visibility of Worksets for Linked Models

When a workshared model is linked to another model, you may want to control whether worksets from the linked model display in a view of the host model. Use the Worksets tab on the RVT Link Display Settings dialog for the host model. On this tab, you can select the specific worksets to display in a view of the host model.

Controlling Visibility of Linked Worksets in the Host Project

1. Link a workshared model to the host model.
2. In the host model, open a view where you want to see worksets from the linked model.
3. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
4. On the Revit Links tab, do the following:
   a. In the Visibility column, select the check box for the linked model.
   b. Click in the Display Settings column.
5. In the RVT Link Display Settings dialog, do the following:
   a. On the Basics tab, select Custom.
   b. On the Worksets tab, for Worksets, select one of the following values:

<table>
<thead>
<tr>
<th>Value</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>By host view</td>
<td>If a workset in the linked model has the same name as a workset in the host model, the linked workset displays according to the settings for the corresponding host workset.</td>
</tr>
</tbody>
</table>
If there is no corresponding workset in the host model, the linked workset displays in the host view.

<table>
<thead>
<tr>
<th>Value</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>By linked view</td>
<td>A workset that is visible in the linked view (specified on the Basics tab) will be visible in the view of the host model. For more information, see Visibility of Worksets on page 1230.</td>
</tr>
<tr>
<td>Custom</td>
<td>In the list, select a workset from the linked model to make it visible in the view of the host model.</td>
</tr>
</tbody>
</table>

6 Click OK twice.

NOTE A linked workset must be open to display in a host view. See Opening Linked Worksets in the Host Model on page 1199.

**Opening Linked Worksets in the Host Model**

To be able to display a workset from a linked model in a host view, the workset must be open when you load the linked model into the host model.

1 In the host model, click Manage tab ➤ Manage Project panel ➤ (Manage Links).
2 In the Manage Links dialog, click the Revit tab.
3 On the Revit tab, select the linked model, and click Manage Worksets.
4 In the Linking Worksets dialog, select a workset, and click Open.
5 Click Reload to reload the linked model and open the specified worksets.

Related topic
- Controlling Visibility of Linked Worksets in the Host Project on page 1198

**Troubleshooting Issues with Visibility of Linked Models**

Read the following topics to learn how to resolve issues with linked models that do not display as intended.

**Annotations from a Linked View Do Not Display**

**Symptom:** In a host view, you are displaying a linked model using the By linked view option. However, the annotations in the specified linked view do not display in the host view.

**Issue:** The linked view must be a plan view, or a section view or an elevation view that is parallel to the host view. Otherwise, the host view will not be able to display the following:

- view-specific elements (such as annotations and details)
- non-view-specific elements (such as datum extents and leaders)

**Solution:** When using By linked view or Custom, specify a linked view that is a plan view, a parallel section view, or a parallel elevation view. See Visibility of Linked Models on page 1187.

### Unable to See a Linked Model in a Host View

**Symptom:** You have linked a model into the current project, but you cannot see the linked model in some views.

**Issues and Solutions:** To determine the source of the problem and resolve it, try the following:

- **Reveal hidden elements:** Open the view in the host model and click (Reveal Hidden Elements) on the View Control Bar. The drawing area displays a magenta border, and hidden elements display in magenta. If the linked model displays in magenta, right-click it, and click Override Graphics in View ➤ By Category. On the Revit Links tab of the Visibility/Graphics Overrides dialog, select the check box in the Visibility column for the linked model.

- **Check display settings:** If the Visibility setting is already turned on for the linked model, check the Display Settings column of that dialog. If it is set to By Linked View or Custom, click the value to display the RVT Link Display Settings dialog. Check whether the selected linked view, view filters, or other settings might prevent the linked model from displaying in the host view.

### Unable to See Worksets of a Linked Model in the Host Project

**Symptom:** In a view of the host project, you are not able to see worksets of a linked model that is workshared.

**Issue:** The visibility settings for the worksets of the linked model are not defined properly, or the worksets are not open.

**Solutions:**

- In the host view, change the visibility settings for the linked model. See Controlling Visibility of Linked Worksets in the Host Project on page 1198.

- In the host project, open the worksets in the linked model. See Opening Linked Worksets in the Host Model on page 1199.

### Tagging Elements in Linked Models

When tagging elements in a view of a host model (C), you can also tag elements from linked models (B) and nested models (A).
Use the Tag or Tag All tool to tag linked elements while also tagging elements in the host model.

**Overview of Tagging Elements in Linked Models**

In a host view, when you tag elements from a linked model, the tags exist only in the host model. They do not exist in the linked model.

When you tag host elements, you can sometimes edit the value that displays in the tag, thereby changing the properties of the element. When you tag linked elements, however, you cannot edit the tag to change the properties of the linked element.

**Related topics**

- What Elements Can I Tag in Linked Models? on page 1201
- What Happens to Tags When a Linked Model is Unavailable? on page 1202
- What Happens to Tags When Linked Elements Are Changed or Deleted? on page 1202
- Reviewing Orphaned Elements from Linked Models on page 1203

**What Elements Can I Tag in Linked Models?**

In linked models and nested models, you can tag elements from most categories. However, you cannot place the following on elements in linked models:

- Keynote tags
- Room tags
- Area tags
- Space tags
- Zone tags
- Beam system tags
- Floor span symbols
- Path reinforcement span symbols
- Area reinforcement span symbols

**Related topics**

- What Happens to Tags When a Linked Model is Unavailable? on page 1202
- What Happens to Tags When Linked Elements Are Changed or Deleted? on page 1202
- Overview of Tagging Elements in Linked Models on page 1201
- Reviewing Orphaned Elements from Linked Models on page 1203
What Happens to Tags When a Linked Model is Unavailable?

Suppose you annotate a host view and tag elements in linked models. If the linked model later becomes unavailable, the tags may or may not persist, as follows.

<table>
<thead>
<tr>
<th>When the linked model is...</th>
<th>Tags for linked elements...</th>
<th>When the linked model is restored, ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unloaded or missing</td>
<td>no longer display in the host view.</td>
<td>tags for linked elements display in the correct positions.</td>
</tr>
<tr>
<td>Removed or deleted</td>
<td>are deleted from the host project.</td>
<td>tags must be reapplied to linked elements.</td>
</tr>
</tbody>
</table>

Related topics
- What Happens to Tags When Linked Elements Are Changed or Deleted? on page 1202
- Reviewing Orphaned Elements from Linked Models on page 1203
- Unloading and Reloading Linked Models on page 1203

What Happens to Tags When Linked Elements Are Changed or Deleted?

Suppose you tag a linked element in the host model, and the element moves in the linked model. Its tag moves with the element in the host view, maintaining the same relative position to the host.

If a tag’s linked element no longer exists, the tag is orphaned. The orphaned tag remains in the host view as long as the linked model is loaded. The tag does not display a leader. If the tag usually displays a parameter value, it now displays a question mark (?). The orphaned tag will be included when the view is printed or exported. You can move, delete, or rehost the orphaned tag.

Related topics
- What Elements Can I Tag in Linked Models? on page 1201
- What Happens to Tags When a Linked Model is Unavailable? on page 1202
- Reviewing Orphaned Elements from Linked Models on page 1203
- Unloading and Reloading Linked Models on page 1203

Linked Model Instance Properties

To modify the properties of a linked model, select the linked model in the drawing area, and access the Properties palette.

You can also see the properties of an element contained in a linked model. Move the cursor over the element in the linked model and press Tab to highlight the element. The properties display on the Properties palette. Properties for elements in linked models are read-only.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the linked model instance. Names of linked models are useful when you have multiple copies of the same linked model in a project and need to add the</td>
</tr>
</tbody>
</table>
linked model elements to a schedule. See Including Elements from Linked Models in a Schedule on page 1196.

Shared Position

Specifies the shared coordinates for the linked model. See Shared Positioning on page 1265.

Linked Model Type Properties

To modify the type properties of a linked model, select the linked model in the drawing area, and click Modify | RVT Links tab ➤ Properties panel ➤ (Type Properties).

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Room Bounding</td>
<td>Makes the host project recognize the Room Bounding property of elements in the linked model.</td>
</tr>
<tr>
<td>Reference Type</td>
<td>Determines whether this linked model will be shown (Attachment) or hidden (Overlay) when the host model is linked into another model. See Showing or Hiding Nested Models on page 1184.</td>
</tr>
<tr>
<td>Phase Mapping</td>
<td>Allows you to set up a correspondence between phases in the host model and phases in the linked model. See Mapping Phases Between Linked Models on page 1185.</td>
</tr>
</tbody>
</table>

Managing Links

If the source file of the link in your project has changed, Revit Structure automatically updates the link when you open the project. To access tools for link management, click Manage tab ➤ Manage Project panel ➤ (Manage Links).

Unloading and Reloading Linked Models

To update linked models without closing the current project, you can unload and reload the linked models.

1. Click Manage tab ➤ Manage Project panel ➤ (Manage Links).
2. In the Manage Links dialog, click the Revit tab.
3. Select the linked model.
4. To unload the selected model, click Unload. Click Yes to confirm.
5. To reload the selected model, click Reload.

Reviewing Orphaned Elements from Linked Models

Elements and tags can become orphaned in the following cases:

- In the host project, you added an element that was hosted by an element in a linked model. The linked element was later moved or deleted.
In a host view, you added a tag to an element in a linked model. The linked element was later deleted from the linked model.

NOTE Tags can also become orphaned as a result of certain functions, such as Mirror, or Cut and Paste. These functions delete the original element and create a copy with a different ID, which can result in an orphaned tag.

You can review these orphaned elements and tags and select new hosts or delete them from the host project.

To review orphaned elements

1. Click Collaborate tab ➤ Coordinate panel ➤ (Reconcile Hosting).
   The Reconcile Hosting browser displays. By default, it is docked on the right side of the Revit window. You can move it by dragging its title bar to the desired location.

2. (Optional) To locate orphaned elements, do the following:
   - Change graphics
     a. In the Reconcile Hosting browser, click Graphics.
     b. In the Graphics dialog, select Apply settings to elements in the list.
     c. Specify values for Weight, Color, and Pattern.
        The project displays orphaned elements using these settings.
   - Show an orphaned element
     a. In the Reconcile Hosting browser, select the orphaned element to locate.
     b. Click Show.
        Revit Structure displays the orphaned element, opening another view and zooming in, if needed.

3. To delete an orphaned element that is no longer needed, select the element in the Reconcile Hosting browser, right-click, and click Delete.
4. To rehost an orphaned element, select the element in the Reconcile Hosting browser, right-click, and click Pick Host. Then in the drawing area, select the new host.

Related topics

- Unloading and Reloading Linked Models on page 1203
- What Happens to Tags When a Linked Model is Unavailable? on page 1202
- What Happens to Tags When Linked Elements Are Changed or Deleted? on page 1202
Rehosting Orphaned Elements

Use this procedure to pick a new host for the following:

- **orphaned tags** on page 1202 for linked elements in a host view
- **orphaned elements** (elements that were hosted by a linked element, and the linked element has been deleted)

**To pick a new host**

1. In the host view, select the orphaned element or tag.
2. On the ribbon, click (Pick New Host).
3. Select the new host for the orphaned element or tag.
   - For example, for an orphaned element that is wall-hosted, select a wall as its host. For an orphaned tag, select an element.

**Related topic**

- [Reviewing Orphaned Elements from Linked Models](#) on page 1203

Unresolved References

If you open a file containing unresolved references, the Unresolved References dialog opens. There are two means of determining unresolved references in a file.

- Use the Show details option in the Unresolved References dialog.
- Click Open Manage Links to correct the problem from the Unresolved References dialog.

**NOTE** You can also open the Manage Links dialog from the project. Click Manage tab ➤ Manage Project panel ➤ Manage Links.

**To re-establish unresolved references**

1. In the Manage Links dialog, click the file type tab of the unresolved link, either CAD Formats, Revit, or DWF Markups. Unresolved links are listed as Not Found in the Status column.
2. Select the file in the Linked File column.
3. Click Reload From.
4. In the file browser, navigate to the new location of the linked file and select it.
5. Click Open.
6. If possible, it is recommended to set the Path Type to Relative. This will maintain the link in most future cases. Otherwise, select Absolute.
7. Repeat steps 2 through 6 for any other unresolved links in the file.
8. Click OK to close the Manage Links dialog.
Manage Links Dialog

The Manage Links dialog has tabs for CAD Formats, Revit models, and DWF Markups. Under the tabs are columns that provide information about the linked file.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linked File</td>
<td>Indicates the name of the file being linked.</td>
</tr>
<tr>
<td>Status</td>
<td>Indicates whether the linked file is loaded in the host model. The field will display as Loaded, Not Loaded, or Not Found.</td>
</tr>
<tr>
<td>Reference Type (Revit models only)</td>
<td>Determines whether this linked model will be shown (Attachment) or hidden (Overlay) when the host file is linked into another model. See Showing or Hiding Nested Models on page 1184.</td>
</tr>
<tr>
<td>Positions Not Saved</td>
<td>Indicates if the linked model's position is saved in the shared coordinate system. See Shared Positioning on page 1265 and Defining Named Positions on page 1265.</td>
</tr>
<tr>
<td>Size</td>
<td>Size of the linked file.</td>
</tr>
<tr>
<td>Saved Path</td>
<td>Location of the linked model on your computer. In worksharing, this is the location of the central file.</td>
</tr>
<tr>
<td>Path Type</td>
<td>Indicates whether the linked model's saved path is relative or absolute. See Link Management Options on page 1206.</td>
</tr>
<tr>
<td>Local Alias (Revit models only)</td>
<td>Location of the linked model if it is a local copy of a central file. For more information on the central file and worksharing, see Working in a Team on page 1209.</td>
</tr>
</tbody>
</table>

Link Management Options

To manage links in your file, select them in the Manage Links dialog. You can select multiple links to modify by pressing Ctrl and clicking on the number of the link in the dialog. The following tools are available for the selected links.

- **Save Positions.** Saves positions for the linked instance. See Defining Named Positions on page 1265.
- **Save Markups.** Saves changes to imported DWF markups. For more information on imported markups, see Linking DWF Markup Files on page 74.
- **Remove.** Removes the link from the project.

**NOTE** When you remove the link from the project, Revit Structure stops monitoring any elements in the linked model. See Stopping Element Monitoring on page 1254.
- **Reload From.** Changes the path of the link if the linked file has been moved. See [Unresolved References](#) on page 1205.

- **Unload.** Removes the display of the linked model in the project but continues the link.

- **Reload.** Loads the latest version of the linked model. You can also close the project and reopen it, and the linked model is reloaded.

- **Import.** Embeds the model into the project. This option is not available for Revit models.

- **Located In.** Lists the sheet that contains the DWF markup import symbol.

- **Preserve graphic overrides.** Maintains any graphic overrides on DWG, DXF, and DGN links, when the links are reloaded.

- **Reference Type drop-down.** Specifies whether this nested linked model is shown (Attachment) or hidden (Overlay) when the host model is linked into another model. See [Showing or Hiding Nested Models](#) on page 1184.

- **Path Type drop-down.** Specifies whether a nested model’s file path is Relative or Absolute. The default is Relative.

- **Manage Worksets.** Opens the Linking Worksets dialog, where you can open and close worksets in a linked model. See [Opening Linked Worksets in the Host Model](#) on page 1199.
Working in a Team

You can work in a team in Revit Structure using worksharing or linked models.

Worksharing allows simultaneous access to a shared model through use of a central model. Use worksharing when you are working with a single model (one RVT file) that will have multiple team members working on it.

Using linked models, project elements or systems are separated into individually managed models that can be linked together. Use linked models when your project contains distinct buildings, such as a campus, or when you are working with team members from other disciplines, such as architects or MEP engineers. You can also use worksharing in linked models.

Worksharing is covered in this topic; for information on linked models, see Linked Models on page 1177.

Worksharing Workflow

The following steps provide the general workflow for setting up and using workshared projects.

1 Select the project to share.
   A workshared project is one that several team members need to work on at the same time. For example, a team may have different members assigned to work on specific functional areas, such as the interior layout, the exterior shell, and the furniture layout.

2 Enable worksharing.
   When you enable worksharing, Revit Structure creates the central model for the project. The central model is like the project database. It stores all changes made to the project and stores all current workset and element ownership information. It is recommended that after the central model is created, all work be done in local copies of the central model. All users will need to save a copy of the central model on their local network or hard drive. All changes can be published to the central model and all users can load other users’ changes from the central model at any time.
   See Enabling Worksharing on page 1210.

3 Optionally, set up worksets.
   A workset is a collection of elements, such as walls, doors, floors, or stairs. When you enable worksharing, several default worksets are created (2 default user-created worksets, and worksets for the families that are loaded in the project, project standards, and project views). For more information, see Default Worksets on page 1214.

   You can create worksets based on functional areas, such as interior, exterior, or site.
   See Setting Up Worksets on page 1212.
4 Begin worksharing.
Each team member creates a copy of the central model on the local network or hard drive to begin using worksharing.
See Using Workshared Files on page 1217.

Worksharing Terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>worksharing</td>
<td>A design method that allows multiple team members to work on the same project file at the same time.</td>
</tr>
<tr>
<td>central model</td>
<td>The master project file for a workshared project. The central model stores the current ownership information for all elements in the project, and acts as the distribution point for all changes published to the file. All users save their own local copies of the central model, work locally, and then Synchronize with Central so that other users can see their work.</td>
</tr>
<tr>
<td>workset</td>
<td>A collection of elements in a project. A workset is typically a discrete functional area, such as interior, exterior, site, or parking. When you enable worksharing, you can divide a project into worksets, with different team members responsible for each workset.</td>
</tr>
<tr>
<td>active workset</td>
<td>The workset to which new elements are added. The active workset name displays on Collaborate tab ➤ Worksets panel or the status bar.</td>
</tr>
<tr>
<td>element borrowing</td>
<td>Allows you to edit an element that you do not own. If no one owns the element, permission to borrow is automatically granted. If another team member is currently editing the element, that team member is the owner of the element and you must place a request to borrow the element from that team member.</td>
</tr>
</tbody>
</table>

Enabling Worksharing

Enabling worksharing involves creating a master project file, known as a central model, from an existing model.

The central model stores the current ownership information for all worksets and elements in the project, and acts as the distribution point for all changes made to the model. All users should save their own local copy of the central model, edit locally in this workspace, and then synchronize with central to publish their changes to the central model so that other users can see their work.

To enable worksharing and create a central model

1. Open the Revit project file (RVT) you want as the central model.
2. Click Collaborate tab ➤ Worksets panel ➤ (Worksets).
   The Worksharing dialog displays, showing the default user-created worksets (Shared Levels and Grids, and Workset1).
3 If desired, rename the worksets.

4 In the Worksharing dialog, click OK.
   The Worksets dialog displays.

5 In the Worksets dialog, click OK.
   You do not need to create worksets at this point. For more information, see Setting Up Worksets on page 1212.

6 Click ➤ Save As ➤ (Project).

7 In the Save As dialog, specify a file name and directory location for the central model.
   When specifying a name for the central model, use a naming convention that identifies it as the central model (for example, OfficeBuilding_CentralFile.rvt).

   **NOTE** Because legacy versions of appended backup file names with a decimal point and a numerical string, you should not end your file name in this manner. Otherwise, a proper backup directory will not be created. For example, if you want to name your central model hotel.2010.rvt, consider naming it hotel_2010.rvt.

   **IMPORTANT** When you save the central model, be sure that it is saved to a network drive to which all team members have access.

8 In the Save As dialog, click Options.

9 In the File Save Options dialog, select Make this a Central File after save.

   **NOTE** If this is the first time you have saved after enabling worksharing, this option is selected by default and cannot be changed.

10 Select a default workset for local copies. See Save Options on page 88. For Open workset default, select one of the following.

<table>
<thead>
<tr>
<th>Workset Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Opens all worksets in the central model. Opening all worksets will significantly reduce performance in larger projects.</td>
</tr>
<tr>
<td>Editable</td>
<td>Opens all editable worksets. Depending on how many editable worksets are in the central model, this option may significantly reduce performance in larger projects.</td>
</tr>
</tbody>
</table>
Workset Default | Description
--- | ---
Last Viewed | Opens worksets according to their state from a previous Revit session. Only worksets open in the last session open. If you are opening the file for the first time, all worksets open.

Specify | Opens specified worksets. When you click Open, the Opening Worksets dialog displays. Initial status is based on when the file was last opened. Specify different worksets or click OK to confirm the default. Press Ctrl+A to select all worksets in this dialog.

11 Click OK.
12 In the Save As dialog, click Save.

The file is now the central model for the project. Revit Structure creates the file in the directory you specified and creates a backup folder for the file. For example, if your central model is called OfficeBuilding_CentralFile, you see the Revit project file and the backup folder (OfficeBuilding_CentralFile_backup) in the directory.

The backup folder contains the backup information and editing permission information for the central model. For more information on backup files and folders, see Workshared Project Rollback on page 1233.

The Revit_temp folder contains files that provide progress information on operations (such as Synchronize with Central) to the Worksharing Monitor. For more information, see Worksharing Monitor on page 1237.

Related topics
- Worksharing Workflow on page 1209
- Setting Up Worksets on page 1212
- Using Workshared Files on page 1217

## Setting Up Worksets

A workset is a collection of elements, such as walls, doors, floors, or stairs. Only one user can edit each workset at a given time. All team members can view worksets owned by other team members, but they cannot make changes to them. This restriction prevents potential conflicts within the project. It is possible to borrow an element from a workset that you do not own. For more information, see Borrowing Elements on page 1219.

When you enable worksharing, several default worksets are created (two default user-created worksets, and worksets for the families that are loaded in the project, project standards, and project views). For more information, see Default Worksets on page 1214.

The following image shows the Worksets dialog, with the two default user-created worksets, Shared Levels and Grids and Workset1.
The Worksets dialog provides the following information:

- **Active workset** designates the workset to which new elements are added. The active workset can be a workset that is editable by you or one that is owned by another team member. You can add elements to worksets you do not own.

  **NOTE** The active workset name also displays on the Collaborate tab ➤ Worksets panel and the status bar.

- **Gray Inactive Workset Graphics.** Displays all elements in the drawing area that are not part of the active workset as gray. This has no effect on printing.

- **Name.** Indicates the name of the workset. You can rename all user-created worksets.

- **Editable.** Indicates the editable status of a workset. You cannot change editable status until you synchronize with central.

- **Owner.** Indicates the owner of the workset. If the Editable status of the workset is Yes, or you change the Editable status of the workset to Yes, then you are the owner of the workset. The Owner value is the user name that is listed on the General tab of the Options dialog. For more information on the Options dialog, see Revit Options on page 1623.

- **Borrowers.** Lists the users who are currently borrowing an element from the workset. If there is more than one borrower, you can view the list of borrowers from the drop-down list.

- **Opened.** Indicates if a workset is open (Yes) or closed (No). Elements in open worksets are visible in the project, elements in closed worksets are not.

- **Show.** Allows you to show or hide the different types of project worksets (User-Created, Families, Project Standards, Views) that display in the Name list.

**Worksets and Element Borrowing**

Generally, it is recommended that you work in your local copy of the central model and not make worksets editable. When you edit an element that is not being edited by another team member, you automatically become the borrower of the element and can make the changes you need. It is recommended that you synchronize with central frequently as you work. Synchronizing relinquishes borrowed elements by default, allowing other team members to edit them.
Use worksets when you want to reserve parts of a project so that only the assigned user can edit the elements in that workset. Also consider these benefits for creating worksets:

- **Convenience for editing**
  Dividing a project into worksets makes it easier to make whole sections of a project editable at once.

- **Visibility control**
  You can control overall visibility in a project when you link Revit models into other Revit projects. For example, it is often convenient to turn off visibility of the Shared Levels and Grids workset when linking Revit models so that you do not have to turn off levels and grids individually in each view.

### Default Worksets

When you enable worksharing, Revit Structure creates default worksets and assigns project elements and settings to these worksets. The default worksets are:

- **User-created.** Revit Structure creates 2 default user-created worksets.
  - **Shared Levels and Grids.** Contains all existing levels, grids, and reference planes. You can rename this workset.
  - **Workset1.** Contains all existing model elements in the project. When you create worksets, you can reassign elements from Workset1 into the appropriate workset. You can rename this workset, but you cannot delete it.

- **Families.** Each family that is loaded in the project is assigned to a separate workset. You cannot rename or delete family worksets.

- **Views.** Contains all project view worksets. For example, Floor Plan Level 1 view is assigned to a workset called View: “Floor Plan Level 1”. View worksets contain view properties and any view-specific elements, such as annotations, dimensions, or text notes. When you add view-specific elements to a view, they are automatically added to the appropriate view workset.
  
  You cannot make a view workset the active workset, but you can change its editable status so that you can modify a view-specific element (for example, a section in a plan view). If the associated workset for the section view is not editable by you, change the editable status of the workset so that you can edit it. See [Making Worksets Editable](#) on page 1223.

  You cannot reassign view-specific elements from a view workset to another workset. View worksets cannot be renamed or deleted.

- **Project Standards.** Contains all project-wide settings defined for the project (for example, line styles and fill patterns). You cannot rename or delete project standard worksets.
  
  For a complete list of project standard worksets:

  1. In a workshared file, click Collaborate tab ➤ Worksets panel ➤ (Worksets).
  2. In the Worksets dialog, select only Project Standards in the Show field.

    ![Worksets dialog](image)

    All project standards worksets display in the Name column.
Considerations for Worksets

In general, when Setting Up Worksets on page 1212, you should consider the following:

- **Project size**
  The size of the project may affect the way you enable worksharing for the team. In general, elements that are edited together should be in one workset. You do not need to create a workset for each floor of the building. In a multistory structure, however, you may want to create a workset for a set of elements that only appear on one floor, such as a tenant interior.
  
  If the floor plate of a project is too large to fit on a sheet and you need to split it up, you may want to consider creating a workset for each side of the building.

- **Team member roles**
  Typically, designers work in teams, with each assigned a specific functional task. Each team member has control over a particular portion of the design (for example, interior, exterior, or site). The workset structure for the project can reflect this breakdown of tasks, and you can name the worksets accordingly.

- **Worksets and templates**
  Worksets cannot be included in templates.

- **Default workset visibility**
  The performance of Revit Structure improves if some worksets are not visible by default. This visibility control eliminates the time required to draw additional views of the project.
  
  To identify visibility requirements, determine the frequency with which the elements in the workset display in the project. Under this guideline, you might have an exterior workset visible by default, while a specific furniture workset would not be.

- **Groups and families**
  Groups and families have a type workset and an instance workset that do not have to be the same.
  
  All elements in a group are in the group instance workset. To edit the group, make the group type workset editable or borrow the group type. To modify the elements inside a group, make the group instance workset editable. To determine which worksets the elements are in, select elements and check the Workset property on the Properties palette. If you use element borrowing to check out a group instance, Revit Structure automatically borrows all elements in the group.

Creating Worksets

1. Open your local copy of the central model.

2. Click Collaborate tab ➤ Worksets panel ➤ (Worksets).

3. In the Worksets dialog, click New.

4. In the New Workset dialog, enter a name for the new workset.

5. To display the workset in all project views, select Visible in all views.
   
   Clear this option if you want the workset to display only in views where you specifically turn on its visibility.
   
   You can change the visibility of worksets later in the Visibility/Graphics dialog. See Changing the Visibility of a Workset in a View on page 1231.

   **BEST PRACTICE** To improve performance, hide worksets that are not required for current work in the local model.

6. Click OK.
The new workset displays in the list of worksets; it is editable, and your user name displays for Owner.

If you are setting up a workshared model for your team and want to assign owners to each workset, each team member must open a local copy of the central model, select the workset in the Worksets dialog, and then select Yes in the Editable column.

7 When you finish creating worksets, click OK to close the Worksets dialog.

8 If you have added only one new workset, Revit Structure prompts you to make the new workset active. Click Yes or No.

Related topics
- Adding Elements to a Workset on page 1216
- Considerations for Worksets on page 1215
- Visibility of Worksets on page 1230

Adding Elements to a Workset
1 Select the workset from the Active Workset drop-down on the status bar or the Collaborate tab ➤ Worksets panel.

NOTE You can select a non-editable workset as the active workset. If you place an element in a non-editable workset, the element becomes non-editable after you synchronize with central. If you add view-specific elements, such as detail lines or dimensions, they are added to the workset of the active project view.

2 If you want all elements that were not created in the active workset to display as gray, click Collaborate tab ➤ Worksets panel ➤ (Gray Inactive Worksets).

3 Add the necessary elements to the Drawing Area on page 32.

Reassigning an Element to a Different Workset
1 In the drawing area, select an element.

NOTE If you select several elements, including view-specific elements (such as tags), you will not be able to edit the Workset parameter. To automatically filter out elements that you cannot edit, on the status bar, select Editable Only before making your selection.

If the selection includes non-editable elements, right-click it and select Make Elements Editable.

2 On the Properties palette, locate the Workset parameter under Identity Data.

3 Click in the Value column for the parameter, and select a new workset.

Changing the Editable Status of a Workset
NOTE You can only change the editable status of worksets that are not owned by another user.

1 Click Collaborate tab ➤ Worksets panel ➤ (Worksets).
2 In the Worksets dialog, click the Editable value next to the workset name, and select Yes or No. If you change the editable status before you synchronize with central, Revit Structure informs you that you remain the borrower of the elements you changed in the workset.

3 Click OK to close the Worksets dialog.

Renaming Worksets

You can rename user-created worksets.

**NOTE** You must be the owner of the workset to rename it.

1 Click Collaborate tab ➤ Worksets panel ➤ (Worksets).
2 In the Worksets dialog, select the name of the workset and click Rename.
3 In the Rename dialog, enter a new name.
4 Click OK twice.

Deleting Worksets

**NOTE** You must be the owner of the workset to delete it.

1 Click Collaborate tab ➤ Worksets panel ➤ (Worksets).
2 In the Worksets dialog, select the name of the workset you want to delete, and click Delete. The Delete option is not available if another user is editing the workset.
3 In the Delete Workset dialog, select either to delete the elements in the workset or move them to another workset.
4 Click OK twice.

**NOTE** You cannot delete the Workset1, Project Standards, Families, or View worksets.

Using Workshared Files

One of the key features of worksharing is the ability for each team member to make changes to a local copy of the central model simultaneously. On many projects, team members are assigned a specific functional area to work on (for example, interior, exterior, or site). Revit Structure projects can be subdivided into worksets to accommodate such environments.

Typical worksharing tasks include the following:

- **Create a local copy of the central model.**
  It is generally recommended that you create a local copy of the central model every day. After you create a local copy of the central model, this is the file you work in.
  See [Creating a Local Copy of the Central Model](#) on page 1218.

- **Open and edit your local copy of the central model.**
  You can make edits by borrowing elements or using worksets.
  See [Editing Workshared Projects](#) on page 1219.
Publish your changes to the central model, or get the latest changes from the central model. Publishing your changes is known as synchronizing with central. You can update your local copy of the central model without synchronizing with central by reloading the latest updates from the central model. Also, when you Synchronize with Central, your local copy of the central model also updates with the latest changes other team members have saved to the central model. See Saving Workshared Files on page 1225 and Loading Updates from the Central Model on page 1230.

Work offsite or offline. You do not have to be connected to a network to make your changes, or to open or edit worksets. This is useful for team members who work offsite and access the central model remotely.

WARNING Working offline can put your project at risk. See Working Offsite and Offline on page 1232.

Creating a Local Copy of the Central Model

It is good practice to create a local copy of the central model every day. Creating a new local copy ensures a local copy is always on your hard drive each time you begin modifying a project.

Creating a Local Copy of a Central Model from the Open Dialog

1. Click Open.
2. In the Open dialog, navigate to the folder where the central model resides and select it. This procedure cannot be used for multiple files at one time.
3. Under Worksharing, verify that Create New Local is selected.

NOTE If you select Detach from Central, then Create New Local will be cleared. Clear both options to open the central model itself instead of a copy.

4. Click Open.

If you are already working in the central model, use Save As to create a local copy.

Creating a Local Copy from an Open Central Model

1. Click Save As (Project).
2. In the Save As dialog, navigate to the desired location on your local network or your hard drive.
3. Enter a name for the file, and click Save.

Worksets on the Status Bar

To streamline the process of working on a workshared project, you can use the status bar. The Worksets button and the Active Workset drop-down provide the same functions as the corresponding tools on the Collaborate tab ➤ Worksets panel. The status bar always displays the active workset, and it provides one-click access to the Worksets dialog.
The Worksets button and drop-down list display in the status bar by default. If they are turned off, turn them on by clicking View tab ➤ Windows panel ➤ User Interface drop-down ➤ Status Bar - Worksets.

**Editing Workshared Projects**

When using a workshared project, you can edit individual elements, or you can edit worksets. When you check out an individual element or a whole workset, the elements are visible to other users but are not editable by them until you relinquish the element or workset.

To check out an individual element, **borrow** it. To check out a workset, **make it editable**.

**NOTE** To edit an element or a workset, it must be up-to-date. If you attempt to edit an element or a workset that is not up-to-date, you are prompted to update your local copy of the central model, so that you have all of the latest changes.

**Borrowing Elements**

You can edit an element without having ownership of the workset it belongs to. To do this, you borrow the element from the workset. The borrowing process is automatic unless another user is editing the element or the workset it belongs to. If this occurs, you can submit a request to borrow the element. When your request is granted, you can edit the element. If changes were made to the element, you are prompted to reload the latest changes from the central model before you can edit the element.

When you borrow an element from a workset, your name is listed in the Worksets dialog as a borrower. Your name also displays on the Properties palette for the Edited by parameter.

The simplest way to borrow an element is to make a change to the element. If the workset to which the element belongs is not owned by another user, you automatically become the borrower of the element and can make changes.

**To borrow an element:**

1. Select an element that is not editable by you. Be sure that the Editable Only option on the status bar is not selected.
   Elements that are not editable by you display the Make element editable icon, when you select them in the drawing area.

2. Click **(Make element editable)** in the drawing area, or right-click the element, and click Make Elements Editable.
   If no one else is editing the element, it opens for you to edit.
   If another team member is editing the element or has ownership of the workset to which the element belongs, a message displays indicating that you cannot edit the element until the other team member (the owner) relinquishes it.

   **NOTE** If you try to make a change to an element that is being edited by another team member, the same message displays, allowing you to place a request to borrow the element.

3. In the Error dialog, click Place Request.
   The Check Editability Grants dialog displays.
4 Ask the owner to approve your request.
The owner does not receive automatic notification of your request. You must contact the owner.

NOTE Your request is granted automatically if the owner synchronizes with central and relinquishes the element.

5 You can leave the Check Editability Grants dialog open, so that you can check to see if your request has been granted, or you can click Continue to close the Check Editability Grants dialog and continue working. If you tried to edit the element, click Cancel in the error dialog to cancel the edit.

NOTE If you close the Check Editability Grants dialog, you will not be able to reopen it. To check the status of your request, ask the owner or click Collaborate tab ➤ Synchronize panel ➤ (Editing Requests) to review pending requests.

When you synchronize with central, borrowed elements are relinquished by default. You can keep them by clearing Borrowed Elements in the Synchronize with Central dialog.

**Granting a Request to Borrow an Element**

This is an explicit granting process. There is also an implicit granting process that occurs when you Synchronize with Central and relinquish the requested elements.

1 After being notified of a pending request, click Collaborate tab ➤ Synchronize panel ➤ (Editing Requests).

NOTE Notification of a pending request is not automatic. A colleague should inform you, independent of Revit Structure, when they need to borrow an element from you.

2 In the Editing Requests dialog, expand Others’ pending Requests.

3 Select the request. It has a time stamp and the user name of the person submitting the request. You can expand the request to see the element name. To view the element, select it from the list and, if the element is not visible in the current view, click Show.
NOTE If you have modified the requested element, and you have not saved your changes to the central model, an asterisk appears next to the request.

4 Click Grant or, if you do not want the other user to borrow this element, click Deny/Retract. You can also use Deny/Retract to withdraw your own request to borrow an element.

NOTE If you try to grant a request that has an asterisk next to it, Revit Structure notifies you that you have not synchronized your changes with central. You must either synchronize your changes with central and then grant the request, or you must relinquish your elements without synchronizing with central. For more information, see Relinquishing Ownership without Synchronizing with Central on page 1229.

Related topics

■ Relinquishing Unchanged Borrowed Elements on page 1221
■ Viewing Requests for Borrowed Elements on page 1221
■ Retracting a Request to Borrow an Element on page 1221

Relinquishing Unchanged Borrowed Elements
If you borrow an element and do not make any changes to it, you can relinquish it.

1 Click Collaborate tab ➤ Worksets panel ➤ (Worksets).
2 Select the workset to which the element belongs.
3 Click Non Editable.

Viewing Requests for Borrowed Elements
When you initially make a request to borrow an element, you can check the status of the request in the Check Editability Grants dialog. If you close this dialog, and continue working, you can check to see if your request is still pending. You can also check status of a request by asking the owner if it was granted or denied.

To view pending requests:

1 Click Collaborate tab ➤ Synchronize panel ➤ (Editing Requests).
2 Expand My pending Requests.
   If your request is listed, it is still pending.

Retracting a Request to Borrow an Element

1 Click Collaborate tab ➤ Synchronize panel ➤ (Editing Requests).
2 Under My pending Requests, select the request.
3 Click Deny/Retract.
4 Click Close.

Outdated Workshared Elements

If another user changes an element and publishes the changes, that element in your local file is outdated. It cannot be edited (even if you borrow it) until you Reload Latest (see Loading Updates from the Central Model on page 1230) or synchronize with central.

Using Worksets

When you work on a workshared project, you specify an active workset. Each new model element you add to the project is then contained in the active workset. View-specific elements, such as annotations and dimensions, are placed in the workset for the current view.

The general workflow for using worksets is
1 Open worksets so they are visible in the project.
2 Make the workset editable.
3 Edit a workset.
4 Synchronize with the central model or reload the latest changes from the central model.

When you Synchronize with Central, the latest changes from the central model are loaded before saving.

Opening Worksets

When you open a workshared project, you can select which worksets to open. When you open only selected worksets and leave others closed, performance improves. Closed worksets are not visible in a project, so less time is required for common operations such as opening files, opening new views, redrawing the screen, and snapping.

You can open worksets from the Open dialog when you initially open your workshared project, or you can open them from the Worksets dialog in the project.

To open worksets from the Open dialog

1 Click ➤ Open ➤ (Project).
2 Navigate to your local copy of the central model, and select it.
3 Select an option from the Open list. See Save Options on page 88.
Workset Default | Description
--- | ---
All | Opens all worksets in the central model. Opening all worksets will significantly reduce performance in larger project files.
Editable | Opens all editable worksets. Depending on how many editable worksets are in the central model, this option may significantly reduce performance in larger project files.
Last Viewed | Opens worksets according to their state from a previous Revit session. Only worksets open in the last session open. If you are opening the file for the first time, all worksets open.
Specify | Opens specified worksets. When you click Open, the Opening Worksets dialog displays. Initial status is based on when the file was last opened. Specify different worksets or click OK to confirm the default. Press Ctrl+A to select all worksets in this dialog.

4 Click Open.

To open worksets from the Worksets dialog

1 Open your local copy of the central model.

2 Click Collaborate tab ➤ Worksets panel ➤ (Worksets).
3 In the Worksets dialog, select the desired workset, and click Open, or, under Opened, click Yes.
4 Click OK.

Making Worksets Editable

There are various methods you can use to make worksets editable.

To make worksets editable from the Worksets dialog

1 Open your local copy of the central model.

2 Click Collaborate tab ➤ Worksets panel ➤ (Worksets).
In the Worksets dialog, to filter the display of worksets, make the appropriate selections under Show. For example, to see the Project Standards worksets, select Project Standards.

4 Click under Editable for the workset, and select Yes. Alternatively, you can select the workset name, and click Editable.

**NOTE** If a workset is owned by another user, you cannot change its editable status.

5 Repeat the previous step for as many worksets as you want to edit.

**TIP** To check out multiple worksets at once, click the workset name under the Name column to select it, hold Ctrl or Shift and select other worksets, and then click Editable. You can select all worksets by pressing Ctrl+A.

6 Click OK.

When you click OK, ownership information is communicated to the central model and to all local copies of the central model, so that all team members have the current ownership information.

**To make worksets editable by selecting an element**
In the drawing area, right-click an element, and click Make Worksets Editable.

**To make project view worksets editable from the Project Browser**
In the Project Browser, right-click a project view, and click Make Workset Editable.

**To make a sheet view workset editable**
In the Project Browser, right-click a sheet view, and click Make Workset Editable With All Views. The sheet view workset and all the project view worksets that are on the sheet are now editable.

Use the Make Workset Editable option if you only want to make the sheet editable. If you already own the workset, this option is not available.

### Editing a Workset

1 Select an active workset, using one of the following methods:
   - On the status bar, select the workset from the Active Workset drop-down.
   - Select the workset from the Active Workset drop-down on the Collaborate tab ➤ Worksets panel.

2 If you want all elements that are not in the active workset to be gray, click Collaborate tab ➤ Worksets panel ➤ (Gray Inactive Worksets).

3 Edit or add elements in the workset, as necessary.

**NOTE** If you add view-specific elements, such as detail lines or dimensions, they are added to the workset of the active project view.

### Related topics

- [Reassigning an Element to a Different Workset](#) on page 1216
- [Editing Workshared Projects](#) on page 1219
Making Worksets Editable on page 1223

Visually Distinguishing Active Workset Elements

All elements that are not in the active workset can display as gray in the drawing area. Temporary elements, such as temporary dimensions and controls, do not display in gray. This option has no effect on printing, but helps to prevent adding elements to an undesired workset.

To visually distinguish the active workset

1. Click Collaborate tab ➤ Worksets panel ➤ (Worksets).
2. In the Worksets dialog, select Gray Inactive Workset Graphics, and click OK.

Alternatively, click Collaborate tab ➤ Worksets panel ➤ (Gray Inactive Worksets).

The following image shows a project floor plan where the Interior Layout workset is active, and all other worksets are gray.

Filtering Non-Editable Workset Elements from Selection

When you select elements in the drawing area, you can filter any that are non-editable. This option is not selected by default.

1. On the Quick Access toolbar, click (Modify).
2. On the status bar, select Editable Only.
3. In the drawing area, make your selection.

Saving Workshared Files

When saving the changes in your local workshared file, you can do either of the following:

- Synchronize with Central
- Save locally
When you Synchronize with Central, the changes you made to your local copy are saved to the central model. In addition, any changes made by other team members to the central model since the last Synchronize with Central or Reload Latest are copied to your local file. Any elements you borrowed are relinquished by default when you Synchronize with Central.

Between synchronizations with the central model, you should save changes to the local model frequently. You might want to establish specific times throughout the day when each team member will be synchronizing with central. This ensures that team members are not trying to Synchronize with Central at the same time. At the end of the day, you should relinquish the elements you borrowed and the worksets you own.

You save your local model the same way you save a project file that does not use worksharing. For more information, see Saving Revit Files on page 87. By default, you automatically save the changes in your local model when you Synchronize with Central.

You can specify save reminders for saving local files and saving to central. For more information, see Setting Save Reminders on page 88.

**Synchronizing with the Central Model**

To Synchronize with Central: Click Collaborate tab ➤ Synchronize panel ➤ Synchronize with Central drop-down ➤ (Synchronize Now).

If you want to modify the Synchronize with Central settings before you synchronize with central: Click Collaborate tab ➤ Synchronize panel ➤ Synchronize with Central drop-down ➤ (Synchronize and Modify Settings). The Synchronize with Central dialog displays.

1. In the Synchronize with Central dialog, verify the location of the central model. If necessary, click Browse to specify a different path for the central model. Specify the new path in the Central File Location dialog, and click OK.

2. Select Compact Central File to reduce file size when saving.

   **NOTE** Selecting this option increases the time needed to save.

3. Under After synchronizing, relinquish the following worksets and elements, select from the following options:

   - To make your changed worksets and elements available to other users, select the appropriate check boxes.
To synchronize the changes to central but keep the worksets and elements editable, clear the appropriate check boxes.

4 If desired, enter a comment that is saved to the central model. You can see all comments using the Show History tool. See Viewing Workshared File History on page 1234.

5 Verify that Save local file before and after synchronizing with central is selected to ensure your local file remains synchronized with central.

6 Click OK.

Your changes are saved to the central model and any changes from other team members are copied to your local model.

Closing Workshared Files without Saving

If you close your local model without saving, the Changes Not Saved dialog displays.

![Changes Not Saved dialog]

The following sections describe each of these options.

**Synchronize with Central**

This option saves your changes to the central model. The default settings are selected, including saving your changes to the local model. Also, any changes that have been saved from other team members are copied to your local model.

**Save Locally**

This option saves your changes to the local model without synchronizing them with the central model and displays the Save Changes to Local File dialog. Because you did not Synchronize with Central, you still own any elements you modified.
You have the following options:

- Click Relinquish unmodified elements and worksets if you want others to have access to them. Unchanged editable elements and worksets are relinquished, and the local model is saved. You remain the borrower of any elements you changed in the editable worksets.
- Click Keep ownership of all elements and worksets to retain all editing permissions when the local model is saved. The local model closes without synchronizing with central or relinquishing worksets or borrowed elements.

**Do Not Save the Project**

This option discards any changes you made to the local model. It has no effect on your last save to the local model. This option rolls back the state of your local model to the last time you saved it and displays the Close Project Without Saving dialog.

You have the following options:

- Click Relinquish all elements and worksets to let others gain access to both modified and unmodified elements and worksets. You relinquish all changes you made to the elements you borrowed and the worksets you own.
- Click Keep ownership of all elements and worksets to retain ownership of the elements you borrowed and the worksets you own. You will lose the changes you made.
Opening Workshared Files Independent of the Central Model

Use this procedure to open a file independently for clients who want to see changes or make changes without saving them. Clients can view the file and modify it without worrying about borrowing elements or owning element worksets. This is also useful for project managers who are not working in the project file, but might want to open it for review without interrupting the team.

1. Click ➤ Open ➤ (Project).
2. In the Open dialog, navigate to the central model and select it.
3. Select Detach from Central.
4. Click Open.

If a non-workshared file is opened with Detach from Central selected, Revit Structure ignores the option, and opens the file normally.

After you open the file, it no longer has any path or permissions information. It is in a state similar to when worksharing was first enabled; all elements in the file can be modified, but no changes can be saved back to the central model. If you save the file, it is saved as a new central model.

NOTE If a longer-lasting independent copy of the central model is needed, such as when the central model is suspected to be corrupt, detach from the central model and save it as a new central model. Note that existing local files cannot synchronize with this new central model, and new local files created from the detached central model cannot synchronize with the old central model.

Editable Elements

If you have saved all changes to the central model, but still have editable elements when you close the local file, the Editable Elements dialog displays.

If you do not want to keep ownership of the checked out worksets and borrowed elements, click Relinquish elements and worksets; otherwise, click Keep ownership of elements and worksets.

Relinquishing Ownership without Synchronizing with Central

To relinquish editable elements for which you have editing permissions without synchronizing with the central model:
1 With the local file open, click Collaborate tab ➤ Synchronize panel ➤ (Relinquish All Mine).

Revit Structure checks for any changes that require synchronizing with central:

- If there are no changes to the model elements, ownership of the worksets and borrowed elements is relinquished. A dialog does not display.
- If there are changes, ownership status does not change. You still own any model elements you modified. A dialog displays telling you that you made changes and suggests synchronizing with central.

2 Click Close to close the dialog, if one displays.

If you do not mind discarding your local changes, you can relinquish permissions and borrow elements. Open the central model directly or create a new local file from the central model, and choose Relinquish All Mine. Best practice is to discard your original local file so that you do not accidentally work on an outdated file or the wrong local file. If you retain your original local file, be aware that if other users have modified elements that you used to own, the original local file will be incompatible with the central model.

**Loading Updates from the Central Model**

As you work, you can see the changes other team members have made to the project after they have been synchronized with the central model. You can load updates from the central model without publishing your changes to the central model.

In your local file, click Collaborate tab ➤ Synchronize panel ➤ (Reload Latest).

**Visibility of Worksets**

In a workshared project, you can control the visibility of worksets in project views. You can specify a global visibility setting when you create a workset. You can also change each workset’s visibility setting at any time, either project-wide or for individual views.

**BEST PRACTICE** To improve performance, hide worksets that are not required for current work in the local model.

**Overview of Workset Visibility**

When you create a workset, you can use the Visible in all views option of the New Workset dialog to indicate whether that workset displays in all views of the model. This setting is reflected in the Visible in all views column of the Worksets dialog.
This global setting defines the default behavior for each workset in project views. You can override the visibility of each workset for individual views.

**NOTE** Elements display in a view when their model categories are visible and their worksets are visible. If the workset to which an element belongs is hidden or the element’s model category is hidden, then the element does not display in the view. See *Overriding Graphic Display of Element Categories* on page 803.

**Related topics**

- Changing the Global Setting for Workset Visibility on page 1231
- Changing the Visibility of a Workset in a View on page 1231

**Changing the Global Setting for Workset Visibility**

1. Click Collaborate tab ➤ Worksets panel ➤ (Worksets).
2. Under Visible in all views, select the check box to show a workset in project views, or clear the check box to hide it.

**Related topics**

- Overview of Workset Visibility on page 1230
- Changing the Visibility of a Workset in a View on page 1231

**Changing the Visibility of a Workset in a View**

1. Open the view.

2. Click View tab ➤ Graphics panel ➤ (Visibility/ Graphics).
3. On the Worksets tab of the Visibility/Graphics dialog, for each workset, select one of the following values:

<table>
<thead>
<tr>
<th>Value</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Global Setting</td>
<td>Shows or hides the workset depending on the value of the Visible in All Views column of the Worksets dialog, which is displayed in parentheses.</td>
</tr>
<tr>
<td>Show</td>
<td>Displays the workset in the view, regardless of its global setting.</td>
</tr>
<tr>
<td>Hide</td>
<td>Hides the workset in the view, regardless of its global setting.</td>
</tr>
</tbody>
</table>

4. Click OK.

**Related topics**

- Overview of Workset Visibility on page 1230
- Changing the Global Setting for Workset Visibility on page 1231
Working Offsite and Offline

**WARNING** Working offline can put your project at risk. Your local model can become incompatible with the central model, preventing you from synchronizing with central. The central model itself remains safe.

You can work remotely, provided you have high-speed network access to the central model, or you can transfer your local model to someone with network access.

**To work offsite or offline**

1. Make the necessary worksets editable while still at the office and connected to the network. See Making Worksets Editable on page 1223.
2. Be sure to save your local copy of the central model before you close it; otherwise, your changes to workset editability are not saved in the local copy when you take it offline.
3. Work on the project offsite as you would in the office. You can modify elements in editable worksets, and you can create new elements in any workset.

**Editing Elements You Do Not Own Offline**

To modify elements in a workset you do not own, you can specify the status of the workset as Editable. This is known as Editable at Risk and should be avoided whenever possible.

If another team member synchronizes changes to any of the same elements that you have changed, you cannot synchronize any of your changes with the central model. All your changes in all worksets are lost.

If you make a workset Editable at Risk, it is recommended that you:

1. Ask a colleague, who is in the office and has access to the central model, to start a session of Revit Structure and specify your name as the User Name. See Revit Options on page 1623.
2. Ask the colleague to open the central model, check out all the worksets that you have at risk, close the file, and reset the User Name to their name. It is not necessary to synchronize with the central model.

This procedure prevents other users from making the workset editable and changing the same elements. If someone else has checked out that workset or has borrowed elements in it, there is no way to assure that there will not be a conflict.

**Rendering Workshared Projects Offline**

**WARNING** Rendering offline is generally not recommended.

If you render the model offline, you will likely change material assignments and other project settings. To change project settings, you need to check out some of the Project Standards worksets. If you make these worksets editable while you are still connected to the central model, other team members working on the project cannot change the Project Standards worksets that you are changing. Instead, if you make the worksets Editable at Risk after going offline, you risk losing all your changes.

**Upgrading Workshared Projects**

Before you upgrade the central model to a new release of Revit Structure, it is recommended that you create a backup copy of the central model for each workshared project in the current release. These backup copies are for use only if a new central model becomes corrupted.

**IMPORTANT** If there are linked models in the central model, the linked model files must be upgraded before the central model.
To create a backup copy of the central model in your current release of Revit Structure

1. Instruct all team members to synchronize with central, relinquish all elements, and close their local copies of the central model. See Synchronizing with the Central Model on page 1226.
2. Use Windows Explorer to make a copy of the central model and its backup folder.

To upgrade the central model to a new release of Revit Structure

3. Open the central model in the new release.
   TIP: Open the central model with the Audit option to identify and fix any possible corrupt elements. This process is more time consuming, but will prevent potential problems. See Opening a Revit Project File on page 83.

4. Click ➤ Save As ➤ (Project).
5. In the Save As dialog, click Options, and in the File Save Options dialog, select Make this a Central File after save.
6. Click OK.
7. Navigate to the directory with the upgraded central model and name it accordingly.
8. Click Save.

   NOTE: Backups of the central model will restart, after it has been upgraded in this manner.

9. Instruct all team members to open the central model and create a local copy of it using ➤ Save As ➤ Project. Alternatively, use the Create New Local option in the Open dialog.

Workshared Project Rollback

When you save a workshared project, Revit Structure creates a directory of backup files. In that directory, backup files are created each time a user synchronizes with central, or saves a local copy of the central model. Successive backups share as much element information as possible; therefore, they are incremental rather than equal in size to the entire project.

You can roll back either a central model or a local file of the project. For example, you may want to roll back to a prior version of the project, if changes made after a certain date are deemed incorrect or inappropriate. You can also save a prior version as a new project file.

When you roll back a file, all later versions in the backup directory are lost. In addition, you lose all information on workset ownership, borrowed elements, and workset editability. You must coordinate with team members to reassign workset and element ownership.

Central Model Backup Files and Folders

The backup folder for the central model contains files that store information about editability and ownership status (permission information). It also contains various DAT files and a worksharing log file (.slog) that provides progress information on operations (such as synchronize with central) to the Worksharing Monitor.

Revit Structure stores central model backup information in a folder called \[Centralfilename\]_backup. Do not delete or rename any files in this folder. If you move or copy the project file, be sure the central model backup folder stays with the project file. If you rename the project file, rename the backup folder appropriately.

You can control the number of backups retained. For more information, see Setting Save Reminders on page 88.
Rolling Back Workshared Projects

IMPORTANT Rollbacks cannot be undone. When you roll back a project, all backup versions subsequent to the selected version are lost. Ensure that you want to roll back the project before continuing, and save any later versions, if necessary.

1 Click Collaborate tab ➤ Synchronize panel ➤ (Restore Backup).
2 In the Browse for Folder dialog, navigate to the backup folder for the project.
   To see the central model backups, browse to the central backup folder.
   To see the local file backups, browse to the local backup folder.
3 Click Open.
4 In the Project Backup Versions dialog, select a version.
5 Click Rollback.
6 Click OK to continue the rollback, or click Cancel.

NOTE If your local copy of the central model has a version number greater than the version number the central model was rolled back to, you will need to open the central model and save a new local copy.

7 Click Close.

Saving a Specific Backup Version as a New File

1 Click Collaborate tab ➤ Synchronize panel ➤ (Restore Backup).
2 In the Browse for Folder dialog, navigate to the backup folder, and click Open.
3 In the Project Backup Versions dialog, select the version to save.
4 Click Save As, and save the file.
5 When you save the project under the new name, Revit Structure prompts you to open the extracted project. Click Yes or No.
   Revit Structure considers this file as a local version of the central model. If you want the file to become the new central model, you must explicitly save it as such. For more information, see Creating a Central Model from an Existing Workshared File on page 1235.

Viewing Workshared File History

You can view a list of all the times a workshared file (the central model or a local copy of the central model) was saved and who saved it. The list also shows any comments entered in the Synchronize with Central dialog.

1 Click Collaborate tab ➤ Synchronize panel ➤ (Show History).
2 In the Show History dialog, navigate to the shared file, select it, and click Open.
3 In the History dialog, click the column headers to sort alphabetically or chronologically.
4 If desired, click Export to export the history table as delimited text. The delimited text can then be read by a spreadsheet program.
Creating a Central Model from an Existing Workshared File

You may need to create a central model from an existing workshared file if you want to move the central model location (see Moving the Central Model on page 1236). You may also need to abandon the existing central model and want to use a local copy of the central model (rather than a backup of the central model) as the new central model. You may need to do this if, for example, a team member was working offline on a local copy of the central model and those changes need to remain in the project.

Before you create a new central model, be sure to rename the workshared file or specify a different directory path before saving. You rename to avoid overwriting the existing central model and potentially losing all other team members’ changes.

1 Open the existing workshared file.

2 Click ➤ Save As ➤ (Project).

3 In the Save As dialog, rename the file, and click Options.

4 In the File Save Options dialog, select Make this a Central File after save.

5 Select a default workset for local copies. See Save Options on page 88. In the Open workset default list, select one of the following.

<table>
<thead>
<tr>
<th>Workset Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Opens all worksets in the central model. Opening all worksets will significantly reduce performance in larger project files.</td>
</tr>
<tr>
<td>Editable</td>
<td>Opens all editable worksets. Depending on how many editable worksets are in the central model, this option may significantly reduce performance in larger project files.</td>
</tr>
<tr>
<td>Last Viewed</td>
<td>Opens specified worksets. When you click Open, the Opening Worksets dialog displays. Initial status is based on when the file was last opened. Specify different worksets or click OK to confirm the default. Press Ctrl+A to select all worksets in this dialog.</td>
</tr>
<tr>
<td>Specify</td>
<td>Opens specified worksets. When you click Open, the Opening Worksets dialog displays. Press Ctrl+A to select all worksets in this dialog. Initial status is based on when the file was last opened. You can specify different worksets or click OK to confirm the default.</td>
</tr>
</tbody>
</table>

6 In the Save As dialog, click Save.
Moving the Central Model

Some examples of when you may need to move a central model include:

- Your office has a new file server, and you need to move the central model from the old server to the new server.
- The current location of the central model contains too many projects.
- Your office has a new naming convention for projects and needs to rename the central model. Revit Structure considers renaming a file the same as moving it.
- One office works on the project, then ships it to another office. The new office wants to work on it locally, so they want to move the central model location from the first office to the second one.

Use caution when moving the central model. If team members are unaware of the new location, they will be unable to submit changes and could lose work. When team members submit changed elements to a central model, those elements must be editable in the team members' names at the central location they specify. Also, any changes to an element must be built on the last submission of that element to the central model, even though the file may now be in a different location.

**NOTE** Moving or copying the file using Windows® Explorer or DOS creates a local copy of the central model. Revit Structure still looks for the central model in its original location. A central model is identified as having worksharing enabled and as residing in the central model location identified in the project. To view (or modify) this location, click Collaborate tab ➤ Synchronize panel ➤ Synchronize with Central drop-down ➤ Synchronize and Modify Settings.

To move the central model

1. Make sure all team members save their work to the current central model location by clicking Collaborate tab ➤ Synchronize panel ➤ Synchronize with Central drop-down ➤ (Synchronize Now). This step ensures that no work is lost as a result of changing the central model location. When saving, each team member should relinquish all elements.

2. Move the file to the new location using either Windows Explorer or DOS commands. If you move rather than copy the central model, you eliminate the risk of team members working with the old file.

3. Open the central model from its new location. A dialog displays telling you that the central model has been moved and that you must re-save it as the central model. Click OK to continue.

4. Click ➤ Save As ➤ (Project).

5. In the Save As dialog, click Options.

6. In the File Save Options dialog, select Make this a Central File after save, and click OK.

7. In the Save As dialog, click Save.

8. Each team member should create a new local file. See Creating a Local Copy of the Central Model on page 1218.
NOTE: If you discover that there is only one local file that was not saved to central, you can save it to the new location by clicking Collaborate tab ➤ Synchronize panel ➤ Synchronize with Central drop-down ➤ Synchronize and Modify Settings, and then navigating to the new central model location through the Browse option. The only time you can do this successfully is before any other changes are saved to the new central location.

If an old version of the central model remains in the old location, you can prevent other team members from saving to this obsolete central model by deleting it or making it read-only.

Worksharing Monitor

The Worksharing Monitor is a utility that allows you to learn information about a workshared project:

- Who is currently working on this project?
- Is my local copy of the project up to date?
- When will my Synchronize with Central operation finish?
- Has my request to borrow elements been granted?
- Are any issues interfering with my work on a Revit project?

The Worksharing Monitor is available to Revit Structure subscription customers.

To use the Worksharing Monitor

1. Download the Worksharing Monitor from the Autodesk customer subscription web page.
2. Install the Worksharing Monitor.
3. Open a Revit project, and click Add-Ins tab ➤ External panel ➤ External Tools drop-down ➤ Worksharing Monitor.
4. In the Worksharing Monitor dialog, click Help to learn how to use the utility.

Troubleshooting Worksharing Issues

Read the following topics to learn how to resolve issues encountered when using workshared projects.

Central File Has Been Restored

**Warning:** The central file has been restored from a previous backup. As a result, the following workset(s) edited by you have been rolled back.

**Issue:** You had a workset editable by you in this local model. Another user has replaced the central model with a previous backup copy, where the workset you are editing either does not exist or has a previous version.

**Solution:** Find out why the central model was restored. If it must stay restored, you have to redo your changes again, by making another local copy. You can copy elements from your current local copy, if that is helpful.
When architects, structural engineers, and mechanical engineers collaborate on a building project, they must share information about the design, so that all teams are working with the same assumptions. By coordinating efforts across disciplines, the teams avoid expensive errors and rework.

To simplify design coordination and change management, the Revit products provide the following tools:

- **Copy/Monitor**: Monitors elements between the host project and a linked model, or within one project. When one team moves or changes a monitored element, other teams are notified so that they can adapt their designs or work with team members to resolve issues. See Copy/Monitor Overview on page 1239.

- **Coordination Review**: Displays a list of warnings about monitored elements that have moved or changed. Use this tool after implementing Copy/Monitor. Teams can periodically review this list, specify an action (such as reject the change or modify the design), and enter comments to communicate with other teams. See Coordination Review on page 1255.

- **Interference Check**: Identifies elements that interfere with one another within a project, or between the host project and a linked model. The interference check locates invalid intersections between elements of different types, whereas the Copy/Monitor tool monitors pairs of elements of the same type. See Interference Checking on page 1261.

### Copy/Monitor Overview

When multiple teams collaborate on a project, effectively monitoring and coordinating work can help to reduce mistakes and expensive rework. Use the Copy/Monitor tool to ensure that design changes are communicated across teams.

### When Should I Use Copy/Monitor?

Use the Copy/Monitor tool when

- The architectural team, the structural team, and the engineering team use Revit software.
- Each team must be informed of changes to levels, grids, and other elements.
- The teams will link project files to work on the same building design. Each team maintains its own edition of the project file and uses Revit software to develop the design for their discipline. Each project file is
linked to the other project files to share information about changes to monitored elements in the building design. (For an alternative method, see Copy/Monitor and Workshared Projects on page 1242.)

For example, the architect uses Revit Architecture to design the architectural model. The structural engineer uses Revit Structure to create an empty structural project. Then the structural engineer uses Copy/Monitor to copy levels and grids from the architectural model, providing a starting point for the structural design. Likewise, the architect links the structural model into the architectural project to monitor levels and grids. Whenever the architect or structural engineer moves or changes a level or grid, the other team member is notified of the change.

Related topics

- What Elements Can I Copy or Monitor? on page 1240
- Copy/Monitor Methods on page 1241
- Copy/Monitor Workflow for Linked Models on page 1243

What Elements Can I Copy or Monitor?

Use the Copy/Monitor tool to monitor changes to the following types of elements:

- Levels
- Grids
- Columns (but not slanted columns)
- Walls
- Floors
- Openings

When monitoring walls, you can specify whether to monitor openings, including openings for doors and windows. When monitoring floors, you can specify whether to monitor floor inserts and openings, such as shafts.

The Copy/Monitor tool is not intended to be used with:

- slanted columns on page 224
- in-place elements
  If you need to represent in-place elements from a linked model, copy and paste them between projects. See Copying Elements from a Linked Model on page 1186.
- design options
- project phasing
  When you use Copy/Monitor to copy an element from a linked model to the current project, the copied element is assigned to the New Construction phase. It does not inherit the phase assigned to the original element in the linked model. See also Mapping Phases Between Linked Models on page 1185.

Related topics

- When Should I Use Copy/Monitor? on page 1239
- Copy/Monitor Methods on page 1241
- Copy/Monitor Workflow for Linked Models on page 1243
Copy/Monitor Methods

When you start the Copy/Monitor tool, you can select Use Current Project or Select Link. Then you can select Copy or Monitor:

- **Copy**: Creates a copy of a selected item and establishes a monitoring relationship between the copied element and the original element. If the original element changes, a warning alerts you when you open the project or reload the linked model. (This Copy tool is different than the other Copy tools, which are used for copying and pasting.)

- **Monitor**: Establishes a monitoring relationship between 2 elements of the same type. If an element changes, a warning alerts you when you open the project or reload the linked model.

The following topics describe how Copy/Monitor works depending on which methods you choose.

Copy Elements in the Current Project

When you start the Copy/Monitor tool, select Use Current Project, and then select Copy, you can copy and monitor selected elements within the same project.

For example, use this method in Revit Architecture when you have created architectural columns and you want to copy structural columns to the same locations. When an architectural column is moved, a warning reminds you to move its structural column.

You can also use this method when implementing Copy/Monitor in a workshared project. See Copy/Monitor and Workshared Projects on page 1242.

Copy Elements from a Linked Model

When you start the Copy/Monitor tool, choose Select Link, and then select Copy, you can copy elements from a linked model to the current project, and monitor changes to the original elements. When an element in the linked model changes, a warning alerts you of the change.

For example, you can copy levels and grids from a linked architectural model to a structural model. When a level or grid is moved in the architectural model, a warning alerts structural engineers.

See Copying Levels for Monitoring on page 1244 and Copying Elements for Monitoring on page 1246.

Monitor Elements in the Current Project

When you start the Copy/Monitor tool, select Use Current Project, and then select Monitor, you can establish relationships between elements in the current project, and monitor changes to the elements. When an element changes, a warning alerts you of the change.

For example, use this method to monitor 2 grid lines. If a grid line is moved, a warning alerts you so that you can adjust the other grid line, if needed. See Monitoring Elements in the Current Project on page 1250.

You can also use this method when implementing Copy/Monitor in a workshared project. See Copy/Monitor and Workshared Projects on page 1242.

Monitor Elements in a Linked Model

When you start the Copy/Monitor tool, choose Select Link, and then select Monitor, you can establish relationships between elements in a linked model and corresponding elements in the current project, and
monitor changes to the elements in the linked model. When an element in the linked model changes, a warning alerts you.

For example, in an architectural model, use this method to monitor levels and grids in a linked structural model. When a level or grid line is moved in the structural model, a warning alerts architects.

See Monitoring Elements in a Linked Model on page 1248.

**Copy/Monitor and Workshared Projects**

As an alternative to using Copy/Monitor to coordinate changes between linked models, you can use it to coordinate changes in a workshared project. This practice is best suited to a small interdisciplinary team that is working on a building project at the same office or location.

When you start the Copy/Monitor tool, select Use Current Project. Then select Copy or Monitor, depending on your needs.

For example, suppose a building model is organized into the following worksets:

- **Shared Levels and Grids**: editable only by the project manager
- **Interior**: used by the interior designer to plan the interior of the building in Revit Architecture
- **Exterior**: used by the lead architect to plan the exterior of the building in Revit Architecture
- **Structure**: used by the structural engineer to plan the structural model in Revit Structure

The structural engineer uses Revit Structure to open the Structural workset, and then uses Copy to copy levels and grids from the Shared Levels and Grids workset. If the project manager moves or changes any levels or grids, the structural engineer receives a warning upon reloading the central model or performing a coordination review.

The interior designer uses Revit Architecture to open the Interior workset, and then uses Monitor to establish relationships between interior walls and exterior walls. If the lead architect moves or changes an exterior wall, the interior designer receives a warning upon reloading the central model or performing a coordination review.

**Related topic**

- Working in a Team on page 1209
Copy/Monitor Workflow for Linked Models

The following workflow describes a typical process to coordinate efforts between an architectural team and a structural team working on the same building using linked models. The process is similar when coordinating efforts between an architectural team and an MEP team, or a structural team and an MEP team.

To use Copy/Monitor with linked models

1. The architect uses Revit Architecture to create the architectural model, as follows:
   a. Creates levels and grids, at a minimum. The architect can also add columns, walls, floors, and other elements.
   b. Saves the architectural project file.

2. The structural engineer uses Revit Structure to create an empty structural project, as follows:
   a. Uses a structural project template that defines the desired views and settings.
      See Structural Template on page 217 and Project Templates on page 1633.
   b. Saves the empty structural project file.

3. The structural engineer copies relevant architectural elements to the empty project, as follows:
   a. Links the architectural model into the empty project.
      See Linking One Model to Another on page 1184.
   b. Pins the linked model in place, so that it cannot be moved inadvertently, as follows:
      ■ Selects the linked model in the drawing area.
      
      **TIP** Move the cursor over the linked model in the drawing area. When its boundary is highlighted, click to select it.

      ■ Clicks Modify | RVT Links tab ➤ Modify panel ➤ (Pin).
   c. Copies levels from the architectural model to the project.
      See Copying Levels for Monitoring on page 1244.
   d. Copies grids and other elements from the architectural model to the project.
Copying Elements for Monitoring on page 1246.
e (Optional) Hides the linked architectural model.
See Hiding a Linked Model in a View on page 1195.
f Adds structural elements to the structural model, as desired.

If any copied elements are moved or changed in the architectural model, the structural engineers are notified of the changes when they open their project or reload the architectural model. These warnings also display in a coordination review.

4 In the architectural model, the architect monitors relevant structural elements, as follows:
a Links the structural model into the architectural project.
See Linking One Model to Another on page 1184.
b Pins the linked model in place.
c Monitors (without copying) levels, grids, and other elements in the structural model.
See Monitoring Elements in the Current Project on page 1250.
d (Optional) Hides the linked structural model.
e Adds architectural elements to the architectural model, as desired.

If any monitored elements are moved or changed in the structural model, architects are notified of the changes whenever they open the architectural project or reload the model. These warnings also display in a coordination review.

5 At regular intervals, architects or structural engineers can do the following:
■ Perform a coordination review to see changes to monitored elements, communicate with team members, and take appropriate action.
■ Perform an interference check to identify invalid intersections of elements between the current project and a linked model.

Related topics
■ Copy/Monitor Best Practices on page 1257
■ Troubleshooting Copy/Monitor Issues on page 1258

Copying Levels for Monitoring

You can copy levels from a linked model to the current project, and monitor them for changes. See Copy/Monitor Overview on page 1239.

For instructions on copying other types of elements for monitoring, see Copying Elements for Monitoring on page 1246.

To copy levels for monitoring

1 Open an existing project or start a new project.
   You will copy levels from a Revit model to this project.

2 Prepare a view:
   a Open an elevation view.
   b In the view properties, for Discipline, select Coordination.
This setting ensures that the view displays elements for all disciplines (architectural, structural, mechanical, and electrical).

3 Delete existing levels from the current project.

When you delete existing levels, Revit Structure also deletes corresponding plan views for the deleted levels. You will create new plan views based on the copied levels.

**NOTE** You can delete all but one level. Change the name of this level to Original Level, and change its extents (far to the left or right of the drawing area) so that you can distinguish it from a copied level and delete it later.

4 Link the model into the current project.

See [Linking One Model to Another](#) on page 1184.

5 Pin the linked model in place, so that it cannot be moved inadvertently.

**How to**

a In the drawing area, select the linked model.

**TIP** Move the cursor over the linked model in the drawing area. When its boundary is highlighted, click to select it.

b Click Modify | RVT Links tab ➤ Modify panel ➤ (Pin).

6 (Optional) Display the linked model in halftone, so that you can distinguish its elements from elements in the current project.

See [Displaying a Linked Model in Halftone](#) on page 1195.

7 Start the Copy/Monitor tool:

a Click Collaborate tab ➤ Coordinate panel ➤ Copy/Monitor drop-down ➤ (Select Link).

b Select the linked model in the drawing area.

8 Specify options for the levels to copy.

For example, you can specify an offset for levels, or add a prefix or suffix to level names. See [Specifying Options for Copy/Monitor](#) on page 1251.

9 Copy the levels for monitoring:

a Click Copy/Monitor tab ➤ Tools panel ➤ (Copy).

b In the linked model, select the levels to copy.

To select multiple levels, on the Options Bar, select Multiple. Then select the levels in the drawing area, and click Finish on the Options Bar.

You can use a selection box and a filter to select all levels in the linked model. See [Selecting Elements Using a Filter](#) on page 1442.
Click Copy/Monitor tab ➤ Copy/Monitor panel ➤ (Finish).

The copied levels now display in the current project.

When you select a copied level, the monitor icon displays next to it to indicate that it has a relationship with the original level in the linked model.

If the levels are moved, changed, or deleted in the linked model, you are notified of the changes when you open the current project or reload the linked model. These warnings also display in a coordination review. (See Coordination Review on page 1255.)

10 Delete the remaining original level from the current project.

When you delete the level, Revit Structure also deletes the related plan view.

11 Create plan views for the new levels:
   a Click View tab ➤ Create panel ➤ Plan Views drop-down, and select the desired type of plan view.
   b In the New Plan dialog, select one or more levels from the list, specify the desired scale, and click OK.
   c (Optional) Repeat this process to create other types of plan views.
      For Revit Structure, create analytical plans that correspond to the structural plans. See Applying a View Template for Steel Elements on page 1279.

      The plan view names display in the Project Browser. To rename a view, right-click the view name, and click Rename.

12 (Optional) Hide the linked model.

Related topics
- Copy/Monitor Workflow for Linked Models on page 1243
- Copy/Monitor Best Practices on page 1257
- Troubleshooting Copy/Monitor Issues on page 1258

Copying Elements for Monitoring

You can copy elements from a linked model to the current project, and monitor them for changes. See Copy/Monitor Overview on page 1239.

Use the following procedure to copy grids, columns, walls, and floors (including related openings and inserts) for monitoring. To copy levels for monitoring, see Copying Levels for Monitoring on page 1244.
BEST PRACTICE Copy one type of element at a time. After copying, check to make sure that you achieved the desired result, and then copy the next type of element.

To copy elements for monitoring

1. Open an existing project or start a new project.
   You will copy elements from a Revit model to this project.

2. Prepare a view:
   a. Open a project view where you will be able to see the copied elements.
      For example, use a floor plan view to copy grids, columns, walls, floors, and related openings for monitoring.
   b. In the view properties, for Discipline, select Coordination.
      This setting ensures that the view displays elements for all disciplines (architectural, structural, mechanical, and electrical).

3. (Optional) If you plan to copy grids to the current project, delete existing grids.

4. Link the model into the current project.
   See Linking One Model to Another on page 1184.

5. Pin the linked model in place, so that it cannot be moved inadvertently.

   How to
   a. In the drawing area, select the linked model.
      TIP Move the cursor over the linked model in the drawing area. When its boundary is highlighted, click to select it.
   b. Click Modify | RVT Links tab ➤ Modify panel ➤ (Pin).

6. (Optional) Display the linked model in halftone, so that you can distinguish its elements from elements in the current project.

7. Start the Copy/Monitor tool:
   a. Click Collaborate tab ➤ Coordinate panel ➤ Copy/Monitor drop-down ➤ (Select Link).
   b. Select the linked model in the drawing area.

8. Specify options for the elements to copy.
   For example, you can copy openings and inserts in walls and floors, or change the family type for copied elements. See Specifying Options for Copy/Monitor on page 1251.

9. Copy the elements for monitoring:
   a. Click Copy/Monitor tab ➤ Tools panel ➤ (Copy).
   b. Select the elements to copy.
To select multiple elements, on the Options Bar, select Multiple. Then select the elements in the drawing area, and click Finish on the Options Bar.

You can use a selection box and a filter to select elements in the linked model. See Selecting Elements Using a Filter on page 1442.

c. Click Copy/Monitor tab ➤ Copy/Monitor panel ➤ (Finish).

When you select a copied element in the current project, the monitor icon displays next to it to indicate that it has a relationship with the original element in the linked model.

If copied elements are moved, changed, or deleted in the linked model, you are notified of the changes when you open the current project or reload the linked model. These warnings also display in a coordination review. (See Coordination Review on page 1255.)

10 (Optional) Hide the linked model.

Related topics
- Copy/Monitor Workflow for Linked Models on page 1243
- Copy/Monitor Best Practices on page 1257
- Troubleshooting Copy/Monitor Issues on page 1258

Monitoring Elements in a Linked Model

You can establish and monitor relationships between elements in the current project and a linked model without copying the elements to the current project. (See Monitor Elements in a Linked Model on page 1241.) When a monitored element changes, a warning message displays.

You establish relationships between pairs of corresponding elements. For example, select a grid line in the current project, and then select a grid line in the linked model to form a relationship between them. You cannot monitor unlike pairs, such as a grid line and a level. If you select an opening in a wall or floor, you can monitor other openings or inserts.

To monitor elements in a linked model without copying
1. Open a project.
2. Prepare a view:
   a. Open a project view where you can see the elements to be monitored.
   b. In the view properties, for Discipline, select Coordination.
      This setting ensures that the view displays elements for all disciplines (architectural, structural, mechanical, and electrical).
c Link the model into the current project. See Linking One Model to Another on page 1184.

d Pin the linked model in place, so that it cannot be moved inadvertently:

- In the drawing area, select the linked model.

  **TIP** Move the cursor over the linked model in the drawing area. When its boundary is highlighted, click to select it.

- Click Modify RVT Links tab ➤ Modify panel ➤ (Pin).

e (Optional) Display the linked model in **halftone**, so that you can distinguish its elements from elements in the current project.

3 Click Collaborate tab ➤ Coordinate panel ➤ Copy/Monitor drop-down ➤ (Select Link), and select the linked model in the drawing area.

4 Click Copy/Monitor tab ➤ Tools panel ➤ (Monitor).

5 Select an element in the current project.

6 Select a corresponding element of the same type in the linked model.

The monitor icon displays next to the element to indicate that it has a relationship with another element.

7 Continue selecting as many element pairs as desired.

8 Click Copy/Monitor tab ➤ Copy/Monitor panel ➤ (Finish).

If you modify one of the elements in a pair, a warning indicates that a monitored element has changed. These warnings also display in a coordination review. See Coordination Review on page 1255.

**Related topics**

- Copy/Monitor Workflow for Linked Models on page 1243
- Copy/Monitor Best Practices on page 1257
- Troubleshooting Copy/Monitor Issues on page 1258
Monitoring Elements in the Current Project

You can establish and monitor relationships between 2 elements of the same type in the current project without copying the elements. (See Monitor Elements in the Current Project on page 1241.) When a monitored element changes, a warning message displays.

You establish relationships between pairs of corresponding elements. For example, select a grid line, and then select another grid line to form a relationship between them. You cannot monitor unlike pairs, such as a grid line and a level. If you select an opening in a wall or floor, you can monitor other openings or inserts.

To monitor elements in the current project without copying

1. Open a project.
2. Open a project view where you can see the elements to be monitored.
3. Click Collaborate tab ➤ Coordinate panel ➤ Copy/Monitor drop-down ➤ (Use Current Project).
4. Click Copy/Monitor tab ➤ Tools panel ➤ (Monitor).
5. Select one element.
6. Select another element of the same type to create a relationship between those elements.

The monitor icon displays next to the element to indicate that it has a relationship with another element.

7. Continue selecting as many element pairs as desired.
8. Click Copy/Monitor tab ➤ Copy/Monitor panel ➤ (Finish).

If you modify one of the elements in a pair, a warning indicates that a monitored element has changed. These warnings also display in a coordination review. See Coordination Review on page 1255.

Related topics

- Copy/Monitor Workflow for Linked Models on page 1243
- Copy/Monitor Best Practices on page 1257
- Troubleshooting Copy/Monitor Issues on page 1258
Specifying Options for Copy/Monitor

Before you select elements to copy for monitoring, specify options for the element type. The Copy/Monitor options apply only to elements that you select after specifying the options.

1 Begin the procedure to copy levels or other elements to monitor, and follow the steps through “Start the Copy/Monitor tool.”

For instructions, see Copying Levels for Monitoring on page 1244 or Copying Elements for Monitoring on page 1246.

When you reach the step “Specify options for the elements to copy,” proceed as follows.

2 Click Copy/Monitor tab ➤ Tools panel ➤ (Options).

On the Copy/Monitor Options dialog, tabs contain options for different element types. Use these options to make the copied element different from the original element in various ways.

3 Click the tab for the type of element to copy, and change values in the New type column as desired:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prevent Revit Structure from copying elements of a certain type</td>
<td>Locate the element type in the Original type column. On the same line in the New type column, select Don’t copy this Type.</td>
</tr>
</tbody>
</table>

| Apply a different type to copies of selected elements | Locate the element type in the Original type column. On the same line in the New type column, select the type to apply to the copies. |

4 Under Additional Copy Parameters, specify the desired values for

- levels
- grids
- columns
- walls
- floors

5 Click OK to close the Copy/Monitor Options dialog.

For further instructions, return to Copying Levels for Monitoring on page 1244 or Copying Elements for Monitoring on page 1246.

Related topics

- Copy/Monitor Workflow for Linked Models on page 1243
Copy/Monitor Parameters for Levels

Before selecting levels to copy for monitoring, specify the following parameter values on the Copy/Monitor Options dialog. See Specifying Options for Copy/Monitor on page 1251 and Copying Levels for Monitoring on page 1244.

Offset level

Offsets the copied level vertically from the original level by a specified value. For example, to compensate for the thickness of floor finishes that are not needed on structural levels, structural engineers can enter a negative number for the level offset. As a result, the copied levels will be located below the corresponding architectural levels.

Reuse levels with the same name

When you select this option, if the current project contains a level with the same name as a level in the linked model, a new level is not created. Instead, the existing level in the current project is moved to match the location of the level in the linked model, and monitoring is established between these levels.

Reuse matching levels

Select one of the following values:

- Don’t reuse: Creates a copy of a level, even if the current project already contains a level at the same elevation.
- Reuse if Elements match exactly: If the current project contains a level that occurs at the same elevation as a level in the linked model, the level is not copied. Instead, Revit Structure creates a relationship between these levels in the current project and the linked model.
- Reuse if within offset: If the current project contains a level that occurs at a similar elevation as a level in the linked model (within the value of the Offset Level parameter), the level is not copied. Instead, Revit Structure creates a relationship between these levels in the current project and the linked model.

Add suffix to level name

Enter a suffix to add to the names of copied levels.

Add prefix to level name

Enter a prefix to add to the names of copied levels.

Copy/Monitor Parameters for Grids

Before selecting grids to copy for monitoring, specify the following parameter values on the Copy/Monitor Options dialog. See Specifying Options for Copy/Monitor on page 1251 and Copying Elements for Monitoring on page 1246.

Reuse grids with the same name

When you select this option, if the current project contains a grid line with the same name as a grid line in the linked model, a new grid line is not created. Instead, the existing grid line in the current project is moved
to match the location of the grid line in the linked model, and monitoring is established between these grid lines.

**Reuse matching grids**

Select one of the following values:

- **Don't reuse**: Creates a copy of a grid line, even if the current project already contains a grid line at the same location.

- **Reuse if Elements match exactly**: If the current project contains a grid line that occurs at the same location as a grid line in the linked model, the grid line in the linked model is not copied. Instead, Revit Structure creates a relationship between these grid lines in the current project and the linked model.

**Add suffix to grid name**
Enter a suffix to add to the names of copied grids.

**Add prefix to grid name**
Enter a prefix to add to the names of copied grids.

---

**Copy/Monitor Parameters for Columns**

Before selecting columns to copy for monitoring, specify the following parameter value on the Copy/Monitor Options dialog. See Specifying Options for Copy/Monitor on page 1251 and Copying Elements for Monitoring on page 1246.

**NOTE** You cannot copy slanted columns for monitoring.

**Split columns by levels**

Architects often design models using columns that extend in one solid piece through several levels of the building. However, structural engineers often prefer that columns extend only from one level to the next. This design avoids problems with the analytical model.

Use this parameter to specify that columns extending through multiple levels in the linked model will be split into shorter columns at level lines when copied to the current project.

---

**Copy/Monitor Parameters for Walls**

Before selecting walls to copy for monitoring, specify the following parameter value on the Copy/Monitor Options dialog. See Specifying Options for Copy/Monitor on page 1251 and Copying Elements for Monitoring on page 1246.

**Copy windows/doors/openings**

Select this option if you want the copied wall to include hosted openings, including openings for inserts (such as doors and windows).

In the following example, walls with doors and windows in Revit Architecture (left) retain the corresponding openings when copied to Revit Structure (right).
Copy/Monitor Parameters for Floors

Before selecting floors to copy for monitoring, specify the following parameter value on the Copy/Monitor Options dialog. See Specifying Options for Copy/Monitor on page 1251 and Copying Elements for Monitoring on page 1246.

NOTE When you use Copy/Monitor to copy a floor from an architectural model to a structural model, you can make the copied floor a structural floor. Edit the floor’s properties in Revit Structure to specify its Structural parameter. See Modifying Instance Properties on page 36.

Copy openings/inserts

When Revit Structure copies selected floors, it also copies any hosted inserts and openings, such as shaft openings.

In the following example, floors with a shaft opening have been copied to Revit Structure.

Stopping Element Monitoring

1 Select one or more monitored elements.

When you select a monitored element, the monitor icon displays next to it.

2 Click Multi-Select tab or Modify | <Elements> tab ➤ Monitor panel ➤ (Stop Monitoring).

You can also stop the monitoring of all elements by removing the linked model from the host project. See Link Management Options on page 1206.

Related topics

- Copy/Monitor Overview on page 1239
- Copying Levels for Monitoring on page 1244
- Copying Elements for Monitoring on page 1246
- Monitoring Elements in a Linked Model on page 1248
Coordination Monitor warnings can occur because

- A monitored element is changed, moved, or deleted.
- A hosted element (door, window, or opening) is added, moved, changed, or deleted in a monitored wall or floor.

Changes to view-specific properties, such as view scale and visibility, do not generate Coordination Monitor warnings.

Reviewing Warnings for Monitored Elements

After you establish relationships between elements using the Copy/Monitor tool, you can perform a coordination review to view and address any warnings generated by changes to those elements.

1. Click Collaborate tab ➤ Coordinate panel ➤ Coordination Review drop-down, and then select one of the following options:
   - **Use Current Project**: To review warnings for elements that are monitored within the current project.
   - **Select Link**: To review warnings for elements that are monitored in a linked model. After clicking Select Link, select the linked model in the drawing area.

   The Coordination Review dialog displays a list of warnings for monitored elements. If you are reviewing warnings for a linked model, the Coordination Review dialog displays warnings for the current (host) project and the linked model on separate tabs.

   **NOTE** To check for comments (such as proposed changes) from team members who work on the linked model, click the tab for that model.

2. Expand items in the Message column until you can see values in the Action column.

3. (Optional) To display or hide information about the elements related to each warning, click Elements.

4. (Optional) To locate a changed element in the current project, select the warning in the Coordination Review dialog, and click Show.

   Revit Structure highlights the element in the drawing area. If needed, Revit Structure opens another view to display the element.

   If you want to see the changed element in a different view, you can double-click a view name in the Project Browser without exiting the Coordination Review dialog.

5. For each item, specify the appropriate action.

   See Actions for Coordination Review on page 1256.
6 (Optional) Enter comments regarding an action:
   a In the Comment column, click Add comment.
   b Enter comments in the Edit Comment dialog.
   c Click OK.

Use comments to communicate with cross-functional team members. When other team members open or reload the linked model and perform a coordination review, they can see these comments for each changed element.

7 (Optional) Export the coordination review to an HTML report.

Creating a Coordination Review Report

After performing a coordination review, you can create an HTML report to save a record of the changes, actions, and related comments, or to communicate with team members about the project. If desired, you can open the HTML file in a spreadsheet application to organize or enhance the information.

1 Review warnings for monitored elements, and leave the Coordination Review dialog open.
See Reviewing Warnings for Monitored Elements on page 1255.

2 (Optional) Change the display of warnings:
   ■ To change how the list of warnings is sorted, for Group by, select an option.
   ■ To display or hide information about the elements related to each warning, click Elements.
   ■ To hide postponed messages, in the Show group, clear Postponed.
   ■ To hide rejected changes, in the Show group, clear Rejected.

3 Click Create Report.
4 In the Export Revit Coordination Report dialog, specify a name and location for the HTML file.
5 Click Save.

Actions for Coordination Review

When performing a coordination review, you can specify how to handle each change in the current project. To specify an action for a change, click in the Action column and select an action from the drop-down list. The available action values vary depending on the type of change.

**NOTE** Actions that result in changes affect the current project only. They do not change a linked model.

**Postpone/Do nothing**: Take no action. This value leaves the change to be addressed at a later time.

**Reject**: Select this action to indicate that the change made to the element in the project is incorrect. Instead, a change must be made to the associated monitored element in the linked model.

**Accept difference**: Select this action to indicate that the change made to the monitored element is acceptable, and to update the relationship without changing the corresponding element. For example, suppose 2 monitored grid lines are 200 mm apart, and one is moved to 300 mm away. When you select Accept difference, the monitored grid lines are not moved, and the relationship is updated to 300 mm.

**Modify**: A grid line or wall centerline has changed or moved. Select Modify to apply this change to the corresponding element in the current project.
Rename: The name of a monitored element has changed. Select Rename to apply this change to the corresponding element in the current project.

Move: A monitored element has moved. Select Move to apply this change to the corresponding element in the current project.

Ignore new elements: A new hosted element was added to a monitored wall or floor. Select this action to ignore the new element in the host. It will not be monitored for changes.

Copy new elements: A new hosted element was added to a monitored wall or floor. Select this action to add the new element to the host, and monitor it for changes.

Delete element: A monitored element has been deleted. Select this action to delete the corresponding element in the current project.

Copy Sketch: The sketch or boundary of a monitored opening has changed. Select this action to change the corresponding opening in the current project.

Update extents: The extents of a monitored element have changed. Select this action to change the corresponding element in the current project.

Copy/Monitor Best Practices

Performance: Use Copy/Monitor to monitor changes to the smallest number of elements required to coordinate efforts across teams. Overuse of Copy/Monitor without thoughtful planning can result in performance degradation.

File names: After you link a model to the current project and establish relationships between elements for monitoring, do not change file names for the linked model or the current project. If you do, the monitoring relationships cannot be maintained.

Grids: Do not associate grids with a scope box until after you have copied the grids from a linked model to the host project. You cannot view scope boxes that are defined in a linked model.

Columns: When using Copy/Monitor to copy columns from an architectural model to a structural model, use the Split Columns by Levels option. For example, if the architect adds columns that span levels 1 - 4, the engineer can split the columns at each level. This design avoids problems with the analytical model. See Specifying Options for Copy/Monitor on page 1251 and Copy/Monitor Parameters for Columns on page 1253.

Walls: To ensure that you copy all walls in the model, use a selection box and a filter in a plan view, or use a 3D orthographic view.

Floors: Use Copy/Monitor to copy a floor from an architectural model to a structural model. To make it a structural floor, edit the floor's properties in Revit Structure to specify its Structural parameter. See Modifying Instance Properties on page 36.

Shape-edited floors: If you use Copy/Monitor to copy a shape-edited floor (or slab), the copied element is flat. Use the Slope Arrow tool to slope slabs when possible, or use a separate slab in each building model. See Sloped Surfaces on page 579.

Related topics

- Multi-Discipline Coordination on page 1239
- Copy/Monitor Overview on page 1239
- Copy/Monitor Workflow for Linked Models on page 1243
- Troubleshooting Copy/Monitor Issues on page 1258
Troubleshooting Copy/Monitor Issues

This section provides solutions to issues that you may encounter when using the Copy/Monitor tool to monitor changes to elements.

Cannot See Monitored Elements in View

**Symptom:** You used the Copy/Monitor tool to monitor elements, but you cannot see them in the current view.

**Issue:** The Copy/Monitor tool is typically used to coordinate changes made by teams of different disciplines (architectural, structural, and MEP). By default, many project views display only elements related to the relevant discipline. For example, in Revit Structure, structural plans only display structural elements; they do not display architectural elements.

**Solution:** To ensure that you can see all types of elements in a view, change the discipline for the view:

1. Open a project view where you expect to be able to see the monitored elements.
2. In the view properties, for Discipline, select Coordination.
   
   This setting ensures that the view displays elements for all disciplines (architectural, structural, mechanical, and electrical).

If you still cannot see the monitored elements:

1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
2. On the Model Categories tab, make sure that the desired elements are selected in the Visibility column.
3. On the Revit Links tab, make sure that the linked file is selected in the Visibility column.

Coordination Monitor Alert

**Warning:** Coordination Monitor alert

**Issue:** This warning displays when a monitored element has been moved, changed, or deleted.

**Solution:** Perform a coordination review to identify the changes, and then take action to address them. See Reviewing Warnings for Monitored Elements on page 1255.

If a hosting element no longer exists in the linked file, review orphaned elements to reconcile hosting.

Instance of Linked RVT File Needs Coordination Review

**Warning:** Instance of linked .rvt file needs Coordination Review.

**Issue:** This warning displays when you open, load, or reload a project with monitored elements, and one or more of those elements have changed since the last time the project was opened or loaded.

**Solution:** Perform a coordination review to identify the changes, and take action to address them. See Reviewing Warnings for Monitored Elements on page 1255.
Site Plan Was Deleted

**Symptom:** After deleting levels from a Revit Architecture project, the site view no longer exists.

**Issue:** When you delete all levels in a Revit Architecture project, the site view is also deleted.

**Solution:** Create a site view as follows:

1. Click View tab ➤ Create panel ➤ Plan Views drop-down ➤ ![Floor Plan](image).
2. In the New Plan dialog, clear Do not duplicate existing views.
3. Under Floor Plan views, select the level on which to base the site view.
4. Select the desired scale, and click OK.
5. In the Project Browser, rename the newly created floor plan view to **Site**.
6. Open the Site view.

7. Click View tab ➤ Graphics panel ➤ View Templates drop-down ➤ ![Apply Template to Current View](image).
8. In the Apply View Template dialog, under View Templates, select Site Plan.
9. Under View Properties, change any view properties as desired for the site view.
10. Click OK.

Walls Copied to Revit Structure Are Inaccurate

**Symptom:** Walls copied from Revit Architecture to Revit Structure are not positioned properly.

**Issue:** When you copied a wall from Revit Architecture to Revit Structure, you changed the wall type to represent the structural core. However, the copied walls do not align with the core of the architectural walls. This problem occurs because a copied wall is positioned based on the centerline of the wall, not the centerline of the core of the wall. If the centerline of the structural wall does not match the centerline of the architectural wall, the copied walls are not positioned properly.

**Solution:** To avoid this problem, you can do either of the following:

- Use the architectural wall type for the copied walls in the structural model.
- Do not use Copy/Monitor to copy walls to the structural model. Instead, do the following in the structural model:
  1. Create a wall style that represents only the structural core of the wall.
  2. Link the architectural model into the structural model, and pin it in place.
  3. Using the new structural wall type, manually trace new walls over the architectural walls in the linked model.
  4. Use the Align tool to align and constrain the walls in the structural model to the walls in the architectural model.
Interference Checking

The Interference Check tool finds intersections between elements in a project. These can be a set of selected elements or all elements in the model.

Typical Workflow for Interference Checking

This tool can be used during the design process to coordinate major building elements and systems. It can be used to prevent conflicts and reduce the risk of construction changes and cost overruns.

A common workflow might occur like this:

- An architect meets with a client and creates a basic model.
- The building model is sent to a team that includes members from other disciplines, such as structural engineers. They work on their own version of the model, and then the architect links it in and checks for interferences.
- Team members from other disciplines return the model to the architect.
- The architect runs the Interference Check tool on the existing model.
- A report is generated from the interference check, and undesired intersections are noted.
- The design team discusses the interferences and creates a strategy to address them.
- One or more team members are assigned to fix any conflicts.

Elements Requiring Interference Checking

Some examples of elements that could be checked for interference include:

- Structural girders and purlins
- Structural columns and Architectural Columns on page 509
- Structural braces and Walls on page 449
- Structural braces, doors, and windows
- Roofs on page 519 and Floors on page 555
- Specialty equipment and Floors on page 555
- A linked Revit model and elements in the current model
Running an Interference Check

1. If desired, select some elements in a view.

2. Click Collaborate tab ➤ Coordinate panel ➤ Interference Check drop-down ➤ (Run Interference Check). The Interference Check dialog opens.
   - If you selected elements in the view, the dialog is filtered to display only those element categories.
   - If you did not select any elements, the dialog displays all categories from the current project.

3. On the left side of the dialog, select a value from the first Categories from drop-down.
   For example, select Current Project.

   **NOTE** If you selected a linked Revit model to run a check, you must select its name from this option. For example, if you selected the linked model called Mylink1, select that name from Categories from drop-down. After you select the name, element categories in the linked model are listed.

4. Select the desired categories.
   For example, select Roofs as the category.

5. On the right side of the dialog, select a value from the second Categories from drop-down.
   This value could be a current selection of elements, the current project, or a linked Revit model.

6. Select the other desired categories.
   For example, to complete a roof-floor interference check, select floors as the category.

7. Click OK.
   - If there are no interferences to report, a dialog displays informing you of this.
   - If there are interferences to report, the Interference Report dialog displays. The dialog lists all elements that are in conflict with one another.
     Interferences are grouped according to the way you generated the check. By default, they are grouped as Category 1 (left category column) and Category 2 (right category column). You can change this grouping to Category 2, Category 1. For example, if you ran the roof and floor check, the dialog would list the roof category first, and then which floors are intersecting the roof.

8. To see one of the elements that is intersected, select its name in the Interference Report dialog, and click Show.
   The current view displays the problem.

9. To correct a conflict, click in the view and modify the overlapping elements.
   The Interference Report dialog remains visible.

10. When you have fixed the problem intersection, in the Interference Report dialog, click Refresh.
    If the problem has been resolved, the problem elements are removed from the list of conflicts.

   **NOTE** Refresh rechecks only those interferences in the current report. It does not rerun the interference check.

You can continue resolving conflicts in this manner.
If you cannot resolve all conflicts without additional input from team members, you can generate an HTML version of the report.


12. Enter a name, navigate to the desired folder to save the report, and click Save.

To see the last report generated again, click Collaborate tab ➤ Coordinate panel ➤ Interference Check drop-down ➤ (Show Last Report).
This tool does not rerun the interference check.

**Interference Check Tips**

- Processing time for interference checks can vary greatly. In a large model, checking all categories against each other can take a long time and is **not recommended**. To reduce processing time, select a limited set of elements or a limited number of categories.

- To run a check on all available categories, click All in the Interference Check dialog, and then select one of the check boxes next to a category.

- Click None to clear the selection of any categories.

- Click Invert to change the selection between categories that are currently selected and those that are not.
A Revit Structure project has internal coordinates for all the elements that compose the model in a project. Those coordinates are known to this project only. This is acceptable if you have a standalone model whose position is not relevant to other models or to a site. However, if you want the position of the model to be known to other linked models, you need to share coordinates.

Shared coordinates are used for remembering the mutual positions of multiple interlinked files. Those interlinked files can be all Revit files, or a combination of Revit, DWG, and DXF files.

**Recommended Uses for Shared Positioning**

If the significant coordinates for a project are in a linked model, such as a building model with a linked site, acquire the coordinates from the linked model.

If the significant coordinates for a project are in the host model, such as a site with linked building models, publish coordinates from the host to the linked models.

**TIP** You should derive shared coordinates from only one file. That one file defines the coordinates for all other files that compose the project. Acquire coordinates from one file and then publish those coordinates to other files.

**Defining Named Positions**

Revit Structure projects can have named positions. A named position is the placement of a model instance in a Revit Structure project. By default, each Revit Structure project contains at least one named position, called Internal.

If your Revit Structure project contains a unique structure or a site model, it typically has only one named position.

If your Revit Structure project contains several identical buildings, it will have many positions in it.

You want may want several positions of a building to create a campus look. For example:

- Several identical dormitory buildings on the same site
- Identical condominiums on the same site

You might also want several positions for a unique building. In this case, you could import the building into a site model and then move the building around on the site by choosing different positions.
Positions are modifiable in a project. You can delete, rename, and create new positions, and switch between positions.

**Seeing and Creating Named Positions**

1. Click Manage tab ➤ Project Location panel ➤ ![Location](Location).
2. In the Location Weather and Site dialog, click the Site tab.
   
   The Location Weather and Site dialog lists the current named positions in the project. By default, each project has a named position called Internal.

3. To create a new named position, click Duplicate.
4. Enter a name for the position, and click OK.
5. To rename an existing position, click Rename.
6. To delete an existing position, click Delete.

   **NOTE** You cannot delete the last position.

7. To change the active position of the project, select it and click Make Current.
8. Click OK.

**Repositioning Named Positions**

After you have set up a shared coordinate system between the host model and the linked files, the placement of a linked file is determined by its corresponding position in the host model. You can drag the linked file to another placement inside the host model. When you do this, you are actually changing the corresponding position in the linked file.

When you reposition the linked file to a new position, you can save that change. There are several ways to do this.

**Warning Dialog**

After you move the linked file, a warning indicates that the linked file will change. This occurred because you have defined a new placement for the named position in the linked file. In the warning dialog, you can choose to save the linked file or save the new position later by clicking Save Positions in the Manage Links dialog. If you click Save Now, Revit Structure saves the new position to the host model.

**Recording a New Location with Manage Links**

1. Click Manage tab ➤ Manage Project panel ➤ ![Manage Links](Manage Links).
2. Click the tab for the model file type that you have linked. For example, if you have linked a Revit model, click the Revit tab.
3. Click the linked file name to select it.
4. Click Save Positions.
5. The Location Position Changed dialog displays the following options:
   - Save. Saves the new position of the host model back to the linked file.
   - Do not save. Changes to positions are discarded, and the linked file returns to its previously saved position when it is reloaded or reopened.
■ Disable shared positioning. The linked model keeps it current position. The shared coordinates between the linked file and the host model are disabled. The Shared Position parameter is set to <Not Shared> in the linked file.

6 Click OK to close the Manage Links dialog.

If you save or close the host model, you are prompted to save the linked models. The Save Modified Linked Model dialog displays.

If you unload a linked file, the Save Modified Linked Model dialog displays. Again, you are prompted to save changes to the linked model.

**Modifying Linked Model Position Through Instance Properties**

1 Select a linked instance in the host model.

2 Click Modify | RVT Links tab ➤ Properties panel ➤ (Properties), and click the button that appears next to the Shared Position parameter.

The Choose Position dialog displays the current position of the linked instance.

**NOTE** If the Share Coordinates dialog displays, select an option to reconcile the coordinates, click Reconcile, and then the Choose Position dialog will display. For more information, see Acquiring or Publishing Through Linked Instance Properties on page 1268.

3 Specify how to set the position of the linked instance:

■ Select Move Instance To and choose a position name. The listed position names are from the linked model file. When you click OK, the linked instance moves to the recorded placement for that named position.

■ Select Record Current Position As to record the current position of the linked model instance back to its file. If you want to create a new position name for the instance, click Change to add a new position name that is also saved back to the linked model file.

■ Select Do Not Share Position of Selected Instance to place the instance in the desired position and break the share between the linked and model files. If you select this option, you can move the linked instance in the host model without changing the linked model file.

4 Click OK.

**Acquiring and Publishing Coordinates**

In general, you want to acquire coordinates from a linked Revit project (such as a site) if you are working in a building model file. If you are working in the site model, you want to publish coordinates from the site model to linked building models.

In either case, you publish or acquire coordinates while you are in a host model.

**Acquire Coordinates**

When you acquire coordinates from a linked Revit project, the shared coordinates of the linked project become the shared coordinates of the host project, based on the position of the linked project instance in the host project. There is no change to the host project's internal coordinates. The host project also acquires True North from the linked project. The origin of the linked project's shared coordinates becomes the origin of the host project's shared coordinates.
When a Revit Structure project acquires coordinates from a linked DWG file, the World Coordinate System (WCS) of the selected linked DWG file becomes the shared coordinate system of the host Revit Structure project, based on the position of the linked DWG instance. The Y axis of the DWG becomes True North, and the origin of the DWG becomes the origin of the shared coordinate system of the Revit Structure project.

**To acquire coordinates:**

1. Click Manage tab ➤ Project Location panel ➤ Coordinates drop-down ➤ (Acquire Coordinates).
2. Place the cursor on a linked model instance, and click.

The host model file now has the same shared coordinates as the linked model file. If other loaded linked models share coordinates with the host model, they also acquire the new coordinates.

**Publish Coordinates**

When you publish shared coordinates from a host project to a linked project, this changes the linked project. The host project’s True North and shared origin are recorded in the linked project, based on the current position of the linked instance. This location is now named in both the host project and the linked project. More than one position of the link can be recorded.

When you publish shared coordinates from a host Revit Structure project to a linked DWG, this changes the linked DWG. The origin of the host Revit Structure project’s shared coordinate system becomes the origin of a new User Coordinate System (UCS) in the DWG file. The Y axis of the new UCS corresponds to the host project’s True North. You can name the UCS when you publish coordinates. It is not recommended that you change this name after publishing coordinates.

**To publish coordinates:**

1. Click Manage tab ➤ Project Location panel ➤ Coordinates drop-down ➤ (Publish Coordinates).
2. Place the cursor on a linked model instance and click.
3. Select a named position from the linked model, and click OK.
   
   See Defining Named Positions on page 1265.

The linked model file now has the same shared coordinates as the host model file.

**Acquiring or Publishing Through Linked Instance Properties**

This procedure assumes that you have a linked model instance in the host model, and its coordinates are not currently shared with those of the host model.

1. Select the linked model in the host model and click Modify | RVT Links tab ➤ Properties panel ➤ (Properties).
   
   Notice the button in the value box next to the Shared Position parameter. It reads Not Shared, which indicates that there is no coordinate sharing between the linked instance and the host model.

2. Click the button.
   
   Because this is the first time that you are setting up shared coordinates between the host and the linked models, a dialog displays, telling you that you need to reconcile the coordinates in favor of the host or the linked model. You need to reconcile the coordinates only once.
3 Select Publish or Acquire:
   ■ You publish the coordinates of the host model to the linked model. The linked model file
     coordinates change to the host model file's coordinates.
   ■ You acquire the coordinates from the linked model to the host model.

4 The linked model's placement in the host model is saved to a position name in the linked model
   file. If desired, you can change the name of the position by clicking Change and selecting a
   name from the Select Position dialog.

5 Click Reconcile to confirm changes.

6 Click OK to close the linked model properties.

Tips on Acquiring and Publishing
You cannot acquire or publish coordinates from a project that has multiple positions using the Acquire
Coordinates or Publish Coordinates tools. Instead, use the properties of the linked model. See Defining
Named Positions on page 1265.

Relocating and Mirroring a Project
To see the results of relocating a project, the host project must contain linked instances at shared positions.
The relocate function modifies the placement of all elements in the project and any import instances that
are not linked. In addition, any linked instances that are not at shared positions move relative to all linked
instances at shared positions.

Related topics
■ Project Location and Orientation on page 107
■ Rotating a View to True North on page 110

Relocating a Project
The Relocate this Project tool moves the entire project relative to the shared coordinate system.

1 Click Manage tab ➤ Project Location panel ➤ Position drop-down ➤ (Relocate Project).
   You use the tool just like the Move tool.

2 Move the project graphically in the view. See Moving Elements with the Move Tool on page
   1475.

   NOTE If you have set levels or spot elevations to report values from the shared origin, their values

Relocating a Project by Entering Points
You can relocate a project and rotate the project to True North by entering specific coordinates for
North/South, East/West, and Elevation. You can also set the angle between True North and Project North.
You can click anywhere in a view to set the coordinates. Some coordinates may not be editable depending
on where you click. For example, in elevation, if you click on a level line, the only value that you can edit
is elevation.
You can use this tool when you have a specific set of coordinates from a surveyor, or if you report shared coordinates and want to relocate the project to the coordinates reported.

To relocate a project by entering points:

1. Click Manage tab ➤ Project Location panel ➤ Coordinates drop-down ➤ (Specify Coordinates at Point).
2. Place the cursor in the view, and click to select a point at which to enter the coordinates.
   The Specify Shared Coordinates dialog displays values for the coordinates of the selected point. The dialog displays only values that it can infer from the point.
3. Enter coordinate values for the selected point.
4. If you want to rotate the project from Project North to True North, enter a value and direction.
5. Click OK to save the new coordinates for the selected point.

Mirroring a Project

Mirroring a project allows you to mirror (reflect the placement and shape of) all elements in a project around an axis you select (North - South, East - West, Northeast - Southwest, or Northwest - Southeast). When you mirror a project, model elements, all views, and annotations are mirrored. Orientation of annotations is preserved when necessary, for example text does not mirror in order to retain readability.

To mirror a project:

1. Click Manage tab ➤ Project Location panel ➤ Position drop-down ➤ (Mirror Project).
2. In the Mirror Project dialog, select an option.
3. Click OK.

In some cases when you mirror a project, relationships between elements are not supported as in the original orientation of the project. This can lead to unexpected results and errors, for example some elements may deviate from exact reflection. After you mirror the project, a message displays to indicate any errors encountered. You can export errors to review and correct them.

For information on exporting errors, see Exporting Warnings to a File on page 1681. For information on finding elements in the project that are associated with errors, see Diagnostic Tools on page 1678. For information on the tools you can use to correct errors, see Editing Elements on page 1439.

Reporting Shared Coordinates

You can report the shared coordinates of a linked model within a host model. The coordinates returned are with respect to the shared coordinates between the models.

1. Click Manage tab ➤ Project Location panel ➤ Coordinates drop-down ➤ (Report Shared Coordinates).
2. Place the cursor on a reference point of the linked model.
   A reference point can be an edge of an element (such as a roof) or the corner of 2 walls.
3. Click the reference.
   The coordinates of the reference display on the Options Bar. The reference's elevation also displays.
NOTE If you click somewhere in a plan view (other than a reference), you see the North, South, East, and West coordinates of that point. In a section or elevation view, you see only the elevation of the point.

Project Base Points and Survey Points

Every project has a project base point 🔧 and a survey point 🔧, although they might not be visible in all views, because of visibility settings and view clippings. They cannot be deleted.

The project base point defines the origin (0,0,0) of the project coordinate system. It also can be used to position the building on the site and for locating the design elements of a building during construction. Spot coordinates and spot elevations that reference the project coordinate system are displayed relative to this point.

The survey point represents a known point in the physical world, such as a geodetic survey marker. The survey point is used to correctly orient the building geometry in another coordinate system, such as the coordinate system used in a civil engineering application.

Making Project Base Points and Survey Points Visible

To turn on the visibility of the project base point and survey point in a view:

1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
2. On the Model Categories tab of the Visibility/Graphics dialog, scroll down to Site, and expand it.
3. To display the project base point, select Project Base Point.
4. To display the survey point, select Survey Point.

You can also click (Reveal Hidden Elements) on the View Control bar to turn on the visibility of the project base point and survey point in a view.

Moving Project Base Points and Survey Points

The project base point and the survey point can be (clipped) or (unclipped). By default, they are clipped in all views. To switch between the clipped and unclipped states, first click the point, and then the icon.

The following table describes how clipping and unclipping affects these points when you move them in a view.

<table>
<thead>
<tr>
<th>Clipped</th>
<th>Unclipped</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Base Point</td>
<td></td>
</tr>
<tr>
<td>Moving a clipped project base point is the same as using the Relocate Project tool. See Relocating a Project on page 1269.</td>
<td></td>
</tr>
<tr>
<td>Project coordinates do not change for the model elements.</td>
<td></td>
</tr>
<tr>
<td>Shared coordinates change for the model elements.</td>
<td></td>
</tr>
<tr>
<td>Moving an unclipped project base point repositions the project coordinate system relative to both the model geometry and shared coordinate system.</td>
<td></td>
</tr>
<tr>
<td>Project coordinates change for the model elements.</td>
<td></td>
</tr>
<tr>
<td>The shared coordinates of the project base point change in the shared co-</td>
<td></td>
</tr>
<tr>
<td>Clipped</td>
<td>Unclipped</td>
</tr>
<tr>
<td>---------</td>
<td>-----------</td>
</tr>
</tbody>
</table>
| - Moving a clipped survey point repositions the shared coordinate system relative to the model geometry and the project coordinate system.  
  - Project coordinates do not change for the model elements.  
  - Shared coordinates change for the model elements. | - Moving an unclipped survey point moves only the survey point relative to the shared coordinate and the project coordinate systems.  
  - Project coordinates do not change for the model elements.  
  - Shared coordinates do not change for the model elements.  
  - Only the shared coordinates of the survey point itself change. |

To move the project base point or survey point in a view, do one of the following:

- Drag the point to the desired position.
- Click the point, and then click the desired coordinate to open the text box. Enter the new coordinates.

For a project base point, changing the value of the Angle to True North is another way of rotating a project to True North. See Rotating a View to True North on page 110.

The startup location is the original position of the project base point in a new project. To return the project base point to its startup location:

1. Unclip the project base point.
2. Right-click the project base point, and click Move to Startup Location.

### Pinning Project Base Points and Survey Points

You cannot move a pinned project base point or survey point. Pinning the project base point disables the Relocate Project and the Rotate Project North tools. Pinning the survey point disables the Rotate True North, Acquire Coordinates, and Specify Coordinates tools. See Preventing Elements from Moving on page 1484.

### Tips for Working with Project Base Points and Survey Points

Consider the following when working with project base points and survey points:

- To ensure accuracy of the model, be sure the model geometry is less than 1 mile from the startup location of the project base point. To check this measurement:
  1. Use Move to Startup Location from the shortcut menu to move the project base point back to its startup location.
  2. Use the Measure tool on the Modify tab to measure the distance from the project base point to the model geometry.
If the distance is more than 1 mile, move the model geometry within 1 mile of the startup location of the project base point.

Before you export a building site to a civil engineering application that accepts ADSK files, such as Civil 3D:

1. Move the unclipped survey point to the location agreed upon with the civil engineer.
2. Use the Specify Coordinates at a Point tool or enter the coordinates on the Site tab of the Building Site Export dialog, using the coordinates provided by the civil engineer.

To ensure that an imported DWG site is positioned correctly in the project:

1. Using the coordinates you received from the civil engineer, specify the shared coordinates of the survey point.
2. Specify the correct angle for True North.
3. Specify Positioning-Auto by Shared Coordinates to link the DWG file.
Analyze the Design
This chapter describes components and tools of the Revit Structure analytical model that develops simultaneously while you develop a physical building model.

**Structural Analytical Model Overview**

In Revit Structure, an analytical model is a simplified 3D representation of the full engineering description of a structural physical model. The analytical model consists of those structural components, geometry, material properties, and loads, that together form an engineering system. The analytical model is created automatically while you create the physical model, and can be exported to analysis and design applications.

For more information, see [Linking with Analysis and Design Applications](#) on page 1327.

In the following illustrations, the top view represents the physical model, and the bottom view represents the analytical model.
You create your physical model in Revit Structure within views that represent the physical structure. You can think of the physical model as a set of production drawings. As you build your physical model, analytical model creation is occurring on-the-fly. Revit Structure maintains the analytical model for you.
The coarse representation of structural elements that you view in the physical model is not the analytical model. The analytical model is geometrically dependent upon the physical model, but is viewed as dependent objects.

**Visualization**

Visualization of the analytical model depends on the project template, view template, view parameters, and object styles.

**Project Template and View Template**

Project template files provide initial conditions to a project. When you start a new project, using a template, the project inherits all families, settings, and geometry from the template file. When you open Revit Structure, a project file is created based on a default template. The default template installed with Revit Structure is either Structural Analysis-Default.rte or Structural Analysis-DefaultMetric.rte, depending on the default units setting.

A project that is created with the structural analysis default template has several default structural plan levels in the Project Browser (see Physical Views and Analytical Views on page 1285). In addition, under 3D views, there is a default three-dimensional analytical view named View 1 - Analytical.

**NOTE** Default elevation views do not include analytical view properties.

If analytical elevation views are required, or additional plan views have been created and require analytical views, the analytical view template may be applied. See Applying a View Template for Steel Elements on page 1279.

**Applying a View Template for Steel Elements**

If you create a new level named, for example, Level 3, you must also explicitly create a new analytical level view named Level 3 - Analytical. You do this in order to use the analytical view for analysis and design purposes.

The following steps detail the creation of a view template for steel elements.

1. In the Project Browser, right-click Level 3, and select Duplicate View ➤ Duplicate.
2. Select the copy of Level 3, right-click, and click Rename.
3. Enter Level 3 - Analytical.
   
   Use the following steps only with steel elements:

4. Select View tab ➤ Graphics panel ➤ View Templates drop-down ➤ Apply Template to Current View.
5. In the Apply View Template dialog, select <all> from Show type. For Names, select Structural Analytical Normal or Structural Analytical Stick.

   The Structural Analytical Normal view template will present structural components in this new analytical plan view with both the analytical model and the physical model displayed.
The Structural Analytical Stick view template will present structural components in this new analytical plan with only the analytical model displayed.

NOTE If the visibility of loads is turned off in the view, apply either the stick or normal analytical view template to the view to cause loads to display.

View Parameters and Object Styles

In addition to using view templates, you can edit view parameters for the custom visualization of the structural member analytical models.

Accessing View Parameters

1. In the Project Browser, open an analytical plan view.

2. Select View tab ➤ Graphics panel ➤ Visibility & Graphics to open the Visibility/Graphics dialog that applies to the current analytical view.

Notice in the following illustration that the Structural Column and Structural Framing Categories are expanded, revealing the current Analytical records of each. These sub-categories are selected in the Visibility field, making these categories currently visible. For more information about editing Visibility/Graphics, see Visibility and Graphic Display in Project Views on page 801.

![Visibility/Graphics dialog for Floor Plan: Level 1](image)
**Viewing Object Styles**

In the Visibility/Graphics dialog of an analytical plan view, click Object Styles to open the Object Styles dialog.

![Object Styles dialog](image)

Notice in the illustration that object visibility parameters are available for editing. These parameters include Line Weight, Line Color, Line Pattern, and Material. For more information about how to use the Object Styles dialog, see *Object Styles* on page 1601.

**Structural Member Analytical Models**

An analytical model of a structure is comprised of a set of structural member analytical models including one for each element in the structure. The following structural elements have structural member analytical models: Structural Columns, Structural Framing elements (such as beams and braces), Structural Floors, and Structural Walls.

The analytical model of any one structural element has:

- **Instance parameters**
- **Physical material properties**
- **Default position relative to the structural member itself**
- **Location with respect to a projection plane, either as placed or as adjusted**

**Instance Parameters**

Analytical parameters of a structural element are instance parameters that are unique to, and apply only to one instance of a structural member in your model. This makes it possible for you to uniquely define each element.

For a complete listing of instance parameters categorized by structural element, see *Structural Modeling* on page 217. The following is a summary of the structural analytical instance parameters:
**Analytical Projection Plane**

The analytical projection plane references the location of, or the limits of, the structural member analytical model. The following table defines the plane for each structural element type.

<table>
<thead>
<tr>
<th>Structural Element</th>
<th>Default Analytical Projection Plane</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columns</td>
<td>Columns have an analytical projection plane at the top and the base of the column. These horizontal planes are offset from a level and define the limits of the structural column analytical model.</td>
</tr>
<tr>
<td>Structural Walls</td>
<td>The central plane of the wall.</td>
</tr>
<tr>
<td>Beams</td>
<td>Beams have an analytical projection plane parallel to the x-axis of the beam. The plane is defined at a plan level or relative to the beam section geometry.</td>
</tr>
<tr>
<td>Braces</td>
<td>Relative to the brace section geometry. The plane is parallel to the x-axis of the brace.</td>
</tr>
<tr>
<td>Structural Floors</td>
<td>The analytical projection plane of a structural floor is parallel to the plan level on first placement. Subsequent structural floor placements reference the last used projection plane.</td>
</tr>
<tr>
<td>Foundation Slabs</td>
<td>The top face of the foundation slab.</td>
</tr>
</tbody>
</table>

See [Projection Plane Options for each Structural Element Type](#) on page 1301.

**Physical Material Properties**

The Material instance parameters of elements in your model are included in the export process of your model to analysis and design applications. Revit Structure provides default concrete, steel, wood and generic material properties. You can use the default material definitions as the basis for adding new physical material types to your model database. For example, you can create a concrete sub-type called Concrete 4000 psi and adjust the physical parameters accordingly for your project.

You add new types and edit these types by using the Structural Material Properties dialog. For information about how to create new physical material types, see [Creating a Material Physical Parameter Set](#) on page 1597.

**Release Conditions**

A release is defined by six components:

- Fx - axial force (X direction)
- Fy - shear force (Y direction)
- Fz - shear force (Z direction)
- Mx - torsion force (X direction)
- My - bending moment (Y direction)
- Mz - bending moment (Z direction)

**NOTE** These components only relate to linear elements such as Structural Framing elements (beams and braces) and Structural Columns. These do not apply to Structural Walls or Structural Floors.

The Revit Structure release conditions are Fixed, Pinned, Bending Moment, or User-defined. The default value for beams, braces, and columns is Pinned at both ends.

- Pinned Release Condition is defined as *all moments released*.
- Fixed Release Condition is defined as *no releases*.
- Bending Moment Release Condition is defined as *my and mz released (torsion not released)*.
- User-defined Release Condition is defined as *all releases made available for engineer to define as needed*.

**Rigid Link**

A rigid link connects an end of the analytical model of a beam to the analytical model of a column. In analysis and design applications, it is resolved to be an infinitely rigid frame element with no weight.

Rigid link is an instance property for columns and beams under Analytical Model properties. For beams, you can select On, Off, or From Column.

Columns that overlap but don’t necessarily join the physical model of a beam can have rigid links with the beam.

In this case, the column is a potential candidate for rigid links as seen in the following illustration.

Beams that span multiple columns can accommodate rigid links similarly. All columns in the following illustration, whether joined or not, can have rigid links with the beam.
The following table shows rigid link behavior based on the settings of both the columns and the beam.

<table>
<thead>
<tr>
<th>Rigid Link Settings</th>
<th>Beam</th>
<th>Column 1</th>
<th>Column 2</th>
<th>Column 3</th>
<th>Column 4</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>From</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>From</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>From</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>From</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

**Default Position Relative to the Structural Member Itself**

Default position of the analytical model of each structural element type is defined in Analytical Model Continuity on page 1286.

**Location with Respect to an Analytical Projection Plane - Either As Placed or As Adjusted**

Analytical reference planes are explained in Analytical Projection Plane on page 1282.
Analytical Model Settings

Use the Analytical Model Settings tab in the Structural Settings dialog to adjust how Revit Structure performs certain tasks on the analytical model.

The settings are as follows

- **Automatic Checks**  When enabled, automatic support checking provides a warning when a member is not supported. This setting is useful when most of the structure has been modeled, and the user desires to know if changes made to the model cause elements to become unsupported. It is not recommended that you enable this setting in the early stages of a project, as the number of elements unsupported during model creation is significant. For more information, see Verifying the Analytical Model on page 1322.

- **Analytical/Physical Model Consistency**  See Verifying the Analytical Model on page 1322.

- **Tolerances**  Set tolerance limits for horizontal and vertical analytical model automatic adjustment. For more information, see Automatic Adjustment of the Analytical Model (Auto-Detect) on page 1288.

- **Analytical/Physical Model Consistency Check**  See Verifying the Analytical Model on page 1322.

Physical Views and Analytical Views

When you start a Revit Structure project using the structural analysis default project template, two structural plan views are created for each of the two default structure levels of your project:

- **Level 1**
- **Level 1 - Analytical**
- **Level 2**
- **Level 2 - Analytical**
The Level 1 and Level 2 views illustrate the physical model. The Level 1 - Analytical and Level 2 - Analytical views illustrate the analytical model. The same element is depicted differently in each view based on the view’s display settings. For example, the following illustrations display the same column-beam connection, although they differ because of the visibility/graphical overrides. For an explanation of how view templates, graphical overrides, and object styles are used to visualize the model, see Visualization on page 1279.

**Level 1 - Plan View**

![Level 1 - Plan View Diagram]

**Level 1 - Analytical Plan View**

![Level 1 - Analytical Plan View Diagram]

### Analytical Model Continuity

The analytical model that is generated in Revit Structure may have discrepancies that are not suitable for direct integration with structural analysis and design software. You can use Revit Structure to automatically adjust the analytical model, reducing or eliminating these discrepancies for both existing and newly created elements. Also, use Revit Structure to disassociate or reassociate continuity of the analytical model.
Examples of End Join Continuity

Following are some of the more common examples of end join continuity:

**Beam to Column**

The default join relationship between a beam and column is set to top of the beam and to the center of the column.

**Beam to Beam**

The default join relationship between two beams is set to the top of each beam.

**Brace to Beam**

Notice in the following example that the analytical model of the brace is at an angle to the physical model of the brace. The automatic joins of a brace are dependent upon where in elevation you locate the brace end using the mouse pointer. In the following illustration, the analytical model of the brace is joined at one end to the analytical model of the column, and at the other end to the analytical model of the beam, which is at the top of the beam.
Beam to Wall

The default join relationship between a concrete beam and wall is the center of the wall to the center of the beam.

Automatic Adjustment of the Analytical Model (Auto-Detect)

Automatic adjustment is performed on a structural element, in relation to a neighboring structural element. Revit Structure can automatically adjust the analytical model for beams, structural columns, structural walls and structural floors so that they align more accurately. For more information, see Analytical Model Continuity on page 1286.

Auto-Detect Instance Parameters

You can modify the auto-detect instance parameters for the following structural elements: beams, columns, walls, floors, and a sketch curve in a structural floor sketch. If the parameter is not set to Auto-Detect, or the horizontal auto-detection parameter is set to False, no automatic adjustment is made. You need to set the parameter to Auto-Detect. Then, the adjustment is performed, as long as the Analytical Model of the adjacent element is within tolerance.
### Analytical Model Instance Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Applicable Elements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analytical Model</td>
<td>When selected, all parameters for the analytical model are enabled. Structural Usage must be set to Bearing.</td>
<td>Walls</td>
</tr>
<tr>
<td>Enable Analytical Model Walls, Columns, Beams</td>
<td>Specifies the horizontal plane (xy direction) to which the analytical model will be adjusted. For more information, see Analytical Projection Rules on page 1289.</td>
<td>Walls, Columns, Beams</td>
</tr>
<tr>
<td>Top VerticalProjection Walls, Columns</td>
<td>Specifies the top vertical projection plane (z-direction) to which the analytical model will be adjusted. For more information, see Analytical Projection Rules on page 1289.</td>
<td>Walls, Columns</td>
</tr>
<tr>
<td>Bottom Vertical Projection Walls, Columns</td>
<td>Specifies the bottom vertical projection plane (z-direction) to which the analytical model will be adjusted. For more information, see Analytical Projection Rules on page 1289.</td>
<td>Walls, Columns</td>
</tr>
<tr>
<td>Horizontal Projection Columns, Beams</td>
<td>Specifies the horizontal projection plane (xy-direction) to which the analytical model will be adjusted. For more information, see Analytical Projection Rules on page 1289.</td>
<td>Columns, Beams</td>
</tr>
<tr>
<td>Vertical Projection Beams, Structural Floors</td>
<td>Specifies the vertical projection plane (z-direction) to which the analytical model will be adjusted. For more information, see Analytical Projection Rules on page 1289.</td>
<td>Beams, Structural Floors</td>
</tr>
<tr>
<td>Rigid Links Structural Columns, Beams</td>
<td>When enabled, an additional analytical segment is engaged in the model between the end of the analytical model of a beam and the analytical model of a column.</td>
<td>Structural Columns, Beams</td>
</tr>
</tbody>
</table>

### Analytical Projection Rules

Analytical projection rules are based on the presence of additional elements in relation to the element, the element itself (whether it's a beam, column, floor, or wall), the order of creation, and specified projection properties.

**Horizontal Projection (xy-direction)**

- Horizontal projection instance properties adjust detection accordingly for columns and beams.

<table>
<thead>
<tr>
<th>Horizontal Projection Plane Property</th>
<th>Structural Columns</th>
<th>Structural Beams</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto-detect</td>
<td>The analytical model auto-detects and orients itself to the horizontal projection plane.</td>
<td>The analytical model starts at the center line of the beam and projects horizontally to</td>
</tr>
<tr>
<td>Horizontal Projection Plane Property</td>
<td>Structural Columns</td>
<td>Structural Beams</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>--------------------</td>
<td>------------------</td>
</tr>
<tr>
<td>See Examples of Auto-Detect on page 1292.</td>
<td>walls if present. The endpoints of the beams maintain joins with neighboring walls and columns. See Examples of Auto-Detect on page 1292.</td>
<td></td>
</tr>
<tr>
<td><strong>Default</strong></td>
<td>The analytical model starts in the center of the column and projects to joined structural walls.</td>
<td>The analytical model starts at the center line of the beam and projects horizontally to walls if present. The endpoints of the beams maintain joins with neighboring walls and columns.</td>
</tr>
<tr>
<td><strong>Center Line</strong></td>
<td>Not applicable to columns.</td>
<td>The analytical model orients to the center line of the beam.</td>
</tr>
<tr>
<td><strong>Location Line</strong></td>
<td>Not applicable to columns.</td>
<td>The analytical model orients to the location line of the beam.</td>
</tr>
<tr>
<td><strong>&lt;Named Reference Planes&gt;</strong></td>
<td>The analytical model projects horizontally to a specific reference plane.</td>
<td>The analytical model projects horizontally to a specific reference plane. In the following illustration, the column is projecting to a reference plane parallel to Grid A.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="image" alt="Diagram" /> This is not applicable to curved beams.</td>
</tr>
<tr>
<td><strong>&lt;Grid&gt;</strong></td>
<td>The analytical model projects horizontally to a specific grid.</td>
<td>The analytical model projects horizontally to a specific grid. In the following illustration, the beam is projecting to Grid 1.</td>
</tr>
</tbody>
</table>
This is not applicable to curved beams.

When structural columns and beams are joined, they can project to the same plane or grid. In the following illustration, columns are projected to a reference plane. The parametric relationship between columns and beams is shown as the analytical projection of the beams adjust to meet those of the columns.

The horizontal projection properties of a structural wall can be specified as Interior, Exterior, Center Line, or Center of Core. When the Horizontal Projection instance property for a wall is specified as a Center Line on a vertically compound structural wall, it includes all layers and regions to calculate the center. To place the analytical projection at the center of the wall core, specify the Horizontal Projection as Center of Core.

Vertical Projection (z - direction)

- In the vertical direction, structural floors will define the location of the analytical projection planes.
- Top and bottom vertical projection planes for walls will adjust to the analytical projection of a structural floor.
- Top and bottom vertical projection planes for columns will adjust to the analytical projection of a structural floor. Similarly, columns will attempt to project to nearby beams.
Structural floors will always take precedence in the auto-detect behavior.

- Analytical projecting plane of beams will adjust to the analytical projection of a structural floor.

Elements of the Same Category

- For elements of the same structural category (such as floor-to-floor or wall-to-wall) auto-detect is based on the order of creation, with the highest priority given to the element created first.

- The exception to this rule is when the analytical project parameter has been changed from “auto-detect” for one of these elements. Then, that element will have the highest priority. For example, wall 1 is the first wall created, followed by wall 2, then by wall 3, all of which are set to Auto-Detect. If the horizontal projection of wall 2 is changed to center line, then the analytical projection of wall 3 and wall 1 will align to the center line of wall 2.

Examples of Auto-Detect

The auto-detect feature automatically adjusts the analytical model when creating the following structural elements within a project:

- Beams
  During creation, the corresponding beam to structural floor projection planes are matched with the beam vertical projection (Analytical Model parameters) set to Auto-Detect, as shown:

- Columns
  During creation, the auto-detect feature places the analytical model of columns and walls in the same plane.

- Structural Floors and Walls
During creation, the auto-detect feature aligns the vertical and horizontal analytical projection plane of walls, despite any variation in wall thicknesses or projection plane location.

If a wall and floor are joined, the top or bottom plane of the wall’s analytical model will coincide with the floor analytical model.
If a wall has a portion that extends beyond the roof (commonly known as a parapet), it can be specified in the wall's analytical model that loads that extend above a level with framing members are excluded. If the analytical edge of floor coincides with the beam or wall analytical model, the exterior of the wall can be defined as the analytical projection plane. Also, it can be trimmed back to the analytical/physical model of the floor, as shown in the following illustration:

Auto-Detect Tolerances

The auto-detect feature provides tolerances, including distances for the analytical-to-physical model and analytical adjustments, and the auto-detect tolerances for both horizontal and vertical planes.

Setting the Auto-Detect tolerances

1. Select Manage tab ➤ Settings panel ➤ Structural Settings.
2. In the Structural Settings dialog, click the Analytical Model Settings tab.

![Structural Settings dialog]

### Auto-Detect Tolerances

| Chapter 53 | The Structural Analytical Model | 1294 |
**Manual Adjustment of the Analytical Model**

Some structural configurations are not suitable for direct integration with analysis and design software. Adaptive adjustment is required before a structural model is input into the analysis and design software. For this reason, the geometry of the structural member analytical model may also be adjusted in relation to those elements to which it joins. Click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Adjust to adjust the analytical model.

In addition, you can click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Reset to reset structural member analytical models back to their original location, relative to their corresponding physical model.

The following procedures provide more specific detail to these two tools.

**Walls of Unequal Width**

Walls of unequal width may be vertically unaligned. You may need to align the analytical models of these walls so that they coincide prior to input into analysis and design software.

*Two walls of different width in Plan view, not centered on each other*

In this example, you can align the analytical model of the wall above (the shorter wall) to the analytical model of the wall below. You can adjust the analytical model of one of these walls so that it is aligned with the analytical model of the other, as shown in the following procedure:

1. On the Project Browser, select View 1 - Analytical as your current view. You can see the vertical lines of the analytical model of each wall.

2. Click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Adjust.
Notice that the Status Bar reads Pick source analytical model for adjustment.

3 In the analytical model of the shorter wall, select a vertical line.
The Status Bar then reads Pick target analytical model for adjustment.

4 In the analytical model of the longer wall, select the vertical line nearest the vertical line selected in Step 3.

5 Click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Adjust.

6 In the analytical model of the shorter wall, select the other vertical line.

7 In the analytical model of the longer wall, select the vertical line opposite the vertical line selected in Step 4.
The analytical models of the walls align vertically.

8 To reset the analytical model of the shorter wall, click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Reset, then select the analytical model of the shorter wall in the drawing area.

Columns Offset in Plan View

Adjustment of the analytical model may also be necessary when columns are offset in Plan View. Analysis and design software may require that the location of a column analytical model be adjusted.

Two columns of different size with beam in plan

In this example, you manually align the columns, aligning the analytical model of the beam with the physical model of the beam.

1 Select the larger column.

2 Drag the analytical model of the column so that it aligns the analytical model of the beam to the physical model of the beam.
3 Optionally, reset the analytical model of the smaller column. Select the column and drag its analytical model back to its original location.

### Adjusting Columns to Beams

Use the top and bottom of columns as an analytical adjustment source when using the Analytical Adjust tool. Notice in the following illustration that the column analytical model doesn't meet the endpoint of the beam analytical model as expected.

To resolve this, do the following.

1. Click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Adjust.
2. Place the cursor over the column and click the filled circle at the end of the column analytical model requiring adjustment to choose the source analytical model.
3. Click the beam analytical model (orange line) to specify the target analytical model. The column analytical model adjusts.
Using this same process, you can resolve issues with projections to continuous beams as in the following sloped example.

<table>
<thead>
<tr>
<th>Before analytical adjustment</th>
<th>After analytical adjustment</th>
</tr>
</thead>
</table>

Similarly you can alternate between plan and elevation views to manually correct analytical connections.

Analytical model requiring adjustment.

Adjust from beam to column in a plan view.

Change to an elevation view.
Adjusting Walls to Beams

In this example, you adjust an endpoint of the wall analytical model to the endpoint of a beam.

Wall and beam in plan

1. Click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Adjust.
2. Select the vertical member at the end of the wall (filled circle) as the source analytical model.
3. Select the beam analytical model (orange line) as the target analytical model. The wall analytical model adjusts.
4 Optionally, reset the analytical model of the wall. Click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Reset, and select the analytical model of the wall.

Wall Joins

In this example, you join three walls. One wall end extends a small amount from the join. Adjust the model so that all three analytical models end at the intersection.

Three joined walls in Plan View

1 Click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Adjust.

2 Select the vertical member of the wall analytical model at the end of the wall (filled circle at end) as the source analytical model.

3 Select the lower wall analytical model as the target analytical model. The wall analytical model adjusts as shown.
To reset the analytical model of the wall, click Analyze tab ➤ Analytical Model Tools panel ➤ Analytical Reset, and select the analytical model of the wall.

Three joined walls in plan

Projection Plane Options for each Structural Element Type

Each structural member analytical physical model has optional locations for its analytical projection plane. These projection plane locations are relative either to the levels of the structure or to the structural element itself. Each projection plane for each element has a default location, but the user may change the location by adjusting the Vertical Parameter on the Analytical Model section of the Properties palette.

The following are the possible locations for each structural element family:

**Columns - Analytical Projection Plane Top**
- Level
- Top of Column
- Ref Plane

**Columns - Analytical Projection Plane Bottom**
- Level
- Bottom of Column
- Ref Plane

**Walls - Analytical Projection Surface**
- Centerline
- Interior Face
- Exterior Face
- Girdling
- Ref Plane
Walls - Analytical Top Projection Plane

- Top of Wall
- Level
- Ref Plane

Walls - Analytical Bottom Projection Plane

- Bottom of Wall
- Level
- Ref Plane

Beams

- Top of Beam
- Center of Beam
- Level
- Ref Plane

Brace

- Connection Dependent

Structural Floor

- Top of Floor
- Center of Floor
- Bottom of Floor
- Level
- Ref Plane

**Segmented Analytical Model**

When creating curved beams, you can either keep a continuous curve analytical model, or approximate it with a series of straight line segments. Revit Structure discretizes the curve when you select the Approximate curve parameter. Otherwise, the analytical model follows the path of the curve.
Access the segmented analytical model parameters of a selected curved beam in the Properties palette.

<table>
<thead>
<tr>
<th>Analytical Model</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Projection</td>
<td>Auto-detect</td>
</tr>
<tr>
<td>Regular Lines</td>
<td>From Column</td>
</tr>
<tr>
<td>Horizontal Projection</td>
<td>Auto-detect</td>
</tr>
<tr>
<td>Approximate curve</td>
<td></td>
</tr>
<tr>
<td>Maximum discretized offset</td>
<td>2 ft</td>
</tr>
<tr>
<td>Use hard-points</td>
<td></td>
</tr>
</tbody>
</table>

**Segmented Analytical Model Parameters**

**Maximum discretized offset** - This parameter limits the distance between a smooth curve and a line segment. For example, the distance between the orange lines and green lines below will not exceed the value set in this parameter.

**Approximation curve** - When this parameter is selected, Revit creates segments based on both the values for Maximum discretized offset and Use hard-points.

**Use hard-points** - Hard-points are the locations on the curved beam where other structural elements are touching. When you select this parameter, it forces the segmented analytical model to have nodal points at the ends of the members attached to the curved beam. When you clear this parameter, the analytical models of the beams that are attached to the segmented curved beam can extend or shorten to reach the segmented model and can cause inaccurate results.
Curved beam analytical model using hard-points.

Loads

You can apply point, line, and area loads in Revit Structure. Each of these three load geometries is a family that contain instance and type parameters. Loads can be applied either by sketching or by using host components, such as floors and beams. You can edit load force and moment parameters before or after placing loads. Loads can be modified in magnitude and in case. You can also apply load combinations to your model (see Load Combinations on page 1305). For more information about the properties of loads, see Load Properties on page 1315.

Load Cases

You edit and add Load Cases in the Structural Settings dialog. The following illustration shows the Structural Settings dialog with the Load Cases tab selected.
Use the first table in the dialog, named Load Cases, to add, edit, or delete load cases.

**Adding a Load Case**

1. Click Analyze tab ➤ Loads panel ➤ Load Cases.
2. Click the Add button. New Case 1 is added as a table record and the Add button changes to Duplicate.
3. Click in the Name cell of this new load case, and enter a name, such as Mechanical Unit.

**NOTE** The Case Number column of the table is read-only. Revit Structure provides a unique number.

4. Click the Category cell of the new load case, and select a category.

**NOTE** You may also create a new load case by selecting an existing load case in the table, clicking Duplicate, and editing the new load case as needed.

The second table in the Structural Settings dialog is the Load Natures table. Use this table to add or delete load natures.

**Adding a Load Nature**

1. Click Analyze tab ➤ Loads panel ➤ Load Cases.
2. Click in the Load Natures table.
3. Click the Add button. A new load nature record is added to the table.

**NOTE** When adding a Dead Load to the model, you must include an estimated load for the self-weight of the structure.

4. Click in the cell of the new load nature.
5. Change the name of the load nature as appropriate.

**NOTE** The new load nature is now available in the drop-down list of each nature in the Nature column of the Load Cases table.

**Load Combinations**

You can edit and add load combinations in the Structural Settings dialog.
Creating a Load Combination

1. Click Analyze tab ➤ Loads panel ➤ Load Combinations.
2. Click in the Load Combination table, and click Add.
3. Click in the Name field, and enter a name.
4. Click in the Edit Selected Formula section, and click Add in the same section.
5. Click in either the Case or Combination field to select a Case or Combination.
6. Click in the Factor field to enter a factor.
7. Notice that the Name and Formula fields change in the Load Combination table.
8. Click Add again in the Edit Selected Formula section.
9. Click in the Case or Combination field to select a Case or Combination value.
10. Click in the Factor field to enter a factor.
11. Notice that the Name and Formula fields change in the Load Combination section.

Setting the Load Combination Type

10. In the Type field of the Load Combination table, select either Combination or Envelope.
11. Setting the load combination type to Combination, gives results (reactions and member forces) for a single load combination. Envelope gives maximum and minimum results on a group of load combinations.

Setting the Load Combination State

11. In the State field of the Load Combination table, select either Serviceability or Ultimate.
12. Setting the load combination state to Serviceability, reflects how a structure performs (deflection, vibration etc.) under normal or expected loading, whereas Ultimate states are based on the total capacity of a structure to safely resist extreme or ‘factored’ loads without failing (buckling, fracturing etc.).

Setting the Load Combination Usage

12. Click in the Load Combination Usage field, and click Add.
13. The load combination usage parameter is user defined (either gravity, lateral or combined).
   - Gravity Load Combinations include the vertical loads, both permanent or dead (self weight of the structure - floor, beams, columns etc.) and live loads based on occupancy (people on an office floor, boxes in a storage room, snow on a roof, etc.).
- Lateral Load Combinations include the horizontal loads, both permanent or dead (soil resting up against a foundation wall) and live loads (wind against the face of a structure or the shaking of a structure from an earthquake).

- Combined Load Combinations include varying degrees of both gravity and lateral loads in order to account for cases when structures are both occupied and experiencing wind or earthquake loads.

### Setting the Load Combination Name

13 Click the Load Combination Name field to select a Combination to which to add a new Load Combination Usage.

14 In the Load Combination field, select the Load Combination to which a new Load Combination Usage is to be applied. This is achieved by clicking anywhere in the row of the Load Combination.

15 In the Load Combination Usage field, check the new Load Combination Usage that you want. Notice that as soon as a Load Combination Usage is checked, it applies itself to the selected Load Combination.

16 Click OK to exit the dialog.

### Load Modeling

Load modeling depends on the type of coordinate system. The following examples of how to place loads refer to the type of coordinate system that is used to place the load. Revit Structure uses several coordinate systems for loads.

#### Coordinate Systems for Loads

- Project coordinate system
- Current work plane
- Host work plane

The project coordinate system appears in the view when you click Analyze tab ➤ Loads panel ➤ Loads. Text is also displayed under the coordinate system in order to indicate whether the load is defined in terms of project, work plane, or host work plane coordinates. If more than one load is selected, the text displays only if the systems match.

![Coordinate Systems](coordinate_systems.png)

The work plane is the current plane of object placement. When the current work plane is used to orient loads, loads will be placed perpendicular to the current work plane. For information about how to set the current work plane, see [Work Planes](#) on page 1517.

The host work plane is the plane in which the element chosen to host a load resides.
Point Loads

1. Open a structural plan level - analytical view with a framing plan model similar to the one shown.

![Diagram of point loads](image)

**NOTE** Place loads in the analytical view of a structural plan level. For information about analytical views, see Visualization on page 1279.

2. Click Analyze tab ➤ Loads panel ➤ Loads.

3. Click Modify | Place Loads tab ➤ Loads panel ➤ Point Load.

4. On the Properties palette, select a value for Load Case. For information about Load Case, see Load Cases on page 1304.

5. For the Orient to parameter, select Project or Work Plane.

6. Place point loads as appropriate in your model, such as at the center of a beam.

Plan view of point load placed using project coordinate system in negative z direction.

---

Point Loads with Host

Only the analytical model is available to be selected for placement of hosted loads. The physical geometry of components will not accept the load.

1. Click Analyze tab ➤ Loads panel ➤ Loads.

2. Click Modify | Place Loads tab ➤ Loads panel ➤ Hosted Point Load.

3. On the Properties palette, select a value for Load Case. For information about Load Case, see Load Cases on page 1304.

4. For the Orient to parameter, select Project or Work Plane.
5 Place hosted point loads as appropriate in your model.

**Sketch Line Loads**

1. Click Analyze tab ➤ Loads panel ➤ Loads.
2. Click Modify | Place Loads tab ➤ Loads panel ➤ Line Load.
3. On the Properties palette, select a value for Load Case. For information about Load Case, see Load Cases on page 1304.
4. For the Orient to parameter, select Project or Work Plane.
5. Sketch line loads as appropriate in your model, such as along a joist. For information about sketching and sketch tools, see Sketching on page 1405.

**Line Loads with Host**

Only the analytical model is available to be selected for placement of hosted loads. The physical geometry of components will not accept the load.

1. Click Analyze tab ➤ Loads panel ➤ Loads.
2. Click Modify | Place Loads tab ➤ Loads panel ➤ Hosted Line Load.
3. On the Properties palette, select a value for Load Case. For information about Load Case, see Load Cases on page 1304.
4. For the Orient to parameter, select Project or Work Plane.
5. Select a component along which you wish to place the load instance.

**NOTE** For an example of placing line loads on a sloped frame, see Placing Line Loads on a Sloped Frame on page 1310.
Placing Line Loads on a Sloped Frame

This example uses a sloped frame, as illustrated.

Set the work plane

2. Draw a reference plane as shown.
3. Click Home tab ➤ Work Plane panel ➤ Set.
4. In the Work Plane dialog, select Pick a Plane.
5. In the drawing area, select the reference plane. The work plane is now set to the angle of the frame slope.
Add a line load to the slope using the current work plane

6 Click Analyze tab ➤ Loads panel ➤ Loads.

7 Click Modify | Place Loads tab ➤ Loads panel ➤ Line Load.

8 On the Properties palette, select a value for Load Case. For information about Load Case, see Load Cases on page 1304.

9 For the Orient to parameter, select Work Plane.

10 Draw the line load as follows:
   ■ Select the endpoint of the member that is at the base of the slope.
   ■ Select the endpoint of the member that is at the top of the slope.
Add a line load perpendicular to the vertical member of the frame using Hosted Line Load

11 Click Home tab ➤ Work Plane panel ➤ Set.
12 In the Work Plane dialog, click Pick a Plane.
13 Select the new reference plane.
14 Click Analyze tab ➤ Loads panel ➤ Loads.
15 Click Modify | Place Loads tab ➤ Loads panel ➤ Hosted Line Load.
16 On the Properties palette, enter a value for Load Case. For information about Load Case, see Load Cases on page 1304.
17 Select a value for Orient to.
18 Select the vertical member.

The Line load is added, perpendicular to vertical member in the positive x direction and created by using the work plane of the host.

---

Area Loads and Area Loads with Host

1 Click Analyze tab ➤ Loads panel ➤ Loads.
2 Click Modify | Place Loads tab ➤ Loads panel ➤ Area Load.
3 On the Properties palette, select a value for Load Case. For information about Load Case, see Load Cases on page 1304.
4 For the Orient to parameter, select Project or Work Plane.
5 Sketch area loads as appropriate in your model. For example, select the rectangle sketch tool and click the corners of a floor. For information about sketching and sketch tools, see Sketching on page 1405.
An area load over a structural floor after picking floor corners. Load is oriented to project and in the negative z direction.

NOTE Load symbols appear in 3D analytical views or in elevation as arrow lines, like the area load representation shown.

**Area Load with Host**

Only the analytical model is available to be selected for placement of hosted loads. The physical geometry of components will not accept the load.

1 When you finish sketching, click Create Area Load Boundary tab ➤ Area Load panel ➤ Finish Area Load.
2 Click Analyze tab ➤ Loads panel ➤ Loads.

3 Click Modify | Place Loads tab ➤ Loads panel ➤ Hosted Area Load.

4 On the Properties palette, select a value for Load Case. For information about Load Case, see Load Cases on page 1304.

5 For the Orient to parameter, select Project or Work Plane.

6 Select a component over which you wish to place the load instance, such as a structural floor. Revit Structure will draw the area load over the extent of the element.

Reference Point Tool

Use the Reference Point tool to create sloped area loads by specifying load values for up to 3 vertices of an area load. These vertices (reference points) map to the forces F1 through F3 found in the properties of the area load. Forces F2 and F3 are not enabled until the reference points are selected with the Reference Point tool.

Creating sloped area loads

1 Select or create an area load. See Area Loads and Area Loads with Host on page 1312.

2 Click Modify | Area Loads tab ➤ Mode panel ➤ Edit Boundary.

3 Click Modify | Area Loads > Edit Boundary tab ➤ Tools panel ➤ Reference Point.

**NOTE** Make sure that Structural Loads are turned on in Visibility Graphics. For more information see, Visibility and Graphic Display in Project Views on page 801.

4 Select the vertices where you would like to specify a load value. Numbers appear that relate to force values in the properties of the load.

**NOTE** Selecting the same point a second time will remove the existing reference at that vertex.

5 When you have added enough reference points, click Modify | Area Loads > Edit Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

6 Select the area load.

7 On the Properties palette, specify force values at each point by entering values in the respective force parameters (F1, F2 or F3). You may specify forces in the x, y, and/or z directions for each reference point.

Loading Load Tags

Load tags indicate load type and magnitude. Revit Structure contains several predefined load tags, which you can edit and use in your project.

1 Select Insert tab ➤ Load from Library panel ➤ Load Family.

2 In the Open dialog, navigate to either the Imperial or Metric Library\Annotations\Structural folder.

3 Select the load tags you want to add. To select multiple tags, press **CTRL** while making your selections.

For more information see Tags on page 944.
4 Click Open and the tags are loaded into the project. You can find these load tags in the project browser under Families ➤ Annotation Symbols.

Tagging Loads

1 In the Project Browser, expand Families ➤ Annotation Symbols, and expand the family that contains the load tag you want to use.
2 Drag the load tag into the drawing area.

**NOTE** You will get a warning if you are not in a plan view with Structural Load visibility turned on.

3 Select Annotate tab ➤ Tag panel ➤ Tag by Category.
4 Click on the loads to place the tag.

Use the Project Browser to locate and apply other tags to the project.

Load Properties

The following table shows parameter names, values, and descriptions for loads. The values can be modified.

**Load Type Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Force Arrowhead</td>
<td>The force symbol at the point of application. Similar to leader selection.</td>
</tr>
<tr>
<td>Force Scale</td>
<td>The display size parameter; this value visually changes the display of the force symbol.</td>
</tr>
<tr>
<td>Distance between arrows</td>
<td>The plot scale distance between force arrows. This parameter is for Line Load and Area Loads only.</td>
</tr>
<tr>
<td>Moment arrowhead (Point and Line Loads only)</td>
<td>The moment symbol indicating direction. Similar to leader selection.</td>
</tr>
<tr>
<td>Moment arrowhead (alternate) (Point and Line Loads only)</td>
<td>The moment symbol indicating direction. Similar to leader selection.</td>
</tr>
<tr>
<td>Moment scale (Point and Line Loads only)</td>
<td>The display size parameter; visually changes display of moment symbol. Scale is for display only.</td>
</tr>
</tbody>
</table>

**Point Load Instance Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identity Data</td>
<td>A description of the load.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments about the load.</td>
</tr>
<tr>
<td><strong>Structural Analysis</strong></td>
<td></td>
</tr>
<tr>
<td>Is Reaction</td>
<td>Specifies the load is a reaction force. Select this parameter to mark the load as a reaction and become part of the Internal Load category.</td>
</tr>
<tr>
<td>Load Case</td>
<td>Specifies the type of load cases.</td>
</tr>
<tr>
<td>Orient to</td>
<td>Selects the plane in which to orient the load. This is either the Work Plane or the Project. The Work Plane setting sets the load coordinate system to the work plane. The Project setting sets X to East, Y to North, and Z to up.</td>
</tr>
<tr>
<td>Fx</td>
<td>The force in the x direction</td>
</tr>
<tr>
<td>Fy</td>
<td>The force in the y direction</td>
</tr>
<tr>
<td>Fz</td>
<td>The force in the z direction</td>
</tr>
<tr>
<td>Mx</td>
<td>The moment about the x axis</td>
</tr>
<tr>
<td>My</td>
<td>The moment about the y axis</td>
</tr>
<tr>
<td>Mz</td>
<td>The moment about the z axis</td>
</tr>
<tr>
<td><strong>Other</strong></td>
<td></td>
</tr>
<tr>
<td>Nature</td>
<td>Displays a user friendly name for the Load Case parameter.</td>
</tr>
</tbody>
</table>

**Line Load Instance Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>A description of the load.</td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments about the load.</td>
</tr>
<tr>
<td><strong>Structural Analysis</strong></td>
<td></td>
</tr>
<tr>
<td>Is Reaction</td>
<td>Specifies the load is a reaction force. Select this parameter to mark the load as a reaction and become part of the Internal Load category.</td>
</tr>
<tr>
<td>Load Case</td>
<td>Specifies the type of load cases.</td>
</tr>
<tr>
<td>Orient to</td>
<td>Selects the plane in which to orient the load. This is either the Work Plane or the Project. The Work Plane setting sets the load coordinate system to the work plane. The Project setting sets X to East, Y to North, and Z to up.</td>
</tr>
<tr>
<td>Fx 1</td>
<td>The force in the x direction</td>
</tr>
<tr>
<td>Fy 1</td>
<td>The force in the y direction</td>
</tr>
</tbody>
</table>
### Area Load Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Identity Data</strong></td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>A description of the load.</td>
</tr>
<tr>
<td>Comments</td>
<td>Specific comments about the load.</td>
</tr>
<tr>
<td><strong>Phasing</strong></td>
<td></td>
</tr>
<tr>
<td>Phase Created</td>
<td>The phase when the area load was created.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>The phase when the area load was demolished.</td>
</tr>
<tr>
<td><strong>Structural Analysis</strong></td>
<td></td>
</tr>
<tr>
<td>Is Reaction</td>
<td>Specifies the load is a reaction force. Select this parameter to mark the load as a reaction and become part of the Internal Load category.</td>
</tr>
<tr>
<td>Load Case</td>
<td>Specifies the type of load cases.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Orient to</td>
<td>Selects the plane in which to orient the load. This is either the Work Plane or the Project. The Work Plane setting sets the load coordinate system to the work plane. The Project setting sets X to East, Y to North, and Z to up.</td>
</tr>
<tr>
<td>Fx 1</td>
<td>The force in the x direction</td>
</tr>
<tr>
<td>Fy 1</td>
<td>The force in the y direction</td>
</tr>
<tr>
<td>Fz 1</td>
<td>The force in the z direction</td>
</tr>
<tr>
<td>Fx 2</td>
<td>The force in the x direction</td>
</tr>
<tr>
<td>Fy 2</td>
<td>The force in the y direction</td>
</tr>
<tr>
<td>Fz 2</td>
<td>The force in the z direction</td>
</tr>
<tr>
<td>Fx 3</td>
<td>The force in the x direction</td>
</tr>
<tr>
<td>Fy 3</td>
<td>The force in the y direction</td>
</tr>
<tr>
<td>Fz 3</td>
<td>The force in the z direction</td>
</tr>
<tr>
<td>Other</td>
<td>Displays a user friendly name for the Load Case parameter.</td>
</tr>
</tbody>
</table>

**Boundary Conditions**

Boundary conditions are analytical model elements that define the support conditions of a structural element by its surrounding environment. For example, the earth supports the foundation of a structure. These elements are used to communicate engineering assumptions about support conditions to analysis software packages. Boundary conditions are also known as supports or restraints in some analysis software packages.

**Adding Boundary Conditions**

1. Identify the structural objects to which you want to add boundary conditions.
2. Open a 3D view to see the analytical model.
3. Click Analyze tab ➤ Boundary Conditions panel ➤ Boundary Conditions.

**NOTE** Before you place a boundary condition type, you must load the boundary condition families into the project (for more information, see Loading and Saving Families on page 688). Also, verify that the boundary condition family types are assigned in the Structural Settings menu (for more information, see Boundary Conditions Settings on page 1321).

4. Click one of the following from the Place Boundary Conditions tab ➤ Boundary Conditions panel:
   - Point
   - Line
5 On the Options bar, select either Fixed, Pinned, Roller, or User from the State drop-down.
6 In the drawing area, click the structural element to which you want to add the boundary condition.

NOTE The end of the analytical line will highlight when you have correctly placed your cursor over it.

If you select User to define the state of your boundary condition, you need to continue on to the following steps.

Setting User Boundary Conditions

7 In the drawing area, click on the boundary condition you set as the user.
8 On the Properties palette, set the $x$, $y$, and $z$ force in and moment about values to meet your requirements.

For information about the default point boundary conditions, see the following tables:

### Default Point Boundary Conditions

**Fixed**

<table>
<thead>
<tr>
<th>Translation in</th>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>X-Translation</td>
<td>Fixed</td>
</tr>
<tr>
<td>Y-Translation</td>
<td>Fixed</td>
</tr>
<tr>
<td>Z-Translation</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

**Rotation about**

<table>
<thead>
<tr>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>X-Rotation</td>
</tr>
<tr>
<td>Fixed</td>
</tr>
<tr>
<td>Y-Rotation</td>
</tr>
<tr>
<td>Fixed</td>
</tr>
<tr>
<td>Z-Rotation</td>
</tr>
<tr>
<td>Fixed</td>
</tr>
</tbody>
</table>

**Pinned**

<table>
<thead>
<tr>
<th>Translation in</th>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>X-Translation</td>
<td>Fixed</td>
</tr>
<tr>
<td>Y-Translation</td>
<td>Fixed</td>
</tr>
<tr>
<td>Z-Translation</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

**Rotation about**

<table>
<thead>
<tr>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>X-Rotation</td>
</tr>
<tr>
<td>Released</td>
</tr>
<tr>
<td>Y-Rotation</td>
</tr>
<tr>
<td>Released</td>
</tr>
</tbody>
</table>
Translation in | State
---|---
Z-Translation | Released

**Roller**

Translation in | State
---|---
X-Translation | Released
Y-Translation | Released
Z-Translation | Fixed

Rotation about | State
---|---
X-Rotation | Released
Y-Rotation | Released
Z-Rotation | Released

**Default Line Boundary Conditions**

**Fixed**

Translation in | State
---|---
X-Translation | Fixed
Y-Translation | Fixed
Z-Translation | Fixed

Rotation about | State
---|---
X-Rotation | Fixed

**Pinned**

Translation in | State
---|---
X-Translation | Fixed
Y-Translation | Fixed
Z-Translation | Fixed

Rotation about | State
---|---
X-Rotation | Released
Default Area Boundary Conditions

Pinned

Translation in | State
--- | ---
X-Translation | Fixed
Y-Translation | Fixed
Z-Translation | Fixed

Boundary Conditions Settings

Click Manage tab ➤ Settings panel ➤ Structural Settings, and use the Boundary Conditions Settings tab to select the family symbol and adjust the spacing for each boundary condition representation.

Boundary condition settings dialog

For the Fixed, Pinned, Roller, and User Defined boundary condition states, there are four symbols that are pre-loaded in structural templates. These families can be duplicated and edited to meet your display standards or needs. See Creating a New Family Type in a Project on page 38.

To choose a new family symbol, click the drop-down next to the boundary condition name and select a name in the list. Specify the desired distance in the Area and Line Symbol Spacing field to complete the Boundary Conditions settings.

Related topics

- Boundary Conditions on page 1318
- Default Point Boundary Conditions on page 1319
- Default Line Boundary Conditions on page 1320
Verifying the Analytical Model

Tools for analytical consistency provide warnings in the early stages of design about the stability of the structure. This gives engineers greater insight into their designs prior to submitting them for complete analysis. Warnings are given either as you add structural members to the project, or all at once, on demand.

Creation Rules

Each structural component (column, beam, etc.) must be supported in the physical model with a point support (a supporting member that has a point intersection with a supported member).

- A column must have at least one point support. Valid supports include: another column, isolated or continuous foundations, beams, walls, floors, or ramps.
- A wall must have at least 2 point supports or one line support. Valid supports include: columns, continuous or isolated foundations, beams, floors, or ramps.
- A beam must have at least 2 point supports or one point support located at one end that must have its release condition set to fixed or one surface support. Valid supports include: columns, continuous or isolated foundations, beams, or walls.
- A brace must have only 2 point supports. Valid supports include: columns, continuous or isolated foundations, beams, or ramps.
- A floor must have one of the following supports: at least 3 point supports, one line support and a point support not located on the line, 2 line supports that are not collinear, or one surface support. Valid supports include: columns, continuous or isolated foundations, beams, or walls.

Automatic Checks

Checking a model for member supports and analytical model consistency is either automatic or on demand.

To enable automatic checking

1. Select Analyze tab ➤ Tools panel .
   Two unchecked options appear under Automatic Checks: Member Supports and Analytical/Physical Model Consistency.

   - Member Supports: Select this box to check for support functionality. Revit Structure posts warnings for all unsupported structural elements (Structural element not supported by another structural element).
   - Analytical/Physical Model Consistency: Select this box to enable analytical model consistency. Revit Structure checks for all inconsistencies found within the analytical model or between the analytical and physical models.

2. On the Analytical Model Settings tab of the Structural Settings dialog, select the options you want to enable.

3. Click OK.
4 Click Yes to run the Analytical Model Check immediately, or click No to run it later.
As you add structural members to your project, Revit Structure alerts you with detailed warnings. Review the warnings and make the appropriate changes to your design.

Checking Member Supports

To check member supports

1 Click Analyze tab ➤ Tools panel ➤ Check Supports.
2 When prompted that the elective checking criteria in the Structural Settings dialog is being used to evaluate the model, click OK.
3 Review the warnings, and make the appropriate changes to your design.

Example warning - Unsupported Elements
View of unsupported elements

Example warning - Circular Support Chain
Checking Analytical/Physical Consistency

To check analytical/physical consistency

1. Click Analyze tab ➤ Tools panel ➤ Consistency Checks.
2. When prompted that the elective checking criteria in the Structural Settings dialog is being used to evaluate the model, click OK.
3. Review the warnings, and make the appropriate changes to your design.

Example warning - Zero Length Analytical Model
Modifying Elective Checking Criteria and Tolerances

1. Click Analyze tab ➤ Tools panel.

2. Select the Analytical Model Settings options you want to enable during consistency or member support checks.

   By default, all of the Elective Checking Criteria options are enabled. For more information, see Automatic Checks on page 1322.

<table>
<thead>
<tr>
<th>Analytical / Physical Model Consistency Check</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analytical Model support distance forjoined physical model (tolerance = 1' 0&quot;)</td>
</tr>
<tr>
<td>Distance between Analytical and Physical Models larger than tolerance of 0' 6&quot;</td>
</tr>
<tr>
<td>Analytical model distance between beam and dish for level</td>
</tr>
<tr>
<td>Analytical model has zero area or length</td>
</tr>
<tr>
<td>Possible instability based on release conditions</td>
</tr>
<tr>
<td>Analytical Model distance from default location is larger than 1' 0&quot;</td>
</tr>
</tbody>
</table>

3. Under Tolerances, enter the appropriate distances to meet your specifications.
Support Distance specifies the distance between supports.

Analytical-to-Physical model distance specifies the distance between the analytical and physical model.

Analytical adjustment distance specifies the analytical model distance from the default location.

Horizontal auto detect specifies the distance between the analytical and physical model for horizontal elements.

Vertical auto detect specifies the distance between the analytical and physical model for vertical elements.

4 Click OK.

Linking with Analysis and Design Applications

Revit Structure links to an analysis and design software, through an Application Programming Interface (API).

Within the API, you can make size changes and geometric modifications to your model. These changes can include member deletion, member relocation, or member additions. Once they are confirmed in the analytical software, they can imported back into Revit Structure. All views, including structural plans, elevations, sections, and detail sheets are updated according to changes that you import into Revit Structure. In addition, some internal analysis software parameters are imported into Revit Structure.

Export a model from Revit Structure to analysis software

➤ Click Add-Ins tab ➤ External panel ➤ External Tools drop-down ➤ Send Model.

The application programming interface (API) starts.

NOTE The External panel is only available after an approved third party analysis software has been installed. See the following Autodesk web page for more information:
http://www.autodesk.com/revitstructure-partners

Sending updates from analysis software to Revit Structure

You can open the analysis software with the API, or write to an export file for later use. When the API opens the software and runs your model, the API also returns you to your Revit Structure model and updates it.

Track Changes

You can view specific structural changes that an extension made to your project with Track Changes tool. Once reviewed, you can selectively reverse these changes. Trackable external changes to structural elements include:

■ Family types.

■ Location.

■ New instances.
Deletion.

**NOTE** The Track Changes tools are only available when an extension modified project is opened in Revit Structure.

**Reviewing Changes**

To review any changes made by a Revit Structure extension, select one of the following options from Add-Ins tab ➤ External Tools panel ➤ Track Changes drop-down:

- Highlight Changed
- Highlight Created
- List Deleted
- Remove Highlighting

Elements that qualify highlight in yellow.

Deleted items display in a dialog of names and descriptions with the ability to undo.

**Reverting Changes**

You can select a highlighted element and right-click to undo extension changes. Depending on the change made, you can select from Revert Type, Revert Location, and Delete.

**Further Extension Instances**

Revit Structure purges Track Changes data when an extension launches. A dialog warns you about this purge. Once purged, all tracking data is lost.
Massing Studies

Massing studies allow you to explore design ideas by using shapes to conceptualize a building model. When your conceptual design is complete, you can add building elements directly to these shapes.

Related topic
- Conceptual Design Environment on page 135

Massing Studies Overview

Massing studies allow you to explore design ideas by using shapes to conceptualize a building model. When your conceptual design is complete, you can add building elements directly to these shapes.

The following image shows a sample massing study.
Typical Uses of Massing Studies

- Create in-place or family-based mass instances that are specific to individual options, worksets, and phases.
- Create mass families that represent the forms associated with often-used building volumes.
- Vary materials, forms, and relations between masses that represent major components of a building or development using design options.
- Abstractly represent phases of a project.
- Study zoning compliance, both visually and numerically, by relating a proposed building mass to the zoning envelope and floor area ratio.
- Assemble various complex masses from a library of predefined mass families.
- Generate floors, roofs, curtain systems, and walls from mass instances with control over element category, type, and parameter values. Fully control regeneration of these elements when the mass changes.

Massing Studies Terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Massing</td>
<td>The process of visualizing, studying, and resolving building forms using mass instances.</td>
</tr>
<tr>
<td>Term</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Mass Family</td>
<td>A family of shapes, belonging to the mass category. An in-place mass is saved with the project; it is not a separate file.</td>
</tr>
<tr>
<td>Mass Instance or Mass</td>
<td>An instance of a loaded mass family or an in-place mass.</td>
</tr>
<tr>
<td>Conceptual Design Environment</td>
<td>A type of family editor that creates conceptual designs using in-place and loadable family mass elements. See Conceptual Design Environment on page 135.</td>
</tr>
<tr>
<td>Mass Form</td>
<td>The overall form of each mass family or in-place mass.</td>
</tr>
<tr>
<td>Massing Study</td>
<td>A study of one or more building forms made from one or more mass instances.</td>
</tr>
<tr>
<td>Mass Face</td>
<td>A surface on a mass instance that can be used to create a building element, such as a wall or roof.</td>
</tr>
<tr>
<td>Mass Floor</td>
<td>A horizontal slice through a mass at a defined level. Mass floors provide geometric information about the dimensions of the mass above the slice, up to the next slice or the top of the mass.</td>
</tr>
<tr>
<td>Building Elements</td>
<td>Walls, roofs, floors, and curtain systems that can be created from mass faces.</td>
</tr>
<tr>
<td>Zoning Envelope</td>
<td>A legally defined volume within which a building must be contained. Zoning envelopes can be modeled as a mass.</td>
</tr>
</tbody>
</table>

**Massing Studies and Building Maker**

Building Maker is a set of tools that draws a closer association between massing studies and building elements. It takes any overall building form described conceptually and maps it to real-world building elements (such as roofs, curtain walls, floors, and walls). Building Maker allows for a cumulative understanding of the relationship between expressive and built form as the design develops.

You can use Building Maker tools to create building elements from masses. See Creating Building Elements from Mass Instances on page 1356.

**Creating a Mass Family**

You can create masses within a project (in-place masses) or outside a project (loadable mass families). In-place masses are used for mass forms that are unique to a project. Loadable mass families are typically used when you will be placing multiple instances of the mass in a project, or when you will use mass families in multiple projects.

To create in-place masses and loadable mass families, use the conceptual design environment. You can nest other mass families into the mass family that you are creating. (See Conceptual Design Environment on page 135.)

If you are importing geometry into a family, see Considerations for Imported Geometry in Mass or Generic Model Families on page 1366.
Creating an In-Place Mass

Create an In-Place Mass

In order to create a mass, Show Mass mode must be activated. If Show Mass mode is not activated when you click In-Place Mass, Revit Structure activates it for you.

1. Enter a name for the in-place mass family, and click OK.
2. Create the desired shapes using the tools on the Draw panel.
3. When you are finished, click Finish Mass.

Example

Create in-place or family-based mass instance that is specific to individual options, worksets, and phases.

How do I get here?

Click Architect & Site tab ➤ Conceptual Mass panel (In-Place Mass).

Related topics

- Conceptual Design Environment on page 135
- Using Multiple Mass Instances in a Project on page 1333
- Controlling Visibility of Mass Instances on page 1365
- Analyzing a Conceptual Design on page 1335

Creating a Mass Family Outside of a Project

2. In the New Concept Model dialog, select Mass.rft, and click Open.

The Conceptual Design Environment opens. For instructions, see Conceptual Design Environment on page 135 and Forms on page 167.
Mass Instance Parameters

You can view instance parameters for a selected mass element in the Properties palette. Loadable mass families and in-place masses have the following instance parameters in common:

- **Mass Floors.** Click Edit to open the Mass Floors dialog. The dialog displays all levels in the project. When you select levels, Revit Structure generates a mass floor for each selected level that intersects the mass. After generating mass floors, the software calculates the mass floor area, perimeter, volume, and exterior surface area. See Creating Mass Floors on page 1337. When the mass changes its vertical extents, only previously selected levels that currently intersect the mass produce mass floors. Each previously selected level is retained even if it does not produce a mass floor until unselected.

- **Gross Volume.** This value is read only.

- **Gross Surface Area.** This value is read only. The gross surface area includes the sides, top, and bottom of the mass.

- **Gross Floor Area.** This read-only value changes when you add mass floors.

Gross Volume, Gross Surface Area, and Gross Floor Area are all parameters that can be scheduled.

Placing a Mass Instance from a Mass Family

1. Click Insert tab ➤ Load from Library panel ➤ (Load Family).
2. Navigate to the mass family file, and click Open.
3. Click Architect & Site tab ➤ Conceptual Mass panel ➤ (Place Mass).
4. In the Type Selector, select the desired mass type.
5. Click in the drawing area to place the mass instance.

Using Multiple Mass Instances in a Project

You can include multiple mass instances in a project. To eliminate overlap, each mass instance can be joined to other mass instances. As a result, their gross volume and gross floor area values are adjusted accordingly. In the project, mass instances can be placed in worksets, included in phases, and added to design options.

Joining Mass Instances in a Project

1. Click Modify tab ➤ Geometry panel ➤ Join drop-down ➤ (Join Geometry).
2. Select the first mass instance, and then the second.
   The overlapping form of the first mass cuts into the second mass. The mass floors of the second mass are adjusted to report accurately gross floor area in a mass schedule.

If you move the joined mass instances, their properties are updated. If you move the mass instances so that they no longer intersect, a warning message displays. You can unjoin them using the Unjoin Geometry tool.
Overlapping Mass Faces

In the project environment, any joined and overlapping mass faces split into 2 faces: interior and exterior. This allows you to create interior or exterior hosts by face.

In the following illustration, 2 masses are joined, and the overlapping faces have 2 different hosts. The exterior face has a curtain system by face. The interior face has a wall by face with a door.

When you join masses, the area of the inner wall shared by the masses is deducted from the gross surface area for each mass. If you create mass floors, this inner wall area is also deducted from the exterior surface area for each mass floor.

The perimeter of a mass floor, however, includes the entire perimeter, even when it overlaps the perimeter of a mass floor in an adjacent joined mass.

Mass Instances in Design Options, Phases, and Worksets

You can assign mass instances to any workset, range of phases, and design options. Consider the following limitations:

- If you want to join geometry of 2 masses and then vary the relationships in different options, you must copy both masses into each option.
- If you want to modify relationships between 2 masses and they are in different worksets, either both worksets must be editable, or you will need to borrow one or both of the masses from the owners of their worksets.
- If the relationships between masses vary from phase to phase, you may need to include each mass in each phase.
Analyzing a Conceptual Design

During the early planning stages of a building project, you can analyze the conceptual design to determine the following:

- The best mix of uses (such as retail, residential, and office space) for the building
- Rough cost estimates for the exterior of the building, based on linear dimensions or surface area
- HVAC (heating-ventilation-air conditioning) requirements for different levels of the building

To perform these types of analysis, you use mass floors to divide a mass based on defined levels. For each mass floor, Revit Structure calculates the floor area, exterior surface area, volume, and perimeter. This information is stored in the instance properties for mass floors. You can include these values in schedules and tags.

Mass Floors Overview

In Revit Structure, you use mass floors to divide a mass. You can create a mass floor at each level defined in the project. Mass floors display graphically as a slice through the mass at a defined level. They provide geometric information about the dimensions of the mass above the slice, up to the next slice or the top of the mass.

For each mass floor, Revit Structure calculates the following:

- **Area** of each mass floor, in square units. Use this information for rough cost estimates or determining usage ratios for the design.
Exterior surface area from the mass floor upward to the next mass floor. Use this information to create rough cost estimates for the exterior of the building based on square units.

Perimeter of each mass floor. Use this information to create rough cost estimates based on linear dimensions.

Volume of each mass floor, in cubic units. Use this information to estimate HVAC loads.

See Examples of Conceptual Design Analysis on page 1342.

Mass Floors at the Top of a Mass

When you use mass floors to divide a mass, Revit Structure creates a visible mass floor at each specified level that intersects the mass, except for any level that coincides with a top face of the mass.

For example, suppose you create a mass that starts at level 1 and ends at level 4. In the Mass Floors dialog, you select levels 1, 2, 3, and 4. As a result, Revit Structure creates mass floors at levels 1, 2, and 3. The software does not create a mass floor at level 4 because level 4 coincides with the top of the mass. It does not have exterior surface area (vertical surfaces extending upward from its perimeter) or volume (from level 4 upward). Instead, the exterior surface area for level 3 includes the vertical surfaces (walls) that enclose level 3 and also the top horizontal surface (roof) that occurs at level 4. As a result, the exterior surface area for the top floor of a mass may be disproportionally larger than lower floors.
Mass Floors at the Bottom of a Mass

To analyze a portion of a mass that occurs below the lowest mass floor, create a level and mass floor at the bottom-most boundary of the mass. Otherwise, Revit Structure does not include that portion in the surface area or volume calculations for any mass floors. As an alternative, you can examine the Gross Surface Area and Gross Volume parameters for the mass.

NOTE The Gross Surface Area includes the bottom surface of a mass. However, the combined exterior surface areas of mass floors include the sides and top of the mass, but not its bottom surface.

Creating Mass Floors

1 If you have not already done so, add levels to the project. Mass floors are based on levels defined in the project. See Adding Levels on page 94.

2 Select the mass.
You can select the mass in any type of project view, including floor plan, RCP, elevation, section, and 3D views.

3 Click Modify | Mass tab ➤ Model panel ➤ Model (Mass Floors).
4 In the Mass Floors dialog, select each level that needs a mass floor, and click OK.

Initially, if you select a level that the mass does not intersect, Revit Structure does not create a mass floor for that level. However, if you later resize the mass so that it intersects the specified level, Revit Structure creates a mass floor on that level.

**Mass floors**

After creating mass floors, you can do any of the following:

- Select a mass floor to view its properties (including area, perimeter, exterior surface area, and volume) and assign a usage. See *Selecting Mass Floors* on page 1338 and *Mass Floor Properties* on page 1353.
- Tag mass floors. See *Tagging Mass Floors* on page 1340.
- Create building floors from mass floors. See *Modeling by Face* on page 1356.

### Selecting Mass Floors

After creating mass floors, you can select each mass floor individually. When you move the cursor over a mass floor, the tooltip and status bar display the following:

**Mass Floor : Mass Floor for <mass name> : <level>**

If the status bar displays the name of the mass instead of the mass floor, press Tab to highlight the mass floor.

When the mass floor is highlighted, click to select it.

You cannot change the shape of a mass floor by manipulating it directly. Instead, change the shape of its mass. Revit Structure automatically updates all affected mass floors and related information.
Creating a Mass Floor Schedule

After creating mass floors, you can create a schedule for them. Use a mass floor schedule to assign usages or to analyze the design. If you change the shape of the mass, the mass floor schedule updates to reflect the changes.

To create a mass floor schedule

1. Click View ➤ Create panel ➤ Schedules drop-down ➤ (Schedule/Quantities).
2. In the New Schedule dialog, do the following:
   a. For Category, click Mass Floor.
      If Mass Floor does not display by default, select Show categories from all disciplines.
   b. For Name, specify the schedule name.
   c. Select Schedule building components.
   d. Click OK.
3. In the Schedule Properties dialog, do the following:
   a. On the Fields tab, select the desired fields.
      See Selecting Fields for a Schedule on page 788.
   b. Use other tabs to specify filtering, sorting, and formatting of the schedule.
      See Specifying Schedule Properties on page 788.
   c. Click OK.

The schedule displays in the drawing area. If you included the Usage field in the schedule, you can assign a usage to each mass floor in the schedule.

Related topics

- Examples of Conceptual Design Analysis on page 1342
Tagging Mass Floors

After creating mass floors, you can tag them in 2D views. The tags can include information about the area, exterior surface area, perimeter, volume, and usage for each mass floor. If you change the shape of the mass, the tags update to reflect the changes. (For information about tags, see Tags on page 944.)

Revit Structure provides the Mass Floor Tag and M_Mass Floor Tag families. These tags reside in the Annotations folder of the Revit Structure library. They provide information about the usage and square units per mass floor.

To display other parameter values in a mass floor tag, create your own, or use the example provided in the Training folder: Mass Floor Tag-Complex.rfa or M_Mass Floor Tag-Complex.rfa. If you use the default installation location for tutorial content, these files reside in the following location:

- **Windows XP**: C:\Documents and Settings\All Users\Application Data\Autodesk\<product name and version>\Training\<Imperial or Metric>\Families\Annotations
- **Windows Vista or Windows 7**: C:\ProgramData\Autodesk\<product name and version>\Training\<Imperial or Metric>\Families\Annotations

When applying these complex tags to mass floors, you can select a family type to display the desired information, as shown.
Sample tags for mass floors

To tag mass floors

1 Open a view in which you can apply tags.
   You can tag elements in 2D views, including plans, sections, and elevations. You cannot tag elements in 3D views.

2 Apply tags to mass floors.
   See Applying a Tag By Category on page 945 and Tag All Not Tagged on page 947.

   **NOTE** If you have trouble tagging a mass floor, move the cursor over the floor and press Tab. (Pressing Tab changes the focus from the mass to the mass floor.) Then click the mass floor to tag it.

3 (Optional) If the tag displays the Usage label, click the Usage text and enter a value.
   When you enter usage values in tags, other areas of the project (such as element properties and mass floor schedules) update with the information.
Assigning a Usage to a Mass Floor

After creating mass floors, you can assign usages to them. Then you can perform various types of analysis on the design. See Examples of Conceptual Design Analysis on page 1342.

Assign a usage to a mass floor using any of the following methods:

- **Schedule**: Include the Usage field in a mass floor schedule. Then assign usages within the schedule. Open the schedule, click the Usage column for a row, and enter text. If you have already entered usage values for other mass floors, you can click in the field and select a value from a list. See Creating a Mass Floor Schedule on page 1339.

- **Tag**: To tag mass floors in a view, use a mass floor tag that displays the usage assigned to each mass floor. Click the tag to change a usage value. See Tagging Mass Floors on page 1340.

- **Properties**: To assign a value to the Usage parameter, use the Properties palette, as follows.

  **To assign a usage to a mass floor**
  1. In a view, select a mass floor.
  2. In the Properties palette, for Usage, enter a value.

Examples of Conceptual Design Analysis

The following topics provide examples of the different types of analysis that you can perform on conceptual designs.

The analysis examples use the following massing study.

Sample massing study

Area Analysis Example

In a sample scenario, you have designed masses to explore a conceptual design for a building. (See Examples of Conceptual Design Analysis on page 1342.) You want to analyze the most cost-effective or profitable mix of uses for each floor of the building.

To perform this analysis, you must do the following:

- Assign a usage to each mass floor.
- Calculate the area of each mass floor.
- Calculate the percentage of floor space devoted to each usage.
- Use this information to determine the best mix of uses for the design.

<table>
<thead>
<tr>
<th>Usage</th>
<th>Level</th>
<th>Mass Type</th>
<th>Floor Area</th>
<th>Floor Area %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offices</td>
<td>3</td>
<td>Square</td>
<td>352 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Offices</td>
<td>4</td>
<td>Square</td>
<td>356 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Offices</td>
<td>4</td>
<td>Wedge</td>
<td>288 m²</td>
<td>4%</td>
</tr>
<tr>
<td>Offices</td>
<td>5</td>
<td>Wedge</td>
<td>277 m²</td>
<td>4%</td>
</tr>
<tr>
<td>Offices</td>
<td>6</td>
<td>Wedge</td>
<td>269 m²</td>
<td>4%</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1541 m²</td>
<td>22%</td>
</tr>
<tr>
<td>Parking</td>
<td>1</td>
<td>Square</td>
<td>342 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Parking</td>
<td>1</td>
<td>Wedge</td>
<td>339 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Parking</td>
<td>1</td>
<td>Rectangle</td>
<td>639 m²</td>
<td>9%</td>
</tr>
<tr>
<td>Parking</td>
<td></td>
<td></td>
<td>1319 m²</td>
<td>19%</td>
</tr>
<tr>
<td>Residential</td>
<td>2</td>
<td>Rectangle</td>
<td>652 m²</td>
<td>9%</td>
</tr>
<tr>
<td>Residential</td>
<td>3</td>
<td>Rectangle</td>
<td>664 m²</td>
<td>9%</td>
</tr>
<tr>
<td>Residential</td>
<td>4</td>
<td>Rectangle</td>
<td>676 m²</td>
<td>9%</td>
</tr>
<tr>
<td>Residential</td>
<td>5</td>
<td>Rectangle</td>
<td>688 m²</td>
<td>10%</td>
</tr>
<tr>
<td>Residential</td>
<td>6</td>
<td>Rectangle</td>
<td>620 m²</td>
<td>9%</td>
</tr>
<tr>
<td>Residential</td>
<td></td>
<td></td>
<td>3300 m²</td>
<td>46%</td>
</tr>
<tr>
<td>Retail</td>
<td>2</td>
<td>Square</td>
<td>347 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Retail</td>
<td>2</td>
<td>Wedge</td>
<td>319 m²</td>
<td>4%</td>
</tr>
<tr>
<td>Retail</td>
<td>3</td>
<td>Wedge</td>
<td>302 m²</td>
<td>4%</td>
</tr>
<tr>
<td>Retail</td>
<td></td>
<td></td>
<td>968 m²</td>
<td>14%</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>7129 m²</td>
<td>100%</td>
</tr>
</tbody>
</table>

Creating an Area Analysis Schedule

Use the following procedure to create a schedule to perform area analysis of masses in a conceptual design, based on the scenario described in Area Analysis Example on page 1342. Specific steps may vary depending on the information that you want to show in the schedule.

To create an area analysis schedule

1. Create mass floors.
   
   See Creating Mass Floors on page 1337.

2. Click View tab ➤ Create panel ➤ Schedules drop-down ➤ (Schedule/Quantities).
3. In the New Schedule dialog, do the following:
   a. For Category, click Mass Floor.
      
      If Mass Floor does not display by default, select Show categories from all disciplines.
   b. For Name, specify the schedule name.
   c. Select Schedule building components.
d Click OK.

4 On the Fields tab of the Schedule Properties dialog, do the following:
   a For Scheduled fields (in order), add the following fields:
      ■ Usage
      ■ Level
      ■ Mass: Type
      ■ Floor Area
   b Click Calculated Value.
   c In the Calculated Value dialog, for Name, enter Floor Area %.
   d Select Percentage.
   e For Of, select Floor Area.
   f For By, select Grand total.
   g Click OK twice.

5 In the schedule, assign a usage to each mass floor.
Enter text in the Usage column for each level. After entering initial values, for the remaining rows you can click in the field to select values from a list.

<table>
<thead>
<tr>
<th>Usage</th>
<th>Level</th>
<th>Area Analyzed</th>
<th>Mass Type</th>
<th>Floor Area</th>
<th>Floor Area %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parking</td>
<td>1</td>
<td>Square</td>
<td>342 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Retail</td>
<td>2</td>
<td>Square</td>
<td>347 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Offices</td>
<td>3</td>
<td>Square</td>
<td>352 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Offices</td>
<td>4</td>
<td>Square</td>
<td>356 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Parking</td>
<td>1</td>
<td>Wedge</td>
<td>323 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Retail</td>
<td>2</td>
<td>Wedge</td>
<td>319 m²</td>
<td>4%</td>
<td></td>
</tr>
<tr>
<td>Retail</td>
<td>3</td>
<td>Wedge</td>
<td>332 m²</td>
<td>4%</td>
<td></td>
</tr>
<tr>
<td>Offices</td>
<td>4</td>
<td>Wedge</td>
<td>338 m²</td>
<td>4%</td>
<td></td>
</tr>
<tr>
<td>Offices</td>
<td>5</td>
<td>Wedge</td>
<td>337 m²</td>
<td>4%</td>
<td></td>
</tr>
<tr>
<td>Parking</td>
<td>1</td>
<td>Rectangle</td>
<td>330 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Residents</td>
<td>2</td>
<td>Rectangle</td>
<td>325 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Residents</td>
<td>3</td>
<td>Rectangle</td>
<td>314 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Residents</td>
<td>4</td>
<td>Rectangle</td>
<td>318 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Residents</td>
<td>5</td>
<td>Rectangle</td>
<td>316 m²</td>
<td>10%</td>
<td></td>
</tr>
<tr>
<td>Residents</td>
<td>6</td>
<td>Rectangle</td>
<td>310 m²</td>
<td>5%</td>
<td></td>
</tr>
</tbody>
</table>

Next, sort and subtotal the schedule by usage, as follows.

6 In the Properties palette, access properties for the schedule.

7 For Sorting/Grouping, click Edit.

8 On the Sorting/Grouping tab of the Schedule Properties dialog, do the following:
   a For Sort by, select the following:
      ■ Usage
      ■ Ascending
      ■ Footer
      ■ Title, count, and totals
      ■ Blank line
   b For Then by, select both Level and Ascending.
At the bottom of the dialog, select the following:
- Grand totals
- Title and totals
- Itemize every instance

9 Click the Formatting tab, and do the following:
   a. Under Fields, select Floor Area.
   b. For Alignment, select Right.
   c. Select Calculate totals.
   d. Specify formatting for Floor Area %: under Fields, select Floor Area %. For Alignment, select Right. Select Calculate totals.
   e. (Optional) Specify formatting for Usage, Level, and Mass: Type: under Fields, select a field name. Then for Alignment, select Center.

10 Click OK.

The schedule updates to sort and subtotal the rows accordingly. It shows the percentage of floor area planned for each usage, as well as square units.

<table>
<thead>
<tr>
<th>Usage</th>
<th>Shape</th>
<th>Floor Area</th>
<th>Floor Area %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offices</td>
<td>Square</td>
<td>352 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Offices</td>
<td>Square</td>
<td>248 m²</td>
<td>3%</td>
</tr>
<tr>
<td>Offices</td>
<td>Square</td>
<td>288 m²</td>
<td>4%</td>
</tr>
<tr>
<td>Office</td>
<td>Square</td>
<td>277 m²</td>
<td>4%</td>
</tr>
<tr>
<td>Offices</td>
<td>Square</td>
<td>360 m²</td>
<td>4%</td>
</tr>
<tr>
<td>Pathway</td>
<td>Square</td>
<td>343 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Pathway</td>
<td>Square</td>
<td>335 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Pathway</td>
<td>Rectangle</td>
<td>635 m²</td>
<td>9%</td>
</tr>
<tr>
<td>Residential</td>
<td>Rectangle</td>
<td>652 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Residential</td>
<td>Rectangle</td>
<td>664 m²</td>
<td>9%</td>
</tr>
<tr>
<td>Residential</td>
<td>Rectangle</td>
<td>678 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Residential</td>
<td>Rectangle</td>
<td>686 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Residential</td>
<td>Rectangle</td>
<td>1206 m²</td>
<td>18%</td>
</tr>
<tr>
<td>Residential</td>
<td>Square</td>
<td>3300 m²</td>
<td>40%</td>
</tr>
<tr>
<td>Retail</td>
<td>Square</td>
<td>347 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Retail</td>
<td>Square</td>
<td>318 m²</td>
<td>5%</td>
</tr>
<tr>
<td>Retail</td>
<td>Square</td>
<td>302 m²</td>
<td>4%</td>
</tr>
<tr>
<td>Retail</td>
<td>Square</td>
<td>305 m²</td>
<td>4%</td>
</tr>
<tr>
<td>Retail</td>
<td>Square</td>
<td>905 m²</td>
<td>14%</td>
</tr>
</tbody>
</table>

Analysis Example for Exterior Surface Area

In a sample scenario, you have designed masses to explore a conceptual design for a building. (See Examples of Conceptual Design Analysis on page 1342.) You want to determine exterior surface areas around the perimeter of each floor. This information will allow you to estimate costs for the building exterior using various materials.
Creating a Schedule to Analyze Exterior Surface Area

Use the following procedure to create a schedule for analyzing the exterior surface areas of masses in a conceptual design, based on the scenario described in Analysis Example for Exterior Surface Area on page 1345. Specific steps may vary depending on the information that you want to show in the schedule.

To create a schedule to analyze exterior surface area

1. Create mass floors.
   See Creating Mass Floors on page 1337.

2. Click View tab ➤ Create panel ➤ Schedules drop-down ➤ (Schedule/Quantities).

3. In the New Schedule dialog, do the following:
   a. For Category, click Mass Floor.
      If Mass Floor does not display by default, select Show categories from all disciplines.
   b. For Name, specify the schedule name.
   c. Select Schedule building components.
   d. Click OK.

4. On the Fields tab of the Schedule Properties dialog, do the following:
   a. For Scheduled fields (in order), add the following fields:
      - Usage
      - Comments
      - Level
      - Mass: Type
      - Exterior Surface Area
   b. Click Calculated Value.
   c. In the Calculated Value dialog, for Name, enter Exterior Surface Area %.

<table>
<thead>
<tr>
<th>Usage</th>
<th>Comments</th>
<th>Level</th>
<th>Mass: Type</th>
<th>Exterior Surface Area %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offices</td>
<td>CorridorClass</td>
<td>2</td>
<td>Square</td>
<td>224 m²</td>
</tr>
<tr>
<td>Offices</td>
<td>CorridorClass</td>
<td>4</td>
<td>Square</td>
<td>562 m²</td>
</tr>
<tr>
<td>Offices</td>
<td>CorridorClass</td>
<td>4</td>
<td>Wedge</td>
<td>224 m²</td>
</tr>
<tr>
<td>Offices</td>
<td>CorridorClass</td>
<td>6</td>
<td>Wedge</td>
<td>224 m²</td>
</tr>
<tr>
<td>Offices</td>
<td>CorridorClass</td>
<td>6</td>
<td>Wedge</td>
<td>224 m²</td>
</tr>
<tr>
<td>Residential</td>
<td>CorridorClass</td>
<td>2</td>
<td>Rectangle</td>
<td>345 m²</td>
</tr>
<tr>
<td>Residential</td>
<td>CorridorClass</td>
<td>2</td>
<td>Rectangle</td>
<td>345 m²</td>
</tr>
<tr>
<td>Residential</td>
<td>CorridorClass</td>
<td>5</td>
<td>Rectangle</td>
<td>780 m²</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Usage</th>
<th>Comments</th>
<th>Level</th>
<th>Mass: Type</th>
<th>Exterior Surface Area %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Retail</td>
<td>Glass</td>
<td>2</td>
<td>Square</td>
<td>224 m²</td>
</tr>
<tr>
<td>Retail</td>
<td>Glass</td>
<td>2</td>
<td>Wedge</td>
<td>224 m²</td>
</tr>
<tr>
<td>Retail</td>
<td>Glass</td>
<td>3</td>
<td>Wedge</td>
<td>224 m²</td>
</tr>
<tr>
<td>Guest</td>
<td>8</td>
<td>876 m²</td>
<td>18%</td>
<td></td>
</tr>
<tr>
<td>Parking</td>
<td>Open</td>
<td>1</td>
<td>Square</td>
<td>224 m²</td>
</tr>
<tr>
<td>Parking</td>
<td>Open</td>
<td>1</td>
<td>Wedge</td>
<td>224 m²</td>
</tr>
<tr>
<td>Parking</td>
<td>Open</td>
<td>1</td>
<td>Rectangle</td>
<td>345 m²</td>
</tr>
<tr>
<td>Open 3</td>
<td>539 m²</td>
<td>10%</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Usage</th>
<th>Comments</th>
<th>Level</th>
<th>Mass: Type</th>
<th>Exterior Surface Area %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offices</td>
<td>CorridorClass</td>
<td>6</td>
<td>Wedge</td>
<td>224 m²</td>
</tr>
<tr>
<td>Residential</td>
<td>CorridorClass</td>
<td>2</td>
<td>Rectangle</td>
<td>345 m²</td>
</tr>
<tr>
<td>Residential</td>
<td>CorridorClass</td>
<td>6</td>
<td>Rectangle</td>
<td>780 m²</td>
</tr>
<tr>
<td>Open 3</td>
<td>539 m²</td>
<td>10%</td>
<td>5813 m²</td>
<td>100%</td>
</tr>
</tbody>
</table>
d Select Percentage.

e For Of, select Exterior Surface Area.

f For By, select Grand total.

g Click OK twice.

5 In the schedule, assign values to the Usage and Comments columns for each mass floor.
Use Comments to indicate the exterior building material. Use consistent values so that you can use this field for sorting.

<table>
<thead>
<tr>
<th>Exterior Surface Area Analysis 1</th>
<th>Usage</th>
<th>Comments</th>
<th>Level</th>
<th>Mass</th>
<th>Type</th>
<th>Exterior Surface Area</th>
<th>Exterior Surface Area %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parking</td>
<td>Open</td>
<td>1</td>
<td>Square</td>
<td>2</td>
<td>254 m²</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>Retail</td>
<td>Glass</td>
<td>5</td>
<td>Square</td>
<td>1236 m²</td>
<td>4%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Offices</td>
<td>Concrete/Masonry</td>
<td>3</td>
<td>Square</td>
<td>127 m²</td>
<td>4%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Offices</td>
<td>Concrete/Masonry</td>
<td>4</td>
<td>Square</td>
<td>352 m²</td>
<td>10%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Parking</td>
<td>Open</td>
<td>5</td>
<td>Mosaic</td>
<td>116 m²</td>
<td>4%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Retail</td>
<td>Glass</td>
<td>3</td>
<td>Mosaic</td>
<td>273 m²</td>
<td>4%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Offices</td>
<td>Concrete/Masonry</td>
<td>4</td>
<td>Mosaic</td>
<td>216 m²</td>
<td>4%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Offices</td>
<td>Concrete/Masonry</td>
<td>5</td>
<td>Mosaic</td>
<td>216 m²</td>
<td>4%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Parking</td>
<td>Open</td>
<td>7</td>
<td>Rectangle</td>
<td>134 m²</td>
<td>6%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Residential</td>
<td>Concrete/Masonry</td>
<td>2</td>
<td>Rectangle</td>
<td>148 m²</td>
<td>6%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Residential</td>
<td>Concrete/Masonry</td>
<td>3</td>
<td>Rectangle</td>
<td>340 m²</td>
<td>6%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Residential</td>
<td>Concrete/Masonry</td>
<td>4</td>
<td>Rectangle</td>
<td>340 m²</td>
<td>6%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Residential</td>
<td>Concrete/Masonry</td>
<td>5</td>
<td>Rectangle</td>
<td>785 m²</td>
<td>14%</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Next, sort and subtotal the schedule by exterior material (using the Comments field), as follows.

6 In the Properties palette, access properties for the schedule.

7 For Sorting/Grouping, click Edit.

8 On the Sorting/Grouping tab of the Schedule Properties dialog, do the following:

   a For Sort by, select the following:
      ■ Comments
      ■ Ascending
      ■ Footer
      ■ Title, count, and totals
      ■ Blank line

   b For Then by, select both Usage and Ascending.

   c At the bottom of the dialog, select the following:
      ■ Grand totals
      ■ Title and totals
      ■ Itemize every instance

9 Click the Formatting tab, and do the following:

   a Under Fields, select Exterior Surface Area.

   b For Alignment, select Right.

   c Select Calculate totals.

   d Specify formatting for Exterior Surface Area %: under Fields, select Exterior Surface Area %. For Alignment, select Right. Select Calculate totals.
10 Click OK.

The schedule updates to sort and subtotal the rows accordingly. It shows the percentage of surface area for each exterior material, as well as square units.

In this example, the exterior surface areas for some mass floors (such as Square Level 4 and Wedge Level 6) are larger than those for other mass floors because they are calculated differently. See Mass Floors at the Top of a Mass on page 1336.

Also, where the masses are joined, the inner surfaces between masses are deducted from the exterior surface area. See Overlapping Mass Faces on page 1334.

### Perimeter Analysis Example

In a sample scenario, you have designed masses to explore a conceptual design for a building. (See Examples of Conceptual Design Analysis on page 1342.) The design contains many angles, and it may be too expensive to build. You want to produce rough cost estimates, based on its linear dimensions, to check construction costs for the project.
Creating a Perimeter Analysis Schedule

Use the following procedure to create a schedule for analyzing the perimeter of masses in a conceptual design, based on the scenario described in Perimeter Analysis Example on page 1348. Specific steps may vary depending on the information that you want to show in the schedule.

To create a perimeter analysis schedule

1. Create mass floors.
   See Creating Mass Floors on page 1337.

2. Click View tab ➤ Create panel ➤ Schedules drop-down ➤ (Schedule/Quantities).

3. In the New Schedule dialog, do the following:
   a. For Category, click Mass Floor.
      If Mass Floor does not display by default, select Show categories from all disciplines.
   b. For Name, specify the schedule name.
   c. Select Schedule building components.
   d. Click OK.

4. On the Fields tab of the Schedule Properties dialog, for Scheduled fields (in order), add the following fields:
   - Mass: Type
   - Level
   - Floor Perimeter

5. Click the Sorting/Grouping tab, and do the following:
   a. For Sort by, select the following:
      - Mass: Type
      - Ascending
      - Footer
      - Title and totals
      - Blank line
   b. For Then by, select both Level and Ascending.
   c. At the bottom of the dialog, select the following:
      - Grand totals
      - Title and totals
      - Itemize every instance

6. Click the Formatting tab, and do the following:
   a. Under Fields, select Floor Perimeter.
   b. For Alignment, select Right.
   c. Select Calculate totals.
d. (Optional) Specify formatting for Level and Mass: Type: under Fields, select a field name. Then for Alignment, select Center.

7 Click OK.

The schedule shows total linear dimensions, based on the combined perimeters of the mass floors. Use this information to estimate building costs for the design.

**NOTE** Perimeter values include the entire perimeter of each mass floor, even when the mass floors in adjacent, joined masses overlap. See *Overlapping Mass Faces* on page 1334.

### Volume Analysis Example

In a sample scenario, you have designed masses to explore a conceptual design for a building. (See *Examples of Conceptual Design Analysis* on page 1342.) You want to do the following:

- Determine which floors of the building require air conditioning. (For example, parking levels are not air conditioned.)
- Calculate the volume of space to be air conditioned.
- Determine the resulting HVAC load.

<table>
<thead>
<tr>
<th>Perimeter Analysis</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Mass Type</td>
<td>Level</td>
</tr>
<tr>
<td>Rectangle</td>
<td>1</td>
</tr>
<tr>
<td>Rectangle</td>
<td>2</td>
</tr>
<tr>
<td>Rectangle</td>
<td>3</td>
</tr>
<tr>
<td>Rectangle</td>
<td>4</td>
</tr>
<tr>
<td>Rectangle</td>
<td>5</td>
</tr>
<tr>
<td>Rectangle</td>
<td>6</td>
</tr>
<tr>
<td>Rectangle</td>
<td>779 m</td>
</tr>
<tr>
<td>Square</td>
<td>1</td>
</tr>
<tr>
<td>Square</td>
<td>2</td>
</tr>
<tr>
<td>Square</td>
<td>3</td>
</tr>
<tr>
<td>Square</td>
<td>4</td>
</tr>
<tr>
<td>Square</td>
<td>398 m</td>
</tr>
<tr>
<td>Wedge</td>
<td>1</td>
</tr>
<tr>
<td>Wedge</td>
<td>2</td>
</tr>
<tr>
<td>Wedge</td>
<td>3</td>
</tr>
<tr>
<td>Wedge</td>
<td>4</td>
</tr>
<tr>
<td>Wedge</td>
<td>5</td>
</tr>
<tr>
<td>Wedge</td>
<td>6</td>
</tr>
<tr>
<td>Wedge</td>
<td>449 m</td>
</tr>
<tr>
<td>Grand Total</td>
<td>1,423 m</td>
</tr>
</tbody>
</table>
Creating a Volume Analysis Schedule

Use the following procedure to create a schedule for analyzing the volume of masses in a conceptual design, based on the scenario described in Volume Analysis Example on page 1350. Specific steps may vary depending on the information that you want to show in the schedule.

To create a volume analysis schedule

1. Create mass floors.
   See Creating Mass Floors on page 1337.

2. Click View tab ➤ Create panel ➤ Schedules drop-down ➤ (Schedule/Quantities).

3. In the New Schedule dialog, do the following:
   a. For Category, click Mass Floor.
      If Mass Floor does not display by default, select Show categories from all disciplines.
   b. For Name, specify the schedule name.
   c. Select Schedule building components.
   d. Click OK.

4. On the Fields tab of the Schedule Properties dialog, for Scheduled fields (in order), add the following fields:
   ■ Usage
   ■ Level
   ■ Mass: Type
   ■ Floor Volume

5. Click OK twice.

6. In the schedule, assign a usage to each mass floor.
   Enter text in the Usage column for each level. After entering initial values, for the remaining rows you can click in the field to select values from a list.

   Next, sort and subtotal the schedule by usage, as follows.
7 In the Properties palette, access properties for the schedule.
8 For Sorting/Grouping, click Edit.
9 On the Sorting/Grouping tab of the Schedule Properties dialog, do the following:
   a For Sort by, select the following:
      - Usage
      - Ascending
      - Footer
      - Title and totals
      - Blank line
   b For Then by, select both Level and Ascending.
   c At the bottom of the dialog, select the following:
      - Grand totals
      - Title and totals
      - Itemize every instance
10 Click the Formatting tab, and do the following:
   a Under Fields, select Floor Volume.
   b For Alignment, select Right.
   c Select Calculate totals.
   d (Optional) Specify formatting for Usage, Level, and Mass: Type: under Fields, select a field name. Then for Alignment, select Center.
11 Click OK.

The schedule shows the volume of each mass floor, volume subtotals by usage, and a grand total for the combined volumes of the mass floors. Use this information to estimate HVAC loads for the design based on the planned usage for each mass floor.
Mass Floor Properties

You can modify some mass floor properties. Several values come from the originating mass. You can include these values in mass floor tags and schedules. Note that the calculated and mass-based values are read only.

Modifying Mass Floor Properties

1. Select a mass floor.
   See Selecting Mass Floors on page 1338.
2. In the Properties palette, view and edit instance parameters for the mass floor.
   See Mass Floor Instance Properties on page 1353.

Mass Floor Instance Properties

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Floor Perimeter</td>
<td>The total linear dimension for the outer boundaries of the mass floor. This value is read only.</td>
</tr>
<tr>
<td>Floor Area</td>
<td>The surface area for the mass floor, in square units. This value is read only.</td>
</tr>
<tr>
<td>Exterior Surface Area</td>
<td>The surface area for the exterior vertical surfaces (walls) from the mass floor perimeter up to the next mass floor, in square units. For the uppermost mass floor, the Exterior Surface Area includes the area of the horizontal surface (roof) above it. (See Mass Floors at the Top of a Mass on page 1336.) This value is read only. The combined exterior surface area of all mass floors in a mass includes the top and sides of the mass. However, it does not include the bottom of the mass. When you join masses, the area of the inner wall shared by the masses is deducted from the exterior surface area for each mass floor. See Overlapping Mass Faces on page 1334.</td>
</tr>
<tr>
<td>Floor Volume</td>
<td>The amount of physical space between the mass floor and the surface above it, bounded by exterior vertical surfaces between them. Floor volume is measured in cubic units. This value is read only.</td>
</tr>
<tr>
<td>Level</td>
<td>The level (horizontal plane) on which the mass floor is based. This value is read only.</td>
</tr>
</tbody>
</table>

Identity Data

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Usage</td>
<td>A description of the intended use for the mass floor. You can enter text, or click in the field to select an existing value.</td>
</tr>
<tr>
<td>Mass: Type</td>
<td>The type of mass to which the mass floor belongs. This value is read only.</td>
</tr>
<tr>
<td>Mass: Family</td>
<td>The family of the mass to which the mass floor belongs. This value is read only.</td>
</tr>
<tr>
<td>Mass: Family and Type</td>
<td>The family and type of mass to which the mass floor belongs. This value is read only.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Mass: Type Comments</td>
<td>Comments about the type of mass to which the mass floor belongs. This value is read only.</td>
</tr>
<tr>
<td>Mass: Comments</td>
<td>Comments about the mass to which the mass floor belongs. This value is read only.</td>
</tr>
<tr>
<td>Mass: Description</td>
<td>A description of the mass to which the mass floor belongs. This value is read only.</td>
</tr>
<tr>
<td>Comments</td>
<td>Text that describes the mass floor.</td>
</tr>
<tr>
<td>Mark</td>
<td>A user-specified identifier for the mass floor.</td>
</tr>
</tbody>
</table>

**Phasing**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase Created</td>
<td>The phase during which the mass floor is created. See Project Phasing on page 877.</td>
</tr>
<tr>
<td>Phase Demolished</td>
<td>The phase during which the mass floor is demolished. See Project Phasing on page 877.</td>
</tr>
</tbody>
</table>

**Troubleshooting Mass Floors and Conceptual Design Analysis**

When using mass floors to analyze a conceptual design, you may encounter the following issues.

**Cannot See the Mass in a View**

**Symptom:** You opened a view, but you cannot see the mass.

**Issue:** The Show Mass tool is not active, or the view is zoomed in too close to the mass.

**Solution:** Try the following:

- Click Architect & Site tab ➤ Conceptual Mass panel ➤ (Show Mass).
- Type ZF to Zoom to Fit.
- Type VG (Visibility/Graphics). On the Model Categories tab of the Visibility/Graphic Overrides dialog, expand Mass. Make sure that Mass and Mass Floor are selected. Click OK.

**Cannot See Mass Floors in a View**

**Symptom:** You opened a view and you can see the mass, but you cannot see mass floors.

**Issue:** The visibility/graphic setting for mass floors is turned off.

**Solution:** Do the following:

1. Type VG (Visibility/Graphics).
Select Mass and Mass Floor.
Click OK.

**Cannot Select or Tag a Mass Floor**

**Symptom:** You cannot select or tag a mass floor.

**Issue:** In a drawing, the mass is the first selectable element.

**Solution:** With the cursor over the mass floor, press Tab to change the focus from the mass to the mass floor. (Check the status bar for confirmation.) Then click to select the mass floor or apply the tag to it.

**Exterior Surface Area Is Too Large**

**Symptom:** You used mass floors to divide a mass. In a schedule, tag, or instance properties, you notice that the exterior surface area for the uppermost mass floor of the mass is disproportionately larger than for the other mass floors.

**Issue:** The exterior surface area calculation for the uppermost mass floor includes the top surface. See Mass Floors at the Top of a Mass on page 1336.

**Solution:** None required.

**Exterior Surface Area Is Too Small**

**Symptom:** You used mass floors to divide a mass. In a schedule, tag, or instance properties, you notice that the exterior surface area for the mass floors is not as large as you expect it to be.

**Issue:** The mass is joined to another mass. The area of the inner wall shared by the masses is deducted from the exterior surface area for each mass floor. It is also deducted from the gross surface area for the mass. See Overlapping Mass Faces on page 1334.

**Solution:** None required.

**Gross Floor Area Is Not Available for a Mass Floor Schedule**

**Symptom:** You want to create a mass floor schedule that includes the gross floor area of the mass. However, the Gross Floor Area field is not listed on the Fields tab of the Schedule Properties dialog.

**Issue:** Gross Floor Area is a parameter of the mass, not the mass floor.

**Solution:** Create a mass schedule that shows Gross Floor Area.

**Mass Gross Surface Area Is Too Small**

**Symptom:** In a schedule, tag, or instance properties, you notice that the gross surface area for a mass is not as large as you expect it to be.

**Issue:** The mass is joined to another mass. The area of the inner wall shared by the masses is deducted from the gross surface area for each mass. If you create mass floors, this inner wall area is also deducted from the exterior surface area for each mass floor. See Overlapping Mass Faces on page 1334.

**Solution:** None required.
Creating Building Elements from Mass Instances

Abstract Models
You can create building elements from the faces of mass instances. Use mass instances when you want to model a building abstractly, or if you want to schedule gross volume, surface, and floor area.

To create building elements from mass instances, use Building Maker tools. Building elements created with Building Maker tools do not automatically update when the mass face changes. You can update the element to adjust to the current size and shape of the mass face.

Generic Models
Use generic models if you must create a unique, unusual shape but do not need to model the entire building abstractly. Walls, roofs, and curtain systems can be made from faces in a generic model family.

Massing and Imported Geometry
- **Imported solids**: To create elements from faces of imported solids, they must be imported into the conceptual design environment while you are creating a mass family, or into the Family Editor while you are creating a generic model.
- **Polymeshes**: You can import polymesh objects from various file types. Generic model families are recommended for polymesh geometry, because mass families cannot extract volumetric information from polymeshes.

Notes
For more information about Revit Structure import capabilities, see Importing Massing Studies from Other Applications on page 1366 and Suitability of Imported Geometry on page 57.

TIP You can import AutoCAD Architecture mass elements into Revit Structure after they are exploded in AutoCAD Architecture. As Revit Structure import symbols, they are polymesh objects. Optionally, you can convert mass elements to solid AutoCAD objects before importing into Revit Structure.

Modeling by Face

Selecting a Single Face
1. In the Type Selector, select an element type.
2. By default, Select Multiple is enabled. To select a single face for the element, click Modify | Place <Element> by Face tab ➤ Multiple Selection panel ➤ (Select Multiple) to disable it.
3. Move the cursor to highlight a face.
4. Click to select the face. The element is placed on the face immediately.

Selecting Multiple Faces
1. In the Type Selector, select an element type.
2. By default, Select Multiple is enabled.
TIP You may want to select mass elements using a selection box, particularly if the mass contains many elements.

2 Click an unselected face to add it to the selection. Click a selected face to remove it. The cursor indicates whether you are adding (+) or removing (−) a face.

3 To clear the selection and start over, click Modify | Place <Element> by Face tab ➤ Multiple Selection panel ➤ (Clear Selection).

4 When the desired faces are selected, click Modify | Place <Element> by Face tab ➤ Multiple Selection panel ➤ Create <Element>.

Examples

Roof Examples
You can create roofs on any non-vertical faces of a mass. You cannot select faces from different masses for the same roof.

NOTE Do not select upward-pointing and downward-pointing faces for the same roof. If you do, Revit Structure warns you that it is placing a roof on the upward pointing faces only. If you want to make roof panels that cover both upward and downward faces, split the mass into 2 faces, so that each face is either completely upward or downward. Then create one or more roofs from the downward faces and one or more from the upward faces.

TIP You can change the pick face location of the roof (either top or bottom) by modifying the roof’s Picked Faces Location property in the Properties palette.
Roofs created using the Roof by Face tool do not automatically update if you change the mass face.

**Cursor highlighting cylindrical face**

**Placed roof**

**Curtain System Examples**

**NOTE** You cannot edit the profile of a curtain system. If you want to edit the profile, place a curtain wall.

Use a curtain system type with a curtain grid layout.
Cursor highlighting mass face

TIP Drag a pick box over the entire shape to make a curtain system on the entire form.

Created curtain system

Wall Examples

TIP To create a non-rectangular wall on a vertical cylindrical face, use openings and in-place cuts to adjust its profile.
Cursor highlighting planar vertical face

Cursor highlighting non-vertical face
Floor Examples

Cursor highlighting mass floor

Created floors
How do I get here?

**Roofs:** Click Architect & Site tab ➤ Model by Face panel ➤ (Roof).

**Curtain Systems:** Click Architect & Site tab ➤ Model by Face panel ➤ (Curtain System).

**Walls:** Click Architect & Site tab ➤ Model by Face panel ➤ (Wall).

**Floors:** Click Architect & Site tab ➤ Model by Face panel ➤ (Floor).

**Related Topics**
- **Roofs** on page 519
- **Extending the Roof Face** on page 1363
- **Roofs on NURB Surfaces** on page 1364
- **Curtain Systems** on page 640
- **Curtain Systems on NURB Surfaces** on page 1362
- **Walls** on page 449
- **Adding Floors** on page 555

**Creating Floors from Mass Floors**

To create floors from a mass instance, use the Floor by Face tool or the Floor tool. To use the Floor by Face tool, you first create mass floors. Mass floors calculate floor areas in a mass instance.

For more information on the Floor tool, see **Floors** on page 555.

**Creating Curtain Systems from Mass Instances**

You can create curtain systems on any mass faces or generic model faces using the Curtain System by Face tool. Curtain systems do not have editable sketches. Use curtain walls if you require an editable sketch on a vertical mass face. See **Curtain Elements Overview** on page 623.

**Curtain Systems on NURB Surfaces**

You can create curtain systems on NURB (Non-Uniform Rational B-spline) surfaces in generic model families or mass families. When creating a generic model or mass family, you can import a DWG or SAT file containing NURB surfaces. (See **Importing Massing Studies from Other Applications** on page 1366.) After saving the family, use the Curtain System by Face tool to place a curtain system on the NURB surfaces. See **Modeling by Face** on page 1356.
NOTE Use open geometry in generic model families rather than mass families. This applies to isolated NURB surfaces, as shown above, as well as other open geometry. For optimal performance in a mass instance, use only geometry that can be recognized by Revit Structure as oriented 3D geometry. Open geometry in a mass instance can slow processing and generate warnings, but it will provide no additional capabilities beyond those available in the generic model family.

Creating Roofs from Mass Instances

Using the Roof by Face tool, you can create roofs on any non-vertical faces of a mass. You cannot select faces from different masses for the same roof.

You can also create roofs or edit the roof sketch using the Roof by Footprint or Roof by Extrusion tools. For more information about Roof by Footprint and Roof by Extrusion, see Roofs on page 519.

Extending the Roof Face

1 In the drawing area, select the roof face.
When you select the roof face, roof shape handles display. Use these handles to drag the side surfaces. Shape handles are available for all non-horizontal side surfaces. Shape handles are not available for surfaces created by openings placed in roof faces.

2 Drag the shape handles to extend the roof face.

These extensions remain in effect after an update.

Extending roof face using shape handles

---

**Roofs on NURB Surfaces**

You can create roofs on NURB (Non-Uniform Rational B-spline) surfaces in generic model or mass families. When you are creating a generic model or mass family, you can import a DWG or SAT file containing NURB surfaces. (See Importing Massing Studies from Other Applications on page 1366.) After saving the family, use the Roof by Face tool to place a roof on the NURB surfaces. See Modeling by Face on page 1356.

Roof created on NURB surface

---

**NOTE** Use open geometry in generic model families rather than mass families. This applies to isolated NURB surfaces, as shown above, as well as other open geometry. For optimal performance in a mass instance, use only geometry that can be recognized by Revit Structure as oriented 3D geometry. Open geometry in a mass instance can slow processing and generate warnings, but it will provide no additional capabilities beyond those available in the generic model family.
Updating Face Selections for Roofs and Curtain Systems

If you have created a roof or curtain system on a mass or generic model, you can add faces to or subtract faces from it.

1 In the drawing area, select the roof or curtain system.

2 Click Modify | Curtain Systems tab ➤ Model by Face panel ➤ (Edit Face Selection).
3 Select the faces to add or remove.
4 Click Recreate Roof or Recreate System.

Updating Face-Based Host Shapes

Building elements created by face do not update when you change the mass face. To adjust to the current size and shape of the mass face, update the element.

**NOTE** If the element has explicit constraints on it (for example, walls with a Top Constraint set to Up to Level), then the Update to Face tool has no effect.

To update face-based host shapes

1 In the drawing area, select the element.

2 Click Modify | <Elements> tab ➤ Model by Face panel ➤ (Update to Face).

Walls and floors lose any sketch edits when you use the Update to Face tool.

Selecting Face-Based Hosts from a Mass Instance

When updating face-based hosts (such as walls, floors, and roofs), you may find it easier to select the mass instance or generic model with which the elements are associated first, and then select the face-based hosts.

1 In the drawing area, select any mass instance or generic model instance that has associated face-based elements.

2 Click Modify | <Element> tab ➤ Model panel ➤ (Related Hosts).

The selection changes from the mass instance or generic model instance to the selection of face-based hosts.

Controlling Visibility of Mass Instances

When you click Show Mass, all mass instances (including a mass and its mass floors) are visible in all views, even if mass category visibility is turned off in the view.

Set View-Specific Mass Category Visibility

The view-specific setting determines whether the mass prints, and whether it is visible when Show Mass is not turned on. If Mass is selected in the Visibility/Graphics Overrides dialog, the subcategories Form and Mass Floor can be controlled independently.
How do I get here?

Click Architect & Site tab ➤ Conceptual Mass panel ➤ (Show Mass).

Click View tab ➤ Graphics panel ➤ (Visibility/Graphics). On the Model Categories tab, select the mass category.

Importing Massing Studies from Other Applications

You can use 3D design software (such as Autodesk 3ds Max®, Google™ SketchUp®, or Form/Z® by AutoDesSys, Inc.) to create large-scale massing studies, and then use Revit Structure to associate host elements (walls, roofs, and so on) to the mass faces.

In order for Revit Structure to understand the exported geometry as a mass object, use the design software to create a design, export the design to a supported file format (such as DWG or SAT), and import the file into a mass family in Revit Structure. Revit Structure then treats the geometry as a mass, allowing the faces of the mass component to be selected and associated to Revit host elements (such as walls, floors, and roofs).

NOTE Exported objects are faceted, rather than smooth. When exported, curved elements may be triangulated.

Related topics

- Importing or Linking CAD Formats on page 58
- Importing Files from SketchUp on page 60
- Referencing Imported Geometry on page 186

Considerations for Imported Geometry in Mass or Generic Model Families

You can import geometry from external CAD formats into a mass instance or mass family in the same way that you import such geometry into other family definitions. However, in some cases, imported geometry is not well suited to mass instances.

When imported geometry is not well suited to mass instances, it may be possible to use the generic model category instead. There is overlap between the mass instance and generic model categories. Walls, roofs, and curtain systems can be made from faces in a generic model family. Floors can be created from sketches that reference the geometry in a generic model or a mass model. Mass models also support level-based mass floors, which in turn support one-click parametric floor creation.

When using imported geometry in mass families and generic model families, consider the following:

- Avoid complex geometry in mass instances. Unlike other family categories, mass instances always maintain a separate copy of each internal geometry, plus extra geometry to represent the combined volume of the mass. For complex geometry, the additional data can slow down processing considerably. When a generic model is joined by the Join Geometry tool, the software also creates an extra copy of the geometry, which can slow performance. For complex geometry in a generic model, you may join the geometry inside a family definition to avoid extra copies of the geometry.

- If the imported geometry in a mass instance (or between generic models) is not well suited to join geometry, then errors, warnings, and unexpected behavior can result. If geometry is combined within a mass definition, it should be solid geometry with either a strong connection or no connection. Examples of geometric characteristics that are ill-suited to joining include odd tangencies, edge-only overlaps, open meshes, and ambiguous connectivity.
Some CAD formats do not have geometry in a form that a mass instance can use to compute volumetric information and mass floors. When such formats are used, errors and warnings result. For more information about imported CAD formats, see Import/Link Overview on page 57 and Suitability of Imported Geometry on page 57.

Host by Face tools (available for roofs, floors, walls, and curtain systems) associate a single host element with one face or several faces. For example, detailed geometry (that contains cornices, reveals, windows, casework, tessellated approximations of surfaces, and so on) is likely to have many small faces that will fail to produce meaningful host elements and may produce errors. This is a consideration for both mass families and generic model families.

**Best Practices When Importing Masses**

- **Complete the design.** Before importing a mass to Revit Structure, complete as much of the design as required in the design software. If you make changes to the design after importing it to Revit Structure, you cannot update the Revit family or project with the changes.

- **Level of detail.** Before importing a mass to Revit Structure, reduce the amount of detail that it contains. For example, cornices, roof eaves, window detail, reveals, windows, casework, tessellated approximations of surfaces, ornaments and articulation on walls, and other such fine work can be imported as separate families. After importing the simplified mass to Revit Structure, you can then add these details to the walls and roofs created from the mass.

- **Mass floors.** If a mass family imports only non-volumetric geometry, you cannot create mass floors in Revit Structure. However, if an imported mass family contains both volumetric and non-volumetric geometry, you will be able to create mass floors from the volumetric portions of the geometry. (You will also receive warnings. You can ignore those.)

**Importing a Design to a Mass Family Outside a Revit Project**

Import a massing study from design software (such as SketchUp) into an external mass family when you plan to use it in multiple projects. (This is the recommended workflow.) Import the design into an in-place mass in a Revit project when you intend to use the design in one project only. (See Importing a Design as an In-Place Mass on page 1369.)

**To import a design to a mass family**

1. Use the design software to create the massing study.
2. In Revit Structure, open the Revit project in which you want to use the massing study, and open a 3D view.
3. Click ➤ New ➤ (Family).
4. In the New dialog, select Mass.rft, and click Open.
5. Import the file containing the design, as follows:
   - **a** Click Insert tab ➤ Import panel ➤ (Import CAD).
     For more information, see Importing or Linking CAD Files Using the Import CAD and Link CAD Tools on page 59.
   - **b** In the Import CAD Formats dialog, navigate to the folder that contains the file to import.
   - **c** For Files of type, select the appropriate file type (such as DWG, SAT, or SKP).
d Select the file to import.

e Specify the desired import settings.
The following settings are recommended:
   ■ Colors: Preserve
   ■ Layers: All
   ■ Import Units: Auto-Detect
   ■ Positioning: Auto - Origin to Origin
   ■ Place at: Level 1 or Ref. Level
   ■ Orient to View

   See Import and Link Options for CAD Formats and Revit Models on page 63.

f Click Open.

To see the massing study, you may need to do the following:
   ■ Switch to a 3D view.
   ■ Type ZF (Zoom to Fit) to adjust the drawing area to show the entire mass.

   ■ Click Architect & Site tab ➤ Conceptual Mass panel ➤ (Show Mass).
   ■ To improve visibility, on the View Control Bar, for Visual Style, select Shading with Edges.

6 Save the mass family.

7 Load the mass family into the Revit project and place the component, as follows:

   a Click Insert tab ➤ Load from Library panel ➤ (Load Family).
   b In the Load Family dialog, navigate to the mass family file and then click Open.

   c Click Architect & Site tab ➤ Conceptual Mass panel ➤ (Place Mass).
   d At the Show Mass Mode message, click OK.
   e Click in the drawing area to place the mass.

   If you cannot see the mass, you may need to do the following:
   ■ Switch to a 3D view.
   ■ Type ZF (Zoom to Fit) to adjust the drawing area to show the entire mass.

   For more information, see Placing a Mass Instance from a Mass Family on page 1333.

8 To convert the faces of the mass component, use the Wall by Face, Floor by Face, Curtain System by Face, and Roof by Face tools.
   For more information about these tools, see Creating Building Elements from Mass Instances on page 1356.
Importing a Design as an In-Place Mass

Import a massing study from design software (such as SketchUp) to an in-place mass in a Revit project when you intend to use the design in one project only. Import the design into an external mass family when you plan to use it in multiple projects. (See Importing a Design to a Mass Family Outside a Revit Project on page 1367.)

To import a design to an in-place mass

1. Use the design software to create the massing study.
2. In Revit Structure, open the Revit project in which you want to use the massing study, and open a 3D view.
3. Click Architect & Site tab ➤ Conceptual Mass panel ➤ (In-Place Mass).
4. At the Show Mass Mode message, click OK.
5. In the Name dialog, enter a name for the mass, and click OK.
6. Import the file containing the design, as follows:
   a. Click Insert tab ➤ Import panel ➤ (Import CAD).
      For more information, see Importing or Linking CAD Files Using the Import CAD and Link CAD Tools on page 59.
   b. In the Import CAD Formats dialog, navigate to the folder that contains the file to import.
   c. For Files of type, select the appropriate file type (such as DWG, SAT, or SKP).
   d. Select the file to import.
   e. Specify the desired import settings.
      The following settings are recommended:
      ■ Colors: Preserve
      ■ Layers: All
      ■ Import Units: Auto-Detect
      ■ Positioning: Auto - Origin to Origin
      ■ Place at: Level 1 or Ref. Level
      ■ Orient to View
      See Import and Link Options for CAD Formats and Revit Models on page 63.
   f. Click Open.

   To see the mass, you may need to type ZF (Zoom to Fit) to adjust the drawing area to show the entire mass.
7. In the Revit project, click (Finish Mass).
8. To convert the faces of the mass, use the Wall by Face, Floor by Face, Curtain System by Face, and Roof by Face tools.
   For more information about these tools, see Creating Building Elements from Mass Instances on page 1356.
Example of Importing a Massing Study

The following images demonstrate the process of importing a massing study created using design software (SketchUp) into Revit Structure, and converting mass faces to building elements.

Building mass created in SketchUp

SketchUp file imported into Revit Structure
Printing Mass Elements

To print mass elements, be sure that mass category visibility is turned on. Mass elements will not print or export if category visibility is turned off, even if Show Mass is turned on. See Controlling Visibility of Mass Instances on page 1365.
Create solar studies of your project to evaluate the impact of natural light and shadows on the buildings and site. Use the **sun path** and **Sun Settings dialog**, either individually or together, to create solar studies that suit your needs. Solar study modes, which include **Still**, **Single Day**, **Multi-Day**, and **Lighting**, are available in the conceptual design environment as well as the project environment.

**Solar Studies Overview**

By showing the impact of natural light and shadows on your project, solar studies yield valuable information that can help support effective passive solar design. Use solar studies to visualize how shadows from terrain and surrounding buildings affect the site, and where natural light penetrates a building during specific times of the day and year.

Create solar studies using the sun path or the Sun Settings dialog, or a combination of both. Each method of creating solar studies offers benefits:

**Sun path**

The sun path is a visual representation of the sun's range of movement across the sky at the geographic **location** you specify for a project. The sun path displays in the context of your project and includes **on-screen controls** for positioning the sun at any point within its range of movement, between sunrise and sunset, throughout the year.
Sun Settings dialog

The Sun Settings dialog extends the capabilities of the sun path by giving you access to preset sun positions, shared sun settings, view-specific lighting settings, time intervals, and ground plane settings.

Using the sun path and Sun Settings dialog together

To experience the full potential of solar studies, display the sun path, and then use the sun path's shortcut menu to access the Sun Settings dialog whenever you need it. Using the sun path and Sun Settings dialog together gives you the combined advantage of the sun path's highly visual, interactive controls and the dialog's presets and shared settings.

NOTE The times displayed in the sun path and Sun Settings dialog are in local time for your project location. Because local time can vary from solar time by an hour or more, depending on your location, the sun's position in the sun path is shown in solar time to ensure that the sun is directly overhead at solar noon.

Solar Studies Workflow

Use the following workflow to create solar studies, using both the sun path and Sun Settings dialog. For an overview of the sun path functionality, see Using the Sun Path on page 1384.

1. Create a project. See Creating a Project on page 55.
2. Specify the geographic location of the project. See Specifying the Project Location on page 107.
3. Create a 2D or 3D view that supports the display of shadows. See Creating Views for Solar Studies on page 1374.
4. Turn on the sun path and shadows. See Displaying Sun and Shadows on page 1375.
6. If you created a Single Day or Multi-Day solar study, view the resulting animation. See Previewing Solar Study Animations on page 1387.
7. Save the solar study results. See Saving Solar Study Images to Projects on page 1387.
8. Export the solar study results. See Exporting Solar Studies on page 1388.

Setting up and Creating Solar Studies

After you create views that support the display of sun and shadows, you are ready to create stationary or animated solar studies to evaluate the impact of natural light and shadows on the project.

Creating Views for Solar Studies

The sun path and shadows are available in all 3D views except those that use the Wireframe or Consistent Colors visual style. In 2D views, the sun path is available in floor plans, reflected ceiling plans, elevations, and sections.

NOTE The sun path's on-screen controls are not editable in perspective, walkthrough, or rendered 3D views.

For the best display of light and shadows on a project, use 3D views of the building model. Typical plan views, such as floor plans and ceiling plans, do not display many elements in 3D, so no shadows will be cast from these elements. For more information, see Creating an Orthographic 3D View on page 757.
To produce solar studies that accurately represent the position of the sun in relation to the project when Project North differs from True North, rotate the view to True North. Alternatively, when producing a Lighting solar study, you can specify the sun’s location relative to the view.

Displaying Sun and Shadows

For the best results when studying the effect of light and shadows on a building and site, turn on both the sun path and shadow display in a 3D view. 3D views have more shadow-casting elements than 2D views, so they yield far more information about natural lighting, shading requirements, passive solar design potential, and renewable energy potential. For more information about views that support sun path and shadow functionality, see Creating Views for Solar Studies on page 1374.

NOTE You control the visibility of the sun path and shadows on a view-by-view basis. When you turn the sun path or shadows on or off in one view, no other views are affected.

To turn on the sun path

Use one of these methods:

- On the View Control Bar, click ☀️ Sun Path Off/On ➤ Sun Path On.
- Click in an empty area of the view to display the view properties. On the Properties palette, under Graphics, select Sun path, and click Apply. If the Properties palette is not displayed, click View tab ➤ Windows panel ➤ User Interface, and select Properties.

TIP When you turn on the sun path in the view properties, the sun path setting is saved in any new view templates you create.

When you are using a default template, the first time you turn on the sun path, the <In-session, Lighting> setting is specified and Relative to View is selected. When Relative to View is selected, the sun does not display. A dialog displays options for specifying sun settings:

- To create lighting conditions based on the project location, date, and time, click Yes. Then, create a Still, Single Day, or Multi-Day solar study.
- To create lighting conditions that might not exist in the real world, click No. Then, use the Sun Settings dialog to specify the sun position.

To turn on shadows

Use one of these methods:

- On the View Control Bar, click 🌋 Shadows Off/On ➤ Shadows On.
- On the View Control Bar, click 🌋 Shadows Off/On ➤ Graphic Display Options. In the Graphic Display Options dialog, select Cast Shadows, and click OK.

To adjust the intensity of sun, indirect light, or shadows

1. On the View Control Bar, click 🌋 Shadows Off/On ➤ Graphic Display Options.
2. In the Graphic Display Options dialog, under Lighting, move the Sun Intensity slider or enter a value between 0 and 100 to change the brightness of the direct light.
3. For Indirect Light, move the slider or enter a value between 0 and 100 to change the brightness of the ambient light.
4 Under Shadows, move the Shadow slider or enter a value between 0 and 100 to change the darkness of the shadows.

5 Click OK.

Related topics

■ Specifying a Sun Setting on page 1390
■ Creating Solar Studies on page 1376

Creating Solar Studies

Solar studies help you visualize the impact of natural light and shadows on both the exteriors and interiors of projects. Create solar studies to see how shadows from terrain and surrounding buildings affect a site, or where natural light penetrates a building at specific times of the day and year.

Use the sun path and Sun Settings dialog, either individually or together, to create solar studies that suit your needs. When you display both the sun path and shadows, you can view the sun position as well as the resulting shadows.

The following solar study modes are available. The mode determines the values you can specify and whether the result is a single image or an animation, as described below.

Still

Produces a single image that shows the shadows at the project location for a specified date and time. For example, you can view the shadow patterns for a project in San Francisco, CA, on June 22 at noon.

Single Day

Produces an animation that shows the movement of shadows at the project location for a specified date, time range, and time interval. For example, you can track shadows at hourly intervals for a project in London, UK, on June 22 from 8:00 AM to 5:00 PM.

Multi-Day

Produces an animation that shows the movement of shadows at the project location for a specified date range, time (or time range), and time interval. For example, you can view shadow patterns at 1:00 PM every day from June 1 through June 30 for a project in Shanghai, China. You can also produce a study for this project that shows shadow patterns at hourly intervals from 10:00 AM to 2:00 PM over the same range of days.

Lighting

Produces a single image that shows the shadows cast from the specified sun position in the active view, rather than a sun position based on project location, date, and time. For example, you can cast 45-degree shadows on elevation views, which can then be used for rendering. Choose a preset for an artificial sun position, such as Sunlight from Top Right, or enter values for Azimuth and Altitude to specify the sun position. The Relative to View option lets you orient the sun to match either the orientation of the view or the orientation of the model.

NOTE The times displayed in the sun path and Sun Settings dialog are in local time for the project location. Because local time can vary from solar time by an hour or more (depending on the location), the sun’s position in the sun path is shown in solar time to ensure that the sun is directly overhead at solar noon.
Tips for creating solar studies

- To produce a series of solar studies, create and open multiple views of a project, and then specify a different solar study period for each view. For example, create separate views for winter solstice, summer solstice, spring equinox, and fall equinox studies. Tile the views to see them all at once.

- You can create solar studies for the same building model in different locations. For example, if the same retail store will be constructed in Los Angeles and London, change the project location in the Location Weather and Site dialog, and then export a solar study for each geographic location.

Creating Still Solar Studies

Still solar studies produce single images that show the impact of sun and shadows at a project location for a specified date and time. You can create these solar studies using the sun path and Sun Settings dialog, either individually or together.

NOTE When you select the Still mode in the Sun Settings dialog, you have the option to use a project-wide sun setting for a set of views. When you adjust the sun position in a view that uses the shared setting, the sun position is updated in all other views that use the shared setting.

To use the sun path

1. Specify the geographic location of the project.
2. Open a 2D or 3D view that supports the display of shadows.
3. Turn on the sun and shadows, and adjust their intensity.

NOTE When you are using a default template, the first time you turn on the sun path, the <In-session, Lighting> setting is specified and Relative to View is selected. When Relative to View is selected, the sun does not display. A dialog displays options for specifying sun settings.

4. Do one of the following:
   - If a dialog displays, click Yes to change the sun setting to <In-session, Still>.
   - If no dialog displays, in the drawing area right-click the ground compass, and click Still.

   The Still mode is now in effect, with the In-session preset specified.

NOTE Each solar study mode has an In-session preset. Using this preset, you can specify a temporary setting for the sun in the active view and see changes in shadow patterns. You can then save this sun setting as a user-defined preset, so you have easy, repeatable access to this project-wide setting across all views. Presets are available in the Sun Settings dialog. To access this dialog, right-click any element of the sun path, and then select Sun Settings from the shortcut menu.

5. Use the following sun path controls to specify a sun position, either by dragging the sun within its range of movement or by entering different dates and times. For illustrations and descriptions of these controls, see Using the Sun Path on page 1384.

   - **Daily Path.** Drag the sun along its daily path to the desired time. Use the hourly snap points and 15-minute interval marks as guides in setting the time.
   - Or, drag the daily path to a new date on the analemma, thus changing the date while maintaining the same time of day.

   TIP With the sun selected, hold down the left mouse button, and press the Left Arrow and Right Arrow keys to move the sun along its daily path. The Left Arrow key increases the time by moving the sun from east to west. The Right Arrow key decreases the time by moving the sun from west to east.
Analemma. Drag the sun along the analemma by moving it perpendicular to the daily path and along the figure-8-shaped path to the desired date. Use the snap points at the start of each month as guides in setting the date.

**TIP** With the sun selected, hold down the left mouse button, and press the Up Arrow and Down Arrow keys to move the sun along the analemma. The Up Arrow key moves the date later in time; the Down Arrow key moves the date earlier in time.

**TIP** After you begin moving the sun, hold down the *SHIFT* key to constrain the sun’s movement to the daily path, or hold down the *CTRL* key to constrain the sun’s movement to the analemma.

Time. Edit the time by clicking the time control and entering a new time.

Date. Edit the date by clicking the date control and entering a new date.

To save the current sun setting as a preset, see Using Sun Setting Presets on page 1392.

You can now save or export the solar study image.

**To use the Sun Settings dialog**

1. Open a 2D or 3D view that supports the display of shadows.
2. Turn on shadows, and adjust their intensity.
   
   **TIP** To view the sun position, turn on the sun path as well.

3. On the View Control Bar, click 🌞 Sun Path Off/On ➤ Sun Settings.
4. In the Sun Settings dialog, under Solar Study, select Still.
5. Under Presets, select one of the predefined sun settings (such as Summer Solstice), and click OK. Or, select <In-session, Still>, and complete the remaining steps in this procedure to define your own sun setting.
6. Under Settings, specify a sun position:
   
   a. For Location, verify that the correct project location is displayed.
      
      To change the location, click 🏙️ (Browse), and specify the project location either by searching on the street address or longitude and latitude, or by selecting the nearest major city from the Default City List.
   
   b. Enter the date of the study.
      
      The date format specified for your computer’s operating system is applied to the date you enter.
   
   c. Enter the time of the study.
   
   d. If <In-session, Still> is selected, you can enable the current view to use a project-wide sun setting by selecting Use shared settings.
      
      When you select Use shared settings, the sun position is based on a project-wide sun setting, rather than a view-specific one. Therefore, when you adjust the sun position in a view that uses the shared setting, the sun position is updated in all other views that use the shared setting. The shared setting is not stored as a preset so, unlike presets which can be modified only in the Sun Settings dialog, the shared setting can be modified in the drawing area.
   
   e. To cast shadows on the ground plane, select Ground Plane at Level, and select the level at which you want the shadows to display.
When you select Ground Plane at Level, the software casts shadows on the specified level in 2D and 3D shaded views. When you clear Ground Plane at Level, the software casts shadows on the toposurface, if one exists.

**NOTE** The ground plane is not used in rendered views. To cast shadows in rendered views, model a ground plane in the project.

7 To test the sun setting in the active view, click Apply.
8 To save the current sun setting as a preset, click Save Settings, enter a unique name, and click OK.
9 Click OK when done.

You can now save or export the solar study image.

**Creating Single Day Solar Studies**

Single Day solar studies produce animations that show the movement of shadows at a project location on a specified date for a specified period of time. You can specify a time interval from 15 minutes to 1 hour between the frames in the animation.

**To use the sun path**

1 Specify the geographic location of the project.
2 Open a 2D or 3D view that supports the display of shadows.
3 Turn on the sun and shadows, and adjust their intensity.

**NOTE** When you are using a default template, the first time you turn on the sun path, the <In-session, Lighting> setting is specified and Relative to View is selected. When Relative to View is selected, the sun does not display. A dialog displays options for specifying sun settings.

4 If a dialog displays, click Yes to display the sun using the current project location.
5 In the drawing area, place the cursor over the ground compass, right-click, and click Single Day. The Single Day mode is now in effect, with the In-session preset specified.

**NOTE** Each solar study mode has an In-session preset. Using this preset, you can specify a temporary setting for the sun in the active view and see changes in shadow patterns. You can then save this sun setting as a user-defined preset, so you have easy, repeatable access to this project-wide setting across all views. Presets are available in the Sun Settings dialog. To access this dialog, right-click any element of the sun path, and then select Sun Settings from the shortcut menu.

6 Use the following sun path controls to specify a sun position, either by dragging the sun within its range of movement or by entering different dates and times. For illustrations and descriptions of these controls, see Using the Sun Path on page 1384.

- **Daily Path.** Drag the sun along its daily path to the desired time within the study period. The sun snaps to the time intervals specified for animation frames. Or, drag the daily path to a new date within the total sun area, thus changing the date while maintaining the same time of day.

**TIP** With the sun selected, hold down the left mouse button, and press the Left Arrow and Right Arrow keys to move the sun along its daily path. The Left Arrow key increases the time by moving the sun from east to west. The Right Arrow key decreases the time by moving the sun from west to east.
- **Time.** Edit the time range by clicking the relevant time control and entering a new time. Or, drag either end point of the selected time range to increase or decrease the range. Or, drag the entire time range along the daily path to change the start and end times, while maintaining the same time span.

- **Date.** Edit the date by clicking the date control and entering a new date.

To save the current sun setting as a preset, see Using Sun Setting Presets on page 1392.

You can now **preview**, **save**, or **export** the solar study.

**To use the Sun Settings dialog**

1. Open a **2D or 3D view** that supports the display of shadows.
2. Turn on shadows, and adjust their intensity.

**TIP** To view the sun position, turn on the sun path as well.

3. On the View Control Bar, click ✡ Sun Path Off/On ➤ Sun Settings.
5. Under Presets, select one of the predefined sun settings, and click OK. Or, select <In-session, Single Day>, and complete the remaining steps in this procedure to define your own sun setting.
6. Under Settings, specify a sun position:
   a. For Location, verify that the correct project location is displayed.
      - To change the location, click ✤ (Browse), and specify the project location either by searching on the street address or longitude and latitude, or by selecting the nearest major city from the Default City List.
   b. Enter the date of the study.
      - The date format specified for your computer’s operating system is applied to the date you enter.
   c. Enter a start time and end time for the study, or select Sunrise to sunset.
      **NOTE** If you enter a start time that is later than the end time, the values are corrected automatically.
   d. For Time Interval, specify the amount of time between images in the animation.
      - When you select a time interval, Frames displays the number of individual images that the solar study animation will contain.
   e. To cast shadows on the ground plane, select Ground Plane at Level, and select the level at which you want the shadows to display.
      - When you select Ground Plane at Level, the software casts shadows on the specified level in 2D and 3D shaded views. When you clear Ground Plane at Level, the software casts shadows on the toposurface, if one exists.
      **NOTE** The ground plane is not used in rendered views. To cast shadows in rendered views, model a ground plane in the project.

7. To test the sun setting in the active view, click Apply.
8. Click OK when done.
To save the current sun setting as a preset, click Save Settings, enter a unique name, and click OK.

Click OK when done.

You can now preview, save, or export the solar study.

Creating Multi-Day Solar Studies

Multi-Day solar studies produce animations that show the movement of shadows at a project location for a specific date range at a specific time, or for a range of time. You can specify a time interval of 1 hour, 1 day, 1 week, or 1 month between the images in the animation.

To use the sun path

1. Specify the geographic location of the project.
2. Open a 2D or 3D view that supports the display of shadows.
3. Turn on the sun and shadows, and adjust their intensity.

**NOTE** When you are using a default template, the first time you turn on the sun path, the <In-session, Lighting> setting is specified and Relative to View is selected. When Relative to View is selected, the sun does not display. A dialog displays options for specifying sun settings.

4. If a dialog displays, click Yes to display the sun using the current project location.
5. In the drawing area, place the cursor over the ground compass, right-click, and click Multi-Day. The Multi-Day mode is now in effect, with the In-session preset specified.

**NOTE** Each solar study mode has an In-session preset. Using this preset, you can specify a temporary setting for the sun in the active view and see changes in shadow patterns. You can then save this sun setting as a user-defined preset, so you have easy, repeatable access to this project-wide setting across all views. Presets are available in the Sun Settings dialog. To access this dialog, right-click any element of the sun path, and then select Sun Settings from the shortcut menu.

6. Use the following sun path controls to specify a sun position, either by dragging the sun within its range of movement or by entering different dates and times. For illustrations and descriptions of these controls, see Using the Sun Path on page 1384.

- **Daily Paths.** Click and drag the sun along one of the daily paths to the desired time within the study period. The sun snaps to the time intervals specified for animation frames within the study period.

**NOTE** The sun movement is constrained by both time (daily path) and date (analemma). You can move the sun along only one path at a time. To change both the date and time, move the sun along one path, and then move it perpendicular to that path, rather than trying to move it diagonally across the total sun area. Or, hold down the left mouse button, and use the arrow keys to move the sun:

- **Left Arrow.** Moves the time later by moving the sun along its daily path from east to west.
- **Right Arrow.** Moves the time earlier by moving the sun along its daily path from west to east.
- **Up Arrow.** Moves the date later in time by moving the sun along the analemma.
- **Down Arrow.** Moves the date earlier in time by moving the sun along the analemma.
You can also drag a daily path to a new date within the total sun area. Moving the daily paths changes the dates while maintaining the same time of day.

- **Study Area.** Drag the boundaries of the study area to increase or decrease the study period. Or, place the cursor over a corner of the study area, press TAB repeatedly until the study area is highlighted, and then drag the entire surface of the study area to a new location within the total sun area.

  **TIP** To change the start and end times while maintaining the same time span, drag the surface along the daily paths. To change the start and end date while maintaining the same date span, drag the surface along the analemma.

- **Time.** Edit the time range by clicking the relevant time control and entering a new time. Or, drag the time boundaries of the study area to increase or decrease the time range.

- **Date.** Edit the date by clicking the relevant date control and entering a new date. Or, drag the date boundaries of the study area to increase or decrease the date range.

To save the current sun setting as a preset, see Using Sun Setting Presets on page 1392.

You can now **preview**, **save**, or **export** the solar study.

**To use the Sun Settings dialog**

1. Open a 2D or 3D view that supports the display of shadows.
2. Turn on shadows, and adjust their intensity.

  **TIP** To view the sun position, turn on the sun path as well.

3. On the View Control Bar, click Sun Path Off/On ➤ Sun Settings.
4. In the Sun Settings dialog, under Solar Study, select Multi-Day.
5. Under Presets, select one of the predefined sun settings, and click OK. Or, select <In-session, Multi-Day>, and complete the remaining steps in this procedure to define your own sun setting.
6. Under Settings, specify a sun position:
   a. For Location, verify that the correct project location is displayed.
      
      To change the location, click (Browse), and specify the project location either by searching on the street address or longitude and latitude, or by selecting the nearest major city from the Default City List.
   b. Enter a start date and end date for the study.
      
      The date format specified for your computer’s operating system is applied to the date you enter.
      
      **NOTE** For both the date and time values, if you enter a start value that is later than the end value, the values are corrected automatically.
   c. Enter a start time and end time for the study, or select Sunrise to sunset.
   d. For Time Interval, specify the amount of time between images in the animation.
      
      When you select a time interval, Frames displays the number of individual images that the solar study animation will contain.
   e. To cast shadows on the ground plane, select Ground Plane at Level, and select the level at which you want the shadows to display.
When you select Ground Plane at Level, the software casts shadows on the specified level in 2D and 3D shaded views. When you clear Ground Plane at Level, the software casts shadows on the toposurface, if one exists.

**NOTE** The ground plane is not used in rendered views. To cast shadows in rendered views, model a ground plane in the project.

7 To test the sun setting in the active view, click Apply.
8 To save the current sun setting as a preset, click Save Settings, enter a unique name, and click OK.
9 Click OK when done.

You can now **preview, save, or export** the solar study.

### Creating Lighting Solar Studies

Lighting solar studies produce single images that show the shadows cast from the sun position in the active view. Specify the sun position in the Sun Settings dialog, either by choosing a preset, such as Sunlight from Top Right, or by entering values for Azimuth and Altitude. Using the Lighting mode, you can create lighting conditions that might not exist in the real world, making Lighting studies most useful for presentation graphics, such as rendered images.

**NOTE** Unlike the other solar study modes, in which you can use the sun path’s on-screen controls to adjust the sun position, the Lighting mode requires the use of the Sun Settings dialog to adjust the sun position.

1 Open a **2D or 3D view** that supports the display of shadows.
2 **Turn on** shadows, and adjust their intensity.
3 To view the sun position, turn on the sun path.

**NOTE** When you are using a default template, the first time you turn on the sun path, the <In-session, Lighting> setting is specified and Relative to View is selected. When Relative to View is selected, the sun does not display. A dialog displays options for specifying sun settings.

4 If a dialog displays, click No, and continue with the current sun setting.

5 On the View Control Bar, click **Sun Path Off/On ➤ Sun Settings**.
6 In the Sun Settings dialog, under Solar Study, select Lighting if it is not already selected.
7 Under Presets, select one of the predefined sun settings, clear Relative to View if you want to display the sun, and click OK. Or, select <In-session, Lighting>, and complete the remaining steps in this procedure to define your own sun setting.
8 Under Settings, specify a sun position:
   a Enter values for Azimuth and Altitude.
      Azimuth is the bearing angle from True North, measured in degrees. Azimuth angles range from 0 degrees (north) through 90 (east), 180 (south), 270 (west), and up to 360 (north again).
      Altitude is the vertical angle between the horizon and the sun, measured from the horizon. Altitude angles range from 0 (on the horizon) up to 90 degrees (at the zenith).
   b To orient the sun to match the orientation of the view, select Relative to View. Or, to orient the sun to match the orientation of the model, clear Relative to View.

**NOTE** When Relative to View is selected, the sun path does not display.
To cast shadows on the ground plane, select Ground Plane at Level, and select the level at which you want the shadows to display. When you select Ground Plane at Level, the software casts shadows on the specified level in 2D and 3D shaded views. When you clear Ground Plane at Level, the software casts shadows on the toposurface, if one exists.

NOTE The ground plane is not used in rendered views. To cast shadows in rendered views, model a ground plane in the project.

9 To test the sun setting in the active view, click Apply.
10 To save the current sun setting as a preset, click Save Settings, enter a unique name, and click OK.
11 Click OK when done.

You can now save or export the solar study image.

Using the Sun Path

The sun path is a visual representation of the sun's range of movement across the sky at the geographic location you specify for a project. Using the sun path's on-screen controls, you can create solar studies by placing the sun at any point along its daily path, and at any point along its analemma (as described in the following illustrations and table).
**Still mode with sun selected**

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Daily path</td>
<td>The arced path the sun follows across the sky for the specified day. Visible in Still, Single Day, and Multi-Day modes.</td>
<td><strong>Still and Single Day:</strong> Drag the sun along the daily path to change the time, or drag the daily path itself to change the date. <strong>Multi-Day:</strong> Drag either daily path to change the start or end date of the study.</td>
</tr>
<tr>
<td>Analemma</td>
<td>The figure-8-shaped path that represents the position of the sun in the sky at the same time every day over the course of a year. Visible in Still, Single Day, and Multi-Day modes.</td>
<td>Drag the sun perpendicular to the daily path and along the analemma to change the date.</td>
</tr>
<tr>
<td>Study area</td>
<td>The highlighted area of the sun path that represents the specified date and time (or date range and time range). Visible in Single Day and Multi-Day modes.</td>
<td><strong>Single Day:</strong> Drag either end point of the specified time range to increase or decrease the study period. <strong>Multi-Day:</strong> Drag any boundary of the highlighted study area to increase or decrease the study period, or drag the entire surface of the study area to a new location within the total sun area. To change the start and end times while maintaining the same time span, drag the surface along the daily paths. To change the start and end date while maintaining the same date.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
<td>Usage</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>span, drag the surface along the analemma.</td>
<td>Place the cursor over the sun and hold down the left mouse button to reveal the total sun area. Moving the sun: Drag the sun anywhere within the specified study area to change the date and/or time.</td>
<td></td>
</tr>
<tr>
<td>Total sun area</td>
<td>The shaded area that represents the region of the sky (above the horizon) in which the sun moves throughout the year at the specified geographic location. Visible in Still, Single Day, and Multi-Day modes.</td>
<td></td>
</tr>
<tr>
<td>Ground compass</td>
<td>The segmented circle placed on the ground plane of the model, which bounds the sun path and shows the project’s orientation relative to True North. Visible in all solar study modes.</td>
<td>The ground compass indicates True North and does not change if you change the project orientation. When you use the View-Cube to adjust the orientation of the model in the view, the ground compass moves with the model because it is part of the view.</td>
</tr>
</tbody>
</table>

**Resizing the Sun Path**

You can resize the sun path by modifying its display size or byfitting it to an updated model:

**Modify display size**

The display size of the sun path in a 2D or 3D view is determined by the size of the bounding box that encompasses the visible model elements. By default, the sun path is displayed at 150% of the model radius in the view. In some cases, such as when you zoom in on a view, you might find it helpful to change the display size of the sun path.

**To change the display size**

1. Right-click the sun path, and click Properties.
2. On the **Properties palette**, for Sun path size (%), enter an integer between 100 and 500, and click OK.

**Fit to updated model**

As you change the size of the model or the visibility of its elements, the size of the bounding box updates automatically. To update the size of the sun path in proportion to the resized bounding box, do one of the following:

- Right-click the sun path, and click Fit to Model.
- Turn off the sun path, and then turn it on again.
Sun Path Instance Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Constraints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>The display size of the sun path in a 3D view, as determined by the size of</td>
</tr>
<tr>
<td>Sun path size</td>
<td>the bounding box that encompasses the visible model elements. By default,</td>
</tr>
<tr>
<td></td>
<td>the sun path is displayed at 150% of the model radius in the view.</td>
</tr>
</tbody>
</table>

Previewing Solar Study Animations

After you create a solar study animation, you can preview specific frames or the full animation using control buttons on the Options Bar.

To preview a solar study animation

1 In the Project Browser, double-click a view for which you created a solar study animation.

2 On the View Control Bar, click Shadows On, and click Preview Solar Study.

3 To play the animation from start to finish, on the Options Bar, click (Play).

4 To stop the animation, press ESC, or on the status bar, click Cancel.

5 To control the animation, use the following buttons on the Options Bar:
   - Moves backward 10 frames
   - Moves forward 10 frames
   - Displays the previous frame
   - Displays the next frame

To display a specific frame of the animation, for Frame, enter the frame number.

Saving Solar Study Images to Projects

Save solar study images to projects for later reference.

1 In the Project Browser, double-click a view for which you created a solar study animation.

2 In the drawing area, adjust the view so that it is displayed the way you want it to be saved.

   For example, verify that sun and shadows are turned on, and adjust the view orientation as needed. When using a solar study animation, use the animation control buttons to display the frame you want to save as an image.

3 In the Project Browser, right-click the current view, and click Save to Project as Image.

4 In the Save to Project as Image dialog, for Name View, enter a unique name for the image.

5 Modify image settings as needed, and click OK.
The image is saved under the Renderings node in the Project Browser.

Exporting Solar Studies

You can export solar studies to a variety of file formats that can be easily distributed and viewed by colleagues and clients. The export file types include AVI, JPEG, TIFF, BMP, and PNG. AVI files are standalone video files. All other export file types have a single-frame format, allowing you to save specified frames of an animation as separate image files.

NOTE When you want to export to a single-frame format, first create a folder in which to save the files (especially if you are exporting several frames). The export process saves each of the specified frames as a separate image file.

To export a solar study

1. In the Project Browser, double-click a view for which you created a solar study animation.
2. If you plan to export a solar study using rendered images (instead of shaded views or hidden line views), adjust the render settings for the 3D view as needed.
3. Click ➤ Export ➤ Images and Animations ➤ Solar Study.
4. In the Length/Format dialog, under Output Length, select All frames to export the entire animation, or select Frame range, and specify the start and end frames in the range.
5. If you are exporting to an AVI file, enter the number of frames per second. Based on the interval that you specify, the software calculates the output length, and displays it under Total time.
6. Under Format, for Visual Style, select one of the following:
   - Hidden Line. Displays the image with all edges and lines drawn except those occluded by surfaces.
   - Shaded. Displays the image with all surfaces shaded according to their material settings and project light locations.
   - Shaded with Edges. Displays the image in shaded mode, but with all non-occluded edges drawn as well.
   - Realistic. Displays the image in a real-time rendering view (a photorealistic rendering in an editable view).
   - Rendering. Uses defined render settings to create a photorealistic image for each frame in the solar study.
7. Enter dimensions (in pixels) or a zoom percentage to specify the size of the frame in the export file. If you enter a value for one dimension, the software calculates and displays the value for the other dimension to maintain the proportions of the frame, and it displays the equivalent zoom percentage. Likewise, when you change the zoom percentage, the software calculates and displays the equivalent dimensions.
8. Click OK.
9. In the Export Animated Solar Study dialog, under Save In, navigate to the target folder.
10. For File name, enter a file name.
11. For Files of type, select an export file type.
12. Click Save.
If you are exporting to a single-frame format, the animation plays while the files are being saved.

13 If you are exporting to an AVI file, do the following:
   a In the Video Compression dialog, select Full Frames (Uncompressed), or select one of the compressed video types.
      Results from various video compression formats (Codecs) vary widely.
   b If Compression Quality is enabled, use the slider to specify the compression quality.
   c Click OK.
      The animation plays while the AVI file is being saved.

**NOTE** Uncompressed AVI files can be zipped to reduce the file size. Typically, the AVI file can be played from within the ZIP file.

---

**Troubleshooting Solar Study Issues**

The following sections provide tips to help you identify and resolve commonly encountered solar study issues.

**The lighting is too dark in shaded views**

**Symptom:** In some shaded views, the lighting is darker than expected.

**Issue:** Changes to the software have resulted in slightly darker lighting in some shaded views.

**Solution:** To solve the problem, try the following:

- Change the sun position to an angle that produces the lighting you prefer.
- Increase the Sun Intensity or Indirect Light value.

**The sun path is turned on, but the sun is not displayed**

**Symptom:** The sun path is turned on and the ground compass displays, but the sun does not display.

**Issue:** The current solar study mode is Lighting, and the Relative to View option is selected. When Relative to View is selected, the sun does not display because its position is controlled by the orientation of the view.

**Solution:** On the View Control Bar, click ➤ Sun Path Off/On ➤ Sun Settings, and do one of the following:

- If you want to display the sun based on project location, date, and time, then select either Still, Single Day, or Multi-Day. For information about each of these solar study modes, see **Creating Solar Studies** on page 1376.
- If you want to show the shadows cast directly from a specified sun position in the active view, then retain Lighting as the solar study mode, and clear Relative to View. Next, choose a preset for an artificial sun position, such as Sunlight from Top Right, or enter values for Azimuth and Altitude to specify the sun position.

**The sun path does not resize to fit an updated model**

**Symptom:** After you have made changes to a model, the sun path is too big or too small for the model.

**Issue:** By default, the sun path is displayed at 150% of the model radius in the view. As you change the size of the model or the visibility of its elements, the size of the bounding box updates automatically, but the sun path is not resized automatically.
**Solution:** Update the size of the sun path in proportion to the resized bounding box by right-clicking the sun path, and clicking Fit to Model. Alternatively, you can turn off the sun path, and then turn it on again.

**The sun path is extremely large**

**Symptom:** In a project that includes an imported DWG file, the sun path is extremely large.

**Issue:** The display size of the sun path in a 2D or 3D view is determined by the size of the bounding box that encompasses the visible model elements. If you imported a DWG file with frozen layers that are encompassed by an extremely large bounding box, the sun path is extremely large as a consequence.

**Solution:** Delete unnecessary layers from the view, and then update the size of the sun path in proportion to the resized bounding box by right-clicking the sun path, and clicking Fit to Model.

**The sun path compass is not set to True North**

**Symptom:** The sun path’s ground compass is not set to True North.

**Issue:** Project North is not rotated to True North.

**Solution:** Rotate the view to True North to ensure that the light falls on the correct sides of the building model and that the sun’s path through the sky is accurately simulated. See Rotating a View to True North on page 110.

**The sun path does not print**

**Symptom:** The sun path is displayed in a view, but it does not print as part of the view.

**Issue:** The sun path is not designed to be printed as part of the view.

**Solution:** Save the solar study image to the project, and then print the saved image. See Saving Solar Study Images to Projects on page 1387.

---

**Working with Sun Settings**

Sun settings specify the position of the sun for the sun path, solar studies, walkthroughs, and rendered images. Use the Sun Settings dialog to define the sun’s position by date, time, and geographic location, or enter azimuth and altitude values to see shadows cast from a sun position that is independent of time and place.

**Specifying a Sun Setting**

You can specify a sun setting for solar studies, walkthroughs, and rendered images either by using the Sun Settings dialog (as described in this topic) or, in many cases, by using the sun path’s on-screen controls.

1. Open a 2D or 3D view that supports the display of shadows.
2. To turn on shadows, on the View Control Bar, click Shadows On/Off ➤ Shadows On.
3. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Sun Settings. Or, on the View Control Bar, click Sun Path Off/On ➤ Sun Settings.

**NOTE** You can also access the Sun Settings dialog from the Rendering dialog or the Graphic Display Options dialog.
4 In the Sun Settings dialog, under Solar Study, select a mode:
   ■ To define the sun setting based on a specified geographic location, select either Still, Single
     Day, or Multi-Day.
   ■ To define the sun setting based on azimuth and altitude, select Lighting.

5 Under Presets, select one of the predefined sun settings (such as a solstice) and click OK, or select
   the In-session preset and complete the remaining steps in this procedure to define your own
   sun setting.

6 Specify a sun setting for the specified mode:

   **For a Still, Single Day, or Multi-Day study**
   a For Location, verify that the correct project location is displayed.

       To change the location, click ![Browse](image) (Browse), and specify the project location either by
       searching on the street address or longitude and latitude, or by selecting the nearest major
       city from the Default City List.

   b For Date, enter a date for the study. For a Multi-Day study, enter both a start date and an
      end date.

   c For Time, enter a time for the study. For Single Day and Multi-Day studies, enter both a
      start time and an end time, or select Sunrise to Sunset.

       **TIP** For a Multi-Day study, to see the sun and shadow patterns for the same point in time over
       a range of days, enter the same start time and end time. You can also accomplish this by
       specifying the Time Interval as One day.

   **For a Lighting study**
   a Enter values for Azimuth and Altitude.

       Azimuth is the bearing angle from True North, measured in degrees. Azimuth angles range
       from 0 degrees (north) through 90 (east), 180 (south), 270 (west), and up to 360 (north
       again).

       Altitude is the vertical angle between the horizon and the sun, measured from the horizon.
       Altitude angles range from 0 (on the horizon) up to 90 degrees (at the zenith).

   b To orient the sun to match the orientation of the view, select Relative to View. Or, to orient
      the sun to match the orientation of the model, clear Relative to View.

7 To cast shadows on the ground plane, select Ground Plane at Level, and select the level at which
   you want the shadows to display.

   When you select Ground Plane at Level, the software casts shadows on the specified level in 2D
   and 3D shaded views. When you clear Ground Plane at Level, the software casts shadows on
   the toposurface, if one exists.

   **NOTE** The ground plane is not used in rendered views. To cast shadows in rendered views, model
   a ground plane in the project.

8 To test the sun setting in the active view, click Apply.

   **NOTE** For Single Day and Multi-Day studies, the sun is placed at the first frame of the animation.
   The shadows you see in the view are cast from this sun position.
9 Click OK when done.
10 To save the current sun setting as a preset, see Using Sun Setting Presets on page 1392.

Using Sun Setting Presets

Sun setting presets are predefined sun settings that give you easy access to dates and times of interest. Each solar study mode has key presets, such as solstices, equinoxes, and seasonal ranges. In addition, you can create your own presets, thereby saving specific sun settings for quick, repeatable access to dates and times of interest.

NOTE When you create new presets, you can either start from scratch, or you can duplicate and edit an existing preset. The only exceptions are the In-session presets, which cannot be duplicated, renamed, or deleted.

In-session presets
Each solar study mode has an In-session preset. Using this preset, you can specify a temporary setting for the sun in the active view and see changes in shadow patterns. You can then save the sun setting as a user-defined preset.

To create a preset
1 Open a 2D or 3D view that supports the display of shadows.
2 On the View Control Bar, click Sun Path Off/On ➤ Sun Settings. Or, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Sun Settings.
3 In the Sun Settings dialog, under Solar Study, select a mode.
4 In the Presets list, select the In-session preset for the current mode.
5 Under Settings, enter the values that you want to save as a preset. Optionally, you can display the sun path and use its on-screen controls to position the sun for the preset. To do this, close the Sun Settings dialog, turn on the sun path, and position the sun in the drawing area. For Lighting mode, enter Azimuth and Altitude values using the on-screen controls, as you cannot drag the sun to adjust its position in Lighting mode. Then, reopen the dialog and complete the remaining steps in this procedure.
6 Click Save Settings.
7 In the Name dialog, enter a unique name for the preset, and click OK. The new preset is added at the end of the Presets list.
8 Click OK.

To apply a preset
1 Open a 2D or 3D view that supports the display of shadows.
2 Turn on the sun and shadows.
3 On the View Control Bar, click Sun Path Off/On ➤ Sun Settings. Or, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Sun Settings.
4 In the Sun Settings dialog, under Solar Study, select a mode.
5 In the Presets list, select a preset.
   The Settings section of the dialog displays the values associated with the preset.
6 Click Apply to preview the preset in the active view.
7 Click OK when done.

To edit a preset

1 On the View Control Bar, click Sun Path Off/On ➤ Sun Settings.

Or, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Sun Settings.
2 In the Sun Settings dialog, under Solar Study, select a mode.
3 In the Presets list, select a preset.

NOTE It is advisable to retain the original values for presets that are tied to solar events, such as equinoxes, solstices, and seasons.

4 Under Settings, modify the values as needed.
5 Click OK.

To duplicate a preset

1 On the View Control Bar, click Sun Path Off/On ➤ Sun Settings.

Or, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Sun Settings.
2 In the Sun Settings dialog, under Solar Study, select a mode.
3 In the Presets list, select a preset.

NOTE You cannot duplicate In-session presets.

4 Click (Duplicate).
5 In the Name dialog, enter a unique name for the preset, and click OK.
   The new preset is added at the end of the Presets list.
6 In the Sun Settings dialog, under Settings, modify the values as needed.
7 Click OK.

To rename a preset

1 On the View Control Bar, click Sun Path Off/On ➤ Sun Settings.

Or, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Sun Settings.
2 In the Sun Settings dialog, under Solar Study, select a mode.
3 In the Presets list, select a preset.

NOTE You cannot rename In-session presets.

4 Click (Rename).
5 In the Rename dialog, enter a unique name for the preset, and click OK. The new preset is added at the end of the Presets list.

6 In the Sun Settings dialog, under Settings, modify the values as needed.

7 Click OK.

To delete a preset

1 On the View Control Bar, click Sun Path Off/On ➤ Sun Settings.

Or, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Sun Settings.

2 In the Sun Settings dialog, under Solar Study, select a mode.

3 In the Presets list, select a preset.

**NOTE** You cannot delete In-session presets.

4 Click (Delete).

5 When prompted to confirm the deletion, click Yes.

6 In the Sun Settings dialog, click OK.

**Sun Settings in Upgraded Projects**

When you upgrade a project from a previous version of Revit Structure, the sun setting that was saved with the project is applied to the upgraded project, unless the project was saved with a named sun setting, shadows off, and the Use sun position for shaded views option cleared (deselected). In this case, the saved settings cannot be applied due to changes in the software; therefore, the <In-session, Lighting> setting is applied, as this setting most closely emulates the lighting conditions produced by the previous settings. If your named sun setting is no longer selected after you upgrade the project, you can select it in the Sun Settings dialog under Presets.

When the Lighting mode is in effect and Relative to View is selected, the sun path does not display. A dialog displays options for specifying sun settings:

- To create lighting conditions based on the project location, date, and time, click Yes. Then, create a Still, Single Day, or Multi-Day solar study.

- To create lighting conditions that might not exist in the real world, click No. Then, use the Sun Settings dialog to specify the sun position.

**Related topics**

- Specifying a Sun Setting on page 1390

- Creating Lighting Solar Studies on page 1383
Revit Structure projects can be analyzed through Revit Structure Add-In applications to predict the effects of various structural and environmental forces. You can create display styles to visualize these results.

For example, you may want to study how applied loads affect a floor beam. Using a Revit Structure Add-In application, the floor model is analyzed and results are returned as a set of points with associated values. You can create styles to visualize these results so that you can see in Revit Structure, at which point a beam is over-stressed.

Display style options:

- **Colored surface** - displays a colored surface that interprets analysis results.
- **Markers with text** - displays a colored graphical shape at each data point, with corresponding numbers, that describes analysis results.
Display styles can include a legend.

<table>
<thead>
<tr>
<th>Colored surfaces</th>
<th>Markers with text</th>
</tr>
</thead>
</table>

Analysis Visualization Overview

The Revit Structure analysis visualization framework tools use an API to interpret analyses performed by Revit Structure Add-In applications. You use the Revit Structure analysis display style tools to create visual styles that display the analysis results. These can be created independently, and applied to an analysis at a later time. See Analysis Display Styles Workflow on page 1397.

**NOTE** Analysis results can only be created and displayed in the project environment. They are not available in the Revit Family Editor.

You can use the same style to display different results in different project views.

**NOTE** Analysis results are not visible in views that use the Wireframe visual style.

Analysis Display Styles

Analysis display styles are used to visualize the results of an analysis created by a Revit Structure Add-in application. Display styles are permanently stored in Revit Structure, and used in a project view. Within the view, you can select a different style that immediately applies to the analysis result.
Analysis Display Styles Workflow

1. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Analysis Display Styles).

2. Click (New), and on the New Analysis Display Style dialog, select Colored surface, or Markers with text.

3. Enter a name in the Name field.  
   **TIP** Create display style names with common prefixes so that they can be effectively filtered during a search.

4. Select options on the Settings, Color, and Legend tabs to create the analysis display view style. See Styles Tools on page 1397.

5. Click OK. The style is ready to be used in any project view.

Styles Tools

The Styles panel contains the tools to:

- search for display styles.
- select from a list, or icon, display.
- create, duplicate, rename, and delete styles.

Analysis Display Style Options

There are several display options you can use to create analysis display styles. After you select one of the style types (Gradient or Ranges), you select from options on the Analysis Display Styles dialog tabs to further configure the style.

- **Settings tab** configures the visible elements on a style.
- **Color tab** establishes the relationship between the colors displayed in a style and the analysis data.
- **Legend tab** configures what displays on the legend.

**Settings Tab**

<table>
<thead>
<tr>
<th>Settings Tab Options - Colored surface</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show gridlines</td>
<td>When selected, a grid displays on the colored surface.</td>
</tr>
</tbody>
</table>
NOTE  Grids are displayed only for model graphic styles that display edges, such as Hidden Line and Shaded with Edges.

<table>
<thead>
<tr>
<th>Settings Tab Options - Markers with text</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape</td>
<td>Determines the marker shape (Circle, Square, or Triangle).</td>
</tr>
<tr>
<td>Size</td>
<td>Determines the marker size in sheet size units. See Sheets on page 978.</td>
</tr>
<tr>
<td>Show text</td>
<td>When selected, displays calculated values next to the marker.</td>
</tr>
<tr>
<td>Text type</td>
<td>Determines marker text display through one of the text types you have set in Revit Structure. Once you choose a text type, it governs the properties of size, font, color, and background.</td>
</tr>
<tr>
<td>Rounding</td>
<td>Sets the rounding increment of the displayed value for the marker text.</td>
</tr>
</tbody>
</table>

### Color Tab

<table>
<thead>
<tr>
<th>Color Tab Options - Colored surface and Markers with text</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gradient</td>
<td>Presents analysis results in a gradient color display from the maximum to minimum values.</td>
</tr>
<tr>
<td>Ranges</td>
<td>Presents analysis results in specific color ranges between the maximum to minimum values.</td>
</tr>
<tr>
<td>+ Add rows above selected row</td>
<td>Adds value-color rows to the analysis display style above the selected row.</td>
</tr>
<tr>
<td>- Remove selected row</td>
<td>Removes value-color rows from the analysis display style.</td>
</tr>
</tbody>
</table>

### Gradient and Ranges Color Display

**Gradient**

In a gradient display, Revit Structure displays colors smoothly across the surface by interpolating between user-specified value-color pairs. For values between the specified values, the displayed color varies linearly (in RGB) between the specified color for those values.

**Ranges**

In a ranges display, Revit Structure displays all values between user-specified value-color pairs as a single color. This is accomplished by specifying the Color below value on the Color tab. All points that have a
value below this specified value (but above the next specified value-color pair) will be displayed with this color.

**NOTE** The maximum and minimum values are always relative to the results displayed in a particular view. You can only modify the colors used to display the maximum and minimum values. For more information about displaying specific values using specific colors, see Setting Colors on page 1400.

---

### Adding or Removing Value-Color Pairs

On the Color tab, by default, there are Max (maximum) and Min (minimum) value-color pairs. These values are relative to the data displayed. You can only set the colors for Min and Max values. These value-color pairs cannot be deleted.

New value-color pairs can be added in between existing value-color pairs. When you add a new value-color pair, the color that is automatically assigned is midway (linearly in RGB) between the color above and below it.

To maintain a smooth color gradient when adding multiple values, you specify the number of values to add using Add rows above selected row. New pairs are always added above the selected pair.

As you add a new color to Ranges, the range is re-divided to accommodate the additional color for equal color distribution. The color that appears in the new row is the equivalent of the midpoint of the gradient between those 2 colors.

**NOTE** Up to 10 values can be added at once.

**To add value-color pairs**

1. On the Color tab, click in the Value column to specify the row above which to start adding rows.
2. In the Specify number of rows to add text box, type the number of rows to add.
3. Select the Add rows above selected row button.

**To remove value-color pairs**

1. On the Color tab, specify the pair to remove by selecting a value.
2. Select Remove selected row.

**NOTE** Color value rows are removed one at a time.

---

### Setting Values

By default, any value-color row has Auto in the Value cell. This means that the actual value is calculated automatically to be exactly between the value above and the value below the selected cell. The exact number
corresponding to the Auto value depends on the analysis results. This can be different for different results, as shown in the following table:

<table>
<thead>
<tr>
<th>Analysis Display Style</th>
<th>Analysis Results A</th>
<th>Analysis Results B</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>min = -10; max = 10</td>
<td>min = 0; max = 30</td>
</tr>
</tbody>
</table>

Auto values can be changed to a number. The color in the Color at value cell in the same row always corresponds to this number independently of the actual results, as shown in the following table:

<table>
<thead>
<tr>
<th>Analysis Display Style</th>
<th>Analysis Results A</th>
<th>Analysis Results B</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>min = -10; max = 10</td>
<td>min = -10; max = 10</td>
</tr>
</tbody>
</table>

To change Auto to a number

1. Double-click Auto.
2. Enter a number to replace Auto.

**NOTE** Numbers must stay in sequential order from greatest (Max) to least (Min).

**Setting Colors**

1. On the Color tab, in the color column, click the color you want to change. The Color dialog displays.
2. Select a color and click OK.

**Legend Tab**

<table>
<thead>
<tr>
<th>Legend Tab Options - Colored surface and Markers with text</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Legend</td>
<td>Displays a legend with the analysis result. This data is populated by the API.</td>
</tr>
<tr>
<td>Steps between min and max</td>
<td>Enter a number (between zero and 25) to set the number of steps to display on the legend between the minimum and maximum.</td>
</tr>
<tr>
<td>Show Units</td>
<td>Displays text to describe the type of measurement units for the analysis results. This data is populated by the API.</td>
</tr>
</tbody>
</table>
**Legend Tab Options - Colored surface and Markers with text**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Name</td>
<td>Displays analysis result name. This data is populated by the API.</td>
</tr>
<tr>
<td>Show Description</td>
<td>Displays analysis result description. This data is populated by the API.</td>
</tr>
<tr>
<td>Text Type</td>
<td>Determines text display for one of the text types you have set in Revit Structure. Once you choose a text type, it governs the properties of size, font, color, and background.</td>
</tr>
<tr>
<td>Rounding</td>
<td>Sets the incremental rounding value for the steps between the minimum and maximum values.</td>
</tr>
</tbody>
</table>

---

**Applying Display Style to a View**

The analysis display style is a property of the project view. When you want to change the view style, select it on the **Properties palette**.

1. Open a view from the Project Browser.
2. On the Properties palette, under Analysis Display Style, select the ellipsis next to the current style name.
3. Select a different style from the Analysis Display Styles dialog and click OK.

The display style applies to analysis results in the view.

---

**Searching for Analysis Display Styles**

Analysis display styles can be searched for by full or partial names on the Analysis Display Styles dialog. The matching results display immediately in the Styles section while you type.

1. Open a view in the Project Browser.
2. Open the Analysis Display Styles dialog.
3. Type the partial or full style name into the Styles search box to display all the matching display style names.

---

**Analysis Results**

When an analysis display style is available, it can be applied to an analysis result. The result can be saved as an image, or modified through its properties.

An analysis result can contain one or more named data sets. The add-in application can supply multiple units for data display. You can control which data set to display (and its units) through the properties of the analysis result. See **Analysis Result and Legend Element Properties** on page 1402.
Saving the Analysis Results View

Analysis results are not saved after the Revit Structure session closes. To preserve the result display, you can save its view to the project as an image. The view is saved in the Project Browser as a static image that can be printed and placed on sheets. It cannot be edited.

1. In the Project Browser, right-click on the active view name.
2. Select Save to Project as Image.
3. In the Save to Project as Image dialog, enter a name in the Name View text box.
4. Specify the output by selecting the Export Range, Image size, Options, and Raster Image Quality, and click OK.

For more information on these options, see Exporting a View to an Image File.

Analysis Result and Legend Element Properties

The analysis result and legend that display in a view are elements with properties. You can change the properties on the Properties palette. Select the analysis result surface, or the legend, to display their properties.

<table>
<thead>
<tr>
<th>Analysis Result Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Max</td>
<td>Displays the maximum value for the analysis result. (read-only)</td>
</tr>
<tr>
<td>Min</td>
<td>Displays the minimum value for the analysis result. (read-only)</td>
</tr>
<tr>
<td>Name</td>
<td>Controls which named data set to display.</td>
</tr>
<tr>
<td>Units</td>
<td>Controls which units to display.</td>
</tr>
<tr>
<td>Range</td>
<td>Controls the Max and Min values. Select Current data or All data to display the maximum and minimum values from the current data set, or the values across all data sets.</td>
</tr>
<tr>
<td>Description</td>
<td>The Analysis result description. (read-only)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Legend Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>Sets the legend width. (sheet-size units)</td>
</tr>
<tr>
<td>Height</td>
<td>Sets the legend height. (sheet-size units)</td>
</tr>
</tbody>
</table>
Tools and Techniques
Sketching

To create certain elements in Revit Structure, such as roofs, floors, stairs, and railings, you draw them by sketching. Sketching is also required to define other types of geometry, such as extrusions, openings, and regions.

**Sketching Terminology**

There are several terms specific to the sketching process in Revit Structure:

- **Sketching** is a process of drawing elements in Revit Structure.

- **Sketch-based elements** are those elements (for example, floors, ceilings, and extrusions) that are typically created using sketch mode. There are also elements, such as walls, that are sketched but do not require the use of sketch mode.

- **Sketch mode** is an environment in Revit Structure that allows you to sketch elements whose size or shape cannot be determined automatically, for example when you create (or edit a sketch of) a roof or a floor. When you enter sketch mode, the Ribbon only displays the tools applicable for the type of sketch you are creating or editing.

- All the elements that comprise a sketch-based element (such as a roof) are known as the **sketch**. For example, a sketch-based roof is selected in the following image.
In this example, when you select the roof (created by extrusion), you can click Modify | Roofs tab ➤ Mode panel ➤ (Edit Profile), which opens the sketch (the pink lines in the following image) in sketch mode. For a roof created by footprint, select the roof and click Modify | Roofs tab ➤ Mode panel ➤ (Edit Footprint). Here you can edit the individual elements of the sketch. The tools that are available in sketch mode vary depending on the type of element you are editing.

**Sketching Elements**

You can either draw sketch lines or use a Pick (Walls, Lines, Edges, Faces) option when sketching. Drawing allows you to create the element by clicking and moving the cursor; Pick options allow you to select existing walls, lines, edges or faces. As you sketch, you can use listening dimensions. For more information, see [Listening Dimensions](#) on page 909.

When you add elements whose size or shape cannot be determined automatically, such as a roof, extrusion, or opening, you enter sketch mode. In sketch mode, only the tools available for that sketch are available for use; the tools vary depending on the type of element you are sketching. There are also elements (such as walls) that are sketched but do not require the use of sketch mode.

**Common Options for Sketches**

<table>
<thead>
<tr>
<th>Use this option</th>
<th>to</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Draw options</strong> (for example, ![Line] or ![Rectangle])</td>
<td>draw sketches.</td>
</tr>
</tbody>
</table>
| **Pick options** (for example, ![Pick Lines]) | select existing walls, lines, or edges. When you use Pick Lines, there is a Lock option (for some elements) on the Options Bar that locks the picked line to the edge.  
**TIP** You can use Tab to toggle to available chains. |
| ![Pick Faces] | add walls by selecting the face of a mass element or generic component. This option is only available when you are sketching walls or curtain walls. |
| Chain | connect (chain) line segments when you are sketching so that the last point on the previous line becomes the first point on the next line. |
### Offset

Offset the placement of a sketch line by the value you specify. When you use offset with the Pick Lines option, the element or sketch line is offset from a line specific to an element (for example, the location line in a wall). The new element has the same shape and length as the picked line. If you use offset when you draw a sketch, the element or sketch is offset from the cursor location. You can create an element of any length or shape when drawing a sketch with an offset. You can also specify the offset location line for walls by selecting an option from the Location Line drop-down.

**NOTE** If you draw with the chain option turned on, the newly created lines are also chained. Therefore, you can create a shape similar to an existing shape by tracing it with an offset.

### Radius

preset a value for the radius. This option is available for walls or lines when you draw a rectangle, circle, arc, or polygon. Use a radius to:

- specify a fixed radius for a circle, a circle in which a polygon is inscribed (or around which it is circumscribed), an arc from center and endpoint, or a tangent arc. The preset radius puts constraints on the element or sketch so that fewer clicks are required to complete it. With a preset radius, you can create a circle with one click or a fillet with 2 clicks.
- specify a rounding of corners (the radius of the fillet) when joining lines (with or without the chain option), when you draw a rectangle, or when you fillet using the Fillet Arc sketch option.

### Using Constraints When Sketching

You can use constraints while you are sketching by pressing *Shift* as you draw. Shift constraints works as follows:

- Constrains straight lines and radii of polygons to horizontal or vertical lines.
- Limits the chords of 3-point arcs, the radii of arcs from center and end points, and the axis of ellipses to multiples of 45 degrees.
- Limits 2-point and 3-point arcs to 90, 180, or 270 degrees.

### Sketching a Line

1. Select a tool that allows for a line, for example, click Home tab ➤ Model panel ➤ \( \text{Line} \).
2. Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create <Element> tab) ➤ Draw panel ➤ \( \text{Line} \).
3. On the Options Bar:
   - Optionally, for Offset, specify a value.
   - Optionally, select Radius and specify a value.
A radius creates fillets at the specified radius between line segments, allowing you to create a rounded chain of lines. A line must be joined to the end of another line for a fillet to display. If a line is connected to more than one line, a fillet cannot be created.

The following image shows line segments sketched without Radius selected and line segments sketched with Radius selected.

NOTE If you specify a radius, the Offset option is overridden.

4 Click in the drawing area to specify the start point of the line.
5 Move the cursor and click to specify the end point of the line.

NOTE You can also use listening dimensions to specify the length of the line. See Listening Dimensions on page 909.

**Sketching a Rectangle**

1 Select a tool that allows for a rectangle, for example, click Home tab ➤ Model panel ➤ (Model Line).
2 Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create <Element> tab) ➤ Draw panel ➤ (Rectangle).
3 On the Options Bar:
   a Optionally, for Offset, specify a value.
   b Optionally, select Radius and specify a value.
      Specifying a radius creates fillets at the corners of the rectangle.
      The following image shows a rectangle sketched without Radius selected and a rectangle sketched with Radius selected.

   NOTE If you specify a radius, the Offset option is overridden.

4 Click in the drawing area to specify the first corner of the rectangle.
5 Move the cursor and click to specify the diagonal corner of the rectangle.

**Sketching a Circle**

1 Select a tool that allows for a circle, for example, click Home tab ➤ Model panel ➤ (Model Line).
2 Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create
<Element> tab) ➤ Draw panel ➤ (Circle).
3 On the Options Bar:
   a Optionally, for Offset, specify a value.
   b Optionally, select Radius and specify a value. If you specify a radius, placing a circle in the
drawing area requires only 1 click.

   NOTE If you specify a radius, the Offset option is overridden.

4 Click in the drawing area to place the circle. If you have not already specified a radius, move
the cursor and click to complete the circle.

   NOTE You can also use listening dimensions to enter a value for the radius. After you click in the
drawing area to place the circle, type the value of the radius and press Enter.

Sketching an Inscribed Polygon

1 Select a tool that allows for an inscribed polygon, such as Wall, Model Line, or Detail Line.

   For example, click Home tab ➤ Model panel ➤ (Model Line).

   For an inscribed polygon, the radius of the circle is measured to a vertex between sides of the
polygon.

2 Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create
<Element> tab) ➤ Draw panel ➤ (Inscribed Polygon).
3 On the Options Bar:
   a Enter the number of sides for the polygon.
   b Optionally, for Offset, specify a value.
   c Optionally, select Radius and specify a value.

   NOTE If you specify a radius, the Offset option is overridden.

4 Click in the drawing area to specify the start point.
5 If you have not already specified a radius, move the cursor and click to complete the inscribed
polygon.

   NOTE You can also use listening dimensions to enter a value for the radius. After you click in the
drawing area to place the inscribed polygon, type the value of the radius and press Enter.

Sketching a Circumscribed Polygon

1 Select a tool that allows for a circumscribed polygon, such as Wall, Model Line, or Detail Line.

   For example, click Home tab ➤ Model panel ➤ (Model Line).

   For a circumscribed polygon, the radius of the circle is measured to a side of the polygon.
2 Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create <Element> tab) ➤ Draw panel ➤ (Circumscribed Polygon).

3 On the Options Bar:
   a Enter the number of sides for the polygon.
   b Optionally, for Offset, specify a value.
   c Optionally, select Radius and specify a value.

   **NOTE** If you specify a radius, the Offset option is overridden.

4 Click in the drawing area to specify the start point.
5 If you have not already specified a radius, move the cursor and click to complete the circumscribed polygon.

   **NOTE** You can also use listening dimensions to enter a value for the radius. After you click in the drawing area to place the circumscribed polygon, type the value of the radius and press Enter.

**Sketching Arcs**

There are several options for sketching arcs in Revit Structure:

- **Start-End-Radius Arc**
  You specify a start-end-radius arc by drawing the chord that connects the 2 ends of the arc, and then you specify the angle or radius with the third point.

- **Center-ends Arc**
  To create an arc from the center and end points, first specify the radius for the arc, and then specify the angle. You cannot specify an arc of more than 180 degrees using this method, although you can modify the arc after you draw it.

- **Tangent End Arc**
  You can create tangent arcs from the end points of existing walls or lines.
Fillet Arc
Use fillet arcs when you need to create rounded corners.

For information on constraining arc sketches, see Using Constraints When Sketching on page 1407.

**Resizing Arc Lines**
You can resize arc lines using middle and end controls.

1. Select the arc.
2. Drag the end controls to change the arc length.
3. To change the radius of the arc while keeping the radius concentric, on the Options Bar, select Keep Concentric.
   Clear that option to retain an existing end condition, such as an end point location or tangency to a straight wall.
4. Drag the middle control.

**Sketching a Start-End-Radius Arc**

1. Select a tool that allows for an arc, for example, click Home tab ➤ Model panel ➤ (Model Line).
2 Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create <Element> tab) ➤ Draw panel ➤ \( \text{(Start-End-Radius Arc)} \), and place the cursor in the drawing area.
3 Click in the drawing area to specify the start point for the arc.
4 Move the cursor and click to specify the length of the chord.

![Image](image1.png)

**NOTE** You can also use listening dimensions to specify the length of the chord. After you click in the drawing area to specify the start point, type a value for the chord and press *Enter*.

5 Move the cursor and click to define the arc.

![Image](image2.png)

**NOTE** You can also use listening dimensions to specify the radius of the arc. Type a value for the radius and press *Enter*.

### Sketching an Arc from the Center and End Points

Use this sketching option to create an arc up to 180 degrees. If you move the cursor so the arc exceeds 180 degrees, the arc flips to the other side.

1 Select a tool that allows for an arc, for example, click Home tab ➤ Model panel ➤ \( \text{Model Line} \).
2 Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create <Element> tab) ➤ Draw panel ➤ \( \text{(Center-ends Arc)} \), and place the cursor in the drawing area.
3 Click in the drawing area to specify the center of the arc.
4 Move the cursor and click to define the arc radius and the start point of the arc.

![Image](image3.png)
NOTE You can also use listening dimensions to specify the radius of the arc. Type a value for the radius and press Enter.

5 Move the cursor and click to specify the end point of the arc.

NOTE You can also use listening dimensions to specify the angle of the arc. Type a value for the angle and press Enter.

Sketching a Tangent Arc

1 Select a tool that allows for an arc, for example, click Home tab ➤ Model panel ➤ (Model Line).
2 Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create <Element> tab) ➤ Draw panel ➤ (Tangent End Arc), and place the cursor in the drawing area.
3 Click the endpoint of an existing wall or line to specify the start point for the tangent arc.
4 Move the cursor and click to specify the end point of the arc.

Sketching a Fillet Arc

NOTE You can only fillet elements that are created with the Line (this includes sides of polygons) or Arc sketch options.

1 Select a tool that allows for an arc, for example, click Home tab ➤ Model panel ➤ (Model Line).
2 Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create <Element> tab) ➤ Draw panel ➤ (Fillet Arc), and place the cursor in the drawing area.
3 Select the first element to fillet.
4 Select the second element to fillet.

5 Move the cursor and click to define the fillet arc.

After you place the fillet, Revit Structure automatically trims the elements to the fillet.

Sketching Ellipses

Ellipses are available for model lines, detail lines, beams, and sketch-based elements.

Sketching a Full Ellipse

1 Select a tool that allows for an ellipse, for example, click Home tab ➤ Model panel ➤ (Model Line).
2 Click Modify | Place Lines tab (or respective Modify | Place <Element> tab or Modify | Create <Element> tab) ➤ Draw panel ➤ (Ellipse) or (Pick Lines).

**NOTE** If you select Pick Lines, you can pick the edge or face of another ellipse.

3 If you selected Pick Lines, on the Options Bar optionally specify a value for Offset.

**NOTE** Offset for an ellipse is only available when you select the Pick Lines option.

When you create a full ellipse with an offset, the result is a spline. For example, if you create a mass element as a full ellipse with an offset and then attempt to create a wall on the face of the mass element, the ellipse is not considered contiguous, as shown in the following image.

4 Click in the drawing area to specify the center of the ellipse. Snapping is enabled for the ellipse, and a preview ellipse displays.

5 Move the cursor away from the center in any direction. An editable listening dimension displays the radius of the major axis.

6 Either click when the desired radius value displays, or type a value and press Enter.

7 Again, move the cursor away from the center in any direction. An editable listening dimension displays the radius of the minor axis.

8 Either click when the desired radius value displays, or type a value and press Enter.

**Sketching a Partial Ellipse**

1 Select a tool that allows for an ellipse, for example, click Home tab ➤ Model panel ➤ (Model Line).

2 Click Place Lines tab (or respective Place <Element> tab or Create <Element> tab) ➤ Draw panel ➤ (Partial Ellipse) or (Pick Lines).

**NOTE** If you select Pick Lines, you can pick the edge or face of another ellipse.

3 If you selected Pick Lines, on the Options Bar optionally specify a value for Offset.
NOTE Offset for an ellipse is only available when you select the Pick Lines option.

4 Click in the drawing area. Snipping is enabled for the partial ellipse, and a preview ellipse displays.

5 Move the cursor away from the first point to define the direction and extent of the major axis.

6 Either click when the desired value displays, or type a value and press Enter.

7 Move the cursor to get the desired partial ellipse shape and either click, or type a value and press Enter.

Resizing an Ellipse

1 Select the ellipse.

2 If you created an ellipse for a sketch-based element, click the edit option to enter sketch mode.

   For example, if you created an elliptical floor, click Modify | Floors tab ➤ Mode panel ➤ (Edit Boundary).

3 Optionally, on the Options Bar, select Modification keeps ratio.
   This allows you to change the radii proportionally.

4 Resize the ellipse:

   To resize using then

   temporary dimensions click the temporary dimension for the axis radius you want to change, enter a new value in the text box, and press Enter.

   controls drag the controls to resize the major and minor axes. For a full ellipse, there are 4 controls (one for each quadrant). For a partial ellipse, there are also 4 controls (one for each quadrant). In addition, there are 2 controls at either end (one for each end of the partial ellipse). You can modify the shape of the ellipse (Drag line end option) or you can resize the axis (Drag axis end option). Place the cursor over the control and press Tab until the desired option displays in the status bar.

5 If necessary, click ✓ (Finish Edit Mode).
Rotating an Ellipse

To rotate ellipses, select the ellipse and click Modify | <element> tab ➤ Modify panel ➤ (Rotate). See Rotating Elements on page 1481.

If you need to snap the axis end to another element, you can use the drag controls to rotate the ellipse. Using this method may cause you to inadvertently resize the axis.

Sketching a Spline

1 Select a tool that allows for a spline, for example, click Home tab ➤ Model panel ➤ (Model Line).
2 Click Place Lines tab (or respective Place <Element> tab or Create <Element> tab) ➤ Draw panel ➤ (Spline), and place the cursor in the drawing area.
3 Click to specify the start point for the spline.
4 Move the cursor and click to specify the next control point on the spline. Repeat as necessary.
5 Click (Modify) to complete the spline.

You cannot create a single closed loop with one spline. However, you can close the loop with a second spline. See Modifying a Spline on page 1418.

Best Practices for Sketching a Spline

When sketching a spline, try to use the simplest lines (or combination of lines) to achieve the desired results. For example, you may need to create a line that looks similar to the following image.

![Spline Example](image)

You could create this line using a combination of arcs and lines, or you could use a spline. Lines that are sketched using splines require more processing time, therefore it is recommended to use arc and line combinations instead of splines whenever possible.

When it is necessary to create a line using a spline, you should use as few control points as possible to keep processing time to a minimum. The following image shows a spline that was sketched by choosing many control points (blue dots).

![Spline with Many Points](image)

You can create the same spline using fewer control points, as shown.
Modifying a Spline

1. Select the spline.
2. Click Modify | Lines tab ➤ Edit Spline panel ➤ (Add Control) or (Delete Control).
   ■ Add Control adds a control point to the spline. Place the cursor over a spline chord and watch the status bar. When it says Reference, click to place a control. A control point is added to the center of the chord.
   ■ Delete Control deletes a spline control point. Select a control point for deletion. The spline adjusts after control point deletion.
3. To move a control point, drag it to a new location.
4. To move spline end points, select the spline.
   ■ To move the entire spline, drag the end controls, which display as blue dots.
   ■ To modify the spline curve between the end point and the next control point, select the end control, press Tab, then drag the end control point.

Closing an Open Loop

You can use the Close snap to close valid open loops when sketching. If there is more than one option to close the loop, you can move the cursor or press Tab to see other snap options.

To close an open loop:

1. Begin sketching off of the open loop.

**NOTE** When sketching, the status bar indicates when there is a valid open loop to close.
2 Right-click, and click Snap Overrides ➤ Close. Revit Structure snaps to close the loop.

If there is more than one option to close the loop, you can move the cursor or press Tab to see other close options.

3 Click to complete the loop.

**Modifying Sketched Elements**

1 In the drawing area, select a sketched element.

2 If you created the sketch for a sketch-based element, click the edit option to enter sketch mode.

   For example, if you sketched a floor, click Modify | Floors tab ➤ Mode panel ➤ (Edit Boundary).

3 Modify the element:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then</th>
</tr>
</thead>
<tbody>
<tr>
<td>move an entire element</td>
<td>select all of its sketch lines, and drag it to the desired location. If another element is attached, it updates accordingly.</td>
</tr>
<tr>
<td>modify the end of a sketch line</td>
<td>select it, and either drag the end control or edit the dimension. If you are moving the end control of a straight line segment, you can change the angle of the line or change the length of the line. If you move the end control of an arc, you change the number of degrees for the arc angle; if you drag the middle control, you change the radius.</td>
</tr>
</tbody>
</table>

4 If you were in sketch mode, when finished, click ✓ (Finish Edit Mode).
Creating Solid and Void Geometry

The tools you use to create solid and void geometry are available only in the Family Editor. For more information, see Family Editor on page 678.

For detailed information about creating families, including tutorials for creating geometry using the Family Editor, see The Families Guide on page 680.

Creating an Extrusion

For information about using extrusions in families, see The Families Guide on page 680.

A solid or void extrusion is the easiest form to create. You sketch a 2D profile of the form on a work plane, and then extrude that profile perpendicular to the plane on which you sketched it.

Sample polygonal concrete isolated foundation extrusion

Before you extrude the shape, you can specify its start and end points to increase or decrease the depth of the form. By default, the extrusion start point is 0. The work plane does not need to be either the start or end point of the extrusion – you only use it to sketch on and to set the extrusion direction.

The following procedure is a general method for creating a solid or void extrusion. Steps may vary depending on your design intent.

To create a solid or void extrusion

1. In the Family Editor, on the Home tab ➤ Forms panel, do one of the following:
   - Click (Extrusion).
   - Click Void Forms drop-down ➤ (Void Extrusion).

   **NOTE** If necessary, set the work plane before you sketch the extrusion. Click Home tab ➤ Work Plane panel ➤ (Set).

2. Use the sketching tools to sketch the extrusion profile:
   - To create a single solid form, sketch a closed loop.
   - To create more than one form, sketch multiple, non-intersecting, closed loops.
3 On the Properties palette on page 34, specify the extrusion properties:

- To extrude the profile from the default start point of 0, under Constraints, for Extrusion End, enter a positive or negative extrusion depth. This value changes the endpoint of the extrusion.

  **NOTE** The extrusion depth is not retained after you create the extrusion. If you need to make multiple extrusions with the same endpoint, sketch the extrusions, select them, and then apply the endpoint.

- To extrude the extrusion from a different start point, under Constraints, for Extrusion Start, enter a new point.

- To set the visibility of a solid extrusion, under Graphics, for Visibility/Graphics Overrides, click Edit, and specify the visibility settings.

- To apply a material to a solid extrusion by category, under Materials and Finishes, click in the Material field, click , and specify a material.

- To assign a solid extrusion to a subcategory, under Identity Data, for Subcategory, select a subcategory.

- Click Apply.

4 Click Modify | Create Extrusion tab ➤ Mode panel ➤ (Finish Edit Mode).

Revit Structure completes the extrusion and returns you to the view in which you started the extrusion.

5 To view the extrusion, open a 3D view.

6 To resize the extrusion in the 3D view, select it and use grips to edit it.

**Editing an Extrusion**

For information about using extrusions in families, see The Families Guide on page 680. You can modify an extrusion after creating it.

**To edit an extrusion**

1 In the drawing area, select the extrusion.

2 If you are in the project environment:

   a Click Modify | <Element> tab ➤ Mode panel ➤ (Edit Family).

   b In the Family Editor, select the extrusion in the drawing area again.

3 Click Modify | Extrusion tab ➤ Mode panel ➤ (Edit Extrusion).

4 If desired, modify the extrusion profile.

5 On the Properties palette on page 34, change the visibility, material, or subcategory of the extrusion, if desired.

6 To change the extrusion to a solid or a void, under Identity Data, for Solid/Void, select Solid or Void.

7 Click Apply.

8 Click Modify | Edit Extrusion tab ➤ Mode panel ➤ (Finish Edit Mode).
Extrusion Tips

- The work plane does not have to be either the start or the end of the extrusion depth. It is only used to sketch on and set the extrusion direction to be perpendicular to the plane.

- You can set the depth of the geometry before sketching it. In sketch mode, enter a value in the Depth text box on the Options Bar. This value changes the end point of the extrusion. Depths can be negative values.

- You can modify the depth of the extrusion after creating it by selecting it and on the Properties palette, specify values for the start and end points. You can also resize the extrusion in a 3D view by selecting it and then dragging it to resize it.

- If specified, Revit Structure does not retain the end point value during creation of the extrusion. If you need to make multiple extrusions with the same end point, first sketch the extrusions, then select them, and then apply the end point.

Creating a Blend

For information about using blends in families, see The Families Guide on page 680.

The Blend tool blends 2 profiles (boundaries) together. For example, if you sketch a large rectangle and a smaller rectangle on top of it, Revit Structure blends the 2 shapes together.

Sample base and top boundaries for a blend.

Finished blend
NOTE If you want to dimension a solid blend after you create it, you can dimension from lines at the top of the blend to lines at the base of the blend. You cannot dimension from lines at the base of the blend to lines at the top of the blend.

To create a solid or void blend

1 In the Family Editor, on the Home tab ➤ Forms panel, do one of the following:
   - Click Blend.
   - Click Void Forms drop-down ➤ (Void Blend).

   NOTE If necessary, set the work plane before you sketch the blend. Click Home tab ➤ Work Plane panel ➤ (Set).

2 On the Modify | Create Blend Base Boundary tab, use the Draw tools to sketch the base boundary of the blend, for example sketch a square.

3 To specify the depth of the blend, on the Properties palette on page 34, do either of the following:
   - To specify a depth that is calculated from a default start point of 0, under Constraints, for Second End, enter a value.
   - To specify a depth that is calculated from a start point other than 0, under Constraints, enter Second End and First End values.

   NOTE If specified, Revit Structure does not retain the end point value during creation of the blend. If you need to make multiple blends with the same end point, first sketch the blends, then select them, and then apply the end point.

4 When finished with the base boundary, on the Modify | Create Blend Base Boundary tab ➤ Mode panel, click (Edit Top).

5 On the Modify | Create Blend Top Boundary tab, sketch a boundary for the top of the blend, for example another square.

6 If necessary, edit the vertex connections to control the amount of twist in the blend:
   - On the Modify | Create Blend Top Boundary tab, click Mode panel ➤ (Edit Vertices).
   - Vertex points become available on one of the blend sketches.

   The dotted lines with blue open-dot controls are suggested connections. Each control is a switch between adding and removing connections.
To display the vertex points on the other blend sketch, on the Edit Vertices tab ➤ Vertex Connect panel, click ➤ (Controls on Base) or ➤ (Controls on Top) - whichever option is currently unselected.

Click a control, and the line becomes a solid connection. A filled blue control displays on the connection.

Click a solid control to remove a connection; the line reverts to a dashed line with an open dot control.

As you click the controls, some possible edges disappear and other ones appear.

On the Vertex Connect panel, click ➤ (Twist Right) or ➤ (Twist Left) to twist the selected blend boundary in a clockwise or counter-clockwise direction.

7 On the Properties palette on page 34, specify the blend properties:

To set the visibility of a solid blend, under Graphics, for Visibility/Graphics Overrides, click Edit, and specify the visibility settings.

To apply a material to a solid blend by category, under Materials and Finishes, click in the Material field, click ➤ , and specify a material.

To assign a solid blend to a subcategory, under Identity Data, for Subcategory, select a subcategory.

Click Apply.

8 Click Modify | Create Blend Top Boundary ➤ Mode panel ➤ (Finish Edit Mode).
9 To view the blend, open a 3D view.
10 To resize the blend in the 3D view, select and use grips to edit it.

Editing a Blend

For information about using blends in families, see The Families Guide on page 680.

1 In the drawing area, select the blend.
2 If you are in the project environment:

   a On the Modify | <Element> tab ➤ Mode panel, click ➤ (Edit Family).
   b In the Family Editor, select the blend in the drawing area again.
3 On the Options Bar, enter a value in the Depth text box to change depth of the blend.
4 On the Modify | Blend tab ➤ Edit Blend panel, select an editing option:
   ■ Click (Edit Top) to edit the top boundary of the blend.
   ■ Click (Edit Base) to edit the base boundary of the blend.
5 On the Properties palette on page 34, change the visibility, material, or subcategory of the blend, as desired.
6 To change the blend to a solid or a void, under Identity Data, for Solid/Void, select Solid or Void.
7 Click Apply.
8 On the Modify | Edit Blend Top Boundary tab or Edit Blend Base Boundary tab, click Mode panel ➤ (Edit Vertices), and edit the blend vertices.
9 On the Mode panel, click ✓ (Finish Edit Mode).

Creating a Revolve

For information about using revolves in families, see The Families Guide on page 680.

A revolve is a form that you create by revolving a shape around an axis. You can revolve the shape in a circle or any fraction of a circle. If the axis touches the revolve shape, the result is a solid.

If you sketch away from the axis, the resulting geometry has a hole in it.

Use solid revolves to create family geometry like door and furniture knobs, columns, and dome roofs.

The following procedure is a general method for creating revolved geometry. Steps may vary depending on your design intent.

To create a solid or void revolve

1 In the Family Editor, on the Home tab ➤ Forms panel, do one of the following:
   ■ Click (Revolve).
   ■ Click Void Forms drop-down ➤ (Void Revolve).

   **NOTE** If necessary, set the work plane before you sketch the revolve. Click Home tab ➤ Work Plane panel ➤ (Set).

2 Place an axis of revolution:
   ■ On the Modify | Create Revolve tab ➤ Draw panel, click (Axis Line).
   ■ Specify the start and endpoint of the axis at the desired orientation.

3 Use the Draw tools to sketch a shape to revolve around the axis:
   ■ Click Modify | Create Revolve tab ➤ Draw panel ➤ (Boundary Line).
   ■ To create a single revolve, sketch a closed loop.
   ■ To create more than one revolve, sketch multiple, non-intersecting, closed loops.
IMPORTANT  If the axis touches the revolve shape, the result is a solid. If the axis does not touch the revolve shape, the revolve will have a hole in it.

4 On the Properties palette on page 34, change the properties of the revolve:
   ■ To change the start and end points of the geometry to revolve, enter a new Start and End Angle.
   ■ To set the visibility of a solid revolve, under Graphics, for Visibility/Graphics Overrides, click Edit.
   ■ To apply a material to a solid revolve by category, under Materials and Finishes, click in the Material field, and click to specify a material.
   ■ To assign a solid revolve to a subcategory, under Identity Data, for Subcategory, select a subcategory.
   ■ Click Apply.

5 On the Mode panel, click (Finish Edit Mode).

6 To view the revolve, open a 3D view.

7 To resize the revolve in the 3D view, select and use grips to edit it.

NOTE  You cannot drag the start and end faces of a 360-degree revolve.

Editing a Revolve

For information about using revolutions in families, see The Families Guide on page 680.

1 In the drawing area, select the revolve.

2 If you are in the project environment:
   a On the Modify | <Element> tab ➤ Mode panel, click (Edit Family).
   b In the Family Editor, select the revolve in the drawing area again.

3 Click Modify | Revolve tab ➤ Mode panel ➤ (Edit Revolve).

4 If desired, modify the revolve sketch.

5 To edit other revolve properties, on the Properties palette on page 34, change the start and end angle values, visibility, material, or subcategory.

6 To change the revolve to a solid or a void, under Identity Data, for Solid/Void, select Solid or Void.

7 Click Apply.

8 On the Mode panel, click (Finish Edit Mode).

Creating a Sweep

For information about using sweeps in families, see The Families Guide on page 680.

A sweep is a tool for creating families that requires you to sketch or apply a profile (shape) and extrude that profile along a path.
The following procedure is a general method for creating a sweep. Steps may vary depending on your design intent.

**To create a solid or void sweep**

1. In the Family Editor, on the Home tab ➤ Forms panel, do one of the following.
   - To create a solid sweep, click ➤ (Sweep).
   - To create a void sweep, click Void Forms drop-down ➤ (Void Sweep).

   **NOTE** If necessary, set the work plane before you sketch the sweep. Click Home tab ➤ Work Plane panel ➤ (Set).

2. Specify the sweep path:
   - To sketch a new path for the sweep, click Modify | Sweep tab ➤ Sweep panel ➤ (Sketch Path).
     The path can either be a single closed or single open path. You cannot have multiple paths. The path can be a combination of straight lines and curves, and it need not be planar.
   - To select an existing line for the sweep, click Modify | Sweep tab ➤ Sweep panel ➤ (Pick Path).
     To select edges of other solid geometry, such as extrusions or blends, click Pick 3D Edges on the ribbon. Or pick existing sketch lines, watching the status bar to know what you are picking. This method of picking automatically locks the sketch lines to the geometry you are picking and allows you to sketch the path in multiple work planes, hence allowing for a 3D path.

3. On the Mode panel, click (Finish Edit Mode).

4. Load or sketch a profile:
   - To load a profile:
     a. Click Modify | Sweep tab ➤ Sweep panel, and select a profile from the Profile list. If the profile you need is not already loaded in the project, click Modify | Sweep tab ➤ Sweep panel ➤ (Load Profile) to load the profile.
     b. On the Options Bar, use the X, Y, Angle, and Flip options to adjust the position of the profile. Enter values for X and Y to specify the offset for the profile. Enter a value for Angle to specify the angle of the profile. The angle rotates the profile around the profile origin. You can enter negative values to rotate in the opposite direction. Click Flip to flip the profile.
     c. Click Apply.
     d. Select the path, and in a 3D view, zoom in to see the profile.
   - To sketch a profile:
     a. Click Modify | Sweep tab ➤ Sweep panel, verify <By Sketch> is displayed, and then click (Edit Profile).
If the Go To View dialog displays, select the view where you want to sketch the profile, and click OK. For example, if you sketched the path in a plan view, you would choose an elevation view to sketch the profile. The profile sketch can be a single-closed loop or multiple closed loops that do not intersect. Sketch the profile near the intersection of the profile plane and the path.

Sketch the profile. Profiles must be closed loops.

Click Modify | Sweep ➤ Mode ➤ (Finish Edit Mode).

On the Properties palette on page 34, specify the sweep properties:

- To set the visibility of a solid sweep, under Graphics, for Visibility/Graphics Overrides, click Edit, and specify the visibility settings.
- To apply a material to a solid sweep by category, under Materials and Finishes, click in the Material field, click , and specify a material.
- To assign a solid sweep to a subcategory, under Identity Data, for Subcategory, select a subcategory.
- Click Apply.

On the Mode panel, click (Finish Edit Mode).

Creating a Segmented Sweep

For information about using sweeps in families, see The Families Guide on page 680.

You create a segmented sweep by setting 2 sweep parameters and sketching a path with arcs. The parameters affect only arcs in the path. The minimum number of segments for a sweep is 2.

1 In the Family Editor, begin creating a sweep.
2 On the Properties palette on page 34, under Other, select the check box for Trajectory Segmentation.
3 Enter a value for Maximum Segment Angle. Valid values are between 0 and 360 degrees.
4 Sketch or pick a path with arcs.
5 On the Mode panel, click (Finish Edit Mode) to complete the path.
6 Create a profile or use a pre-loaded profile.
7 On the Mode panel, click (Finish Edit Mode) to complete the sketch of the sweep.
Sample segmented sweep with 30 degree Maximum Segment Angle.

TIP You can change a segmented sweep to a non-segmented sweep by clearing the check box for Trajectory Segmentation.

## Editing a Sweep

For information about using sweeps in families, see The Families Guide on page 680.

1 In the drawing area, select the sweep.

2 If you are in the project environment:
   a On the Modify | <Element> tab ➤ Mode panel, click (Edit Family).
   b In the Family Editor, select the sweep in the drawing area.

3 On the Modify | Sweep tab ➤ Mode panel, click (Edit Sweep).

4 To modify the sweep path:
   ■ On the Modify | Sweep tab ➤ Sweep panel, click (Sketch Path).
   ■ Use the tools on the Modify | Sweep > Sketch Path tab to modify the path.
   ■ On the Mode panel, click (Finish Edit Mode).

5 To modify the sweep profile:
   ■ On the Modify | Sweep tab ➤ Sweep panel, click (Select Profile).
   ■ On the Sweep panel, use the tools that display to select a new sweep profile or change the sweep profile location.
   ■ To edit the existing profile, on the Sweep panel, click (Edit Profile), and use the tools on the Modify | Sweep > Edit Profile tab.
   ■ On the Mode panel, click (Finish Edit Mode) to finish editing the profile and again to finish editing the sweep.

6 To edit other sweep properties, select the sweep, and on the Properties palette on page 34, change the visibility, material, segmentation, or subcategory of the sweep, as desired.
To change the sweep to a solid or a void, under Identity Data, for Solid/Void, select Solid or Void.

Click Apply.

Sweep Tips

When creating a sweep with a tangent arc in the path, be sure the profile is small enough to sweep around the arc without the resulting geometry intersecting itself. An error occurs if the geometry intersects.

If you create a sweep path by using the Pick Path tool, you can drag the end points of the path lines as you are sketching it.

Creating a Swept Blend

For information about using swept blends in families, see The Families Guide on page 680.

The Swept Blend tool allows you to create a blend that has 2 different profiles and then sweep it along a path. The shape of a swept blend is determined by the 2D path you either sketch or pick and the 2 profiles you either sketch or load.

The following procedure is a general method for creating a swept blend. Steps may vary depending on your design intent.
To create a solid or void swept blend

1. In the Family Editor, on the Home tab ➤ Forms panel, do one of the following:
   - To create a solid swept blend, click ➤  (Swept Blend).
   - To create a void swept blend, click Void Forms drop-down ➤  (Void Swept Blend).

2. Specify the path for the swept blend.
   
   **NOTE** If necessary, set the work plane before you sketch or pick the path for the swept blend. Click Home tab ➤ Work Plane panel ➤  (Set).

   Do one of the following on the Modify | Swept Blend tab ➤ Swept Blend panel:
   - Click ➤  (Sketch Path) to sketch a path for the swept blend.
   - Click ➤  (Pick Path) to pick existing lines and edges for the swept blend.

3. Sketch or pick the path.
   
   To select edges of other solid geometry, such as extrusions or blends, click Pick Path. Or pick existing sketch lines, watching the status bar to know what you are picking. This method of picking automatically locks the sketch lines to the geometry you are picking and allows you to sketch the path in multiple work planes, hence allowing for a 3D path.
   
   **NOTE** A swept blend path can only have one segment.

4. On the Mode panel, click ➤  (Finish Edit Mode)

5. Load or sketch Profile 1.
   
   The end point for Profile 1 on the swept blend path is highlighted.
   
   To load a profile:
   - Click Modify | Swept Blend tab ➤ Swept Blend panel, and select a profile from the Profile drop-down.
     If the profile you need is not already loaded in the project, click ➤  (Load Profile) to load the profile.
   - Zoom in to see the profile.
c Use the X, Y, Angle, and Flip options to adjust the position of the profile. Enter values for X and Y to specify the offset for the profile. Enter a value for Angle to specify the angle of the profile. The angle rotates the profile around the profile origin. You can enter negative values to rotate in the opposite direction. Click Flip to flip the profile.

d Click Apply.

To sketch a profile:

a On the Swept Blend panel, verify that <By Sketch> is selected and click (Edit Profile).

b If the Go To View dialog displays, select the view where you want to sketch the profile, and click OK.

c Use the tools on the Modify | Swept Blend > Edit Profile tab to sketch the profile. Profiles must be closed loops.

d On the Mode panel, click (Finish Edit Mode).

6 Click Modify | Swept Blend tab ➤ Swept Blend panel ➤ (Select Profile 2).

7 Load or sketch Profile 2 using the steps above.

8 Optionally, edit the vertex connections. By editing vertex connections, you control the amount of twist in the swept blend. You can edit vertex connections in plan or 3D views.

a On the Modify | Swept Blend tab ➤ Swept Blend panel, click (Edit Vertices).

b On the Edit Vertices tab ➤ Vertex Connect panel, select (Controls on Base) or (Controls on Top).

c In the drawing area, click the blue controls to move the vertex connections.

d On the Vertex Connect panel, click the (Twist Right) and (Twist Left) tools to twist the swept blend.

9 When finished, click Mode panel ➤ (Finish Edit Mode).

10 On the Properties palette on page 34, specify the swept blend properties:

■ To set the visibility of a solid swept blend, under Graphics, for Visibility/Graphics Overrides, click Edit, and specify the visibility settings.
To apply a material to a solid swept blend, under Materials and Finishes, click in the Material field, click , and specify a material.

To assign a solid swept blend to a subcategory, under Identity Data, for Subcategory, select a subcategory.

Click Apply.

Editing a Swept Blend

For information about using swept blends in families, see The Families Guide on page 680.

1 In the drawing area, select the swept blend.

2 If you are in the project environment:
   a On the Modify | <Element> tab ➤ Mode panel, click (Edit Family).
   b In the Family Editor, select the swept blend in the drawing area.

3 On the Modify | Swept Blend tab ➤ Mode panel, click (Edit Swept Blend).

4 To edit the path:
   a On the Modify | Swept Blend tab ➤ Swept Blend panel, click (Sketch Path).
   b Use the tools on the Modify | Swept Blend > Sketch Path tab to modify the path, and click Mode panel ➤ (Finish Edit Mode).

5 To edit the profiles:
   a On the Modify | Swept Blend tab ➤ Swept Blend panel, click (Select Profile 1) or (Select Profile 2).
   b On the Swept Blend panel, select a different loaded profile from the drop-down list, or select <By Sketch> from the list to sketch a new profile.
   c If you selected <By Sketch>, click (Edit Profile) on the Swept Blend panel.
   d Sketch the profile and then click Mode panel ➤ (Finish Edit Mode) to finish editing the profile.
   e Click Mode panel ➤ (Finish Edit Mode) to finish editing the sweep.

6 On the Properties palette on page 34, change the visibility, material, or subcategory of the sweep, as desired.

7 To change the swept blend to a solid or a void, under Identity Data, for Solid/Void, select Solid or Void.

8 Click Apply.
Cut Geometry

With the Cut Geometry tool, you can pick and choose which geometry gets cut and which does not, regardless of when you created the geometry.

1 In the Family Editor, create solid geometry; it can be a single primitive or some joined primitives.

2 Create a void through the solid geometry.

3 Create another solid geometry shape and join it to the existing geometry.

4 Click Modify tab ➤ Geometry panel ➤ Cut drop-down ➤ (Cut Geometry) and select the void you created.
   Notice the cursor changes shape.
5 Select the geometry you created in Step 3.

Revit Structure cuts the selected geometry.

**UnCut Geometry**

1 In the Family Editor, click Modify tab ➤ Geometry panel ➤ Cut drop-down ➤ (Uncut Geometry).
2 Select the void.
3 Select the appropriate solid primitives that you do not want to cut.

**NOTE** If you select all geometry to not be cut, then the void appears at all times in the view.
Creating 2D Geometry

To create 2D family geometry, you use the Revit Structure Model and Symbolic lines tools that are available in the Family Editor.

The Model Line tool on the Home tab ➤ Model panel lets you sketch two-dimensional geometry for when you do not need to show solid geometry. For example, you could sketch door panels and hardware as 2D rather than sketch solid extrusions. Model lines are always visible in 3D views. You can control their visibility in plan and elevation views by selecting the lines and clicking Modify ➤ Lines tab ➤ Visibility panel ➤ (Visibility Settings).

The Symbolic Line tool on the Annotate tab ➤ Detail panel lets you sketch lines that are meant for symbolic purposes only. Symbolic lines are not part of the actual geometry of the family. Symbolic lines are visible parallel to the view in which you sketch them.

You can control symbolic line visibility on cut instances. Select the symbolic line and click Modify ➤ Lines tab ➤ Visibility panel ➤ (Visibility Settings). Select Show only if instance is cut.

In the displayed dialog, you can also control the visibility of lines based on the detail level of the view. For example, if you select Coarse, that means that when you load the family into a project and place it in a view at the Coarse detail level, the symbolic lines are visible.

Adding a Reference Line

In the Family Editor, you can add a reference line in any view and use the same drawing tools and techniques used when adding model lines. When you sketch a reference line, it displays as a single line.

In a view where the visual style is set to hidden line or wireframe, the sketched line displays as a solid line and the plane extents display with dashed lines.

To add a reference line

1. In the Family Editor, click Home tab ➤ Datum panel ➤ (Reference Line).
2. Using the drawing tools, sketch the line.

The line displays as a solitary solid line until selected or when highlighted during preselection.

Example of reference lines sketched as a polygon

When selected or highlighted, the associated planes display according to the active view.
To use reference lines and linear dimensions to control model geometry

3 Align the face of a model element to the reference line and lock it.
4 Add a dimension line referring to the reference line and label it as an instance or type parameter.
5 Flex the model by changing and applying a new value within the Family Types dialog.

Troubleshooting Sketching Issues

Read the following topics to learn about issues with sketches.

Element Is Slightly Off Axis

**Warning:** Element is slightly off axis and may cause inaccuracies.

**Issue:** This warning is triggered by elements based on lines that are misaligned — by 1x(10^-9) to .2 degrees — in either the horizontal or vertical directions, or with a line at 45 degrees to the horizontal/vertical direction.

The problem can be caused by sketching or rotating elements when angle snaps are turned off, or it can result from pre-existing elements when you do any of the following:

- Create an element by picking a slightly off-axis face or line.
- Align an element to a slightly off-axis reference.
- Explode an AutoCAD import that contains slightly off-axis lines.
- Create floor area faces on a mass that has slightly off-axis geometry.
- Snap defining line ends to references that are slightly off-axis (such as imported drawings or 2 columns that are not properly aligned).
- Snap defining line ends to references that are positioned correctly in their respective contexts but the line between them is slightly off-axis (such as snapping to 2 different ceiling grids).

Off-axis problems need to be resolved, because Revit Structure cannot create dimensions between lines that are not exactly parallel, and cannot join or cut geometry if faces are slightly off-parallel or have very small gaps due to off-axis elements.
Solution: Depending on the cause of the problem, do one of the following:

- Drag the end of the off-axis element a short distance and let it snap to the axis.
- Repeat the rotation operation with angle snaps turned on.
- If the inaccuracy is derived from pre-existing elements, correct them and repeat the operation.
- If the problem is caused by imported data, consider correcting it in the original software and re-importing it into Revit Architecture.

Ceiling Sketch Is Invalid

Warning: Ceiling sketch is invalid.

Issue: Revit Structure failed to regenerate the ceiling geometry upon executing your last action.

Solution: You cannot ignore this warning. You must cancel the action. This error might occur if you have sketched an opening in a ceiling, and then locked that opening to another element, such as a wall. If you move the wall, the opening moves with it. If the opening should suddenly lose its host (the ceiling), this error would display. You can edit the ceiling sketch and then attempt the action again.

Floor Sketch Is Invalid

Warning: Floor sketch is invalid.

Issue: Revit Structure failed to regenerate the floor geometry upon executing your last action.

Solution: You cannot ignore this warning. You must cancel the action. This error might occur if you have sketched an opening in a floor, and then locked that opening to another element, such as a wall. If you move the wall, the opening moves with it. If the opening should suddenly lose its host (the floor), this error would display. You can edit the floor sketch and then attempt the action again.

Dimension Cannot Be Made Constraining

Warning: The dimension cannot be made constraining.

Issue: While creating a family, you have tried to make a reference dimension constraining.

Solution: You cannot turn a reference dimension into a constraint.

Element Is Too Small on Screen

Warning: Element is too small on screen.

Issue: Revit Structure prevents you from accidentally drawing the element, typically a wall, reference plane, or line, if it is less than 1mm on the screen.

Solution: If you intend to make the element that small, zoom in the view.
Editing Elements

This topic describes the tools and techniques that you can use to edit elements in the drawing area.

Selecting Elements

Many of the controls and tools that you use to modify an element in the drawing area are only available when an element is selected.

To help you identify elements and mark them for selection, Revit Structure includes an automatic highlighting feature. When you move the cursor onto or near an element in the drawing area, the outline of the element is highlighted. (It displays in a heavier line weight.) A description of the element displays on the status bar at the bottom of the Revit window. After a brief delay, the element description also displays within a tool tip just below the cursor.

Wall element before and after highlighting

When an element is highlighted, click to select it. When an element is selected in one view, the selection applies to all other views as well.

**Tip** If you have difficulty highlighting a particular element because other elements are in close proximity, press Tab to cycle through the elements until the desired element is highlighted. The status bar identifies the currently highlighted element. Press Shift+Tab to cycle through elements in reverse order.

When you select an element:

- The element is outlined in the color specified in options.
- Any element-specific editing controls and dimensions display on or adjacent to the element.
- Applicable editing tools are available on the Modify | <Element> tab.
- The selection count on the status bar ( ) displays the number of elements selected. (See How Many Elements Are Selected? on page 1441)
### Basics for Selecting Elements

Use the following techniques to select elements in the drawing area.

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then do this…</th>
</tr>
</thead>
<tbody>
<tr>
<td>locate the desired element to select</td>
<td>move the cursor over the element in the drawing area. Revit Structure highlights the element and displays information about it in the status bar and in a tooltip. If several elements are very close to or on top of one another, move the cursor over that area and press <em>Tab</em> until the status bar describes the desired element. Press <em>Shift-Tab</em> to cycle through elements in reverse order.</td>
</tr>
<tr>
<td>select an element</td>
<td>click the element.</td>
</tr>
<tr>
<td>select multiple elements</td>
<td><em>Ctrl</em>+ click each element. For more ways to select multiple elements, see Selecting Multiple Elements on page 1440.</td>
</tr>
<tr>
<td>determine how many elements are currently selected</td>
<td>check the selection count on the status bar (14). See How Many Elements Are Selected? on page 1441</td>
</tr>
<tr>
<td>select all elements of a particular type</td>
<td>select one element of the desired type, and type <em>SA</em> (for Select All Instances). For more ways to select all instances, see Selecting All Instances on page 1441.</td>
</tr>
<tr>
<td>select all elements of a certain category (or categories)</td>
<td>draw a pick box around the elements, and click Modify</td>
</tr>
<tr>
<td>deselect an element</td>
<td><em>Shift</em>-click each element to deselect that element from a group of selected elements.</td>
</tr>
<tr>
<td>re-select the previously selected elements</td>
<td>press <em>Ctrl</em>-left arrow.</td>
</tr>
</tbody>
</table>

### Selecting Multiple Elements

To select more than one element, use one of the following methods:

- While pressing *Ctrl*, click each of the elements.

**NOTE** If you are selecting multiple elements and need to use the *Tab* key to select an element in close proximity to others, do not hold the *Ctrl* key while pressing *Tab*. 
Draw a selection box by placing the cursor on one side of the elements to be selected and dragging it diagonally to form a rectangular boundary.

To select only elements that are completely within the boundary of the selection box, drag the cursor from left to right.

To select any elements that are wholly or partially within the boundary of the selection box, drag the cursor from right to left.

Press Tab to highlight connected elements, and then click to select. See Selecting Chains of Walls and Lines on page 1442.

Use the Select All Instances tool to select all instances of an element or family type in your project or view. See Selecting All Instances on page 1441.

NOTE If you are editing a design option, the tool name is Select All Instances in Active Option. It selects all elements of that type in the active option only.

Selecting All Instances

You can select all of the elements that are similar to the selected element in the current view, or throughout the project. After they’re selected, all elements can be modified simultaneously. You can:

- Change properties
- Swap types
- Delete or modify only the families that are in the current view.

To select all instances

1 Right-click an element in any view, or a Family type in the Project Browser.
2 Click Select All Instances, and then click Visible in View or In Entire Project.

NOTE While using Design Options on page 653, the Select All Instances command displays as Select All Instances in Active Option, and the Visible in View/In Entire Project commands only select the elements in the current design option.

All instances are selected, and can be modified.

How Many Elements Are Selected?

When you select multiple elements, it can be difficult to determine whether you have selected the intended elements. To verify this and make any needed adjustments, do the following:

- Check the selection count on the status bar.

  Revit Structure indicates the total number of selected elements using: 🃽:4

- Click the selection count to display the Filter dialog.

  The Filter dialog lists the categories of the selected elements. It also indicates the number of selected elements in each category, and the total number of selected elements. You can clear check boxes to deselect categories of elements. See Selecting Elements Using a Filter on page 1442.
Selecting Elements Using a Filter

When a selection includes elements of different categories, you can use a filter to remove unwanted categories from the selection. For example, if the selection includes walls, doors, windows, and furniture, you can use a filter to omit the furniture from the selection.

To select elements using a filter

1. Define a selection box around the elements to select. Place the cursor on one side of the elements and drag it diagonally to form a rectangular boundary.
   
   To select only elements that are completely within the boundary of the box, drag the cursor from left to right. To select any elements that are wholly or partially within the boundary of the box, drag the cursor from right to left.

2. Click Modify | Multi-Select tab ➤ Filter panel ➤ (Filter).
   
   The Filter dialog lists all categories of the elements that are currently selected. The Count column indicates the number of selected elements in each category. The total number of elements currently selected displays at the bottom of the dialog.

3. Specify the categories of elements to include in the selection:
   - To exclude all elements in a category, clear its check box.
   - To include all elements in a category, select its check box.
   - To select all categories, click Check All.
   - To clear all categories, click Check None.
   
   As you modify selections, the totals update in the dialog and on the status bar.

4. Click OK.

Selecting Chains of Walls and Lines

If multiple elements (such as walls and/or lines) are joined in a continuous chain, you can select the entire chain. The chain can include different types of elements.

To select a chain of walls or lines

1. Highlight any one of the elements in the chain.

2. Press Tab.

   Revit Structure highlights all elements in the chain.

3. Click to select the entire chain.

Valid chains for selection:

Four walls joined
Four area separation lines joined

Walls and area separation lines joined

If multiple walls are joined at the same point, the chain continues along the wall that makes the smallest angle with the one currently highlighted. Walls joined at mid-end faces can also be included in a chain selection. See Joining Walls to Mid-End Faces on page 461.

As shown in the following illustration of a selected chain of walls, drag controls display at the coincident endpoints. You can drag these controls to new locations without unjoining the endpoints. See Modifying a Selected Chain on page 1444.

A selected chain of walls with drag controls

**Selecting Part of a Chain**

If multiple elements (such as walls and/or lines) are joined in a continuous chain, you can select part of the chain.

**To select part of a chain**

1. Select the first desired element in the chain.
2. Move the cursor to highlight the last desired element in the chain.
3. Press Tab.
Revit Structure highlights all elements in the partial chain between the first and last elements that you selected. (Press Tab again to highlight the entire chain. Press it a third time to highlight only the last desired element in the chain.)

4 Click to select the part of the chain that is highlighted.

If the chain is a closed loop, the elements to be highlighted for partial chain selection are determined by the cursor position when you highlight the last desired element. As shown in the following wall layout, if you position the cursor near the left endpoint of the upper-right wall, the partial chain includes the walls along the top of the layout. If you place the cursor on the right side of that wall, the walls on both sides and along the bottom are included in the partial chain.

Modifying a Selected Chain

When a chain of walls or lines is selected, you can use the drag controls that display at the coincident endpoints to perform any of the following edits without unjoining elements in the chain:

- To change the layout of the chain, drag a control to a new location.
Editing a selected chain of walls.

- To move the entire chain (preserving its layout), while pressing `Shift`, drag the chain vertically or horizontally to a new location.

**NOTE** If the movement is constrained, you can release `Shift` and then move the chain.

Dragging a wall chain to a new location

- To create and place a copy of the chain, while pressing `Ctrl`, drag the chain to the desired location.
Selecting Walls or Lines Joined at a Point

When multiple walls or lines are joined at a common point, you can use TAB to select multiple elements, as follows:

- Place the cursor on or near one wall or line, and click to select it.

- Press Tab. Revit Structure highlights the second wall or line that is closest to the cursor. For example, in the following example, the cursor is positioned on the right side of the lower wall. If you want to select these 2 walls or lines, click to select them.
Press Tab again to highlight all of the connected walls or lines. Then click to select them.

Selecting Multiple Curtain Elements

You can select multiple curtain elements on large curtain hosts using selection tools on the shortcut menu. Curtain hosts include curtain walls, sloped glazing, and curtain systems created by face.

When selecting multiple elements in a curtain wall, use the status bar and the Filter dialog to ensure that you have selected the intended elements. See Selecting Elements Using a Filter on page 1442.

Selecting Panels

You can select curtain panels in multiple ways.

To select all panels on a curtain host element, right-click the host element, and click Select Panels on Host. You can then select an individual panel, right-click, and click Select Panels to access the following options for selecting multiple panels:

- Panels along Vertical Grid (available for curtain walls only)
- Panels along Horizontal Grid (available for curtain walls only)
- Panels along Grid 1
- Panels along Grid 2
- Panels on Face (available for curtain systems created by face only)
Panels on Host

Selecting Mullions
The shortcut menu options for selecting multiple mullions vary depending on whether you access them from the curtain host element or a selected mullion.

If you right-click a curtain wall and click Select Mullions, the following options are available:

- **On Vertical Grid.** Selects all interior mullions on vertical grids.
- **On Horizontal Grid.** Selects all interior mullions on horizontal grids.
- **Inner Mullions.** Selects all interior mullions on the same face as the selected mullion.
- **Border Mullions.** Selects all border mullions on the same face as the selected mullion.
- **Mullions on Host.** Selects all mullions on the host.

If you right-click a curtain system or sloped glazings and click Select Mullions, the following options are available:

- **On Grid 1.** Selects all interior mullions that lie on the grid 1 layout. For more information on grid layouts, see Type-Driven Curtain Element Layout on page 648.
- **On Grid 2.** Selects all interior mullions that lie on the grid 2 layout.
- **Inner Mullions.** Selects all interior mullions on the same face as the selected mullion.
- **Border Mullions.** Selects all border mullions on the same face as the selected mullion.
- **Mullions on Host.** Selects all mullions on the host.

If you right-click an individual mullion and click Select Mullions, the following options are available:

- **On Gridline.** Selects all mullions that lie on the same gridline as the selected mullion.
- **Across Gridline.** Selects all interior mullions that lie on gridlines opposite the gridline on which the selected mullion lies.
- **On Vertical Grid.** Selects all vertical mullions.
- **On Horizontal Grid.** Selects all horizontal mullions.
- **Inner Mullions.** Selects all interior mullions on the same face as the selected mullion.
- **Border Mullions.** Selects all border mullions on the same face as the selected mullion.
- **Mullions on Host.** Selects all mullions on the host.

Restoring a Selection

To restore a selection (of one or more elements) that you have cleared, while pressing Ctrl, press the Left Arrow on the keyboard. Alternatively, you can right-click anywhere in the drawing area, and click Select Previous.

You can only restore a selection while Modify is active. If you switch to a different tool, the selection is cleared.
Removing Elements from a Selection

To deselect an element, while pressing *Shift*, click the element. Other selected elements remain selected. The selection count on the status bar ( ) updates to display the new number of selected items. (See How Many Elements Are Selected? on page 1441)

Controls and Shape Handles

When you select an element, various controls and handles appear on or near the element. Use these controls to move the element or modify its size or shape. The types of controls that are available depend on the type of element selected and the type of view.

When a control has multiple functions, move the cursor over the control and press *Tab* to toggle between the functions. For example, press *Tab* to display shape handles for most basic wall types when they are highlighted in elevation or 3D views. In plan views, however, this only works for curtain walls. To display shape handles for a basic wall in plan view, select the wall first, and then press *Tab*.

Related topic
- Snaps on page 1614

Drag Controls

Drag controls display at the ends of selected elements in plan views. They also display along the ends, bottoms, and tops of selected elements in elevation and 3D views, where they are labeled as shape handles. Drag these controls to resize an element.

When a chain of walls or lines is selected, drag controls display at the coincident endpoints. Drag the controls to change the layout of the chain. See Selecting Chains of Walls and Lines on page 1442.

Revit Structure uses the following types of drag controls:

- Dots ( ) display when movement is constrained to a plane, as with walls and lines in plan views. Drag a dot control to lengthen, shorten, or change the orientation of the element.

  Drag controls (shown in blue) on a wall in plan

- Single arrows ( ) display as shape handles in elevation and 3D views when movement is constrained to a line, but the outside direction is unambiguous. For example, a massing shape with no dimension constraints displays with single arrows. Single arrow controls on a selected wall in 3D views can also be used to move the wall. Place the cursor over the control and press *Tab* to be able to move the wall without resizing it.
Drag controls on massing form

- Double arrows ( ) display when the shape handles are constrained to move along a line. For example, if you add a labeled dimension to a family and make it an instance parameter, it displays with a double arrow after you load it into a project and select it.

**TIP** You can right-click the wall end controls and use an option on the shortcut menu to allow or disallow wall joins.

### Flip Controls

Click a flip control (double arrows) to change the orientation of an element. For example, when you flip a compound wall, you reverse the order of its component layers. Doors with a swing have 2 flip controls: Flip the Instance Facing (which controls whether the door swings in or out) and Flip the Instance Hand (which controls whether the door swings right or left).

**TIP** You can also flip a selected element by pressing the *Spacebar*.

### Pushpin Controls

A pushpin is a user-placed control that provides a quick way to allow or prevent changes to an element’s position. After you place a pushpin, you cannot move the element until you unpin it (by clicking the pushpin control). When the element is unpinned, a red X displays on the control. After moving the element, you can click the control again to pin the element to its new position. For information on placing pushpin controls, see *Preventing Elements from Moving* on page 1484.
**Rotate Controls**

Use rotate controls to drag an element or text note to a desired degree of rotation around a central axis. If desired, drag the center of rotation symbol. The symbol snaps to points and lines of interest, such as walls and the intersections of walls and lines. You can also drag it onto open space.

See Rotating Elements on page 1481.
**Dimension Text Controls**

Dimension text controls are blue squares that display on selected dimension elements that you have added to a drawing. Drag a control to move dimension text away from the dimension line.

*NOTE* You may need to zoom in to see dimension text controls.

See *Dimension Witness Lines* on page 910.

**View Controls**

Double-click a view control to open a new view associated with an element. For example, when you double-click a view control for level lines, Revit Structure opens the appropriate floor plan level. When you double-click a view control with a section level, Revit Structure opens the appropriate section view.

**Spacebar**

Use the *Spacebar* to flip a selected element. You can select multiple elements and flip them all at the same time. Free standing families, such as furniture and columns, rotate 90 degrees each time you press the *Spacebar*. Some annotations can be flipped. For example spot slopes, baseline dimensions, and ordinate dimensions can be flipped.

The following general rules apply to using the *Spacebar* to flip multiple elements:

- When multiple walls are selected, pressing the *Spacebar* flips the orientation of them all.
- For elements such as doors, which can be flipped in 2 directions relative to their host, press the *Spacebar* multiple times to cycle through the possible positions.
- If elements constrained to flip in only one direction (such as windows) are selected with elements that can flip in multiple directions (such as doors), then all elements flip along the common direction.

Pressing the *Spacebar* does not work in the following cases:

- The selection contains any element that cannot be flipped.
- The selection includes elements that do not share a common flip direction.

For example, if you select a door and its host wall, you cannot use the *Spacebar* to flip the selection.
Shape Handles

When a wall is selected in a plan view, place the cursor over an end control (blue dot) and press Tab to display a shape handle. When a wall is highlighted in an elevation view or a 3D view, press Tab to display the entire edge (closest to the cursor) as a shape handle that you can drag to resize the wall. The edge functioning as a shape handle is blue (or the defined selection color) when you drag it. The edge remains selected for further resizing until you press Esc or click elsewhere in the drawing area.

NOTE You can change the selection color from blue (the default) to another color using Options. See Setting Options on page 1623.

Undoing, Redoing, or Canceling an Action

While working in Revit Structure, you can undo past actions, redo past actions, or cancel a current action.
Undoing an Action

Use the Undo tool to cancel the most recent action or a series of recent actions.

To undo a single action

➤ Click (Undo) on the Quick Access toolbar.
Revit Structure cancels the most recent action.

To undo multiple actions:

1 On the Quick Access toolbar, click the drop-down list adjacent to the Undo tool ( ).
2 Scroll down to find the action to cancel.
3 Select the action.
Revit Structure cancels all actions up to and including the selected action.

TIP You can also use the keyboard shortcut Ctrl+Z to undo actions one at a time.

Redoing an Action

The Redo tool reinstates all actions canceled by Undo. After reinstating the actions, the current tool continues.

For example, suppose that you place a door and then cancel the placement with Undo. You then choose to place a window. While the Window tool is active, you click Redo. Revit Structure reinserts the door and then continues the Window tool.

If the Redo tool is active and you execute an action, the Redo information is lost.

NOTE The Redo tool is available only after you use the Undo tool.

To redo a single action

1 Undo a Revit Structure action.

2 Click (Redo) on the Quick Access toolbar.
Revit Structure reinstates the action that you had previously canceled with Undo.

To redo multiple actions

1 Undo multiple Revit Structure actions.

2 On the Quick Access toolbar, click the drop-down list adjacent to the Redo tool ( ).
3 Scroll down to find the action to redo.
4 Select the action.
Revit Structure reinstates all actions up to and including the selected action.

TIP You can also use the keyboard shortcut Ctrl+Y to redo actions one at a time.
Canceling an Action

To exit an action that you have already started, do any of the following:

■ Press Esc twice.
■ Right-click, and click Cancel.
■ On the Select panel, click \( \text{_modify} \) (Modify).

Repeating Last Command

While working in Revit Structure, you can repeat the command that was last used, or select from a list of recently used commands.

To repeat commands, do any of the following

■ Right-click in the drawing, and click Repeat [Last Command].
■ Right-click in the drawing, and click Recent Commands ➤ <Command Name>. Recently used commands are options as shown here. A maximum of five recent commands display in the list.

NOTE The following are not available from the recent commands list: tool settings, in-canvas and view commands, modify, redo/undo, copy/cut/paste, finish/cancel, and some Options Bar commands

■ Press Enter to invoke the last-used command.
■ Assign a keyboard shortcut for Repeat Last Command.

Editing Elements in Groups

You can group elements in a project or family and then place that group many times in a project or family. Grouping elements is useful when you need to create entities that represent repeating layouts or are common to many building projects.

With each instance of a group that you place, there is associativity among them. For example, you create a group with a bed, walls, and window and then place multiple instances of the group in your project. If you modify a wall in one group, it changes for all instances of that group, simplifying the modification process.

You can create:

■ Model groups, which can contain model elements.
■ Detail groups, which can contain view-specific elements (such as text and filled regions).
■ Attached detail groups, which can contain view-specific elements that are associated with a specific model group.
A group cannot contain both model and view-specific elements. If you select both types of elements and then try to group them, Revit Structure creates a model group and places the detail elements into an attached detail group for that model group. The result is the same if you select both detail elements and a model group; Revit Structure creates an attached detail group of the detail elements for that model group.

**Restrictions on Grouping**

If elements cannot be copied together, they cannot be grouped together. See Copying Elements to the Clipboard on page 1492 for information on copy restrictions.

**Creating Groups**

You can create a group by selecting elements in a project view, or you can use the group editor. In the group editor, you can

- Add elements from the project view
- Place additional elements in the view, which are then automatically added to the group
- Remove elements
- Create attached detail groups (for model groups)
- View group properties

You can also create groups from linked Revit models, or you can duplicate and modify an existing group. See Converting Groups and Linked Revit Models on page 1465 and Duplicating Group Types on page 1458.

**NOTE** You cannot group dimensions, tags, or keynotes without also grouping the elements that they reference. You can group them in an attached detail group for the model group they reference.

**Creating a Group by Selecting Elements**

1. In a project view, select the desired elements or existing groups you want in the group.

2. Click Modify | Multi-Select tab ➤ Create panel ➤ (Create Group).

   **NOTE** If you have only selected one element type, the respective Modify | <Element> tab displays instead of the Multi-Select tab.

3. In the Create Group dialog, enter a name for the group.

   **NOTE** The name of this dialog will vary depending on the types of elements you selected.

4. If you want to open the group in the group editor, select Open in Group Editor.
   The group editor allows you to add or remove elements from a group, attach detail groups (for model groups), and view group properties.

5. Click OK.
Creating a Group Using the Group Editor

1 Click Home tab ➤ Model panel ➤ Model Group drop-down ➤ (Create Group).

Alternatively, you can click Annotate tab ➤ Detail panel ➤ Detail Group drop-down ➤ (Create Group).

2 In the Create Group dialog, enter a name for the group.

3 Select the type of group to create (model or detail), and click OK.

Revit Structure enters group edit mode. The background color of the drawing area changes when you are in group edit mode.

4 If there are elements in the project view that you want to add to the group, click Edit Group panel ➤ (Add), and then select the elements.

5 If you want to add elements to the group that do not already exist in the project view, select an element creation tool from the appropriate tab and place the new element. When you add an element to a view in group edit mode, it is automatically added to the group.

**NOTE** If you add a view-specific element to a model group (for example, a window tag), the view-specific element is placed in the project view and not in the model group.

6 When you are finished adding elements to the group, click Edit Group panel ➤ (Finish).

Related topics

- Editing Elements in Groups on page 1455
- Loading Groups on page 1458
- Placing Groups on page 1459
- Modifying Groups on page 1461

Creating an Attached Detail Group

1 In the drawing area, do one of the following:

- Select model elements and detail elements, simultaneously. Click Modify | Multi-Select tab ➤ Create panel ➤ (Create Group).

- Select view-specific elements, tags, or dimensions that are associated with an existing model group, and click Modify | <Elements> tab ➤ Create panel ➤ (Create Group).
Select an existing model group, and click Modify | Model Groups tab ➤ Group panel ➤ Edit Group. Click Edit Group panel ➤ (Attach).

2 In the Create Model Group and Attached Detail Group dialog, enter a name for the model group (if necessary), and enter a name for the attached detail group.

3 Click OK.

In the Project Browser, the attached detail group displays under the model group that it belongs to.

Related topic

- Adding or Removing Elements in a Group on page 1461

Duplicating Group Types

You can create a new group type by duplicating an existing group. When you duplicate a group, you can edit the new group type without affecting the original group or its instances.

Use one of the following methods to duplicate a group type:

- In the Project Browser, right-click the group name, and click Duplicate. The new group displays in the Project Browser. For example, if your original group was called Group 1, the new group would be Group 2. You can rename the group as necessary.

- Select the group in the drawing area, and on the Properties palette, click (Edit Type). In the Type Properties dialog, click Duplicate. Enter a name for the group, and click OK twice.

Loading Groups

You can load Revit project files (RVT) into a project as a group, and you can load Revit family files (RFA) into the Family Editor as a group. If you have existing Revit group files (RVG), you can also load them into a project or family.

To load a project or family file as a group

1 Click Insert tab ➤ Load from Library panel ➤ (Load as Group).

2 In the Load File as Group dialog, navigate to the Revit project file (RVT), Revit family file (RFA), or Revit group (RVG) you want to load.

3 If you are loading an RVT or RVG file, select whether you want to include attached details, levels, or grids.

   When you select attached details, detail elements in the file are loaded as attached detail groups.

4 Click Open.

   The file is loaded as a group, and the group displays in the Project Browser under the Groups branch. You can now place the group in the project or family. See Placing Groups on page 1459.

To reload a group

1 In the Project Browser, expand Groups.
2 Right-click the group to reload, and select Reload.
3 In the Load File as Group dialog, navigate to the file.
4 Optionally, select whether you want to include attached details, levels, or grids.
5 Click Open.

If any family types differ between the file you are loading and the host file, the Duplicate Types dialog opens to indicate this.

Placing Groups

To place a model group

1 Click Home tab ➤ Model panel ➤ Model Group drop-down ➤ (Place Model Group).
2 In the Type Selector on page 35, select the model group type to place.
3 Click in the drawing area to place the group.

To place a detail group

1 Click Annotate tab ➤ Detail panel ➤ Detail Group drop-down ➤ (Place Detail Group).
2 In the Type Selector on page 35, select the detail group type to place.
3 Click in the drawing area to place the group.

To place a model or detail group from the Project Browser

1 In the Project Browser, expand Groups ➤ Model or Detail.
2 Drag the model or detail group to place in the drawing area.

Alternatively, right-click a group name in the Project Browser and click Create Instance. Click in the drawing area to place instances of the group. When you are finished placing groups, click Modify on the ribbon.

**NOTE** Attached detail groups cannot be dragged from the Project Browser into the drawing area.

To place an attached detail group

1 Place an instance of a model group that has a detail group associated with it.

**NOTE** Attached detail groups can only be placed in the view type in which they were created: plans or section/elevation views. They cannot be placed in 3D views. The Project Browser indicates the type of view that an attached detail group can be placed in and to which model group it is attached.

2 Select the model group or multiple instances of the same model group.
   This model group must already have an attached detail group defined for it.

3 Click Modify | Model Groups tab ➤ Group panel ➤ (Attached Detail Groups).
4 In the Attached Detail Group Placement dialog, select the detail groups to display, or clear the detail groups to hide in the current view.
5 Click OK.
Specifying the Position of a Group by its Origin

When you are placing, moving, rotating, or pasting groups, the cursor is at the group origin. You can modify the position of the group origin. Once established, the origin position is used for each instance of the group that you place.

1. To display the origin, select the group in plan or 3D view. Three drag controls display.

2. Drag the center control to move the origin.

3. Drag the end controls to rotate the origin about the z axis.

Snap points help you place the origin or rotate the end controls.

The following image shows the same group with its origin moved. The origin snaps to the wall.
Modifying Groups

After you create or load a group, you can modify it. You can modify a group within a project (or family) using the group editor, or you can edit the group externally.

The group editor allows you to add elements from the project view, place additional elements in the view which are then automatically added to the group, remove elements, create attached detail groups (for model groups), and view group properties. When you edit a group using the group editor, the background color of the drawing area changes. The background color is ignored when you print from the group editor.

When you edit a group externally, the group opens as a Revit project file (RVT) or a Revit family file (RFA), depending on the environment from which you open it.

Adding or Removing Elements in a Group

1 In the drawing area, select the group to modify. If the group to modify is nested, press Tab until the group is highlighted, and click to select it.
2 Click Modify | Model Groups tab or Modify | Attached Detail Groups tab ➤ Group panel ➤ (Edit Group).
On the Edit Group panel, click (Add) to add elements to the group, or click (Remove) to remove elements from the group. Select the elements to add or remove from the group.

NOTE If you add a view-specific element to a model group (for example, a window tag), the view-specific element is placed in the project view and not in the model group.

When you are finished, click (Finish).

Excluding Elements from a Group Instance

Excluding elements from a group instance may be useful when, for example, you place a hotel unit group defined with 4 bounding walls adjacent to a similar unit, and the walls overlap. You can exclude the overlapping wall from the group instance. If the excluded wall is hosting any elements (for example, a wall-hosted tub or a door), Revit Structure attempts to rehost those elements on the remaining wall.

You can exclude an element using any of the following methods:

- Exclude an element from a group instance. The element remains in the group but is not visible in the project view for that group instance. If the excluded element is hosting any elements, Revit Structure attempts to rehost those elements.
- Move an element from a group instance to the project view. The element is visible in the project view, and can be edited from the project view. The element is also excluded from the group instance.

When elements are excluded and are not visible in the project view for a group instance, they are not included in schedules.

Excluded elements can be restored to their group instances.

To exclude an element from a group instance

1. In the drawing area, place the cursor over the group element to exclude.
2. Press TAB to highlight the element, and then click to select it.
3. In the drawing area, click the icon ( ) to exclude the element, or right-click, and click Exclude.

NOTE You can also use the following keyboard shortcuts: Delete or Ctrl-X.

The element is excluded from the group instance, and hosted elements are rehosted as necessary.

To move an element from a group instance to the project view

1. In the drawing area, place the cursor over the element to move.
2. Press Tab to highlight the element, and then click to select it.
3 Right-click, and click Move to Project.

**To restore an excluded element to a group**

1 In the drawing area, place the cursor over the excluded group element.
2 Press Tab to highlight the element, and then click to select it.
3 In the drawing area, click the icon ( ) to restore the excluded element, or right-click, and click Restore Excluded Member.

**To restore all excluded elements in a group**

1 In the drawing area, select the group.
2 Click Modify | Model Groups tab or Modify | Attached Detail Groups tab ➤ Group panel ➤ (Restore All Excluded).

**Editing a Group Externally**

1 In the Project Browser, right-click the group name, and click Edit.
2 Click Yes to confirm that you want to edit the group externally.
3 Make the necessary changes, and save the file.

**To load (or reload) the group into a project or family**

4 Click Home tab ➤ Model panel ➤ Model Group drop-down ➤ (Load as Group into Open Projects).
5 In the Load into Projects dialog, select the projects (or families) to load the group into.

---

**NOTE** In order for project or family files to appear in this list, they must be open.

6 Select Attached Details to load detail elements as attached detail groups.
7 Select levels to load levels into the group.
8 Select grids to load grids into the group.
9 Click OK.
   The group is loaded into the project (or family), and the group file remains open.

**Renaming a Group**

1 In the Project Browser, right-click the group name, and click Rename.
2 Enter a new name for the group, and press Enter.

**Showing/Hiding Attached Detail Groups**

1 In the drawing area, select a model group that has an attached detail group, or groups.
2 Click Modify | Model Groups tab ➤ Group panel ➤ (Attached Detail Groups).
3 In the Attached Detail Group Placement dialog, select or clear check boxes to show or hide the attached detail group.
4 Click OK.

Detaching an Attached Detail Group from a Model Group

An attached detail group that does not include dimensions or tags can be detached from a model group.

1 In the drawing area, select an attached detail group.
2 Click Modify | Attached Detail Groups tab ➤ Group panel ➤ (Detach from Model Group).

Swapping Out Group Types

You can replace one group with another by selecting a group and then choosing a different group name in the Type Selector. Revit Structure automatically replaces the group.

When you swap an instance of a group type for an instance of a different group type, Revit Structure attempts to replace any attached detail groups from the old group instance with attached detail groups of the same name from the new group instance. For elements in attached detail groups that were not replaced, and for all other elements that depend on elements in the swapped group instance, Revit Structure attempts to find references within the new group instance. If new references cannot be found for these dependent elements, Revit Structure posts a warning to indicate which dependent elements it could not find references for. In addition, the origin of the new group is placed at the position of the first group. For more information on group origins, see Specifying the Position of a Group by its Origin on page 1460.

Specifying Height for Model Groups

1 In the drawing area, select a model group.
2 On the Properties palette, edit the group properties.
   ■ Reference Level specifies the level with which the group is associated.
   ■ Origin Level Offset specifies a height above or below that level.

NOTE Some group members may not move as a result of entering an offset value. Some elements, such as components, remain on the level line if they are not hosted by another object such as a floor.

Draw Order for Elements in Detail Groups

Detail elements in a detail group move as a unit with respect to draw order. They move forward or backward together when the group draw order is changed. If you want to change the draw order of individual members of the group, you first need to edit the group. After you change the draw order of the members of a detail group and finish editing the group, all instances of that detail group are updated with the new draw order.

For more information on draw order, see Sorting the Draw Order of Detail Components on page 958.
Converting Groups and Linked Revit Models

You can convert groups to linked Revit models, and you can convert linked Revit models to groups. It is recommended that you use groups when there is significant geometrical interactivity in a model (for example, joins, inserts, or references) and where project standards need to be managed in one location. Sample scenarios where you would use groups are hotel rooms, apartments, and repeating floors.

Switching between groups and links may be useful in the following scenarios:

- Your model contains multiple groups of repeating elements that exist as linked Revit models. As you work in the main model, you can convert the linked models to groups to make edits. This allows you to make edits to linked models in context of the main model. When you finish modifying the group, you can convert it back to a link.

- You have created a group or linked Revit model, and then decide that you need to change the group to a linked model, or change the linked model to a group.

When you convert a group to a linked Revit model, any excluded elements are restored in the link. For more information about excluded elements, see Excluding Elements from a Group Instance on page 1462.

Converting Groups to Linked Revit Models

1 In the drawing area, select the group.

2 Click Modify | Model Groups tab ➤ Group panel ➤ (Link).

3 In the Convert to Link dialog, select one of the following:

- **Replace with a new project file**: Creates a new Revit model. When you select this option, the Save Group dialog opens. Navigate to the location where you want to save the file. If you want the new link to have the same name as the group, leave the default name, otherwise enter a name for the link, and click Save.

- **Replace with an existing project file**: Replaces the group with an existing Revit model. When you select this option, the Open dialog opens. Navigate to the location of the Revit file you want to use, and click Open.

If there is a linked Revit model in the project with the same name as the group, a message displays to indicate this. You can do one of the following:

- Click Yes to replace the file.

- Click No to save the file with a new name. The Save As dialog opens, where you can enter a new name for the linked Revit model.

- Click Cancel to cancel the conversion.

Converting Linked Revit Models to Groups

1 In the drawing area, select the linked Revit model.

2 Click Modify | RVT Links tab ➤ Link panel ➤ (Bind Link).

3 In the Bind Link Options dialog, select the elements and datum to include in the group, and click OK.
If there is a group in the project with the same name as the linked Revit model, a message displays to indicate this. You can do one of the following:

- Click Yes to replace the group.
- Click No to save the group with a new name. Another message displays indicating that all instances of the linked model will be deleted from the project, but the linked model file will still be loaded in the project. You can remove the linked file from the project by clicking Remove Link in the message dialog, or you can remove it at a later time from the Manage Links dialog.
- Click Cancel to cancel the conversion.

**Saving Groups**

You can save a group as a Revit project file (RVT) if you are working in a project, or a Revit family file (RFA) if you are working in the Family Editor.

1. Click ➤ Save As ➤ Library ➤ (Group).
2. By default, the File name text box displays “Same as group name”. If you accept this name, Revit Structure saves the file with the same name as the group. So a group called Group 5 saves as Group 5.rvt (or Group 5.rfa). If desired, you can change this name.
3. If your project has multiple groups, select the appropriate group from the Group to Save drop-down.
4. Specify whether to Include attached detail groups as views.
5. Click Save.

**Deleting Groups**

To delete a group, you must first delete all instances of the group in the project.

1. In the Project Browser, right-click the group, and click Select All Instances ➤ In Entire Project.
2. Click Modify | <group type> Groups tab ➤ Modify panel ➤ (Delete), or press Delete. All instances of the group are deleted in the project.
3. In the Project Browser, right-click the group, and click Delete.

**Group Properties**

To modify group properties

1. In the drawing area, select the group.
2. On the Properties palette, change group properties as desired.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
<td></td>
</tr>
<tr>
<td>Reference Level</td>
<td>The level where the group resides or to which it refers.</td>
</tr>
</tbody>
</table>
An offset from the reference level where the group origin resides. See Specifying the Position of a Group by its Origin on page 1460.

### Using Arrays of Elements

The Array tool creates a linear or radial array of selected elements.

**NOTE** Arrays are not supported for most annotation symbols.

### Creating an Array

The elements of an array can follow a line (a linear array), or they can follow an arc (a radial array). When creating an array, you specify the distance between elements using either of the following methods:

- Specify the distance between the first and second elements. (Use the Move To 2nd option.) All subsequent elements use the same spacing.
- Specify the distance between the first and last elements. (Use the Move To Last option.) All remaining elements are evenly spaced between them.

### Creating a Linear Array

1. Do one of the following:
   - Select the elements to be copied in an array, and then click Modify | <Element> tab ➤ Modify panel ➤ (Array).
   - Click Modify tab ➤ Modify panel ➤ (Array), select the elements to be copied in an array, and then press Enter.

2. On the Options Bar, click (Linear).

3. Select the desired options:
   - **Group And Associate**: Includes each member of the array in a group. If not selected, Revit Structure creates the specified number of copies and does not group them. Once placed, each copy acts independently of the others.
   - **Number**: Specifies the total number of copies (of the selected elements) in the array.
   - **Move To**:
     - **2nd**: Specifies the spacing between each member of the array. Additional array members appear after the second member.
     - **Last**: Specifies the entire span of the array. Array members are evenly spaced between the first member and the last member.
Constrain: Restricts movement of array members along vectors that run perpendicular or collinear to the selected elements.

NOTE You cannot group together detail components and model components.

4 If you selected Move To 2nd, place array members as follows:
   a Click in the drawing area to indicate a starting point for measuring.
   b Move the cursor the desired distance between members. As you move the cursor, a box displays to indicate the size of the selected elements. The box moves along snap points. A dimension displays between the first click location and the current cursor position.
   c Click again to place the second member, or type a dimension and press Enter.

5 If you selected Move To Last, place array members as follows:
   a Click in the drawing area to indicate a starting point for measuring.
   b Move the cursor to the desired location for the last array member. As you move the cursor, a box displays to indicate the size of the selected elements. The box moves along snap points. A dimension displays between the first click location and the current cursor position.
   c Click again to place the last member, or specify a dimension and press Enter.

6 If you selected Group and Associate on the Options Bar, a number box displays, indicating the number of copies to create in the array. If desired, change the number and press Enter.

Revit Structure creates the specified number of copies of the selected elements, and places them using the appropriate spacing.

Placing the first and second items in a linear array
Specifying the number of elements in the array

Creating a Radial Array

1. Select one or more elements to be copied in an array.

2. Click Modify | <Element> tab ➤ Modify panel ➤ (Array).

3. On the Options Bar, click (Radial).

4. Select the desired options, as described for creating a linear array.

TIP When you create a radial array, the steps are similar to rotating an element and copying it. See Rotating Elements on page 1481.

5. Drag the center of rotation symbol ( ) to the desired location.
The array members will be placed around an arc measured from this point. In most instances, you want to drag the center of rotation symbol away from the center of the selected elements. The symbol snaps to points and lines of interest, such as walls and the intersections of walls and lines. You can also drag it onto open space.

6 Move the cursor to a position where the arc of the radial array will begin. (A line radiates from the center of rotation symbol to the cursor position.)

**NOTE** If you want to specify the angle of rotation (instead of drawing it), specify an Angle value on the Options Bar and press Enter. Skip the remaining steps.

7 Move the cursor to a position where the arc of the radial array will begin. (A line radiates from the center of rotation symbol to the cursor position.)

8 Click to position the first ray of rotation. If the cursor snaps while specifying the first ray, the snap line rotates along with the preview box and snaps to angles on the screen while placing the second ray.

9 Move the cursor to place the second ray of rotation.

Another line displays to indicate the ray. A temporary angular dimension displays as you rotate, and a preview image shows the selection rotating.

9 Click to place the second ray and finish the array.

If you selected Move To 2nd on the Options Bar, the second ray of rotation defines the location of the second member of the array. Additional array members are placed using the same spacing.

If you selected Move To Last, the second ray of rotation defines the location of the last member of the array. Additional array members are spaced equally between the first and last members.

If you selected Group and Associate on the Options Bar, controls appear on the radial array. Use the 2 end controls to resize the angle of the arc. Use the middle control to drag the array to a new location. Use the top control to resize the radius of the array.

**Drawing the arc for the radial array**
Specifying the number of elements in the array

The completed radial array

Copying an Array

1 Select all members of the array.
2 While pressing Ctrl, click and drag an array member to a new location.
Deleting Members from an Array

You can select one or more members of an array and delete them. If the array was grouped, deleting a member of the array effectively ungroups the remaining members.

Changing an Array

You can modify any dimension associated with array members. If the modified array member is part of a group, the change affects that element and proportionally affects other members of the group, depending on the dimension modified. If the modified array member is not part of a group, the change affects the selected element only. See Changing a Dimension Value on page 912.

If array members belong to a group, you can change the number of members in the array. Select the pattern line and enter a new value in the array instance number box. Controls for array groups are visible in all views in which the array is visible. When you modify the number of elements in an array, you can specify how elements are added to or removed from the array with the Append to End option.

Changing the dimensions of an array
Changing the number of elements in an array

Specifying how elements are added to or removed from an array

When you change the number of elements in an array, you can specify how the additional elements are added to (or removed from) the array.

1. Select the array.
   An array is selected when the line that indicates the layout is selected, as shown in the following image.

2. On the Options Bar, select or clear Append to End.
   - If Append to End is selected, the spacing between the elements in the array remains the same, and any elements you add to (or remove from) the array are added to (or removed from) the existing endpoint of the array.

   Array selected

   - If Append to End is not selected, the endpoints of the array remain the same, and any elements added to (or removed from) the array are evenly spaced in between the existing endpoints.
Moving Elements

Revit Structure offers a variety of ribbon options, keyboard actions, and on-screen element controls for moving elements in the drawing area, either independently or in association with other elements.

You can move a hosted component from one host to another. For example, you can move a window from one wall to another wall. See Moving a Window to a Different Wall on page 501.

You can also move a component that is dimensioned to another element (by distance or angle) by changing the dimension. See Changing a Dimension Value on page 912.

Moving Elements by Dragging

You can click and drag a selected element to a new location in the drawing area. If multiple elements are selected, they all move when you drag one. The spatial relationships among them are preserved.

TIP When moving elements one at a time, select Press & Drag on the status bar to drag an element without selecting it first. When using this option, the element is selected as you drag it.

Some elements can move only horizontally or vertically by default; Revit Structure provides visual cues about the way that a selected element can move. To remove this constraint, press and hold Shift while dragging the element.

Conversely, some elements can move in any direction by default. To constrain their movement, press and hold Shift while dragging the elements. For example, you can move a window freely in an elevation or a 3D
view, but pressing \textit{Shift} constrains the movement of the window so that its elevation does not change. Likewise, you can normally move walls, lines, or gridlines freely in any direction. Pressing \textit{Shift} constrains their movement to directions perpendicular to the wall or line.

When you select a wall or line that has an end joined to another (unselected) wall or line, movement is constrained to a direction perpendicular to the selected wall or line to keep the joined end from extending or shrinking. Press and hold \textit{Shift} to remove this constraint.

**Moving Elements with Arrow Keys**

Use arrow keys on the keyboard to move selected elements vertically or horizontally. You cannot use the arrow keys to move a level-based element up or down from the level.

**Moving Elements with the Move Tool**

The Move tool works similarly to dragging. However, it offers additional functionality on the Options Bar and allows more precise placement. You can create multiple copies of an element when you move it.

To move elements with the Move tool

1. Do one of the following:
   - Select the elements to move, and then click Modify | \{Element\} tab ➤ Modify panel ➤ (Move).
   - Click Modify tab ➤ Modify panel ➤ \quad (Move), select the elements to move, and then press \textit{Enter}.

2. On the Options Bar, click the desired options:
   - \textbf{Constrain}: Click Constrain to restrict the movement of the element along vectors that run perpendicular or collinear to the element.
   - \textbf{Disjoin}: Click Disjoin to break the association between the selection and other elements before moving. This option is useful, for example, when you want to move a wall that is joined to another wall. You can also use the Disjoin option to move a hosted element from its current host to a new host. For example, you can move a window from one wall to another wall. This feature works best when you clear the Constrain option.
   - \textbf{Multiple}: Click Multiple to create multiple copies of an element every time you click in the drawing area. The option is available only when the Copy option is selected. See \textit{Copying Elements with the Copy Tool} on page 1492. (To exit the Multiple Copy function, press \textit{Esc}).

3. Click once to enter a start point for moving.
   A preview image of the element displays.

4. Move the cursor in the direction that you want the element to move.
   The cursor snaps to snap points. Dimensions appear as guides.

5. Click again to complete the move, or, for more precision, type a value for the distance to move the element, and press \textit{Enter}.
Moving Elements with the Offset Tool

Use the Offset tool to copy or move a selected model line, detail line, wall, or beam a specified distance perpendicular to its length. You can apply the tool to single elements or to chains of elements belonging to the same family. You can specify the offset distance by dragging the selected elements or by entering a value.

The following restrictions apply to the Offset tool:

■ You can offset lines, beams, or braces in their own work planes only. For example, if you sketch a model line whose work plane is set to floor plan: level 1, you can offset that line only in the plan view plane.

■ You cannot offset walls created as in-place families.

■ You cannot offset elements in a view perpendicular to their move plane. For example, you cannot offset a wall in an elevation view.

To offset an element or a copy of an element

1 Click Modify tab ➤ Modify panel ➤ (Offset).
2 On the Options Bar, select how you want to specify the offset distance:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>drag the selected element the desired distance</td>
<td>select Graphical.</td>
</tr>
<tr>
<td>enter a value for the offset distance</td>
<td>select Numerical. Enter a positive number in the Offset box.</td>
</tr>
</tbody>
</table>

3 If you want to create and offset copies of the selected element, select Copy on the Options Bar. (If you selected Graphical in the previous step, pressing Ctrl as you move the cursor has the same effect.)

4 Select the element or chain to offset.

If you specified an offset distance using the Numerical option, a preview line displays at that distance from the highlighted elements on the side where the cursor is positioned, as shown.
5 Move the cursor as necessary to display the preview line at the desired offset position, and then click to move the element or chain to that position or to place a copy there. Or, if you selected the Graphical option, click to select the highlighted element, and then drag it to the desired distance and click again. After you start the drag, a listening dimension displays, and you can enter a specific offset distance.

**Moving Elements with Cut-and-Paste**

The Cut tool removes one or more selected elements from the drawing and pastes them to the clipboard. You can then use the Paste or Paste Aligned tools to paste the elements in the current drawing or in another project.

You cannot cut

- Elements that cannot be deleted, such as the last level in a building model
- Some combinations of elements (for example, you cannot cut curtain panels and mullions without cutting the entire curtain system)
- An interior elevation arrow without cutting its adjoined elevation symbol
- Certain elements in any context (for example, you cannot cut the Ref. Level in the Family Editor)

**To cut and paste elements**

1. Select one or more elements in the drawing area.

2. Click Modify | <Element> tab ➤ Clipboard panel ➤ (Cut).

   **NOTE** You can also use the keyboard shortcut Ctrl+X to cut elements.

3. Paste the elements using a tool from the Modify tab ➤ Clipboard panel ➤ Paste drop-down:
   - **Paste from Clipboard:** To place the elements in another area of the drawing, or in another project.
An Aligned option: To place the elements to another level exactly above or below the original location of the elements.

### Moving End-joined Elements

You can move elements that share a common end join simultaneously without breaking the join. To do this, use a drag control or select an option on the shortcut menu. This functionality is available for walls, lines, beams, braces, and line-based families.

The following image shows 3 walls moving together by their common end join.

Only selected joined elements move. Unselected elements that are part of a join detach from the join when it is moved. The exception to this is braces that are joined to beams. Braces always move with the beams to which they are joined.

1. Right-click a member of the join, and click Select Joined Elements.
2. In the drawing area, click the drag end control, or right-click and click Drag End.
3. Drag the join to the desired location.

### Moving Lines and Components with Walls

You can specify that lines and components near a wall move a corresponding distance whenever that wall is moved. To do this, use the Moves with Nearby Elements option.

1. Select one or more components.
3. Move the selected components to the desired position.

Witness lines show dimensions from walls and other points. If desired, you can click a dimension to change it.

Now when you move the wall that the component is linked to, the component also moves, maintaining its distance from the wall.

The following restrictions apply to the Move With Nearby Elements option:

- Only straight lines that are parallel to a wall are affected by this option. It is not available for detail lines, sketch-based elements, and families.
For arc lines, the radius remains at a constant offset from the arc wall, even if the radius of the wall changes. For example, if you change a wall radius from 40 to 30 meters, a 20-meter arc line radius updates to 10 meters, maintaining the 20-meter offset.

If you copy a line or component that is set to move with nearby elements, the copy also moves with the element.

If you move the line or component toward another element, it then moves with that new element. For example, suppose that a straight line moves with a wall. When you move the line closer to another straight wall with which it is parallel, the line now moves with the new wall. However, if you place a wall closer to the line or component, it does not move with that new wall. It retains its movement with the first wall.

Using the Moves with Nearby Elements option

Aligning Elements

Use the Align tool to align one or more elements with a selected element. This tool is generally used to align walls, beams, and lines, but it can be used with other types of elements as well. For example, in 3D views you can align surface patterns of walls with other elements.

The elements to align can be of the same type, or they can be from different families. You can align elements in a plan view (2D), 3D view, or elevation view.

For example, you can use the Align tool to

- Align the ends of Walls on page 449 or Beams on page 247 with a selected beam, line, or wall. (This action extends the lengths of the aligned walls or beams.)
- Align the centers of Walls on page 449 or Beams on page 247 with a selected beam, line, or wall. (This action moves the aligned walls or beams.)
- Align the heights of Windows on page 499 with a selected line or wall.
- Join selected endpoints (of walls, for example) with a selected line.

**Grid line and 4 columns**

```
  2

Align columns with grid line

  2

Selected point to align to an element

Element and point joined
To align elements

1 Click Modify tab ➤ Modify panel ➤ (Align).

The cursor displays with the align symbol.

2 On the Options Bar, select the desired options:
   ■ Select Multiple Alignment to align multiple elements with a selected element. (As an alternative, you can press Ctrl while selecting multiple elements to align.)
   ■ When aligning walls, use the Prefer option to indicate how selected walls will be aligned: using Wall Faces, Wall Centerlines, Faces of Core, or Center of Core. (The core options refer to walls that have multiple layers.)

3 Select the reference element (the element to align other elements to).
4 Select one or more elements to align with the reference element.

   NOTE Before selecting, move the cursor over the element until the part of the element to align with the reference element is highlighted. Then click it.

5 If you want the selected elements to stay aligned with the reference element (if you later move it), click the padlock to lock the alignment. If the padlock symbol no longer displays because you have done something else, click Modify and select the reference element to make the symbol redisplay.
6 To start a new alignment, press Esc once.
7 To exit the Align tool, press Esc twice.

Rotating Elements

Use the Rotate tool to rotate elements around an axis. In floor plan, reflected ceiling plan, elevation, and section views, elements rotate around an axis perpendicular to the view. In 3D views, the axis is perpendicular to the work plane of the view.
Not all elements can rotate around any axis. For example, walls do not rotate in elevation views. Windows cannot rotate without their walls.

The Rotate tool is available only after the element is selected. After you rotate the element, Revit Structure returns to Modify mode.

To rotate elements

1 Do one of the following:
   - Select the elements to rotate, and then click Modify | <Element> tab ➤ Modify panel ➤ (Rotate).
   - Click Modify tab ➤ Modify panel ➤ (Rotate), select the elements to rotate, and then press Enter.

A center of rotation symbol (⊙) displays at the center of the selected element.

2 If desired, drag the center of rotation symbol.
   The symbol snaps to points and lines of interest, such as walls and the intersections of walls and lines. You can also drag it onto open space.

3 On the Options Bar, select any of the following:
   - Disjoin: Select Disjoin to break the connection between the selection and other elements before rotating. This option is useful, for example, when you want to rotate one wall that is joined to another wall.
   - Copy: Select Copy to rotate a copy of the selection. The original remains in place.
   - Angle: Specify the angle of rotation, and press Enter. Revit Structure performs the rotation at the specified angle. Skip the remaining steps.

4 Click to specify the first ray of rotation.
   A line displays to indicate the first ray. If the cursor snaps while specifying the first ray, the snap line will rotate with the preview box and snap to angles on the screen while placing the second ray.

5 Move the cursor to place the second ray of rotation.
   Another line displays to indicate the ray. A temporary angular dimension displays as you rotate, and a preview image shows the selection rotating.

   **TIP** You can also rotate an element using listening dimensions. After you click to specify the first ray of rotation, the angular dimension displays in bold. Enter a value using the keyboard.

6 Click to place the second ray and finish rotating the selection.
   The selection rotates between the first and second rays.

Revit Structure returns to the Modify tool with the rotated element still selected.
**Flipping Elements**

Revit Structure provides the following ways to flip an element (change its orientation) in the drawing area.

- Press the *Spacebar* to flip one or more selected elements. Free-standing families, such as columns, rotate 90 degrees each time you press the *Spacebar*. See *Spacebar* on page 1452.
- Click a flip control to change the orientation of a selected element. For example, click the flip control (|=) for a compound wall to reverse the order of its component layers. See *Flip Controls* on page 1450.

**Mirroring Elements**

The Mirror tool mirrors (reverses the position of) a selected model element, using a line as the mirror axis. For example, if you mirror a wall across a reference plane, the wall flips opposite the original. You can pick the mirror axis or draw a temporary axis. Use the Mirror tool to flip a selected element, or to make a copy of an element and reverse its position in one step.

1. Do one of the following:
   - Select the element to mirror, and on the Modify | Element tab ➤ Modify panel, click either (Mirror - Pick Axis) or (Mirror - Draw Axis).
   - Click Modify tab ➤ Modify panel, and click either (Mirror - Pick Axis) or (Mirror - Draw Axis). Then, select the element to mirror, and press *Enter*.

   **TIP** You can select inserts, such as doors and windows, without their hosts.

   To select the line that represents the mirror axis, select Pick Mirror Axis. Or to sketch a temporary mirror axis line, select Draw Mirror Axis.

2. To move the selected item (rather than making a copy of it), clear Copy on the Options Bar.
3. Select or draw the line to use as a mirror axis.
   - You can pick only a line or a reference plane that the cursor can snap to. You cannot mirror an element around empty space.

Revit Structure moves or copies the selected element and reverses its position opposite the selected axis.
Selecting the element to mirror (and copy) and the mirror axis

Mirrored (and copied) rebar

Related topics
- Selecting Elements on page 1439
- Flipping Elements on page 1483
- Moving Elements on page 1474
- Copying Elements on page 1491

Preventing Elements from Moving

Use the Pin tool to lock a modeling element in place. When you pin a modeling element, it cannot be moved. If you try to delete a pinned element, Revit Structure warns you that the element is pinned. A pushpin control displays near the element to indicate that it is locked.
If you pin a component, it can still move if it is set to move with nearby elements or if the level where it is placed moves up or down. See Moving Lines and Components with Walls on page 1478.

Using Pins to Lock Elements in Place

Do one of the following:

- Select the elements to be pinned, and then click Modify \(\text{<Element> tab} \rightarrow \text{Modify panel} \rightarrow \text{(Pin)}\).
- Click Modify tab \(\rightarrow\) Modify panel \(\rightarrow\) (Pin), select the elements to be pinned, and then press Enter.

Revit Structure displays a pushpin control near the element to indicate that it is pinned in place. To move or delete the element, you must first unlock it by clicking the pushpin control. Click the pushpin again to lock the element.

Related topics
- Preventing Elements from Moving on page 1484
- Unpinning Elements on page 1485
- Constraints on page 1537

Unpinning Elements

The Unpin tool unpins a locked element. You can then move the element or delete it without being prompted. You can select multiple elements for unpinning. If some of the elements you select are not pinned, the Unpin tool has no effect.

Do one of the following:

- Select the elements to be unpinned, and then click Modify \(\text{<Element> tab} \rightarrow \text{Modify panel} \rightarrow \text{(Unpin)}\).
- Click Modify tab \(\rightarrow\) Modify panel \(\rightarrow\) (Unpin), select the elements to be unpinned, and then press Enter.

When you click the pushpin control in the drawing area to unpin an element, an X displays near the pin control to indicate that it is unlocked.
Resizing Elements

To modify multiple elements simultaneously, use shape handles or the Scale tool. The Scale tool is available for lines, walls, images, DWG and DXF imports, reference planes, and position of dimensions. You can scale elements graphically or numerically.

When resizing elements, consider the following:

- To resize an element, you define an origin, which is a fixed point from which the elements equally resize.
- All elements must lie in parallel planes. All walls in the selection must have the same base level.
- When you resize a wall, inserts remain at a fixed distance from the wall’s midpoint.
- Resizing changes the position of dimensions but not their values. If you resize an element that a dimension references, the dimension value does change.
- Import symbols have a read-only instance parameter called Instance Scale. It shows how much the instance size differs from the base symbol. You can change it by resizing the import symbol.

Resizing Elements with Shape Handles

When you select and drag the handles of multiple elements, Revit Structure resizes the elements simultaneously.

Dragging multiple wall handles to resize them simultaneously

1. Move the cursor over the part of the first element to resize and press Tab until the desired handle is highlighted. Click to select it. For example, to resize the length of a wall, move the cursor over the end of the wall, press Tab to highlight that handle, and click to select it.
2. Move the cursor over the part of the next element to resize and press Tab until the desired handle is highlighted. While pressing Ctrl, click to select it.
3. Repeat Step 2 for the remaining elements, until handles on all desired elements are selected. Remember to press Ctrl when you click to select another element.

   **NOTE** To deselect a selected element (without deselecting other elements), move the cursor over the selected element and, while pressing Shift, click the element.

4. Click the handle of one of the selected elements, and drag it to resize. The other selected elements are resized at the same time.

Scaling Graphically

Graphical scaling requires 3 clicks: the first click determines the origin, and the next 2 clicks define the scale vectors. Revit Structure calculates a scale factor by determining the ratio of the lengths of the 2 vectors. For example, suppose you sketch a first vector that is 5 feet and a second vector that is 10 feet. This creates a scale factor of 2. As a result, the elements become twice their original size.
1 Do one of the following:

- Select the elements to scale, and then click Modify | <Element> tab ➤ Modify panel ➤ (Scale).

- Click Modify tab ➤ Modify panel ➤ (Scale), select the elements to scale, and then press Enter.

Be sure to select only supported elements, such as walls and lines. The Scale tool is unavailable if your entire selection contains just one non-supported element.

2 On the Options Bar, select Graphical.

3 In the drawing area, click to set the origin.

   The origin is the point from which the size of the element will change. The cursor snaps to various references. Press Tab to change the snap points.

4 Move the cursor to define the first vector.

5 Click to set that length.

6 Move the cursor again to define the second vector.

   **TIP** You can use listening dimensions to enter values for the lengths of the vectors.

7 Click to set that point.

The selected element scales so that the ends of vector 1 now coincide with those of vector 2.

**Defining the first scale vector**
Defining the second scale vector

Scaling Numerically

To scale numerically, enter a scale factor and specify the origin.

To scale elements numerically:

1 Select the elements to scale.

Be sure to select only supported elements, such as walls and lines. The Scale tool is unavailable if your entire selection contains just one non-supported element.
2 Click Modify | Element tab > Modify panel > (Scale).

3 On the Options Bar, select Numerical.

4 Enter a scale factor.

5 Click in the drawing area to specify the origin.

The element resizes by the defined scale factor.

Trimming and Extending Elements

Use the Trim and Extend tools to trim or extend one or more elements to a boundary defined by the same element type. You can also extend non-parallel elements to form a corner, or trim them to form a corner if they intersect. When you select an element to be trimmed, the cursor position indicates the part of the element to retain. You can use these tools with walls, lines, beams, or braces.

To trim or extend elements

1 Do one of the following:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>trim or extend 2 selected elements to a corner</td>
<td>click Modify tab &gt; Modify panel &gt; (Trim/Extend to Corner). Select each of the elements. When selecting an element that needs to be trimmed to form the corner, make sure you click the part of the element to be retained.</td>
</tr>
<tr>
<td>trim or extend one element to a boundary defined by another element</td>
<td>click Modify tab &gt; Modify panel &gt; (Trim/Extend Single Element). Select the reference to use as a boundary. Then select the element to trim or extend. If this element crosses the boundary (or a projection), the part that you click is retained. The part on the other side of the boundary is trimmed.</td>
</tr>
<tr>
<td>trim or extend multiple elements to a boundary defined by another element</td>
<td>click Modify tab &gt; Modify panel &gt; (Trim/Extend Multiple Elements). Select the reference to use as a boundary. Then select each of the elements to trim or extend. For any elements that cross the boundary, the part that you click is retained. The part on the other side of the boundary is trimmed.</td>
</tr>
</tbody>
</table>

2 Continue trimming or extending elements with the currently selected option, or select a different option.
NOTE You can select a different Trim or Extend option at any time while the tool is active. This also clears any initial selection made with the previous option.

3 To exit the tool, press Esc.

Preview for Trim/Extend to Corner tool

Result of Trim/Extend to Corner operation

Preview of Trim/Extend Single Element option with horizontal wall selected as the boundary
Copying Elements

Revit Structure provides several methods for copying one or more selected elements.

- Select an element and, while pressing Ctrl, drag the element to copy it.
- Use the Copy tool to copy elements and place them immediately.
- Use the clipboard to copy and paste elements with Ctrl+C and Ctrl+V.
- Use the Create Similar tool to add a new instance of a selected element.
- Make a mirror copy of an element. (Use the Mirror tool with the Copy option. See Mirroring Elements on page 1483.)
- Copy an array of elements. See Copying an Array on page 1471.

**Copying Elements with the Copy Tool**

The Copy tool copies one or more selected elements and allows you to place copies in the drawing immediately.

The Copy tool is different than the Copy to Clipboard tool. Use the Copy tool when you want to copy a selected element and place it immediately (for example, in the same view). Use the Copy to Clipboard tool, for example, when you need to switch views before placing the copies.

1. Do one of the following:

   - Select the elements to copy, and then click Modify | <Element> tab ➤ Modify panel ➤ (Copy).

   - Click Modify tab ➤ Modify panel ➤ (Copy), select the elements to copy, and then press Enter.

2. Click once in the drawing area to begin moving and copying the elements.

3. Move the cursor away from the original elements and toward the area where you want to place a copy.

4. Click to place the copy or enter a value for the listening dimension.

5. Continue placing more elements, or press Esc to exit the Copy tool.

**Copying Elements to the Clipboard**

The Copy to Clipboard tool copies one or more elements to the clipboard. You can then use the Paste from Clipboard or Paste Aligned tools to paste copies of the elements in the drawing or in another project.

The Copy to Clipboard tool is different than the Copy tool. Use the Copy tool when you want to copy a selected element and place it immediately (for example, in the same view). Use the Copy to Clipboard tool, for example, when you need to switch views before placing the copies.

1. Select one or more elements in the drawing area.

2. Click Modify | <Element> tab ➤ Clipboard panel ➤ (Copy).
3 Paste the elements using either of the following tools:
- Paste from Clipboard: To copy the elements to another area of the drawing, or to another project. See Pasting Elements from the Clipboard on page 1494.
- Paste Aligned: To copy the elements to another level exactly above or below the original location of the elements. See Pasting Aligned Elements on page 1496.

You cannot copy
- An interior elevation arrow without copying its adjoined elevation symbol
- Some combinations of elements (for example, you cannot copy curtain panels and mullions without copying the entire curtain system)
- Certain elements in any context (for example, you cannot copy the Ref. Level in the Family Editor)

Related topics
- Pasting Elements on page 1493
- Copying Elements with the Create Similar Tool on page 1497
- Moving Elements on page 1474

Pasting Elements

The Paste tool inserts elements from the clipboard to the current view or a different view. This tool is available only after cutting or copying elements. You can only copy (or cut) and paste elements within the same session of Revit Structure.

The Paste Aligned tool allows you to copy multiple elements on one level and paste them to another level exactly above or below the location of the original elements. This tool is most useful for multi-story buildings, where you can copy and paste aligned elements from one level to many other levels.
Pasting Elements from the Clipboard

1 Cut or copy elements to the clipboard.
   See Moving Elements with Cut-and-Paste on page 1477 or Copying Elements to the Clipboard on page 1492.

2 Place the cursor in the view where you want to paste the elements.

3 Click Modify tab ➤ Clipboard panel ➤ Paste drop-down ➤ (Paste from Clipboard).

   NOTE You can also use the keyboard shortcut Ctrl+V to paste elements.

   In Paste mode, a preview image of the elements displays in the drawing area, similar to the following. Temporary dimensions and witness lines display to help position the elements.

4 Click to place the preview image in the desired location.
   The pasted elements appear in the drawing area. They are selected so that you can adjust them if needed.

5 Refine placement of the pasted elements, if desired.
   While the elements are selected, you can modify them as desired. Depending on the type of elements being pasted, you may be able to use the Move, Rotate, and Mirror tools.
   You can also use tools on the Modify | <Element> tab. The available options depend on the pasted elements. For example, for building components (such as windows), you can use the Pick Host or Edit Family tools. For other types of elements, you can use the Activate Dimensions (on the Options Bar) or Edit Pasted Elements tools.
To finish the paste operation, click in the drawing area away from the pasted elements to deselect them. (For some types of elements, click Modify | <Elements> tab ➤ Tools panel ➤ (Finish).)

If you want to quit Paste mode, discarding the pasted elements, click (Cancel) on the Modify | <Elements> tab.

**Editing Pasted Elements**

During a paste operation, you may need to refine the placement of pasted elements, rehost pasted building components, or specify new references for pasted elements. The Edit Pasted Elements tool allows you to move or modify elements before the paste operation is finalized.

1. Paste one or more elements from the clipboard.
   
   See Pasting Elements from the Clipboard on page 1494.

2. Click Modify | <Elements> tab ➤ Edit Pasted panel ➤ (Edit Pasted Elements).
   
   The Edit Pasted panel displays in the drawing area. The newly pasted elements display in the defined selection color, indicating that they are selected so that you can move them. Other elements in the drawing area display in gray, indicating that you cannot modify them during Edit Pasted mode.
While in Edit Pasted mode, you can deselect and select specific elements. (Deselected elements display in black; selected elements display in blue [or the defined selection color].) This tool allows you to move a specific element without moving all pasted elements. After moving a pasted element, you can deselect it, and then select another element to move it to the desired location.

3 The Edit Pasted panel displays the available tools. Use these tools as follows:

- **Finalize Selected** finalizes the placement of the currently selected elements. The elements display in gray, indicating that you can no longer modify them during Edit Pasted mode. You can continue to move or modify any pasted elements that display in black.

- **Select All** selects all pasted elements, so that you can move or modify them.

4 Use other tools as needed to rehost building components, activate listening dimensions to refine placement, or perform other actions.

5 To complete the paste process, click (Finish).

If you want to quit Edit Paste mode, discarding the pasted elements, click (Cancel) on the Edit Pasted panel.

The pasted elements display in black. In addition, the other elements in the drawing area, which appeared gray during Edit Pasted mode, display in black.

**Pasting Aligned Elements**

1 Cut or copy elements to the clipboard.

See Moving Elements with Cut-and-Paste on page 1477 or Copying Elements to the Clipboard on page 1492.

2 Click Modify tab ➤ Clipboard panel ➤ Paste drop-down, and select one of the following options:

- **Aligned to Selected Levels**: If you copy all model elements, you can paste them into one or more levels. In the dialog that displays, choose the levels by name. To select more than one, press Ctrl while selecting the names.

- **Aligned to Selected Views**: If you copy view-specific elements (such as dimensions) or model and view-specific elements, you can paste them into similar types of views.

- **Aligned to Current View**: Pastes the elements to the current view. For example, you can paste elements from a plan view to a callout view. The view must be different from the view where the elements were cut or copied.

- **Aligned to Same Place**: Pastes the elements into the same place from where you cut or copied them. This is useful for pasting elements between worksets or design options. Also, you can use it to paste between 2 files that have shared coordinates.

- **Aligned to Picked Level**: Pastes the elements in an elevation view. You must be in an elevation view to use this tool, because it requires that you select a level line on which to paste the elements.

**NOTE** Do not pick levels using the Project Browser.

Revit Structure aligns the elements as directed.
Copying Elements with the Create Similar Tool

Use the Create Similar tool to place an element of the same type as the selected element. For example, when you right-click a door in a view and click Create Similar, the Door tool becomes active with the selected door type already chosen in the Type Selector. The Create Similar tool is available for most Revit Structure elements.

When you use Create Similar, each new element inherits family instance parameters defined in the Family Editor for the selected element. Elements created with Create Similar do not inherit values of instance parameters that were not defined in the Family Editor (such as Comments). The instance parameter values for the selected element apply to all elements created using that tool until the type is changed in the Type Selector.

For example, if the selected element is a wall, then its height properties are specified as the default for new walls. Walls created on the same level have the same Base Offset, Unconnected Height, Top Extension Distance, Bottom Extension Distance, Top Constraint, and Top Offset. If the new wall is created on a different level, the Top Constraint is set to the appropriate level.

To create similar elements:

1 Select an element.

2 Click Modify | <Element> tab ➤ Create panel ➤ (Create Similar), or right-click an element in the drawing area, and click Create Similar.

3 Click in the drawing area to place the newly created instance in the desired location. Repeat as many times as needed.

4 To exit the Create Similar tool, press Esc twice.

Modifying Elements

Revit Structure provides tools to manipulate, modify, and otherwise manage the display of elements in the drawing area.

Changing Element Types Using the Match Type Tool

Use the Match Type tool to convert one or more elements of the same category so that they match another selected type in the same category. For example, you can select a generic 12” wall, and then select other walls of various types and convert them all to generic 12” walls.

The Match Type tool copies instance parameters from the source element to target elements. These instance parameters must be defined in the Family Editor.

1 Click Modify tab ➤ Clipboard panel ➤ (Match Type Properties).

The cursor changes to a paint brush.

2 Click an element of the type to which you want to convert other elements.

The cursor paint brush is now full.
3 Click an element of the same category to convert it to the type you selected.
To convert multiple elements, continue clicking them individually, or on the Modify | Match
Type tab ➤ Multiple panel, click (Select Multiple). Draw a selection box to select the
elements, and click Finish Selection.

4 If you want to select a new type, click an open space in the drawing area (or press Esc once) to
eempty the paint brush cursor and start over.

5 To exit the tool, press Esc twice.

The following restrictions apply to the Match Type tool:

- The Match Type tool only works within one view. You cannot match types between project views.
- To match a family type or a group type from the Project Browser, make your selection in the Project
  Browser first. Then start the Match Type tool, and select the elements to be converted in the drawing
  area.
- When changing a wall’s type, the Match Type tool copies Base Offset, Unconnected Height, Top Extension
  Distance, and Base Extension Distance from the source wall type to the target wall. If the target wall is
  on the same level as the source wall, then the values for Top Constraint and Top Offset are also copied.

**Changing the Line Style of Elements**

Use the Linework tool to quickly change the line style for selected edges of model elements in a view.

For example, you can use the Linework tool to

- Differentiate cut edges and projection edges of the model
- Hide selected edges (by applying an Invisible line style)
- Reveal edges of elements that exist in the model, but are hidden in the view
- Differentiate the edges of a building in an elevation view
- Differentiate edges in an imported CAD file or a linked Revit file
Related topics

- Overriding Visibility and Graphic Display of Individual Elements on page 802
- Overriding Graphic Display of Element Categories on page 803
- Hiding Elements in a View on page 811

Linework Overview

The Linework tool does not create new model or detail lines in the view. Instead, it overrides the current line style of the selected line and applies a different line style.

You can use the Linework tool to change the line style of

- Projection edges of model elements, including silhouette edges and projection edges caused by plan regions
  
  ![Red linework applied to projection edges of a roof](image)

- Cut edges of model elements
  
  ![Blue linework applied to cut edges of a window](image)

- Edges in imported CAD files
- Edges in linked Revit files.

**NOTE** You cannot use the Linework tool to modify the line style of a dimension line or any other annotation line.

Linework and Cut Edges

In addition to using the Linework tool for projection edges, you can use it to apply other line styles to different types of cut edges of the same model element. For example, you can apply one line style to the front cut edge of a face, and another line style to the back cut edge of the same element. (A front cut edge is an edge of a model element that is generated by a section box or front clip plane. A back cut edge is an edge of a model element that is generated by the back clip plane.)
When you select an edge for the Linework tool, Revit Structure applies the same line style to all segments of that face edge. You cannot apply different line styles to different segments of the same edge. For example, the upper edge of the following wall is a single face, so the green dashed line style is applied to the entire edge.

Linework and Views

You can use the Linework tool in all types of views except drafting views and legends. You can also use the Linework tool in graphical column schedules.

In perspective 3D views, you cannot specify segments for projection edges, and you cannot change the line pattern. However, you can use different line colors and weights.

Any changes that you make to model elements using the Linework tool are view-specific. The line style change does not affect other views.

Using the Linework Tool

1. Open the view in which you want to change line styles.

2. (Optional) To turn off Thin Lines, click View tab ➤ Graphics panel ➤ (Thin Lines).

3. Click Modify tab ➤ View panel ➤ (Linework).

4. Click Modify | Linework tab ➤ Line Style panel, and select the line style to apply to the edge from the Line Style drop-down.
   For information about defining and modifying line styles, see Line Styles on page 1602.

5. In the drawing area, highlight the edge whose line style you want to change.
   For elements with multiple edges, press Tab to cycle the highlighting from individual edges to the whole element. The tooltip and the status bar identify the currently highlighted entity.

6. Click the highlighted edges to apply the selected line style.
   If you are changing the line style of a projection edge, see Changing the Line Style of a Projection Edge on page 1501.

   **NOTE** You can restore the original line style to a changed edge. With the Linework tool active, select By Category in the Line Style drop-down. Then select the edge.

7. Continue applying the selected line style to edges in the view, or select a new style in the Line Style drop-down.

8. To exit the Linework tool, press Esc.
Changing Line Styles in a Linked Model

You can use the Linework tool to change the line style for edges in a linked Revit model. To do this, you must set the view’s visibility property for the linked model to By host view.

1. In the host model, open the view in which you want to change line styles.
2. Type `VG`, or click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
3. In the Visibility/Graphic Overrides dialog, click the Revit Links tab.
4. For the linked model, if the Display Settings value is not By Host View, do the following:
   a. Click in the Display Settings cell.
   b. In the RVT Link Display Settings dialog, on the Basics tab, select By host view.
   c. Click OK twice.

Now you can use the Linework tool to change the line style of edges in the linked model. See Using the Linework Tool on page 1500.

Changing the Line Style of a Projection Edge

You can change the line style of only a part of a projection edge. When you are changing the line style for a single edge (see Using the Linework Tool on page 1500), blue controls display at each end of the edge. You can drag these controls so that the new style is applied only to a segment of the edge.

For example, the following elevation view shows a hidden line style applied to the top edge of one wall that stands behind another.
The controls can then be dragged toward each other so that the hidden line style is applied only to the segment that is obscured by the taller wall in the foreground, as follows.

If you want the entire edge to use the selected line style (instead of a segment of it), press and hold Shift, and then click the edge.

### Changing Line Styles for a View Underlay

When you use a level as an underlay in the current view and use the Linework tool on the edges of elements from that level, the elements become part of the current view, and you can modify them. See View Properties on page 873.

For example, in a Level 1 floor plan view, you can specify Level 2 as an underlay. If Level 2 has a roof, you can select the roof in the plan view and then modify it. You can even underlay the same level as the view to select a ceiling or beams or other elements that are not shown in the view. You can use the Overhead line style for tracing underlays or define your own line style. (See Line Styles on page 1602 and Halftone/Underlay on page 1605.)

### Using Hidden Lines

You can use hidden lines to display elements that are not visible in a view. For example, suppose you have an entrance on the south elevation, and you want to show an outline of this entrance using hidden lines on the north elevation.

1. Open a view where an element is obscuring an element you want to show using hidden lines. For example, in the sample above, you would open the north elevation view.
3. Click View tab ➤ Graphics panel ➤ (Show Hidden Lines).
4. In the drawing area, select the element that is obscuring the hidden element.
5. Select the element that you want to show in Hidden Line mode.
6. Click Modify to exit the Hidden Lines tool.
When you switch the view back to Hidden Line mode (on the View Control Bar, click Visual Style: Hidden Line), the obscured element is visible.

**Using Linework for Coincident Edges**

You can use linework to achieve the desired effect when several edges of model components project onto the same line. In this case, the Linework tool may not immediately produce the desired results, because each of the coincident edges is treated as a separate line.

To apply a dashed line style to one of 3 coincident edges, for example, apply the <Invisible lines> style to 2 of the edges. (See Using the Linework Tool on page 1500.) Then apply a dashed style (such as <Demolished>) to the third edge.

**Changing the Cut Profile of Elements**

Use the Cut Profile tool to change the shape of elements that are cut in a view, such as roofs, floors, walls, and the layers of compound structures. The tool is available in plan, RCP, and section views. Changes made to the profile are view-specific; that is, the element's 3D geometry and its appearance in other views does not change.

1. Click View tab ➤ Graphics panel ➤ (Cut Profile).
2. On the Options Bar, for Edit, select Face (to edit the entire boundary around the face) or Boundary between faces (to edit the boundary line between faces).
3. Move the cursor over an element in the view (for example, a compound wall). Depending on the selected Edit option, a valid cut face or a boundary line is highlighted.
4. Click the highlighted cut face or boundary to select it and enter sketch mode.
5. Sketch an area to be added to or subtracted from the selection. Use a sequence of lines that starts and ends at the same boundary line. You cannot sketch a closed loop or cross the starting boundary line. However, if you are using the Boundary Between Faces option, you can sketch over other boundaries of the face.
A control arrow displays on the first line that you sketch. It points toward the portion that will remain after editing. Click the control arrow to change its direction.

**NOTE** When you are editing a boundary line between faces, you only need to sketch the 2 boundary lines for the area. A connecting line displays between the 2 lines that you sketch. You do not need to sketch this line.

6 When finished editing, click ![Finish Edit Mode](image).  
7 To change the graphic display (such as line weight or color) of elements in the view, right-click the element, and click Override Graphics in View ➤ By Element. See Overriding Visibility and Graphic Display of Individual Elements on page 802.

**Before the Cut Profile tool**
After the Cut Profile tool

When you have 2 adjoining elements and you want to edit the profile as shown below, use the Boundary Between Faces option to achieve the desired effect.

**Measuring Elements**

The Measure tool provides a quick way to measure and temporarily display the length (and angle from the horizontal, if applicable) of individual walls or lines that you select in plan views. In elevation views, you can use this tool to select only the ends of walls running perpendicular to the view direction (to display the height of the wall). In both plan and elevation views, however, you can draw a temporary line or a chain of lines connecting points that you specify. In either case, the dimensions generated by the tool remain on the screen until you start the next measurement or exit the tool. Length dimensions also display in the Total Length box on the Options Bar.
1. Click Modify tab ➤ Measure panel ➤ Measure drop-down, and then click either (Measure Between Two References) or (Measure Along An Element).

If you select Measure Between Two References, you can measure a certain length from a starting point. Click the starting point, move the cursor in the direction that you want the line to extend, and enter a value for the length of the line.

If you select Measure Along An Element, select the element in the drawing area. Temporary dimensions display for the element and the total length displays on the Options Bar.

2. If you want to display dimensions for a chain of temporary lines that you draw, on the Options Bar, select Chain and do either of the following:
   ■ Specify a series of points.
   ■ Specify the first point, move the cursor in the direction that you want the line to extend, and enter a value for the length of the line, repeating until all lines in the chain are drawn.

   The Total Length box on the Options Bar keeps a running total for the length of the chain. Double-click to end the chain.

   **NOTE** Chain is only available when you select Measure Between Two References.

3. Press Esc once to exit the current measurement.

4. Press Esc twice to exit the Measure tool.

   **Measure line with length and angle measurements**

   **Measure chain with the total length displaying on the Options Bar**

   **Joining Geometry**

   Use the Join Geometry tool to create clean joins between 2 or more host elements that share a common face, such as walls and floors. You can also use the tool to join hosts and in-place families, or hosts and project families. As shown in the following illustrations, the tool removes the visible edge between the joined elements. The joined elements then share the same line weight and fill pattern.
When you join geometry in the Family Editor, you create a union between different shapes. In a project, however, one of the joined elements actually cuts the other according to the following scheme:

- Walls cut columns.
- Structural elements cut host elements (walls, roofs, ceilings, and floors).
- Floors, ceilings, and roofs cut walls.
- Gutters, fascias, and slab edges cut other host elements. Cornices do not cut any elements.

**To join geometry**

1. Click Modify tab ➤ Geometry panel ➤ Join drop-down ➤ (Join Geometry).
2. If you want to join the first selected geometry instance to several other instances, select Multiple Join on the Options Bar. If you do not select this option, you must make a first and second selection each time.
3. Select the first geometry to join (for example, a wall face).
4. Select the second geometry to join to the first (for example, an edge of a floor).
5 If you selected Multiple Join, continue selecting other geometry to join to the first.
6 To exit the tool, click Modify or press Esc.

NOTE If you join solids in the Family Editor, you can apply a Visibility (on/off) parameter only to the entire joined geometry, not to the sub-elements that were joined. Use Tab to toggle to the combined geometry.

Unjoining Geometry

Use the Unjoin Geometry tool to remove a join (between 2 or more elements) that was applied using the Join Geometry tool. For information on the kinds of elements that can be joined and unjoined with these tools, see Joining Geometry on page 1506.

See also Concrete Geometry Joins on page 393.

1 Click Modify tab ➤ Geometry panel ➤ Join drop-down ➤ (Unjoin Geometry).
2 Select the geometry to unjoin.
3 To exit the tool, click Modify or press Esc.

Cut Structural Member with Plane

Use the Cut Geometry tool to cut a structural member with a plane. For example, use Cut Geometry to cut a column to a certain height, or to stop a beam or bracing at a wall.

To cut a beam at a wall

1 Create a reference plane in the plane of the wall where you want the cut to occur.

2 Click Modify tab ➤ Geometry panel ➤ Cut drop-down ➤ (Cut Geometry).
3 Select the beam to be cut.
4 Select the reference plane.
   If you move the wall or the beam, the cut will persist at the wall unless the beam is no longer joined with the wall.

Coping and Remove Coping

Coping can be applied to steel members of the model, such as beams and columns. For example, in locations where beams frame into girders, Revit Structure can cope the beam around the girder. To see coping, the view Detail Level must be Medium or Fine. (See Detail Level on page 1618.)
Beam before coping is applied (left) and after coping is applied (right)

To apply coping

1 Click Modify tab ➤ Geometry panel ➤ Cope drop-down ➤ (Apply Coping).
2 Select the element to which coping is to be applied.
3 Select the column or framing with which to cut the cope.
4 To adjust the coping distance, click Modify. Select the structural framing member (beam), and on the Properties palette, specify a value for Coping Distance.
   For more information about beam parameters, see Beam Instance Properties on page 269.

To remove coping

1 Click Modify tab ➤ Geometry panel ➤ Cope drop-down ➤ (Remove Coping).
2 Select the member with coping to be removed.
3 Select framing with which the member was coped.

Splitting Elements

There are 2 ways to use Split tools:

- Split Element
- Split with Gap

Use a Split tool to divide elements into 2 separate parts, remove segments between 2 points, or to create a defined gap between 2 walls. You can split the following elements:

- walls
- lines
- beams
- braces

Splitting Elements

1 Click Modify tab ➤ Modify panel ➤ (Split Element).
2 If desired, on the Options Bar, select Delete Inner Segment. When you select this option, Revit Structure removes the segment of the wall or line between selected points.

3 Click the element at the point you wish to split. If you selected Delete Inner Segment, click at another point to remove a segment.

Splitting wall with Delete Inner Segment option selected

Wall with removed inner segment

4 When you split a wall, the resulting parts are individual walls that can be worked on independently.

Splitting Walls with a Defined Gap

To create 2 walls with a defined gap

1 Click Modify tab ➤ Modify panel ➤ (Split with Gap).
2 On the Options Bar, specify the Joint Gap dimension.

NOTE Joint Gap is limited to values between 1/16” and 1’ (Imperial).

3 Move the cursor over the wall, and click to place the gap. The wall splits into 2 independent walls.

Joining walls that are split with a gap between them

When you select a wall that was created using Split with Gap, the Allow Join symbol displays in the drawing area. If desired, select Allow Join and drag the wall to the second wall to join them. Or, right-click and select Disallow Join. This allows the wall to rejoin with no gap.

1 Select a wall that was created using Split with Gap.

2 Click to unlock the dimension constraint.
3 Select Drag Wall End (indicated by a blue circle on the selected wall), right-click, and click Allow Join.
4 Select the other wall and repeat Steps 2-3.
5 Select Drag Wall End and drag the wall to the other wall. The walls join.

Unjoining walls created using Split with Gap

1 Move the cursor over 1 of the 2 walls that was created using Split with Gap. The wall highlights.
2 Select the wall, right-click Drag Wall End (indicated by a blue circle on the selected wall), and click Select Disallow Join.
3 Drag the wall apart from the wall to which it had been joined.
Splitting Walls Horizontally

You can split a wall along a horizontal line in an elevation or a 3D view. After you split a wall, Revit Structure treats it as 2 separate walls, which means that you can modify one part independently of the other.

For example, in a 2-level building, suppose you snap the split to Level 2, and the top piece has a base constraint of Level 1. The lower wall has a height constraint of Level 2. If you split the walls at another point away from the levels, the lower wall has an explicit height constraint, while the top wall has a value for the base offset. For more explanation of these properties, see Wall Instance Properties on page 488.

1 Click Modify tab ➤ Modify panel ➤ (Split Element).
2 Place the cursor on the wall or line at the point you wish to split.

**NOTE** A stacked wall can only be split vertically.

A temporary horizontal line displays on the wall when you place the cursor near vertical edges. If desired, you can snap to levels, so you split the wall evenly between levels.

Temporary horizontal line appearing

3 Click to place the split.

A permanent horizontal line displays on the wall indicating the split.

Permanent horizontal split

Splitting Faces

You can use Split Face on any non-family instance. The Split Face tool splits the selected face of the element; it does not change the structure of the element. After splitting the face, you can use the Paint tool to apply a different material to this section of face. See Applying a Material to the Face of an Element on page 1512.

1 Click Modify tab ➤ Geometry panel ➤ (Split Face).
2 Place the cursor on the element face to highlight it. You may need to press Tab to select the desired face.
3 Click to select the face.
4 Sketch the face area to split.

**NOTE** The sketch must be in a closed loop inside the face or an open loop that ends on the boundary of the face.
Click (Finish Edit Mode).

**TIP** You can split the face of a column. However, if you plan to have multiple instances of the split-face column in your project, create the column in the Family Editor and apply the split there.

---

**Applying a Material to the Face of an Element**

The Paint tool applies a material to the selected face of the element or family; it does not change the structure of the element. (See Materials on page 1573.) Elements that you can paint include walls, roofs, massing, families, and floors. If the element highlights when you place the cursor near it, you can paint it. The Paint tool is especially useful for applying materials to split faces. See Splitting Faces on page 1511.

**To paint a surface**

1. Click Modify tab ➤ Geometry panel ➤ (Paint).
2. Click Modify | Paint tab ➤ Element panel, and select the material to apply from the Material drop-down.
3. Place the cursor on the element face to highlight it. You may need to press Tab to select the desired face.
   
   If you highlight a face that has already been painted, the status bar indicates the material that is applied to it.
4. Click to apply the paint.

**More About Painting Surfaces**

- You cannot apply materials to family instances in a project. You must apply the materials to faces in the Family Editor.
- To remove the paint, activate the Paint tool and choose <By Category> from the Material drop-down. Click a face that was painted, and the paint is removed.
- You can apply paint to the face of a column. However, if you plan to have multiple instances of the painted column in your project, create the column in the Family Editor and apply the paint there.
- When you are in the Family Editor, you can create a family parameter of type material. You can then paint that face of the family with that parameter. For more information on creating a parameter, see Creating Parameters on page 692.
Before painting (applying material to) stairs
Deleting Elements

The Delete tool removes selected elements from the drawing, but does not paste deleted elements to the clipboard.

Do one of the following:

- Select the elements to delete, and then click Modify | <Element> tab ➤ Modify panel ➤ (Delete).

- Click Modify tab ➤ Modify panel ➤ (Delete), select the elements to delete, and then press Enter.

Troubleshooting Editing Issues

Read the following topics to learn how to resolve issues encountered when editing elements in Revit Structure.
Can't Cut Instances Out of Wall

**Warning:** Can't cut instance(s) of `<element>` out of wall.

**Issue:** Revit Structure cannot regenerate the geometry to display the moved model component.

If you move a door or a window (or other wall-hosted components) in such a way that Revit Structure cannot regenerate the geometry properly, this message displays. This might happen if you move a window onto a door in a plan view. Revit Structure cannot cut both a door instance and a window instance simultaneously. Also, the error might occur if you move a component outside a wall, by either dragging the component, or shortening the wall, such that it cannot host the component.

**Solution:** You can either cancel the move or delete the particular instance.

Elements Were Deleted

**Warning:** Elements were deleted. Use Edit Pasted Elements to keep them.

**Issue:** Revit Structure requires a proper host for the copied element. For example, a window needs a wall, and a tag or dimension needs reference elements.

**Solution:** If you tried to paste an element into a location that does not contain a proper host, you see this message. Click Cancel to remove the warning. On the ribbon, click Edit Pasted Elements. In Edit Pasted mode, place the copied element on its proper host. Click Finish to complete the paste process.

**TIP** The Paste Aligned tool does not provide the Edit Pasted Elements button. If you see this message, you can cancel, and use the Paste tool instead.

Also see Editing Pasted Elements on page 1495.

Cannot Paste Selection

**Error:** Cannot paste selection in `<view_name>` view.

**Issue:** Revit Structure is unable to paste the selected element in the view.

**Solution:** If you tried to paste a wall in an elevation view or a section view, you see this message. Try pasting in a plan, reflected ceiling plan, or 3D view. This message also displays if you try to paste a group of elements that cannot be pasted into a certain view, for example, a column group into an elevation view.
Work Planes

Each view in Revit Structure is associated with a work plane. In some views (such as plan, 3D, and drafting) and for views in the Family Editor, the work plane is automatically set. In other views, such as elevation and section views, you need to set the work plane. The work plane is necessary for sketching operations such as creating an extruded roof, and for enabling tools in particular views, such as Rotate and Mirror in a 3D view.

When you set a work plane in a view, it is saved with that view. You can change the work plane as necessary.

When sketching, you can snap to the work plane grid, but you cannot align or dimension to it.

Setting the Work Plane

1. Click Home tab ➤ Work Plane panel ➤  (Set).
2. In the Work Plane dialog, under Specify a new Work Plane, select one of the following options:
   - **Name**—Choose an available work plane from the list, which contains names of levels, grids, and named reference planes.
     
     **NOTE** The list is active even if you have not selected the Name option. If you choose a name from the list, Revit Structure automatically selects the Name option.

   - **Pick a plane**—Revit Structure creates a plane coincident to the selected plane. You can select any plane that can be dimensioned, including wall faces, faces in linked Revit models, extrusion faces, levels, grids, and reference planes.

   - **Pick a line and use the work plane it was sketched in**—Revit Structure creates a work plane that is coplanar with the work plane of the selected line.

If the plane you choose is perpendicular to the current view, the Go to View dialog opens, giving you options of which view to open based on your selection.

For example, if you select a north-facing wall, the upper pane in the dialog lets you choose a parallel view (east or west elevation), or in the lower pane you can choose a 3D view, as shown.
Select a view, and click Open View.

Making the Work Plane Visible

Click Home tab ➤ Work Plane panel ➤ (Show).

The work plane appears as a grid in the view.

Work plane grid set at the level of a depression in a composite deck system

Modifying Work Plane Grid Spacing

1 If necessary, click Home tab ➤ Work Plane panel ➤ (Show), to make the work plane visible.
2 Select the work plane.

NOTE Click the edge of the work plane to select it.

3 On the Options Bar, for Spacing, enter a value to specify the desired distance between grid lines.
Rotating a Work Plane Grid

When you rotate a work plane grid, the new orientation affects placement of components and affects the rectangle draw option for walls and lines. For example, if you rotate the work plane grid and then place a component, the component is oriented on the same angle as the work plane grid. If you create a chain of walls with the rectangle option, you can create them in the orientation of the work plane grid only.

To rotate a work plane grid, see Rotating Elements on page 1481.

Elements Associated with Work Planes

If you create a family that is work plane-based, or an element that is not level-based (a hosted element), it is associated with a work plane. Work plane association controls how an element moves when its host moves. When an element is created, it inherits the work plane of the view; subsequent changes to the view work plane do not effect the element.

It is important to associate geometry to a work plane in order for geometry to move correctly. For example, you associate an element to its host via the work plane. When the host moves, the element moves as well. Most elements have a read-only instance parameter called Work Plane, which identifies the current work plane of the element. You can view this property on the Properties palette. You can change the work plane an element is associated with, or you can dissociate an element from a work plane. Some sketch-based elements, such as stairs, floors, footprint roofs, and ceilings, are sketched on a work plane, but that work plane must be a level. You cannot dissociate these element types from their work plane.

Changing the Work Plane of an Element

1. Select a work plane-based element in a view.
2. Click Modify | <Element> tab ➤ Work Plane panel ➤ (Edit Work Plane).

   **NOTE** When you use the Edit Work Plane option, the new work plane must be parallel to the existing work plane. If you need to select a work plane that is not parallel to the existing work plane, use the Rehost option. See Moving Work Plane-Based or Face-Based Elements and Components to Different Hosts on page 507.

   The Work Plane dialog displays, and the work plane grid for the element displays in the view.
3. If desired, click Show to display other views that can show the work plane for the element.
4. Select another work plane.
   See Setting the Work Plane on page 1517 for details on work plane options.

Dissociating an Element from a Work Plane

1. Select a work plane-based element in a view.
   This type of element includes any solid geometry in the Family Editor or extruded roofs in a project.
2. Click Modify | <Element> tab ➤ Work Plane panel ➤ (Edit Work Plane).
   The Work Plane dialog displays, and the work plane grid for the element displays in the view.
3. Click Dissociate.
TIP You can also dissociate an element graphically by clicking (Disassociate Work Plane), which displays near the element when you select it in the view.

When an element is no longer associated with a work plane, the value of its Work Plane parameter (on the Properties palette) is <not associated>. The element is free to move irrespective of a work plane.

Creating a Work Plane-based Family

You can create a family that is hosted by the active work plane. This can be very useful both in a project environment and within a nested family where you may need a nested sub-component to reside on a particular plane. You can make any non-hosted family a work plane-based family.

For more information about work plane-based families, see The Families Guide on page 680.

1 Open or create a non-hosted family.

NOTE Only non-hosted components can become work plane-based families.

2 In the Family Editor, Click Home tab ➤ Properties panel ➤ (Family Category and Parameters).
3 In the Family Category and Parameters dialog, under Family Parameters, select Work Plane-Based.
4 Click OK.

NOTE You can make a family both work plane-based and always vertical. Examples of both are shown below.

In the nested family below, the rectangular extrusion is a work plane-based component. On the left, the extrusion is work plane-based but not always vertical. On the right, the same extrusion was reloaded into the family after designating it work plane-based and always vertical.

Flip Control for Work Plane-based Families

After you save and load a work plane-based family into the project, you can flip it about its work plane in a view.
Select the family instance in the project, and a Flip Work Plane control displays . Click the Flip Work Plane control to rotate the family instance 180 degrees about the x-axis of the work plane. You can also right-click the instance, and click Flip Work Plane.
Reference Planes

Use the Reference Plane tool to draw reference planes to use as a guideline in your design. Reference planes are an integral part of family creation. For detailed information about creating families, see The Families Guide on page 680. Reference planes appear in each new plan view that you create for a project. See Datum Extents and Visibility on page 1527.

Adding Reference Planes

1. Click Home tab ➤ Work Plane panel ➤ (Reference Plane).
2. To draw a line:
   1. On the Draw panel, click (Line).
   2. In the drawing area, draw the reference planes by dragging the cursor.
   3. Click Modify to end the line.

3. To pick an existing line:
   1. On the Draw panel, click (Pick Lines).
2 On the Options bar, specify an offset, if desired.
3 Select the Lock option to lock the reference plane to the line.
4 Move the cursor near the line to which you want to place the reference plane and click.

Related topics
- Reference Planes on page 1523
- Naming Reference Planes on page 1524
- Reference Plane Properties on page 1524
- Datum Extents and Visibility on page 1527

Naming Reference Planes
1 In the drawing area, select a reference plane.
2 In the Properties palette, for name, enter a name for the reference plane.

Hiding the Annotation in the View
1 Select one or more annotation lines to hide.
2 Right-click and click Hide in View ➤ Elements.
   To hide the selected annotations and all other annotations of the same category in the current
   view, click Hide in View ➤ Category.

   To redisplay the hidden annotation lines, see Revealing and Unhiding Hidden Elements on page 812.

Reference Plane Properties
Use the Properties palette to modify reference plane properties.

Reference Plane Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
<td></td>
</tr>
<tr>
<td>Wall Closure</td>
<td>You can use a reference plane to define the point where walls wrap for doors and windows. Select this option to use the reference plane to define this point. This parameter is only available in the Family Editor. See The Families Guide on page 680.</td>
</tr>
<tr>
<td>Identity Data</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>The name of the reference plane.</td>
</tr>
<tr>
<td>Extents</td>
<td></td>
</tr>
</tbody>
</table>
### Name | Description
--- | ---
Scope Box | The scope box applied to the reference plane. See [Controlling Visibility of Datums Using Scope Boxes](#) on page 1531.

### Other

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is Reference</td>
<td>Specifies whether a reference plane, sketched during the creation of a family, is a reference in a project. This means that you can dimension to the family or align to it. If you set a reference plane as a reference for all family types, then you can consistently dimension to that family type when you place it in your project. For example, you create a door family with 24&quot;, 30&quot;, and 36&quot; types. For each type, you specify a reference plane as left. Then you place the new 24&quot; door type in your project and dimension it 5' from an exterior wall. Then you decide to replace that 24&quot; door with a 30&quot; door. When you swap out the doors, Revit Structure retains the 5' dimension. The Is Reference names are arbitrary and are meant as a convenient method for maintaining consistency across family types. For more information, including information on strong and weak references, see <a href="#">The Families Guide</a> on page 680.</td>
</tr>
<tr>
<td>Defines Origin</td>
<td>Specifies where the cursor rests on the object you are placing. For example, as you place a rectangular column, the cursor rests at the centerline of the column shape.</td>
</tr>
</tbody>
</table>
Datum Extents and Visibility

Datum planes, such as those for levels, grids, and reference planes are not visible in all views. If the datum does not intersect a view's plane (or does not intersect the plane in the correct way), then it will not be visible in that view.

Datum planes are modifiable. You can resize their extents so that they are visible in some views, but not others. You can also change datum extents in one view and then propagate that change to any desired parallel views in which the datum is visible.

You can also use scope boxes to control visibility of datum.

Example of Datum Visibility in Project Views

When you resize model (3D) datum extents, you can control in which view they are visible. If the datum planes do not intersect the view plane, they are not visible in the view.

In the following example, the top level line is not visible in the section view, because its model (3D) extents do not intersect it.

In the next example, the grid is visible only in the first 2 plan views, because its model (3D) extents do not intersect the third level line.
You may notice a datum intersecting a view plane but not displaying in the view. If you select the datum, you will notice that its view-specific extent intersects the view plane, but not its model extent, as the next figure shows. The open circle in the figure shows the 3D model extent, which is not intersecting the section. The filled circle is showing the 2D extent, which has intersected the section. As a result, Level 3 will not display in the section view.

Visibility of Non-Perpendicular Datums in Views

If a datum element (such as a reference plane) is not perpendicular to a view, then the datum element does not display in the view.

For example, the following floor plan shows 2 reference planes, indicated with dashed green lines. The reference plane on the left intersects the section line at an angle. The reference plane on the right is perpendicular to the section line. Because the angled reference plane is not perpendicular to the section line, the plane does not appear in the resulting section view. However, the perpendicular reference plane does display in the section view.
Visibility of Arc Grids in Views

In plan views (such as floor plans and ceiling plans), you can define grid lines that are arcs rather than straight lines. Arc grid lines will display in section views where the center of the arc intersects and is perpendicular to the section line.

For example, the following floor plan shows 2 arc grid lines. Grid Line 3 intersects the section line, but its center is not perpendicular to the section line. As a result, Grid Line 3 does not display in the section view. Grid Line 2 intersects the section line in the floor plan, and its center intersects the section line perpendicularly. Therefore, Grid Line 2 displays in the section view, indicating the center of the arc.
Resizing Datum Extent Controls

1 Select a datum.

Notice that there is a control titled 3D that displays at the ends of the datum. With the 3D designation, the datum is in Model Extent mode. This means that if you drag the control to resize the datum extent, it changes the extent of that datum in all other parallel views, provided those datums also have the 3D model extent control.

**NOTE** When you select a datum, it is selected in all views in which it is visible.

![Model extent control](image)

**Resize datum in all views**

2 Drag the hollow circle 3D control at either end of the datum to the desired location.

**Resize datum in a specific view only**

3 Click the 3D control. It changes to display 2D, and the control changes from an open circle to a filled circle. This means the datum is in view-specific mode. If you resize the datum, the change occurs in that view only.

![View-specific extent control](image)

**NOTE** When you drag the filled circle, the open circle remains. This shows where the model (3D) extent is. If you want to return to that extent, right-click the datum, and click Reset to 3D Extents.

If you drag a datum extent outside the crop boundary of the view, the control on the extent is always in view-specific (2D) mode. You also cannot propagate its extents to other views.

If you move the 2D control of a datum on top of a 3D control, the 2D control becomes a 3D control.

Maximizing 3D Model Extents

A datum may be of a certain size, such that it is not visible in all views of the model. You can change the 3D model extents to intersect the boundary of the model, so that the datum will be visible in more views.

In the following example, the grid is not visible in the 2 section views of the model, because its 3D model extents do not intersect either section view plane.
To maximize 3D model extents

1. Select the datum, and right-click it.
2. From the shortcut menu, click Maximize 3D Extents.

The grid is resized to the boundary of the model.

Propagating 2D Datum Extents

When you have modified a 2D datum to the desired extent, you may have similar views in which you want it to display the same way. You can use Propagate Extents to accomplish this.

To propagate 2D datum extents

1. Select the datum.
2. Click Modify | <datum> tab ➤ Datum panel ➤ (Propagate Extents).
3. In the Propagate Datum Extents dialog, select the parallel views in which you want the datum to look the same, and click OK.

There is no permanent connection between the look of the datum in multiple views. If you modify the datum again, you must use Propagate Extents again. Propagate Extents does not affect Model (3D) extents.

Controlling Visibility of Datums Using Scope Boxes

When you add datum elements (grids, levels, and reference lines) to a project, they can display in more views than desired. For example, when you add grid lines to a plan view, the grid lines display in all plan views of the model. However, you may want the grid lines to display in only certain views. This is exactly what a scope box is for: to specify the views in which the datum elements will display.

Scope boxes control the visibility of datum elements in views whose cutting plane intersects the scope box. Scope boxes are particularly useful to control the visibility of datums that are not parallel or orthogonal to a view.

For example, the following floor plan shows a science center with an aviary wing at an angle to the main building. The main building and the aviary wing use different grids. The matchline indicates where this
floor plan is divided into dependent views, to show each part of the building on separate sheets. (See Duplicate Dependent Views on page 843.) However, on the dependent view for the aviary wing, you do not want to show the grid lines for the main building. On the dependent view for the main building, you do not want to show the grid lines for the aviary wing. You can accomplish this using scope boxes.

To use scope boxes to control datum elements

1. Create one or more scope boxes.
2. Apply a scope box to datum elements (grid lines, levels, or reference planes).
3. (Optional) Apply a scope box to desired views.

Creating a Scope Box

You create scope boxes in plan views only. After a scope box is created, you can change its size and position in a 3D view.

1. In a plan view, click View tab ➤ Create panel ➤ (Scope Box).
2. On the Options Bar, enter a name and specify a height for the scope box, if desired.
   
   **TIP** You can also change the name of the scope box after creating it. Select the scope box, and on the Properties palette, enter a value for the Name property.

3. To draw a scope box, click in the upper left-hand corner to start the box. Click in the lower right-hand corner to finish it.
   
   The following floor plan shows 2 scope boxes: one around the main building, and another around the aviary wing. When you draw a scope box, it displays drag controls, which you can use to resize the scope box. You can also rotate the scope box using the rotate control and the Rotate tool. (See Rotating Elements on page 1481.)
4 If desired, open a 3D view to further adjust the size and position of the scope boxes.

After creating scope boxes, you need to do the following:

- Apply each scope box to datum elements.
- (Optional) Apply each scope box to the desired views.

### Applying a Scope Box to Datums

To control the visibility of datum elements in a scope box, you must associate each datum element with the scope box.

1. Select the appropriate datum element (for example, a grid line).
2. On the Properties palette, for Scope Box, select the desired scope box.

   For example, for a project with 2 scope boxes named Scope Box 1 and Scope Box 2, select Scope Box 1 from the drop-down list.

3. Click Apply.

   The datum now displays only in views whose cutting plane intersects the selected scope box. If a view's cutting plane lies outside the scope, the associated datum does not display in the view.

   For example, in the following illustration, the top view shows scope boxes around the main building and the aviary wing. Scope Box 1 was applied to grid lines for the main building, and Scope Box 2 was applied to grid lines for the aviary wing. As a result, the dependent views (bottom) show only the grid lines that apply to each part of the building.
TIP If a section view’s cutting plane intersects the scope box, the datums will appear in the section view.

**Datums Resize with Scope Box**

You can drag the extent of datums associated with scope boxes by selecting the scope box and dragging it; the associated datum moves with it.

Dragged scope box moves level lines associated with it

To revert the extents of a level datum back to its default, select the level, right-click, and click Reset to 3D Extents. The model (3D) extent cannot be moved from the edge of a scope box to which it is assigned, but the 2D extent can be modified in a view. This option returns the extent to the default position: slightly offset to the outside the scope box.
Controlling Visibility of Scope Boxes

Scope boxes are automatically visible in 3D views and any view whose cut plane intersects the scope. They can also be set to display in elevation views. You can set their visibility for other views by resizing them or changing their visibility property. Scope boxes do not print in construction documents.

Resizing a Scope Box

1. Open a plan or 3D view, and select the scope box. Handles appear on the scope box.
2. Drag the handles to resize the scope box.
   As you resize the scope box, you control the views in which it displays. If a view plane no longer cuts through the scope box, the scope box is not visible in that view. Consequently, any datums associated with that scope box do not display in that view.

For example, suppose a building has 8 floors. You resize the scope box so that its top boundary extent is at Level 4. As a result, the scope box and associated datums will not display in the plan views for Levels 5 through 8. Conversely, if you resize the scope box to intersect those levels, the datums will display in those views.

Setting the Views Visible Property for a Scope Box

The Views Visible property sets the display of a scope box in various views, including elevation views.

1. Open a view in which you can see the scope box.
2. Select the scope box.
3. On the Properties palette, for the Views Visible property, click Edit.

The Scope Box Views Visible dialog lists all the view types and view names in the project. It shows in which views the scope box is visible. Revit Structure calculates the visibility of the scope box when you create it and subsequently change its extents. The Automatic Visibility column shows the views in which the scope is automatically visible. The scope box is not automatically visible in exterior elevations, but you can override this behavior.
4 Locate the appropriate view row (for example, South Elevation), and find its value in the Override column. Click in the text box, and select Visible in the list.
5 Click OK.
   The scope box is now visible in that view.

Hiding Scope Boxes in a View

A scope box may apply to a view, but you may not want the scope box to be visible in the view.

To hide one scope box in a view

In the drawing area, select the scope box you want to hide, and do either of the following:

- Click Modify | Scope Boxes tab ➤ View panel ➤ Hide in View drop-down ➤ (Hide Elements).
- Right-click a scope box, and click Hide in View ➤ Elements.

The selected scope box is no longer visible in the view. (The scope box is still visible in other views.)

To hide all scope boxes in a view

Open the view in which one or more scope boxes display, select a scope box, and do either of the following:

- Click Modify | Scope Boxes tab ➤ View panel ➤ Hide in View drop-down ➤ (Hide Category).
- Right-click any scope box, and click Hide in View ➤ Category.

All scope boxes are no longer visible in the view.
To redisplay hidden scope boxes, see Revealing and Unhiding Hidden Elements on page 812.
Constraints

Constraints are non-view specific elements that can function independently of dimensions. Constraint elements appear in all views in which their references are visible; dimensions are view-specific. You can modify and delete constraints independently of dimensions or remove them when you delete dimensions.

You create constraints by placing dimensions and locking them or by creating equality constraints. Constraints appear as blue dashed lines in project views.

Applying Constraints with Dimensions

When you place permanent dimensions, you can lock those dimensions. When you lock a dimension, you create a constraint. A constraint (dashed blue line) appears when you select its references, as shown in the following image.

Constraint from locked dimensions

Many dimensions may correspond to the same constraint. For example, if you place a dimension between 2 walls and lock it, you have created a constraint. If you place another dimension between the same 2 walls and lock it, no additional constraint is created.

Also see Locking Permanent Dimensions on page 896.

Equality Constraints

An equality constraint appears as an EQ symbol near the dimension line when you select a multi-segmented dimension. If you select one of the references for the dimension line (such as a wall), the EQ symbol appears with a dashed blue line at the middle of the references.
The EQ symbol represents an equality constraint element applied to the references for this dimension. The references, which are walls in the graphic, remain at equal distances from one another while this constraint is active. If you select one of the walls and move it, all walls move together at a fixed distance.

**Applying an Equality Constraint**

1. Select a multi-segmented permanent dimension. If you need to place a dimension, see Permanent Dimensions on page 888.
2. Click the EQ symbol so that it no longer has a slash through it.

**Changing the EQ Label to the Dimension Value**

Multi-segmented dimensions have an EQ label that displays directly above each segment of the dimension line. The label displays when the values for all segments in the dimension are equal, or if the values for the first and last segments of the dimension are equal. If neither of these conditions is satisfied, then the dimension segment cannot display the EQ label and instead displays the value.

You can change the display of the label from EQ to the dimension value.

To change the EQ label to the dimension value:

1. Select the dimension.
2. On the Properties palette, for Equality Display, select Value.
3. Click Apply.

**Controlling Visibility of Constraints**

1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics).
2. Click the Annotation Categories tab.
3. Find the Constraints category, and deselect the check box to hide constraints in the view.

The following image shows the constraint (the blue dashed line) visible.
The following image shows the constraint hidden.

For more information, see Visibility and Graphic Display in Project Views on page 801.

**Removing Constraints**

1. Select a dimension.
2. Do any of the following:
   - Click a lock to unlock it.
   - Click the EQ symbol to remove an equality constraint. The EQ symbol appears with a slash through it when the equality constraint is not applied.
   - Delete the dimension that corresponds to the constraint. A warning appears that you are not deleting the actual constraint. Click Delete Element(s) in the warning dialog to remove the constraint.

**Constraints and Worksets**

Constraints belong to the worksets of the elements they constrain. In order to add a constraint, the worksets of all the elements that can be moved by the constraint must be editable. See Making Worksets Editable on page 1223.
You can create custom parameters for any element or component category in your project. Parameters that you create display in the Properties palette or Type Properties dialog under the group you define and with the values you define.

There are 2 types of custom parameters:

- **Shared parameters**
  Shared parameters can be shared with other projects or families. Use shared parameters when the same piece of information must exist in more than one project or family.
  For example, if a parameter in a family or a project needs to be tagged, that parameter must exist in the project (or element family) and the tag family. Therefore, taggable parameters need to be shared parameters. Shared parameters can also be used when elements of 2 different families are scheduled together. For example, if you need to create 2 different Isolated Foundation families, and need the Thickness parameter of both families scheduled in the same column, Thickness needs to be a shared parameter that is loaded in both Isolated Foundation families.

- **Project parameters**
  Project parameters are specific to a single project file. Information stored in project parameters cannot be shared with other projects. A project parameter can be used, for example, to categorize views within a project.

### Shared Parameters

Shared parameters are parameters that you can add to families or projects and then share with other families and projects. They give you the ability to add specific data that is not already predefined in the family file or the project template.

Shared parameters are particularly useful when you want to create a schedule that displays various family categories; without a shared parameter, you cannot do this. If you create a shared parameter and add it to the desired family categories, you can then create a schedule with these categories. This is called creating a multi-category schedule in Revit Structure.

Shared parameters are stored in a file independent of any family file or Revit Structure project; this allows you to access the file from different families or projects.

**Related topic**

- **Project Parameters** on page 1549
Categories Allowing Shared Parameters

Only certain categories within Revit Structure allow shared parameters. This table lists the categories that allow them.

<table>
<thead>
<tr>
<th>Family Categories Allowing</th>
<th>Additional Categories</th>
</tr>
</thead>
<tbody>
<tr>
<td>Casework</td>
<td>Areas</td>
</tr>
<tr>
<td>Ceilings: created as in-place families</td>
<td>Drawing Sheets</td>
</tr>
<tr>
<td>Columns</td>
<td>Structural Beam Systems</td>
</tr>
<tr>
<td>Curtain Panels</td>
<td>Structural Columns</td>
</tr>
<tr>
<td>Curtain Wall Mullions</td>
<td>Structural Connections</td>
</tr>
<tr>
<td>Doors</td>
<td>Structural Foundations</td>
</tr>
<tr>
<td>Electrical Equipment</td>
<td>Structural Framing</td>
</tr>
<tr>
<td>Electrical Fixtures</td>
<td>Structural Rebar</td>
</tr>
<tr>
<td>Floors: created as in-place families</td>
<td></td>
</tr>
<tr>
<td>Furniture</td>
<td></td>
</tr>
<tr>
<td>Furniture Systems</td>
<td></td>
</tr>
<tr>
<td>Generic Models</td>
<td></td>
</tr>
<tr>
<td>Lighting Fixtures</td>
<td></td>
</tr>
<tr>
<td>Mechanical Equipment</td>
<td></td>
</tr>
<tr>
<td>Parking</td>
<td></td>
</tr>
<tr>
<td>Planting</td>
<td></td>
</tr>
<tr>
<td>Plumbing Fixtures</td>
<td></td>
</tr>
<tr>
<td>Railings</td>
<td></td>
</tr>
<tr>
<td>Ramps</td>
<td></td>
</tr>
<tr>
<td>Roofs</td>
<td></td>
</tr>
<tr>
<td>Rooms</td>
<td></td>
</tr>
<tr>
<td>Site</td>
<td></td>
</tr>
<tr>
<td>Specialty Equipment</td>
<td></td>
</tr>
<tr>
<td>Stairs</td>
<td></td>
</tr>
<tr>
<td>Structural Columns</td>
<td></td>
</tr>
</tbody>
</table>
Setting Up Shared Parameter Files

You can create shared parameters in the project environment or in the Family Editor. Shared parameters are saved in a text file; you can then place this file in a shared area on your network to allow others to access it.

Shared parameters are organized in groups that you create to assist with categorization. For example, you might create a group called electrical for specific electrical parameters or a hardware group for specific hardware parameters. You can create as many groups and parameters as desired.

Your session of Revit Structure can reference only one shared parameter file at a time. If there are other shared parameters in a different file that you want in the active shared parameter file, you need to export the parameters to the active file.

Creating Shared Parameters Files, Groups, and Parameters

1. Click Manage tab ➤ Settings panel ➤ (Shared Parameters).
   The Edit Shared Parameters dialog opens.
2. Click Create.
3. In the Create Shared Parameter File dialog, enter a file name, and navigate to the desired location.
4. Click Save.
5. To add groups:
   5. In the Groups box, click New.
   6. Enter a name for the parameter group, and click OK.
6. To add parameters:
   7. From the Parameter group drop-down menu, select a group.
   8. In the Parameters group box, click New.
   9. In the Parameter Properties dialog, enter a name, discipline, and type for the parameter.
      Type specifies the format of the information you can enter for the parameter value. You can select:
      ■ Text
      ■ Integer
      ■ Number
      ■ Length
      ■ Area
      ■ Volume
      ■ Angle
You do not specify the parameter to be instance or type. You decide that later when you add the parameter to a family or a project.

When finished creating parameters, click OK.

### Related topics
- [Shared Parameters](#) on page 1541
- [Categories Allowing Shared Parameters](#) on page 1542
- [Setting Up Shared Parameter Files](#) on page 1543
- [Viewing, Moving, and Deleting Shared Parameters](#) on page 1544

### Renaming Parameter Groups

1. Click Manage tab ➤ Project Settings panel ➤ (Shared Parameters).
2. In the Edit Shared Parameters dialog, select the group from the Parameter group menu.
3. Click Rename.
4. Enter the new name, and click OK.

### Deleting Parameter Groups

1. Click Manage tab ➤ Project Settings panel ➤ (Shared Parameters).
2. In the Edit Shared Parameters dialog, select the group from the Parameter group menu.
3. Delete or move all parameters from the group.
4. Click Delete from the Groups box.

### Viewing, Moving, and Deleting Shared Parameters

After you create shared parameters, you cannot rename them or change their type. You can do the following:

- View their properties.
To view the properties of a parameter, such as its value type, click Manage tab ➤ Project Settings panel ➤ (Shared Parameters). In the Edit Shared Parameters dialog, select the parameter from the Parameters pane and click Properties from the Parameters group box.

- Move them to another parameter group.

To move a parameter to another group, click Manage tab ➤ Project Settings panel ➤ (Shared Parameters). In the Edit Shared Parameters dialog, select the parameter from the Parameters pane and click Move from the Parameters group box. Choose another group from the menu and click OK.

- Delete them.

To delete a parameter, click Manage tab ➤ Project Settings panel ➤ (Shared Parameters). In the Edit Shared Parameters dialog, select the parameter from the Parameters pane and click Delete from the Parameters group box.

**WARNING** Use care when deleting shared parameters since they may be used in other projects. If you delete a parameter and then create another parameter with the same name, Revit Structure does not consider it to be the same parameter.

---

### Adding Shared Parameters to Families

You add shared parameters to families in the Family Editor.

1. Start creating a family or open an existing one.
2. In the drawing, select the object.
3. Click Modify | <object> tab ➤ Properties panel ➤ (Family Types).
4. In the Family Types dialog, under the Parameters group box, click Add.
5. In the Parameter Properties dialog, select Shared parameter. If this option is not enabled, check to be sure you are working with a valid family category. See Categories Allowing Shared Parameters on page 1542.
6. Click Select and choose the appropriate shared parameter from the appropriate parameter group.
7. If desired, click Edit; this returns you to the Edit Shared Parameters dialog, where you can open a different shared parameter file or add new parameters.
8. Choose whether to store the parameter by instance or type.
   - For more information on instance and type properties, see Modifying Type Properties on page 38.
9. Click OK.
   - The parameter name appears in the Family Types dialog.
10. Enter a value for the shared parameter or create a formula to calculate its value.
11. Click OK when finished entering values.
12. Save the family and load it into a project.

---

### Shared and Family Parameters

If you click the Modify button in the Family Types dialog, the Parameter Properties dialog opens. You can replace a shared parameter with a family parameter or a family parameter with a shared parameter. Family parameters are specific to one family. You can also replace one shared parameter with another.
Exporting Shared Parameters to a Shared Parameter File

You can export shared parameters to a new shared parameter file if the old parameter file is deleted, or if there are shared parameters in a family or a project that are not in the current shared parameter file.

Before you can export them, you must already have added the shared parameters into a Revit Structure project file or family file. For more information on adding shared parameters, see Adding Shared Parameters to Families on page 1545 and Project Parameters on page 1549.

1 Create or open a shared parameter file.
   For more information on creating shared parameter files, see Setting Up Shared Parameter Files on page 1543.

2 Select a shared parameter in either a family or a project.
3 Click Modify.
4 In the Parameter Properties dialog, click Export.

   **NOTE** The Export option is never enabled if the selected shared parameter is already in the current shared parameter file.

A message displays informing you that the shared parameter will be exported to the shared parameter file you set up in Step 1.

5 Click OK to complete the export.

Tagging with Shared Parameters

Shared parameters are available for both single- and multi-category tags. You can apply a multi-category tag to any kind of component, regardless of its category, by applying a filter parameter to a tag.

Creating a Single-Category Tag

1 Click ➤ New ➤ (Annotation Symbol), select a template (such as, Door Tag.rft) and click Open.
   The Family Editor opens.

2 Click Home tab ➤ Text panel ➤ (Label).
3 Click in the drawing area. The Edit Label dialog opens.

4 Click (Add Parameter).
5 In the Parameter Properties dialog, click Select and select the shared parameter to add to the label.
6 Click OK twice.
   The selected parameter displays in the Category Parameters list.

7 Select the shared parameter from the Category Parameters list and click (Add parameters to label).
8 Click OK.
9 Create the tag using the Lines tool and save the file.
When you tag instances of the category in the project, the tag label displays a value only if those category instances have the external parameter. For example, you create a door tag with the shared parameter Door Trim Finish. You can then tag all doors with that tag, but the tag displays a value for Door Trim Finish only if the door has that shared parameter, otherwise a “?” appears in the tag.

Creating a Multi-Category Tag

1 Click ➤ New ➤ (Annotation Symbol), select the Multi-Category Tag.rft template for imperial, or M_Multi-Category Tag.rft for metric, and click Open. The Family Editor opens.

2 Click Home tab ➤ Text panel ➤ (Label).

3 Click in the drawing area. The Edit Label dialog opens.

4 Select one or more parameters in the Category Parameters list, and click (Add parameters to label).

5 (Optional) Include a shared parameter.

How to

1 Click (Add Parameter).

2 In the Parameter Properties dialog, click Select and select the parameter to add to the label.

3 Click OK twice. The selected parameter displays in the Category Parameters list.

4 Select the parameter from the Category Parameters list and click (Add parameters to label).

NOTE If you do not specify a filter parameter for the tag, the tag can attach to any component.

6 Click OK.

7 Create the tag using the Lines tool and save the file.

TIP If you want to change the filter parameter for the tag, click Home tab ➤ Properties panel ➤ (Family Category and Parameters). Change the value of Filter Parameter in the dialog.

Using the Multi-Category Tag in a Project

You can include shared parameters in tags for system families, such as rooms, walls, and stairs.

1 Load the multi-category tag into a project.

2 Place several components into the project that have the specific shared filter parameter.

3 Click Annotate tab ➤ Tag panel ➤ (Multi-Category).

4 If necessary, from the Type Selector on page 35, select the multi-category tag you loaded.
5 As you move the cursor in the drawing area, you can highlight only those components that have the filter parameter.

6 Click to place the tag.

**TIP** You can also use the Tag All tool to quickly tag components with the filter parameter. Click Annotate tab ➤ Tag panel ➤ ![Tag All](Tag All). In the Tag All Not Tagged dialog, select the multi-category tag and click OK.

### Related topics
- Creating a Multi-Category Tag on page 1547
- Tagging with Shared Parameters on page 1546
- Shared Parameters on page 1541

### Schedules with Shared Parameters

You can schedule shared parameters in both single- and multi-category schedules.

#### Creating a Single-Category Schedule

Follow the procedure for creating multi-category schedules. For more information, see Creating a Multi-Category Schedule on page 1548. In place of `<Multi-Category>`, choose the appropriate category, such as doors or windows. Also, the Filter tab is not available for a single-category schedule.

#### Creating a Multi-Category Schedule

1 Place several components into your project that have shared parameters.

2 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ ![Schedule/Quantities](Schedule/Quantities).

3 In the New Schedule dialog, select `<Multi-Category>` from the Category list. Click OK.

4 In the Fields tab of the Schedule Properties dialog, you notice that shared parameters are available as schedulable fields. Add the appropriate shared parameter to the scheduled fields list.

5 Click the Filter tab in the Schedule Properties dialog and choose the shared project parameter you just added. Only components that have this parameter display in the schedule.

**NOTE** If you do not specify a filter parameter for the schedule, then all family categories in your project that can have a shared project parameter will display in the schedule. See Categories Allowing Shared Parameters on page 1542.

6 Format the rest of the schedule as desired. For more information, see Specifying Schedule Properties on page 788.

7 When finished, click OK.

The schedule lists all components with the shared parameter.

**TIP** You can modify or add a shared parameter in the Fields tab of the Schedule Properties dialog. To modify a shared parameter, select it and click Edit under Scheduled fields. To add a new parameter, click Add Parameter. In both cases, the Parameter Properties dialog opens.
## Project Parameters

Project parameters are parameters you define and then add to multiple categories of elements in a project. They are specific to the project and cannot be shared with other projects. You can then use those project parameters in multi-category or single-category schedules.

### Related topics

- Including Project Parameters or Area Schemes from Linked Models in a Schedule on page 1197
- Shared Parameters on page 1541

## Creating Project Parameters

1. Click Manage tab ➤ Settings panel ➤ 🛠 (Project Parameters).
2. In the Project Parameters dialog, click Add.
3. In the Parameter Properties dialog, select Project parameter.
4. Enter a name for the project parameter.

**NOTE** It is recommended that you do not use a dash (-) when naming parameters.

5. Select a discipline.
6. Select the Type of Parameter.

<table>
<thead>
<tr>
<th>Parameter Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>A value that is entered as text. This value is completely customizable.</td>
</tr>
<tr>
<td>Integer</td>
<td>A value that is expressed as an integer.</td>
</tr>
<tr>
<td>Number</td>
<td>A value that is numeric. Can have real numbers.</td>
</tr>
<tr>
<td>Length</td>
<td>A value that is the length of an element or sub-component.</td>
</tr>
<tr>
<td>Area</td>
<td>A value that is the area of an element or sub-component.</td>
</tr>
<tr>
<td>Volume</td>
<td>A value that is the volume of an element or sub-component.</td>
</tr>
<tr>
<td>Angle</td>
<td>A value that is the angle of an element or sub-component.</td>
</tr>
<tr>
<td>Slope</td>
<td>Can be used to create parameters that define slope.</td>
</tr>
<tr>
<td>Currency</td>
<td>Can be used to create currency parameters in addition to the default Cost parameter.</td>
</tr>
<tr>
<td>URL</td>
<td>Provides a web link to a user-defined URL.</td>
</tr>
<tr>
<td>Material</td>
<td>A value that is the material for the element.</td>
</tr>
<tr>
<td>Yes/No</td>
<td>Used most often for instance properties when the parameter is defined with either a Yes or No.</td>
</tr>
</tbody>
</table>

7. Under Group parameter under, select the heading under which the parameter should display in the Properties palette or Type Properties dialog.
8 Choose whether the parameter is stored by instance or type. For more information on instance and type properties, see Modifying Type Properties on page 38.

9 Select the element categories to which you want to apply this parameter.

10 Click OK.

Creating Shared Project Parameters

1 Click Manage tab ➤ Settings panel ➤ (Project Parameters).

2 In the Project Parameters dialog, click Add.

3 In the Parameter Properties dialog, under Parameter Type, select Shared parameter, and click Select.

4 In the Shared Parameters dialog, select the appropriate parameter from the appropriate parameter group, and click OK.

   If you click Edit, the Edit Shared Parameters dialog displays. From this dialog, you can open a different shared parameter file or add new parameters. See Creating Shared Parameters Files, Groups, and Parameters on page 1543.

5 In the Parameter Properties dialog, under Categories, select the categories to which you want to apply this parameter.

   If the shared parameter provides project-specific information, select the Project Information category. You can then click Manage tab ➤ Project Settings panel ➤ (Project Information) to see or change the parameter's value.

   If the shared parameter provides sheet-specific information, select the Drawing Sheet category. The parameter is then listed in each sheet's view properties.

   TIP If you add a shared parameter to the Drawing Sheets or Project Information category, you can add the parameter to a title block family, so you can have custom parameters on the title block. See Adding Custom Fields to a Title Block on page 1003.

6 Under Parameter Data, select Instance or Type to store the parameter by element instance or family type.

   Optionally, if you select Instance you have the option to specify the parameter as a Reporting Parameter. See Reporting Parameters on page 1550.

   For more information on instance and type properties, see Modifying Type Properties on page 38.

7 For Group parameter under, select the heading under which the parameter should display in the Instance or Type Properties dialog.

8 Click OK.

Reporting Parameters

A reporting parameter is a parameter type that has its value driven by a particular dimension in the family model. Reporting parameters extract a value from a geometric condition and use it to report the data to a formula or as a schedulable parameter.

- Length, radius, angle, and arc length are available as reporting parameters. (Arc length can only be labeled as a reporting parameter.)
NOTE Area cannot be used as a reporting parameter.

- Reporting parameters are useful when a family is driven by external references that are updated based on contextual information from placed family instances, such as curtain panels or the width of a wall for the frame of a door or a window.

- For external reference cases in which the geometry depends on the specific conditions of individual family instance placement, the reporting parameter allows the dimension value to be saved and reported in the family parameter.

- A reporting parameter can be used in a formula only if its dimension references are to host elements in the family (such as levels, curtain panel boundary reference planes). If any of the dimension's references is to family geometry, the dimension can be labeled with a reporting parameter, but this parameter cannot be used in formulas.

When you create a shared project parameter, you can specify it as a reporting parameter in the Parameter Properties dialog. See Shared Parameters on page 1541 and Creating Shared Parameters Files, Groups, and Parameters on page 1543.

For example, you can create reporting parameters for the four length and four angle dimensions in a curtain panel by pattern as shown here.

Then after you place the curtain panel by pattern in a project, you can select a panel as shown here and then display the reporting parameters in the instance properties.
NOTE Use of reporting parameters is not restricted to curtain panels. For example, you can use reporting parameters to rebuild door and window families.

After creating reporting parameters, you can also create a schedule to report the data. See Schedules with Shared Parameters on page 1548.

The schedule shown here reports the four angle and four length dimensions parameters for all of the curtain wall panels.
You can use formulas in dimensions and parameters. Use conditional statements in formulas to incorporate information from parameters.

**Using Formulas for Numerical Parameters**

Formulas allow you to create parameters that depend on other parameters for their values. A simple example would be a width parameter set to equal twice the height of an object. In practice, formulas can be used in many ways, both simple and sophisticated. Typical uses include embedding design relationships, relating a number of instances to a variable length, and setting up angular relationships. For example, formulas can be used to

- Calculate area or volume of geometry
- Create a clearance dimension parameter controlled by element size
- Convert continuously variable values into integer values
- Add shelves as the height of casework increases
- Add diagonals in an open web joist as the length increases

**Valid Formula Syntax and Abbreviations**

Formulas support the following arithmetic operations: addition, subtraction, multiplication, division, exponentiation, logarithms, and square roots. Formulas also support the following trigonometric functions: sine, cosine, tangent, arcsine, arccosine, and arctangent.

The valid formula abbreviations for arithmetic operations and trigonometric functions are

- Addition— +
- Subtraction— -
- Multiplication— *
- Division— /
- Exponentiation— ^: x^y, x raised to the power of y
You can enter integers, decimals, and fractional values in formulas, using normal mathematical syntax, as shown in the examples below:

- **Length** = Height + Width + sqrt(Height*Width)
- **Length** = Wall 1 (11000mm) + Wall 2 (15000mm)
- **Area** = Length (500mm) * Width (300mm)
- **Volume** = Length (500mm) * Width (300mm) * Height (800 mm)
- **Width** = 100m * cos(angle)
- **x** = 2*abs(a) + abs(b/2)
- **ArrayNum** = Length/Spacing

Parameter names in formulas are case sensitive. For example, if a parameter name begins with a capital letter, such as Width, you must enter it in the formula with an initial capital letter. If you enter it in a formula using lower-case letters instead, for example, width * 2, the software will not recognize the formula.

**NOTE** It is recommended that you do not use a dash (-) when naming parameters.

### Conditional Statements in Formulas

You can use conditional statements in formulas to define actions in a family that depend on the state of other parameters. With conditional statements, the software enters values for a parameter based on whether a specified condition is satisfied. Conditional statements are useful in certain circumstances; however, they make families more complex and should be used only when necessary.

For most type parameters, conditional statements are unnecessary because the type parameter itself is like a conditional statement: If this is the type, then set this parameter to a specified value. Instance parameters are a more productive place to use conditional statements, particularly when they are used to set a parameter that does not vary continuously.

**Syntax for Conditional Statements**

A conditional statement uses this structure: IF (<condition>, <result-if-true>, <result-if-false>)
This means that the values entered for the parameter depend on whether the condition is satisfied (true) or not satisfied (false). If the condition is true, the software returns the true value. If the condition is false, it returns the false value.

Conditional statements can contain numeric values, numeric parameter names, and Yes/No parameters. You can use the following comparisons in a condition: <, >, =. You can also use Boolean operators with a conditional statement: AND, OR, NOT. Currently, <= and => are not implemented. To express such a comparison, you can use a logical NOT. For example, a<=b can be entered as NOT(a>b).

The following are sample formulas that use conditional statements.

**Simple IF:** =IF (Length < 3000mm, 200mm, 300mm)

**IF with a text parameter:** =IF (Length > 35', "String1", "String2")

**IF with logical AND:** =IF ( AND (x = 1, y = 2), 8, 3 )

**IF with logical OR:** =IF ( OR ( A = 1, B = 3 ), 8, 3 )

**Embedded IF statements:** =IF ( Length < 35', 2' 6", IF ( Length < 45', 3', IF ( Length < 55', 5', 8' ) ) )

**IF with Yes/No condition:** =Length > 40 (Note that both the condition and the results are implied.)

### Examples of Conditional Statement Usage

Typical uses for conditional statements in formulas include calculating array values and controlling an element’s visibility based on a parameter value. For example, you can use conditional statements to

- Prevent an array parameter from taking a value less than 2.
  - In Revit Structure, arrays can only have an integer value of 2 or greater. In some situations, it may be useful to create a conditional formula that maintains an array parameter of 2 even if the calculated value is 1 or 0. With such a formula, if the calculated array value is 2 or greater, the formula retains the value. However, if the calculated value is 1 or 0, the formula changes the value to 2.
  - **Formula:** Array number = IF (Arrayparam < 2, 2, Arrayparam)

- Make muntins visible only when the number of window lights is greater than 1.
  - For example, if you have a Lights parameter that you want to use to control the visibility of muntin geometry, you can create a Yes/No parameter like MuntinVis, and assign it to the Visible parameter on the Properties palette for the muntin geometry. Because the MuntinVis parameter is a Yes/No (or Boolean) operation, both the condition (IF) and the results are implied. In this example, when the condition is met (true), the MuntinVis parameter value is selected, and the muntin geometry is visible. Conversely, when the condition is not met (false), the MuntinVis parameter is cleared, and the muntin geometry is not visible.
  - **Formula:** MuntinVis = Lights > 1
Customize Revit

Related topics
- Customizing the Ribbon on page 22
- Quick Access Toolbar on page 25
Revit Structure provides many predefined keyboard shortcuts for Revit tools. You can change most of these keyboard shortcuts and add your own key combinations. One tool can have multiple keyboard shortcuts assigned to it. Some keys are reserved and cannot be assigned to Revit tools.

For tools on the ribbon, the application menu, or shortcut menus, keyboard shortcuts display in tooltips. (If a tool has multiple shortcuts, only the first shortcut displays in the tooltip.)

Related topic
■ Keytips on page 27

Adding Keyboard Shortcuts

1 Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Keyboard Shortcuts.
2 In the Keyboard Shortcuts dialog, locate the desired Revit tool or command, using one or both of the following methods:
   ■ In the search field, enter the name of the command. As you type, the Assignments list displays the commands that match any part of a word. For example, all matches Wall, Tag All, and Callout. The search is not case-sensitive.
   ■ For Filter, select the user interface area in which the command occurs, or select one of the following values:
     ■ All: Lists all commands.
     ■ All Defined: Lists commands for which keyboard shortcuts are already defined.
     ■ All Not Defined: Lists commands that currently have no keyboard shortcuts defined.
     ■ All Reserved: Lists keyboard shortcuts that are reserved for specific commands. These keyboard shortcuts display in the list in gray. They cannot be assigned to other commands.

If you specify search text and a filter, the Assignments list displays commands that match both criteria. If no commands are listed, select All for Filter.

The Paths column of the Assignments list indicates where the command can be found in the ribbon or user interface. To sort the list by path or another column, click the column heading.
3 Add a keyboard shortcut to a command:
   a Select the desired command from the Assignments list.
      The cursor moves to the Press new keys field.

   NOTE If the Press new keys field is gray, you cannot define keyboard shortcuts for the selected
      command. It is a reserved command with a reserved keyboard shortcut. However, each reserved
      command has a corresponding command to which you can assign keyboard shortcuts. In the
      search field, enter the command name to locate the corresponding command.

   b Press the desired key sequence.
      As you press keys, the sequence displays in the field. If needed, you can delete the contents
      of the field and press the desired keys again. See Rules for Keyboard Shortcuts on page 1563.

   c When the desired key sequence displays in the field, click Assign.

      The new key sequence displays in the Shortcuts column for the selected command.

      If a command has only one keyboard shortcut, the shortcut displays in the tooltip the next time you start
      Revit Structure. If a command has multiple shortcuts, the first shortcut in the Assignment list displays in
      the tooltip.

   Related topics
   ■ Keyboard Shortcuts on page 1559
   ■ Reserved Keys on page 1563
   ■ Using Keyboard Shortcuts on page 1562
   ■ Exporting Keyboard Shortcuts on page 1561

 Removing Keyboard Shortcuts

   You can remove keyboard shortcuts that are not reserved.

   1 Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Keyboard Shortcuts.
   2 In the Keyboard Shortcuts dialog, locate the desired command, using one or both of the following
      methods:
      ■ In the search field, enter the name of the command.
      ■ For Filter, select the user interface area in which the command occurs.

      If you specify search text and a filter, the Assignments list displays commands that match both
      criteria.

   3 In the Command column, select the desired command.
   4 In the Shortcuts column, select the shortcut to remove.

      To remove multiple shortcuts, press Ctrl while selecting the shortcuts.

   5 Click Remove.

   Related topics
   ■ Keyboard Shortcuts on page 1559
   ■ Adding Keyboard Shortcuts on page 1559
Importing Keyboard Shortcuts

You can import keyboard shortcuts from a text file or an XML file. Use this feature to

- Import a keyboard shortcuts file given to you by another user.
- Migrate a keyboard shortcuts file from a previous release (Revit Structure 2010 or later). For Revit Structure 2010, the keyboardshortcuts.txt file resides in the Program folder of a Revit installation. For later releases, KeyboardShortcuts.xml resides in the following location (only after you make changes to your keyboard shortcuts):
  - Windows XP: %USERPROFILE%\Local Settings\Application Data\Autodesk\Revit\<product name and release>
  - Windows Vista or Windows 7: %LOCALAPPDATA%\Autodesk\Revit\<product name and release>

During the import process, you can specify whether you want to

- Overwrite existing keyboard shortcuts with the imported ones. None of your current keyboard shortcuts will be preserved.
- Merge existing shortcuts with imported shortcuts. New keyboard shortcuts from the imported file are added to your keyboard shortcuts list. Your existing keyboard shortcuts are preserved.

To import keyboard shortcuts

1. Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Keyboard Shortcuts.
2. In the Keyboard Shortcuts dialog, click Import.
3. Navigate to the desired keyboard shortcuts file, select it, and click Open.
4. If you have an existing keyboard shortcuts file, a message displays asking whether you want to overwrite existing keyboard shortcuts with the imported ones, or merge them together. Select the appropriate option.

Related topics

- Keyboard Shortcuts on page 1559
- Exporting Keyboard Shortcuts on page 1561
- Using Keyboard Shortcuts on page 1562

Exporting Keyboard Shortcuts

You can export keyboard shortcuts to an XML file. You can use the XML file to

- Share your keyboard shortcuts with other users.
- Organize and print your keyboard shortcuts as a quick reference.
- Create a backup file for keyboard shortcuts.

The resulting file contains a list of all Revit tools or commands with assigned keyboard shortcuts.
To export keyboard shortcuts

1. Click View tab ➤ Windows panel ➤ User Interface drop-down ➤ Keyboard Shortcuts.
2. In the Keyboard Shortcuts dialog, click Export.
3. Navigate to the desired folder, specify a file name, and click Save.

After exporting the XML file, you can open it in a spreadsheet program, organize and enhance the information, and print it as a quick reference. Or you can send it to other Revit users, so they can import it into their Revit installations.

Related topics

- Keyboard Shortcuts on page 1559
- Importing Keyboard Shortcuts on page 1561

Resetting Keyboard Shortcuts

If you want to revert to the default keyboard shortcuts, use the following procedure. These steps discard any changes you have made to keyboard shortcuts.

1. Navigate to the KeyboardShortcuts.xml file.
   - Windows XP:
     %USERPROFILE%\Local Settings\Application Data\Autodesk\Revit\<product name and release>
   - Windows Vista or Windows 7:
     %LOCALAPPDATA%\Autodesk\Revit\<product name and release>
2. Delete KeyboardShortcuts.xml.

Using Keyboard Shortcuts

To use a keyboard shortcut in Revit Structure, press the keys of the shortcut. When you press the final key in the shortcut, Revit Structure executes the tool.

**Keyboard Shortcuts From the Status Bar**

As you press one or more keys in the shortcut, the status bar displays those keys and indicates the first matching shortcut and its corresponding tool.

- To cycle through additional matching shortcuts, press the down arrow or the right arrow.
- To reverse direction through the list of matching shortcuts, press the up arrow or the left arrow.
- To execute the tool that is currently displayed on the status bar without typing the remaining keys, press the *Spacebar*.

**NOTE** This feature does not apply to keyboard shortcuts that include Ctrl, Shift, or Alt. If only one keyboard shortcut matches the pressed keys, nothing displays on the status bar.

Related topics

- Keyboard Shortcuts on page 1559
- Adding Keyboard Shortcuts on page 1559
Rules for Keyboard Shortcuts

When adding a keyboard shortcut to a Revit tool, use the following guidelines:

- A keyboard shortcut can consist of up to 5 unique alphanumeric keys.

- You can specify a keyboard shortcut that uses Ctrl, Shift, and Alt with a single alphanumeric key. The sequence displays in the Press new keys field. For example, if you press Control and Shift and D, it displays as Ctrl+Shift+D.

- If a keyboard shortcut includes Alt, it must also include Ctrl and/or Shift.

- You cannot assign reserved keys.

- You can specify multiple keyboard shortcuts for each Revit tool.

- You can assign the same keyboard shortcut to multiple tools. To select the desired tool when you execute the shortcut, use the status bar. See Using Keyboard Shortcuts on page 1562.

Related topics

- Keyboard Shortcuts on page 1559
- Adding Keyboard Shortcuts on page 1559
- Importing Keyboard Shortcuts on page 1561

Reserved Keys

The following table lists keys and key sequences that cannot be used in keyboard shortcuts for Revit tools. They are reserved for various functions in Revit Structure, and they do not display in the Assignments list of the Keyboard Shortcuts dialog.

To see a list of reserved keyboard shortcuts, in the Keyboard Shortcuts dialog, for Filter, select All Reserved. In the Assignments list, reserved keyboard shortcuts display in gray and in angle brackets.

<table>
<thead>
<tr>
<th>Key</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+F4</td>
<td>Closes an open project.</td>
</tr>
<tr>
<td>Tab</td>
<td>Advances through options or the selection of nearby or connected elements.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Reverses through options or the selection of nearby or connected elements.</td>
</tr>
<tr>
<td>Shift+W</td>
<td>Opens SteeringWheels.</td>
</tr>
<tr>
<td>Esc</td>
<td>Cancels placement of an element. (Pressing Esc twice cancels an editor or tool).</td>
</tr>
<tr>
<td>F1</td>
<td>Opens online Help.</td>
</tr>
<tr>
<td>Enter</td>
<td>Executes an action.</td>
</tr>
<tr>
<td>Spacebar</td>
<td>Flips a selected element, changing its orientation.</td>
</tr>
</tbody>
</table>
Related topics

- Keyboard Shortcuts on page 1559
- Adding Keyboard Shortcuts on page 1559
- Rules for Keyboard Shortcuts on page 1563
Revit Structure provides many options for project customization, including project units, materials, fill patterns, line styles, and more.

**Project Information**

1. Click Manage tab ➤ Settings panel ➤ Project Information.
2. In the Instance Properties dialog, specify the following:
   - Energy Settings. Specifies parameters that define values that are exported to a gbXML file. See **Specifying Energy Analysis (gbXML) Settings** on page 1566.
   - Project Issue Date.
   - Project Status.
   - Client Name.
   - Project Address: Click Edit, enter the address in the text box, and click OK.
   - Project Name.
   - Project Number.
3. Click OK.

Project information can be included in schedules that contain elements from linked models. It can also be used in title blocks on sheets.

**Related topics**

- Including Elements from Linked Models in a Schedule on page 1196
- Specifying Title Block Information for Sheets on page 985
- Creating Shared Project Parameters on page 1550
- Adding Custom Fields to a Title Block on page 1003
Specifying Energy Analysis (gbXML) Settings

You can define the gbXML information that can be used by third-party energy analysis software. gbXML settings specify the parameter values used by third-party software applications when calculating energy use. The following parameters must be specified prior to exporting the building model to a gbXML file for use with an energy analysis application:

- **Building Type** - specifies the type of building according to the gbXML schema 0.37 (similar to ASHRAE).
- **Ground Plane** - specifies the level that serves as the ground level reference for the building. Surfaces below this level are considered to be underground. The default level is zero.
- **Project Phase** - specifies the stage of construction (Existing, New Construction).
- **Sliver Space Tolerance** - specifies the tolerance for areas that will be considered sliver spaces.

To specify gbXML settings:

1. Click Manage tab ➤ Settings panel ➤ (Project Information).
2. In the Instance Properties dialog, click Edit for the Energy Settings parameter.
3. In the Energy Settings dialog, do the following:
   - For Building Type, select one of the predefined values.
   - For Location, specify the project location.
   - For Project Phase, select Existing or New Construction.
   - For Sliver Space, specify a tolerance value for sliver spaces. All areas that are within the sliver space tolerance are considered sliver spaces.
4. Click OK twice.

Fill Patterns

Fill patterns control the appearance of surfaces that are cut or shown in projection. Use the Fill Patterns tool to create or modify drafting patterns.

Drafting Patterns

Drafting patterns represent materials in symbolic form; for example, sand is represented by a stipple pattern. The density of drafting patterns is fixed with respect to the drawing sheet.

You can place drafting patterns on planar and cylindrical surfaces and on families. You can also place drafting patterns on cut component surfaces in plan or section views.

Revit Structure includes several fill patterns and stores them in the default project template file. Alternatively, you can create your own or edit an existing fill pattern to meet your needs.

A fill pattern is stored in the file in which it was created. To save the pattern to a template file, open the template file and create the pattern there.

You can transfer fill patterns between projects using the Transfer Project Standards tool. See Transferring Project Standards on page 1635.
Creating a Simple Fill Pattern

A simple fill pattern consists of a series of parallel or orthogonal lines; examples include Diagonal Crosshatch or Vertical Siding.

To create a fill pattern using parallel lines:

1. Click Manage tab ➤ Settings Panel ➤ Additional Settings drop-down ➤ Fill Patterns.
2. In the Fill Patterns dialog, under Pattern Type, select Drafting.
3. Click New.
4. If you are creating a drafting fill pattern, select how to orient the fill pattern in the host layers. See Fill Pattern Host Orientation on page 1567 for details.
5. In the New Pattern dialog, select Simple.
6. Enter a name for Name.
7. Select Parallel lines.
8. Enter values for Line angle and Line spacing 1. For a drafting pattern, these values affect spacing on the sheet.
9. Click OK.

To create a crosshatch fill pattern:

1. Follow steps 1-6 of the previous procedure.
2. Select Crosshatch.
3. Enter values for Line angle, Line spacing 1, and Line spacing 2. For a drafting pattern, these values affect spacing on the sheet.
4. Click OK.

Fill Pattern Host Orientation

Drafting fill patterns can have different orientations to their host layers. Orientation affects how drafting patterns display when used as cut patterns in hosts (walls, floors, roofs, ceilings).

The following examples show the same fill pattern applied with the different orientation options.

- **Orient to View.** All patterns share the same orientation and origin with respect to paper, so they perfectly align at element transitions.

- **Keep Readable.** This option mimics the behavior of text. Patterns align with the host; however patterns flip 90 degrees when the host is slanted 45, 135, 225, and 315 degrees. A right diagonal pattern always stays more or less right diagonal, and a 90 degree corner has a smooth transition. Patterns share the same origin with respect to paper.
Align with Element. Patterns align with the host and compute a good origin.

For information on applying these patterns, see Creating a Simple Fill Pattern on page 1567 or Creating a Custom Fill Pattern on page 1568.

Creating a Custom Fill Pattern

1. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Fill Patterns.
2. In the Fill Patterns dialog, under Pattern Type, select Drafting.
3. Click New.
4. If you are creating a drafting fill pattern, select how to orient the fill pattern in the host layers. See Fill Pattern Host Orientation on page 1567 for details.
5. In the New Pattern dialog, select Custom.
6. Click Import.
7. Select the desired pattern file (PAT), and click Open. See Custom Pattern Files on page 1570 for information on creating a custom pattern (PAT) file.

**NOTE** Default Revit Structure fill patterns are stored in the revit.pat and revit metric.pat files in the Revit Structure program group Data directory. The revit metric.pat file contains various metric masonry and iso patterns.

8. Click the menu next to Import to view the list of available patterns. Select a pattern from the list.
9. If desired, enter a new name for Name.
10. If desired, enter a value for Import scale.
11. Click OK twice.
Applying a Fill Pattern

You can apply fill patterns to the surfaces of components and families using the Materials tool or the Paint tool. See Applying Materials to Elements on page 1576 and Applying a Material to the Face of an Element on page 1512.

Deleting a Fill Pattern

1. Click Manage tab ➤ Settings Panel ➤ Additional Settings drop-down ➤ Fill Patterns.
2. In the Fill Patterns dialog, select the appropriate fill pattern.
3. Click Delete.
4. When prompted to confirm deletion, click Yes.

**NOTE** You cannot delete the Solid fill drafting pattern.

Editing a Fill Pattern

You can edit simple fill patterns. To edit a custom pattern, you must reload the pattern from the PAT file.

**NOTE** You cannot edit the Solid fill drafting pattern.

To edit a fill pattern:

1. Click Manage tab ➤ Settings Panel ➤ Additional Settings drop-down ➤ Fill Patterns.
2. In the Fill Patterns dialog, select the pattern to modify, and click Edit.
   With a pattern name selected, you can also select Custom and import a new pattern from a PAT file; the imported custom pattern replaces the existing pattern, using the same name.
3. Follow the steps in Creating a Simple Fill Pattern on page 1567.

Working with Model Patterns

Moving Model Pattern Lines

1. In the drawing area, highlight the element that has the model pattern.
2. Press **TAB** to highlight a pattern line shape handle. See Controls and Shape Handles on page 1449. The status bar indicates if you have highlighted a shape handle.
3. Click to select the shape handle.
4. Drag the shape handle, or use the Move tool to move the pattern lines. See Moving Elements on page 1474.

Creating Dimensions to Model Pattern Lines

1. Click Annotate tab ➤ Dimension panel ➤ Linear.
2 Place the cursor on the model pattern: the cursor snaps to the pattern line, which is a reference point. You can move the cursor toward another pattern line and press \textit{TAB} to select a different reference point.

3 Place the dimension.

\section*{Rotating a Model Pattern}

1 Place the cursor on the model pattern, and press \textit{TAB} to highlight a shape handle. The status bar indicates if you have selected a shape handle.

2 Click to select the handle.

3 Click Modify | <element> tab \textgreater Modify panel \textgreater \textcircled{rotate} Rotate.

4 Rotate the pattern. See Rotating Elements on page 1481.

\section*{Aligning Model Pattern Lines to Elements}

1 Click Modify tab \textgreater Modify panel \textgreater Align.

2 Click the line on the element that you want to align with the model pattern line.

3 Place the cursor on the element that has the model pattern. Check the status bar to confirm that you have highlighted a shape handle. If the desired pattern line is not highlighted, move the cursor near the line and press \textit{TAB} again until it highlights.

4 Click to select the shape handle as the alignment reference.

\section*{Custom Pattern Files}

A pattern file is a text file that contains definitions for model or drafting patterns in a project. The file must be saved with a PAT extension. For information on using a custom pattern file, follow the procedure in Creating a Custom Fill Pattern on page 1568.

\section*{Pattern File Format}

\begin{itemize}
  \item \texttt{Units:}  
  \begin{verbatim}
  ;%UNITS={value}
  \end{verbatim}
  \item \texttt{Header:}  
  \begin{verbatim}
  *pattern-name, [optional description]
  \end{verbatim}
  \item \texttt{Type declaration:}  
  \begin{verbatim}
  ;%TYPE=MODEL
  \end{verbatim}
  \item \texttt{Pattern descriptors:}  
  \begin{verbatim}
  angle, x-origin, y-origin, shift, spacing
  \end{verbatim}
\end{itemize}
Creating a Custom Pattern

This example shows how to create a pattern of octagons and squares in the pattern file. You can use the description here to create other patterns.

The completed pattern contains octagons that are 8 inches at their widest point; both the octagon and the square are 3 5/16 inches on a side.

1 Open a text editor, such as Notepad, to begin creating the pattern file.
2 On the first line, enter the header in this format: *Concrete Paver.
3 On the next line, enter the type declaration: ;%TYPE=MODEL.
   The first value for a pattern descriptor is the angle at which the pen line is drawn. For example, a 0 angle indicates the line is horizontally straight; 90 angle indicates the line is drawn vertically straight.
4 Create the first pattern descriptor, using the following values:
   ■ Angle: 0
      This value is the angle at which the pen line is drawn. For example, a 0 angle indicates the line is horizontally straight; a 90 angle indicates the line is drawn vertically straight.
   ■ Origin: 0, 0
      These values are the x-origin and y-origin, which indicate the start point.
   ■ Shift: 5.656, 5.656
      These values establish the x-shift and y-shift, which is the x and y distance between the start of any pass and the start of the next pass.
   ■ Pen down: 3.3125
   ■ Pen up: -8
      Pen down and pen up indicate how long the pen is down and how long the pen is up, respectively. A negative number indicates the pen is up.
   The first pattern descriptor is complete:
   0, 0, 0, 5.656, 5.656, 3.3125, -8
   The pattern is as shown:
   \[ \text{Pattern 1} \]

5 Create the second pattern descriptor, using the following values:
   ■ Angle: 0
   ■ Origin: 0, 3.3125
   ■ Shift: 5.656, 5.656
   ■ Pen down: 3.3125
   ■ Pen up: -8
   The pattern is as shown:
   \[ \text{Pattern 2} \]
Because you changed the origin, the lines are drawn above the first set.

6 Create the third pattern descriptor, using the following values:
   ■ Angle: 90
   ■ Origin: 0, 0
   ■ Shift: 5.656, 5.656
   ■ Pen down: 3.3125
   ■ Pen up: -8
   The pattern is as shown:
   
   Because of the 90 angle, the lines are drawn vertically, beginning to create a square pattern.

7 Create the fourth pattern descriptor, using the following values:
   ■ Angle: 90
   ■ Origin: 3.3125, 0
   ■ Shift: 5.656, 5.656
   ■ Pen down: 3.3125
   ■ Pen up: -8
   The pattern is as shown:

8 Create the fifth pattern descriptor, using the following values:
   ■ Angle: 45
   ■ Origin: 3.3125, 3.3125
   ■ Shift: 8, 8
   ■ Pen down: 3.3125
   ■ Pen up: -4.6875
   The pattern now looks like this:

   A 45 angle has a positive slope and results in a slanted line effect.

9 Create the sixth pattern descriptor, using the following values:
   ■ Angle: -45
   ■ Origin: 3.3125, 0
   ■ Shift: 8, 8
   ■ Pen down: 3.3125
Pen up: -4.6875

The completed pattern file is:

```
*Concrete Paver,
;TYPE=MODEL
0, 0, 0, 5.656, 5.656, 3.3125, -8
0, 0, 3.3125, 5.656, 5.656, 3.3125, -8
90, 0, 0, 5.656, 5.656, 3.3125, -8
90, 3.3125, 0, 5.656, 5.656, 3.3125, -8
45, 3.3125, 3.3125, 8, 8, 3.3125, -4.6875
-45, 3.3125, 0, 8, 8, 3.3125, -4.6875
```

The completed pattern.

For information on using a custom pattern file, follow the procedure in Creating a Custom Fill Pattern on page 1568.

**Materials**

Materials define the appearance of elements in the building model. Revit Structure provides many materials that you can use, or you can create your own materials.

To search for materials to apply to model elements, or to change material properties, use the Materials dialog.

You can access the Materials dialog by clicking Manage tab ➤ Settings Panel ➤ Materials. Use the left pane of the Materials dialog to find a material. Use the right pane to change properties of the selected material. To show or hide the right pane, click Properties at the bottom of the left pane.
Materials Overview

Materials specify how model elements should display in views and rendered images. They also provide descriptive and structural information. In Revit Structure, you apply materials to elements in a building model in a project. You can also apply materials to elements when defining their families.

**NOTE** Materials do not display in wireframe views.

Materials define the following:

- The color that displays in a shaded project view
- The color and pattern that display on the surface of an element
- The color and fill pattern that display when the element is cut
- The render appearance that displays in a rendered image, and Realistic view
- Information about the material's description, manufacturer, cost, and keynotes
- Structural information about the material (for structural analysis)

Material Appearance Overview

You can add appearances to materials used in your model to provide a realistic effect. This is done using options on the Render Appearance tab in the Materials dialog. A physical material describes all aspects of a material including its appearance, metadata, and physical properties. The material appearance is the visual result of applying a material asset to a surface with any rendered view.

The Materials Browser provides a large number of appearances already created for you. It gives you access to a library of materials that are editable using controls relevant to each type of material.

The use of textures adds complexity and realism to the material. For example, you can replicate the bumps in a ceiling tile surface by using a noise texture and applying it to an object representing a ceiling in the scene.

After textures are applied to an appearance and modified to your preference, a texture can be adjusted on the object using various attributes that are available in the Texture Editor.
How Materials Are Stored

Materials are stored as part of a project file. When you create a project, Revit Structure provides many default materials to choose from. If necessary, you can create custom materials or change the settings for existing materials. New and changed materials are also saved as part of a project file.

To share custom materials with team members, click Manage tab ➤ Settings panel ➤ Transfer Project Standards. (See Transferring Project Standards on page 1635.) Be sure to also make available any custom bitmaps or image files used to define bump patterns or custom colors used by the render appearance. See Best Practice for Storing Image Files on page 1627.

For information about how render appearances are stored, see Render Appearance Library on page 1599.

Searching for a Material

1 Open the Materials dialog.

You can access the Materials dialog by clicking Manage tab ➤ Settings panel ➤ Materials, or from several other points in the software.

2 (Optional) To specify the type of list to display, at the bottom of the materials list, click Show list, Show small icons, or Show large icons.

3 (Optional) For Material Class, select the desired class (such as Concrete or Metal). The Materials dialog displays only materials that belong to the selected class.

4 (Optional) Type text in the search field.

See Entering Search Text on page 1600.

Revit Structure searches each material for the specified text, checking the fields on the Identity tab of the Materials dialog. (See Material Identity Parameters on page 1596.) If you selected a material class, Revit Structure searches only materials in that class for the specified text. To search all materials for the specified text, reset Material Class to All.

The Materials dialog displays matching materials, sorted in order of relevance.

TIP To clear the search field, click the X that displays at the end of the field after you enter text.

5 If necessary, use the scroll bar to locate the desired material in the list.

6 Click the material to select it.

Revit Structure displays properties of the selected material in the right pane of the Materials dialog.
Applying Materials to Elements

You can apply materials to model elements in any of the following ways:

**By category or subcategory**
In a project, you can apply a material to a model element based on its category or subcategory.

**By family**
In the Family Editor, when creating or modifying a component, you can use family type parameters to apply a different material to each piece of geometry in the component.

**By element parameter**
In a project, you can select a model element in a view, and use element properties to apply a material.

**By face**
In a project, you can use the Paint tool to apply a material to selected faces of model elements. See Applying a Material to the Face of an Element on page 1512.

---

**NOTE** Materials do not display in wireframe views.

---

**Applying a Material by Category or Subcategory**

1. In a project, click Manage tab ➤ Settings panel ➤ Object Styles.
2. On the Model Objects tab or the Import Objects tab, click in the Material column of the category or subcategory.
3. Click in the Material column.
4. In the Materials dialog, select a material, and click OK. See Searching for a Material on page 1575.
5. Click Apply.
6. To exit the Object Styles dialog, click OK.

In project views, all elements of the selected category or subcategory display the applied material.

---

**NOTE** Materials do not display in wireframe views.

---

**Applying a Material by Family**

1. In the Family Editor, open the family to modify. See Family Editor on page 678.
2. Link a family parameter to the object, as follows:
   a. In the drawing area, select the geometry to which you want to apply a material. See Selecting Elements on page 1439. You can assign a different material to each part of the component.
   b. On the Properties palette, for Material, click in the Value column, and click .
   c. In the Associate Family Parameter dialog, select a parameter, or create a new one.
When creating a parameter, in the Parameter Properties dialog, do the following:

- For Group parameter under, select Materials and Finishes.
- Select Instance or Type depending on whether you want to be able to change the material for an element using instance parameters or type parameters in a project.

3 Apply a material to the family parameter, as follows:

   a Click Modify | <element> tab ➤ Properties panel ➤ (Family Types).
   b In the Family Types dialog, under Materials and Finishes, locate the parameter for the object.
   c Click in the Value column for the parameter.
   d Click .
   e In the Materials dialog, select a material, and click OK.
      See Searching for a Material on page 1575.
   f Click OK.

**Applying a Material by Element Parameter**

1 In a project, open a view that displays the model element to which you want to apply a material.

   **NOTE** Materials do not display in wireframe views.

2 Select the model element.

3 On the Properties palette, locate the material parameter, as follows:

- **If the material is an instance parameter**: Under Materials and Finishes, locate the material parameter to change. Click in the Value column for the parameter.
- **If the material is a type parameter**: Click Edit Type. In the Type Properties dialog, under Materials and Finishes, locate the material parameter to change. Click in the Value column for the parameter.
- **If the material is a structural parameter**: (for example, if the element is wall) Click Edit Type. In the Type Properties dialog, for Structure, click Edit. In the Edit Assembly dialog, click in the Material column for the layer whose material you want to change.

4 Click .

5 In the Materials dialog, select a material, and click OK.
   See Searching for a Material on page 1575.

6 Click OK.

**Create and Modify Material Appearances**

You can use the Materials Editor to modify material appearances.
Modify Materials

After a material has been added to an element in your model, you can modify it in the Material Editor. The material swatches that are available in the model are displayed on the Render Appearance tab in the Materials dialog. When you click a material swatch, the properties for the material become active in the Texture Editor.

Related topics
- Changing the Display Properties of a Material on page 1578

Changing the Display Properties of a Material

To change the display properties of a material in project views, use the Graphics tab of the Materials dialog. You can change settings that define the way the material displays in shaded views, as well as the way its outer surfaces and cut surfaces display in other views. The material appearance editors, on the Render Appearance tab, give you all the necessary controls to change the display.

**NOTE** Materials do not display in wireframe views. To change the appearance of a material in rendered images, change its render appearance. For realistic rendered appearances, select the Realistic visual style. See Changing the Render Appearance of a Material on page 1582.

To change the display properties of a material

1. Open the Materials dialog, and select the material to change.
2. Click the Graphics tab.
3. To change how the material looks in shaded views (such as 3D views and elevations), under Shading, do the following:
   - If you want to use the render appearance to represent the material in shaded views, select Use Render Appearance for Shading. Revit Structure calculates an average color for the render appearance and uses it to represent the material in 2D and 3D views whose Visual Style setting is Shaded or Shaded with Edges. You can present realistic views by selecting Realistic.
• Click the color swatch. In the Color dialog, select a color. (See Colors on page 1622.) Click OK.

• For Transparency, enter a value between 0% (completely opaque) and 100% (completely transparent), or move the slider to the desired setting.

4 To change how the outer surface of the material displays in views (such as plan views and section views), under Surface Pattern, do the following:

• To change the surface pattern, click the arrow, and select a pattern from the list.

• To change the color that is used to draw the surface pattern, click the color swatch. In the Color dialog, select a color. Click OK.

NOTE In the project, you can align the surface pattern to a model element. See Aligning the Surface Pattern on a Model Element on page 1579.

5 To change how the cut surface of the material displays in views, under Cut Pattern, do the following:

• To change the cut pattern, click the arrow, and select a pattern from the list.

• To change the color that is used to draw the cut pattern, click the color swatch. In the Color dialog, select a color. Click OK.

6 Click Apply.

7 To exit the Materials dialog, click OK.

Aligning the Surface Pattern on a Model Element

In a 2D or 3D view, you can align a surface pattern on a model element. For example, you can use this technique to align the following:

• ceiling tiles with a corner of a room

• masonry to the edge of an exterior wall

Surface pattern on wall before alignment
You can align the surface pattern for each surface of a model element (not just for the model element as a whole).

Suppose you align the texture of a render appearance to the surface pattern (see Texture Alignment on page 1580), and you align the surface pattern with a model element. When you render a 3D view containing the element, the rendered image reflects the alignment of the surface pattern and the texture.

**NOTE** In drafting patterns, new textures do not apply.

**To align a surface pattern on a model element**

1. Open a project view that displays the model element with the surface pattern to align.
   - To specify a surface pattern for the material of the model element, see Changing the Display Properties of a Material on page 1578. If the surface pattern does not display in the view, you may need to change the view’s detail level to fine, or zoom in on the model element.

2. Place the cursor over a line of the surface pattern.

3. Press TAB one or more times until the surface pattern line highlights.

4. Click to select the surface pattern line.

5. Move the selected surface pattern line as desired, using one or more of the following techniques:
   - Press the arrow keys to nudge the surface pattern up, down, left, or right, in small increments.
   - Use the Move tool to move it a specified distance. See Moving Elements with the Move Tool on page 1475.
   - Use the Rotate tool to rotate the surface pattern. See Rotating Elements on page 1481.
   - Use the Align tool to select a model reference with which to align the surface.

**Texture Alignment**

Use the Texture Alignment tool to align the texture of the render appearance to the surface pattern of the material (defined on the Graphics tab of the Materials dialog). When you render a 3D view, the rendered image displays the texture, positioned as specified using the Texture Alignment tool.
Aligning the Render Appearance to the Surface Pattern

The following procedure assumes that you have done the following:

- Specified a surface model pattern for the material. See Changing the Display Properties of a Material on page 1578. This is not available in drafting views.
- Specified a texture for the render appearance of the material. See Changing the Render Appearance of a Material on page 1582.

To align the render appearance to the surface pattern


   **TIP** If the Texture Alignment button is not active, click the Graphics tab and specify a surface pattern for the material.

   The Align Render Appearance to Surface Pattern dialog displays. The preview area displays the texture specified for the render appearance, overlaid with the surface pattern for the material.

   **NOTE** If the render appearance is dark and the surface pattern uses black lines, it may be difficult to see the surface pattern. Try changing the color of the surface pattern lines to white or another light color to make them more visible.

2. Use the arrows to position the render appearance relative to the surface pattern as desired.

   To rotate the texture or change its sample size, use the render appearance properties where you specify the image file for the texture. See Specifying an Image File for a Render Appearance on page 1593.

3. Click OK.
In addition to aligning the rendering texture to the surface pattern, you can also align the surface pattern to faces of the model element, as desired. See Aligning the Surface Pattern on a Model Element on page 1579.

**Changing the Render Appearance of a Material**

1. Open the Materials dialog, and select the material to change.

   Click Manage tab ➤ Settings panel ➤ Materials, or open the dialog from another point in the software. See Searching for a Material on page 1575.

2. Click the Render Appearance tab.

   ![Render Appearance Tab](image)

3. Do the following:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the preview of the render appearance</td>
<td>For Swatch shape and render quality, select the desired scene from the list. The preview is a rendered image of the material. Updating the preview takes a moment while Revit Structure renders the preview scene.</td>
</tr>
<tr>
<td>select a different render appearance</td>
<td>Click Replace to open the Autodesk library. Select a material, for example, Concrete. Then select a swatch, for example, Blocks. Click OK. For Swatch shape and render quality, select the desired preview shape, such as Cube, and then a render quality. Click Replace. Select a render appearance. (See Searching for a Render Appearance on page 1599.) Click OK.</td>
</tr>
<tr>
<td>change the render quality</td>
<td>Under Render Appearance Based On, in the lower, right corner, select Rendered - Draft, Medium or High Quality from the Swatch shape and render quality drop-down.</td>
</tr>
<tr>
<td>align the texture of the render appearance to the surface pattern of the material</td>
<td>Click Texture Alignment on the Graphics tab. See Texture Alignment on page 1580 for further instructions.</td>
</tr>
</tbody>
</table>
If you want to... Then...

change properties of the render appearance

In the lower part of the Render Appearance tab, change property values. The properties vary depending on the type of render appearance. See Render Appearance Properties on page 1586 for further instructions.

NOTE The render appearance can affect the amount of time required to render an image. See Render Performance and Materials on page 1092.

4 Click Apply.
5 To exit the Materials dialog, click OK.

Procedural Maps

Procedural maps add further realism to a material.

Overview of Procedural Maps

Unlike bitmap images, which are produced by a fixed matrix of colored pixels, a procedural map is generated by a mathematical algorithm. Consequently, the types of controls you find for a procedural map vary depending on the capabilities of the procedure. A procedural map can be generated in either two or three dimensions. You can also nest texture or procedural maps within another procedural map to add depth and complexity to the material.

Checker

Applies a two-color checkerboard pattern to the material.

The default checker map is a pattern of black and white squares. The component checks can be either colors or maps. You can preview this map in the swatch preview.
**Gradient**

Creates gradients using colors, and blends.

You can make highly customized gradients with the Gradient procedural map. Gradient uses several colors to create shades or ramps from one to another.

**Marble**

Applies a stone and vein color pattern.

You can use the Marble map to specify stone and vein color. You can modify the vein spacing and vein width.

**Noise**

Creates random perturbation of a surface based on the interaction of two colors, texture maps or a combination.

You can use Noise to attenuate the repetitiveness aspect of bitmap and tiles. The noise procedural map uses two colors, sub-procedural maps or a combination of both to create a random pattern.
Speckle

Generates a speckled surface pattern.

The Speckle map is useful for diffuse mapping and bump mapping to create granite-like and other patterned surfaces.

Tiles

Applies a brick or stacked tiling of colors or material mappings.

You can apply an image and repeat the image as a pattern using Tiles. The Materials Browser provides commonly defined architectural brick patterns, which you can select and modify in the Materials Editor.

Waves

Simulates water or wave effects.

You can use the Bump map to simulate the surface of a body of water. The Waves map generates a number of spherical wave centers and randomly distributes them over a sphere. You can control the number of wave sets, the amplitude, and the speed of the waves. This map works effectively as both a diffuse and bump map at the same time, or combined with an opacity map.
Wood

Creates the color and grain pattern of wood.
Use the Wood map to create the realistic color and grain properties of wood.

Render Appearance Properties

The properties of render appearances vary depending on the mental ray® shaders used to render them. A shader is an algorithm that tells the program how to calculate surface rendering. Each shader requires different information to render the material accurately.

The following topics describe the render appearance properties for some of the shaders.

NOTE The render appearance can affect the amount of time required to render an image. See Render Performance and Materials on page 1092.

Ceramic Properties

You can define the following properties for ceramic materials on the Render Appearance tab of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Type of material: Ceramic or Porcelain.</td>
</tr>
<tr>
<td>Color</td>
<td>Color of the render appearance for the material. See Specifying a Render Appearance Color on page 1593.</td>
</tr>
<tr>
<td>TIP</td>
<td>To specify a grout color, use an image file that shows both the tile color and the grout color.</td>
</tr>
<tr>
<td>Image</td>
<td>Controls the base diffuse color map of the material. The diffuse color is the color that an object reflects when illuminated by direct daylight or artificial light.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Finish</td>
<td>High Gloss/Glazed, Stain, Matte. These are the texture options for the finished surface. Select a predefined finish.</td>
</tr>
<tr>
<td>Finish Bumps</td>
<td>Wavy. This is the bump pattern to use on the finished surface (for example, to represent the surface roughness). To define bumps using an image, select Custom. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
<tr>
<td>Amount</td>
<td>Relative height or depth of the bumps only when Finish Bumps is Wavy or Custom. Enter 0 to make the surface flat. Enter higher decimal values (up to 1.0) to increase the depth of the surface irregularities.</td>
</tr>
<tr>
<td>Relief Pattern</td>
<td>An additional relief pattern, superimposed on the Finish Bumps pattern (for example, to define grout lines). To define bumps using an image, select Custom. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
</tbody>
</table>

**Concrete Properties**

You can define the following properties for concrete materials on the Render Appearance tab of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Color of the render appearance for the concrete. See Specifying a Render Appearance Color on page 1593.</td>
</tr>
<tr>
<td>Image</td>
<td>Controls the base diffuse color map of the material. The diffuse color is the color that an object reflects when illuminated by direct daylight or artificial light.</td>
</tr>
<tr>
<td>Sealant</td>
<td>Substance used to seal the surface.</td>
</tr>
<tr>
<td>Finish Bumps</td>
<td>Texture of the finished surface. To define the finish using an image, select a predefined image, for example, Stamped/Custom. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
<tr>
<td>Weathering</td>
<td>Discoloration due to weather. To define a weathering pattern using an image, select Custom. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
</tbody>
</table>

**Generic Material Properties**

You can define the following properties for materials on the Render Appearance tab of the Materials dialog. In general, use a generic material when other types of rendering shaders do not provide the desired properties or controls.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Color of the render appearance for the material. This color affects the diffuse reflection as well as the transmittance of light in the material. See Specifying a Render Appearance Color on page 1593.</td>
</tr>
<tr>
<td>Image</td>
<td>Controls the base diffuse color map of the material. The diffuse color is the color that an object reflects when illuminated by direct daylight or artificial light.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Image Fade</td>
<td>Controls the composite between the base color and the diffuse image. The image fade property is only editable if an image is used.</td>
</tr>
<tr>
<td>Glossiness</td>
<td>Measurement of the glossy quality of the surface (or its roughness), which affects both reflectivity and transparency. Enter a value between 0 (dull) and 1.0 (a perfect mirror). By changing the glossiness, you can change the size and intensity of highlights. Reduce glossiness to create matte surfaces or frosted glass.</td>
</tr>
<tr>
<td>Reflectivity</td>
<td></td>
</tr>
<tr>
<td>Direct</td>
<td>Measurement of how much light the material reflects when the surface is directly facing the camera. Enter a value between 0 (no reflections) and 1 (maximum reflections).</td>
</tr>
<tr>
<td>Oblique</td>
<td>Measurement of how much light the material reflects when the surface is at an angle to the camera. Enter a value between 0 (no reflections) and 1 (maximum reflections).</td>
</tr>
<tr>
<td>Transparency</td>
<td></td>
</tr>
<tr>
<td>Transparency</td>
<td>Measurement of how much light passes through the material. Enter a value between 0 (completely opaque) and 1 (completely transparent). When Transparency is 0, Translucency and Index of Refraction are not available. See Transparency and Translucency on page 1593.</td>
</tr>
<tr>
<td>Translucency</td>
<td>Measurement of how much of the Transparency light is scattered by the material, so that objects behind the material cannot be seen clearly. Enter a value between 0 (not translucent) and 1 (completely translucent, such as frosted glass). See Transparency and Translucency on page 1593.</td>
</tr>
<tr>
<td>Index of Refraction</td>
<td>Measurement of how much a ray of light bends when it passes through the material. Select a predefined index, or select Custom to specify an index number between 0 (no refraction) and 5 (most refraction).</td>
</tr>
<tr>
<td>Cut-outs/Perforations</td>
<td></td>
</tr>
<tr>
<td>Cutouts</td>
<td>Shapes cut into the surface of the material. Select a shape, or select Custom to define cut-outs using a black-and-white image, leaving holes where the black areas occur. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
<tr>
<td>Self-Illumination</td>
<td></td>
</tr>
<tr>
<td>Luminance (cd/m²)</td>
<td>Brightness of the light emitted by the material, measured in candelas per square meter. Select a predefined value, or select Custom to enter a value.</td>
</tr>
<tr>
<td>Color Temperature (Kelvin)</td>
<td>Color temperature (warmth or coolness) of the light emitted by the material, described in terms of degrees Kelvin (K). This is useful for describing color values that are close to white. Select a predefined value, or select Custom to enter a value.</td>
</tr>
<tr>
<td>Filter Color</td>
<td>Color transmitted through a transparent or semi-transparent material, such as glass. See Specifying a Render Appearance Color on page 1593.</td>
</tr>
<tr>
<td>Bump</td>
<td></td>
</tr>
<tr>
<td>Bump Pattern</td>
<td>Bump pattern to use on the finished surface. A bump pattern defines raised and lowered areas based on dark and light areas of an image file. Select a predefined image,</td>
</tr>
</tbody>
</table>
**Property** | **Description**
--- | ---

or, to define a custom bump pattern, select Custom. See Specifying an Image File for a Render Appearance on page 1593.

**Amount**

Relative height or depth of the specified bump pattern. Enter 0 to make the surface flat. Enter higher decimal values (up to 1.0) to increase the depth of the surface irregularities.

---

**Glass Properties**

You can define the following properties for glass materials on the Render Appearance tab of the Materials dialog. See also Glass, glazing, and mirrors on page 1594.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color (Transmittance)</td>
<td>Color of the glass. (Transmittance refers to the light that passes through the glass.) Select a predefined glass color, or select Custom to specify a color. See Specifying a Render Appearance Color on page 1593.</td>
</tr>
<tr>
<td>Reflectance</td>
<td>Percentage of light striking the glass that bounces off rather than being absorbed or passing through (transmittance). Enter a value between 0% and 50%.</td>
</tr>
<tr>
<td>Refraction</td>
<td>Measurement of how much a ray of light bends when entering the glass. Select a predefined index, or select Custom to specify an index number between 0 (no refraction) and 5 (most refraction).</td>
</tr>
<tr>
<td>Roughness</td>
<td>Relative amplitude of bumps in the surface of the glass. Enter 0 to make the surface flat. Enter higher decimal values (up to 1.0) to increase the depth of the surface irregularities.</td>
</tr>
<tr>
<td>Relief Pattern</td>
<td>Relief pattern to use on the finished surface. A relief pattern defines raised and lowered areas based on dark and light areas of an image file. To define a custom relief pattern, select Custom. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
</tbody>
</table>

**Glazing Properties**

You can define the following properties for glazing materials on the Render Appearance tab of the Materials dialog. See also Glass, glazing, and mirrors on page 1594.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color (Transmittance)</td>
<td>Color of the glazing. (Transmittance refers to the light that passes through the glazing.) Select a predefined glazing color, or select Custom to specify a color. See Specifying a Render Appearance Color on page 1593.</td>
</tr>
<tr>
<td>Reflectance</td>
<td>Percentage of light striking the glass that bounces off again (like a reflection) rather than being absorbed or passing through (transmittance). Enter a value between 0% and 50%.</td>
</tr>
<tr>
<td>Sheets of glass</td>
<td>Number of sheets of glass in the glazing system that are modeled in the geometry and rendered in images. Enter a number to define how many sheets of glass you want.</td>
</tr>
</tbody>
</table>
Masonry/CMU Properties

You can define the following properties for masonry or CMU materials on the Render Appearance tab of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Type of masonry material.</td>
</tr>
<tr>
<td>Color</td>
<td>Color of the material. See Specifying a Render Appearance Color on page 1593.</td>
</tr>
<tr>
<td>Finish</td>
<td>Texture of the finished surface.</td>
</tr>
<tr>
<td>Relief Amount</td>
<td>Pattern to use on the finished surface. A bump pattern defines raised and lowered areas based on dark and light areas of an image file. To define a custom bump pattern, select Custom. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
</tbody>
</table>

Metal Properties

You can define the following properties for metal materials on the Render Appearance tab of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Type of metal: aluminum, anodized aluminum, chrome, copper, brass, bronze, stainless steel, or zinc. Each type of metal displays different properties.</td>
</tr>
<tr>
<td>Color</td>
<td>Color of the metal when the Type value is Anodized Aluminum. Click the color swatch. In the Color dialog, select a color. (See Colors on page 1622.) Click OK.</td>
</tr>
<tr>
<td>Patina</td>
<td>For copper or bronze, the degree of discoloration due to oxidation or the application of a chemical compound. Enter a value between 0 (none) and 1 (full), or use the slider.</td>
</tr>
<tr>
<td>Finish</td>
<td>Texture of the finished surface.</td>
</tr>
<tr>
<td>Relief Pattern</td>
<td>Decorative design pressed onto the surface of the metal. Select a pattern, or select Custom to define the relief pattern using an image. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
<tr>
<td>Relief Pattern Height</td>
<td>Relative height of the relief pattern. Enter 0 to make the surface flat. Enter a value up to 2.0 to increase the depth of the relief pattern.</td>
</tr>
<tr>
<td>Relief Pattern Scale</td>
<td>Relative size of the relief pattern. Enter a value between 0 (smaller) and 5 (larger), or use the slider.</td>
</tr>
<tr>
<td>Cutouts</td>
<td>Shapes cut into the surface of the metal. Select a shape, or select Custom to define cut-outs using a black-and-white image, leaving holes where the black areas occur. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
</tbody>
</table>
### Metallic Paint Properties

You can define the following properties for metallic paint materials on the **Render Appearance tab** of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Color of the metallic paint. Click the color swatch. In the Color dialog, select a color. (See Colors on page 1622.) Click OK.</td>
</tr>
<tr>
<td>Flecks</td>
<td>Texture of the finished surface.</td>
</tr>
<tr>
<td>Top Coat</td>
<td>Type: Car Paint, Chrome, Matte, Custome. The top coat of paint appearance. Select from a predefined value.</td>
</tr>
<tr>
<td>Finish</td>
<td>Smooth, Orange Peel.</td>
</tr>
</tbody>
</table>

### Mirror Properties

You can define the following properties for mirror materials on the **Render Appearance tab** of the Materials dialog. See also Glass, glazing, and mirrors on page 1594.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tint Color</td>
<td>Color of the mirror surface. Click the color swatch. In the Color dialog, select a color. (See Colors on page 1622.) Click OK.</td>
</tr>
</tbody>
</table>

### Paint Properties

You can define the following properties for paint materials on the **Render Appearance tab** of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Color of the paint. Click the color swatch. In the Color dialog, select a color. (See Colors on page 1622.) Click OK.</td>
</tr>
<tr>
<td>Finish</td>
<td>Amount of glossiness of the paint.</td>
</tr>
<tr>
<td>Application</td>
<td>The method used to apply the paint to the surface. This value applies a bump map to the paint to define its texture. It affects the render appearance of the surface only for close-up views. The default value varies. Select the desired value: Roller, Brush, or Spray.</td>
</tr>
</tbody>
</table>

### Plastic/Vinyl Properties

You can define the following properties for plastic or vinyl materials on the **Render Appearance tab** of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Type of material: plastic (solid), plastic (transparent), or vinyl.</td>
</tr>
<tr>
<td>Color</td>
<td>Color of the material. See Specifying a Render Appearance Color on page 1593.</td>
</tr>
</tbody>
</table>
### Stone Properties

You can define the following properties for stone materials on the Render Appearance tab of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image File</td>
<td>Image to use to represent the stone’s surface. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
<tr>
<td>Finish</td>
<td>Texture of the finished surface.</td>
</tr>
<tr>
<td>Finish Bumps</td>
<td>Bump pattern to use on the finished surface. To define bumps using an image, select Custom. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
<tr>
<td>Bump Pattern</td>
<td>Additional bump pattern, superimposed on the Finish Bumps pattern. To define bump pattern using an image, select Custom. See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
</tbody>
</table>

### Water Properties

You can define the following properties for water materials on the Render Appearance tab of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Type of water source.</td>
</tr>
<tr>
<td>Color</td>
<td>Color of the water (available when Type is not Swimming Pool). Select a predefined water color, or select Custom to specify a color.</td>
</tr>
<tr>
<td>Wave Height</td>
<td>Relative height of waves in the water. Enter a value between 0 (no waves) and 5 (big waves), or use the slider.</td>
</tr>
</tbody>
</table>

### Wood Properties

You can define the following properties for wood materials on the Render Appearance tab of the Materials dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image File</td>
<td>The image to use to represent the surface of the wood (the wood grain). See Specifying an Image File for a Render Appearance on page 1593.</td>
</tr>
</tbody>
</table>
## Transparency and Translucency

When defining a render appearance that uses **Generic Material Properties**, remember that reflections on a surface are created by light bouncing off it. Of the light that strikes a surface, the Transparency and Translucency properties specify the amount of light that bounces off the surface rather than passing through or being absorbed by it.

Transparency specifies the amount of light that strikes the surface at a 90-degree angle and bounces off. Translucency specifies the amount of light that strikes the surface at a very shallow angle (close to 0 degrees) and bounces off.

To determine the amount of light that bounces off the surface at any other angle, Revit Structure interpolates between these 2 values. The effects of these values can be altered by the value of the Glossiness property.

## Specifying a Render Appearance Color

To specify a color for a render appearance property, use the Color control on the Render Appearance tab of the Materials dialog. (See Changing the Render Appearance of a Material on page 1582.) You can specify either a single color or an image file that defines a custom color, design, or pattern. This is accessed from the drop-down on the Image panel.

- **Single color**: For the Color property, select Edit Color on the Color drop-down. Click the color swatch. On the Color dialog, select the color to use. (See Colors on page 1622.) Click OK.

- **Image file**: For the Color property, select the Image drop-down. Specify the desired image file and its display properties, or select Edit Image. See Specifying an Image File for a Render Appearance on page 1593.

## Specifying an Image File for a Render Appearance

To use a unique color, design, pattern, texture, or bump map for a render appearance, you can specify an image file. You specify the file and its display properties (such as rotation and sample size) on the Render Appearance tab of the Materials dialog. (See Changing the Render Appearance of a Material on page 1582.)
NOTE  A complicated design or texture for a render appearance can increase the amount of time required to render an image. It is recommended not bringing in images that exceed 10K bit. See Render Performance and Materials on page 1092.

To specify an image file

1. For Image, click the image that is displayed to open the Texture Editor.
   Revit Structure supports image files of the following types: BMP, JPG, JPEG, and PNG. See Best Practice for Storing Image Files on page 1627.

2. For Sample Size, specify the size that the image represents.
   For example, if the image represents 100 mm, enter 100.

3. Under Position, for Rotate, specify degrees of rotation in a clockwise direction.
   You can enter a value between 0 and 360, or use the slider.

4. If you are specifying an image file to define a custom color, for Brightness, specify a value.
   Brightness is a multiplier, so a value of 1.0 makes no change. If you specify 0.5, the brightness of the image is reduced by half.

5. To reverse the image, click Invert.
   For an image that defines a color, Invert reverses the light and dark colors in the image. For an image that defines a texture, Invert reverses the high and low points of the texture pattern.

6. For texture properties, such as Finish Bumps and Bump Pattern, specify a value for Amount.
   This value specifies the amplitude of surface irregularities. Enter 0 to make the surface flat. Enter higher values to increase the depth of the surface irregularities.

Best Practices for Render Appearances

When modifying or creating render appearances for materials, consider the following strategies:

Start with something similar

To create a render appearance, first find an existing material and render appearance that are as close as possible to the new material and render appearance. For example, the existing render appearance should have the same class as the new render appearance. It should also have many properties that are the same as or similar to the new render appearance. This strategy reduces the amount of work you must perform to define the new render appearance. It also increases the likelihood that the new render appearance will perform as expected.

Glass, glazing, and mirrors

Revit Structure provides the following render appearances for glass-like materials:

- **Glass**: Use a glass render appearance for objects made of glass, such as vases and pitchers. For a solid glass block, use the render appearance named Glass Block.

- **Glazing**: Use a glazing render appearance for windows, curtain walls, and other objects that require flat sheets of thin glass. These render appearances include the word glazing in their names and keywords.

- **Mirrors**: Depending on your needs, you can either use a mirror render appearance, or use a glazing or glass render appearance and specify a high Reflectance value.

To see these render appearances, in the Render Appearance Library, for Class, select Glass.
Textures and bump maps

To specify a texture or bump map for a material, use a photo, image or procedure map. Revit Structure uses the image to define the surface to give it texture. See Specifying an Image File for a Render Appearance on page 1593.

Tileable textures

If you want to make your own texture that can be repeated like a tile (a tileable texture), use tiles and define a map image.

Light bulbs

If you want the surface of a light bulb to display in a rendered image, create geometry for it in the lighting fixture family. Then apply a material to it whose render appearance is Glass Light Bulb On. This render appearance mimics the surface of a light bulb that is turned on. It is white, shiny, and emits the appropriate amount of light. See Creating a Lighting Fixture with One Light Source on page 1038.

Sunscreens

To create a material that renders like a semi-transparent fabric or sunscreen, start with the Fabric Mesh render appearance. Then define the render appearance properties as follows: Glossiness = 1, Transparency = 1, Translucency = 0, Luminance = No self-illumination.

Changing Material Identity Data

1 Open the Materials dialog, and select the material to change.

   Click Manage tab ➤ Settings panel ➤ Materials. See Searching for a Material on page 1575.

2 Click the Identity tab.
3 Edit the parameters as necessary.
   See Material Identity Parameters on page 1596 and Adding a Material Class on page 1595.
4 Click Apply.
5 To exit the Materials dialog, click OK.

Adding a Material Class

You can add a material class when you want to make it easy to find a particular set of materials. For example, when you create a custom material, you can create a material class for it.

NOTE You cannot delete or change existing material classes. However, you can assign a different material class to a material.

To add a material class

1 In the Materials dialog, select the material that you want to assign to a new material class.
   See Searching for a Material on page 1575.
2 Click the Identity tab.
3 For Material Class, enter the new material class name.
4 Click Apply.
In the left pane of the Materials dialog, under Materials, click the list arrow for Material Class. The new material class displays in the list.

You can assign the new material class to more materials, as appropriate. You can also use the new material class to narrow the scope of a material search.

### Material Identity Parameters

When you enter search text to find a material, Revit Structure searches the values of all parameters on the Identity tab of the Materials dialog. (See Searching for a Material on page 1575.) Also, you can include most of these parameters in a material takeoff. (See Material Takeoff Schedules on page 774.)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Filter Criteria</strong></td>
<td></td>
</tr>
<tr>
<td>Material Class</td>
<td>Class assigned to the material. Assign an existing class, or create a new one. See Adding a Material Class on page 1595.</td>
</tr>
<tr>
<td><strong>Descriptive Information</strong></td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>Description of the material. This value displays in material tags for elements. See Material Tags on page 948.</td>
</tr>
<tr>
<td>Comments</td>
<td>User-defined comments or other information about the material. If the value is Render appearance not upgraded, assign a new render appearance to the material. See Changing the Render Appearance of a Material on page 1582.</td>
</tr>
<tr>
<td>Keywords</td>
<td>Words that may be useful when searching for the material, and that are not used in the material description, comments, or other fields.</td>
</tr>
<tr>
<td><strong>Product Information</strong></td>
<td></td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Name of the manufacturer of the material.</td>
</tr>
<tr>
<td>Model</td>
<td>Model number or code assigned to the material by the manufacturer.</td>
</tr>
<tr>
<td>Cost</td>
<td>Cost of the material.</td>
</tr>
<tr>
<td>URL</td>
<td>URL of the Web site for the manufacturer or vendor.</td>
</tr>
<tr>
<td><strong>Annotation Information</strong></td>
<td></td>
</tr>
<tr>
<td>Keynote</td>
<td>Keynote for the material. Enter text or click the button to select a standard keynote. See Keynotes on page 938.</td>
</tr>
<tr>
<td>Mark</td>
<td>User-defined identification number for the material.</td>
</tr>
</tbody>
</table>

### Changing Material Physical Data

The Physical tab of the Materials dialog displays structural information about the selected material. This information is used in the structural analysis of buildings.
Creating a Material Physical Parameter Set

1 In the Materials dialog, select a material. See Searching for a Material on page 1575.
2 Click the Physical tab.
3 Select a Material Type.
   Revit Structure displays an additional category based on the selected material type.
4 Edit parameter values as needed for the new set.
5 Click Save As to save a set by name.
   The name of the new set then becomes available in the Concrete Type list box (if you had selected concrete as the material type) or Wood Type list box (if you had selected wood as the material type) and so on.

Editing a Material Physical Type

1 In the Materials dialog, select a material. See Searching for a Material on page 1575.
2 Click the Physical tab.
3 Change the settings to the desired values.
   Read-only parameters represent the natural material properties. Those that you can change represent standards of engineering practice.

Material Physical Type Parameters

Material physical type parameters are organized into the following types:

- Unassigned
- Generic
- Concrete
- Steel
- Wood

This family parameter controls the hidden view display of structural elements. If the Structural Material Type of an element is set to Concrete or Precast, then it will display as hidden. If it is set to Steel or Wood, it will be visible when another element is in front of it. If it is set to Unassigned, the element will not display if hidden by another element.

Creating a Material

To create a material, first find an existing material that is as close as possible to the new material. For example, the existing material should have the same material class as the new material. It should also have many properties that are the same as or similar to the new material. This strategy reduces the amount of work you must perform to define the new material. It also increases the likelihood that the new material will perform as expected in the building model.
To create a material

1 In the Materials dialog, select an existing material that is similar to the new material.
   See Searching for a Material on page 1575.

2 At the bottom of the left pane of the Materials dialog, click (Duplicate).
   Or you can right-click a material in the list, and click Duplicate.

3 In the Duplicate Revit Material dialog, for Name, enter a name for the new material, and click OK.

4 On the Graphics tab of the Materials dialog, specify display properties for the new material, and click Apply.
   See Changing the Display Properties of a Material on page 1578.

5 On the Render Appearance tab of the Materials dialog, specify a render appearance for the new material, and click Apply.
   See Changing the Render Appearance of a Material on page 1582.

6 On the Identity tab of the Materials dialog, enter information about the new material, and click Apply.
   See Changing Material Identity Data on page 1595 and Adding a Material Class on page 1595.

7 (Optional) On the Physical tab of the Materials dialog, specify physical parameters for the new material, and click Apply.
   See Changing Material Physical Data on page 1596.

8 To exit the Materials dialog, click OK.
   See Applying Materials to Elements on page 1576.

Renaming a Material

1 Click Manage tab ➤ Settings panel ➤ Materials.
2 In the Materials dialog, select the material to rename.
   See Searching for a Material on page 1575.

3 At the bottom of the left pane of the Materials dialog, click (Rename).
   Or you can right-click a material in the list, and click Rename.

4 In the Rename dialog, enter a new name for the material, and click OK.
5 In the Materials dialog, click Apply.

Deleting a Material

1 Click Manage tab ➤ Settings panel ➤ Materials.
2 In the Materials dialog, select the material to delete.
   See Searching for a Material on page 1575.

3 At the bottom of the left pane of the Materials dialog, click (Delete).
Or you can right-click a material in the list, and click Delete.

4 At the confirmation prompt, click Yes.

Revit Structure deletes the material from the project. If the material was applied to elements in the building model, Revit Structure applies a default material to them instead.

**Importing ADSK Files**

You can open or import ADSK files from Inventor that contain both a DWG with Protein 2.0 appearances, and any user-created image files associated with those appearances. The appearances defined in the ADSK file will be displayed in Revit Structure and become available for use in the Revit Structure file. User-defined appearances in imported files will not become available in the appearance library. Revit Structure materials will be created to display them and these materials can be applied to Revit Structure elements. Appearances that use images in the Autodesk image library will have access to those same image files in Revit Structure without the images being included in the ADSK file.

**NOTE** When importing ADSK files, this version of Revit Structure can open only valid ADSK files created in Autodesk® Inventor, versions R2009 or R2010. ADSK files created in Revit Structure are intended for use by AutoCAD Civil 3D only.

**Render Appearance Library**

The Render Appearance Library is a local, read-only library for render appearances. You assign render appearances to materials using the Materials dialog.

When you change the properties of a render appearance, the modified render appearance is stored as part of the project file. It is not stored in the read-only Render Appearance Library.

To share a modified render appearance with team members, click Manage tab ➤ Settings panel ➤ Transfer Project Standards. Be sure to also make available any custom bitmaps or image files used to define bump patterns or custom colors used by the render appearance.

**Related topics**

- Changing the Render Appearance of a Material on page 1582
- Transferring Project Standards on page 1635
- Best Practice for Storing Image Files on page 1627
- How Materials Are Stored on page 1575
- Additional Render Appearance Paths on page 1627

**Searching for a Render Appearance**

You can specify render appearances for materials and entourage. The following procedure assumes that you have already opened the Render Appearance Library as part of the following task.

- Changing the Render Appearance of a Material on page 1582
You can also open the Render Appearance Library to search for materials by clicking Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Render Appearance Library.

**To search for a render appearance**

1. (Optional) To specify the type of list to display, at the bottom of the render appearance list, click Show list, Show small icons, or Show large icons.

2. Type text in the search field.

See *Entering Search Text* on page 1600. The Render Appearance Library displays matching render appearances, sorted in order of relevance.

**TIP** To clear the search field, click the X that displays at the end of the field after you enter text.

3. If necessary, use the scroll bar to locate the desired render appearance in the list.

4. Click the render appearance to select it.

   At the bottom of the Render Appearance Library, Revit Structure displays a description and keywords for the selected render appearance.

5. Click OK.

**Entering Search Text**

When searching for materials or render appearances, you can enter search text in the box of the dialog.

The search is not case-sensitive. Use commas, spaces, or semi-colons as delimiters. Revit Structure automatically performs an OR search on multiple words. In the Render Appearances search, Revit Structure automatically performs an AND search.

Revit Structure searches each item for the specified text, checking its description and keywords. If you selected a class, Revit Structure searches only items in that class for the specified text.

The dialog displays matching items, sorted in order of relevance. Items that match all of the search words display at the top of the list. Items that match fewer search words display near the bottom of the list.

**TIP** To clear the search field, click the X that displays at the end of the field after you enter text.

**Related topics**

- Searching for a Render Appearance on page 1599
- Searching for a Material on page 1575
Object Styles

The Object Styles tool specifies line weights, line colors, line patterns, and materials for different categories and subcategories of model objects, annotation objects, and imported objects in a project.

You can override project object styles on a view-by-view basis. For more information, see Visibility and Graphic Display in Project Views on page 801.

Creating Object Style Subcategories

1. Click Manage tab ➤ Settings panel ➤ Object Styles.
2. Click the Model Objects, Annotation Objects, or Imported Objects tab.
3. In the Object Styles dialog under Modify Subcategories, click New.
4. In the New Subcategory dialog, enter a name.
5. Select the Category for Subcategory of.
6. Click OK.

Modifying Object Styles

1. Click Manage tab ➤ Settings panel ➤ Object Styles.
2. Click the Model Objects, Annotation Objects, or Imported Objects tab.
3. Specify the projection, and, if applicable, cut line weights for the category.
   This enables you to control the display of geometry when it is cut and not cut without having to create separate subcategories. For imported geometry layers, specify the appropriate line weight.
4. Click the color value to set the line color.
5. Select a line pattern.
6. Click the button in the Material field to open the Materials dialog. Select a material for the family category from the Material column. You can override the material for the family by changing its material type property. For imported geometry, specify a material for the layer. This is not available for annotation objects.
7. When you are finished, click OK.

Deleting an Object Style

You can delete any user-created object style.

1. Click Manage tab ➤ Settings panel ➤ Object Styles.
2. Select the category name to delete.
3. Click Delete.
4. When prompted to confirm the deletion, click Yes.
Renaming an Object Style

You can rename any user-created object style.

1. Click Manage tab ➤ Settings panel ➤ Object Styles.
2. Select the category name.
3. Click Rename.
4. In the Rename dialog, enter a new name.
5. Click OK.

Line Styles

Line styles are used to indicate different effects, such as a dashed (-----) line for reference planes. When you install and run Revit Structure, several line styles are included. Each predefined line style has a name that describes either the line (for example, Dash dot), or where Revit Structure uses the line style (for example, <Sketch> lines). Revit Structure stores the line styles in the default template.

When you are in the Family Editor, you cannot create new line styles, but you can modify line weight, line color, and line pattern.

Creating a Line Style

**NOTE** You can only create line styles in the project environment. You can modify line weight, line color, and line pattern in the Family Editor. See Modifying Line Styles in the Family Editor on page 1603.

1. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Styles.
2. In the Line Styles dialog, click New, and enter a new name for the line style.
   The name displays under Category in the Line Styles dialog.
3. Click the value for Line Weight to choose a line weight.
4. Click the value for Line Color to choose a line color.
5. Click the value for Line Pattern to choose a line pattern.
6. Click OK.

The new line style is stored in the project only.

Deleting a Line Style

You can delete any user-created line styles.

1. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Styles.
2. In the Line Styles dialog, select the line style name.
3. Click Delete.
4. When prompted to confirm the deletion, click Yes.
Modifying Line Styles in the Family Editor

1 Click Manage tab ➤ Settings panel ➤ Object Styles.
2 In the Object Styles dialog, click the Model Objects, Annotation Objects, or Imported objects tab.
3 Click in the Line Weight, Line Color, or Line Pattern cell for the category you want to modify and make changes as necessary.
4 When finished, click OK.

Line Weights

You can control line weights for model lines, perspective lines, and annotation lines.

For model lines, you can specify line weight for modeling components, such as doors, windows, and walls, in orthographic views. Line weight is dependent on the scale of the view.

For perspective lines, you can specify line weights for modeling components in perspective views. You may want to apply different line styles and line weights using the Linework tool. For more information, see Changing the Line Style of Elements on page 1498.

For annotation lines, you can control the line weight of annotation objects, such as section lines and dimension lines. The weights of annotation symbols are not dependent on the scale of the design.

Specifying Line Weights

1 Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Weights.
2 In the Line Weights dialog, click the Model Line Weights, Perspective Line Weights, or Annotation Line Weights tab.
3 Click a cell in the table and enter a value.
4 Click OK.

Adding Scales to Model Line Weights

1 Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Weights.
2 In the Line Weights dialog, click the Model Line Weights tab, and then click Add.
3 In the Add Scale dialog, select a scale value, and click OK.
4 Click OK to close the Line Weights dialog.

Deleting Scales

1 Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Weights.
2 In the Line Weights dialog, click the Model Line Weights tab, and then select the View Scale header.
3 Click Delete.
4 Click OK.

Line Patterns

You can specify the pattern for the line styles used in Revit Structure. Several predefined line patterns are provided with Revit Structure, or you can create your own. Line patterns are a series of dashes or dots alternating with blank spaces.

Creating a Line Pattern

1 Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Patterns.
2 In the Line Patterns dialog, click New.
3 In the Line Pattern Properties dialog, enter a name for the pattern.
4 Click in the value for Type, and select either a dash or a dot.
5 If you selected a dash, click under Value, and enter a value. This is the length of the dash. Because dots are all drawn at 1.5 points, they do not require an associated value.
6 In the next row, select space for Type. Revit Structure requires that you follow a dash or dot with a space.
7 Click under Value, and enter a value for the space.
8 Repeat the procedure until the pattern is complete.
9 Click OK.
10 In the Line Patterns dialog, the new line pattern displays in the list of available patterns.
11 Click OK.

The new line pattern is stored in the project only.

Editing a Line Pattern

1 Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Patterns.
2 In the Line Patterns dialog, select the line pattern you wish to modify, and click Edit.
3 Make any necessary changes.
4 Click OK.

Deleting a Line Pattern

1 Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Patterns.
2 In the Line Patterns dialog, select the line pattern.
3 Click Delete.
4 When prompted to confirm the deletion, click Yes.
Halftone/Underlay

Revit Structure lets you control the line weight and pattern used for underlays, and the brightness of halftone elements. When printing views or sheets, you can specify that halftones print as thin lines to retain print fidelity.

To define Halftone/Underlay settings

1. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ (Halftone/Underlay).
2. In the Halftone/Underlay dialog, under Underlay, define the following settings:
   - **Weight**: Specifies the line weight for underlays. Select a value from the list. See Line Weights on page 1603.
   - **Pattern**: Specifies the line pattern for underlays. Select a value from the list, or click ... to modify an existing pattern or create a new one. See Line Patterns on page 1604.
   - **Apply halftone**: Applies halftone to underlay graphics.
3. Under Halftone, for Brightness, enter a value or use the slider to specify a setting between Light and Dark. This setting blends the line color of an element with the background color of the view to the specified amount.
4. Click OK.

To specify that halftones print as thin lines, use Print Setup options. See Print Setup on page 1147.

Structural Settings

For each project, you can control the symbolic representation of structural framing components. You can specify the symbolic cutback distance of beams and columns (see Cutback on page 275), brace symbols in plan, moment symbols, and analytical model adjustment. The values you specify are applied to structural framing components throughout the project. You can also save these settings as part of a template.

**NOTE** Most of the settings in the Structural Settings dialog are available if the project was created using the structural template.

Structural Settings Dialog

The Structural Settings dialog lets you modify settings that are specific to documentation and analysis of structural models. These settings include Symbolic Representation Settings, Load Cases, Load Combinations, Analytical Model Settings, and Boundary Conditions Settings.

Symbolic Representation Settings Tab

The values that are entered on this tab reflect the plotted representation of the drawings. Therefore, the visible representations that are set with these values will change based on the view scale of the drawing.
Open Structural Settings dialog

1 Click Manage tab ➤ Settings panel ➤ Structural Settings.

Modify symbolic cutback distance

2 On the Symbolic Representation Settings tab, enter a value for the symbolic cutback distance for brace, and beam/truss.

Structural Representation Settings tab

This setting affects the distance between steel beams and beams/trusses, and between beams and braces. Members must be joined to see the change in the cutback distance. Changes to this setting are applied only to the symbolic representation of structural framing components.

Cutback distance at larger setting in coarse mode

Cutback distance at smaller setting in coarse mode

3 Enter a value for the symbolic column cutback distance.

This setting affects the gap between symbolic representations of joined columns in an elevation view. The gap is visible only if the Top Connection Symbol instance property of the bottom column is set to a value other than None.

Plan representation options:

4 Under Brace Symbols, select a value for Plan representation.

Plan Representation options

- Parallel Line:
  Symbolic representation of braces in a plan view are displayed with a line parallel to and offset from the brace at the value specified in the Structural Settings dialog. The line displays below, or to the right to vertical brace centerline if the brace is below the level and above, or to the left to vertical brace centerline if the brace is above the level.

NOTE The parallel line brace symbol displays in a symbolic plan view only when the structural usage of the brace is set to Vertical Bracing.
Line with Angle:
Symbolic representation of braces in a plan view are displayed with an angled line. Line with angle originates from the point of intersection of a brace and level if they intersect, and from the closest point to the level on the brace otherwise. The symbol goes upward (downward) for the portion of the brace which is above (below) the level.

NOTE The line with angle brace symbol displays in a symbolic plan view only when the structural usage of the brace is set to Vertical Bracing.

5 Under Brace Symbols, specify Parallel line offset.
This value is available only after selecting Parallel Line for Plan representation. The parallel line is offset the specified value from the vertical brace centerline.

NOTE You can create new brace representation symbols using the generic annotation template. In the Family Category and Parameters dialog, set their Family Category to Brace in Plan View Symbols. Brace in Plan View symbols have a Representation Type parameter that can be either Parallel Line, Line with Angle, or Kicker Brace.

Show brace above

6 Under Brace Symbols, select Show brace above if you want the brace symbols representing the braces above the current view to display.

Show brace above

7 For Symbol, select the symbol that represents braces above the current view.

NOTE The brace above symbol changes automatically when you change the plan representation from parallel line to angle line.

Show brace below

8 Under Brace Symbols, select Show brace below if you want the brace symbols representing the braces below the current view to display.

Show brace below
9 For Symbol, select the symbol that represents braces below the current view.

**NOTE** The brace below symbol changes automatically when you change the plan representation from parallel line to angle line.

**Kicker brace symbol**

10 Under Brace Symbols, select the symbol that represents kicker bracing.

**NOTE** The kicker brace symbol displays in a symbolic plan view only when the structural usage of the brace is set to Kicker Bracing.

**Loading and Assigning Connection Symbol Families**

Connection symbols display at the ends of the symbol of beams, braces, and columns. You can define your own connection types, and assign a connection symbol family to each type. The types are divided into beam/brace end connections, column top connections, and column base connections.

11 In the Connection Symbols section, select Display Symbols for Beams and Braces.

12 Click Load.

13 Navigate to the Annotations/Structural directory, select a connection symbol family, and click Open.

14 Select the Annotation Symbol from the drop-down for the Connection Type.

15 Click OK.
NOTE: Use the following tools to manage your connection types.

- **Add a connection type**
  - Opens the New Connection Type dialog. Name and assign an annotation symbol to the connection type. You can optionally load a new symbol, if needed. Click OK to continue.

- **Duplicate a connection type**
  - Duplicates a selected connection type. Rename and assign an Annotation Symbol as needed.

- **Rename a connection type**
  - Opens the Rename dialog to change the name of the selected connection type.

- **Delete a connection type**
  - Deletes the selected connection type.

---

**Load Cases Tab**

For information on how to use the Load Case Tab in the Structural Settings dialog, see Load Cases on page 1304.

**Load Combinations Tab**

For information on how to use the Load Combinations Tab in the Structural Settings dialog, see Load Combinations on page 1305.

**Analytical Model Settings Tab**

For information on how to use the Load Case Tab in the Structural Settings dialog, see Analytical Model Settings on page 1285.

**Boundary Conditions Settings Tab**

For information on how to use the Load Case Tab in the Structural Settings dialog, see Boundary Conditions Settings on page 1321.

**Annotation Styles**

You can create or modify leader arrowhead, text note, dimension, and loaded tag styles in a project.

**Specifying Arrowhead Styles**

1. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Arrowheads.
2. In the Type Properties dialog, select the arrowhead type you want to work with from the Type list.
If desired, click Rename to rename the type, or click Duplicate to create a new arrowhead type.

Specify the properties for the display of leader arrowheads. See Leader Arrowhead Properties on page 938 for property descriptions.

Click OK.

Specifying Text Note Styles

1 Click Annotate tab ➤ Text panel ➤ .
2 In the Type Properties dialog, select the text properties you want to work with from the Type list.
3 If desired, click Rename to rename the type, or click Duplicate to create a new text type.
4 Specify the properties for the display of text notes.
   See Modifying Text Note Properties on page 936.
5 Click OK.

Specifying Dimension Styles

You can specify the style of linear, angular, or radial dimensions, as well as spot elevations, spot coordinates, and spot slopes.

1 Click Annotate tab ➤ Dimension panel drop-down, and select one of the options.
2 In the Type Properties dialog, select the dimension type you want to work with from the Type list.
3 If desired, click Rename to rename the type, or click Duplicate to create a new dimension type.
4 Specify the dimension display properties. See Dimension Properties on page 916 for property descriptions.

Related topics

■ Specifying Arrowhead Styles on page 1609
■ Placing Permanent Dimensions on page 889
■ Spot Dimensions on page 902
■ Dimensions on page 887

Modifying Reinforcement Tag Abbreviations

You can customize reinforcement-specific tagging abbreviations for both area and path annotations in a project. This is achieved with the Abbreviations settings.

1 Click Home tab ➤ Reinforcement panel drop-down ➤ Abbreviations
2 In the Abbreviations dialog, click either Area Reinforcement or Path Reinforcement.
   Along the left-hand side of either dialog is a list of possible annotation abbreviations (Setting).
   Along the right-hand side is the editable abbreviations (Value). The default values display in the following dialogs.
3 Select and highlight a value.
4 Edit the abbreviation as it should read in annotation.
5 Click OK to accept the abbreviation change.

The following illustrations show the default abbreviations and modified examples as they display in a project.

<table>
<thead>
<tr>
<th>Default Abbreviations</th>
<th>Modified Abbreviations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Area Reinforcement</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Path Reinforcement</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Modified Abbreviations

For more information on tagging reinforcement, refer to Tagging Area Reinforcement on page 438 and Tagging Path Reinforcement on page 443.

Loading Tag Styles

1 Click Annotate tab ➪ Tag panel drop-down ➪ Loaded Tags.

The Tags dialog displays, listing the different family categories and any associated tags. Depending on the project template, some element categories may have default tags loaded.

2 Click Load.

You can load multiple tags for element categories.

3 Navigate to the location of the tag, and open the tag. You can select multiple tag files by holding either SHIFT or CTRL while selecting. The tag name displays adjacent to the element category.

4 When you are finished loading tags, click OK.

The last loaded tag for an element category becomes the default tag for that element.

Related topics

- Tags on page 944
- Applying a Tag By Category on page 945
- Tag All Not Tagged on page 947

Specifying the Default Tag for an Element Category

1 Click Annotate tab ➪ Tag panel drop-down ➪ Loaded Tags.

2 In the Tags dialog, click in the Value column for an element category, and then select a tag name.

NOTE You can also specify the default tag when you click Insert tab ➪ Load From Library panel ➪ Load Family to load a tag. This loaded tag becomes the default. See Loading Families on page 688.
**Project Units**

You can specify the display format of various quantities in a project. What you specify affects the look of quantities on the screen and in a printout. You can format data for informational or presentation purposes.

Project units are grouped by discipline, such as common, structural, or electrical. When you change the discipline, different unit types are available. In the Project Units dialog, each unit type has a preview of the display format. For example, length might have a display format of 1’ 5 1/2”.

**NOTE** The actual display of editable values that affect the size of the model may be different. For example, you might specify the display of dimensions to round to the nearest 1 inch; however, if you edit a dimension value in the drawing area, it may show a value that has fractional inches.

**Setting Project Units**

1. Click Manage tab ➤ Settings panel ➤ Project Units.
2. In the Project Units dialog, select the discipline.
3. Click the value in the Format column to change the display value for that unit type. The Format dialog displays.
4. Specify Units, if necessary.
5. For Rounding, select an appropriate value. If you select Custom, enter a value in the Rounding increment text box.
6. For Unit symbol, select an appropriate option from the list.
7. Optionally select:
   - Suppress trailing 0’s
     When selected, trailing zeros do not display (for example, 123.400 displays as 123.4).
   - Suppress 0 feet
     When selected, does not display the 0 foot value (for example, 0’ - 4” displays as 4”). This option is available for Length and Slope units.
   - Show + for positive values
   - Use digit grouping
     When selected, the Decimal symbol/digit grouping option specified in the Project Units dialog is applied to the unit value.
   - Suppress spaces
     When selected, suppresses spaces around feet and fractional inches (for example, 1’ - 2” displays as 1'-2”). This option is available for Length and Slope units.
8. Click OK.

**Changing Decimal Display and Digit Grouping**

1. Click Manage tab ➤ Settings panel ➤ Project Units.
2. In the Project Units dialog, select a value from the Decimal symbol/digit grouping list.
3. In the Format column, click the button for the unit you want to use this setting.
4. In the Format dialog, select Use digit grouping.
5 Click OK twice.

**Snaps**

When you place an element or component, or sketch a line (straight, arc, or circle), Revit Structure displays snap points and snap lines to assist in lining up elements, components, or lines with existing geometry. Snap points depend on the type of snap, but are represented in the drawing area as shapes (triangles, squares, diamonds, and so on). Snap lines are represented as dashed green lines in the drawing area.

The following illustration shows the green dashed snap line and a midpoint snap point (triangle).

You can enable or disable object snaps, and specify dimension snap increments. You can also override snap settings using keyboard shortcuts. You set snap settings in the Snaps dialog, and the settings are held for the duration of the Revit Structure session. Snap settings apply to all files open in the session, but are not saved with a project.

**Jump Snaps**

Jump snaps are any snap points that are away from the current position of the cursor. For example, if you are resting the cursor on the midpoint of a wall, a jump snap might display at the endpoint of the wall.

Jump snaps occur when you clear the check box for the Nearest object snap in the Snaps dialog.

**Setting Snap Increments**

When you place an element or component in a project view, it snaps to set dimension increments. For example, when you are sketching a wall and move the cursor from left to right in the drawing area, you see the dimensions for the wall increase according to the defined length dimension snap increments. Likewise, when you place an element by an angle, angle snap dimensions increase according to the defined angle dimension snap increments.

You can define multiple length and angle snap increments because increments change as you change your zoom level (the closer you zoom in, the smaller the increment; the further you zoom out, the larger the increment).

**To set snap increments:**

1. Click Manage tab ➤ Settings panel ➤ Snaps.
2. Select Length dimension snap increments and Angular dimension snap increments to turn on the snaps.
3. Enter the snapping increment values, separating increments with semicolons. There is no limit to the number of increments you can specify.
4 Click OK.

**Enabling and Disabling Snaps**

1. Click Manage tab ➤ Settings panel ➤ Snaps.
2. Do one of the following:
   - Select Snaps Off to disable all snapping in the project.
   - Select or clear the appropriate object snaps. For object snap descriptions, see Object Snaps and Snap Shortcut Key Combinations on page 1617.
3. Click OK.

You can also enable and disable snaps by right-clicking and selecting Snap Overrides ➤ Snaps Off after you have selected an element or component to place in the drawing area.

**Temporarily Overriding Snap Settings**

When you are working in a project, you can use shortcut key combinations or the right-click shortcut menu to temporarily override snap settings. Temporary overrides affect a single pick only.

For example, if you need a one-time snap to the center of an arc, you type SC or select Snap Overrides ➤ Centers from the context menu, so that only arc centers are recognized as a snap option. After you make a pick, snapping returns to the settings specified in the Snaps dialog.

To temporarily override snap settings:

1. Choose the component or element you want to place. For components or elements that require more than one pick (for example, a wall), select the component and make the first pick.
2. Do one of the following:
   - Type the shortcut key combination.
   - Right-click, click Snap Overrides, and select an option.

See Object Snaps and Snap Shortcut Key Combinations on page 1617 for object snap descriptions and snap shortcut key combinations.

3. Place (or finish placing, for components or elements that require more than one pick) the component or element.

**Snap Points**

Components snap to reference planes and other components of the same category.

The following is a list of snap conditions for first and second points.

**First or Second Point Snapping**

**Snap Collinear to Existing Line**—Snaps a point to be collinear to existing geometry.

**Snap to Line**—Snaps point to an existing line or geometry. The cursor also snaps to the midpoint of a line.
Snap Tangent to an Arc—Snaps a point tangent to an existing arc end.

Snap to Endpoint or Center Point—Snaps a point to endpoint of straight or arc, or to arc or circle center.

Second Point or Whole Line Snapping Only

Horizontal or Vertical snap—When sketching a straight line, Revit Structure snaps the line to be perfectly horizontal or vertical when the cursor approaches horizontal or vertical.

Horizontal snap

Vertical snap

Snap Parallel to Existing Line—Snaps a line parallel to existing geometry.

Snap Perpendicular to Existing Line—Snaps a line perpendicular to existing geometry.
**Object Snaps and Snap Shortcut Key Combinations**

The following table defines the object snaps listed in the Snaps dialog (Manage tab ➤ Settings panel ➤ Snaps) and the shortcut key combinations for these objects. Shortcut key combinations override snap settings for one pick.

<table>
<thead>
<tr>
<th>Object Snap</th>
<th>Shortcut Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Endpoints</td>
<td>SE</td>
<td>Snaps to the endpoint of an element or component.</td>
</tr>
<tr>
<td>Midpoints</td>
<td>SM</td>
<td>Snaps to the midpoint of an element or component. When placing a wall insert, such as a window, door, or opening, you can use the midpoint override, SM, to snap the insert to the midpoint of the wall segment.</td>
</tr>
<tr>
<td>Nearest</td>
<td>SN</td>
<td>Snaps to the nearest element or component. If you turn off the Nearest object snap by clearing the check box or using the keyboard override, Revit Structure allows jump snaps to endpoints, midpoints, and centers. A jump snap is a snap point that is more than 2 mm away from the cursor on the screen.</td>
</tr>
<tr>
<td>Work Plane Grid</td>
<td>SW</td>
<td>Snaps to a work plane grid.</td>
</tr>
<tr>
<td>Quadrants</td>
<td>SQ</td>
<td>Snaps to quadrant points. For arcs, jump snaps are enabled.</td>
</tr>
<tr>
<td>Intersections</td>
<td>SI</td>
<td>Snaps to intersections.</td>
</tr>
<tr>
<td>Centers</td>
<td>SC</td>
<td>Snaps to the center of an arc.</td>
</tr>
<tr>
<td>Perpendicular</td>
<td>SP</td>
<td>Snaps to perpendicular elements or components.</td>
</tr>
<tr>
<td>Tangents</td>
<td>ST</td>
<td>Snaps tangent to an arc.</td>
</tr>
<tr>
<td>Points</td>
<td>SX</td>
<td>Snaps to site points when editing points using the Move or Copy tool.</td>
</tr>
<tr>
<td>Snap to Remote Objects</td>
<td>SR</td>
<td>This is similar to jump snaps. When you select this option, snaps look for objects that are not near the element.</td>
</tr>
<tr>
<td>Close</td>
<td>SZ</td>
<td>Snaps to close valid open loops. See Closing an Open Loop on page 1418.</td>
</tr>
<tr>
<td>Turn Override Off</td>
<td>SS</td>
<td>Turns off snap overrides.</td>
</tr>
<tr>
<td>Cycle through snaps</td>
<td>Tab key</td>
<td>Cycles through the available snap options.</td>
</tr>
<tr>
<td>Object Snap</td>
<td>Shortcut Key</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Reverse direction when cycling through snaps</td>
<td>Shift+Tab</td>
<td>Cycles through the available snap options in reverse order.</td>
</tr>
<tr>
<td>Force Horizontal and Vertical</td>
<td>Shift key</td>
<td>Forces horizontal and vertical constraints.</td>
</tr>
<tr>
<td>Snaps Off</td>
<td>SO</td>
<td>Disables all snap settings.</td>
</tr>
</tbody>
</table>

**Temporary Dimension Settings**

You can specify the display and placement of temporary dimensions in the design. You can set temporary dimensions to:

- measure from wall centerlines, wall faces, center of core, or core faces
- measure from door and window centerlines or door and window openings

**To specify temporary dimension settings:**

1. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Temporary Dimensions.
2. From the Temporary Dimension Properties dialog, select the appropriate settings.
3. Click OK.

**Detail Level**

You can set the detail level for newly created views based on a view scale. View scales are organized under the detail level headings Coarse, Medium, or Fine. When you create a new view in your project and set its view scale, its detail level is automatically set according to the arrangement in the table.

By predefining detail levels, you can affect the display of the same geometry at different view scales.

You can override the detail level at any time by setting the Detail Level parameter in the view properties. See View Properties on page 873.

For information on detail levels and the display of structural components, see Detail Levels and Display of Structural Components on page 861.

**Setting Detail Level Scale Values**

1. Click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Detail Level.
2. Click ➤ to move scale values to the right or click ➤ to move detail levels to the left. You cannot select scales individually; they move in sequential order only.
3. To return to the original settings, click Default.
Specifying the Detail Level for a View

Use one of the following methods:

- Right-click in the drawing area, and click Properties. Then, on the Properties palette, for Detail Level, select Coarse, Medium, or Fine.
- On the View Control Bar at the bottom of the drawing area, click the Detail Level icon, and select an option.

Related topics
- Detail Level on page 1618
- Setting Detail Level Scale Values on page 1618
- Detail Levels and Display of Structural Components on page 861

Managing Family Visibility and Detail Level

Visibility of a family determines in which view the family displays and what it looks like in that view. Typically, when an element is created by a family, the geometry of the element will change, depending on the current view. In a plan view, you may want to see a 2D representation of the element. In a 3D or elevation view, you may want a fully detailed 3D representation of the element. You have the flexibility to display different levels of geometry.

Detail Level determines the visibility of elements at different levels of detail. You control the detail level in a project view with the Detail Level option on the View Control Bar.

You can set the visibility and detail level of any 2D and 3D geometry in the family after you create it. Families are either cuttable or non-cuttable. If a family is cuttable, the family displays as cut when the cut plane of a plan view intersects that family in all types of views. If the family is non-cuttable, it displays in projection, regardless of whether it is intersected by the cut plane.

You can determine if a family category is cuttable in the Object Styles dialog (click Manage tab ➤ Settings panel ➤ Object Styles). If the Line Weight Cut column is disabled, the category is non-cuttable. For more information, see The Families Guide on page 680.
Setting Family Geometry Visibility

1. Select the geometry, and click Modify | <Element> tab ➤ Mode panel ➤ (Visibility Settings).
2. In the Family Element Visibility Settings dialog, select the views in which you want the geometry to display:
   - Plan/RCP
   - Front/Back
   - Left/Right

   **NOTE** All geometry automatically displays in 3D views.

3. If desired, select When cut in Plan/RCP (if category permits).
   If you select this option, the geometry appears cut if it is intersected by the cut plane of the view. If the element is cut by a section view, it also shows if you select this option.

4. Select the detail levels at which you want the geometry to display in a project:
   - Coarse
   - Medium
   - Fine

   Detail levels are dependent upon view scale.

   **NOTE** The Family Element Visibility Settings dialog is different for families of profiles and detail components. For these families, you can set only the detail level.

5. Click OK.

   **TIP** You can set family elements to be visible or not visible in the project by associating the Visible parameter of solid geometry tools with a family parameter for that element. The Visible parameter is available for solid and void geometry tools (blends, sweeps, swept blends, revolves, and extrusions). This lets you create one family type with optionally visible geometry on it. Note that the family geometry still exists in the project, it is just invisible. For example, it may still be involved when you join geometry in the project.

Cuttable Families

If a family is cuttable, the family displays as cut when the cut plane of a view intersects that family in all types of views.

In the Family Element Visibility Settings dialog, there is an option called When cut in Plan/RCP. This option determines if family geometry is shown when the cut plane intersects that family.

This option is never made available and is never selected for non-cuttable families. For some cuttable families, the option is made available, and you can select it. For other cuttable families, the option is never made available, but it is always selected.

The following table lists cuttable families and whether the option is made available for that family.
NOTE Not Applicable means the category is a system family that cannot be made from a family template.

<table>
<thead>
<tr>
<th>Family Category</th>
<th>Option Made Available</th>
</tr>
</thead>
<tbody>
<tr>
<td>Casework</td>
<td>Yes</td>
</tr>
<tr>
<td>Ceilings</td>
<td>Not Applicable</td>
</tr>
<tr>
<td>Columns</td>
<td>Yes</td>
</tr>
<tr>
<td>Curtain Wall Panels</td>
<td>No</td>
</tr>
<tr>
<td>Doors</td>
<td>Yes</td>
</tr>
<tr>
<td>Floors</td>
<td>Not Applicable</td>
</tr>
<tr>
<td>Generic Models</td>
<td>No</td>
</tr>
<tr>
<td>Roofs</td>
<td>Not Applicable</td>
</tr>
<tr>
<td>Site</td>
<td>Yes</td>
</tr>
<tr>
<td>Structural Columns</td>
<td>Yes</td>
</tr>
<tr>
<td>Structural Foundations</td>
<td>Yes</td>
</tr>
<tr>
<td>Structural Framing</td>
<td>Yes</td>
</tr>
<tr>
<td>Topography</td>
<td>No</td>
</tr>
<tr>
<td>Walls</td>
<td>Not Applicable</td>
</tr>
<tr>
<td>Windows</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Non-Cuttable Families

The following families are not cuttable and are always shown in projection in views:

- Detail Items
- Entourage
- Mechanical Equipment
- Parking
- Planting
- Plumbing Fixtures
- Specialty Equipment
Colors

You set colors for many elements in Revit Structure, such as objects, lines, annotation symbols, materials, rooms, and phasing. When you select colors, the standard Windows color dialog opens. If you click PANTONE from the Windows color picker, the PANTONE color dialog opens.

You can specify No Color in the Windows Color dialog to not associate a color with a particular item. This does not mean the item has no color. A component can assume its color from a parent category or use black. For example, if you specify No Color for Door Panel, but Doors are defined as brown, the Door Panel displays in brown.

Using the Windows Color Dialog

1. From the appropriate Revit Structure dialog, access the Windows Color dialog. For example, in the Materials dialog, on the Graphics tab or the Render Appearance tab, click a color swatch. (See Materials on page 1573.)

2. In the Color dialog, select a color using one of the following methods:
   - Basic colors: A table of 48 commonly used colors is available. Click one of the boxes containing the desired color.
   - Hue, Sat, Lum, Red, Green, Blue boxes: Type values in these boxes to define the desired color.
   - Black and white settings box: Move the slider up and down to alter the amount of white or black in the color. The result displays in the color/solid box.
   - Custom colors: Add up to 16 custom colors. To add a custom color, click one of the 16 color squares under Custom Colors. Mix the new color by clicking one of the Basic Color squares or by choosing a PANTONE color. When you have finished mixing the color, click Add Custom.

3. When you have specified the desired color, click OK.

Using the PANTONE Color Picker

1. From the appropriate Revit Structure dialog, access the Windows Color dialog. For example, in the Materials dialog, on the Graphics tab or the Render Appearance tab, click a color swatch. (See Materials on page 1573.)

2. In the Color dialog, click PANTONE.

3. Create a color in the PANTONE Color Picker.

4. Click a color in the pane to select it.
   The PANTONE preview window displays the selected color.

5. When you find the desired color, click OK.

6. Click OK to exit the Color dialog.
   Revit Structure assigns the PANTONE color to the dialog. Note that Revit Structure uses the PANTONE name.
Revit Options

You can configure global settings for your Revit installation. You can specify these settings any time that Revit Structure is open, before or after opening a Revit file.

Setting Options

1. Click ➤ Options.
2. Specify the desired options.
3. Click OK.

General Options

Click the General tab of the Options dialog to set notifications, user names, and journal file cleanup.

Notifications

- Specify a time value for the Save reminder interval.
- Specify a time value for the Synchronize with Central reminder interval.

Username

- Username is the identifier Revit Structure associates with a particular session. The first time Revit Structure is run on a workstation, it uses the Windows login name as the default Username. You can change and save the username. In subsequent sessions on the same workstation, Revit Structure defaults to the saved username, not the Windows login name. If team members are not consistently working on the same workstations day-to-day, they must be sure to reset the username for each session because the default name will be that of the previous user.
- In a multi-user (worksharing) Revit environment, editing permissions are based on the username. Two (or more) active local models (or a local model and the central model) should never be edited under the same username; doing so could cause the local models to be incompatible with the central model.

Journal File Cleanup

- Specifies the number of journal files to retain.
Journal files are text documents that record each step during your Revit Structure sessions. These files are used primarily in the software support process. Journals can be run in order to detect a problem or recreate lost steps or files. They are saved at the termination of each Revit Structure session. See Journal Files on page 90.

**User Interface Options**

Click the User Interface tab of the Options dialog to change the behavior of the user interface. For more information, see User Interface on page 21 and Customizing the Ribbon on page 22.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure</td>
<td></td>
</tr>
<tr>
<td>Active theme</td>
<td>Specifies the visual theme to use for the Revit user interface: Light (the default), or Dark.</td>
</tr>
<tr>
<td>Keyboard Shortcuts</td>
<td>Displays a dialog to add, remove, import, and export keyboard shortcuts. You can change predefined keyboard shortcuts, and add your own key combinations for Revit tools. See Keyboard Shortcuts on page 1559.</td>
</tr>
<tr>
<td>Enable Recent Files page at startup</td>
<td>Displays the Recent Files page when you start Revit Structure. This page lists the projects and families that you worked on most recently. It also provides access to online help and videos. As an alternative, you can open the Recent Files page at any time by clicking View tab ➤ Windows panel ➤ User Interface drop-down ➤ Recent Files.</td>
</tr>
</tbody>
</table>

**Tab Display Behavior**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| After clearing a selection or after exiting from a tool | Specifies the desired behavior in the project environment or in the Family Editor:  
  ■ **Stay on the Modify tab:** After you deselect an element or exit a tool, the Modify tab stays in focus.  
  ■ **Return to the previous tab:** After you deselect an element or exit a tool, Revit Structure displays the ribbon tab that displayed previously. |
| Display the contextual tab on selection    | Displays the contextual tab for a selected element, providing immediate access to relevant tools. When this option is turned off, the contextual tab opens but does not come into focus; instead, the current tab remains in focus. Click the contextual tab to access it. |
Tooltips

Specifies the desired level of information about ribbon tools. The default is Normal. See Tooltips on page 26.

Graphics Options

Click the Graphics tab of the Options dialog to enable hardware acceleration for improved display performance. On this tab you can also configure colors for selection, highlighting, and alerts, enable anti-aliasing for 3D views, and specify the appearance of temporary dimension text.

Graphics Mode

Use hardware acceleration. Some of the benefits of using hardware acceleration are:

- Faster display of large models upon refresh.
- Switching between windows of views occurs faster with 3D graphics acceleration.
- Creation and modification of annotations is faster.

Colors

- Select Invert background color to change the display of the background of the view and the elements in the view. For example, if you are drawing black elements in a white background, select this option so the background becomes black and the elements display in white.

- To define a new selection color, click the color button next to Selection Color. This option sets the color for items you select in the drawing area, either by clicking on them or using a pick box.

- To define a new highlight color, click the color button next to Highlight Color. This option sets the color of highlighted elements (when you move the cursor over an element in the drawing area).

- To define a different error color, click the color button next to Alert Color. This option sets the color for elements that are selected when a warning or error occurs.

Appearance Quality

- Use Anti-Aliasing for 3D views.
  When enabled, the quality of lines in 3D views is improved. For example, edges display smoother.

Temporary Dimensions Text Appearance

- Specify a font size.

- Specify a transparent or opaque background.

File Location Options

Click the File Locations tab of the Options dialog to set paths for files and directories.
Files and Directories

- Specify the path for the default template file. The Revit Structure installation automatically sets this path; however, you may want to change it if you need to use either Imperial or Metric units for your project. There are default templates installed in either Revit Structure\Imperial Templates\ or Revit Structure\Metric Templates. Select whichever one is appropriate. Also, you can change this path to point to a custom template to use for all your projects.

- Specify the default project path where Revit Structure saves the current file. This setting overrides the default path for saving files. When you specify a folder, Revit Structure opens that folder by default when you save or open a file.

- Specify the path for the templates and libraries. The Revit Structure installation automatically sets this path; however, you may want to change it if you need to use either Imperial or Metric families for your project. There are default templates installed in either Revit Structure\Imperial Library\ or Revit Structure\Metric Library.

- Add secondary libraries that may be specific to your company. To do this, click Places. See Places on page 1626.

Places

You can add libraries or folders that are specific to your organization. These folders display in the left pane of most dialogs that list files, such as the Open dialog.

To define folders or libraries

1. Open the Places dialog.

How to

- Click ➤ Options. On the File Locations tab, click Places.
- On the Open dialog, right-click in the left pane, and click Edit Places.

2. In the Places dialog, click (Add).
3. In the new table row, enter a value for Library Name.

4. Click in the row for Library Path, and click (Browse).
5. Navigate to the desired location, and click Open.
6. Add more libraries as needed.
7. To change the order in which the libraries are listed, select a row and click (Move Up) or (Move Down).
8. To delete a library from the list, select its row and click Remove.

Rendering Options

Click the Rendering tab of the Options dialog to specify paths for files used for render appearances and decals, and to specify the location of the ArchVision Content Manager (ACM), if needed.
Additional Render Appearance Paths

On the Rendering tab of the Options dialog, specify the locations of files used for render appearances. For example, you can specify paths for the following:

- Image files used to define a custom color, design, texture, or bump map for a render appearance. See Specifying an Image File for a Render Appearance on page 1593.
- Image files for decals.
- Additional RPC content that is stored in a common network location.

**NOTE** You only need to specify paths for additional RPC content that you license directly from ArchVision. You do not need to specify paths for the RPC content that Revit Structure provides.

Suppose you specify image files for render appearances and decals. When Revit Structure needs to access the image file, first it looks in the location specified for the file, using the absolute path. If it cannot find the file in that location, Revit Structure then searches the paths that you specify in this list, in the order in which the paths are listed.

**If you want to...**  
**Then...**

add a path  
click . Enter a path, or click , navigate to the desired location, and click Open.

remove a path  
select the path in the list, and click .

change the order of the listed paths  
select a path in the list, and click the arrows until the paths are listed in the desired order. Revit Structure searches these paths in the order listed.

**Best Practice for Storing Image Files**

Store image files related to a project in one location. Specify this location on the Rendering tab of the Options dialog. If you need to send a project file to a team member, you can also send the directory containing its image files. This strategy ensures that the team member has all files required for the project, and that custom render appearances and decals display properly in the project.

**ArchVision Content Manager Location**

If your organization has licensed additional RPC content from ArchVision, specify the location of the ArchVision® Content Manager (ACM) on the Rendering tab of the Options dialog. (This RPC content is licensed separately from the RPC content that is provided with Revit Structure.)

You may also need to download and install the ACM.

Complete the fields as follows.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network</td>
<td>Select this option to indicate that the RPC plug-in should connect to the ACM on the network. Use this option when your organization stores additional RPC content in a network location so that multiple users can access it.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Address</td>
<td>Specify the network address where the ACM resides. You can enter a machine name or an IP address.</td>
</tr>
<tr>
<td>Port</td>
<td>Specify the port used by the ACM. The default is 14931.</td>
</tr>
<tr>
<td>Local</td>
<td>Select this option to indicate that the RPC plug-in should connect to the ACM on the local computer. Use this option when you store additional RPC content on the local computer.</td>
</tr>
<tr>
<td>Executable location</td>
<td>Specify the location of the local ACM executable file (rcpACMapp.exe). If the ACM is not running, the RPC plug-in starts it when needed. To navigate to the executable location, click Browse.</td>
</tr>
<tr>
<td>Get More RPC</td>
<td>Click to go to the ArchVision web site, where you can purchase additional RPC content to use in Revit projects.</td>
</tr>
</tbody>
</table>

### Spelling Options

Click the Spelling tab of the Options dialog to set options for the spell checker. You can specify a language for the main dictionary. If desired, you can click Edit to add words to the additional dictionaries.

### SteeringWheels Options

On the SteeringWheels tab of the Options dialog, specify options for the SteeringWheels view navigation tools.

For more information, see SteeringWheels on page 826.

<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Visibility</td>
<td></td>
</tr>
<tr>
<td>Show tool messages</td>
<td>Show or hide tool messages.</td>
</tr>
</tbody>
</table>

Tool messages always display for basic wheels (View Object Wheel and Tour Building Wheel) regardless of this setting.
<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show tooltips</strong></td>
<td>Show or hide tooltips.</td>
</tr>
<tr>
<td><strong>Show tool cursor text</strong></td>
<td>Shows or hides the cursor text when the tool is active. Cursor text always displays for basic wheels (View Object Wheel and Tour Building Wheel) regardless of this setting.</td>
</tr>
<tr>
<td><strong>Big Steering Wheel Appearance</strong></td>
<td></td>
</tr>
<tr>
<td>Size</td>
<td>Specify the size of the big steering wheel.</td>
</tr>
<tr>
<td>Opacity</td>
<td>Specify the opacity of the big steering wheel.</td>
</tr>
<tr>
<td><strong>Mini Wheel Appearance</strong></td>
<td></td>
</tr>
<tr>
<td>Size</td>
<td>Specify the size of the mini wheel.</td>
</tr>
<tr>
<td>Opacity</td>
<td>Specify the opacity of the mini wheel.</td>
</tr>
<tr>
<td><strong>Look Tool Behavior</strong></td>
<td></td>
</tr>
<tr>
<td>Invert vertical access</td>
<td>Inverts the up and down action of the Look tool. See Look Tool on page 834.</td>
</tr>
<tr>
<td><strong>Walk Tool</strong></td>
<td></td>
</tr>
<tr>
<td>Move parallel to ground plane</td>
<td>When walking through a model using the Walk tool, you can constrain the movement angle to the ground plane by selecting this option. You can freely look around while the current view moves parallel to the ground plane. When this option is deselected, the walk angle is not constrained and you will &quot;fly&quot; in the direction you are looking so that you can move around the model in any direction or angle. See Walk Tool on page 839.</td>
</tr>
<tr>
<td>Speed Factor</td>
<td>As you use the Walk tool to walk or “fly” through a model, you can control the movement speed. The speed of movement is controlled by the distance that the cursor is moved from the Center Circle icon. Set the movement speed here. See Walk Tool on page 839.</td>
</tr>
</tbody>
</table>
### Zoom Tool

**Zoom in one increment with each mouse click**
Allows you to zoom the view with a single click. See [Zoom Tool](page 841) on page 841.

### Orbit Tool

**Keep scene upright**
Keeps the sides of the view perpendicular to the ground plane. If you deselect this option, you can orbit the model in full 360 degree motion, which may be useful when you are editing a family. See [Orbit Tool](page 835) on page 835.

### ViewCube Options

On the ViewCube tab of the **Options dialog**, specify options for the **ViewCube** on page 819 navigation tool.

<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ViewCube Appearance</strong></td>
<td></td>
</tr>
<tr>
<td>Show the ViewCube</td>
<td>Show or hide the ViewCube in 3D views.</td>
</tr>
<tr>
<td>Show in</td>
<td>Specify which views to show the ViewCube.</td>
</tr>
<tr>
<td>On-screen position</td>
<td>Specify the position of the ViewCube in the drawing area.</td>
</tr>
<tr>
<td>ViewCube size</td>
<td>Specify the size of the ViewCube.</td>
</tr>
<tr>
<td>Inactive opacity</td>
<td>Specify the opacity of the ViewCube when not in use. If you select 0%, the ViewCube will not display in the drawing area unless you move the cursor over the ViewCube on-screen position.</td>
</tr>
</tbody>
</table>

#### When Dragging the ViewCube

**Snap to closest view**
When selected, snaps to the closest ViewCube view orientation. A ViewCube view orientation is one of the 26 view options (a face, edge, or corner of the ViewCube).

#### When Clicking on the ViewCube

**Fit-to-view on view change**
If you have an element or component selected in the drawing area and click on the ViewCube, the view rotates accordingly and the view zooms to fit the element in the drawing area.

**Use animated transition when switching views**
Shows an animated action when you switch view orientation.
Keep scene upright

Keeps the sides of the ViewCube, and the view, perpendicular to the ground plane. If you deselect this option, you can orbit the model in full 360 degree motion, which may be useful when you are editing a family. See Orbit Tool on page 835.

Compass

Show the compass with the ViewCube

Shows or hides the ViewCube compass.

### Macros Options

Click the Macros tab of the Options dialog to set options for the macros. For more information, see Macro Security on page 1656.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Application Macro Security Settings</strong></td>
<td></td>
</tr>
<tr>
<td>Enable application macros</td>
<td>Turns on application macros. Only run macros from trustworthy sources.</td>
</tr>
<tr>
<td>Disable application macros</td>
<td>Turns off application macros. You will still be able to see, edit, and build the code, but modifications will not change the current module status.</td>
</tr>
<tr>
<td><strong>Document Macro Security Settings</strong></td>
<td></td>
</tr>
<tr>
<td>Ask before enabling document macros</td>
<td>Turns off macros, but you are prompted to enable them, if macros are present when a Revit project is opened. You can then choose to enable macros whenever they are detected. This option is the default.</td>
</tr>
<tr>
<td>Disable document macros</td>
<td>Turns off document-level macros when a project is opened. You will still be able to see, edit, and build the code, but modifications will not change the current module status.</td>
</tr>
<tr>
<td>Enable document macros.</td>
<td>Turns on document macros. Only run macros from trustworthy sources.</td>
</tr>
</tbody>
</table>
Project Templates

Project templates provide initial conditions for a project. Several templates are provided with Revit Structure, or you can create your own. Any new project based on the template inherits all families, settings (such as units, fill patterns, line styles, line weights, and view scales), and geometry from the template. For more information on what you can include in a project template, see Project Template Settings on page 1634.

There are various methods you can use to create a custom project template:

- Open an existing template file, modify the settings as necessary, and save it as a new template (RTE) file.
- Start with a blank project file, define all settings for it, and then save it as a template (RTE) file.
- Start with a blank project file and specify all names for views, levels, and viewports. You can create a set of drawings by creating sheets and adding views to the sheets. As you start to draw the geometry in those views, the views on the sheets update. See Sheets on page 978 and Adding Views to a Sheet on page 980.
- Start with a project that includes geometry that can be used as a base for new projects. For example, if you have defined geometry for a college campus and want to include that geometry in multiple new projects for the college, save the project with the geometry as a template. Each time you open a project with this template, the geometry is included.

Templates use the file extension RTE.

For information about using a custom template when starting a new project, see Creating a Project Using a Template on page 55.

Creating a Template

1. Click ➤ New ➤ Project.
2. In the New Project dialog, under Template file, select:
   - None to create your template from a blank project file.
   - Browse to base your template on an existing project template. Navigate to the template location.
3. Under Create new, select Project template.
4. Click OK.

**NOTE** If you do not base the template on an existing template, the Select Initial Units dialog displays. Specify either Imperial or metric units.
5 Define settings.
6 Create any geometry that will be used as a base in future projects.
7 Click ➤ Save As ➤ Template.
8 Enter a name and select a directory for the template.
9 Click Save.

**Project Template Settings**

In a Revit Structure project template, you can predefine the following:

- **Project information.** This includes information such as the name of the project, the project number, the client name, and so on. See Project Information on page 1565.

- **Project settings.** For example, you can predefine line styles for components and lines, fill patterns for materials, project units, snapping increments for model views, and so on. See Project Settings on page 1565.

- **Families.** These include system families and loaded families. You can modify or duplicate system families (for example, walls) as necessary for a project. You can also load families, for example, commonly used families, custom families, and titleblocks. See Loading Families on page 688 and Title Blocks on page 995.

- **Project views.** Predefine plan views, levels, schedules, legends, sheets, and so on. See Document the Project on page 723.

- **Visibility/graphic settings.** Visibility and graphic settings are specified for the project in the Object Styles dialog. See Object Styles on page 1601. If necessary, you can override settings on a view-by-view basis. See Visibility and Graphic Display in Project Views on page 801.

- **Print settings.** Predefine printers and print settings. See Print Setup on page 1147.

- **Project and shared parameters.** Predefine project parameters and identify a shared parameter file. See Parameters on page 1541.

**NOTE** You cannot include worksets in project templates.
Transferring Project Standards

You can copy project standards from one project and apply them to another. Project standards include family types (this includes system families, but not loaded families), line weights, materials, view templates, and object styles.

You can specify which standards to copy. Any object referenced by an object that will be copied is included in the transfer. For example, if you select a wall type and forget to copy the material, Revit Structure copies it.

To transfer project standards:

1. Open both the source and target projects.
2. In the target project, click Manage tab ➤ Settings panel ➤ Transfer Project Standards.
3. In the Select Items to Copy dialog, select the source project for Copy from.
4. Select the desired project standards. To select all project standards, click Check All.
5. Click OK.
6. If the Duplicate Types dialog opens, select from the following options:
   ■ Overwrite: Transfers all new project standards, and overrides duplicate types.
   ■ New Only: Transfers all new project standards, and ignores duplicate types.
   ■ Cancel: Cancels the operation.
Several view templates are provided with Revit Structure, or you can create your own based on these. View templates can be transferred from one project to another.

**View Template Overview**

A view template is a collection of view properties, such as view scale, discipline, detail level, and visibility settings, that are common for a view type (such as plan or elevation). You specify the value for each property in the template. You can exclude properties from a view template. Excluded properties do not require a value and are not overridden when you apply a view template.

You can use view templates to:

- Apply a defined set of view properties to a specific view. For example, if you have a plan view that shows a furniture layout, you can create a view template that has the view properties you require for this type of plan view. If you create other plan views that require the same properties as the furniture plan, you can apply the same view template.

- Standardize the look of your project views before you print or export a view or a project. To do this, you define a default view template that you can then apply to multiple views simultaneously.

Project views and view templates are not linked. When a template changes, all views created from that template do not automatically update. You can reapply the modified template, which overrides previous view property settings.

**Creating a View Template**

You can create a view template by duplicating an existing view template and making necessary modifications. You can also create a view template from a project view.

**To create a view template from an existing view template**

1. Click View tab ➤ Graphics panel ➤ View Templates drop-down ➤ View Template Settings.

The View Templates dialog displays.
2 In the View Templates dialog, select a view template type from the Show type list. Each view template type contains a different set of view properties. Select a type that contains the view properties you want for the template you are creating.

3 In the Names list, select a view template.

4 Click \(\text{(Duplicate)}\). 

5 In the New View Template dialog, enter a name for the template, and click OK.

6 Modify view template property values as needed. See View Template Properties on page 1640. The Include option allows you to select the properties that will be included in the view template. Clear the Include option to remove properties. For properties that you do not include in the view template, you do not need to specify a value and these view properties will not be overridden when you apply the view template.

7 Click OK.

To create a view template from a project view:

1 In the Project Browser, select the view from which you want to create the view template.

2 Click View tab ➤ Graphics panel ➤ View Templates drop-down ➤ Create Template from Current View, or right-click and select Create View Template From View.

3 In the New View Template dialog, enter a name for the template, and click OK. The View Templates dialog displays.

4 Modify view template property values as needed. See View Template Properties on page 1640. The Include option allows you to select the properties that will be included in the view template. Clear the Include option to remove properties. For properties that you do not include in the view template, you do not need to specify a value and these view properties will not be overridden when you apply the view template.

5 Click OK.

For information on applying a view template, see Applying a View Template on page 1639 and Applying a View Template to All Views on a Sheet on page 1639.
Specifying and Applying a Default View Template

Specifying default view templates allows you to apply standardized view properties to multiple views simultaneously. For example, you can use default view templates to ensure that all views have the desired view properties before printing or exporting.

When you apply the default view template to multiple views simultaneously, the default template that is specified in each view's properties (which can be different for each view) is applied.

**To specify a default view template**

1. Right-click a project view in the Project Browser, and click Properties.
2. On the **Properties palette**, under Identity Data, select a value for Default View Template.

**To apply a default view template**

1. In the Project Browser, select the view or views you want to apply the default view template to.
2. Click **View tab ➤ Graphics panel ➤ View Templates drop-down ➤ Apply Default Template to Current View**, or right-click and select **Apply Default View Template**.

**Related Topic**

*Applying a View Template to All Views on a Sheet* on page 1639

---

**Applying a View Template**

1. In the Project Browser, select the view or views you want to apply a view template to.

   **NOTE** Use the **CTRL** key to select multiple views in the Project Browser.

2. Click **View tab ➤ Graphics panel ➤ View Templates drop-down ➤ Apply Template to Current View**, or right-click and select **Apply View Template**.
3. In the **Apply View Template** dialog, select a type from the Show type list.
4. In the Names list, select the view template you want to apply.
   
   You can use the view properties of another project view as a view template. To do this, select **Show Views** and select the view name.
5. Optionally, select **Apply automatically to new views of same type to apply this template to all new views of the same type**.
6. Click **Apply**.
7. Click **OK**.

The selected view template is applied.

**Applying a View Template to All Views on a Sheet**

1. In the Project Browser, right-click a sheet view name, and click **Apply View Templates to All Views** or **Apply Default View Template to All Views**.

   When you select **Apply Default View Template to All Views**, the default view template that is defined in each view's properties is applied and the task is complete. For information on specifying the default view template for a view, see *Specifying and Applying a Default View Template* on page 1639.
2. In the **Apply View Template** dialog, select a type from the Show type list.
3 In the Names list, select the view template you want to apply. You can use the view properties of another project view as a view template. To do this, select Show Views and select the view name.

4 Click Apply.
5 Click OK.

The view template is applied to all views on the sheet.

Deleting a View Template

1 Click View tab ➤ Graphics panel ➤ View Templates drop-down ➤ View template settings.
2 In the View Templates dialog, select a type from the Show type list.
3 In the Names list, select the view template you want to delete.
4 Click ✗ (Delete).

**NOTE** Because templates are not linked to views, deleting a view template has no impact on existing views.

View Template Properties

You can access view template properties from View tab ➤ Graphics panel ➤ View Templates drop-down ➤ View template settings. Not all properties are available for each view template type.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Scale</td>
<td>The scale of the view. When you select Custom, you can edit the Scale Value property.</td>
</tr>
<tr>
<td>Scale Value 1:</td>
<td>A ratio derived from the view scale. For example, if the view scale is 1:100, the scale value is the ratio of 100/1 or 100. You can edit this value when you select Custom for the View Scale property.</td>
</tr>
<tr>
<td>Display Model</td>
<td>Hides the model in detail view. The Normal setting displays all elements normally. It is intended for all non-detail views. The Do Not Display setting shows only detail-view-specific elements. These elements include lines, regions, dimensions, text, and symbols. Elements in the model do not display. The Halftone setting displays all detail-view-specific elements normally, while model elements display in halftone. You can use the halftone model elements as references for tracing lines, dimensioning, and aligning. (See <a href="#">Halftone/Underlay on page 1605</a>.)</td>
</tr>
<tr>
<td>Detail Level</td>
<td>Applies the detail level setting to the view. See <a href="#">Detail Level on page 1618</a>.</td>
</tr>
<tr>
<td>V/G Overrides Model</td>
<td>Click Edit to view and modify visibility options for model categories. See <a href="#">Visibility and Graphic Display in Project Views on page 801</a>.</td>
</tr>
<tr>
<td>V/G Overrides Annotation</td>
<td>Click Edit to view and modify visibility options for annotation categories. See <a href="#">Visibility and Graphic Display in Project Views on page 801</a>.</td>
</tr>
<tr>
<td>V/G Overrides Import</td>
<td>Click Edit to view and modify visibility options for imported categories. See <a href="#">Visibility and Graphic Display in Project Views on page 801</a>.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>V/G Overrides Filters</td>
<td>Click Edit to view and modify visibility options for filters. See Visibility and Graphic Display in Project Views on page 801.</td>
</tr>
<tr>
<td>V/G Overrides Design Options</td>
<td>Click Edit to view and modify visibility options for design options. See Checking the Design Option Settings for a View on page 669.</td>
</tr>
<tr>
<td>Visual Style</td>
<td>Indicates the view setting applied to the view.</td>
</tr>
<tr>
<td>Graphic Display Options</td>
<td>Click Edit to access the Graphic Display Options dialog. In this dialog, you can add shadows and silhouette edges. For more information, see Displaying Sun and Shadows on page 1375 and Applying or Removing a Line Style for a Silhouette Edge on page 872.</td>
</tr>
<tr>
<td>Far Clipping</td>
<td>Specify far clip plane settings. See Cut a View by the Far Clip Plane on page 854.</td>
</tr>
<tr>
<td>View Range</td>
<td>Click Edit to access the View Range dialog. The Primary Range is defined by the Top and Bottom Clip Planes. Elements within the boundaries of the primary range are drawn according to their Object Styles. Elements that are not within the primary range yet fall within the specified view depth are drawn using the Beyond line style. The level at which the plan is cut is determined by the Cut plane offset from the current level value. Applicable only to plan and RCP views. For more details, see View Range Properties on page 867.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Orients the project to project north or true north. For more information, see Rotating a View to True North on page 110.</td>
</tr>
<tr>
<td>Phase Filter</td>
<td>Applies the phase properties to the view. See Phase Filters on page 879.</td>
</tr>
<tr>
<td>Discipline</td>
<td>Determines the visibility of non-bearing walls and discipline specific annotation symbols (such as framing elevations).</td>
</tr>
<tr>
<td>Color Scheme Location</td>
<td>Specify the display for the color scheme. Foreground colors all elements in the room or area; Background colors only the floor.</td>
</tr>
<tr>
<td>Depth Clipping</td>
<td>Specify depth clip plane settings. See Cutting a Plan View by the Back Clip Plane on page 727.</td>
</tr>
<tr>
<td>Rendering Settings</td>
<td>Specify settings to use when rendering an image from a 3D view. See Creating a View Template for Render Settings on page 1089.</td>
</tr>
<tr>
<td>Column Symbolic Offset</td>
<td>Specify the offset of a beam join to a slanted structural column. This only applies to coarse detail levels.</td>
</tr>
</tbody>
</table>
Creating Macros with Revit

VSTA

This topic explains how to create macros in Revit. We will describe macro capabilities, the overall workflow, specific installation steps, a development environment called Revit VSTA, code examples, frequently asked questions, and related information about the Revit SDK.

Getting Started with Macros

First, let’s answer the question: “What are macros, and why would you use them?” Macros are programs that are designed to help you save time, by automating repetitive tasks. Each macro performs a series of pre-defined steps to accomplish a particular task. The steps should be repeatable and the actions predictable.

For example, you might define a macro to add a grid to your project, to rotate a selected object, or to collect information about the square footage of all the rooms in your structure. Other general examples include:

- Locating and extracting Revit content to external files
- Refining geometry or parameters
- Creating many types of elements
- Importing and exporting external file formats

Revit provides an Application Programming Interface (API) that allows you to extend the functionality of the product. You can add customized commands to the Add-Ins tab ➤ External Tools panel, or add new panels and tools.

In addition to those API extensions, you can use the API to define macros that run in Revit. Unlike external commands and external applications, the macro functionality is available to Revit from the Revit VSTA add-in. We will explain the API differences later in this topic, but for experienced developers, note that you do not need to register the macros in Revit.ini, or add RevitAPI.dll as a reference.

VSTA is an acronym for Visual Studio Tools for Applications. It is a Microsoft technology that provides the .NET framework for creating macros in C# and VB.NET based on specific applications. VSTA is the next evolution of Visual Basic for Applications (VBA) that appears in several existing Autodesk applications.
About Revit VSTA Installation

The Revit VSTA application is now installed with Revit Structure by default. Also note that Revit uses Microsoft .NET Framework version 3.5. Older applications compiled using .NET 2.0 will continue to function unless otherwise affected by changes in the Revit 2010 API.

Experienced Revit VSTA users should refer to Upgrading Revit VSTA on page 1644 for important upgrade information.

Expect API Changes

It is very likely that the Revit API will change in subsequent product releases. This means that after installing the next Revit release, you will need to edit and rebuild your macros to reflect the API changes.

Upgrading Revit VSTA

If you are upgrading Revit VSTA, some file management may be required to update and operate macros correctly in Revit. Be sure to familiarize yourself with changes in the Revit Software Development Kit (SDK) and the following macros upgrade information.

Upgrading Document-Level Macros

1. Open the project containing embedded document-level macros. Once opened, the project has been updated.
2. Click Manage tab ➤ Macros panel ➤ Macro Manager.
3. Click each Document-level tab to update.
4. When complete, click Close.
5. Save and close the project.

No further steps are required unless the macro code needs to be manually edited.

Upgrading Application-Level Macros

1. Copy the directories in C:\Program Files\Autodesk Revit Structure 2010\Program\VstaMacros\AppHookup.
2. Paste the directories into C:\Program Files\Autodesk\Revit Structure <release>\Program\VstaMacros\AppHookup.
3. Launch Revit.
4. Click Manage tab ➤ Macros panel ➤ Macro Manager.
5. Click the Application tab.
6. When complete, click Close.

NOTE: In the event there are compatibility issues in the upgrade process, copies of the original project (for document-level macros) and application macros are placed in My Documents\Revit Structure <release> VSTA and appended with ~R. These files may be hidden depending on your Windows Explorer folder settings.

The code in projects may need to be manually modified in order to successfully build and run the macros in Autodesk Revit Structure 2011. Consult the SDK for the list of changes to the API in order to address any version compatibility issues.
Revit VSTA Tools

You can use the Revit VSTA macro features in all Revit products: Revit Architecture, Revit Structure, and Revit MEP. In this topic, we refer to any of these products generically as Revit.

Revit VSTA provides:

- Tools on the Manage tab ➤ Macros panel:
  - Macro Manager
  - Macro Security

- Macro Manager, a user interface launched by clicking Manage tab ➤ Macros panel ➤ Macro Manager. The Macro Manager presents a list of macros you built previously that you can run, edit, or debug (StepInto). Macro Manager also provides options to create new macros using different types of templates.

- An Integrated Development Environment (IDE) built into the product, the Revit VSTA IDE. You can launch it several ways, such as by selecting the Macro, Edit, or StepInto buttons from the Macro Manager.

- Access to the Revit API.

- Revit security settings for both application-level and document-level macros.

Using Macro Manager and the Revit VSTA IDE

Macro Manager is the user interface for:

- Selecting an option that launches the Revit VSTA IDE, where you can add, edit, build and debug your macros.

- Running a previously built macro from a categorized list.

Shown below is the Macro Manager screen:
The tabs indicate the scope or level of a macro.

- **Application tab.** The Application tab lists macro modules available to all opened Revit projects in the current instance of the Revit application. It is always the first tab to the left and active (indicated by the icon). It is always available, whether projects are open.

  **NOTE** If you send the RVT file to a person on another computer, application level macros would not be available.

- **Active document tab.** The active document tab represents the currently active project in Revit. The project does not necessarily contain embedded macros as in this case, although it can. The tab bears the name of the active project (Project1 in this case) and is indicated by the icon. This tab is not visible when a project is not open.

- **Inactive document tabs.** Inactive document tabs represent open projects that contain embedded macros (see below). The tab bears the name of the project (Project2 and Project3 in this case).

You add, modify, build, and delete modules and macros from these tabs.

**Macros and Modules**

A module is an organizational grouping of macros. Macros can be either independent within a module when they run, or share code or utilities with each other. They are arranged in the Macro Manager as follows with the macros organized under their parent module.

![Macro Manager](image)

Macros within a module are seen and built together. The icons representing the module also show their current state.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Macro State</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Module" /></td>
<td>The module is successfully built, enabled, and loaded. This module is ready to be run. See Running Macros in the Macro Manager on page 1655.</td>
</tr>
<tr>
<td><img src="image" alt="Macro" /></td>
<td>The module has been edited, but not built. See Building Macros in the Revit VSTA IDE on page 1654.</td>
</tr>
<tr>
<td><img src="image" alt="Disabled" /></td>
<td>The module is disabled. See Macro Security on page 1656.</td>
</tr>
</tbody>
</table>
The module failed to build. See Building Macros in the Revit VSTA IDE on page 1654.

The module failed to load.

The module is corrupt.

Application-level and Document-level Modules

Fundamentally, application-level macro tools are written to be useful in any document in nearly any Revit session. Additionally, they do not require a project to be open in Revit to run. This allows you the flexibility to:

- Customize the Revit UI
- Add tools to Revit Structure
- Modify documents on opening
- Batch open documents
- Apply new standards or settings to new documents

Should these uses be implemented, it is good practice to create application-level macros that initiate transactions needed by the macro.

Document-level macros tools are written for specific projects and are saved in the Revit project.

About Revit VSTA Implementation Languages

You create macros in Revit VSTA using the implementation language, C# or VB.NET. Your selection determines the type of source code template generated and edited in Revit VSTA IDE.

Macro Project File Locations

When you work in the Revit VSTA IDE, you must save and build the macros successfully before they will display in the Macro Manager’s categorized list. Before we look at an example of the initial code loaded into the Revit VSTA IDE, let’s discuss where macro project files reside on your computer.

Application-level macro projects are stored in a subfolder of the Revit installation directory. For example:

C:\Program Files\Autodesk\Revit Structure <release>\Program\VstaMacros\AppHookup...

Document-level macro projects are stored within an RVT file. On disk, when the associated RVT project opens, any built and saved macro(s) are stored temporarily in:

C:\Program Files\Autodesk\Revit Structure <release>\Program\VstaMacros\DocHookups...

However, these Document-level macro files are deleted from your local computer when their corresponding Revit project document (.rvt) closes. The saved document-level macros are stored in the RVT file.

Now that we have introduced the overall tools and processes, let’s look at the specific tasks.

Basic Workflow for Revit VSTA Macro Development

The overall workflow for creating and using macros is as follows.
1 Click Manage tab ➤ Macros panel ➤ Macro Manager.
2 Create modules based on application-level or document-level design. See Creating Modules on page 1648.
3 Define macros for the module with your implementation code using the Revit VSTA IDE. See Creating Macros on page 1649.
4 Build the module and its macros. See Building Macros in the Revit VSTA IDE on page 1654.
5 Run the macros in the Macro Manager to observe the results. See Running Macros in the Macro Manager on page 1655.

Creating Modules

To create macros, perform the following steps.

NOTE If the application or current document already contains modules, macros must be enabled in the Macro Security settings. See Macro Security on page 1656.

1 Click Manage tab ➤ Macros panel ➤ Macro Manager.
2 Select the Application tab (for application-level macros) or a Project tab (for document-level macros).
3 In the Create section of the Macro Manager dialog, click Module.
   The Create a New Module dialog opens.
4 Enter the following information:
   ■ Enter a name in the Module name field.
   ■ Select either C# or VB.NET in the Language field.
   ■ Optionally, add a brief description of the module in the Description field.

Creating an Application-level module in C#

5 Click OK.
   The new module is created and listed in the Macros Manager. One or more macros may now be added.
Creating Macros

In Revit, all Application-level macros use the `Application` keyword for addressing the application object in both C# and VB.NET. This includes all the application-wide data and settings.

In Revit specific Document-level macros, the `Document` keyword, in both C# and VB.NET, returns the API `Document` object. If you need to access the `Application` object from a Document-level macro, use:

```csharp
Document.Application
```

**NOTE** If the application or current document already contains macros, macros must be enabled in the Macro Security settings. See [Macro Security](#) on page 1656.

**Macros creation overview**

1. In the Macro Manager, select the Application tab (for application-level macros) or a Project tab (for document-level macros) where the macro will be placed.
2. In the Create section of the Macro Manager dialog, click Macro.
   The Create a New Macro dialog opens.
3. Enter the following information:
   - Enter a name in the Macro name field.
   - Select a parent module from the Macro in list. The language of the parent module will define the language of the macro.
   - Optionally, add a brief description of the macro in the Description field.
4 Click OK.

The new macro is placed in the parent module in the Macro Manager.

The Revit VSTA IDE application launches to write the macros. It displays a starting template for the macros in a specific programming language.
Notice that in this C# template for application-level macros, Revit VSTA has already:

- Included the necessary `using` directives.
- Identified the module namespace (`MacroAppCS` in the graphic above).
- Started the `ThisApplication` class definition.
- Started the methods for `Module_Startup()` and `Module_Shutdown()`.
- Started your new macro’s method (`MyFirstMacrosApp` in the graphic above), giving you the opportunity to add your implementation code between the braces.

Also, note that the Revit VSTA Project Explorer shows your context.

5. In the main window of the IDE, you can now enter your source code. See Macro Source Code Examples on page 1652.

6. Click File ➤ Save <macro name>, then close the Revit VSTA IDE.

7. Repeat steps 6 through 10 for any additional macros needed in the module.

**NOTE** Remember that you must successfully build and save module projects in the Revit VSTA IDE, before they will display in the Macro Manager’s categorized list. See Building Macros in the Revit VSTA IDE on page 1654.

**Optional Tools**

- Click Description to view a description of a selected module or macro in its entirety. This is useful when the Description column of the Macro Manager is truncated.
- See Modifying and Removing Modules and Macros on page 1655.
Macro Source Code Examples

The following four code samples can be used to explore the Macro Manager tools and better understand how they interact with the VSTA IDE.

C# Application-Level Macro Code Example

In the IDE, use the following code for the method:

```csharp
public void MyFirstMacroAppCS()
{
    Autodesk.Revit.DB.XYZ baseVec = Application.Create.NewXYZ(1.0, 0.0, 0.0);
    Autodesk.Revit.DB.XYZ upVec = Application.Create.NewXYZ(0.0, 0.0, 1.0);
    Autodesk.Revit.DB.XYZ origin = Application.Create.NewXYZ(0.0, 0.0, 0.0);
    Autodesk.Revit.DB.TextAlignFlags align = Autodesk.Revit.DB.TextAlignFlags.TEF_ALIGN_LEFT |
        Autodesk.Revit.DB.TextAlignFlags.TEF_ALIGN_TOP;
    string strText = "My First Macro, App level, C#!";
    double lineWidth = 4.0 / 12.0;
    t.Start();
    ActiveUIDocument.Document.Create.NewTextNote(pView, origin, baseVec, upVec, lineWidth, align, strText);
    t.Commit();
}
```

Please note that because this application-level macro is written to modify a document, you must begin a transaction (`t.Start();`) and end the transaction (`t.Commit();`) for it to run properly.

In the example, the Revit.DB.Geometry.XYZ class is used to define a position (with X, Y, Z coordinates) for a text note that the macro will add the text box to the active view of the active document.

The macro placed text box

```
My First Macro, App level, C#!
```

TIP Be sure to build your project in the Revit VSTA IDE, before trying to run it from the Macro Manager.
VB.NET Application-Level Macro Code Example

In the IDE, use the following code for the method:

```vbnet
Public Sub MyFirstMacroAppVB()
    Dim baseVec As Autodesk.Revit.DB.XYZ = Application.Create.NewXYZ(1.0, 0.0, 0.0)
    Dim upVec As Autodesk.Revit.DB.XYZ = Application.Create.NewXYZ(0.0, 0.0, 1.0)
    Dim origin As Autodesk.Revit.DB.XYZ = Application.Create.NewXYZ(0.0, 0.0, 0.0)
    Dim align As Autodesk.Revit.DB.TextAlignFlags = Autodesk.Revit.DB.TextAlignFlags.TEF_ALIGN_LEFT Or Autodesk.Revit.DB.TextAlignFlags.TEF_ALIGN_TOP
    Dim strText As String = "My First Macro, App Level, VB.NET!"
    Dim lineWidth As Double = 4.0 / 12.0
    Dim pView As Autodesk.Revit.DB.View = ActiveUIDocument.Document.ActiveView
    Transaction.Start()
    ActiveUIDocument.Document.Create.NewTextNote(pView, origin, baseVec, upVec, lineWidth, align, strText)
    Transaction.Commit()
End Sub
```

Please note that because this application-level macro is written to modify a document, you must begin a transaction (`Transaction.Start()`) and end the transaction (`Transaction.Commit()`) for it to run properly.

**TIP** Be sure to build your project in the Revit VSTA IDE before trying to run it from the Macro Manager.

The macro placed text box

![My First Macro, App Level, VB.NET!](image)

C# Document-Level Macro Code Example

In the IDE, use the following code for the method:

```csharp
public void MyFirstMacroDocCS()
{
    Autodesk.Revit.DB.XYZ baseVec = Document.Application.Create.NewXYZ(0.0, 0.0, 1.0);
    Autodesk.Revit.DB.XYZ upVec = Document.Application.Create.NewXYZ(0.0, 0.0, 1.0);
    Autodesk.Revit.DB.XYZ origin = Document.Application.Create.NewXYZ(0.0, 0.0, 0.0);
    Autodesk.Revit.DB.TextAlignFlags align = Autodesk.Revit.DB.TextAlignFlags.TEF_ALIGN_LEFT
        | Autodesk.Revit.DB.TextAlignFlags.TEF_ALIGN_TOP;
    string strText = "My First Macro, Doc level, C#!";
    double lineWidth = 4.0 / 12.0;
    t.Start();
    Autodesk.Revit.DB.View pView = Document.ActiveView;
    Document.Create.NewTextNote(pView, origin, baseVec, upVec, lineWidth, align, strText);
    t.Commit();
}
```
TIP Be sure to build your project in the Revit VSTA IDE, before trying to run it from the Macro Manager.

For this example, when you build the project in the Revit VSTA IDE, also notice that you are building the `DocCSHarp` project. Your document-level C# macro's code resides in `ThisDocument.cs`. You can use the IDE’s Project Explorer to see its temporary location on disk. Recall that the code for successfully built document-level macros are stored in the RVT file after you save the RVT file. The project files are removed from the temporary location when you exit Revit.

The macro placed text box

```
My First Macro, Doc level, C#!
```

**VB.NET Document-Level Macro Code Example**

In the IDE, use the following code for the method:

```vbnet
Public Sub MyFirstMacroDocVB()
    Dim baseVec As Autodesk.Revit.DB.XYZ = Document.Application.Create.NewXYZ(1.0, 0.0, 0.0)
    Dim upVec As Autodesk.Revit.DB.XYZ = Document.Application.Create.NewXYZ(0.0, 0.0, 1.0)
    Dim origin As Autodesk.Revit.DB.XYZ = Document.Application.Create.NewXYZ(0.0, 0.0, 0.0)
    Dim align As Autodesk.Revit.DB.TextAlignFlags = Autodesk.Revit.DB.TextAlignFlags.TEF_ALIGN_LEFT Or Autodesk.Revit.DB.TextAlignFlags.TEF_ALIGN_TOP
    Dim pView As Autodesk.Revit.DB.View = Document.ActiveView
    Transaction.Start()
    Document.Create.NewTextNote(pView, origin, baseVec, upVec, lineWidth, align, strText)
    Transaction.Commit()
End Sub
```

TIP Be sure to build your project in the Revit VSTA IDE, before trying to run it from the Macro Manager.

For this example, when you build the project in the Revit VSTA IDE, notice that you are building the `DocVisualBasic` project, and your Document-level VB.NET macro’s code resides in `ThisDocument.vb`. You can use the IDE’s Project Explorer to see its temporary location on disk. Recall that the code for successfully built Document-level macros are stored in the RVT file after you save the RVT file. The project files are removed from the temporary location when you exit Revit.

The macro placed text box

```
My First Macro, Doc Level, VB NET!
```

**Building Macros in the Revit VSTA IDE**

1. Open the project that hosts the document-level macros. If you are only building application level-macros, skip to step 2.
2. Click Manage tab ➤ Macros panel ➤ Macro Manager.
3. Select either the Application tab (for application-level macros) or the tab named by the project (for document-level macros).
4. Expand the module containing the macros needed to be built.
5. Select the macros and click Edit.
6. In the Revit VSTA IDE, select the macro specific Build option from the drop-down list.
In this example, notice that you are building a macro named AppCS. The macro application-level C# macro’s code resides in ThisApplication.cs. You can use the IDE’s Project Explorer to see its location on disk.

7 Close the Revit VSTA IDE.

If your code is set up correctly, you should see a Build Succeeded message in the lower-left corner of the Revit VSTA application window.

Modifying and Removing Modules and Macros

In the Macro Manager, select the Application tab (for application-level macros) or a Project tab (for document-level macros) of the macros to be modified.

**Modules**

To delete a module, select it, and click Delete. Deleting the module will permanently remove it and its associated macros.

To modify a module, select it, and click Edit. The IDE will open the module, and you can edit it and its associated macros.

**Macros**

To delete a macro, select it and click Delete. Deleting the macro does not permanently remove it. It will be commented out in the source code. To permanently delete the macro, it will need to be removed manually by editing it in the IDE.

To modify a macro, select it, and click Edit. The IDE will open the module and you can edit it, its module, and its associated macros.

Running Macros in the Macro Manager

1 Click Manage tab ➤ Macros panel ➤ Macro Manager.
2 Select a macro.
3 Click Run.

Optionally, double-click individual macros in the Macro Manager to run them.

Macros will run only from the Application tab and the currently active document, not those in inactive documents. Macros security must also be set appropriately. See Macro Security on page 1656.

Using the StepInto Option

You can debug your macros by using the StepInto option in Macro Manager.

1 Open the code for your macro in the IDE.
2 You can optionally set breakpoints in the macros. Click in the left margin of the code window, or click in the code and press F9 or Toggle Breakpoint in the Debug menu. Break points will display as red circles.
3 In the Macro Manager, select your macro from the categorized list, and click StepInto. The IDE will enter debug mode and stop the macro at the first line.

- Press F10 to step through the macro code, line by line.
- Press F5 or Continue to move the next breakpoint if they were set in Step 2.

**WARNING** Avoid switching Windows users or allowing Windows to enter sleep mode while using StepInto. In some cases, this can cause errors and unexpected data loss.

In the Revit VSTA IDE, you can use Watch, Locals, and other options to perform debugging tasks like checking variable values. For more debugging information, see the VSTA IDE Help.

**NOTE** Currently Module_Startup and Module_Shutdown cannot be debugged. Because Revit VSTA debugging is macro centric, the module must be loaded before debugging begins.

### Macro Security

You have the option to enable and disable macros by default. This protects your work and computer from running dangerous malicious code unexpectedly. When working with macros, it is important to be wary of the risks involved with their vulnerabilities. Only run known macros from trustworthy sources.

#### Setting Application-level macro security

1 Disabling Application-level macros restricts access to both the Run and StepInto tools on the Macro Manager. You will still be able to see, edit, and build the code, but modifications will not change the current module status.

   - Click Manage tab ➤ Macros panel ➤ ![Macro Security].

2 Select the Macros tab.

3 In the Application Macros Security Settings section, select either Enable application macros or Disable application macros.

4 Click OK.

5 Close and reopen Revit Structure.

**NOTE** Any changes to application-level macro settings will take effect after Revit Structure is restarted. The setting will persist until it is changed.

#### Setting Document-level macro security

1 Disabling document-level macros restricts access to both the Run and StepInto tools on the Macro Manager for any project opened in Revit Structure. You will still be able to see, edit, and build the code, but modifications will not change the current module status.

   - Click Manage tab ➤ Macros panel ➤ ![Macro Security].

2 Select the Macros tab.

3 In the Document Macros Security Settings section, select one of the following:
   - **Ask before enabling document macros.** This is the default setting. Macros are disabled, but you will be prompted to enable them, if macros are present when a Revit project is opened. You can then choose to enable macros whenever they are detected.
   - **Disable document macros.** Disables document-level macros when a project is opened. To enable macros in this state, you must close the project, adjust the Macro Security settings, and reopen the project.
Enable document macros. Enables document-level macros when a project is opened. To disable macros in this state, you must close the project, adjust the Macro Security settings, and reopen the project.

You should avoid the Enable document macros setting if possible. You will not be warned when opening a document about macros and potentially dangerous and malicious code that can run. It is recommended that you use Ask before enabling document macros, if you are not familiar with Revit macros or frequently open projects from unfamiliar sources. The Enable document macros setting should only be used when you know the source of the embedded macros.

Document-level Macro Status and Warnings

To help you identify the current status of macro security, you are given status icons and notification prompts in the lower right corner of the Revit application frame.

<table>
<thead>
<tr>
<th>Macro Security Setting</th>
<th>Status Icon</th>
<th>Notification when Opened</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable document macros</td>
<td><img src="image" alt="Document Macro Status" /></td>
<td>All the macros in this document are enabled. Click here to learn more</td>
</tr>
<tr>
<td>Disable document macros</td>
<td><img src="image" alt="Document Macro Status" /></td>
<td>All the macros in this document are disabled. Click here to learn more</td>
</tr>
<tr>
<td>Ask before enabling document macros</td>
<td>User-defined.</td>
<td>A warning dialog prompts you to either enable or disable the macros. The resulting answer displays the correct icon. This is the default setting.</td>
</tr>
</tbody>
</table>

Revit SDK, API Reference Documentation, VSTA Samples

The Revit Software Development Kit (SDK) contains useful resources to help you understand the Revit API and to create macros. The SDK includes the Revit API reference documentation, the full SDK API samples, and the Revit VSTA samples. The Revit SDK is available on:

- The Revit DVD or download
- The Autodesk Developer Network, [http://adn.autodesk.com](http://adn.autodesk.com). If you are interested, please contact your Autodesk representative for information about getting an ADN account.

The SDK is packaged in a ZIP file. After unzipping the SDK and agreeing to the license text, look for the RevitAPI.chm Help file. On a Windows computer, open the CHM file and refer to the classes, properties, and methods described there. For example:
Also see the Revit VSTA samples that are part of the SDK. You can find them under:
\Software Development Kit\VSTA Samples\...

The next section explains how to integrate the VSTA Samples into your Revit VSTA projects.

**Using the Revit VSTA Samples from SDK**

You can learn various API techniques by using the Revit VSTA samples provided with the SDK.

Copy and open the following Revit project files from \Software Development Kit\VSTA Samples\...:

- Revit_VSTA_Samples.rvt
- Revit_VSTA_MEP_Samples.rvt
- Revit_VSTA_Family_Samples.rfa

Included in this RVT file are several document-level macros. In Revit, start the Macro Manager, select one of the document-level macros, and select Run. Note that when you open Revit_VSTA_Samples.rvt from the SDK, it may contain more samples than the ones shown in the following screen, and the macro methods may be named differently.
These macros have been preconfigured to run in Revit. In the Macro Manager, you can also select any of the VSTA sample macros, and click Edit to see the code created to run that sample. You can also select any of the VSTA sample macros and click Edit to see the code created to run that sample.

Revit VSTA application-level macro samples are provided with the SDK in `\Software Development Kit\VSTA Samples`:

- GetTimeElapsed_CSharp
- GetTimeElapsed_VBNet
- Rooms

Copy these directories into `C:\Program Files\Autodesk\Revit Structure <release>\Program\VstaMacros\AppHookup`, and then launch Revit.

**NOTE** Be sure the copied directories are writable. The application-level macros will not run correctly if they are read-only.

## Revit API Differences

### Quick Reference

The following table summarizes differences between the standard Revit API and the Revit Macro API.

<table>
<thead>
<tr>
<th>Feature or Capability</th>
<th>Standard Revit API</th>
<th>Revit Macro API</th>
</tr>
</thead>
<tbody>
<tr>
<td>Declaration</td>
<td>Must implement IExternalCommand interface and its Execute method.</td>
<td>Declare a public method with no parameters and void return type in the ThisApplication or ThisDocument class.</td>
</tr>
<tr>
<td>Application object</td>
<td>Access the Application object through externalCommand=Data.Application</td>
<td>The Application keyword in C# and VB.NET points to the Application object for application-level macros. For document-level macros, Document.Application points to the Application object.</td>
</tr>
</tbody>
</table>
Integrating Macros into Revit VSTA

Let’s walk through the steps to integrate a macro into a Revit VSTA project. You can skip this section if the samples described in the section Using the Revit VSTA Samples from SDK on page 1658 meet your needs.

This section explains where to create folders in the IDE projects that correspond to resources on the file system, how to add required references, and how to define properties. Those steps were done for you in the macros that were built into Revit_VSTA_Samples.rvt, which is provided on the SDK.

Add Required References

If your macro presents a user interface, you will need to add required references to your project. For example, in the SDK VSTAExampleRooms macro, we need to reference:

1. System.Windows.Forms
2. System.Drawing

Starting in the Macro Manager, select the project type and click Edit.

In the IDE, go to the Project Explorer. By default, it is docked on the right side of the display.

For the macro project (example: AppCSharp), right-click on the References section and select Add Reference from the menu.

In the Add Reference dialog, find and select System.Drawing and System.Windows.Forms on the list. Hold down the Ctrl key for the multi-select operation. For example:

When you are ready, click OK.

The IDE’s Project Explorer is updated with the references:
Create Folders in Revit VSTA IDE

In the IDE’s Project Explorer, right-click on the macro project, and select Add ➤ New Folder from the menu. For example:

Name the folder. In this example, we call it Samples. Then right-click on the Samples folder entry, and click Add ➤ New Folder again to add a secondary folder, such as Rooms.

Here is the resulting Project Explorer screen:
Outside of the IDE, use Windows Explorer to navigate to the Revit installation folders, and find the VstaMacros folder. Notice that the corresponding \Samples\Rooms subfolders have been created in this location.

**Copy Your Macro to File System Folder**

Still outside of the Revit VSTA IDE, copy your macro’s files to the subfolder you created.

**NOTE** If your macro uses a ResX file, copy it too.

**Add Existing Files to Macro Project in IDE**

Return to the Revit VSTA IDE. In the Project Explorer (to continue this example), right-click on the folder you created for your macro, and select Add ➤ Existing Item from the menu. For example:

In the resulting IDE dialog, browse to the corresponding subfolder on the file system (such as the Revit SDK VSTA Sample directory), under your Revit installation folder, select all the files that comprise the macro, and click Add.

In this example, the refreshed IDE Project Explorer for `GetTimeElapsed_Csharp` contains:
Create and Build Your Macro

Once the files have been added to your project, you can write a method that runs the macro. For example, in C#:

```csharp
/// Sample Rooms test
public void RunSampleRooms()
{
    SamplesRoom sample = new SamplesRoom(this);
    sample.Run();
}
```

Be sure to add a using directive for the macro's namespace. For example:

```csharp
using Revit.SDK.Samples.Rooms.CS;
```

Save the project and then click Build from the IDE toolbar menu. In Revit, launch Macro Manager and select your macro from the categorized list. On the SDK, the Rooms sample may be coded as a document-level macro, in which case code changes would be needed to run it in the AppCSharp project shown in this section's screens.

When run from Macro Manager, the macro collects data from your model and presents summary information. Here is an example:

<table>
<thead>
<tr>
<th>Room Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
</tr>
<tr>
<td>-----</td>
</tr>
<tr>
<td>42307</td>
</tr>
<tr>
<td>42308</td>
</tr>
<tr>
<td>42025</td>
</tr>
<tr>
<td>42024</td>
</tr>
<tr>
<td>42337</td>
</tr>
<tr>
<td>42340</td>
</tr>
<tr>
<td>43007</td>
</tr>
<tr>
<td>43044</td>
</tr>
<tr>
<td>43046</td>
</tr>
<tr>
<td>43346</td>
</tr>
</tbody>
</table>

Resources.resx Properties

Note that one of the Revit VSTA samples, GridCreation, has a dependency on a resources.resx file. Before experimenting with the GridCreation sample, set the ResX file in the Revit VSTA IDE. This was already done for you in the document-level samples built into Revit_VSTA_Samples.rvt (from the SDK). However, for macros you develop yourself, you may need to define properties in the project's resources.resx file. This section shows an example.

In the Project Explorer, navigate to the Properties folder for your macro. For example: YourMacro ➤ Samples ➤ GridCreation ➤ Properties.
Highlight the resources.resx file. In the Properties pane, select the Custom Tool property, and enter ResXFileCodeGenerator in the value column.

**Restoring RevitAPI.dll and RevitAPIUI.dll**

RevitAPI.dll and RevitAPIUI.dll are required references for the interaction between the Macro Manager and Revit VSTA IDE. If they are inadvertently removed from a module, the following procedure will restore them.

1. Select the module in the Macro Manager.
2. Click Edit.
3. In the Project Explorer of IDE, right-click on the references section, and select Add Reference.
4. In the Add Reference dialog, click the Browse tab.
5. Navigate to `\Revit Structure <release>\Program`.
6. Select RevitAPI.dll and RevitAPIUI.dll.
7. Click OK.

The references are restored and the macro will build, debug, and run as needed.

**Migrating SDK Samples to Revit VSTA**

The Revit SDK contains two samples folders:

- `\Revit SDK <release>\Software Development Kit\Samples\`
- `\Revit SDK <release>\Software Development Kit\VSTA Samples\`

The programs in the SDK’s `\Samples\` folder use the standard Revit API. We refer to these samples as the SDK sample code, as distinct from the Revit VSTA samples.

If you want to use the SDK sample code for macros, modifications are needed. Follow the steps in this section. For a programming language, we will show C# examples. However these instructions also apply to the VB.NET versions of the SDK samples.

**Initial Steps**

The initial steps to migrate standard API samples from the SDK into your Revit VSTA macro project are similar to the section Integrating Macros into Revit VSTA on page 1660. Except, instead of copying files from the SDK’s `\VSTA Samples\<sample-name>\` folders, you will copy files from the SDK’s `\Samples\<sample-name>\` folders.

To review, the steps are:

1. In the IDE, add required references.
2. In the IDE, create folders for the SDK samples you want to migrate.
3. In Windows Explorer, copy the SDK standard API samples’ files to the corresponding file system folders.
4. In the IDE, add existing files to the macro project.

**Update the SDK Samples’ Code**

In the Revit VSTA IDE, the `IExternalCommand` interface is not available or used. In the SDK standard API sample code, you must update the class that inherits from this interface:

- Remove the method parameters and the return of the `Execute` method.
Update other code related to `ExternalCommandData`.

**Code Example Before Edits**

The following code snippet is from a program that uses the standard Revit API:

```csharp
/// the operation
public IExternalCommand Result Execute(External CommandData commandData, string message, ElementSet elements)
{
    try
    {
        // create a new instance of class data
        ResultData data = new ResultData(commandData.Application);

        // create a form to display the information of rooms
        using (RoomInformationForm infoForm = new RoomInformationForm(data))
        {
            infoForm.ShowDialog();
            return IExternalCommandResult.Succeeded;
        }
        catch (Exception ex)
        {
            // if there was something wrong, give error information and return failed
            message += ex.Message;
            return IExternalCommandResult.Failed;
        }
    }
}
```

**Code Example After Edits**

In the Revit VSTA IDE, we need to update the code as follows. This example shows an application-level macro. The method `RunSampleRooms()` is the entry for this VSTA sample. Notice that we used the `this` pointer to replace `commandData.Application`.

```csharp
public void RunSampleRooms()
{
    try
    {
        // create a new instance of class data
        ResultData data = new ResultData(this);

        // create a form to display the information of rooms
        using (RoomInformationForm infoForm = new RoomInformationForm(data))
        {
            infoForm.ShowDialog();
        }
        catch (Exception ex)
        {
            MessageBox.Show("Failed to run sample. " + ex.ToString());
        }
    }
}
```

**Additional Migration Notes for SDK Standard API Samples**

- By default, the SDK sample namespace is: `Revit.SDK.Samples.<SampleName>.CS`. As you edit the sample code that came from the SDK standard API samples, be sure to change the namespace for Revit VSTA. For example, in `ThisApplication.cs`:
  ```csharp
  namespace AppCSharp.csproj
  ```

- The default project references in Revit VSTA projects only consist of basic references, such as `Revit.Proxy`. Remember to add other required references. For example, you have to add `System.Windows.Forms` and `System.Drawing` references when running samples that present a user interface.

- Some samples have resources that must be defined in the resources.resx file. GridCreation is one such sample. If you migrate the SDK standard API sample for GridCreation to Revit VSTA, be sure to set the `resx` property.

- Project build dependence is not supported within the Revit VSTA IDE. If you want to use other DLLs, you must compile that dependent sample project outside the Revit VSTA IDE. For example, in the SDK standard API samples, there are several samples related to Viewers, such as AnalyticalViewer and RoomViewer, which depend on references to RevitViewer. In the SDK sample's solution, you can set the project dependences as shown here:
However, we cannot set the project dependency due to a limitation in Revit VSTA. We cannot migrate the RevitViewer sample to VSTA. Therefore, you need to compile RevitViewer as an independent SDK sample, and then add its DLL as a reference in the Revit VSTA project:

- When you migrate SDK standard API samples to Revit VSTA, do not copy any Solution files (*.sln*) or existing project files (*.csproj or *.vbproj).
- Toolbar-related samples are unavailable in Revit VSTA.

## Revit Macros FAQ

### Quick Reference

This section answers frequently asked questions about Revit macros.

<table>
<thead>
<tr>
<th>Question</th>
<th>Answer</th>
</tr>
</thead>
<tbody>
<tr>
<td>I was expecting to see my newly created macro listed in the Macro Manager's categorized list, but it is not there. Why?</td>
<td>You must successfully build the macro project in the Revit VSTA IDE (use the Build menu) before your new macros will appear in the Macro Manager.</td>
</tr>
<tr>
<td>Do I need to add RevitAPI.dll and RevitAPIUI.dll as references when writing a new macro?</td>
<td>No. You do not need to reference RevitAPI.dll and RevitAPIUI.dll files because this step was completed for you. A Revit VSTA macro project uses both as required references. Revit macros will fail if you delete these references in the IDE.</td>
</tr>
<tr>
<td>Question</td>
<td>Answer</td>
</tr>
<tr>
<td>-------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Do I need to edit my Revit.ini files?</td>
<td>No. Revit knows the API for the macro support.</td>
</tr>
<tr>
<td>In the Revit VSTA IDE, I deleted a macro by removing its method in the</td>
<td>You must build your edited project successfully before Macro Manager recognizes the removal.</td>
</tr>
<tr>
<td>This*.cs file or This*.vb file. However, the deleted macro's name still</td>
<td></td>
</tr>
<tr>
<td>appears when I open the Macro Manager's categorized list again. How do</td>
<td></td>
</tr>
<tr>
<td>I clear the name from the list?</td>
<td></td>
</tr>
<tr>
<td>Why didn't anything happen when I selected File ➤ New Project... in the</td>
<td>The IDE is an editor for the Macro Manager. Modules and macros are created on the Macro Manager, which are then edited in the IDE.</td>
</tr>
<tr>
<td>Revit VSTA IDE?</td>
<td>Therefore, File ➤ Open Project in the IDE is disabled.</td>
</tr>
<tr>
<td>What are the differences between application-level and document-level</td>
<td>Application-level macros can be run on all opened Revit projects within a single instance of the Revit application. Document-level</td>
</tr>
<tr>
<td>macros?</td>
<td>macro projects are stored within an RVT file. They can be loaded from the current active document and run on that document.</td>
</tr>
<tr>
<td>How do I access the Application object or the externalCommandData</td>
<td>All the Application-level macros are associated with the UIApplication object. In application-level macros, the Application</td>
</tr>
<tr>
<td>equivalent?</td>
<td>keyword pointer in C# and VB.NET returns the API Application object. In document-level macros, the Document keyword returns the API</td>
</tr>
<tr>
<td></td>
<td>Document object. To access the UIApplication object from a document-level macro, use this.Application.</td>
</tr>
<tr>
<td>What should I include in the startup and shutdown methods: Module_Start</td>
<td>The Module_Startup method is called when a module loads and Module_Shutdown is called when a module unloads. For Application-level</td>
</tr>
<tr>
<td>up and Module_Shutdown?</td>
<td>macro modules, Module_Startup is called when a Revit-</td>
</tr>
<tr>
<td>Question</td>
<td>Answer</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>project opens and Module_Shutdown is called when the project document closes. For Document-level macro modules, Module_Startup is called when Revit starts and Module_Shutdown is called when Revit shuts down. Module_Startup and Module_Shutdown will also be called when the macro project is rebuilt. You can add your initializing code in the Module_Startup methods and do the cleanup work in Module_Shutdown methods. For example, you can register event handlers at start up and unregister them at shutdown (which is the recommended way). How and why should I register and unregister my Revit event handler?</td>
<td>As noted previously, the recommended way to do this in Revit VSTA is to register event handlers in the *_Startup method and unregister them in the *_Shutdown method. Every VSTA macro will be loaded and unloaded dynamically. When you debug a macro, if the event handler is not properly unregistered, Revit may call a wrong method (maybe an invalid memory address). Although Revit VSTA may prevent Revit from crashing in this scenario, any event handlers that are not properly unregistered may cause performance issues during your current Revit session.</td>
</tr>
<tr>
<td>I have a dialog that does not seem to work correctly and is causing issues with Revit.</td>
<td>Modeless dialogs operating outside the scope of a running API callback may cause problems. It is recommended that you avoid such callbacks to prevent instability in Revit.</td>
</tr>
<tr>
<td>I want to experiment with the Startup and Shutdown methods and an event handler. Can you show me an example?</td>
<td>The following sample code shows how to register an OnDocumentNewed event handler, which will automatically launch a message box when a new Revit project is created. Note: One of the VSTA samples provided on the Revit SDK may show an example of a document-level event handler’s startup and shutdown. This FAQ shows Application-level event handler examples. Please note that all API events can be accessed by VSTA in 2011. Events prior to 2011 were removed. The following examples show the new events in VSTA:</td>
</tr>
</tbody>
</table>
### Related Information about Revit Macros

#### Quick Reference

To learn more, please refer to the following resources:

- **The RevitAPI.chm Help file** contains the Revit API .NET reference documentation. The API reference documentation is provided with the Revit SDK, which is on the product DVD and the Autodesk web site: [http://www.autodesk.com/revit-sdk](http://www.autodesk.com/revit-sdk). Be sure to access the Revit API SDK for your release of Revit. As noted earlier in this topic, the SDK also includes the Revit VSTA samples.

- **DevTV: Introduction to Revit Programming** is a video on autodesk.com that you can download. The narrated video covers the Revit API for external commands and external applications. It does not describe
the macros functionality with Revit VSTA, but should be of interest to developers who are looking for more details about the full Revit SDK API and its samples. See http://www.autodesk.com/revit-sdk, and look for the section that starts with “DevTV.”

■ The Autodesk Developer Network (ADN), http://adn.autodesk.com, has information and expert advice about the full Revit API. If you do not already have an ADN login account, please contact your Autodesk representative.
Memory Usage

To minimize possible instability in Revit Structure when it uses operating system memory, you can:

- Restart Revit Structure regularly.
  If you receive a message that the current session’s memory usage is approaching the operating system limit, save your work as soon as possible and restart Revit Structure. If you are using a workshared environment, save your local file, restart Revit Structure, and then synchronize with central.

- Enable the 3 GB feature on your Windows® operating system to improve performance on 32-bit machines. See Enabling the 3 GB Feature on 32-Bit Machines on page 1672.

- Run 64-bit Revit Structure on a Windows 64-bit operating system.

- Reduce the number of loaded DWG and RVT links. See Managing Links on page 1203.

- Reduce the number of loaded RVT and RFA files. See Deleting Unused Families and Family Types on page 683.

- Limit the number of views open. If you have multiple views open, you can quickly close all hidden views by selecting View tab ➤ Windows panel ➤ (Close Hidden).

- Limit the number of worksets that you open when using a workshared file. In the Open dialog, from the Open drop-down list, select Specify, which lets you select the worksets to close before opening the local file.

**NOTE** In some cases, antivirus software solutions can lock files or slow data transfer, giving the appearance of memory limitations. See File Operations (Open, Save, Synchronize) Are Blocked or Slow on page 80 for more information.

3 GB Feature Considerations

Before deciding to use the 3 GB feature, review the following considerations:

- This feature is supported only on Windows XP SP2 and Windows Vista running on 32-bit machines.

- When the 3 GB feature is enabled, your operating system has less memory space. It is not completely clear what implications this may have on Windows, so be cautious with regard to the total application load placed on Windows while running in this mode. If you do not require the larger address space, it is recommended that you do not enable this option.
At least one graphics card driver version (ATI Fire GL 8800, driver version 6.12.10.3035) is known not to work with 3 GB. If you experience a crash, restart your computer without the /3GB option and check whether upgrading to the latest graphics card driver resolves the issue.

Enabling the 3 GB Feature on 32-Bit Machines

Revit Structure is a 32-bit application, which is limited to 4 GB of virtual address space. Typically, on a 32-bit machine, Microsoft® Windows® reserves 2 GB of the 4 GB virtual address space of any process for the operating system and leaves the remaining 2 GB for the application process (including the space for the code pages, the stack, and all dynamically allocated memory). The 3 GB feature divides the virtual address space differently on 32-bit machines, providing 3 GB for the application and 1 GB for the operating system.

On 64-bit machines, the 3 GB switch does not apply because Windows does not reserve virtual address space for the operating system, allowing Revit Structure to use up to the available 4 GB.

Before enabling the 3 GB feature, see 3 GB Feature Considerations on page 1671.

To enable the 3 GB feature on Windows XP

1. Open the boot.ini file.
   
   This file is typically located in C:\, and it is a protected operating system file. To see it, in a Windows Explorer window, click Tools menu ➤ Folder Options. On the View tab, clear Hide protected operating system files, and click OK.

2. In the operating systems section, copy the original line containing the boot path, then modify the copied line to add the option (/3GB) and the display string that identifies the boot option. Examples of the line to copy and the modified version of the line are shown below. The modified portions of the copied line are in bold.

   - multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
   - multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional 3GB" /3GB /fastdetect

When you start your computer with the modified boot.ini file, you see the following options to select from:

- Microsoft Windows XP Professional
- Microsoft Windows XP Professional 3GB

To enable the 3 GB feature on Windows Vista

1. Click Start menu ➤ All Programs ➤ Accessories, and run the command prompt.

2. Enter BCDEDIT /SetIncreaseUserVa 3072, and exit the command prompt.

   **NOTE** If you are not able to set this value, when you run the command prompt, right-click, and click Run as Administrator.

3. Reboot the computer.

   The switch is now set. It is not necessary to make a selection when you reboot the computer; it is automatically enabled.

After you enable the 3 GB feature, you should verify that you have sufficient virtual memory allocated for your purposes. See Verifying Virtual Memory Allocation on page 1673.
Verifying Virtual Memory Allocation

To verify virtual memory allocation on Windows XP

1 Click Start menu ➤ Settings ➤ Control Panel.
2 In the Control Panel, double-click System.
3 In the System Properties dialog, click the Advanced tab.
4 In the Performance field, click Settings.
5 In the Performance Options dialog, click the Advanced tab.
6 In the Virtual Memory field, click Change.

To verify virtual memory allocation on Windows Vista

1 Click Start menu ➤ All Programs ➤ Accessories, and run the command prompt.
2 To change the virtual memory allocation back to 2 GB, enter:
   BCDEDIT /SetIncreaseUserVa 2048

   **NOTE** If you are not able to set this value, when you run the command prompt, right-click and select Run as Administrator.

   To verify the virtual memory allocation, enter BCDEDIT.
   In the boot entry option list, the value displays with the IncreaseUserVa option.

Your system should have at least 3 GB set aside for the paging file size to take full advantage of the available address space. Every concurrently running application is sharing the available paging file size, so setting it to something more than 3 GB (such as 4 GB) is recommended.
Best Practices

Performance
- Memory usage
- Rendering performance

Modeling
- Walls
- Structural walls
- Beams
- Lighting
- Design options

Sketching
- Splines
- Extrusions
- Sweeps

Document the project
- Keynotes
- Rendering
- Render appearances
- Image files for rendering
- Printing

Collaborate with others
- Linked models
- Worksharing
- Project base points and survey points
- Copy/Monitor

Importing
- Building components
- Masses
- CAD geometry

Exporting
- Export model geometry
- Export to 3ds Max
Troubleshoot

Troubleshooting

Read these topics for information about troubleshooting issues when using Revit Structure.

Modeling
- Sketching
- Editing elements
- Walls
- Roofs
- Curtain elements
- Design options

Document the project
- Views and visibility
- Keynotes
- Printing
- Rendering
- Exporting to 3ds Max

Collaborate with others
- Linked files
- Visibility of linked models
- Orphaned elements
- Unresolved references to linked models
- Worksharing
Diagnostic Tools

Revit Structure features a diagnostic tool that can assist you when you are communicating with support. You can select elements by their ID or show their ID, which allows support to address your issues promptly.

Selecting Elements by ID Number

If you receive an error message during the course of your work, the message may report a problem with an element and refer to that element by an ID number. To help you locate that element in your project, you can select it using that ID number. Your support representative may also ask you to find the element using its ID.

To select an element by ID number
1. Click Modify tab ➤ Inquiry panel ➤ Element ID drop-down ➤ Select by ID.
2. In the Select Elements by ID dialog, type the ID number, and click Show.

Revit Structure locates the element and selects it in the view. This tool is especially useful if you are trying to locate a view-specific element by its ID.

Finding an Element's ID Number

1. Select an element in a view.
2. Click Modify tab ➤ Inquiry panel ➤ Element ID drop-down ➤ IDs of Selection.

The ID number is reported in the Element IDs of Selection dialog.

Error Handling

If errors occur during your work, Revit Structure displays dialogs that indicate the problems. Sometimes you can ignore the message, other times Revit Structure requires that you cancel your last action. The dialog includes what the appropriate action should be.
Sample error dialog

Viewing Elements Involved in Errors

In the error message dialog, click Show to zoom in on the highlighted elements involved in the error. When you click Show, Revit Structure tries to display the elements in one of the following ways:

- The only view an element is visible in, if it is only visible in one view. Dimensions are such an example.
- A plan view that shows all the elements.
- An elevation view that shows all the elements.
- A drawing sheet that shows all the elements.
- A 3D view.
- Any view where many of the elements are visible.

If the element cannot be shown in any view, Revit Structure informs you.

Viewing all Errors and Warnings Associated with an Error Message

In the error message dialog, click Expand to extend the error message dialog and view a tree structure listing the errors and warnings associated with your last action.

To see more information about each error, click the plus sign (+) in the tree structure.

You can select (highlight) an error heading, such as Error 1, and all elements associated with that error are selected in the drawing area. Additionally, you can highlight an element name and only that element is
selected in the drawing area. After you highlight the element name, you can click Show, and Revit Structure searches views for that element only.

You can select the check box next to an element and delete it by clicking Delete Checked.

To return the error dialog to the normal view, click Collapse.

**Messages and Warnings You Can Ignore**

Warnings that require no action can be ignored. These warnings display in a dialog in the lower-right corner of the interface. When the warning displays, the element or elements that cause it are highlighted in a user-definable color. See Graphics Options on page 1625, for information about changing this color.

Unlike error messages, warning messages do not prohibit the current action. They just inform you of a situation that may not be your design intent. You can choose to correct the situation or ignore it. Revit Structure maintains a list of warning messages that are displayed and ignored while you are working. The Warnings tool lets you view the list at your convenience to determine if the conditions described in the warnings still exist.

**Reviewing Warning Messages**

1. Click Modify tab ➤ Inquiry panel ➤ Warnings.
2. Click the arrow buttons as needed to scroll through the list of warning messages.
3. Click OK to close the list.

**NOTE** This tool is not enabled if there are no warning messages.

**Warnings for Selected Elements**

If there are any warnings associated with an element you select in a drawing, the respective Modify tab for the element displays a Warning panel with a Show Related Warnings tool. You can click this tool to view a list of the related warnings. These warnings are listed in the Messages panel on the Autodesk Revit Structure 2011 dialog. The following graphic displays a list of warnings.
The Messages dialog lists warnings in a tree view that you can expand to see the individual elements associated with each warning. When you select the text next to a warning, the element highlights in all open views where it is visible.

To delete an element from the model, select the check box next to an element name, and click Delete Checked.

**Exporting Warnings to a File**

Warnings that are related to selected elements in the drawing area can be exported to a separate file using on the Autodesk Revit Structure 2011 dialog. See Warnings for Selected Elements on page 1680. This can be useful, if you want to have the warnings listed next to a project as you work on it.

To export warnings to a separate file

1. In the Autodesk Revit Structure 2011 dialog, click Export.
2. In the Export Revit Error Report dialog, browse to the location where you want to store this file.
3. Click Save to save the file, and close the window.
4. Click Close to close the Autodesk Revit Structure 2011 dialog.

**NOTE** Warnings are exported in HTML format, but they can be opened in an Excel format for more advanced data manipulation.
Reference
Revit Structure exports a gbXML file structure according to version 0.37 of the gbXML schema (http://www.gbxml.org/schema/0-37/GreenBuildingXML.xsd). It contains all of the elements required to validate to the schema. The following elements and attributes are supported by Revit Structure.

### gbXML Element

This element specifies the default attributes for the entire gbXML document.

**Supported Attributes:**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>temperature-Unit</td>
<td>F or C</td>
<td>Specifies the default temperature unit wherever the temperatureUnit simple type is used. The value is F when Feet and Fractional Inches is specified as the Project Units for Length and C when Meters specified as the Project Units for Length.</td>
</tr>
<tr>
<td>lengthUnit</td>
<td>Feet or Meters</td>
<td>Specifies the default unit for length. The value is Feet when Feet and Fractional Inches is specified as the Project Units for Length and Meters when Meters is specified as the Project Units for Length.</td>
</tr>
<tr>
<td>areaUnit</td>
<td>SquareFeet or Square-Meters</td>
<td>Specifies the default unit for area.</td>
</tr>
<tr>
<td>volumeUnit</td>
<td>CubicFeet or CubicMeters</td>
<td>Specifies the default unit for volume.</td>
</tr>
<tr>
<td>useSIUnitsForResults</td>
<td>false or true</td>
<td>Specifies if the results should be given in imperial or metric units--false for imperial and true for metric.</td>
</tr>
<tr>
<td>version</td>
<td>&quot;0.37&quot;</td>
<td>Version number of the gbXML schema this file uses.</td>
</tr>
</tbody>
</table>
### Supported Children

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Campus</td>
<td>See <a href="#">Campus Element</a> on page 1686.</td>
</tr>
<tr>
<td>DocumentHistory</td>
<td>See <a href="#">DocumentHistory Element</a> on page 1687.</td>
</tr>
</tbody>
</table>

### Sample:

```xml
- </gbXML>
temperatureUnit="F"
lengthUnit="Feet"
areaUnit="SquareFeet"
volumeUnit="CubicFeet"
useSIUnitsForResults="false" xmlns="http://www.gbxml.org/schema">
version="0.37">
+ <Campus id="cmps-1">
+ <Construction id="con-w10">
+ <Layer id="lay-266">
+ <Material id="mat-266">
+ <Schedule id="schdl-Common_Office">
+ <WeekSchedule id="wk-schdl-Common_Office">
+ <DaySchedule id="dy-schdl-Common_Office">
+ <Zone id="zone-A">
+ <DocumentHistory>
</gbXML>
```

### Campus Element

The Campus element should be used as the base for all physical objects. On a campus, position one or more buildings.

#### Supported Attributes:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>Always icmps-1</td>
</tr>
</tbody>
</table>

#### Supported Children:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>See Location Element.</td>
</tr>
</tbody>
</table>
Sample:

```xml
<Campus id="cmps-1">
  + <Location>
  + <Building id="bldg-1" buildingType="Office">
  + <Surface id="su-1" surfaceType="ExteriorWall">
</Campus>
```

**DocumentHistory Element**

This element contains details about the people and programs that created and modified the gbXML file.

**Supported Children:**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProgramInfo</td>
<td>The id attribute of this element will be adesk-rvt-1. This element contains the below described children with information about Revit MEP.</td>
</tr>
<tr>
<td>CompanyName</td>
<td>The value of this element will be Autodesk.</td>
</tr>
<tr>
<td>ProductName</td>
<td>This is the name of the product release that produces this file. If this file is produced by Revit MEP, the value of this element will be Revit MEP YYYY. The YYYY can vary depending on release.</td>
</tr>
<tr>
<td>Version</td>
<td>This is the number of the product release that produces this file. If this file is produced by Revit MEP, the value of this element will be YYYY. The release number YYYY, currently 2008, will vary depending on release.</td>
</tr>
<tr>
<td>Platform</td>
<td>This is the version of Microsoft Windows. The value can be Microsoft Windows [95/98/Me/NT/2000/XP/Server 2003].</td>
</tr>
<tr>
<td>PersonInfo</td>
<td>The id attribute of this element will be adesk-rvt-usr-1.</td>
</tr>
<tr>
<td>LastName</td>
<td>The value of this element is collected from the Username in Options.</td>
</tr>
<tr>
<td>CreatedBy</td>
<td>This element indicates the time and date when this file was created. This element will include an element CADModelId, which is the Global Unique ID for this Revit project.</td>
</tr>
</tbody>
</table>

Sample:

```xml
<DocumentHistory>
  <ProgramInfo id="adesk-rvt-1">
    <CompanyInfo>Autodesk</CompanyInfo>
    <ProductName>Revit MEP 2008</ProductName>
    <Version>2008</Version>
  </ProgramInfo>
</DocumentHistory>
```
Location Element

Supported Children:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This is the value specified for Project Address or City in the Location Weather and Site dialog—blank, if a location is specified by latitude and longitude.</td>
</tr>
<tr>
<td>Latitude</td>
<td>This is the value specified for Latitude in the Location Weather and Site dialog.</td>
</tr>
<tr>
<td>Longitude</td>
<td>This is the value specified for Longitude in the Location Weather and Site dialog. Longitude is given as an angular measurement ranging from 0× at the Prime Meridian (Greenwich) to +180× eastward and 180× westward.</td>
</tr>
</tbody>
</table>

Sample:

```xml
<Location>
  <Name>Boston, MA, USA</Name>
  <City>London, United Kingdom</City>
  <Latitude>42.358300</Latitude>
  <Longitude>-71.060300</Longitude>
</Location>
```

Building Element

Supported Attributes:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>Always bldg-1</td>
</tr>
</tbody>
</table>
This is the value specified for Building Type in the Project Information dialog. The list of building types available is defined by the gbXML schema and is based on ASHRAE 90.1.

Supported Children:

**Element** | **Description**
---|---
**Area** | The building area, the total floor area is computed as the sum of areas for each Surface element of type InteriorFloor, UndergroundSlab, RaisedFloor, or SlabOnGrade.

**BuildingStorey** | Captures Building Storey Structure. A BuildingStorey element will be specified for each Level element in the project that has referenced Spaces. The Name element will be collected from the Level:Name property and the Level element in BuildingStorey will be collected from the elevation for the "Revit" Level element.

**Space** | See Space Element.

Sample:

```xml
- <Building id="bldg-1" buildingType="MultiFamily">
  <Area>2972.114583</Area>
  <InfiltrationFlow type="Average" />
  - <BuildingStorey id="bldg-lvl-Level_1">
    <Name>Level 1</Name>
    <Level>0.000000</Level>
  </BuildingStorey>
  + <Space id="sp-1-"/>
</Building>
```

---

**Space Element**

**Supported Attributes:**

**Attribute** | **Description**
---|---
**id** | This attribute is a hyphen-separated string, consisting of a prefix sp, Room Number, and Room Name. For example, sp-1-Lounge. The id attribute must be unique within the file. A number can be added to the end to avoid duplicate values. The attribute is formatted as a XML string (XSD:IDREF). Unwanted characters are filtered out or replaced with an underbar (_). The following special characters are filtered out: Period (;); Apostrophe ('); Backslash (\); Semicolon (;); DollarSign ($);

**buildingStoreyIdRef** | This specifies a unique “id” for a building storey that references this space (e.g. the Level for the Space).

---

**Basic Supported Children:**

**Element** | **Description**
---|---
**Name** | This is the value specified for Number in the Room Instance Properties dialog.
<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Area</td>
<td>This value is collected from the Space: Area parameter. This is the area computed at the Wall Finish.</td>
</tr>
<tr>
<td>Volume</td>
<td>This value is collected from the Space: Volume Parameter. This is the enclosed volume measured by interior bounding surfaces.</td>
</tr>
<tr>
<td>PlanarGeometry</td>
<td>The 2D boundary for the space measured by interior. This is a planar polygon that represents the perimeter of the space, and whose area is equal to the floor area of the space.</td>
</tr>
<tr>
<td>ShellGeometry</td>
<td>Polygons enclosing the volume measured by interior bounding surfaces. See ShellGeometry Element.</td>
</tr>
<tr>
<td>CADObjectId</td>
<td>ElementId for the associated Room element.</td>
</tr>
<tr>
<td>SpaceBoundary</td>
<td>Geometry data defining an analytical space volume where each polygon/face has a reference to a Surface. Through the Surface you can connect a source element with each polygon in a space. There will be a number of SpaceBoundary elements per Space. See SpaceBoundary Element.</td>
</tr>
</tbody>
</table>

Sample:

```xml
<Space id="sp-1-Room" buildingStoreyIdRef="bldg-lvl-Level_1">
  <Name>1 Space</Name>
  <Area>296.444444</Area>
  <Volume>2371.555556</Volume>
  + <ShellGeometry id="sg-sp-1-Room" unit="Feet">
    <CADObjectId>223542</CADObjectId>
    + <SpaceBoundary isSecondLevelBoundary="true" surfaceIdRef="su-1">
  </SpaceBoundary>
</Space>
```

**ShellGeometry Element**

**Supported Attributes:**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>This attribute is a hyphen-separated string, consisting of a prefix This attribute is sg-sp and a sequential number. For example: sg-sp-1.</td>
</tr>
<tr>
<td>unit</td>
<td>This attribute specifies the length unit for the polygons in the ClosedShell geometry--Feet for imperial or Meters for metric.</td>
</tr>
</tbody>
</table>

**Supported Children:**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ClosedShell</td>
<td>This element describes a collection of faces that make up a closed shell. It contains a series of polygons (PolyLoops) defining an enclosed volume. The volume is measured by the interior bounding surfaces for a space. It forms a solid body, which also defines the value of the volume specified for each space.</td>
</tr>
</tbody>
</table>
Sample:

```xml
<ShellGeometry id="sg-sp-1-Room" unit="Feet">
  + <ClosedShell>
</ShellGeometry>
```

**SpaceBoundary Element**

This element establishes the logical relation of a given part of the space geometry to the building constructions through its surfaceIdRef attribute. One Surface may be referenced by more space boundaries of one space.

Attributes:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>surfaceRef</td>
<td>Every SpaceBoundary will have a corresponding Surface.</td>
</tr>
</tbody>
</table>

Children:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PlanarGeometry</td>
<td>A planar polygon describing the surface geometry as described in gbXML. The geometry is currently measured per analytical (center-line), the same way as the surfaces are measured.</td>
</tr>
</tbody>
</table>

Sample:

```xml
<SpaceBoundary isSecondLevelBoundary="true" surfaceIdRef="su-1">
  <PlanarGeometry>
    + <PolyLoop>
    + <PolyLoop>
  </PlanarGeometry>
</SpaceBoundary>
```

**Surface Element**

Supported Attributes:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>This attribute is a hyphen-separated string, consisting of a prefix, su and a sequential number. For example, su-1.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>surfaceType</td>
<td>The type of surface is figured out depending on the source element and the number of space adjacencies. If there is no associate source element and no space adjacencies, it will have a type of Shade. If there are any space adjacencies, it will have a type of Air. If the source element is a Wall or a Curtain Wall and have one space adjacency, it will have a type of ExteriorWall. If the source element is a Wall or a Curtain Wall and have two space adjacencies, it will have a type of InteriorWall.</td>
</tr>
</tbody>
</table>
If the source element is a Wall or a Curtain Wall and the type Function parameter is set to Interior or CoreShaft, it will have a type of InteriorWall.

If the source element is a Wall or a Curtain Wall and have one space adjacency and if it is below grade, it will have a type of UndergroundWall.

**NOTE** If the top elevation of a surface is equal to or below the elevation specified in Ground Plane, this surface is considered to be below grade.

If the source element is a Floor and have one space adjacency, it will have a type of SlabOnGrade. If the source element is above grade, it will have a type of RaisedFloor. If the source element is below grade, it will have a type of UndergroundSlab.

If the source element is a Floor and have two space adjacencies, it will have a type of InteriorFloor.

If the source element is a Floor and the Function parameter is set to Interior, it will have a type of InteriorFloor.

If the source element is a Roof or a Ceiling and have one space adjacency, it will have a type of Roof.

<table>
<thead>
<tr>
<th>Supported Children:</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><strong>Element</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Surface and Opening elements get an Name element assigned according to the below described schema: (Orientation)-(Space#)-(Other space#)-(Exposure)-(Type)-(sequence number) [Opening Type+#] Sample: N-101-102-E-W-D-84 N = Orientation [N/NE/E/SE/S/SW/W/NW/N/T/B/X] (every surface within the sector of 22.5 degrees from the north vector gets the letter N etc) (horizontal surfaces facing upwards get the letter T for top, downwards B for bottom) (shading surfaces get the letter X for differentiation) 101 = Space number 102 = Other space number E = Exposure - exterior/interior/underground [E/I/U] W = Type [W/C/R/F] (Wall, Roof, Ceiling, Floor, Shade) (every surface type has it’s letter W-Wall R-Roof C-Ceiling F-Floor S-Shade) O = Opening Type [W/D/O] (Window, Door, Opening) (every opening type has it’s letter W-Window D-Door O-Opening) 77 = sequence number Sample surface names: N-101-E-W-84 North facing Exterior Wall #84 in space 101 N-101-E-W-84-D-1 Door #1 in North facing Exterior Wall #84 in space 101 E-101-102-I-W-92 Vertical Interior Wall #92 between space 101 and 102 T-101-E-R-141 Top facing Exterior Roof #141 in space 101 B-101-201-I-F-88 Bottom facing Interior Floor #88 between space 101 and 201 X-73 Shade #73</td>
</tr>
<tr>
<td>AdjacentSpaceId</td>
<td>This is the Id for a space that is bounded by this surface.</td>
</tr>
<tr>
<td>RectangularGeometry</td>
<td>See Opening Element</td>
</tr>
<tr>
<td>PlanarGeometry</td>
<td>See Opening Element</td>
</tr>
</tbody>
</table>
Surface and Opening elements get an CADObjectId element assigned according to the below described schema, based on associative room bounding. (Family Name): (Family Type)(Element Id) Sample:
Basic Wall: Cast Concrete Wall 12" [49749]

Sample:
- <Surface id="su-1" surfaceType="ExteriorWall">
  <Name>S-101-E-W-1</Name>
  <AdjacentSpaceId spaceIdRef="sp-1-Room" />
  + <RectangularGeometry>
  + <PlanarGeometry>
  + <Opening id="su-1-op-1" openingType="NonSlidingDoor" constructionIdRef="con-sample-3">
  <CADObjectId>223528</CADObjectId>
  </Opening>
  </PlanarGeometry>
  </RectangularGeometry>
</Surface>

Opening Element
Supported Attributes:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>This attribute is a hyphen-separated string, consisting of a prefix, op and a sequential number. For example, op-1.</td>
</tr>
</tbody>
</table>

Name
Surface and Opening elements get an Name element assigned according to the below described schema:
(Orientation)-(Space#)-(Other space#)-(Exposure)-(Type)-(sequence number) [Opening Type+#]
Sample:
N-101-102-E-W-D-84
N = Orientation [N/NE/E/SE/S/SW/W/NW/N/T/B/X] (every surface within the sector of 22.5 degrees from the north vector gets the letter N etc) (horizontal surfaces facing upwards get the letter T for top, downwards B for bottom) (shading surfaces get the letter X for differentiation)
101 = Space number
102 = Other space number
E = Expose - exterior/interior/underground [E/I/U]
W = Type [W/C/R/F] (Wall, Roof, Ceiling, Floor, Shade) (every surface type has it's letter W-Wall R-Roof C-Ceiling F-Floor S-Shade)
O = Opening Type [W/D/O] (Window, Door, Opening) (every opening type has it's letter W-Window D-Door O-Opening)
77 = sequence number
Sample surface names:
N-101-E-W-84 North facing Exterior Wall #84 in space 101
N-101-E-W-84-D-1 Door #1 in North facing Exterior Wall #84 in space 101
E-101-102-I-W-92 Vertical Interior Wall #92 between space 101 and 102
T-101-E-R-141 Top facing Exterior Roof #141 in space 101
B-101-201-I-F-88 Bottom facing Interior Floor #88 between space 101 and 201
X-73 Shade #73
The value for this attribute is based on the family category for the opening and the element in which it is contained:
For a Window, the type is OperableWindow.
For a Door, the type is NonSlidingDoor.
For an opening contained in a Roof, the type is OperableSkylight.
For a Curtain Wall Panel, the type will default to type FixedWindow. A Curtain Wall panel having a material and the material is not transparent (less than 3% transparency), the type is solid panel. Otherwise it is treated as a FixedWindow. For a Curtain Wall Panel having no material, the type is FixedWindow.
For an opening of the category Openings, the type is Air.

### Supported Children:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RectangularGeometry</td>
<td>As described in gbXML. The azimuth and tilt are always 0. The optional Polyloop is not specified.</td>
</tr>
<tr>
<td>PlanarGeometry</td>
<td>As described in gbXML</td>
</tr>
<tr>
<td>CADObjectId</td>
<td>This is the element Id for the associated element.</td>
</tr>
</tbody>
</table>

Sample:

```xml
<Opening id="su-1-op-1" openingType="NonSlidingDoor">
  <Name>S-101-E-W-1-D-1</Name>
  + <RectangularGeometry>
  + <PlanarGeometry>
  <CADObjectId>172339</CADObjectId>
</Opening>
```
Glossary

This glossary defines terms that are used in the documentation to describe features and functions that are unique to Revit Structure® or that are used in the design industries.

Glossary Terms

2D view A 2-dimensional (2D) representation of a building model displayed in the Revit interface. For example, floor plans and elevations are 2D views.

Compare with 3D view on page 1695. See 2D Views on page 725.

3D level A three-dimensional (3D) plane in the conceptual design environment on which to draw and manipulate forms.

3D model A three-dimensional (3D) representation of a building or other design.

See also building information modeling (BIM) on page 1701.

3D reference plane Reference planes are displayed in the conceptual design environment in the 3D views.

3D view A three-dimensional (3D) representation of a building model displayed in the Revit interface.

Compare with 2D view on page 1695. For more information, see 3D Views on page 757.

3ds Max An Autodesk product. 3ds Max is professional 3D animation software that provides animation, modelling, and workflow functionality for the most complex problems in design visualization and visual effects.
Revit Structure can export 3D models for use in 3ds Max. See Exporting to 3ds Max on page 1139.

**ACIS** A solid modeling technology. An ACIS object is a geometric shape that is defined using this technology. For example, ACIS represents a cube as a single object (or shape) with 6 sides. Compare with polymesh on page 1750.

Revit Structure can import ACIS objects contained in DWG, DXF, and SAT files. See Importing ACIS Objects on page 62.

Revit Structure can export 3D shapes as ACIS solids. See Solids (3D Views Only) on page 1117.

**ADSK** Autodesk Exchange File, the file format used by Autodesk applications to transmit design information. See Importing Building Components on page 68 for workflows that use ADSK files.

**altitude** The vertical angle between the horizon and the sun, with the observer at the vertex of the angle. Also called elevation angle. Angles range from 0 (on the horizon) up to 90 degrees (at the zenith).

**analemma** The figure-8-shaped path that represents the position of the sun in the sky at the same time every day over the course of a year, as viewed from the same location on Earth.

**annotation** A 2D, view-specific element that you use to document a building or design. For example, symbols, tags, keynotes, and dimensions are annotations (also referred to as annotation elements). Annotation elements are always displayed at the same paper size regardless of view scale. Compare with model element on page 1742 and datum on page 1710. For more information, see Annotating on page 887.

**annotation schedule** See note block on page 1744.

**architectural column** A column that adds architectural interest to a building. You can use architectural columns to model box-outs around structural columns and for decorative applications. Compare with structural column on page 1767. For more information, see Architectural Columns on page 509.

**area** Usable space that is defined by walls or boundary lines or both. In Revit Structure, you can perform an area analysis to define spatial relationships in a building model. See Area Analysis on page 711.
**area scheme** A set of spatial relationships in a building. For example, in an office building, you may want to distinguish between common space (such as lobbies, hallways, rest rooms, and kitchens), office space, and storage. In an apartment building, you may want to indicate rentable space and non-rentable space. After creating an area scheme, you can assign area types to individual areas in an area plan. For more information, see *Area Schemes* on page 711.

![Area Scheme Diagram]

**array** An arrangement of elements in a building model. For example, in a large office, you can create an array of desks and chairs. In a structural design, you can create an array of beams or columns. You can create a linear array, in which the elements are distributed evenly along a line, or a radial array, in which the elements are distributed evenly along an arc or a circle. See *Creating an Array* on page 1467.

![Radial Array of Columns]

**assembly code** See *Uniformat assembly code* on page 1773.

**attach** To explicitly join elements (such as walls or columns) to other modeling components. For example, you can attach walls to floors, ceilings, and roofs. (See *Attaching Walls to Other Elements* on page 453.) You can attach columns to roofs, floors, ceilings, reference planes, structural framing members, and other reference levels. (See *Attaching Columns* on page 510.)
The following image shows a floor attached to the structural layer of a wall.

**attached detail group** A group of view-specific elements that are associated with a model group. For example, an attached detail group may be comprised of door tags and window tags. See Editing Elements in Groups on page 1455.

**AutoCAD** An Autodesk product. AutoCAD enables you to create, visualize, document, and share your ideas, from conceptual design through drafting and detailing. You can import AutoCAD files for use in Revit projects, and you can export Revit files for use in AutoCAD projects.

**Autodesk® Seek** A web service that lets you search for, download, and integrate product and design information into your drawing. You can also publish families to the Autodesk Seek website to make them available for other designers to incorporate into their designs. Autodesk Seek is currently available in English only.

**AVI** A stand-alone video file that contains an animation.

Revit Structure can export solar studies and walkthroughs to AVI files. See Exporting Solar Studies on page 1388 and Exporting a Walkthrough on page 1102.

**azimuth** The bearing angle from true north, measured in degrees. Azimuth angles range from 0 degrees (north) through 90 (east), 180 (south), 270 (west), and up to 360 (north again).

**baluster** One of the small posts that make up a railing (for example, for a set of stairs).

**beam** A horizontal load-bearing element of a structure. Beams are often made of steel, wood, or concrete. For more information, see Beams on page 247.
**bearing wall** A wall that supports a vertical load in addition to its own weight. Compare with non-bearing wall on page 1744. For more information, see Structural Walls on page 345.

**BIM** See building information modeling (BIM) on page 1701.

**blend** A combination (blending) of 2 shapes to create a 3D shape. You can create blends using solid geometry and void geometry.

For example, the 2D shapes below are blended to create the solid extrusion that follows. See Creating a Blend on page 1422.

**bounding box** An invisible 3-dimensional rectangular space that contains all model elements, annotation elements, and datum elements defined in a family-based element.
The bounding box helps define the family origin of some elements, and aids joining and cutback of structural framing elements. See Bounding Boxes on page 273.

Bounding boxes of columns represented in orange

**brace** A diagonal structural element that is connected to beams and columns to help support the building. For more information, see Braces on page 310.

**break control** A Revit symbol that you can use to break a section line, break a schedule into multiple sections, or break a crop region into sections. In the following elevation view, the blue Z-shaped break controls allow you to break the crop region into sections.

**break line** The Z-shaped line used in a drafting view or detail view to obscure parts of the drawing, to focus the drawing on a particular area. The following drafting view uses break lines above and below the section to obscure less intricate parts of the door assembly.
**bubble** A shape (such as a circle or cloud) that contains identification text for a grid, level, view title, callout, or annotation.

**building footprint** The gross building area plan at ground level that is exported to an ADSK file when exporting a building site to a civil engineering application, such as AutoCAD® Civil 3D®.

**building information modeling (BIM)** A design methodology that maintains a single database of information about a building design. All information for a building design, from geometry to construction data, is stored in a project file. This information includes components used to design the model, views of the project, drawings of the design, and related documentation.

In a Revit project, every drawing sheet, 2D and 3D view, and schedule is a representation of information from the same underlying building model database. For more information, see **Building Information Modeling** on page 11.

**Building Maker** A conceptual design and modeling environment that takes any overall building form described conceptually, and maps it to building elements, such as roofs, curtain walls, floors, and walls.

See **Massing Studies and Building Maker** on page 1331.

**building model** A design created using building information modeling.

**building pad** A flat surface that is designed to be occupied by buildings and is prepared by grading, excavating, filling, or a combination of these.

In Revit Structure, you can add a building pad to a toposurface, and then modify the structure and depth of the pad. For more information, see **Building Pads** on page 125.
Buzzsaw  An Autodesk product that is an online collaboration service. Using Buzzsaw, you can store, manage, and share project documents from any Internet connection, thus enhancing team productivity and reducing costs.

In Revit Structure, you can use Publish tools to save sheets and views as DWG or DWF files, and upload these to a Buzzsaw project site in one step. See Publishing to Buzzsaw on page 1144.

CAD See computer-aided design (CAD) on page 1706.

callout  A detailed drawing of part of a view. In Revit Structure, the callout appears in a separate view. In the callout, you can add annotations and detail, which will not display in the parent view. In the parent view, the callout area is marked with a callout tag.

The following views show a callout tag in a section view, and the detail view for the callout. For more information, see Callout Views on page 746.

camera  A visualization tool that you use to create a 3D view of a building model. When you place a camera in a 2D view, you can control the target point, the camera level, and the focal point of the camera.

The following views show a camera positioned in a floor plan view, and the resulting 3D view. See Modifying the Camera Position in a Perspective 3D View on page 758.

cantilever  Part of an element that extends beyond its vertical support. For example, cantilevered beams may extend beyond the structural columns that support them, as shown.

See Cantilevers on page 367.
canvas  See drawing area on page 1715.

casework  Pre-built components, such as cabinets and cupboards for a kitchen or bathroom. Revit Structure provides family types for casework.

category  A group of elements that you use to model or document a building design. For example, categories of model elements include walls, windows, columns, and beams. Categories of annotation elements include dimensions, tags, and text notes.

Categories are organized into families of elements with similar purposes and characteristics. Families are further organized into types, as shown.

centerline  A line that indicates the middle of a dimension or model element (such as a column or a wall). In Revit Structure, you can use an element’s centerline to measure, dimension, align, resize, specify constraints, and perform other functions in a building model.

Measuring from the centerlines of walls

central model  The master project for a model on which multiple team members are working. The model can be subdivided into functional areas (worksets), such as interior, exterior, and site. The central model stores the current ownership information for all elements in the project, and acts as the distribution point for publishing work to the rest of the team. All users work in local copies of the central model and periodically save changes to the central model so that other users can see their work.
chain  A linked set of lines or walls. When drawing walls or lines in a building model, you can simplify the process by drawing a chain. You can also select a chain of lines or walls to manipulate them simultaneously.

clean  To resolve joins between 2 or more host elements that share a common face, such as walls and floors. When a view shows a coarse level of detail, Revit Structure removes visible lines between the elements. When a view shows a fine level of detail, Revit Structure shows precisely how the layers of compound walls or other structures join together. The cleaned join applies only to the current view. See Working with Wall Joins on page 457 and Joining Geometry on page 1506.

clip plane  A vertical or horizontal plane that defines a boundary for a view. You can use top, bottom, left, and right clip planes to define a view. In elevation and section views, you can also use a far clip plane to define the depth of the view. See View Range on page 864.

closed loop  A sketched line that connects to itself, creating a 2-dimensional shape. A closed loop cannot contain coincident or intersecting segments. In Revit Structure, you sketch closed loops to create floors, ceilings, plan regions, openings in walls and roofs, solid extrusions, and other parts of a building design. In the following sketch, a closed loop defines the walls, ceiling, and floor. An open loop defines the roof. See Sketching on page 1405.
**collinear** Passing through or lying on the same straight line.

**Sketching a line that is collinear with an existing wall**

**color scheme** A set of colors and fill patterns used to graphically designate rooms or areas in a floor plan. You can apply color schemes based on any parameter value for a room or area. For example, if you want to color rooms by department, set the Department parameter for each room to the desired value, and create a color scheme based on the values of the Department parameter. You can then add a color scheme legend to identify the department that each color represents.

**column** A vertical element in a building. Architectural columns add visual interest to a design. (See *Architectural Columns* on page 509.) Structural columns are vertical load-bearing elements in a structure. See *Structural Columns* on page 218.
Communication Center A tool that displays links to information about product updates and announcements.

To access the Communication Center, click in the InfoCenter toolbar in the upper right corner of the Revit window.

component A building element that is usually delivered and installed on site, rather than built in place. (Also referred to as a hosted component.)

For example, windows, doors, and furniture are components. In contrast, walls, floors, and roofs are built in place; these are called hosts or host elements. See Components on page 505.

compound wall A wall that consists of multiple vertical layers. Each layer can use a different material (such as concrete, insulation, and interior finish) and have a different function (such as structure, thermal layer, and substrate). See Working with Compound Walls on page 465.

computer-aided design (CAD) The use of computer-based tools that assist engineers, architects, and other design professionals in their design work.

conceptual design environment A type of family editor that uses geometric form-making and direct manipulation tools to create in-place and loadable mass family elements.

constraint A parameter that defines a relationship between elements in a building design. For example, you can specify the top constraint for a wall as Level 2. If Level 2 moves upward, the height of the wall increases to maintain the relationship.

For more information, see Constraints on page 1537.

construction document A document that communicates a building design to builders and contractors, so they can create the building.
Revit Structure generates construction documents using the information about the building model stored in the project file, along with user-added annotation, detailing, and layout information. For more information, see Preparing Construction Documents on page 977.

**Construction Specifications Institute (CSI)** An association that provides technical information, standards, continuing education, and other services to architects, engineers, contractors, and other building professionals. For more information, go to [http://www.csiet.org](http://www.csiet.org).

**context menu** See shortcut menu on page 1763.

**contour line** An imaginary line that connects points of equal elevation to describe the topography of a building site.

See Site Design on page 113.

**control** A graphical icon in the Revit drawing area that you use to manipulate elements. For example, when you select a chain of walls, blue circles display. These blue circles are drag controls. You can drag such a control to change the shape of the walls.
Other controls allows you to flip, lock, rotate, view, and change the shape or size of elements. See Controls and Shape Handles on page 1449.

coping (1) In structural design, the process of cutting a piece of steel from a beam to fit it to a column.

Beam before coping is applied (left) and after coping is applied (right)

coping (2) In architectural design, a finishing or protective cap for an exterior wall.

core The structural part of a compound wall or other host element. When you use Revit Structure to design a compound wall, you specify the layers and materials that compose the core of the wall, as well as the interior and exterior layers of the wall.

In the following illustration, the core is outlined in green in the wall preview. The layer list is where you define and change the layers in and around the core.
When aligning or dimensioning the wall, you can choose to measure from the center of the core or from the interior face or exterior face of the core. See Working with Compound Walls on page 465 and Dimensioning to Core in Compound Structures on page 900.

crop To limit the boundaries of a view, omitting parts of the building model from the view. See also crop region.

crop region A user interface mechanism that defines the boundaries of a view. Elements in the building model that are outside the crop region do not display in the view or on a sheet on which the view is placed. In the following floor plan view, the inner, solid red line indicates the model crop region. The outer, dashed red line indicates the annotation crop region. For more information, see Crop Regions on page 849.

CSI See Construction Specifications Institute (CSI) on page 1707.

curtain system A building component consisting of panels, curtain grids, and mullions. A curtain system usually does not have a rectangular shape. (Compare with curtain wall on page 1709). For more information, see Curtain Systems on page 640.

curtain wall An exterior wall consisting of panels connected by joints or mullions. The panels can be made of glass, brick, or other materials.
See Curtain Elements Overview on page 623.

cut line style A graphic style applied to an element when a view (such as a section view) cuts through the element, so that you are seeing a representation of its interior surface. (Compare with projection line style on page 1751.)

For the cut line style of an element, you can specify the line weight, color, and pattern. See Modifying Object Styles on page 1601 and Override Cut Line Styles on page 814.

cut plane A horizontal height at which certain elements in the view are shown in cross-section.

cut volume The amount of material that must be excavated and removed from a site to prepare it for construction. For example, in the following drawing, the red area indicates the cut volume, and the blue area indicates the fill volume required to level the site for a building. See Reporting Cut and Fill Volumes on a Site on page 124.

cutback The calculated adjustment in beam geometry that ensures beam ends meet without overlaying one another at a join. This is the visible gap seen in a steel beam connection within the Revit project. See Cutback on page 275.

datum A non-physical item that is used to establish project context. Also called a datum element. Datum elements include levels, grids, and reference planes.

For example, the following image shows a grid, which is used for the placement of columns and other model elements. The grid is not a part of the building (such as a wall or a roof) but is used in a view to help design the building.

Compare with annotation on page 1696 and model element on page 1742. For more information, see Annotating on page 887.

datum extent The size of a datum plane (a plane for a level, grid, or reference line). Datum planes are not visible in all views. If the datum does not intersect a view plane, it will not be visible in that view. You can resize datum planes so that they are visible only in certain views.

For more information, see Datum Extents and Visibility on page 1527.
**decal** An image to display on a face of a model element. For example, you can use decals for signs, paintings, and billboards. In project views, a placeholder indicates the location of a decal. The full decal displays in a rendered image.

**dependent view** A copy of a view. Use dependent views when a view of the building model is too large to display on a single sheet, and you need to divide the model into smaller segments that fit on the sheets. The dependent view remains synchronous with the primary view and other dependent views. When view-specific changes (such as view scale and annotations) are made in one view, they are reflected in all views.

For more information, see Duplicate Dependent Views on page 843.

**design option** An alternative design for a project. Design options allow a team to develop, evaluate, and redesign building components within a single project file. You can develop design options to adapt to changes in product scope, to review other designs, or to show alternatives to a client.

For more information, see Design Options on page 653.

**detail component** A 2D element that you can add to a detail view or a drafting view. For example, you may want to add a metal stud or a shim to a drafting view. Revit Structure provides over 500 detail component families, based on 16 CSI divisions. You can also create your own detail components.

See Inserting a Detail Component on page 967.

**detail group** A group of view-specific elements, such as text and filled regions. See Editing Elements in Groups on page 1455.

**detail level** A Revit setting that determines the amount of geometry displayed in a view. Detail level settings include coarse, medium, and fine, where coarse shows the least detail and fine shows the most detail.
**detail line** A line that is used to create a detail drawing. A detail line is visible only in the view in which it is drawn. (Compare with model line on page 1743.)
You can use detail lines as follows:

- To detail a view with part of the model visible, such as in a wall section or callout
- In a drafting view to draw lines with no reference to the model
- To trace underlay elements

In the following drawing, the arc is a detail line drawn in a drafting view that shows details of the roller assembly for a sliding door. For more information, see Detail Lines on page 969.

---

**detail view** A view of a model that displays as a callout or section in other views. This type of view typically represents the model in finer detail than shown in the parent view. It is used to add more information to specific parts of the model.

A detail view reflects geometry of the building model. If a related part of the building model changes, the detail view updates to reflect the change. (Compare with drafting view on page 1714.)
For more information, see Detail Views on page 959.

---

**detailing** The process of adding information about parts of a building model. Details show how materials interconnect, providing information to the builders on how a design should be constructed.
For more information, see Detailing Overview on page 955.
Roof overhang detail

**DGN** A file format supported by MicroStation of Bentley Systems, Inc. Revit Structure can import and export DGN files. For more information, see Share the Design on page 1105.

**dimension** A view-specific element that shows the size of an element or shows distances between elements or points in a building model.

As you place an element, Revit Structure displays temporary dimensions so that you can place the element accurately. You can create permanent dimensions and lock them to specify and maintain a particular size or distance.

For more information, see Dimensions on page 887.

**discipline** A functional area (such as structural, mechanical, electrical, or architectural), or an area of expertise (such as architecture, structural engineering, or construction).

In a Revit project, you can assign disciplines to categories and to views. You can then control the visibility or graphic display of elements in a view based on assigned disciplines. For more information, see Specifying Element Category Visibility on page 805.

You can also specify project units by discipline and organize the Project Browser by discipline.

**display mode** See visual style on page 1774.

**divided surface** A face or surface of a form that has been divided into UV grids. The grids act as a guide in patterning the surface. Manipulating the divided surface also manipulates the parametrically dependant patterns and component families. See Rationalizing Surfaces on page 190.

**dormer** A gabled extension that is built out of a sloped roof to hold a window.

For more information, see Dormers on page 536.
**drafting pattern** A symbolic representation of a material in a drawing. (For example, sand is represented by a stipple pattern.) You can place drafting patterns on flat and cylindrical surfaces, and you can define them for families. You can also place drafting patterns on cut component surfaces in plan views and section views.

**drafting view** A project view that shows details not directly associated with the building model. For example, a drafting view can show how carpet transitions to tile, or details of a roof drain. A drafting view typically shows construction details that may not be apparent in other views.

A drafting view is saved with the project in which it is created, and it can be included on a sheet. However, a drafting view does not reflect the actual building model, and it does not update when the model changes. (Compare with [detail view](#) on page 1712.)

The following image shows a drafting view created using the 2D detailing tools in Revit Structure. (It is not a 3D view.) For more information, see [Drafting Views](#) on page 964.

**drag control** A graphical icon in the Revit drawing area that you drag to change the shape or size of an element in the building model. When you select an element, Revit Structure displays its drag controls as blue circles or triangles.

For more information, see [Drag Controls](#) on page 1449.
**draw order** The order in which elements display in a view, as if layered on a flat surface. You can move an element backward or forward in the draw order, or bring it to the front or back of a stack of elements. See Sorting the Draw Order of Detail Components on page 958.

**drawing area** The part of the Revit user interface that displays views, sheets, schedules, and other representations of the building model. See Drawing Area on page 32.

**drawing list** A schedule (list) of all drawing sheets in a project. The drawing list functions as a table of contents for the project. It is typically placed on the first sheet of a construction document set.

For more information, see Sheet Lists on page 1015.

<table>
<thead>
<tr>
<th>Sheet Number</th>
<th>Sheet Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>A101</td>
<td>Site Plan Floor Plan</td>
</tr>
<tr>
<td>A102</td>
<td>Unit 18</td>
</tr>
<tr>
<td>A103</td>
<td>Elevations</td>
</tr>
<tr>
<td>A104</td>
<td>Elevations</td>
</tr>
<tr>
<td>A105</td>
<td>Floor/Basement/Details</td>
</tr>
<tr>
<td>A106</td>
<td>Stairs/Details</td>
</tr>
</tbody>
</table>

**drawing sheet** See sheet on page 1763.

**DWF** The Autodesk file format for publishing design data. It offers an alternative to generating PDF (Portable Document Format) files.

DWF files are significantly smaller than the original RVT files, making them easy to send by email or to post to a web site. Recipients can view DWF files using Autodesk Design Review. See Exporting to DWF Format on page 1120.

**DWF markups** A construction document that has been reviewed and revised or commented on (marked up). Typically, the reviewer is the project designer, a client, or another building professional.

When you export construction documents as DWF files, the files can be marked up electronically using a program such as Autodesk Design Review. You can link the markups back into Revit Structure to see the desired changes. See Linking DWF Markup Files on page 74.

**DWG** A drawing file format supported by AutoCAD and other CAD applications. Revit Structure can import and export DWG files. See Share the Design on page 1105.

**DXF** Drawing Exchange Format. An open file format that is supported by many CAD applications. A DXF file is a text file that describes a 2D drawing. The text is not encoded or compressed, so DXF files are generally large.

Revit Structure can import and export DXF files. See Share the Design on page 1105.

**eave** The lower edge of a roof that overhangs an exterior wall.

The following drawing shows the eave of the roof in green. For more information, see Eaves on page 533.
element An individual item in a building model.
Revit Structure projects use 3 types of elements:

- **Model elements** represent the actual 3D geometry of a building. For example, walls, floors, and roofs are model elements.
- **Annotation elements** help to document the model. For example, dimensions, text notes, and section tags are annotation elements.
- **Datum elements** are non-physical items that are used to establish project context. For example, levels, grids, and reference planes are datum elements.

The following drawing includes model elements (walls, doors, planters), annotation elements (dimensions, text notes), and datum elements (grid lines). For more information, see Element Behavior in a Parametric Modeler on page 14.

**element borrowing** A Revit function for workshared projects. Element borrowing allows you to edit an element in a workset that you do not own. If another team member is currently editing the workset, that team member is the owner of the workset and you must place a request to borrow the element. If no one owns the workset, permission to borrow is automatically granted.

See Borrowing Elements on page 1219.

**element properties** Appearance or behavior attributes of elements in a project. Element properties include both instance properties and type properties.

When an element is selected in the drawing area, you can view or change its instance properties on the Properties palette. Click the Edit Type button on the palette to access a dialog in which you can view or edit the element’s type properties.

**elevation** An orthographic view of a vertical part of a building model. Typically, an elevation provides a side view of a building. Also called an elevation view.

For more information, see Elevation Views on page 730.

**embedded wall** A wall that is inserted into another wall of a different type or construction. Embedded walls are useful, for example, when you need to create a storefront on a building exterior.

The following image shows a curtain wall embedded in a host wall. For more information, see Embedding Curtain Walls on page 629.
end cap An end of a wall that does not join to another wall. The unjoined end of the wall is exposed. You can specify whether compound wall layers wrap at end caps. For example, the following image shows a cross-section of a compound wall that uses interior wrapping at the end caps. See Layer Wrapping on page 576.

endpoint The end of a sketched line. See Sketching on page 1405.

entourage An architectural term that refers to the landscaping and other environmental features shown in a rendering of a building. For example, entourage can include plants, trees, people, cars, and signs. Revit Structure provides a library of entourage families, and you can create or load additional entourage into a project.

explode To disassemble an import symbol (which represents imported geometry) into its next highest level of elements. See Exploding Imported Geometry on page 75.

export To convert information from a Revit project to another format, for use with another software application. For more information, see Export on page 1105.

extend To lengthen selected elements to meet a specified boundary. See Trimming and Extending Elements on page 1489.

exterior The outside of a building, or the outside face of a surface.

external reference An AutoCAD mechanism that allows the architect to reference other drawing files in an AutoCAD-based project. Also referred to as an xref. See Implications of Importing vs. Linking for Xrefs on page 58 and Exploding Imported Geometry on page 75.

extrusion A method of defining 3D geometry for a building model. You begin a solid extrusion by sketching 2D shapes on a plane. Revit Structure then extrudes the sketch between a start point and an endpoint. See Creating an Extrusion on page 1420. You can also create a void extrusion by cutting a shape out of a 3D solid. See Creating an Extrusion on page 1420.
face A surface of a model element or mass.
You can apply paint, materials, and textures to each face of a model element (such as a wall). These details display when you render an image of the building model. See Applying a Material to the Face of an Element on page 1512.
You can use mass faces as the basis for creating walls, roofs, curtain systems, and floors in a building model. The following image shows a mass face that is being used to create a wall. See Creating Building Elements from Mass Instances on page 1356.
**family** A class of elements in a category. A family groups elements with a common set of parameters (properties), identical use, and similar graphical representation.

Different elements in a family may have different values for some or all properties, but the set of properties (their names and meaning) is the same. For example, a family of concrete round columns contains columns that are all concrete and round, but of different sizes. Each column size is a type within the Concrete Round Column family.

See category on page 1703 for examples of the hierarchy of categories, families, and types of model elements and annotation elements. For more information, see Element Behavior in a Parametric Modeler on page 14 and Revit Families on page 677.

**family type** Also referred to as simply a *type*. See family on page 1719 and type on page 1772.

**far clip plane** The clip plane that is at the side of the view farthest from the start point of an elevation view, a section view, a 3D view, or a walkthrough view.

In the following floor plan, the green dotted line opposite the blue line represents the far clip plane for an elevation. See Changing the Clip Plane in an Elevation View on page 732.

**fascia** A board (or other covering) used to conceal the exposed ends of roof rafters. The fascia can be plain or decorative, as in the following illustration (shown in red). For more information, see Fascia on page 539.

**fenestration** The stylistic arrangement of windows on the face of a building.

**fill pattern** A graphic design for surfaces that are cut or shown in projection. You can use fill patterns for model patterns and drafting patterns.

For more information, see Fill Patterns on page 1566.
**Floor fill pattern**

**fill volume** The amount of fill (material) required to prepare a site for construction. For example, in the following drawing, the red area indicates the cut volume, and the blue area indicates the fill volume required to level the site for a building. See Reporting Cut and Fill Volumes on a Site on page 124.

**filled region** A 2D, view-specific graphic. You can use filled regions to represent various surfaces, such as concrete or compacted earth. You can add a filled region to a detail view, a drafting view, or an annotation family. For each filled region, you can specify a boundary line style and a fill pattern.

For more information, see Filled Region on page 972.

**Fillet** A drafting term that refers to rounding a square corner, using a radius to define the curve. See Sketching a Fillet Arc on page 1413.
**filter** A mechanism for eliminating or including the display or selection of elements in a view, based on their properties. In Revit Structure, you can use filters in the following ways:
- To select or deselect elements in a view. See *Selecting Elements Using a Filter* on page 1442.
- To override the graphic display and control the visibility of elements in a view. See *Controlling Visibility and Graphic Display of Elements Using Filters* on page 806.
- To control the display of elements based on their phase status: new, existing, demolished, or temporary. See *Phase Filters* on page 879.

**flange** A ridge that projects at right angles from the edge of a beam to provide strength and rigidity.

**flip control** A graphical icon in the Revit drawing area that you can use to reverse the position or orientation of an element in the drawing area.

For example, when you click the flip control for a compound wall, the wall flips over, so its layers reverse. See *Flipping Elements* on page 1483.

*Compound wall with flip control*

**flip grip** Another name for a flip control.

**floor area face** See *mass floor* on page 1739.

**floor plan** A 2D drawing of a building model that shows the layout of walls and other building components. In Revit Structure, a floor plan is also referred to as a floor plan view. See *Plan Views* on page 725.

**focal point** The point in the distance on which a camera is focusing. See *camera* on page 1702.
**footing** The base of a foundation that rests directly on the soil. The footing is generally wider than the foundation to distribute its load and provide additional stability for the building.

![Footing Diagram](image)

**footprint** The area covered by or required by an object. For example, the footprint of a toaster on your kitchen counter is the amount of countertop that the toaster covers.

In Revit Structure, you can create a roof or floor based on the footprint of the walls. You can also sketch a 2D shape to represent the desired footprint of the walls, roof, floor, or stairway of a building.

In the following image, the pink lines indicate the sketched footprint of a roof for a building. The pink angles indicate the slope of the roof on each side.

![Footprint Diagram](image)

**form** The various geometric shapes created in the conceptual design environment, for example, extrusions, sweeps and lofts.

![Form Diagram](image)

**formula** A mathematical equation used to determine the dimension of an object or a calculated value for a schedule. Formulas allow you to create parameters that depend on other parameters for their values. For example, you can create a width parameter that equals twice the height of an object.

**foundation** The structural base of a building that provides stability and rigidity. A wall foundation usually rests on a footing. A slab foundation may rest directly on prepared ground.

See Wall Foundations on page 355 and Foundation Slabs on page 382.
frame (1) In an animation, a single image (for example, in a walkthrough animation or a solar study).

frame (2) In a building, a rigid structure built into a wall to hold a door, window, or other component. In Revit Structure, you can specify the material and finish for a door frame.

Frame for a new window family

framing elevation An elevation view that shows the structural framing of a building model. You can work in a framing elevation when adding vertical bracing to the model, or for any task that requires quick work plane alignment to a grid or to a named reference plane.

See Framing Elevation Views on page 733.

full explode The process of completely disassembling an import symbol (which represents imported geometry) into Revit elements, including text, curves, lines, and filled regions. (Compare with partial explode on page 1746.)
See Exploding Imported Geometry on page 75.

gable A triangular area of an exterior wall formed by 2 sloping roofs, from ridge to eaves.
For more information, see Roofs on page 519.

generic annotation Text that documents a building model. Generic annotations are usually related to a parameter for a model element or type.
You can create generic annotation families and nest them inside host model families, so that the annotations display in the project. This is useful if you want to include a label with a model family and display that label in the project.

generic model A family of geometry that does not fit into any of the other, pre-defined categories (such as columns, roofs, and floors). In a Revit project, an instance of a generic model is a model element.
You can create a generic model as a loadable family, or as an in-place element that is specific to a project. (See Revit Families on page 677.) Revit Structure provides templates for various types of generic model families.

glazing Panes or sheets of glass set into sashes or frames (for example, for windows, doors, or mirrors). See Creating a Roof on page 521.

girder A beam used as a main horizontal support in a building or bridge. Girders are often made of steel, wood, or reinforced concrete.

graded region A sloped area in a topographical surface.
For more information, see Graded Regions on page 121.
grid A series of lines that you can use to help draw or place elements in a building design. Grids are useful in the design and documentation phases of a project. In Revit Structure, grids are datum elements. For more information, see Grids on page 98.

ground plane A horizontal plane that represents ground level in a building model. In Revit Structure, you can specify the ground plane when creating a solar study for 2D and 3D views. (See Creating Solar Studies on page 1376.)

group A defined set of elements that can be placed as a unit in a building design. Grouping elements is useful when you need to create entities that represent repeating units or are common to many building projects (for example, hotel rooms, apartments, or repeating floors). See Editing Elements in Groups on page 1455.

Hotel room elements grouped and repeated

gutter A trough (often made of metal or plastic) along the edge of a roof. A gutter collects water off the eave and carries it to the down spout. See Roof Gutters on page 545.

halftone A display color that blends the line color of an element with the background color of the view. For example, the following image shows some elements in halftone (gray) and others in black. You can specify the halftone display properties using the Visibility/Graphics dialog. See Visibility and Graphic Display in Project Views on page 801 and Halftone/Underlay on page 1605.
head (1) For elements that can slope (including roofs, ramps, floors, and ceilings), the upper end of the slope. For example, in the following illustration, the head is the upper end of the sloped floor.

hidden element An element that you hide in a particular view.
See Hiding Elements in a View on page 811 and Showing Hidden Element Lines on page 862.
**hidden line** A dashed line representing an edge or surface that cannot be seen in a view. For example, in the following image, 2 bolts go through the stud. The view shows the hidden lines of one bolt but does not show the hidden lines of the second bolt. See also **hidden line mode** on page 1727. For more information, see **Show Hidden Lines** on page 957.

![Hidden Line Example](image)

**hidden line mode** A visual style in which Revit Structure hides the lines of elements that are obscured by other surfaces. (Compare with **wireframe** on page 1776.) See **Hidden Line Visual Style** on page 869.

![Hidden Line Mode Example](image)

**highlight** To move the cursor over an object in the drawing area so that Revit Structure displays the object's outline in a different weight (bold) and color (such as gray instead of black). A description of the element displays on the status bar at the bottom of the Revit window. After a brief delay, the element description also displays in a tooltip near the cursor. This highlighting indicates that the object is ready for selection. Click to select the highlighted object. See **Selecting Elements** on page 1439.

**Wall before and after highlighting**

![Wall Highlighting](image)

**host** A model element that can accept (host) other components. For example, a wall is a host for windows and doors. A roof is a host for skylights and dormers. A host may also be referred to as a host element or a host component.

Compare with **hosted component** on page 1728.
**hosted component** A model element that can exist in a building model only if sponsored by another (host) element.

For more information, see **Components** on page 505.

**i-drop** An Autodesk feature that allows you to drag and drop content from a web page into a Revit session. Using i-drop, designers and developers have the power to create web pages that can easily be dragged and dropped into Autodesk design products that are i-drop enabled.

You can import CAD files into Revit Structure using i-drop. See **Importing CAD Files Using i-drop** on page 59.

**IFC** See **Industry Foundation Classes (IFC)** on page 1728.

**imperial** The British Imperial System of weights and measures.

When you install Revit Structure, you specify whether you want to use imperial units (feet and inches) or metric units (meters and centimeters). You can also change the type of units used in a project. See **Project Units** on page 1613.

**import** To bring information from another source into a Revit project. For example, you can import DWG files created using a CAD application (such as AutoCAD) into Revit Structure. See **Import/Link Overview** on page 57.

**import symbol** A Revit element that contains all objects (such as blocks and xrefs) from an imported drawing. When you move the cursor over the imported objects, Revit Structure shows information about the import symbol.

You can explode an import symbol to convert it into individual Revit elements. See **Exploding Imported Geometry** on page 75.

**imported categories** Categories of elements that are derived from an imported drawing. See **Exploding Imported Geometry** on page 75.

You can change the visibility and graphic display of imported categories. See **Visibility and Graphic Display in Project Views** on page 801.

**in-place family** A family of elements that is created within the context of the current project. An in-place family exists only in the project and cannot be loaded into other projects.

Using in-place families, you can create components that are unique to a project or components that reference geometry within the project. In a structural model, you might create an in-place family for a thickened structural floor, or a wall extrusion that conforms to a uniquely shaped architectural wall that it supports. If the original design ever changes, the in-place element changes accordingly.

The following dome roof was created as an in-place element. For more information, see **In-Place Elements** on page 696.

*A dome roof created as an in-place element*

**Industry Foundation Classes (IFC)** A file format developed by the International Alliance for Interoperability (IAI). IFC provides an interoperability solution between IFC-compatible software applications in the construction and facilities management industry. The format has established, international standards to import and export building objects and their properties.
Revit Structure provides IFC import and export based on the latest IAI IFC data exchange standard. When you export a Revit building model to IFC format, the information can be used directly by other building specialists, such as structural and building services engineers.

For more information about Revit Structure and IFC, see Exporting to Industry Foundation Classes (IFC) on page 1132 and Opening Industry Foundation Class (IFC) Files on page 70.

For more information about the IFC file format, go to http://www.iai-international.org.

**infill element** An insert that fills (patches) a hole in a host element after changes are made during different phases of a building project. For example, if you remove a window from a wall during a demolition phase, Revit Structure fills the hole with an infill element. By default, the infill element has the same properties as the host element (the wall).

The following illustration shows a demolished window that has become an infill element. See Infill Elements for Phasing on page 881.

An infill element replacing a demolished window

**InfoCenter**

You can use InfoCenter to search a variety of information sources with one query. You can also easily access product updates and announcements.

**instance** An individual occurrence of an element type.

For example, when you place a wall in a building model, the wall is an instance of the wall type. If you change parameters for the wall instance, the changes affect only that wall. If you change parameters for the wall type, the changes affect all walls (instances) of that type, including existing walls and new walls that you create in the future.

**instance parameters** Settings on the Properties palette that specify the instance properties on page 1729 of an individual element in a project.

**instance properties** Appearance and behavior properties that can vary for individual instances of an element type. Instance properties are specified through corresponding instance parameters on page 1729 on the Properties palette.

**insulation** Material that has insulating properties designed to help a building retain heat in winter and prevent heat gain in summer. In Revit Structure, you use a detail component to represent insulation in 2D drawings.
interior  The inside of a building, or the inside surface of an object.

interoperability  The ability of Revit Structure to interact with other software applications. Examples of interoperability include importing files from other applications into a Revit project, and exporting a Revit project to a file format that can be used by other applications.
For more information, see Share the Design on page 1105.

isolate  To display only a certain element or type of element, so that you can work with it in a particular view without being distracted by other elements in the design.
See Temporarily Hiding or Isolating Elements or Element Categories on page 812.

A roof that has been isolated from the rest of the building model

join  The intersection where 2 or more elements share a common face.

join (2)  To resolve intersections between elements that share a common face. The level of detail for the view determines the detail of join geometry that is shown.
The following images show geometry before they are joined (top) and after they are joined (bottom) in a view with a coarse detail level. See Joining Geometry on page 1506.
Before joining geometry

After joining geometry

**joist** A beam that supports a floor or ceiling. Joists are generally made of wood, steel, or concrete. They are often set parallel from wall to wall or across or abutting girders. See Structural Usage of Beams on page 249.
key schedule A table of information that you create to simplify or automate data entry in other, larger schedules. A key schedule can reduce the time required to produce a larger schedule and help to generate accurate cost estimates.

For more information, see Key Schedules on page 772.

keynote legend A list of keynote numbers and the corresponding keynote text. (See keynoting.)

If you choose to annotate model elements using keynote numbers only, you can use a keynote legend to provide descriptive text for each keynote number. By using a keynote legend, you avoid cluttering the drawing with text.

For more information, see Keynote Legend on page 941.

keynoting A method of annotating drawings to identify building materials, describe assembly instructions, or provide special instructions or explanations. Keynotes help to standardize information related to the building design and can help reduce clutter in drawings.

In Revit Structure, each sheet can display its own keynote legend, or all keynotes for the project can be documented on one sheet. For more information, see Keynotes on page 938.

label A text placeholder added to tags or title blocks. You create a label as part of a tag or title block family while in the Family Editor. When you place the tag or title block in the project, you replace the label with the actual value for that instance.

For example, the following title block template contains labels that indicate the type of information to be entered on a sheet. When you create a sheet, the labels are replaced with actual values.

<table>
<thead>
<tr>
<th>Owner</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Name</td>
</tr>
<tr>
<td>Project Number</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Issue Date</th>
<th>Name</th>
<th>Checker</th>
</tr>
</thead>
<tbody>
<tr>
<td>Steel Number</td>
<td>A101</td>
<td></td>
</tr>
</tbody>
</table>

landing A platform between sets of stairs, or the floor at the head or foot of a ramp or a set of stairs.
layer (1) In Revit Structure, the adjacent materials of a compound structure, such as a wall. You can define the layers in a compound structure. See Compound Structure on page 573.

layer (2) In AutoCAD, a mechanism for defining, organizing, and controlling the display of drawing objects. When you export a Revit project to a CAD format, you can create a layer mapping file to map Revit categories and subcategories to CAD layers. See Exporting Layers on page 1125.

layer mapping file A text file that maps each Revit category or subcategory to a preconfigured layer name for the CAD software.

The layer names are preconfigured in the text file, but you can change them. You use a layer mapping file when exporting a Revit project to a CAD format. See Exporting Layers on page 1125.

leader A line that connects an annotation to an element or part of the building model in a view. Also referred to as a leader line.

In Revit Structure, you can control the line weight, style, and color of the leader, as well as its position, shape, and arrowhead.

legend A table that provides descriptions or information about symbols used in drawings.

In Revit Structure, you can create a legend and include it on multiple sheets. See Legend Views on page 767.

Symbol legend for use on construction documents

level A finite horizontal plane that acts as a reference for level-hosted elements, such as roofs, floors, and ceilings.

In Revit Structure, you define a level for each vertical height or story within a building, or other needed reference of the building (for example, first floor, top of wall, or bottom of foundation). You can add levels in a section or elevation view.

For more information, see Levels on page 93.
library A collection of predefined resources that you can use in a Revit project. For example, you can access libraries of templates, detail components, entourage, materials, and families of model elements and annotation elements. Revit Structure provides some libraries. Other libraries are available on the Internet.

Family categories in the Imperial library

<table>
<thead>
<tr>
<th>Category</th>
<th>Size</th>
<th>Type</th>
<th>Date Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Annotations</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Elevators</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Fixtures</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Framwork</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Columns</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Curtain Family Pattern</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Curtain Wall Finishes</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Metal Components</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Door</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Architectural Elements</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Furniture</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Furniture Screens</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Lighting Fixtures</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Plans</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Mechanical Equipment</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Plumbing</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Piping</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Stone</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Specialty Equipment</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Structural</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Sustainable Design</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
<tr>
<td>Windows</td>
<td>File</td>
<td>Folder</td>
<td>1/10/10 01:47 PM</td>
</tr>
</tbody>
</table>

line pattern A series of dashes or dots alternating with blank spaces.
In the building industry, construction documents often use different line style conventions to convey information and to differentiate one line from another. For example, dimensions may use thin solid lines, while callout bubbles use heavy dashed lines.

You can specify the line pattern as part of the line style for many types of lines used in Revit Structure. (See line style on page 1735.)

To define line patterns, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Patterns. For more information, see Line Patterns on page 1604.

**line style** A line of a particular pattern, weight, and color, used to indicate different effects. For example, in the following site plan, a red dashed line indicates the zoning setback.

Revit Structure predefines several line styles and uses them for default purposes. You can change these and add your own line styles to suit your needs and preferences. For more information, see Line Styles on page 1602.

**line weight** The thickness of a line.

You can specify the line weight as part of the line style for model lines, perspective lines, and annotation lines used in Revit Structure. (See line style on page 1735.) To define line weights, click Manage tab ➤ Settings panel ➤ Additional Settings ➤ Line Weights.

For more information, see Line Weights on page 1603.
**linear** Arranged in a line.

For example, when you create a linear array, the elements in the array are arranged along a straight line. See Creating a Linear Array on page 1467.

**link** To connect a file to a Revit project. When a linked file is updated, the updated information is automatically made available in the Revit project. Linking avoids the need to re-import updated information into the project.

In Revit Structure, you can create a link between projects. You can also link CAD files and DWF markup files to a Revit project. See Import/Link Overview on page 57 and Linked Models on page 1177.

**listening dimensions** A Revit feature that allows you to specify a value for a dimension as you sketch an element in a view. You specify a start point for the element, start sketching in the desired direction, type the exact dimension desired, and press `Enter`. Revit Structure draws the element to the specified length.

The following image shows the text box that appears when you start to type a listening dimension. For more information, see Listening Dimensions on page 909.

**load** To transfer a file or a collection of information from an outside location into a Revit project.

In Revit Structure, you can load groups, templates, detail components, entourage, materials, families of model elements and annotation elements, and other project information.

See also library on page 1734.

**local file** A copy of the project file that resides on the computer system of the team member who is working on the file. When worksharing is used to distribute project work among team members, each member uses a local file to work on his or her workset (functional area). Team members periodically save their changes to the central file so that others can see the changes and update their local files with the latest project information.

For more information, see Working in a Team on page 1209.
**location line** A vertical plane in a wall that is used for dimensioning. You create a wall by sketching the location line of the wall in a plan view or a 3D view. You specify what to use for the location line in the instance properties on page 1729 of the wall: the wall centerline, core centerline, interior or exterior wall face, or interior or exterior face of wall core.

In the following illustration, the green dashed lines indicate the location line of the wall. See Walls on page 449.

![Illustration of a wall with location line](image)

**lock** To secure a dimension or the location of an element so that it cannot be changed. When you select a locked dimension or element, a lock control displays next to it.

The following drawing shows a locked dimension. See Locking Permanent Dimensions on page 896.

![Locked dimension](image)

You can also use the Pin tool to restrict the movement of elements. See Preventing Elements from Moving on page 1484.

**mark** A unique identifier that you assign to an element in its properties. (Compare with tick mark on page 1771.)

You can include marks in schedules and tag labels. For example, the following site plan shows marks for individual parking spaces. These marks are also listed in the parking schedule.

![Site plan with marks](image)

**markup** Comments or revision instructions from someone who reviewed a building design.

When you publish construction documents as DWF files, the files can be marked up electronically using a program such as Autodesk Design Review. Then the markups can be linked back into Revit Structure to display the desired changes. See Linking DWF Markup Files on page 74.
**masking region** A defined area that obscures elements in a view. Masking regions are useful when you are creating a model family from an imported 2D DWG file, and you need the model element to obscure other elements when placed in a view. You can also use them to hide parts of a drawing.

For more information, see **Masking Regions** on page 973.

**Masking regions sketched in upper corners**

**mass** A 3-dimensional shape used in the initial design of a building model. See **Massing Studies** on page 1329.
mass face See face on page 1718.

mass floor An interior horizontal surface in a mass. During the conceptual design stage of a building project, a mass floor represents a story in the building.

You can divide masses into mass floors to perform various types of analysis on the design. See Analyzing a Conceptual Design on page 1335.

massing study One or more masses in a Revit project. Massing studies allow you to explore design ideas by using shapes to conceptualize a building model. When your conceptual design is complete, you can add building elements directly to these shapes.

See Massing Studies on page 1329.

Massing study used as the basis for a building design
**matchline** A sketch line that indicates where to split a view for a dependent view, as shown. See Duplicate Dependent Views on page 843.

**material** The substance of which an element is made.

In Revit Structure, the material assigned to an element determines how the element appears in a view or rendering. Revit Structure includes several materials in the default project templates, or you can define your own. You can specify the color (in a shaded view), texture (in a rendered image), surface pattern (in a projection), and fill pattern (in a cut view).

See Materials on page 1573.

**material takeoff schedule** A list of the subcomponents or materials of any Revit family. Material takeoff schedules have all the functionality and characteristics of other schedule views, but they allow you to show more detail about the assembly of a component. Any material that is applied to a component within Revit Structure can be scheduled.

For more information, see Material Takeoff Schedules on page 774.

Max See 3ds Max on page 1695.

**mesh** A grid of lines used to approximate a surface (for example, when rendering an image).
**metric** A standard of measurement that is based on the meter.

When you install Revit Structure, you specify whether you want to use imperial units (feet and inches) or metric units (meters and centimeters). You can also change the type of units used in a project. See **Project Units** on page 1613.

**mid-end face** When you edit the elevation profile of a wall that spans multiple levels and create notches such as those shown below, the new vertical edges represent jambs that are referred to in Revit as mid-end faces. Other walls can form corner joins with mid-end faces.

![Mid-End Faces](image)

**mirror** To reverse the position of a selected model element, using a line as the mirror axis.

For example, if you mirror a wall on a reference plane, the wall flips opposite the original wall. You can pick the mirror axis or draw a temporary axis. Use the Mirror tool to flip a selected element, or to make a copy of an element and reverse its position in one step.

**miter** A joint at a 45-degree angle, or evenly angled between the joined elements. Mitering can apply to walls, wall sweeps, railings, structural floors, roof fascia, curtain wall mullions, and other model elements. When 2 walls join, you can edit the wall join using a miter joint or other joint styles. See **Changing the Configuration of a Wall Join** on page 458.
**model** A representation of a building or other design. See also building information modeling (BIM) on page 1701.

**model element** An element in a building model that represents actual 3D geometry. For example, walls and roofs are model elements. Compare with annotation on page 1696 and datum on page 1710. See also element on page 1716. For example, the following image shows only model elements. It does not include annotation elements (such as dimensions or text notes) or datum elements (such as grid lines or levels). See Element Behavior in a Parametric Modeler on page 14.

**model group** A set of model elements that are placed together in a building design. Model groups are useful when you need to create entities that represent repeating units or are common to many building projects (such as hotel rooms, apartments, or repeating floors). Compare with attached detail group on page 1698 and detail group on page 1711. The following illustration shows a model group (highlighted in red) that has been placed in multiple hotel rooms. See Editing Elements in Groups on page 1455.
**model line** A model element that exists in 3D space and is visible in all views of a Revit project. You can use model lines to represent 3D geometry in a building design, such as cords or cables that secure a tarp. You can sketch straight, curved, arc, circular, fillet, and tangent lines. (Compare with detail line on page 1712 and symbolic line on page 1769.) The following truss uses a model line to represent the beam stick symbol. For more information, see Model Lines on page 569.

**model pattern** A graphic design that is applied to the surface of a model element. Model patterns represent the actual appearance of an element, such as brick coursing or ceramic tile on a wall. They are fixed with respect to the model and scale with the model. See Fill Patterns on page 1566.

**model text** Text used in a building model, such as for signage. You can add model text in a project view and in the Family Editor for families that can be represented in 3D, such as walls. An instance of model text is a model element. Model text is not available for families that can only be represented as 2D, such as annotations, detail components, and profiles. You can specify properties for model text, including font, size, and material.

**modeling** The process of representing a design. See also building information modeling (BIM) on page 1701.

**moment** The amount of rotation at an axis caused by downward force applied to a beam at a distance from its supporting members. A moment connection is a connection that is designed to transfer moment and other forces between a beam and its supporting members. In Revit Structure, you can specify moment parameters for a beam, including the moment connection start and moment connection end. See Moment Symbols on page 261.

**monolithic stairs** Stairs that consist of one solid piece of material, such as concrete. In Revit Structure, you can specify that stairs are monolithic in the stair type properties. You can also specify the material for monolithic stairs. See Stair Type Properties on page 602.

**mullion** In Revit Structure, a vertical or horizontal strip between panels of a curtain wall or curtain system.

**nested family** A family that consists of instances of other families (subcomponents). The subcomponents can belong to the same category or different categories. You create nested families using the Family Editor.
For more information, see The Families Guide on page 680. See also shared family on page 1762.

**non-bearing wall** A wall that supports no additional vertical load except its own weight. Non-bearing walls can be used to define and divide spaces in Revit Structure. Compare with bearing wall on page 1699. For more information, see Structural Walls on page 345.

**note block** A list of all instances of annotations. Also referred to as an annotation schedule. Note blocks are useful for listing notes that are applied to elements in a project. For more information, see Annotation Schedules (Note Blocks) on page 774.

**Sample note block**

<table>
<thead>
<tr>
<th></th>
<th>Exterior Construction Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Seal existing doors and window frames.</td>
</tr>
<tr>
<td>B</td>
<td>Repair existing door and window. Contact Historic Preservation District official for specific requirements.</td>
</tr>
<tr>
<td>C</td>
<td>Clean and repair door and window as required.</td>
</tr>
<tr>
<td>D</td>
<td>Clean and repair existing doors and window as required.</td>
</tr>
<tr>
<td>E</td>
<td>Remove all existing windows. Clean opening and repair as required for new window installation.</td>
</tr>
<tr>
<td>F</td>
<td>Clean exterior brick wall. Touch-up as required.</td>
</tr>
<tr>
<td>G</td>
<td>Clean existing concrete (bedding stock). Repair as required.</td>
</tr>
<tr>
<td>H</td>
<td>Saw out existing brick wall. Clean cut and repair as required.</td>
</tr>
</tbody>
</table>

**NURB surface** Non-uniform rational B-spline. A mathematical model commonly used in computer graphics for representing and generating curves and surfaces. In Revit Structure, you can create roofs and curtain systems on NURB surfaces. See Creating Building Elements from Mass Instances on page 1356.

**object** A model element, annotation element, datum element, or imported element in a project.

**object style** A set of characteristics that define the line weight, line color, line pattern, and material for a category of model elements, annotation elements, or imported objects in a project. For more information, see Object Styles on page 1601.

**ODBC** Open Database Connectivity. ODBC is a general export tool that works in conjunction with many software drivers. You can export information about model elements in a Revit project to an ODBC database. See Exporting to ODBC on page 1126.

**offset** A uniform distance from an element or line, along which the element or line will move, or a new element or line will be created. For example, when creating walls, you might specify an offset of 5 meters. When you select an existing wall, Revit Structure draws a new wall 5 meters from the selected wall.
The following illustration shows that, when you move the cursor near the outside of a chain of walls, Revit Structure draws a preview line to show the offset from the walls. See Moving Elements with the Offset Tool on page 1476.

**open loop** A sketched line that does not connect to itself. Instead, it leaves an open space between the start point and endpoint of the line.

In Revit Structure, you use open loops to sketch a roof by extrusion and to split toposurfaces and faces. In the following sketch, a closed loop defines the walls, ceiling, and floor. An open loop defines the roof.

**Options Bar** Part of the Revit interface that provides context-sensitive settings and functions, depending on the tool currently in use. In the Revit window, the Options Bar is located below the ribbon and above the drawing area.

See User Interface on page 21 and Options Bar on page 34.

**orientation** The state of being aligned with (or facing the same direction as) a particular item or direction. For example, in Revit Structure you can change the orientation of a view to True North, or you can change the orientation of a compound wall to reverse the order of its layers.

**origin** A fixed starting point, or the point in a coordinate system where the axes intersect.

In Revit Structure, you use an origin for many functions, such as positioning a linked project, creating a custom fill pattern, positioning a group, resizing walls, or sketching lines for a new family.

**orthogonal** At right angles to, or perpendicular to.

**orthographic view** A 3D view that shows a building model in which all components are the same size, regardless of the camera’s distance from them.
paint  To apply a material to a surface of a model element. In Revit Structure, you can paint walls, floors, roofs, and masses.

See Applying a Material to the Face of an Element on page 1512.

pan  In a 3D context, pan moves the camera left and right.
In a 2D context, pan scrolls the view. If you are using pan with an active view on a sheet, pan scrolls the sheet view, not the active view on the sheet.

See Navigating Views on page 818.

panel  In Revit Structure, a section of a curtain wall or a curtain system. Panels are separated by mullions. Panels can consist of glass or different types of walls. See Wall Panels in Curtain Walls on page 630.

parallel view  A view whose plane is parallel to the plane of another view. (Compare with perpendicular view on page 1747.)
For example, a Level 1 floor plan is parallel to a Level 2 floor plan. An east elevation view is parallel to a west elevation view. The following drawing illustrates the parallel planes that are used for the east and west elevations. For more information, see Propagating Dependent View Configuration on page 847 and Datum Extents and Visibility on page 1527.

parameter  A setting that determines a particular property of an individual element, an element type, or a view.

See Element Properties on page 15 and View Properties on page 873.

parametric  Controlled by parameters.
In a Revit project, parameters define the relationships between elements of the building model. These relationships are created automatically by Revit Structure and by you as you create the design. As you work in drawing and schedule views, Revit Structure collects information about the building model. The Revit parametric change engine automatically coordinates changes in all model views, drawing sheets, schedules, sections, and plans.
For more information, see What Is Meant by Parametric? on page 11.

partial explode  The process of disassembling an import symbol (which represents imported geometry) into its next highest level of elements: nested import symbols. A partial explode yields more import symbols,
which, in turn, can be exploded into elements or other import symbols. (Compare with full explode on page 1723.)

See Exploding Imported Geometry on page 75.

PAT A file format for fill patterns. A pattern file is a text file that contains definitions for model or drafting patterns in a project. See Custom Pattern Files on page 1570.

pattern component Nested family which is applied to populate buildable architectural components across a large variety of geometric divided and patterned surfaces. It can contain both 2D and 3D geometry which create intelligent and flexible parametric components. See Pattern Component Families on page 201.

patterned surface A divided surface (see Rationalizing Surfaces on page 190) on which geometric shapes have been applied. These patterns become part of the surface and (depending on their shape) will require a specific number of grid cells when applied. See Patterning Surfaces on page 197.


In Revit Structure, you can print construction documents as PDF files. You can then share the construction documents with team members, view them online, or print them. See Printing to PDF on page 1151.

permanent dimension A dimension that specifies a particular size for an element or a distance between elements or points. Permanent dimensions always display in the view in which they are created. (Compare with temporary dimension on page 1770.)

You can lock permanent dimensions so that they cannot be changed without first unlocking them. You can also control the placement of the witness lines for dimensions. For more information, see Permanent Dimensions on page 888.

perpendicular view A view whose plane is at a right angle to the plane of another view. (Compare with parallel view on page 1746.)

The following image illustrates the perpendicular planes on which a floor plan and an elevation are based. For more information, see Propagating Dependent View Configuration on page 847 and Datum Extents and Visibility on page 1527.
**perspective view** A 3D view of a building model, in which components that are further away appear smaller than those that are closer. In Revit Structure, you create a perspective view by placing a camera in a 3D view. (See camera on page 1702.)

Compare with **orthographic view** on page 1745. For more information, see 3D Views on page 757.

**phase** A stage or time period in the construction process of a building project. Typical phases include existing construction, demolition, remodeling, and new construction.

Revit Structure tracks the phase in which views or components are created or demolished, and lets you apply phase-specific filters to views so you can define how the project appears during various stages of work. The following project views show different phases of construction for one project. See Project Phasing on page 877.

**pick box** See selection box on page 1760.

**pin** To restrict the movement of an element using the Pin tool.

When you pin an element, you cannot move it by dragging or using the Move tool. However, changes in other attached elements may result in movement of the pinned element. See Preventing Elements from Moving on page 1484.
**plan** A 2D drawing of a building model that shows the layout of walls and other building components. A floor plan presents a view of the building as though you are looking down on it from above, with the roof and intervening levels removed. See Plan Views on page 725.

**plan region** Part of a plan view that has a different view range from the overall view. Plan regions are useful for split level plans or for displaying inserts above or below the cut plane. For more information, see Plan Region on page 729.

**plan view** A view of a floor plan or a reflected ceiling plan for a building model. For more information, see Plan Views on page 725.

**planting** Vegetation used to create a landscape around a building design. Revit Structure provides a library of planting families. You can also create or download additional plants.

**poche** A fill pattern that represents a cut surface. (pronounced po-shay)
In Revit Structure, you can specify the coarse poche material to display in 3D views. You can also specify the poche depth for a cross-section of earth in topography elements. In the following floor plan, the poche for the walls is a solid fill pattern.

**polyline** A set of connected straight line segments. Polylines typically define open loops. See Export Rooms and Areas as Polylines on page 1117.
**polymesh** A 3D shape consisting of multiple polygons that are joined (meshed) together. For example, a polymesh cube consists of 6 square surfaces that are joined together to form the cube shape. This is sometimes referred to as face-based geometry.

Compare with **ACIS** on page 1696. For more information, see **Solids (3D Views Only)** on page 1117.

**post** A vertical support for a railing.

See **Controlling Placement of Balusters and Posts** on page 614.

**primary view** The view on which one or more dependent views are based. The dependent views remain synchronous with the primary view and other dependent views, so that when view-specific changes (such as view scale and annotations) are made in one view, they are reflected in all views.

See **Duplicate Dependent Views** on page 843.

**profile** A series of 2-dimensional lines and arcs that form a closed loop. Use profiles to define cross-sections for railings, balusters, soffits, cornices, and other sweep-defined objects.


**project** A Revit file that contains all information about a building design.

For more information, see **Understanding Revit Terms** on page 12.

**project base point** The project base point defines the origin (0,0,0) of the project coordinate system. It also can be used to position a building on a site and for locating the design elements of a building during construction.

See **Project Base Points and Survey Points** on page 1271.

**Project Browser** Part of the Revit interface that shows a logical hierarchy for all views, schedules, sheets, families, groups, and linked Revit models in the current project.

For more information, see **Project Browser** on page 28.
**Project North** The top of the view in the drawing area. When producing solar studies or rendered images, change the view orientation from Project North to True North to create accurate sunlight and shadow patterns for the project.

See Rotating a View to True North on page 110.

**project parameters** User-defined fields that you add to multiple categories of elements, sheets, or views in a project. These parameters are specific to the project and cannot be shared with other projects.

For example, you can create a project parameter named Approved By for views. In the properties for each view, you can enter a value for this parameter to indicate who approved the view.

You can use project parameters in multi-category or single-category schedules. However, you cannot use project parameters in tags for model elements.

Compare with shared parameters on page 1762. For more information, see Project Parameters on page 1549.

**project standards** The settings used in a project that you want to apply to another project. Project standards include family types, line weights, materials, view templates, and object styles. See Transferring Project Standards on page 1635.

**project template** A set of initial conditions for a project. Revit Structure provides several templates, and you can create your own templates. Any new project based on a template inherits all families, settings (such as units, fill patterns, line styles, line weights, and view scales), and geometry from the template. Templates use the file extension RTE.

See Project Templates on page 1633.

**project view** A representation of a building model. A Revit project file contains a database of information about a building model, and a project view is one way of looking at that information. Also called a view.

The Project Browser lists the views available for a project. These can include floor plans, ceiling plans, elevations, sections, detail views, drafting views, 3D views, walkthrough views, legend views, schedules, renderings, and sheets.

For more information, see Document the Project on page 723.

**projection line style** A graphic style applied to an element when a view displays the element, so that you are seeing a representation of its exterior surface. (Compare with cut line style on page 1710.)

For the projection line style of an element, you can specify the line weight, color, and fill pattern. See Modifying Object Styles on page 1601.

**property** An attribute of appearance or behavior for an element, type, or view. Properties are specified through instance parameters on page 1729 and type parameters on page 1772.

For more information, see Element Properties on page 15 and View Properties on page 873.

**property line** The boundary of a plot of land or the site for a building project.

For more information, see Property Lines on page 122.
**proxy graphics** Representations of AutoCAD objects. Revit Structure supports proxy graphics from AutoCAD files. Unlike AutoCAD objects, proxy graphics have no intelligence. See Importing or Linking CAD Formats on page 58.

**purlin** A longitudinal structural member in a roof. Purlins support the loads from the roof deck or sheathing. They are supported by the principal rafters or building walls (or both).

In Revit Structure, when you use the Beam tool to add beams between joists, the structural usage of the beams is automatically set to purlin, and their display within the plan view adjusts accordingly. In the following floor plan, the dotted lines indicate purlins placed along the midpoints of the joists. See Structural Usage of Beams on page 249.

**pushpin** A user-placed control that provides a quick way to allow or prevent changes to the position of an element. After you place a pushpin, you cannot move the element until you unpin it by clicking the pushpin control. See Preventing Elements from Moving on page 1484.
**quantity** The number or amount of building materials used in a project. Schedules can calculate the quantities of individual items or materials needed to complete a project. You can use this information to estimate costs and plan purchases.

**radial** Arranged along a radius or arc.
In Revit Structure, when you create a radial array, the elements in the array are arranged along a curve.

**rail** A hand rail, or a horizontal bar extending between posts in a railing.
See Railings on page 611.

**railing** A barrier consisting of horizontal rails supported by posts and balusters.
In Revit Structure, you can add railings as free-standing components to levels, or attach them to host elements (such as floors, ramps, or stairs). For more information, see Railings on page 611.

**ramp** A sloped floor or passageway.
For more information, see Ramps on page 607 and Sloped Floors on page 556.

**RCP view** See reflected ceiling plan view on page 1755.

**rebar** A steel rod or bar used in reinforced concrete construction. The following detail of a footing shows typical usage of rebar in walls and foundations.
**reference elevation** An elevation tag that refers to an existing elevation or drafting view. When you add a reference elevation to a project, Revit Structure does not create a new view for it. Instead, the reference elevation uses an existing elevation, allowing you to indicate different areas that have identical elevations. You can place a reference elevation in a plan or callout view.

For more information, see Reference Elevation on page 732.

**reference label** Text displayed in a callout tag when a reference callout is created in the plan view, or text displayed in a section head when a reference section is created in the plan view.

See Reference Sections on page 742 and Reference Callouts on page 753.

**Reference callout with callout tag**

**reference line** A line used when designing families of model elements or placing elements in a building model. When you draw a reference line in a view, the line is visible in other, related views.

A straight reference line provides 4 planes to sketch on. One plane is parallel to the work plane of the line itself, another is perpendicular to that plane, and the remaining 2 are at the ends of the line (perpendicular to the ends). All planes go through the reference line.

A curved reference line (for example, an arc or a spline) has 2 planes at the ends of the element.

The following image shows a selected reference line (and its reference planes) in multiple views. For detailed information about reference lines, see The Families Guide on page 680.

**reference plane** A 2-dimensional plane used when designing families of model elements or placing elements in a building model.
See also reference line on page 1754. For more information, see Reference Planes on page 1523.

**reference point (1)** A point in the current view that you can use for positioning or dimensioning a model element. When you move the cursor near a reference point, Revit Structure displays a temporary dimension between the element being placed and the reference point. To display different reference points, press Tab. When you are creating a family and you use a reference plane with the Is Reference property turned on, the reference plane can be used as a reference point for dimensions. For more information, see The Families Guide on page 680.

**reference point (2)** Provides a specific reference location in the 3D workspace of the conceptual design environment. You place these points to design and plot lines, splines, and forms. Reference points may be free (unattached), hosted by an element, or driving (element geometry modifying). See Reference Points on page 152.

**reference section** A section tag that refers to an existing section view. When you create a reference section, Revit Structure does not create a new view in the project. Instead, the reference section uses an existing section, allowing you to indicate different areas that have identical sections. You can place reference sections in plan, elevation, section, drafting, and callout views. Reference sections can refer to section views, callouts of section views, and drafting views. For more information, see Reference Sections on page 742.

**referencing view** The parent view of a callout or section; that is, the view from which a callout or section originates. The referencing sheet is the sheet on which the referencing view displays. The referencing detail corresponds to the detail number assigned to a callout or section in its view properties. Values for referencing sheet and referencing detail occur in view properties and sheet properties. You can create labels for these values and include them in callout tags or section tags to create a cross-referencing documentation system for a Revit project.

See Referencing a Drafting View on page 966 and Referencing a Callout View on page 962.

**referring view** A view in which the annotation symbol for the current view is visible. For example, if you use the Find Referring Views tool for an elevation view, Revit Structure lists all views in which its elevation symbol is visible. See Finding Referring Views on page 855.

**reflected ceiling plan view** A drawing that shows the ceiling in a building design. Also called an RCP view. When you add a level to a building model, Revit Structure automatically creates an RCP view for it. See Plan Views on page 725.
**rehost**  To move a component from one host to another. For example, you can use the Pick New Host tool to move a window from one wall to another wall. For more information, see Moving Components to Different Hosts on page 507, Moving a Door to a Different Wall on page 494, and Moving a Window to a Different Wall on page 501.

**rendering**  The process of generating a photorealistic illustration of a building design. Rendered images are often used to present building designs to clients. Revit Structure renders 3D project views with various effects, such as lights, plants, decals, and people. For more information, see Rendering on page 1031.

**resize**  To change the size of a model element. For example, in Revit Structure you can resize a wall or a foundation to adjust to changing specifications. See Resizing Elements on page 1486.

**retaining wall**  A wall that holds back earth (for example, at the edge of a terrace or excavation). In Revit Structure, you can specify that a wall type functions as a retaining wall in the type properties. See Wall Type Properties on page 487.

**reveal**  (1) A decorative cutout in a wall. See Wall Reveals on page 482.
reveal (2) To display in a view. After hiding elements, you can reveal (redisplay) them in a view. See Revealing and Unhiding Hidden Elements on page 812.

revision A change to a construction document or building design. Revit Structure provides tools (revision clouds and revision schedules) that enable you to include revision information on sheets.

For more information, see Revisions on page 1018.

revision cloud A graphic (shaped like a cloud) that indicates changes in a construction document. In Revit Structure, you can sketch revision clouds in all views except 3D views. The cloud is visible only in the view in which it is sketched.

For more information, see Revision Clouds on page 1024.

revision schedule A list of changes made to a building design or construction document. A revision schedule displays in the title block of a sheet. As you add views with revision clouds to sheets, the revision schedule updates with information about the corresponding revisions.

For more information, see Revision Schedules on Sheets on page 1028.

<table>
<thead>
<tr>
<th>Number</th>
<th>Date</th>
<th>Description</th>
<th>Issued to</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>11/17/2005</td>
<td>Flipped the door (Mark 26)</td>
<td>Phil</td>
</tr>
<tr>
<td>2</td>
<td>11/05/2006</td>
<td>Moved the window (Mark 05) along the East wall</td>
<td>Joe</td>
</tr>
<tr>
<td>3</td>
<td>10/02/2006</td>
<td>Added a wall profile on the exterior walls (Level 1 &amp; 2)</td>
<td>Peter</td>
</tr>
</tbody>
</table>
**revision table** See revision schedule.

**Revit Architecture** An Autodesk product. Revit Architecture is a building design and documentation system that uses building information modeling to coordinate changes across all aspects of an architecture project.

**Revit MEP** An Autodesk product. Revit MEP optimizes mechanical/electrical/plumbing (MEP) systems engineering through data-driven system sizing and design. It provides a building information modelling design and documentation solution for MEP engineering.

**Revit Structure** An Autodesk product. Revit Structure integrates a physical model for layout, coordination, and documentation with an independently editable analytical model for building design and analysis. Using a single building information model and dynamic linking to third-party analysis applications, Revit Structure integrates and coordinates structural design and documentation.

**revolve** Solid geometry that turns (revolves) around an axis. For example, you can use the Revolve tool to design a dome roof, a column, or door knobs.

See Creating a Revolve on page 1425.

---

**RFA** The file format for a Revit family. (See family on page 1719.)


**riser** The vertical face of a step in a set of stairs.

**rough opening** The framed hole (opening) in a wall into which a manufactured window or door is installed. In Revit Structure, you can specify the height and width of the rough opening for a window type or door type.

**RPC** Rich Photorealistic Content. The file type for ArchVision realpeople and other objects, which can be loaded into Revit Structure as an entourage family, for use in rendered images.

**RSS feed**

Information published by a website to which you subscribe. Usually allows users to receive notifications when new content (articles) are posted. RSS stands for Rich Site Summary (or Really Simple Syndication).

**RTE** The file type for a Revit project template. See Project Templates on page 1633.

**rule-based filter** A filter with user-defined rules that determine the visibility/graphics settings for model elements in a particular view. For example, you can create a rule-based filter that displays all fire-rated walls as solid red in a plan view to distinguish them from non-fire-rated walls in the building.

See Controlling Visibility and Graphic Display of Elements Using Filters on page 806.
run (1) A set of stairs or a ramp of a defined length. In Revit Structure, you can sketch a run to create a ramp or set of stairs. See Stairs on page 591 and Ramps on page 607.

run (2) When drawing conduit and cable tray, a continuous segment of the same size and type. A run may contain a bend or elbow. A tee, cross, or other fitting ends a conduit or cable tray run.

RVG The file format for a Revit group prior to Revit Structure 2008. In Revit Structure 2008 and later, you can still load Revit groups (RVG files) into a project or a family. However, new groups can be saved as RVT or RFA files, not RVG files. See Loading Groups on page 1458.

RVT The file format for a Revit project.

sash The part of a window that holds the glass panes in place. The sash can be movable or fixed in place. It usually consists of horizontal and vertical pieces.

SAT Standard ACIS Text. The file format for ACIS, a solid modeling technology that is supported by many CAD applications. Revit Structure can import and export SAT files. See Importing ACIS Objects on page 62 and Exporting to SAT on page 1110.

scale The proportional system used to represent objects in a drawing. In Revit Structure, you can assign a different scale to each view. See View Scale on page 860.

Metric view scale

schedule A tabular display of information. In Revit Structure, a schedule is extracted from the properties of elements in a project. It is displayed in a schedule view. Using Revit Structure, you can create many types of schedules, including quantities, material takeoffs, annotation schedules, revision schedules, view lists, and drawing lists. See Schedule Overview on page 771.

scope box A user interface mechanism that controls the visibility of datum planes (levels, reference lines, and grids) in views. When you add grids, levels, and reference lines to a project, they may display in more views than desired. For example, when you add grid lines to a plan view, the grid lines display in all plan views of the model. To limit the appearance of datum planes to certain views, use a scope box. See Controlling Visibility of Datums Using Scope Boxes on page 1531.

section A representation of a building model as if the model is cut vertically to show interior detail. See Section Views on page 737.

section box A user interface mechanism that crops the model in a 3D view. Elements in the building model that are outside the section box do not display in the view or in an exported view. See Change the Extents of a 3D View on page 762.
section view  See section on page 1759.

select  To choose an object in the drawing area.
Many of the controls and tools that you use to modify an element in the drawing area are available only when an element is selected. In Revit Structure, a selected element displays in the selection color, and controls or handles indicate how the element can be manipulated or modified.
See Selecting Elements on page 1439.

selection box  A user interface mechanism that you use to select elements within a defined area by dragging the cursor around them.
To create a selection box, place the cursor near the elements to select, click and hold the left mouse button, and drag the cursor diagonally across the screen to draw a rectangle around the desired elements. Dragging from right to left includes elements completely enclosed by the selection box. Dragging from left to right includes any element that the selection box encloses or touches.
See Selecting Multiple Elements on page 1440.

selection filter  A mechanism for determining which elements are selected (for modification or manipulation) based on their family types or element parameters.
See Selecting Elements Using a Filter on page 1442.
**setback (1)** The distance that a wall sweep or wall reveal is offset from intersecting wall inserts. The setback value allows you to place sweeps or reveals properly near window or door trims. You can define a default setback for wall sweeps and wall reveals in their type properties.

**setback (2)** The legally required distance between the property line and buildings. For example, in the following site plan, a red dashed line indicates the zoning setback.

![setback (2) example](image)

**setback (3)** The distance from the connection point of a primary beam in a join to its edge. This is measured linearly with a connecting beam's center.

For more information, see [Cutback](#) on page 275.

**shaded** A visual style in which Revit Structure shows the image with all surfaces shaded according to their material color settings and project light locations. A default light source provides illumination for the shaded elements.

See [Shaded Visual Style](#) on page 869.
**shaded with edges** A visual style in which Revit Structure shows the image with all surfaces shaded according to their material color settings and project light locations, and with all non-occluded edges drawn. A default light source provides illumination for the shaded elements.

See [Shaded with Edges Visual Style](page 870)

![Shaded with Edges Visual Style Image]

**shadow study** See [solar study](page 1765).

**shaft** An opening that extends the entire height (or through specified levels) of a building, cutting through floors, ceilings, and roofs, as appropriate.

See [Cutting Shaft Openings](page 564).

**shape handle** A user interface mechanism that you drag to change the shape of an element in the building model. A shape handle appears in the selection color.

For more information, see [Shape Handles](page 1453)

![Shape Handle Image]

**shared coordinates** Project coordinates that are used for remembering the mutual positions of multiple interlinked files. Those interlinked files can be all RVT files, or a combination of RVT, DWG, and DXF files.

See [Shared Positioning](page 1265).

**shared family** A family of model elements that can be used to create subcomponents of a [nested family](page 1743).
When you use shared families to create a nested family, you can select, tag, and schedule the individual subcomponents in a project. (If subcomponents are not from shared families, Revit Structure treats an instance of the nested family as a single item for selecting, tagging, and scheduling.)

See also [nested family](page 1743). For more information, see [The Families Guide](page 680).

**shared parameters** User-defined fields that you add to families or projects and then share with other families and projects. They are stored in a file independently of a family file or Revit project; this allows you to access the file from different families or projects. In addition, shared parameters can be used in tags for model elements, and they can display in schedules.

Compare with [project parameters](page 1751). For more information, see [Shared Parameters](page 1541).
**shear wall** A wall composed of braced panels to counter the effects of lateral loads (such as wind and earthquakes) acting on a structure. See Structural Walls on page 345.

**sheet** A construction document. Also referred to as a drawing sheet.

In Revit Structure, you place project views on sheets to create a construction document set. For more information, see Sheets on page 978.

**shortcut menu** A menu of context-sensitive options. A shortcut menu displays when you right-click an element or view.

**silhouette edges** The edges of a building design when the visual style is Shaded with Edges or Hidden Line. You can change the line style used for silhouette edges in these modes. See Applying or Removing a Line Style for a Silhouette Edge on page 872.

**sill** The horizontal member at the bottom of a door or window frame.

In Revit Structure, you can specify a default sill height for a window type, or a specific sill height for a window instance or door instance. The sill height is the measurement from the floor up to the sill.

**site** The location or defined plot of ground for a building project.

See Site Design on page 113.

**site plan** The design for the site on which a building is located, including building pads, parking lots, sidewalks, and landscaping.

See Site Design on page 113.
**site utility** A component family that either has connectors or has the capability of hosting connectors that become functional when linked in a civil engineering application, such as AutoCAD® Civil 3D®.

**sketch (1)** To draw a line or shape. Revit Structure provides several tools and techniques for sketching. See Sketching on page 1405.

**sketch (2)** A drawing of a 2D shape. The following sketch contains an open loop (the roof) and a closed loop (the walls, floor, and ceiling).

**SKP** The file format for projects created using Google® SketchUp, a general purpose modeling and visualization tool.

You can import SKP files into a Revit project. See Importing SKP Files on page 60.

**slope** An angled surface (such as a roof or ramp), or the angle at which the surface rises.

See Roof Slope on page 528, and Ramps on page 607.
**slope arrow** A user interface mechanism that defines the slope of a roof, floor, or ceiling plane, using a line in the direction of the slope.

Use a slope arrow when you know the height at the top and bottom of the object’s plane rather than the slope. For example, slope arrows can be used to adjust a flat roof to satisfy a particular height at a drainage point. See *Sloped Surfaces* on page 579.

---

**snap (1)** To jump to a line or reference point in a drawing.

**snap (2)** A line or reference point to which Revit Structure will jump when you are placing a component or sketching a line.

When you place a model element or sketch a line in a drawing, Revit Structure displays snap points and snap lines to assist in aligning elements or lines with existing geometry. Snap points display in the drawing area as triangles, squares, and diamonds, depending on the snap type. Snap lines display as dashed lines in the drawing area.

For example, when you move the cursor over an existing wall to draw a new wall, Revit Structure displays a snap line (a dashed line at the center line of the wall) and a snap point (purple triangle at the midpoint of the wall). Click a snap point or snap line to start drawing the new wall from that location. For more information, see *Snaps* on page 1614.

---

**soffit** The exposed underside of an architectural element.

On a roof, the soffit is the underside of an overhanging roof eave. See *Roof Soffits* on page 542.

**solar study** A photorealistic image of a building model used to evaluate the impact of natural light and shadows on the buildings and site.

For more information, see *Creating Solar Studies* on page 1376.

**solar time** A sun-based system of time-keeping in which the sun is directly overhead at a given location at solar noon. Solar noon may differ from noon in local time.

**solid geometry** A 3-dimensional shape used in a building model.

You can use the Family Editor to create solid geometry shapes to build families of model elements. See *Creating Solid and Void Geometry* on page 1420.
**span direction**  The orientation of a structural floor.
When you place a structural floor in the plan view, Revit Structure creates a span direction component. Rotate the span direction component to change the orientation of the structural floor. For more information, see Span Direction on page 369.

**spline**  A curved line drawn by specifying and positioning a number of points. Revit Structure uses a mathematical polynomial function to smoothly join the segments at these points, creating the curved line. See Best Practices for Sketching a Spline on page 1417 and Modifying a Spline on page 1418.

**split**  To divide a single object into multiple objects or sections.
In a Revit project, you can split walls, lines, faces, toposurfaces, layers in vertically compound walls, and schedules using various split tools.

**spot coordinate**  The North/South and East/West coordinates of an individual point with respect to the shared coordinate system for a group of linked Revit projects.
See Spot Coordinates on page 905.

**spot elevation dimension**  The elevation of a selected point. Use spot elevation dimensions to determine a point of elevation for ramps, roads, toposurfaces, and stair landings.
For more information, see Spot Dimensions on page 902.

**stacked wall**  A wall that has 2 or more horizontal layers, each consisting of different materials and surfaces.
See Working with Stacked Walls on page 472.

**stair calculator**  A Revit tool that automates the creation of stairs based on a specified minimum tread depth and maximum riser height.
For more information, see Stair Calculator on page 598.
stairs A series of steps that allow you to go from one level to another. Also referred to as a staircase.

start point The beginning of a sketched line. See Sketching on page 1405.

status bar Part of the Revit interface that displays information about what is highlighted or selected, or hints on what to do next. The status bar is located in the lower left corner of the Revit window. See User Interface on page 21 and Status Bar on page 33.

stringer The diagonal support for the treads and risers in a staircase. See stairs on page 1767.

structural column A column that supports a vertical load in addition to its own weight. Compare with architectural column on page 1696. For more information, see Structural Columns on page 218.

structural floor A section of solid concrete pavement, roof, or floor. Structural floors can be used as a combined floor and foundation system. See Structural Floors on page 366.

subcategory For a subcomponent of a family, a property that defines its display (the line weight, line color, and line pattern). For information about creating a subcategory, see The Families Guide on page 680.

subscription Purchased support for Revit Structure. A subscription provides access to web-based resources, such as e-learning lessons, extension announcements, and subscription program news.

Subscription Center Provides access to information about subscription services such as product enhancements, web support from Autodesk technical experts, and self-paced e-Learning.

substrate Material (such as plywood or gypsum board) that acts as a foundation for another material.

subwall A component wall in a stacked wall. See Working with Stacked Walls on page 472.
surface pattern The graphic design (fill pattern) used to represent a surface when shown in projection. See Fill Patterns on page 1566.

Surface patterns (left) and cut patterns (right) for a wall

survey Topographical information about a building site, including its location, boundaries, and elevation. See Property Lines on page 122.

survey point The survey point represents a known point in the physical world, such as a geodetic survey marker. The survey point is used to correctly orient a building’s geometry in another coordinate system, such as the coordinate system used in a civil engineering application. See Project Base Points and Survey Points on page 1271.

sustainable design The art of planning physical objects so they can be created and maintained in a way that supports the longevity of natural ecosystems and reserves. It ranges from designing small objects for everyday use to designing buildings, cities, and the physical surface of the earth. Revit Structure provides predefined families of model elements that promote sustainable design, including water tanks, solar panels, and wind-powered generators. For information about loading predefined families into a project, see Loading Families on page 688.

swatch A sample patch of a color or pattern.
sweep  See wall sweep on page 1776.

symbol  A graphic representation of an annotation element or other object. Symbols are sometimes referred to as tags.
Revit Structure uses symbols for annotations, moment frames, cantilever connections, and other elements. For more information, see Symbols on page 951.

Annotation symbols used in a set of construction documents

symbolic line  A line that provides information but is not intended to represent actual geometry in an element. Symbolic lines are visible parallel to the view in which you sketch them.
You can control the visibility of symbolic lines on cut instances. You can also control the visibility of symbolic lines based on the detail level of the view.

system family  A Revit family that can be used as a building block for creating families. Revit Structure provides system families for floors, walls, ceilings, roofs, drawing sheets, viewports, and other elements. You cannot delete system families.

tag  An annotation used to identify elements in a drawing. Tags provide a way to automate the display of attributes for an element or type. Revit Structure provides default tags for some types of elements. You can change the information displayed in tags, and you can create labels to add information to tags. You can also control the visibility of tags in each view. For more information, see Tags on page 944.
For example, the following drawing shows a beam tag.

tangent  A line that passes through the same point as a curve, in the same direction as the curve.
tape measure A long, flexible ruler (often made of cloth, plastic, or metal) used for measuring. In Revit Structure, you can use the Measure tool to measure between points in a drawing or to measure the length of an element. See Measuring Elements on page 1505.

target point The point in the distance at which a camera is aimed or directed. See camera on page 1702.

template A collection of settings that you can use as a starting point for projects, families, views, and more. See Project Templates on page 1633 and View Templates on page 1637. For information about family templates, see The Families Guide on page 680.

temporary dimension A dimension that Revit Structure displays as you draw or place elements in a view. Temporary dimensions can help you to position an element in the desired location, or to draw a line to the desired length or angle. When you finish drawing or placing an element, temporary dimensions no longer display.

Compare with permanent dimension on page 1747. See also listening dimensions on page 1736. For more information, see Temporary Dimensions on page 887.

tessellation A technique used to manage datasets of polygons and divide them into suitable structures for rendering. Data is often tessellated into triangles, which is sometimes referred to as triangulation.

When CAD or design software applications export 3D geometry to a file for use in Revit Structure, they may use tessellation to approximate a curved surface.

text note An annotation that consists of text and may include a leader line and arrow. You can add text notes to a detail view, drafting view, or a sheet.

For more information, see Text Notes on page 926.
**tick mark** The graphic shape used to represent the end of a dimension, such as an arrow or a slash. See *Changing the Dimension Line Tick Mark* on page 913.

A floor plan that uses 2 types of tick marks

![Floor plan with tick marks](image)

**title block** A template for a sheet. A title block generally includes information about the company, address, date of the project, and revisions. For more information, see *Title Blocks* on page 995.

![Title block example](image)

**topographical surface** See *toposurface*.

**toposurface** Topographical surface. A graphic representation of the terrain of a building site or plot. The toposurface may include contour lines to represent elevations. For more information, see *Toposurfaces* on page 115.

![Topographical surface example](image)

**tread** The horizontal surface of a step in a set of stairs.

**triangulation** The process of dividing a shape into triangles to determine its area or to approximate a curved surface (as for a 3D shape). See also *tessellation* on page 1770.
For more information, see Toposurfaces on page 115.

**trim**  To shorten selected elements to meet a specified boundary. See Trimming and Extending Elements on page 1489.

**True North**  The direction toward the North Pole.

Drafting conventions dictate that Project North is the top of the view. You may want to orient a view to True North when producing solar studies (to create accurate sunlight and shadow patterns for the project) or rendered images. See Rotating a View to True North on page 110.

**type**  A subdivision within a family of elements.

For example, the family of Concrete Round Columns is further divided into types such as Concrete Round 18”, Concrete Round 24”, and Concrete Round 30”.

See category on page 1703 for examples of the hierarchy of categories, families, and types of model elements and annotation elements. For more information, see Element Behavior in a Parametric Modeler on page 14 and Revit Families on page 677.

**type catalog**  A list of model elements that belong to a particular family type but that differ in size or other characteristics. Using type catalogs, you can load only the size you need, rather than loading the entire family type.

For example, suppose that you want to load detail components for wood framing to use in detail views. Rather than load the entire Nominal Cut Lumber-Section family, which includes 32 sizes of cut lumber, you can select the specific sizes that you need.

By using the type catalog to load selected items from a family type, you can reduce project size and limit the number of items listed in the Type Selector for that family, which, in turn, improves productivity. For information about creating a type catalog, see The Families Guide on page 680.

### Type catalog for a lumber family

![Type catalog for a lumber family](image)

**type parameters**  Settings in the Type Properties dialog that specify the properties common to all elements of a particular family type. See Modifying Type Properties on page 38.

**type properties**  Appearance and behavior properties that are the same for all elements of a particular family type. Type properties are specified through corresponding type parameters on page 1772 in the Type Properties dialog. See Modifying Type Properties on page 38.

**Type Selector**  A drop-down list on the Properties palette from which you can select a family type for the element being added or modified.

For more information, see Type Selector on page 35.

**underlay**  A project view or imported file that you use to help position elements in the current view.

For example, when you use a section view as an underlay to a detail view, model elements in the detail view display in halftone or a different line weight and line pattern. This allows you to see the difference between the model geometry (from the section view) and added detail components.

To use a view as the underlay for the current view, set the Underlay parameter in its view properties. See View Properties on page 873 and Halftone/Underlay on page 1605.
Uniformat assembly code A standard classification of building elements and related site work. During the design phase of a building project, Uniformat assembly codes can be used to define performance specifications and technical requirements, and to generate cost estimates for the project.

unit The basic quantity or amount used as a standard for measuring. When you install Revit Structure, you specify whether you want to use imperial units (feet and inches) or metric units (meters and centimeters). You can also change the type of units used in a project. See Project Units on page 1613 and Creating Custom Dimension Units on page 900.

UV grid Coordinate plotting grids for non-planar surfaces. Plotting locations in a 3D space is based on an XYZ coordinate system, while 2D Space is based on an XY system. Since surfaces are not necessarily planar, the UVW coordinate system is used to plot location. This maps a grid adjusting for the contours of a non-planar surface or form. UV Grids, as used in the conceptual design environment, are comparable to XY Grids. See Understanding UV Grids on page 190.

vertex (1) For a 2-dimensional polygon, an intersection of 2 sides.

vertex (2) For a 3-dimensional shape, an intersection of 3 sides. When you blend 2D shapes to create a 3D shape, you can use vertex connections to control the rate at which one shape is blended to another shape. See Creating a Blend on page 1422.

view See project view on page 1751.

View Control Bar A panel of buttons providing quick access to functions that control the current view. Use the View Control Bar to change the scale, detail level, visual style, shadowing, crop views, and display of elements or categories in the view. The View Control Bar is located at the bottom of the Revit drawing area. For more information, see View Control Bar on page 39.

view depth A horizontal plane that helps to define the view range in a floor plan or reflected ceiling plan. By default, the view depth is the same as the bottom clip plane. However, you can specify the view depth to show elements (such as foundation footings) below the bottom clip plane. You define the view depth in the view range properties, which are accessible from the view properties. See View Range on page 864.

view list A schedule (list) of all views in a project. The schedule includes the view parameters that you specify. You can use a view list to manage the views in a project. For more information, see Using View Lists on page 858.

view properties Settings that control the appearance or behavior of a project view.
To see or change view properties, right-click a blank area of the view in the drawing area, and click View Properties. Or right-click a view name in the Project Browser, and click Properties. For more information, see View Properties on page 873.

**view range** A set of horizontal planes that control the visibility and display of objects in a view. The horizontal planes are Top Clip Plane, Cut Plane, Bottom Clip Plane, and View Depth. Elements outside the view range do not display in the view.

For more information, see View Range on page 864.

**view reference** A symbol indicating a dependent view to which the primary view is linked. See Duplicate Dependent Views on page 843 and Navigating Primary and Dependent Views on page 817.

**view scale** See scale on page 1759.

**view template** A collection of view properties (such as view scale, discipline, detail level, and visibility settings) that can be applied to a project view.

For example, you might create one view template for a structural floor plan, and another view template for an exit floor plan. You can then apply these templates to different floor plans to display information in each plan according to its purpose. See View Templates on page 1637.

**view-specific** The characteristic of being visible in one project view only.

**viewport** A user interface mechanism that allows you to manipulate and activate a view that has been placed on a sheet. When you activate a view through a viewport, you can edit the model directly on the sheet.

For more information, see Sheets on page 978 and Viewports on page 1005.

**visual style** Various styles for displaying model elements in views are available from a menu on the View Control Bar at the bottom of the Revit window. For more information, see Visual Styles on page 867.

**VIZ** An Autodesk product. VIZ is a 3D modeling, rendering, and presentation software application that provides state-of-the-art image creation technologies for communicating and sharing design intent. Revit Structure can export 3D models for use in VIZ. See Exporting to 3ds Max on page 1139.

**void geometry** A 3-dimensional shape that results from removing shapes from solid geometry. See Creating Solid and Void Geometry on page 1420.

**volumetric geometry** A 3-dimensional shape that has measurable volume.
Non-volumetric geometry refers to a 2-dimensional shape.

**walkthrough** A representation of a building model that simulates a person walking through the model along a defined path.

The following walkthrough view shows the walkthrough path in red. See *Walkthrough Overview* on page 1099.

**wall join** An intersection of 2 or more walls.

In Revit Structure, you can specify the type of join between walls. For more information, see *Working with Wall Joins* on page 457.

**wall reveal** A decorative cutout in a wall.

For more information, see *Wall Reveals* on page 482.
**wall sweep** A horizontal or vertical projection from a wall, often decorative in nature. Examples of wall sweeps include baseboards and crown molding.

For more information, see Wall Sweeps on page 476.

**web library** A collection of predefined project resources that are available on the Internet. For example, you can access web libraries of templates, detail components, entourage, and families of model elements and annotation elements. See Opening Files from the Web Library on page 84.

**wireframe** A visual style in which Revit Structure displays the image of the model with all edges and lines drawn, but no surfaces.

See Wireframe Visual Style on page 868.

**witness line** An annotation that indicates the distance between 2 points or elements in a building model. In Revit Structure, you can change the points or elements that are used as references for a witness line. You can also control the gap between the witness line and the element being measured. See Dimension Witness Lines on page 910.
**work plane** A planar surface on which you can add sketch lines or other components. Each view in Revit Structure is associated with a work plane. In some views (such as plan, 3D, and drafting) and for views in the Family Editor, the work plane is automatically defined. In other views, such as elevation and section views, you need to define the plane. The work plane is necessary for sketching operations (such as creating an extruded roof) and for using tools in particular views (such as Rotate and Mirror in a 3D view). For more information, see Work Planes on page 1517.

**workset** A collection of elements in a workshared project that can be worked on independently. A workset is typically a discrete functional area, such as interior, exterior, or site. When you enable worksharing, you can divide a project into worksets, with different team members responsible for each workset. For more information, see Setting Up Worksets on page 1212.

**worksharing** A design method in which different team members are responsible for designing different functional areas of the same project file. See Working in a Team on page 1209.

**X-Ray** Available in the conceptual design environment, X-Ray mode is a transparent view that displays the underlying geometric skeleton of a form.

**xref** See external reference on page 1717.

**z-direction** The direction of the third axis (the z-axis) in a 3-dimensional coordinate system.

**zoning envelope** A set of legal constraints on a building project that defines the volume within which the building must be contained. These constraints include the maximum height of the building, the percentage of the lot that the building can cover, and rear and side setbacks.

**zoom** To change the magnification of a view.
In a 3D context, zoom moves the camera in and out. In a 2D context, zoom moves up and down perpendicular to the view.

- To **zoom in** is to increase the magnification, making the building appear larger.
- To **zoom out** is to decrease the magnification, making the building appear smaller.

Zoom tools are available on the 2d and 3D SteeringWheels and the Navigation Bar. See *Zooming Project Views* on page 860.
Index

2D datum extents 1530
2D Navigation wheel 831
2D views
  rendering 1078
3 GB switch 1671–1672
3D datum extents 1530
3D levels 148
3D model extents
  maximizing 1530
3D models 56
3D reference planes 151
3D snapping 141–142
3D views 758
  changing quality of line display 1625
  exporting to 2D DWF 1121
  exporting to 3D DWF 1121
  gradient background 761
  modifying viewable portion 762
  properties 763
  rendering 1076
  rotating 760
  saving 843
3D work planes 145
3ds Max 1139–1141
  before exporting to 1140
  camera views 1141
  exporting to 1141
  limiting model geometry 1140
  performance 1141
  preparing for 1140
64-bit computers 52

A
  absolute path 73, 1181
  ACIS solids 1117
    description of 1117
    exporting geometry to 1117
    importing 62
  acquire coordinates 1267
  Activate View tool 987
  active options 656
    Active Only 663
    determining 660
  Add to Set tool 661
  adjust analytical model 1295
  ADSK files
    importing as building components 68
  Align tool 1479
  align with element 1567
  alpha channel 1088
  alphabetic sequence for revision numbers 1023
  altitude 1383
  aluminum 1590
  ambient occlusion 871
  analytical model 1277
    default position 1284
    elements 1281
    location by projection plane 1284
    object styles 1281
    physical properties of materials 1282
    project template 1279
    projection plane 1282
    projection planes 1301
    release conditions 1282
    rigid link 1283
    view parameters 1280
    view template 1279
  analytical projection plane 1282
  analytical view 1285
  anchor symbol 897
  angular dimensions 892
  animations 52
    solar studies 1387
  annotation crop regions 849–850
    specifying offset from the model crop region 853
  annotation elements 14
  annotation schedules
    sheets and 991
  annotation styles 1609
    arrowheads 1609
    dimensions 1610
    loaded tags 1612
    text notes 1610
  annotation symbols
    annotation symbol families 953
    new 953
  annotations
    line weights 1603
    linked models and 1187, 1199
  anti-aliasing 1081, 1093

API
  frequently asked questions 1666
  macro differences 1659
  Macro Manager 1645
  macro workflow 1645
  macros 1643
  reference documentation 1657
  related information 1669
  samples on SDK 1657
arch walls
  cutting 351
  resizing 350
arced landings 597
arced walls
  placing 453
architectural columns
  instance properties 517
  type properties 516
ArchVision Content Manager
  file paths 1627
  location of 1627
arcs
  fillet 1413
  from center and end points 1412
  passing through 3 points 1412
  sketching 1410
  start-end-radius arc 1412
  tangent 1413
area 1335, 1342–1343, 1353
area reinforcement 433
  sketching 434
  tagging 438
  viewing 435
  whole host 434
area schemes
  linked models and 1197
areas 711, 714
  area plans 712
  area schemes 711–712
  area tags 714–715
  boundaries 713, 718
  creating 714
  deleting 716, 718
  exporting 1117
  listing 717
  moving 716
  placing 716
  properties 716
  removing 716
  schedule 717
  showing in linked models 718
  types 718–719
  unplacing 716–717
  viewing using filled regions 973
arrange icons 32
array
  changing 1472
  copying 1471
  creating 1467
  deleting members 1472
  linear 1467
radial 1467
Array tool 1467
arrays
  design options and 671
  arrow tick marks 913
  arrowheads 1609
  artifacts 1096
  artificial light 1084
  Artificial Lights dialog 1067–1068
  Assign Layers tool 470
  Attach Top/Base tool 453
  attached detail groups 1455
    creating 1457
    detaching from a model group 1464
    hiding 1463
    showing 1463
  attached end leader 944
  audit option 83
AutoCAD
  Architecture 1154
  entities 1113
  formats
    drag-and-drop 59
    exporting to 1105
    fonts 65
    importing 59
    linked files 71
    overrides 1113
  Autodesk Channels 44
  Autodesk Seek 47–48, 1142
    sharing with 1142
  automating tasks
    macros 1643
    AVI file export 1102
    AVI files
      solar studies 1388
      azimuth 1383
B
back clip plane
  cutting by 727
background 761
  rendered images and 1085
background color 32, 1625
backup files 88–89
ballast
  loss factor 1056
  number of poles 1052
  voltage 1052
balusters
  defining a pattern 615
  deleting 619
  pattern properties 616
  placement 614
  stair pattern properties 616
baseline dimensions 893
batch print 1153
batt insulation 971
beam angle 1052, 1063, 1065
beam cutback 275
drop end join types 281
instance 277
symbolic 277
beam systems 286–287
dropping 300
justification 296
modifying tags 305
non-planar 301
pattern 299, 308
tagging 303
tagging on placement 304
beams 247, 249
adding a single beam 250
adding by use of grid 250
adding by use of imported geometry 1172
beam annotations tool 263
beam handles 259
Beam/Join Editor 283
cantilevered 300
cutting openings in 343
elevation 285
exporting to AutoCAD Architecture 1167
extending 1489
importing from AutoCAD Architecture 1158
moving 258
properties 267
rotating 258
shape handles 260
spot elevations 265
structural usage 249
tags 262–263
trimming 1489
best practices
Copy/Monitor 1257
lighting 1036
render appearances 1594
rendering 1090
BIM. See building information modeling.
bind 1465
blends
creating 1422
editing 1424
swept blend 1430
blurred refractions precision 1081
Boolean operations
joining geometry 1506
unjoining geometry 1508
borrowing elements
relinquish 1221
retracting a request 1221
bottom-up revision schedules 1002
bounces 1081, 1091, 1093
boundaries 595
boundary conditions 1318
boundary lines
properties 581, 583, 585
sloped surfaces 579
braces 249
attachments 313
cutting openings in 343
exporting to AutoCAD Architecture 1167
extending 1489
importing from AutoCAD Architecture 1158
properties 314
structural 310
trimming 1489
brass 1590
bronze 1590
bubbles
grids 100
offsetting 100
building components
importing 68
placing connectors 68
building elements
creating from mass instances 1356
building information modeling 11–12
Building Maker 1331
building pad
sloping 127
building pads 125
adding 125
cut and fill volume for 125
function 1138
modifying 127
properties 128
slope arrow 580
sloping 579
bump patterns 1586, 1593
Buzzsaw publishing 1144
adding a location 1146
DWF files 1145
DWG files 1144
C
C# macro examples 1652–1653
CAD formats
drag-and-drop 59
exporting to 1105
fonts 65
importing 59
CAD Manager Control utility
InfoCenter and 45
calculated fields 789
callout bubbles 746–747, 749
callout heads 746, 751
callout tags
bubbles 747, 749
changing 749
creating 752
heads 751
intersecting views and 747
line style 752
moving the leader line 750
overview 750
parts of 746
selecting 863
Callout tool 746–747, 754
callout views
adding 747
changing boundaries of 749
cut by the far clip plane 854
displaying 748
modifying 748
opening 748
overview 746
parts of 746
properties 755
rotating 848
sheets and 747
tags 750, 862
types 746
visibility of 753
callouts
tags
design options 669
camera clipping plane
rendered images and 1079
cameras
orienting 758
selecting 759
turning off 760
cancel 1453
cantilevers 367
applying 368
at slab creation 368
cascade 32
categories
definition 13
materials and 1576
overriding graphic display of 803
ceilings
slope arrow 580
slope properties 585
sloping 579
Center tool 833
central file
creating 1210
creating a local copy of 1218
creating from an existing file 1235
moving 1236
central location 88
ceramic materials 1586, 1590
chained walls and lines
modifying 1444
partial selection 1443
selecting 1442
chandeliers 1039–1040, 1043
change management 1239, 1255
checkerboard patterns 1583
circle shape for light sources 1050
circles
sketching 1409
circumscribed polygons 1409
close open loops 1418
clouds 1085
CMU materials 1590
coarse detail level 1618
coarse-scale cut patterns 515
coefficient of utilization 1052
coincident edges
line styles 1503
color picker
PANTONE 1622
Windows 1622
color schemes 711
color, index 1115
color, true 1115
colors
color filters 1052
color preset 1059
color temperature 1059, 1587
dimming lamp color temperature shift 1052
filter color 1587
gradients 1584
image files for 1593
initial color of light sources 1052, 1058–1059
materials and 1578
modifying 1622
new 1622
render appearances and 1593
render performance and 1092
setting 1622
colour. See color
colours. See colors.
columns 509
attaching 510
column families 220
Copy/Monitor 1246, 1248, 1250, 1253
creating 510
cutting openings in 343
detaching 515
exporting to AutoCAD Architecture 1167
headings in schedules 796
importing from AutoCAD Architecture 1158
location marks 781
off-grid 777
locking to grid 230
modifying 516
modifying slanted 237, 239
moving 516
placing slanted 224–228
placing vertical 222
schedule of 775
slanted 224
slanted, upgrade behavior 224
splitting by level 1253
structural 218
totals for schedules 791
types of 516
Communication Center
about 43
receiving announcements 43
settings 44
compact files 88
compass (ViewCube) 819
component legends
sheets and 990
components 14, 677
aligning 1479
hosts, changing 507–508
placing 506
site components 130
compound structure 573
function, applying 574
layer join cleanup 573
layer wrapping 576
layers as references 577
layers, inserting 575
materials 573
preview 577
compound walls
joined to columns 577
orientation, flipping 577
conceptual design
analysis of 1335, 1342, 1354
conceptual design environment 135
3D levels 148
3D reference planes 151
3D snapping 141–142
3D work planes 145
ACIS imported geometry 186
concept creation 141
concept usage 136–137
Create Form tool 167–168, 170, 187
dimensions, loose-labeled 185–186
draw lines 141
draw points 141
drawing 141
extrusions 174
forms 170, 188
adding elements 181
deleting elements 184
dimensions 184
modifying 180
rehosting 184
types 173
in-place families 138, 140
loadable families 138–139
lofts 179
massing family creation 138
opening files 84
profiles 165
project environment 138
reference-based forms 171
revolves 175
selecting forms 172
solid cutting geometry 169
solid form 167
surfaces 173
sweeps 176
swept blends 177
templates 140
unconstrained forms 171
user interface 137
voids 167, 170
X-Ray 163
concrete
gallery joins 393
hidden lines 395
materials 1587
conditional statements in formulas 1554
connectors 68, 697, 1036
deleting 701
linking 700
orientation 697, 700
place on face 697, 699
place on work plane 697, 699
properties 701
selecting primary 700
unlinking 701
working with 697
Consistent Colors style 870
constraints 1537
applying to sketch lines 1407
design options and 670
dimensions and 1537
equality 1537
for imported geometry 66
linked models and 1178
removing 1539
visibility 1538
worksets and 1539
construction documents 977
printing 1149
contour lines
adding 114
labels 130, 132
controls
dimension text 1452
drag 1449
flip 1450
lock 1450
overview 1449
rotate 1451
spacebar 1452
view 1452
coordinate system 1270
coordinate system basis 1116
coordination 1244, 1258
linked models and 1178
Coordination Monitor alert 1258
Coordination Review 1239, 1255, 1258
actions 1256
report 1256
reviewing warnings 1255
coping 1508
copper 1590
Copy tool 1492
Copy/Monitor 1239
best practices 1257
copy vs. monitor 1241
copying elements
current project 1241
Index

linked model 1241, 1244, 1246

elements to monitor 1240
in-place elements and 1240
methods of using 1241
monitoring elements
  current project 1241, 1250
  linked model 1241, 1248
options 1251–1254
overview 1239
performance 1257
phasing and 1240
reviewing warnings 1255
slabs 1257
stopping 1254
troubleshooting 1258
visibility of monitored elements 1258
walls 1259
when to use 1239
workflow 1243
workshared projects and 1242
copying elements
to clipboard 1492
core layer clean-up options 813
corner mullions 637
cost
  materials 1596
cover sheets 989
Create Form tool 167, 170, 187
Create Similar tool 1497
crop regions 849–850
callouts and 753
exporting and 1106
modifying 850
rendered images and 1079
setting the size 853
sheets and 981
using to rotate a view 849
currency
  formatting in schedules 793–794
curtain elements
  selecting 1447
curtain grids 625
  adding 627
  placing 633, 648
  snapping 628
curtain host
  selecting mullions 1448
  selecting panels 1447
curtain systems 640
  adding faces 1365
    by face 641, 1356, 1358
  grid placement 648
  on nurb surfaces 1362
curtain wall panels 630
  joining 632
  merging 628
  reshaping 632
tips 626
  unjoining 632
curtain walls 625
  adding curtain wall doors 493
  cleaning joins 630
  corner mullions 637
  daylight portals 1081, 1083
  grid placement 648
  mitered mullions 639
  non-rectangular 627
  properties 642
  rectangular 625
  wall panels 630
curved walls
  placing 453
custom parameters 1541
custom project templates 1633
custom view scale 860
cut and fill volumes 124
  for building pads 125
  schedule 125
  viewing 124
cut geometry 1434
cut lines 803
cut patterns 803
  materials and 1578
Cut Profile tool 1503
cut structural member with plane 1508
Cut tool 1477
cut-outs 1587, 1590
cutable families 1620
D
dash 1602
data source 1127–1128
database, exporting to 1126
datum elements 14
datum extents
  2D 1530
  3D 1530
  controls 1530
  model extent controls 1530
  propagating 1531
  resizing 1527, 1530
  view specific extent controls 1530
  visibility in views 1527–1529
daylight 1084
daylight portals 1081, 1083, 1086
Deactivate View tool 987
debugging macros 1655
decals 1071
  attributes 1075
  creating 1072
  deleting 1073
  duplicating 1073
  images for 1075
  modifying 1073
  properties 1074–1075
  renaming 1073
  sharing 1074

1784 | Index
dimension styles 1610
dimension text
  overriding 898
dimension text controls 1452
dimension values
  adding text to 898
  replacing with text 899
dimensions
  aligned 889
  anchor symbol 897
  angular, placing 892
  arc lengths 893
  arc wall centers 890
  arrow type tick marks 913
  automatic with walls 890
  baseline 893
  changing values 912
  core boundary 900
  custom dimension units 900
  dimension line text 912
  editing labeled permanent 901
  elements related by constraints 898
  horizontal 891
  legends 769
  listening 909
  locking 896
  loose-labeled 186
  model pattern lines 1569
  modifying 912
  moving temporary witness lines 910
  ordinate 893
  permanent 888
  properties 889, 916
  radial 892
  spot elevation 903
  spot slope 908
  temporary 887, 1618
  temporary to permanent 888
  text size 916
  tick marks 913
  type 887
  units, custom 900
  unlocking 896
  vertical 891
  witness line control 910
dimming lamp color temperature shift 1052
Dimming parameter 1066
disallow complex join 463
discipline 1244, 1258
displaying
  Help 47
document-level macros 1645
C# examples 1653
disable 1656
enable 1656
VB.NET examples 1654
documentation 977
don't cut geometry 1435
doors 491
  adding to a curtain wall 493
Copy/Monitor 1253
daylight portals 1081, 1083
instance properties 495
placing 492
tags 493
type of 494
type properties 496
dormers 537
DPI
  rendered images 1084
drafting patterns 1566
drafting views 964
  creating 964
  display 966
  filled regions 966
  reusing 859
  saving to an external project 967
drag controls 1449
drag-and-drop CAD formats 59
draw order
  detail groups 1464
draw order
  detail groups 1464
drawing area 32
  background color 32, 1625
  highlight color 1625
drawing indexes. See drawing lists
drawing lists
  adding to sheets 1017
  creating 1015
  omitting sheets from 1016
  organizing 1017
  sheet order 1017
drawing sets 977
drawing sheets 1003
  See also sheets
drop panels 373
duct connectors 697
duplicate dependent views 843
  creating 847
  deleting 847
  making independent 847
  matchlines 845
  navigating 817
  propagating 847
DWF files
  2D room and area data export 1120
  custom sheet size 1147
  exporting 1120
    2D DWF 1121–1122
    3D DWF 1121–1122
  importing markup files 1123
  object data 1121
  viewing 1121
  printing 1147
  publishing to Buzzsaw 1145
  XPS 1120
DWF markup files 74
  linking 74, 1123
  managing 1125
  modifying 74
DWFx 1120
linked models and 1178
materials and 1576–1577
model 14
model components 14
moving 1474
overriding graphic display settings 802
phases and 877
properties of 15, 36
scaling 1486
specifying visibility 802
type of 14
view-specific 14
elevation reporting 97, 905
elevation tags 863
elevation views
cut by the far clip plane 854
elevations
changing clip planes 732
reference elevations 732
tags, hiding 862–863
views 730–731
elevator shafts 564
ellipses
full 1415
partial 1415
resizing 1416
rotating 1417
sketching 1414
embedded walls
separating 629
Emit from Circle Diameter parameter 1052
Emit from Line Length parameter 1052
Emit from Rectangle parameters 1052
Emit from Shape parameter 1050
Emit Shape Visible in Rendering parameter 1052
enable worksharing 1210
energy analysis
settings 1566
energy data 1566
entourage
decals 1071
envelopes, zoning 1330
EQ symbol 1537
changing to dimension value 1538
equality constraints 1537
applying 1538
changing to dimension value 1538
EQ symbol 1538
error messages 1678
ESCAPE key 1453
Exclude Options 663
exploding data
SketchUp and 61
export 1105
2D DWF 1122
3ds Max 1139–1141
ACIS solids 1117
AutoCAD Architecture 1165
beams 1167
braces 1167
E
eaves 533
aligning 535
plumb cut, creating 535
two-cut plumb 535
two-cut square 535
edges
line styles 1499
des, silhouette 872
edit
loaded families 692
dit pasted elements 1495, 1515
Edit Rail Joins tool 613
dit witness lines 911
editable only 1216
efficacy 1058, 1095
electrical connectors 697, 1036
element borrowing 1219
checking a request 1221
granting a request 1220
element categories
overriding graphic display of 803
element ID number
finding 1678
locating 1678
selecting 1678
element keynote 940
element properties 15
elements
adding to worksets 1216
annotation 14
behavior 14
-cutting 1477
datum 14
definition 12
demolishing 883
details 14
ditting in groups 1455
flipping 1450, 1452, 1483
hidden 812
hiding 811
in-fill elements 881
interference checking 1261
linked models and 1178
materials and 1576–1577
model 14
model components 14
moving 1474
overriding graphic display settings 802
phases and 877
properties of 15, 36
scaling 1486
specifying visibility 802
type of 14
view-specific 14
elevation reporting 97, 905
elevation tags 863
elevation views
cut by the far clip plane 854
elevations
changing clip planes 732
reference elevations 732
tags, hiding 862–863
views 730–731
elevator shafts 564
ellipses
full 1415
partial 1415
resizing 1416
rotating 1417
sketching 1414
embedded walls
separating 629
Emit from Circle Diameter parameter 1052
Emit from Line Length parameter 1052
Emit from Rectangle parameters 1052
Emit from Shape parameter 1050
Emit Shape Visible in Rendering parameter 1052
enable worksharing 1210
energy analysis
settings 1566
energy data 1566
entourage
decals 1071
envelopes, zoning 1330
EQ symbol 1537
changing to dimension value 1538
equality constraints 1537
applying 1538
changing to dimension value 1538
EQ symbol 1538
error messages 1678
ESCAPE key 1453
Exclude Options 663
exploding data
SketchUp and 61
export 1105
2D DWF 1122
3ds Max 1139–1141
ACIS solids 1117
AutoCAD Architecture 1165
beams 1167
braces 1167
E
eaves 533
aligning 535
plumb cut, creating 535
two-cut plumb 535
two-cut square 535
edges
line styles 1499
des, silhouette 872
edit
loaded families 692
dit pasted elements 1495, 1515
Edit Rail Joins tool 613
dit witness lines 911
editable only 1216
efficacy 1058, 1095
electrical connectors 697, 1036
element borrowing 1219
checking a request 1221
granting a request 1220
element categories
overriding graphic display of 803
element ID number
finding 1678
locating 1678
selecting 1678
element keynote 940
element properties 15
elements
adding to worksets 1216
annotation 14
behavior 14
-cutting 1477
datum 14
definition 12
demolishing 883
details 14
ditting in groups 1455
flipping 1450, 1452, 1483
hidden 812
hiding 811
in-fill elements 881
interference checking 1261
columns 1167
floors 1170
grids 1166
slabs 1170
structural members 1167
walls 1170
AutoCAD formats 1105
CAD formats 1105
coordinate system basis 1116
crop regions and 1106
DGN files 1109
DWF 1120
DWG files 1107
DXF files 1108
file names 1118
format properties 1113, 1123
geometry 1120
IFC 1132
images 1129
improving performance of 1106
layers 1125
properties and 1113
settings 1113
limiting model geometry 1106, 1140
linetype scaling 1115
ODBC database 1126
one DWG unit is 1116
options 1113, 1123
polymesh 1117
room area report 1131
rooms and areas 1117
SAT files 1110
section boxes and 1106
solar study 1388
text notes 1116
to a gbXML file 1137
views as images 1129
exposure settings 1087
Extend tool 1489
exterior light 1084
exterior surface area 1335–1337, 1345–1346, 1353
exterior surfaces 1138
exterior walls 452, 485
properties 348
external references
importing vs. linking 58
extruded roofs 520
aligning 524
editing the work plane 520, 522
end point 523
plan profile 525
rehosting 520, 522
resizing 524
start point 523
extrusions 1420, 1422

face-based family 1520
faces
applying transparency to 806
families 677
adding types 683
applying material to surface 1512
callout heads 751
callout tags 749, 752
changing family types for elements 682
columns 220–221
connectors and 697
creating 691
creating elements from 681
definition 13
deleting unused 683
detail components 968
edit loaded families 692
exploring design variations 682
face-based 1520
Families Guide 680
Family Editor 678
flip control 1520
IFC entities for 1135
in-place families 678, 696
load from library 688
loadable families 678, 687
loading 690
loading shared 689
mass families 1331
model patterns 1512
modifying 692
modifying family types 682
multiple tags 945
overview 677
parameters 695
publishing to Autodesk Seek 1142
reloading 691
section heads 744–745
section views 737
shared parameters 1545
system families 678, 684, 686
trusses 321
viewing 680–681
work plane-based 1520
working with 680
working with shared 695
family categories
assigning 695
Family Category and Parameters tool 695
Family Editor 678
materials and 1576
opening 679
family files
loading as a group 1458
family parameter links 694
family parameters
creating 692
linking 694
family types
adding 38

F

fabric 1594
previewing 39
properties of 15
FAQ
for macros 1666
far clip plane
cutting by 854
far clipping 854
fascias
adding 539
flipping 540
horizontal offset 541
mitering options 540
properties 547
resizing 540
segments 540
vertical offset 541
Favorites links (InfoCenter) 44
FBX file format
exporting to 1139, 1141
preparing for 1140
fbxoprender.exe 1090
field angle 1052, 1063, 1065
Field of View mode 854
Fields tab for schedules 788
files
auditing 83
backup copies of 88
default template files 55
exporting 1105, 1118
importing 57
linking 57
opening 83
reducing size of 88
saving 87
fill patterns 1566
applying 1569
deleting 1569
editing 1569
host orientation 1567
simple, creating 1567
fill volumes 124
filled elevation target 905
Filled Region tool 972
filled regions
creating 972
drafting views 966
fill pattern category 956
properties, changing 972
resizing 972
viewing area 973
fillet arcs 1413
filter color 1587
Filter tab for schedules 789
filters 806
applying 808
color filters 1052
creating 806
deleting 811
keyboard shortcuts 1559
linked models and 1188–1189
modifying
filter criteria 811
visibility and graphics settings 811
renaming 811
selection-based 809
Find Referring Views tool 855
finding
InfoCenter information 41, 44
finding information with Autodesk Seek 47
fine detail level 1618
finish bumps 1586, 1593
flecks in paint 1591
flip control 1520
flip controls 1450
flipped dimension line extension parameter 913
floor area 1353
floor area faces. See mass floors.
floor plan views 725
floor plans
lighting fixtures and 1060
floors 555
adding 555
Copy/Monitor 1246, 1248, 1250, 1254
editing 556
exporting to AutoCAD Architecture 1170
floor surfaces 1138
function 1138
properties 557
slab edges 379
slope arrow 580
slope properties 585
sloped 372, 556
sloping 579
type of 556
folders 1626
foliage 130
fonts, mapping 65
footings
continuous 358, 363
isolated 361
schedule and quantities 797
footprint roofs 519
arc segments 523
creating 521
Formatting tab for schedules 791
forms
conceptual design environment 167, 170
formulas 1553–1554
abbreviations 1553
conditional statements 1554
for family parameters 1553
numerical parameters 1553
schedules and 789
syntax 1553
foundation slabs 382
properties 383
framing elevation 733
bracing 733
work plane 733
free end leader 944
frequently asked questions
about macros 1666
full ellipse 1415
Full Navigation wheels 832
function 1138

G

gable roofs 531
gbXML 1138
exporting to a gbXML file 1137
parameters 1137
gbXML settings 1566
generic materials 1587, 1593
generic models 1356, 1358
imported geometry for 1366
geometry
cement joints 393
constraints when importing 66
exploding 75
exporting 1120
how treated in SketchUp 61
intersecting 1120
snapping to 58
girders 250
glass 1096
glass materials 1589
glazing 1096
glazing materials 1589
glossiness 1587, 1593
graded region 121
gradient background 761
gradient fills
materials maps 1584
grand totals in schedules 790
graphic display
overriding 801
removing overrides 804
graphic display options 867, 871
graphical column schedule 775
display properties 785
grid properties 784
location range 786
materials 783
off-grid columns 776
plan level range 783
segments 786
sheets 787
tagging columns 786
text properties 784
view parameters 787
graphical user interface 21
grey inactive workset graphics 1225
grey scale 1147
Grid tool 98
grids
adding 98
arc 98, 1529
bubbles 100
center segment of 104
changing 99
circular 98
color of 103
continuous 103
Copy/Monitor 1246, 1248, 1250, 1252
customizing grid lines 103–104
display, controlling 1531
exporting to AutoCAD Architecture 1166
gaps in 104
importing from AutoCAD Architecture 1155
length, changing 99
line weight 103
locking columns to 230
modifying 99
number, changing 99
pattern 103
properties 105
visibility in views 1529
ground plane 761
ground plane at level 1377, 1379, 1381, 1383
groups 1455
adding elements 1461
attached detail groups 1455
converting to linked models 1465
copying 1458
creating 1456
deleting 1466
design options and 671
detail groups 1455
editing externally 1463
excluding elements 1462
loading 1458
loading a group into a project or family 1463
model groups 1455
modifying 1461
moving elements to the project view 1462
origin 1460
placing 1459
positioning 1460
properties 1466
reloding 1458
removing elements 1461
renaming 1463
restoring excluded elements 1462
saving 1466
specifying height 1464
swapping out 1464
GUI 21
GUID 1121
guide grids
sheets and 982
gutters 545
adding 545
flipping 546
offsets, changing 547
properties 547
removing elements 546
segments 546
halftone 804
linked model 1195
settings 1605
haze 1085
headings in schedules 796
Help 52
displaying 47
searching multiple Help sources 41
tooltips 26
hemispherical light distribution 1050
hidden elements 812
Hidden Line style 869
hidden lines 395, 862
line styles 1502
projection edges and 1501
Hidden Lines tool 1502
hidden windows, closing 32
Hide at Scales Coarser Than parameter 753
hide elements 811
highlights 1087
horizon 761
horizontal dimensions 891
horizontal line splitting 1511
host components 505
host elements 14
design options and 671, 673
host layers 813
hosted components 505
design options and 671, 673
hosts
changing 507
HTML reports 1256
HTML version of project 1130

I
i-drop 50, 59
IDE
building macros 1654
C# application-level examples 1652
C# document-level examples 1653
creating macros 1645
debugging macros 1655
frequently asked questions 1666
integrating macros 1660
macros 1649
modules 1648
related information 1669
running macros 1655
samples on SDK 1657
using SDK samples 1658
VB.NET application-level examples 1653
VB.NET document-level examples 1654
identity data for materials 1595–1596
IES files 1035–1036, 1047
IFC files
exporting to 1132
file locations 1136
IFC entities for families 1135
loading an IFC class mapping file 71
mapping file 71
opening 70
overriding categories for IFC objects 71
supported IFC classes 1133
illuminance 1058
image files
decals 1075
missing 1094
render appearances and 1593
image precision 1081, 1093
image size 1084
render performance and 1093
images
deleting from a project 67
exporting views as 1129
hidden lines 869
importing 66
modifying imported 67
raster image management 67
rendering 1076
shaded 869
shaded with edges 870
sheets and 993
title blocks and 996
wireframe 868
import
3ds Max 1140
ACIS objects 62
AutoCAD Architecture 1154
beams 1158
braces 1158
columns 1158
grids 1155
slabs 1163
walls 1161
building components 68
CAD formats 59
DGN files 58
draw order 66
DWG files 58
DXF files 58
fonts 65
full explode 75
line weights 65
massing study 1367, 1369–1370
options 63
partial explode 75
scaling 65
sending to back 66
sending to front 66
SketchUp (SKP) files 60
suitability of geometry 57
toposurface 116
using i-drop 59
Import tool 57
import/link
external references and 58
imported files
  changing graphic display of 78–79
  deleting layers 77
  hiding layers 77
  querying objects in layers 75
imported geometry
  constraints for 66
  exploding 75
  snapping to 58
importing
  images 993, 996
  title blocks 1004
in-canvas tooltips 27
in-fill elements 881
in-place elements 678, 696
  Copy/Monitor and 1240
  creating 696
  workflow 696
in-place families
  definition 13
  importing 1369
index of refraction 1587
indirect illumination 1081, 1091
InfoCenter 40
  about 40
  favorite links 44
  searching for information 41
  settings 44
initial color 1052, 1058–1059
initial intensity 1052, 1057–1058, 1066, 1095
inscribed polygons 1409
instance properties 15
  architectural columns 517
  doors 495
  model text 567
  spot coordinates 924
  spot elevation 921
  spot slope 926
  wall sweeps 482
  walls 485, 488
  windows 501
instances
  definition 14
  properties of 15
  schedules and 790
insulation 971
Integrated Development Environment. See IDE
interface 21
Interference Check 1239, 1261
interior light 1084
interior surfaces 1138
interior tick marks 913
interior wall properties 348
interior walls 452, 485
intersecting geometry 1120
isolated footings 361
itemizing instances in schedules 790

J
join geometry 1333, 1506
joined 188
joins
  concrete geometry 393
  editing 457–458
  mullions 636
  roofs 527
  wall 458
joist systems 286–287
  beam direction 295
  boundary location 293
  cutting openings 294
  defining boundaries 289
  picking supports 290
  sketching boundaries 292
joists 249–250
journal files 90, 1624
jump snaps 1614

K
keep readable 1567
key schedules 772
keyboard shortcuts 1559, 1624
  adding 1559
  backing up 1561
  defaults 1562
  defined 1559
  deleting 1560
  dimension values 569
  duplicates 1562
  exporting 1561
  filters for 1559
  importing 1561
  merging 1561
  migrating from a previous release 1561
  printing 1561
  removing 1560
  reserved 1559, 1563
  resetting 1562
  rules for 1563
  searching 1559
  sharing with users 1561
  using 1562
keynote legends
  sheets and 990
keynotes 938
  assigning values 941
  compared to tags 938
  editing keynote files 942
  element 940
  file locations 943
  file versions 943
  filtering 942
  legends 941
  materials 940
  materials and 1596
placing 940
resolving file errors 944
schedules 941
settings 939
tag ends 944
types 940
user 940
workflow 939

keys 1129
keywords

L
L-corner mullions 637
labels
    applying to a tag 708–709
    creating 704
    multi-parameter 705
    properties 707–708
    shared 706
    unit formats 706
lamp lumen depreciation 1056
Lamp parameter 1052
lamp tilt loss factor 1056
landings 595, 597
latitude 1377
layer mapping files 1113, 1125
layers
    as references 577
    assignment rules 470
    changing graphic display of 78–80
    custom 1126
    deleting 77
    exporting 1125
    hiding 77
    join cleanup 573
    linked files and 72
    properties and 1113
    querying objects in 75
    settings 1113
    troubleshooting 79–80
    wrapping 576
leader arrowheads 938
leader lines 926, 935
callout tags and 746, 750
legends 767
    as palettes 769
dimensioning 769
    sheets and 990
level lines 95–96
Level tool 93
levels
    adding 93
    changing type 95
    Copy/Monitor 1244, 1248, 1250, 1252
definition 12
deleting 1244
design options and 670
modifying 95
moving 95
non-story 93
offsetting 1252
properties 97
splitting columns by level 1253
story 93
visibility, controlling 1531
libraries 1626
library
    web library 84
licensing
    borrowing 18
    options 17
    standalone 17
    transferring 18
light bulbs 1034, 1038, 1594
light distribution 1050
light groups 1067
    adding lights to 1068–1069
    Artificial Lights dialog 1067–1068
    creating 1068
deleting 1071
    Light Group Editor 1069
    removing lights from 1068–1069
    renaming 1071
    render performance and 1091
    turning on/off 1070
light loss factors 1056
    changing 1066
    defining 1052, 1055
    parameters 1056
Light Source Definition dialog 1050
light sources
    brightness 1065
    changing light source definitions 1049
defining 1049
defining geometry of 1050
dimming 1066
displaying in project views 1062
    Emit from Shape 1050
    IES files 1047
    initial color 1058–1059
    initial intensity 1057–1058, 1066
    light distribution 1050
    lighting fixture with multiple light sources 1039
    lighting fixture with one light source 1038
    overview 1034
    parameters 1051–1052
    problems in rendered images 1097
    symbol length 1052
    symbol size 1052
    turning on/off 1070
lighting fixtures
    adding to building models 1060
    Artificial Lights dialog 1067
    building models and 1059
    chandeliers 1039, 1043
    changing 1061
    changing light source definitions 1049
creating 1038
defining light sources 1049–1050
displaying light sources for 1062
floor plans and 1060
groups of 1067
IES files 1047
linking parameters 1043
modifying 1049, 1061
multiple light sources 1039
nested families 1039
one light source 1038
overview 1034
parameters 1051–1052
projects and 1059
sharing families 1040
templates 1038
track lights 1039–1040
turning on/off 1070
lighting schemes 1084
lighting solar studies 1383
lights 1033, 1374
adjusting before rendering 1037
best practices 1036
dimming 1066
electrical connectors 1036
IES files 1035–1036
number of 1086
overview 1033
photometrics 1035–1036
render performance and 1091
rendered images and 1084
turning on/off 1070
line patterns 1604
creating 1604
deleting 1604
setting 1604
line shape for light sources 1050
line styles 1602
callout tags and 752
changing in a view 1498–1503
controlling appearance of 803
creating 1602
dash 1602
deleting 1602
in the Family Editor 1603
underlays 1502
views and 1500
line weights 1603
annotation lines 1603
for imported files 65
model lines 1603
perspective lines 1603
linear array 1467
lines 569
adding 569
arc, resizing 1411
extending 1489
hidden 861
model lines 569
offsetting chains of 1476
sketching 1407
splitting 1509
thin 860
trimming 1489
Lines tool 569
linetype scaling 1115
linework
silhouette edges 872
Linework tool 1498–1503
Link tool 57
linked files
AutoCAD files 71
changing graphic display of 78–80
deleting layers 76–77
DWF markups 1123
exported to 3D DWF 1120
hiding layers 76–77
how linking works 72
layers to link 72
linking to a file 72
linking vs. importing 72
location of 73
preserving graphic overrides 78
querying objects in layers 75
Revit and DWF files 1125
troubleshooting 79
linked models 1177
annotations and 1199
by host view 1192
by linked view 1193
constraints to the host 1178
converting to groups 1465
copying 1179, 1185
copying elements from 1186
custom display settings 1194
directory paths for 1181
displaying annotations 1187
elements in 1178
halftone 1195
hiding in a view 1195
hiding nested links 1179
line styles 1499, 1501
linking models 1183–1184
managing 1203
nested links 1184
orphaned elements 1203, 1205
overview 1177
phasing and 1180, 1185
positioning 1184
properties 1202–1203
reloading 1203
schedules and 1195–1197
selecting elements in 1186
showing areas and area boundaries 718
showing nested links 1179
tagging elements in 1200–1203, 1205
transferring project standards 1181
troubleshooting 1199
unloading 1203
updating 1203
view filters 1188–1189
visibility of 1200
when to use 1178
workflow 1182
workshared projects and 1181, 1198–1200

links
managing 1203, 1205–1206
unresolved 1205

listening dimensions 909
Load From Library, Load Family command 688
load properties 1315
loadable families 678, 687
creating 691
definition 13
loading 688–690
modifying 692
with type catalogs 690
workflow 688
loaded tags 1612
loads 1304
area loads
with host 1313
coordinate system 1307
line loads
sketching 1308
sloped frame 1310
load cases 1304
load combinations 1305
load modelling 1307
point loads 1308
loads analysis
using a gbXML file 1137
location lines 642
location of project 107
troubleshooting 109
lock controls 1450
locking
views on sheets 984
lofts 179
logos in title blocks 996
longitude 1377
loops
closing 1418
loose-labeled dimensions 186
LTSCALE 1115
luminaire dirt depreciation 1056
luminance 1587
luminous flux 1058
luminous intensity 1058

M
Macro Manager 1645
macros 1649
API 1643
API differences 1659
application level 1645
C# application-level examples 1652
C# document-level examples 1653
common uses 1643
debugging 1655
document level 1645
document properties 1647
frequently asked questions 1666
gaining started 1643
initial steps 1645
integrating in VSTA 1660
Macro Manager 1645
overview 1643
reference documentation 1657
related information 1669
running 1655
samples on SDK 1657
security 1656
using SDK samples 1658
VB.NET application-level examples 1653
VB.NET document-level examples 1654
workflow 1645
main model 655
elements deleted 673
incorporating a design option 666
moving elements to design options 661
selecting elements in 663
viewing without design options 668
Make Primary tool 658, 661
Manage Images tool 67
manufacturers
materials and 1596
mapping file
for IFC 1132
for layers 1125
marble maps 1584
marked-up DWF
linking 1123
managing links 1125
masking regions 973
adding
in a 2D family 973
in a 3D family 974
in a family 974
in a project 973
exporting to DWG 973
properties 976
sheets and 981
using with imported 2D DWG files 975
masonry materials 1590
mass face 1334
mass family 1330
creating 1331
importing 1367, 1369–1370
in-place mass 1332
loading 1333
placing 1333
mass floors
analysis 1342
bottom of mass 1337
creating 1337
masses and 1333
overview 1335
mid-end wall joins
disallowing 464
mirror materials 1591
mirror project 1270
mirror reference labels 755
Mirror tool 1483
miter joins
beams 281, 283
model components 14
model crop regions 849–850
model elements 14
host 14
model components 14
model extents 1530
model faces
applying transparency to 806
model graphics style
DWF files and 1121
model groups 1455
creating 1456
model line weights 1603
model lines 569
fillet 1407
joining 1407
rounded chain of lines 1407
sketching 1407
Model Lines command 1436
model patterns
aligning to elements 1570
dimensions 1569
moving 1569
rotating 1570
model text 565
adding 566
changing work plane 566
editing text 566
instance properties 567
moving 566
rehosting 566
shown cut 565
type properties 568
modelspace 1115
modules 1648
moment symbols 262
monitoring elements
changes to 1239
reviewing warnings 1255
stopping 1254
monolithic stairs 601
Move tool 1475
moves with nearby elements 1478
movies 52
moving elements
arrow keys 1475
moving level-based components 507
moving workplane-based components 507
mullions 635
adding 635
angle of 636
changing materials 639
corner mullions 637
joins, controlling 636
locking 635
position of 636
profiles 640
properties 642
selecting 1448
types of 637
multi-category schedules 1548
multi-category tags 1547
using in a project 1547
multi-day solar studies
settings 1381
multi-discipline coordination 1239

N
named locations 1265
natural light 1084
navigating
navigation bar 824
navigation tools 833
SteeringWheels 827
ViewCube 819
navigation bar 824
nested families
lighting fixtures 1039
nested linked models
hiding 1179, 1184
showing 1179, 1184
view filters and 1188–1189
New tool 55
new window 32
noise maps 1584
non cuttable families 1621
non-planar beam system 301
north 107, 110
note blocks 774
sheets and 982, 991
numeric fields, formatting 792
numeric sketching 569
nurb surfaces
curtain systems from 1362
roofs from 1364

O
object data
DWF files and 1121
exporting 1121
viewing in DWF files 1121
object snaps 1617
object styles 1601
creating subcategories 1601
deleting 1601
exporting 1113
materials and 1576
modifying 1601
renaming 1602
Index | 1797
ODBC database
exporting to 1126
primary keys 1129
supported drivers 1127
table relationships 1129
Offset tool 1476
OmniClass codes
assigning 1142
online help 52
tooltips 26
Open Documents 25
open loops
closing 1418
Open tool 83
openings 486, 561
beams 343
braces 343
ceilings 563
columns 343
Copy/Monitor 1246, 1248, 1250, 1253–1254
defining 348, 455
floors 563
floors, multiple 564
roofs 563
shafts 564
walls 562
option conflicts 674–675
Options Bar 34
Options dialog 1623
File Locations tab 1625
General tab 1623
Graphics tab 1625
Macros tab 1631
Rendering tab 1626
Spelling tab 1628
SteeringWheels tab 1628
User Interface tab 1624
ViewCube tab 1630
ordinate dimensions 893
orient to view 1567
Orient tool 758
orientation in host layers 1567
origin
for groups 1460
orphaned elements
rehosting 1205
reviewing 1203
orthographic 3D views 757–758
orthographic views
background 761
overhang 525
overlap 673
override snaps 1615

P

paint
flecks 1591
material properties 1591

metallic paint properties 1591
Paint tool 1512
panels 21
paperspace 115
parallel dimensions 893
parallel walls
joining 461
parameter groups
deleting 1544
renaming 1544
parameter properties
drawing sheets 1003
project information 1003
parameter values 1553
parameters 695
creating 692
custom 1541
linking 694
shared 1541
parameters, reporting 1550
parametric engine 11–12
parking components 129
partial ellipse 1415
Paste Aligned tool 1493
design options and 662
Paste tool 1493
path of linked files 73, 1181
path reinforcement 439
sketching 440
tagging 443
viewing 441
patina 1590
pattern files 1570
patterns 197
component families 202
creating 1571
render performance and 1092
PDF 1151–1152
perforations 1587, 1590
performance 1671
Copy/Monitor 1257
perimeter 1335, 1348–1349, 1353
permanent dimensions 888
perspective lines 1603
perspective views 758
3D 757
background 761
properties 763
saving 843
phases 877
combining 879
Copy/Monitor and 1240
demolishing elements 883
elements and 877
graphic display of elements 880
in-fill elements 881
linked models and 1180, 1185
masses and 1334
overrides 880
Index | 1799

Phase filters 879
   applying 880
   default 879
properties 877
schedules 877
photometrics 1035–1036
   photometric web file 1052
   photometric web light distribution 1050
   specifying IES files for light sources 1047
physical data for materials 1596–1597
physical properties of materials 1282
physical quantities 1613
Pick to Edit tool 659
picking paths 1426
pin sheets and 984
Pin tool 1484
pipe connectors 697
pitch of sloped surfaces 581, 583
Place a Component tool 506
places 1626
plan regions 729–730
plan views 725
cut by the back clip plane 727
plants 130
plastic materials 1591
plumb cut eaves 535
poche depth 114
point shape for light sources 1050
points file, toposurface from 116
polygons
   circumscribed 1409
   inscribed 1409
   sketching 1409
polylines
   exporting rooms and areas as 1117
   line styles 1499
polymeshes
   creating faced-based elements 1356
   description of 1117
   exporting solids as 1117
   masses and 1356
porcelain materials 1586
posts
   defining a pattern 617
   deleting 619
   placement properties 618
   placing 617
Press & Drag 1474
preview image
   of a project 88
   of family types 39
primary keys 1129
primary options 656
   promoting secondary options 661
   viewing 667
primary views 817, 843
Print Preview tool 1149
print resolution 1077
Print tool 1146, 1149, 1151
   Setup 1147
printing 1146, 1149
   batch print 1153
   construction documents 1149
   DWF 1147
   mass elements 1371
   PDF 1151–1152
   preview 1149
   settings 1148
   setup 1147
   sheets 1149
   tips 1147
to a file 1149
views 1150
privacy 43
procedural maps 1583
product updates 43
progress bar 33
project base points 1271
   clipped 1271
   making visible 1271
   moving 1271
   pinning 1272
Project Browser 28
   filtering views 855
   organizing views 855
   using 28
project files
   loading as a group 1458
project information 1565–1566
   parameter properties 1003
   sheets and 986
   title blocks and 1003
project location 107
   troubleshooting 109
Project North 111
project parameters 1549
   creating 1549
   linked models and 1197
project place 1265
project settings 1605
project standards
   linked models and 1181
   transferring to another project 1635
project templates
   creating 1633
   custom 1633
   saving 1633
   settings 1634
   sheets and 979
project units by discipline 1613
Project Units tool 1613
project views
   3D views 757
   closing hidden views 32
   crop regions 849
   dedicating to design options 667
   dependent views 843
design option settings 669
   to a file 1149
elevation views | 730  
exporting to HTML | 1130  
legend views | 767  
light sources | 1062  
organization of | 855  
phases and | 877, 880  
plan views | 725  
primary views | 843  
renaming | 817  
rendering | 1076, 1088  
rotating | 848  
schedule views | 771  
section views | 737  
view settings | 859  
visibility and graphic display in | 801  
walkthrough views | 1099  

projection edges  
line styles | 1501  
segmenting | 1501  

projection lines | 803  
projection patterns | 803  
projection plane | 1301  

projects  
creating | 55  
definition | 12  
global settings | 1623  
internal coordinates | 1116  
new | 55  
phasing | 877  
physical quantities | 1613  
relocating | 1269  
starting | 56  
units, setting | 55  

properties  
3D views | 763  
areas | 716  
building pad | 128  
callout views | 755  
contour line labels | 132  
curtain walls | 642  
dimension | 916  
element properties | 36  
fascias | 547  
floors | 557  
grids | 105  
gutters | 547  
instance properties | 15  
leader arrowheads | 938  
levels | 97  
loads | 1315  
mass floors | 1353  
mullions | 642  
perspective views | 763  
railings | 619  
ramps | 608  
rebar | 423–424, 431, 436–437, 441–442  
reference planes | 1524  
revision clouds | 1027  
roofs | 547  
section views | 962  
sheets | 993–994  
site settings | 115  
slab edges | 380  
slope arrows | 547  
stairs | 601  
structural columns | 241  
text notes | 936  
toposurfaces | 122  
type properties | 15  
view | 873  
view range | 867  
view templates | 1640  
viewports | 1007  

property lines | 122  
angle display | 114  
converting to table-based | 124  
creating with survey data | 122  
exporting | 123  
scheduling | 123  
sketching | 122  
tagging | 123  
units | 114  

proxy graphics | 58  
PSLTSCALE | 1115  
publish  
assigning OmniClass codes | 1142  
guidelines for manufacturers | 1142  
to Autodesk Seek website | 1142  
to Buzzsaw | 1144  
adding a Buzzsaw location | 1146  
DWF | 1145  
DWG | 1144  
publish coordinates | 1267  
purlins | 249–250  

Q  
quad-corner mullions | 637  
quality of rendered images | 1080–1081  
Query tool | 75  
Quick Access toolbar | 25  

R  
radial array | 1467  
radial dimensions | 892  
railings | 611  
adding | 611  
editing joins | 613  
height and slope | 613  
properties | 619  
rail structure | 612  
type of | 597, 612  
ramps  
adding | 607  
curved | 607  
editing | 608  
properties | 608  
type of | 608  

raster images
  deleting from a project 67
  importing 66
raster quality 1147
real-time rendering 871, 1031–1032
real-time rendering workflow 1032
Realistic style 871
rebar 397
  area reinforcement 433
  hooks 426
  path reinforcement 439
  placing 397, 403, 405–406
  407
    placement planes
  schedule mark 420
shape
  controls 413
  family editor 418
  parameters 420
  snapping 413
shapes 402
  auto expansion 411
  browser 402
  orientation 410
  placement 402
sketching 397, 417
spiral 415
valid hosts 398
view as solid 421
view unobscured 421
view visibility 421
rebar cover 399
  editing 399
  properties 401
  references 399
settings 400
rebar hooks 426
  controls 429
  moving 429
orientation 429
parameters 427
swapping 431
rebar sets 432
  creating 432
  shape handles 433
rebar shapes 402
recent commands 1455
Recent Documents 25
Recent Files window 40, 83
recovery files 89
rectangle shape for light sources 1050
rectangles
  sketching 1408
redo 25, 1453
reference callouts
  adding 754
  labels for 755
  overview 747, 753
reference elevations 732
reference labels 746, 755
Reference Other View option 754
Reference Plane tool 1523
reference planes
  3D 151
  adding 1523
  annotation, hiding 1524
  properties 1524
  visibility in views 1528
reference point 152
  adaptive 155
  driving 155
  free 152
  hosted 153
reference sections 742
reference type 1179
reference-based form, converting 172
reflectance 1589
  diffuse 1587
reflections
  render performance and 1092–1093
  render quality setting 1081
reflectivity 1587
refraction 1587
refractions
  blurred refractions precision 1081
  render performance and 1093
  render quality setting 1081
refresh 32
relative path 73, 1181
release conditions 1282
relief pattern 1590
relinquish all mine 1229
relinquish borrowed elements 1221, 1229
relocate projects 1269
Rename tool 817
render appearances
  best practices 1594
  colors, specifying 1593
  file paths 1627
  image files for 1593
  library 1599
  materials and 1582
  preview of 1582
  properties 1586–1587, 1589–1592
  render performance and 1092–1093
  searching for 1599–1600
  shaders 1586
  texture alignment 1580–1582
render performance
  building model and 1091
  image size/quality and 1093
  lighting and 1091
  materials and 1092–1093
  render appearances and 1092
render quality
  advanced settings 1081
  best practices 1090
  custom 1081
  render performance and 1093
  specifying 1080
  troubleshooting 1096
extruded 520
fascias 539
four-sided gable 531
gutters 545
intersecting slope lines 530
joining 527
modifying 524
nurb surfaces and 1364
overhang 525
properties 547
resizing 524
slope 528
slope arrow 580
sloping glazing 520
sloping 579
soffits 542
type of 524
unjoining 528
room area report 1131
rooms 711
exporting 1117
option conflicts 674–675
schedules and 789
rotate controls 1451
rotate project views 848
Rotate tool 1481
rotating
Project North 111
revision schedules 1000
views on sheets 988
views to True North 110
round-tripping 1123
rounded chain of lines 1407
RPC content
file paths 1627
RSS feeds 44
ruled curtain systems
curtain grids, adding 641
mullions, adding 641
RVT files
loading as a group 1458

S

SAT files
ACIS solids 1117
exporting to 1110
importing 59
saturation 1087
Save As
template 1633
Save As tool 87
options 88
save options 88
reminders 88
Save tool 87
scale 860
scale factors 1486
Scale mode 854
Scale tool 1486
scales
adding 1603
deleting 1603
Schedule tool 771
schedules 772
adding room parameters 789
adding to sheets 1011
adjusting column width 1014
area analysis 1343
areas 717
calculated fields 789
column headings, grouping 796
column schedule 775
column totals 791
creating 771
design options and 667
exporting 798
exterior surface area analysis 1346
footings 797
formatting on sheets 1012
formulas 789
grand totals 790
grouping 790
instance display 790
joining split sections on sheets 1013
keys 772
linked models and 1195–1197
mass floors 1339, 1343, 1346, 1349, 1351
material takeoffs 774
modifying 795
moving sections on sheets 1013
multi-category 1548
multiple sections 1012
note blocks 774
percentages 789
perimeter analysis 1349
phases and 877
properties tabs 788
reusing 859
sections, moving 1013
shared parameters 1548
sheets and 1011
single-category 1548
splitting on sheets 1012
subtotals 791
text in cells, editing 796
updating 795
usage analysis 1343
vertical column headings 1014
view lists 858
views 797
volume analysis 1351
scope boxes 1531
creating 1532
datums, applying 1533
rotating 848
visibility of 1535
screen refresh 32
screen resolution 1077
screen savers 1090
SDK
macro API samples 1657
migrating samples 1664
reference documentation 1657
using samples 1658
sealant 1587
searching
InfoCenter 41, 44
searching with Autodesk Seek 47
secondary options 656
promoting to primary 661
viewing 667
section boxes 762
exporting and 1106
limiting model geometry and 1119
render performance and 1091
rendered images and 1079
when exporting a model 1119
section cut material 114
section head family 745
creating 744
parameters 744
starting 744
section lines, breaking 739
section tags 862–863
design options and 669
Section tool 737
section views 962
creating 737
cut by the far clip plane 854
displaying 743
in the Family Editor 737
overview 737
reference 742
resizing 740
rotating 848
symbols 738
sections
jogged 740
segmented 740
Seek utility 47–48, 1142
segmented sweeps 1428
selecting
elements in design options 663
mass floors 1338
selection
all instances 1441
chain 1442
count of selected elements 1441
curtain elements 1447
elements 1439–1440
mullions 1448
multiple elements 1440
removing elements from 1440, 1449
selection count 1441
shortcuts 1440
walls or lines joined at a point 1446
sequential tag numbering 950
settings 1605
printing 1147
Shaded style 869
shaded views
materials 1578
shaders 1586
shading surfaces 1138
Shading with Edges style 870
shadows 1374–1376
defining place on Earth 107, 1391
exposure setting 1087
sunlight source 1390
shafts 564
Copy/Monitor 1254
shape handles 260, 1453
shared coordinates 1116
reporting 905, 1270
shared families
lighting fixtures 1040
loading 689
working with 695
shared parameters 1541
categories 1542
creating 1543
defining 1543
deleting 1544
exporting 1546
families 1545
IFC export 1135
projects 1549
schedules 1548
setting up 1543
tagging 1546
title blocks and 1003
viewing 1544
shared positioning 1265
acquiring coordinates 1267
named locations 1265
origin-to-origin 1184
publishing coordinates 1267
reporting shared coordinates 1270
sheet indexes. See sheet lists
Sheet Issues/Revisions dialog 1019
sheet lists 1015
adding placeholder sheets to 1015
sheet sets 977
sheet views. See sheets
sheet-specific information
sheets and 985–986
title blocks and 1003
sheets 978
activating views 987
adding 979
adding placeholder sheets to list 1015
adding views to 980
aligning views on 984
annotation schedules and 991
callouts and 747
changing title blocks on 998
cover sheets 989
crop regions and 981
date/time stamp 978
deactivating views 987
dependent views and 987
dividing views across 987
drawing lists and 1017
external information on 992-993
guide grid 982
guide grids 982
hiding parts of views 981
images and 993
legends and 990
locking views on 984
masking regions and 981
modifying views from 987
note blocks and 991
numbers, changing 985
omitting from drawing lists 1016
order in a drawing list 1017
overview 978
printing 1149-1150
project templates and 979
properties 993-994
renaming 985
reusing 859
rotating viewports 848
rotating views on 988
saving to an external project 967
schedules on 1011-1012
spreadsheets and 992
table of contents 989
time stamp 978
title blocks for 979
title sheets 989
view lists and 859
view references 988
view titles 1007
viewports 1005-1006
shortcuts
selecting elements 1440
Show Hidden Lines tool 1502
Show Mass mode 1332, 1365
SHX fonts 65
silhouette edges 872
Sim labels 755
single day solar studies
settings 1379
single-category schedules 1548
single-category tags 1546
site components 113, 130
site plans
creating 1259
deleted 1259
site settings 113
properties 115
sketch lines
constraining 1407
explicitly specifying length 909
sketch mode 1405
sketch-based elements 1405
sketching 1405
applying constraints 1407
arcs 1410
chains 1406
circles 1409
ellipses 1414
jump snaps 1614
lines 1407
modifying 1419
numeric 569
offsetting sketch lines 1406
options 1406
polygons 1409
radius 1406
rectangles 1408
snap points 1614
splines 1417
terminology 1405
sketching paths 1426
SketchUp
creating content for use in Revit 61
exploding 3D data 61
files, importing 60
geometric flexing 61
integrating with 60
massing studies in 1366-1367, 1369-1370
SKP files 60
sky
background 1085
clouds 1085
color 761
haze 1085
illumination 1081
slab edges
flipping 380
resizing 380
segments 380
slab surfaces 1138
slabs
adding 366
Copy/Monitor 1257
curved edges 390
drop panels 373
exporting to AutoCAD Architecture 1170
foundation 382
importing from AutoCAD Architecture 1163
modifying 375
offsets 380
properties 376
shape edit 386
slab edges 380
structural 366
slope 581, 583
slope arrow 579-581
examples 580
properties 584
tail 580-581
sloped surfaces 579-580
boundary line properties 581, 583, 585
multiple slopes 580
properties, how measured 579
roofs 528
slopes
  slope arrows
  properties 547
  slope-defining arcs 523
  sloped floors 372, 556
  sloped glazing 520, 648
snapping
  3D 141–142
snaps 1614
  disabling 1615
  enabling 1615
  keyboard shortcuts 1617
  setting 1614
  temporary overrides 1615
  turning on/off 1614
softs 542
  slope arrow 580
  slope properties 585
  sloping 579
soft shadows 1081, 1091
Software Development Kit. See SDK
solar studies 1373–1374
  animations 1387
    based on azimuth and altitude 1383
    creating 1376
    exporting 1388
    lighting 1383
    multi-day 1381
    previewing 1387
    single day 1379
    still 1377
  True North 110
  views 1374
  workflow 1374
solid glass materials 1589
solid swept blend 1430
solids
  swept blend 1430
  sort order
    detail group 1464
Sorting/Grouping tab for schedules 790
spacebar 1452
span direction 371
  adding 370
speckled patterns 1585
spell checker
  options 1628
Spelling tool 934
spherical light distribution 1050
spiral rebar 415
spiral staircases 596
spline 1417
  modifying 1418
split face 1511
split level plans 729
Split Region tool 469
split surfaces 120
Split Walls and Lines tool 1509
spot beam angle 1052, 1063, 1065
spot coordinates 905
  instance properties 924
  placing 906
  type properties 922
spot dimensions 902
spot elevation 903
  arrowhead style 905
  instance properties 921
  placing 903
  reporting, changing 905
  type properties 919
spot elevations 265
spot field angle 1052, 1063, 1065
spot light distribution 1050
spot slope 908
  instance properties 926
  type properties 925
spot tilt angle 1052, 1063, 1065
spotlights
  aiming 1063
  angles for 1065
  rotating 1063
spreadsheets
  sheets and 992
  square off joins 281
  stain on wood 1592
  stainless steel 1590
stairs
  arced landings 597
  balusters 591, 616
  boundaries 595
  changing direction 601
  creating 591–593, 595
  labels for 601
  landings 595
  modifying 599
  monolithic 601
  properties 601
  railings 597, 599
  risers 595
  spiral 596
  stair calculator 598–599
standalone licensing 17
standards 47
start-end-radius arc 1412
status bar 33
  design options 660
  worksets 1218
SteeringWheels 827
  options 1628
SteplInto
  debugging macros 1655
  still solar studies
  settings 1377
  stone materials 1592
  stone textures 1584
  structural
    beam end pocket seats 250
Index | 1807

beams  247, 249–250
braces  310–311
columns  218, 241
      inside architectural columns  230
families  218
joist systems  286, 294
settings  1605
slabs  366
      symbolic representation  1605
symbols  1605
      template  217
walls  345–346
structural elements  861
structural floors
      slope arrow  580
      slope properties  585
      sloping  579
structural members
      exporting to AutoCAD Architecture  1165, 1167
      importing from AutoCAD Architecture  1154
      interoperability with AutoCAD Architecture  1154
structural openings  900
subcategories
      materials and  1576
subtotals  791
sun intensity  1375
sun path  1373, 1375
sun settings  1373, 1390
sun studies  1376
sunlight  1084
sunscreens  1594
surface area  1353
surface depreciation factor  1056
surface lines  803
surface patterns  803
      materials and  1578
surfaces  1138
      dividing  190
      patterning  197
      rationalizing  190
survey points  1271
      clipped  1271
      making visible  1271
      moving  1271
      pinning  1272
sweeps
      conceptual design environment  176–177
      creating  1426
      cuts wall  471
      cuttable  471
      mechanical duct work  1428
      profile  471
      segmented  1428
      setback  471
      swept blend  1430
      tips  1430
      swept blend  1430
symbol legends
      sheets and  990
Symbol tool  951
symbolic lines  1436
symbols
      adding  951
      modifying  952
Synchronize to Central  1623
synchronizing with the central file
      default options  1226
system families  684, 686
      definition  13
      loading  687
      overview  684
system family types
      loading into a project or template  686
T
table of Contents
      sheet list  1015
      title sheet  989
tabs  21
tag all not tagged  947
tag numbering  950
Tag tool  944
tags
      aligning  947
      applying by category  945
      applying on placement  946
      compared to keynotes  938
      design options and  669
door tags  493
doors  950
      labels  944
linked models and  1200–1202
loading  1612
mass floors  1340
material  948
modifying  949
multiple  945
revision clouds  1026
      specifying default style  1612
tag all not tagged  947
window tags  500
windows  950
tangent arcs  1413
Tape Measure tool  1505
temperature
      color temperature  1059
dimming lamp color temperature shift  1052
      loss/gain factor  1056
templates
      creating  1633
      custom  1633
      default project templates  55
      settings  1634
      worksets and  1215
Temporary Dimension tool  1618
temporary dimensions  887
appearance  887
setting  1618
temporary files 89
Temporary Hide/Isolate tool 812
text
  overriding in dimensions 898
text files
  sheets and 992
text notes
  adding 926
  editing 929
  leaders 926
  modifying 929
  non-wrapping 926
  properties 936
  special characters 935
  wrapping 926
text treatment 1116
texture
  alignment 1580–1582
  image files for 1593
  tileable 1594
Thin Lines tool 860
tick marks
  for dimension lines 913
  interior 913
tile 32
  tileable textures 1594
tiling
  simulating 1585
tilt angle 1052, 1063, 1065
title blocks 995
  adding fields to 1003
  changing on a sheet 998
  creating 995
  images in 996
  importing 1004
  loading into projects 997
  logos in 996
  modifying 996
  overview 995
  project-specific information 1003
  revision schedules on 998
  shared parameters and 1003
  sheet-specific information 1003
  title sheets and 989
title marks 1006
  title sheets 989
ToolClips 26
tooltips 26
top-down revision schedules 1002
toposurfaces 115
  creating by picking points 115
  from points file 116
  grading 121
  importing 116
  merging 120
  properties 122
  simplifying 118
  splitting 120
  subregion 118
Tour Building wheels 831
track lights 1039–1040
transferring project standards
  linked models 1181
translucency 1587, 1593
transmittance 1589
transparency 806, 1593
  alpha channel 1088
  generic materials 1587
  materials and 1578
trapezoid corner mullions 637
trees 130
Trim tool 1489
troubleshooting
  3ds Max export/import 1141
  Copy/Monitor 1258
  design options 673
  layers 79–80
  linked files 79
  linked models 1199
  mass floors 1354
  rendering 1093
  visibility
    linked models 1199
True North 107, 110
trusses 320
  adding 323
  attaching to a roof or slab 324
  creating a truss family 321
  editing a truss profile 326
  properties 331
  reset 331
  tagging 329
two-cut plumb eaves 535
two-cut square eaves 535
type catalogs
  loading families with 690
type parameters 15
  architectural columns 516
  doors 496
  model text 568
  spot coordinates 922
  spot elevation 919
  spot slope 925
  walls 481, 484, 487
  windows 502
types
  adding 38
  definition 13
  previewing 39
U
U grid lines 190
UI 21
uncut geometry 629
underlay
  settings 1605
underlays
  line styles 1502
undo 25, 1453
Uniformat assembly codes 587
units
  for DWG export 1116
units for a project 1613
setting 55
unjoin geometry 1508
unjoin roofs 528
Unpin tool 1485
Update to Face tool 1365
updating
  Communication Center updates 43
upgrading
  workshared projects 1232
usage 1353
  analysis 1342–1343
  assigning to mass floors 1342
user defined height for revision schedules 1001
user interface 21
user keynote 940
username 1623

V
V grid lines 190
V-corner mullions 637
variable height for revision schedules 1001
VB.NET
  macro examples 1653–1654
vector data 59
vegetation 130
vertical dimensions 891
vertically compound walls
  sample height 467
tools
  accessing 466
  Assign Layers 470
  Merge Region 469
  Modify 467
  Split Region 469
vertically stacked walls 472–473, 475
defining structure 473
inserts 476
videos 52
view callouts 747
View Control Bar 39
view controls 1452
view filters
  linked models and 1188–1189
view lists 858–859
View Object wheels 831
view properties
  renderings 1090
View Properties tool 873
view range 864, 867
view references 817–818, 988
view scale 860
  custom 860
view symbols 855
view tags 862–863
  design options and 669
view templates 1637
  applying 1639
  creating 1637
  default 1639
  deleting 1640
  properties 1640
  render settings 1089
view titles
  modifying 1008
  removing 1009
  sheets and 1007
  types 1009–1011
view-specific elements 14
  annotation elements 14
details 14
ViewCube 819
  options 1630
viewports 1005
  properties 1007
  rotating 848
  types 1006
  view title types and 1011
views
  3D 758
  activating on sheets 987
  changing the names of 817
  creating 725
  deactivating on sheets 987
  dedicated views 656
detail 959
direction 725
displaying 729
drafting 964
exporting as images 1129
framing elevation 733
legends 767
managing the properties of 858
orthographic 3D 757–758
perspective 758
phases and 877, 880
printing 1150
renaming 817
renderings 1088
reusing 859
rotating 848
saving 843
saving 2D 959
saving to an external project 963
schedule 771
selecting 1150
sheet views. See sheets
  sheets and 980–981, 984, 987–988
  view tags 862
vinyl materials 1591
virtual memory 1671, 1673
visibility
  constraints 1538
  controlling with filters 806
  limiting model geometry and 1106
  linked models 1187, 1199–1200
  mass instances and 1365
  specifying 801
    for element categories 805
    for individual elements 802
  temporary hide/isolate 812
  when exporting a model 1106
  worksets and 1230–1231
Visibility/Graphics dialog 801
Visible in Option parameter 666, 669
  deleting design option sets and 666
  deleting design options and 665
visible range 864
Visual Studio Tools for Applications. See VSTA
visual styles options 867
void swept blend 1430
voids
  conceptual design environment 170
  swept blend 1430
voltage loss/gain factor 1056
volume 1333, 1335, 1350–1351, 1353
VSTA
  building macros 1654
  C# application-level examples 1652
  C# document-level examples 1653
  components 1645
  frequently asked questions 1666
  integrating macros 1660
  introduction 1643
  macro development 1643
  Macro Manager 1645
  macros 1649
  modules 1648
  reference documentation 1657
  related information 1669
  running macros 1655
  samples on SDK 1657
  SteplInto option 1655
  using IDE 1645
  using SDK samples 1658
  VB.NET application-level examples 1653
  VB.NET document-level examples 1654
  workflow 1645

W
walkthroughs 1099
  AVI files 1102
  creating 1099
  displaying 1101
  editing 1100
  exporting 1102
  frames 1101
  playing 1102
  Wall by Face tool 1356
wall elevations
  modifying 348
wall foundations 355
  breaks 357
  creating 355
  end extensions 357
  modifying 356
wall joins
  cleaning 459
  design options and 671
  disallowing 463
  editing 457–458
  incorrect 673
  non-editable walls and 463
  selecting 458
Wall joins
  parallel walls 461
wall openings 350
wall reveals
  adding 482
  moving away from wall 484
  profile 484
  segments 484
  type of 484
wall shapes 348, 350
wall sweeps
  adding 477
  dimensioning to 480
  instance properties 482
  profile 478
  resizing 480
  returning to wall 478
  segments 479
  type of 479
Wall Sweeps tool 471
walls 449
  arced 453
  attaching to components 453
  automatic dimension with 890
  best practices 485
  compound 465
  compound walls 573
  Copy/Monitor 1246, 1248, 1250, 1253, 1259
  creating from mass instances 1356
  curtain wall panels 630
  curved 453
  cutouts 348, 455
  detaching from other elements 453
  elevations 455
  exporting to AutoCAD Architecture 1170
  extending 1489
  exterior properties 348
  exterior walls 452
  fillets, creating automatically 486
  function 1138
  importing from AutoCAD Architecture 1161
  instance properties 485, 488
  interior properties 348
  interior walls 452
  modifying 347, 454
Z

zero tread thickness  601

zinc  1590
zoning envelopes  1330
Zoom tool  860
  line thickness and  860