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Autodesk Robot 
stRuctuRAl AnAlysis 

FAst oVeRVieW 

Synopsis:

	 Th	 e	purpose	of	this	Manual	is	introduce	the	novice	user	to	the	Autodesk	Robot	
Structural	Analysis	system	and	to	provide	some	guidance	into	the	program	confi	gura-
tion,	menu	system	and	navigation	techniques.	 It	will	also	show	the	many	and	varied	
methods	of	input	of	data	and	extraction	of	results.
It	is	assumed	that	Autodesk	Robot	Structural	Analysis	2010	is	installed	on	the	PC.
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General description of the program 
What is Autodesk Robot Structural Analysis?

	 Autodesk Robot Structural Analysis (Robot) is a single integrated program used 
for modeling, analyzing and designing various types of structures. The program allows 
users to create structures, to carry out structural analysis, to verify obtained results, to 
perform code check calculations of structural members and to prepare documentation 
for a calculated and designed structure.

	 Robot – key features of the Commercial version are shown below:

Linear, nonlinear and dynamic (modal, spectral, seismic, time history, push over, 
P-Delta, buckling deformation, plasticity) structure analysis
working in a multilingual environment (15 languages independently set to user 
interface, designing and calculation notes)
working in a multinational environment - designing according to over 50 de-	
sign codes    
frames, plates and shells, plus a powerful GUI modeler and mesher allows the 
user to define virtually any shape or configuration of structure – you analyze the 
true structure geometry
quality bi-directional integration with Revit® Structure, plus integration through 
IFC, CIS2 etc.
an open API to allow the user to interface their own applications for pre and/or 
post processing

Robot modules 
Robot is a single product with many functions and a common user enviroment.

Once Robot is activated (click on the appropriate icon on the desktop or choose the 
appropriate command from the taskbar), the window shown below  (Figure 2.1) will 
appear on the screen. The window is used to select the type of structure that will be 
analyzed or to load an existing structure.










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Figure 2.1 - Robot modules window

When the cursor is positioned on an icon, a short description of its function is displayed.

NOTE:

Th	 e	most	commonly	used	icons	are	described	below:

2D Frame Analysis
 

2D Truss Analysis

 
Grillage Analysis

 
3D Truss Analysis

3D Frame Analysis
 

2D FE Plate Analysis

Shell Analysis – used to model 
surfaces of any shape in 3d 
structures

Bulding Analysis

Open the previously created 
project fi le  

Open a new project

Table 2.1 - Robot basic modules
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Robot screen layout

GRAPHIC VIEWER / EDITOR

edit, view, tools, preferences

STANDARD toolbar  
– these options are mainly associated with non structural 
items, such as print, save, undo etc.

Layout System 
– designed to 
take the new user 
through a model 
from start to finish, 
while opening pre-
defined windows 
for selected tasks

STRUCTURE MODEL toolbar  
– sections, nodes, members, supports, 
loads etc.

OBJECT 
INSPECTOR 
– management 
of structural 
objects

VIEW MANAGER  
– selection of a work plane; switching between 2D and 3D view  

Figure 3.1 - Robot typical screen layout
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bAsic conFiGuRAtion oF the pRoGRAm
	 Th	 e	two	options,	Preferences	and	Job Preferences,	allowing	the	user	to	set	pro-
gram	parameters	in	the	Robot	system,	are	available	from	the	menu	by	opening	toolbar	
Tools	and	pressing	the	appropriate	icon:

Tools icon

Job Preferences iconPreferences  icon

Figure 4.1 - Tools toolbar

preferences

Th	 e	Preferences	dialog	box	presented	below	is	used	to	defi	ne	basic	parameters	
in	the	program:

REGIONAL 
SETTINGS 
adjust the 
databases 
(profi les, 
materials), 
units and 
codes to the 
standards of 
a country

Robot is a multilingual program – the user can independently set different 
languages for input and printout, if desired

Figure 4.2 - Preferences menu
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The most regularly used options are:

languages - selection of regional settings (definition of the country whose codes 
materials and regulations - e.g. code combination regulations - will be used dur-
ing the design process, calculations and structure design) and working and print-
out language
general parameters (saving parameters, number of recently used structures, 
sound on/off etc.)
display parameters (colors and fonts for screen components)
toolbar and menu (menu type and the type of toolbars)
printout parameters (colors and fonts for printouts, scale and symbols, 	
line thickness)
protection parameters (protection, authorization) - for changing 	
the system protection 
COM interface - presentation of the registered additional programs/modules

Job Preferences

	 The Job Preferences dialog box, presented below, allows you to define general 
program parameters to be used in a given project:

Figure 4.3 - Job Preferences menu

The most important functions are:










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number units and formats (dimensions, forces, possibility of unit edition)
materials (selection of material set, according to the country and the possibility 
of creating user-defined material)
section database (selection of the appropriate database with member sections)
structure analysis parameters (selection of the static analysis method and defini-
tion of basic parameters for dynamic and non-linear analysis; selection of analy-
sis types, possibility of saving results for seismic analysis – combination of seis-
mic cases)
parameters for generation of surface finite element meshes for plates and shells

Navigation techniques
	 In the Robot software, various mechanisms have been introduced to make struc-
ture definition simple and more efficient. According to the type of operation performed, 
the mouse cursor changes its shape to:

“hand” – a selection mode for highlighting entities
“cross pointer” - during node and bar definition, to define precise points e.g. start 
and end points of members
shape of the appropriate feature e.g. when adding sections the cursor is in shape 
of an I section, when adding supports a support icon appears etc. 

The cursor operation in a viewer by means of the third mouse button (or wheel) is 
identical to that in the AutoCAD® program. The following cursor support modes 	
are available:   

wheel rotation – zoom in / out
wheel rotation +  Ctrl key – horizontal pan 
wheel rotation +  Shift key – vertical pan 
pressing the third button - pan
double-click with the third button – initial view 













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The user should take note of the work capabilities in 3D views when the menu option 
Dynamic View (View → Dynamic View → Dynamic View) is switched on. 3D viewing 
enables work in one of five modes:

four simple modes: 3D rotation, 2D rotation, zoom and pan
one multi-function mode

The user may switch from one work mode to another by selecting an appropriate option 
in the View / Dynamic View menu, on the View toolbar and in the context menu. After 
choosing a work mode, the mouse cursor movement (with mouse left button pressed) 
brings about the relevant change in the 3D view: 

3D Rotation – rotates a structure in all planes 
2D Rotation - rotates a structure in the plane parallel to the screen plane 
Zoom – movement down the view – zooming in / zooming out a structure to / 
from the screen plane 
Pan – movement in the view plane (structure shift with respect to the 	
screen center)

The multi-function mode (Rotation / Zoom / Pan) enables work using all the modes 
at the same time. The viewer of 3D view is divided into quarters and each of them is 
ascribed one of the modes: 

top left: 3D rotation top right: pan

bottom left: zoom bottom right: 2D rotation

Table 5.1 - Cursor modes

Once the cursor is positioned in the relevant quarter of the screen, the cursor shape 
changes (see the icons above). 












10 METHODS OF WORKING WITH ROBOT INTERFACE | System menu

Autodesk Robot Structural Analysis - Getting Started Guide

	 Navigation tool (ViewCube) is also available in the program. ViewCube is a 3D 
interactive tool that lets you reorient a view and set the current orientation of a struc-
ture model. Clicking a predefined face, edge or corner on the ViewCube, you can re-
orient the view of a model. Moreover, clicking and dragging the ViewCube lets you 
reorient the model to different directions. Access the ViewCube option by selecting 	
the View > ViewCube - Properties.

Figure 5.1 - ViewCube

The ViewCube also uses the compass to indicate a direction from which you view a 
model. To change the viewpoint of a model, click a selected direction on the compass 
(N, S, E, W). You can show or hide the compass from the ViewCube context menu after 
you right-click on the ViewCube and select the Show compass option.

Methods of working with  
Robot interface
	 There are two methods to work with Robot - by using System Menu to entering 
data, or special Layout System.

System menu

	 The system menu consists of two parts: a text menu and toolbars with appropriate 
icons. They can be used interchangeably, according to the users’ needs and preferences. 
Both are displayed in the same way - as a horizontal bar at the top of the screen (ad-
ditionally, for some layouts in the Robot system, another toolbar with most frequently 
used icons is displayed on the right side of the screen).
Basic options available within the modules are accessible both from the text menu and 
the toolbar. 
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Th	 ough	contents	of	the	text	menu	and	toolbars	for	successive	modules	vary,	the	main	
options	are	always	available	regardless	of	which	module	is	active.	
Th	 e	fi	gure	below	illustrates	both	types	of	menus	(the	main	menu	that	appears	once	the	
Start	layout	is	selected	is	shown	as	an	example):	

STRUCTURE 
MODEL bar 
- additional 
side toolbar 
with most 
frequently 
used icons 

SySTEM MENU – text menu 
& standard toolbar

	
Figure 6.1 - System menu

Options	available	in	the	text	menu	are	grouped	as	follows:

F�le menu

FILE MENU – contains options for: 
File management (New, Open, Save etc.)
Calculation notes and drawing printouts 
(Screen Capture..., Printout Composi-
tion... etc.), a list of information about 
project and a list of recently open fi les




Figure 6.2 - File menu window

ed�t menu

Figure 6.3 - Edit menu window

EDIT MENU – contains options for: 
Elements edition (Undo, Redo, Cut, 
Copy etc.)
Selection (Select...,Select All)
Selection using fi lters (Select Special)
Model modifi cation (Edit, Complex 
Edit..., Divide, Intersect etc.)






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View menu

VIEW MENU – contains options for: 
2D/3D view management of a structure’s 
model (Dynamic View, Zoom, Pan etc, Work 
in 3D)
Structure attributes to be presented on the 
screen (Display); definition of grid parame-
ters (Grid)
Selection of tables with data or results 
(Tables) and saving defined views of a stru-
cture (History)







Figure 6.4 - View menu window

Geometry menu

GEOMETRY MENU - contains options to: 
Select or modify a type of a structure
Define a model construction axis (Axis Definition)
Define structural data - nodes, bars, panels and 
auxiliary objects
Define materials
Define bar profiles and their orientation and 
direction of local coordinate system
Define supports and many other structural items










Figure 6.5 - Geometry menu window

Loads menu

LOADS MENU – contains options to define load 
cases and combinations

Figure 6.6 - Loads menu window
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Analysis menu

ANALYSIS MENU – contains options to: 
Start the calculation process
Change from linear to non linear, P-Delta 
or buckling
Set up dynamic analyses
Design concrete beams, columns and 
surfaces







Figure 6.7 - Analysis menu window

Results menu

RESULTS MENU – contains options to:
Display beam results graphically
Display detailed results for beams graphi-
cally
Display results for surfaces
Display tables that easily be edited, sorted, 
filtered, exported to MS Excel® etc.







Figure 6.8 - Results menu window

Tools menu

Figure 6.9 - Tools menu window

TOOLS MENU – contains differ-
ent types of configuration options  
(Preferences, Job Preferences…) 
and possibility to define user’s in-
terface, menu, shortcuts  and form 
of calculation notes
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Window menu

WINDOW MENU – offers options to ma-
nage and arrange the graphic windows 
and an option to activate/deactivate the 
“Object Inspector”

Figure 6.10 - Window menu

Help menu

HELP MENU – contains help options and 
various product information items

Figure 6.11 - Help menu window

Layout System

	 The second method of work with Robot is by using the special layout  system.

Robot has been equipped with a layout mechanism that simplifies the design process. 
The layouts in Robot are specially designed systems of dialog boxes, viewers and tables 
that are used to perform specific defined operations. 

Layouts available in Robot were created to make consecutive operations leading to 
defining, calculating, and designing the structure easier – the layouts guide the user 
through the process from model generation to results.
In order to make the system as easy to use as possible, each layout has its own predefined 
set of windows which are automatically opened on entering the layout and closed 	
on exit.
Layouts are available from the selection list found in the right, upper corner of the 
screen: 
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SySTEM LAyOUT SELECTION WINDOW 
A list of standard layouts available in Robot. 
This example shows the layouts for a shell structure and 
the layouis vary depending on the structure type

Figure 6.12 - System layout selection window

Th	 e	layout	order	and	arrangement	follows	a	chronological	process,	starting	from	defi	n-
ing	nodes,	beams,	then	supports,	sections	etc.

RESULTS 
Contains layouts showing beam results, maps on surfaces 
etc.

DEFINITION OF STRUCTURE MODEL 
Contains layouts relating to the geometry and basic defi ni-
tion of a structural model, such as supports, sections etc.

DESIGN
Contains layouts relating to steel and concrete design, slab 
design etc.

Figure 6.13 - System layout selection window - chronological layout order

A	typical	 layout	 for	nodes	 is	shown	–	note	 that	each	window	cannot	be	closed	until	
a	new	layout	is	selected.
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Dialog boxes to show entered data. It is also 
possible to enter data manually in this screen 
or to paste from programs such as MS Excel®

STRUCTURE MODEL toolbar – this (as in other 
layouts) contains data relating to structural enti-
ties, but limited to the type of data that is appropri-
ate to node definition

Layout selection pull down menu 
– in this case layout  Nodes is selected 

graphic viewer / editor

Figure 6.14 - Typical layout for nodes

However it is not necessary to define the structure according to the layout order. This 
may be done in any order chosen by the user. The layout system was introduced in such 
a way that Robot structure definition is intuitive and efficient. 

	 All Robot operations may be performed without using the defined layouts but by 
using system menu instead or also taking advantage of both methods (simultaneously) 
according to the user’s needs and preferences. 
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Entering the structural analysis data
There are 3 ways to enter data: 

By entering data using the appropriate text dialog box or direct in a table (or 
pasted from MS Excel®)

By entering data in the Robot GUI – using tools for graphic structure definition 
- i.e. snap grids or structural axes. 

Examples of data entering using the System Layout mechanism (for Bars and 
Loads options) are presented below:

1.

2.
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GRAPHIC VIEWER/EDITOR allows 
the user to enter and view data Dialog box to load cases defi nition 

Toolbar with load tools (including 
advanced options such as soil loading, 
vehicle loading etc.)

Dialog box to defi ne different types of 
loads (node, beam, surface, self-weight)

Data concerning defi ned load cases (case, 
load type etc.) in tabular form

Figure 7.1 - Examples of loads data entering with System Layout mechanism

The updating of data is dynamic – tables refl ect graphics and vice versa at all times. 

NOTE:

By	entering	data	in	another	application	and	importing	into	Robot	-	several	fi	le	
formats	are	supported	including:

DXF,	DWG,	IFC,	SDNF	(steel	detailing	neutral	fi	le),	CIS/2.	A	dynamic	 link	to	
and	from	Revit®	Structure	also	provides	bi-directional	integration.

As	the	preparation	of	the	structural	model	progresses,	the	user	can	control	ex-
actly	what	is	seen	on	the	screen	by	using	the	Display	settings	(it	is	available	by	

3.
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pressing  icon from context menu or direct from the bottom, right corner on 
the Robot screen): 

DISPLAY allows the user 
to switch on and off a wide 
selection of items, including 
node and members numbers, 
section shapes, supports, FE 
mesh and also sets up hidden 
line and render options. 
A wide range of customization 
options allows to the user 
to define a view of structure 
as required exactly to user’s 
preferences.

Figure 7.2 - Display window

After defining the model data, the user now proceeds to the analysis stage.
However, prior to this stage, the model must be “discretized” into finite elements. 
Robot has wide ranging capabilities for “automeshing” the structure and meshing is 
generally a very fast process for even the largest of models. Some of the “meshing pa-
rameters are shown below:

Mesh refining options allow 
the user to easily refine the mesh in 
user selected areas.

Automeshing parameters can mesh all or part of the 
structure and also define mesh density and meshing type

Figure 7.3 - FE Mesh Generation toolbar

Example of structure with meshed panels is shown below: 
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Figure 7.4 - Example of meshing 

AnAlyZinG the stRuctuRe
	 Structural	analysis	can	be	started	by	selecting	one	of	the	two	“calculation”	buttons	
in	the	horizontal	toolbar.	

Figure 8.1 - Calculation icons
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Th	 e	icon	on	the	left		side	starts	the	calculation	process.	Th	 e	second	icon	is	used	to	set	dif-
ferent	analysis	parameters.	Th	 is	option	allows	the	user	to	change	specifi	c	analysis	types	
from	linear	to	non	linear	or	to	set	up	dynamic	analysis.

Figure 8.2 - Changing analysis parameters

As	a	default,	all	analysis	is	set	as	“linear	static”,	unless	the	user	has	included	some	mem-
bers	or	parameters	such	as	cables,	tension	only,	hinges	etc.	In	such	a	case	the	analysis	
type	is	automatically	changed	to	“non	linear”	and	Robot	will	apply	the	loads	incremen-
tally	to	ensure	the	true	structural	equilibrium	and	a	fi	nal	exact	geometry	is	reached.	
Robot	has	many	non	linear	parameters	that	the	user	can	set	in	the	case	of	non	conver-
gence	of	analysis	data,	including	the	options	to	set	full	or	modifi	ed	Newton-Raphson	
and	“step	halving”.	In	addition	to	general	non	linear	calculations,	the	user	can	also	set	
the	following	analysis	options:

P-Delta	
Modal
Seismic	(to	codes	such	as	IBC,	UBC,	EC	etc.)
Spectral	response
Time	history
Buckling







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Results pReVieW
Th	 e	Results	Layout	shows	a	wide	range	of	analysis	results	presentation.

All of results preview options are also available through the RESULTS pull-down menu.
NOTE:

User can view results of calculations by selecting 
the results layout, where a set of submenus for 
particular results then appears 

Figure 9.1 - Results type selection from results layout

Results	can	be	split	into	various	categories,	each	having	their	own	characteristics.

Graph�cal results for beams

(graphical	 results	 for	 individual	 beams,	 or	 selection	 of	 beams,	 or	 groups	 of	 beams	
presentation	-	bending		moment,	shear,	stress,	defl	ection	animation	of	results	in	.avi	
format	etc.)
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Dialog box selects type of result to be displayedGraphical presentation of results as diagrams 
in graphic viewer/editor

Side toolbar shows additional results of structural 
analysis in tabular form, graphical form, plus links to 
design modules

Tables of results – can easily be con-
verted to MS Excel® format by clicking 
right hand mouse 

Figure 9.2 - Results in the diagrams form

There is also easy acces to calculation results for single bars. In context menu of the bar  
(right mouse click on the element, then select Object Properties option) user can see 
diagrams and values for selected quantity of internal forces. 
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A right mouse click on any bar 
displays its properties and results (if 
analysis has been carried out)

Figure 9.3 - Calculation results for single bar

Graphical results for surfaces

(graphical results for surfaces, contour maps for bending, deflection, stress, animations; 
”reduced results” showing global forces in surface cuts, including direct reduced results 
for cores and stiff diaphragms)
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Graphical presentation of result maps in 
graphic viewer/editor Dialog box to select type of map to display

Side toolbar shows additional results of structural 
analysis in tabular form, graphical form, plus links 
to design modules

Figure 9.4 - Results in the maps form
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Tabular results

Tables can easily be edited, enveloping results, 
setting limits, filtering data by load case etc.

Dialog box used to define contents of the 
table. It is available from the menu activated 
by pressing the right mouse button when the 
cursor is located in the table, and selecting 
TABLE COLUMNS

Figure 9.5 - Tabular results

Robot tables can be easily transferred to MS Excel® by pressing the right hand mouse 
button.
Inside Robot, the tables can be manipulated in many ways, in the same way as input 
tables:

filtering data for specific load cases, members or groups of members
filtering data inside or outside user defined limits showing global maxima and 
minima for selected members, nodes or surfaces



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RepoRts And pRintout composition 
	 Robot	has	a	built	in	“report	generator”	which	permits	the	user	to	create	a	user	
defi	ned	printout	for	a	Project.	
Th	 ere	are	two	options	on	the	menu	bar	-	“Printout	Composition”	and	“Screen	Capture”	
which	help	to	prepare	the	fi	nal	calculations	notes,	tables	and	graphic	printouts.

Tables can easily be edited, enveloping results, set-
ting limits, fi ltering data by load case etc.

Dialog box used to defi ne contents of the table - it is 
available from the menu activated by pressing the 
right mouse button when the cursor is located in 
the table, and selecting TABLE COLUMNS

Figure 10.1  - Printout Composition and Screen Capture icons

Th	 e	Standard	tab	lists	a	set	of	predefi	ned	options	for	printout,	which	can	be	mixed	with	
screen	captures	to	the	user’s	requirements.

List of fi nal printout, show-
ing order of data to be 
printed - the dashed red 
line indicates a page break 
between each item

Predefi ned list of printout components 

Various method of saving 
the report – in .doc, html 
and sxw formats 

Figure 10.2 - Printout composition
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	 A key feature of Robot is that all of the data in the program is saved in a com-
mon binary file – this data includes input, output, design plus also printout data. When 
structural data is altered or amended the output and printout (tables and graphics) are 
automatically updated on re-analysis to reflect the new results of the analysis. This is 
particularly useful when considering a schematic design or “sensitivity study” since the 
printout is automatically updated at every analysis step to reflect the current structural 
configuration.

Advanced analysis and design
	 Following analysis of the structure, the user may wish to take advantage of many 
of the additional features – such as:

Steel design
Concrete design for beams, columns, floors
Advanced analysis – P-Delta, dynamic etc.

These items are beyond the scope of this “Getting Started Manual” and are covered in 
more depth in the help for Robot.




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List of shortcuts
In order to	 Press  
select all Ctrl + A
copy a text or a drawing Ctrl + C
open a new project Ctrl + N
open an existing project Ctrl + O
start printing Ctrl + P
save the current project Ctrl + S
cut a text or a drawing Ctrl + X
repeat the last operation Ctrl + Y
paste a text or a drawing Ctrl + V
undo the last operation Ctrl + Z
display the 3D view of a structure (3D XYZ) Ctrl + Alt + 0
project a structure on XZ plane Ctrl + Alt + 1
project a structure on XY plane Ctrl + Alt + 2
project a structure on YZ plane Ctrl + Alt + 3
zoom in the structure view on screen Ctrl + Alt + A
display the initial view of the structure (defined by the initial an-
gles and scale)

Ctrl + Alt + D

“exploded” view of structure elements (on/off) Ctrl + Alt + E
zoom window Ctrl + Alt + L
turn on/off section drawing display Ctrl + Alt + P
screen capture Ctrl + Alt + Q
zoom out structure view on screen Ctrl + Alt + R
turn on/off section symbol display Ctrl + Alt + S
rotate continuously around the X axis Ctrl + Alt + X
rotate continuously around the Y axis Ctrl + Alt + Y
rotate continuously around the Z axis Ctrl + Alt + Z
delete a text or a drawing Del
call Robot Help system for the active option in the active dialog 
box 

F1

call text editor F9
reduce structure attributes (supports, numbers of nodes, bars, 
loads) presented on screen 

PgDn

enlarge structure attributes (supports, numbers of nodes, bars, 
loads) presented on screen

PgUp





3d FRAme stRuctuRe

Synopsis:

Th	 e	purpose	of	this	example	is	to	show	the	ease	of	defi	nition,	analysis	and	report	
generation	for	a	simple	steel	3D	frame	in	Robot.
For	 this	 example,	 it	 is	 assumed	 that	 Autodesk	 Robot	 Structural	 Analysis	 2010	 is	 in-
stalled	on	the	PC.
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Configuration of the program

	 Following installation of Robot, the user may configure the working parameters 
or “Preferences”. To do this:

Start the Robot program (click the appropriate icon or select the command from 
the taskbar). 

On the opening window, displayed on the screen click the last but one icon 

 in the first row (Frame 3D Design). Other options are for 2d and 3d 
frames, models with surfaces such as walls and floors, access to stand alone de-
sign modules etc.

Select Tools > Preferences from the text menu or click on the  , then  
a

  
icons on the toolbars to open the “Preferences” dialog box. Preferences allow the 
user to set up working and printout languages, fonts, colors etc.

Figure 1 - Regional settings in Preferences dialog box.

Select the first preferences option - Languages (tree on the left part of the win-
dow), then as the Regional settings choose United States.

1.

2.

3.

4.
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Regional settings set the default databases (profiles, materials), units and codes to the stan-
dards of a country. In the example above, we have chosen American section database (AISC) 
and metric data units: [m],[cm], [kN].

NOTE:

Click Accept to close the window.

You can check active units in right, bottom corner of the screen. In this example should be 
the display: [m] [kN] [Deg].

NOTE:

Model Definition

Bars definition (frame 2D)

In this step, you create frame members consisting of 2 columns and a beam.   

Click  icon (right side of the screen) to open the Bars dialog box. 

Set Bar type: as Column – whatever is selected is not important for analysis, but 
affects the design parameters for subsequent member design, such a buckling 
length, position of restraint etc.

Define Section: as W14x211.

5.

1.

2.

3.
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If the W14x211 section is not available on the list, you should click the (…) button located 
beside the Section field and add this section from the database. In opened New section 
dialog box, in Section selection field for Database: AISC – choose Family: W then Section: 
W14x211. Click Add and Close the box.

NOTE:

There are many extra options that may be entered for fabricated mem-
bers, tapering sections and also for beams that the user wants to define 
as able to exhibit plasticity.

INFO

Enter the following points in the Beginning and End field:
to define first column of frame: (0;0;0) and (0;0;3) Add
to define second column: (7;0;0) and (7;0;3) Add

Set Bar type: as Beam.

Define Section: as W14x211.

To define a beam in the structure, enter the following points in the Beginning 
and End field: (0;0;3) and (7;0;3) Add.

Close the Section window.

Supports definition

In this step, you create supports for the frame structure.   

Click  icon (right side of the screen) to open the Supports dialog box.

To choose structure nodes, the user can either select a support type from the list 
and then select a node or nodes by click or window, or the user can directly input 

4.
-
-

5.

6.

7.

8.

1.

2.
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MODEL DEFINITION | 2-bay frame definition

the node number and apply. To make a window selection, press the right hand 
mouse key and then the Select menu option and window around the nodes to be 
supported and click inside the selection box.

From the Supports dialog box select the Fixed support icon.

Click Apply.

2-bay frame definition

In this step, we create a 2 bay frame by mirroring the existing frame.

Select all bars (by window or CTRL+A) and mirror them Edit > Edit > Vertical 
Mirror by vertical axis of the right column (just click on this axis). 

There are many editing possibilities: copy, move, divide, intersect,  
rotation etc. to make modeling of structure easier and more effective.

INFO

Click  icon (top of the screen) to show the whole structure.

To display bars and nodes numbers click  icon (bottom left corner of the 
screen) then in the Display dialog box tick on Favorites > Node numbers and 
Favorites > Bar description > Bar numbers.

Click Apply and OK.

Click  ,   icon at the bottom of the screen to display supports symbol and 
sections shape.

The frame should appear as below:

3.

4.

1.

2.

3.

4.

5.

6.
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Figure 2 - Frame with supports and sections shape view.

load case defi n�t�on

In	this	step,	you	defi	ne	load	cases	(their	number,	nature	and	description).

Click	 	icon	(right	side	of	the	screen)	to	open	the	Load Types	dialog	box.

Click	New	to	defi	ne	a dead load	(self-weight)	with	a	standard	name	DL1.

The self-weight load is automatically applied in the fi rst row to all structure bars (in the “Z” 
direction).

NOTE:

1.

2.
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Choose in the Nature field live, then New to define a live load with a standard 
name LL1. We have now defined 2 load cases.

Choose in the Nature field wind, then New to define a wind load with a stan-
dard name WIND1 (in the same way define WIND2). We have now defined 	
4 load cases.

Close the dialog box.

Loads definition for particular load cases

In this step, you define loads for each created load case.

To define loads for LL1 case select the 2nd load case in the list of defined 	
cases field: 

Figure 3 - Load case LL1 selection.

Click  icon (right side of the screen) to open the Load Definition dialog 
box.

On the Bar tab click  icon to open the Uniform load dialog box, then type 
value of load -45.0 in the pZ field, click Add (Uniform load dialog box is auto-
matically closed). 

Select beam span (no.3) – indicate them or just type 3 in field Apply to.

Click Apply.

3.

4.

5.

1.

2.

3.

4.

5.
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On the Bar tab click  icon to open Trapezoidal load dialog box, then type 
values of loads and coordinates as shown below, click Add and close the box. This 
generates a varying load on the beam.

Figure 4 - Trapezoidal load definition.

Select beam span (no.5) – indicate the beam or just type 5 in field Apply to.

Click Apply and close Load Definition dialog box.

To define loads for WIND1 case select the 3rd load case in the list of defined cases field.  

On the Node tab in Load Definition dialog box click  icon to open Nodal 
Force dialog box, then type value of load 9.0 in the FX field, click Add and close 
the box.

Select the upper node of the left column (no.2) – graphically or by cross-window 
or just type 2 in field Apply to.

6.

7.

8.

9.

10.

11.
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Click Apply and close Load Definition dialog box.

To define loads for WIND2 case select the 4th load case in the list of defined cases field. 

On the Bar tab in Load Definition dialog box click  icon to open Uniform 
load dialog box, then type value of load -20.0 in the pX field (pY=0; pZ=0), click 
Add and close the box.

Select the right column (no.4) – indicate it or just type 4 in field Apply to.

Click Apply and close Load Definition dialog box.

Close the Load Types dialog box.

Click ,  icons at the bottom of the screen to turn displaying loads sym-
bols and loads values description on.

The loads can also be seen in tabular form – click  Tables icon (right side 
of the screen) then tick Loads on or select View > Tables > Loads command 	
(see below). 

All tables in Robot can be exported to MS Excel® by simply clicking the 
right hand mouse button in the table.

INFO

	
Figure 5 - Load cases data in tabular form.

In the list of defined load cases choose the load case for which the loads will be 
displayed:

12.

13.

14.

15.

16.

17.

18.

19.

20.
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All	defi	ned	loads	cases	will	be	displayed	together	(as	shown	below):

Figure 6 - All defi ned load cases view.

copy�ng ex�st�ng frame

In	this	step,	we	copy	the	2D	frame	to	generate	3D	structure.	When	we	copy	that	frame,	
all	attributes	attached	to	it	(loads,	sections,	supports	etc.)	are	also	copied:

Click	 	 icon	 (top	 of	 the	 screen)	 to	 open	 the	 View	 dialog	 box,	 then	 	
or	choose	View > Work in 3D > 3D	xyz	from	the	menu	to	select	the	isometric	
structure	view.	

21.

1.
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Click CTRL+A to select all of the structure.

 Edit then  Translation – or select the Edit > Edit > Translate option 
from the pull-down menu to open the Translation dialog box.  

In Translation vector field type coordinates as shown below (be sure that in Edit 
mode option Copy instead of Move is checked on and Number of repetitions is 1).

Figure 7 - Copy frame parameters definition.

Click Execute – second frame should be display on the screen.

Close the Translation dialog box.

Click  icon to show the whole structure. The structure should look as 
shown below:

2.

3.

4.

5.

6.

7.
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Figure 8 - 3D View of copied frame.

defi n�t�on of lateral beam

In	this	step,	you	defi	ne	beams	to	join	the	selected	frames	together:

Click	 	icon	(right	side	of	the	screen)	to	open	the	Bars	dialog	box.

In	Bars	dialog	box	set	Bar type:	as	Beam.

Defi	ne	Section:	as	W12x190.

1.

2.

3.
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If the W12x190 section is not available on the list, one should click the (…) button located 
beside the Section field and add this section to the active section list in the New section 
dialog box.

NOTE:

In the fields Beginning and End type coordinates (as shown below) or simply select 
beginning field and then graphically draw the start and end points of the member.

Figure 9 - Bars definition.

If entered by coordinates, Click Add and close Bars dialog box.

Definition of cross bracings

 Sections then  New section definition – or select the Geometry > 
Properties > Sections > New section definition option from the menu to open 
the New Section dialog box:

4.

5.

1.
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Figure 10 - New section definition.

Select Section (L4x4x0.25) from American section Database (AISC) as shown above.

Click Add - new section type will be added to the active Sections list.

Close New section definition and Sections dialog boxes.

Click  icon (right side of the screen) to open the Bars dialog box.

In Bars dialog box set Bar type: as Simple bar.

Define Section: as L4x4x0.25.

In the fields Beginning and End type coordinates: 	
(14;0;3) (14;8;0) click Add then (14;8;3) (14;0;0) and press Add. Or draw in the 
GUI.

Close Bars dialog box.

2.

3.

4.

5.

6.

7.

8.

9.
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Copying defined bars (lateral beam and bracings)

In this step, you copy the recently defined bars to finish the definition of the frame:

Select the three recently defined bars – just indicate them (bars no.11,12,13)  - 
multiple selections can be made by holding down CTRL key.

 Edit then  Translation – or select the Edit > Edit > Translate option 
from the menu to open the Translation dialog box.  

In Translation vector field type coordinates: (-7;0;0) or select 2 points on the 
screen that represent the translation vector such as the bottom of 2 columns (be 
sure that in Edit mode option Copy is checked on) and in Number of repeti-
tions type 2.

If entered by coordinate, click Execute button then close Translation and Edit 
dialog boxes.

The structure should look as shown below:

1.

2.

3.

4.

5.
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Figure 11 - Complete 3D frame structure view.

stRuctuRe AnAlysis
Here	we	start	the	analysis	process,	but	fi	rstly	we	will	tell	Robot	to	make	automatic	

code	combinations	(from	any	one	of	the		list	of	Codes	in	Job	Preferences):

Select	Loads > Automatic Combinations…		option	from	the	menu	to	open	the	
Load Case Code Combinations	dialog	box.	Select	the	Full automatic combina-
tions	option.	Th	 e	program	will	now	automatically	assign	a	number	of	combina-
tions	to	fi	nd	the	most	onerous	load	combination.

Click	OK	button	–	automatic	calculation	of	code	combinations	will	be	done.

1.

2.
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Results Preview |  Displaying beam results graphically

 Calculations – click this icon or select the Analysis > Calculations option 
from the menu to start calculation process. 

Once the calculations are completed the information: Results (FEM): Available 
should be displayed at the top of the screen.

A key strength of Robot is the possibility to define a wide range of analysis types (linear 
static, non-linear geometry and material, buckling, modal analysis, harmonic analysis, 
seismic analysis, time history analysis etc.) 
If the user wishes to see these possibilities, he/she may look in the Analysis > Analysis 
Types > Change analysis type  pull down menu.

However, for this simple example, we will just assume the default linear static type of analysis.

NOTE:

Results Preview

Displaying beam results graphically

In this step, we display My bending moment on bars for selected load case:

Click  icon at the bottom of the screen to switch off the section shape and 
simply display a “stick model” for all members.

In the list of defined load cases choose the desired load case to display:

Select Results > Diagrams for Bars…  from the menu to open 
Diagrams dialog box.

3.

4.

1.

2.

3.
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On	the NTM	tab	check My Moment	(this	shows	the	major	axis	bending	moment	
on	the	beams),	then	click	Normalize	button	(to	auto	scale)	and	click Apply	to	
display	bending	moments	diagrams	for	all	beams:	

Figure 12 - Diagram of bending moment.

To display numerical values of internal forces in the d�agrams dialog box, click on tab pa-
rameters, d�agram descr�pt�on tick labels and Apply.

NOTE:

In	a	similar	way,	diagrams	that	exhibit	other	values	available	from	the	Diagrams 
dialog	box	can	be	viewed.

Tick	off		My	Moment	and	Apply.

4.

5.

6.
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RESULTS PREVIEW |  Displaying results on bars in tabular form

d�splay�ng results on bars �n tabular form

In	this	step,	you	display	internal	forces	for	bars	for	particular	load	cases	and	combinations:

Select	View > Tables	to	open	Tables: Data and Results	dialog	box,	then	tick	on		
Forces	and OK	to	view	all	information	about	internal	forces	(Values,	Envelope,	
Global	extremes).

Figure 13 - Example of results presentation in tabular form.

In a similar way, tables that exhibit other values available from the tables: data and Results 
dialog box can be viewed.
The tables can easily be exported to MS Excel® (by right hand mouse click) and tables can 
also be sorted by choosing certain load cases, member types etc. Advanced users can also 
defi ne “groups” and display results only for these groups. Column values may be placed in 
order by simply clicking the appropriate column header, for example FX.

NOTE:

1.
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Close the Forces table.

Click  icon at the bottom of the screen to turn sections shape back on.

Stress analysis

In this step, we learn how to obtain and analyze stress diagrams and maps for the entire 
bar structure:

Switch layout to Stress Analysis - Structure. To do this go to the Robot layouts 
selection combo-box (right top screen corner)

Click the Results option and later the Stress Analysis - Structure.

Figure 14 - Layout selection pull-down menu (stress analysis selection).

Now the screen is divided into three main parts:
the graphic viewer where the structure is displayed,
the Stress Analysis -Structure  dialog box – to managing stress analysis. This dialog 
box is used for selecting stresses and determining the manner of stress graphical 
presentation
the Stress Analysis -Structure  results table to view actual values of stresses for bars






NOTE:

2.

3.

1.

2.
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RESULTS PREVIEW |  Stress analysis

In	the	list	of	defi	ned	load	cases	choose	the	load	case	for	which	the	results	will	be	
displayed:	

On	the	Diagrams tab	located	in	the	Stress Analysis - Structure	dialog	box	select	the	
Max	option	from	the	Mises	fi	eld,	then	Apply	(the	result	should	look	as	shown	below):

Figure 15 - Stress analysis in diagram form.

This dialog box allows selecting a user-defi ned stress and a set of basic stress types: nor-
mal, tangent, Mises and Tresca. 

NOTE:

3.

4.
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On the Stress Analysis - Structure dialog box tick off the Max option from the 
Mises  field, then Apply.

On the Maps - Deformation tab located in the Stress Analysis - Structure dialog 
box tick the Deformation option on, then Apply.

 Stress Analysis for structure - maps - click this icon or select the Results 
>  Stress Analysis > Stress Maps option from the menu to view the structure 
together with section shapes and accurate detailed stress maps on these sections 
(as shown in the figure below).

Figure 16 - Stress analysis in maps form.

The size of member sections in stress maps is by default greater than the real size of 
member sections so that the stress maps presented for these sections are more readable.  
Real proportions between the member length and dimensions of the member cross section 
can be obtained after pressing the Home key on the keyboard. These proportions can be 
modified using the following keys on the keyboard: PgUp and PgDn.

NOTE:

Close the Stress Analysis – structure (3D View) window.

5.

6.

7.

8.



54

Autodesk Robot Structural Analysis - Getting Started Guide

Preparation of printouts | “Capturing” views and data

Preparation of printouts
Robot has a powerful built in report generator that allows the user to compile and 

manipulate standard data, plus screen captures of graphical and tabular data.

“Capturing” views and data for the calculation note

In layouts selection combo-box (right top screen corner) switch to Start layout. 
The picture of the model is shown on the screen with no other windows. Let’s as-
sume we want to print this image.

Click  icon (top of the screen on the standard toolbar) to open the Screen 
Capture dialog box.

Figure 17 - Screen capture parameters definition.

In the above dialog box change Screen capture orientation to Horizontal and 
type name of the picture as a Structure View. 

1.

2.

3.
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The Screen capture update enables the user to choose automatic update of screenshots 
– this means that the images and data are automatically updated should the structure be 
changed. Alternatively, they can be saved in JPG format. 

NOTE:

Click OK to close the box.

In the list of defined load cases choose the 2:LL1 load case. 

Click  icon (top of the screen on the standard toolbar) to open the Screen 
Capture dialog box.

In this dialog box change Screen capture orientation to Horizontal and leave 
name of the picture as a Structure – Cases 2: (LL1). 

Click OK to close the box.

In the same way prepare pictures: Structure – Cases 3: (WIND1) and Structure 
– Cases 4: (WIND2)

Preparing printout composition

Here we prepare the layout of the report:

Click  icon (top of the screen on the standard toolbar) to open the Printout 
Composition - Wizard dialog box.

On the Standard tab, select report components (click them while pressing CTRL 
key)  as shown below:

4.

5.

6.

7.

8.

9.

1.

2.
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Preparation of printouts | Preparing printout composition

Figure 18 - Report components selection.

Click Add to transfer the marked components to the right panel which shows the 
actual layout of the printout.

On the Screen Captures tab select all screenshots.

Click Add to transfer marked components to the right panel. 

Using icons  move particular components to the order shown below: 

3.

4.

5.

6.
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Figure 19 - Screen captures selection.

Printing and exporting the calculation report

In this step, we learn how to print and save the calculation note:

Click Preview to display the report:

	

1.
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Preparation of printouts | Printing and exporting the calculation report

Figure 20 - Report preview.

Before printing of the report, save your project. In this case we save it as “Frame 3D”. 
Thanks to this operation actual information about project will be used to generate the docu-
mentation (i.e. project name on the title page – as shown above). To change this information 
(and many more) later we can use File > Project properties option from the top menu. 

NOTE:

Using buttons  browse each page of the Report.

If you need to make some corrections to the layout or tabular content you can edit them 

directly in this preview window. To do this, you should press icon  (top bar) and double 
click on the appropriate item to be edited. The general Robot window will be open, which al-
lows the user to make changes or corrections. After that press button Return to Preview to 
continue the preview of the calculation report. 

NOTE:

2.
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Click Page setup. The Page and Margins tab allows the user to set various pa-
rameters.

Click Header/footer tab. In this tab you can define the look of the title page, 
header and footer.

Figure 21 - Page setup settings.

Click OK to close the dialog box. 

Close the preview of report printout window.

If desired, In Printout Composition – Wizard dialog box click on Print button 
to print all reports.

To save the calculation note, click on icon  to export the report to .html 

format,  to export to .rtf (MS Word®) format or  to save in .sxw (Open 
Office) format.

3.

4.

5.

6.

7.

8.





Rc And steel miXed stRuctuRe

Synopsis:

Th	 e	 purpose	 of	 this	 example	 is	 to	 show	 the	 ease	 of	 defi	nition,	 analysis	 and	
presentation	 of	 results	 for	 a	 3D	 frame	 and	 shell	 structure	 (mixed	 RC	 and	 steel)	 in	
Robot.
For	this	example,	it	is	assumed	that	Autodesk	Robot	Structural	Analysis	2010	is	installed	
on	the	PC.
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Configuration of the program
	 Following installation of Robot, the user may configure the working parameters 
or “Preferences”. To do this:

Start the Robot program (click the appropriate icon or select the command 
from the taskbar). 

On the opening window, displayed on the screen click the first icon    in 
the first row (Frame 2D Design). Other options are for 3d frames and models 
with surfaces such as walls and floors, access to stand alone design modules etc

Select Tools > Preferences from the text menu or click on the  , then 
a

 
icons on the toolbars to open the Preferences dialog box. Preferences allow the 
user to set up working and printout languages, fonts, colors etc.

Figure 1 - Regional settings in Preferences dialog box.

Select the first preferences option - Languages (tree on the left part of the win-
dow), then as the Regional settings choose United States

1.

2.

3.

4.
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Regional settings set the default databases (profiles, materials), units and codes to the stan-
dards of a country. In the example above, we have chosen American section database (AISC) 
and metric data units: [m],[cm], [kN].

NOTE:

Click Accept  to close the window

You can check active units in right, bottom corner of the screen. In this example should be 
the display: [m] [kN] [Deg].

NOTE:

Model definition

Definition of structural axes

In this step, we define a rectangular axis grid in the Cartesian coordinate system. 

The axes of the structure create an additional grid which can be used to 
define different elements of the structure and select structure compo-
nents. 
The grid intersections form points that facilitate the users work by guiding 
cursor movements during graphical structure definition.

INFO

Press  icon (right side of the Robot screen) or select Geometry > Axis Defi-
nition… from the menu to open the Structural Axis dialog box. 

5.

1.
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On the X tab in the Position field type -1  and press Insert button, in the same 
way enter following axis coordinates as shown below (Figure 2):

Set  Numbering as A B C…

On the Z tab in the Position field type 0 and press Insert button, in the same way 
enter following axis coordinates as shown below (Figure 3):

Set  Numbering as 1 2 3…

	
Figure 2 - Definition of structural axis in X direction.

2.

3.

4.

5.
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Figure 3 - Definition of structural axis in Z direction.

Apply and Close the Structural Axis dialog box.

Defined axes should appear as shown below:

	

6.

7.
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Figure 4 - View of defi ned structural axis.

sect�on defi n�t�on

In	this	step,	we	learn	how	to	add	new	sections	to	the	list	of	available	sections.

Press	 	icon	(right	side	of	the	screen)	or	select	Geometry > Properties > Sec-
tions	from	the	menu	to	open	the	Sections	dialog	box.	

Check	presence	of	the	following	sections:

CR30x30, BR30x60, W8x28, W10x45.

If	the	above	sections	are	not	present	in	the	list	of	available	sections	press	the	New 

section defi nition		 	icon	to	open	New Section	dialog	box.

1.

2.

3.
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In	the	Section	type pull-down	menu	choose	RC Column.

Figure 5 - New RC column defi nition.

Set	30	in	the	b	and	h	fi	eld,	in	the	Label	fi	eld	column	name:	CR30x30	will	be	au-
tomatically	created	and	click	Add	(see	above).

In	the	Section	type	pull-down	menu	choose	RC Beam.

Set 30	in	the	b	and	60	in	the	h	fi	eld,	in	the	Label	fi	eld	column	name:	BR30x60	
will	be	automatically	created,	then	press	Add.

In	the	Section type	fi	eld	select Steel.

Set	 AISC	 in	 the	 Database	 fi	eld,	 W	 in	 the	 Family	 fi	eld	 and	 W 8X28	 in	 the	
Section fi	eld.

4.

5.

6.

7.

8.

9.
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Figure 6 - New steel section definition.

Press Add to add defined section to the list of the active sections.

As before, set AISC in the Database field, W in the Family field and W 10x45 in 
the Section field.

Press Add, close New Section and Sections dialog boxes.

10.

11.

12.
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Bars definition

In this step, we define a 2D frame using the previously defined sections.

Go to the Robot layouts selection box (right top corner of screen) and switch 
layout to the Bars:

Figure 7 - Bars layout selection.

Go to the Bars dialog box and set: RC Column (Bar Type field), CR30x30 (Sec-
tion field). 

Place the cursor in the Node Coordinates > Beginning field, switch to the graph-
ic viewer and select graphically the beginning and end of the columns by means 
of the coordinates of the intersection point of the defined axes: B1-B2, C1-C2, 
D1-D2 (see below):

1.

2.

3.
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Figure 8 - View of defi ned columns.

Set	the	following	options:	RC Beam	(Bar	Type	fi	eld),	BR30x60	(Section	fi	eld).	

Go	to	the	Node Coordinates > Beginning	and,	as	before,	indicate	the	beginning	
and	end	of	the	beams:	A2-B2, B2-C2, C2-D2, D2-E2	(see	below):

	

4.

5.
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Figure 9 - View of added beams.

Set	the	following	options:	Column	(Bar	Type	fi	eld),	W8x28	(Section	fi	eld).

Go	to	the	Node Coordinates > Beginning	and,	as	before,	indicate	the	beginning	
and	end	of	the	columns:	A2-A3, C2-C5, E2-E3	(see	below):

	

6.

7.
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Figure 10 - View of added columns on the 2nd  storey .

Set	the	following	options:	Beam	(Bar	Type	fi	eld),	W10x45	(Section	fi	eld).

Go	to	the	Node Coordinates > Beginning	and,	as	before,	indicate	the	beginning	
and	end	of	the	beams:	A3-C5, E3-C4	(see	below):

	

8.

9.
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Figure 11 - Finished 2D frame view .

Press	 ,	 	icons	at	the	bottom	of	the	screen	to	display	supports	symbols	and	
sections	shapes.

Press	 	icon	at	the	bottom	of	the	screen	to	open	the	Display	dialog	box.

Select	the	Bars	option	(left		panel)	and	tick	Symbols	off		(right	panel)	to	turn	off		
display	of	cross	sections.

10.

11.

12.
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Figure 12 - Switch off bars symbols displaying .

Click	Apply	and	OK	 to	close	the	box.	Frame	2D	should	look	as	shown	below:
	 	 	 	 	 	

Figure 13 - 2D frame view with additional attributes - section shapes .

13.
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supports defi n�t�on

In	this	step,	we	create	supports	for	the	frame	structure.			

Go	to	the	Robot	layouts	selection	box	(right	top	screen	corner)	and	switch	layout	
to	Supports.

Go	to	the	Supports	dialog	box	and	select	Fixed	in	the	list	of	supports.

Move	the	cursor	to	the	graphical	view.	Note	that	a	support	symbol	is	shown	that	
will	allow	the	user	to	add	supports	to	discrete	nodes.	To	add	to	all	nodes,	press	
right	 mouse	 button	 and	 “select”	 and	 drag	 window	 round	 the	 nodes	 that	 have	
supports.

Click	inside	“current	selection”	box	and	apply.	
Notice	that	the	supports	are	also	now	shown	in	the	tab.

Figure 14 - Nodes selection to supports defi nition .

1.

2.

3.

4.
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you may also type the relevant supports numbers (1 3 5) into the current select�on fi eld and 
apply.

NOTE:

Defi	ned	frame	with	supports	should	look	as	shown	below:

Figure 15 - Frame with defi ned supports view.

load cases defi n�t�on

In	this	step,	we	defi	ne	names	and	natures	of	all	load	cases.

Go	to	the	Robot	layouts	selection	box	(right	top	screen	corner)	and	switch	layout	
to	the	Loads.

5.

1.
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Figure 16 - Loads layout.

In	the	Load Types	dialog	box	click	New	to	defi	ne	a	dead	load	(self-weight)	with	
a	standard	name	DL1.

The self-weight load is automatically applied – see the table (in the “Z” direction).

NOTE:

Click	New	once	again	to	defi	ne	a	dead	load	with	a	standard	name	DL2.

Choose	in	the	Nature	fi	eld live,	then	New	to	defi	ne	a	live	load	with	a	standard	
name	LL1.

2.

3.

4.
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Click New once again to define a live load with a standard name LL2.

Choose in the Nature field wind, then New to define a wind load with a standard 
name WIND1.

Choose in the Nature field snow, then New to define a snow load with a standard 
name SN1:

Figure 17 - Load types definition.

Definition of loads for predefined load cases

In this step, we define types and values of loads for particular load cases. Each load case 
can have several loads applied within it.

To define loads for DL2 case select the 2nd  load case in the list of defined load 
cases field (see below):  

5.

6.

7.

1.
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Figure 18 - DL2 load type selection.

Press  icon (right side of the screen) to open the Load Definition dialog box.

On the Bar tab press  icon to open Uniform load dialog box, then type value 
of load –10 [kN/m] in the pZ field, click Add and close the box:

Figure 19 - Uniform load definition for DL2 case.

Select beams (no. 4 5 6 7) – indicate them or just type 4to7 in field Apply to and 
click Apply (as before its possible to window them too)

2.

3.

4.
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Press	 	 icon	 at	 the	 bottom	 of	 the	 screen	 to	 turn	 display	 Load value 
descriptions on.

Figure 20 - DL2 load case view.

To	defi	ne	 loads	for	LL1	case	select	 the	3rd load case	 in	the	 list	of	defi	ned	 load	
cases	fi	eld.		

On	the	Bar	tab	press	 	icon	to	open	Bar Force dialog	box,	then	type	value	of	
load	–20 [kN]	in	the	FZ	fi	eld.

On	the	Coordinate fi	eld	leave	x=0,50	value	(defi	ned	force	will	be	applied	halfway	
along	the	member),	click	Add	and	Close	the	box.

5.

6.

7.
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Figure 21 - Bar force definition for LL1 case.

Select beams (no.5) – indicate them or just type 5 in field Apply to and click 
Apply.

9.
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Figure 22 - LL1 load case view.

In	the	same	way	you	may	defi	ne	for	4th:LL2	load	case	bar	force	–30 [kN]	on	the	
half	length	of	the	bar	No.6.

	

10.
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Figure 23 - LL2 load case view.

To	defi	ne	loads	for	WIND1	case	select	the	5th	load	case	in	the	list	of	defi	ned	load	
cases	fi	eld.		

On	the	Bar	 tab	press	 	 icon	to	open	Uniform Load	dialog	box,	 then	type	
value	of	load	–1,5 [kN/m]	in	the	pZ	fi	eld,	tick	Coord.	system	–	Local	on,	then	
click	Add	and	close	the	box.

11.

12.
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Figure 24 - Uniform load definition for WIND1 case.

Select beam (no.1) – indicate them or just type 1 in field Apply to and click 
Apply.

In the same way define uniform loads: -2,50 [kN/m] for bar no. 8 and -3 [kN/m] 
for bar no. 11.

	

13.

14.
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Figure 25 - WIND1 load case view.

To	defi	ne	loads	for	SN1	case	select	the 6th 	 load	case	in	the	list	of	defi	ned	load	
cases	fi	eld.	

On	the	Bar tab	press	 	 icon	to	open	Uniform Load dialog	box,	 then	type	
value	of	 load	–2,50 [kN/m]	 in	 the	pZ	fi	eld,	 tick	Projected load on,	 then	click	
Add	and	close	the	box.

15.

16.
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Figure 26 - Uniform load definition for SN1 case.

Select beams (no.11 and 12) – indicate them or just type 11 12 in field Apply to 
and click Apply.

	

17.
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Figure 27 - SN1 load case view.

Close	the	Load Defi nition	dialog	box.

Go	to	the	Robot	layouts	selection	box	(right	top	screen	corner)	and	switch	layout	
to	Start.

Now,	using	the	existing	2D	frame,	we	defi	ne	a	3D	frame	structure	with	slabs	and	walls.	

18.

19.
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Changing the structure type

So far we have worked in 2D. In this step, we open new module Shell design to enable 
wall and slab definition and work in 3D.

Select Geometry > Structure type from the menu, which opens the window 
presented below:

Figure 28 - Structure type selection window.

Select Shell design icon (the third one from the left in the second row) to change 
structure type from 2D frame to shell. The program prompts you to save your 
work so far.

Definition of additional structural axis

In this step, w define additional structural axes on in the third axis - the Y direction.

Press  icon (right side of the Robot screen) or select Geometry > Axis Defi-
nition… from the menu to open the Structural Axis dialog box. 

Set  Numbering as Define and type in the next field (on the right side) L1.

1.

2.

1.

2.
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On the Y tab in the Position field type 0 and press Insert button, in the same way 
enter following axis coordinates as shown below:

Figure 29 - Definition of structural axis in Y direction.

Press Apply and close the Structural Axis dialog box.

3.

4.
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copy�ng ex�st�ng frame

In	this	step,	we	copy	the	2D	frame	to	generate	a	3D	structure.	When	we	copy	that	frame,	
all	attributes	attached	to	it	(loads,	sections,	supports	etc)	are	also	copied:

Press	 	 icon	 (top	 of	 the	 Robot	 screen)	 to	 open	 the	 View	 dialog	 box,	 then		

	or	choose	View > Work in 3D > 3D xyz	from	the	menu	to	select	the	iso-
metric	structure	view	(see	picture	below):

Figure 30 - 3D view of defi ned frame.

Press	CTRL+A	to	select	all	of	the	structure.

1.

2.
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 Edit then  Translation – press this icons or select the Edit/Edit/Trans-
late option from the menu to open the Translation dialog box.  

In Translation vector type the value to copy in each axis as shown below:

In Edit mode tick option Copy on and Number of repetitions set as 2 (see 
below):

Figure 31 - Copy of the frame - translaction vector definition.

You may define translation vector graphically by indicating the beginning and end of the 
translation vector (in isometric structure view).

NOTE:

Copied frames should look as shown below:

3.

4.

5.

6.
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Figure 32 - Copied frame view.

defi n�t�on of lateral beams

In	this	step,	we	defi	ne	beams	to	join	the	selected	frames	together:

Go	to	the	Robot	layouts	selection	box	(right	top	screen	corner)	and	switch		layout	
to	the	Bars.

Click	 , 	 icons	at	the	bottom	of	the	screen	to	turn	node	and	bars	numbers	
display	off	.

In	Bars	dialog	box	set	Bar type:	as	Beam.

Defi	ne	Section:	as	W8x15.

1.

2.

3.
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If the W8x15 section is not available on the list, you should click the (…) button located beside 
the Section field and add this section from the database. In opened New section dialog box, in 
Section selection field for Database: AISC – choose Family: W then Section: W8x15. Click Add 
and close the box (see below)

NOTE:

Figure 33 - New steel section definition.

Press Add - new section type to be added to the active Sections list.

Close New Section dialog box.

Place the cursor in the Node Coordinates > Beginning field, then switch to the 
graphic viewer and select graphically the beginning and end of the bars by means 
of the coordinates of the intersection point of defined axes:

(E,L1,3) and (E,L2,3)
(E,L2,3) and (E,L3,3)
(C,L1,5) and (C,L2,5)
(C,L2,5) and (C,L3,5)
(A,L1,3) and (A,L2,3)
(A,L2,3) and (A,L3,3)

5.

6.

7.

-
-
-
-
-
-
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Th	 e	structure	with	lateral	tie	beams	should	look	as	shown	below:

Figure 34 - View of structure with lateral tie beams added.

Go	to	the	Robot	layouts	selection	box	(right	top	screen	corner)	and	switch	layout	
to	the	Geometry.

8.
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Definition of slab

In this step, we learn how to define a slab, first we define a contour (shape) of the plate 
then we assign physical properties to it. Firstly, we need to define the elevation of the 
structure that we wish to work on – we do this with a “work plane”.

To set new a work plane press the icon  provided in the bottom left corner 
of the screen which represents the active work plane – a View dialog box will be 
opened.

Press 2D and XY buttons and select “Structure axis 2” 4,00 (m) – as shown 
below. Once these options are selected the structure is set on the XY plane at the 
recently defined Z coordinate (e.g. Z=12); only structure components from this 
plane are displayed.

Figure 35 - New work plane definition (in axis no 2).

Close the View dialog box.

Press  icon (right side of the Robot screen) or select Geometry > Objects > 
Polyline-contour from the menu to open the Polyline-Contour dialog box. 

Indicate required points of the contour in the graphic viewer by cursor as follow: 
(A,L1); (E,L1); (E,L3); (A,L3); (A,L1) – note, always select the start and end point 
to “close”the contour.

1.

2.

3.

4.

5.
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Close	 the	 Polyline-Contour	 dialog	 box,	 the	 defi	ned	 contour	 should	 look	 as	
shown	below:

Figure 36 - Defi ned contour of panel view.

Press	 	 icon	(right	 side	of	 the	Robot	screen)	or	 select	Geometry > Panels	
from	the	menu	to	open	the	Panel	dialog	box.

A surface in Robot is called a “panel”. So if you want to create a slab or 
wall, you must defi ne an appropriate panel.

INFO

  

In	 the	Panel	dialog	box	set	parameters:	Panel	 in	Contour type	fi	eld,	Internal 
point	(Creation	with	fi	eld),	none	(Reinforcement	fi	eld),	TH12_CONCR	(Th	 ick-
ness	fi	eld)	and	Shell	(Model	fi	eld)	-	see	picture	below:

6.

7.

8.
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Figure 37 - Panel definition settings.

In the Reinforcement option you can define a reinforcement type. However this option is 
unavailable in Robot Free, in the Slab design module, in the full commercial version of the 
program, you can perform a complete design process of an RC slab (including calculation of 
provided reinforcement and deflection verification with reinforcement and cracking taken into 
consideration).

NOTE:

To assign the recently defined panel to the selected contour set the cursor in the 
Internal Point field then move it to the graphical viewer and click on a point 
located within the area of the slab.

Close the Panel dialog box.

To set the 3D view of the structure, click the icon  (bottom left corner of 
the screen), then in View dialog box press 3D button and close the box.

9.

10.

11.
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Press	 ,	 	icons	at	the	bottom	of	the	screen	to	turn	on	appropriate	display	of	
supports	and	sections	shapes.

Th	 e	defi	ned		structure	with	slabs	should	look	as	shown	below:

Figure 38 - Structure with slab view.

offset defi n�t�on

In	this	step	we	defi	ne	off	set	between	axis	slab	and	RC	beams:

Press	 	icon	at	the	bottom	of	the	screen	to	open	Display	dialog	box.

Select	the	Panels/FE option	(left		panel)	and	tick	Panel thickness	on	(right	panel)	
to	turn	displaying	thickness	of	panels	on.

12.

13.

1.

2.
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Figure 39 - Switch thickness of panel display on.

On the structure drawing, which appears on the screen we can see that neutral 
axis of the RC beams and RC slab are on the same level with no eccentricity by 
default.

	

3.
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Figure 40 - Default view of RC beams and RC slab on the same level with no eccentricity.

Select	Geometry > Additional Attributes > Off sets…	from	the	menu	then	press	

	New	off	set	defi	nition		button	to	open	the	New Off set	dialog	box.

In	the	New Off set	dialog	box	set	parameters:	Off set_1	in	Label	fi	eld,	-45,24	[cm]	
(this	 is	half	of	RC	slab	height	plus	half	of	RC	beams	height)	 in	the	Beginning 
– UZ:	and	End	-	UZ:	fi	elds	and	tick	Global	(Coordinate	system	fi	eld)	on	-	see	
picture	below:

4.

5.
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Figure 41 - New offset (between beams and slab) definition.

Add and close the New Offset dialog box.

Press  icon (left,top corner of the Robot screen) to open the Selection dialog 
box.

Figure 42 - Selection of RC beams by filters.

6.

7.
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Indicate Section as selection criterion and click B R30x60  in the list-	 	
box above.

Press the  button to enter defined selection to the edit field and mark red con-
crete beams, to which offsets will be attributed. Close the box.

In the Offsets dialog box place the cursor in the Current Selection field – num-
bers of selected beams will appear.

Press Apply and Close to finish offset definition.

To display defined offset beams press  icon at the bottom of the screen to open 
Display dialog box.

Select the Favorites option (left panel) and tick Offsets on (right panel), then 
press Apply and OK – result should look as shown below:

Figure 43 - Switch offsets display on.

8.

9.

10.

11.

12.

13.
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Figure 44 - View of RC beams and RC slab with offset defi ned.

defi n�t�on of a wall

In	this	step,	we	learn	how	to	defi	ne	a	wall,	fi	rst	we	defi	ne	a	contour	then	we	assign	physi-
cal	properties	to	it:

To	set	a	new	work	plane	press	the	icon	 	provided	in	the	bottom	left		corner	
of	the	screen	–	View	dialog	box	will	be	open.

Press	2D and	YZ buttons	and	select “Structure axis D” 14,00 (m).	Once	these	
options	are	selected	the	structure	is	set	on	the	YZ	plane	at	the	recently	defi	ned	X	
coordinate	(e.g.	X=40);	only	structure	components	from	this	plane	are	displayed.

1.

2.
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Figure 45 - New work plane definition (in axis D).

Close the View dialog box.

Press ,  icons at the bottom of the screen to turn display of supports symbol 
and sections shape off.

Press  icon (right side of the Robot screen) or select Geometry > Objects > 
Polyline-contour from the menu to open the Polyline-Contour dialog box.

Indicate required points of the contour in the graphic viewer by cursor as 
follow:

(14; 0; 0) 
(14; 2; 0) 
(14; 2; 3)
(14; 4; 3)
(14; 4; 0)
(14; 10; 0)
(14; 10; 3)
(14; 12; 3)
(14; 12; 0)
(14; 14; 0) 
(14; 14; 4) 
(14; 0; 4) 

Press Apply and close the Polyline-Contour dialog box.

3.

4.

5.

6.

-
-
-
-
-
-
-
-
-
-
-
-

7.
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Defi	ned	contour	should	look	as	shown	below:

Figure 46 - Contour of defi ned panel view.

Press	 	icon	(right	side	of	the	Robot	screen)	or	select	Geometry/Panels	from	
the	menu	to	open	the	Panel	dialog	box.

In	 the	Panel dialog	box	set	parameters:	Panel in Contour type	fi	eld,	Internal 
point	(Creation	with	fi	eld),	none	(Reinforcement:)	and Shell	(Model	fi	eld).

8.

9.

10.
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Figure 47 - Panel definition settings.

To define thickness of the panel press  button (right to the Thickness field), 
then in the Th = field type 30 (cm), in Label: field name TH30,00 will be auto-
matically updated, Add and close the New Thickness dialog box (see below).

11.



108 Model definition |  Definition of wall

Autodesk Robot Structural Analysis - Getting Started Guide

Figure 48 - New panel thickness definition.

To apply chosen panel properties to the recently defined contour, in the Panel 
dialog box, set the cursor in the Internal point field, then move the cursor to the 
graphical viewer and indicate a point within the boundaries of the panel con-
tour.

Close the box.

12.

13.
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Definition of wall support

In this step, we create a line support underneath the wall.   

Press  icon (right side of the Robot screen) to open the Supports dialog 
box.

Go to the Linear tab then select the Fixed support type.

Figure 49 - Linear support of the wall definition.

Switch to the graphical viewer, point at the bottom slab edges and click once 
(when it is highlighted) on the edge.

Close the box.

To set 3D view of structure click the icon  (bottom left corner of the 
screen), then in View dialog box press 3D button and close the box. 

Press ,  icons at the bottom of the screen to turn on display of supports 
symbol and sections shapes.

1.

2.

3.

4.

5.

6.
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Defi	ned		structure	with	slab	and	wall	should	look	as	shown	below:

Figure 50 - View of entire structure (with slab and wall defi ned).

mesh�ng parameters defi n�t�on

In	this	step,	we	learn	how	to	mesh	the	panels,	since	Robot	is	fi	nite	element	solution.	
Robot	has	extremely	powerful	meshing	algorithms	to	cope	with	virtually	any	shape	of	
structure	or	mesh	requirement.

The meshing of the plates and shells are made automatically (with standard parameters), 
after starting the calculation process. However it is often desirable to mesh the structure 
manually - often to obtain better quality meshing we should to modify the standard settings.  

NOTE:

7.
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 Options of FE Mesh Generation then  Meshing Options  – click 
these icons  or select the Analysis > Calculation model > Meshing Options op-
tion from the menu to open the Meshing Options dialog box. 

	

 

Select  Complex mesh generation (Delaunay) to choose meshing method. 

Type 0,5 [m] to define size of finite elements (as shown below):

1.

2.

3.

Because there were no panels selected, the program will ask you the question:

Answer Yes to select all panels.

NOTE:
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Figure 51 - Meshing method and parametrs definition.

Click OK to close  Meshing Options dialog box.

From Options of FE Mesh Generation toolbar click  Generation icon or 
select the Analysis > Calculation model > Generation option to generate the 
mesh.

Close the Options of FE Mesh Generation toolbar.

Meshed slab and wall should look as shown below:

4.

5.

6.

7.
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Figure 52 - Structure with meshed panels view.

Meshing parameters may be defi ned separately for each panel. This is s 
times useful if the Engineer is interested in results in a set area and can 
therefore mesh this area more densely than other areas.

INFO
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Definition of slab loads

In this step, we define additional loads to be applied to the slab.

Press  icon (right side of the Robot screen) to open the Load Types dialog 
box.

Choose in the Nature field live, then New to define a live load with a standard 
name LL3.

To define loads for LL3 case select this load case in the List of defined cases 
field.

Close the Load Types box.  

Press  icon (right side of the Robot screen) to open the Load Definition 
dialog box.

On the Surface tab press  icon to open Uniform Planar Load dialog box, 
then type value of load –10 (kN/m2) in the pZ field, click Add and close the 
box.

In the Load Definition dialog box set the cursor in the Apply to field, then indi-
cate panel (click when it is highlighted).

Press Apply and close Load definition dialog box.

1.

2.

3.

4.

5.

6.

7.

8.
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Structure Analysis
Here we start the analysis process, but firstly we will define load case	

 combinations:

Select Loads > Manual Combinations… option from the menu to open the 
Combination Definition > Modification dialog box. Leave Combination name 
and Combination type as set default.

Figure 53 - Definition of combination type.

Click OK button to open Combinations dialog box. 

1.

2.
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Figure 54 - Definition of cases in combination.

	

Combination factors may be defined manually for each nature of load case 
(Factor definition button) or applied automatically for the selected load 
nature (option auto in Factor field).

INFO

In this case we use automatic definition of factors (option auto in Factor field) 

so in the Combinations dialog box press  button to transfer all defined load 
cases (left panel) to the list of cases in combination (right panel):

3.
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Figure 55 - List of cases in combination with automatically assigned factors.

Apply and close the box.

Defined load combination COMB1 was added to the list of defined load cases:

Figure 56 - List of defined load cases updated by load combination COMB1.

 Calculations – click this icon or select the Analysis > Calculations option 
from the menu to start the calculation process. 

4.

5.

6.
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Once the calculations are completed the information: Results (FEM): Available 
should be displayed at the top of the screen.

	

A key strength of Robot is the possibility to define a wide range of analysis 
types (linear static, non-linear geometry and material, buckling, modal 
analysis, harmonic analysis, seismic analysis, time history analysis etc.) 
If the user wishes to see these possibilities, he/she may look in the Analy-
sis > Analysis Types > Change analysis type  pull down menu.
However, for this simple example, we will just assume the default linear 
static type of analysis.

INFO

Results Preview

Panels results in map form

In this step, we learn how to display calculation results on panels as “maps” for selected 
load cases:

In the list of defined load cases choose the load case for which the results will be 
displayed:

	

Select Results > Maps…  from the menu to open Maps dialog box.

In the Detailed tab check Displacements – u,w for z direction box.

Tick With FE mesh on (bottom part of the box):

7.

1.

2.

3.

4.
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Figure 57 - Parameters of maps on panels definition.

To display scale of colors, on the Detailed tab tick the “Open new window 
with scale” displayed box . On the Scale tab you can change parameters of 
map presentation (color palette, scale type), in this example, choose Color 
palette: 256 colors.

INFO

Click Apply and close the Maps dialog box then enlarge the graphical viewer (by 

stretching) and click  Zoom All icon to maximize model view.

5.
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Map	of	defl	ection	of	the	plate	should	look	as	shown	below:

Figure 58 - Panels displacements in z direction in map form.

Press	Exit	to	close	additional	window.	To	switch	off		the	map	display,	go	back	to	
the	maps	dialogue	box,	remove	the	tick	and	apply

 

In the similar way, maps that show other values available from the deta�led dialog box can 
also be displayed.

NOTE:

6.

7.
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Deformation of the structure

In this step, we learn how to display deformation of the structure.

Press  icon at the bottom of the screen to turn displaying sections shape off.

Select Results >  Diagrams for Bars…  from the menu to open Diagrams dialog box.

Figure 59 - Presentation parameters of structure deformation.

On the Deformation tab tick Deformation box on, then press Normalize button 
(to auto scale). Deformation of the structure should look as shown below:

1.

2.

3.
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Figure 60 -Deformation of the structure.

In a similar way, diagrams that exhibit other values available from the ntm dialog box can be 
viewed (see below):

NOTE:
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Figure 61 - Diagrams for bars dialog box.

Tick off Deformation and Apply, then close the Diagrams dialog box.

Results on panels in tabular form

In this step, you learn how to display calculation results as tables:

Select Results > Panel and Shell Results from the menu to open FE Results dia-

log box, or click  Tables icon (toolbar on the right side of the screen) and 
tick Results for Plates and Shells option on, then OK to close the box.

4.

1.
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Figure 62 - Selection of data to tabular presentation.

Click the right mouse button and select Table Columns option to open Results 
for Plates and Shells dialog box.

In the Detailed tab tick the following options in:

Membrane forces – N: in direction xx
Shear forces – Q: in direction xx
Displacements – u,w: in direction z (as shown below):

2.

3.

-
-
-
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Figure 63 - Table content composition.

Click the Direction X button and in the opened Selection of Direction dialog 
box tick the Automatic option in:

4.



126 RESULTS PREVIEW | Results on panels in tabular form 

Autodesk Robot Structural Analysis - Getting Started Guide

Figure 64 - Definition of the X direction of the local co-ordinate system of panels.

Selection of Direction window allows the user to define the main direction 
of the co-ordinate system (more precisely, to define the X-axis), which will 
be utilized by the user during surface FE result presentation.  In this case 
we using Automatic option so the local element system will be automati-
cally adopted according to the system defined for each of the panels.

INFO

Press OK to close Selection of Direction dialog box then OK to close the Results 
for finite elements box.

In the list of defined load cases choose the 8:COMB1 for which the results will be 
displayed, the results for selected values in tabular form is shown below:

	

5.

6.
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Figure 65 - Example of data presentation in tabular form.

There are few tabs on the bottom of the window to display additional data 
such as envelope, Global extremes and info about panels.

INFO

In	the	table,	press	right	mouse	button,	then	“convert	to	Excel”	to	extract	all	data	
to	a	spreadsheet

Close	the	FE Results	table.

7.

8.





inteGRAtion oF Autodesk Robot 
stRuctuRAl AnAlysis 

With ReVit® stRuctuRe

Th	 is	example	of	a	fi	ve	storey	concrete	building	shows	the	 importance	of	using
	a	capable	analysis	solution	as	part	of	the	BIM	process.	Such	a	model	cannot	be	described	
as	“architecturally	demanding”,	yet	the	analysis	model	produced	from	Revit®	Structure	
poses	some	challenges	for	a	lot	of	structural	analysis	solutions	-	including	non-rectan-
gular	openings,	curved	slab	edges	and	cores.	However,	Robot	is	ideally	suited	to	such	
structures	and	will	directly	calculate	 the	Revit®	Structure	generated	data,	without	 the	
need	to	“hack”	the	geometry	as	would	be	necessary	to	satisfy	the	limitations	of	some	
other	structural	soft	ware,	thereby	compromising	the	overall	BIM	integrity.

Synopsis:

Th	 e	 purpose	 of	 this	 example	 is	 to	 show	 the	 ease	 of	 transfer	 of	 data	 from	
Revit®	Structure	to	Robot	and	also	to	show	how	changes	in	the	model	made	in	Robot	
can	be	refl	ected	again	in	Revit®	Structure,	thereby	maintaining	the	integrity	of	the	over-
all	Building	Information	Model.	In	particular,	this	example	looks	at	the	import	of	fl	oors	
and	walls	from	Revit®	Structure,	in	the	form	of	fi	nite	element	surfaces	in	Robot.
In	addition	to	showing	the	user	how	to	interact	with	and	display	basic	data	in	Robot,	
this	example	also	highlights	the	display	of	FE	results	and	making	a	basic	FE	mesh,	plus	
amending	the	mesh	to	suit	the	Engineer’s	preferences
For	this	example,	it	is	assumed	that	Autodesk	Robot	Structural	Analysis	2010,	plus	the	
Extensions	For	Revit	(Integration	with	Robot	Structural	Analysis)	are	installed	on	the	
same	PC.
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eXpoRt ReVit model to Robot

open�ng project �n Rev�t® structure

In	this	step,	we	open	and	examine	the	model	in	Revit	Structure: 

Press	 	icon	to	run	the	Revit	Structure	program	then	open	the	Revit Struc-
ture	project:	Revit2Robot building example.rvt:

Figure 1 - Model of building in Revit�  Structure

1.
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Rotate it to show the type of elements it contains:

Sections:
steel (according to US AISC and also UK Steel section databases)
concrete beams and columns

Slabs, walls
Foundations: 

isolated footings - in Robot these will be treated as a fixed support,
continuous around wall base - in Robot these 
will be treated as a line support

Loads (Line and Area Load)

Sending data to Robot

In this step, we learn how to export the Revit model to Robot: 

A useful feature is that only “selected” structure data in Revit® Structure is transferred to 
Robot – this allows only part of the model to be transferred to Robot  (it could be useful if 
the user wants to select only part of a structure to analyze).

However, in this example, we want Robot to analyze all of the Revit® Structure data so it 
is important to ensure that either no data is selected or alternatively all of the structure is 
selected.

NOTE:

Go to the extensions4revit menu and select the Extensions Manager option:

Figure 2 - Extensions4revit menu

2.

-
-
-

-
-

-
-

-

1.
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Revit® Structure: Modify option should be selected in the Basics tab of the Design Bar.

NOTE:

Extensions Manager dialog box will appear:

Figure 3 - Extensions Manager dialog box

To open Integration with Robot Structural Analysis double click the appropri-
ate option (see above). 

In dialog box shown below leave Send model to Autodesk Robot Structural 
Analysis option active (it is chosen by default) and click OK.

Figure 4 -Integration with Robot Structural Analysis (send model option) 

2.

3.

4.
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There are 2 ways to send data to Robot:

dynamic – Send model to Autodesk Robot Structural Analysis –this is a dymanic trans-
fer of data between programs
by file – Use  Autodesk Robot Structural Analysis RTD file – useful if, for example, 
Revit® Structure and Robot are on different computers





NOTE:

During the transfer process the following splash screen is displayed:

Figure 5 -Send model to Robot splash screen

Next, Integration with Robot Structural Analysis – Send Options dialog box 
will appear:  

Figure 6 -Integration with Robot Structural Analysis - Send Options dialog box

Leave default settings as shown above and click OK.

5.

6.

7.
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Integration with Robot Structural Analysis – Send Options dialog box 
allows you to configure export parameters

Basic Opitons tab:

Scope and correction group – enables the user to:
Send entire Revit project (ignore current selection) - sends whole 
model (this option is selected by default – it prevents exporting of an 
accidentally selected element or elements.
Send current selection only - sends only selected elements
Execute model correction in Robot - decides whether to run “draw-
ing model correction” in Robot automatically, which will serve to join 
nodes to gether that fall within a certain tolerance

Specify the case that contains self-weight - option allows for defining 
which load case will be considered in RSA as a self-weight case

If the first option is chosen, then User is able to specify Revit load 
case, which will be used in RSA for definition of self-weight. All loads 
defined in this case remain unchanged – self-weight will be added. 
It is possible to ignore definition of self-weight with using Revit load 
cases – by choosing second option.

Bar end releases group - allows the user to select the way of handling 
end releases:

Do not use Revit settings (assign end releases in Robot) – end releas-
es are manually defined in Robot.
Use Revit settings – recognizes and assigns bar end releases defined 
in Revit® Structure
Change Pinned-Pinned to Fixed-Fixed – all Pinned-Pinned end re-
leases defined in Revit® Structure are changed to Fixed-Fixed. This is 
often set to avoid mechanisms in the structural model
















INFO
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Integration with Robot Structural Analysis – Send Options dialog box 
allows you to configure export parameters

Additional Opitons tab:

Materials group - allows you to select the way of handling materials:
Use Robot default materials – for each element’s material type (steel, 
concrete, timber) Robot will assign material from Robot database 
with standard properties 
Define new materials in Robot – creates new materials in Robot with 
such physical properties as defined in Revit® Structure
Select material of the best matching parameters - assigns material 
properties from Robot data base with the nearest values to those 
defined in Revit® Structure

Curtain walls - option allows for setting sending parameters for Curtain 
walls. Panels created in RSA have a property (triangular method of load 
distribution in panel calculation model is set), which allows load distribu-
tion to other elements.

Analytical model only (no system panels, no mullions) – creates one 
panel in RSA without interior elements (system panels and mullions) 
– differences in singular panels are neglected
Analytical model and mullions (no system panels) – creates one 
panel in RSA (no division to system panels) but also mullions are 
transferred – differences in singular panels are neglected
System panels and mullions (detailed model) – sends all interior ele-
ments – system panels and mullions are created in RSA – differences 
in singular panels are considered

Transfer (optionally) – set of additional options of sending
Use drawing model offsets as analytical – an offset parameter is 
defined for bar elements in RSA according to Revit’s definition 
Reinforcement projects (beams, columns, spread footings) – defined 
reinforcement in listed elements is transferred to concrete design 
modules in RSA
Steel connections – option not available in current version



















INFO
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The Send model to Robot splash screen is displayed once again. Information 
about Robot launching appears. A progress information shows each step of the 
transfer process (such as reading of necessary Revit® Structure data, creation of 
Robot project, export of elements and creation of corresponding Robot struc-
tural elements).

Figure 7 -Send model to Robot splash screen

Occasionally sections may be defined in Revit Structure that are not defined in Robot. The 
Section Database Organizer (see below) allows the user to add such databases into Robot 
without disturbing the transfer of data between programs. 

NOTE:

Adaptation of Active Section Databases of Robot dialog box may appear and 
display (upper, left corner of the box) information about Unknown sections 
(in this case there is one unknown section 178x102x19UB from the British 	
section database). 

Such a message may or may not occur on individual PC’s depending on the language, prefer-
ences and databases that are used in Robot.

NOTE:

8.

9.
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Figure 8 - Adaptation of Active Section Databases of Robot - information about unknown sections

In the Available section databases pull-down menu select UKST (British 	
section database).

Figure 9 - Adaptation of Active Section Databases of Robot - available section databases pull-down 
menu 

10.
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Click to Add to active databases button, UKST database will appear in the Active 
section databases window.

Figure 10 - Adaptation of Active Section Databases of Robot - information about added section 
database

Press Apply to close the window and continue exporting process.

After data transfer, we can see an events report, to do this click Yes.

Figure 11 - Events report after exporting data selection.

List of messages (and eventual warnings) will appear (see below):

11.

12.

13.

14.
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Figure 12 -Warning and messages list

Close the Warning list to finish sending data to Robot process.15.
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stRuctuRe AnAlysis in Robot

Change units from imperial to metric:  Tools/Job Preferences/Units and Formats/Metric.
you can check active units in right, bottom corner of the screen. In this example should be 
the display: [m] [kN] [Deg].

NOTE:

Exported	 Revit®	 model	 of	 structure	 should	 appear	 in	 Robot	 as	 shown	 below:

Figure 13 -Exported model of structure in Robot
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d�splay�ng �tems on the screen

In	 this	 step,	 we	 learn	 how	 to	 display	 additional	 attributes	 on	 the	 screen.	
By	selecting	icons	of	the	toolbar	located	under	the	graphic	fi	eld	display	a	few	more	items	
can	be	displayed:

	-	Support	symbols

	-	Section	shapes

	-	Load	symbols

Figure 14 -Model of structure in Robot with additional display attributes
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presentat�on of load cases transferred from  Rev�t® structure

In	this	step,	we	display	the	load	cases	defi	ned	in	Revit®	Structure:	

From	the	list	of	defi	ned	load	cases	choose	2: LL1

Figure 15 -List of defi ned load cases

Loads	belonging	to	the	case	2:LL1	case	are	shown	in	the	graphic	viewer	(in	the	
same	way	display	next	cases:	3: WIND1	and	4: SNOW1):

Figure 16 -2:LL1 Load case

1.

2.
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Figure 17 -3:WIND1 Load case

Figure 18 -4:SNOW1 Load case
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To display numerical values of loads click  icon (bottom left corner of the 
screen).

 Display the View submenu.

 By means of 3D Orbit option from the View toolbar rotate the model to 

show all the details: Profiles, Panels, Supports, Loads.

Click one more time the icons:   to turn loads display off.

Click one more time the icons:   to turn support and sections display off.

Meshing parameters definition

In this step, we learn how to mesh the panels. 

The meshing of the plates and shells are made automatically (with stan-
dard parameters). A key strength of Robot is the ability to rapidly auto-
mesh virtually any shape of surface and to edit and refine the mesh as 
required.

INFO

 Options of FE Mesh Generation then  Meshing Options – click these 
icons or select the Analysis > Calculation model > Meshing Options option 
from the menu to open the Meshing Options dialog box. 

3.

4.

5.

6.

7.

1.
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NOTE:

Because there were no panels selected, the program will ask you the question:

Answer Yes to select all panels.

Select Complex mesh generation (Delaunay) to choose meshing method. 

Type 0,61 [m] to define size of finite elements (as shown below):

Figure 19 -Meshing method selection

Click OK to close Meshing Options dialog box.

From Options of FE Mesh Generation toolbar click  Generations icon or select 
the Analysis > Calculation model > Generation option to generate the FE mesh.

2.

3.

4.

5.
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Close	the	Options of FE Mesh Generation	toolbar.

Meshed	slabs	and	core	walls	should	appear	as	shown	below:

Figure 20 -Example of meshed structure

Press	 	icon	at	the	bottom	of	the	screen	to	hide	the	fi	nite	element	mesh.

Meshing parameters may be defi ned separately for each panel.
INFO

6.

7.

8.
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Calculations

Here we start the analysis process, but firstly we will tell Robot to make automatic code 
combinations (from any one of the list of Codes in Job Preferences):

Select Loads > Automatic Combinations… option from the menu to open the 
Load Case Code Combinations dialog box.  Select the Full automatic combina-
tions option. The program will now automatically assign a number of combina-
tions to find the most onerous load combination.

Figure 21 -Code combinations dialog box

Click OK button – automatic calculation of code combinations will be done.

 Calculations – click this icon or select the Analysis > Calculations option 
from the menu to start the calculation process. 

Once the calculations are completed the information: Results (FEM): Available 
should be displayed at the top of the screen.

1.

2.

3.

4.
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A key strength of Robot is the possibility to define a wide range of analysis 
types (linear static, non-linear geometry and material, buckling, modal 
analysis, harmonic analysis, seismic analysis, time history analysis etc.) 
If the user wishes to see these possibilities, he/she may look in the Analy-
sis > Analysis Types > Change analysis type  pull down menu.

However, for this simple example, we will just assume the default linear 
static type of analysis.

INFO

Results preview - displaying panel results in map form

In this step, we learn how to display calculation results on panels as contour maps for 
selected load cases:

In the list of defined load cases choose the load case for which the results will be 
displayed:

Select Results > Maps… from the menu to open Maps dialog box.

In the Detailed tab check Displacements – u,w for  z  direction box in.

Tick With FE mesh on (bottom part of the box):

1.

2.

3.

4.
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Figure 22 -Maps for surface finite elements (panels) definition 

To display scale of colors, on the Detailed tab tick the Open new window with scale dis-
played box on. On the Scale tab you can change parameters of map presentation (color 
palette, scale type), in this example  choose Color palette: 256 colors.

NOTE:

Click Apply and Close the Maps dialog box then enlarge the graphical viewer (by 

stretching) and click  Zoom All icon to maximize the model view.

Maps for selected value should look as shown below:

5.

6.
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Figure 23 -Example of displacements presentation in map form.

Tick	off		the	Displacement z	check-box	and	click	Apply	to	switch	the	maps	off	.

Close	the	Maps dialog	box.

Click	Exit	button	(upper,	 left		corner	of	the	Robot	screen)	to	close	the	window	
with	the	scale.

7.

8.

9.
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Results preview - displaying results on bars in diagram form

In this step, we learn how to display calculation results on bars as diagrams for selected 
load cases:

In the list of defined load cases choose the load case for which the results will 
be displayed:

Press  icon at the bottom of the screen to turn off display of panel interiors.

Select Results > Diagrams for Bars option from the menu to open the Diagrams 
dialog box.

Select MY Moment (this shows the major axis bending moment on the beams) 
as shown below:

Figure 24 -Diagrams on bars definition (force selection)

1.

2.

3.

4.
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On the Parameters tab tick differentiated option (on Positive and negative val-
ues field) on (see below) and return to NTM tab:

Figure 25 -Diagrams on bars definition (parameters of diagrams displaying)

On the NTM tab press Normalize button (to autoscale) to display bending mo-
ment diagrams for bars:

5.

6.
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Figure 26 -Example of bending moment presentation in diagram form

Tick	off		My Moment	and	apply	to	remove	the	diagram.

Close	the	dialog	box.

Press	 ,	 ,	 	 icons	at	the	bottom	of	the	screen	to	turn	on	display	of	the	
supports,	section	shapes	and	panel	interior.

7.

8.

9.



1��MODIFICATION  OF THE STRUCTURE IN ROBOT | Replacing sections

Autodesk Robot Structural Analysis - Getting Started Guide

modiFicAtion oF the stRuctuRe in Robot

Replac�ng sect�ons

In	this	step,	we	learn	how	to	replace	section	shapes:

Press	 	icon		on	top	toolbar	to	open	the	Selection	dialog	box.	

Indicate	Section	as	selection	criterion	and	click	178x102x19UB.		

Press	the	 	button	to	enter	defi	ned	selection	to	the	edit	fi	eld	and	mark	red	steel	
beams	(see	picture	below):

Figure 27 -Selection of beams by fi lters.

1.

2.

3.



156 Modification of the Structure in ROBOT | Replacing sections

Autodesk Robot Structural Analysis - Getting Started Guide

Go to the toolbar on the right side of the screen and click  Bar Sections 
icon.

In Sections dialog box select W 8x10 section:

Figure 28 -Section selection.

Apply and Close the box. This changes all the selected sections to W 8x10

Because the section exchange implicates changes in the structure stiffness, the program 
will ask you the question:

Answer Yes

NOTE:

In the same way we can replace concrete columns 18x24 by sections C18x18.

Press  icon to open the Selection dialog box. 

Indicate Sections as selection criterion and click 18x24.  

4.

5.

6.

7.

8.
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Press	 the	 	button	 to	 enter	defi	ned	 selection	 to	 the	 edit	fi	eld	and	mark	 red	
concrete		columns:

Figure 29 -Selection of columns by fi lters.

Click	Close.

In	the	Sections	dialog	box	choose	C18x18 section	as	shown	below:

9.

10.

11.
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Figure 30 -Section selection.

Click Apply in Sections dialog box to give the new section type to bars 

Close the Sections dialog box.

Deleting bars

In this step, we learn how to delete elements:

Indicate bars (just click bar when is highlighted) as shown below. To make a multi 
selection, click while holding down the ctrl button:  

12.

13.

1.
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Figure 31 -Selection of beams by coursor.

	Delete	–	press	this	icon	or	select	the	Edit > Delete option	from	the	menu	to	
delete	selected	elements.

Add�ng new elements

In	this	step,	we	learn	how	to	create	new	elements	(in	this	case	we	will	add	cross	bracing):

Press	the	icon	 	to	turn	sections	display	off	.

Press	right	mouse	button	on	the	graphics	screen,	then	in	the	context	menu	select	
Window	option:

2.

1.

2.
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Select	by	dragging	window	the	view	of	the	highest	storey	as	shown	below:

Figure 32 -Top storey view.

Select	the	Geometry > Bars option	from	the	menu	to	open	the	Bars	dialog	box.	

3.

4.
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Set Bar type: as Simple bar (whatever is selected is not important for analysis, 
but affects the design parameters for subsequent member design, such a buckling 
length, position of restraint etc)

Figure 33 -Bar type definition.

Define Section: as L4x4x0.375.

If the L4x4x0.375 section is not available on the list, you should click the (…) 
button located beside the Section field.

In New section dialog box, in Section selection field for Database: select AISC, 
for Family: select L then in the Section: set L4x4x0.375:

5.

6.

7.

8.
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Figure 34 -New section definition

Click Add and Close the box.

There are many extra options that may be entered for fabricated mem-
bers, tapering sections and also for beams that the user wants to define 
as able to exhibit plasticity.

INFO

Click the following points (their numbers are shown in the picture below) to 
draw new bracing:

137 126 to create 1st bar
124 125 to create 2nd bar
126 136 to create 3rd bar
127 128 to create 4th bar

9.

10.

-
-
-
-
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Figure 35 -Nodes numbers necessary to bracing defi nition.

Close	the	Bars	dialog	box.

Press	the	icon	 	to	turn	sections	display	on.

Bracings	should	look	as	shown	below:

11.

12.

13.
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Figure 36 -View of defi ned bracings.

updAte ReVit model FRom Robot

updat�ng Rev�t® structure project

In	 this	 step,	 we	 learn	 how	 to	 update	 model	 data	 aft	er	 analysis	 and	 changes	 in	
Robot:

Go	back	to	Revit®	Structure.

Choose	the	extensions4revit	menu	and	select	the	Extensions Manager	option:

1.

2.
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Figure 37 - Extensions4revit menu

Extensions Manager dialog box will appear (see below): 

Figure 38 - Extensions Manager dialog box.	

To open Integration with Robot Structural Analysis double click appropriate op-
tion (see above) 

In dialog box shown below click Update model from Autodesk Robot Struc-
tural Analysis option and click OK:

3.

4.
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Figure 39 -Integration with Robot Structural Analysis (update model option).

Next, Integration with Robot Structural Analysis – Update Options dialog box 
will appear:  

Figure 40  -Integration with Robot Structural Analysis - Update Options dialog box

Leave default settings as shown above and click OK.

6.

7.
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Integration with Robot Structural Analysis – Update Options dialog box 
allows you to configure update parameters

Scope – consider current selection – possibility of update whole struc-
ture or selected elements

Update the whole project (ignore current selection) – all elements 
will be taken into account in update process
Update only the structure part selected in Robot – only selected ele-
ments in RSA will be updated
Update only the structure part selected in Revit Structure – only se-
lected elements in Revit will be updated
Select modified elements in Revit Structure – if some elements are 
new or changed then they will be selected in Revit after update pro-
cess

Transfer (optionally)
Results (reactions and internal forces) – allows to transfer internal 
forces for Revit load cases in elements (option available only if the 
structure is calculated in RSA).
Reinforcement projects (beams, columns, spread footings) – defined 
reinforcement in listed elements is transferred from concrete design 
modules in RSA to Revit
Steel connections – option not available in current version















INFO

During sending process the following splash screen is displayed:8.
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It is often the case that the user can generate sections in Robot that are 
not in the Revit Structure database. Simple feature allows the user to 
add this database information without interrupting or abandoning the 
transfer of data. 

INFO

Autodesk Robot Structural Analysis To Revit Update Log dialog box 	
may appear:  

Figure 40 -Unknown section during updating process.

Click Multi-select and load Revit Family Files… button (bottom, left corner of 
the box).

In the opened dialog box select  L-Angle.rfa family file (default localization: C:\
Documents and Settings\All Users\Application Data\Autodesk\RST 2008\Impe-
rial Library\Structural\Framing\Steel) to load unavailable section family:

9.

10.

11.
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Figure 41 -Selection of missing Revit family file.

Press Open to open the database and this will close the window and continue the 
updating process.

The Update model from Robot splash screen is displayed once again. A progress 
information shows each step of the transfer process.

Autodesk Robot Structural Analysis To Revit Update Log dialog box will ap-
pear once again showing  information about successfully updated sections:  

12.

13.

14.
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Figure 42 -Sections succesfully updated list.

Click Apply to close the box.

After finish sending data you can see an events report, to do this click Yes.

Figure 43 -Events report after updating data selection.

List of messages (and also warnings, if any will appear - see below):

15.

16.

17.
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Figure 44 -Events report.

Close	the	box.

Updated	model	of	structure	should	look	as	shown	below:

Figure 45 -Updated model of building in Revit�  Structure.

18.

19.
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model changes presentat�on

In	this	step,	we	can	check	and	display	changes	in	the	model:

Zoom	to	view	upper	storey	as	shown	below,	notice	that	lateral	beams	W 8x10	has	
been	deleted	and	new	bracings	added	(as	changed	in	Robot):

Figure 46 -View of added bracings.

Go	with	the	mouse	cursor	to	the	one	of	the	new	beams	and	select	it	to	check	the	
section	(L4x4x3/8	should	be	displayed).

Zoom	to	view	second	storey	on	the	left		side	of	the	building	as	shown	below:

1.

2.

3.
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