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Getting Started Guide

Thank you for choosing the Revit® Structure 2009 parametric building modeler. Revit Structure
is designed to respond to your work methodology, communication requirements, and design
applications. The exercises in this guide give you a starting point for preparation of your
models.

Getting Started
Before beginning the exercises, you need to install and register the software. All
you need is the Revit Structure CD and an Internet connection. The registration
options are demo or subscription. Demo mode serves as a no-cost viewer,
allowing you to export, print, or plot projects that have not been edited.

Imperial/Metric Conventions
The exercises in this guide contain both imperial and metric values. This means
that when you see an imperial value, the corresponding metric value is displayed
in square brackets ([ ]) next to it. For example: Enter 6'' [150 mm] for the
dimension. Use the values that correspond to the units of the training file that
you decide to work with.

Scale
You will find that Revit Structure takes care of object and view scale for you. If
you wish to change scale, change the View Scale parameter of the view. You
will have the opportunity to work with View Scale in an exercise that follows.

1
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Families,Types, and Instances
Revit Structure is built on the idea of using parametric objects that can be
adapted to specific structural framing, detailing, and analytical modelling. For
example, in this lesson, you will begin a model by adding columns. These
column components are members of a column family in Revit Structure. Each
column shape size is a type of that family, and each time that you place a
column in your model, it is referred to as an instance of that type. You can
adjust parameters for types and instances to meet the specific requirements
of your model.

Levels and Grids
Revit Structure models have levels and grid systems that provide elevations
and dimensions. Levels and grids are also families. You can constrain the
structural elements of your model to these, so that when there is an elevation
or dimensional change to your model, constraints are maintained and the
structural elements move as a level or grid line changes.

Exploring the User Interface
Open Revit Structure. When the Revit Structure window displays, take a minute
to view the different areas of the window.
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Menu Bar and Tool Bar

At the top of the screen is the standard Microsoft® Windows® based menu
bar. You can access each of the Revit Structure menus by clicking the menu
name. Below the menu bar is the Toolbar, which contains buttons with icons
representing some of the common Revit Structure commands.

Options Bar

Below the Toolbar is the Options Bar, which displays different command
options that complement the current operation. On the Design Bar, click
Structural Wall. Notice the different commands on the Options Bar that are
related to the Structural Wall command.

Type Selector

On the left side of the Options Bar is the Type Selector, which lists the available
types of elements within the currently selected family. For example, if you
click Structural Column on the Design Bar (described below), you can choose
from a number of different column types to place in your model.
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Element Properties Button

To the right of the Type Selector is the Element Properties button. Click this
button to display a dialog in which you can change the different property
values of your elements.

Design Bar

On the left side of the Revit Structure window is the Design Bar, where you
access the commands for adding various types of elements to your model. The
commands are organized on 9 tabs: Basics, View, Architectural, Drafting,
Rendering, Site, Massing, Modelling, and Construction. You can control the
visibility of each tab on and off by right-clicking on the Design Bar and
selecting the tab from the context menu.

Project Browser

To the right of the Design Bar is the Project Browser. Similar to Windows®

Explorer®, the Project Browser displays views, families, and groups in your
project. You can select any of the items listed in the Project Browser. A
convenient way to open the views is to double-click the view names in the
Project Browser list.

Status Bar

At the lower-left corner of the interface is the Status Bar, which displays the
status of the current command or the name of a highlighted element.

You can also learn more about the environment and tools in Revit Structure
by using the tutorials that are available from the Help menu.

Creating a Concrete Structure
In this lesson, you import an AutoCAD® architectural plan to use as the basis
of your model. You then create the following concrete structural model using
the tools available in Revit Structure.
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Creating a New Project

In this first exercise, you create and name a project in which you will create
the concrete structure.

1 Click File menu ➤ New ➤ Project.

2 In the New Project dialog, click Browse.

3 In the Choose Template dialog, in the Imperial [Metric] Templates
folder, select Structural Analysis-Default.rte [Structural
Analysis-Default Metric.rte], and click Open.

4 In the New Project dialog, click OK.

5 Click File menu ➤ Save.

6 In the left pane of the Save As dialog, click Training Files, and
then, in the file window, double-click Imperial [Metric].

7 For File name, enter Getting_Started, and click Save.

8 Proceed to the next exercise, Importing an AutoCAD Drawing on
page 6.

Creating a New Project | 5



Importing an AutoCAD Drawing

In this exercise, you learn how to import an AutoCAD drawing for use with
your project. You will import the Level 2 drawing for use as a background.

1 Click File menu ➤ Import/Link ➤ CAD Formats.

2 In the Import/Link dialog:

■ In the left pane, click the Training Files icon, and in the
Imperial [Metric] folder, select i_rst_gsg_concrete.dwg
[m_rst_gsg_concrete.dwg].

■ Select Current view only.

NOTE Selecting Current View Only prevents the DWG file from
appearing in all other views.

■ For Colors, select Black and white.

■ For Positioning, select Auto - Center to Center.

■ Click Open.
Exterior facade outlines, and a few basic interior walls and
openings display in the view.

3 Click View menu ➤ Visibility/Graphics.

4 In the Visibility/Graphic dialog, select the Imported Categories
tab.

5 Select Halftone for i_rst_gsg_concrete.dwg
[m_rst_gsg_concrete.dwg], and click OK.

6 Proceed to the next exercise, Adding Grid Lines on page 6.

Adding Grid Lines

In this exercise, the halftone imported drawing file is used as a background
for placing grid lines.

1 Add horizontal grid lines.

■ On the View Toolbar, click  , and zoom in on the lower
structure.

■ On the Drafting tab of the Design Bar, click Grid.
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■ On the Options Bar, click  .

■ Select the top horizontal grid line.
By selecting each grid line in the linked drawing, you are
creating new grid lines in your Revit Structure model.

■ Click the value in the grid line balloon, and enter A.

NOTE Select the check box next to the grid line balloon to display
the value.

■ Select the next horizontal grid line below grid line A. Notice
it is renamed B.
New grid lines are labelled in alphabetical sequence.

■ Select the remaining horizontal grid lines, moving top to
bottom. Zoom in and out as needed.

NOTE When you get to grid line I, change the value to J. The last
horizontal grid line is K.

2 Add vertical grid lines.

■ On the View Toolbar, click  , and zoom in on the first
vertical grid line on the left side of the structure.

■ Select the first vertical grid line.

■ Click the value in the grid balloon, and enter 1.

NOTE Select the check box next to the grid line balloon to display
the value.

■ Select the remaining vertical grid lines.
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The last vertical grid line is 9.

3 Proceed to the next exercise, Adding New Levels on page 8.

Adding New Levels

In this exercise, you add all remaining levels to the structure.

1 Move the elevation symbol.

■ In the Project Browser ➤ Structural Plans, double-click Level
2.
Notice the elevation symbol is positioned on the north side
of the structure.

■ Click the elevation symbol.

■ Drag the symbol below the vertical grid lines.

2 Create Foundation and Level 1.

■ In the Project Browser ➤ Elevations (Building Elevations),
double-click Building Elevation [North].

■ Double-click the Level 1 Text, enter Foundation, and press
ENTER.
When the dialog appears, click yes to rename the views.

■ Double-click the level elevation for Foundation, enter -9'- 0"
[-2700 mm], and press ENTER.

■ Use the same technique to rename Level 2 as Level 1.

■ Double-click the level dimension for Level 1, enter 0'- 0" [0
mm], and press ENTER.

3 Create levels up to Level 3.

■ On the Drafting Tab of the Design Bar, click Level.

■ On the Options Bar, click  , and enter 4'-6" [1400 mm] for
Offset.

■ In the drawing area, highlight the Level 1 line; when a dashed
line is displayed above the level line, click to create a level.

■ Double-click the level text, enter Level 1M, and press ENTER.
When the dialog appears, click yes to rename the views.
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■ Use the same technique to create 3 new levels (Level 2, Level
2M, and Level 3), offset by 4'-6" [1400 mm].

4 Create remaining levels.

■ On the Options Bar, click  , and enter 9'- 0" [2700 mm] for
Offset.

■ In the drawing area, highlight the Level 3 line; when a dashed
line is displayed above the level line, click to create a level
(Level 4).

■ Use the same technique to create 7 new levels (Level 5 through
Level 11).

■ Press ESC twice to exit the Level command.

5 Click the level tags and drag them closer to grid 9.

6 Click the grid line balloons and drag them above Level 11.

7 Proceed to the next exercise, Adding Structural Columns on page
9.

Adding Structural Columns

In this exercise, you load existing column types from the Revit Structure
Library, change dimensions, and create custom column sizes. You then place
these columns at specific grid intersections.

1 In the Project Browser, double-click Level 1.

2 If the Modelling tab of the Design Bar is not displayed, right-click
on the Design Bar, and click Modelling.

3 On the View Toolbar, click  , and zoom in on the lower
structure.

4 On the Modelling tab of the Design Bar, click Structural Column.

5 In the Type Selector, select Concrete-Rectangular-Column 24 x
30 [600 x 750 mm].

Press SPACEBAR to rotate the column as required.

6 Place a column at grid location B1.

7 On the Design Bar, click Modify.
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Create a new column size

8 Select the column, and on the Options Bar, click  .

9 In the Element Properties dialog, click Edit/New.

10 In the Type Properties dialog, do the following:

■ Click Rename.

■ In the Rename dialog, under New, enter 24 x 44 [600 x 1200
mm], and click OK.

■ Under Dimensions, for b, enter 2' 0" [600 mm].

■ Under Dimensions, for h, enter 3' 8" [1200 mm].

■ Click Apply, and then click OK twice.

Place the new column

11 In the Type Selector, select Concrete-Rectangular- Column 24 x
44 [600 x 1200 mm].

12 Place a column at each of the grid locations shown (but do not
place a second column at B1).
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13 Right-click the column at B1, and click Select All Instances.

14 On the Options Bar, click  .

15 In the Element Properties dialog, do the following:

■ Under Constraints, specify 0' 0" [0 mm] for Base Offset and
for Top Offset.

■ Under Constraints, specify Foundation for Base Level, and
Level 1M for Top Level.

■ Click OK.

Create additional column

16 In the Project Browser, double-click Level 1.

17 On the Modelling tab of the Design Bar, click Structural Column.

18 In the Type Selector, select Concrete-Rectangular-Column 18 x
24 [450 x 600 mm].

19 Place a column at grid location J3.

20 Select the column.

21 On the Options Bar, click  .

22 In the Element Properties dialog, click Edit/New.

23 In the Type Properties dialog, do the following:

■ Click Rename.

■ In the Rename dialog, under New, enter 24 x 32 [600 x 800
mm], and click OK.

■ Under Dimensions, for b, enter 2' 0" [600 mm].

■ Under Dimensions, for h, enter 2' 8" [800 mm].

■ Click Apply, and then click OK twice.

Place the new column

24 In the Type Selector, select Concrete-Rectangular- Column 24 x
32 [600 x 800 mm].

25 Place a column at each of the following grid locations:

■ K3

■ J5, K5
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■ J7, K7

Press SPACEBAR to rotate the column as required.

26 Right-click the column at J3, and click Select All Instances.

27 On the Options Bar, click  .

28 In the Element Properties dialog, do the following:

■ Under Constraints, specify 0' 0" [0 mm] for Base Offset and
for Top Offset.

■ Under Constraints, specify Foundation for Base Level, and
Level 1M for Top Level.

■ Click OK.

29 Proceed to the next exercise, Adding Shear Walls on page 12.

Adding Shear Walls

In this exercise, you add 4 shear walls to form the elevator shafts and stairways.

Create a new concrete wall

1 In the Project Browser ➤ Structural Plans, double-click Level 1.

2 On the View toolbar, click  , and draw a zoom box around
the center of the structure.

3 If the Modelling tab of the Design Bar is not displayed, right-click
in the Design Bar, and click Modelling.

4 On the Modelling tab of the Design Bar, click Structural Wall.

5 In the Type Selector, select Basic Wall: Generic - 8" [200 mm].

6 Using the imported drawing as a guide, trace the outline of the
elevator shafts and stairways as shown.
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7 On the Design Bar, click Modify.

8 Select the wall.

9 On the Options Bar, click  .

10 In the Element Properties dialog, click Edit/New.

11 In the Type Properties dialog, do the following:

■ Click Rename.

■ In the Rename dialog, under New, enter Generic 18" [450 mm],
and click OK.

■ Under Structure, click Edit for Value.

■ In the Edit Assembly dialog, click the value for Layer 2
Thickness, enter 1' 6" [450 mm], and click OK.

■ Click Apply, and then click OK.

12 In the Element Properties dialog, click OK.

13 Select one of the walls, press Ctrl, and select the remaining walls.
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14 On the Options Bar, click  .

15 In the Element Properties dialog, under Constraints, do the
following:

■ For Base Constraint, select Foundation.

■ For Base Offset, enter 0' 0" [0.0 mm].

■ For Top Constraint, select Up to level: Level 4.

■ Click OK.

16 Proceed to the next exercise, Adding Horizontal Framing on page
14.

Adding Horizontal Framing

In this exercise, you frame Level 1M by adding horizontal beams.

Add beams to Level 1M

1 In the Project Browser ➤ Structural Plans, double-click Level 1M.

2 On the Modelling tab of the Design Bar, click Beam.

3 In the Type Selector, select Concrete-Rectangular Beam: 12 x 24
[300 x 600 mm].

4 Select a column center, and draw a beam from column to column.
Then continue framing the bays with concrete beams as shown.

5 Press ESC twice to finish adding beams.
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Add a beam system

6 On the Modelling tab of the Design Bar, click Beam System.

7 On the Options Bar, click  .

8 In the Element Properties dialog, do the following:

■ Under Layout Rule, select Fixed Number.

■ Under Number of Lines, enter 3.

■ Under Beam Type, select Concrete-Rectangular Beam: 12 x 24
[300 x 600 mm].

■ Click OK.

9 Select the beam in the upper-left bay as shown.

NOTE The dotted lines represent the beam system direction. The
longitudinal axis of the beam system members will be placed parallel
to these lines.

10 Click to place the beam system.

11 Use the same technique to place beam systems in 3 additional
bays as shown.
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12 Proceed to the next exercise, Adding Slabs and Columns on page
16.

Adding Slabs and Columns

In this exercise, you add concrete slabs and columns to the remaining levels
of the structure.

1 Add slabs to Level 1M.

■ In the Project Browser ➤ Structural Plans, double-click Level
1M.

■ On the Modelling tab of the Design Bar, click Slab.

■ On the Design Bar, click Floor Properties.

■ In the Element Properties dialog, select 6" Concrete
[Concrete-Commercial 362 mm] for Type, and click OK.

■ On the Design Bar, click Lines.

■ Sketch lines along the building perimeter as shown.
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■ On the Design Bar, click Finish Sketch.

2 Using the same technique, add an additional slab to Level 1M as
shown.

3 Copy columns from Level 1M to Level 2M.

■ In the Project Browser ➤ Structural Plans, double-click Level
1M.

■ Right-click the column at grid location B1, and click Select All
Instances.

■ Click Edit menu ➤ Copy to Clipboard.

■ Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

■ In the Select Levels dialog, select Level 2M, and click OK.

Adding Slabs and Columns | 17



■ On the Options Bar, click  .

■ In the Element Properties dialog, under Constraints, select
Level 1M for Base Level, select Level 2M for Top Level, enter
0' 0" [0 mm] for Base Offset, and click OK.

■ Use the same technique to copy all instances of columns
located at grid J3.

■ On the Design Bar, click Modify.

4 Copy slabs from Level 1M to Level 2M.

■ In the Project Browser ➤ Structural Plans, double-click Level
1M.

■ Click one of the slabs on Level 1M, press CTRL and select the
remaining slabs.

■ Click Edit menu ➤ Copy to Clipboard.

■ Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

■ In the Select Levels dialog, select Level 2M, and click OK.

5 Extend columns to Level 4.

■ In the Project Browser ➤ Structural Plans, double-click Level
2M.

■ Draw a pick box around all structural elements as shown.
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■ On the Options Bar, click  .

■ In the Filter dialog, click Check None, select Structural
Columns, and click OK.

■ Click Edit menu ➤ Copy to Clipboard.

■ Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

■ In the Select Levels dialog, select Level 4, and click OK.

■ In the Project Browser ➤ Structural Plans, double-click Level
4.

■ On the Options Bar, click  .

■ In the Element Properties dialog, under Constraints, select
Level 2M for Base Level, select Level 4 for Top Level, enter 0'
0" [0.0 mm] for Base Offset, and click OK.
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6 Create a slab at Level 4.

■ In the Project Browser ➤ Structural Plans, double-click Level
4.

■ On the Modelling tab of the Design Bar, click Slab.

■ On the Sketch tab, click Floor Properties.

■ In the Element Properties dialog, select 6" Concrete
[Concrete-Commercial 362 mm] for Type, and click OK.

■ On the Design Bar, click Lines.

■ Sketch lines along the building perimeter using the
exterior-most model lines of the columns as snap points, and
then sketch along the beams as shown.

■ On the Design Bar, click Finish Sketch.
In the Revit dialog, click No when asked if you want to attach
the shear walls to the bottom of the slab.

7 Add a shaft opening to Level 4.

■ In the Project Browser ➤ Structural Plans, double-click Level
4.

■ On the Modelling Tab of the Design Bar, click
Opening ➤ Opening By Face.
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■ Select the slab.

■ Sketch lines along the outside face of the shear walls as shown.

■ On the Design bar, click Finish Sketch.

8 Extend the structure to Level 5.

■ In the Project Browser ➤ Structural Plans, double-click Level
4.

■ Draw a pick box around all structural elements.

■ On the Options Bar, click  .

■ In the Filter dialog, click Check None.

■ In the Filter dialog, select Floors, Floor Opening Cut, and
Structural Columns, and click OK.

■ Click Edit menu ➤ Copy to Clipboard.

■ Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

■ In the Select Levels dialog, select Level 5, and click OK.
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■ In the Project Browser ➤ Structural Plans, double-click Level
5.

■ On the Options Bar, click  .

■ In the Filter dialog, click Check None.

■ In the Filter dialog, select Structural Columns, and click OK.

■ On the Options Bar, click  .

■ In the Element Properties dialog, under Constraints, select
Level 4 for Base Level, select Level 5 for Top Level, enter 0' 0"
[0 mm] for Base Offset, and click OK.

9 Extend the structure to Level 11.

■ In the Project Browser ➤ Structural Plans, double-click Level
5.

■ Draw a pick box around all structural elements.

■ Click Edit menu ➤ Copy to Clipboard.

■ Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

■ In the Select Levels dialog, select Levels 6 through 11, and
click OK.

10 Extend the shear wall to Level 11.

■ In the Project Browser ➤ Structural Plans, double-click Level
4.

■ Select all 4 shear walls.

■ On the Options Bar, click  .

■ In the Element Properties dialog, under Constraints, select up
to Level: Level 11 for Top Constraint, and click OK.

11 Set the concrete floor height offset.

■ In the Project Browser ➤ Structural Plans, double-click Level
11.

■ Select the concrete floor slab.
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■ On the Options Bar, click  .

■ In the Element Properties dialog, under Constraints, enter 0'
6" [150 mm] for Height Offset From Level, and click OK.

12 Proceed to the next exercise, Adding Isolated Foundations on page
23.

Adding Isolated Foundations

In this exercise, you add isolated foundations to column locations.

Place isolated foundations under each column

1 In the Project Browser ➤ Structural Plans, double-click Foundation.

2 On the Modelling tab of the Design Bar, click
Foundation ➤ Isolated.

3 In the Type Selector, select Footing-Rectangular: 72" x 48" x 18"
[1800 x 1200 x 450 mm].

4 Place a foundation by snapping to the midpoint of one the
columns.

5 On the Design Bar, click Modify.

6 Select the foundation.

7 On the Options Bar, click  .

8 In the Element Properties dialog, click Edit/New.

9 In the Type Properties dialog, do the following:

■ Click Rename, and in the Rename dialog, enter 10' x 10' x 24"
[3000 x 3000 x 600 mm] under New, and click OK.

■ Under Dimensions, for Width and Length, enter 10' [3000
mm].

■ Under Dimensions, for Thickness, enter 2' 0" [600 mm].

■ Click Apply, and then click OK.

10 In the Element Properties dialog, click OK.

11 Snapping to the midpoints of the remaining columns, click to
place isolated foundations in the locations shown.
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Place a foundation under the elevator shaft

12 In the Project Browser ➤ Structural Plans, double-click Foundation.

13 On the Modelling tab of the Design Bar, click Foundation ➤ Slab.

You are now in sketch mode.

14 On the Design Bar, click Floor Properties.

15 In the Element Properties dialog, click Edit/New.

16 In the Type Properties dialog, do the following:

■ Click Rename.

■ In the Rename dialog, under New, enter 36" Floor Slab [900
mm Floor Slab], and click OK.

■ Under Construction, click Edit for Structural.

■ Under Thickness for Layer 2, enter 3' 0" [900 mm].

■ Click OK.

■ In the Type Properties dialog, click OK.

17 In the Element Properties dialog, click OK.
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18 On the Design bar, click Lines.

19 Sketch the slab approximately as shown.

20 On the Design Bar, click Finish Sketch.

View the structure in 3D

21 On the View Toolbar, click  .

22 On the View Control bar, for Model Graphics Style, select Shading
with Edges.

23 In an empty part of the drawing area, right-click, and select Zoom
to Fit.

24 Click the ViewCube to rotate the model until it appears as shown.
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25 Proceed to the next exercise, Viewing the Analytical Model on
page 26.

Viewing the Analytical Model

In this exercise, you view the analytical model and add a dead load to a
concrete slab.

View the analytical model

1 In the Project Browser ➤ 3D Views, double-click View 1 -
Analytical.

2 On the View Control bar:

■ For Detail Level, select Fine.

■ For Model Graphics Style, select Wireframe.
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3 On the View toolbar, click  , and draw a zoom box around
the one of the beam systems located on Level 1M.

Structural elements within the analytical view are displayed by
the following colors: brown lines indicate slabs, blue lines indicate
columns, and orange lines indicate beams.

4 Select one of the beams.

5 On the Options Bar, click  .

6 In the Element Properties dialog, scroll down to the Analytical
Model parameter.

Notice the default setting for Vertical Projection is Auto-detect.

7 Click OK.

Add a dead load to the Level 11 slab

8 In the Project Browser ➤ 3D Views, double-click View 1 -
Analytical.

9 Click View menu ➤ Visibility/Graphics.
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10 In the Visibility/Graphic Overrides dialog, click the Model
Categories tab, and under Visibility, select Structural Load Cases
and Structural Loads, and click OK.

11 On the Modelling tab of the Design Bar, click Loads.

12 On the Options Bar, click  .

NOTE Be sure to click the Area Load with Host option. Use the
Tooltips to be sure you click the correct option.

13 In the Type Selector, select Area Loads: Area Load 1.

14 Select the slab perimeter on Level 11.

15 In the Project Browser ➤ Views (all) ➤ Structural Plans,
double-click Level 11.

16 On the Design Bar, click Modify to exit the Loads tool.

17 Right-click on the load, and click Element Properties.

18 In the Element Properties dialog, for the Fz 1 parameter, enter
-0.0300 ksf [-1.40 kN/m2], and click OK.

19 On the Design Bar, click Modify.

20 On the View Toolbar, click  to view the 3D View of the area
load.
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21 Proceed to the next exercise, Creating Sheets and Adding Views
on page 29.

Creating Sheets and Adding Views

In this exercise, you place an elevation view, a plan view, and a 3D view on
a sheet.

Create a sheet and place views on the sheet

1 Click View menu ➤ New ➤ Sheet.

2 In the Select a Titleblock dialog, select E1 30x42 Horizontal [A1
Metric], and click OK.

3 In the Project Browser ➤ Sheets, right-click on the S-1-Unnamed
sheet, and click Rename.

4 In the Rename dialog, do the following:

■ For Number, enter S-1.

■ For Name, enter Plans and Elevations.

■ Click OK.

5 Add a plan view to the sheet.

■ In the Project Browser ➤  Sheets, click on S-1, Plans and
Elevations.

■ On the View tab of the Design Bar, click Add View.

■ In the Views dialog, select Structural Plan: Level 1M, and click
Add View to Sheet.
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■ Click on the upper-left portion of the sheet to place the view.

■ Drag the view as necessary to position it on the sheet.

■ Adjust the length of the title line by clicking the view, then
dragging an end control such that the line fits under the view.

6 Add an elevation view to the sheet.

■ On the View tab of the Design Bar, click Add View.

■ In the Views dialog, select Elevation: Building Elevation
[Elevation: North], and click Add View to Sheet.

■ Click on the lower-right portion of the sheet to place the view.

■ Drag the view as necessary to position it on the sheet.

■ Adjust the length of the title line by dragging an end control
such that the line fits under the view.

7 Add a 3D view to the sheet.

■ On the View tab of the Design Bar, click Add View.

■ In the Views dialog, select 3D View: 3D, and click Add View
to Sheet.

■ Click on the upper-right portion of the sheet to place the view.

■ Right-click on this view, and click Element Properties.

■ In the Element Properties dialog, specify 1/16"=1'- 0" [1:200]
for View Scale, and click OK.

■ Drag the view as necessary to position it on the sheet
approximately as shown
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.

■ Adjust the length of the title line by dragging an end control
such that the line fits under the view.

Sheet views update automatically when you modify your model.

8 Proceed to the next lesson, Creating a Steel Structure on page 31

Creating a Steel Structure
In this lesson, you import an AutoCAD architectural plan to use as the basis
of your model. You then create a steel structural model using the tools available
in Revit Structure. You begin by adding columns from Ground Level to Level
2. You copy columns by using the Paste-align command to add structure to
other levels. You also learn how to splice the columns. After you copy columns,
you add horizontal framing to an area of Level 2, and then copy this framing
to other levels.
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Importing an AutoCAD Drawing File

In this exercise, you learn how to import an AutoCAD drawing for use with
your project. You will import the Level 2 drawing for use as a background.

Training File

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_rst_gsg.rvt [m_rst_gsg.rvt] located in the Imperial [Metric] folder.

Import the drawing

1 In the Project Browser ➤ Views (all) ➤ Structural Plans,
double-click Level 2.

2 Click File menu ➤ Import/Link ➤ CAD Formats.

3 In the Import/Link dialog:

■ In the left pane, click the Training Files icon, and select
i_rst_gsg_Level2.dwg [m_rst_gsg_Level2.dwg] located in the
Imperial [Metric] folder.

■ Select Current view only.

NOTE Selecting Current View Only will prevent the DWG file
from appearing in all other views.

■ For Colors, select Black and White.

■ For Positioning, select Auto - Center to Center.

■ Click Open.
Exterior facade outlines, stairs, elevator opening symbols, and
a few basic interior walls and doors display in the view.

4 Click View menu ➤ Visibility/Graphics.

5 In the Visibility/Graphic dialog, select the Imported Categories
tab.

6 Select Halftone for value of i_rst_gsg_Level2.dwg
[m_rst_gsg_Level2.dwg] and click OK.

The imported drawing file is halftoned, so that you may use it as
a background drawing for placing grid lines and columns.
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7 Proceed to the next exercise, Adding Grid Lines on page 33.

Adding Grid Lines

In this exercise, the halftone drawing file is used as a background for placing
grid lines.

Add grid lines using the imported drawing

1 On the Drafting tab of the Design Bar, click Grid.

2 On the Options Bar, click  .

3 On the View Toolbar, click  , and zoom into the first vertical
grid line on the left.

4 Select the left, vertical grid line.

By selecting each grid line in the linked drawing, you are creating
new grid lines in your Revit Structure model.

5 Click the value in the grid head and enter A.

New grid lines are labelled in alphabetical sequence.

6 Select the next vertical grid line to the right of grid A. Notice it is
grid B.

7 Select the remaining vertical grid lines moving left to right. Zoom
in and out as needed.

NOTE When you get to grid I, change the value to J. The last vertical
grid is K.

8 Select the first horizontal grid line.

9 Click the value in the grid head and enter 1.

10 Select the remaining horizontal grid lines.

The last horizontal grid line is 5.

11 Proceed to the next exercise, Adding Structural Columns on page
34.
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Adding Structural Columns

In this exercise, you load a new column type from the Revit Structure Library,
and add columns at each grid intersection. These columns extend from an
elevation to a splice elevation just above Level 2.

Set the Level

1 In the Project Browser, double-click Level 2.

NOTE Some structural columns are already placed in the model at
off-grid locations where there are architectural columns.

2 On the keyboard, enter ZF.

This is the keyboard shortcut for Zoom to Fit.

Place columns at grid intersections

3 If the Modelling tab of the Design Bar is not displayed, right-click
in the Design Bar, and click Modelling.

4 On the Modelling tab of the Design Bar, click Structural Column.

34 | Chapter 1   Getting Started Guide



5 In the Type Selector, select W-Wide Flange-Column:W10x33
[W-Wide Flange-Column: W250x38.5].

6 In the Options Bar, click  .

NOTE When you use the Grid Intersection tool to place columns,
Revit Structure places columns, such that the top of column is at the
current level, and the base of the column is at the level below.

7 Press CTRL and select all of the grid lines.

8 On the Options Bar, click Finish.

9 Press ESC once to finish placing the columns.

You will notice that columns are placed at each grid intersection,
and that there are a few extraneous columns on grid line
intersections that are exterior to the structure.

10 Select the columns that are outside of the building footprint, and
press DEL.

Specify base and top of column elevations and splicing

11 Select any one of the columns that you previously added,
right-click on the column, and click Select All Instances.

12 In the Options Bar, click  .

13 In the Element Properties dialog:

■ Under Constraints, enter 2'- 0" [600 mm] for Base Offset.

■ Under Constraints, enter 2'- 0" [600 mm] for Top Offset.

■ Click OK.

14 Proceed to the next exercise, Adding New Levels on page 35.

Adding New Levels

In this exercise, you add levels to the structure.

Create new levels

1 In the Project Browser, double-click South Elevation to make this
the current view.
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2 On the View Toolbar, click  , and zoom in on the levels.

3 On the Drafting Tab of the Design Bar, click Level.

4 Draw a new level:

■ Start the level line above Level 2.

■ Align the endpoint with the level heads of the existing
elevations.

This new level is automatically named Level 3. A new structural
plan view by the same name is also created automatically.

5 Select the temporary vertical dimension and specify 10'-0" [3000
mm] for the Level elevation.

6 Press ESC to exit the Level command.

7 Using the same method, create a new Level 4 elevation at 30'- 0"
[9000 mm].

Copy the columns to new levels

8 In the Project Browser ➤ Structural Plans, double-click Level 2.

You copy the columns to new levels by first copying the set of
columns at grid intersections, and then by copying the set of
columns that are not on grid intersections. This is necessary
because each column set represents a different column type.

9 Right-click a column that is on a grid intersection, and click Select
All Instances.

10 Click Edit menu ➤ Copy to Clipboard.

11 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

12 In the Select Levels dialog, hold SHIFT and select Level 3 and Level
4.

13 Right-click a column that is not on a grid intersection, and click
Select All Instances.

14 Click Edit menu ➤ Copy to Clipboard.

15 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

16 In the Select Levels dialog, hold SHIFT and select Level 3 and Level
4.

17 Click OK.

18 In the Project Browser ➤ Elevations, double-click South Elevation.
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19 Select grid K, and drag all grid heads above Level 4 as shown.

20 Proceed to the next exercise, Adding Horizontal Framing  on page
37.

Adding Horizontal Framing

In this exercise, you frame four bays of Level 2 by adding horizontal members
and a steel deck.

Select the girder from the Type Selector

1 In the Project Browser ➤ Structural Plans, double-click Level 2.

2 On the Modelling tab of the Design Bar, click Beam.

3 In the Type Selector, select W-Wide Flange W18x40 [UB-Universal
Beam:356x171x51UB].

4 On the keyboard, enter ZF.

This is the keyboard shortcut for Zoom to Fit.

5 On the View toolbar, click  , and draw a zoom box around
the east area of the structure as shown.
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Use the Grid Tool

6 You add some of the girders by using the grid tool. Others you
add individually.

On the Options Bar:

■ Specify Level 2 for Plane

■ Specify Girder for Usage

■ Click Grid.

7 Press CTRL, and select grids H and J.

8 On the Options Bar, click Finish.

Add remaining girders to the four bays

9 On the Options Bar:

■ Specify Level 2.

■ Set Usage to Girder.
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10 Select a column center, and draw a girder from column to column,
framing the bays with girders.

11 Press ESC twice to finish adding girders.

12 Delete the girders between grid intersections H4 and H5, and J4
and J5 as shown.

Set top of steel

13 Right-click a girder, and Select All Instances.
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14 On the Options Bar, click  .

15 In the Element Properties dialog, do the following:

■ Under Constraints, for z - Direction Justification, select Other.

■ Under Constraints, for z-Direction Offset Value, enter - 0' 7"
[-400mm].

■ Click OK.

Copy the girders to levels above

16 Click Edit menu ➤ Copy to Clipboard.

17 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

18 In the Select Levels dialog, select Level 3 and Level 4.

19 Click OK.

20 Proceed to the next exercise, Adding a Beam System on page 40.

Adding a Beam System

In this exercise, you add a beam system to the structure.

Add a beam system to the top two bays

1 In the Project Browser ➤ Structural Plans, double-click Level 2.

2 On the Modelling tab of the Design Bar, click Beam System.

3 On the Options Bar, click  .

4 In the Element Properties dialog, do the following:

■ Under Constraints, enter -0' 7" [-400 mm] for Elevation.

■ For Layout Rule, select Fixed Distance.

■ For Fixed Spacing, enter 6'-0" [1800 mm].

■ For Justification, select Center.

■ For Beam Type, select W-Wide Flange: W14x22 [UB-Universal
Beam: 254x102x28UB].

■ Click OK.

5 Select the girder in the upper-left bay as shown.
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NOTE The dotted lines represent the beam system direction. The
longitudinal axis of the beam system members will be placed parallel
to these lines.

6 Click to place the beam system.

7 On the Options Bar, click  .

8 In the Element Properties dialog, do the following:

■ Under Constraints, enter -0' 7" [-400 mm] for Elevation.

■ For Layout Rule, select Fixed Number.

■ For Number of Lines, enter 2.

■ For Beam Type, select W-Wide Flange: W14x22 [UB-Universal
Beam: 254x102x28UB].

■ Click OK.

9 Select the girder in the upper-right bay as shown.
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10 Click to place the beam system.

11 On the Options Bar, click  .

12 In the Element Properties dialog, do the following:

■ Under Constraints, enter -0' 7" [-400 mm] for Elevation.

■ For Layout Rule, select Fixed Number.

■ For Number of Lines, enter 3.

■ For Beam Type, select W-Wide Flange: W14x22 [UB-Universal
Beam: 254x102x28UB].

■ Click OK.

13 Select the top girder in the lower-left bay as shown.
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14 Click to place the beam system.

15 Select the top girder in the lower-right bay as shown.

16 Click to place the beam system.

17 Press ESC.

18 Hold the cursor over a grid line where there is a beam system, and
press TAB until the beam system highlights.

19 Right-click on the beam system, and click Select All Instances.

20 Click Edit menu ➤ Copy to Clipboard.

21 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

22 In the Select Levels dialog, select Level 3, press SHIFT and select
Level 4.

23 Click OK.

24 In the Project Browser ➤ 3D Views, double-click East Section -
Perspective.
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25 Proceed to the next exercise, Adding a Composite Deck on page
44.

Adding a Composite Deck

In this exercise, you add a composite deck to the structure.

Add a composite deck to level 2

1 In the Project Browser ➤ Structural Plans, double-click Level 2.

2 On the Modelling tab of the Design Bar, click Slab.

3 On the Sketch tab, click Floor Properties.

4 In the Element Properties dialog, do the following:

■ Select 3" LW Concrete on 2" Metal Deck [Concrete-Commercial
362 mm] for Type.

■ Under Constraints, specify -2" [-50 mm] for Height Offset from
Level.

■ Click OK.

5 On the Design Bar, click Lines.

6 Sketch lines along the building perimeter using the exterior-most
model lines of the glazing as snap points, and then sketch along
the girders.

7 On the Design Bar, click Finish Sketch.
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Revit Structure provides a deck span direction symbol when the
deck is placed. The filled half-arrows of this symbol represent the
span of the deck.

Copy the slab to other levels

8 Select the slab.

9 Click Edit menu ➤ Copy to Clipboard.

10 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

11 In the dialog, select Level 3 and Level 4 and click OK.

12 In the Project Browser ➤ 3D Views, double-click East Section -
Perspective.
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13 Proceed to the next exercise, Adding Isolated Foundations on page
46.

Adding Isolated Foundations

In this exercise, you add isolated foundations to column locations.

Place isolated foundations

1 In the Project Browser ➤ Structural Plans, double-click Level 2.

2 On the View toolbar, click  , and draw a zoom box around
the east area of the structure.

3 Draw a pick box around all structural elements as shown.
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4 On the Options Bar, click  .

5 In the Filter dialog, do the following:

■ Click Check None.

■ Select Structural Columns.

■ Click OK.

6 On the Options Bar, click  .

7 In the Element Properties dialog, do the following:

■ Under Constraints, enter 0' 0" [0 mm] for Base Offset.

■ Under Analytical Model, select Level 2 for Top Vertical
Projection.

■ Under Analytical Model, select Ground Level for Bottom
Vertical Projection.

■ Click OK.

8 In the Project Browser ➤ Structural Plans, double-click Ground
Level.
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9 On the Modelling tab of the Design Bar, click
Foundation ➤ Isolated.

10 In the Type Selector, choose Footing-Rectangular: 72"x48"x18"
[1800x1200x450 mm].

11 Snap the cursor to the midpoint of the columns in the area where
you have added horizontal framing to place an isolated foundation
at each location.

By default, each foundation is placed at Ground Level.

12 Press ESC twice to finish placing foundations.

13 Proceed to the next exercise, Viewing the Analytical Model on
page 48.

Viewing the Analytical Model

In this exercise, you view the analytical model.
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View the analytical model

1 In the Project Browser ➤ 3D Views, double-click View 1 -
Analytical.

2 On the View Control bar:

■ Select Detail Level: Fine.

■ Select Model Graphic Style: Wireframe.

3 On the View toolbar, click  , and draw a zoom box around
the east area of the structure.

Structural elements within the analytical view are displayed by
the following colors: brown lines indicate slabs, blue lines indicate
columns, and orange lines indicate beams.

4 Select one of the beams.

5 On the Options Bar, click  .

6 In the Element Properties dialog, scroll down to the Analytical
Model parameter.
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Notice the default setting for Vertical Projection is set to
Auto-detect.

7 Click OK.

8 Proceed to the next exercise, Adding a Load to Level 4 on page
50.

Adding a Load to Level 4

In this exercise, you add an area load to Level 4 of the structure.

Add an area load at level 4 slab

1 In the Project Browser ➤ 3D Views, double-click View 1 -
Analytical.

2 On the Modelling tab of the Design Bar, click Loads.

3 On the Options Bar, click  .

NOTE Be sure to click the Area Load with Host option. Use the
Tooltips to be sure you click the correct option.

4 In the Type Selector, select Area Loads: Area Load 1.

5 Select the slab perimeter on Level 4.

6 In the Project Browser ➤ Views (all) ➤ Structural Plans,
double-click Level 4.
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7 On the Design Bar, click Modify to exit the Loads tool.

8 Right-click on the load, and select Element Properties.

9 In the Element Properties dialog, enter -0.0300 ksf [-0.1330 kN]
for the Fz 1 parameter, and click OK.

10 Proceed to the next exercise, Creating Sheets and Adding Views
on page 51.

Creating Sheets and Adding Views

In this exercise, you place a plan, elevation, 3D, and callout view on a sheet.

Create a sheet and place views on the sheet

1 Click View menu ➤ New ➤ Sheet.

2 In the Select a Titleblock dialog, select E1 30x42 Horizontal [A1
Metric] and click OK.

3 In the Project Browser ➤ Sheets, right-click on the S-1-Unnamed
sheet, and click Rename.

4 In the Rename dialog, do the following:

■ For Number, enter S-1.
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■ For Name, enter Plans and Elevations.

■ Click OK.

Add plan view

5 In the Project Browser ➤ Sheets (all), double-click S-1 Plans and
Elevations.

6 On the View tab of the Design Bar, click Add View.

7 In the Views dialog, select Structural Plan: Level 2, and click Add
View to Sheet.

8 Click on the sheet to place the view of the structural plan.

9 Right-click on this view, and click Element Properties.

10 In the Element Properties dialog, specify 1/16"=1'- 0" [1:200] for
View Scale, and click OK.

11 Drag the view as necessary to position on the sheet.

12 Adjust the length of the title line by dragging an end control such
that the line fits under the view.

Add elevation view

13 On the Design Bar, click Add View.

14 In the Views dialog, select Elevation: South Elevation, and click
Add View to Sheet.

15 Click on the sheet to place the view.

16 On the Options Bar, click  .

17 Specify 1/16"=1'- 0" [1:200] for View Scale, and click OK.

18 Drag the view as necessary to position on the sheet.

19 Adjust the length of the title line by dragging an end such that
the line fits under the view.

Add 3D view

20 On the Design Bar, click Add View.

21 In the Views dialog, select 3D View: East Section - Perspective,
and click Add View to Sheet.

22 Click on the sheet to place the view.

23 Drag the view as necessary to position on the sheet.
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Create a callout view

24 In the Project Browser ➤ Structural Plans, double-click Ground
Level.

25 On the View tab, click Callout.

26 Sketch a callout as shown.

Add callout view to sheet

27 In the Project Browser, right-click on S-1, Plans and Elevations,
and click Add View.

28 In the Views dialog, click Structural Plans: Callout of Ground
Level, and then click Add View to Sheet.

29 Click on the sheet to place the view.

30 On the Options Bar, click  .

31 Specify 1/8"=1'- 0" [1:96] for View Scale.

32 Specify Fine for Detail Level.

33 Click OK.

34 Drag the view as necessary to position on the sheet.
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You have completed the Revit Structure 2009 Getting Started
Guide.
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