## Contents

### Chapter 1  Understanding Autodesk MapGuide® Studio  

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>What is New in Autodesk MapGuide Enterprise 2011?</td>
<td>1</td>
</tr>
<tr>
<td>Sample Data Available in Autodesk MapGuide Enterprise</td>
<td>2</td>
</tr>
<tr>
<td>Real World Data from Data Providers</td>
<td>3</td>
</tr>
<tr>
<td>City of Grand Forks, North Dakota</td>
<td>3</td>
</tr>
<tr>
<td>City of Redding, California</td>
<td>4</td>
</tr>
<tr>
<td>Institut Geographique National, France</td>
<td>4</td>
</tr>
<tr>
<td>NAVTEQ Data</td>
<td>5</td>
</tr>
<tr>
<td>DigitalGlobe Imagery</td>
<td>5</td>
</tr>
<tr>
<td>Sample Maps</td>
<td>5</td>
</tr>
<tr>
<td>Symbols</td>
<td>6</td>
</tr>
<tr>
<td>Getting Additional Geospatial Data to Enhance Your Maps</td>
<td>6</td>
</tr>
<tr>
<td>The MapGuide Studio Interface</td>
<td>7</td>
</tr>
<tr>
<td>Understanding Resources</td>
<td>8</td>
</tr>
<tr>
<td>Resource Diagram</td>
<td>9</td>
</tr>
<tr>
<td>Web Layouts</td>
<td>9</td>
</tr>
<tr>
<td>Maps</td>
<td>9</td>
</tr>
<tr>
<td>Layers</td>
<td>10</td>
</tr>
<tr>
<td>Data Resources</td>
<td>10</td>
</tr>
<tr>
<td>Load Procedures</td>
<td>10</td>
</tr>
<tr>
<td>Symbol Libraries</td>
<td>10</td>
</tr>
<tr>
<td>Print Layouts</td>
<td>11</td>
</tr>
<tr>
<td>Starting the Application and Connecting to a Site</td>
<td>11</td>
</tr>
</tbody>
</table>
Basic Layout Viewer .................................................. 130
Setting Up the Web Layout ........................................ 130
  Creating a New Basic Web Layout ............................ 130
  Specifying General Web Layout Settings .................. 130
  Specifying Viewer Components to Display ................. 132
  Customizing Task Bar Buttons ............................... 134
Defining the Viewer Toolbar, Context Menu, and Task Pane
  Menu .................................................................... 135
  Customizing the Viewer Toolbar .............................. 135
  Customizing the Context Menu ............................... 136
  Customizing the Task Bar Menu .............................. 137
  Creating Flyouts .................................................. 138
  Restoring Toolbar, Context Menu, and Task Bar Menu
    Defaults ............................................................ 138
  Duplicating the Toolbar, Context Menu, and Task Bar
    Menu .................................................................... 138
Customizing Commands ................................................ 139
  Basic Command Settings ....................................... 139
  Creating New Basic Commands ............................... 140
  Creating New Advanced Commands .......................... 141
  Creating an Invoke Script Command ...................... 142
  Creating an Invoke URL Command ............................ 142
  Creating a Search Command ................................... 143
  Creating a Print Command ...................................... 144
Previewing the Web Layout ......................................... 144
  Previewing the Web Layout in MapGuide Studio .......... 145
  Previewing the Web Layout in a Browser ................... 145

Chapter 7 Working with Symbols ................................. 147
  Creating a New Symbol Library .............................. 147
  Importing Images into a Symbol Library .................. 148
  Importing Font Characters as Symbols .................... 148
  Deleting Symbols .................................................. 149
  Copying Symbols .................................................. 149

Chapter 8 Setting Options ........................................... 151
  Setting Site Explorer Options ................................. 151
  Setting Layer Editor Options ............................... 151
  Setting Viewer Options ....................................... 152

Chapter 9 Working with Print Layouts ......................... 153
  Creating Print Layouts ........................................... 153
  Print Layout Schema ............................................. 156
  Print Layout Sample ............................................. 160
<table>
<thead>
<tr>
<th>Aggregate Options</th>
<th>238</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Chapter 12  Tips and Troubleshooting</strong></td>
<td>243</td>
</tr>
<tr>
<td><strong>Tips</strong></td>
<td></td>
</tr>
<tr>
<td>Adding a Custom Logo</td>
<td>243</td>
</tr>
<tr>
<td>Using Packages to Load Large Resources</td>
<td>243</td>
</tr>
<tr>
<td>Connecting to External Databases Using a Connection String</td>
<td>244</td>
</tr>
<tr>
<td><strong>Troubleshooting</strong></td>
<td></td>
</tr>
<tr>
<td>Troubleshooting Fonts</td>
<td>245</td>
</tr>
<tr>
<td>Troubleshooting SHP Files</td>
<td>246</td>
</tr>
<tr>
<td>Troubleshooting MapGuide Enterprise</td>
<td>246</td>
</tr>
<tr>
<td><strong>Index</strong></td>
<td>249</td>
</tr>
</tbody>
</table>
Use MapGuide Studio to assemble resources into a web layout that your users can view and interact with across a network. Resources include spatial and attribute data from files or databases, raster images, symbols, maps, and layers.

Before building a web layout, you need to understand the MapGuide Studio interface and its resources.

What is New in Autodesk MapGuide Enterprise 2011?

Welcome to Autodesk MapGuide Enterprise 2011. The following list describes what is new in this release.

- You can add base maps from Google Maps™, Yahoo® Maps, and Bing™ Maps applications.
- New widgets available in the Flexible Web Layout viewer include: Theme, Query, Redline, and Measure.
- When consuming WMS and WFS services in MapGuide Enterprise, you can now select which coordinate system to use from the publishing server. In addition, for WMS, you can select image format and transparency.
- MapGuide Studio now fixes references between resources (“broken links”) when the resources are moved or renamed in the repository tree.
- MapGuide Studio is available in French, Italian, German, Spanish, and Japanese. (MapGuide Studio 2010 was available only in English.)
Improved user feedback on session failure

New FDO providers have been added for SQLite and PostgreSQL/PostGIS.

The FDO providers for ESRI® ArcSDE 9.3.1 and Microsoft® SQL Server 2008 SP1 software have been updated.

MapGuide Enterprise Server and Web Extensions now support 64-bit on supported Microsoft Windows® Server operating systems.

Updated internet browser support: Windows Internet Explorer® 8, Firefox® 3.5, Safari® 4, and Chrome™ 4 browsers

OGC® Certified WMS 1.1.1 support

Improved performance of MgMap creation

Dynamic (progressive) Legend Generation

New EULA terms for Virtual Machine use

The DWF Viewer has been removed.

Sample Data Available in Autodesk MapGuide Enterprise

Included with Autodesk MapGuide Enterprise are several kinds of sample data that you can use in different ways to learn and experiment with the product. The available sample data includes the following:

Getting Started Guide Sample Data - This set of sample data is specifically for completing the exercises in chapter 3 of the Getting Started Guide. This data is installed with Autodesk MapGuide Studio in the Sample Data folder in your MapGuideStudio2011 install location.

Sample Viewer Application Sample Data - This data is specifically for use with the Developer's Guide, API, and Viewer Sample Application. For installation instructions, refer to the document Installing Sample Data and Viewer Sample Application, available from the media browser on your Autodesk MapGuide Enterprise CD.

Real World Data from Data Providers- This data is available for you to explore and experiment with before you create your own maps. For more information, see Real World Data from Data Providers on page 3.
Real World Data from Data Providers

Autodesk MapGuide Enterprise comes with an extensive set of sample data that you can explore to get ideas, or experiment with before you create your own maps.

The sample data is available in a separate folder called "Autodesk MapGuide 2011 Sample Data". Depending on which version of the product you have, this folder is located on your product DVD, on a separate CD, or as a separate download.

Because the sample data includes large files (aerial images, database, and so on), the sample data folder is not installed by default. To explore it, you must copy the folder of data to the root of your C: drive.

For all data connections to be correct and connected automatically, the final location of your sample data should be: C:\Autodesk MapGuide 2011 Sample Data. If you put it in a different location, you will need to fix data connections.

The sample data folder includes the data listed below. For more information about the data, see the documentation in the Autodesk MapGuide Sample Data 2011 folder.

City of Grand Forks, North Dakota

This real-world municipal data set include feature data, aerial imagery, and sample maps.
City of Redding, California

A real-world data set from the City of Redding, California, in the United States. Data includes real parcel data, soil drawings, water data, metadata, and more.

Institut Geographique National, France

A comprehensive set of sample data from Institut Geographique National (IGN), the national mapping agency of France. The data covers “department 92” in France. Departments are administrative units of France, roughly analogous to English counties. Department 92 includes several cities just outside of Paris. The area is often called Haute-de-Seine.
**NAVTEQ Data**

NAVTEQ data sets for 3km x 3km areas of seven sample cities from around the world. NAVTEQ data is used in a broad range of location based applications and navigation products and mapping sites. They provide vector data, street centerline map data, and much more. You can use the sample data to get an idea of what NAVTEQ can provide and how you can use to enhance your maps in AutoCAD Map 3D.

**DigitalGlobe Imagery**

Samples of DigitalGlobe imagery for the seven sample cities. DigitalGlobe is a provider of high resolution aerial and satellite imagery.

![Sample Map of London Using the Sample Data from NAVTEQ and DigitalGlobe](image)

**Sample Maps**

Sample maps highlighting sample data from NAVTEQ, DigitalGlobe, and other real-world maps from Redding, Grand Forks, Crater Lake, and more.
Symbols

A copy of the bitmap symbols that are installed with Autodesk MapGuide Studio. Examples are shown below.

Getting Additional Geospatial Data to Enhance Your Maps

As you create maps, you may want to add data to enhance them. For example, you may want to add raster 3D elevation data to help you create 3D maps, add new vector data such as land plots or points of interest, or add satellite imagery for your area.

So that you can get the high resolution precision geospatial data you need quickly, easily and at lower cost, Autodesk has partnered with leading geospatial data providers to provide a geodata portal that gives you access to all the geospatial data you need.

Visit the geodata portal at www.autodesk.com/geodata.

Examples of the types of data available on the portal:

- Aerial and satellite imagery from DigitalGlobe
- 3D raster elevation data from Intermap Technologies
- Vector data such as roads and land parcels from NAVTEQ
The MapGuide Studio Interface

The collection of servers that process MapGuide Studio and Viewer requests is called a site. The servers in each site share a single resource repository, which stores resources used to create web layouts.

In the MapGuide Studio application window, use the Site Explorer to access the resource repository and the editor pane to define and edit resources.

To work with MapGuide Studio you must connect to the site where your resources are stored. The resources on the site are displayed in the Site Explorer. When you double-click a resource, its properties are displayed in the editor, where you can make changes. The features of the editor vary depending on the type of resource you are editing.
The MapGuide Studio interface

You can open multiple resources in the editor pane. Each resource has its own editor. The resource name appears on a tab at the top of the editor. The toolbar at the upper left of the program window contains tools for both the Site Explorer and the various editors. Right-click a site, folder, or resource for additional options.

For more information about resources, see Understanding Resources on page 8.

Understanding Resources

Resources are the data and other elements used to build a MapGuide Studio web layout, including the web layout itself. You can load files from a variety of formats and connect to databases to create data resources.

Resources are displayed in the Site Explorer as you load or create them.

NOTE Resources have associated permissions that control who views and edits them. For more information about permissions, see Setting Permissions on page 66.
**Resource Diagram**

The following diagram shows how you assemble MapGuide Studio resources to build a web layout.

**Web Layouts**

The MapGuide Studio web layout is the highest-level resource in a hierarchy of resources. It is the end product of your work in MapGuide Studio. You can make the web layout available to users directly or embed it in your application.

For more information about creating web layouts, see *Displaying the Map in a Web Browser* on page 115.

**Maps**

Web layouts reference a single map resource. The map resource references one or more layers. Each layer, in turn, references a data resource that provides the content for the layer. You can create new maps in MapGuide Studio, or load maps from Autodesk Map. When you create a new map, you must add layers and then specify the data to use with each layer.

For more information about creating a new map, see *Working with Maps* on page 71. For more information about loading a map, see *About DWG Files* on page 18.
Layers

Maps reference one or more layer resources that contain links to data. Layers are independent MapGuide Studio elements that are displayed in the Site Explorer and can be shared among maps.

For more information about layers, see Working with Layers on page 81.

Data Resources

You can display two types of data in a map: drawing source and feature source.

Drawing sources Preserve styles and themes created using the Display Manager in Autodesk Map or other Autodesk applications. The data is converted to Design Web Format (DWF) so the styles and themes are rendered accurately in the displayed map. You cannot modify these styles and themes.

To make styles and themes available for further analysis and editing, convert the data to SDF when loading. The data becomes feature source data in MapGuide Studio. Styles and themes are preserved and are available for further analysis and modification.

Feature sources Unstyled data that you can stylize and theme in MapGuide Studio. Feature sources are SDF, SHP, and raster files, as well as database connections, including Oracle, ArcSDE, and ODBC. MapGuide Studio also supports WMS and WFS sources.

Load Procedures

These resources control how drawing and feature sources are loaded onto the site repository. For more information, see Accessing Data on page 15.

Symbol Libraries

Symbol library resources contain one or many symbols that can be used when applying styles to points or labels. MapGuide Studio supports numerous file formats.

For more information about working with symbols, see Working with Symbols on page 147.
Print Layouts

Print layouts define the elements to include in the DWF ePlot that is sent to the printer. You can include the following elements in a layout:

- Background color
- Title
- Legend
- Scale bar
- North arrow
- URL
- Date and time
- Custom logo
- Custom text

For more information about print layouts, see Working with Print Layouts on page 153.

Starting the Application and Connecting to a Site

To work with MapGuide Studio you must connect to the site where your resources are stored.

To start MapGuide Studio and connect to your site

1. Click Start menu ➤ Programs ➤ Autodesk ➤ Autodesk MapGuide Studio.
2. Click File menu ➤ Open Site or click File menu ➤ Recent Sites.
3. Select a site name.
4. In the Site Authentication dialog box, enter the URL for the site, your user name, and password.
   Site, User ID, and Password entries are case-sensitive.
   To obtain the site URL, see your administrator. Enter the site URL using the following syntax:
   http://MySiteAddress/mapguide
The Site Explorer displays the site and all available resources. Note that resources have associated permissions that control who views and edits them. For more information about permissions, see Setting Permissions on page 66. For more information about resources, see Understanding Resources on page 8 and Accessing Data on page 15.

Basic Steps for Building a Web Layout

The following steps summarize creating a web layout and provide links to more information.

To build a web layout

1. Start MapGuide Studio and connect to a site.
   For more information, see Starting the Application and Connecting to a Site on page 11.

2. Determine the coordinate system to use for your web layout. For more information, see Setting the Coordinate System for Your Map on page 72.

3. Load or connect to data resources, making them available in the Site Explorer.
   For more information, see Accessing Data on page 15.

4. Load raster images, making them available in the Site Explorer.
   For more information, see Loading Raster Files on page 32.

5. Create symbol library resources to use in point layers.
   For more information about working with symbols, see Working with Symbols on page 147.

6. Define layers to organize your data and customize the display.
   For more information about working with layers to organize and present data, see Working with Layers on page 81.

7. Define a map by adding layers.
   For more information about building a map, see Working with Maps on page 71.
   You can also create a map with associated layers in one step by loading an Autodesk Map drawing with Display Manager elements defined.
8 Define print layouts.
   For more information about print layouts, see Working with Print Layouts on page 153.

9 Create the web layout.
   For more information about creating a web layout, see Displaying the Map in a Web Browser on page 115.

Copyright Information

© 2010 Autodesk, Inc. All Rights Reserved. Except as otherwise permitted by Autodesk, Inc., this publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose.

Certain materials included in this publication are reprinted with the permission of the copyright holder.

Disclaimer

THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE BY AUTODESK, INC. "AS IS." AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS.

Trademarks

The following are registered trademarks or trademarks of Autodesk, Inc., and/or its subsidiaries and/or affiliates in the USA and other countries: 3DEC (design/logo), 3December, 3December.com, 3ds Max, Algor, Alias, Alias (swirl design/logo), AliasStudio, AliasWavefront (design/logo), ATC, AUGC, AutoCAD, AutoCAD Learning Assistance, AutoCAD LT, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, Autodesk, Autodesk Envision, Autodesk Intent, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSnap, AutoSketch, AutoTrack, Backburner, Backdraft, Built with ObjectARX (logo), Burn, Buzzsaw, CAiCE, Civil 3D, Cleaner, Cleaner Central, ClearScale, Colour Warper, Combustion, Communication Specification, Constructware, Content Explorer, Dancing Baby (image), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, Design Web Format, Discreet, DWF, DWG, DWG (logo), DWG Extreme, DWG TrueConvert, DWG TrueView, DXF, Ecotect, Exposure, Extending the Design Team, Face Robot, FBX, Fempro, Fire,
Flame, Flare, Flint, FMDesktop, Freewheel, GDX Driver, Green Building Studio, Heads-up Design, Heidi, HumanIK, IDEA Server, i-drop, ImageModeler, iMOUT, Incinerator, Inferno, Inventor, Inventor LT, Kaydara, Kaydara (design/logo), Kynapse, Kynogon, LandXplorer, Lustre, MatchMover, Maya, Mechanical Desktop, Moldflow, Moonbox, MotionBuilder, Movimento, MPA, MPA (design/logo), Moldflow Plastics Advisers, MPI, Moldflow Plastics Insight, MPX, MPX (design/logo), Moldflow Plastics Xpert, Mudbox, Multi-Master Editing, Navisworks, ObjectARX, ObjectDBX, Open Reality, Opticore, Opticore Opus, Pipeplus, PolarSnap, PortfolioWall, Powered with Autodesk Technology, Productstream, ProjectPoint, ProMaterials, RasterDWG, RealDWG, Real-time Roto, Recognize, Render Queue, Retimer, Reveal, Revit, Showcase, ShowMotion, SketchBook, Smoke, Softimage, Softimage|XSI (design/logo), Sparks, SteeringWheels, Stitcher, Stone, StudioTools, ToolClip, TopoBase, Toxik, TrustedDWG, ViewCube, Visual, Visual LISP, Volo, Vtour, Wire, Wiretap, WiretapCentral, XSI, and XSI (design/logo).

All other brand names, product names or trademarks belong to their respective holders.

Published by:
Autodesk, Inc.
111 McInnis Parkway
San Rafael, CA 94903, USA
Accessing Data

Before you can build maps and web layouts in Autodesk MapGuide Studio, you must make your source data available. There are three ways to make source data available:

- Load any file-based data, such as DWG, SHP, or SDF. You can also load raster files.
- Configure connections to SDF, SHP, and raster files not loaded into the MapGuide resource repository.
- Configure connections to databases or web services, such as Oracle, ArcSDE, SQL Server, or WMS.

Load data by converting all, or part of, the source file into a format that MapGuide can use, and storing it as a resource. For example, you can load all the layers in a DWG file and create a separate resource for each one.

Connect to SDF, SHP, or raster files without loading them onto the MapGuide resource repository. The files can be located on the same server as MapGuide or on a different server.

Data stored in a database does not need to be loaded. You simply connect to it by configuring a data source for it. In this case, the information necessary to connect to the database is stored as the resource.

All resources are stored in the resource repository on the site server. When you open MapGuide Studio and connect to your site server, the contents of the resource repository are displayed in the Site Explorer.
The Site Explorer provides a view into the resource repository.

Look up your source data format in the following table to find out how to make that data available in MapGuide Studio. Click the links below the table to go to step-by-step instructions.

<table>
<thead>
<tr>
<th>Supported File Format</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autodesk DWG, DXF</td>
<td>Load</td>
</tr>
<tr>
<td>Autodesk DWF</td>
<td>Load</td>
</tr>
<tr>
<td>Autodesk SDF</td>
<td>Load or Configure connection</td>
</tr>
<tr>
<td>SHP (ArcView shapefile)</td>
<td>Load or Configure connection</td>
</tr>
<tr>
<td>Raster formats (.bil, .bmp, .cal, .ecw, .jpg/.jpeg, .png, .sid, .tif/.tiff, .tga)</td>
<td>Load or Configure connection</td>
</tr>
<tr>
<td>ArcSDE database</td>
<td>Configure connection</td>
</tr>
<tr>
<td>MySQL</td>
<td>Configure connection</td>
</tr>
</tbody>
</table>
### Supported File Format

<table>
<thead>
<tr>
<th>Supported File Format</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft SQL Server</td>
<td>Configure connection</td>
</tr>
<tr>
<td>ODBC databases (Microsoft Access, Excel etc.)</td>
<td>Configure connection</td>
</tr>
<tr>
<td>Oracle database</td>
<td>Configure connection</td>
</tr>
<tr>
<td>PostgreSQL/PostGIS</td>
<td>Configure connection</td>
</tr>
<tr>
<td>SQLite</td>
<td>Load or Configure connection</td>
</tr>
<tr>
<td>Microsoft SQL Server Spatial</td>
<td>Configure connection</td>
</tr>
<tr>
<td>Web map service (WMS)</td>
<td>Configure connection</td>
</tr>
<tr>
<td>Web feature service (WFS)</td>
<td>Configure connection</td>
</tr>
</tbody>
</table>

### Loading Files

You load file-based data into the resource repository using load procedures. Load procedures specify the files you want to load and where you want to store the resources created from them.

In the case of DWG files, the load procedures also specify how you want to load each layer or element. For example, a procedure might specify that you want to load a layer called “Buildings” from a DWG file and store it as a resource called “Building outlines,” or another procedure might load all the layers as a single resource.

In MapGuide Studio, there are three ways to load your source files:
Load procedures are displayed in the Site Explorer as resources. You can reuse them, copy them, or modify them. Load procedures are essentially saved scripts for reloading data. You can use load procedures to automate the updating of resources on the server. They capture the location of the source files, the conversion rules, and where to put the resulting data on the server. You can execute these rules (either interactively in MapGuide Studio or through a script) to refresh file-based spatial data on your site. Scripts can be run overnight at regular intervals to keep the data up-to-date.

For more information about automation using scripts, see the Developer’s Guide.

About DWG Files

MapGuide Studio can load only CAD layers from a DWG file. These CAD layers are translated to individual SDF feature classes within a single SDF feature source. If you have xrefs in your DWG, the layers from the externally referenced files can also be loaded.

**NOTE** If you are using Autodesk Map 3D 2011, you can style and theme your maps in the DWG environment and then publish them directly to MapGuide. The Publish to MapGuide command loads the data into the resource repository, creates layers, applies styles, and creates maps, as appropriate. For more information, see your Autodesk Map 3D 2011 documentation.
How DWG Files Are Transformed

DWG files are loaded one at a time. If you have more than one file in the load procedure, the different files are loaded sequentially. For example, if you have several DWG files in the procedure, you will get several resources, each one of which contains the layers of a single drawing, not one resource containing all the layers of all the drawings together.

Loading A DWG

This procedure assumes that you have one or more DWG files that you want to load. To load a DWG file, you drag one or more source files to the Site Explorer. Before you start loading files, you may want to create a folder in the Site Explorer to store the resources produced by the load. To find out how to create the recommended folder structure, see Organizing and Sorting Resources on page 59.

To load a DWG

1. Drag a DWG file from Windows Explorer to the Site Explorer.
   The Load Procedure Editor is displayed to the right of the Site Explorer. The path to, and name of, the DWG source file is displayed at the top. The DWG, with its path information, is displayed under Specify The Source DWG File(s).

2. For Which Components Do You Want To Extract, click Select CAD Layers.

3. In the Select Individual Components dialog box, select the layers you want to load. Then click OK.

4. For How Do You Want To Transform The Data, select the coordinate system you want to use.
   MapGuide Studio cannot detect any coordinate system applied to the DWG. You must assign a coordinate system to apply to all DWGs in this load procedure.

5. Optional: for Generalize The Data By This Percentage, enter a percentage to reduce the number of vertices in the polylines or polygons in the source data.

6. Optional: select Transform Closed Polylines To Polygons to create polygon objects, for example, for parcels that have been drawn with polylines.
7  For Where Do You Want To Load The Resources, accept the defaults or specify a destination folder for the map resource that will be created by this load procedure. (You can also move the map resource later in the Site Explorer.)

8  Click Load Resources.

MapGuide Studio converts each AutoCAD layer into a feature class within a single SDF. You can view the results by double-clicking the SDF or the map in the Site Explorer.

### About SDF Files

There are two types of SDF (Spatial Database Format) files:

- **SDF 2**—Compatible with Autodesk MapGuide 6.5 and earlier.

SDF 2 files contain a single type of data (text, point, polyline, or polygon), and have only three attributes: Key, URL, and Name. Therefore, they are typically associated with external database files to provide table data for theming. SDF 3 files can store both geometry and any table data associated with it.

### Loading SDF Files

This procedure assumes that you have one or more SDF 2 or SDF 3 files that you want to load. To load an SDF file, you drag one or more source files to the Site Explorer. MapGuide Studio converts SDF 2 files to SDF 3 format and automatically creates a new layer for each file as well as a new feature source.

#### To load an SDF file

1  Drag the SDF file or files you want to load into a folder in the Site Explorer.

A new load procedure is displayed to the right of the Site Explorer. It contains a list of the files to load. You can drag other files into this load procedure.
2. For How Do You Want To Transform The Data, select the coordinate system you want to use.

   The coordinate system you select here will be used only if there is no coordinate system already defined for the source file or files.

3. Optional: for Generalize The Data By This Percentage, enter a percentage to reduce the number of vertices in the polylines or polygons in the source data.

4. Under Duplicate Records, select Auto-Generate Unique Keys unless you know that the SDF 2 file already has links to an external database table that you want to preserve, in which case, select Merge Duplicates or Discard Duplicates.

5. For Where Do You Want To Load The Resources, select the destination folder for the resources that will be created by this load. (You can also move the resources later in the Site Explorer.)

6. Click Load Resources.

   MapGuide Studio creates a new feature source and a new layer for each SDF file.

7. Double-click one of the new layers to open it.
The Layer Editor is displayed to the right of the Site Explorer. (For more information about the Layer Editor, see Working with Feature Source Layers on page 82.)

On the MapGuide Studio toolbar, click Save to save the load procedure in the repository. You can rename the new feature sources and the layers in the Site Explorer.

About SHP Files

The SHP format, also known as "shape format" or "shapefile," is published by ESRI and is widely used for data interchange in GIS. Shapefiles store both geometry and attribute data for features. A single shapefile consists of three physical files with the same file name, but different file extensions:

- .shp—Points, polylines, and polygon geometric data can be stored in a shp file. However a single shp file can contain only one type of geometry.
- .shx—Index to the geometric map features
- .dbf—Table data associated with the map features.
There may also be a .prj file, which defines the coordinate system for the shapefile.

**Loading SHP Files**

This procedure assumes that the necessary .shx and .dbf files are in the same folder as the .shp files. To load a shapefile, you drag the source file to the Site Explorer. MapGuide Studio automatically creates a new layer as well as a new feature source.

**To load an SHP file**

1. Drag the SHP file or files you want to load into a folder in the Site Explorer.
   
   A new load procedure is displayed to the right of the Site Explorer. It contains a list of the files to load. You can drag other files into this load procedure.

2. For How Do You Want To Transform The Data, select the coordinate system you want to use.
   
   The coordinate system you select here will be used only if there is no coordinate system already defined for the source file or files.
3 Optional: For Generalize The Data By This Percentage, enter a percentage to reduce the number of vertices in the polylines or polygons in the source data (must convert to SDF).

4 Optional: Clear Convert To SDF Resource if you want to leave the resource in SHP format (generalization is ignored).

5 For Where Do You Want To Load The Resources, select the destination folder for the resources that will be created by this load. (You can also move the resources later in the Site Explorer.)

6 Click Load Resources.
MapGuide Studio creates a new feature source and a new layer for each SHP file.

7 Double-click one of the new layers to open it.
The Layer Editor is displayed to the right of the Site Explorer. (For more information about the Layer Editor, see Working with Feature Source Layers on page 82.)

8 On the MapGuide Studio toolbar, click Save to save the load procedure in the repository.
You can rename the new feature sources and the layers in the Site Explorer.
About SQLite Files

Loading SQLite files is similar to loading SDF files. However, because the SQLite provider already contains unique keys, options for handling duplicate records are unnecessary.

Loading SQLite Files

To load a SQLite file, you drag one or more source files to the Site Explorer. MapGuide Studio automatically creates a new layer for each file as well as a new feature source.

To load a SQLite file

1. Drag the SQLite file or files you want to load into a folder in the Site Explorer.
   A new load procedure is displayed to the right of the Site Explorer. It contains a list of the files to load. You can drag other files into this load procedure.

2. For How Do You Want To Transform The Data, select the coordinate system you want to use.
   The coordinate system you select here will be used only if there is no coordinate system already defined for the source file or files.

3. Optional: for Generalize The Data By This Percentage, enter a percentage to reduce the number of vertices in the polylines or polygons in the source data.

4. For Where Do You Want To Load The Resources, select the destination folder for the resources that will be created by this load. (You can also move the resources later in the Site Explorer.)

5. Click Load Resources.
   MapGuide Studio creates a new feature source and a new layer for each SQLite file.

6. Double-click one of the new layers to open it.
   The Layer Editor is displayed to the right of the Site Explorer. (For more information about the Layer Editor, see Working with Feature Source Layers on page 82.)
7 On the MapGuide Studio toolbar, click Save to save the load procedure in the repository.

You can rename the new feature sources and the layers in the Site Explorer.

About DWF Files

A DWF file is an electronic plot of a source file. It reproduces the appearance of the original drawing, including any stylization or theming. You can use a DWF to add a layer from styles, themes, or layouts which have been created in Autodesk Map or any other program that can write DWF files. This pre-styled data is loaded as a drawing source in MapGuide Studio. The following illustration shows the data sources in a typical DWF file:
A DWF file has two elements that you can select when you create a layer from the DWF drawing source in MapGuide Studio:

- Sheets—Different plot sheets containing views or layouts of the original data. You can select these in the Layer Editor.
Layers—The layers from the original drawing, if the DWF was published from a DWG file. If layers were enabled when the DWF was published, you can turn layers on and off in the Layer Editor.

Loading DWF Files

This procedure assumes that you have one or more DWF files that you want to load. To load a DWF file, you drag the source file to the Site Explorer. MapGuide Studio automatically creates a new layer as well as a new feature source.

To load a DWF file

1 Drag the DWF file or files you want to load into a folder in the Site Explorer.
   A new load procedure is displayed to the right of the Site Explorer. It contains a list of the files to load. You can drag other files into this load procedure.

2 For How Do You Want To Transform The Data, select the coordinate system you want to use.
   DWF files do not have a coordinate system assigned to them, so you always need to specify it.
3 For Where Do You Want To Load The Resources, select the destination folder for the resources that will be created by this load. (You can also move the resources later in the Site Explorer.)

4 Click Load Resources.
MapGuide Studio creates a new drawing source and a new layer for each DWF file.

5 Double-click one of the new layers to open it.
The Layer Editor is displayed to the right of the Site Explorer.

6 Select the drawing sheet and the layers that you want to use.

(For more information about the Layer Editor, see Working with Feature Source Layers on page 82.)

7 On the MapGuide Studio toolbar, click Save to save the load procedure in the repository.
You can rename the new drawing sources and the layers in the Site Explorer.

About Raster Files

Raster (or image) files are pixel-based data, such as digital photographs, that you can use as backgrounds for feature and drawing data. For example, you
can display an aerial photograph of a city under a layer of streets. Raster files are cataloged to optimize performance. You create a raster catalog as part of the load process.

A raster catalog file contains a list of image files and their lower-left and upper-right coordinates. When you access a layer that references a raster catalog, the Server scans the catalog file to find the images that correspond to the area being viewed, and then sends only the data for that area.

An individual image file must be georeferenced, that is, it must have an associated file (for example, TFW for TIFF files) that specifies the location of the image within the coordinate system used in the map.

TIFF, ECW, and MrSID files are loaded without conversion. All other formats are converted to TIFF during the load process.

**Raster Image File Formats**

The following table provides a brief description of the raster image file formats supported by Autodesk MapGuide Studio:

<table>
<thead>
<tr>
<th>Format</th>
<th>File Extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BMP</td>
<td>.bmp</td>
<td>Microsoft Windows Bitmap</td>
</tr>
<tr>
<td>Format</td>
<td>File Extension</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>CALS</td>
<td>.cal</td>
<td>CALS MIL-R-28002A Type 1 Format</td>
</tr>
<tr>
<td>ECW</td>
<td>.ecw</td>
<td>Enhanced Compression Wavelet</td>
</tr>
<tr>
<td>GeoSPOT</td>
<td>.bil</td>
<td>Band Interleaved (GeoSPOT, others) Note that GeoSPOT files need their associated color index files, which have a .clr file extension. The CLR file should be in the same directory as the BIL file.</td>
</tr>
<tr>
<td>JPEG</td>
<td>.jpg, .jpeg</td>
<td>Joint Photographic Experts Group</td>
</tr>
<tr>
<td>MrSID</td>
<td>.sid</td>
<td>Multi-Resolution Seamless Image Database</td>
</tr>
<tr>
<td>PNG</td>
<td>.png</td>
<td>Portable Network Graphic</td>
</tr>
<tr>
<td>TGA</td>
<td>.tga</td>
<td>TrueVision Targa 2.0 Format</td>
</tr>
<tr>
<td>TIFF</td>
<td>.tiff</td>
<td>Tagged Image File Format</td>
</tr>
</tbody>
</table>

### Georeference File Formats

The following table lists the raster file formats supported by MapGuide Studio and their associated georeference files.

<table>
<thead>
<tr>
<th>Raster File Formats</th>
<th>Georeference file formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>.bmp</td>
<td>.bpw, .tab</td>
</tr>
<tr>
<td>.cal</td>
<td>.clw, .tab</td>
</tr>
<tr>
<td>.ecw</td>
<td></td>
</tr>
<tr>
<td>.jpg/.jpeg</td>
<td>.jgw, .tab</td>
</tr>
<tr>
<td>.png</td>
<td>.pgw, .tab</td>
</tr>
<tr>
<td>.sid</td>
<td></td>
</tr>
<tr>
<td>.tga</td>
<td>.taw, .tab</td>
</tr>
<tr>
<td>.tif/.tiff</td>
<td>.tfw, .tab</td>
</tr>
</tbody>
</table>

About Raster Files | 31
Loading Raster Files

This procedure assumes that you have prepared your image source files and have them all in one folder, together with any georeferencing files. The simplest way to load images is to drag them into the Site Explorer. This automatically prepares a raster catalog for them. (The raster catalog is created when you click Load Resources.)

Before you start loading files, you may want to create a folder in the Site Explorer to store the resources produced by the load. To find out how to create the recommended folder structure, see Organizing and Sorting Resources on page 59.

To load image files and create a catalog

1. Drag one or more image files from the Windows Explorer to the Site Explorer.
   
   A new load procedure is displayed to the right of the Site Explorer. MapGuide Studio prepares a catalog file for your images and names it after the first image file.
2 Optional: Use the up and down arrows to arrange the order of the images. Images higher in the list are displayed above any overlapping images that are lower in the list.

3 For How Do You Want To Transform The Tiled Images, select the coordinate system you want to use.

4 For Where Do You Want To Load The Resources, select the destination folder for the raster-catalog and layer resources that will be created by this load. (You can also move the resources later in the Site Explorer.)

5 Rename the raster catalog (the default is the name of the first raster file in the list).

6 Click Load Resources.
   MapGuide Studio converts the images into a single raster-catalog resource and creates a layer to reference it. The raster catalog and layer icons are displayed in the Site Explorer.

7 On the MapGuide Studio toolbar, click Save and save the load procedure in the Site Explorer.

8 Double-click the new layer to open it.
   The Layer Editor is displayed to the right of the Site Explorer. (For more information about the Layer Editor, see Working with Feature Source Layers on page 82.)
After you have a raster catalog, you can easily create another catalog, using the same image files. This is an easy way to build another set of image resources at a different resolution. You can then set the scale ranges for the layers so that the appropriate images appear at different zoom levels.

**To create another catalog with a different resolution**

1. In the Site Explorer, select the load procedure for the images, right-click and click Copy.
2. Select the destination folder, right-click and click Paste.
3. Double-click the new load procedure to open it.
4. For How Do You Want To Transform The Tiled Images, select the coordinate system you want to use, if the source images do not have a coordinate system, or use a different one.
5. For Subsample Factor, enter a number. The higher the number, the lower the resolution. For example, a factor of 2 reduces the resolution of the images to 25% of the original.
6 For Where Do You Want To Load The Resources, select the destination folder for the raster-catalog and layer resources that will be created by this load. (You can also move the map resource later in the Site Explorer.)

7 Rename the raster catalog (the default is the name of the first raster file in the list).

8 Click Load Resources.
   MapGuide Studio converts the images into a single raster-catalog resource and creates a layer to reference it. The raster catalog and layer icons are displayed in the Site Explorer.

9 On the MapGuide Studio toolbar, click Save and save the load procedure in the Site Explorer.

**Other Controls in the Dialog Box**

**Bitonal Images--Merge Overlapping Edges** Any overlapping bitonal (black and white) images that are referenced by the raster catalog are merged. When images overlap, the foreground pixels are preserved and may overwrite the background pixels of an overlapping image. Specify whether you want the “on” bits (the drawing pixels) or the “off” bits (the pixels surrounding the drawings) to be the foreground pixels.

**Connecting to Databases and Web Services**

You can create a live connection to an external database or a web service, and after the connection has been made, use the data in MapGuide Studio.

MapGuide uses Autodesk and OSGeo FDO providers. An FDO provider is an implementation of the FDO (Feature Data Objects) API that provides access to data in a particular data store or to specific kinds of files. (For more information about FDO, see the Open Source Geospatial website at https://mapguide.osgeo.org/gettingstarted.html.)

Connections to databases or web services are stored as resources in the resource repository and can be edited just like any other resource. Connection resources use one of the following providers:

- Autodesk FDO Provider for Oracle
- Autodesk FDO Provider for Raster
- Autodesk FDO Provider for SQL Server
- OSGeo FDO Provider for SQL Server Spatial
About ODBC Data Sources

The ODBC provider connects to databases such as Microsoft Access, Microsoft Excel, and DB2. An ODBC database contains points, which are typically specified either by Latitude and Longitude columns or by arbitrary XY coordinates. For example, a database “State” contains tables for “Cities” and “Villages,” each of which has columns LAT and LON to define the position of the point features.

ODBC databases do not store feature classification. However, you can define feature classes when you configure the data source. By default, the ODBC Provider maps each table in the database to a “feature class” while each column becomes a “property.”

If your data is in Microsoft Access or Excel format, you can upload the source files to the site server from any location in your file system. You can also download the files from the server to your file system for update and replacement.
Connecting to an ODBC Database

To connect using the ODBC provider, you either make a direct connection to a database or upload a file for the resource. The resource created from an ODBC database is always a feature source.

To connect to an ODBC database

1. Click File ➤ New ➤ Data Connection.
2. In the Connect To Data dialog box, select OSGeo FDO Provider for ODBC and click OK.
   The Connection Editor is displayed to the right of the Site Explorer.
3. For Type Of Connection, select one of the following:
   - Connect To A File And Upload To The MapGuide Library: Click New and select the file to access (Microsoft Access or Excel). When you save the connection, the file is loaded into the resource repository, where it is stored as resource data.
   - Connect To An External File: Click File and enter a pathname or select an alias set up in Site Administration. A connection string is automatically generated after you select the file.
   - Connect To A Database: Make a selection from the Type Of Database list. A connection string template is automatically generated. You must replace the square brackets with the required parameters to make the connection.
   - Connect Via A Data Source Name (DSN) Set Up On This Server: The MapGuide server administrator must set up the DSN. The system DSN must be on all of the servers (if the site has multiple servers). Files are not loaded into the resource repository; they are left where they were originally set up.
4. Optionally, select Specify User Credentials. Then do one of the following:
   - If the database does not require a user ID and password, select Use MapGuide Credentials.
   - If the database requires them, select Use The Following Credentials and enter the user ID and password.
5 Click Test Connection.
   ■ You should see a Successful Connection message. If you receive an error, check the connection string carefully or verify that the DSN is set up correctly.
   ■ If necessary, modify the string in the Connection String field or enter your own.

   **NOTE** For Microsoft SQL Server, when entering the server name in the appropriate place in the Connection String window, you must enter the fully qualified Microsoft SQL Server 2008 server name. In many cases, this is the server name followed by the Microsoft SQL Server instance name.

   ■ Click Reset to restore the automatically generated connection string.

6 Optionally, under Define Geometry Properties To Create Spatial Feature Classes, select the tables and coordinate system to use to create geometry.

7 Optionally, under Joins With Other Feature Sources, you can set up feature joins after you have saved the connection. For more information, see Using Feature Joins on page 53.

8 On the MapGuide Studio toolbar, click Save to store this connection resource in the repository.

### About PostgreSQL/PostGIS Data Sources

PostGIS adds support for geographic objects to the PostgreSQL object-relational database so that the PostgreSQL server can be used as a back end spatial database for GIS.

### Connecting to a PostGIS Database

Make sure that the PostGIS server is accessible and that the database you want to connect to is available.

**To connect to a PostGIS database**

1 Click File ➤ New ➤ Data Connection.

2 In the Create Spatial Data Source dialog box, select OSGeo FDO Provider for PostgreSQL/PostGIS and click OK.
The Connection Editor is displayed to the right of the Site Explorer.

3 Enter the server to connect to.

4 Do one of the following:
   ■ If the database is set up to recognize them, select Use MapGuide Credentials.
   ■ If the database requires them, select Use The Following Credentials and enter the userID and password.

5 Select the data store from the list.

6 Click Test Connection.
   You should see a Successful Connection message.

7 On the MapGuide Studio toolbar, click Save to store this connection resource in the repository.

About Oracle Data Sources

FDO Provider for Oracle provides access to an Oracle-based data store. FDO Provider for Oracle supports the following software:

■ Oracle Client—Oracle 10g (10.1.0.2)
■ Oracle Server—Oracle 10g or 11g

Connecting to an Oracle Database

Make sure that the Oracle client is installed and that the services you want to connect to are available.

To connect to an Oracle database

1 Click File ➤ New ➤ Data Connection.

2 In the Create Spatial Data Source dialog box, select Autodesk FDO Provider for Oracle and click OK.
   The Connection Editor is displayed to the right of the Site Explorer.

3 Enter the service to connect to.

4 Select Use MapGuide Credentials or Use The Following Credentials.

About Oracle Data Sources | 39
5 Do one of the following:
  ■ If the database is set up to recognize them, select Use MapGuide Credentials.
  ■ If the database requires them, select Use The Following Credentials and enter the userID and password.

6 Select the data store from the list.

7 Click Test Connection.
   You should see a Successful Connection message.

8 On the MapGuide Studio toolbar, click Save to store this connection resource in the repository.

**Other Controls in this Dialog Box**

**Version (Long Transaction)** If the provider provides this capability, select a long transaction name. A long transaction retains the context of an open transaction if it is interrupted and resumed.
About ArcSDE Data Sources

ESRI ArcSDE (Spatial Database Engine) allows storage of GIS data (including feature geometry) in databases such as Microsoft SQL Server and Oracle. ArcSDE manages the storage of feature geometry using standard data types provided by the host database management system.

ArcSDE is part of the ArcGIS 9 system. ArcSDE manages the exchange of information between an (ArcGIS 9 Desktop) application and a relational database management system. FDO Provider for ArcSDE provides FDO with access to an ArcSDE 8.3-based data store, which, in this case, must be Oracle 9i.

Connecting to an ArcSDE Database

Make sure that the ArcSDE server is accessible and that the instances you want to connect to are available.

To connect to an ArcSDE database

1. Click File ➤ New ➤ Data Connection.
2. In the Create Spatial Data Source dialog box, select OSGeo FDO Provider for ArcSDE and click OK. The Connection Editor is displayed to the right of the Site Explorer.
3. Enter the server and the instance to connect to.
4. Do one of the following:
   - If the database is set up to recognize them, select Use MapGuide Credentials.
   - If the database requires them, select Use The Following Credentials and enter the userID and password.
5. Select the data store from the list.
6. Click Test Connection.
   You should see a Successful Connection message.
On the MapGuide Studio toolbar, click Save to store this connection resource in the repository.

Other Controls in this Dialog Box
Version (Long Transaction) If the provider provides this capability, select a long transaction name. A long transaction retains the context of an open transaction if it is interrupted and resumed.

Connecting to a MySQL Database
Make sure that the MySQL server is accessible and that the database you want to connect to is available.

To connect to a MySQL database
1. Click File ➤ New ➤ Data Connection.
2. In the Create Spatial Data Source dialog box, select OSGeo FDO Provider for MySQL and click OK.
   The Connection Editor is displayed to the right of the Site Explorer.
3. Enter the server to connect to.
4 Do one of the following:
   ■ If the database is set up to recognize them, select Use MapGuide Credentials.
   ■ If the database requires them, select Use The Following Credentials and enter the userID and password.

5 Select the data store from the list.

6 Click Test Connection.
   You should see a Successful Connection message.

7 On the MapGuide Studio toolbar, click Save to store this connection resource in the repository.

Other Controls in this Dialog Box

Version (Long Transaction) If the provider provides this capability, select a long transaction name. A long transaction retains the context of an open transaction if it is interrupted and resumed.

Connecting to a SQL Server Database

Make sure that the computer running SQL Server is accessible and that the database you want to connect to is available.
To connect to a SQL Server database

1. Click File ➤ New ➤ Data Connection.

2. In the Create Spatial Data Source dialog box, select Autodesk FDO Provider for SQL Server and click OK.
   The Connection Editor is displayed to the right of the Site Explorer.

3. Enter the server to connect to.

4. Do one of the following:
   - If the database is set up to recognize them, select Use MapGuide Credentials.
   - If the database requires them, select Use The Following Credentials and enter the userID and password.

5. Select the data store from the list.

6. Click Test Connection.
   You should see a Successful Connection message.

7. On the MapGuide Studio toolbar, click Save to store this connection resource in the repository.
Connecting to a SQL Server Spatial Database

Make sure that the computer running SQL Server Spatial is accessible and that the database you want to connect to is available.

**To connect to a SQL Server Spatial database**

1. Click File ➤ New ➤ Data Connection.

2. In the Create Spatial Data Source dialog box, select OSGeo FDO Provider for SQL Server and click OK.
   The Connection Editor is displayed to the right of the Site Explorer.

3. Enter the server to connect to.

4. Do one of the following:
   - If the database is set up to recognize them, select Use MapGuide Credentials.
   - If the database requires them, select Use The Following Credentials and enter the user ID and password.

5. Select the data store from the list.

6. Click Test Connection.
   You should see a Successful Connection message.

7. On the MapGuide Studio toolbar, click Save to store this connection resource in the repository.

About Web Services

MapGuide has two FDO providers to connect to web services. Web services are becoming increasingly popular as a way of bringing commonly-used spatial data into a map. The two types of supported web services are WFS (Web Feature Service), and WMS (Web Map Service). Both of these are standards developed and maintained by the Open Geospatial Consortium (OGC).

The WFS provider allows you to connect to servers offering feature (vector-based) data, such as political boundaries or transportation networks.

The WMS provider allows you to connect to servers or websites offering raster data, such as satellite photographs or scanned topo maps.
Connecting to a Web Map Service (WMS)

Make sure that the service you want to connect to is available and that you have the correct URL.

To connect to a web map service (WMS)

1. Click File ➤ New ➤ Data Connection.
2. In the Connect to Data dialog box, select OSGeo FDO Provider for WMS and click OK. The Connection Editor is displayed to the right of the Site Explorer.
3. Under Configure WMS Connection, enter the URL to connect to.
   If you are connecting to layers that have been published on a MapGuide server, the connection string looks like this:
5. If the server requires a password, do one of the following:
   - If the service is set up to recognize them, select Use MapGuide Credentials.
   - If the service requires them, select Use The Following Credentials and enter the userID and password.
6. Click Test Connection.
   You should see a Successful Connection message.
7 Click Refresh to reconnect to the server and display the feature source information in the WMS editor.

8 Click Edit Coordinate System to override the original feature source coordinate system.

9 In the WMS Schema table, you can do the following:
   ■ Schema column - This column displays the original feature source name, as defined in the provider’s schema.
   ■ Image Format column - To choose an image format for which you want to set up an override, click a cell in this column.
   ■ Server CS Code column - To choose from the available coordinate systems in the original feature sources on the server, click a cell in this column.
   ■ Layer CS Code column - To reproject the data into a different coordinate system, click a cell in this column.
   ■ Style column - To override the original feature source style, click a cell in this column.
   ■ Background column - This column displays the original feature source background. To change the background to transparent, click a cell in this column.

10 On the MapGuide Studio toolbar, click Save to store this connection resource in the repository.

NOTE To revert to the original state of a particular element, select it, and then click Restore.

Connecting to a Web Feature Service (WFS)

Make sure that the service you want to connect to is available and that you have the correct URL.

To connect to a web feature service (WFS)

1 Click File ➤ New ➤ Data Connection.

2 In the Create Spatial Data Source dialog box, select OSGeo FDO Provider for WFS and click OK.
The Connection Editor is displayed to the right of the Site Explorer.

3 Enter the URL to connect to.
   If you are connecting to feature sources that have been published on a
   MapGuide server, the connection string looks like this:

4 http://servername/mapguide/mapagent/mapagent.fcgi?

5 If the server requires a password, do one of the following:
   ■ If the service is set up to recognize them, select Use MapGuide
     Credentials.
   ■ If the service requires them, select Use The Following Credentials and
     enter the user ID and password.

6 Click Test Connection.
   You should see a Successful Connection message.

7 Click Refresh to reconnect to the server and display the feature source
   information in the WFS editor.

8 Click Edit Coordinate System to override the original feature source
   coordinate system.

9 On the MapGuide Studio toolbar, click Save to store this connection
   resource in the repository.

NOTE To revert to the original state of a particular element, select it, and then
   click Restore.
Connecting to File-based Data Stores

You can create a connection to external SDF, SHP, SQLite, and raster files, without loading them into the resource repository.

MapGuide uses Autodesk and OSGeo FDO providers. An FDO provider is an implementation of the FDO (Feature Data Objects) API that provides access to data in a particular data store or to specific kinds of files. (For more information about FDO, see the Open Source Geospatial website at https://mapguide.osgeo.org/gettingstarted.html.)

You have the option of entering a pathname or selecting a file using the aliases set up in Site Administrator. If you enter a pathname, the file must be located either on the MapGuide Server, although not in the resource repository, or in a location directly accessible from the server. If you want to access resources on your local machine, you must set up an alias in Site Administrator; entering the pathname to a location on your local machine will not work.

Connecting to SDF Files

You can configure a connection to SDF files. For information about SDF files, see About SDF Files on page 20.

To connect to an SDF file

1. Click File ➤ New ➤ Data Connection.
2. In the Connect To Data dialog box, select OSGeo FDO Provider for SDF and click OK.
   The Connection Editor is displayed to the right of the Site Explorer.
3. Under File To Connect To, either enter a pathname or click File to select a file from aliases set up in Site Administrator.
4. Click Test Connection.
   The results are displayed in the field below.
5. Optionally, set coordinate system overrides.
   For more information about coordinate systems, see Setting the Coordinate System for Your Map on page 72.
6. On the MapGuide Studio toolbar, click Save to save the connection to the feature source.
   You can rename the new feature source in the Site Explorer.
Connecting to SHP Files

You can configure a connection to SHP files. For information about SHP files, see About SHP Files on page 22.

To connect to an SHP file

1. Click File ➤ New ➤ Data Connection.
2. In the Connect To Data dialog box, select OSGeo FDO Provider for SHP and click OK.
   The Connection Editor is displayed to the right of the Site Explorer.
3. Under File To Connect To, do one of the following:
   ■ Enter a pathname.
   ■ Click File or Folder to select a file or folder from aliases set up in Site Administrator.
4. Click Test Connection.
   The results are displayed in the field below.
5. Optionally, set coordinate system overrides.
   For more information about coordinate systems, see Setting the Coordinate System for Your Map on page 72.
6. On the MapGuide Studio toolbar, click Save to save the connection to the feature source.
   You can rename the new feature source in the Site Explorer.

NOTE After you have saved the connection, you can create joined feature classes. For more information, see Using Feature Joins on page 53.

Connecting to SQLite Files

You can configure a connection to SQLite files. For information about SQLite files, see About SQLite Files on page 25.
To connect to a SQLite file

1. Click File ➤ New ➤ Data Connection.
2. In the Connect To Data dialog box, select OSGeo FDO Provider for SQLite (spatial) and click OK.
   The Connection Editor is displayed to the right of the Site Explorer.
3. Under File To Connect To, do one of the following:
   - Enter a pathname.
   - Click File and select a file from aliases set up in Site Administrator.
4. Click Test Connection.
   The results are displayed in the field below.
5. Optionally, set coordinate system overrides.
   For more information about coordinate systems, see Setting the Coordinate System for Your Map on page 72.
6. On the MapGuide Studio toolbar, click Save to save the connection to the feature source.
   You can rename the new feature source in the Site Explorer.

**NOTE** After you have saved the connection, you can create joined feature classes. For more information, see Using Feature Joins on page 53.

Connecting to Raster Files

You can configure a connection to individual raster images or to raster image catalog files. This procedure assumes that any georeference files are located in the folder with your image source files.

For more information about image files, see About Raster Files on page 29.

To connect to a raster file

1. Click File ➤ New ➤ Data Connection.
2. In the Connect To Data dialog box, select Autodesk FDO Provider for Raster and click OK.
   The Connection Editor is displayed to the right of the Site Explorer.
3 Under File To Connect To, do one of the following:
   ■ Enter a pathname.
   ■ Click File or Folder to select a file or folder from aliases set up in Site Administrator.

4 Click Test Connection.
   Results are displayed in the field below.

5 Optionally, set coordinate system overrides.
   For more information about coordinate systems, see Setting the Coordinate System for Your Map on page 72.

6 On the MapGuide Studio toolbar, click Save to save the connection to the feature source.
   You can rename the new feature source in the Site Explorer.

**Using Coordinate System Overrides**

Autodesk MapGuide Studio must be able to detect the coordinate system of a feature source to be able to display the features in a map. You can see the coordinate system assigned to a feature source on the feature source editor pane. If MapGuide Studio cannot detect the coordinate system information, <unknown> will be displayed in the feature source editor. You can override the coordinate system of any feature source.

For more information about coordinate systems, see Setting the Coordinate System for Your Map on page 72.

**Setting Coordinate System Overrides**

When you open a feature source, you can override the coordinate system assigned to that resource.

**To set coordinate system overrides**

1 In the Set Coordinate System Overrides pane of the feature source Editor, click Refresh.
   The coordinate system for the feature source are displayed in the table, including any overrides created previously.

2 In the Set Coordinate System Overrides pane, click Edit.
3 In the Coordinate System dialog box, under Categories, select the category that contains the coordinate system for your map. To assign a coordinate system in which points are meaningful in relation to one another but do not represent single, absolute, fixed points on the Earth, select Arbitrary X-Y Coordinate Systems. For more information about coordinate systems, see Setting the Coordinate System for Your Map on page 72.

4 In the Available Coordinate Systems list, click a coordinate system.

5 Click OK.

In the table under Set Coordinate System Overrides, the coordinate system you specified will be listed in the Override column.

NOTE To remove a coordinate system override, highlight the coordinate system in the table and click Remove. This will remove only the override, not the original coordinate system.

Using Feature Joins

After you have loaded your data or connected to it, you can establish relationships between any two feature sources. These relationships are called feature joins. A feature join is similar to a relational join in a database. You are “extending” one feature resource to include another.

About Feature Joins

The illustration below shows an example of relating a feature source containing state or county boundaries to another feature source containing census population data.
Creating a New Feature Join

Creating a feature join involves the following general steps:

- Select the primary resource (for example, Counties).
- Select the secondary resource (for example, Population).
- Match the feature classes (a feature class is equivalent to a table, for example, Counties and Population).
- Enter a name for the joined feature class (appears in layer feature class list).
Map the identifying properties (for example, ID and CountyID).

**To create a feature join**

1. In Site Explorer, double-click the feature source for which you want to create a feature join. This is the primary feature source.

2. In the Join With Other Feature Sources (optional) pane, click New Join.

3. Select a table from the Primary Feature Class (Table) list.

4. In the Name Of This Joined Feature Class field, enter the name that you want to be displayed in the layer feature class list.

5. In the Joins Within Feature Source "<name>" tree list, click the New Join node.

6. For the Secondary Source, click ... to select the feature source with which you want to create a join.

7. Select a table from the Secondary Class (Table) list.

8. In the Name Of This Secondary Join field, enter the name that you want to appear as a prefix in the property lists.

9. Under Match This Column From A Table On The Left, select a column from the primary feature source.

10. Under With This Column From Secondary Class, select a column from the secondary feature source.

11. Under Type Of Join, make a selection.

12. Under Relationship With Secondary Records (Cardinality), make a selection.

13. On the MapGuide Studio toolbar, click Save to store the updated resource definition in the repository.

**NOTE** To preview the new join, see *Previewing the Data* on page 57.

---

**Packaging Spatial Data**

During the process of loading file-based data in MapGuide Studio, you can create data packages (.mgp files). Large collections of source-data files can be...
zipped up in this file format and saved for easy transport. You can use packages to load data onto the site when a standard load procedure fails on very large files due to a timeout. The advantage of creating spatial data packages is that you can transfer large files to the server by CD-ROM/DVD rather than across a network.

You can save a package file anywhere. However, all data packages must be copied to a specific packages folder before they can be loaded into the repository. You specify the location of the package folder with the Site Administrator program (on the Configure Services page: Packages folder). You then use the Load Packages page to extract the data directly into the resource repository on the site server.

The process of creating and loading a package file looks like this:
Creating a Spatial Data Package

In Autodesk MapGuide Studio, you can create a spatial data package after you define the settings for the load procedure and before you actually load the files.

**NOTE** You can also create a package using the Make Package command in the Site Administrator application.

**To create a spatial data package**

1. Drag the files you want to load into a folder in the Site Explorer.
2. While displaying the Load Procedure Editor, click File menu ➤ Package Spatial Data.
3. In the Select Destination dialog box, specify a location in the resource repository to save the load procedure.
   - If you have already saved the load procedure in the Site Explorer, this dialog box is not displayed.
4. In the Save Package As dialog box, enter a name for the package file.

Loading a Spatial Data Package

After you create and save the spatial data package, you can copy it to the packages folder for uploading to the resource repository on the server. You load the package using the Site Administrator/Load Packages page. See the Site Administrator Help pages for the steps.

Once the package has been successfully loaded onto the server, the resources are available in the Site Explorer.

Previewing the Data

As you style a layer, use the Layer Preview pane to view what it will look like when a user displays it in the Viewer.
To preview the data

1 If the Feature Source Preview pane is not displayed, click Preview.

2 Click Refresh.

The Feature Source Preview divides into two frames. The left frame displays the feature source schema, class, data properties, and geometric properties.

3 Do one of the following:
   ■ Click View Data in the left frame to display the feature class data table in the right frame.
   ■ Click View Feature in the left frame to display a preview of the feature class geometry in the right frame.

NOTE To display the Feature Source Preview pane below the Feature Source Editor pane as you work, click Split.
Working with the Site Explorer

The collection of servers that process Autodesk MapGuide® Studio and MapGuide Viewer requests is called a site. The servers in each site share a single resource repository, which stores resources used to create web layouts. The resources and folders in the repository are displayed in hierarchical order in the Site Explorer. You can use the Site Explorer to perform the operations described in this section.

Organizing and Sorting Resources

You can use folders to organize resources in the Site Explorer. Sort resources by name or type.

Create a project folder that contains the following folders:

**Data:** Database connection resources, such as ODBC, Oracle, and ArcSDE.

**Load:** File-based data resources, such as DWG, SHP, and other files.

**Layer:** Layer resources that reference data resources.

**Map:** Map resources that reference layer resources.

**Symbol libraries:** Symbols libraries used to style elements on layers.

**Web layout:** Web layouts that reference maps.

To create a folder

1. In the Site Explorer, click a site or folder.
2. Click File menu ➤ New ➤ Folder.
   
   You can also right-click a site name or folder and click New ➤ Folder.
3 Enter a name for the new folder and press Enter. The new folder is added to the selected folder or to the top of the tree if the site is selected.

To sort resources

1 Click the arrow next to Sort.
2 Click By Name or By Type.

Click Sort to toggle between By Name and By Type sorting methods.

Creating New Resources

You can use the Site Explorer to create new data resources, layers, maps, symbol libraries, and web layouts. There are two ways to create new data resources: create new database connections and load files.

To create a new resource

1 Click File menu ➤ New.
2 Click the type of resource you want to create.

The appropriate editor for the new resource is displayed in the resource editor. For more information, see the following Help topics:

<table>
<thead>
<tr>
<th>For more information about creating...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data resources</td>
<td>Accessing Data on page 15</td>
</tr>
<tr>
<td>Layers</td>
<td>Working with Layers on page 81</td>
</tr>
<tr>
<td>Maps</td>
<td>Working with Maps on page 71</td>
</tr>
<tr>
<td>Web layouts</td>
<td>Displaying the Map in a Web Browser on page 115.</td>
</tr>
</tbody>
</table>
Saving a Resource as XML

If you are developing web-tier applications, you can save most MapGuide Studio resources as XML. Use the XML versions as templates or use portions of the XML code as needed. The following resource types can be saved as XML: maps, layers, load procedures, feature source, drawing source, web layouts, and print layouts.

For more information about developing web-tier applications, see See the Web Tier API Reference.

To save a resource as XML

1. Create or open the resource.
2. Click File menu ➤ Save or File menu ➤ Save As to save the new resource.

Copying, Moving, Deleting, and Renaming Resources

After creating resources, you can move, delete, or rename them, including resources that are referenced by other resources.

**WARNING** Moving, deleting, and renaming a resource breaks references to that resource. You can have MapGuide Studio display a warning message when performing any of these operations. For more information see Displaying Warning Messages on page 67.

Copying a resource

1. Click the resource to copy.
2 Click Edit menu ➤ Copy.
   You can also right-click and click Copy.

3 Click the destination folder and click Edit menu ➤ Paste.
   You can also right-click the destination folder and click Paste.

To move a resource
   ▪ Drag the resource to the destination folder.

To delete a resource
   1 Click the resource to delete.
   2 Click Edit menu ➤ Delete.
      You can also right-click and click Delete.

To rename a resource
   1 Click the resource to rename.
   2 Do any of the following:
      ▪ Click the resource again to edit the name.
      ▪ Right-click and click Rename.
      ▪ Press F2.
   3 Enter a new name for the resource.

**Refreshing the Site Explorer**

The contents of the site repository can change as other users add, move, rename, and delete resources. To view the most current content in the site repository, refresh the Site Explorer periodically.

To refresh the Site Explorer
   ▪ In the Site Explorer toolbar, click Refresh.
Showing and Hiding the Site Explorer

You can hide the Site Explorer to increase your work area when you are using one of the resource editors.

To show or hide the Site Explorer

- In the toolbar, click Site Explorer.

Viewing Site Properties

View general properties and permission information about a site.

To change the owner of the site, see Changing the Owner of a Resource or Site on page 65. To set or change permissions on a site, see Setting Permissions on page 66.

To view site properties

1. Right-click the site node in the Site Explorer and click Properties.
2. In the Properties dialog box, click General.
   - The General tab displays the site name if available, URL, version number, operating system, and owner.
   - Set the site name in the Site Administration program.
   - The site owner has complete control over permissions on all resources on the site. An owner or administrator can change the owner of a resource.
   - To change the site owner, see Changing the Owner of a Resource or Site on page 65.
3. To view the level of access users have to the site, click Permissions.
   - To change permissions, see Setting Permissions on page 66.

Viewing Resource Properties

For any resource in the Site Explorer, you can view general properties, permissions, and the resources that the selected resource references and is
referenced by. For example, select a map and view the layers this map
references and the web layouts that reference this map.

To change the resource owner, see Changing the Owner of a Resource or Site
on page 65. To set or change permissions on a resource, see Setting Permissions
on page 66.

**To view resource properties**

1. Right-click the resource or folder in the Site Explorer and click Properties.

2. In the Properties dialog box, click General.
   The General tab displays the following properties for the selected resource:
   - **Resource Name**: Name of the currently selected resource in the Site
     Explorer.
   - **Type**: Type of resource, either folder, data, layer, map, web layout, print
     layout, symbol library, database connections, and load procedures. For
     more information about the different types of resources, see
     Understanding Resources on page 8.
   - **Location**: Location of the currently selected resource in the site repository.
     A resource can be referenced in multiple resources from one location in
     the site repository.

   **WARNING** If you move a resource that is referenced in multiple resources,
   you will break these references.

   - **Owner**: Owner of the currently selected resource. By default, the owner
     is the user who created the resource. The owner has complete control
     over permissions on a resource, regardless of permission settings. Only
     an administrator can change the owner of a resource. To change the
     owner, see Changing the Owner of a Resource or Site on page 65.

   - **Created**: Date and time that the resource or folder was created.

   - **Modified**: Date and time that the resource was last changed.

3. To view the level of access users have to the selected resource, click
   Permissions.
   To change permissions, see Setting Permissions on page 66.

4. To view the resources used by the selected resource, click References.
   For example, if the selected resource is a map, the References tab will list
   the layers used in the map.
To view the resources that use the selected resource, click Referenced By. For example, if the selected resource is data, Referenced By will list the layers that use the data resource.

Changing the Owner of a Resource or Site

The owner of a resource is the user who creates, loads, or connects to the resource. The owner controls access to the resource by controlling permissions. A different user might work with the resource in Studio. For this reason, the owner or an administrator can assign a different owner to the resource.

**NOTE** A user who copies a resource becomes the owner of the copied resource.

**To change the owner of a resource**

1. Right-click the resource or folder in the Site Explorer and click Properties.
2. In the Properties dialog box for the selected resource, on the General tab, click Change Owner.
3. In the Change Owner dialog box, click [...].
4. In the Users In Everyone dialog box, click a user. Then click Close.
5. In the Change Owner dialog box, click Ok. The owner is changed. The new owner is shown on the General tab in the Properties dialog box.

**To change the owner for a set of resources**

1. Right-click the folder containing the resources for which to change ownership and click Properties.
2. In the Properties dialog box for the selected folder, on the General tab, click Change Owner.
3. In the Change Owner dialog box, click [...].
4. In the Users In Everyone dialog box, click a user. Then click Close.
5. In the Change Owner dialog box, click Change Owner On All My Child Resources (Administrator Changes All).
The owner is changed for all resources belonging to this particular user in the selected folder and all folders within that folder. The new owner is shown on the General tab in the Properties dialog box.

**Setting Permissions**

Users with the proper permissions can view and edit resources in the Site Explorer. You can control permissions for individual resources, for the folders that contain them, or for the site. By default, resources inherit the permissions of the folder that contains them. Modify permissions as needed after you create them.

You must be an Administrator or the owner of the resource to modify permissions.

**To set permissions for a resource, folder, or site**

1. Right-click the resource, folder, or site node in the Site Explorer and click Properties.
2. In the Properties dialog box, click the Permissions tab.
3. If setting permissions on a resource or folder, clear the Inherit Permissions From Parent `parentname` checkbox.
   The `parentname` variable represents the folder name.
4. Click Add.
5. In the Select Users And Groups dialog box, click either the Groups or the Users tab.
6. Click the checkbox next to the name of the group or user to add.
   To view the members of a group, select the group name and click Members.
7. Click OK.
8. In the Groups And Users list, select each group and user in turn and specify the type of access to allow: Read/Write, Read-Only, or No Access.
9. Click Apply to save permissions you specify as you work.

**To inherit permissions from the parent folder**

1. Right-click a resource or folder and click Properties.
In the Properties dialog box, click the Permissions tab.

3 Click the Inherit Permissions From Parent *parentname* checkbox.
   The *parentname* variable represents the parent folder name.

4 Click OK.

### Displaying Warning Messages

You can have MapGuide Studio display warning messages when moving, renaming, or deleting resources. For more information, see Setting Site Explorer Options on page 151.

### Publishing WMS and WFS Data

You can choose to publish some or all of your data using either WMS (Web Mapping Service) or WFS (Web Feature Service) protocols in MapGuide. Publish layer resources using WMS. Publish feature data resources using WFS. Use the Properties dialog box in the Site Explorer to publish and add metadata to layer resources and feature data resources.

Publishing data to WMS or WFS are two separate operations. You can decide which of these protocols your site will support. The steps for each are similar.

**To publish using WMS or WFS**

1 In the Site Explorer, right-click a layer resource to publish to WMS or a feature data resource to publish to WFS. Click Properties.

2 In the Properties dialog box, click the Service Properties tab.

3 Do one of the following:
   - If you are publishing a layer resource to WMS, select Publish Via Web Mapping Service.
   - If you are publishing a feature data resource to WFS, select Publish Via Web Feature Service.

4 Add metadata as follows:
   - Use Title to enter a title for the layer. This is the name that appears to the client user, for example *County Waterways*. This field is required.
Use Abstract to provide a more detailed description of the data. For example, enter *Waterways of the county. 1972 base map with 1995 survey updates*. This field is optional.

Use Keywords to enter a comma-separated list of words to help locate the data among a set of sources. For example, enter *Waterway,River,Lake,Stream,Canal,1995 survey*. This field is optional.

Use Extended Metadata, to associate a web page with the data. This field is optional. For example, provide the client user a link for additional information. Use the following sample syntax:

```
<Link href="http://myserver/wfs/meta.cgi?feature=Waterways&amp;format=plain&amp;" type="TC211" format="text/plain" />
<Link href="http://myserver/wfs/meta.cgi?feature=Waterways&amp;format=xml&amp;" type="FGDC" format="text/xml" />
```

Use Bounds to specify the area to display. This field is required. Define one or more `<Bounds />` elements, each of which describes the same extent but uses units appropriate for the spatial reference system (SRS). The SRS attributes document which spatial reference systems the data is available in (based on server-side point transformation.) EPSG:4326 must be one of the spatial reference systems.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>SRS</td>
<td>Any valid spatial reference system as defined by the OGC specification. The west, south, east, and north attributes are expressed in terms of this value.</td>
</tr>
<tr>
<td>west</td>
<td>Western-most extent of the data.</td>
</tr>
<tr>
<td>south</td>
<td>Southern-most extent of the data.</td>
</tr>
<tr>
<td>east</td>
<td>Eastern-most extent of the data.</td>
</tr>
<tr>
<td>north</td>
<td>Northern-most extent of the data.</td>
</tr>
</tbody>
</table>
| abstract  | Optional attribute, assumed ="false" if omitted. This attribute is used specifically for `<Bounds SRS="EPSG:4326" .../>` and
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>must be = “true” only if EPSG:4326 is not one of the user-selected reference systems.</td>
<td></td>
</tr>
<tr>
<td>default</td>
<td>Optional attribute, assumed = “false” if omitted. This attribute is used to identify the native reference system of the source data. If a client requested data in this SRS, no transformation would be necessary.</td>
</tr>
</tbody>
</table>

Use the following sample syntax:

```xml
<Bounds SRS="EPSG:4326" north="38" west="-123.5" south="36" east="-121.5" abstract="true" />
```

- Use Other SRS to define any additional reference systems the underlying data can be transformed into. Create a comma-separated list. This field is optional.
- For WFS feature data resources, use Primary SRS to specify the spatial reference system native to the underlying data. This field is optional if the SRS is specified in the Bounds field.
- For WMS layer resources, select Opaque if this layer produces an image that is essentially opaque, such that any layer placed beneath it would be obscured. Clear the checkbox to indicate that the layer contains sparse data, for example points, lines, and polygons, that does not cover the entire bounds and can be rendered with transparency to expose layers behind it. This setting provides information to help the client user determine layer ordering. Opaque layers should be moved to the bottom of the viewing order.
- For WMS layer resources, select Queryable to indicate additional queryable metadata for individual features on the layer.
Working with Maps

Use the Map Editor to specify basic map settings and add layers. Create a new map and drag layers into it from the Site Explorer or work with an existing map and make adjustments as needed.

Creating a New Map

Use the Map Editor to specify general map settings and add layers. As you create new maps, each map is displayed on its own tab in the editor space.

To create a new map

1. Do one of the following:
   - Click File menu ➤ New ➤ Map.
   - Double-click an existing map in the Site Explorer.

2. In the Settings pane, for Description, enter a description for the map.

3. For Coordinate System, specify a coordinate system for this map.
   For more information, see Setting the Coordinate System for Your Map on page 72.

4. Optionally, for Background Color, specify a background color for the map.
   For more information, see Setting the Background Color on page 73.

5. To specify the initial view of the map that is displayed when a user views it in a browser, do one of the following:
   - Enter values in the boxes in the Initial View area to specify the initial view of the map.
   - Click Use Current Map Zoom To Set These Coordinates.
If this option is not available, be sure the Map Editor is in Split mode so the Preview pane is showing. For more information, see Previewing the Map on page 79.

6 Click File menu ➤ Save As and specify a name and location for the map in the Site Explorer.

Setting the Coordinate System for Your Map

A coordinate system is a description of the origin (datum) of your map, the projection system used, and the units you are using. It describes how the sphere of the Earth is projected onto a sheet of paper and converted to the Cartesian coordinate system.

Mapping applications use coordinate systems to determine where to display features on the map. In a latitude/longitude coordinate system, each coordinate pair corresponds to an exact fixed location on the Earth; in an arbitrary XY system, the coordinates have meaning in relation to each other but do not necessarily correspond to exact fixed locations on the Earth.

For example, a floor plan map might specify that the southwest corner is 0,0 and the northeast corner is 500,500, so that if the building were moved to another location, these coordinates would still be accurate because they are not tied to exact locations on the Earth. If you used latitude/longitude coordinates for that map, however, the coordinates would change if you moved the building, because each pair corresponds to one exact point on the Earth.

Some types of arbitrary XY systems, such as the state plane systems, make use of both of these concepts. Each system represents a specific area, usually a state or a section of a state. Within that area, the coordinates are meaningful and represent exact locations on the Earth. So a point with the coordinates 100000,100000 always represents a specific location in the New York state plane system. However, if you change the system to another state plane system, all of the data moves to that area, where 100000,100000 represents a specific location in that area. In this way, the data is arbitrary XY, because the numbers themselves do not represent exact locations except within the context of the fixed areas.

**NOTE** Arbitrary XY data is not converted to latitude/longitude. Use it only in maps that use arbitrary XY as the system and in which all data is in arbitrary XY.
To set the coordinate system for your map

1. In the Settings pane of the Map Editor, for Coordinate System, click [...].
2. In the Coordinate System dialog box, under Categories, select the category that contains the coordinate system for your map.
   
   To assign a coordinate system in which points are meaningful in relation to one another but do not represent single, absolute, fixed points on the Earth, select Arbitrary X-Y Coordinate Systems.
3. In the Available Coordinate Systems list, click a coordinate system.
4. Click OK.

Setting the Background Color

Set the background color for your map to a predefined color or a custom color that you define.

To set the background color

1. In the Settings pane of the Map Editor, for Background Color, select a color. Click More Colors to select a color from a larger set or define a custom color.

To define a custom color

1. In the Settings pane of the Map Editor, for Background Color, click More Colors.
2. In the Color dialog box, click Define Custom Colors.
3. Enter values for Hue, Saturation, and Luminance or Red, Green, Blue settings to define a custom color.
4. Click Add To Custom Colors.
5. Click OK.

Setting the Initial Map View

Specify the initial view of the map to display when the map is opened in the MapGuide Viewer. Users can zoom out from this initial view to see more of the map. When you reference the map in a web layout, you can override this
initial view. The unit of measurement varies depending on the selected coordinate system.

**To define the initial view manually**

- In the Settings pane of the Map Editor, in the Initial View area, use the coordinates boxes to define the lower left and upper right corners of the initial view. The left value should be less than the right and the bottom value should be less than the top. To avoid map distortion, make sure the numbers fit the current range of the coordinate system.

**To set the initial view using the current map view**

1. In the Map Preview pane, zoom in to the geographic area required for your new map.
2. Click Use Current Map Zoom To Set These Coordinates. The current view is used for the initial view of the new map.

### Setting Up Layers

You can use the Layers pane of the Map Editor to add layers to your map, create layer groups to organize layers, and control the draw order and other layer display options. Layers reside in the Site Explorer, and you add them to maps by creating a reference to them within a map. When you create a new layer reference in the Map Editor, you must specify the layer resource that you want to reference.

To control the data associated with a layer and how it is displayed in the map, use the Layer Editor. For more information, see [Working with Layers](#) on page 81.

### Adding Layers to Your Map

Create a reference to the layer by dragging the layer onto the Layers pane. The layer remains in the Site Explorer and can be used in other maps. A link to the layer is created in the Layers pane of the Map Editor. You can also create new layer references in the Map Editor and associate them with layers in the Site Explorer.
To add layers to your map

- Drag a layer from the Site Explorer to the Layers pane of the Map Editor.
  You can change the layer resource and other settings as needed. For more information, see Specifying Layer Settings on page 76.

**WARNING** Users with write permission can modify, move, or delete layer resources used in your map.

### Creating Layer Groups and Adjusting Viewer Legend

Organize your layers in the Map Editor by creating one or more layer groups. The legend displayed in the Viewer matches the Layers By Group tab on the Layers pane in the Map Editor.

**To create a layer group**

1. In the Layers pane of the Map Editor, click the Layers By Group tab if it is not already displayed.
2. Click Create A New Group.
3. Name the new layer group.
   The new layer group name is selected by default when you create it. Enter a new name and press Enter.

**To control the order of groups**

1. Click a group.
2. Click Move Up or Move Down to position the group as desired in the draw order.

**To rename a layer group**

1. Click the group name.
2. In the Group Settings area, for Name, enter a new name and press Enter.
Adjusting Layer Draw Order

The Drawing Order tab in the Layers pane controls the order in which layers are drawn when the map is displayed in the Viewer. The order of layers represents a stack of layers viewed from the top. Objects on layers higher in the list obscure objects on layers lower in the list.

To arrange layer draw order

1. In the Layers pane, click the Drawing Order tab.
2. Click a layer.
3. Click Move Up or Move Down to position the layer as desired in the draw order.

NOTE The drawing order does not affect how the layers are listed in the Viewer legend.

Specifying Layer Settings

You can change the layer resource referenced by the selected layer in the map as well as the layer name and group. Note that these changes affect the layer only within the current map, not in the Site Explorer. You can also set the default display status for the layer, whether features on the layer can be selected, and whether the layer is included in the legend. If the layer is to be included in the legend, you can assign a legend label and display status.

To specify layer settings

1. In the Layers pane, click a layer on either the Layers By Group or Drawing Order tab.
2. To change the layer resource that this layer references, do the following:
   - For Layer Resource, click [...].
   - In the Select A Layer Resource dialog box, navigate to the layer you want to reference.
   - Click Open.
3. Optionally, enter a new name for the layer.
4 To change the group the layer belongs to, under Group, click a different group name or click None.
   You can also drag the layer into the desired group on the Layers By Group tab.

5 To specify that the layer is visible when first displayed in the Viewer, click Layer Is Initially Displayed In The Map.
   The actual visibility of the layer depends on the zoom position selected by the user.

6 To allow users to select features on this layer when they view the map, click Features On The Layer Can Be Selected.

7 Do any of the following:
   ■ To show the layer name in the legend when the map is displayed in the Viewer, click Layer Is Visible In The Legend.
   ■ Under Legend Label, enter a name for the layer.
     This name is used for the layer in the legend when the map is displayed in the Viewer.
   ■ To show layer themes in the legend when the map is first displayed in the Viewer, click Layer (If Themed) Is Initially Expanded In The Legend.

**Specifying Layer Group Settings**

You can rename a group and add it to another group. You can also set the default display status for the group and whether the group is included in the legend. If the group is to be included in the legend, you can assign a legend label and display status.

**To specify layer group settings**

1 In the Layers pane, click the Layers By Group tab. Then click a layer group.

2 Optionally, enter a new name for the layer group.

3 To add the layer group to another layer group, click the group name under Parent Group.
   You can also drag the layer group into the desired group on the Layers By Group tab.
4 To specify that the layer group is visible when first displayed in the Viewer, click Group Is Initially Displayed In The Map. The actual visibility of the layer group depends on the user’s zoom position.

5 To adjust legend settings for the selected layer group, do the following:
- To show the layer group name in the legend when the map is displayed in the Viewer, click Group Is Visible In The Legend.
- Under Legend Label, enter a name for the layer group. This name is used for the layer group in the legend when the map is displayed in the Viewer.
- To show the layers in the group when the map is first displayed in the Viewer, click Group Is Initially Expanded In The Legend.

**Setting Up Smooth Map Viewing**

You can create a set of base map layers to enable smooth panning and zooming in the AJAX version of the MapGuide Viewer. These layers are cached and tiled on the server so they can be quickly displayed as users move around the map. Only specified scale ranges are cached and displayed. As users zoom in or out, the cached layers at the nearest scale range are displayed.

**NOTE** For consistency, the list of base layers is displayed in the DWF viewer as well but the layers are not cached and tiled.

**To setup smooth pan and zoom for the AJAX viewer**

1 In the Base Layers For Smooth Navigation In AJAX Viewer pane, under Layers By Group And Drawing Order, click Base Layers (0 Groups, 0 Layers).

2 Click Create A New Group. Create as many base layer groups as you need. In the legend, users can turn the base layers groups on or off as needed. You must create at least one group and you cannot create nested groups.

3 Add layers to groups. These layers do not work as individual layers but rather as a group to provide a contextual experience for the user during pan and zoom operations.
Do not duplicate the layers in the Layers pane. If you want to use layers as base layers, remove them from the Layers pane.

4. Under Set Fixed Scales For Incremental Zooming, under Total Number Of Scales, enter the number of zoom scales you need. A set of evenly spaced scales is created. The zoom factor is indicated under Messages.

5. Specify Nearest Zoom In and Farthest Zoom Out. You can also adjust the map zoom in the Preview pane and click Use Current Map Zoom.

**Previewing the Map**

As you build a map, use the Map Preview pane to view what it will look like when a user displays it in the Viewer.

**To preview the map**

1. If the Map Preview pane is not displayed, click Preview.

2. Click Refresh.

To display the Map Preview pane below the Map Editor pane as you work, click Split.
Working with Layers

You can use the Layer Editor to create a layer resource that can be shared and reused in many maps. A preview of the data resource using default styling is provided. Customize the styles or theme the data as needed.

NOTE As with any application accessing resources across a network it is advisable to save often after incremental changes are made to prevent the possible loss of work.

Specifying the Data Resource for a Layer

Using the Layer Editor, you can specify the data resource for a new layer or change the data resource specified for an existing layer. For more information about the types of data Autodesk MapGuide Studio supports, see Accessing Data on page 15.

To specify or change the data resource for a layer

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer’s tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60.

2. In the Settings pane, click [...].

3. In the Open Resource dialog box, navigate to the data resource to associate with this layer.

4. Click the data resource name and click Open.
5 Click File menu ➤ Save.

Working with Feature Source Layers

If the data resource for the layer is a feature source, you can do any of the following:

■ Specify the feature class, geometry, and properties to display when a user views this layer in the MapGuide Viewer.
■ Define a filter to further specify the data to include with this layer.
■ Define a URL to display when a user clicks a feature on this layer.
■ Define a tooltip to display when the pointer pauses on a feature on this layer.
■ Define styles and themes to apply to the data on this layer. For more information about styles and themes, see Creating Styles for Feature Source Layers on page 87.

For more information about feature sources, see Understanding Resources on page 8.

Specifying Feature Class and Geometry

For the feature source, specify the feature class and geometry to use if more than one are available. Also, you can specify the properties to display in the Properties section of the Viewer.

To specify feature class and geometry

1 Open the layer to edit by doing one of the following:
   ■ Create a new layer.
   ■ Double-click an existing layer.
   ■ Click the layer’s tab if the layer is already open.

For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.
2 In the Settings pane of the Layer Editor, in the Feature Data Setup area:
   ■ For Feature Class, select the feature class containing the features to
display for this layer.
   ■ For Geometry, select the property that contains the geometry for the
features in this layer.

3 Click File menu ➤ Save.

Specifying the Properties to Display in the Viewer

When a user selects an object in the Viewer, its properties can be displayed
in the Viewer’s Properties section. Use the Layer Editor to define the properties
to display.

To specify object properties to display in the Viewer

1 Open the layer to edit by doing one of the following:
   ■ Create a new layer.
   ■ Double-click an existing layer.
   ■ Click the layer’s tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources
   on page 60. For information about associating a data resource with a new
   layer, see Specifying the Data Resource for a Layer on page 81.

2 In the Settings pane of the Layer Editor, in the Feature Data Setup area,
   select properties to display from the Properties Displayed In The Viewer
   list.
   ■ To select all available properties, click Select All.
   ■ To clear selected properties, click Clear All.

3 To adjust the name of the property that is displayed in the Viewer, click
   the property name and enter a new name.

   NOTE If you clear the checkbox for a property, the name reverts to the
default.
To sort the properties list, do either of the following:

- To display selected properties at the top of the list, click either column heading once.
- To sort the list alphabetically, click either column heading twice.

Click File menu ➤ Save.

Filtering Data

Use a filter to select a subset of features for a layer or for theming. For example, if you have a data resource containing all US cities with a property called STATE, you might create the following filter to display only cities in California:

```
STATE = 'CA'
```

The Filter dialog box has two modes: Builder and Advanced. In Builder mode you can only create filters that use valid syntax. In Advanced mode you can create filters using any syntax, even if it is not handled by the Builder. You cannot move from Advanced mode to Builder mode unless filter conditions are valid. Further, a filter with valid syntax is not allowed in the builder if it contains functions or property names that are not in the layer's data source.

All conditions must be in the following format:

```
<property> <operator> <constant>
```

To filter data

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer's tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. Open the Filter dialog box by doing one of the following:
   - To select a subset of features for a layer, in the Settings pane of the Layer Editor, in the Feature Data Setup area, for Filter Applied To Data, click [...].
To select a subset of features for theming, in the Style pane of the Layer Editor, under Scale Ranges, select the scale range to theme. In the style rule grid, click the Condition box.

For more information about scale ranges, see Understanding Scale Ranges on page 87.

3 In the Filter dialog box, do one of the following:
   ■ Select Property and then select a property from the list.
   ■ Select Expression and use the Number Expression dialog box to build an expression.
     For more information, see Building Number Expressions on page 112.

4 Under Conditions and Values, select a relational operator and a value from each list.
   To display available values for the selected property, click Get.

5 To add conditions, do the following:
   ■ Click New.
   ■ Under Operation, click And or Or.
   ■ To precede the selected condition with the Not boolean operator, under Operations, click Not.
   ■ Specify a property or expression, condition, and value.

6 To group and ungroup conditions, select the conditions and click Group Selected Conditions or Ungroup Selected Conditions as needed.

7 Click OK.

8 Click File menu ➤ Save.

**Setting Up Linked Documents and Tooltips**

Enable your users to view documents and tooltips associated with map features. For more information, see Building Text Expressions on page 110.

**To specify a linked document**

1 Open the layer to edit by doing one of the following:
   ■ Create a new layer.
Double-click an existing layer.

Click the layer’s tab if the layer is already open.

For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2 In the Settings pane of the Layer Editor, in the Feature Data Setup area, for URL Activated For Feature, click […].

3 Use the Text Expression dialog box to specify the URL to use for the linked document.
   For more information, see Building Text Expressions on page 110.

4 Click File menu ➤ Save.

To specify a tooltip

1 Open the layer to edit by doing one of the following:
   ■ Create a new layer.
   ■ Double-click an existing layer.
   ■ Click the layer’s tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2 In the Settings pane of the Layer Editor, in the Feature Data Setup area, for Tooltip Displayed For Feature, click […].

3 Use the Text Expression dialog box to specify the text to use for the tooltip.
   For more information, see Building Text Expressions on page 110.
   To display multi-line tooltips, insert the backslash character followed by the n character (\n) where you want line breaks. For example, 123 Main St\nParcel 2115.

4 Click File menu ➤ Save.
Creating Styles for Feature Source Layers

You can specify properties that control how feature source layers appear on a map. For example, you can specify the scale ranges at which a layer is visible, set the line color, and add labels to the map features. You can also create a theme, which displays the data in varying styles to indicate different values in the data. To specify styles for a layer, you define a style for a scale range. By default, 0 - Infinity is the only scale range. Add narrower scale ranges as you define styles to define how the data should appear at various scales. For example, you could create one scale range that displays roads with thick lines when you zoom in, and create a second scale range that displays roads with thin lines when you zoom out.

Understanding Scale Ranges

A scale range specifies the zoom level at which a particular style is applied to the display of your data. When the zoom level of MapGuide Studio or the Viewer is within the specified scale range, MapGuide Studio redraws the layer as specified by the style associated with the scale range.

The style is applied when the zoom level is greater than or equal to the From value and less than the To value. When setting up adjacent scale ranges, use the same To value as the next range’s From value. For example, if one range is 0 - 20,000 set the next range to 20,000 - 40,000.

Defining Scale Ranges

The first step in creating styles is to define your scale ranges.

NOTE When setting up multiple scale ranges for a layer, make sure that they do not overlap. For example, the ranges 500,000 - 5,000,000 and 2,000,000 - 10,000,000 overlap. In such cases, when the zoom level is within the overlapping scale range, MapGuide Studio displays the features using the style of the first scale range.

To define scale ranges

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
Click the layer’s tab if the layer is already open.

For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2 In the Style pane of the Layer Editor, in the Scale Ranges area, under From, enter the lower end of the scale range. Under To, enter the upper end of the scale range.

For example, to make a style visible when the map is zoomed anywhere between 1:250,000 and 1:5,000,000, enter 250000 for From and enter 5000000 for To.

3 To add a new scale range, click Add A Scale Range.

4 Specify From and To values.

5 When working with scale ranges:
   ■ To copy a scale range, select the range and click Duplicate.
   ■ To delete a scale range, select the range and click Delete.
   ■ To change the position of a scale in the list, select the range and click Move Up or Move Down.

6 Click File menu ➤ Save.

Styling Points

Use symbols to represent and display point features. MapGuide Studio provides six mark symbols: square, circle, triangle, star, cross, and X. You can also use font symbols and build MapGuide Studio symbol libraries.

In symbol libraries you can use Bitmap (BMP), Device Independent Bitmap (DIB), Enhanced Metafile (EMF), TrueType Fonts (TTF), Windows Metafile (WMF), Portable Network Graphics (PNG), and Joint Photographic Experts Group (JPG/JPEG). Create your own symbols in Autodesk Map 3D or other application and then import them into MapGuide Studio.

Symbols can contain four types of elements:

■ Images
■ Text
■ Lines
Polygons

You cannot modify images. However, you can override the fill colors of polygon elements, the color of line elements, and the color of text elements. If a symbol element contains multiple colors (for example, a line element with three segments, each a different color), overriding applies the same color to all parts of the element.

If precise placement of labels is important, you can display labels instead of symbols at feature point locations. For more information, see Displaying Fixed Labels at Point Locations on page 99. You can also specify whether other labels should obscure symbols on this layer. For more information, see Allowing Labels to Obscure Points (Overposting) on page 99.

For more information about working with symbols, see Working with Symbols on page 147.

**NOTE** Set default size context and units in Options. For more information, see Setting Layer Editor Options on page 151.

### To apply styles to points

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer’s tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. In the Style pane of the Layer Editor, under Scale Ranges, select the scale range to style.

   For more information about scale ranges, see Understanding Scale Ranges on page 87.

3. In the Point Style area for the selected scale range, for Style Of The Geometry, click [...].

4. In the Style Point dialog box, select the Style A Point Symbol checkbox.

5. For Symbol, do one of the following:
   - Select a mark symbol from the list.
Select Font Symbol […]. In the Font Symbol dialog box, from the Font list, select a font. Click a symbol. Click OK.

Select Symbol Library […]. In the Select A Symbol dialog box, click […]. Specify a symbol library. Click Open. Click a symbol. Click OK.

For Size Context, specify the type of units:
- Select Device Space to specify symbol widths and heights in screen units. Available units are Points, Inches, Millimeters, or Centimeters.
- Select Map Space to specify symbol widths and heights in Mapping Coordinate System (MCS) units. Available units are Inches, Feet, Yards, Miles, Millimeters, Centimeters, Meters, and Kilometers.

For Units, select the type of units to use.

For Width, enter the symbol width or specify the width using a number expression.
For more information, see Building Number Expressions on page 112.

For Height, enter the symbol height or specify the height using a number expression.
For more information, see Building Number Expressions on page 112.

To maintain width-to-height proportions when you change the width or height of the symbol, select the Maintain Aspect Ratio checkbox.

For Reference, specify the reference point for the symbol.
The reference point of a symbol controls the position of a symbol over a feature in a map. The default reference point is the center of the symbol. X specifies a value for the horizontal center of the symbol. Y specifies a value for the vertical center of the symbol. You can change the reference point position.

For Rotation, do one of the following:
- Enter the amount to rotate the symbol.
- Click Any Angle. Specify the angle using the slider or enter an angle in the box. Click OK.
- Click Expression. Specify the rotation using a number expression. For more information about creating a number expression, see Building Number Expressions on page 112.
For mark symbols, do either or both of the following:

- To apply a fill to the symbol, select Apply Fill To The Symbol. For Fill Pattern, select a solid or pattern fill. Specify a foreground color and for patterned fills, a background color or transparency.

- To apply a border to the symbol, select Apply A Border To The Area. Specify border pattern, thickness, and color.

NOTE Select 0 thickness to draw the border as thinly as possible.

For font symbols, specify a format and text color.

For symbols from a Symbol library, you can override the fill colors of polygon elements, the color of line elements, and the color of text elements, use the Fill Color, Line Color, and Text Color lists.

If you do not specify overrides, the default colors from the symbol are used.

Click OK.

Click File menu ➤ Save.

NOTE To add labels to features, see Adding Labels to Features on page 96.

### Changing a Symbol's Reference Point

The reference point of a symbol controls the position of a symbol over a feature in a map. The default reference point is the center of the symbol. In the Style Point dialog box, for Reference Point, X specifies a value for the horizontal center of the symbol. Y specifies a value for the vertical center of the symbol.

**To change the reference point of a symbol**

1. In the Style Point dialog box, select Style A Point Symbol.
2. For Symbol, specify the symbol to edit.
3. For Reference Point, click [...].
4. In the Symbol Editor, use any of the following methods to define the reference point:
   - Click the new reference point.
A red box indicates the new position of the reference point. The X and Y values are updated.

- Click Center.
  The reference point is positioned at the center of the symbol.
- Enter values for X and Y.
  Use In, Out, and Extents to adjust your view of the symbol as needed.
  To view the edges of the symbol, click Outline.

5 If necessary, click Reset to restore the reference point to its original position.

6 Click OK.

7 Click File menu Save.

**Styling Lines**

Specify the thickness, color, and pattern of polyline features. Style a single line or build a composite line with several components and then style each component. For example, to illustrate a highway, create a thick black line and add a thinner, dashed, yellow line.

**NOTE** Set default units in Options. For more information, see Setting Layer Editor Options on page 151.

1 To apply styles to lines

- Open the layer to edit by doing one of the following:
  - Create a new layer.
  - Double-click an existing layer.
  - Click the layer’s tab if the layer is already open.

For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2 In the Style pane of the Layer Editor, under Scale Ranges, select the scale range to style.

For more information about scale ranges, see Understanding Scale Ranges on page 87.
3 In the Line Style area for the selected scale range, for Style Of The Geometry, click [...].

4 In the Style Line dialog box, select the Apply Styles To The Line checkbox.

5 To style a single line, do the following:
   ■ For Size Context, select Map Space to specify the size in standard real-world units (inches, feet, yards, miles, millimeters, centimeters, meters, kilometers) or Device Space to specify the size in screen units (points, inches, millimeters, centimeters).
   ■ For Units, select the type of units to measure line thickness.
   ■ Use the lists to specify polyline thickness, color, and pattern.

   **NOTE** Select 0 thickness to draw the line as thin as possible.

6 To build a composite line, do the following:
   ■ Click Create Composite Lines to expand the Style Line dialog box.
   ■ Style the first line in the composite.
   ■ Click New to add a new component to the line.
   ■ Style the new component as desired.
   ■ Control the position of the selected component in the overall composite line by clicking the up and down arrows.

7 Click OK.

8 Click File menu ➤ Save.

**NOTE** To add labels to features, see Adding Labels to Features on page 96.

**Styling Areas**

Specify the fill style and color, background color, edge style and color, and line thickness used to draw polygon features.

**NOTE** Set default size context and units in Options. For more information, see Setting Layer Editor Options on page 151.
To apply styles to areas

1 Open the layer to edit by doing one of the following:
   ■ Create a new layer.
   ■ Double-click an existing layer.
   ■ Click the layer’s tab if the layer is already open.

For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2 In the Style pane of the Layer Editor, under Scale Ranges, select the scale range to style.

For more information about scale ranges, see Understanding Scale Ranges on page 87.

3 In the Area Style area for the selected scale range, for Style Of The Geometry, click […].

4 To fill polygons, in the Style Area dialog box, select the Apply Fill To The Area check box.

5 For Fill Pattern, select Solid or a pattern.
   ■ If you specified Solid fill, specify Foreground Transparency and Foreground Color.
   ■ If you specified a pattern fill, specify colors for Foreground Color and Background Color. If you do not want a background color for the pattern, click Transparent for Background Color.

   **NOTE** In polygons with transparent backgrounds, the colors you see on the map may differ from the colors displayed in the preview frame because the preview frame always uses a white background, which may differ from the color beneath the transparent objects in your map.

6 To add borders to polygons, select the Apply A Border To The Area checkbox and then do the following:
   ■ For Line Pattern, specify the pattern for the area border.
   ■ For Size Context, select Map Space to specify the size in standard real-world units (inches, feet, yards, miles, millimeters, centimeters, meters, kilometers) or Device Space to specify the size in screen units (points, inches, millimeters, centimeters).
For Units, select the type of units to use to measure border thickness.

For Line Thickness, specify a thickness for the area border.

NOTE Select 0 thickness to draw the border as thin as possible.

For Line Color, specify a color for the area border.

7 Click OK.

8 Click File menu ➤ Save.

NOTE To add labels to features, see Adding Labels to Features on page 96.

Styling an Annotation Layer

If you are working with data that was created using the Publish to MapGuide feature in AutoCAD Map 3D, the data may include annotation layers. You cannot create or edit annotation layers in MapGuide Studio, but you can style them.

To style an annotation layer

1 In the Site Explorer, double-click the annotation layer.

2 At the top of the Layer Editor, click Style (blue text, not a button) to bring the Style panel of the editor to the top.

3 In the Style panel, next to Style of the geometry, click ....

4 In the Style Text Layer dialog box specify the Size Context.
   ■ Select Device Space to specify symbol widths and heights in screen units. Available units are Points, Inches, Millimeters, or Centimeters.

   ■ Select Map Space to specify symbol widths and heights in Mapping Coordinate System (MCS) units. Available units are Inches, Feet, Yards, Miles, Millimeters, Centimeters, Meters, and Kilometers.

5 Specify the Units.

6 For Text Type, select one of the following:
   ■ Plain—Formats annotation text uniformly using the settings specified for the layer in the Style Text Layer dialog box. The text has no formatting information itself.
Mtext—Formats annotation text as multiline. The settings specified for the layer in the Style Text Layer dialog box define the base formatting style. You can override this formatting when you insert individual Annotative text features.

The Edit Expression button lets you specify an expression for this setting for advanced use cases. We recommend that you do not use expressions for Text Type.

7 For Text, leave the "Label_Text" value unchanged. This is the name of a property in the feature source.

8 For Font Name, specify the font to use on the annotation layer.

9 For Font Size, leave the "NullValue(SIZE,number)" expression. The initial setting for font height is in mapping units and is based on the existing view. We recommend that you try the suggested height and adjust the number as needed. If individual instances require a different height, adjust the value in the SIZE column in the Data Table after you insert the annotation instances.

10 Specify other font styling using the drop downs.

11 For Horizontal Alignment, Vertical Alignment, and Rotation, leave the "HORIZONTAL_ALIGNMENT", "VERTICAL_ALIGNMENT", and "ORIENTATION" expression values unchanged. These are the names of properties in the feature source.

12 Click OK.

Adding Labels to Features

Add labels to features on feature source layers. The label is placed near the line, point symbol, or polygon. For point layers, if precise placement is important, display the label at a point location. For more information, see Displaying Fixed Labels at Point Locations on page 99. If a feature label obscures another label, it is not displayed. Feature labels are drawn on top of point symbols, lines, and polygons. By default, feature labels will not obscure point symbols. You can allow feature labels to obscure point symbols. For more information, see Allowing Labels to Obscure Points (Overposting) on page 99.

Specify the label text, font, size, format, color, background style and color, alignment, and rotation of the label.
To label features

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer’s tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. In the Style pane of the Layer Editor, under Scale Ranges, select the scale range to style.
   For more information about scale ranges, see Understanding Scale Ranges on page 87.

3. In the style area for the selected scale range, for Feature Label, click […].

4. In the Style Label dialog box, select the Create A Label checkbox.

5. For Property To Display, do one of the following:
   - Select a property.
   - Select Expression to use Text Expression dialog box to specify label text.

   For more information, see Building Text Expressions on page 110.

6. For Font, select a font from the list.

7. For Size Context, specify the type of units:
   - Select Device Space to specify symbol widths and heights in screen units. Available units are Points, Inches, Millimeters, or Centimeters.
   - Select Map Space to specify symbol widths and heights in Mapping Coordinate System (MCS) units. Available units are Inches, Feet, Yards, Miles, Millimeters, Centimeters, Meters, and Kilometers.

8. For Units, select the type of units to use.

9. For Size, enter the text size or specify the size using a number expression.
   For more information, see Building Number Expressions on page 112.
To apply bold, italic, or underlining, click one or more of the Format options.

For Text Color, click a color.

To specify a background style, from the Background Style list click one of the following:
- Ghosted: Draws an opaque border around each character. Use Background Color to specify a color for the outline.
- Opaque: Draws a background behind the labels. They are displayed as rectangles with text inside. Use Background Color to specify a color for the rectangles.
- Transparent: No background is applied to the labels, which are displayed only as text on the map.

For Ghosted and Opaque background styles, click a color in the Background Color list.

If you are adding labels to a polyline layer, use Vertical Alignment to specify the label position.
You can select one of the available positions or select a layer property that contains alignment information for each feature.

**NOTE** Horizontal and vertical alignment settings are not available for area layers. Only the vertical alignment setting is available for line layers. Horizontal and vertical alignment settings are available for point layers that display fixed labels instead of symbols. For more information, see Displaying Fixed Labels at Point Locations on page 99.

For Rotation, do one of the following:
- Enter the amount to rotate the text.
- Click Any Angle. Specify the angle using the slider or enter an angle in the box. Click OK.
- Click Expression. Specify the rotation using a number expression. For more information about creating a number expression, see Building Number Expressions on page 112.

Click OK.

Click File menu ➤ Save.
Allowing Labels to Obscure Points (Overposting)

Feature labels are drawn on top of point symbols, lines, and polygons. This can be a problem on point layers where the point symbol can be completely obscured by a label. This is called overposting. To minimize overposting, a default setting prevents a label from being drawn at a specific zoom level if it obscures other labels or point features on the map. However, overposting is always allowed for line and polygon features. MapGuide Studio displays the label when you zoom in far enough to allow sufficient space to display it.

To allow overposting

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer's tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. In the Style pane of the Layer Editor, under Scale Ranges, select the scale range to style.

   For more information about scale ranges, see Understanding Scale Ranges on page 87.

3. Click Allow Other Labels To Obscure Feature Symbols On This Layer.

4. Click File menu ➤ Save.

Displaying Fixed Labels at Point Locations

If exact placement of labels is important, disable the point style and place fixed labels at feature locations.

**NOTE** Fixed labels are always displayed, even if they obscure other labels or features. While feature labels are drawn after all layer features have been drawn, fixed labels are drawn according to the draw order of their layer within a map, and may be obscured by features from other layers.
To place labels at points

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer’s tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. In the Style pane of the Layer Editor, under Scale Ranges, select the scale range to style.

   For more information about scale ranges, see Understanding Scale Ranges on page 87.

3. In the Point Style area for the selected scale range, select the Labels Are Fixed (Not Dynamic) checkbox.

4. In the Point Style area for the selected scale range, for Style Of The Geometry, click [...].

5. To remove the point symbol, in the Style Point dialog box, clear the Style a Point Symbol checkbox.

6. In the Point Style area for the selected scale range, for Feature Label, click [...].

7. To turn on and style the label, in the Style Label dialog box, select the Style checkbox.

8. Specify label text and style.

   For more information about feature labels, see Adding Labels to Features on page 96.

9. Use the Horizontal Alignment and Vertical Alignment lists to specify the position of the label relative to the feature.

   You can select one of the available positions or select a layer property that contains alignment information for each feature. The alignment values in the property must be specified as follows:

   - Horizontal: Left, Center, or Right.
   - Vertical: Baseline, Bottom, Capline, Halfline, or Top.
Click File menu ➤ Save.

Creating Themes

Themes are styles based on the data associated with features in your map. Themes provide a visual representation of the data. For example, a typical theme for a point layer might display retail store locations with a different symbol for each type of store, or a polygon layer theme might display each land use classification with a different color or shading.

A theme consists of a collection of rules. Each rule specifies a style and feature label for the features that meet the specified condition. You can add a legend label to provide a description of a rule’s condition. As a layer is drawn, each feature is compared to the rules in the order that they are listed. The first rule for which the feature meets the condition is used to specify the style and feature label for that feature. A default or empty condition applies to all features and defines the style for features that do not meet any of the preceding rules. A well-constructed theme contains only one default rule and it is last in the list.

Create rules manually or use the MapGuide Studio theming tool to automate theming based on a range of conditions. For more information, see Creating Themes Automatically on page 102.

To create a theme manually

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer’s tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. In the Style pane of the Layer Editor, under Scale Ranges, select the scale range to theme.

   For more information about scale ranges, see Understanding Scale Ranges on page 87.

3. In the geometry style area, click Theme>> if the style rule grid is not displayed.
4 In the style rule grid, click the Condition grid cell.

5 Use the Filter dialog box to specify the subset of features to theme. Click OK.
   For more information about using the Filter dialog box, see Filtering Data on page 84.

6 In the style rule grid, click the Style grid cell.
   The Style Point, Style Line, or Style Area dialog box is displayed depending on the type of data associated with the layer.

7 Create point, line, and area styles for the theme.
   For more information about defining styles, see Styling Points on page 88, Styling Lines on page 92, and Styling Areas on page 93.

8 To add labels to features in the theme, in the style rule grid, click the Feature Label grid cell.
   For more information about creating feature labels, see Adding Labels to Features on page 96.

9 To label the theme in the legend, enter the text in the Legend Label grid cell.

10 Optionally, do one or more of the following:
   ■ To add a new rule to an existing theme, click Add A Rule.
       Define the rule as described in the preceding steps.
   ■ To copy and modify a selected rule, click Duplicate.
       Modify the new rule as described in the preceding steps.
   ■ To delete the selected rule, click Delete.
   ■ To adjust the position of the selected rule in the list, click Move Up and Move Down as needed.
       After a rule applies to a feature, none of the rules that come after it in the list are applied to the feature.

11 Click File menu ➤ Save.

Creating Themes Automatically

The MapGuide Studio theming tool creates a theme automatically based on a range of conditions.
To create a theme automatically

1 Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer’s tab if the layer is already open.

For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2 In the Style pane of the Layer Editor, under Scale Ranges, select the scale range to theme.

   For more information about scale ranges, see Understanding Scale Ranges on page 87.

3 In the style rule grid, click Theme>> to display the advanced editor.

4 Click Theme [...] to display the Theme dialog box.

5 In the Rules area, specify the number of ranges to create and whether new ranges replace existing ranges or are added before or after existing ranges.

   You can specify the number of ranges to create if Distribution method is Equal, Quantile, or Jenks (Natural Breaks). Properties containing strings use an Individual Values distribution that does not allow the number of rules to be edited. Adjust the number of rules to control the coarseness of the theme.

   For more information about distribution methods, see Understanding Distribution Methods on page 105.

6 To analyze features based on values that fall into various numerical ranges, do the following:
   - Select the Create A Range Of Conditions checkbox.
   - For Property, select the property on which to base the theme.
   - Specify the Minimum Value and Maximum Value for the range. The first rule includes the Minimum Value and the last rule includes the Maximum Value. Styles are interpolated across the range.
   - For Distribution, select a method. For more information about distribution methods, see Understanding Distribution Methods on page 105.
If you clear the Create A Range Of Conditions checkbox, the theming tool creates a set of ranges with interpolated styles and labels, but with empty conditions. You can then fill in the conditions manually.

7 To interpolate styles across the range of conditions, do the following:
   ■ Select the Interpolate Styles Across The Range Of Conditions checkbox.
   ■ For Style Ramp, click [...] . The Style Point, Style Line, or Style Area dialog box is displayed depending on the type of data associated with the layer. An additional column of controls is provided for defining the end-of-range style.
   ■ Use the From column to define the start of the range.
   ■ Use the To column to define the end of the range.
   The first rule uses the From style and the last rule uses the To style. Styles are interpolated across the range.
   For more information about defining styles, see Styling Points on page 88, Styling Lines on page 92, and Styling Areas on page 93.
   If you clear the Interpolate Styles Across The Range Of Conditions checkbox, the theming tool creates a range of conditions with blank styles. Then, you can fill in the styles manually.

8 To add labels to features in the theme, do the following:
   ■ Select the Create Feature Labels For The Range Of Conditions checkbox.
   ■ Click Label Ramp. You can interpolate label size, text color, and rotation across the range of conditions.
   ■ In the Style Label dialog box, use the From column to define the start of the ramp. Use the To column to define the end of the ramp. The first rule uses the From label style and the last rule uses the To label style. Label styles are interpolated across the range.
   For more information about creating feature labels, see Adding Labels to Features on page 96.

9 To create legend labels for the theme, do the following:
   ■ Select the Create Legend Labels For The Range Of Conditions checkbox.
   ■ For Legend Text, enter the text to appear within each rule in the legend.
For Label Format, specify how to display the legend label. If you theme a layer on a property that contained area information and you used the label text Area, the label formats might look like the following examples:

<Label Text> <Min> to <Max>
Area: 100 to 200

<Label Text> <Min> - <Max>
Area: 100 - 200

<Min> <= <Label Text> <Max>
100 <= Area < 200

**NOTE** If you are connecting to a multi-geometry feature source, you can specify whether each separate geometry appears in the legend. Select the Show In Legend check box for each geometry that you want to appear.

10 Click File menu ➤ Save.

### Understanding Distribution Methods

When you create a range of conditions for a theme, you must specify the distribution method. The following methods are available:

<table>
<thead>
<tr>
<th>Distribution method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal</td>
<td>The difference between the high and low values is the same for every range. This method is easy to interpret and is useful for showing continuous data such as rainfall.</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>Features are placed in ranges based on how much their values vary from the mean. MapGuide Studio calculates the mean and then adds or subtracts the standard deviation to or from the mean to create the ranges.</td>
</tr>
<tr>
<td>Quantile</td>
<td>Each range contains an equal number of features. This method is useful for showing data in which values are evenly distributed.</td>
</tr>
</tbody>
</table>
Distribution method | Description
--- | ---
Jenks (Natural Breaks) | Ranges are based on natural groupings of data values. Features with similar values are grouped together. This method shows the natural groupings in the data.
Individual Values | Features are not grouped. This distribution is useful if values are not continuous, there is a fixed number of values, and many features have the same value.

**Working with Drawing Source Layers**

If the data resource associated with the layer is a drawing source (DWF file), you can specify a scale range and the sheet and layers to display in the Viewer. For more information about drawing sources, see Understanding Resources on page 8.

**Setting the Scale Range**

Specify the range at which the DWF data is visible.

**To specify or change the scale range for a layer**

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer’s tab if the layer is already open.
   
   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. In the Settings pane of the Layer Editor, under Scale Range, for From enter the lower range value.

3. For To, enter the upper range value.

4. Click File menu ➤ Save.
Specifying the Drawing Sheet and Layers

When you work with a drawing source (DWF) layer, you can specify which sheet and layers to use. Sheets are individual plot sheets containing views or layouts of the original data. You must specify a single sheet to display in the layer. If the DWF was published from a DWG file, and layers were enabled, you can turn layers on and off.

To specify the sheet and layers

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer's tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. In the Settings pane of the Layer Editor, under Drawing Data Setup, for Which Drawing Sheet, select the sheet to use for the layer.

3. For Include Only These Layers, click [...].

4. In the Select Layers dialog box, do one of the following:
   - In the Layers list, select the layers to display.
   - Click Select All to select all available layers.
   - Click Clear All to clear selected layers.

5. Click OK.

6. Click File menu ➤ Save.

Working with Raster Layers and WMS Layers

When the data resource associated with the layer is a raster catalog or a WMS, the layer settings are slightly different from other files and database connections. You can specify a scale range, how often to redraw the image during zooming, and how to display bitonal images.

For more information about creating raster catalogs, see About Raster Files on page 29.
For more information about creating WMS layers, see About Web Services on page 45.

**Setting the Scale Range**

Specify the range at which the raster image is visible.

**To specify a scale range**

1. Open the layer to edit by doing one of the following:
   - Create a new layer.
   - Double-click an existing layer.
   - Click the layer’s tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. In the Style pane of the Layer Editor, under Scale Range, for From enter the lower range value.

3. For To, enter the upper range value.

4. Click File menu ➤ Save.

**Specifying the Zoom Rebuild Factor**

Specify how often MapGuide Studio should re-sample the raster image data after zooming in. To understand how the zoom rebuild factor works, suppose the value is set to 3 and the Viewer is displaying a map that is 300x200 pixels. Assume that the source of the raster image layer is 3000x2000 pixels in size. The first time the Viewer displays the map, the application makes a request to the server to resample the entire raster image to a resolution of 300x200 pixels. MapGuide Viewer displays and scales this resampled image locally until the user has zoomed in by a magnification factor of 3. At that time, the application issues another request to the server to re-sample a smaller subset of the original raster image to a resolution of 300x200 pixels. Again, the Viewer displays and scales this re-sampled image locally as zooming continues, until the user zooms in another 3 times.
To specify the zoom rebuild factor

1. Open the layer to edit by doing one of the following:
   ■ Create a new layer.
   ■ Double-click an existing layer.
   ■ Click the layer’s tab if the layer is already open.

   For information about creating a new layer, see Creating New Resources on page 60. For information about associating a data resource with a new layer, see Specifying the Data Resource for a Layer on page 81.

2. In the Rebuild Layer After Zooming By A Factor Of box, enter a magnification factor.
   This number must be an integer.

3. Click File menu ➤ Save.

Setting Foreground and Background Color for Bitonal Images

For bitonal raster images, Foreground Color (1 Or “On” Pixels) is black by default and Background Color (0 Or “Off” Pixels) is white. You can specify the following settings for the foreground and background colors:

■ Specify any color.

■ Set foreground or background to transparent. Features from other layers will show through the raster image.

■ Use the foreground or background color in the map that references this layer and raster data.

To set foreground and background colors

1. From the Foreground color (1 or “on” pixels) list, select one of the following:
   ■ A color
   ■ Map Window Background
   ■ Transparent
2 From the Background color (0 or “off” pixels) list, select one of the following:
  ■ A color
  ■ Map Window Background
  ■ Transparent

3 Click File menu ➤ Save.

**Building Text Expressions**

The Text Expression dialog box is available in several places in MapGuide Studio. Use it to specify URL, tooltip, and feature label values. For example, you might create a text expression that specifies the following label text:

<State_Name>: <Population>

Where <State_Name> and <Population> are the values of these properties for each feature. For example, California: 33,871,648.

The Text Expression dialog box has two modes: Builder and Advanced. In Builder mode you can only create expressions that use valid syntax. In Advanced mode you can create expressions using any syntax, even if it is not handled by the Builder. You cannot move from Advanced mode to Builder mode unless conditions are valid. Further, an expression with valid syntax is not allowed in the builder if it contains functions or property names that are not in the layer’s data source.

**To build a text expression**

1 In the Text Expression dialog box, under Text Value, do any of the following:
   ■ Click Property and select a property from the list.
   ■ Click Constant and enter the text to use.
   ■ Click Number Expression and click [...]. Use the Number Expression dialog box to create a number expression.
     For more information, see Building Number Expressions on page 112.

2 To add components to the expression, click New and define the next component.
   To join multiple components in Advanced mode, use `concat`. For example:
Spaces are ignored in Advanced mode except within the single quotes that specify a constant.

3 Click OK.

4 Click File menu ➤ Save.

Building URL Expressions

The following functions are designed to help build URL expressions that include identifying information with each feature. For example, when you click on a feature, the link opens a browser window that displays the feature’s properties.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MAPNAME()</td>
<td>Name of the runtime map for the current session</td>
</tr>
<tr>
<td>SESSION()</td>
<td>Current session ID</td>
</tr>
<tr>
<td>LAYERID()</td>
<td>Layer ID of the feature associated with the URL</td>
</tr>
<tr>
<td>FEATURECLASS()</td>
<td>Class name of the feature associated with the URL</td>
</tr>
<tr>
<td>FEATUREID()</td>
<td>ID of the feature associated with the URL</td>
</tr>
<tr>
<td>URLENCODE(string)</td>
<td>URL-encodes the supplied string</td>
</tr>
</tbody>
</table>

To create this type of expression, you must use the Text Expression dialog box in Advanced Mode. For the above mentioned use case, the following expression is an example of a feature URL that includes the necessary identifying information:

```sql
concat(concat('Hyperlink.php?FeatureID=', URLENCODE(FEATUREID())),
        concat('&FeatureClass=', URLENCODE(FEATURECLASS())),
        concat('&LayerID=', URLENCODE(LAYERID())))
```

**NOTE** When using these functions in feature URL expressions, remember to use URLENCODE to ensure that all URL parameter values are properly encoded.
Building Number Expressions

Use number expressions to specify values in many places in MapGuide Studio. You can generate a new numerical value based on existing values. You can also include a number expression within a text expression by placing it within parentheses. For example, you might create a text expression that specifies a state name and population for a label. To express the population in millions, you can apply a number expression that divides the population value by 1,000,000.

For example, you might create a text and number expression that specifies the following label text:

```
concat (State_Name, concat (':', (Population/1000000)))
```

Where `<State_Name>` and `<Population>` are the values of these properties for each feature. The label would display California: 3.3.

The Number Expression dialog box has two modes: Builder and Advanced. In Builder mode you can only create expressions that use valid syntax. In Advanced mode you can create expressions using any syntax, even if it is not handled by the Builder. You cannot move from Advanced mode to Builder mode unless conditions are valid. Further, an expression with valid syntax is not allowed in the builder if it contains functions or property names that are not in the layer’s data source.

Spaces are ignored in Advanced mode except within the single quotes that specify a constant.

To build a number expression

1. In the Number Expression dialog box, under Property Or Constant, do either of the following:
   - Click Property and select a property from the list.
   - Click Constant and enter the value to use.
2. Click New to add additional elements to the expression.
3. Under Operation, click a arithmetic operator.
4. Under Property Or Constant, specify a property or constant value.
5. To group and ungroup conditions, select the conditions and click Group Selected Conditions or Ungroup Selected Conditions as needed.
6. Click OK.
7 Click File menu ➤ Save.

**Previewing the Layer**

As you style a layer, use the Layer Preview pane to view what it will look like when a user displays it in the Viewer.

**To preview the layer**

1 If the Layer Preview pane is not displayed, click Preview.

2 Click Refresh.

To display the Layer Preview pane below the Layer Editor pane as you work, click Split.
Displaying the Map in a Web Browser

After you create a map, you can build a flexible or basic web layout so that users can view and interact with the map on the Internet or an intranet. The flexible web layout is a CSS-based web layout, which allows you to modify the templates provided with MapGuide Studio and add third party templates. The basic web layout supports the table-based DWF and AJAX viewers and maintains backward compatibility with your basic web layouts from previous versions of MapGuide Studio. Test your flexible or basic web layout using either the Preview pane in the Web Layout Editor or by viewing it in your default browser.

When you build a new flexible or basic web layout you only need to specify the map to display. All other settings have default values. Use the Web Layout Editor to perform the following tasks:

- Create a new web layout and specify the map to display.
- Modify default web layout settings.
- Design Viewer toolbars, right-click menus, and a task pane.
- Create custom components.

Flexible Layout Viewer

Setting Up the Web Layout

You can create a new flexible web layout, specify general settings, select a template, and specify the Viewer components to display.
Creating a New Flexible Web Layout

MapGuide Studio provides default web layout settings so that you only need to specify a map to display when you create a new flexible web layout.

To create a new flexible web layout

1. Click File menu ➤ New ➤ Web Layout ➤ Flexible Layout.
2. For Map Resource Used In This Layout click [ ... ], locate and select the map to reference in the web layout and click Open.
3. Click File menu ➤ Save As. In the Save Resource As dialog box, specify a name for the web layout and a location in the Site Explorer and click Save.

Selecting a Template

You can choose any 1 of the 5 templates to create your web layout. If you select the Aqua, LimeGold, or TurquoiseYellow templates, the containers are displayed in a tab format. If you select the Maroon or Slate templates, the containers are displayed in a pane format.

NOTE Each template has a separate URL, which launches it in a separate browser. To preview your web layout in a browser, see Previewing the Web Layout in a Browser on page 129.

To select a template

1. Open the web layout to edit by doing one of the following:
   - Create a new web layout.
   - Double-click an existing web layout.
   - Click the web layout’s tab if it is already open.
2 In the Select A Template For The Web Layout pane, click a template thumbnail.

3 For Web Page Title enter a title to appear in the title bar of the browser.

4 Use the Configure Components of the Selected Template to specify the settings for your web layout.
   If you choose to use a different template, you can reuse the settings that you selected for the previous template.

Specifying General Web Layout Settings

Use the Web Layout Editor to specify the following settings for your web layout:

- The template to display
- Web page title
- Map resource to reference in the web layout
- Initial view of the map when displayed in a browser
- URL for the initial task to display in the task pane of the Viewer
- The Viewer components to display

To set general web layout settings

1 Open the web layout to edit.
   For information about creating a new web layout, see Creating a New Basic Web Layout on page 130.

2 On the MapGuide Studio toolbar, click Edit to hide the preview panel.

3 Select a template by clicking on a thumbnail.
   For information about selecting a template, see Selecting a Template on page 116.

4 For Web Page Title enter a title to appear in the title bar of the browser.

5 Under Configure Components Of The Selected Template, click the Map tab, if it is not already selected.

6 For Map Resource Used In This Layout click [...], locate and select the map to reference in the web layout and click Open.
7 For Initial View Of The Map do the one of the following:
   ■ Click Use Map's Initial View.  
      The initial view in the layout matches the initial view you specified  
      in the Map Editor. For more information, see Setting the Initial Map  
      View on page 73.
   ■ Click Use Custom View. For Center, enter the XY values of the point  
      to use as the initial center point of the map.  
      The XY values correspond to the units used in the referenced map  
      resource. For example, if the map uses a Lat/Lon coordinate system,  
      X is Lon and Y is Lat in degrees. If the map uses the Miller Cylindrical  
      Projection, X and Y values are in Meters.  
      To adjust the zoom level, for Zoom To enter the zoom factor for the  
      initial zoom scale of the map.  
      Leave the Zoom To field clear to display the entire map.  
      Click Set To Current Map Zoom to use the center and zoom level you  
      have defined in the Web Preview pane of the Web Layout Editor.

8 Under Add Basemap From External Providers, you can do the following:
   ■ Select the external provider basemaps that you want to include in  
      your layout. There are three baselayers available from each provider.  
      You can include any combination of baselayers and providers.
   ■ For Google Maps and Yahoo! Maps basemaps you must enter an API  
      key. If you do not have an API key, click the link in the text under  
      the API field next to the relevent provider's name. Note that Bing  
      Maps does not require an API key.
   ■ Select the default baselayer to display.

9 Click the Task Pane tab. For Inital Task URL specify the location of the  
    initial HTML content to display in the task pane to assist your users.

10 Click File menu ➤ Save.

Displaying Viewer Containers

All templates display the following containers in your web layout browser:

Legend Controls the display of the Legend pane. The Legend pane displays  
    a list of layers.

Map Controls the display of the referenced map.
Overview Map Controls the display of the Overview Map pane. To display the overview map, click View ➤ Show Overview Map in the browser of your completed web layout.

Right-Click Menu Controls the display of the components in the Right-Click Menu. The Right-Click Menu contains the following default components: Refresh, Pan, Zoom Rectangle, Zoom In, Zoom Out, Zoom, Select, Clear Selection, Select More, Buffer, Measure, Help, and About. To customize this menu, see Customizing the Right-Click Menu on page 121.

Selection Displays properties for a selected feature. The pane is blank if multiple features are selected. To define the properties to display in the Selection pane, see Specifying the Properties to Display in the Viewer on page 83.

Status Bar Controls the display of the cursor position, layer name, number of features selected, current map scale, current map window height and width, and command descriptions.

Task Pane Controls the display of the Task pane. The Task pane displays the Task List menu, which contains the Buffer and Measure default components, task bar buttons, interactive prompts, and the results of searches and interactive commands. To customize this pane, see Customizing the Task List Menu on page 122.

Main Menu Toolbar Controls the display of the components in the Main Menu toolbar. The Main Menu toolbar contains the following default components: Maps and View. To customize this toolbar, see Customizing the Viewer Toolbars on page 120.

Primary Toolbar Controls the display of the components in the Primary toolbar. The Primary toolbar contains the following default components: Refresh, Select Radius, Select Polygon, Clear Selection, Buffer, Measure, Print, Options, About, and Help. To customize this toolbar, see Customizing the Viewer Toolbars on page 120.

Vertical (or Secondary) Toolbar Controls the display of the Vertical toolbar and Secondary toolbar. These toolbars contain the following default components: Select, Pan, Zoom Rectangle, Zoom In, Zoom Out, Zoom Extents, Zoom Selection, Previous, and Next. To customize these toolbars, see Customizing the Viewer Toolbars on page 120.

If you detach the default components from the Legend, Selection, Task, or Overview Map panes, the panes will appear blank in your web layout.
Specifying Additional Maps to Display

You can specify additional maps to display in the Maps menu item of the main menu toolbar in the browser of your completed web layout.

To specify additional maps to display

1. In the Configure Components Of The Selected Template pane, click the Map tab.
2. For Map Resource Used In This Layout click […], locate and select the map to reference in the web layout and click Open.
3. Click File menu ➤ Save.

NOTE To delete maps from the map group, click Edit Map Groups in the Map tab to access the Map Set Editor window, in which you can edit the XML code.

Defining the Viewer Toolbars, Right-Click Menu, and Task Pane Menu

Use the toolbar, right-click menu, and task pane menu tabs of the Web Layout Editor to set up the components to make available to your users. You can provide different sets of components in the Viewer toolbars, the right-click menu, and task list menu. The set of available components is defined by MapGuide Studio.

A set of built-in basic components with few or no settings is available for immediate use. Three additional components require configuration and have additional parameters. These are: Search, Invoke Script, and Invoke URL. For more information about working with these components, see Customizing Components on page 124.

Customizing the Viewer Toolbars

MapGuide Studio provides the following toolbars: the Main Menu toolbar, the Primary toolbar, and the Vertical (or Secondary) toolbar. You can customize all toolbars by specifying additional components to include. If you have customized the right-click menu or task list menu, you can use those settings for the toolbars. For more information, see Duplicating the Toolbar, Right-Click Menu, and Task List Menu on page 124.
NOTE The position of the toolbars in the browser depends on which template you select. When you select the LimeGold or Slate templates, the Secondary Toolbar appears below the Primary Toolbar in the browser. The Vertical Toolbar appears if you select the Aqua, Maroon, or TurquoiseYellow templates.

To customize the Viewer toolbars

1. In the Configure Components Of The Selected Template pane of the Web Layout Editor, select the toolbar to customize by clicking a tab.

2. Do any or all of the following:
   - Drag component icons from the Components Available in This Layout pane to the Items Displayed In Container pane.
   - To add a separator between items in the toolbar, click the item that will appear to the right of the separator and click Add ➤ New Separator.
   - To change the position of an item, click the item and click Move Item Up or Move Item Down.
   - To delete an item, click the item and click Remove Item.
   - To add a flyout menu, see Creating Flyouts on page 138.

3. View the toolbar in the Web Preview pane.

4. Click File menu ➤ Save.

Customizing the Right-Click Menu

You can specify additional components to include in the Right-Click menu. If you have customized the toolbars or task list menu, you can use those settings for the right-click menu. For more information, see Duplicating the Toolbar, Right-Click Menu, and Task List Menu on page 124.

To customize the right-click menu

1. In the Configure Components Of The Selected Template pane, click the Map:Right-Click Menu tab.

2. Do any or all of the following:
   - Drag component icons from the Components Available In This Layout pane to the Items Displayed In Container pane.
To add a separator between items in the right-click menu, select the item that will appear below the separator and click Add ➤ New Separator.

To change the position of an item, click the item. Then click Move Item Up and Move Item Down.

To delete an item, click the item. Then click Remove Item.

To add a flyout menu, see Creating Flyouts on page 138.

3 To preview the right-click menu, right-click the map in the Web Preview pane.

4 Click File menu ➤ Save.

Customizing the Task List Menu

You can specify additional components to include in the Task List menu. If you have customized the toolbars or right-click menu, you can use the same settings for the task list menu. For more information, see Duplicating the Toolbar, Right-Click Menu, and Task List Menu on page 124.

To customize the task list menu

1 In the Configure Components Of The Selected Template pane, click the Task Pane: Task Menu tab.

2 Do any or all of the following:
   ■ Drag component icons from the Components Available In This Layout pane to the Items Displayed In Container pane.
   ■ To add a separator between items in the task list menu, click the item that will appear below the separator. Then click Add ➤ New Separator.
   ■ To change the position of an item, click the item. Then click Move Item Up and Move Item Down.
   ■ To delete an item, click the item. Then click Remove Item.

3 To view the task list menu, click Task List in the Task pane displayed in the Web Preview pane.

4 Click File menu ➤ Save.
Creating Flyouts

Add a flyout menu to any container in the toolbar, task pane menu, and right-click menu.

To create a flyout

1. Click the Toolbar or Map:Right-Click Menu tab.
2. Click Add ➤ New Flyout.
3. Click the new flyout and do the following:
   - Position the flyout menu using Move Item Up and Move Item Down.
   - In the Flyout Parameters panel, specify the label, tooltip, and images to use for this control. For more information about these properties, see Basic Command Settings on page 139.
   - Add components and separators to the flyout the same way you add them to the toolbar, task list menu, and right-click menu.
4. Click File menu ➤ Save.

Restoring Toolbar, Right-Click Menu, and Task List Menu Defaults

You can restore the toolbar, right-click menu, and task list menu to the default state before customization.

To restore defaults

1. In the Configure Components Of The Selected Template pane of the Web Layout Editor, click the Toolbar, Map:Right-Click Menu, or Task Pane:Task Menu tab.
2. In the Items Displayed In Container click Reset ➤ To Defaults For and click the menu to restore its defaults.
Duplicating the Toolbar, Right-Click Menu, and Task List Menu

After you customize the toolbar, right-click menu, or task list menu, you can apply the same settings to each of the other two tabs making the contents match.

To duplicate settings

1. Click the tab you want to make match the customized tab.
2. Click Reset ➤ To Match and select the customized menu or toolbar that you want to match.

Customizing Components

MapGuide Studio provides a set of built-in basic components and three advanced components: Invoke Script, Invoke URL, and Search.

You cannot modify or delete the components that are provided with MapGuide Studio. However, you can customize the built-in components by creating new components based on each action type and modifying the settings of the new components.

To create new basic components, see Creating New Basic Components on page 125. To create new advanced components, see Creating New Advanced Components on page 126.

Basic Component Settings

Many components share the following settings:

ID Internal name for the component.

Label To Display In The Interface Name to display for this component.

Tool Tip To Appear On Hover Short text description that is displayed when the cursor is placed over the button that activates the component.

Description To Appear On The Status Bar Additional description that is displayed in the status bar when the cursor is placed over the button, menu item, or task that activates this component.

URL To Image For This Control Location for the button image to use when the component is available.
Image Class Controls how the image is displayed in the web application when a CSS class is specified.

In addition to the basic component settings, a component may have additional settings, which you can adjust as necessary.

The following components generate results:

- Buffer Panel
- Measure
- Select Within

You must specify a location (target) to display results. Target options are:

Task Pane Displays results in the Task pane.

New Window Opens a new browser window to display results.

Specified Frame Displays results in the named frame that you specify.

Creating New Basic Components

Customize a basic component by creating a new component with the same action type, and then modifying its settings. For more information about basic component settings, see Basic Command Settings on page 139.

To create a new basic component

1. In the Configure Components Of The Selected Template pane, select the tab where you want to place the customized component.

2. In the Components Available In This Layout, click New....

3. In the list of components, click the new component and click OK.

4. Use the Parameters For Selected Item panel to specify basic component settings.

   For more information, see Basic Command Settings on page 139.

5. If you are creating a new component based on Buffer Panel, Measure, or Select Within do the following:

   - In the Parameters For Selected Item pane, for Target, click either Task Pane, New Window, or Specified Frame.

   - If you select Specify Frame, enter the frame name.
For more information about target options, see Basic Command Settings on page 139.

6 To create a new print component, see Creating a Print Command on page 144.

7 Click File menu ➤ Save.

Creating New Advanced Components

Customize an advanced component by creating a new component with the same action type, and then modifying its settings.

Advanced commands are:

- Invoke Script
- Invoke URL
- Search

To create a new advanced component

1 In the Configure Components Of The Selected Template, do one of the following:
   - Select a toolbar
   - Click Map: Right-Click Menu
   - Click Task Pane: Task menu

2 In the Components Available In This Layout panel, click New and select a new component.

3 Use the Parameters For Selected Item panel to specify basic component settings.
   For more information, see Basic Command Settings on page 139.

4 Do one of the following:
   - To create a new Invoke Script component, see Creating an Invoke Script Command on page 142.
   - To create a new Invoke URL component, see Creating an Invoke URL Command on page 142.
To create a new Search component, see Creating a Search Command on page 143.

5 Click File menu ➤ Save.

Creating an Invoke Script Component

Use an Invoke Script component to call a JavaScript function inside your web layout.

To create an Invoke Script component

1 Follow steps 1 - 4 in Creating New Advanced Components on page 126.
2 In the Parameters For Selected Item panel, under Script To Invoke, enter the name of the script file to associate with this component.
3 Click File menu ➤ Save.

Creating an Invoke URL Component

Use an Invoke URL component to call a URL from your web layout.

To create an Invoke URL component

1 Follow steps 1 - 4 in Creating New Advanced Components on page 126.
2 In the Parameters For Selected Item panel, under URL To Invoke, enter the URL to call when this component is executed.
3 Under Pass In These Additional Parameters With The URL, specify one or more key/value parameters to include with the URL.
4 Under Use Only These Layers, specify the layers to which the component applies.
5 To specify that the component is only available if features are selected, click Disable Command If Nothing Is Selected.
6 Under Target, specify whether the results should display in the task pane, a new window, or a specific frame.

For more information about target options, see Basic Component Settings on page 124.
7 Click File menu ➤ Save.

Creating a Search Component

Use a Search component to build a search tool for your users.

To create a search component

1 Follow steps 1 - 4 in Creating New Advanced Components on page 126.

2 In the Parameters For Selected Item panel, for Display This Prompt For Users To Enter A Search specify the prompt to display to your users.

3 For Search This Layer, specify the layer to which the search applies.

4 For Pass The Search Term Into This Filter, click [...] and define a filter to select a subset of features.
   For more information about defining a filter, see Filtering Data on page 84.

5 For Use These Columns To Display The Results Returned By This Search Component, click Add and do the following:
   ■ Enter a title for the column.
   ■ Select the property to display in the column.
   ■ Use the Move Up and Move Down buttons to adjust the order of the columns in the results table.

6 Specify a maximum number of results under Return A List Of Results No Larger Than.

7 For Target, click either Task Pane, New Window, or Specified Frame.
   If you select Specify Frame, enter the frame name.
   For more information about target options, see Basic Component Settings on page 124.

8 Click File menu ➤ Save.

Creating a Print Component

Create a custom print component by modifying a built-in basic component.
To create a print component

1. Follow the instructions for creating a basic component. For more information, see Creating New Basic Components on page 125.

2. In the Parameters For Selected Item, select any or all of the following checkboxes: Show Title, Show Legend, Show North Arrow.

3. Enter a title to be printed on the page.

4. Click File menu ➤ Save.

Previewing the Web Layout

Use the Web Preview pane of the Web Layout Editor to preview your flexible layout as you work.

Previewing the Web Layout in MapGuide Studio

Preview your web layout as you work using the Web Preview pane of the Web Layout Editor. When you preview your web layout in the Web Layout Editor, you are not required to save your changes.

To preview your web layout within MapGuide Studio

1. If the Web Preview pane is not displayed, click Preview.

2. In the Web Preview pane, click Refresh.

Previewing the Web Layout in a Browser

Your default browser displays the last saved version of your web layout.
To preview your web layout in a browser

1. In the Select a Template For The Web Layout pane, click View in Browser.

2. Enter your MapGuide Studio User Name and Password when prompted and click OK.
   You can also copy and paste the URL into the location bar of your browser.

**NOTE** The URLs displayed are the locations of your web layouts in the MapGuide Studio virtual directory structure. For newly created web layouts, the Web Address Of This Layout field is blank and you will be prompted to save when you click View in Browser.

Basic Layout Viewer

Setting Up the Web Layout

You can create a new web layout, specify general settings, and specify the Viewer components to display.

Creating a New Basic Web Layout

To create a new basic web layout

1. Click File menu ➤ New ➤ Web Layout ➤ Basic Layout.

2. For Map Resource Used In This Layout click […], locate and select the map to reference in the web layout and click Open.

3. Click File menu ➤ Save As. In the Save Resource As dialog box, specify a name for the web layout and a location in the Site Explorer and click Save.

Specifying General Web Layout Settings

Use the Settings pane of the Web Layout Editor to specify the following settings for your web layout:

- Browser title bar text

130 | Chapter 6   Displaying the Map in a Web Browser
To set general web layout settings

1. Open the web layout to edit by doing one of the following:
   - Create a new web layout.
   - Double-click an existing web layout.
   - Click the web layout’s tab if the web layout is already open.

   For information about creating a new basic web layout, see Creating a New Basic Web Layout on page 130.

2. Expand the Settings pane if it is not already displayed.

3. For Text for Browser Title Bar enter a title to appear in the title bar of the browser.

4. For Map Resource Used In This Layout click [...], locate and select the map to reference in the web layout and click Open.

5. For Initial View Of The Map do the one of the following:
   - Click Use Map’s Initial View. The initial view in the layout matches the initial view you specified in the Map Editor. For more information, see Setting the Initial Map View on page 73.
   - Click Use Custom View. For Center, enter the XY values of the point to use as the initial center point of the map. The XY values correspond to the units used in the referenced map resource. For example, if the map uses a Lat/Lon coordinate system, X is Lon and Y is Lat in degrees. If the map uses the Miller Cylindrical Projection, X and Y values are in Meters.

   To adjust the zoom level, for Zoom To enter the zoom factor for the initial zoom scale of the map. Leave the Zoom To field clear to display the entire map.
Click Set To Current Map Zoom to use the center and zoom level you have defined in the Web Preview pane of the Web Layout Editor.

6   For Display These Components In The Viewer, specify which components of the Viewer to display.
    For more information, see Specifying Viewer Components to Display on page 132.

7   For URL For Home Task Displayed In The Task Pane specify the location of the initial HTML content to display in the task pane to assist your users.
    The Home button in the task pane displays this initial page. Various commands can also use the task pane as the frame in which to display their output. For more information, see Customizing the Task Bar Menu on page 137.

8   Make sure that Keep Connection Alive is selected.
    If enabled, this option prevents the Ajax viewer from timing-out after a period of inactivity. If disabled, when the Ajax viewer times-out, the viewer will lose connection with the server and the session will close.

9   For Open Feature URL Hyperlinks In This Target Interface specify how to display hyperlinks associated with features.
    You can open hyperlinks in the Task pane, a new browser window, or a named frame that you specify.

10  Click File menu ➤ Save.

**Specifying Viewer Components to Display**

Specify which components of the Viewer are displayed when your users view the web layout in a browser. The Viewer can display the following sets of components:

**Left Pane** Controls the display of the Layers Pane and the Properties Pane. The Layers Pane displays a list of layers. The Properties Pane displays properties for a selected feature. The pane is blank if multiple features are selected. To define the properties to display in the Properties Pane, see Specifying the Properties to Display in the Viewer on page 83.

If you display the left pane you can specify the width in pixels.
**Middle Pane** Controls the display of the Toolbar, Context Menu, Status Bar, and the Zoom Control for the AJAX viewer.

**Right Pane** Controls the display of the Task pane. The Task pane can display a Task bar, interactive prompts, and the results of searches and interactive commands.

If you display the right pane you can specify the width in pixels.

**To specify Viewer components**

1. In the Settings pane of the Web Layout Editor, locate the Display These Components In The Viewer section.

2. For Left Pane, do the following:
   - Select Layers Pane, Properties Pane, or both.
   - For Width (Pixels), specify a width for the left pane.

3. For Middle Pane, select any or all of the following checkboxes: Toolbar, Context Menu, Status Bar, Zoom Control (AJAX Viewer Only).
   
The status bar displays the cursor position, layer name, number of features selected, current map scale, current map window height and width, and command descriptions.
   
   To customize the contents of the Viewer toolbar and context menu, see Customizing the Viewer Toolbar on page 135 and Customizing the Context Menu on page 136.
   
   If you set up base layers with a set of defined scales for smooth zooming in the AJAX viewer, the zoom control snaps to the specified scales. For more information, see Setting Up Smooth Map Viewing on page 78.

4. For Right Pane, do the following:
   - To include a task pane, select the Task Pane checkbox.
     
     To specify the location of HTML content to display in the task pane, see Specifying General Web Layout Settings on page 130.
     
     The task pane contains Home, Back, and Forward buttons and a Tasks menu button.
   
   - To include a task bar, select the Task Bar checkbox.
     
     To define the contents in the task bar menu, see Customizing the Task Bar Menu on page 137.

   - To customize the buttons on the bar, click Edit Navigation Buttons. You can change the name of each button, the tooltip text to display when the cursor is placed over the button, the text that displays in
the Viewer status bar (if turned on), and the images to use when the button is enabled or disabled. For more information, see Customizing Task Bar Buttons on page 134.

- For Width (Pixels), specify a width for the right pane.

The Width and the Task Bar checkbox are unavailable when Task Pane is turned off.

5 To define a toolbar, context menu, and task pane in the Viewer, follow the instructions in Defining the Viewer Toolbar, Context Menu, and Task Pane Menu on page 135.

6 Click File menu ➤ Save.

Customizing Task Bar Buttons

The Task Bar in the Task Pane contains the Home, Back, Forward, and Tasks menu buttons.

- Home—Navigates to the home task URL specified when you set general web layout properties. For more information, see Specifying General Web Layout Settings on page 130.

- Back and Forward—Provide navigation in the task pane.

- Tasks—Provides access to the commands in the Task menu. For more information about customizing the Tasks menu, see Customizing the Task Bar Menu on page 137.

You can change the name of each button, the text to display when the cursor is placed over the button, the text that displays in the Viewer status bar, and the images to use when the button is enabled and disabled.

To customize task bar buttons

1 In the Settings pane of the Web Layout Editor, locate the Display These Components In The Viewer section.

2 In the Right Pane area, click Edit Navigation Buttons.

3 In the Customize Navigation Buttons dialog box, select the button you want to customize.
Do any of the following tasks:

■ For Name To Display In The Interface, enter a new name for the button.

■ For Tool Tip To Appear Upon Hover, enter the text to display when a user positions the cursor over the icon.

■ For Description To Appear On The Status Bar, enter additional descriptive text to display in the status bar when the cursor is placed over the button.

■ For URL To An Image For Enabled State, enter a location for the button image to use when the command is available.

■ For URL To An Image For Disabled State, enter a location for the button image to use when the command is not available.

Defining the Viewer Toolbar, Context Menu, and Task Pane Menu

Use the Toolbar And Menus pane of the Web Layout Editor to set up the commands to make available to your users. You can provide different sets of commands in the Viewer toolbar, the context menu, and task pane menu. The set of available commands is defined by Autodesk MapGuide Studio.

A set of built-in basic commands with few or no parameters is available for immediate use. Three additional commands require configuration and have additional parameters. These are: Search, Invoke Script, and Invoke URL. For more information about working with these commands, see Customizing Commands on page 139.

Customizing the Viewer Toolbar

When you make a Viewer toolbar available to your users, specify the commands to include. If you have customized the context menu or task bar menu, you can use those settings for the toolbar. For more information, see Duplicating the Toolbar, Context Menu, and Task Bar Menu on page 138.

To customize the Viewer toolbar

1 In the Settings pane of the Web Layout Editor, under Middle Pane, select the Toolbar checkbox to enable a Viewer toolbar.
2 Display the Toolbar And Menus pane.
3 Click the Toolbar tab.
4 Do any or all of the following:
   ■ Drag command icons from the Command List tab to the Toolbar tab.
   ■ To add a separator between items in the toolbar, click the item that will appear to the right of the separator and click Add ➤ Add Separator.
   ■ To change the position of an item, click the item and click Move Up or Move Down.
   ■ To delete an item, click the item and click Remove Item.
   ■ To add a flyout menu, see Creating Flyouts on page 138.
5 View the toolbar in the Web Preview pane.
6 Click File menu ➤ Save.

**Customizing the Context Menu**

When you make a Viewer context menu available to your users, specify the commands to include. If you have customized the toolbar or task bar menu, you can use those settings for the context menu. For more information, see Duplicating the Toolbar, Context Menu, and Task Bar Menu on page 138.

To customize the context menu

1 In the Settings pane of the Web Layout Editor, under Middle Pane, select the Context Menu checkbox to enable a Viewer context menu.
2 Display the Toolbar And Menus pane.
3 Click the Context Menu tab.
4 Do any or all of the following:
   ■ Drag command icons from the Command List tab to the Context Menu tab.
   ■ To add a separator between items in the context menu, select the item that will appear below the separator and click Add ➤ Add Separator.
   ■ To change the position of an item, click the item. Then click Move Up and Move Down.
To delete an item, click the item. Then click Remove Item.

To add a flyout menu, see Creating Flyouts on page 138.

5 To preview the context menu, right-click the map in the Web Preview pane.

6 Click File menu ➤ Save.

**Customizing the Task Bar Menu**

When you make a Viewer Task Pane and Task Bar menu available to your users, specify the commands to include. If you have customized the toolbar or context menu, you can use the same settings for the task bar menu. For more information, see Duplicating the Toolbar, Context Menu, and Task Bar Menu on page 138.

**To customize the task bar menu**

1 In the Settings pane of the Web Layout Editor, under Right Pane, select the Task Pane and Task Bar checkboxes.

2 Display the Toolbar And Menus pane.

3 Click the Task Bar Menu tab.

4 Do any or all of the following:
   - Drag command icons from the Command List tab to the Task Bar Menu tab.
   - To add a separator between items in the task bar menu, click the item that will appear below the separator. Then click Add ➤ Add Separator.
   - To change the position of an item, click the item. Then click Move Up and Move Down.
   - To delete an item, click the item. Then click Remove Item.

5 To view the task bar menu, click Tasks in the Task Pane displayed in the Web Preview pane.

6 Click File menu ➤ Save.
Creating Flyouts

Add a flyout menu to any command in the toolbar and context menu.

To create a flyout
1. Click the Toolbar or Context Menu tab.
2. Click Add ➤ Add Flyout Menu.
3. Click the flyout and do the following:
   - Position the flyout menu using Move Up and Move Down.
   - Click Item Properties.
   - On the Item Properties tab, specify the name, tooltip, description, and images to use for enabled and disabled states.
     For more information about these properties, see Basic Command Settings on page 139.
   - Add commands and separators to the flyout the same way you add them to the toolbar and context menu.
4. Click File menu ➤ Save.

Restoring Toolbar, Context Menu, and Task Bar Menu Defaults

You can restore the toolbar, context menu, and task bar menu to the default state before customization.

To restore defaults
1. Display the Toolbar And Menus pane of the Web Layout Editor.
2. Click the Toolbar, Context Menu, or Task Bar Menu tab.
3. Click Reset ➤ To Defaults.

Duplicating the Toolbar, Context Menu, and Task Bar Menu

After you customize the toolbar, context menu, or task bar menu, you can apply the same settings to each of the other two tabs making the contents match.
To duplicate settings

1. Click the tab you want to make match the customized tab.
2. Click one of the following as needed:
   - Reset ➤ To Match Toolbar
   - Reset ➤ To Match Context Menu
   - Reset ➤ To Match Task Bar Menu

Customizing Commands

MapGuide Studio provides a set of built-in basic commands and three advanced commands: Invoke Script, Invoke URL, and Search.

You cannot modify or delete the commands that are provided with MapGuide Studio. However, you can customize the built-in commands by creating new commands based on each action type and modifying the settings of the new commands.

To create new basic commands, see Creating New Basic Commands on page 140. To create new advanced commands, see Creating New Advanced Commands on page 141.

Basic Command Settings

All commands share the following settings:

**Action To Be Performed By This Command** Action to perform when the command is executed by a user.

**Command Name** Internal name for the command.

**Name To Display In The Interface** Name to display for this command.

**Tool Tip To Appear On Hover** Short text description that is displayed when the cursor is placed over the button that activates the command.

**Description To Appear On The Status Bar** Additional description that is displayed in the status bar when the cursor is placed over the button, menu item, or task that activates this command.

**URL To An Image For Enabled State** Location for the button image to use when the command is available.
URL To An Image For Disabled State Location for the button image to use when the command is not available.

Viewers That Support This Command The type of Viewer that supports this command: All, AJAX, or DWF. This property is determined by the action type and cannot be modified.

The following commands generate results:

- Buffer
- Get Printable Page
- Measure
- Select Within
- View Options

You must specify a location (target) to display results. Target options are:

Task Pane Displays results in the Task pane.

New Window Opens a new browser window to display results.

Specified Frame Displays results in the named frame that you specify.

The Print command requires you to specify the print layouts to make available to your users. For more information about setting up print layouts, see Working with Print Layouts on page 153.

Creating New Basic Commands

Customize a basic command by creating a new command with the same action type and then modifying its settings. For more information about basic command settings, see Basic Command Settings on page 139.

To create a new basic command

1 In the Web Layout Editor, expand the New Commands pane.

2 Click Add ➤ Built-In Commands and click the type of command to add.

3 In the list of commands, click the new command.

4 Use the Settings tab to specify basic command settings.
   For more information, see Basic Command Settings on page 139.
5 If you are creating a new command based on Buffer, Get Printable Page, Measure, Select Within, or View Options do the following:
   ■ Click the Additional Parameters tab.
   ■ For Display Results In This Target Interface, click either Task Pane, New Window, or Specified Frame.
   ■ If you select Specify Frame, enter the frame name. For more information about target options, see Basic Command Settings on page 139.

6 To create a new print command, see Creating a Print Command on page 144.

7 Click File menu ➤ Save.

Creating New Advanced Commands

Customize an advanced command by creating a new command with the same action type and then modifying its settings.

Advanced commands are:
   ■ Invoke Script
   ■ Invoke URL
   ■ Search

To create a new advanced command

1 In the Web Layout Editor, expand the New Commands pane.

2 Do one of the following:
   ■ Click Add ➤ Invoke Script
   ■ Click Add ➤ Invoke URL
   ■ Click Add ➤ Search

3 In the list of commands, click the new command.

4 Use the Settings tab to specify basic command settings. For more information, see Basic Command Settings on page 139.
5  Do one of the following:
   ■ To create a new Invoke Script command, see Creating an Invoke Script Command on page 142.
   ■ To create a new Invoke URL command, see Creating an Invoke URL Command on page 142.
   ■ To create a new Search command, see Creating a Search Command on page 143.

6  Click File menu ➤ Save.

Creating an Invoke Script Command

Use an Invoke Script command to call a JavaScript function inside your web layout.

To create an Invoke Script command

1  Follow steps 1 - 4 in Creating New Advanced Commands on page 141.
2  Click the Additional Parameters tab.
3  On the Additional Parameters tab, under Script To Invoke, enter the name of the script file to associate with this command.
4  Click File menu ➤ Save.

Creating an Invoke URL Command

Use an Invoke URL command to call a URL from your web layout.

To create an Invoke URL command

1  Follow steps 1 - 4 in Creating New Advanced Commands on page 141.
2  Click the Additional Parameters tab.
3  Under URL To Invoke, enter the URL to call when this command is executed.
4  Under Pass In These Additional Parameters With The URL, specify one or more key/value parameters to include with the URL.
5 Under Use Only These Layers, specify the layers to which the command applies.

6 To specify that the command is only available if features are selected, click Disable Command If Nothing Is Selected.

7 Under Display Results In This Target Interface, specify whether the results should display in the task pane, a new window, or a specific frame. For more information about target options, see Basic Command Settings on page 139.

8 Click File menu ➤ Save.

Creating a Search Command

Use a Search command to build a search tool for your users.

To create a search command

1 Follow steps 1 - 4 in Creating New Advanced Commands on page 141.

2 Click the Additional Parameters tab.

3 For Display This Prompt For Users To Enter A Search Term, specify the prompt to display to your users.

4 For Search This Layer, specify the layer to which the search applies.

5 For Pass The Search Term Into This Filter, click […] and define a filter to select a subset of features. For more information about defining a filter, see Filtering Data on page 84.

6 For Use These Columns To Display The Results Returned By This Search Command, click Add and do the following:
   ■ Enter a title for the column.
   ■ Select the property to display in the column.
   ■ Use the Move Up and Move Down buttons to adjust the order of the columns in the results table.

7 Specify a maximum number of results under To Return A List Of Results No Larger Than.
8 For Display Results In This Target Interface, click either Task Pane, New Window, or Specified Frame.
   If you select Specify Frame, enter the frame name.
   For more information about target options, see Basic Command Settings on page 139.

9 Click File menu ➤ Save.

Creating a Print Command

Create a custom print command by modifying a built-in basic command. You must specify the print layouts to make available to users when they print from the Viewer.

For information about setting up print layouts, see Working with Print Layouts on page 153.

To create a print command

1 Follow the instructions for creating a basic command.
   For more information, see Creating New Basic Commands on page 140.

2 Click the Additional Parameters tab.

3 Under Print Layouts Options To Be Displayed To End Users, click […]

4 In the Select Print Layouts dialog box, do one of the following:
   ■ In the Print Layouts list, select the layouts to make available.
   ■ Click Select All to select all available layers.
   ■ Click Clear All to clear selected layers.

5 Click OK.

6 Click File menu ➤ Save.

Previewing the Web Layout

Use the Web Preview pane of the Web Layout Editor to preview your layout as you work. Preview your web layout using either the DWF Viewer or the AJAX Viewer.
Previewing the Web Layout in MapGuide Studio

Preview your web layout as you work using the Web Preview pane of the Web Layout Editor.

To preview your web layout within MapGuide Studio

1. If the Web Preview pane is not displayed, click Preview.

2. In the Web Preview pane, click Refresh.

Previewing the Web Layout in a Browser

Preview your web layout in a browser using either the AJAX or DWF option of the Autodesk MapGuide Viewer. The AJAX option is for users who do not use Microsoft Internet Explorer.

To preview your web layout in a browser

- Click either of the following options:
  - For Preview In Browser Using DWF Viewer, click Go. Internet Explorer displays the last saved version of your layout using the Autodesk DWF Viewer. You can also copy and paste the URL into the location bar of your browser.
  - For Preview In Browser Using AJAX Viewer, click Go. Your default browser displays the last saved version of your layout using the AJAX Viewer. You can also copy and paste the URL into the location bar of your browser.

**NOTE** The URLs displayed are the locations of your web layouts in the MapGuide Studio virtual directory structure. For newly created web layouts, the URL field is blank and the Go button is disabled until the resource has been saved.
Working with Symbols

Autodesk MapGuide® Studio provides six mark symbols: square, circle, triangle, star, cross, and X. In addition you can use font symbols and build MapGuide Studio symbol libraries.

Insert symbols in point layers using the Style Point dialog box. For more information, see Styling Points on page 88.

Organize symbols into symbol libraries based on themes or on the frequency with which you use certain symbols. A symbol library is a resource in the Site Explorer.

Symbol Libraries support the following file formats:

- Bitmap (BMP)
- Device Independent Bitmap (DIB)
- Enhanced Metafile (EMF)
- TrueType Fonts (TTF)
- Windows Metafile (WMF)
- Portable Network Graphics (PNG)
- Joint Photographic Experts Group (JPG/JPEG)

Symbol Libraries support vector as well as bitmap images and complex symbols that combine both formats.

Creating a New Symbol Library

You can create symbol libraries to group symbols, making them easier to locate and use.

NOTE When you load an Autodesk Map drawing into Autodesk MapGuide Studio, blocks are converted into a symbol library.
To create a new symbol library

1. Click File menu ➤ New ➤ Symbol Library.
2. For Description, enter a description of the library.
3. Do any or all of the following:
   - Import images into a library. For more information, see Importing Images into a Symbol Library on page 148.
   - Import fonts as symbols. For more information, see Importing Font Characters as Symbols on page 148.
4. Click File menu ➤ Save.

Importing Images into a Symbol Library

You can import images of a variety of file types to use as symbols.

To import images

2. In the Load Symbols dialog box, navigate to and select the file to import.
3. Click Open.
   The name of the symbol is displayed in the list and the selected symbol is displayed in the Preview area.
4. Click File menu ➤ Save.

NOTE Alternatively, drag images from your file system into the symbol list area.

Importing Font Characters as Symbols

Import True Type font characters to use as symbols. You can also insert a font symbol directly in the Style Point dialog box. For more information, see Styling Points on page 88.

To import font characters

1. On the Symbol Library toolbar, click Fonts.
2 In the Load Fonts dialog box, for Font, select the font family from which to import characters.

3 Optionally, for Format, click Bold and/or Italic.
   For some fonts, Bold and/or Italic are not available or are enabled by default.

4 For Symbol Color, select a color.

5 For Background Style, specify either Opaque or Transparent.

6 If you specify an opaque background for a symbol, for Background Color, select a color.

7 Click OK.

8 Click File menu ➤ Save.

Deleting Symbols

You can customize symbol libraries to include only symbols based on one theme or to include only symbols you frequently use. If you have a symbol in multiple symbol libraries, deleting it from one will not delete it from the others.

To delete a symbol

1 Open the symbol library containing the symbol to delete by doing one of the following:
   ■ Double-click the symbol library in the Site Explorer.
   ■ Click the symbol library’s tab if the symbol library is already open.

2 Click the symbol in the symbol list area.

3 Click Delete.

Copying Symbols

You can duplicate a symbol to create a new symbol with many of the same properties of an existing symbol. Customize the new symbol by modifying the reference point, zoom level, and outline.
To copy a symbol

1. Open the symbol library containing the symbol to copy by doing one of the following:
   - Double-click the symbol library in the Site Explorer.
   - Click the symbol library's tab if the symbol library is already open.

2. Click the symbol in the symbol list area.

3. Click Duplicate.
   A new symbol is created. A number is appended to the name to indicate that one or more copies of the symbol exist.

4. Customize and rename the symbol as desired.
Setting Options

Use Options to control the default settings for the Site Explorer and Layer Editor. Also use options to specify whether to use the DWF Viewer or AJAX Viewer for previews in the Layer, Map, and Web Layout editors.

Setting Site Explorer Options

Control the display of a warning message when moving, renaming, or deleting resources.

To set Site Explorer options

1. Click Tools menu ➤ Options.
2. In the Options dialog box, click the Site Explorer tab.
3. Select or clear the checkbox, Show Confirmation Dialog Before Moving, Renaming, Or Deleting A Resource.
4. Click OK.

Setting Layer Editor Options

Control the default settings for size context and units used in the Layer Editor.

To set Layer editor options

1. Click Tools menu ➤ Options.
2. In the Options dialog box, click the Layer Editor tab.
3. Specify default size context for labels, points, and lines and borders.
Device Space sets widths and heights in screen units. Map Space sets widths and heights in Mapping Coordinate System (MCS) units.

4 Specify default units for labels, points, and lines and borders.

**Setting Viewer Options**

MapGuide Studio can use the Basic Layout Viewer or the Flexible Layout Viewer.

To specify the default viewer

1 Click Tools menu ➤ Options.
2 In the Options dialog box, click the Viewer tab.
3 Specify the default viewer.
Working with Print Layouts

Define any number of print layouts to include with a web layout. When your users view the web layout in a browser, they can print using a layout from the set you provide. The layout describes the elements to include in the DWF ePlot that is sent to the printer. You can include the following elements in a layout:

- Background color
- Title
- Legend
- Scale bar
- North arrow
- URL
- Date and time
- Custom logo
- Custom text

**NOTE** Print layouts are XML files. The Print Layout Editor requires a basic understanding of XML.

Creating Print Layouts

When you create a new print layout, all the elements are provide by default. Edit them as necessary. All page elements except custom symbols and text are placed at a predetermined location on the page which cannot be modified. You can specify the placement of custom logos and text.
To create a new print layout

1 Click File menu ➤ New ➤ Print Layout.
   The Print Layout Editor displays an XML template that includes all possible print layout elements.

2 Edit the XML template as necessary.
   ■ When specifying a background color, enter color values for red, green, and blue using RGB color values. There are 256 possible values for each of the red, green, and blue components of a color pixel on a computer screen. Each color value ranges from 0 (no color) to 255 (full color). A full color value combines a red, a green, and a blue value. The following table provides sample color values (red, green, blue):

<table>
<thead>
<tr>
<th>RGB values</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>0, 0, 0</td>
<td>black</td>
</tr>
<tr>
<td>255, 0, 0</td>
<td>bright red</td>
</tr>
<tr>
<td>255, 255, 0</td>
<td>bright yellow</td>
</tr>
<tr>
<td>0, 0, 255</td>
<td>bright blue</td>
</tr>
<tr>
<td>255, 255, 255</td>
<td>white</td>
</tr>
</tbody>
</table>

■ Custom logos are stored in a Symbol Library resource. If you are adding a logo to a layout, locate the CustomLogos section and specify the logo position, Symbol Library resource, name, size, and rotation. Valid units for Logo Position are percent, meters, and inches. If the Position Units value is not specified, the default is percent. Valid units for Logo Size are meters and inches. Default Logo Size units are inches.

■ If you are adding text to a layout, locate the CustomText section and specify the text position, font and size, and the text to print. Valid units for Text Position are percent, meters, and inches. If the Position Units value is not specified, the default is percent. Valid units for Font Height are inches, meters, and points. Default Font Height units are points.

3 Click Validate to check for syntax errors.
Syntax errors are displayed at the bottom of the Print Layout Editor.

4 If errors are detected, click on each error in turn to locate the problem in the XML code.
   When you have addressed each error, a message indicates that the layout is valid.

5 Click File menu ➤ Save As to save the layout.

When you create a new print command in the Web Layout Editor, the print layouts you have saved are available under Additional Parameters. For more information, see Customizing Commands on page 139.
Print Layout Schema

The following schema describes the print layouts you can create using the Print Layout editor. The schema file is named `PrintLayout-1.0.0.xsd`. It can be found in the MapGuide Studio installation folder.
<?xml version="1.0" encoding="UTF-8" ?>
<xs:schema
xmlns:xs="http://www.w3.org/2001/XMLSchema"
elementFormDefault="qualified"
attributeFormDefault="unqualified">
<xs:element name="PrintLayout">
<xs:complexType>
<xs:sequence>
<xs:element name="PageProperties">
<xs:complexType>
<xs:sequence>
<xs:element name="BackgroundColor" minOccurs="0">
<xs:complexType>
<xs:sequence>
<xs:element name="Red" type="xs:integer" minOccurs="0" />
<xs:element name="Blue" type="xs:integer" minOccurs="0" />  
<xs:element name="Green" type="xs:integer" minOccurs="0" />
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:sequence>
</xs:complexType>
</xs:element>
<xs:element name="LayoutProperties">
<xs:complexType>
<xs:sequence>
<xs:element name="ShowTitle" type="xs:boolean" minOccurs="0" />
<xs:element name="ShowLegend" type="xs:boolean" minOccurs="0" />
<xs:element name="ShowScaleBar" type="xs:boolean" minOccurs="0" />
<xs:element name="ShowNorthArrow" type="xs:boolean" minOccurs="0" />
<xs:element name="ShowURL" type="xs:boolean" minOccurs="0" />
<xs:element name="ShowDateTime" type="xs:boolean" minOccurs="0" />
<xs:element name="ShowCustomLogos" type="xs:boolean" minOccurs="0" />
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:sequence>
</xs:schema>
<xs:element name="ShowCustomText" type="xs:boolean" minOccurs="0" />
</xs:element>
</xs:complexType>
</xs:element>
<xs:element name="CustomLogos">
<xs:complexType>
<xs:sequence>
<xs:element name="Logo" minOccurs="0" maxOccurs="unbounded">
<xs:complexType>
<xs:sequence>
<xs:element name="Position" minOccurs="0">
<xs:complexType>
<xs:sequence>
<xs:element name="Left" type="xs:float" />
<xs:element name="Bottom" type="xs:float" />
<xs:element name="Units" type="xs:string" />
</xs:sequence>
</xs:complexType>
</xs:element>
<xs:element name="ResourceId" type="xs:string" minOccurs="0" />
<xs:element name="Name" type="xs:string" minOccurs="0" />
<xs:element name="Size" minOccurs="0">
<xs:complexType>
<xs:sequence>
<xs:element name="Width" type="xs:float" />
<xs:element name="Height" type="xs:float" />
<xs:element name="Units" type="xs:string" />
</xs:sequence>
</xs:complexType>
</xs:element>
<xs:element name="Rotation" type="xs:float" minOccurs="0" />
</xs:element>
</xs:complexType>
</xs:element>
<xs:element name="CustomText">
<xs:complexType>
<xs:sequence>
</xs:element>
</xs:complexType>
</xs:element>
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:element>
<xs:element name="CustomText" type="xs:string">
<xs:complexType>
<xs:sequence>
</xs:element>
</xs:complexType>
</xs:element>
Print Layout Schema | 159
Print Layout Sample

The following sample layout specifies a white background with a title, legend, scale bar, north arrow, URL, and time and date. Sample custom text is included. Custom logos are not included.
When you've set up your custom logo, please remove this comment tag. -->
</CustomLogos>
<CustomText>
<Text>
<Position>
<Left>1.5</Left>
<Bottom>1.5</Bottom>
<Units>inches</Units>
</Position>
<Font>
<Name>Times New Roman</Name>
<Height>0.005</Height>
<Units>meters</Units>
</Font>
<Value>Custom Text #1</Value>
</Text>
<Text>
<Position>
<Left>0.05</Left>
<Bottom>0.05</Bottom>
<Units>meters</Units>
</Position>
<Font>
<Name>Arial</Name>
<Height>12</Height>
<Units>points</Units>
</Font>
<Value>Custom Text #2</Value>
</Text>
</CustomText>
</PrintLayout>
Overview of Expressions for Geospatial Features

An expression is the part of a query that specifies its conditions. A query evaluates data and returns only the subset of data that meets the conditions of the query.

For example, you can create an expression that specifies all parcels whose area is larger than 4000 square feet. A query containing this expression displays or selects only parcels that meet those criteria.

A complete query also specifies the following:

- The set of data to which the conditions are applied
- The action to apply to the data that meets the conditions

For example, you can query a feature layer in a map and display or hide its data based on whether it meets the query conditions.

In practice, you specify the data set by selecting the feature class or layer to query before you build the expression. You specify the action to apply when you select the command that lets you build the expression. For example, in AutoCAD Map 3D, select Add To Map With Query or Search To Select.

The title bar for the dialog box in which you create expressions is different, depending on the command you choose. The contents of the dialog box are much the same, no matter what it is called.

Use expressions to filter geospatial data, select a subset of data, calculate values, or convert data from one data type to another. Use text expressions to format
text strings for display, for example, as labels. Use numeric expressions to apply math functions to properties with numeric values.

The text in the title bar changes, depending on which command you select.

Basic Steps for Creating Expressions

To create an expression, follow these basic steps:

■ Specify the data to which the expression applies. For example, select the layer to filter.
■ Select a command that can use an expression. For example, right-click a layer and select Query To Filter Data.
■ Use an expression to specify the conditions for the command. For example, create an expression to specify the subset of features on the layer to select.

Ways to Use Expressions          Description

Evaluating Properties on page 173  You can filter or select data based on the value of one or more properties. A simple expression evaluates a single property, but you can create complex expressions that use multiple properties or multiple values. For example, you could create an expression that shows counties with a population over 50,000 but under 100,000. The result of a filter expression must be a Boolean value.
<table>
<thead>
<tr>
<th>Ways to Use Expressions</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Creating a Calculation on page 178** | You can calculate a new value based on existing values. For example, you can do the following:  
- Calculate the area of a polygon or the length of a linear feature.  
- Convert a text string to a date format and add days or months to the resulting date. |
| **Performing a Conversion on page 181** | Conversions change data values from one data type to another. For example, if a data store keeps date values as text, you can convert these values to date strings. Then you can use Date Functions on page 227 on them.  
You can also convert numeric or text strings to a particular numeric format, for example to a single- or double-precision number. You can convert numeric values into text strings, for example, to extract a substring or find the number of characters in the string. |
| **Creating Text Expressions on page 182** | With text expressions, you can analyze and manipulate strings. For example, you can do the following:  
- Format multiline labels.  
- Concatenate multiple properties into a single entry. For example, concatenate First_Name and Last_Name to get Full_Name.  
- Find the length of a text string, or the position of one text string within another.  
- Convert a text string to all uppercase or lowercase characters.  
- Trim or add to the beginning or end of a text string. |
<table>
<thead>
<tr>
<th>Ways to Use Expressions</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ Replace one set of characters with another.</td>
<td></td>
</tr>
</tbody>
</table>

**Creating Numeric Expressions** on page 183  
Numeric expressions operate only on numeric values. They use math functions, with which you can analyze and manipulate numeric strings. For example, with numeric expressions, you can do the following:
■ Round a value up or down.
■ Find the square root of a value, use trigonometric functions, or determine the remainder of a number after it is divided by another number.
■ Find the average, mean, or median of a set of values.

**Using Expressions to Filter Feature Data** on page 192  
With filters, you can work with a subset of your data. For example, if your map includes all the counties in California, you can create a filter to show only counties with a population over 50,000.
Use expressions to do the following:
■ Filter data as you add it to an AutoCAD Map 3D map on page 193.
■ Filter the display of data in a map on page 194.
■ Select only features that meet a set of conditions on page 195.

**Using Expressions to Label Features** on page 188  
Use a text expression on page 182 or a numeric expression on page 183 to determine the content of labels when you style your map.

**Using Expressions In Split/Merge Rules** on page 189  
Use expressions in AutoCAD Map 3D to determine how property values are specified after merging or splitting features.
Creating Expressions

Overview of Creating Expressions

An expression is the part of a query that specifies the conditions. For example, you can create an expression to specify all parcels whose area is larger than 4000 square feet. A query containing that expression displays or selects only parcels that meet those criteria.

A complete query also specifies the set of data to which the conditions are applied and the action to apply. For example, you can query a feature layer in a map and display or hide its data based on whether it meets the query conditions.

In practice, you specify the data set by selecting the feature class or layer to query before you build the expression. You specify the action to apply when you select the command or option for building the expression. For example, in AutoCAD Map 3D, select Add To Map With Query or Search To Select.

The title bar for the dialog box in which you create expressions is different, depending on the command you choose. The contents of the dialog box are much the same, no matter what it is called. In AutoCAD Map 3D, you can create expressions for geospatial features from the following locations:

<table>
<thead>
<tr>
<th>Command</th>
<th>Title Bar Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home tab ➤ Data panel ➤ Search</td>
<td>Search For Features Across Multiple Layers</td>
</tr>
<tr>
<td>Right-click Display Manager layers ➤ Query To Filter Data</td>
<td>Create Query</td>
</tr>
<tr>
<td>Data Table ➤ Search To Select</td>
<td>Search To Select</td>
</tr>
<tr>
<td>Data Connect ➤ Add To Map With Query</td>
<td>Create Query</td>
</tr>
<tr>
<td>Data Table ➤ Options ➤ Create A Calculation</td>
<td>Create A Calculation</td>
</tr>
<tr>
<td>Data Table ➤ Set Split And Merge Rules</td>
<td>Split or Merge Rule Expression</td>
</tr>
</tbody>
</table>
To create an expression

1 Select the feature classes or feature layers to apply the expression to and the action the query will affect.
For example, in the AutoCAD Map 3D Display Manager, right-click the layer, and click Query To Filter Data. The layer you right-clicked is the data source for the expression. When you filter the data, AutoCAD Map 3D displays only the data in that layer that matches the conditions of the expression.

2 In the window that displays, insert the elements that comprise the expression.

If the expression startup page is turned on, buttons representing different expression types are displayed. You can click one of these buttons to insert an expression template.

Click one of these buttons to start with a sample expression.

To prevent these startup buttons from displaying each time you create an expression, select the Don’t Show At Startup check box. You can redisplay them later by clicking Getting Started.

To close the startup page, click Close.

3 In the expression area, do any of the following to build your expression:

- Click an element in the expression to replace it with a property, value, or operator. See Selecting Property Values from a List on page 176 for information on viewing and selecting properties.

Click an element to see a menu of options for replacing or deleting it.

- Use commands and icons to add elements.
If you know the names of the properties, values, and operators you want, enter them directly.

All expressions consist of text you can type.

An expression can combine operations in many ways. For example, you can calculate the area of all parcels and then find features that have the StreetName “Elm” and are larger than 20,000 square feet.

In building your expression, you can do any of the following:

- **Evaluate the value of a property** on page 173. For example, find features on a Parcels layer whose StreetName property is “Elm.” That expression would look like this one:
  \[ \text{ST \_NAME} = 'ELM St' \]

- **Perform a calculation** on page 178, and then evaluate the result of the calculation. For example, first determine the area of parcels, and then find parcels with an area smaller than a value you specify. That expression would look like this one:
  \[ \text{Area2D (Geometry)} < 12000 \]

  **NOTE** The Geometry property may have a different name in your data store. It is always listed under Geometry Properties in the Property list. Insert the property from the list. Do not change it manually or substitute a value for this property.

- **Perform a conversion** on page 181, and then evaluate the result of the conversion. For example, convert a parcel property called Purchase_Date from a text string to a date string, and then find parcels purchased before a date you specify. That expression would look like this one:
  \[ \text{ToDate} (\text{PURCHASE\_DATE, MM/DD/YYYY}) \text{ AND PURCHASE\_DATE < 01/01/2005} \]

  **NOTE** See Using Dates in Expressions on page 171 for information about date formatting.
Create a text expression on page 182. For example, you can label a
layer representing roads with the street name, a space, and a suffix
(for example, “Portobello Road” or “Fifth Avenue”). That expression
would look like this one:
```
Concat (ST_NAME, ' ', SUFFIX)
```

Create a numeric expression on page 183. For example, you can round
off repair costs to the next highest dollar. That expression would look
like this one:
```
Ceil (REPAIR_COST)
```

Filter by location on page 185. For example, you can find all parcels
within or touching a circle that you draw on the map.

For help with any expression element, see Creating Expressions - Reference
on page 205.

5 Validate the expression by clicking Validate (at the bottom of the
window). Validation checks the syntax of the expression only. It does not check
whether the values you specified are valid for the data, or whether the
results are as expected. If there are validation problems, an error message
helps direct you to their solutions on page 197.

6 To reuse your expression later, save it on page 199 using the Options
menu (at the bottom of the window).

7 To apply your expression, click OK.

8 To set expression options on page 200, use the Options menu.

Using Dates in Expressions

You can use the following date options in your expressions:

- To convert a text property that contains date or time information into a
date value, use the ToDate or ToString conversion options. See Conversion
Options on page 232. These options support a variety of formats on page
235 for the resulting date strings.

- To use standard date and time formats, use the Date-Time Operators on
page 211. When you insert a date-time property from the Get Values panel into your
expression, that value uses a Date-Time operator. If you are an advanced
user, you can also add one of these operators to an expression if you know its FDO syntax.

The Date-Time operators are parsed using the standard SQL literal strings:

- `DATE 'YYYY-MM-DD'`
- `TIME 'HH:MM:SS[.sss]'`
- `TIMESTAMP 'YYYY-MM-DD HH:MM:SS[.sss]'`

To convert a text string to a date string and change its format

1. Select the command for which you want to create an expression. on page 168
2. Select ToDate from Conversion.
3. In the ToDate function, do one of the following:
   - Within the parentheses, type a property name.
   - Click Property. In the Property list, select the property to convert.
     Select a text property that represents a date value.

   ![Create a Calculation](image)

   Convert a text string to a date string.

4. Optionally, specify the date format on page 235.
5. Specify any further conditions for the expression.
   For information about formulating an expression, see Overview of Creating Expressions on page 167.
   For help with any expression element, see Creating Expressions - Reference on page 205.

6. Click OK to apply the expression.
Evaluating Properties

You can use expressions to evaluate properties. Here are some examples:

- Find all features on a layer that have a property equal to, greater than, or less than a particular value. For example, find all parcels with an assessed value greater than $250,000.

- Display all the features on a layer with a property that matches a pattern you specify. For example, display all roads whose names begin with “Mt.”

- Label features with the value of a particular property, rounded in a particular way. For example, label roads with their length, rounded up to the nearest whole number.

You can enter property names directly into an expression, or you can select them from the Property list. If you selected multiple feature layers, the properties for all those layers are available.

If you enter a property name that is not in the Property list, the Validate operation may issue a warning. However, if that property exists in your data store, the expression may still be valid when it is run.

You can also view and insert the valid values on page 176 for any listed property.

The syntax for an expression that evaluates a property is slightly different, depending on whether you use an operator, a function, or an option. For an operator, the basic syntax is `Property OPERATOR Value`. For functions and options, the basic syntax is `Function (PROPERTY)`.

See also:

- Using Expressions to Filter Feature Data on page 192
- Overview of Creating Expressions on page 167
- Creating Expressions - Reference on page 205

To evaluate properties in an expression using an operator

1. Select the command for which you want to create an expression. on page 168

2. In the expression area, do one of the following:
   - Enter a property name manually.
   - Click Property. In the Property list, select a property.
3 Enter an operator using one of these methods:
  ■ Enter an operator manually.
  ■ Click an operator button.

| + | - | * | / | = | ≤ | ≥ | LIKE | AND | OR | [ ]

- Use the Operator buttons.

  ■ Select an operator from a menu.

4 You can use the following types of operators:

  ■ Math Operators on page 208
    For example, this expression could be used to label repair locations with the total amount spent on parts and labor for a pipe repair project:
    
    \[ \text{PIPE\_PARTS\_COST} + \text{PIPE\_LABOR\_COST} \]

  ■ Comparison Operators on page 209
    For example, to find parcels whose assessed value is $100,000 or more, use this expression:
    
    \[ \text{PARCEL\_VALUE} \geq 100000 \]

  ■ Logical Operators on page 210
    For example, to find only parcels that have a value for the \text{PARCEL\_OWNER} property, use this expression:
    
    \[ \text{NOT} \ \text{PARCEL\_OWNER} \ \text{NULL} \]

5 Select or type the value to evaluate on page 176.

6 To create a complex property evaluation, insert an AND or OR operator, and then insert another property, operator, and value combination.

Precede every operator with a property. For example, to find parcels whose last purchase date is after 1990 and before 2005, the expression must look like this one:

\[ \text{PURCHASE\_DATE} > 1990 \ \text{AND} \ \text{PURCHASE\_DATE} < 2005 \]

7 Click OK to apply the expression.
To evaluate properties in an expression using a function or option

1. Select the command for which you want to create an expression.

2. In the expression area, do one of the following:
   - Type a function or option for this property.
   - Select a function or option from a menu.
     You can use the following types of functions:
     - **Math Functions** on page 213
       For example, to find the square root of the value representing parcel area, use this expression:
       \[ \text{Sqrt} \left( \text{PARCEL\_AREA} \right) \]
     - **Numeric Functions** on page 219
       Numeric functions are available from the Math Functions menu. For example, to round the assessed value of parcels down to the nearest lower whole dollar, use this expression:
       \[ \text{Floor} \left( \text{PARCEL\_VALUE} \right) \]
     - **Text Functions** on page 221
       For example, to convert pipe names to all uppercase letters, use this expression:
       \[ \text{Upper} \left( \text{PIPE\_NAME} \right) \]
     - **Date Functions** on page 227
       For example, to add one month to the start date for a project, use this expression:
       \[ \text{AddMonths} \left( \text{START\_DATE}, 1 \right) \]

You can use the following types of options:
- **Geometric Options** on page 231
  Geometric options may include Area, Length2D, M, X, Y, and Z (depending on the feature source). For example, to find the perimeter value for parcels, use this expression (when Parcels is the current feature or layer):
  \[ \text{Length2D} \left( \text{geometry property} \right) \]

**NOTE** The Geometry property may have a different name in your data store. It is always listed under Geometry Properties in the Property list. Insert the property from the list. Do not change it manually or substitute a value for this property.
Conversion Options on page 232
For example, to create label text that displays “Unoccupied” if the property Occupied is null, use this expression:
```
NullValue(OCCUPIED, 'Unoccupied')
```

Aggregate Options on page 238
Aggregate functions are not available from a menu, but you can type them in. For example, to find the median value of all parcels, use this expression:
```
Median(PARCEL_VALUE)
```

3 In your expression, do one of the following:
- Enter a property name manually.
- Click Property. In the Property list, select a property.

4 Select or type the value to evaluate on page 176.

5 To create a complex property evaluation, insert an AND or OR operator, and then insert another operator, property, and value combination.

6 Click OK to apply the expression.

Selecting Property Values from a List

You can see the valid values for any property in the current data set. For example, suppose a parcel has the property IS_OWNER_OCCUPIED. If you are unfamiliar with the data, you would not know the valid values for this property. They could be Yes and No, True and False, Y and N, or T and F. You can view and insert the possible values for this property from the Properties pane.

Some properties have many values, which can take a long time to retrieve. In some cases, a warning is displayed. You can retrieve the values anyway, or cancel the retrieval.

NOTE You cannot view or insert values when you are creating a calculation or an expression for a label.

See also:
- Evaluating Properties on page 173
To select property values from a list

NOTE You cannot view or insert values when you are creating a calculation or an expression for a label.

1. Select the command for which you want to create an expression. on page 168

2. To see the possible values for a property, do one of the following:
   - Click the green arrow next to Get Values and select the property whose values you want to see.
   - Click a property in your expression. In the list that displays, click Get Values From A List.

   The Properties panel is displayed on the right side of the window.

3. In the Properties panel, click the green arrow next to the property name to see the values for this property.

   The list of values is sorted in ascending order or in the order used in the data source.

   Use the Properties panel to insert values from a list.
4 To filter the list, under Filter The List Of Values, enter the characters to filter by. For example, enter ill to find Dillard and Fillmore. Click the green arrow. The list shows all values that contain those characters.

**NOTE** Wildcards are not supported.

5 Double-click a value to insert it in your expression, or select the value and click Insert Value.

For help with any expression element, see *Creating Expressions - Reference* on page 205.

---

**Creating a Calculation**

You can use operators and functions to calculate a new value based on existing property values. You can use the resulting value to filter or select data. For example, you can calculate the area of parcels and then select parcels whose areas are above a certain area value.

**NOTE** In AutoCAD Map 3D, you can store the resulting calculation as a new property in the Data Table. The calculated property is stored with the map, but is not written back to the original data store. To save the property to a data store, export the layer to an SDF file or Bulk Copy the feature class to another data store.

The syntax for calculations varies, depending on whether you use operators or functions.

**NOTE** Connect to the data store that contains the data for the calculation to create or manage calculations.

**NOTE** For some calculations, values do not update automatically because the data providers do not support their underlying functions. Instead, the values display as read-only properties. If you do not see a new calculated value immediately, refresh the layer manually. Right-click the layer in Display Manager and click Refresh Layer.

---

**Tell me more**

- **Videos**
  - Show me how to create a calculated field.

- **Procedures**
  - To perform a calculation using an operator on page 179
  - To perform a calculation using a function on page 180
To perform a calculation using an operator

1. Select the command for which you want to create an expression.
2. In the expression area, do one of the following:
   - Enter a property name manually.
   - Click Property. Select the property you want.
3. To insert an operator, do one of the following:
   - Enter an operator for this property manually.
   - Click an operator button.
   - Click Operators. Select the operator you want.
4. Select or enter the value to evaluate.
   For example, if you are multiplying the value of the property, enter the number or insert a property to multiply by.
5. Specify any further conditions for the expression.
   To create a complex property evaluation, insert an AND or OR operator, and then insert another operator/property combination.
For help with any expression element, see Creating Expressions - Reference on page 205.

6 Click OK to apply the expression.

To perform a calculation using a function

1 Select the command for which you want to create an expression. on page 168

2 In the expression area, click one of the following and select a function:
   ■ Math Function on page 213
   ■ Text Functions on page 221
   ■ Date Functions on page 227

3 Click Property and select the property to apply the function to.

This expression is the definition of a calculated property.

For help with any expression element, see Creating Expressions - Reference on page 205.

4 Click OK to apply the expression.

To find area or length

1 Select the command for which you want to create an expression. on page 168

2 In the expression area, enter or insert the geometric function (Area2D or Length2D).

3 Insert the property Geometry in parentheses after the function.
NOTE  The Geometry property may have a different name in your data store. It is always listed under Geometry Properties in the Property list. Insert the property from the list. Do not change it manually or substitute a value for this property.

For help with any expression element, see Creating Expressions - Reference on page 205.

4  Click OK to apply the expression.

Performing a Conversion

Conversions change data values from one data type to another. For example, an assessor database can store the last date that a parcel was sold as a simple text string. You can convert these text strings to date strings so you can use Date Functions on page 227 on them.

You can also convert numeric or text strings to a particular numeric format. For example, if your data source stores a numeric value as a single-precision floating-point value, you can convert it to double-precision.

You can convert numeric values into text strings, for example, to extract a substring or find the number of characters in the string.

See also:

- Conversion Options on page 232
- Creating Expressions on page 167
- Creating Expressions - Reference on page 205

To convert a data value to a different format

1  Select the command for which you want to create an expression. on page 168

2  In the expression area, select the conversion type you want from Conversion.
   For a complete list, see Conversion Options on page 232

3  Click Property and select the property to convert.

4  Specify any further arguments or values required by the conversion.
Some conversions let you specify the format of the converted string. For example, if you convert a text string to a date format, you can specify how the date value appears. For more information, see Date Formatting Options on page 235.

Use conversions to change the format or type of a string property.

For help with any expression element, see Creating Expressions - Reference on page 205.

5 Click OK to apply the expression.

Creating Text Expressions

Text expressions are useful for formatting the results of text-related queries. You can use text expressions when you create labels for features.

See also:

- Text Functions on page 221
- Creating Expressions on page 167
- Using Expressions to Label Features on page 188
- Adding Labels to Features on page 96
- Creating Expressions - Reference on page 205

To create a text expression

1 Select the command for which you want to create an expression. on page 168
2 In the expression area, do one of the following:
   ■ Enter a text function on page 221 manually.
   ■ Click Text Function and select the function you want.

3 Click Property. In the Property list, select the property for the function.

4 Specify any arguments required by the function, enclosed in single quotation marks.
   For example, if you are padding the right side of a text string with three asterisks, the expression looks like this:

   For text expressions, the property is within parentheses, followed by any arguments within single quotation marks.

   If you are translating a text string from mixed case to lowercase, the expression looks like this:

   Lower (PRODUCT_NAME)

   For an example of a multiline label using the Concat function, see To use expressions in labels on page 188.

5 Specify any further conditions for the expression.
   To create a complex property evaluation, insert an AND or OR operator, and then insert another operator, property, and value combination.
   For help with any expression element, see Creating Expressions - Reference on page 205.

6 Click OK to apply the expression.

Creating Numeric Expressions

Numeric expressions operate on numeric properties and are useful for performing calculations within expressions.
To create a numeric expression

1. Select the command for which you want to create an expression.

2. In the expression area, do one of the following:
   - Enter a numeric function manually.
   - Click Math Function and select the function you want.

3. Click Property. In the Property list, select the property for the function.

4. Specify any arguments required by the function.
   For example, if you are rounding off the length of an item to two decimal places, the expression looks like this one:

```
Round (IMP_VALUE, 2) > LAND_VALUE
```

Numeric expressions operate on numeric properties or values.
If you are truncating the value for population estimates to a specified number of digits, the expression looks like this one:

\[ \text{Trunc}(\text{POPULATION}, 5) \]

If you are checking the sign of a profit/loss value, the expression looks like this one:

\[ \text{Sign}(\text{PROFIT\_LOSS}) \]

For help with any expression element, see Creating Expressions - Reference on page 205.

5 Click OK to apply the expression.

**Filtering by Location**

You can filter or select data by specifying a location in your map. For example, you can find all roads within 100 meters of a power line, or all parcels within a specific section of the drawing.

When you specify a location condition in an expression, you switch to your map and draw the location manually. For example, if you want to find all parcels within a circular area, you draw the circle on your map. As soon as your designation is complete, you return to the expression.

You cannot use location filters for labels or calculations.

In the following illustrations, the objects that are retrieved are highlighted.

<table>
<thead>
<tr>
<th>Location Type</th>
<th>Items retrieved</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inside Circle</td>
<td>![Inside Circle Illustration]</td>
</tr>
<tr>
<td>Location Type</td>
<td>Items retrieved</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Inside Rectangle</td>
<td>![Inside Rectangle Diagram]</td>
</tr>
<tr>
<td>Inside Polygon</td>
<td>![Inside Polygon Diagram]</td>
</tr>
<tr>
<td>Touching any part of a circle</td>
<td>![Touching any part of a circle Diagram]</td>
</tr>
<tr>
<td>Touching any part of a rectangle</td>
<td>![Touching any part of a rectangle Diagram]</td>
</tr>
<tr>
<td>Location Type</td>
<td>Items retrieved</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Touching any part of a polygon</td>
<td><img src="image1" alt="Diagram" /></td>
</tr>
<tr>
<td>Touching any part of a fence (line)</td>
<td><img src="image2" alt="Diagram" /></td>
</tr>
<tr>
<td>Touching a point</td>
<td><img src="image3" alt="Diagram" /></td>
</tr>
</tbody>
</table>

See also:
- Creating Expressions - Reference on page 205

To specify a location condition
1. Select the command for which you want to create an expression. on page 168
2. Click Location and select a location condition.
   The dialog box is hidden while you specify the area for the condition.
3. In the map, indicate whether to create a boundary or use an existing feature as the boundary.
4 Do one of the following:
   ■ If you chose Create, draw the area to include.
   ■ If you chose Select, click the feature to use as a boundary.

Once you specify the area, the dialog box appears again.

For help with any expression element, see Creating Expressions - Reference on page 205.

5 Click OK to apply the expression.

Using Expressions to Label Features

You can create text or numeric expressions that determine the content of labels when you style features.

See also:
■ Adding Labels to Features on page 96
■ Creating Expressions - Reference on page 205

To use expressions in labels

1 Display the Style Editor for the feature or layer you are labeling.

2 Under Feature Label, click \(\ldots\) for the appropriate entry.

   If you are theming this feature, there is one entry for each theme rule. Click the entry for a rule that displays labels.

   If your layer supports multiple geometry types (for example, point, line, and polygon), scroll down and click the Style cell for the appropriate geometry type.

3 In the Style Label dialog box, do one of the following:

   ■ To create a label with multiple lines, select Multiline.

   ■ To create single-line labels, select Advanced Placement. Text follows the outline of a linear feature and displays a single label, even if there are multiple line segments. The text shrinks to fit the length of the line.

   In either case, you can specify an expression for the content of the label.
4 To create an expression for the label content, click Property To Display and scroll to the bottom of the list. Click Expression.

5 In the Create/Modify Expressions dialog box, enter the expression on page 182.

If you selected Multiline, use \n to insert a line break.

The following example shows a three-line label. It displays the street name on the first line, the area of the parcel on the second line, and the APN code on the third line.

Concat ( STNAME , \n Area: , AREA , \n APN: , APN )

**NOTE** The label uses the Concat operator, which combines multiple properties and text strings and can include spaces and line breaks. For more information, see Text Functions on page 221.

The static text (in this case, the words “Area:” and “APN:”) are surrounded by single quotes. Including a space after the text strings inserts a space between this static text and the dynamic property that follows it.

The \n entry moves the subsequent text to a new line. The expression results in the following label:

![Label Example](image)

For help with any expression element, see Creating Expressions - Reference on page 205.

6 Click OK to apply the expression to the labels.

**Using Expressions In Split/Merge Rules**

In AutoCAD Map 3D, you can set rules for the assignment of properties when you split and merge geospatial features. You can use expressions to define these rules.
For example, when splitting a parcel, you can base the land value of the resulting parcels on a calculation that you define. There are also choices for automatic calculations. You can assign the average value of all merged features to the resulting feature. You can divide the value of a feature evenly among its split features.

This table lists the options for split and merge rules and describes how to use them.

<table>
<thead>
<tr>
<th>Split Rules</th>
<th>Merge Rules</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculation divides the value of the property for each resulting feature based on an expression you specify. For example, suppose the average parcel value for a neighborhood is 2000 times the value of the property Parcel_Acres. You can specify that Land_Value for each resulting parcel use that formula. This option is for numeric values only.</td>
<td>Average gives the new feature a value that is an average of the original features. This option is for numeric values only.</td>
</tr>
<tr>
<td>Copy gives each new feature an exact copy of the original property value. The original is unchanged.</td>
<td>Calculation determines the value of the property for the resulting feature based on an expression you specify. For example, you can specify that Net_Value for each resulting parcel equal Imp_Value minus Land_Value. (This option is available for numeric properties only.)</td>
</tr>
<tr>
<td>Divide gives each resulting feature an equal fraction of the original value. This option is for numeric values only.</td>
<td>Concatenation appends the values for each merged feature to create the value for the new feature.</td>
</tr>
<tr>
<td>Empty leaves the new property value empty for each new feature. The original is unchanged.</td>
<td>Count gives the new feature the value of the total number of features merged to produce it. This option is for numeric values only.</td>
</tr>
<tr>
<td>Expression Specifies an expression for string properties.</td>
<td>Empty leaves the new property value empty for the new feature. The original features are unchanged.</td>
</tr>
<tr>
<td>Proportional divides the value of the property for each resulting feature proportionally.</td>
<td>Expression Specifies an expression for string properties.</td>
</tr>
<tr>
<td>Split Rules</td>
<td>Merge Rules</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>ally, based on a value you specify. For example, you can assign a proportional value for Parcel_Acres based on the value of the area of the resulting parcels. This option is for numeric values only.</td>
<td>First Selected gives the new feature the value of the first feature you select for the merge. This option is meaningful only if you select the objects for the merge sequentially. (First Selected is the default for all properties except numeric ones.)</td>
</tr>
<tr>
<td></td>
<td>Last Selected gives the new feature the value of the last feature you select for the merge. This option is meaningful only if you select the objects for the merge sequentially.</td>
</tr>
<tr>
<td></td>
<td>Maximum gives the new feature the maximum value available in all features in the merge. (This option is available for numeric properties only.)</td>
</tr>
<tr>
<td></td>
<td>Median gives the new feature the median value calculated from all features in the merge. (This option is available for numeric properties only.)</td>
</tr>
<tr>
<td></td>
<td>Minimum gives the new feature the minimum value available in all features in the merge. (This option is available for numeric properties only.)</td>
</tr>
<tr>
<td></td>
<td>Standard Deviation gives the new feature the standard deviation value calculated from all features in the merge. (This option is available for numeric properties only.)</td>
</tr>
<tr>
<td></td>
<td>Sum gives the new feature the total value of all features in the merge. (This option is available for numeric properties only.)</td>
</tr>
</tbody>
</table>
To create split/merge rules using expressions

1. In Display Manager, select the layer containing the feature to split or merge.
2. In the Task Pane, click Table.
3. In the Data Table, click Options (at the bottom of the window) and select Set Split And Merge Rules.
4. In the Split and Merge Rules dialog box, under Feature Properties, select a property whose rules you want to set.
   For example, if you are splitting or merging parcels, select LAND_VALUE to specify how to determine the land value of the resulting parcels.
   For help with any expression element, see Creating Expressions - Reference on page 205.
5. Click Split Rule and select a value.
6. Click Merge Rule and select a value.
   For a description of the possible values, see the Concept tab of this topic.
7. Click OK.

Using Expressions to Filter Feature Data

You can filter layers based on a single property, multiple properties, a location in the map that you specify, or a set of conditions.

Before you create an expression for the filter, you select the feature layers to filter. Methods for selecting layers vary, depending on whether you are using AutoCAD Map 3D or MapGuide Studio. For example, in AutoCAD Map 3D, you can filter feature layers as you add them to the map. Only a subset of data is added. You can also select layers in Display Manager and filter the data after
it is added to the map. You can filter a single layer or multiple layers at one time.

The result of a filter expression must be a Boolean value.

Filtering the Layers You Add to a Map

When you connect to a geospatial data store in AutoCAD Map 3D, you can filter the data you bring into your map. Use Add To Map With Query in the Data Connect window.

You can filter a single layer or multiple layers. You can filter the data by location, by data properties, and by conditions that you define.

The result of a filter expression must be a Boolean value.

See also:

■ Creating Expressions on page 167
■ Evaluating Properties on page 173
■ Filtering Features When You Add Them to a Map
■ Creating Expressions - Reference on page 205

To filter feature data when you add it to a map

1 In AutoCAD Map 3D, connect to the data source in the Data Connect window.
   For detailed information, see Overview of Bringing In GIS Features.

2 In the Data Connect window, under Add Data To Map, select the layers to add.

3 Click the Add To Map down arrow and select Add To Map With Query.

4 In the Create Query dialog box, create the expression for your query on page 167.
   For help with any expression element, see Creating Expressions - Reference on page 205.

5 Click OK.
Filtering Feature Layers

Filter feature source layers so that only some of the features appear in your map. Using a filter can help you improve performance when working with large sets of feature data.

To filter the layers, define a query condition or a set of conditions that specify which features you want. The procedure is like performing a search.

The result of a filter expression must be a Boolean value.

**TIP** In AutoCAD Map 3D, you can filter data in two ways. You can filter after you bring data into your map. You can use the Add To Map With Query option while bringing it in and then use Query To Filter Data to apply a filter.

You can create a single filter for multiple layers from different data sources, as long as they share the property you are filtering on. For example, you can have an SDF layer of parcels, a SHP layer of parks, and an Oracle layer of hospitals. If they all share a STREET_NAME property, you can filter by street name.

You can also create a filter for a group. All the layers in that group must be feature layers (not drawing layers). All the feature layers must contain features (that is, none of them can be empty).

**See also:**
- Filtering the Layers You Add to a Map on page 193
- Finding and Selecting Features
- Overview of Creating Expressions on page 167
- Evaluating Properties on page 173
- Filtering by Location on page 185

**To filter a feature layer**

1. If you are filtering by location, zoom the window to the extents of the selected feature class.

2. In Display Manager, select the feature layers and select the filter command.
   
   For example, in AutoCAD Map 3D Display Manager, right-click a selected layer and click Query To Filter Data.
3 In the Create Query window, do either of the following:
- To add more feature layers to the data being searched by the expression, click Add Layer and select the layer to add.
- To delete a layer, select it in the list and click Delete.

The list of layers at the top of the window shows any existing filters for the selected layers. If the layers use a common query (specifying a property that all the layers have in common), that query is listed separately.

4 Create an expression, using any of the following expression types:
- **Filtering by Location** on page 185 — Selects all features in a location you specify. Select one of the Locate On Map options and define a location in your drawing.
  For example, use a location expression to find all manholes in one section of town. You can also find all parcels that touch a road, or all water pipes within 100 meters of a road.
- **Evaluating Properties** on page 173— Selects all features that have the property value you specify. Insert a property, an operator, and a value.
  For example, to select all pipes with a diameter greater than 10, specify Diameter > 10.

  The Property list displays the properties available for this feature class.
  You can view and insert available values for a property from a list on page 176.

5 Optionally, add conditions to the expression.

6 Validate your expression on page 197.

7 Click OK to apply the filter.

**Searching to Select Feature Layers**

You can find and select features in your map based on their location or properties. You create an expression that specifies a set of conditions to use for finding and selecting the features.

For example, you can find just the roads in Shanghai within a circular area you specify. Specify criteria that limit the results to road features that lie within the circle you define and whose City field is "Shanghai."

You can search multiple layers from different data sources, as long as they share the property you are searching. For example, you can have an SDF layer...
of parcels, a SHP layer of parks, and an Oracle layer of hospitals. If they all share a STREET_NAME property, you can search by street name.

See also:

- Finding and Selecting Features
- Overview of Creating Expressions on page 167
- Evaluating Properties on page 173
- Filtering by Location on page 185

To search for and select parts of feature layers

1. If you are filtering by location, zoom the drawing window to see the area of interest.

2. In your map, select the feature layers and select the search command. For example, in AutoCAD Map 3D, click Home tab ➤ Data panel ➤ Search.

3. To add more feature layers to the data being searched by the expression, click Add Layer and select the layer to add. To delete a layer, select it in the list and click Delete.

4. In the expression area, use any of the following expression types:
   - **Location Condition** on page 185 — Select one of the Locate On Map options and define a location in your drawing. For example, use a location condition to find all manholes in one section of town. You can also find all parcels that touch a road, or all water pipes within 100 meters of a road.
   - **Property Condition** on page 173— Selects all features that have the property value you specify. Insert a property, an operator, and a value. For example, to select all pipes with a diameter greater than 10, specify `Diameter > 10`.

   The Property list displays the properties available for this feature class. You can view and insert available values for a property from a list on page 176.
Add layers and specify the expression for the search.

5 Optionally, add conditions to the expression.
6 Validate your expression on page 197.
7 Click OK to apply the filter.

Managing Expressions

You can check your expressions to make sure they are valid. You can save and reuse expressions.

Troubleshooting Validation Errors

When you save an expression, it is always checked to be sure it is valid. You can also check whether your expression is valid before you save it.

The validation checks the syntax of the expression, whether the specified properties are present in the current data store, and whether the property values are valid.
When possible, the validation operation displays a message describing the errors it finds. Often, you can click this error message to place the cursor at the problem spot so you can correct it.

Validation can fail for one of the following reasons:

- A separator character is missing or invalid. For example, for some functions, commas must separate each argument. Perhaps one of the commas is missing, or you entered a semicolon instead of a comma.
- An operator or property is missing. This problem is common in expressions with multiple conditions. For example, the expression `PARCEL_VALUE > 100000 AND <200000` is invalid. The correct syntax is `PARCEL_VALUE > 100000 AND PARCEL_VALUE < 200000`. Notice that in the second example, `PARCEL_VALUE` appears twice, while in the first example it appears only once.
- A character or property is the wrong type. This problem can occur if you use an operator that requires a numeric value, but you inserted a text character instead. For a function that requires a hexadecimal value, a numeral can cause an error. For a function that requires a numeric property, a text property causes an error.
- A required value is missing or “empty.” Perhaps you failed to insert a property value or a value for an argument.
- The expression is missing a bracket, quotation mark, or parenthesis character. For example, there is an opening bracket that has no related closing bracket. This problem is common in complex expressions.

The validation process can help you avoid many errors, but it cannot guarantee that your expression will work the way you intend when it is applied. Validation does not execute the query against actual data. It only checks that the expression syntax is correct and that the properties and values are valid for the current data store.

See also:

- Creating Expressions on page 167
- Creating Expressions - Reference on page 205
To validate an expression

1. Select the command for which you want to create an expression. on page 168
2. Create the expression.
3. Save the expression or click Validate.
4. If the validation panel displays errors, click the error message to move the cursor to the problem area.
5. Resolve the problems and run the validation check again, until the validation panel indicates that the expression is valid.
   For help with any expression element, see Creating Expressions - Reference on page 205.

Saving and Reusing Expressions

You can save any expression for reuse. You can share expressions you saved with other users.

You cannot save a calculation on page 178. The calculation becomes a property for the current feature class in the current map, but is not saved back to the original data store. You can export the feature class layer from the Display Manager to create a feature that permanently includes the calculated property.

See also:
- Creating Expressions on page 167
- Saving or Exporting a Display Manager Layer

To save an expression

1. Select the command for which you want to create an expression. on page 168.
2. Create the expression.
3. When your expression is complete, click Options and select Save Expression.
4. In the dialog box that displays, specify a location and name for the saved expression file.
The next time you save or load an expression, this location will be displayed by default. To share this saved expression with another user, send that user the file from this location. By default, the expression file name is the first element in the expression. All expressions use the file extension .fdq.

5 Click Save.

To reuse a saved expression

1 In your map, select the command that will use the expression.
2 Click Options and select Load Expression.
3 Select the saved expression file to open and click Load.

The last location you used to save or load an expression is displayed by default. You can navigate to a different location.
The saved expression replaces whatever you entered in the expression area. Click OK to apply it.

Customizing Expression Options

You can set display options and use navigation options while you are creating expressions.

To set expression options, do any of the following

■ Display the buttons that show expression templates. on page 201
■ Show or hide tooltips. on page 201
■ Use navigation options. on page 201

Setting Expression Display Options

You can set the following display options for expressions:

■ Display the buttons that show expression templates every time you start creating an expression.
■ Show or hide tooltips.
NOTE You can also save or load expressions from the Options drop-down. For more information, see Saving and Reusing Expressions on page 199.

To display the buttons that show expression templates
1 Select the command for which you want to create an expression. on page 168
2 Click Getting Started (at the bottom of the window).

To show or hide tooltips
1 Select the command for which you want to create an expression. on page 168
2 Click Options (at the bottom of the window).
3 Click Show Tool Tips.
4 Click OK.

Navigating While Creating Expressions

While creating an expression, use the following to navigate:

- **Zoom Extents.** You can zoom to the extents of the selected feature layers.

  NOTE Zoom Extents is not available when you create a calculation or when you are using expressions for labeling.

- **Show Location.** If you applied a location filter on page 185, you can view the area on the map defined by that filter.

  NOTE Show Location is not available in MapGuide Studio. In AutoCAD Map 3D, it is not available when you create a calculation or when you are using expressions for labeling.

To navigate while creating expressions
1 To zoom the map to the extents of the current feature layer, click Zoom Extents (at the bottom of the window).
To see the dotted line representing the location filter currently applied to the map, click the location component of the expression and then click Show Location.

About Expressions and Data Providers

Most expression functions behave the same way across all data providers, but there are a few exceptions.

Unsupported Functions

You can use any function when creating a filter or a calculated property. These results are not saved back to the data store. However, if you use a function that returns an unsupported data type to insert a value into the Data Table, an exception results. That operation is not valid for the data provider. For example, SHP files do not support the FdoInt16 or FdoDouble data types. If you try to save a value of that data type back to a SHP data store, an error occurs.

ODBC Providers

In AutoCAD Map 3D, you can apply an expression before you actually connect to the data store. For example, you can use a query to add features to a map. This situation can be an issue for ODBC providers, which can connect to multiple data sources. Not all ODBC sources support expression functions. For this reason, the functions are evaluated as part of the expression-building process in all cases, even if the connected data source can do so.

Soundex

The Soundex function on page 221 is natively supported by all relational database management systems (RDBMS). The underlying RDBMS evaluates any expression including this function. However, the result returned by a MySQL provider may differ from the result you receive from other providers.

Boolean Value Representation

SDF and SHP providers represent a Boolean value with the terms TRUE and FALSE. RDBMS providers represent a Boolean value with 0 and 1. This difference can affect the display of labels. For example, the following expression defines a label that indicates whether a valve is open:

```
Concat('Valve is open: ', <valve_status_property>)
```
For SDF and SHP data, the label will read “Valve is open: True.” For RDBMS data, the label will read, “Valve is open: 1.”

**AddMonths and MonthsBetween**

The *AddMonths* and *MonthsBetween* functions on page 227 do not take day information into account, but RDBMS systems do.

For example, for the expression `AddMonths(<date_property>, 88.7)`, an RDBMS provider might add 88.7 months to the provided date. The function in expressions you create in the product adds 88 months only.

Similarly, for the expression `MonthsBetween(<date_1>, <date_2>)`, an RDBMS provider might return a value of 77.4. The function in expressions you create in the product returns 77.

**Cache-based Operation Versus RDBMS-based Operation**

Some operations (for example, the creation of a calculated property) are cache-based operations and use the expression-building process for evaluation. Other operations (for example, a filter on an RDBMS data store) use the underlying RDBMS system.

Due to differences between providers, the results can differ. For example, if you connect to a MySQL data store, you can create two calculated properties: CP1 and CP2. CP1 is defined by the expression `Soundex(<property>)` and CP2 is defined by the expression `Soundex(<literal>)`. In the Data Table, the value for CP1 and CP2 may be identical. However, if you use a filter containing the expression `Soundex(<property>) = Soundex(<literal>)`, the resulting values may be different. In the Data Table, the expression-building process evaluates the expressions. The MySQL data store (which uses a different function definition) evaluates the filter.
Creating Expressions - Dialog Box

Use expressions to do the following tasks:

- Define conditions that retrieve the features you want from a feature source
- Select features for an operation
- Specify criteria for styling or labeling
- Define split/merge rules

**Layers**

This area is displayed only when you search. Click Home tab ➤ Data panel ➤ Search.

- **Add Layer**
  - Adds another feature layer to the search operation.

- **Delete**
  - Deletes the selected layer from the search operation.

- **Layers list**
  - Lists the layers to search.

**Menus and Toolbar**

Inserts elements into your expression.
Property
Displays a list of properties. Select a property to display its values. For example, for a Parcel feature with a Street_Address property, you can examine the Street_Address values and choose only parcels on a particular street. Properties are sometimes called attributes in other GIS systems. Properties can provide demographic, physical, historical, and other data about a geometric feature.

Operator
Displays a list of math on page 208, comparison on page 209, and logical on page 210 operators.

Math Function
Displays a list of math and numeric functions, including standard trigonometric operations, as well as functions for absolute value, exponents, and others.

Text Function
Displays a list of functions that operate on text properties and are useful for formatting the results of text-related queries.

Date Function
Displays a list of functions that return the current date or operate on a date string.

Locate on Map
Specifies a location as a filter when you draw it on your map. For example, select all items within or touching a specified circle, rectangle, or polygon that you draw.

Geometric
Displays the geometric elements Area2D and Length2D. Each of these elements takes only the argument Geometry. Using that argument, the expression determines the area or length of the data on the layer. You can then create an expression that filters data by its size. For example, you can select only pipes longer than 50 feet.

Conversion
Displays a list of options for converting strings from one format to another. For example, you can convert text strings to dates, and then select only items before or after a particular date.

Undo/Redo
Reverses or reinstates your most recent edit.
Math operators
    Inserts +, -, *, or / into your expression.

Comparison operators
    Inserts Boolean comparison operators (equal to, less than, greater than, and so on) into your expression.

Logical operators
    Inserts AND, OR, or grouping parentheses into your expression.

Get values
    Displays a pane that lists property values. Select a property from the list and click the green arrow to see the values for that property. You can filter the list. If the list is long, use Previous and Next to page through it. Select a value and click Insert Value to add that value to your expression at the insertion point.

Expression area
    Displays the current expression.

Lower command area

Validate
    Checks whether the current expression is valid. If it is not, a message helps you determine where the problems are.

Clear
    Deletes the current expression.

Zoom Extents
    Zooms to the extents of the selected feature source.

Show Location
    If you have defined a location condition, click that part of your expression. Then click this button to display the location extents in the drawing window.

Options
    Displays options for saving or reusing expressions and hiding or showing startup tips and tooltips.
Overview of Expression Elements

Expressions that filter, search, or style geospatial features use one set of operators, functions, conditions, and options across all supported FDO providers. To check the syntax for a particular element, or to see examples of use, see the following topics:

- **Operators** on page 208
- **Functions** on page 212
- **Location Conditions** on page 229
- **Options** on page 231

Operators

When you create an expression for geospatial features, you can use the following types of operators:

<table>
<thead>
<tr>
<th>Type of Operator</th>
<th>Definition</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Math Operators on page 208</td>
<td>Simple arithmetic operators</td>
<td>Plus, minus, multiply, divide</td>
</tr>
<tr>
<td>Comparison Operators on page 209</td>
<td>Simple comparative operators</td>
<td>Greater than, less than, not equal to</td>
</tr>
<tr>
<td>Logical Operators on page 210</td>
<td>Operators that match or group values</td>
<td>Like, Not Like, Boolean operators (And, Or, Not)</td>
</tr>
<tr>
<td>Date-Time Operators on page 211</td>
<td>Operators that convert a string to a date or time value.</td>
<td>Date, Time, Timestamp</td>
</tr>
</tbody>
</table>

Math Operators

Math operators are available from the Operator menu. They perform simple arithmetic operations. (Do not confuse the Math + operator with the Boolean AND operator. They are not interchangeable.)
When you create an expression for geospatial features, you can use the following math operators:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Definition</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Add</td>
<td>Property + Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value + Property</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Property + Property</td>
</tr>
<tr>
<td>-</td>
<td>Subtract</td>
<td>Property - Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value - Property</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Property - Property</td>
</tr>
<tr>
<td>*</td>
<td>Multiply by</td>
<td>Property * Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value * Property</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Property * Property</td>
</tr>
<tr>
<td>/</td>
<td>Divide by</td>
<td>Property / Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value / Property</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Property / Property</td>
</tr>
</tbody>
</table>

Comparison Operators

Comparison operators are available from the Operator menu. They modify a property value. Make sure that every instance of a comparison operator is preceded by a property and followed by a value. For example, if you create an expression to find every parcel whose street number is greater than 100 but less than 200, your expression would be:

Parcel_Street_Address > 100 AND Parcel_Street_Address < 200

In the example, the property Parcel_Street_Address is inserted twice. A single instance of Parcel_Street_Address does not work.

Numeric properties are evaluated arithmetically. Date properties are evaluated chronologically. Text properties are evaluated alphabetically. For example, Parcel_Area < 20000 will find parcels whose area is less than 20,000 square feet. Purchase_Date > 01/01/2001 will find parcels purchased after the beginning of 2001. Street_Address < “Mt. Whitney” will find parcels whose street address comes before Mt. Whitney alphabetically.
When you create an expression for geospatial features, you can use the following comparison operators:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Definition</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equals</td>
<td>Property = Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value = Property</td>
</tr>
<tr>
<td>&gt;</td>
<td>Is greater than</td>
<td>Property &gt; Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value &gt; Property</td>
</tr>
<tr>
<td>&lt;</td>
<td>Is less than</td>
<td>Property &lt; Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value &lt; Property</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Is less than or equal to</td>
<td>Property &lt;= Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value &lt;= Property</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Is greater than or equal to</td>
<td>Property &gt;= Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value &gt;= Property</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Is not equal to</td>
<td>Property &lt;&gt; Value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value &lt;&gt; Property</td>
</tr>
</tbody>
</table>

**Logical Operators**

Logical operators are available from the Operator menu. They create conditions that return a value for a text property if it matches a particular pattern, or appears within a particular list.

When you create an expression for geospatial features, you can use the following logical operators:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Definition</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIKE</td>
<td>Finds text that matches a pattern. The pattern you specify (within single quotation marks) can include regular characters and the percent (%) wildcard character. To match, regular characters must exactly match the characters specified in the pattern; the percent character can match an arbitrary fragment of the pattern.</td>
<td>Property LIKE 'text%'</td>
</tr>
<tr>
<td>Operator</td>
<td>Definition</td>
<td>Syntax</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>NOT LIKE</td>
<td>Finds text that does not match a pattern. You can use the percent wildcard as you do with LIKE.</td>
<td>NOT Property LIKE 'text%'</td>
</tr>
<tr>
<td>IN</td>
<td>Determines whether a specified value matches any value in a list.</td>
<td>Property IN (Value,Value)</td>
</tr>
<tr>
<td>NOT IN</td>
<td>Determines whether a specified value does not match any value in a list.</td>
<td>NOT Property IN (Value,Value)</td>
</tr>
<tr>
<td>IS NULL</td>
<td>Returns the specified property if it is null. An expression with a bitwise or arithmetic operator evaluates to NULL if any one of the operands is NULL.</td>
<td>Property IS NULL</td>
</tr>
<tr>
<td>IS NOT NULL</td>
<td>Returns the specified property if it is not null. An expression with a bitwise or arithmetic operator evaluates to NULL if any one of the operands is NULL.</td>
<td>NOT Property IS NULL</td>
</tr>
<tr>
<td>AND</td>
<td>Combines conditions and matches a value if it meets all conditions.</td>
<td>Expression AND Expression</td>
</tr>
<tr>
<td>OR</td>
<td>Combines conditions and matches a value if it meets any one of the conditions.</td>
<td>Expression OR Expression</td>
</tr>
<tr>
<td>NOT</td>
<td>Negates a Boolean expression.</td>
<td>NOT Value</td>
</tr>
<tr>
<td>()</td>
<td>Groups the selection in parentheses.</td>
<td>(Value, Value)</td>
</tr>
</tbody>
</table>

**Date-Time Operators**

A date-time property from the Get Values panel uses one of the following operators, depending on the field type. If you are an advanced user, you can also add one of these operators to an expression if you know its FDO syntax. These operators are not available from a list.
The Date-Time operators are parsed using the standard SQL literal strings:

- **DATE 'YYYY-MM-DD'**
- **TIME 'HH:MM:SS[.sss]'**
- **TIMESTAMP 'YYYY-MM-DD HH:MM:SS[.sss]'**

To use other formats, use **TODATE** or **TOSTRING** instead. See **Conversion Options** on page 232.

<table>
<thead>
<tr>
<th>Function</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATE</td>
<td>Converts the string you specify into a date value using the format you choose from a list.</td>
<td>DATE 'string'</td>
<td>DATE '1971-12-24'</td>
</tr>
<tr>
<td>TIME</td>
<td>Converts the string you specify into a time value using the format you choose from a list.</td>
<td>TIME 'string'</td>
<td>TIME '11:00:02'</td>
</tr>
<tr>
<td>TIMESTAMP</td>
<td>Converts the string you specify into a date and time value using the format you choose from a list.</td>
<td>TIMESTAMP 'string'</td>
<td>TIMESTAMP '2003-10-23 11:00:02'</td>
</tr>
</tbody>
</table>

**Functions**

When you create an expression for geospatial features, you can use the following types of functions:

<table>
<thead>
<tr>
<th>Type of function</th>
<th>Definition</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Math Functions</strong></td>
<td>Trigonometric, exponential, log, and other functions</td>
<td>Absolute value, modulus, remainder, square</td>
</tr>
<tr>
<td>Type of function</td>
<td>Definition</td>
<td>Example</td>
</tr>
<tr>
<td>------------------</td>
<td>------------</td>
<td>---------</td>
</tr>
<tr>
<td><strong>Numeric Functions</strong> on page 219</td>
<td>Functions that round off, truncate, or find the sign of a numeric value</td>
<td>Ceiling, Floor, Round, Truncate</td>
</tr>
<tr>
<td><strong>Text Functions</strong> on page 221</td>
<td>Functions that operate on text strings</td>
<td>Concatenate, pad, or trim the left or right side of a string, specify the length or position of a string</td>
</tr>
<tr>
<td><strong>Date Functions</strong> on page 227</td>
<td>Functions that operate on date values</td>
<td>Specify the current date, find the result of adding months to a date</td>
</tr>
</tbody>
</table>

### Math Functions

Math functions are available from the Math Function menu. They include standard trigonometric operations, as well as functions for absolute value, exponents, and others. These functions are available for every data provider except for raster, WFS, and WMS providers.

The functions that return angles (for example, ARCCOS) are helpful in formulating expressions that define rotation.

When you create an expression for geospatial features, you can use the following math functions.

<table>
<thead>
<tr>
<th>Function</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABS</td>
<td>Returns the absolute value of a number (without its sign) using the input data type. For example, $\text{ABS}(-2) = 2$</td>
<td>$\text{ABS}$(Numeric_Property)</td>
<td>$\text{ABS}$(Pipe_Angle)</td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>ACOS</td>
<td>Returns the arc-cosine, or inverse cosine, of a number between or equal to -1 and 1. (Arcosine is the angle that has a cosine equal to a given number.) The returned value is in radians with a Double data type. For example, ( \text{ACOS}(0.5) = \pi/3 )</td>
<td>( \text{ACOS}(\text{Pipe}_\text{Property}) )</td>
<td>ACOS(Pipe_Property)</td>
</tr>
<tr>
<td>ASIN</td>
<td>Returns the arc-sine, or inverse sine, of a number between or equal to -1 and 1. (Asin is the angle that has a sine equal to a given number.) The returned value is in radians with a Double data type. For example, ( \text{ASIN}(0.5) = \pi/6 )</td>
<td>( \text{ASIN}(\text{Pipe}_\text{Property}) )</td>
<td>ASIN(Pipe_Property)</td>
</tr>
<tr>
<td>ATAN</td>
<td>Returns the arctangent, or inverse tangent, of any number. (Atan is the angle that has a tangent equal to a given number.) The returned value is in radians</td>
<td>( \text{ATAN}(\text{Numeric}_\text{Property}) )</td>
<td>ATAN(Pipe_Property)</td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>ATAN2</td>
<td>Returns the arctangent, or inverse tangent, of X and Y coordinates of a point. Each coordinate can be any real number. The returned value is in radians with a Double data type. For example, ATAN2 (-.7071,.7071)=3pi/4</td>
<td>ATAN2 (x_Numeric_Property, y_Numeric_Property)</td>
<td>ATAN2(NS_Street_Property, EW_Street_Property)</td>
</tr>
<tr>
<td>COS</td>
<td>Returns the cosine of an angle. The returned value has a Double data type. (In a right triangle, the cosine of an angle is the ratio of the adjacent side to the hypotenuse.) For example, COS(pi/3)=.5</td>
<td>COS(Angle_Property)</td>
<td>COS(Pipe_Angle)</td>
</tr>
<tr>
<td>EXP</td>
<td>EXP returns e raised to the specified power, where e = 2.71828183 ...</td>
<td>EXP(Numeric_Property)</td>
<td>EXP(Street_Length_Property)</td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>EXP</td>
<td>EXP returns a value with a Double data type. For example, EXP(2) ~ 7.389056099...</td>
<td>EXP(Numeric Property)</td>
<td>LN(Desired_Level_Property)</td>
</tr>
<tr>
<td>LN</td>
<td>Returns the natural logarithm of a positive number. The returned value has a Double data type. The natural log is often used to determine how long it will take to achieve a stated level. For example, LN(2.71828183) = 1</td>
<td>LN(Numeric Property)</td>
<td>LN(Desired_Level_Property)</td>
</tr>
<tr>
<td>LOG</td>
<td>Returns the logarithm, to the base specified, of a number. The returned value has a Double data type. The base can be any positive value other than 1 and the number can be any positive value. For example, LOG(10, 100) = 2</td>
<td>LOG(Base, Numeric Property)</td>
<td>LOG(10, Cost_Property)</td>
</tr>
<tr>
<td>MOD</td>
<td>Returns the remainder of a number (the dividend) after being divided by another number (the divisor).</td>
<td>MOD(Dividend, Divisor)</td>
<td>MOD(Parcel_Value, Parcel_Area)</td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td><strong>POWER</strong></td>
<td>Returns the result of one number raised to the power of a second number. The returned value has a Double data type. The base and the exponent can be any numbers, but if the base is negative, then the power must be an integer. For example, $POWER(5,2)=25$</td>
<td>$POWER(Base_number,Power_number)$</td>
<td>$POWER(Parcel_Cost,2)$</td>
</tr>
<tr>
<td><strong>REMAINDER</strong></td>
<td>Returns the remainder of a number after being divided by another number. For example, $REMAINDER(11,4)=-1$</td>
<td>$REMAINDER(Dividend,Divisor)$</td>
<td>$REMAINDER(Parcel_Cost,4)$</td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>Uses the ROUND function to round. For more information, see Using Mod and Remainder on page 219</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>SIN</strong></td>
<td>Returns the sine of an angle. The returned value has a Double data type. In a right triangle, the sine of an angle is the ratio of the opposite side to the hypotenuse. For example, ( \text{SIN}(\text{pi}/6) = .5 )</td>
<td>( \text{SIN}(\text{Angle_Property}) )</td>
<td>( \text{SIN}(\text{Pipe_Angle}) )</td>
</tr>
<tr>
<td><strong>SQRT</strong></td>
<td>Returns the square root of a positive number. The returned value has a Double data type. For example, ( \text{SQRT}(25) = 5 )</td>
<td>( \text{SQRT}(\text{Numeric_Property}) )</td>
<td>( \text{SQRT}(\text{Parcel_Area}) )</td>
</tr>
<tr>
<td><strong>TAN</strong></td>
<td>Returns the tangent of an angle. The returned value has a Double data type. In a right triangle, TAN is the ratio of the opposite side to the adjacent side.</td>
<td>( \text{TAN}(\text{Angle_Property}) )</td>
<td>( \text{TAN}(\text{Pipe_Angle}) )</td>
</tr>
</tbody>
</table>
Using Mod and Remainder

The functions MOD and REMAINDER both return the remainder of a division of two numbers. The difference is that MOD uses the function FLOOR in its algorithm, and REMAINDER uses the function ROUND instead. This difference can affect the result. For example, the call to MOD (34.5, 3) returns 1.5. The call REMAINDER (34.5, 3) returns -1.5. For REMAINDER, n cannot equal zero.

The formulas for the two functions are:

\[
\text{MOD}(m, n) = \text{SIGN}(m) \times (\text{ABS}(m) - (\text{ABS}(n) \times \text{FLOOR}(\text{ABS}(m) / \text{ABS}(n))))
\]

\[
\text{REMAINDER}(m, n) = m - (n \times \text{ROUND}(m/n))
\]

You can see the differences that can result by examining the following table:

<table>
<thead>
<tr>
<th>If (m) =</th>
<th>And (n) =</th>
<th>MOD ((m,n)) returns</th>
<th>REMAINDER ((m,n)) returns</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>4</td>
<td>3</td>
<td>-1</td>
</tr>
<tr>
<td>11</td>
<td>-4</td>
<td>3</td>
<td>-1</td>
</tr>
<tr>
<td>-11</td>
<td>4</td>
<td>-3</td>
<td>1</td>
</tr>
<tr>
<td>-11</td>
<td>-4</td>
<td>-3</td>
<td>1</td>
</tr>
</tbody>
</table>

Numeric Functions

Numeric functions are available from the Math Function menu. They operate on numeric values to round numbers up or down, truncate them, or determine whether the number is negative or positive. These functions are available for every data provider except for raster, WFS, and WMS providers.
When you create an expression for geospatial features, you can use the following numeric functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>CEIL</td>
<td>Rounds a number up to the next highest integer. The return value uses the input data type. For example, CEIL(2.6)=3 CEIL(-2.6)=-2</td>
<td>CEIL(Numeric_Property)</td>
<td>CEIL(Part_Cost)</td>
</tr>
<tr>
<td>FLOOR</td>
<td>Rounds a number down to the next lowest integer. The return value uses the input data type. For example, FLOOR(2.6)=2 FLOOR(-2.6)=-3</td>
<td>FLOOR(Numeric_Property)</td>
<td>FLOOR(Part_Cost)</td>
</tr>
<tr>
<td>ROUND</td>
<td>Rounds a number to the specified decimal places. The return value uses the input data type. For example, ROUND(1.476,2)=1.48</td>
<td>ROUND(Numeric_Property), Number of decimal places</td>
<td>ROUND(Part_Cost,2)</td>
</tr>
<tr>
<td>SIGN</td>
<td>Finds the sign of a number. Returns 1 if the number is positive; 0 if the</td>
<td>SIGN(Numeric_Property)</td>
<td>SIGN(Part_Sale_Profit)</td>
</tr>
</tbody>
</table>

220 | Chapter 11  Creating Expressions - Reference
<table>
<thead>
<tr>
<th>Function</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>SIGN</td>
<td>number is 0; -1 if the number is negative. The return value uses an Int16 data type. For example, SIGN(-3.76)=-1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TRUNC</td>
<td>Truncates a date property to the specified format (YEAR, 'MONTH', 'DAY', 'HOUR' or 'MINUTE') or Truncates a numeric property to the specified number of decimal places. The return value uses the input data type. For example, TRUNC(1.476, 2)=1.47 This function returns a DOUBLE.</td>
<td>TRUNC(Date_Property, 'Format') or TRUNC(Numeric_Property, Number of decimal places)</td>
<td>TRUNC(Repair_Date, 'DAY') or TRUNC(Repair_Cost, 2)</td>
</tr>
</tbody>
</table>

**Text Functions**

Text functions are available from the Text Function menu. They operate on text properties and are useful for formatting the results of text-related queries. These functions are available for every data provider except for raster, WFS, and WMS providers.
When you create an expression for geospatial features, you can use the following text functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONCAT</td>
<td>Joins multiple strings into one. CONCAT takes any number of arguments, which can be any property type except Geometry or Raster. The return value uses the String data type. Use ‘\n’ to insert a line break. To include static text labels or spaces, surround them with single quotes. When you use Concat with a Boolean property, the operation generates 1/0 (not True/False) as a result.</td>
<td>CONCAT(Property, Property, ...)</td>
<td>CONCAT(First_Name, 'First_Name', 'First_Name', ...), Street_number, ' ', Street_name, ' ', Suffix) This example produces a label like this: John Smith Address: 123 Maple Street</td>
</tr>
<tr>
<td>INSTR</td>
<td>Finds the position of the first occurrence of a substring in another string. Specify the source string as the first argument and the string you are searching for as the second argument.</td>
<td>INSTR(Text property or value, Text property or value)</td>
<td>INSTR(Parcel_Owner, 'field') This example looks for the substring “field” within the parcel owner string. If the name of the parcel owner is Smithfield, the value returned would be 6.</td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>LENGTH</td>
<td>Returns the number of characters of the specified string as an integer with the data type Int64. Does not include trailing blank characters.</td>
<td><code>LENGTH(Property)</code></td>
<td><code>LENGTH(First_Name)</code>&lt;br&gt;This example finds the number of characters in the First_Name property.</td>
</tr>
<tr>
<td>LOWER</td>
<td>Converts text to lowercase. The return value uses the String data type.</td>
<td><code>LOWER(Property)</code></td>
<td><code>LOWER(Product_Name)</code>&lt;br&gt;This example changes a product name entry to lowercase (for example, PIPE COMPOUND to pipe compound).</td>
</tr>
</tbody>
</table>
| LPAD    | Pads the left side of a string with the characters specified. The return value uses the String data type. LPAD can take two to three parameters. If you do not specify the text character argument, a space character is used. | `LPAD(Property, Number of characters, 'text character')` | `LPAD(High_PRIORITY,3,'*')`<br>This example would show a value for the property High_Priority (for example, "Emergency Repair") preceded by ***.
<table>
<thead>
<tr>
<th>Function</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>LTRIM</td>
<td>Trims characters from the left side of a text string. The return value uses the String data type.</td>
<td>LTRIM(Text_property)</td>
<td>LTRIM(Parcel_ID) This example removes leading characters from parcel identifiers.</td>
</tr>
</tbody>
</table>
| RPAD        | Pads the right side of a string with the characters specified. The return value uses the String data type. RPAD can take two to three parameters. If you do not specify the text character argument, a space character is used. | RPAD(Text_property, Number of characters,'text character') | RPAD(Costly_Repair,3,§) This example would show a value for the property Costly_Repair (for example, “Complete Redesign”) followed by $$$.
<p>| RTRIM       | Trims characters from the right side of a text string (trailing characters). The return value uses the String data type. To remove leading characters, use TRIM. See TRIM on page ?. | RTRIM(Text_property) | RTRIM(Parcel_ID) This example removes characters that follow parcel identifiers. |
| SOUNDEX     | Returns names that, in English, sound like the | SOUNDEX(Text_property) | SOUNDEX(Last_Name) = SOUNDEX('Smith') |</p>
<table>
<thead>
<tr>
<th>Function</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOUNDEX</td>
<td>This example finds last names that sound like Smith (for example, “Smythe”).</td>
<td><code>SOUNDEX('text string')</code></td>
<td></td>
</tr>
<tr>
<td>SUBSTR</td>
<td>Extracts a substring from a string. If the start position is 0, it is treated as 1. If you specify a negative value for this position, the expression counts backwards from the end of the string. The return value uses the String data type. For example, <code>SUBSTR('ABCDEF',-6,4)</code> finds BCDE.</td>
<td><code>SUBSTR(Text_property, Start-position, Length of substring)</code></td>
<td><code>SUBSTR(Last_Name,0,4)</code></td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td><strong>TRANSLATE</strong></td>
<td>Replaces a sequence of characters with another set of characters. The return value uses the String data type. For example, <code>TRANSLATE('A GIS Specialist's Guide to C# ',''#', '___')</code> transforms the book title shown to “A GIS Specialist’s Guide to C” The original title required an additional single quote as an escape character.</td>
<td><code>TRANSLATE(Text_property, 'from=to=text')</code></td>
<td><code>TRANSLATE(Comment_Property ' ''}', '___')</code> This example changes spaces, quotation marks, and # characters to underscore characters.</td>
</tr>
<tr>
<td><strong>TRIM</strong></td>
<td>Trims leading characters from a text string. To remove trailing characters, use <code>RTRIM</code>. The return value uses the String data type. You can specify an optional argument: be BOTH, LEADING or TRAILING. If you do not specify the trim character, a</td>
<td><code>TRIM('optional_argument', Text_property)</code></td>
<td><code>TRIM('trailing', Parcel_ID)</code> This example trims trailing characters from the parcel ID.</td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>UPPER</td>
<td>Converts text to uppercase. The return value uses the String data type.</td>
<td>UPPER(Text property)</td>
<td>UPPER(Parcel_Owner)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>This example would display the value “John McMan-sion” as “JOHN MCMAN-SION.”</td>
</tr>
</tbody>
</table>

**Date Functions**

Date functions are available from the Date Function menu. They return the current date or operate on a date string. These functions are available every data provider except for raster, WFS, and WMS providers.

When you create an expression for geospatial features, you can use the following date functions.

<table>
<thead>
<tr>
<th>Function</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADDMONTHS</td>
<td>Finds the result of adding months to a date. The property value provided must have an integer value. Returns a string with a DateTime data type in the format of the original date value.</td>
<td>ADDMONTHS(Date property, Number)</td>
<td>ADD_MONTHS(Start_Date,1) This example adds one month to the value of Start_Date. If Start_Date is June 1, 2008, ADDMONTHS would return July 1, 2008.</td>
</tr>
<tr>
<td>CURRENTDATE</td>
<td>Returns the current date as a string with a DateTime type</td>
<td>CURRENTDATE()</td>
<td>CURRENTDATE()</td>
</tr>
<tr>
<td>Function</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>--------------</td>
<td>---------------------------------------------------------------------------</td>
<td>-------------------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>EXTRACT</td>
<td>Extracts a date/time field from a date/time value. Returns a value in the</td>
<td>EXTRACT(field, Date_property)</td>
<td>This example extracts the year from the value of Start_Date. If Start_Date is June 1, 2008, EXTRACT would return 2008.</td>
</tr>
<tr>
<td></td>
<td>Gregorian calendar with a DateTime data type. The date/time field can be</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>'YEAR', 'MONTH', 'DAY', 'HOUR', 'MINUTE', or 'SECOND'.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MONTHSBETWEEN</td>
<td>Returns the number of months between two dates as a Double data type. If</td>
<td>MONTHSBETWEEN(Date_property, Date_property)</td>
<td>In this example, if Start_Date is March 1, 2007 and End_Date is April 1, 2007, MONTHSBETWEEN would return 1.</td>
</tr>
<tr>
<td></td>
<td>the first date is later than the second one, the result is positive. If</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>the first date is earlier than the second one, the result is negative.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>If both dates are the same day of a month or are both the last day of</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>a month, the result is an integer. Otherwise, it is the</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
fractional portion of the result based on a 31-day month.

Location Conditions

Location conditions are available from the Locate On Map menu. They filter or select data based on a location you specify in your map.

For example, you can find all roads within 100 meters of a power line, or all parcels within a specific section of the drawing.

In the following illustrations, the objects that are retrieved are highlighted:

<table>
<thead>
<tr>
<th>Condition</th>
<th>Definition</th>
<th>Illustration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inside Circle</td>
<td>Selects features entirely inside a circle drawn on the map.</td>
<td><img src="image" alt="Inside Circle Illustration" /></td>
</tr>
<tr>
<td>Inside Rectangle</td>
<td>Selects features entirely inside a rectangle drawn on the map.</td>
<td><img src="image" alt="Inside Rectangle Illustration" /></td>
</tr>
<tr>
<td>Inside Polygon</td>
<td>Selects features entirely inside a polygon drawn on the map.</td>
<td><img src="image" alt="Inside Polygon Illustration" /></td>
</tr>
<tr>
<td>Condition</td>
<td>Definition</td>
<td>Illustration</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Touching Any Part Of Circle</td>
<td>Selects features touching a circle drawn on the map.</td>
<td><img src="image" alt="Illustration of circle touching multiple shapes" /></td>
</tr>
<tr>
<td>Touching Any Part Of Rectangle</td>
<td>Selects features touching a rectangle drawn on the map.</td>
<td><img src="image" alt="Illustration of rectangle touching multiple shapes" /></td>
</tr>
<tr>
<td>Touching Any Part Of Polygon</td>
<td>Selects features touching a polygon drawn on the map.</td>
<td><img src="image" alt="Illustration of polygon touching multiple shapes" /></td>
</tr>
<tr>
<td>Touching Any Part Of Fence</td>
<td>Selects features touching a line drawn on the map.</td>
<td><img src="image" alt="Illustration of line touching multiple shapes" /></td>
</tr>
<tr>
<td>Condition</td>
<td>Definition</td>
<td>Illustration</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------------------------------------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Touching Any Part Of Point</td>
<td>Selects features touching a point drawn on the map.</td>
<td></td>
</tr>
</tbody>
</table>

**Options**

When you create an expression for geospatial features, you can use the following types of options:

<table>
<thead>
<tr>
<th>Type of Option</th>
<th>Definition</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometric Options</td>
<td>Ways to calculate length and area</td>
<td>Length, area</td>
</tr>
<tr>
<td>Conversion Options</td>
<td>Ways to convert values from one format to another</td>
<td>ToDate, ToDouble, ToFloat</td>
</tr>
<tr>
<td>Aggregate Options</td>
<td>Operate on a set of values</td>
<td>Average, Count, Standard Deviation</td>
</tr>
</tbody>
</table>

**Geometric Options**

Geometric options are available from the Geometric menu. Use them to do the following:

- Calculate the length of lines
- Calculate the perimeters or areas of polygons in a particular feature layer
- Include m, x, y, or z properties for points in data stores that support them.

The Length2D and Area2D options perform calculations on fields in the data store. However, the results of these calculations are not saved back to the data store. In AutoCAD Map, you can create a calculated field to store this...
These functions are available for every data provider except for raster, WFS, and WMS providers.

To use these options, select the object on which you want to perform the calculation. Then create the exact expression shown in the examples that follow. Do not replace the argument `Geometry` with an actual value.

<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>LENGTH2D</td>
<td>Calculates the length of lines and perimeters of polygons</td>
<td>LENGTH2D(Geometry)</td>
<td>LENGTH2D(Geometry)</td>
</tr>
<tr>
<td>AREA2D</td>
<td>Calculates the area of a polygon</td>
<td>AREA2D(Geometry)</td>
<td>AREA2D(Geometry)</td>
</tr>
<tr>
<td>M</td>
<td>Accesses the m (measure) ordinate of a point</td>
<td>M (Geometry)</td>
<td>M (Geometry)</td>
</tr>
<tr>
<td>X</td>
<td>Accesses the x ordinate of a point</td>
<td>X (Geometry)</td>
<td>X (Geometry)</td>
</tr>
<tr>
<td>Y</td>
<td>Accesses the y ordinate of a point</td>
<td>Y (Geometry)</td>
<td>Y (Geometry)</td>
</tr>
<tr>
<td>Z</td>
<td>Accesses the z ordinate of a point</td>
<td>Z (Geometry)</td>
<td>Z (Geometry)</td>
</tr>
</tbody>
</table>

**Conversion Options**

Conversion options are available from the Conversion menu. They convert strings from one format to another. These functions are available for every data provider except for raster, WFS, and WMS providers.
The functions TODATE and TOSTRING support [date formatting options](#) on page 235.

<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>NULVALUE</td>
<td>Evaluates two properties. If the first one is not null, NULVALUE returns the value for that property. Otherwise, NULVALUE returns the second property value.</td>
<td>NULLVALUE(Text_Property, Value)</td>
<td>Nullable(Parcel_Owner,'No Owner Listed')</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>In this example, NULVALUE evaluates the value of Parcel_Owner. If it is null, it converts that null value to the string “no owner listed.” If there is a value for Parcel_Owner, it returns the owner value.</td>
</tr>
<tr>
<td>TODATE</td>
<td>Converts a text string representing date/time information to a date object. The returned value has a DateTime data type. The text property provided must match the format provided. If it does not match, the conversion does not take place. See <a href="#">Date Formatting Options</a> on page 235.</td>
<td>TODATE(Purchase_Date,MM/DD/YYYY)</td>
<td>TODATE(Purchase_Date,MM/DD/YYYY) In this example, the value for purchase date is converted to a date value with the format MM/DD/YYYY. If the purchase date value is November 2, 2002, it would convert to 11/02/2002.</td>
</tr>
<tr>
<td>Option</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>----------</td>
<td>---------------------------------------------------------------------------</td>
<td>---------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>TODOUBLE</td>
<td>Converts a numeric or text string to a double-precision, floating-point number.</td>
<td>TODOUBLE(Text_property)</td>
<td>In this example, the Parcel_Value value is converted to a text string.</td>
</tr>
<tr>
<td>TOFLOAT</td>
<td>Converts a numeric or text string to a single-precision floating-point number.</td>
<td>TOFLOAT(Text_property)</td>
<td>In this example, the Parcel_Value value is converted to a string.</td>
</tr>
<tr>
<td>TOINT32</td>
<td>Converts a numeric or string expression to an int32.</td>
<td>TOINT32(Text_property)</td>
<td></td>
</tr>
<tr>
<td>TOINT64</td>
<td>Converts a numeric or string expression to an int64.</td>
<td>TOINT64(Text_property)</td>
<td></td>
</tr>
<tr>
<td>TOSTRING</td>
<td>Converts a numeric or date expression to a string using an optional format you specify or Converts a numeric or Boolean property to a text</td>
<td>TOSTRING(Date_property, format) or TOSTRING(Numeric_property)</td>
<td>In this example, if the value for Parcel_Sale_Date is January 12, 2007, it is converted to the text string 01/12/2007.</td>
</tr>
</tbody>
</table>


**Example Syntax Definition Option**

string (no format can be assigned). When you use ToString with a Boolean property, the operation generates 1/0 (not True/False) as a result. See Date Formatting Options on page 235 for format options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>string (no format can be assigned). When you use ToString with a Boolean property, the operation generates 1/0 (not True/False) as a result. See Date Formatting Options on page 235 for format options.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Date Formatting Options**

The TOSTRING and TODATE Conversion Options on page 232 provide different formatting options.

**TOSTRING Formatting**

TOSTRING takes a date value and creates a representation of it as a string. The optional format specification parameter defines the structure of the string to create. For example, if the date information is 1998-APR-02, you can format the resulting string as April 2, 1998.

Use any combination in your format (except those that return the number of a day or week within a year for a given date). For example, TOSTRING (1998-APR-02, 'MONTH DD, YY') returns the value APRIL 02, 98.

If you use a relational database management system, your data store may not be able to use its native (built-in) functions to execute the request. If so, the program performs the conversion, which can take more time than if the data store did the conversion.
TODATE Formatting Options
TODATE takes a string value representing a date or time and converts it to a date object. The optional format specification parameter defines the format used to represent the date in the string. For example, for a string containing the date April 2, 1998, the format specification should contain Month DD, YYYY. The following table outlines the formatting options available:

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>YY</td>
<td>Defines the year as a two-digit number, for example, 07.</td>
</tr>
<tr>
<td>YYYY</td>
<td>Defines the year as a four-digit number, for example, 2007.</td>
</tr>
<tr>
<td>MONTH</td>
<td>Defines the month using its name in uppercase letters, for example, APRIL.</td>
</tr>
<tr>
<td>month</td>
<td>Defines the month using its name in lowercase letters, for example, april.</td>
</tr>
<tr>
<td>Month</td>
<td>Defines the month using its name with an initial capital letter, for example, April.</td>
</tr>
<tr>
<td>MON</td>
<td>Defines the month using its three-letter abbreviation in uppercase, for example, APR.</td>
</tr>
<tr>
<td>mon</td>
<td>Defines the month using its three-letter abbreviation in lowercase, for example, apr.</td>
</tr>
<tr>
<td>MM</td>
<td>Defines the month using its two-number abbreviation, for example, 04.</td>
</tr>
<tr>
<td>DAY</td>
<td>Defines the day using its name in uppercase letters, for example, FRIDAY.</td>
</tr>
<tr>
<td>day</td>
<td>Defines the day using its name in lowercase letters, for example, friday.</td>
</tr>
<tr>
<td>Day</td>
<td>Defines the day using its name with an initial capital letter, for example, Friday.</td>
</tr>
<tr>
<td>Abbreviation</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>DY</td>
<td>Defines the day using its abbreviation in uppercase, for example, FRI.</td>
</tr>
<tr>
<td>dy</td>
<td>Defines the day using its abbreviation in lowercase, for example, fri.</td>
</tr>
<tr>
<td>DD</td>
<td>Defines the day using its two-number abbreviation, for example, 06.</td>
</tr>
<tr>
<td>hh24</td>
<td>Defines an hour using its number in the range [0-24].</td>
</tr>
<tr>
<td>hh12</td>
<td>Defines an hour using its number in the range [0-12].</td>
</tr>
<tr>
<td>hh</td>
<td>Defines an hour using its number in the default representation (by default, hh24).</td>
</tr>
<tr>
<td>mm</td>
<td>Defines minutes.</td>
</tr>
<tr>
<td>ss</td>
<td>Defines seconds.</td>
</tr>
<tr>
<td>ms</td>
<td>Defines milliseconds.</td>
</tr>
<tr>
<td>am/pm</td>
<td>Uses the ante-meridiem (morning) and post-meridiem (after noon) specification. Noon is often called 12:00 p.m. and midnight 12:00 a.m., as at the beginning of a day. This format is considered only when used with the time range [1-12] (format hh12).</td>
</tr>
</tbody>
</table>
## Aggregate Options

Aggregate functions are not available from a menu. They operate on a set of values. These functions are available for every data provider except for raster, WFS, and WMS providers (which can use only the SpatialExtent function).

<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
<th>Syntax</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVG</td>
<td>Returns the average of the values as a Double data type. You can specify an optional argument: ALL or DISTINCT. For example: AVG(Id), AVG('all', Id), AVG('distinct', Id)</td>
<td>AVG('all', Numeric_property)</td>
<td>AVG('all', Parcel_Value) This example finds the average of all parcels that have a Parcel_Value property, including the ones that are null or empty.</td>
</tr>
<tr>
<td>COUNT</td>
<td>Returns the number of rows as an Int64 data type. You can specify an optional argument: ALL or DISTINCT. For example: COUNT(Id), COUNT('all', Id), COUNT('distinct', Id)</td>
<td>COUNT('option-al_argument', Numeric_property)</td>
<td>COUNT('all', Parcel_ID) This example counts all the rows containing a Parcel_ID property, including the ones that are null or empty.</td>
</tr>
<tr>
<td>Option</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>--------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>MAX</td>
<td>Returns the maximum value with the same data type as the input parameter. You can specify an optional argument: ALL or DISTINCT. For example: (\text{MAX(Id)}, \text{MAX('all', Id)}, \text{MAX('distinct', Id)})</td>
<td>(\text{MAX('option- al_argument', Numeric_property)})</td>
<td>(\text{MAX('all', Parcel_Area)}) This example finds the largest parcel area value for all parcels containing a Parcel_Area property, including the ones that are null or empty.</td>
</tr>
<tr>
<td>MEDIAN</td>
<td>Takes a numeric value and returns the middle value or an interpolated value that would be the middle value once the values are sorted. The returned value has the same data type as the input parameter. Represents an inverse distribution function that as-</td>
<td>(\text{MEDIAN(Numeric_property)})</td>
<td>(\text{MEDIAN(Parcel_Value)}) This example finds the median value for all parcels that have a Parcel_Value property. It includes parcels with null or empty values for Parcel_Value if it is a numeric property.</td>
</tr>
<tr>
<td>Option</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>------------</td>
<td>----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>MIN</td>
<td>Returns the minimum value with the same data type as the input parameter.</td>
<td><code>MIN('option-al_argument', Numeric_property)</code></td>
<td>This example finds the area of the smallest parcel that has a Parcel_Area property, including the ones that are null or empty.</td>
</tr>
<tr>
<td></td>
<td>The returned value has the same data type as the input parameter.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>You can specify an optional argument: ALL or DISTINCT.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>For example: <code>Min(Id)</code>, <code>Min('all', Id)</code>,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>Min('distinct', Id)</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SPATIALEXTENT</td>
<td>Returns the smallest possible bounding rectangle of all geometries in a layer.</td>
<td><code>SPATIALEXTENT(geometry)</code></td>
<td></td>
</tr>
<tr>
<td>STDDEV</td>
<td>Returns the sample standard deviation</td>
<td><code>STDDEV(Numeric_property)</code></td>
<td>This example finds the standard deviation among</td>
</tr>
<tr>
<td>Option</td>
<td>Definition</td>
<td>Syntax</td>
<td>Example</td>
</tr>
<tr>
<td>--------</td>
<td>------------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>as a Double data type.</td>
<td>parcel values for all parcels with a Parcel_Value property, including the ones that are null or empty.</td>
<td>SUM('all', Parcel_Value)</td>
<td>This example finds the total of parcel values for all parcels with a Parcel_Value property, including the ones that are null or empty.</td>
</tr>
</tbody>
</table>

| SUM | Returns the sum of the values as a Double data type. You can specify an optional argument: ALL or DISTINCT. For example: Sum(Id), Sum('all', Id), Sum('distinct', Id) | SUM('all', Numeric_property) | This example finds the total of parcel values for all parcels with a Parcel_Value property, including the ones that are null or empty. |
Tips and Troubleshooting

Tips

This section contains information about the following:

- Adding a Custom Logo on page 243
- Using Packages to Load Large Resources on page 243
- Connecting to External Databases Using a Connection String on page 244

Adding a Custom Logo

To add a custom logo, import the image into a Symbol Library. Then reference the image in the MapGuide Studio Print Layout template.

For more information, refer to Working with Print Layouts on page 153.

Using Packages to Load Large Resources

If you plan to upload large resources to the server, use packages to load the data. Make sure the MapGuide Administrator has modified the "upload_max_filesize" setting in the php.ini file in the PHP directory of the Web Server Extensions before uploading large files.

   - This creates an MGP package containing all of the data described in the Load Procedure.
This menu option is available only after creating a new load procedure or opening an existing one.

2 Copy the MGP package to the Server Packages folder:
   - Windows: C:\Program Files\Autodesk\MapGuideEnterprise2011\Server\Packages folder
   - Linux: /opt/Autodesk/mapguideenterprise2011/server/Packages


4 Enter an Administrator login. The default is:
   - User ID: Administrator
   - Password: admin

5 Choose the Configure Services menu.

6 In the Resource Services section, make sure that the path for Packages Folder is the same as in Step 2.

7 Choose the Manage Packages menu.

8 In the list of packages in the Load Package section, click the MGP package you created.

9 Click Load Package.

**Connecting to External Databases Using a Connection String**

The revised ODBC Connection Editor in MapGuide Studio uses an XML driver template file to help you connect to external databases using a connection string.

Edit the OdbcConnectionStringTemplateMap.xml file found in C:\Program Files\Autodesk\MapGuideStudio2011. Revise the driver name so that you do not have to retype the driver name each time you configure a connection to an external database. You must do this for each installation of MapGuide Studio. However, this is only required if DSN-based connections are not used. You can also modify the template file to accommodate other drivers, if necessary. Driver names must exactly match the names displayed within the ODBC Administrator under the Drivers tab on the server hosting MapGuideEnterprise.
Troubleshooting

This section includes information concerning:

- Troubleshooting Fonts on page 245
- Troubleshooting SHP Files on page 246
- Troubleshooting MapGuide Enterprise on page 246

Troubleshooting Fonts

Server Fonts Versus Client Fonts

In MapGuide Studio, when you select fonts to be used for labeling or text layers, the fonts listed are those from the client machine. For these fonts to be rendered successfully by the Server, the fonts used on the client machine should be added to the server font directory. If a selected font does not exist on the server, the last available font from the server folder will probably be chosen as a default. On a Windows server, this usually results in WingDings, an unreadable font, being selected and rendered.

Potential Font Mismatch Between a Windows Client and a Linux Server

When a layer is styled in MapGuide Studio, the fonts on the local machine are used. When the layer is served up from MapGuide Server, the fonts on the server are used. For an Autodesk MapGuide Server running on Windows, this generally does not present a problem. However, when MapGuide Server is running on Linux, the default font set on Linux may not contain the required fonts.

LegendFont Property

The serverconfig.ini file installed with MapGuide Server in C:\Program Files\Autodesk\MapGuideEnterprise2011\Server\Bin has a property called LegendFont. This property is used by the Mapping Service to control the font that is used by the server when generating legend images. Please use Site Administrator to change any other property settings.
Troubleshooting SHP Files

Potential Locale Setting Discrepancies Between SHP Data and MapGuide Server

If the locale setting of SHP data is not the same as the locale setting in MapGuide Server, you may get garbled attribute data. To avoid this possibility, change the locale setting of MapGuide Studio to correspond to the SHP data locale setting and select the "Convert to SDF feature source" option while loading the SHP data. This will produce an SDF file containing the correct attributes, which can then be read correctly by MapGuide Server via the SDF provider, regardless of the locale setting in MapGuide Server.

Duplicate Field Names in SHP data

The FDO SHP provider will not properly read SHP data if the associated DBF file contains duplicate fields. To avoid this possibility, rename or delete the duplicate fields.

Troubleshooting MapGuide Enterprise

Serving WMS/WFS

To configure MapGuide Enterprise Server as WMS and/or WFS server

1 From Site Administrator, click Configure WMS/WFS, and update the Server name field with the server name and port of the system on which the Web Server Extensions component is installed. Remove the 8008 port in an IIS Install.

NOTE Change the Script name (the path) mapguide/mapagent/mapagent.fcgi to mapguide2011/mapagent/mapagent.fcgi.

2 In MapGuide Studio, do the following:
   1 Select the Layer/Feature Source to be advertised for WMS/WFS.
   2 Right-click and select Properties.
   3 Select the Service Properties tab, and set the metadata.
The WFS Provider is currently for preview only. It may support connections to external WFS sources, but does not support connections to other MapGuide Enterprise WFS sources.

Enabling MapGuide WMS to Use Unsupported SRS codes

Symptom: Using the request=GetMap operation in Autodesk MapGuide fails with an InvalidSRS exception, even though the request is well-formed and is using a valid EPSG code.

Background: The OGC WMS standard uses European Petroleum Standards Group designations for spatial reference systems (SRS's.) These take the form of EPSG:nnnn where nnnn is a number. For example, WGS 84 is represented as "EPSG:4326" and California zone 1 in US feet / NAD83 is "EPSG:2225" The coordinate system library used by Autodesk MapGuide has only limited support for EPSG codes.

Solution: Autodesk MapGuide overcomes this limited support by transforming the EPSG codes into OGC "Well Known Text" or WKT, which the coordinate system library can consume.

To enable MapGuide WMS to use unsupported SRS codes

1. Find the Well Known Text (WKT) string for the SRS in question. A WKT string looks like this:
   
   GEOGCS["WGS 84", DATUM["WGS_1984", SPHEROID["WGS 84",6378137,298.257223563,AUTHORITY["EPSG","7030"]], TOWGS84[0,0,0,0,0,0,0],AUTHORITY["EPSG","6326"]], PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]], UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9108"]], AXIS["Lat",NORTH],AXIS["Long",EAST],AUTHORITY["EPSG","4326"]]

2. Open the OgcWmsService.config.awd found in the Wms folder of your Server installation using any text editor. Do not use a word processor, as this might corrupt the file.

   NOTE Back up this file before making any changes.

3. Find the SRS.WKT.map definition in this file.

4. Insert the following on the line immediately before the </Define>:

   <translate from="your:srs">your-wkt-string</translate>
In the line above, replace `your:srs` with the SRS that is exhibiting problems, and replace `your-wkt-string` with the WKT string for your SRS (as discussed in step 1). The results should look similar to the following example (truncated for simplicity):

```xml
<Define item="SRS.WKT.map">
<translate from="EPSG:21781">PROJCS["CH1903.LV03", ... </translate>
<translate from="EPSG:9999">PROJCS["Troublesome.SRS", ...</translate>
</Define>
```

5. Save the file.

6. Stop and Restart your web server (IIS or Apache) because this file is cached for performance reasons.

7. Confirm that a WMS GetMap request using the SRS in question works.

You can put any number of `<translate from=""></translate>` elements into this definition. However, there is a memory and performance cost with using them, so it is best to define only those you need, and remove those that you do not need.
Index

A
Access database, as ODBC source 36
aerial imagery
  samples 3
aggregate options
  for geospatial feature queries 238
ajax viewer
  setting up 78
annotation layers
  styling 95
ArcSDE
  about 41
  configuring a connection 41
  areas
    styling 93
  arithmetic operators 208
Autodesk Spatial Application Studio
  about 7
  editor pane 7
  interface 7
  resources 8
  Site Explorer 7
  starting 11
  understanding 7
  web layout 12

B
background color
  setting 73
bitonal images 34, 109
browser
  defining initial map view 131
  displaying a map 115
browser title text
  defining 117, 130
buying data 2

C
calculated fields
  video 167, 178
calculated properties
  and expressions 179
  expressions for 167
calculating
  new values based on existing
    properties 179
catalog, raster 29
classification
  in ODBC 36
commands
  customizing 124, 139
  comparison operators 209
  for geospatial feature queries 209
  compressing data files 56
  Concat function 221
concatenating
  text properties in expressions 221
conditions for queries
  for geospatial data 163
configuring a connection
  ArcSDE 41
  MySQL 42
  ODBC 37
  Oracle 39
  PostGIS 38
  SQL Server 43
  SQL Server Spatial 45
  web services 46–47
confirmation dialog box 151
connecting to a site 11
connecting to databases 35, 49
connection string 37
context menus
  defining 120, 135
conversion options
  for geospatial feature queries 232
converting

data values from one format to another 181
Create A Calculation dialog box 167, 205
Create Query dialog box 167, 205
Create/Modify Expression dialog box 167, 205
creating print layouts 153
creating styles 87
creating themes 101
  automatically 102
  manually 101

D

data
  samples included with Autodesk MapGuide Enterprise 2
  samples included with Autodesk MapGuide Studio 2
Data Connect
  Add to Map With Query 193
data providers
  and expressions 202
date formatting
  for geospatial feature queries 235
date functions
  for geospatial feature queries 227
date-time operators
  for geospatial feature queries 211
dates
  converting from text strings 172
  in expressions 171–172
DB2, as ODBC source 36
dialog boxes
  Create A Calculation 205
  Create Query 205
  Create/Modify Expression 205
  Search For Features Across Multiple Layers 205
  Search To Select 205
  Split Rule Expression/Merge Rule Expression 205
DigitalGlobe 2
displaying
  expression template buttons 201
distribution methods
  equal 105
  individual values 105
  Jenks (natural breaks) 105
  quantile 105
  standard deviation 105
draw order
  adjusting 76
drawing sheets
  specifying for drawing source layers 107
drawing source 10
DSN, system 37
duplicate records, in SDF files 21, 25
DWF files
  about 26
  loading 28
DWG files
  how they are transformed 19
  load entire DWG 19
  loading 18

E

editor pane 7
editors 7
equal distribution 105
Excel spreadsheet, as ODBC source 36
expressions
  aggregate options for geospatial feature queries 238
  and data providers 202
  and date values 171–172
  and feature class properties 173
  and split/merge rules 192
  comparison operators 209
  comparison operators for geospatial feature queries 209
  conversion options for geospatial feature queries 232
  creating 167–168
  date formatting for geospatial feature queries 235
date functions for geospatial feature queries 227
date-time operators for geospatial feature queries 211
defining for geospatial features 163
displaying template buttons 201
for labels 188
for labels (video) 167, 183
for location-based queries 187
for numeric values 184
for text values 182
functions for geospatial feature queries 212
geometric options for geospatial feature queries 232
hiding tooltips 201
location conditions for geospatial feature queries 229
logical operators for geospatial feature queries 210
math functions for geospatial feature queries 213
math operators for geospatial feature queries 209
number 112
numeric functions for geospatial feature queries 219
operators for geospatial feature queries 208
overview 163
reusing 199
rounding options 219
saving 199
Search For Features Across Multiple Layers 196
selecting properties from a list 177
text 110
text functions for geospatial feature queries 221
troubleshooting 197
using Mod and Remainder 219
using properties and functions 173
using properties and operators 173
using properties and options 173
using to convert data formats 181
viewing location boundaries 201
zooming extents 201

F

FDO providers 35, 49
feature class
  specifying for layer 82
feature classification
  in ODBC 36
feature data
  converting value formats 181
feature joins
  about 53
  creating 54
feature source 10
feature source layers 82
  creating styles for 87
  creating themes for 101
  defining scale ranges 87
  specifying feature class 82
  specifying geometry 82
features
  creating expressions 168
  expressions for 163, 167
  filtering by conditions 194, 196
  filtering by location 194
  filtering when adding to maps 193
  labeling with expressions 188
  searching 196
files
  DWF 26
  DWG 18-19
  loading 17
  raster 29
  SDF 20, 25
  SHP 22
filtering
  feature data when adding to maps 193
  feature layers 194
  feature layers by location 187
  feature layers using expressions 167
filtering data 84
filters
  conditions for features in maps 194, 196
flyouts
  creating 123, 138
folders
  creating 59
fonts
  using in symbol library 148
functions
  for geospatial feature queries 212

G
geodata 2
geometric options
  for geospatial feature queries 232
geometry
  specifying for layer 82
geospatial features
  creating expressions 168
  expressions for 163, 167
  filtering when adding to maps 193
  searching 196

H
hiding
  tooltips for expressions 201
hyperlinks
  target location 131

I
ImageConnect 2
images
  importing into symbol libraries 148
  images, see raster files 34
individual values distribution 105
initial task pane task
  defining 131
initial view
  setting 73
installing
  sample data 3

Intermap 2
invoke script command
  creating 127, 142
invoke URL command
  creating 127, 142

J
Jenks (natural breaks) distribution 105

L
labeling features 96
labeling points 99
labels
  allowing to obscure points 99
  and expressions (video) 167, 183
  following a path 188
  multiline 188
  on features 96
  on features using expressions 188
  on points 99
layer
  drawing source 106
  filtering data for 84
  linked documents 85
  previewing 57, 113
  settings 76
  tooltips 85
Layer Editor options 151
layer groups
  creating 75
layers
  adding 74
  adjusting draw order 76
  feature source 82
  in DWF files 28
  raster 108
  searching 196
  setting up 74
  specifying for drawing source layers 107
  specifying the data resource for 81
  working with 81
legend
  adjusting 75
lines
  calculating length with expressions 232
  styling 92
linked documents 85
loading data, overview 17
loading files
  DWF 28
  DWG 19
  raster 32
  SDF 20
  SHP 23
  SQLite 25
location
  filtering feature layers by 194
  finding features by 187
  viewing current expression boundaries 201
location conditions
  for geospatial data 187
  for geospatial feature queries 229
logarithmic functions
  for geospatial feature expressions 213
logical operators
  for geospatial feature queries 210

M
map
  adding layers 74
  creating 71
  creating layer groups 75
  previewing 79
  setting background color 73
  setting coordinate system 72
  setting initial view 73
  setting up layers 74
math functions
  and Mod/Remainder 219
  for geospatial feature queries 213
math operators
  for geospatial feature queries 209
  mathematical operators 208
merging
  polygon features using expressions 192
metadata
  samples 3
  Microsoft Access, as ODBC source 36
  Microsoft Excel, as ODBC source 36
  Mod
    and functions in expressions 219
  multiline labels 188
MySQL
  configuring a connection 42
  MySQL, as ODBC source 36

N
NAVTEQ 2
number expressions
  building 112
  numeric expressions 184
  numeric functions
    for geospatial feature queries 219

O
ODBC
  configuring a connection 37
  coordinate system for 36
  points database 36
operators
  arithmetic 208
  comparison 209
  for geospatial feature queries 208
  mathematical 208
options
  setting 151
Oracle
  configuring a connection 39
  versions supported 39
overposting 99

P
packages
  about 56
creating parcel data samples points styling points database, ODBC polygons calculating area with expressions calculating perimeter with expressions merging using expressions splitting using expressions PostGIS about configuring a connection print command creating print layout schema print layouts creating sample schema for properties selecting for expressions specifying for viewer using in expressions Property list for expressions providers, FDO publishing wfs wms purchasing data creating for geospatial data date formatting for geospatial features date functions for geospatial features date-time operators for geospatial features for features using expressions functions for geospatial features geometric options for geospatial features location conditions for geospatial features logical operators for geospatial features math functions for geospatial features math operators for geospatial features numeric functions for geospatial features operators for geospatial features text functions for geospatial features Query To Filter Data R raster catalog raster files about loading resolution of raster layers background color foreground color scale range zoom rebuild factor relationships, database Remainder and functions in expressions resource properties viewing resources changing owner
creating new  60
deleting  61
drawing source  10
feature source  10
joining  53
layer  10
load procedures  10
map  9
moving  61
organizing  59
print layouts  11
properties of  64
refreshing display of  62
renaming  61
saving as xml  61
setting permissions  66
sorting  59–60
symbol libraries  10
understanding  8
viewing properties of  64
web page  9
reusing
  expressions for features  199
rounding options
  for expressions  219

S

sample data
  downloading  3
  for Autodesk MapGuide Enterprise  2
  for Autodesk MapGuide Studio  2
  on product CDs  3
satellite imagery
  samples  3
saving
  expressions  199
scale range
  defining for drawing source layers  106
  defining for feature source layers  87
  defining for raster layers  108
  understanding  87
SDF files
  about  20
  loading  20
  types of  20, 25
search command
  creating  128, 143
Search For Features Across Multiple Layers dialog box  167, 205
Search To Select dialog box  167, 205
searching
  and expressions  196
  by location  196
  by property values  196
  for features  196
  for features using expressions  167
selecting
  features using expressions  167
setting options  151
shapefiles, see SHP files  22
SHP files
  about  22
  loading  23
site explorer
  hiding  63
  showing  63
Site Explorer  7
  options  151
  refreshing  62
site properties
  viewing  63
smooth pan and zoom
  ajax viewer  78
soil drawings
  samples  3
Soundex function  221
Split Rule Expression/Merge Rule Expression dialog box  205
split/merge rules  189
splitting
  polygon features using expressions  192
SQL Server
  configuring a connection  43
SQL Server Spatial
  configuring a connection  45
SQLite files
  about  25
  loading  25
standard deviation distribution 105
street centerline data samples 3
styles creating 87 styling areas 93 styling lines 92 styling points 88 symbol copying 149 deleting from library 149 symbol library creating 147 importing fonts 148 importing images 148 symbols 2 adding to point layers 88 using 147
task bar buttons customizing 134
task pane menu defining 120, 135 templates 2 for expressions 201 text and expressions 182 formatting using expressions 221 text expressions building 110 text functions for geospatial feature queries 221 themes creating 101 creating automatically 102 creating manually 101 distribution methods 105 ToDate formatting in expressions 235 tooltips 85 for expressions 201 ToString formatting in expressions 235 Trim function 221 troubleshooting expressions for features 197
URL defining initial task 131
validation expressions 197 videos calculated fields 167, 178 expressions for labels 167, 183 viewer Autodesk DWF 152 components to display 119, 132 defining components to display 131 HTML/AJAX 152 setting up 119, 132 specifying 152 specifying properties to display in 83 viewer legend 75 viewer toolbar defining 120, 135
Web warning messages 67 water data samples 3 web feature service (wfs) 67 publishing 67 web layout basic steps for building 12 building 115 creating 115, 130 defining map resource 117, 131 previewing 129, 144 setting up 115, 130 web layout editor using 117, 130
web mapping service (wms) 67
  publishing 67
web services 13
  about 45
  configuring a connection 46–47
wfs
  publishing 67
wms
  publishing 67

X
xml  
  saving a resource as 61

Z
zoom rebuild factor  
  specifying 108
zooming  
  for expressions 201