Display Model Tutorial

Working with Display Models

NOTE This tutorial requires a workspace with two documents, one for land data
and one for gas data. Your administrator can create this workspace and import the
two associated documents using the sample data provided in Topobase 2010. For
more information, see the Topobase Installation and Configuration Guide.

When you generate your map, Topobase applies a display model (.tbdm) to the
geometry. You can select a display model or use the default display model. The
default display model draws all the geometry in the document and applies a
default stylization to each layer. When you generate your map using the default
display model, a default style applies to each feature class. You cannot influence
the styling of a default display model. You can create new display models and
save them for all your stylization requirements. Customized display models
control what geometry is drawn and how it is displayed.

When you generate graphics, the viewport is applied the next time you generate
graphics. For example, say you have two display models, DM1 and DM2.
Generate graphics with DM1 and zoom into an area of interest. Next, select
DM?2 and generate graphics again. The same area of interest is generated using
DM2 as with DM1. This enables you to switch to another display model easily
and view the same area of interest. If you do not want to view the previous area
of interest, you must define a new area of interest using a viewport or the
position finder. To define a viewport or use the position finder, use Advanced
Generate Graphics. For more information, see the online help.



Exercise 1: Set Display Model Options

In this exercise you will:

B Create a relative path for display models to facilitate sharing.

B Specify that for each Generate Graphic the current drawing will be closed,

and a new drawing will be opened.

1 On your local drive, create the following folder structure:

Topobase2010\DisplayModels

address | S Topobase201d)|
Folders

= | Topohasez010
= |Z) DisplayModels

2 Start Topobase 2010 Client and open the workspace containing Land

and Gas sample data.

Open Workspace

Select Workzpace to be opened

TB2010_Elestric_CE W5 _Tutarial
TB2010_Electic_MA

TB2010_Gas

TE2010_LM_102

TE2010_WwWa_102

TE2010_WwWw_102

l

Open

]l Cancel ][

Help

]

The workspace opens and the two documents are visible in the Topobase
pane. Note that the Home tab » Display panel shows the Default Display

Model selected.
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Autodesk Topobase Client 20

£y | TB2010_1M_102 [ =
& ¢ | Defaulk Display Model [~ & -
g i)

— EL Connect to Data... " Style Layers Generate
[=] | Real world view [2e] Graphic ~

Data Source Display

TEZ2010_LM_102 | TE2010_GA_102

Gk GBS
= E[y TB2010_LM_102
=-E7 Topics

IMPORTANT Do not generate graphics. If you click Generate Graphic now,
Topobase draws all the data from both documents which can take quite some
time. To improve performance, you should create a display model that
contains just the information of interest.

In the ribbon, click Settings tab » Setup panel » Application Options.

© & B emqw:

Application | Document  Customize, mm (T [ B3
Options Options Interface... AN Y

Setup

In the left pane of the Application Options window, click the Generate
Graphic node.

In the Display Model area, under Repository Base Path, click Browse. In
the Browse For Folder dialog box, navigate to the folder you created in
step 1. Click OK.

When you set a repository base path for your display models, you can
share display models more easily. A relative path is stored in the display
model so you can copy it to any location on another computer. If you
do not use a relative path, the same folder structure must be present on
each computer that uses the display model.

NOTE Itis also possible to share display models or layers using absolute UNC
paths. For example, \\server\SharedDisplayModels. In this case, the folder
structure only has to be created once.
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7 In the Display Model area, make sure that Close Current Drawings is
selected.

[izplay Maodel
R epository baze path:

C:\Topobase201 0\ DisplapModels

Drawing options when generating a dizplay model:

{?} Cloze current drawings
Thiz will only zhow drawings related to the cument dizplay model

) Keep current drawings open
Thiz will zhow all drawings related to the curent and previous display models

) Reuse active drawing
Thiz will allow the firzt display model map to populate the active drawing

When you generate graphics, Topobase opens a new drawing and closes
the previous drawing. This is the default selection.

8 In the left pane of the Application Options window, click the Map Options
node.

9 Under Map Options, clear Always Display Highlighted Features. Click OK
to close the Application Options dialog box.

Exercise 2: Connect to Data and Define Styles

In this exercise you will:
B Connect to the Topobase documents.
B Add some feature class layers to your map.

B Define layer styles.

1 In the Display Manager task pane, click Data » Connect To Data.
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Current Map: | EEEN

Display Manager

ita @ Conneck to Data. .. h i

"":3 Mew Map. ..

ﬁ-’j Mew Group

%} Mew Text Laver. ..
Load Lawver..,

L) Bulk Copy...

Map Explorer

Add Drawing Data *

2 In the Data Connect window, click Add Topobase Connection.

You are prompted to create a connection, such as Topobase_1 or
Topobase_2.

3 Inthe Add A New Connection area, provide the service name, user name
and password.

See your administrator for this information.

4 From the Document list, select TB2010_LM_102. Click Connect.
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Data Connections by Provider

4 Add ArcSDE Connection

Add My3QL Connection

Add CDBC Connection

5 Add Oracle Connection

L add Raster Image or Surface Connecl
Add SDF Connection

Add SHP Connection

_,Q_ Add SOL Server Conneckion

Add S0L Server Spatial Connection
Add Topobase Connection

G Add WFS Connection

G Add WMS Cornection

Bl T x

D3

78
[

[
=]

- Data Connect

[7] Data Connect help i Learn more

Autodesk FDO Provider for T opobase
Add aNew Connection

Read access to Topobase, Establish connection to Topobase Main User (TEMAIN)
or Topobase System User (TESYS), Select a Document,

Connection name:

Topobase_1

Service name:

arel

Topobase Main o System User name:

thsys

Topobase Main or System User password:

Docurnent:

TBZ010_LM_102 v

You are now prompted to select the feature class layers to add to the map.

5 In the Add Data To Map area, select LM_BUILDING and LM_PARCEL_L.
Click Add To Map and then close the Data Connect window.

Data Connections by Provider

Add ArcSDE Connection

Add MySQL Connection

Add ODBC Connection

Add Oracle Connection

Add Raster Image or Surface Connectio

Add SDF Connection

Add SHP Connection

Add SQL Server Connection

Add SQL Server Spatial Connection

Fed add Topobase Connection
Topobase_1

(R Add WFS Connaction

G Add WS Connection

Bl x

DDEEDDDD

-4 Data Connect

[7] Dataconnect help i| Learn more
Topobase
Topobase_1 [orel/TE2010_LM_102)
AddDatatoMap

Available sources in this connection. Select Items ko add to the map as lavers.

@Ed\t Coordinate Systems | E@ Refresh J

Schema Coordinate System i
[ EILANDUSE_TSUR = urikniown
(LM BUILDING = uniknown =
[ (3L _BUILDIMG _TEL < unknawn >
[ (LM _LANDUSE < unknown >
[] E9ILM_LANDUSE L < unknawn >
] E3ILM_PaRcEL = urikniown =
[ILM PARCEL L = uniknown >

hd

131 m panre TR £ nnknon

>

7 add ta Map [-]
e

Map Coordinate System Add to May
P

< unknown

< unknown =

< unknown >

Digconnect from Feature Source

To reconfigure this connection, disconnect, and then edit the
infarmation,

Disconneck
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Layers corresponding to the Building polygon feature class and Parcel
line feature class are added to the Display Manager with a default

stylization.

o [ Teskbere

Current Map: |Defau|t

(]

=

Data Style Table Groups Tools

B

Display Manager

|

Map Explorer

/

T

- 1 Topobase_1

—————— LM_PARCEL_L

[ LM_BUILDING
- Map Bare

| Default

Exercise 3: Save a Land Display Model

In this exercise you will:

B Save layer styles as a display model file.

NOTE Because a display model is made up of several files, we recommend
that you create a folder for each display model as shown in this exercise.

B Modify the initial viewport and save your changes.

1 Click Home tab » Display panel » Save Display Model As.

v

& Style Layers

/ | Default Display Model

EL Connect to Data...

Display

Displ{ Save Display Model As...
Saves a copy of the current display model under a new file name

) TEDMSAVEAS
Press F1 for more help
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2 In the New Display Model dialog box, in the General area, under Name,
enter Land Tutorial.

3 In the Window List area, right-click any column title, and click Restore
Default Configuration. This is for the purpose of the exercise only. It will
ensure that you are able to follow the exercise correctly.

4 Click the area under Name, and replace the default map name (New
Display Model Map) with Land Map.

5 In the Layer List area, right-click any column title, and click Restore
Default Configuration. We will use the other options later in this tutorial.

6 Notice that the Autoload and Filter checkboxes are cleared for both layers,
and that the Confine To Viewport checkboxes are selected. Leave these
settings as they are for now. We will explain them later in this exercise.

Click OK.
- -
T New Display Model E]@
General
Name
Land Tutorial
Window list
Mame Coordinate 5. Stats Height | Width | X Y
Land Map Maximized 105% 100% 0% -5%
Layer list
Mams Autcload | Filter | Confine to Viewport | Source| Ref. | Path
LM_PARCEL L [
. LM_BUILDING [ ]

A dialog box displays the repository you created in Exercise 1.

8 Click Create New Folder and name the new folder DM_Land. Click Open
and then click Save to save the display model to the DM_Land folder.

The display model files are saved to the DM_Land folder in your
repository. We will examine the display model files in the next exercise.
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9 Make sure the display model you just created, Land Tutorial, is displayed
in the Home tab » Display panel » Display Model list.

10

11

12

Click Home tab » Display panel » Generate Graphic.

& | Land Tutorial

va| U

El Connect to Data...  #” Style Layers Generate
Graphic ™
Display
piay ——

NOTE The Generate Graphic icon contains two options, Generate Graphic
and Advanced Generate Graphic. Be sure you click Generate Graphic.

Zoom in or out and click Generate Graphic again. Note the display model

uses the current zoom.

Click Home tab » Display panel » Save Display Model.

4 | Land Tutorial [w

EL Connect to Data.. & Style Layers

Display

@ 2 @ as

E Save Display Model

g Save Display Model &s... Save Display Model
Saves the cumrent display model

Display Model Properties ; TBDMSAVE

Press F1 for more help

@ Assign Display Model Map for use in To |

In the Layer List area, note that the Filter checkbox is now selected for
each layer. A spatial filter is set to the viewport. If you save the display
model with this spatial filter applied, this viewport will be used the first
time you generate graphics using this display model. Thereafter, the
viewport reflects the current zoom setting. The spatial filter helps you
quickly orient yourself in a map by displaying an area of interest the first
time you generate graphics.

NOTE In this exercise, the Filter checkbox only includes the spatial filter on
the viewport. Keep in mind that the Filter also includes any Query To Filter
Data settings you have defined in Display Manager.
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l Land Tutorial g@

General

Name

Land Tutorial

Window list

Mames | Coordinate 5. State Height | Width | X Y

Land Map Maximized 105% 100% 0% -5%
Layer list
Mams Autcload | Filter | Confine to Viewport | Source| Raf, Path
LM_PARCEL L [
LM_BUILDING  []

13 Do not save the Display Model now. Click Cancel.

Exercise 4: Examine Display Model File Structure

When you save a display model, Topobase creates the following files:

B Display model master file (*.tbdm)—References the map file (*.tbdmmap).
For each map there is one .tbdmmap file.

B Display model map (*.tbdmmap)—References the layer files (*./ayer).
B Layer files (*./ayer)—Contain style information for each layer.

B Recovery files—The folder .disasterrecovery is created in your Repository
Base Path. This folder holds a temporary copy of the current Display Model
during the Save Display Model operation.

B Block definition files (BlockDefinitons*.dwg)—Store the block definitions
that are referenced in a layer file.

1 In an Explorer window, navigate to the
Topobase2010\DisplayModels\DM_Land folder.
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Address |3 '\ Topobase201 0\DisplayModels\DM_Land

Folders x Marme
= 03 Topobasez010 || [ Land Tutorial.thdm
= |} DisplayModels LM_BUILDING.Iayer
) DM_Land =] LM_LANDUSE _L Jayer

Map1.tbdmmap

2 Open the files in a text editor. Notice that land tutorial.tbdm references
the map1.tbdmmap file which references the layer files. The layer files
define the layer style.

Exercise 5: Create Autoload Layers

When you save a display model, you can define Autoload layers. The Autoload
layers for the last selected display model are loaded the next time you open
the workspace. You do not need to generate graphics first. Autoload layers
provide context to help you quickly navigate to a region of interest before
generating graphics.

In this exercise you will define LM_PARCEL_L layer as an Autoload layer in
the Land Tutorial display model.

1 Click Home tab » Display panel » Save Display Model.

2 Inthe Land Tutorial dialog box, in the Layer List area, select the Autoload
checkbox to the right of the LM_PARCEL_L layer.

3 If selected, clear the Filter checkboxes for both layers. Leave the Confine
To Viewport checkboxes selected.
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M

~ General
Name

Land Tutorial

~ Window list

MName | Coordinatz 5. State | Height | width | X | v |
Land Map Maximized 105% 100% 0% -5%

~ Layer list

Mame | Autcload | Filter | Confine to Viewport | Source | Ref, | Path |

LM_BUILDING L} L] [ fOM_Land/LM_BUTLDING.layer

4 Click OK.
5 Exit Topobase Client; click No when prompted to save changes. Restart,
and reopen the workspace.

Notice that Land Tutorial is selected in the Home tab » Display
panel » Display Model list. The Autoload layer, LM_PARCEL_L, is drawn
immediately and is shown in the Display Manager.
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j | Land Tutorial |E|| H- @ I;; @ C

[l Connect to Data... & Style Layers Generste Edit Aftributes g
Graphic ™ | Geometries

Display Quick Access
x
Current Map: |Defaull M o
2 £
a =y -
[
S B %
) Data Style Table Groups Tools
a
&

7 21 Topobase_1

——— LM_PARCEL L
o - fMap Saze
[E]
/éf _E. P Default
wl

6 Zoom to any area in the map.

7 Make sure that Land Tutorial is still selected in the Home tab » Display
panel » Display Model list. Click Home tab » Display panel » Generate
Graphic.

Notice that the contents of both layers in the Land Tutorial display model
are drawn, and both layers are shown in the Display Manager.
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& Land Tutorial [~ H - @ Q @ NS

Bl Connect to Data... & Style Layers Generate Edit Atbutes & @) -
Graphic ™ | Geometries

Display Quick Access
x
Current Map: |Default [v] ol
5 .
q ST =h
[=
5 O 5 2
& | Data Style Table Groups Tools
)
&

- 3 Topobase_1
[ LM_BUILDING

_ LM_PARCEL_L
[}

k]

L% g Map Baze

E 1 Default

Exercise 6: Confine Layers to Viewport

By default, when you generate graphics, the layers are confined to the viewport.
When you zoom out, features outside the viewport are not visible.

In this exercise you will:

Use Advanced Generate Graphic to zoom into a viewport.

Set up the parcel layer so it does not confine to the viewport and can be
used as context to navigate to a region of interest.

Save the settings in the Display Model.

Specify that features resulting from a tracing or a filter are always displayed,
whether they lie within the viewport or not.

1 Click Home tab » Display panel » Advanced Generate Graphic.
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& | Land Tutorial ~ H- @

EL Connect to Data.. & Style Layers Generats
Graphic

-

L @

Edit Attribu
Geometries

Display
Generate Graphic

.u Advanced Generats Graphic

- 1

In the Advanced Graphic Generation dialog box, click the

TB2010_LM_102 tab. Enter the following values:
B Easting: 687700

B Norting: 335400
m Width: 300
B Height: 200

Click Generate Graphic. Zoom out. Notice that the layers are confined

to your specified viewport.
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Quick Access

Display Manager

|

Map Explorer

4 Click Home tab » Display panel » Display Model Properties.

P sEl & (D @ as
5l Connect to Datz... &7 Style Layers E Save Display Model

Display
g Save Display Model As...

Display Model Properties

@ Assign Display Model Map for use in Topobase Web

vl

5 In the Layer List area,
B clear the Filter checkboxes for both layers.

B clear the Confine To Viewport checkbox for the LM_Parcel_L layer.
Click OK.

6 Zoom in, and generate graphics.
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7 Zoom out. Notice, that the parcel borders are drawn for the complete
area, while the buildings are drawn within the previous viewport.

Displaw Manager

|

rap Explorer

8 Click Home tab » Display panel » Save Display Model.

9 In the Land Tutorial dialog box, in the Layer List area, if selected, clear
the Filter checkboxes for all layers.
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BEI[X]

1 Land Tutorial
General
Name
Land Tutorial
Window list
Mams | Coordinats &. State Height | Width X Y
Land Map Maximized 105% 100% Q% -5%
Layer list
Name Autoload | Filker | Confine to Viewport | Source| Ref.
LM_PARCEL L [ ] u
M_BUILDING [ [
10 Click OK.

Path

Confine To Viewport also affects highlighting of filtered features or tracing
results. By default, only the features within the viewport are highlighted. You

can change this behavior.

1 Zoom in, and generate graphics. Zoom out.

2 In Topobase Explorer, click the TB2020_LM_102 tab, expand the Building
topic, and select Building. Right-click, and click Show Form.

17

DI &7

Fl7 i

3 In the Building form toolbar, click Remove Filter.

:@D%I@E%

4 Click Highlight All Features In The Selection Set

. Notice that only the buildings within the viewport are highlighted.
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In the ribbon, click Settings tab » Setup panel » Application Options.

In the left pane of the Application Options window, click the Map Options
node.

Under Map Options, select Always Display Highlighted Features. Click
OK.

In the Building form, click Highlight All Features In The Selection Set
again. Notice that all buildings are highlighted now.

In the Building form, click Unhighlight Highlighted features.

Close the Building form.
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10 In the ribbon, click Settings tab » Setup panel » Application Options.

11 In the left pane of the Application Options window, click the Map Options
node.

12 Under Map Options, clear Always Display Highlighted Features. Click
OK.

Exercise 7: Modify and Save Layer Settings

You can use the Display Model properties to update layer settings without
editing each layer in the Display Manager. The modifications apply to the
next Generate Graphics. For example, you can clear layers you do not want
to draw. In this exercise you will:

m Show additional display model properties in the Display Model Properties
dialog box.

B Modity the caption of the layers, and make the parcel layer un-selectable.

B Save the settings in the Display Model.

1 Click Home tab » Display panel » Display Model Properties.

2 In the Layer List area, right-click any column title, and select Feature
Class, and Selectable.

3 Click the area under Name, and replace the feature class name
(LM_Parcel_L) with Parcel. Replace the feature class name (LM_Building)
with Building.

4 For the Parcel layer, clear the Selectable checkbox. Click OK.

5 Generate graphics.

Notice that the Display Manager shows the modified captions. Right-click
the Parcel layer, and notice that the layer is not selectable.
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-\_\_H_‘—‘-—\.
S
)

6 Until now, your modifications only apply to the Display Manager. You

Current Map: | Drefault

B8 B X

Data Style Table Groups Tools

Display Manager

- 21 Topobase_1

@ Edit Connection. ..
# Edit style..,
@ Show Data Table

@ Zoom ko Extents

E@ Refresh Laver
Make Laver Selectable

can save them in the Display Model.

1 Buiding

Click Home tab » Display panel » Save Display Model.

7 In the Layer List, if selected, clear the Filter checkboxes. Click OK.

L
~General
Name
Land Tutorial
~ Window list
Name |Coordinate 5.| State | Height | width | x | ¥ |
Land Map Maximized 105% 100% 0% -5%
~ Layer list
Mame | Featurs Class | Autoload | Filter | Confine to Viewport | Selectablz | Source | Ref. | Path
Parcel LM_PARCEL_L = [P [F JOM_Land/LM_PARCEL_| layer
Building LM_BUILDING [ =] =] /DM _Land/LM_BUILDING layer
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Exercise 8: Create a Gas Display Model

In this exercise you will create another display model, Gas Tutorial. You will
use the Gas Tutorial display model in Exercise 10 to create a multimap display
model.

1 In the ribbon, click Home tab » Display panel » Connect To Data.

j Land Tutorial L E - @

|EL Connect to Data...| & Style Layers Generate
Graphic ~

Connect to data...

Connects a featurs source

‘= MAPCONNECT

Press F1 for more help

2 In the Data Connect window, click Add Topobase Connection.

You are prompted to create a Topobase_2 connection.

3 Inthe Add A New Connection area, provide the service name, user name
and password.

See your administrator for this information.

4 From the Document list, select TB2010_GA_102. Click Connect.
You are now prompted to select the feature class layers to add to the map.

5 In the Add Data To Map area, select GA_LINE and GA_POINT. Click Add
To Map and then close the Data Connect window.

Layers corresponding to the Gas line feature class and Gas point feature
class are added to the Display Manager with a default stylization.

Click Home tab » Display panel » Save Display Model As.
In the General area, under Name, enter Gas Tutorial.

In the Window List area, click the area under Name, and enter Gas Map.

O 0O N O

For GA_LINE,
B select the Autoload checkbox.
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B clear the Confine To Viewport checkbox.

10 Clear the Autoload and Filter checkboxes for the other layers. Keep the

11

12

13

14

Confine To Viewport checkbox selected for the other layers. Keep the
Selectable checkbox selected for all layers.

Under Name, replace the feature class name (GA_LINE) with Gas Network
Line. Replace the feature class name (GA_POINT) with Gas Network Point.

l Land Tutorial g@

General
Name

Gas Tutorial

Window list

Mame | Coordinate S. State Height | Width X Y
Gas Map Maximized 105% 100% 0% -5%
Layer list
MName Featurs Class | Autcload | Filter | Confine to Viewport | Selectable | Source | Ref. | Path

Gas Metwark Paint O

Gas Metwork Line O

Parcel O O
Building O 0O O

Click OK.

A dialog box displays the repository you created in Exercise 1.

Click Create New Folder and name the new folder DM_Land_Gas. Click
Open and then click Save to save the display model to the DM_Land_Gas
folder.

The display model files are saved to the DM_Land_Gas folder in your
repository.

Generate graphics.

Exercise 8: Create a Gas Display Model | 23



Exercise 9: Modify a Display Model

When you modify a layer definition, the changes apply to the Display Manager.
You must explicitly save the changes to your Display Model. When you
generate graphics without having saved your changes, you are prompted
whether you want to save the changes. In this exercise you will:

B Modify the stylization of the Gas layers.

B See the difference between the layer settings loaded in Display Manager,
and layer settings stored in a Display Model.

1 In the ribbon, click Home tab » Display panel » Style Layers. Select the
Gas Network Point, and define another symbol.

2 For the buildings, define another fill color, and for the parcel lines, define
another line color.

3 Generate graphics.

(V] Layer Display Settings Changed

L You have made changes to the layer display settings, do you
“== wish to:

< Keep
Generate graphic using the current layer settings (changes are not
saved in the display model)

= Discard

Discard the modified layers settings and generate the selected display
model

4 Click Keep. Generate Graphic uses the Display Manager settings instead
of the settings that are stored in the selected Display Model.

5 Continue to refine the layer settings.
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Click Home tab » Display panel » Save Display Model. Clear the Filter
checkboxes for all layers. Notice the Path. All layers are stored in the same
repository. Click OK.

Exit Topobase Client. Click No when prompted to save changes.

Exercise 10: Create a Multimap Display Model

A multimap display model consists of multiple drawings. In a Display Model,
you can specify the size, the position, and the feature layers of each drawing.
In this exercise you will:

1
2
3

Specify that for each Generate Graphic current drawings will remain open.
That means, if you use different display models, each display model will
be drawn in a separate drawing.

Create a multimap display model that generates two drawings, one with
the land data, one with the land and gas data.

Set the Application Option back so that for each Generate Graphic the
current drawing will be closed, and a new drawing will be opened.
Restart Topobase Client and open the tutorial workspace.
In the ribbon, click Settings tab » Setup panel » Application Options.

In the left pane of the Application Options window, click the Generate
Graphic node.

In the Display Model area, select Keep Current Drawings Open.
Click OK to close the Application Options dialog box.

Click Home tab » Display panel and select Land Tutorial from the display
model list.

# | Gas Tutorial E H - @

F

= |Gas Tutorial Generats

: Eng Tutorial Graphic ~
n

=+ Open Display Modal...
Opan Default Display Model
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11
12
13

14

15

16

17

Click Home tab » Display panel » Generate Graphic.

Click Home tab » Display panel and select Gas Tutorial from the display
model list.

Click Home tab » Display panel » Generate Graphic.

Click Settings tab » Window panel » Cascade. Each display model is
generated in a separate drawing. Keep the Land drawing and the Land
and Gas drawing and close any other drawings.

Click Settings tab » Window panel » Tile Horizontally.
Click Home tab » Display panel » Save Display Model As.

In the General area, under Name, enter MultiMap Tutorial.
In the Layer List, right-click any column title, and make sure that all
properties are shown.

The Window List displays the maps in the display model. Click each map
name in turn to view the layers in the map in the Layer List area.

In the Land Map, select LM_PARCEL_L as Autoload layer. Clear the
Confine To Viewport checkbox for LM_PARCEL_L. Clear all Filter
checkboxes. Clear all Ref. checkboxes.

In the Gas Map, select GA_LINE as Autoload layer. Clear the Confine To
Viewport checkbox for GA_LINE. Clear all Filter checkboxes. Clear all
Ref. checkboxes.

Click OK.
A dialog box displays the repository you created in Exercise 1.
Click Create New Folder and name the new folder DM_MultiMap. Click

Open and then click Save to save the display model to the DM_MultiMap
folder.

The display model files are saved to the DM_MultiMap folder in your
repository. Each map is stored in a separate *.tbdmmap file.

Notice that all layer files (*.layer) have been copied to the repository
folder.
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18
19

20
21

22
23

Address |5 C:\Topobase201 D\DisplayModelsh DM _Multimap

Folders X Marme
= ) Topobasez010 s GF'._LINE.Ia',-'er
= |[J) DisplayModels EA_POINT laver
) DM_Gas LM_BUILDING. layer
[C3) oM _Land LM_BUILDING_2.|ayer
) DM_Multimap LM_PARCEL_L.laver

LM_PARCEL_L_z.layer
Map1.tbdmmap
MapZ.tbdmmap
MultiMap Tutorial. tbdm

In the ribbon, click Settings tab » Setup panel » Application Options.

In the left pane of the Application Options window, click the Generate
Graphic node.

In the Display Model area, select Close Current Drawings. Click OK.

Exit and restart Topobase Client. Click No when prompted to save
changes. Reopen the workspace.

The MultiMap Tutorial display model is still selected, and the Autoload
layers are drawn.

Click Home tab » Display panel » Generate Graphic.

Zoom in or out in either of the drawings and generate graphics again.

Notice that the same viewport is shown in both drawings.

Exercise 11: Reuse and Share Layer Definitions

You can use the same layer definition in multiple display models. For example,
you store and maintain your base map layers in one central Land display
model. You reference these layers in other display models, such as the utility
display models. In this exercise you will modify the Gas display model that
you have created in exercise 8. You will replace the Parcel and the Building
layers by referenced layers.

1

Click Home tab » Display panel, and select the Gas Tutorial display
model. Click Generate Graphic.

In Display Manager, select Building, and Parcel. Right-click and click
Remove Layer.

Exercise 11: Reuse and Share Layer Definitions | 27



3 In Windows Explorer, navigate to the repository of the DM_Land display
model. Drag the layer files (LM_BUILDING.layer, LM_PARCEL_L.layer)
to the drawing.

NOTE If you drop the layers into Display Manager, make sure that the draw
order is By Group, otherwise you cannot drop the layers.

4 Click Home tab » Display panel » Save Display Model As.
l Gas Tutorial E]@

General

Name

Gas Tutorial Ref

Window list

Name Coordinate =. State Height | width | X Y
Gas Map Ref Maximized 105% 100% 0% -53%

Layer list

Name Feature Class | Autoload | Filter | Confine to Viewpart | Selectable | Source| Ref, Path
LM_PARCEL_L
LM_BUILDING
Gas Netwark Paint
Gas Network Line

O

000
OFEE
BEEE

O
O

5 In the General area, under Name, enter Gas Tutorial Ref.

6 In the Layer List, for LM_PARCEL_L and LM_BUILDING, keep the Ref.
checkboxes selected. Notice under Path, that the repository folder of the
referenced layer files is shown.

7 Click OK. When prompted, click Yes to continue.

When you modify a referenced layer, and save the DM, you are prompted
that you will overwrite the referenced layers. You can either overwrite,
or cancel, or clear the Ref. checkboxes.

8 Click Create New Folder and name the new folder DM_Gas_Referenced.
Click Open and then click Save to save the display model to the
DM_Gas_Referenced folder.

9 Exit Topobase Client; click No when prompted to save changes. Restart,
and reopen the workspace.
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11

12
13
14

15

16

In the Display Model list, the Gas Tutorial Ref is still selected, and the
Autoload layer, Gas Network Line, is drawn immediately.

Click Home tab » Display panel » Display Model list, and select Land
Tutorial. Generate graphics.

In Display Manager, modify the color of the buildings.
Click Home tab » Display panel » Save Display Model.

In the Land Tutorial dialog box, if selected, clear the Filter checkboxes
for all layers. Click OK.

Click Home tab » Display panel » Display Model list, and select Gas
Tutorial Referenced. Generate graphics. Notice that the changes you made
in the Land display model are applied.

Click Home tab » Display panel » Display Model Properties. Notice the
Path values.

Notice that the Filter checkboxes are selected after the Generate Graphics.
Click Cancel.

Exercise 12: Populate an existing drawing

Until now, each Generate Graphic opened a new drawing containing the data
specified in the display model. Sometimes it is useful to load the data into an
existing drawing. For example, into a drawing that contains project data from
an external supplier to be added to your database. In this exercise you will:

B Specify that Generate Graphics loads your data into an open drawing

containing some planned buildings (AutoCAD polylines).

B Create building features from the AutoCAD polylines.

In the ribbon, click Settings tab » Setup panel » Application Options.

In the left pane of the Application Options window, click the Generate
Graphic node.

In the Display Model area, select Reuse Active Drawing.
Click OK to close the Application Options dialog box.

Click Application menu » File » Open. Select the drawing (*.DWG) that
contains the planned buildings.
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6 Click Home tab » Display panel » Display Model list, and select Land
Tutorial. Generate graphics.
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“S DM_Tutorial. dwg

Navigate to the area of the planned buildings. Notice that the (*.dwg) file
is overlayed onto the display model map.

Select one of the planned buildings. Right-click and click Properties
(Polyline). Press <ESC> to undo the selection. Next, select one of the
building features. Right-click and click Properties (Map Feature). Press
<ESC> to undo the selection.

In Topobase Explorer, click the TB2010_LM_102 tab, expand the Building
topic, and select Building. Right-click, and click Create New Feature From
Geometry.

In the drawing, select the polygons. Press <Enter> to finish the selection.

The building features are saved in the database and displayed according
to the layer stylization.
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NOTE If your have already selected some entities in the drawing, the features are
created immediately. If no entities are selected, note the command line prompt.
If you have selected a building feature, you are notified that the feature is already
stored in the database, and you can decide how to proceed.
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