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Topobase Client User
Guide

Getting Started with Topobase Client

Overview of Topobase Client

Autodesk Topobase Client 2011 provides the tools to create, maintain, analyze,
and store geometry and related attribute data in a centralized Oracle database.
Different departments, such as design, mapping, customer service, and
operations, can work with a single, current source rather than multiple versions.
This saves time and reduce errors.

Topobase Client is built on AutoCAD Map 3D. Topobase Client combines the
drawing and editing tools of AutoCAD with the GIS functionality in AutoCAD
Map 3D and database functionality in Topobase. For each feature, you can
display a form to enter and revise attribute data directly in the database. In
addition, Topobase provides workflows (page 216) that improve the speed and
accuracy of data creation. Workflows use standardized steps and apply business
rules to maintain consistency. As you create geometry, Topobase prompts you
to populate necessary attribute data fields.

Display Models

Display models (page 211) use the AutoCAD Map 3D Display Manager (page 211)
to display the same data in different ways depending on department needs and
requirements. For example, a network engineer can view network data with
land base information in the background. Similarly, an operations manager can
view color-coded assets that reflect maintenance schedules.



Standalone Client

Use the Topobase Standalone Client to work directly with features in the
database without running AutoCAD Map 3D. Use the Standalone Client for
working with forms, reports, the Data Checker, export, the Survey module,
and other operations that do not require geometry. The Standalone Client is
available from the Start menu and as an icon on the Desktop.

Vertical Applications

This guide describes standard Topobase Client functionality. Topobase also
provides vertical applications specific to water, wastewater, gas, and electric
networks, and for land management. These vertical applications contain
common industry-specific database structures, including data schema, database
relationships, user-definable data constraints, and workflows (page 216) for the
management of these networks.

Error Messages

The Generated Error Messages dialog box displays a variety of error messages.
In general, they are self explanatory. For Oracle-related messages, use the
Oracle error code to locate more information in your Oracle help.

Working with Topobase Client

Start Topobase Client. Topobase Client starts within Autodesk Map 3D.

You must open a workspace (page 216) to work
with Topobase. When you launch Topobase Client
Open a workspace (page 8) you are prompted to select a workspace to open.
To work with multiple workspaces, close the
current workspace and open another one.

For most of the tasks you perform in Autodesk
Topobase Client, you begin by generating your
map with the geometry stored in the database.

Generate graphics to display data

in your map. (page 13)
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You can create features by digitizing or by
Create features. (page 29) importing geometry data from AutoCAD Map 3D
drawings.

Edit feature geometry with AutoCAD commands

Edit existing feature geometry.

(page 30) or with the Geometry Editor dialog box (page
163).

Work with feature class forms. Use feature class forms to edit, view, and analyze

(page 32) feature data stored in Topobase.

Generate standard reports or user-defined reports
Generate reports. (page 68) for each form. You can add, edit, or remove
reports assigned to a feature class form.

Use the Manage Connections control to view and
edit logical topologies. Topobase Client has a
Topology Checker to validate topologies (page
216).

Check topologies. (page 75)

Create plot layouts and save them as plot
templates. Define the map area and plot quickly
Plot. (page93) g and accurately. Topobase plots the current state
of the features on demand. You can print a plot
or save it to a file.

Overview of Topobase Client | 3



New Features in Topobase Client

Display Manager

Configurable hatch pattern orientation—Using Enhanced Stylization, you
can configure the hatch pattern orientation. You can either apply a predefined
orientation, specify an absolute value, or use a feature attribute that determines
the orientation. See Enhanced Polygon Stylization.

Display Model Management

Use the Display Model Manager to administer your display models. For
example, for workspaces with more than one document you can reuse and
merge existing display models, display model maps, or feature layers. See
Setting up Display Models.

Feature Search

Use Feature Search to zoom into the area of a specific feature. You access the
Feature Search from the Home tab » Quick Access panel. See Displaying
Specific Features (page 17).

Interlis Import

Interlis Import provides extended support for multiple geometries, and support
for invalid geometries. Features with invalid geometries can now be imported
into a special feature class, thus they can be visualized, and you can correct

invalid features. See Multiple geometry (AV93) support and Invalid geometries.

Plot

Rotate, scale, and move plot capture area—When creating a plot, you can
rotate, scale, and move the map placeholder in the drawing to specify the
exact location to capture in the context of your project data. See Creating a
Plot (page 94).

Plot templates with static text—When you edit a plot layout, use Decoration
Text to add static text information. For example, you might define placeholders
for approval remarks or create static strings such as “Revision Date:” or “Time:”
See Creating Plot Templates (page 111).

Survey

Configurable level of accuracy—You can configure the adjustment calculation
for points that do not require a high level of accuracy. For example, you can
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introduce building corners as single measurement points. Also, you can modify
the tolerance values for the reliability indicators (Chi-square test, local
reliability). See Field Code Settings for Calculation.

Control distance management—You can now import control distance files.
Control distance measurements are no longer part of the adjustment
calculation. However, the results are stored, and have an impact on the
coordinate reliability. See also Control Distance Measurements.

Reference point manager—You can now use reference points that are stored
in documents outside of your current workspace. See Managing additional
base points and detail points.

Wastewater Import

The handling of possible invalid inspection data has been improved, for
example, by enhancing data validation, and providing detailed logfiles, and
optionally enabling import of invalid data. See also Manage Inspection Data.

Enhanced support of encoding rules, and classification rules. See Inspection
File Formats.
Construction and Calculation Commands (COGO)

The “Select feature” prompts in all COGO commands now accept features from
any document in the workspace. Therefore, it is now possible to calculate the
intersection of data across documents, for example, a Wastewater section and
a Land Use street border. Note that features can only be stored in feature classes
of the document that was selected when the COGO command was started.
This is because COGO commands work as document plug ins.

See also:

B New Features in Topobase Administrator

Starting Topobase Client
You can start Topobase Client in the following ways:

B Double-click the Topobase Client desktop icon. When you install Topobase
Client, a shortcut icon is placed on your desktop unless you cleared that
option during installation.

B Open the Start menu. On the Windows Start menu, click Programs »
Autodesk » Autodesk Topobase 2011 » Autodesk Topobase Client 2011.

Starting Topobase Client | 5



Topobase System User

At the first login, you must connect to the Topobase Main or System User.
You specify these settings only once. See also the Topobase Administrator
Guide, section To connect to the Topobase main user.

You may be required to log in as a Topobase Main User (TBMAIN). This set of
login credentials is for non-administrative users only. Check with your
Topobase administrator for the TBMAIN login credentials.

License Server

If you start the application for the first time, you are prompted to specify the
licence server. See also Installing Topobase.

To connect the license server

1 In the FlexLm License Finder dialog box select Specify the License Server
System and click Next.

2 Enter the computer name of the license server.

To start Topobase Client

1 Click Start menu » Programs » Autodesk » Autodesk Topobase Client
2011 » Autodesk Topobase Client 2011.

2 Login with the following values:
User Name: Topobase

Password: Leave empty.

NOTE These are default values. Ask your Topobase administrator for your
personal Topobase username and password.

3 Click Connect.

4 In the Open Workspace dialog box select a workspace and click Open.

If no workspace exists, click Cancel. Ask your Topobase administrator to
create a new workspace.

6 | Chapter 1 Topobase Client User Guide



To start the Standalone Topobase Client
The Topobase Standalone Client enables you to work directly with features
in the database without running AutoCAD Map 3D.

1 On the Windows Start menu, click Programs » Autodesk » Autodesk
Topobase Client 2011 » (Standalone).

2 Login with the following values:
User Name: Topobase

Password: Leave empty.

NOTE These are default values. Ask your Topobase administrator for your
personal Topobase username and password.

3 Click Connect.

4 In the Open Workspace dialog box select a workspace and click Open.

If no workspace exists, click Cancel. Ask your Topobase administrator to
create a new workspace.

Opening and Closing Topobase Workspaces

The Topobase workspace (page 216) is your Topobase Client work area. Your
administrator creates and manages Topobase workspaces. A workspace contains
one or more documents (page 211). Documents are the Oracle database schemas
that contain your data.

You must open a workspace to work with Topobase. When you launch
Topobase Client you are prompted to select a workspace to open. To work
with multiple workspaces, close the current workspace and open another one.

See also:

B Topobase Application Menu (page 157)

To close a workspace

m Click ' » File » Close Workspace.
Command entry: TBWSCLOSE

Opening and Closing Topobase Workspaces | 7



To open a workspace

1 Click 'v » File » Open Workspace.

2 In the Open Workspace dialog box, select the workspace (page 216) and
click Open.

Topobase loads the workspace and opens the associated documents (page
2171).

Command entry: TBWSOPEN

Using the Topobase Ribbon

The Topobase Ribbon (page 153) at the top of the application window provides
access to commands. It eliminates the need for multiple toolbars, reducing
clutter in the application and maximizing the area available for work.

Instructions in this guide specify a tab, panel, and command name. In some
cases, you might not see the command you are looking for until you open a
dropdown list.

Please refer to the AutoCAD and AutoCAD Map 3D documentation for more
information on standard AutoCAD and AutoCAD Map 3D commands.

See Also

Overview of the Ribbon
Home Tab (page 153)
Tools Tab (page 155)
Settings Tab (page 155)
Output Tab (page 156)

Using the Topobase Explorer Pane

The Topobase Explorer pane displays the documents (page 211) associated with
the current workspace (page 216). The feature classes in each document are
grouped into categories called topics (page 215). Right-click a feature class to
see commands for creating, editing, and viewing information about it.

The Topobase Explorer pane toolbar controls the display within the Explorer
pane. These controls are described in the following sections.
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You can also display the explorer views from the ribbon » Settings
tab » Palettes panel.

Electric Explorer

In Topobase Electric you use the Electric explorer to process the electric
features.

Topology Explorer

You use the Topology explorer to manage area topologies. See Maintaining
Topologies (page 73). The Topology explorer is displayed additionally below
the currently displayed explorer.

Job Explorer

In job enabled documents, you use the Job explorer. See Managing Jobs (page
78). The Job explorer is displayed additionally below the currently displayed
explorer.

See also:

B Feature Explorer (page 162)

Document Explorer

The Topobase Explorer pane has multiple explorer views: Document Explorer
(page 161), Workflow Explorer (page 10), Plot Explorer, and Electric Explorer.
Use the Document Explorer to view and process feature classes and topics
(page 215) from a data model point of view.

The Document Explorer is shown by default. It shows the data model structure
with its feature classes, and other objects (such as topologies) that can be
processed in the current document (page 211).

You can hide or show feature classes in the Document Explorer. For example,
you can show feature classes that were recently created and are not yet visible.

Your Topobase Administrator can customize the content of the Document
and Workflow Explorers, and provide different Explorer groups.

NOTE In Edit mode, you can edit only the objects defined for the Explorer group.
If you miss any objects, ask your Topobase administrator to define an appropriate
Explorer group.

Using the Topobase Explorer Pane | 9



See also:

B Document Explorer

To toggle between the explorer views

1 In the Topobase Task Pane, click Workflow Explorer (page 10). 5

2 In the Topobase Task Pane, click Document Explorer (page 161) to show
the Document Explorer again. (Y

To show or hide feature classes in Document Explorer
1 Click Document Explorer (page 161).

2 From the list box above the Explorer tree, select an Explorer profile, for
example, Default.

3 Click three-dot button beside the list box. E]

The tree view changes to Edit mode.
4 Select the feature classes and objects to show.

5 Click the two-dot button again to change back to the default mode.

To work with features in the Document Explorer
1 Click Document Explorer (page 161).
2 Right-click a feature class or object (such as a topology (page 216)).

3 Select a command from the shortcut menu.

Workflow Explorer

The Topobase Explorer pane has multiple explorer views. Use the Workflow
Explorer to view and process workflows (page 216). Workflows are mainly used
in the utility applications such as Water, Wastewater, Gas, and Electric.

See also:
B Autodesk Topobase Modules User Guide

B Autodesk Topobase Electric User Guide
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B Workflow Definition

To toggle between the Document Explorer and the Workflow Explorer

1 In the Topobase task pane, click Document Explorer (page 161). G
2 In the Topobase Task Pane, click Workflow Explorer to show the Workflow

Explorer again. &8

The tree view shows the workflows (page 216) available for the current
document (page 211).

Plot Explorer

If your Topobase administrator has enabled the Plot extension, you can create
plot templates and plot the active drawing.

See also:

B Overview of Plotting (page 93)

Adapting a Viewport for Feature Highlighting

Configure the Map viewport (page 216) size for feature highlighting in the
Application Options or Document Options dialog box.

See also:
B Setting Map Options

B Setting document Map options

To adapt the viewport size for feature highlight

1 In Topobase Client, click Settings tab » Setup panel » Application
Options or Document Options.

2 In the left pane, click Map Options.

Adapting a Viewport for Feature Highlighting | 11



Working with Multiple Coordinate Systems

In Topobase, a workspace (page 216) can contain several documents (page 211),
and each one can have a different coordinate system (SRID). In Topobase
Client, the SRID is used for on-the-fly coordinate transformation to represent
the geometry data in Map in a single global coordinate system. Any data you
edited is converted back to its original coordinate system when you save it
back to its source.

Areas affected by coordinate transformation
B Generating graphics.

B [Editing data in the drawing, for example, digitizing features, modifying
features, and creating features from geometry.

B Viewport definition in the drawing. For example, if you specify a viewport
(page 216) by dragging a rectangle in the drawing, a transformation is
performed. However if you define a viewport by typing the coordinate
values, you must use the document coordinates.

NOTE All calculations are made in the document coordinate system. Coordinate
values shown in Topobase dialog boxes and feature class forms are the internal
database values.

Displaying a Map with Coordinate Transformation

When you generate your map, Topobase checks the configuration of the
coordinate systems and performs transformations if necessary.

Sample cases

B The Map drawing has an assigned global coordinate system (Setup menu
» Assign Global Coordinate System). The coordinates of the Topobase
documents are transformed into this system for representation in the map.

B The Map drawing has no global coordinate system assigned. The document
has an SRID assigned. Topobase sets the global coordinate system to the
document SRID.

B The Map drawing has no global coordinate system assigned. At least one
of the documents in the current workspace (page 216) has an SRID assigned.
No transformation can be performed.
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B The Map drawing has a global coordinate system assigned. The document
(or one of the documents in the workspace) has no SRID. No transformation
can be performed. A message informs you about this: A coordinate system
has been globally assigned, but not for the following document:.

NOTE If the Map drawing has a global coordinate system assigned, all documents
in the current workspace must have an SRID. In Topobase Administrator, you can
update the SRID of existing documents.

All feature classes of a document (page 211) have the same coordinate system.
The layer coordinate systems must not be modified in the FDO data connection
properties. Any modifications you made will be reset to their default values
before graphic generation.

Displaying Features In Your Map

For most of the tasks you perform in Autodesk Topobase Client, you begin by
generating your map with the geometry stored in the database. When you

generate your map, Topobase applies a display model (page 211) to the geometry.
See also the Topobase Administrators Guide, section Setting up Display Models.

About Display Models

Topobase Client uses the Display Manager (page 211) in AutoCAD Map 3D to
define styles for layers. In addition, Topobase Client saves layer stylizations
as display model (page 211) files (.thdm). You can apply different display models
as needed for your work. Topobase provides a default display model and
autoloaded layers to help orient users to the map before generating.

The display model (.thdm) determines how the geometry appears in the map.
If your Topobase administrator created display models, the current one is
used. If your administrator did not create display models, Topobase applies
default styles.

You can select a display model or use the default display model. Customized
display models control what geometry is drawn and how it is displayed. The
default display model draws all the geometry in the document (page 211) and
applies a default stylization to each layer. When you generate your map using
the default display model, a default style applies to each feature class. You
cannot modify the default display model.

NOTE Display models with many layers take some time to display.
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About Viewports

When you switch to another display model, you can easily view the area of
interest from the previous display model. If you change the viewport (page
216), the new viewport is applied the next time you generate graphics. For
example, you might have two display models, DM1 and DM2. You can generate
graphics with DM1 and zoom into an area of interest. If you then select DM2
and generate graphics again, the same area of interest is generated using DM2.
To view a different area of interest, define a new one using a viewport or
Feature Search (page 213).

About Drawing Units

When your Topobase administrator creates a document (page 211) in Topobase
Administrator, he specifies all the unit settings to be used in the document.
These are stored in the database. In your drawing, you can set units for the
display of your geometry. These units affect only the display within the
drawing, and are not stored in the database.

NOTE In Topobase the base angle is always set to North, overriding any setting
you make in AutoCAD Map 3D.

To display your map
1 Start Topobase Client and open a workspace (page 8).
2 Click Home tab » Display panel.

3 From the Display Model list, select the display model to use for the current
workspace (page 216).

4 Click Open Display Model to locate a display model (page 211) file (.tbdm).
5 Click Open Default Display Model to apply the default stylization.

&

Generate
6 Click Generate Graphic. Greehic i
Topobase generates the map with the geometry and styles specified by
the display model. The Display Manager (page 211) lists each layer in the
display model with a symbol representing the style. If the map display
is no longer up-to-date, for example, if you add or edit layers, the Generate
Graphic button glows. Click Generate Graphic again.
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To display your map and zoom to an area of interest

1 Open a workspace (page 8).

If you selected a display model the last time you opened the workspace
(page 216), the autolayers are drawn immediately.

2 Using the autolayers for reference, zoom to an area of interest.

3 Generate Graphics.

The display is updated to show all the layers in the area of interest. This
process is faster than generating graphics first and then zooming to the
area of interest.

Displaying Specific Areas

If you use Generate Graphic to draw your geometry, Topobase draws all the
features represented in the display model (page 211). To generate your map
more selectively, use Advanced Generate Graphic to define a viewport (page
216). You can save and reuse viewports.

There are several ways to define the viewport:

B Define the center (Easting and Northing), height and width of the viewport
manually.

B Define the viewport using geometry or a selection window.

B Use Feature Search (page 213) to specify the center of the viewport.

See also:
B Displaying Specific Features (page 16)

B Displaying Features Using an Oracle Spatial Filter (page 18)
To define a viewport

“H

Advanced
Generate ¥

1 Click Home tab » Display panel » Advanced Generate Graphic. Grphic
2 In the Advanced Graphic Generation dialog box, in the Geographical

Selection area, under Viewport, click 4 . Then click Create New.
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3 In the Create Viewport dialog box, enter a name for the viewport. Then
click OK.

Topobase marks the viewport as private. To share your viewport with
other users, click V4 again. Then click Make Public.

4 Define the center and size of the viewport using any of the following
methods:

B In the Coordinates area, specify the viewport center by entering values
for Easting and Northing. Specify the viewport size by entering values
for Width and Height.

B In the Define Graphically area, click Point or Geometry to define the
center of the viewport by selecting a point or feature in the map. Then
specify the viewport size by entering values for Width and Height.

B In the Define Graphically area, click Window. Use a selection window
to define the viewport in the map.

B In the Define Graphically area, click Polygon. Define the viewport by
drawing a polygon (page 214).

The viewport is automatically saved in the database.

Displaying Specific Features

Use to generate your map around a specific feature, for example a building,
parcel, street, or any other type of feature with geometry.

Feature Search options are defined by your Topobase Administrator.
See also:

B Displaying Specific Areas (page 15)

B Displaying Features Using an Oracle Spatial Filter (page 18)

B Feature Search Reference
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To generate specific features in your map

@

Feaburs

1 Click Home tab » Quick Access panel » Feature Search. Search

The Feature Search pane is displayed next to the Topobase task pane.

2 In the Feature Search pane, select the search to use, for example, “Street
Search.”

Depending on the search you selected, additional options may display.
You can specify a particular feature, narrow the search using attributes,
or select a custom search defined by your administrator.

3 Select options from the lists to specify the position.

When you are finished, Generate Graphics starts automatically.

4 To close the Feature Search pane, click Home tab » Quick Access
panel » Feature Search again.

NOTE The Feature Search is also imbedded in the Advanced Generate Graphics
dialog box.

Modifying Display Models

If you Generate Graphic before saving modifications of your layer settings,
you are prompted how to proceed. In the Layer Display Settings Changed
dialog box, select one of the following.

B Keep—To Generate Graphic using the modified layer settings. The changes
are not saved in the display model.

B Discard—To discard the modifications, and to Generate Graphic using the
selected display model.

To save the changes in the display model, click Home tab » Display panel »

Save Display Model.

See also Display Model Manager.
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Displaying Features Using an Oracle Spatial Filter

When you generate your map, you can apply Oracle spatial filtering to the
viewport (page 216).

See also:
B Displaying Specific Areas (page 15)

B Displaying Specific Features (page 16)
To define an Oracle spatial filter

=

v

Advanced
Generatz ™

1 Click Home tab » Display panel » Advanced Generate Graphics. Grrhic
2 Inthe Advanced Graphic Generation dialog box, click Advanced Settings.

3 In the Advanced Settings dialog box, click one of the following options:
B Default For Each Feature Class—Use the default settings specified
when the feature class was created.
For more information about Spatial Relationship Settings, see the
Topobase Administrator Guide, section Data Model: Spatial
Relationship Settings.

B Global For all Feature Classes—Specifies a global spatial mask to apply
when you generate your map.

4 If you clicked Global For all Feature Classes, select a Global Spatial Mask
setting.

For more information, see the Oracle Spatial documentation.

5 Click Close.

Saving Drawing Objects

The Generate Graphic command creates FDO features. When you save the
graphic as *.DWG using the File menu » Save command, the file contains
only the FDO connection information but no drawing objects. For example,
when you open this *. DWG file on another computer, you have to reconnect
to the database.
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You can save the graphic as a *. DWG containing drawing objects. In Display
Manager, click the Tools icon and select Save Current Map To DWG. Using
this command, the FDO features are exported as drawing objects. This
command does not export 3D data, and it does not export feature attribute
data.

See also:

B Exporting to DWG (page 19)

Exporting to DWG

To export your FDO drawing into a *. DWG file that is compatible with
AutoCAD drawings, and that contains the feature attribute data as Xdata, you
use the Export To DWG command. This command exports drawing objects,
including 3D data. This command requires that the FDO styles have
corresponding AutoCAD styles.

For each element in the Display Manager (page 211), the export creates a layer
in the export (*.DWG) file.

Use the Export To DWG command to:
Create a (*.DWG) file to exchange with AutoCAD users.
Export your FDO features as drawing objects (AcDDb entities).

|
|
B Export your feature attribute data as Xdata.
B Export 3D features.

|

Create a (*.dwg) file that can be exported into DXF.

Styles

Export To DWG exports only the stylization that is available in AutoCAD
drawings. For example, if your display model (page 211) uses lines of a specific
line type (for example, dash-dot) that line type must also be available in the
Acad.lin file.

Each FDO style must match a DWG style with the same name. For example,
the FDO point symbol BORDER must match the block definition BORDER.
The exported (*.dwg) file includes all style definitions and all default styles.
For unmatched FDO styles, the default style is applied.
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Use Enhanced Stylization to style a line with AutoCAD line styles. When you
use Enhanced Stylization, the export skips Feature Text Label and Feature
Symbol Label settings.

See also:

B Saving Drawing Objects (page 18)

To export data to DWG

1
2
3

Start Topobase Client and open a workspace (page 8).
Generate Graphic.

Click Output tab » Send panel » Export To DWG.
On the command line: TBEXPORTDWG.

To use styles that can be mapped to an AutoCAD style

1

2
3
4
5

(o)}

In Display Manager (page 211), click Data » Connect To Data.
Configure the data connection and select a line feature class to add.
Click Add To Map Using Enhanced Styles instead of Add To Map.
Select the layer and click Style.

In the Symbolization Style area for the selected scale range, click the box
under Style.

In the Style And Label Editor dialog box, next to Line Pattern, click Load.

In the Select A Symbol In Repository dialog box, click Import, and select
a (*.lin) file, such as acad.lin.

Select a line pattern.

Click OK and then click Apply.
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Working with Features

Overview of Features

You can edit, modify, and update features. You can create features by importing
geometry data from an AutoCAD Map 3D drawing. You can create labels (page
213) from a label definition created by your system administrator.

The Topobase Feature Explorer (page 162) provides a tree view of features that
come from operations such as feature selection, network tracing, analysis
workflows (page 216), topology (page 216) validation, geometry validation, or
managing logical connections.

Use the Feature Explorer to verify the selected features and to modify the
selection.

Selecting Features

Selecting Spatially

You can perform a spatial selection in the database for each feature class.
Use the spatial export tool to print the spatial selection in the drawing. See
Using Spatial Export (page 70)
To perform a spatial selection

1 Start Topobase Client and open a workspace (page 8).

2 Inthe Document Explorer (page 161), right-click a feature class and click
Spatial Selection.

3 Under Selection Type, select a rectangle, polygon, or point and click Select
Rectangle in Map.
4 Select the area of interest in the map.

If you used a polygon (page 214) for Selection Type, enter ¢ and press Enter
to close the polygon.

The Spatial Selection dialog box is redisplayed. The geometry you specified
is described under Geometry.
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5 Click Show Feature Data to view the results of your selection in the feature
class form.

Selecting With Feature Class Forms

Use feature class forms to select features of a single class or of multiple classes.

To select features of a single feature class
1 In the Document Explorer (page 161), right-click a feature class.
2 Click Show Form.

3 In the feature class form, click Select Graphic Entities Into The Dialog.
The feature class form is dismissed.

4 Select features in the drawing using any selection method (page 21).

The feature class form is redisplayed, showing records for the selected
features of the current feature class.

To select features of multiple feature classes

@

1 Click Home tab » Quick Access panel » Attributes. Attributes

2 Select features in the drawing using any selection method (page 21).

3 Press Enter when you have finished selecting features.

A feature class form is displayed for each class in the selection.

To query related records

B Click the Reference button

Filtering Data

In feature class forms, you can use several techniques to filter data.
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To filter data using the filter commands of the Feature Class Form Input Fields
Shortcut Menus (page 169)

B [n Edit mode, use the Filter icon on the Feature Class Form Toolbar (page
164) to define a filter. Use the Remove Filter icon to show all records again.

B [n Filter mode, enter the values to filter in the respective input fields.
In Filter mode, you can select Using Additive and Or Filters (page 24)
options from the list box at the right bottom status bar of the form.

See also Filter Expressions (page 23).

To define, save and reuse filter definitions

B Right-click the feature class form and click Filter » Execute Filter
respectively Filter » .

To tag certain records with bookmarks and filter the bookmarked records

1 In table view, on the Feature Class Form Toolbar (page 164), click Tools.

td

2 Click Filter » Filter Bookmarked.

To select graphic entities into the dialog

B Select elements in the drawing and click &= on the main toolbar.

B Open a feature class form and click &2 on the Feature Class Form Toolbar
(page 164) to select the respective features in the drawing.

Filter Expressions

Oracle is case sensitive when searching text.

NOTE You can filter columns that have the type “Date” by typing only the year.

Expression Description
<, <= Less than (or equal to)
>; >= Greater than (or equal to)
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Expression Description

<> Unequal

* A wildcard character. Oracle uses a differ-
ent wildcard character (%) in tables.

IS NULL Searches for blank fields (database NULL)

IS NOT NULL Searches for non-blank fields

>17.3.99 <19.3.99

Searches by Date. All data created between
17.03. and 19.03 is found.

Filtering by multiple values (numeric
fields only)

Examples Available operators for linking:
AND; OR; (unspecified = AND)
;=0R
[=1I=0R
& = && =AND

>50 <20 Single range specification

>5 AND <10 Greater than 5 and less than 10

5;10;15 5o0r10or15

50R100R 15

<50R15 Less than 5 or 15

Using Additive and Or Filters

In Filter mode, you can use the following options.

Filter options

Description

Simple Filter

Default

Additive Filter

Connects the previous and new filters with
an SQL AND condition.
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Filter options Description

Or Filter Like additive filter, but uses the SQL OR
condition.

To use filter options

B Select Additive and Or filter options from the list box on the right bottom
status bar of the form.

Using SQL Filters

Use SQL statements to select records. The SQL Filter dialog box shows the
select statement used by the active filter, such as

B rownum<101 for a start filter or

B (AREA > 300) AND (ID_QUALITY = 2).

The dialog box also displays OrderBy clauses defined in the form designer
options. You can set these options, but you must separate the Order and the
By expression with exactly one blank space.

You can use input parameters in SQL filter select statements, such as a length,
which the user is prompted to enter. An input box will appear. If the parameter
is a numeric value, you must use the # character. If it is a text value, use the
$ character.

Example: {#length} {$Name}

select * from WW_SECTION where
pipe length > {#Length}

NOTE For better performance this filter is not saved, but you can save and reuse
filter definitions (page 27).

See also:

B Saving and Reusing Filters (page 27)

To filter with SQL statements

1 Display the feature class form.
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On the Feature Class Form Toolbar (page 164), click Tools. 4
Click Filter » SQL Filter.

In the SQL Filter dialog box, define the SQL filter statement.

“n A~ W N

Click OK to execute the filter.

Using Excel Filters

You can filter by values that are collected in an Excel spreadsheet. Use this
method to define filters that are more complex than simple AND - OR
conditions in individual fields. Using Excel, you can also include fixed lists
in the filter.

See also:

B Saving and Reusing Filters (page 27)

To use Excel to include fixed lists in the filter

1 Create an Excel spreadsheet with the required values.

For example, create a spreadsheet with the column NAME that contains
selected manhole names.

2 Select the column in Excel.

NOTE In the Excel table, the first selected column must be the column
heading.

3 In Topobase, in the feature class form, right-click and click Filter » Excel.

To update data using Microsoft Excel
1 Open a workspace. (page 8)
2 Open the Excel spreadsheet containing the data.

3 In Excel, mark the key column headings that you want to use in the
WHERE clause with the pound sign (#).

4 In Topobase, in the Document Explorer (page 161), select the feature class
to update.
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5 Right-click the feature class and click Show Form.

6 On the Feature Class Form Toolbar (page 164), click Tools. [t4]

7 Click Import » Excel Update (Direct).

Saving and Reusing Filters

Use Filter Manager (page 171) to store and reuse filters.

See also:
B Using SQL Filters (page 25)

B Using Excel Filters (page 26)

To start the Filter Manager

1 Show the feature class form.

2 On the Feature Class Form Toolbar (page 164), click Tools. 4 Then click
Filter » Filter Manager (page 171).

To re-use filter conditions
1 Execute any filter.

2 Start the Filter Manager (page 171).

3 Add a filter.

The filter (SQL statement) you executed is shown as the default. You can
add or modify it.

To execute a stored filter

B Right-click and click Filter » Execute.

Filtering with References

If a form A is in Filter mode and you click a Reference button (page 170), the
related form opens in Filter mode, too.
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The filter is used together with the filter set in form A to filter the data. To see
the filter set by the referenced form, view the tool tip of the Reference button.

To filter with references

1

2

In the SQL Filter dialog box (page 25), enter a filter and click OK.
The filter is transferred to the current form.

Run the filter of the current form.

Using Projections as Filters

You can use projections to show related records. Projections can be used as
an additional filter.

For example, to see all the labels (page 213) that belong to the currently selected
features, use the Projection command. If you use the Reference button (page
170), you see only the labels of the current feature.

To define a named projection

1

2

Open the feature class form. (page 33)

On the Feature Class Form Toolbar (page 164), click Tools. {4 Then click
Projection (page 171).

Select the Named Projections tab.
Click Add to open the New Named Projections dialog box (page 171).

Enter a title.

Under Project to Table, click I/ to select one of the existing relations
(TB_RELATIONS)

These relations are the same as the items in the All Projections list.

To filter data with projections

1

2

Open the feature class form. (page 33)

On the Feature Class Form Toolbar (page 164), click Tools. [t4] Then click
Projection.

Click the All Projections tab (page 171) to see a list of all existing feature
class relations.
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4 Select a relation and click OK.

To add a named projection
1 Click the Named Projections tab (page 171).
2 Click Add.

3 Inthe New Named Projection dialog box (page 171) define the projection.

Creating Features

You can create features by digitizing or by importing geometry data from
AutoCAD Map 3D drawings.

If you digitize a utility point or line, you are prompted to select the feature
class to which it belongs.

NOTE You can insert only features of a geometry type that matches the feature
class type.

If you start the Digitize command for a feature class, you can use any AutoCAD
Map 3D tool to create the features. If you select Digitize With Form, Topobase
opens the feature class forms for the new features and you can edit attribute
data.

To digitize features

1 Inthe Document Explorer (page 161), right-click a feature class and click
Digitize or Digitize With Form.

2 In the drawing, digitize the features.
Watch the AutoCAD command line.

3 Press Enter when you finish digitizing the features.

If you chose Digitize With Form, you see the feature class form with the
new features in the filter.

To create features from geometry

1 Inthe Document Explorer (page 161), right-click a feature class and click
Create Feature From Geometry.
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2 On the command line, you are prompted to select the entities to add to
the database.

3 Press Enter.

4 If you selected features that are already saved in the database, choose
from the following options:

B Delete Existing Features: Replace an existing feature with the new
one.

B Leave Existing Features Intact: Add a new feature and retain the
existing one.

Editing Features

Edit feature geometry with AutoCAD commands (page 30) or with the
Geometry Editor dialog box (page 163).

Using AutoCAD Commands

To modify a Topobase feature in the drawing using AutoCAD commands, you
must first enable Edit Geometries mode. In Edit Geometries mode, the
modifications are automatically stored in the database. No further command
is necessary.

When Edit Geometries mode is enabled, grips appear on selected features to
indicate that you can use AutoCAD commands. The color of the crosshairs
changes to yellow. You can change this color using the AutoCAD OPTIONS
command. Click the Colors button on the Display tab.

See also:
B Using the Geometry Editor (page 32)

B Using Feature Class Forms (page 32)

To enable Edit Geometries mode

1 Open a workspace (page 8).

30 | Chapter 1 Topobase Client User Guide



U

.
Generate

2 Click Home tab » Display panel » Generate Graphic. &2

.

Edit
Geometries

3 Click Home tab » Quick Access panel » Edit Geometries.

To update feature geometry
1 Enable Edit Geometries mode.

2 Select the features to edit.
You can select multiple features.

3 Update the features using AutoCAD tools.

To delete features in Edit Geometries mode
1 Enable Edit Geometries mode.

2 Select the features in the drawing and start a Delete command.
The Delete Feature Confirmation dialog box displays the selected features.

3 Click OK to delete the features from the database.

To delete a feature without being in Edit Geometries mode
1 Select the feature in the drawing.
2 Click Home tab » Quick Access panel Delete Feature. Cx
The Delete Feature Confirmation dialog box displays the selected features.

3 Click OK to delete the features from the database.

NOTE You cannot undo the deletion of features.
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Using the Geometry Editor

In feature class forms, the coordinates (geometry) appear in special text boxes
or list boxes. Use the Topobase Form Designer to change the representation
of the data, for example, to change the order of the vertices of a line.

You cannot edit coordinates directly (even in Edit mode). Use the Geometry
Editor instead.

See also:
B Using AutoCAD Commands (page 30)

B Using Feature Class Forms (page 32)

To edit coordinates with the Geometry Editor

1 Open the feature class form. (page 33)

2 On the Feature Class Form Toolbar (page 164) click Edit Record. 7

3 Click Edit (next to the coordinates text box).

4 In the Geometry Editor dialog box (page 163) dialog box, edit and view
the geometry information.

Using Feature Class Forms

Use feature class forms to edit, view, and analyze feature data stored in
Topobase. The Document Explorer (page 161) shows the data model feature
classes and related feature class information you can edit with feature class
forms.

Feature Form Toolbar

The Feature Class Form Toolbar (page 164) appears at the bottom of each form.
Move your cursor over an icon to see its tooltip. Some icons are visible only
under certain conditions.

A symbol at the far left of the title bar indicates the type of feature class and
the name of the feature class.
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Master-Detail

A master-detail form (page 214) consists of a master pane and a detail pane.
Using master-detail, you can set the filter on every input field of the master
and detail pane. After you have set the filter, you can execute the filter by

clicking Filter. *

Without master-detail, you can query related records. This opens all related
records that belong to the current record, for example, all symbols belonging
to a boundary point. You can display these records in a separate pane.

By default, the master-detail panes are not displayed.

Auto Highlight

Use the Auto Highlight option to highlight a feature when you move a record.
There is no need to click Highlight. You can activate Auto Highlight for each
form.

Auto Highlight is active until you switch it off or until you close the
application. This option is only available for feature classes with geometry
(GEOM column).

See also:

B Feature Class Form Toolbar (page 164)

B Feature Class Form Shortcut Menus (page 167)

B Feature Class Form Input Fields Shortcut Menus (page 169)
|

Feature Class Form Control Elements (page 170)

To access feature data, use any of the following methods:

@

B Click Home tab » Quick Access panel » Attributes. “&%s Select a feature
in the map.

B [n the Document Explorer (page 161), right-click a feature class and click
Show Form.

B On the Feature Class Form Toolbar (page 164), click the Select Graphic
Entities icon.
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To turn Auto Highlight on

B Right-click the background of the form and click Options » Auto Highlight.
Click Auto Highlight again to switch it off.

Switching Modes

You can view data in feature class forms in Table or in Form mode. Use Filter
mode to search for records containing specific values. Use Edit mode to enter
or change values.

Filter and Edit Modes

When you enter a value in a form box, the color of the input fields and the
icons change to indicate the mode. The Feature Class Form Shortcut Menus
(page 167) also change depending on the current mode. If you change to Edit
mode, all filters are deactivated.

Modes Description

Edit Use this mode to acquire and edit data.
You can enter or change values.
Input fields are highlighted with pale yel-
low. Mandatory input fields display a red
background.

Filter Use this mode to view and analyze data.
Use the input fields as the filter specifica-
tion. Type a value to search for and press
Filter.

All input fields are highlighted with green.

Start Modes

The start modes control the number of records that are loaded when you open

a form.

Start modes Description

View Open the form with a certain number of
records loaded, usually 100.

View (empty) Open the form with no records loaded.
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Start modes Description

Filter Open the form in Filter mode, so you can
filter for the desired records immediately.

To switch between the view modes

1 If the Table or Form tabs are not visible at the top of the form, right-click
and click View menu » Tabs.

2 Click a tab.

To switch between Filter and Edit mode

m Right-click the background of the form and click Options » Default mode.

To change the Start mode

B Right-click the background of the form and click Options » Start Mode.

Adding Records

You can add records in the following ways:

B Create a feature that has no geometry yet. (page 35)

B Digitize a feature with geometry. (page 36)

B Digitize the geometry of an existing feature. (page 36)

B Connect an existing feature in the drawing to the current feature record.
(page 36)

To create a feature that has no geometry yet

1 In the feature class form, click New Record ™ .

The feature class form switches to Edit mode and you can capture data.
If a Reference Record is active, it will be applied.

2 Click Insert to store the record in the database.
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To digitize a feature with geometry, do one of the following

B In the feature class form, click Digitize New Feature And Select It Into the

Form B
When you start the command, the Graphic window becomes active and
you can use all available graphic tools to create the feature.

B From the Document Explorer (page 161) shortcut menu » Digitize or Digitize
With Form.
To digitize the geometry of an existing record

B In the feature class form, click Digitize New Geometry For the Selected

Feature .
You can create geometry data subsequently, if the attribute data was
captured before.
To connect an existing feature in the drawing to the current feature
B [n the feature class form, click Connect An Existing Geometry With the
a0

Selected Feature *

Editing Attribute Information

To modify attribute data using feature class forms, the forms must be in Edit
Mode (page 34).

If the form is in Filter mode, it switches to Edit mode as soon as you enter a
character into a text box. The Edit toolbar replaces the Feature Class Form
Toolbar (page 164) and the text box background color changes.

See also:

B Switching Modes (page 34)

To modify attribute data

1 Select a feature in the map.

®

2 Click Home tab » Quick Access panel » Attributes. #tributes
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3 Locate the field to modify and enter the change.
Edit mode is enabled.

4 Click Update (FS).

Refreshing Records

Refresh records to update and redisplay the current records with the same
filter. The most recently active record is redisplayed.

The Refresh command unloads the buffer and reloads the current record using
the current filter. In most cases, the buffer improves performance. This is
controlled by the UseBuffer property.

Use the Refresh command wherever you use triggers in fields, because changes
initiated by triggers are not displayed by a simple update.

For example, in a Parcel form, the parcel identification is created using a trigger
from the parcel name or number. If the parcel changes, an update adds the
new information to the Topobase database. However, the modified parcel
identification does not appear. To display it, perform a refresh.

To refresh records, do one of the following

m Click @

B DPress FS.

Using Reference Records

A reference record is like a template for new records. Reference records comprise
a set of defined attributes and their values (reference attributes), which are
entered when a new record is inserted.

When you edit, capture, and modify data in Edit mode forms, you can use
reference records to apply the same set of attributes and values to multiple
records, making data acquisition faster and more accurate. Reference records
are also applied when you digitize features or when you create features using
workflows (page 216).

If selected the reference record is shown in the status bar on the right. *No
Reference indicates that no reference record will be applied. If you create a
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new record, the values are shown in the respective input fields. You can change
the values before updating.

See also:

B Working with Templates (page 44)

To define reference records

1

2

Open the feature class form. (page 33)
On the Feature Class Form Toolbar (page 164), click Tools. 4 Then click
Reference Records » Add.

In the New Reference Record dialog box enter a name, such as Healthy
Trees.

Select Public if the reference record is available to all users.
Select Use Last Value as Reference to use previous values.

Click OK.

The input fields are highlighted in light blue, indicating that the form is
in Reference Record mode.

Enter the reference values, such as Health = excellent.

Click Save to activate and save the reference record.

The new reference record is activated. To check whether a reference record
is active, on the Feature Class Form Toolbar (page 164) click Edit Record.
The current reference is indicated in the status bar.

To select a predefined reference record

1
2
3

In the feature class form, click the drop down arrow.
Right-click the green background to see the shortcut menu.

Use one of the two options in the New Reference Record dialog box:

B DPublic: If this option is selected, reference records are available to all
users that are logged in. For example, administrators might make
certain reference records compulsory for all users. Non-public reference
records are only available to the current user.
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B Use Last Value as Reference: If this option is selected, reference data
is dynamic and will be set to the values the user has entered before
in the reference attributes. The recently entered values are displayed.
If Use Last Value as Reference is not selected, the next new record
displays the defined reference values.

Globally Updating Records

Use the Global Update command to modify all records in the current filter
with the same values.

Global Update supports mandatory fields (IsMandatory columns). Before the
update occurs, Global Update checks for empty mandatory column values. If
there are any, you must enter the mandatory data or set a value to the control
(to avoid updating the mandatory columns).

To globally update records
1 Open the feature class form. (page 33)
2 Select the records to change.

3 On the Feature Class Form Toolbar (page 164) click the Global Update
icon.

The form switches to Global Update mode.

4 Enter the new values.

5 Click Global Update.

Digitizing Polygons With Islands

Polygon (page 214) features can contain islands (holes), for example, an island
in a lake or the footprint of a building with a courtyard. The inner and outer
ring are parts of one feature that can be appropriately displayed with solids.

Based on the outer ring, you can either digitize the inner ring or select an
existing polygon or feature to insert.

To digitize a polygon with an island

1 Open a workspace (page 8)

Editing Features | 39



U

G
Generate

2 Click Home tab » Display panel » Generate Graphic. &2
3 Draw the inner ring.

4 In the Document Explorer (page 161) select a polygon feature class.
Right-click and click Digitize With Form.

5 Digitize the outer ring.

When you finish, the feature class form is displayed.
6 Enter attribute data and click Update.

&
(=)

7 On the Feature Class Form Toolbar (page 164) click
Geometry As Inner Ring And Add It To the Polygon.

Insert An Existing

8 In the drawing, select the inner ring.

The inner ring is added to the polygon. If you selected a Topobase feature
as an inner ring, you are prompted to delete the inner ring.

9 Choose Delete Existing Features to delete the inner ring feature.

Processing Compound Features

Add child features to an existing compound feature by selecting a geometry
in the drawing (page 40) or by digitizing a new child feature (page 40).

See also:

B Data Model: Compounds
To add lines to a compound feature
m Click Digitize New Child Feature ¢ .

To add an existing feature to the selected compound feature

B Click Insert An Existing Geometry *# .
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Assigning Documents to Features

Each feature can have any number of documents (page 211). The documents
are processed in the table TB_FEATURE_DOCUMENT. The Document Manager
enters the FID of the feature and offers a choice of data files.

To assign a document to a feature

1
2
3

Select the feature class in the Document Explorer (page 161).
Right-click and click Show Form.

In the feature class form, right-click any empty space and click Document
Manager.

Click the New Record icon.
Select the name of the data file.

Right-click the green arrow to see the related document.

Labeling Features

Use label definitions (page 213) to create label text for any feature. Label
definitions are child feature classes of the feature class you label.

See also:

B Data Model: Labels

To label features

1

2
3

Start Topobase Client and open a workspace. (page 8)

U

Generate

Click Home tab » Display panel » Generate Graphic. 6rzehic
Start the Create Label command in either of the following ways:

B Click Home tab » Quick Access panel » Create Label. B
Select the features to label. Press Enter.

W In a feature class form, click Create Label. B
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In the Choose Label Definition dialog box, under Parent Features,
specify whether to apply the label to all features in the parent feature
class, all the features that are filtered in the form, or just the current
feature shown in the form.

4 In the Choose Label Definition dialog box, select the label definition to
apply. Click OK.

B If the label definition specifies Auto Label Placement, labels are placed
without further interaction.

B If the label definition requires you to specify a position, you are
prompted on the AutoCAD command line.

Adding Dimensions

You can add two types of dimension lines to features:

m Aligned Dimensioning—Labels distances with or without abscissa and
subsidiary lines.

B Orthogonal Dimensioning—Labels distances using orthogonal dimension
lines.

Aligned Dimensioning
Topobase has three styles of aligned dimensions:

B Aligned Complete—Draws the dimension label (page 213), abscissa, and
subsidiary lines.

W Aligned Abscissa Only—Draws the abscissa but not the subsidiary lines.

m Aligned Text Only—Draws only the dimensioning label without abscissa
or subsidiary lines.

Orthogonal Dimensioning

With orthogonal dimensions, if an offset (ordinate) point lies beyond the
abscissa start or end point, you can extend the abscissa line. If a line feature
lies on the abscissa of the orthogonal dimension, the intersection point can
be embedded like any other orthogonal point.

You can add orthogonal dimensioning in extension of a baseline. For example,
using the edge of a building.
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NOTE Your administrator must enable the dimensioning extension for the
document (page 211) in Document Options in Topobase Administrator.

See also:

B Setting Document Options

To add an aligned dimension

1 In the Document Explorer (page 161), right-click the Dimension feature
class. Click any of the following options:

B Aligned Complete
B Aligned Abscissa Only
B Aligned Text Only

2 Specify the abscissa start point, end point, and offset in the map.

You can specify a fixed offset in Document Options. For more
information, see To set COGO and dimensioning options.

3 DPress Enter to add dimensions.

To add a default orthogonal dimension

1 In the Document Explorer (page 161), right-click the Dimension feature
class. Click Orthogonal Complete.

2 Specify the abscissa start and end points in the map.
3 Specify one or more orthogonal points.

4 If a feature crosses the abscissa, you can include it as another orthogonal
point. Select the feature when prompted.

5 Press Enter to add dimensions.

To add an orthogonal dimension as an extension of a baseline

1 In the Document Explorer (page 161), right-click the Dimension feature
class. Click Orthogonal Extension Baseline.

2 Specify the baseline start point and end point in the map.
3 Specify the abscissa start point in the map.

4 Specify the abscissa length in the map.
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5 Specify one or more orthogonal points.

6 If a feature crosses the abscissa, you can include it as another orthogonal
point. Select the feature when prompted.

7 Press Enter to add dimensions.

Working with Templates

A template (page 215) consists of several features with predefined geometry,
attributes, labels (page 213) and internal connectivity.

Use templates to create groups of features that you can insert and reuse as
needed. For example, use a template to create a transformer bank, compatible
unit, substation, or cross section. You can also define templates for types of
equipment that vary in their attribute values (reference records (page 37)).

You assign a template to a feature class. When you define the template, you
must select at least one feature of the feature class to which you assign that
template. If the document (page 211) contains a job (page 215)-enabled feature
class, the Feature Group and Feature Group Feature in the template must be
job-enabled. All other template feature classes must not be job-enabled. Also,
they must be added to the Job template.

Grouping Features in Templates

If you group template features, you can move or rotate the feature arrangement
as a single entity. However, you cannot move the components separately
when you instantiate it. This behavior is controlled by the feature rule Update
Template Instances on the feature classes that are part of the template.

junction
transformer
conductor

>< origin
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Example—This template for an electric feature arrangement consists of a
transformer, two junctions, and two conductors. Using this template, you can
instantiate the five objects and apply their attributes and connectivity with
a single mouse click. The template is grouped: you can place and move it as
a single entity. After that, you can continue to digitize the conductors.

—

: : | | — P ILP,—_—'_
X
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| I

service point
awitch
transfarmer

> origin
internal connectivity

Example—This template for an electric feature arrangement can be used in
residential areas to create the connections to service points. In residential
areas, service points are commonly connected to a transformer using identical
feature arrangements. A template speeds up data acquisition in this situation.
This feature arrangement is not grouped: you can instantiate the template
and then move each service point individually to its exact location without
moving the other features.

Template Reference Records

When you select the features to include in a template, the attribute values of
each feature are stored as reference records (page 37). By default, the reference
records are named <feature class name>_<number>. In the Create Template
dialog box (page 188), you can replace the reference record with any existing
reference record. In the Create Template settings, you can select the public
reference record to apply when the template is instantiated. (You must choose
a public reference record, because templates are available to all users.)

Defining a Template

Define templates using existing features in a drawing. After creating the
template, you can delete the original features. Templates are defined in a local
coordinate system. When you instantiate a template in the map, you digitize
the origin and specify an orientation.
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You view existing templates in the Template Manager (page 189). Once you
have saved a template definition, you cannot modify it.

For cross-sections, a group also includes features that will be been added later,
such as conductors that are placed in a duct.

NOTE Using Topobase Administrator User Interface settings, you can hide the
Create Template context menu for user groups.

See also:
B Creating Features From Templates (page 47)

B Importing and Exporting Templates (page 48)

To define templates

1 In the Document Explorer (page 161), select a feature class that will be a
part of the template.

2 Right-click and click Create Template From Selection.

3 Select the template features in the drawing.

Related attribute features (no geometry) are selected automatically. Select
related geometry features manually.

NOTE You can now delete the features that you used to create the template.

To define a template for a transformer bank that can be used for data
acquisition (example)

1 Start Topobase Client and open a workspace (page 8).

&

Generate .
2 Click Home tab » Display panel » Generate Graphic. &rhic
3 In the drawing, create the features to include in the template.

For example, use AutoCAD tools to draw lines that mark the position of
the points. Then, digitize a transformer feature and two junction features.
Enter their attribute values. Digitize the conductors between the features.

4 In the Document Explorer (page 161), select the feature class for the
template.
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The template must contain a feature of the class you select.

5 Right-click and click Templates » Create From Selection.

6 In the drawing, select the features that belong to the template. Click to
finish the selection.
7 In the drawing, select the origin point for the template.

This is the point whose coordinates are local (0,0). This point will be used
when you instantiate the template by digitizing an origin. Click to specify
the orientation of the template.

8 On the Create Template dialog box (page 188) General tab, enter a name
for the template, such as Transformer - Junction.

9 Select Group Features When Moving, Rotating, Or Deleting.

This option keeps a multi feature template together as a group when you
instantiate it.

10 On the General tab, make sure that you selected only the template
features. Click Delete to remove a feature from the template.

11 On the Access tab, optionally select the feature classes for which the
template will be available.

12 Click Save.

Creating Features From Templates

In Topobase Client, use templates (page 215) to create recurring arrangements
of features, including attributes and connectivity.

If you created a grouped template, select any feature in the group and apply
the command to move, rotate, or delete. The command affects all features of
the group.

NOTE Feature rules (Update Template Instances) on the feature classes that are
part of the template make sure that the Move, Rotate, or Delete command will
be applied on all features of the template group.

See also:
B Defining a Template (page 45)

B Importing and Exporting Templates (page 48)
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To create features using a template

1 In the Document Explorer (page 161), select the feature class of the
template.

2 Right-click and click Templates » <template name>.

3 In the drawing, specify the template origin and orientation.

To move, rotate, or delete a feature arrangement

-

Edit
Geometries

1 Click Home tab » Quick Access panel » Edit Geometries.
2 In the drawing, select a feature in the feature arrangement.

3 Use the AutoCAD tools to move or rotate the feature.

If you delete the selected feature, confirm whether to delete the entire
group.

Importing and Exporting Templates

Feature templates (page 215) are exported to XML files (Topobase Template file
*.thtx). A single template file can hold multiple feature templates.

When you import exported feature templates, all template information is
transferred, including reference records, feature classes, and connectivity.

You can transfer templates only between documents (page 211) of the same
module (data model). You cannot import a template if the target document
is missing feature classes for that template. You cannot import a template if
feature classes have different names in the target and source documents.

Use the Template Manager (page 189) to create, edit, import, and export your
feature templates.

See also:
B Defining a Template (page 45)

B Creating Features From Templates (page 47)
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To start the Template Manager

1

In the Document Explorer (page 161), select a feature class, right-click,
and click Templates Manage.

In the Template Manager (page 189), under Template Name, select the
template.

To export feature templates

1

From the Topobase Application Menu (page 157), click
File » Export » Feature Template.

If the Template Manager (page 189) is open, click Export.

In the Template Manager, in the tree view, select one or more templates
to export.

Click Export.

In the Export dialog box, specify a name and location for the Topobase
template (*.tbtx) file.

Click Save.

Click Close to close the Template Manager.

To import a feature template

1

From the Topobase Application Menu (page 157), click
File » Import » Feature Template.

If the Template Manager (page 189) is open, click Import.

In the Import dialog box, select the Topobase template (*.tbtx) file to
import.

Click Open.

Creating Schematic Representations

Schematic features (page 214) and generalizations are location features that
represent real-world features.

Create schematic location features automatically from real-world geometry
features using the Build Schematic workflow (page 216). This workflow produces
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orthogonal and geoschematic diagrams, depending on the schema plan created
by your Topobase administrator.

B A geoschematic diagram is a simplified geometric representation of
topologically connected point and line features. The relative position of
geoschematic features closely reflects the position of the real-world features
from which they are abstracted. However, the geoschematic diagram
reduces geometric complexity, making features easier to view and manage.

B An orthogonal schema represents an abstraction of topologically connected
point and line features. It uses straight lines that are joined at right angles.

In addition, you can create schematic features manually from real-world
attribute features that do not have geometry. See Creating Schematic Features
for Attribute Features (page 52). Schematic features are point and line geometry.

NOTE When you delete real world features, they are deleted in the schematic.

Building a Schematic

Before you can build a schematic, your Topobase administrator must create
a schema plan (page 214). The schema plan specifies the type of schematic to
generate (orthogonal or geoschematic), the schema topology (page 216), the
feature classes that can be included, and some specific drawing settings.

NOTE Conductors must be connected with the start and end devices. Otherwise,
the schematic will not build successfully.

See also:
B Data Model: Schematics
B Creating Schematic Features for Attribute Features (page 52)

B Creating Generalized Features (page 52)

To build a schematic
1 Click Home tab » Data Source panel.

2 From the Representation list, select the schema to work on.

3 Open the Workflow Explorer (page 11). 5
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4 Right-click Build Schematic. Click Execute.

5 Do one of the following:

B Click Select In Map. Select the features to include in the schematic.
The selected features populate the schematic Feature Explorer (page
162) in the Review And Modify Selection area.

B Click Select From Trace. Define a network trace and click OK.
The traced features populate the schematic Feature Explorer in the
Review And Modify Selection area.

You can select a stop condition through the schematics Select From
Trace workflow. You cannot edit an existing stop condition, but you
can define a new one through the schematics workflow (page 216). The
new stop condition is saved to the database. You can edit the new
stop condition.

The trace direction is initially set by the direction value in the tracing
template. You can override the direction through the schematics
workflow. This value is then stored in TB_SETTINGS. When you use
the trace template through the schematics workflow, the TB_SETTINGS
value is applied. The direction value in the trace template stored in
the database is not changed.

B Use Feature Specific Selection to navigate the document tree and
display forms for the feature classes to include in the trace. Select
features by attribute, or include all features in the feature class. Click
Add The Features In This Dialog To The Schematics Workflow Feature

Explorer. F

The selected features are added to the schematic workflow Feature
Explorer. Only features that are included in the schema topology (page
216) are shown in the document tree. The selected features populate
the schematic Feature Explorer in the Review And Modify Selection
area.

6 Review the set of features in the schematic Feature Explorer. Clear any
features to exclude from the schematic.

7 Click Build to generate the schematic.

Only features that are included in the schema topology are included in
the schematic. The schematic Feature Explorer displays the remaining
features.

NOTE To add new features to the schematic, run the Build Schematic
workflow again and include just the new features.
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Creating Schematic Features for Attribute Features

You can create a schematic feature (page 214) for an attribute feature class.
Attribute feature classes do not have geometry.

NOTE Your system administrator must add the feature class to the schema
topology (page 216).

See also:
B Data Model: Schematics
B Building a Schematic (page 50)

B Creating Generalized Features (page 52)

To create a schematic feature for an attribute feature

1 Click Home tab » Data Source panel.

2 From the Representation list, select the schema to work on.

3 Open the Document Explorer (page 161). |Eﬁ

4 In the Document explorer, right-click the attribute feature class for which
to create a schematic feature (page 214).

5 Click Digitize or Digitize With Form.

6 Draw the schematic feature as desired in the map.

When prompted, select the real-world feature class that corresponds to
the schematic feature.

Creating Generalized Features

Cartographic generalization emphasizes the most important map elements,
while still representing the real world. Use generalization features to represent
real-world features in modified locations that are easier to view and understand.
Generalized features are point, line, polygon, and collection geometry.

NOTE Your system administrator must create a generalization plan and specify
the feature classes to include.
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See also:
B Data Model: Schematics
B Building a Schematic (page 50)

B Creating Schematic Features for Attribute Features (page 52)

To create a generalized feature

1 Click Home tab » Data Source panel.

2 From the Representation list, select the generalization to work on.

3 Open the Document Explorer (page 161). |%

4 In the Document Explorer, right-click the attribute feature class for the
generalized feature.

5 Click Digitize or Digitize With Form.

6 Draw the generalized feature in the map.

When prompted, select the real-world feature class that corresponds to
the generalized feature.

Exporting Feature Data

You can export data to various formats. Only the filtered records are exported.

See also:

B Coordinate Export Workflow (page 180)

To export data from feature class forms
1 Display the feature class form.
2 Filter the data to export.

3 Right-click in the form and click the type of export to perform.
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Exporting to Microsoft Excel

When you export data to Microsoft Excel files, you can export all data that is
shown in a form, including:

B Values that are shown only by controls (such as SQL Label)

B Values without explicit relation

Note the following limitations:

B Only columns that are visible in the form are exported; group-suspended
columns are suppressed.

B CRcharacters (Ascii 13) are replaced, because Excel needs only a Line Feed.
This is required for multiline text.

See also:
B Exporting to DWG (page 19)
B Exporting to Microsoft® Word Using Serial Letter (page 55)

B Exporting Point Coordinates (page S6)

To export data to Microsoft Excel
1 Show the feature class form (page 33).
2 Filter the data. (page 23)

3 Right-click in the form and do one of the following:

B To export all data as it is stored in the database (DB data), click
Export » Excel (Direct) (page 182).
The Excel columns are sorted like the columns in the database.

B To export data as shown in the form, click Export » Excel (Form Data)
(page 182).
Use this mode when you have related data but want to avoid exporting
the ID of the related feature (which is stored in the database). Instead,
you export the value shown in the form. The Excel columns are sorted
like the columns in the form.
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Exporting to Microsoft® Word Using Serial Letter
Export data to MS Word using mail merge.
This command creates two files in the <topobase_client>\Data\ Word\ folder.

B Word template <table name>.dot (with all table columns available as serial
letter fields).

B Data source file <table_name>.dat (containing the records to use in the

serial letter).

When you use this command for the first time, the merge fields are not yet
inserted into the *.dot file. Add the desired serial fields, and save and close
the *.dot file. The next time you start the serial letter command, the fields are
replaced by the corresponding values of the current filter.

Create special views containing all data to print in a serial letter, such as names
and addresses. You can then apply the serial letter command to this view.

See also:
B Exporting to DWG (page 19)
B Exporting to Microsoft Excel (page 54)

B Exporting Point Coordinates (page 56)

To insert merge fields and export to Word Serial Letter

1 Open a feature class form (page 33) and select the records for the serial
letter.

2 On the Feature Class Form Toolbar (page 164), click Tools. 4

3 Click Export » Word Serial Letter.
Two Microsoft Word documents open.

4 Navigate to the <topobase_client>\Data\ Word folder.

In the folder, Tablename.dat is the data for the Serial Letter and
Tablename.dot is the template for the Serial Letter.

5 Close the blank file that opened when you started Microsoft Word.
6 Open the Tablename.dot file.
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NOTE You must open the (*.dot) file inside Microsoft Word. Do not
double-click the filename outside of Word.

7 Click Yes and OK.

Now you can insert the Serial Letter data columns using the Microsoft
Word toolbar and create the Serial Letter.

8 Save the (*.dot) template file.
You perform these steps only once to create the template document.

When you select Export » Word Serial Letter, the template you just
created appears with the (*.dot) file you designed.

9 In Microsoft Word, on the Mail Merge toolbar, click the Insert Merge
Fields icon and select the fields (attributes) to use in the serial letter.

10 Start the Export » Word Serial Letter command again.

Close the (*.dot) without saving. The serial letter is generated and ready
to print.

You can modify the <table_name>.dot template at any time.

Exporting Point Coordinates

When you use the Coordinate Export tool, use one of the following methods
to select point coordinates:

Select the points in the map.
Select the points from a trace, using a logical topology (page 213).
Select the points from the current job (page 215).

Select the points from areas, using an area topology (page 211).

Select the points from a feature class form.

The Coordinate Export tool creates various output formats.

GSl

To export to GSI files, the point features must have a point number that is
stored in the attribute TB_POINTNUMBER.
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Generic File Formats

For generic file formats, the Coordinate Export tool exports coordinates and
point attributes (page 175) that you specify in the Format Definition Manager
(page 173).

Text Files

Export point coordinates to any text file for which you have defined the export
format. The export format can be lines with fixed column width or lines with
separators.

See also:
B Generating a Coordinate Report (page 72)

B Exporting to Microsoft Excel (page 54)

Exporting to GSI

To export coordinates to a GSl file
1 Start Topobase Client and open a workspace (page 8).
2 Click Home tab » Display panel » Generate Graphic.
3 Select a viewport (page 15) that contains the points to export.

4 Select the document (page 211), right-click, and click Export » Coordinate
Export.

5 In the Coordinate Export Workflow (page 180) pane, do the following:
B Expand the Filter Feature Class control.

B Under Selected, specify the point feature classes add to the selection
method you use.

B Select a feature class, such as Point.

6 In the workflow pane, click Select In Map .
7 In the drawing, select the points. Press <Enter> to finish the selection.

8 In the Coordinate Export Workflow (page 180) pane, do the following:

B Expand the Review And Modify Selection control.
The explorer displays the selected points.

Exporting Feature Data | 57



B Review, and click OK.

B Select Export Into File.

9 Select the exporter type GSI Exporter.
10 Select Extend Existing File to append the coordinates to an existing file.
11 Click OK. Enter the export file name, such as PointCoord.

12 Click Save. A log file <coordinate file name>.log) displays the export
result. The log file is stored in the same directory as the coordinate file.

Generic Coordinate Export

To select the points to export
1 Start Topobase Client and open a workspace (page 8).
2 Click Home tab » Display panel » Generate Graphic.
3 Select a viewport (page 216) that contains the points to export.
4

Select the document (page 211), right-click, and click Export » Coordinate
Export.

5 In the Coordinate Export Workflow (page 180) pane, in the coordinate
selection pane, do the following:

B Expand the Filter Feature Class control.

B Under Selected, specify the point feature classes to add to the selection
method you use.

W Select a feature class, such as Point.

B Click Select In Map .

6 In the drawing, select the points. Press <Enter> to finish the selection.
In the workflow pane, the Feature Explorer (page 162) displays the selected
points.

7 Click OK.

In the Coordinate Export Workflow (page 180) pane, specify the export
options.

If no Generic Exporter Formats are available, define a format.
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To define an export format

1

10
11

Select the points to export.
See the previous procedure (page 58).

In the Coordinate Export Workflow (page 180) pane, select Export Into
File.

Select the Generic Exporter.
Under Select Format Definition, click New.

In the Format Definition Manager (page 173), specify the file format. For
example, enter the following values:

B Definition Name: PointXYZ

B Default File Extension When Exporting Coordinate Files: txt.

Select Parse With Separators.
Under Properties, enter a separator, (for example, “!”).

Select the point attributes (page 175) to export, for example:
B Northing Coordinate

B Easting Coordinate

B Identifier

Under Index, specify the order of the exported values.
For example, use the indices 0, 1, 2.

Click Save and enter a name for the definition.

Click Cancel to close the Format Definition Manager.

Exporting to a Text File

To export coordinates to a text file

1
2

Start Topobase Client and open a workspace (page 8).

Click Home tab » Display panel » Generate Graphic. Select a viewport
(page 216) that contains the points to export.

Select the document (page 211), right-click, and click Export » Coordinate
Export.
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In the Coordinate Export Workflow (page 180) pane, do the following:
B Expand the Filter Feature Class control.

B Under Selected, specify the point feature classes to add to the selection
method you use.

W Select a feature class, such as Point.

B Click click Select In Map I—J .

In the drawing, select the points. Press <Enter> to finish selecting.

Click OK.

In the Coordinate Export Workflow (page 180) pane, do the following:
B Select Export Into File.

B Select the Generic Exporter.
B Select the format definition.
|

Select Extend Existing File to append the coordinates to an existing
file.

m Click OK.

Enter the name of the coordinate file.

Click Save. A log file <coordinate file name>.log) displays the export
result. The log file is stored in the same directory as the coordinate file.

Selecting Points for Export

The Coordinate Export tool provides the following methods for selecting the
points to export:
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Select In Map—Selects points in the drawing

Select From Area Topology—Selects points that lie within an area. This
method is available if the document (page 211) has area topologies (page
211).

Select Specific Feature— Selects the points from a point feature class. You
can select all features in a feature class, or only those displayed by a filter.
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Use one of the following methods to export the points

B Filter Feature Class—Pre-selects feature classes. Only the preselected feature
classes are considered when using a selection method. The Filter Feature
Class area displays a list of available point feature classes and a list of
selected feature classes.

Use the arrow buttons to add or remove a feature class from the Selected
list.

B Add Features From Current Job—Selects the point that have been created
or modified in the current job (page 215), and that are not pending or live.
This method is available in job-enabled documents (page 211).

B Select From Trace—Selects points from a tracing analysis. This method is
available if the document has logical topologies. The list displays the
available topologies.

See also:

B Exporting Field Codes (page 62)

To select coordinate features using Select In Map

1 In the Display Manager (page 211), set the layers to Make Layer Selectable.

2 Click Select In Map @J .

3 In the drawing select the points, for example, drag a rectangle.

To select coordinate features using Select From Area Topology
1 Select a topology from the list.
2 Click Select.

3 Inthe drawing, click inside the polygons that contain the point features.

To select all features of a feature class
1 Select a feature class node.

2 Right-click, and click Select All.
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To select some features of a feature class
1 Select the feature class.
2 Right-click, and click Open Form.

3 Use the filter tools.
Do not close the form, otherwise you will lose your filter settings.

4 To add the filtered points to your selection, right-click, and click Get
Features Of Form
To export using Select From Trace
1 Select a topology (page 216).
To open the tracing workflow (page 216), click Start.
In the tracing workflow, select the tracing template.

Specify the tracing.

“vn A W N

Click OK.

The tracing results are added to your selection. For more information
about tracing, see the Topobase Administrator Guide - Network Tracer.

Exporting Field Codes

In the Topobase Survey module, you use field codes to classify the points that
you measure. The field code specifies in what database schema and feature
class a point will be stored. You can export the field code of a point feature.

Topobase Survey uses a field code list to map a point to a Topobase feature
class. The Coordinate Export tool uses the field code list to determine the field
code of the exported points. When you export points, you select the field code
list from the appropriate Survey project. For more information about Topobase
Survey, see the Topobase Survey User Guide.

For Generic Exporter formats, you must select a format definition that includes
the field code.

See also:
B Selecting Points for Export (page 60)

B Format Definition: Point Attributes (page 175)
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To export point coordinates and their field codes

1

A L A W N

N

Open a workspace (page 8) that contains the Survey document (page
211).

Click Home tab » Display panel » Generate Graphic.

Select a viewport (page 216) that contains the points to export.
Start the Coordinate Export tool and select the points to export.
Click OK.

In the Coordinate Export Workflow (page 180) pane, select Export Into
File.

Select an exporter that includes the field code, such as GSI Exporter.
Select Export Field Code.

Specify the Survey document and the field code list.

Click OK.

Importing Feature Data

Importing Point Coordinates

Use the Coordinate Import tool to import coordinate files from the following
formats:

W Text files with fixed column width

B Text files with character-separated values, such as CSV

The Coordinate Import tool provides a Format Definition Manager (page 173)
that helps you to define your own file formats.

The Coordinate Import tool imports the points into a single feature class, or
uses a field code list to distribute the points into different feature classes in
one or more documents (page 211).

Importing Feature Data | 63



Import Coordinates Using Field Codes

In the Topobase Survey module, you use field codes to classify the points that
you measure. The field code specifies the database schema and feature class
in which a point will be stored.

The Coordinate Import tool uses the field code list to distribute the points.
When you import points, you select the field code list from the appropriate
Survey project.

For example, using field codes, you can distribute the points to different
documents (page 211).

B Field code 1 - Water document - Hydrant.

B Field code 2 - Land document - Border point.

Format Definition: Sample Files

This coordinate file has fixed column widths. For example, the identifier is

from position 17 to position 30.

*23456789012345678901234567890123456789012345678901234567890

*Point type!Identifier !Easting !Northing !
Coordinate ! 41502000! 599999.999! 200000.003!
Coordinate ! 41501000! 600200.001! 200000.001!
Coordinate ! 41501001! 600250.000! 200500.000!

Coordinate file with comma-separated values. For example, the easting
coordinate is the third value.

*Point typeldentifier,Easting,Northing, Height
Coordinate, 41502000, 599999,200000, 765
Coordinate, 41501000, 600200,200001,767
Coordinate, 41501001, 600250,200500,768

See also:

B Importing from Excel (page 66)

To import a coordinate file into a single feature class
1 Start Topobase Client and open a workspace (page 8).

2 Right-click the document node and click Import » Coordinate File Import.
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In Import Wizard 1: Select Files (page 177), click Add, and select the
coordinate files.

Select or create the format definition file (*.def).
Click Next.

In Import Wizard 2: Distribution Settings (page 178), select Distribute Into
One Single Feature Class.

To select the points, do one of the following.

B Select the point feature class.

B For utility models, select the attribute feature class, such as Hydrant
(WA_HYDRANT).

Click Next.

In Import Wizard 3: Analyzing import Files (page 178), the import file is
validated. Under Parsed Points, the grid displays the parsing result for all
points.

Click Next.
In Import Wizard 4: Import (page 179), the import status is displayed.

Click Close (or click Save As to save the log file).

To import coordinates using field codes

1

Start Topobase Client and open a workspace (page 8) that has access to
the Survey document and the documents (page 211) to which you want
to distribute the points.

Select the Survey document, right-click the document node, and click
Import » Coordinate File Import.

In Import Wizard 1: Select Files (page 177), select the coordinate file and
the format definition.

Click Next.

In Import Wizard 2: Distribution Settings (page 178), select Distribute
With Predefined Field Codes, and select the survey project that contains
the field code list.

If a field code is not available in the selected field code list, on the Task
Overview, click the Distribution Settings link. In Step 2, click Open Survey
to modify the field code list.
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6 Click Next.

7 InImport Wizard 3: Analyzing import Files (page 178), check the parsing
status.

8 Click Next to import the points.

To select another format definition
1 On the Navigation Task pane, click the Select Files link.
2 Select the format definition file for the import file.

3 On the Navigation Task pane, click the Analyzing Import Files link.

Importing from Excel

You can import data from Excel from complete Excel files or from selected

columns.

Excel Import Description

Excel Import (Direct) Imports data from Excel files.

Excel Update (Direct) Updates feature data from Excel files. The

new values are loaded from the Excel file.
Mark key columns with the # character. All
fields used for search (search condition

WHERE) must be preceded with the # sign.
If the Excel file contains a # field, Topobase
performs an update instead of an import.

TIP For point feature classes, you can import or update point geometry data. Use
GEOM.X and GEOM.Y as column names in your Excel sheet.

TIP If you import years with a two-digit format, the two missing numbers are
added as follows: For numbers between 0 and 50, the year is saved as 20xx. For
numbers greater than 50, the year is saved as 19xx. For example, 50 becomes
2050; 49 becomes 2049; 51 becomes 1951.

TIP If no cell range is selected, or if just one cell is selected, the cells are selected
from cell A1 to the last cell found. Normally, you do not need to select any cells.
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Updating Data using Excel

You can also update data using Excel.

Example 1: Excel table

The example shows how to update the feature class TREE. The attribute
TREE_NAME is updated for all records whose FIDs are listed in the Excel file.

#FID TREE_NAME

1 oak

2 pine

Excel import will process the following commands:
Update TREE set TREE_NAME='oak' where ID=1;
Update TREE set TREE NAME='pine' where ID=2;

Example 2: Excel table

The example shows how to update the feature class TREE. The attribute
CATEGORY will be updated with a more detailed value depending on the
TYPE. The example assumes that TYPE = 1 = oak and TYPE = 2 = pine.

#CATEGORY #TYPE CATEGORY

tree 1 deciduous tree

tree 2 conifer

Excel import will process the following commands:

Update TREE set CATEGORY='deciduous tree' where CATEGORY='tree'
and TYPE=1;

Update TREE set CATEGORY='conifer' where CATEGORY ='tree' and
TYPE=2;

See also:

B Importing Point Coordinates (page 63)

To import data from Excel

1 Open the Excel file and select the columns and rows to import.

The corresponding field names must be in the first row of the selected
area.

2 Navigate to the directory where you will save your data.
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In the Document Explorer (page 161), select the feature class to update.

Right-click the feature class and click Show Form.

On the Feature Class Form Toolbar (page 164), click lE' . Click
Import » Excel Import.

To update data using Excel

1
2
3

Open a workspace (page 8).
Open the Excel file.

Mark the key column headings to use in the WHERE clause with the
pound sign (#).

In the Document Explorer (page 161), select the feature class to update.
Right-click the feature class and click Show Form.

On the Feature Class Form Toolbar (page 164), click IEI . Click
Import » Excel Update (Direct).

Generating Reports

Overview of Reports

You can generate standard reports or user-defined reports for each feature class
form. Standard reports are based on the form's structure and arrangement.
User-defined reports can be generated using Topobase Report Designer or
Crystal Reports ™.

You can add, edit, or remove reports assigned to a feature class form.

See also:

Report Designer Reference
Overview of Construction (page 127)

Constructions: Reports (page 149)
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To print a feature class report
1 Open the feature class form (page 33).

2 Filter the form (page 23) to show the records to print.

3 On the Feature Class Form Toolbar (page 164) click Print. =

4 In the Report dialog box (page 172) select the report and click OK.

To add a report
1 Open the feature class form (page 33).
2 On the Feature Class Form Toolbar (page 164) click the Print icon.
3 In the Report dialog box (page 172) right-click anywhere and click one of
the commands.
To edit or remove a Topobase report
1 Open the feature class form (page 33).
2 On the Feature Class Form Toolbar (page 164) click the Print icon.

3 Inthe Report dialog box (page 172) right-click the report to edit or remove.

To print a COGO report

B Click Output tab » Reports and Profiles panel » Open COGO Report.

NOTE Do not use the Open Report command.

Generating Topobase Reports

You can print any report defined with Topobase Report Designer in the current
document (page 211).

You can send the report to different output formats, for example, a printer,
ASCII file, or HTML file.

See also:

B Report Designer Reference
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To print a Topobase report

1 Start Topobase Client, open the workspace (page 8), and select the
document (page 211).

B

Open
Report ™

2 Click Output tab » Reports and Profiles panel » Open Report.

3 Select the report and click Preview.
The report designer preview opens.

Using Spatial Export

Use the Spatial Export tool to export features that were selected with a spatial
selection method. For example:

B All feature that lie within a job perimeter (page 213)
m All features that lie within a topology (page 216)

B All features that lie within an area
|

All manholes that lie on a selected section

NOTE These methods require customized reports.

NOTE If you have only one feature class, you can perform a spatial selection in
the database and then print the selected records using the Print icon in the Feature
Class Form Toolbar (page 164).

See also:
B Report Designer: Spatial Selection Report
B Selecting Features (page 21)

B Report Designer Reference

To perform a spatial export

1 Start Topobase Client, open the workspace (page 8), and select a
document (page 211) in the Topobase Task Pane.
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Click Home tab » Display panel » Generate Graphic. &rehic
Click Output tab » Reports and Profiles panel » Open Spatial Report.

In the Spatial Export dialog box (page 181) select a spatial selection method
and select the features in the map.

Select the report.
Click Create.

The Report Designer preview opens. You can send the report to different
output formats, for example a printer, ASCII file, or HTML file.

Click the Print icon to print the report.

Generating a Polygon/Line Definition Report

Use the Polygon/Line Definition command to create a detailed polygon (page
214) or line definition report. For example, create a parcel report that lists area,
distance between the parcel border points, parcel borders, points, and parcel
numbers.

See also:

B Report Designer Reference

To create a Polygon/Line Definition report

1

Start Topobase Client, open the workspace (page 8), and select a
document (page 211) in the Topobase Task Pane.

&

Generate .

Click Home tab » Display panel » Generate Graphic. Sz

Click Output tab » Reports and Profiles panel » Open Lines and Polygon
Report.

In the Report for Lines/Polygons dialog box, select the line or polygon
to define.
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Select the job (page 215) that includes the desired features.
Select the report to produce.

To reverse the direction of the points, select the check box.

® N & wn

Click Calculate/Preview.
The report is generated and displayed using the settings you specified.

Generating a Coordinate Report

Use the Coordinate Export tool to export point coordinates that were selected
with a spatial selection method, topology (page 216) selection, or filter.

See also:
B Exporting Point Coordinates (page 56)
B Selecting Points for Export (page 60)

B Report Designer: Coordinate Report

To print a coordinate report

1 Start Topobase Client, open the workspace (page 8), and select a
document (page 211) in the Topobase Task Pane.

2 Click Home tab » Display panel » Generate Graphic.
3 Select a viewport (page 216) that contains the points to print.

4 Select the document, right-click, and click Export » Coordinate Export.

NOTE If you use Output tab » Reports and Profiles panel » Open Report,
the filter methods are not available and the report lists all points of the
document.

5 In the Coordinate Export Workflow (page 180) pane, expand the Filter
Feature Class control.

6 Under Selected, select the point feature classes to include in the selection
method you use.

7 In the workflow pane, click Select In Map .
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8 In the drawing, select the points. Press <Enter> to finish the selection.

9 In the Coordinate Export Workflow (page 180) pane, expand the Review
And Modify Selection control. The explorer displays the selected points.

10 Review the points and click OK.

11 Select Generate Report.

12 Select the report template.

13 Click OK.

14 In the Report Preview dialog box, click ASCII.

15 Save the file.

NOTE The Generate Report option is active only if your system administrator has
provided a report template.

To import a coordinate export report template

1 Start Topobase Administrator, open the workspace (page 8), and select
a document (page 211).

2 Click Document menu » Report Designer.

3 In the Report Designer dialog box, click Report
menu » Import/Export » Import XML Report Definition.

4 Select the report definition file (*.XML), for example,
CoordinateExportReport.xmi.

5 Exit the Report Designer.
Maintaining Topologies

Checking an Area Topology

Use the Topology Checker to validate the state of area topologies (page 211).
The Topology Checker checks the data in the topology system tables (_ TEDG,
_TSUR, _TISL, _TSER, _TCEN) to find out whether there are topology errors,

such as polygons crossing themselves or centroids (page 211) without polygons.
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The polygons on the left are detected only with the Find Intersecting
Lines command. The polygons on the right are detected using the
standard Topology Checker.

The Feature Explorer (page 162) shows each topology error type in a special
node. Expand the nodes and items to see more details. At the feature level,
by default, the FID and name of the feature class is shown.

The results are shown in the Area Topology Checker (page 183) pane. The
Feature Explorer (page 162) shows all offending features (page 185). Use the
icons and the shortcut menus to process and highlight the features.

NOTE In Topobase Administrator, when you initialize the topology, you can
optionally create a log file that records all topology errors, including the intersecting
lines.

See also:
B Maintaining Topologies (page 73)
B Checking a Logical Topology (page 76)

NOTE Before you use the Topology Checker, the topology must be initialized.

To start the Topology Checker
1 Start Topobase Client.
2 Open a workspace. (page 8)

3 Do one of the following:

B In the Topobase Task Pane, click the Topology Checker icon and
select the topology.
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B In the Document Explorer (page 161), select the topology, right-click
and click Topology Checker (page 183).
Example: Select the Line Not In Closed Loop item and click Highlight.
This highlights all features that are listed under the selected item.

Managing Logical Connections

To connect feature logically, the features must be part of a logical topology
(page 213). You can connect them manually or automatically.

Use the Manage Connections control to view and edit logical topologies. The
Manage Connections area (page 183) displays the connectivity tree of features
that are part of a logical topology (page 213). The Manage Connections area is
available if a logical topology is defined.

B Automatically—When digitizing, features are spatially connected if they
lie within the tolerance.

B Manually—Use the Manage Connections area (page 183) to connect the
features.

See also:

B Adapting a Viewport for Feature Highlighting (page 11)

B Logical Topology Properties

To display the Manage Connections area

B In the Topobase Task Pane, click Connectivity Manager. %
The Manage Connections area (page 183) is displayed below the Document
Explorer (page 161).

B Alternatively, open the form for a feature class that is part of a logical
topology (page 213). On the Feature Class Form Toolbar (page 164), click the
Manage Connections icon.

To connect features manually

1 Start Topobase Client.

2 Open a workspace. (page 8)
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3 Generate the map.

4 Select the feature in the map.

i
5 In the Topobase Task Pane, click Connectivity Manager. d

6 Inthe Manage Connections area (page 183), in the connectivity tree, select
the feature (root item).

==

7 Click Connect Features.

8 In the drawing, select the features to connect to the selected feature.

To view logical connections
1 Start Topobase Client and open a workspace (page 8).

2 Inthe drawing, select a feature. Alternatively, click Manage Connections
first and then select the feature in the drawing.

3 In the Topobase Task Pane, click Connectivity Manager. b

4 The Manage Connections area (page 183) displays all connections that are
defined to and from the selected feature.

Checking a Logical Topology

Use the Logical Topology Checker (page 186) to process logical topologies (page
213).

The results are shown in the Logical Topology Checker (page 186) pane. The
Feature Explorer (page 162) shows all offending features (page 187). Use the
icons and the shortcut menus to process and highlight the features.

For information about network analysis workflows (page 216), see the respective
Utility Application Guides, such as the Topobase Water User Guide.

See also:

B Checking an Area Topology (page 73)

NOTE Before using the Topology Checker, you must add the topology item to
the appropriate Document Explorer and initialize the topology.
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To check logical topologies
1 Start Topobase Client and open a workspace (page 8).

2 Inthe Document Explorer (page 161), select the topology, right-click, and
click Topology Checker.

The results are displayed in the Logical Topology Checker (page 186) dialog
box. Use the icons to find the features in the map and to show feature
information. You can also right-click the feature and click a command.

See also:

B Logical Topology Checker Error Messages (page 187)

Working with Jobs

Overview of Jobs

Working with jobs (page 215) involves steps in Topobase Administrator and
Topobase Client.

Job-enabled documents (page 211) and Job
templates are provided by the Topobase
Administrator.

Job-enable documents and create
Job templates.

Create a job (page 79) Use the Topobase Job Manager to create a job.

In the Topobase Task Pane, from the Job toolbar,
select the job to work with.

Select a job (page 81)
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Edit feature geometry (page 30) Edit feature geometry using AutoCAD commands.

Edit attributes (page 36) Modify attribute data using feature class forms.

You can change the job state (job state transition)
from job level or from job topic (page 215) level.
Run a data check before changing the job state.

Change the job state to Pending.
(page 83)

If you change the job status, the system
automatically checks whether the job contains
features that have been modified in other jobs.
In the Conflict Explorer, you can resolve the
conflict.

Validate and approve the
modifications. (page 85)

Change the job state to Live. Once a job is live, you cannot change its state
(page 83) again.

Managing Jobs
Topobase Client provides the following tools for working with jobs (page 215):
B Topobase Job toolbar.

] Live v

Job toolbar
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Select the jobs to work with.

m Topobase Job Explorer (page 191)
Process the features that are modified in the selected job.

B Topobase Job Manager
Process jobs and job states using the Job Manager Icons (page 190) and Job
Manager Menus (page 190).

See also:

Creating a Job (page 79)

Selecting a Job (page 81)

Defining the Job Perimeter (page 81)

Deleting Job Modifications (page 82)

Changing the Job State (page 83)

Resolving Job Conflicts (page 85)

To start the Job Manager

1 Start Topobase Client and open a workspace (page 8).

2 Click Job Manager.

To start the Job Explorer
1 Start Topobase Client and open a workspace (page 8).

2 Select a job.

3 In the Topobase Task Pane, click ﬁ .

Creating a Job
Use the Topobase Job Manager to create a job (page 215).
The properties are saved in the system table TB_JOB.
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See also:

Managing Jobs (page 78)

Selecting a Job (page 81)

Defining the Job Perimeter (page 81)
Deleting Job Modifications (page 82)
Changing the Job State (page 83)
Resolving Job Conflicts (page 85)

To create a job

1

Start Topobase Client and open a workspace (page 8).
i

In the Create Job dialog box, select a job template and provide a job name
and any comments.

To start the Job Manager, click Job Manager.

On the Job Manager toolbar, click Create Job.

Click OK.

When prompted to regenerate the map, click Yes to make sure that the
drawing represents the data for the current job.

When prompted whether to select the job perimeter (page 213) now, click
Yes if you work with perimeters.

To define the perimter, see Defining the Job Perimeter (page 81).

In the Job Manager, expand Jobs, Job States, Open.
The new job is listed.

Expand the new job to see which feature classes it contains.

NOTE In the Topobase Task Pane, the new job is automatically selected as
the current job.
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Selecting a Job

To work with a job (page 215), click Home tab » Data Source panel and select
the job from the Job list. The Job list displays all jobs created by the current
user. Use a filter to reduce the number of jobs that are displayed in the list.

Once you select a job, you can work with all the feature classes of that job.
When you finish, you can change the job state or delete your modifications.

See also:

Managing Jobs (page 78)

Creating a Job (page 79)

Defining the Job Perimeter (page 81)
Deleting Job Modifications (page 82)
Changing the Job State (page 83)

Resolving Job Conflicts (page 85)

To select a job without a filter

B From the Job toolbar (page 78), select the job to work with.

To select a job with a filter

1 Select Filter Jobs With Forms to open the Job form (TB_JOB).
TB_JOB stores all jobs of your current document (page 211).

2 Use the form to select a job.

3 Click Select.

NOTE If you select the Live job, you cannot modify the features of job-enabled
feature classes. However, you can process all features of job-disabled feature classes.

Defining the Job Perimeter

A job perimeter is the spatial area where a job (page 215) can be processed. Use
job perimeters to control where the modifications of the current job are
allowed. Features outside the job perimeter cannot be processed. You can
define feature rules to apply to the objects within the perimeter.
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You can define a job perimeter when you create a job, or afterwards. When
you select a job in the Job Manager (page 190) to define its perimeter, it becomes
the current job automatically.

You can select an existing polygon (page 214) as the job perimeter, or digitize
a new perimeter.

See also:
Managing Jobs (page 78)
Creating a Job (page 79)

|

|

B Selecting a Job (page 81)

B Deleting Job Modifications (page 82)
B Changing the Job State (page 83)

|

Resolving Job Conflicts (page 85)

To define a job perimeter
1 Start the Job Manager (page 79).
2 In the Job Explorer (page 191), expand Jobs » Job States » Open.
3 Select the job, right-click and click Select Perimeter.

4 Define the perimeter. See Defining the Job Perimeter (page 81).
See also Select Perimeter dialog box (page 193).

The job perimeter (page 213) select or digitized is stored in the
corresponding perimeter feature class. If perimeters intersect, a warning
is displayed. Perimeter intersections are allowed. To check whether the
intersection causes a conflict, use the Job Conflict Explorer (page 86).

Deleting Job Modifications

You can delete or undo any modifications that have been made in a job (page
215) that is still open. You can delete either all or some modifications.

See also:
B Managing Jobs (page 78)
B Creating a Job (page 79)
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Selecting a Job (page 81)
Defining the Job Perimeter (page 81)
Changing the Job State (page 83)

Resolving Job Conflicts (page 85)

To delete some modifications
1 Start the Job Manager (page 79).

2 In the Job Explorer (page 191), expand Jobs » Job States » Open and
select the job.

3 Right-click and click Delete Some Modifications.

The Delete Modifications dialog box shows all modifications down to
the feature level. They are grouped by event (for example, “inserted”) or
by feature class.

Use the toolbar icons to process the features. For example, select an item
and highlight it in the map. Then delete it.

Changing the Job State

You can change the job (page 215) state (job state transition) at the job level
or at the job topic (page 215) level. (Within a job, you can change the state
topic-wise).

Depending on how your administrator set up jobs, you may need a password
to change the job state. Define passwords for each job state transition in the
Job Administrator.

NOTE You can define intersections that are calculated when the job state changes.

Concurrent Jobs

When you change the job state, if the same feature has been modified or
deleted in different jobs, Topobase notifies you of any conflicts. You can
specify how to resolve them.

Partial Posting

Partial Posting is available for Pessimistic Feature Locking. While working in
a Job, you can set single features to live, for example to resolve Job conflicts,
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or to provide the live feature for other users. Partial posting extracts the feature
from the current job, creates a new job <job>_PP_x for the feature, and sets
this job to Live.

Job State Options

Depending on the current state and the job state transition definitions, your
options for the new job state vary.

Change the job state To:

from:

Open Pending

Pending Open

Pending Live

Live None (Live is Live!)
See also:

Managing Jobs (page 78)
Creating a Job (page 79)
Selecting a Job (page 81)

|
|
|
B Defining the Job Perimeter (page 81)
B Deleting Job Modifications (page 82)
|

Resolving Job Conflicts (page 85)

To change the job state

1 Optionally, run a data check before changing the job state.
See the Topobase Administrator Guide, section Topobase Data Checker.

2 Start the Job Manager (page 79).
3 Expand Jobs » Job States and select the job.

4 Right-click the job (or job topic (page 215)) and click Change State or
Change State per Topic.

5 Resolve any conflicts. (page 86)
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To change the job state for a selected feature (partial posting)
1 Start the Job Explorer.
2 Select the features.

J Merge Selected Merge Selected Features Into Live Jobs.

3 Click

NOTE Be sure to also merge related features, such as label features. Otherwise
the feature will still be locked.

Resolving Job Conflicts

Topobase supports two types of feature locking. The main difference is the
handling of job conflicts. A job conflict occurs if the same feature is modified
in different jobs (page 215).

Optimistic Feature Locking

If you work with several jobs, use these techniques to ensure that feature
modifications do not conflict with each other.

B Before you change the job status, check the job manually for conflicts.
(page 86)

B If you change the job status, the system automatically checks whether the
job contains features that were modified in other jobs.

B Use the Job Manager to check for job conflicts. (page 86)

Example
1 Create a job X, and modify feature 1000.
2 Create a job Y, and delete feature 1000.
3 Setjob X to pending. A warning is displayed.

4 Setjob Y to pending. This is not allowed because there is a job conflict.
Pessimistic Feature Locking

Pessimistic Feature Locking detects any job conflicts as early as possible. For
example, in Job A, you add a transformer on a pole. In Job B, User B selects
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the same pole to delete it from the database. User B is alerted immediately
that the feature is locked. User B cannot modify the feature.

To solve the job conflict, user B contacts you. You can jointly decide how to
proceed. For example, use the Partial Posting command to extract a the feature
from the current job and change its state to Live. Then, that feature can be
modified again in the other job.

See also:
Managing Jobs (page 78)
Creating a Job (page 79)

|

|

B Selecting a Job (page 81)

B Defining the Job Perimeter (page 81)
B Deleting Job Modifications (page 82)
|

Changing the Job State (page 83)
To manually check for job conflicts (Job Explorer)
1 Start the Job Explorer (page 79) E .

2 Click Check For Job Conflicts E .

3 Select the job state for the check.

To manually check for job conflicts (Job Manager)
1 Start the Job Manager (page 79).
2 Expand Jobs » Job States and select the job.
3 Right-click the job and click Check Job Conflict.
4

Select the jobs state for the check.

If conflicts are detected, they are displayed in the Job Conflict Explorer
dialog box (page 193).
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To validate job state changes

If a feature was modified in more than one job (page 215), the Concurrent Job
dialog box is displayed as soon as you change the job state of the first job.

B Click Yes to change the job state.

B The Job Conflict Explorer dialog box (page 193) dialog box is displayed to
change the second job state. Use the Conflict Explorer to resolve the
conflict.

To resolve a job conflict (partial posting)
1 Start the Job Explorer (page 79) g
2 Select the feature, and click Merge Selected Features To Live Job .

To manually lock features

In the Job Explorer (page 191), select the Locked Features node and click Lock

Features Q .

Creating a Historical Job View

You can show data as it was at a certain date, for example a year ago.

To create a historical job view
1 Start Job Manager.
2 In Job Manager, expand Jobs » Job States.
3 Select a job.
4 Click Data menu » Historical View.

5 Set a data, and click Set.
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Working with Profiles

Overview of Profiles

In Topobase, a profile is a longitudinal section of line features. You create a
profile by projecting features on an axis.

Use the Profile Manager (page 194) to create and modify profiles based on
profile definitions. You can create profiles for any linear features. Profile
definitions must be provided by your Topobase administrator prior to creating
profiles.

NOTE The Topobase Wastewater demo data set provides a sample profile
definition.

Use the Profile Manager dialog box (page 195) to set the profile properties and
select the features to draw in the profile.

See also:
B Drawing the Profile (page 89)

B Querying Information About Profile Objects (page 92)

To start the Profile Manager

1 Start Topobase Client and open a workspace (page 8), for example, a
wastewater workspace (page 216).

3

Generate

2 Click Home tab » Display panel » Generate Graphic. 6&reehic

3 Click Output tab » Reports and Profiles panel » Profile Manager (page

To edit or modify a profile

1 In the Profile Manager dialog box (page 195), click Profile menu » Select
Profile » From List.
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2 In the Profile List dialog box, select a profile (page 214) and click OK.

To create a profile

1 Inthe Profile Manager dialog box (page 195), click Profile menu » Create
Profile.

2 In the Profile Definition List dialog box, select a profile definition and
click OK.

Drawing the Profile

To create profiles (page 214), your Topobase administrator must first provide
pre-defined profile definitions. You can select the profile features, as for
example sections and manholes of a wastewater network, and the profile axis
in the map. Use either of the following selection processes.

Topological Selection With Intermediate Features

Use Topological Selection to specify the start and end feature, as well as an
intermediate feature. The function selects all network features between these
points by calculating the shortest path, according to the following guidelines:

B Between start point and the first intermediate point.
B Between the first intermediate point and the second intermediate point.

B Between the last intermediate point and the end point.
See the Topobase Administrator Guide, section Topology Reference.

Feature Selection in the Map

Use Feature Selection to select lines and points. You can draw a window to
select multiple features.
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Profile Axis

If you do not specify an axis explicitly, a default axis is used. The default is
calculated differently, depending on the feature selection process. Alternatively,
you can specify the profile axis in the map.

Axis Selection Process Determination of Default Axis
Topological Selection With Intermediate Determines the axis by network tracing.
Points See also Topological selection (page 91).
Polyline Digitization Digitizes the axis in the map.

The default axis can be determined only if the selected features are valid. The
default axis cannot be created in the following cases:

B The features are not connected.
B The point features are not on the line.

B The features are connected, but the direction cannot be determined. In
this case, you are prompted to specify the start feature.

When the main features and the axis have been selected, you can draw the
profile.

Invalid Features

During the profile calculation, the system validates the selected main features.
If invalid features are detected, use the Feature Explorer (page 162), the toolbar,
and the shortcut menu to process the features.

Invalid main features
B Points that cannot be vertically projected on the profile axis.

B Point and Lines without height information.

See also:
B Overview of Profiles (page 88)

B Querying Information About Profile Objects (page 92)
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To create a profile

1

10
11
12

Start Topobase Client and open a workspace (page 8), such as
Wastewater.

3

Generate .

Click Home tab » Display panel » Generate Graphic. Sraehic

Click Output tab » Reports and Profiles panel » Profile Manager (page

i

Profile
Manager

194).
Click Profile menu » Create Profile.

In the Profile Definition List dialog box, select a profile definition, such
as Wastewater Standard Profile. Click OK.

Enter a name, such as Wastewater Demo Profile.
Under Feature Selection, select an item, such as Feature Selection.

In the map, select the sections. You must select connected lines. Finish
the selection by pressing <Enter>. Cancel the selection by pressing <ESC>.

The selected features are displayed in the Adapting a Viewport for Feature
Highlighting (page 11).

Use the toolbar to highlight a selected feature in the map or to remove
it from the selection.

Click Draw Profile. Lt Follow the AutoCAD Map prompts.

In the map, digitize the profile origin.

Click OK to save the profile.
9 Indicates invalid or missing input. Use the tooltips for further
information.

The workflow (page 216) status indicates whether the workflow is done or
needs to be done.

The profile is created with a default axis. Optionally, specify the axis.
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To select the features with topological selection

1 In the Topological Selection dialog box, select a logical topology (page
213), such as WW.

2 Click Select A Start Feature. & Click the start node in the map.

3 Click Select An End Feature. & Click the end node.

4 Click OK to start the network tracing and transfer the result to the Profile
Manager.

You can select only features that are part of the selected topology (page
216). For example, if you select the Wastewater topology WW, you can
select network points (manholes and house connectors).

Querying Information About Profile Objects

You can query attribute data about the network objects that are represented
in a profile (page 214) drawing. For each profile feature, the data model stores
arelationship to the original network feature. You can identify a profile object
in the drawing and view the related attribute data.

See also:
B Overview of Profiles (page 88)

B Overview of Profiles (page 88)

To view information

1 Select a connection line in the profile drawing. For example, select a line
that represents a wastewater section.

©,

2 Click Home tab » Quick Access panel » Attributes, A&ributes

The form for the related feature class of the network object is displayed,
for example the Section feature class WW_SECTION.
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Topobase Plotting

Overview of Plotting

In Topobase, you can create plot layouts and save them as plot templates. Define
the map area and plot quickly and accurately. Topobase plots the current state
of the features on demand. You can print a plot or save it to a file.

NOTE Before you can plot in Topobase Client, your administrator must enable the
document for plotting.

A Topobase plot definition contains the settings for sending a map to a plotter.
It specifies the printer, paper size, and display model for the plot. It defines
elements such as a map placeholder, legend, north arrow, and scalebar. A map
placeholder is a frame that designates where a specific area of a map is shown
in the plot. You can define attributes for the map placeholder such as stylization,
scale, extents and rotation. One or more map placeholders can be shown in a
single plot. These elements are stored in a special feature class. Each plot
definition and plot template refers to a plot display model, which specifies the
visual style of the plot, for example, which block is used to represent the north
arrow or scalebar.

A plot template lets you specify some settings for all the plots that use that
template, while any unspecified settings can be set at plot time. For example,
you can specify the paper size, and elements for the plot, but each individual
plot can specify the printer to use and the insertion point and rotation for the
map placeholder.

You can create a plot that is based on a template or a blank page. In either case,
you can save and reuse plots.
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Plotting on the Web

If you are using Topobase Web, you can create plots from an existing template
or plot. You cannot create a plot from a blank page, and you cannot create a
plot template.

See also:

m Configuring Plots

B Creating a Plot (page 94)

B Creating a New Plot Using a Template (page 95)
B Working With the Plot Library (page 120)

Creating a Plot

The quickest and easiest way to print your map is to use an existing plot
definition. This refreshes the content of the map, showing what is currently
stored in the database without changing any plot settings.

If your administrator has created plot templates, you can plot quickly using
an existing template and defining specific settings at plot time. For more
information, see Creating a New Plot Using a Template (page 95).

If you need to specify all plot settings, you can plot with a blank layout. When
you plot using a blank layout, you must save the plot. See Creating a New Plot
Without a Template (page 97)

See also:

B Working With Plot Templates (page 111)

To plot a drawing using an existing plot definition

1 Display the Plot Explorer in the Topobase task pane using either of the
following methods:

3

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. Igﬂﬁ
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The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

2 In the Plot Library, display the Plot dialog box using either of the
following methods:

B Select an existing plot definition and click Plot at the bottom of the
Plot Library.

B Right-click an existing plot definition and click Plot.

3 Specify any printer settings, and send the plot to the printer.

Creating a New Plot Using a Template

In most cases you plot your map using an existing plot template from the Plot
Library. To define templates, see Working With Plot Templates (page 111).

When you create a new plot that uses a plot template, the plot inherits the
template settings and features. You cannot add features to a plot you create
with a template. However, you can modify the non-system attributes of some
features in their generic forms.

You can change the printer and paper for a specific plot, as long as you select
the same paper format as the one specified in the template.

If the plot template has blank values, you can specify those values for a specific
plot (except for grids and cross hair settings).

If you change the template after you create a plot from it, the plot does not
change. The connection between the template and the plot exists only during
plot creation.

See also:

B Creating Plot Templates (page 111)

B Creating a New Plot Without a Template (page 97)
B Batch Plotting (page 110)

To create a plot using a plot template

1 Generate graphics and zoom to the area of interest.
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2 Display the Plot Explorer in the Topobase task pane using either of the
following methods:

5

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. lﬁﬂﬂ

The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

3 In the Plot Library, open the Templates folder and right-click the plot
template to use.

4 Display the Plot - New dialog box using either of the following methods:
B At the bottom of the Plot Library, click Plot New.

B Select a template and click Plot New.

In the Plot - New dialog box, the plot template is already specified because
you selected it in the library. You can select a different template from the
library or None-Blank Layout to create a new layout. To create a plot from
a blank layout, see Creating a New Plot Without a Template (page 97).

5 Do either of the following:

B Rotate, scale, or move the map placeholder frame as desired using
grip points to define the portion of the map to plot.

B To specify a new map placeholder frame, click New Frame. Draw the
new frame.

The map placeholder is defined in the template. It is the container that
holds the map. The New Frame button lets you specify an area of the
map to display in the map placeholder. If a scale is specified in the
template for the map placeholder, you cannot draw a new frame.

You can also adjust the frame using the Scale, Rotation, and Map Insertion
Point settings.

If there are multiple map placeholders in your template, you are prompted
to specify the frame for each in turn.

6 For Map Style, select the display model for the data you are plotting.
Click Generate to see the display model.

Select Current Drawing as the Map Style to plot the current drawing and
include any style changes you have made that are not saved in a display
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model. Note that you cannot save the plot if you plot the current drawing
because these styles are not saved in the database.

7 If the display model supports island maps, you can create one by selecting
Create Island Map Now. Then click Next and specify the island map
settings.

For more information, see Plotting an Island Map (page 109).

To support Island Maps, the display model must contain at least one layer
from the feature class, PLT_PLOT_ISLAND_COVER.

8 If you plan to save the plot, select Save Plot Definition.

Enter a name for the plot. Click Browse and specify the plot library
location to store the plot. You can plot now or just save the plot. Select
Plot Now to save and plot.

9 Click Plot.
If you are saving and plotting, click Save & Plot.
The AutoCAD Plot dialog box is displayed. Click OK.

Creating a New Plot Without a Template

You can create an empty plot without using a template. For this type of plot,
you define all parameters when setting up the plot. The process is similar to
creating a new template.

See also:
B Creating a New Plot Using a Template (page 95)
B Batch Plotting (page 110)

To create a plot without a template

1 Display the Plot Explorer in the Topobase task pane using either of the
following methods:

N

Plot Explorar

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. Igﬂﬁ
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The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

2 Display the Plot - New dialog box using any of the following methods:

=

Plat New
. o Definition
B Click Output tab » Plot panel » Plot New Definition.

B At the bottom of the Plot Library, click Plot New.

B Right click the Plot Library node or a template and click Plot New.

3 In the Plot - New dialog box, for Plot Template, click None - (Blank
Layout).

4 Specify the following:

B Default Printer: Select a printer from the list. Do not select None unless
you want to specify a printer each time you use this plot. The None
option is not a true printer and cannot be used to send a plot to a
printer.

B Paper Format: Select a paper size from the list and click the icon
representing portrait or landscape orientation.

B Use An Existing Style For This Plot: In rare cases, you can select an
existing AutoCAD style sheet from this list. However, the appearance
of the plot is defined by the display model defined in the AutoCAD
Map 3D Display Manager. In most cases, you will leave this option
blank.

B Plot Display Model: Select the TBDM file that contains the set of
display styles to apply to the plot. This display model is not the one
used for the map, but rather for the plot elements. A sample plot
display model, Plot.tbdm, is installed with Topobase Client, and is
located in your default display model repository.

B Save Plot Definition - Name: Enter a name for the plot.

B Save Plot Definition - Location: By default, plots are saved in the Plot
Library\Plots sub-folder. If you have created sub-folders and want to
save your plot to one of them, click Browse and select the sub-folder
to use.
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B Advanced: Click the Advanced arrow and specify the initial scale and
initial origin for the plot.
The scale and origin specified here are not used for the maps contained
in the plot. These values are used only to create the initial template
features within the Topobase document's valid extents and the spatial
reference system assigned to it, if any.

5 To preview and create the plot, click Draw Layout.

This button is gray until you complete the settings for the plot. If it
remains gray, check to be sure that the advanced settings are not blank.

Topobase creates the plot and opens it in edit mode. Add the map
placeholder and other elements to the plot in model space. For an
explanation of the plot elements, see Plot Template Elements (page 112).

6 Add the map placeholder to the layout.
B In the Plot Explorer task pane, right-click Map Placeholder and select

Digitize Rectangle. (You might want to turn off AutoCAD OSNAP to
position the map placeholder as desired.)

B In the drawing, click where you want the lower left point of the map
placeholder rectangle, then click where you want its upper right
corner.

The new map placeholder feature is also displayed under the Map
Placeholder node in the Plot Explorer.

7 Capture the map.
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In the Plot Explorer task pane, under the Map Placeholder node, select
the new Map placeholder which you have just created. Click Capture
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Add labels to the template.
For example, add a title and a label that shows the captured map scale.

B In the Plot Explorer, open the Plot Labels item to see the label types
you can create.

B Right-click a label type and select Digitize.

B In the template drawing, specify the label insertion point and
orientation. Any other label settings are defined by the selected display
model.

B Press ENTER or ESC to finish the command.
The label feature is added to the Plot Explorer under the related Plot
Label node.

Optionally, add image placeholders.
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10

11

12

13

NOTE For the image placeholders, north arrow, legend, and scalebar, the
image's representation is determined by the selected display model. See
Overview of Display Models. You can configure the display model to use a
saved block. The block you use will depend on the feature's attributes. Both
the plot and the template use the same display model. For example, if the
display model specifies an AutoCAD block to use for scalebars and you digitize
a scalebar point in the template, the scalebar block will appear (instead of
the point) in your drawing.

B Right-click Image and select Digitize Point.

B In the template drawing, click the insertion point for the image block.

Add the legend.
B Right-click Legend and select Digitize Point.

B In the template drawing, click the insertion point for the legend.

Add the north arrow.
B Right-click North Arrow and select Digitize Point.

B In the template drawing, click the insertion point for the north arrow.
If you place this block on top of the map placeholder, it appears
superimposed on the drawing (if the display model specifies this
position in the draw order).

Add the scalebar.
B Right-click Scalebar and select Digitize Point.

B In the template drawing, click the insertion point for the scalebar.
You can place this block just above or below the Plot Scale element.

To adjust any element, select it and, on the Home tab of the ribbon, click
Attributes. In the Attribute dialog box, use the Form tab to make your
changes.

B You can change the size of the map placeholder, decoration lines,
and decoration polygon features.

B You cannot modify the values defined for a template's map placeholder
when you create a plot from this template. You can define grids and
cross-hair settings only for the first (main) map placeholder. If these
items are not defined in the template, you cannot set them in a plot
you create from this template.
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B To add a grid and grid crosses, in the Plot library, right-click the
placeholder and click Show Form. In the Map Placeholder form, click
the Details tab. Under Grids and Grid Cross Settings, specify the grid
settings. For more information, see Plot Extension.

B A label’s text is determined by its parent feature. For example,
modifying a plot's name will change any existing plot-name-label.
See Data Model: Labels.

B For images, legends, north arrows, and scalebars, you can change the
orientation and type.
For point features like images, north arrows and scalebars, you can
select a pre-defined type, if one exists. These types are determined by
Topobase domain tables. If you select a pre-defined type, you can
configure the display model to style the respective point feature with
a particular block. See “Styling a Scalebar Point Using a Specific
AutoCAD Block,” below, for an example.

14 When you have finished adding elements to your template, click Close
at the bottom of the Plot Explorer task pane to end plot edit mode.

The new plot definition is displayed in the Plot Explorer.

15 To send the plot to the printer specified in the template, do either of the
following:

B Click Plot at the bottom of the Plot Library.
B Right click the plot and click Plot.
The AutoCAD Plot dialog box is displayed.

Creating a Plot Using AutoCAD Blocks

In this tutorial, you will create a plot that uses an AutoCAD block as a frame,
instead of using the normal Topobase plot decoration features.

Prerequisites

To perform this tutorial successfully, you should be familiar with the following
aspects of AutoCAD, AutoCAD Map 3D, and Topobase:

B What AutoCAD blocks and AutoCAD block references are, and how to use
AutoCAD's block editor

B How to use the AutoCAD Map 3D Display Manager
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How to use Topobase workspaces, documents, feature classes, features, and
generic forms

How to create a Topobase display model and set up a repository path

How to create and edit a Topobase plot, and use the Plot Library

Assumptions

Before performing this tutorial, the following should be true:

You have created a workspace.

You have imported the Land Management demo dump shipped with
Topobase 2010 and named the document PLOT_ACADBLOCKS.You have
enabled the Topobase Plot Extension for that document.

You have set up the repository path for your display models correctly.

You have copied the default display model for plots, shipped with Topobase
2010, to a sub-directory of your display model repository path, and adjusted
all settings.

To create a plot using AutoCAD blocks

In Topobase Client, create a new plot.
B Use the settings shown below.
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T Plot - New

Flot termplate:

Mone - [blank lapout) ]

Define the plot setup and start drawing the layaut

Drefault printer:

['wFE ePlot DETE.pc3 v

Orientation:
Paper farmat:

IS0 A4 (287.00 210,00 MM) v

Use an existing style for this plat;

Flot Dizplay model:
Land ™

Sawve Plot Definition

Mame:
Acad Block Test1: 1000

Location:
Flot Library
~ Advanced

Plot initial scale:
1: 1000

Plot initial origin:
« |500000 y | 200000

[ Diraws Layaut ] [ Cancel ] [ Help ]

B Click Draw Layout to open the plot for editing.

B Close all open drawings except the one that contains the newly created
plot.

2 In the newly created plot drawing, type BEDIT to open the AutoCAD Block
Editor.

B Create a new AutoCAD block that is 297 units wide and 210 units tall
(A4).

B Set the block’s base point to its center.
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B Close the block editor.

3 Style the layer PLT_PLOT_DECORATION.
B In the Display Manager, select the layer and click Style.

B In the Style Editor, under Point style O - Infinity Scale Range, click the
browse button in the column labeled Style.Set the parameters as
follows:

Symbol: Select the block you just created from the current drawing.
Size Context: Map space

Units: Meters

Width: 297 (A4, 1:1000)

Height: 297 (this is set automatically when you set the width)
Fill color: Keep the original color.

Edge Color: Keep the original color.

Rotation: Enter the expression ORIENTATION * 0.9 + 90
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4 Save the current display model, overwriting the existing plot display
model.

This creates a new drawing named BlockDefinitions.dwg, which contains
the block you just created.

5 Digitize a new plot point decoration feature, as shown below.
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6 Open the generic form for this point feature, and set its position to the
center of the page, as shown below.
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Once updated, the AutoCAD block will be centered on the paper.

The point decoration feature is styled using the AutoCAD block you
created. This AutoCAD block has its base point set at its center. Because
the point decoration feature is centered on the paper, the AutoCAD is
correctly positioned.

7 Optionally, create a (primary) map placeholder and set it to a pre-defined
width and position.
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B Capture the map for this map placeholder.
B Specify an existing display model.

B Apply a rotation value, if necessary.

8 Optionally, extend the plot by adding a label for the plot’s scale, an
overview map, and any other desired elements.

The plot shown here is scaled at 1:1000.
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Plotting an Island Map

In some places, surveyors are legally required to show where a particular region
ends and another begins. In order to do this, you can place a “mask” over the
irregular area that defines the region in question. This mask is called an island.
It is a solid layer with a hole that allows the region to show through.

You can define an island from polygon feature classes only. This includes
normal polygon feature classes and area topologies (as they are polygon feature
classes, too). For example, if you are designing a new development, you might
define a feature class called DevelopmentPerimeter that defines an area
topology based on the outline surrounding the development. You can then
create an island based on the DevelopmentPerimeter feature.

For islands to show up properly on a plot, the Topobase Administrator must
define a draw order for the plot display model so that the islands lie on top
of the features they are meant to cover.

To capture an island for a plot, you must first capture the map specified by
the plot or template you are using.

See also:
B Creating a New Plot Using a Template (page 95)

B Creating a New Plot Without a Template (page 97)

To set an island map for a plot

1 Create the plot.

For a detailed procedure for creating a plot, see Creating a New Plot Using
a Template (page 95).

The display model you use during this capture must contain all layers
(plot layers, GIS layers, and the layer that will make up the covering areas,
or “masks”). If you created an island map plan, the display model
originally assigned to the plot will not be considered. Only the display
model of the map placeholder is considered. That is why it must contain
the plot layers, too.

2 In the Capture Map Settings dialog box, click the arrow on the Capture
Map button and select Set Island Map.

3 In the Island Map Settings dialog box, select the polygon feature class to
use as the basis for the island.

The options in the list are determined by the Topobase Administrator.
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4 To expand the island in or out from the selected feature or topology, set
a buffer distance by clicking Advanced Settings and entering the distance
settings.

5 Click Select and click the location where the island map should be created.
If Topobase finds a feature at the selected location, it will display an
AutoCAD hatch. You can create multiple island masks on the same plot.

6 Click Create to capture the island.

Batch Plotting

When you use batch plotting, you can select multiple plots to send to the
printer.

See also:
B Creating a New Plot Using a Template (page 95)

B Creating a New Plot Without a Template (page 97)

To batch plot

1 Display the Plot Explorer in the Topobase task pane using either of the
following methods:

=

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. IFN

The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

2 In the Plot Library, select multiple plots.
To select multiple plots, hold down the Ctrl key as you click each plot.
The plots you select can be in different folders.

3 At the bottom of the Plot Library, click Batch Plot.

Batch Plot appears at the at the bottom of the Plot Library when you
select multiple plots.

To change which plots are selected, move them between the lists in the
Batch Plot dialog box. To add a plot, click it in the left-hand list and click
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the right arrow. To delete a selected plot from the batch-plot list, select
it in the right-hand list and click the left arrow.

To send all the selected plots to a single printer, select the target printer
from the list under Printer/Plotter.

If you do not select a single printer, each plot is sent to the printer
specified in the plot or its template.

5 Click OK to print all the plots.

Working With Plot Templates

Use plot templates to store basic settings and elements that you can use for
multiple plots.

Creating Plot Templates

NOTE This procedure should be performed by an administrator.

Each plot inherits the settings of the plot template that is used to define it.
When you define a plot from a plot template, the following is true:

You can modify some attributes, but generally not those defined in the
template. There are a few exceptions. If a value cannot be modified, its
control is grayed in the generic form. See Using Feature Class Forms (page
32).

You cannot add any feature such as images, north arrows, decorations,
and so on.

You cannot add any labels that were not already defined in the template.
For example, if the template did not specify a label for the plot's name, it
cannot be added to the plot instance.

Plot templates ensure consistency across an organization, and are usually
defined by administrators.

A template always specifies the paper size, orientation, and stylization for the
plot. When you create an individual plot using a template, you cannot change
those settings. Other settings in a plot template can be specified or left blank,
for example, the scale used for a map placeholder or the layout of the maps
on the page and how each map is styled. If you specify these settings in the
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template, you will not be able to override them when you create a plot with
that template. If you leave such settings blank, you must specify them each
time you create a plot with that template.

Use plot templates to store the settings for multiple plots, for example several
plots at a scale of 1:5000 at a certain size. Individual plots use the scale, layout,
and settings from the template, but specify a different location or updated
data. For example, you can produce current plots every month to send updated
data to your civil engineers.

Plot Template Settings

A plot template can include any of the following settings:

B Printer, paper size, and orientation: You must specify these in the template.
When you create a plot with this template, you can change the printer,
but the plot will always use the template’s paper size and orientation.

B Plot style: In rare cases, you can select an existing AutoCAD style sheet for
a template. However, the appearance of a plot is defined by the display
model defined in the AutoCAD Map 3D Display Manager.

B Display model: An XML file that holds a collection of display styles. The
display model for the plot is different from the one used for the map you
are plotting. The plot display model specifies the appearance of the plot
elements, for example, the block used for the scalebar. For more
information about display models, see Overview of Display Models.

B Scale and origin: An initial valid scale and insertion point for the plot
(point) feature. These values depend on the Topobase document in which
the new template is stored. Typically, they are pre-defined in Topobase
Administrator. You do not need to set them when creating the template.
The values are used to create the initial plot/template features in the
database. You define the actual insertion point and the scale of the Map
Placeholder when you capture the map for the plot.

Plot Template Elements

The elements in the plot template are objects that you can style. They are
stored in the Topobase database as a special feature class. A plot template can
include any of the following elements:

B Map placeholder: A viewport that displays the portion of the drawing that
you capture when you create a plot. You can rotate, move, or scale the
map placeholder using grip points to capture the specific area of interest.
To create a template that contains a specific map, first define the map
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placeholder, next, select the map placeholder in the Plot Explorer, and
then capture the map. This area of the map will always appear in the
template. For example, you might create a template with two map
placeholders: one for the user to define the portion of the map to capture
at plot time, and the other to hold a specified overview map that is captured
and saved with the map placeholder during tempate creation.

Map placeholders are rectangular. To create a map placeholder that is not
a rectangle, do one of the following:

B Use the Display Manager to place a white custom shape on top of the
map placeholder.

B Create an island map for this purpose. An island map has irregular
borders defined by a perimeter feature class or a topology. For more
information about creating islands, see Plotting an Island Map (page
109).

Images: Points that are stylized by the display model. The Display Model
must refer to a block that contains vector data. Unlike map placeholders
which are going to be populated with the current data from the database,
the images are static. Raster images in AutoCAD blocks are not supported.

Legend: A simple point that can be styled to use a defined legend block.

North arrow: A simple point that is styled according to the selected display
model for this plot. If you style it to use an AutoCAD block, the block will
appear at the position of the point feature. See Overview of Display Models.

The north arrow feature will always have a rotation of 0°, even if the entire
plot is rotated. If you use an AutoCAD block to style it, the block will always
point in the northing direction, so it will appear to rotate (while all other
plot elements, such as the legend, decorations, and so on, will remain
aligned with the paper). For example, if you capture a section of the city
and rotate it so that north is at 10 degrees, a north arrow using an AutoCAD
block will show north at ten degrees.

Scalebar: A simple point that can be styled to use a defined scalebar block.

NOTE The blocks used for template elements are AutoCAD blocks. The Topobase
administrator specifies a location for these blocks, and may install standard blocks
in that location for you to use in your display models. See Overview of Display
Models.
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Plot Template Text Elements

Text elements in the plot template can include any of the following elements:

Plot Label: A Topobase label. Displays dynamic information that is specific
to each plot, such as the scale. To populate the label, you must enter an
attribute. By default, labels can be created for the plot’s name and scale.
For other types of label, create an appropriate label definition in Topobase
Administrator. See Data Model: Labels.

Decoration Text: Displays static text that does not change with each plot,
for example “Date:”. The actual date would be displayed as a dynamic
label. Unlike plot labels, decoration text does not require a label definition.
In your display model, you style the Decoration Text as annotation layer.
See Plot Display Models.

Plot Decoration Label: Displays any kind of dynamic label information
related to a decoration feature. Because the Decoration feature class is of
type Collection, it cannot be used for static text information.

See also:

Creating a New Plot Using a Template (page 95)
Managing Plot Template Folders (page 121)
Creating a New Plot Without a Template (page 97)

Plot Reference

To create a plot template

NOTE This procedure should be performed by an administrator.

1 Display the Plot Explorer in the Topobase task pane using either of the

following methods:

53

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. lﬁﬂ

The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.
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2 In the Plot Library, right-click the Templates folder and click Create New
Template.

3 In the Create New Template dialog box, specify the following:

B Default Printer: Select a printer from the list. The selected printer
determines the available paper format choices. The None option is
not a true printer and cannot be used to send a plot to a printer.
However, you can use it to create a template. When you create a plot
with such a template, you must specify a printer in the plot instance.

B Paper Format: Select a paper size and click the icon representing
portrait or landscape orientation.

B Use An Existing Style For This Plot: In rare cases, you can select an
existing AutoCAD style sheet from this list. However, the appearance
of the plot is defined by the display model defined in the AutoCAD
Map 3D Display Manager. In most cases, you will leave this option
blank.

B Plot Display Model: Select the TBDM file that contains the set of
display styles to apply to the template. This display model is not the
one used for the drawing, but rather for the plot elements.

B Name: Enter a name for the plot template.

4 Location: By default, plots are saved in the Plot Library. If you have created
sub-folders and want to save your plot to one of them, click Browse and
select the sub-folder to use. Templates must be stored in template folders
to be recognized as templates. For more information about creating
template folders, see Managing Plot Template Folders (page 121).

5 Advanced: Click the Advanced arrow to specify the scale and origin for
the plot.

This is required only if the fields are blank. The scale and origin specified
here are not used for the maps contained in the plot. These values are
used by Topobase only to create the initial template features within the
Topobase document's valid extents and the spatial reference system
assigned to it, if any.

Typically, the Topobase administrator sets the scale and origin, which
must match the Topobase document's extension settings or a spatial
reference system. Do not change these settings unless the administrator
tells you to. If the values are wrong, the plot creation will fail.

6 Click Draw Layout to see the blank template canvas.
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This button is gray until you specify a name, paper format, and default
printer for the plot template. If it remains gray, check to be sure that the
advanced settings are not blank.

Topobase creates the template and opens it in edit mode. You can now
add the map placeholder and other elements to your layout. For an
explanation of the template elements, see Plot Template Elements (page
112). After you close template edit mode, you can later return to edit mode
to make changes. Select the template in the plot library and click Edit
from the Preview/Edit split button at the bottom of the Plot Library.

7 Add the map placeholder to the layout.

B Right-click Map Placeholder and select Digitize Rectangle. (You might
want to turn of AutoCAD OSNAP to position the map placeholder as
desired.)

B In the template drawing, click where you want the lower left point
of the map placeholder rectangle, then click where you want its upper
right corner.

B Press Enter to complete the map placeholder.

Create additional map placeholders as needed. You can capture a fixed
portion of the map, for example, to create an overview map. In the Plot
Explorer task pane, select the newly created map placeholder node in the
tree view and click Capture Map. Rotate, scale, and move the map
placeholder frame as needed using the grips. The captured area of the
map will always appear in the template. In the Capture Map Settings
dialog box, click Save Capture.

8 Add dynamic labels to the template.

For example, add a title and a label that shows the captured map scale.
B Open the Plot Label item to see available label types.
B Right-click a label type and select Digitize.

B In the template drawing, specify the label insertion point and
orientation. Any other label settings are defined by the selected display
model.

9 Add static labels to the template.
For example, add an approval remark.

B Right-click the Decoration Text item. Click Add Text.
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11

12
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B In the template drawing, specify the text insertion point and enter
the text.
By default, reference records are used to provide some style options.
Select a style option. For more information about reference records,
see Using Reference Records (page 37).

After you add decoration text, reposition it if necessary using Edit
Geometry or using the positioning attributes in the Decoration Text
form. To adjust the text style and size, use the Text Style and Text
Size attributes in the Decoration Text form.

Optionally, add image placeholders.

NOTE For the image placeholders, north arrow, legend, and scalebar, the
image's representation is determined by the selected display model. See
Overview of Display Models. You can configure the display model to use a
saved block. The block you use will depend on the feature's attributes. Both
the plot and the template use the same display model. For example, if the
display model specifies an AutoCAD block to use for scalebars and you digitize
a scalebar point in the template, the scalebar block will appear (instead of
the point) in your drawing.

B Right-click Image and select Digitize Point.

B In the template drawing, click the insertion point for the image block.
Add the legend.

This placeholder is inserted as a point.

B Right-click Legend and select Digitize Point.

B In the template drawing, click the insertion point for the legend.
Add the north arrow.

This placeholder is inserted as a point.

B Right-click North Arrow and select Digitize Point.

B In the template drawing, click the insertion point for the north arrow.
If you place this block on top of the map placeholder, it appears
superimposed on the drawing (if the display model specifies this
position in the draw order).

Add the scalebar.
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This placeholder is inserted as a point.
B Right-click Scalebar and select Digitize Point.

B In the template drawing, click the insertion point for the scalebar.
You can place this block just above or below the Plot Scale element.

14 To adjust any element, select it and, on the Home tab of the ribbon, click
Attributes. In the Attribute dialog box, use the Form tab to make your
changes.

B You can change the size of the map placeholder, decoration lines,
and decoration polygon features.

B You cannot modify the values defined for a template's map placeholder
when you create a plot from this template. You can define grids and
cross-hair settings only for the first (main) map placeholder. If these
items are not defined in the template, you cannot set them in a plot
you create from this template.

B To add a grid and grid crosses, in the Plot library, right-click the
placeholder and click Show Form. In the Map Placeholder form, click
the Details tab. Under Grids and Grid Cross Settings, specify the grid
settings. For more information, see Plot Extension.

B A label’s text is determined by its parent feature. For example,
modifying a plot's name will change any existing plot-name-label.
See Data Model: Labels.

B For images, legends, north arrows, and scalebars, you can change the
orientation and type.
For point features like images, north arrows and scalebars, you can
select a pre-defined type, if one exists. These types are determined by
Topobase domain tables. If you select a pre-defined type, you can
configure the display model to style the respective point feature with
a particular block. See Styling a Scalebar Point Using a Specific
AutoCAD Block (page 119) for an example.

15 When you have finished creating the layout, click Close.

The template is now ready to use for plotting. After you close template
edit mode, you can later return to edit mode to make changes. Select the
template in the plot library and click Edit from the Preview/Edit split
button at the bottom of the Plot Library.
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Styling a Scalebar Point Using a Specific AutoCAD Block

The following example explains how to style a scalebar point feature using
the AutoCAD block defined in a display model. It assumes that you have
already created a template with a scalebar feature.

To style a scalebar point feature with a specific block
1 In Topobase Administrator, add the value Black scalebar (1:1000) to the
domain table Plot scalebar type.

Enter an ID greater than or equal to 10,000, so it does not interfere with
system IDs used within Topobase. See Data Model: Domain Tables.

2 In Topobase Client, use the Display Manager to modify the plot display
model (the one that contains the styles for the plot or template layout).

B Add a rule for the Scalebar layer (the feature class
PLT_PLOT_SCALEBAR) that applies only to scalebar features that have
an ID_SCALEBAR_TYPE attribute set to 10,000, which is the ID of the
domain entry Black scalebar (1:1000).

B Set the size on the AutoCAD block to reflect the template's actual
scale, so the scalebar will have the correct size on the plot.

3 In Topobase Client, set the scalebar type in the template.
B Open an existing template for editing.
B Open the generic form for an existing scalebar feature.
B Click Edit Record in the dialog box toolbar.
|

For Scalebar Type, select Black scalebar (1:1000).

4 Click Update.

Importing And Exporting Plot Templates

You can export and import plots and plot templates for exchange across
documents. Plots are exported to a plot XML file (.tbplx). When you import
or export a plot or plot template, the display model is not imported or
exported.
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To export plot templates

1

Display the Plot Explorer in the Topobase task pane using either of the
following methods:
)

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. lﬁﬂﬂ

The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

In the Plot Library, right-click the Plot Library node, the Templates node,
a template, or a plot. Click Export.

Select the plot templates or plots to export.
Click Browse and specify the location and name for your export file.

Click Export.

To import plot templates

1

Display the Plot Explorer in the Topobase task pane using either of the
following methods:

=

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. Igﬂh

The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

In the Plot Library, right-click the Plot Library node, the Templates node,
a template, or a plot. Click Import.

Select the file to import. Click Import.

Working With the Plot Library

Use the plot library to organize plot templates and plots. For example, create
sub-folders for different types of plots and store templates for a particular plot
type in a sub-folder within that plot folder.
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Managing Plot Template Folders

NOTE This procedure should be performed by an administrator.

The Plot Library has a default Templates folder for plot templates. You can
create a new template folder for each plot folder in the library. For example,
if you group your plots by scale settings, you can create a plot folder for 1:5000
scale plots, and then create a template folder within that plot folder for 1:5000
plot templates.

You can rename or delete plot template folders. If you delete a plot template
folder, all its contents are also deleted.

See also:
B Working With the Plot Library (page 120)
B Managing Plot Templates (page 122)

B Managing Plots (page 124)

NOTE This procedure should be performed by an administrator.

To create a plot template folder

1 Display the Plot Explorer in the Topobase task pane using either of the
following methods:
<

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. IEN

The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

2 In the Plot Library, right-click a plot folder and click Create New Template
Folder.

NOTE If you right-click the Plot Library folder, the new template folder is on
the same level as the default Templates folder.

By default, the new folder is called Templates.
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To rename a plot template folder
1 In the Plot Library, right-click the template folder and click Show Form.

2 Enter a new name and click Update & Close.

To delete a plot template folder
1 In the Plot Library, right-click the template folder and click Delete.

2 On the confirmation message, click Yes.
Any templates within the folder are also deleted.

Managing Plot Templates

NOTE This procedure should be performed by an administrator.

You must store new plot templates in template folders only. If you add a
template to a regular plot folder, you cannot use it as a template.

By default, there is a single template folder called Templates. You can create
a template folder inside any plot folder, but you can have only one template
folder in any normal plot folder. For information on this, see Managing Plot
Template Folders (page 121).

You can rename or delete plot templates. Plots that use a deleted template are
unaffected. They continue to use the settings that were originally specified
by the deleted template.

See also:
B Working With the Plot Library (page 120)
B Managing Plot Template Folders (page 121)

B Managing Plots (page 124)

NOTE These procedures should be performed by an administrator.
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To edit a plot template

1 Display the Plot Explorer in the Topobase task pane using either of the
following methods:

=

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. lgﬂﬂ

The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

2 In the Plot Library, select the template and click Open In Editor (at the
bottom of the Plot Library).

The selected plot template opens as a preview, showing the model tab
by default.

To rename a plot template
1 In the Plot Library, right-click the template and click Show Form.

2 Enter a new name and click Update & Close.

To delete a plot template
1 In the Plot Library, right-click the template and click Delete.

2 On the confirmation message, click Yes.
Plots that use a deleted template are unaffected. They continue to use

the settings that were originally specified by the deleted template.
To move a plot template to a different folder, do either of the following
m [n the Plot Library, drag the template to the target template folder.
B In the Plot Library, right-click the template and choose Cut. Right-click
the target template folder and click Paste.
To copy a plot template to a different folder

B [n the Plot Library, right-click the template and choose Copy. Right-click
the target template folder and click Paste.
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Managing Plots

You can create sub-folders for different types of plots. Each time you create a
new plot, you are prompted for a location in which to store it. You must select
a plot folder (not a template folder) for saved plots.

You can rename, cut, copy, paste, link, and delete plots.

See also:
B Working With the Plot Library (page 120)
B Managing Plot Template Folders (page 121)

B Managing Plot Templates (page 122)

To create a new plot folder

1 Display the Plot Explorer in the Topobase task pane using either of the
following methods:

=)

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. Iﬁﬂﬁ

The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

2 In the Plot Library, right-click a plot folder and click Create New Folder.

NOTE The new folder is always created as a sub-folder of the one you
right-clicked.

To edit a plot

1 Display the Plot Explorer in the Topobase task pane using either of the
following methods:

Plot Explorer

B Click Output tab » Plot panel » Plot Explorer.

B Click Plot Explorer in the Topobase task pane. Iﬁﬂh
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The Plot Explorer pane opens to display your Plot Library. The Plot Library
contains plot templates and any plots you have saved.

2 Inthe Plot Library, select the plot and click Open In Editor (at the bottom
of the Plot Library).

The selected plot opens as a preview, showing the model tab by default.

To rename a plot
1 In the Plot Library, right-click the plot and click Show Form.

2 Enter a new name and click Update & Close.

To delete a plot
1 In the Plot Library, right-click the plot and click Delete.

2 On the confirmation message, click Yes.

To move a plot to a different folder, do either of the following

B In the Plot Library, drag the plot to the target plot folder.

B In the Plot Library, right-click the plot and choose Cut. Right-click the
target plot folder and click Paste.

To copy a plot to a different folder

® [n the Plot Library, right-click the plot and choose Copy. Right-click the

target plot folder and click Paste.

To copy the link of a plot to a different folder
Use the Copy Link command to reference a plot in multiple plot folders.

B [n the Plot Library, right-click the plot and choose Copy Link. Right-click
another target plot folder and click Paste.

Make sure that you select a target plot folder that is different from the original
plot folder. Otherwise no link will be pasted. Copy Link does not create a copy
of the plot, but adds a reference of the plot.
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Using Topobase
Construction and
Calculation Commands

Overview of Construction

Autodesk® Topobase™ provides construction and calculation functions (COGO),
which can be used with AutoCAD® Map 3D and Autodesk MapGuide® as
graphical front end.

Construction functions have direct access to the database. Existing coordinates
are retrieved and results are directly stored in the database.

Optionally you can generate detailed construction reports.

NOTE You can use the COGO commands in a document that is 3D enabled, however
the following commands do not support 3D: Arc Intersection, Orthogonal
Calculation, Polar Calculation, Offset, Right Angle Course, Free Standpoint.

Workspaces (page 216) can be created and configured with Topobase
Administrator.

Basic Handling

Topobase construction functions work in close interaction with Autodesk Map
or MapGuide commands. There is a frequent interchange between the Autodesk
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command line and the construction dialog boxes and the user alternately
gives input to both parts.

B When you start a construction command, you normally are prompted to
select the elements in the drawing or in the map. Be sure to watch the
command line.

m All elements of the calculation (such as arcs, circles, and points) appear
temporarily in the drawing.

NOTE These elements are Topobase features and are stored in the database.

B As soon as the required elements are selected, the focus changes to the
relevant construction dialog box.

B The construction dialog box displays all construction elements, parameters
and results, such as point coordinates, radius, or distance. You can modify
the parameters and calculate again.

B After the re-calculation the drawing is updated with the new result.

B When you are ready, you can save the result in the database.

NOTE If you press <ESC> instead of selecting an element, the construction dialog
box is displayed immediately without prompting.

NOTE Some construction functions have no dialog box and run completely
through the command line.

See also:
B Construction Dialog Boxes (page 197)

B Construction Settings (page 129)

To COGO enable Topobase construction commands

B Use Topobase Administrator to add the COGO extension.

To use Topobase construction commands

B Click the Tools tab » COGO panel.
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Construction Reference

Construction Settings

The Topobase construction functions require some general settings in the
application options. General settings and options can be specified with
Topobase Administrator.

Construction Feature Classes

The construction elements (lines, points, and text) appear temporarily with
the help of special construct feature classes. They are removed from the drawing
as soon as you save the new elements and quit or close the dialog boxes.

NOTE Use Document Setting in Topobase Administrator to add construction
feature classes.

Make sure that the newly created feature classes are visible in the selected
explorer group and that an appropriate stylization has been defined in the
Display Model.

Construction Reports

Topobase provides construction reports that have been defined with the
Topobase report designer. If necessary you can import these reports from the
<topobase_administrator> template folder.

COGO reports

B ARC Intersection
m Center

Free Standpoint
General
Intersection
Orthogonal
Polar

Projection

Snap_Trim
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Construction and Dimensioning

When you use Orthogonal Calculation or Arc Intersection, you optionally
create dimensioning for the calculated points. In the construction dialog box,
under Save Options, select Save The Dimension Features.

NOTE For Arc Intersections, when calculate the tangentials, you cannot create
dimensioning.

See also:

B Setting COGO Application Options

COGO And Dimensioning Document Options
Create New Document Dialog Box

Constructions: Reports (page 149)

Data Model: Dimensioning

Constructions: Intersection

Use the intersection function to calculate the intersection of two elements
(straight lines or circular arcs) or to connect two elements by a tangent or
circle (tangential).
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Intersections between lines and arcs

The intersection elements can be specified in various ways, for example:

B Identify an element in the drawing by a mouse click.
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B Identify an element by two points
B Identify an element and shift it by an offset value.

B Specify an element by point and orientation.

Intersection Elements

To calculate an intersection between two straight lines
1 Open a workspace and generate graphic.
2 Click Tools tab » COGO panel » Intersection.

3 In the map: Select element 1: The element with its determining points
P1 and P2 is highlighted in the drawing.

4 Select element 2. The element with P3 and P4 is highlighted. The
Intersection dialog box (page 200) is shown.

5 In the Intersection dialog box, do the following:

B Under Save Options, select the feature class to store the intersection
point.

B Click Save Inters 1 to store the point in the database.
You can now quit or calculate other intersections.

B Cick Reset to reset the intersection parameters. You can now select
new elements in the map.
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6 Select element 1.

7 Select element 2.

The Intersection dialog box redisplays.

8 In the Intersection dialog box, do the following:

In the Intersection 1 row, click the Reverse icon to switch to Tangential
mode.

Enter a radius for the tangent to be calculated.

Click the Calculate button to calculate the tangent with the modified
parameters.

Click the Show Next Reverse icon to show all possible locations of
the tangential arc.

Select the feature class you want to store the tangent in.

Click the Save Inters. 1 button to store the arc in the database.

Constructions: Arc Intersection

Use the arc intersection function to calculate intersections of two circular arcs.
Optionally you also can determine the tangents to the arcs.
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Arc Intersection elements

See also:

B Construction Settings (page 129)

To calculate intersections of two circular arcs
1 Open a workspace and generate graphic.
Click Tools tab » COGO panel » Arc Intersection.
In the map, select the center of arc 1.
Select the radius of arc 1.
Select the center of arc 2.
Select the radius of arc 2.

In the Arc Intersection dialog box (page 201), select the feature class.
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Click Reverse in the Intersection 1 row to switch to intersection type
Tangentials.

9 In the Tangent line: Enter a radius for the tangents, if you want to
calculate an arc. Note, that the feature class list box now shows the
available line string feature classes.
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10 Click the Reverse icon in the Intersection 1 row to switch to intersection
type Points.

11 Click File menu » Save to save both results.
You can now quit or calculate other intersections.

12 Click Reset to reset the arc intersection parameters. Select new elements
in the map.

Constructions: Orthogonal Calculation

Use the Orthogonal Calculation function for orthogonal surveying. The base
element is either represented by an existing line or it can be defined by using
two points which can lie aside. When calculation is performed, measured and
calculated dimensions are taken into account.
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base line

Orthogonal calculation elements

See also:

B Construction Settings (page 129)

To calculate orthogonal points

1 Open a workspace and generate graphic.
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2 Click Tools tab » COGO panel » Orthogonal Calculation.

3 Inthe map, select the base element. The line is highlighted in the drawing
with the abscissa values at the starting and end point. The construction

dialog box is opened.

4 In the Orthogonal Calculation dialog box (page 201), click the Reverse

icon ﬁ of the Azimuth column to interchange start and end point.

5 To calculate new points, type the abscissa and ordinate value and click
Calculate. The result is highlighted in the drawing.

6 To save the new point in the database, select a feature class and click Save

Point.

Constructions: Polar Calculation

Use the Polar Calculation function for polar surveying. The base element is
either represented by an existing line or it can be defined by using two points

which can lie aside.

, azimuth
] /

base element P1-P2

Ip2

base angle
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Polar calculation elements
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To perform a polar calculation

1
2
3

Open a workspace and generate graphic.
Click Tools tab » COGO panel » Polar Calculation.

In the map, select the base element. The line is highlighted in the drawing
with the distance between station and connection end point. The
construction dialog box is opened.

In the Polar Calculation dialog box (page 203), click the Reverse icon ﬁ
of the Azimuth column to interchange station and connection point.
Enter the base angle.

To calculate new points, enter the distance and angle value and click
Calculate. The result is highlighted in the drawing.

To save the new point in the database: Select a feature class and click
Save Point.

Constructions: Orthogonal Projection

Use the Orthogonal Projection function to determine the orthogonal projection
point on lines and arcs.
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Projection elements

Constructions: Orthogonal Projection | 137



To determine the orthogonal projection point on lines and arcs
1 Open a workspace and generate graphic.
2 Click Tools tab » COGO panel » Orthogonal Projection.
3 In the map, select the base element.
4

Select the projection point. The construction elements are highlighted
in the drawing.
The Orthogonal Projection dialog box (page 204) is opened.

5 To save the new point in the database, select a feature class and click Save
Point.

Constructions: Snap and Trim

Use the Snap and Trim function for line feature processing. You can trim or
extend a line so the end point lies exactly on a base line. This is often used to
create correct topologies or to correct inaccurate data acquisition.

BASE ELEMENT

P1

feature to be modified trim

Snap and trim elements

To use the Snap and Trim function for line feature processing
1 Open a workspace and generate graphic.

2 Click Tools tab » COGO panel » Snap.
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3 In the map, select the base element.

4 Select the line feature to be modified. The elements are highlighted in
the drawing.

The Snap and Trim dialog box (page 205) is opened.

5 To save the modifications in the database click Save Feature.

Constructions: Offset (Line Calculation)

Use the Offset function to calculate lines with any offset, based on an existing
line.

base feature

end abscissa

start abscissa
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Line offset calculation

To calculate lines with any offset, based on an existing line
1 Open a workspace and generate graphic.
2 Click Tools tab » COGO panel » Offset icon.

3 In the map, select the base line. You can only select lines that are saved
in the database.

The line and its start and end point are indicated in the drawing and the
Line Offset Calculation dialog box (page 206) is opened.

4 In the dialog box, click Add.
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5 In the map, click to specify the distance of the first offset line. Click for
the next line. Right-click to finish the entry.

In the dialog box, modify the parameters of the shifted lines.
Click Calculate to see the results in the drawing.

Select a feature class.
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Click Save Features to save into Topobase.

Constructions: Line Processing (Vertices)

Topobase provides several functions to process Topobase line features. You
can add or remove vertices of lines that are stored in the database.

NOTE These functions are run on the AutoCAD command line.

., splitting point
I:\_><_/"

R
before: one line string
w T

after: two line strings

Line processing example: Split line creates two line features.
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Line processing example: Add vertex inserts a new vertex. The lines
move to the point.

Icon

Description

M

Use Split to add a vertex and split an exist-
ing line into two line features that both
inherit the attribute data of the existing
feature. You can select an existing point or
digitize any point in the drawing.

A

Use Add Vertex to add a vertex to a line
feature. Contrary to the split function there
will be one line feature with a new vertex.
You can select an existing point or digitize
any point in the drawing.
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ﬁ Use Remove Vertex to remove a vertex.

To split a Topobase line feature with two or more vertices

1

2
3
4

Open a workspace and generate graphic.
Click Tools tab » COGO panel » Split.
In the map, select the feature to be split.

Select or digitize the splitting point. Note that there are two separate line
features after the calculation. Each new feature has inherited the attribute
data of the old deleted feature.

To add a vertex to a Topobase line feature with two or more vertices

1
2
3

Click Tools tab » COGO panel » Add vertex icon.
In the map, select the feature.

Select or digitize the point to insert.

To remove a vertex from a Topobase line feature with three or more vertices

1
2
3

Click Tools tab » COGO panel » Remove vertex
In the map, select the feature.

Select the point to remove. You need not to snap the point; you can click
in the neighborhood of the vertex.

Constructions: Line Processing (Points)

Topobase provides several functions to process Topobase point and line
features. For general understanding be aware of the difference between a vertex
and a point.
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Vertex: Component of a line feature, whose coordinates are stored with
the line feature.

Point: Topobase feature, basically independent from lines. Every line has
a vertex at its start point, but not necessarily point features.
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The following functions consider the relation between line and point features.
You can use them to improve the consistency of network geometry, to create
correct topological relations or to adjust inaccuracies that are due to
measurement.

You can insert an existing point into a line feature and optionally split the
existing line into two line features.

You can extract an existing point from a line feature and connect the two
existing lines into one.

NOTE These functions are controlled only by the Autodesk command line.

Icon Description

/ Use Insert Point to move an existing point
< that lies within a tolerance exactly on the
line feature.

/ Use Extract Point to remove a point from

& a line and delete it from the database. You
can only remove the point if it lies on the
straight line, within a split tolerance.

split tolerance

Points can only be inserted or extracted if they lie within the split
tolerance.
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Constructions: Insert Point

The Insert Point command calculates new point coordinates that lie exactly
on the line. At the insertion point a new vertex is inserted. For further
processing the vertex indicates the relation between point and line.

Optionally you can split the line at the insertion point: The existing line
feature is deleted and two new line features are created instead. Whether to
split a line or not can be specified in the application options.

split tolerance T o]
-

insert vertex

—

| ——

split line

O Topobase point feature
m vertex

A point is inserted into a line: Its coordinates are moved
to the line.

The insertion is documented in the database: An inserted point is saved with
a special reliability attribute.

If the difference between the old and new position of the point exceeds the
split tolerance, the point will not be inserted and a message appears. The split
tolerance can be set in the application options.

You can only insert a point under certain conditions. If a condition is not
fulfilled, one of the following messages appears in the command line.

B The distance from point to line is too large: The split tolerance has been
exceeded.

B There is no suitable point at the vertex before the point: You can insert a
point only if there are points at the vertices before and after the insertion
point.

B The line already has a vertex at this position: It is not allowed to insert a
point at an existing vertex.

B The spatial tolerance of the selected line must be smaller than the split
tolerance: The spatial tolerance has been set in Topobase Administrator
while creating the database.
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For more information about application options see the Topobase
Administrator Guide.

To insert a point in a Topobase line feature

NOTE The line feature must have point features at the start and end of the line
segment and a point feature that lies within the split tolerance.

1 Open a workspace and generate graphic.

2 Click Tools tab » COGO panel » Insert Point.

3 When prompted on the command line, select the line.
4 Select the point feature to insert.

If the conditions are fulfilled, the point is inserted. If not, a message in the
command line informs you. The calculation is cancelled.

Constructions: Extract Point

The Extract Point command removes a point from a line: The point is deleted
from the database and a new line feature is built.

Split tolerance: A point can only be extracted, if it is within the split tolerance
of his adjacent points (orthogonal projection on the new straight line).

The distance to the line being built is too large: The distance of the point to
the new line feature is greater than the split tolerance.

The line has no vertex at this position: You can only extract a point, if there
is aline vertex at the same location. By means of the vertex the routine detects,
whether the point has a relation to the line.

To extract a point from a Topobase line feature with two segments and point
features at each vertex

NOTE The middle vertex must lie on the straight line, within the split tolerance.

1 Open a workspace and generate graphic.

2 Click Tools tab » COGO panel » Extract Point.

3 When prompted on the command line, select the line.
4

Select the point to extract.
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If the conditions are fulfilled, the point is extracted: Note that the point
is deleted from the database and a new line is built.

If the point cannot be extracted, a message in the command line informs
you and the calculation is cancelled.

Constructions: Right Angle Course

Use the Right Angle Course function to construct line definitions for buildings,
provided at least two coordinates (existing points) are defined and a right
angle (outline size) has been measured between the known points.

You can construct the line in two construction modes:

B Point Mode: With two arbitrary corner points that are connected by
measured sections.

B Base Line Mode: Starting with two points specifying the base line for further
sections.

The construction mode can be specified in the application options. See also
the Topobase Administrator Guide, section Setting COGO Application Options.
The default is Point Mode.

P1

base line

Right Angle Course: Constructing a line feature from measures distances
based on corner points.

Depending on the current mode, there are different workflows. You can
recognize the current mode by the kind of input, the program prompts you.
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If base line mode is active (default), you are prompted to select the two points
that specify the base line. Then the dialog box is opened and you can continue
adding the measured sections.

If point mode is active, you are prompted to select the base point. Then the
dialog box is opened and you can continue with either a point or a measured
section.

To use base line mode

1

2
3
4

%]

Open a workspace and generate graphic.
Click Tools tab » COGO panel » Right Angle Course icon.
In the map, select the first point.

Select the second point.

The Right Angle Course dialog box (page 207) is opened.
In the dialog box, click Add Sections.
In the map, enter the measured value by typing the value.

Enter as many measured sections as necessary. Press <ESC> to redisplay
the dialog box.

Use the Graphic icons besides the Northing column to identify existing
points.

Select a feature class and click Save to store the line in the database.

Constructions: Join Lines

Use the Join Lines function to join two line features as one feature.

To join two line features as one feature

1

2
3
4

Open a workspace and generate graphic.
Click Tools tab » COGO panel » Join Lines.
In the map, select the lines (two or more).

Right-click to finish the selection of lines.

If the selected lines are continuous, the lines are connected to one line
feature.
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Constructions: Free Standpoint

Use the Free Standpoint function to calculate station summaries and free

stations or to calculate the center of three circles. Corrections and residual
discrepancies are displayed as well as the azimuth (orientation).

Calculation of free standpoint

To calculate station summaries and free stations or to calculate the center of
three circles

1 Open a workspace and generate graphic.

2 Click Tools tab » COGO panel » Free Standpoint.
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In the map, select the connection points of your distance and direction
measurements.

Right-click to finish the selection of the connection points.
In the Free Standpoint dialog box (page 208), enter the measurements.
Click Calculate.

Select a feature class and click Save to store the point lines in the database.

Constructions: Center

Use the Center function to determine the center of an arbitrary number of
source points. The source points need not to be saved in the database. The
result can be saved in the database.

To determine the center of an arbitrary number of source points

1
2

Open a workspace and generate graphic.

Click Tools tab » COGO panel » Center.
The Center dialog box (page 209) is displayed.

In the map, select or digitize the points.
Right-click to finish the selection of points.

Select a feature class and click Save to store the point in the database.

Constructions: Reports

Use the Open COGO Report command to print reports of your constructions.
You can select by different criteria, as for example job or date.

Construction Report Description

Job Select the job.

From Select the date range.

To

Report Select a report definition.
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Preview Show a preview. If it is OK, you can print
the report or export it to any available file
format.

See also:

B Construction Settings (page 129)

To print a construction report
1 Open a workspace and generate graphic.
Click Output tab » Reports And Profiles panel » Open COGO Report.
Select a job, for example Live.
Select a time period.

Select a report, for example Intersection.
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Click Preview.

In the Topobase Report Preview dialog box you can examine the report
and its layout and send it to the desired output device, for example the
printer or a file format.

Constructions: Tips and Tricks

You can use the document options to remove the temporary construction
feature classes from the database.

While you are running the construction functions you can acquire distances
and projections.

To remove temporary construction feature classes

1 Click Settings tab » Setup pane » Document Options.
2 Click COGO and Dimensioning.

3 In the COGO and Dimensioning area, click Delete.

To measure a distance

1 Start Orthogonal Calculation.
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Use the Graphic icon ﬂ of the Constructed point to measure ordinate
and abscissa of a point.

Use the Abscissa P1 icon ﬁj to measure the projection of a point on
the base line.

Constructions: Tips and Tricks | 151



152



Topobase Client Reference
Guide

The Topobase Ribbon

Home Tab

The Home tab contains the Data Source, Display, and Quick Access panels.

Data Source Panel

Document
Displays the selected document in the Topobase task pane.

Jobs
Specifies the current job.

Representation

Specifies the current view, either the real world view or a schematic view.
Display Panel

Display Model
Specifies a display model to apply to your document. Open From Location
specifies a display model (.tbdm file) to apply to the workspace. Open Default
applies the default display model.

Create Display Model

Creates a new display model using resources from the display model
repository.
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Edit Display Model
Edits the current display model.

Save Display Model

Imports the display model from AutoCAD Map 3D into Topobase,
synchronizes it with the current display model, and saves it to the current
.tbdm file.

Save Display Model As
Imports the display model from AutoCAD Map 3D into Topobase,
synchronizes it with the current display model, and saves it to the .tbdm
file that you specify.

Assign Display Model For Use In Topobase Web

Assigns display models that can be used in Topobase Web. You map display
models to Map Guide Definitions.

Generate Graphic

Draws geometry as defined by the current display model. If no display model
is selected, draws all the geometry in the document.

Advanced Generate Graphic
Generates your map selectively by defining a viewport or using Feature
Search.

Edit Geometries
Starts and ends Edit Geometries mode. In Edit Geometries mode, grips
appear on the selected feature and you can edit the feature using most
AutoCAD commands.

Attributes
Display the attribute data form for the selected feature.

Delete Feature

Deletes the selected feature. Note that you must use Delete Feature, not the
ERASE command to remove Topobase features from the database.

Create Label
Applies a label to the selected feature.

Pan
Pans the drawing.

Zoom
Zooms the drawing.
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Quick Access Panel

Feature Search
Finds the location of an object, and zooms to the area in the map.

Tools Tab

The Tools tab contains the Modify, Draw, COGO, Analyze, and Survey panels.
The Draw panel provides quick access to AutoCAD drawing commands. The
COGO panel provides access to the Topobase COGO commands.

Modify Panel

Edit Geometries

Starts and ends Edit Geometries mode. In Edit Geometries mode, grips
appear on the selected feature and you can edit the feature using most
AutoCAD commands.

Attributes
Display the attribute data form for the selected feature.

Delete Feature

Deletes the selected feature. Note that you must use Delete Feature, not the
ERASE command to remove Topobase features from the database.

Validate Geometries
Checks for geometry errors.

Data Checker
Checks for data errors.

Settings Tab

The Settings tab contains the Window, Window Elements, Palettes, and Setup
panels. Use Close All Forms and Dock In All Forms to control the display of
attribute data forms. The Window Elements panel provides access to AutoCAD
window controls. See the AutoCAD help for more information on working
with these tools. The Palettes pane provides commands to show and hide the
Topobase Task Pane, the Display Manager, tool palettes, and the Command
Line.
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Setup Panel

Application Options

Provides access to a variety of options that affect the Topobase application
in general.

Document Options
Provides access to a variety of options that apply to the current document.

About Topobase
Displays product and license information.

Borrow and Return License

If you are running a network-licensed version of the program, you can
borrow a license from a license server to use the program for a specified
time when your computer is not connected to the network.

Topobase Administrator
Starts the Topobase Administrator application.

Change Password
Changes the Topobase application password.

Output Tab

The Output tab contains the Send, Plot, Publish, and Reports and Profiles
panels. The Send and Publish panels contain AutoCAD and AutoCAD Map
3D commands. The Plot panel displays the Topobase Plot Explorer.

Send panel

Export to DWG
Export data to a DWG file. See also Exporting to DWG (page 19).

Plot panel

Batch Plot
Send multiple plots to the printer. See also Batch Plotting (page 110).

Use Default Transparency
Uses the transparency default set in the Page Setup Manager.
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Reports and Profiles panel

Open Report
Opens a variety of Topobase reports. For more information, see Generating
Reports (page 68).

Open Lines and Polygons Report

Generates a Line/Polygon report. For more information, see Generating a
Polygon/Line Definition Report (page 71).

Open Spatial Report

Exports selected data to a spatial report. For more information, see Using
Spatial Export (page 70).

Open COGO Report
Generates a COGO report. Constructions: Reports (page 149).

Profile Manager

Displays the Profile Manager for configuring profile views. Working with
Profiles (page 88).

Topobase Application Menu

The Topobase Application Menu contains the following Topobase commands
in addition to Map 3D commands:

File menu

Open Workspace

Displays the Open Workspace dialog box so you can select a workspace.
The workspace contains one or more associated documents.

Close Workspace
Closes a workspace.

Reports
Provides access to saved reports and line/polygon, spatial, and cogo reports.

Import
Imports data.
B Feature Template

B Plot Or Plot Template

B Coordinate. See Importing Point Coordinates (page 63).
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B Wastewater.

B Start Interlis Data Import. See the Topobase Land Management User
Guide.

B Complete Interlis Data Import. See the Topobase Land Management
User Guide.

Export
Exports data.
B Feature Template

m Plot Or Plot Template

B Wastewater Export - Available in Wastewater documents.
B Coordinate. See Exporting Point Coordinates (page 56).
|

Interlis Data. See the Topobase Land Management User Guide.

Profile Manager
Displays the Profile Manager.
For more information, see Working with Profiles (page 88).
Job Manager
Displays the Job Manager. For more information, see Working with Jobs
(page 77).
Survey
Opens the Survey module.

Edit Menu
Create Label
Adds labels to features.

Edit Geometries

Enables Edit Geometries mode for the selected feature. You can edit the
feature using AutoCAD commands. Click Edit Geometries again to end Edit
Geometries mode. Changes are automatically saved in the database.

Attributes
Displays the attribute data form for the selected feature.

Delete Feature
Deletes the selected Topobase feature from the database.
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View Menu

Generate Graphics
Draws geometry as defined by the current display model. If no display model
is selected, draws all the geometry in the document.

Open Display Model
Specifies a display model (.tbdm file) to apply to the workspace.

Open Default Display Model
Applies the default display model to the workspace.

Save Display Model
Manages and saves the current display model to the current .tbdm file.

Save Display Model As
Manages and saves the current display model to a new .tbdm file that you
specify.

Display Model Properties
Shows display model properties.

Create Menu

Create New Feature From Geometry

Converts the selected AutoCAD or AutoCAD Map object into a Topobase
feature.

COGO Menu

COGO commands
Provides access to the Topobase COGO commands.

Analyze Menu

Validate Geometries

Checks the geometries for the entire document. Searches spatial errors (for
example ORA-133xx), redundant geometries, shortline sections, amount of
vertices.

This command can also be started for single topics or feature classes.

Data Checker
Checks data for errors. For more information, see Topobase Data Checker.
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Setup Menu

Application Options
Sets a variety of options for Topobase Client.

Document Options

Sets a variety of options for the document. For more information, see the
Topobase Administrator Guide, section Setting Document Options.

Topobase Administrator
Launches Topobase Administrator.

Change Password
Changes the Topobase password.

Borrow License
Borrows an available Topobase license.

Return License
Returns a borrowed Topobase license.
Help Menu

Help
Displays Autodesk Topobase help.

New Features Workshop

Displays the Topobase New Features Workshop which provides an overview
of the application.

Learning Tools
Provides links to additional learning tools.

Additional Resources

Provides links to a wide variety of additional support resources for learning
and using Topobase.

Customer Involvement Program
Provides a link to the Autodesk Customer Involvement Program.

Product Wishes
Provides a way for you to give feedback on Topobase.

About Autodesk Topobase
Displays product information.

160 | Chapter 4 Topobase Client Reference Guide



Window Menu

Topobase Explorer
Displays the Topobase pane.

Display Manager
Displays the AutoCAD Map Display Manager pane.

Close All Forms
Closes all open attribute data forms.

Dock In All Forms
Docks open forms.

Dock In Out Forms
Undocks open forms.

Document Explorer

Use the Document Explorer (page 9) to view and process the feature classes
and topics from a data model point of view.

Topic shortcut menu

Search
To find a feature class.

Validate Geometries in the topic
To check the geometries for the entire topic.

Feature Class shortcut menu

Show Form
To open the feature class form to view and edit data. See also Using Feature
Class Forms (page 32).

Digitize
To digitize a feature. See also Creating Features (page 29).

Digitize with Form

To digitize a feature using feature class forms to edit attributes. See also
Creating Features (page 29).
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Create New Feature from Geometry

To create features from drawing elements. See also Creating Features (page
29).

Create Features with Form

To create features from drawing elements and using feature class forms to
edit attributes. See also Creating Features (page 29).

Validate Geometries in the feature class
To check the geometries.

Spatial Selection
To perform a spatial selection. See also Selecting Features (page 21).

Feature Explorer

Use the Feature Explorer (page 21) to verify the selected features and to modify
the selection. Expand the nodes, select an item and use the toolbar icons or
shortcut menus to process the feature.

The feature explorer is used by the following components:
Profile Manager, see Working with Profiles (page 88)
Topology Checker

Area Topology Checker

Analysis workflows in the utility applications such as water, wastewater
and gas.

®

Attributes

Shows the feature information.

]

Highlights the selected feature in the drawing, if you have selected a single
item.

%)

Highlights the selected features in the drawing, if you have selected a node.
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%)

Unhighlights the features.

B

Zooms to the selected feature.

®

Removes the feature from the selection.

&

o

&

Splits the line with a hard split. Applicable for utility analysis results.

e
Splits the line with a soft split. Applicable for utility analysis results.

=]

Corrects short line sections. Applicable for geometry validation analysis
results.

Editing Features Dialog Boxes

Create Features From Entities dialog box

If you edit features (page 29) that are already saved in the database, you can
choose from the following options.

Delete Existing Features
Replace an existing feature with the new one.

Leave Existing Features Intact
Add a new feature and retain the previous feature.

Geometry Editor dialog box

The Geometry Editor (page 32) displays the essentials of the information that
is stored in the feature’s GEOM attribute. In case of lines or polygons the
coordinates of all vertices are displayed.
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X
easting (geodetic Y)

Y
northing (geodetic X)

z

elevation

Interpretation

Type of linear connection between two vertices, for example straight;
ArcMidpoint; ArcBegin, ArcEnd.

Add/Remove buttons
To remove vertices from the line.

Feature Class Forms

Feature Class Form Toolbar

At the bottom of each (page 32) there is a navigation toolbar.
|14 D Dl

First record, previous, next, last record

T,

+

Filter: To filter records in the database, to search for features. See also
Filtering Data (page 22)

=

Remove Filter: To remove the filter, that means to show all records.

Vi
Edit Record

o,
Y

Refresh

Use this command to create a new feature that has no geometry yet. When
you start the command, the feature class form changes into Edit mode and
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you can capture data. If a Reference Record is active, it will be applied. Click
Insert to store the record in the database.

Opens the related model table. See also Data Model: Model Tables.

Delete Record

=

Print

O
Highlight the selected feature (in the drawing)

)

Highlight all the features in the selection set

Highlight Related Features. To highlight all features that are related to the
selected feature.

Remove highlight from feature(s)

Select graphic entities into the dialog

ia]
Use this command to digitize a feature with geometry. When you start the
command, the graphic window becomes active and you can use all available

graphic tools to create the feature.
You can also start this command from the Document Explorer shortcut

menu » Digitize or Digitize With Form.
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Use this command to digitize the geometry of an existing record. You can

create geometry data subsequently, in case the attribute data was captured
before.

Use this command to choose an existing feature in the drawing and connect
it to the current feature.

Digitizes an inner ring and adds it to the selected polygon. See also Digitizing
Polygons With Islands (page 39).

©

Inserts an existing geometry as an inner ring and adds it to the polygon.
See also Digitizing Polygons With Islands (page 39)

Creates and positions a label connected with the selected feature.
0

For line features, reverses the direction.
7%

Reverses the direction of all features in the filter.
S5

Adds the features to the schematics workflow feature explorer.

R

Displays the Manage Connections area. See also Managing Logical
Connections (page 75).
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2]

Displays the shortcut menu of the feature class form. See also Feature Class
Form Shortcut Menus (page 167).

o]
Dock out/Dock in

Feature Class Form Shortcut Menus

Right-click on any tab, anywhere inside the feature class form (page 32) (other
than the title bar and input fields) to access the shortcut menus. The Input
Fields have their own shortcut menus. See Feature Class Form Input Fields
Shortcut Menus (page 169)

You can spread the contents to different tabs. By default you use only one
tab: the Form tab.

Additional tabs can be renamed, add or removed with Topobase Form Designer.

TIP You can also display the shortcut menus by clicking IEI in the forms toolbar.

View
Displays the View mode. Link to View mode menus below.

Document Manager
See Assigning Documents to Features (page 41).

Projection
See Using Projections as Filters (page 28).

Reference Records
See Using Reference Records (page 37).

Filter
See Filtering Data (page 22).

Delete All Filtered Records
To delete all features in the filter.

Delete Bookmarked Records
To delete bookmarked records. You can bookmark records in the table view.
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Import
See Importing Feature Data (page 63).

Export
See Exporting Feature Data (page 53)

Copy/Paste
Commands to copy and paste the whole record.

NOTE The Copy/Paste commands will copy all data of controls that are not
locked. So if you do not want the IDs/FIDs to be copied, set them to IsLocked.

Copy Record (F7)
Copy the current record.

Paste Record (F8)

To add a new record: First copy with (F7) and then paste with (F8). The
copy will be inserted as new record.

To overwrite the current record: Copy with (F7), change to Edit mode and
then paste with (F8).

Copy-AddNew-Paste Record (F9)

To copy and paste in one step:
Press F9: The current record is copied, then changed to Add New Mode and
then pasted.

Options
See Switching Modes (page 34)

View mode shortcut menu

The feature class forms (page 32) display the feature data in Table or in Form
mode. You can switch between the view modes by clicking the respective tab
at the top of the form

NOTE There are some differences in handling the feature class forms in Table or
Form view mode.

View mode

Tabs
To show or hide the Form and Table tabs
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Form
To change to Form view mode

Table
To change to Table view mode

Table View mode only
e
To fit columns to content.

sorting

Click the respective column heading to sort all records in filter descending
or ascending.

bookmarking

In Table view mode you can tag a record by clicking the first column. The
selected records are tagged = bookmarked by the # sign. Bookmarked records
can be processed together, for example deleted.

#it

Use this button in the lower left corner to remove or add the bookmark
signs (for example to bookmark or unbookmark all records).

Sort by coordinates
Exceptionally for point feature classes you can click the column heading
even for a Geometry Control to sort points by coordinates.

Form View mode only

Additional tabs

You can spread the contents to different tabs. By default you use only one
tab: the Form tab.

Additional tabs can be renamed, add or removed with Topobase Form
Designer.

Feature Class Form Input Fields Shortcut Menus

The following shortcut menus are available only by right-clicking in an input
field in a feature class form (page 32).
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Filter (Commands to find records)

Selectionbased Filter

Finds all records with the same value. The filter is the value in the text box
from which you started the shortcut menu.

Is Null/Is not Null

To find all records where the respective value is empty (= database NULL
that is different from the value 0) or not empty.

Remove Filter

To remove the filter to show all records. This is the same command as from
the toolbar icon.

Sort

ASC/DESC

To sort the records (filter) either in ascending (ASC) or in descending (DESC)
order.

Add To Sort ASC/Add To Sort DESC

Click to sort by additional fields. That means you can enhance the sorting
by additional criteria. You can for example first sort by TYPE, then by AGE
and so on.

Other

Get Related Value
For fields with list boxes: To open the table with the values to select.

Copy/Paste

To copy or paste the field value. You can only paste a value if the record is
in Edit mode.

Feature Class Form Control Elements

Besides the Feature Class Form Toolbar (page 164), Feature Class Form Input
Fields Shortcut Menus (page 169) and the Feature Class Form Shortcut Menus
(page 167), each feature class form (page 32) has a number of control elements,
like buttons, property text boxes and combo boxes.

Basic Form Launcher - Reference Button [ ]

Use this button to open a second form with related records in the filter.
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If there are no related records the filter will be empty, which is indicated
by the status indicator No record found! However, you can capture related
data now.

NOTE If you use the Reference button to open a form and then create a new
record, the value of the linked form is entered automatically (master reference).

Combo Box

A frequently used control element is the combo box. A combo box is a text
box with an attached list box. The list box can be opened by clicking the
drop-down arrow.

The properties of the different types can be set with the Topobase Form
Designer. For more information, see Working with Features (page 21).

Filter Manager

Use the Filter Manager to define, save and reuse filter definitions (page 27).

Add
To add a filter definition. The filter expression that has recently been used,
is displayed as default.
Example:
Select * from <current feature class> a where <current condition>
Modify
To moditfy a filter definition.

Remove
To remove a filter definition.

Projection

The Named Projections tab shows named projections (page 28). As the names
of the relations are not very expressive for non technical users, you can prepare
projections with a speaking caption.

Add/Edit/Remove
To add, delete or modify name projection definitions.
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New Named Projection dialog box

Projection to Table

To select the table for the projection. The list box shows all available tables
of the current document.
With the link button you can show all tables that have a relation.

Projection Filter

You can define a projection filter. If you choose one of the existing
projections, the filter is already defined. Set the values that should be
replaced in {Filter}.

Report Dialog Boxes

Report dialog box

You can generate standard reports or user-defined reports for each form (page
68). Standard reports are based on form structure and arrangement.
User-defined reports can for example be generated using Topobase Report
Designer or Crystal Reports ™.

Current Record Only
To print only the current record (one record only).

All Records Of the Selection
To print the currently selected records (all filtered records).

Report dialog box shortcut menus

Add
Commands to assign reports to the feature class form.

Crystal Reports 10

To add a Crystal Report™ report.
Title: This is displayed in the report selection list.
Filename: To select the report definition file *.rpt.

Topobase Report
To add a report that has been designed with Topobase Report Designer.
Title: This is displayed in the report selection list.
Report Name: To select the report definition.
Restricted To Usergroup: To select the user group that can use the report.
Note that an ADMIN user can use all reports.
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Web and Desktop: To specify whether the report is available in the Web.

Default
To add a default report that is based on the form structure.

Importing Dialog Boxes

Format Definition Manager

You use the Format Definition Manager to define import file formats, and
export file formats. A format definition can both be used for coordinate import,
and for coordinate export.
Definition Name

Name of the format definition.

Default File Extension When Exporting Coordinate Files

Specifies the default extension for the export files that are created using the
format definition.

Parse By Positions
Defines a file format where the values are stored in columns of fixed width.

Properties

Specifies which values you import, and their position in the import file. For
information about the values, see Format Definition: Point Attributes (page
175).

Ol
Determines the position of the value, using the display in the Preview
Coordinate File pane. Select the value, click the icon, and highlight the
value in the Preview Coordinate File pane.

From/ To
Specifies the position of the value in the import file.

Parse With Separators
Defines a file format where the values are separated by a character.
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Properties

Specifies which values you import, and the sequence of the values in the
import file. For information about the values, see Format Definition: Point
Attributes (page 175).

Separator
Specifies the separator, such as !

Index
Specifies the order of the values in the import file. For example, first value
is the identifier, second the easting coordinate. For example, use a unique
index for the selected values, such as 0, 1, 2, 3.

Y

Determines the order of the values. Click the icon next to the value, and
click the value in the Preview Coordinate File pane.

Preview Coordinate File
Displays the first lines of the first import file.

Open
Opens a coordinate file for preview. For example, if you want to define
multiple format definitions.

Show Entire File

Displays all lines of the selected import file. For example, if the first lines
do not contain any data, but only comments.

Exclude Lines Which Start With (Comments)

Specifies a key that indicates the lines that you do not want to import. For
example, if your import file contains comment lines that start with a special
character, such as *.

Includes Lines Which Start With (Coordinates)

Specifies a key that indicates lines that you want to import. If you select
this option, only the lines that start with that key will be imported. For
example, if your import file contains both coordinates, and other
measurements, you specify the key for coordinates, such as K.

Save/ Save As
Saves the format definition file (*.def).
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Format Definition: Point Attributes

You can import or export point attributes.

The identifier, the reliability attributes, and the precision attributes are default
attributes, that can optionally be added to point feature classes. See Topobase
Administrator - section Feature Class Type: Point.

The reliability attributes, and the precision attributes store the results of
adjustment calculations of the Topobase Survey module.
Field Code
If applicable, the field code is determined from the field code list. See
Exporting Field Codes (page 62).
Northing Coordinate/ Easting Coordinate
Planimetry coordinates, stored in the GEOM attribute.

Identifier
<point feature class>.TB_POINTNUMBER.

Height
Height, stored in <point feature class>.Z, or in the height value of the Spatial
geometry.

Position Is Reliable(0/1)
<point feature class>.TB_POSITION_RELIABLE

Position Reliability (Value)
<point feature class>.TB_RELIABILITY_POSITION

Position Accuracy
<point feature class>.TB_ACCURACY_POSITION

Height Is Reliable (0/1)
<point feature class>.TB_HEIGHT_RELIABLE

Height Reliability (Value)
<point feature class>.TB_RELIABILITY_HEIGHT

Height Accuracy
<point feature class>.TB_ACCURACY_HEIGHT

Format Definition: Point Attributes | 175



Import Point Numbers

If an import file contains identifiers (point numbers), these are stored in the
TB_POINTNUMBER attribute. Depending on your distribution settings the
automatic point numbering rules apply.

Distribute points to a single feature class

The coordinate file contains point numbers (identifier).

The identifier is stored in the feature class attribute TB_POINTNUMBER.
Automatic point numbering does not apply.

The coordinate file does NOT contain identifiers.

The point numbers are generated according to the automatic point
numbering setting. We recommend that you enable automatic point
numbering. Otherwise the point number would be NULL.

Distribute points using the field code list
The coordinate file contains identifiers, and field code settings specify Keep Identifier

= TRUE.

The identifier is stored in the feature class attribute TB_POINTNUMBER.
Automatic point numbering does not apply.

The coordinate file contains identifiers, and field code settings specify Keep Identifier
= FALSE.
The point numbers are generated according to the automatic point
numbering setting. We recommend that you enable automatic point
numbering. Otherwise the point number would be NULL.

The coordinate file does NOT contain identifiers, and field code settings specify
Keep Identifier = TRUE.

The point numbers are generated according to the automatic point
numbering setting. We recommend that you enable automatic point
numbering. Otherwise the point number would be NULL.

The coordinate file does NOT contain identifiers, and field code settings specify
Keep Identifier = FALSE.

The point numbers are generated according to the automatic point
numbering setting. We recommend that you enable automatic point
numbering. Otherwise the point number would be NULL.

Related procedures:

B Point Numbering
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Import Wizard

The coordinate import provides a wizard that guides you through the import
process.The wizard controls the sequence of the steps, and validates your
input.

On the left side of the wizard, the Task Overview panel displays the status of

rd !
[ 3]

progress, and indicates which steps to perform next. Click ' to show, or
L £ J
=— to hide the Task Overview pane.

The navigation bar at the bottom of the window provides buttons to start the
steps. When the current step is done, the Next button is activated. Click Next
to continue.

Use the links on the Task Overview Pane, or click the navigation buttons to
proceed.

Import Wizard 1: Select Files

In step 1, you select the files to import.

Select The Coordinate Files To Import
Displays the coordinate files that have been selectect to import.

Add
Opens the file selector to add a file to the import list.

Remove

Removes the selected file from the import list.
View

Opens the selected file in a default editor.

Select The Format Definition File For The Coordinate Files
Displays the format definition.

Select

Selects a format definition. If no format definition is avaliable, click Manage,
and create a format definition.
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Manage

Opens the Format Definition Manager. See Format Definition Manager
(page 173).

Import Wizard 2: Distribution Settings

In the second step, you specify the feature classes into which the points are
imported (page 63).
Distribute Into One Single Feature Class

Imports the points into the specified feature class.

Feature Class

Selects the feature class. The list displays the point feature classes of the
document.

Distribute With Predefined Field Codes

For workspaces that contain a Survey document: This option is available,
if you start the coordinate import from the Survey document.

Imports the points into different feature classes and documents, as specified
in the field code list.

Survey Project Group/ Survey Project
Specifies the project group, and the project that stores the field code list.

Field Code List

Displays the field code list that will be used for the import. The field code
list specifies the document / feature class into which a point of a certain
field code will be imported.

Open Survey
Opens the Survey application.

Import Wizard 3: Analyzing import Files

In the third step, the coordinate files are parsed based on the selected format
definition (page 63). The wizard pane displays any messages and
incompatibilities. For example, if the format definition does not fit, you can
return to step one, to select another format definition.

Finished Parsing The Files
Displays the status of the parsing process.
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Parsed Points

Displays information about the points that match the format definition.
A tooltip displays the line of the coordinate file.

Refresh

Validates the distribution. For example, if you have modified a setting
without exiting the import wizard , such as a job selection.

Import Wizard 4: Import

The fourth step of the import imports the coordinates into the specified feature
classes (page 63). You can save the points that could not be imported in a text
file. Then, you can modify the text file, and repeat the import for these points.

Finished Importing The Files
Displays the status of the import.

Save As File
Saves the import log into a text file.

Not Distributed Points
Displays the points that could not be imported.

Save As File

Saves the points that could not be imported into a file, for further review
and modification.

Exporting Dialog Boxes

Export Menu

Use the Export menu to export data to various formats (page 53).

Excel
Exports data into Excel.

ASCII File
Exports data to text (*.txt) files.

XML

Exports to (*.xml) files. Point feature coordinates are written as GEOM.X
and GEOM.Y columns.
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sQL
Exports to SQL files. You can select:
Oracle SQL loader files (with spatial geometry)
Oracle SQL files (insert statements without spatial geometry)
PostGre SQL files (insert statements with PostGre spatial geometry)
Word Serial Letter
Exports to Microsoft Word using MS Word mail merge.

Coordinate Export Workflow

Use the Coordinate Export workflow to export point coordinates, or to print
point coordinates reports. The workflow consists of two parts: point feature
selection, and coordinate export generation.

Coordinate Export- feature selection

Select Features area

Specifies the selection method for the point features to export. See also
Selecting Points for Export (page 60).

[ Select In Map
Selects the features in the drawing.

Select From Area Topology
Selects the points from an area topology.

Select From Trace
Selects the points from a tracing result.

Select Specific Feature area
Selects the points using feature class forms, or selects all points of a selected
topic or feature class.

Filter Feature Class area
Sets a feature class filter that is applied to any selection method.

Review And Modify Selection area

Displays the selected points in the feature explorer. Use the buttons on the
toolbar to modify the selection.

oK
Activated, if a valid selection has been defined. Continues the workflow.
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Coordinate Export- export generation
Specifies the export parameters.

Generate Report
Creates a report to print the coordinates of the selected points. See also

Generating a Coordinate Report (page 72).

Select Your Report
Selects the report template.

Export Into File
Exports the coordinates into a text file.

Select Format Definition
For Generic Export, selects the format definition file.

New/ Edit
For Generic Export, opens the Format Definition Manager. Creates a format
definition, or edits the selected format definition. See also Format Definition
Manager (page 173).

Export Field Code

Exports the field code. This option is only available, if the selected format
definition requires a field code, and if the workspace contains a Survey
document. See also Exporting Field Codes (page 62).

Survey Option area

For field code export. You select the Survey document, and the project of
the field code list that maps the export feature classes and the field codes.

Edit
Opens the Survey application.

Extend Existing File
Appends the coordinates to an existing file.

Spatial Export dialog box

Use the spatial export tool to export features that have been selected with a
spatial selection method (page 70).

Spatial Selection
Defines the type of spatial selection.
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No Spatial Selection

Digitize a Window
Draw a rectangle around the features to include in your report.

Digitize a Polygon
Draw a polygon around the features to include in your report.

Select Reference Feature(s)

Specify a reference for features to be included, for example, a line to include
all points that lie on this line. Press ENTER to finish the selection of the
reference features.

Select a Topology
Select a topology from the list. Click Select Position to define a perimeter.

Use Current Job Perimeter
Includes the features within the job perimeter.

Report

Specify the report you want to print. Use the Topobase report designer to
define reports.

Spatial Mask

Select either ANYINTERACT or Composite, depending on what you want
to include in the report.

Export To Excel dialog box

You can export Excel data from the feature class form (page 54).

Columns

List of all feature class attributes with control titles (captions) and field name
in parentheses.

Select or deselect the columns to be exported. Select Clear All to select or
deselect all fields.

Change the order using the arrow buttons.

Control Titles

Select this to export additionally the column title. This is not the name of
the column in the database, but the caption. The column names of the
database are always exported by default.

Default setting for direct export is OFF.

Default setting for form export is ON.
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Topology Dialog Boxes

Manage Connections area
The Manage Connections area displays the connectivity tree of features that

are part of a logical topology (page 75).
root node
Shows the selected feature.
Forward Connected To
Shows features that are forward connected to the selected feature.
Backward Connected To
Shows features that are backward connected to the selected feature.
Forward And Backward Connected To
Shows features that are forward and backward connected to the selected
feature.

&=
Connects features. Select the feature in the feature explorer. Then, click the

icon and select the connected features in the drawing.

%
Disconnects the features. Select the connected feature in the feature explorer

and click the icon.

ui

Sets or modifies the flow direction of the connection.
NOTE You can modify the flow by dragging the feature to another flow node.

Area Topology Checker
The Area Topology Checker dialog box lists all detected topology errors (page

1835) in a feature explorer.
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Topology:

PARCEL W

QOGO KLk +

=] Line not in closed loop [1]
+-7 1 Parcel Line: 106899

=-7] Palygon has multiple centroids [2]
F R PARCEL_TSUR: 100291

L —
A,

=y PARCEL_TSUR: 100659
=-F] Centroids [2]
# Parcel: 12614

H Parcel: 12617

Refreshes the topology explorer, in case you have repaired.

i)

E

Highlights the selected feature in the drawing.

2

Zooms to the feature.

©

Opens the feature class form and displays feature information.

&

Removes the feature from the database.

]

Creates missing centroids for the selected polygon. Deactivated, if no
centroids are missing.
See also Area Topology Initialization.
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@
Finds intersecting lines, that have not been detected by the standard
topology check. This command is for rare cases, where intersecting lines
do not cause invalid polygons. The execution of this command may take
a long time, so it has been separated from the standard check.

NOTE You can use this command before the topology has been initialized. For
example to validate data that has been migrated to Topobase.

@&,

Zooms to the selected feature. Select this option to enable automatic zoom
when you click an object.

Area Topology Checker Error Messages

Double-click an item in the Topology Checker (page 73) to display the feature
information, related to this error message.

NOTE You must enable the double-clicking in the application options. See Setting
Document Explorer Options.

Centroid Has No Polygon

Indicates that a centroid feature has been found that does not lie within a
polygon. This type of error often is due to a “Line Not In Closed Loop”
error; see following error messages:

Centroid Has Null-Geometry
Indicates, that the centroid has no geometry (no coordinates).

Line Not In Closed Loop

Indicates that the line does not meet the following condition: The edges of
an area topology have to build a closed polygon. All lines that do not fulfill
this condition are listed under this node.

The line is not part of a valid polygon. The reason for this error can be either
of the following:

Lines Cross Or Touch
The edge crosses or touches another line.

Line Crosses Or Touches Self
Lines cross or touch each other.
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Line Has Null-Geometry
The edge has no geometry (no coordinates).

Polygon Has Errors

Invalid polygons are saved in the system table _TSER. See also Area Topology
Tables. The reason for this error can be one of the following:

Line Has More Than {0} Vertices
The edge has many vertices.

Line Has Duplicated Sections

The edge has a section that has been digitized twice (mostly forth — back —
forth).

Line Has Adjacent Points

The edge has two or more adjacent points that lie together closer than the
tolerance value.

Two Or More Rings Touch
An outer and inner ring or two inner rings touch.

Coordinates are outside of the spatial extents.
The coordinates are outside of the spatial extents.

Polygon Has Multiple Centroids

The polygon has more than one centroid. Expand the polygon items to see
the centroids.

Polygon Has Been Modified Outside Perimeter

The area of a polygon that lies outside, or partially outside the perimeter,
has been changed, and the change exceeds the tolerance. See also Area
Topology Tolerance Values.

Logical Topology Checker

You use the logical topology checker to process logical topologies (page 76).
Double-click an item to open the feature class form.

The Topology Checker dialog box lists all detected topology errors (page 187)
in a feature explorer.

NOTE You must enable the double-clicking in the application options. See Setting
Document Explorer Options.
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Refreshes the topology explorer, in case you have resolved an error.
)

Highlights the selected feature in the drawing.
]

Removes the highlight from the feature.

@

Zooms to the feature.

©

Opens the feature class form and displays feature information.

(]

Removes the feature from the database.

@&,

Zooms to the selected feature. Select this option to enable automatic
zooming when you click an object.

Logical Topology Checker Error Messages

You use the Logical Topology Checker (page 186) to process logical topologies
(page 76). The feature explorer shows the error types in separate nodes. Expand
the nodes and items to see more details. At the feature level the FID is shown.

Feature Has No Connections
The feature is not connected to another feature.

Edge Without Start Node
Applies to a utility model topology.

Edge Without End Node
Applies to a utility model topology.

Node Without Edge
Applies to a utility model topology.
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Edge With More Than One Start Node
Applies to a utility model topology.

Edge With More Than One End Node
Applies to a utility model topology.

Template Dialog Boxes

Create Template dialog box

After you have selected the feature classes of the template, and specified the
origin and orientation, you can set the template properties (page 45) in the
Template Manager.

General tab

Features
Lists the features <feature class caption>_FID that are part of the template.

Ref. Record

Lists the reference record that will be applied, when you instantiate the
template. The list displays all available reference records.

Highlight
Highlights a template feature in the map. Select the feature in feature list
and click the Highlight icon.

Delete

In the Create Template dialog box: Removes a feature from the template,
but not from the database. Select the feature in the list and click the Delete
icon.

Group Features When Moving, Rotating, Or Deleting
Groups template features. Select this option if you want to treat all template
features as one group. When you instantiate the template and then move
or rotate one of the features, the change applies to the whole group.

IMPORTANT You cannot reset this property. If you want to ungroup template
features, you must delete and redefine the template.

Access tab

Defines which feature class shortcut menus provide the template. The default
is the feature class from which you started the Create From Selection
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command. Optionally, you can make the template available from all feature
classes that are part of the template.

Connectivity tab

Shows the connectivity between the template features. For example, in a
transformer bank, a junction is connected to a conductor and the conductor
is connected to the transformer.

Relations tab

Shows the relations between the template features. This is useful for related
features that have no geometry and therefore cannot be shown in the
drawing. For example, you can view which labels belong to which parent
features.

Template Manager

Use the Template Manager to create, edit, import, and export (page 48) your
feature templates.

Export
Exports the templates that are selected in the tree view. See Importing and
Exporting Templates (page 48).

Duplicate
Duplicates the selected template.

Delete

Select the template and click the Delete icon. If you delete a nongrouped
template, you are prompted to confirm the deletion. The features that have
been created using the template are not deleted. If you delete a grouped
template, the features that have been created using the template are
ungrouped, but not deleted.

Import
Exports a template. See Importing and Exporting Templates (page 48).

Access tab
Assign the template to another appropriate feature class.

Connectivity tab and Relations tab
View connections and relations of the template features.
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Jobs

Job Manager Icons

Use Topobase Job Manager to process jobs and job states (page 78).

The Job Manager explorer shows the jobs, grouped in different ways: in
chronological order or by job state.

&
To make the selected job to current job.
&
To create a job. See also Creating a Job (page 79)

iz

To edit a job. For example modify the description.

To select a job perimeter. See also Defining the Job Perimeter (page 81)

o)
To change the job state. See also Changing the Job State (page 83)

3

To cancel all modifications of this job (rollback) without deleting the job.
This command is available for open jobs only.

R

To delete the job: To cancel all modifications and delete the job.

Job Manager Menus

Use the Topobase Job Manager to process jobs and job states (page 78).

Lease Job

To lease the selected job. See also the Topobase Administrator Guide, section
Job Leasing.
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Release Job
To release the selected job. See also the Topobase Administrator Guide,
section Job Leasing.

Delete All Modifications/ Delete Some Modifications
To delete all modifications or to select single features. See also Deleting Job
Modifications (page 82)

State menu
Commands to change the job state. See also Changing the Job State (page
83)

View menu
To select the list order in the explorer. You can list the jobs by state (open,
pending, live) or be date (chronological).

Data menu

To show historical views. To show the data as it has been at a certain date,
for example a year ago.

Job Explorer

Use Job Explorer to view and process all modifications for a job (page 78). Job
Explorer groups features as follows:

Inserted
Updated
Deleted

Locked Features (features you locked manually to modify in the future,
but have not yet selected)

®
Opens the form for the selected feature.
) |

Highlights or unhighlights the selected feature in the map.

&

Zooms to the selected feature.
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&

Enables automatic zoom to the selected feature.

i
Creates a job.

i

il

Changes the job state. See Changing the Job State (page 83).

&

Returns selected features to their original state, undoing any modifications
you made.

Extracts the selected features, adds them to a new job, and sets them to live
(partial posting). Available for pessimistic locking. See Changing the Job
State (page 83).

4

Locks a feature manually. Available for pessimistic locking. To activate the
icon, select the Locked Features node.

[d

Unlocks a feature you locked manually.

2

Undoes all modifications to the selected job.

5

Checks for job conflicts and opens the Job Conflict Explorer. Available for
optimistic locking. See also Resolving Job Conflicts (page 85).
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Select Perimeter dialog box

After creating a job or during the job creation workflow you can optionally
define a job perimeter (page 81).
Create Perimeter From Topology

If the job contains any topologies, the list box shows the topology (page
216) polygon feature class (*_TSUR).

Click Select to select all polygons you want to work with, for example parcels
you want to modify in the current job. You can even select polygons that
are disjointed. The system builds the job perimeter of all selected polygons.
The list box is empty, if there are no topology feature classes in the job. You
can then digitize the job perimeter.

Create Perimeter From Polygon

To digitize the perimeter. The list box shows all polygon feature classes that
are specified as perimeter and that are job enabled. Select one from the list
and digitize.

No Perimeter

Indicates that no perimeter has been selected.
o

Highlights the selected perimeter.
x]

Removes the selected perimeter.

Job Conflict Explorer dialog box

For Optimistic Feature Locking, the Job Conflict Explorer dialog box displays
job conflicts that occur when a job state changes. Use the icons and shortcut
menus to analyze and solve the conflicts (page 85).

Conflict Explorer

Each conflict is shown in a separate tab.
Expand the items. If you have decided which modification you want to
cancel, select the feature and click Delete Modification.

MyJob
Expand the MyJob node to see all features of the current job.
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<other jobs>
The explorer shows all jobs that are affected by the feature conflict.

Profile Dialog Boxes

Profile Manager

Use the Profile Manager to create and modify profiles based on profile
definitions (page 88).
L

Selects a profile in the map or in a list.

[

Creates a profile. Select the profile definition in the Profile Definition List.
See also Profile Manager dialog box (page 195)

[
Draws the profile. When the features and axis have been selected you can
draw the profile. You are prompted to digitize the profile origin and
orientation. See also Drawing the Profile (page 89)

Igi
Updates the profile.
ligk
Deletes the profile.
9
Indicates invalid or missing input. Note the tooltips for further information.

Profile Settings
See Profile Manager dialog box (page 195)

Feature Selection/Axis Selection
See Drawing the Profile (page 89)
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Profile Manager dialog box

The default profile settings are specified in the profile definition. In the Profile
Manager you can edit these setting before you create the profile (page 88).

NOTE The profile settings are stored in the profile system tables. See also the
Topobase Administrator Guide, section Profiles.

Profile Definition
Displays the name of the profile definition the profile is based on.

Profile Title
Specifies the profile title. For example, the title is displayed in the Profile
List dialog box, when you select a profile to modify.

FID
Specifies the unique identifier of the profile.

User

Displays the Topobase login name of the user who created the profile
definition.

Height Scale Factor

Specifies a height scale factor to make the height differences clearly visible
in the profile. The value is dependent on the actual height differences and
extension of your profile features.

Reference Altitude

Specifies the reference altitude. This altitude is the lowest level displayed
in the profile drawing.

Length Scale Factor
Specifies a scale factor for the axis.

Reference Distance
Specifies the distance between linear points.

Origin
Shows the global coordinates of the profile origin.

Orientation
Shows the orientation of the profile drawing.
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Construction (COGO)

Construction Toolbar

The Topobase construction commands (page 127) can be started from the
COGO panel on the Tools tab.

X

Intersection. See also Constructions: Intersection (page 130)

-

Arc Intersection. See also Constructions: Arc Intersection (page 133)

Y

Orthogonal Calculation. See also Constructions: Orthogonal Calculation
(page 135)

A

Polar Calculation. See also Constructions: Polar Calculation (page 136)

1

Orthogonal Projection. See also Constructions: Orthogonal Projection (page
137)

.'C_

Snap/Trim. See also Constructions: Snap and Trim (page 138)

M

Split. See also Constructions: Line Processing (Vertices) (page 140)

A

Add Vertex. See also Constructions: Line Processing (Vertices) (page 140)

A

Remove Vertex. See also Constructions: Line Processing (Vertices) (page 140)
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/4

Insert Point. See also Constructions: Line Processing (Points) (page 142)

/A

Extract Point. See also Constructions: Line Processing (Points) (page 142)

4

Offset. See also Constructions: Offset (Line Calculation) (page 139)

=il

Right Angle Course. See also Constructions: Right Angle Course (page 146)

Free Standpoint. See also Constructions: Free Standpoint (page 148)

n};n

Center. See also Constructions: Center (page 149)

s

Join LInes. See also Constructions: Join Lines (page 147)

Construction Dialog Boxes

The following Arc Intersection dialog box shows the dialog controls and
components for Topobase construction commands (page 127).
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l Arc intersection E]@

File  Wiew  Element  Calculate  Help

Calculation
E asting Morthing Fiadiuz
Arc @] E85897 767 336657 456 @ 1293360 @
Ao 2 @] E88053.367 TR0 @ 1811.747 @
Tangent E]Ia
Intersection 1 D B26248.801 337942 267 paints E]Ia
Intersection 2 ] BE7106.251 336236.647 E]Ia

1 intersection pair(s]
Calculate

Save options
Feature class

Paint [Utility] hdl Save intersection 1
Save intersection 2

Feset ] [ Cloze ] [ Help ]

Construction dialog box

White text box
Can be edited to modify values.

Gray text boxes
Show the results of calculations.

Shortcut menus

Right-click any text box in the construction dialog boxes to view the shortcut
menu.

Feature Class list box

Specifies the feature class for the calculated object (point or line string
feature class). This list displays all appropriate feature classes of the
workspace, for example point feature class if the result is a point.

I
Selects an element in the drawing. If you click this icon, the focus changes

to the map (Map 3D or MapGuide). With this icon you can also measure
distances (excluding angles and orthogonal projections).
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%

Reverse icon. Depending on its context this command does any of the
following operations:

Changes an element’s orientation.

Toggles between two possible results.

Change the algebraic sign.

[

Highlights a result or a construction element.

i-j

Shift Abscissa. Modifies or determines an abscissa value in the drawing.

New

Resets all entries and starts a new calculation. The focus changes to the map
and you are prompted to identify the required elements.

Calculate

Starts a calculation, for example after you have modified parameters. The
results of the Calculate operation are not stored in the database but the
display in the drawing is updated.

Save Options area
Saves the calculation result.

Save

Saves the result to the database. If a calculation has more than one result,
you can either save result lor result 2.

Save The Dimension Features

Automatically saves dimensioning for the calculated features. Available for
Orthogonal Calculation, and Arc Intersection. Use the COGO and
Dimensioning Document Options to specify the dimensioning feature
classes.

This option is only available under the following conditions:

B The document contains the Dimension extension.

B The COGO and Dimensioning options have been set and saved.

Reset
Resets all entries and starts a new calculation.
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Close
Closes the dialog box and to exits the calculation.

Status row

Shows information about the calculation, for example, number of
intersections or tangents.

Intersection dialog box

Use the elements in the dialog box to modify the parameters of an intersection.
(page 130)
Element 1/Element 2

Element 1 and 2 can be a straight line or a circular arc.

Click the Highlight icon to show the element in the drawing.

Click the Graphic icon B to identify another element in the drawing.
Specify an offset value to shift the element.
Specify an azimuth value to rotate the element.

Point 1/Point 2
The orientation of element 1 is indicated by the direction of P1 and P2.

Point 3/ Point 4
The orientation of element 2 is indicated by the direction of P3 and P4.

Easting/ Northing/Elevation
Coordinates of the points. You can edit the coordinates or use the Graphic

icon Bl to select another point.

Radius

Radius of the element, can be modified. Use the Reverse icon to switch
between long arc and short arc.

Azimuth
Use the azimuth to rotate the element. For tangents the azimuth value
specifies in which quadrant the result is located.
Use the Reverse icon to reverse the line, which means to add 200 gon to
the azimuth value.

Intersection 1/ Intersection 2

Intersections with arcs have more than one result.
Use the Tangentials Reverse icon to toggle between point and tangents
calculation.
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Tangentials: If you define tangents, you can specify a radius: Type O or keep
the value empty, if you want to calculate a straight line.

If you define a radius you can use the Show Next Reverse icon to show all
possible locations of the tangential arc.

Arc Intersection dialog box
Use the elements in the dialog box to modify the parameters of an arc
intersection. (page 133)
Arc 1/Arc 2
Specify the arc by a center point P1 or P2 and a radius.
Easting/ Northing/Radius
Coordinates of the center points. You can edit the coordinates in the dialog

box or use the Graphic icon Bl to select another point.
Radius of the arcs. You can edit the value in the dialog box or use the

Graphic icon Bl to define it in the drawing.

Tangent

If intersection type is Tangentials you can enter a radius. Set Radius to NULL
or O for straight line tangents.

Intersection 1
11

Points/Tangentials

Use the Reverse icon to change between intersection type Points or
Tangentials.

Intersection 2
12

Show Next

If you calculate tangents with a radius you can use the Show Next Reverse
icon to show all possible locations of the tangential arc.

Orthogonal Calculation dialog box

Use the elements in the dialog box to modify the parameters of an orthogonal
calculation. (page 135)
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Element
Base line for orthogonal surveying.
Click the Highlight icon to show the element in the drawing.
Click Graphic icon B to identify another base line.

Type an Offset value or use the Graphic icon Bl to shift the line.
Type a Radius value, if your base line is an arc.

Type an Azimuth value or use the Graphicicon B to modify the orientation
of the base line.

Point 1/ Point 2

P1 and P2: You can specify the base line by two points and a radius (straight
lines radius = 0).

With a point Offset value you can specify a base line that is tangent to a
circle with that radius.

If you click a base line in the drawing, the coordinates of the next two
vertices are inserted in the dialog box.

Easting/ Northing

You can edit the coordinates in the dialog box or use the Graphic icon B
to select another point.

Constructed
CP: Coordinates of the calculated point.
Use the Graphic icon B} to determine the abscissa and ordinate of an

existing point. This is useful, if you want to calculate another point with
delta values.

Abscissa/ Ordinate
Type the abscissa and ordinate of the new point.
Type negative ordinates to determine points that are left to the base line.

Use the Graphic icon B in the Constructed row to transfer the values of
an existing point into the dialog box.

Use the Graphicicon BT} in the abscissa or ordinate row to specify the value
in the drawing.

Value/ Delta

You can specify the values by an absolute number or by delta values, related
to the current value. This is useful if you want to calculate a number of
points with the same abscissa or ordinate distances.
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Type a delta value and click Calculate. The new value is calculated by adding
the delta to the current value. Click Calculate again. The delta is added
again.

Distance
Base line properties

Measured
Distance that has been measured in the field.

Calculated
Calculated distance of the base line points P1-P2; read-only.

Factor
Enter a Measured distance to calculate a factor, which is used to adjust the
differences between calculated and measured distance proportional to the
abscissa values.

Abscissa P1
Abscissa value at point 1; default is 0.00.
If your measurement did not start with the abscissa 0.00 you can type a
new value.
If your actual starting point is different to the indicated P1, you can use the
Abscissa P1 icon to select this point in the drawing. If the point is not on
the selected base line, the projection point is calculated.

Polar Calculation dialog box

Use the elements in the dialog box to modify the parameters of a polar
calculation. (page 136)

Element
Base line for polar surveying. It is determined by a station P1 and a
connection point P2
Click Graphic icon B to identify another base line.

Type an Offset value or use the Graphic icon Bl to shift the line.
Type an Azimuth value or use the Azimuth Reverse icon to interchange
start and end point.

Point 1/ Point 2

P1: observing station.
P2: connecting point to determine the base line. If you select a poly line,
the vertices that are nearest to the click are used.
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Easting/ Northing

You can edit the coordinates in the dialog box or use the Graphic icon L
to select another point.

Offset
Specify the base line with an offset to the selected element.

Azimuth
Azimuth of the base line (angle between base line and north).

Constructed
CP: Coordinates of the calculated point, target point.

Use the Graphicicon Bl to determine the distance and angle of an existing
point. This is useful, if you want to calculate another point with delta values.

Distance
Measured distance between station and new point

Angle
Measured angle (direction) to the new point CP (reading from field
measurement.

Value/Delta
You can specify the values by an absolute number or by delta values, related
to the current value. This is useful if you want to calculate a number of
points with the same distances or angles.
Type a delta value and click Calculate. The new value is calculated by adding
the delta to the current value. Click Calculate again. The delta is added
again.

Longitud. Shift
Enter a longitudinal offset.

Lateral Shift
Enter a lateral offset (rectangular to the P1-CP line).

Base Angle
Measured angle to the base line point P2

Orthogonal Projection dialog box

Use the elements in the dialog box to modify the parameters of an orthogonal
projection. (page 137)
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Element
Base line for orthogonal projection: P1 — P2

Click Graphic icon B to identify another base line.

Type an Offset value or use the Graphic icon Bl to shift the line.
Type a Radius value, if your base line is an arc.

Type an Azimuth value or use the Graphicicon B to modify the orientation
of the base line.

Point 1/ Point 2
P1: If the base element is an arc (radius is not null), you can use the Reverse
icon to switch between long and short arc.

Easting/ Northing/Elevation

You can edit the coordinates in the dialog box or use the Graphic icon B
to select another point.

Point P
P: Point to be projected. Use the Graphic icon Bl to select another point.

Projection
Coordinates of the projected point on the line.

Distance Measured/Calculated

Length of the base element, distance between P1 and P2. You can enter a
measured value to calculate a factor for adjusting the resulting abscissa.

Abscissa
Abscissa value of the projection line (ordinate = 0,00).

Abscissa P1
See also Constructions: Orthogonal Calculation (page 135)

Snap and Trim dialog box

Use the elements in the dialog box to modify the parameters of snap and trim
constructions. (page 138)

Element
Base line for trimming or extending, determined by points P1 and P2.

Click Graphic icon B to identify another base line.
Type an Offset value or use the Graphic icon Bl to shift the line.
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Type a Radius value, if your base line is an arc. If the radius is not null, you
can use the Reverse icon to switch between long and short arc.

Type an Azimuth value or use the Reverse icon to modify the orientation
of the base line.

Point 1/ Point 2

P1: start point of the base line.
P2: end point of base line.

Easting/ Northing/ Elevation
You can edit the coordinates of the base line in the dialog box or use the

Graphic icon BL: to select another point.

Point P

P: Point of the line to be modified, as default this is the first vertex of the
line definition.

Index

Use this value to switch to another vertex of the selected line. Index = 0
indicates the first vertex, index 1 the second and so on.

Feature ID
Use the Graphic icon BE to select another point.

Value
FID of the feature to be modified.

Moved P
CP: New end point of the line after trim or snap process.

Feature Class

Shows the current feature class. The result of snap or trim overrides the
existing feature.

Line Offset Calculation dialog box

Use the elements in the dialog box to modify the parameters of an offset (line
calculation). (page 139)

Base Feature
Base line for calculations (offset = 0.00).

Use the Graphic icon B% to select another base line.
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Add

Use this button to add definition rows for the offset lines. You can specify
the distance to the base line by mouse-click.

Shifted Line x

Definition rows for the offset lines.
Use the Add button to add more lines.

Start Abscissa/ End Abscissa

Use these values to extend or shorten the offset line in relation to the base
feature.
Use the Shift Abscissa icon or edit the text box to modify the value.

Shift

Offset value. The initial value is specified in the drawing. You can edit this
value, for example to set it to an even value.

S

Use the Shift Abscissa icon to specify the abscissa value in the drawing.

x|

Use the Delete icon to delete a definition row.

Right Angle Course dialog box

Use the elements in the dialog box to modify the parameters of a right angle
course. (page 146)

Point 1
Base line for calculations (offset = 0.00).

Use the Graphic icon Blf to select another base line.

Point 2

Use this button to add definition rows for the offset lines. You can specify
the distance to the base line by mouse-click.

Easting/ Northing

Coordinates of existing points. Use the Graphic icon B to select a point
in the drawing. Use the Delete icon to delete the coordinates of a point.

Distance
Measured value.
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Calculated Distance/Delta

Distance calculated from existing coordinates. The measured sections are
adjusted to the existing points. Delta shows the difference between measured
and calculated values, so you can decide, whether the object can be described
with a right angle course.

Point 3/ Point <nr>

The right angle course can consist of an arbitrary number of measured
sections and existing points. For sections only the distance column is filled
out.

Add Sections

Use the Add Sections button to enter the measured values. The focus changes
to the map and you can either specify the location with a click or type the
value.

Free Standpoint dialog box

Use the elements in the dialog box to modify the parameters of a free
standpoint. (page 148)
Free PT

The coordinates and the direction are calculated from the measurements
(distances and directions).
Use the Highlight icon to highlight the point in the drawing.

Point 1/Point 2/Point <nr>
Connection points with measured distances and directions.

Distance
Measurement (distance).

NOTE With 3 points and 3 distances you can calculate the center of three circles.

Delta
Difference between the measured and calculated distance.

Direction
Measurement (angle)

Ang. Delta
Difference of direction
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Add Point

Click to add another connection point: Select the point in the drawing and
type the measurements

X
Use the Delete icon to remove a point
LT

Use the Graphic icon to select the point or item in the drawing.

Center dialog box

Use the elements in the dialog box to modify the parameters of a center. (page
149)

Center
Coordinates of the calculated center point.

Point 1/ Point <nr>
Source points.

Use the Graphic icon B to select another point.
Click Add Point to add one or more source points.
Click Calculate to see the modifications.

X

Use the Delete icon to remove a point from the calculation.
B}

Use the Graphic icon to select the point in the drawing.
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Glossary

area topology Description of spatial relationship between geographic area
features. Area topologies contain line strings and centroids. In Topobase™,
the polygons are generated automatically from the surrounding line strings.
Examples of area topologies are parcels, land use, land cover and political
boundaries. See also Topology.

centroid A point that indicates a polygon (approximately in the center). In
Topobase, centroids are part of area topologies and belong to the surrounding
edges (line string feature class). The centroid normally holds the polygon's
attribute data. See also Area Topology.

COGO Abbreviation for Coordinate Geometry. COGO functionality provides
calculation routines, such as for intersection, projection, orthogonal survey,
offset lines, and right angle course.

Display Manager For stylization in Autodesk Map 3D, applies custom styles
to selected features and objects. To view the Display Manager task, select
Display Manager in the list at the top of the Task Pane. Also used for stylization
of Topobase features.

display model In Topobase, you use display models to administer thematic
views. A display model definition specifies which set of layer files (feature
layers) is loaded into the Display Manager. Also, the display model defines
multi map windows and autoload layers.

display model repository Central location on your file system or on a shared
networKk to store the display model files (*.tbdm, *.tbdmmap, *.LAYER, *.DWG).

Autodesk provides a default display model repository <default display model
repository> containing the display models for the demo data sets, and the
extensions.

document In Topobase, a document is an Oracle® database schema with
additional settings in the Topobase System user (database server schema TBSYS).
A document is an Oracle database user plus settings for menu bars, toolbars
and forms. A document must be assigned to a workspace to be accessible by
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Topobase Client or Topobase Web. You can create, edit, and configure the
documents using the Topobase Administrator.

document explorer Control element in the Topobase Client task pane and
in the Topobase Web layout. Use the tree view to show the objects that are
stored in the database. For different requirements and more clarity these
objects can be grouped into explorer groups. Provides a document-specific
view to process the following objects: Topics (and feature classes), domains,
topologies, intersections, system tables, and workflows. You can define a
different document explorers for each document. Also called Topobase explorer.

domain Sets of values. For example, a domain defines the values that are
allowed for a feature attribute. Topobase data models store domains in domain
tables (*_TBD). Domain tables are created using the Topobase data model
administrator.

explorer group In Topobase Administrator, a configuration that specifies
which objects are to be shown in the document explorer. These settings are
saved as Explorer Groups.

feature In Topobase, an entity of a feature class. Each feature in a feature class
represents a row or record in the feature class table.

feature class In Topobase, the basic class for objects. For example, a parcel is
a feature class. In a database, each feature class corresponds to one Oracle
table. A feature class can have any number of attributes (Oracle columns), one
of which can be of type "geometry". There are general types of feature classes,
such as the following:

Attribute (feature class without geometry)
Line String

Polygon

Point

Centroid

Label

Compound Polygon

Compound Linestring

You can group several feature classes for each topic. Each feature class contains
many entities/instances or records, which are called features.
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feature class form Database form to view and edit attribute data stored in
Topobase. Forms can be customized with the Topobase form designer.

feature explorer Control element used to display a set of features in a tree
view, resulting from a selection, a validation, or a tracing.

Feature Search Finds the location of a certain object, such as a building, a
parcel, or any other type of feature that has geometry. The geometry found
will be the center of a graphic generation or a zoom GoTo. There are several
types of search such as Sequential search and Flat search.

graphic connection A connection between Topobase and Autodesk Map or
Autodesk MapGuide to display the features. Topobase Client has a graphic
connection to Autodesk Map. Topobase Web has a graphic connection to
Autodesk MapGuide.

job perimeter Spatial area where a job can be processed. You can use job
perimeters to control where the modifications of the current job is allowed.
Features outside the job perimeter cannot be processed. Also, you can define
feature rules to be applied on the objects within the perimeter.

label In Topobase, any attribute data of a feature can be displayed as text,
using label features. Label features are generated by arbitrary select statements
that can be defined by the customer and therefore are a flexible way to add
inscriptions to the objects. Label definitions (select statements and other
settings) are stored in the system table TB_LABEL_DEF. Label definitions can
be created or edited using the Topobase data model administrator. Label
features can be stylized with the Display Manager by displaying the
LABEL_TEXT property.

label definition Select statements that create labels. The label definition 1)
queries data from the database and 2) specifies positioning and text orientation.
This information is used in the Display Manager for stylization.

label feature class Feature class type used to store label features in the database
<feature class name>_TBL. Each feature class (parent feature class) can have
exactly one label feature class. The label feature class contains default attributes
only, and contains no other specific attributes. It stores a relation to the parent
feature class.

label placer Places a label to generate a label feature, to write information
into the drawing or the map.

logical topology Description of the relationship of features of any feature
classes, both attribute or geometry feature classes. The features need not to be
spatially connected. For example, a logical topology connects points with
points, lines with lines,lines to points, or attribute features to attriute features.
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Utility networks are based on logical topologies that connect points (nodes)
and lines (edges).

For example, a logical topology can represent a waste water network or
electrical transmission lines.

master-detail form Type of feature class form where related records are shown
in an embedded sub-form on one or more tabs.

network topology See logical topology.

Polygon Object built of line segments that form an enclosed area. In Topobase,
polygons are stored in a polygon feature class.

profile In Topobase, a longitudinal section of line features. A profile is created
by projecting features on an axis.

profile data model Data model consisting of a set of profile system tables
and an arbitrary set of profile feature classes. Profile system tables store the
basic configuration and settings. Profile feature classes store the components
of each profile drawing.

prototype drawing Drawing that stores all used blocks, symbols, regular and
other lines, text styles and dimensioning styles.

schema plan A schematic diagram that represents real world features by
transforming the original feature geometry to an alternative location, for
example by applying a coordinate offset. The schema plan represents the real
world features in a clear structure, and preserves topology. A schema plan can
either be displayed as overlay to the original features, or in a secondary
window. You use Topobase Administrator to define schema plans.

schematic feature In Topobase, schematic features are derived from real world
features. They are stored in the database and are used to draw the schema
plan. Each schematic feature is associated to its real world feature.

TBMAIN Topobase Main User, which is a Topobase System User with restricted
rights. The default name for the Topobase Main User is TBMAIN. To start the
application, non-administrator users can optionally connect to the Topobase
Main User.

TBSYS Topobase System User. Topobase system database schema. Topobase
server component that stores application settings and server-side stored
procedures. The default name for the Topobase System user is TBSYS.
Application users must be connected to the Topobase System user or to the
Topobase Main User TBMAIN to start the application.
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template In Topobase, a template is an arrangement of recurrent features.
The arrangement includes feature attributes, geometry and connectivity. In
Topobase Client, you use templates to place a feature arrangement in one
single step.

topic In Topobase, a group of several feature classes. A topic is a collection of
feature class tables. Topics can be thought of as containers used to organize
feature classes. Considering a data transfer, topics are fully independent of
one another. Each topic may have sub-topics.

To build a clear and transparent data structure, you can group feature classes
into topics, group several topics into main topics, and define feature classes
with sub-feature classes. These relations between topics and feature classes
serve only as an illustration of the data structure. There is not necessarily an
actual relation between the tables.

Topobase Administrator A Topobase basic module, used for Topobase
administration. Topobase Administrator contains several components, such
as:

Topobase data model administrator
Topobase form designer

Topobase report designer

Topobase job administrator

Topobase Client A component of Topobase Administrator, used for registering
and processing data stored in Topobase through forms and using Autodesk
Map for graphic processing.

Topobase data model administrator A Topobase module used to process
and establish data structures (topics, tables, attributes, topologies, and
intersections) in Topobase. Also, you can define label definitions and
dimensioning.

Topobase job All changes in the Topobase data pool can be controlled and
performed by exact reports on appropriate processing steps, if they are
performed inside a job. Using jobs allows you to control the version. A job
includes various processing states (live, pending, project). For each processing
state, an application exactly defines which actions are allowed.

Topobase System User Database schema that stores application settings and
server-side stored procedures. Default name is TBSYS. Application users must
be connected to the Topobase System User to start the application. They can
either connect directly to the Topobase System User or use a Topobase Main
User which has restricted rights. See also TBSYS and TBMAIN.
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Topobase Web The web version of Topobase applications.

topology A geometric shape property in which metrical relations play no role.
Topology describes how lines, nodes, and polygons connect and relate to each
other, and it forms the basis for spatial analysis as network tracing. In
Topobase, topologies can be administered within individual groups of feature
classes. They can be defined with the Topobase data model administrator.

topology checker Tool to check topologies. The results are displayed in a tree
view, displaying all feature errors.

user A person who works with any Topobase application. Each application
user belongs to a group called a user group, with certain tasks and rights.
Examples of users: Mr. MILLER, Mr. SMITH, Ms. BAKER; BILLY, TONY, LARRY.

user group A group of users having certain task and rights. Examples of user
groups: ADMIN, VIEWER, EDITOR, and so on. A member of a user group can
access workspaces only if he has a permission. He may use certain tools and
functions and he has certain rights to edit or view the data.

utility model Topobase data model component for utility applications, which
provides feature classes and rules for utility networks.

viewport Area of interest for the generate graphic process. A Topobase viewport
is a spatial filter on the map.

workflow In Topobase applications, a guide for the user through tasks like
acquisition, analysis, and reports.

workspace The central workflow unit in Topobase. For different user groups,
such as EDITOR, VIEWER or ADMIN, you can define the appropriate
workspaces, with respective roles and rights. A workspace comprises one or
more documents.

From the user’s point of view, a workspace is the starting point of his work.
He must open a workspace to work with any Topobase application. By selecting
a workspace, he will load all necessary objects, including the appropriate
menus and toolbars, with a single mouse-click. Therefore, he can even access
data from different applications, such as land management and wastewater,
in arbitrary combinations.
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