Plot Tutorial

Working with Plots

NOTE This tutorial requires a workspace with one document. Your administrator
can create a workspace WS_Land_102, and import the land sample data provided
in Topobase 2010. Exercise 1 describes how an administrator sets up the plot
environment, and plot enables the document. We will be using the same display
model repository as in the Display Model tutorial. If you are not familiar with display
models, we recommend that you run through the Display Model tutorial first.

Topobase uses a Plot library that stores your plots and plot templates in the
database so that you can print your maps consistently and keep up to date.
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Plot—A plot definition contains the settings for sending a map to a plotter.
It specifies the printer, paper size, and display model for the plot. It defines
elements such as a map placeholder, legend, north arrow, and scalebar. A map
placeholder is a frame that designates where a specific area of a map is shown
in the plot. Each time you print the plot, the content of the map placeholder
- your GIS data - will be refreshed, showing what is currently stored in the
database without changing any plot settings. You can create a plot either from
a blank sheet, or you can use a plot template.

Plot Template—A plot template lets you specify some settings for all the plots
that use that template, while any unspecified settings can be set at plot time.
For example, you can specify the paper size, and elements for the plot, but
each individual plot can specify the printer to use and the insertion point and
rotation for the map placeholder.

Exercise 1a: Set Up Plotting

NOTE These procedures are performed by an administrator.

Before you start to create and print a plot or a plot template, you set up the
system, and you provide layouts and templates. In this exercise you will:

Plot-enable the Land sample data.
Create an explorer group.

Set the Plot Administrator options.

Specify that for each Generate Graphic the current drawing will be closed,
and a new drawing will be opened.

Populate a domain table with scale values.
Provide some folders in the Plot Library to store the plots and plot templates
of this tutorial.
1 Start Topobase 2010 Administrator and open the workspace containing
Land sample data.

2 In the Administrator explorer, on the left, select the document. Under
Document Settings, click Extensions.
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Notice that the COGO extension, and the Template Extension are already
selected. Select Plot Extension. Click Save.

In the Update Modules And Data Models window, click Update. Click
Close.

In the Administrator explorer, under the document node, click Explorer.
Create a new Explorer Group. Enter the name Tutorial Admin. Click OK.

Under the explorer tree, select all items, including the Plot topic. Click
Save Tree to save the explorer group.

As an administrator, you will use this explorer group to edit the plot
feature classes in Topobase Client. Later, as a Client user you will need
this explorer group; you will use the Plot Explorer instead.

In the Administrator explorer, under the document node, click Plot.

Under Plot Administrator, enter the default scale and insertion point.
The insertion point must lie within the spatial extents of your document.

B Default Scale: 1000.
B Easting: 600 000 m.
B Northing: 200 000 m.

The purpose of these settings is to enable the system to draw the initial
plot layout - the blank sheet- in Model space. These settings are not related
to the real map insertion point you will be using when you define a plot.

Leave Island Map Settings as they are. Click Save. We will use the Island
Map Settings later in Exercise 7.
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10 Exit Topobase Administrator.

11 Start Topobase 2010 Client and open the workspace containing the Land
sample data.

12 In the ribbon, click Settings tab » Setup panel » Application Options.

13 In the left pane of the Application Options window, click the Generate
Graphic node.

14 In the Display Model area, make sure that Close Current Drawings is
selected. This is the default selection. Click OK.

15 In the Topobase pane, click the Groups icon, and select the Tutorial
Admin group.

f To pobase

Oilok & BES
Tutorial Admin V ﬁ

Default

Tukorial Admin

Mo explarer group
+-I7 | Building

+ D Conskruck
= 10 o-a.oo

16 In the document explorer, expand the Plot topic, and the Plot feature
class. Right-click Predefined Plotscale, and click Show Form.

17 In the form, click the Details tab. On the form toolbar, click New Record.
Enter the Scale Identifier, and the scale values for 1:1000, 1:500, 1: 2000,
and 1:5000.
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When you capture a map, you can select the scale from this list.

Predefined plot scale - TB2010_LM_102

| General || Details || Related tables[ Table l
#[|« | Feature 1D: || Scale identifier: || Scale : || : || PlIt_plot_rmap: |
106340/ 1:000 1 1000
106341 1:500 1 500
1 ns342| 1:2000 | 1 | 2unn|[ ]

18 Close the form.

)

19 In the Topobase pane, click Plot Explorer .

The explorer shows the basic structure of your plot library.

20 Right-click the Plot Library node, and click Create New Folder. Enter the
name Plot Tutorial.

21 Right-click the Plot Tutorial folder, and click Create New Template Folder.
Notice the Template icon, and that the folder is automatically named
Templates.
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22 In the Topobase pane, click Document Explorer.

Exercise 1b: Display Models

Plotting requires at least two separate display models, one for the plot layers,
and one for the GIS layers. Along with this tutorial, we provide display models
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to use for the exercises. Your administrator can copy these display models to
your display model repository.

B LandTutorial: LandTutorial.tbdm

B PlotTutorial: PlotTutorial.tbdm

B PlotIslandMapTutorial: PlotIlslandMapTutorial.tbdm. This is for your
reference. In Exercise 7 you will create a display model for island maps.

Exercise 2: Create and Print a Plot

A plot consists of plot components (plot layers) and GIS data (GIS layers).
When you do not use a plot template, for each plot you need to specify
settings, such as scale, area of the map, north arrow, and scale bar. This exercise
introduces these plot elements. In a later exercise you will create a Plot template
that specifies the elements that are used for all plots that use that template.
In this exercise you will:

B Create a plot 1:1000.

B Add a label, a grid, a north arrow, and an image.

B Modify and adjust the plot layout.

1 In the ribbon, click Output tab » Plot panel » Plot New Definition.
Notice that in the Topobase pane, the Plot Library is shown.

2 Specify the plot, and enter the following values:

Template: None.

Printer: None. You need to set the printer to None in order to be able
to select the right paper format.

Paper Format: ISO A4 (210.00 x 297.00mm)
Orientation: Click Portrait.

Under Plot Display Model, select Open Display model, and select
PlotTutorial\Plot Tutorial.tbdm.

Enter a name: Market Place. Notice that the Draw Layout button is
now activated.

Under Location, browse for the Plot Tutorial folder.
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3 Click Draw Layout. The Model space displays a blank sheet. The Topobase
pane displays the Plot editor. Notice that the Display Manager has loaded
the Plot layers.
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4 Right-click Map Placeholder and select Digitize Rectangle. Follow the
instructions in the AutoCAD command line. We will later adjust the
position of the plot elements.

5 Right-click North Arrow and select Digitize Point. Press <ESC> to finish
digitalization.

6 Expand Plot Label, right-click Plot Name and select Digitize. Follow the
instructions in the AutoCAD command line.

7 Right-click Plot Scale and select Digitize. Follow the instructions in the
AutoCAD command line. Notice that the plot elements are added to the
explorer tree.
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8 Right-click Image and select Digitize Point. Press <ESC> to finish
digitalization. In the sample Plot display model, the default image is
represented as a red triangle. We will add more image types Exercise 3.

Until now, we have prepared a ISO A4 sized sheet of paper to be printed where
the map placeholder is a frame that designates where a specific area of a map
is shown in the plot in a specific scale. We will now select that area of the
map.

1 In the Plot editor, select the map placeholder. Notice that the Capture
Map button is activated. Click Capture Map.

2 Under Map Style, select the display model Land Tutorial. Click Generate.

3 If your GIS data is not visible in the viewport, in Display Manager, select
a layer, such as LM_Building, right-click, and click Zoom To Extends.
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NOTE If other drawings are open, and no display model is selected, click
<Ctrl> + <TAB> to switch between your drawings. Notice that for each
drawing, the Display Manager shows the related feature layers. Notice that
in the Capture Map Settings dialog box, the insertion point is adjusted.

4 Under Map Insertion Point, click Select, and click the insertion point.
5 Click Save Capture.

6 Click Close to quit the edit mode. Notice that the plot has been added
to your Plot Library. Select the plot, and click Preview to see the Layout.
Notice that the Preview is shown in the Layout tab.

You will now edit the plot to adjust the position of the digitized elements to
match exact values.

1 In the Plot Library, select the plot. Right-click, and click Edit. Notice that
the Topobase pane displays the plot explorer, and the drawing shows the
plot elements in Model space.

You can edit the plot elements either in the drawing by editing the
geometry, or using forms. To open the forms, do one of the following:

B Select the plot element in the drawing. Double-click.
B Select the plot element in the drawing. Right-click, and click Attributes.

B Select the plot element in the drawing. In the ribbon, click Home
tab » Quick Access panel » Attributes.

B Select the plot element in the plot explorer. Right-click, and click
Show form.

2 In the drawing, select the map placeholder, and double-click.

3 In the Map Placeholder form, click the General tab, enter the size of the
placeholder. Under Size, enter Height: 225 mm, and Width: 175 mm.
Under Position In Page, for the horizontal position, select 0 mm from
Center Of Page, and for Vertical, select 30 mm from Bottom Border. These
values are related to the Paper format.
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Size

Height: 225.00 2 Millirneter

"Width: 175.00 2. Millimeter

Fosition in page

Horizontal, | 0.00 & Millimeter From: |Center of page w
Yertical, | 20.00 1 Millimeter From: Battorn bordsr ~

4 Click the Details tab. For Display, select Grid, and enter the grid intervals
for Easting and Northing: 100 m. Click Update & Close.
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5 In the drawing, select the plot name, and double-click.

6 In the Plot Labels form, click the General tab. Under Position In Page,

specify the position of the label related to the sheet. For Horizontal, select
17 mm from Left Border, and for Vertical, select 30 mm from Top Border.

Click Update & Close.

General | Details | Related tables | Table

Feature 10: 106379
Parent feature 10: | 10g373 -
Label definition 1D: 1100

Pasition in page

Harizontal 17.00000000 mm From: | |_eft horder

Wertical 35.00000000 mm From: | Taop border

7 Click Close to quit the edit mode.
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8 In the Plot Library, select the plot, and click Plot. Select the Printer, and
enter the Plot Offset values. Click OK to send the plot to the printer.

Exercise 3: Customize the Layout

For the image and the north arrow, you have digitized point features, whose
representation is determined by the Plot display model. You can configure
the display model to display any symbol or AutoCAD block. Besides, you can
provide different types of images, north arrows, legends, or scale bars for each
scale, to be selected when you create your plot or plot template. In this exercise
you will:

B Provide different types of images, such as your own company logo.
B Adjust the display model to represent the different types of images.
B Replace the default image by your logo.
1 In the Topobase pane, click Document Explorer. Expand the Domains
node.
2 Right-click Plot Image Type, and select Show Form.
3 In the form toolbar, click Remove Filter.

4 Click New Record. For the new record, ID = 2, enter the Short_Value, and
the Value: Topo; Topobase. Click Insert.

5 Click New Record. For the new record, ID = 3, enter the Short_Value, and
the Value: Comp; Company. Click Insert.

6 Close the form.

7 In the Topobase pane, select the Default explorer group. Notice that the
Default explorer group does not display the Plot topic.
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Click Groups to hide the explorer selector.

In the ribbon, click Home tab » Display panel and select the Plot Tutorial
display model. Click Generate Graphic.

If prompted, whether to save changes, click Discard. The drawing displays
the plot elements in Model space. In Display Manager, the Plot layers are
loaded.

In Display Manager, select PLT_PLOT_IMAGE, and click Style.

In the Style Editor, under Point Style, select the Default definition, and
click Duplicate.

In line 1, click the area under Thematic Rules. In the Create/Modify
Expressions dialog box, click Property, and select ID_IMAGE_TYPE. This
value refers to the Plot Image Type you have edited before.

Create/Modify Expressions

% S - 9 .

Properby Operakar Math Funckion Text Funckion

][>

Mumeric Properties
FID

FID_PAREMT _PLOT
HORIZOMTAL_OFFSET
ID_HORIZOMTAL_POSITION

ID_IMAGE_TYPE
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14 Enter the expression ID_IMAGE_TYPE = 2. Click Validate, and if the
expression is valid, click OK.

15 Under Legend Label, enter Topobase.

16 Click the area under Style, and select the symbol from your symbol library,
for example from an AutoCAD Symbol Block File
<topobase_client>\Sample\Symbols.

iew: Pont
b sl A
Skyle a point symbol a3
Symbal: @ D
5 ol
U Select a symbol from a Symbol Library —
b Symbal Library: | <curent drawing> v g ]
) )
| Al —
Open Block Symbol File
Laok ir: | [ Symbals v > ¥ G-
F 8
N 3 Map - Electric,dwg
E Lﬁ 3Map - ER Fire Planing, dwa
My Recent 3 Map - ER Hazmat.dwg
Documents E Map - ER Incident Centers,dwg
R = 3 Map - ER Locators.dwg
5 EMap - ER Sensors.dwg
r 3
Desktop 3 Map - as.dwg
‘@ Map - Imperial Scale Bars.dwg
3Map - Metric Scale Bars.dwg
1{\_\ ,..-/ 3 Map - Morth Arrows.dwg

" Map - Poi .

a My Documents |0l {\‘?ap .Ffén.'nts Dr Interest.dwg

17 Add another thematic rule for the company logo ID_IMAGE_TYPE = 3.

Point Style For O - Infinity Scale Range

=5 New Theme. .. | g.ﬁ.dd a Rule D Duplicate 3% Delete = Delete All | G Up G Do

Thematic Rules Style Legend Label
ID_IMAGE_TYFE =2 [E [:] Topobase

3 ID_IMAGE_TYFE =3 [E b [:] Cornpany
[default) = A =

18 In the Style Point dialog box, under Size Context, use Map Space. For a
base scale of 1:1000, enter 20 Meters to draw a symbol of 20 mm height.
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NOTE You can use a Calculation to style a symbol size that is fixed for all
scales. In exercise 5 you will style a symbol size using a Calculation.

19 Click OK to close the Style Point dialog box.
20 Click Apply, and close the Style Editor.

21 Be sure to save the Tutorial Plot display model, consisting of one map.
In the ribbon, click Home tab » Display panel » Save Display Model.

NOTE Follow the same procedure to add more types of north arrows (Plot North
Arrow Type domain), legends (Plot Legend Type domain), scale bars (Plot Scale
Bar Type domain).

You can replace the default image by one of the images you have styled
previously.

1 Click Plot Explorer. In the Plot Library, select your plot.
2 Right-click, and click Edit.

3 In the drawing, double-click the image.

4

In the Image form, click the Details tab. Select the Image Type, such as
Company. Click Update. Notice that in the drawing, the image is updated.

You can adjust position of the image by entering relative values in the
form.
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5 In the Image form, click the General tab. Under Position in Page, For
Horizontal, enter 35 mm from Right Border, and for Vertical, enter 25
mm from Top Border. Click Update & Close.

% Image - TB2010_LM_102

Feature ID:

Puozition in page

General | Details | Felated tables | Table

Parent plat: | {pg4nz

Hornzontal:

Wertical:

6 Close Edit mode.

35.00000000 e Fram: | Right border

2500000000 Fram: | Top border

KK

7 Quit Topobase Client; click No when prompted to save changes.

Exercise 4: Add a plot label

A plot layout can contain static and dynamic labels. For example, the Plot
Labels describe content that is stored in the database, such as the name, or
the scale (PLT_PLOT.PLOT_NAME, PLT_PLOT.SCALE). When you change the

name, the label is updated automatically.

You can define additional plot specific text to be added to your plot layout.
In this exercise you will create a label definition to describe a comment, such

as “For internal review”.

1 Start Topobase Administrator, and open the workspace.

2 In the administrator explorer, select Data Model.

3 In the data model explorer, expand the Plot topic, and the Plot Label
feature class. Right-click Plot Label, and click Create Label Definition.
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4 In the Label Properties dialog box, under Name, enter “Plot label: Review”.

5 Under Content To Display (Select Statement), replace the default entry
by the following: SELECT 'For internal review' FROM DUAL. Note the
label ID that is displayed in the title of the dialog box. You will need the

ID when you define the label stylization.

O ®© N &

Click OK. Exit Topobase Administrator.

Under Positioning, select User Selects The Label Position.

Start Topobase Client and open the workspace.

In the Topobase pane, click Plot Explorer. In the Plot Library, right-click
your plot Market Place, and click Edit.

10 In the Plot Editor, expand the Plot Label feature class. Right-click Plot
label: Review, and click Digitize.
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11

12

Follow the AutoCAD command line. The label is added to the Plot
explorer. The label is represented in the default style. You can use Display
Manager, to define a different style.

Close the Plot Editor.

Exercise 5: Style Fixed Label and Symbol Size

On your plot, plot labels such as names should appear in a fixed size, regardless
of the plot scale. Display Manager supports Map space and Device Space. While
Map space works fine for your plot previews in Layout space, your labels would
not be displayed in their correct size when you edit the layout in Model space.
You can use a a calculation to style the plot label layer, so the plot labels are
displayed correctly both in Model space (Edit mode) and in Layout space
(Preview mode). The same applies to other plot layers, such as images, north
arrows, legend, and scale bar. In this exercise you will:

1

Create a Calculation for the Plot labels that query the current plot scale.
Create a Calculation for the north arrow that query the current plot scale.
Style the Plot label layer to display the plot name with a height of 8 mm.

Style the Plot NA layer to display the north arrow with a fixed height of
20 mm.

In the ribbon, click Home tab » Display panel and select the Plot Tutorial
display model. Click Generate Graphic. The drawing displays the plot
elements in Model space. In Display Manager, the Plot layers are loaded.

In Display Manager, select PLT_PLOT_TBL. Right-click, and click Create
A Calculation.

In the Create A Calculation dialog box, enter a name for the calculation:
PlotLabelScale.

Click Text Function, and select TB_SQL. Enter the following SQL
command: 'SELECT TO CHAR (SCALE DENOMINATOR) FROM PLT PLOT p
where p.FID = g.FID PARENT'
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5 Click Validate. Click OK.

6 In Display Manager, select PLT_PLOT_NA. Right-click, and click Create
A Calculation.

7 In the Create A Calculation dialog box, enter a name for the calculation:
PlotScale.

8 Click Text Function, and select TB_SQL. Enter the following SQL
command: 'SELECT TO_CHAR (SCALE_DENOMINATOR) FROM PLT PLOT p
where p.FID = g.FID PARENT PLOT'

9 Click Validate. Click OK.

10 In Display Manager, select PLT_PLOT_TBL. Right-click, and click Edit
Style.

11 In the Style Editor, select the row for LABEL_DEF_ID = 1100 (the plot
name). Click the area under Style.

12 In the Style Text Layer dialog box enter the following values.
B Size Context: Map.

B Units: Millimeters.

B Font Size: Click Edit Expression and enter: 8 * ToDouble (
PlotLabelScale ) . Click Validate. Click OK.
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The expression for the font size assumes that you have designed your
plot display model for a default scale of 1: 1000 and that you have set
the unit to millimeter.

In the Style Editor, click Apply.
In Display Manager, select PLT_PLOT_NA.
In the Style Editor, under Point Style, click the area under Style.

In the Style Point dialog box enter the following values:
m Size Context: Map Space.

B Units: Millimeters.

B Width: Select Expression. In the Create/Modify Expressions dialog
box, enter: 20 * ToDouble ( PlotScale ) .Click Validate. Click OK.

B Height: Select Expression. In the Create/Modify Expressions dialog
box, enter: 20 * ToDouble ( PlotScale ) .Click Validate. Click OK.
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17 Click Apply, and close the Style Editor.

18 Save your modifications: In the ribbon, click Home tab » Display
panel » Save Display Model. Be sure the Window list contains only one
map, and the Layer list contains plot layers only.

Exercise 6: Create plots from templates

In this exercise you will:

B Create a plot template 1:1000 consisting of 2 maps, one of which is a static
overview map.

B Create a plot template 1:500.

B Create plots using the templates.

For more information about plot templates, see the Topobase Client User
Guide.

1 Intheribbon, click Home tab » Display panel and select the Land Tutorial
display model. Click Generate Graphic.

2 Inthe Topobase pane, click Plot explorer. Expand the Plot Tutorial folder.
Right-click Templates, and click Create New Template.
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3

4 Click Draw Layout. Digitize the map placeholders, a north arrow, and
the plot name.

5 Digitize an image. Select Digitize With Form. After you have finished

digitizing, the Image form opens, and you can select an image type, and
adjust the position. In the form:

B Click Details tab. Select image type Company.
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B Click General tab. Under Position in Page, For Horizontal, enter 380
mm from Left Border, and for Vertical, enter 250 mm from Bottom
Border. Click Update & Close.

City A3 1:1000
380 mim _¥\
250 x 200
240 njm
130 x 160
20 mm a
20 mm

6 Select the second map placeholder. Click Capture Map. Capture the area
of GIS data that will be part of every plot you create from the template.
For example:

W Select Scale 1:5000.

B Map Style: Land Tutorial

7 Save the capture.

8 In the drawing, select the first - your main - map placeholder, and
double-click. In the Map Placeholder form, click the Details tab. Enter
the Map Scale 1: 1000. Notice that there is no Map Display Model selected.
You can select the display model when you create a plot from this
template.

9 Click Update & Close.
10 In the Plot editor, click Close. The template is added to your plot library.

11 In the Plot Library, select Plot Tutorial\Templates, right-click, and click
Create New Template. Create another template 1:500.

12 Your templates are added to your plot library.
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NOTE When you use the Plot New Definition command, the item that is
currently selected in the Plot Library will be used. That means, if you have a
template selected, this template will be pre-selected. If you have selected a
plot, this plot will be sent to the printer.

Topobase

Hs ok (5 BH &
= 7] Plot Library
C\ Templates
=-F7] Plak Tutarial
=-E) Templates
Cikw &3 1:1000
Ciky & 3 1:500
[ Market Place

In the ribbon, click Home tab. Make sure the Land Tutorial Display model
is selected. Click Generate Graphic.

Click Output tab » Plot panel » Plot New Definition.

In the Plot New dialog box, under Plot Template, select Open From
Library. Select City A3 1:1000. In the Plot New dialog box, enter the
following values:

B Map Style: Land Tutorial.

B Notice that you cannot select the scale. The scale has been set in the
template.

B Map Insertion Point: Click Select, and click the point in the map.
Optionally, you can save the plot.

B Name: Enter City East.

B Select Save Plot Definition.

B Browse for the folder in the Plot Library: Plot Tutorial.

|

Clear Plot Now.

Click Save. The plot is added to your plot library.

Select the plot, and click Preview.
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19 Create another plot from the template City A3 1:500: In the Plot Library,
select the template City A3 1:500.

20 In the ribbon, click Output tab » Plot panel » Plot New Definition.

NOTE When you capture the map, under Map Style you can select Use
Current Drawing. Then, your plot will not use the selected display model,
but the current drawing, including ACAD entities, and any modifications you
have made on the display model without saving. If selected, you cannot save
your plot.

In the Plot Library, you can copy your plots between the folders. Select the
plot, right-click, and select:

B Copy—Create a copy of the plot. When you Paste the plot, the system
duplicates the plot in the database.

B Copy Link—Create a link of the plot. When you Paste the plot, the system
adds a link to the destination folder, that means that the same plot can
be shown in multiple folders of the Plot Library.

Exercise 7: Create an Island Map

An island map has irregular borders defined by a perimeter feature class or a
topology. For more information see the Topobase Client User Guide.

Island maps require a display model that contains both the GIS layers, and
the plot layers including the island buffer layers. In this exercise you will:

B Specify Administrator Island Map settings.

B Create a display model that supports island maps, and where buffer 1
displays the parcel borders and border points, and buffer 2 displays border
points.
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Base Island Perimeter

Buffer 1

Buffer 2

., -
—
—

B Create an island map from a plot template.

1 Quit Topobase Client; click No when prompted to save changes.
Start Topobase 2010 Administrator and open the workspace.

In the Administrator explorer, under the document node, click Plot.

A W N

Under Island Map Settings, select the Island Perimeter feature class
PARCEL_TSUR.

5 Set the default values for First Buffer to 20 m, and Second Buffer to 50
m.

In this exercise we use large buffer values, so you can clearly see the use
of the buffers.

6 Click Save, and exit Topobase Administrator.
7 Start Topobase Client and open the workspace.

8 In the Topobase pane, click Plot Explorer.
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9 Select the plot Market Place. Right-click, and click Edit. Notice that the
Display Manager loads both GIS layers, and Plot layers.

10 In Display manager, click Data » Connect To Data. Select the existing
Topobase connection, and add a layer for the data source
PLT_PLOT_ISLAND_COVER.

Home Tools Settings [elfadhy =

o Data Connections by Provider [7] Data Connecthelp. i) Learn more
B Fd Add ArcSDE Connection A Topobase
_,Q_ Add MySQL Connection Topobase_1 [orcl/TE2010_LM_102 [17)
F{d Add ODEC Connection AddDatatoMap
% 2:: :;::: ?rzzgzc:rugurface Conne Available sources in this connection.  Select Items ko add ko the map as lavers.
% Add SDF Connection @ Edit Coordinate Systems | E‘@ Refresh
5% add SHF Connection L -
F Add 5L Server Comnection Schema Coordinate System iadl
Fd Add 50L Server Spatial Connection LI EHPLT_PLOT_GRID < unknown >
f3 Add Topobase Connection [] (D PLT_PLOT_GRID_EXTLINE < unknown =
=-{=) Topobass_t [l O PLT_PLCT_GRID_EXTLINE_TBL < unknown =
£ LM_BUILDING O O PLT_PLOT_GRID_FRAME < unknown =
£ LM_BUILDING_TEL [ EFPLT_PLOT_IMAGE < unknawn >
<7 LM_LANDUSE (IPLT_PLOT_ISLAND_COVER. < unknawn >
g tm_:;ir;[éﬁfE_L O PLT_PLOT_LEGEND < unknown >
5 L_PARCEL | O pLt_pLor_mep < unknown v
2= LM_PARCEL_TEL £ 2
& LM_POINT I
£ LM_STREET_TEL L = — 1

11 Add two more layers for PLT_PLOT_ISLAND_COVER. If you want to use
two buffers, the display model requires 3 layers to display the island itself,
the island plus buffer zone 1, and the island plus buffer zone 2.

B PLT PLOT_ISLAND_COVER (2): Displays the map within buffer 2.
This island cover displays the selected islands plus buffer 2.

B PLT_PLOT_ISLAND_COVER (1): Displays the map within buffer 1.

B PLT PLOT_ISLAND_COVER: Displays the map without any buffer.
This island cover lets only the selected islands be visible in the map.
For the Draw Order, this is the first plot layer to be drawn.

12 Style the island cover areas to be solid white.

13 Save the display model.
B Click Home tab » Display panel » Save Display Model As.

B Check the properties: Be sure there is only the Plot map in the Window
list. Remove any other maps.

B Enter a name: Plot Island Tutorial.

B Enter the map name: Plot Island Tutorial Map.
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14

15

16

17

18

Notice that the GIS layers are referenced.

Reference the Plot layers: For all Plot layers, except the
PLT_PLOT_ISLAND_COVER layers, select the Ref. check boxes.

TIP You can select the relevant items in the Names column using the <CTRL>
or <Shift> key or using <Ctrl> + <A>. Then select one item in the Ref. column
to check all the items.

Remove the filter for the GIS layers: Clear the Filter check boxes.

General
Name

Plot Island Tutorial

Window list

Name Coordinate 5. State Height | Width | X i
Plot Island Tutorizl Map Maximized 105% 100% 0% -5%
Layer list

Name Feature (| Autoload | Filter | Confin | Selectal| So| Ref. Path

PLT_PLOT_DECORATION_TEL O O JEtotTutorial
PLT_PLOT_IMAGE O O
PLT_PLOT_DECORATION O O
PLT_PLOT_GRID_FRAME O O
PLT_v_GRID_EXTLINE_TEL ] [
LM_PARCEL_L O O o JLandTutorial/l
FLT_PLOT_MAP O O
LM_POINT O O od
PLT_PLOT_GRID O O
PLT_PLOT_CROSSHAIR O O
LM_PARCEL O o 0O
LM_LANDUSE O 0O O
LM_V_LANDUSE_TSUR O O O
1A 1 ANPMISE | - - [_al - -

Click OK. Click Yes to continue and overwrite the referenced layers.

A dialog box displays your repository.

Click Create New Folder and name the new folder
DM_Plot_Island_Tutorial. Click Open and then click Save.

Close the Plot editor.
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19 Draw Order—Modify the draw order, so that the island displays your
complete drawing, the first buffer displays the parcel lines, and the second
buffer displays border points.

In Display Manager, click Groups » Draw Order.

20 Drag the layers as shown below.

= - e e e e e

—— PLT_PLOT_GRID

[ 1 PLT_PLOT_ISLAND_COVER (2)
[ Oy fn o LM_POINT
[ ] PLT_PLOT_ISLAMND COVER {1}

LM_PARCEL_L
N PLT_PLOT_ISLAMND_COVER
LM_PARCEL

Layer: TB2010 LM_102:PLT_PLOT_ISLAND COVER
__________ Data Souwrce: PLT_PLOT_ISLAND_COVER
Connection: Topobass_1

Number of Layers using this source: 3
label | Coordinate system:

First plot layer: PLT PLOT_ISLAND_COVER.

Parcel lines: LM_PARCEL L.

Second plot layer: PLT_PLOT_ISLAND_COVER (1).

Border points: LM_POINT.

Third plot layer: PLT_PLOT_ISLAND_COVER (2).

Forth and all other plot layers: PLT_PLOT_GRID, keep the same order as
in the sample plot display model.

21 Click Home tab » Display panel » Save Display Model. Check the
properties: Be sure the Layer list shows the changed draw order.

22 Click OK. Click Yes to continue and overwrite the referenced layers.

23 In the Plot Library, select the Plot Library node.
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24
25
26
27

28
29
30
31

32

33

Select the Land Tutorial display model. Generate graphics.

In the ribbon, click Output tab » Plot panel » Plot New Definition.

Select the template City A3 1:1000.

Under Map Style, select Plot Island Tutorial. Notice that you can now

create islands.

b ap ztyle:

Flat 1zland Tutornial

Scale:

1: 1000

b ap inzertion paint;
E azting:
BEVE20.96

The zelected dizplay model allows pou to create an izland map

[] Create izland map now

Select the Map Insertion Point.

R otation:

Harthing:

w Generate

[gon clockwize]

Select Create An Island Map Now. Click Next.

In the Island Map Settings dialog box, click Select.

In the drawing, click the parcels you want to draw. (You might want to
turn off AutoCAD OSNAP to click the parcels.) Click Enter to finish the

selection.

Enter a name: Parcels 1:1000. Click Save.
The plot is added to your Plot Library\Plot Tutorial.

Select the plot, and click Preview.
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Exercise 8: Web Plot

NOTE This exercise requires that the Land workspace that can be opened in
Topobase Web. See the Topobase Installation and Configuration Guide. Your
Administrator can set up MapGuide, and the Topobase Web Layout.

=-F7] workspace - WS_Land_102 b apl vide
7 'wieb Lapout -
£ Plug-in Control MapGiuids Site:
+ Docurment - TB20T0_LM_102 ;
N Etup - - http: A#4127.0.0.1 /mapauide2010
£ UserUserGroups :
P User Interface tapGuide Uzermame:
0 MapG_ uide Administrator
£ Plug-in Control
tMapGuide Pazsword:
admit
=-F7 workspace - w5 _Land_102 wieb Lapout
£ web Layout
F7 Plug-in Caontral wfeh Lapout:
é ;Dt Document - TB2010_LM_102 Library: 44T opobase Land/TB2010_LM_F ApplicatiorDefinition v
Be uLiljser.-’UserGroups ‘wieh Symbol Library:
F7 User Interface 7
7 MapGuide ‘wieb Sumbal Marne:
F7 Plug-in Cantral =
‘wieh Viewer:
Fuzion v

In this exercise you will:

B Publish the Display Models to MapGuide. Each display model has to be
published to its own folder: Land Tutorial, Plot Tutorial, and Plot Island

Tutorial.

B Create and print a plot.

1 Start Topobase Client.
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Select the Land Tutorial display model. Generate Graphic. Make sure
there is no spatial filter applied.

In Display Manager, click Tools » Publish To MapGuide.

Enter the site URL, and click Connect.

In the Publish To MapGuide dialog box, select the site node. Click
New Folder.

Enter a name: Tutorial Land. Click Publish.

NOTE The sample data has no coordinate system assigned. When you Publish
To MapGuide the log file contains a warning about this. You can assign the
coordinate system in MapGuide Studio.

In the ribbon, click Home tab » Display panel and select Assign Display
Model Map For Use In Topobase Web.

# [ Land Tutorial (]| || @ IJ? @ L%

(5L, Connect to Data... Style La
# Connect to Data e hER E Save Display Model

Display
g save Display Model As...

Display Madel Properties

@ Assign Display Model Map for use in Topobase Web

For the Land Tutorial display model, select the MapGuide Definition.
Notice that you can assign one MapGuide definition for each map of
your display models.
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l Assign Display Model Map for use in Topobase Web

-

Display Model

Land Tutorial (1)

Plot Tutorial (1)

Flot Tutorial

Select the appropriate MapGuide Definition for each Display Model Map.

MapGuide Definition

Cancel

Land Tutorial Main Map Library://Tutorial Land/Default.MapDeafi |,

Flease selact g

9 Click Save. Click Close.

10 Start MapGuide Studio.

11 In the MapGuide Site Explorer, double-click the Tutorial Land > Default

map.

12 Under Settings, locate and select XY-M in the Arbitrary X-Y Coordinate
System category.

Map Editor
[=] Settings

Description:
Loordinate system:
Background color:

Initial g

Lower left coordina

Upper right coardi

Use curent map 2

[=] Layers

I anare b Rrmnim

Setting: Layers Base Layers

P

“_", Coordinate System

Categories: Arbitrary ¥y Coordinate Spstems

Available coordinate systems:

Code Description Prajection
=N Aybitrary 27 Coordinates [U.5 . Survey Inches) Mon-georef...
wr-IvD Aybitrary 27 Coordinates [I'vards) Mon-georef...
-k Arbitrany #-7 Coordinates [Kilometers) Mon-georef...
kT Arbitrary #-Y Coordinates [Knats) Mor-gearef...
=M Abitrary 2 Coordinates [Meters] Mon-gearef...

13 Exit MapGuide Studio, and save the changes.

14 Follow the same procedure to publish the plot display models to

MapGuide.

B Plot Tutorial: Library://Tutorial Plot ...

B Plot Island Map: Library://Tutorial Island Plot ...
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15 Start Topobase Web, and open the workspace.
16 In the taskpane, click Plot Library.

* Topobase Explorer
Display Madel: [ Land Tutorial v
Document: | TB2010_LM_102 v |
Explorers: % Efﬁ E;h %
Default Flok LiI:urar';.-'l M ~
0 Tez010_Lm_102
E| EI Topics
- BT Buitding
" EI Landuse

17 The Plot Llbrary displays your plots and plot templates.

* Topobase Explorer

Disglay Model: (Land Tutorial |
Document: | TB2010_LM_102 v
Explorers: Hg o 5]

]
E_I Flot Library

EﬂTemplatEE-
= B piat Tuterisl

E| EE Templates

g LR city a2 1:1000
: City A2 1:500

t [ =
N e

18 Right-click a plot template, and click Create New With Template.

19 In the Create New Plot dialog box, enter a name.
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20 Under Template Maps < Actions, click Capture Map.

E Create Mew Plot - Microsoft Internet Explorer provid...

—IiZeneral

Name:

|Web City 500

Sawve in plet library location:

|F"Iut Library'Flot Tutorial

| [ Browse...
—Design
Cheoose template from library:
|P|ut Library\Plot Tutorial\Templates\City A3 1:500 | [ Browse... |

Template Maps:

Map | State | Actions

21

22 Under Map View, select the display model.
23 Click Select, and click the Map Insertion point.
24 Click Save Capture. Click Create.
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