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Tutorial 4 — Advanced

Exercises
In this tutorial, you learn how to create 3D effects, use In this tutorial
the Web tools called eTransmit, hyperlinks, and gener- B Create 3D Effects

ate a database report. W Use Web Tools

B Generate a Database Report

More information about each of the concepts in this

tutorial is available in the AutoSketch®Help system.




Create 3D Effects

2

In this exercise, you learn to

O Create a 3D parallel extrusion.
O Use the Standard toolbar.
O Use the 3D Effects toolbar.

While two-dimensional drawings are the basic building blocks of most
projects, you might need a three-dimensional view of a project. In
AutoSketch, you can simulate three-dimensional drawings through parallel
and perspective extrusion.

m 3D parallel extrusion creates a copy of the selection set that you place in
the drawing. AutoSketch connects corresponding edges with lines or poly-
gons. You learn how to create a 3D parallel extrusion in this exercise.

m 3D perspective extrusion creates a scaled copy of the selection set. You
place the copy anywhere in the drawing, and AutoSketch connects the

corresponding edges using lines or polygons.

To apply parallel extrusion to an entity

1 On the File menu, click New. In the New dialog box, click Start a Drawing

Immediately, and then click OK.

Hew

Wizard | Template

Select Wizard name:

Create Precizion Drawing
Building

Office Layout

“work, Bench Project
Diiagram

Mechanical Part

Creates a new drawing page
bazed on the default page

zettings. To start drawing
immediately, click OF.

Create a new drawing using a ‘Wizard

Ok Cancel

Now, you reset the interface to make sure your settings match the

tutorial’s instructions.
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On the View menu, click Toolbars.

Toolbars
Toolbars: i
Status ”~
Standard I
Property
e '
Shap
[Symbal Library
Content Librarian
[“]&Hn-One |
[]3D Effects hd
Button Size: Small e Show ToolTips

In the Toolbars dialog box, in the lower-right corner, click Reset Interface.

In the warning message that is displayed, click Yes.

AutoSketch

This command will change the position and visibility of all of the toolbars, This will destroy any customization made to
. the toolbar layout, Are yvou sure that you want ko da this?

Your drawing window is now opened and set up for this tutorial.

On the Snap toolbar, click the Centerpoint Snap button to turn it on.
On the All-In-One toolbar, click the Circle button.

On the toolset, drag the pointer to select Center, Side Circle.

In the drawing, create two circles of roughly the same size.

Your drawing should look similar to the following illustration.

()
5
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g 9 On the Standard toolbar, click the 3D Effects button.
The 3D Effects toolbar is displayed.

i A

10 Click the circle that is closer to the bottom of the drawing.

! 11 On the 3D Effects toolbar, click the 3D Parallel Extrusion button.

12 In the drawing, click the bottom circle again.

()
Sl

This is the first of two points that define the distance and direction that
the selection set will be extruded. A rubber-band extrusion appears and
moves the same distance and direction as the pointer.
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13 Click the edge of the second circle. The selection set is extruded.
14 Right-click to end the command.

Your drawing should look similar to the following illustration.

15 On the File menu, click Close.
16 In the Save Changes to Drawing dialog box, click No.
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Use Web Tools
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AutoSketch Web tools include Web editing tools (such as eTransmit, and
hyperlinks creation).

Use eTransmit

In this exercise, you learn to

O Create a transmittal set of an AutoSketch drawing and related files.

O Email the transmittal set (an Internet connection is required).

O Check the receipt of the transmittal set and save it (an Internet connec-
tion is required).

With eTransmit, you can create a transmittal set of an AutoSketch drawing
that automatically includes all related files. You then publish the transmittal
set as an email attachment.

When you use eTransmit, a report file is automatically generated that
includes instructions detailing what files are included in the transmittal set
and what must be done with them so that they are usable by the original
drawing. You can also do the following:

m Add notes to the report and specify password protection for the
transmittal set.

m Specify path options for the transmittal set and create a self-extracting
executable or zip file that packages all the files.

To create a transmittal set

1 On the File menu, click Open.
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Open Drawing File
Loak in: |.|-:| Drawings |v] e " x LY Miews v Toos
= T Preview
.} Mame = Sie|
L\..:" [33_demodh. skf 221k
Histary [FHassembly 1.5kF 720k gﬂ:[- m._ ;5
o 5 BgE
208
My Documents || [T Homez. SKF 171K =
A jig.skF 62K Show Preview
w [ office_dh.5kF 9K
Eiics OFFiceSheII.SKF 29K
[Fpaddle done.5kF 282
[Fpid.skf 138k
security.skf 80k
Desklop speaker.SKF 122k
[Biestsite.5kF 192,
<] i (2]
e iBirdhouse_finaI.SKF Iv] E'
Fils of type: | AutoSketoh (* 5KF) ]

2 In the Open Drawing File dialog box, in the Drawings folder, click
Birdhouse_final.skf. Then, click Open. (This drawing is the completed
drawing that you worked on in Tutorial 1, “Create a Birdhouse Drawing.”)

3 On the File menu, click eTransmit.
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eTransmit
[N
Current Drawing:  C:\Program FileshAutodes. . ings\Birdhouse_final SKF

General : .Files Fieport |

Motes:

.Let's create a Eirdhouse this weekend, based on the drawing | created in AutoSketc:.h. |

Tupe:

Path processing:

[ Make web page files

[ Ok, ] [ Cancel I

4 In the eTransmit dialog box, in the Notes section, add any notes you want.
5 In the Type list, select Set of Files.

6 Clear the check box next to Make Web Page Files. You don’t make a Web
page in this exercise.

7 Click OK.
If the Choose Profile dialog box is displayed, click OK.
Choose Profile
Prafile Mamne: |Out|00k2 j Mew, ..
[ OF ] [ Cancel ] [ Help ] [Options >>]

Your default email program opens with an email that contains the files, as
shown in the following illustration.
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= Untitled - Message (Rich Text)

File  Edit View Insert Format  Tools  Actions

Hsend | | & B R0 @
Verdana - 1 - é B I O

€} This message has not been sent.

Subject: |

9]

Birdhouse_final.txt  arial.ttf {304 KB 3irdhouse_final. SKF
(741 B) (122 KB)

9 Inyour email program, enter your own email address, and send the email.

10 Check your email inbox, and save the transmitted files.

11 In AutoSketch, on the File menu, click Close. Do not save your work.

Create a Hyperlink

In this exercise, you learn to

O Assign a hyperlink to a Web site.
O Open the Web site (an Internet connection is required).

You can assign hyperlinks to entities in your drawings that point to Web
pages, or to other files stored on local servers or on the Internet.

To assign a hyperlink to a Web site

1 On the File menu, click Open.

Use Web Tools
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Open Drawing File
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2 In the Open Drawing File dialog box, in the Drawings folder, click Jig.skf.
Then, click Open.

The drawing you opened should match the following illustration.
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3 Click and drag your pointer from the top left portion of the illustration on
the left to the lower-right corner of that illustration. When all of the enti-
ties in the illustration on the left are selected, release the mouse.
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The drawing should match the following illustration.
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4 With the entity still selected, right-click, and then click Group. Do not
right-click again, because you want the entity to remain selected.

The individual entities are now grouped into a single entity. Now, assign
a hyperlink to this grouped entity.

5 On the Database menu, click Edit.

6 In the Edit Hyperlink dialog box, in the Hyperlink (File or URL) text box,
enter www.autodesk.com, and then click OK.

Edit Hyperlink
Hyperlink [File or URL); Browse... 0K,
wiww. autodesk. com

The entity you grouped is now hyperlinked to the Autodesk Web site.

Use Web Tools | 11
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7 Anywhere in the grouped entity, right-click, and then click Jump to
Hyperlink.

If you have an Internet connection, the Web site now opens.

Generate a Database Report

In this exercise, you learn to

O View a symbol’s properties.
O Select a database report.

O Run a report.

O Print a report.

The office plan you use for this exercise is a simple office plan, much like the
office layout you created in an earlier tutorial. This drawing contains several
symbols, each of which represents individual office items that can be ordered
from a manufacturer. Using the database feature in AutoSketch, you can
create a database report to run when the time comes to order the items.

To create a database report

1 On the File menu, click Open.
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Open Drawing File
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2 In the Open Drawing Files dialog box, in the Drawings folder, click

Office_db.skf. Then, click Open.

The drawing you opened should match the following illustration.

Generate a Database Report
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3 In the drawing window, right-click the chair, and then click Symbol

Properties to display the Symbol Properties dialog box.

Symbol Properties
=
Froperty Walue
Bazepaint 109.50", 78.00"
Scale Factor 1.00,1.00
Aszpect 1.00
Angle 135.00°
Extent Size 24.89", 2483
Color 0: Black [By-Layer)
Style Solid [By-Layer)
WwWidth Hairline [By-Layer]
Layer 1
uip 5
Manufacturer [String)  Herman Miller
Wendor [String] western OFf. Equip,
Employee [String] Beth Morgan
Frice [Mumber] 438,50
Purchase Date [String)  09-22-92
Symbol Mame ChairQperator
Symbal Type zeating
Symbol Description operator's chair

The chair symbol contains a lot of information. Viewing the Symbol
Libraries dialog box, you can find out this symbol’s properties and values,
such as its basepoint, scale factor, color, width, layer, name, and manufac-
turer. This information can be extracted to a database report.

4 In the Symbol Properties dialog box, click Close.
5 In the drawing, press CTRL-A to select all entities.
6 On the Database menu, click Report.

-

Database Report

Reports ] Organize ]

Available Reports:

Edi..
Lreate...
Fename

Delete

| Employee Invertary

Cloze

In the Database Report dialog box, you can see that one report, “Employee
Inventory,” is selected.
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7 Click Report.
The Employee Inventory report is generated, as shown in the following

illustration.
Employee Inventory ?
H & gt =
M anufacturer Sy ame Wendor Frice UID | Employe
Compag Compk.eyboard Computtfa... | 89.47 | 47 Beth Man
Compag CompCazeDesk | Computwa... | 294076 | 46 Beth Man
Herman Miller Wik SurfCror 24 ‘Western 0., | B90.81 |6 Beth Man
Herman Miller Wik Surf 72624 ‘Western 0., [ 48892 | 11 Beth Man
Herman Miller Witk Surf 24w24 ‘Western 0., | 36812 |9 Beth Man
Herman Miller FileL-4dr 18x30 Western 0., | 712058 |12 Beth Man
Herman Miller Chair0perator ‘Western 0., | 43860 |5 Beth Man
Herman Miller ChailConference | Western 0., | 554.20 |13 Beth Man
MEC Comphdon 16 ABC Comp... | 82290 |15 Beth Man
< ¥

= 8 In the Employee Inventory window, on the toolbar, click the Print button.

9 In the Report Print Options dialog box, click Print to print the Employee
Inventory report.

Report Print Options

Fiepart Title:

P
Employee Inventary

Frint Column Headings

Colurnnz ta Print:

Calurnn Title Frint?
M anufacturer
SymMame
Wendor
Frice
uip
Employee
Furchase D ate

Foater
Fage Mumber

Date/Time

Frinter

idabe POE ™

Nice work! You have completed all of the tutorials offered in Getting Started.
Now, you can become more proficient with CAD, explore AutoSketch, and
use the program for your drawing needs.

To find out how to perform tasks not highlighted in these tutorials, or to
learn more conceptual information, see the AutoSketch Help system.
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