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Getting Started

About Autodesk MatchMover
Autodesk® MatchMoverTM is a camera tracking application that automatically
captures 3D camera path and camera parameters from 2D video and film image
sequences. After capturing a 3D camera path with MatchMover, you can export
the camera data to a number of file formats supported by 3D animation or
compositing programs. This allows you to work with the camera data in your
favorite animation or compositing application to accurately place 3D objects
into a video or film sequence. Providing a straightforward and cost-effective
way to mix 2D live-action footage with 3D animation and special effects,
MatchMover allows you to take advantage of the 2D world of film and the 3D
world of animation.

MatchMover extracts all camera parameters from information contained in a
film sequence. From a set of 2D points automatically tracked through an image
sequence, MatchMover computes the following:

■ The camera path and all the camera internal parameters such as zoom and
distortion.

■ The coordinates of the 3D points that project onto the 2D point tracks.

■ The motion of independent moving objects.

A preview sequence with additional computer-generated objects in the scene
can be generated to check the quality of the tracking result. If necessary, post
filtering can be used to smooth the computed camera path. The camera data is
then ready to export to an animation or compositing program.

With MatchMover, no geometric data from the set or from the camera is
required, but they can be used for faster computation and stronger constraints.

1
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Integrated high-end 2D tracking modes enable very precise camera
reconstruction. MatchMover works with any type of camera equipment, any
image resolution, and can process any camera path in the most commonly
used image formats.

MatchMover Help

MatchMover Help overview
The MatchMover Help is accessible from the Help menu of MatchMover. The
MatchMover Help appears in your Web browser and gives you complete access
to the online documentation of MatchMover, including Tutorials, Interface
Guide, and User Guide.

The left-hand navigation frame gives you tabbed access to Contents, Index,
Search, and Favorites. Help information appears in the right-hand frame.
When you first open the MatchMover Help, a legend appears in the right side
frame, showing the various information types of the MatchMover Help.
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Navigation buttons are available on the top of the right-hand frame. These
include:

■ Show in Contents  the left-hand frame, if necessary, and highlights
the current topic.

■ Add to Favorites  : adds the current page to the Favorites list.

■ Home  : reloads the home page of the MatchMover Help.

■ Previous Page, Next Page  .

■ Up one level  : opens the parent topic of the current topic.

You can click Please send us your comment about this page at the bottom of
each page, to send an email to MatchMover documentation about the current
page.

There are also Index, Search, and Favorites pages that you can access by clicking
the appropriate button in the left panel.

Index

The index provides you with an alphabetical list of key points in the
documentation. Clicking any of the keywords in the index displays the
appropriate subject in the right panel.

You can search the index by typing a query into the textbox at the top of the
left panel. When you click the View button, the left panel automatically scrolls
to the first instance of the queried keyword, whose page is then displayed in
the right panel. You can click the Next button to move to subsequent instances.

Search

You can search through the documentation for words or combinations of
words using the search menu. Type your query into the textbox and click the
Search button. Matches are ranked according to the number of occurrences
of the keyword(s) and are listed from the highest rank to the lowest. Search
also has a number of options.
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Search Method Defines whether to find topics containing any of the keywords
(or) or all of the keywords (and).

Match case Considers upper or lower case when searching.

Highlight When on, all instances of the keyword(s) are highlighted in the
result pages.

Find whole words only When on, the search does not consider partial
matches. For example, when Find whole words only is on, if you search for
the keyword model, modeling does not match.

Favorites

Displays a list of pages you’ve designated as favorites using the Add to Favorites
button. You can remove a favorite page at any time by selecting the page and
clicking the Remove selected from Favorites button.
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Tutorials

Introduction

Autodesk MatchMover enables artists to track 3D camera data and motion
from videos and film sequences, in order to more easily insert CG elements
into a scene. MatchMover combines the ease of automatic tracking with the
precise manual control of tracking points.

The lessons in this tutorial describe how to use MatchMover to perform basic
matchmoving, which includes loading images sequences, tracking a sequence,
and then exporting the tracked rendered 3D data to file that can be used in
3D animation and compositing programs. You will also learn how to create
a track manually using supervised tracking and set up survey points.

This chapter includes the following lessons:

■ Lesson 1: Tracking an image sequence on page 6
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■ Lesson 2: Using supervised tracking on page 18

■ Lesson 3: Object-based tracking on page 35

■ Lesson 4: Motion capture on page 45

Lesson 1: Tracking an image sequence

Introduction

In this lesson you will learn how to track a sequence in 3D using MatchMover’s
automatic tracking engine, inspect the results, and export the result to one of
MatchMover’s supported file formats. The automatic tracking feature locates
good tracking points in the image, and then tracks them through the sequence.

In this tutorial you will learn how to:

■ Load an image sequence.

■ Use the automatic tracker to compute the 3D camera path and the 3D
scene.
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■ Navigate in the project with a 3D view to visualize and inspect the tracking
results.

■ Render a preview sequence.

■ Export the tracking results to a supported file format.

Lesson setup
To ensure the lesson works as described, do these steps before beginning:

1 Start MatchMover and ensure that it is set to Light mode.

To set MatchMover to Light mode, select Light from the MatchMover
toolbar.

Although this tutorial is designed for Light mode, it can be completed
using MatchMover Full mode.

2 If you have not already done so, copy the Tutorials folder from its
installation location to your a project directory.

The Tutorials folder can be found in the Help folder of MatchMover’s
installation location: Help/Tutorials.

Loading the image sequence
The first step in matchmoving is to load the image sequence you want to
track.

NOTE You can bypass this section of the lesson by openningBasic_Sequence.mmf.
This file can be found in the Tutorials/Basic directory. You can then proceed
to Running the automatic tracker on page 10.

To load an image sequence

1 Select File > Load Sequence or click the Load Sequence  icon in the
toolbar.

The Load Sequence window appears.
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2 In the Load Sequence window, browse to the location of the MatchMover
Tutorials/Basic directory, and select lion000.jpg, which is the first
image in the sequence.

3 Click Details.

Information about the image sequence, such as its length as well as
preview images, are displayed in the Details section of the Load Sequence
window.

The video you use for this lesson is in the interlaced PAL format, which
means you need to set MatchMover sequence options for this type of
video.

4 In the Sequence Options section, select Lower field first from the Interlace
drop-down list.

5 In the Camera Settings section, select 25 fps from the Frame Rate
drop-down list.
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Leave Motion set to Free because in this example, the camera does not
follow any of the motion types specified in the list.

To play the image sequence

1 Select Sequence > Play or click the play button  which is in Play
Sequence Toolbar at the bottom of the Workspace.

Note that when you play the beginning of the sequence it is slightly
jerky. This is because the sequence is loading into your computer’s RAM.
After the images are in the cache, the sequence plays smoothly. The size
of the current cache is displayed in the bottom-right corner of
MatchMover user interface.

Since the image sequence is only 50 frames, it plays back too quickly to
closely examine. Changing the play mode to PingPong will continuously
loop the sequence back and forth, making it easier to check the sequence
motion.

Lesson 1: Tracking an image sequence | 9



2 Select Sequence > Play Mode > PingPong or click the PingPong button

 in the Play Sequence Toolbar.

3 To stop the playback, click the Stop button  or press Esc.

TIP To play the scene manually, you can press Ctrl, click anywhere in the
image, and drag the pointer to the left or to the right.

4 To go back to the first frame, press Ctrl+Home (Windows) or

Command+Home (Mac) or press  .

Running the automatic tracker
You can use the automatic tracking feature to have MatchMover select the
best location of place track points in the image sequence.

NOTE You can bypass this section of the lesson by
openningBasic_Calibrated.mmf. This file can be found in the Tutorials/Basic
directory. You can then proceed to Checking the tracking results on page 12.

To run the automatic tracker

1 Select 2D Tracking > Automatic Tracking or click the Run the Automatic

Tracking icon  .

The Automatic Tracking window appears listing the steps in the automatic
matchmoving process.
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2 Click Run.

Colored indicators display beside the option name to show you the status
of each step.

After MatchMover has computed the camera path, a collection of 3D
points are displayed as cross-hairs in the Workspace. The points are also
represented by colored icons in the Project window in the Point Track >
Auto Tracks folders.
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The colors indicate the quality of the tracking, where green indicates
good, yellow fair, and red bad tracking. Some grayed tracks have not been
reconstructed, which means that MatchMover considered them unfit to
calculate.

Checking the tracking results

To check the results of the automatic tracking you can:

■ View the track quality by looking at the cross-hairs superimposed on the
Workspace, or by view the color icons in the Auto Tracks folder. Most of
your reconstructed tracks should be green, a few yellow, and none red.

■ View the reconstructed 3D scene, and check to ensure that it is consistent
with the real scene.

■ Render a video sequence where the 3D objects are superimposed on the
image sequence and check to ensure that the integration is seamless.

To check the tracking results in 3D space

1 Click the 3D space icon  that is located in the top left of the workspace
view.
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MatchMover switches to 3D mode. The tracks are now displayed as 3D
cones rather than cross-hairs.

2 Use the following Navigation tools to examine the tracking:

■ Click-hold the Dolly icon to move backward and forward in the space.

■ Click-hold the Orbit icon to view the space in 360 degrees.
When orbiting the camera, the 3D View automatically orbits around
the selected 3D object, point cloud, or camera.

When you navigate in the 3D scene, you can recognize the different
elements of the scene, such as the lamppost, statue and wall, as well as
the camera path.
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3 To center the view on a track, select it, then select View > Look At.

4 To view the Workspace through the computed camera with the image

in the background, select View > Lock on Camera or click the  icon.

When viewing the Workspace, you can use of the location of the 3D
cones to judge the potential orientation of any elements that you might
want to introduce into the scene.

5 If the 3D cones appear too big or small, you can change their size by
selecting the Project tab in the Parameters window. Change the 3D Helper
size value from 1 to 0.5.
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Rendering the tracked image sequence
After you have created and checked the quality of the 3D tracking in the
Workspace, you can render the scene in a video format to further check its
quality. You can also export the tracked sequence to a file format that you
can open in your favorite 3D animation or compositing program.

To render the tracked sequence

1 Select 3D Scene > Render Setup.

The Render Setup window appears.

2 In the Render Setup window, click Setup/Browse and do the following:

■ Type a file name for your rendered sequence.

■ From the File type list, select an output file format.

■ Click Save.

3 From the Resolution list, select 50%.

4 In the Options section, turn on Antialiasing.

5 Click Render.

The Render window appears, displaying your rendered sequence with 3D
cones composited on your original image sequence. With perfect tracking,
the 3D cones should appear as if they were part of the scene. Otherwise,
you would notice slight discrepancies between the motions of the real
scene and the 3D elements.
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Now that you have automatically tracked a PAL video sequence and
verified it by rendering it, you can export the results to a file that can be
opened in your favorite animation or compositing software.

6 Select File > Export or click the  icon.

The Export window appears.

7 In the Export window, do the following:

■ Type a name for your exported file

■ From the File type list, select a format for you exported file.
For example, to open your tracked image sequence in Maya, select
Maya (*.ma).

■ Click Save.

The image sequence is exported to the specified file format for use in
your 3D animation or compositing program.
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Beyond the lesson
In this tutorial you learned how to:

■ Load an image sequence.

■ Use the automatic tracker to compute the 3D camera path and the 3D
scene.

■ Navigate in the project with a 3D view to visualize and inspect the tracking
results.

■ Render a preview sequence

■ Export the tracking results to a file format that is supported by your favorite
3D animation or compositing program.

For more information and related techniques about MatchMover, refer to the
MatchMover Help.
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Lesson 2: Using supervised tracking

Introduction

For complicated scenes, it may be necessary to manually control the tracking
process by editing or deleting tracks that were created by MatchMover’s
automatic tracking feature. Using a supervised tracking technique, you can
place tracks manually by specifying the key points or then edit their location
if required. Matchmover then generates a whole point trajectory based on the
manually placed points.

In this lesson, you will learn how to place tracks manually in a scene using.
The image sequence you use for the lesson was shot against a green background
using professional equipment. The green background serves as a typical support
for the actors, and would be replaced by virtual decors. The gray crosses on
the background will help you accurately place tracking points in the scene.

The image sequence appears courtesy of Clear Ltd.

In this lesson you will:

■ Load a sequence.
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■ Create and edit tracks manually.

■ Launch the solver.

■ Define a coordinate system.

■ Add a 3D object to verify the tracked sequence.

Lesson setup
To ensure the lesson works as described, do these steps before beginning:

1 Start MatchMover and set it to Full mode.

To set MatchMover to Full mode, select Full from the MatchMover toolbar.

2 If you have not already done so, copy the Tutorials folder from its
installation location to your a project directory.

The Tutorials folder can be found in the Help folder of MatchMover’s
installation location: Help/Tutorials.

Creating a point track
In matchmoving, creating a point track by manually placing points in a scene
is also known as a hard track. The automatic process that you completed in
lesson 1 is different from supervised tracking in that many tracks are handled
at the same time and 3D coherency is used while tracking. For supervised
tracking, only one track is handled at a time. Also, when supervised tracks are
present before launching the automatic process, they are used in the 3D
coherency checking.

NOTE You can bypass this section of the lesson by openningShot_tracked.mmf.
This file can be found in the Tutorials/Supervised_Shot directory. You can then
proceed to Adding tracking points on page 24.
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To load the image sequence

1 Select File > Load Sequence or click the Load Sequence  icon.

The Load Sequence window appears.

2 In the Load Sequence window, browse to the location of the MatchMover
Tutorials/Supervised_Shot directory, and select shot01.jpg, which is
the first image in the sequence.

3 Click OK.

MatchMover loads the sequence into the Workspace.

Placing a track point

When placing tracks manually, try to cover as much of the scene as possible.
The tracked points should be points that can be accurately localized in the
image and represent physical points such as markings, corners, or shadows.To
help with the accuracy of the manually placed points you will place tracks on
the most contrasted areas. In the image sequence, you will use the gray X’s
that appear on the green background of scene to help position your tracking
points.
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For more information about placing tracks, see Supervised 2D tracking on
page 132.

To place a track point in the scene

1 Go to the first frame of the sequence.

2 Select 2D Tracking > New Track or click the New Track  icon.

When you drag the cursor over the Workspace, it changes to cross-hairs.

3 Position the cross-hairs near the one of the gray X’s that appear in the
scene. Use the location shown in the image below as a guide.

Use the Magnifier window view below the Project window to help you
precisely position the location of the new point.
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Corner areas are often good locations to place the track points. The
extremity areas have less contrast and do not allow you to visually locate
the point as precisely as the intersections and can introduce a higher risk
of ending up with a “sliding” track point.

4 Click-hold the location of the new point.

A Magnifier window appears around the area you placed the point. This
is another window you can use to help place the track point accurately.

5 Release the mouse button to create the track point.

A window labeled Track 01 appears in the Workspace. The presence of
the window indicates that the track point is still selected.

6 With the track point selected, select 2D Tracking > Track Forward or click

the  icon to run 2D tracking for your point.

While the point is being tracked, the Tracking Monitor window appears
showing you the tracking progress.

After the point tracking is complete, its trajectory line appears on the
image. You may notice that the trajectory line has green, yellow, and
possibly, red segments. The red segments indicate areas where the tracking
slides or is of low quality.
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You can correct the sliding track by manually adjusting the point positions
where the track has drifted significantly. In the next section of the lesson,
you adjust the point positions to improve the tracking quality.

Editing a point track
To improve the quality of your hard track, you can adjust the location of a
tracking point and re-run the tracking process.

To adjust tracking point positions

1 Using the time line controls, go to a frame where the track drifts.

This is indicated by the red sections.

2 In the Workspace, click-hold the tracking point and move it in the
direction that will improve the tracking such as closer to an inside corner
of the gray X’s.

Use the Magnifier window that appear around the point to help you
adjust the point's position.

3 Release the mouse button.

Notice that when you release the mouse button, MatchMover clears the
end of the trajectory. That is because the tracked data is no longer
compatible with new position of the point. This means that you must
re-compute the trajectory based on the new point position.

4 With the track point selected, select 2D Tracking > Track Forward or press
F3, which is the Track Forward keyboard shortcut.

MatchMover calculates a new trajectory for the track.
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To make the track trajectory smoother, you can update the tracked data
between the initial point and the point's new location by using
bi-directional tracking.

5 Select 2D Tracking > Bidirectional or click the Run Track Full  icon.

You can check the smoothness of your edited track by centering your
view on the current track.

6 Select View > Lock on Track or click the  icon.

7 Play the image sequence in PingPong mode by clicking  followed by

 .

Notice that when the sequence plays back section of the sequence you
have tracked, the view is locked to the motion of the edited track.

8 Stop the sequence playback by clicking the  icon.

9 To get a close-up view of the track, press Ctrl+Alt and drag the mouse up
and down to zoom in and out of the Workspace view. If you are not
satisfied with the quality of the track, adjust the point and run the
tracking again.

TIP If you notice a jump in the trajectory, you can adjust the point position
by pressing the arrow keys. Select Preferences > 2D Tracking to adjust the
nudge step. Use shift to multiply the nudge step by 10. If needed, a key point
is inserted at the current edited frame.

Adding tracking points
Adding more tracking points to your scene improves the overall quality of
the tracking.

Open the file for the lesson

To ensure this lesson works as described, open the scene file named
Shot_tracked.mmf. This file is in the Tutorials directory that you copied from
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the MatchMover installation directory to a local directory:
Tutorials\Supervised_Shot\Shot_tracked.mmf.

Supervised tracking

Eight tracks have been added to the image sequence. In this section of the
lesson, you will add more tracking points starting with Track 9.

To make the tracking process quicker, you can use MatchMover's keyboard
shortcuts to create the track and run the forward tracking.

To create a new track

1 Using the image below as a reference, place the mouse pointer in the
location shown in the image below. Use the Magnifier window to help
find the correct location for the tracking point.
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2 Create the tracking point by pressing Shift+right-click.

The tracking begins then stop around frame 15. Track 09 appears in the
Workspace and is also added to the track points in the Project window.

3 To run forward tracking press F3.

A window appears in the Workspace indicates that the tracking quality
is too low for MatchMover to continue the trajectory.

4 Click OK.

The reason the tracking quality is so low is that the actor’s body hides
the area you want track in the sequence.

5 In the time line, double the last frame of the Track 9 trajectory.
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The Parameters window now displays the parameters for the tracked point
under the Track 09 tab.

Since the tracked point’s trajectory cannot continue to be tracked, you
can change the status of last frame by setting it to an end keyframe. This
means that MatchMover will not track forward past this frame.

6 Select 2D Tracking > Set Key > End.

The End status of the keyframe is indicated in the Track 9 Parameters
window in the Status field.

7 With Track 09 selected, advance the sequence one frame at a time by
pressing Ctrl+right arrow key.

As you advance, the tracked point and its trajectory is hidden between
frames 16 and 28, then re-appears at frame 29. Since the track is likely to
disappear again, this time behind another obstacle, you can track the
point frame-by-frame using the Step-tracking mode.

8 To use Step-tracking mode, press Alt+right arrow to continue tracking
forward from frame 29.

At frame 31, a window appears indicating that the tracking quality is too
low to continue tracking.
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TIP  Use the Magnifier window to get a better view of the obstacles that are
hiding the Track 09 trajectory path.

9 At frame 31, change the status of the keyframe to End by selecting 2D
Tracking > Set Key > End.

10 Go to frame 44 and press F3 to run forward tracking.

Track 09 is now complete and set in the scene.

To check the quality of the track

1 Ensure that Track 9 is selected in the Workspace.

2 Click the padlock icon  at the bottom right of the Magnifier window.

This makes the Magnifier window the only active view.

3 Select View > Skip Untracked or click the  icon.

4 Play the image sequence in PingPong mode by clicking  followed by

 .

Notice that MatchMover only plays the sections of Track 09 that have
been tracked. The frames that could not be tracked because of obstacles
in the scene are not played.

5 Click the lock icon to make the Workspace window active again.

6 Select View > Skip Untracked so that all frames play when the sequence
is played back.

Calibrating the camera
In MatchMover, a camera is characterized by its internal parameters such as
Principal Point, Focal Length, Pixel Aspect Ratio, and Distortion. In some
cases, you may already have information about the camera. For example, you
may know that it is a 24 ×36 mm film back camera with a 35 mm lens. You
can then input this information into MatchMover before launching the camera
tracker. For this lesson, you will calibrate the camera using MatchMover's
default values. This process of calibrating a camera involves reconstructing
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the 3D points corresponding to the 2D tracks and computing the camera path
for all the sequences or frames and all the objects in one solve.

NOTE You can bypass this section of the lesson by openningShot_solved.mmf.
This file can be found in the Tutorials/Supervised_Shot directory. You can then
proceed to Creating a coordinate system on page 29.

To calibrate the camera

1 Run the calibration by selecting 3D Tracking > Solve For Camera or by

clicking the Solve For Camera  icon.

The camera is calibrated.

2 Click the 3D space icon  that is located in the top left of the
Workspace view.

The view switches to 3D mode and the tracks are now displayed as 3D
cones rather than cross-hairs. A camera icon is placed in the Workspace,
which represents the camera you calibrated.

3 Select View > Lock On Camera or click the Lock on Camera  icon.

4 Play the sequence to check the tracking.

Notice the image sequence plays back from the perspective of the camera.

Creating a coordinate system
MatchMover manages a set of user-defined coordinate systems with respect
to the cameras and 3D points in the Workspace. If no coordinate system is
specified, MatchMover chooses an arbitrary one. You can define a coordinate
system in order to facilitate the manipulation of your exported project in a
3D package. If no point relations have been set up, MatchMover aligns the
coordinate system on the computed position of the camera for the first frame;
the default is the camera looking towards Z and Y as Up axis, but this changes
according to your project's 3D parameters if you selected a different up axis.

NOTE You can bypass this section of the lesson by openningShot_coordsys.mmf.
This file can be found in the Tutorials/Supervised_Shotdirectory. You can then
proceed to Add a 3D object on page 32.
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Open the file for the lesson

To ensure this lesson works as described, do the following:

1 Ensure that it is set to Full mode.

To set MatchMover to Full mode, select Full from the MatchMover toolbar.

2 Ensure that MatchMover is set to 3D mode.

To switch MatchMover to 3D mode, click the 3D space icon  that is

located in the top left of the Workspace view. If a 2D space icon 
appears instead, then MatchMover is already in 3D mode.

3 If you have not already done so, copy the Tutorial folder from its
installation location to your a project directory.

4 Open the scene file named Shot_solved.mmf. This file is in the Tutorials
directory that you copied from the MatchMover installation directory to
a local directory: Tutorials\Supervised_Shot\Shot_solved.mmf.

Setting up the coordinate system

To set up the coordinate system

1 In the Project window, right-click the Coordinate Systems folder and
select New Coordinate System from the pop-up menu.

A grid and coordinate indicators appear in the Workspace.

2 In the Parameters window, click the Coord 01 tab.

For your new coordinate system values, you will use Track 05 as the origin.
This point is the center of the grid and floor of the scene.

3 In the General section, select Track 05 from the Origin list.
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4 To set the grid value, in the General section, do the following:

■ In the Distance field, type 20.00.
This value defines the distance between two points in the scene.

■ From the From list, select Track 07.

■ From the To list, select Track 09.

These two points provide tracking locations in the corners of the room,
making them well suited for defining the boundaries of the coordinate
system.

5 Click the Axis 1 tab and do the following:

■ Select Y from the X, Y, and Z list.

■ Select normal to 3 points from the list to the right of Y.

■ For the three points, select Track 03, Track 04, and Track 05 from the
lists located under Y.

These settings create a Y-based coordinate system using three points that
are located on the ground of the scene.

6 Click the Axis 2 tab and do the following:

■ Select Z from the X, Y, and Z list.

■ Select through 2 points from the list to the right of Z.
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■ For the two points, select Track 01 and Track 02 from the lists located
under Z.

These settings create a Z-axis as the second axis which is based on the
crosses on the wall of the scene background.

7 Click Apply Coordinate System to validate your coordinate settings.

The defined coordinate system appears in the Workspace.

Add a 3D object

Now that you have defined a 3D coordinate system in MatchMover, you can
import an object into the Workspace and check its behavior in the scene.

NOTE You can bypass this section of the lesson by openningShot_object.mmf.
This file can be found in the Tutorials/Supervised_Shotdirectory.

To add a 3D object

1 Select 3D Scene > New Primitive > Pyramid or click the  from the
primitive list located on the Toolbar.

The pyramid primitive appears in the Workspace at the origin of the
coordinate system. A Pyramid tab appears in the Parameters window
displaying the pyramids position and scale.

The pyramid is too large for the scene. You can make the pyramid smaller
by using MatchMover’s scaling tools.

2 If the pyramid is not selected, select it now by clicking it in the Workspace
or by clicking Pyramid in the Project window under the 3D Scene folder.
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3 Press the Tab key to select the scaling tools.

The scaling tools appear as a series of light blue, dark blue, green, and
red cubes surrounding the pyramid.

4 Click-drag one of the light blue cubes inward until the Scale X, Y, and Z
values are 0.48, or until the base of the pyramid is on the grid.

Notice that as you drag the cursor, the X, Y, and Z values are scaled
uniformly.

5 Play the sequence in PingPong mode.

Notice that the tip of the pyramid is out of the camera view. You can use
the move tool to change the pyramid’s position so that it remains in the
camera view throughout the sequence.

6 Select the dark blue arrow and move the pyramid along the Z-axis toward
the front of the scene until its Pos Z value is about -4.20.

7 Play the sequence in PingPong mode.

Notice that the pyramid remains in the camera view throughout the
sequence.
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You can now export the sequence and verify its tracking quality in your
favorite 3D animation or compositing program.

8 Select File > Export to export the scene to a file format supported by your
3D animation or compositing program.

The Export window appears.

9 In the Export window, do the following:

■ Type a name for your exported file.

■ From the File type list, select a format for you exported file.
For example, to open your tracked image sequence in Maya, select
Maya (*.ma).

■ Click Save.

The image sequence is exported to the specified file format.

Beyond the lesson
In this lesson you learned how to:

■ Create and edit tracks manually.

■ Launch the solver and calibrate a camera.

■ Create a new coordinate system.

■ Add a 3D object to verify the tracked sequence.

For more information and related techniques about MatchMover, refer to the
MatchMover Help.
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Lesson 3: Object-based tracking

Introduction

In this lesson, you will learn how to track an object, such as an image plane
in MatchMover using a 3D model of it. This is a useful technique in situations
such as the following:

■ Augmenting a real set for which some 3D information is available as
manual measurements or CAD data.

■ Matchmoving characters from a Cyberware scan.

■ Tracking complex shots of a set using data from an active scanning device
(LIDAR).

Using this technique ensures that, in any case (even with low or zero parallax),
the camera path will be exactly consistent with the 3D geometry of the tracked
element.

The image sequence you will use in this lesson was shot using a hand-held
DV camcorder.
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In this lesson you will learn how to:

■ Import a 3D mesh.

■ Create tracks and survey points attached to vertices of the mesh, using the
“elastics” feature.

Lesson setup
To ensure the lesson works as described, do these steps before beginning:

1 Start MatchMover and set it to Full mode.

To set MatchMover to Full mode, select Full from the MatchMover toolbar.

2 If you have not already done so, copy the Tutorials folder from its
installation location to your a project directory.

The Tutorials folder can be found in the Help folder of MatchMover’s
installation location: Help/Tutorials.

Importing the 3D mesh

Load the footage

NOTE You can bypass this section of the lesson by
openningElastic_Import_Scene.mmf. This file can be found in the
Tutorials/Elastics directory. You can then proceed to Set up the trackers and
the survey points on page 39.

To load the image sequence

1 Select File > Load Sequence or click the Load Sequence  icon.

The Load Sequence window appears.
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2 In the Load Sequence window, browse to the location of the MatchMover
Tutorials/Elastics directory, and select Elastic00.jpg, which is the
first image in the sequence.

3 In the Load Sequence window, under Sequence Options, set Interlace
type to Lower field first.

4 Under Camera Settings, set Frame Rate to 24 fps (Frames Per Second).

Leave Motion set to its default setting of Free.

5 Click OK.

Import the 3D mesh

To import the 3D mesh

1 Click the 3D space icon  that is located in the top left of the
Workspace.

The view switches to 3D mode. A camera icon and grid is placed in the
Workspace.

2 Select File > Import, or right-click in the Workspace and select Import
Scene from the pop-up menu.

Lesson 3: Object-based tracking | 37



The Import Object window appears.

3 In the Import Object window, select Wavefront Ascii Model (*.obj) from
the Files of Type list.

4 Browse to the location of the Tutorial/Elastics directory, and select
Box.obj.

A 3D mesh of the box appears, in wireframe, in front of the image plane.
This mesh will now be used as a reference for the 3D tracking. This ensures
that the solution will be consistent with this geometry even though this
shot holds little parallax.
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Set up the trackers and the survey points
You can use survey points to analyze the results of 3D tracking and to isolate
specific frames or points where adjustment may be necessary.

NOTE You can bypass this section of the lesson by opening
Elastic_SetUp_Elastics.mmf. This file can be found in the Tutorials/Elastics
directory. You can then proceed to Solve and check the tracking results on page
43.

1 Using the Pan and Dolly controls, make sure both the imported 3D object,
which represents the shape of the box, and the image plane are clearly
visible.

For example, set up your viewing position and angle similar to the image
below.
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2 Make sure that the Magnifier window is open by selecting Window >
Magnifier Window.

3 Click-hold the vertex located at the top right corner of the 3D object and
move the cursor to the position of the same corner in the image plane.

As you drag the curser toward the image plane, a red elastic line follows,
joining the selected vertex and the image plane.
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NOTE  If you want to abort the operation while dragging the cursor, drag
the cursor out of the image plane. The elastic line becomes dashed, meaning
nothing will happen when you release the mouse button.

4 Release the mouse button.

The elastic is now blue and a new track, Track 01, is created with a point
in the current frame (visible in the track view).
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Survey point information issued from the selected vertex is automatically
associated to the track. You can see this information in the Parameters
window under the Track 01 tab. Click the 3D tab and look in the Survey
Info section.

5 If necessary, you can adjust the position of the tracking point by clicking
it in the Magnifier window.

6 Run forward tracking on the point by pressing F3.

You can check the quality of the new track by playing the sequence.

7 Press F2 to play the sequence.

To get a close-up view of the tracking point, you can lock the sequence
play to the Magnifier window. See Supervised 2D tracking on page 132.

8 Go to the first frame and repeat steps 3 to 7 for all the corners of the box.

Your project should now look similar to the image below.
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NOTE  If needed, you can change the viewpoint to better view the 3D object’s
vertices and locations on the image plane. You can move and rotate the
object in the Workspace by selecting it and using the object manipulator.
The transform you apply to the object will not be used in the survey
information, unless you specify it by turning on Use Object Transform in the
Survey Info section tab of the track Parameters window.

Solve and check the tracking results

To solve and check the tracking results

1 Select 3D Tracking > Solve For Camera or press F9.

After the camera completes the solve, blue cones appear at the tracking
points on the 3D object and the new tracks appear in the Track window.

When you look in the Track window, notice that some of your new tracks
have yellow segments, indicating that acceptable, but not good tracking.
This occurs because the constraints induced by the 3D points are quite
strong, while the footage quality does not allow the points to reach a
high accuracy on the 2D points locations.

2 Select View > Lock on Camera.

The Workspace view now displays the cameras perspective.
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3 Press F2 to play the sequence and check the alignment of the mesh with
the image.

Beyond the lesson
In this lesson you learned how to:

■ Import a 3D mesh.

■ Create tracks and survey points attached to vertices of a mesh, using the
“elastics” feature.

For more information and related techniques about MatchMover, refer to the
MatchMover Help.
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Lesson 4: Motion capture

Introduction

In addition to conventional matchmoving, such as automatically capturing
the 3D camera paths from 2D live-action video sequences, you can use
Autodesk MatchMover to perform motion capture. Motion capture is the
process of tracking, in 3D, the motion of non-rigid objects such as a human
body, face, or a piece of cloth.

In this lesson, you will capture the motion of an animated character from two
synchronized videos sequences. The sequences were captured as DV video
using two static cameras. This provides you with the basic setup required for
motion capture.

In this lesson you will:

■ Create a motion capture project.

■ Synchronize two video sequences.

Lesson 4: Motion capture  | 45



■ Create motion tracks for two synchronized video sequences.

■ Calibrate the camera to obtain camera parameters.

■ Build a skeleton line representation of an actor’s motion.

Lesson setup
To ensure the lesson works as described, do these steps before beginning:

1 Start MatchMover and ensure that it is set to Full mode.

To set MatchMover to Full mode, select Full from the MatchMover
Toolbar.

2 If you have not already done so, copy the Tutorials folder from its
installation location to your a project directory.

The Tutorials folder can be found in the Help folder of MatchMover’s
installation location: Help/Tutorials.

Synchronizing the sequences

Load two sequences

The first step in synchronizing the video sequences for motion capture is to
load both sequences into MatchMover.

NOTE You can bypass this section of the lesson by opening Load_sequences.mmf.
This file can be found in the Tutorials/Mocap directory. You can then proceed
to Synchronize the sequences on page 47.

To load the image sequences

1 Select File > Load Sequence or click the Load Sequence  icon.

The Load Sequence window appears.
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2 In the Load Sequence window, browse to the location of the MatchMover
Tutorials/Mocap directory, and select Motion1_00.jpg, which is the first
image in the first sequence.

3 In the Load Sequence window, set the following:

■ In the Sequence Options section, select Lower field first from the
Interlace drop-down list.

■ In the Camera Setting section, set Motion to Fixed.
This setting will impose a constraint attached to the camera,
representing a static camera.

■ Set Frame Rate to 25.

4 Load the second sequence by repeating steps 1 to 3.

In the Load Sequence window, browse to the location of the MatchMover
Tutorials/Mocap directory, and select Motion2_00.jpg, which is the first
image in the second sequence.

The two sequences are represented by different colors in the Track View
and Project windows.

Synchronize the sequences

Because you need to adjust these sequences to the same time reference, you
will synchronize them by specifying a synchronization tick. To do this, you
need to identify a visible event that you can easily see in both image sequences.
For example, while you are shooting the sequences, you can use a specific
device, such as a flash or a clapperboard, to create the event.

NOTE You can bypass this section of the lesson by opening
Synchronize_sequences.mmf. This file can be found in the Tutorials/Mocap
directory. You can then proceed to Creating motion tracks on page 49.

For this lesson, you can use the instant the actor's left foot begins to touch
the floor. In Sequence 01, it occurs at frame 9 (9/50) and for Sequence 02 it
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occurs at frame 58 (7/50). You can see this information displayed on the
top-left corner of the image viewport.

To synchronize the sequences

1 In the Project window, click Sequence01.

2 In the Parameters window, in the Synchronization section, turn on
Synchronized at Frame and set it to 9.

3 Repeat steps 1 and 2 for Sequence02, setting the Synchronized at Frame
to 7.

Notice that in the Project window the sequence icons have changed,
indicating that they each have a specified synchronization frame.

4 To change the workspace viewport so that you can see both sequences

at the same time, from the Toolbar, click  icon and select Two Side
by Side from the list.

5 Right-click the left viewport and select Synchronize Time from the pop-up
menu.
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The information displayed in the top-left corner of this viewport is now
displayed in bright green, meaning it will update its own time using the
synchronization information specified.

6 Right-click the right viewport and select Synchronize Time from the
pop-up menu.

7 With the right viewport still active, select any frame between 51 and 101
in the Time line.

You can now play the sequence from this point in the Time Line to check
that the sequences are synchronized.

Click the  icon to play the sequence.

When you look at the start of Sequence 02 at frame 51 in the right
viewport, notice in the left viewport that Sequence 01 is at frame 2. It is
this difference that allows us to have a good synchronization between
the sequences.

Creating motion tracks
In this section of the lesson, you create a motion track of the actor’s
movements.

NOTE You can bypass this section of the lesson by opening
Motion_solved.mmf.mmf. This file can be found in the Tutorials/Mocap directory.
You can then proceed to Finalizing your motion capture project on page 53.

The first step in this process is to create a new point track group that you will
use to place the actor's tracks.

To create a new point track group

1 In the Project window, right-click the Point Tracks folder and select New
Group from the pop-up menu.

2 In the Parameters window, click the Group 01 tab.

3 In the Label field, select Group 01and type Actor.

4 In the Options section, select Non-rigid (motion capture) from the Motion
list.

This option specifies that the point track belonging to the new group
will be for the motion of non-rigid objects.
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Creating point tracks

In this section of the lesson, you place track point on markers that are attached
to the actor. There are 18 markers attached to the actor, but for this section
of the lesson, you use only six for your tracking points. When creating a
motion track, you must place your track points on the same marker in both
sequences. For example, if you place Track 01 on the white marker located on
the right side of the actor’s head in Sequence01, you must also place Track 01
on the same marker in Sequence02.

Be aware that some tracks may need manual adjustment as can be the case
when using supervised tracking. For example, in a few of the frames,
MatchMover confuses the motion of the actor's saber with the motion of the
markers on the actor's leg and includes the saber’s motion in the track.

The easiest markers to track in both sequences are located on the actor's head
and on the legs. In all cases, try to choose the most visible markers in your
sequences.

For information about supervised tracking, see Lesson 2: Using supervised
tracking on page 18.

To create the track points

1 Go to frame 51 in the Time Line.

The left viewport now displays the first frame of Sequence 01and the right
viewport now displays the first frame of Sequence 02.

2 Select 2D Tracking > New Track or click the New Track  icon.

When you drag the cursor over the Workspace, it changes to cross-hairs.

3 In Sequence 01, position the cross-hairs over the white mark located on
the right side of the actor's head.

Use the Magnifier window view below the Project window to help you
precisely position the location of the new point.

4 Click to create Track01 for Sequence 01.
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5 In Sequence 02, position the cross-hairs over the same marker, and click
to create Track01 for Sequence 02.

Use the locations shown in the image below as a guide.

6 With the track point selected, select 2D Tracking > Track Forward or click

the  icon to run 2D tracking for your points.

7 Using steps 2 to 6, create five more track points.

Your project should look similar to the one in image below.
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Performing an initial solve

Before you can perform the camera solve, you must remove the two-frame
shift between the two sequences.

The first two frames (0-1 in the Time Line) only appear in Sequence 01, and
the last two frames (100-101 in the Time Line) only appear in sequence
Sequence 02. Since no 3D information can be derived for these frames, you
need to specify that the frames are not solved.

To solve for the camera

1 In the Track View, Shift-select the time interval of the first two frames (0
and 1) of Sequence 01.

2 Right-click in the Track View and select Set Frames > Do Not Solve from
the pop-up menu.

3 Repeat steps 1 and 2 for Sequence 02.

For Sequence 02, select the time interval of the last two frames in the
sequence (100-101).

4 Deselect the time interval by Shift+right-clicking in the Track View.

5 Solve for the camera by selecting 3D Tracking > Solve For Camera or by

clicking the Solve For Camera  icon.

The camera is now calibrated.
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Finalizing your motion capture project
In this section of the lesson, you will add three tracks that correspond to points
in the scene’s static background. This is the minimum number of points
required to define a coordinate system. Creating these tracks defines a 3D
coordinates with respect to a world coordinate system attached to the
background, which is very useful in motion capture. This step might not be
necessary if all you need is to compute the 3D trajectories with respect to an
unspecified coordinate system

In the last step of the lesson you will create skeleton lines which will better
display the motion captured and of the tracked scene.

Since there are 18 markers attached to the actor, each potentially a track point,
you can either continue adding tracks to your current project, or you can open
Actor_tracked.mmf which has tracks already created for all 18 markers. This
file can be found in the Tutorials/Mocap directory.

You can also start this section of the lesson using Motion_solved.mmf. In this
file, six markers have been tracked. This file can be found in the
Tutorials/Mocap directory.
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If you want to add the tracks yourself, do so before continuing the lesson.

To create point tracks in the background

1 In the Project window, select the Point Tracks folder.

Since the point tracks that you will create for the background are for
static, rigid objects, selecting the Point Tracks folder ensures that your
new point tracks are not added to the Actor Point Tracks folder.

2 In the first frame of Sequence01, place a track point on the floor of the
scene by selecting 2D Tracking > New Track or clicking the New Track

 icon.

You can try to use the square patterns to locate easily recognizable
locations on the floor as you will need to place a track point in the same
location in Sequence02.

NOTE You can try to use the square patterns to locate the points on the
floor. Once the first track is placed, you do not need to run the Track Forward
on it, because the sequence was shot with a fixed camera, and MatchMover
detects this through the “fixed” motion constraint.

3 In the first frame of Sequence02, place the same track point in same
location as you did in the first frame of Sequence01.

This point is reconstructed in space right away, based on the existing
camera calibration (solve). If the point is in the wrong location in one of
the sequences, the cross-hairs will appear in red. This can often happen
if your video sequences are low-resolution, compressed footage.

4 Repeat steps 2 and 3 to create the remaining two track points for
Sequence01 and Sequence02.

The goal is to place track points that define a coordinate system on the
ground.
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5 Solve for the camera by selecting 3D Tracking > Solve For Camera or by

clicking the Solve For Camera  icon.

The camera is calibrated with the a coordinate system on the scene’s
background. You can now finalize you project by building some skeleton
lines.

6 Click the 3D space icon  that is located in the top left corner of both
viewports.

The view switches to 3D mode. A camera icon and grid is placed in the
Workspace.

You can also switch back to a single viewport by selecting Single Viewport
Space from the Toolbar.

7 In the viewport, select the yellow cone that appears at the right side of
the actor’s head.

This cone represents Track01.

8 Shift-select the yellow cone that appears at the left side of the actor’s
head.

This cone represents Track02.

9 With both cones still selected, select 3D Tracking > New Relation.

10 In the Parameters window, click the Relation 01 tab.

11 From the Type list, select Line.
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A line is displayed between the two cones.

12 Repeat steps 7 to 11 for the remaining track points or until you see
satisfied with the line reconstruction of your motion capture.

NOTE You can open Motion_finalized.mmf to see the entire project. The result
should look similar to the one in the following image.

56 | Chapter 1   Getting Started



You can export your project to a file format supported by your favorite
animation or composition software by selecting File > Export.

Beyond the lesson
In this lesson you learned how to:

■ Create a motion capture project.

■ Synchronize two video sequences.

■ Create motion tracks for two synchronized video sequences.

■ Calibrate the camera to obtain camera parameters.

■ Build a skeleton line representation of an actor’s motion.

For more information and related techniques about MatchMover, refer to the
MatchMover Help.
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Overview

About matchmoving
Matchmoving is the computation of the global 3D geometry of a scene including
camera path, internal parameters, and moving object. By exporting the real 3D
camera path and parameters to animation software, the position and motion
of virtual cameras can be accurately established. With the motion of the virtual
cameras, new, matched image sequences can be created whose virtual objects
are seamlessly composited into live action footage.

Matchmoving lets you accurately place 3D objects into a film, video or image
sequence. For virtual objects to appear as part of the scene, the objects have to
be rendered by a virtual camera whose motion exactly matches the motion of
the actual camera that shot the film. Using Autodesk MatchMover you can
generate the exact camera parameters that match the motion of the actual
camera used in the sequence.

Film, video and image sequences
The principle data used by MatchMover is film, video, and image sequences.
You can simultaneously use a number of different sequences and image files in
MatchMover as long as they all share some 3D information such as different
viewpoints of the same scene. MatchMover supports most commonly used video
and image formats including interlaced footage. See Importing footage on page
108.

Your footage is used to identify feature tracks either automatically or manually,
and these tracks will be used for the solving. In the case of multiple sequences
or stills, the same feature can be easily spread and tracked across all the footage
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it appears, thus adding information about its position in the 3D space. See
Point tracks on page 65 and Helper images on page 60.

When you create a new project, the first step is to load your film, video or
image sequence.

Using MatchMover, you can:

■ Load image sequences. See Identifying image regions on page 113.

■ Load matte sequences. See Identifying image regions on page 113.

■ Load helper images. See Loading helper images on page 111.

Helper images

A helper image is an additional shot of a scene taken from another point of
view than that of the sequence. This enables you to introduce parallax into
your project when the sequence itself has low parallax.

For example, you have a camera pan from point A to point B while focusing
on object C. By taking additional shots of object C from other positions, you
are providing parallax to the sequence.

When you have a sequence with little or no parallax, for example, no camera
translation, you can add helper images to the sequence to aid the MatchMover
computation. These helper images are shot from different viewpoints from
that of the camera that filmed the main sequence.

They can be taken with either the same camera or a different one. The
following sections describe situations where helper images aid in MatchMover
calculations.

Using helper images with images taken with a tripod camera

You have an object at position A. The camera is fixed at position B, but there
is a rotation of the camera as it pans left and right. You can take one or several
helper shots from different positions (two in the example below) and then
load them into your project.
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Using helper images with images taken with a traveling camera

In the following diagram the camera moves from position A towards position
B. At each moment, it sees a small fraction of the scene.

You can use helper images shot from more distant viewpoints (C, D) and/or
with a wider-angle camera (C1, D1) that sees a larger portion of the scene, as
shown in the following image.

NOTE Helper images are only useful if they see the same elements as your shot.
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Loading these helper images into your project helps the camera solving process.
Helper images only help MatchMover calculations; they are not compulsory.

TIP  Helper images are a very convenient way of matchmoving shots with no or
little parallax. You can use the same camera that took the shot to acquire them
or any other photographic or video camera.

Frame rate

The video and film sequences you use with MatchMover can be in different
standard frame rates including 24 fps (frames per second) for film, and 25 fps
(PAL) and 29.97or 30 fps (NTSC) for video. In some cases, your footage might
have a custom or non-standard frame rate. The frame rate of your sequence
is used for playback speed and is exported along with the matchmover data
to the 3D package.

TIP The current project frame rate is displayed in the MatchMover time line above
the current time. SG needed. You can specify a project frame rate by typing it into
the field.

You can set the project frame rate in the MatchMover User Preferences.

To set frame rate in the User Preferences

1 Select Edit > Preferences.

The User Preferences window appears.

2 Click the Images/Cache tab.

3 In the Preview Frame Rate field, type the desired frame rate.
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4 Click OK.

TIP  You can set the frame rate for an image sequence in the Load Sequences
window. See Loading a sequence on page 108.

Cameras
Cameras represent the different devices used to capture the images. By default,
when you load a sequence or helper image, MatchMover creates a camera and
assigns it to all images. In MatchMover, a camera is characterized by its internal
parameters such as Principal Point, Focal Length, Pixel Aspect Ratio, and
Distortion. If you already have information about the camera, for example,
you know that it is a 24 ×36 mm film back camera with a 35 mm lens, you
can input this information into MatchMover® Pro before launching the camera
tracker.

The focal length is the distance between the film and the optical center of the
lens when the lens is focused on infinity. The principal point represents the
projection of the optical center onto the film back, perpendicular to the film
back plane. The film back value represents the size of your film and is
proportional to the pixel aspect ratio. See Setting up cameras on page 159.

Camera parameters

Each camera parameter has a value that you can input into MatchMover, or
you can have MatchMover calculate. The camera parameters Focal Length,
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Principal Point, Pixel Aspect Ratio, and Distortion can vary or remain constant
throughout the sequence. Depending on the information you have about the
cameras used to create the sequence, these parameters can either be known
or unknown.

Pixel aspect ratio

Providing extra information to the camera tracker gives more accurate results
with a faster calculation time. The pixel aspect ratio defines the aspect ratio
of the sequence you render. If the sequence has square pixels, then the pixel
aspect ratio is 1.

It is common, especially with video footage, to work with non-square pixels,
such as in the image below. In these cases, the pixel ratio is different from 1.

You can define the pixel aspect ratio for your sequence. As the pixel aspect
ratio is dependent on the film back value, and vice versa, changing the pixel
aspect ratio also changes the film back value.
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Non-linear distortion

Mathematical models of a perfect camera imply that the image of a straight
line is always a straight line. However, real lenses are not always perfect and
may introduce distortion into your footage. The effect of distortion is that
straight lines become curved as shown in the following image.

You can input the radial distortion of your cameras if you know it, or will
compute it if you don’t.

Point tracks
To calculate the camera parameters, MatchMover needs points in different
images in your sequence that represent the image location across the time of
the same physical 3D point. This collection of points is called a point track.
The camera solving process uses several point tracks to represent 3D points
that follow one rigid motion.A point track is composed of the following data:

■ Key points: Key points are Print locations defined in a small subset of the
sequence images. These points are seeds that MatchMover uses to build
up the whole point trajectory.

■ Derived 2D points: Derived 2D points created by MatchMover based on
information from the key points. They are derived from using an automatic
correlation-based template matching process.

The tracked points should be characteristic points, for example, points that
can be accurately localized in the image and represent physical points such
as markings, corners, or shadows.
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Automatic 2D tracking

MatchMover automatic tracking feature automatically locates “good” points
in the images, and then tracks them through the sequence. You can guide
this automated process by specifying key parameters and elements. However,
using automatic 2D tracking provides you with a tracking solution that does
not require manual editing.

Supervised tracking

For complicated scenes, it may be necessary to manually control the tracking
process by editing or deleting tracks created automatically by MatchMover.
You can also create your own tracks. When creating your own track, you
specify the key points, and then MatchMover derives the whole point
trajectory. You can mix automatic and supervised tracks in the same project.

Mattes
MatchMover lets you to identify areas within your sequence that you want
to exclude or highlight. For example, you can crop unwanted areas of a
sequence or import a matte sequence to flag objects as following an
independent motion.

You can use MatchMover cropping options to remove unnecessary black
borders from image sequences. Cropping the image focuses the tracking process
on the area you define, ignoring the unnecessary borders. Cropping is a global
operation, meaning that it is applied to all frames in the sequence. Cropping
cannot be animated as a matte.

Using a matte, you identify an area in the sequence that has a different motion,
such as a a character occluding part of the background you want to track, and
have MatchMover ignore the area. You can also have MatchMover compute
independent motions for areas lying inside and outside the matte. For example,
you can compute the motion of the moving camera with respect to the fixed
background, and at the same time, compute the motion of a mobile object
appearing in the sequence. In the latter case, both the background and the
car will be tracked within the same solve.

You import mattes made in other application into MatchMover or you can
create your own mattes by drawing their outline. Mattes created either method
can be combined in the same project.

TIP You can combine the results of two cropping operations on an image then
exclude specified areas with a matte.
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3D objects
MatchMover provides you with a set of objects called 3D primitives. 3D
primitives are basic 3D shapes such as cubes, cones or spheres. You can import
other objects into MatchMover as long as the object s are in the OBJ format.
You can use a 3D object as it appears or edit it, using one of the MatchMover’s
manipulator tools. These virtual objects are fixed in space, and rendered using
the estimated camera parameters. The process is successful when the motion
of the virtual objects in the composed sequence is consistent with that of the
real scene. You can also use 3D objects to define survey points mapping by
dragging the mouse from one vertex to the image plane. See Setting survey
points using elastics on page 177.

Camera computation
From the collection of 2D tracks, MatchMover estimates all camera parameter
including internal parameters such as focal length and non-linear distortion,
camera position and orientation over time, and 3D point coordinates.

Depending on your project, you can provide MatchMover with some specific
information about the shot, thus constraining the process by reducing its
parameter space.

Keyframes

A keyframe is a frame containing enough parameter data for the camera solving
process. Using the data obtained from the 2D tracking process, MatchMover
initializes the cameras and creates the 3D points for the sequence. The
computation process starts on a solid keyframe pair, called the reference frames
(1 and 2). MatchMover automatically selects these frames when the solver is
launched or when using the Select keyframes command, if it is not locked by
the user. Depending on the camera motion, overriding reference frames may
help solve complex shots when the selected references are not well located.

Relations on 3D points

Point relations are used by MatchMover to obtain information about the
geometry of the scene. For example, this information can be that several points
share a coordinate, for example, all points on a horizontal plane, such as the
ground, share the same Y value. Or, that some points have known coordinates.
This usually happens when you have measured survey points in your on-set.
In this case, it may be simpler to use survey points. Providing MatchMover
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with information that helps the camera solving process improves the accuracy
of the results.

Survey points

If you know some of the properties of a scene, such as measurements, or you
have some constraints, you may know the 3D coordinates of some points of
the scene. Instead of letting MatchMover compute their 3D coordinates, you
can set them before the computation.

You can either set these coordinates manually or use one of your 3D object
vertex coordinates.

Camera constraints

Camera constraints tell MatchMover that a parameter is constant over a subset
of frames associated with a camera. As it reduces the number of computed
parameters, it limits the calculation time and speeds up the process.
MatchMover has four types of constraints. Focal length, Nodal Pan, Dolly,
and Planar.

Motion control

Some hardware devices, such as a Scorpio crane or Flair, output what is known
as “Motion Control Data”. You can import some of this data into MatchMover
using the motion control file parser. This information is directly input in the
calibration engine, and used as an initial solution. It can therefore be refined,
and additional camera parameters computed. See Importing motion control
data on page 181.

You can also manually input or override specified aspects of this data to
constrain the final solution to a valid, specified range before launching the
solver.
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User Interface Guide

User Interface overview
When you start Autodesk MatchMover, you are presented with the following
user interface.
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MatchMover Light Mode user interface

Light Mode is designed for simple automatic workflows. The user interface
displays only the tools that allow you to launch the assistant, load, autotrack,
and export.

NOTE All windows are fully floatable/dockable/resizable/hideable. Double-click a
window title to toggle the display status.

Use the interface mode selector in the Toolbar to switch the interface to ‘Full
Mode”.
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MatchMover Full Mode user interface

■ A number of menu items appear in the main menu bar. If a shortcut is
available, it is shown next to the menu entry. Some of the drop-down
menu functions are available directly through Toolbar icons and keyboard
shortcuts.

■ The Project window appears in the left pane of the MatchMover interface
and hosts the project elements in folders. See Project window on page 86.

■ The Workspace is where you do most of your work. When you load a
sequence, the images are displayed here.

■ The Parameters window displays the properties for the project, the current
camera, if any, and the selected project item.

■ The Track window shows the time variable elements that MatchMover can
manipulate within your project.
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■ The Time line appears at the bottom of the screen between the Track
window and the Status bar and gives a graphic display of the current time
and helps you to navigate through your image sequence.

■ When you select a menu item or a Toolbar icon a brief description appears
in the Status bar, located at the bottom to the interface.
The cache usage is also displayed in the Status Bar in the form of a pie
chart that changes from green to red as the cache left memory lowers. The
cache details are shown next to it (used cache memory/available cache
memory).

NOTE You can change the default theme color in the Preferences > Display
window:

The Toolbar
When you launch MatchMover for the first time, you can access several tools
in the Light and Full modes.

Light Toolbar - This toolbar provides functions for managing your files.
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In the Full mode:

■ File management tools - These tools provide functions for managing your
files, undoing and redoing actions, switching between the Full and Light
modes, and accessing the online Help.

NOTE In MatchMover, you use the Undo and the Redo icon  to
undo or redo, respectively, the last action. The Undo Buffer holds data required
to undo/redo actions. In addition the Actions window shows the most recent
undoable actions.
This stack is of limited size. Double-clicking on an action toggles its (and
all the next actions) undo/redo status.

■ Tracking tools - These tools provide functions for importing footage, the
management of your 2D tracking process, the camera solving.

■ Object manipulation tools - These tools provide access to management of
the 3D object manipulation.

■ Display tools - These tools provide access to the track display options and
the layout of the Workspace.

The Workspace
The first time you launch MatchMover, the Workspace is empty. Once you
load an image sequence, the frames of the sequence are shown in the
Workspace. The file name and size of the current frame are displayed next to
current time.
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Switching between the 2D and 3D mode

By default, a 2D View (a viewport in 2D mode) is shown. You can reset or
change the view type by using Window > New View and select the required
view.

As soon as a sequence or images are loaded, the 3D View (a viewport in 3D
mode) is available, with a default camera looking at the origin. The view can
be used for example to estimate distortion, by just shifting its value in the
curve editor, or to place 3D object and map survey points.

Use the 2D Mode button  and the 3D Mode button  in the top left
corner of the Workspace to toggle between the 2D and the 3D views.

For more information on the different views, see Working in 2D mode on
page 75 and Working in 3D mode on page 80.

Changing the viewport layout

You can split the Workspace into two or four viewports by selecting Window
> Layout from the main menu and the required split option.

Alternatively, you can click the icons in the Display tools to change the
viewport layout:

TIP Press the Spacebar to return to a single viewport from multiple viewports.

If split, one of the viewports is outlined as the current view. For example, the
Project window may be the currently activated window while the last edited
viewport remains current and receives any viewing action coming from the
Project window or from the main menu.

MatchMover stores the current viewport layout configuration in the project
file.

To switch between the Full Screen mode and the normal mode, click the Full

Screen icon  in the Toolbar.
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Resizing viewports

When you have several viewports in the Workspace, you can change their
size. Click the border of a view and drag the pointer to resize the view.

TIP Re-clicking on the current layout icon just reset to default layout geometry.
Re-clicking on single viewport icon just toggle between single and previous layout.

Working in 2D mode
MatchMover provides you with the ability to open different views within the
Workspace window to study and manipulate the image sequence and the
results of the tracking process.

When you load a sequence, the default view is the 2D View. The 2D View is
designed to display single images, image sequences and tracking information
to help in your 2D tracking task. The following list shows all items that are
drawn in the 2D View:

■ Images, helper images and matte sequences.

■ The current and local times of the frames in the upper left corner.

■ Masks. See Identifying image regions on page 113.

■ Camera Anamorphism, expanding the view to fit the anamorphic camera
settings.

■ Tracking information.

■ 2D Tracks, showing the position of the point in one frame. 2D tracks
can be displayed using the default cross-hairs or in pattern mode. You
can customize the display by selecting Preferences > Display > 2D Mode.

■ Point Labels, showing the point name.

■ Track Paths, showing the displacement of the point between frames.
The track paths are displayed either in a uniform color or using different
colors, depending on current track frame quality, from poorest (red),
to best (green). You can customize the display by selecting Preferences
> Display > 2D Mode and either Quality Color or Uniform Color from
the Track Path Style drop-down list.

To change the Track Path length, select Edit > Preferences, click the Display
tab, and in the Track Path Length text field, enter a number. MatchMover
defines the maximum number of frames in which the Track Path is shown
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from the current time. A value of 100 shows the Track Path for 50 frames
before and 50 frames after the current frame.

■ 3D Tracks, showing the color-coded 3D reconstructed points (green for
good, yellow for fair, red for bad), and a link to its corresponding 2D
track, calculated after running the automatic tracking process. Hard
tracks are displayed with a surrounding circle to easily identify them.

■ Tracker Tool, showing the key search size and pattern size.

NOTE To change the color of the 2D View background, select Edit > Preferences,
click the Color tab in the User Preferences window, and change the color of the
corresponding sample box.

Displaying the 2D View attributes

You can display or hide points’ attributes by either:

■ Selecting Display from the main menu then clicking on the attribute in
the pop-up menu.

■ Right-clicking in the 2D View and selecting Display and an attribute from
the pop-up menu.

For the Masks and Anamorphism options, a check mark beside the option
indicates that the option is active. Clicking the option again hides the check
mark and deactivates it.
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For other attributes, a single diamond  shown beside the attribute in the
menu defines that the attribute is displayed for the selected point.

If you click again, two diamonds  appear beside the attribute defining that
the selected attribute is displayed for all points. No diamonds means this
feature is not displayed. By default the Point Label, Track Path, Tracker Tool,
and Tracking Score are only displayed for the selected key point or computed
point.

NOTE To change the color of the Track Path (in uniform color mode) or the key
points on the track, select Edit > Preferences, click the Color tab in the User
Preferences window, and change the color of the corresponding sample box.

Changing the time in the 2D View

The 2D View shows an image at a given time. The current time is shown in
the top left corner of the viewport.

■ To change the current time, press Ctrl+click and drag the pointer. The

pointer changes to  .

■ To move to the previous frame, press Ctrl+left arrow.

■ To move to the next frame, press Ctrl+right arrow.

■ To reset the current time to the beginning of the sequence, right-click the
required sequence in the Image Sequences folder in the Project window
and select Goto Begin from the pop-up menu.

To hide the current time, select Edit > Preferences > Display and click in the
Show Current Time in Viewports check box to disable the option.

TIP If nothing is currently selected, just pressing arrows navigate through
time/zoom.

Freezing the time

By default, time changes in the Time Line or other 2D views are always
synchronized with current time. However, when you “freeze” the 2D View,
changing the time in other views (the Time Line, the Track window or other
2D Views) does not affect the time in the frozen view. Other views are not
synchronized with current time.
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If you change the time in the frozen view, other views are synchronized with
the current time in the frozen view.

The Freeze Time mode is useful if you need to study frames at different times,
for example, when you have multiple 2D views and need to see them at a
certain time, for instance when editing tracks in a helper frame.

The shortcuts Ctrl+left arrow or right arrow change the time in the frozen
window only if the window is active (blue surround).

To freeze the time in the 2D View, do one of the following:

■ Select View > Freeze Time.

■ click the icon  in the Workspace.

■ Right-click in the 2D View to show the pop-up menu and select Freeze
Time.

Resetting the current view

To reset the current view, select Window > New View > New 2D View or press
Ctrl+2 (default shortcut).

Navigating in the 2D View
You can access the navigation options in the View menu. Alternatively, use
the following shortcuts and drag the pointer in the 2D View, Track View,
Graph Editor, and Track Status View

PointerShortcutAction

Ctrl+clickChanges the current
time

-Ctrl+right arrowMove to next frame

-Ctrl+left arrowMove to previous
frame

Alt+click (or scroll
bars)

Pan#
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PointerShortcutAction

Alt+Ctrl+click (or
“+” or “-”)

Zoom

Alt+Shift+clickZoom in an area in
the 2D View

#Pan horizontally only in the Track View, Graph Editor, and Track Status View

In the 2D View:

■ click the Panicon  in the Navigation toolbar at the bottom of the
window and drag the pointer to perform the navigation.

■ Use the scroll buttons and slider  to scroll
through the images.

■ Click and hold the Navigate button  to easily pan in the image. A
popup window of the entire image appears with a rectangular guide to
orientate you in the image.

In addition to the navigation options shown in the previous table, you can
right-click in the 2D View and select the following options from the pop-up
menu.

■ To center the view on the selected item, select View > Fit to Selection.

■ To set the largest zoom that keeps the entire image contained in the
viewport select View > Fit to Viewport.

NOTE You can also click the Fit to Viewport  in the Toolbar.icon.

■ If you have zoomed the image you can return to the original size with
View > Reset zoom.
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Working in 3D mode
The 3D View shows the following from an arbitrary viewpoint:

■ Cameras

■ Tracking information

■ Point Labels, showing the point names.

■ 3D Markers, or 3D Helpers, displaying the estimated 3D points as
customizable 3D Helpers (cones, pyramids, crosses). A link is drawn
between the 2D reprojections and the corresponding 3D points if
available.

■ Manipulator Axes

■ A 3D planar Grid

■ Non-physical objects: Lights and Relations

■ Built-in contours

■ The estimated Camera Path

■ The reference coordinate system

■ 3D objects created directly in MatchMover or imported. See Working with
3D objects on page 205.

The default 3D View is in the Free Camera mode with the image plane
displayed. By clicking on the image plane, you are able to tweak its displayed
depth by using the displayed translation manipulator.

Toggle the image plane display by selecting Display > Background Image.
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In the 3D View window you can switch to Lock on Camera mode. See Lock
on Camera mode on page 83. The view constrains the camera to see the image
as the background.

When you place a 3D object within the 3D View window, MatchMover
provides manipulators that you can use to edit them. See Editing 3D primitives
and objects on page 207.

NOTE To change the color of the 3D View background, the camera, or the camera
path, select Edit > Preferences, click the Color tab in the User Preferences
window, and change the color of the corresponding sample box.

NOTE To reset the current 3D View, see Resetting the current view on page 78.

You can create tracks in the 3D View in the same way as in the 2D View. See
Working in 3D mode on page 80.

Displaying the 3D View attributes

By default the 3D View shows a grid and axes with a perspective viewing, the
camera path with its corresponding image plane, and the reconstructed points.

You can display or hide points’ attributes by either:

■ Selecting Display from the main menu then clicking on the attribute in
the pop-up menu.
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■ Right-clicking in the 3D View and selecting Display and an attribute from
the pop-up menu.

For Point Labels and 3D Marker Styles attributes, a single diamond defines
that the attribute is displayed for the selected point.

If you click again, two diamonds appear beside the attribute defining that the
selected attribute is displayed for all points.

No diamonds means that this attribute is not displayed.

For all other options, a check mark beside the option indicates that the option
is active. Clicking the option again hides the check mark and deactivates it.

You can also toggle the 3D object display in the Display menu:

■ Flat shading

■ Wireframe. A backface culling option for wireframe mode also exists in
the Display menu.

■ Transparent

■ Texture mode.

TIP The default shading is smooth. See the Preferences window to change it to
real flat shading.

Select Display > Inliners to show only the 3D points that are defined in 2D at
the current frame.

Changing the number of wireframe divisions

You can change the number of divisions in the wireframe of a selected object
in the 3D View mode.

1 Select the Project tab in the Parameters window.

2 Enter a number in the 3D Primitive Resolution text field. A smaller number
reduces the size of the intervals in the wireframe grid; a greater number
decreases their size.

Changing the size and shape of the 3D Helpers

To change the size of the 3D helpers:

1 Select the Project tab in the Parameters window.
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2 Select a 3D Helper Shape from Cone, Pyramid, or Cross. Select Cross for
a better feedback of the 3D helpers’ orientation.

3 Enter a number in the 3D Helper Size text field. A smaller number reduces
the size of the 3D Helpers; a greater number increase their size.

NOTE To change the color of a 3D point or the selected 3D point, select
Edit > Preferences, click the Color tab in the User Preferences window,
and change the color of the corresponding sample box.

Changing the Grid Step

By default, the 3D Grid Step has a value of 10. You can change this value in
the Subdivisions text field in the Project tab in the Parameters window.

Lock on Camera mode

The Lock on Camera mode allows you to insert virtual objects and constrains
the computed camera to view the image sequence as the background.

It can be considered as a 2D view with superimposed 3D objects.

The Lock On Camera mode allows you to display the same attributes as the
Free Camera mode.

Working in 3D mode | 83



To lock on a camera:

1 Make sure that you are in the 3D mode.

2 Do one of the following:

■ Select View > Lock On Camera.

■ Right-click in the 3D View window and select Lock On Camera from
the pop-up menu.

■ Click the Lock on Camera icon  in the Navigation toolbar.

NOTE As the Lock on Camera mode includes the image sequence, you are
viewing the scene from the position of the estimated camera. Unlike the Free
Camera mode, you cannot rotate or the scene to view it from a different
position.

Navigating in the 3D View

You can access the navigation options in the 3D View in the View menu or
in the Navigation toolbar located at the bottom of the Workspace.

Use the slider to scroll through the images.

Alternatively, you can use the following shortcuts and dragging the pointer.

PointerShortcutAction

Ctrl+clickChanges the cur-
rent time

Alt+Ctrl+clickDolly
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PointerShortcutAction

Alt+Shift+clickFit to rectangle

-Ctrl+right arrowMove to next
frame

-Ctrl+left arrowMove to previous
frame

Alt+right-clickOrbit in the Free
Camera mode

Alt+click (or scroll
bars)

Pan

Alt+Ctrl+right-click
(or “+” or “-”)

Zoom

NOTE By right-clicking in the 3D View, you can turn the camera toward the
selected item by selecting View > Look At from the pop-up menu.

Browsing the footage
Once you have loaded a sequence, you can play it by clicking on the Play
Sequence Toolbar at the bottom of the Workspace.

The Play Sequence Toolbar from left to right is described below.

■ First Frame - Navigates to the first frame of the sequence.

■ Previous Frame - Changes the current time to point to the preceding frame.

■ Play Reverse - Runs the play segment backwards.
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■ Play/Stop - Runs the play segment forwards in the current view. The play
segment is either the frames contained within the selection, if any, then
in the Work Area, if any, or all the frames of a sequence. Other views or
controls are refreshed only if the hardware performance allows it.

■ Next Frame - Changes the current time to point to the next frame of the
sequence.

■ Last Frame - Navigates to the last frame of the sequence.

You can also play the sequence forward or in reverse by selecting Sequence >
Play or Play Reverse or skip untracked or unsolved frames. See Skipping
untracked frames on page 150 and Skipping unsolved tracks on page 150.

Selecting a Play Mode

You can determine how a sequence is played by selecting Sequence > Play
Mode and selecting one of the following options:

■ Normal - Plays the sequence from the current frame and automatically
stops the playback when the play segment limit is reached.

■ Loop - Continuously loops the entire sequence or a segment of the sequence
(if a Work Area is defined).

■ PingPong - Continuously loops the entire sequence or a segment (if a Work
Area or a time range is defined) forward and backward.

Alternatively, you can press the corresponding options in the Navigation
Toolbar.

Project window
The Project window appears in the left pane of the MatchMover interface and
allows you to have an overall view of the project.
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The Project window shows all the elements that can be manipulated by
MatchMover. You can also create, delete or launch an action in the Project
window. The tree structure organization aids in arranging and managing your
project.

Click  to close the Project window.

To restore the view, select Window > Project Window.

Some Project window elements appear in bold. Only one element of a given
type can be bold at a given moment.

For example, an image sequence label is bold if the current time corresponds
to an image of this sequence. A coordinate system label is bold if it is used to
calculate or show 3D information. A camera label is bold if it is associated
with the enabled image sequence. A constraint label is bold if it is defined for
the current time.

Project window folders

The Project window folders contain the elements of your project. To expand
or collapse a folder, click the + or - symbols to show the list of all the elements
within the folder.

■ Image Sequences - Contains the list of images, image sequences, contour,
mattes and the sub-folders Bookmarks containing shortcuts to images.

■ Point Tracks - Contains the list of point tracks and groups created.

■ All tracks can be sorted in groups. See Groups attributes on page 152.

■ A group can be designated as mobile (designing a rigid moving object)

by selecting the Mobile option in the Parameters window  .

■ Hidden tracks are dimmed and they are not displayed in the 2D View
or in the 3D View. Selecting the corresponding option in the Render
window can still render them.
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■ Coordinate Systems - Contains the list of coordinate systems that can be
used to represent the 3D data.

■ Point Relations - Contains the list of defined relations between point tracks.

■ Cameras - Contains the list of cameras and their relative sub-folders
containing the camera constraints defined for them, if any. Empty
constraints are dimmed with “empty” after their label. You should add
frames to any constraint before using it.

■ 3D Scene - Contains the 3D scene elements of a project.

Click an element to open its properties in the Parameters window.

Track window
The Track window contains two separate panes; each pane reacts in
synchronization with the other, and shows the time variable elements that
MatchMover can manipulate within your project.

Scroll through the Track View, the Graph Editor, and the Track Status View
by clicking on the tabs at the bottom of the window, just above the Time line.
See User Interface overview on page 69.

Click close the Track window. To restore the view, select Window > Track
Window.

The Track View

The Track View is used mainly for supervised 2D tracking. See Supervised 2D
tracking on page 132. The left pane is a sub section of the Project window
showing the elements contained in your project in relation to time. See Project
window on page 86. Within the right pane of the Track View, symbols are
used to give a graphic representation of the elements and their state.

88 | Chapter 3   User Interface Guide



■ The Time Bar is a double vertical bar represents the current time.
Double-click in the right pane to move the Time Bar to the required frame.

■ The Graded Ruler shows the position of the current time in the sequence.
Click and drag the ruler to move it vertically within the pane. Symbols in

the Graded Ruler indicate whether the frame is a reference frame,  and

 or a keyframe  .

■ If it is yellow  , the keyframes are automatically generated and
unlocked; otherwise, they are locked.
The graded ruler also shows information about the 3D solving status of
each frame. A lock icon is displayed on the right-end of the graded ruler

that enables easy keyframes locking/unlocking  .

■ The Time Range allows you to select a group of frames, also displayed in
the Time Line. See Time Line window on page 93.

The shape of a point indicates whether the point is a key point or a computed
point, and the type of tracking generated. See Editing a key point type on page
138.

Navigation in the Track View

The horizontal zoom is available by pressing Ctrl+Alt+click and you can fit
the entire sequence if possible (one frame has a one pixel minimum width).
Just do it by selecting View > Fit To Viewport (“=” is the default shortcut).

Click a track in the Project window and select Sequence > Track Begin or End
(or press Ctrl+Shift+up or down) to move to the beginning or the end of a
track. Panning in this view is done in the same way as any other view (using
Alt+mouse drag), or just by using the horizontal slider.
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Track View folders

The right pane is divided into several rows, each one corresponding to an item
in the left pane tree view. If an item in the tree view is selected, its
corresponding row in the right pane is surrounded by a colored rectangle.

■ The Image Sequences folder contains all the footage. A blue colored bar
in the right pane indicates which frames correspond to each sequence.

■ Colored bars for each track in the Point Tracks folder indicate the tracking
status and quality according to the Quality Thresholds set in the User
Preferences window. See About key points on page 137.

Tracking QualityColor

Not trackedNone

PoorRed

FairYellow

GoodGreen

Hard tracks (manual tracks) are defined by a circle with a cross.

Soft tracks (automatic tracks) are defined by a cross.

See also Creating a new track on page 132 for a definition of the symbols
used for the track reconstructuon status.

■ The Camera folder contains the project’s cameras and constraints. A blue
colored bar in the Track View indicates that the camera belongs to the
current image sequence.

■ For constraints, a small colored line just above the constraint’s colored bar
indicates the type of constraint.

Constraint TypeColor

UnknownLight gray

InitializedDark gray

FixedBlack

If the constraint is disabled, the bar is hatched.
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The Graph Editor

The Graph Editor displays a graphical representation of computed camera
parameters as well as providing options to edit the results. Depending on the
type of camera motion (hand-held, stabilized, motion-controlled) and the
quality of the 2D tracks, it may be useful to smooth some or all of the
computed camera parameters. Smoothing can be done by hand, or by using
a post filter. See Filtering the results on page 195.

The Track Status View

The Track Status View provides read-only information on the computation
of track points.

Use the Track Status View to survey the quality of pixel residuals for each
track.

■ Show Thresholds - Toggles the display of the threshold parameters. See
Configuring the tracker on page 144.

■ Show Track Average - Highlights the average track residual.

■ Show Global Average - Displays a curve representing the average pixel
residual of all tracks in a sequence.

■ Find Frame Max - Displays the maximum frame residual.

■ Find Average Frame Max - Displays the average maximum frame residual.

■ Find Track Max - Displays the maximum track residual.

NOTE You can also access the above options by right-clicking in the Track
Status View and selecting them from the pop-up menu.

Click  to close the Track Status View.

To restore the view, select Window > Track View.
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To fit the graph to the viewport, select Graph > Fit or right-click in the Track
Status View and select Fit from the pop-up menu.

Parameters window
The Parameters window allows you to visualize the properties for selected
project elements and edit project element data and parameters.

The Parameters window describes the following: project properties:

■ Global project parameters (displayed when no item is selected, just press
Esc), such as view settings and keyframes. See Editing reference and
keyframes on page 158 and Working in 3D mode on page 80.

■ Image sequences parameters. See Managing footage on page 108.

■ Bookmarks parameters. See Moving to a bookmarked frame on page 112.

■ Contours parameters. See Changing a contour’s properties on page 120.

■ Matte sequences parameters. See Setting the matte properties on page 115.

■ Track groups parameters. See Groups attributes on page 152.

■ Tracks parameters. See Creating a new track on page 132.

■ Coordinate system parameters. See Defining the coordinate system using
the Parameters Window on page 168.

■ Point relations parameters. See Creating a point relation on page 173.

■ Cameras parameters. See Setting up cameras on page 159.

■ Camera constraints parameters. See Creating and enabling a constraint on
page 178.

■ 3D objects parameters. See 3D primitives and objects Parameters Window
on page 211.

Actions window
The Actions window shows the most recent undoable actions. This stack is of
limited size. Double-clicking on an action toggles its (and all the next actions)
undo/redo status.
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Time Line window
The Time Line appears at the bottom of the screen between the Track window
and the Status bar and gives a graphic display of the current time and helps
you to navigate through your image sequence.

1 Work Area start frame

2 Selected area start frame

3 Work Area begin marker

4 Work Area

5 Time range

6 Current selected frame

7 Slider

8 Work Area end marker

9 Work Area end frame

10 Selected area end frame

11 Current selected frame

12 Frame rate

■ The Work Area defines the beginning and the end of the sub section of
the sequence that you work with. Frames outside the Work Area are ignored
for tracking and playing purposes. If a Work Area has not been defined
previously, begin and end markers are positioned at the first and last frames.

■ When you load a sequence, the Slider, a red pointer, shows the current
frame position with the corresponding frame number. The first frame is
always 0 and the total number of frames appears on the far right of the
sliders.
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■ The Numeric Fields show the Work Area start and end frames, the selected
area start and end frames, the number of the current frame, and the current
output frame rate in frames per second.

■ A fourth element, not present at all times, is the Time Range, shown in
yellow. See Running the automatic 2D tracking on page 127.
The Time Range is used for one-shot operations such as clearing points in
several frames, or defining the span of a camera constraint.

When you create a bookmark for a frame, a check in the Time Line indicates
its position. See Placing a bookmark on page 112.

Double-click the edge of the time line to undock it. Once undocked, click and
drag on its edge to reposition it within the interface.

To close the Time Line, click the  and restore it by using Window > Time
Line Window.

Changing the current time using the Slider

Click within the Slider to change the current time. The blue pointer now
points to the new current time with the current time frame number shown
above the pointer.

If you load several image sequences, a black vertical bar shows the position
of the start frame for each sequence.

Changing the current frame using the Numeric Field

1 Click inside the Numeric Field.

2 Enter the current frame number to change to and press Return/Tab to
validate.

MatchMover moves the pointer to point to the required frame.

Defining a Work Area

Before running the automatic tracking process, you can specify a section of
the sequence to track, defined by the Work Area. The Work Area is an interval
of frames in a sequence to which you can selectively apply the automatic
tracking operation. If you don’t specify a Work Area, the entire active sequence
matching the current time will be processed. If there are other sequences
loaded, they will be ignored.
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NOTE All frames in the Work Area must belong to the same sequence; otherwise,
autotracking is disabled. Therefore, MatchMover cannot process scenes with helper
frames automatically. However, you can automatically track the main sequence,
then edit the helpers before solving the scene.

To define a Work Area:

1 Position the pointer at the frame where you want to begin the Work Area
and do one of the following:

■ Select Sequence > Begin Work Area.

■ Right-click in the Track View and select Set Current Frame > Begin
Work Area from the pop-up menu.

■ Edit the gray Work Area start frame box. For a description of the Time
Line, see Time Line window on page 93.

The begin marker is set to the current frame.

NOTE If a Work Area has not been defined previously, begin and end markers
are positioned at the first and last frames.

2 Position the pointer at the frame where you want to end the Work Area
and do one of the following:

■ Select Sequence > End Work Area.

■ Right-click in the Track View and select Set Current Frame > End Work
Area from the pop-up menu.

■ Edit the gray Work Area end frame box. For a description of the Time
Line, see Time Line window on page 93.

The end marker is set to the current frame.

The background changes color indicating the time range. For a description
of the Work Area, see Time Line window on page 93.

Alternatively, you can define the Work Area by dragging the Work Area marker.

Resetting the Work Area

To reset the Work Area.

Position the pointer in the Track window select Sequence > Reset Work Area.

MatchMover moves the begin and end markers to the first and last frames,
respectively.
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Magnifier window
Always available in either 2D View or the 3D View, the docked Magnifier
window appears by default below the Project window. The window is used to
zoom the area around a track and to fine tune the currently selected track by
simply clicking on it. When a track is selected, the Magnifier window stays
locked on the track. If you move the pointer over another track, this track is
displayed. When you move the pointer out, the locked track is restored.

When the Magnifier window is active, other views are frozen. It then can be
used to check one track very easily and fast, combined with the Skip Untracked
option. See Skipping untracked frames on page 150.

Activate the Magnifier window by clicking on the open padlock  on the

right of the zoom slide bar. The closed padlock  appears.

Zoom in the Magnifier window by moving the horizontal slider.

To change the Magnifier behavior when placing 2D tracks:

1 Select Edit > Preferences. The User Preferences window appears.

2 Select the Display page.
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3 In the Magnifier Behavior drop-down list, choose an option:

■ Disabled - No magnifier is shown.

■ Popup - Zooms the selected area under the pointer in the 2D View
and the 3D View (default).

■ Toolbox - Use the Magnifier window. If you chose this option, enter
the size in pixels and the default zoom of the toolbox in the Magnifier
Toolbox Size and Magnifier Zoom fields.

4 Click OK.

Keyboard shortcuts
MatchMover provides the following types of command shortcuts:

■ The pop-up (shortcut) menus contain commonly used commands,
depending on in which window the pointer is located. To access the pop-up
menus, right-click an element.

■ User-defined shortcuts
Every command can have a user-defined shortcut. Select Preferences >
Keyboard then select a command in the list, for example, Display > Point
Label and then press the new shortcut keys in the indicated box. If the
shortcut is already assigned to another command, it will be displayed. Press
Assign to validate the new shortcut.
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Default keyboard shortcuts
The keyboard shortcuts are shown next to the main menu commands or
actions.

ShortcutAction

33D tracks display, toggle

22D tracks display, toggle

Page UpAlign Pivot

F11Automatic clean-up

F10Automatic tracking

BBackground display, toggle

Shift+right-clickCancel time range

HomeCenter Pivot

Ctrl+clickChange the current time

BackspaceClear Tracked Points

Ctrl+KCreate or remove keyframe

Shift+clickDefine a time range

DelDelete

Ctrl+Alt+clickDolly

Ctrl+NFile New

Ctrl+OFile Open

Ctrl+SFile Save

=Fit

Shift+Alt+clickFit to rectangle
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ShortcutAction

FFlat Shading

Ctrl+DelFlush the cache

Ctrl+HomeFrame, First

Ctrl+EndFrame, Last

Ctrl+right arrowFrame, Next

Ctrl+left arrowFrame, Previous

XFullscreen Layout

GGrid display, toggle

F12Import Motion Control

Page DownInvert Pivot

Ctrl+down arrowKey, Next

Ctrl+up arrowKey, Previous

LLabels display, toggle

CLock On Camera

MMatte display, toggle

Ctrl+2New 2D View

Ctrl+3New 3D View

Alt+right-clickOrbit the camera

Alt+clickPan

PPreferences

Ctrl+YRedo
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ShortcutAction

RRender Setup

0Reset Zoom

Ctrl+Page DownSequence, Next

F2Sequence, Play

Shift+F2Sequence, Play reverse

Ctrl+Page UpSequence, Previous

F5Set key, Begin

F7Set key, End

F6Set key, Intermediate

F8Set key, Single

SpaceSingle Viewport

F9Solve for camera

Alt+TTextured Shading

Shift+F3Track backward

Ctrl+Shift+UpTrack Begin

F4Track bidirectional

Ctrl+Shift+DownTrack End

F3Track forward

TTransparency mode

Ctrl+ZUndo

WWireframe mode
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ShortcutAction

Ctrl+Alt+right-clickZoom

Alt+Shift+clickZoom in an area
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User Guide

Solving a sequence using the Matchmoving
Assistant

Using the Matchmoving Assistant, you can easily set up the values for solving
a sequence:

1 You can launch the assistant by clicking on its icon  in the toolbar
(in light mode) or by selecting Help > Assistant.

The Basic Settings window opens. Select a sequence to matchmove and if
required, a mask sequence and the corresponding channel information.

A mask allows you to identify some areas within your sequence to either
exclude them (black areas of the mask represent the ignored area). Select
the type of the mask: alpha to use alpha channel or RGB to use the color
values.

4
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You can also load settings as a MatchMover RZML file. Click the Next
button.

2 In the Sequence Range window, you can choose the start and end frames
of the part of the sequence you want to solve and click Next. If you want
to matchmove the entire sequence, just click Next:

3 In the Camera Settings window, the MatchMover Assistant displays the
automatically detected camera type. If the selected camera is not correct,
choose the camera that you want to assign to the sequence from the
drop-down list. Select the required camera motion and focal length
options.
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4 Click Finish to close the assistant. The project will be set up and ready
for tracking.

5 Click Finish to run the solver.

Managing projects
Projects are the basic elements of file management within MatchMover and
it is important that you understand what a project contains. A project is
defined as one scene.

MatchMover projects files have the “.mmf” extension. You can load as many
image sequences within a project, as long as they are from the same scene and
contain points that are common.

To start a new, empty project, do one of the following:

■ Select File > New.

■ Click the New icon  in the Toolbar.

You can load a project previously saved to disk under the (.mmf) format.

To open an existing project, do one of the following:

■ Select File > Open.
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■ Click the Open icon  in the Toolbar.

■ Drag and drop a project file into the Workspace.

NOTE To open one of the five most recently loaded projects, select File and
choose a file from the pop-up menu.

If a project is already open, MatchMover prompts you to save it before opening
a new one.

To save a project.

1 Select File > Save  or Save As to change the project file.

2 Enter the name of the project in the Save As window and click Save.

MatchMover saves the project with the “.mmf” extension.

TIP A star is displayed next to the project name in the title bar if the current project
has been modified. If you click the save icon of an unmodified project, it will open
the Save As window.

NOTE In the event where the application crashes, MatchMover tries to save current
project (it may be impossible in some cases). This file is then displayed at the top
of the most recently used file list in the File menu, at the next execution of the
application only.

Setting the project preferences

You can set various project and display preferences in the User Preferences
window by selecting Edit > Preferences. For example, in the Colors page, you
can define the default colors for various project elements.

Setting the image cache size

You can also set up the Image Cache Size, which refers to the amount of
memory (%) used for storing the real time RAM playback. The higher, the
smoother the playback and scrubbing you will have. If you are running other
applications in the background, or plan to leave MatchMover running on the
background then it is suggested to lower the amount.
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All 2D images are always stored in the cache. By default, 3D textured images
are not stored in the cache, but this can be enabled in the cache preferences.
You can opt to display 3D textures, even in 2D Mode.

Flushing the cache

The current Cache Manager status is displayed in Status Bar as a semi-circle
(current memory used in color/memory available in gray).

The cache can also be flushed by selecting Edit > Flush Cache or pressing
Ctrl+Del.

Resetting the project preferences

The Reset Page and Reset All buttons at the bottom of the Preferences window
can be used to change the current values to their default status, either for
current page or for all pages. This action can be cancelled by pressing the
Cancel button in the Preferences window, but once the window is closed, it
cannot be undone.

Setting user-defined shortcuts

Every command can have a user-defined shortcut that can be set in the
Keyboard tab of the Preferences window.
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Managing footage

Importing footage
MatchMover can load image sequences with the following formats:

■ AVI files (*.avi) (Windows only)

■ Cineon files (*.cin)

■ JPEG files (*.jpg, *.jpeg)

■ Maya Image File Format (*.iff, *.tdi)

■ PNG files (*.png)

■ PNM files (*.ppm, *.pgm, *.pnm)

■ QuickTime (*.mov) (Windows and Mac only)

■ SGI files (*.sgi, *.rgb)

■ Softimage Pict files (*.pic)

■ TGA files (*.tga)

■ TIFF files (*.tif, *.tiff)

Loading a sequence

To load a sequence:

1 Do one of the following:

■ Select File > Load Sequence. The Open window appears.

■ Click the Load Sequence icon  in the Toolbar.

■ Drag and drop a sequence into the Workspace.

NOTE You can also right-click the Image Sequences folder in the Project
window or the Track window and select Load Sequences from the pop-up
menu or simply double click this folder.
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2 Use the Details button to enlarge the window and show a preview of the
first and last image of the sequence. The number of images in the
sequence, their width and their height are shown at the bottom of the
window.

3 Select an AVI or MOV sequence (*.avi or *.mov) or single image. In the
case of sequence of consecutive images, you can force the last frame in
the dedicated Set end edit box.

IMPORTANT A sequence composed of a series of images must contain a
minimum of two consecutive frames.

4 If the images are from a video camera, select an Interlace type from None,
Upper field first, and Lower field first in the corresponding combo box.

5 You can use the following shortcuts to apply a parameter to the entire
sequence:

■ Choosing a camera Motion different from “Free” is equivalent to
creating the same constraint later. See Defining camera constraints
on page 177.

■ Set the Frame Rate for the sequence. See Frame rate on page 62.

■ Set the camera Focal Length constraint to Constant or Variable. See
Setting up cameras on page 159.
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6 If you want to use the sequence alpha channel as a matte, check the
corresponding option. See Identifying image regions on page 113.

7 Click Open.

8 Click the browser button to change the source of the loaded footage. You
must only select a footage with the same characteristics (resolution and
length).

See Assigning the camera to a sequence on page 160 for camera settings
and Cropping an image sequence on page 126 for borders settings.

MatchMover loads the film into the Workspace and creates a new sequence
label in the Project window.

File mask naming convention

The file mask name is defined from the image name by replacing the last
number found in the filename with:

■ An asterisk * (the file img100.jpg, gives the mask img*.jpg).
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■ With a pound sign #, if the number begins with a zero (zero padding). The
mask contains as many # as there are numbers in the filename (the file
img0001.jpg gives the mask img####.jpg).

If you select a single image, all the images present in the directory that share
this mask and have a higher number than the selected image are loaded, unless
Set end is checked. In this case, the numeric field defines the number of the
last image to load.

The image numbers must be continuous. If a number is not found,
MatchMover assumes the last image of the sequence has been found. All
images must be of the same size.

Loading helper images

To load helper images, select File > Load Images and proceed in the same way
as you loaded your sequence. See Loading a sequence on page 108.

All images selected at the same time will be assigned to the same camera.
MatchMover assumes they have been shot with the same camera, although
in different positions. You can modify this, however, by creating new cameras
and associating them with the appropriate images.

Switching between sequences

To switch between loaded sequences, select Sequence from the main menu
and either of the following options:

■ Previous Sequence - If the current time points to the beginning of the
sequence, this command changes it to point to the start of the previous
sequence. If the current time does not point to the beginning of the
sequence, it changes it to point to the beginning of the sequence.

■ Next Sequence - Navigates to the start of the next sequence.

Deleting a sequence

To delete a sequence, do one of the following:

■ Select the required sequence in the Image Sequences folder in the Project
window or the Track window and either:

■ Select Edit > Delete.

■ Press the Delete key.
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■ Right-click the required sequence in the Image Sequences folder in the
Project window or the Track window and select Delete Sequence from the
pop-up menu.

Working with bookmarks
When you have spent a lot of time and effort placing your key points in a
certain frame and you wish to find this frame quickly, you can use the
bookmark feature.

Placing a bookmark

From the frame you want to bookmark, do one of the following:

■ Select Sequence > New Bookmark  .

■ Right-click the Bookmark folder in the Project window and select New
Bookmark from the pop-up menu.

MatchMover bookmarks the frame and places a check mark in the Time Line
so you can easily move to it.

At the same time a bookmark element appears in the Project window.

Moving to a bookmarked frame

To go to a bookmark, do one of the following:

■ Select Sequence > Goto Bookmark. MatchMover changes the current time
to the selected bookmark. This option is available only if a bookmark is
selected.

■ Click the check in the Time Line.

■ Right-click the Bookmark folder in the Project window and select GoTo
Bookmark from the pop-up menu.

■ Modify the value in the Time text field in the Parameters Window.
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The bookmark’s Parameters Window also shows the bookmarks’ Label (name
of the bookmark), Sequence Name to which the bookmark belongs, and the
Frame Number in relation to the start of this sequence (local time).

TIP By using the View > Freeze Time option you can lock a view to a specific
time. This is particularly useful when navigating between two specific frames. See
Freezing the time on page 77.

Deleting a bookmark

To delete a sequence, do one of the following:

■ Select a bookmark in the Bookmark folder in the Project window and either:

■ Select Edit > Delete.

■ Press the Delete key.

■ Right-click a bookmark in the Bookmark folder in the Project window and
select Delete Bookmark from the pop-up menu.

The bookmark is deleted from the project.

Identifying image regions
In MatchMover, you can load one matte for each sequence. The matte,
however, must have the same resolution and number of frames as those of
the sequence.

The matte can be loaded simultaneously with the loading of the actual film
sequence if it is included in the alpha channel. In the File > Load Sequence
or File > Load Images window, check the option “Use alpha channel as matte”.

Alternatively, to load a matte sequence:

1 Select File > Load Matte Sequence.
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The Open window appears.

2 Click the Details button to see thumbnails of the files in your directories.

3 In Files of type, select one from among the file types supported by
MatchMover. See Loading a sequence on page 108.

4 In the case of sequence of consecutive images, you can force the last
frame in the dedicated Set end edit box.

5 Select a Matte Channel. The default channel used is the Alpha channel,
which stores selections as 8-bit grayscale images, but you can choose
other color information channels. Red, Green, Blue, and Gray (for
grayscale images). These colors do not affect the actual images.

6 Select an Interlace type from None, Upper field first, and Lower field
first.

7 Select the matte sequence file you want and click Open.

MatchMover loads the matte sequence into the Workspace.
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The example shows a black matte that serves to focus the points on a moving
car.

Following the child-parent hierarchy, the matte is listed in the Project window
and Track window in the Image Sequences folder under the sequence it covers.

■ The icon  represents a matte with black masking a selected area.

■ The icon  represents a matte with white masking a selected area.

Displaying, hiding, and deleting mattes

If mattes are displayed, all the areas masked out are shown with the matte
color and transparency in the 2D Mode. You can hide or show mattes by doing
one of the following:

■ Select Display > Matte from the main menu.

■ Right-click in the Workspace and select Display > Matte.

The check mark beside the Matte option signifies that the matte is shown.
Click the option to deselect it and hide the matte. You will see the full video
footage.

To delete a matte, right-click the matte in the Project window and select Delete
Matte from the pop-up menu.

Setting the matte properties

The Parameters Window lists the matte properties.
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■ The matte’s Label and File Name

■ The Number of Frames in the sequence

■ The beginning and end Frames in the range

■ The Range of frames being used

■ The Interlace attribute that you can set to None, Upper field first, and
Lower field first.

■ The displayed color and transparency

■ The Group attributes.

You can also select the channel being used by the matte sequence. Red, Green,
Blue, Alpha, and Gray (for grayscale images) channels. However, if a matte
has only certain channels, the other channels are grayed out.

Checking the option Inverted to invert the area that is masked. Optionally,
right-click the matte in the Project window and select Invert to check the
option.

Each matte is displayed using alpha blending, with customizable transparency
and color for each. Mattes also can be tagged as “Group” with a label, and are
therefore used to design a coherent rigid mobile object. While autotracking,
each object is handled separately, and a group of the specified label is created
with its tracks in it, and is calibrated as a separate moving object.
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Drawing mattes in MatchMover

MatchMover’s Matte Drawing Tool allows you to draw binary mattes to
identify areas. These areas can be excluded from the automatic tracking process,
or used to identify rigid moving objects. Mattes are the result of compositing
one or several contours, which are closed, 2D polygons, defined using control
points and animated over time.

The Matte Drawing Tool allows you to place control points and, therefore,
define contours. For any given frame, once you edit a contour, the frame is
called a “keyframe” and the contours are interpolated in between keyframes.

■ A contour is active at the current frame if it effectively masks an area out.
This is true for all frames between the first keyframe and the last keyframe,
inclusive.

■ A contour is inactive before its first keyframe and after its last keyframe.

You do not need to define a matte for each frame. Defining a matte for some
keyframes is sufficient to exclude the required area from the tracking process.
MatchMover interpolates the matte in the frames between the keyframes.

You can apply several contours to the same image sequence, either at the same
frame or at different frames.

The matte drawing workflow is described as follows:

1 Create and close a contour.

2 Create keyframes and interpolate the contour.

3 Edit the contour, if necessary.

4 Use several contours to mask areas of a sequence.

NOTE Both imported mattes and contours can be used at the same time.

Creating a new contour

When you draw a contour, the last point that was added or edited is the active
point. For an open curve, the active point must be the last point of the curve.
The active point is highlighted red.

To draw a new contour:

1 Do one of the following:

■ Select Contour > New Contour.
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■ Click the New Contour icon  in the Toolbar.

MatchMover enters the Contour Drawing mode, creates a new empty

contour and selects it. The pointer changes to  .

NOTE To exit the Contour Edition Mode, select any other element in the
project (or press Esc).

2 Click in the Workspace where you want to begin drawing the contour.
The newly created control point is added to the curve and it is then
selected as the active point.

3 Click in the Workspace to add a second point to the contour. A new point
is added to the contour and it becomes the active point.

NOTE Pressing Del or Backspace deletes the active point.

4 Continue clicking in the Workspace until you have defined the contour
you want.

5 If you have placed at least three points, do one of the following to close
the contour:

■ Press Enter

■ Double-click the mouse button

■ Hover the pointer over the first point of the contour. The pointer

changes to  . Click the mouse button.

A keyframe is created for the current contour and a new contour is added to
the Contours folder in the Project window.

When you create a new contour, you create a new matte. The new matte is
listed in the Project window as a child of the sequence to which it belongs.

In the Track window, contours are shown as children of the sequence mask.
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The Track window shows for each contour:

■ Keyframes represented by a dark icon with a central black dot

■ Interpolated frames represented by a lighter color

■ Frames where this contour is not in use remain with the background color.

Selecting points and contours

In the Contour Drawing mode in the 2D View, you can select:

■ A contour by clicking on it in the Project window or the 2D View

■ A control point in a selected contour by clicking on it in the 2D View. The

pointer changes to a  nd the point becomes the active point.

When you select a contour in the Contour Drawing mode, it is represented
by a thick outline and control points.
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Other contours in the selected frame are represented by thin outlines and
control points.

If the selected contour is inactive for the current frame, it is represented by a
dashed line.

Inactive contours that are not selected are not displayed.

NOTE While you are working on contours, the resulting matte is not shown in
the 2D View, only the outline is displayed, even if matte display is turned off.

Changing a contour’s properties

The image below shows the contour’s Parameters window.
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■ To rename the contour, change the name of the contour in the Label text
field in the Parameters Window. The matte’s name is updated in the Image
Sequences folder in the Project window.

■ The read-only text field Control points displays the number of vertices or
control points for the contour.

■ Check the option Inverted to exclude the area outside the contour instead
of excluding the one inside.

■ Check the Group attributes to specify a rigid moving object and set its
corresponding sub-folder name.

■ Choose contour displayed color and use the slider to adjust the
transparency.

Deleting a contour

Do one of the following:

1 Select a contour and either:

■ Select Contour > Delete.

■ Right-click in the 2D View and select Delete Contour from the pop-up
menu.

■ Press the Delete key.

2 Right-click the contour in the Image Sequences folder in the Project
window or the Track window and select Delete Contour from the pop-up
menu.

The selected contour is removed.
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About keyframes and interpolating the contour

A keyframe is created for each closed contour. When you change the current
time, the contour shown in the Workspace depends on the content of the
contour at this frame.

■ If this is a keyframe, the contour for this keyframe is displayed.

■ If the contour is interpolated at this frame, the result of the interpolation
is displayed.

■ Otherwise, the curve for the closest keyframe will be displayed.

Editing the curve at the current frame creates a new keyframe at the current
frame and interpolates it between the other keyframe from which it was copied.

Adding a keyframe

To add a keyframe, do one of the following:

■ Select Contour > Add Keyframe.

■ Right-click in the 2D View and select Add Keyframe from the pop-up menu.

MatchMover creates a keyframe for the selected contour at the current frame
using either the interpolated curve, if any, or the displayed curve.

If the new keyframe is between existing keyframes, then the interpolated curve
is used. Otherwise a copy of the contour at the nearest keyframe is used. This
ensures that the domain of definition of a contour is always an interval.

For example, a keyframe is defined at the time t0. When the time is changed
to t1, the former curve is still displayed. When the curve is edited at t1, a new
keyframe is created and interpolation of the curve will be performed between
t0 and t1.
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Deleting a keyframe

To delete a keyframe, do one of the following:

■ Select Contour > Remove Keyframe.

■ Right-click in the 2D View and select Remove Keyframe from the pop-up
menu.

Editing a contour

Once you have created a contour, you can edit it to define the shape of your
required matte.

Adding points to a contour

To add a new point to a contour, double-click anywhere on the selected
contour.

The point is added for all keyframes of the contour.

Moving a point in a contour

To move a point in a contour:

1 Select a point so that it becomes the active point.

2 While holding down the pointer, drag the point to a new position.

Deleting a point from a contour

To delete a point from a contour:

1 Select a point so that it becomes the active point.

2 Do one of the following:

■ Select Contour > Delete Point.

■ Press the Backspace button on the keyboard.

The active point is removed from the contour and the preceding point becomes
the active point. The point is deleted for all keyframes of the contour.

Moving the contour

To translate a contour:
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1 Select a contour. See Selecting points and contours on page 119.

2 Click and drag the pointer anywhere in the 2D View.

The contour and its control points are translated and a keyframe is created at
the current frame.

Rotating the contour

To rotate a contour:

1 Select a contour. See Selecting points and contours on page 119.

2 Press Shift+click. The pointer changes to  . Drag the pointer anywhere
in the 2D View.

This action rotates all the control points defining the current curve by a
constant angle around a given 2D point, determined by the original position
of the pointer at the time of the click, and creates a keyframe at the current
frame.

Scaling the contour

To scale a contour:

1 Select a contour. See Selecting points and contours on page 119.

2 Press Ctrl+Alt+click. The pointer changes to  . Drag the pointer
horizontally in the 2D View.
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The center of the scale is the original position of the pointer at the time of
the click. The scale factor increases toward the right, decreases towards the
left.

Copying and pasting a contour

You can copy and paste a contour at one keyframe only using the Copy and
Paste commands.

To make a copy and paste a keyframe of a contour:

1 Do one of the following:

■ Select a contour to duplicate and select Contour > Copy.

■ Right-click in the 2D View and select Copy Contour from the pop-up
menu.

■ Right-click the contour in the Image Sequences folder in the Project
window or the Track window and select Copy Contour from the
pop-up menu.

MatchMover creates a copy of the contour at the current keyframe and
stores it into a buffer.

NOTE Only one curve can be copied that way; if there is already a curve in
the buffer, it is overwritten.

2 Select the contour and the frame where you will paste the contour frame
as a new keyframe.

3 Select Contour > Paste.

Duplicating a contour

To duplicate all keyframes of a selected contour.

Select a contour then do one of the following:

■ Select Contour > Duplicate.
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■ Right-click in the 2D View and select Duplicate Contour from the pop-up
menu.

MatchMover creates an exact copy of the current contour featuring all
keyframes. The contour is interpolated between this new keyframe and the
existing ones.

Cropping an image sequence
To crop an image:

1 Select the image sequence from the Image Sequences folder in the Project
window or the Track window.

2 To crop the entire image proportionally, pull a corner handle inward.

If you want to crop only one side, pull a side handle inward.

As an alternative, you can crop the image by editing the sequence’s Parameters
Window window:

1 Click a selected sequence in the Image Sequences folder in the Project
window or the Track window.

2 In the Parameters Window, enter the pixel sizes of the border(s) to crop.

Validate by pressing the Tab key to jump to the next field or pressing the
Enter key.
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2D tracking

Automatic 2D tracking

Running the automatic 2D tracking

To run the automatic tracking:

1 Do one of the following:

■ Select 2D Tracking > Automatic Tracking.

■ Click the Run the Automatic Tracking icon  in the Toolbar.

■ Press F10.

A window appears, listing the steps in the automatic matchmoving
process.

■ If checked, Clear Soft Tracks clears previously generated soft tracks,
which are indicated by a single cross in the tree view.

■ The next step, 2D Tracking, extracts relevant information from images
within the video sequence as you would do manually. See Supervised
2D tracking on page 132. All tracks generated during this step are
flagged “automatic.”

■ In Camera Solving, the movement of the camera in 3D space and its
(the camera’s) settings are calculated. For more details. See Solving
for the camera on page 185.
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2 The Settings button allows you to configure the automatic tracking
engine:

■ From the Track Using drop-down list, choose either Grayscale to track
the feature’s luminance (it's the faster way, and should fit most cases),
or Colors to take care of each color channel independently.

■ Enter the Minimum Track Length. Tracks that do not last at least this
number of frames will be discarded.

■ Use the sliders to set the Features Sensitivity (how sensitive is the
feature detector) and the Features Density (to allow more or less points
in an area).

■ Set a minimum and maximum Displacement Range, expressed as a
percentage of the largest dimension of the image. You can also enter
this data in pixel unit.

TIP Use the Colors option when your sequence contains motion blur or
low-contrast images or sequences.

3 Now click Run to begin the matchmoving process. Colored indicators
beside the option name show you the status of the process as well as the
status of each step.
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■ A gray button indicates a task that has not been started yet.

■ A yellow button indicates a task in progress.

■ A green button indicates a completed task.

Viewing the results

Upon completion of the automatic tracking process, you will have a list of
the automatically generated point tracks, marked with a circle in the Point
Tracks / Auto Tracks folder (and optionally, moving rigid object sub-folders,
if any) in the Project window and Track window. Tracks are only generated
in areas of the image that are not masked or cropped out. Each track is
automatically named “Auto####,” where “####” represents the track number.

NOTE All automatically generated tracks will be flagged as soft tracks.

Differences with supervised tracking

Running the automatic tracking is an easy and robust way to track many
points simultaneously. The process can be launched whenever needed, on the
entire sequence or on a selected time range, on the entire image, or on selected
areas only using masks. The automatic process is different from supervised
tracking in the sense that as many tracks are handled at the same time, 3D
coherency is used while tracking.

Also, when supervised tracks are present before launching the automatic
process, they are used in the 3D coherency checking.

The results are different from the kind of tracks you will have when using the
supervised tracking, as in this case, each track is handled individually.
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As automatic tracking may lead to huge number of tracks, a soft track is not
guaranteed to be used in the solving process. An algorithm that automatically
selects the best soft tracks to fit the computation in memory is launched before
the solving. To convert a soft track into a hard track, simply check the hard
track check-box in the track parameters window or pop-up menu. This way
you’re sure it will always be fed into the engine.

Apart from this difference, the same tools handle automatic and supervised
tracks.

Refining tracking results
If you are satisfied with the results of the automatic tracking process, you can
export your project at this point. Otherwise, you may want to edit the 2D
tracks.

You can do so by:

■ Adding tracks. SeeCreating a new track on page 132.

■ Deleting unnecessary or unwanted tracks. See Deleting tracks on page 135.

■ Cleaning up the 2D tracks. See Cleaning up tracks on page 130.

■ Defining point relations. SeeMotion control on page 68.

If you are an expert user, adding track points serves to work around a weakness
of the automatic tracker or to add a point necessary for defining a coordinate
system which the automatic tracker would not have considered. See Defining
coordinate systems on page 167.

Cleaning up tracks

You can run the Cleanup Assistant to let MatchMover automatically remove
points, based on the parameters you set. This option’s main purpose is to
reduce the number of tracks, while keeping relevant tracking information, so
that manual edition becomes easier.

NOTE As a recommendation, however, do the automatic clean-up only if you are
unhappy with the result after running the solver once. It is best to first run the
solver with all the tracks.

1 Do one of the following:

■ Select 3D Tracking > Clean Assistant.
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■ Click the Clean up tracks  icon in the Toolbar.

■ Press F11.

The Cleanup window opens.

2 Specify the settings.

■ Keep ... tracks per frame targets an average number of tracks in each
frame after the clean up. The default value is 30 frames.

■ Keep tracks that last at least ... frames deletes all tracks lasting less
than the desired number of frames. The default value is 10 frames.

■ Residual cleanup deletes all tracks with a residual value above a
threshold you set.

This can only be done after the solver has finished running.

3 If you do not want to delete manually added tracks, select the option to
Always keep hard tracks.

For example, if a track satisfies at least one condition, it will be kept. For
instance if you set the length > 10 and residual < 0.8, then a track lasting six
frames with residual 0.4 will be kept because of the second filter.
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TIP The Automatic Cleanup option of the previous version of MatchMover is
roughly equivalent to keeping 40 tracks per frame.

Supervised 2D tracking
MatchMover allows manual editing of track points. In addition, advanced
users may prefer to manually add tracks before running the automatic tracking
process to strengthen the result, or after, to refine the result.

Creating a new track

To create a new track.

1 Do one of the following:

■ Select 2D Tracking > New Track.

■ Click the New Track icon  in the Toolbar.

■ Right-click in the 2D View or in the Point Tracks folder in the Project
window or the Track window and select New Track from the pop-up
menu.

MatchMover creates an item in the Point Tracks sub folder in the Project

window and the pointer changes to  in the Workspace. Whenever
the pointer has this appearance, you are in the New Track Creation mode.

2 Position the pointer where you want to create a key for this track and
click.

See Magnifier window on page 96 for the Magnifier configuration.

NOTE You can simply create tracks in the same way in the 2D or 3D mode using
Shift+right-click the background image plane. If you select a track group in the
Project window, new tracks will be added automatically to the group. See Creating
groups on page 153 for more information about track groups.

When you add a track, the following icons appear in the Project window
indicating the track status.
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The left part of the icon shows its calibration status:

■  An empty circle indicates a track not used for 3D solving.

■

■ A single cross indicates a soft track (the engine will decide to use it or not).

■  A cross in circle indicates a hard track (always fed into the engine).

■  An xyz indicates a survey points (a track with known 3D coordinates).

The right part of the icon shows its 3D reconstruction status:

■  An empty circle indicates a track that should not be reconstructed.

■  A gray circle indicates a track that can be reconstructed by the engine.

■  A green/yellow/red circle indicates a good/medium/bad
reconstructed point.

In the Parameters Window, or if you right-click any point in the Point Tracks
folder in the Project window or the Track window, the following options are
checked by default in the pop-up menu and correspond to the icons above
table.

■ Use for 3D Solving, indicating that the point is to be used in the solving
process.

■ Reconstructed in 3D, indicating that the point will be reconstructed in
3D.

■ You can access the detailed 3D information of a track in the 3D tab of its
Parameters Window.

Supervised 2D tracking | 133



The window shows read-only fields:

■ The point coordinates, X, Y, and Z, calculated by the camera solving
process.

■ The Residual at time, which is the difference in pixels between the 2D
point position and the position obtained by viewing the reconstructed 3D
point through the calculated camera at the current time.

■ The Average Residual, which shows the average difference in pixels for all
the frames.

For example, you want to track a table corner through an image sequence. In
image 0, press Shift+right-click the table corner. MatchMover creates the “Track
0” and an intermediate key. The tracker uses this key point to remain on the
point track during the tracking process. Now, you can launch the tracker.

The Relations tab just shows the list of relations involving this track.
Double-click one to select it.

NOTE For 2D configuration, see Setting the parameters of a single key point on
page 142 and Color Tracking on page 144. For 3D survey configuration, see Defining
survey points and object mapping on page 175.

Selecting tracks

Click a track (either the cross, the pattern, the point or the 3D helper
depending on your current view and settings) to select it.

To select several points, do any of the following:

■ In the Workspace, hold the Shift key and click the points in the image one
by one.

■ In the Workspace, click the image and drag the pointer to contain certain
points in a selection Rectangle or click several points to define a polygon
Contour (2D mode only) then release the mouse button. The selection
mode is specified in the Track Selection Display drop-down list in the
Preferences > Display window. All tracks with points inside the rectangle
or contour are selected.
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■ To add to the selection, press the Shift key. To deselect the points, click
any empty area in the image or press Esc.

■ For a sequential selection, in the folder Point Tracks in the Project window,
click the first point, press and hold the Shift key, and click the last point
drag the rubber rectangle to select points.

■ For a non-sequential selection, in the folder Point Tracks in the Project
window, hold the Ctrl key and click the points one by one.

NOTE The currently selected track or a track multiselection can be inverted by
right-clicking in the Project Window and selecting Invert Selection from the
pop-up menu.

Deleting tracks

To delete tracks, do one of the following:

■ Select the track(s) that you want to delete.

■ Select Edit > Delete.

■ Press the Delete key.

■ Right-click the track(s) in the Project window or the Track window and
select Delete Track.

Merging tracks

When 2D features of the scene move out of the view then back in or are
occulted by objects in motion causing the tracker to misinterpret them as
distinct points, you can merge the keys from several tracks into one.

1 Select at least two track points to merge.
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2 Do one of the following:

■ Select 2D Tracking > Merge Tracks.

■ Right-click in the 2D View or the Point Tracks folder in the Project
window or the Track window and select Merge Tracks from the pop-up
menu.

MatchMover checks whether the selected tracks have keys in common (at the
same frame) or not. If not, all keys and computed points are copied to the
first tracks, and the other tracks are deleted.

NOTE You can configure MatchMover to merge tracks automatically during the
solving by selecting Edit > Preferences and checking the Automatically Merge
Tracks option in the 3D Tracking page.

About the Tracking Tool
Tracking Tool in the 2D View surrounds any track key point.

The Tracking Tool is composed of two rectangles, an inner rectangle containing
the Pattern Zone and an outer one containing the Search Zone.

A track is identified through the pixels around it. All pixels in the Pattern
Zone are considered for this identification. During the tracking process,
MatchMover looks for that pattern anywhere in the Search Zone in the next
frame.

NOTE To change the colors of the Pattern Zone and the Search Zone, select
Edit > Preferences, click the Color tab in the User Preferences window, and
change the color of the corresponding sample box.

By default the size of these zones is determined by the Default Search Size
and Default Pattern Size settings in the 2D Tracking page of the User
Preferences window that applies to all new keys created. See Configuring the
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tracker on page 144. You can set independent values for each new key with
the following procedure:

■ Click a corner to uniformly scale the rectangle. The pointer changes to a
double-headed arrow.

■ Click the center of an edge to size the selected edge only. The pointer
changes to a double-headed arrow.

To change the size of the Tracking Tool for a selected point, enter the values
in the Pattern Zone and Search Zone fields in the Parameters Window. When
adding a key to an existing track, they Pattern Zone and Search Zone sizes
will be copied from the closest existing key of this track.

TIP To set the size of the Tracking Tool for all tracked points, see Configuring
the tracker on page 144.

About key points
Key points are the basic elements of the 2D tracking. Key points can be inserted
in any image and anywhere within the image. For each track point the
following information is shown in the Track window. See The Track View on
page 88.

■ The point type

■ The track quality

■ The tracking direction.

If a point is computed, the shape indicates that MatchMover has generated
the point. Computed points appear red if bidirectional tracking is only partially
completed. There are five key types and each key type has a different symbol.

Type of PointShape

Automatic - Defines a key point added
automatically by the tracker when the qual-
ity falls below a defined threshold (if the
Automatic Key Insertion option is selected
in the Preferences).
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Start - defines the start of a track segment.

End - Defines the end of a track segment.

Intermediate - Default key type when you
create a new track. Use this type of key to
constrain the tracker so that it passes
through important positions.

Single - Defines a key point that you created
manually. The data from this key point is
ignored by the 2D tracking but used in the
3D tracking process. Use this type of key to
correct the results of the 2D tracker at isol-
ated frames without affecting the rest of the
tracker, for example, if a track is obscured
in a scene but it’s position is known.

In a 2D View, editing an auto-tracked point automatically turns it into a key
point. When you create a key point, it has by default an intermediate key
point type. You can create begin, end, intermediate, and single key points. If
you edit an intermediate key, computation for the track will be lost if the
“Auto Clean” option is set and tracking must be re-run. You can have several
tracked segments for one track.

Editing a key point type

To edit a key point type, do one of the following:

■ Select 2D Tracking > Set Key.

■ Right-click in the 2D View, the Point Tracks folder in the Project window
or the Track window to show the pop-up menu and select Set Key.

Choose the desired key type from Begin, Intermediate, End and Single. See
About key points on page 137 for more details on key types.
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Notice that the key symbol changes (in the Track window), to show the new
status of the key.

Inserting a new key point in a track

Select a track. Click and hold in the 2D View where you want to place the new
key. By default MatchMover zooms in on the area using a pop-up magnifier.

NOTE You can replace the pop-up magnifier with the Magnifier Window to help
you in placing a key point, see Magnifier window on page 96.

MatchMover places the key. The center of the key point is marked with a cross
that is surrounded by two boxes. This is the Tracking Tool. See About the
Tracking Tool on page 136. The key type symbol and its label are also displayed.

TIP Repeat the procedure for other tracks in the same frame or for other keys for
the same track in different frames. If you want to place other key points for the
same track, you can use the Auto Key Match function.

In editing keys while a 2D View is in focus, you can use the arrow keys to
move the current key. You set the number of pixels for each hit in the Nudge
step box in Edit > Preferences > 2D Tracking. The value can be less than one
pixel. See Configuring the tracker on page 144.

If the edited point was not a key, it is automatically turned into one.

TIP Pressing shift with an arrow key will multiply the nudge step by 10.

Moving a key point

1 Select the key point you want to move. The pointer changes to  .

2 Drag the pointer to the new position and release.

NOTE If Auto Clean is enabled, this action deletes the 2D computed points
that have been created from this key. To recompute these points, you have
to rerun the tracking process. To enable or disable Auto Clean, select Edit >
Preferences > 2D Tracking and click the corresponding box.

Deleting a key

1 Select a track then a frame if none is selected.
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2 Do one of the following:

■ Select 2D Tracking > Clear Keys.

■ Right-click in the 2D View or the Point Tracks folder in the Project
window or the Track window to show the pop-up menu and select
Clear Keys.

If you have not created a time range, MatchMover deletes the key at the current
time. If you have created a time range, MatchMover deletes all keys within
the time range.

Using the Auto Match Key

The Auto Match Key uses the pattern around the position of the previous key
and attempts to find a similar pattern at the current frame. If you do not use
the Auto Match Key option, you have to be careful to place a key point exactly
in the position so that it matches the position of the previous key in the same
track. The area to search is defined by the value in pixels in the First Pass field.
The default value is generally sufficient.

For example, place a key point in frame 1. Then move to frame 5 where you
place another key point. In Auto Match Key mode, clicking near to the original
key point is sufficient for MatchMover to place the new key in the right
position.

To toggle the Auto Match Key option for the current key point, press
Shift+click.

If you want to enable the Auto Match Key permanently:

1 Select Edit > Preferences and open the 2D/Auto Tracking page.
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2 Check the Auto Match Key check box.

MatchMover now uses this function when you place a key.

Key point placing strategy
When you have examined your sequence you can now concentrate on the
strategy of placing your key points to achieve the best results. It is important
to understand the difference between the different keys and the effect they
have on the tracking process before you begin placing them.

When selecting tracked points, you should choose points that:

■ Represent physical 3D points (avoid highlights or the meeting point of a
foreground and a background object. See Troubleshooting the
solvertroubleshooting:automatic 2D tracking on page 190.

■ Can be accurately localized (avoid points in uniform image areas, points
located on linear edges that can “slide” along the edge are not good
candidates).

■ Follow the same 3D rigid motion. Do not track points in a static background
and on a moving object in the foreground in the same track group.

All of the 3D calculation depends on the correct choice when placing points.

TIP Before creating your key points within the image sequence, review the
sequence and plan the key point positioning. This aids the tracker calculations and
saves you time and effort in the later stages.

Scatter - Place the key points over the widest possible area trying to cover the
3D volume. Concentrate on areas where you want to put a 3D object.

Balance - As you move through the sequence some points may leave the frame
and other points may enter the frame. Therefore try to keep a balance of the
number of points within each frame and avoid a lot of points leaving or
entering at the same time.

Depth - Place key points in the background and the foreground of your
sequence to enable depth calculations.

Examples

Image masking - You want to track a point from image 1 to image 20. You
know that in images 12 to 15 there is a partial masking of the point.
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You place a Begin key in image 1 and an end key in image 20. For the images
12 to 15, you may be able to place single keys. The tracker ignores these keys
and this part of the sequence. Therefore the tracker tracks from image 1 to
image 12 then ‘jumps’ to image 16. However, the 3D tracker uses the single
key points in the same way as other points.

Intermediate keys - You want to track a point from image 1 to 20. However,
the point in image 1 and in image 20 is very blurred so you cannot place a
begin key or end key. In image 10 the point is clear so you place an
Intermediate key and launch a forward track to image 20 and a backward track
to image 1. By doing this you succeed in tracking the point throughout the
entire sequence despite the blur.

Variable Zoom - If you track a feature with an image size that changes
drastically (large motion or zoom), it is better to place a key in a frame where
the resolution is high and start tracking from this key towards frames where
the feature appears smaller.

Setting key point parameters
By default each key point has a pattern size, search zone and quality threshold,
as defined in 2D Tracking page of the User Preferences window. See
Configuring the tracker on page 144.

These parameters are global and apply to all key points, however it is possible
to set the parameters for each key point separately. In most cases the default
values are sufficient to complete a successful track, but you may want to set
them.

Setting the parameters of a single key point

To set the parameters of a single key point:

1 Select the point to edit.

2 In the Parameters Window, the Current time text field shows the current
time.

Refer to the following list for parameters details:

■ The horizontal point position X in pixels in the image (if the point
is a key, you can modify its position. The origin is the upper left corner
of the image).

■ The vertical point position Y in pixels in the image.
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■ Status shows the type of key. Select a new key type from Begin, End,
Intermediate, and Single from the drop-down list.

■ Threshold is the minimum accuracy of the similarity between two
pixels. A value too low causes the tracker to match any pixels. A value
too high causes the tracker to stop or to place too many automatic
keys.

■ Pattern Zone is the area to search for in the adjacent image. You can
use different values for the different sides. For example, if you track
a point within an area of uniform color, the tracker may have problems
to follow the point. Increase the template area to include pixels of a
different brightness to eliminate this problem.

■ Search Zone is the area in which to search, in the adjacent image.
You can use different values for the different sides. If you see that the
point moves a lot through the sequence, make the search area larger,
remembering that a larger search size decreases the tracking speed.

The tracker uses these parameters to find the corresponding point in the
adjacent image and track the point and the information is updated if you
change the current time.

NOTE If the selected point is not a key point, but has been calculated by the
tracking process, then you can only read the track point information in the 2D
page.

■ Parameters at time shows the current time.

■ X shows the horizontal pixel position of the point in the image. The origin
is the upper left corner of the image.

■ Y shows the vertical pixel position of the point in the image. The origin
is the upper left corner of the image.

■ Tracking Score shows the estimated precision quality of the tracking.

■ Status shows the type of tracking used to calculate this point. The status
can be Forward, Backward or Bidirectional.
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Color Tracking

All key points have a separate color tracking setting. For example, a red cross
on green background may ignore blue channel.

■ Gray. Track using luminance information (an average of the R,G,B colors).
This is the default option.

■ Color. Track using all color components independently.

■ Coeff. Track using a coefficient for each color channel. For example, when
a color seems to be too “noisy”, just lower its coefficient. If the coefficient
is 0, then the color is ignored.

■ Auto. Track using a coefficient for each color channel, but coefficient is
computed automatically. MatchMover analyzes the image to find the best
coefficient.

Configuring the tracker
Before launching the tracker you can configure the parameters to aid the
tracking process. When you have a sequence with particular characteristics,
such as zoom or rapid movement causing blur, you set the tracker’s parameters
to aid the tracking process.

Select Edit > Preferences and select the 2D/Auto Tracking page.
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Choose the desired options. By default the options Gray Levels, Smart
Prediction and Automatic Key Insertion are selected. These options apply to
all key points.

■ Track using - Use Color where the contrast between two colors is low. For
high-contrast colors, use Gray Levels. The Gray Levels option is faster, but
less accurate than the Color option. See Color Tracking on page 144.

■ Auto Match Key - Toggles the use of automatic key placing. This decreases
the possibility of error by placing the key using the position of the
neighboring key.

■ Auto Clean - toggles the automatic removal of all tracked points when
editing the originator key. It is enabled by default.

■ Smart Prediction - predicts the position of a point in the successive
image and reduces the tracking time by a factor of 10. Smart Prediction
works in smooth sequences so if you have a “shaky” camera sequence
toggle the Smart Prediction option to off. If there is a smooth camera
movement, use the option.

■ Nudge step - sets the number of pixels for each arrow-key press when
editing keys. The value can be less than one pixel.

■ Automatic Key Insertion - places automatic keys when the quality falls
below a certain threshold caused by factors such as camera zoom (the
pattern followed by the tracker changes size and resembles less and less
the original pattern, causing the quality to decrease).

■ If you do not use Automatic Key Insertion under these circumstances the
tracker halts. You may notice that in some situations the position of an
automatic key deviates from the point to track, if this is the case toggle
Automatic Key Insertion to off.

TIP You want to track a point from image 20 to image 40. If you know that
within this sequence there is a zoom, use Automatic key insertion. By using
the Automatic key insertion option the tracker is able to follow the point,
despite the zoom.

The other options in the User Preferences window refer to the default settings
of the key points. Any changes made here affect all new key points. The settings
for current key points do not change.
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To change values for a single key point, use the Parameters Window. See
Setting the parameters of a single key point on page 142.

■ Default Pattern Size defines the area to search for in the adjacent image.
The default value of 14 means that the Pattern Size is 7 pixels to the left
of the point and 7 pixels to the right.

■ Default Search Size

■ Bootstrap - Defines the search area in pixels used by all the key points
when Smart Prediction is not used. Increase this value if you find that
the pixel motion of the point you are tracking moves substantially. If
Smart Prediction is used the Bootstrap value is used up to the point
where the prediction process starts.

■ First Pass - Defines the search area in pixels when Smart Prediction is
selected. The tracker starts with the Bootstrap value then changes to
the First Pass value when the Smart Prediction process starts. When
the sequence is not as smooth as you would like and you still want to
use Smart Prediction, increase the First Pass value.

■ Second Pass - Defines the search area in pixels and is only used in a
bi-directional tracking. If you have already tracked in one direction,
the tracker uses this value for the opposite direction track. The tracker
uses the results from the direction already tracked and therefore the
search is more localized, the search area is smaller and the tracking
process is faster.

■ Sub-pixel Accuracy - Defines the search precision. For example, a value of
8 means the maximum search distance of the pixel match is 1/8th of a
pixel. The tracking process is slightly longer when there is a high accuracy
value.

■ Quality Thresholds - Stop defines the minimum quality value. There are
two possible situations. If Automatic key insertion is not selected and the
quality falls below this value, the tracker stops. If Automatic key insertion
is selected and the quality falls below this value an automatic key is
inserted.
For display purposes the Poor and Good values determine the on-screen
appearance of the points in the Track window. They have no effect on the
tracking process itself.

A quality value between the Stop and Poor values is shown as red. A quality
value between the Poor and Good values is shown as yellow. A quality
value above the Good value is shown as green.
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Running the tracker
By default when you run the tracker the whole of your sequence is tracked
(as defined by the key types). If you want to track points for a subset of your
sequence you must create a time range.

You can run the tracker in three ways:

■ A forward track

■ A backward track

■ A bi-directional track

The tracker stops when:

■ It reaches the beginning or end of the sequence or time range.

■ The match falls below the quality set in the tracking parameters box.

■ It reaches a Begin or End key point.

■ The point is about to leave the image.

To check the quality of the tracking you can zoom on the image to view the
pixels. Do one of the following then zoom on the track:

■ Select View > Lock On Track.

■ Right-click in the 2D View and select Lock On Track from the pop-up menu.

■ Click the Lock On Track icon  in the Workspace.

About the tracking monitor

When you run the 2D tracking process, the Track Monitor appears in a toolbox
window. It shows a zoomed view of the point being tracked through the
sequence.

Running the tracker forward or backward

You can launch the tracking process in a forward or backward direction. Only
one key point is necessary to track either forward or backward, but it must be
either a begin key or an intermediate key. Only one point can be tracked at a
time. When more than one track is selected, the tracking function is disabled.
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To run the tracker forward or backward, either:

■ Select 2D Tracking > Track Forward or Track Backward.

■ Right-click a track in the 2D View, the Point Tracks folder in the Project
window or the Track Window to open the pop-up menu and select Track
Forward or Track Backward.

■ Click the Run/Stop Track Forward  icon or Run/Stop Track Backward

 icon in the Toolbar.

MatchMover launches the 2D tracker. Notice that by default the Tracking
Monitor opens showing the point being tracked through the image sequence.
A colored line in the Track View shows the track as it is tracked.

TIP To obtain the best results, when you have placed two key points in a sequence,
use the option Bidirectional.

Running the tracker in bidirectional mode

This option launches the tracking process in a forward and backward direction.
There must be at least two key points enclosing the segment or sequence to
track. Use this option when there is some deviation of the point through the
track sequence.

By blending the two trajections produced by forward and backward tracking,
MatchMover guarantees that the final point track has a smooth trajectory that
passes exactly through the two enclosing key points.

To run the tracker bidirectional, do one of the following:

■ Select 2D Tracking > Track Bidirectional.

■ Right-click a track in the 2D View, the Point Tracks folder in the Project
window or the Track Window to open the pop-up menu and select Track
Bidirectional.

■ Click the Run/Stop Track Bidirectional  in the Toolbar.icon

MatchMover launches the 2D tracker.

148 | Chapter 4   User Guide



Computed 2D points
The tracker automatically creates and places computed 2D points, using
information from the key points, in the sequence, that are used in the camera
solving process. The type of computed point generated depends on the type
of tracking process that you run to create them.

There are three types of computed 2D points shown by the following symbols
that appear in the Track window.

Type of PointShape

Forward computed point

Backward computed point

Bi-directional computed point

Clearing computed points

1 Select a track(s) and then a frame(s) range.

2 Do one of the following:

■ Select 2D Tracking > Clear Tracked Points.

■ Right-click 2D View, the Point Tracks folder in the Project window or
the Track window to show the pop-up menu and select Clear Tracked
Points.

■ Press the Backspace key.

If you have not created a time range, MatchMover deletes the point at the
current time. If you have created a time range, MatchMover deletes all points
within the range.

Locking tracks

Locking a track protects a track against modification or deletion. For example,
a locked point will not be removed from the project when you cleanup the
tracks.
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To lock a track:

1 Select a track(s).

2 Enable Locked. In the Project window and Track window, you will also
notice that the track point is now represented with a lock.

A Locked  icon appears beside the corresponding point track in the Project
window and the Track window indicating that the point track is locked.
Alternatively, simply right-click a track point in the 2D View or in the Point
Tracks folder in the Project window or the Track window and in the pop-up
menu, select Locked.

Track color display

Each track is displayed with a specific configurable color, either in 2D or 3D
Mode. If the track color is the default one (black), it’s displayed as such.

■ 2D Mode: Label is black, pattern uses the 2D point color (from user
preferences)

■ 3D Mode: Label and 2D point uses the 2D point color. 3D helpers use the
3D point color.

If a custom color is set, then this color will be used for the 2D label, the 2D
track and the corresponding 3D helper (3D reconstruction).

Checking tracks

Skipping untracked frames

MatchMover allows you to navigate through the tracked frames only. For
example, you may want to fine-tune the frames in a track.

By selecting View > Skip Untracked,  any navigation command (except
direct mouse click or a user input) skips the frames where the selected track
is not defined. The icon appears next to the Lock on Track icon.

Skipping unsolved tracks

If you are working only on a part of your sequence, for example, you loaded
a 100 frames sequence, but the frames 30 to 60 are not important, you can
set those frames to Do not solve and select View > Skip Unsolved to activate
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the option. After calibration, any navigation command (except direct mouse
click or user input) skips the frames that are not solved. See Setting frames to
solve on page 185.

The Magnifier’s fast refresh

When the Magnifier window is locked by clicking on the padlock to the right
of the zoom bar, you can click a track and play the sequence to check the
track’s path. See Magnifier window on page 96.

Note that in this case, and if the format allowed it, only the Magnifier displayed
area is loaded for a faster refresh.

Troubleshooting the tracker
If the tracker fails, it is often because the aspect of the tracked pattern has
changed significantly between the reference frame (the track start frame) and
the current frame.

If the solver has already been launched, you can verify the distance in pixels
between a 2D point and the projection of a 3D point on the camera in the 2D
View or in the Survey View. You can examine the residuals for all the points
and frames. Sort them by frame and check if any points have a high residual
value. See Examining the computation quality in the Survey Window on page
189.

If so, it is probably because the point has been poorly located by the 2D tracker.
If a frame has a high error, viewed in the Frame mode, this may be due to the
bad positioning of a 2D computed point within the frame.

By examining the errors on the points in the Points mode, it is possible to
find the computed 2D point responsible for the high error. It is then useful
to restart the tracker from an intermediate frame (insert an intermediate key),
where the tracked position is correct, and the aspect is more similar to the
current frame.

You can also check the track path for bumps. If the track path is jagged, it
means that either the camera follows a jerky motion, or that the point suddenly
drifted during tracking. In this case, you should return at the time the track
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jumped, and correct it by creating a new key at the appropriate coordinates
and resuming tracking.

Another potential cause for the tracker to stop is when the point image motion
is so fast that the search area of the tracker becomes smaller than the point
displacement between two consecutive frames.

If this is the case enlarge the search area and re-run the tracker from the last
correct frame, then reduce the search area to a normal size.

When a point that is being tracked starts to leave the image, MatchMover
shows a warning message and the 2D tracker stops. When the quality of the
tracking falls below the defined threshold a warning message appears and the
tracking stops.

TIP Do not forget that in Smart Prediction mode, the search area defined with
the tracker tool is only used in the first and the second frames, then the size used
is the one defined by First Pass in the 2D Tracking page of the User Preferences
window.

Groups attributes
To make complex supervised tracking a little easier, related tracks can be
grouped together. The group hierarchy will be exported and should be the
same in the final 3D package.

Each group has the same set of attributes as a track. The group has a label,
which is the name of the item displayed in the Project window. All other
attributes reflect the tracks stored in this group.

■ An unchecked option means that none of the tracks have this attribute.

■ A checked option means that all of the tracks have this attribute.

■ A dimmed option means that all of the tracks do not share the same value
for this attribute.

By simply setting a group attribute, you apply the attribute to all the tracks
in the group.

Each group also has the “mobile” rigid object attributes. See Moving objects
on page 154.

In addition, the group Parameters window shows the statistics of all its tracks:
number of tracks, shortest, longest and average length. This is a good measure
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of the quality of an automatic process that generated a huge number of tracks.
A good average length is usually synonymous of robust tracking.

Creating groups

You can create track groups by either:

■ Right-clicking in the Point Tracks folder in the Project window and selecting
New Group from the pop-up menu.

■ Selecting 2D Tracking > New Group.

Managing groups

There are several ways to put tracks in a group.

■ Right-click a group and select New Track from the pop-up menu to create
a track directly in this group.

■ Select tracks in the Project window, and then right-click and select Send
to Group. You can then send them in an existing group or in a new group.

■ Drag and drop a track selection in the Project window into a group.

To delete a group (and of course, all its tracks), either press Del, or select Edit
> Delete, or right-click and select Delete from the pop-up menu.
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NOTE The track folder is the default group, and behaves exactly like additional
groups, except that it’s never a mobile object.

Moving objects

Groups can be used to identify rigid moving objects. If the group has been
created by the automatic process, which means that we have a matte with the
group attribute sets, then it is automatically filled up with its corresponding
tracks, and the mobile attributes is set.

You can manually create as many mobile groups as needed and fill them with
corresponding tracks. For a mobile object to be calibrated, it must have enough
tracks (as for the main camera. See Camera solving on page 154.

When running the camera solving process, the background static tracks (all
the ones that are not in a “mobile” group) will first be used to compute the
main camera path, then all mobile groups will be processed and merged in
the final scene, creating mobile points.

As it is not possible to recover the scale between a mobile object and the
background with a single camera, each group has a scale attribute that can be
tuned directly in the group parameter’s corresponding edit box or by using
the slider.

Camera solving

Keyframes
Keyframes are specific frames for which the system first computes the camera
parameters and 3D points using a powerful optimization process. Once
keyframes and 3D points are computed, the system computes the intermediate
frames by first interpolating between the keyframes, as in a standard animation
package, then refining the camera parameters using the estimated 3D point
information.
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MatchMover chooses automatically the keyframes to compute using the
following criteria:

■ If the focal length is known, at least four 3D points are needed.

■ If the focal length is unknown, at least six 3D points are needed. These
points should not all lie on the same plane.

In most situations the keyframes chosen by MatchMover are sufficient, however
in some cases (e.g. where there is jagged camera motion), it can be useful to
position the keyframes manually.

By default, keyframes, and indeed reference frames are chosen automatically.
The number of keyframes is determined by the keyframe Step value and
Maximum keyframes value. The keyframe Step value is the maximum number
of frames between each keyframe. A low step value gives a higher accuracy,
but computation is slower. See Reference frames on page 155.

The Maximum keyframes value determines the highest number of
non-automatic keyframes allowed in a sequence. This value is only an
indication, as the number of keyframes generated may be larger, especially in
shots where a large number of points enter or leave the image.

TIP Use enough keyframes to “cover” all the tracks, but bear in mind that too
many keyframes slow the solving process. If there is a very smooth camera
movement, very few keyframes are needed. keyframes should cover the movement
in a sequence.

Reference frames
Reference frames are 2 specific keyframes that will be used to bootstrap the
camera solving. They should therefore be rock-solid ones with good parallax.
MatchMover chooses the reference frames automatically when you run the
3D tracker.

The data from 2D tracking is used to choose them, therefore if you change
the data (e.g., you create a new point track), MatchMover may automatically
choose two new reference frames.

MatchMover examines the image sequence and compares frames using two
methods.
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Method 1. Where all the intrinsic parameters are known (through camera
information and constraints), it checks that there are either:

■ At least four 3D points with known coordinates are common to two frames.

■ At least seven points (of potentially unknown coordinates) are common
to two frames.

Method 2. Where all the parameters are unknown (except nonlinear distortion,
which must have an approximately value), it checks that there are at least six
known 3D points between two frames.

Ideally, they should include views of the same scene from a different position,
which induces parallax between the images.

The automatically generated reference frames, if not locked, are recomputed
when you select 3DTracking > Solve for Camera (F9) or when you use 3D
tracking > Select keyframes.

They are locked either when the user edited them, or when the lock icon at
the right end of the Track View Graded Ruler graduation window is toggled.

When locked, all the keys and references frames are grayed,  otherwise

they are highlighted in yellow,  .

NOTE If MatchMover cannot initialize the two reference frames, it warns you
that there is not sufficient data to run the camera tracker. In this case, you have
to provide added information by creating extra point tracks in the two frames or
by defining 3D point coordinates using relations, where possible.

Changing the keyframe default settings

To change the keyframe default settings

1 Select Edit > Preferences and open the 3D Tracking page.
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2 Enter the keyframe Step value. A step of approximately 15-20 keyframes
is generally a good trade-off between computation speed and accuracy.

3 Enter the Maximum keyframes. This value allows you to limit the
calculation time regardless of the sequence size.

See Keyframes on page 67.

Selecting reference and keyframes
After the 2D tracking process is complete, do one of the following:

■ Select 3D Tracking > Select keyframes.

■ Right-click the Image Sequences folder in the Project window or in the
Track window and select Select keyframes from the pop-up menu.

Note that if the keyframes are not locked this step is automatically launched
when running the solver. See Reference frames on page 155.

Once all the required keyframes are selected, user settings are applied to fill
the gaps, with the non-automatic keyframes.

At this point you can run the camera solving process using the reference and
keyframes chosen by MatchMover, or you can choose your own by manually
editing them.
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If you make any manual changes and want to return to automatic initialization,

just click the lock icon  or relaunch the Select keyframes command.
Manual initialization is designed for an advanced user.

Under most circumstances the automatic initialization option is sufficient as
MatchMover suggests optimum reference and keyframes. If you are not satisfied
with the suggestion, you can edit the results.

Editing reference and keyframes

In complex sequences involving lots of camera movement, you may decide
to choose your own reference frames and keyframes. If so, you must use the
manual initialization option before you change the reference or the keyframes.

Method 1

1 Select the Image Sequence folder in the Project window.

2 In the Parameters Window in the Reference Frames tab, enter the frame
number for the first or second reference frame.

3 Use the Enter key to validate the value.

4 In the Keyframes tab, the right box shows the list of all the frames of the
sequence. The left box shows the list of all the current keyframes.

5 Select the frame(s) that you want to use as keyframes from the right box
and add them to the keyframe list using the left arrow button.

6 To remove a keyframe, select it from the keyframe list and use the right
arrow button.
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Method 2

From the right pane of the Track window:

1 Do one of the following:

■ Select 3D Tracking > Set Current Frame.

■ Right-click the required frame in the right pane of the Track window
and select Set Current Frame from the pop-up menu.

2 Select either First Reference to set the current frame as the first reference,
Second Reference to set the current frame as the first reference, or Key
to set the current frame as a keyframe.

The Track window updates automatically.

TIP To create or delete a keyframe quickly, use the shortcut Ctrl+K, which toggles
between the two actions.

NOTE If you select non-valid reference frames, MatchMover warns you that camera
solving is not possible during the solving process.

After editing reference or keyframes, if you change the 2D data (for example,
you add a new point track), you should either re-select the keyframes so that
MatchMover can incorporate this new data in the choice of reference frames
and keyframes, or run the camera solver without reselecting frames.
MatchMover then uses the current reference and keyframes.

Browsing the keyframes

To change the current time to point to the previous keyframe, press Ctrl+up
arrow. To change the current time to point to the next keyframe, press
Ctrl+down arrow.

Setting up cameras
Since MatchMover automatically assigns a new camera for each loaded image
or sequence, you usually do not have to create a camera. However, there are
a few situations where you should create a new camera. For example, when
you load a number of helper images, MatchMover assigns the same camera
to all of the images. If you know that a different camera was used for one of
the helper images, you should create a different camera for that image.
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To create a new camera, do one of the following:

■ Select 3D Tracking > New Camera.

■ Right-click the Cameras folder in the Project window or the Track window
and select New Camera from the pop-up menu.

MatchMover creates a camera label in the Project window and Track window.

Assigning the camera to a sequence

Once you have created a camera, you can assign it to a sequence. Click a
sequence and in the Parameters Window, choose the camera that you want
to assign to the sequence from the Camera drop-down list.

Notice that the enabled camera is shown in bold in all the tree views.

Setting up a camera

NOTE Some advanced camera parameters are not displayed while the interface
is in Light mode, because they’re mostly useless in simple cases. Be sure to switch
the interface to Full mode to make use of all the functions.

Click the camera to view its properties in the Parameters Window. Note that
computed camera values are grayed out in the Parameters window if they do
not correspond to the current camera.
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Time Range

If needed, select a time range. Using a time range is needed when you want
to tweak a parameter over a given time interval. For example, you know that
the focal length between frames 20 and 30 is fixed.

The camera parameter window time range is synchronized with the time line:
when you move to a new frame, it automatically switches to this frame. When
you select an interval, it switches to “Use Selection” with this interval. You
can also simply select “Global Time” to apply your changes to all the frames.

Camera type settings

1 Select the type of camera from the Type drop-down list. The drop-down
list contains standard camera types. These provide you with default
parameter values for the selected camera type.

For example, selecting Type PAL gives you a camera with the principal
point in the center of the image; a pixel aspect ratio of 1.06667, a focal
length initialized at 50 mm and a non-linear distortion set to 0. If you
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set Type to User in the camera Parameters Window, you can define your
own parameters for the camera.

NOTE The camera Type reverts to User if you change any value. Since the
default camera types feature an image size, the camera will revert
automatically to User if your sequence or image has a different size.

NOTE All the predefined camera types are stored in the Data > Camera
Types subdirectory of your installation. Each camera is stored in a simple
“.cam” ascii file. You can easily add/edit/remove those file to customized
your camera database. Just look at one of these file, and you’ll see how to do
it!

2 The Film Back shows the Height and Width of the film back, either in
mm or inches (use the unit combo box at the top to switch). If you change
the height or width, the pixel aspect ratio changes, accordingly.

3 If an anamorphic camera was used to shoot the footage, the Lens Squeeze
Factor may be different from the default value of 1.0. If this is the case,
change the value in the corresponding text field.

4 Three read only fields show the image resolution. Width, Height and
Ratio giving the size of the loaded image. Ratio is the value of the Width
divided by the Height.

Camera parameter types
There are five different camera parameter types as explained in the following
table. When you create a new camera, by default the three intrinsic (or internal)
camera parameters-- principal point, pixel aspect ratio, and non-linear
distortion-- are of the type fixed. The focal length is of the type “constant
initialized”.

DescriptionType

Estimates the parameter value, start-
ing from an approximate value that

Constant Initial-
ized

you provide and the value remains
constant for all the frames.

Computes the parameter value with
no value input from you and the value
remains constant for all the frames.

Constant Un-
known#
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DescriptionType

Uses the parameter value you provide
and does not modify it.

Fixed

Estimates the parameter value, start-
ing from an approximate value that

Variable Initial-
ized

you provide. The value can change
across the frames.

Computes the parameter value with
no input from you. The value can
change across the frames

Variable Un-
known#

#This option is only available for the focal length parameter

All these types are in fact a combination of two settings. One controls the way

the parameters vary over time: is it constant  or variable  . The other

one controls the way the computation starts: unknown  , initialized 

, or fixed  .

These two settings are easily set though simple push buttons in the camera
parameters window.

Not all the parameters can use all the settings combination.

■ Extrinsic parameters (translation/rotation) are always variable.

■ Distortion / Aspect Ration / Principal point cannot be unknown.

Intrinsic and Extrinsic parameters

Each camera has four intrinsic (or internal) parameters: focal length, radial
distortion, pixel aspect ratio, and principal point, and some extrinsic
parameters: translation (or optical center position), and rotation angles.

Intrinsic parameters are, by default, given by the camera type (shown by a
little camera icon at the end the row). These parameters can simply be
overridden by changing their default value or their type. for type They can
also be “motion controlled” by providing a valid range for each (then shown

with the icon  or  ). See Camera parameter types on page 162.
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Extrinsic parameters are, by default, undefined (it’s what we want to find in
MatchMover!). So they’re basically user defined as variable unknown (shown

as  ).

As intrinsic parameters, each of them can be “motion controlled”, either
directly by the user or by importing motion control file (shown with an icon

 ). See Importing motion control data on page 181.

The General tab shows the information for the Focal Length and all the camera
extrinsic parameters (translation, a.k.a optical center position, and rotation
angles).

Click the first row button to define if the corresponding parameter is constant

 or variable  over time. For example in shots where the zoom does
not change throughout the sequence, set the Focal Length to fixed or constant.
If you change the focal length parameter type to variable, you can then define
constraints for this parameter.

■ The first editable box represents the currently computed values. This can
be simply edited or overridden once your shot have been calibrated for
fine tuning (it has the same effect as editing the corresponding curve in
the Graph Editor).

■ Next, you have a button showing how the computed value relates to the

initialization value. It can simply be a totally unknown parameter  ,

or its computation can starts with an initialization value  , or it can

be fixed to a given value  .
Clicking on it toggles through initialized to fixed. Just empty the
initialization value for “unknown” status.

■ The next editable box (with a light blue background) shows the
computation initial value. Next to the initialization value, you have a text
box that sums up the parameter behavior (with a little popup to show the
whole message if needed). For example, it will display the validity interval
set by the user.

■ Finally, the last button shows where the parameter configuration comes

from. Either from the camera type  , from the user  , or from on
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externally imported file  . Depending on the current parameter
configuration, clicking on it will enable following actions:

■ Setting up a validity range

■ Removing motion control data

TIP  If you want to export the results to software that does not handle
non-linear distortion or non-centered principal points (which is the case for
most 3D software), do not change the default values. MatchMover compensates
for the error on these parameters by adjusting the other parameters.

NOTE  If an export format supports anamorphism, the appropriate parameter
will be set. Otherwise, the pixel aspect ratio will be enlarged in the exported
file to account for the squeeze.

About the lens squeeze factor

The Lens Squeeze Factor changes the image or sequence shown in the 2D
View. The following image shows the default image (top) the effects of applying
a smaller lens squeeze factor that the default setting (bottom). This can be
used in the case of anamorphic lenses.
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Deleting a camera

To delete a camera, do one of the following:

■ Select a camera in the Cameras folder in the Project window or the Track
window and either:

■ Select Edit > Delete.

■ Press the Delete key.

■ Right-click a camera in the Cameras folder in the Project window or the
Track window and select Delete Camera from the pop-up menu.

The camera is deleted from the project.
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Defining coordinate systems
MatchMover manages a set of user-defined coordinate systems with respect
to which the cameras and 3D points are expressed. If no coordinate system is
specified, MatchMover chooses an arbitrary one. You can define a coordinate
system in order to facilitate the manipulation of your exported project in a
3D package. If no point relations have been set up, MatchMover aligns the
coordinate system on the computed position of the camera for the first frame;
the default is the camera looking towards Z and Y as Up axis, but this changes
according to your project’s 3D parameters if you selected a different up axis.

If no coordinate system is defined, MatchMover tries to create one from the
point relations or the survey points you defined (it needs at last 4 non colinear
survey points to do so).

There are two main advantages in defining a particular coordinate system,
described below.

Advantage 1 - It makes manipulation easier and more intuitive in the next
stages, when virtual objects are inserted in the scene. For example, if a virtual
object such as a car has to be placed on a flat surface, e.g., a road, it is very
helpful to have two coordinate axes, e.g., X and Y, in the plane of that surface.

Advantage 2 - It allows you to impose strong constraints on the computed
3D points and the camera move, based on clear alignments in the scene
inferred from the image sequence.

For example, two points that are at the same height above the floor, where
the X and Y coordinate axes lie, have the same Z coordinate. These constraints
help the system to compute data that is more accurate and closer to reality.
In practice this applies to a lot of cases such as house walls and floors, any flat
surface etc.

To set a 3D coordinate system, you specify two directions. Each direction is
defined as one of the following:

■ Passing through the origin and one point, selected from the tracked points.

■ Passing through two points, selected from the tracked points.

■ Normal to three points, selected from the tracked points.

The coordinate system is then defined in 3 steps.

■ The first direction defines the first coordinate axis.
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■ The second direction defines, with the first direction, the half-plane in
which the second axis is chosen.

■ Using the two axes, MatchMover finds the third and final axis that is used
to build a direct orthogonal coordinate system.

You can define a coordinate system to the scene using two methods:

■ Defining points for the coordinate system in the coordinate label’s
Parameters Window. See Defining the coordinate system using the
Parameters Window on page 168.

■ Snapping the axes of the Coordinate System Manipulator to 3D points in
the 3D View. See Defining a coordinate system using the Coordinate System
Manipulator on page 170.

NOTE You can move, rotate, and scale the Grid like any 3D object to manually
adjust the coordinate system. See Editing 3D primitives and objects on page
207.

Defining the coordinate system using the Parameters Window

1 Select the points you want to include in your coordinate system.

See Selecting tracks on page 134.

2 Do one of the following:

■ Select 3D Tracking > New Coordinate System.

■ Click the New Coordinate System  icon in the Toolbar.

■ Right-click Coordinate System in the Project window to open the
pop-up menu and select New Coordinate System. MatchMover creates
a new coordinate label.

NOTE Only the points you have selected when you created the coordinate
system will appear in the Parameters Window drop-down list later. See
Creating a point relation on page 173.

By default, no points are selected and all the points will appear in the
list. However, if there is a long list of points, you might find it difficult
to select from such a long list. That’s why there is a way to pre-select
points.
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3 In the Parameters Window, select the point track that serves as the center
of your coordinate system from the Origin drop-down list.

4 In Distance, enter the distance between two tracks.

5 From the other two drop-down lists (below Distance), choose the two
tracks for which you have defined the distance.

6 Select either X, Y or Z from the Axis1 and Axis2 drop-down list.

7 From the drop-down list to the right of Axis1, select either:

■ from origin to - Defines an axis from the origin to the selected track
point.

■ through 2 points - Defines an axis from the first point to the second
point.

■ normal to 3 points - Defines an axis as the normal to the plane defined
by three points.

8 From the activated drop-down lists, below, select the appropriate tracks
to define the axis.

9 Repeat the above process for Axis2.

10 Click the Apply Coordinate System button.

The coordinate system is now defined and the coordinates you set are listed
in the Coordinate Systems folder in the Project window.

NOTE If you have deleted a point track that is used by a coordinate system, you
will be given a warning message during the calculation process and offered the
option of redefining the coordinate system.
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Defining a coordinate system using the Coordinate System Manipulator

The Coordinate System Manipulator makes creating the coordinate system
easy. The manipulator is displayed in the 3D View whenever a coordinate
system is selected or a new coordinate system is created.

You can drag and snap the vertices of the manipulator’s three axes (red: X-axis,
green: Y-axis, blue: Z-axis) to 3D points in the scene and use the independent,
light blue distance line for determining the scale of the scene by measuring
the distance between two points.

To create a coordinate system:

1 Click and drag the origin of the manipulator and snap it to a 3D Helper.

2 Click and drag the sphere at the end of an axis and snap it to a 3D Helper.
The sphere changes color when it overlaps a 3D Helper. The first axis to
be snapped to a 3D point is assigned as the “1st axis” and is equivalent
to the first axis defined in the coordinate label’s properties in the
Parameters Window. See Defining the coordinate system using the
Parameters Window on page 168.

3 Click and drag another axis and snap it to a 3D Helper. The second axis
that you snap to a 3D point is assigned as the “2nd axis”, defining a plane
with the 1st axis. The 2nd axis is defined as the normal to the first axis
that lies in that plane.

4 Resize the light blue distance line by snapping its ends to 3D Helpers.
This scales the scene to using the arbitrary distance between two tracks.
The first point of the line is linked to the origin by a thin, dashed line.
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NOTE You must snap both ends of the distance line to a 3D Helper to
properly define the coordinate system; otherwise it will not be taken into
account. The only way to change the distance (or to define an axis using
three points) is to edit it in the coordinate system’s properties in the
Parameters Window. See Defining the coordinate system using the
Parameters Window on page 168.

To change the color of the manipulator axes and distance line, select Edit >
Preferences, click the Color tab in the User Preferences window, and change
the color of the corresponding sample box.

Understanding locked axes

When an axis is defined as “1st axis” or “2nd axis”, it is locked, meaning that
although it can be moved and snapped to another point, it still retains its
quality of being first or second axis.

The origin can also be moved and snapped to a different point, and although
the manipulator’s axes remain in the same direction, they are now defined
between two points instead of being defined from the former origin to their
snap point.

Deleting a coordinate system

To delete a coordinate system, do one of the following:

■ Select a coordinate system in the Coordinate Systems folder in the Project
window and either:

■ Select Edit > Delete.

■ Press the Delete key.

■ Right-click a coordinate system in the Coordinate Systems folder in the
Project window and select Delete Coordinate System from the pop-up
menu.

The coordinate system is deleted from the project.

Setting the world reference

When you have created several coordinate systems, you can select one to
define the world reference, shown by the three axes in the bottom left corner
of the Workspace.
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To set the world reference:

1 Select a coordinate system from the Project window.

2 Do one of the following:

■ Select 3D Scene > Set World Reference.

■ Right-click and select Set World Reference from the pop-up menu.

Mapping the coordinate system to a camera

You can also center the coordinate system on a camera at the current frame
by selecting 3D Scene > Map World on Camera. This defines the coordinate
system from the computed camera at the current frame so that the origin is
at the optical center and the axes are that of the camera (Z is the optical axis
and Y is the up axis).

Defining point relations
Point relations appear within the Point Relations folder in the Project window.
When you run the camera tracker, MatchMover uses the enabled point
relations.

TIP You can start running the solving process without point relations. Then, if
needed, add them to improve the results.

Point relations apply to the coordinate values of one or several points. When
setting a coordinate constraint, you define the coordinate (X, Y, or Z) that is
shared by the selected point or points.

Then, you set the parameter type as follows:

■ Unknown - The program computes the value without any input from you.

■ Initialized - The program estimates the parameter, starting from the
approximate value you provide.

■ Fixed - The program uses the value you provide and does not modify it.
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For each point, you can independently set point relations for all three
coordinates (X, Y, or Z).

TIP  If you know the coordinates of 3D points in the scene, from manual
measurements or from a map, you can provide MatchMover with this information.
You can either create three point relations for each survey point, one involving
each coordinate and setting their parameter to Initialized or Fixed, depending
on the accuracy of the survey data or you can directly enter those coordinates in
the corresponding track 3D parameter tab, as survey info.

A relation involving one point and whose parameter is set to Unknown does
not provide any information and will not be used for calibration.

Creating a point relation

To create a point relation:

1 Select the points you want to include in the relation from the Point Tracks
folder of the Project window.

2 Do one of the following:

■ Select 3D Tracking > New Relation.

■ Click the New Relation icon  in the Toolbar.

■ Right-click the Point Relations label in the Relations folder in the
Project window and select New Relation from the pop-up menu.

A new relation is created featuring all the points that were selected. A
new Relation label appears in the Point Relations folder. All featured
points are listed (the points selected from the Point Tracks folder) in the
Parameters Window and can be sorted using the up and down arrow
keys.
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NOTE If no points are selected from the Point Tracks folder, a new relation
is created containing no points.

3 You can add extra points:

■ By selecting them from the right list box and add them to the left list
box using the left arrow button.

■ By selecting track(s) in the Workspace, right-click a relation in the
Project window, and select Add Selection.

■ By dragging and dropping tracks directly from the Point Tracks folder
in the Project window into the Point Relations folder.

To remove points:

■ By selecting them from the left list box and add them to the tight list
box using the right arrow button.

■ By selecting track(s) in the Workspace, right-click a relation in the
Project window, and select Remove Selection.

4 In the Parameters Window, from the Type field, select the relation type
for points that share a coordinate. Share X, Share Y, or Share Z.

5 From the Status field, select the status for this relation. It can be Fixed,
Initialized or Unknown.

6 If you select Fixed or Initialized, enter the value in the Value field. If you
select Unknown, the Value field is disabled.
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7 To enable this point relation, click the Enable box to check the option.

NOTE If a point belongs to several point relations of a given type (X, Y, Z),
only one of these can be enabled.

Relations are shown in the 3D View as a semi-transparent rectangle in the
appropriate plane. The rectangle’s edges are normal to the coordinate system
axes. The relation rectangle is the smallest that contains all points featured
in the relation; however the rectangle has a minimum width and height that
ensures that it is not restricted to a thin line if all points are aligned on one
axis.

NOTE To change the color of the relations displayed in the 3D View, select Edit
> Preferences, click the Color tab in the User Preferences window, and change
the color of the corresponding sample box.

To show or hide relation planes in the 3D View, select Display > Relations.

Deleting a relation

To delete a relation:

■ Select a relation in the Relations folder in the Project window and either:

■ Select Edit > Delete.

■ Press the Delete key.

■ Select track(s) in the Workspace, right-click a relation in the Project
window, and select Delete Relation.

Defining survey points and object mapping
The main goal of the matchmoving is to compute both the camera motion
and the scene. If you know some of the properties of a scene, because you
took measurements, or you have some constraints, you may know the 3D
coordinates of some points of the scene. Instead of letting MatchMover
compute their 3D coordinates, you can set them before the computation.
Setting these “3D Survey points” has several advantages:

■ The coordinates of the points at the end of the computation will be exactly
what you entered.
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■ The points help MatchMover automatically finding the appropriate
coordinate system that matches your measurements of the scene.

■ The computation will be more robust, as all the survey points will help
MatchMover finding other points in the scene.

A minimum of four survey points is required to define the coordinate system.
You can either set these coordinates manually or use one of your 3D object
vertex coordinates.

Setting survey points manually

1 Select a track. The track’s properties are shown in the Parameters Window.

2 Check the Survey Info options and either enter each known 3D
coordinates directly in the corresponding edit box or check the Use 3D
Object option, then select a 3D object in the Mesh drop-down list and a
Vertex number. You can view the vertex number by selecting Display >
Mesh Vertices to toggle the display of each vertex index of a 3D object
from “none”, through “selected vertices” to “all vertices”.

3 Click the Use Object Transform checkbox if you want to be able to alter
the original shape of your object.
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4 Click Commit Changes to validate.

Setting survey points using elastics

You can create a survey point simply by using a 3D object vertex.

In a 3D View, select the object. Drag the vertex to a position on the background
image or an existing track point to make a link. You can then fine-tune its 2D
position by clicking in the Magnifier window.

A new survey point is created with coordinates mapped on the 3D object’s
selected vertex. The mappings can be edited in the Parameters Window. See
Setting survey points manually on page 176.

TIP  When drawing an elastic from a large object to the image plane is
complicated, you can select the vertex you want to link and check the Use 3D
Object option in the 3D tab of the track Parameters window. The selected vertex
creates a new survey point with coordinates mapped on the 3D object’s selected
vertex.

Defining camera constraints
Constraints are listed the Cameras folder with the enabled constraint name
in bold type. Constraints with no frames are shown as dimmed and with
“empty” next to their name, to show the user that these are useless. Don’t
forget to add frames to your constraints!

Focal length constraints

With the camera focal length parameter set to Variable, it is possible to set a
“constant” constraint on the focal length that can be applied to a part of your
sequence.
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The focal length camera constraint can be of three types:

■ Fixed - Uses the parameter value you provide and does not modify it.

■ Initialized - Estimates the parameter value, starting from an approximate
value that you provide.

■ Unknown - Computes the parameter value without any input from you.
This is the default.

When using a focal length constraint there are three main steps. First you
create the constraint, and then you edit the constraint providing MatchMover
with information on its type and value. Finally, you decide which frames use
this constraint for the tracking process.

Nodal pan constraints

The nodal pan constraint fixes the optical center of the camera and limits the
camera movement to rotation only. All nodal-only features (2D tracks that
have no keys out of the nodal pan) are reconstructed with a median default
depth.

Dolly constraints

The dolly constraint fixes the camera motion in one direction only, either
along the X-, Y-, or the Z-axis.

Planar constraints

The planar constraint fixes the camera motion in two directions, either along
the XY, XZ, or YZ planes.

Creating and enabling a constraint

You can create as many constraints as you like and toggle them by using the
enable/disable check box in the constraint Parameters Window.

To create a new constraint:

1 Select the camera for which you want to add a constraint in the Project
window or the Track window.

2 Do one of the following:

■ Select 3D Tracking > New Constraint.
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■ Right-click the camera for which you want to create the constraint in
the Project window to open the pop-up menu and select New
Constraint.

3 Select the constraint parameter from the drop-down list in the Parameters
Window.

4 When needed, select a Type from the drop-down list and enter the value
in the Value text field.

5 In the Label text field, enter the name of the constraint.

6 Use the Enable check box to activate or disable the constraint for the
required frame(s) of your sequence. See Adding frames to a constraint on
page 179.

NOTE If you choose to create a focal length constraint and the camera focal
length parameter is not variable, a message box opens telling you that the
camera constraint will be disabled.

The frames to which the constraint applies are shown by a colored rectangle
in the Track window. The enabled constraint appears in bold in the Project
window and the Track window.

NOTE To toggle the constraint, right-click a constraint in the Constraint folder
in the Project window or the Track window and select Toggle Constraint from
the pop-up menu.

Adding frames to a constraint

On creation, a constraint is not applied to any frames and you have to add
frames to the constraint and enable it. MatchMover can only use the constraint
when you have provided information concerning the frames to which the
constraint is applied.
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To do this, configure MatchMover to use the constraint on specified frames
by creating a time range and adding or removing frames that use the constraint
in the camera solving process.

In the Track window:

1 Select the time range for the constraint by pressing Shift+click and drag
the pointer from the first frame to the last frame to include in the time
range.

2 Do one of the following:

■ Select 3D Tracking > Edit Constraint > Add Frames.

■ Right-click in the Track window and select Add Frames from the
pop-up menu.

The frames within the selected time range now have the camera constraint
applied to them and MatchMover uses this information in the tracking process.

The constraint label appears in bold in both the Project window and Track
window to show that it is enabled and it applies to the current time.

If another constraint already exists for the added frames, it is disabled
automatically.

For example, you have a sequence of 400 frames and you know that there is
a fixed zoom for the first 300 frames and a variable zoom for the last 100
frames. In the camera Parameters Window, set the Focal Length to variable
and initialized.

You create a new focal length constraint and then define a time range from
frames 0 to 300 in the Track View or in the Time Line. Using the function Add
Frames, you apply the constraint to the frame sin the range. Finally, you set
the Type according to your knowledge of the focal length in the constrained
time range.

Deleting frames from a constraint

In the Track window:

1 Select the time range to delete from the focal length constraint by pressing
Shift+click and drag the pointer from the first frame to the last frame to
include in the time range.

2 Do one of the following:

■ Select 3D Tracking > Edit Constraint > Remove Frames.
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■ Right-click in the Track window to show the pop-up menu and select
Remove Frames.

Deleting a constraint

To delete a constraint select a constraint in the Constraint folder in the Project
window or the Track window and either:

■ Select Edit > Delete.

■ Press the Delete key.

■ Right-click a constraint in the Constraint folder in the Project window or
the Track window and select Delete Constraint from the pop-up menu.

Importing motion control data

Specifying import format

Some hardware devices are able to output what we call “motion control data”.
That is, information about its position, rotation and/or internal parameters.
All this information can be fed into the MatchMover solver.

It can be used as an initial solution, and MatchMover will then compute the
remaining missing parameters, or simply to fine-tune these data, usually not
so accurate.

The only need to do so is that the motion control data is stored in an ascii
file, which can be easily sequentially processed (that’s to say the data are stored
frame by frame). You can then use the Import File Format window to describe
and parse your custom files.

1 Select 3D Tracking > Motion Control Import  or press F12.

Importing motion control data | 181



2 The Currently Loaded Files list displays any files that you have loaded.
To remove one, select it and press Remove. You can also reload it by
pressing Reload if data have changed.

3 Either select an existing file format from the drop-down list, or create a
new one using the New/Edit button (see next paragraph for details).

4 Click the Browse button to import an existing file.

NOTE Click the button to the right of the User Data or the File Data text

fields  .

5 Set the Default Accuracy of the motion control data (either from file or
from user).
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6 Set the Status and Valid Range if needed.

Specifying the import format

Click the New/Edit button of the Motion Control Import window to edit a
file format. The Import File Format window opens.
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For example, this corresponds to the dummy file.

>> begin of sample file

This is motion control data

These 2 lines will be skipped

# these are comments lines

# camera 0 with focal 25.65

# data is frame number, OCX, OCY, OCZ

0 12.34 5 2.56

1 45.3 6 3.45

1 44 7 4.55

<< end of sample file

For a new format, enter a name in the Preset Name text field or select an
existing one to modify it. Press Delete to remove the current one from the
list.

■ The Skipped Lines size specifies the number of header lines to skip not
counting comments and empty lines.

■ The Comment Lines Tag is used to specify a list of single characters selected
from the list or user entered. Each line starting with such a character will
be ignored. Click the Add or Del button as appropriate.

■ The Data order specifies how data is read for each frame. Select an item
from the drop-down list and click Add. Dummy data type can be used for
any value/word to ignore. The default frame number starts at 0 and
increases after each read frame if not specified.
Options.

■ Use Radian Angle: Default angles are specified in degrees.

■ Reverse Rotation: Rotation angles are reversed after import.

■ Use Frame Shift: Specifies an offset for the frame index.

■ Default Value Range: This range will be applied to all imported data.
You can also set these parameters in the Motion Control Import window.

■ Default Optical Center: This value is added to all imported optical
center.

■ Default Rotation: This value is added to all imported rotation.

All changes can be reset using the Reset Changes button.

Motion control is then automatically applied for all imported data.
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A dummy motion control constraint is then created under the corresponding
camera, to show where motion control data is available and used.

Solving for the camera
This process reconstructs the 3D points corresponding to the 2D tracks and
computes the camera path for all the sequences or frames and all the objects
in one solve. There are several stages:

1 Select key and reference frames

2 Solve the two reference frames

3 Solve all the keyframes

4 Solve all other frames

5 Solve all the 3D points.

This process is done first for the main camera (looking at a static scene), and
then for all the mobile rigid objects.

At the same time the process computes the camera parameters and reconstructs
the 3D coordinates of the 2D computed points.

NOTE Camera solving is an automatic step in the Automatic Tracking process.
See Running the automatic 2D tracking on page 127.

Each camera parameter--focal length, principal point, pixel aspect ratio and
non-linear distortion-- has a value that varies or remains constant throughout
the sequence and is either known or unknown.

Optionally, you can specify these parameters. Doing so helps the camera solver
to give more accurate and faster results. See Setting up a camera on page 160.

Setting frames to solve

By default, MatchMover processes all frames in the Work Area. However, you
may have for example, blurred images or an obscured frame, for which the
camera will not solve. You can select the frame that you want to solve and
therefore ignoring the frames that will not solve.

1 Use Shift+click and drag the pointer to define a time range in the Work
Area. See Defining a Work Area on page 94.
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2 Do one of the following:

■ Select 3D Tracking > Set Frames.

■ Right-click in the Track View and select Set Frames from the pop-up
menu.

3 Select one of the following:

■ To Be Solved - When you run the camera solving process, MatchMover
process the marked frames.

■ Do Not Solve - When you run the camera solving process, MatchMover
does not process the marked frames.

NOTE Frames that will not be solved are marked with a black bar in the Track
window graded ruler.

Running the camera solver

To run the camera solver, do one of the following:

■ Select 3D Tracking > Solve for Camera.

■ Click the Run/Stop Camera Solving  icon in the Toolbar.

■ Right-click in the Cameras folder in the Project window or the Track
window and select Solve for Camera from the pop-up menu.

■ Press F9.

A blue progress bar appears in the status bar, showing the progress of the
solving process.

A popup window also opens to show you the current solving step:
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You can press the Stop button inside it at any time to stop the solver (this
may take a little time before the computation thread really safely stops).

NOTE The process halts if you attempt to run the solver with no frames initialized.
If the tracking fails for any reason, an error message is displayed to give some hints
to the user on how to fix it. It may be, for example, that some frames do not have
enough tracks, or that the coordinate system definition is bad with respect to
some survey points, etc.

Extending the computation

In some tough case, you might prefer tracking your shots pieces by pieces.
You basically start from a rock-solid frame range that you track the best you
can.

If you want, you can extend your solve by adding more frames into it. You
can do it in three ways in MatchMover:

■ Add frames, either by setting them “to be solved” or by extending 2D
tracks to them, or by adding them in the Work Area, then you relaunch
the solver.

■ If you consider your existing solution as a good starting point, use the

Extend camera command  . This option starts the solver, but first
initializes the solution with the current one. The solver can refine current
frames in this case, and any additional data will be computed.

■ If you know your current tracking is good, and do not want MatchMover

to modify it, use the Extend camera fixed command  . All additional
data are computed, but currently computed tracks are locked and will not
be modified.

In some cases you may need to tweak the keyframes settings to cope with your
new configuration.

NOTE  Shots solved with extend camera tools may not give the same result if
solved from scratch. So the user needs to keep track of its solving steps in order
to solve it again, if needed.
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Fine-tuning the results

Inspecting the results

Inspecting the results

Once your shot has been solved, you will need to check the quality of the
solving. Is it accurate enough to fit your needs or are there some frames that
are not solved correctly? MatchMover provides several ways to check the
tracking.

Checking the computation quality in the Track window

The quickest and simplest method is to examine the colored line in the Track
window graded ruler that corresponds to the residual value for a given frame
(the average of all the track residuals present at that frame). See The Track
View on page 88.

This colored line indicates the quality of the tracking according to the residual
value thresholds set in the Preferences window. See Configuring the tracker
on page 144.

Gray lines indicate frames that are not computed and black lines are ignored
since these frames were set to “do not solve” before the camera solving process.
Green lines mean good solving, through yellow (fair) to red (bad). So, you
have an instant feedback of the average quality of all your frames. It’s almost
the same for all the track points.

You can really easily spot out the bad areas, a bad time range, or bad tracks,
if any, and concentrate on them. Anyway, for further inspection, MatchMover
provides the other solutions detailed in the next sections.
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Checking the position of 3D Helpers

Another quick and simple method of checking the results involves using a 3D
View. When working in the 3D View, each reconstructed track is displayed
using a 3D helper. The tracks are displayed by a default 3D cone, but can be
changed to a pyramid, or a cross in the Preferences window. So if you look

through the computed camera (using Lock on Camera)  , you should
easily see if orientation and relative depth of the helpers fit the real footage.
By playing the sequence, you’ll also be able to check how accurate the 3D
helpers reproject on the background. Accurate tracking results in natural and
synchronized helper motion. Mobile points are displayed with a different
customizable color, and are animated while sequence is played.

You can easily change the 3D helper size, either in the global parameter
window, which is displayed when nothing is selected (just hit Esc), or in the
Preferences window (press P).

Examining the computation quality in the Track Status View

The Track Status View shows a graphical representation of the pixel residuals
for each track in a frame. Use this to isolate quickly the tracks or frames with
a high-pixel residual. See The Track Status View on page 91.

Examining the computation quality in the Survey Window

Use the Survey Window to analyze the results of 3D tracking and to isolate
specific frames or points where adjustment may be necessary.

Select Window > Survey Window.

The Survey Window shows values of the distance in pixels between a 2D point
and the projection of a 3D point on the camera. These are called the residuals.
Numeric information is shown for the points and/or frames and their average
error values.

By default the Survey Window shows two columns, the points and the 3D
residuals, but you can display a maximum of four columns.

To change the display:

1 Do one of the following:

■ Select Display > Survey Mode.

■ Right-click in the Survey Window.
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2 Select either:

■ Points to show the point number and 3D tracking residual data.

■ Frames to show the frame number and 3D tracking residual data.

■ Points & Frames to show the point number, frame number, the 2D
tracking quality residual data, and 3D tracking residual data. The 2D
tracking quality residual data ranges from 0 to 1. A score of 0 indicates
a poor tracking quality; 1 indicates perfect tracking quality.

Selecting Points mode allows you to double-click a track in the first
column to select the track in all views. Selecting Frames or Points and
Frames allows you to double-click in the first column to change the
current time.

By default, the data is sorted for the Points column in ascending order.

To sort the data in the 3D Residual column:

1 Click the 3D Residual column header to sort the data in descending order.

2 Click the 3D Residual column header to sort the data in ascending order.

A sort can be done for other columns by repeating the above procedure
substituting the required header.

Inserting 3D objects and using them as references

The next method involves inserting virtual objects in a 3D View and producing
a preview of the composed sequences in any output format. See Working with
3D objects on page 205.

The virtual objects are fixed in space (with respect to the tracked rigid object)
and rendered using the estimated camera parameters. The process is successful
when the motion of the virtual objects in the composed sequence is consistent
with that of the real scene. Previewing allows you to study the results of the
tracking process and make any modifications, if necessary.

Troubleshooting the solver
Unable to solve for frames

If you get the error message “Cannot process frames. X X X. Check that you
have provided enough track information.”, the solver did not have enough
information to complete the reconstruction process for some frames. To correct
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this, you need to manually add some tracks that will cover all concerned
frames, then run the solving process again.

Incorrect reconstruction

Pay special attention to the reference frames in such a situation. They are used
to bootstrap the computation and should contain plenty of relevant
information and tracks in common.

It is important that depth information can be extracted from these two frames.

Motions that feature a still optical center, such as panning and zooming, do
not provide that information. Orbitals and lateral travelings are your best bets.
Keeping that in mind, you may manually edit the reference frames; this may
greatly improve the calibration process.

The quality of tracked points in the reference frames is paramount. Although
MatchMover is usually able to filter out inconsistent points, in some cases the
low signal-to-noise ratio hinders the sorting process between relevant and
inconsistent tracks, resulting in some of the latter getting through.

If several bad tracks (with the red helper icon) are listed, it is a good idea to
review the quality of your tracks. First of all, run the Automatic Clean up (F11)
in order to restrict the number of tracks. Do not hesitate to start solving only
a subset of your shot, and then extending it smoothly in case of really complex
shots. It’ll then be easier to isolate tough frames. You can extend the solving
in 3 different manners. See Camera solving on page 154.

Look for the following issues:

■ Jumpy tracks.

Jumpy tracks can be found by carefully looking at track paths. A sudden
bump in the path may mean that the track “jumped” from one feature to
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another or it may also be caused by a jerky camera motion. Usually these
can be manually edited and corrected or simply deleted.

■ Periodic textures, such as windows of a building.

This is a special case of jumpy track, the tracker was fooled by the repeating
pattern. Make sure the corners match or remove the tracks altogether.

■ Non-physical points.

The intersection of the border of an object and a line in the background
represents a 3D point whose position in space changes with the camera
position; it is not a physical 3D point. More generally, any 3D point whose
position in space depends on the camera position (for example, the
occluding edge of a cylinder) should be removed.
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In some cases, this is harder to figure out. The apparent corners of a bottle
or any other cylindrical object placed on a table will not represent the
same 3D point when you orbit around it. Specular highlights should also
be removed.

■ Moving objects.
If there are points left of objects in motion, when you intend to track the
scene, the information they will provide, while relevant to the object, can
be confusing for MatchMover. Deleting such point tracks will help solve
the issue. You can also use mattes to mask moving objects.

Mattes must be drawn before running the automatic tracker, not afterwards.

Ghosted object

If an object moves out of the camera field then back in, MatchMover may not
recognize it and so may add new tracks on it. Inaccuracies during computation
may then produce a “ghost” of the object; two copies of the object, slightly
offset, will be reconstructed.

Editing the 2D tracking will get rid of this problem; use the Merge Tracks
option on all tracks that represent the same physical point (see Merging tracks
on page 135). Note that the solving can do that automatically.
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Noise in camera path

If a part of the computed path is noisy, quivering, uneven, or otherwise
incorrect, there is a big chance that the corresponding frames are marked red.
This is usually the first symptom of the issue, which can also be diagnosed in
3D View.

Keyframes are usually the way to obtain a smoother motion. If the area
contains only a few keyframes or none at all, adding some will improve the
result. To manually add a keyframe, select the frame, right-click it, and in the
pop-up menu select it as a keyframe or decrease the average step between
keyframes in the Edit > Preferences > 3D Tracking window.

Zoom computed as a dolly

If you have set the camera to have a constant focal, which is the default setting,
MatchMover will see motions instead of zooms.

Fixing this problem is simple. Open the camera’s Parameters Window and set
the focal length to Variable, then re-run the camera solver.

Skewed scene structure
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The symptom is that some angles are either too sharp or not enough. This is
most obvious with angles that should be right but are not reconstructed as
such.

This condition can be improved using point relations. Constraining points
on a wall to share the X coordinate and point on the other wall to share the
Z coordinate will force the angle to be right. To do this, however, you need
to define your coordinate system in a way that your axes are parallel to the
aforementioned walls.

Filtering the results

The Graph Editor

The Graph Editor displays a graphical representation of computed camera
parameters as well as providing options to edit the results. Depending on the
type of camera motion (hand-held, stabilized, motion-controlled) and the
quality of the 2D tracks, it may be useful to smooth some or all of the
computed camera parameters. Smoothing can be done by hand, or by using
a post filter.

Switch to the Graph Editor by clicking on the Graph Editor tab at the bottom
of the Track window.
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In the Parameter Tree, you can select the parameter you want display. The
corresponding curve is then shown in the graph display.

The available parameters are:

DescriptionFolder

Contains the three components of
camera translation, named X-, Y-, and
Z-axes

Translation

Contains the three components of
camera rotation, named X-, Y-, and Z-
axes

Rotation

Shows how camera focal length varies
over time

Focal

Shows how lens distortion varies over
time

Distortion

The Graph Display shows the curve representing the selected parameter value
over time. The X-axis always represents the time in frames, and the Y-axis
represents the parameter value.

For example, rotation is expressed in degrees, translation is in the units defined
in the coordinate system, and the focal length is in millimeters.

Each curve is shown as a continuous line joining the points calculated for
each frame. The color of a curve is determined by the parameter it represents.
One or more parameters can be selected and displayed at a time by using Shift
or Ctrl+right-click.

The points used to extrapolate a curve are displayed in the Graph Display and
can be edited.

Click to close the Graph Editor.

To restore the view, select Window > Track Window.

To fit the graph to the viewport, select Graph > Fit or right-click in the Graph
Editor and select Fit from the pop-up menu.

The Graph Editor Toolbox

The Graph Editor Toolbox is displayed when you open the Graph Editor.
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This toolbox provides access to the MatchMover post-filtering options. As you
move the pointer over the graph, the Graph Editor Toolbox displays
information on the position of the cursor (time and position) and the key
number and its value in read-only fields.

If you select a key, or multiple keys using a rubber band selector or pressing
Shift while selecting more keys, the keys are listed and you can set their value
by entering a number in the Value field and clicking on Set Value.

The filter options are displayed in the Graph Editor Toolbox. After you have

edited a camera parameter, use the recompute function  to recalculate
the effects of editing on the other parameters. See Smoothing a curve using
post filters on page 198.

Toggle the Graph Editor Toolbox display by selecting Graph > Graph Editor
> Editor Toolbox or use the pop-up menu.

Toggling the display grid

To toggle the grid display in the Graph Editor:

1 Click in the Graph Display to select it.

2 Do one of the following:

■ Select Graph > Show Grid to display the grid.

■ Right-click in the Graph Editor or the Track Status View and select
Show Grid from the pop-up menu.

A check mark appears beside the option indicating that the option is activated.
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Locking the grid axes

To lock the X- or Y-axis of the grid, either:

■ Select Graph > X Locked or Y-Locked.

■ Right-click in the Graph Editor or the Track Status View and click X Locked
or Y-Locked in the pop-up menu.

A check mark appears beside the option indicating that the option is activated.

Smoothing a curve using post filters

The Graph Editor allows you to modify curves and point values using post
filters. MatchMover has four types of post filter.

■ Spline - Replaces frame parameters with the values obtained from spline
interpolation of the neighboring values. This is useful when one frame
looks “jumpy” and neighboring frames are not. In this mode, you can
change the tangent of the curve at a given point to create a smoother curve.

■ Linear - Replaces frame parameters with the values obtained by creating a
linear curve between the first and last selected frame.

■ Smooth - Applies a smoothing filter to the computed values. This is useful
to remove the small vibrations that can appear in the computed camera
path even when the actual camera motion is smooth.

For example, if the original camera path computed by MatchMover is too
jagged, as shown below, we will use the smoothing function to improve it.

A low-strength smoothing operation polishes the curve while keeping the
general motion.
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However, if the smoothing is too strong, it will erase details and flatten the
curve. Smoothing has worsened the result and the smoothed path is further
from the solution than the originally computed one was.

Each time you modify a curve, its name in the Project window and the Track
window changes to italic font and its corresponding icon changes to yellow.

This indicates that the value has been modified and some recomputation may
be needed.

To smooth a curve using a post filter:

1 Click the Graph Editor tab.

2 Select the parameters to edit it in the left pane of the Graph Editor. Its
curve will then be displayed in the Graph Editor.

■ To select more than one parameter use Shift+click to add new items
to a current selection.

■ Use Ctrl+click to remove parameters from a selection.
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TIP If you select more than one parameter in the left pane of the Graph
Editor, several curves will be displayed in the graph area.

3 Do one of the following:

■ Select a frame range. A frame range is a set of frames. In some
situations, you may find that you only need to edit a limited part of
your sequence. In the graph area, press Shift+click and drag the mouse
horizontally to include the frames you want to select.

■ Select a curve point by clicking on it. This will turn the point into a
small red circle. If you are in the Spline mode, it will also activate the
display of the curve tangents at this point.

NOTE If a time range exists, the filter is applied only to the frames within
the time range. Frames outside the time range are unaffected. If no time
range exists, the whole of the current sequence is filtered.

4 Select the relevant filter from the Graph Editor Toolbox.

■  to convert a time range to spline.

■  to convert a time range to inear.l

■  to smooth a time range. Edit the number in the
corresponding text field to define the strength of the smoothing.

■ You can also set this value in the Smoothing Strength text field by
selecting Edit > Preferences > 3D Tracking.

■ Right-click in the Graph Editor and select Filter and then a post filter
from the pop-up menu.

MatchMover applies the post filter to the selection.

Modifying a curve manually

For more controllable editing of a curve, you can edit points manually.

1 Place the pointer over the curve point you wish to edit. The pointer

changes to  .
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2 Click the point. The point changes to a red label with a pencil indicating
that it is selected.

3 Drag and drop the point to its new position.

TIP You can do exactly the same using multiple points selection.

NOTE You can show or hide the original curve by toggling the option Graph
> Graph Editor > Show Ghost or right-clicking in the Graph Editor and
click Show Ghost in the pop-up menu. A check mark appears beside the
option indicating that the option is activated.

Editing tangents

You can also edit the tangents. By default, the two vectors are aligned and
synchronized. If desired, you can desynchronize the two tangents and set
them independently.

1 Run a Spline filter on a curve.

2 Select a point.

3 Place the pointer over a tangent of the point to edit.
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4 Move the pointer up or down to set the tangent.

To edit tangents freely:

1 Do one of the following:

■ Select Graph > Free Tangents.

■ Right-click in the Graph Editor and click Free Tangents in the pop-up
menu.

A check mark appears beside the option indicating that the option is
activated.

2 Run a spline filter on a curve.
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See Smoothing a curve using post filters on page 198.

3 Select a point.

4 Place the pointer over a tangent of the point to edit.

5 Move the pointer up or down to set the tangent.

NOTE The Free Tangent mode causes discontinuities in the smoothness of
a curve and should be used by advanced users only.

Adding keys to and deleting keys from the curve

To add a key to the curve, do one of the following:

■ Select Graph > Graph Editor > Add Key.

■ Right-click in the Graph Editor and select Add Key from the pop-up menu.

To delete a key from the curve, select it and do one of the following:

■ Select Graph > Graph Editor > Delete Key.

■ Right-click in the Graph Editor and select Delete Key from the pop-up
menu.

Resetting the curve

To restore the curve to its initial state, do one of the following:

■ Select Graph > Graph Editor > Reset Curve.
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■ Right-click in the Graph Editor and select Reset Curve from the pop-up
menu.

Recomputing parameters
Once you have edited a camera parameter, use the recompute function to
recalculate the effects of editing on the other parameters. To recompute the
parameters:

1 Do one of the following:

■ Select Graph > Graph Editor > Filter > Recompute.

■ Click the Recompute icon  in the Graph Editor Toolbox.

2 Select the parameters to recompute by checking the associated option as
appropriate in the Recompute parameters window.

3 After editing a curve, MatchMover selects automatically which curves
should be recomputed based on the modifications made. Check or clear
the appropriate toggle box to set the Parameters to be recomputed. Red
options indicate the parameter is already edited. It also suggests parameters
for recomputation and checks them automatically.

4 Select a time frame in the Time parameters text fields or drop-down
menu. Choose from Full File, Time Range, or User.

5 Press the Recompute button.
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NOTE When recomputing camera parameters in the Graph Editor, the items
Distortion and Focal Length in the Recompute parameters box are by
default disabled to keep the focal length and the distortion constant.

MatchMover re-estimates the specified camera parameters from the 3D
points, the 2D tracks and the modified camera parameters without changing
the 3D points. For example, with a variable zoom, it is common for the system
to produce a camera path that is jagged along the depth axis. MatchMover
compensates for slight errors along this axis by adjusting the focal length.

To avoid this, you can first filter the focal length then re-compute the rotation
and translation.

Working with 3D objects
MatchMover provides you with a set of objects called 3D primitives. 3D
primitives are basic 3D shapes such as cubes, cones or spheres. It is also possible
to import an object or a scene in the OBJ format. You can use a 3D object as
it appears or edit it, using one of the manipulators. The virtual objects are
fixed in space, and rendered using the estimated camera parameters. The
process is successful when the motion of the virtual objects in the composed
sequence is consistent with that of the real scene. You can also use 3D objects
to define survey points mapping by dragging the mouse from one vertex to
the image plane. See Setting survey points using elastics on page 177.

To insert a new primitive:

1 Do one of the following:

■ Select 3DScene > New Primitive.

■ Right-click in the 3D View or on the 3D Scene folder in the Project
window and select New Primitive from the pop-up menu.

2 Select the type of new primitive from the sub menu. Plane, Cube, Pyramid,
Dihedron, Sphere, Cylinder, Cone, or Light.

Alternatively, you can select a primitive from the Toolbar by clicking on one
of the primitive icons. See User Interface overview on page 69.
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MatchMover inserts the new primitive in the scene at the origin of the
coordinate system and selects it.

Importing 3D objects

You can import 3D objects as files in the OBJ format. Only polygonal objects
are imported. The imported objects are imported along with texture
information, and can be manipulated in the same manner as the 3D primitives.

1 Do one of the following:

■ Select 3D Scene > Import Scene.

■ Right-click the 3D Scene folder in the Project window or anywhere
in the 3D View and select Import Scene from the pop-up menu. The
Import Scene window opens.

2 Select the OBJ file to import and click OK.

Viewing 3D primitives and objects

You can position the viewing camera to view the different faces of a 3D object
or primitive by selecting View > Set 3D Viewing and one of the following
options.

■ Front - Shows the front view of the object relative to the active coordinate
system.

■ Top - Shows the top view of the object relative to the active coordinate
system.

■ Side - Shows the side view of the object relative to the active coordinate
system.

■ Perspective - Changes the scene’s perspective.
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■ Orthographic - Shows the scene without perspective.

Deleting a 3D primitive or an object

To delete a primitive or a 3D object, do one of the following:

■ Select an object in the 3D Scene folder in the Project window or in the 3D
View and either:

■ Select Edit > Delete.

■ Press the Delete key.

■ Right-click an object in the 3D Scene folder in the Project window and
select Delete Object from the pop-up menu.

The object is deleted from the project.

Editing 3D primitives and objects

You can either edit primitives in the Parameters Window or by using
MatchMover’s three manipulators. See 3D primitives and objects Parameters
Window on page 211.

■ General manipulator

■ Translate/Scale manipulator

■ Alignment manipulator

The different manipulators provide specific object manipulation possibilities,
enabling you to edit any object placed within the 3D View. By default, when
you create a new primitive or new light, the General manipulator surrounds
the object.

1 To access the manipulators either:

■ Click an object and select 3D Scene > Select Manipulator.

■ Right-click an object in the 3D View and select Select Manipulator
from the pop-up menu.

2 Choose General, Translate/Scale, or Alignment.

The manipulator changes. Notice that the same manipulator is assigned to all
new objects. Toggle between the manipulators using the Tab key.
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NOTE To change the color of the manipulator or the manipulator’s active handle,
select Edit > Preferences, click the Color tab in the User Preferences window,
and change the color of the corresponding sample box.

The General manipulator

The General manipulator allows you to carry out the following actions:

■ Independent scaling along to the selected axes by clicking and dragging
the cylinder.

■ Rotation around the selected axes by clicking and dragging one of the
three circles surrounding the object.

■ Translation in the plane perpendicular to the camera by clicking and
dragging the cone.

■ Translation along two axes by clicking and dragging the central cube.

The Translate/scale manipulator

The Translate/scale manipulator allows you to carry out the following actions:

■ Independent translation along the selected axes by clicking and dragging
the cone.
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■ Translation in the plane of the selected manipulator face by selecting and
dragging a face.

■ Symmetrical scaling in relation to the center of the manipulator by clicking
and dragging a cube in the edge of the manipulator.

■ Symmetrical scaling in relation to the center of the manipulator along
three axes by clicking and dragging a corner cube.

The Alignment manipulator

The Alignment manipulator, more complex than the other two manipulators,
defines the alignment of manipulator axes and pivots.

The Alignment manipulator allows you to carry out the following actions:

■ Align the object with the principal axis by clicking and dragging the sphere.

■ Align the object with the central pivot by clicking and dragging the center
cube.

■ Align the object with the orientation axes by clicking and dragging the
cone.

■ Snap the manipulator to an object’s vertex, edge, or faces, track points,
and other primitives in the scene (see below).

Snapping the manipulator to elements

Press Shift and drag and drop a manipulator element on a vertex, an edge, or
a face of the object, track points, and other primitives. The orientation axes
and principal axis align an object whereas the center cube translates it.

When you place the pointer over an element, it changes to reflect the type of
element you are snapping to.

 when snapping to a vertex or a 3D Helper.

Working with 3D objects | 209



 when snapping to an edge of an object.

 when snapping to a face of the object.

Aligning the manipulators’ pivot

MatchMover allows you to align the manipulators’ pivot with object elements.

When any of the manipulators are activated:

1 Do one of the following:

■ Select 3DScene > Edit Pivot.

■ Right-click an object in the 3D View and select Edit Pivot from the
pop-up menu.

2 Select from the pivot alignment options in menu:

■ Orient Pivot - Aligns the pivot with a face of the selected object. See
Orientating the manipulator’s pivot on page 210.

■ Align Mesh - Aligns the pivot with the mesh. See 3D primitives and
objects Parameters Window on page 211.

The following additional options apply only when the Alignment manipulator
is activated:

■ Center Pivot - Aligns the pivot with the center of the selected object.

■ Align Pivot - Aligns the pivot with the coordinate system.

■ Invert Pivot - Inverts the pivot at its current position.

Orientating the manipulator’s pivot

The Orient Pivot option aligns the pivot with a face of the selected object.

1 Do one of the following:

■ Select 3DScene > Edit Pivot > Orient Pivot.

■ Click the Orient Pivot icon  in the Toolbar.
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The pointer changes to.  .

2 Place the pointer over a vertex. It changes to  , indicating that you
can select the vertex.

Select three vertices to define an alignment with the principle axis aligned
with the normal of the triangulation.

3D primitives and objects Parameters Window

You can change the name, position, rotation, scaling and color of a 3D
primitive and objects in the Parameters Window.

1 Click an object label in the 3D Scene folder of the Project window to
open its properties in the Parameters Window.

2 Enter the values you want to change.

■ Label - Shows the name of the object.
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■ Type - This field is read only. Shows the type of 3D object. Primitive
for a simple object created by MatchMover, Imported scene for an
imported file or a light.

■ Pos. X, Y, Z - Shows the object position in the active coordinate system.

■ Rot. X, Y, Z - Shows the object rotation in the active coordinate system.

■ Scale X, Y, Z - Shows the scaling value for each axis.

NOTE Click the Uniform Scaling option to scale in all three directions at the
same time.

■ Color - Shows the object color. Click the Color box to open the color
editor and to modify the colors.

NOTE The color is used in Flat/Transparent modes only.

Stacking objects

You can stack or reposition objects by defining a plane to which a 3D object
snaps.

1 In the 3D View, select a 3D object that you want to stack or reposition
in the scene.

2 Do one of the following:

■ Select 3DScene > Edit Pivot > Align Mesh.

■ Click the Align Mesh icon  in the Toolbar.

3 Place the pointer over a 3D Helper. It changes, indicating that you can
select the 3D Helper. Select three 3D Helpers in either a clockwise or
counter-clockwise direction using the same method for selecting track
points. See Selecting tracks on page 134.

The object snaps to the plane and the principle axis is aligned with the normal
of the triangulation.

NOTE To change the color of the mesh, select Edit > Preferences, click the Color
tab in the User Preferences window, and change the color of the corresponding
sample box.
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Illuminating your scene

Lights are used to illuminate your scene. Lights in the 3D View are directional
lights. They are created at the origin of the 3D world. By default, a diffused,
ambient light illuminates the whole of the scene.

Creating a new light

You can move lights around in the 3D View without changing the lighting;
only the light orientation is important.

As soon as you insert a new light, the effects of the default lighting disappear.

To create a new light, do one of the following:

■ Select 3D Scene > New Light.

■ Click the Light icon  in the Toolbar.

■ Right-click the 3D Scene folder in the Project window or anywhere in the
3D View and select New Light from the pop-up menu.

A new light appears in the 3D Scene folder of the Project window.

NOTE To change the default color of the lights, select Edit > Preferences, click
the Color tab in the User Preferences window, and change the color of the
corresponding sample box.

Editing lights

By default, when you place a light within a scene it is surrounded by the
General manipulator. Lights are edited in the same manner as physical 3D
primitives. See Editing 3D primitives and objects on page 207.
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Changing the size of the non-physical objects

To change the size of any non-physical objects in a scene, for example, lights
and cameras:

1 Select Edit > Preferences > Display.

2 Enter a number in the 3D Icon Size text field. A smaller number reduces
the size of the non-physical object; a greater number increases their size.

The 3D Icon Size is also reported in the Global Parameters Window.

Rendering the sequence
To generate a preview sequence you can create a sequence of any available
format, depending on your platform, for example, AVI, QuickTime, single
image files, using the Render function. By doing this you can examine the
estimated camera path quality.

If you have configured the render process, select 3D Scene > Render.

If you have not configured the render process:

1 Select 3D Scene > Render Setup. The Render Setup window opens.

2 The File Name field automatically points to the last directory used for
rendering. If you click Render without entering a filename, a window
pops up asking you to enter one. If this is the case, choose a destination
directory and enter a File Name.

214 | Chapter 4   User Guide



3 From the drop-down Size list, choose the size you want for the rendered
image. Full image renders the whole image. Crop to viewport only renders
the portion of the image visible in the current viewport at the moment
you open the Render Setup window. Each time you open it the area to
render is updated.

4 From the Resolution drop-down list, choose the resolution percentage.
Choose the option User to define a custom size.

5 To determine the section of the sequence to render, select an option in
the Length drop-down list.

■ Full Length renders the whole sequence.

■ Time range renders the sequence within the time range at the moment
of the render.

■ User renders the sequence frames entered in the adjacent fields.

■ Work Area renders the sequence within the selected Work Area.

6 Check the Antialiasing box if you want the object edges to have a clearer
appearance. This is important if you want to check for very small,
sub-pixel vibrations of the object, but slow down the process.

7 If you have distortion in the original image, check the Distortion box.
This applies the non-linear distortion to the object while leaving the
background image intact.

TIP If you do not check this box in a shot where you computed a non-zero
distortion, the objects appear to slide slightly with respect to the background
image motion. This is normal, as they are rendered without taking into
account the geometric parameters of the camera.

8 Select a render opacity for the 3D objects from the drop-down list:

■ Flat - Solid objects

■ Wireframe objects

■ Texture - Solid objects textured with the background from the
corresponding imported objects.

9 Click the Render Only 2D Visible checkbox to render only the 3D points
in a frame if the corresponding 2D track is defined for this frame.

10 Click the Render Hidden Points checkbox to render hidden tracks. Hidden
tracks are not rendered by default.
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11 Click Setup if you want to customize the output format (compression
factor).

12 If you want to save and run the rendering process immediately click the
Render button. If you want to save your setup but not run the rendering
process click the Close button.

Importing and exporting

Importing files
You can import files with the following formats:

■ REALVIZ Ascii Point Tracks (*.rz2)

■ REALVIZ Ascii Camera 3D Tracks (*.rz3)

■ REALVIZ XML (*.rzml; *.rzi; *.rzs)

■ Alias|Wavefront Ascii Model (*.obj).

To import a file:

1 Select File > Import to open the window.
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2 Use the Files of type drop-down list to show files with the same format
only or select All Files to show all files.

3 Select the file to import and click Open.

TIP You can simply drag and drop any kind of known file in the Workspace
area to automatically import it.

Importing REALVIZ Ascii files

If you have a REALVIZ Ascii Point Tracks RZ2 file containing data on point
tracks, you can import it into MatchMover.

TIP If you have re-scaled the film, the points are re-scaled when you import them
to match the new resolution of the images.

If you have a REALVIZ Ascii Camera 3D Tracks RZ3 containing either
cameras/and or points, you can re-import it. If no 2D tracks correspond to the
imported 3D tracks, dummy tracks are created.

Importing REALVIZ XML files

You can import REALVIZ XML file within MatchMover. This file can come
from any other REALVIZ software, such as ImageModeler. This format is also
used to communicate with the MMTrack plugins family. This imports a whole
scene, so it's suggested to start a new project before importing such a file.

Importing Alias|Wavefront Ascii Model

If you have an Alias|Wavefront OBJ file it can be imported into MatchMover.
When imported, MatchMover treats the file as a scene keeping the original
polygonal geometry along with the colors and textures within the original
file.

You can only import polygonal objects. See Importing 3D objects on page 206.

NOTE Textures are loaded only if they are in a MTL file with the same name as
the corresponding OBJ file.
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Exporting files

Export file formats
MatchMover supports the following file formats.

ExtensionFile format

*.ms3ds max

*.c4dCinema 4D

*.cwsCombustion

*.nkDigital Domain NUKE*

*.actionDiscreet Flame

*.actionDiscreet Flint

*.actionDiscreet Inferno

*.lwsLightWave 3D

*.maMaya

*.movQuickTime

*.rz3REALVIZ Ascii Camera 3D Tracks

*.rz2REALVIZ Ascii Point Tracks

*.rzmlREALVIZ RZML

*.xsiSOFTIMAGE|3D

*.xsiSOFTIMAGE|XSI

*.vbsVisual Basic

*Using a Perl script
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Setting the up axis
Before exporting your project, you may want to set the up axis to facilitate
the manipulation of your scene in your 3D package.

To set the up axis:

1 Select Project tab in the Parameters window.

2 From the 3D Up axis drop-down list, select either X, Y, or Z.

MatchMover sets the up axis as required.

NOTE You should set up the up axis before launching the solver, this way it will
be taken into account correctly.

Reconstructing 3D points for export
You may want to add more point tracks to a scene, for example, to export
them to a 3D package, or manually track them. See Supervised 2D tracking
on page 132.

In MatchMover, you can construct them in 3D automatically without
re-running the calibration process. 3D point reconstruction is triggered when
the Reconstructed in 3D option in the point track Parameters Window window
is checked.

The option is checked by default. If you edit a track, add a key, edit a key, or
merge tracks, reconstruction is performed automatically providing that enough
2D information is available on the key or computed points in a minimum
number of frames.

NOTE If you right-click any point in the Point Tracks folder in the Project window
or the Track window, the option Reconstructed in 3D is checked in the pop-up
menu, indicating that the point is reconstructed in 3D.
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Exporting a project

1 Select File > Export  . The Export window opens.

2 In Save as type, select a file format from the drop-down list of formats
supported by MatchMover.

3 Type a File Name in the corresponding text field.

4 In 3D Points, click either:

■ Selected (if you want only those point tracks you have selected).

■ All tracks that match at least one criterion in each column. Manual,
Automatic, or both, and the quality of the points (Good, Fair, Bad).
For example, if you check Manual and Good and Fair, only hard tracks
with yellow and green icons will be exported. Regardless of quality,
no soft tracks will be exported.

5 Choose an Animate radio button. For certain formats both Camera and
Scene radio buttons are available. If you select Camera, the 3D points are
fixed and the camera moves. If you select Scene, the camera position is
fixed and the 3D points move.

■ If enabled, you can set a first frame index to select the frame in the
3D package when the current solve will start.
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■ If enabled, you can set a point scale that will be used to scale all the
exported 3D tracks.

6 Click Save.

NOTE The Export toggle boxes show the type of data to export. All track
groups are exported as such, and mobile points are animated.

Exporting REALVIZ Ascii Camera 3D Tracks (.rz3)
Use the procedure described in the Exporting a project section. See Exporting a
project on page 220. From the Save as type drop-down list, select REALVIZ Ascii
Camera (.rz3).

MatchMover exports only the camera and static 3D tracks associated to the
current sequence (contained in the current time).

NOTE If you have several sequences you must change the current time to export
the associated camera of each sequence.

MatchMover creates an Ascii file as follows.

imageSequence "Sequence00"

{ 720 576

f("\\Spirou\public\images\MatchMoving\sgi320.avi" ) b(

0 238 1 ) -even}

Camera

{0 F ( 943.095 ) Pr ( 1.06667 ) Pp ( 360 288 ) K ( 0 )

Oc ( -42.4206 67.3594 -19.604 )

Rot ( 0.793155 0.598043 -0.115111 -0.158493 0.38519 0.909125

0.588035 -0.702832 0.400301 )1

F ( 943.095 ) Pr ( 1.06667 ) Pp ( 360 288 ) K ( 0 )

Oc ( -41.9334 67.8446 -19.764 )

Rot ( 0.795385 0.594972 -0.115633 -0.157956 0.387665 0.908166

0.58516 -0.704077 0.402323 )

}PointTrack Track00 (4.79921 0.0732729 1.00537)

PointTrack Track01 (-0.00894661 0 0)

PointTrack Track02 (-0.00894661 1.37239 10.0013)

■ The label imageSequence  contains the name of the sequence in the Project
window.

■ The values 720 and 576 refer to the size of the image.
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■ f( "\\Spirou\public\images\MatchMoving\sgi320.avi" ) gives the full
path name of the sequence.

■ b( 0 238 1 ) refers to the begin, end and step values.

■ -even defines the type of interlace which can be Upper field first or
Lower field first. The default value is no interlace if no type is specified.

■ Camera
The first line gives the frame number.

■ F indicates the focal length in pixels, defined as focal length (mm)
times image width (pixels)/film back width (mm).

■ Pr indicates the pixel aspect ratio.

■ Pp indicates the position of the principal point.

■ K indicates the distortion value.

■ Oc indicates the Camera position (X, Y, Z).

■ Rot indicates the three lines of the Matrix of rotation. The last line of
the Matrix, the last three coefficients, also represents the direction
along which the camera is pointing, expressed with respect to the
reference coordinate system.

■ The remaining lines of code give the Point Track label and its X, Y and
Z coordinates.

You can edit this file and re-import it into MatchMover.

Exporting REALVIZ Ascii Point Tracks (.rz2)
Use the procedure described in the Exporting a project section. See Exporting a
project on page 220. From the Save as type drop-down list, select REALVIZ
Point Tracks (.rz2). MatchMover exports only the point tracks of the current
sequence.

TIP If you have several sequences you must change the current time to export
the point tracks of each sequence.

You can edit this file then re-import it into MatchMover.
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The file created contains four object type descriptions, the tracks, the computed
2D points, the keys and the sequence corresponding to the file (a file equals
a sequence).

Sequence

This is the first information contained in the file.

imageSequence "Label"

{360 243 f("path") b(0 38 1) -Upper field first/-Lower field

first}

The label can contain letters, numbers, spaces and underscores. It must be
contained within quotation marks and is optional.

The numbers 360 and 243 correspond to the film resolution, width followed
by height.

The path indicates the position of the file. It is shown by f("...").The path is
optional.

b(0 38 1) indicates the start, end and step of the sequence and determines the
tracked point Id. Start, end and step are whole numbers. This element is
optional and if omitted the start value is 0.

For example, if b(15 50 1), the tracked point Id is numbered between 15 and
50. When you open the file with a sequence that starts at 0, the tracked point
Id is automatically re-numbered between 0 and 35. However, if you want to
keep the original Id you must change b(15 50 1) to b(0 35 1).

-Upper field first/-Lower field first specifies the interlacing of the film.
If there is no parameter, there is no interlacing. Otherwise, you must specify
it with Upper field first or Lower field first.

Track

pointTrack "Label" -nc -nr rgb( 64 0 128 )

{

...

}

The label can contain letters, numbers, spaces and underscores. It must be
contained within brackets and is optional. The Label is useful to complete a
track when one sequence follows another (there are two files). During the
import of the second file, the tracks with the same label are completed.

If nc is specified this indicates that the track is not used for 3D calibration.

If nr is specified this indicates that the track is not reconstructed in 3D.
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The color rgb (red, green, blue) is optional.

The track contains the points and the corresponding keys.

Keys and points

For the keys:

Id X Y kb(threshold) s(top bottom right left ) p(top bottom

right left)

■ Intermediate key -> ki (threshold).

■ Automatic key -> ka (threshold).

■ Begin key -> kb (threshold).

■ End key -> ke (threshold).

■ Single key -> ks (threshold).

■ s(...)corresponds to the search area.

■ p(...)corresponds to the pattern area.

For the points:

Id X Y p+( score ) -ncp

Id indicates the frame number relative to the start of the sequence.

X and Y indicate the coordinates of the key or point from the upper left corner.

For the points:

■ p+(score ) Point obtained from a backward track.

■ p-( score ) Point obtained from a forward track.

■ p*(score) Point obtained from a bi-directional track.

If ncp is specified, this indicates an incomplete track point.

If there is only Id X Y, this means the creation of a single key with default
parameters.
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Creating a minimal rz2 file

For each track:

Track point

{

Id CoordX CoordY

Id CoordX CoordY

Id CoordX CoordY

Id CoordX CoordY

Id CoordX CoordY

... }

Maya export
The Maya export function allows you to create a Maya Ascii file (*.ma) to
import all MatchMover’s 3D geometry into Maya software versions 2.0 and
later. All 3D geometry is exported as such, and mobile points are animated.

The generated file includes:

■ A root object called rzGroup that you can use to move the entire scene
exported from MatchMover.

■ A camera object with animated transformation, focal length and clipping
planes (the clipping planes are initialized to bind the reconstructed points
cloud. You may need to modify them if you add some objects to the scene).

■ All 3D objects in the project.

■ An image plane, eventually undistorted, attached to the camera with a
size and coverage initialized to assure the right matching between the
camera aperture and the tracked sequence.

■ A set of locators for each reconstructed point track.

■ Presets for render resolution.

■ Synchronized cameras with their respective image planes in case of a
MOCAP project.

Depending on your default Maya preferences parameters, you may need to
adjust your viewport settings in order to display the textured sequence:

1 Apply shader using Shading > Smooth Shade All.

2 Texture sequence using Shading > Hardware Texturing.
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You can now look through the tracked camera using Panels > Perspective >
rzCamera1.

Create or import some scene objects and lights and set their positions using
the predefined locators transformations, then render some preview images
with Render > Render into New Window.

For more information about Maya camera and image planes, refer to “Maya
User Guide.”

SOFTIMAGE|3D export
MatchMover generates an Ascii file of the type XSI that can be imported into
SOFTIMAGE |3D using the following procedure.

NOTE MatchMover has separate exporters to Sotfimage |3D 3.8 (.xsi version 1.3)
and Softimage |3D 3.9 (.xsi version 3.0). The latter is more complete and can
perform camera animation using constraints, which is easier to manipulate than
the motion paths used in the former.

1 Select Tools > Import > Objects > Ascii Import. A window opens.

2 Select the XSI file exported by MatchMover. When the process is complete,
the camera and the 3D points have been imported into Softimage.

3 To verify the import, choose a Perspective viewport and move the time
line.

Compositing in Softimage (Rotoscoping)

The images must be of the Softimage (PIC) format. To convert an AVI sequence
or images into another format. See Conversion of AVI and other formats to
Softimage PIC format on page 227.

1 In the Perspective viewport, go to SHADE > Rotoscope (wire). The
Rotoscopy window opens.
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2 Click the Select button and choose the image sequence.

3 Choose Play Sequence in the Playback options.

4 Adjust the Use Frames fields and if necessary the Sync Frame field when
there is a difference between the number of the first frame exported by
MatchMover (generally 0) and the number of the first image.

Conversion of AVI and other formats to Softimage PIC format

The Softimage image format defines the image Pixel Ratio and this is taken
into account for the image display in the viewports. It is crucial that you
export the image with the correct pixel ratio, which by default is always 1.
Amongst the executable files supplied by Softimage, tga2soft allows you to
specify the Pixel Ratio with the option -p. One solution is to convert the AVI
into PIC, then the PIC into TGA then the TGA into PIC.

To convert file formats:

1 From the MS DOS prompt window, move to the directory containing the
Softimage binaries.

2 Use the following commands provided by Softimage.

■ Avi2soft

■ Soft2tga

■ Tga2soft
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For example, to convert an avi file composed of 25 images with PAL pixel
aspect ratio (1.0666) into the Softimage PIC format, enter: avi2soft sequence.avi
sequence -s 1 25 1, soft2tga sequence sequence -s 1 25 1, tga2soft sequence
sequence -s 1 25 1 -p 1.0666.

SOFTIMAGE|XSI export
When exporting for SOFTIMAGE|XSI, MatchMover creates two files: a dotXSI
file and a .vbs file. You don’t need to import dotXSI file by yourself, open the
.vbs file in the script editor and it will load the exported scene and set all
needed parameters for rendering:

1 Open the script editor using: Application > Views > Script Editor.

2 Select File > Open... in the script editor.

3 In the window that open. Select the “.vbs” file exported by MatchMover.

4 Select Run.

The XSI format does not specify whether the FOV is horizontal or vertical.
SOFTIMAGE|3D reads it as vertical, while SOFTIMAGE|XSI reads it as
horizontal.

You will therefore need to adjust it when import completed.

The imported scene includes:

■ A root object called rzGroup which you can use to move the entire scene
exported from MatchMover.

■ A camera object with animated transformation and focal length.

■ All 3D objects in the project.

■ An image plane, eventually undistorted, attached to the camera with a
size and coverage initialized to assure the right matching between the
camera aperture and the tracked sequence.

■ A set of locators for each reconstructed point track.

■ Presets for render resolution.

■ Synchronized cameras with their respective image planes in case of a
MOCAP project.
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You may need to adjust your viewport settings in order to display the textured
sequence.

If you wish, you can delete this image plane and use rotoscopy options of
SOFTIMAGE|XSI:

1 Select the Rotoscope mode.

2 Edit the Rotoscope options.

3 Select Camera Rotoscopy > General > New > New from file.

4 In the window that opens, select your video file.

5 In Source Info, adjust the frame rate if necessary.

6 In Time Control > Source Clipping, adjust “out frame” to your video
length-1 (number of frames displayed in Source Info).

LightWave 3D export
The LightWave 3D® scene exported by MatchMover can be imported as is in
LightWave 3D.

MatchMover produces a LightWave 3D scene file, a LightWave object for each
3D object in the project and a LightWave object used to create an image plane
for each exported camera.
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Select File > Load Scene. The scene contains the tracked camera, the 3D points
as “null object” and information about the pixel aspect ratio. The output size
is also automatically set.

The scene contains:

■ A root object called rzGroup which you can use to move the entire scene
exported from MatchMover.

■ A camera object with animated transformation and focal length.

■ All 3D objects in the project.

■ An image plane, eventually undistorted, attached to the camera with a
size and coverage initialized to assure the right matching between the
camera aperture and the tracked sequence.

■ The 3D points as “null object”.

■ Presets for render resolution.

Synchronized cameras with their respective image planes in case of a MOCAP
project.

Compositing in LightWave 3D

If you wish, you can delete the image plane and use the sequence in LightWave
3D as a background image.

Refer to “LightWave 3D User Guide” for more information.

To use the sequence as a background image:

1 In the Images Panel choose Load Sequence, and choose an image in your
sequence.
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NOTE Correctly set the frame offset. If your sequence numbering does not
begin at 0 and you enter 1, this would mean that “foo0001.tga” corresponds
to frame 0 in your animation.

2 In the Options Panel choose OpenGL as Layout View Graphics and BG
Image as Layout Background.

3 In the Effects Panel, click the Compositing tab and select your sequence
from the Background Image combo.
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Now you can start animation on top on the tracked sequence.

Working with interlaced sequences

If your background sequence is interlaced, you should check the Interlaced
box in the Images Panel.

1 In the Camera Panel, check the Field Rendering box.

2 If you chose Lower field first as the interlace type in MatchMover, check
the Reverse Fields box.
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Now you can render your interlaced sequence.

TIP If there is a slight apparent motion of the virtual objects with respect to the
background image, make sure that you have chosen the right field rendering type
and the right frame offset for your sequence.

MAXScript export
The MaxScript generated by MatchMover allows you to import the camera
trajectory and the 3D points calculated by MatchMover.

1 Choose Utilities > MAXScript > Run Script.

2 In the File window, load the MAXScript that you have just created with
MatchMover.

After the loading the scene contains:

■ A root object called rzGroup which you can use to move the entire scene
exported from MatchMover.

■ A camera object with animated transformation and focal length.

■ All 3D objects in the project.

■ An image plane, eventually undistorted, attached to the camera with a
size and coverage initialized to assure the right matching between the
camera aperture and the tracked sequence.
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■ The 3D points as “null object”.

■ Correct render settings.

■ Synchronized cameras with their respective image planes in case of a
MOCAP project.

Rendering

Select Rendering > Render from the menu or Render Scene from the toolbar.

Interlaced sequence

If the original sequence is interlaced and you want to keep the same fluidity
of movement, you have to render in interlaced mode. To do this, check the
Render to Fields box.

When you do this you must keep the exact original image size so that each
synthesized frame superimposes exactly on the original sequence.

To keep the frame order the same as that used in MatchMover, it may be
necessary to modify

the frame order in 3ds max.

1 Select File > Preferences from the main menu and open the Rendering
page.

2 Select the correct order in the Field Order radio buttons.

Compositing in 3ds max

It is possible to do the compositing directly in 3ds max in order to merge live
action with a computer-generated model.

If you wish, you can delete the image plane and use the sequence as a
background image.

The following procedure represents the simplest way to define a background
image concerning the pixel aspect matching. When this is done correctly, the
background image should exactly match the 3D.

1 Select Rendering > Environment.
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2 Define an Environment Map of the type Bitmap.

3 While keeping the Environment window open, open the Material Editor
from the toolbar.
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4 Drag and drop the Map #1 (Bitmap) to a channel of the material editor
using the Instance method.

5 In the Material Editor, choose the image to use as the background.

6 Set Bitmap > Parameters > Filtering to none.

7 Set Coordinates > Mapping to Screen.

8 Select Views > Background Image and check the Use Environment
Background box.
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If the matching between the background image and the 3D is not “clean”,
there are two possible reasons.

■ The start of the sequence does not correspond to the start of the camera
trajectory. In Material Editor > Time, change the Start Frame field for the
environment map.

■ The background image is interlaced but when 3ds max does a filtering,
you have the impression of a mismatch in the camera view. However the
render is okay. You can solve this display problem by creating a
non-interlaced sequence and by using it as the background image while
keeping the interlaced environment map.

Other problems

Sometimes, when your sequence contains very far points, the 3ds max camera
can have problems calculating the clipping planes (the objects situated in
front of the camera are not visible in the camera view). If this is the case, you
must use the manual clipping mode and define the near and far parameters
of the clipping.

Exporting to combustion from Discreet
Exporting your MatchMover project to combustion--the paint, animation,
and 3D compositing software from Discreet--is a straightforward process.
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1 Save your project with the combustion extension *.cws (combustion
workspace).

The file contains essential MatchMover information, such as the camera
or helper path, the camera FOV animation, link to the video or sequence
of images, and other video information.

2 Run combustion.

3 Open the file by doing one of the following:

■ Select File > Open Workspace.

■ Press Ctrl+Shift+O.

4 Select Workspace. When the CWS file is opened, combustion loads the
video or image sequence.

5 Now edit the project.

Shake export

Shake track files

All chosen tracks are exported as individual Track Files in order to be used as
input for the Shake® MatchMove or Stabilize nodes. While these files only
contain 2D information, the exported values are not simply the result of 2D
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tracking, but the 2D projection of the 3D reconstructed points. The main
advantage is that the point coordinates are known even though a point may
move out of the image.

Shake script

MatchMover generates a Shake script containing the following information:

■ Four point tracks that will be used as input data by a MatchMove node to
perform corner pinning.

■ A warping grid to apply distortion to your CG elements so they can
integrate perfectly with distorted footage.

■ A warping grip to remove distortion from the original footage.

The window controls for this export are quite different from the other ones.
Unlike other exports formats, you cannot have an arbitrary number of points.
Shake controls require you have one, two, or four points for a matchmoving
process.

Use the drop-down boxes to choose the points to export. The corner indications
are only valid if you want to perform a four-point corner pinning.

Point order is important: the arrow buttons swap points and let you reorder
them.
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NOTE You can provide several sets of 4-points that will each generate a
corresponding MatchMove node. Set the total number of sets in the “Nb of sets”
spin-box, and select the current one in the “Current set” spin-box.

TIP The boxes contain initially the first four points in the selection, if any. Selecting
your points of interest before calling the export window will save you time and
effort.

In Shake, load the script by selecting File > Open Script and choose your file.

The Node View then contains the following nodes:

■ rzVideo is a “FileIn” node containing your video. You may edit the
imageName if it is incorrect, which may happen if you are working not
on the same computer that you used to run MatchMover.

■ rzMatchMove is a “MatchMove” node containing all the information to
perform your composition operation. Load another image or video, connect
it to the second input of the rzMatchMove node, then enable it by opening
its properties, toggling the applyTransform parameter to active, and change
the outputType to Over. You may also have to change the source X and
Y positions if your source is of a different size of you want to crop it.

NOTE If several sets of points have been provided, additional nodes will be
numbered (e.g., rzMatchMover 2 ...).

■ rzDistort is a “WarpX” node designed to apply distortion to any CG
element before compositing it with your footage. If the latter has no
distortion at all, this node is no use to you and you can delete it safely.
rzUndistort is a “WarpX” node designed to remove the distortion from
the original footage.
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Cinema 4D export
Scenes exported by MatchMover can be read directly in Cinema 4DTM; all
points are exported as Null objects.

Select File > Open and choose the *.c4d file exported by MatchMover.

Compositing with your footage requires some extra manipulations.

1 Create a background object by selecting Objects > Scene > Background.

2 Open the Material Manager window and create a new Material by
selecting File > New Material.

3 Open the Material Editor by double-clicking on the newly created
material.

4 Open the image browser by clicking on the Image button and choose
your video file.

5 Press Edit to open the Time Controls.
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6 Set the first frame, last frame and appropriate Frame Rate. Also set the
Timing to Exact Frame.

7 Add a Texture property to your Background Object.

8 Set it to the newly created material. Change the projection to Planar.

Inferno export
MatchMover generates an Actionsetup that can be read by Discreet’s Flint,
Flame, and Inferno.

1 Open the Action module and choose your clips for composition.
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2 Select Setup > Load then choose the Action setup exported by
MatchMover. All points appear as individual helpers in the Perspective
view.

TIP Each point will have its own node in the Schematics view. Automatic
tracking will generate hundreds of points, which, without filtering, will quickly
clutter your Schematics view. It is therefore recommended to select the
points of interest and export these only. See Reconstructing 3D points for
export on page 219.
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Motion Capture Module

About the Motion Capture Module
Motion Capture is the ability to track in 3D the motion of a non-rigid object,
like a human body or face or a piece of cloth. This is a special case compared
to rigid moving objects or standard matchmoving, because, for each frame of
the footage, the position of any non-rigid track is totally independent from any
other previous position, or any other track. Therefore, its 3D position cannot
be computed from a single view. To be able to compute the depth of such a
track, you must see it through at last two different viewpoints.

So, the basic setup for doing MOCAP (Motion Capture) is to have two
synchronized cameras shooting at the same scene, therefore producing two
different viewpoints of the same deformable scene.

The MatchMover Motion Capture module is able to cope with any number of
synchronized cameras, at different frame rate and resolution each, although it’s
easier if all the cameras share at last the frame rate. Cameras can be either fixed
or moving. If all cameras moves, the camera motion in respect to the background
should be computable through standard matchmoving process using the scene
background.

Loading and synchronizing your sequence

Loading

The sequence loading process is almost the same as for standard matchmoving.
The only difference is that you have to load the two synchronized sequences
last. A new “fixed” camera constraint is added to handle fixed camera cases (no
rotation, no translation...). You can easily set this constraint directly in the Load
Sequence window. Note that each camera device associated with each loaded
sequence is assigned a different color:

5

245



This color can later be changed in the camera’s Parameters window, and is
used to quickly identify which data goes with which camera.

The camera color will be used for:

■ The Project window: the camera label and corresponding sequence label

■ The Track View: the camera frame bar and the corresponding sequences
ones

■ The viewport: the camera / sequence labels displayed at the top, and the
3D camera icons.

Synchronization

Synchronization information is displayed in each sequence’s Parameters
window under the General settings:
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Here is the information that should be provided:

■ Frame rate: Enter the frame rate of the sequence. See note below about
using different frame rates.

■ Synchronized at Frame check box is used to specify if this is a synchronized
sequence. You should then enter a “synchro frame”. This “synchro frame”
is used like a synchronization tick, which means it is just an absolute time
reference that will be used to synchronize all sequences. For example, the
frame number 10 in sequence 1 is shot at the same time as frame 25 in
sequence 2. Then you can use these values for the synchronization tick.

NOTE You can use here floating values for the synchro tick, like 10.5, if you
know accurately your setup. Note that a sequence icon is shown with a little

clock  in the Project window to show that it is synchronized.

Viewport configuration

You can configure the viewports to automatically synchronize their content.

Just toggle the Synchronize Time  icon for each viewport you want. In
this case, when a viewport is synchronized, it will stay locked on its current
sequence, and display the frame synchronized with the global current frame.

To change the current sequence of a viewport, select the viewport and set time
to a frame of the new sequence. For example, switch to two viewports layout,
and toggle Synchronize Time for both. Select the first viewport and jump to
a frame in the first sequence, then select the second viewport and jump to a
frame in the second sequence. Then when you play, both viewports should
be synchronized.

Synchronous frame navigation

The current camera and sequence information, colored with respect to the
camera, is displayed at the top of each viewport next to current time, displayed
in green for synchronized viewports so you can easily identify your setup.
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When on a synchronized viewport, you can easily switch to the synchronized
frame in other sequences using different methods, either using the menu
entries (Next/Previous Synchro Frame, default shortcuts PgUp, PgDn), or by
right/left clicking on the camera label at the top of the viewport. If the viewport
is in 3D free navigation mode, all the synchronized cameras will be displayed,
with non-current ones darker.

You can also simply click any camera icon to select it and switch to its
corresponding synchronized frame.

NOTE Although the solver is able to cope with different frame rates, this setup
will of course introduce more complexity in the process, and is not recommended.
Note that in this case, the first loaded sequence will be used as the time reference,
and other sequences will be mapped onto it. That means that the exported project
will share its frame rate with the first sequence (this might be customizable in a
future version).

Building and tracking a MOCAP group
Building a MOCAP group

Building a MOCAP group is as simple as building a group for a rigid moving
object: just create a track group, and select “non-rigid motion” in its options
attribute. Then, all tracks located in this group will be considered as non-rigid

ones. MOCAP groups are displayed with green arrows in the tree view  .

Adding MOCAP tracks

You have to create your tracks and track them as in a standard matchmoving
workflow, except that automatic tracking will not make the match between
several sequences. Note that if the MOCAP group or a MOCAP track is already
selected when creating a new one, the new track will automatically be added
to the MOCAP group.

Adding other tracks

Of course, you’re still able to add other kind of tracks, fixed, or rigid ones.
These one can be used to make the solution more robust or track the motion
of a moving camera. Note that for fixed cameras, fixed tracks need to be set
only on one frame of the sequence. Other frames will then automatically be
displayed as “implicit” in the Track View.
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Solving

The solving is done the same way: just hit F9! Note that some special things
are done with keyframes/reference frame: they are automatically set on all
synchronized frames. For example, if you add a keyframe in the first sequence,
the synchronized frame in all the other sequences will also be set as a keyframe.
This should be the same for reference frames if the project contains only
motion capture tracks: the solver will not be able to start if the reference frames
are set on two non-synchronized frames.
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Glossary

Glossary
When working with Autodesk MatchMover you have to understand a few of
the basic key concepts from the worlds of 2D and 3D.

Angle - Field of view (FOV) in degrees. 30 corresponds to the normal lens of 35
mm still camera.

Antialiasing - Antialiasing is sub pixel interpolation, a technique that makes
edges appear to have better resolution. Antialiasing is process to render an image
at a higher resolution than the screen can display (typically two to four times
higher linear resolution). This high-resolution result is then filtered down to
the screen resolution, eliminating most visible rendering errors.

Cache - A block of memory, generally of fixed size, that is used to store data
loaded from the hard disk. Reading data from cache memory speeds up
processing as it is faster than reading data from disk.

Channel selection button  to help optimize 2D tracking shown in the
bottom left corner that toggles display of a single color channel. Clicking on it
cycles through RGB, R, G, B, and Alpha, when available.

Dolly - Moves the camera along the line of sight, i.e. close and far from the
target. Term originally refers to the carriage under the camera stand, pushed on
wheels along rails.

Film Back - Value that represents the size of your film.

FOV - Field of view.

Interlace - Division of video frames into halves (odd and even), or fields, increase
the frame rate without increasing the needed bandwidth.
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Motion blur - A method of blurring images to create the effect of speed and
movement.

Occlusion - The effect of one object in 3D space blocking another object from
view.

Pan - Rotates the camera along vertical axis, that is, moving camera target
sideways.

Parallax - Changes the perspective between two adjacent pictures caused by
the camera position changing between shots.

Pixels - Array of picture elements, usually consisting of red, green, and blue
color values, each with five to sixteen bits of precision.

Rendering - The process used by MatchMover to create images from the data
files.

Rendering algorithms - Algorithms that create images from models.

Rendering Engine - Generically applies to the part of the graphics engine that
draws 3D primitives, usually triangles or other simple polygons. In most
implementations, the rendering engine is responsible for interpolation of
edges and ‘filling in’ the triangle.

Rendering packages - programs that implement rendering algorithms

RGB - Red-green-blue color models.

Roll - Rotates the camera along the line of sight. If animated, a swaying effect
is achieved.

Scene - Defined by a data structure known as the scene database.

Scene database - Database which provides a mathematical representation of
the virtual objects in the scene and their position relative to each other.

Scene management - The process of updating the scene database definitions
as objects move or change.

Scene space or world space - The coordinate system of a scene.

Screen space - The 2D coordinates of pixels on the display device plus a third
coordinate that defines the distance from the view point.

Sub-pixel accuracy - A method of estimating movement to the nearest 1/5th
of a pixel rather than one pixel.

Tilt - Rotates the camera along the axis perpendicular to the line of sight, i.e
moving target vertically. If animated, a nodding effect is achieved.
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Transformation - Change of coordinates; a series of mathematical operations
that act on output primitives and geometric attributes to convert them from
modeling coordinates to device coordinates.

Track - A track is anything that is animated over time. In MatchMover Pro,
these are the point tracks

Vector - Segment showing the displacement of a given pixel from one frame
to the next one.

View point - A virtual camera (analogous to the position of the camera in
photography).

Z values - (x, y) distance values.

Zoom - Changes the field of view.
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Mode

button 74
tracking, automatic 127
tracking, supervised 132
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automatically generated 129
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2D View
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navigation 78
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viewing the results 129
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bookmarks
deleting 113
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browsing the footage 85
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Cache Manager 107
cache size, setting 106
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camera computation 67
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the mesh 212
the Track Path 77
the Tracking Tool 136

the current frame using the Numeric
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divisions 82
the size of the 3D Helpers 82
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Channel Selection 251
cleaning up tracks 130
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a focal length constraint 179
a keyframe 122
a light 213
a post filter 200
a relation 173
frames to a constraint 180
keys to a curve 203

centering the view on the selected
item 79

clearing
computed points 149
keys 140

copying a contour 125

creating
a new camera 160
a new track 132

deleting
a bookmark 113
a camera 166
a constraint 181
a contour 121
a coordinate system 171
a keyframe 123
a matte 115
a sequence 112
an object 207
keys from a curve 203

displaying
the 2D View attributes 76
the 3D View attributes 82

duplicating a contour 126
editing

a key point type 138
a pivot 210
reference and key frames 159

ending a Work Area 95
freeing graph tangents 202
freezing the time 78
importing a scene 206
initializing frames 157
inverting a matte sequence 116
loading

sequences 108
locking

on the camera 84
the camera on a track 147
the grid axes 198

merging tracks 136
modifying a bookmark’s

position 112
pasting a contour 125
reconstructing a point in 3D 219
removing frames from a

constraint 181
resetting a curve 204
resizing

the Graph Editor graph 196
the Track Status graph 92
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returning
to the original zoom 79
to the start of the sequence 77

running
the camera solver 186
the tracker bidirectional 148
the tracker forward or

backward 148
selecting a manipulator 207
setting

frames to solve 186
the largest zoom in a

viewport 79
the world reference 172

showing
and hiding the original

curve 201
the grid 197

starting a Work Area 95
toggling a constraint 179
turning the camera toward the

selected item 85
Contour Edition Mode 118
contours 125

adding a keyframe 122
creating 117
deleting 121

a keyframe 123
duplicating 126
editing 123
renaming 120
selecting 119

coordinate system
centering on a camera 172
defining using the Parameters

Window 168
deleting 171
manipulator 170

locking the axes of 171
copyright ii
creating

a contour 117
a new camera 160
a new light 213
a new track 132
and enabling a constraint 178

curves
adding keys to 203
deleting keys from 203
editing tangents 201
manual edition of 200
resetting 203
smoothing using post filters 198

D

deleting
3D primitives and objects 207
a bookmark 113
a camera 166
a constraint 181
a contour 121
a coordinate system 171
a key 139
a keyframe 123
a relation 175
a sequence 112
frames

from a constraint 180
keys from a curve 203
point tracks 135

Display Toolbar 73
displaying

mattes 115
relation planes 175
the 2D View attributes 76
the 3D View attributes 81–82

drawing mattes 117

E

editing
3D primitives and objects 207
a curve manually 200
a key point type 138
a light 213
contours 123
curve tangents 201
reference and keyframes 158

elastics
setting survey points 177
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exporting
a project 220
Cinema4D 241
combustion from Discreet 237
file formats 218
Inferno 242
REALVIZ Ascii Camera 3D

Tracks 221
REALVIZ Ascii Point Tracks 222
reconstructing 3D points for 219
to LightWave 3D 229
to MAXScript 238
to Maya 225
to SOFTIMAGE|3D 226
to SOFTIMAGE|XSI 228

F

file formats
exporting 218
importing 216
motion control 183

file mask naming convention 110
flushing the cache 107
footage 59

importing 108
frame rate 62
frame rate, setting 109
frames

key 154
Free Camera mode 83
freezing the time 77
Full mode 69
full screen, toggling 74

G

Graded Ruler, description 89
Graph Editor Window

locking the grid axes 198
resizing the graph 196
toolbar 196

Grid Step, changing the value of 83

H

helper images 60
loading 111

hidden tracks 87
horizontal zooming 89

I

icons
2D Mode 74
3D Mode 74
Align Mesh 212
channel selection 251
Clean up tracks 131
Fit to Viewport 79
for adding new primitives 205
for changing the viewport layout 74
Full Screen 74
Light 213
Lock on Camera 84
Lock On Track 147
Locked 150
Navigator 79
New

Contour 118
Project 105
Track 132

Open 106
Orient Pivot 210
Pan 79
Project Tree 132
Recompute 204
Run the Automatic Tracking 10, 127
Run/Stop

Camera Solving 186
Track Bidirectional 148
Track Forward 148

scroll buttons 79
Smooth a time range 200
Time range

to linear 200
to spline 200

Undo 73
image plane display, toggling 80
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importing
3D objects 206
files 216
footage 108
motion control data 181

interface
description 69
Full mode 69
Light mode 69
Project Window 86
Time Line 193
Track Window 94

inverting selected tracks 135

K

key frames 154
key points

editing 138
moving 139
placing strategy 141
setting the parameters 142

of a single point 142
keyboard shortcuts 97

default 98
user-defined shortcuts 97

keyframes 67
and contours 122
editing 158

L

Light mode 69
Light Toolbar 72
lights

creating 213
editing 213

loading
helper images 111
mattes 113
sequences 108

loading a sequence 108
Lock on Camera mode 83
locking

on the camera in the 3D View 84
the camera on a track 147

the grid axes 198
tracks 149

looping a sequence 86

M

Magnifier
changing the behavior 96
fast refresh 151
Toolbox 97

manipulators
aligning the pivot of 210
Alignment 209
General 208
orienting the pivot of 210
Translate/Scale 208

mapping the coordinate system on a
camera 172

mattes 66
drawing 117
setting the properties of 115
toggling the display of 115

Maya Help
navigation buttons 3
overview 2

merging tracks 135
mobile tracks 87
Motion Capture Module 245
motion control 68, 181
moving a key point 139
multiselection of tracks 134

N

navigation
in the 2D View 78
in the 3D View 84

navigation buttons
Maya Help 3

O

object mapping 175
objects

deleting 207

Index | 259



editing 207
stacking 212
viewing 206

opening a project 105
orientating the manipulators’ pivot 210

P

padlock, Magnifier Wndow 96
Ping-Pong 86
play modes 86
Play Sequence toolbar 85
point

labels 75
point tracks

creating a new 132
deleting 135
merging 135
selecting 134

post filters 198
preferences

autocleaning tracked points 145
automatic key insertion 145
automatically merge tracks 136
changing

the 3D Grid Step value 83
the key frame default

settings 156
the Magnifier behavior 96
the number of wireframe

divisions 82
the size of non-physical

objects 214
the size of the 3D Helpers 82
the Toolbox size 97
the Track Path length 75

configuring the tracker 144
defining the search distance

precision 146
enabling the Auto Match Key

permanently 140
limiting the number of key

frames 157
predicting point positions in

successive images 145
resetting 107

setting
the graph smoothing

strength 200
the image cache size 106
the Key Frame Step value 157
the number of pixels to

nudge 145
the Quality Thresholds 146
the Tracking Tool’s pattern

size 146
the Tracking Tool’s search

size 146
the up axis 219

toggling
automatic key placement 145
the Auto Clean function 139
the current time display 77

tracking high/low-contrast
sequences 145

primitives
deleting 207
editing 207
stacking 212
viewing 206

Project Window 86
projects

exporting 220
managing 105
opening 105
saving 106
starting a new 105

properties
accessing sequence information 111
bookmarks 113
camera parameters 163
changing the size of the Tracking

Tool 137
constraints 179
coordinate system 169
cropping images 126
defining

the coordinate system 168
the Work Area 95

mattes, setting 115
modifying the position of a

bookmark 112
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relations 173
renaming a contour 120
sequence 110
setting the parameters of a single key

point 142
survey points 176
tracks 133

R

recomputing parameters 204
reconstructing 3D points for

exporting 219
reference frames, editing 158
refining the automatic 2D tracking

results 130
relations 67

creating 173
deleting 175
displaying in the 3D View 175

renaming a contour 120
rendering

a sequence 214
hidden points 215
only visible 2D tracks 215

resetting
preferences 107
the Graph Editor curve 203
the Work Area 95

resizing
the Graph Editor graph 196
the Track Status graph 92
viewports 75

running
the automatic 2D tracking 127
the camera solver 186
the tracker

forward or backward 147
in bidirectional mode 148

S

saving a project 106
scaling

uniform 212

selecting
a Play Mode 86
point tracks 134
points and contours 119

sequence
accessing information 111
deleting 112
loading 108
returning to the start 77

sequences, switching between 111
setting

frames to solve 185
key point parameters 142

of a single key point 142
matte properties 115
the current time 77
the frame rate 109
the image cache size 106
the largest zoom in a viewport 79
the world reference 171–172

Show in Contents 3
skipping

unsolved tracks 150
untracked frames 150

smoothing a curve using post filters 198
stacking objects 212
starting a new project 105
Status Bar 72
supervised tracking 66, 132
survey points 68, 175, 207

setting using elastics 177
Survey View 189
switching between sequence 111

T

Time Line 193
changing

the current frame using the
Numeric Field 94

the current time using the
Slider 94

Work Area 93
toggling

a constraint 179
between the 2D and 3D modes 74
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the current time display 77
the display of mattes 115
the full screen 74
the Graph Editor grid 197

toolbars
Display 73
Graph Editor 196
Light 72
Play Sequence 85

track
multiselection 134
paths 75

Track
Status Window 91
Window 88–89

tracker
configuring 144
running 147

Tracking Tool 76
changing the size of 137
description 136

tracks
color display 150
defining path color 75
hidden 87
inverting the selection 135
mobile 87

troubleshooting
automatic 2D tracking 190
the tracker 151

tutorials
motion capture 45
object-based tracking 35
supervised tracking 18
Tracking an image sequence 6

U

Undo 73
uniform scaling 212

V

viewing
3D primitives and objects 206

viewports
changing the layout 74
resizing 75

views
Survey 189

W

wireframe divisions, changing the number
of 82

Work Area
description 93
ending 95
resetting 95
starting 95

Workspace 73
changing the viewport layout 74

world reference, setting 171

Z

zooming
fitting to a viewport 79
Magnifier Window 96
returning to the original 79
Track Window 89
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