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AutoCAD Map 3D and ESRI 
ArcSDE  
 
Many organizations, such as utilities, telecommunication 
providers, and government agencies, depend on 
geospatial data that is stored in a spatial database 
accessed by ESRI® ArcSDE® software. AutoCAD® Map 
3D software enables organizations to expand access to 
ESRI ArcSDE data by providing other groups such as the 
engineering staff access data that was once accessible 
only to geographic information system (GIS) professionals 
using ESRI software. 
 
With embedded Feature Data Objects (FDO) Data Access Technology, AutoCAD Map 3D software 
enables users to work seamlessly on a variety of spatial and nonspatial databases and file formats 
natively, without the need for translation and risk of data loss. Incorporated into Autodesk® geospatial 
products, and also available as a stand-alone, open source technology for developers, FDO helps break 
down the barriers around data.  

This paper shows how organizations can reduce bottlenecks and data management costs with powerful 
computer-aided design (CAD) tools that are familiar to many users in the organization by using 
AutoCAD Map 3D software to access, edit and create data stored in an ESRI ArcSDE spatial database 
environment.  
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http://www.autodesk.com/fdo
http://www.osgeo.org/faq#Open_Source
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Terminology 
When working with spatial databases, it is essential to understand the associated terminology and 
concepts. The following terms are used throughout this document.  

Data Store—In Feature Data Objects (FDO), a collection of feature classes contained in a single 
storage location. The data store consists of an integrated set of objects, which are modeled by classes 
or feature classes defined within one or more schemas. Data stores can be either file based, such as 
SDF, or a database, such as Oracle® Spatial software. 

Drawing Objects—Objects that exist in a drawing (DWG™) file or come from an attached drawing. 
Compare to features.  

FDO Provider—An implementation of the FDO API (application programming interface) that provides 
access to data in a particular data store, such as an Oracle or ArcSDE database, or to a file-based data 
store, such as SDF or SHP. 

Feature(s)—An abstraction of natural or man-made, real-world object. A spatial feature has one or 
more geometric properties. For example, a road feature might be represented by a line, and a hydrant 
might be represented by a point. A non-spatial feature does not have geometry, but can be related to a 
spatial feature that does. For example, a road feature may contain a sidewalk feature that is defined as 
not containing any geometry. In AutoCAD Map 3D, features are accessed and added to maps using 
FDO via the Data Connect dialog. Compare to drawing objects.  

Feature Class—For feature data, a schema element that describes a type of real-world object. It 
includes a class name and property definitions. Commonly used to refer to a set of features of a 
particular class, for example, the feature class “roads” or the feature class “hydrants.” 

Feature Data Objects (FDO)—An Autodesk® software standard and general-purpose API for 
accessing features and geospatial data regardless of the underlying data store. 

Feature Layer—A layer in AutoCAD Map 3D software’s Display Manager containing feature(s) from a 
feature source such as SDF, ESRI SHP, or ArcSDE. Feature layers are brought into AutoCAD Map 3D 
using Data Connect.  

Feature Source—In AutoCAD Map 3D, any source of feature data that has been connected by means 
of FDO.  

Schema—The definition of multiple feature classes and the relationships between them. A schema is a 
logical description of the data types used to model real-world objects, and does not reference the actual 
data instances (a particular road or parcel). Rather, it is metadata. 

SDF—Spatial Data File. An open source file-based geodatabase that can contain multiple feature 
classes or types of data stored in tables with attributes and geometry. 

Service —An executable process installed in the Microsoft® Windows® registry and administered by the 
operating system. Once a service is created and started, it can run even when no user is logged on to 
the computer. 

Transaction—A unit of interaction with a database management system or similar system that is 
treated in a coherent and reliable way independent of other transactions. A single transaction might 
require several queries, each reading and/or writing information in the database. 



AUTOCAD MAP 3D AND ESRI ARCSDE  

 4 

Initial Setup and Configuration 
Before you can use AutoCAD Map 3D software to access, create and edit ESRI ArcSDE data, you must 
establish a connection to the ArcSDE server.  

Note: It is your responsibility to ensure that you have the necessary license rights to use ArcSDE 
software as described herein. 

Confirm ArcSDE Files and Directory Locations 
The first step is to confirm that you have the proper files installed on the machine where AutoCAD Map 
3D resides. 

1. Navigate to C:\Program Files\AutoCAD Map 3D 200X\FDO\bin and make sure the following 
files are installed:  

AutoCAD Map 3D 2008 

 ArcSDEMessage.dll 

 ArcSDEProvider.dll 

AutoCAD Map 3D 2009 

 ArcSDEMessage.dll 

 ArcSDEProvider.dll 

 ArcSDEProvider91.dll 

 ArcSDEProvider92.dll 

2. The FDO Provider for ArcSDE requires three dynamically linked libraries (DLLs) that are 
included with the ESRI ArcSDE software license, (See Requirements below under Working 
with the OSGeo FDO Provider for ArcSDE). In addition, you must ensure that the PATH 
environment variable references the local folder containing these DLLs or place the DLLs in 
C:\Program Files\AutoCAD Map 3D 200X\FDO\bin. The absence of this configuration may 
cause the following exception message: “The ArcSDE runtime was not found.” 
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Connect AutoCAD Map 3D to ArcSDE  
Once you have confirmed that you have the correct files installed, the next step is to use AutoCAD Map 
3D to connect to ESRI ArcSDE. 

1. Start AutoCAD Map 3D, and open a new drawing or the drawing you want to use with ArcSDE. 

2. Set the drawing coordinate system. See Assigning Coordinate Systems in the AutoCAD Map 
3D Help for details.   

3. In Display Manager, click Data and then select Add Data. Or type the MAPCONNECT 
command on command line. 

 

4. In the Data Connect dialog box, under Feature Sources, choose Add ArcSDE Connection and 
specify the following to connect to ArcSDE: 

 Enter a connection name. This is a user defined connection name. 

 Enter the server name. This is the server name or server’s IP address. 

 Enter Instance to Use. Enter the ESRI ArcSDE server TCP/IP port number and protocol, 
for example, 5151/tcp. 

 Enter the user name and password. 

 Click the down arrow under Data Store and select the data store. “Default datastore” will 
show up with an Oracle database.  For a Microsoft® SQL Server™ connection, pick a 
datastore from the list. 

 Optionally, click the down arrow under Version and select a version of the database.  

  
Note: The 9.2 provider doesn’t support entering the instance connection like “5151/tcp”.  The 
c:\windows\system32\drivers\etc\service file needs to be modified to add the correct ArcSDE server 
connection information.   
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 Navigate to C:\WINDOWS\system32\drivers\etc, and using any text editor, open the 
services file. 

 

 Scroll down and verify that there is an entry similar to “ESRI_SDE 5151/tcp 
#ArcSDEServer Listening Port.”  

  

 This line item must exist for the connection between AutoCAD Map 3D and ArcSDE to 
work.  

5. Click the Connect button. If the connection is successful, you see a list of feature classes.  

 
Note: The list of classes depends on the ArcSDE user you connected with.  To increase load speed, 
you can constrain the number of classes by defining an ArcSDE user with limited access and then 
connect to ArcSDE using this user.  

To save connection information for future projects, save the DWG file as a drawing template file (DWT).  

In case the coordinate system used by the ArcSDE data is not recognized by AutoCAD Map 3D 
(<unknown> showing under Coordinate System in Data Connect), it is possible to define an overrides 
coordinate system.  The overrides coordinate system enables AutoCAD Map 3D to properly project data 
between the DWG coordinate system and the data source coordinate system.  
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Basic Usage 
Users of AutoCAD Map 3D software can utilize spatial data accessed through ESRI ArcSDE in a variety 
of ways. In many instances, AutoCAD Map 3D users need only to access and view spatial information 
for reference purposes when starting a new design project such as a highway or residential 
development. In other cases, users can aid in the creation and maintenance of spatial information by 
directly editing and creating new information in the data store accessed through ArcSDE. In the case of 
a new infrastructure project, the engineer can design and populate the organization’s spatial database 
within the same application, streamlining workflow and enabling other users in the organization to use 
this new information. The following scenario shows how you can use AutoCAD Map 3D 2009 software’s 
precision CAD editing tools to directly access, edit, manage, and create data in an ESRI ArcSDE 
environment. 

Query Data into a Map 
Once you have connected to the ArcSDE server, you can query data directly into AutoCAD Map 3D. 

1. In the Data Connect dialog box, select the feature classes that you want to query into your 
drawing project 

 
2. Click Add to Map to add the full feature extents to your drawing. 

3. Optionally, choose Add to Map with Query to add query conditions to filter data based on 
location and/or properties, or define custom SQL where clauses. 
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4. If you choose Add to Map with Query, specify the query conditions within the Create Query 
dialog box and click OK to add the features to your drawing. 

  

When you query data from an external data store into AutoCAD Map 3D, the feature class or classes 
you queried are displayed in the Display Manager. AutoCAD Map 3D also assigns a default stylization 
to the features. To change the stylization of a feature class, use the Display Manager tools. 

Stylize Data 
Using the Display Manager, you can stylize the data to create maps, highlight specific features or 
perform analysis.  
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Note: Point features by default are displayed using a square symbol. In the Display Manager, you can 
stylize points with user-defined symbols. For example, you can represent objects, such as manholes, 
with a symbol or graphic created as an AutoCAD® block.  

Edit Data 
Using the precision editing tools in AutoCAD Map 3D, you can quickly and easily edit the queried data, 
including geometry and attribute information. 

Step 1: Check out Features for Edit 
1. Ensure that you are working in the Map 3D for Geospatial workspace. 

  
2. From the Edit menu, make sure Check-Out Edits Automatically is checked. 

3. Select the feature you want to edit and using grips or standard AutoCAD editing 
commands (Pedit, Trim, Break, Join, Offset, Extend, Rotate, Move, and Cut/Copy/Paste) 
make your changes. 

Checking out a feature makes it available to edit (grips are enabled). The feature you selected has been 
checked out and locked within the data store (Note: ArcSDE supports persistent locking and long 
transaction versioning, but these cannot be used together on the same table. On check-out, AutoCAD 
Map 3D will check the capabilities of the particular class and use locking if it is available). You can now 
edit the geometry using the grips or by using AutoCAD editing commands. You can also edit attribute 
information.  

  
4. To edit a feature’s attribute values, launch the Data Table by clicking the Table icon on the 

Display Manager Tool Strip. 

 
5. In the Data Table you can edit attribute values. 
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Note: When you edit feature data in the Data Table, the corresponding geometry is checked out and 
locked if possible. You must check in the geometry when you are finished editing.  

Step 2: Check in Features to Save Edits 
Once you have finished editing either geometry, attribute values, or both, check the feature in 
to save your changes and additions to the feature source, releasing any locks. You can use 
the select Checked-Out features from the Edit Menu to see the current status of your data. To 
Check-In your edits one of the following methods may be used:  

 Click a feature or features, from the Edit menu (or right click), choose Check-In. 

 Right-click the feature layer in the Display Manager, and choose Check-In Features. 

 Select Check-In from the Edit menu. You will be prompted to choose an option - All, 
Erased, Layer or Select objects.  

 Close the DWG file. You will be prompted to check in features. 

Note: If you have Update Edits Automatically enabled, the edits are written back to the data 
store as you edit. Checking in a feature in this scenario simply takes you out of an editing 
mode for that feature. When working in a relational database environment, it is advisable to 
disable Update Edits Automatically. For more information, refer to the AutoCAD Map 3D Help.  

Step 3: Extract Feature Geometry 
To use all of the AutoCAD editing tools on features; AutoCAD Map 3D users extract the 
geometry from the feature to create a drawing object, modify the drawing object using CAD 
tools, and then update the feature’s geometry.  

1. Check out the feature (see step 1 above). 

2. From the Modify menu, choose Advanced Feature Editing>Extract Geometry from Feature 
(Alternately, right-click the feature, and choose Extract Geometry from Feature). 

You can now use the full suite of AutoCAD Map 3D editing tools to edit the drawing object.  

Step 4: Update Feature Geometry 
When edits have been completed, update the feature’s geometry from the drawing object.  

1. Right-click the feature to be merged with a drawing object. Choose Update Feature from 
Geometry. 

2. When prompted, select the drawing object to merge. Press Enter. 

3. When prompted to erase the drawing object, do one of the following: 

 Click Yes to erase the original drawing object. 

 Click No to keep the drawing object in the drawing. 

Note: Keep the object if you plan to use it to create other features. You can store drawing 
objects on an AutoCAD layer and turn off visibility of the layer. 

4. Check in the edited feature. 
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Work Offline  
AutoCAD Map 3D provides functionality that can be useful for workers in the field or anyone who needs 
to work with data that resides in an RDBMS (relational database management system) data store 
(Oracle, Microsoft SQL Server, MySQL, and so forth) in a disconnected or offline state. To put it simply, 
AutoCAD Map 3D enables you to work with a local copy of your RDBMS data and commit changes 
when you return to an online state. 

1. Ensure that you are working in the Map 3D for Geospatial workspace. 

2. From the Edit menu, clear the Update Edits Automatically check box. 

 
3. Check out the features you plan to use. (See Step 1 above under Edit Data.) 

4. On the status bar, click the Online/Offline toggle. 

 
You can now disconnect from your network and update or edit the feature(s) you checked out in a 
remote setting. Features that you checked out are now locked in the RDBMS. You can still check out 
and edit features while you are offline. When you return online, AutoCAD Map 3D attempts to lock 
features that you checked out while offline. Non-feature data cannot be checked out, so you cannot edit 
it unless you are connected to its source. When you have completed your edits and are reconnected to 
the network, you can check your changes in to the feature source, releasing the locks.  

5. On the status bar, click the Offline/Online toggle. 

  
6. Check in the checked-out feature(s). 

Create New Geometry 
In addition to editing existing data, you can use AutoCAD Map 3D to create new geometry.  

There are two ways to create new features:  

 Use one of the feature creation commands to create a new feature. New features can be one 
of the following: Point, MultiPoint, LineString, MultiLineString, Polygon, or MultiPolygon.  

Note:If the provider supports curves, the arc option is available in the LineString, 
MultiLineString, Polygon, and MultiPolygon creation commands. 

 Create a new feature from a drawing object’s geometry. Using standard CAD drawing tools 
such as point, line, and polyline, you can create new entities.  

Using Feature Creation Commands 
The following procedures assume that you are creating LineString or MultiLineString features. Similar 
procedures are used for point, multipoint, polygon, and multipolygon features. For more information, 
refer to the AutoCAD Map 3D help. 

1. In Display Manager, right-click the feature layer for the new feature. Do one of the following: 
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 Click Create New LineString feature_name. 

 Click Create New MultiLineString feature_name. 

 Where feature_name is the name of the LineString or MultiLineString feature layer. 

2. When prompted, specify the location for the new LineString or MultiLineString feature.  

3. Use the command line or right-click to complete the new feature. 

For more information, see MAPLINESTRINGCREATE and MAPMULTILINESTRINGCREATE 
in the AutoCAD Map 3D help. 

4. Press Enter to complete the operation. 

The new feature is added to the data grid. To add information to the grid, see Editing Features 
using the Data Grid in the AutoCAD Map 3D help. 

5. Check in the new features. 

Creating a New Feature from a Drawing Object  
To create a new feature from geometry: 

1. In Display Manager, right-click the feature layer. Choose New Feature from Geometry. 

2. When prompted, select the object or objects to convert to features. Press Enter. 

All selected objects are converted into a single feature. To create multiple features, perform 
this operation on one object at a time. When prompted, select the feature you want to edit and 
press Enter. 

3. When prompted to erase the drawing object, do one of the following:  

 Click Yes to erase the original drawing object. 

 Click No to keep the drawing object in the drawing. 

Note: Keep the object if you plan to use it to create other features. You can store 
drawing objects on a layer and turn off visibility of the layer. 

4. Check in the new features. 
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Moving CAD data to ESRI ArcSDE 
AutoCAD Map 3D software provides additional functionality that makes it easy to move multiple drawing 
objects or geospatial features accessed via FDO into other spatial datastores. This can be extremely 
useful when trying to populate a datastore in a single operation with an entire DWG file or subset of 
one. Taking the data offline in the previous section allowed for updates of one or more features within 
ArcSDE via a transaction. However, if you wanted to take all or part of a selection set and insert that 
into ArcSDE, you would use AutoCAD Map 3D DWG Export and/or Bulk Copy functionality. Moving 
drawing objects to ArcSDE is a two step operation; step one is to export to SDF, the second step is to 
use Bulk Copy to insert data into ArcSDE. 

DWG Export 
With the mapexport command the user can export drawing objects contained in the DWG file to several 
different spatial data formats including SDF, ESRI SHP and Coverages, MapInfo® Tab, GML and Oracle 
databases.  

Step1: Create a New SDF from AutoCAD Entities 
1. Make sure the workspace is set to Map 3D for Geospatial. 

2. From the File menu choose Convert DWG to Autodesk SDF. 

 
3. Provide a name and location for the new SDF file. 

4. Once the Export dialog box appears, you have several choices in how and what data to 
choose. For this exercise we will choose to include everything on the Roads and 
Floodzone layers. 
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5. On the Feature Class tab we are presented with several options. This is the tab that really 
defines how to define our SDF and what attributes to export and if they are to be renamed 
(visuals included at end of process). 

 Choose the option Create multiple classes based on a drawing object. 

 Choose to base the classes on Layer objects. 

 Select the Attributes to include with the classes. Note: Attributes you specify in item 
3A below, will be assigned to all the feature classes in the SDF file, so select only 
attributes that are appropriate to all feature classes. For example, Lineweight and 
Linestyle.  

 Choose what type(s) of geometry will be available per class. 

 
Note: You can specify additional drawing object attributes, including Map 3D Object Data 
that are specific to a particular feature class. For example, Speed Limit would apply only 
apply to the Roads feature class.  
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6. Under the Options tab, data can be converted from its current projection to another and 

closed polylines can be converted to polygons (recommended). 
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Bulk Copy 
The Bulk Copy functionality of AutoCAD Map 3D software facilitates the movement of data from one 
FDO data source to another. Using Bulk Copy, FDO accessed data can be inserted directly into 
ArcSDE, Microsoft SQL Server, MySQL® and Oracle databases as well as other data stores.  

When data-types are different, Bulk Copy will attempt a conversion when needed. For instance, If 
ArcSDE does not support Boolean, the data type for that attribute will be converted to Byte if that is data 
type is available. If not, Bulk Copy will continue attempting Int16, Int32, or Int64 respectively, until a 
congruent data type is found. 

Bulk Copy will also re-project your data if the coordinate system is known or defined in the data 
connection. A log is presented after a Bulk Copy operation informing the user of any issues or warnings. 
For datastores that the corresponding FDO Provider does not support creation of new schema, Bulk 
Copy is not an update, but rather an insert routine. If objects have the same unique identifier, Bulk Copy 
will create a duplicate object with a new object ID. Care should be taken when using Bulk Copy so that 
only new features are inserted and duplicates are not created. 

Step 2: Use Bulk Copy to Insert Data from SDF files into ArcSDE 
We will now use the SDF file from the previous workflow (See Step1 under DWG Export) and insert 
those objects into our ArcSDE Feature Classes.  

1. Connect to the SDF file from the previous workflow using Data Connect (see section, 
“Query Data into Map”). Rendering the data in AutoCAD Map 3D is not necessary; only 
the connection to the datastore is required. 

2. Make a connection to ArcSDE as a user with insert privileges. 

 
3. In the Display Manager choose Data, then Bulk Copy 

 
4. Under From, choose the SDF source from Connection Name list. 
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5. Select which feature classes to insert into ArcSDE. 

 
6. Under To, choose the ArcSDE connection name, appropriate version state, and 

schema. 

 
7. Select the appropriate schema in the destination class(s). 

 
8. The final configuration should now include the source, destination, Schema, and 

attributes to copy. 
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9. Once all of the parameters have been defined, choose Copy Now.  

Note: AutoCAD Map 3D will not be able to roll-back these inserts; database 
restoration processes (for instance, backups and dumps) would be required to undo 
the inserts. 

 
10. ArcSDE feature classes will now reflect the inserts. 
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Working with Long Transactions and Versions 
Often, several departments in an organization use enterprise spatial databases, such as Oracle or 
Microsoft SQL Server. This interdepartmental use of spatial data creates challenges when it comes to 
managing that data. As a result, enterprise databases must provide the ability for multiple concurrent 
users to create and edit the same data without creating duplicates or multiple copies of the original data. 
With spatial database access in AutoCAD Map 3D software, a true multiuser editing environment is 
available to users of enterprise spatial databases. Before illustrating how AutoCAD Map 3D supports a 
multiuser editing environment, it is useful to introduce some specific terminology. 

Every edit or change to data stored in a database is a transaction. There are two types of transactions: 

 Short transactions—Changes made to data usually completed within a matter of seconds and 
within a single session; normally used for ordinary maintenance of the database. 

 Long transactions—Changes made to data over several sessions; normally used for larger 
projects, such as a major equipment upgrade or extension to a service network. The data may 
change many times before it is considered permanent, and the time required before committing the 
changes may be several hours to several months. 

AutoCAD Map 3D supports long transactions. Versioning is a type of long transaction. Simply stated, 
versioning is a method by which changes to a multiuser database are recorded and managed by 
creating a “version” or alternate view of the database without duplicating the original data. 

Using the versioning features of AutoCAD Map 3D, designers and analysts can create and store more 
than one scenario in the database. This is particularly useful when working with designed versus as-
built information or for creating what-if scenarios during the planning and design phases of a project. 

Create a Version 
All version-enabled databases accessed through ESRI ArcSDE contain a default version, which is the 
original published view of the database. This original parent version is the root of a version tree. 
Successive versions are children of the default version. 

Note: A new version is dependent on an existing parent version. By default, ArcSDE tables are not 
version enabled. To use versioning in ArcSDE, use ArcSDE tools to enable versioning. When a table is 
not version enabled, edits you make to that table appear in all versions, regardless of which version is 
active at the time of editing. Additionally, when creating and manipulating versions, it is important to 
connect as a user that has sufficient privileges. 

1. To create a new version, in the Map Explorer, click the connection name and then click Tools> 
Manage Versions. 

 

2. The Versions dialog box appears. This is where versions are managed. 
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3. To create a new version, click Add. Then select one of the following: 

 New Version. This creates a sibling version. 

 New Child Version. This creates a child version. 

4. Enter a name for the new version. Click OK. 

 
5. Once you have created a version, you must activate it. Reopen the Versions dialog box 

(Tools>Set and Manage Versions). Note that the new version lies beneath the default or parent 
version. Select the version, and choose Active. 

 
6. The icon next to the active version is highlighted in green. Click OK. 

 
7. You can now use AutoCAD Map 3D software’s data creation and editing tools to create and 

modify versioned data. Use the same procedure for saving edits to the data store for versioned 
and nonversioned tables. See “Edit Data” earlier in this document. 
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One of the benefits of versioning is that you can quickly compare different views of the data, such as a 
series of proposed utility network layouts. In AutoCAD Map 3D you simply switch between the different 
versions.  

8. In Map Explorer, from the Tools menu, choose Set and Manage Versions. Select the version 
and choose Active. Click OK to close the dialog box.  

 
AutoCAD Map 3D will query the data store and display the versioned view of the data. 

Commit or Discard a Version 
When the project is finished, or at the end of an editing session, you can discard (remove) or commit 
(save) edited features to the parent version, and reconcile any conflicts. Before discarding or committing 
versions to the parent, make sure the parent is active. 

 To commit or discard a version: In Map Explorer, from the Tools menu, choose Set and 
Manage Versions. Select the version and choose Save or Remove. Click OK to close the 
dialog box. 
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Working with the OSGeo FDO Provider for ArcSDE 
AutoCAD Map 3D software’s FDO technology uses a provider to connect to different data stores. When 
working with the OSGeo FDO Provider for ArcSDE, you must follow specific parameters as well as 
understand some limitations.  

Requirements 
AutoCAD Map 3D requires the following software when connecting to ArcSDE: 

AutoCAD Map 3D 2009 

ESRI ArcSDE Server 9.2 and 9.1 with Oracle 10gR2, or Microsoft SQL Server 2005 (SP2) and 
2000 (SP4)  

Data can be stored in binary large object (BLOB) column type or SDO_Geometry column type. 

AutoCAD Map 3D 2008 

ESRI ArcSDE Server 9.1 with Oracle 10gR2, or Microsoft SQL Server 2005 (SP2) and 2000 
(SP4)  

Data can be stored in binary large object (BLOB) column type or SDO_Geometry column type. 

Note: The FDO Provider for ArcSDE included with AutoCAD Map 3D 2008 can be updated 
with an open source version that will enable connections to ArcSDE 9.2. Visit the OSGeo 
website to download the provider and installation instructions and see the Autodesk technical 
white paper FDO Data Access Technology - New FDO Providers at www.autodesk.com/fdo for 
further information. 

Dynamic Link Libraries  
The following ESRI files must be installed on the same machine as AutoCAD Map 3D: 

AutoCAD Map 3D 2008 or AutoCAD Map 3D 2009 connecting to ESRI ArcSDE 9.1 

 Pe91.dll 

 Sde91.dll 

 Sg91.dll 

AutoCAD Map 3D 2009 connecting to ESRI ArcSDE 9.2 

 Pe.dll 

 Sde.dll 

 Sg.dll 

Note: The provider will look for the 9.2 component and if they are not found will use the 9.1 
components.  Avoid having both components under the FDO/bin directory to remove any 
confusion. 

OSGeo FDO Provider for ArcSDE Limitations 
The OSGeo FDO Provider for ArcSDE is based on a subset of the ArcSDE API. This subset does not 
include the following: 

 Raster functionality 

 Native ArcSDE metadata 

 The annotation data, with the exception of the ANNO_TEXT column  

 Domains and Subtypes 

http://fdo.osgeo.org/content/fdo-322-downloads
http://trac.osgeo.org/fdo/wiki/FdoArcSDE92Notes
http://images.autodesk.com/adsk/files/fdo_data_access_technology_third_party_providers_final.pdf
http://www.autodesk.com/fdo
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ArcSDE Limitations  
OsGeo FDO Provider for ArcSDE must abide by limitations of the ArcSDE technology to which it 
connects. This section discusses these limitations in relation to ArcObjects™ API and ArcGIS® Server 
API. 

The ArcSDE API does not support the following advanced functionality found in the ArcObjects API and 
the newer ArcGIS Server API: 

 Advanced geometries, such as Bezier curves and ellipses 

 Relationships 

 Topology 

 Networks 

 Analysis 

 Linear referencing 

Autodesk Software Limitations 
AutoCAD Map 3D and Autodesk MapGuide® Studio software do not support the following functionality:  

 ArcSDE Direct Connections 

 Windows authenticated connects for Microsoft SQL Server. 

 With version 9.2, ArcSDE can be configured with either a dbo-schema or an sde-schema. 
Currently, dbo-schema is not supported. 
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Tips and Suggestions 
Use the following tips and suggestions when working with AutoCAD Map 3D 2009 and ESRI ArcSDE 
software applications. 

Performance—Connection times can be significantly reduced if you constrain the number of classes 
the ArcSDE user has access to. Additionally, to increase rendering speed of features within AutoCAD 
Map 3D, add a condition or filter when querying data from ArcSDE.   

Schema and Feature Classes—The current release of the OSGeo FDO Provider for ArcSDE does not 
support creation or deletion of schemas or feature classes within ArcSDE. Use ArcSDE tools to create 
new schemas and feature classes. The OSGeo FDO Provider for ArcSDE supports inserting, selecting, 
updating, and deleting data in existing schemas. 

Curved Segments—If ArcSDE encounters curved segments, it will automatically segment them. This 
means that if you create a geometry containing an arc segment in an ArcSDE table using ArcObjects 
API and then you try to read that geometry back using the ArcSDE API, you will get a series of line 
segments that approximate the original arc segment. That is, you get an approximation of the original 
geometry. 

Measure (m) Coordinate Values—ArcSDE objects that have measure (m) values in the coordinates 
cannot be edited. 

Locking and Versioning—ArcSDE permits row locks or table versioning provided that the ID column, 
which uniquely identifies the row, is maintained by ArcSDE. If there is no ID column or the ID column is 
maintained by the user, ArcSDE does not permit row locking or table versioning to be enabled. By 
default, ArcSDE tables are not lock enabled. With the FDO Provider for ArcSDE, you can either lock 
rows in a table or version a table. You cannot do both at the same time. To use locking in ArcSDE, use 
ArcSDE tools to enable locking. When locking is not enabled, users can add objects to the edit set, but 
they are not locked in the feature source. Multiple users can check out the same object. One user’s 
edits may be overwritten by those of another user.  

Documentation—In-depth documentation can be found in the AutoCAD Map 3D Help. Developer 
documentation can be found in the Autodesk FDO Developer’s Guide available in the Autodesk 
Developer Center at www.autodesk.com/developer. 

Additional Information—Further information can be found on the FDO section of the OSGeo website 
at http://fdo.osgeo.org/ 
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