Autodesk Mudbox 2013 Service Pack 1 Release Notes

This document describes known limitations, issues, and fixes included in Autodesk Mudbox 2013 Service
Pack 1. It is strongly recommended that you read this document before you install this release.
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What’s Fixed?
The following list contains bug numbers and corresponding descriptions for issues fixed in this release.
Bug Number
MDBX-1628
MDBX-1657
MDBX-1569
MDBX-1536
MDBX-1488
MDBX-1442
MDBX-1382
MDBX-1202
MDBX-1339
MDBX-1659
MDBX-940

MDBX-8
MDBX-1482
MDBX-1751
MDBX-1406
MDBX-1215
MDBX-1387
MDBX-1720

Description
Need a curve property for controlling virtual "pressure" along the curve for
Stroke on Curve.
Pressing the Shift key in the Create Curve tool should switch to the Smooth
Curve tool.
Curve end points are not fixed and the Smooth Curve tool will cause them to
change.
Grab Curve and Smooth Curve tools do not work on curves without splines.
Cannot create a View Curve after pressing Ctrl+N (to create a new scene).
Grab Curve and Smooth Curve marking menus are incorrect.
Snapping to 3D curve doesn't work on the stencil canvas and may cause crash.
This functionality has been removed.
View curves break the "Frame Selection" function.
"Snap to Curve" doesn't snap reliably.
Sculpting on tiling plane after deleting some of the faces may cause Mudbox to
crash. The ability to delete tiling plane faces has been removed.
Mudbox environment variable MUDBOX2009_SUBDIVIDE_SMOOTH_UV does
not accurately match RenderMan UV Smoothing option -- cc smooth borders
and internal UV's.
Subdivide with Smooth UV's is incorrect and should match RenderMan -- linear
(unchanged) border with cc smoothed internal UV's.
When importing an FBX file that has both blend shapes and creasing from Maya
2013, the blends shapes fail to load into Mudbox 2013.
PTEX export causes seams in some cases.
Cannot mirror individual sculpt layer if other layers are visible.
Layer > Mirror command produces incorrect result.
Mac OS X: error beeps while clicking on Spacebar marking menu.
Help preference set to use the Installed Local Help instead of Autodesk Web
Site does not launch 2013 Help.
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Feature Limitations and Notes
This section lists known limitations and workarounds for Mudbox 2013 Service Pack 1.
Please report any additional issues using the online bug reporting form at:
www.autodesk.com/mudbox-bugreport or from the Help > Report a Problem menu item in Mudbox.
Bug Number

MDBX-1663

388437

MDBX-1616

MDBX-371

388529

355918

357041

358312
360224
362133
362857

Description
Mac OS X: File > Send To is not working correctly. Maya or Mudbox will open
when you select "Send to.." but nothing will be sent.
Workaround:
1. Copy the libsynHub.dylib from the Mudbox 2013 SP1 directory:
/Applications/Autodesk/Mudbox2013/Mudbox.app/Contents/MacOS
2. Replace the file of the same name in the Maya 2013 directory
/Applications/Autodesk/maya2013/Maya.app/Contents/MacOS
The Gigatexel Engine stops working intermittently after assigning a new
material or Ptex setup.
Workaround: Toggle the visibility of the offending paint layer on and off, create
a new paint layer (can be empty or hidden), or save the file and reopen it to
restart the Gigatexel Engine.
You need to start the Gigatexel Engine with this workaround before painting,
otherwise textures on some tiles will go missing.
An environment variable MUDBOX_EXPOSE_8K exposes "8192" in the Create
New Paint Layer "Size" option. (It will not be exposed if less than 512 MB GPU
available. 1.5 GB or more recommended).
When the amount of texture data exceeds the available GPU on your machine,
the effects brushes draw red temporarily if "Solo as Diffuse" is ON for a paint
layer.
Workaround: Once the stroke is done, the brush correctly applies the effect
and the result is correct. You can turn off the Gigatexel Engine in the Render
preferences (which effectively disables the paint buffer) and the effects
brushes will work correctly.
Flip a mesh with crease information and an empty paint layers may cause faces
to become transparent.
Workaround: Delete the empty paint layer, or subdivide the mesh, or
change subdivision levels.
Installation: Error that says the product key may be invalid and to re-enter it.
Workaround: Click OK on this dialog, click Next button again, and if product key
is valid the installation continues.
Mudbox on Linux does not get pressure events from Wacom tablets with
Fedora 12/Redhat 6, QT 4.5. You can find more details in the bug report here:
https://bugzilla.redhat.com/show_bug.cgi?id=569132
There is a patch for Qt here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=160252
Files that include 16 bit TIF maps will show errors with "Send to Maya..."
operation.
Mudbox crashes if the extraction map output file name contains %S in string
(for example: AO_(%S).bmp).
Creating a joint with Topology Weights doesn't work properly with non-4-sided
meshes. Workaround: Use alternative Weights method.
If the level of the source model is not the current level when extracting a map,

2

Bug Number

363366

MDBX-260

374126
MDBX-292
381496

MDBX-1614

MDBX-1203

MDBX-456

MDBX-341
MDBX-1556







Description
the detail of lower sculpt layers will be missing. Workaround: Ensure you
display the required subdivision level before extracting the map, or select the
current level in the Extract Texture Maps window to get the correct result.
Transfer paint layer works incorrectly if target and source have overlapping
UVs.
The Transfer Details function works best on objects that are the same size, or
larger than the default Mudbox meshes. If the transfer produces artifacts on
the target mesh, try scaling up the source and target meshes to the same size
as the default head mesh.
When using a non US-English standard keyboard, some of the hotkeys may not
work. Workaround: Set your IME to "English - United States" while using
Mudbox. For more information see your operating system documentation.
Send to 3ds Max: Changing units between Max and Mudbox causes
unpredictable results.
When painting or sculpting with symmetry ON, sometimes the result will not
appear on the opposite side. Verify that you have "Falloff based on Facing
Angle" turned off.
On Linux, if Mudbox crashes when starting up with an error message such as
"mudbox: symbol lookup error: /usr/lib64/libssl.so.0.9.8: undefined symbol:
X509_VERIFY_PARAM_new", try the following workaround:
1. Install OpenSSL >= 1.0.0 if you haven’t already.
2. Point the old symbol link to the 1.0.0 version, like "ln -s -f
/usr/lib64/libssl.so.1.0.0b /usr/lib64/libssl.so.0.9.8"
If a portion of a curve on a mesh is obscured (for instance, if a portion of the
curve is on the back side of an object) and you use Stroke on Curve" with mirror
ON, results may be incorrect.
On Linux Fedora 14+ the SELinux is false by default. This may prevent Mudbox
from launching properly and produce plugin errors. A possible workaround is to
set the SELinux enforcing mode to "Permissive" or "Disable".
When saving a .mud file to replace the original .mud file with the same name
the file will also keep the original file size. To save the file with the actual file
size use "Save Scene As..." and save the file with a new name.
On Mac OS X the installer may hang at end of a successful installation. It is
recommended to force quit the installer. Mudbox will then run normally.

To run Mudbox 2013 you must have a processor which is SSE3 compliant. Mudbox uses SSE3specific code, which does not allow Mudbox to run on hardware which is SSE2 or previous.
Sculpting with the Stamp Spacing property turned on will cause the brush stamp to be offset to the
cursor location when using a Wacom Cintiq or a Wacom tablet when the pen setting is set to Mouse
mode. To correct this, add the environment variable "MUDBOX_USE_LOWRES_TABLET_DATA".
With ATi graphics cards, if you are seeing texture painting corruption such as painting black and
artifacts adding the environment variable "MUDBOX_PAINT_CONTEXT_FLUSH" may fix the problem.
Some users may be seeing incorrect GPU RAM reporting causing many warnings to pop up every
time they create or merges layers, or change the visibility of layers. The environment variable
"MUDBOX_FORCE_GPU_RAM" (on Windows only) lets you override the amount of GPU memory in
megabytes that Mudbox sees. If you have an Nvidia Quadro 5600 and it reports 1 MB of GPU RAM
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(the hardware has 1.5GB), set the variable to 1536 (which is 1.5 * 1024) for that card. Values which
are not numbers will be ignored, and values will be clamped to the range 256 to 4096.
Note: For more information on these environment variables, see the Environment Variables topic in
the Mudbox Help.
You can download and install the MudboxHelp locally from http://www.autodesk.com/mudboxhelpdownload-enu
If you previously installed any beta version (including Release Candidate versions) of Autodesk
Mudbox 2013, you must uninstall and delete all system folders pertaining to the pre-release
versions before you can install the commercial version.

(Windows 32-bit and 64-bit) Uninstalling or repairing Mudbox 2013 fails with a message “SetupRes.dll
is not found!”
This maintenance failure message occurs if Autodesk Mudbox 2013 was installed in a suite package or
from a standalone image and the selected product language is other than the four supported by
Mudbox (English, French, Japanese, German).
Fix: You will need administrator privileges. Make the following changes to the registry and then try
to repair or uninstall:
For 64 bit Windows
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Autodesk
Mudbox 2013 64-bit\
Name: UninstallPath
Data: <InstallationDirectory>\Setup\Setup.exe /P {0C821839-EA2A-48C2-BBD5-2B3D28159BC0} /M
Mudbox /LANG ko-KR en-US
For 32 bit Windows
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Autodesk
Mudbox 2013 32-bit\
Name: UninstallPath
Data: <InstallationDirectory>\Setup\Setup.exe /P {A675D66E-0CBD-4A8F-0068-82B774DD4C9E}
/M Mudbox /LANG ko-KR en-US
SDK Examples
On Mac OS X, release configurations may not build correctly. User must set the Active Architecture to
x86_64 in Xcode. To do this:
1. Open example project using Xcode.
2. In menu bar, select Project > Edit Project Settings.
3. Select the Build tab.
4. Under Architectures in the Setting window, make sure the Architectures value is set to 64-bit Intel.
5. Close window and build using the Release configuration.
PtexImporter example requires PtexExtractor example to be built and copied into PtexImporter's build
directory for linking.
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To build Turntable example, install Qt and run moc on the example header files. See readme in example.

Additional Resources
For complete installation and licensing instructions refer to the Installation Help and the Licensing Help.
Access these guides from the Installation Help link of the Mudbox installer or find them here:
http://www.autodesk.com/mudbox-install-2013-enu
http://www.autodesk.com/me-licensing-2013-enu
Find new feature information in the "What's New" section of the Mudbox Help at:
http://www.autodesk.com/mudbox-help-2013-enu-whatsnew
Find learning resources for Mudbox at:
http://www.autodesk.com/mudbox-learningpath
Watch videos to learn how to use Mudbox at:
http://www.autodesk.com/mudbox-trainingvideos
Find support and troubleshooting resources at:
http://www.autodesk.com/mudbox-support
For the latest list of certified hardware to run Mudbox 2013, including graphics cards, refer to the
Mudbox 2013 certification chart located at:
http://www.autodesk.com/mudbox-hardware
Find the Mudbox 2013 minimum system requirements at:
www.autodesk.com/mudbox-systemreq-2013-enu
Find documentation and examples for the Mudbox SDK with your installed version of Mudbox here:
\Mudbox 2013\SDK or online here:
http://www.autodesk.com/mudbox-sdkdoc-2013-enu

Customer Involvement Program (CIP)
The first time you start Mudbox, the Customer Involvement Program dialog box appears. If you choose
to participate in the Customer Involvement Program, Mudbox will automatically send Autodesk
information about your system configuration, what features you use most, any problems that you
encounter, and other information helpful to the future direction of the product. For further information,
see http://www.autodesk.com/cip.
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Customer Error Reports (CERs)
We are able to improve the stability of Mudbox largely because of the Customer Error Reports (CERs)
that users of our products submit. We thank you for taking the time to fill out these reports and ask that
you include as much information as possible about what actions you were performing at the time the
error occurred. These details raise the value of the report immensely and are very much appreciated by
the Autodesk Mudbox Engineering team.
For further information about CERs refer to http://www.autodesk.com/cer.

Autodesk, Backburner, FBX, Maya, MotionBuilder, Mudbox, Softimage, and 3ds Max are registered trademarks or trademarks
of Autodesk, Inc., and/or its subsidiaries and/or affiliates in the USA and/or other countries. All other brand names, product
names, or trademarks belong to their respective holders. Autodesk reserves the right to alter product and services offerings,
and specifications and pricing at any time without notice, and is not responsible for typographical or graphical errors that may
appear in this document.
©2012 Autodesk, Inc. All rights reserved.
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