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What Is Autodesk Direct-
Connect

Autodesk® DirectConnect is a family of data translators. Each of these translators
imports a specific CAD file format into one or more of the following Autodesk®

software products:
■ Autodesk® Alias®

■ Autodesk® Maya®

■ Autodesk® Showcase®

■ Autodesk® Opticore® Studio

■ 3ds Max®/3ds Max® Design

1
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In addition, you can export some CAD file formats from some products with
Autodesk DirectConnect.

Supported products and translators

Import to: Autodesk Alias, Autodesk Showcase, Autodesk Maya, Autodesk
Opticore Studio, 3ds Max, 3ds Max Design

Apple® Mac OS® X® 10.6 or
higher, 64 bit

Microsoft®Windows®

XP, Windows® 7, 32-bit
and 64 bit

File Format

Not availableAutodesk Inventor (page 10)
Not available in 3ds Max/3ds Max
Design

Not availableCATIA V4 (page 12) All versions +
V3RX

Not availableCATIA V5 (page 14) R6-R21

 Not available in Showcase,
Opticore Studio

DWG DXF (page 19)™ Real DWG
2013
Not available in 3ds Max/3ds Max
Design

 Not available in Showcase,
Opticore Studio

IGES (page 21) V5.3

Not availableJT (page 26) Up to 9.5

Not availablePro/ENGINEER (page 35)® Up to
Wildfire 6.0 and Creo Parametrics
Not Available in Showcase

Not availableNX (page 28)® UG V13.0 to NX 7.5
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Import to: Autodesk Alias, Autodesk Showcase, Autodesk Maya, Autodesk
Opticore Studio, 3ds Max, 3ds Max Design

Apple® Mac OS® X® 10.6 or
higher, 64 bit

Microsoft®Windows®

XP, Windows® 7, 32-bit
and 64 bit

File Format

Not availableOpen Inventor™ and Cosmo™_ (page
33) All versions
Not available in 3ds Max/3ds Max
Design

Not availableSolidWorks (page 37)®(1) 2003-2012
Must be licensed and running on the
import machine.

 Not available in Showcase
SPF (Alias Packet File) (.wire)

 Not available in Showcase,
Opticore Studio.

STEP (page 39)
AP214, AP203E2

 Not available in Showcase,
Opticore Studio.

STL (page 41) (Stereo-lithography)
Not available in 3ds Max/3ds Max
Design

Export from: Autodesk Alias, Autodesk Maya, 3ds Max, 3ds Max Design

Apple® Mac OS® X® 10.6 or
higher, 64 bit

Microsoft®Windows® XP,
Windows® 7, 32-bit and 64
bit

File Format

DWG DXF (page 19) Real Dwg
2013, Alias (.wire) only.
Not available in 3ds Max/3ds Max
Design.

IGES (page 21)
V5.3
Not available in 3ds Max/3ds Max
Design.

Supported products and translators | 3



Export from: Autodesk Alias, Autodesk Maya, 3ds Max, 3ds Max Design

Apple® Mac OS® X® 10.6 or
higher, 64 bit

Microsoft®Windows® XP,
Windows® 7, 32-bit and 64
bit

File Format

Not availableNX (page 28)
NX1.0, 3.0, 5.0, 7.0
Not available in 3ds Max/3ds Max
Design.

SPF (Alias Packet File) (.wire)

STL (Stereo-lithography)
Not available in 3ds Max/3ds Max
Design.

Not availableZPR (page 43)™ (ZPrint CAD for
Rapid Prototyping) V1.2
Not available in 3ds Max/3ds Max
Design.
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What's New in This Re-
lease

This section lists the new features and improvements in Autodesk® DirectConnect
2013.

New Features
Support is added for:
■ CATIA V5 (R21) for import (export in Alias).

■ Alias to CATIA V5 translation supports export of Alias meshes.

2
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■ Granite version 7.0

■ JT version 9.5

■ Parasolid V24

■ Solidworks 2012

Improvements
■ JT

■ XBREP import quality is improved.

■ A new option is added to read mesh, but only if BREP is not available.

■ New options for meshes and tessellation detail are added, including
the highest detail and lowest detail option.

■ NX supports the import of all mesh data.
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Installation and Licenses

Install Autodesk DirectConnect
Autodesk® DirectConnect® software installs automatically when the following
Autodesk software is installed:
■ Autodesk® Alias®

■ Autodesk® Maya®

■ Autodesk® Showcase®

■ 3ds Max®/3ds Max® Design

Autodesk DirectConnect software is provided on the media with Autodesk®

Opticore® Studio software, in the Autodesk DirectConnect 2013 folder. It requires
manual installation.

For information about installing these software products, refer to their respective
installation guides.

NOTE
■ When installing DirectConnect, install the same version, such as 32-bit or

64-bit, as your Autodesk Opticore Studio.

■ DirectConnect Help is supported only on Microsoft® Internet Explorer®.
Performance on other browsers does not provide consistent results.

3
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Support platforms

Autodesk DirectConnect runs on the same platform as the Autodesk product
it installs with:

Apple® Mac OS® X®
10.6 or higher, 64-bit

Microsoft® Windows® XP,
Windows® 7, 32-bit and 64-
bit

Autodesk Software

Autodesk Alias

Autodesk Maya

Not availableAutodesk Showcase

Not availableAutodesk Opticore Stu-
dio

Not available3ds Max/3ds Max
Design

System requirements

Autodesk DirectConnect requires the following amount of available disk space:
■ Windows XP, Windows 7: 671 MB for 32-bit, and 838 MB for 64-bit.

■ Mac OS X: 10.6 or greater. On Snow Leopard: 65 MB on an Apple Mac
computer with 64-bit Intel processors.

DirectConnect installs with other products, so your system must also
accommodate the host product requirements. (For the system requirements
of the host product, consult the appropriate installation guide.)

For the most up-to-date information about hardware qualifications, see
Qualified Hardware.

For information about how to import specific file formats into each of these
products, see chapter 4, Translator details. (page 9)

To locate imported data in your Autodesk software, see Locations of Imported
Data. (page 45)
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Autodesk Inventor

Autodesk® Inventor® is a 3D mechanical design, product simulation, tooling
creation, and design communication software.

Autodesk DirectConnect supports the import of Autodesk Inventor part (*.ipt)
and assembly (*.iam) files into the Autodesk Alias, Autodesk Maya, Autodesk
Showcase, and Autodesk Opticore Studio software. See installation information
in Install Autodesk DirectConnect. (page 7)

Import Autodesk Inventor files

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 In the browser, select an Autodesk Inventor *.ipt or *.iam file.
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3 Click OK, or Open to launch the translator and import the file.

NOTE  To maintain the original positioning and orientation of part files in
your scene, import the assembly file. Importing part files before the assembly
file positions all of them at the origin (0,0,0), and removes the original
positioning.

Types of data imported

NURBS are imported, and the following additional information is maintained
on import:
■ Brep bodies

■ Data organization

■ Tolerances and units

■ Material colors and simple transparency

■ Weld maps (beads only)

■ Thread maps

■ Decals

NOTE For information about locating this data in your Autodesk software, see
Locations of Imported Data (page 45).

Limitations

■ Work sources, display meshes, and some 2D/3D sketches are automatically
excluded when importing an Autodesk Inventor file.

■ Some cylindrical surfaces (pipes) do not trim properly.
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CATIA V4

CATIA is computer-aided design software from Dassault Systèmes.

Autodesk DirectConnect supports the import of CATIA V4 (V4.xx and earlier
V3RX Levels) geometric sets, attributes, such as names, layers, RGB colors,
and visibility, and the CATIA file types into the Autodesk Alias, Autodesk
Showcase, Autodesk Opticore Studio, and 3ds Max/3ds Max Designsoftware.
See installation information in Install Autodesk DirectConnect. (page 7)

DirectConnect supports CATIA model and export files produced with CATIA
V4.xx and earlier V3RX Levels.

Import CATIA V4 files

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)
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File > Import > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

Application Menu > Import > Select File
to Import dialog

3ds Max/3dsMax Design

2 In the browser, select a CATIA V4 *.model, *.mdl, *.session, *.exp,
*.dlv,*.dlv3, or .dlv4 file.

3 Click OK, or Open.

The translator launches automatically, and the file imports into the
scene.

Types of SPACE (SP) entities supported for import

■ Point (Type 1)

■ Line (Type 2)

■ Parametric curve (Type 3)

■ Plane (Type 4)

■ Parametric surface (Type 5)

■ Face (Type 6)

■ Volume (Type 7)

■ Transformation (Type 9)

■ Edge (Type 12)

■ Circle (Type 20)

■ Ellipse (Type 21)

■ Parabola (Type 22)

■ Hyperbola (Type 23)

■ Polyhedral surface (Type 16)

■ Composite curve (Type 24)

■ Solids - Mockup (Type 17, secondary type 1)

■ Exact solid (Type 17, secondary type 2)

■ Space ditto (Type 28)

■ Parametric skin (Type 35)
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■ NURB curve (Type 46)

■ NURB surface (Type 47)

NOTE
■ To locate this data in your Autodesk software, see Locations of Imported

Data (page 45).

■ For information about options in Alias for data importation, see the
Autodesk Alias Help.

■ For definitions on these data types, consult your CATIA documentation.

CATIA V5

CATIA® is computer-aided design software from Dassault Systèmes.

Autodesk® DirectConnect supports the import of CATIA V5 (R6-R21) files in
the Autodesk Alias, Autodesk Maya, Autodesk Showcase, Autodesk Opticore
Studio, and 3ds Max/3ds Max Design software. See installation information
in Install Autodesk DirectConnect. (page 7)

Export of CATIA V5 Part files is available only in Alias (from release 10 to 21).
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Import CATIA V5 files

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

Application Menu > Import > Select File
to Import dialog

3ds Max/3dsMax Design

2 In the browser, select a CATIA V5 (*.CATProduct ,*.CATPart, or *.cgr)
file.

3 Click OK, or Open to launch the translator and import the file into the
scene.

Types of data imported

We support the import of files from CATIA V5 releases R21 and earlier, and
the following types of data:
■ Point

■ Line

■ Arc

■ Ellipse

■ Parabola

■ Hyperbola

■ BSpline curve

■ Polynomial curve

■ Plane

■ Cylindrical surface

■ Conical surface

■ Spherical surface
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■ Toroidal surface

■ BSpline surface

■ Revolve surface

■ Ruled surface

■ Open body

■ Solid body

■ Layer

■ Geometric set

■ Part (from CATIA V5 release 6 and higher)

■ Product (from CATIA V5 release 6 and higher)

■ Attributes (RGB color, layer, name, visibility, and materials)

■ Per face color assignments

■ Cloud mesh data

■ Tessellated data

■ Weld data

NOTE
■ To locate this data in your Autodesk software, see Locations of Imported

Data (page 45).

■ For information about options in Alias for data importation, see the
Autodesk Alias Help.

■ For definitions about these data types, consult your CATIA documentation.

Export CATIA V5 files

NOTE Not available in 3ds Max/3ds Max Design software.

1 In your Autodesk software, choose File > Save As, or File > Export >

Active As  .

2 For details about the available options, see the Help in the Autodesk
software.

3 Save to CATIA version R6-R21.
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File formats referenced

The following are some of the file formats that can be referenced by CATIA
V5 assembly files:
■ .CATProduct

■ .CATPart

■ .model

■ .cgr

■ .stl

DWF

Design Web Format (DWF™) is a file format developed by Autodesk for web
viewing and printing.

Autodesk DirectConnect supports the export of Autodesk Alias® tessellated
model data to DWF format files (*.dwf) to view in Autodesk Design Review
and Project Freewheel. See installation information in Install Autodesk Direct-
Connect. (page 7)

NOTE For information about additional software setup for Autodesk Alias, please
see the Autodesk Alias Help.
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Export DWF files

1 In Autodesk Alias, select a file to be exported as a DWF, and choose File

> Export > Active As  , or File > Save As  .

2 On the File Formats menu, select DWF (.dwf).

3 Set export options, and then click Save.

FunctionOption

When turned ON, exports curves.Export Curves

If an Alias layer has symmetry turned ON, this information and
the geometric objects resulting from symmetry can be merged
and converted, or left intact (unmerged) and converted.

Export Symmetry

When turned OFF, layer symmetry is not exported.

Fast- Models triangulate quickly and less accurately.Tessellator
Accurate -Models triangulate slowly and more accurately.

■ Tolerance – The amount a polygonal surface can deviate
from the original NURBS surface. The default value is 0.01.

■ Limit Edge Length – If checked, a Max edge length slider
controls maximum size of the triangles. If unchecked, there
is no limit to the size of the triangles.

■ Max Edge Length – The maximum length of any triangle
edge (in current linear units).

Types of data exported

The DirectConnect translator for DWF exports only meshes. The Alias scene
DAG hierarchy is preserved. Associated color information is also exported.

NOTE For information about options in Alias for data importation, see the Autodesk
Alias Help.
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DWG DXF

The DWG and DXF file types are drawing files and Drawing eXchange files
in the AutoCAD ® software.

Autodesk DirectConnect supports the import of AutoCAD (DWG and DXF)
files into the Autodesk Alias, Autodesk Maya, Autodesk Showcase, and Autodesk
Opticore Studio software. See installation information in Install Autodesk
DirectConnect. (page 7)

Import DWG/DXF files

1 Choose the menu path in your installed Autodesk software product:

File > Open  or File > Import > FileAutodesk Alias

File > Open Scene or  File > ImportAutodesk Maya

File > Import > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore
Studio

2 Browse to, and select a DWG (.dwg) or DXF (.dxf) file.
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3 Click OK, or Open to launch the translator and import the file.

Types of DWG and DXF data imported

■ Colors

■ Materials

■ Lines, arcs, and splines

■ Extruded curves

■ Extrusions

■ Layers

■ Meshes

■ Surfaces

■ Text

■ 3D solids

IMPORTANT
■ Showcase does not support the AutoCAD material attribute Illumination.

Alias supports the AutoCAD material attribute Illumination; however,
it is called Incandescence.

■ Showcase supports only 3D hierarchical data. It does not support 2D
drawings.

NOTE
■ To locate this data in your Autodesk software, see Locations of Imported

Data (page 45).

■ For information about options in Alias for data importation, see the
Autodesk Alias Help.

■ With want curves set to ON, DWG and DXF both support curves and
round trip data export. If they do not come in, set want curves to ON.

Export DWG/DXF files (Autodesk Alias)

1 In your Autodesk software, choose File > Save As  , or File > Export

> Active As  .

20 | Chapter 4   Translator Details



2 On the File Formats menu, click DWG or DXF. For details about the
available options, see the Help in the Autodesk software.

3 Select a DWG/DXF version, and click Save.

IGES

Initial Graphics Exchange Specification (IGES) is a file format for transferring
graphics data between CAD/CAM systems.

Autodesk DirectConnect supports the import and export of the neutral IGES
V5.3 (*.iges or *.igs) format files in the Autodesk Alias, Autodesk Maya (Wndows
version), Autodesk Showcase, Autodesk Opticore Studio, and 3ds Max/3ds
Max Design software. See installation information in Install Autodesk Direct-
Connect. (page 7)

NOTE For information about additional software setup for Autodesk Alias, please
see the Autodesk Alias Help.

Import IGES files

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import > Import ModelsAutodesk Showcase
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File > ImportAutodesk Opticore Studio

Application Menu > Import > Select File
to Import dialog

3ds Max/3dsMax Design

2 In the browser, select a native IGES V5.3 (*.iges or *.igs) file.

3 Click OK, or Open to launch the translator and import the file into the
scene.

Export IGES files

1 In your Autodesk software, choose File > Save As, or File > Export >

Active As  .

2 On the File Formats menu, click DWG or DXF. For details about the
available options, see the Help in the Autodesk software.

3 Save to a native IGES V5.3(*.iges or *.igs) file.

Troubleshoot (Autodesk Alias)

If the files you import contain unsatisfactory data, change the following import
options in Autodesk Alias:

Default Trim Curves Specifies the trim curves that the processor uses. You
can select parameter space curves, model space curves, or use the flag that is
present in the IGES file. By default, the preference flag in the IGES files is used.

Shrink Surface When turned ON, Alias detects trimmed surfaces with trim
boundaries that are the same as, or isoparametric to, the natural boundaries
of the untrimmed surface. It then converts these surfaces into Alias surfaces
by shrinking the untrimmed surface to the trim boundaries.

When turned OFF, Alias converts all trimmed surfaces of this type to Alias
trimmed surfaces.

Types of data imported

The DirectConnect for IGES translator imports ASCII format IGES files with
or without linefeed characters at the end of each record. The software does
not support Binary IGES files.
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The software imports NURBS for this file format and maintains the following
information on import:
■ Surfaces and curves

■ Data organization (groups, layers, visibility, and instances)

■ Units

■ Colors

NOTE
■ For information about this data in your Autodesk software, see Locations

of Imported Data (page 1).

■ For information about options in Alias for data importation, see the
Autodesk Alias Help.

Identify IGES supported entities in log files

The following table shows IGES entities supported on import by DirectConnect
for IGES.

NOTE  The input translator ignores any entities with an entity use flag value 02
(Definition), except for entity use flag value with IGES Subfigure Definition entity
(Type 308).

IGES EntityFormType

circular arc0100

composite curve0102

conic arc, ellipse, parabola, hyperbola0-3104

copious data1106

copious data2106

copious data11106

copious data12106
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IGES EntityFormType

closed area63106

plane0108

bounded plane+/- 1108

line0110

parametric curve0112

parametric surface0114

point0116

ruled surface0 - 1118

surface of revolution0120

tabulated cylinder0122

direction0123

transformation matrix0124

rational B-spline curve0-5126

rational B-spline surface0-9128

offset curve0130

offset surface0140

boundary entity0141
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IGES EntityFormType

curve on surface0142

boundary surface0143

trimmed surface0144

Manifold Solid BRep Object (MSBO)-1,0,1186

plane surface (1)0,1190

right circular cylindrical surface0,1192

right circular conical surface0,1194

spherical surface0,1196

toroidal surface0,1198

subfigure definition0308

associativity instance7, 9402

singular subfigure instance0408

vertex list1502

edge list1504

loop0,1508

face1510

shell1,2514
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(1)For type 190, 0 means unparameterized surface and 1 parameterized. The
plane surface type is unbounded unless it is subordinate to another entity,
such as the Bounded Surface Entity (type 143) or the Trimmed parametric
Surface Entity (type 144), that references its bounding geometry.

IGES levels

The system adds all supported geometric IGES entities that are associated with
IGES level <n> to an Alias layer called LEVEL<n>.

For example, if a 126 B-spline entity directory entry indicates that it is on level
42, then it is added as Layer LEVEL42.

JT

The JT Open Program develops and supports the DirectModel format JT for
the visualization of 3D models.

Autodesk DirectConnect supports the import of JT (up to V9.5) files into the
Autodesk Alias, Autodesk Maya, Autodesk Showcase, Autodesk Opticore Studio,
and 3ds Max/3ds Max Design software. See installation information in Install
Autodesk DirectConnect. (page 7)

Import JT files

1 Choose the menu path in your installed Autodesk software product:

File > Open  or File > Import > FileAutodesk Alias

File > Open Scene or  File > ImportAutodesk Maya
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File > Import > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

Application Menu > Import > Select File to
Import dialog

3ds Max/3dsMax Design

2 In the browser, select a (*.jt) file.

3 Click OK, or Open to launch the translator and import the file into the
scene.

Type of data imported

The software maintains the following information when importing JT files:
■ Precise geometric data conversion

■ Data organization (parent and child hierarchal data, visibility, and
instances)

■ Units

■ Levels of detail (degrees of tessellation)

■ Materials (brightness (shininess), ambient color, specular color, diffuse
color, and emission color)

■ Textures (embedded image files)

■ XT BRep and JT BRep topology

NOTE
■ To locate this data in your Autodesk software, see Locations of Imported

Data (page 1).

■ For Information about Alias options for data importation, see the Autodesk
Alias Help.

Limitations

■ Import options are not available.

■ The software automatically excludes curve geometry and animation when
importing a JT file.
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NX

NX is a solid modeling package based on the Parasolid kernel. The package
contains many (mostly optional) modules, for example CAD, CAM, CAE, sheet
metal applications, knowledge bases, quality control, and rapid prototyping.
The file structure is binary.

Autodesk DirectConnect supports the import of NX files (UG V13.0 through
NX 7.5) into the Autodesk Alias, Autodesk Maya, Autodesk Showcase, Autodesk
Opticore Studio, and 3ds Max/3ds Max Design software.

See installation information in the Install_DirectConnect.pdf document on the
installation CD.

Import NX files

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

Application Menu > Import > Select File
to Import dialog

3ds Max/3dsMax Design
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2 In the browser, select an NX (version UG V13.0 to NX 7.5) part or
assembly*.prt file.

For information about import options in Alias, see the Autodesk Alias
Help.

3 Click OK, or Open to launch the translator and import the file into the
scene.

Export NX files - Autodesk Alias, Autodesk Maya

1 In your installed Autodesk software, choose the menu path:

File > Save As  or  File > Export > Active As
Autodesk Alias

File > Export all or  File > Export SelectionAutodesk Maya

2 In Alias, on the File Formats menu, click NX.

3 For options, see the Help in the Autodesk software.

4 Click Save.

See the Alias documentation for details about building a model for maximum
compatibility between NX and Alias.

Supported Alias geometry types for export to NX

The translator does not support non-geometry entities, such as lights, cameras,
textures, windows, and animations. The numbers in the table entries refer to
Notes for NX entities following the table.

NX EntityAlias Entity

BcurveConic (ellipse/hyperbola/parabola)

CurveConic

CircleCircle

LineLine

BCurveCurve
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NX EntityAlias Entity

BSurface (1), (2)Surface

Face (1), (2)Trimmed Surface

Bsurface (1), (2)Plane

Colour Attribute (3)Shader

Sheet BodyShell (Open)

Solid BodyShell (Closed)

Layer (4)Layer

CategoryCategory

Notes for NX entities

(1) NX cannot have free-standing surfaces, so it maps all surfaces to faces
which must be attached to a sheet body.

(2) Splits appear in surfaces that have internal discontinuities at the
discontinuities.

(3) Mapped as a Display Attribute of the mapped surface or shell.

(4) Layer name is not mapped.

Supported Alias NX entities for Alias import

Alias EntityNX Entity Objects

SurfaceBSurface

SurfaceBounded Plane

SurfaceCylindrical Surface
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Alias EntityNX Entity Objects

SurfaceConical Surface

SurfaceTabulated Cylinder

SurfaceRules Surface

SurfaceBlended Face Surface

SurfaceSurface of Revolution

SurfaceOffset Surface

SurfaceSculptured Surface

CurveBCurve

Line (Curve)Line

CurveBcurve

Point (Curve) (1)Point

Shell (Open) (2)Sheet Body

Groups/Instance (3)Assembly

LayerLayer

CategoryCategory

Notes for Alias NX (object) entities

(1) An NX point converts to a degree 1 curve composed of two coincident
points. On export to NX, this construction converts back to an NX point.
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(2) If the sheet body only points to one face, then Alias converts the face to
a trimmed surface.

(3) This is a one-way mapping. Assemblies cannot be exported.

(4 ) Added as blind data. Can be re-exported.

Types of data imported

We support the import of the following types of NX geometry, and attributes
such as name, color, layer, and visibility.
■ Point

■ Line

■ BCurve

■ Circle

■ Ellipse

■ Parabola

■ Hyperbola

■ Surface Parameter Curve

■ Trimmed Curve

■ Intersection Curve

■ BSurface

■ Planar Surface

■ Spherical Surface

■ Cylindrical Surface

■ Conical Surface

■ Surface of Revolution

■ Spun Surface

■ Offset Surface

■ Ruled Surface

■ Swept Surface

■ Toroidal Surface

■ Blended Edge Surface

■ Blended Bound Surface

■ Facet

32 | Chapter 4   Translator Details



■ Sheet Body

■ Solid Body

■ Part

■ Instance

■ Assembly

■ Category

Open Inventor and Cosmo

Open Inventor™ is a 3D file format from Silicon Graphics Inc., with no relation
to Autodesk Inventor software.

Autodesk DirectConnect supports the import of Open Inventor ASCII or binary
(*.iv) files, or Cosmo 3D™scene binary (*.csb) files into the Autodesk Alias,
Autodesk Maya, Autodesk Showcase, and Autodesk Opticore Studio software.
See installation information in Install Autodesk DirectConnect. (page 7).

Import Open Inventor or Cosmo files

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

Open Inventor and Cosmo | 33



File > Import > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Browse to and select an Open Inventor (*.iv) or Cosmo (*.csb) file.

3 Click OK, or Open.

The translator launches and imports the file.

Type of data imported

The software imports polygons and NURBS for these file formats, and maintains
the following information on import:
■ Data organization (parent, child, and groups)

■ Units

■ Materials

■ Textures

■ Polygonal Shapes

■ Transformation nodes

NOTE To locate this data in your Autodesk software, see Locations of Imported
Data (page 45).

Limitations

When importing Open Inventor files, the system automatically excludes lines,
cameras, lights, manipulators, tolerances, and animation.

34 | Chapter 4   Translator Details



Pro/ENGINEER

Pro/ENGINEER® is a computer-aided design software application.

Autodesk DirectConnect supports the import of Pro/ENGINEER (Wildfire™

Release 6 or lower and Creo Parametrics) part, assembly, or PTC® Granite®

(Release 7 or lower) files (*.prt, *.asm, *.g) into the Autodesk Alias, Autodesk
Maya, Autodesk Opticore Studio, and 3ds Max/3ds Max Design software. See
installation information in Install Autodesk DirectConnect. (page 7)

NOTE For information about additional software setup for Autodesk Alias, see the
Autodesk Alias Help.

Import Pro/ENGINEER files

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import > Import ModelsAutodesk Showcase
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File > ImportAutodesk Opticore Studio

Application Menu > Import > Select File
to Import dialog

3ds Max/3dsMax Design

2 Select a Pro/ENGINEER part(*.prt), assembly (*.asm), or Granite (*.g))
file.

3 Click OK, or Open to launch the translator and import the file.

NOTE  To maintain the original positioning and orientation of part files in
your scene, import the assembly file. Importing part files before the assembly
file positions all of them at the origin (0,0,0) and removes the original
positioning.

Type of data imported

The software imports NURBS for this file format and maintains the following
data on import:
■ Precise geometric surface and topology information

■ Data organization

■ Tolerances and units.

NOTE
■ To locate this data in your Autodesk software, see Locations of Imported

Data (page 45).

■ For information about options in Alias for data importation, see the
Autodesk Alias Help.

Limitations

■ The software changes node names based on geometry, assembly, or part
names.

■ When importing a Pro/ENGINEER file, the software automatically excludes
construction history, lines, and animation.

■ Granite does not support layers or curves.

36 | Chapter 4   Translator Details



SolidWorks

SolidWorks® is a computer-aided design software application.

Autodesk DirectConnect supports the import of SolidWorks part *.sldprt and
assembly *.sldasm files into the Autodesk Alias, Autodesk Maya, Autodesk
Showcase, Autodesk Opticore Studio, and 3ds Max/3ds Max Design software.
It is required that you install and license SolidWorks 2003-2012 on your
machine, and have it running. See installation information in Install Autodesk
DirectConnect. (page 7)

NOTE For information about additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias Help.

Import SolidWorks files

NOTE

Before you can import SolidWorks files, purchase, install, and license
SolidWorks 2005, 2006, 2007, 2008, 2009, 2010, or 2011 on the same machine,
and have it running.

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import > Import ModelsAutodesk Showcase
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File > ImportAutodesk Opticore Studio

Application Menu > Import > Select File
to Import dialog

3ds Max/3dsMax Design

2 Select a SolidWorks part (*.sldprt) or assembly *.sldasm file. If you cannot
see the files, start the SolidWorks software, minimize its window, and
then try again to open the files.

3 Click OK, or Open to launch the translator and import the file into the
scene.

NOTE  To maintain the original positioning and orientation of part files in
your scene, import the assembly file. Importing part files before the assembly
file positions all of them at the origin (0,0,0) and removes the original
positioning.

Type of data imported

The software imports NURBS for this file format and maintains the following
information on import:
■ Precise geometric surface and topology information

■ Data organization

■ Tolerances and unit

■ Colors

NOTE
■ To locate this data in your Autodesk software, see Locations of Imported

Data (page 45).

■ For information about Alias options for data importation, see the Autodesk
Alias Help.

Limitations

When importing SolidWorks files, the software automatically excludes
construction history, lines, and animation.

38 | Chapter 4   Translator Details



STEP

Standard for the Exchange of Product Data (STEP) is an ISO standard exchange
format that multiple programs can recognize. It is used for transferring graphics
data between CAD/CAM systems.

Autodesk DirectConnect supports the import of STEP (*.stp or *.step) files into
the Autodesk Alias, Autodesk Maya, Autodesk Showcase, Autodesk Opticore
Studio, and 3ds Max/3ds Max Design software. See installation information
in Install Autodesk DirectConnect (page 7).

Import STEP files

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio
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Application Menu > Import > Select File
to Import dialog

3ds Max/3dsMax Design

2 In the browser, select a native STEP (*.stp or *.step) file.

3 Click OK, or Open to launch the translator and import the file into the
scene.

Types of data imported

The software imports NURBS for this file format and maintains the following
information on import:
■ Precise geometric surface and topology information (ISO 10303:42)

■ Data organization (layers)

■ Tolerances and units

■ Colors

NOTE
■ To locate this data in your Autodesk software, see Locations of Imported

Data (page 45).

■ For information about Alias options for data importation, see the Autodesk
Alias Help.

Export STEP files

To export STEP files from the CAD software, use AP203 or AP214 specifications.
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STL

STL is a file format native to the stereolithography CAD software created by
3D Systems. Multiple software packages support the STL file format.

Autodesk DirectConnect supports the import of STL files into the Autodesk
Alias, Autodesk Maya, Autodesk Showcase, and Autodesk Opticore Studio
software, and the export of STL files from the Autodesk Alias and Autodesk
Maya software. See installation information in Install Autodesk DirectConnect.
(page 7).

Import STL files

1 Choose the menu path in your installed Autodesk software product:

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 In the browser, select a native .stl (Stereolithography) file.
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3 Click OK, or Open to launch the translator and import the file into the
scene.

Type of files imported

We support ASCII and binary STL (color STL) files.

NOTE To locate this data in your Autodesk software, see Locations of Imported
Data (page 45).

Export STL files

1 In your Autodesk software, choose the appropriate menu item:

File > Export > Rapid PrototypeAutodesk Alias

File > Export All or File > Export Selec-
tion

Autodesk Maya (Windows version)

2 In Maya, you can specify the file type as either ASCII or binary.

Click OK.

In Alias, on the File Format menu, click STL. You can also specify
tolerance levels used in the export of the file.

3 Pick the meshes or shell to export, then click Accept.

4 Adjust settings, if necessary, and click Update.

5 Click Accept.

6 In the Object name box (Windows), or Save As box (Mac), enter a
name for the file, and click Save.
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ZPR

ZPrint CAD format (ZPR™) is a proprietary file format developed by Z
Corporation® and used with ZPrint and ZEdit for printing on high definition
color 3D printers.

Autodesk DirectConnect supports the export of ZPR (*.zpr) files to use in the
Autodesk rapid prototyping solution in the Autodesk Alias, Autodesk Maya,
Autodesk Showcase, and Autodesk Opticore Studio software. See installation
information in Install Autodesk DirectConnect. (page 7)

Export ZPR files using the output command

1 Select a file to export as a ZPR file.

2 Choose File > Export > Rapid Prototype.

3 On the File Format menu, click ZPR (.zpr).
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Depending on the entity selected for export, such as a shell, additional
setup can be required. For information about additional setup options,
see the Autodesk Alias Help.

4 Pick the meshes or shell to export, then click Accept.

5 Adjust settings, if necessary, and click Update.

6 Click Accept.

Types of data exported for ZPR

■ Triangle meshes with simple colors.

■ Textures for use with ZEdit and Zprint software for rapid prototyping.
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Locations of Imported
Data

Autodesk Alias Data

Colors (Shaders)Tolerances and UnitsData Organization

Colors are visible in the Render >
Multi-lister > Shaders window.

View unit settings at Prefer-
ences > Construction Op-
tions.

Parts and assembly information
displays in the Windows > Inform-
ation > Layer Categories win-
dow.

For information about these settings, menu items, and options, see the
Autodesk® Alias® Help.

5
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Autodesk Maya Data

Colors (Shaders)Tolerances and UnitsData Organization

Colors are imported as shaders and
are visible at Window > Render-
ing Editors > Hypershade.

View unit settings at Window >
Settings/Preferences > Prefer-
ences > Settings.
Change the Working Units and
Tolerance settings.

To view layer information, display the
Layer Editor: click Display > UI Ele-
ments > Channel Box/Layer Edit-
or
or
display the Relationship Editor: click
Window > Relationship Editors >
Display Layers.
To View part and assembly informa-
tion, click Window > Outliner or
Window > Hypergraph.

For more information about these settings and menu items, see the Autodesk®

Maya® Help.

Autodesk Showcase Data

Colors (Shaders)Tolerances and UnitsData Organization

Colors are imported as materials and
are visible from Material > Mater-
ial Properties.

Change unit settings in the Import
Status window (File > Show
Status). See the Showcase docu-
mentation for more information.

View Layers, parts, and assembly
hierarchies in the Organizer window
(Scene > Organizer).
This window shows the original file
hierarchy. You can create your own Change tessellation quality in the

Import Status window. See thearrangements of objects. You can
Showcase documentation for more
information.

view and change the state of ob-
jects to visible, hidden, or deleted.

To adjust the Level of Detail (LOD)
for models imported into Showcase,
select Options > Performance
and Quality. Then click the Lock
display quality to button, and
adjust the slider to see the different
LODs.
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For more information about these settings and menu items, see the Autodesk®

Showcase® Help.

Autodesk Opticore Studio Data

Colors (Shaders)Tolerances and UnitsData Organization

Colors can be shaders or appear-
ances. In the Scene Graph Editor,

There are no units in Studio. All im-
ported data is considered the same

View the node structure in the
Scene Graph Editor, in the Win-

in scenegraph, all colors are visibleunit. Set tolerances for tessellationdow > Scene Graph Editor
menu. It opens by default. in the appearance field of a shape

node. Appearances are visible only
in the File > Preferences dialog-
box, GeomX tab.

NOTE GeomX is not available until
you load the GeomX module in the
Modules tab (in the same dialog
box) and restart Studio.

in the Scene Graph Editor. Shaders
are visible in both the Scene Graph
Editor and through the Windows
> Shader List dialog box.

Set tessellation tolerances on the
GeomX tab, Import tessellation
section. To retessellate, use the
Window > GeomX > Tessellate
dialog box, and enter new settings.

For information about these settings, menu items, and options, see the
Autodesk® Opticore® Studio Help.
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Glossary

ASM (.asm)

A file format used by Pro/ENGINEER to represent an assembly.

assembly

An organizational file that fits together a collection of manufactured parts
into a complete model.

BSD license

The Berkeley Software Distribution license for redistribution and use of source
code.

CATIA® V4

CATIA V4 is computer-aided design software from Dassault Systèmes. Autodesk
DirectConnect allows the exchange of 3D model data from CATIA V4, using
.model, .session, .exp, .dlv, and .dlv3 files.

CATIA® V5

CATIA V5 is computer-aided design software from Dassault Systèmes. Autodesk
DirectConnect allows the exchange of 3D model data from CATIA V5, using
the native CATIA part (.CATPart), product (.CATProduct), and (.cgr) files.

CGR ® (.cgr)

CATIA Graphical Representation (.cgr) is the triangulated format used by
CATIA V5.

Cosmo™

A legacy 3D file format from Silicon Graphics Inc. using efficient binary
compression and *.csb (Cosmo scene binary) files.
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CSB (.csb)

Cosmo 3D™scene binary (*.csb) files.

DLV (.dlv)

A file format used by CATIA V4 computer-aided design software from Dassault
Systèmes.

DRAW (DR)

A two-dimensional entity defined in the drafting and detailing world.

DWF™

Design Web Format, a file format developed by Autodesk for web viewing and
printing.

DWG™

AutoCAD drawing file) A file format used by Autodesk AutoCAD software that
contains lines, curves, and 3D data.

DXF™

(Drawing eXchange File) A file exchange format containing ASCII code and
binary representations of the objects in a DWG file.

G (.g)

A file format used by Pro/ENGINEER PTC Granite for import into the Autodesk
products that DirectConnect supports.

Granite®

A CAD technology platform for design collaboration using solid models.

IAM (.iam)

A file format in the Autodesk Inventor software represent an assembly.

IGES

(Initial Graphics Exchange Specification) A file format for transferring graphics
data between CAD/CAM systems. A neutral file format that can be imported
into any number of CAD or modeling packages.

IPT (.ipt)

A file format in the Autodesk Inventor software to represent a part.
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IV (.iv)

A file format in the Open Inventor software.

JT

JT is a DirectModel file format that is developed and supported by the JT Open
Program for the visualization of 3D models.

NX®

NX is a solid modeling package based on the Parasolid kernel. The package
contains many (mostly optional) modules: for example, CAD, CAM, CAE,
sheet metal applications, knowledge bases, quality control, and rapid
prototyping. The files structure is binary.

Open Inventor™

Open Inventor is a legacy 3D file format from Silicon Graphics, Inc. Open
Inventor is not related to Autodesk Inventor software. Open Inventor is an
object-oriented 3D toolkit that describes complete 3D scenes, which can be
made interactive and that are optimized for OpenGL. It is an ASCII or binary
file format.

PCRE

The Perl-compatible regular expressions is a library of functions to support
regular expressions, with syntax and semantics as close as possible to the
syntax and semantics in the Perl 5 language.

Pro/ENGINEER®

A solid modeling CAD/CAM/CAE software product from Parametric Technology
Corporation that requires positional construction tolerances.

PRT (.prt)

A file format used by NX to represent a part or assembly file.

SLDASM (.sldasm)

A file format used by SolidWorks to represent an assembly file.

.sldprt

A file format used by SolidWorks to represent a part file.

SolidWorks®

A solid modeling CAD/CAM/CAE software product from SolidWorks
Corporation that requires positional construction tolerances.
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SPACE (SP)

A three-dimensional entity defined in the 3D modeling world.

SPF

Alias SPF (Studio Packet File) is a native file format used by Autodesk Alias
software, with the extension .wire.

STEP (.step)

An international standard for the exchange of geometric product definitions.
STEP formats that are relevant to Autodesk products are AP203 (general
mechanical CAD) and AP214 (automotive CAD).

STL

An STL (StereoLithography) file is a triangular representation of 3D surface
geometry. The surface is tessellated, or broken down logically into a series of
small triangles (facets). A perpendicular direction and three points representing
the vertices (corners) of the triangle describe each facet.

STP (.stp)

A file format used in STEP (Standard for the Exchange of Product Data) for
transferring graphics data between CAD/CAM systems.

V3Rx

A file format generated by a version of CATIA that is older than V4.

ZPR

ZPrint CAD format (ZPR) is a proprietary file format developed by Z
Corporation. It is used with ZPrint and ZEdit for printing on high definition
color 3D printers. Autodesk Direct lets you export files in ZPR (*.zpr) format
to use in the Autodesk Rapid Prototyping solution.
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