Introduction _______________________________________________________________ 2

About Autodesk® ImageModeler™ ________________________________________________ 2
Goal of this tutorial ................................................................................................. 2
Taking photographs ................................................................................................. 2

1. Getting Started .................................................................................................. 3
The Autodesk ImageModeler 2009 interface .............................................................. 3
Loading your shots ................................................................................................. 5

2. Creating markers and calibrating the camera ____________________________________ 9
Creating the first marker ....................................................................................... 9
Creating subsequent markers ............................................................................... 10

3. Improving the Calibration ................................................................................ 13
Creating an additional marker ............................................................................. 13
Creating constraints ............................................................................................. 14
Defining the world space ...................................................................................... 15
Defining the reference distance ........................................................................... 16

4. Measuring tools ................................................................................................ 17
Measuring your scene ........................................................................................... 17

5. 3D Modeling and Texture Extraction ................................................................ 19
Introduction

About Autodesk® ImageModeler™

Autodesk® ImageModeler is the software solution to take measures and create photo-realistic 3D models based on photographs and full panorama images.

Since all the workflow with ImageModeler is based on real pictures, all measures and photo-realistic scenes creation is now an intuitive process. Creating a 3D model becomes as simple as drawing lines on images!

Goal of this tutorial

This step-by-step tutorial guides you through the ImageModeler workflow. You will learn how to create a project and you will become familiar with ImageModeler and its tools. The first stage in any project is to take good quality shots, and this tutorial gives a few hints on how to do it properly. The next stage is to calibrate the cameras, which estimates the camera parameters for all the shots (viewpoint, orientation, focal length). You can then create 3D shapes and perform 3D measurements directly from the shots, and project textures onto the 3D shapes from the original shots.

Taking photographs

This is one of the major steps, because it influences the success of your project. The major tips are the following:

- Take at least 2 photographs of your subject with known zoom value.
- Take at least 3 photographs of your subject with unknown parameters.
- Take photographs from substantially different positions, but with enough common areas.
- Try to capture as much of the subject as you can in each photograph.
- Keep perspective in your subject; try not to take pictures showing only a portion of a flat surface.
- If your object does not have natural features, easy to identify in the images (e.g., a corner of a building), place physical markers on your subject or place an additional object in the scene with visible features.
1. Getting Started

In this tutorial, we took three photographs of a building. These photographs show the building with clear perspective from different viewpoints to cover the front and the top parts of the building.

The Autodesk ImageModeler 2009 interface

When you start ImageModeler, you will see the following window organization:

- The Display toolbar contains the display options for objects and components in the viewports.
- The Scene Browser allows you to select and change properties all the ImageModeler components such as camera shots, locators, measure objects, camera devices, objects, mapping group and materials.
- The Properties Toolbar contains information on the settings relevant to the active Tool.
- The 3D Workspace is where you do your work, including managing images, calibrating cameras, modeling objects, and extracting textures.
Loading your shots

Before starting a new project, you must choose the project type:

- **single image**, which could be a normal shot or a full 360 panoramic image
- **multiple images**, which could be mix of normal shots and panoramic images

When ImageModeler starts, you must choose between “Single” and “Multiples” and between “Images” and “Panoramas”.

In this tutorial, we will work with three photographs so choose **Multiples** and click **Load Images** or select **File > Load Images** (Shortcut: **Ctrl + L** (Windows) or **Command + L** (Mac)).

1. This opens a dialog in which you select shots taken with the same camera and the same image resolution. In our case, the three shots have been taken with one camera and they have the same resolution, but have not been taken with the same zoom parameters.
2. Click **Add Images** to import the images from disk. A file dialog opens, where you can select the images to import.
3. Select the three images “Image1.jpg” and “Image2.jpg” and “Image3.jpg” and click **Open**.
4. This imports the selected images to the Load Images dialog. You can then specify additional information for these images, such as an estimate of the focal length when the picture was shot, and whether they have been taken with constant zoom settings or not. In the current case, the zoom was not necessarily the same, and we know nothing about the focal length value, so we leave the default values and ImageModeler will take care of the rest.
5. Click **OK**. ImageModeler automatically adds the images (shots) into the Shots folder of the Scene Browser and installs them into the viewports.
6. A message dialog opens and ImageModeler asks whether you want to load additional images. For some projects you could add other images, for example, more images of the subject taken with another camera. In the current case, we have loaded all the pictures we need. Select No.

**NOTE** If you need to change the suggested layout, you can use **Window > Layout** to select a specific layout, and then drag and drop images from the **Scene Browser** to the viewport of your choice.
Load the **loaded.rzi** file to see this result.
2. Creating markers and calibrating the camera

By identifying 2D points in the images ("markers") that correspond to the same point in space ("locators"), you will provide ImageModeler with the information it needs to derive the 3D position, orientation, focal length, and distortion of the camera(s) that were used to capture the photographs.

Creating the first marker

To create the first marker:

1. Activate the **Place Marker** tool (it should already be activated):

2. While moving the pointer over the images, you should see a green pointer with which to create a new locator.

3. To place the first marker, click in “image1” on the left facing corner of the balcony. The **Magnifier** pops up (keep the mouse button down):

4. Drag the cursor precisely on the left corner (see picture above) and release the mouse button. The first marker is placed and a “Locator” is created and selected in the **Scene Browser**.

5. To place corresponding markers in images “image2.jpg” and “image3.jpg”, click in image2 and in image3 on the left facing corner of the balcony. The images below demonstrate where to place the marker in Image2.jpg and Image3.jpg, respectively:
NOTE the cursor is now white, indicating that you are placing a marker corresponding to an existing locator. You notice that all three markers have the same name, “Locator”, meaning that they represent different views of the same point in space.

Creating subsequent markers

1. To create markers for a new locator, click the Place Marker tool again, or press the Ctrl key (Windows) or Command key (Mac) while clicking (the cursor changes to green).
2. Create seven new locators at the positions highlighted in the images below. Since they are all visible in all three pictures, this represents a total of 21 additional markers.

   - Locator_2 is on the right upper corner of the terrace.
   - Locator_3 is on the right upper corner of the second building.
   - Locator_4 is on the left upper back corner of the second building.
   - Locator_5 is on the parking (ground marquee corner).
   - Locator_6 is on windshield of a white car.
   - Locator_7 is on the middle column of the first building.
   - Locator_8 is on the corner of the terrace veranda roof.
The photo below shows the position of all markers in ImageModeler:

3. After placing the “Locator_8” marker in the second image, ImageModeler pops up a message indicating that the calibration has succeeded. Click OK.
NOTE When the calibration process is incomplete, ImageModeler automatically switches from the Calibration tab to the Modeling tab. To make calibration changes or to add some elements, go back to the calibration tab.

You can adjust the position of a marker by doing the following:

1. Select the **Place Marker** tool again.
2. Select the marker you want to move.
3. Click and drag to the new position.

By default, once you have placed the markers, the calibration process runs automatically.

If calibration does not start, try the following:

1. Verify that **Use Progressive Calibration** is not turned off in the Calibration page of the Preferences dialog (press “P” (Windows) or Command + , (Mac) to open Preferences).
2. Add more markers.
3. Launch the calibration process manually by selecting **Camera > Calibrate** (or press F9 (Windows) or Command + R (Mac)).

Load the **calibrated.rzi** to view the result.
3. Improving the Calibration

To make calibration more accurate, you can provide ImageModeler with information on the scene, such as the known position of survey points, the planarity of a group of points (planar constraints), a known distance between 2 points (distance constraints), or right angles (Corner tool). Because our subject is a building, we first show how to create a right angle constraint. Planar constraints require a coordinate system to be set, so we will move on to those later.

**NOTE** Constraint information is given precedence in the calibration process, so it is important to verify real world information that you want to use (poor constraints produce bad calibration if accuracy is not properly verified).

Creating an additional marker

We don’t have three locators defining a right angle, so we need to create an additional 3D locator at the back corner of the front building.

1. Place a new marker in “image1” (left image). Since cameras are now calibrated, ImageModeler shows a guiding line in “image2” (and in “image3”) on which the marker should be placed (see right image).

2. Place the corresponding locator in “image2” (left image). ImageModeler calibrates again. The 3rd locator is automatically created in “image3” as the intersection of the two guiding lines (right image)
NOTE After you have calibrated, only two markers (drawn as crosses) are necessary to calculate a 3D locator. In the following cases, you will need to add more markers:

- The resulting 3D locator is too far from the feature in the image ("Image3" in our case)
- You want to refine the calibration
- In our case, the feature corresponding to “Locator_9” is hidden in “Image3” by the trees, so we can not add a marker in “Image3”

Creating constraints

We are now going to identify the right angle defined by: “Locator_9”, “Locator”, and “Locator_2”.

1. Activate the Create Corner tool:

2. Select consecutively the three corresponding markers in one of the viewports (e.g., “image1”), starting with the corner, then the edges. In our case, first select “Locator” and then “Locator_9” and “Locator_2”. A corner is drawn in the viewport:

3. Start the calibration process by selecting Camera > Calibrate.

ImageModeler will refine calibration incorporating this new constraint.

NOTE You do not need to use many constraints. One per plane reference is usually enough.

4. Planar constraints are useful when two or more locators share the same plane in the scene. In such scenes we can find a lot of such constraints.

Examples: “Locator”, “Locator_2” and “Locator_9” are planar, and share their Z coordinates (According to the coordinate system, see next Section).
To create these constraints, you need to select the locators all together, in the Scene Browser for example, and select Marker > Define Planar Constraint... or click the planar constraint icon you want.

**Defining the world space**

The world Space defines the reference coordinate system with respect to which all 3D entities will be expressed. It contains the following information:

- The origin of space: O
- The three axes: Ox, Oy, and Oz
- A reference distance

To define the world space:

1. Choose the Worldspace tool.
2. The world space manipulator is drawn in the viewports. ImageModeler has chosen an arbitrary world space position and orientation.
3. First place the origin by dragging and dropping the light blue handle onto “Locator”.
4. Place the X-axis by dragging and dropping the red disk onto “Locator_2”.
5. Place the Y-axis by dragging and dropping the blue disk onto “Locator_8”.
The origin and orientation of your coordinate system are now set. No need to define Z-axis as it is imposed, being orthogonal to the two other axes.

**Defining the reference distance**

1. To refine the constraints even more to the real world, we will now provide ImageModeler with a reference distance taken on site. We measured the width of the building to be 20 meters.
2. Activate the Reference Distance tool
3. Set the reference distance by dragging and dropping the endpoints of the displayed segment onto “Locator” and “Locator_2”.
4. Type 20 in the Reference Distance edit field, then press the Tab key to initialize this value.
5. Click Apply in the world space tool properties

Load calibrated_constraint.rzi to see the result.
4. Measuring tools

Once you have calibrated the shots, defined the world space and the reference distance, you can make distance and angle measurements directly from the images.

Measuring your scene

To measure the height of the two floors of the building, do the following:

1. From the Modeling tab, choose the Place Marker tool and create an additional locator on the bottom of the first floor, on the same vertical edge as “Locator_2”.
2. Place markers in “Image3” and “Image2” as shown in the picture below to create additional locators “Locator_10”
3. From the Measuring tab activate the Distance Ruler tool
4. Move the pointer over “Locator_2” in the viewport of your choice. The cursor snaps on “Locator_2”.
5. Click “Locator_2” to select the first endpoint of your ruler.
6. Move the cursor over “Locator_10” and click to select the second endpoint of your ruler.

An object named “Ruler” is created in the Measures folder of the Scene Browser. The length of the ruler is shown in the viewport, and also in the property page of the ruler in the Scene Browser.

**NOTE** You can change the units in the Preferences dialog by selecting Edit > Preferences > Measure (Windows) or ImageModeler > Preferences > Measure (Mac) tab.

Load the measuring.rzi file to see the result.
5. 3D Modeling and Texture Extraction

This tutorial shows the creation of a model for one part of the building. We will create this part of the model starting with a cube that will be snapped on the existing locators.

1. Activate the Create Primitive tool.

   By default the primitive mode is set to cube.

2. The Create Primitive tool asks you to set four points (objects extremities) to position your box. To set the first point of the box, move the pointer over “Locator_9” and click when the cursor is snapped on the locator. To set the second point of the box, move the pointer over “Locator” and click when it snaps.

3. To set the third point of the box, move the pointer over “Locator_2” and click when it snaps. The basis of the box is created.

4. To set the height of the box, move the pointer over “Locator_10” and click.
The box is now created. A new object named “Cube” is now added in the Objects folder of the Scene Browser.

5. To rename the object “Cube” to “Building”, select the object “Cube” in the Scene Browser and edit the label value.

**NOTE** As all the primitives inside ImageModeler are yet to have UV mapping done, until any topologic modification is made inside the created primitives, no mapping projection needs to be done.
You can also change the mapping group name related to the object to prepare the texture extraction with an associated naming convention.

![Mapping Group Name Example](Image)

The next step is to launch the extraction process.

1. Select the **Texturing tab** in the workflow toolbar.
2. Activate **Object selection** mode (it should be already activated by default).
3. ImageModeler needs to know which object(s) or face(s) need to be textured. To select the object “building”, click “Building” in the viewport (or in the **Scene Browser**). The object is highlighted in the **Scene Browser**.
4. Click **Extract texture** to start the texture extraction process (or **F11** (Windows) or **Command + E** (Mac)).

The texture dialog is displayed. At this point you can change some extraction parameters:

- **Image(s) Selection to use (or not)**
- **Define size mode and value (Density/Best/Custom)**
- **Extraction Mode (Vertex Weighted /Use all Shots/Area Weighted)**
- **Blending Mode (Smart/Linear/PSD manual)**
- **Use Hidden Objects For Visibility option**

By default, all images are selected, the texture size is defined by density (and density value is set in the preferences to 100), the extraction mode is vertex weighted, the blending mode is set to smart and the visibility option is not checked.
5. Change the **Density value to 20** and click **OK** to launch the extraction process.
ImageModeler creates the corresponding texture for each mapping linked to the selected object or selection, named “Building_MG_TX”.

After the texture is extracted, you can activate the UV View in one of the 4 viewports (right-click and choose “Switch to UV View”, or press “\” key) to see how the texture is mapped onto your object (UV Mapping).
Your first textured object is created! You can now export your textured scene in a 3D format with the File > Export As... option.

Load the model_textured.rzi file to see the result.
By repeating the steps above and adding more information, you can make your model more detailed.