Getting Started
Table of Contents

Overview .................................................................................. 1
  Introduction to AutoCAD P&ID 2009 ........................................ 2
  Tour the P&ID Drawing Environment ....................................... 2
  Control the Display of the P&ID Drawing Space .................. 12

Create a Project and Organize Drawings ................................ 15
  Create a Project ................................................................. 17
  Create Drawing Files for My Project .................................... 18
  Set Drawing Properties ..................................................... 19
  Organize Project Files ....................................................... 21

Work in a Project Environment ................................................. 23
  Open a Project ................................................................. 25
  Refresh the Drawing Status ............................................... 25
  Update Work History ....................................................... 26
  Save Project Drawings ..................................................... 27
  Package a Project ............................................................ 27
  Publish a P&ID DWF or DWFx File ..................................... 30
Table of Contents

Design a P&ID Drawing
   Add Components          35
   Add Schematic Lines     37
   Validate the Drawing    39
   Add Inline Components   43
   Add Instruments         44
   Edit the P&ID Drawing   46
   Tag and Annotate Components and Lines 50
   View and Manipulate Drawing Data 53
   Export a P&ID Drawing to AutoCAD 58

Advanced Tasks—Configure the P&ID Drawing Environment
   Set Up a New Project     63
   Set Up Components and Lines 67
   Set Up Tag Formatting   74
   Set Up Annotations      79
   Set Up Layers and Colors for Components and Lines 82
   Set Up Properties for Components and Lines 85
   Set Up a Customized View for the Data Manager 90

Glossary 97
Welcome to the AutoCAD P&ID 2009 *Getting Started Guide*.

This guide provides introductory best-practice workflows and tasks that prepare you for working in AutoCAD P&ID 2009. Each chapter contains a workflow diagram for each major project or drawing. Each workflow is a visual representation of the specific exercises that follow the workflow.

In this guide, PIP symbols are used in the examples and exercises. The program includes PIP, ISO, ISA, and DIN symbols.

For more information about each workflow and set of procedures, see the AutoCAD P&ID Help system (available from the Help menu in the program).
Introduction to AutoCAD P&ID 2009

AutoCAD® P&ID 2009 is a drafting program that helps you to create P&ID drawings easily and with a minimum of training. AutoCAD P&ID provides a library of symbols that you access from a tool palette and then place in your drawing. You use schematic lines that move when you move equipment, resize automatically, and display the flow direction.

You work exclusively in a project environment, so that your drafting is consistent with others working in the same project.

You can also create reports for a single drawing or an entire project.

If you are an administrator, you can configure a custom P&ID drafting environment that is exactly right for your organization and your drafters.

Tour the P&ID Drawing Environment

Before you draft in AutoCAD P&ID 2009, it is important that you understand how the drawing environment is organized and learn some tips for working in this environment.

P&ID Workspaces

A workspace consists of menus, toolbars, and palettes that are organized so that you can work in a custom, task-oriented drawing environment while saving drawing real estate for those interface elements you want to display.

When you first open the program, the P&ID PIP workspace is displayed by default. It displays interface elements that are particular to both that symbol standard and to the P&ID program. Other elements of the workspace are displayed as you use the program.

The Workspaces toolbar is displayed in the upper-left corner of your drawing area. You can choose from four P&ID workspaces (P&ID PIP, P&ID ISO, P&ID ISA, and P&ID DIN). You can also select AutoCAD workspaces.

For more information about using workspaces, see “Create Task-Based Workspaces” in the AutoCAD Help system.
Following are descriptions of interface elements that are frequently used in a P&ID workspace.

**Project Manager**

The Project Manager provides an organized project environment in which to work. You can create a new project, and you can open, add, and create drawings. You can also export and import data, create project reports, and perform other project tasks.

The Project Manager also provides access to the Project Setup dialog box, which is used by administrators to configure the drawing environment based on your company or client requirements.

**Project Setup Dialog Box**

Administrators can configure project and drafting preferences, such as symbology, tagging rules, annotation properties, layers, colors, and Data Manager views.
Chapter 1 Overview

P&ID Toolbar

The P&ID toolbar displays grouped icons that provide quick access to creating or editing schematic lines and line groups. It also provides quick access to the Project Manager and the Data Manager, and to the validation, annotation, and tagging options. If the toolbar is not displayed, you can display it by right-clicking any toolbar and selecting PID.

Tool Palettes

The P&ID PIP, ISO, ISA, and DIN tool palettes display standard component and line symbols for your P&ID drawings. By default, the P&ID PIP tool palette is displayed. You can switch to another tool palette by right-clicking the tool palette title bar and...
selecting a tool palette from the list. Of course, you want to use the tool palette that matches the symbol standards you use in your P&ID project.

Administrators can add custom component and line symbols to a P&ID tool palette when they set up a project. For more information about project setup, see Chapter 5, “Advanced Tasks—Configure the P&ID Drawing Environment.”

The following illustration displays the P&ID PIP, ISO, ISA, and DIN tool palettes, with the Equipment tabs selected for each standard.

To place a tool from the tool palette into a drawing, click a symbol in the tool palette and click in the drawing where you want to place it.

**NOTE** If you do not see the P&ID workspace interface elements in your drawing area, you may not be displaying the proper workspace. Verify that you are using one of the four P&ID workspaces by clicking Tools menu ➤ Workspaces ➤ P&ID PIP, P&ID ISO, P&ID ISA, or P&ID DIN.

**P&ID Properties Palette**

The P&ID Properties palette is similar to the AutoCAD Properties palette, where you can change the property values of selected components or lines. Additionally, the P&ID Properties palette allows you to change values of P&ID properties.
Following is an illustration of the Properties palette that is displayed when you double-click a schematic line. The P&ID-specific properties that you can populate are illustrated here (under P&ID).

Data Manager
Like the Properties palette, the Data Manager provides access to component and line data. You can view and change data for multiple P&ID objects in a drawing or project. You can tag multiple components and lines, select components and lines to zoom to in the drawing, export component and line data to Microsoft® Excel® spreadsheets (XLS/XLSX), and import modified data back into your drawing or project. You can also export data to and import data from text-only CSV (comma-separated value) files.
P&ID Validation Setting Dialog Box

You can check your project for common errors such as size or spec mismatches, non-terminating lines, unconnected components, and flow direction conflicts. You specify what errors are checked in the P&ID Validation Settings dialog box.
Chapter 1  Overview

Validation Summary
The Validation Summary window displays a list of all errors found in your drawings.

Work History Dialog Box
Depending on how your administrator sets up the Work History prompting behavior, the Work History dialog box may be displayed when you open a drawing from the Project Manager or close the drawing. You are prompted to provide details about the drawing file that you or another drafter may find useful later, such as the work history status, and any notes about the drawing.
Assign Tag Dialog Box

Depending on how your administrator sets up the tag prompting behavior, the Assign Tag dialog box may be displayed when you add a component or line that is likely to require a tag. You may not know the tagging data at the time you insert a component or line. You can always add the data later by right-clicking the component or line and clicking Assign Tag, by double-clicking the item and changing data in the Properties palette, or by using the Assign Tag toolbar button.
P&ID Grips

Grips are displayed at strategic points on components or lines that you select. You can click or drag these grips to perform actions described in the following table.

<table>
<thead>
<tr>
<th>Grip Name</th>
<th>Grip Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection grip</td>
<td></td>
<td>Connects a schematic line to a component or to another schematic line.</td>
</tr>
<tr>
<td>Endline grip</td>
<td></td>
<td>Continues or shortens a schematic line.</td>
</tr>
<tr>
<td>Flip grip</td>
<td></td>
<td>Flips an object in the opposite direction.</td>
</tr>
<tr>
<td>Gap grip</td>
<td></td>
<td>Breaks a schematic line between the gap symbols.</td>
</tr>
</tbody>
</table>
Substitution Palettes

Substitution palettes are displayed for certain components and lines. With these palettes, you can switch to a similar item by selecting the item from the palette. To access the substitution palette, click the component or line and click the substitution grip, or right-click a selected item and click Substitute on the shortcut menu.

<table>
<thead>
<tr>
<th>Grip Name</th>
<th>Grip Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stretch grip</td>
<td></td>
<td>Moves a schematic line orthogonally.</td>
</tr>
<tr>
<td>Substitution grip</td>
<td></td>
<td>Displays a palette with similar components so that you can select a substitute for the component you originally placed.</td>
</tr>
</tbody>
</table>

P&ID Drawing Tooltips

After you add components and line segments to a P&ID drawing, you can perform a quick query of a component or line segment by moving the crosshairs over it. When the crosshairs are positioned over a component, the values stored in the Class Name and Tag fields for the component are displayed in a tooltip. If the crosshairs are positioned over a line segment, the Pipe Line Type (instead of the Class Name), Tag, and To and From information are displayed in a tooltip.

P&ID Shortcut Menus

With shortcut menus, you can perform tasks that are specific to a component or line. For example, when you right-click a schematic line, a shortcut menu is displayed for
quick access to tasks such as assigning a tag, annotating the line, substituting a line type, and various options for schematic line editing.

Control the Display of the P&ID Drawing Space

By controlling the display of dockable windows and toolbars, locking their position, and using two monitors, you can optimize your P&ID drawing space.

Control the Display of Dockable Windows

Many windows, such as the Project Manager, the P&ID tool palette, and the Data Manager, are dockable. Each can be docked, anchored, or floating.

Settings for changing the display of dockable windows can be accessed on a shortcut menu. To display the shortcut menu, right-click the title bar of the window and select one of the following options:

- **Size.** Drag an edge of the window to change its size. If the window has panes, drag the bar between panes to resize the panes.
Allow Docking. A docked window adheres to one side of the application window, causing the drawing area to be resized. To undock a window temporarily, hold down CTRL and move the window.

Anchor. Attach, or anchor, a dockable window or palette to the left or right side of the drawing area. An anchored window opens or closes as the cursor moves across it. When an anchored window is open, it overlaps the drawing area. An anchored window cannot be set to stay open. The Allow Docking option must be selected before you can anchor a window.

Auto-hide. Display a floating window that opens or closes as the cursor moves across it. When this option is cleared, the window stays open.

Transparency. Display a window as transparent so that it does not obscure objects behind it. This option is not available for all windows or when hardware acceleration is turned on.

Control the Display of Toolbars
To display or hide toolbars, right-click any toolbar to display a list of toolbars. A check mark next to a toolbar name indicates that it is displayed. Click a toolbar name in the list to display or clear the check mark.

A toolbar can be docked or floating. A docked toolbar is attached to any edge of the drawing area. Undock a toolbar by clicking the double bars and dragging it into the drawing area. You can click the title bar and drag it to a new location or dock it. Resize a floating toolbar by dragging an edge.

Lock the Position of Toolbars and Dockable Windows
Once you have arranged toolbars and windows, you can lock their positions. Locked toolbars and windows can still be opened and closed, and items can be added and deleted. To lock the position of a toolbar or dockable window, click Window menu ➤ Lock Location, and select a toolbar or window to lock. To reposition it temporarily, hold down the CTRL key while you move it.

Use Dual Monitors to Optimize the Drawing Area
To create a larger drawing space, you can use two monitors. For example, you could use one monitor to display the drawing area, while the other monitor displays the P&ID tool palette, the P&ID toolbar, the Project Manager, Data Manager, and so on.

For more information about setting up dual monitors, see the instructions provided with your graphics card or review the display properties of your operating system.
Create a Project and Organize Drawings

Use the Project Manager to create and organize the drawings in your AutoCAD P&ID project.

The workflow on the next page describes one way to create a project and organize your project drawings. For more information and procedures, see “Set Up a New Project” and “Organize Project Drawings” in the AutoCAD P&ID Help system.

You can also configure various settings for a project. Learn more about project setup in Chapter 5, “Advanced Tasks—Configure the P&ID Drawing Environment.”
Chapter 2  Create a Project and Organize Drawings

Create a Project

Create Drawing Files

Set Drawing Properties

Organize Project Files
Create a Project and Organize Project Drawings

Create a Project
Create a new project to use as the default for the exercises you’ll perform in this book.

To create a project
1. Click File menu ➤ New Project.

2. In the Create Project dialog box, Template section, select the PIP (Imperial) standards template from the list.

3. Under Project Details, do the following:
   - Under Name, enter My Project.
   - Under Description, enter My project for Getting Started Guide tasks.
   - Under Project Directory, enter C:\My Documents\My Project.
   - Under Project DWG Directory, enter C:\My Documents\My Project.
   - To the left of Edit project properties after creating project, clear the check box.

4. Click Create.
You are now ready to add drawing files to your project.

**Create Drawing Files for My Project**

Now that you’ve created a project, you create drawing files that become part of the project. In later exercises, you work within those drawing files.

**To create new project drawing files**

1. In the Project Manager, right-click *My Project*. Click New Drawing.
2. In the New DWG dialog box, do the following:
   - Under DWG Number, enter 01.
   - Under DWG Title, enter 001.
3. Click OK.

The drawing file is added to your project.

4. Repeat steps 1-3 of this exercise to create a second drawing file with the drawing number 02 and a drawing title of 002.
5. Click and drag drawing 001 to place it above drawing 002.
You are now ready to set drawing properties for your project's drawing files.

**Set Drawing Properties**

Drawing properties that you can set for a project include the drawing title, the drawing number, the author, a short description of the drawing, and the plant area documented in a drawing.

**To set drawing properties**

1. In the Project Manager, under *My Project*, right-click 001. Click Properties.
2 In the Drawing Properties dialog box, enter the following information:

- To the right of Area, enter 51.
- To the right of Description, enter **Test drawing file 01-001**.
- Click OK.

**Note** Make sure you add the drawing number to all drawings in your project. You can then track drawing-specific data in the Data Manager, which displays the drawing number for all components and lines that are part of this drawing. The drawing number is particularly important when you are using an off-page connector to continue a line from one drawing to another.

You now add the area to the second project drawing.
Create a Project and Organize Project Drawings

3 In the Drawing Properties dialog box for drawing 002, do the following:

- To the right of Area, enter 52.
- To the right of Description, enter Test drawing file 02-002.
- Click OK.

Always add the drawing properties, especially the drawing number, to each drawing in a project.

Organize Project Files

Now that you’ve created your project, added new drawings to the project, and added drawing properties, you can arrange drawings into folders in the project tree.

To create a folder in the Project Manager

1 In the Project Manager, right-click My Project. Click New Folder.

2 In the Project Folder Properties dialog box, do the following:

- Under Folder Name, enter Areas 51-52.
- Select the Create Folders Relative to Parent Folder Storage Location option. This option ensures that the folder paths retain the same folder hierarchy, even if the project files are moved to another computer.
- Click OK.

The folder you created is added to the My Project tree view.
Chapter 2  Create a Project and Organize Drawings

3 Click and drag 001 to move it into the *Areas 51-52* folder. When you see an arrow next to the *Areas 51-52* folder, release the cursor.

4 Click and drag drawing 002, and place it into the *Areas 51-52* folder, under drawing 001. If necessary, drag drawing 001 above drawing 002.

   The new folder expands to display the drawings you moved into it.

Now that you have learned the basics of creating and organizing a project and project drawings, move on to Chapter 3, where you learn how to work in the project environment.
Work in a Project Environment

When you work in a project environment, you can be sure that you and other drafters and designers are all working with the same drawing files, symbols, data, and templates.

The following workflow describes one way to work in the project environment. For more information and procedures, see “Work in a Project Environment” in the AutoCAD P&ID Help system.
Chapter 3  Work in a Project Environment

Open a Project

Refresh Drawing Status  Update Work History

Save Project Drawings  Package a Project

Publish a P&ID DWF or DWFx File
Open a Project

When a P&ID workspace (P&ID PIP, P&ID ISO, P&ID ISA, or P&ID DIN) is the current workspace, the Project Manager is automatically displayed. The last project you opened is displayed in the project tree. You can start work immediately, select a recent project from the drop-down list, create a new project, or search for another project.

In this set of exercises, you work with the project you created in Chapter 2 (My Project, located at C:\My Documents\My Project\My Project\Project.xml).

To open a project

1. If the Project Manager is not already displayed, click Tools menu ➤ Palettes ➤ Project Manager.
2. If My Project (the project you created in the previous chapter) is not already open, open it now.

Refresh the Drawing Status

In the Project Manager, you can display a thumbnail view of a drawing in the project by selecting a drawing and clicking the Preview button on the bottom toolbar.
Chapter 3  Work in a Project Environment

To refresh the drawing status

■ In the Project Manager, on the Project toolbar, click the Refresh DWG Status button. 
The icons representing drawings are updated to indicate their current editing status,
as follows:

■ Locked (opened by you or another user)
■ Available (drawing is available for editing)
■ Missing (drawing has been moved or removed from the project)

Update Work History
You can add work history information as you work in project drawings.

To add status and notes to the Work History

1  In the Project Manager, click drawing 001.
2  On the bottom toolbar, click the Work History button.
Work in a Project Environment  

3 Under Work History, do the following:

■ In the Status drop-down list, select Revision 1.
■ In the Notes box, enter **Updated PID data for process engineer. Round 1.**

**NOTE** In the Project Setup dialog box, Other Settings pane, you can also set up prompting behavior so that the Work History dialog box opens when drafters open or close a drawing file. For more information about this setting and other project settings, see “Configure Drawing Behavior Settings” in the AutoCAD P&ID Help system.

**Save Project Drawings**

Save all project drawings or save a single drawing.

To save all open drawings in a project

■ In the Project Manager, right-click **My Project**. Click **Resave All Project Drawings**.

To save an open drawing in a project

■ Click File menu ➤ **Save**.

**Package a Project**

When you package a project, you can send it digitally or include all supporting documents in an archive. When you create a transmittal, you designate drawings and related files, such as external references (xrefs) and fonts, to be included in the transmittal. You can also specify file formats, folder structures, and instructions to the recipient.

You create the P&ID transmittal package outside of the P&ID project environment.

To transmit drawings

1 Click File menu ➤ **eTransmit**.

2 If you have not already saved your drawings, you are prompted to save them now.
   In the Create Transmittal dialog box, the active drawing file and support files are automatically added to the Files Tree tab.
3 On the Files Tree tab, click Add File.

4 In the Add File to Transmittal dialog box, browse to `C:\My Documents\My Project`, and select the files in the root directory. You can ignore backup files.
5  Click Open.

6  If a message is displayed stating that a file has already been included in the transmittal package, click OK.

7  Repeat steps 3-6 to continue adding all files from the My Project subfolder. Include the following files:

   - ProjSymbolStyle.dwg
   - SubstitutionPalettes.xml
   - PnIdPart.xml
   - ProcessPower.dcf
   - ProcessPower.dcf
   - Project.xml

8  When you finish adding all project files in the Create Transmittal dialog box, click OK.
9  In the Specify Zip File dialog box, do the following:

- To the right of Save In, specify the *My Project* folder location for the ZIP file.
- To the right of File Name, enter *My Project*.
- Click Save.

**NOTE** For more information about setting up and using a transmittal package, see “Package a Set of Files for Internet Transmission” in the AutoCAD P&ID Help system.

### Publish a P&ID DWF or DWFx File

A DWF (Design Web Format) is a set of drawings or images that is compressed into a single, smaller file, making sharing across the Web fast and secure. A DWFx file is based on the XML Paper Specification (XPS) format from Microsoft. DWFx files are easily distributable on the Windows Vista platform as this format is supported by the XPS Viewer. You can also view DWFx files using Autodesk Design Review.

Much like Adobe® PDF, the sheets within the set are images of the drawings and are not intended to be any more editable than drawings printed to paper. In addition, DWF and DWFx files retain design information and scale and are therefore suitable for architects, engineers, and designers to review and mark up, without risk of changes to the original DWG file.
In the Project Manager, you can publish to DWF or DWFx format an entire project, a subset of a project, or a single drawing in a project. In the following exercise, you publish the entire project. For more information about other DWF publishing options, see “Share P&IDs” in the AutoCAD P&ID Help system.

**To publish a P&ID DWF file**

1. In the Project Manager, right-click *My Project*. Click Publish Dialog Box.

2. In the Publish dialog box, under Publish To, in the drop-down list, select either DWF File or DWFx File.

3. Under Include When Adding Sheets, make sure both Model Tab and Layout Tabs are selected.

4. Click P&ID Publish Options.
In the P&ID Publish Options dialog box, do the following:

- Under P&ID DWF Options, to the right of P&ID Information, verify that Include is selected. If it is not, click the box and select Include in the drop-down list.
- Under Default Output Location, to the right of Location, select C:\My Documents\ and click the [...] button. In the Select a Folder for Generated Files dialog box, navigate to the My Project folder and select it. Click Select.
- Click OK to close the P&ID Publish Options dialog box.

5 In the Publish dialog box, click Publish.

6 If the Processing Background message is displayed, click OK.

5 When the DWF or DWFx file is published, you can use Autodesk Design Review to communicate changes and markups without changing the actual drawing (DWG) file. If you plan to share the DWF or DWFx file with clients, they should download Autodesk Design Review from the Autodesk website (www.autodesk.com).
Design a P&ID Drawing

You can easily create dynamic schematic drawings. AutoCAD P&ID provides numerous components and lines that you can place in your drawings. Components and lines contain data that links to the Data Manager, where you can view reports, export the data, and import changed data back into the program. You can also export a drawing to AutoCAD.

At any stage in the drafting process, you can validate a drawing, several drawings, or an entire project. By checking for errors often, you can make corrections early in the drafting process and make sure that your drawings comply with your company’s standards.

The following workflow describes one way to design your P&ID drawings using the PIP standards. For more information and procedures, see “Create and Modify a Drawing” in the AutoCAD P&ID Help system.
Chapter 4  Design a P&ID Drawing

1. Add Components → Add Schematic Lines
2. Validate the Drawing → Add Inline Components
3. Add Instruments → Edit the P&ID Drawing
4. Tag and Annotate Components and Lines → View and Manipulate Drawing Data → Export a Drawing to AutoCAD
Add Components

You can place various types of components and lines to create and edit dynamic schematic drawings that are part of your project.

The following exercises illustrate how to add a pump and then a tank to a drawing. This is just one way that you can work on drawings.

**NOTE** In the exercises that follow, you create a simple schematic drawing that builds from one exercise to the next. Make sure to save your drawing file after each exercise.

To add a pump to a drawing

1. In the Project Manager, right-click drawing 001 and click Open.
2. If the P&ID PIP tool palette is not already open, click Tools ➤ Palettes ➤ Tool Palettes.
3. In the P&ID PIP tool palette, on the Equipment tab, under Pumps, select Horizontal Centrifugal Pump.
Chapter 4  Design a P&ID Drawing

4  Click an open area in the middle of the drawing to specify a location for the pump.

5  If the Assign Tag dialog box is displayed, click Cancel. You add tagging information and annotations later.

6  Save the drawing file.

To add a tank to a drawing

1  In the P&ID PIP tool palette, on the Equipment tab, under Storage Tanks, select Dome Roof Tank.

2  Click any open area in the upper-right section of the drawing to specify a location for the tank.
3 Specify a scale factor for the tank size or press ENTER to accept the default scale.
4 If the Assign Tag dialog box is displayed, click Cancel. You add tagging information later.
5 Save the drawing file.

Add Schematic Lines

Schematic lines are an integral part of the entire P&ID process and are necessary to design, convey, and construct your drawings.

In the previous exercises, you added a pump and a tank to your drawing. Now, connect these components with a pipe line.

To add a pipe line

1 In the P&ID tool palette, on the Lines tab, under Pipe Lines, select Primary Line Segment.
2 In the drawing, click the top nozzle of the pump to place the primary line.
3 Click to the left of the tank to specify the second point of the pipe line.
4 Click again at the edge of the tank to connect the line to the tank.
   A nozzle is created automatically when the line is connected to the tank.
5  Press ENTER to end the series of pipe line segments.
   A pipe line is displayed with arrows that show the flow direction of the line.
6  Click File menu ➤ Save.

**Validate the Drawing**

You can check your drawing for errors at any time, preferably early in the project. The validation process detects property mismatches between components and lines and identifies any items that do not conform to your company's standards.

The following exercises illustrate how to configure validation, validate a drawing, and fix a common error.

**To view validation settings**

1  On the P&ID toolbar, click Configure Validation Settings.

   **Note** If the P&ID toolbar is not displayed, you can display it by right-clicking any toolbar in the menu area and selecting PID.
In the P&ID Validation Settings dialog box, do the following:

- Under P&ID Objects, make sure all options are selected.
- Click the plus sign (+) to the left of Base AutoCAD Objects to expand the list. Clear each check box.
- Click OK.

**Note** To view a description of all error types, click each error type (do not click the check box). Under Description, view the error description.

To validate a drawing

1. In the Project Manager, right-click drawing 001. Select Validate.

   The Validation Progress dialog box is displayed. When the validation is complete, the Validation Summary window displays the validation results. You should see an unconnected component error.
In the Validation Summary window, click the Unconnected Components error node. In the drawing, the horizontal centrifugal pump is highlighted because its left nozzle is not connected to a line.

Close the Validation Summary window.

In the next exercise, you add another tank and line to correct this problem.

To repair the validation error

1. In the P&ID PIP tool palette, click the Equipment tab. Under Storage Tanks, select Dome Roof Tank.

2. Click any open area in the lower-left section of the drawing to specify a location for the tank.

   **Note** If you want to reposition the view, right-click the drawing and select Pan. Drag the cursor to pan the drawing to a new location. To zoom, right-click the drawing and select Zoom. Drag the cursor up to zoom in and down to zoom out. Right-click again and select Exit.

3. Specify a scale factor for the tank size or press ENTER to accept the default scale.

4. If the Assign Tag dialog box is displayed, click Cancel. You add tagging information later.
5 Add a schematic line that connects the tank to the left nozzle of the pump. To make sure the flow direction is from tank to pump, start the schematic line at the tank and connect it to the pump.

Note To view a flow-direction error, start the schematic line at the pump and end it at the tank. You can then reverse the flow to fix the error. To reverse the flow, right-click the line and select Schematic Line Edit ➤ Reverse Flow.

6 Click File menu ➤ Save.

7 In the Project Manager, right-click drawing 001 and click Validate.

8 In the Validation Complete message, click Close.

9 Close the Validation Summary window.

Note If your drawing has additional errors, experiment with resolving the errors using the Validation tool.
**Add Inline Components**

Inline components, such as valves, are placed on schematic lines.

In the previous exercises, you added a pump and two tanks to your drawing, and then you connected the components with pipe lines. Now, place a valve on one of the lines.

**To place a valve on a line**

1. In the P&ID PIP tool palette, on the Valves tab, select Gate Valve.

2. Click a location on the top horizontal line to place the valve.
Chapter 4  Design a P&ID Drawing

Add Instruments
In the previous exercises, you added a pump, two tanks, and two pipe lines. You placed a valve on one of the lines. Now, add a control valve to one of the pipe lines.

To add a control valve to a line
1. In the P&ID PIP tool palette, on the Instruments tab, select Control Valve.

   Note  The Control Valve Browser is displayed the first time you place a control valve in a drawing. If the Control Valve Browser is not displayed, skip to step 3.

2. In the Control Valve Browser, do the following:
   - Under Select Control Valve Body, select Gate Valve.
   - Under Select Control Valve Actuator, select Diaphragm Actuator.
   - Click OK.

3. Click File menu ➤ Save.
3 Click the horizontal line to the right of the gate valve to place the control valve.

4 You are prompted to select an annotation position. Move your cursor to position the annotation, and click where you want to place it.
Chapter 4  Design a P&ID Drawing

46

A leader line is automatically placed to connect the annotation bubble to the control valve.

5 If the Assign Tag dialog box is displayed, click Cancel. You add tagging information later.

6 Click File menu ➤ Save.

Edit the P&ID Drawing

Once you have created a drawing file and added components (such as equipment), valves, lines, and instruments, you can continue to make modifications to the drawing to make sure that it is precise and current.

Editing tasks you perform in this exercise include moving an equipment item, a valve, and a line, and substituting one component for another. These are just some of the editing tasks you can perform. For more information about editing your P&ID drawings, see “Create and Modify a Drawing” in the AutoCAD P&ID Help system.
To move a tank

1. In the P&ID drawing (001) you worked on in the previous exercises, click anywhere on the border of the top tank to select it.

2. On the bottom-left corner of the selected tank, click the grip and drag the tank to the left, about half the length of the horizontal line. Click again to place the tank in the new position.

   Note: The control valve and gate valve adjust to fit the shortened horizontal line.

3. Click File menu ➤ Save.
To move the gate valve

1. In the P&ID drawing (001) you worked on previously, click the gate valve.

2. Drag the gate valve from the horizontal line, and click on the vertical line to place the valve.

   **Note** If the gate valve jumps to the top of the vertical line, click the Object Snap button at the bottom left of the P&ID window to turn off snap behavior. When object snap is inactive, the button background is gray instead of blue. Return the gate valve to its former position and attempt the move again.

3. Right-click the gate valve and click Deselect All to see that the valve has flipped to align with the vertical line.

To substitute a valve type

1. Click the gate valve to select it.
2. Click the substitution grip.
3 Click Ball Valve (the second valve in the list). The gate valve is replaced by the ball valve.

4 Click File menu ➤ Save.

**To move a line**

1 In the P&ID drawing (001) you worked on previously, click the top horizontal line. All items on or connected to the line are also selected.
2 Click the stretch grip in the middle of the top horizontal line, and move the line up slightly. Click the new location to place the line.
   The control valve and instrument bubble move with the line, but the tank does not move.

3 Continue to experiment with moving the lines and the components.
4 Click File menu ➤ Save.

Tag and Annotate Components and Lines
A tag is a property that uniquely identifies a component or line. You can assign tags to components and lines at any time. Use annotations to place text on a drawing to label a component. An annotation often includes a tag property and displays that property on the drawing. The result is not a tag, however, but an annotation.
Because the terms tag and annotation are easily confused, they are described in detail in this table.

<table>
<thead>
<tr>
<th>A tag is:</th>
<th>An annotation is:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A unique identifier for a component or line segment</td>
<td>Component or line segment information that is displayed in a drawing</td>
</tr>
<tr>
<td>Data</td>
<td>Text and (optional) shapes</td>
</tr>
<tr>
<td>Located in the data cache</td>
<td>Located in the drawing</td>
</tr>
<tr>
<td>Unique</td>
<td>Not necessarily unique</td>
</tr>
<tr>
<td>Viewable as a property in the Data Manager</td>
<td>Viewable in the drawing</td>
</tr>
<tr>
<td>A single element for each component or line segment</td>
<td>Not necessarily a single element per component or line segment. (A component or line segment can have multiple annotations.)</td>
</tr>
<tr>
<td>Comprised of sub-parts as defined by the tag format</td>
<td>Text defined in the Annotation Style's block definition</td>
</tr>
<tr>
<td></td>
<td>Text that can include the tag property of a component or line segment. This text is not a tag, but an annotation.</td>
</tr>
</tbody>
</table>

In the previous exercises, you added a pump and two tanks to the drawing, connected them with a pipe lines, and then added a valve and a control valve to one of the pipe lines. Then you edited some of those items.

Now, add tagging information and specify that an annotation be placed on the drawing.

**NOTE** You can add tagging information and annotations to the other items in the drawing using the same method illustrated in the following exercise.

**To add a tag in a drawing**

1. In the P&ID drawing (001) you worked on previously, right-click the pump. Click Assign Tag.
2 In the Assign Tag dialog box, click the arrow to the right of Existing Pumps to view the tag data for other horizontal centrifugal pumps in your project (the list may be empty or differ from the one shown in the illustration).

3 In the Expression (NNN) box, enter 110 (or another number if that number is not available).

4 Select the Place Annotation After Assigning Tag option.

5 To the right of Annotation Style, in the drop-down list, select Pump InfoTag.

6 Click Assign.

   You are prompted to select an annotation position.

7 Move your cursor to position the annotation below the pump, and click to place it.
Continue tagging and annotating the other items in the drawing using the method you learned in this exercise.

9 Click File menu ➤ Save.

View and Manipulate Drawing Data
You use the Data Manager to view, edit, and manipulate component and line data and to generate reports.

Export reports or import them using Microsoft® Excel® spreadsheets (XLS/XLSX) or as plain text in the form of comma-separated value (CSV) files.

In the exercises that follow, you export data, manipulate the data in a spreadsheet, and import the data back into the Data Manager.

NOTE You must have Microsoft Excel 2003 or later installed on your system.

To view and export drawing data in the Data Manager

1 In the Project Manager, right-click drawing 001. Click Data Manager.

   The Data Manager displays data for the components and lines that you placed in drawing 001 in the previous exercises.

   Note In the upper-left corner of the Data Manager, Drawing Data is displayed in the drop-down list to indicate that you are working with a drawing’s component and line data. You can also work with project data, report data, or data organized in a customized view. You learn how to create a customized view for the Data Manager later. For information about other ways to view data, see “Work with the Data Manager” in the AutoCAD P&ID Help system.
2 On the left side of the Data Manager, click Engineering Items. If you select the top-level node, you export all components and line data in the drawing.

3 In the Data Manager toolbar, click the Export button.

4 In the Export Data dialog box, click Browse.
5 In the Export To dialog box, in the Save In drop-down list, navigate to the My Documents\My Project folder. In the File Name box, accept the default spreadsheet file name (01-001-EngineeringItems.xls), and click Save.

6 In the Export Data dialog box, click OK.

To modify exported P&ID data in a spreadsheet

1 Open Windows Explorer and locate the spreadsheet (01-001-EngineeringItems.xls) that you exported and saved previously in the My Documents\My Project folder.

2 Double-click the file to open it in Microsoft Excel 2003 or later. In the spreadsheet, data for each component or line is separated into multiple worksheets.

3 In the spreadsheet, locate and select the EngineeringItems tab.

4 On the EngineeringItems tab, in the Manufacturer column, enter Sam's Discount Valves as the manufacturer for valves and ACME as the manufacturer for nozzles.
56 | Chapter 4  Design a P&ID Drawing

5  Save the file with the same name, same file type (xls), and in the same location (My Documents\My Project) as the original file.

To import changed P&ID data from a spreadsheet

1  In the Data Manager, make sure that the Engineering Items node is selected.
2  In the Data Manager toolbar, click the Import button.
3  If the AutoCAD P&ID log file message is displayed, click OK.

   Note  The message displays a link to the folder location where the Import log file (ACCEPTED_m-dd-yyyy.log) for accepted and rejected changes is stored.

4  In the Import From dialog box, navigate to the My Documents\My Project folder and click 01-001-EngineeringItems.xls.
5 Click Open.

6 In the Import Data dialog box, click OK.

In the Data Manager, the changes you made in the spreadsheet are highlighted in yellow. In the drawing, the affected components have red outlines, called revision clouds.

7 In the Data Manager, click the Revision Cloud button to hide or show the revision clouds.
8 Right-click each of the modified records and click Accept Edit.

**Note** In this exercise, you are accepting changes one at a time. You can also accept or reject all changes by using the Accept All or Reject All buttons on the Data Manager toolbar.

9 Click File menu ➤ Save.

**Export a P&ID Drawing to AutoCAD**

You can export a P&ID DWG file to an AutoCAD DWG file format without losing the visual fidelity of the P&ID drawing. The exported drawing retains all P&ID components and annotations as AutoCAD blocks. All P&ID schematic lines are retained as AutoCAD lines. You can then use AutoCAD to open, view, edit, and plot the exported P&ID DWG files.

**NOTE** Once you have exported your drawing and opened it in AutoCAD, you can no longer work with it in P&ID. The export is a one-way process that removes the data associated with the original P&ID drawing.

**To export a P&ID drawing to AutoCAD**

1 Make sure the drawing you have been working on (001) is open.

2 To start the export process, click File menu ➤ Export to AutoCAD.
3 In the Export to AutoCAD dialog box, browse to the location where you want to save the drawing.

4 To the right of File Name, enter **PID_to_ACAD**.

5 To the right of Files of Type, specify one of the following file formats for the drawing:
   - AutoCAD 2007 Drawing (*.dwg)
   - AutoCAD 2004/LT 2004 Drawing (*.dwg)

6 Click Save.

You can now open your P&ID drawing in AutoCAD, where you can edit and plot it. Congratulations! You have completed the first four chapters of the *Getting Started Guide*.

If you want to learn more about the advanced features of the program, you can continue with Chapter 5, “Advanced Tasks—Configure the P&ID Environment.” You can also continue to experiment with the program and build onto the project you used throughout this guide (*My Documents\My Project*), or you can delete the files from your system and start with a new project.

For more information about how to use AutoCAD P&ID 2009, see the AutoCAD P&ID Help system, available from the program Help menu.
Advanced Tasks—Configure the P&ID Drawing Environment

AutoCAD P&ID 2009 provides a default project configuration that works for the majority of your project and drawing needs. As an administrator of a project, you can modify project and drawing settings by using the Project Setup dialog box.

The following workflow describes some of the ways you can configure project settings. For more information and procedures, see “Configure the P&ID Drawing Environment” in the AutoCAD P&ID Help system.
Chapter 5  Advanced Tasks—Configure the P&ID Drawing Environment

- Set Up a New Project
  - Set Up Components and Lines
  - Set Up Tag Formatting
  - Set Up Layers and Colors for Components and Lines
  - Set Up Properties for Components and Lines
  - Set Up Customized Views for the Data Manager
Set Up a New Project

In Chapter 2 of this guide ("Create a Project and Organize Drawings"), you created a new project but you did not configure the project settings.

If you want to change the default project settings, create a new project and then change the settings. That way, you retain the default project settings in the original project.

To set up a new project

1. Click File menu ➤ New Project.

2. In the Create Project dialog box, under Template, select PIP (Imperial).

3. Under Project Details, do the following:
   - Under Name, enter P&ID Test Project.
   - Under Description, enter P&ID Test Project for Learning AutoCAD P&ID.
   - Under Project Directory, click the [...] button. In the Select Project Directory dialog box, navigate to the Temp folder on your local drive. (If you do not have
Chapter 5  Advanced Tasks—Configure the P&ID Drawing Environment

a Temp folder on your local drive, create one.) Click Open. Enter \P&ID Test Project. The complete path is C:\Temp\P&ID Test Project.

Under Project DWG Directory, click the [...] button. In the Select Project DWG Directory dialog box, navigate to the Temp folder on your local drive and click Open. Enter \P&ID Test Project. The complete path is C:\Temp\P&ID Test Project.

4 Make sure the check box for Edit Project Properties After Creating Project is selected.
5 Click Create.

Note If you already have project drawings open, you are prompted to close those drawings before you start the new project.

The Create Settings message box displays a progress bar that shows the progress of the new project creation. Once the new project is created, it is displayed in the Project Manager, and the Project Setup dialog box is displayed. You have a new test project where you can make changes without modifying the configuration of an actual working project.

6 In the Project Setup dialog box, familiarize yourself with the tree structure and the configuration options. You can use the tree nodes on the left side of the Project Setup dialog box to choose the options you want to change, and then modify the information displayed on the right pane.
When you finish exploring the Project Setup dialog box, click OK.

Next, you set up some drawing files to use for your project setup tasks. Later, you see how changes you make in Project Setup affect the drawings in a project.

**To set up a new project drawing**

1. In the Project Manager, right-click *P&ID Test Project* (the project you created in the previous exercise). Click New Drawing.
In the New DWG dialog box, do the following:

- Under DWG number, enter **01**.
- Under DWG Title, enter **Test Drawing 1**.
  The DWG number and the title name you entered are displayed automatically under File Name.
- Click OK.

3 Repeat steps 1 and 2 to add another new drawing to your project, making sure to number the second drawing **02** and title it **Test Drawing 2**.

4 In the Project Manager, click and drag **Test Drawing 1** and place it above **Test Drawing 2**.
In the Project Manager, the new drawings are added to the project. You are ready to start editing properties for the project you just created.

**Set Up Components and Lines**

To create most equipment, instruments, lines, inline items, and nozzles, you start with an existing *class definition* and you edit that class definition.

You might also want to create your own class definitions. For example, your company might use a different kind of pump than the pump symbols provided in the product. You can create your own pump symbol for your drafters to use. For more information about creating your own class definitions, see “Set Up Class Definitions for Components and Lines” in the AutoCAD P&ID Help system.

When you create or modify a component, you can modify the following class definitions in the program:

- **Symbol or line settings.** The name of the symbol or line style; the name of the block controlling the geometry that is displayed in the drawing after a component is inserted; the layer, color, linetype, linetype scale, and plot style; the lineweight of a component when it is inserted; and other settings that affect the insertion of a component or how a schematic line is drawn.

- **Properties.** The values assigned to a component or line class definition to determine how it looks and behaves in a P&ID drawing, and the values that are attached to a component or line (such as default value, description, substitution, supported standards, and so on).
Chapter 5  Advanced Tasks—Configure the P&ID Drawing Environment

■ **Tag format.** The information that comprises a unique tag for a component or line.
■ **Annotation.** The text and symbol settings that annotate a component or line.

You can also create and rename class definitions and purge any that are not used in a project drawing.

In the following exercise, you create a new pump from an existing pump, change the class definitions for the new pump, and then add the new pump to the Equipment tab of the tool palette. This is just one way you can add new components and lines to your library of symbols.

**To create a pump from an existing pump and add it to the tool palette**

1. In the Project Manager, right-click *Test Drawing 1* and click Open.
2. If the P&ID PIP tool palette is not already displayed, click Tools menu ➤ Palettes ➤ Tool Palettes. Click the Equipment tab to make it active.
3 In the Project Manager, right-click P&ID Test Project. Click Properties.

4 In the Project Setup dialog box, click the plus sign (+) next to P&ID Class Definitions to expand the list.

5 Continue to expand the list until you locate and select Engineering Items ➤ Equipment ➤ Pumps ➤ Centrifugal Sump Pump.
On the Class Settings pane, under Symbol, click Add Symbol.
In the Symbol Settings dialog box, do the following:

- Under Symbol Properties, to the right of Symbol Name, enter **Centrifugal Sump Pump Style2**.
- Under Other Properties, to the right of Scale On Insert, in the drop-down list, select Yes. When you place the pump in a drawing, you are prompted to scale the symbol (by dragging the cursor).
- Under Other Properties, to the right of Tagging Prompt, in the drop-down list, select Automatically Assign an Auto-Generated Tag. When you use the pump in a drawing, you are not prompted to add tagging information.
- Click OK.
On the Class Settings pane, under Symbol, do the following:

- In the drop-down list, select *Centrifugal Sump Pump Style2*.
- Click Add to Tool Palette.

In the Create Tool message, click OK.

The new component is added to the bottom of the active tab on the tool palette and contains the styles you just defined. It can be used just like the default components provided with AutoCAD P&ID and is included in reports.
In the Project Setup dialog box, click OK to save the changes and close the dialog box.

Note You can move the pump tool you just added to the tool palette by dragging it and placing it in its new location in the palette. You can also copy or cut it and paste it onto another P&ID tool palette.

11 In the drawing area, in the bottom-right corner of the tool palette, click the centrifugal sump pump you just created (Centrifugal Sump Pump Style2) and click in the drawing to place it.

You are prompted to set the scale, but you are not prompted to add tagging information.
Set Up Tag Formatting

Set up tag formats to help drafters apply tag elements consistently throughout a project cycle. You can set up tag formats for equipment, valves, nozzles, instrumentation, pipe lines, and pipes. You can create new tag formats or modify existing formats.

Tag formats are assigned to a class definition. Typically, parts of the tag are also class definitions (for example, a definition type, such as equipment). You can also use a property of a drawing or project in the tag numbering format. For example, at the drawing level, you might want to set tag formatting to reflect a property such as the drawing number.

In this exercise, you set up tag formatting for the new pump to be Type-Area.Number.

To create a new tag format

1. In the Project Manager, right-click P&ID Test Project. Click Properties.
2. In the Project Setup dialog box, click the plus sign (+) next to P&ID Class Definitions to expand the list.
3. Continue to expand the list until you locate and select Engineering Items ➤ Equipment ➤ Pumps ➤ Centrifugal Sump Pump.
4 On the P&ID Class Settings pane, under Tag Format, click New.

5 In the Tag Format Setup dialog box, do the following:
   - To the right of Format Name, enter **Pump Tag**.
   - To the right of Number of Subparts, click the Up arrow twice so that the number 3 is displayed.
   - In the first row of icons, click Select Class Properties (the first icon on the left).
In the Select Class Property dialog box, do the following:

- Under Class, expand Engineering Items, and click Equipment.
- Under Property, click Type.
- Make sure the Use Target Object's Property option is selected.
- Click OK.

In the Tag Format Setup dialog box, in the second row, click Select Drawing Properties (the second icon).
8 In the Select Drawing Property dialog box, do the following:

- Under Category, select General.
- Under Drawing Properties, select Area.
- Click OK.

9 In the Tag Format Setup dialog box, in the third row, click Define Expression (the last icon in the row).

![Define Expression dialog box]

10 In the Define Expression dialog box, under Expression, do the following:

- Select Numbers.
- Select Fixed Length.
- In the box to the right of Fixed Length, click the Up arrow twice until the number 3 is displayed.
- Click OK.
In the Tag Format Setup dialog box, set the Delimiter fields as follows:

- Leave the dash (-) in the first Delimiter field.
- Insert a period (.) instead of the dash in the second Delimiter field.
- Leave the third Delimiter field blank.
- Click OK.

In the Project Setup dialog box, in the Class Settings pane, under Properties, scroll to the bottom of the table. In the Property Name column, locate the TagFormatName row. To the right of TagFormatName, in the Default Value column, select Pump Tag in the drop-down list.

In the Project Setup dialog box, click OK to save the changes and close the dialog box.

You have created a new Pump Tag format and assigned it to the centrifugal sump pump. When you use this pump in a drawing, the Assign Tag dialog box prompts you to enter tag data for the three-part tag you created (*Type/Area.Number*).
For more information about assigning tags, see “Tag and Annotate Components and Lines” in Chapter 4 of this guide.

**Set Up Annotations**

Annotation is used to describe a component or line in a drawing.

You can change the following information for annotations:

- **Symbol Properties.** Sets the name of the annotation style and defines the block that is displayed when the style is used.
- **General Style Properties.** Sets the layer, color, linetype, linetype scale, plot style, and linewidth for the annotation.
- **Other Properties.** Sets the scale factor used for the symbol, whether the annotation inherits the component’s properties, whether the annotation is linked to a class, whether the annotation is automatically inserted, and the X and Y offset distance from a component.

**To create a new annotation style from an existing annotation style**

1. In the Project Manager, right-click *P&ID Test Project*. Click Properties.
2. In the Project Setup dialog box, click the plus sign (+) next to P&ID Class Definitions to expand the list.
Chapter 5  Advanced Tasks—Configure the P&ID Drawing Environment

3  Continue to expand the list until you locate and select Engineering Items ➤ Equipment ➤ Pumps ➤ Centrifugal Sump Pump.

4  On the Class Settings pane, under Annotation, do the following:
   ■ In the drop-down list, select Pump Infotag.
   ■ Click Add Annotation.
In the Symbol Settings dialog box, do the following:

- Under Symbol Properties, to the right of Symbol Name, enter **Pump InfoTag2**.
- Under Other Properties, to the right of Linked, in the drop-down list, select No. When you use the annotation in a drawing, the annotation does not move with the pump when the pump is moved.
- Under Other Properties, to the right of Auto Insert, in the drop-down list, select Auto Insert with Prompt. When you use the annotation in a drawing, you are prompted to annotate the pump.
- Click OK.
6 On the Class Settings pane, under Properties, scroll to the bottom of the table. In the Property Name column, locate the AnnotationStyleName row. In the Default Value column, in the drop-down list, select Pump InfoTag2.

7 In the Project Setup dialog box, click OK.

8 In the active drawing, on the tool palette, click the Equipment tab. Click the centrifugal sump pump, and click in the drawing to place it.

   Based on the way you set up the annotation's insertion behavior in step 5, you are prompted to specify the annotation position.

9 Click in the drawing to place the annotation.

10 If the Assign Tag dialog box is displayed, click Cancel.

11 Move the pump in the drawing. Because of the way you set up the annotation linking behavior in step 5, the annotation does not move with the pump.

**Set Up Layers and Colors for Components and Lines**

You can set up layers and colors for individual P&ID components and lines.

In the following exercise, you edit the layer and color of an existing symbol. You can modify an existing symbol or create a new symbol (to make sure that the original symbol is not modified). To modify the layer and color of a symbol later, modify the original style.

**To modify an existing component's layer and color**

**NOTE** Before you start this exercise, make sure that the P&ID PIP tool palette is displayed in your drawing and that the Equipment tab is active. The component you create is added to that tool palette tab at the end of this exercise.

1 In the Project Manager, right-click *P&ID Test Project*. Click Properties.
2 In the Project Setup dialog box, click the plus sign (+) next to P&ID Class Definitions to expand the list.

3 Continue to expand the list until you locate and select Engineering Items ➤ Equipment ➤ Pumps ➤ Centrifugal Sump Pump.

4 On the Class Settings pane, under Symbol, do the following:
   - In the drop-down list, select Centrifugal Sump Pump Style.
   - Click Edit Symbol.
In the Symbol Settings dialog box, under General Style Properties, do the following:

- To the right of Layer, in the drop-down list, select --Use Current--.
- To the right of Color, in the drop-down list, select Red.
- Click OK.

6 On the Class Settings pane, under Symbol, click Add to Tool Palette.
7 In the Create Tool message box, click OK.
8 In the Project Setup dialog box, click OK.
   In the drawing, on the tool palette, the new Centrifugal Sump Pump Style component is added to the bottom-right corner of the Equipment tab.
9 On the Equipment tab of the tool palette, select the new pump and click in the drawing to place it. When you place the component, its color is red, and it is placed on the current layer.
Any other instances of a centrifugal sump pump in the drawing also inherit the layer and color properties you set here.

**Set Up Properties for Components and Lines**

Properties are the individual attributes that make up a class definition. For example, the class definition of Hand Valves includes such properties as manufacturer, supplier, model number, size, spec, and so on. You can modify existing properties, add custom properties, or set up a property so that it acquires its value from another property.

Class definitions are divided into the following categories:

- **Engineering items** (Includes equipment, inline assets, instrumentation, lines, and nozzles)
- **Non-engineering items** (Includes items that are not counted in reports, including actuators, annotation, connectors, flow arrow, flag, gap, line breakers, and others)
- **Pipe line group**
- **Signal line group**

The following exercise explains how to change properties for a gate valve. You can use the same general steps to set the properties for any component or line.

**To change default properties for a component or line**

1. In the Project Manager, right-click *P&ID Test Project*. Click Properties.
2. In the Project Setup dialog box, click the plus sign (+) next to P&ID Class Definitions to expand the list.
3 Continue to expand the list until you locate and select Engineering Items ➤ Inline Assets ➤ Hand Valves ➤ Gate Valve.

4 On the P&ID Class Settings pane, under Properties, do the following:

- In the Display Name column, add the number 1 to the end of the Class Name and Description fields.
- In the Read Only column, select the check box for Description to make this field read-only.

**Note** The Size and Spec properties are set up to acquire values from PipeLines (the class name for Pipe Line Segments). In the next exercise you add another acquisition property that also acquires its value from PipeLines.

5 In the Project Setup dialog box, click OK.

The following exercise illustrates how to set up a new acquisition property for Hand Valves called PipeLinesInsulationType, a property that the Gate Valve inherits.

**To set up a new acquisition property**

1 In the Project Manager, right-click P&ID Test Project. Click Properties.

2 In the Project Setup dialog box, click the plus sign (+) next to P&ID Class Definitions to expand the list.
3. Continue to expand the list until you locate and select *Engineering Items ➤ Inline Assets ➤ Hand Valves.*

4. On the Class Settings pane, under Properties, click Add.

5. In the Add Property dialog box, do the following:
   - Under Property name, enter *PipelinesInsulationType.*
   - Under Display name, enter *PipelinesInsulationType.*
   - Under Choose a Type, select Acquisition.
   - Click OK.
In the Select Data Source dialog box, on the Class Properties tab, do the following:

- Under Categories, click the plus sign (+) next to Engineering Items to expand the list.
- Continue to expand the list until you locate and select *Lines ➤ Pipe Line Segments*.
- Under Properties, select Insulation Type.
- Click OK.
7 On the Class Settings pane, under Properties, locate the Property name column, *PipelinesInsulationType* property. In the Acquisition column, notice that the property is set to acquire its value from *PipeLines* (the class name for Pipe Line Segments).

8 In the Project Setup dialog, click OK.

9 If *Test Drawing 1* is not already open, in the Project Manager, right-click the drawing. Click Open.

10 In the drawing, do the following:
   - Add a pump
   - Add a tank.
   - Add a pipe line that connects the pump to the tank.
   - Place a gate valve on the pipe line.

In the next exercise, you add property values to Pipe Line Segments. After you enter the values, the gate valve’s acquired property values are updated as well.

**To add values and view property changes in the Data Manager**

In this exercise, you open the Data Manager, add values to Pipe Line Segments, and see the results of all property changes you have made.

1 On the P&ID Toolbar, click Data Manager.

2 In the Data Manager, click the plus sign (+) next to Engineering Items to expand the list.

3 Continue to expand the list until you locate and select *Lines ➤ Pipe Line Segments*.

4 On the right pane (the data view), do the following:
   - Locate the Size column. Double-click the Size box. In the drop-down list, select 1/4".
   - Locate the Insulation Type column (scroll to the right, if necessary). Double-click the Insulation Type box. In the drop-down list, select IS.
5 In the Data Manager tree view, click the plus sign (+) next to Engineering Items to expand the list.

6 Continue to expand the list until you locate and select **Inline Assets ➤ Hand Valves ➤ Gate Valve**.

7 On the toolbar, click Hide Blank Columns.

8 In the data view, view the changes you made to the properties:
   - Class Name has a 1 appended to it.
   - Description has a 1 appended to it and is read-only (unreadable).
   - Size has an acquired value of 1/4”.
   - **PipelinesInsulationType** has an acquired value of IS.

**Set Up a Customized View for the Data Manager**

In the Data Manager, the default tree view mirrors the P&ID class hierarchy, starting with Engineering Items at the top level, followed by Equipment, Inline Assets, Lines, and so on.
By creating a customized Data Manager view, you can view drawing data with the focus on properties instead of classes. For example, you can set up existing properties, such as Manufacturer and Supplier, as the basis of the new view. You can also create and use new properties for a view.

In this exercise, you set up a customized view based on two properties: Manufacturer and Supplier. At the end of the exercise, compare the new tree view with the one representing the typical class hierarchy.

**To set up a customized view for the Data Manager**

1. In the Project Manager drop-down list, select `C:\My Documents\My Project\My Project\Project.xml`. This is the project you created previously.

2. In the Project Manager, right-click `My Project`. Click Properties.
3 In the Project Setup dialog box, Project Settings, click Data Manager Configuration.
4 On the Customized Views pane, click Create View.

5 Under A New Customized View - Drawing Data, do the following:
   - Next to Name, enter Manufacturer and Supplier View.
   - To define the scope of your view, in the Scope drop-down list, select Drawing Data.
   - Click New Level.
In the Select Class Property dialog box, do the following:

- Under Class, select Engineering Items.
- Under Properties, select Manufacturer.
- Click OK.

In the Customized View pane, under Manufacturer and Supplier View - Drawing Data, Level 1, `EngineeringItems.Manufacturer`, is displayed.
Chapter 5 Advanced Tasks—Configure the P&ID Drawing Environment

7 Click New Level.

8 In the Select Class Property dialog box, do the following:
   - Under Class, select Engineering Items.
   - Under properties, select Supplier.
   - Click OK.

Level 2, EngineeringItems.Supplier, is displayed.

9 On the Project Setup dialog box, click OK.

10 In the Project Manager, right click Test Drawing 1 and select Data Manager.

11 In the Data Manager, click Engineering Items.

12 In the Data Manager, data view, Manufacturer column, do the following:
   - In the first row, enter Bausch.
Advanced Tasks—Configure the P&ID Drawing Environment

- In the second row, enter Adams.
- In the third row, enter 3Tier.
- Continue to add manufacturer names until the Manufacturer column has a name in every box.

13 In the Data Manager, data view, Supplier column, do the following:

- In the first row, enter Kendall.
- In the second row, enter Johnson.
- Continue to add supplier names until the Supplier column has a name in every box.

14 In the Data Manager drop-down list, select the new customized view.

15 Expand the new view by clicking the plus sign (+) next to each node. Click the Manufacturer - Bausch node.

The customized view displays the data in a property-based hierarchy. Level one is Manufacturer, and level two is Supplier. When you click the level one node, Manufacturer - Bausch, you see the details about those components or lines manufactured by Bausch. Click the various nodes in the tree to view the relevant detail in the data view.

This customized view is different from one that is based on the typical component and line class hierarchy. See the illustration of a class hierarchy at the beginning of the section, “Set Up a Customized View for the Data Manager.”
Chapter 5  Advanced Tasks—Configure the P&ID Drawing Environment
Glossary
## Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acquire mode</td>
<td>The mode in which a property acquires its value from another source (project, drawing, or class properties).</td>
</tr>
<tr>
<td>Acquisition</td>
<td>A property type that acquires its value from another source such as project properties, drawing properties, or class properties.</td>
</tr>
<tr>
<td>Annotation</td>
<td>An AutoCAD object comprised of text and (optional) shapes. In AutoCAD P&amp;ID, annotations are used to display data values of P&amp;ID components (including equipment, valves, lines, and so on). These values are displayed as text.</td>
</tr>
<tr>
<td>Assembly</td>
<td>A group of connected components that are commonly placed in a drawing at the same time. For example, a level gauge assembly might contain an instrument and five valves. You can place an assembly from a tool palette instead of selecting each component individually.</td>
</tr>
<tr>
<td>Automatic annotation</td>
<td>A type of annotation that is automatically inserted when a component is created. See also Annotation and Linked Annotation.</td>
</tr>
<tr>
<td>Class definition</td>
<td>A specific type of a class definition, as opposed to a class definition family. For example, Centrifugal Pump is a class definition from the Pumps class definition family.</td>
</tr>
<tr>
<td>Class definition family</td>
<td>A class definition used to categorize other class definitions and set a starting point for class definition properties, tags, and annotations for those class definitions. For example, pump and equipment are class definition families; centrifugal pump and ball valve are class definitions.</td>
</tr>
<tr>
<td>Class definition property</td>
<td>A property of a class definition, it reflects a data value. For example, the HandValve class definition type may have attributes of size, spec, and manufacturer. The Pumps class definition type may have flow, TDH, and manufacturer.</td>
</tr>
<tr>
<td>Component</td>
<td>A native AutoCAD P&amp;ID object type. AutoCAD P&amp;ID components include Equipment, Nozzles, Lines, Instruments, and Inline items.</td>
</tr>
<tr>
<td>Component class</td>
<td>See Class Definition.</td>
</tr>
<tr>
<td>Connection grip</td>
<td>The graphical element in a drawing that indicates an off-page or on-page line connection. Users can choose from several grips.</td>
</tr>
</tbody>
</table>
Data Manager

An enhanced secondary window in AutoCAD P&ID that displays data in a table. You can export the data to, and manipulate the data in, Microsoft®Excel® 2003 or later.

Equipment InfoTag

An annotation style. A multiline set of data values that displays selected attributes for a placed piece of equipment. One InfoTag for each equipment component is typically placed at the top of a drawing or in a grid across the bottom of the drawing.

Flip grip

A grip that flips a class in the opposite direction.

Flow arrow

A graphical element that shows the direction in which a schematic line flows.

Freestanding annotation

Text that is associated with a component; it does not move when the component moves. However, the data associated with the annotation updates with the component. Annotations are either freestanding or linked. See also Linked Annotation.

Gap grip

A graphical element that shows a break on both sides of a gap.

Inline component

A component that can be placed on a line.

Instrument

A device or combination of devices used directly or indirectly to measure, display, or control a variable.

Linked annotation

Graphics, text, or text with a graphic that labels a component. The text values reflect the data attribute values of a component. Linked annotation moves when the component moves. See also Freestanding Annotation.

Off-page connector

The graphical representation on a P&ID drawing of the continuance of a line from one project drawing to another.

Schematic line

A line in AutoCAD P&ID that represents pipe lines and signal lines.

Tag

A property that uniquely identifies a component or line.

Validation

A feature that lets you check drawings for common errors, such as non-terminating lines and flow-direction conflicts.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Manager</td>
<td>An enhanced secondary window in AutoCAD P&amp;ID that displays data in a table. You can export the data to, and manipulate the data in, Microsoft®Excel® 2003 or later.</td>
</tr>
<tr>
<td>Equipment InfoTag</td>
<td>An annotation style. A multiline set of data values that displays selected attributes for a placed piece of equipment. One InfoTag for each equipment component is typically placed at the top of a drawing or in a grid across the bottom of the drawing.</td>
</tr>
<tr>
<td>Flip grip</td>
<td>A grip that flips a class in the opposite direction.</td>
</tr>
<tr>
<td>Flow arrow</td>
<td>A graphical element that shows the direction in which a schematic line flows.</td>
</tr>
<tr>
<td>Freestanding annotation</td>
<td>Text that is associated with a component; it does not move when the component moves. However, the data associated with the annotation updates with the component. Annotations are either freestanding or linked. See also Linked Annotation.</td>
</tr>
<tr>
<td>Gap grip</td>
<td>A graphical element that shows a break on both sides of a gap.</td>
</tr>
<tr>
<td>Inline component</td>
<td>A component that can be placed on a line.</td>
</tr>
<tr>
<td>Instrument</td>
<td>A device or combination of devices used directly or indirectly to measure, display, or control a variable.</td>
</tr>
<tr>
<td>Linked annotation</td>
<td>Graphics, text, or text with a graphic that labels a component. The text values reflect the data attribute values of a component. Linked annotation moves when the component moves. See also Freestanding Annotation.</td>
</tr>
<tr>
<td>Off-page connector</td>
<td>The graphical representation on a P&amp;ID drawing of the continuance of a line from one project drawing to another.</td>
</tr>
<tr>
<td>Schematic line</td>
<td>A line in AutoCAD P&amp;ID that represents pipe lines and signal lines.</td>
</tr>
<tr>
<td>Tag</td>
<td>A property that uniquely identifies a component or line.</td>
</tr>
<tr>
<td>Validation</td>
<td>A feature that lets you check drawings for common errors, such as non-terminating lines and flow-direction conflicts.</td>
</tr>
</tbody>
</table>